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What is Gopher+ ?

A Gopher is an Internet-based file retrieval system.

Gopher+ is an application that uses the Gopher plus protocol to communicate with Gopher servers on
the Internet. Gopher+ first connects to a Gopher server, and then displays a menu of Gopher items for
you to choose from.

Gopher items can be many different types of files. Retrieving an item may take you to a subdirectory,
another Gopher server, or some type of file that you can use. These files may consist of text, graphics,
sounds, or even video. They might even be Telnet connections, or allow searches of large collections
of documents.

When you select a file, Gopher+ automatically starts the correct viewer application to display that file.
This means that if you copy a text file, Gopher+ starts up the configured text editor that you have on
your PC. If you copy a graphics file, Gopher+ starts the correct image viewer to display that file. You
configure viewers for Gopher+ from the Options menu.

Finding the information you want may require you to explore Gopherspace. This may involve switching
among many different Gopher servers. To find your way back, Gopher+ allows you to set bookmarks.
Bookmarks specify Gopher items that you marked. You can click a bookmark to return to an item.
Gopher+ saves these bookmarks in a bookmark file.

Related Topic

What are Bookmarks?

What are Gopher+ Attributes?

What is the Gopher+ Protocol?
What are Preferred File Formats?

What are Viewers?
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What is a Gopher Item?

The types of information that you can retrieve from a Gopher server (computers on the Internet that the
Gopher+ application connects to for Gopher services). These items can be files of different types,
directories, connections to other Gopher servers, Telnet connections, or searches of a collection of
documents.

Related Topics

What is Gopher+?
What is Gopherspace?
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What is Gopherspace?

The collection of all Gopher servers on the Internet. Anything that you can access via a Gopher
application exists in Gopherspace.

Related Topics

What is Gopher+?
What is a Gopher Item?
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What is the Gopher+ Protocol?

Gopher servers originally used the Gopher protocol to communicate. Some Gopher servers use the
improved Gopher plus protocol.

The Gopher plus protocol supports attributes. Attributes provide Gopher+ with information about the
file format before you retrieve the file. This feature lets Gopher start the correct viewer when the file is
retrieved.

Gopher items that have attributes that have not yet been retrieved appear with the plus symbol next
to them. Click and hold on the symbol and release on the Fetch Attributes box that appears to retrieve
the attributes.

Gopher items that have attributes that have already been retrieved appear with the multiview symbol @
to their left. To see a list of information you can get on the item, click and hold the mouse button on the

@ multiview symbol. Release on an item to retrieve that information.

Related Topics

What are Gopher+ Attributes?
What are Preferred File Formats?

Set Preferred Languages
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The Gopher+ Main Window

The main viewing area displays a menu (sometimes called a directory) of Gopher items that you can
access. The title bar indicates which Gopher server menu Gopher+ is presently displaying. The menu
and tool bars provide the Gopher+ commands. A section of the tool bar also displays the status of any
connections in progress.

Each Gopher item has one or more symbols that indicate the item type and has text describing the item.
Double-click on the text for Gopher+ to retrieve that item for you. If the connection is successful, a new
menu of Gopher items appears.

Use the following buttons and commands to navigate with Gopher+:

To go to Choose

Your Home Gopher server The Home Button ﬂl

o Go Home from the Navigate menu.
The previous directory The Previous arrow button W

o Previous Menu from the Navigate menu.
The next directory The Next arrow button LI

--or--

Next Menu from the Navigate menu.

The current Bookmark file The World button ﬁl
=-=Of ==
The right mouse button
-=Or-=
Show Bookmarks from the Bookmarks menu.

Related Topics

File Menu Commands

Options Menu Commands
Navigate Menu Commands
Bookmarks Menu Commands
Gopher+ Symbols

The Gopher+ Tool Bar
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The Gopher+ Tool Bar

Use the buttons on the Gopher+ tool bar to accomplish tasks quickly.

Use this button To do this
:ﬁl Switch to the current bookmark file.

= Choose the copy mode that Gopher+ uses when it transfers items to your PC. You can specify
that Gopher+ display items, copy items to a file, or copy items to a directory.

ﬂl Go to your Home Gopher server.
Go to the next open Gopher menu.
W Go to the previous open Gopher menu.

Related Topics

The Gopher+ Main Window
Gopher+ Symbols
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Gopher+ Symbols

The following symbols are used in Gopher+:

T
&

The eyeglasses symbol represents a text Gopher item.

The binary symbol represents a Gopher item with the Gopher base type File.

The musical note symbol represents an audio Gopher item.

The CSO symbol represents a connection to a CSO server that provides a directory for a site.
The camera symbol represents an image file Gopher item.

The book pointer symbol represents an index Gopher item.

The film symbol represents a movie file Gopher item.

The H symbol represents a document that contains hypertext links.

The bullet symbol indicates this is an information line and not a Gopher item.

The computer terminal symbol represents a Gopher item that is a Telnet connection.

The IBM terminal symbol represents a Gopher item that is a TN3270 remote login connection.
The forward arrow symbol represents proceeding to the next Gopher directory or menu.

The backward arrow symbol represents returning to the previous Gopher directory.

The house symbol takes you to your Home Gopher server.

The question mark symbol represents an item that is unrecognizable to Gopher+.

The plus symbol represents a Gopher item using the Gopher plus protocol, whose attributes
her+ has not retrieved.

The multiview symbol represents a Gopher item that has one or more formats for viewing (from
Gopher servers using the Gopher plus protocol only). Clicking this symbol provides information about
the file.
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This symbol represents a connection to a server.

4 The eye symbol indicates that Gopher+ retrieves items for you to view on your monitor.
4 The folder symbol indicates that Gopher+ retrieves and saves items directly to a file.
The open folder symbol indicates that Gopher+ retrieves and saves items to a directory.

PSP

Related Topics
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Abort a Connection

To abort a connection

1. Choose the connection button for the connection you want to abort, or choose Abort from the
File menu.

The Transfer Terminate dialog box opens.
2. Choose Abort to end the transfer and lose the data already received.
--or--
Choose End to end the transfer and view the data received so far.

Related Topics
Fetch a Gopher Item
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Configure Gopher+

You can configure Gopher+ by choosing Configure Gopher+ from the Options menu.

Use the Gopher+ Set Up Options dialog box to customize the settings that Gopher+ uses when you start
the application.

Use your right mouse button to display popup help topics about what each box in the Gopher+ Set Up
Options dialog box does.

Related Topics
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What are Viewers?

Use the Viewer dialog box to configure the viewers that you use with Gopher+. A viewer application
processes a file that Gopher+ retrieves for you. An image or text viewer displays information. A sound
viewer plays an audio file. Some viewers perform background processing for you; for example,
decompressing compressed files.

You must set up Gopher+ to use the viewers you want after retrieving different file types, such as ASCII,
binary, and so forth. Gopher+ provides settings for several viewer applications. For these viewers,
selecting an item under Select View Types displays the application settings in the Viewer Details and the
Transfer Modes boxes.

You can configure viewers by choosing Configure Viewers from the Options menu.

Related Topics
Configuring Viewers
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Configure Viewers

1. From the Options menu, choose Configure Viewers.
2. From the Select View Type list box, select a view type.

If the view type already has a viewer associated with it, the parameters appear in the Viewer Details
box.

3. Enter or change the parameters in the Viewer Details box:

Viewer

Working Directory
Extension Guesses

Save Extension
Disabled

Slow weight
Fast weight

4. In the Transfer Mode box, select either Binary or ASCII to designate the mode for retrieving files of
this view type.

To add a new view type
1. Choose the Add New View Type button.
The Add a New View Type dialog box appears.

n

Enter a file type.
. Choose OK.

. Set up the viewer for the new view type.

A~ W

Related Topic

What are Viewers?
What are Preferred File Formats?
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Display Your Connection History

Exploring Gopherspace often involves connecting to several different servers and directories. Use the
Navigate menu to find your way back to directories or Gopher servers that you accessed since you
started Gopher+.
To display your connection history
1. From the Navigate menu, choose Show History.

A Gopher menu of servers and directories that you have connected to in this session appears.

2. To reconnect to an item, double-click that item in the menu.
=-=Of ==
To return to the previous menu, click the Previous button in the tool bar.

Related Topic
Displaying Your Bookmark History
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Display Your Bookmark History

Use the Show Bookmark History command to display a list of the Bookmarks you have used during this
connection.
To display your bookmark history

From the Bookmarks menu, choose Show Bookmark History.

A Gopher menu of the bookmark menus you used during this connection appears.

Related Topic
Displaying Your Connection History
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Learn about a Gopher Item

You can find information about a gopher item before copying the entire file by fetching Gopher plus
attributes.

To fetch Gopher+ attributes

1. Press and hold the mouse button on the plus symbol W

A popup menu appears.
2. Select the Fetch Attributes option.

After Gopher+ retrieves the attributes, the symbol changes to W
Types of attribute information may include an abstract about the item, the size of the file, and the
different formats that the file is offered in.

Text files might be available in format such as ASCII, or PostScript, and may also be available in more
than one language. Graphic files might be available in formats such as .GIF (graphical image files).

To use Gopher plus attributes

1. Press and hold the mouse button on W

A popup menu appears.
2. Release the mouse button on the attribute you want to retrieve.

Related Topic

Getting Gopher Item and Server Information
What are Gopher+ Attributes?
Fetching Gopher ltems in Different File Formats
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Fetch a Gopher Item

To retrieve a Gopher item

Double-click the text of the item with the mouse. This action is the quickest way to choose an item
from the Gopher menu.
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Select the text of the item with the mouse, and choose Fetch from the Navigate menu.

Gopher+ can retrieve different types of Gopher items. If you select a file or directory that is stored on the
Gopher server that your client is currently connected to, Gopher+ gets that item. If you select a menu
item that is a pointer to another Gopher server, Gopher+ attempts to connect to that server.

Related Topics

Aborting a Connection
Fetching a Gopher Item Directly to a File or Directory
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What are Preferred File Formats?

When a file is available in multiple formats on a Gopher server using the Gopher plus protocol, you can
set up Gopher+ to retrieve the file format you prefer. Do this by assigning different weights to different
types of files. When Gopher+ can retrieve a file in more than one format, it fetches the file with the
highest assigned weight.

For example, if you want a .JPG version of a graphics file rather than a .GIF version, you give the .JPG
viewer a higher weight in the Viewer dialog box.

In addition, you can specify what type of format to retrieve when you are connected to a server that you
have classified in the Servers dialog box as "fast" or "slow."

Related Topics

Set a Preferred File Format

What is the Gopher+ Protocol?
What are Gopher+ Attributes?
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Set a Preferred File Format

The Gopher+ client can be configured so that when a Gopher server offers a file in more than one file
format, Gopher+ automatically fetches the format you prefer.
To set preferred file formats
1. From the Options menu, choose Configure Viewer.
The Viewers dialog box appears.
2. In the Select View Type box, select the viewer you prefer most.

3. Click the pointer in the Fast Weight box to the right.
==QOf ==
Enter a number to represent a weight.

4. To save your changes, choose Accept.

5. For other file formats for the same type of file, set decreasing values for the weight in the order that
you prefer those formats.

6. To save your changes, choose Accept.

7. Choose Done.

Related Topics

What are Preferred File Formats?
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Fetch Multiple Gopher Iltems

You can have up to three Gopher connections at one time. This means that you can retrieve more than
one Gopher item at the same time. You retrieve multiple items at the same time by fetching (retrieving)
a new Gopher item while Gopher+ is still in the process of getting another item.

Look at the status section of the tool bar to monitor the state of the transfers. When retrieving multiple
Gopher items, the items are displayed when they are finished being copied over the network. After the
transfers are complete, use the arrow buttons in the tool bar to move between the retrieved Gopher
items.

Related Topics

Aborting a Connection
Use the Gopher+ Tool Bar
Using the Gopher+ Main Window
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Get Gopher Item and Server Information

The first symbol to the left of a Gopher+ item indicates the type of file it is. It may be a:

W directory

[ textfile

graphics image file
sound file

movie file

Telnet connection

or others (see Gopher+ Symbols for a complete list).

To get additional Gopher item information
1. Select the Gopher item you want information about.
2. From the Navigate menu, choose Get Info on ltem.

To find out more information about the server that this item is located on
1. Select a Gopher item on the server you want information on.

2. From the Navigate menu, choose Get Info on Server.

Related Topics

Learn about a Gopher Item
Gopher+ Symbols
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Connect to a Specific Gopher Server

Use the Connect to a Gopher Server dialog box to connect to Gopher servers around the world.

To connect to a specific Gopher server

1. From the Navigate menu, choose Connect to a Gopher.

2. Enter the Internet address or hostname of the server you want to go to.
3. Choose OK.

Related Topics
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Print Gopher Menus
You can print Gopher menus.

To print the contents of a Gopher menu
1. From the File menu, choose Print.

The Print dialog box appears.
2. Choose OK.

Related Topics
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What are Bookmarks?

Bookmarks allow you to easily return to a specific menu or file in Gopherspace. When Gopher+ marks
an item with a bookmark, it saves the Internet address or hostname of the Gopher server, the port
number, the path to the directory or item, and the menu item description.

Related Topics

Place a Bookmark
Display Bookmarks
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Set a Bookmark

1. Select the Gopher item you want to mark.
You can either move to a menu and mark it, or select an item and mark just that item.

2. From the Bookmarks menu, choose Mark Menu.
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From the Bookmarks menu, choose Mark Item.

The new bookmark appears in the currently open bookmark file.

3. Remember to save your new bookmarks before exiting Gopher+. To save bookmarks, choose Save
Bookmarks from the Bookmarks menu.

Related Topics

Display Bookmarks
What are Bookmarks?

Building Bookmark Files
Bookmarks Menu Commands

Introducing Gopher+
Step-by-Step Instructions
Concepts



Set Preferred Languages

Use the Languages dialog box to specify the language, or languages, that you want Gopher+ to use
when displaying a Gopher item.

When a file is available in multiple languages on a server using the Gopher plus protocol, you can
preset the Gopher+ application to display the item in the language you prefer. Assign different weights
to different languages to control the languages used for display. When Gopher+ can retrieve a file in
more than one language, it retrieves the file with the highest assigned weight.

For example, say that your native language is German and that your second language is English. Assign
a higher weight to German than you do for English. When you fetch a Gopher item that has German text
available, the German version is automatically retrieved.

You can set preferred languages by choosing Configure Languages from the Options menu.

Related Topics
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Set a Preferred Language

The Gopher+ client can be configured so that when a Gopher server offers a file in more than one
language, Gopher+ automatically fetches the file you prefer.

To set your preferred language

1.

o > 0N

6.

From the Options menu, choose Configure Languages.

In the Select language box, select the language you prefer most.
In the Weight box, type an arbitrary number to represent a weight.
Choose Accept to save that setting.

For other languages, set decreasing values for the weight in the order that you want Gopher+ to
retrieve them.

When you are finished, choose Done.

Related Topics
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Configure Servers for Gopher+

Use the Server dialog box to classify different Gopher servers that you connect to as either "fast” or
"slow." Use this in conjunction with the fast and slow weights you set in the Viewers dialog box to
configure the types of file formats that Gopher+ retrieves.

Note that the fast and slow classifications do not refer to the speed of the machine, but rather to how
fast or slow you think the network access to it is.

You configure servers by choosing Tailor by Server from the Options menu.

Related Topics
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Configure Servers for Gopher+

Use the Server dialog box to classify different Gopher servers that you connect to as either "fast” or
"slow." Use this in conjunction with the fast and slow weights you set in the Viewers dialog box to
configure the types of file formats that Gopher+ retrieves.

Note that the fast and slow classifications do not refer to the speed of the machine, but rather to how
fast or slow you think the network access to it is.

To configure a server

1. Choose Tailor by Server from the Options menu.

2. To add a fast server, choose Add Fast.
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To add a slow server, choose Add Slow.

The Add a Server dialog box appears.

3. Enter the Gopher address of the Gopher server you want to classify, for example:
gopher.ftp.com

4. Choose OK.

Related Topics
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Set Fonts

You can change the fonts that Gopher+ uses to display Gopher items, as well as the size, style, and
color of the print.

To change fonts for Gopher item text

1. From the Options menu, choose Fonts.

2. In the Font dialog box, select the font, size, color, and style you want.

3. Choose OK.

Related Topics

Introducing Gopher+
Step-by-Step Instructions
Concepts



Build Bookmark Files

To help you organize your bookmarks, you can save the bookmarks to different files. When Gopher+
starts, it loads into memory the default bookmark file, which you set in the Gopher+ Set Up dialog box.
Anytime you create a new bookmark, it is added to the currently open bookmark file.

Related Topics

Append a Bookmark File
Link Bookmark Files

Load a Bookmark File
Save a Bookmark File
Set Bookmarks
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Fetch a Gopher Item Directly to a File or Directory

You can configure Gopher+ to save retrieved Gopher items directly to a file or a directory. If you set up
Gopher+ to copy items to a file, Gopher+ lets you specify a filename when it retrieves an item. If you
set up Gopher+ to copy items to a directory, the application assigns a filename and places the file in the
directory that you specified under Save to in the Gopher+ Set Up dialog box.

Note: Copy to File and Copy to Directory modes have no effect on some Gopher items, such as
directories, Gopher server links, or Telnet items.

Related Items

Change the Copy mode
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Change the Copy Mode

1. From the Options menu, choose Set Copy Mode.

A sub menu with a list of modes appears.
2. From the sub menu, choose View, Copy to File, or Copy to Directory to select the mode you want.
You can also change modes using the mode icon in the tool bar. The following icons represent the
three modes. Click the current icon to change to another mode.

Icon Mode

W View
Kl Copy to File
W Copy to Directory

Related Topics
Fetch a Gopher Item Directly to a File or Directory
Introducing Gopher+
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Link Bookmark Files

You can organize your bookmark files by creating Gopher items that point to different bookmark files.

To link one bookmark file to another
1. Open the bookmark file that you want to contain the linked Gopher item.
2. From the Bookmarks menu, choose Create Bookmark.
The Create/Edit Bookmark dialog box appears.
3. From the Type menu, choose Book Mark.
4. In the Create/Edit Bookmark dialog box, choose the Browse button.
The Open dialog box appears.
Select the filename of the Bookmark file you want to link to.
Choose OK.
In the Description field, enter the text you want to appear as the Gopher item.
Choose OK.

® N o o

Related Topics
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Save a Gopher Screen as Text

You can save information that you retrieve with Gopher+ as a text file.

To save a screen of Gopher items as a text file
1. From the File menu, choose Save.
The Save As dialog box appears.
2. Enter a filename.
3. Choose OK.

You can open this file using any text editor.

Related Topics
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Edit a Bookmark

You can change bookmarks after you create them.

To edit a bookmark

1.
2.

Select the Bookmark you want to edit.
From the Bookmarks menu, choose Edit Bookmark.
The Edit Bookmark dialog box appears.

Make changes in any of the provided fields.

4. Choose OK.

Related Topics

Create and Change Bookmarks
Save a Bookmark File
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Load a Bookmark File

You can view and use a bookmark file after you create it.

To load a bookmark file

1. From the Bookmarks menu, choose Load Bookmarks.
The Open dialog box appears.

2. Select the bookmark file you want to open.

3. Choose OK.

Note: You can open only one bookmark file at one time.

Related Topic
Linking Bookmark Files
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Save a Bookmark File

Anytime that you add new bookmarks to a bookmark file, you must save them before quitting Gopher+.

To save new bookmarks to the currently open bookmark file

From the Bookmarks menu, choose Save Bookmarks.

To save a bookmark file with a different filename
1. Make sure the bookmark file you want to save under a new name is open.
2. From the Bookmarks menu, choose Save Bookmarks As.
The Save As dialog box appears.
3. Enter a new filename.
4. Choose OK.

Related Topics
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Append a Bookmark File

You can consolidate a bookmark file by appending one file to the end of another.

To append one bookmark file to another
1. Open the bookmark file that you want to append another file to.
2. From the Bookmarks menu, choose Append Bookmarks.

The Open dialog box appears.
3. Select the bookmark file that you want to append to the first file.
4. Choose OK.

5. Save your bookmarks before quitting Gopher+.

Related Topics

Create and Change Bookmarks
Save a Bookmark File
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Remove Old Gopher Menus from Memory

Gopher+ keeps a copy of menus that you have accessed for a given amount of time. If you think these
menus are out of date, you can delete these copies.
To delete copies of saved menus

From the Navigate menu, choose Flush Cache.

All menus will then have to be retrieved over the network. The present menu is not in the cache. If you
want to refresh the present menu, switch to your Bookmarks menu, choose Flush Cache, and then
move back to it.

Related Topics
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File Menu Commands

Use the File menu to save and print Gopher menus.

Use this command To do this

Save Save a Gopher menu to a text file.

Print Print a Gopher menu.

Print Extended Print the current Gopher menu, and include the Gopher item type, the IP address
or hostname of the server, and the directory for each Gopher item in the menu.

Print Setup Set up print options.

Abort Exit the Gopher+ application without waiting for any outstanding network
connections to terminate.

Exit Exit Gopher+.

Related Topics

Introducing Gopher+
Step-by-Step Instructions
Concepts



Options Menu Commands

Use the Options menu to configure Gopher+.

Use this command To do this

Set Copy Mode Specify how Gopher+ copies items to your PC. The application can display
items, copy items to a file, or copy items to a directory.

Configure Gopher+  Configure the application settings that Gopher+ uses at startup.
Configure Viewer Configure the applications that Gopher+ uses to display different types of files.

Configure Languages Set the language or languages that you want Gopher+ to use when files are
available in more than one language.

Tailor by Server Classify network access to specific Gopher servers as "fast" or "slow."

Configure Special Features
Set Gopher+ options.

Fonts Set the fonts that Gopher+ uses.

Related Topics
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Navigate Menu Commands

Use the Navigate menu to get information, retrieve Gopher items, and navigate through Gopherspace.

Use this command
Connect to a Gopher
Go Home

Fetch ltem

Show History

Previous Menu

Next Menu

Flip

Get Info on Item

Get Info on Server

Flush Cache

Related Topics
Introducing Gopher+

To do this

Connect to a Gopher server using the servers Internet address or hostname.

Connect to the home server specified in the Gopher Set Up dialog box.
Retrieve the selected Gopher item.

Display a list of all the Gopher items you selected since you started the Gopher+
application running.

Return to Gopher menus you previously viewed.

Go to the next open Gopher menu. (This works only after you have used the
Previous menu command.)

Switch between the current Gopher server menu and the currently open
bookmark file.

Get Internet address or hostname information about the selected Gopher item.

Get server information about the Gopher server that you are currently connected
to. Individual servers determine the type of information that you receive.
Servers may return information about the server location, administration, and the
version of the server.

Deletes copies of menus. All menus will then have to be retrieved over the
network. The present menu is not in the cache. If you want to refresh the
present menu, switch to your Bookmarks menu, choose Flush Cache, and then
move back to it.

Step-by-Step Instructions
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Bookmarks Menu Commands

Use the commands in the Bookmarks menu to manipulate, create, edit, delete, and save your

bookmarks.

Use this command
Mark Item

Mark Menu

Go to Bookmark Home
Show Bookmark History
Show Bookmarks

Hide Bookmarks
Remove Bookmark
Clear All Bookmarks

Create Bookmark

Edit Bookmark
Load Bookmarks
Append Bookmarks
Save Bookmarks

Save Bookmarks As

Related Topics
Introducing Gopher+

To do this

Set a bookmark to return to a specific Gopher item.

Set a bookmark to return to an entire menu.

Display the initial bookmark file specified in the Gopher Set Up dialog box.
Display a list of the Bookmarks you viewed since you started Gopher+.
Display the currently open bookmark file in the main viewing area.

Hide the currently open bookmark file, and return to the current Gopher menu.
Remove a bookmark from the current bookmark file.

Delete all the bookmarks in the current bookmark file.

Create a new bookmark. Enter the Internet address or hostname and
directory for the bookmark. (Gopher+ does not need to be at the place where
you are setting this bookmark when it is created.)

Change the settings of a bookmark.

Load a bookmark file.

Attach one bookmark file to the end of the current bookmark file.
Save any new bookmarks to the currently open bookmark file.

Save the currently open bookmark file with a new filename.

Step-by-Step Instructions

Concepts



Add a View Type

Use the Add a New View Type dialog box to add another file type to those listed in the Viewer dialog
box.

To add another view type

1. In the Enter the View Type box, type the name of a file type.

2. Choose OK.

Related Topics

Introducing Gopher+
Step-by-Step Instructions
Concepts



Add a Server

Use the Add a Server dialog box to specify a server.

To add a server
1. Under Enter Fully Qualified Server Name, type the hostname or IP_address of the server.
2. Choose OK.

Related Topics

Introducing Gopher+
Step-by-Step Instructions
Concepts



Search Indexes

Use the Index Search dialog box to search for gopher items.

To search for an entry word
1. In the Search Strings box, type the characters that you want Gopher to search for.

2. Choose OK.

You can search on items that have the @ symbol next to them.

Related Topics

Introducing Gopher+
Step-by-Step Instructions
Concepts



Display Bookmarks

To display the currently open bookmark file

From the Bookmarks menu choose Show Bookmarks
=-=Or==

Click the right mouse button

=-=Of==

Choose the world button W from the toolbar.
Related Topics

Set a Bookmark

Display Bookmark History
What are Bookmarks?

Introducing Gopher+
Step-by-Step Instructions
Concepts



What is Ask Procecessing?

Ask Processing only applies to Gopher items from servers that use the Gopher plus protocol.

When a Gopher item uses Ask Processing, the item prompts you for information that the Gopher item
can then use.

Gopher+ displays a dialog box that requests the information.

Caution: You do not know who will receive the information that you are sending. Be careful not to
transmit sensitive information. For example, do not give out your password and user ID.

Related Topics

Introducing Gopher+
Step-by-Step Instructions
Concepts



What are Gopher+ Attributes?

Gopher plus attributes provide information about an item before you fetch (retrieve) it.

If an item resides on a Gopher server that is using the Gopher plus protocol, a second symbol appears
to the left of that item.

This symbol Indicates that you can

W View the file attributes by clicking the symbol.
W Retrieve Gopher plus attributes.

Related Topics

Learn about a Gopher Item
Getting Gopher Item and Server Information

What is the Gopher plus protocol?
What are Preferred File Formats?

Introducing Gopher+
Step-by-Step Instructions
Concepts



Ask Processing

Ask Processing only applies to Gopher items from servers that use the Gopher plus protocol, an
improved Gopher protocol implemented on some servers.

When a Gopher item uses Ask Processing, the item prompts you for information that the Gopher item
can then use.

Gopher+ displays a dialog box that requests the information.

Caution: You do not know who will receive the information that you are sending. Be careful not to
transmit sensitive information. For example, do not give out your password and user ID.



ASCII

An acronym for American Standard Code for Information Interchange. A standard computer character
set used in text files that do not include formatting instructions.



Attributes

Information about an item than you can retrieve with Gopher+. The attributes might provide an abstract
of the item, the size of the file, and the different formats available for the file.



Binary

A file that contains program instructions. For example, executable files (having an .EXE extension) are
binary files.



Bookmark File

A file that contains the bookmarks that you create for Gopher+ items. Bookmarks include information
about items and the location of those items. You use bookmarks to mark frequently used items and to

easily locate and return to items.



Dot Stuffing

When transferring data in ASCIl mode, Gopher+ uses a dot to signify End of File. This mechanism can
cause problems with files that contain lines that start with a dot. Gopher+ adds extra dots in these lines
to identify that this area is not the end of the file.

You need this option when Gopher+ is communicating with the many servers that do not follow the
specification for handling dots. If a file appears corrupted, try setting this option before retrieving the file
again. Although setting this option tries to correct the situation, you might find that some lines are still
be corrupted.



Gopherspace

The collection of all Gopher servers on the Internet. Anything that you can access via a Gopher
application exists in Gopherspace.



Gopher Items

The types of information that you can retrieve from a Gopher server (computers on the Internet that the
Gopher+ application connects to for Gopher services). These items can be files of different types,
directories, connections to other Gopher servers, Telnet connections, or searches of a collection of
documents.



Gopher+ Protocol

An improved Gopher protocol. Gopher servers originally used the Gopher protocol to communicate.
Some Gopher servers use the improved Gopher plus protocol.

The Gopher+ protocol supports attributes. Attributes provide Gopher+ with information about the file
format before you retrieve the file. This feature lets Gopher start the correct viewer when the file is
retrieved.

Gopher items that have attributes that have not yet been retrieved appear with the plus symbol W next
to them. Click and hold on the symbol and release on the Fetch Attributes box that appears to retrieve
the attributes.

Gopher items that have attributes that have already been retrieved appear with the multiview symbol

[

to their left. To see a list of information you can get on the item, click and hold the mouse button on
the

W multiview symbol. Release on an item to retrieve that information.



Gopher+ Viewer Variables

Gopher+ replaces viewer variables with Gopher item information it retrieves from the server it is
connected to. Use the following variables in the Viewer details box to have Gopher+ replace the
variable with the appropriate information when starting a viewer.

Item Variable
File name Y%f
Gopher description  %d
Gopher type Yot

Host name %h
Internet address Yoi

Port number Y%p
Search string %S

%% %%

If you use a viewer that requires a parameter that is the same as one of the variables listed, you can
insert an additional % before the variable for Gopher+ to use that variable. For example, for the
filename variable, you would use %$%f.



Gopher Servers

Computers on the Internet that the Gopher+ application connects to for Gopher services.



Home Gopher Server

The server that Gopher+ connects to when you start the Gopher+ application.



Host

A computer on the network. Your computer is the local host; other computers are remote hosts.



Hostname

The name assigned to a computer on the network. A fully qualified hostname has the form
hostname.subdomain.domain; for example, gopher.ftp.com.



Internet

The worldwide collection of networks using the TCP/IP protocol. The Internet includes sites at
universities, research laboratories, corporations, governments, and nonprofit organizations.



Internet Address

The Internet Protocol (IP) number that uniquely identifies a computer on a network. The form of an IP
address is four groups of numbers separated by periods, for example, 128.127.55.55.



PostScript

A page description language (developed by Adobe Systems, Inc) that contains instructions for formatting
text.



Telnet

The standard TCP/IP remote login protocol. With Telnet, you can work from your PC as if it were a
terminal physically attached to another machine.

While using Telnet with Gopher+, keep in mind that Telnet is considered a viewer and thus is a separate
application from Gopher+. This means that, unlike Gopher+, you may be required to type in username
and password information to access data on some servers.

A Gopher item that is a Telnet connection is represented by the symbol.



TN3270

A remote login application that lets you work from your PC as if it were a terminal physically attached to
another machine.

The application translates input from your keyboard into a format usable by the remote computer, and
that translates output from the remote computer into a format suitable for display on your PC. This
translation process is called terminal emulation.



Text File

Afile that contains information only in text form.



Weights

Weights are arbitrary numbers that you assign to a file format. When Gopher+ has the choice of
fetching a file in more than one format, it fetches the file with the highest assigned weight.



Working Directory

Type the full pathname of the directory where the viewer is stored.



Extension Guesses

Type the possible file extensions for the viewer application. Gopher+ attempts to match the file
extension with extensions you specify.

Gopher+ uses this entry when it retrieves items; for example, different types of files. The entry is
effective only when you connect to Gopher servers (computers on the network that make Gopher
services available to you) that use the Gopher plus protocol. The Gopher plus protocol is an improved
Gopher protocol supported by some servers.



Disabled

Select this checkbox to turn off the viewer for this view type. When retrieving a file of this view type, the
following message appears:

no viewer for this view type enabled



Slow Weight

Specify the weight of this view type of Gopher servers in the category slow. Weights are arbitrary
numbers that you assign to a file format. When Gopher+ can retrieve a file in one of several formats, it
retrieves the file with the highest assigned weight.



Fast Weight

Specify the weight of this view type of Gopher servers in the category fast. Weights are arbitrary
numbers that you assign to a file format. When Gopher+ can retrieve a file in one of several formats, it
retrieves the file with the highest assigned weight.



Save Extension

Type the extension that you want Gopher+ to use when it saves temporary files generated by the
application when you retrieve a file.



Creating and Changing Bookmarks

Use the Create/Edit Bookmarks dialog box to create or change references to Gopher items.

You can create bookmarks by choosing Create Bookmark from the Bookmarks menu, or change
bookmarks by choosing Edit Bookmark from that menu.

Use this field
Type
Description
Host

Port

Selector

Ask ltem
Gopher+

Related Topics

To specify

The type of Gopher item (a directory, image file, text file, and so forth).
The Gopher item text in the bookmark file.

The Internet address or hostname of the Gopher server you want.

The port that Gopher+ should connect to on the server. With Gopher, this is
usually port 70.

The directory you want to go to on the Gopher server. You do not need to
specify a directory to connect to the server.

Whether to accept Ask item requests.

If the server is using the Gopher plus protocol.

Bookmark Commands Menu

Setting Bookmarks



Configuring Special Gopher+ Features

The Configure Special Features dialog box lets you customize how you use Gopher+ on your PC.

You configure Gopher+ options by choosing Configure Special Features from the Options menu.

Use this box To do this

How to do Dot Stuffing
Set how Gopher+ handles Dot Sutffing.
Show the Multiview Symbol
Set when the multiview symbol W should be displayed.

Feedback Bars
Set whether Gopher+ displays the percentage of transfer complete bars.

Network Buffer Size

Tune Gopher+ performance by adjusting the amount of data it reads from the
network at one time.

Ask Dialog Size
Set the size of the dialog box for Ask items.

When to Delete Temp Files
Set Gopher+ to delete temporary files on viewer exit or on Gopher+ application exit.



account name: The name or word that identifes who is billed for
this session on a computer system.

case sensitivity: The ability of a program to evalutate the difference
between the capitalized and non-capitalized versions of a character.
Case sensitive programs treat for example, caf and Cat, as distinct
items.

It matters how you enter file and variable names on a case sensitive
operating system (such as the UNIX operating system). If you want
to view a file named Cat, and you enter the characters cat, the
system displays the file named cat if one exists, or gives you an
error message. It does not display a file named Cat. Case sensitivity
also effects the way that files are listed when sorted in alphabetical
order.

filename conventions: A TCP/IP network usually contains
computers that run different operating systems. Each operating
system has different conventions for naming files. For example, both
the number and kinds of characters that can be used in a name are
often subject to limits.

When you use some TCP/IP supported services such as telnet and
ftp, use the filenaming conventions in effect on the host system to
work with files that are on the host.

hostname: The name of a networked computer.

The hostname is one form of the computers TCP/IP network
address; the other is its complete numeric network address.You can
access a computer by its hostname or its numeric network address.

toolbar: A group of buttons that appears below the menu bar. These
buttons let you gain access quickly to the application's features.

IP address: A number (in the form n.n.n.n where each n is a value
in the range 0 to 255) that uniquely identifies a networked computer
that uses the TCP/IP communication protocol. (The Internet Protocol
is defined in RFC 791.)

MIB-II: The Management Information Base (MIB) database used by
an SNMP MIB agent to store information about the network
operations of your PC. MIB-II (or MIB version 2) is the second
version of the Internet-standard MIB. RFC 1213 defines the format
of MIB-II.

packet: A single network message with its associated header,
addressing information, data, and optional trailer. Also known as a
"frame" or "datagram".

password: A word or string of characters that you supply in order to
login to another system on a network. Systems that accept the
username "anonymous" often require you to provide your e-mail
address as the password.

permissions: On UNIX systems, settings that control who has
access to a file and what rights (read, write, or execute) are given.
NFS uses UNIX-style permissions to control access to network files.



protocol window: Some OnNet applications support a window
dedicated to displaying the interactions between your PC and the
remote host (the protocol). You can display the window usually from a
View, Settings, or Options menu.

remote host: A networked computer that makes a service available
to other computers on the network. Typical host services include
transferring files, printing files, and managing logins from remote
users.

SNMP community: A relationship between an SNMP agent and one
or more SNMP management stations.

SNMP community name: A unique name shared by the members of
an SNMP community.

SNMP message: A packet of data, consisting of an SNMP
community name and SNMP commands and operands.

status bar: A message area, typically at the bottom of the application
window, that provides information about the component that is currently
selected, or the state of the application.

session: A session comprises the interactions between your PC and a
remote host beginning with the initial connection and ending when you
or the host explicitly disconnect.

Some OnNet applications allow you to configure sessions, that is,
automatically send parameters such as your username and password
to the remote host..

session definition: The configuration settings for a particular session
or host connection. A session definition might include such settings as
the hostname of a computer on the network and your login name for
that computer, as well as other values that you specify. The set of
session parameters you can specify differs with each program.

TCP (Transmission Control Protocol): A Transport layer, connection-
oriented, end-to-end protocol that provides reliable, sequenced, and
nonduplicated delivery of bytes to a remote or a local user. TCP
provides reliable byte stream communication between pairs of
processes in hosts attached to interconnected networks.

time out: A period of time when a connection between a PC and a
host computer is allowed to be idle or unused, or when a PC can
attempt to make a connection to a networked host..

When the time period elapses, the host closes the idle connection, or
the PC reports that it failed to connect to a host.

UDP (User Datagram Protocol): A Transport layer, connection-less
mode protocol providing a (potentially unreliable, unsequenced, and/or
duplicated) datagram communication for delivery of packets to a remote
or a local user. UDP provides a procedure for a process to send
messages to other processes with a minimum of protocol mechanism.

username: A name required for login to a remote system.

wildcard: A character such as * or ? that represents one or more
characters in a filename. In a network, each operating system supports



its own wildcard characters and syntax. When you use wildcards on a
remote host, follow the conventions that apply to that host.



Displays or hides additional elements of this dialog box.
Returns to the previous dialog box.

Displays the Open dialog box so that you can search for
a specific file.

Cancels your selection(s) and close the dialog box
without taking any action.

Closes the dialog box.

Exits the application.

Displays Help about the contents of this dialog box.
Does not proceed as indicated.

Proceeds to the next dialog box.

Confirms your selection(s) and close the dialog box.
Opens the Options dialog box.

Enter a word or string of characters to log in to another
system, workgroup, or domain on a network.

Protects the contents of the file from modification.

Starts the operation.
Stops the operation.
Starts or stops the operation.

Enter the hostname or IP address of the
remote host that you are trying to reach.

Enter the name that you use to log in to a computer on a
network.

Proceeds as indicated.

Proceeds as indicated and avoids further prompts for
confirmation.

Click this to set up options,

Saves all the changes you have
made without closing the dialog box.

Context-sensitive help for this
item is not yet implemented.

Help for this dialog box is not yet implemented.






Technical assistance

Users in the U.S. and Canada, and worldwide resellers Contact FTP Software®:
Telephone: (800) 382-4387
(508) 685-3600
E-mail: support@ftp.com
Fax: (508) 794-4484
or
Users outside of the U.S. and Canada Contact your local reseller.

Tip
For FREE online technical services, see:
World Wide Web: http://www.ftp.com
Anonymous Ftp Server: ftp.ftp.com
Bulletin Board System: (508) 684-6240 ( settings 8,N,1)

CompusServe: GO FTPSOFT (PCVENJ Section 8)






