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Introduction
FTP Plus has been designed to bring the power of enterprise computing to the Windows desktop. 
Realising the gap existing between familiar Windows application users and legacy terminal users, FTP 
Plus allows the navigation and maintenance of files and directories using FTP Explorer and the ease of
editing remote files directly using Edit PLUS.

Edit PLUS provides a feature rich text editor for enterprise computing users, supporting all the features
found in Windows text editors. Edit PLUS increases productivity by bringing new functionality to those 
users limited to using vi and other editors.

Features Summary
· Ability to edit multiple files simultaneously
· Support for both ASCII and binary type files
· Additional features for editing COBOL and other fixed number type files
· Users can create and insert their own code templates
· Ability to indent/unindent text blocks
· Support for Tab/Space character transposition
· Print and print preview support
· Text alignment ruler
· Support for bookmarks and line numbers

FTP Explorer complements Windows Explorer by providing a familiar view of enterprise computer file 
systems. To complement the standard Unix file view, FTP Explorer also supports HP3000 MPE/iX and 
DEC VMS/VAX. This allows a single solution to view and modify files and directories for both users and
system administrators.

Features Summary
· Windows Explorer compliant user interface
· Supports file transfers, create directories, rename files and directories, delete files and directories.
· Files can be transferred and viewed quickly using Windows file associations
· "Send To" shortcut menu support
· Multi-platform FTP client for Unix, HP3000 MPE/iX and DEC VMS.



Technical Support

Unregistered Users 

Low-priority email and fax support 

Registered Users 

All registered users of Whisper Technology products are entitled to the following services during the 
90-day warranty period which commences on date of purchase of the Software: 

Email support 
Fax support 

All registered users are entitled to use new incremental releases of the purchased product within the 
same version (i.e. Version 1.1 -> 1.2) at no extra charge. New versions (i.e. Version 1.2 -> 2.0) will be 
chargeable. 

Subscription and Support Program 

After the warranty period has expired, Whisper Technology offer the following Subscription and Support
Program which includes: 

No cost upgrade to new versions of the Software purchased 
Priority telephone support (Monday to Friday from 5:00 AM to 5 PM EST) 
Priority email support 
Priority fax support 

The Subscription and Support Program is charged at an annual subscription of 30% of the total 
Software purchase price within the organisation (subject to a minimum annual charge of $500). 

Customers who purchase the Subscription and Support Program at the same time as their order for the
Software will also benefit from the full level of support during their 90-day warranty period. The next 
payment due under the Subscription and Support Program will then not be due until 15 months after 
the purchase of the Software, to allow for the 90-day warranty period. 

To order the Subscription and Support Program please note this on the Order Form or email 
sales@whispertech.com 

Contacting Whisper Technology Support 

Email support: support@whispertech.com

Telephone support: 

North America: 011 44 1372 360080 
International: +44 1372 360080 



Fax support: 

North America: 011 44 1372 360090 
International: +44 1372 360090 



FTP Plus Order Form

Please print and complete both sections of the form below and fax to:
        North America 1-888-465-8146        International    +44 1372 360090

Alternatively you can call our sales line with these details on:
        North America 1-888-465-8145       International    +44 1372 360080

1.    Pricing and Ordering for Whisper FTP Plus *

  To order 1   - 4   copies. ..... copies  @ $99  each  =  .......
  To order 5   - 9   copies. ..... copies  @ $79  each  =  .......
  To order 10  - 19  copies. ..... copies  @ $69  each  =  .......
  To order 20  - 49  copies. ..... copies  @ $62  each  =  .......
  To order 50  - 99  copies. ..... copies  @ $49  each  =  .......

* Value Added Tax (VAT/TVA) @ 17.5% will be applied to all orders from the UK. VAT/TVA @ 17.5% will
be applied to all orders from other European Community member states unless the organisation's 
VAT/TVA Registration number is correctly completed below.

2.    Billing Address and Payment Details

     Name:    ..................................................

     Company: ..................................................

     Address: ..................................................
              
              ..................................................

              ..................................................

     Country: ..................................................
 
     * VAT/TVA No: .............................................

     Phone:   ..................................................

     Fax:     ..................................................

     Email:   ..................................................

     Purchase Order No: ........................................

     Credit Card:  VISA / MASTERCARD / AMEX   (please circle)

     Name on Card: .............................................



     Card Number: .. .. .. .. .. .. .. .. .. .. .. .. .. .. .. .

     Expiration Date:  .. .. / .. ..

     Which Company recommended this software (if any) ..........

Thank you for your order.
All orders are subject to Whisper Technology's License Agreement.



License Agreement

Definitions

"Software" means all the software items supplied in this package including programs, dictionaries, 
indexes, data files, help files, tutorial and sample programs, files, databases, forms and reports.

"Validation Codes" are those codes or keys supplied to the Customer on purchase of a license for the 
Software.    The Validation Codes confirm the Software as licensed and register the Software with the 
name of the Customer.      

Whisper Technology Limited ("Whisper Technology") is the owner of the copyright and other rights in 
the Software and is, accordingly, the licensor of the Software.

"Customer" is the person acquiring the Software and is, accordingly, the licensee in respect of it.

License Agreement

Prior to payment of the applicable license fees, Whisper Technology permits the Customer to use the 
unregistered Software for the sole purpose of evaluating whether to purchase a license for the 
Software.    This evaluation period is limited to a maximum period of 30 days after which the Customer 
should delete all copies of the Software or purchase a license for the Software. 

Subject to payment of the applicable license fees, Whisper Technology grants the Customer a non-
exclusive, non-transferable license to use the Software.    On purchase of a license for the Software, 
Whisper Technology will supply Validation Codes to confirm the Software as licensed and to register 
the Software with the Customer's name.

The Software may be used on a single computer, or on a network provided that each person who uses 
the Software through the network has a copy of the Software licensed to him or her.

Where the Customer uses a computer at work and a separate computer at home then the Customer 
may also use the Software on the second computer so long as only one copy is used at a time.

The Software may be copied for back-up or archival purposes provided that any copies of the Software
are clearly labelled as such and include a prominent notice to the effect that Whisper Technology is the 
copyright owner.

The Customer may freely copy the Software, only in its original distribution format and without 
modification, to others for their evaluation purposes.    In no circumstances may the Customer charge, 
or request donations, for any such copies.    

In no circumstances may the Customer copy or in any other way provide any Validation Codes 
supplied to the Customer by Whisper Technology to any other person.

The Customer shall take all reasonable precautions and measures to protect the Software and 
Validation Codes from unauthorised use, access, copying, modification, reproduction, distribution or 
publication.



No title to, or ownership of the Software is transferred to the Customer.

Prohibited Uses
 
The Customer may not make copies of the Software and Validation Codes except as provided above.
 
The Customer may not rent, lease, lend, share, license or transfer the Software.

The Customer may not decompile, disassemble, reverse engineer, or otherwise modify the Software, 
save as provided for under local law.    

Embedded Distribution License (where purchased)

Only where Customer also purchases an "Embedded Distribution" License, the Customer may, without 
additional payment to Whisper Technology, additionally distribute the Software to third parties only 
together with compiled programs sold to the third party by the Customer.    Use of the Software by t he 
third party is solely limited to use with these Customers compiled programs as supplied and as 
documented to the third party by the Customer.    Any other use of the Software by the third party, such 
as use with other programs, files or databases is prohibited.    

Customer shall provide the third party with all documentation and support required to use the Software 
supplied under an Embedded Distribution License.

The Customer may not supply any Validation Codes to the third parties other than the Validation Code 
supplied to the Customer specifically for distribution to the third parties.    This Validation Code will 
name the Licensee as the Customer and will contain the phrase "Embedded License".

The Customer must include a notice with any copies of the Customer's compiled programs and the 
Software setting out the restrictions on use of the Software as outlined above.    The notice should also 
make clear that all support for the Software licensed under an Embedded Distribution License is 
through the Customer, and that in no circumstances can Whisper Technology provide any support 
directly to the third party. .    The notice should clearly inform the third party that any other use of the 
Software, or direct support from Whisper Technology, would require the third party to purchase t heir 
own license for the Software.            

The notice must also set out that the copyright in the compiled programs (and associated databases, 
files, forms and reports) belongs to the Customer and copyright in the Software belongs to Whisper 
Technology and that the Software may not be copied, decompiled, disassembled, reverse engineered, 
or otherwise modified.    

The notice must also set out that Whisper Technology has not written the Customer's compiled 
programs (and associated databases, files, forms and reports) and accepts no responsibility for any of 
the programs or other software items delivered by the Customer.

The Customer must make clear to the third party the features in the Customer's software provided by 
use of the Software.

The Customer is entirely responsible for the quality and fitness for purpose of any software distributed 
to third parties containing programs compiled by the Customer using the Software.



The Customer shall save harmless and indemnify Whisper Technology against claims from third 
parties.

Termination

The Customer may terminate this agreement at any time by permanently deleting or destroying all 
copies of the Software and sending written confirmation of this to Whisper Technology.
      
Whisper Technology may terminate this agreement at any time following a breach of this agreement 
and/or infringement of Whisper Technology 's copyright.

Warranty

Whisper Technology warrants that the Software, when correctly installed, will perform in substantial 
accordance with the documentation provided for a period of 90 days after licensing of the Software.    
Whisper Technology does not warrant that the operation of the Software will be uninterrupted or error 
free.

Whisper Technology's sole liability under any breach of this Warranty is to replace a defective copy of 
the Software or to refund the license fee paid for the Software.

Liability

The Customer is entirely responsible for determining the suitability of the Software for his/her purposes
and for the use that he/she makes of the Software.

Whisper Technology are not liable for any loss or direct, indirect, special or consequential damages 
arising from the use of the Software, however caused, save that provided for under local law.

Entire Agreement

This agreement represents the entire agreement between Whisper Technology and the Customer and 
supersedes all previous agreements or representations whether written or oral.

Applicable Law

This agreement is subject to the laws of England.



MPE/iX Questions and Answers

If you have a question about how to use FTP Plus with an MPE/iX FTP Server it is likely that the 
question has been asked before. If you are still having problems or have a question please email 
support@whispertech.com.

Q. I am unable to connect to the HP3000
 
A. Check with your network administrator. The FTP service must be available before you can connect. 

Check that the FTP server job (JFTPSTRT.ARPA.SYS) is running.

Check that the correct IP/host address has been specified. See your network administrator for this 
information.

 
Q. I am unable to logon.
 
A. If an MPE/iX user cannot logon to the remote system, verify the logon account and passwords are 
correct.
 
Try to logon to the server from a terminal with the user's account and password(s).

Q. What do I enter for username and password for a connection ?

A. MPE/iX user logon accounts are in the form:

sessname,username.acctname,groupname 
 
The session name parameter (sessname) is optional. Passwords may be
required for all three parts of the user account:
 
userpass,accountpass,grouppass 
 
You can enter the user logon account and passwords together as follows:
 
session1,username/userpass.acctname/acctpass,groupname/grouppass 

Q. What is the difference between folders and Account and Groups ?

A. FTP provides a hierarchical view of a file system. In terms of native MPE/iX, the folders off the root 
are Accounts, and the sub folders are Groups.



Q. How can I specify a connection starting in a specific account ?

A. In the connection properties specify the account name (in upper case) prefixed by a '/'. For example 
"/SYS", or for a group in the SYS account "/SYS/PUB". Please note you cannot traverse back from the 
start folder.

Q. Can I be prompted for my password when I connect or do I have to specify my password in 
the connection properties?

A. If the password field is left blank FTP Plus will prompt you if it requires a password for the specified 
account. Please see above for logon and password rules. Please remember that the password will be 
requested every time the FTP server is connected and that the frequency of this is determined by the 
timeout setting.

Q. What is the difference between native MPE/iX file system and the POSIX file system ?

A. FTP Plus attempts to distinguish between POSIX and MPE/iX file systems in order to reduce the 
confusion of users when dealing with files.

Restrictions and implications of the choice of file system are summarised below. More information on 
the differences between the two file systems is available from Hewlett-Packard.

Native MPE/iX

· New files cannot be created with file extensions.
· It is not possible to create either Accounts or Groups.
· It is not possible to delete either Accounts or Groups.
· It is not possible to download the entire contents of an Account.
· All new folders are created as HPFS Directories.
· Files uploaded as either ASCII or binary are created with default file attributes.
· File names are case-insensitive and all appear in upper case
· FTP Plus allows any files whose MPE file type is ASCII to be streamed to the MPE job queue.

MPE POSIX

· New files are not necessarily visible to the native MPE/iX file system.

 
Q. Why are new folders created using FTP Plus not appearing in the MPE/iX file system?

A. Folders created using FTP Plus are created as HPFS directories and are only visible in the POSIX 
file system.

If you want these new folders to appear in FTP Plus change the connection type to POSIX.

Please note it is not possible to create new Accounts or Groups using FTP Plus.



Q. Can I work with multiple files in the Explorer windows ?

A. Yes, select the files using the CONTROL or ALT keys while selecting items with the mouse.

Q. Can I download complete accounts from my HP3000?

A. Yes, however you have to download each group individually.

Q. What happens when I open a file that has a lockword ?

A. FTP Plus will prompt for the lockword for the file. If the lockword is not known the operation with be 
aborted.

Q. How can I add a lockword to a file ?

A. Select rename from the File menu, suffix the filename with "/" followed by the new lockword.

Q. What happens when I open a numbered file in Edit PLUS ?

A. Edit PLUS should be able to determine if a file is numbered and prompt you to remove the numbers 
while editing. When saving the file the numbers will be added.

Q. What happens when I open an EDTCT (COBOL Edit File) in Edit PLUS ?

A. Edit PLUS should be able to determine if a file is COBOL file and remove the numbers while editing.
When saving the file will be renumbered from 1000 in steps of 10.

Q. What happens if I edit a QEDIT file ?

A. There is currently no support for QEDIT files and the file is viewed in its ASCII format. We are 
currently investigating the possibility of supporting QEDIT and other native file formats.

Q. Can I upload or download a file that has been transferred using WRQ Reflection with labels ?

A. Yes, however due to inconsistencies between versions of the FTP Server, support for files with user 
labels and variable binary files may be disabled.

Q. Why does it take longer to connect to the HP3000 in comparison to a standard UNIX server ?



A. The HP3000 FTP server program issues a programmatic logon for each connection in order to 
conform to the HP3000 security semantics. This results in slow connection times similar to that of a 
normal logon.

Q. When I open a file in Edit PLUS each line is padded with spaces to the file’s record length, is 
there any way to remove these trailing spaces ?

A. In Edit PLUS you can either use the Replace Special item in the Edit menu to remove all trailing 
spaces or through the program Options remove trailing spaces by default.

Q. Can I set the record length of an open file in Edit PLUS ?

A. When Edit PLUS saves a file it uses the Margin Size of a file to determine a files record length. 
When this is zero the file is saved as variable ASCII, when it is a positive value the file is saved as fixed
ASCII.



Command Macros

Edit PLUS now includes support for Command Macros. These allow the recording of keyboard and 
mouse operations in order to quickly reproduce a repetitive series of user interactions.

Recording a new Macro

1. From the Macro menu, click Record
2. Perform the task you wish to record (you can use either the mouse of the keyboard)
3. From the Macro menu, click Stop

Note: You can you the Pause item in the Macro menu to suspend recording. Clicking pause again will 
continue recording.

Saving a New Macro

1. From the Macro menu, click Save As
2. Enter a file name and choose save

Loading an Existing Macro

1. From the Macro menu, click Load
2. Select the macro file to load and choose open

Note: Loading a new macro will replace any existing macro.

Playing the Current Macro

1. From the Macro menu, click Play
2. The tasks that were recorded will now be played in order.

Note: To interrupt a macro while it is playing press Ctrl+Break.



Native Language Support

Since the 8 bit character set using by PC’s often does not match the 8 bit character set on FTP 
servers, Edit PLUS now includes support for translating files. Native Language Support or NLS allows 
the contents of a file to be translated as it is opened and restored when it is saved.

Using NLS

To allow a file to be translated between the FTP Server and Edit PLUS a translation file is required. 
This file determines how specific characters in the ASCII character set should be translated.

Hebrew Support

For details on native Hebrew language support please contact Technical Support .

Creating a Translation File

A translation file takes the format of an INI file, with a section determining the language name followed 
by the ASCII table assignments. The values in the conversion table are always listed as the client 8 bit 
ASCII code followed by the ‘=’ character followed by the server 8 bit ASCII code. 

A translation file must have the extension NLS and must reside in the same directory as Edit PLUS. If 
you have created a new NLS file while Edit PLUS was running it must be restarted in order to search 
for the new file.

The following example determines how a translation table may be constructed for the Finnish* 
language. Remember that for every entry in the table there must be a matching translation, in this 
example note that the translation 201=221 is followed by 221=201. This allows Edit PLUS to correctly 
translated the file when it is saved as well as opened.

[Finnish]

201=221
221=201

217=222
222=217

An NLS file can contain any number of translation tables.

Note: It is very important to check that the translation table is complete, with all translations 
from server to client being matched with client to server entries. If this is not done correctly the 
file may not be translated properly which can lead to file corruption. 



Using Native Language Support in Edit PLUS

When Edit PLUS is loaded it searches for any NLS files in the directory it is running from. If any NLS 
files are detected, a new item, “Language”, is added to the bottom of the Edit menu.

Translating a Document
 
1. From the Edit menu, click Language
2. From the Language menu, select the desired language translation

The file is now translated using the specified language. When the file is saved the document will be 
translated back into its native language before it is transferred.

Removing Translation from a Document

1. From the Edit menu, click Language
2. From the Language menu, click None

The file will now be returned to its native format. The file will be transferred verbatim when it is saved.

Automatically Translating Documents

If you find that the majority of your documents require translating to a single language, Edit PLUS 
allows a default translation to be specified in the program Options. 

1. From the View menu, click Options
2. In the Options dialog, select the Language tab
3. Select the “Automatically convert files to” option
4. Select the desired language translation and click OK

Note: When applying a default language translation remember to remove translations when loading 
files from an FTP server using a different language set.



New Editing Features

Select Line – Automatically select the entire contents of the current line (Ctrl+L)
Display Options – Set the Typeface and Color of the editor
Command Macros – Record common tasks and play them back
Custom Insert Menu Items – Add your own items to the insert menu
Default Templates for New Files – Easily select the template options for new files
Enhanced Support for MPE/iX Files – Specify the file type ID for MPE/iX files

Edit PLUS has been designed to aid its users in quickly editing files.    Because we are committed to 
providing the most feature rich edit available for FTP users we are constantly taking comments from 
our users and incorporating them into the product. If you have any features you would like to be 
considered for the next release of Edit PLUS, please email us at support@whispertech.com



Adding Custom Items to the Insert Menu

Edit PLUS allows users to add commonly used text strings to the insert menu by means of    external 
INC files. These appear on the Insert menu and when selected insert the contents of the INC file at the 
current cursor position.

Creating a New INC File

INC files are simply ASCII files containing text.    When Edit PLUS is loaded it searches the specified 
INC file location for files with the extension INC and adds them to the Insert menu.

Specifying INC File Location

1. From the View menu, click Options
2. In the Options dialog, select the Includes tab
3. Select the location of the INC files and click OK



Using Bookmarks

Bookmarks are a handy way to mark lines and quickly jump back to them when required. 

Adding a Bookmark

1. Place the cursor on the line on which you want to bookmark
2. From the Edit menu, click Toggle Bookmark

Note: To remove a bookmark click Toggle Bookmark again

Navigating Bookmarks

Bookmarks are easily navigated using the Next Bookmark item from the Edit menu, this will move the
cursor to the next line in the document on which a bookmark is set. When the end of the document is 
reached, searching for the next bookmark continues at the start of the file. If there are no bookmarks 
the cursor will not be moved.

Viewing the Bookmark Margin

Lines marked with Bookmarks are displayed using a pin in the Bookmark margin. Using the Bookmark
Margin option in the View menu it is possible to show or hide the margin. This will not affect navigating
or adding/removing bookmarks.



Using Edit PLUS for Terminal Users

Those users familiar with using a terminal emulator to edit their files will need to determine how tabs 
are entered in those files and whether they overwrite text by default. 

Tabs settings are set in the program’s Options dialog. This allows the tab character to be substituted 
with spaces, which is especially useful for COBOL programmers using compilers that do not support 
the tab character.

By default when the user presses the tab key (not applicable if there is a text selection) a tab character 
is inserted at the current cursor position. If you are more familiar with the tab key moving the cursor 
position to the next tab stop, you will need to change the edit mode. Pressing the Insert key will force 
all text to be overwritten, pressing the Insert key again will switch this off.

Note: You can determine which edit mode is selected by looking at the second field from the right in 
the status bar, if it displays INS the current edit mode is insert, if it displays OVR the current edit mode 
is overwrite.



Context Sensitive Help for Programmers

Applications such as Microsoft Visual C and Microsoft Visual Basic offer programmers the ability to 
search an external help file based on the word currently under the cursor position. Using Edit PLUS it 
is also possible to open an external help file as a programming language reference. 

Using this functionality, users of Microsoft Visual C 1.5 can to use the help file MSCXX.HLP (which is 
optionally installed into the help directory) to provide context sensitive help on “C” within Edit PLUS.

Specifying a Context Help File

1. From the View menu, click Options
2. In the Options dialog select the Help Files tab
3. Enter the name of the help file and click OK

Note: Edit PLUS uses the current selection or the word under the cursor as a search item in the index 
of the specified help file. If the item does not exist, the Help file will list the closest possible match in its 
index.



Working with Local Files

Edit PLUS gives users the option to open or save documents as standard PC files. Using the Local 
Open and Local Save As items in the File menu, files can be stored locally for backup purposes, in the 
event of a loss in communications with the FTP server or as an alternative to Notepad.

Opening a PC file

1. From the File menu, click Local Open.
2. Select the file(s) to open and click Open.

Note: you must use Local Save As to save the file locally.

Saving a file as a PC file

1. From the File menu, click Local Save As.
2. Enter the destination file name and click Save.



Command Line Options

Edit PLUS supports the following command line options:

ftp:// [server] / [directory] / [filename]

For examples of how to specify the fully qualified filename, open the file in Edit PLUS, the correct 
filename will appear in the caption.



Editing Native MPE/iX Files

Opening Known File Types

COBOL (EDTCT) Files – Are automatically assigned the COBOL file template, this includes support for 
line numbering and entering tabs as spaces.

Numbered Files – When loading a file, Edit PLUS checks for right hand line numbers in the file. These 
are then removed and the Numbered Files template is assigned.

Fixed (FA or FB) Type Files – The margin size    is set to the record length taking into account and 
numbering template assigned

Changing the Record Length of a File

The record length of an MPE file is determined by the margin size assigned by Edit PLUS. When 
opening any fixed type file (FA or FB) Edit PLUS uses the MPE record length as the margin size after 
taking into account and numbering template assigned. When the file is saved the margin size is then 
used to set the record length of the file. 

Files with a margin size are saved as either FB or FA, files with a margin size of 0 are saved as either 
VA or BS, depending on whether the file is saved as ASCII or Binary.

See Setting the Margin Size for more information

Changing the File Code of a File

The MPE/iX file code is used by applications on HP3000 to identify the type of a given file. 

1. From the Edit menu, click Properties
2. Select the new file code from the MPE File Code drop down list or enter a numeric value
3. Click OK to update the file properties.

Note: The file must have be native MPE/iX file to allow the file code to be changed. The type of a file, 
MPE/iX or UNIX, is identified in the 4th panel from the right on the status bar.



Setting the Margin Size

The margin size is used to restrict the maximum length of any given line in a document. This is ideal for
COBOL files or files which must maintain a predetermined file structure during editing. The MPE/iX 
Numbering template also uses the margin size to determine where to insert right hand line numbers 
when saving a file.

Changing the Margin Size

1. From the Edit menu, click Margin (Ctrl+M)
2. Enter the new margin size.
3. Click OK to update the document.

Note: The margin size must exceed the length of the longest line in the document including any 
numbering template assigned.




