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Preface

The TEDVISION User’s Guide provides thorough product information on using,
customizing, and troubleshooting TEDVISION so that you can take full
advantage of the Internet and your local file system.  Numerous illustrations
have been included to support text references in order to make using
TEDVISION as simple as possible.

Who Should Use This Guide

TEDVISION is easy to use.  It should take next to no time at all before you are
exploring  the “information superhighway.” TEDVISION will provide a
consistently easy-to-use interface that will make navigating the Internet and
your desktop both simple and productive.

Note – The TriTeal Enterprise Desktop™ (TED™) is based on Common Desktop
Environment (CDE) technology. This manual may refer to the desktop as
TriTeal Enterprise Desktop, TED, or simply, the desktop.

How This Guide Is Organized

Chapter 1, “Introduction to the World Wide Web (WWW),” describes the
basics of the WWW and how TEDVISION works with the Internet.

Chapter 2, “Getting Started with TEDvision,” describes the basics of
TEDVISION so that you can immediately take advantage of all that is available
to you through the Internet.

Chapter 3, “Using TEDvision,” describes all the features available to you.

Chapter 4, “Working with Non-HTML Files,” is a more in-depth look at the
features of TEDVISION that enable you to work with various file types (audio,
video, and so on).

Chapter 5, “Customizing TEDvision,” describes how to customize the
interface to suit your needs, whether by preferences, resources, or commands.
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Chapter 6, “System Administration,” contains information on setup and
configuration of TEDVISION, including email servers, proxy servers, and
newsgroups. It also provides a comprehensive list of errors and problems, as
well as possible solutions.

Related Books

The following books provide information on the TEDVISION desktop service
and the Internet Information Services.

• The Mosaic Handbook for the X Window System, by Dale Dougherty, Richard
Koman, and Paula Ferguson, published by O’Reilly and Associates, Inc.,
Sebastopol, CA 95472.

• Managing INTERNET Information Services, by Cricket Liu, Jerry Peek, Russ
Jones, Bryan Buus, and Adrian Nye, published by O’Reilly and Associates,
Inc., Sebastopol, CA 95472.

What Typographic Changes and Symbols Mean

The following table describes the type changes and symbols used in this book.

Table P-1 Typographic Conventions

Typeface or

Symbol Meaning Example

AaBbCc123 The names of commands, files,

and directories; onscreen

computer output

Edit your .login file.

Use ls -a to list all files.

system% You have mail.

AaBbCc123 Command-line placeholder:

replace with a real name or

value

To delete a file, type rm filename.

AaBbCc123 Book titles, new words or terms,

or words to be emphasized

Read Chapter 6 in User’s Guide.

These are called class options.

You must be root to do this.
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About TEDVISION

TEDVISION lets you navigate the World Wide Web (WWW), your local file system,
and other Internet services by simply clicking on hyperlinks. It is based on
NCSA Mosaic, which was developed by the National Center for
Supercomputing Applications (NCSA) at the University of Illinois in Urbana-
Champaign.

New Features in this release

TEDVISION takes advantage of Hypertext Markup Language (HTML) 2.1, as
well as a variety of new features including internationalization, multi-screen
display, simultaneous graphics downloading, and a significantly enhanced
Preferences window allowing for a greater range of personal customization.

New support for HTML 2.1 features

The following HTML 2.1 features are now supported by the TEDVISION

browser:
• Tables
• Background graphics
• Centered text or graphics

Documents that contain tags for any of these elements will be displayed
correctly in TEDVISION.

Other enhancements

TEDVISION supports multiple network connections, which allows multiple
graphics in an HTML document to be downloaded simultaneously.

TEDVISION has also been internationalized, supporting browser-server
language negotiation and the display and printing of multi-byte HTML
documents.
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The TEDVISION Preferences panel has changed significantly, letting you
customize your display by changing fonts, colors, improving image quality, or
setting preferred languages. You can also specify proxy servers for HTTP,
gopher, and ftp protocols.

TEDVISION has improved the way you select text in a browser view. If you
select text and drag to extend the selection, the document will automatically
scroll to let you extend the selection to the end of the document. Previous
versions of TEDVISION would not let you extend the selection past the text in
the current window.

TEDVISION has been multi-screen enabled, letting you open multiple browser
views on multi-screen displays.

Internet Basics

If you’re new to the net, understanding some basic concepts will help you get
started.

Like other Internet components, the World Wide Web (WWW) is an
information-sharing system that allows documents to be stored on and
retrieved from servers along the network. Unlike other Internet components,
the WWW uses the powerful information technology called hypermedia.

On the WWW, hypermedia works as follows: every document has a unique
address, much like a telephone number, called a Uniform Resource Locator
(URL). WWW documents can contain hyperlinks that point to the URLs of
other documents.

TEDVISION lets you explore the WWW interactively by simply clicking on
hyperlinks. For example, a document on British literature can link the word
“Shakespeare” to a document listing the writer’s work by title. Each title in
that document could, in turn, be linked to a complete work.

TEDvision is an Internet application for the World Wide Web (also known as
WWW, W3, or the Web), and can also be used to access other Internet services
including FTP, Usenet newsgroups, and gopher sites. The WWW is a global
network of interconnected documents. HTML, which stands for HyperText
Markup Language, is the markup language used to write documents on the
WWW.

HTML documents can be linked to other resources on the Internet, including
other documents, audio files, graphics, videos, and software programs.

Each document on the Internet is identified by a unique address called a
uniform resource locator (URL), such as the following example:

http://www.triteal.com/support/index.html

This is the URL for the document index.html in the support directory on a server
named www.triteal.com. The first part of the URL, http://, indicates the protocol
used to transfer the document.

The easiest way to open documents is to click on hyperlinks associated with
URLs. You can also open a document by entering a URL directly.
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Note – TEDVISION lets you save a document as a URL file. You may drag and
drop this URL into TEDVISION to go directly to the Internet address that it
specifies. URLs may also be saved to the File Manager or sent to others as an
attachment in the Mailer or saved to the desktop.

These are the concepts you’ll need to get started. To learn more about the Web
or HTML, see the following online documents (for information about opening
documents, see Chapter 3, “Using TEDvision”):

• A Beginner’s Guide to URLs

http://www.ncsa.uiuc.edu/demoweb/url-primer.html

• A Beginner’s Guide to HTML

http://www.ncsa.uiuc.edu/General/Internet/WWW/HTMLPrimer.html
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Getting Started with TEDVISION 2

This chapter will quickly familiarize you with the TEDVISION features, so that
you may begin using TEDVISION right away. For a more in-depth look at what
TEDVISION has to offer, see Chapter 3, “Using TEDVISION” or if you want to
personalize the interface, see Chapter 5, “Customizing TEDVISION.”

TEDVISION lets you access information on the World Wide Web (WWW) and
other Internet services. For a basic understanding of the Internet and the World
Wide Web, please see “Internet Basics” on page 2.

Note – Please see “Installation Issues” on page 51 of Chapter 6, “System
Administration” for more information on setting up TEDVISION for your
system.

What’s Hot

TEDVISION is built on an open, standards-based architecture. This makes
TEDVISION adaptable to the various requirements of network publishing and
commerce. Key aspects of the new architecture and a rundown of new features
are listed below:

• Mosaic Security Framework—Basic Authentication and Digest
Authentication come pre-installed.

• Software Development Interface—This two-way application programming
interface (SDI) lets other applications seamlessly interoperate with
TEDVISION.

• Advanced Display Technology—Lets you download documents in multiple
windows. Text is immediately displayed, allowing you to follow links before
the downloads are complete.

• Inline JPEG Support—In addition to GIF images, inline JPEG images are
now supported.

• Built-in GIF and JPEG Viewers—An internal image viewer automatically
displays stand-alone GIF and JPEG files.

• Configurable Helper Applications—Configuring helper applications to
support new file types is now easier with an easy-to-use dialog box.
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• Drag-n-Drop—Full drag-n-drop functionality with the TriTeal Enterprise
Desktop with the addition of three new datatypes: FTP, URL, and HTML.

• Popup Menus—Objects and CDE action objects include CDE actions in
menus as well as popups on images, anchors (URLs), background, and so
on.

• Improved URL Field Entry—Allows direct entry for URLs, tilde expansion
of pathnames, collapsed pathnames and simple hostname entry.

• History List—A drop down history list lets you quickly access previously
visited sites with the touch of a button.

• Client-Side Image Maps—Client-side image maps now let you access image
maps locally without interacting with a server.

• Tool bar—A new tool bar provides quick access to frequently used menu
commands.

Starting TEDVISION

You can start TEDVISION either from command line or by double-clicking the
TEDVISION application icon.

▼ To start TEDVISION from the Application Manager

1. Locate the TEDVISION folder icon inside the Application Manager.

2. Double-click the TEDVISION folder.

You will see several items including the TEDVISION icon, a Search_Tools

folder, and so on.

3. Double-click the TEDVISION icon.

▼ To start TEDVISION from the command line

1. Change directory to /usr/dt/bin.

2. Type the following command:

tedvision

Getting to Know the TEDVISION Interface

TEDVISION can display HTML, SHTML, JPEG, GIF, and text files in one or
more windows. You can also add helper applications to work with other file
types such as audio files or movie clips.

You can open more than one browser window. This lets you interact with each
document window independently. For example, you can read a document in
one window while loading new documents in other windows.
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When you load a document, text is displayed as soon as TEDVISION receives it.
After all text is received, any inline images are loaded. You can click links as
soon as they are visible. If you click a link before the entire document is
loaded, the current document will be cancelled, and the new document will be
downloaded in the same window.

The TEDVISION interface makes using the Internet simple. The elements of the
TEDVISION main window are described in Figure 2-1.

Figure 2-1 The TEDVISION Interface

The graphical elements of the TEDVISION window are described below:

Title Bar The title bar contains the title of the document in the
window.

Menu Bar The menu bar contains all menus and available
options. For more information on menu command
descriptions, please see “Menu Bar” on page 8.

Tool Bar Tool bar buttons provide quick access to frequently
used menu commands. For more information on tool
bar functions, please see “Tool Bar” on page 10.

URL Field The URL field displays the current URL. You can open
a document by entering its URL here. URLs must not
begin with a space.

Activity Indicator The activity indicator is activated while TEDVISION is
transferring information or waiting to receive
information. The activity indicator moves at a constant
speed and does not indicate how fast data is being
transferred.

Status Bar The status message area displays:

• Status messages during a document transfer.

Title Bar

Tool Bar

URL Field

Status Bar

Progress

Indicator

Activity

Indicator

Menu Bar
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• A URL when the mouse pointer is over a link.

• Command descriptions when the mouse pointer is
over a menu command or tool bar button.

Progress Indicator The progress indicator shows the portion of the
document that has been loaded. Because some servers
do not provide file size information, the progress
indicator does not always display.

Title Bar

The title bar contains the title of the document in the window. Note the location
of the title bar in Figure 2-1.

Menu Bar

While the tool bar contains all the necessary functions to quickly use
TEDVISION, the menu bar provides quick access to almost all features. See
online help (press F1) for descriptions of menu commands. The menu bar is
displayed in Figure 2-1.

File Menu

Open URL... Opens a document on the Internet by entering a URL.

Open Local... Opens a document on your computer or local
network.

Save As... Saves the current document to your computer.

Find... Searches the document for a specified word or phrase.

Find Again Repeats the last search within a document.

Print... Prints the current document.

Print Setup... Lets you change printer options.

View Source Displays the HTML tags in the current document but
does not allow changes.

Close Closes the current browser window. If there is only
one window open then TEDVISION will exit.

Exit Closes all browser windows and quits the TEDVISION

application.

View Menu

Open New View Opens a new TEDVISION window.

Load Missing Images Loads images that have not been loaded due to
settings in the Preferences dialog box.

Reload Reloads the current document.
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Options Menu

Security Lists installed security modules:

Basic Authentication...
A basic, non-secure protocol supported by nearly all
web servers. A user name and password are sent to
the server in uuencoded form. This method can be
used to limit access to a server.

Digest Authentication...
Uses MD5-encrypted passwords for authorization to
receive an HTTP reply. Server access may also be
controlled with Digest Authentication.

Preferences... Lets you change TEDVISION options.

Helpers... Configures helper applications

Navigate Menu

Back Displays the previous document.

Forward Opposite of the Back command.

Home Displays the home page.

Add Current to Hotlist Adds the current document to the Hotlist window.

History... Displays the History window.

Hotlist... Displays the Hotlist window.

Stop Stops requested documents from downloading.

Help Menu

Overview... Displays an overview of available help.

Table of Contents... Displays a list of headings by subject.

Tasks... Displays list of topics by tasks.

Reference... Lists reference help.

On Item Click on the item you want help on.

Using Help... Displays help on the help system.

About TEDvision... Displays program and system information.
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Popup Menu

Within the TEDVISION main window, you can invoke a popup menu. Click
anywhere within the main window with mouse button 3, and you will get a
popup menu that lets you perform many of the TEDVISION’s menu actions. It is
shown here in Figure 2-2.

Figure 2-2 Popup Menu

Tool Bar

Tool bar buttons provide quick access to frequently used menu commands. For
a description of a tool bar button, place your mouse pointer on the button. See
Figure 2-3 for a description of various tools.

Figure 2-3 Tool Bar Buttons

Back Home

Open

URL Find Print

Load Missing

Images
View

Source

Forward Add

Current to

Hotlist

Save

File

Find

Again

Reload Open New

View

Stop

Activity
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Table 2-1 shows each tool bar button, its function, and a brief description.

Table 2-1 Tool bar Components

Button Function Description

Back Returns to a previously visited

document.

Forward Moves forward one document in the list

of previously visited documents.

Home Accesses the home page document that

has been set in the Preferences window

(see “Returning Home” on page 25).

Add Current

To Hotlist

Adds the current document to the

Hotlist.

Open URL Opens a dialog box that prompts for a

uniform resource locator (see “Internet

Basics” on page 2).

Save Current File Opens a Save As window for the

currently loaded file.

Find Opens a dialog box that allows you to

search the current document.

Find Again Repeats the last search specified in the

Find dialog box.

Print Prints the current document.

Reload Reloads the current document.

Load Missing

Images

Loads any images that are missing. This

may be done all at once or one at a time

depending on Preferences settings.
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If you wish to turn the tool bar off, choose Preferences from the Options menu,
and display the Miscellaneous view. Then clear the Show Tool Bar check box.

URL Field

The URL field displays the location of the current document. You can open a
web site or document by entering its URL here. URLs are case sensitive and
must not begin with a space. The URL field is shown in Figure 2-1.

Drop Down History List Button

At the far right of the URL field is a history button that, when pressed, will
show a history of all the locations you have been. To revisit a given location,
simply highlight an entry with the mouse and release the mouse button. For
more information about this topic please see “Using the History List” on
page 20.

The History List window is shown below in Figure 2-4.

Figure 2-4 The Drop Down History List

Status Bar

Below the display area is the status bar. Figure 2-5 shows a typical display in
the status bar.

Figure 2-5 Status Bar Message Area

Open New View Opens another browser window that you

can use to access another web site or

local document.

View Source Opens another browser window, which

contains the HTML source for the

currently displayed document.

Stop Activity Stops downloading the current

document.

Table 2-1 Tool bar Components

Button Function Description

History Button
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The status bar displays:

• Status messages during a document transfer.

• A URL when the mouse pointer is over a link.

• Command descriptions when the mouse pointer is over a menu command
or tool bar button.

Indicators

The progress indicator provides a visual reference for the percentage of the
current document that has been loaded. Since some servers do not provide file
size information, the progress indicator does not always display.

The activity indicator is activated while TEDVISION is accessing the network. The
activity indicator moves at a constant speed and does not indicate how fast
data is being transferred.

Searching the Internet

In the TEDVISION Application Manager folder, there is a folder labeled
Search_Tools. This directory contains URLs, which when double-clicked or
dropped into TEDVISION will access Internet search tools. Simply double-click
on the tool of your choice, and TEDVISION will navigate to the site containing
that tool.

You can use online search tools to search for specific information on the
Internet. There are many different kinds of tools that allow you to take
advantage of the Internet. You can find categorical listings, subject headings,
exhaustive indexes, and many other databases to browse through.
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Using TEDVISION 3

This chapter describes how to use the features of TEDVISION. It will give you
detailed instructions on performing a variety of tasks. If you wish to get
started immediately, please see Chapter 2, “Getting Started with TEDvision”
for a short summary of the TEDVISION interface.

Opening Files

TEDVISION can access both Internet and local documents. There are a number
of ways to open documents including dragging certain file types and dropping
them into TEDVISION.

Getting to the Internet

All the information that is available from the Internet is organized by
addresses that are called uniform resource locators (URLs). Every site has a
unique address that distinguishes it from others. The address is contained in a
link that TEDVISION interprets in order to connect with the appropriate server.
If you know the URL, you can go to the location directly.

It usually takes this form:

protocol://machine.name[:port]/directory/filename

Note – URLs are case sensitive with respect to the directory and filename.

The protocol is the Internet protocol used to transmit the document. When
accessing a WWW server, the protocol is typically http, but other protocols are
supported (ftp, gopher, news, and file). The machine name is the domain name
of the server where the document is stored (such as www.company.com). The
port part of the address is only required when a non-standard TCP port
number is used.

You can save time downloading documents from the Internet by using a non-
graphical version of a document, if one is available.
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▼ To open a document on the Internet

♦ Do one of the following:

- In the URL field, type the URL of the document that you want to open
and press the Return key.

- Drag and drop a URL file from your desktop or another application (File
Manager, Mailer, and so on) to TEDVISION.

- Choose Open URL from the File menu, type the desired URL, and click
OK.

- Click the Open URL button on the tool bar, type the desired URL, and
click OK.

For more information on drag and drop behavior within TEDVISION please
see “To open documents by dragging them into TEDvision” on page 17.

Retrieving Local Documents From Your Computer

Local documents are loaded directly from your own computer or local
network. An example of a local document would be your own personal home
page or a text file on a server within your office.

▼ To open a local document

♦ Do one of the following:

- In the URL field, type the path to the document or directory that you
want to open, and press the Return key.

- Drag and drop a document or directory from your desktop or another
application (File Manager, Mailer, and so on) to TEDVISION.

- Choose Open Local from the File menu, type the path to the document or
directory that you want to open, and click OK.

For more information on drag-n-drop behavior within TEDVISION, please
see “To open documents by dragging them into TEDvision” on page 17.

Opening Newsgroups

Note – For configuration information, please see “To configure TEDvision to
access newsgroups” on page 52.

▼ To list the available newsgroups

1. Type news:* in the URL field, and press the Return key.

An alphabetical list of group names and brief descriptions is displayed.

2. Click a newsgroup name to open a list of articles in that newsgroup.
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▼ To access a particular newsgroup

1. Enter a news URL of the form news:newsgroup.

For example,

news:news.announce.newusers

When you first access a newsgroup, the subject lines of the first 20 articles
are listed. Articles are listed in the order that they appear on the server
rather than by topic threads.

2. Click a subject line to display the full article. If an article is related to other
messages, links to the related articles are included.

Note – Unlike other URLs, news URLs do not include slashes (//) after the
colon.

▼ To specify the range of articles to list

♦ Type the URL of the newsgroup followed by a slash and the range of
articles, specified by the article number.

For example,

news:news.answers/38179-38198

For more information about newsgroups, see:

http://www.cis.ohio-state.edu/text/faq/usenet/usenet/

what-is/part1/faq.html

Opening Files By Dragging and Dropping

▼ To open documents by dragging them into TEDVISION

TEDVISION lets you drag and drop documents into the browser and display
them. You may drag a URL file that will access the site specified by the URL.
You can also display local documents by dragging and dropping them into the
main window of TEDVISION.

1. Position the pointer over the desired object, such as an html document from
the File Manager.

2. Press and hold mouse button 1 or 2.
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3. Drag the document to the main window of TEDVISION and release the
mouse button as shown in Figure 3-1.

Figure 3-1 Dragging files into TEDVISION

HTML, URL, GIF, JPEG, and text files can be dropped and displayed in
TEDVISION without defining a helper application. However, if you are
dragging a file type that is different from these, then you will need to refer
to “Configuring Helper Applications” on page 31.

▼ To display the hyperlinked document in a new window

When you click on a hyperlink, the document normally replaces your currently
displayed document with the one you just selected. You may wish to open
another window to display the new document.

♦ Press the Shift key and click the link.

The document opens in a new browser window.

▼ To view the source in an HTML document

It is possible to view the HTML source used to create the currently displayed
document.

1. Choose View Source from the File menu.

The View Source window appears displaying the tags used in the current
HTML document.
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2. Click the Close button when you have viewed the material. The View Source
window is shown in Figure 3-2.

Figure 3-2 Viewing Source in HTML

Note – You may also copy the page to the Text Editor and manipulate the
document. Just select the text you want and drag it to the Editor.

▼ To stop a document from downloading

From time to time it may be necessary to stop a document from downloading.
For example, the server you are trying to access may be taking an excessive
amount of time with no apparent results, or perhaps you are trying to load an
extremely large graphic file that is slowing TEDVISION considerably.

♦ To interrupt or stop a document from downloading, do one of the following:

- Press the Esc key.

- Click the Stop button in the tool bar.

Searching a Document

You can use the Find command to search for a specific word or phrase in the
current document. This command does not let you search the Internet. Please
see “Searching the Internet” on page 13 for more information on search tools.
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▼ To search a document

♦ Do one of the following to open the Find Command dialog box:

- Click the Find button on the tool bar.

- Choose Find from the File menu.

A Find Command dialog box appears as shown in Figure 3-3.

Figure 3-3 Find Command Dialog Box

3. Type the word or phrase that you want to find in the Text to Find field.

4. To find text with specific capitalization, check Match Case.

5. To start searching from the top of the document, check Start From Top.

6. Click OK to start searching.

If the search is successful, the first occurrence of the word or phrase is
selected.

▼ To search for the same word or phrase again

♦ Do one of the following:

- Click the Find Again button on the tool bar.

- Choose Find Again from the File menu.

Getting Back To Where You’ve Been

There are several ways to reopen documents that you have previously viewed.
You can access both local and Internet documents by adding and then
retrieving them from your Hotlist or by retrieving them from your History list.

Using the History List

You can use the History list to open documents you have viewed during the
past 60 days. This will let you keep track of all the documents you visit as well
as display them again.
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▼ To open a document in the drop down History list

1. Click the drop down history button with mouse button 1.

The drop down History list window is shown in Figure 3-4.

Figure 3-4 The Drop Down History List

2. To revisit a given location, select the entry.

▼ To save the global history list as an HTML document

1. Choose History from the Navigate menu. The History list will appear as
shown in Figure 3-5.

Figure 3-5 The History List

History Button
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2. Click Export. The Export History window will appear as shown in
Figure 3-6.

Figure 3-6 History List Export

3. Enter the path where you want the document saved.

4. Type the filename you want and click OK.

Using the Hotlist Window

You can use the Hotlist window to save titles and URLs of frequently used
documents. The Hotlist window is shown in Figure 3-7.

Figure 3-7 The Hotlist Window

▼ To open a document in the hotlist

1. Choose Hotlist from the Navigate menu.
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2. Do one of the following:

- Double-click the document you want to open.

- Select the document and click Go To.

Note – The Hotlist window remains open until you close it.

▼ To add the current document to the hotlist

♦ Do one of the following:

- Choose Add Current to Hotlist from the Navigate menu.

- Click the Add Current to Hotlist button on the tool bar.

If the document you decide to add to the Hotlist is already present, an error
dialog box will appear informing you that a Hotlist item with the same URL
already exits.

▼ To delete a document from the hotlist

1. Choose Hotlist from the Navigate menu.

2. Select the document you want to delete and click Delete.

3. Click Close.

▼ To copy or edit an entry in the hotlist

1. Choose Hotlist from the Navigate menu.

2. Select the document you want to copy or edit and click Edit. The Edit
Hotlist Entry dialog box appears as shown in Figure 3-8.

Figure 3-8 Editing a Hotlist Entry

3. Type a different title or copy the URL if desired.

4. Click OK.

▼ To save the hotlist as an HTML document

1. Choose Hotlist from the Navigate menu.
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2. Click Export. The Export window is shown in Figure 3-9.

Figure 3-9 Saving a Document as an HTML

3. Choose a format from the menu pop-up list.

4. Enter the path where you want the document saved.

5. Type a filename (use a.htm or.html extension) and click OK.

▼ To import a hotlist

Importing a Hotlist can be useful for transferring a group of URLs from one
person to another. You can save time by sending Hotlists to each other rather
than each person having to manually enter URLs.

1. Choose Open Local from the File menu.
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The Open Local window will appear as shown in Figure 3-10.

Figure 3-10 Importing a Hotlist with the Open Local Dialog Box

2. Type or select the name of the Hotlist document you want to import and
click OK. The hotlist is displayed as an html document with a list of links.

3. Click a link you want to add to your Hotlist.

4. When the document is displayed, choose Add Current to Hotlist from the
Navigate menu.

5. Click the Back button to return to the list of links.

6. Repeat steps 3-5 for each link you want to add.

Returning Home

Using the Home Page

A home page is the document that is loaded when TEDVISION is started. You can
use the home page that came with TEDVISION or specify your own.

▼ To use a different home page

1. Choose Preferences from the Options menu.

2. Choose the Miscellaneous View.
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The Preferences window will appear as shown. The Home Page field is near
the top in Figure 3-11.

Figure 3-11 Preferences

3. In the Home Page field, type or paste the URL of the document you want to
use as your home page.

4. Click OK.

Note –  Since documents on your computer load faster than documents
from the network, using a local document as your home page is
recommended.

Saving Files

To save a document, simply drag the file from TEDVISION to the File Manager.
You can drag files to and from the File Manager, Print Manager, Text Editor,
Icon Editor, Trash Can, and so on. Just as in TED, not all file types will be
compatible with all applications. For instance, dragging a text file from
TEDVISION to Icon Editor would create an error dialog box and could invoke
the application.

URL and HTML documents may have several different components that make
up the display. For example, the TriTeal home page is comprised of
background text, hyperlinks, image maps, anchored images, and images. It will
be helpful to have a basic understanding of these components. They are as
follows:
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anchor This is a hyperlink that will access another web site if
you click it with mouse button 1.

image This is a picture that is not a link. That is, it does not
access another web site.

anchored image This is an image that functions in the same way an
anchor does. Clicking on it accesses another web site.

image map This is a clickable image or picture with “hot spots”
that act as hyperlinks to other web sites.

background text The background text is generally the text of a given
document or URL.

What happens when you drag and drop within TEDVISION will depend on the
type of file you drag and what its destination is.

▼ To save anchors as a URL file

1. Position the pointer over the desired object (hyperlink).

2. Press and hold mouse button 2.

3. Drag the document icon to the File Manager.

Note – If you release the mouse button while you are dragging, the
hyperlink will be invoked, and TEDVISION will display the web page
defined by the anchor.

▼ To save images that are not links from TEDVISION

1. Position the pointer over the desired object.

2. Press and hold mouse button 1 or 2.

3. Drag the image icon to the File Manager.

Note – When an image is dragged from TEDVISION to the desktop, it will
become a local file in a graphic format such as GIF, JPEG, XBM, or XPM.

▼ To save images that are links from TEDVISION

1. Position the pointer over the desired image (hyperlink).

2. Press and hold mouse button 2.

3. Drag the anchored image icon to the File Manager.

Note – If you release the mouse button while you are dragging, the
hyperlink will be invoked, and TEDVISION will display the web page
defined by the anchor.
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▼ To save an inline image

1. Press the Ctrl key and click the image with mouse buttons 1 and 3.

A new browser window will open, which contains only the image that has
been selected.

2. Choose Save As from the File menu.

3. Enter the path where you want the file saved.

4. Type a filename and click OK.

▼ To save an image map as a URL file

1. Position the pointer over the desired object.

2. Press and hold mouse button 2.

3. Drag the image icon to the File Manager.

▼ To save background text from TEDVISION

Do one of the following:

1. From the File menu, select the Save As... option.

2. Choose Plain Text from the Format for saved document pop-up list.

Or,

1. Position the pointer over the desired text.

2. Press and hold mouse button 1.

3. Drag the pointer to the end of the text selection you wish to include.

Note – TEDVISION has improved the way you select text in a browser view.
If you select text and drag to extend the selection, the document will
automatically scroll to let you extend the selection to the end of the
document.

4. Paste the selected text into the Text Editor or Mailer by pressing mouse
button 2.

▼ To save a hyperlinked document

You may wish to save an HTML document that a link will take you to without
actually visiting the link by doing the following:

1. Press the Ctrl key and click the link with mouse button 1.
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The Unhandled File Type dialog box appears as shown in Figure 3-12.

Figure 3-12 Unhandled File Type Dialog Box

2. Click the Save As button.

The Save As window will open which prompts you for a file name and
format to save the file in, as shown in Figure 3-13.

Figure 3-13 The Save As Window

3. Enter a name for the file.

4. Choose the format you wish to save the file in from the Format for saved
document pop-up list.

5. Click OK.

Printing Files

TEDVISION lets you print documents directly to your printer, or save them to a
file, then print them. You may print images, text files, HTML documents, and
so on. For more information on saving files please see “Saving Files” on
page 26.

Before you print a document TEDVISION will reformat the document to fit
within the currently defined paper size. You can change the paper size and
other settings in the Print Setup dialog box.



30 TEDVISION User’s Guide

3

▼ To select printer options

1. Choose Print Setup from the File menu. The Print Setup window is shown
in Figure 3-14.

Figure 3-14 Print Setup

2. Choose a paper size.

3. Set page margins.

4. Optional. Press the Save button to make the settings you have specified the
default settings for Print Setup.

5. Click OK.

▼ To print a document

♦ Do one of the following:

- Choose Print from the File menu.

- Drag the document from TEDVISION to the Print Manager or a printer
icon in the Personal Printers subpanel.
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This chapter describes how to configure helper applications to handle file types
that TEDVISION is not familiar with, such as audio or movie files. When you set
up a helper application, TEDVISION will automatically invoke it when the file
type is recognized.

Configuring Helper Applications

By default, the file types supported by TEDVISION include URL, HTML, text
files, JPEG and GIF images, and AU and AIFF sound files, as well as all CDE
file types. You can add support for other types of files by configuring a helper
application. Any program that accepts command line instructions can be used
as a helper application.

Some examples of using helper applications are:

• Invoking a PostScript viewer when you access a PostScript file.

• Launching a movie viewer to display MPEG files you download from the
internet.

• Starting the sound tool for your system when an audio file is loaded
through TEDVISION.
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The Helpers screen is displayed below in Figure 4-1.

Figure 4-1 Helpers Screen

▼ To configure a helper application

1. Choose Helpers from the Options menu.

2. Do one of the following:

- If the file type you want to support is listed, select it and click Edit.
Verify that all the information for this helper is correct or make changes
as needed. For more information on configuring helpers, see Step 3.

- Click Add to define a new file type.

The Configure File Type dialog box appears, as shown in Figure 4-2.

Figure 4-2 Adding Helpers

3. In the Configure File Type dialog box, enter information in the following
fields:

Description Type a descriptive name for the file type.

MIME Type Type the MIME type of the file type. For more
information on MIME types, please see “Sending
Multimedia Files Over the Network” on page 33.
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Suffixes Type each filename suffix (or extension) associated
with the file type. Begin each suffix with a period.
Separate multiple suffixes by a space.

Encoding Select the Binary or Text option to indicate how the file
type is encoded. Most file types are binary.

How to Handle Choose how you want to handle files of the type you
are configuring.

The options are:
• Use Mosaic as Viewer
• Use an SDI-Enabled Helper
• Save as a File
• Save and use a Helper

Helper Application Type the full path and name of the helper application,
followed by %s where the name of a downloaded file
should be inserted. Click Browse to locate the helper
application in your directory structure.

4. Click OK.

Note – For most predefined file types, the Helper Application field is the
only field you need to complete. Default values are provided for the other
fields.

Sending Multimedia Files Over the Network

MIME, or Multi-purpose Internet Mail Extensions, is a protocol for sending
multimedia file types sent over the network.

MIME types are attached to files downloaded from HTTP servers, or WWW
servers. TEDVISION uses the MIME type to determine a file type. After
determining the file type, TEDVISION knows to either handle the file internally
or to send it to a helper application.

Note – TEDVISION uses filename extensions (suffixes) to identify files from non-
HTTP servers, which do not use MIME types.

If TEDVISION cannot handle a file type and an appropriate helper application is
not available, it displays the Unhandled File Type dialog box. This dialog box,
shown in Figure 4-3, lets you either save the file, configure a helper application
to view the file, or cancel the file transfer.

Figure 4-3 Unhandled File Type Dialog Box
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For each file type you want to configure, you need to specify a MIME type in
the Configure File Type dialog box. A MIME type consist of two parts; a type
and a subtype, separated by a slash (/). For example, the MIME type for JPEG
files is “image/jpeg.”

For most file types, you can use an existing MIME type, as described below.
However, you may have to define your own MIME type, which is also
described below.

▼ To specify a MIME type

1. Open the list of registered MIME types by choosing Helpers from the
Options menu.

The Helpers Window appears as shown below in Figure 4-4.

Figure 4-4 Helper Applications

2. Choose the MIME type that best describes your file type.

3. If none of the registered MIME types describe your file type, define your
own MIME type/subtype by clicking the Add... button.

For the type part of the MIME type, shown in Figure 4-2, use one of the
following types:

- text
- multipart
- message
- application
- image
- audio
- video

     If none of these types describe the file type, use the application type.
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4. Use your own description for the subtype. You may want to distinguish
your subtype from registered subtypes, type x- before the subtype.

For example,

application/x-acad

5. When you have defined the MIME type, click OK.

6. Click Close.

Viewing Images

TEDVISION can display GIF, JPEG, XPM, and XBM images. You can display
other image types by configuring a helper application.

▼ To display a GIF or JPEG image

♦ Do one of the following:

- Drag the file (URL, JPEG, or GIF) to TEDVISION.

- Enter the URL of an image file into the URL field.

- In a file window, choose Open Local from the File menu. Then type or
select the filename of the image file.

Note –  You can add the URL of an image to the Hotlist by choosing Add
Current to Hotlist from the Navigate menu.
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▼ To close an image window

♦ Do one of the following:

- Choose Close from the File menu.

- Choose Exit from the File menu, which closes all windows and quits the
TEDVISION program.

- If you become lost and want to return to a familiar starting point, choose
Home from the Navigate menu or click the Home button in the tool bar.

Playing Sounds

TEDVISION can play AU and AIFF sound files. You can play other sound
formats by configuring a helper application to work with the sound devices
currently on your system.

▼ To play an AU or AIFF sound file

♦ Do one of the following:

- Drag a sound file to the TEDVISION window.

- Click or enter the URL of a sound file.

- In a file window, choose Open Local from the File menu. Then type or
select the name of the sound file.

Note – You can add the URL of a sound file to the Hotlist by choosing Add
Current to Hotlist from the Navigate menu.
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This chapter describes the order of precedence of TEDVISION’s settings, the
TEDvision’s Command Line Options and Resources, as well as an overview of
available preferences. In choosing where to specify preferences, you should
consider what preferences you want to use and whether you want them to
occur every time TEDVISION is started or on an “as needed” basis only.

Many of the different preferences settings can be specified in two or more
locations. For parameters that can be set in multiple places, the following order
of precedence applies:
• Command line options override all other settings.
• Preference dialog settings override X resource variables.
• Resource variables.

Command Line Options

You can start TEDVISION from the command line by changing directory to
/usr/dt/bin and executing tedvision.

The following command line options can be used when starting TEDVISION

from the Command Line:

-colors number Sets number to the minimum number of colors
allowed before automatically creating a private
colormap for use with TEDVISION. The colors are
typically allocated from the default system
colormap, unless the Use Default Colormap
preference setting is disabled, or the -private
option was used.

-default Uses the default colormap unless the situation above
exists.

-delayImages Withholds any images loads until specified.

-diskCacheDir Uses the disk cache (this is a default setting).

-documentCacheSize Controls memory cache for documents.

-home filename Specifies a file to be the home file. When you press
the Home button it will load the file specified as
filename.
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-imageCacheSize Controls memory cache size for images.

-ngh Specifies the use of global history (this is a default
setting).

-private Creates a private colormap.

-sdi Activates the SDI port.

-tmpdir Specifies a temporary directory (the default is set to
$HOME/.dt/tmp). You would change the directory
if the file system containing /tmp has limited or no
space.

-verbose Displays warning messages on the display in
addition to the support log dialog.

-8 Uses 8-bit color if available.

-24 Uses 24-bit color if available.

Setting Preferences

TEDVISION lets you make instant changes to preferences settings with the
Preferences Window. From the Preferences Window you can access settings for
the following:
• Display
• Fonts
• Colors
• Cache
• Proxies

Changing Display Options for Images

You can improve the performance of TEDVISION by making changes to the way
images are displayed in TEDVISION. Images may be dithered, loaded
simultaneously, or not loaded at all.

▼ To specify how images are displayed

The Display View of the Preferences panel lets you choose how your images
are displayed:

1. Choose Preferences from the Options menu.
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2. Choose the Display View shown in Figure 5-1.

Figure 5-1 Display Preferences

3. Do one of the following:

- Select Reformat Once After All Images if you want the images displayed
at the same time after they are all loaded into memory.

- Select Reformat After Each Image if you want the images displayed as
soon as each is loaded into memory.

4. Select Display Images Progressively to display partial images as they are
loaded into memory.

▼ To dither images

1. Choose Preferences from the Options menu.

2. Choose the Display View.

3. Select the Dither Images option.

On display monitors with 256 or fewer colors, this option will improve
image coloring, but may cause the application to slow down as well as add
a grainy texture to images.

4. Select the Use Private Colormap option.

A private colormap will be created the next time you start TEDVISION.

5. Click OK.
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▼ To load documents without images

1. Choose Preferences from the Options menu.

2. Choose the Display View.

3. Deselect the Load Images Automatically check box.

4. Click OK.

▼ To load a single image

1. Press and hold mouse button 1 with the pointer over the “missing image”
box.

2. Click mouse button 3 while still holding mouse button 1.

Figure 5-2 shows a missing image box before and after loading the graphic.

Figure 5-2 Loading a Single Image

▼ To load all images

♦ From the View menu, choose Load Missing Images, or click the Load
Missing Images button on the tool bar.

It is possible to load all the images in a file at the same time. Please see “To
load multiple images in an HTML file simultaneously” on page 47 for more
information.

Missing Image Box
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Changing Fonts

▼ To change font sizes

1. Choose Preferences from the Options menu.

2. Choose the Fonts View shown in Figure 5-3.

Figure 5-3 Font Preferences

3. Make choices from the following pop-up lists:

- Display Font Size

- Normal Text Font

- Header Font

- Monospace Text Font

4. Click OK.
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Changing Colors

▼ To change display colors

1. Choose Preferences from the Options menu.

2. Choose the Colors View as shown in Figure 5-4.

Figure 5-4 Colors Preferences

3. Click the Set button to specify the color of the following elements:

- Text Color is the color of normal text.

- Background Color is the color of background in file windows.

- Link Color is the color of links.

- Visited Link Color is the color of links that have been selected recently.

4. Move the sliders for the Red, Green, and Blue values.
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The new color will be displayed in the top half of the rectangle to the right
of the sliders while the original color is displayed in the bottom half of the
rectangle as shown in Figure 5-5.

Figure 5-5 Colors Preferences: Text Color Window

5. Click OK.

▼ To ignore color attributes specified in files

If colors are specified in the <BODY> tag of the HTML files you display, you
can choose to ignore those colors and use the colors you choose in the Colors
View instead.

1. Choose Preferences from the Options menu.

2. Choose the Colors View.

3. Select the Ignore Document Attributes option.

4. Click OK.

Any colors specified in the <BODY> tag will be ignored, and colors you
specify in the Colors View will be used instead.

Working with Your TEDVISION Cache

The Preferences panel has a Cache View that lets you make changes to your
cache, which may make your TEDVISION session run more smoothly. You can
do the following:
• Specify the location of your cache
• Determine and set the size of the cache
• Empty the cache, or choose flush cache on exit
• Specify how often to verify the cache
• Determine and set the size of the cache

▼ To adjust the disk cache size

1. Choose Preferences from the Options menu.

2. Choose the Cache View.
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Figure 5-6 Cache Preferences

3. Enter the cache size (in kilobytes) into the text field.

For example, you would enter 2000 if you wanted the cache size to be 2 MB.

4. Click OK.

▼ To access other cache options

1. Choose Preferences from the Options menu.

2. Choose the Cache View.

3. Do any of the following:

- To specify your cache directory, type the path in the Cache Directory field
or click Browse to locate the directory.

- To empty your cache, click the Flush Cache button, or check Flush Cache
on Exit to empty the cache each time you exit TEDVISION.

- To specify how often to verify your cache, choose an option from the
Verify Cache pop-up menu.

4. Click OK.
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Using Proxy Servers

Many organizations use a firewall to protect their internal network from
external access. A proxy server is a program, typically running on a firewall
machine, which can be configured to block external access, while permitting
users behind a firewall to access Internet resources. You can specify a different
proxy server for HTTP, gopher, and FTP protocols.

▼ To access proxy information

1. Choose Preferences from the Options menu.

2. Choose the Proxies View as shown in Figure 5-7.

Figure 5-7 Proxies Preferences

Please see “Setting Up Proxies” on page 51 of Chapter 6, “System
Administration” for information on configuring your system to use proxies.

Miscellaneous Preference Settings

For email and news server configuration information please see Chapter 6,
“System Administration.”

▼ To specify the preferred language for files

1. Choose Preferences from the Options menu.
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2. Choose the Miscellaneous View as shown in Figure 5-8.

Figure 5-8 Miscellaneous Preferences

3. Open the Preferred Language menu and choose the language that you
prefer for displaying files.

If you request a file that is available in multiple languages, TEDVISION will
open the file in the language that you prefer, if a version in that language is
available.

This setting only affects the language used to display files, not the
appearance of TEDVISION.

4. Click OK.

▼ To show server messages

If you wish to see messages related to the server you are contacting to access a
particular file, you may display server messages by doing the following:

1. Choose Preferences from the Options menu.

2. Choose the Miscellaneous View.

3. Check the Show Server Messages check box.

4. Click OK.

▼ To underline hypertext links

1. Choose Preferences from the Options menu.
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2. Choose the Miscellaneous View.

3. Select the Underline Links option.

4. Click OK.

▼ To load multiple images in an HTML file simultaneously

1. Choose Preferences from the Options menu.

2. Choose the Miscellaneous View.

3. Check the Use Multiple Connections check box.

4. Click OK.

TEDVISION Resources

This section provides a list of resources in the TEDVISION application. They can
be found in the /usr/dt/app-defaults/C/TEDvision file.

Warning – Any resource customizations should be done in the /etc/dt/
directory. Copy the TEDvision file to the /etc/dt/app-defaults/C
directory. You may need to create this directory if it does not already exist.

*useDynamicColors Setting the useDynamicColors resource to true
uses dynamic colors in the view document area,
otherwise the following colors are used:
*windowBackgroundColor,
*windowForegroundColor, *anchorColor,
*visitedAnchorColor, *activeAnchorColor.

*homeDocument Set the homeDocument resource for a default home
page (default: commented out).

*diskCacheDirectory When changing the Disk Cache directory resource,
make sure the directory has 777 (rwxrwxrwx)
permissions. This is a global cache directory.

*ditherColors Set the ditherColors resource to false for faster
image displaying.

*delayImageLoads Set the delayImageLoads to true to disable
loading images automatically.

*historyExpireDays Set the historyExpireDays resource to the
number of days TEDVISION lets you know that you
visited a URL.

*documentCacheSize Set the documentCacheSize resource to the
number of documents you want to cache in memory.

*imageCacheSize Set the imageCacheSize resource to the number of
images you want to cache in memory.

*useDiskCache Set the useDiskCache resource to false if you do
not want to cache documents on the local file system.



48 TEDVISION User’s Guide

5

*verifyImages Set the verifyImages resource to once, never, or
always. This resource determines how often the
images in the disk cache are checked against the
images from the WWW server.

*rloginAction If you want to use xterm instead of dtterm, set the
rloginAction to XtermRloginHost.

*telnetAction Tells what terminal emulator to use when running
the telnetCmd program. The default action is
DttermTelnetHost, which uses dtterm as the
terminal emulator to run the telnetCmd program. If
you want to use xterm instead of dtterm, set the
telnetAction to XtermTelnetHost.

*rloginCmd You may have to change this to a different program
that is SOCKS-enabled to access sites outside a
firewall. The browser uses this resource when
invoking the TED actions in the telnetAction.

*telnetCmd The default for telnetCmd is telnet. You may
have to change this to a different program like
rtelnet that is SOCKS-enabled to access sites
outside a firewall. The browser uses these resources
when invoking the TED actions in telnetAction.
Tells what program to use when contacting the
remote host.

*globalExtensionMap Defines the file types that are used. They can be
found in the following location:
/usr/dt/appconfig/appmanager/C/

TEDvision/mime.types

*globalTypeMap Defines the actions assigned to the file types that are
used. They can be found in the following location:
/usr/dt/appconfig/appmanager/C/

TEDvision/mailcap

*colorLimit Set the colorLimit resource to the number of color
cells in the standard colormap you want to be
available to other applications after TEDVISION

allocates its color cells.

*tmpDirectory Change and uncomment this resource to set the
directory where files are stored temporarily.
TEDVISION defaults this resource to
$HOME/.dt/tmp (default: commented out).

Network resources

*SOCKS_SERVER Change and uncomment this resource to set the
SOCKS server (default: commented out).

*httpProx Change and uncomment this resource to set the
HTTP proxy (default: commented out).

*newsProxy Change and uncomment this resource to set the
NEWS server. TEDVISION defaults this resource to
the environment variable NNTPSERVER (default:
commented out).
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*proxyOverrides Change and uncomment this resource to set which
addresses you don’t want the proxy server to service
(default: commented out).

*networkTimeout Set the networkTimeout resource to the allowed
number of seconds of inactivity when accessing the
network, except for running CGI scripts.

Security Modules

Security modules are third-party programs that allow TEDVISION to
communicate with secure servers using various security protocols.

When TEDVISION accesses a secure server, it activates the security module
required by that server.

▼ To list the security modules for TEDVISION

1. From the Options menu, choose Security.

2. Choose from the modules listed below:

Digest Authentication Uses MD5-encrypted passwords for authorization to
receive an HTTP reply.

Basic Authentication A basic, non-secure protocol supported by nearly all
WWW servers. A user name and password are sent
to the server in UUENCODED form. This method
can be used to limit access to a server.
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System Administration 6

This chapter deals with system configuration and advanced customization
including proxy servers, news groups, and email servers. You will also find a
section for troubleshooting problems.

Advanced Configuration

Installation Issues

System administrator’s need to make sure of the following when installing
TEDVISION:

• A file called resolv.conf must exist in the /etc directory. It should have
the following lines:

domain name <your domain name>

servername <IP address of your server>

• The DNS server must be operating on your machine.

Setting Up Proxies

▼ To setup proxy servers

1. Choose Preferences from the Options menu.

2. Choose the Proxies View as shown in Figure 6-1.
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Figure 6-1 Proxies Preference: Setting Proxy Servers

3. For each Proxy field, type the host name (or IP address) and port number of
the proxy server.

4. Click OK.

▼ To bypass proxy servers

1. Choose Preferences from the Options menu.

2. Choose the Proxies View.

3. In the Bypass Proxy On field, specify the IP addresses, domain names, and
ports that should be accessed directly without using a proxy server. Separate
entries with commas.

This field is ignored if no proxy server is specified in the Proxy Server field.

4. Click OK.

Setting Up Newsgroups

If you subscribe to a news service, you can use TEDVISION to read Usenet
newsgroups. To post articles to newsgroups, you’ll need a dedicated news
program.

▼ To configure TEDVISION to access newsgroups

1. Choose Preferences from the Options menu.
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2. Choose the Miscellaneous View, as shown in Figure 6-2.

Figure 6-2 Miscellaneous Preferences: Accessing A Newsgroup

3. In the News Server field, type the domain name or IP address of your news
provider.

4. Click OK.

Using Email

▼ To configure your email server

1. Choose Preferences from the Options menu.

2. Choose the Miscellaneous View, as shown in Figure 6-2.

3. In the Email Server field, type the domain name or IP address of your email
server.

4. Click OK.
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Troubleshooting

Common Problems

Why does TEDVISION get a “connection refused” message when I try to

access the World Wide Web?

Solution: This message occurs when a user has set the socks server in the
TEDVISION preferences but has not set the SOCKS_SERVER
environment variable. After the variable is set, the message should
cease.

Why is TEDVISION exiting when I try to bring it up?

Solution 1: It may be that something in your TEDVISION directory has become
corrupt. Try moving or deleting your TEDVISION directory and then
launch TEDVISION again. This may clear up the problem.

If you want to save your hotlist and global history list, you will need
to move these files out of your TEDVISION directory before you delete
it. Move them back into the new TEDVISION directory that is created.
If TEDVISION still won’t launch correctly, it may be that one of these
files is corrupt.

Solution 2: This problem can sometimes be fixed by removing the tedvision_cache
directories from /var/dt and $HOME/TEDvision.

I get one of the following errors: “No network support is available,” “Could

not initialize the network,” or “Cannot resolve host name.” Why?

Solution: These error messages indicate a problem with the network or TCP/IP
software. Try the following tests:

• Do other TCP/IP applications, such as email and FTP, work
correctly?

• If you are not behind a firewall, can you ping a server?

• If a URL works after replacing the domain name of the server with
the server’s IP address, your DNS (domain name system) server may
be broken.

• Is the proxy server set up correctly?

Whenever I click on a link I get “Attempt to load... failed” or “Failed to

connect: timeout.” However, when I type the URL explicitly I can move

about with no problems. Why?

Solution: This is caused by an incorrect baud setting for your modem (usually
too high). Check that the baud rate on your modem is set to the
manufacturer’s specification.
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I am using a modem and get timeout errors when downloading large files.

Why?

Solution: Increase the timeout settings in your TCP/IP software.

Error Messages

General Errors

The program was unable to <X> because the system is running low on

memory.

Solution: Your system does not have enough memory to start another operation.
Close unused applications or install additional memory.

The program couldn’t create the external viewer file <filename>. The disk

may be full.

Solution: Check for free disk space. About 10 MB of disk space should be free
before starting TEDVISION.

The program couldn’t save the file <filename>. The disk may be full.

Solution: Check for free disk space. About 10 MB of disk space should be free
before starting TEDVISION.

Out of memory: <X>

Solution: Your system does not have enough memory to continue. Close unused
applications or install additional memory.

Initialization Errors

The program could not initialize the network.

Solution: Make sure your network connection is configured correctly. You can
still view local files.

TEDVISION does not recognize your network connection.

Solution: Ask your system administrator to verify that the connection is
configured properly.

Some of your preferences were invalid or corrupted.

Solution: You may need to set them again. Your preference settings can become
corrupted if TEDVISION unexpectedly exits while preferences are
being edited.
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Networking Errors

The program could not find an address for the system <address>.

Solution: You tried to access a server that does not exist at the specified URL.
Confirm that the URL is correct.

The system that looks up network addresses for you didn’t reply to the

program’s request within the allotted time.

Solution: The system that provides domain name system (DNS) services is not
working. Or, the address of the system to which you are connecting
was not found within the allotted time. Try again after a few minutes.
If this error still occurs, your system administrator may need to fix the
system that handles DNS.

Your system is not properly configured to look up network addresses.

Solution: Something is wrong with the network setup for the specific platform.

The network connection that was being used closed unexpectedly.

Solution: A connection to another system was disconnected without being
properly closed. No action is required.

The server that was providing information didn’t send its data within the

allotted time.

Solution: The network or server is overloaded. Try again after a few minutes.

The system could not successfully connect to a server.

Solution: The server you tried to access is not working or the wrong port was
specified. This error can also be caused if the network is overloaded. Try
again after a few minutes.

The program could not successfully send a request for data to a server.

Solution: This is a network or server timeout error, which is different from a
“Cannot connect” error. TEDVISION can connect to the URL, but
either your local server or the remote server did not reply to the request
for data. Try again after a few minutes.

All of the available network connections from this system were in use.

Solution: TEDVISION tried to open more network connections than the
operating system allows to be open simultaneously. Close other
applications using a network connection.

A network connection did not close down properly.

Solution: No action is required.
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News Errors

This program is not configured to read news.

Solution: You tried to access a newsgroup, but a news server is not configured.

You are not allowed to access the news server at <news server name> from

your machine.

Solution: Your machine is not recognized as a subscriber by the news server you
tried to access. Contact your news server administrator to subscribe
your machine.

Your news server doesn’t carry that group.

Solution: The news server to which you subscribe does not offer the newsgroup
you requested. Type news:* to list the available newsgroups.

The selected range of articles was invalid.

Solution: There are no articles in the range you specified. Retype the URL
without specifying a range to determine the number of articles in the
newsgroup.

There are no articles in the group <newsgroup>.

Solution: Currently, there are no articles in the newsgroup.

Your news server doesn’t support the XHDR command.

Solution: Some older news servers do not support the XHDR command, which
is widely used to access newsgroups. If this error occurs, upgrade to a
newer news server.

Loading Errors

The attempt to load <URL> failed or was cancelled.

Solution: This problem has several potential causes. Try the following tests to
help isolate the problem:

• Do any other URLs work?

• Can you access the URL after waiting a few minutes?

• If you are not behind a firewall, can you ping a server?

• Do other TCP/IP applications, such as email and FTP, work
correctly?

• If you are going through a firewall, is your proxy server configured?

• Is the URL entered correctly; with no proceeding spaces?
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The picture <filename> did not load properly.

Solution: The server was unable to send information requested by TEDVISION,
or the network is overloaded. Choose Reload from the View menu to
load the file again. If the problem occurs again, wait a few minutes,
then try again.

No URL was specified.

Solution: This error occurs if you choose Open URL from the File menu and
click OK without typing a URL.

Clicking on this picture does different things depending on where you click.

You must first load the image by clicking on it with the right mouse button.

Solution: This error occurs if you single click an unloaded image map. Click the
icon with the right mouse button to load it. Then click on the image.

The program tried to load data that was in an unexpected format, or which

had a filename that implied a different format. The program thought the file

had format <name of format> and needed to convert it to format <name of

format>.

Solution: TEDVISION tried to load in an inline image but received an
unexpected format, such as a text/html document. The HTTP server
returned the wrong MIME type because it was set up incorrectly or
uses a nonstandard filename extension. Check to see that your helper
application is properly configured.

HTTP Response Errors

The server sent a message which the program couldn’t understand, so

<URL> didn’t load.

Solution: TEDVISION received an HTTP response code from a server that it did
not recognize, possibly because the response was garbage.

The authorization you sent for <X> wasn’t valid.

Solution: The user name or password entered was not recognized.

The server considered the request for <URL> an invalid request.

Solution: TEDVISION sent a request that was not recognized by a server.

You must pay to access <URL>.

Solution: You tried to access a resource that requires payment or uses a payment
scheme that is not recognized by TEDVISION.
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You are not allowed to access <URL>.

Solution: The file you requested requires special permissions to access. For
example, some documents are only available to computers in a specific
domain.

The server couldn’t find <URL>.

Solution: The file you requested no longer exists or was moved.

The link <URL> doesn’t go anywhere.

Solution: You clicked on an image map in an area that is not associated with a
URL. Click on a different region of the image.

The server had an internal problem and couldn’t send <URL>.

Solution: The file you requested could not be sent because the server had an
internal problem, such as insufficient memory or an error reading the
file.

Errors for non-HTTP Protocols

This FTP server does not support passive mode.

Solution: You tried to access an FTP server that still requires active connections,
which TEDVISION does not support. TEDVISION connects to FTP
servers using a passive connection. During a passive connection, you
are only connected long enough to perform a command (such as
getting file or listing a directory) and are disconnected between
commands. Passive connections allow more users to access a server at
the same time than active connections, which remain connected to the
FTP server during the entire session.

URL could not be found.

Solution: The file you requested no longer exists or was moved without notice.

This program doesn’t support the protocol for accessing <URL>.

Solution: The URL you tried to open uses a protocol that is not supported by
TEDVISION or the URL was entered incorrectly. Check that the URL
does not begin with a space, which may have been added if you cut and
pasted the URL. If a proxy server is being used, check that it is
configured correctly.

The mailto and telnet protocols are not supported by TEDVISION. In these

cases, you must use an email and telnet program separately from TEDVISION.

Solution: This link requires a telnet program. To follow this link, run your telnet
program, and connect to <address>.
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The server you tried to contact requires a security protocol that is not

supported by TEDVISION.

Solution: You must have a security module installed that has the correct protocol
for the server you are trying to connect to.

Miscellaneous Errors

The text <word or phrase> was not found.

Solution: When using the Find command, the text you specified does not exist
in the document. Turn off Match Case, if it was checked, and check the
Start from Top option. Then try again.

There was an error launching the external viewer for the file <filename>.

Solution: TEDVISION tried to launch a helper application (or viewer), but there
was not enough memory or the program was not in the specified path.

There is already a hotlist item with this title.

Solution: Each file in the hotlist must have a unique title; you cannot add a file
if it is already in the hotlist.

The program couldn’t process an external request because it was working on

something else.

Solution: TEDVISION cannot do multiple tasks simultaneously. For example,
this error occurs if you are downloading a document and another
application requests TEDVISION to download a file at the same time.

Sound Errors

There is no sound device in the system.

Solution: The appropriate sound hardware and device driver must be installed
in your system.

There is not enough memory to play the sound.

Solution: Large sound files may require more memory than is available to play
them. Save the sound file on your disk until more memory is available.

This sound file is corrupt or has unrecognized format.

Solution: The sound file cannot be played because it is damaged.

The sound device is currently busy.

Solution: The sound device is being used by another application. Either
interrupt the other application or wait until the other application is
done.
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