HexView Help Index

HexView is a Freeware application Copyright 1996 Funduc Software Inc. Please distribute freely. It
allows View, Print and Print Preview of any file formatted as a Hex Dump. To download the source code
and other useful utilities (including Search and Replace for Windows 95/NT), visit
http://home.sprynet.com/sprynet/funduc or http://ourworld.compuserve.com/homepages/funduc.

Commands
File menu
View menu
Window menu

Help menu



File menu commands

The File menu offers the following commands:

Open Opens an existing document.

Close Closes an opened document.

Print Prints a document.

Print Displays the document on the screen as it would appear printed.
Preview

Print Setup Selects a printer and printer connection.

m

Xit Exits HexView.






View menu commands
The View menu offers the following commands:
Toolbar Shows or hides the toolbar.
Status Bar  Shows or hides the status bar.
Previous Displays the previous block in the current file.

Block
Next Block Displays the next block in the current file.

Go To Block Allows you to display the contents of a file at a specific
location(offset).

Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple
views of multiple documents in the application window:

New Window Creates a new window that views the same document.

Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.

Split Split the active window into panes.

Window 1 Goes to specified window.

2, ...



Help menu commands

The Help menu offers the following commands, which provide you assistance with this
application:

Help Offers you an index to topics on which you can get help.

Topics
About Displays the version number of this application.



Open command (File menu)

Use this command to open an existing document in a new window. You can open multiple
documents at once. Use the Window menu to switch among the multiple open documents.
See Window 1, 2, ... command.

You can create new documents with the New command.

Shortcuts

Toolbar:

Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:

File Name
Type or select the filename you want to open. This box lists files with the extension you
select in the List Files of Type box.

List Files of Type

Select the type of file you want to open:

All Files (*.*)
Drives

Select the drive in which HexView stores the file that you want to open.
Directories

Select the directory in which HexView stores the file that you want to open.
Network...

Choose this button to connect to a network location, assigning it a new drive letter.



Close command (File menu)

Use this command to close all windows containing the active document.

You can also close a document by using the Close icon on the document's window, as shown
below:




The toolbar is displayed across the top of the application window, below the menu bar. The
toolbar provides quick mouse access to many tools used in HexView,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).
Click To

Open an existing document. HexView displays the Open dialog box, in which you
can locate and open the desired file.

Print the active document.

Go to the previous block in the current file.

E. Go to the next record in the current file.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be
executed by the selected menu item or depressed toolbar button, and keyboard latch state.
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

caP

The status bar is displayed at the bottom of the HexView window. To display or hide the
status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to
navigate through menus. This area similarly shows messages that describe the actions of
toolbar buttons as you depress them, before releasing them. If after viewing the description
of the toolbar button command you wish not to execute the command, then release the
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.

SCRL The Scroll Lock key is latched down.



Previous Block command (View menu)

Use this command to display the Previous Block of the current file.



Next Block command (View menu)

Use this command to display the Next Block of the current file.



Go To Block command (View menu)

Use this command to Go to a specific offset in the current file. The Go To Dialog will be
displayed.



New command (Window menu)

Use this command to open a new window with the same contents as the active window. You
can open multiple document windows to display different parts or views of a document at
the same time. If you change the contents in one window, all other windows containing the
same document reflect those changes. When you open a new window, it becomes the
active window and is displayed on top of all other open windows.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion.



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped
fashion.



Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.



Window Arrange lcons Command

Use this command to arrange the icons for minimized windows at the bottom of the main
window. If there is an open document window at the bottom of the main window, then
some or all of the icons may not be visible because they will be underneath this document
window.



Split Command (Window menu)

Use this command to split the active window into panes. You may then use the mouse or
the keyboard arrows to move the splitter bars. When you are finished, press the mouse
button or enter to leave the splitter bars in their new location. Pressing escape keeps the
splitter bars in their original location.



1, 2, ... command (Window menu)

HexView displays a list of currently open document windows at the bottom of the Window
menu. A check mark appears in front of the document name of the active window. Choose
a document from this list to make its window active.



Index command (Help menu)

Use this command to display the opening screen of Help. From the opening screen, you can
jump to step-by-step instructions for using HexView and various types of reference
information.

Once you open Help, you can click the Contents button whenever you want to return to the
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

HexView is a Freeware application Copyright 1996 Funduc Software Inc. Please distribute freely. It
allows View, Print and Print Preview of any file formatted as a Hex Dump. To download the source code
and other useful utilities (including Search and Replace for Windows 95/NT), visit
http://home.sprynet.com/sprynet/funduc or http://ourworld.compuserve.com/homepages/funduc.



Context Help command

Use the Context Help command to obtain help on some portion of HexView. When you
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and
question mark. Then click somewhere in the HexView window, such as another Toolbar
button. The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window. It contains the name of the application
and document.

To move the window, drag the title bar. Note: You can also move dialog boxes by dragging
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button

Minimize button

Name of the application

Name of the document

e

Restore button



Scroll bars

Displayed at the right and bottom edges of the document window. The scroll boxes inside
the scroll bars indicate your vertical and horizontal location in the document. You can use
the mouse to scroll to other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

<

After the pointer changes to the four-headed arrow:

1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer
to the border you want to move.

2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note: This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or
dialog box with the arrow keys.

<

Note: This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)
Use this command to reduce the HexView window to an icon.

Shortcut

Mouse: Click the minimize icon E on the title bar.
Keys: ALT+F9



Maximize command (System menu)
Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon E on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window. HexView determines
which window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window. HexView determines
which window is previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)
Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note: If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time. You can close all windows at
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window
ALT+F4 closes the Hex View window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications. Use this "Task List" to switch to
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the
following options:
Task List
Select the application you want to switch to or close.
Switch To
Makes the selected application active.
End Task
Closes the selected application.

Cancel
Closes the Task List box.

Cascade
Arranges open applications so they overlap and you can see each title bar. This option
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap. This option does not
affect applications reduced to icons.

Arrange lcons
Arranges the icons of all minimized applications across the bottom of the screen.



Go To Dialog

This dialog allows you to display the contents of a file at a specific location (offset) in the file.
You can enter the offset in decimal, hexadecimal(0OXnnnn) or octal (starts with 0 ie. 047540)
format.
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Print command (File menu)

Use this command to print a document. This command presents a Print dialog box, where
you may specify the range of pages to be printed, the number of copies, the destination
printer, and other printer setup options.

Shortcuts

Toolbar:

Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:

Printer
This is the active printer and printer connection. Choose the Setup option to change the
printer and printer connection.

Setu

Digplays a Print Setup dialog box, so you can select a printer and printer connection.
Print Range

Specify the pages you want to print:

All Prints the entire document.

Selectio  Prints the currently selected text.

n

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.

Collate Copies
Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality
Select the quality of the printing. Generally, lower quality printing takes less time to
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that <<YourApp>> is sending output to the
printer. The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed. When
you choose this command, the main window will be replaced with a print preview window in
which one or two pages will be displayed in their printed format. The print preview toolbar
offers you options to view either one or two pages at a time; move back and forth through
the document; zoom in and out of pages; and initiate a print job.




Print Preview toolbar

The print preview toolbar offers you the following options:

Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.

Close
Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection. This command presents a
Print Setup dialog box, where you specify the printer and its connection.




Print Setup dialog box

The following options allow you to select the destination printer and its connection.

Printer
Select the printer you want to use. Choose the Default Printer; or choose the Specific
Printer option and select one of the current installed printers shown in the box. You
install printers and configure ports using the Windows Control Panel.

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources. Specify the tray here.
Options
Displays a dialog box where you can make additional choices about printing, specific to
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

<< Write application-specific help here. >>






