


















































Learn the main steps to create a project

This tutorial is arranged as a series of lessons that will teach you the main steps involved in creating a project. 
Use the Table of Contents or click Next to read about each step.



Follow step-by-step directions to enter your project data

From each lesson in this tutorial, you can click the titles underlined in blue to follow step-by-step directions for 
entering your data. The step-by-step directions will float on top of your project as you work in Microsoft Project. 
Click Lesson to return to the lesson when you are finished with that step.



After you enter your project data, click Next to go to the next topic in the tutorial

When you have completed the step-by-step directions that apply to your project data, click Next to move on to 
the next lesson in the tutorial.



Set the project's start or finish date
The first steps in creating a schedule are creating a new file, designating a project start date or finish date, and 
entering other general project information. If you don't enter a project start date or finish date, Microsoft Project 
automatically uses the current date as the start date. For more information about scheduling from a finish date, 
click    .

1 Click New     on the Standard toolbar.
2 Enter a start date or a finish date.

· To enter a start date, type or select the date on which you want to start your project in the Start date box. 
Or, if you are unsure of the date, you can choose a day from the drop-down calendar in either box.

· To enter a finish date, click Project Finish Date in the Schedule from box, and then type or select a finish 
date from which to schedule your project in the Finish date box.

Tip      If your plans change, you can change your project information at any time by clicking Project Information 
on the Project menu.



Strategies for scheduling from a finish date
If you have an absolute deadline that cannot be moved or you're uncertain when your project will begin (for 
example, if you're receiving work from another source that could be delayed), then you may find it useful to 
schedule from a finish date.

0 As you work with your project scheduled from a finish date, you should be aware of differences in the way 
Microsoft Project handles some activities:

· When you enter tasks in a project scheduled from a finish date, Microsoft automatically assigns the As Late As
Possible constraint. You should set other constraints only when necessary.

· If you change your project to schedule from a finish date, and it was previously scheduled from a start date, 
you will remove all leveling delays and leveling splits from tasks and assignments.

· If you drag a Gantt bar to change the finish date of a task, Microsoft Project automatically assigns a Finish No 
Earlier Than constraint.

· If you use automatic leveling to reduce resource overallocations in your project, Microsoft Project will add 
leveling delay after a task, rather than before a task.



Enter the project title, manager's name, and important notes
Each project has a unique set of ingredients: the tasks involved, the people who do them, and the project goal 
that they hope to achieve. To help you remember and communicate important details, you can enter information 
about the project and refer to it or print it when needed. 

1 On the File menu, click    Properties.
2 On the Summary tab, enter the information for your project such as the people who will manage the project 

and maintain the project file, the project goal, any known limitations that may make it difficult to reach that 
goal, and other general project notes.
Tip You can choose to print this information when you print your project file.



Set a work schedule
You can change the working days and hours for your project calendar to reflect the work schedule for everyone 
working on your project. You can specify regular nonworking days and hours (such as weekends and evenings), 
as well as special days off (such as holidays).

1 On the Tools menu, click Change Working Time.
2 To change the entire calendar, select each weekday at the top of the calendar.

To change a single day, select the date on the calendar.
3 Click Nonworking time for days off, or Working time to change the hours worked.
4 If you clicked Working time in step 3, type the times you want work to start and end in the From and To 

boxes.



Enter tasks and their durations
A typical project consists of a series of interrelated tasks, the building blocks of your schedule. A task should 
represent a significant amount of work with a clear deliverable, but still be short enough to track its progress 
regularly and identify problems early. As a guideline, tasks should be between 1 day and 2 weeks long. But you 
can enter a duration in minutes (such as 30m), hours, days, or weeks, whichever is most accurate. Enter tasks in
the general order in which they will occur. You can rearrange, delete or add new tasks later, if necessary.

1 On the View Bar, click Gantt Chart    .
2 In the Task Name field, type a task name.
3 Press ENTER.
4 In the Duration field, type the amount of time in minutes (such as 30m), hours, days or weeks. Enter smaller
increments such as a half day as .5 days. Microsoft Project uses durations to calculate the amount of work to be done
on the task. You can revise these estimates later, if necessary.

Note      Don't enter dates in the Start and Finish fields. Microsoft Project will calculate the start and finish dates 
based on how the tasks are related with task dependencies you enter.
Tip      You can add a note to a task that contains information, such as detailed explanations, assumptions, or 

where the task originated. In the Task Name field, select the task, and then click Task Notes    . Type your 
information in the Notes box.



Enter a recurring task
You can set up a recurring task to occur daily, weekly, monthly, or yearly. You can also specify the duration of 
each occurrence, when the task will occur, and for how long or how many times it should recur. Recurring tasks 
are useful for repetitive tasks that occur at regular intervals, such as weekly meetings. You can edit the fields of 
an individual occurrence of a recurring task without affecting the other occurrences.

1 In the Task Name field, select the row above which you want to insert a recurring task.
2 On the Insert menu, click Recurring Task.
3 In the Name box, type the task name.
4 In the Duration box, type the duration of a single occurrence of the task.
5 Under This occurs, click the interval at which the task will recur.

The option you click determines whether the Daily, Weekly, Monthly, or Yearly options are displayed.
6 Under Daily, Weekly, Monthly, or Yearly, specify the task frequency. 
7 Under Length, type a date in the From box and type a date in the To box, or type the number of times the 

task will occur in the For occurrences box.
If you don't enter a date in the From box, Microsoft Project uses the project start and finish dates to determine
the number of occurrences.

Note      Tasks are automatically renumbered after you insert a task.

Tip      To view all occurrences of a recurring task, click     next to the main recurring task.



Split a task into segments
You can split a task so that the task is interrupted, and then resumes later in the schedule. This is useful when 
you need to stop work on a task temporarily to work on another task. Splitting a task into parts is not the same as
entering a recurring task scheduled to occur at regular intervals, such as a staff meeting.

1 Click Split Task    .
2 Move the pointer over the task bar you want to split, and then click on the task bar where the split should 

occur.
Tip      You can create a longer split by clicking and dragging the task bar to the right.
Note      If you drag a portion of a split task so that it touches another portion, you will remove the split.



Rearrange the task list
As you create your task list, you will probably want to rearrange some tasks and break down large tasks into 
smaller tasks. You can add new tasks, delete unnecessary tasks, or move tasks to a better location. As you fine-
tune your task list, you will probably discover some tasks that summarize the work of smaller tasks. When you 
reach this point, your task list needs a hierarchical structure, and you are ready to move on to the next stage of 
creating your project.

1 In the ID field, select the task you want to copy, move, or delete.
· To select a row, click the task ID number.
· To select a group of adjacent rows, hold down SHIFT, and then click the first and last ID numbers of the 

group.
· To select several nonadjacent rows, hold down CTRL, and then click the task ID numbers.

2 To move the task, click Cut    .

To copy the task, click Copy    .
To delete a task, press DELETE.

3 In the ID field, select the rows where you want to paste the selection.

4 Click Paste    .
If there is information in the destination row, the new rows will be inserted above the destination row.

Tip      To add a task between existing tasks in a sheet view, click New Task on the Insert menu, and then type 
the name of the task in the Task Name field. Tasks are renumbered automatically after you insert a new task.



Create a milestone
A milestone is simply a task you use to identify significant events in your schedule, such as the completion of a 
major phase. When you enter a duration of zero days for a task, Microsoft Project displays the milestone symbol

 on the Gantt Chart at the start of that day.

1 In the Duration field, select the task you want to change, and then type 0 days.
2 Press ENTER.

Tip      You can also mark a task as a milestone without changing the duration. Click Task Information    , 
click the Advanced tab, and then select the Mark task as milestone check box.



Structure tasks into a logical outline
After you have entered your task list you may discover that some tasks actually summarize the work of smaller 
tasks. You can establish a hierarchy to accurately reflect how they are interrelated. An outline helps you organize 
your tasks into summary tasks and subtasks. By default, summary tasks are bold and subtasks are indented 
underneath them. A summary task's start and finish dates are determined by the start and finish dates of its 
earliest and latest subtasks.

1 On the View Bar, click Gantt Chart    .
2 In the Task Name field, select the task you want to indent or outdent.

3 Click Indent        to indent the task or click Outdent    

    to outdent the task.
Tips
· If you need to create a new task to make a summary task, click Insert Task on the Insert menu.
· You can indent or outdent a task quickly with the mouse. Position the pointer over the first letter of the task 

name. When the pointer changes to a two-way arrow    , drag right to indent the task or drag left to outdent 
the task.

· To undo outlining, outdent all subtasks until all your tasks return to the same outline level.



Show or hide the subtasks
In an outline, you can show or hide the subtasks of a summary task. By showing or hiding all subtasks, you can 
quickly display or hide all tasks on all outline levels in your entire project.

1 In the Task Name field, select the summary task containing the subtasks you want to show or the subtasks 
you want to hide.

2 Click Show Subtasks        to show the subtasks or click Hide Subtasks    

    to hide the subtasks.

To show all subtasks, click Show All Subtasks    .
To hide all subtasks, select the entire sheet view by clicking the ID column heading (the left-uppermost field in 

the Gantt Chart) and click Hide Subtasks .
Tips
· You can also show and hide subtasks by clicking the summary task’s outline symbol. Outline symbols indicate

whether a summary task has subtasks displayed        or does not have subtasks displayed    

.

· You can easily rearrange project phases in your outlined schedule. When you move or delete a summary 
task, you automatically move or delete all the subtasks associated with it.



Add work breakdown structure codes
Built-in outline numbers are used as the default work breakdown structure (WBS) codes in Microsoft Project. You
can add your own numbering system to the tasks in your schedule by changing the default outline numbers to 
your custom WBS codes in the WBS field.

1 Select the indicators column.
2 On the Insert menu, click Column.
3 In Field name, select WBS.
4 In the WBS column, type the code you want to assign to the tasks.
Notes
· WBS codes don’t change built-in outline numbers.
· Because WBS codes aren't automatically calculated between summary tasks and subtasks, you'll need to 

enter them for each individual task.
· Unlike built-in outline numbers, WBS codes are not automatically updated when you add, move, delete, or 

rearrange tasks. You'll have to adjust your WBS codes manually.



Sequence the tasks
After you’ve decided what the order of your tasks should be, you’re ready to sequence them by linking related 
tasks. For example, some tasks may need to finish before a successor task. Others may depend on the start of a
predecessor task.

1 On the View Bar, click Gantt Chart    .
2 In the Task Name field, select two or more tasks you want to link.

3 Click Link Tasks    .
Notes
· If you're linking tasks using multiple selections, select the tasks in the order in which you want them to be 

linked.

· To see more of the task bars in your chart, click Zoom Out    .
· Microsoft Project creates a finish-to-start task link by default. You can change this task link to start-to-start, 
finish-to-finish, or finish-to-start.

       How?  
· If you want to unlink tasks, select the tasks you want to unlink in the Task Name field, and then click Unlink 

Tasks    . The tasks will be rescheduled based on any links to other tasks or constraints. 



Change a task dependency
Microsoft Project assigns a finish-to-start task dependency when you link tasks. But there are other ways that 
tasks can be sequenced: start-to-start, finish-to-finish, or finish-to-start. If one of these dependencies better 
models your tasks, change the dependency type.
1 Double-click the link line of the tasks you want to change.

The Task Dependency dialog box appears. If the Bar Styles dialog box appears, you didn’t click precisely on
the task link and need to close this dialog box and click on the task link again.

2 In the Type box, click the task link you want.
Tip      A simple finish-to-start link does not work in every situation. Microsoft Project provides additional types of 
task links so you can model your project realistically. For example, when two tasks need to start at the same 
time, you can create a start-to-start link. When tasks need to finish at the same time, you can use a finish-to-
finish link.



Start or finish tasks on specific dates
You can schedule tasks most effectively by entering task durations, creating dependencies between tasks, and 
then letting Microsoft Project calculate the start and finish dates for you. Only when tasks must start and finish on
specific dates should you add an inflexible constraint to a date and have Microsoft Project calculate the task 
duration.

1 In the Task Name field, select the task you want, and then click Task Information    .
2 Click the Advanced tab.
3 In the Type box, click a constraint type.
4 If you selected a constraint other than As Late As Possible or As Soon As Possible, type a constraint 
date in the Date box.

Note      If you type a start date for a task or drag a Gantt bar to change the start date, Microsoft Project sets a 
Start No Earlier Than (SNET) constraint based on the new start date. If you type a finish date for a task, 
Microsoft Project automatically assigns a Finish No Earlier Than (FNET) constraint.



Overlap tasks or add lag time between tasks
After you've sequenced tasks by linking them, you can overlap or delay certain tasks to more accurately model 
how the work will be done. In Microsoft Project, you delay tasks by adding lag time, such as 2d, to the 
predecessor task and overlap tasks by entering negative lag time. You can also enter lag time as a percentage of
the task, such as –25%.

1 In the Task Name field, select the task you want, and then click Task Information    .
2 Click the Predecessors tab.
3 In the Lag field, type the lead time or lag time you want, as a duration or as a percentage of the predecessor
task duration.

Type lead time as a negative number or as a percentage, and type lag time as a positive number or as a 
percentage.

Tip      You can quickly add lead or lag time to a successor task by double-clicking the link line on the Gantt Chart,
and then typing the amount of lead or lag time in the Task Dependency dialog box.



Create a resource list
Before you begin assigning resources, you can enter all of the resource information for your project, such as 
resource groups and costs, at once by creating a resource list. This will save you time when assigning resources 
to your tasks. Or, you can create a list as you add and assign resources to your project. A resource list includes 
the names of the resources and the maximum number of units as a percentage of each resource’s availability.

1 On the View Bar, click Resource Sheet    .
2 On the View menu, point to Table, and then click Entry.
3 In the Resource Name field, type a resource name.
4 If you want to designate a resource group, type a name in the Group field.
5 If necessary, type the number of resource units available for this resource in the Max. Units field, as a 
percentage.

For example, type 300% to indicate three full-time units of a particular resource.
6 Change the default information in the remaining fields as appropriate.
7 Repeat steps 3 through 6 for each resource.
Tip      As you work in the Gantt Chart or other task views, you can enter additional resource names. To assign 

additional resources, click Assign Resources    , and then type a resource name in the Name field. You can 
also click Address and select a resource from your e-mail address book.



Assign resources
Assigning resources to tasks can be an important part of managing a successful project. You should assign 
resources to tasks when you want to:

· Track the costs and amount of work done by the people and equipment assigned to the tasks.
· Ensure high accountability. When responsibilities are clear, there is less risk of tasks being overlooked.
· Have greater flexibility in planning how long tasks will take.

1 On the View Bar, click Gantt Chart    .

2 In the Task Name field, select the task to assign a resource, and then click Assign Resources .
3 In the Name field, select the resource to assign to the task or click Address to select a resource from your 
e-mail address book.

· To assign a resource part-time, type a percentage less than 100 in the Units field.
· To assign several different resources, press CTRL to select nonadjacent resources or press SHIFT to select 

adjacent resources.
· To assign more than one of the same resource, type a percentage amount greater than 100 in the Units 

field, such as 200 percent for two carpenters.
If necessary, type the name of a new resource in the Name field.

1 Click Assign.
A check mark to the left of the Name field indicates that the resource is assigned to the selected task. The 
resource's name also appears next to the task bar in the Gantt Chart.

Note      If you don’t enter resource information, Microsoft Project calculates your schedule using just task 
duration and task dependency information.
Tips
· As your schedule changes,    you can replace one resource with another. In the Assign Resources dialog 

box, select the assigned resource, and then click Replace. Select one or more resources to assign, and then 
click OK.

· If you want to assign resources as you complete other work on your schedule, you can continue to display the
Assign Resources dialog box while you work with the Gantt Chart and other Microsoft Project views.

· As you assign additional resources to a task, the duration will be reduced to reflect the addition of the 
resources. If you want the duration of the task to stay the same regardless of the resources assigned, select 

the task, click Task Information    , and then click the Advanced tab. Clear the Effort driven check box.



Change a resource's work schedule
By default, the working hours and days off defined by the project calendar are the default working hours and 
days off for each resource. If your resources will work the same days and hours, you can use this calendar for all 
resources. But, if you need to specify different working times for individual resources, you can modify individual 
resource calendars for those resources.

1 On the Tools menu, click Change Working Time.
2 In the For box, click the resource whose calendar you want to change.
3 On the calendar, select the days you want to change.

To change a day of the week for the entire calendar, select the day at the top of the calendar.
4 Click Use default, Nonworking time, or Working time.
5 If you clicked Working time in step 4, type the times at which you want work to start in the From boxes and 

the times at which you want work to end in the To boxes.
Tip      If a group of resources will have the same special working hours and days off, you can create a new base 
calendar for them. Click New, and type a name for the new base calendar. Click Create new base calendar to 
begin with a default calendar. Or, to base it on an existing calendar, click Make a copy of, and then click the 
calendar name in the Calendar box. Click OK, and then modify the days and hours on the calendar. Click 
Resource Sheet, and select the new base calendar in the Base Calendar field for each resource to which you 
want to assign it.



See to which tasks the resources are assigned
The Resource Usage view shows project resources with their assigned tasks grouped underneath them. Using 
the Resource Usage view, you can find out how many hours each resource is scheduled to work on specific 
tasks and see which resources are overallocated. You can also determine how much time each resource has 
available for additional work assignments.

1 On the View Bar, click Resource Usage .
To see different information about resource assignments, such as work and cost, from the View menu, select 
Tables, then click the table you want to see in the Resource Usage view.

2 In the Resource Name field, review the resource assignments.
Note      Changing the view or table does not add information to or remove information from your project, it only 
changes the project information that is displayed.



Assign pay rates to resources
Microsoft Project allows you to assign rates to resources so you can manage project costs accurately. You can 
assign multiple standard rates, overtime rates, or per-use rates to resources along with the dates for each rate to 
go into effect.

1 On the View Bar, click Resource Sheet    .
2 In the Std. Rate, Ovt. Rate, or Cost/Use field for the resource, type the rates you want.
3 Press ENTER.

Tips
· You can assign up to five sets of cost rates to support different types of work or future rate changes, such as 

pay increases. In the Resource Name field, select the resource, and then click Resource Information    . 
Click the Costs tab, and then enter the rates in the Cost rate tables.

· You can assign per-use rates for resources (such as one-time costs of equipment). In the Cost/Use field, 
type a per-use rate for the resource.
· You can change the default standard and overtime rates for any new resources you enter. On the Tools 

menu, click Options, and then click the General tab. In the Default standard rate and Default overtime rate
boxes, type the new rates. If you want to set this default for all future projects, click Set as Default.



Set a fixed cost
When you know the exact cost of materials (such as equipment or supplies), and you're not assigning resources 
to a task, you can enter a fixed cost for the task.

1 On the View Bar, click Gantt Chart    .
2 On the View menu, point to Table, and then click Cost.
3 In the Fixed Cost field for the task, type the cost.
4 Press ENTER.

Tip      In the Cost table, you can also change when the fixed cost is accrued by selecting an accrual method in 
the Fixed Cost Accrual field.
Note      Unlike fixed costs for a resource, fixed costs for tasks do not require resource assignments.



Change when a cost accrues
In Microsoft Project, resource costs are prorated by default and their accrual is based on the percentage of 
completion of the task and is distributed over its duration. You can, however, change the accrual method for 
resource costs to take effect at the start or end of the task instead.

1 On the View Bar, click Resource Sheet    .
2 In the Resource Name field, select the resource whose accrual method you want to change.

3 Click Resource Information    , and then click the Costs tab.
4 In the Cost accrual box, click an accrual method.

Notes
· When you enter timephased rate changes for a resource and use the prorated cost accrual method, your 

costs will be calculated using the rates for the appropriate time periods and may change during the completion
of the task.

· You cannot prorate per-use resource costs or accrue them at the end of a task assignment. They are always 
accrued at the start of the assignment.



Update or add another pay rate
To allow for changes in resource rates, such as pay increases or decreases, you can assign different rate values 
to be applied at times you specify. You can save up to five different sets of rates for each resource to support 
different charges for different types of work.

1 On the View Bar, click Resource Sheet    .
2 In the Resource Name field, select the resource for which you want to enter different rates.

3 Click Resource Information    , and then click the Costs tab.
4 In the Cost rate tables, type the effective date and the new standard, overtime, or per-use cost rate in the 
corresponding fields of the first blank row.

Tips
· From any task view, you can open the Resource Information dialog box by double-clicking the resource in the 

Assign Resources dialog box.
· In the rate fields of the cost rate tables, you can enter rate increases or decreases in values by typing a new 

rate or in percentages by typing +10% or –10%, for example. When entering percentages, Microsoft Project 
will calculate the new rate for you.



See the cost of tasks or resources
After you assign rates to tasks or resources, you may want to review the total cost of these assignments to make 
sure they fall within your expectations. If the total cost of a task or resource does not meet your budget, you may 
need to examine each individual task's costs and each resource's task assignments to see where costs can be 
reduced.

1 To see task costs, click Gantt Chart  on the View Bar.

To see resource costs, click Resource Sheet     on the View Bar.
2 On the View menu, point to Table, and then click Cost.
3 In the Gantt Chart, drag the divider bar to the right to view the Total Cost field.

Tips
· You can also view how costs are distributed over a task's duration in the Task Usage view by displaying its 

cost details. On the View Bar, click Task Usage    . On the Format menu, point to Details, and then 
click Cost.

· You can view resource costs in more detail by clicking Resource Usage        on the View Bar, pointing 
to Details on the Format menu, and then clicking Cost. 

· You can also see resource cost totals displayed graphically by clicking Resource Graph        on the 
View Bar, pointing to Details on the Format menu, and then clicking Cost or Cumulative Cost.



See the cost of the entire project
You can view your project's current, baseline, actual, and remaining costs to see whether you're staying within 
your overall budget. These costs are updated each time Microsoft Project recalculates your project.

1 On the Project menu, click Project Information.
2 Click Statistics.
3 In the Current field under Cost, the total planned cost of the project is shown.
Tips
· After you have set a baseline and begun to track actual costs, you can compare the Baseline and Actual 

fields to see if total project costs are progressing as expected. 
· As actual work is progressing, you can also compare the variance between the Current and Remaining fields

to see if you will have enough money to complete the project.



Use the GanttChartWizard for easy formatting
The GanttChartWizard is a series of interactive dialog boxes containing options that you select to help you format
the Gantt Chart, such as highlighting the critical path. When you finish selecting the options you want, the 
GanttChartWizard formats your Gantt Chart for you.

1 On the View Bar, click Gantt Chart    .

2 Click GanttChartWizard    .
3 Follow the GanttChartWizard instructions.

Tip      To undo the formatting you chose with the GanttChartWizard, click GanttChartWizard and choose the 
default options to return the Gantt Chart to its. default settings.



Format a category of Gantt bars
To call attention to all tasks of a certain category, you can change the format of the Gantt bars that represent that 
type of category on the Gantt Chart. A category can, for example, include all the tasks in your project, or just 
specific types such as milestone tasks, or critical and noncritical tasks.

1 On the View Bar, click Gantt Chart .
2 On the Format menu, click Bar Styles.
3 In the Name field, select the category (such as Task or Milestone) you want to change, and then click the 
Bars tab.
4 Under Start shape, Middle bar, and End shape, select shapes, patterns or types, and colors for the bar.

Note      Some categories have only a start shape (such as Milestone), while others have a start shape, middle 
bar, and end shape (such as Summary Task).
Tip      To change the formatting of an individual Gantt bar, select the task, and then click Bar on the Format 
menu. Click the Bar Shape tab, and then format the Gantt bar.



Format a category of tasks in your task list
To distinguish a category of tasks, such as critical tasks, from other tasks in your project, you can change the 
formatting of all the text of the tasks in that category in any view except the PERT Chart and form views. (In 
some views, however, not all formatting options are available.) 

If certain information in your view requires urgent attention, such as the completion date of a slipped task, you 
can call attention to that information by formatting it individually

1 On the View Bar, click a sheet view such as the Gantt Chart .
2 On the Format menu, click Text Styles.
3 In the Item to Change box, click the type of information you want to change, and then select formatting 
options for that information.

To change the formatting of another type of information without closing the dialog box, click a new type in the 
Item to Change box, and then select formatting options for that information.

Tips
· To change the format of an individual task, select the task, click Font on the Format menu, and then select 

formatting options for that text.
· To quickly copy the formatting of one task to another, select the task with formatting you want to copy, click 

Format Painter , and then select the task to which you want to apply that formatting.



View different project information
You can display project information in task views or resource views. Use a task view when you want to enter, 
change, or display task information. Use a resource view when you want to enter, change, or display resource 
information.

· On the View Bar, scroll and click the view you want to use.

To use a view that is not on the View Bar, click More Views    , click the view you want in the Views list, 
and then click Apply.

Note      Changing the view does not add information to or remove information from your project, it only changes 
the project information that is displayed.



Add a title, page number, or other project information
You can add project information to the header, footer, or legend of a view. The project information can be data 
you entered (such as your company's name or manager's name) or data provided by Microsoft Project (such as 
the page number or project finish date). You can choose the project information that adds the most impact to your
printed view.

1 On the File menu, click Page Setup.
2 Click the Header, Footer, or Legend tab.
3 Click the Left, Center, or Right tab.
4 In the text box, place the insertion point where you want to add the project information.
5 In the box at the bottom of the tab, click each type of information you want, and then click Add. Microsoft 

Project will use the information you typed into the Project Information and Properties dialog boxes to fill in 
each type of information.

Tip      To format project information, you need to select the ampersand (&) that precedes it or select the entire 

line, and then click Font    . Select the font, font style, size, and color you want, select the Underline check 
box if you want, and then click OK.



Preview your schedule
Before printing a view, it is often useful to see what the information will actually look like when printed. In the Print
Preview window, you can adjust the page orientation and size, edit headers, footers, and legends, and set print 
options. You cannot edit the information in the view itself in the Print Preview window.

· To preview what a project view will look like when printed, click Print Preview    .



Print the view on the screen

· To print a view using the default settings, click Print    .
If you want to change the default print settings, click Print on the File menu, and then specify the printer and 
printer properties, the print range, the number of copies, and the date range. You cannot, however, save print 
options; you must reset print options every time you print. To see the results of your changes immediately, click 
Preview in the Print dialog box.

Tips
· To change options, such as printing notes or a specific number of columns, click Page Setup on the File 

menu, click the View tab, and then select the options you want.
· If you preview a view, and then decide to change the appearance of the view pages, click Page Setup in the 

Print Preview window, and then make the changes you want. To return to the Print Preview window, click 
Print Preview in the Page Setup dialog box.



See the entire project on the screen
You can get an overview of your project's start and finish dates and when major phases will occur by zooming in 
and out on the Gantt Chart.    

1 On the View Bar, click Gantt Chart    .
2 Click Zoom on the View menu, and then click Entire project.

Tips

· To see the Gantt bars on a larger or smaller timescale, click Zoom In     or Zoom Out    

.
· If you have to scroll down to see the project's finish date, and you have outlined tasks into a hierarchy, you 
can hide the subtasks and look at just the summary tasks. Click the ID column heading (the left-uppermost field in the

Gantt Chart), and then click Hide Subtasks    .



Check the project's finish or start date
You can review important project information, such as the finish date, to see if the project will meet your 
expectations as it is currently scheduled.

1 On the View Bar, click Gantt Chart    .
2 On the File menu, click    Properties, and then click the Contents tab. The project's start and finish dates 
are shown, as well as the project's total work and cost, and the percentages of the tasks and work that are complete.

Tip        Once the project is underway, you can also see a comparison of the project's planned and actual 
information. Click Project Information on the Project menu, and then click Statistics.



Identify the critical path
The critical path is a series of tasks that must be completed on time for a project to finish on schedule. Most 
tasks in a typical project have some slack and can therefore be delayed a little without affecting the project's 
finish date. Those tasks that cannot be delayed without affecting the project finish date are the critical tasks. As 
you modify tasks to resolve overallocations or other problems in your schedule, be aware of the critical tasks and
that changes to them will affect your project finish date.

1 On the View Bar, click Gantt Chart    .

2 Click GanttChartWizard    .
3 Follow the GanttChartWizard instructions to format critical path tasks.

Tips
· You can filter your schedule so that only the critical tasks (tasks with no total slack) are displayed. On the 

Project menu, point to Filtered for, and then click    Critical. Click All Tasks to display all tasks again.
· After filtering critical tasks, you can sort them by duration so that the critical tasks will be in order from the 

longest to the shortest. This helps you see where to put your efforts in shortening tasks.
· You can adjust the amount of time a task can slip before it affects another task's date or the project finish 

date, and thus become a critical task. On the Tools menu, click Options, and then click the Calculation tab. 
In the Tasks are critical if slack is less than or equal to box, enter the amount of slack.



Change the view
You can display project information in task views or resource views. Some task and resource views are like 
spreadsheets, listing columns of related information, called sheet views. You can change the table in a sheet 
view to see different columns of information. Other views show tasks or resource allocation graphically, such as 
the Calendar View, PERT Chart, and Resource Graph, or tasks and resources related to a timescale, such as the
Task Usage and Resource Usage views. 

· On the View Bar, click the view you want to use.

To use a view that is not on the View Bar, click More Views    , click the view you want in the Views list, 
and then click Apply.

Note      Changing the view neither adds information to nor removes information from your project, it only changes
what is displayed.



Apply a different table to a view
As you plan and track your schedule, it's useful to look at different combinations of information. By changing the 
table applied to a sheet view, you can change the fields of information displayed in that view.

1 On the View Bar, click the view to which you want to apply a table.

To use a view that is not on the View Bar, click More Views    , click the view you want in the Views list, 
and then click Apply.

2 On the View menu, point to Table, and then click the table you want to apply.
To apply a table that isn't on the Table submenu, click More Tables, click the task or resource table you want, 
and then click Apply.



Apply a filter to a sheet view
When you want to focus on certain tasks or resources in the current view, you can apply a filter to the view. You 
can specify that the filter either show or highlight only those tasks or resources that meet the filter criteria.

1 On the Project menu, point to Filtered for, and then click the filter you want to apply.
To apply a filter that isn't on the Filtered for submenu or to apply a highlighting filter, and click More Filters.

2 Click Apply to apply the filter or click Highlight to apply a highlighting filter.
3 If you apply an interactive filter, type the requested values, and then click OK.
Note      You cannot apply task filters to resource views or apply resource filters to task views.
Tip      To turn off a filter, point to Filtered for on the Project menu, and then click All Tasks or All Resources.



Check task dependencies
A task dependency describes how a task is related to the start or finish of another task. Microsoft Project 
provides four task dependencies you can use to connect a series of tasks in a schedule: finish-to-start (the most 
commonly used dependency), start-to-start, start-to-finish, and finish-to-finish. By using these dependencies 
effectively, you can modify the critical path and shorten your project schedule.

1 On the View Bar, click Gantt Chart    .
2 Double-click the link line of the tasks you want to check.

3 In the Type box, look at the task dependency.
Tips
· The appearance of the link itself will identify the task dependency type. For example, a link line drawn from 

the beginning of one Gantt bar to the beginning of another denotes a start-to-start dependency.
· If you have tasks that can be worked on at the same time, you can shorten the critical path most by changing 

the task dependency. For example, if two tasks can be started at the same time, you can change the task 
dependency to start-to-start. If two tasks should finish at the same time, you can change the task dependency 
to finish-to-finish.

· You can add lead or lag time to tasks to make their start or finish dates overlap each other or to delay a 
predecessor task.



Find slack in your schedule 
When you analyze the tasks in your schedule, you can look for slack, which is the amount of time a task can be 
delayed without delaying any other task. You can also look at total slack, which is the amount of time a task can 
be delayed without affecting the finish date of the project.

It's important to know where slack exists in your schedule so you can move tasks when certain phases of the 
schedule have no slack and other phases have too much. Most schedules have some noncritical tasks with 
slack. You can allow these tasks to start late without affecting the schedule to compensate for tasks that take 
longer than planned or to delay tasks and resolve resource overallocations.

1 On the View Bar, click More Views    .
2 In the Views list, click Detail    Gantt, and then click Apply.

Slack on a task appears graphically as thin slack bars adjoining the regular Gantt bars.
3 Drag the divider bar to the right to view the Free Slack and Total Slack fields.

Note      Slack values may also indicate a schedule inconsistency. For example, a negative slack value occurs 
when one task has a finish-to-start dependency with a second task, but the second task has a Must Start On 
constraint that is earlier than the finish date of the first task.
Tips
· You can filter your schedule so that only critical tasks (tasks with no total slack) are displayed. On the Project 

menu, point to Filtered for, and then click    Critical. Click All Tasks to display all tasks again.
· You can adjust the point at which tasks become critical. On the Tools menu, click Options, and then click the 

Calculation tab. In the Tasks are critical if slack is less than or equal to box, enter the amount of slack at 
which the task becomes critical.



Overlap tasks or add lag time between tasks
After you've sequenced tasks by linking them, you can overlap or delay certain tasks to more accurately model 
how the work will be done. In Microsoft Project, you delay tasks by adding lag time to the predecessor task and 
overlap tasks by adding negative lag time.

1 In the Task Name field, select the task you want, and then click Task Information    .
2 Click the Predecessors tab.
3 In the Lag field, type the lead time or lag time you want, as a duration or as a percentage of the predecessor
task duration.

Type lead time as a negative number or as a percentage, and type lag time as a positive number or as a 
percentage.

Tip      You can quickly add lead or lag time to a successor task by double-clicking the link line on the Gantt Chart,
and then typing the amount of lead or lag time in the Task Dependency dialog box.



Check constraints on tasks 
Task constraints can help you create a more accurate schedule by modifying when tasks occur in relation to 
dates. For example, you can specify that a task must start no earlier than a particular date or finish no later than 
a particular date. You can change the constraint on a task from the default, As Soon As Possible, to eight 
different constraints or reset it to the default constraint to better reflect how the task will be done.

1 On the View Bar, click Gantt Chart    .
2 On the View menu, point to Table, and then click More Tables.
3 In the Tables list, click Constraint Dates, and then click Apply.
4 Drag the divider bar to the right to view the Constraint Type and Constraint Date fields.

5 For each task with a constraint other than the default, As Soon As Possible, look at the predecessor tasks and
successor tasks on the Gantt Chart to determine if the constraint is necessary.

Notes
· If you type a start date for a task or drag a Gantt bar to change the start date, Microsoft Project sets a Start No

Earlier Than (SNET) constraint based on the new start date. If you type a finish date for a task, Microsoft 
Project automatically assigns a Finish No Earlier Than (FNET) constraint.

· If you're scheduling your project from a finish date, typing a start date for a task or dragging a Gantt bar to 
change the start date sets a Start No Later Than (SNLT) constraint. If you type a finish date for a task, 
Microsoft Project automatically assigns a Finish No Later Than (FNLT) constraint.



Make tasks shorter by adding more resources
Once you've assigned resources to a task, Microsoft Project will recalculate the task's duration if you add or 
remove additional resources. For example, if you add another resource to a task with a 4 day duration and one 
assigned resource, the task will be shortened to 2 days. If you have more flexibility with your resource 
assignments than schedule deadlines, this can be an effective way to shorten your schedule.

1 On the View Bar, click Gantt Chart    .
2 In the Task Name field, select the task to which you want to assign more resources, and then click Assign 

Resources    .
3 In the Name field, select the resource you want to assign to the task or click Address to select a resource 
from your e-mail address book.
4 Click Assign.

If necessary, type the name of a new resource in the Name field.
A check mark to the left of the Name field indicates that the resource is assigned to the selected task. The 
resource's name also appears next to the task bar in the Gantt Chart.

Note      As you assign additional resources to a task, the duration will be reduced to reflect the addition of the 
resources.
Tips
· If you don't know which resources have the availability to take on extra work, you can see current resource 

allocations by clicking Resource Usage        on the View Bar.
· To assign a resource part-time, type a percentage less than 100 in the Units field to represent the 
percentage of working time you want the resource to spend on the task.
· To assign several different resources, press CTRL to select nonadjacent resources or press SHIFT to select 
adjacent resources.
· To assign more than one of the same resource (such as two carpenters), type a percentage amount greater 

than 100 in the Units field.



Save a baseline of your project’s information
When you have entered all the information needed for your project and you're ready to start actual work, you can
save a baseline of your project's information to compare with the actual progress of your project. Using a 
baseline, you can track the progress of your schedule and make any necessary corrections. For example, you 
can see which tasks started later than planned, how much work resources performed, and keep track of your 
budget. After you save a baseline, you can save up to ten interim plans to compare planning strategies or as 
checkpoints during the actual progress of your project. 

1 On the Tools menu, point to Tracking, and then click Save Baseline.
2 Click Entire project or Selected tasks to add new tasks to an existing baseline.
Tip        If you want to create a budget, first enter all your resource assignment and rate information, and then 
save a baseline. You cannot save this information in an interim plan.



Save the project without a baseline
Remember to save your project file periodically as you work. The first time you save the file, you will be asked 
whether to save a baseline of your project's information. If you've entered all your basic project information and 
you're ready to start actual work, you can save a baseline of your plan so that you can compare any future 
changes with your project as it was planned initially. If your project is not polished, you may prefer to save it 
without a baseline until you have entered more complete or accurate information.

1 Click Save    .
2 In the File name box, type a name for the project and then click Save.
3 Click Save Without a Baseline.



Save an interim plan
After you save a baseline of your project's information, you can save up to 10 interim plans as checkpoints during
the actual progress of your project.

1 On the Tools menu, point to Tracking, and then click Save Baseline.
2 Click Save interim plan.
3 In the Copy box, click the plan name you want to save.
4 In the Into box, click the name to which you want to save the plan.
5 Click Entire project or Selected tasks to save the portion of the schedule you want.
Note      An interim plan saves the tasks' start and finish dates. No resource or assignment data is saved in an 
interim plan.



Save a budget
If you've entered resource assignments and assigned rates to the resources or have entered fixed costs for 
tasks, you can save a baseline plan of your project's information to use as a budget. With a baseline plan as your
budget, you can keep track of your project costs and see how much work resources performed, as well as other 
project information, such as which tasks finished later than expected. You can use baseline information to make 
cost projections and compare them with the actual cost of your project, which can help you catch potential cost 
overruns before they become critical.

1 On the Tools menu, point to Tracking, and then click Save Baseline.
2 Click Entire project or Selected tasks to add tasks to an existing baseline.



Compare actual task information to the baseline
When you save a baseline plan and then update your schedule, you can compare the baseline plan to your 
actual progress to identify variances. Variances alert you to the areas of the project that are not going as 
planned. To keep your project on schedule, you need to make sure that tasks start and finish on time as much as
possible. Every project has variances, but it is important to find tasks that vary from the baseline plan as soon as 
possible so you can adjust task dependencies, reassign resources, or delete some tasks to meet your deadlines.

1 On the View Bar, click Tracking Gantt    .
The Tracking Gantt shows task variances graphically, making it easier to see variances in your schedule. 

2 On the View menu, point to Table, and then click Variance.
3 Drag the divider bar to the right to view the variance fields.

Note      You must update tasks' actual start and finish dates, actual work values, or actual durations before 
variances will appear. Microsoft Project will calculate the other task information based on the information you 
enter.



Make the number of resources drive the amount of work
As you assign more resources or remove resources from a task, Microsoft Project by default decreases or 
increases the duration of the task. But, you may want to change the amount of work on the task instead. For 
example, a task with a 1 day duration and one assigned resource has 8 hours of work. If you turn off effort-driven
scheduling and assign another resource, the task will have 16 hours of work and still have a 1-day duration.

1 On the View Bar, click Gantt Chart    .
2 In the Task Name field, select the tasks for which you want to turn off effort-driven scheduling.

3 Click Task Information    , and then click the Advanced tab.
4 Clear the Effort driven check box.

Tip      You can turn off effort-driven scheduling for all new tasks you create. Existing tasks will not be affected. On
the Tools menu, click Options, click the Schedule tab, and then clear the New tasks are effort driven check 
box.
Note      Previous versions of Microsoft Project behave as if effort-driven scheduling is turned off.



Split a task into segments
You can split a task so that the task is interrupted, and then resumes later in the schedule.

1 On the View Bar, click Gantt Chart    .

2 Click Split Task    .
3 Move the pointer over the task bar you want to split, and then click the task bar where you want the split to 

occur.
Tips
· You can create a longer split by clicking and dragging the task bar to the right.
· You can remove the split by dragging a portion of a split task so that it touches another portion.



Schedule work in uneven increments
When you assign a resource to a task, Microsoft Project automatically assigns the same number of hours per 
time period throughout the duration of the task, which is a flat work contour. You can tailor work values for a 
specific time period using preset work contours to more accurately reflect the pattern of a resource's work 
throughout the duration of a specific task. For example, you may want to use a frontloaded contour to increase 
the working hours of a resource toward the beginning of a writing assignment to reflect the additional time 
devoted to research, travel, and interviews.

1 On the View Bar, click Task Usage    .
Resources are grouped under the tasks to which they are assigned.

2 In the Task Name field, select a resource for which you want to apply a preset work contour.

3 Click Assignment Information    , and then click the General tab.
4 In the Work contour box, click a contour pattern.

An icon representing the contour pattern appears in the Indicators field.



Find overallocated resources and their task assignments
Resources are overallocated when they are assigned more work than they can complete in their scheduled 
working hours. Before you can attempt to resolve resource overallocation problems, you must determine which 
resources are overallocated, when they are overallocated, and what tasks they are assigned to at those times. To
resolve the problem, either the resources must be allocated differently or the task must be rescheduled to a time 
when the resource is available.

· On the View Bar, scroll down and click Resource Usage    .
Notes
· For each resource, the Resource Usage view shows the total hours the resource is working, the total hours 

the resource is working on each task, and the hours worked per time period on the timescale. Overallocated 
resources are highlighted.

· Resources with no tasks yet assigned do not have any tasks listed underneath their names.
· Tasks with no resources assigned are located under Unassigned in the Resource Name field.
Tips
· If you see pound symbols (##) in the timescale portion of the Resource Usage view, the columns in the 

timescale are not wide enough to display the information. To change the width of the columns, click 
Timescale on the Format menu, and then increase the value in the Enlarge box.

· You can see how much of a resource's work is allocated to particular tasks and per time period. On the 
Format menu, click Detail Styles. In the Available fields list, click Percent Allocation, and then click Show.



Reduce a resource's work
After you've assigned a resource to a task, you can either change the total work values for the resource's work 
on the task or change work values for a specific time period during which the resource works on the task. 
Tailoring work values this way can make your schedule more accurate at a finer level of detail.

1 On the View Bar, click Task Usage    .
Resources are grouped under the tasks to which they are assigned.

2 On the timescale portion of the view, change the individual work values (or hours) for the assigned resources.
Note      You can also change the total work value for a resource assignment by entering a new value in the Work 
field.
Tip      You can also use the Resource Usage view to see and edit work values for tasks grouped under the 

resources to which they are assigned. On the View Bar, scroll down and click Resource Usage    .



Reassign work to another resource
If you have tried to resolve a resource overallocation using other methods and the overallocation persists, it may 
be time to reassign the task to another more available resource. This is an alternate method of manually leveling 
your schedule by reassigning work rather than delaying work. Be careful to avoid causing an overallocation for 
the replacement resource.

1 On the View Bar, scroll down and click Resource Usage    .
2 On the Format menu, point to Details, and then click Overallocation.
3 Look at the timescale on the right and for each highlighted overallocation, examine the availability of other 
resources on that day.
4 Select the entire row of the task assignment you need to reassign.
5 Drag the task assignment to the resource to which you want to reassign it.



Delay a task
One of the simplest ways to resolve a resource overallocation is to delay a task assigned to the resource until the
resource has time to work on it. You can add delay to a task, check the effect on the resource's allocation, and 
then adjust the delay further if needed.

Delaying a task will also delay the start dates of its successors and can affect the finish date of your schedule. To
avoid this, delay tasks with free slack first (noncritical tasks) and only delay them up to the amount of slack that is
available for each task. Experiment with adding delay to different tasks to see the effect on your schedule.

1 On the View Bar, click More Views    .
2 In the Views list, click Detail Gantt, and then click Apply.

Slack on a task appears graphically as thin slack bars adjoining the regular Gantt bars.
3 On the View menu, point to Table, and then click Schedule.
4 Drag the divider bar to the right to view the Free Slack and Total Slack fields.

5 In the Task Name field, select the task you want to delay, and then click Task Information    .
6 Click the Predecessors tab.
7 In the Lag field, type the duration you want the task to be delayed.

To ensure that successor tasks are not affected, do not enter more lag than the amount of free slack for that 
task.



Change a resource's working days and hours
The project calendar designates the default work schedule for the project. But, you can create a resource 
calendar to indicate work hours, vacations, leaves of absence, and sick time for individual resources.

1 On the Tools menu, click Change Working Time.
2 In the For box, click the resource whose calendar you want to change.
3 On the calendar, select the days you want to change.

To change a day of the week for the entire calendar, select the day at the top of the calendar.
4 Click Use default, Nonworking time, or Working time.
5 If you clicked Working time in step 4, type the times you want work to start in the From boxes and the times 

you want work to end in the To boxes.
Tip      If a group of resources will have the same special working hours and days off, you can create a new base 
calendar for them. Click New, and type a name for the new base calendar. Click Create new base calendar to 
begin with a default calendar. Or, to base it on an existing calendar, click Make a copy of, and then click the 
calendar name in the Calendar box. Click OK, and then modify the days and hours on the calendar. Click 
Resource Sheet, and select the new base calendar in the Base Calendar field for each resource to which you 
want to assign it.



Insert a project into an existing project
By inserting individual project files into a existing project, you can view, print, or change information for the 
projects you're working with (and even those projects "owned" by other project managers) as though they were a
single project. 

1 Open a new or existing project file.

2 On the View Bar, click Gantt Chart    .
3 In the Task Name field, click the row above which you want to insert the project.

You can insert a project at any level of the outline.
4 On the Insert menu, click Project.
5 In the Look in box, click the drive or folder that contains the project file.
6 In the folder list, open the folder that contains the project file you want.
7 Change the insert project options you want.

· If you don't want the inserted project to be linked to its source project, clear the Link to Project check box. 
By default, this option is selected.

· If you don't want changes to the inserted project to be made in its source project, select the Read Only 
check box. By default, this option is cleared.

· If you want the inserted project's tasks to be shown immediately in the consolidated project, clear the Hide 
Subtasks check box. You also can choose to hide or show subtasksafter you've inserted the project. 

8 Click the project you want to insert. 
To insert two or more projects at the same time, hold down CTRL as you click each project.

9 Click Insert.
Tips

· After you've inserted a project, you can quickly show an inserted project's hidden subtasks by clicking the 
summary task's outline symbol. Outline symbols indicate whether a summary task has subtasks displayed   

    or does not have subtasks displayed    

.

· For more information about the options in a dialog box, click        and then click the item you want.



Create a dependency between tasks in different projects
If you have several projects in which tasks in one project are dependent on tasks in another project, you can 
create a task dependency between tasks in the different projects. When you link the tasks, Microsoft Project 
displays an external task in each project with which to show the task dependency. The external task is not 
editable.

1 Open both projects.
2 On the Window menu, click New Window.
3 Hold down CRTL, click the projects you want to consolidate temporarily, and then click OK.

4 On the View Bar, click Gantt Chart .
5 Position the pointer over the Gantt bar for the predecessor task and drag to the successor task in the other 
project.

A finish-to-start task dependency is created. If the tasks you linked are not in a consolidated project, an 
external predecessor task is added to the project containing the successor task and an external successor 
task is added to the project containing the predecessor task.

Note      You can also link tasks between projects by typing "project name\ID" in the predecessor field (where 
project name is the file name of the project containing the task you want to link to and ID is the Task ID of the 
task you want to link to).



Create a resource pool
If you manage a group of resources in more than one project for an ongoing period, you can create a new project
file that contains only resource information (no tasks), and then have all projects use this project's pool of 
common resources when they are assigned resources. You can also update the pool with current information so 
that the resource pool is up to date when you schedule other projects.

1 Open a new project file.
2 If your existing projects already contain resources, switch to each project, and then, in turn, have each project 

share resources with the new project.

          How?  
Resource information from each project is added to the new project and made available to each other.

3 Click Save    .
If this is the first time you've saved the project file, type a name for the project in the File name box, and then 
click Save.

Tip      Occasionally, you may need to stop sharing resources across projects, for example, when your resources 
are assigned exclusively to your project. On the Tools menu, point to Resources, and then click Share 
Resources. Click Use own resources to disconnect the project file from the resource pool.



Use another project's resources in your project
Balancing the usage of resources shared between projects doesn't require a lot of preparation. You can "borrow" 
resources from an existing project and stop sharing resources whenever you want. When you do this, all of the 
resources in the pool project, as well as the projects that are sharing resources with it, are combined and 
available to your project.

1 Open the project containing the resources you want to use in your project.
2 On the Tools menu, point to Resources, and then click Share Resources.
3 Click Use Resources, and then click the project file in the From box that contains the resources you want to 

use.
If you want the information in the active project file to take precedence when the active file and the resource 
pool file contain calendars or resources with the same name, click Sharer takes precedence.

4 Click OK.
The resources are now available in the active project file, and you can assign them just as you would assign 
any resources. If your project already had its own resources, the resources from both projects are combined.



Update the resource pool
After you create a resource pool, assign resources, and start tracking actual information, you need to update the 
pool with the latest information so that it is available to project managers who might be working on other projects 
sharing resources from the pool at the same time.

· On the Tools menu, point to Resources, and then click Update Resource Pool.



Review resource assignments in all projects
Occasionally, you may want to see all the resource assignments for a particular resource across all the projects 
the resource is working on. Because resource assignment information is stored in the resource pool, you can do 
this quickly by opening the project file containing the pool of resources working on multiple projects.

1 Open the project file containing the pool of resources shared by all projects.

2 On the View Bar, click Resource Usage    , and then review the resource assignments you want.



Check if tasks are progressing according to plan
To keep your project on schedule, you need to make sure that tasks start and finish on time as much as possible.
Of course, there will always be tasks that do not start on time or run behind schedule. It is important to find tasks 
that vary from the baseline plan as soon as possible, so you can adjust task dependencies, reassign resources, 
or delete some tasks to meet your deadlines.

1 On the View Bar, click Tracking Gantt    .
2 On the View menu, point to Table, and then click Variance.
3 Drag the divider bar to the right to view the variance fields.

Note      You must have saved a baseline in order to have variance information.



Enter actual start and finish dates for a task
It's important to track whether tasks start and finish on time. Tasks that start or finish late can throw an entire 
project off schedule by delaying the start or finish dates of related tasks. Tasks that start or finish early can free 
resources to work on other tasks that are behind schedule. Microsoft Project uses the actual values you enter to 
reschedule the remaining portions of your project.

1 In the Task Name field, select the task you want to update.
2 On the Tools menu, point to Tracking, and then click Update Tasks.
3 Under Actual, type the dates in the Start and Finish boxes.
Note      Entering an actual start date or actual finish date for a task changes the corresponding scheduled date 
for that task. Baseline dates, however, are not affected by changes you make to the actual or scheduled dates.
Tip      If a number of tasks started and finished on time, you can set the actual start and actual finish information 
for all of those tasks at once. In the Task Name field, select the tasks that started and finished on time. On the 
Tools menu, point to Tracking, click Update Project, and then click Selected tasks.



Enter the actual duration of a task
If you know the number of days that a task has been in progress and it is progressing as planned, you can track 
progress by entering the duration for which you've been working on the task. When you enter the actual duration 
of a task, Microsoft Project updates the actual start date, the task's percentage complete, and the duration of the 
task remaining in the schedule.

1 Select the task for which you want to enter the actual duration.
2 On the Tools menu, point to Tracking, and then click Update Tasks.
3 In the Actual dur box, type the actual duration of the task.
Tip      If you think the task is going to be finished sooner or later than originally scheduled, you can enter a new 
value in the Remaining dur box.
Notes
· If you use effort-driven scheduling, you should not change the scheduled or actual duration of tasks. Instead, 

adjust the amount of work for the resource or resource units to change the task duration.
· Microsoft Project displays a check mark in the Indicators field for a completed task.
· If the actual duration of a task is greater than the scheduled duration, you should enter the actual amount of 

work for the task. Microsoft Project changes the actual finish date to reflect the increased amount of work and 
also increases the task duration. If you enter an actual duration for a task that is greater than the scheduled 
duration, Microsoft Project updates the scheduled task duration to equal the actual task duration, changes the 
remaining task duration to zero, and marks the task as 100 percent complete.



Update a task's progress as a percentage
You can indicate how much progress has been made on a task by entering the percentage of the task duration 
that is complete. For tasks that are relatively short in duration, it may not be worthwhile to track progress in such 
detail; but for tasks of an extended duration, indicating the percentage complete of the task helps you track 
actual progress against the baseline plan. By default, Microsoft Project indicates the task's percentage complete 
on the Gantt Chart as a thin, black line drawn horizontally through the middle of each task bar.

1 Select the task for which you want to update progress.

2 Click Task Information    , and then click the General tab.
3 In the Percent complete box, type a whole number between 0 and 100.

Notes
· Microsoft Project calculates the summary task's percentage complete based on the progress of its subtasks. 

You can also manually enter the summary task's percentage complete, which Microsoft Project will use to 
calculate the percentage complete of its subtasks.

· Microsoft Project displays a check mark in the Indicators field for a completed task.
Tips
· To indicate progress on a recurring task, add the % Complete field to your Gantt Chart and type the number in

that field. On the View Bar, click Gantt Chart    , and then click Column on the Insert menu. Click % 
Complete in the Field name box, and then enter the percentage in the % Complete field for the recurring 
task.

· You can use the buttons on the Tracking toolbar to update progress on a task and to perform other tracking 
activities. On the View menu, point to Toolbars, and then click Tracking.



See if tasks have more or less work than planned
If you're managing resource assignments in your project, you need to make sure that resources are completing 
their tasks in the amount of time scheduled. Variances in your schedule can be good as well as bad, depending 
on the type and severity of the variance. A task with less work than planned, for example, is normally good news, 
but may indicate that your resources are not allocated efficiently.

1 On the View Bar, click Gantt Chart    .
2 On the View menu, point to Table, and then click Work.
3 Drag the divider bar to the right to view the Baseline field.

4 Compare the values in the Work and Baseline fields.
To see the variance between the baseline and actual work, look at the values in the Variance field.



Update actual work on a daily basis
You can track actual work using the timephased fields in Microsoft Project. This can be a useful way of keeping 
your project up-to-date on a daily or weekly basis, because you can enter information for a particular day in your 
schedule.

1 On the View Bar, click Task Usage    .
2 On the View menu, point to Table, and then click Work.
3 Drag the divider bar to the right to view the Actual field.

4 In the Actual Work field, type the updated work value and the duration abbreviation for the actual work of 
each assigned resource.

Tip      If it makes no difference which of the resources assigned to a task performs the work, then type a value for
the combined work done on the task by all the resources in the Actual field for the task. Microsoft Project divides
the actual and remaining work among the resources based on where they are scheduled on the task and the 
remaining work for each assignment.



Enter actual costs for a task
Microsoft Project automatically updates actual costs as a task progresses based on the task's accrual method. 
But if you want to track actual costs separately from the actual work on a task, you can enter costs manually 
instead of allowing Microsoft Project to calculate them. First, you must turn off the automatic updating of actual 
costs and then, if you want to enter your own actual cost for a resource assignment, you can do so after the 
remaining work is zero.

1 On the Tools menu, click Options, and then click the Calculation tab.
2 Clear the Actual costs are always calculated by Microsoft Project check box.
3 Click OK.

4 On the View Bar, click Task Usage    .
5 On the View menu, point to Table, and then click Tracking.
6 Drag the divider bar to the right to view the Act. Cost field.

7 In the Act. Cost field, type the actual cost for the assignment for which you want to update costs.
Tips
· You can set the fixed cost for a task to accrue at the beginning or the completion of a task or to be prorated for

the length of the task. Click Gantt Chart on the View Bar. On the View menu, click Table, and then click 
Cost. In the Fixed Cost Accrual field, select the accrual method you want.

· Sometimes resource assignment costs include a per-use cost for items such as equipment costs, setup 
charges, delivery, or rental fees, in addition to a standard rate. You can change the fixed amount charged to a 

resource each time it is assigned to a task by clicking Resource Sheet        on the View Bar, and then 
typing a new cost in the Cost/Use field for the resource whose per-use cost you want to change.



Update actual costs on a daily basis
You can track actual costs using the timephased fields in Microsoft Project. This can be a useful way of keeping 
your project up-to-date on a daily or weekly basis, because you can enter information for a particular day in your 
schedule.

Microsoft Project automatically updates actual costs as a task progresses based on the accrual method you set. 
First, you must turn off the automatic updating of actual costs to make the actual costs editable and then, if you 
want to enter your own actual cost for a resource assignment, you can do so after the remaining work is zero.

1 On the Tools menu, click Options, and then click the Calculation tab.
2 Clear the Actual costs are always calculated by Microsoft Project check box.
3 Click OK.

4 On the View Bar, click Task Usage    .
5 On the View menu, point to Table, and then click Cost.
6 On the Format menu, point to Details, and then click Cost.

7 On the Format menu, point to Details, and then click Actual Cost.
8 To enter actual values for a task, select the column for the day you want to track, and then type a value into 

the field of the task.
To enter actual values for a resource assignment, select the column for the day you want to track, and then 
type a value into the field of the resource.



See the cost variance of the entire project
You can view your project's current, baseline, actual, and remaining costs to see whether you're staying within 
your overall budget. These costs are updated each time Microsoft Project recalculates your project.

1 On the Project menu, click Project Information.
2 Click Statistics.



See if tasks cost more or less than budgeted
If you're assigning fixed costs to tasks or specifying wages for resources, you may want to see tasks accruing 
more cost than budgeted. By creating a budget using a baseline planand closely tracking your project costs, you 
can catch cost overruns early and adjust either your schedule or your budget accordingly.

Microsoft Project calculates the cost of each resource's work, the total cost for each task and resource, and the 
total project cost. These costs are considered scheduled or projected costs, which reflect the latest cost picture 
as the project progresses.

1 On the View Bar, click Gantt Chart    .
2 On the View menu, point to Table, and then click Cost.
3 Drag the divider bar to the right to view the Total Cost and Baseline fields.

4 Compare the values in the Total Cost and Baseline fields.
For the cost variance, look at the value in the Variance field.

Tips
· You can compare the baseline total cost of your project to the actual total cost. On the Project menu, click 

Project Information, and then click Statistics. In the Cost column, compare the values in the Baseline and 
Actual fields.

· You can check the resources assigned to a task and the resource costs related to that task. On the View Bar, 

click Task Usage    . On the View menu, point to Table, and then click Cost. Drag the divider bar to the 
right and compare the values in the Total Cost, Baseline, Actual, and Remaining fields for the resources 
assigned to that task.



Analyze costs with the Earned Value table
When you want to compare your expected progress with the actual progress to date for tasks that have 
resources assigned, you can use the Earned Value table. It expresses, in terms of resource costs, each task's 
actual percentage complete.

You can also use the Earned Value table to forecast whether the task will finish under or over budget based on 
the cost incurred while the task is in progress. For example, if a task is 50 percent complete and the actual cost 
incurred to date is $200, you can see if $200 is more, less, or equal to 50 percent of the baseline (or budgeted) 
cost.

1 On the View Bar, click Gantt Chart    .
2 On the View menu, point to Table, and then click More Tables.
3 In the Tables list, click Earned Value, and then click Apply.
4 Drag the divider bar to the right to display all of the Earned Value table fields.

Tips

· You can also view earned value data on a daily basis. On the View Bar, click Task Usage    . On the 
Format menu, click Detail Styles, and then click the Usage Details tab. In the Available fields list, hold 
down CTRL, click the fields you want to display, and then click Show.

· You can set a project status date for the purpose of calculating the values of fields in the Earned Value table.
Microsoft Project will calculate the value of these fields based on the actual work and costs up through and including 
the project status date. If you do not set the project status date, Microsoft Project will use the current date to calculate
these fields. On the Project menu, click Project Information. In the Status date box, type the date you want 
Microsoft Project to use as a status date.



Enter the total actual work done by a resource
If you're scheduling tasks based on the availability of resources, you should track the progress of your tasks by 
updating the work completed on a task. Using this updating approach, you can track the work that each resource 
is performing.

When you update the actual work a resource has done on a task, Microsoft Project automatically calculates the 
work remaining by subtracting the actual work done by the resource from the total work the resource is 
scheduled to do.

1 On the View Bar, click Task Usage    .
2 On the View menu, point to Table, and then click Work.
3 Drag the divider bar to the right to view the Actual field.

4 In the Actual Work field, type the updated work value and the duration abbreviation for the actual work of 
each assigned resource.

Tip      If it makes no difference which of the resources assigned to a task performs the work, then type a value for
the combined work done on the task by all the resources in the Actual field for the task. Microsoft Project divides
the actual and remaining work among the resources based on where they are scheduled on the task and the 
remaining work for each assignment.



Update a resource's actual work on a daily basis
You can track actual work using the timephased fields in Microsoft Project. This can be a useful way of keeping 
your project up-to-date on a daily or weekly basis, because you can enter information for a particular day in your 
schedule.

1 On the View Bar, scroll down and click Resource Usage    .
2 On the View menu, point to Table, and then click Work.
3 On the Format menu, point to Details, and then click Actual Work.
4 In the Actual Work field, type the updated work value and the duration abbreviation for the resource's actual
work on each assigned task.



See the variance between a resource's planned and actual work
If you're scheduling tasks based on the availability of resources and you're tracking actual work, you can analyze 
how much total work a resource is accomplishing by looking at the variance between the baseline work and 
actual work. You can also compare those figures to the baseline work and actual work on a daily basis to see in 
greater detail how the resource's work is progressing.

1 On the View Bar, scroll down and click Resource Usage    .
2 On the View menu, point to Table, and then click Work.
3 Drag the divider bar to the right to view the Baseline and Actual Work fields.
4 Compare the values in the Baseline and Actual Work fields for each resource.
5 On the Format menu, point to Details, and then click Work.

6 On the Format menu, point to Details, and then click Actual Work.
7 In the Details column on the timescale portion of the view, compare the Work and Actual Work fields for a 

daily summary of each resource's work.



Baseline plan

The original project plan you use to track progress during a project. The baseline plan includes task start and 
finish dates and resource and cost information.



Project calendar

The base calendar used by a project.



Base calendar

A calendar that specifies working and nonworking time for a project or set of resources. A base calendar differs 
from a resource calendar, which specifies working and nonworking time for an individual resource.



Constraint

A restriction or limitation you set on the start or finish date of a task. For example, you can specify that a task 
must start on a particular date or finish no later than a particular date.



Critical path

The series of tasks that must be completed on schedule for a project to finish on schedule. Each task on the 
critical path is a critical task.



Critical task

A task that must be completed on schedule for the project to finish on time. If a critical task is delayed, the project
completion date is also delayed. A series of critical tasks makes up a project's critical path.



Lag time

A delay between tasks that have a dependency. For example, if you need a two-day delay between the finish of 
one task and the start of another, you can establish a finish-to-start relationship and specify a two-day lag time. 
You enter lag time as a positive value.



Lead time

An overlap between tasks that have a dependency. For example, if a task can start when its predecessor is 
halffinished, you can specify a finish-to-start relationship with a lead time of 50 percent for the successor task. 
You enter lead time as a negative value.



Resource group

A set of resources that shares some characteristic, categorized by a group name. For example, you can 
categorize resources by job function and use group names such as plumbers or editors. Or, you can categorize 
resources by employment status and use group names such as contractors and permanent employees.



Resource List

The list of resources that you amass in the Assign Resources box, which you bring up by clicking the Assign 
Resources button located on the Standard toolbar.

If you're planning on communicating with these resources across e-mail, you must add each resource's e-mail 
address to their Resource Information. To get to a resource's information, double-click a resource's name in the
Assign Resources box.



Resources

The people, equipment, and supplies used to complete tasks in a project. 



Successor

A task that cannot start or finish until another task starts or finishes.



Filter

A tool you use to specify which task or resource information should be displayed or highlighted in a view. For 
example, when you apply the Critical filter, only critical tasks are displayed.



Footer

Text that appears at the bottom of every printed page. A footer typically contains information such as page 
number, total page count, and date.



Header

Text that appears at the top of every printed page. A header typically contains information such as the project or 
company name and the project start and finish dates.



Resource pool

A set of resources available for assignment to project tasks. A resource pool can be used exclusively by one 
project or can be shared by several projects.



Resource view

A view that displays resource information. Resource views include the Resource Sheet, the Resource Graph, the
Resource Usage view, and resource forms.



Work breakdown structure (WBS)

A hierarchical structure used to organize tasks for reporting schedules and tracking costs. With Microsoft Project,
you can represent the work breakdown structure by using task IDs or by assigning your own WBS code to each 
task.



Legend

The explanatory list of symbols printed on a chart or graph.



Accrual method

Determines when the cost for a resource is incurred and when actual costs are charged to a project. You can 
incur costs at the start or finish of a task or prorate them during the task.

To Select
Accrue the cost when 
the task begins

Start

Accrue the cost when 
the task is completed

End

Accrue the cost based 
on the percentage of 
completion of the task

Prorated

Divider bar

The vertical bar that separates the chart from the table or legend in the Gantt Chart, Resource Graph, and 
Resource Usage view.



Task dependencies (FS, SS, FF, SF)

The nature of the dependencies between linked tasks. You link tasks by defining a dependency between their 
finish and start dates. For example, the "Contact caterers" task must finish before the start of the "Determine 
menus" task. There are four kinds of task dependencies in Microsoft Project:

Finish-to-start (FS) The task (B) cannot start 
until another task (A) 
finishes.

Start-to-start (SS) The task (B) cannot start 
until another task (A) starts.

Finish-to-finish (FF) The task (B) cannot finish 
until another task (A) 
finishes.

Start-to-finish (SF) The task (B) cannot finish 
until another task (A) starts.

Schedule

The timing and sequence of tasks within a project. The schedule consists mainly of tasks, dependencies among 
the tasks, durations, constraints, and time-oriented project information.



External task
When you link tasks between standalone projects, Microsoft Project displays external tasks in each project. An 
external task represents the task in the other project to which the task is linked, providing an easy way to review 
the attributes of the linked tasks without switching between projects. You can format an external task and edit the
links between tasks. You cannot, however, edit an external task. An external tasks can only be changed in the 
source project.



Field

A location in a sheet, form, or chart that contains a specific kind of information about a task or resource. For 
example, in a sheet, a field is the intersection of a column and a row. In a form, a field is a named box or a place 
in a column. In a PERT Chart, fields are contained in each PERT box.



Resource-driven scheduling

A scheduling method that bases a task's duration on the amount of work the task requires and the number of 
resource units assigned to it. Resource-driven scheduling is the default scheduling method in Microsoft Project.



Recurring task

A task that occurs repeatedly during the course of a project. You might define the weekly status meeting as a 
recurring task, for example.



Interactive filter

A filter that displays a dialog box for entering filter criteria each time you apply the filter. For example, the Using 
Resource filter displays a dialog box in which you enter a resource name. Microsoft Project then displays all the 
tasks that are using that resource.



Interim plan

A set of task start and finish dates, and sometimes resource and cost information, that you can save at certain 
stages of your project. You can compare an interim plan with the baseline plan to monitor project progress or 
slippage. You can save up to ten interim plans.



Cost

The total scheduled cost for a task, resource, resource assignment, or for an entire project. Sometimes this is 
also called current cost, or budget.



View

The combination of one or more views (Gantt Chart, Resource Sheet, and so on) and, if applicable, a table and a
filter. Using views, you can enter, organize, and examine information in a variety of formats.

There are three types of views:

Charts or graphs represent information graphically. The Gantt Chart, PERT Chart, Resource Graph, and 
Calendar are charts or graphs.

Sheets represent information in rows and columns. Each row contains information about an individual task or 
resource. Each column contains a set of fields in which you enter specific information about tasks or resources.

Forms represent information in a format similar to a dialog box. Forms show information about only one task or 
resource at a time.



Milestone

A reference point marking a major event in a project, used to monitor the project's progress. Any task with zero 
duration is displayed as a milestone.



Outline

A hierarchical structure for a project that shows how some tasks fit within broader groupings. In Microsoft Project,
subtasks are indented under summary tasks.



Fixed cost

A cost that remains constant regardless of the task duration or the work performed by a resource.



Timescale

The indicator of time periods that appears at the top of the Gantt Chart, the Resource Graph, Task Usage, and 
the Resource Usage view. The timescale consists of a major timescale and, below it, a minor timescale. Both the
major and the minor timescale can display units of minutes, hours, days, weeks, months, quarters, and years. 
For example, the major timescale can display units of months while the minor timescale displays units of weeks.



Predecessor

A task that must start or finish before another task can start or finish.



Consolidated file

A file that contains copies of one or more inserted project files. The inserted projects can retain links to their 
source projects so that any changes to the inserted projects in the consolidated file are passed on to the source 
file.



Summary task

A task that is made up of subtasks and that also summarizes those subtasks. You can use the Microsoft Project 
outlining feature to create summary tasks. Microsoft Project automatically determines summary task information 
(duration, cost, and so on) using information from the subtasks.



Highlighting filter

A filter that displays all tasks or resources and highlights the tasks or resources that match the filter criteria.



Linking

In a project, establishing a dependency between tasks. When you link tasks, you define a relationship between 
their start and finish dates. There are four kinds of task dependencies: finish-to-start (FS), start-to-start (SS), 
finish-to-finish (FF), and start-to-finish (SF).



Actual

Information that shows what has actually occurred. For example, the actual start for a task is the day the task 
started and its actual cost is the amount spent up to the present.



Slack

The amount of time a task can slip before it affects another task's dates or the project finish date. Slack is 
sometimes referred to as float time.

Free slack is the amount of time a task can slip before it delays another task.

Total slack is the amount of time a task can slip before it delays the project finish date.

When the total slack is negative, the duration for a task is too long for its successor to begin on the date required 
by its constraint.



Table

A set of columns that shows specific information about tasks or resources in a sheet view.



Task

A job that has a beginning and an ending. The completion of a task is important to the project's completion. 
Projects are made up of tasks. A task is sometimes referred to as an activity.



Units

The number of units or the quantity of a resource assigned to a task. For example, if you have a plumbing task, 
you could assign two units, or two plumbers, to the task. If you have one plumber, you could assign .5 units (half 
of the plumber's time) to the task. The maximum units is the maximum number of units available for the resource.
For example, if you have three plumbers working on a project, the maximum units is three---three plumbers 
working full-time.



Resource calendar

A calendar that specifies working and nonworking time for an individual resource. A resource calendar differs 
from a base calendar, which specifies working and nonworking time for more than one resource. You can use 
resource calendars to define unique exceptions for individual resources, such as vacations, different working 
days, or different shifts.



Duration

The amount of time required to complete a task. Elapsed duration includes working and nonworking time.

A duration value is followed by a time unit abbreviation:

Working time Elapsed time
min = minute emin = elapsed 

minutes
hr = hour ehr = elapsed hours
day = day edays = elapsed days
wk = week ewk = elapsed weeks

Overallocation

The result of assigning more tasks to a resource than the resource can accomplish in the working time available. 
Microsoft Project determines which resources are overallocated based on the work and duration values for 
assigned tasks, the maximum number of units available for the resource, and the calendar used by the resource.



Sheet

A spreadsheet-like representation (in rows and columns) of task or resource information. Each row specifies an 
individual task or resource, such as the "Design package" task or the Advertising Agency resource. Each column 
specifies a type of information, such as start dates or standard rates.



Subtask

A task that is part of a summary task. The subtask information is consolidated into the summary task. You can 
designate subtasks using the Microsoft Project outlining feature.



Variance

The difference between baseline and scheduled task or resource information. Variances usually occur when you 
set a baseline plan and begin entering actual information into your schedule. Variances in task information 
usually refer to differences between baseline and scheduled dates. Variances in resource information usually 
refer to differences between baseline and scheduled work and costs.



Task view

A view that displays task information. Task views include three task forms and the following views:

· Bar Rollup
· Calendar
· Detail Gantt
· Gantt Chart
· Leveling Gantt
· Milestone Date Rollup
· Milestone Rollup
· PA_Expected Gantt
· PA_Optimistic Gantt
· PA_PERT Entry Sheet
· PA_Pessimistic Gantt
· PERT Chart
· Task Entry
· Task PERT
· Task Sheet
· Task Usage
· Tracking Gantt



Overtime

The amount of work beyond a resource's normal working hours. It is the amount of existing work that is 
considered by Microsoft Project to be overtime work. When overtime hours are entered for a resource, Microsoft 
Project subtracts overtime hours from regular hours before the duration is calculated.

Duration = (Work – Overtime Work) ÷ Units




