
Commands and tools
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click a letter to go to that section.

To display help for a command while working in Visio, pause the pointer over the command, and then 
press the F1 key. You can also click the Help button in most dialog boxes.

1, 2, 3... Pages and Backgrounds
1, 2, 3, 4 Files
1, 2, 3... More Windows

A
About Visio
Action
Actions Submenu
Activate
Actual Size (100%)
Add To Favorites
Add To Group
Align Shapes
Arc tool
Arrange Icons
Auto Arrange
Automation Reference

B
Back button
Background
Behavior
Bring Forward
Bring To Front



Browse Sample Drawings
Browse Templates
Bullet tool

C
Cascade
Center Drawing
Change Row Type
Change Source dialog box
Change Timeline Units
Chart Shape Wizard
Choose A Drawing Template dialog box
Clear
Clip Art
Close
Close (stencil)
Color Palette
Combine
Configure Task Bar Sizes
Configure Task Bar Text
Configure Timeline Symbols
Configure Working Days
Connect Shapes
Connection point tool
Connection Points
Connector tool
Control
Convert <OLE object>
Convert To Group
Copy, Copy Drawing
Copy Hyperlink
Corners
Crop tool
Custom Fit
Custom Line Weight
Custom Properties
Custom Properties Editor
Cut

D
Data Map
Database Export
Database Refresh
Database Settings
Database Update
Database Wizard
Days/Months
Define Styles
Delete Column
Delete Page
Delete Row (Edit menu)
Delete Row (Project Timeline Template)
Delete Section



Delete Shape and Record
Demote Tasks
Design mode button
Developer toolbar
Distribute Shapes
Double-Click
Drawing
Drawing Page submenu
Drawing Resources
Duplicate

E
Edit Color dialog box
Edit Icon
Edit Master
Edit <OLE object>
Edit Text
Ellipse tool
Exchange Folder
Exit
Export [data]
Export Project

F
Field
Fill
Fill Color tool
Fill Pattern tool
Find
First Tile
Fit Curve
Flip Horizontal
Flip Vertical
Float
Flowchart-TQM Diagram Wizard
Foreground
Format Painter tool
Formulas
Forward button
Fragment
Freeform tool
Full Screen Preview
Function

G
Go To submenu
Grid
Group
Grouping submenu
Guides

H



Hyperlink
Hyperlink submenu

I
Icon pencil tool
Icons And Names
Icons Only
Import Project
Insert Column
Insert Control
Insert Row
Intersect

J - K
Join

L
Lasso tool
Last Tile
Last Zoom
Lay Out Shapes dialog box
Layer Properties
Left Color box
Line
Line tool
Link All Tasks
Links
Link Tasks
Lotus Notes Field

M
Macro submenu
Macros
Mail Recipient
Make Department, Make Subpage
Months/Years

N
Name
Names Only
New Drawing
New submenu
New Layer dialog box
New Master
New Window
Next Page
Next Tile

O
Object (Edit)



Object (Insert)
Offset
Online Support
Open
Open Group
Open Hyperlink
Open In New Window
Open In Visio
Open Stencil
Operations submenu
Options dialog box
Organization Chart Wizard

P
Page (Go To submenu)
Page (Insert menu)
Page Breaks
Page Layout Wizard
Page Setup dialog box
Page toolbar
Page Width
Paint Bucket tool
Paste
Paste As Hyperlink
Paste Special
Pencil tool
Picture
Pointer tool
Previous Page
Previous Tile
Print
Print Preview
Print Preview toolbar
Print Setup dialog box
Project Timeline Options
Project Timeline Wizard
Promote Tasks
Properties (File menu)
Properties (Master menu)
Property Report
Protect Document
Protection

Q
Quarters/Years

R
Rectangle tool
Redo
Refresh Shape Properties
Remove From Group
Reorder Pages
Repeat



Replace
Reverse Ends
Right Color box
Rotate Left
Rotate Right
Rotate text 90º tool
Rotation tool
Routing Recipient
Row
Row After
Ruler & Grid
Rulers
Run Macro tool

S
Save
Save As
Save As (to a Document Management System)
Save As HTML
Save Workspace
Search The Web
Section
Sections
Select All
Select Color palette
Select Database Record
Select Special
Selection net tool
Send Backward
Send To Back
Send To submenu
Set To L Connectors
Set To S Connectors
Shadow
Shadow Color tool
Shape Explorer
Shape Help
Shape Layer
Shape toolbar
Show Drawing Page
Show Master Shapes
Show ShapeSheet
Show Task Bar
Single Tile
Size & Position (shape selected)
Size & Position (guide selected)
SmartShape Wizard
Snap & Glue
Special
Spelling
Stamp tool
Standard toolbar
Status Bar
Stencil Report Wizard



Stencils submenu
Style
Subtract
Switch Sides

T
Tab Properties
Template Help
Text dialog box
Text block tool
Text tool
Text toolbar
Tile
Toolbars
Toolbars submenu
Transparent Color box
Trim

U
Undo
Ungroup
Union
Unlink All Tasks
Unlink Tasks
Unprotect Document
Update Alignment Box
Update Database Record
Update Icon

V
Values
View End Date
View Next Date
View Previous Date
View Start Date
View Timeline Range
View toolbar
Visual Basic Editor
Visio DWG Display Properties (General tab)
Visio On The Web submenu
Visio Home Page
Visio Solutions Library

W - Y
Web toolbar
What's This?
Whole Page

Z
Zoom (Custom)
Zoom %



Zoom In
Zoom Out
Zoom submenu



Actions submenu
    Related Topics

Shape menu, drawing window
Displays a list of commands that correspond to actions you can perform with the shape. This list changes 
depending on the shape you select. For example, if a shape has custom-properties data associated with 
it, Properties appears on the list and choosing it opens the Custom Properties dialog box. If a shape has 
no actions, the Actions submenu is not available.

The commands listed under Actions are also available on a shape's shortcut (right-mouse) menu.

For details about actions related to project timeline shapes, see Project Timeline Template or choose Help
> Visio Help, click Index, then type the action name, such as Link Tasks or View Start Date. 



Drawing Page submenu
    Related Topics

Edit menu, drawing window
Includes commands that remove and change the order of pages in the drawing:

Delete
Reorder



Go To submenu
    Related Topics

Edit menu, drawing and print preview windows
Includes commands for viewing other pages or backgrounds, or a background's foreground:

Foreground
Background
1, 2, 3... Pages and Backgrounds
Page



Grouping submenu
    Related Topics

Shape menu, drawing window
Includes commands for grouping shapes:

Group
Ungroup
Add To Group
Remove From Group
Convert To Group



Hyperlink submenu
    Related Topics

Right-click linked object, drawing window
Includes commands for hyperlinked shapes:

Open
Open In New Window
Copy Hyperlink
Add To Favorites
Edit Hyperlink



New submenu
    Related Topics

File menu
Creates a new drawing or starts one of the Visio wizards. You can

· Base a new drawing on a template by choosing Browse Templates or choosing a template from the 
drawing type submenus.

· Start a new drawing from scratch by choosing Drawing or Blank Drawing.

· Start a wizard to automate a task by choosing the appropriate wizard from the drawing type submenus.

You can also use the new button on the Standard toolbar to start a drawing that is not based on a 
template. Use tips to identify the button.

Tip: To open additional stencils while you are working on a drawing, use File > Stencils. You can also use 
the open stencil button on the Standard toolbar. Use tips to identify the button.



Macro submenu
    Related Topics

Tools menu
Includes commands with which you can run macros you've created, the Visual Basic Editor, the Custom 
Properties Editor, and the Shape Explorer. You can also display other category submenus (for example, 
Business Diagram, Internet Diagram, Network Diagram, Visio Extras) from which you can run wizards, 
macros, and programs called add-ons. For details about running a specific wizard, macro, or add-on, see 
its online help topic.



Operations submenu
    Related Topics

Shape menu, drawing window
Includes commands for combining two or more shapes to create one shape:

Union
Combine
Fragment
Intersect
Subtract
Join
Trim
Offset
Fit Curve
Custom Fit



Send To submenu
    Related Topics

File menu, drawing window
Includes a list of commands you can use to send drawings to another person through electronic mail. 
Visio products are compatible with electronic mail programs that support the Messaging Application 
Program Interface (MAPI) protocol. 

Visio also takes advantage of Microsoft Office 97 routing features, including sending drawings to 
Microsoft Exchange folders, adding routing slips to drawings you send through e-mail, and adding journal 
entries to Outlook.



Stencils submenu
    Related Topics

File menu
Includes a list of drawing types for which Visio includes stencils. When you're working with a drawing, use
the Stencils command (or the Open Stencil button on the Standard toolbar) to open additional stencils, or 
to open an original stencil file so you can add or modify master shapes. 

OTHER SUBMENU COMMANDS

Open Stencil  Displays a dialog box in which you can navigate to the folder that contains the stencil you 
want.

Blank Stencil  Creates a new blank stencil on which you can drag and drop the master shapes you want.
You can then save the stencil as a .vss file to use with future drawings.

Shape Explorer  Opens Shape Explorer, where you can search for and catalog Visio shapes, stencils, 
and templates that are provided with Visio products, on the World Wide Web, in databases you create.



Toolbars submenu
    Related Topics

View menu
Includes commands that display or hide appropriate Visio toolbars, depending on the window you are 
working in. Toolbars that are currently displayed have a check mark next to them; toolbars that are hidden
do not. 

OTHER SUBMENU COMMANDS

Toolbars    Opens a dialog box in which you can choose to display larger toolbar icons or show or hide 
screen tips that identify tools on the screen when you pause your mouse over them.



Visio On The Web submenu

Help menu
Includes commands that open your World Wide Web browser application to search the Internet; browse 
resources for drawing, online technical support, and Visio templates and stencils; and view the Visio 
home page on the Web:

Search The Web
Drawing Resources
Online Support
Visio Solutions Library
Visio Home Page



Zoom submenu
    Related Topics

View menu, drawing window
Includes commands for changing the magnification of the view. To choose a different zoom percentage, 
choose the Custom command.



1, 2, 3, 4... More Files
    Related Topics

File menu
Opens one of the last files you closed. Choose the number that corresponds to the file you want to open. 
Choosing a numbered file from the File menu is a convenient alternative to the Open command, because 
Visio opens the file without displaying the Open dialog box.



1, 2, 3... More Windows
    Related Topics

Window menu
Opens the drawing, stencil (if it's open as a copy or original), or ShapeSheet window that corresponds to 
a number and brings it to the front. More Windows displays a list from which you can select a window. 
The More Windows command appears on the menu only if there are more than nine windows open.



1, 2, 3... Pages and Backgrounds
    Related Topics

Edit > Go To, drawing and print preview windows
Displays the selected page or background in the drawing window.



About Visio
    Related Topics

Help menu
Identifies the version of Visio you are using and displays copyright information. 



Action
    Related Topics

Edit menu, ShapeSheet window
Assigns an action to a shape. The action appears on the shape's shortcut (right-mouse) menu. The 
command is dimmed unless you have inserted an Actions section (by choosing Section from the Insert 
menu, then checking Actions) and selected a cell.

DIALOG BOX OPTIONS
Properties  Specifies the menu command name, status bar prompt, and online help topic for the shortcut 
menu command.

Menu    Specifies the menu command to add to the shape's shortcut menu.

Prompt    Adds a status bar prompt for the shortcut menu command.

Help    When the user selects this menu command on the shortcut menu, then presses F1, the help 
topic for the command appears. The syntax is:

FILENAME.HLP!keyword or FILENAME.HLP!#Number

where filename is the Windows help file, keyword is the index term associated with the Help topic, 
and number is a numeric ID which is referenced in the MAP section of the Help project file (HPJ). For 
information on developing Microsoft Windows online help, see the Microsoft Platform SDK 
documentation.

Action    Specifies the action performed by the shortcut menu command.

Edit Shape's Text    Opens the shape's text block.

Open Group In New Window    Opens a group in the group window.

Show ShapeSheet    Opens the ShapeSheet window.

Custom    Performs custom action. You enter the formula for this action directly in the Action section of 
the ShapeSheet spreadsheet.

OLE Verb    Activates OLE options, such as Edit, when an OLE object is double-clicked.

Run Macro    Activates the macro or wizard selected from the list.

Display Help    Opens an online help topic. Uses the same syntax as described in the Special dialog 
box.

Go To Page    Displays a specific drawing page.

Open In New Window    Displays a specific drawing page in a new window.



Activate (stencil)
    Related Topics

Right-click a docked stencil's title bar
When multiple stencils are open, Activate brings the stencil you right-click to the front, displaying that 
stencil's masters. This command is available only when multiple stencils are open and docked, but is not 
available on the front-most (active) stencil.

Note: You can also click a stencil's title bar to activate it.



Actual Size (100%) (Ctrl+I)
    Related Topics

View menu, drawing and print preview windows
Displays the page at approximately its actual printed size. If a shape is selected in the drawing window, 
the view is centered on the shape. If nothing is selected, the view is centered on whatever was in the 
center of the previous view.

You can also choose 100% from the zoom list on the Standard toolbar. Use tips to identify the zoom list.



Add To Group
    Related Topics

Shape > Grouping, drawing window
Adds the selected shape to the selected group without affecting the group in other ways. The added 
shape remains in its current location, and Visio repositions the group's selection rectangle to encompass 
it. The shape keeps its own ShapeSheet spreadsheet, and Visio updates the group's ShapeSheet 
spreadsheet to reflect the added shape.

While holding down the Shift key, select the group to which you want to add the shapes and the shapes 
you want to add. You can add a group to another group.

Bitmaps
A metafile can contain a bitmap or consist solely of a bitmap. Visio cannot convert bitmaps into shapes. 
However, a metafile that consists of a single bitmap sometimes stores the bitmap in separate segments. 
In that case, the Add To Group command converts each segment of the metafile into an individual bitmap 
object.

Linked objects
If an object from another program is linked, adding the object to a group breaks the object's link to its 
original file. Edits you make to the object in the original program will no longer be reflected in the copy in 
Visio.



Add To Favorites
    Related Topics

Hyperlink submenu
Opens a dialog box in which you can add the linked object to the Favorites folder so that you can navigate
to it quickly later.



Align Shapes (F8)
    Related Topics

Tools menu, drawing window
Aligns selected shapes with the first shape you select (the one that displays green selection handles). If 
you dragged the pointer tool around a group of shapes to select them, they are aligned with the shape at 
the front of the stacking order (also indicated by green selection handles if 25 or fewer shapes are 
selected).

You can also use the align shapes palette on the Shape toolbar to display alignment options. Use tips to 
identify the palette. To choose an alignment option, click the toolbar button and hold down the mouse 
button. 

Click to display information about the dialog box.



Determines vertical alignment.



Aligns the tops of shapes.



Aligns shapes along their vertical centers.



Aligns the bottoms of shapes.



No vertical alignment (default).



Determines horizontal alignment.



Aligns the left sides of shapes.



Aligns shapes along their horizontal centers.



Aligns the right sides of shapes.



No horizontal alignment (default).



If checked, creates a guide and glues selected shapes to the guide to retain the alignment. When you 
move the guide, the shapes move with it.



 Arc tool (Ctrl+7)
    Related Topics

Standard toolbar
Use the arc tool to draw elliptical quarter-arc segments. A single arc is a 1-D shape when you first draw it. 
Adding other arc and line segments creates a 2-D shape.

The way you drag the mouse determines whether the arc has a horizontal axis (the end point is right or 
left of the begin point) or vertical axis (the end point is above or below the begin point). If the end point is 
exactly horizontal or vertical to the begin point, the arc becomes a straight line.

You can use the arc tool, line tool, pencil tool, or freeform tool to draw shapes of contiguous segments. 



Arrange Icons
    Related Topics

Window menu, right-click in stencil window
Note: This command is available only when you have an original stencil open.

Arranges master shape icons in the stencil window into rows. The stencil window must be active.



 Auto Arrange
    Related Topics

View menu, right-click in stencil window
Note: This command is available only when you have an original stencil open.

When Auto Arrange is checked, master shape icons are rearranged in the stencil window after the window
is resized or when icons are added to or deleted from a stencil. The stencil window must be active.



Automation Reference
    Related Topics

Help menu
Opens the Visio Automation Reference—online help that contains information about creating Visio 
macros with Visual Basic for Applications (VBA).



Back button
    Related Topics

Web toolbar
Pages back in a Web document.



Background
    Related Topics

Edit > Go To, drawing and print preview windows
Displays the background page assigned to the page displayed in the drawing window. This command is 
available only when the displayed page has a background assigned to it. Choose Foreground to return to 
the foreground page of a drawing.



Behavior
    Related Topics

Format menu, drawing and ShapeSheet windows
Opens a dialog box where you can specify options for shape behavior.

Interaction Style  Sets whether a shape behaves as a 1-D or a 2-D shape.

Selection Highlighting  Sets the way a shape is displayed onscreen.

Resize Behavior  Determines how a shape or other object within a group resizes when you resize the 
group.

Layout Behavior  Determines how a 2-D shape interacts with routable connectors, and whether or not 
it's included in a layout when you choose the Lay Out Shapes command. You can set the shape so that 
routable connectors can detect it and route around it rather than cross through it. A 2-D shape that 
routable connectors can detect is called a "placeable" shape.

Let Visio Decide  Allows Visio to determine when to make the shape placeable, based on the type of 
connector you glue to the shape. Visio makes the shape placeable if you glue a Dynamic Connector, or
other routable connector, to it.

Layout And Route Around  Makes a 2-D shape placeable in all cases. Routable connectors always 
route around it, and it is always included in an automatic layout. For organization charts, flowcharts, 
and network and software diagrams, this is the default setting for 2-D shapes.

Do Not Layout And Route Around  Sets a shape so it's never placeable. Routable connectors cannot
detect it, and it is not included in an automatic layout.

Non-Printing Shape  When checked, makes the shape non-printing. The shape still appears onscreen, 
but when you print the drawing, the shape does not appear on the printed page.



Bring Forward 
    Related Topics

Shape menu, drawing window
Moves selected shapes forward one position in the stacking order. If multiple shapes are selected, they all
move closer to the front and keep their original stacking order in relation to each other.



Bring To Front (Ctrl+F)
    Related Topics

Shape menu, drawing window
Moves selected shapes to the front of the stacking order for shapes on a page. If multiple shapes are 
selected, they all move to the front and keep their original stacking order in relation to each other.

You can also use the bring to front button on the Shape toolbar. Use tips to identify the button.



Browse Sample Drawings

File > New > Browse Sample Drawings
Opens the Browse Sample Drawings dialog box, where you can double-click a solutions folder to see 
sample Visio drawing files. To preview a sample drawing, select it. A thumbnail appears under preview. To
open a sample drawing, select it, then click Open.



Browse Templates
    Related Topics

File > New > Browse Templates
Opens the New Drawing dialog box, where you can double-click a template icon to open a template. The 
templates that appear in the dialog box are in the solutions folder you last opened when you started Visio.
To choose a different solutions folder, click the up one level button.

DIALOG BOX OPTIONS
Look In  Displays the current folder. Double-click the folder you want to open.

Up One Level  Moves the Look In folder up one level in the hierarchy.

Create New Folder  Creates a new folder in the current hierarchy.

List  Displays the list as an icon and a label.

Details  Displays list of files by name, size, type, and modified date.

File Name  Displays files of the type specified in the List Files Of Type box. To open a file, choose from 
the list, or type a path and filename in the box.

Files Of Type  Displays the file types you can open, identified by their file name extension. To change the 
type, choose from the list.

Description  Displays information about the selected file. This information comes from the Description 
box in the Properties dialog box.

Open button  Opens the selected file.

Open section  Determines whether the file is opened as original, copy, or read-only.

Preview  Displays a preview of the selected file if a preview has been saved for the file in the Properties 
dialog box.

File Preview  Turns file preview on or off.



Bullet button
    Related Topics

Text tool bar
Use the bullet button to create bulleted lists from text you've already typed or text you begin typing after 
you choose the button. To convert text you've already typed to bullets, select the text, the click the bullet 
button. To type bullets, choose the text tool or select a shape, choose the bullet button, then type the 
bullets you want.



Cascade (Alt+F7)
    Related Topics

Window menu
Arranges open windows so the title bar of each window is visible. Stencil windows that are open as copies
or originals, or that are floating, stack on the left; drawing and ShapeSheet windows stack on the right. To 
activate a window and bring it to the front, click its title bar.



Center Drawing
    Related Topics

Tools menu, drawing window
Centers the entire drawing on the page, regardless of whether shapes are selected.



Change Row Type
    Related Topics

Edit menu, ShapeSheet window
Opens a dialog box where you can change the type of a selected row in a Geometry section of a 
ShapeSheet spreadsheet. Changing the row type changes the type of the segment the row refers to. 

If you select a Controls cell, this command toggles between displaying and hiding the control handle tips.

DIALOG BOX OPTIONS
Row Type    Displays the current type for the selected row. Choose a different option to change the row 
type.

LineTo    Changes the segment into a line. The endpoints are defined by the X and Y cells in the 
Geometry section row.

ArcTo    Changes the segment into a circular arc. The endpoints are defined by the X and Y cells, and the 
bow is defined by the A cell in the Geometry section row.

EllipticalArcTo    Changes the segment into an elliptical arc. The endpoints are defined by the X and Y 
cells, the A and B cells indicate the coordinates of the segment's control point, the C cell specifies an 
angle between 0 and 180 degrees for orientation, and the D cell specifies the ratio of the major to minor 
axis, which is usually one or greater (must be greater than zero).

SplineStart    Changes the segment into a spline start. The X and Y cells define the spline's second 
control point. (The spline's first control point is defined by the X and Y cells in the row preceding the 
SplineStart row). The A, B, and C cells indicate the spline's first, second, and last knot, respectively. The 
D cell indicates the degree of the spline, which controls the curvature of the spline with respect to its 
control polygon.

SplineKnot    Changes the segment into a spline knot. The X and Y cells define the control point for the 
row. The A cell indicates a spline knot.



Change Source dialog box
    Related Topics

Links dialog box
Click this option in the Links dialog box to change the reference for a linked file. For example, you can 
update a link if the file name or path has changed.

DIALOG BOX OPTIONS
Source    Determines the file to which Visio will link the object. You can choose an item in the Files Of 
Type and Folder lists to locate the file. You can change a linked object's file reference to any other file of 
the same format.

Directories    Displays the current folder.

List Files Of Type    Displays files of the same file format as the original linked file.

Drives    Displays the current drive.



Change Timeline Units
    Related Topics

Project timeline template, Project > Change Timeline Units
Lists the units you can display on the timeline in the project frame for a project timeline. The choices are 
Days/Months, Months/Years, and Quarters/Years. When you change the units, the size of the project 
frame doesn’t change so the smaller the unit (Days/Months being the smallest unit), the shorter the time 
period displayed in the project frame, and the longer the task bars.



Chart Shape Wizard
    Related Topics

Tools > Macro > Macros 
Use this wizard to create custom stackable or extendable shapes for use in charts. A stackable shape is 
duplicated when you drag to enlarge it, and an extendable shape stretches when you drag to enlarge it.    



Choose A Drawing Template dialog box
    Related Topics

Start Visio
Opens only when you start Visio. Enables you to choose a template on which to base a new drawing or to
open an existing drawing, stencil, or workplace file.

DIALOG BOX OPTIONS
Look In    Choose the type of drawing you want to create.

File List Box    Choose the template on which you want to base your drawing or the file you want to open.
The Blank Drawing in the Solutions folder opens a new drawing that is not based on a template.

File Name    Displays the name of the file selected. For example, you can choose Drawing (*.vsd), then 
choose an existing Visio drawing to open, instead of creating a new drawing. 

Files of Type    Choose the type of file you want to display in the file list.

Description    Displays a description of the template selected in the file list.

File Preview    Check to see a preview.

Preview    Displays a thumbnail of the first page of the drawing.

Open    Choose whether you want to open the original file, a copy of the file that you can edit, or read-only
copy of the file that you cannot edit.

Cancel    Closes the dialog box and returns to Visio.



Clear (Del key)
    Related Topics

Edit menu (not in print preview window)
Deletes selected shapes or text. To restore a deleted item, use the Undo command. You cannot use the 
Paste command to restore a shape that has been deleted using the Clear command.



Clip Art
    Related Topics

Insert menu
Opens the Microsoft ClipArt Gallery, a tool that helps you organize clip art files. In the ClipArt Gallery, you 
can select a clip art picture you want to include in your Visio drawing.

This command appears only when the ClipArt Gallery is installed.

For details about the Microsoft ClipArt Gallery, click Help in the ClipArt Gallery window.



Close
    Related Topics

File menu and Windows system menu
Closes the file in the active window. If you changed a Visio file but did not save it before choosing the 
Close command on the File menu, Visio asks if you want to save the changes. Choose Yes to save the 
changes, No to close the file without saving changes, or Cancel to keep the file open and cancel the 
Close command. If you choose Yes and have not saved the file, Visio opens the Save As dialog box so 
you can save the file.

You can also click the close button on the Print Preview toolbar to close the print preview window and 
return to the drawing page.



Close (stencil)
    Related Topics

Right-click a docked stencil's title bar
Closes only the stencil you right-click. If the stencil is floating, you can click  to close it.



Color Palette
    Related Topics

Tools menu, drawing window
Opens a dialog box that displays the current color palette. You can customize the color palette for the 
active drawing file or choose a different color palette to use for the file.

Visio uses solid colors for lines. For fills that don't have a pattern (item 0 or 1 in the pattern lists in the Fill 
dialog box), Visio uses the dithered version of the foreground color you specify. For patterned and 
gradient fills (patterns 2 through 40), Visio uses the solid color for the foreground and background colors 
you specify.

To create a custom fill, line, or text color, you can add a new color, or edit an existing color in the color 
palette. If shapes in the file are formatted with a color that you edit, the shapes' formatting changes to the 
new color. Colors you define or edit appear in the color lists in the Fill, Font, and Line dialog boxes.

DIALOG BOX OPTIONS
Color Solid    Displays the 24 colors in the drawing file's color palette. The left side of each color bar 
shows the color when dithered; the right side shows the closest solid color. (If your display driver supports
16 colors, you will see dithered color. If it supports 256 colors or higher, you may not see any dithered 
colors.)

Copy Colors From    Displays a list of open template and drawing files and predefined color palettes. By 
choosing from the list, you can copy a new color palette to the active drawing file.

Edit    Click to edit the color selected in the Color Palette. Visio opens the Edit Color dialog box so you 
can edit the color.

Apply    Click to apply color changes without closing the dialog box. Visio applies the new colors.



Combine
    Related Topics

Shape > Operations, drawing window
Creates a new shape from selected shapes. If the selected shapes overlap, Visio cuts out, or discards, 
the area where they overlap, which creates holes in the new shape. Use this command to create picture 
frames, windows, and other shapes that you want to see through.

The combined shape inherits the formatting and text of the first shape you select when you combine the 
shapes. The combined shape also has a single ShapeSheet spreadsheet, which contains the Geometry 
rows from each component shape's ShapeSheet spreadsheet.



Configure Task Bar Sizes
    Related Topics

Project Timeline template, right-click the drawing page with no shapes selected, then 
choose Configure Task Bar Sizes
Opens the Custom Properties dialog box, in which you can set the size of normal and summary task bars 
and the percent-complete line. You can also set the size of the symbols that you can add to the ends of 
task bars.

Time Symbol Height Type the height of all end, start, and milestone symbols used in the project timeline.

Normal Task Bar Height Type the height of all normal task bars in the project timeline.

Summary Task Bar Height Type the height of all summary task bars (for tasks with subtasks) in the 
project timeline.

Normal Task Bar Percent Complete Height Type the height of the blue percent-complete line that 
appears in normal task bars when you add a Percent Complete column to your project timeline.

Summary Task Bar Percent Complete Height Type the height of the green percent-complete line that 
appears in summary task bars when you add a Percent Complete column to your project timeline.



Configure Task Bar Text
    Related Topics

Project Timeline template, right-click the drawing page with no shapes selected, then 
choose Configure Task Bar Text

Or, right-click a task bar or milestone, then choose Configure Task Bar Text
Opens the Custom Properties dialog box, in which you can set the text that appears in or beside the task 
bars in your project timeline.

Task Left Text Choose or type text that appears at the left end of all task bars in your project timeline.

Task Inner Text Choose or type text that appears inside all task bars in your project timeline.

Task Right Text Choose or type text that appears at the right end of all task bars in your project timeline.



Configure Timeline Symbols
    Related Topics

Project Timeline template, right-click the drawing page with no shapes selected, then 
choose Configure Timeline Symbols
Opens the Custom Properties dialog box, in which you can set the symbols that appear on the ends of 
normal and summary task bars. You can also set a size for all the symbols in your project timeline.

Normal Task Start Symbol Choose the symbol you want to add to the beginning of all task bars in your 
project timeline.

Normal Task End Symbol Choose the symbol you want to add to the end of all task bars in your project 
timeline.

Summary Task Start Symbol Choose the symbol you want to add to the beginning of all summary task 
bars in your project timeline.

Summary Task End Symbol Choose the symbol you want to add to the end of all summary task bars in 
your project timeline.

Milestone Symbol Choose the symbol you want to use for milestones in your project timeline.



Configure Working Days
    Related Topics

Project Timeline template, Project > Configure Working Days
Opens the Configure Working Days dialog box, where you can check the non-working days for the current
project. By default, Saturday and Sunday are checked. Non-working days appear as light yellow areas in 
the project timeline. Task bars extend over non-working days but the days aren’t counted as part of the 
task duration.



Connect Shapes
    Related Topics

Tools menu, drawing window
Connects selected 2-D shapes (or other objects) in the order you select them. The shapes are connected 
with an instance of the connector master shape selected in the stencil. If no master shape is selected, 
Visio creates an instance of the Dynamic Connector to connect the shapes.

You can also use the connect shapes button on the Shape toolbar. Use tips to identify the button.



 Connection point tool
    Related Topics

Standard toolbar
Use the connection point tool to add, move, or delete connection points. 

Note:    The connection point tool always adds a connection point to the selected shape. Before using this
tool, you must always select the shape to which you want to add the connection point.

To add a new connection point, select the shape, hold down the Ctrl key (the pointer should display an X 
above it), and click the shape where you want to add the connection point.

To select a connection point, position the mouse pointer over the connection point (the pointer is a four-
headed arrow), and then click. The connection point turns magenta when it is selected.

To delete a connection point, select it, then press the Delete key. (Note: You cannot delete a connection 
point that has something glued to it.) 

To move a connection point, select the connection point, and then drag it to a new location. The 
connection point turns magenta when it is selected.

Display options
Connection points appear as  on shapes. To display connection points, make sure Connection Points is 
checked on the View menu.



Connection Points
    Related Topics

View menu, drawing window
Turns the display of connection points on and off. When this command is checked, Visio displays 
connection points as . When you select a connection point, it turns magenta.

You can also use the connector tool on the View toolbar. Use tips to identify the button.



 Connector tool (Ctrl+3)
    Related Topics

Standard toolbar
Use the connector tool to connect two shapes as you drop them. To connect shapes, choose the 
connector tool, and then drag 2-D shapes from the stencil to the drawing page. The shapes are 
connected with an instance of the connector master shape selected in the stencil. If no master shape is 
selected, Visio creates an instance of the Dynamic Connector to connect the shapes.

To connect shapes point-to-point, drag the shapes you want to connect to the drawing page, select the 
connector tool, point to one of the shape's connection points, and then drag to one of the other shape's 
connection points.

To connect shapes shape-to-shape with the Dynamic Connector, press Ctrl and drag the shapes you want
to connect to the drawing page, select the connector tool, point to one of the shape's connection points, 
and then drag to one of the other shape's connection points.

When you've successfully connected two shapes, the endpoints of the connector turn red when the 
connection is selected. The shade of red varies according to whether the connection is point-to-point or 
shape-to-shape.



Control
    Related Topics

Insert menu, drawing window
Inserts ActiveX controls, which are programmable objects that you can use to add functionality to a 
drawing. For example, you might insert standard Windows dialog box controls such as single-click 
buttons, check boxes, or list boxes, or custom controls that provide more complex functionality such as 
animation. To program a control, you typically write event procedures in the drawing's VBA project to 
handle the control's events, and you may get or set the control's properties or invoke its methods in other 
procedures. 

DIALOG BOX OPTIONS
Controls    Lists the controls installed on your system, including those installed by applications that 
contain the controls. You might need a design license to insert such controls in your own drawings. For 
details, contact the control vendor. 

<control name>    Displays the location of the file that contains the control selected in the Controls list.



Convert To Group
    Related Topics

Shape menu, Grouping submenu, drawing window
Changes a selected Windows metafile (.wmf) or an object from another application into a group so you 
can edit it. If you want to separate the group into individual shapes, use the Ungroup command on the 
Shape menu.

Bitmaps
A metafile can either contain a bitmap or consist solely of a bitmap. Visio cannot convert bitmaps into 
shapes. However, a metafile that consists of a single bitmap sometimes stores the bitmap in separate 
segments. In that case, the Convert To Group command converts each segment of the metafile into an 
individual bitmap object.

Linked objects
If an object from another application is embedded or linked, converting the object to a group disassociates
the object from its original file so you can no longer edit the object in its original application.



Convert <OLE object>, <OLE object> Convert
    Related Topics

Edit > Object, drawing window
Converts an OLE object to another format. Use this command to display the OLE object as an icon in a 
drawing. The command appears on a submenu when you choose the Object command from the Edit 
menu.

DIALOG BOX OPTIONS
Current Type    Specifies the current type of embedded object.

Convert To    Displays the Object Type list.

Activate As    Displays the Treat As list.

Result    Displays a message that describes the results of converting the object.

Display As Icon    Displays the OLE object as an icon in a drawing.

Change Icon    Opens a dialog box where you can specify a custom icon and change the icon label. (This
option is available only when Display As Icon is checked.)



Copy, Copy Drawing (Ctrl+C)
    Related Topics

Edit menu (not in print preview window)
Places a copy of selected shapes or text onto the clipboard. When the drawing window is active and 
nothing in it is selected, the Copy command changes to Copy Drawing. Copy Drawing places a copy of 
the entire drawing on the Clipboard.

The information remains on the Clipboard until you use the Copy or Cut command again. Use the Paste 
command to paste as many copies as you want from the Clipboard. If both programs support OLE, 
pasting an object from another program embeds it.

You can also use the copy button on the Standard toolbar. Use tips to identify the button.



Copy Hyperlink
    Related Topics

Right-click linked object, then choose Hyperlink > Copy Hyperlink
Places a copy of the linked Visio shape or drawing on the clipboard. You can then choose Edit > Paste As
Hyperlink in the destination document.



Corners
    Related Topics

Format menu, drawing and ShapeSheet windows
Applies formats to corners. You can choose from options for rounded corners or enter a value for a 
custom corner.

You can also use the corner rounding palette on the Shape toolbar. Use tips to identify the button.

Note: If you use the Union, Combine, Fragment, Intersect, or Subtract command, round corners are 
replaced by arcs.

DIALOG BOX OPTIONS
Round Corners    Displays icons from which you can choose a corner roundness.

Rounding    Displays a numeric value for each corner option. You can also enter a value.

Apply    Applies formatting without closing the Corners dialog box.



 Crop tool 
    Related Topics

Standard toolbar
Use the crop tool to size the border that encloses an object from another program or to move the object 
within the border. 

When you change the size of an object's border with the crop tool, the object itself is not sized, but the 
amount of the object that is visible is reduced or enlarged. Drag the object's selection handles to crop, or 
drag inside the border to pan the object.



Custom Fit
    Related Topics

Shape > Operations, drawing window
Converts a polygonal line into a combination of lines, arcs, and splines that go approximately through its 
vertices. You can specify the error tolerance. If the tolerance is sufficiently loose (that is, if a large error is 
acceptable), the converted shape may be smaller in size than the original. Ungroup clipart shapes before 
you use the Custom Fit command.

DIALOG BOX OPTIONS
Periodic Splines    Check to create a periodic (seamless) spline if the original shape is closed and 
smooth. If Cusps And Bumps is unchecked, the original shape need not be smooth.

Circular Arcs    Check to replace polygonal line vertices with either line segments or circular arcs. For this
option to work, the polygonal line vertices must be close to a line segment or circular arc within the 
specified tolerance.

Cusps And Bumps    Check to preserve sharp angles and other features in the original shape. 

Error Tolerance    Type a tolerance value. The looser the tolerance (that is, the higher the amount of error
tolerated), the simpler (less data, smaller disk size) the arc or spline. Zero tolerance results in no 
reduction in data. The typical error tolerance for converting clipart should be about 0.1 mm (.004 inches).

If you check Periodic Splines, uncheck Circular Arcs and Cusps and Bumps, and type an Error Tolerance 
of zero, you convert a polygonal line to a spline that goes exactly through the polygonal line's vertices. If 
the polygonal line is closed (that is, if it's a polygon), the result is a periodic spline. These Custom Fit 
settings are equivalent to choosing the Fit Curve command. 



Custom Line Weight
    Related Topics

Format > Line, click Weight and choose Custom
A dialog box in which you can type a specific value for the selected shape's line weight, in any unit of 
measure Visio recognizes. 



Custom Properties
    Related Topics

Shape menu, drawing and ShapeSheet windows
Opens a box in which you can edit a shape's ShapeSheet custom-property fields. The contents of this box
change depending on the shape you select and the custom properties set for that shape in its 
ShapeSheet spreadsheet.

This command is available only when a shape contains custom-property fields.

You can also use the custom properties button on the Shape toolbar. Use tips to identify the button.

Tip: You can define new custom-property fields for a shape, or edit existing properties, with the Custom 
Properties Editor.



Custom Properties Editor
    Related Topics

Tools > Macro
Runs a wizard in which you can add new custom property fields to selected shapes, edit existing 
properties, or delete existing property fields from shapes. 



Cut (Ctrl+X)
    Related Topics

Edit menu (not in print preview window)
Deletes selected shapes or text and places them on the clipboard. The items remain on the Clipboard 
until you use the Cut command again or use the Copy command.

You can also use the cut button on the Standard toolbar. Use tips to identify the button.



Data Map (Insert menu)
    Related Topics

Insert menu, drawing window
Inserts data maps created in Microsoft Data Map. Data maps are geographical maps based on data from 
Microsoft Excel and Microsoft Access.



Database Export
    Related Topics

Tools > Macro > Database, drawing window
Starts the Database Export Wizard, which exports data from ShapeSheet cells in Visio shapes and 
creates a new database table. You can insert the database table into an existing database or create a 
new database in which to contain the table. If you insert the table into an existing database, the database 
must have been created in an ODBC-compliant application. You can export data for every shape in a 
drawing or for selected shapes. 

For information about options on Database Export Wizard screens, click More Info.



Database Refresh
    Related Topics

Tools > Macro > Database, drawing window
When a shape or drawing is linked to a database created in an ODBC-compliant program, this command 
refreshes linked ShapeSheet cell values to match values in database records. The command applies to 
selected shapes or to all shapes in the drawing, if no shapes are selected. For information about how to 
link shapes and drawings to data sources, see Database Wizard.



Database Settings
    Related Topics

Tools > Macro > Database
Opens the Database Settings dialog box where you can set certain aspects of ODBC behavior. When 
you’ve linked Visio shapes or drawings to databases created in ODBC-compliant applications, the 
settings control how the drawing monitor passes changes to the database. The settings are global, that is,
they apply to all the drawing-database links you have established. You can override the global settings in 
the process of establishing a link between a database and a drawing.

DIALOG BOX OPTIONS
Number Of Retries    Type the number of times you want to try updating a database based on changes to
a drawing the database is linked to if the first attempt fails.

UpdateRetry Interval (msecs.)    Type the number of milliseconds between update attempts.

Time out Interval (secs)    Type the number of seconds after which the update attempts time out.

Default ODBC Data Source    Choose the ODBC data source you want the Database Wizard to link to by
default. When you’re using the wizard to link a shape to a database, you can choose a different data 
source.

Automatically Refresh Drawing Page    Check to pass changes from a database to a drawing according
to the interval you type in the next option.

Refresh Drawing Interval (secs.)    Type the number of seconds (for example, 30 seconds) that should 
elapse before changes to a database are passed to a drawing. If it takes longer than the time you type to 
actually refresh a drawing, Visio adjusts the time accordingly.



Database Update
    Related Topics

Tools > Macro > Database, drawing window
When a shape or drawing is linked to a database created in an ODBC-compliant program, this add-on 
updates values in database records to match the values in linked ShapeSheet cells. The command 
applies to selected shapes or to all shapes in the drawing, if no shapes are selected. For information 
about how to link shapes and drawings to data sources, see Database Wizard.



Database Wizard
    Related Topics

Tools > Macro > Database, drawing window
Links Visio shapes or drawings to databases created in programs compliant with the Open Database 
Connectivity (ODBC) standard, such as Microsoft Access 7.0 or later, Microsoft SQL Server, and Oracle 
SQL Server. When you link a shape, you link specific ShapeSheet cells to specific database fields. You 
can keep the shape's ShapeSheet cell values synchronized with the database field values by using the 
Refresh and Update commands. After you link a shape to a database record, you can use the wizard to 
create drawings that are graphical representations of database tables and you can generate new master 
shapes, which are graphical representations of database records.

For information about options on Database Wizard screens, click More Info.



Days/Months
    Related Topics

Project Timeline template, right-click Project Frame shape, then choose Days/Months

Or, right-click the timescale, or the nonworking stripe, then choose Days/Months
Changes the timeline to display days and months. When you change the units, the size of the project 
frame doesn’t change so the smaller the unit (Days/Months being the smallest unit), the shorter the time 
period displayed in the project frame, and the longer the task bars.



Define Styles
    Related Topics

Format menu, drawing window
Opens a dialog box where you can create, edit, rename, and delete styles. Before using the Define Styles
command, you can select one or more shapes and apply the newly created or edited style to the shapes.

Click to display information about the dialog box.

Tip: If you apply local formatting to selected characters in a shape's text block after applying a style to the
shape, the link between the shape's text and the style is broken. The shape will still respond to changes in
the style's definition of line and fill attributes.



Displays a list of existing styles, as well as New style. If a shape is selected, the style for that shape is 
highlighted in the list.



Displays the style that the style displayed in the Style box is based on.



Indicates whether the style includes attributes for lines, fills, or text.



Includes buttons that open the Font, Line, and Fill dialog boxes in which you define attributes for the style.
If a style is selected in the Style box, the dialog boxes display the current style's attributes; if no style is 
selected, they display default attributes or attributes for the style in the Based On box. Choosing OK in the
Line, Fill, or Text dialog box returns you to the Define Styles dialog box.



If checked, prevents the style's attributes from replacing formatting you applied directly to the shape. 
Uncheck Preserve Local Formatting on Apply if you want the style to replace all previous formatting.



Discards only those changes specified the last time you clicked the Add, Change, Delete, or Rename 
button.



When you finish defining a new style or revising a style, Visio adds a new style to the style lists or 
changes a style without closing the dialog box so you can continue creating and editing styles. 



Deletes the style selected in the Style list. A shape previously formatted with the deleted style becomes 
linked to and formatted with the Based On style, and may change in appearance as a result. Any local 
formatting that had been applied to the shape is preserved.



Opens the Rename dialog box, which displays the name of the style selected in the Style list. If you 
previously applied the style to shapes, Visio updates the link to the renamed style.



Delete Column
    Related Topics

Project Timeline template, Project > Delete Column

Or, right-click a column in the project timeline, then choose Delete Column
Deletes the selected column from the project frame. The data contained in the column is not deleted from 
the file. If you insert the same column type again, the data reappears in the column.



Delete Page
    Related Topics

Edit > Drawing Page, drawing window
Lists the pages in a drawing file so you can choose the pages to delete. You can restore a page you 
delete by using the Undo command.

DIALOG BOX OPTIONS
Page    Lists the pages in the drawing file.

Update Page Names    Check this option to renumber the remaining pages. This option applies only to 
pages that use default names.



Delete Row (Edit menu)
    Related Topics

Edit menu, ShapeSheet window
Deletes the selected ShapeSheet row. You can restore a row you've deleted by using the Undo 
command. Deleting a row in a ShapeSheet spreadsheet may change the shape's behavior.



Delete Row (Project Timeline template)
    Related Topics

Project Timeline template, Project > Delete Row

Or, right-click a task bar or a horizontal grid line, then choose Delete Row
Deletes the task corresponding to the selected row or task bar. To select a row, select any cell in the row. 
Deleting a row deletes the data for the task from your project.



Delete Section
    Related Topics

Edit menu, ShapeSheet window
Deletes the selected ShapeSheet section. You can restore a section you delete by using the Undo 
command. Deleting a section can change a shape's behavior.



Delete Shape and Record
    Related Topics

Right-click a selected shape linked to a database record
For this command to appear on a shape’s shortcut menu, you must have previously run the Database 
Wizard to link the shape to a database record.

Deletes the shape from the Visio drawing and the database record the shape is linked to in the database 
table.



Demote Tasks
    Related Topics

Project Timeline template, Project > Demote Tasks

Or, right-click a task bar or a horizontal grid line, then choose Demote Tasks
Makes selected tasks substasks of the nearest preceding task and moves the subtasks to the right in the 
Task Name column. A task with subtasks becomes a summary task. By default, summary task bars have 
yellow triangles on either end.



Design mode button
    Related Topics

Developer toolbar
Switches Visio to a mode in which you can design pages and forms. In design mode, inserted ActiveX 
controls cannot send events. By default, Visio opens files in run mode, unless you have Macro Virus 
Protection checked in the General tab of the Options dialog box. To protect your document from macro 
viruses, Visio runs in design mode.

The fundamental distinction between run mode and design mode is that 1) controls hosted in a document 
are told not to fire events when the document is in design mode and to fire events when in run mode and 
2) Visio will not source events from any object whose document is in design mode.



Developer toolbar
    Related Topics

View > Toolbars, Toolbar shortcut menu
Displays a Visio toolbar that provides buttons you can use as shortcuts for choosing menu commands. To
switch the toolbar, choose View > Toolbars or right-click the toolbar, then choose Developer from the 
shortcut menu.

The tools available on the Developer toolbar are 

· Run macro
· Visual Basic Editor
· Insert control
· Show ShapeSheet
· Design mode

Note: Your toolbar may vary depending on the display resolution of your monitor, the size of your window,
and which window is active. 



Distribute Shapes
    Related Topics

Tools menu, drawing window
Places three or more selected shapes at regular intervals on the drawing page. Choose from horizontal 
and vertical distribution options. The order in which you select shapes is not relevant when distributing 
shapes.

You can also use the distribute shapes palette on the Shape toolbar to display distribution options. Use 
tips to identify the palette. To choose a distribution option, click the toolbar button and hold down the 
mouse button. 

Click to display information about the dialog box.



Displays options for distributing shapes horizontally.



Distributes shapes horizontally so there is a uniform space between shapes.



Distributes shapes so their left edges are uniformly spaced.



Distributes shapes horizontally so their centers are uniformly spaced.



Displays options for distributing shapes vertically.



Distributes shapes so their right edges are uniformly spaced.



Distributes shapes vertically so there is a uniform space between shapes.



Distributes shapes so their top edges are uniformly spaced.



Distributes shapes vertically so their centers are uniformly spaced.



Distributes shapes so their bottom edges are uniformly spaced.



If checked, creates guides to retain the distribution of the shapes. Select and move the outermost guides 
to move the shapes without changing their distribution.



Double-Click
    Related Topics

Format menu, drawing and ShapeSheet windows
Opens a dialog box where you can assign an action to be performed when a shape is double-clicked.

Click to display information about the dialog box.



Activates the default action for the shape.



Takes no action.



Opens the shape's text block.



Opens a group in the group window.



Opens the ShapeSheet window.



Activates OLE options, such as Edit, when an OLE object is double-clicked.



Activates the macro selected from the list.



Opens an online help topic. Uses the same syntax as described in the Special dialog box.



Displays a specific drawing page.



Displays the drawing page in a new window.



Performs custom double-click behavior.



Drawing
    Related Topics

File > New
Opens a new drawing file (.vsd) based on the currently open template.



Drawing Resources
    Related Topics

Help > Visio On The Web
Opens your World Wide Web browser application and displays a Web site, 
http://www.visio.com/resources, that contains links to other Web sites that can help you create accurate 
drawings quickly. For example, some of the sites contain information and forums about such topics as 
demographics or OSHA (Occupational Safety and Health Administration) standards. Other sites contains 
graphics such as clip art or standard forms. 



Duplicate (Ctrl+D)
    Related Topics

Edit menu, drawing and stencil windows
Places a copy of selected shapes offset to the lower right of the original shapes.

Tip: To duplicate the shape at a specific distance from the original, select the shape, hold down the Ctrl 
key, and drag to the location where you want the new shape. To make copies quickly, duplicate one 
shape, and then press F4 to duplicate others.

Note: To view this command for a stencil, you must have an original stencil open.



Edit Color dialog box
    Related Topics

Tools menu, Color Palette dialog box
Opens a dialog box where you can edit the basic color palette and create up to 16 custom colors.

DIALOG BOX OPTIONS
Basic Colors    Displays the Microsoft Windows basic color palette. Select any of the colors and use the 
Color Selector Palette to change the default color.

Custom Colors    Specifies up to 16 custom colors.

Define Custom Colors    This button is dimmed because the Edit Color dialog box is already in custom 
color mode.

Add To Custom Colors    Use the Color Selector Palette to create a custom color by adjusting the hue, 
saturation, and luminosity of the color. Alternatively, specify its red, green, and blue values. Once you're 
satisfied with the color displayed in the Color/Solid box, choose the Add To Custom Colors option.



Edit Icon
    Related Topics

Master menu, stencil window
Opens the edit icon window, where you can edit the icon for the master shape selected in the stencil 
window. The window, whose title bar identifies the stencil and master shape, displays the icon as a 
bitmap, which you can edit pixel by pixel.

Tip: Before choosing Edit Icon, use the Properties command (on the Master menu) to specify the size of 
the icon. The icon's size determines the size of the area available for editing the icon. You should also 
choose Manual as the Update option in the Properties or New Master dialog box, so you don't 
accidentally overwrite the customized icon each time you change the master shape.



Edit Master
    Related Topics

Master menu, stencil window
Displays a selected master shape in the master drawing window, so you can edit the master shape. You 
can choose to have changes you make to the master shape be applied to future instances. The Edit 
Master command is available only when you open an original stencil.

You can also open the master drawing window by double-clicking a master shape icon when an original 
stencil is opened.

To close the master drawing window, click the close box  in the upper-right corner of the window.



Edit Text (F2)
    Related Topics

Shape menu, drawing window
Controls the text block for the selected shape. If a shape is selected with a tool other than the text tool, 
choosing Edit Text opens the shape's text block so you can edit text. If a shape is selected with the text 
tool, choosing Edit Text selects the shape's text block so you can move, rotate, or size the text block 
independently of the shape.



Edit <OLE object>, <OLE object> Edit
    Related Topics

Edit menu, drawing window
Opens an OLE object so you can edit it. If the object is embedded, and the program in which it was 
created is compatible with in-place editing, the object opens in place. Otherwise the object's program 
opens in its full window. This command appears on a submenu when you choose Edit > <OLE object>. 
For example, if you select a Windows Paintbrush object, the command changes to Paintbrush Object.

If a group is selected, the command in this position is Open <group name>. If nothing is selected, the 
command in this position is Object.



 Ellipse tool (Ctrl+9)
    Related Topics

Standard toolbar
Use the ellipse tool to draw ellipses and circles. 

Drag diagonally to draw an ellipse. As you drag, hold down the Shift key to draw a circle. Both ellipses 
and circles are closed shapes, consisting of two arc segments. To size an ellipse or circle, drag a 
selection handle. Drag a corner handle to preserve the shape's original proportions. 

To manipulate the arc segments of the ellipse, select the ellipse with the pencil tool to display vertices and
control points that you can drag.

To apply a fill style or fill format to an ellipse, use the Fill command.



Exchange Folder
    Related Topics

Send To submenu, drawing window
This command is available only if Microsoft Office 97 is installed on your computer. 

Choose to send a drawing to a folder in Microsoft Exchange or Outlook. The drawing becomes an 
embedded object in that folder, after which you can open and edit it in Visio by double-clicking it.



Exit
    Related Topics

File menu
Closes Visio windows and exits Visio. If you have changed a Visio file but did not save it before choosing 
the Exit command, a message asks if you want to save the changes before closing.



Export [data]
    Related Topics

Tools menu
Exports an inventory report based on shape properties. The Export [data] command is available for 
certain types of drawings in which you may incorporate data frequently, such as network diagrams, office 
layouts, and organization charts.

When you export information, you choose whether to report on all pages in the document, whether to 
report on all shapes or selected shapes, and whether to create a report in Excel, Notepad, or Access 
format.

DIALOG BOX OPTIONS
Range    Specifies whether you want to create an inventory report for the entire document or the current 
page.

Include    Specifies whether to include all shapes, only selected shapes, or all shapes on a specific layer.

Export To    Specifies whether to export the inventory report to Notepad, Microsoft Excel, or Microsoft 
Access.

File Name    Specifies text you enter as the name of the inventory report; for example, “Bill of Materials.”

Total Identical Items    Totals identical items in the inventory report. 

Display column Headings    Displays column headings in the resulting inventory report.



Export Project
    Related Topics

Project Timeline template, Project > Export Project
Opens the Save As dialog box, in which you can save a project timeline you created in the Visio Project 
Timeline template as a Microsoft Project exchange file (.mpx) so you can open the file in Microsoft 
Project.



Field (Ctrl+F9)
    Related Topics

Insert menu, drawing window
Inserts a text field into a text block. Visio inserts a field at the insertion point or, if a shape is selected but 
its text block is not open, replaces the shape's existing text with the field.

Click to display information about the dialog box.

Tip: Some field categories, such as Date/Time, are useful for providing up-to-the-minute information in 
final drawings. Other field categories, such as Document Info, help you keep track of information as you 
work on a drawing.



Lists the field categories. Insert a text field to display information in drawings.



Lists the fields within the selected category. For example, if you choose Geometry, the Field box displays 
options for Height, Width, and Angle.



Determines the format of the selected field. For example, if you chose Angle in the Field box, you can 
choose from the General, Radians, and Degrees options.



If you choose Custom Formula as the category, enter the formula in the formula box. To create a formula, 
use the same functions you use in the ShapeSheet spreadsheet.



Enter ShapeSheet functions to create a formula.



Uses system information to track the Creation Date, Creation Time, Current Date, Current Time, Last Edit 
Date, Last Edit Time, Print Date, and Print Time.



Uses information entered in the Properties dialog box to track Creator, Description, Folder, Filename, 
Keywords, Subject, and Title.



Uses the shape's width, height, and angle information. Use the Width field for dimension lines, or the 
Angle field to show how far a shape is rotated from its original position. Use any Geometry field to 
automatically update technical specifications in a drawing.



Uses information entered in the Special dialog box to track Data 1, Data 2, Data 3, ID, Master, Name, and
Type.



Uses information entered in the Properties or Page dialog box to track Background Name, Number of 
Pages, and Page Number.



Uses information entered in the Lotus Notes Field dialog box to manage information such as shape 
details, shape measurements, and date of creation.



Uses custom properties stored in the Custom Property section of the selected shape's ShapeSheet 
spreadsheet. You define Custom Properties to associate the type of information you want with a shape. 
For example, you can associate a serial number with a piece of equipment.



Uses information entered in the Value cell of the User-defined Cells section in the shape's ShapeSheet 
spreadsheet. For details, see User-Defined Cells section.



Fill (F3)
    Related Topics

Format menu, drawing and ShapeSheet windows
Opens a dialog box where you apply fills and shadows to selected shapes. Closed shapes can have fills 
and shadows. Open shapes can have shadows but no fill.

You can also use the fill formatting buttons on the Shape toolbar. Use tips to identify the buttons.

The numbers preceding the patterns and colors in the Pattern, Foreground, and Background lists act as 
labels. As you work with the ShapeSheet spreadsheet, these numbers provide a shorthand for identifying 
patterns and colors.

Patterns
For both Fill and Shadow, you can specify a pattern of none (transparent) or a solid, gradient, or bitmap 
pattern. Each bitmap and gradient pattern has two components: a foreground color applied to the dots 
and lines making up the pattern, and a background color. You can specify different colors in the 
Foreground and Background lists, and Visio changes the display of the Pattern list according to your color
choices. If there are custom patterns associated with a stencil you have open, those patterns will appear 
by name at the end of the pattern list. 

Colors
Some colors in the Foreground and Background lists are quite dark. For those colors, the left half of the 
color sample shows how the color will look as a solid (pattern 1). The right side shows how the color will 
appear in any bitmap pattern.

You can use the color palette to define a custom fill color. To define a custom color, on the Foreground or 
Background list, choose Custom. The Color dialog box appears, in which you can define the color and 
assign it to the shape.

DIALOG BOX OPTIONS
Fill    Displays the current pattern, foreground color, and background color for the selected shape's fill. 
Choose options from the following lists:

Pattern    Choose a pattern, which can be blank or transparent (None or pattern 0), solid (pattern 1), a 
bitmap pattern (patterns 2 through 24), or a gradient pattern (patterns 25 through 40). Choosing None 
in the Pattern list creates a transparent shape. Visio ignores the foreground and background colors.

Foreground    Choose a color that is applied to the dots and lines making the pattern.

Background    Choose a color that is behind the dots and lines making the pattern.

Shadow    Displays the current pattern, foreground color, and background color for the selected shape's 
shadow. Choose options from the following lists:

Pattern    Choose a pattern, which can be blank or transparent (None or pattern 0), solid (pattern 1), or 
a bitmap pattern (patterns 2 through 24). Choosing None in the Pattern list deletes an existing shadow,
and Visio ignores the foreground and background colors.

Foreground    Choose a color that is applied to the dots and lines making the shadow.

Background    Choose a color that is behind the dots and lines making the shadow.

Preview    Displays a preview of the Fill and Shadow options you select.

Apply    Applies formats without closing the dialog box.



Fill Color tool
    Related Topics

Shape toolbar
Use the fill color tool to fill shapes with color or to make them transparent. Select the shape or shapes you
want to fill, then click the fill color tool to display the fill color palette. On the palette, choose

· No Fill, to make shapes transparent.

· One of the colors in the palette to fill the shapes with that color. 

· More Colors to open the Fill dialog box where you can choose colors and patterns for fills and 
shadows.



Fill Pattern tool
    Related Topics

Shape toolbar
Use the fill pattern tool to fill shapes with a pattern. Select the shape or shapes you want to fill, then click 
the fill pattern tool to display the fill pattern palette. On the palette, choose

· No Fill, to make shapes transparent.

· One of the patterns in the palette to fill the shapes with that pattern.

· More Fill Patterns to open the Fill dialog box where you can choose different background and 
foreground colors for the pattern.



Find
    Related Topics

Edit menu, drawing window
Searches for specified text in shapes, stencils, the Properties dialog box, and data fields in the active 
drawing file.

Click to display information about the dialog box.



Specifies the text you want to find. You can type or paste text into this field. To search using text you 
previously searched for, click the down arrow, then choose the text from the list.



Displays a list of special characters on which you can search: Tab Character, Manual Return, Optional 
Hyphen, Caret Character, or Any Character.



Specifies the range of the search.



Specifies to search only the current selection.



Specifies to search only the current page.



Specifies to search all pages in the open diagram.



Finds only those occurrences with the exact combination of uppercase and lowercase letters specified in 
the Find What box. Visio uses the case of letters as they were originally typed, regardless of whether the 
text has been formatted using Small Caps or All Caps formatting. 



Finds occurrences that are words and not parts of larger words. For example, if you type "for" in the Find 
What box, Visio finds all instances of "for" but ignores "foreign." 



Finds and selects the next occurrence of the text in the Find What box.



Ignores occurrences of Japanese words if the character widths do not match.



First Tile button
    Related Topics

Print preview toolbar
For a large drawing that Visio tiles, displays the part of the drawing that prints on the first page (or tile).



Fit Curve
    Related Topics

Shape > Operations, drawing window
Draws a spline based on a polygonal line. Fit Curve converts a polygonal line to a spline that goes exactly
through the polygonal line's vertices. If the shape is a closed polygon, the result is a periodic (seamless) 
spline. Choosing Fit Curve is the same as choosing Custom Fit, then checking Periodic Splines, 
unchecking Circular Arcs and Cusps and Bumps, and setting Error Tolerance at zero. 



Flip Horizontal (Ctrl+H)
    Related Topics

Shape menu, drawing window
Transposes the left and right sides of selected shapes.

You can also use the flip horizontal button on the Shape toolbar. Use tips to identify the button.



Flip Vertical (Ctrl+J)
    Related Topics

Shape menu, drawing window
Transposes the top and bottom sides of selected shapes.

You can also use the flip vertical button on the Shape toolbar. Use tips to identify the button.



Float
    Related Topics

Right-click a docked stencil's title bar
Makes the stencil float. By default, stencils are docked.



Flowchart-TQM Diagram Wizard
    Related Topics

File > New > Flowchart

Or, Tools > Macro > Flowchart
Starts the Flowchart-TQM Diagram Wizard, which:

· Lays out the initial structure for and formats a cause and effect, force field, top down, or cross 
functional (Rummler-Brache) flowchart, or

· Reads data from a text (.txt) or Microsoft Excel (.xls) file and generates a flowchart based on the data.



Foreground
    Related Topics

Edit > Go To, drawing and print preview windows
Displays the foreground page for a drawing. Available only when a background page is displayed.

To cycle through the background pages in a drawing, from the Edit menu, choose Go To, then choose 
Background.

Tip: Although you can see shapes on a background page when a foreground page is displayed, you can't
edit the shapes on the background unless you display the background page.



 Format Painter tool
    Related Topics

Standard toolbar
If you're pleased with the formatting of a shape, you can use this tool to quickly transfer the formatting 
(such as line, fill, and text styles) to another shape instead of starting from scratch.



Formulas
    Related Topics

View menu, ShapeSheet window, formula bar
Displays cell formulas in the ShapeSheet spreadsheet. To display values instead of formulas, use the 
Values command.



Forward button
    Related Topics

Web toolbar
Pages forward in a Web document.



Fragment
    Related Topics

Shape > Operations, drawing window
Breaks selected shapes into smaller shapes. For example, you can draw lines through a 2-D shape 
where you want to break the shape, select the 2-D shape and the lines, and then choose Fragment to 
break the shape where the lines intersect it.

When you fragment shapes, Visio creates a new ShapeSheet spreadsheet for each of the new shapes.

When you fragment overlapping 2-D shapes, new shapes are formed from both the areas where the 
original shapes overlap and the areas where they do not overlap.

When you fragment three or more intersecting lines, the enclosed spaces become new shapes. 



 Freeform tool (Ctrl+5)
    Related Topics

Standard toolbar
Draws smooth curves (also called splines). For example, you can draw a flower bed with an irregular 
border that is smooth, not jagged.



Full Screen Preview
    Related Topics

View menu
Maximizes the amount of space for your drawing. In full-screen view, the Visio toolbars, title bars, status 
bar, menus, scrollbars, and stencils are hidden and the drawing page takes up the entire screen. The 
drawing page grid is also turned off. Full-screen view is a view-only mode—you cannot edit or change the
pages you view.



Function
    Related Topics

Insert menu, ShapeSheet window
Opens a dialog box where you select a function to paste into a formula for a ShapeSheet cell. Visio 
pastes the function at the insertion point in the formula bar. (The command is dimmed until you click in the
formula bar to place an insertion point.)

DIALOG BOX OPTIONS
Select Function    Lists functions you can paste into a formula. When you select a function, the function 
and its arguments appear below the Select Function list.

Paste Arguments    Check this box if you want to paste placeholders for a function's arguments. Uncheck
this box to paste only the function.



Grid 
    Related Topics

View menu, drawing window
When checked, displays the grid. The grid helps you position shapes visually. You can also snap shapes 
to the grid.

The intervals of the grid correspond to the unit of measure you set in the Options dialog box. You control 
the size of the intervals in the Ruler & Grid dialog box.

You can also use the grid button on the View toolbar. Use tips to identify the button.



Group (Ctrl+G)
    Related Topics

Shape > Grouping, drawing window
Creates a group from the shapes and objects from other programs selected on the drawing page. Group 
members keep their original spatial relationships to each other and also retain their original ShapeSheet 
spreadsheets. Visio also creates a new ShapeSheet spreadsheet for the group.

You can also use the group button on the Shape toolbar. Use tips to identify the button.



Guides 
    Related Topics

View menu, drawing window
When checked, displays guides and guide points. Rulers must be visible if you want to create guides and 
guide points.

You can also use the guides button on the View toolbar. Use tips to identify the button.



Hyperlink
    Related Topics

Insert menu, drawing window

Or, right-click linked object, then choose Hyperlink > Edit Hyperlink
Opens the Hyperlink dialog box, where you can create a jump between a shape or drawing page and 
another drawing page, another file, or a World Wide Web site. 

You can also use the insert hyperlink button on the Web toolbar. Use tips to identify the button.

DIALOG BOX OPTIONS
Link To File Or URL    Specifies the file or Web site you want to link to. You can either type in a path or 
URL, or click Browse and navigate to the file or Web site. If you are using a relative path, you can simply 
type the name of the file.

Path    Indicates the full path to the file or URL. Visio updates this path as you type data in the dialog box. 
If you are using a relative path, only the appended portion of the path is indicated.

Base    Indicates the base path, which you can specify in the Properties dialog box for the file. If this is not
present in the dialog box, the path to the current document will be used.

Named Location In File    Specifies the location in a file or Web site that you want to link to. For example,
a specific page or anchor. If you are linking to a Visio drawing, you can click Browse and select a drawing 
page from a list.

Descriptive Name Of Link    Specifies a name for the link that appears in the Hyperlink section of the 
ShapeSheet spreadsheet for the shape or page. For example, "Link to our pricing Web site."

Use Relative Path For Hyperlink    A relative link describes the location of the linked file in relation to the 
Visio drawing. You can move the Visio drawing and the linked file together (that is, move the entire path 
structure) without breaking the link. An absolute link spells out the exact location of the linked file in terms 
of drives, directories, and folders. You can move the Visio drawing file without affecting an absolute link 
but if you move the linked file, you must reset the path. To specify an absolute link, uncheck Use Relative 
Path For Hyperlink.



 Icon pencil tool
    Related Topics

Edit icon toolbar, edit icon window
Use the icon pencil tool to change the color of a pixel in a bitmap. Assign the color you want to the left or 
right mouse button by clicking in the color palette, and then with the same mouse button, click the pixel 
you want to change.



Icons And Names
    Related Topics

View menu, stencil window
When checked, displays master shape icons and their names in the stencil window.



Icons Only
    Related Topics

View menu, stencil window
When checked, displays master shape icons without their names in the stencil window.

You can also use the Icons Only button. Use tips to identify the button.

Tip: Even though the names aren't visible when Icons Only is checked, you can display the master 
shape's name by placing the pointer over a master shape icon. A tip containing the master shape's name 
appears. (If you've turned off ScreenTips with the toolbar shortcut menu, these tips are also turned off.)



Import Project
    Related Topics

Project Timeline template, Project > Import Project
Opens an Open dialog box where you can locate a Microsoft Project exchange file (.mpx) to import into 
Visio. When you import the file, the project data is displayed in a project timeline.



Insert Column
    Related Topics

Project Timeline template, Project > Insert Column

Or, right-click a column or the project frame, then choose Insert Column
With a column in the project frame selected, opens the Insert Column dialog box where you choose a 
column type and type the name of the column. When you click OK, a column is inserted before the 
selected column.

Column type    Choose a column type from the drop-down list. Column Name reflects the type you 
choose.

Column name    Type a name for the column you’re inserting if you don’t want to accept the default 
name, which is the same as the Column Type.



Insert Control
    Related Topics

Developer toolbar
Inserts ActiveX controls, which are programmable objects that you can use to add functionality to a 
drawing. For example, you might insert standard Windows dialog box controls such as single-click 
buttons, check boxes, or list boxes, or custom controls that provide more complex functionality such as 
animation. To program a control, you typically write event procedures in the drawing's VBA project to 
handle the control's events, and you may get or set the control's properties or invoke its methods in other 
procedures. 

DIALOG BOX OPTIONS
Controls    Lists the controls installed on your system, including those installed by applications that 
contain the controls. You might need a design license to insert such controls in your own drawings. For 
details, contact the control vendor. 

<control name>    Displays the location of the file that contains the control selected in the Controls list.



Insert Row
    Related Topics

Project Timeline template, Project > Insert Row

Or, right-click a task bar or horizontal grid line, then choose Insert Row
Inserts a row above the selected row or task bars. To select a row, click any cell in the row. To select more
than one task bar, hold down the Shift key, then click the shapes you want to select.



Intersect
    Related Topics

Shape > Operations, drawing window
Creates one closed shape from the area in which two shapes overlap or intersect. The new shape inherits
the text and formatting of the first shape you select.

When you intersect two or more shapes, the ShapeSheet spreadsheet for the shapes you intersected are 
deleted, and Visio creates a ShapeSheet spreadsheet for the new shape.



Join
    Related Topics

Shape > Operations, drawing window
Assembles selected segments into paths. The number of paths depends upon the configuration of the 
selected shapes. 



 Lasso tool
    Related Topics

Edit icon toolbar, edit icon window
Use the lasso tool to select a non-rectangular area of a master shape icon. The area can be any size or 
contour. Drag the lasso tool to select the area you want. You can then drag the selected area to move it or
use commands on the Edit menu to change the selected area.



Last Tile button
    Related Topics

Print preview toolbar
For a large drawing that Visio tiles, displays the part of the drawing that prints on the last page (or tile).



Last Zoom
    Related Topics

View menu, drawing window
Toggles between the current view and the most recent view. 

You can also choose Last from the zoom list on the Standard toolbar. Use tips to identify the zoom list.



Lay Out Shapes dialog box
    Related Topics

Tools > Lay Out Shapes, drawing window
With certain connected drawings, such as flowcharts, you can have Visio position shapes automatically. 
The Lay Out Shapes command opens a tabbed dialog box where you can choose settings to control how 
Visio positions shapes. 

You can also use the lay out shapes button on the Shape toolbar to lay out shapes using the last-selected
layout settings. Use tips to identify the button.

By default Visio lays out all the shapes on the page, but you can choose to lay out only selected shapes, 
or exclude shapes or connectors.

Click one of the following tabs to choose layout settings:

General
Advanced



Lay Out Shapes dialog box (Advanced tab)
    Related Topics

Tools > Lay Out Shapes, click the Advanced tab; drawing window 
Contains settings that determine how the Lay Out Shapes grid is set up. This grid is separate from the 
drawing page grid; it applies only to the Lay Out Shapes command. It's set up with blocks and avenues, 
like a city map, and isn't visible on the drawing page, even when it's enabled.

Note: Avoid using the grid if your drawing contains shapes of various sizes, particularly shapes that 
exceed the size of the grid blocks. Visio can position these shapes more precisely when they do not need 
to fit within a fixed grid block.

DIALOG BOX OPTIONS
Line To Line Spacing    Specifies the minimum amount of space between connectors. 

Line To Node Spacing    Specifies the minimum amount of space between connectors and shapes.

Avenue size    Specifies the amount of space between shapes.

Block Size    Specifies the size of the shapes in your drawing.



Lay Out Shapes dialog box (General tab)
    Related Topics

Tools > Lay Out Shapes, click the General tab; drawing window
Determines how Visio places nodes (shapes) and draws, or routes, lines (connectors) between the 
shapes. Specifies the spacing between connectors, between connectors and shapes, and between 
shapes and shapes.

DIALOG BOX OPTIONS
Style    When shapes are automatically laid out, specifies the direction Visio uses to place shapes. 
Interactively determines the direction of flowchart and tree routing. Choose Top To Bottom or Left To Right
for directed drawing styles, such as organization charts, process flow diagrams, and other drawings that 
flow in a specific direction. Choose Radial for undirected drawing styles, such as network diagrams.

Depth    When automatically laying out a drawing, determines the number of levels Visio looks at in the 
drawing before establishing the layout. The more levels Visio checks, the better it can determine how 
much space to leave between shapes so that all the shapes fit. You may want to try different depth 
settings on the same drawing to find the one that produces the best results.

Routing    Indicates the type of drawing path, or route, that Visio uses to connect shapes.

Enable Grid    Check to have Visio lay out shapes based on an internal grid. You can specify settings for 
the grid on the Advanced tab.

Range    Determines whether Visio lays out only the selected shapes or all of the shapes on the current 
page.

Lay Out    Determines whether Visio lays out nodes (shapes), lines (connectors), or both.

Set Layout Properties Only    Sets the layout properties of the diagram in the page's ShapeSheet 
spreadsheet but does not change the diagram display.

Move Other Shapes Away on Drop    Shapes in the diagram automatically adjust to allow placement of a
shape that is dropped, moved, or resized on the page.

Enlarge Page to Fit Drawing on Layout    When shapes are automatically laid out, the drawing page 
enlarges to accommodate the diagram.



Layer Properties
    Related Topics

View menu, drawing and print preview windows
Creates and modifies layers in a diagram. By assigning shapes to different layers, you can selectively 
view, print, and lock layers, as well as control whether shapes on a layer can be snapped to or glued to. 

You can also use the layer properties button on the View toolbar. Use tips to identify the button.

Note: Some templates, such as the Office Layout Template, contain shapes that are already assigned to 
pre-existing layers.

Click to display information about the dialog box.



Specifies the name of the layers in the diagram. Clicking this button opens the Rename Layer box, in 
which you can change the name of the selected layer.



Displays the number of shapes assigned to each layer.



Specifies whether the shapes on a layer are visible or hidden. Check to show the layer and uncheck to 
hide the layer.



Specifies whether to print the shapes on a layer. Check to have the layer print; uncheck this option so that
the layer does not print.



Specifies the active layer to which shapes without a pre-assigned layer are assigned. Check to make the 
layer active or uncheck to deactivate the layer. The active layer cannot be locked.



Prevents shapes on a layer from being selected or altered. Check to lock the layer or uncheck to unlock 
the layer. If a layer is locked, it cannot be the active layer, and its Visible, Print, Snap, Glue, or Color 
properties cannot be changed.



Specifies whether other shapes can snap to shapes assigned to the layer. A shape on a layer that has 
Snap unchecked can still snap to other shapes, but other shapes cannot snap to it.



Specifies whether other shapes can glue to shapes assigned to the layer. A shape on a layer that has 
Glue unchecked can still glue to other shapes, but other shapes cannot glue to it.



Specifies that all shapes assigned to the layer appear in the specified color; this option does not 
permanently change the shape colors. Check to override each shape's original color in favor of the layer 
color. Uncheck to return shapes to their original colors.



Applies the current settings of the box to the drawing page without closing the box.



Adds a new layer and opens the New Layer dialog box, in which you can type a name for a new layer.



Deletes the selected layer. All shapes that are assigned to only the selected layer are deleted.



Opens the Rename Layer dialog box, in which you can rename the selected layer.



Removes all layers that do not have shapes on them.



Adds color to a layer so that all objects assigned to the selected layer appear in the layer color.



 Left Color box
    Related Topics

Edit icon toolbar, edit icon window
Displays the color assigned to the left mouse button in the edit icon window. Choose the icon pencil and 
click with the left mouse button to change the pixels in the icon to this color. To change the assigned color,
click with the left mouse button in the color palette.



Line (Shift+F3)
    Related Topics

Format menu, drawing and ShapeSheet windows
Applies formatting such as line pattern, line weight, line ends, and corner rounding to lines and arcs in the
selected shape.

You can also use line formatting buttons or the line style list on the Shape toolbar. Use tips to identify the 
buttons.

DIALOG BOX OPTIONS
Line    Displays options to change the shape's formatting.

Pattern    Choose among none, solid, or dashed lines. 

Weight    Choose an appropriate thickness.

Color    Choose among colors that are set in the Visio color palette. To add a new color to the color 
palette, choose Custom.

Cap    Choose between round and square line caps.

Line Ends    Displays options for line ends such as arrowheads for the endpoints of an open shape.

Begin    Displays line end options for the shape's begin point.

End    Displays line end options for the shape's end point.

Size    Displays options for the size of line ends.

Round Corners    Choose among various round corner formats.

Rounding    Displays the numeric equivalent for the roundness of the corner¾the higher the number, the 
rounder the corners.

Preview    Displays a preview of the options you select.

Apply    Applies formats without closing the dialog box.



 Line tool (Ctrl+6)
    Related Topics

Standard toolbar
Use the line tool to draw straight line segments in any direction. 

As you drag, hold down the Shift key to constrain the line to angles at 45-degree intervals. A single line is 
a 1-D shape when you first draw it. Adding other line or arc segments creates a 2-D shape.

Endpoints
Any selected 1-D shape displays two square endpoints: the begin point contains an X, and the end point 
contains a plus sign (+). To move a 1-D line or arc segment, drag a portion of the line other than an 
endpoint with the pointer tool. To size a 1-D line or arc segment, drag an endpoint with the pointer tool.

Arc/line segment
To change a line to an arc or to edit a line segment in a 2-D shape, use the pencil tool. You can switch 
between the arc tool, line tool, pencil tool, and freeform tool to draw shapes consisting of contiguous 
segments.



Link All Tasks
    Related Topics

Project Timeline template, Project > Link All Tasks
Links all tasks in a project timeline. A link is a dependency. Linking two tasks means that you can’t start 
the later task until the earlier task is completed.



Link Tasks
    Related Topics

Project Timeline template, Project > Link Tasks

Or, right-click a task bar or horizontal grid line, then choose Link Tasks
Links selected tasks in a project timeline. A link is a dependency. Linking two tasks means that you can’t 
start the later task until the earlier task is completed.



Links 
    Related Topics

Edit menu, drawing window
Opens a dialog box where you can manage links between objects from other programs in Visio drawings 
and their original files. You can view the links and choose whether to update the object manually or 
automatically as you use the original program to edit the linked file. You can also open a dialog box where
you can change the file reference for the linked object.

DIALOG BOX OPTIONS
Links    Lists the object's folder path, the original OLE program used to create the linked object, and the 
update option you specified: Automatic or Manual. To change information for a linked file, choose it from 
the list. You can then change its update option or use the Change Source button to change the file 
reference.

Source    Lists the folder path.

Type    Lists the original OLE program used to create the linked object.

Update    Specifies when Visio updates the linked object. Choose Automatic or Manual.

Update Now    Checks the file reference. If changes have been made since you last updated, Visio 
applies those changes to the object.

Open Source    Opens the OLE program used to create the linked object.

Change Source    Opens the Change Source dialog box, where you can change the file reference to the 
correct file.

Break Link    Breaks the link between the object and the original file. Future changes to the original file 
will not affect the object on the drawing page, which Visio changes to a Windows metafile. As a result, you
don't have to provide any additional files when giving someone a Visio drawing on disk.



Lotus Notes Field
    Related Topics

Insert menu
Opens a dialog box where you can create and display Lotus Notes Fields for the active drawing.

If you create a field in Lotus Notes, you need to create a corresponding field in the Lotus Notes Field 
dialog box in order for Visio to read the field. Once you create a field in Visio, you can embed a Visio 
object into a Lotus Notes document.

Fields created using the Lotus Notes Field command are also displayed in the Field dialog box.

DIALOG BOX OPTIONS
Field Name And Direction    Displays the field name. Indicates whether the field is read from Lotus Notes
or written to Lotus Notes.

If Read From Notes is checked, choose from Text, Time, and Number.

If Write To Notes is checked, choose from:

Text    Choose from Text, Name, Data 1, Data 2, Data 3 and Help.

Time    Enter a custom formula that returns a time or date.

Number    Enter a custom formula.

Data Type    Lists three data types for the field: Text, Time, Number. Also lists available shape fields.

Custom Formula    Use this section to enter a custom formula for a field.



Macros (Alt+F8)
    Related Topics

Tools menu, Macro submenu
Opens a dialog box that displays macros and add-ons that you can run to automate a specific task.

DIALOG BOX OPTIONS
Macro Name    Specifies the name of the macro or add-on to run, edit, delete, or step into. To create a 
macro, enter a new name, then click the Create button. 

Run    Runs the seleted macro. You can also use the run macro button on the Developer toolbar. Use tips 
to identify the button.

Step Into    Begins executing the selected macro in the Visual Basic Editor and allows you to step through
its execution.

Edit    Opens the selected macro in the Visual Basic Editor so you can edit its code.

Create    Creates a macro with the given name and opens it in the Visual Basic Editor.

Delete    Deletes the selected macro.

Macros In    Determines the set of macros and add-ons that are listed in the dialog box. You can list:

· Macros in the active drawing (but not all open drawings) and all available add-ons.

· Available add-ons only.

· Macros in a specific module in any Visio file that is currently open with read-write access. 

Description    Displays information about the selected macro. You can assign a description to a macro 
using the Object Browser in the Visual Basic Editor. For details about the Object Browser, see the 
Microsoft Visual Basic online help.



Mail Recipient
    Related Topics

Send To submenu, drawing window
Choose to send a drawing to another person through e-mail. Your mail program opens with a new 
message containing the Visio drawing as an attachment. To open Visio and view the drawing, open the 
mail message and double-click the Visio icon.



Make Department, Make Subpage
    Related Topics

Organization Chart Template, right-click a position shape, then choose Make Department

Web Diagram Template (Visio Professional only), right-click a URL shape, then choose 
Make Subpage
When an organization chart or Web site diagram is large enough to require more than one drawing page, 
use this command to move parts of the diagram to other pages.

Choosing the command opens a dialog box in which you can click OK to create a new drawing page. The 
selected shape and all the shapes connected to it are placed on the new page. A copy of the selected 
shape remains in the original location.

To jump from the original shape to the new drawing page, right-click the shape, then choose Go To [Page 
Name]. To return to the original page from the new page, right-click the drawing page, then choose Go To 
[Page Number].

DIALOG BOX OPTIONS
Page Name    Type or choose a name for the new drawing page. 

Add Title Bar To New Page    Adds a title bar to the top center of the new drawing page. The page name 
appears in the title bar.



Months/Years
    Related Topics

Project Timeline Template, right-click Project Frame shape, then choose Months/Years

Or, right-click the timescale or nonworking strip, then choose Months/Years
Changes the timeline to display months and years. When you change the units, the size of the project 
frame doesn’t change so the smaller the unit (Days/Months being the smallest unit), the shorter the time 
period displayed in the project frame, and the longer the task bars.



More <options>
    Related Topics

File > New > More Templates; File > Stencils > More Stencils; Tools > Macro > More 
Macros
Use these commands to display more options from which to choose. Choose More Templates or More 
Stencils to display additional templates and stencils, or choose More Macros to display all macros and 
automated tools available from the Tools menu.



Name
    Related Topics

Insert menu, ShapeSheet window
Opens a dialog box where you select a cell name to paste into a formula for a ShapeSheet cell. Visio 
pastes the cell name at the insertion point in the formula bar. (The command remains dimmed until you 
place an insertion point by clicking in the formula bar.)

DIALOG BOX OPTIONS
Select Name    Lists the names of cells in the open ShapeSheet spreadsheet.

Insert    Pastes the selected cell name into the formula. You can paste one cell name after another at the 
insertion point.

Close    Cancels all changes made since you opened the dialog box.



Names Only 
    Related Topics

View menu, stencil window
When checked, displays the names of master shapes in the stencil window. 

You can also use the names only button. Use tips to identify the button.



New Drawing
    Related Topics

File > New > Browse Templates
Opens a dialog box in which you can navigate to the folder that contains the template on which you want 
to base a new drawing.

You can also use the new button on the Standard toolbar. Use tips to identify the button.

DIALOG BOX OPTIONS
Look In    Displays the current folder. Double-click the folder you want to open.

Up One Level    Moves the Look In folder up one level in the hierarchy.

Create New Folder    Creates a new folder in the current hierarchy.

List    Displays the list as an icon and a label.

Details    Displays list of files by name, size, type, and modified date.

File Name    Displays files that are in the format selected in the Files Of Type list.

Files Of Type    Displays the file formats you can import in the folder you chose.

Open    Includes options for opening the file as an original, a copy, or in read-only mode.

Preview    Displays the first page of the file (if the file was saved with a preview picture).

Description    Displays information about the selected template or wizard.



New Layer dialog box
    Related Topics

View menu, Shape Layer dialog box
Creates a new layer. This dialog box is displayed by clicking New in the Shape Layer dialog box. To 
create a new layer, type a name in the Layer Name box, this click OK. The new layer appears in the 
Shape Layer dialog box.



New Master
    Related Topics

Master menu, stencil window
Creates and displays a blank master shape icon for a new master shape. Use the command to specify 
the new master shape's name, icon size, icon update method, and master shape prompt. When you 
double-click the blank icon, Visio opens the master drawing window, where you can draw the new master 
shape.

DIALOG BOX OPTIONS
Master Name    Displays the name that appears under the master icon in the stencil window. Master 
shape names can contain up to 31 characters. To specify how the name is aligned below the icon, choose
Left, Center, or Right.

Icon    Specifies the icon size and when Visio should update the icon.

Size    Choose Normal, Tall, Wide, or Double. The default icon size is Normal. Tall is the same width, 
but twice the height; Wide is the same height, but twice the width. Double is twice as wide and twice as
tall as Normal. Choose the Edit Icon command on the Master menu to adjust the icon to fit a larger 
size.

Update    Updates the master shape icon each time you edit the drawing of the master shape. 
Manually updates a master shape icon when you choose Update Icon from the Master menu.

Master Type    Specifies whether the shape is to be a shape, line pattern, line end, or fill pattern.

Prompt    Displays the text that appears when you point to the master icon in the stencil window. To 
change the text, type new text in the Prompt box.

Match Master By Name On Drop    If you've created a stencil, preserves the formatting you've applied to 
the stencil's master shapes. For example, you've modified the shapes in the Office Layout stencil, created
a stencil called My Office, then you drop a shape from the Office Layout stencil into the drawing.

· If Match Master By Name On Drop is checked for the shapes on the My Office stencil, when you drop a
shape into the drawing, Visio checks to see if the shape you're dropping matches any of the master 
shapes in the My Office stencil. If it finds a match, Visio formats the shape with the changes you made 
to the My Office master shape. 

· If Match Master By Name On Drop is unchecked for the shapes on the My Office stencil, when you 
drop a shape from the Office Layout stencil, the shape is added to the drawing file with the default 
Office Layout formatting.



New Window
    Related Topics

Window menu
Opens a copy of the active window (stencil, drawing, or ShapeSheet spreadsheet) in a new window.



Next Page
    Related Topics

Edit > Go To, print preview window
Displays the next page in the current drawing file.

You can also use the next page button on the Page toolbar. Use tips to identify the button.



Next Tile
    Related Topics

View menu, print preview window
For a large drawing that Visio tiles, displays the next printed page (or tile) of the drawing.

You can use the View > Previous Tile command to display the previous tile.

You can also use the next tile button. Use tips to identify the button.



Object (Insert)
    Related Topics

Insert menu, drawing window
Inserts objects from other programs into a Visio drawing. You can either open another program from 
within Visio and create a new object or insert an existing file into Visio.

DIALOG BOX OPTIONS
Object Type    Lists the types of objects that you can link or embed from an OLE-compatible program. 
The items in the list depend on which OLE-compatible applications are installed on your computer. Some 
programs installed on your system appear as commands on the Page menu. Choose the program's 
command to insert an object created in that program.

Create New    Opens the corresponding program and creates the object you want to insert.

Create From File    Inserts an existing file. To link the object to Visio, choose Link. 

Display As Icon    Displays the application's icon in Visio.

Change Icon    Displays the Change Icon option. When Display As Icon is checked, you can choose 
between the current icon, a default icon, or an icon from a bitmap file. You can also change the icon 
Label.

Result    Displays a message detailing the result you'll get by clicking OK.



Object (Edit)
    Related Topics

Edit menu, drawing window
Displays the submenu of commands that you use to work with embedded or linked objects from another 
application. Usually the submenu contains the <OLE object> Edit  and the <OLE object> Convert 
commands. In some cases, the submenu may contain the Open command.

Tip: This command is available only when an OLE object is selected.

If you select an embedded or linked object, the menu command's name reflects the type of object. For 
example, if you select a Windows Paintbrush object, the menu command appears as Paintbrush Object.



Offset 
    Related Topics

Shape > Operations
Creates a set of parallel lines and curves on either side of the original shape. For example, you can 
create a representation of a two-way road by offsetting a line. If the offset to a curve is neither a line nor a 
curve, then it is approximated by a spline. This approximation comes as close as possible to fitting all the 
points that are a specified distance from a curve.

DIALOG BOX OPTION
Offset Distance    Specifies the offset distance you want from the original line or curve.



Online Support 
    Related Topics

Help > Visio On The Web
Opens your World Wide Web browser application and displays a site where you can find "tips & tricks" 
and answers to specific product support questions.



Open (Ctrl+O)
    Related Topics

File menu
Displays a dialog box where you can open an existing drawing file, stencil, template, workspace, or other 
graphic formats.

You can also use the open button on the Standard toolbar. Use tips to identify the button.

DIALOG BOX OPTIONS
Look In  Displays the current folder. Double-click the folder you want to open.

Up One Level  Moves the Look In folder up one level in the hierarchy.

Create New Folder  Creates a new folder in the current hierarchy.

List  Displays the list as an icon and a label.

Details  Displays list of files by name, size, type, and modified date.

File Name  Displays files of the type specified in the List Files Of Type box. To open a file, choose from 
the list, or type a path and filename in the box.

Files Of Type  Displays the file types you can open, identified by their filename extension. To change the 
type, choose from the list.

Description  Displays information about the selected file. This information comes from the Description 
box in the Properties dialog box.

Open button  Opens the selected file.

Open section  Determines whether the file is opened as original, copy, or read-only.

Preview  Displays a preview of the selected file if a preview has been saved for the file in the Properties 
dialog box.

File Preview  Turns file preview on or off.



Opens the original file so you can edit it. If this option is dimmed when opening a stencil file, it means the 
original stencil is open or has been saved as read-only.



Opens an untitled copy of the selected file. You can edit the file, and then use the Save As command on 
the File menu to name and save it. You cannot save it with its original name (default for a template).



Opens a read-only file. Read-only templates or drawing files are identified in the title bar with brackets. 
Use this option to open a stencil that you don't expect to modify.



Open Group, Open <group name> 
    Related Topics

Edit menu, drawing window
Opens the selected group and displays its component shapes in the group window. (If you have named 
the group by using the Special command, the group name follows the command Open; otherwise, the 
command reads Open Group.)

Whether or not the group is rotated on the drawing page, it does not appear rotated in the group window. 
Shapes appear as if they were independent, not grouped. The group window displays a page just large 
enough to hold the shapes. You can edit the shapes in the same way as you edit shapes in the drawing 
window. Changes you make in the group window are reflected in the drawing window.

Tip: After editing the shapes in a group in the group window, you might need to readjust the width and 
height of the group so its selection rectangle tightly encloses all the group's shapes. To do this, select the 
group, and choose Update Alignment Box from the Tools menu.



Open (Hyperlink submenu)
    Related Topics

Hyperlink submenu
Jumps from the linked object to its destination. In full-screen view, you can simply click the shape or page 
to open the hyperlink.



Open In New Window
    Related Topics

Hyperlink submenu
Opens the linked object's destination in a new window. 



Open In Visio
    Related Topics

View menu, in-place window only
Opens Visio in its own window when working with an embedded or a linked Visio drawing in place in an 
OLE container application. When Visio is open in its own window, you can open original stencil files so 
you can add or delete shapes from a stencil.

Note: When Visio is open in its own window, the File and Window menus are updated to include 
additional commands.



Open Stencil
    Related Topics

File > Stencils > Browse Stencils 
Opens a stencil in the stencil window. Use the Stencils command to open additional stencils or to open an
original stencil file so you can add or modify master shapes.

You can also use the open stencil button on the Standard toolbar. Use tips to identify the button.

DIALOG BOX OPTIONS
File list    Lists folders of drawing types for which Visio includes stencils. Double-click to open a folder, 
then select a stencil and click Open.

Note: If you created your own stencil (.vss file) and saved it in the Visio\Solutions folder, it will also be 
included in the Open Stencil file list.

Browse    Displays the Open dialog box, where you can search folders to find a stencil file.

Open    Determines whether the stencil opens as an original, a copy, or a read-only version.

Description    Displays information about the selected stencil file. This information comes from the 
Description box in the Properties dialog box.

Filename    Displays the Windows path for the file name.



Options dialog box
    Related Topics

Tools > Options
Opens a tabbed dialog box where you can set paths to files Visio saves or uses, units of measure, 
spelling settings, and other options.

Click one of the following tabs to set file options:

General
File Paths
Default Units
Spelling
Advanced



Options dialog box (Advanced tab)
    Related Topics

Tools > Options, click the Advanced tab
Specifies advanced user and developer settings.

DIALOG BOX OPTIONS
Record Actions In Microsoft Outlook Journal    Specifies that your actions, such as editing a file, are 
recorded in Microsoft Outlook Journal.

Enable Page Rotation    Enables dynamic page rotation so that you can use the rotation tool to grab the 
corner of a page and rotate it.

Undo Levels    Specifies the number of consecutive actions you can undo. The higher the number, the 
more memory Visio requires to store the actions.

Recently Used Files    Specifies the number of recently used files listed on the File menu. You can then 
choose the files on the File menu to reopen them quickly.

Enable Microsoft Visual Basic For Applications    Enables Visual Basic for Applications (VBA) in Visio. 
If unchecked, disables VBA.

Enable Automation Events    Enables Visio events to be sent to Visio add-ons and VBA macros. If 
unchecked, disables all Visio events.

Run in Developer Mode    Enables certain user interface functions for the development environment. If 
checked, the Show Shapesheet command is added to shapes' context (right-click) menus.

Put All Settings In Visio.ini File    Includes all possible application settings in Visio.ini file. By default, 
Visio writes out only those settings that are not default and a few others that are useful (for example, file 
paths, import and export filters, and last files) to keep the file small and simple.



Options dialog box (Default Units tab)
    Related Topics

Tools > Options, click the Default Units tab
Specifies the default units of measure for your drawings.

DIALOG BOX OPTIONS
Page    Specifies the unit of measure for a page's dimensions, margins, drawing size, scale, and other 
features.

Text    Specifies the unit of measure for indents, line spacing, and other text measurements. The default 
unit for type size is points (1 point = 1/72 in.). You can enter type size in another unit of measure (for 
example, 1 ft. or 12 in.), but you can't change the default unit for type size.

Angle    Specifies the unit of measure for the angle of rotation. 

Duration    Specifies the unit of measure for duration, which is elapsed time as compared to a specific 
date or a given hour.



Options dialog box (File Paths tab)
    Related Topics

Tools > Options, click the File Paths tab
Specifies the default file paths for Visio files. To change the default path, select the option you want to 
change and type a new path.

Tip: You can specify multiple paths by separating them with semicolons. For example, in the Add-ons 
option Visio looks in two folders for macros and add-ons: Solutions and Startup.

DIALOG BOX OPTIONS
Drawings    Displays the default drawings folder: My Documents.

Templates    Displays the default templates folder: Solutions.

Stencils    Displays the default stencil folder: Solutions.

Help    Displays the default help files folders: Help;Solutions.

Add-ons    Displays the default folders for macros and add-ons: Solutions;Startup.

Start-up    Displays the folder for macros and add-ons opened when you start Visio: Startup.

Filters    Displays the default filters folder: System\Filter32.



Options dialog box (General tab)
    Related Topics

Tools > Options, click the General tab
Opens a dialog box where you can set the units of measure, the default folder in which drawing files are 
saved, and other options.

DIALOG BOX OPTIONS
User Name    Specifies the name of the person working on the file. This name appears in the File 
Properties dialog box the first time you save the file.

Macro Virus Protection    Specifies whether or not to check drawings for macros that may contain 
viruses. When Macro Virus Protection is enabled, documents run in design mode. 

Prompt For Document Properties On Save    Specifies to display the Properties dialog box for the file 
when you save. File properties include author name and information such as the status of the file, preview
settings, and other properties.

Freeform Drawing    For a shape drawn with the freeform tool, the Precision bar controls how many 
points there are in the shape, and Smoothing controls how precisely Visio smoothes the mouse 
movements.



Options dialog box (Spelling tab)
    Related Topics

Tools > Options, click the Spelling tab

Or, Tools > Spelling, click Options
Specifies default settings for the Spelling command.

DIALOG BOX OPTIONS
Search  Specifies where Visio checks the spelling of text.

Selection  Specifies to check the spelling of only the current selection.

Page  Specifies to check the spelling of only the current page.

All Pages  Specifies to check the spelling of the entire drawing file.

User Dictionaries  Specifies the dictionaries Visio uses to check the spelling of text.

Active  Specifies the dictionaries Visio is currently using to check the spelling of text.

Add  Opens the Add User Dictionary box, in which you can add a new dictionary to the list of active 
dictionaries.

Remove  Removes a dictionary from the list of active dictionaries.

Use MS Word Dictionaries  If you have Microsoft Word installed, check this option to use its dictionary.

Ignore Words With Numbers  Check this option if you want Visio to ignore words that have numbers in 
them.



Organization Chart Wizard
    Related Topics

File > New > Business Diagram

Or, Tools > Macro > Business Diagram 
Starts the Organization Chart Wizard, which reads employee data from a text (.txt), Microsoft Excel (.xls), 
or database file and generates an organization chart. The database must have been created in an ODBC-
compliant database application and the employee data must be contained in one database table.

You can also use the Organization Chart Wizard to generate and format a generic organization chart to 
which you can add your own information.





Page (Go To submenu)
    Related Topics

Edit > Go To, drawing and print preview windows
Opens a dialog box in which you can choose a page to display in the drawing window. 

You can also choose a page to display from the list on the Page toolbar. Use tips to identify the button.

DIALOG BOX OPTIONS
Select Page    Displays a list of background and foreground pages in the drawing file. Foreground pages 
are listed in bold type; background pages are listed in normal type. The current page is dimmed.

New    Displays the Page (Insert) dialog box so that you can create and go to a new page.

Open Page In New Window    Displays the selected page in a new window.



Page (Insert menu)
    Related Topics

Insert menu, drawing window
Creates a new page and opens a tabbed dialog box where you can change the settings for the new page.
To create a new page or a background with the same settings as the page currently displayed, leave the 
settings as shown, and then click OK in the Page dialog box.

The Page dialog box is similar to the Page Setup dialog box. Use the Page command to create and set 
options for a new page. Use Page Setup to change the settings for the displayed page.

Visio adds the new page after the last page in the drawing file. You can change the page order by using 
the Reorder command on the Page menu.

DIALOG BOX OPTIONS
Click one of the following tabs to change page options:

Page Size
Drawing Scale
Page Properties



Page Breaks
    Related Topics

View menu, drawing window
Displays page breaks for a drawing that's larger than the paper in the printer on which you want to print it.
Page breaks are displayed where the document tiles when printed. Page breaks are determined by 
settings in the Page Setup dialog box.



Page Layout Wizard
    Related Topics

Tools > Macro > Visio Extras
Automates setting up the page and adding title or border details.



Page Setup dialog box
    Related Topics

File > Page Setup, drawing and print preview windows
Opens a tabbed dialog box where you change page size and orientation, printer settings, drawing scale, 
and set other options.

Click one of the following tabs to change page setup options:

Page Size
Drawing Scale
Page Properties
Output Format
Header/Footer



Page Setup dialog box (Drawing Scale tab)
    Related Topics

File > Page Setup, click Drawing Scale tab; drawing and print preview windows
Determines the drawing page size and scale.

Note: If you choose No Scale in the Drawing Scale tab and choose 100% scale in the Print Setup dialog 
box, the printed drawing will be the same size as the drawing page. Changing the scale of a drawing page
does not change the scale of a background page assigned to it.

Tip: If you specify a scale other than No Scale, you can specify the size of the drawing in scaled units 
(shown on the Visio rulers) by setting dimensions for Page Size. You can specify the size of the drawing 
page in units by choosing Custom in the Page Size option. For example, If you want the drawing to be 40 
feet by 50 feet in scaled units, specify a scale of 1 inch = 1 foot. Then, you can type either 40 feet by 50 
feet in the Dimensions option or 40 inches by 50 inches in the Custom option.

DIALOG BOX OPTIONS
Drawing Scale    Specifies the scale of the drawing. You can choose from the following options:

No Scale (1:1)    If the drawing should print at its actual size, choose No Scale. If you specify No Scale 
and chose Same As Printer in the Drawing Size section, the drawing page and printed drawing are the 
size specified for paper with the Page Setup command on the File menu.

Metric    Changes the list in the Scale box to include Metric standard scales, such as 1:100.

Architectural    Changes the list in the Scale box to include Imperial measurements such as 3/32" = 1' 
0".

Civil Engineering    Changes the list in the Scale box to include Imperial measurements such as 1" = 
10' 0".

Mechanical Engineering    Changes the list in the Scale box to include Imperial measurements such 
as 1/32:1.

Custom Scale    Sets a custom ratio of page size to drawing size. For example, at 1 inch = 25 feet, a 
shape which measures 1 inch (when printed at 100 percent) measures 25 feet on Visio's rulers.

Scaled Drawing Size    Specifies the size of the drawing page, based on the Drawing Scale you choose 
and the Physical Page Size.

Physical Page Size    Indicates the size of the printed page. You can change this setting in the Page Size 
tab.



Page Setup dialog box (Header/Footer tab)
    Related Topics

File > Page Setup, click Header/Footer tab; drawing and print preview windows
Specifies the text and formatting for the header and footer, which will appear on all of the pages of the 
drawing. The header and footer only appear on the printed page, not on screen.

DIALOG BOX OPTIONS
Header And Footer    Specifies text that appears at the top (header) or bottom (footer) of every tile when 
you print pages from the drawing file. You can type up to 128 characters in each of the header and footer 
boxes.

Margins    Specifies the distance from the text to the edge of the page. For Header, the distance is 
measured from the top of the header text to the upper edge of the page. For Footer, the distance is 
measured from the bottom of the header text to the lower edge of the page.

Formatting    Indicates the text formatting specified for the header and footer. Click Choose Font to open 
a dialog box when you can choose font, style, size, and other text formatting options.

Target Printer Information    Indicates paper size and orientation specified in the Print Setup dialog box. 
To change the settings, click Print Setup.

Print Setup button    Opens a dialog box where you can choose printing options, such as the orientation 
and size of the paper, the margins, reduce/enlarge options, and the targeted printer.



Page Setup dialog box (Output Format tab)
    Related Topics

File > Page Setup, click Output Format tab; drawing and print preview windows
Sets the output format for the open drawing. This tab applies to all pages in the active document.

By default, Visio formats drawings for printing. Choose a screen resolution option (PowerPoint Slide Show
and HTML or GIF Output) if you intend to use the drawing onscreen, for example, in a PowerPoint slide 
show or on a Web page.

When you choose the onscreen format, Visio substitutes screen fonts for any printer fonts you've used in 
the text of your drawing.



Page Setup dialog box (Page Properties tab)
    Related Topics

File > Page Setup, click Page Properties tab; drawing and print preview windows
Opens a dialog box where you can change the size, scale, and other settings for a drawing page.

DIALOG BOX OPTIONS
Page Properties    Specifies the page type and name, whether a background is assigned to it, and the 
unit of measurement of the rulers. 

Shape Shadow Offset    Specifies the position of shadows in relation to shapes. All shapes on a page 
that are formatted with shadows have the same shadow offset. By default, shadows appear 0.125 inches 
down and to the right of the shape. Type new distances after Right and Down to change the shadow 
offset. To position shadows above or to the left of a shape, type negative numbers.

Add Line Jumps To    Specifies that line jumps be on horizontal or vertical routers only, or that they be on
the last router that was created or adjusted. If you choose Last Routed Line, jumps will occur on both 
horizontal and vertical routers. A line jump is a small, uneditable arc that occurs on one of two crossing 
lines, indicating that the lines are crossed rather than connected.

Page Size And Drawing Scale    Displays the page size and scale. To change these settings, click the 
Page Size or Drawing Scale tab.



Lists properties for either the drawing page or the background page.



To change the name of the drawing page, type a name containing up to 31 characters.



Lists the name of the background page in the drawing.



Choose the unit of measure the Visio rulers should display on the page. Unless you specify different units 
here, the ruler units will be those specified in the drawing scale.



Page Setup dialog box (Page Size tab)
    Related Topics

File > Page Setup, click Page Size tab; drawing and print preview windows
Specifies page size and orientation, as well as print setup options.

DIALOG BOX OPTIONS
Page Orientation    Specifies the drawing page orientation as either portrait (a page taller than it is wide) 
or landscape (a page wider than it is tall). Changing the orientation of the drawing page does not change 
the paper orientation of the paper you print on. Make sure the drawing page size and orientation you 
choose will fit on the paper size and orientation you specify in the Print Setup dialog box.

Page Size    Specifies the dimensions of the drawing page. You can choose a Custom Page Size from the
list and then type custom dimensions or you can choose one of the following options: (Options in the list 
reflect page orientation as well as size. The width is listed first and then the height.)

Standard    Changes the list in the Page Size box to include Imperial standard paper sizes, such as 
letter, legal, and so on.

Metric (ISO)    Changes the list in the Page Size box to include Metric standard paper sizes, such as 
210mm x 149mm.

ANSI Engineering    Changes the list in the Page Size box to include ANSI Engineering standard 
paper sizes, such as 8.5in x 11in.

ANSI Architectural    Changes the list in the Page Size box to include ANSI Architectural standard 
paper sizes, such as 9in x 12in.

Custom Page Size    Lets you enter a custom dimensions in the Page Size box.

Size Page To Fit Drawing    Creates a drawing page just large enough to contain the shapes.

Custom Scaled Drawing Size    Specifies the ratio of the printed drawing to the drawing page.

Same As Printer    Matches the drawing page size to the paper size specified in the Print Setup dialog 
box.

Print Setup    Opens a dialog box where you can choose printing options, such as the orientation and 
size of the paper, the margins, reduce/enlarge options, and the targeted printer.



Page toolbar
    Related Topics

View > Toolbars, Toolbar shortcut menu
Displays a Visio toolbar that provides buttons you can use as shortcuts for choosing menu commands. To
switch the toolbar, choose View > Toolbars or right-click the toolbar, then choose Page from the shortcut 
menu.

The tools on the Page toolbar are 

· Snap

· Glue

· Previous Page

· Next Page

· Go To Page

Note: Your toolbar may vary depending on the display resolution of your monitor, the size of your window,
and which window is active. 



Page Width
    Related Topics

View menu, drawing window
Displays the entire width of the page in the drawing window.

You can also adjust width view by using the Actual Size command. 

You can also choose Width from the zoom list on the Standard toolbar. Use tips to identify the zoom list.



 Paint bucket tool
    Related Topics

Edit icon toolbar, edit icon window
Use the paint bucket tool to change the color of an area of a master shape icon (a bitmap). Assign the 
color you want to the left or right mouse button by clicking in the color palette. Then click a pixel in the 
area you want to change with the same mouse button. The new color is applied to all contiguous pixels of 
the same color in the area you clicked.



Paste (Ctrl+V)
    Related Topics

Edit menu (not in print preview window)
Pastes the shape, object, or text stored on the Windows clipboard into the center of the active drawing 
window. If a text block is open, text is pasted at the insertion point. The pasted item remains on the 
Clipboard until you use the Copy or Cut command again.

If both programs support OLE, pasting embeds the object. Many Windows programs put objects on the 
Clipboard in several formats. The Paste command chooses a preferred format. To select a specific 
format, choose the Paste Special command from the Edit menu. 

You can also use the paste toolbar button. Use tips to identify the button.



Paste As Hyperlink
    Related Topics

Edit menu
Appears when you have a hyperlink on the clipboard. Pastes the hyperlink into the document.



Paste Special
    Related Topics

Edit menu, drawing window
Pastes an object on the clipboard into a Visio drawing in the format you choose.

Many Windows programs put information on the Clipboard in several formats. With this command, you 
can choose which format you want. For example, Visio automatically embeds objects from OLE-
compatible programs, but you can use the Paste Special command to paste the object as a non-editable 
bitmap.

DIALOG BOX OPTIONS
Source  Identifies the program used to create information on the Clipboard. If the program is unknown, 
displays Unknown.

As  Lists the default format and other formats that Visio can use. Usually these include Bitmap, Picture (a 
Windows metafile), and Text. Choose the format you want from this list.

Paste  Pastes the Clipboard contents onto the page in the specified format. Depending on the program 
that created the object, pasting may embed the object in Visio.

Paste Link  Pastes the Clipboard contents onto the page in the specified format and establishes a link to 
the original file.

Result  Displays a message that describes the result you'll get by clicking OK.

Display As Icon  Displays the OLE object as an icon in a drawing.

Tip: You can convert Visio shapes into a Windows metafile with the Paste Special command. To convert 
shapes, select them, copy them to the Clipboard with the Cut command, and then use the Paste Special 
command to paste them as a metafile. If you've completed a complex drawing and know you won't need 
to make further changes, converting it to a metafile may reduce its file size. 



 Pencil tool (Ctrl+4)
    Related Topics

Standard toolbar
Use the pencil tool to draw both line and arc segments. You also use the pencil tool to edit shapes by 
dragging an endpoints, a control point, or a vertex. Drawing with the pencil tool relies on gesture 
recognition.

Line segment
To draw a line segment, drag the pencil tool in a straight line in any direction. The pointer displays a small 
line. Hold down the Shift key as you drag to draw lines at 45-degree intervals.

Arc segment
To draw an arc segment, drag the pencil tool along a curve. The pointer displays a small arc.



Picture
    Related Topics

Insert menu, drawing window
Displays a list of graphic files that you can insert into a Visio drawing. Visio converts the image to a 
metafile that cannot be edited or rotated. To edit the image, you must convert it to a Visio object using the 
Ungroup command.

DIALOG BOX OPTIONS
Look In  Displays the current folder. Double-click the folder you want to open.

Up One Level  Moves the Look In folder up one level in the hierarchy.

Create New Folder  Creates a new folder in the current hierarchy.

List  Displays the list as an icon and a label.

Details  Displays list of files by name, size, type, and modified date.

File Name  Displays files that are in the format selected in the File Type list.

Files Of Type  Displays the file formats you can import in the folder you chose.

Open  Opens the selected file.

Depending on the format of the graphic file you're importing, Visio may respond with a dialog box that 
contains options for setting Color Translation. If you import .cgm, .eps, or .pct files, the dialog box also has
options for Retain Background, Emulate Line Styles, and Color Translation.

Retain Background  When checked, preserves the background color of the original image. To do this, 
Visio draws a background rectangle in that color.

Emulate Line Styles  When checked, draws thick or patterned lines as polygons rather than as lines to 
ensure they match the lines of the original file.

Color Translation  Lists five options for displaying color: normal, inverse, inverse grays only, gray scale, 
and inverse gray scale.



Matches the color of the original image.



Inverts the colors (for example, what was black becomes white).



Inverts only the black, white, and gray shades, matching all other colors to the original file.



Converts all colors to gray shades (useful if you plan to print on a monochrome printer).



Converts all colors to grays and inverts them.



 Pointer tool (Ctrl+1)
    Related Topics

Standard toolbar
Choose the pointer tool from the Standard toolbar to select shapes so you can move, format, and size 
them. You also use the pointer tool to drag master shapes from stencils and drop them in the drawing. 
When you move the pointer tool over a shape that you can select, the pointer turns white.

Selection net
You can select more than one shape by dragging the pointer tool to form a selection net that encloses all 
the shapes you want to select. The shape that is first in the stacking order becomes the primary selection.

Selection handles
The number of handles on a selected shape depends on its type and size. A 1-D arc or line segment has 
handles at each endpoints and one in between. A 2-D shape displays at least four handles and can 
display eight selection handles at a large enough view.



Previous Page
    Related Topics

Edit > Go To, print preview window
Displays the previous page in the current drawing file.

You can also use the previous page button on the Page toolbar. Use tips to identify the button.



Previous Tile
    Related Topics

View menu, print preview window
For a large drawing that Visio tiles, displays the previous printed page (or tile) of the drawing.

You can use the View > Next Tile command to display the next tile.

You can also use the Previous Tile button. Use tips to identify the button.



Print (Ctrl+P)
    Related Topics

File menu, drawing and print preview windows
Opens a dialog box where you specify which pages to print and other print options. Clicking the OK button
sends the drawing file to the selected printer.

You can also use the print button on the Standard toolbar to print the current page. Use tips to identify the 
button.

DIALOG BOX OPTIONS
Printer  Displays the name, status, and location current printer. To change the printer, choose another 
printer listed for Name.

Print To File    Specifies that Visio sends the information for printing to a file on disk, rather than to the 
printer. When you click OK, a dialog box opens in which you name the print file and specify where it 
should be saved. You can send the resulting print file from any computer connected to the printer 
specified for the drawing file, even if Visio is not installed on the computer. 

Color As Black  If checked, Visio prints all colors as black to ensure that all shapes are visible in the 
printed drawing. This is useful if a monochrome printer translates very light colors in a drawing to white 
rather than a shade of gray.

Properties    Opens a tabbed dialog box where you can specify printer properties such as paper size 
and orientation, and print resolution. The options available depends on your printer. For details, see the
documentation for your printer.

Print Range  Specifies which drawing pages to print. Choose All Pages or Current Page, or specify a 
range of pages.

Copies  Specifies the number of copies.



Prints every page in the drawing file in the order in which the foreground pages are stored in the file. This 
is the default setting.



Prints the currently displayed drawing. If the page is a foreground, Visio prints the entire drawing. If the 
page is a background, Visio prints the background and the backgrounds on lower layers in the drawing, 
but does not print the foreground and backgrounds on higher layers in the drawing.



Prints only the specific range of pages identified by the values you type in the From and To boxes.



Tells Visio how many copies to print (default is 1).



Print Preview
    Related Topics

File menu, drawing and print preview windows
Opens the print preview window and displays a drawing as it will appear when printed. When you preview
a drawing in the print preview window, Visio displays the drawing within the margins and tiles the drawing 
if the drawing page is larger than the page size. 

Note: If the Print Preview command is checked on the menu, choosing this command displays the 
drawing window.

Once you're in the print preview window, you can use the View > Previous Tile and View > Next Tile 
commands to move from tile to tile or page to page.

To exit the print preview window, click the Close button or press the Esc key.

You can also use the print preview button on the Standard toolbar. Use tips to identify the button.



Print Preview toolbar
    Related Topics

View > Toolbars > Print Preview, print preview window
Check to display the print preview toolbar in the print preview window. Uncheck to hide the toolbar. The 
toolbar includes tools for zooming in and out, moving between tiles, and displaying the whole page or a 
single tile at a time as well as tools for printing, saving, and opening files.



Print Setup dialog box
    Related Topics

File > Page Setup, click Page Size tab or Header/Footer tab, click Print Setup
Specifies page size and orientation, as well as print setup options.

DIALOG BOX OPTIONS
Paper    Identifies the paper size and source. For details about options, see your printer documentation.

Orientation    Specifies the drawing page orientation as either portrait (a page taller than it is wide) or 
landscape (a page wider than it is tall). Changing the orientation of the drawing page does not change the
paper orientation of the paper you print on. Make sure the drawing page size and orientation you choose 
will fit on the paper size and orientation you specify in the Print Setup dialog box.

Margins    Defines an area that Visio can use to position the drawing on the paper. Enter values for Left, 
Top, Right, Bottom, and Center.

Note: To center a drawing that's smaller than the paper, you must first set the drawing size to Fit Page 
To Drawing Contents in the Drawing Scale tab. 

Reduce/Enlarge    Specifies the size you want the drawing when it prints. Choose one of the following 
options:

Percentage    Reduces or enlarges by a specified percentage. For example, to reduce a drawing to three 
quarters of its original size, type 75. 

Fit On    Fits each drawing in the print job on the specified number of sheets across and down. Depending
on the number of pages and the margins you specify, Visio enlarges or reduces the drawing. If the pages 
across and down are not proportional to the drawing's dimensions, Visio uses only those sheets needed 
to maintain the drawing's proportions.

Printer    Opens a dialog box where you can choose the printer you want to target. 



Lists the paper sizes available for the specified printer. Changing the paper size also affects the drawing 
page size if you check Same As Page Setup in the Drawing Size/Scale dialog box.



Lists paper trays, cassettes, manual feed, and other paper sources specific to the specified printer.



Specifies the distance from the left edge of the paper to the left margin.



Specifies the distance from the top edge of the paper to the top margin.



Specifies the distance from the right edge of the paper to the right margin.



Specifies the distance from the bottom edge of the paper to the bottom margin.



Centers a printed drawing that is smaller than the paper. Check Left/Right to center the drawing between 
the left and right margins or edges of the paper, and Up/Down to center the drawing between the top and 
bottom margins or edges of the paper.



Project Timeline Options
    Related Topics

Project Timeline template. Drop a Project Frame shape on the drawing page and choose 
not to run the Project Timeline Wizard.
Opens the Project Timeline Options dialog box where you can choose layout and formatting options for 
your project timeline. Based on the information you provide in this dialog box, Visio creates a project 
timeline. You can revise the project timeline after it’s on the drawing page.

DIALOG BOX OPTIONS
Grid line options - Vertical lines    Check to display vertical lines in the project timeline frame. You can 
show both vertical and horizontal lines.

Grid line options - Horizontal lines    Check to display horizontal lines in the project timeline frame. You 
can show both horizontal and vertical lines.

Date label options    Choose the units you want to display in the timeline.

Chart options: Number of tasks    Type the number of tasks in your project. 

Project start date    Type the date on which your project begins.



Project Timeline Wizard
    Related Topics

File > New > Business Diagram

Or, Tools > Macro > Business Diagram
Starts the Project Timeline Wizard, which reads project data from a text (.txt), Microsoft Excel (.xls), or 
Microsoft Project Exchange (.mpx) file and generates a project timeline.

If you haven’t created a data file you can still run the Project Timeline Wizard to set formatting and style 
options for your project timeline.



Promote Tasks
    Related Topics

Project Timeline template, Project > Promote Tasks

Or, right-click a task bar or horizontal grid line, then choose Promote Tasks
Makes selected subtasks tasks and moves the subtasks to the left in the Task Name column.



Properties (Master menu)
    Related Topics

Master menu, stencil window
Changes the name, icon size, update status, master type, and prompt for the selected master shape. 
Available only when a stencil is open as an original and the stencil window is active.

DIALOG BOX OPTIONS
Master Name    Displays the name that appears under the master icon in the stencil window. Master 
shape names can contain up to 31 characters. To specify how the name is aligned below the icon, choose
Left, Center, or Right.

Icon    Specifies the icon size and when Visio should update the icon.

Size    Choose Normal, Tall, Wide, or Double. The default icon size is Normal. Tall is the same width, 
but twice the height; Wide is the same height, but twice the width. Double is twice as wide and twice as
tall as Normal. Choose the Edit Icon command on the Master menu to adjust the icon to fit a larger 
size.

Update    Updates the master shape icon each time you edit the drawing of the master shape. 
Manually updates a master shape icon when you choose Update Icon from the Master menu.

Master Type    Specifies whether the shape is to be a shape, line pattern, line end, or fill pattern.

Prompt    Displays the text that appears when you point to the master icon in the stencil window. To 
change the text, type new text in the Prompt box.

Match Master By Name On Drop    If you've created a stencil, preserves the formatting you've applied to 
the stencil's master shapes. For example, you've modified the shapes in the Office Layout stencil, created
a stencil called My Office, then you drop a shape from the Office Layout stencil into the drawing.

· If Match Master By Name On Drop is checked for the shapes on the My Office stencil, when you drop a
shape into the drawing, Visio checks to see if the shape you're dropping matches any of the master 
shapes in the My Office stencil. If it finds a match, Visio formats the shape with the changes you made 
to the My Office master shape. 

· If Match Master By Name On Drop is unchecked for the shapes on the My Office stencil, when you 
drop a shape from the Office Layout stencil, the shape is added to the drawing file with the default 
Office Layout formatting.



Properties (File menu)
    Related Topics

File > Properties
Opens a tabbed dialog box where you can view and add information that describes a file and set preview 
options.

The information you type and the preview appear in the Open and Open Stencil dialog boxes when you 
select a drawing file, template, or stencil to open. Entering a detailed description in the dialog box can 
help you locate and keep track of files more easily, especially if you work with many files over a network 
or share them with a workgroup.

If you opt to have previews of every page in the drawing, they appear when you right-click the file in 
Windows and choose Quick View.

Note: To view this command for a stencil, you must have an original stencil open.

Click one of the following tabs to view or set file properties:

General
Summary
Contents



Properties dialog box (General tab)
    Related Topics

File > Properties, click the General tab
Displays details about the open file. The information comes from the file itself and cannot be edited in this 
dialog box.

DIALOG BOX OPTIONS
File name    Displays the file's name if the file has been named and saved.

Type    Indicates the kind of Visio file, such as Visio Drawing File.

Location    Identifies the path for the folder where the file is stored.

Size    Indicates how many bytes the file occupies on the drive.

Based On  Lists the template on which the file is based.



Properties dialog box (Summary tab)
    Related Topics

File > Properties, click the Summary tab
Specifies preview options and information that describes the file. To add information, type it in the 
appropriate box. To edit information, select and then delete or replace text.

You can use the Field command to create text fields that display file summary information entered in the 
dialog box. Any changes you make to information in the dialog box carry over to the fields.

DIALOG BOX OPTIONS
Title  Displays a descriptive title for the file. You can type up to 63 characters.

Subject  Describes the contents of the file. You can type up to 63 characters.

Author  Identifies the person who created or last updated the file. You can type up to 63 characters.

Manager    Identifies the person in charge of the project or department. You can type up to 63 characters.

Company    Identifies the company creating the drawing or the company that the drawing is for. You can 
type up to 63 characters.

Category    Describes the drawing, such as flowchart or office layout. You can type up to 63 characters.

Keywords  Displays words (up to a total of 63 characters) that identify topics or other important 
information about the file, such as project name, client name, or version number.

Description    Displays important information (up to 191 characters) about the file, such as its purpose, 
recent changes, pending changes, and so on.

Hyperlink Base    Type the path you want Visio to use for relative hyperlinks (hyperlinks for which the 
linked file location is described in relation to the Visio drawing). By default, a hyperlink's path is relative to 
the current document unless you type a different base path here. You can type up to 259 characters.

Preview Picture  Specifies to save a preview picture of one or all of the pages in the file. A preview of the
first page appears in the Open box and in Windows Quick View. Previews of all the pages appear in 
Quick View. Choose from the following options:

None    Saves the file without a preview picture.

Draft    Saves the file with a preview picture of Visio shapes only (does not show embedded objects, 
text, or gradient fills).

Detailed    Saves the file with a preview picture of all objects.

First Page Only    Save a preview of the first page in the file. When unchecked, Visio saves previews 
of all of the pages in the file.



Properties dialog box (Contents tab)
    Related Topics

File > Properties, click the Contents tab
Displays a list of the contents of the file, including each page and the masters on it.



Property Report
    Related Topics

Tools menu
Runs the Property Reporting Wizard. The wizard can write shape, custom property, or inventory data to a 
spreadsheet, to generate a report which provides results of numeric calculations on data, such as a bill of 
materials.

Note: To add custom properties to a shape, use the Custom Property Editor.



Protect Document
    Related Topics

Tools menu, drawing window
Protects document features from unauthorized changes. Other users can open the file to look at 
drawings, but they cannot edit the features you protect. You can protect individual features and also set a 
password.

Note: Use the Protect Document command to apply protection to all shapes in the drawing file. To protect
individual shapes, use the Protection command.

DIALOG BOX OPTIONS
Password  Provides a text box where you can type a password. If you do, the Protect Document 
command changes to Unprotect Document. To turn off protection, choose Unprotect Document from 
the Tools menu, and enter the password. Be sure to make a note of your password so you don't forget 
it.

Protect  Lists features you can lock. Choose from styles, backgrounds, shapes, and master shapes.



Prevents users from creating and editing styles, although users still can apply styles.



Prevents users from deleting or editing background pages.



Prevents users from selecting shapes if From Selection is also checked in the Protection dialog box.



Prevents users from creating, editing, or deleting master shapes, although they can still create instances 
of master shapes.



Protection
    Related Topics

Format menu, drawing and ShapeSheet windows
Opens a dialog box where you choose characteristics of a selected shape you want to lock. For example, 
if you lock a shape's dimensions, you cannot change the size of the shape.

DIALOG BOX OPTIONS
Protect  Lists characteristics you can lock on the selected shape. When an item is checked, the 
characteristic is locked against changes. You can choose as many of the characteristics as you want: 
Width, Height, Aspect Ratio, X-Position, Y-Position, Rotation, Begin Point, End Point, From Deletion, and 
From Selection.

All  Locks all options in the Protect section. The Protection section in the ShapeSheet spreadsheet 
includes protection options not available in the Protection dialog box, such as locking against cropping, 
editing with any drawing tool, text editing and formatting, group editing, and recalculation of height and 
width when you size the shape.

None  Unlocks all options in the Protect section.



Locks the shape's width against sizing. To lock a 1-D shape against rotation, you must lock its width.



Locks the shape's height against sizing.



Locks the ratio between a shape's height and width so its proportions won't change when you size it.



Locks the x (horizontal) position.



Locks the y (vertical) position.



Locks a shape against rotation using the rotation tool. A 1-D shape can still be rotated by dragging its 
endpoints. To lock a 1-D shape against rotation, you must lock its width.



Locks the beginning point of a 1-D shape to a specific location.



Locks the ending point of a 1-D shape to a specific location.



Locks the shape so it cannot be deleted.



Locks the shape so it cannot be selected. For this setting to take effect, you must also check Shapes in 
the Protect Document dialog box.



Quarters/Years
    Related Topics

Project Timeline template, right-click Project Frame shape, then choose Quarters/Years

Or, right-click the timescale or nonworking stripe, then choose Quarters/Years
Changes the timeline to display quarters and years. When you change the units, the size of the project 
frame doesn’t change so the smaller the unit, the shorter the time period displayed in the project frame, 
and the longer the task bars.



 Rectangle tool (Ctrl+8)
    Related Topics

Standard toolbar
Use the rectangle tool to draw rectangles or squares. 

Drag diagonally to draw a rectangle. To draw a square, hold down the Shift key as you drag. Both 
rectangles and squares you draw with the rectangle tool are closed shapes.

Editing options
To size a rectangle or square, select it with the pointer tool and drag a selection handle. To size the shape
proportionally, drag a corner handle.

To edit the component line segments, select the rectangle with the pencil tool and then drag vertices and 
control points.

Fill styles
To apply a fill style or fill format to a rectangle, use the Fill command.



Redo (Ctrl+Y)
    Related Topics

Edit menu
Reverses the most recent Undo command. If the action cannot be redone, the command is dimmed, or 
Visio beeps when you click the toolbar button.

Tip: You can use the Undo command to reverse the action of the Redo command.

You can also use the redo button on the Standard toolbar. Use tips to identify the button.



Refresh Shape Properties
    Related Topics

Right-click a selected shape linked to a database record
For this command to appear on a shape’s shortcut menu, you must have previously run the Database 
Wizard to link the shape to a database record.

Refreshes the selected shape to reflect changes in the database record the shape is linked to. Values in 
the shape’s linked ShapeSheet cells are updated to match values in fields of the database record.



Remove From Group
    Related Topics

Shape > Grouping, drawing window
Removes the selected shapes from the selected group without affecting the rest of the group in other 
ways. The removed shape remains in its current location.

First, select the group, and then click to subselect the shape you want to remove. The group displays 
green selection handles, but the shape shows gray handles. When you choose Remove From Group, the 
handles of the selected shape turn green, to indicate that it is independent of the group.

Note: The group's selection rectangle is updated when you remove a shape from a group. 



Reorder Pages
    Related Topics

Edit > Drawing Page, drawing window
Opens a dialog box where you can change the sequence of the drawing pages in the drawing file.

DIALOG BOX OPTIONS
Page Order  Lists all foreground pages by name in the order stored in the drawing file. Choose the page 
you want to move.

Update Page Names  When checked, renumbers pages that use default names (for example, Page-1, 
Page-2, and so on). Visio renumbers the pages to match the new order. This option doesn't affect pages 
you've renamed in Page Properties tab of the File > Page Setup dialog box.

Move Up  Moves the page closer to the beginning of the file.

Move Down  Moves the page farther from the beginning of the file.



Repeat (F4)
    Related Topics

Edit menu
Repeats the most recent action. If an action cannot be repeated, Visio dims the command and changes it 
to Can't Repeat.

Tip: To create evenly spaced copies of a shape, select the shape, and then press the Ctrl key and drag to
create the first copy and place it where you want. To space other copies evenly, press F4 for each 
additional copy.



Replace
    Related Topics

Edit menu, drawing window
Searches for and replaces specified text in shapes, the Properties dialog box, and data fields in the active
drawing file.

Click to display information about the dialog box.



Specifies the text you want to find. You can type or paste text into this field. To search using text you 
previously searched for, click the down arrow, then choose the text from the list.



Specifies the text to use as replacement text. You can type or paste text into this field. To use text you 
previously used as Replace With text, click the down arrow, then choose the text from the list. To delete 
the text in the Find What box from the drawing file, leave the Replace With box empty.



Displays a list of special characters on which you can search: Tab Character, Manual Return, Optional 
Hyphen, Caret Character, or Any Character.



Specifies the range of the search.



Specifies to search only the current selection.



Specifies to search only the current page.



Specifies to search all pages in the open diagram.



Finds only those occurrences with the exact combination of uppercase and lowercase letters specified in 
the Find What box. Visio uses the case of letters as they were originally typed, regardless of whether the 
text has been formatted using Small Caps or All Caps formatting. 



Finds occurrences that are words and not parts of larger words. For example, if you type "for" in the Find 
What box, Visio finds all instances of "for" but ignores "foreign." 



Finds and selects the next occurrence of the text in the Find What box.



Replaces the Find What text with the Replace With text, and then finds the next occurrence.



Replaces all occurrences of the Find What text with the Replace With text. To undo a Replace All, choose 
Undo from the Edit menu.



Reverse Ends
    Related Topics

Shape menu, drawing window
Flips selected shapes horizontally and vertically. What was at the top appears at the bottom, and what 
was on the left appears on the right.



 Right Color box
    Related Topics

Edit icon toolbar, edit icon window
Displays the color assigned to the right mouse button in the edit icon window. Choose the icon pencil tool 
on the Standard toolbar and click with the right mouse button to change the pixels in the icon to this color. 
To change the assigned color, click with the right mouse button in the color palette.



 Rotate Left (Ctrl+L)
    Related Topics

Shape menu, drawing window
Rotates selected shapes (including freestanding text blocks) counterclockwise by 90-degrees. A shape's 
text usually rotates with the shape. Use the Rotate Right command to rotate a shape clockwise. You can 
also use the rotation tool to rotate a shape by any increment.

You can also use the rotate left button on the Shape toolbar. Use tips to identify the button.



 Rotate Right (Ctrl+R)
    Related Topics

Shape menu, drawing window
Rotates selected shapes (including freestanding text blocks) clockwise by 90-degrees. A shape's text 
usually rotates with the shape. Use the Rotate Left command to rotate a shape counterclockwise. You can
also use the rotation tool to rotate a shape by any increment.

You can also use the rotate right button on the Shape toolbar. Use tips to identify the button.



 Rotate Text 90º tool
    Related Topics

Text toolbar
Use the rotate text 90º tool to rotate a text block in 90º increments. To use the rotate text 90º tool, choose 
it from the Text toolbar, then click on the text block.



 Rotation tool (Ctrl+ Ø)
    Related Topics

Standard toolbar
Use the rotation tool to rotate a shape by any amount. To rotate a shape, select it with the rotation tool, 
and then drag a round rotation handle. For finer control, drag the handle farther out from the shape. As 
you drag, the angle of rotation appears in the status bar at the bottom of the drawing page.

By dragging the center of rotation to a new location, you can rotate the shape around a point other than 
its center.

To rotate a shape by 90-degree increments, use the Rotate Left and Rotate Right commands.

You can also rotate a 1-D shape by using the pointer tool to drag one of its endpoints.



Routing Recipient
    Related Topics

Send To submenu, drawing window
This command is available only if Microsoft Office 97 is installed on your computer, or Microsoft Outlook is
your mail program. 

Choose to add a routing slip to a drawing that you send to other people through e-mail. When you add a 
routing slip, you can track the progress of the drawing as each recipient opens it (updates are sent to your
Inbox), and have the drawing returned to you when the last recipient is finished with it.



Row
    Related Topics

Insert menu, ShapeSheet window
Inserts a ShapeSheet row before the selected row. For example, to add a segment to a shape, insert a 
row in the Geometry section; to define a new connection point, insert a row in the Connection Points 
section.

To insert a row after the selected row, use the Row After command.



Row After
    Related Topics

Insert menu, ShapeSheet window
Inserts a ShapeSheet row after the selected row. For example, to add a segment to a shape, insert a row 
in the Geometry section; to define a new connection point, insert a row in the Connection Points section.

To insert a row before the selected row, use the Row command.



Ruler & Grid
    Related Topics

Tools menu, drawing window
Specifies the settings for the rulers and the grid lines. You can have separate settings for the horizontal 
and vertical rulers and grid lines.

DIALOG BOX OPTIONS
Rulers  Specifies the ruler settings.

Subdivisions  Specifies how many tick marks are on the vertical or horizontal ruler. You can choose 
Fine, Normal, or Coarse.

Ruler Zero  Specifies the location of zero on the horizontal and vertical ruler. By default, the horizontal 
ruler's zero point is the top-left corner of the page, and the vertical ruler's zero point is the bottom-left 
corner of the page. For example, if you specify 3 inches for both rulers, the ruler zero is positioned to 
the right (for the horizontal ruler) and 3 inches toward the top (for the vertical ruler).

Grid  Specifies the grid lines settings.

Grid Spacing  Specifies how far apart the grid lines are. You can choose Fine, Normal, Coarse, or 
Fixed. Fine, Normal, and Coarse set the grid to a variable grid: the grid spacing changes as you zoom 
in and out. Fixed sets the grid to a fixed grid; if you zoom in or out, the spacing between grid lines does
not change.

Minimum Spacing  For Fine, Normal, or Coarse, specifies the minimum grid lines. For Fixed, specifies
how far apart the grid lines are.

Grid Origin  Specifies where to place the grid origin. For example, you could move the grid in 
increments different from the ruler to align the grid with a shape or part of the diagram. By default, the 
grid origin is in the lower-left corner.



Rulers
    Related Topics

View menu, drawing and print preview windows
Hides or displays the rulers. When rulers are displayed, they appear along the top and left sides of the 
drawing window.

The intervals of the ruler correspond to the unit of measure you set in the Options dialog box. You control 
the subdivisions for the rulers in the Ruler & Grid dialog box.

Tip: To create guides and guide points, rulers must be visible.



Run Macro tool
    Related Topics

Developer toolbar
Opens a dialog box that displays macros and add-ons that you can run to automate a specific task.

DIALOG BOX OPTIONS
Macro Name    Specifies the name of the macro or add-on to run, edit, delete, or step into. To create a 
macro, enter a new name, then click the Create button. 

Run    Runs the selected macro. You can also use the run macro button on the Developer toolbar. Use 
tips to identify the button.

Step Into    Begins executing the selected macro in the Visual Basic Editor and allows you to step through
its execution.

Edit    Opens the selected macro in the Visual Basic Editor so you can edit its code.

Create    Creates a macro with the given name and opens it in the Visual Basic Editor.

Delete    Deletes the selected macro.

Macros In    Determines the set of macros and add-ons that are listed in the dialog box. You can list:

· Macros in the active drawing (but not all open drawings) and all available add-ons.

· Available add-ons only.

· Macros in a specific module in any Visio file that is currently open with read-write access. 

Description    Displays information about the selected macro. You can assign a description to a macro 
using the Object Browser in the Visual Basic Editor. For details about the Object Browser, see the 
Microsoft Visual Basic online help.



Save (Ctrl+S)
    Related Topics

File menu
Saves changes to the file in the active window. If the file is new and you haven't saved and named it yet, 
Visio displays the Save As dialog box.

You can also use the save button on the Standard toolbar. Use tips to identify the button.



Save As (F12)
    Related Topics

File menu
The first time you save a file, this dialog box appears. After you name the file and click Save, the 
Properties dialog box appears where you add file information and save a preview of the first page in the 
file (which is used in the Open dialog box and in Quick View).

You can also use this dialog box to

· Name and save a drawing, stencil, or template file.

· Change the name or format of the open file.

· Save a file to a different disk location.

· Make a copy of a file, naming and saving the copy as a new file while leaving the original version 
intact.

· Save the workspace within a drawing, stencil, or template file.

· Export a Visio drawing or the selected shapes for use by another program. If you have appropriate 
export filters installed, Visio uses a matching filter to convert the drawing from its original format (.vsd) 
to the format you choose. The exported file will not be linked to a Visio file. You can export an entire 
Visio page or export selected shapes. 

After you save the file, it remains open. Use the Close command to close the file or the Exit command to 
quit Visio. To name and save all open windows, use the Save Workspace command.

DIALOG BOX OPTIONS
Save In  Displays the current folder. To change the folder, choose from the list.

Up One Level  Moves the Look In folder up one level in the hierarchy.

Create New Folder  Creates a new folder in the current level in the hierarchy.

List  Displays the list as an icon and a label.

Details  Displays the list as the name, size, type, and modified date.

File Name  Names the file. Change the name or create a new name by typing up to eight characters, 
followed by the file name extension. If you don't type an extension, Visio enters the extension displayed in
the File Type box.

Save As  Lists formats for these files: Stencil (.vss), Drawing (.vsd), Template (.vst), Visio 4 Stencil (.vss), 
Visio 4 Drawing (.vsd), Visio 4 Template (.vst), HTML Files (.htm, .html), Adobe Illustrator File (.ai), 
Computer Graphics Metafile (.cgm), Encapsulated PostScript File (.eps), Enhanced Metafile (.emf), 
Graphics Interchange Format (.gif), IGES Drawing File Format (.igs), JPEG Format (.jpg), Macintosh 
PICT Format (.pct), Portable Networks Graphics Format (.png), PostScript File (.ps), Tag Image File 
Format (.tif), Windows Bitmap (.bmp, .dib), Windows Metafile (.wmf), and Zsoft PC Paintbrush Bitmap 
(.pcx). 

Save button  Saves the file with the selected options.

Save  Lists additional options for saving the file. Choose the Workspace and Read Only options.



Creates a new file that retains the positions of the open windows.



Saves the file so that it opens as read-only or can be opened as a copy. You cannot open the original file. 
Check this option to protect a file from changes.



Save As (to a Document Management System) 
    Related Topics

File menu, drawing window
If you have Open Document Management Architecture (ODMA) version 1.5 on your system, this 
command opens the Document Management System (DMS) Save As dialog box, which you can use to 
save Visio drawings and store them within your document management system. The exact appearance of
the dialog box depends on the document management system you’re using.



Save As HTML
    Related Topics

File menu, Save As dialog box
Saves a Visio drawing in HTML format so you can open and view the file with a World Wide Web browser.
When you save a drawing as an HTML page, Visio creates a Web page complete with HTML source code
and includes the drawing on the page.

If shapes in the drawing include navigational links to other Visio drawing pages, to files created in different
applications, or to Web sites, these links are also exported and are still active on the Web page.

DIALOG BOX OPTIONS
Page  Lists the pages in the drawing. Choose the pages you want to save as HTML pages. By default, 
Visio saves all the drawing pages.

Filter  Lists the file formats in which you can save the drawing pages. The .jpg, .gif, and .png file formats 
are supported by Web browsers.

Filter Settings  Opens a dialog box that contains settings that control the size of the saved HTML files.

Zoom  Determines the level of magnification in which Visio saves the drawing. By default, Visio saves 
the drawing at 50% of the size it appears in Visio.

Dots-Per-Inch  Controls the size of the exported drawing by setting the horizontal and vertical pixels 
per inch.

Screen Resolution  Targets the HTML page to a specific screen resolution.

Options  Opens a dialog box that contains settings that determine how links from a Visio drawing are 
saved, and which template on which to base the HTML file formatting.

Enable Image Maps  Determines whether or not links in Visio shapes are exported.

Client Side  Controls whether or not drawings are saved as client-side image maps. Check this option 
unless you know your Web site has a program on its server for processing image map data.

Server Side  Controls whether or not drawings are saved as server-side image maps. Check this 
option if your Web site has a program on the server that examines map data associated with image 
maps and processes the links.

URL  The box in which you type the URL to the Common Gateway Interface (CGI) directory on the 
Web server. Visio includes this URL as an anchor on the HTML page it creates when it saves your 
drawing.

Format  Determines the standard for handling image map data. Choose either NCSA (National Center 
for Supercomputing Applications) or CERN (European Particle Physics Laboratory).

HTML Template  Displays the path to the HTML template you want to use to format the exported Visio 
drawing.



Save Workspace (Alt+F12)
    Related Topics

File menu
Opens a dialog box where you can name and save a workspace file. Workspace files save the 
arrangement of windows currently open in the Visio window. Save a workspace when you have not 
finished a drawing file but need to close the file. When you want to resume work, Visio opens the 
workspace—not just the drawing file—so all windows are open and ready for you to continue where you 
left off.

Important: Before saving a workspace, you must use the Save As or Save command from the File menu 
to name and save any unnamed open files¾including the drawing file you're working on. If unnamed files 
are open, Visio asks if you want to save the workspace without them.

DIALOG BOX OPTIONS
Save In  Displays the current folder.

Up One Level  Moves the Look In folder up one level in the hierarchy.

Create New Folder  Creates a new folder in the current level in the hierarchy.

List  Displays the list as an icon and a label.

Details  Displays the list as the name, size, type, and modified date.

File Name  Names the workspace file. Filenames can be up to eight characters; Visio adds the .vsw file 
name extension to identify the file as a workspace.

Save As Type  Lists the file name extension for a workspace (.vsw).

Save  Saves the file with the selected options.



Search The Web
    Related Topics

Help > Visio on the Web
Choose Search The Web to open your web browser application and search the Internet.

You can also use the search the web button on the Web toolbar. Use tips to identify the button.



Section
    Related Topics

Insert menu, ShapeSheet window
Opens a dialog box where you can choose which sections to add to a ShapeSheet spreadsheet. Each 
section controls the behavior and appearance of some aspect of a shape.

By default, each ShapeSheet spreadsheet has at least one section that provides positioning information. 
Visio builds in other sections required for a specific shape. Each ShapeSheet spreadsheet can contain 
only one of each type of section except for Geometry sections.

Each path in a shape is represented by a Geometry section, which Visio numbers sequentially (Geometry
1, Geometry 2, and so on). You can add sections to modify a shape. Which sections are visible or hidden 
in the ShapeSheet spreadsheet depends on which sections are checked in the Sections dialog box.

DIALOG BOX OPTIONS
Show Sections    Lists the sections you can add to a ShapeSheet spreadsheet. Sections included in the 
ShapeSheet spreadsheet of the selected shape and sections that are not available for the selected shape
are dimmed.

Text Transform    Used to position text in relation to its shape. Without this section, text can only be 
positioned within the shape. With the Text Transform section, you can move the text; for example, you 
can rotate text independently of its shape.

Geometry    Lists the vertices for a path in a shape. Each path requires its own Geometry section. 
Within each Geometry section, a row describes each line and each arc segment in the path.

Connection Points    Specifies the x- and y-coordinates for each connection point on a shape.

Controls    Specifies the x- and y-coordinates, behavior, and anchor point for each control handle 
defined for a shape.

Scratch    Contains cells where you can enter and test formulas or calculate intermediate values that 
can be referred to in other sections.

Text Fields    Contains formulas inserted in a shape's text block using the Field command. The 
formulas appear in this section in the same order as in the text block.

Actions  Inserts a section from which you can add an action to a shape or page.

Layer Membership  For a shape, inserts a section in which you can change the shape's layer 
assignment.

Layers  For the page, inserts a section in which you can view the page's layer properties.

User-Defined Cells  Inserts a section in which you can add user-defined cells for a shape or page.

Custom Properties  Inserts a section in which you can add custom properties for a shape or page.

Ruler & Grid    Inserts a section in which you can enter values for the page's ruler and grid.



Sections
    Related Topics

View menu, ShapeSheet window
Opens a dialog box where you choose which ShapeSheet sections are displayed for the selected shape.

DIALOG BOX OPTIONS
Section  Indicates the sections you want to display. Check to display and uncheck to hide any number of 
sections. (Sections not available for the selected shape are dimmed.) When you activate the ShapeSheet 
window, all the checked sections included in the ShapeSheet spreadsheet are visible.

All  Displays all sections.

None  Displays no sections.

You can also collapse and expand a section by clicking its title. When a section is collapsed, you see only
its title; when it is expanded, you see all of its rows.

Tip: If you use the Section command to add a section to the ShapeSheet spreadsheet, but you don't see 
the section in the ShapeSheet window, use the Sections command to make sure the section is set to 
display.



Select All (Ctrl+A)
    Related Topics

Edit menu; drawing, stencil, and edit icon windows
Selects all shapes, guides, and objects from other programs on a drawing page. To select all of a specific 
kind of item, use the Select Special command.

Note: To view this command for a stencil, you must have an original stencil open.



Select Color palette
    Related Topics

Edit icon toolbar, edit icon window
Displays color swatches, including the Transparent Color box, that you can choose to assign to the Left 
Color box or the Right Color box. To assign a color, click with the left or right mouse button in the color 
palette.



Select Database Record
    Related Topics

Right-click a selected shape linked to a database record
For this command to appear on a shape’s shortcut menu, you must have previously run the Database 
Wizard to link the shape to a database record.

Opens the Select Database Record dialog box where you can select the database record you want the 
selected shape to represent. The dialog box lists the data source and data source table to which the 
shape is linked and the table’s primary key field.

Key Value Choose the value in the primary key field for the record you want the shape to link to.



Select Special 
    Related Topics

Edit menu, drawing window
Opens a dialog box where you can choose one or more types of items you want to select. When you click
OK, Visio selects all items of the specified types on the page.

Tip: To determine a shape's type, choose Special from the Format menu.

DIALOG BOX OPTIONS
Select By  Specifies the type of objects you want to select.

Shape Type  Lists the types of items you can select all at once. Select any number of these types: 
Shapes, Groups, Guides, OLE Objects, Metafiles, Bitmaps.

Layer  Lists the available layers from which you can select.

All  Click this button to select all types in the Select By list.

None  Click this button to uncheck all types in the Select By list.



Selects all shapes on the page.



Selects all groups on the page.



Selects all the guides and guide points on the page.



Selects all objects from other programs saved in the .wmf (Windows metafile) format or objects inserted 
into Visio by selecting Windows Metafile Data in Paste Special.



Selects all objects from other programs saved as bitmaps.



Selects all linked or embedded objects to a container.



 Selection net tool
    Related Topics

Edit icon toolbar, edit icon window
Use the selection net tool to select a rectangular area of a master shape icon. Drag a selection net 
around the area of the bitmap you want to select. You can then drag to move the selected area or use the 
commands on the Edit menu to work with the selected area.



Send Backward 
    Related Topics

Shape menu, drawing window
Moves selected shapes back one position in the stacking order. If multiple shapes are selected, they all 
move back one position and keep their original stacking order in relation to each other.



Send To Back (Ctrl+B)
    Related Topics

Shape menu, drawing window
Moves selected shapes behind other shapes in the stacking order. If multiple shapes are selected, they 
keep their original stacking order in relation to each other.

You can also use the send to back button on the Shape toolbar. Use tips to identify the button.



Set To L Connectors
    Related Topics

Right-click the drawing page with no shapes selected, Project Timeline template
Sets all the connectors in your project timeline to L-shaped connectors. Connectors indicate links, or 
dependencies, between tasks.



Set To S Connectors
    Related Topics

Right-click the drawing page with no shapes selected, Project Timeline template
Sets all the connectors in your project timeline to S-shaped connectors. Connectors indicate links, or 
dependencies, between tasks.



Shadow
    Related Topics

Format menu, drawing and stencil windows
Applies or changes the shadow for selected shapes. 

You can also use the shadow color palette on the Shape toolbar. Use tips to identify the button.

DIALOG BOX OPTIONS
Pattern  Determines the shadow pattern. Choosing None deletes a shadow.

Foreground  Determines the shadow foreground color. For example, in a grid pattern, the grid displays 
the foreground color.

Background  Determines the shadow background color. For example, in a grid pattern, the spaces 
between the grid show the background color.

Apply  Applies a shadow format without closing the dialog box.



Shadow Color tool
    Related Topics

Shape toolbar
Use the shadow color tool to add or remove shadows from shapes and to choose the shadow color. 
Select the shape or shapes to which you want to add shadows, then click the shadow color tool to display
the shadow color palette. On the palette, choose

· No Shadow, to remove shadows from shapes.

· One of the colors in the palette to fill the shadow with that color.

· More Shadow Colors to open the Shadow dialog box where you can choose a shadow's pattern and 
background and foreground colors.



Shape Explorer
    Related Topics

Tools > Macro > Shape Explorer
Searches for and catalogs Visio shapes, stencils, and templates that are provided with Visio products, 
that are on the World Wide Web, or that are in databases you create.



Shape Help
    Related Topics

Stencil master and shape shortcut menus
Displays online help for a specific shape in a stencil. This command is available only when a Windows 
online help topic is associated with the shape.

You can activate the Shape Help command by entering syntax in the Special dialog box. For information 
on developing Microsoft Windows online help, see the Microsoft Platform SDK documentation.

To associate a help topic to a double-click action, use the Double-Click command on the Format menu.



Shape Layer
    Related Topics

View menu, drawing and ShapeSheet windows
Assigns the selected shape to one or more layers, or removes a shape's layer assignment.

You can assign a selected shape to a layer using the shape layers list on the View toolbar. Use tips to 
identify the button.

DIALOG BOX OPTIONS
On Layer(s)  Assigns the selected shape to one or more layers. You can assign a shape to multiple 
layers.

Preserve Group Member Layers  Specifies that individual shapes in a group retain their current layer 
assignments. For example, you might assign a desk to the furniture layer and a computer to the 
electronics layer, then group them. If you then assign the group to the den layer, the desk and computer 
retain their previous layer assignments as well. When this option is unchecked, when you assign a group 
to a layer, all of the group members become members of the new layer. Their previous layer assignments 
are canceled.

All  Assigns the selected shape to all layers.

None  Assigns the selected shape to no layers.

New  Opens the New Layer box, in which you can type a name to create a new layer.



Shape toolbar
    Related Topics

View > Toolbars, Toolbar shortcut menu
Displays a Visio toolbar that provides buttons you can use as shortcuts for choosing menu commands. To
switch the toolbar, choose View > Toolbars or right-click the toolbar, then choose Shape from the shortcut 
menu.

The tools available on the Shape toolbar are line style list, line color palette, line weight list, line pattern 
list, line ends list, corner roundings list, fill style list, fill color palette, fill pattern list, shadow list, align 
shapes palette, distribute shapes palette, lay out shapes, connect shapes, flip horizontal, flip vertical, 
rotate right, rotate left, bring to front, send to back, group, ungroup, and custom properties.

Note: Your toolbar may vary depending on the display resolution of your monitor, the size of your window,
and which window is active. 



Show Drawing Page
    Related Topics

Window menu, stencil window
Note: This command is available only when you have an original stencil open.

Opens a dialog box that lists current drawing pages. Choose a page to display in the drawing window. 
Show Drawing Page is available only when a stencil window is active.

DIALOG BOX OPTIONS
Select Page  Displays a list of background and foreground pages in the drawing file. Foreground pages 
are listed in bold type; background pages are listed in normal type.



Show Master Shapes
    Related Topics

Window menu, drawing window
Opens the local stencil for the current drawing file. The local stencil contains a copy of every master 
shape that appears in the current drawing file. Instances in a drawing file remain linked to their master 
shapes in the local stencil (unless you ungroup the instance or delete the master).

Note: The local stencil also includes masters you may have deleted from the drawing page.

To use the command, make sure the drawing window is active by clicking the title bar of the drawing 
window. The local stencil window displays the name of the drawing file, followed by "Stencil."

When you select a master shape in a local stencil, you can use the Edit Master command to edit a master
shape. Visio updates all instances of the master in the drawing file.



Show ShapeSheet 
    Related Topics

Window menu, drawing window
Opens the ShapeSheet spreadsheet for the selected shape or the page.

Every shape you draw with Visio or object you insert from another program has a ShapeSheet 
spreadsheet. When you group shapes, Visio retains the ShapeSheet spreadsheet for each shape in the 
group and creates a separate ShapeSheet spreadsheet for the group.

When you open the ShapeSheet window, the menu bar changes and displays menus and commands for 
working in the ShapeSheet spreadsheet. What you see in a ShapeSheet spreadsheet depends on which 
shape is selected and how you have set ShapeSheet display options with the Values, Formulas, and 
Sections commands.

You can also use the show ShapeSheet button on the Developer toolbar. Use tips to identify the button.



Show Task Bar
    Related Topics

Project Timeline template, right-click a task bar, the choose Show Task Bar

Or, right-click a horizontal grid line or text entry area, then click Show Task Bar
Brings a selected task (or the task in a selected row) into the project frame. The timeline scrolls so the 
first date that displays in the project frame corresponds to the start date of a selected task. You can also 
click the Show Task Bar ( ) toolbar button.



Single Tile
    Related Topics

View menu, print preview window
Displays a single page or tile of a drawing as it appears when printed. You can view the entire drawing by 
choosing Whole Page from the View menu.

You can also use the Single Tile button. Use tips to identify the button.

Alternatively, you can use the Zoom In and Zoom Out buttons.



Size & Position
    Related Topics

Shape menu, drawing and stencil windows
If a shape is selected, determines the selected shape's position on the page, its dimensions, and its 
degree of rotation. The dialog box options vary depending on whether a 1-D or 2-D shape is selected.

If a guide is selected, determines the selected guide's or guide point's position on the page and its degree
of rotation. The dialog box options vary depending on whether the selected guide or guide point is 
vertical, horizontal, or oblique (in other words, diagonal).



Size & Position (shape selected)
    Related Topics

Shape menu, drawing and stencil windows
Determines the selected shape's position on the page, its dimensions, and its degree of rotation. The 
dialog box options vary depending on whether a 1-D or 2-D shape is selected.

For a 1-D shape, the options in the Parameters section vary depending on which option you choose in the
Show section. You can change the size and position of a 1-D shape by changing values in the 
Parameters section of the dialog box.

Click to display information about the dialog box options for a 1-D shape.

Click to display information about the dialog box options for a 2-D shape.



Displays the shape's beginning and ending points and its height in the Parameters section.



Displays the shape's beginning point, angle of rotation, length, and height in the Parameters section. Visio
calculates the ending point. 



Displays the shape's ending point, angle of rotation, length, and height in the Parameters section. Visio 
calculates the beginning point.



The x-coordinate of the beginning point of the 1-D shape in relation to the origin of its parent.



The y-coordinate of the beginning point of the 1-D shape in relation to the origin of its parent.



The x-coordinate of the ending point of the 1-D shape in relation to the origin of its parent.



The y-coordinate of the ending point of the 1-D shape in relation to the origin of its parent.



The height of the shape.



The shape's current angle of rotation in relation to its parent.



Applies a setting without closing the dialog box.



Specifies the width, height, and angle of the shape. Enter a new value to resize the shape.



The width of the shape.



When checked, flips the shape horizontally.



When checked, flips the shape vertically.



Specifies the position of the x- and y-coordinates of the shape's local pin (center of rotation) in relation to 
the page. Enter a new value to change the position of the pin.



Specifies the position of the x-coordinate of the shape's local pin (center of rotation) in relation to the 
page. Enter a new value to change the horizontal position of the shape on the page.



Specifies the position of the y-coordinate of the shape's local pin (center of rotation) in relation to the 
page. Enter a new value to change the vertical position of the shape on the page.



Changes the location of the pin (center of rotation) on the shape so you can rotate the shape around a 
point other than its center. Choose a section to change the pin location. When you change the location of 
the pin, the shape's position on the page also changes.



Size & Position (guide selected)
    Related Topics

Shape menu, drawing and stencil windows
Determines the selected guide's or guide point's position on the page and its degree of rotation. The 
dialog box options vary depending on whether the selected guide or guide point is vertical, horizontal, or 
oblique (in other words, diagonal).



SmartShape Wizard
    Related Topics

Tools > Macro > Visio Extras
Automates adding smart behavior to shapes you create, including text behavior, control handle 
connectors, hidden notes, custom properties, and protection options.



Snap & Glue (Alt+F9)
    Related Topics

Tools menu, drawing window
Specifies whether snap and glue are active and what objects shapes will snap and glue to. You can 
change these settings at any time without affecting shapes that are positioned or glued. You can check 
any number of items to snap and glue to. For aligning shapes, the most useful options are ruler 
subdivisions, grid, and guides. The other options are most useful when you are gluing shapes.

You can change the snap and glue strength setting in the Options dialog box.

Tip: Press F9 to toggle glue on or off, and press Shift+F9 to toggle snap on or off.

You can also use the snap and glue buttons on the Page toolbar to turn snap and glue on or off. Use tips 
to identify the button.

Click to display information about the dialog box.



When checked, you can snap to these items.



Specifies the distance in pixels that the grid, guides, rulers, or points (connection points, vertices, 
handles) pull when snapping or gluing is on.



When checked, you can glue to these items.



Activates snapping so shapes snap to items checked in the Snap To section.



Activates glue so shapes glue to items checked in the Glue To section.



Spelling (F7)
    Related Topics

Tools menu, drawing window
Checks the spelling of text in shapes, summary information, and data fields in the active drawing file.

You can also use the spelling button on the Standard toolbar. Use tips to identify the button.

DIALOG BOX OPTIONS
Not In Dictionary    Displays a word not found in the open dictionaries.

Change To    Type or select a word from the Suggestions list to replace the misspelled word.

Suggestions    Lists replacement words from the open dictionaries.

Add Words To    Select the dictionary to which you want to add the word. For example, a person's name 
might not be in the dictionary.

Ignore    Ignores the word and continues checking.

Change    Changes the word to the one in the Change To box.

Add    Adds the word to the dictionary selected in the Add Words To box.

Ignore All  Ignores all instances of the word and continues checking.

Change All    Changes all instances of the word to the one in the Change To box.

Options    Displays the Spelling tab, in which you can specify default settings for the Spelling command.

Cancel    Closes the Spelling box, but does not reverse any changes you have made.



Special
    Related Topics

Format menu, drawing and ShapeSheet windows
Opens a dialog box that identifies the selected shape and provides three text boxes where you can type 
information about the shape.

DIALOG BOX OPTIONS
ID  The sequential ID number Visio assigns to the selected shape. The number is based on the order in 
which shapes are created. The first shape you create in the drawing is 1, the second is 2, and so on.

Master  Displays the name of the master shape if the shape is an instance of a master. If a shape is a 
component shape in a master shape, the section displays the name of the master and the name or 
number of the component shape.

Type  Identifies the type of shape or other object.

Name  Identifies the shape by its default Visio name or a name you assign. You can type up to 31 
characters for the name. Note: You cannot use the open rounded bracket ( { ) as the first character of a 
shape name.

Help    Enables the Shape Help command by associating the selected shape with a help keyword. The 
syntax is:

FILENAME.HLP!keyword or FILENAME.HLP!#Number

where filename is the Windows help file, keyword is the index term associated with the help topic, and
number is a numeric ID which is referenced in the MAP section of the help project file (HPJ). For 
information on developing Microsoft Windows online help, see the Microsoft Platform SDK 
documentation.

Copyright. Displays copyright information for the selected shape.

Data 1, Data 2, and Data 3  Provides room for information you want to supply about the shape. You can 
type up to 64KB of data in each box.

Note: The default path for shape and stencil help files is the Visio Help folder, although VISIO.HLP resides 
in Visio's main folder. You can change the default path in the File Paths tab, which remains in effect until 
you set it again.

To enter descriptive information about the file, use the Properties command.

If you use the Field command to create a text field, one category option is Object Info. The Object Info 
fields (Data 1, Data 2, Data 3, ID, Master, Name, and Type) display the information you enter in the 
Special dialog box. Any changes you make to information in the Special dialog box are displayed in the 
fields.



 Stamp tool
    Related Topics

Standard toolbar
Use the stamp tool to create instances of the selected master shape in a drawing.

To stamp a shape, choose the stamp tool, and then select the master shape in the stencil. Click the 
drawing page where you want to position the center of the shape.

To create multiple shapes, drag a master shape to the drawing page, select the stamp tool, and then click 
on the page to make copies of the original shape.



Standard toolbar
    Related Topics

View > Toolbars, Toolbar shortcut menu
Displays a Visio toolbar that provides buttons you can use as shortcuts for choosing menu commands 
and for choosing drawing and formatting tools. To switch the toolbar, choose View > Toolbars or right-click
the toolbar, then choose Standard from the shortcut menu.

Note: Your toolbar may vary depending on the display resolution of your monitor, the size of your window,
and which window is active. 



Status Bar 
    Related Topics

View menu; drawing, stencil, and print preview windows
Displays or hides the status bar at the bottom of the Visio window. The status bar is displayed when the 
command is checked.

The status bar provides information related to the task you are doing. For example, when you point to a 
master shape on a stencil, the status bar shows a brief description of the master shape. As you drag a 
shape, the status bar displays the shape's position.



Stencil Report Wizard
    Related Topics

Tools > Macro > Visio Extras
Automates creating a report showing all shapes on a stencil, creating a catalog of shapes.



Style
    Related Topics

Format menu, drawing window
Applies styles to selected shapes. The styles listed in the dialog box are the same as those listed in the 
style lists on the Text toolbar and Shape toolbar.

DIALOG BOX OPTIONS
Text Style  Lists styles that contain text formats.

Line Style  Lists styles that contain line formats.

Fill Style  Lists styles that contain fill formats.

Preserve Local Formatting  When checked, this option prevents attributes defined in a style from 
overriding formatting applied directly to selected shapes. For example, if a text style specifies italic text, 
and you've used the Bold button to make the text bold, Visio leaves the text bold but also makes it italic.

Apply  Choose this button to apply styles without closing the dialog box. If necessary, drag the dialog box
by its title bar to make selected shapes visible on the page.



Subtract
    Related Topics

Shape > Operations, drawing window
The Subtract command works like a cookie cutter. Overlap two shapes, select the first one, and then the 
second. Choose Subtract to delete the second shape you selected, leaving its shape cut into the first. 
(The overlapping segment of the second shape is "subtracted" from the first.)

When you use this command on two or more shapes, Visio creates a ShapeSheet spreadsheet for the 
new shape and deletes the ShapeSheet spreadsheets of the original shapes.



Switch Sides
    Related Topics

Right-click a docked stencil's title bar
Docks the stencil on the opposite side of the drawing window.



Tab Properties dialog box
    Related Topics

Text dialog box (Tabs tab), click New or Edit
Specifies the position and alignment for a new or existing tab.

DIALOG BOX OPTIONS
Position    Shows the distance of the tab stop from the left margin. To move the tab, change the setting.

Align    Shows the alignment of the selected tab. To change the alignment, choose between Left (the left 
side of the text aligns with the tab stop), Center (centers the text on the tab stop), Right (the right side of 
the text aligns), or Decimal (the decimal points in a column of numbers align).



Template Help
    Related Topics

Help menu
Opens online documentation for the template you're working with. Template Help provides helpful tips and
instructions for creating drawings with a specific template. 

For details about a specific shape on a stencil or on the drawing page, right-click the shape and choose 
Shape Help.



 Text block tool
    Related Topics

Standard toolbar
Use the text block tool to select a shape's text block. You can size, move, and rotate the text block 
independently of its shape. To use the text block tool, click the text tool and hold down the mouse button. 
The text tool menu appears, from which you can choose the text block tool.

To rotate a text block, select a rotation handle, and then drag. To move a shape, click inside the center of 
the shape or on the green border, and then drag. To size a shape, click one of the selection handles, and 
then drag.



Text dialog box
    Related Topics

Format >Text, drawing and ShapeSheet windows
Opens a tabbed dialog box where you can apply formatting to selected text or to all text in the text blocks 
of selected shapes.

To format selected text, use the text tool on the Standard toolbar to open the text block and then select 
the text you want to format. To apply formatting to all text in a shape's text block, select the shape.

Tip: If the selected text contains more than one setting for any format (for example, more than one font), 
the Text dialog box displays the formatting of the first character in the selection.

Click one of the following tabs to set formatting options: 

Font
Paragraph
Text Block
Tabs
Bullets

Tip: You can also use buttons on the Text toolbar to format text. Use tips to identify the buttons.



Text dialog box (Font tab)
    Related Topics

Format > Text, click Font tab; drawing and ShapeSheet windows
Specifies font and style characteristics for selected text or the selected shape's entire text block. 

DIALOG BOX OPTIONS
Font    Displays a list of all the enabled fonts installed in Microsoft Windows. To change the font, choose 
from the list. You can also use the font list on the Text toolbar. Use tips to identify the button.

The symbol TT precedes TrueType fonts. A printer icon precedes printer fonts that are not TrueType fonts.
Fonts with neither icon are Windows fonts but not TrueType, so they may not size or print as well as 
TrueType or printer fonts.

Size    Determines the point size of selected text. You can also use the font size list, or the increase font 
size or decrease font size buttons on the Text toolbar. Use tips to identify the buttons.

Color    Determines the text color. To assign a custom color, choose Custom. The Color dialog box 
appears, in which you can define the new color in the color palette. You can also use the font color palette
on the Text toolbar. Use tips to identify the button.

Case    Determines whether text appears in uppercase or lowercase as you type, or as all uppercase or 
initial capitals regardless of how you typed the text. (For small caps, choose that option in the Style 
section.)

Position    Determines whether text is displayed in normal, superscript, or subscript position.

Language    Once you choose a language (such as French) from this box, when you use Spelling, Visio 
uses the appropriate dictionary (such as the French dictionary) to check the spelling of the formatted text. 

Style    Determines whether text is displayed in bold, italic, underline, or small caps style. You can also 
use the bold, italic, and underline buttons on the Text toolbar. Use tips to identify the buttons.

Apply    Applies formatting without closing the Text dialog box.



Displays all characters as uppercase, regardless of whether you typed lowercase or uppercase letters. 
(For small caps, choose that option in the Style section.)



Displays the font as you first typed it¾uppercase, lowercase, or a mixture of characters.



Displays the first character of every word as an uppercase letter, with all other characters lowercase, 
regardless of whether you typed lowercase or uppercase letters.



Aligns text horizontally on the baseline.



Raises text slightly above the baseline and reduces the point size.



Drops text slightly below the baseline and reduces the point size.



Makes the font heavier.



Makes the font slanted.



Draws a line under the text.



Displays all lowercase characters as small capital letters (smaller than the specified point size), leaving 
uppercase characters full-size.



Text dialog box (Paragraph tab)
    Related Topics

Format > Text, click Paragraph tab; drawing and ShapeSheet windows
Specifies alignment, indentation, and spacing for selected paragraphs or the selected shape's entire text 
block.

DIALOG BOX OPTIONS
Horizontal Alignment    Displays the current horizontal alignment of the text in relation to the text block 
margin. Choose Left, Right, Center, Justify, or Force Justify. You can also use the align and justify buttons
on the Text toolbar. Use tips to identify the buttons.

Indentation    Displays the current indentation from the text block margins. You can also use the increase 
indent or decrease indent buttons on the Text toolbar. Use tips to identify the buttons.

Spacing    Displays the current paragraph and line spacing. Type values for Before, After, and Line. You 
can also use the increase paragraph spacing and decrease paragraph spacing buttons on the Text 
toolbar. Use tips to identify the button.

Apply    Applies formatting without closing the dialog box. 



Starts each line of text at the left margin. The right side of the text is ragged.



Centers each line of text between the left and right margins.



Positions the last character in each line at the right margin. The left side of the text is ragged.



Adjusts the spacing between words and characters so each line of text (except the last line of the 
paragraph) fills the space between the left and right margins.



Adjusts the spacing between words and characters so each line of text (including the last line of the 
paragraph) fills the space between the left and right margins.



Specifies the space Visio inserts before a paragraph (except for the first paragraph in the text block). 
Traditionally, vertical spacing is measured in points. One point (abbreviated as pt.) equals 1/72 inch. You 
can type new values using any unit of measure.



Specifies the space Visio inserts after a paragraph (except for the last paragraph in the text block). If you 
specified a value for Before, the amount of space between paragraphs will equal the sum of the Before 
and After values. Traditionally, vertical spacing is measured in points. One point (abbreviated as pt.) 
equals 1/72 inch. You can type new values using any unit of measure.



Specifies the space Visio inserts between lines in a paragraph. You can specify a percentage of the type 
size; the default setting of 120 percent ensures that characters do not touch the line below. Otherwise, 
you can type an absolute size (for example, for 12-point type with two extra points inserted between lines,
set line spacing to 14 points).



Text dialog box (Text Block tab)
    Related Topics

Format > Text, click Font tab; drawing and ShapeSheet windows
Sets the vertical alignment, margins, and background color for the selected text block.

DIALOG BOX OPTIONS

Vertical Alignment    Specifies the vertical position of the text in relation to the top and bottom margins of 
the text block. Choose from Top, Middle, or Bottom. You can also use the alignment buttons on the Text 
toolbar. Use tips to identify the buttons.

Margins    Specifies the distance between the text and each edge of the text block. To change margins, 
type a number in the appropriate box: Top, Left, Bottom, or Right.

Text Background    Specifies whether the text block is transparent or opaque. For an invisible 
background that reveals shapes behind the text, choose None (Transparent).

Apply    Applies text block formats to the selected shapes without closing the dialog box.



Aligns the top line of text with the top margin.



Centers the text between the top and bottom margins so the distance from the top line to the top margin 
equals the distance from the bottom line to the bottom margin.



Aligns the bottom line of text with the bottom margin.



Text dialog box (Tabs tab)
    Related Topics

Format > Text, click Font tab; drawing and ShapeSheet windows
Adds, deletes, and adjusts tab stops for paragraphs or for a selected shape's entire text block.

You can add up to 10 tab stops and delete tabs you no longer want. To move a tab, change the settings in
the Edit Tab section. To define a new tab, type the tab's position in the Position box, and then select the 
alignment from the Alignment list.

DIALOG BOX OPTIONS
Tab Stops    Lists the current tab stops. The left side of the box lists tab positions, and tab alignment is 
listed on the right. To edit a tab, select it, then click Edit.

Add    Opens the Tab Properties dialog box, where you can set the position and alignment for a new tab. 
The new tab appears in the Tab Stops list.

Edit    Opens the Tab Properties dialog box, where you can edit the position and alignment for the select 
tab.

Delete    Deletes the tab stop selected in the Tab Stops list.

Apply    Applies all the tabs in the Tab Stops list to the selected text without closing the dialog box.



Text dialog box (Bullets tab)
    Related Topics

Format > Text, click Font tab; drawing and ShapeSheet windows
Specifies bullet options for selected paragraphs or for the selected shape's entire text block.

You can also use the bullets button on the Text toolbar to apply the last-used bullet formatting. Use tips to 
identify the button.

DIALOG BOX OPTIONS
None    Removes bullet formatting from text.

Other options    Specifies bullet formatting indicated by the icons. All of the formatting options use 
hanging indents, except the last.

Apply    Applies formatting without closing the Text dialog box.



 Text tool (Ctrl+2)

Standard toolbar
Use the text tool to create a freestanding text block (the shape is invisible) or activate a text block so you 
can edit the text. To create new freestanding text, choose the text tool to place an insertion point, and 
then type.

If you want the text block to have a certain line length, drag to create an area of the width you want, and 
then type.

Tip: To add text to a shape or replace all of a shape's text with new text, select the shape with any tool 
and start typing.



Text toolbar
    Related Topics

View > Toolbars, Toolbar shortcut menu
Displays a Visio toolbar that provides buttons you can use as shortcuts for choosing menu commands. To
switch the toolbar, choose View > Toolbars or right-click the toolbar, then choose Text from the shortcut 
menu.

The tools available on the Text toolbar are style list, font list, font size list, bold, italic, underline, align left, 
center, align right, justify, align top, middle, align bottom, bullets, decrease indent, increase indent, 
decrease paragraph spacing, increase paragraph spacing, increase font size, decrease font size, font 
color palette, and rotate text 90º.

Note: Your toolbar may vary depending on the display resolution of your monitor, the size of your window,
and which window is active. 



Tile
    Related Topics

Window menu
Sizes and arranges open windows side by side so that all windows are visible. 

Shortcut: Press Shift+F7 to tile horizontally, or press Ctrl+Shift+F7 to tile vertically.

Tip: To enlarge the active window so it fills the screen, choose the Maximize button in the upper-right 
corner of the window. Choose the Restore button to return the window to its previous tiled size.



Toolbars
    Related Topics

View > Toolbars menu; drawing, stencil, and print preview windows
Changes the Visio toolbar.

DIALOG BOX OPTIONS
Toolbars  Check the toolbars that you want Visio to display. Options are Standard, Text, Shape, View, 
Page, Web, and Developer.

Options  Choose display options for the toolbar. Options are Large Buttons and Show ScreenTips.

Tip: Right-click anywhere on the toolbar or status bar to change display options.



Transparent Color box
    Related Topics

Edit icon toolbar, edit icon window
Specifies that the pixels you draw be transparent. To draw transparent pixels, click the Transparent Color 
box with the left or right mouse button; the transparent color appears in the Left Color box or the Right 
Color box.



Trim
    Related Topics

Shape > Operations, drawing window
Splits selected objects at their intersections. It creates a new shape for each piece, preserving styles. 
Shapes you trim lose their fill.



Undo (Ctrl+Z)
    Related Topics

Edit menu
Reverses the most recent action. You can reverse up to ten actions, one at a time.

You can also use the undo button on the Standard toolbar. Use tips to identify the button.

You can undo most but not all actions. If an action can be undone, the command is Undo, followed by the 
type of action. When you cannot undo an action, this command changes to Can't Undo. You can reverse 
an undo action by using the Redo command from the Edit menu.



Ungroup (Ctrl+U)
    Related Topics

Shape > Grouping, drawing window
Ungroups the selected group, leaving the individual shapes that belong to the group selected. Also, 
converts a pasted or imported Windows metafile (.wmf) or an OLE object into individual shapes.

When you ungroup a group, Visio deletes the group's ShapeSheet spreadsheet and leaves the individual 
shapes' ShapeSheet spreadsheets intact.

You can also use the ungroup button on the Shape toolbar. Use tips to identify the button.

Tip: If a shape within the group is a group, it remains a group, and you must select and ungroup it to 
make individual shapes of its components.



Union 
    Related Topics

Shape > Operations, drawing window
Creates one closed shape from overlapping shapes, which inherits the text and formatting of the first 
shape you select. If the shapes do not overlap, Visio creates a single shape that looks the same as the 
shapes you united, except that it uses the text and formatting of the shape you selected first.

When you unite two or more shapes, the ShapeSheet spreadsheets for the shapes you unite are deleted, 
and Visio creates a ShapeSheet spreadsheet for the new shape.



Unlink All Tasks
    Related Topics

Project Timeline template, Project > Unlink All Tasks
Unlinks all tasks in a project timeline. A link is a dependency. Linking two tasks means that you can’t start 
the later task until the earlier task is completed. Unlinking breaks the dependency.



Unlink Tasks
    Related Topics

Project Timeline template, Project > Unlink Tasks

Or, right-click a task bar or horiztonal grid line, then choose Unlink Tasks
Unlinks selected tasks in a project timeline. A link is a dependency. Linking two tasks means that you 
can’t start the later task until the earlier task is completed. Unlinking breaks the dependency.



Unprotect Document 
    Related Topics

Tools menu, drawing window
Opens a dialog box where you can cancel the protection options set in the Protect Document dialog box. 
Available only if you used the Protect Document command with a password to lock a drawing file from 
editing.

DIALOG BOX OPTIONS
Password  Type the password that was entered in the Protect Document dialog box. If you used a 
password, you must type it to cancel the protection.



Update Alignment Box
    Related Topics

Tools menu, drawing window
Adjusts the selection rectangle of a group to fit its new dimensions. You can use this command after 
deleting or adding a shape to a group, or changing the size of a shape in the group, in the group window. 
You can also use this command after editing the vertices of a shape in the ShapeSheet spreadsheet.



Update Database Record
    Related Topics

Right-click a selected shape linked to a database record
For this command to appear on a shape’s shortcut menu, you must have previously run the Database 
Wizard to link the shape to a database record.

Updates cells in a database record to reflect changes to the Visio shape the record is linked to. Values for
fields in the record’s cells are updated to match values in the shape’s linked ShapeSheet cells.



Update Icon
    Related Topics

Master menu, stencil window
Updates the selected master shape icon to look like the master shape.

If you specify automatic updating for the icon in the Properties or New Master dialog box, Visio changes 
the master shape icon to look like a miniature of the master shape when you change the master shape.

If you specify manual updating in the Properties or New Master dialog box and create a custom master 
shape icon, you can use the Edit Icon command to make the icon look different from the master shape. At
any point, you can use the Update Icon command to change a custom icon to a miniature of the master 
drawing.



Values
    Related Topics

View menu, ShapeSheet window
Displays the values of ShapeSheet cells instead of formulas. To display formulas instead of values, use 
the Formulas command.



View End Date
    Related Topics

Project Timeline template, right-click Project Frame shape, then choose View End Date

Or, right-click the timescale or nonworking strip, then choose View End Date
Scrolls the timeline to the end date for the last task in a project timeline. You can also click the end date (

) toolbar button.



View Next Date
    Related Topics

Project Timeline template, right-click Project Frame shape, then choose View Next Date

Or, right-click the timescale or nonworking strip, then choose View Next Date
Scrolls the timeline one unit (days, months, or quarters) forward. You can also click the next date ( ) 
toolbar button.



View Previous Date
    Related Topics

Project Timeline template, right-click Project Frame shape, then choose View Previous 
Date

Or, right-click the timescale or nonworking strip, then choose View Previous Date
Scrolls the timeline one unit (days, months, or quarters) backward. You can also click the previous date (

) toolbar button.



View Start Date
    Related Topics

Project Timeline template, right-click Project Frame shape, then choose View Start Date

Or, right-click the timescale or nonworking strip, then choose View Start Date
Scrolls the timeline to the start date for the first task in the project. You can also click the start date ( ) 
toolbar button.



View Timeline Range
    Related Topics

Project Timeline template, Project > View Timeline Range

Or, Right-click the timescale or Project Frame shape, then choose View Timeline Range
Opens the View Timeline Range dialog box where you can type the first and last dates that display on the 
timeline in the project frame for a project timeline. When you type new dates, the size of the project frame 
doesn’t change. The timeline units may change, therefore, to accommodate the change in dates. For 
example, if a timeline originally has a first date of April 28 and a last date of May 17 and you change the 
first date to March 1, the scale units change from Days/Months to Months/Years so the entire date range 
can be displayed in the project frame.

To resize the project frame so more dates display, select the frame, then drag a side selection handle.



View toolbar
    Related Topics

View > Toolbars, Toolbar shortcut menu
Displays a Visio toolbar that provides buttons you can use as shortcuts for choosing menu commands. To
switch the toolbar, choose View > Toolbars or right-click the toolbar, then choose View from the shortcut 
menu.

The tools available on the View toolbar are grid, guides, connections, layer properties, and shape layer 
list.

Note: Your toolbar may vary depending on the display resolution of your monitor, the size of your window,
and which window is active. 



Visio DWG Display Properties (General tab)

Double-click a displayed AutoCAD drawing to open the Visio DWG Display Properties 
dialog box
When you double-click an embedded AutoCAD drawing, Visio displays the Visio DWG Display Properties 
dialog box. The General tab in this dialog box describes the drawing’s dimensions, including the size, 
number of entities, current space or model space limits, and extents.

DIALOG BOX OPTIONS
Name    Shows the name of the AutoCAD file.

Location    Shows the drive and path from which the file was opened.

Size    Shows the size of the file.

Modified    Shows the date the file was last changed.

Number of Entities    Shows the number of graphic objects in the file.

Current View/Current Space    Shows whether a named view or model space was selected in the 
displayed file.

Model Space Limits/View Limits    Shows the user-defined size limits for the drawing. 

Extents    Shows the height and width of the drawing in AutoCAD units. Visio reads the size of the 
AutoCAD drawing extents to determine if the drawing can fit on the drawing page. If you display an 
AutoCAD file with drawing extents that exceed the Visio drawing page size, the portions of the drawing 
that fall outside the page won’t print. 



Visio Home Page
    Related Topics

Help > Visio On The Web
Opens your World Wide Web browser application and displays the Visio home page on the Web 
http://www.visio.com. On the Visio Web site you can find the following:

· Product information  The latest news about Visio products, white papers, sample drawings, and other
information. 

· Visio Corporation  Information about the Visio Corporation's evolution, international contacts, career 
opportunities, and more.

· Sales and service  Customer service, ordering information, including corporate, academic, and 
government sales information.

· Resellers and partners  The reseller newsletter, distribution SKU list, sales tools, descriptions of the 
reseller and business partner programs, and applications for both.

· Downloads and demos  Sample code for creating Visio add-ons and macros, stencils and templates 
contributed by third-party developers, and Visio patches and demo versions.



Visio Solutions Library
    Related Topics

Help > Visio On The Web
Opens your World Wide Web browser application and displays a Web site, http://www.visio.com/solutions,
that contains a variety of specialized drawing solutions—everything from job-specific shapes to time-
saving utilities. You can purchase and download these solutions directly from the Web to anywhere in 
North America.



Visual Basic Editor (Alt+F11)
    Related Topics

Tools menu, Macro submenu
Opens the Visual Basic Editor window, in which you can use Visual Basic for Applications (VBA) to debug,
edit, or create a new macro.

You can also use the Visual Basic editor button on the Developer toolbar. Use tips to identify the button.



Web toolbar
    Related Topics

View > Toolbars, Toolbar shortcut menu
Displays a Visio toolbar that provides buttons you can use as shortcuts for choosing menu commands. To
switch the toolbar, choose View > Toolbars or right-click the toolbar, then choose Web from the shortcut 
menu.

The tools available on the Web toolbar are insert hyperlink, back, forward, search the web, and Shape 
Explorer.

Note: Your toolbar may vary depending on the display resolution of your monitor, the size of your window,
and which window is active. 



What's This? (Shift+F1)
    Related Topics

Help menu
Displays context-sensitive online help for the item you click after choosing the What's This command. For 
example, to display Help for the drawing page, choose What's This from the Help menu (the cursor 
becomes a question mark), then click the drawing page. 

You can also use the help button on the Standard toolbar. Use tips to identify the button.



Whole Page (Ctrl+W)
    Related Topics

View menu, drawing and print preview windows
Displays the entire page in the drawing or print preview window.

You can also use the whole page button in the print preview window. Use tips to identify the button.

Or, while working in the drawing window, you can choose Page from the zoom list on the Standard 
toolbar.



Zoom (Custom) (F6)
    Related Topics

View > Zoom, drawing window
Adjusts the view of a page. You can choose from percentage options to display a page in proportion to its 
actual size (which corresponds to the 100% option) or choose Custom and type a percentage to specify 
the view. The range of the view depends on the drawing size.

Zoom to the size that best suits your work; for example, viewing a very small drawing probably requires 
magnification.

You can also use the zoom list on the Standard toolbar. Use tips to identify the list.

DIALOG BOX OPTIONS
Magnification    Choose Whole Page to display the entire page and part of the surrounding pasteboard. 
Standard percentages from 50 to 400 percent, as well as Whole Page and Page Width, are available with 
the Zoom command or in the zoom list; or type a number in the Percent box.

Options    Specifies zoom options.

Zoom When Editing Text  When this option is checked, Visio zooms in on text (depending on the font 
size and the current view) when you select a shape and type, double-click instances of certain master 
shapes, or select a shape with the text tool or text block tool.

Center Selection In Window  If any shapes are selected when you adjust the view, Visio zooms in on 
the center of the selection. If nothing is selected, Visio centers the new view in the center of the 
previous view.

Tip: When you hold down the Ctrl+Shift keys, the pointer turns into a magnifying glass. Clicking the left 
mouse button enlarges the view; clicking the right mouse button reduces the view. Whether you enlarge 
or reduce, Visio centers the new view wherever you click.



Zoom %
    Related Topics

View > Zoom; drawing window
Magnifies the page to the percent you choose. You can choose preset zoom levels or choose Custom to 
specify a zoom level.

You can also use the zoom in or zoom out buttons, or the zoom list on the Standard toolbar. Use tips to 
identify the buttons and the list.



Zoom In
    Related Topics

View menu, print preview window
Magnifies the page or tile to its actual size in the print preview window. Zoom to the size that best suits 
your work; for example, viewing a very small drawing probably requires increased magnification.

You can also use the zoom in button on the Standard toolbar. Use tips to identify the button.



Zoom Out
    Related Topics

View menu, print preview window
Returns the page or tile to the Whole Page view in the print preview window. Zoom to the size that best 
suits your work; for example, viewing a very large drawing probably requires decreased magnification.

You can also use the zoom out button on the Standard toolbar. Use tips to identify the button.
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Click a letter to go to that section.

A
Action
Active document
Active page
Add-on
Alignment box
Anchor point
Angle of rotation
Angular units
Antiscaling
Attribute
Automation

B
Background
Begin point
Bitmap
Bow

C
Cell reference
Center of rotation
Chord
Class module
Client-side image maps
Clipboard
Code behind events
Connection point
Connector
Container
Control



Control handle
Controller application
Control point
Control polygon
Coordinates
Crop
Crow's Foot 
Custom color
Custom property

D
Default font
Default units
Docked stencil
Domain of influence
Drag and drop drawing
Drawing
Drawing file
Drawing page
Drawing scale
Drawing unit
Dynamic Connector
Dynamic glue

E
Eccentricity handle
Embed
Endpoint
Event
Event object
Event procedure
Event sink
Explicit units
Expression

F
Field
Fill
Floating stencil
Foreground
Format
Format picture
Formula
Formula bar
Function

G
Geometry
Gesture recognition
Glue
Grid
Grid lines



Grid origin
Group
Group window
Guide, guide point

H
Handle

I
IDEF1X
Image maps
Implicit units
Index
Inherited formula
In place
Insertion point
Instance
Internal units

J
Jump

K

L
Layer
Library
Link
Local coordinates
Local formatting
Local formula
Local stencil
Lock

M
Macro
Master shape
Modeless activity
Module
Multiplicity

N
Nonperiodic spline
Notification sink
Number-unit pair

O
Object
Object linking and embedding (OLE)



Offset
One-dimensional (1-D) shape
ODBC (Open Database Connectivity)
Origin
Orthogonal

P - Q
Page
Page coordinates
Page scale
Page sheet
Page unit
Pan
Parametric
Parent
Paste
Pasteboard
Path
Periodic spline
Persistence
Pin
Pixel
Placeable shape
Point
Polygonal line
Primary selection
Procedure
Procedure template
Project
Provider application

R
Range of eight
Resize
Routable connector
Rotation handle

S
Scale
Scope
Segment
Selection
Selection handle
Selection net
Selection rectangle
Server-side image map
Shape
ShapeSheet
Sink object
Size
SmartConnector shape
SmartShape symbol
Snap



Spline
Spline knot
Stacking order
Stamp
Stand-alone stencil
Static glue
Stencil
Style
Subdivision
Subselect

T
Template
Text block
Tile
Toolbar
Tip
Two-dimensional (2-D) shape

U
Unitless number
Units of measure
Universal Connector
Unscaled drawing page
User form

V
Vertex, Vertices
Visio library
Visio type library

W - Y
Wizard
Workspace

Z
Zero point
Zoom





Action

1. A user-defined menu item associated with a shape. 
When the shape is selected, the item appears on the 
shortcut menu and on the Actions submenu of the 
Shape menu. 2. A program or Visio command that runs 
in response to an event. See also event.

Active document

The document that is currently available for editing in an
instance of Visio. 

Active page

The drawing page that is currently available for editing 
in a Visio document.

Add-on

A program that extends Visio through Automation 
references to Visio objects, methods, and properties. 
When an add-on's .exe or .vsl file is installed in a folder 
along the Visio add-on's path, its name appears in the 
Macros dialog box.

Alignment box

The rectangle that appears around shapes and objects 
from other applications as you move them. See also 
selection rectangle.

Anchor point

A fixed point that anchors a "rubber band" line, whose 
other end is connected to a control handle. As the user 
moves the control handle, the rubber band stretches 
and shrinks to show the original location of the handle. 
The anchor point provides information to the user, but it 
does not affect the behavior of the control handle. See 
also control handle.

Angle of rotation

The angle of the orientation of a shape's local 
coordinate system with respect to its parent coordinate 
system. The angle of rotation is specified in the Angle 
cell of the ShapeSheet's Shape Transform section.

Angular units

The units in which angles are expressed in ShapeSheet



cells. See also default units, internal units.

Antiscaling

Behavior in which a shape is not sized according to the 
drawing scale of a page. Visio automatically antiscales 
shapes when the drawing scale of the master exceeds 
the range of eight. See also range of eight.

Attribute

Individual formatting elements, such as line color, fill 
color, and line weight, that you can apply to shapes. A 
style can have several attributes. See also format, style.

Automation

A means by which an application can incorporate or 
extend the functionality of another application by using 
its objects. Formerly known as OLE Automation. See 
also object.

Background

A page that you can assign to another page to create 
multiple layers in a drawing. You can see shapes on a 
background when the page it is assigned to is 
displayed, but you can't select or edit the background's 
shapes without displaying the background. See also 
foreground page, layer.

Begin point

The selection handle at the beginning of a 1-D shape. 
The begin point is marked by an X. Also called 
beginning point.

Bitmap

An image stored as a pattern of dots. A scanned 
photograph or graphic that you create in a paint 
program is usually stored as a bitmap.

Bow

The distance from the midpoint of a circular arc to the 
midpoint of the arc's chord.

Cell reference

Used in ShapeSheet formulas to calculate the value of 



one cell on the basis of the value of another cell.

Center of rotation

The point around which a shape or text block rotates. 
When you select a 2-D shape with the rotation tool, its 
center of rotation is marked by a circle with a plus sign 
inside it. By default, the center of rotation is at the 
center of the shape. You can move the center of rotation
by dragging it with the rotation tool. See also pin.

Chord

A line that connects the endpoints of an arc.

Class module

In a VBA or Visual Basic project, a module containing 
the definition of a class (its properties and methods). 
See also module.

Client-side image map

A graphic with different linked regions. All the 
information a Web browser needs to process a click on 
a linked region is stored in the HTML file with the image 
data. See also Server-side image map.

Clipboard

A temporary storage area in Windows that is used to 
transfer data between documents and applications. You 
can use the Clipboard to copy shapes and text and to 
copy shapes between drawings in Visio or between 
Visio and other Windows applications.

Code behind events

In a VBA program, code that is executed when an event
occurs. For example, a button on a user form usually 
has code behind the Click event. See also event 
procedure.

Connection point

A point on a shape where a connector can be glued to a
shape. You can create new connection points inside, 
outside, or on the perimeter of a shape by using the 
connection point tool. Each of a shape's connection 
points is marked with a blue X ( ) when Connection 
Points is checked on the View menu.



Connector

Any one-dimensional shape that can be glued between 
two shapes in a drawing to connect the shapes. Some 
master shapes are connectors. You can also use lines 
and other shapes you draw as connectors. See also 
SmartConnector.

Container

An OLE application in which you embed or link 
information. For example, if you insert a Visio drawing 
into a Microsoft Word document, Microsoft Word is the 
container application. A container application is also 
known as a client. See also OLE.

Control

An object you can place on a user form or a Visio 
drawing page that has its own set of properties, 
methods, and events, such as a toolbar button.

Control handle

A handle that makes shapes behave in special ways. 
For example, you might use a control handle to adjust 
the roundness of a shape's corners, to reshape an 
arrow, or to drag a connector directly out of another 
shape.

Controller application

In Automation, the application (such as your program) 
that uses the objects exposed by a provider application. 
The controller application creates instances of the 
objects and then sets their properties or invokes their 
methods to make the objects serve the application.

Control point

1. The circle that appears on a line or an arc (or a line or
an arc segment) when the line or arc is selected with 
the pencil tool. You can drag a control point to change 
the curvature of an arc or ellipse. 2. A point that 
influences the curvature of a spline segment. See also 
domain of influence.

Control polygon

A series of straight line segments that connect all the 
control points of a single spline.



Coordinates

A pair of numbers that indicates the position of a point in
relation to the origin of a shape, a group, or the page. 
The x-coordinate indicates the horizontal distance and 
the y-coordinate indicates the vertical distance of the 
point. Most ShapeSheet formulas are expressed as 
coordinates for controlling the position and size of a 
shape. See also origin.

Crop

To reduce or expand an object from another application 
used in a Visio drawing. Although cropping appears to 
clip off parts of the object, Visio retains the clipped 
portions of the object in memory. You crop an object by 
selecting it with the crop tool and dragging one of its 
handles.

Crow's Foot

A specification language for describing data structures. 
Visio includes a Crow's Foot template. You can use the 
Crow's Foot entity and relationship shapes to diagram 
the structure of databases.

Custom color

A color in Visio that is stored with a shape as an rgb or 
hsl value rather than as an index to the document's 
color palette. A custom color is saved only with the 
shape to which it is applied.

Default font

The font that Visio uses by default to display text 
included in a shape. The default font can be specified in
the [Application] section of visio.ini with settings for 
DefaultFontName, DefaultFontFamily, and 
DefaultFontCharset. If the [Application] section of 
visio.ini contains the line "ShowDefaultFont = 1", the 
default font is displayed with angle brackets in the Font 
dialog box.

Default units

The units of measure used to display a value in a 
ShapeSheet cell if no units of measure are explicitly 
specified. Default drawing and page units are properties
of a drawing page. Default angular and text units are 
application settings.



Domain of influence

The portion of a spline, specified as a number of spline 
knots, whose curvature is influenced by a single control 
point.

Drag and drop drawing

Creating an instance of a master shape in a drawing by 
dragging the master shape from a stencil to the 
drawing. To drag a master shape, point to it with the 
mouse and hold down the left mouse button. Move the 
mouse until the shape is where you want it in the 
drawing, and then release the mouse button to drop the 
shape.

Drawing

All the shapes on the foreground page together with all 
the shapes on optional background pages.

Drawing file

A Visio file with a .vsd extension that contains a drawing.
To create a drawing file, choose New from the File 
menu, and start the drawing from scratch, or base it on 
a template (drawing type). Then save the file.

A drawing file can contain one or more pages. Every 
drawing file has its own stencil, called a local stencil, 
which contains all the master shapes you used on any 
of the drawing pages in that file, even if you deleted 
them from the drawing page. You can view the local 
stencil by choosing Show Master Shapes from the 
Window menu.

Drawing page

The printable area in a drawing window that contains a 
drawing. A page can be either a foreground or a 
background page. Each page has a size, which usually 
corresponds to a standard paper size, and it has a 
scale. See also background page, foreground page.

Drawing scale

The ratio of a page scale to a specified number of 
drawing units, such as 1 cm = 1 m. Also called scale.

Dynamic Connector

A 1-D connector shape that changes its path to avoid 



crossing through 2-D placeable shapes that lie between 
the two shapes the connector connects. (This type of 
connector is also called a "routable connector.") When 
you drag a Dynamic Connector's endpoints, it reroutes 
automatically. When you select the Dynamic Connector,
it displays midpoints and vertices you can drag to 
manually change its route from one shape to the other.

Visio creates a Dynamic Connector when you use the 
connector tool or the Connect Shapes command, as 
long as a connector shape is not selected on the stencil.
See also placeable shape.

Dynamic glue

A type of glue that allows the endpoint of a connector 
shape to move from one connection point to another as 
the connected shapes are moved. (When shapes are 
connected without dynamic glue, the endpoints of the 
connector are attached to specific connection points; in 
that case, instead of jumping to a new connection point, 
the connector will change shape to avoid crossing over 
the shapes when they're moved.)

Eccentricity handle

The circle that appears at each end of a dotted line 
when a control point of an elliptical arc is selected with 
the pencil tool. Eccentricity handles are dragged to 
change the angle and magnitude of an arc's eccentricity.

Embed

To insert a Visio drawing into another application's 
document (a container application) to establish a 
dynamic connection between the drawing and the other 
document through the object linking and embedding 
(OLE) protocol. In the container application, you can 
open the embedded drawing in Visio to edit it. You can 
also insert objects from other applications into Visio. 
When you embed an object based on an existing file, 
then edit the original file, the embedded object does not 
automatically reflect changes. See also OLE and In 
place.

Endpoint

Either of the square handles that appear at the 
beginning or end of a selected line, arc, or other one-
dimensional shape. The endpoint at the beginning of the
shape (begin point) is marked by an X. The endpoint at 
the end of the shape (end point) is marked by a plus 
sign (+). See also vertex, vertices.



Event

An occurrence in Visio, such as a change to a shape 
formula or the deletion of a page. See also action, code 
behind events.

Event object

A Visio object you create from a standalone Visual 
Basic, C, or C++ program to handle Visio events. An 
Event object pairs an event with an action-either to run 
an add-on or to notify an object in your program that the
event occurred. When the event occurs, the Event 
object fires, triggering its action.

Event procedure

In a Visual Basic program, code that is executed when 
an event occurs. For example, a button on a Visual 
Basic form usually has an event procedure to handle 
the Click event. See also code behind events.

Event sink

See sink object.

Explicit units

Units of measure specified as part of a number-unit pair 
so that the result is always displayed using the units 
specified. For example, the value "3 mm" always 
appears in the ShapeSheet window as "3 mm." See 
also default units, implicit units.

Expression

A combination of values, operators, functions, and sheet
references that results in a value. A logical expression 
compares two values and yields a true or false result. 

Field

A placeholder in text that displays information such as 
dimensions, dates, and times. A field might display the 
date and time a drawing is printed, a shape's angle of 
rotation, or the result of a formula you write. Fields are 
automatically updated when you change a drawing. A 
field can also read information from Lotus Notes.

Fill



The color and pattern inside a closed shape. Visio's 
default fill is solid white.

Foreground

The top page of a drawing. Shapes on the foreground 
page appear in front of shapes on the background page 
and are not visible when you edit the background of the 
drawing. See also background.

Format

To affect the visual appearance of a shape (such as the 
thickness and color of its lines, the color and pattern 
inside the shape, and its font) either by using a style or 
by applying individual attributes. See also attribute, 
style.

Format picture

A set of symbols and abbreviations that Visio interprets 
and uses to format string output, such as in a custom 
text field formula. For example, "0.## UU" is a    format 
picture that displays the input value "260.125 ft." as 
"260.13 FEET".

Formula

An expression that is entered in a ShapeSheet cell, 
which returns a value. See also expression.

Formula bar

The portion of the ShapeSheet window in which you 
enter a formula for the selected ShapeSheet cell.

Function

A calculation tool used for a variety of purposes in a 
ShapeSheet formula. Visio includes mathematical, 
trigonometric, geometric, event, date and time, color, 
logical, statistical, and other functions. 

Geometry

An arrangement of vertices and segments that define a 
path. 

Gesture recognition

A feature of the pencil tool. As you begin to move the 
mouse, Visio quickly calculates the path the mouse 



pointer travels. If the path of the mouse is straight, the 
pencil tool draws a straight line segment. If the path 
curves, the pencil tool draws an arc.

Glue

A property of shapes that causes them to stay 
connected even when one of the shapes is moved. 
When you attach a connector to a shape, you are gluing
the connector. If you move the shape, Visio adjusts the 
connector as needed. If you move the connector, the 
glue is broken and the shapes are no longer connected. 
See also dynamic glue.

Grid

Grids are non-printing horizontal and vertical lines 
displayed at regular intervals on the page. 

Grid lines

The faint vertical and horizontal lines that appear in the 
drawing window when the grid is turned on. You can use
grid lines to help position shapes precisely.

Grid origin

The point that defines the layout of grid lines on the 
drawing page. A vertical grid line and a horizontal grid 
line pass through the grid origin, and all other grid lines 
are drawn at specified intervals from these reference 
lines. By default, the grid origin is the lower-left corner of
the drawing page.

Group

A shape that is composed of two or more shapes. A 
group can also include other groups and objects from 
other applications. A group can be moved and sized as 
a single shape, but its members retain their original 
appearance and properties.

Group window

A drawing window you can open to edit individual 
components of a group. The group appears unrotated in
the group window even if it is rotated on the drawing 
page. To open the group window, select the group, then 
choose Edit > Open [group name].

Guide, guide point



A reference line that can be dragged into the drawing 
window to help position shapes precisely. A horizontal 
guide is dragged from the horizontal ruler, a vertical 
guide from the vertical ruler, and a guide point from the 
upper-left corner of the drawing window, where the 
horizontal and vertical rulers meet.

Handle

A control that appears when you select a shape. You 
can use handles to alter a shape. Handles vary with the 
type of shape and the tool you use to select it. For 
example, when you select a shape with the pointer tool, 
it displays selection handles that you can drag to 
change the shape's size and proportions. When you 
select a shape with the rotation tool, the shape displays 
rotation handles that you can drag to rotate the shape. 
See also control handle, eccentricity handle, rotation 
handle.

IDEF1X

A specification language for describing data structures. 
Visio includes an IDEF1X template. You can use the 
IDEF1X entity and relationship shapes to diagram the 
structure of databases.

Image map

A type of graphic used on the World Wide Web. An 
image map is divided into different regions, some of 
which are associated with links. See also Client-side 
image map and Server-side image map.

Implicit units

Units of measure specified as part of a number-unit pair 
in which the result is displayed using a specified 
measurement system, which may not coincide with the 
units originally entered. For example, the expression "1 
[in.,d]" specifies that the value is initially interpreted as 1
inch, but the d indicates that the result is displayed 
using the default drawing units of the current page. If 
the drawing units are centimeters, the ShapeSheet 
displays "2.54 cm." See also default units, explicit units.

Index

A number corresponding to the position of a color in the 
Color dialog box. The index is displayed to the left of the
color. Visio records stores a shape's color as the index 
for that color.



Inherited formula

A formula that is stored in a style or a master but used 
by an instance as if the formula were stored locally with 
the shape. A change to a formula in the style or master 
affects all shapes that inherit the formula and do not 
have an overriding local formula.

In place

Visio opens in place when you run it from within a 
container application. When you work in place, Visio 
menus and toolbars appear and replace some of the 
container's menus and toolbars.

Insertion point

The blinking vertical line that appears in text when you 
select a shape with the text tool and click the text with 
the mouse. Text you type appears at the insertion point. 
You can move the insertion point by clicking another 
location with the mouse or by pressing the arrow keys.

Instance

1. A copy of a master shape, which you create by 
dragging the master shape from a stencil to a drawing. 
2. A running image of a Windows application.

Internal units

The units of measure that Visio uses internally to store 
dimensional values. Visio's internal units are inches for 
linear measurements and radians for angular 
measurements.

Jump

A hyperlink between a shape or drawing page and 
another page in the drawing file, a file in another 
application, or an Internet site. You can right-click the 
shape or drawing page to "jump" to the destination.

Library

See Visio library, Visio type library.

Link

To establish a dynamic connection between an object in
a Visio drawing and another application's file through 



the object linking and embedding (OLE) protocol. When 
changes are made to the original file, you can update 
the link so that the most current version of the object 
appears in the linked file. See also OLE.

Local coordinates

The coordinate system whose origin is the lower-left 
corner of a shape's width-height box. The geometry of a
shape is expressed in local coordinates. See also page 
coordinates, parent coordinates.

Local formatting

Individual formatting attributes such as line width, fill 
color, or font size, that you apply to a selected shape by 
using a command on the Format menu, such as Line, 
Fill, or Text. Local formatting is most useful when you 
want to give a unique look to one shape, or to just a few
shapes.

Local formula

A formula that is stored in a cell of a shape instead of 
being inherited from a master or a style. A local formula 
overrides changes to the corresponding cell in the 
master of which the shape is an instance. Also called 
local override. See also inherited formula.

Local stencil

A stencil stored in a drawing file, which contains an 
inventory of the master shapes used in all of the 
drawings in the file. Master shapes on the local stencil 
are linked to their instances in the drawings. To display 
the local stencil for the current drawing file, choose 
Show Master Shapes from the Window menu. See also 
stand-alone stencil.

Lock

A setting that limits the ways that users can change a 
shape. For example, a lock on a selection handle 
prevents the user from resizing a shape using the 
selection handle.

Macro

1. A Visual Basic for Applications (VBA) program that 
extends Visio through Automation by referencing Visio 
objects, properties, methods, and events. 2. A 
procedure that takes no arguments and is contained 



within a module within a project stored in a Visio 
template, stencil or drawing.

Master shape

A shape in a stencil. You drag and drop a master shape 
from a stencil into a drawing to create an instance of the
master shape. Many of the master shapes in the 
stencils provided with Visio are SmartShapes 
symbols¾shapes with programming that controls how 
the shape behaves when it is moved or sized.

Modeless activity

A program activity that does not terminate when control 
returns to Visio. For example, an add-on may open a 
modeless window, which remains open after the add-on 
terminates.

Module

In a VBA or Visual Basic project, code that is a set of 
declarations followed by procedures. A standard module
contains only procedure, type, and data declarations 
and definitions. See also class module, user form.

Multiplicity

The number of times a spline knot is repeated.

Nonperiodic spline

A spline with defined endpoints. If a spline's begin point 
and end point coincide, the spline is closed. See also 
periodic spline.

Notification sink

See sink object.

Number-unit pair

An expression that includes a number and a 
corresponding dimension. For example, "1 cm" is a 
number-unit pair.

Object

Information created in another application and imported,
embedded, or linked in a Visio drawing. The term object
is used to refer to objects from other applications and 
OLE objects. The application that the object is created 



in is known as the server application. See also OLE.

Object linking and embedding (OLE)

A Windows protocol that makes it possible to embed an 
object created in one Windows application into a 
document created in a different Windows application, or 
to link an object to a file that contains the original object.

Offset

For a specified line or curve, Visio implements the offset
as a pair of lines that are equidistant from the original 
line or curve. The offset from a straight line is a pair of 
straight lines, and the offset of a circular arc is a pair of 
circular arcs. If the offset to a curve is not a line, arc, or 
elliptical arc, then the offset is a spline, or series of 
splines that approximate the offset of the curve. This 
approximation comes as close as possible to fitting all 
the points that are a specified distance from a curve.

One-dimensional (1-D) shape

A straight line or arc you draw in Visio, a connector on a
stencil, or any shape you define as a one-dimensional 
shape. A one-dimensional shape has a beginning point 
and an ending point and can be glued between two 
shapes to connect them. See also two-dimensional (2-
D) shape.

ODBC (Open Database Connectivity)

A Microsoft interface that allows applications to access, 
view, and modify data from a variety of databases. 
Many database applications, including Microsoft Access
7.0, Microsoft SQL Server, and Oracle SQL Server, are 
ODBC-compliant.

Origin

The lower-left corner of the selection rectangle of a 
shape, of a group, or of the drawing page. The x- and y-
coordinates of the origin are always 0,0. Dimensions of 
a shape, such as its width and height, and the center of 
rotation are measured from its origin. The location of a 
shape in relation to its parent (a group or the page) is 
measured from the parent's origin. See also 
coordinates.

Orthogonal

Intersecting or lying at right angles. You can rotate a 



Visio drawing page so that every shape in your 
drawing¾regardless of the angle at which it is 
drawn¾can be drawn orthogonally; in effect, the 
drawing maintains a horizontal and/or vertical 
orientation to the Visio gridlines and rulers.

Page

The printable area in a drawing window that contains a 
drawing. A page can be either a foreground or a 
background page. Each page has a size, which usually 
corresponds to a standard paper size, and it has a 
scale. See also background, foreground, layer.

Page coordinates

The coordinate system whose origin is the lower-left 
corner of a drawing page.

Page scale

The number of page units that represent the number of 
drawing units specified in the drawing scale. For 
example, if the drawing scale is 1 cm = 1 m, the page 
scale is 1 cm. See also drawing scale, drawing unit, 
page unit.

Page sheet

A ShapeSheet that represents a page. See also 
ShapeSheet.

Pan

To move an OLE object with the crop tool by holding 
down the left mouse button and shifting the object within
the object's border. See also handle, object linking and 
embedding (OLE).

Parametric

The ability of a Visio shape to adjust its geometry and 
other attributes according to the values of certain 
parameters.

Parent

The group that contains a shape is the shape's parent. 
If the shape is not in a group, its parent is the page.

Paste



To insert information from the Windows Clipboard into a 
Visio drawing or another Windows application.

Pasteboard

The area that surrounds a page in the drawing window. 
You can store shapes on the pasteboard. Each page 
has its own pasteboard.

Path

A series of contiguous line or arc segments in a shape. 
A shape can have more than one path. See also 
segment.

Periodic spline

A closed spline with no defined endpoints. See also 
nonperiodic spline.

Persistence

The lifetime of a variable, procedure, or object. For 
example, an object can persist while Visio is running. An
object that can store Event objects between Visio 
sessions is said to persist events.

Pin

The point around which a shape or text block rotates. 
When you select a 2-D shape with the rotation tool, its 
center of rotation is marked by a circle with a plus sign 
inside it. A shape's pin expressed in parent coordinates 
(the PinX and PinY cells of the Shape Transform 
section) defines the shape's location on the drawing 
page. Also known as center of rotation.

Placeable shape

A 2-D shape that is set to work with routable connectors
and automatic layout (Lay Out Shapes). If a shape is set
as placeable, a routable connector can detect and avoid
crossing through it. You can set a shape as placeable in
the Behavior dialog box, by selecting Lay Out and 
Route Around. If you glue a routable connector, such as 
the Dynamic Connector, to a 2-D shape, Visio 
automatically sets the 2-D shape as placeable.

Pixel

An individual block of display information. The term pixel



is derived from the phrase "picture element."

Point

A single value that embodies a set of x- and y-
coordinates for greater convenience in calculations.

Primary selection

The first selected shape in a multiple selection, 
indicated on the drawing page by green selection 
handles. When a multiple selection is combined, the 
formatting of the primary selection is applied to the new 
shape. In a Selection object, the primary selection is the
first item in the object's Shapes collection. See also 
selection.

Procedure

A named sequence of statements executed as a unit. 
For example, Function, Property, and Sub are types of 
procedures.

Procedure template

The beginning and ending statements that are 
automatically inserted in the Code window when you 
specify a Function, Property, or Sub procedure in the 
Insert Procedure dialog box.

Project

In VBA, the code that you write that is saved with a 
Visio file. You can create only one project for a Visio 
document, but that project can consist of any number of 
modules, class modules, and user forms.

Provider application

An application that provides objects that can be 
controlled through Automation. A provider application 
makes the objects accessible to other applications and 
provides, or exposes, the properties and methods that 
control them. See also controller application.

Range of eight

A rule for handling instances whose scale is different 
from that of the drawing page. If the ratio of a master's 
drawing scale differs from that of the drawing page by 
less than a factor of eight, the instance is scaled 
appropriately for the drawing page. Otherwise, the 



instance is antiscaled. See also antiscaling.

Resize

To change the dimensions of a shape.

Rotation handle

One of the round handles that appear at a corner of a 
shape's selection rectangle when you select the shape 
with the rotation tool.

Routable connector

A 1-D connector that automatically changes its path to 
avoid crossing through 2-D placeable shapes that lie 
between the two shapes the connector connects. When 
you select a routable connector, it displays midpoints 
and vertices that you can drag to edit the connector's 
path manually. The Dynamic Connector is a routable 
connector.

Scale

A measure of the relationship between actual distances 
and distances represented in a Visio drawing. For 
example, a floor plan might have a scale of one meter of
actual distance to one centimeter in the drawing. 

Scope

The extent to which a variable, procedure, or object 
persists in a running program. The scope of an item 
typically depends on where it is declared. For example, 
the scope of a variable declared in a procedure is the 
procedure-when the procedure finishes executing, the 
variable goes out of scope.

Segment

A straight line or curve that is part of a more complex 
shape.

Selection

Shapes in a drawing that are the focus of your next 
action. Selected shapes display handles. Selection also 
refers to text selected in a text block. Selected text is 
highlighted.

Selection handle



A square handle that appears on a shape selected with 
the pointer tool. Selection handles indicate that you can 
size or move the shape.

Selection net

A means of selecting more than one shape at a time by 
dragging the pointer tool to define a rectangular area 
that encloses all the shapes to be selected.

Selection rectangle

The dotted line that surrounds selected shapes or 
objects from other applications. See also alignment box.

Server-side image map

A World Wide Web graphic with different linked regions. 
A program on a Web server examines map data 
associated with the linked regions and processes the 
links. See also Client-side image map.

Shape

1. An open or closed object that is created using Visio's 
drawing tools or commands. 2. A grouped collection of 
shapes. 3. An instance of a master dropped in a 
drawing. 4. In a program, any item represented by a 
Shape object-a shape, group, guide, guide point, or 
page sheet of a drawing page or a master.

ShapeSheet

The spreadsheet that contains information about a 
shape¾for example its dimensions, its angle and center
of rotation, and the styles that determine the shape's 
appearance. ShapeSheets can contain formulas that 
define how the shape behaves when it is moved or 
sized.

Sink object

In a VBA program, a class that receives events fired by 
a particular kind of Visio object. In a standalone Visual 
Basic, C, or C++ program, an object that receives the 
notification sent by a Visio Event object and that 
enables two-way communication between a standalone 
solution and Visio. Also known as event sink, notification
sink.

Size



To change the dimensions of a shape by dragging one 
of its handles after it has been selected with the pointer 
tool.

SmartConnector shape

A 1-D shape that behaves intelligently when it's used to 
connect other shapes. For example, if you use a 
SmartConnector shape to connect two shapes and you 
move one of the shapes, the SmartConnector shape 
repositions itself and in some cases can change its 
shape to avoid crossing over the shapes it connects. 
See also one-dimensional (1-D) 
shapegls_OneDimensionalShape, Universal 
connectorgls_UniversalConnector@visio.hlp.

SmartShape symbol

A shape that is programmed to behave predictably 
when you move or size it.

Snap

The ability of shapes, guides, grid lines, and other 
elements in Visio to pull shapes and other elements into
position when they are moved and sized.

Spline

A freeform curve that is based on a polynomial 
equation.

Spline knot

A real number that marks the boundary between 
polynomial pieces on a spline.

Stacking order

Determines how shapes overlap other shapes on the 
page and the order in which shapes are selected. You 
can change the stacking order of shapes by using the 
Bring To Front, Bring Forward, Send To Back, and Send
Backward commands on the Shape menu.

Stamp

To create an instance of a master shape with the stamp 
tool. To stamp a master shape, select the master shape 
in the stencil, choose the stamp tool, and click to where 
you want the instance to appear. To glue a connector 
with the stamp tool, select the connector in the stencil, 



and then drag between connection points on the shapes
you want to connect.

Stand-alone stencil

A Visio file with a .vss filename extension that contains a
collection of master shapes and is usually referred to 
simply as a stencil. Unlike a local stencil, a stand-alone 
stencil usually does not have an accompanying 
drawing. See also local stencilgls_LocalStencil, stencil.

Static glue

A type of glue behavior in which the endpoint of a 
connector remains fixed to a particular connection point,
no matter how the shape to which it is glued moves. 
See also glue, dynamic glue.

Stencil

A collection of master shapes that are associated with a 
particular drawing type. To create a drawing, you drag 
and drop shapes from the stencil to the drawing page. 
Stencils are stored in stencil files (with a .vss extension).
When you create a new drawing based on a template, 
the template opens stencils that are related to the 
template's drawing type. By default, stencils appear 
docked on the right-side of the drawing window. You can
also open a stencil file independently of a template. See
also templategls_Template@visio.hlp.

Style

A collection of attributes that has a name and is saved 
with a template or drawing file. You can use a style to 
apply a set of attributes to a shape with a single action. 
Many of Visio's templates have styles that are included 
in the new drawings you create from a template. See 
also attribute.

Subdivision

The division between grid lines and between intervals of
the ruler. This option is set using the Ruler & Grid 
command. The choices are Fine, Normal, and Coarse.

Subselect

To select individual shapes within a group.

Template



A Visio file that opens one or more stencils and can 
contain styles and settings for a particular kind of 
drawing, for example, the appropriate scale and grid. 
You can create a new drawing with a template's styles 
and settings by opening the template. See also 
stencilgls_Stencil.

Text block

The text area associated with a shape that appears 
when you click the shape with the text tool or select the 
shape and start typing. You can size a text block and 
move a text block in relation to its shape.

Tile

A printing technique whereby oversized drawing pages 
are printed on multiple sheets of paper. Also, a 
command on the Window menu that arranges open 
windows side by side in the Visio main window.

Toolbars

The rows of boxes, buttons, and tools that appears 
below the menu bar in the Visio window. On the 
toolbars, you can choose styles from lists, turn options 
such as snap and glue on or off, and choose tools to 
create and modify shapes.

Tip

When you pause the pointer (without the mouse button pressed) 
over an item on the toolbar, a control handle, or a master shape 
icon (when the stencil window is set to display icons only), a tip 
appears. To turn off tips, choose View > Toolbars > Toolbars, 
then uncheck the Show ScreenTips option.

Two-dimensional (2-D) shape

A shape that has corner selection handles that you can 
use to size the shape proportionally. Most rectangles, 
ellipses, and freeform shapes are defined as two-
dimensional. See also one-dimensional (1-D) 
shapegls_OneDimensionalShape.

Units of measure

The type of measurement system used in a drawing. In 
formulas, used after a number to specify the unit of 
measure that the number represents. You specify the 
default unit of measure for a document (inches, feet, 
miles, points, meters, and so on) in the Options box.



Unitless number

A number that is not associated with a unit of measure.

Universal connector

A master shape that is programmed to connect any two 
points without crossing over the shapes it connects. By 
default, an instance of the Universal Connector is 
created when you use the connector tool and the 
Connect Shapes command. See also connector, 
SmartConnector.

Unscaled drawing page

A drawing page whose drawing scale is 1:1.

User form

A file in a VBA or Visual Basic project with the file 
extension .frm that contains user interface controls, 
such as command buttons and text boxes.

Vertex, vertices

One of the diamond-shaped handles that appears 
between two segments on a multiple-segment shape or 
at the end of a segment. On most shapes, vertices 
appear when you select a shape with the pencil tool. On
a Dynamic Connector, vertices appear when you select 
the shape with the pointer tool. You can reshape a 
shape or connector by dragging its vertices. See also 
endpoint.

Visio library

A special dynamic-link library (dll) that is loaded by Visio
at run time and can implement one or more Visio add-
ons. A Visio library has the filename extension .vsl.

Visio type library

A file that contains definitions of the objects, properties, 
methods, events, and constants that Visio exposes to 
Automation.

Workspace

A Visio file that contains information about the size and 
position of drawings and stencils at the time you save 
the workspace. When you open a workspace, Visio 



recreates the arrangement of stencil and drawing 
windows for you. You can store a workspace with a 
drawing file or save a workspace as a workspace (.vsw) 
file.

Zero point

1. The location of the 0 on the horizontal or vertical 
ruler. 2. The point in the drawing window where the zero
points of each ruler intersect. By default, the zero point 
is the lower-left corner of the drawing page.

Zoom

To increase or decrease the display size of a drawing in 
the drawing window. A display size of 100% (or Actual 
Size) displays the drawing at the same size it will be 
when it is printed, unless you reduce or enlarge the 
printed output in the Page Setup dialog box.

Docked stencil

A stencil that is attached to the side of the drawing 
window. By default, stencils are docked on the left side 
of the window. You can make stencils float, or you can 
dock them on the right side of the drawing window. See 
also floating stencil.

Floating stencil

A stencil that appears in the size and location you 
choose. By default, stencils are docked on the left side 
of the window. You can make stencils float, or you can 
dock them on the right side of the drawing window. See 
also docked stencil.

Custom property

A database field in which you enter information relevant 
to a shape. Many Visio masters come with custom 
properties already defined. You can edit or delete 
existing properties and add new properties.

To edit, add, or delete custom properties, choose Tools 
> Macro > Custom Properties Editor. To view a shape's 
custom properties, select the shape, then choose 
Shape > Custom Properties.

Drawing unit

Drawing units are sizes in the real world, and page units
are sizes on the printed page. For example, in an 
architectural drawing that uses the scale I cm = 1m, 1 



meter is the drawing unit and 1 centimeter is the page 
unit. The ratio of page units to drawing units is the 
drawing scale.

Page unit

Page units are sizes on the printed page, and drawing 
units are sizes in the real world. For example, in an 
architectural drawing that uses the scale I cm = 1m, 1 
meter is the drawing unit and 1 centimeter is the page 
unit. The ratio of page units to drawing units is the 
drawing scale. See also drawing scale, drawing unit.

Wizard

A Visio tool that automates common tasks. For 
example, you can use the Org Chart Wizard to 
automate creating an organization chart.

To open Wizards, choose File > New, or Tools > Macro.

Layer

A named category of shapes. You can organize shapes 
in your drawing by assigning them to layers. You can 
selectively view, edit, print, or lock layers, as well as 
control whether shapes on a layer can be snapped to or
glued to. See also background.

Polygonal line

The type of line you create when you draw a sequence 
of line segments in one stroke without lifting your pen. A
closed polygonal line is a polygon. A polygonal line in 
Visio is represented in the ShapeSheet by a contiguous 
sequence of LineTo rows.



Command shortcuts

Keyboard shortcuts for some commands are listed on Visio's menus.

To choose this 
command:

Press:

Actual Size Ctrl+I

Align Shapes F8

Bring To Front Ctrl+F

Cascade Alt+F7

Copy Ctrl+C

Cut Ctrl+X

Duplicate Ctrl+D

Field Ctrl+F9

Fill F3

Flip Horizontal Ctrl+H

Flip Vertical Ctrl+J

Font F11

Glue (toggles on or off) F9

Group Ctrl+G

Help, display online Help F1

Line Shift+F3

Macros Alt+F8

New Blank Drawing Ctrl+N

Open Ctrl+O

Page F5

Paragraph Shift+F11

Paste Ctrl+V

Print Ctrl+P

Page Properties Shift+F5

Redo Ctrl+Y

Repeat F4

Rotate Left Ctrl+L

Rotate Right Ctrl+R

Save Ctrl+S

Save As F12

Save Workspace Alt+F12



Select All Ctrl+A

Send To Back Ctrl+B

Snap (toggles on or off) Shift+F9

Snap & Glue Alt+F9

Spelling F7

Tabs Ctrl+F11

Tile Horizontally Shift+F7

Tile Vertically Ctrl+Shift+F7

Undo Ctrl+Z

Ungroup Ctrl+U

Visual Basic Editor Alt+F11

Whole Page Ctrl+W

Zoom F6

Tip: To activate the menu bar, press Alt or F10.

You can use these shortcuts with text:

To insert a field in text: Press:

Height field Ctrl+Shift+H

Rotation angle field Ctrl+Shift+A

Width field Ctrl+Shift+W

Tip: To select a shape's text block if the text tool is selected or to toggle between text edit and shape 
selection mode, press F2.



Drawing tools
    Related Topics

Keyboard shortcuts for Visio's drawing tools are as follows:

To choose this tool: Press:

Arc Ctrl+7

Connection Point Ctrl+Shift+1

Connector Ctrl+3

Crop Ctrl+Shift+2

Ellipse Ctrl+9

Line Ctrl+6

Pencil Ctrl+4

Pointer Ctrl+1

Rectangle Ctrl+8

Rotation Ctrl+Ø

Spline Ctrl+5

Stamp Ctrl+Shift+3

Text Ctrl+2

Text Block Ctrl+Shift+4



Hyperlink navigation
    Related Topics

After you add navigational links (jumps) to shapes or pages, use these keyboard shortcuts to navigate 
between Visio and the jump destination's program. 

Forward Alt+Right Arrow

Back Alt+Left Arrow

Next Page Ctrl+Page Down

Previous Page Ctrl+Page Up

Special characters
    Related Topics

Use these key combinations to type commonly used special characters in text:

To type: Press:

Beginning single-quote Ctrl+[

Ending single-quote Ctrl+]

Beginning double-quote Ctrl+Shift+[

Ending double-quote Ctrl+Shift+]

Bullet Ctrl+Shift+8

En dash Ctrl+=

Em dash Ctrl+Shift+=

Discretionary hyphen Ctrl+hyphen

Non-breaking hyphen Ctrl+Shift+hyphen

Non-breaking slash Ctrl+Shift+/

Non-breaking backslash Ctrl+Shift+\

Section marker Ctrl+Shift+6

Paragraph marker Ctrl+Shift+7

Copyright symbol Ctrl+Shift+C

Registered trademark Ctrl+Shift+R



ANSI extended characters
    Related Topics

You can type characters from the ANSI extended character set by using the numeric keypad on the 
keyboard. To type ANSI characters, hold down the Alt key, then using the keys on the numeric keypad, 
type 0 and the ANSI code for the character you want.

The following table lists codes for extended characters from the ANSI character set:

Character ANSI code Character ANSI code

‚ 130 Ë 203

ƒ 131 Ì 204

„ 132 Í 205

… 133 Î 206

† 134 Ï 207

‡ 135 Ð 208

ˆ 136 Ñ 209

‰ 137 Ò 210

Š 138 Ó 211

‹ 139 Ô 212

Œ 140 Õ 213

· 149 Ö 214

¡ 161 × 215

¢ 162 Ø 216

£ 163 Ù 217

¤ 164 Ú 218

¥ 165 Û 219

¦ 166 Ü 220

§ 167 Ý 221

¨ 168 Þ 222

© 169 ß 223

ª 170 à 224

« 171 á 225

¬ 172 â 226

173 ã 227

® 174 ä 228

¯ 175 å 229

° 176 æ 230

± 177 ç 231



² 178 è 232

³ 179 é 233

' 180 ê 234

µ 181 ë 235

¶ 182 ì 236

¸ 184 í 237

¹ 185 î 238

º 186 ï 239

» 187 ð 240

¼ 188 ñ 241

½ 189 ò 242

¾ 190 ó 243

¿ 191 ô 244

À 192 õ 245

Á 193 ö 246

Â 194 ÷ 247

Ã 195 ø 248

Ä 196 ù 249

Å 197 ú 250

Æ 198 û 251

Ç 199 ü 252

È 200 ý 253

É 201 þ 254

Ê 202 ÿ 255





Toolbars
    Related Topics

The toolbars provide buttons and tools you can use as shortcuts for choosing menu commands. 

To display a tip about a specific button, pause with the pointer over the button. To display more detailed 
help about a specific button, click the Help button, and then click the toolbar button.



Status Bar

The status bar displays information about shapes and a status prompt. When you select a shape, the 
status bar displays its dimensions. When you pause the pointer over a shape on the stencil, the status bar
displays a description about the shape.

For additional information about how to use a shape, right-click a shape (on the drawing page or a 
stencil), then choose Shape Help from the shortcut menu.



Scroll bars
    Related Topics

Use scroll bars to scroll through a large drawing or to display more shapes in a stencil. The box on the 
scroll bars tells you where you are in the drawing.



Drawing page
    Related Topics

You create a drawing on the drawing page, which is contained in the drawing window. The drawing page 
is surrounded by a blue background called the pasteboard. The drawing page can display a grid, which 
consists of grid lines like those on traditional quadrille paper.

The drawing page title bar is located at the top of the drawing window. The title bar lists the page name 
and number. If you maximize the drawing window, the page name and number are displayed in the Visio 
main window.

Tip: If you need help with a particular template, you can learn more from Template help. Template help 
tells you how best to use Visio shapes, wizards, and other tools to create a particular type of drawing. It 
also points you to sources where you can find more information about the drawing type.



Rulers
    Related Topics

The rulers show measurements at the scale of the drawing. You can also use the rulers as a source for 
guides and guide points.



Stencil
    Related Topics

Stencils contain master shapes. You create drawings in Visio by dragging shapes from a stencil and 
dropping them onto the drawing page.

Many of the master shapes in Visio stencils are SmartShapes symbols. These shapes are designed to act
the way you need them to in a particular context.

SmartShapes symbols

When you start a new drawing based on a template, by default, stencils open as read-only and docked 
within the drawing window. You can also undock a stencil, to view it in its own floating window.

You can open stencils separately, so that you can create drawings that include shapes from any 
stencil¾not only the stencils that open with a template. To open a stencil separately, from the File menu, 
choose Stencils, then choose Open Stencil. In the Open Stencil dialog box, open the folder that contains 
the stencil you want. Select the stencil, then click Open. The stencil opens docked, and other open 
stencils' title bars cascade behind it.

To close a docked stencil, right-click the stencil title bar, then choose Close from the menu.

To find out how to use a shape on a stencil, right-click it, then choose Shape Help from the shortcut menu.

If you open a copy or original stencil, Visio opens it in a floating stencil window.

Tip: If you need help with a particular template, you can learn more from Template help. Template help 
tells you how best to use Visio shapes, wizards, and other tools to create a particular type of drawing. It 
also points you to sources where you can find more information about the drawing type.



Visio title bar
    Related Topics

The title bar has standard features, such as the Close button  and the Minimize/Maximize button, at the 
upper-right corner.

When a drawing window is maximized, the title of the open drawing appears on the Visio title bar.



Pasteboard
    Related Topics

The pasteboard is the blue background located behind a drawing page in the drawing window. You can 
use the pasteboard to store shapes. When you print a drawing shapes on the pasteboard do not print. 
Each page has its own pasteboard.



Text block
    Related Topics

The box with a dashed line and a flashing I-beam cursor indicates the shape's text block is open. To close
the text block, choose the pointer tool, or press the Esc key.

You can add text to any shape (including lines and connectors). To add text to a shape, select the shape 
and type. If the shape contains text, the existing text is replaced by the text you type.

You can also select, edit, copy, and paste text from one shape to another, check the spelling of text, and 
search for and replace text much as you do with many word-processing programs. 



Visio Workspace
    Related Topics

When you have no drawings open, the Visio workspace appears as a gray area.





The Visio main window
    Related Topics

When you start Visio, it displays the Choose A Drawing Template dialog box (similar to the New Drawing 
dialog box), in which you can choose options to create a new blank drawing or one based on a template, 
create a stencil file, or open an existing file. If you choose to create a drawing based on a template, the 
drawing window contains a stencil and a drawing page.

Menu bar and toolbars
The menu bar contains menus of commands that you can use to create and change drawings. The 
toolbars contain buttons that set and change Visio options and tools you can use to create and format 
shapes and text.

The toolbars and menu bar vary depending on the currently active window (drawing, ShapeSheet, stencil,
edit icon, or print preview). In addition, the toolbars can vary depending on the display resolution of your 
monitor, which tools you are using, and the size of the main window.

Tips
A tip appears when you pause with the pointer over items on the toolbars, status bar, control handles on a
shape, or master shapes on a stencil window when the stencil is set to display icons only.

You can turn the display of ScreenTips on and off by choosing View > Toolbars > Toolbars.

Status bar
The status bar at the bottom of the main window displays a status prompt. When the pointer is over the 
stencil window or when a menu is open, the status bar suggests possible actions that you can perform in 
Visio and displays information about what you are doing. Check the status bar frequently for helpful 
messages, such as information about a shape's position and angle.

Standard Windows features
The Visio main window has standard features, such as the Close button  and the Minimize/Maximize 
button, in the upper-right corner. You can also use scroll bars to scroll through a large drawing in the 
drawing window. For details about these and other standard Windows features, see your Windows 
documentation.



Drawing window
    Related Topics

You create a drawing in the drawing window. The drawing window displays a single drawing page on a 
blue background called the pasteboard. 

Drawing tools
You create a drawing by dragging and dropping master shapes from stencils or by using the drawing tools
on the toolbars to create your own shapes.

Toolbars
You can format text and graphics quickly by using tools on Visio's toolbars. The content of the toolbars 
varies depending on whether a drawing or stencil window is active, the display resolution of your monitor, 
which tools you use, and the size of the main window.

Rulers and grids
The drawing window has rulers that show measurements at the scale of the drawing. You can also use 
the rulers as a source for guides and guide points. The drawing page displays the grid like those on 
traditional quadrille paper.

You can turn the display of rulers and the grid on and off with the Rulers and Grid commands on the View 
menu. Intervals on the grid correspond to the unit of measure you set with the Options command on the 
Tools menu. You control the size of the intervals using the Ruler & Grid command on the Tools menu. 



Stencil window
    Related Topics

The stencil looks much like a traditional stencil. Master shape icons¾small representations of master 
shapes that you drag and drop into the drawing¾are displayed in rows on the stencil's characteristic 
green background. When you base a drawing on a template, stencil windows open alongside the drawing 
page. By default, stencils open as read-only and docked. You can view stencils as docked (on the right or 
left side of the drawing window) or as floating.

Opening additional stencils
When you want to include shapes from several different stencils in your drawing, you can open those 
stencils separately. To open a stencil separately, choose File > Stencil >    Open Stencil. In the Open 
Stencil dialog box, navigate to the folder that contains the stencil you want. Select the stencil, then click 
Open. The stencil opens docked, and other open stencils' title bars cascade behind it.

Modifying stencils
If you want to modify master shapes, you need to open a copy or original stencil. To open an original 
stencil, choose File > Stencil > Open Stencil. In the Open Stencil dialog box, choose Original in the Open 
section. To open a copy, choose Copy in the Open section. When you open an original or a copy of a 
stencil file and activate the stencil window, menu commands for the stencil window are available.

Closing stencils
To close a stencil, right-click the stencil title bar, then choose Close from the menu.

Master shapes and icons
To find out how to use a shape that comes with Visio, right-click it (on the drawing page or stencil), then 
choose Shape Help from the shortcut menu.

Master shape icons can provide clues about how to use the shape. A yellow background identifies a 
connector¾a 1-D shape that is designed for connecting two 2-D shapes.

Menu commands
View menu

Icons And Names
Icons Only
Names Only
Arrange Icons
Auto Arrange

Master menu

New Master
Edit Master
Properties
Edit Icon
Update Icon

Window menu

Show Drawing Page



ShapeSheet window
    Related Topics

When you select a shape or an object from another application and choose Show ShapeSheet from the 
Window menu, Visio opens the ShapeSheet window.

When the ShapeSheet window is active, menus display commands for programming shape behavior and 
controlling formulas that the ShapeSheet displays.

What you see in the ShapeSheet window depends on the shape itself and what you have set to display. 
When a ShapeSheet cell is selected, a formula bar appears, which you use to enter and edit ShapeSheet 
formulas.

ShapeSheet formula bar

A    Enter box. Accepts changes you make to a formula.

B    Cancel box. Cancels changes you make to a formula.

C    Formula bar. Visio displays formulas in the formula bar. To change a formula, click a cell and type.

Every shape you draw with Visio and object you insert from another application has a ShapeSheet. When
you create a group, Visio retains the ShapeSheet for each shape or object in the group and creates a 
separate ShapeSheet for the group. In the ShapeSheet you can change Visio's default formulas and set 
other properties to control the way the shape or object behaves.

Menu commands
Edit menu

Delete Section
Delete Row
Change Row Type
Action

View menu

Values
Formulas
Sections

Insert menu

Section
Row
Row After
Name
Function

Shape menu

Custom Properties



Edit icon window
    Related Topics

When a stencil window is active, and you choose Edit Icon from the Master menu, Visio opens a window 
in which you can edit the icon for the master shape selected in the stencil window. The window's title bar 
identifies the stencil and master shape.

Icon bitmaps
The window displays the master shape icon as a bitmap that you can edit pixel by pixel. As you edit the 
icon, changes appear in the stencil window. When you finish editing the icon, click  to close the window.

Window details and tools
The edit icon window displays the solid colors defined in Visio's default color palette plus the stencil 
background color. (The stencil background color is green unless you change it in the VISIO.INI file.) To edit 
an icon, use these tools:

Left Color box
Right Color box
Icon pencil tool
Paint bucket tool
Lasso tool
Selection net tool



Group window
    Related Topics

When you select a group and choose the Open Group command from the Edit menu, Visio displays the 
group in the group window. The group is displayed as if it were an entire drawing of independent shapes. 
The shapes appear without rotation applied to the group so you can use the grid, guides, and rulers.

You can select and edit the shapes individually by using the same menus and tools as in the drawing 
window. Changes you make in the group window appear in the drawing window.

To readjust the width and height of the group so its selection rectangle contains all the group's shapes, 
choose Update Alignment Box from the Tools menu.



Print preview window
    Related Topics

When you choose Print Preview from the File menu, Visio displays the active drawing page in the print 
preview window. Visio displays the drawing within the margins you set in the Page Setup dialog box.

If the drawing size is larger than the page size, the drawing is tiled and page breaks are displayed at the 
tile borders. To view a single tile, click the tile you want to see.

You can use the First Tile, Previous Tile, Next Tile, and Last Tile commands to move from tile to tile or 
page to page.

To exit the print preview window, click the Close button or press the Esc key.

Toolbars
When the print preview window is active, the toolbar displays buttons you can use to change the display 
of the window.

For details about the toolbar buttons and tools, pause with the pointer over a button to display a tip. 

Or, click the Help button on the toolbar, then click the toolbar button you want.

Help button

Menu commands
View menu

Single Tile
Zoom In
Zoom Out
Previous Tile
Next Tile



Visual Basic Editor window
    Related Topics

In the Visual Basic Editor you can use Visual Basic for Applications (VBA) to create a new macro, or 
debug or edit an existing one. 

Macros you create with VBA use Automation to control Visio. This can help you determine how to 
customize Visio to fit the needs of your organization. You can use Automation to drag and drop shapes, 
link information between Visio and another application, or automate a complex process to make it 
available to a wider scope of users.



Welcome to Visio Online Help

Visio Help Contents
Overview information and step-by-step 
procedures; commands and tools, 
keyboard shortcuts, and ShapeSheet 
reference.

Using Templates to Create Drawings
Helps you create specific drawing types 
using Visio templates.

Automation Reference
Objects, properties, methods, and events 
Automation Reference.

Service and Support
Customer service and technical support 
information.

Using Visio Help
    Related Topics

To display the Contents for the Visio online help, click the Contents button. For additional instructions on 
how to use Windows help, press F1 while the Help window is active. 

For information about accessing help on specific shapes, see Getting help on shapes. 

For help creating specific drawing types, see Using templates to create drawings.

Help windows
· Visio 5.0 Online Help displays overviews and command, toolbar, and dialog box reference 

information. Reference information appears in a window designed to stay on top of the Visio window, 
so you can read about any dialog box you have open.

· Step-by-step procedures displays procedures in a window designed to stay on top of the Visio 
window, so you can follow the numbered steps while working in Visio.

· Glossary includes a list of terms that display a definition when clicked. The glossary terms also appear
throughout Visio help.

Tips
When you pause the pointer (without the mouse button pressed) over an item on the toolbars, a control 
handle, or a master shape icon (when the stencil window is set to display icons only), a tip appears.

Shapes with control handles have control handle help: select the shape, then place the pointer over the 
control handles to display the handle's tips.

To turn off tips, choose View > Toolbars > Toolbars, then uncheck the Show ScreenTips option.

Searching
To search for a particular term:



· In the help Contents tab, click the Index tab and follow the instructions.

Scrolling
Some help topics contain more information than can fit in the help window at one time. To see more 
information, scroll through the topic in the help window.

To scroll in the help window:

· Press the Up Arrow () or Down Arrow (¯) key

or

· Use the scroll bars with the mouse.

To return to the previous topic:

· Click the Back button or press the B key.

To browse through topics:

· Click the << and >> buttons or press the < and > keys.

Exiting help
To close the help window:

· From the help window's File menu (not Visio's), choose Exit.

Context-sensitive help
While working in Visio, you can access help for menu commands, dialog boxes, toolbar buttons, and 
other screen elements.

To display help for a toolbar button or other screen element:

1. Choose the Help button on the toolbar and click anywhere on the screen.

Help button

To display help for a menu command:

1. Highlight the menu command using the keyboard. Press the Alt key followed by the underlined letter in 
the menu name, and then press the arrow keys to highlight the command.

2. Press F1.

To display help for a dialog box:

1. Choose a menu command that opens a dialog box.

2. Press F1 or click the Help button.



Getting help on shapes
    Related Topics

You can quickly find out what a shape does and how you can use it.

To get help on shapes:

1. Right-click the shape (on the stencil or on the drawing page).

2. Choose Shape Help from the shortcut menu.

A popup window appears containing information about the shape.

3. To close Shape Help, click away from the popup window.

4. To print or copy the information, right-click inside the popup window, then choose Copy or Print Topic 
from the shortcut menu.

Tip: Shapes with control handles have control handle help: select the shape, then place the pointer over 
the control handles to display the handle's tips.



Getting help on templates
    Related Topics

Each template has help explaining the most efficient way to draw, the best way to use and combine 
shapes, how to perform specific actions using shape and page right-mouse menus, how and when to 
access wizards that automate tasks, and more.

For help creating specific drawing types, see Using templates to create drawings.

To get help for a particular template:

· Press F1, click Index, then type the name of the template, or choose Template Help from the Visio Help
menu, then choose the type and name of the template you want.



Arranging Visio windows
    Related Topics

By default, the Visio main window usually contains a drawing page and one or more stencils. You can 
undock stencils to make them float. 

If you have more than one drawing open, you can arrange and resize the windows to see them all.

To arrange windows so each window is visible:

· Choose Window > Tile.

To arrange windows to see the title bar of each window:

· Choose Window > Cascade.

To size a window:

· Drag a window border.

Tip: For details about other ways to arrange windows, see your Windows documentation.



Checking drawings for macro viruses

A macro virus is a type of computer virus that's stored in the macros within a file. 

When you open a file, by default, Visio does not check it for VBA macros (macros you created in Visio 
with Microsoft Visual Basic for Applications) that may have viruses. However, you can choose to have 
Visio display a warning message when you open a file that contains macros. You can then decide 
whether to open the file with or without its macros enabled.

To turn on Visio macro checking:

1. Choose Tools > Options.

2. In the Options dialog box, under General, check Macro Virus Protection, then click OK.

Note: If you frequently receive Visio files as attachments to e-mail messages or from a network or 
Internet site that isn't secure, it's a good idea to have Visio check files for macros that may have 
viruses.

If you disable a file's macros, you won't be able to run any macros or add-ons, use ActiveX controls to 
initiate events, or run event handlers¾for example a macro that runs when you double-click a particular 
shape. You can still open the Visual Basic Editor to view and edit the file's macros. If you want to run the 
macros, close the file, then open it with macros enabled.



Microsoft Office 97 Compatible
    Related Topics

Visio is a Microsoft Office 97 Compatible product, which means that its toolbars, menus, and accelerator 
keys are similar to those used by Microsoft Office. If you are already using Microsoft Office or an Office 97
compatible product, which includes Microsoft Excel, Word, Access, and PowerPoint, then many of the 
tasks you have learned to complete in Office can be completed in a similar manner in Visio. Visio and 
Microsoft hope these similarities will make it easier for you to use our products together and with other 
Microsoft Office 97 Compatible products.

Look for the Microsoft Office 97 Compatible logo when purchasing software. For more information about 
the Microsoft Office 97 Compatible program, and for a complete listing of Microsoft Office 97 Compatible 
products, please see the Office Compatible Web site at http://www.microsoft.com/office/compatible, or, in 
the United States, call Microsoft Customer Service at 1-800-426-9400. Customers outside the United 
States should contact their local Microsoft office.

Visio and Office Compatible Features

· Improved formatting toolbar buttons 

Line, Fill, and Text formatting buttons on the toolbar now provide pop-up palettes, similar to those in 
Excel, from which you can select the formatting you want.

· Routing drawings through email    

You can add a routing slip to a drawing that you send via email, or you can save a drawing directly to 
an Exchange folder.

· Recording activities in the Outlook Journal    

In Journal, you can automatically record time you spend using Visio.

· Using the menus

The Visio menus, commands, and dialog boxes are designed to look and feel like Microsoft Office 
programs, so you can quickly be up and running with Visio.

· Using the keyboard shortcuts

The Visio keyboard shortcuts are designed to match Microsoft Office programs. For example, to cut a 
shape to the Windows Clipboard, press Ctrl+X; to copy it, press Ctrl+C; and to paste it, press Ctrl+V.

· Using wizards

Visio includes many wizards that automate your tasks. For example, the Organization Chart Wizard 
automates creating an organization chart; you can base your organization chart on an existing 
spreadsheet or text file, or you can enter your data directly into the Organization Chart Wizard.

· Checking the spelling of text

To ensure a professional diagram, check the spelling of text in your drawings. (Choose Tools > 
Spelling.) Use your Microsoft Office spell checker in Visio.

· Finding and replacing text

Make global changes to your diagram by finding and replacing text in your drawings. (Choose Edit > 
Find or Edit > Replace.)

Using Visio with Microsoft Office

· Cutting, copying, and pasting Visio into other programs

You can easily cut, copy, and paste your diagram from one program to another using the Cut, Copy, 
and Paste commands on the Edit menu.



· Using the Microsoft Office Binder program

In Microsoft Office 97, you can create a file that combines pages from multiple programs. For example,
a single file can include pages from Microsoft Word, Visio, and Microsoft Excel.

· Sending Visio files through electronic mail

Within Visio, you can send your drawing through email by using the Send To command on the File 
menu. Visio supports Outlook, Exchange, and any other mail system that is compatible with the 
Messaging Application Programming Interface (MAPI).

· Object linking and embedding (OLE)

You can use object linking and embedding (OLE) to include a Visio diagram in another program, such 
as Microsoft Word, and to include objects from other programs in your Visio file.



Visio Corporation License Agreement

THIS VISIO CORPORATION LICENSE AGREEMENT (“LICENSE AGREEMENT”) IS A LEGAL 
AGREEMENT BETWEEN YOU AND VISIO CORPORATION, INCLUDING ITS SUBSIDIARY VISIO 
INTERNATIONAL LIMITED (TOGETHER, “VISIO CORPORATION”), FOR THE SOFTWARE PRODUCT. BY
USING THE SOFTWARE PRODUCT, YOU ARE AGREEING UNCONDITIONALLY TO BE BOUND BY THE 
TERMS OF THIS LICENSE AGREEMENT, EVEN IF THIS LICENSE AGREEMENT IS DEEMED A 
MODIFICATION OF ANY PREVIOUS ARRANGEMENT OR CONTRACT.    IF YOU DO NOT AGREE TO 
THE TERMS OF THIS LICENSE AGREEMENT, DO NOT USE THE SOFTWARE PRODUCT.    INSTEAD, 
YOU MAY RETURN THE SOFTWARE PRODUCT TO THE PLACE YOU OBTAINED IT FOR A FULL 
REFUND (IF APPLICABLE).

Software Product License

The Software Product is protected by copyright laws and international copyright treaties, as well as other intellectual
property laws and treaties.    The Software Product is licensed, not sold.

For purposes of this License Agreement, “Software Product” refers to the computer software and associated media, 
printed materials, and “online” or electronic documentation, including without limitation any and all executable 
files, add-ons, stencils, templates, SmartShapes® symbols, filters, tutorials, help files and other files, that 
accompany the Visio Corporation product identified above, herein or in the accompanying documentation; “Use” 
means storing, loading (whether into temporary memory (i.e., RAM) or into permanent memory (e.g., hard disk, 
CD-ROM or other storage device)), installing, executing or displaying the Software Product; and “You” means the 
company, entity or individual whose funds are used to pay the license fee or who has otherwise acquired the 
Software Product.

1.    Grant of License

Software Product.    Visio Corporation grants You the non-exclusive, non-sublicensable, limited license to Use one 
copy of the Software Product on a single computer only for a period of thirty (30) days from the date of first Use by 
You, subject to the terms and conditions of this License Agreement.    

2.      Ownership

Title, ownership rights and intellectual property rights in and to the Software Product shall remain in Visio 
Corporation and its suppliers and are protected by US and international copyright laws and international copyright 
treaties, as well as other intellectual property laws and treaties.    The Software Product is licensed, not sold.    There 
is no transfer to You of any title to or ownership of the Software Product and the license granted under this License 
Agreement should not be construed as a sale of any right in the Software Product.    You must treat the Software 
Product like any other copyrighted materials (e.g., a book or musical recording) except that You may make one copy
of the Software Product solely for backup or archival purposes (with the inclusion of all copyright and other 
proprietary notices), only as long as You otherwise comply with the terms and conditions of this License Agreement.
You may not make additional copies of the Software Product.    You may not copy the printed materials 
accompanying the Software Product.    All rights not specifically granted under this License Agreement are reserved 
by Visio Corporation.

3.      Description of Other Rights and Limitations

Limitations on Reverse-Engineering, Decompilation and Disassembly; Other Restrictions.      You acknowledge that 
the Software Product in source code form remains a confidential trade secret of Visio Corporation and therefore You 
agree not to reverse-engineer, decompile or disassemble the Software Product, or make any attempt to discover the 
source code to the Software Product, except and only to the extent that such activity is expressly permitted by 
applicable law notwithstanding this limitation.    Except as expressly permitted in this License Agreement,    the 
Software Product may not be Used, copied, translated,    redistributed, retransmitted, published, sold, rented, leased, 



marketed, sublicensed, pledged, assigned, disposed of, encumbered, transferred, altered, modified or enhanced, 
whether in whole or in part, nor may You create derivative works from or based on the Software Product.    You may 
not remove any proprietary notices, marks or labels from the Software Product. 

Separation of Components.      The Software Product is licensed as a single product and its component parts may not 
be separated for Use on more than one computer.

Transfer of Software Product.      You may transfer all Your rights under this License Agreement on a permanent 
basis only, provided You retain no copies, You transfer the License Agreement, the corresponding serial number (if 
applicable) and all the Software Product (including without limitation all component parts, media and printed 
materials) and the recipient agrees to all the terms and conditions of this License Agreement. 

Termination.      This License Agreement is in effect until terminated.    You may terminate it at any time by 
destroying the Software Product and all copies You have made.    Unauthorized copying or duplication of the 
Software Product will result in automatic termination of this License Agreement.    Without prejudice to any other 
rights, Visio Corporation may terminate this License Agreement if You fail to comply with any term or condition of 
this License Agreement.    Upon termination of this License Agreement, You agree to destroy the Software Product 
and all copies You have made.

Support Services.      Visio Corporation may provide You with customer and technical support services related to the 
Software Product ("Support Services"). Use of Support Services is governed by the Visio Corporation policies and 
programs described in the user manual, in "online" or electronic documentation, and/or in other Visio Corporation-
provided materials. Any supplemental software code provided to You as part of the Support Services shall be 
considered part of the Software Product and subject to the terms and conditions of this License Agreement. With 
respect to any technical information You provide to Visio Corporation as part of the Support Services, Visio 
Corporation may use such information for its business purposes, including product support and development. Visio 
Corporation will not utilize such technical information in a manner that personally identifies You.

4.      Dual-Media Software

You may receive the Software Product in more than one medium; for example, in disk media, on a CD-ROM or in 
both media.    Regardless of the type or size of medium You receive, You may Use only one medium that is 
appropriate for Your computer.    You may not Use the other medium on another computer.    You may not distribute, 
transmit, sell, loan, rent, lease or otherwise transfer the other medium to another user, except as part of the 
permanent transfer of the Software Product pursuant to the terms and conditions of this License Agreement.

5.      Reports and Audit Rights

You shall institute reasonable measures to ensure compliance with the terms and conditions of this License 
Agreement.    Upon Visio Corporation’s reasonable request, You agree to provide reports relating to Your Use of the 
Software Product as necessary to demonstrate Your compliance with the terms and conditions of this License 
Agreement.    You further agree that Visio Corporation has the right, upon reasonable prior notice, to audit Your 
records and inspect Your facilities to verify Your compliance with the terms and conditions of this License 
Agreement.

6.      US Government Restricted Rights

The Software Product and documentation are provided with RESTRICTED RIGHTS.    Use, duplication or 
disclosure by the US Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of The Rights in 
Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) of the 
Commercial Computer Software-Restricted Rights at 48 CFR 52.227-19, as applicable.    The 
contractor/manufacturer is Visio Corporation, 520 Pike Street, Suite 1800, Seattle, WA    98101-4001, USA.

7.      Export Restrictions 

You may not export or reexport the Software Product or any underlying information or technology except in full 



compliance with all United States and other applicable laws and regulations.    In particular, but without limitation, 
none of the Software Product or underlying information or technology may be exported or reexported (a) into (or to 
a national or resident of) Cuba, Haiti, Iran, Iraq, Libya, Serbia, Montenegro, North Korea, Sudan or Syria or (b) to 
anyone on the US Treasury Department's list of Specially Designated Nationals or the US Commerce Department's 
Table of Deny Orders, as such countries, lists and orders may be amended or modified from time to time.    By Using
the Software Product, You are specifically agreeing to the foregoing and You are representing and warranting that 
You are not located in, under the control of, or a national or resident of any such country or on any such list.

8.      Entire Agreement; Governing Law

This License Agreement constitutes the entire agreement between Visio Corporation and You with regard to the 
subject matter hereof and supersedes any and all prior agreements, understandings and representations, whether 
written or oral, concerning the subject matter of this License Agreement.    This License Agreement shall not be 
modify except by a written agreement executed by a duly authorized representative of each of Visio Corporation and
You.

Nothing in this License Agreement is intended to exclude, modify or restrict    the operation of any applicable statute
or other law, the provisions of which cannot lawfully be excluded, modified or restricted.    If any court of competent
jurisdiction determines that a provision of this License Agreement is illegal, invalid or unenforceable in any 
jurisdiction, then such provision shall be deemed modified to the minimum extent necessary to make it comply with 
the applicable statute or law of such jurisdiction, and the remaining provisions of this License Agreement shall 
continue in full force and effect.    Any such modification shall not effect any provisions of this License Agreement 
in any other jurisdiction where this License Agreement governs the Use of the Software Product.

If You acquired the Software Product in Canada, You agree to the following:    Each of Visio Corporation and You 
hereby confirm, desire and agree that this License Agreement has been and shall be written solely in the English 
Language.

IF YOU ACQUIRED THE SOFTWARE PRODUCT IN THE UNITED STATES, THIS LICENSE AGREEMENT 
IS GOVERNED BY THE LAWS OF THE STATE OF WASHINGTON, USA, EXCEPT FOR THAT BODY OF 
LAW DEALING WITH CONFLICTS OF LAW, WITHOUT REFERENCE TO THE 1980 UNITED NATIONS 
CONVENTION ON THE INTERNATIONAL SALE OF GOODS.

IF YOU ACQUIRED THE SOFTWARE PRODUCT OUTSIDE THE UNITED STATES, THIS LICENSE 
AGREEMENT IS GOVERNED BY THE LAWS OF THE REPUBLIC OF IRELAND.

No Warranty

No Warranties.      TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, VISIO 
CORPORATION AND ITS SUPPLIERS EXPRESSLY DISCLAIM ANY AND ALL WARRANTIES AND 
CONDITIONS, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, IMPLIED 
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, AND NON-
INFRINGEMENT, AND THOSE ARISING OUT OF USAGE OF TRADE OR COURSE OF DEALING, 
CONCERNING THE SOFTWARE PRODUCT, AND THE PROVISION OF OR FAILURE TO PROVIDE 
SUPPORT SERVICES.    NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN BY VISIO 
CORPORATION, ITS AGENTS, DEALERS, DISTRIBUTORS OR EMPLOYEES SHALL CREATE ANY 
WARRANTIES.    THE SOFTWARE PRODUCT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY 
KIND.    THE ENTIRE RISK ARISING OUT OF USE OR PERFORMANCE OF THE SOFTWARE PRODUCT 
REMAINS WITH YOU.    Some jurisdictions do not allow limitations on duration of an implied warranty, so the 
above limitation may not apply to You.

No Liability for Damages.      REGARDLESS OF WHETHER ANY REMEDY SET FORTH HEREIN FAILS OF 
ITS ESSENTIAL PURPOSE, TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO 
EVENT SHALL VISIO CORPORATION OR ITS SUPPLIERS (OR THEIR RESPECTIVE AGENTS, 
DIRECTORS, EMPLOYEES OR REPRESENTATIVES) BE LIABLE FOR ANY DAMAGES WHATSOEVER    
(INCLUDING, WITHOUT LIMITATION, CONSEQUENTIAL, INCIDENTAL, DIRECT, INDIRECT, SPECIAL, 



ECONOMIC, PUNITIVE OR SIMILAR DAMAGES, OR DAMAGES FOR LOSS OF BUSINESS PROFITS, 
LOSS OF GOODWILL, BUSINESS INTERRUPTION, COMPUTER FAILURE OR MALFUNCTION, LOSS OF 
BUSINESS INFORMATION OR ANY AND ALL OTHER COMMERCIAL OR PECUNIARY DAMAGES OR 
LOSSES) ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE PRODUCT OR THE 
PROVISION OF OR FAILURE TO PROVIDE SUPPORT SERVICES, HOWEVER CAUSED AND ON ANY 
LEGAL THEORY OF LIABILITY (WHETHER IN TORT, CONTRACT OR OTHERWISE), EVEN IF VISIO 
CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM 
BY ANY OTHER PARTY. In any event, if any statute implies warranties or conditions not stated in this License 
Agreement, Visio Corporation’s entire liability under any provision of this License Agreement shall be limited to 
Five United States Dollars (US$5.00).    Because some jurisdictions do not allow the exclusion or limitation of 
liability for consequential or incidental damages, the above limitation may not apply to You.

Copyright © 1997 Visio Corporation.
All Rights Reserved.

Visio Corporation
520 Pike Street, Suite 1800
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USA

Visio International Limited
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Dublin 2
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About creating and saving drawings
    Related Topics

In general, here are the steps you take in Visio to create a drawing:

1. Start a drawing by opening a template. 

A template sets up your drawing page and opens stencils that contain master shapes.

Open a template.

2. Add shapes to your new drawing by dragging them from a stencil to the drawing page or by drawing 
your own.

You can create additional shapes with the Visio drawing tools on the Standard toolbar, and open 
additional stencils to choose from a wider variety of shapes.

Add shapes.

3. Arrange shapes to create the drawing you want. 

Onscreen, the grid helps you align shapes, and the rulers give you precise control. You can place 
guides and use the Align and Distribute commands for quick alignment, or use the Size & Position 
command to enter exact coordinates and dimensions.

Arrange shapes.

4. Glue shapes together, so they stay connected when you move them. 

With glue, you can update your diagrams quickly, without selecting and dragging every line. 



Glue shapes together.

5. Add text to your drawing.

You can add text to a shape by clicking a shape with the pointer tool, then typing. Or use the text tool 
to type anywhere on a drawing. 

6. Modify the look of shapes.

Formatting shapes is quick with the tools and style lists on the toolbars and the commands on the 
Format menu. You can define your own styles in addition to the ones that come with the product. 

7. Get your drawing to your audience. 

Your drawing can stand on its own or become part of a larger document, such as a Microsoft 
PowerPoint slide show, a Microsoft Word publication, or a page on a World Wide Web site. 



Displaying and hiding toolbars and windows
    How To
    Related Topics

In Visio, you can decide how you want to work by displaying only the toolbars you need and arranging 
your windows to see them all at once. 

Displaying and showing toolbars
The tools in Visio are grouped on toolbars based on the type of task you perform with them. For example, 
the Shape toolbar contains tools such as the fill color and align shapes palettes, which you can use to 
format and arrange shapes. The View toolbar contains tools you can use to choose what you want to see 
onscreen.

The following toolbars are available in Visio:

Standard    Primary tools for dragging, dropping, and drawing shapes, as well as standard Windows-
program tools for opening, closing, saving, and printing files.

Text    Style lists for text along with tools for choosing format, alignment, size, color, and bullets.

Shape    Style lists for lines and fills along with tools for shadows, layout, grouping, stacking order, and 
rotation.

View    Buttons for showing or hiding the grid, guides, connection points, and displaying particular layers 
or layer properties.

Page    Buttons for paging forward or back, displaying a particular page, and for turning snap and glue off 
and on.

Web    Tools for inserting hyperlinks, paging forward or back on the Web, opening Internet Explorer, and 
starting Shape Explorer. 

Developer    Tools for running macros, displaying the ShapeSheet spreadsheet, opening Visual Basic For 
Applications, and switching to design mode while working in VBA.

TIP    To see what a tool is for, pause the pointer over the tool on the toolbar. A tip appears that describes 
the tool. If no tip appears, choose View > Toolbars > Toolbars and make sure the Show ScreenTips option
is checked.



To show or hide toolbars:

1. Choose View > Toolbars > Toolbars.

2. Check the toolbars you want to view and uncheck those you don't, then click OK. 

TIP    You can also view and hide toolbars by choosing View > Toolbars or right-clicking the toolbar, then 
clicking to add or remove a checkmark next to the appropriate toolbar on the menu.

    Overview



Arranging windows
If you have more than one window open, you can arrange and resize them to see them all.

To display windows side by side:

· Choose Window > Tile.

To arrange windows to see the title bar of each window:

· Choose Window > Cascade.

    Overview



Displaying, moving, and adding stencils
    Related Topics

When you start a new drawing by opening a template, Visio opens one or more task-related stencils. 
Stencils store master shapes, or "masters," that you can drag to the drawing page to add shapes to your 
drawing. If you need masters that don't appear on an open stencil, you can open additional stencils. By 
default, stencils are docked to the drawing-page window, but you can display stencils as either docked or 
floating. Unlike a docked stencil, you can drag a floating stencil to a different location on the screen.

Methods for working with stencils
To Do This

Switch between 
stencils

Click the name of the stencil to 
switch to that stencil. This 
applies to stencils that are 
docked.

Open additional 
stencils

Choose File > Stencils > Open 
Stencil, choose the stencil you 
want, then click OK.

Close a stencil Right-click the stencil's title bar, 
then choose Close from the 
shortcut menu.

Make a stencil 
float

Click inside the stencil where 
there are no buttons or icons, 
then drag the stencil away from 
its docked position. Or right-
click the stencil's title bar, then 
choose Float from the shortcut 
menu.

Dock a stencil Click inside the stencil where 
there are no buttons or icons, 
then drag the stencil to the left 
or right side of the drawing 
window. Release the mouse 
button when an outline of the 
stencil appears.

Minimize a 
floating stencil

Click the minimize button on the
stencil's title bar. To expand the 
stencil again, click the maximize
button on the stencil's title bar.

Move a docked 
stencil from one 
side of the 
drawing window 
to another

Right-click the stencil's title bar, 
then choose Switch Sides from 
the shortcut menu.

Change how 
masters display 
on a stencil

Right-click the stencil, then 
choose Icons And Names to 
display both master shape icons
and names, Icons Only to 
display only master shape 
icons, or Names Only to display



only the master shape names.

Change the order
of masters on a 
stencil

Open the original stencil and 
drag each master shape icon to 
arrange them in the order you 
want.



Basing new drawings on templates
    How To
    Related Topics

You can quickly create the type of drawing you want when you start with a Visio template (*.vst) file. A 
template includes everything you need to create a drawing, from the drawing page to shapes and styles. 
Using a template ensures consistency across your drawing files, so you can focus on what goes on the 
page while the template takes care of the rest.

When you start a drawing with a template, a Visio file opens that contains the following:

· One or more stencils containing related shapes.

· A blank drawing page using a grid and measurement system that's appropriate for the type of drawing 
you're creating, saving you the time it takes to set up pages.

· A drawing page set up with the correct scale and page size. This applies to scaled drawing types.

· Styles for text, lines, and fills appropriate to the type of drawing you're creating, saving you the time it 
takes to define your own styles.

NOTE    Each template comes with help explaining the most efficient way to use and combine shapes, 
how to perform specific actions using shape and page right-click menus, how and when to run wizards 
that automate tasks, and more. To display template help, choose Help > Template Help > Visio Templates,
then choose the appropriate template.

If the drawings you usually create require settings not available in any Visio template, you can open a 
drawing with no template, revise an existing template, or create one of your own. 



To start Visio and open a new drawing file based on a template:

1. Start Visio by clicking Start, then choosing Programs > Visio.

2. Double-click to open the folder that contains the type of drawing you want to create, choose a 
template, then click OK.

To open a new drawing file without basing it on a template:

· Choose File > New > Drawing. An unscaled drawing page opens with no stencils.

To display help for a particular template:

· Press F1, click the Index tab, then type the name of the template, or choose Help > Template Help, 
double-click Visio Templates, then choose the type and name of the template you want.

    Overview



Adding shapes to drawings
    How To
    Related Topics

The easiest way to create a drawing is to drag master shapes (or "masters") from a stencil to the drawing 
page. When you drop a master on a drawing page, you create an "instance" of the master. The master 
itself remains on the stencil so you can use it again and again to create instances.

When you drop an instance, Visio snaps the shape to the nearest grid line or ruler subdivision so that you 
can position it precisely. To place shapes even more accurately, you can zoom in or out from the drawing 
page. You can also change what you snap to by choosing Tools > Snap & Glue.

If you want to create multiple instances of a master quickly, you can use the stamp tool.

Dragging and dropping to create a drawing is accurate and fast when you use the grid and rulers to position shapes.

To place the shape more precisely, pause while dragging to see the shape instead of the box or line representing it. 
The pointer turns white when it's over an object that you can drag.



To drag and drop a shape:

1. Choose the pointer tool ( ) from the Standard toolbar.

2. In the stencil, point to a master.
3. Hold down the left mouse button and drag the master from the stencil to the drawing page.
4. Release the mouse button to drop an instance of the master in the drawing.

    Overview



To stamp multiple instances:

1. Choose the stamp tool ( ) from the Standard toolbar.

2. In the stencil, click a master.
3. In the drawing window, place the pointer where you want the shape. The stamp tool places the 
shape's pin where the pointer is. In most shapes, the pin is in the center of the shape, so you would place
the pointer where you want the center of the shape.
4. Click the left mouse button.

You can continue clicking the page to add as many instances of the stamped shape as you want.

5. When you're done stamping, press the Esc key.

    Overview



To delete a shape from the drawing page:

1. Select the shape.

2. Do one of the following:

Choose Edit > Clear.

Press the Delete key on the keyboard.

    Overview



To delete a shape from the drawing page and place a copy on the clipboard:

1. Select the shape.

2. Do one of the following:

Choose Edit > Cut.

Click the Cut button ( ) on the Standard toolbar.

    Overview



To display help for a particular shape:

· Right-click the shape, then choose Shape Help from the shortcut menu.

    Overview



Saving drawing files
    How To
    Related Topics

When you work on a drawing, you should save the drawing file frequently. When you change a stencil or 
template, you should also save these files. 

How you save a Visio drawing file (*.vsd) influences what happens when you next open it. You can 

· Enter file properties, such as title, author, keywords, and descriptions. When you save a file for the first 
time, Visio prompts you for this information. Then, when you select the file name in the Open dialog 
box, these description and preview properties appear to help you identify the file before opening it. You 
can view all of the properties by right-clicking the file in Windows, then choosing Properties.

· Save a preview of the first page or all of the pages of the drawing so that you can identify the file 
before you open it. In the Open dialog box in Visio, you see only the first page. In Windows 95 or 
Windows NT 4.0 Quick View (right-click a file in Windows, then choose Quick View), you can see all of 
the pages. Saving previews of all of the pages can increase the file size considerably.

· Save a drawing file as a template (*.vst) that you can use as a model for other drawings.

· Save a drawing file in Visio 4.x format. When you open a 5.0 file in an earlier version of Visio, 
information specific to Visio 5.0 products will be lost or converted.

· Save a file as read-only to prevent it from being inadvertently edited or changed. 

· Export a file in HTML, Windows Metafile, or another format.

· Save the workspace when you save a drawing file. When you next open the file, the stencil and 
drawing page windows will look just as they did when you saved the file. You can save a workspace as 
part of a drawing, stencil, or template, or as a separate file (*.vsw).

Saving a drawing file for the first time
The first time you save a drawing, Visio prompts you for document properties, including whether or not to 
save preview pictures, which are small thumbnails of drawing pages. Properties such as the description 
and the preview picture appear in the Open dialog box when you select the drawing file name.

TIP    You can change a file's properties later by choosing File > Properties. 



To save a drawing file for the first time:

1. From the File menu, choose Save or Save As.

2. For File Name, type a name for the drawing file.

3. Under Save In, open the folder in which you want to save the file.

4. Click Save.

5. Enter properties information, then click OK to close the Properties dialog box dialog box.

TIP    To quickly save changes to a file you've already saved, click the Save button on the Standard 
toolbar or press Ctrl+S. By default, Visio saves existing files in the format in which they were opened. To 
save in a different format, including earlier versions of Visio, use the Save As command.
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About working with pages
    Related Topics

You can work with multiple pages in a single Visio drawing file to present and organize your information. 
Using pages, you can

· Keep related drawings in the same file. For example, for an office expansion project, you could keep 
the pages that contain office layout drawings in one file and drawings of the distribution of office 
equipment in another.

· Keep all revisions of a single drawing in one file on successive pages, so that you can show the 
progression from the beginning of the project to the end.

· Present a series of drawings at full screen view and navigate between them, like a slide show.

· Link pages together like a Web site. For example, you could jump from a workflow diagram shape to a 
detailed procedure on another page.

· Place items on background pages that you want to appear on every page, such as a company logo.

· Rotate pages to make it easier to edit information that's at an angle, such as a room that isn't square, 
or a city plan with some streets that are not perpendicular.

As you work with drawing pages in a Visio drawing file, keep the following distinctions in mind: The page 
you see on the screen is called the "drawing page." You print the drawing on the "printed page," which is 
the paper in the printer. And the result of printing is the "printed drawing."

Most Visio templates are set up so that the drawing page, printed page, and printed drawing sizes are all 
the same, so you don't have to change any settings or sizes to get the printed drawing you expect.

In some cases, though, you may change drawing-page settings, such as size, orientation, or scale, as 
you create your drawing, in which case you'll want to verify that your printed-page settings work with the 
new drawing-page settings. 

If you print a drawing that is larger than the printed page, the drawing prints across multiple pages. This is called 
tiling. You can verify whether and where your drawing will break across pages by choosing View > Page Breaks. Gray
lines indicate the page breaks.

To avoid printing a large drawing across several tiled pages, you can:

· Change the drawing orientation to see if everything will fit.

· Choose to reduce the drawing by a percentage in the Print dialog box when you print, so that it fits on 
the current page size.

· Set a drawing scale that represents larger real-world dimensions in a smaller scaled space. 

· Choose a larger printed page size.



Changes you make to drawing-page settings aren't automatically reflected in printed-page settings. Before you print, 
make sure settings, such as orientation, are the same for both the drawing page and the printed page. For example, if
you change a drawing page's orientation to landscape (left) without changing the printed-page settings from the 
default portrait orientation, the drawing prints on a portrait page (right). 



Setting page orientation and scale
    How To
    Related Topics

When you start a drawing by opening a template, the template includes page settings for orientation and 
scale that affect how you work in a drawing and how it prints. Sometimes you may want to change these 
settings as you work in a drawing. 

TIP    Changes you make to drawing-page settings aren't automatically reflected in printed-page settings. 
If you change the drawing-page orientation or scale, check the printed-page settings in the Page Setup 
dialog box and change them if needed. 

Setting page orientation
You can set the orientation of the drawing page to portrait (tall) or landscape (wide) in the Page Setup 
dialog box.

Portrait specifies a tall orientation; Landscape is a wide orientation.

Setting a scale
When you are creating a drawing that represents real-world objects too large to fit at their actual size on a
piece of paper, or too small to depict, you must set a "drawing scale." The ratio of the shapes' dimensions 
as they appear onscreen (page units) to their real-world measurements (page units) defines the scale. 
For example, in an office plan, the drawing scale might be 1:10, where 1 inch onscreen represents 10 feet
in the real world.



To set drawing orientation and scale:

1. Display the drawing page you want to change, then choose File > Page Setup.

2. On the Page Size tab, select the orientation option you want. 

3. On the Drawing Scale tab, select the scale you want or enter a custom scale, then click OK.
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To set printed page orientation:

1. Display the drawing page you want to change, then choose File > Page Setup.

2. On the Page Size tab, click Print Setup.

3. Choose the orientation you want for the printed page, then click OK.
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Rotating and resizing pages
    How To
    Related Topics

You can rotate pages using the rotation tool and resize them using the pointer tool. 

Using the rotation tool, you can easily create drawings in which part of the drawing is at an angle to the 
rest and work in each part orthogonally, that is, at right angles or parallel to the rulers. For example, you 
can draw a building that isn't square or a city plan in which some of the streets run at an angle from the 
rest. Rotating, similar to zooming, is simply a way of viewing your page. It doesn't affect printing or the 
page orientation you select in the Page Setup dialog box. When you print, the page prints just as it would 
if it were not rotated. Resizing pages, on the other hand, does affect printing and the settings in the Page 
Setup dialog box. You can resize pages when you want to add space to or remove space from a drawing.

Rotating pages
When you rotate the page, existing shapes and guides rotate with it. However, the rulers and grid stay at 
their original angle. Page rotation is disabled by default in all versions of Visio except Visio Technical. You 
can enable page rotation in the Advanced tab of the Options dialog box.

        

        

Rotating the page and using rotated guides make it easy to create an angled section in a drawing. You can glue and 
align shapes to any guide.

        



When you move the rotation tool over a page corner, it becomes a round rotation pointer (A). The page's drop 
shadow (B) indicates that the page is unrotated. Rotated pages have no drop shadow. 

When you drag the round rotation cursor, the page rotates around the zero point (C), which is in the lower-left corner 
by default.

        

The origin of the rotation is the zero point of the rulers. To change the origin of rotation, move the zero point by 
Ctrl+dragging the crosshair from the intersection of the rulers to where you want the new zero point. 

After you move the zero point (D) the center of rotation changes for the page. Rotated pages have a gray non-printing
dot at the lower-left corner of the page (E). This dot indicates that the drawing is rotated so that you can tell the 
difference between a landscape page, for example, and a portrait page that has been rotated 90 degrees. When you 
rotate the page, the dot stays with that corner, so that if you rotated the page upside-down, the dot would then be at 
the upper-right corner of the page.



To enable page rotation:

1. Choose Tools > Options, then click the Advanced tab.

2. Check Enable Page Rotation, then click OK.
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To rotate a page:

1. Make sure that page rotation is enabled, then display the page you want to rotate.

2. Choose the rotation tool ( ) from the Standard toolbar.

3. Position the cursor over a corner of the page.
The cursor changes to a round rotation pointer ( ).

4. Drag the corner of the page to the rotation angle you want, then release the mouse button.

TIP    To quickly rotate an angled section of your drawing so that it's orthogonal, right click on an angled 
guide and choose View As Horizontal or View As Vertical.
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Resizing pages
Resizing pages enables you to add space to a page where you need it and to remove empty space you're
not going to use from a page, both without changing the drawing scale. There are two ways to resize 
pages:

· Use the Page Setup dialog box to add space to or remove space from the top and right sides of the 
drawing. For example, if you want more white space around a drawing on which a reviewer can write 
comments, you can increase the dimensions of the page to create a margin of space on those sides.

· Use the Ctrl key with the pointer tool to remove space from a particular side of the drawing. For 
example, if you set the page size to be 9 by 12 inches, but discover later that your drawing extends off 
the right side of the page, you can drag that side of the page out to give yourself more room to draw.

You can use Page Setup to remove an equal amount of space from the top and right sides of a page. 

Use the Ctrl key with the pointer tool to remove space from only the side you drag. In this example, the left side was 
dragged in to remove extra space.

When you resize a page using either method, the shapes on the page stay in their positions relative to the
rulers. In other words, the x, y coordinates of the shape remain the same.

When you print, the page prints starting in the top-left corner of the drawing page. Keep this in mind when
you resize a drawing page to be larger than the paper you print it on, causing the drawing to be tiled on 
several pages when you print.

NOTE    If the drawing page you resized has backgrounds assigned to it, you must resize each of the 
backgrounds individually if you want the page sizes to match.

To resize a page using Page Setup:

1. Choose File > Page Setup.

2. On the Page Size tab, type the page dimensions you want or select a page size option, such as Scale 
Page To Fit Drawing, then click OK.

To resize a page with the pointer tool:

1. Choose the pointer tool ( ) from the Standard toolbar.

2. Position the pointer at the edge of the page on the side you want to move, then hold down the 
Ctrl key. 

The cursor changes to a double-ended arrow.

3. Drag the page edge to where you want it, then release the mouse button.

The new page size is reflected in the Page Setup dialog box.

To set the printed page size:

1. Display the drawing page you want to change.

2. Choose File > Page Setup, then on the Page Size tab, click Print Setup.

3. Choose the size you want for the printed page.



The display at the top of the dialog box shows the effect of your choices.

4. Click OK.
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Creating multiple-page drawings
    How To
    Related Topics

For some drawing projects, you may want to create a single drawing file that contains many drawing 
pages. For example, a file could represent a facilities project with the overall floor plan on one drawing 
page, a detailed view on another page, and the plan for equipment and furniture on another page. New 
drawings in Visio open with only one drawing page, but you can add as many new pages as you want. 

Each page in a multiple-page drawing can have its own settings. For example, each page can have a different 
drawing scale. Print settings, however, affect all pages.



Creating and deleting pages
When you create a new drawing page, it inherits the size, orientation, scale, measurement unit, shadow 
offset, and grid settings of the page currently displayed in the drawing window. You can change these 
settings in the Page dialog box when you insert the page, or later in the Page Setup dialog box.

You can delete pages you no longer need. If you delete the last page in a file, Visio replaces that page 
with a blank page.

TIP    To delete a background page, you first need to cancel its page assignment because a background 
page assigned to a foreground page cannot be deleted.

To create a new page:

1. Choose Insert > Page command to open the Page dialog box.

2. On the Page Properties tab, type a name for the page or use the default name provided by Visio.

3. If necessary, click the Drawing Scale tab to change the scale or the Page Size tab to change the page 
size for the new page.

4. Click OK.

To delete a page:

1. Choose Edit > Drawing Page > Delete Pages.

2. Choose the page you want to delete.

3. To update default page names to reflect the new page order, check Update Page Names.

Checking this option has no effect on pages without default names.

4. Click OK.
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Navigating between pages
Visio stores pages in the order you create them and displays them one at a time in the drawing window. 
You can quickly navigate between pages and, if necessary, you can change page order. When you 
change the order, you can also change page names so they reflect the new arrangement. 

You can also add navigational links to drawing pages or shapes that you can use to jump directly to 
another drawing page.

To navigate to a particular page: 

· Choose the page that you want to go to from the Page list on the Page toolbar. You can also use the 
Next Page ( ) and Previous Page (

) buttons on the Page toolbar to navigate between pages. 
NOTE    The Page toolbar is not displayed by default. To display it, choose View > Toolbars > Page.

To rearrange pages:

1. Choose Edit > Drawing Page > Reorder Pages.

2. Choose the page you want to move.

The list displays the page names in the order they are stored in the file.

3. Click Move Up or Move Down to change the position of the page.

4. To update default page names to reflect the new page order, check Update Page Names.

Checking this option has no effect on pages for which you changed the names from the default.

5. Click OK.
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Displaying pages simultaneously
If you want to view more than one drawing page at a time, you can open each page in its own window. Or 
you can open a new window so that you can display a new page you create and the original page at the 
same time.

To display a specific page in its own window:

· Choose Edit > Go To  > Page. Select the page, check Open Page In New Window, then click OK.

To open a new drawing window and display a page in it:

1. Choose Window > New Window.

Choose New Window when a drawing window is open to open a new window that contains a duplicate 
of the open window's contents.

2. To see all the open windows, choose Window > Tile.
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Using backgrounds for common page elements
    How To
    Related Topics

Each Visio drawing contains at least one foreground page and may also contain one or more 
backgrounds. A background is a page that appears behind another page. Create a background when you 
want the same shape to appear on more than one drawing page. For example, you can place a common 
graphical element, such as a company logo or a border, on a background. The element will appear on 
each page to which you assign the background.

Use a background to repeat a common element on several drawings. For example, on these three pages, the 
company name is repeated on each one.

You can assign only one background to each foreground, but each background can also have a 
background, so you can use backgrounds to create a layered effect.

When you assign a background to a foreground page, the shapes on the background are visible when 
you display the foreground page, but you cannot edit them from the foreground page. To edit the shapes 
on a background, you display that background in the drawing window, and then edit the same way you 
edit a foreground page.

TIP    If you want to selectively view, edit, print, or lock shapes in a drawing, or if you want to have multiple
depths of text and shapes within the same page, use layers instead of a background. 



Creating and editing backgrounds
You can create a new page as a background or convert a foreground page to a background. When you 
create a background, Visio adds it to the list of available backgrounds in the Insert Page and Properties 
dialog boxes.

You edit the shapes on a background in the same way you edit the shapes on a foreground page. You 
can display the background in one window and the page it's assigned to in another window, so you can 
see how the changes affect the whole drawing. You cannot edit shapes on the background in the window 
that displays the foreground page.

NOTE    If you use the Page Layout Wizard to set up a drawing, the wizard automatically creates a 
background and creates placeholders for elements such as title blocks, borders, and logos. If you want to 
add any of these elements, you must display the background page to modify it.

To create a background:

1. Choose Insert > Page.

2. On the Page Properties tab, select Background for Type.

3. If necessary, click the Drawing Scale tab to change the scale or the Page Size tab to change the page 
size for the new page.

4. Click OK.

To convert a foreground page to a background:

1. Display the foreground page you want to convert to a background.

2. Choose File > Page Setup, then click the Page Properties tab.

3. For Type, select Background.

4. Click OK.

To display a background so you can edit it:

· Display the page to which the background is assigned, then choose Edit > Go To > Background.

TIP    You can also display a background in a new window so you can view the background and the pages
it's assigned to at the same time. To display a background in a new window, choose Edit > Go To > Page, 
check Open Page In New Window, then click OK. Then, choose Window > Tile.
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Assigning a background page
You can assign one background to each page in a drawing. You can assign the same background to as 
many pages as you want. If you no longer want a background assigned to a particular page, you can 
cancel the assignment.

To assign a background to a page:

1. Display the page to which you want to assign the background.

2. Choose File > Page Setup, then click the Page Properties tab.

3. In the Background list, select the name of the background that you want to assign.

4. Click OK.

The background displays behind the shapes on the foreground page.

To cancel a page's background assignment:

1. Display the page to which the background is assigned.

2. Choose File > Page Setup, then click the Page Properties tab.

3. In the Background list, select None.

4. Click OK.
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Previewing drawings in full-screen view
    How To
    Related Topics

If you want to preview or present Visio drawings, you can use full-screen view to maximize the amount of 
space for your drawing. In full-screen view, the Visio toolbars, title bars, status bar, menus, scrollbars, and
stencils are hidden and the drawing page takes up the entire screen. The drawing-page grid is also turned
off. Full-screen view is a view-only mode¾you cannot edit or change the pages you view.



To enter full-screen view:

· Choose View > Full Screen.

To exit full-screen view:

· Press the Esc key.

To navigate between pages in full-screen view:

· Press the left arrow, Page Up, or P keys on your keyboard to display the previous page.

· Press the right arrow, Page Down, or N keys to display the next page.

· Click the left-mouse button (when it's not over a hyperlink) to display the next page.

· Right-click anywhere in the window and choose Previous Page, Next Page, or Go To > <page name>.

To navigate hyperlinks in full-screen view:

· Click hyperlinked shapes once to jump to the link.
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About working with shapes
    Related Topics

In Visio, the term "shape" can refer to one line, arc, or spline; a series of segments; or several shapes 
grouped together.

Shapes include master shapes, or "masters," that come with Visio, as well as shapes you draw yourself. 
Visio shapes are programmed to act the way you need them to in a particular context. For example, 
shapes for doors, windows, desks¾things that are built to standard industry sizes¾are locked against 
sizing so you don't accidentally stretch the shapes inappropriately as you are working with them.

A single line is a shape and so is a rectangle. The table with chairs is a Visio master composed of simpler shapes 
grouped together.

The desk chair is programmed to be easy to rotate.

Closed and open shapes
A shape can be either closed or open. Shapes that are surrounded by a continuous outline, such as 
rectangles or circles, are closed shapes, which means that you can fill them with colors and patterns. 
Lines, arcs, or zigzag shapes are open shapes, which means that you can format their ends.

The rectangle, which is a closed shape, is filled with a pattern. The lines, which are open shapes, have line ends 
applied to them. 

1-D and 2-D shapes
A shape can be either one-dimensional (1-D) or two-dimensional (2-D).

A 1-D shape behaves like a line, and displays endpoints that you can drag to resize the shape when you 
select it with the pointer tool. You can glue the endpoints of 1-D shapes to the sides of 2-D shapes to 
create connecting lines that stay in place when the shapes are moved.

A 1-D shape has only two endpoints. Some 1-D shapes also have other handles, such as this arc's control handle.

A 2-D shape behaves like a rectangle, and displays selection handles that you can drag to resize the 
shape when you select it with the pointer tool.

A 2-D shape has more than two handles and can be closed (like the ellipse) or open (like the zig-zag line). 

With all shapes, except those that are locked against specific behavior, you can do the following:



· Resize, move, flip, or rotate them.

· Change their stacking order relative to other shapes.

· Format and add text to them.

· Glue them to other shapes and guides.

· Snap them to a guide, guide point, grid, or the alignment box of another shape.

· Revise them by adding segments or changing the way they curve.

· Control how they appear onscreen, whether they print, and how they behave when you double-click 
them.

· Associate them with data and use the data to generate reports.

· Add jumps to them that go to other pages in the same drawing, to other files, or to World Wide Web 
sites.

· Control their behavior by modifying their ShapeSheet spreadsheets.

Customizing shapes in the ShapeSheet spreadsheet
To understand what makes a shape smart, it helps to know how shapes are drawn and stored in Visio. 
Every Visio shape is described in its own ShapeSheet spreadsheet, which contains information about the 
shape's geometry and other properties. For example, the ShapeSheet contains the coordinates of each 
shape vertex and the shape's dimensions. Much of this information can be defined by formulas rather 
than by hard-coded numbers. This is important because it's what makes a shape smart; formulas allow a 
shape to behave differently based on how it is used, rather than always behaving the same way.

To display a ShapeSheet spreadsheet, select a shape, then choose Show ShapeSheet from the Window menu.



Using shape handles
    Related Topics

Visio shapes come with a variety of handles that you can drag to modify the shape's appearance, 
position, or behavior. For example, you can use handles to glue one shape to another, move a shape's 
text, or change the curve of an arc. 

This section discusses the various types of shape handles and how to use them.

Selection handles and endpoints
Selection handles and endpoints appear when you select shapes with the pointer tool ( ) on the 
Standard toolbar. To resize a shape, drag its selection handles or endpoints.

Most shapes are two-dimensional (2-D) shapes, which have corner selection handles that you drag to 
resize the shapes proportionally and side selection handles that you drag to resize that side of the shape.

Two-dimensional shapes. The small green boxes on the corners and sides of each shape (A) are its selection 
handles.

Some shapes, including all connector shapes, are one-dimensional (1-D) shapes. One-dimensional 
shapes have endpoints¾a begin point ( ) and an end point (

).

One-dimensional shapes. In addition to begin points (A) and end points (B), some 1-D shapes have two selection 
handles (C).

Connection points
Some 2-D shapes have connections points, where you can glue the endpoints of a 1-D shape to the 2-D 
shape. You an create new connection points using the connection point tool ( ) on the Standard toolbar.

A connection point appears as a blue x on a shape.

Rotation handles
Rotation handles appear when you select a shape with the rotation tool ( ) on the Standard toolbar. They 
are indicated by green round corner handles, and a pin, which marks the center of rotation. To rotate a 
shape, drag a corner handle. To change the center of rotation, move the rotation pin. 



Rotation handles appear as round corner handles. The rotation pin appears as a circle with a plus in the center.

Vertices
Vertices appear when you select a shape with the pencil ( ), line (

), arc (
), or freeform (
) tool on the Standard toolbar. A vertex is marked by a green diamond-shaped handle. To change the 

form of a shape, drag a vertex with the tool used to create the shape. (The vertex turns magenta to 
indicate that it's selected.) To add or delete segments, you add or delete vertices using the pencil, line, 
arc, or freeform tool on the Standard toolbar.
Control points
Control points appear on lines, arcs, and freeform curves when you select them with the pencil tool. 
These are green round handles that appear between two vertices. You can drag control points to change 
the curve or symmetry of a segment.

Vertices appear as green diamond-shaped handles. Control points appear as round handles.

Eccentricity handles
With eccentricity handles, you adjust the angle and magnitude of an elliptical arc's eccentricity. To display 
eccentricity handles, first select an arc. Then select the pencil tool and click the control point at the center.

Eccentricity handles appear as circles on each end of a dashed line.

Control handles
Some master shapes have control handles that let you work with shapes in ways you can't with standard 
1-D and 2-D shapes. The control handle looks like a selection handle with darker shading. Each control 
handle has a function unique to the shape on which it appears. For example, it may adjust the roundness 
of a shape's corners or reshape an arrow. To display a tip about what a control handle does, pause the 
pointer over the control handle.

        



Tips explain the use of control handles. In this example, dragging the control handle ( ) adjusts the line spacing. This 
behavior is programmed into the shape's ShapeSheet spreadsheet.

Padlocks
Padlocks appear in place of corner handles when you select a shape to indicate that the shape is locked 
against specific changes. Some shapes are locked against flipping, rotating, sizing, or other changes that 
would destroy their specially programmed behavior. You can lock shapes using the Protection command.

NOTE    Padlocks only appear when a shape is locked against sizing or rotating. When a shape is locked 
against repositioning, deleting, or selecting, no padlocks appear, but you can't perform the action.

When you select a shape locked against sizing or rotating, the selection handles appear as padlocks.



Selecting shapes
    Related Topics

To work with a shape you must select it. In most cases you select shapes by clicking them with the pointer
tool, but you can also use other tools or drag the pointer tool to create a selection net around multiple 
shapes.

Methods for selecting shapes
To Do this

Select one 
shape

Move the pointer over a shape. 
When the pointer changes from a
black arrow to a white arrow, 
click to select the shape. The 
shape's selection handles 
appear in green.

Select multiple 
shapes by 
clicking

Select the first shape, hold down 
the Shift key, then click to select 
other shapes one at a time. The 
primary shape has green 
selection handles, and all other 
shapes have blue selection 
handles. 

Select multiple 
shapes by 
dragging

Use the pointer tool ( ) from the 
Standard toolbar and drag a 
selection net around all of the 
shapes you want to select. 

Select all 
shapes on the 
page

Choose Edit > Select All. If there 
are more than 25 shapes, they 
appear with a magenta outline to 
show that they are selected. 
Otherwise, shapes appear 
selected as described earler.

Select all of a 
particular kind of
object

Choose Edit > Select Special, 
then check the type of object that
you want to select, such as 
shapes, groups, or guides. 

Cancel a 
selection

Click away from the selected 
shape or press the Esc key.

Cancel the 
selection of one 
shape when 
several are 
selected

Shift+click the shape.



Resizing and reshaping shapes
    How To
    Related Topics

You can change the size and shape of a shape. For example, you can

· Change the width and height of two-dimensional (2-D) shapes.

· Make one-dimensional (1-D) shapes longer, shorter, wider, or narrower.

· Add segments to and delete segments from shapes.

· Change the angle where two segments meet.

· Edit arcs¾drawn with the arc tool, pencil tool, or freeform tool¾with the pencil tool.

NOTE    To resize a shape exactly, use the Size & Position command and then type the shape's height 
and width dimensions.

If a 1-D shape has selection handles, you can drag them to change the width of the shape.



Resizing 2-D shapes
A 2-D shape, such as a rectangle, has corner selection handles you can use to resize the shape 
proportionally and side selection handles you can use to resize that side of the shape. Selection handles 
appear as green boxes. Examples include most rectangles, ellipses, and freeform shapes.

NOTE    If you select a shape and it's selection handles appear gray, the shape is part of a group.

To resize a 2-D shape:

1. Choose the pointer tool ( ) on the Standard toolbar, then select the shape.

2. Drag a selection handle until the shape is the size you want. To resize the shape proportionally, drag a 
corner handle.

TIP    If you see fewer than eight handles on a 2-D shape, zoom in on the drawing to see the rest of the 
handles and to size the shape more accurately.
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Resizing 1-D shapes
A 1-D shape has two endpoints: a begin point ( ) and an end point (

). You can change the size of a 1-D shape by dragging one of its endpoints. 1-D shapes that are not 
straight lines have selection handles you can use to resize the shape.
To resize a 1-D shape:

1. Choose the pointer tool ( ) from the Standard toolbar, then select the shape.

2. To adjust the shape's length, pause the pointer over an endpoint until it changes to a four-headed 
arrow, then drag to make the shape the length you want.

For 1-D shapes that can be adjusted in width, pause the pointer over a selection handle until it 
changes to a two-headed arrow, then drag until the shape is as wide or narrow as you want.

3. Release the mouse button.

NOTE    Changing a 1-D shape's width is not the same as changing its line weight. 
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Adding or deleting shape segments
A segment is a straight line or curve that is part of a more complex shape. Between each pair of 
segments is a vertex. You can add segments to shapes to change the way they look. For example, you 
can turn a triangle into a rectangle. You add a segment by adding a new vertex to an existing segment. 
You can also delete segments you don't want. For example, you can delete a segment from a rectangle to
make it a triangle.

When you delete a segment, Visio redraws the shape based on

· The order in which the shape's segments were created.

· Whether a vertex is at the beginning or end of an open shape.

· Whether the segment that follows the one you delete is a line or an arc.

To add a new segment to a shape:

1. Choose the pencil ( ), freeform (

), line (
), or arc tool (
) from the Standard toolbar, then select the shape.

2. Between two existing vertices on the shape's outline, point to where you want to add the 
segment.
3. Hold down the Ctrl key and click. 

A new vertex appears where you clicked on the shape, creating a new segment. To make the shape 
look the way you want, you may need to adjust the shape by dragging vertices and control points.

TIP    Zoom in on the drawing so you can clearly see when the pencil is over a line or arc segment.

To delete a segment:

1. With the pencil tool, select the shape.

2. Click the vertex at the end of the segment you want to delete.

When the vertex is selected, it turns magenta.

3. Press the Delete key, or choose Edit > Clear.

After you delete segments, you can adjust the shape by dragging vertices and control points.

    Overview



Changing the angle where two segments meet
By dragging a vertex, you can change the angle at which two segments meet. Dragging a vertex often 
makes a segment longer or shorter. You can also select several vertices and drag them all at the same 
time. The selected vertices maintain their position in relation to one another and move in relation to the 
rest of the shape.

To reshape angles by dragging a vertex:

1. Choose the pencil tool ( ) from the Standard toolbar, then select the shape.

2. Click the vertex you want to move.
When the pointer is directly over the vertex, it changes to a four-headed arrow. When the vertex is 
selected, it turns magenta.

3. Drag the vertex to its new position.

To reshape angles by dragging multiple vertices:

1. With the pencil tool, select the shape.

2. Click a vertex that you want to move, then hold down the Shift key and click the other vertices with 
positions you want to change.

3. Place the pointer over one of the selected vertices, then drag.

The selected vertices move together, maintaining their relationship.

    Overview



Reshaping arcs
Every arc drawn with the arc tool ( ) follows the perimeter of an invisible ellipse. You can change the bow 
of an arc so the arc becomes a larger or smaller portion of the circle or ellipse¾even flatten an arc to 
make it a line. You can also edit an arc by dragging its eccentricity handles to reshape the ellipse on 
which the arc is based. You can change the way the arc leans (the angle of eccentricity) or its flatness 
(the magnitude of eccentricity). An arc has an invisible snap point in the middle of an invisible line 
between its two endpoints. When you drag the control point to that snap point, the arc becomes a line.

To reshape an arc:

1. Choose the pencil tool ( ) from the Standard toolbar, then select the arc or the shape that contains the
arc.

2. Point to the arc's control point.
3. Drag the control point until the arc looks the way you want.

To change an arc's eccentricity:

1. With the pencil tool, select the arc or the shape that contains the arc.

2. Click the control point on the arc to display the eccentricity handles.

On circular arcs, the eccentricity handles are under the control point.

If you don't see the eccentricity handles, hold down the Ctrl key and drag the pointer slightly away from
the control point to display them.

3. Edit the arc by doing the following:

To change the arc's magnitude of eccentricity, drag an eccentricity handle farther from or closer to the 
control point.

To change the arc's angle of eccentricity, drag an eccentricity handle around the control point.

    Overview



Moving shapes
    How To
    Related Topics

You can change the location of a single shape or move multiple shapes so they keep their positions in 
relation to one another. You move shapes by dragging them. There are a number of ways to ensure that 
you place your shapes where you want them:

· Faint lines on each ruler indicate the location of the shape or group of shapes. You can also use the 
grid or guides to help you position shapes.

· If you drag the shape quickly, a rectangle (representing a 2-D shape) or a line (representing a 1-D 
shape) shows the location of the shape or group of shapes on the page.

· If you pause while dragging and continue to hold down the left mouse button, you'll see the shape or 
group of shapes instead of the rectangle or line that represents it, so you can position it more precisely.

If you want to place a shape or group of shapes exactly in a certain position, you can use the Shape > 
Size & Position command and then type the shape's x, y coordinates relative to the zero point of the 
drawing.

        

When you move a shape, watch the pointer. If the pointer is black, it's not positioned over the shape, so you cannot 
move the shape. The pointer turns white to indicate that you can move the shape.



Moving single shapes
To move a single shape:

1. Choose the pointer tool ( ) from the Standard toolbar, then point to the shape. The pointer turns white.

2. Press the left mouse button, then drag the shape to where you want it. To constrain the 
movement of the shape to vertical or horizontal, hold down the Shift key while you drag the shape.

If snapping is on, the shape may jump into place.

TIP    Be careful not to point to a selection handle. If you accidentally resize a shape, choose Edit > Undo 
(or press Ctrl+Z).

    Overview



Moving multiple shapes
If several shapes are related to each other, you may want to move them together. To keep them aligned 
as you move them, glue the shapes to a guide, then move the guide. You can group some shapes first, so
that even shapes that don't actually touch the guide move with it.

        

When shapes are glued to a guide (A), you can move the guide to make several adjustments to the drawing at once 
(B). In this example, the shapes that represent the plant, couch, and side table are glued to a guide, which is then 
moved to the right to put more space between them and the table shape.

To move multiple shapes:

1. Select the shapes you want to move.

2. Place the pointer over one of the shapes. The pointer turns white.

If one of the objects you're moving is a group, the pointer needs to be over one of the shapes in the 
group in order to turn white.

3. Drag the shape to its new position. All selected shapes move the same distance and direction from 
their original positions.

TIP    To constrain the movement of the shapes to vertical or horizontal, hold down the Shift key while you 
drag the shapes.

To use a guide to move several related shapes:

1. Choose Tools > Snap & Glue, then in the Snap & Glue dialog box make sure Guides is checked in the 
Snap To and Glue To lists.

2. Drag a guide from the appropriate ruler and glue shapes to the guide. Shapes' endpoints and selection
handles turn red when glued.

3. Drag the guide to the shapes' new location.

    Overview



Working with shapes in groups
    Related Topics

In Visio, you can group shapes so they function as a unit. It's useful to group shapes when you regularly 
use them together. You can group any combination of Visio shapes and shapes you draw yourself. 
Groups can also include guides, other groups, and objects from other programs. 

Some Visio shapes are groups¾that is, a set of shapes grouped to form a single shape.

Keep these points in mind as you work with groups:

· You can manipulate groups or individual shapes, including formatting, moving, rotating, flipping, and 
reversing. You can also set behaviors for how an individual shape acts in relation to the group it 
belongs to. 

· When you create a group, Visio builds a group ShapeSheet spreadsheet, which describes the group's 
attributes, but not those of the individual shapes within it. Each shape in the group retains its own 
ShapeSheet spreadsheet; Visio puts references to the group ShapeSheet spreadsheet into the 
individual shapes' ShapeSheet spreadsheets. When you ungroup shapes, Visio discards the group's 
ShapeSheet spreadsheet.

· If you add a guide and the shapes glued to it to a group, be sure to select both the guide and shapes 
before you add them to the group; otherwise the glue breaks. You can add guides to rotated groups 
only when the group is displayed in the group window, which is where you can edit the shapes that 
make up the group.

· Bitmaps or other imported objects cannot be rotated even when you rotate the group that contains 
them. To rotate an imported object that is not a bitmap, you must first convert it to a Visio group.

· After you reposition, add, or delete individual shapes within a group, the alignment box that appears 
when you select a group may no longer fit its dimensions. To adjust it, choose Tools > Update 
Alignment Box.

Methods for working with groups
To Do this

Group shapes 
and objects

Select the shapes and objects 
you want to group. Choose 
Shape > Grouping > Group

Ungroup shapes
and objects

Select a group, then choose 
Shape > Grouping > Ungroup.

Open a group 
so that you can 
work with the 
shapes in it

Select a group, then choose 
Edit > Open Group to open the 
group window.

Add a shape to 
a group

Select the group. Press the Shift 
key and select the shape you 
want to add. Choose Shape > 
Grouping > Add To Group. You 
can also open the group window 
as described above, then drag a 
shape from the drawing page or 



a stencil into the group window.

Remove a 
shape from a 
group

Select the group, then click the 
shape you want to remove to 
subselect it. Choose Shape > 
Grouping > Remove From 
Group.



Flipping and reversing shapes
    Related Topics

You can change the direction shapes face by flipping or reversing them.

A Flipping shapes horizontally.

B Flipping shapes vertically.

C Reversing ends to flip shapes both horizontally and vertically.

Methods for flipping and reversing shapes
To Use this 

tool
Do this

Flip a shape Select the shape. 
From the Shape menu,
choose Flip Vertical 
(Ctrl+J) or Flip 
Horizontal (Ctrl+H).

        Or select the shape 
and click the flip 
vertical or flip 
horizontal button on 
the Shape toolbar.

Reverse a 
shape

Select the shape. 
Choose Shape > 
Reverse Ends.

Flip or 
reverse a 
group

Flip or reverse as you 
would any shape.

Flip or 
reverse a 
shape within 
a group

Select the group, then 
choose Edit > Open 
Group. In the group 
window, flip or reverse 
individual shapes as 
you would any shape. 
Click the group 
window's close box.



Rotating shapes
    Related Topics

You can change the angle of shapes by rotating them in one of two ways: You can use commands or 
buttons to rotate in 90-degree increments, or you can use the rotation tool to rotate the shape at any 
angle. As you rotate shapes with the rotation tool, the status bar at the bottom of the Visio window 
displays the exact angle of rotation.

A Rotate Left and Rotate Right rotate a shape in 90-degree increments.

B With the rotation tool, you can rotate a shape at any angle.

Keep these points in mind as you rotate shapes:

· You can rotate a 1-D shape by dragging one of its endpoints with the pointer tool ( ). However, it's 
easy to resize the shape when you do this. If you don't want to resize the shape it's better to use the 
rotation tool.

· You cannot rotate imported bitmaps or OLE objects.
· For precise rotation of a shape, use the Shape > Size & Position command to enter a numerical value 

for angle. 

Methods for rotating shapes
To Use this 

tool
Do this

Rotate a 
shape 90 
degrees

               Select the shape. 
Choose Shape > 
Rotate Left (Ctrl+L) to
rotate 
counterclockwise or 
Rotate Right (Ctrl+R) 
to rotate clockwise. 
Or select the shape, 
then click the rotate 
right or rotate left 
button on the Shape 
toolbar.

Rotate a 
shape by any 
amount

Click the shape to 
select it. Drag a 
rotation handle. For 
more control, drag the
pointer farther from 
the rotation pin.

Rotate a 
group

Rotate as you would 
any shape.

Rotate a 
shape within 

Select the group, then
choose Edit > Open 



a group Group. In the group 
window, rotate 
individual shapes as 
you would any shape.
Click the group 
window's close box.

Changing the center of rotation
When you select a 2-D shape with the rotation tool, a plus sign in a circle appears at the center of 
rotation, which is usually at the center of the shape's selection rectangle. You can move the center of 
rotation, called the pin, to rotate a 2-D shape around any point in the drawing window. To do this, select 
the shape with the rotation tool, then drag the pin to a new location.

        

When you select a shape with the rotation tool, rotation handles appear in the corners and a pin (center of rotation) 
appears in the center. As it moves over a rotation handle, the pointer changes to a round arrow indicating that you 
can rotate the shape.

You can rotate a shape around any point by moving the shape's pin to that point.



Duplicating shapes
    Related Topics

You can duplicate shapes within the same drawing, or copy shapes from one    Visio drawing to another or
to a document in another Windows application. You can also drag shapes from one drawing to another or 
from Visio to another Windows application that is compatible with OLE 2.

You can place shapes exactly where you want them in relation to one another as you duplicate them. For 
example, you can easily design an auditorium with dozens of rows of seats or a steel structure with 
regularly placed rivets. 

Methods for duplicating shapes
To Do this

Add several 
copies of a 
master to a 
drawing

Select the stamp tool from the 
Standard toolbar, then click a 
master on a stencil to select it. In
the drawing window, click the 
pointer where you want the 
center of the shape to appear. 
Continue clicking where you 
want additional copies of the 
shape.

Duplicate a 
shape within the
same drawing

Select the shape you want to 
duplicate, then choose Edit > 
Duplicate (Ctrl+D). The copy 
appears on the page slightly 
offset from the original.

Duplicate a 
shape at a 
specific location

Select the shape. Hold down the 
Ctrl key and drag to where you 
want the copy.

Repeatedly 
duplicate a 
shape and the 
offset between 
copies

Select the shape. Hold down the 
Ctrl key and drag to where you 
want the copy. Release the 
mouse button. Press F4 for each 
copy you want.

Drag and drop 
shapes from a 
Visio drawing 
into another 
application that 
supports OLE 2

Display the drawing page that 
contains the shape you want to 
copy. Open the document into 
which you want to copy the 
shape. Hold down the Ctrl key 
and drag the shape from Visio 
into the other document.

Copy and paste 
shapes from a 
Visio drawing 
into another 
application that 
doesn't support 
OLE 2

Select the shape you want to 
copy. Choose Edit > Copy. In the
document in which you want to 
copy the shape, choose Edit > 
Paste.



Finding shapes on stencils
    How To
    Related Topics

When you want to find a shape, but aren't sure which stencil it's on, you can quickly search with Shape 
Explorer instead of opening multiple stencils. Shape Explorer provides an easy way to search for and 
catalog Visio shapes, stencils, and templates that are provided with Visio products, that are on the World 
Wide Web, or that are in databases you create.

For example, if you know a 3-D Box shape exists, but don't know where to find it, use Shape Explorer to 
determine which stencil contains the shape, then open the stencil or use Shape Explorer to add the shape
to your drawing.

You search with Shape Explorer by typing the keywords you want to use in the Search For box on the 
Search tab. A keyword can be a shape or stencil name, or a word or phrase that describes the shape 
you're looking for, or the type of drawing you want to create.



To open the Shape Explorer:

1. Choose File > Stencils > Shape Explorer.

2. On the Search tab, in the Search For box, type a name, word, or phrase that describes what you want 
to find. 

3. Click Find Now.

The status bar at the bottom of the Shape Explorer window indicates the progress of the search.

    Overview





About formatting shapes
    Related Topics

You can format shapes in your drawing by changing any one or all of their attributes, such as line weight 
and pattern, fill color and pattern, or text. For example, you might use color to make a drawing for a slide 
presentation more effective, or use line patterns to represent a specific type of connection between 
shapes.

The type of formatting you apply to a shape depends on whether the shape is open or closed. For 
example, you can add fills to closed shapes, such as circles or rectangles, but not to open ones. You can 
add line ends to open shapes, such as arcs or zigzag lines, but not to closed ones. 

On open shapes, such as arcs, you can change

· Line ends (such as arrowheads). 

· Line caps (round, square).

· Line pattern (solid, dashed), line weight, and line color.

· Shadow pattern and shadow color.

· Corners.

On closed shapes, such as rectangles, you can change

· Line pattern (solid, dashed), line weight, and line color.

· Fill color and pattern.

· Shadow pattern and shadow color.

· Corners.

The quickest way to change a shape's appearance is to

· Use Shape toolbar buttons to apply local formatting

· Use the Text, Line, or Fill style lists to apply a style.

For greater precision, you can use the commands on the Format menu. 



Formatting shapes
    How To
    Related Topics

You can choose from among the following formatting methods according to the type of formatting you 
want to do.

Toolbar buttons
By using the Shape toolbar buttons to apply local formatting, you can quickly change

· Line ends (such as arrowheads).

· Line patterns, weight, and color.

· Fill color and patterns.

· Shadow color.

· Corners on shapes.

NOTE    Buttons S–V only appear at resolutions higher than 600x800.

Toolbar palettes
Some of the buttons on the Shape toolbar display palettes from which you can choose an attribute to 
apply to your shape. After you choose the option you want, the palette closes.

Line pattern palette

TIP    If the option you want isn't available as a palette, you can use a command on the Format menu.

Format menu commands
Although formatting with toolbar buttons is faster, you may sometimes want to use the formatting 
commands on the Format menu. Format menu commands have options that are not on the toolbar. For 
example, you can only apply a pattern to a shadow using the Shadow or Fill commands on the Format 
menu.

Style lists
When you format shapes using the Text, Line, or Fill style lists, you're actually applying a style. Styles can
contain line, fill, and text formatting attributes. It's best to use a style if you want to apply many formatting 
attributes to many different shapes. When you start a drawing with a Visio template, the template includes
style definitions and the appropriate styles appear in the style lists on the toolbars. 



To display the Shape toolbar:

· Choose View > Toolbars > Shape. A checkmark next to a toolbar name indicates that the toolbar is 
currently displayed.
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To format shapes:

· Do one of the following:

Select the shape or shapes you want to format, then choose the appropriate button or style list from 
the Shape toolbar.

Select the shape or shapes, then choose the appropriate command from the Format menu.

    Overview



Formatting multiple shapes
    Related Topics

You can format several shapes at once by doing one of the following:

· Selecting multiple shapes at the same time.

· Selecting shapes in a group. 

Selecting multiple shapes
When you select multiple shapes and then apply a command, the result depends on the primary shape, 
the order in which you select, and the stacking order of the shapes.

When you are working with multiple shapes, the primary shape determines

· How all the shapes align when you use the Align Shapes command.

· How the selected shapes are affected when you edit or position them.

· The attributes that appear in any dialog boxes or styles lists you open. 

· The order in which shapes connect when you use the Connect Shapes command.

The shape that is primary is determined by one of two things: the selection order or the stacking order.

When you select multiple shapes by shift-clicking, the primary shape (A) is the first shape you select. The primary 
shape is indicated by green handles.

When you select shapes by dragging a selection net around them, the primary shape (A) is the one you dropped 
most recently on the page. The most recently dropped shape is at the front of the stacking order.

How a command affects multiple shapes in a selection is also determined by the stacking order of the 
shapes on the page. The first shape you draw or drop on the page is at the back of the stack; the most 
recently created shape is at the front. Stacking order determines

· Which shape is positioned in front of another if they overlap.

· How multiple shapes are affected by commands. For example, when you type in a group, the text 
appears on the frontmost shape in the stacking order.

· The selection order when you select multiple shapes by dragging a selection net around them. The 
shape at the front of the stacking order becomes the primary shape, displaying green handles. (When 
you select multiple shapes by Shift+clicking, the stacking order doesn't affect the selection order. The 
first shape you click becomes the primary shape.)

NOTE    Shapes on a background always appear behind shapes on a foreground. Layers, however, have 
no effect on stacking order.



Methods for selecting multiple shapes
To Do this

Select multiple 
shapes by 
clicking

Select the first shape, hold down 
the Shift key, then click to select 
other shapes one at a time. The 
primary shape has green 
selection handles; all other 
shapes have blue selection 
handles. 

Select multiple 
shapes by 
dragging

Using the pointer tool ( ) on the 
Standard toolbar, drag a 
selection net around all of the 
shapes you want to select. The 
shapes appear selected as 
described above.

Select all 
shapes on the 
page

Choose Edit > Select All. If there 
are more than 25 shapes, they 
appear with a magenta outline to 
show that they are selected. 
Otherwise, shapes appear 
selected as described above.

Select all of a 
particular kind of
object

Choose Edit > Select Special, 
then check the type of object that
you want to select, such as 
shapes, groups, or guides. The 
shapes appear selected as 
described above.

Cancel the 
selection of one 
shape when 
several are 
selected

Shift+click the shape.

When you group shapes using the Shape > Grouping > Group command, you can apply formatting to the 
group or to individual shapes in the group.

When you select a group and type text, the text appears on the frontmost shape in the stacking order.

Methods for selecting shapes in groups
To Do this

Format all the 
shapes in a 
group

Select the group, then change 
the style or attribute.

Format a shape 
within a group

Select the group, then choose 
Edit > Open Group to open the 
group in the group window. 



Select the shape and format it as
you would any shape, then click 
the group window's close box.

Format several 
shapes at once

Select all the shapes, then 
change the style or attribute.



Changing the stacking order of shapes
    Related Topics

You can change the stacking order of shapes. For example, you can bring a specific shape to the front to 
act as the primary shape when you drag a selection net around multiple shapes.

Methods for changing a shape's position in the stacking order
To Do this

Bring a shape 
forward one 
level in the 
stacking order

Select the shape, then choose 
Shape > Bring Forward.

Bring a shape to
the front of the 
stacking order

Select the shape, then choose 
Shape > Bring To Front (or press
Ctrl+F).

Send a shape 
backward one 
level in the 
stacking order

Select the shape, then choose 
Shape > Send Backward.

Send a shape to
the back of the 
stacking order

Select the shape, then choose 
Shape > Send To Back (or press 
Ctrl+B).

Change the 
stacking order 
of a shape in a 
group

Select the group, then choose 
Edit > Open Group. Select a 
shape, change its position in the 
stacking order as described 
above, then close the Group 
window.



Formatting lines
    How To
    Related Topics

A line can be an open straight line, freeform line, or arc; or the border around a closed shape, such as a 
rectangle. You can format lines or arcs by adding a pattern or color, changing the line weight, adding or 
removing line ends, changing the line caps, or rounding the line's corners. You can also add a shadow 
and format the shape's text. 

By applying line ends, you can turn any line or other open shape into an arrow. You can apply an 
arrowhead or other line end to the begin point, the end point, or both endpoints of a shape. You can also 
choose options for the size of line ends. You can turn an arrow into a straight line by removing any line 
ends that are applied to it.

Rounded corners can be applied to any corner where two segments meet on open or closed shapes.



To change formatting for a line:

1. Select the shape, then choose Format > Line.

2. Choose the options you want.

You can see how the options you select will look in the Preview box.

3. Click Apply to apply the formatting options you've chosen and view the change before closing the 
dialog box, or click OK to apply the formatting and close the dialog box.

    Overview



Repeating and copying formatting
    Related Topics

If you want to format several shapes the same way, you can select all the shapes and apply the 
formatting options you want. You can also experiment with one shape until it looks exactly the way you 
want and then use the Format Painter button to copy that shape's formatting to one or more other shapes 
in your drawing.

If you want to use the same formatting again and again in many drawings, you can create a style. 

Methods for repeating or copying formatting
To Do this

Format several 
shapes at once

Select all the shapes you want to
format, then click the formatting 
buttons and choose the style list 
options you want, or use the 
appropriate command on the 
Format menu.

Quickly repeat 
one formatting 
change

Make one formatting change to a
shape. Select other shapes, then
press F4. The last formatting 
change you made will be used. 

Copy one 
shape's 
formatting to 
another shape

Select the shape with the 
formatting you want to copy. 
Click the Format Painter button (

), then click the shape to which
you want to copy the formatting.

Copy only text 
attributes from 
one shape to 
another

Double-click the shape to select 
the text. Click the Format Painter
button. Click the shape to which 
you want to copy the formatting.

Copy one 
shape's 
formatting to 
other shapes 
sequentially

Select the shape with the 
formatting you want to copy. 
Double-click the Format Painter 
button, then click the shapes to 
which you want to copy the 
formatting. 

Copy one 
shape's 
formatting to 
several other 
shapes 
simultaneously

Select the shape with the 
formatting you want to copy, then
press the Shift key and select the
shapes to which you want to 
copy the formatting. Click the 
Format Painter button.



Adding color and shadows to shapes
    How To
    Related Topics

You can fill closed shapes and you can give shadows to both closed and open shapes.

Fills and shadows can be a solid or bitmap pattern. Fills can also be a gradient pattern. You choose colors
and a pattern from set lists to which you can add custom colors or patterns you create. 

Both fills and shadows function in the same way. The only difference is that a shadow is a copy of the 
shape that is offset from and behind the shape to which it's applied.

NOTE    If your display driver supports 16 colors or fewer, colors may be dithered when you apply a solid 
or gradient pattern to a fill or shadow. When you apply a bitmap pattern, Visio uses the closest 
approximation of the specified color. For example, orange may be mapped to yellow. 



To apply a fill to a closed shape:

1. Select the shape.

2. Choose Format > Fill.

NOTE    You can also use fill formatting palettes on the Shape toolbar. Pause the pointer over the 
palettes to see tips that identify them.

3. In the Fill section, choose options from the Pattern, Foreground, and Background lists. (You can also 
choose the same options in the Shadow section.) You can see how the options you select will look in 
the Preview box.

There are 40 patterns included with Visio: 0 is no pattern (transparent); 1 is a solid one-color pattern; 
2–24 are bitmap patterns; and 25–40 are gradient patterns (for fills only).

If you choose a bitmap pattern, Visio uses the foreground color for the pattern and the background 
color for the background.

4. Click Apply to apply the formatting options you've chosen and view the change before closing the 
dialog box, or click OK to apply the formatting and close the dialog box.

TIP    To hide a shape completely, apply to it a 0 (transparent) fill in the Fill dialog box and a pattern of 
None in the Line dialog box. You can also create shapes with transparent holes by using the Combine 
command. To temporarily hide a shape, assign the shape to a layer, then hide the layer in the Layer 
Properties dialog box.

    Overview



To apply a shadow to a closed or open shape:

1. Select the shape.

2. Choose Format > Shadow.

3. In the Shadow section, choose options from the Pattern, Foreground, and Background lists.

4. Click OK.

TIP    To delete a shadow, choose None from the Pattern list for Shadow.
    Overview



Changing the shadow offset for shapes
    Related Topics

Although each shape can have a shadow of a different color and pattern, all shadows on the same page 
are offset the same amount because shadows are a page property. You can change the size and angle of
the shadow offset for all the shapes on a page.

To change the shadow offset for a shape:

1. Choose File > Page Setup, then click the Page Properties tab in the Page Setup dialog box.

2. In the Shape Shadow Offset section, type values for the shadow offset in the Right and Down boxes.

To move shadows to the left or top of shapes, use negative values.

3. Click OK.



Applying custom line and fill patterns
    How To
    Related Topics

Visio includes a number of stencils that contain custom line and fill patterns and custom line ends. When 
you open these stencils, the patterns they contain appear as a choice in the Line and Fill dialog boxes. 
For example, you can open a custom hatch pattern stencil and then apply those hatch patterns as fills 
from the Fill dialog box. The custom patterns don't appear as masters on the stencil unless you open the 
original stencil, which gives you read/write access. This is because patterns are not true shapes, but 
attributes that you apply to shapes.

The way a custom pattern is created affects the way it behaves when you apply it to a shape. For 
example, some line patterns are set to scale with the line weight, so when a line is very fine, the pattern 
may be scaled so small that it's difficult to see. Also, some patterns may be set to take on the color of the 
shape they're applied to, while others are set to override the shape's colors with their own. 



To apply a custom pattern:

1. Open the stencil that contains the custom pattern you want to apply.

2. Select the shape to which you want to apply the custom pattern.

3. Choose Format > Line to apply a line or line-end pattern, or Format > Fill to apply a fill pattern.

4. To apply a line-end pattern, choose the custom pattern's name from the Begin or End list in the Line 
dialog box. To add a line or fill pattern, choose the custom pattern's name from the Pattern list. 

5. Click OK.

The shape displays the pattern. 

NOTE    If you apply a line pattern or line-end pattern and it doesn't look the way you expected it to (for 
example, you can't see it), try increasing the line weight. 
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Creating custom line and fill patterns
    How To
    Related Topics

If you want to use a fill pattern, line pattern, or line-end not available in Visio, you can create your own. 
Once you've developed a master fill or line pattern, you can apply the pattern to other shapes. When you 
create a custom line or fill pattern, you create it initially as a master pattern, which then appears as a 
choice in the Fill or Line dialog box and can be applied to other shapes in the drawing.

You can create a master pattern from a shape you create in Visio, or a shape that already exists, and set 
its properties, which affect how the pattern behaves. For example, you can choose how the pattern will 
appear when it is applied to a shape, how it responds when the shape is resized, or how it responds when
the drawing page scale changes.

For line patterns, you can set the following options.

Line pattern settings
To Use

Bend the pattern to the line, so that 
the pattern is tiled and distorted 
along the path of the line. The 
original line is no longer visible.

Tile multiple images along the line 
without distorting them

Stretch a single image along the 
line

Tile multiple images along the line 
without distorting them, while still 
retaining the line's original 
formatting

You can use a shape like a triangle to create a line pattern. The line pattern's properties affect how Visio applies the 
shape to a line. 

You can bend the pattern (A), tile it (B), stretch it the length of the line (C), or tile it while keeping the line's original 
formatting (D).

For line ends, you can set the following options.

Line-end settings
To Use

Orient the line end to the direction 
of the line

Orient the line end so that it is 
always upright



You can use a shape like an X to create a line end. The line end's properties affect how Visio applies the shape to the
end of a line. 

You can orient the line end to the direction of the line (A) or keep the line end upright, regardless of the line's angle 
(B).

For fill patterns, you can set the following options.

Fill pattern settings
To Use

Create multiple copies (tile) of the 
image to fill a shape

Use a single, centered, image

Stretch a single image to fill the 
shape

You can use a shape like a star to create a fill pattern. The fill pattern's properties affect how Visio applies the shape 
to a line. 

You can tile the pattern (A), use a single, centered image of it (B), or stretch it to fill the space (C).

For all types of patterns, you can choose to scale the pattern as the drawing page scale changes, or you 
can keep the pattern at a constant size.

Creating a pattern is a simple process, but keep in mind that developing a pattern that works a particular 
way requires a good understanding of how shapes work and may also require some trial and error testing.



To create a new master pattern and set its properties:

1. Open as an original file the stencil to which you want to add the new master pattern, or choose File > 
Stencils > Blank Stencil to open a new stencil. 

2. On the drawing page, create the shape or shapes you want to designate as a pattern. You can create 
shapes from scratch or modify existing shapes. To create a pattern from multiple shapes, select them 
all, then choose Shape > Grouping > Group.

3. Drag the shape or group from the drawing page and drop it into the stencil window to create a new 
master.

4. Right-click the new master, then choose Properties from the shortcut menu.

5. Type a name for the pattern in the Master Name section, select the alignment, size, and update options
for the master icon.

6. Select a type of master and behaviors you want for the shape, then click OK.

7. Save the stencil.

TIP    You can also create a new master by right-clicking the green stencil background and choosing New 
Master from the shortcut menu. In the New Master dialog box, choose the options you want, then click 
OK. Right-click the new master and choose Edit Master to open a drawing window where you can draw 
the shape or shapes you want to make up the pattern. 
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About creating and revising connected drawings
    Related Topics

Many drawings include lines, or one-dimensional (1-D) shapes, that indicate connections between two-
dimensional (2-D) shapes. These drawings are called "connected drawings," like flowcharts, which use 1-
D shapes to connect the stages in a process.

In Visio, these 1-D shapes are called "connectors," and they include special behavior to make it easier 
and faster for you to create, and later change, connected drawings. You can use this behavior¾called 
"glue,"¾to ensure that shapes that need to stay connected do so when you revise the drawing.

You can revise a connected drawing by using one of the following methods:

· Moving 2-D shapes. 

When you reposition 2-D shapes, connections remain intact, so you don't need to redraw them.

· Manually editing the paths of routable connectors by moving, adding, or deleting endpoints, midpoints, 
and vertices.

You can change the path a routable connector takes around shapes that lie between the shapes it 
connects.



Using glue to maintain shape connections
    How To
    Related Topics

Glue is what keeps shapes connected when you move them. When you want to reposition shapes in your
drawing, glue saves you the time it would take to drag each shape one at a time and re-attach 
connectors. 

While you're working with glue, it helps to keep the following in mind: 

· You can use dynamic or static glue to create connections between shapes or specific points on them.

· You can change glue settings to determine the types of points that connectors and shapes can glue to.

· You can add new connection points to shapes to make your connections more precise.



Gluing connectors to shapes or to specific points on them
You can glue connectors to shapes with

· Dynamic glue, in which the connector is glued to the shapes and changes the points at which it's 
connected when you reposition the shapes. Dynamic glue keeps the shapes connected at the closest 
available points. 

For example, dynamic glue is appropriate for a flowchart, which represents the flow of a process. Each 
subsequent step must be connected to the previous step, but the specific point on the shape 
representing the previous step doesn't matter. When you move a step, you want the connector to shift 
to the point on the previous step closest to the subsequent step's new location.

Dynamic glue    When you glue a connector to an entire shape, a box appears around the shape before you drop the
connector endpoint onto it. If you move one of the 2-D shapes, the connector adjusts to glue to the point that's closest
to the other shape.

· Static glue, in which the 1-D connector is glued to one specific point on each 2-D shape, and stays 
glued to those specific points when you reposition the shapes. 

For example, static glue is appropriate for an organization chart, which represents a reporting 
hierarchy. Position shapes appear under and are connected to the bottom center of Manager shapes. 
When you move a Position shape, you don't want the connector to shift to any other point on the 
Manager shape.

Static glue    When you glue a connector to a specific point on a shape, a box appears around that point before you 
drop the connector endpoint on the shape. If you move one of the 2-D shapes, the connector remains glued at the 
specific points.

Whether shapes use static or dynamic glue depends upon the method you use to connect them and the 
type of connector you use. With connectors that glue both statically and dynamically, you can switch 
between static and dynamic glue. Not all connectors can glue dynamically. For example, control-handle 
connectors that you drag from shapes can only glue to a specific point. 

TIP    You can recognize a properly-glued connector endpoint or control handle by the color of its selection
handle. When you select the connector, its glued endpoints or control handles are red. If an endpoint is 
light red and slightly larger than a normal selection handle, it's glued using dynamic glue. If it's darker red 
and is the same size as other selection handles, it's glued using static glue.

To switch from static to dynamic glue:

· Hold down the Ctrl key, then drag a connector endpoint away from the shape and then back to one of 
the shape's connection points.

When you drag the endpoint back to the shape, a box appears around the entire shape.

To switch from dynamic to static glue:



· Drag a connector endpoint away from the shape and then back to one of the shape's connection 
points.

When you drag the endpoint back to the shape, a box appears only around the connector endpoint.
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Setting glue options
You can control what types of objects shapes glue to and what their glue strength is. Glue strength is the 
amount of pull (measured in pixels) that a guide, selection handle, vertex, or connection point exerts. If 
you don't want endpoints to glue to guides or any points on shapes, you can turn glue off completely.

The glue settings you choose in the Snap & Glue dialog box apply to all shapes on the current drawing 
page. If you have more than one page in your drawing, you can set different glue options for each page.

TIP    Options you set in the Snap & Glue dialog box don't affect connections you make with the Connect 
Shapes command or with the connector tool.

To set glue options:

1. Choose Tools > Snap & Glue.

2. Under Currently Active, make sure the Glue option is checked.

3. Under Glue To, check the options you want, then click OK.
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Adding connection points to shapes
You can specify the points on a 2-D shape that connectors can glue to. If you need to show a connector 
attached to a particular location on a shape, you can add a connection point at that location. Connection 
points can lie on the perimeter, inside, or even outside the shape. They appear on the screen but don't 
print, and you can prevent connection points from appearing onscreen.

By default, 1-D endpoints and control handles glue to connection points ( ) on shapes. You can also choose to have 
endpoints glue to selection handles and vertices, and you can add new connection points.

To add a connection point to a shape:

1. Select the shape to which you want to add a connection point.

2. From the toolbar, choose the connection point tool ( ).

3. Hold down the Ctrl key and click on, inside, or outside the selected shape's boundaries.

TIP    To delete a connection point, click the point with the connection point tool (it turns magenta), and 
then press the Delete key.

To prevent connection points from displaying onscreen:

· From the View menu, choose Connection Points.

When the command is unchecked, connection points do not display onscreen.
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Adding connectors to your drawings
    How To
    Related Topics

Visio provides four main ways to add connectors to your drawings:

Drawing connectors with the connector tool    You can choose the connector tool from the Standard 
toolbar and then drag 2-D shapes from stencils to your drawing page. The shapes are connected when 
you drop them on the page. You can also draw connectors between shapes that are already on the page.

Pulling connectors from shapes    Some 2-D shapes include control handles that you can click and drag
to pull a connector from the shape.

Using the Connect Shapes command    You can connect a series of shapes at once by choosing 
Connect Shapes from the Tools menu to add connectors between the shapes. 

Dragging and dropping connector shapes    Many Visio stencils include connectors that you can drag 
to your drawing page and drop in place. 

Which method you use depends on the type of drawing you're creating, whether you expect to make 
extensive revisions later, and how much control you want over the connections you have.



Working with connectors
Connectors are 1-D shapes with endpoints. You glue these endpoints to 2-D shapes to create 
connections that are maintained when you reposition the 2-D shapes.

Connectors have begin points (A) and end points (B) that are indicated by an x and a + respectively.

Certain connectors, such as the Dynamic Connector and other routable connectors, also display 
midpoints and vertices when you select them. These points give you additional control over the 
connector's path from one shape to another. Vertices look the way they do on other shapes: green 
diamond-shaped handles. Midpoints look like control handles, that is, green squares with darker shading. 
You can set up a drawing so that routable connectors detect 2-D "placeable shapes" and draw paths 
around them rather than crossing through them.

Routable connectors display midpoints (A) and vertices (B) for additional editing capabilities.

To connect 2-D shapes with a Dynamic Connector using dynamic glue:

1. Display the drawing that contains the 2-D shapes you want to connect, and make sure a connector 
master is not selected on an open stencil (selected master icons are highlighted in blue).

2. Choose the connector tool ( ) from the Standard toolbar.

3. Position the connector tool over the center of the first shape, until a box appears around the 
entire shape, then hold down the mouse button and drag to draw a connector.
4. While holding the mouse button, position the connector tool over the center of the other shape, 
until a box appears around it, then release the mouse button.

NOTE    If a box appears around a particular point on the shape, you'll create a connector that's glued 
using static glue.

To connect shapes with Visio connectors:

1. Drag a connector from the stencil, and position one of its endpoints on a 2-D shape's connection point. 

The endpoint turns red to indicate that the shapes are glued.

TIP    In the Snap & Glue dialog box, you can also specify to glue endpoints to 2-D shapes' selection 
handles or vertices.

2. Drag the other endpoint to another 2-D shape.
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Connecting shapes as you drop them on the page
You can connect shapes as you drop them on the page by using the connector tool as you drag and drop.

As long as the connector tool is selected, if a connector master is not selected on the stencil, Visio adds a
Dynamic Connector between the selected shape and the next shape you drop onto the drawing page. To 
create new branches in a chart or diagram, select the shape from which you want to start the new branch,
then drag a new shape to the drawing page.

To connect shapes as you drag and drop them:

1. Make sure a connector is not selected on an open stencil. To cancel a master selection, click the green
stencil background with the pointer tool.

2. Choose the connector tool ( ) from the toolbar.

3. Drag and drop a 2-D shape from the stencil onto the drawing page.
4. With the first shape still selected, drag and drop another 2-D shape onto the drawing page.

Visio automatically connects the shapes with an instance of the Dynamic Connector.
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Dragging connectors from control handles on shapes
Some 2-D shapes, such as organization chart position shapes and the network Ethernet and ring shapes,
function as specialized connectors. These shapes have built-in connectors: control handles that you can 
drag and glue to other 2-D shapes.

Some shapes have control handles ( ) that you can drag to glue to other shapes.

You can often tell which shapes contain control-handle connectors by looking at master icons in the 
stencil. Connectors appear as yellow lines extending from the main shape.

To drag a connector from a control handle on a shape:

1. Drag and drop organization chart shapes or a ring or Ethernet shape from a network diagramming 
stencil.

2. Select a shape and position the pointer over the shape's control handle ( ).

3. Drag the control handle to a connection point on the other 2-D shape.
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Connecting a series of shapes at once
You can use the Connect Shapes command on the Tools menu to add connectors between multiple 
shapes at once in a drawing.

To connect a series of shapes at once:

1. Select the 2-D shapes in the order you want to connect them.

Click the first shape, then press the Shift key and click the other shapes. 

2. If you want to use a particular connector, select its master icon in the stencil.

If you don't select a connector, Visio uses the Dynamic Connector. If a connector is selected and you 
want to cancel its selection, click the green stencil background with the pointer tool.

3. Choose Tools > Connect Shapes or click the Connect Shapes button ( ).

Visio creates an instance of the connector and, if the connector you select can use dynamic glue, 
connects the shapes with dynamic glue.
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Displaying line jumps on crossing connectors
    How To
    Related Topics

In some drawings, such as flowcharts or network diagrams, connectors may cross over one another. In a 
complex drawing, it can be hard to follow the path of a connector if it crosses over another of the same 
type.

To make connections easier to follow when you or others analyze your drawing, you can have routable 
connectors display "line jumps," when they cross over other connectors. 

Line jumps (A) clarify the shapes that a connector connects to.



To enable line jumps and specify which connectors show them:

1. Display the drawing in which you want to display connector line jumps.

2. Choose File > Page Setup, then click the Page Properties tab.

3. Under Add Line Jumps To, select the type of connectors that, when two lines cross, display a line jump.
Choose one of the following:

None to turn off all line jumps.

Horizontal Lines to add a line jump to the connector that runs horizontally. 

Vertical Lines to add a line jump to the connector that runs vertically.

Last Routed Line to add a line jump to the connector you added or modified most recently (default).

NOTE    Changing this setting changes line jumps on connectors that already exist in the drawing, as 
well as those you add after changing the setting.

4. Click OK.
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Working with routable connectors and placeable shapes
    How To
    Related Topics

In some templates, such as those for creating flowcharts, organization charts, and network diagramming, 
the connectors are set up to draw a path around other shapes rather than crossing over them. These 
connectors are called "routable," and they work with 2-D shapes that are set to work with them, called 
"placeable shapes." 

When a routable connector encounters a placeable shape between the two shapes it connects, it draws a
path around the shape rather than crossing through it. Routable connectors can route around only shapes
set as placeable.

A routable connector can detect placeable shapes and change its path to avoid crossing through them.

A routable connector changes its path from one shape to another when you drop a placeable shape on 
top of a connector that's already in the drawing. 

After you glue a routable connector to a shape, you can manually edit the connector's midpoints and 
vertices to change the path it takes from one shape to the other. 

To change a routable connector's path manually, you can edit its midpoints (A), vertices (B), and endpoints (C). 
Endpoints and vertices look the same as they do on other 1-D shapes. Midpoints look like control handles¾green 
squares with darker shading¾but function differently on routable connectors.

If you use the connector tool or Connect Shapes command, you can create routable connectors by first 
making sure a connector is not selected on the stencil. When you do not select a connector, Visio 
connects shapes with a Dynamic Connector, which is always routable.



To set a 2-D shape as placeable:

1. Select the shape, then choose Format > Behavior.

2. Under Layout Behavior, choose one of the following:

Layout And Route Around to set the shape as placeable. 

Do Not Layout And Route Around to set the shape as non-placeable. (It does not become placeable 
even when you glue a routable connector to it.)

Let Visio Decide to have Visio determine when to make the shape placeable, according to the type of 
connector you glue to the shape. If you glue a Dynamic Connector to the shape, Visio makes it 
placeable.

3. Click OK.
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About working with text
    Related Topics

Text can clarify the meaning of your Visio drawings, list shape attributes, or document changes you or 
other Visio users make to a drawing. For example, you can 

· Describe the process a shape represents in a process flow diagram.

· Add title blocks and bulleted lists to your drawings.

· Add page numbers or footers to every page of a multiple-page drawing.

· Annotate a technical drawing.



Adding text to shapes and drawings
    How To
    Related Topics

You can add text to any Visio shape, including connectors, by selecting the shape and typing. You can 
also create text-only shapes to add titles and lists to a drawing. In a text-only shape, the shape has no 
line or fill, so only text you type in the shape is visible. Text-only shapes also enable you to add text to 
objects from other programs¾position the text-only shape where you want to type text for the imported 
object. 

The part of the shape in which you type text is called the text block. A text block can differ from its shape 
in size, angle, and relative location, so you can place text where you want it in relation to a shape. Each 
shape has only one text block.

When you select a shape with a non-text tool, such as the pointer tool, Visio selects all of the existing text 
so that when you type, the existing text is replaced with the new text. To select only a part of the existing 
text or to place an insertion point in the text, use the text tool ( ). The text tool selects the shape and 
opens the shape's text block. After you highlight text within a text block, you can delete, cut, copy, or 
format the selection, or you can type or paste to replace it. To add text without replacing any of the 
existing text, click with the text tool to place an insertion point where you want to type new text.

To rotate, resize, or move an entire text block, select its shape with the text block tool ( ). 

Methods for selecting text
To Use this 

tool
Take these steps

Select a text 
block

Click the shape with the
text block you want to 
select. If the handles 
are gray, the shape is 
grouped. Use the Open
Group command to 
view the shape in the 
group window.

Select all text in 
a block or, if 
there's no text, 
to display the 
insertion point

Double-click the shape.
Or select the shape, 
then press F2.

Select part of 
the text in a text 
block

Click the shape, then 
drag the insertion point.
Select all the text, then 
drag the insertion point.

Select a word or
paragraph

Click the shape, then 
double-click a word or 
triple-click a paragraph.

Place the 
insertion point in
text

Click the shape.

NOTE    Visio zooms in on the drawing when you select text so that you can see what you are typing. To 
return to the original magnification, press the Esc key on your keyboard or click anywhere outside the 
shape or text block after you type the text.





To type text in a shape:

1. Select the shape, then type the text.

2. When you finish typing, press the Esc key or click outside the text block.

To create a text-only shape:

1. Choose the text tool ( ) from the Standard toolbar.

2. Click where you want to start typing, or click and then drag until the text block is the size you 
want, then release the mouse button.
3. Type the text. 

When you start typing, Visio creates a text-only shape and zooms in on its text block.

4. When you finish typing, press the Esc key or choose the pointer tool from the Standard toolbar.

To turn off automatic zooming when editing text:

1. Choose View > Zoom > Custom. 

2. Uncheck Zoom When Editing Text.
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Cutting, copying, and pasting text
    Related Topics

You cut, copy, or paste text in Visio in the same way you do in many word-processing programs. You can 
also reverse text changes by using the Undo command.

NOTE    When you paste text from another application, the formatting information is lost.

Methods for cutting, copying, and pasting text
To Use this 

tool
Take these steps

Cut or copy 
selected text to 
the clipboard

Select the text, 
then press Ctrl+X 
to cut or Ctrl+C to 
copy.

Copy all text to 
the clipboard

Click the shape, 
then press Ctrl+C.

Paste text from 
the clipboard

Click to place the 
insertion point, then
press Ctrl+V.

Repeat a text 
action, such as 
pasting text

Press F4.



Editing existing text
    How To
    Related Topics

After you've added text to a shape, you can edit it by placing an insertion point into the text and typing. 
You can also edit existing text in shapes that come with Visio.

NOTE    Visio automatically zooms in on the drawing so that you can see what you are typing. To return to
the original magnification, press the Esc key or click anywhere outside the shape or text block after you 
type the text.



To edit existing text:

1. Double-click the shape to open the text block, or click the text with the text tool ( ) on the Standard 
toolbar.

2. Click where you want to place the insertion point.
You can move the insertion point by clicking anywhere in the text block or by using the arrow keys on 
the keyboard.

3. Type the new text, then press the Esc key.

NOTE    Double-clicking a grouped shape opens the group window rather than opening the text block. In 
the group window, you can double-click shapes within the group to edit their text blocks.
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To delete text from a shape:

1. Choose the text tool ( ) from the Standard toolbar.

2. Click the shape that contains the text you want to delete.
When you click the shape, the text block opens and the insertion point appears at the end of the text.

3. Select the text to delete, or press Ctrl+A to select all text in the text block.

4. Press the Delete key.

5. Choose the pointer tool from the Standard toolbar to close the text block.
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To delete a text-only shape:

· Select the shape with the pointer tool, then press the Delete key.
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Adding and editing text in groups
    How To
    Related Topics

In grouped shapes, such as the 3-D bar shapes in the charting stencils, Visio adds any text you type to 
the frontmost shape in the shape's stacking order. The group itself doesn't have its own text block.

You can change the stacking order of a group by using the Edit > Open Group command, then using the 
Shape > Bring To Front command to make the shape you want the frontmost shape.



To add or edit text in a shape within a group:

1. Select the group. 

Green selection handles appear on the group.

2. Click the shape you want to work with to subselect it. 

Gray selection handles appear on the shape.

3. Type to add or edit the text just as you would in an ungrouped shape.
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Setting, changing, and deleting tabs 
    How To
    Related Topics

You can use tabs to align text in table form or to create bulleted or numbered lists. Tabs can be left-, 
center-, or right-aligned. You can also use decimal tabs to align columns of numbers. A text block can 
have up to ten tab stops.

Tab options in Visio include Left alignment (A), Center alignment (B), Right alignment (C), and Decimal alignment (D).

NOTE    Tabs can only be applied to an entire paragraph, not to selections within a paragraph.

Tab positions are based on the width of the text block, not the width of the shape or the shape's distance 
from the edges of the page. If you are working at a scale of 1:1, you can make setting tabs easier if you 
move the horizontal ruler's zero point to the edge of the text block before you choose tab positions.

TIP    If you're working at a scale other than 1:1, such as ¼"=1', the rulers measure in drawing units (in 
this case, feet), while the tabs are measured in page units (in this case, inches). This difference can be 
confusing when you're trying to use the ruler to determine tab positions. You can use the rulers, it just 
requires a little math. For example, if your scale is ¼"=1', every foot on the ruler is ¼", so if you want to 
set a tab where the ruler reads 3', multiply 3 by ¼ and set your tab at .75".

        

Moving the zero point.

TIP    To set a tab that applies to the entire text block, click an insertion point anywhere within the text 
(without highlighting the text) or select the whole text block with the pointer or text block tool ( ).

Select specific paragraphs to set tabs for part of a text block.

Select a text block or place an insertion point in the text to set tabs for the whole text block at once.



To move the ruler's zero point to the left edge of a text block:

1. Select the shape with the text tool ( ) so you can see the edge of the text block.

2. Hold down the Ctrl key and point to the vertical ruler to the left of the drawing window, then drag a
vertical line to the left edge of the text block.

When you release the mouse button, the line disappears and the horizontal ruler's zero point appears 
at the left edge of the text block. 

TIP    To return the ruler's zero point to its original position after setting tabs, double-click the ruler 
intersection in the upper-left corner of the drawing page.
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To add tab stops to selected paragraphs:

1. Choose the text tool from the Standard toolbar, then select the shape to open the text block.

2. Select one or more paragraphs that you want to format.

3. Choose Format > Text to open the Text dialog box, then click the Tabs tab.

4. Click the Add button to open the Tab Properties dialog box, then type the position you want for a tab 
stop in the Position box. Choose an alignment option for the tab, then click OK in the Tab Properties 
dialog box.

The tab appears in the Tab Stops list.

5. Click OK in the Text dialog box.

TIP    If you're working at a scale other than 1:1, such as ¼"=1', the rulers measure in drawing units (in 
this case, feet), while the tabs are measured in page units (in this case, inches). This difference can be 
confusing when you're trying to use the ruler to determine tab positions. You can use the rulers, it just 
requires a little math. For example, if your scale is ¼"=1', every foot on the ruler is ¼", so if you want to 
set a tab where the ruler reads 3', multiply 3 by ¼ and set your tab at .75".

    Overview



To delete tab stops from selected paragraphs:

1. Select the shape.

2. Select one or more paragraphs that you want to delete tabs from.

3. Choose Format > Text to open the Text dialog box, then click the Tabs tab.

4. In the Tab Stop list, choose the tab stop you want to delete, then click Delete.

Repeat for other tab stops you want to delete.

5. Click OK.
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To change the position of a tab stop:

1. Select the shape.

2. Select the paragraph that includes the tab you want to move.

3. Choose Format > Text to open the Text dialog box, then click the Tabs tab.

4. In the Tab Stop list, choose the tab stop you want to move.

5. Click Edit to open the Tab Properties dialog box, enter a new value in the Position box, then click OK. 

The tab appears with its new value in the Tab Stops list. 

6. Click OK.

TIP    If you're working at a scale other than 1:1, such as ¼"=1', the rulers measure in drawing units (in 
this case, feet), while the tabs are measured in page units (in this case, inches). This difference can be 
confusing when you're trying to use the ruler to determine tab positions. You can use the rulers, it just 
requires a little math. For example, if your scale is ¼"=1', every foot on the ruler is ¼", so if you want to 
set a tab where the ruler reads 3', multiply 3 by ¼ and set your tab at .75".
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To set tabs for table text:

1. With the text tool, select an existing text block or shape.

2. Choose Format > Text to open the Text dialog box, then click the Paragraph tab.

3. Set Horizontal Alignment to Left and Indents to zero, then click OK.

4. Move the vertical ruler's zero point to the left edge of the text block. To do this, hold down the Ctrl key 
and drag from the vertical ruler.

5. Choose Format > Text to open the Text dialog box again, click the Tabs tab, then drag the Text dialog 
box so that you can see the text block.

6. Click Add in the Text dialog box to open the Tab Properties dialog box, enter the position and set the 
alignment for the first tab in your table, then click OK. 

Because you moved the zero point, you can set tab stops as the distance from zero.

7. Repeat step 6 for each tab in your table, then click OK in the Text dialog box.

TIP    If you're working at a scale other than 1:1, such as ¼"=1', the rulers measure in drawing units (in 
this case, feet), while the tabs are measured in page units (in this case, inches). This difference can be 
confusing when you're trying to use the ruler to determine tab positions. You can use the rulers, it just 
requires a little math. For example, if your scale is ¼"=1', every foot on the ruler is ¼", so if you want to 
set a tab where the ruler reads 3', multiply 3 by ¼ and set your tab at .75".
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Creating numbered and bulleted lists using tabs and indents
    How To
    Related Topics

You can create numbered and bulleted lists, using tabs and hanging indents. After you've set tabs and 
indents using the Format > Text command, you can type bullets or numbers before each paragraph. 

By using tabs in combination with paragraph indent settings, you can create bullet lists with hanging indents.

You can select the bullet and use the Font Size list on the toolbar to change its size.

NOTE    To create bullet lists quickly and automatically, use the bullets button on the Text toolbar or the 
Bullets tab in the Text dialog box.



To create a numbered list using tabs and indents:

1. Use the text tool to select an existing text block or shape. 

2. Choose Format > Text to open the Text dialog box, then click the Paragraph tab.

3. Set Horizontal Alignment to Left, then for Left enter a value that leaves enough room for a bullet and a 
blank space, such as 1 pica.

4. For First enter a negative value, such as 1 pica.

5. Click the Tabs tab, then click Add. For Position, enter the same value you used in step 3, then click OK.

To create a list item, type the number in the style you want, press Tab, then type.
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To create a bulleted list using tabs and indents:

1. Use the text tool to select an existing text block or shape. 

2. Choose Format > Text to open the Text dialog box, then click the Paragraph tab.

3. Set Horizontal Alignment to Left, then for From Left enter a value that leaves enough room for a bullet 
and a blank space, such as 1 pica.

4. For First Line enter a negative value, such as -1 pica.

5. Click the Tabs tab, then click Add. For Position, enter the same value you used in step 3, then click OK.

To create a list item, type the bullet (Ctrl+Shift+8) in the style you want, press Tab, then type. You can also
add bullets using the bullet tool on the Text toolbar.
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Creating bulleted lists automatically
    How To
    Related Topics

To create bulleted lists quickly and automatically, you can use the bullet button on the Text toolbar or 
choose an option in the Bullets tab in the Text dialog box. When you apply bullet formatting to a piece of 
text, each paragraph in the text becomes a bulleted item with a hanging indent.

The bullets Visio uses for bulleted lists do not change shape when you apply a different font to the list 
text. For example, if you apply round bullets to a list and then change the list text to Zapf Dingbats, the 
bullets remain round. However, if you change the font size of the list text, the bullets increase in size with 
the text. 

TIP    To create custom bullets or bullets that are a different size from the list text, create them manually 
using tabs and indents.



To create a bulleted list using the Bullets tab:

1. Use the text tool to select the list text or place a cursor in a text block where you want to type a bulleted
list. 

2. Choose Format > Text to open the Text dialog box, then click the Bullets tab.

3. Select a bullet option, then click OK.
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To create a bulleted list using the bullets button:

1. Use the text tool to select the list text or place a cursor in a text block where you want to type a bulleted
list. 

2. Click the bullet button on the Text toolbar.

The last bullet format that was chosen in the Bullets tab will be applied to the text.
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Adding annotation layers to drawings
    How To
    Related Topics

During the life cycle of certain types of technical drawings, an engineer or architect creates the drawing 
and then may forward the file to a manager, client, or quality assurance person, who marks changes to be
made. Using Visio, you can streamline this markup, or redlining, process by creating a separate layer for 
review comments. Placing the comments on a layer by themselves makes them easy to view, print, and 
color separately from the rest of the drawing, and makes the incorporation process easy and efficient.



To add and set up a separate layer for review comments:

1. In the drawing you want to add comments to, choose View > Layer Properties.

2. Click New, type Redlining, then click OK.

3. With the Redlining layer selected, click the Active button. A checkmark appears next to Redlining in the 
Active column.

4. With the Redlining layer selected, click the Color button, then choose a color from the Layer Color list. 
Click OK to close the dialog box.

TIP    If more than one person is reviewing a drawing, create a redlining layer for each reviewer and give 
each layer a different display color.

    Overview





About formatting text
    Related Topics

You can format text in your drawing by changing any one or all of the text's attributes, such as color, 
alignment, font, and size.

To change the appearance of your text:

· Use tools from the Text toolbar to apply local formatting.

· Use the commands on the Format menu to apply local formatting.

· Use the Text style lists to apply a style.

In addition to formatting text, you can format the text block that contains the text. You can change the 
background color, vertical alignment, margins, and rotation.



Applying text formatting
    How To
    Related Topics

You can choose from the following formatting methods according to the type of formatting you are doing.

The Text toolbar
By using the tools on the Text toolbar to apply local formatting to your text, you can quickly change size, 
color, font, style, indents, paragraph spacing, and bullets.

Format menu commands
Using the commands on the Format menu takes a little more time than using the toolbar, but you gain a 
degree of precision and a few additional options. For example, you can enter the precise font size you 
want and set text case and position in the Text dialog box.

The Text style list
When you format text using the text style list on the Text toolbar, you're actually applying a style. When 
you start a drawing with a Visio template, the template includes style definitions and the appropriate styles
appear in the style lists on the toolbar. It's best to use a style if you want to apply many formatting 
attributes to many different shapes. Using styles instead of local formatting can also reduce the file size of
your drawing and increase its performance. 



To display the Text toolbar:

· Choose View > Toolbars > Text. A checkmark next to a toolbar name indicates that it is currently 
displayed. 
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To quickly format individual paragraphs, words, or characters: 

· Choose the text tool ( ) from the Standard toolbar, select the text you want to format, then choose 
formatting options from the Text toolbar or Format menu.
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To format all the text in a shape's text block:

1. Select the shape with any tool that can select shapes. Or choose the text tool from the Standard 
toolbar, then click to place an insertion point in the shape.

2. Choose the formatting options you want from the Text toolbar or Format menu.
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To format text using the Text dialog box:

1. Double-click the shape to open the text block.

To format part of the text block, select the text you want to format.

2. Choose Format > Text, then click the Font tab.

3. Choose the formatting options you want. 

4. Click Apply to apply the attributes and continue working in the dialog box, or click OK to apply the 
attributes and close the dialog box.

    Overview



To format text using keyboard shortcuts:

1. Double-click the shape to open the text block, or click the text with the text tool.

2. To format part of the text block, select the text you want to format.

3. Use the following keyboard shortcuts to format the selected text.

Keyboard shortcuts
For Type

Bold Ctrl+Shift+B

Italic Ctrl+Shift+I

Small caps Ctrl+Shift+Y

Subscript Ctrl+Shift+X

Superscript Ctrl+Shift+Z

Underline Ctrl+Shift+U
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Changing the horizontal alignment, indentation, and spacing of paragraphs
    How To
    Related Topics

The alignment of text in shapes is determined in relation to the text block, not the shape or the drawing 
page. 

You can change the alignment and indentation of any paragraph with respect to its text block. For 
example, if you want to create a bulleted list or a table, you begin by aligning the text on the left side of 
the text block. If you want to create a hanging indent for your bullet list, you set the indentation of the left 
side and first line of each paragraph. And if you want to ensure that there are always four points of space 
after each bulleted item, you set the paragraph spacing.

This list uses left alignment, indentation to create hanging indents, and paragraph spacing after each item.



To change horizontal alignment of a paragraph:

1. Double-click the shape to open the text block, or click the text with the text tool ( ) on the standard 
toolbar.

2. Select the paragraph you want to format.
3. Choose Format > Text, then click the Paragraph tab.
4. For Horizontal Alignment, choose Left, Center, Right, Justify, or Force Justify.
5. Click Apply to apply the formats without closing the dialog box, or click OK to apply the formats and 

close the dialog box.
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To change the indentation of a paragraph:

1. Double-click the shape to open the text block, or click the text with the text tool ( ).

2. Select the paragraph you want to format.
3. Choose Format > Text, then click the Paragraph tab.
4. For Indentation, specify the indentation you want:

Enter a value for Left, such as 3p2 (3 picas, 2 points) to indent the whole left side of the paragraph.

Enter a value for Right, such as 1in (1 inch) to indent the whole right side of the paragraph.

Enter a value for First, such as 2cm (2 centimeters) to indent the left side of the first line of the 
paragraph.

5. Click Apply to apply the formats without closing the dialog box, or click OK to apply the formats and 
close the dialog box.
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To change the line spacing of a paragraph:

1. Double-click the shape to open the text block, or click the text with the text tool ( ).

2. Select the paragraph you want to format.
3. Choose Format > Text, then click the Paragraph tab.
4. For Spacing, specify the paragraph spacing you want:

Enter a value for Before to set the amount of space before the paragraph.

Enter a value for After to set the amount of space after the paragraph.

Enter a value for Line to set the amount of space between each line in the paragraph.

5. Click Apply to apply the formats without closing the dialog box, or click OK to apply the formats and 
close the dialog box.
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Changing vertical alignment and margins of text blocks
    How To
    Related Topics

In most cases, the vertical alignment of text within a text block is set to Middle by default, but you can 
change the alignment of any text block. You can also change the margins of a text block to add or delete 
space between the text block and the boundary of the shape. 

Using the commands on the Format menu gives you more precise control than dragging the borders of 
the text block, allowing you to ensure that your text is positioned properly with respect to the shape, even 
when you change the text. For example, you can set exact margins or make sure your text starts at the 
top of the text block instead of being aligned in the middle. 

TIP    If you want a shape's text to resize when you resize its shape, you can use the SmartShape Wizard 
to add formulas that change the default text behavior. 

You can use the toolbar buttons on the Text toolbar to align text vertically at the top, middle, or bottom of the text 
block. 



To change vertical alignment of text within a text block:

1. Select the shape you want to format.

2. Choose Format > Text, then click the Text Block tab.

3. From the Vertical Alignment list, choose a text alignment option.

4. Click OK.
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To change the margins between the text and the edge of the text block:

1. Select the shape you want to format.

2. Choose Format > Text, then click the Text Block tab.

3. In the Margins section, enter values such as 3p1 or .5in in the Top, Bottom, Right, and Left boxes to set
the text block margins.

4. Click OK.
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Rotating, resizing, and moving text blocks
    How To
    Related Topics

When you rotate, resize, or move a shape, its text block rotates, resizes, or moves with it. You can also 
rotate, resize, and move a text block separately from its shape using the text block tool on the Standard 
toolbar. This tool moves or rotates only the text block, whereas the rotate tool and pointer move or rotate 
the whole shape. 

In addition, Visio masters often include a control handle that you can use to reposition the text block, but if
you draw your own shape or want to change the text block size, you can move or resize a text block 
manually.



To rotate text independently of its shape:

1. Select the text block tool ( ). 

The text block cursor is a page ( ).

2. Click the shape to select its text block. 

Green handles appear around the shape, indicating that it is selected. If the handles are gray, the 
shape is grouped. Choose Edit > Open Group to view the shape in the group window.

3. Drag a corner handle to rotate the text block.

When it is over a rotation handle, the pointer changes to a pair of arrows forming a circle ( ). If the text
block is so small that you don't see rotation handles, drag the selection handle at the center of the 
shape to resize the text block until you see the rotation handles.

TIP    To rotate text in 90º increments, use the rotate text 90º tool ( ) instead of the text block tool.
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To resize a text block independently of its shape:

1. Select the text block tool ( ).

The text block cursor is a page ( ).

2. Click the shape to select its text block. 

Green handles appear around the shape, indicating that it is selected. If the handles are gray, the 
shape is grouped. Choose Edit > Open Group to view the shape in the group window.

3. Drag a side selection handle until the text block is the width or height you want.
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To move a text block independently of its shape:

1. Select the text block tool ( ). 

The text block cursor is a page ( ).

2. Click the shape to select its text block. 

Green handles appear around the shape, indicating that it is selected. If the handles are gray, the 
shape is grouped. Choose Edit > Open Group to view the shape in the group window.

3. Point to the dotted green line that indicates that the text block is selected.

When it is over the dotted line, the pointer changes to a double rectangle.

4. Drag the text block to a new position.

The text block remains part of the shape, so you can move the text block completely outside the 
shape's borders and it will still move, rotate, and resize with the shape, keeping its new position 
relative to the shape.
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Changing the background color of text blocks
    How To
    Related Topics

In most Visio shapes, the area around the text, or "text background," is transparent. You can apply color 
to text backgrounds to make them opaque, so elements of the shape don't show through and make the 
text unreadable. For example, you can add a text block background to "break" a connector line when it 
crosses through the text.

Changing the text background to solid white makes the connector line appear to "break" before and after the text 
block, ensuring the text is readable.

NOTE    Because the background color fills in the area around the text, the color only appears when the 
shape contains text.



To change the color of a text background:

1. Select the shape.

2. Choose Format > Text, then click the Text Block tab.

3. For Text Background, select Solid Color, then choose a color from the list.

The color fills the area around the text, not the whole text block.

4. Click OK.
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Copying text formatting to another shape
    How To
    Related Topics

If you're pleased with the text formatting of a particular shape, you can quickly transfer that formatting to 
another shape. With the Format Painter tool you can copy all text formatting¾the font, size, color, style, 
alignment, spacing, and text block background¾in one step, rather than having to change each setting 
individually on the new shape. 



To copy text formatting from one shape to another:

1. From the Standard toolbar, select the text tool ( ), then click the shape to open the text block with the 
text formatting you want to copy.

TIP    If Visio automatically zooms in on the text so that you can no longer see the other shape you 
want to format, press Ctrl+W to zoom out and display the entire drawing page in the Visio window.

2. Click the format painter button ( ) on the Standard toolbar.

The pointer changes to an arrow with a paint brush.

3. Click the new shape you want to format.

NOTE    This procedure copies text formatting only. To copy all shape formatting, in step 1, use the pointer
tool instead of the text tool to click the shape with the formatting you want to copy.
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About including other programs' data in Visio drawings
    Related Topics

You can use any one of the following methods to insert other programs' objects or files in Visio drawings:

· Embedding

· Linking

· Converting

· Importing

The method you choose depends on the type of object or file you want to include in your Visio drawing, 
and what you want to do with the object or file once it's there. 



Embedding objects in drawings
    How To
    Related Topics

Embed an object in your Visio drawing when you want to keep all the data you want to work with in one 
file, or if you want to transfer the file to other computers. You can embed data from programs that support 
OLE.

For example, if you want to distribute data about a department's computer equipment along with a 
network diagram you created in Visio, you can quickly embed a Microsoft Excel spreadsheet into the 
network diagram.

When you embed data from another program, Visio becomes the "container" for that data. The object 
embedded in the Visio drawing becomes part of the Visio file and, when you edit the data, you open its 
program from within the Visio drawing. 

The changes exist only in the Visio drawing, so it's not necessary to keep that data in a separate file. If 
the data does exist in a separate file, the original file does not change when you change the embedded 
object in Visio. Also, changes to the original file do not affect the embedded object in the Visio drawing.



To embed another program's object in a Visio drawing:

1. Open the file that contains the data you want.

2. In the file, select the data you want to embed in the Visio drawing.

3. Choose that program's command to place data on the Clipboard.

Usually the command is Edit > Copy.

4. In the Visio window, display the drawing in which you want to embed the object.

5. Choose Edit > Paste or click the Paste button ( ) on the Standard toolbar.

The data on the Clipboard is pasted into the drawing as an embedded object. The object appears in 
the center of the view, but you can select and move it as you would any Visio shape.
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To embed an object from an existing file within Visio:

1. Choose Insert > Object, then, in the Insert Object dialog box, select Create From File.

2. Type a path and file name in the text box. 

Click Browse to look for the file if you're not sure of its path or file name.

3. Check Display As Icon if you want that program's icon to appear in the drawing instead of the data.

4. Click OK.

The first page of the file appears in the Visio drawing, unless you chose to display it as an icon. You 
can select the object and drag to reposition it.
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To create a new embedded object from within Visio:

1. Choose Insert > Object, then, in the Insert Object dialog box, select Create New.

2. From the Object Type list, select the type of object you want to create, then click OK.

The program for creating that object opens within Visio. If the program is compatible with OLE 2, it 
opens in place in the Visio drawing, otherwise the program opens in its full window.

3. Create the object in the other program.

4. If the program is running in place, click anywhere outside the embedded object to close the program. If 
it's running in its full window, from the program's File menu, choose Exit.

    Overview



Linking objects to drawings
    How To
    Related Topics

If another program supports OLE, you can link its data to Visio drawings. Use linking when you want to 
include the same data in many files. When you update the data, all links to other files reflect the changes.

For example, if you created your company logo in an OLE-compatible drawing program, and you want to 
include the logo in every flowchart, organization chart, and network diagram you create in Visio, you can 
link the logo to each Visio drawing. When you change your original logo in the drawing program, the Visio 
drawings update automatically.

When you link data from another program, the Visio drawing stores only a reference to the location of the 
file in which you created the data. You link data from a saved file, so Visio can find the data and display it.

Because linking adds only a reference to a file, the data does not significantly increase the file size of the 
Visio drawing. However, links require a little more maintenance. If you move any of the linked files, you 
need to update links. In addition, if you want to transport linked data, you must include all linked files.

You can update a linked object automatically every time you open the drawing or choose to do so only 
when you explicitly request it. Any time a link is updated, changes made to the object in its original file 
appear in the Visio drawing, and will appear in the original file if the changes were made through Visio.



To link a file to a Visio drawing:

1. Save the original file.

Because a link consists of a reference to the original file, you must save the file before you can link to 
it.

2. Select the data you want in the Visio drawing.

3. Choose the command used by that program to place data on the Clipboard.

This is usually the Edit > Copy command.

4. Display the Visio drawing to which you want to link the file.

5. In Visio, choose Edit > Paste Special, then, in the Paste Special dialog box select Paste Link.

6. Click OK.
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To create a linked object from within Visio:

1. Display the Visio drawing in which you want to display the linked object.

2. Choose Insert > Object.

3. In the Insert Object dialog box, select Create From File.

4. Type a path and file name in the text box. 

Click Browse to look for the file if you're not sure of its path or file name.

5. Check the Link box.

6. Check Display As Icon if you want that program's icon to appear in the drawing instead of the data.

7. Click OK.

The first page of the file appears in the Visio drawing, unless you chose to display it as an icon. You 
can select the object and drag to reposition it.
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Updating and managing linked objects
    How To
    Related Topics

When you include linked objects in a Visio drawing, you need to decide how you want to update the 
objects when the original file changes. If you move or rename the original file, you also need to update the
links in the Visio file. 

By default, links for an object update automatically when you open a drawing that includes the object. If 
you open a drawing that includes a linked object for which Visio cannot find the original file, Visio prompts 
you to update links manually. If the object's program is not available¾for example, if you open a drawing 
on a system that doesn't have that program installed¾Visio displays another prompt. The visible 
representation of the object in the drawing is not affected, but because the object's program is not 
available, there isn't a working link between the Visio drawing and the object's file, so you cannot edit it.



To set a link so you can update it manually:

1. Choose Edit > Links.

2. Select the link you want to update manually.

3. Select Manual, then click Close to close the dialog box.
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To update a link manually:

1. Choose Edit > Links.

2. Select the link you want to update.

3. Click Update Now, then click Close.
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To change a link:

1. Choose Edit > Links.

2. Choose the link you want to change.

3. Choose the appropriate settings. 

To have Visio update the link automatically, choose Automatic. 

To update the link by using the Links command, choose Manual.

To open the object's program and edit the object, click Open Source.

To link a different file to the Visio drawing, click Change Source. 

When you finish viewing and changing links, click OK in the Change Source dialog box.

4. In the Links dialog box, click Close.
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To break a link:

1. Choose Edit > Links.

2. Choose the link you want to break.

3. Click Break Link.

Visio displays a warning that breaking the link will disconnect the object from its source. Click Yes to 
proceed. Visio converts the object to a metafile in the drawing and discards the reference to its original 
file.

4. Click Close.

NOTE    You can also break a link between an object and its original file by converting it to a Visio shape 
with the Convert To Group command.
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Pasting data in particular formats
    How To
    Related Topics

Most OLE-compatible programs place data on the Clipboard in more than one format to make the data 
usable to more programs. When you paste another program's data into Visio, by default it's embedded 
into the Visio drawing in its original format. That way, you can open the embedded data in its native 
program from within the Visio drawing.

Sometimes you may want to use a different format. For example, if you typed text in a Microsoft Word 
document, and want it to appear within a Visio shape's text block, you can copy the text in Word, then 
paste it into the text block as ANSI text rather than embed it as a Word document. In this example, the 
text is formatted according to the styles set for the shape's text block.



To paste data into a drawing in a particular format:

1. In the other program, choose the command to copy the data you want to paste into the Visio drawing.

This command is usually Edit > Copy.

2. Display the Visio drawing that you want to paste the data in.

3. Choose Edit > Paste Special.

4. In the Paste As box, select the format you want, then click OK.
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Editing objects from other programs
    How To
    Related Topics

After you embed or link an object from another program into a Visio drawing, you can modify the object in 
several ways. You can

· Edit the object in place so you can see how changes affect the way it fits into the drawing.

· Convert the object to another format.

· Change the appearance of the object's border.



Editing an embedded or linked object from within Visio
You can modify an embedded or linked object in its original program from within Visio. When you modify 
an embedded object, you change only the object in Visio, not its original file (if you pasted the object from 
an existing file). When you modify a linked file, you open and change the original file.

Most programs include a submenu of actions you can perform on an embedded or linked OLE object. 
Usually, the commands for editing OLE objects are Edit and Open. If the object is embedded and its 
program supports in-place editing, the Edit command opens the object in place. The Open command 
opens the object in the full program window. In Visio, this command appears at the bottom of the Edit 
menu.

To edit an embedded or linked object:

· In the Visio drawing, double-click the object.

If the object is embedded and the program in which you created the object supports in-place editing, 
the object opens in place. If the object is linked, or its program does not support in-place editing, the 
other program opens in its full window and displays the object.

TIP    To open an object in its full program window, even if it supports in-place editing, select the object, 
then choose Edit > [Object Name] > Open.
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Converting pasted or imported metafiles to Visio shapes
You can convert pasted or imported metafiles to Visio groups or shapes. If a linked or embedded object is 
represented by a metafile, you can also convert the object; however, doing so breaks the object's link to 
its original file, so you can no longer edit it in its original program.

To convert a pasted or imported metafile:

1. Select the object you want to convert.

2. Choose Shape > Grouping > Convert To Group.

TIP    If you want to edit individual components of the object after you convert them, choose Ungroup 
rather than Convert To Group.

A metafile may contain a bitmap as a component or may consist solely of a bitmap. Bitmaps cannot be 
converted to Visio shapes because, in a bitmap, Visio cannot determine what part of the object is a line, 
what is text, and so on.

A metafile that consists of a single bitmap usually stores the bitmap in segments. When you convert such 
a metafile to Visio shapes, each segment of the metafile becomes an individual bitmap object. In this case
you may want to convert the metafile to a group rather than ungrouping it to keep the bitmaps together.
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Changing an object's appearance
You can format an object from another program in the following ways:

· You can apply a line style or attribute to change the appearance of the object's border. For example, 
you might choose a distinctive outline for embedded or linked objects to indicate they can be edited 
from within a drawing.

· You can apply a fill style or attribute to change the fill color and pattern of the object. For the fill color 
and pattern of an object to be visible, there must be some empty space around the object, or 
background, within its border.

To format an object from another program:

1. Select the object you want to format.

2. From the Format menu, choose

Line to change the appearance of the object's border.

Fill to change the appearance of the object's background.

Shadow to add a drop shadow to the object.

3. Click OK.
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Importing non-Visio files as graphic images
    How To
    Related Topics

Importing provides an alternative to linking or embedding an object when you want to include data from 
another program that is not compatible with OLE. When you import data into a Visio drawing, it only exists
in Visio as a picture. That is, the only editing capabilities you have are resizing, repositioning, and 
cropping.

To do this, you export the other program's file to a format Visio can import. When you export, the file's 
data is directed through a filter that translates it and saves it to a separate file in a different format. Then, 
when you import the file into the Visio drawing, Visio uses a filter to translate the data and display the file.

Importing also works well if you only want to view or annotate the image in the Visio drawing, or if file size 
is your primary concern.

Because the data can go through up to two translations before it appears in the Visio drawing¾one when 
you export from the other program, and one when you import into the Visio drawing¾the picture may not 
look exactly the way it does in the original program.



Compatible file formats
In Visio you can import files of these formats:

· ABC FlowCharter 2.0, 3.0, 4.0 (.af3, .af2)

· Adobe Illustrator File Format (.ai)

· AutoCAD Drawing File Format R10-R13 (.dwg)

· AutoCAD Drawing Interchange (.dxf)

· AutoCAD Drawing Web Format (.dwf)

· CompuServe Interchange Format (.gif)

· Computer Graphics Metafile (.cgm)

· Corel Clipart (.cmx)

· CorelDRAW! Drawing File Format, version 3.0, 4.0, 5.0, 6.0 and 7.0 (.cdr)

· CorelFLOW 2.0 (.cfl)

· Encapsulated PostScript (.eps)

· Initial Graphics Exchange Specification (.igs)

· Joint Photographic Experts Group (.jpg)

· Macintosh Picture File Format (.pct)

· Micrografx Designer Version 3.1 File Format (.drw)

· Micrografx Designer Version 6.0 File Format (.dsf)

· Portable Network Graphics (.png)

· Tag Image File Format (.tif)

· Text and Comma Separated Variable (.txt and .csv)

· Windows Bitmap (.bmp and .dib)

· Windows Metafile (.wmf)

· ZSoft PC PaintBrush Bitmap (.pcx)

Most files you import into Visio drawings as graphic images appear as metafiles. However, bitmap files, 
such as .dib, .bmp, .pcx, and so on, remain bitmaps in the Visio drawing. 

With some vector-based graphics, such as Adobe Illustrator (.ai), CorelDRAW! (.cdr), Encapsulated 
PostScript (.eps), and Micrografx Designer (.drw) files, lines may appear jagged in the Visio drawing. You 
may get better results with these file formats if you convert rather than import them.

For most files you import, Visio displays an import settings dialog box where you can specify how you 
want the imported file to appear in a drawing. For example, if you're importing a file in .pct format, you can
specify whether to retain gradients and background and how to translate colors.

To import a non-Visio file as a graphic image:

1. Display the Visio drawing that you want to import the graphic into, then choose Insert > Picture.

2. Under Files Of Type, select the file format you want to import, then, under File Name, type the path and
file name of the file you want to import, then click Open.

If you don't know the path and file name, you can look for the file in the Look In section of the dialog 
box.



TIP    If you want to modify a graphic image after you import it, and if the image is a metafile, you can 
ungroup it. Ungrouping converts the picture to Visio shapes you can use the way you use shapes that 
come with your Visio product. This procedure works only for metafiles¾Visio cannot convert bitmaps to 
shapes. To make the converted graphic easier to edit, you can use the Fit Curve command. 
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Viewing AutoCAD DWG files in Visio
If you collaborate with AutoCAD users in the process of creating a drawing, you may need to review and 
annotate the drawing, then return it to your colleague to incorporate your ideas. With Visio, you can 
view .dwg drawings created in AutoCAD R10–13, then add your comments on a separate annotation layer
in Visio. 

To view an AutoCAD drawing in Visio:

1. In Visio, choose File > Open.

2. Under Files Of Type, select AutoCAD Drawing (*.dwg).

3. Under Look In, find the folder that contains the file you want and select the file, then click Open.

To add a separate annotation layer:

1. While the AutoCAD drawing you want to annotate is open, choose View > Layer Properties.

2. Click New. In the New Layer dialog box, type Redlining, then click OK.

3. In the Redlining row of the Layer Properties dialog box, click the column titled Active. A check mark 
appears in the column.

NOTE    Make sure not to click the Active button at the top of the column. This checks all rows, not only 
the Redlining row.

4. In the Redlining row, click to check the Color column.

5. In the Layer Color box at the bottom of the dialog box, select the color for your comments, then click 
OK to close the Layer Properties dialog box.
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Converting non-Visio files to shapes and drawings
    How To
    Related Topics

When you open a file of a format compatible with Visio, Visio converts the file to a drawing with 
SmartShapes symbols. Convert data to Visio shapes when you want to transfer shapes you created in 
another program to a Visio drawing, so you can edit them in ways other than resizing or repositioning, as 
well as save them as masters onto stencils.

You can edit the converted shapes as any other Visio shapes using the Visio formatting and drawing 
tools. You can also flip, rotate, and resize them. However, with bitmap formats (BMP, DIB, PCX, and so 
on), Visio pastes the contents of the bitmap into the drawing without converting it.

Files you convert are larger in size than files you import as graphic images. If file size is your main 
consideration, you may want to import the data.



Converting ABC FlowCharter and CorelFLOW! files
For ABC FlowCharter 2.0, 3.0, and 4.0 and CorelFLOW 2.0 files, Visio includes masters that match 
shapes provided with those programs (all of the FlowCharter shapes, and many of the CorelFLOW 
shapes). When you open a file of one of these formats, Visio converts the FlowCharter or CorelFLOW 
images to the shape equivalents.

To convert a file to a Visio drawing and shapes:

1. In Visio, choose File > Open.

2. Under Files Of Type, select the file type you want to open, then under File Name, type the path and file
name, then click Open.

If you don't know the path and file name, you can find it in the Look In section of the dialog box.
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About printing drawings
    Related Topics

For the most part, you can print your Visio drawings by choosing Print from the file menu, and then 
clicking OK. Most Visio templates are set up so that the drawing-page and printed-page sizes are the 
same, so you don't have to change page settings to get the printed drawing you expect.

Sometimes, however, you may want to change the size, orientation, or scale of the drawing page as you 
create your drawing. If so, you'll need to keep the following terms in mind as you set up your drawing for 
printing:

· The "drawing page"¾the white page you see onscreen.

· The "printed page"¾the paper in the printer on which you print your Visio drawing.

· The "printed drawing"¾your end result: the image on your drawing page printed onto one or more 
printed pages.

If you change drawing-page settings, to make sure the drawing prints correctly, you may need to change 
the printed-page settings as well.

For example, if you base a new drawing on a flowchart template with a portrait (tall) drawing-page 
orientation, but you create a left-to-right flowchart, you may want to change the drawing-page orientation 
to landscape (wide). To print the drawing the way it appears on the screen, you also need to change the 
printed-page orientation.

If you work with large drawings, it's possible to have a drawing page that's larger than the printed page. 
For example, if you want to create a large network diagram, you may want to increase the size of the 
drawing page that opens with the network template. If you increase the drawing-page size but don't 
change the paper in your printer, when you print the drawing, Visio "tiles" it, or prints it over multiple 
pages.

For multiple-page drawings, you can choose to add headers, footers, and page numbers to the printed 
drawing.



Previewing drawings before you print
    How To
    Related Topics

Before you print a drawing, you can preview it to see whether the shapes on the drawing page fit as you 
intend on the printed page. In the print preview window, gray lines indicate where the drawing continues 
onto multiple pages, or "tiles."

If the print preview window shows that the drawing will tile, you may want to reposition some shapes so 
they print on the correct page. To see how repositioning shapes on the drawing affects the printed page, 
you can display the drawing window alongside the print preview window.

If, after you see the print preview, you want to make changes to the drawing page or printer settings, such
as orientation, size, margins, and so on, choose Page Setup from the File menu.



To preview a drawing before printing:

· From the Standard toolbar, choose the Print Preview button ( ).

TIP    While working with your drawing you can quickly determine whether it fits within the printable area 
by choosing View > Page Breaks.
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To edit a drawing while in Print Preview:

1. In the print preview window, choose Window > New Window.

Visio opens a new drawing window and displays the drawing.

2. Choose Window > Tile.

Visio displays the drawing in the print preview window and the drawing window.

3. In the drawing window, edit the drawing using the Visio tools and commands.

Changes you make to the drawing appear in the print preview window.
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Changing margins and centering drawings
    How To
    Related Topics

To fine-tune a drawing's placement on the page, you can center it on the drawing page before you print, 
or you can adjust the margins or center the drawing on the printed page only. 

To center a drawing on the drawing page:

· Choose Tools > Center Drawing.

Visio centers the drawing. If the drawing page and printer paper are the same size, the drawing will be 
centered on the printed page as well.



Repositioning a drawing on the printed page
Before you can reposition a drawing on the printed page, you must adjust the drawing-page size to 
eliminate all the white space around the drawing. It's best to use this method when you want to print a 
completed drawing.

To adjust the drawing-page size to fit the drawing contents:

1. Choose File > Page Setup.

2. For Page Size, select Size Page To Fit Drawing, then click OK.

The page size changes to fit the drawing without any surrounding white space. Onscreen it may 
appear as though you zoomed in on the drawing. 

NOTE    If you want to add shapes later, you may need to open the Page Setup dialog box again to set the
drawing page back to its original size.

After you size the page to fit the drawing, you can adjust the drawing's placement on the printed page by 
changing margins or centering the drawing. 

To change margins or center a drawing on the printed page:

1. Choose File > Page Setup, then, in the Page Setup dialog box, click Print Setup.

2. For Margins, type the margin settings you want.

To center the drawing, under Center, check Left/Right, Up/Down, or both.

TIP    To preview the drawing as it will appear on the printed page, choose File > Print Preview.
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Printing drawings to paper or files
    How To
    Related Topics

For many drawings, you can use the default printer settings. You can print an entire drawing or a range of 
pages and you can center a drawing on a page before you print. You can also print to a PostScript file if 
you want to send a drawing to another printer or deliver a file to a service provider to produce.

Visio templates are set up to print to your default Windows printer. However, you may sometimes want to 
print to a different printer or change the properties set for your default printer. 



To choose a printer or change printer settings:

1. Choose File > Page Setup.

2. Click Print Setup, then click Printer.

3. For Name, select a printer from the list, then click OK.

4. In the Print Setup dialog box, choose the settings you want, then click OK.

5. Click OK in the Page Setup dialog box.

Visio redraws the drawing page with the new settings. 
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To print a drawing:

1. Choose File > Print.

2. In the Print Range section, choose an option for which pages to print:

Choose All or Current Page, or specify a range of pages in the Pages From and To boxes.

If a foreground page is displayed, choosing the Current Page option prints the foreground page, its 
background, and subsequent background layers. If a background is displayed, Current Page prints that
background page and subsequent background pages.

3. For Copies, enter the number of copies you want.

4. For Printer, specify to print to a file or to print all colors as black.

5. Click OK.

TIP    In Windows 95, to send a file to a printer, you can also drag the file icon from the desktop or from 
Windows Explorer and drop it on a printer icon.
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To print a drawing to a PostScript file:

1. Choose File > Print.

2. For Name, select a PostScript printer from the list.

3. Check Print To File, then click OK.

4. In the Print To File dialog box, choose a location and type the name of the file, then click Save.
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Printing large and small drawings
    How To
    Related Topics

If the size of a drawing is larger than the paper in your printer, Visio tiles the drawing¾that is, the drawing 
prints across several sheets of paper. Visio does not crop a drawing to fit within the margins.

A drawing on a large drawing page will print by tiling across several sheets of printer paper.

Small drawings print on part of a page. By changing margin settings, you can print a small drawing at 
various locations on a sheet of paper.

You can control where the image on a small drawing prints on a printed page.



Printing large drawings
You can control the way large drawings tile. For example, you can control the amount the drawing 
overlaps on adjacent pages. You can also specify the number of pages across which a drawing tiles. Visio
reduces or enlarges the drawing to fit the number of pages you specify.

To determine whether a large drawing will tile:

· Choose View > Page Breaks.

Gray lines appear on the drawing page, indicating the printed page size and margins selected in the 
Print Setup dialog box.

To increase the area where tiled drawings overlap:

1. Choose File > Page Setup, then, in the Page Setup dialog box, click Print Setup.

2. Type larger amounts for the margin settings, then click OK.

The larger the margins, the greater the overlap.

3. Click OK in the Page Setup dialog box.

To specify the number of pages for a tiled drawing: 

1. Choose File > Page Setup, then, in the Page Setup dialog box, click Print Setup.

2. For Reduce/Enlarge, select Fit On, and then specify the number of sheets across and down.

TIP    Choose the number of pages that represents an area proportionate to the drawing page. For 
example, if the drawing is square and you specify two sheets down and four sheets across, Visio fits 
the drawing on an area that is no more than two sheets either way so the drawing stays in proportion.

3. Click OK in both the Print Setup and Page Setup dialog boxes.
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Printing small drawings
If your drawing onscreen is smaller than the size of the paper you're printing it on, you can specify its 
position on the printed page. Before you can control its position, you must adjust the drawing-page size to
eliminate all the white space around the drawing.

To adjust the drawing-page size to fit the drawing contents:

1. From the File menu, choose Page Setup.

2. For Page Size, select Size Page To Fit Drawing, then click OK.

The page size changes to fit the drawing without any surrounding white space. Onscreen it may 
appear as though you zoomed in on the drawing. 

NOTE    If you want to add shapes later, you may need to set the drawing page back to its original size.

After you size the page to fit the drawing contents, you can specify the drawing's placement on the printed
page. 

To specify where on the page a small drawing prints:

1. Choose File > Page Setup, then, in the Page Setup dialog box, click Print Setup.

2. Select the combination of margin and center settings to place the drawing at the location you want, 
then click OK.

3. Click OK in the Page Setup dialog box.
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Reducing and enlarging drawings for printing
    How To
    Related Topics

To print a drawing at various sizes, or to fit a drawing within the printable area of the paper, you can 
reduce or enlarge a drawing for printing. 

Because Visio treats the drawing page itself as part of the drawing, you must adjust the drawing-page 
size onscreen to eliminate all white space around the drawing to get the results you expect when reducing
or enlarging a drawing. 



To reduce or enlarge a drawing:

1. Choose File > Page Setup.

2. For Page Size, select Size Page To Fit Drawing, then click OK.

The page size changes to fit the drawing without any surrounding white space. Onscreen it may 
appear as though you zoomed in on the drawing. 

3. Choose File > Page Setup, then click Print Setup.

4. For Reduce/Enlarge, select one of the following options:

To specify a percentage, select Scale, then type the percentage by which you want to enlarge or 
reduce the drawing. To reduce the drawing, type a number less than 100; to enlarge it, type a number 
greater than 100.

To specify a number of pages, select Fit On, then type the number of pages across and down on which
you want the drawing to print.

5. Click OK in both the Print Setup and Page Setup dialog boxes.

6. Choose File > Print Preview to make sure the drawing is the correct size and prints where you want it 
to on the page, and on the correct number of pages.

NOTE    If you want to add shapes to the drawing later, you may need to set the drawing page back to its 
original size.
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Printing selected shapes or pages
    How To
    Related Topics

When you don't want to print your entire drawing, you can print only pages you specify, only the currently 
displayed page, or only a page's background. You can also define shapes or layers as non-printing so 
they show up on the screen but not on the printed page. 

The printed page includes all background and foreground shapes except the non-printing shape.

A Background shapes 

B Foreground shapes

C Shape assigned to a non-printing layer

D Printed page



To print only the pages you specify:

1. Display the drawing you want to print, then choose File > Print.

2. Under Page Range, click Pages, then type the page number range in the From and To boxes.

To print only the page that's displayed onscreen, click Current Page.
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To print a background separately:

1. Display the background you want to print.

2. Choose File > Print.

3. Under Page Range, click Current Page, then click OK.

TIP    To print a page without its background, display the page and cancel its background assignment 
before printing. To cancel a background, choose File > Page Setup, then click the Page Properties tab. 
Under Background, select None, then click OK. After printing, you can reassign the background by 
selecting it from the list of backgrounds on the Page Properties tab.
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To set a shape as nonprinting:

1. Select the shape, then choose Format > Behavior.

2. Check Non-Printing Shape, then click OK.

TIP    To set all shapes on a layer to nonprinting, you can choose View > Layer Properties to set the layer 
to nonprinting.
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Printing headers, footers, and page numbers
    How To
    Related Topics

When you print a multiple-page drawing you may want certain information, such as the name of the 
drawing file, a border, or your company logo, to appear on each page. You may also want each page 
numbered automatically.

By using backgrounds and data fields, you can easily set up items that automatically appear and print on 
every page of a drawing. In addition, for certain common items, such as page numbers, the drawing file 
name, and the date and time, you can apply headers, footers, and page numbers that appear in the 
printed drawing only.



Adding headers, footers, and page numbers to the printed drawing only
You can add automatic headers, footers, and page numbers on the Headers/Footers tab of the Page 
Setup dialog box. You type formatting codes for common elements, such as page number, time, and date,
and specify whether you want the elements to appear in the upper or lower left, center, or right portion of 
the page. 

A formatting code is simply an ampersand (&) followed by a letter. For example, to add a page number, 
type &p.

Header and Footer formatting codes
For Type

Page number &p

Current time &t or &T

Current date &d (short) or &D (long)

Ampersand &&

File extension &e

File name &f

File name and extension &f&e

Page name &n

Total printed pages &P

To add headers, footers, or page numbers to the printed drawing only:

1. Open the drawing, and choose File > Page Setup, then click the Header/Footer tab.

2. For Header and Footer, type the formatting code you want in the box that corresponds to the section of
the printed page on which you want the header or footer to appear.

3. For Margins, type a value to specify how far the header or footer prints from the top or bottom of the 
page. 

4. To open the Font dialog box and edit the header or footer text, click Choose Font.

5. Click Apply to apply the header/footer settings and continue working in the dialog box. Click OK to 
apply the settings and close the dialog box.

To add a custom header or footer that appears on the drawing page and the printed page:

1. Start a new drawing and, on the Page Properties tab in the File > Page Setup dialog box, make the 
first page a background.

Note the name of this page¾you'll need to use it when assigning the background to a foreground.

2. On the background, add any shapes you want to repeat on each page of the drawing, for example, a 
company logo, a border, or a text field that displays up-to-date drawing information.

TIP    For border shapes, choose File > Stencils > Visio Extras > Borders.

3. Insert a new page, and, on the Page Properties tab in the File > Page Setup dialog box, make this 
page a foreground. Under Background, assign the background you just created.

4. Click OK.

NOTE    Setting up drawing elements that repeat on each page works best when you're starting a new 
drawing. If you start by creating the background and assigning it to the first foreground page, it is 



automatically assigned to each subsequent page you add within the file.
    Overview





About converting shapes and drawings to HTML
    Related Topics

You can easily prepare Visio drawings so they can be viewed using a World Wide Web browser. You can 
prepare drawings in two ways:

· Save them as HTML pages. For example, you have a new departmental organization chart you want 
everyone in the company to see. To immediately make the chart available on the intranet, save it as an
HTML page.

· Export them in .jpg, .gif, or .png format. For example, you have a Web page on the intranet where you've 
explained the complex process your department uses to handle customer inquiries. Recently, you 
created a block diagram that makes the process easier to understand. To include the graphic on your 
existing Web page, export it as a .gif, and add an <IMG> tag to your Web page HTML code.

Save drawings as HTML pages when

· You want to simultaneously export more than one page of a multiple-page drawing.

· Shapes in your drawing include navigational links (hyperlinks) and you want to make your drawing an 
image map on the Web page.

· You want Visio to create an HTML-coded page and convert a drawing to a format Web browsers can 
use.

Export drawings in .jpg, .gif, or .png format when

· You already have an HTML-coded page in which you want to insert a Visio drawing.

· You want to export only a portion of a drawing.



Saving drawings as HTML pages
    How To
    Related Topics

When you save a drawing as an HTML page, Visio creates a Web page that contains the drawing and 
HTML source code. You can immediately view the HTML page(s) using a Web browser.

If your drawing has multiple pages, Visio creates an HTML page for each drawing page and adds 
navigation buttons to each page.

Visio adds navigation buttons to each page of a multiple-page drawing when you save it as an HTML page.

By default, if shapes in your drawing have navigational links to other Visio drawing pages, files created in 
different applications, or to Web sites, Visio preserves these links as active on the HTML page. The Visio 
drawing becomes a "client-side image map." An image map is a graphic with different regions, some of 
which are "hot." In client-side image maps, all the information a Web browser needs to process a click on 
a hot region is stored in the HTML file with the image data.

You can also save a drawing with navigational links as a "server-side image map". In server-side image 
maps, a program on the Web server examines map data associated with the hot regions and processes 
the links.

Visio formats the saved HTML files with a template. The template is an HTML file with HTML tags and 
codes that correspond to elements from the drawing, such as page number, the page graphic, and 
anchors or jumps to other HTML pages or files. You can create your own template for saving Visio 
drawings as HTML files by modifying the default template.



To save a drawing as HTML pages:

1. In Visio, display the drawing you want to save.

2. Choose File > Save As.

3. Type a name for the HTML file using the .htm extension, such as Drawing.htm.

4. For Save As Type, choose HTML files (*.htm, *.html), choose where to save the file, then click Save.

5. In the Save As HTML dialog box, choose the graphics format and the drawing pages you want the 
HTML file to include. 

6. Click Filter Settings to control the on-screen image size of the saved drawing or to choose options 
specific to the graphics format, then click OK twice.

7. Visio prompts you to view the HTML pages. Click Yes to open your Web browser and view the first 
HTML page. 
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To save a drawing as HTML pages without preserving links:

1. In Visio, display the drawing you want to save.

2. Choose File > Save As.

3. Type a name for the HTML file using the .htm extension, such as Drawing.htm.

4. For Save As Type, choose HTML files (*.htm, *.html), choose where to save the file, then click Save.

5. In the Save As HTML dialog box, choose the graphics format and the drawing pages you want the 
HTML file to include, then click Options.

6. In the Export Options dialog box, uncheck Enable Image Maps, then click OK twice.

7. Visio prompts you to view the HTML pages. Click Yes to open your Web browser and view the first 
HTML page.
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Creating templates for saving and formatting HTML pages
    How To
    Related Topics

Visio formats saved HTML pages with a template. The template is an HTML page with regular HTML tags 
and special substitution codes that correspond to elements from the drawing, such as page number, the 
Visio graphic, and links (or anchors) to other HTML pages or files. When you export, Visio substitutes 
drawing elements for the codes.

You can create a custom template for saving and formatting HTML pages by modifying the Visio default 
template and by including substitution codes. When you save a drawing as an HTML file, you can choose 
which template you want to use.



To create a custom template:

1. Copy the default HTML template, Dfltdoc.htm, which is located in the \Visio\Solutions\Visio Extras 
folder.

2. Open the copy in a program that can open and edit HTML files, such as Notepad.

3. Change or delete the existing HTML tags or add new ones. Rearrange or delete the substitution codes.

4. Save the revised template under a new name with an .htm extension.
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To use a custom template when you save a drawing as HTML pages:

1. In Visio, create or open the drawing you want to save, then choose File > Save As.

2. Type a name using the .htm extension, such as Drawing.htm.

3. For Save As Type, choose HTML files (*.htm, *.html), choose where to save the file, then click Save.

4. In the Save As HTML dialog box, choose the graphics format and the drawing pages you want the 
HTML file to include, then click Options.

5. In the Export Options dialog box, under HTML Template, check Use Custom Template, click Browse to 
locate your custom template, then click OK.

6. In the Save As HTML dialog box, click OK. Visio prompts you to view the HTML pages. Click Yes to 
open your Web browser and view the first HTML page.

    Overview



Exporting shapes and drawings in .jpg or .gif format
    How To
    Related Topics

When you export a Visio drawing as a .jpg (Joint Photographic Experts Group) or .gif (Graphics 
Interchange Format) graphic, you convert it to a format you can distribute over the Internet or intranet. 
The .jpg and .gif formats are supported by virtually all Web browsers. 

Once the Visio drawing is exported, you can include it in an HTML page by adding the <IMG > HTML tag 
(for example, <IMG SRC="drawing1.gif" >) to the page.

If a drawing includes shapes with navigational links to other Visio drawing pages, to files created in 
different applications, or to Web sites, the links are lost when you export.



To export a drawing in .jpg or .gif format:

1. In Visio, select the shape or drawing you want to export.

2. Choose File > Save As.

3. For Save As Type, choose .jpg ,.gif, or .png, then click Save.

4. In the Output Filter Setup dialog box, choose the options you want, then click OK.
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About Visio and Microsoft Office 97
    Related Topics

Visio products are fully compatible with Microsoft Office 97 programs, so you don't need to spend time 
getting used to a new environment when you work with Visio. 

Full Office 97 compatibility means Visio toolbars, menu commands, and accelerator keys are similar to 
those you find in Office programs. It also means you can easily exchange shapes, text, and other objects 
between Visio and Office programs.

Some features in Visio that provide improved Office 97 compatibility include

· Full-screen view    When you view your Visio drawing in the full-screen, Visio hides the menus, 
toolbars, and everything but the drawing page so you can view the drawing in the maximum space 
your screen allows. You can use the left and right arrow keys or the mouse to navigate between pages.
Full-screen view is read-only, so to edit your drawing, press the Esc key to return to the normal view.

· Improved formatting toolbar buttons    Line, Fill, and Text formatting buttons on the toolbars now 
provide pop-up palettes, similar to those in Microsoft Excel, from which you can select the formatting 
you want.

If you are running Office 97, you can use the following features in Visio:

· Routing drawings through email    You can add a routing slip to a drawing that you send through 
email so that you are notified when the drawing is routed from one person to the next, and the drawing 
is returned to you when the last person on the list finishes reviewing it. 

You can also save a drawing directly to an Exchange folder.

· Recording activities in the Outlook Journal    In Journal, you can automatically record time you 
spend using Visio.

NOTE    Visio is also an Office 95-compatible program.



Displaying and editing Visio drawings in Internet Explorer
    How To
    Related Topics

From Internet Explorer you can open and work on your Visio drawings without leaving the Internet 
environment. You can open a Visio drawing (.vsd) file by using the Open command¾the same way you 
open an HTML or Office 97 program file. Visio opens the drawing with Visio menus and toolbars, and 
opens stencils you saved with the drawing. When you open a drawing from within Internet Explorer, Visio 
provides the same tools that are available when you work with it as a standalone program.

After the Visio drawing is open within Internet Explorer, you can navigate between the drawing and other 
Office documents or Web pages by clicking the Forward and Back buttons on the Internet Explorer 
toolbar.



To open a Visio drawing from within Internet Explorer:

1. In Internet Explorer, choose File > Open. 

2. Under Open, type the path and name of the Visio file, or click Browse to find it.

If you click Browse, the Open dialog box appears. Under Files Of Type, select All Files to display Visio 
files in the list.

3. When you find the file, select it and click Open.

The file opens in Visio in the Internet Explorer environment. 

4. Click the Tools button on the Internet Explorer toolbar to display the Visio toolbar and menus.

TIP    You can navigate between the Visio drawing, other documents, and Web pages by clicking the 
Forward and Back buttons on the Internet Explorer toolbar. You can also type the URL of the Web site or 
path and file name of the document in the Address box.

    Overview



Exchanging data between Visio and Microsoft PowerPoint
    Related Topics

You can include Visio drawings in your Microsoft PowerPoint presentations to strengthen and clarify your 
ideas, as well as to take advantage of the PowerPoint slide features. You use OLE to embed or link Visio 
shapes and drawings into PowerPoint slides. You can open Visio from within PowerPoint to create new 
drawings, or you can copy and paste or drag and drop existing shapes and drawings. 

You can also include PowerPoint shapes and clip art in your Visio drawings by importing them as graphic 
images.



Including Visio drawings in Microsoft Binder reports
    How To
    Related Topics

You can use Microsoft Office Binder to include a full-page or multiple-page Visio drawing in a larger 
report. 

For example, a report you've composed for a bid on a building project includes a narrative written in 
Microsoft Word, a budget calculated in Microsoft Excel, and an extensive floor plan and project timeline 
created in Visio. By including the Word, Excel, and Visio documents in a Binder in the order you want 
them to appear in the report, you can save, move, print, and distribute them as a single file. You can also 
add consecutive headers and footers to each Binder page.

By gathering documents into a Binder, rather than dealing with them separately, you can

· Add headers, footers, and other elements from within the Binder to ensure a consistent look across 
documents (Office 97).

· Paginate the entire Binder at one time.

· Preview the entire Binder before printing it (Office 97).

· Print the entire Binder at one time.

To use the Microsoft Office Binder, you must have Microsoft Office 95 or Office 97. For details about the 
Binder, see Microsoft Office Binder online help.



To include a Visio drawing in a Binder:

1. In Windows 95 or Windows NT 4.0, from the Start menu, choose Programs, then choose Microsoft 
Binder.

2. Drag the Visio drawing you want to include from the Desktop or from Windows Explorer into the left 
pane of the Binder window.

3. From the Binder File menu, choose Save Binder As to save the Binder file.

TIP    Although you can create a Visio drawing from within the Binder, it's more efficient to use the Binder 
to assemble finished documents.
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About including Visio data in other programs' documents
    Related Topics

You can use any one of the following methods to include Visio data in a document created in another 
program:

· Embedding

· Linking

· Exporting

The method you choose depends upon the capabilities of the other program and how you want to work 
with the Visio data once you've placed it in the other document. 

NOTE    Every method except exporting uses OLE to integrate data from different programs. With OLE, 
you can open Visio from within the other program to modify the Visio shapes and drawings.



Embedding shapes and drawings
    How To
    Related Topics

When you embed Visio data, it becomes part of the other program's file, and when you edit it, you edit 
only the version that's embedded in the other program. 

Embedding is useful in cases when you don't want to keep a separate Visio file for the data you include in
the other document. Or, if you want to transfer the file to other computers, you can transfer all the data in 
one file. Embedded objects, however, increase the file size; if you want to keep the data in a separate 
Visio file, you have to update the data in both places.

When you embed Visio data in another OLE-compatible program, it becomes part of the other program's document.

From within a document in a program that supports OLE, such as a Microsoft Word document, you can 
create a new embedded Visio drawing or embed an existing Visio drawing. 



To create a Visio drawing in another document:

1. In the document, choose Insert > Object (or the appropriate command for that program).

2. In the dialog box, click the options for creating a new file, then, under Object Type, choose Visio 5 
Drawing, and click OK.

3. In the Visio Choose A Drawing Template dialog box, open the folder that contains the drawing type you 
want, select the template for the drawing type, then click Open.

4. Create the Visio drawing.

5. If Visio is running in its own window, choose File > Exit. If it's running within the other document (in 
place), click somewhere in the document outside the Visio drawing to close Visio.

6. To edit the Visio drawing from within the document, double-click the drawing.

TIP    You can also embed an existing Visio drawing from within another document. Follow step 1 above, 
then, in the dialog box, click the option for creating an object from an existing file.
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To embed selected Visio shapes:

1. In Visio, select the shapes you want to embed.

2. Choose Edit > Copy (or press Ctrl+C).

3. Open the document in which you want to embed the shapes, then choose Edit > Paste (or the 
equivalent command).
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To embed an entire Visio drawing:

1. In Visio, make sure nothing is selected.

2. Choose Edit > Copy Drawing.

This command copies the entire drawing, including shapes on other drawing pages and on 
backgrounds.

3. Open the document in which you want to embed the drawing, then choose Edit > Paste (or the 
equivalent command).

When you embed a multiple-page Visio drawing, only the page displayed at the time you choose Copy 
Drawing appears in the container document. 
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Editing an embedded Visio object in place
    Related Topics

In many OLE 2-compatible programs, you can edit an embedded Visio object without leaving the program
(or "container application")¾this is called "in-place editing." A special set of Visio menus and toolbars 
temporarily replaces most of the menus and controls in the active window while you edit the Visio object. 

To edit an embedded Visio object in place: 

1. In the container application, double-click the embedded Visio object.

A special set of Visio menus and controls appears.

2. Edit the Visio drawing.

3. Click anywhere outside the drawing window to exit the in-place editing controls.



Linking shapes and drawings
    How To
    Related Topics

The way you link shapes and drawings is similar to the way you embed them. However, when you link a 
Visio shape or drawing to another document, the other document contains only a reference to the Visio 
drawing file, rather than the actual drawing. You link data in a saved Visio file so the other program can 
find the data and display it.

Linking works well when you want to include the same Visio data in more than one document. When you 
update the data, you only need to update it in one location. The versions that are linked to other 
documents reflect the changes automatically.

Linking a Visio file to another document does not increase the file size the way embedding a Visio object 
does. However, links require a little more maintenance. If you want to transport the data, you must make 
sure to transfer all linked files to the other computer.

When you make changes to a drawing that's linked to another document, the changes appear in the other document 
simultaneously.



To link a Visio file to another document:

1. Open the drawing you want to link. If it's a multiple-page drawing, display the page you want to appear 
in the other document.

NOTE    Because a link is a reference to a file, you can only link files that are saved to a location on a 
disk. If you haven't saved the drawing you want to link, choose File > Save.

2. Make sure nothing on the drawing is selected, then choose Edit > Copy Drawing.

3. Without closing Visio, open the document in the other program in which you want to include the Visio 
drawing.

4. Choose that program's command for linking objects.

In Microsoft Office programs, choose Edit > Paste Special.

5. In the dialog box, make sure Visio 5 Drawing Object is selected, select Paste Link, then click OK.

The drawing you copied appears in the document, with a link to the original Visio file.
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Dragging Visio shapes and drawings into other programs
    How To
    Related Topics

If the other program in which you want to include Visio data is compatible with OLE 2, an alternative to 
using menu commands to paste Visio shapes is to drag shapes from a Visio drawing or stencil into the 
other document. Dragging and dropping shapes does not use the Windows Clipboard, so data on the 
Clipboard is not affected.

You can drag shapes from the drawing page or masters from stencils. When you drop a master, an 
instance of the master appears in the document and the master is not removed from the stencil. If you 
drag multiple shapes from a drawing page, they are treated as one object in the other document.

Pointer tool changes
When you drag shapes between programs, the pointer tool changes in response to the action you take.

How the pointer tool changes
Pointer 
appearance

Action

Press Ctrl and 
then drag to 
move the 
selected 
shapes to the 
other 
document.

Press 
Ctrl+Shift and 
then drag to 
copy the 
selected 
shapes to the 
other 
document.

Cannot drop 
shapes in that 
document.

TIP    Before you drag shapes, position the Visio window and the other program's window so you can see 
the shapes and the document in which you want to drop them.



To position program windows quickly:

1. Open Visio with the drawing or stencil that contains the shapes you want to drag into another 
document, then, without minimizing the Visio window, open the other program.

2. Right-click the Windows taskbar and choose Tile Vertically.
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To drag and embed shapes into another document:

· Select the shapes, then press Ctrl and drag the shapes into the document.

Dragging the shapes from the drawing page copies them into the other document. To move the shapes
(so they no longer appear on the drawing page), don't press Ctrl as you drag.

To drag and link shapes to another document:

· Select the shapes and, when you select the last shape, hold the mouse pointer down. Then press 
Ctrl+Shift and drag the shapes into the document.

NOTE    If you press Ctrl+Shift before pressing the mouse button to drag the shapes, the pointer 
becomes a magnifying glass for zooming in on the drawing, and you will not be able to drag the 
shapes.
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Exporting shapes and drawings
    How To
    Related Topics

When you export Visio data, it is directed through a filter that converts the Visio data to an independent 
non-Visio file. You then open that file or import it as a picture in the other program. Exporting works best 
when you want to include Visio data in a document that is not compatible with OLE, or if you want to 
include a Visio drawing in an HTML document you want to post on the Web.

After you export a Visio drawing to another format and insert it in another document, it's considered a 
static picture. That means you will not be able to open Visio to edit it from within the other program. In 
addition, because your Visio file can go through up to two translations before it appears in the other 
program¾one when you export from Visio, and one if you import into the other program¾the graphic 
image may not look exactly the way it does in the Visio drawing.

For example,

· By exporting a Visio drawing in .ai format, you can open it in Adobe Illustrator and edit it using that 
program's tools.

· By exporting a Visio shape as a Windows bitmap, you can open the bitmap in any program that 
supports .bmp format.

· By exporting a Visio drawing in a format another program can open, you can include Visio data as a 
graphic image in the other program's documents.

Exporting translates a file to a non-Visio format that the other program can import.

TIP    If the other program in which you want to include Visio data supports OLE, it's best to link or embed 
the Visio data rather than export it. OLE produces more consistent results and allows you to edit the data 
after you include it in the other program.



To export shapes or drawings to another file format:

1. To export all the shapes on a page, display the page you want to export.

To export specific shapes, select the shapes you want to export. (Use Shift+click to select more than 
one shape.)

2. Choose File > Save As, then

For Save As Type, choose the format you want. 

For File Name, type a name for the file.

3. Click Save.

Visio exports the shapes or page in the format you choose. You can use the file in any program that 
can read files in that format.

4. If necessary, in the Filter Setup dialog box, choose the export settings you want, then click OK.
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Sending drawings through electronic mail
    How To
    Related Topics

You can send a Visio drawing to another user via e-mail. Visio products are compatible with electronic 
mail programs that support the Messaging Application Program Interface (MAPI) protocol. 

Visio also takes advantage of Microsoft Office 97 routing features, including sending drawings to 
Microsoft Exchange folders, adding routing slips to drawings you send through e-mail, and adding journal 
entries to Outlook.



To include a drawing file in an e-mail message:

1. While the drawing file is open, choose File > Send To > Mail Recipient.

If your mail program hasn't been running, it starts; then a new e-mail message containing the Visio icon
and the file name appears.

2. Address the message, type any accompanying data, and send the e-mail message as you would any 
other message.
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To view a Visio file sent by e-mail:

· Open the e-mail message, then double-click the Visio icon.

NOTE    Visio must be installed to open drawings you receive in e-mail.
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Microsoft Office 97 document-routing support
If you use Office 97, you can send a drawing with a routing slip or send a drawing directly to a folder in 
Microsoft Exchange.

To send a drawing with a routing slip:

1. Display the drawing you want to send, then choose File > Send To > Routing Recipient.

2. Click Address to open your post office address list and select the individuals or groups to whom you 
want to route the drawing. When you've finished adding to the recipient list, click OK.

3. If you need to route the drawing to people in a specific order, select a person's name, then click the up 
or down arrow in the Move section to change that person's position on the list.

4. Under Route To Recipients, select whether to route the drawing to one person at a time or to everyone 
at once.

If you choose to route the drawing to one person at a time, the first person on the list views or updates 
the drawing, then routes the drawing to the next person, and so on. 

If you route a drawing to a group alias, everyone in the group will receive the drawing at the same time.
To send the drawing to one group member at a time, list each of their names rather than the group 
alias.

5. Check Track Status or Return When Done to receive an update as each person on the list passes the 
drawing to the next person or to have the drawing sent back to you after everyone has seen it.

6. Under Message Text, type the text you want in the email message. When you're finished, click Add 
Slip.

7. Choose File > Send To > Next Routing Recipient to send the drawing to the first person on the routing 
list.

NOTE    You can choose to send the drawing (step 7) later. If you try to close the file before sending the
drawing, Visio displays a message reminding you that it contains a routing slip. You can then choose to
route the drawing, send it without the routing slip (you won't be able to track its status and it won't 
automatically be returned to you), or not to send it at all.

TIP    If you receive a routed drawing and want to route it to the next person, choose File > Next Routing 
Recipient. If you want to route the drawing to someone who isn't on the list, choose File > Other Routing 
Recipient, and then follow steps 2–7 above.

For details about routing files, see your Microsoft Office 97 documentation.
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To send a drawing directly to a Microsoft Exchange folder:

1. Display the drawing you want to send, then choose File > Send To > Exchange Folder.

2. Select the folder in which you want to place the drawing, then click OK.

Visio saves the drawing in the Microsoft Exchange folder as an embedded object, so you can open the 
drawing in Visio from within Microsoft Exchange.
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About working with styles and templates
    Related Topics

You can use styles and templates in Visio to create drawings that can be quickly and efficiently revised. 

Using styles
A "style" is a named collection of formatting attributes¾for example, blue fill and magenta bold text¾that 
you can apply to your shapes to give them a consistent look and make them easier to revise. By editing 
the style, you can simultaneously change the look of all shapes formatted with that style.

A style can contain line, fill, and text formatting attributes¾a single attribute or any combination of the 
three. Visio templates come with styles built in, but you can also define your own. 

Select three shapes and apply one style to make them look the same.

Creating templates
When you know that you'll be creating multiple drawing files that need a consistent look, consider creating
a template on which to base all the drawings. Creating your own template eliminates the need to open the
appropriate stencils, create styles, and establish page settings for each drawing file, because they are all 
contained in one place.

Also, you can increase your efficiency by creating your own templates when

· Your drawings require customized settings for page size or scale, window size and position, shape or 
text styles, color palette, snap and glue, or printing, create a template with the appropriate settings in 
place.

· Your drawings often use a standard background or set of layers¾for example, you place your company
logo in every drawing¾create a template with the background or layers in place.



Applying styles
    How To
    Related Topics

Some styles include formatting for all three attributes (line, fill, and text); others are specific to one 
attribute. For example, one style may contain text formatting, such as the font, size, and color, as well as 
fill color and pattern, and line color and pattern. Another style may contain only text formatting.

When you apply formatting to a shape by choosing the style from one of the style lists (for example, the Text style list)
on the toolbars, if the style also includes line or fill formatting, Visio asks if you want to apply all of the style's 
formatting, rather than just the text formatting. Click Yes to apply all formatting to the shape. Click No to apply 
formatting for the single attribute you initially chose from the list.



To apply a style:

1. Select one or more shapes you want to format.

2. From the Line or Fill style lists on the Shape toolbar, or from the Text style list on the Text toolbar, 
choose the style you want to apply.

TIP    You can apply styles to a shape by choosing Format > Style, then selecting the style you want from 
the lists. All the styles available in a drawing, both those pre-defined in a template and those you define 
yourself, are listed in the Style dialog box.

    Overview



Defining and editing styles
    How To
    Related Topics

In the Define Styles dialog box, you can edit and rename existing styles, define your own styles from 
scratch, and delete styles you no longer need. 

When you define or edit styles in a drawing file, the changes you make are available only in the current 
drawing. To make a style available across many future drawings, you can define or edit it in an existing 
template, or save the drawing file in which you created the style as a new template. The style will be 
included in every new drawing you create using that template.

When you edit or define a style, the colors you can choose are determined by the color palette in the 
template on which you base your drawing. All Visio templates use a default color palette. You can change 
the color palette a drawing uses, or modify the colors within the default color palette.



To define a new style:

1. Choose Format > Define Styles.

2. Type a name for the new style.

3. If you want to base the new style on an existing style, choose that style under Based On.

4. Under Includes, check the attributes that your style includes. A style can include formatting from any 
combination of the three attributes.

5. Under Change, click Text, Line, or Fill to change the settings for that attribute. Choose the settings you 
want for each attribute you included in step 4.

6. When the style contains the settings you want, do one of the following:

Click Apply to add the new style, apply it to selected shapes, and close the dialog box.

Click OK when no shapes are selected to add the new style and close the dialog box.

Click Add to add the new style and continue working in the dialog box.
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To edit a style:

1. Choose Format > Define Styles.

2. In the Style list, select the style you want to edit.

3. To rename the style, click Rename, type a new name for the style, then click OK.

4. To change the style settings, under Change, click the attributes you want to edit. When you finish 
editing the attributes, do one of the following:

Click OK (when no shapes are selected) or Apply (when shapes are selected) to add the changes to 
the style and close the dialog box.

Click Change to add the changes and continue working in the dialog box.
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To delete a style:

1. Choose Format > Define Styles.

2. Choose the name of the style you want to delete.

3. Click Delete, then click OK.
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Copying styles from one drawing to another
    How To
    Related Topics

If you want to transfer a style you created in one drawing to another drawing, you can copy and paste a 
shape to which the style is applied from the first drawing into the second. 

NOTE    If a style with the same name already exists in the second drawing, the style of the shape you 
copy does not replace the original style. Instead, it inherits the formatting of the style as it is defined in the
second drawing. In this situation, if you want to copy the style, rename the style in either of the drawings 
before you begin.



To copy a style from one drawing to another:

1. Select a shape in the first drawing, and apply to it the style or styles you want to copy to the new 
drawing.

2. Choose Edit > Copy (or press Ctrl+C).

3. Open the new drawing.

4. Choose Edit > Paste (or press Ctrl+V).

The shape is copied to the new drawing, along with the styles you assigned to it in the original drawing.
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Preserving individual shape formatting
    How To
    Related Topics

You can apply special, or local, formatting to an individual shape even when the shape has a formatting 
style assigned. For example, if a computer in a network diagram has the Net-Normal style assigned, you 
can change the computer shape's text from normal to italic. If a Process shape in a flowchart has the 
Flow-Normal style assigned, you can change the fill color of the shape from white to blue.

If you apply a new style to a shape for which you've defined local formatting or edit the style already 
assigned to the shape, the style's attributes will replace any local formatting you've applied. 

To prevent a style from overriding a shape's local formatting, you can choose to assign all of the style's 
attributes except those you assigned locally. Or you can preserve a shape's local formatting when you 
create or apply a style in the Define Styles and Style dialog boxes.

If you experiment with local formatting and then decide you preferred the formatting the shape originally 
displayed, you can revert to the styles associated with the shape's master.



To preserve local formatting when applying a style:

1. Select the shape, then choose Format > Style.

2. Choose the styles you want to apply.

3. Check Preserve Local Formatting.

4. Click OK.

TIP    In the Define Styles dialog box, the setting is called Choose Preserve Local Formatting on Apply.
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To revert to a master's style:

1. Select the shape, then choose Format > Style.

2. In the Style dialog box, choose Use Master's Format from the Text, Line, or Fill style lists.

The Use Master's Format item appears at the top of each style list; you may need to scroll up to see it.

3. Click OK.
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Creating new templates
    How To
    Related Topics

You can create your own template to set up the most common stencils, styles, and page settings you use.
Then you can base new drawings on this template and distribute the template to other Visio users in your 
organization.

The easiest way to create a template is to set up a drawing file the way you want, open the stencils you 
want, and then save the settings as a template (.vst) file. If you simply want to change some of the 
settings of an existing Visio template, you can base a drawing on that template, save it with a new name, 
and make your changes. 

TIP    If you want to preserve an original drawing file but also base a new template on it, you can open a 
copy of the drawing file. Choose File > Open. In the Open dialog box, select the drawing you want, then 
under Open, click Copy.



To create a template from a drawing file or an existing template:

1. Open the drawing or start a new drawing based on the template you want to modify.

2. Open any additional stencils you want to save with the template.

3. Modify drawing page settings and styles you want to use in future drawings you base on this template.

For example, if you want to have a background page that displays your company logo, or a title block 
that contains fields such as the date a drawing is created and so on, create it and assign it to the 
foreground page.

4. Choose File > Save As, then do the following:

For Save As Type, select Template (*.vst).

For File Name, type a name for your template.

For Save, make sure Workspace is checked.

For Save in, select the folder in which you want to save the template. 

TIP    If you want the template to display when you choose New from the File menu, save it in the 
Solutions folder or one of its subfolders.

5. Click Save.
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About layers
    Related Topics

You can use Visio layers to organize related shapes on a drawing page. A layer, in Visio, is a named 
category of shapes. Using layers, you can

· Show, hide, or lock shapes and guides on specific layers so you can edit certain layers without viewing 
or affecting others.

· Select and print shapes based on their layer assignments.

· Temporarily change the display color of all shapes on a layer to make them easier to identify. 

· Assign a shape to more than one layer, as well as assign the member shapes of a group to different 
layers.

· Control whether shapes on a layer can be snapped to or glued to.

· Create reports based on data stored in shapes assigned to a particular layer. 

For example, if you're drawing an office layout, you can assign walls, doors, and windows to one layer, 
electrical outlets to another layer, and furniture to a third layer. That way, when you plan the electrical 
system, you don't have to worry about accidentally rearranging the walls. 

After locking the wall and electrical outlet layers, you can distribute the office layout to co-workers, who 
can arrange the furniture in their offices without disturbing the underlying office layout. 

Some shapes, such as those in the Office Layout Template, are already assigned to pre-existing layers. If 
you want to use layers with shapes from other stencils, you need to create the layers and assign the 
shapes to them.

A shape can be assigned to multiple layers or no layers, and every page in a drawing can have a different
set of layers.

Shapes can belong to more than one layer. Here, the lake and compass shapes belong to the Streets layer (A), the 
Landmarks layer (B), and the Routes layer (C).

NOTE    Visio layers do not determine how shapes appear on the page. The way shapes overlap is 
determined by their stacking order and whether or not there are backgrounds assigned to the page.



Using layers on backgrounds
    Related Topics

A background is a page that appears behind another page. It can have its own set of layers. Because a 
background can be shared by more than one page, but layers cannot, you may want to use layers on 
background pages. For example:

· In a drawing where the same map is used on multiple pages, you can put the map on the background 
and assign its parts to different layers, such as the Road layer or River layer. If you want to hide the 
roads on all the pages, you can then hide the background's Road layer.

· In a drawing with a title block on the background, you can assign it to a Revision History layer and then
hide that layer if you don't want to print it.

· If the background includes information you don't want modified, such as your company logo and name,
but you need to give the file to your client modifications, you can assign those shapes to a Corporate 
layer, lock it, then pass the file on to your client.

Background page elements (A) appear on the foreground pages to which they are assigned (B and C). When you 
open a Visio file, the drawing page on the screen is a foreground page. If you want to use backgrounds, you need to 
create them.



Creating, removing, and renaming layers
    How To
    Related Topics

Many Visio masters are already assigned to layers so, when you drop them on the page, the layer is 
added as well. You can create new layers to organize custom categories of shapes, then assign your 
shapes to those layers, as well as to the layers that Visio provides. For example, when you open the 
Office Layout Template, the masters are already assigned to the layers. As you drop instances of the 
masters, the layout layers are set up for you.



Creating layers
When you create a new layer, Visio adds it only to the current page, not to all pages in the file. Similarly, 
when you create a new page, you must define its layers; the new page does not inherit layers from the 
previous page. However, when you copy a shape with a layer assignment from one page to another, 
whether in the same drawing or between drawings, Visio adds the layer to the new page. If the page 
already has a layer with the same name, the shape is added to the existing layer.

To create a layer:

1. Choose View > Layer Properties.

2. Click New. 

3. In the New Layer dialog box, type a name for the layer, then click OK. 

4. In the Layer Properties dialog box, click to place a checkmark below properties you want the layer to 
have, then click OK.

    Overview



Removing and renaming layers
When you no longer need a layer, you can remove it. If you remove a layer, all shapes assigned only to 
that layer are removed as well. If you don't want to remove the shapes along with the layer, change or 
remove each shape's layer assignment before you remove the layer.

When you rename a layer, only the layer's name is changed¾the shapes on the layer are not removed or 
changed.

TIP    To see how many shapes are assigned to a layer, choose View > Layer Properties, then click the 
number button ( ) in the Layer Properties dialog box.

To remove a layer:

1. Choose View > Layer Properties.

2. Select the layer you want to delete, then click Remove. 

3. Click OK.

TIP    To delete all unused layers, check Remove Unreferenced Layers.

To rename a layer:

1. Choose View > Layer Properties.

2. Select the layer you want to rename, then click Rename.

3. For Layer Name, type a new name, then click OK.

4. Click OK.

    Overview



Assigning shapes to layers
    How To
    Related Topics

You can assign shapes to one or more layers by selecting the shapes, then choosing which layer you 
want to assign them to. For example, you can add walls and furniture, then assign them to corresponding 
layers. 

When you drop an instance of a master that is pre-assigned to a layer, the instance inherits the master's 
layer assignments. If a layer of that name does not already exist on the drawing page, dropping the 
instance adds the layer. If you have designated an active layer for the page, that instance is assigned only
to the layer it inherited from its master shape, although you can later assign it to the active layer or to 
another layer.

TIP    You can check Preserve Group Member Layers to specify that individual shapes in a group retain 
their current layer assignments. For example, you might assign a desk to the furniture layer and a 
computer to the electronics layer, then group them. If you then assign the group to the den layer, the desk
and computer retain their previous layer assignments as well. When this option is unchecked, when you 
assign a group to a layer, all of the group members become members of the new layer. Their previous 
layer assignments are canceled.



To assign a shape to a layer:

1. Select the shape. 

If the shape is part of a group, click to select the group (indicated by green selection handles), then 
click to subselect the shape in the group (indicated by gray selection handles).

2. Choose View > Shape Layer.

3. Choose the layer to which you want to assign the shape, then click OK. 

TIP    To assign a shape to more than one layer, press Ctrl to choose multiple layers.
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To assign a group to a layer:

1. Select the group.

2. Choose View > Shape Layer.

3. Click the layer to which you want to assign the group, check Preserve Group Member Layers, then 
click OK. 

    Overview



Making a layer active
    How To
    Related Topics

When you create a shape that doesn't already have a pre-defined layer assignment, it is automatically 
assigned to the active layer. You can change the active layer as you work to make sure that new shapes 
are added to the appropriate layer. For example, if you are going to add electrical wiring shapes to a 
drawing of an office layout, you can make the electrical layer active. All the shapes you add from then on 
are assigned to the electrical layer. When you begin to add windows, you can designate the wall layer as 
the active layer. 

In a drawing with many shapes and layers, you may find it more efficient to designate one or more active 
layers, so that all shapes you subsequently draw or drop are automatically assigned to those layers. 



To designate a layer as active:

1. Choose View > Layer Properties.

2. Click in the Active column to add a check for each layer you want to make active. 

3. Click OK.

TIP    If a layer is locked against editing, you cannot make it the active layer.
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Controlling shape behavior using layers
    How To
    Related Topics

After you've assigned shapes to a layer, you can control the behavior and appearance of the shapes as a 
group. You can

· Select all shapes on a layer.

· Show or hide the shapes on a layer. For example, in a garden diagram, you can view the layers that 
contain the flowerbed and the spring-blooming plants, and hide the layers that contain summer- and 
fall-blooming plants, to see what will be blooming in the spring.

· Lock shapes on a layer, so that you cannot select, move, or edit the shapes on the locked layer. To 
identify these shapes, you can also temporarily change their color by setting color property for the 
locked layer. You cannot add shapes to a locked layer.

· Specify whether other shapes can snap or glue to the shapes assigned to a layer. If a shape is on a 
layer that has Snap or Glue unchecked, you can still snap or glue it to other shapes, but you can't snap
or glue other shapes to it. 

· Use color to highlight shapes on a layer. For example, in an office layout you can create a layer for 
each department, then assign each layer a unique color so that, at a glance, you can see which 
department owns different equipment.

· Print only the shapes assigned to particular layers.

TIP    The color you assign to shapes on a layer temporarily overrides each shape's original color. If you 
turn off the layer color, each shape returns to its original color. If you have assigned a shape to more than 
one layer, the shape will not use a layer color, but instead will appear in its original color. Layer colors are 
temporary and intended for display only, but they can affect printed output.



To select all the shapes on a layer:

1. Choose Edit > Select Special.

2. For Selection By, click Layer, then choose the layer with the shapes you want to select. Or, choose No 
Layer to select shapes that are not assigned to any layer. To choose multiple layers, press Ctrl, then 
click the layers you want.

3. Click OK.
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To control shapes on layers:

1. Choose View > Layer Properties.

2. Check the options you want. Uncheck an option to deactivate it for that layer. 

3. Click OK.

    Overview





About automatic layout
    Related Topics

With certain types of connected drawings, such as flowcharts and network diagrams, you can use the Lay
Out Shapes command to have Visio position, then reposition, shapes. Having Visio reposition shapes can
help you revise large drawings more quickly than using the pointer tool to select and drag each one to the
new location. For example, if you're updating a large flowchart to include a new process, you can add and
connect the shapes that make up the process, then use the Lay Out Shapes command to have Visio lay 
out the updated drawing for you.

Preparing for automatic layout
For best results with automatic layout, use the following guidelines when you create connected drawings:

· Connect shapes using connectors that Visio can route. 

Most connectors are routable. A routable connector can detect certain 2-D shapes that lie in its path 
from one shape to another, and change its route to avoid crossing through them. Some connectors that
are designed for a specific purpose, such as the tree and crow's-foot connectors, or control-handle 
connectors that you can drag out directly from other shapes, are not routable.

· Set all 2-D shapes so that connectors can detect them.

Routable connectors can detect and route around only the shapes set as "placeable." To quickly set all 
2-D shapes as placeable, select them all (shift+click to select multiple shapes), then choose Format > 
Behavior and, for Layout Behavior, select Layout And Route Around.

· Orient connectors so that begin and end points direct the flow of your drawing. 

Visio determines where to position shapes based on begin and end point locations. A connector may 
have an arrow on one or both ends but the direction the arrow points doesn't necessarily indicate the 
begin and end point locations.

· Ensure that begin and end points of connectors are properly glued to other shapes. When you select a 
glued connector its begin and end points turn red.

In this diagram, the begin point is connected to the top shape, and the end point is connected to the bottom shape. If 
the points are reversed in this example, Visio will lay out the shapes in the opposite order.

Lay Out Shapes works best with the flowchart, network diagramming, organization chart, or other typical 
connected-drawing types. If you try to use automatic layout with a drawing that you did not create with 
these shapes, an alert appears to let you know that the results may not look as you expect. You can 
choose to continue or cancel the layout process. If you continue and are not satisfied with the results, you
can use the Undo command to undo it (choose Edit > Undo Lay Out Shapes).



Setting layout style, depth, and routing
    How To
    Related Topics

When you have Visio lay out a drawing, you can specify the style of layout you want, as well as the layout
depth and the connector routing style.

Layout style
You can choose one of three styles: Top To Bottom, Left To Right, and Radial. Choose Top To Bottom or 
Left To Right for directed drawings, such as organization charts and process flow diagrams. Choose 
Radial for undirected drawings such as some types of network diagrams.

Depth
The Depth setting determines the number of levels of the drawing Visio looks at before creating the 
layout. When choosing depth settings, Shallow means a shallow layout. That is, in a top-to-bottom 
organization chart, a shallow layout requires more horizontal space than a deep layout.

In addition, depth settings refer to the type of layout you want. If you set the depth to Shallow, Visio 
checks more levels of the drawing than it does if you set the depth to Deep. The more levels Visio checks,
the better it can determine, in a top-to-bottom chart, how much space to leave between top-level shapes 
so that shapes in lower levels can fit on the same horizontal line. In this case "shallow" refers to the 
layout, because it requires more horizontal and less vertical space than it would if you had set the depth 
to Deep.

Whatever the Depth setting, the number of levels Visio looks at depends upon the style and complexity of 
the drawing you're working on. You may want to try different depth settings on the same drawing to find 
the one that produces the result that works best for your drawing.

Routing style
The routing style determines the path automatic layout takes to connect 2-D shapes. You can choose one
of two routing styles: Flowchart and Right Angle. The Flowchart routing style uses both straight and right-
angle connectors; the Right Angle routing style uses only right-angle connectors.



To lay out shapes and change layout style, depth, and connector-routing style:

1. Display or create the drawing you want to lay out.

2. Choose Tools > Lay Out Shapes.

3. Select the layout style, the depth, and the routing style you want, then click OK. 

Lay Out Shapes works best with the flowchart, network diagramming, organization chart, or other typical 
connected-drawing types. If you try to use automatic layout with a drawing that you did not create with 
these shapes, an alert appears to let you know that the results may not look as you expect. You can 
choose to continue or cancel the layout process. If you continue and are not satisfied with the results, you
can use the Undo command to undo it (choose Edit > Undo Lay Out Shapes).

    Overview



Customizing shape spacing and connector routing settings
    How To
    Related Topics

When you use automatic layout, you can fine-tune the way Visio places shapes (or "nodes") and 
connectors (or "lines"). You can

· Change shapes' placement settings to affect the way Visio routes connectors between shapes.

· Change the minimum amount of space you want between shapes and connectors, and between 
connectors' parallel segments.

The settings on the Advanced tab of the Lay Out Shapes dialog box are based on the layout grid. You turn
on the grid by checking the Enable Grid box on the General tab. The layout grid is set up with blocks and 
avenues, like a city map. On the Advanced tab, you can set the Block Size to the size of the shapes in 
your drawing, and the Avenue size to the amount of space you want between them.

Note that the grid you create here serves as an internal guide only¾it does not correspond to the drawing 
page grid, and does not appear on the drawing page when you enable it.

Avoid using the grid if your drawing contains shapes of various sizes, particularly shapes that exceed the 
size of the grid blocks. Visio can position these shapes more precisely when they do not need to fit within 
a fixed grid block.

When you enable the grid, shapes are placed within the blocks (A) and connectors are routed through avenues (B).

To make connections easier to see in a large drawing, you can increase the amount of spacing between connectors 
or between shapes and connectors.

A Line to node spacing

B Line to line spacing



To customize routing and grid options:

1. Choose Tools > Lay Out Shapes to open the dialog box.

2. Click General to display the General tab, then check Enable Grid.

3. Click Advanced, and on the Advanced tab:

Under Line To Line Spacing, set the minimum amount of space you want between connectors' parallel 
segments.

Under Line To Node Spacing, set the minimum amount of space you want between connectors and 
shapes.

Under Block Size, type values that match the size of the shapes in your drawing.

Under Avenue size, type the minimum amount of space you want between the shapes (this should be 
at least twice the values of the Line To Node settings).

4. When you've finished fine-tuning the settings on the Advanced tab, click OK to close the dialog box 
and create the automatic layout, or click Apply to create the automatic layout without closing the dialog 
box.

TIP    If you are not satisfied with the layout, choose Edit > Undo Lay Out Shapes (or press Ctrl+Z).
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About positioning shapes precisely
    Related Topics

When precision counts, you can use the Visio rulers, guides, grid, and alignment and positioning tools to 
draw and place shapes accurately. By default, shapes snap, or pull, to ruler subdivisions, guides, guide 
points, grid lines, and other shapes, so lining them up is quick and easy. Which element you snap shapes 
to depends on what you want to do. For example, to position shapes at regular intervals, you can snap 
them to the grid. To align shapes, snap them to a guide. 

Methods for snapping shapes into position
Position for shape Snap to

Align several shapes Guides

Align shapes by their 
corners

Guide points

Position shapes 
equidistant from one 
another

Grid, ruler subdivisions, 
or guides

Position 1-D shapes 
against 2-D shapes

Shape geometry, 
handles, vertices, or 
connection points

Position 2-D shapes 
against one another

Shape's alignment box

To place a shape more accurately, pause while dragging its line or outline (shown on the left), without releasing the 
mouse button. The line or outline changes to the shape itself (shown on the right).

Other ways you can position shapes include the following:

· The Align Shapes command aligns several shapes to one shape.

· The Size & Position command positions shapes using numerical x, y coordinates.

· The position information that appears on the status bar when you select a shape. This information 
changes as you drag the shape. 

When you drag shapes, guides, or guide points on the drawing page, precise coordinates for the object's position 
appear in the status bar at the bottom of the Visio window. On the rulers, faint lines appear and track the shape as 
you move it to help you position the shape precisely.



Snapping shapes for automatic alignment
    How To
    Related Topics

You can rely on snap behavior to position and align shapes exactly. Snapping pulls shapes to one another
or to ruler subdivisions, grid lines, guides, or guide points so you can control placement and alignment. 
You can control what types of objects shapes snap to and the snap strength, which is the amount of pull 
that an object exerts.

        

By default, shapes snap to both ruler subdivisions and grid lines. To snap shapes more easily to ruler subdivisions, 
turn snapping to grid lines off.

TIP    You may not always want to snap shapes. For example, by turning off snapping, you may find it 
easier to draw a smooth freeform curve.



Setting snap options
The snap settings you choose apply to all shapes in the current drawing. When you set snap options, set 
only the options you need. For example, if you want to snap to guides, you do not need to set the Grid 
option.

To set how shapes snap:

1. Choose Tools > Snap & Glue.

2. In the Snap To section of the dialog box, check the options you want.

The Ruler Subdivisions, Grid, and Guides options are useful for positioning and aligning shapes. 

The Shape Handles (selection handles), Shape Vertices, and Connection Points options are useful for 
gluing shapes together.

3. Check the Snap option in the Currently Active section, then click OK.

TIP    To place shapes as precisely as possible, set the snap strength to a high setting, press Ctrl+Shift 
and click the left mouse button to zoom into the drawing, then move shapes into place.
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Creating guides and guide points
    Related Topics

You can use guides and guide points when you want to position shapes precisely or align several shapes 
and keep them in the same position even when you move them. Guides are useful in ways rulers and grid
lines are not. For example:

· You can rotate existing guides by rotating the entire page or by rotating a single selected guide using 
the Size & Position command. 

· You can glue shapes to guides so that when you move the guides the shapes move too.

· You can place guides anywhere on the page and use the Snap & Glue command to make shapes snap
to the guides.

· Guides don't print.

        

        

Guide points are two short, crossed guides that you can use to align shapes at their corners or to center shapes on 
top of one another.

Methods for creating guides and guide points
To Do This

Prepare to 
create guides 
and guide points

On the View menu, check both 
Guides and Rulers. 

Place a guide 
on the drawing 
page

Drag a guide from the horizontal 
or vertical ruler onto the drawing 
page, then release the mouse 
button. 

Place a guide 
point on the 
drawing page

Drag from the intersection of the 
two rulers onto the drawing page,
then release the mouse button.

Delete a guide 
or guide point

Click to select the guide or guide 
point you want to delete. Press 
the Delete key, or choose Edit > 



Clear.

Rotate a guide Select the guide, then choose 
Shape > Size & Position. In the 
Size & Position dialog box, select
Rotated, then type values for X, 
Y, and Angle. The x, y 
coordinates and angle are 
relative to the zero point. 
Negative values for Angle rotate 
the guide counterclockwise; 
positive values rotate the guide 
clockwise.



Controlling grid spacing and origin
    How To
    Related Topics

Each drawing page is crisscrossed by grid lines like those on traditional graph paper. You can control the 
grid spacing, set whether the grid is variable or fixed, or change the grid origin. You can even set spacing 
separately for the horizontal and vertical grid lines. The grid helps you position shapes visually. You can 
also snap shapes to the grid.

The intervals of the grid correspond to the unit of measure you set in the Options dialog box. You set the 
size of the intervals in the Ruler & Grid dialog box and you type settings for the horizontal and vertical grid
lines. 

NOTE    If you rotate your page, the grid doesn't rotate with it, but stays parallel to the rulers.



Using a variable grid
By default, Visio uses a "variable" grid. Variable grid lines change depending on the magnification at 
which you are viewing your drawing. If you zoom in on your drawing, grid lines may be closer together; if 
you zoom out, they may be further apart. (You can check this by changing the magnification and then 
looking at how the grid lines line up with the rulers.) Visio determines the best grid spacing for the view. 
Variable grids are useful when you want to zoom in to align something precisely.

To set grid spacing between lines for a variable grid:

1. Choose Tools > Ruler & Grid.

2. In the Grid Spacing Horizontal and Vertical list boxes, select Fine, Normal, or Coarse. Fine is the 
smallest grid spacing and Coarse is the largest.

3. Click OK.

To hide the grid:

· Choose View > Grid to uncheck the Grid command.
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Using a fixed grid
For some drawings, such as space plans and engineering diagrams, you may want to set a fixed grid, so 
that grid lines stay the same distance apart regardless of magnification. For example, you can set the grid
to match the size of ceiling tiles. If you set a fixed grid for tiles that are 40cm by 40cm, you'll notice that 
the grid lines always match this distance on the ruler, regardless of the magnification.

To set a fixed grid:

1. Choose Tools > Ruler & Grid.

2. In the Grid Spacing Horizontal and Vertical list boxes, select Fixed.

3. For Minimum Spacing, type the spacing you want for the fixed grid, then click OK.

To change the point where a fixed grid originates:

1. Choose Tools > Ruler & Grid.

2. For Grid Origin, enter x- (horizontal) and y- (vertical) coordinates for the point from which you want the 
grid to originate, then click OK.
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Setting ruler units and the zero point
    Related Topics

Each drawing window has vertical and horizontal rulers that show measurements at the scale of the 
drawing. The intervals of the ruler correspond to the unit of measure you set in the Options dialog box. 
You can specify both the units that appear on the ruler and where the zero point, or starting point, for both
rulers is located in the Ruler & Grid dialog box.

The zero point is typically in the lower-left corner of the page, but sometimes it's helpful to move it to 
make it easier to measure the distances in a specific drawing. For example, you might want the zero point
to line up with a wall in a floor plan. When you move the zero point on a ruler, the grid origin does not 
move with it so the grid and ruler increments might become misaligned, making it difficult to snap to ruler 
increments. You can adjust the grid to match or turn the grid off. 

If you rotate your page or a guide, Visio uses the zero point as the center of the rotation.

Methods for setting rulers
To Do this

Set ruler 
measurement 
units

Choose File > Page Setup, then 
click the Page Properties tab. 
Under Measurement Units, 
choose the units you want, then 
click OK.

Change the 
position of the 
zero point on 
both rulers

Hold down the Ctrl key, then drag
from the intersection of the two 
rulers to where you want the new
zero point.

Change the 
position of the 
zero point on 
one ruler

Hold down the Ctrl key, then drag
from the other ruler.

Return the zero 
point to the 
lower-left corner
of the page

Double-click the intersection of 
the two rulers.

Change ruler 
subdivisions

Choose Tools > Ruler & Grid. 
Under Rulers, choose the kind of
subdivisions you want.

Hide the rulers Choose View > Rulers to 
uncheck the Rulers options. To 
create guides and guide points, 
rulers must be visible.



Using guides to reposition multiple shapes
    Related Topics

When you need to precisely align several shapes and keep them in the same position even when you 
move them, guides and guide points are very useful. You can glue shapes to guides and guide points so 
that when you move the guide the shapes move with it. 

NOTE    You can glue shapes to rotated guides, but if you rotate a guide after a shape is glued to it 
(whether the guide was rotated when you glued the shape to it or not) the glue breaks.

Methods for using guides to reposition multiple shapes
To Do This

Align shapes 
with a guide or 
guide point

Drag shapes until their selection 
handles, endpoints, or connection 
points align with the guide or 
guide point.

Glue a 1-D 
shape to a 
guide

Make sure the glue options are 
set appropriately in the Snap & 
Glue dialog box. Drag one of the 
shape's endpoints to the place on 
the guide where you want to glue 
it. When the shape is successfully 
glued, the endpoint turns red.

Glue a 2-D 
shape to a 
guide

Drag the shape to the place on 
the guide where you want to glue 
it. When the shape is successfully 
glued, the selection handles on 
the glued part of the shape turn 
red.



Specifying exact size and position for shapes and guides
    How To
    Related Topics

With the Shape > Size & Position command, you can

· Set the position and degree of rotation of shapes and guides on the page, as well as the dimensions of
shapes, using precise numerical values.

· Obtain precise size and position information about selected shapes or guides.

· Resize and move one shape or several shapes at once.

For a 1-D shape, use the Size & Position command to

· Resize a shape vertically, horizontally, or in both directions.

· Change the position of a shape's begin point while keeping the end point stationary.

· Change the position of a shape's end point while keeping the begin point stationary.

· Change the height or angle of rotation of a shape.

For a 2-D shape, use the Size & Position command to

· Change the width and height of a shape.

· Change a shape's angle of rotation.

· Flip a shape vertically or horizontally.

· Move a shape by changing the x- and y-coordinates of its pin, or point of reference.

· Change the position of a shape's pin on the shape.

For a guide or guide point, use the Size & Position command to set the orientation and position.



To set a 1-D shape's size or position precisely:

1. Select the shape.

2. Choose Shape > Size & Position, or click the status bar.

3. In the Show section, choose one of the following options:

To change the position of the shape's begin and end points or to change the shape's height, choose 
Begin And End Points (the default option).

To change the position of the shape's begin point (the end point remains stationary) or to change the 
length, angle of rotation, or height of the shape, choose Begin, Length, Angle.

To change the position of the shape's end point (the begin point remains stationary) or to change the 
length, angle of rotation, or height of the shape, choose End, Length, Angle.

4. In the Parameters section, specify values for any or all of the options:

If you chose Begin And End Points in the Show section, specify a value in the Begin X or End X box to 
resize the shape horizontally; specify a value in the Begin Y or End Y box to resize the shape vertically;
or specify a value in the Height box to change the shape's height.

If you chose Begin, Length, Angle in the Show section, specify a value in the Begin X or Begin Y box to
change the position of the shape's begin point, or specify a value in the Length, Angle, or Height box to
change the size and position of the shape.

If you chose End, Length, Angle in the Show section, specify a value in the End X or End Y box to 
change the position of the shape's end point, or specify a value in the Length, Angle, or Height box to 
change the size and position of the shape.

5. Click Apply to see the results before you close the dialog box, or click OK to apply the changes and 
close the dialog box.

TIP    To move a shape without resizing or rotating it, change the values in the Begin X and End X or 
Begin Y and End Y boxes by the same amount. For example, to move a shape down one inch, decrease 
the values of Begin Y and End Y by one inch each. To resize and rotate the shape at the same time, enter
new values for both the x- and y-coordinates.
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To set a 2-D shape's size or orientation precisely:

1. Select the shape.

2. Choose Shape > Size & Position, or click the status bar.

3. In the Size section, specify values for the shape's width, height, and angle of rotation. You can also 
check options to flip the shape vertically or horizontally.

4. Click Apply to see the results without closing the dialog box, or click OK to apply the changes and close
the dialog box.
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To set a 2-D shape's position or reference point precisely:

1. Select the shape.

2. Choose Shape > Size & Position, or click the status bar.

3. To move the shape, specify values in the X and Y boxes in the Position section.

4. To change the shape's reference point, or pin, click the grid section on the shape diagram that 
corresponds to the point to which you want to move the pin.

The X and Y coordinates in the dialog box indicate the location of the shape's pin on the drawing page.
Therefore, when you change the location of the pin on the shape, the shape's position on the drawing 
page changes. 

5. Click Apply to see the results without closing the dialog box, or click OK to apply the changes and close
the dialog box.
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To set a guide's position or rotation precisely:

1. Select the guide or guide point.

2. Choose Shape > Size & Position, or click the status bar.

3. To change the orientation of a guide, choose Horizontal, Vertical, or Rotated in the Guide Orientation 
section.

4. To move the guide or guide point, specify values in the X or Y boxes (or both) in the Guide Parameters 
section.

5. To set the angle of rotation for a rotated guide, type a value for Angle in the Guide Parameters section.

6. Click Apply to see the results without closing the dialog box, or click OK to apply the changes and close
the dialog box.
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To set the size and position of multiple shapes precisely:

1. Select all of the shapes you want to size.

2. Choose Shape > Size & Position, or click the status bar.

3. Type values or select options that you want, then click OK.

4. Click Apply to see the results without closing the dialog box, or click OK to apply the changes and close
the dialog box.

    Overview



Aligning and distributing shapes
    How To
    Related Topics

As you move shapes, you can align them with ruler intervals and grid lines. You can also

· Align shapes to other shapes. You can align the tops, bottoms, left sides, right sides, or centers of 
shapes.

· Create guides or guide points and align shapes to them. When shapes are glued to a guide, the 
aligned shapes move with the guide.

· Distribute three or more shapes to create an equal distance between the ends or centers of the 
shapes.

When you're aligning shapes to one another, the primary shape, indicated by green handles, is the shape 
to which other shapes align. You can establish a certain shape as primary by selecting that shape first, 
then Shift+clicking to select the other shapes you want to align to the primary one. If you drag a selection 
net around several shapes, the top shape in the stacking order is the primary shape.



Aligning shapes
When you move the shapes, faint lines on the vertical and horizontal rulers indicate where you're moving 
the shapes. If you don't see the rulers, make sure Rulers is checked in the View menu.

By default, the ruler zero point is at the lower-left corner of the drawing page. Sometimes it's useful to 
change the position of the zero point. For example, you might want to measure the distances between 
shapes that aren't near the current zero point. 

To align shapes to a primary shape:

1. Select the shape to which you want to align other shapes, then Shift+click to select the shapes you 
want to align.

2. Choose Tools > Align Shapes.

NOTE    You can also use one of the six align shapes buttons on the Shape toolbar: align left ( ), align 
center (

), align right (
), align top (
), align middle (
), or align bottom (
).

3. Select the alignment options you want.

Each alignment option is represented by an illustration. Choose an Up/Down Alignment or a Left/Right 
Alignment option, or one of each. To cancel the selection of either Alignment option, click the red X in 
that section.

4. To create a guide and glue the shapes to it, check Create Guide And Glue Shapes To It.

If you choose this option, you can move all the shapes and maintain their alignment by selecting and 
moving the guide.

5. Click OK.

To align shapes to a guide:

1. Drag a guide from a ruler onto the drawing page. The guide appears as a green line (it appears as a 
blue line when deselected).

2. Choose Tools > Snap & Glue to make sure that Glue is checked under Currently Active and Guides is 
checked under Glue To, then click OK.

TIP    You can automatically create a guide and glue shapes to it using the Align Shapes command. 
Simply check Create Guide And Glue Shapes To It in the Align Shapes dialog box.

To align shapes to a guide point:

1. Point to the crossbar at the intersection of the two rulers, then drag to where you want the guide point.

The guide point appears as two blue crossed lines.

2. Position shapes you want to align with their centers, selection handles (for 2-D shapes), or endpoints 
(for 1-D shapes) on the guide point.
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Distributing shapes
You can distribute three or more shapes to create an equal distance between the ends or centers of the 
shapes. When you distribute shapes vertically, the top and bottom shapes in the selection define the 
boundaries of the distribution. For horizontal distribution, the boundaries are defined by the leftmost and 
rightmost shapes.

To distribute shapes using the Distribute Shapes command:

1. Shift+click to select three or more shapes.

2. Choose Tools > Distribute Shapes.

You can also use one of four Distribute Shapes buttons on the Shape toolbar: distribute centers 
horizontal ( ), distribute horizontal spacing (

), distribute centers vertical (
), or distribute vertical spacing (
).

3. Choose a distribution option.

4. To add guides and glue the shapes to them, check Create Guides And Glue Shapes To Them.

If you choose this option, you can move an outermost guide to redistribute all the shapes.

5. Click OK.

Visio distributes the shapes evenly between the two outermost shapes. 

To distribute shapes using evenly spaced guides:

1. Drag the first guide from the appropriate ruler.

2. To create the second guide, hold down the Ctrl key and drag from the first guide to where you want the 
second guide.

3. Press F4 to create additional guides.

4. Glue shapes to the guides so they're distributed the way you want.

TIP    You can create a guide and glue shapes to it using the Distribute Shapes command. Check Create 
Guides And Glue Shapes To Them in the Distribute Shapes dialog box.
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About measuring and scaling in drawings
    Related Topics

When the drawings you create represent real-world objects that are larger than the paper size, such as a 
potted plant or a grand piano, you need to draw to scale. For example, 1mm on the drawing page of an 
office layout might represent 50mm of the actual office.

In Visio, the units of measure that appear on the rulers, or "drawing units," are sizes in the real world. In 
the example above, 50mm is the drawing unit. 

"Page units" are sizes on the printed page1mm in the office layout example. The ratio of page units to 
drawing units is the "drawing scale."

When you start a drawing by opening a template, the drawing scale and units of measure are already set 
up for you. Some templates, such as the Basic Flowchart Template, have no drawing scale, because you 
use them to create abstract drawings that don't represent actual objects in the real world. 

You can change the units of measure and the drawing scale settings to accommodate the particular type 
and size of drawing you want to create.



Setting drawing scales
    How To
    Related Topics

Whenever you need to recreate the exact spatial relationships of very small or very large objects in the 
space of a drawing page, you need to set a drawing scale. 

You can set a drawing scale in any drawing. Some templates, such as the Office Layout Template, open 
with a drawing scale already set. If you want to work with a different drawing scale, you can change the 
setting. 

When you set a drawing scale, keep the following points in mind:

· Changing the scale of a drawing page does not change any background pages assigned to it, so you 
must set their scale separately if you want the foreground and background pages to match. This 
feature allows a single drawing to contain multiple scales.

· Most masters are designed for drawings with a scale of 1:1. Visio adjusts an instance of a master 
automatically if its drawing scale is more than eight times larger or smaller than the drawing scale of 
the page. If the scales differ less, Visio doesn't adjust the shape.

Scale is a page property. In a multiple-page drawing, each page can have a different scale. The rulers in each of 
these drawings reflect a change in scale.

Because drawing scale is the ratio of page units (measurements on the printed page of drawing) to 
drawing units (units of measure) that appear on the rulers and represent the real-world measurements), 
you need to make sure that you choose the appropriate measurement unit for each before you set your 
drawing scale.

For example, a drawing of a bolt may have a drawing scale of 10:1, meaning that every 10mm on the 
printed drawing represents 1mm on the actual bolt. In that case, you would set both the page units and 
the drawing units to millimeters.

In some cases, however, you may want to have a drawing scale where the ratio is made up of two 
different measurement units. For example, in a landscape layout, 1 inch on the printed drawing may need 
to represent 3 feet or even 3 yards. If you set the drawing scale as 1:3 and both the page and drawing 
units are set to inches, you won't get the scale you want. Instead, 1 inch on the page will represent 3 
inches in the landscape, which would require an enormous drawing!



To set default page units:

1. Choose Tools > Options, then click the Default Units tab.

2. For Page, choose the units of measure you want. 

You can also set default Text, Angle, and Duration units.

3. Click OK.
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To set drawing units for a particular page:

1. Display the page for which you want to change the drawing units.

2. Choose File > Page Setup, then click the Page Properties tab.

3. Choose the units of measure you want, then click OK.

The rulers will show the new measurement units. 
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To set a drawing scale:

1. Display the page for which you want to set a scale.

2. Choose File > Page Setup, then click the Drawing Scale tab.

3. Choose a standard architectural or engineering scale, or enter a custom scale in the Drawing Scale 
edit box, then click OK.

Visio redraws the page and adjusts the rulers to reflect the new settings.
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About protecting shapes and files
    Related Topics

If you plan to share drawings, stencils, or templates with other people, you may want to protect the files, 
the shapes you create, or certain aspects of a drawing to prevent inadvertent changes. 

You can protect shapes and drawings using the following methods:

· Lock shapes to prevent them from being modified in specific ways. For example, you can lock a shape 
against rotation or resizing.

· Lock a layer so no shape on that layer can be modified. For example, if you give an office layout to an 
electrical wiring planner, you can lock all layers except the one for the wiring so that no other aspects 
of the layout are available for editing. 

· Place shapes, such as logos or title blocks, on a background so they won't be affected by changes 
made to the drawing page. 

· Prevent attributes of a drawing, such as styles, from being modified.

· Save a file as read-only, so it can't be modified in any way.



Locking shapes against changes
    How To
    Related Topics

You can lock shapes using the Protection command to protect them from resizing, repositioning, rotating, 
deleting, and selecting.

When a shape is locked against resizing or rotating, it displays padlocks where the resizing and rotation 
handles usually appear, to indicate that those handles cannot be selected. 

Padlocks over a shape's selection handles indicate that the shape is locked against changes. Some Visio shapes are 
locked against editing in this way, such as the Auto-size shape on the Block Diagram stencil, which is locked against 
manual sizing because its size is determined by the amount of text you type in the shape. Unlocking and changing 
these shapes may cause them to behave in unexpected ways.

NOTE    The Protection section in the ShapeSheet spreadsheet includes protection options not available 
in the Protection dialog box, such as locking against cropping, editing with any drawing tool, text editing 
and formatting, group editing, and recalculation of height and width when you size the shape.



To lock a shape against selection:

1. Select the shape you want to protect.

2. Choose Format > Protection.

3. Check From Selection, then click OK. When a message box appears, click OK.

4. Choose Tools > Protect Document. Check Shapes, enter a password if you want, then click OK.

NOTE    After you click OK, you won't be able to see your password, so make sure you memorize it or 
write it down.
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To unlock shapes so you can select them:

1. Choose Tools > Protect Document, then uncheck Shapes.

2. Choose Format > Protection, then uncheck From Selection. 
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To lock or unlock other shape behaviors:

1. Select the shape.

2. Choose Format > Protection.

3. Check the shape behaviors that you want to lock or uncheck the behaviors you want to unlock, then 
click OK.

TIP    You can also use the SmartShape Wizard to lock shape behaviors. To run the wizard, choose 
Tools > Macro > Visio Extras > SmartShape Wizard.
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Saving files as read-only to prevent changes
    How To
    Related Topics

When you base a drawing on a template, or open a stencil separately, the stencil opens as read-only by 
default. That way, if you share a stencil you created with other Visio users, they can't accidentally change 
masters on your stencil. However, unless you save the stencil as read-only, other users have the option to
open it in read/write mode by clicking the Original button in the Open Stencil dialog box. 

To prevent others from changing an original stencil, template, or drawing file you create, you can save it 
as read-only. If a Visio stencil, template, or drawing file is saved as read-only, you can open a copy of the 
file for editing, but the only way to change the original file is to reset the file properties through Windows. 
For details about resetting the file properties through Windows, see your Windows documentation.

If you plan to save a stencil as read-only, you must have the original stencil open.



To open an original stencil:

1. Choose File > Stencil > Open Stencil.

2. Highlight the file icon for the stencil name you want to open.

3. Under Open, select Original, then click Open.
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To save a file as read-only:

1. Open the file and make the appropriate window active. For example, if you're saving a stencil, open the
original stencil, then click the stencil window title bar.

2. Choose File > Save As.

3. For Save In, navigate to the folder you want to save the file in.

4. For File Name, type a file name for the read-only file.

5. For Save As Type, choose the type of file you want to save, for example, Stencil (*.vss). 

6. Under Save, check Read Only.

7. Click Save.

TIP    After you have saved a file as read-only, to make the file read/write again use the Save As command
to save the file to another name.
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To open a copy of a read-only file:

1. Choose File > Open.

2. Highlight the file icon for the read-only file you want to open.

3. Under Open, check Copy, then click OK.
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About storing data in shapes
    Related Topics

A Visio drawing is more than a picture¾it's a valuable medium for storing data. A shape can act as a 
visual database field that stores data you can retrieve in a report. For example, a shape in a flowchart can
store data about the cost, duration, and resources involved in the process the shape represents.

Custom-property fields are stored in their own section of the shape's ShapeSheet spreadsheet. You can add fields 
using the Custom Properties Editor.

To store data with a Visio shape, give the shape custom-property fields into which others can enter 
custom-property data. Many Visio shapes come with some custom-property data already assigned in 
custom-property fields.



Adding data to shapes' custom-property fields
    How To
    Related Topics

Many masters already include custom-property fields. All you have to do is enter the data. For example:

· Flowchart masters include custom-property fields in which you can enter cost, duration, and resources.

· Office layout masters include fields for inventory number and owner.

You can also create custom-property fields if the fields you want don't already exist.



To find out if a shape has custom-property fields:

· Select the shape, then choose Shape > Custom Properties.

If the shape has property fields, the Custom Properties dialog box appears, listing the property fields 
and describing their purpose. If the shape doesn't contain custom-property fields, a message appears 
to that effect.

    Overview



To enter values in a shape's custom-property fields:

1. Select the shape to which you want to add the data.

2. Choose Shape > Custom Properties.

3. Enter the data you want in each field, then click OK.

TIP    You can also enter custom-property data by right-clicking the shape then choosing Properties or, for 
some shapes, a "Set…" command for setting a particular property.
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Adding, editing, and deleting custom-property fields
    How To
    Related Topics

To develop your own custom solution, you may want to edit existing custom-property fields, add new 
ones, or delete fields you don't need. You may also want to add custom-property fields to new shapes you
create. You can do all these things with the Custom Properties Editor.

With the Custom Properties Editor, you can make changes only to masters on stencils. You can edit 
shapes on the following stencils:

· A standalone stencil that comes with your Visio product.

· A stencil that you created.

· A particular drawing's local stencil. Changing the shapes on a drawing's local stencil updates the 
instances on the drawing page.

Choosing where to edit custom-property fields
Where you edit custom-property fields depends on what you intend to do with the shapes. If you want to 
reuse a master with updated custom-property fields in several drawings, edit the master's properties in 
the standalone stencil. If you want to apply the updated properties to the current drawing only, edit the 
master's properties on the local stencil.

Editing in a standalone stencil    A standalone stencil is a file with a .vss extension. Stencils that open 
with templates are standalone stencils. You can also open standalone stencils separately to use with any 
drawing.

If you edit custom-property fields for a master in a standalone stencil, the changes are available in new 
drawings you create after saving the new property fields for the master.

Editing in a local stencil    A local stencil is the stencil associated with a particular drawing. It contains all
the masters you've dragged from standalone stencils to that drawing, even if you've deleted the instance 
of the master from the drawing. Unless you save a local stencil as a file (so it becomes a standalone 
stencil), it's available only when you open the drawing with which it's associated. 

A shape on a drawing page inherits its styles and properties from the master on the local stencil. 
Therefore, if you edit custom properties for a master on the local stencil, you also edit all the instances of 
that master in the drawing. In addition, each new instance you create by dropping the master from the 
standalone stencil to the same drawing inherits the custom-property edits you made.



To edit, add, or delete custom-property fields:

1. Choose Tools > Macro > Custom Properties Editor.

2. On the first screen, choose the location of the masters you want to edit, then click Next.

3. Follow the remaining screens.

NOTE    Many Visio shapes come with custom-property fields already assigned. It's best not to delete 
these fields because they can affect other aspects of shape behavior.

To see the changes you've made to a shape's custom-property fields:

1. If you edited a master on a standalone stencil, drop an instance of the master with the custom 
properties you edited onto a drawing page. 

If you edited a master on a local stencil, select an instance of that master on the drawing page.

2. With the shape selected, choose Shape > Custom Properties, or right-click the shape and choose 
Properties.

The Custom Properties dialog box appears, showing the changes you made.

After you add, edit, or delete custom-property fields, you can add data to the fields.
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Creating reports from custom data
    How To
    Related Topics

If shapes have custom-property fields in which you have entered data, you can generate inventory and 
numeric reports based on that data. Visio places your report data in a spreadsheet, which you can save 
as a Microsoft Excel worksheet (.xls) or a text file (.txt). The results appear in one or more report shapes 
in your drawing. 

A numeric report can include calculations for totals, averages, maximums, minimums, and medians, as well as any 
advanced calculations you can perform using formulas in a spreadsheet. This report shape shows totals for the cost, 
resources, and duration properties.

Layers and reports
When you want to generate more than one report for a drawing, you can use layers to assign your shapes
to separate categories, and then create reports based on the categories. For example, in a process 
flowchart, you can assign the shapes associated with each subprocess to a separate layer. Then you can 
easily generate an inventory report for the entire process that lists the cost, time, and resources 
associated with each step. You can also generate separate numeric reports for each subprocess that 
calculate the total or average costs for each step in the subprocess.

If you generate a report on shapes not on a layer, Visio creates a new layer and assigns the selected 
shapes to it. The layer doesn't affect the appearance of your drawing¾it places the shapes in a category 
that you can select, hide, lock, print, or color separately. Having shapes on a layer also makes it easier to 
update a report.



Generating numeric and inventory reports
You have options for limiting and presenting reports. For example, you can report on all shapes in a 
drawing or only on selected shapes, and you can choose the properties you want the report to include. 
You can decide which drawing page to place the report shape on and you can add subtotal reports to 
each drawing page. Your report shapes can include document information, such as creation date and 
time.

To generate a numeric or inventory report:

1. Choose Tools > Property Report.

2. On the first screen of the Property Reporting Wizard, click Next.

3. On the second screen, choose the shapes you want to report on, then click Next.

4. Follow the wizard screens.

TIP    When you run the Property Reporting Wizard, you have the option of saving the spreadsheet. If you 
save it, you can open it in any program, such as Microsoft Excel or Windows Notepad, that can open .xls 
or .txt files.
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Generating quick inventory reports
For certain types of drawings in which you may incorporate data frequently, such as network diagrams, 
office layouts, and organization charts, you can quickly export an inventory report based on the shapes 
you specify and their custom properties. You save the exported information in a Microsoft Excel file, a 
Microsoft Access file, or a Text file.

To generate a quick inventory report:

1. Select the shapes you want to report on.

2. Choose Tools > Export [data].

3. Click the Properties button to choose which properties to include in your report.

4. Choose whether to report on all pages in the document, whether to report on all shapes or selected 
shapes, and whether to create a report in Excel, Notepad, or Access.

5. Type a name for, or navigate to locate, the report file, then click OK.
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Updating and revising reports
    How To
    Related Topics

When you run the Property Reporting Wizard to create an inventory report, it creates a report shape that 
contains the data you specified. Once a report shape is on a drawing page, you can edit the shape data 
to update the report. 

When you update a report, you also update the spreadsheet if you saved it when you first generated the report. You 
can save the revised spreadsheet under a new name or replace the original. 



To update a report:

· Right-click the report shape, then choose Update Property Report from the shortcut menu.

If you saved the spreadsheet when you first generated the report, the wizard opens a new spreadsheet
that includes the revised report results. You can save the revised spreadsheet under a new name or 
replace the original one.
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To replace the title for a report shape:

1. Select the report shape.

2. Choose the text tool from the Standard toolbar, click the existing title, select the text, then type a new 
title.
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Creating databases from shape properties
    How To
    Related Topics

You can run the Database Export Wizard to export data from shapes into a database table. For example, 
you can create an inventory report for shapes in an office layout or network diagram. In the process of 
running the wizard, you can select the ShapeSheet cells from which you want data exported.

You can either generate a new database, overwrite data in an existing database table, or insert a new 
table into an existing database. The wizard works with any ODBC-compliant database application.

If you want to insert a table into an existing database, the database must be defined as an ODBC-data 
source. You can define the database as a data source within the Database Export Wizard. When you 
create a new database in the wizard, you also define it as a data source.

You can export data for every shape in the drawing or for selected shapes. You can select the shapes 
with data you want to export by placing those shapes on a separate layer. The wizard prompts you for the
appropriate layer.

When you export, the wizard determines the most appropriate data type for the information in each cell or 
field you're exporting. You can change the data type settings and you can specify how you want to 
interpret the data (for example, as a formula, value, number, or number with a particular set of units).

Each shape in the drawing is represented by a record (or row) in the database table and each custom-property field 
or ShapeSheet cell is represented by a field (or column). Data you enter in the custom-property fields in Visio or in 
ShapeSheet cells appear as values in the database table cells.



To create a database from shape properties:

1. Open the drawing with shape data you want to export.

2. Choose Tools > Macro > Database > Database Export.

3. On the first wizard screen, click Next.

4. Follow the wizard screens. 

TIP    When you run the Database Export Wizard to export shape data, the wizard stores export-related 
information with the drawing page. If you make changes to the shapes and want to re-export the data, you
can right-click the drawing page and choose Database Table Export.
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About creating drawings from data
    Related Topics

You can use data created in programs other than Visio to generate drawings. The data is represented 
graphically by Visio shapes. Drawings and shapes created in this way are called "data-driven."

The data can be in text (.txt), Microsoft Excel (.xls), or Microsoft Project exchange (.mpx) format, or it can 
exist in a database created in an ODBC-compliant database application. ODBC stands for Open 
Database Connectivity, which is a standard Microsoft interface that allows applications to access, view, 
and modify data from a variety of databases.

For example, from 

· A human-resources employee database, you could generate a corporate organization chart.

· A data file that lists project tasks, resources, start dates, and end dates, you could generate a project 
timeline.

· A text file that includes information about shapes and links, you could generate a flowchart.

You can also create data-driven shapes and drawings by establishing links between Visio objects and 
records in database tables.



Creating organization charts from data files
    How To
    Related Topics

Visio includes stencils with shapes that make it easy for you to create organization charts. Often, 
however, electronic data files already exist that include the information about your corporation or group 
that you'd want the organization chart to convey. For example, many corporations have human-resources 
data files that list employee names, job titles, managers, and more. Using the Organization Chart Wizard, 
you can use the data from such a data file to generate an organization chart.

The Organization Chart Wizard can read data files in the following formats:

· Microsoft Excel (.xls)

· Org Plus (.txt)

· Text (.txt), tab- or comma-delimited

· The file format for a database created in an ODBC-compliant database application, such as Microsoft 
SQL Server, Microsoft Access, and Oracle SQL Server. The database must be a "flat file," that is, all 
the data the wizard requires must reside in one database table.

If you don't have such a data file, the wizard provides templates you can use to create one in Microsoft 
Excel or text file format.



Setting up an organization chart data file
In the data file, each row represents a box (or employee) in the organization chart. Each column 
represents data about the employee. The data file must include at least three columns that provide

· An ID number or name that uniquely identifies each employee.

· Employee name.

· Who the employee reports to.

The data file can also include additional columns for other data, such as telephone number, office 
location, and more. When you run the wizard, you can add the optional columns to the organization chart 
shapes as custom property fields.

If you have custom shapes you want the wizard to use when it creates the organization chart, you must 
include a column named Master_Shapes in the data file. In each row, type the name of the shape you 
want to use.

You'll get the best results by setting up the data file you want the Organization Chart Wizard to read so 
that it conforms to certain requirements. The following comma-delimited text (.txt) file illustrates how to set
up your data file.

Your data file must include the following:

A Information broken out under the column headings Unique_ID, Name, and Reports_To, or equivalent columns with 
different names. If your data file uses different heading names, the wizard prompts you to indicate which columns it
should use to find this information. You can include additional columns, as shown here, but they are not required by
the wizard.

B A field that uniquely identifies each record from the database. If each employee has a unique name, the Name field
can serve as the unique identifier field. Otherwise, you must provide another field, such as Unique ID or Employee 
Number. 

C Placeholders for columns with no data in them. In a spreadsheet or database table, leave the columns blank. 

D Entries in the Reports_To column for all the records except one (the one for the person at the top of the chart). Use 
the unique identifier in the Reports_To column to indicate to whom a person reports. 

E In an Excel data file, use a single quotation mark before any telephone numbers you want to include. For example, 
enter a telephone number in Excel as '555-4497. The single quotation mark tells Excel to treat the number as a 
string (rather than as an integer).

F Shape names in this column for any shapes (including custom shapes you create) you want the organization chart 
to substitute for its own default shapes while creating the chart.

NOTE    You can add comment lines to a text file. Use a single quotation mark as the first character in a 
comment line to tell the wizard that the line does not contain data.

To draw an organization chart from an existing text or Microsoft Excel file:

1. In Visio, choose File > New > Business Diagram > Organization Chart Wizard.

2. On the first screen, click Next.

3. On the second screen, click Read Data From Existing File, then type the file location and name, or 



click Browse to locate the file.

4. Follow the wizard screens. 
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Creating an organization chart from a database table
With the Organization Chart Wizard, you can create an organization chart from a database table and link 
the chart and the table so that you can pass information back and forth to keep the two files synchronized.
For example, you can change an employee's phone number and manager information in the database 
and then refresh the chart to reflect the changes.

In the wizard, you can choose options that control which direction information flows. For example, if the 
database table is the human resources database for your corporation, you may not want changes you 
make in the organization chart to affect the database.

NOTE    The Organization Chart Wizard requires that the database you are linking to be defined as an 
ODBC-compliant data source. You can define the database as a data source by clicking Create Data 
Source on one of the wizard screens.

To create an organization chart from a database table and link the two files:

1. In Visio, choose File > New > Business Diagram > Organization Chart Wizard.

2. On the first screen, click Next.

3. On the second screen, click ODBC Data Source.

4. On the third screen, choose the data source you want the wizard to read, then click Next.

If your database does not appear in the list, it is probably not defined as an ODBC data source. Click 
Create Data Source, then follow the instructions onscreen until you are returned to the wizard, then 
choose your database in the list.

5. Follow the wizard screens. 
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Creating a data file using a template
If you haven't already created a data file, you can run the Organization Chart Wizard to open a data file 
template in text (.txt) or Microsoft Excel (.xls) format. The template is set up with the correct column 
heading structure so that you can enter your data.

NOTE    You can also open the templates without running the wizard. Both template files are named Org 
Chart Data Template and are located in the \Visio\Solutions\Business Diagram folder. Check the file icon 
to determine which template you want to open. 

To create a data file using a template:

1. In Visio, choose File > New > Business Diagram > Organization Chart Wizard.

2. On the first screen, click Next.

3. On the second screen, click Enter Data In New Text File or Enter Data In New Microsoft Excel 
Workbook, then click Next.

4. Follow instructions on the wizard screens for entering data into a text or Excel template.

5. After entering the data in the template, name and save the file. Choose Tools > Macro > Business 
Diagram > Organization Chart Wizard to restart the Organization Chart Wizard and, on the second 
screen, choose Read Data From Existing File.
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Organization Chart Wizard troubleshooting
If the Organization Chart Wizard is unable to read your data file or produces an unexpected result, check 
your file for the following:

· Missing tabs or commas from your data file. 

· Any records that are not uniquely identified. 

· Circular references¾that is, a person who reports to him or herself or to a subordinate.

· More than one record without an entry in the Reports_To column. Only the Reports_To record for the 
person at the top of the chart should be left blank.

To simplify working with data files, create your files using one of the two organization chart data-file 
templates that ship with Visio.

    Overview



Creating project timelines from data files
    How To
    Related Topics

Using the Project Timeline Wizard, you can generate a timeline from a data file created in another 
application that contains task names, start and end dates, dependencies, resources, and other 
information.

The wizard requires that the data file be in comma- or tab-delimited text (.txt), Microsoft Project exchange 
(.mpx), or Microsoft Excel (.xls) format.

If you haven't already created a data file, you can run the Project Timeline Wizard to open a data file 
template in text (.txt) or Microsoft Excel (.xls) format. The templates are set up with column headings in 
place so that you can simply enter your data.

NOTE    You can also open the templates without running the wizard. Both template files are named 
Timeline Data Template and are located in the \Visio\Solutions\Business Diagram folder. Check the file 
icon to determine which template you want to open. 

Even if you don't have a data file, you can run the Project Timeline Wizard and create a project timeline to
which you add data later. While running the wizard, you can choose format (for example, whether or not 
to display vertical and horizontal lines) and style (for example, taskbar color) options.

Setting up a project timeline data file
You'll get the best results by setting up the data file you want the Project Timeline Wizard to read so that it
conforms to certain requirements. The following comma-delimited text (.txt) file illustrates how to set up 
your data file.

Your data file should adhere to the following guidelines:

A Information should be broken out under the column headings Task#, Task Name, Duration, Start Date, End Date, 
Dependency, Resource. (If a task includes a Start Date and a Duration, you don't have to include an End Date.) 

B For milestones, specify only a Start Date.

C Include placeholders for columns with no data in them. 

D For Dependency, use the number of the task that the current task is dependent upon.

E Abbreviate durations as follows:    "d" for days, "w" for weeks, or "m" for months.

F For Resource, you can use anything you want, including names or number of people. Data in the Resource column
doesn't automatically appear in your project timeline drawing. You can choose to display Resources in timeline bars
when you run the Project Timeline Wizard, or you can add a Resource column to the project timeline on the 
drawing page. 



To create a project timeline from an existing data file:

1. Choose File > New > Business Diagram > Project Timeline Wizard.

2. On the first screen, click Next.

3. On the second screen, click Import MPX File to import a Microsoft Project exchange file or Read Data 
From Existing File to have the wizard read a text (.txt) or Microsoft Excel (.xls) file.

4. Type the file location and name or click Browse to locate the file.

5. Follow the wizard screens. 
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To create a data file using a template:

1. Choose File > New > Business Diagram > Project Timeline Wizard.

2. On the first screen, click Next.

3. On the second screen, click Enter Data In New Text File or Enter Data In New Microsoft Excel 
Workbook, then click Next.

4. On the third screen, type a name for the data file, then click Next.

5. If you chose to enter data into a new text file, the wizard opens a comma-delimited text file with column
headings in Notepad. Enter your data, name and save the file, and exit Notepad. In Visio, choose 
Tools > Macro > Business Diagram > Project Timeline Wizard. On the second screen, confirm that the 
text file listed is the one you just created, then follow the wizard screens.

Or, if you chose to enter data into a new Excel workbook, the wizard opens an Excel workbook with 
column headings. Enter your data. Name and save the file, then choose Tools > Macro > Business 
Diagram > Visio Timeline Wizard and follow the wizard screens.
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Creating connected drawings from text files
    Related Topics

If you have a large amount of existing data in text files, you can import the data using the Visio text import
filter, and then convert it to drawings. The text files must be in Comma Separated Variable (.csv) or Text 
(.txt) format.

You can create the files in a spreadsheet application, a word-processing application, or a text editor such 
as Notepad. For example, you can use a spreadsheet application, such as Microsoft Excel, to create an 
employee list that you can convert to an organization chart. Then you can export that data to .csv or .txt 
format and import it into Visio to convert the data to a drawing.

To import a text file and create a drawing, you must set up the text file in a certain way. The example 
below shows you a text file that has been set up correctly and the drawing the text file creates. Following 
the drawing, you can find additional details about text file structure, text delimiters, record delimiters, 
comment lines, and record types.

This text file:
;Shape,ID,Master,Text,X,Y,Width,Height,Property
Shape,PATRICIA,,Patricia Rodman
Shape,STEVE,,Steve Melvin
Shape,TROY,,Troy Morris
Shape,ELIZABETH,,Elizabeth Davis
Shape,SARAH,,Sarah Wright
;Link,ID,Master,Text,From,To
Link,,,,PATRICIA,TROY
Link,,,, PATRICIA,STEVE
Link,,,,TROY,ELIZABETH
Link,,,,TROY,SARAH

Becomes this Visio drawing:

Text file structure
To compose a file that the Visio text import filter can translate, create records of various types, each 
containing individual fields. Generally, each line of text in the file is considered a separate record, and the 
first field in a record identifies the record type. In the example file above, there are five "Shape" records 
and four "Link" records. Shape and Link are the record types. Each record is divided into fields by a field 
separator character. In .csv files, the default field separator character is the comma; in .txt files, the 
default character is the tab.

Text delimiters
The Visio import filter interprets anything enclosed in double quotation marks as text, including numbers 
and characters that may otherwise have a special meaning, such as the End-of-Line character. Using text
delimiters is optional¾if you do not enclose a text field within quotes, the filter assumes any field that isn't 
a number or special character is text.



Record delimiters
To begin a new record, type an End-of-Line character, or hard carriage return. (Press the Enter key on 
your keyboard.) If a hard carriage return is part of a text field enclosed in double quotes, it is not 
interpreted as a record delimiter.

Comment lines
If you want to add comments to the file that aren't part of the drawing, type a semi-colon (;) at the 
beginning of a line, then type your comments. In the example above, the comment lines help you 
remember the order of the fields by listing the field headings.

Record types
To code a text file for importing into Visio, you should be familiar with the record types that the Visio text 
import filter recognizes and the fields used with each type.





About data-driven shapes and drawings
    How To
    Related Topics

By establishing connections between shapes and database records, you can create Visio drawings that 
function as visual representations of data. You can also generate new masters from database records. 
Once you've established a shape-record connection, you can pass information back and forth between 
Visio and the database and keep the two versions of the data synchronized.

For example:

· From a personnel database, you can generate business cards for all of your employees.

· From a parts-specifications database, you can generate masters for your employees to use in 
drawings.

· By connecting an inventory database to an office space plan, you can track furniture and equipment. If 
you delete a chair from the office plan, you also delete a record from the database.

You can use the Database Wizard to connect Visio drawings to databases created in applications 
compliant with the Open Database Connectivity (ODBC) standard, a Microsoft interface that allows 
applications to access, view, and modify data from a variety of databases. ODBC-compliant applications 
include Microsoft SQL Server, Microsoft Access, and Oracle SQL Server.

Before you can connect Visio shapes and drawings to database records, you must have the appropriate 
ODBC components and database drivers installed on your computer. (Choose Complete while installing 
Visio to install the ODBC components and drivers.) In addition, the database you want to connect to must 
be defined as an ODBC data source.



Defining a database as an ODBC data source
You can define a database as an ODBC data source through the Windows control panel. Or you can run 
the Database Wizard to link a shape or drawing to a database and define your database as a data source
without leaving the wizard.

To define a database as an ODBC data source:

1. From the Windows 95 Start menu, choose Settings > Control Panel.

2. In the Control Panel, double-click the ODBC icon. The icon may be called 32-bit ODBC.

If the icon doesn't appear, you may have chosen Custom or Minimum when you installed Visio. To 
install the ODBC components, begin the Visio installation process again. Choose Custom for the type 
of installation, then choose to install only Database Tools.

3. If you're using Office 95, in the Data Sources dialog box, the databases that are set up as data sources
appear under User Data Sources. If your database isn't listed, click Add.

If you're using Office 97, in the ODBC Data Source Administration dialog box, the databases that are 
set up as data sources appear under User Data Sources. If your database isn't listed, click Add.

4. If you're using Office 95, in the Add Data Source dialog box, select the driver for the application in 
which you created your database, then click OK.

If you're using Office 97, in the Create New Data Source dialog box, select the driver for the application
in which you created your database, then click Finish.

5. In the Setup dialog box for the driver, locate the database you want to link to a Visio shape or drawing. 
Supply other information and options as needed, then click OK.

6. In the Data Sources dialog box, click Close. Click OK.
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ODBC Settings
If you connect to databases in multi-user environments, you may want to control certain ODBC settings, 
such as how many times the wizard attempts to update the database or how long it waits before the 
operation fails.

To control ODBC settings:

1. In Visio, choose Tools > Macro > Database > Database Settings.

2. Choose the number of retries, retry interval, or time out interval you want, then click OK.
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About shape-database connections
    Related Topics

When you connect a shape to a database, you actually connect cells in the shape's ShapeSheet 
spreadsheet to fields in a database table. The Database Wizard lets you choose which ShapeSheet cells 
link to fields in the database. If no appropriate ShapeSheet cells exist, the wizard creates new cells in the 
Custom Properties section of the ShapeSheet spreadsheet.

As a simple example, assume you had a database for colored blocks that includes fields for Block Name, 
Color, Height, and Width. In the Shape Transform section, the ShapeSheet spreadsheet includes cells for 
Height and Width. In the Fill Format section, the ShapeSheet spreadsheet includes a cell called 
FillForegnd. In the process of linking a master to the colored blocks database, you can choose to connect 
the Height, Width, and FillForegnd cells in the ShapeSheet spreadsheet to the Height, Width, and Color 
fields in the database. Because the ShapeSheet spreadsheet contains no cells that correspond to Block 
Name, you can have the wizard create such a cell in the ShapeSheet spreadsheet's Custom Properties 
section.

Values in ShapeSheet cells match values in the database records the cells are connected to. If you change the 
shape, you can pass the new values to the database. If you change the database, you can pass the new values to 
the shape's ShapeSheet spreadsheet.

When it links a shape to a database, Visio also creates a User-defined Cells section in the ShapeSheet, if
that section doesn't already exist for the shape. In this section, the wizard stores information about the 
primary key for the database table, which database fields are associated with which ShapeSheet cells, 
and the last valid data retrieved from the database. The rows Visio creates include:

· ODBCDataSource, which contains the ODBC data source name.

· ODBCQualifier, which stores the name of the database or directory that contains the linked table. This
cell contains a value only for ODBC data sources in which a single data source can support multiple 
databases or directories.

· ODBCTable, which contains the name of the linked data source table or view.



· ODBCKeyField1 to ODBCKeyField5, which contain the names of the fields (key fields) that comprise 
the primary key for the linked table.

· ODBCKeyCell1 to ODBCKeyCell5, which contain the names of the custom properties in the 
ShapeSheet that are used to store the values for the key fields named in the ODBCKeyFields cells.

· ODBCLink1, ODBCLink2, and so on (one row per linked field), which specify which data source table 
fields correspond to which ShapeSheet cells. Information about how Visio evaluates data copied from 
the field to the cell (that is, as a string or as a number) is also stored here and, if the number is a 
measurement, the row includes measurement units.

Information about how Visio evaluates data is stored in the form of numeric codes. Value (string) is 
indicated by a 0, Formula (string) is indicated by a 1, and Number is indicated by 32. For a list of the 
numeric codes corresponding to measurement units, in the online Visio Automation Reference, search 
for "result property."

· ODBCKeyMirror1 to ODBCKeyMirror5, which contain the last valid key values used when 
transferring information to or from the data source. The wizard monitors these cells to determine which 
record a shape was linked to when you changed its key values. Changes to key values in a monitored 
shape are reflected in the corresponding data source table record.

· ODBCMirror1, ODBCMirror2, and so on, which store the last valid values retrieved from linked data 
source table fields. There is one ODBCMirror cell for each cell-field link defined in the ODBCLink cells. 
The wizard uses these cells to determine whether values have changed, in the database or shape, 
since the most recent synchronization of the data.



Connecting shapes to database records
    How To
    Related Topics

The first step in establishing a connection between Visio and a database is to connect a shape to a 
database record. You can connect a shape instance, a master on the local stencil, or a master on a 
standalone stencil.

· When you connect a shape instance, no other shapes are affected. If you make copies of the shape, 
the copies are also linked.

· When you connect a master on a local stencil (the stencil made up of all the masters you've used in a 
drawing file), you also automatically connect all instances of that master in the drawing.

· When you connect a master on a standalone stencil (one of the stencils that came with Visio or one 
you created), each time you drop the master, the new instance is also connected.



To connect a shape to a database record:

1. In Visio, choose Tools > Macro > Database > Database Wizard.

2. On the first wizard screen, click Next.

3. On the second screen, choose Link A Shape To A Database, then click Next.

4. Follow the remaining wizard screens until you've completed the connection. 

    Overview



Creating drawings that represent database tables
    How To
    Related Topics

After you've connected a master on a stencil to a database, you can run the Database Wizard and create 
a drawing in which each database record is represented by a shape on the Visio drawing page. When you
create a drawing with one-to-one connections to database records, the wizard launches a drawing 
monitor. The monitor manages the connections between the Visio shapes and database records. If you 
delete a shape, the monitor informs the database table, which deletes the corresponding record. If you 
add a shape, the monitor informs the database table and a record is added. If you change a shape, the 
monitor passes on the changes and values in the database table are updated.

When you run the Database Wizard to create a drawing that represents a database table, you can control
how the drawing monitor will behave when you subsequently open the drawing. You can also establish a 
connection that allows you to pass changes from the database to the drawing, but not from the drawing to
the database.

With a global setting that affects all ODBC database-drawing connections, you can set the drawing 
monitor to refresh shapes (that is, pass any changes made in the database to the shapes' ShapeSheet 
cells) at regular intervals (the interval you set depends upon how frequently you update the database). In 
the Database Wizard, when you're creating a particular drawing, you have the option of turning the 
refresh-interval setting off for a particular master-database table link. Turning global refresh off for one link
doesn't affect any other links.

In the Database Wizard, you can set an option for opening the drawing monitor automatically each time you open a 
drawing connected to a database. You can also add a Launch Monitor action to the drawing page so you can launch 
the monitor by right-clicking the page and choosing the action command.



To create a drawing that represents a database table:

1. Run the Database Wizard and connect a master shape to a database record. Link each database field 
to a ShapeSheet cell.

2. After the master shape is connected to a database record, choose Tools > Macro > Database > 
Database Wizard to run the wizard again.

3. On the first wizard screen, click Next.

4. On the second screen, choose Create A New Linked Drawing Or Modify An Existing One, then click 
Next.

5. On the third screen, choose Create A Drawing Which Represents A Database Table, then click Next.

6. Follow the wizard screens to create the drawing. 

TIP    If you want to open an existing drawing that is connected to a database or add events and right-
mouse actions to synchronize the database and drawing, run the Database Wizard. On the second 
screen, choose Create A New Linked Drawing Or Modify An Existing One, and on the third screen, 
choose the option you want.

To set a global refresh interval for the drawing monitor:

1. In Visio, choose Tools > Macro > Database > Database Settings.

2. Check Automatically Refresh Drawing Page, type the number of seconds in the interval, then click 
Save.

TIP    When you run the Database Wizard to create a particular drawing, you have the option of turning 
the refresh setting off for a particular master-database table link.
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Creating new masters from database tables
    How To
    Related Topics

Using the Database Wizard, you can generate a set of masters that graphically represents the records in 
a database table, then save the masters on a stencil.

For example, if you maintain an inventory database of bookcases that your company manufactures, you 
can generate a master for each specific bookcase, save the masters on a new stencil, then distribute the 
stencil so everyone in the company can include bookcase shapes in their drawings and other documents.

If you expect to revise the database table, you can save the connections between the masters and the 
database records. Then, when you revise the table, you can refresh the masters so the values in their 
ShapeSheet cells match the values in the database records.

NOTE    If you don't save the connections, the masters' ShapeSheet cells contain a snapshot of the data 
that existed in the database fields at the time you created the new masters, but no information about 
which database records the data came from. If you make changes to the database, you can't refresh the 
existing masters to reflect the changes. You must run the Database Wizard again and generate new 
masters.



To generate new masters from a database table:

1. In Visio, choose Tools > Macro > Database > Database Wizard.

2. On the first wizard screen, click Next.

3. On the second wizard screen, choose Generate New Masters From A Database, then click Next.

4. Follow the screens until you create the masters. 
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Synchronizing drawings and databases
    Related Topics

When you run the Database Wizard to connect a shape or drawing to a database, you can add right-
mouse actions and ShapeSheet events to shapes or to a drawing page. You can use these actions and 
events to pass information between Visio and the database application.

· Right mouse-click actions are available on a shortcut menu that appears when you right-click a shape 
or page.

· Events represent Visio's responses to a user action, such as opening a drawing. 

NOTE    If you create a drawing that is a graphical representation of a database table, you can also use 
the drawing monitor to pass information between the drawing and the database.

Right-mouse actions and events
Action or 
event

Added to
shape or 
page

Result

Refresh 
shape on-
drop event

Shape When you drop a 
master or copy a 
shape, the values in 
the linked ShapeSheet 
cells for that shape (or 
instance) are 
automatically refreshed
to match values in the 
database.

Select record
on-drop 
event

Shape When you drop a 
master or copy a 
shape, you're 
prompted automatically
to select the database 
record that links to the 
shape instance.

Refresh 
linked 
shapes on 
document-
open event

Page Refreshes ShapeSheet
cell values for all the 
shapes in your drawing
each time you open the
drawing.

Refresh 
based on the 
NOW 
function 
event

Page Allows you to switch on
or off refreshing 
ShapeSheet cell 
values for all the 
shapes in a linked 
drawing at specific 
intervals as defined by 
the NOW function.

Select 
database 
record action

Shape Allows you to select 
the database record to 
which you want a 
shape linked.



Refresh 
shape cells 
action

Shape Refreshes the values 
in the shape's linked 
ShapeSheet cells to 
match the values in the
database.

Refresh 
shapes on 
page action

Page Refreshes the values 
in the shapes' linked 
ShapeSheet cells to 
match the values in the
database for all the 
shapes on the drawing 
page.

Update 
database 
record action

Shape Updates the values in 
the database to match 
the values in the 
shape's linked 
ShapeSheet cells.

Update 
shapes on 
page action

Page Updates the values in 
the database to match 
the values in the 
shapes' linked 
ShapeSheet cells for 
all the shapes on the 
drawing page.

Delete shape
and database
record action

Shape Deletes the shape and 
the database record to 
which the shape is 
linked.





About using Lotus Notes with Visio
    Related Topics

Visio supports a two-way exchange of data between Visio and Lotus Notes. You can

· Write data from a Visio shape, a custom formula, or the Properties dialog box to a Lotus Notes field. 

For example, you can combine Lotus Notes and Visio to keep track of a company's processes, such as
writing and prototyping specifications. In Lotus Notes, you embed a Visio diagram for each process. 
Then you create a table that shows only the titles of the processes (which is data you wrote from Visio 
to Lotus Notes). Anyone who needs to see the process can click the flowchart's title to see the 
embedded Visio diagram. Then, to edit it, the user can double-click the embedded Visio diagram to 
start Visio.

· Read data from a Lotus Notes Field and display it in Visio. 

For example, in a timeline, you can have a Lotus Notes date field automatically update the Visio 
timeline. 

Because of the way Lotus Notes and Visio interact, incompatibilities can arise when one of the programs 
is 32-bit and the other is 16-bit. The following combinations are compatible:

· 32-bit Visio products and 32-bit Lotus Notes 4.x on any 32-bit Windows platform.

· 32-bit Visio versions and Lotus Notes 3.x on Windows 95. (This combination is not compatible on 
Windows NT 3.51.)



Writing data from Visio to a Lotus Notes field
    How To
    Related Topics

You can pass data from a Visio diagram to a Lotus Notes database field. Each field in Lotus Notes that 
contains Visio data is based on either the Visio diagram's Properties dialog box, a shape, or a custom 
formula. 

NOTE    Make sure the fields in both programs have exactly the same name.



To include Visio data in a Lotus Notes field:

1. In Lotus Notes, set up the fields you want to fill in with Visio data. Note the names of these fields, 
because you will use them in Visio.

2. Choose Insert > Object, and insert a Visio drawing. You can create a new Visio drawing or insert an 
existing file.

3. If the Lotus Notes fields are not based on the drawing's Properties dialog box, add the shapes that will 
be associated with the Lotus Notes fields.

4. Select one of the shapes that will be associated with a Lotus Notes field, then choose Format > 
Special. Note the shape's ID (you'll use it in step 8).

Complete this step for each shape that will be associated with a Lotus Notes field.

5. Choose Insert > Lotus Notes Fields, then, for Field Name and Direction, type a name for the field that 
exactly matches the name of the field you defined in Lotus Notes.

6. Check Write To Notes.

7. For Data Type, select the type of data you want to exchange: Text, Time, or Number.

8. If you select Text under Data Type, type the Shape ID from step 4. The data you write to Lotus Notes 
can be the shape's name, text, copyright, or data you enter in the Data 1, 2, and 3 sections of the 
Special dialog box.

If you select Time or Number, enter a custom formula in the Custom Formula box. 

9. Click Add, then click OK.

Here is an example that uses the Number data type (in step 8 above). In the equation below, "sheet.1" is 
a shape representing an office plan's perimeter. The office plan is set up in inches. The formula multiplies 
the width and height of the walls, then divides that total by 144 to get the square footage of the office.
=(sheet.1!Width*sheet.1!Height)/144
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To include the Visio Properties dialog box data in a Lotus Notes field:

· In Lotus Notes, use field names that correspond with settings in the Visio Properties dialog box (File > 
Properties). The Visio drawing's properties are then automatically included.

The Properties dialog box fields are Title, Subject, Author, Manager, Company, Category, Keywords, 
Description, and Hyperlink Base.
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Displaying Lotus Notes data in Visio
    How To
    Related Topics

You can read data from a Lotus Notes database field, then display it in a Visio diagram. You can also use 
the Lotus Notes field data in formulas.

TIP    You may want to lock the Visio shape in which you place data from Lotus Notes so that users cannot
edit it.



To display data from Lotus Notes in Visio:

1. In Lotus Notes, set up the fields you will read into Visio. Make sure you note the names of these fields, 
because you will use them in Visio.

2. In Visio, open or create a drawing with which you want to exchange data with Lotus Notes.

3. Choose Insert > Lotus Notes Fields, then, in the Field Name and Direction section, type a name for the
field that exactly matches the name of the field you defined in Lotus Notes.

4. Check Read From Notes.

5. In the Data Type section, select the type of data you want to exchange: Text, Time, or Number.

For Number, choose the units for the number (such as centimeters) so that the user knows how to 
interpret the number. For example, a number might represent inches or centimeters; the distinction for 
the user may be very significant. 

6. Click Add, then click OK.

7. Follow one of the next procedures to either insert the Lotus Notes field in a shape as a text field or 
insert it in a shape's ShapeSheet spreadsheet.
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To insert a Lotus Notes field in a shape as a text field:

1. Select the shape in which you will insert the Lotus Notes data.

2. Press F2 to open the shape's text block, then place the insertion point where you want to insert the 
data.

3. Choose Insert > Field. 

4. Under Category, select Lotus Notes Field. Under Field, select the specific Lotus Notes field. Under 
Format, select the way you want to view the data, then click OK.

Data is passed between Visio and Lotus Notes when the programs are started, so the next time you 
open this Visio drawing file, these fields will include data from the Lotus Notes fields you inserted.
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To insert a Lotus Notes field into a shape's ShapeSheet spreadsheet:

1. Select the shape, then choose Window > Show ShapeSheet. 

2. Select the cell in which you want to insert the Lotus Notes field, place the insertion point in the formula 
bar, then choose Insert > Function. 

3. Under Select Function, choose LOTUSNOTES, then click OK. 

4. In the edit area, for "notename," type the name of the Lotus Notes field.

Data is passed between Visio and Lotus Notes when the programs are started, so the next time you 
open this Visio drawing file, the ShapeSheet will include data from Lotus Notes.

    Overview





About creating your own shapes
    Related Topics

There are several ways to create your own shapes. You can

· Draw a shape from scratch using the Visio drawing tools. For example, if you want to add a freeform 
arrow to a block diagram, you can draw the arrow with the freeform tool.

· Merge a shape with other shapes to create a new, unique shape. For example, if you want to create a 
round sign with an arrow cut out of its center, you can place an arrow shape on top of a circle, then use
the Combine command to create the shape you want.

· Revise an existing Visio shape. For example, if your company uses a special Process shape in its 
flowcharts, you can modify the Visio Process shape, save it on the Flowchart stencil, and use it in all 
the flowcharts you draw.

You can revise an individual shape for use in a specific drawing, or you can revise all instances of a 
shape in a drawing at the same time. You can also convert a new shape you create into a master and 
place the master on a stencil so you can reuse the shape in many drawings.



Drawing shapes
    How To
    Related Topics

To draw a shape, use one or more of the drawing tools on the Standard toolbar. While you're drawing 
shapes, you can use the View > Toolbars > Toolbars command to hide other toolbars and display only the
Standard toolbar

TIP    When drawing shapes, it's often helpful to use guides and grid lines to help you position the shapes.



Drawing lines or arcs
( ) If you move the pencil tool in a straight line, it draws a line. If you move it in a curve, it draws an arc. 
Each arc is a portion of a circle; its size is determined by the distance you move the mouse. 

( ) The line tool is best for drawing shapes composed only of straight lines. To constrain a line to any 45-
degree angle, hold down the Shift key as you drag.

( ) The arc tool draws arcs that are always one quarter of an ellipse. The direction you drag the mouse 
determines which way the arc bows. 

To draw a line or an arc:

1. Choose the pencil tool from the Standard toolbar.

Or choose the line tool or the arc tool.

2. Point to where you want to start the line or arc.

3. Drag to draw the line or arc, then release the mouse button.
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Drawing freeform shapes
( ) The freeform tool works like a pencil on paper. Select it and drag to draw splines and freeform curves.
For smoother curves, turn snapping off before you draw (choose Tools > Snap & Glue, then under 
Currently Active, uncheck Snap).

To draw a freeform shape: 

1. Choose the freeform tool from the Standard toolbar.

2. Hold down the left mouse button as you drag in various directions to draw a freeform shape, then 
release the mouse button.
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Drawing rectangles and squares
( ) The rectangle tool draws rectangles and squares. 

To draw a rectangle or square:

1. Choose the rectangle tool from the Standard toolbar.

2. Point to where you want a corner of the shape.

3. Drag until the shape is the size you want, then release the mouse button.

To draw a square, hold down the Shift key as you drag.
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Drawing ellipses and circles
( ) The ellipse tool draws ellipses and circles. 

To draw an ellipse or circle:

1. Choose the ellipse tool from the Standard toolbar.

2. Point to where you want to start drawing the shape.

3. Drag until the shape is the size you want, then release the mouse button.

To draw a circle, hold down the Shift key as you drag.
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Drawing shapes with multiple segments
Shapes with multiple segments are 2-D shapes. To draw a 2-D shape, start each new segment at one of 
the endpoints or at a vertex of another segment. After you complete a shape, you can add, adjust, or 
delete segments.

Endpoints (A and B)

Vertices (A) and control points (B)

To draw a shape with multiple segments:

1. Choose the pencil tool ( ) from the Standard toolbar.

Or, choose the line tool ( ), arc tool (

), or freeform tool(
).

2. To draw the first segment, point to where you want to start the shape. Press the mouse button and 
drag until the segment is the size you want, then release the mouse button. This first segment is a 1-D 
shape with endpoints.

3. To draw the second segment, point to the endpoint of the first segment (the pointer looks like a plus 
sign) and drag, then release the mouse button.

When you are creating the second and subsequent segments, be careful not to click the endpoint of 
the first segment, which selects it. A selected endpoint turns magenta. Dragging the selected endpoint 
resizes the existing segment instead of starting a new one. (If you resize a segment, rather than draw a
new one, choose Edit > Undo.)

After you draw the second segment, the shape displays vertices instead of endpoints, to indicate that 
it's a 2-D shape.

4. To draw additional segments, point to the vertex at the end of the last segment you added, then drag to
draw the next segment.

5. If you want to close the shape, drag the endpoint of the last segment you create over the vertex at the 
beginning of the first segment, then release the mouse.

TIP    You can use the freeform or ellipse tool to create a closed shape that is composed of only one 
segment.

To undo a segment while drawing:

· Before you release the mouse button at the end of a segment, draw back to the vertex at the beginning
of the segment. Make sure you hit the vertex precisely or you might not completely delete the segment.

To undo several segments:

· After you've drawn one or more segments, but before you do anything else, choose Edit > Undo. Keep 
choosing Undo until you've deleted all of the segments you no longer want. Segments are deleted in 
the reverse order in which they were drawn. By default, you can undo up to ten actions.

You can also undo an action, such as drawing a segment, by clicking the Undo button on the Standard 
toolbar, or pressing Crtl+Z or Alt+Backspace.
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Merging shapes to create new ones
    How To
    Related Topics

The easiest way to create a complex shape is to draw its simple parts, then use the Boolean operation 
commands to merge the parts into one complex whole. The result of a merge operation depends partly on
the shape you select first (the primary shape). The primary shape's formatting is used in the resulting 
shape, and, in some cases, it even determines the shape of the new shape (with the Subtract command, 
for example). You can also use Boolean operation commands to convert polygonal lines and polygons to 
lines, arcs, and freeform curves (or "splines").

Merging operations create new shapes. The old shapes, including ShapeSheet spreadsheets that define 
smart behavior, are discarded. The new shape gets its own ShapeSheet spreadsheet. 



Union
Union creates a new shape from the perimeter of two or more overlapping shapes. The new shape is a 
set of all the points that were either in one original or another. Union is the equivalent of the Boolean 
operator "OR."

Union

NOTE    Take care not to use the Union command when you simply want to group shapes together. Group
and Union are two separate operations in Visio and do not produce the same results. Union is also 
different from Combine, which deletes areas where the combined shapes overlap. 

To unite shapes:

1. Arrange the shapes that you want to unite on the drawing page.

2. Select the shapes. 

(Remember that the new shape will inherit the text and formatting of the first shape you select.)

3. Choose Shape > Operations > Union.

NOTE    If the shapes do not overlap, the Union command creates one shape, but the shapes appear 
unchanged. If a shape is open, Visio discards the open shape when you choose Union.
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Subtract
Subtract creates a new shape by "subtracting" from the primary selection the areas where subsequent 
selections overlap. For example, if you overlap a square and a circle and select the square, then the 
circle, Subtract will remove the overlapping segment of the circle from the square.

Subtract

To subtract shapes: 

1. Arrange the shapes you want to subtract on the drawing page.

2. Select the shapes. 

(Remember that Visio subtracts from the first shape you select.) 

3. Choose Shape > Operations > Subtract.
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Intersect
Intersect forms a new closed shape from the area where selected shapes overlap, eliminating non-
overlapping areas. Because Visio doesn't define specific points on a line, nothing is left if you intersect 
two overlapping lines.

Intersect

To intersect shapes:

1. Arrange the shapes you want to intersect on the drawing page.

2. Select the shapes. 

(Remember that the new shape will inherit the text and formatting of the first shape you select.)

3. Choose Shape > Operations > Intersect.
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Fit Curve
Use the Fit Curve command to create a spline from a polygonal line. The spline goes exactly through the 
polygonal line's vertices. If the polygonal line is a closed polygon, the result is a periodic (seamless) 
spline.

Fit Curve

To create a spline from a polygonal line:

1. Select the polygonal line.

2. Choose Shape > Operations > Fit Curve.
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Custom Fit
Use the Custom Fit command to reduce the number of segments in clip art or other shapes you import. 
Custom Fit makes an imported shape easier to edit and may reduce its size.

When a shape is imported, the exchange process converts it into a relatively unintelligent format. For 
example, an imported clip art shape is a dense series of points that is almost impossible to edit. Using the
Custom Fit command, you can convert polygonal lines into splines. By dragging the control points on a 
spline, you can edit the converted clip art shape.

When you use the Custom Fit command, you can specify the error tolerance. The more loosely you set 
the tolerance (that is, the greater the acceptable error), the more likely you are to reduce the size of the 
converted shape.

Some shapes on which you use the Custom Fit command occupy less disk space because Custom Fit 
replaces the many LineTo rows in the shape's ShapeSheet spreadsheet with fewer SplineKnot rows. 
When enough LineTo rows are replaced, the shape requires less disk space.

To convert an imported object into an editable format:

1. Select the shape. If the shape is a group, choose Shape > Grouping > Ungroup to ungroup it.

2. Choose Shape > Operations > Custom Fit.

3. Choose the options you want, then click OK.
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Fragment
The Fragment command can break a shape into smaller parts. You can also use it to create new shapes 
from intersecting lines or from 2-D shapes that overlap. The Fragment command provides an ideal way to
create Venn diagrams and marketing pyramids. Fragment can:

· Divide selected shapes into smaller shapes. 

· Create a new closed shape where two or more closed shapes overlap. 

· Create new shapes from the enclosed spaces of three or more intersecting lines. 

To break a 2-D shape into smaller parts:

1. Draw lines through the shape where you want to break it.

2. Select the shape and the lines.

3. Choose Shape > Operations > Fragment.

To create new shapes where 2-D shapes overlap or where lines intersect:

1. Select the overlapping shape or intersecting lines.

2. Choose Shape > Operations > Fragment.

TIP    After you fragment shapes, delete the pieces you don't need.
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Trim
You can create new shapes from existing intersecting shapes by trimming them. Trim resembles the trim 
operation in Autodesk AutoCAD, although in Visio you can trim more than two objects. Trim splits selected
objects at their intersections, including where a shape intersects itself. It creates a new shape for each 
piece, preserving the styles. If closed shapes are split open, they lose their fill. 

Trim

To trim shapes:

1. Select the shapes you want to trim.

2. Choose Shape > Operations > Trim.
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Join
Join assembles individual 1-D segments into one or more continuous paths. The number of paths 
depends upon the configuration of the selected shapes. For example, if the segments lie along a straight 
line, the new shape will have one path. If the segments lie in the form of a 2-D shape such as a rectangle,
the new shape will become a closed 2-D shape that you can fill. 

Join

To join shapes:

1. Select the segments you want to join.

2. Choose Shape > Operations > Join.
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Combine
Combine creates a new shape from selected shapes. If the selected shapes overlap, Visio cuts out, or 
discards, the area where they overlap. This creates holes in the new shape that make the drawing page 
grid visible through the shape. Combine converts multiple shapes into one shape with multiple paths, 
represented by the same number of geometry sections in the ShapeSheet spreadsheet (rather than 
multiple ShapeSheet spreadsheets).

You can also combine 1-D shapes with each other and combine 1-D and 2-D shapes. In these cases, 
Visio creates one shape from the selected shapes, but the new shape might not look different from the old
ones. The difference is that the new shape has one ShapeSheet spreadsheet with multiple sections so 
that when you apply a style, such as a fill, the style formats the entire shape. This is different from using 
the Group command, where each shape in the group retains its own ShapeSheet spreadsheet, in addition
to the group's ShapeSheet spreadsheet.

NOTE    Take care not to use the Combine operation when you simply want to group shapes together. 
Group and Combine are two separate operations in Visio, and do not produce the same results. Combine 
is also different from Union, which creates a new shape from the perimeter of two or more overlapping 
shapes, without deleting any areas of the shapes.

In this example, selecting the large rectangle first makes it the primary shape, so that when the two rectangles are 
combined, the small rectangle will be discarded, leaving a hole in the large rectangle.

For example, to create a picture frame shape (a rectangle with a hole in the middle through which you can
see what's beneath), place a small rectangle in the middle of a larger one. Select the large rectangle first, 
then the small one, and then choose Shape > Operations > Combine to combine them.

To combine shapes: 

1. Arrange the shapes you want to combine on the drawing page.

2. Select the shapes. 

(Remember that the new shape will inherit the shape and formatting of the first shape you select.)

3. Choose Shape > Operations > Combine.
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Offsetting shapes to create parallel lines and curves
    How To
    Related Topics

The Offset command creates a set of parallel lines and curves to the right and left of the original shape. 
For example, you can create a representation of a two-way road by offsetting a line. Or, you can choose 
to delete any line or curve you want, even the original, which is always positioned between the offset lines
or curves.

You can set the distance you want between the original shape and the offset shapes.

NOTE    Offset shapes inherit line styles from the original shapes. They do not inherit any fill patterns or 
text from the original shapes.

                  

The Offset command positions the offset shapes on either side of the original shape, at a distance that you specify. 

The Offset command reproduces the points of a line at a fixed distance from the line and then attempts to 
connect those lines, based on where they intersect. If the offset lines don't intersect, Visio extends them 
until they do. 

                

When creating an offset shape such as the one left of this angle (A), Visio extends the duplicate lines to make them 
meet. 

When creating an offset shape such as the one right of this angle (B), Visio deletes a portion of the duplicated lines to
prevent them from crossing. 



            

In this example (A), extending the arc and the line doesn't result in an intersection, so Visio creates offset duplicates 
of each shape and leaves them unconnected.

If the offset is wide, especially inside curves, the offset may not look like the original (B). 

Once you've offset a shape, the two new shapes each have their own ShapeSheet spreadsheets and you
can work with them independently. For example, if you only want one duplicate, you can delete the other.



To create an offset shape:

1. Select the shape from which to create the offset shape.

2. Choose Shape > Operations > Offset.

3. Type a value for the distance you want between the duplicate and the original, then click OK.
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Revising existing shapes
    Related Topics

You can revise any Visio shape or shape you draw from scratch as long as the shape isn't locked to 
prevent changes.

To revise a shape, select it with the pencil tool ( ), then drag, add, or delete vertices. To change curves, 
drag a control point or a point's eccentricity handles. 

        

        

To reshape a shape, you can drag a vertex (A), add, then drag, a vertex (B), or drag control points to edit curves (C).

        

Deleting vertex A in either of these shapes deletes the segment with which the vertex is associated. The remaining 
segments are reshaped accordingly.

Methods for revising shapes
To Do this after selecting the 

shape with the pencil tool

Select a vertex 
or control point

Click the vertex or control point 
you want to select. The selected 
item turns magenta.

Reshape angles Select one or more vertices and 
drag. (Hold down the Shift key to 
select more than one.)

Add a segment Point to where you want to add a
segment, hold down the Ctrl key, 
and click.

Delete a 
segment

Select a vertex associated with 
the segment you want to delete, 
then press the Delete key.

Change the 
curvature of an 

Drag a control point until the 
segment looks the way you want.



arc or freeform 
curve

Change the 
eccentricity (or 
symmetry) of an
arc

Select a control point, hold down 
the Ctrl key, and drag the pointer 
slightly away from the point to 
display the eccentricity handles, 
then release the mouse button. 
Drag one handle farther from or 
closer to the control point or 
rotate it around the control point 
until the arc is shaped the way 
you want.

Move the end of
a freeform curve

Select the curve, then drag a 
handle associated with the 
curve's endpoint.

TIP    If you select a shape with the pencil tool and don't see any vertices or control handles, the shape is 
probably a group. To find out if the shape is a group, select it, choose Format > Special, then check the 
Special dialog box to see if Group is listed for Type. To revise the group, select it, then choose Edit > 
Open Group. A group window opens in which you can revise the shape using the pencil tool.



Revising several identical shapes at once
    How To
    Related Topics

When you create a drawing, Visio creates a stencil specific to that drawing file called the "local stencil." 
Each time you drag a master to the drawing page, Visio copies the master to the local stencil, and then 
creates an "instance" of the master on the drawing page. Instances inherit formatting and other properties
from masters on the local stencil.

In the local stencil, you can

· Track which shapes you've used in your drawing.

· Quickly revise all instances of a shape on all pages in a drawing file by revising the master on the local 
stencil.

· Save the local stencil as a standalone stencil so you can distribute it to others who want to use the 
shapes in other drawings.

· Add shapes to the local stencil directly to make them easier to reuse later.

When you first open the local stencil, it lines up along the left side of the screen. You can drag the stencil's title bar to 
move it anywhere you want, and you can drag a side or corner to change the stencil's size. 



To open a local stencil and display the shapes you've used in your drawing:

· Choose Window > Show Master Shapes.
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Revising all shape instances at once
Local stencils provide a way for you to update all instances of a shape at once. Each shape instance in a 
drawing is linked to its master in the local stencil, so to change all shape instances at once, you simply 
modify the master. For example, in an organization chart, if you want to change the color of all the 
Position shapes' text to blue, you can simply modify the Position master on the local stencil. All instances 
of the Position shape in the drawing inherit the changes.

Shape instances in the drawing remain linked to their masters in the local stencil unless you perform an 
action that severs the link, such as ungrouping the shape in the drawing. In this case, a message appears
onscreen letting you know the action will sever the link, and you can choose to continue or cancel the 
action.

NOTE    In some cases, applying local formatting to a shape instance on the drawing page may break that
individual attribute's link to the master on the local stencil. For example, if you resize an instance on the 
drawing page and then, in the local stencil, size its master, all instances except the one you resized 
manually inherit the new size.

To revise a master on the local stencil and all of its instances on the drawing page:

1. Open the drawing you want to modify, and choose Window > Show Master Shapes.

2. Click the local stencil's title bar to make sure it's the active window, then double-click the master you 
want to modify to open it in the master drawing window.

3. In the master drawing window, revise the master.

When you're finished revising, close the master drawing window by clicking the close box. When Visio 
asks if you want to update the master and its instances, click Yes.

The instances of the shape update to show the changes. 
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Saving a local stencil for use in other drawings
Unlike the stencils that are individual .vss files, a local stencil is stored as part of a drawing's .vsd file. A 
drawing's local stencil contains a copy of every master that you dragged and dropped from a standalone 
stencil to the drawing, even if you deleted it from the drawing.

You can save a local stencil as a standalone stencil (.vss) file. After you save it, you can use it with any 
drawing, or distribute it, just as you do stencils that come with Visio products.

To save a local stencil as a standalone file:

1. Click the local stencil's title bar to make it the active window.

If the local stencil isn't open, display the drawing to which it's associated, then choose Window > Show 
Master Shapes.

2. Choose File > Save As, then, in the Save As dialog box:

Under Save In, find the folder in which you want to save the stencil. (If you save the stencil in a 
Solutions sub-folder, it appears when you choose File > Stencils.)

Under File Name, type a name for the stencil.

Under Save As Type, select Stencil (*.vss).

Under Save, uncheck the Workspace box if it's checked.

3. Click Save.
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Adding shapes to the local stencil
You can add shapes you draw to the local stencil. Not only does this make revising instances of those 
shapes easier, it also makes it easy to quickly reuse a shape by dragging it from the local stencil. If you 
plan to add a shape you draw to the local stencil, it's best to do so before duplicating and copying the 
shape¾revising the shape on the stencil doesn't revise copies of the shape that are on the page before 
you add the shape to the local stencil.

To add a shape to the local stencil:

1. Open the local stencil by choosing Window > Show Master Shapes. To arrange the windows, choose 
Window > Tile.

2. Press Ctrl, then drag the shape and drop it onto the local stencil.

TIP    To align the new master shape icon with the existing ones, right-click the green stencil 
background, then choose Arrange Icons.
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Creating shapes for charts
    How To
    Related Topics

Most charts use bars or lines to compare amounts or indicate change. By creating an extendable or 
stackable shape, you can show an amount and at the same time add special effects to charts. For 
example, you can use the People shape included with Visio to indicate an increase in employees. When 
you stretch the shape, the people duplicate. Or you can use the Growing Flower shape to indicate a 
company's growth. When you stretch the shape, the flower's stem grows longer. 

Visio includes stackable shapes, such as People and Stack Of Papers, and extendable shapes, such as 
the Growing Flower and the Pencil. You can also create your own stackable or extendable shapes.



Stackable shapes
You can create a stackable shape from any Visio shape or piece of clip art. Stackable shapes can stack 
horizontally or vertically. You can fix the number of shapes in a stack or make the number change as the 
stack is stretched. Shapes in a stack can have spaces between them and their alignment can vary.

When you increase the size of a stackable shape, the shape duplicates itself.

To create a stackable shape:

1. Drop the shape you want to stack onto the drawing page. Make sure the shape is selected.

2. Choose Tools > Macro > Business Diagram > Chart Shape Wizard.

3. On the first wizard screen, click Next. On the second screen, choose Stackable Shapes, then click 
Next.

4. On the third screen, choose the options you want. Click More Info if you need help with an option.

NOTE    The higher the value you enter for Number Of Shapes, the more disk space the drawing will 
occupy. For each shape in the stackable shape, Visio adds a new Geometry section to the 
ShapeSheet spreadsheet. 

5. On the last wizard screen, click Finish.

TIP    You can modify a stackable shape after you've created it. Right-click the shape, then choose 
Configure to change the height, the width, the offset between the shapes, or the stack's background color.
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Extendable shapes
The extendable shapes that you create can be two- or three-part shapes. Each part can be a shape from 
a Visio stencil, a shape you draw, or a piece of clip art. Where you place the parts determines which part 
extends. In a two-part shape, the left (for horizontal shapes) or bottom (for vertical shapes) part extends. 
In a three-part shape, the middle part extends. Simple shapes make the best extendable parts. Complex 
shapes may distort when they extend. Extendable shapes can be solid or they can include gaps between 
the parts.

When you increase the size of an extendable shape, only one part of the shape extends.

To create an extendable shape:

1. Assemble the parts of the extendable shape you want to create. Place the extendable part on the left, 
for a two-part shape, or in the middle, for a three-part shape. Click the drawing page to make sure no 
shapes are selected.

2. Choose Tools > Macro > Business Diagram > Chart Shape Wizard.

3. On the first wizard screen, click Next. On the second screen, select Extendable Shapes, then click 
Next.

4. On the third screen, choose the options you want, then click Next.

5. Follow the instructions in the Select Shapes dialog boxes.

6. On the last wizard screen, click Finish.

TIP    You can modify an extendable shape after you've created it. Right-click the shape, then choose 
Configure to change the height, width, or spacing between the parts.

To create an extendable shape from parts of a single shape:

1. Drop the single shape you want to use onto the drawing page.

2. Select the shape, then choose Edit > Copy.

3. Choose Edit > Paste Special.

4. Choose Windows Metafile Data, then click OK.

5. Repeat steps 3 and 4 to make more Windows Metafile copies of the original shape. Make two copies if 
you're creating a two-part extendable shape. Make three copies if you're creating a three-part 
extendable shape.

6. Choose the crop tool from the Tools toolbar and crop each Windows Metafile copy until it looks like the 
part of the extendable shape you want it to represent.

7. Choose Tools > Macro > Business Diagram > Chart Shape Wizard. Follow the steps described above 
for creating an extendable shape.
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Creating master shapes
    How To
    Related Topics

If you want to create a new shape and reuse it in many drawings, create the shape as a master. To create
a master, you can 

· Convert a shape to a master by moving it onto an existing Visio stencil or onto a new stencil you 
create.

· Develop a new master from scratch.

· Revise an existing master. 

Before you can create a master, you must open a stencil as an original file, with read/write access. 
Normally, stencils open with read-only access. To work with a read-write stencil while maintaining the 
original, open a copy of the original.

The masters supplied by Visio Corporation are copyrighted. You may copy and reorganize them for your 
own use, modify them for your own use, and distribute drawings that contain them. You may not sell or 
distribute original or modified Visio masters (or "SmartShapes symbols").



To open an original stencil:

NOTE    You cannot open an original stencil if a read-only copy of the stencil is open already. If a read-
only copy of a stencil is open, close it, then open the original.

1. Choose File > Stencils > Open Stencil.

You can also click the open stencil button ( ) on the Standard toolbar.

2. Open the folder that contains the stencil you want.

3. Select the stencil to which you want to add the new shape.

4. Click Original in the Open section, then click Open.

The stencil window opens, undocked, with read/write access.

TIP    To open a copy of the original stencil, click Copy instead of Original in step 4.
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Converting shapes to masters
You can use shapes you draw or revise, or objects from other applications, as masters. You may not be 
able to edit an object, however, in all the ways you can edit a Visio shape.

When you drag a shape to a stencil, a master shape icon based on the shape and a default name for the 
master appear in the stencil window. You can then name the master, align its name, choose options for 
the icon size, and write a prompt that provides information about how to use the master.

To convert a shape to a master:

1. In the drawing window, display the shape you want to convert to a master, or draw a shape to convert.

2. Open the stencil file in which you want to store the new master.

Make sure to open the original stencil or a copy.

3. Click the drawing page to make it active, then drag the shape from the drawing page and drop it on the
stencil. You can create a copy of the shape by holding down the Ctrl key while you drag.

The shape icon appears, with a label "Master.X," where X is a number representing the number of 
shapes on the stencil.

4. Choose View > Arrange Icons.

Visio rearranges the existing icons to align the new icon.

5. Choose File > Save to save the changes to the stencil.
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Developing masters from scratch
When you develop a master from scratch, you can change or specify the way the master displays in the 
stencil. For example, you can rename the master's icon and choose options for how the name aligns.

TIP    You can also change the way any master on an original stencil displays by right-clicking the master 
and choosing Properties.

To develop a new master from scratch:

1. Open the stencil file to which you want to add a master or open a blank stencil.

Make sure to open the original stencil or a copy.

2. With the stencil selected, choose Master > New Master.

3. Specify characteristics for the master:

In the Master Name section, specify the name of the new master and how to align the name.

In the Icon section, choose an option for the size and how to update the master shape icon.

In the Prompt section, type information about the master that appears when you point to it.

For Match Master By Name On Drop, check to preserve the formatting you've applied to the stencil's 
masters. 

4. Click OK.

A blank master shape icon appears in the stencil window. (You may need to scroll to see it.)

5. Choose Master > Edit Master, or double-click the master to open the master drawing window. 

6. Create the master.

You can create it just as you would in a regular drawing page by using shapes from different stencils, 
drawing the shape with the drawing tools, or pasting an object from another application.

7. Click to close the master drawing window. When Visio prompts you to update the master, click Yes.

8. While the stencil is still active (that is, the stencil title bar is blue), choose File > Save to save the 
changes to the local stencil.
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Revising existing masters
    How To
    Related Topics

You can revise the way an existing master will look when you drop it on the drawing page by dragging, 
adding, or deleting vertices, or by editing the master's text. For example, you can add arms to an office 
chair master or change its model number. 

To revise every instance of a master in a drawing, edit the master stored in the local stencil. When you 
edit the master locally, you change each instance of the shape in the drawing file. You do not, however, 
change the master in any standalone stencil you may have used to create the drawing.

You can also revise a master on a standalone stencil so that every time you use that stencil to create a 
drawing, the revised master appears on the local stencil. 

If you no longer need a master, you can delete it. Deleting a master breaks the connection between the 
master and any instances in a drawing.



To revise the way a master will look on the drawing page:

1. To revise a master on the local stencil, make sure the drawing window is active by clicking the title bar, 
then choose Window menu > Show Master Shapes to display the local stencil.

To revise a master on a standalone stencil, open the stencil as an original or as a copy that contains 
the master you want to change, then click in the stencil window to make it active.

2. Double-click the icon of the master you want to edit, or select it, then choose Master > Edit Master.

The master opens in the master drawing window.

3. To modify the master, use the same tools and techniques that you use to create and edit shapes in a 
drawing.

4. When you've finished revising the master, click the close box to close the master drawing window.
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To delete a master:

1. Open the stencil file that contains the master you want to delete.

Make sure to open the stencil as an original or a copy.

2. Select the stencil window, then select the master.

3. Choose Edit > Clear.

When Visio prompts you, click OK to delete the master or Cancel to cancel the deletion. 

4. Choose File > Save.
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Saving shapes you create on stencils
    Related Topics

It's worthwhile to create a new stencil if

· You've created shapes of your own that you plan to reuse or share with others.

· You frequently use shapes from several different Visio stencils, and you want to consolidate them on 
one stencil.

Creating a custom stencil involves either adding or deleting shapes from an existing Visio stencil, or 
building an entirely new stencil using shapes that you create from scratch and save in the stencil file.

There are two types of stencils:

· A standalone stencil is a stencil file with the extension .vss that can be opened separately or with a 
template. If you save a stencil with a template, the stencil opens with the template, along with a 
drawing page that has the scale, styles, and other features appropriate for the shapes on the stencil.

When you add or edit masters in a standalone stencil, the new or revised masters become available for
any new drawing you create using that stencil or a template that opens the stencil. Instances of the 
masters in existing drawings are not affected.

· A local stencil is a stencil stored in a drawing file. It contains copies of the masters used in that drawing
file.

When you add or edit masters in a local stencil, the changes affect only that drawing file. The masters 
are linked to their instances in the drawing, so changes you make to masters in a local stencil are 
reflected in each instance of the shape in the drawing.

Methods for creating new stencils
To Do this

Base a new 
stencil on an 
existing stencil

Choose File > Stencils > Open 
Stencil. In the Open Stencil 
dialog box, open the folder that 
contains the stencil on which you
want to base the new stencil. 
Select the stencil and, in the 
Open section, click Copy. Click 
the Open button.

Create a new 
stencil from 
scratch

Choose File > Stencils > Blank 
Stencil.

Create a new 
stencil from a 
drawing file's 
local stencil

With the local stencil window 
selected, choose File > Save As, 
type the file name you want, 
choose Stencil (*.vss) for Save 
As Type, then click Save.

Copy a master 
from one stencil 
to another

Open both stencils, then drag the
master from one stencil to 
another.

Move or copy a 
shape from the 
drawing page to
a stencil

To move the shape, drag it from 
the drawing page to the stencil. 
To copy the shape, hold down 
the Ctrl key as you drag the 



shape.

Change the 
order of the 
stencil's icons

Open the original stencil file, then
drag each master shape icon to 
arrange them in the order you 
want.

Align the icons 
in rows on the 
stencil

Open the original stencil file, then
choose View > Arrange Icons to 
align the icons vertically and 
horizontally.

Set the stencil 
so that its icons 
stay in rows 
even when the 
window is 
resized or when 
icons are added
or deleted

Open the original stencil or a 
copy, then right-click the stencil 
and choose Auto Arrange from 
the shortcut menu.

Save a new 
stencil as a local
stencil

Save the drawing that includes 
the local stencil. The stencil is 
stored in the drawing. Choose 
File > Save As, choose Drawing 
(*.vsd) for Save As Type, name 
the file, then click Save.

Save a new 
stencil as a 
standalone 
stencil

Click the stencil title bar to make 
it active. Choose File > Save As. 
For Save As Type, choose 
Stencil (*.vss), name the file, 
then click Save.





About using hyperlinks
    Related Topics

You can add a hyperlink, or jump, to each Visio shape and drawing page. The link can jump to

· Another page in the same Visio drawing.

· Another Visio drawing.

· A non-Visio document.

· A World Wide Web location (URL).

For example, from a process shape in a flowchart, you can jump to a drawing page that shows the 
detailed steps the process involves.

After you add a link, right-click the shape or drawing page and choose Hyperlink > Open to jump to the 
destination. In full-screen view, you can click the shape or page to open the hyperlink. (Keep in mind that, 
for the URL links to work, you must have a Web browser installed on your computer.) 

If you intend to save a drawing as HTML pages using the Save As HTML add-on, you can preserve your 
hyperlinks as image maps. 

In a Web browser, the linked shapes will be "hot." (Links to other Visio drawing pages remain active in the
HTML file only if you save the page that the shape is linked to, as well as the page the linked shape is on,
in HTML format.)

You can also paste objects created in other applications into Visio drawings as hyperlinks and paste Visio 
shapes and drawings into other documents as hyperlinks.



Adding, modifying, and deleting hyperlinks
    How To
    Related Topics

When you add a navigational link, or "jump," to a shape or drawing page, you can navigate to the link by 
right-clicking the shape or page, then choosing Hyperlink > Open. Once you've added a link to a shape or
page, you can modify or delete the link.

Relative versus absolute paths to hyperlinks
When you link a shape or page, you can decide whether the path to the link should be relative or 
absolute. A relative path describes the location of the linked file in relation to the Visio drawing or a 
hyperlink base. You can move the Visio drawing and the linked file together (that is, move the entire path 
structure) without breaking the link. An absolute path spells out the exact location of the linked file in 
terms of drives, directories, and folders. You can move the Visio drawing file without affecting the link but 
if you move the linked file, you must reset the path. To specify an absolute path, uncheck Use Relative 
Path For Hyperlink.

If you want to use a relative path that is not based on the location of the Visio drawing, you can set a base
path in the Properties dialog box for the file. Choose File > Properties, then type the base path that you 
want in the Hyperlink Base box. This base path is then displayed in the Insert Hyperlink dialog box.



To link a shape or page to another Visio drawing page, a Web URL, or a non-Visio file:

1. In Visio, create or open a Visio drawing. To add a link to a page, display the page with nothing 
selected. To add a link to a shape, select the shape.

2. Choose Insert > Hyperlink.

3. Under Link To File Or URL, click Browse to locate the local file or Internet address (URL) you want to 
link to. The path to the linked file is displayed under Path. 

If you want to link to a shape or page in the current drawing, skip to step 4.

4. Optionally, if you're jumping to a Visio file or URL, under Named Location In File, type the page name 
within the file or anchor on the Web page you want to link to. If you're jumping to the current open file 
or another Visio file that is open, you can click Browse to see a list of the pages in that file.

5. Under Descriptive Name Of Link, type a name for the link that identifies the location you're linking to. 

6. Choose whether you want a relative path for the hyperlink, then click OK.

NOTE    If you've set a base path for the hyperlink in the Properties dialog box for the file, that path will 
appear as the Base in the Hyperlink dialog box.
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To paste a Visio shape or drawing into another document as a hyperlink:

1. Right-click the hyperlinked shape, then choose Hyperlink > Copy Hyperlink.

2. In the destination document, choose Edit > Paste As Hyperlink.

NOTE    Some applications, such as Microsoft Office 95 applications, do not support the Paste As 
Hyperlink command.

    Overview



To paste an object into Visio as a hyperlink:

1. After you've copied the hyperlinked object, go to the drawing page on which you want to paste it.

2. Choose Edit > Paste As Hyperlink.

    Overview



To modify a hyperlink:

1. To modify a link on a page, display the page, with nothing selected. To modify a link on a shape, select 
the shape.

2. Right-click the page or shape, then choose Hyperlink > Edit Hyperlink.

3. Make the changes you need, then click OK.

    Overview



To remove a hyperlink from a shape or page:

1. In Visio, create or open a Visio drawing. To remove a link from a page, display the page with nothing 
selected. To remove a link from a shape, select the shape.

2. Choose Insert > Hyperlink.

3. Click Remove Link, then click OK.

    Overview



Jumping between hyperlinked shapes and pages
    How To
    Related Topics

You always jump from a linked shape or drawing page by right-clicking the shape or page, then choosing 
Hyperlink > Open. How you get back to the original location in Visio depends upon the destination of the 
jump.

NOTE    You can only use the forward and back tools to navigate between a Visio drawing and other 
ActiveX documents, such as other Visio drawings, Office 97 documents, and HTML pages loaded into 
Internet Explorer 3.01 and later.



To activate a hyperlink on a shape or page:

· Right-click the shape or page and choose Hyperlink > Open. If you want to be able to see both the 
drawing page and the link destination, choose Hyperlink > Open In New Window. If you are in full 
screen view, click the shape or page.
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To go to the next hyperlink:

· Click the forward tool ( ) on the Web toolbar or press Alt+right arrow.

To return from another Visio page in a drawing or another document, application, or Web site:

· Click the back tool ( ) on the Web toolbar or press Alt+left arrow.

NOTE    You can only go to and return from Visio drawings and Office 97 documents. To navigate to and 
from other document types, such as text (*.txt) files, you must host the files in Internet Explorer 3.01 or 
later.

    Overview





About customizing shape behavior
    Related Topics

If you've used Visio shapes, you already know they're smart¾that is, programmed to act the way you 
need them to in particular contexts. For example, the desks in the Office Planning Template are built to 
standard industry sizes and locked against resizing so you can't accidentally stretch them inappropriately.

But what if you want to program a shape to behave the way you decide it should behave? You can take 
advantage of another aspect of Visio shapes' smart behavior: you can change it. For example, you can 
define the actions that affect the way a shape displays onscreen, how a shape responds when you 
double-click it, or how its text behaves. You can also run the SmartShape Wizard to customize a shape's 
text, add built-in connectors to a shape, or protect shape attributes so they can't be changed.

Visio provides several methods that you can use to customize shape behavior:

· Use the Behavior or Double-Click commands on the Format menu.

· Run the SmartShape Wizard.

· Modify formulas in a shape's ShapeSheet spreadsheet.

· Add a command to a shape's or drawing page's shortcut menu.

· Associate an event with a shape.

· Write a program that controls Visio or its shapes through Automation.

ShapeSheet spreadsheets are representations of shapes. As you make changes to a shape on the 
drawing page, Visio updates mathematical formulas in the ShapeSheet spreadsheet. The ShapeSheet 
spreadsheet stores the shape's attributes, such as the width and height, the angle and center of rotation, 
and the formatting attributes that determine the shape's appearance. The ShapeSheet spreadsheet also 
contains information such as the x- and y-coordinates of each vertex relative to the shape's origin.

By associating an event with a shape, you can define how the shape responds to a particular action. An 
"event" is an occurrence, such as the mouse being double-clicked or the shape being dropped on the 
page, that the shape can detect and respond to. You can quickly associate any of a number of actions 
with a double-click event, so that when you double-click a shape, it performs that action. For example, 
you can define a double-click event that causes a shape to start an add-on, display its ShapeSheet 
spreadsheet, or jump to another page in the drawing file.

If you want to use a shape you've customized in many drawings, you can convert the shape to a master 
and save it on a stencil.

For details about customizing shape behavior using the ShapeSheet window, actions, events, or 
Automation, see Visio and Automation. 



Controlling how shapes display onscreen
    How To
    Related Topics

You can control whether or not a shape's selection handles, control handles, and selection rectangle 
display on the screen. (The handles and rectangle never appear in a printed drawing.)



To change a shape's display options:

1. Select the shape, then choose Format > Behavior.

2. Under Selection Highlighting, uncheck the items that you do not want to appear on the selected shape,
then click OK.

NOTE    If you uncheck all of the Selection-Highlighting options, you won't be able to tell when the 
shape is selected.
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Setting double-click behavior
    How To
    Related Topics

You can specify what happens when you double-click a shape. By default, double-clicking a shape opens 
the shape's text block so you can edit it. However, you can change double-click behavior to display a 
different page in the same drawing, for example, or to open the shape's ShapeSheet spreadsheet.



To specify a shape's double-click behavior:

1. Select the shape for which you want to change double-click behavior, then choose Format > Double-
Click.

2. Choose a double-click action for the shape, then click OK.

    Overview



Changing shapes from 1-D to 2-D or from 2-D to 1-D
    How To
    Related Topics

You can convert a two dimensional (2-D) shape to a one dimensional (1-D) shape so you can use it as a 
connector to glue to 2-D shapes. Or you can change a 1-D shape to a 2-D shape so you can glue 1-D 
connectors to it or size it proportionately when you drag its corner selection handles.

Changing a shape between 1-D and 2-D changes the underlying structure of the shape and may produce 
unexpected results. For example, if a 1-D shape is glued to another shape, changing the 1-D shape to a 
2-D shape breaks the glue. If you're not sure of the results of changing a shape's behavior, it's best to 
make a copy of the shape first, then change the behavior of the copy.



To change 1-D or 2-D shape behavior:

1. Select the shape you want to change from 1-D to 2-D or from 2-D to 1-D.

2. Choose Format > Behavior.

3. Under Interaction Style, select Line (1-Dimensional) or Box (2-Dimensional), then click OK.
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Adding built-in connectors to shapes
    How To
    Related Topics

If you always connect a certain shape to other shapes, you can use the SmartShape Wizard to add a 
built-in connector without having to learn complex formulas. Then, when you want to connect the shape to
another, you can drag the connector directly from the shape. For example, in a data flow diagram, if you 
always glue a Data Process shape to another shape, you can add a connector to the Data Process shape
so you don't need to drag a separate connector each time you add a new Data Process shape.



To use the SmartShape Wizard to add a built-in connector to a shape: 

1. Select the shape to which you want to add a connector, then choose Tools > Macro > Visio Extras > 
SmartShape Wizard.

2. On the main wizard screen, under SmartShape Options, check Create Built-In Connectors, then click 
Change Option.

3. On the Built-In Connectors screen, select the type of connector you want to create, then click Next.

You can select each option to see a graphic representation of the type of connector the selected option
creates.

4. If you selected an option other than Radial, the next screen prompts you to choose where to put the 
bends in the connectors and how much space to allow before bending the line. Choose whether to 
have the bend appear closer to the shape or closer to the control handle that represents the 
connector's end point. Then specify how much space you want to allow, then click Next.

5. On the main wizard screen, click Finish.

6. On the next screen, select whether to apply the connector to a copy of the shape (recommended) or 
the original shape, then click Create SmartShape.

NOTE    Do not use the SmartShape Wizard to add a connector to a shape that already has built-in 
connectors, such as the Ethernet shape. Adding a connector this way invalidates the formulas for the 
existing connectors, making them unusable.
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Adding hidden notes to shapes
    How To
    Related Topics

Generally, you add text to a shape by selecting the shape and then typing the text you want. This creates 
text that is visible in the drawing. But, for some drawings, you might want to add text to a shape that gives
more information, but doesn't appear in the drawing unless you need it. For example, on a shape in a 
large organization chart, you can type a note that describes how to get to that person's workspace, and 
hide the note when you want to print the chart. You can also choose to display the data in a shape's 
custom-property fields. For example, on a shape in a network diagram, you can add a note that displays 
the manufacturer, serial number, and so on, of a piece of equipment, and hide it when you want to view 
only the network layout. 

With the SmartShape Wizard, you can quickly add a hidden note to a shape. After you add the note, you 
can show or hide it by right-clicking the shape.



To use the SmartShape Wizard to add a hidden note to a shape:

1. Select the shape to which you want to add the note, then choose Tools > Macro > Visio Extras > 
SmartShape Wizard.

2. In the main wizard screen, under SmartShape Options, check Create A Hidden Note, then click 
Change Option.

3. In the Hidden Note screen, type the text for your note. 

If the shape has custom properties, you can also select the custom-property fields you want to include 
in the note.

For helpful tips about typing certain text characters, such as a line break, click Show Hints.

4. When you've completed typing the note or selecting custom property fields, click Next. In the main 
wizard screen, click Finish.

5. In the final screen, select whether to add the note to a copy of the shape (recommended) or to the 
original shape, then click Create SmartShape.

NOTE    For more information while performing any of the steps above, click Show Hints in the wizard 
screen.
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Adding commands to shapes' and drawing pages' shortcut menus
    How To
    Related Topics

All Visio shapes and drawing pages have shortcut menus from which you can choose commands that 
change the way the shape looks or behaves. For example, if you frequently work with layers, you can 
right-click a shape to open the Layer Properties dialog box.

You can add an item to a shortcut menu by using the Actions section and command in the ShapeSheet 
window. For example, if you switch back and forth between pages in a Visio drawing, you can add a Go 
To Page command to each page's right-click menu.



To add a right-click command to a shape's or drawing-page's shortcut menu:

1. Select the shape or drawing page to which you want to add a right-click command, then choose 
Window > Show ShapeSheet.

The menu bar changes to show menus associated with the ShapeSheet window.

2. Choose Insert > Section, check Actions, then click OK. 

3. In the ShapeSheet window, scroll to the Actions section, select one of its cells, then choose Edit > 
Action and do the following:

Under Menu, type the command you want to appear on the shape's or page's right-click menu.

Under Prompt, type the instructions you want to appear on the status bar when you hold the mouse 
over the command.

Under Action, select the action you want to perform when you right-click the shape or page. For details,
click Help on the dialog box.

4. When you've completed the changes in the Action dialog box, click OK.

5. Close the ShapeSheet window.

When you right-click the shape or page, the command you just added appears at the top of the menu.

NOTE    You can add your own commands on a shape's shortcut menu.
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Controlling how shapes respond to events
    How To
    Related Topics

You can easily define a double-click event for a shape by choosing Double-Click from the Format menu. 
In the Double-Click dialog box, you can choose from among several events, but there may be other 
events not included there which you want to add. For example, you can choose to open a separate file 
when you double-click the shape.

You can also define other events, such as one that triggers an action when you drop a shape on the 
drawing page. For example, you can run a macro when you drop a certain shape.

To define how a shape responds when you drop it on the page, you type a function into the EventDrop 
cell of the Events section of a shape's ShapeSheet spreadsheet. 



To program an action in the EventDrop cell:

1. Select the shape, then choose Window > Show ShapeSheet to open its ShapeSheet window.

2. Choose View > Sections, click Events, then click OK.

3. In the Events section, select the EventDrop cell, then place the insertion point in the formula bar.

4. Choose Insert > Function, then select the function you want to insert, and click OK.

The function appears in the formula bar.

5. If the function you insert requires arguments, add them in the appropriate section in the formula bar, 
then press Enter.

The function appears in the cell.

6. Close the ShapeSheet window and test the shape. To trigger the event, you can drag and drop the 
shape from the stencil, copy and paste it, or duplicate it by pressing Ctrl+D or by Ctrl+dragging it.
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Useful functions to associate with events
· OPENFILE("filename")

Opens a Visio file in a new window. 

· GOTOPAGE("pagename")
Displays the page in the currently active window. For example:
GOTOPAGE("Page-2")
A page's name appears in the title bar of its window in the Page Setup dialog box (Page Properties 
tab). You can also use GOTOPAGE with a URL to display a Web site.

· HYPERLINK("address")
Navigates to a URL address.

· OPENPAGE("pagename")
Displays the page in a new window.

· RUNADDON("name")
Runs the specified macro or add-on (including those that are wizards). To pass arguments to a macro, 
include them in the string. To pass arguments to a standalone add-on, use the RUNADDONWARGS 
function.

For additional events and functions you can use in the Events section and advice on how to use events 
effectively, see the Automation Reference.
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Controlling shapes through Automation
    Related Topics

With Automation, you can write macros and programs that control Visio or extend its capabilities. A macro 
or program uses Automation to automate repetitive tasks, whether simple or complex, or to incorporate 
Visio drawing and diagramming capabilities into larger solutions. For example, you can create a program 
that generates an organization chart from a list of names and positions in a database.

To write macros, you can use Microsoft Visual Basic for Applications (VBA). VBA comes with Visio; you 
write and edit programs in the Visual Basic Editor. A macro is stored only in the drawing you are working 
with when you create the macro, rather than as a separate program. You can write standalone programs 
in Visual Basic, Visual C/C++, or any other programming language that supports Automation. 

A program controls Visio by accessing its objects and then using their properties, methods, and events. 
Here is a brief overview:

· Objects represent items you work with in Visio, such as documents, drawing pages, shapes, and 
formulas.

· Properties are attributes that determine the appearance or behavior of objects. For example, a Shape 
object has a Name property, which represents the name of that shape.

· Methods are actions that can be performed with an object. For instance, a program can use the Copy 
method of a Window object to copy a selected shape to the Clipboard. This method is equivalent to 
selecting a shape on the drawing page and using the Copy command on the Edit menu in Visio.

· Events are occurrences or notifications that can trigger responses. For example, you can 
programmatically trigger code when a document is opened or you can trigger a program by double-
clicking a shape.

For details about Visio objects, properties, methods, and events, see the Automation Reference.





About customizing text behavior
    Related Topics

With the SmartShape Wizard, you can quickly add smart formulas to ShapeSheet cells that change the 
default text behavior for a shape. For example, you can

· Change the text position in relation to the shape and add a text-block control handle that you can drag 
to reposition the text.

· Determine whether or not a shape's font size changes along with the shape size.

· Set the way you want text to behave when the shape is rotated.

The SmartShape Wizard can also guide you through changing other aspects of a shape, such as creating
built-in connectors or a hidden note.

NOTE    To make more significant and detailed changes to a shape's behavior, such as adding a shortcut 
menu to a shape, use the ShapeSheet spreadsheet instead of the SmartShape Wizard. 



Adding control handles that move text
    How To
    Related Topics

With the SmartShape Wizard, you can reposition a text block with respect to its shape, and you can add a
control handle that you or others can use later to move the text block independently of the shape. 

When you use the wizard to reposition the text block, you choose from a limited number of new positions, 
such as directly above or below the shape. When you use the control handle to drag the text block to a 
new position, you can choose any position you want.

NOTE    You can also use the text block tool ( ) to move a text block independently of its shape. 

You can choose a new placement for the text that enhances the usefulness of the shape. 



To reposition text and add a text-block control handle:

1. Choose Tools > Macro > Visio Extras > SmartShape Wizard.

2. In the main wizard screen, check Customize Shape's Text, then click Change Option.

3. In the SmartShape Wizard Text Position screen, click the position you want for the text block, and 
select Add Control Handle To Shape.

4. Click Next until the main wizard screen appears, then click Finish.
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Setting text-rotation behavior
    How To
    Related Topics

With the SmartShape Wizard, you can determine how a text block behaves when you rotate it. For 
example, when rotated, the text can

· Rotate with the shape.

· Stay level and upright regardless of how its shape is rotated.

· Rotate with the shape, but flip in certain circumstances to ensure the text is never upside down.

Using the SmartShape Wizard, you have a number of options for the rotation behavior of text. For example, you set 
the text to rotate with the shape, but never be upside down. 



To determine how text is rotated when the shape is rotated:

1. Choose Tools > Macro > Visio Extras > SmartShape Wizard.

2. In the main wizard screen, check Customize Shape's Text, then click Change Option.

3. In the Text Position screen, click next, then select the rotation behavior option you want.

4. Click Next until the main wizard screen appears, then click Finish.
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Setting text to resize with shapes
    How To
    Related Topics

With the SmartShape Wizard, you can determine whether the font size of text changes or stays the same 
when you change the size of its shape. 

Certain shapes, such as those that model objects in the real world, should contain text that automatically resizes 
when the shape is resized.



To set a shape's text to change when the shape is sized:

1. Choose Tools > Macro > Visio Extras > SmartShape Wizard.

2. In the main wizard screen, check Customize Shape's Text, click Change Option, then click Next until 
the SmartShape Wizard - Text Size screen appears.

3. Select the text sizing option you want.

4. Click Next until the main wizard screen appears, then click Finish.
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Visio wizards and other tools
    Related Topics

Wizards and other automated tools in Visio create special drawing types from scratch, automate routine 
tasks, and perform unique functions.

When you open certain templates, such as the Project Timeline Wizard Template, a wizard that you can 
use to create the drawing starts automatically. When you open other templates, Visio adds a command 
you can choose to start a wizard to the top of the Tools menu. For example, when you open the 
Organization Chart Template, Visio adds a command so that you can choose Tools > Organization Chart 
Wizard.

Regardless of the template you start with, you can run any wizard or automated tool by choosing Tools > 
Macro > Macros, or in some cases by choosing it from the Tools menu.

TIP    You can display background information about certain wizard screens by clicking the More Info 
button onscreen. 

Visio wizards
Wizard What it does How you 

run it

Build Region Assembles selected 
geographic shapes 
into a region.

Tools > 
Macro > 
Maps > 
Build 
Region

Chart Shape
Wizard

Creates stackable 
and extendable 
shapes you can use 
to add special effects 
to charts.

Tools > 
Macro > 
Business 
Diagram > 
Chart 
Shape 
Wizard

Custom 
Properties 
Editor

Edits, adds, or 
deletes custom 
property fields from 
master shapes.

Tools > 
Macro > 
Custom 
Properties 
Editor

Database 
Export

Generates a 
database table that 
reflects the data in 
custom property and 
other ShapeSheet 
cells.

Tools > 
Macro > 
Database >
Database 
Export

Database 
Wizard

Links Visio shapes 
and drawings to 
databases created in 
ODBC-compliant 
database programs. 
After establishing    
links, you can pass 
information between 
a drawing and 

Tools > 
Macro > 
Database >
Database 
Wizard



database, create 
drawings that 
represent database 
tables, and generate 
new master shapes 
that represent data 
stored in database 
records.

Export [data] Exports an inventory 
report based on 
shape properties. The
Export [data] 
command is available
in the network 
diagram, office layout,
and organization 
chart templates.

Tools > 
Export 
[data]

Flowchart-
TQM 
Diagram 
Wizard

Guides you through 
the process of laying 
out and formatting a 
Cause/Effect, Force 
Field, Top Down, or 
Cross Functional 
(Rummler-Brache) 
diagram.

Tools > 
Macro > 
Flowchart >
Flowchart-
TQM 
Diagram 
Wizard

Office 
Layout 
Wizard

Guides you through 
the process of setting 
the drawing scale, 
choosing the page 
size and orientation, 
and creating the basic
wall structure for an 
office layout diagram.

Tools > 
Macro > 
Business 
Diagram > 
Office 
Layout 
Wizard

Organization
Chart Wizard

Generates an 
organization chart 
from a data file in 
Microsoft Excel (.xls), 
Org Plus (.txt), or 
comma or tab-
delimited text (.txt) 
format, or from a 
database table 
created in an ODBC-
compliant program. 
Or, generates a basic 
organization chart 
structure into which 
you can add data.

Tools > 
Macro > 
Business 
Diagram > 
Organizatio
n Chart 
Wizard

Page Layout
Wizard

Automates setting up 
the drawing-page 
size, orientation, and 
scale. Assists you in 

Tools > 
Macro > 
Visio 
Extras > 



adding a title block 
and border to the 
pages in a new or 
existing drawing.

Page 
Layout 
Wizard

Print 
ShapeSheet

Opens the Print 
ShapeSheet dialog 
box, where you can 
choose which 
sections of the 
ShapeSheet to print 
and whether to print 
the ShapeSheet to a 
printer, the Clipboard,
or a file.

Tools > 
Macro > 
Visio 
Extras > 
Print 
ShapeShee
t

Project 
Timeline 
Wizard

Generates a project 
timeline from a data 
file in Microsoft Excel 
(.xls), comma- or tab-
delimited text, or 
Microsoft Project 
Exchange (.mpx) 
format. Or, generates 
a project timeline 
structure into which 
you can enter data.

Tools > 
Macro > 
Business 
Diagram > 
Project 
Timeline 
Wizard

Property 
Reporting 
Wizard

Generates inventory 
reports, such as bills 
of materials or 
equipment and 
furniture inventories; 
and numeric reports, 
such as cost totals or 
averages, from data 
stored in shapes.

Tools > 
Property 
Report

Shape 
Explorer

Locates specific 
shapes and stencils 
in Visio products. You
can open stencils and
templates from within 
Shape Explorer.

Tools > 
Macro > 
Shape 
Explorer

SmartShape 
Wizard

Customizes the 
appearance or 
behavior of a selected
shape's text, 
connectors, notes, or 
protection.

Tools > 
Macro > 
Visio 
Extras > 
SmartShap
e Wizard

Stencil 
Report 
Wizard

Generates a Visio 
drawing of the 
masters on a selected
stencil. 

Tools > 
Macro > 
Visio 
Extras > 
Stencil 
Report 



Wizard





Saving drawings with hyperlinks as server-side image maps
    How To
    Related Topics

By default, when you save drawings with navigational links as HTML pages, Visio converts the drawing 
into a client-side image map. In server-side image maps, a program on the Web server examines map 
data associated with the linked regions and processes the links. If you know that your server is set up to 
support server-side image maps, you can save your drawings that include navigational links in this way.

When you save Visio drawings as HTML files, Visio saves the .htm, graphics and map (.map) files in the 
folder that you specify in the Save As HTML dialog box. You must move the .map files from this local 
folder to the CGI (Common Gateway Interface) directory on the Web server for links on the server-side 
image maps to work. 



To save a drawing as a server-side image map:

1. In Visio, create or open the drawing you want to export.

2. Choose File menu > Save As.

3. In the Save As dialog box, type a name using the .htm extension (for example, Drawing.htm).

4. For Save As Type, choose HTML files (*.htm, *.html), then click Save.

5. In the Save As HTML dialog box, choose the location where you want to save the file, the graphics 
format, and the drawing pages you want the HTML file to include, then click Options.

6. In the Export Options dialog box, choose Server Side, type the URL to the CGI directory on the Web 
server, choose the format you want, then click OK twice.

7. Visio prompts you to view the HTML pages. Click Yes to open your Web browser and view the first 
HTML page.

NOTE    Hyperlinks in the image map won't be active until you move the .map files from your local folder 
to the CGI folder on the Web server.

    Overview



Customizing HTML pages
    How To
    Related Topics

In the process of saving a drawing as HTML pages, Visio creates several files and saves them in the 
location you specify. The files include:

· An HTML file for each exported page (Page1.htm, Page2.htm, and so on).

· A graphics file for the Visio drawing on each page (Page1.jpg or Page2.gif).

· Graphics files for the Next and Back buttons Visio adds to each HTML page (Back.gif and Next.gif).

· Image map files, if you save your drawing as a server-side image map (Page1.map, and so on).

You can customize the HTML files by opening them in Notepad or any other HTML editor. If you modify or 
move the .htm files, remember to update pointers to the graphics files.



Substitution codes for customizing the Save As HTML template
The following table describes the substitution codes you can include in the template and the information 
the codes are replaced by when you save a Visio drawing in HTML format. Some of the information 
comes from the Visio Properties dialog box. The first time you save a file, Visio opens the Properties 
dialog box and you can type information, such as keywords or a description, that help you identify and 
locate the file in the future. You can access the dialog box at any time by choosing File > Properties.

Substitution Codes
Code Replaced by

<!--CREATOR-- 
> 

Creator in the Visio File 
Properties dialog box.

<!--
DESCRIPTION-
- > 

The description listed in the Visio
Properties dialog box.

<!--
FULL_NAME-- 
> 

Full Visio drawing file name, 
including drive and path.

<!--
KEYWORDS-- >

Keywords in the Visio File 
Properties dialog box.

<!--SUBJECT-- 
> 

The subject listed in the Visio 
File Properties dialog box.

<!--TITLE-- > The title listed in the Visio File 
Properties dialog box.

<!--x-- > x can be Category, Company, 
Manager, or Hyperlink_Base.

<!--
PAGE_NAME-- 
> 

Name of the Visio page to be 
saved in HTML format (Page-1, 
etc.).

<!--IMAGE-- > The <IMG > Tag for the page's 
Visio graphic (for example, <IMG
SRC="Page2.GIF" > tag, where 
Page2.GIF is the Visio drawing 
on page-2 saved in .gif format).

<!--
NEXT_PAGE_B
TN-- > 

<IMG SRC="Next.GIF" > Tag for 
a Next button graphic.

<!--
BACK_PAGE_B
TN-- > 

<IMG SRC="Back.GIF" > Tag for 
a Back button graphic.

<! --
NEXT_ANCHO
R-- > 

Anchor <A > Tag to make the 
Next button a navigational link to 
the next page.

<! --
BACK_ANCHO
R-- > 

Anchor <A > Tag to make the 
Back button a navigational link to
the previous page.

<!--
NEXT_ANCHO

Ending anchor </A > Tag for the 
Next button.



R_END > 

<!--
BACK_ANCHO
R_END > 

Ending anchor </A > Tag for the 
Back button.

<!--
FILE_NAME-- > 

Visio drawing file name.

<!--
FILE_PATH-- > 

Visio drawing file path. 

<!--
PAGE_INDEX-- 
> 

Page number relative to other 
pages in the Visio drawing.

<!--
PAGE_COUNT-
- > 

Total number of pages in the 
Visio drawing.

<!--
HTML_PAGE_I
NDEX-- > 

HTML page number relative to 
other HTML pages.

<!--
HTML_PAGE_C
OUNT-- > 

Total number of HTML pages.

<!--
CS_IMAGE_MA
P-- > 

If any of the shapes in your Visio 
drawing include navigational 
links to other pages, files, or 
URLs, and you have enabled 
client-side image mapping, map 
data about links replaces this 
code on the HTML page. This 
map data tells your Web browser
which regions of the graphic 
have links, the URLs the regions 
are linked to, and more.
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Zooming in on or out from pages
    Related Topics

In Visio, the magnification at which you view and work on a drawing is independent of the scale you set 
for a drawing page. To position shapes exactly or do precise work, you may need to zoom in on a portion 
of a drawing¾especially if you're working with a scaled drawing. 

You can zoom in and out from a drawing by using the Zoom tool on the Standard toolbar, or you can use 
the shortcuts listed here:

· Zoom in: Ctrl+Shift+left-click

· Zoom out: Ctrl+Shift+right-click

· Zoom in on a selected area: Hold down Ctrl+Shift+left-mouse button and drag a rectangle around the 
area you want to zoom in on.

· Scroll: Hold down Ctrl+Shift+right-mouse button and drag the page.

TIP    You can also choose Last Zoom, Actual Size, Page Width, Whole Page, or Full Screen from the 
View menu. 



Using dimension lines to display shape size
    How To
    Related Topics

When you select a shape, its dimensions appear on the left side of the status bar, which is at the bottom 
of the Visio window, and change as you resize the shape. Sometimes, though, you want dimension 
information to appear in your drawing.

Dimension lines show the dimensions of a shape in drawing units, rather than page units. For example, this shape is 
shown in meters, while a football field might be shown in yards, or a civil engineering plan in kilometers. 

Depending on which Visio product you're using, you may have one or more dimension line masters that 
calculate and display linear and angled dimensions. You can glue one of these dimension lines to another
shape so that, when you resize the shape, dimensions are calculated automatically. 

You can also use dimension lines to ensure that several distances total a certain length. To measure a 
series of distances, form dimension lines into a chain.

Draw a chain of dimension lines with the stamp tool.

You can change how dimension values appear on dimension line shapes by choosing the unit of 
measure, fractional or decimal values, and the precision of decimal values. The unit of measure for a 
dimension line can differ from the unit set for the drawing scale.

You can use a dimension line to measure the radius of a circle by gluing the line's endpoints to the center and 
perimeter of the circle. To make the measurement easy to read, you can move, rotate, and format the line's text block.



To glue a dimension line to a shape handle:

1. Choose Tools > Snap & Glue.

2. Under Currently Active, check Glue. 

3. Under Glue To, check Shape Handles.

4. Under Snap & Glue Strength, drag the box along the Points slider bar to increase or decrease the 
strength of the glue, then click OK.

5. Drag a dimension line shape from the stencil to the drawing page and glue its endpoints to selection 
handles on the shape you want to measure. 

    Overview



To form dimension lines in a chain:

1. Open the Callouts stencil and a drawing page.

2. If you want, place guides on the page to mark off a series of distances.

3. Choose the stamp tool ( ) from the Standard toolbar.

4. On the Callouts stencil, click the Automatic Dimension shape.
5. Click the page where you want the first dimension line to start (at the first guide), then drag to 
extend the dimension line to the second guide. 
6. Press the Esc key to deselect the dimension line.
7. Position the stamp tool on the second guide and drag to the third guide. 

8. Repeat steps 6 and 7 for subsequent dimension lines until all the dimension lines in the series are on 
the page.

    Overview



To change the format of dimension line values:

1. Select the dimension line shape, then choose Insert > Field.

2. Under Format, choose the units you want displayed, then click OK.

    Overview



Calculating and displaying shape dimensions
    How To
    Related Topics

If you want specifications to appear in shapes in a drawing, you can add text fields that display a shape's 
geometry. A field is a placeholder in text that displays information such as a date, time, or measurement. A
text block can contain as many fields as you want. You can use fields from existing categories or create 
your own formulas for fields, and you can format or delete fields just as you format or delete other text.

After you've added a dimension field, when you resize or rotate a shape, Visio automatically calculates 
and displays a new height, width, angle, or rotation. For example, you can add a rotation-angle dimension
field to a shape so that, when you rotate the shape, the field displays the rotation angle in positive or 
negative numbers.

NOTE    When you cut or copy a field and then paste it, the pasted text is no longer a field. The field text 
becomes static.



To add height and width dimension fields to a shape:

1. Choose the text tool ( ) from the Standard toolbar, then select the shape to which you want to add 
dimensions and place the insertion point where you want to display the field. 

2. Choose Insert > Field, then
Under Category, choose Geometry.

Under Field, choose Width.

Under Format, choose the format in which you want the field information to appear.

3. Click OK.

4. Place the insertion point after the width number and type "x" or "by".

5. Follow steps 2 through 4 above, but choose Height instead of Width.

6. Choose the pointer tool, then resize the shape. 

The dimensions change automatically.
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To add a rotation-angle field to a shape:

1. Select the text tool ( ) from the Standard toolbar, then select the shape to which you want to add a 
rotation-angle field and place the insertion point where you want to display the field. 

2. Choose Insert > Field, then
Under Category, choose Geometry.

Under Field, choose Angle.

Under Format, choose the format in which you want the field information to appear, then click OK.

TIP    If you display the angle in degrees, you can add the degree symbol (for example, 30°) instead of 
displaying the label "deg." To display the degree symbol instead of text, in step 2 of the procedure above, 
choose General under Format, then click OK. Make sure the NumLock key is turned on, then press 
Alt+0176.

As you rotate a shape, its rotation-angle field records the angle of rotation in positive or negative numbers.

    Overview



Revising master shape icons
    How To
    Related Topics

When you create a master, Visio creates an icon that resembles it on the stencil. You can revise the 
existing icon in two ways. You can use the Master > Properties command to change the icon's size, text, 
and status bar prompt. Or you can use the icon editing window to change the shape and colors of the icon
itself.

It's important to check the properties of an icon before you begin revising it in the icon editing window. 
First, the size of the icon determines the size of the area that you can use to create the icon in the edit 
icon window. Second, the update option controls how Visio updates the master shape icon. If you are 
creating a custom icon, choose Manual as the update option so you don't accidentally replace the custom
icon when you edit the master shape.

Changing the stencil icon in the icon editing window doesn't affect how the actual shape looks. To edit and
format the master shape you need to open it in the master drawing window.

After you've ensured that the properties of a shape are set the way you want them, you can open the 
master icon in the icon editing window and change its shape and colors. The icon editing window is 
bitmap-based, meaning that instead of working with segments and vertices, you change the icon pixel by 
pixel.



To change the properties of a master icon:

1. Open the stencil that contains the master you want to change, then click in the stencil window to make 
it active.

Make sure to open the stencil as an original or a copy.

2. Select the master icon, then choose Master > Properties.

3. In the Master Name section, type or change the name for the master and choose an option to align the 
master name.

4. In the Icon section, choose an option for the icon size.

The default size is Normal. You can also choose Tall, Wide, or Double.

5. In the Icon section, choose an option to update the master icon.

Choose Automatic to have the icon automatically reflect changes you make to the master shape it 
represents. Choose Manual to update the icon with the Update Icon command.

If you plan to create a custom icon for the master shape, choose Manual, so you won't accidentally 
replace the custom icon when you edit the master shape.

6. In the Prompt section, type information that will appear on the status bar when you point to the master 
shape icon.

7. Check Match Master By Name On Drop to preserve the formatting you've applied to the stencil's 
master shapes. 

8. Click OK.

9. Choose File > Save to save the changes to the stencil.
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To edit a master icon in the icon editing window:

1. Open the stencil that contains the master you want to change, then click in the stencil window to make 
it active.

Make sure to open the stencil as an original or a copy.

2. Select the master icon, then choose Master > Edit Icon.

The icon editing window opens, and the icon appears in the window. The icon editing tools appear on 
the toolbar. 

3. Use the tools to change the colors and shape of the icon. 

4. After you've edited the icon, click the close box to close the editing window. When Visio prompts you to
save the changes to the stencil, click Yes to accept them or No to close the window without saving the 
changes.

NOTE    You cannot cancel changes you make to an icon after you close the edit icon window. However, 
you can use the Undo command to undo changes to the icon while the edit icon window is still open.
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To change the colors of a master icon:

1. In the icon editing window, choose the pencil tool to change the color one pixel at a time. Choose the 
fill color tool to change an area of color.

2. In the color palette, point to the color you want to use.

3. Click the color with the left or right mouse button.

The color appears in the Left Color box or the Right Color box on the toolbar.

4. Point to the pixel you want to change and click with the mouse button that is assigned the color you 
want.

If you're using the pencil tool, only the pixel you click on will change color. 

If you're using the fill color tool, all of the pixels contiguous to the pixel you clicked will change color.

TIP    To create icons that appear to have holes cut in them, use the stencil background color.
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To move or delete part of a master icon:

1. In the icon editing window, choose the lasso tool or selection net tool.

2. Select the area you want to move or delete.

3. To move the selection, drag it to where you want it. To delete the selection, choose Edit > Clear or 
press the Delete key.

The area from which the icon part was moved or deleted is replaced with the stencil background color.

    Overview



Quitting Visio
    How To
    Related Topics

When you finish working in Visio, quit Visio before you quit Windows. If an unsaved file is open when you 
choose to quit Visio, Visio prompts you to save the file before quitting.



To quit Visio:

1. Choose File > Exit.

Or click the close box to close the main Visio window.

2. If an unsaved file is open when you quit Visio, Visio prompts you to save the file before quitting. Click 
Yes to save changes and then quit; click No to quit Visio without saving changes; or click Cancel to 
continue working in Visio.

    Overview



Opening existing drawings
    How To
    Related Topics

You can open existing Visio drawing (*.vsd) files to edit them. When you select a file name in the Open 
dialog box, information about the file appears, which allows you to identify the drawing you want to open. 

You can choose whether to open the original file, a copy, or a read-only version that you can't edit.



To open an existing drawing file:

· Choose File > Open, choose the drawing you want to open, then click Open.
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Saving workspace (*.vsw) files
    How To
    Related Topics

If you like to have two or more drawing files open at a time, as well as multiple stencils, you can save all 
the open files as a workspace (*.vsw) file. Then, when you open the workspace file, all of the drawings 
and stencils you had open will be intact. Workspace files contain only pointers to all of the files you have 
open, so you still need to save your drawing as a drawing (*.vsd) file.



To save a workspace file:

1. Save the files you have edited.

2. Choose File > Save Workspace.

3. For File Name, type a name for the workspace file.

4. In the Save In box, choose the folder in which you want to save the file.

5. Click Save.

    Overview



Saving a Visio 5.0 file as an earlier version
    Related Topics

You can save Visio 5.0 drawings in Visio 4.x formats so that you can share files with others who have the 
earlier version of Visio. If you save a Visio 5.0 file in a Visio 4.x format, the file will lose information that 
the earlier version does not support.

If you save a Visio 5.0 file in a Visio 4.x format:

· Some SmartShapes won't be as "smart." For example, if you've associated actions or events with any 
of the new marketing shapes, they will be lost.

· Dynamic connectors become universal connectors.

· Any named connections you've created are lost.

· Hyperlinks are lost.

· Email routing lists are lost.

· ActiveX controls won't function as expected.

· Custom patterns convert to a solid pattern.

· Custom line ends convert to a line end of None.

· Rotated Guides are no longer rotated and all associated glue is lost.



Typing special characters
    How To
    Related Topics

You can insert ANSI characters into text. The ANSI character set consists of 256 characters established 
by the American National Standards Institute. How ANSI characters look onscreen depends on which font
you are using.



To type ANSI characters:

1. Make sure you have NumLock on.

2. Hold down the Alt key. Using the keys on the numeric keypad, type 0, then the ANSI code for the 
character you want. For example, to type an em dash (¾), press Alt + 0151.
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Checking spelling
    How To
    Related Topics

You can check the spelling of any text in a drawing. When you check spelling, Visio searches all shapes, 
including text-only shapes and data fields. You can specify whether Visio searches an entire drawing, a 
particular page, or selected text only.

If you use industry or company words that aren't in a standard dictionary, you can create a user dictionary 
that includes these words. Then, when Visio checks your spelling, it will be able to check the spelling of 
those words against the spelling you set. You can even create different user dictionaries for different 
purposes and activate each as you need it.



To check spelling in a drawing:

1. Choose Tools > Spelling, click the spelling tool ( ), or press F7.

If Visio encounters any words not found in its dictionary, it displays the Spelling dialog box. Click 
Options to ensure that the spelling options are set the way you want. 

2. When Visio has finished checking spelling (or if it doesn't find any misspelled words), a message box 
appears indicating that it has finished checking. Click OK.

TIP    To set spelling checker defaults, choose Tools > Options, then click the Spelling tab and set the 
options you want.
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To create a user dictionary and make it active:

1. Choose Tools > Options. In the Options dialog box, click the Spelling tab.

2. Under User Dictionaries, click Add.

3. In the Add User Dictionary dialog box, under File Name, type a name for the dictionary, then click 
Open. 

4. Click OK.

To make an existing dictionary active:

1. Choose Tools > Options. In the Options dialog box, click the Spelling tab.

2. Under User Dictionaries, click add, select the dictionary you want to make active, then click Open.

3. Click OK.

To make a user dictionary inactive:

1. Choose Tools > Options. In the Options dialog box, click the Spelling tab.

2. Under User Dictionaries, choose the dictionary you want to make inactive, then click Remove. This 
doesn't delete the file, but keeps it from appearing in the Add Word To list in the Spelling dialog box. 
You can make the dictionary active at another time.

3. Click OK.

NOTE    If you're using the Visio dictionary, user dictionaries are stored in the Visio\Systems\Spelling 
folder. If you're using a Microsoft Word dictionary and Windows, see your Word documentation to find 
where dictionaries are stored.
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Finding and replacing text
    How To
    Related Topics

You can search for text or replace specified text with another word or phrase. When you search for text, 
Visio searches all shapes, including text-only shapes and data fields. You can specify whether Visio 
searches an entire drawing, a particular shape, or selected text only.



To search for a word or phrase:

1. Choose Edit > Find to open the Find dialog box.

2. Type a word or phrase you want to find or click Special to specify a special character, such as a tab or 
caret.

3. Choose the search and match options you want, then click Find Next.

4. Click the Close button to close the Find dialog box to edit the word or phrase, or click Find Next to find 
its next occurrence.
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To replace a word or phrase:

1. Choose Edit > Replace to open the Replace dialog box.

2. Type the word or phrase you want to replace or click Special to specify a special character, such as a 
tab or caret. 

3. Choose the search and match options you want, then click Find Next or Replace All (to replace all 
instances of the word or phrase).

4. When Visio has finished replacing text, a message box appears. Click OK, then click the Close button 
to close the Replace dialog box.

NOTE    In international English versions of Visio, you can also specify whether you want to search for 
double-wide characters, single-wide characters, or both.
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Modifying layer assignments for masters
    How To
    Related Topics

If you create multiple drawings that use the same layers, the most efficient way to assign shapes to layers
is to assign the masters on your stencils to layers first. When you create an instance in your drawing, the 
instance inherits the master's layer assignment, and the layer is automatically added to the page. You can
also change the layer assignments for masters that have pre-defined layers.

Assigning masters to layers works particularly well if you have standard categories to which groups of 
shapes belong, such as roads, signs, water, and buildings in a directional map diagram or wall, fixtures, 
and dimensions in a space plan.

Assign masters to layers so that when you drop the shapes on the page, they automatically appear on the correct 
layer.

A The Thin road master is assigned to the Streets layer.

B The Hospital and other building masters are assigned to the Landmarks layer.

You can edit an existing stencil and modify the layer assignments of its masters. You must open the 
stencil as an original file to do this. If you have already created a drawing, you can edit the masters on the
drawing's local stencil, then save it as a new stencil for the next time you need to create a drawing using 
those shapes.



To create or modify master layer assignments:

1. To modify an existing stencil, choose File > Stencils > Open Stencil, select the stencil you want, click 
Original, then click OK. To modify a drawing's local stencil, choose Window > Show Master Shapes.

2. Click the stencil's title bar to activate the window, then double-click a master to open it in the master 
drawing window.

3. Select the master.

4. If the master is already assigned to a layer that you want to rename, Choose View > Layer Properties.

In the Layer Properties dialog box, choose the layer you want to rename, then click Rename. Type a 
new name for the layer, then click OK. Click OK in the Layer Properties dialog box.

5. Choose View > Shape Layer.

6. Choose the layer to which you want to add the shape, click OK, then close the master drawing window.
When Visio prompts you to update the master, click Yes.
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Protecting drawing-file attributes
    How To
    Related Topics

You can protect certain attributes in a drawing file so they can't be changed. Others can open the file to 
look at the drawings, but they cannot edit the attributes you protect. If you want to allow certain people to 
make changes, you can set a password. 

For example, you can

· Protect a background containing a company logo so people can edit shapes on the drawing page 
without inadvertently changing the logo.

· Password-protect a drawing file's styles so only specific people can change the way standard shapes 
look.

· Protect a file's shapes or master shapes so people can add to the drawing, but not change the existing 
shapes or masters.

NOTE    Protecting a drawing file's attributes applies protection to all shapes in the file. To protect 
individual shapes, use the Protection command.



To protect a file:

1. Choose Tools > Protect Document.

2. Check the items that you want to protect.

If you want specific people to be able to bypass the protection settings, type a password. The 
password is not visible after you close the dialog box, so be sure to memorize it or write it down.

3. Click OK.
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To remove protection from a file:

· If you've used a password to protect the file, choose Tools > Unprotect Document, type the password, 
then click OK. All options you protected will be unprotected.

· If you haven't used a password to protect the file, choose Tools > Protect Document. Uncheck the 
items from which you want to remove protection, then click OK.
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About working with color
    Related Topics

When you apply color to a line, fill, shadow, or text, it helps to understand how the results are affected by 
the way color works in Visio.

Colors are opaque
All colors in Visio, including white, are opaque both in print and onscreen. For example, if you apply a 
solid white to a rectangle, you cannot see what's underneath the rectangle. To make a line or fill 
transparent, you must apply a pattern of None to it. (Because you cannot apply a pattern to text, you 
cannot make text transparent.)

Screen resolution affects display of color
The number of colors your display driver supports affects how colors display when you apply them to 
different kinds of elements in a Visio drawing.

When you apply a color to lines, text, or bitmap-pattern fills and shadows, Visio uses the color that is the 
closest match available to the specified color. For example, with a 16-color display, orange is mapped to 
yellow. If your display driver supports 256 colors or more, the match is likely to be exact, meaning orange 
is mapped to orange.

When you apply a color to a solid- or gradient-pattern fill or to a shadow, Visio dithers any color that is not 
one of the eight standard colors to approximate the specified color. For example, on a 16-color display, 
orange is dithered. If your display driver supports 256 colors or more, colors may not need to be dithered.

Visio shows both the closest-matching solid color and the dithered approximation in each color swatch in 
its palette or list. The dithered color is the left half of the swatch and the solid color is the right half. On 
high resolution monitors, there may not be any difference between the two.

Working with foreground and background colors
For fills and shadows, you can specify a foreground color and a background color.

· For the solid pattern, Visio uses the foreground color and ignores the background color.

· For bitmap patterns, Visio applies the foreground color to the dots and lines that make up the pattern 
and the background color to the background.

· For gradient patterns, Visio graduates from one color to the other. 

Because a solid pattern fill is applied to this rectangle, the foreground color is used for the fill.



When you change the fill to a bitmap pattern, the foreground color is used for the pattern, and the background color is
used for the background.



About custom colors
    Related Topics

The difference between a custom color and a color on the color palette is that a custom color is tied to the
shapes to which it is applied. If you remove all of those shapes from the drawing and then save the 
drawing, the custom color is removed from the color lists in the dialog boxes. That's because custom color
values are defined absolutely in each shape's ShapeSheet spreadsheet. For example, if you create a 
custom orange for a rectangle, the ShapeSheet spreadsheet for that shape lists the color as 
RGB(255,128,0). Until that formula is changed, the shape will be orange no matter where you take it. 
When you delete the shape, its ShapeSheet spreadsheet is also deleted.

In contrast, a color on the color palette is tied to the color palette. Even if you have no shapes in the 
drawing, the 24 palette colors remain. For example, if you change the blue in the default color palette to 
orange, but don't apply it to any shape, the orange still exists when you save the drawing. If you apply the
color to a shape, it is defined in the ShapeSheet spreadsheet by its position on the color palette. For 
example, in the default color palette, blue is number 4, which is what would be listed in the ShapeSheet 
spreadsheet for color. If you change the color in the color palette to orange, it's still number 4, so every 
shape that was blue becomes orange. And if you paste the shape into a drawing in which color number 4 
is red, the shape becomes red.



Using custom colors and color palettes
    How To
    Related Topics

When you assign colors to fills, lines, or text in Visio using toolbar palettes or commands on the Format 
menu, you have a limited number of color choices. However, you can assign custom colors to shapes or 
modify an existing color in the active drawing file's color palette. You can also use a different color palette 
by choosing one Visio provides (such as the Excel Chart Color Palette), or by copying one from another 
Visio drawing file.

Each drawing file contains its own color palette¾in other words, palettes are not standalone files. If you 
have a palette file that you use regularly in other programs, recreate it in a blank Visio drawing file and 
then save it. You can then copy that color palette into any drawing you create. 

To create a custom fill, line, or text color, you can add a new color or edit an existing color in the color 
palette. If shapes in the file are formatted with a color that you edit, the shapes' formatting changes to the 
new color. Colors you define or edit appear in the color lists in the Fill, Text, and Line dialog boxes.



To create and assign a custom color in a color list:

1. Select a shape, then choose Text, Line, Fill, or Shadow from the Format menu.

2. In the Text or Line dialog box, choose Custom from the Color list. In the Fill or Shadow dialog box, 
choose Custom from the Foreground or Background color list.

3. In the Color dialog box, specify the color you want, then click Add To Custom Colors. 

4. Click OK.

The color appears in the color list. It will also appear in the color lists in the other formatting dialog 
boxes, but will not appear in the Color Palette dialog box.

NOTE    If you delete all shapes to which a custom list color is applied and then save the drawing, Visio 
removes the custom color from the color lists.

    Overview



To modify colors in the color palette:

1. Choose Tools > Color Palette.

2. From the list of colors, click the color you want to change.

It's best not to edit colors 0 (black) and 1 (white). Changing these colors will affect many areas of the 
drawing, including those you may not want to change.

3. Click Edit.

The Color dialog box appears.

4. In the Color dialog box, choose one of the basic colors or define a custom color.

5. Click OK. 

The new color appears in the Visio color palette.

6. In the Color Palette dialog box, click OK.

In addition to appearing in the color palette, the modified color appears on the color list in the Text, 
Line, Fill, or Shadow dialog boxes.

Any shapes colored with the original color take on the modified color.

For details about editing colors, see your Windows documentation.
    Overview



To choose a different color palette for a drawing file:

1. Choose Tools > Color Palette.

2. In the Copy Colors From list, choose one of the palettes provided with Visio.

The new colors show in the color palette.

3. Click OK.

    Overview



To copy the color palette from another drawing file:

1. Open the file with the color palette you want to use.

2. Choose Tools > Color Palette

3. From the Copy Colors From list, choose one of the listed color palettes or a file name. 

Choosing a file name copies the color palette for that file to the current drawing. Only the names of 
open files appear in the list.

4. Click OK.

    Overview



Setting color behavior in custom line and fill patterns
    How To
    Related Topics

When you create a custom line or fill pattern, you can choose whether the pattern takes on the colors of 
the shape it's applied to, as the Visio patterns do, or whether the pattern's colors override the shape's 
colors.



To set a pattern to take on a shape's colors:

· For fills, make sure the foreground color for the shape on which the pattern is based is set to white and
the background color to black. If you want only the foreground or background color to take on the 
shape's color, you only need to set that one. For example, if you want the foreground to always be red, 
but the background to take on the shape's color, set the foreground to red and the background to 
black.

· For lines, make sure the line color for the shape on which the pattern is based is set to black.

    Overview



To set a pattern to override a shape's colors:

· For fills, make sure the foreground color for the shape on which the pattern is based is set to a color 
other than white and that the background color is set to a color other than black. If you only want the 
foreground or background color to override the shape's color, you only need to set that one. For 
example, if you want the foreground to always be red, but the background to take on the shape's color, 
set the foreground to red and the background to black.

· For lines, make sure the line color for the shape on which the pattern is based is set to a color other 
than black.

    Overview



Converting a text file to a Visio drawing
    How To
    Related Topics

You can import text files in Comma Separated Variable (.csv) or Text (.txt) format into Visio. The Visio text 
file converter translates specific codes contained in the text file into a Visio drawing. 

Text import record types
Each line in a text file you import is a record, and each record must conform to a record type by listing 
specific fields in a specific order.

The general syntax for records and fields is:
<record type, > <field,field,field,... > 

For example:
Master,Logo,Pentagon,BASIC.VSS

In this example, "Master" is the record type, and "Logo," "Pentagon," and "BASIC.VSS" are fields.

NOTE    The comma is the default field separator for .csv files. If you're creating a file in the .txt format, the
default field separator is a tab.

If a field is optional, you can leave it blank. To leave a field empty, you type only the field separator (that 
is, comma or tab).

For example:
Master,,Pentagon,BASIC.VSS

The first field is left blank. 

Available record types
AvenueSize
BlockSize
Gridding
LineToLineClearance
Link
Master
NodeToLineClearance
PlacementStyle
Property
RoutingStyle
Shape
Template



To import a text file:

1. Choose File > Open.

2. Under Files Of Type, choose Text Files (*.csv, *.txt).

3. In the Look In box, find the folder that contains the text file, select the file, and click Open.

4. In the Visio File Converter dialog box, choose the options you want.

Field Separator    Select the character your text file uses to separate fields within records. The text 
import filter recognizes the comma, tab, or semi-colon as valid field separators.

Text Delimiter    Select whether your text file uses single or double quotation marks to enclose text 
strings.

Comment Character    Select the character that marks a comment line that the filter can ignore during 
the conversion process. Valid comment characters are: semi-colon (default), number sign (#), 
exclamation point (!), forward slash (/), or backward slash (\).

Merge Into Current Drawing    Check this option if you want to incorporate the text file into an existing 
drawing. If you want Visio to start a new drawing file, leave this box unchecked.

5. When you're finished selecting options, click OK.

Visio converts the text file to a drawing.

NOTE    If the text file's Shape records do not include position information, Visio uses the Lay Out Shapes 
command to place shapes automatically. However, if the drawing is not a connected diagram (such as a 
flowchart or network diagram), you may need to reposition shapes after the conversion process is 
complete.

    Overview



AvenueSize record type (text import)
    Related Topics

Description    Optional. Used to specify the width or height of avenues in the Lay Out Shapes grid.

Usage    Used by text import operations.

Fields:

Width Width in inches.

Height Height in inches.

BlockSize record type (text import)
    Related Topics

Description    Optional. Used to specify the block size of the Lay Out Shapes grid.

Usage    Used by text import operations.

Fields:

Width Width in inches.

Height Height in inches.

Gridding record type (text import)
    Related Topics

Description    Optional. Used to specify whether or not to turn on the Lay Out Shapes grid.

Usage    Used by text import operations.

Fields:

UseGrid A Boolean (integer) value. Non-
zero enables the grid; 0 disables 
it.

LineToLineClearance record type (text import)
    Related Topics

Description    Optional. Used by the Lay Out Shapes command to specify the minimum distance between
connectors.

Usage    Used by text import operations.

Fields:

Horizontal Horizontal space in inches.

Vertical Vertical space in inches.

Link record type (text import)



    Related Topics

Description    Required. Works similarly to the Shape record type, but it is used for 1-D shapes 
(connectors) that connect two other shapes. It identifies the master used to draw the connector, and it 
contains shape text, connections, and custom property values.

TIP    Use the Dynamic Connector shape because it connects shapes with dynamic glue, which allows 
Visio to reposition connectors as shapes move. Then those connectors connect the closest points 
between two shapes and do not cross through other shapes.

Usage    Used by all text import operations.

Fields:

ShapeID A shape identifier (a string). 
ShapeID must be unique within 
the drawing.

MasterName Refers to the MasterName field 
defined in a Master record, which
identifies the link master to use. 
If this field is empty, or if the 
master cannot be found, the link 
is created with the Layout 
Connector shape.

Text The text you want to display in 
the connector's text block.

From The ShapeID of the shape from 
which the link begins.

To The ShapeID of the shape where
the link ends.

Propertyn 0 or more custom property 
values.

Master record type (text import)
    Related Topics

Description    Required. Defines masters that can be referenced from Shape record types.

Usage    Used to find masters that are referred to in Shape records.

NOTE    The text import filter uses existing master shapes to determine how to draw a shape. If the text 
import filter cannot locate master information for a shape in the text import file, it draws a rectangle.

Fields:

MasterName Optional. The name you assign 
to reference the master from the 
Shape and Link records. The 
MasterName must be unique 
within a drawing. You can choose
any name¾the MasterName field
is not associated with the 
master's name on the stencil. 

MasterID The name of the master in the 



Visio stencil. This is the name 
the text import filter uses to find 
the master. NOTE    If this 
information is not included, the 
text import filter draws a 
rectangle for the shape.

StencilName The name of the Visio stencil 
(.vss) file that contains the 
master. The file path is optional. 
NOTE    This field may be left 
blank if you include the Template 
record type and the master is on 
one of the template's stencils.

NodeToLineClearance record type (text import)
    Related Topics

Description    Optional. Used by the Lay Out Shapes command to specify minimum distance between 
"nodes" (shapes) and connectors.

Usage    Used by text import operations.

Fields:

Horizontal Horizontal space in inches.

Vertical Vertical space in inches.

PlacementStyle record type (text import)
    Related Topics

Description    Optional. Used to define the layout style for the Lay Out Shapes command. If you do not 
include x- and y-coordinate information with Shape records, the text import filter runs the Lay Out Shapes 
command automatically.

Usage    Used by text import operations.

Fields:

Style An integer corresponding to one 
of the styles listed in the Lay Out 
Shapes dialog box.

0    Radial 
1    Top to Bottom
2    Left to Right

Property record type (text import)
    Related Topics

Description    Optional. Used to define or redefine custom properties for a master (or all masters). Note 
that this deletes and replaces any of the shape's existing custom properties.

Usage    Used by text import operations.



Fields:

Master The name of the master for 
which you want to define or 
redefine custom properties. If this
field is blank, the custom 
property is assigned to all 
masters in the drawing. NOTE    
The Master name in this field is 
the same as the MasterName 
field you assign in Shape and 
Link records.

RowName The name of the custom property
row in the ShapeSheet 
spreadsheet. If left blank, Visio 
generates a generic name, such 
as "Row_1".

Label The label that appears in the 
Custom Properties dialog box. 
This field may be left blank.

Prompt The text that appears in the 
Prompt section of the Custom 
Properties dialog box when this 
property is selected.

Type An integer that must be a valid 
custom property type. For a list 
of valid custom property types, 
see Type (Custom Properties 
section).

Format A string that is a valid custom 
property format string. For details
about valid format strings, see 
FORMAT function.

Value A default value for the custom 
property. The value can be a 
string or a number, but it must 
agree with the Type field. This 
field may be left blank.

Hidden A Boolean (integer) value. Non-
zero prevents the custom 
property from being displayed in 
the Custom Properties dialog 
box. Blank or zero allows the 
custom property to be displayed 
normally.

Ask A Boolean (integer) value. Non-
zero displays the Custom 
Properties dialog box when the 
shape is dropped on the page, to
prompt the user to enter a value 
for the property. A blank field or 



zero value does not display the 
dialog box.

NOTE    For details about Property fields, see Custom Properties section.



RoutingStyle record type (text import)
    Related Topics

Description    Optional. Used to define the connector routing style for the Lay Out Shapes command.

Usage    Used by text import operations. 

Fields:

Style An integer corresponding to one 
of the routing styles listed in the 
Lay Out Routing dialog box.

5    Flowchart
1    Right Angle

Shape record type (text import)
    Related Topics

Description    Required. Used for shapes that are not connectors. It identifies the master used to draw the
shape, and it contains shape text, size and position data, and custom property values. (For connectors, 
see the Link record type.)

Usage    Used by all text import operations.

Fields:

ShapeID A shape identifier (a string). 
ShapeID must be unique within 
the drawing.

MasterName Refers to the MasterName field 
defined in a Master record that 
creates the shape. If this field is 
blank, or if the master cannot be 
found, the shape is drawn as a 
rectangle.

ShapeText The text you want to display in 
the shape's text block.

ShapeX The shape's x coordinate.

ShapeY The shape's y coordinate. TIP    If
you don't want to calculate each 
shape's x and y position, leave 
the ShapeX and ShapeY fields 
blank. When these fields are 
empty, the text import filter runs 
the Lay Out Shapes command, 
which positions the shapes 
automatically.

Width Width of shape. If this field is 
empty, Visio uses the default 
width for the master.

Height Height of shape. If this field is 



empty, Visio uses the default 
height for the master.

Propertyn 0 or more custom property 
values.

Template record type
    Related Topics

Description    Optional. Specifies a Visio template upon which the drawing is based. Each text file can 
contain only one template record.

Usage    Used to establish defaults for drawing parameters such as page size, date formats, grid and ruler
settings, and so on, when a new drawing is created.

Fields:

FileName Name of a Visio template file 
(path optional).

Manually editing routable connector paths
    Related Topics

You can move a routable connector's vertices and midpoints to change its path between the two shapes it
connects. For example, if a connector runs through the space between two shapes, but you want to keep 
the shapes visibly associated with each other, you can create a "bridge" in the connector to route it 
around the other side of one of the shapes. You can also create connectors with diagonal segments¾for 
example, for network diagrams.

Techniques for manually editing routable connector paths
To Do This Example

Move a connector line
segment while 
maintaining the 
angles between it and
the segments on each
side of it

Drag a 
midpoint

Create a new vertex 
in a connector

Shift+drag
a midpoint

Create a "bridge" in a 
line segment

Ctrl+drag 
a midpoint

Move a vertex while 
maintaining angles of 
the line segments

Drag a 
vertex

Reposition a vertex 
without maintaining 
angles of the line 
segments

Ctrl+drag 
a vertex



NOTE    Before you edit a routable connector, make sure it's connected to each shape the way you want. 
If you move one of its endpoints after editing it, it automatically reroutes with a new path.



Printing color drawings on monochrome printers
    How To
    Related Topics

When you print drawings on a monochrome printer, Visio translates the colors on the screen into gray 
tones on the printed page. White prints as no color and black prints as black. 

Some printer drivers provide grayscale options. You can experiment with grayscale options to find which 
one works best.



To specify a grayscale option:

1. Choose File > Page Setup, then click Print Setup.

2. Click Printer, then click Properties.

3. In the Properties dialog box, set printing options that control the grayscale. 

This dialog box is printer specific.

4. Click OK, then click OK again.

5. Click OK in both the Print Setup and Page Setup dialog boxes.

TIP    For the best gray tones in a printed drawing, use the grays in the Visio default color palette. If you 
use patterned fills, try using a solid color for the fill background and a shade of gray for the foreground. 
These patterns print better than some other patterns.

    Overview



Avoiding unexpected printing results
    Related Topics

The best way to prevent unexpected printing results is to choose File > Print Preview to view the printed 
drawing before you print it. If the print preview doesn't look the way you expect, you can reposition 
shapes or adjust drawing settings to make sure it prints correctly.

Another way to avoid common unexpected printing results is by understanding the relationships between 
the drawing page, printed drawing, and printed page size.

Below are some common problems that may occur when one of the three components isn't set to match 
the other two.
You can avoid some common, unexpected printing results by making sure drawing- and printed-page orientation 
settings are the same.

When the drawing page orientation is different from the printed page orientation. Sometimes, 
changing the orientation of the drawing page fits your drawing more appropriately. However, because 
Visio considers drawing- and printed-page orientation to be separate elements, if you change the 
drawing-page orientation but not the printed-page orientation, Visio displays an alert that tells you the 
drawing page is oriented differently than the printed page.

When you see this alert, you can click OK to continue printing. The drawing will require additional printed 
pages. Usually, though, a better alternative is to click Cancel, then open the File > Page Setup dialog box 
and change the printed page orientation to match the drawing page. That way the drawing prints the way 
it looks onscreen.



When changing margins or centering a drawing has no effect. The Print Setup dialog box includes 
settings for changing the margins or centering the drawing on the printed page. If the drawing-page size is
not set properly, the printed drawing may not reflect changes in these settings.

To use the margin and centering settings in the Print Setup dialog box successfully, before you print the 
drawing, set the drawing-page size to Size Page To Fit Drawing in the Page Setup dialog box.

When enlarging a drawing causes unnecessary blank printed pages. In the Print Setup dialog box, 
you can choose to reduce or enlarge your drawing on the printed page. If your drawing is small, enlarging 
it can make it easier to see on the printed page. However, when you enlarge a drawing, Visio may print a 
number of blank pages in addition to the drawing.

To avoid this problem, before you print the drawing, set the drawing-page size to Size Page To Fit 
Drawing in the Page Setup dialog box. 

When some shapes don't appear in printed drawings. If a shape doesn't appear in a printed drawing, 
the printer driver may have translated the color of the shape's line and fill as white.

To print the shapes:

· Change the color of the shape's line or fill to a darker color. The printer driver translates the color as a 
darker gray, so the shape appears in the printed drawing.

· Choose File > Print and, in the Print dialog box, check Color As Black. Visio converts the lines and fills 
of all shapes to black before sending them to the printer, so shapes are visible in the printed drawing. 
This is helpful if you can't determine which shapes are missing from the printed drawing.

Another reason why a shape doesn't print is that it's set as a non-printing shape. To find out if a shape is 
non-printing and set it to print, select the shape, then choose Format > Behavior. If the Non-Printing 
Shape box is checked, uncheck it, then click OK.





Controlling the border around embedded or linked Visio objects
    How To
    Related Topics

Sometimes when you embed or link an entire drawing, extra white space appears around the Visio object 
in the container program. These are the areas of the original Visio drawing page that don't have shapes, 
but are included when you use the Copy Drawing command. 

However, sometimes when you embed or link selected shapes, there may not be enough white space 
around the Visio object in the container program. In either of these situations, you can easily define the 
amount of white space that appears around the Visio object.



To eliminate space around an embedded or linked drawing:

1. In the program from which you are linking the drawing, use the command to open the embedded or 
linked drawing in the full Visio window.

In Microsoft Office programs, this command is Edit > Visio Object > Open.

2. In Visio, choose File > Page Setup.

3. On the Page Size tab, select Size Page To Fit Drawing, then click OK.

The drawing page resizes to fit only the shapes. It may appear as though you zoomed in on the 
drawing.

4. Choose File > Exit And Return To <File name>.

    Overview



To define a specific amount of white space around linked or embedded shapes:

1. In Visio, draw a rectangle that encloses the area you want to link or embed. Size and position the area 
to reflect the amount of space you want on each side of the drawing when it's linked or embedded.

2. Make the rectangle transparent by applying the fill style None to the rectangle, or move it behind the 
shapes by choosing Shape > Send To Back.

3. If you don't want the drawing to have a border, make the border transparent by applying the line style 
None to the rectangle.

4. Choose Edit > Select All, then choose Edit > Copy.

5. Embed or link the drawing into the other program's document.

    Overview



Formats in which you can export Visio shapes and drawings
Visio can export shapes and drawings in these formats:

· Adobe Illustrator File Format (.ai)

· AutoCAD Drawing Web Format (.dwf) (Visio Technical only)

· CompuServe Interchange Format (.gif)

· Computer Graphics Metafile (.cgm)

· Encapsulated PostScript (.eps)

· Initial Graphics Exchange Specification (.igs)

· Joint Photographic Experts Group (.jpg)

· Macintosh Picture File Format (.pct)

· Portable Network Graphics (.png)

· Tag Image File Format (.tif)

· Windows Bitmap (.bmp, .dib)

· ZSoft PC PaintBrush Bitmap (.pcx)

When you export a shape or drawing, a Filter Setup dialog box may appear in which you choose settings 
for the exported file. Because each file type has its own settings, the dialog box you see depends upon 
the format in which you export the drawing. Some of the most common settings include:

Profiles    Lists the preset setting profiles for the file format you're exporting. To create a new profile with 
settings you select, click the New option, and enter a profile name. To remove a profile from the list, select
the profile, then click the Delete option. To return to the default settings, click the Defaults option.

Color Translation    Controls how colors translate. The Normal option translates colors exactly as 
specified in the original file. The Inverse option inverts all colors to their opposite values. For example, 
white becomes black and blue becomes yellow. The Inverse Grays Only option inverts only white, black, 
and grays. The Gray Scale option converts all colors to shades of gray. The Inverse Gray Scale option 
converts all colors to shades of gray, and then inverts them.

Line Cap Mode    Controls the appearance of line ends. The Device option bases line ends on those the 
file format supports directly. The Stroked option bases line ends on those the program offers or the file 
format can emulate. The Device option supports fewer line ends but results in faster screen redraw.

Resolution    The Screen option bases the exported file's resolution on current screen resolution. The 
Printer option bases the resolution on current printer resolution and gives optimum printout results. The 
Source option allows the source program to determine the resolution. The Custom option allows you to 
choose the resolution (your width x height dimensions should be somewhere between 32 and 400 pixels 
per inch).

Size    The Screen option bases the exported file's size on the screen size and places the largest possible 
image within the dimensions of the screen while maintaining the original drawing's or shape's aspect ratio.
The Printer option bases the size on the currently selected printer paper size, and places the largest 
possible image within the dimensions of the paper size while maintaining the original drawing's or shape's
aspect ratio. The Source option bases the size on the size of the source. The Custom option bases the 
size on the custom size (width x height) you enter and places the largest possible image within the 
custom dimensions while maintaining the original drawing's or shape's aspect ratio.

    Overview



Changing default styles for drawing and text tools
    How To
    Related Topics

You can change default line, fill, and text formatting for the drawing tools¾the pencil, freeform, line, arc, 
rectangle, and ellipse tools¾and for the text tool. When you change the default styles, shapes you draw 
with those tools automatically display the new formatting.



To change the default style for the drawing and text tools:

1. Click a blank area of the drawing page to cancel any shape selections.

2. On the Shape and Text toolbars, choose the formatting settings you want. For example, if you want all 
text-only shapes you draw with the Text tool to use the Times New Roman font, select that font from 
the font list. (Text you type into shapes you draw with the drawing tools also use the font you select.)

Now when you draw a shape with one of the drawing tools, it displays the formatting you defined. (Text-
only shapes that you draw with the Text tool do not display the line and fill settings.)

    Overview



Changing the default text, line, or fill styles in shapes
    How To
    Related Topics

You can define default styles for your drawing file so that shapes display the styles you want    when you 
drop them onto the drawing page.

The formatting for shapes on stencils is defined by styles that you can edit. Frequently, the same styles 
are applied to all related shapes on a stencil. That way, you can change the formatting for all the shapes 
in the current drawing at once by editing the style.

First, find out what styles are assigned to a set of shapes, then edit the attributes in the style listed as the 
default. After you edit the style, all shapes to which the style is assigned inherit the new formatting. 



To determine the default styles:

1. Drag a shape from the stencil to the drawing page.

2. While the shape is selected, choose Format > Styles.

The styles that appear in the Text, Line, and Fill sections are the default styles assigned to that shape. 
The same style may be assigned to more than one or all of the attributes.

    Overview



Working with Document Management Systems
    Related Topics

Visio supports the Open Document Management Architecture (ODMA) standard so that, if you work with a
Document Management System (DMS), you can include Visio drawings within it. 

When Visio detects the presence of ODMA 1.5 on your system, it passes the Open and Save file-
management operations to the DMS program so that

· When you choose the Open command from the Visio File menu, the DMS Open dialog box appears so
that you can open files stored within your document management system.

· When you choose the Save or Save As command from the Visio File menu, the DMS Save dialog 
boxes appear so that you can save Visio drawings and store them within your document management 
system.

To take advantage of Visio's ODMA compatibility, you must open and save files using the File > Open and
File > Save commands (rather than using keyboard alternatives or the list of recently opened files on the 
File menu).

You may need to register Visio 5.0 with your DMS program before you can open and save Visio drawing 
files. For details, see your DMS program documentation.




