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INTRODUCTORY TUTORIAL





Graphic Workshop Professional is an image management package. It can be regarded as a simple picture viewer, a file converter or a sophisticated image processor, depending on what you require of it. It has been designed to allow you to use as much or as little of its functionality as you require – without having the rest get in your way.





This document will provide you with a quick overview of the most commonly used features of Graphic Workshop. Because Graphic Workshop is a powerful application with a lot of functionality, it will of necessity leave out quite a lot. More extensive documentation for Graphic Workshop was installed along with the software.





Graphic Workshop supports virtually all the popular bitmapped graphic file formats and quite a few really obscure ones. You can find out more about the file formats it supports in the Formats document.





Throughout this discussion, you'll encounter references to configuring Graphic Workshop to fine-tune its options to your requirements. The details of how to change Graphic Workshop's configurable options are dealt with in the Configuration document. For the moment, while you might want to keep these options in mind, you can ignore them as you work through this tutorial – Graphic Workshop comes configured with pretty reasonable default settings.





The first important thing to keep in mind about Graphic Workshop is that its user interface is that of a file browser – along the line of Windows Explorer – not a document-based application, like WordPad. To use it, you must:





1. Point a browser window at the directory where your files are.





2. Process the files you're interested in. This unquestionably sounds more involved than it really is.





Graphic Workshop supports multiple browser windows. If you have several directories where you usually keep files, you'll probably find that its convenient to leave a browser window pointing to each one and just switch between them. Graphic Workshop remembers its open browser windows between sessions.





When you first run Graphic Workshop, it will create a single browser window which will be pointing at its parent directory. There are several example graphics in this directory to look at.





Note that a browser window will only show you files of those types which Graphic Workshop knows how to work with. For example, if the directory a browser window is looking at contains GIF files and DOC files, the browser window will only show you the GIF files. DOC files are Word documents, rather than graphics, and Graphic Workshop wouldn't know what to do with them.





Each browser window can display the names of the files it sees in one of four modes. These modes are:





Small text – just the file names


Normal text – just the file names plus a grey document icon


Small thumbnails – the file names plus small thumbnail images


Normal thumbnails -- the file names plus normal thumbnail images





By default, Graphic Workshop will open browser windows in the latter mode. You can change this once a browser window has been open, and you can configure Graphic Workshop to use a different default mode for new browser windows if you like.





Once you get tired of Graphic Workshop's example images, you'll probably want to point one of its browser windows at a directory where your graphics are. You can do this in one of two ways:





1. The easiest way to navigate around your hard drive with a Graphic Workshop browser window is to select the directory where your files reside using the directory tree at the left side of each browser window. This works the same way as the directory tree in Windows Explorer, save that each Graphic Workshop browser window has its own directory tree, and as such each browser window can look at a different directory.





Note that if you need a wider directory tree display, you can click and hold in the area between the directory tree and the file list in a browser window and drag the directory tree to change its size.





2. Alternately, you can change directories by clicking on the yellow folder button in the Graphic Workshop tool bar or selecting Change Directories from the file menu. A dialog will appear to allow you to select the new directory you want your browser window to look at.





As with all the functions in the tool bar, if you have multiple browser windows open, the tool bar always refers to the topmost one.





When Graphic Workshop first comes on line, you will see thumbnail images for most of the files that its browser window is looking at. Any file which does not have a thumbnail available will display a symbol that looks like this:





�





Files which display this symbol are probably just fine – they simply don't have thumbnails associated with them as yet.








Viewing Files





You can view any graphic file that Graphic Workshop shows you in a browser window by double-clicking on the name or thumbnail of the graphic in question. The file will be unpacked and a display window will open. By default, Graphic Workshop's display windows will size themselves to fill your screen. You can configure Graphic Workshop to create display windows which are sized to the dimensions of each graphic you view if you like.





To exit a display window, you can do any of the following:





1. Hit Enter or Esc on your keyboard.





2. Open the Picture menu in the View window and select either Next or Cancel.





3. Right-click with your mouse and select Next or Cancel from the menu which appears.





Graphic Workshop can be configured to close its view windows as soon as you right-click in one, and not display the right-click menu.








Adding Thumbnails





If you point a Graphic Workshop browser window at a directory of your own graphics, you'll probably see a field of the grey thumbnail symbols mentioned above. Because thumbnails take a few seconds to create and they occupy space on your hard drive, Graphic Workshop will not create them unless you tell it do so. Here's how to create a thumbnail.





1. Click once on the graphic you'd like to have a thumbnail for. This will select the file.





2. Select Add Thumbnail from the Thumbnail menu.





After a few seconds, a thumbnail should appear for the selected graphic.





Adding thumbnails, like all the other image processes Graphic Workshop can do, can be done with more than one file at a time. This is called "batch processing." If you select more than one file and add thumbnails as was discussed above, all the selected files will have thumbnails created for them.





Graphic Workshop supports a wealth of selection options to make it easy to select the files you want to process. They'll be discussed in greater detail later in this document. For the moment, however, you might want to find these two buttons in the tool bar:
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These are the Tag All and Clear All buttons respectively. The Tag All button will select all the files in a browser window. The Clear All button will unselect all the selected files in a browser window. Once again, keep in mind that these buttons always work on the files in the topmost browser window if you have more than one browser window open.





If you click on Tag All and then select Add Thumbnails from the Thumbnail menu, all the files in the directory your browser window is looking at will be assigned thumbnails.





Once created, thumbnails are permanent until you explicitly remove them. They'll stick around between Graphic Workshop sessions.








Changing Browser Modes





The default normal-size thumbnails make it easy to ascertain what a graphic file's image looks like, but they take up a fair bit of screen real estate. The smaller thumbnail mode might prove more useful in some situations.





If you're working with files for which you don't need thumbnails at all, you'll probably find that seeing just the file names is much more effective.





You can change the browser mode of a browser window by clicking on the Thumbnail button in the Graphic Workshop tool bar.
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A small menu will appear with four icons – a large thumb and a small thumb for normal and small thumbnails and a large "A" and a small "A" for normal and small text. Select the mode you want your browser window to show you. You can change this mode whenever you like.





Note that you can also create multiple browser windows pointing at the same directory but in different modes and just switch between browser windows, rather than changing modes, if you like.





The current browser mode is remembered between sessions, along with the window size and position, for each open browser window.








Working with Browser Windows





You can create new browser windows by selecting New Browser from the File menu. You can have as many browser windows open as you like. Having said this, keep in mind that you might find it difficult to keep track of dozens of them. In addition, having a really enormous number of them open will slow down some aspects of Graphic Workshop.





To close a previously opened browser window, click on the close button in its title bar or select Close from its system menu.
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Browser windows can also be minimized – if you want to keep a browser window pointed at a directory of graphic files you only use occasionally, click on the minimize button in its title bar.
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By default, Graphic Workshop creates new browsers as normal, unmaximized windows. You can configure it to create maximized browser windows if you prefer.





Every time you select a new directory for a browser window, the path to this directory will be added to the list of recently visited directories at the end of the File menu. By default, this list will include your ten most recently visited directories. You can change the directory that a browser window is looking at by opening the File menu and selecting one of the paths.





If you hold down the Shift key and select a path from the File menu, a new browser window will be created to point to the directory you have selected, rather than changing the directory of the topmost browser window.





If you right-click in the directory tree of a browser window, the most recently visited directory menu will appear. If you right-click in the file list of a browser window, the Image menu will appear. The Image menu will allow you to access the same file functions as appear in the Graphic Workshop tool bar.








Processing Files





Processing files can be as simple as converting between formats or as complex as colour reduction, rotating an image in space and enhancing its details. It's doubtful that you'll need all Graphic Workshop's image processing tools. Keep in mind that some of them are a bit complex, and have a variety of options – it's not necessary to understand them all by this afternoon.





You can process files with Graphic Workshop in two distinct ways:





1. You can interactively make changes to characteristics of an image through the tools in View mode. This typically involves looking at a picture and applying "filters" to it to change its colour balance, size and overall appearance. Once an image has been modified, it can be saved back to a new file.





2. You can batch process one or more images without actually ever seeing them in View mode. This can involve things like converting between formats, scaling a batch of files so they all wind up the same size, printing a group of files and so on.





The capabilities of these two approaches overlap somewhat.





This section will deal with batch processing files. A discussion of processing images in View mode will appear later in this document.





The simplest batch process is format conversion. When you convert a file from one format to another, Graphic Workshop actually reads the image out of your source file and writes it to a new destination file in the format you have selected. As with all batch processes, your source image files will not be modified by processing.





The EXAMPLE3.JPG file installed with Graphic Workshop is in a format which cannot be opened in Windows Paint. Windows Paint likes to have the files it works with in the BMP format. If you wanted to edit EXAMPLE3.JPG in Windows Paintbrush, you would do the following. This assumes that you have a Graphic Workshop browser window pointing at the directory where EXAMPLE3.JPG resides.





1. Click once on EXAMPLE 3.JPG to select it.





2. Click on the Convert button in the Graphic Workshop tool bar. This is the leftmost button. Alternately, select Convert from the Image menu, or right-click in the file area of the browser window to display a floating Image menu and select Convert from that.
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Note that all the tool bar buttons have tip windows. If you forget what a button does, leave you mouse cursor positioned over it for a moment and a window will open to explain its function.





3. A destination window will appear. Each format that Graphic Workshop can write images to will be represented by a button. Click on the BMP button.





4. A dialog will appear to ask you what directory you'd like your new file written to. It will default to the directory where your source file, EXAMPLE3.JPG, is located. This is as good a place as any to put your new file – just click on OK.





Note that Graphic Workshop can be configured not to prompt you for a destination directory if you like – in this case, it will assume that you want it to write processed files to the same directory as they're read from.





A progress window will appear momentarily – this keeps track of the names of files being processed when you're working with a lot of them. You can ignore it for now.





The Graphic Workshop status display at the bottom of its main window will show you a moving bar to indicate that the source image is being read, and then that the new BMP version is being written. When the operation is complete, you'll see a new file in your browser window called EXAMPLE3.BMP. This file can be opened by Windows Paint.








Other Processes





Graphic Workshop offers a number of other useful batch processes. For example, you can "transform" images. Transformation includes rotating a picture and mirroring it horizontally or vertically.





To transform EXAMPLE3.JPG, do the following:





1. Click once on EXAMPLE3.JPG to select it.





2. Click on the Transform button or select Transform from the Image menu. This is what the Transform button looks like:
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3. A dialog will appear. Select the transformation you wish to apply to EXAMPLE3.JPG – the 90 º rotation is a good choice to see how this works. Click on OK.





4. Select the destination format you wish to save your rotated image in. While any of a number of formats will do, select BMP for this example.





5. Select the destination directory for your new file. As you want to save the transformed image in the same directory as its source file, just click on OK.





Graphic Workshop will read your source image and write a transformed version of it to a new file. For all processes except conversion, Graphic Workshop likes to prepend a letter and an underscore character to processed file names to make sure that your new files don't overwrite your old files if you happen to select a destination format that's the same as your source format. The prefix for transformation is "T_" – the new file will be called T_EXAMPLE3.JPG.





You can configure Graphic Workshop not to add prefixes to processed file names, but be careful if you do so. It's easy to overwrite your source files accidentally  if you're batch processing lots of images and you don't keep track of which formats they're all in.





To see what Graphic Workshop did when it transformed EXAMPLE3.JPG, double click on the file T_EXAMPLE3.JPG to open it in View mode.





Note that the Transform function can only rotate files in 90-degree increments. If you'd like to rotate an image by a smaller amount, you'll need to use the Transform function in View mode, to be discussed later in this document. Rotation by smaller amounts – what's called "free" rotation – must be handled interactively because it leaves triangular areas between the edges of your rotated graphic and the rectangle in which it resides. The interactive transformation function allows you to select the colour to be used to fill these areas.





You can make graphics larger or smaller using the Scale function. The is referred to as "resizing" or "resampling" by some graphic applications.
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When you scale a graphic up, its pixels are in a sense moved apart and additional pixels are generated to fill the gaps between them. This can be handled in one of two ways. The simplest one – and by far the fastest – is to duplicate the existing pixels in the source image to fill the gaps. This can result in a final graphic which looks like a Roman mosaic, with a small number of large, visible pixels.





The second approach to scaling a picture up is to generate the required new pixels as a smooth transition between the existing pixels. This is called "interpolation" or "anti-aliased scaling." The results are much more attractive, but they take longer to achieve. 





Having said this, for graphics of moderate size and a fast computer, the difference in processing time will be significantly less than that required to read the foregoing paragraphs and realize that a difference exists at all.





In scaling a graphic down, some of the pixels in the source image have to be removed, and hence some of the detail will be lost. As with scaling up, this can be handled in one of two ways. Graphic Workshop can just remove the required pixels and send them into the eleventh dimension, or it can average all the pixels to be removed to generate the new pixels for the scaled-down image. The first case is faster, while the second one typically looks a lot better. Averaging the source pixels is called "integration", or, once again, "anti-aliased scaling."





The scaling function of Graphic Workshop behaves just like the Transform function. Select one or more graphics to scale and click on the Scale button or select Scale from the Image menu. The Scaling dialog offers an initially daunting range of options. Here's a quick overview of them – this function, like everything Graphic Workshop knows how to do – is discussed in much greater detail elsewhere in the documentation.





You can scale either by factor or by size. In scaling by factor, you might tell Graphic Workshop "make this picture twice its current size" by telling it to scale to 200 percent. In scaling by size, you might tell Graphic Workshop "I want my final picture to be 1280 by 1024 pixels." Graphic Workshop would figure out the actual percentages for you.





By default, scaling by factor is constant, that is, Graphic Workshop will scale both dimensions by the same percentage. If you have need to apply different horizontal and vertical scaling factors to an image, select the Anamorphic option in the Scaling dialog.





Scaling is also available as an interactive filter in the Graphic Workshop view mode. You can do quite a lot more with the Graphic Workshop Scaling function – you'll probably want to check out the complete documentation for it to really make it do its stuff.








Getting File Information





If you select a file in one of Graphic Workshop's browser windows and click on the Get Info button or select Get Info from the Image menu, a dialog will appear to tell you about the file. The important things you'll probably want to know are the pixel dimensions and the colour depth of the image in your file. This can be handy, for example, if you want to ascertain whether a particular graphic will fit on your web page without having to be scaled down.
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Some image processed don't work on files having fewer than 24 bits of colour, or 16,777,216 colours, as the Get Info dialog expresses it. The Get Info function will help you ascertain the relevant information about an image file before you try to convert or process it.





The introduction to graphics, found elsewhere in the documentation, will outline the characteristics of graphic files you'll probably need to keep in mind as you work become more proficient in working with Graphic Workshop.








Deleting and Renaming Files





You can delete one or more files in a Graphic Workshop browser window by selecting each file to be deleted and then clicking on the Delete button, or selecting Delete from the file menu. A dialog will appear prompting you to confirm that you want to delete the selected files. Note that it will tell you how many files it proposes to delete. Make sure this number corresponds with the files you think you selected – it's not uncommon in working with large directories of files to have selected a few earlier and subsequently forgotten about them.
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The Delete function can delete files in two ways:





1. It can remove them from your hard drive. Files thus deleted are gone for good, and cannot be recovered. 





2. It can send them to the Windows recycle bin. If you send files to the recycle bin and subsequently change your mind about their general unworthiness to continue existing, you can drag them back into existence. The catch in using the recycle bin is that most graphic files are uncommonly large, and it's not at all difficult to tie up a lot of hard drive space by sending them to the recycle bin if you don't keep an eye on them. If you have the Recycle Bin option in the file deletion dialog enabled, make sure you empty your recycle bin frequently.





You might want to delete T_EXAMPLE3.JPG, the transformed version of EXAMPLE3.JPG, to see how the Delete function works.





The Rename function works like the Delete function – it will rename all the selected files in a browser window. It will prompt you for a new name for each selected file. If you attempt to enter a new name which contains characters that are not legal in file names, it will omit the errant characters.
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Note that you cannot use the Rename function to change the file extension of an image file. If you were to attempt to rename EXAMPLE3.JPG to FlyingPurpleWombats.BMP, the renamed file would in fact be called FlyingPurpleWombats.JPG.





It's also worth noting that space characters are legal in Windows file names. As such, you could rename a file to Flying Purple Wombats.JPG.








Displaying a Slide Show





Graphic Workshop will display selected graphics in a continuous slide show. While hardly as sophisticated as a presentation package, the slide show function is an easy way to view a collection of images while you sit back in your chair and test the tensile strength of its springs.





To use the slide show function, select several images in a browser window and click on the View button, the one with the sunglasses. A small menu will appear. Click on the slide option. You can also select Slideshow from the Image menu. The Slide Show Options dialog will appear.
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You can configure Graphic Workshop's slide show to display each image for whatever duration you like. You can configure the background colour and the font Graphic Workshop will use to display the name of each file in the slide show – assuming that you want the file names displayed at all. You can also enable the Zoom option, which will automatically scale files too large to fit on your screen down to size. Note that zooming only scales the image being displayed – it will not actually change anything in your source graphic files.





Click on OK to start the slide show.





Once a slide show has begun, you can interrupt it by hitting the Esc key or by clicking with the right button of your mouse. You can also have it proceed immediately to the next slide by hitting Enter.








Printing Graphics





You can print one or more graphic files by selecting them in a browser window and clicking on the Print button, or by selecting Print from the Image menu. Graphic Workshop's print function has a lot of options – you'll do well to ignore them all for the moment. It comes configured to print correctly with its default settings. You might have to select the correct printer to print with by clicking on the Setup button in the Print Options dialog. The title bar of the Print Options dialog will display the name of the currently selected printer.
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Note that as with the slide show, you can configure Graphic Workshop's print function to print the names of files in your choice of fonts, and to paint the background with any colour you like. Keep in mind, however, that if you select a fairly dark background your printer will get through a lot of toner or ink.








Manipulating Graphics in View Mode





The graphic filters in View mode offer a way to manipulate graphics interactively, such that you can see the result of a process in real time and change your mind if you don't like the look of what you've done.





To process an image with the View mode filters:





1. Double click on the image file name in a browser window to open it in View mode.





2. Select Filters from the Picture menu.





3. Apply a filter to the image – we'll get to this in more detail in a moment.





4. At such time as you like the results of the filter, select Save As from the Picture menu to save your modified graphic back to disk as a new file.





The Image Filter dialog in View mode offers an extensive library of image processes – it's beyond the scope of this introduction to get into them all in detail. You might want to experiment with a few of the more interesting ones. For this discussion, open EXAMPLE3.JPG in View mode and select the Filter option from the Picture menu.





It's worth noting that most of the interesting filters are only available for use with 24-bit images – which EXAMPLE3.JPG is.





In applying a filter to an image, you can use the Preview button to see what the filtered graphic will look like before you actually filter it. Once you click on OK, your graphic will be processed and the Filter dialog will close. Should the results prove unexpectedly ugly, you can restore the unfiltered version of your graphic by selecting Undo from the Picture menu. Finally, if you really succeed in turning your graphic into a neo-impressionist depiction of the torque converter for a 1964 Buick transmission, you can abandon it by exiting View mode without saving the changed image back to disk, and your source graphic file will be untouched.





Note that the Image Filter preview window can be panned around your graphic using the scroll bars provided. Clicking on the button at the union of the two scroll bars will return the preview window to the center of your picture.





You might want to experiment with some of these filters:





Average: This is a softening filter – use it carefully, as it tends to make people look about ten pounds heavier than they really are.





Colour and Intensity: This filter allows you to adjust the balance of colour in an image – as subtly or as radically as you like.





Emboss: This filter will turn any graphic into a paper sculpture – it's a slick effect, but easily overused.





Obscure: This filter will render an image in a small number of large pixels, making otherwise blameless subjects appear as if their identity is being protected by the eleven-o'clock news.





Sharpen: This filter will enhance the details of an image.





Water drops: This filter will make any picture look like it's being viewed through pebbled glass.





Waves: This filter will add waves to otherwise motionless images. Do not apply this filter to faces if you've had a few – the results can be genuinely creepy.





A digital camera and the Graphic Workshop image filter functions can provide hours of entertainment if you've successfully shaved your poodle bald and can't think of anything more interesting to do.








Don't Stop Reading Now





This introduction has highlighted some of the more popular features of Graphic Workshop – of necessity, it has omitted more than it's covered. There are additional introductory documents included with the Graphic Workshop software, and an exhaustive discussion of its features in detail. While the best way to learn to use the full power of Graphic Workshop is to play with it, keep in mind that there's plenty of help available, both in the documentation itself and in the Help functions of the software, should you find yourself lost.








