
Commands and tools
Click a letter to search for a term

To display help for a command while working in Visio, highlight the command, and then 
press the F1 key. You can also choose the Help button in most dialog boxes.
1, 2, 3... Pages and Backgrounds
1, 2, 3, 4 Files
1, 2, 3... More Windows

A
About Visio
Action
Actions
Activate
Actual Size
Add-ons
Add To Group
Align Shapes
Arc tool
Arrange Icons
Auto Arrange

B
Background
Behavior
Bring Forward
Bring To Front

C
Cascade
Center Drawing
Change Row Type
Change Source dialog box
Clear
Close
Close (stencil)
Color Palette
Combine
Connect Shapes
Connection point tool
Connection Points
Connector tool
Convert <OLE object>
Convert To Group
Copy, Copy Drawing
Corners
Crop tool
Custom Properties
Cut



D
Define Styles
Delete
Delete Row
Delete Section
Distribute Shapes
Double-Click
Drawing Page submenu
Duplicate

E
Edit Color dialog box
Edit Icon
Edit Master
Edit <OLE object>
Edit Text
Ellipse tool
Exit

F
Field
File Paths dialog box
Fill
Find
First Tile
Flip Horizontal
Flip Vertical
Float
Font
Foreground
Format painter tool
Formulas
Fragment
Freeform tool
Function

G
Go To submenu
Grid
Group
Grouping submenu
Guides

I
Icon pencil tool
Icons And Names
Icons Only
Intersect

L
Lasso tool
Last Tile
Last Zoom



Layer
Layer Properties
Left Color box
Line
Line tool
Links
Lotus Notes Field
Lotus SmartSuite

M
Microsoft Office

N
Name
Names Only
New
New Master
New Window
Next Page
Next Tile
Novell PerfectOffice

O
Object (Edit)
Object (Insert)
Open
Open Group
Open In Visio
Operations submenu
Options
Organization Chart Wizard

P
Page (Edit)
Page (Insert)
Page Breaks
Page Layout Wizard
Page Setup
Page Width
Paint bucket tool
Paragraph
Paste
Paste Special
Pencil tool
Picture
Pointer tool
Previous Page
Previous Tile
Print
Print Preview
Project Timeline Wizard
Properties (Edit menu)
Properties (File menu)
Properties (Master menu)



Properties Reporter Wizard
Protect Document
Protection

Q
Quick Tour

R
Rectangle tool
Redo
Remove From Group
Reorder
Repeat
Replace
Reverse Ends
Right Color box
Rotate Left
Rotate Right
Rotation tool
Row
Row After
Ruler & Grid
Rulers
Run Add-on submenu

S
Save
Save As
Save Workspace
Section
Sections
Select All
Select dialog box
Select Special
Selection net tool
Send
Send Backward
Send To Back
Shadow
Shape Help
Shape Report
Show Drawing Page
Show Master Shapes
Show ShapeSheet
Single Tile
Size & Position
Size & Scale
SmartShape Wizard
Snap & Glue
Special
Spelling
Spelling Options dialog box
Stamp tool
Status Bar



Stencil Report Wizard
Stencils
Style
Subtract
Switch Sides

T
Tabs
Text Block
Text block tool
Text tool
Tile
Toolbars

U
Undo
Ungroup
Union
Unprotect Document
Update Alignment Box
Update Icon

V
Values

W
Whole Page

Z
Zoom (Custom)
Zoom In
Zoom Out
Zoom submenu



Submenu topics



Drawing Page submenu

Edit menu, drawing window
Includes commands that set up pages in the diagram:
Properties
Size & Scale
Delete
Reorder



Go To submenu

Edit menu, drawing and print preview windows
Includes commands for viewing other pages or backgrounds or a background's foreground:
Foreground
Background
1, 2, 3... Pages and Backgrounds
Page



Grouping submenu

Shape menu, drawing window
Includes commands for grouping shapes:
Group
Ungroup
Add To Group
Remove From Group
Convert To Group



Operations submenu

Shape menu, drawing window
Includes commands for combining two or more shapes to create one shape:
Union
Combine
Fragment
Intersect
Subtract



Run Add-on submenu

Tools menu
Displays a submenu from which you can run Wizards and special programs called add-ons. 
Add-ons perform tasks and other operations in Visio. Some add-ons perform tasks 
immediately. Others run behind the scenes, giving you more options with Visio. For details 
about running a specific add-on, see the online Help topic for the add-on.



Zoom submenu

View menu, drawing window
Includes commands for changing the magnification of the view. To choose a different zoom 
percentage, choose the Custom command.



1, 2, 3, 4 Files

File menu
Opens one of the last four files you closed. Choose the number that corresponds to the file 
you want to open. Choosing a numbered file from the File menu is a convenient alternative 
to the Open command, because Visio opens the file without displaying the Open box.

See also
Opening a stencil
Opening a template to modify or copy it
Opening an existing drawing file



1, 2, 3... More Windows

Window menu
Opens the drawing, stencil (if it's open as a copy or original), or ShapeSheet window that 
corresponds to a number and brings it to the front. More Windows displays a list from which 
you can select a window. The More Windows command appears on the menu only if there 
are more than nine windows open.

See also
Arranging Visio windows



1, 2, 3... Pages and Backgrounds

Edit menu, Go To submenu, drawing and print preview windows
Displays the selected page or background in the drawing window.

See also
Creating a background page
Creating a new page
Displaying pages
Rearranging foreground pages



Action

Edit menu, ShapeSheet window
Assigns an action to the shape that appears on the shape's shortcut (right-click) menu.

DIALOG BOX OPTIONS
Properties. Specifies the menu command name, status bar prompt, and online Help topic 
for the shortcut menu command.

Menu. Specifies the menu command to add to the shape's shortcut menu.
Prompt. Adds a status bar prompt for the shortcut menu command.
Help. When the user selects this menu command on the shortcut menu, then presses 
F1, the help topic for the command appears. The syntax is:
FILENAME.HLP!keyword or FILENAME.HLP!#Number
where filename is the Windows help file, keyword is the index term associated with 
the help topic, and number is a numeric ID which is referenced in the MAP section of 
the help project file (HPJ). For information on developing Microsoft Windows online 
Help, see the Microsoft Software Development Kit (SDK) documentation.

Action. Specifies the action performed by the shortcut menu command.
Edit Shape's Text. Opens the shape's text block.
Open Group In New Window. Opens a group in the group window.
Show ShapeSheet. Opens the ShapeSheet window.
Custom. Performs custom action. You enter the formula for this action directly in the 
Action section of the ShapeSheet.
OLE Verb. Activates OLE options, such as Edit, when an OLE object is double-clicked.
Run Add-on. Activates the add-on selected in the add-on list.
Display Help. Opens an online Help topic. Uses the same syntax as described in the 
Special box.
Go To Page. Displays a particular drawing page.
Open In New Window. Displays a particular drawing page in a new window.

See also
Displaying a ShapeSheet
Special



 Actions

Shape menu, drawing window
Displays a submenu containing actions you can perform with the shape. This menu changes 
depending on the shape you select; some shapes have no actions. For example, this menu 
might include a command to change an S-connector to an L-connector, or vice versa.
The commands listed under Action are also available on a shape's shortcut right-click menu.

See also
Adding and deleting sections
Getting quick access to common commands



Activate

Right-click a docked stencil's title bar
Switches to the stencil, displaying the stencil's masters.

See also
Arranging master shapes in a stencil
Arranging stencils
Arranging Visio windows



Actual Size (100%) (Ctrl+I)

View menu, drawing and print preview windows
Displays the page at approximately its actual printed size. If a shape is selected in the 
drawing window, the view is centered on the shape. If nothing is selected, the view is 
centered on whatever was in the center of the previous view.
You can also choose 100% from the Zoom box on the toolbar. Use ToolTips to identify the 
button.

See also
Zoom command
Zooming in and out of a drawing



About Visio

Help menu
Identifies the version of Visio you are using and displays copyright information. 



Add To Group

Shape menu, Grouping submenu, drawing window
Adds the selected shape(s) to the selected group without affecting the group in other ways. 
The added shape remains in its current location, and Visio repositions the group's selection 
rectangle to encompass it. The shape keeps its own ShapeSheets, and Visio updates the 
group's ShapeSheet to reflect the added shape.
Select the group to which you want to add the shape(s) and the shape(s) you want to add. 
You can add a group to another group.

Bitmaps
A metafile can contain a bitmap or consist solely of a bitmap. Visio cannot convert bitmaps 
into shapes. However, a metafile that consists of a single bitmap sometimes stores the 
bitmap in separate segments. In that case, the Add To Group command converts each 
segment of the metafile into an individual bitmap object.

Linked objects
If an object from another program is linked, adding the object to a group breaks the object's 
link to its original file, so edits you make to the object in the original program will no longer 
be reflected in the copy in Visio.

See also
Adding and removing shapes in groups
Convert To Group
Converting an object to Visio shapes
Editing and formatting a group
Group
Grouping and ungrouping shapes
Remove From Group
Ungroup
Updating a group's selection rectangle



Align Shapes (F8)

Tools menu, drawing window
Aligns selected shapes with the first shape you select (if you dragged to select shapes, 
shapes are aligned with the shape at the front of the stacking order).
You can also use the Align Shapes button to display alignment options. Use ToolTips to 
identify the button.

Click to display information about the dialog box.

See also
Aligning shapes to guides
Aligning shapes to other shapes
Distributing shapes



Determines vertical alignment.



Aligns the tops of shapes.



Aligns shapes along their vertical centers.



Aligns the bottoms of shapes.



No vertical alignment (default).



Determines horizontal alignment.



Aligns the left sides of shapes.



Aligns shapes along their horizontal centers.



Aligns the right sides of shapes.



No horizontal alignment (default).



If checked, creates a guide and glues selected shapes to the guide to retain the alignment. 
When you move the guide, the shapes move with it.



 Arc tool (Ctrl+4)

Drawing tool menu
Use the arc tool to draw elliptical quarter-arc segments. A single arc is a 1-D shape when you
first draw it. Adding other arc and line segments creates a 2-D shape.
The way you drag the mouse determines whether the arc has a horizontal axis (the ending 
point is right or left of the beginning point) or vertical axis (the ending point is above or 
below the beginning point). If the ending point is exactly horizontal or vertical to the 
beginning point, the arc becomes a straight line.
You can use the arc tool, line tool, pencil tool, or freeform tool to draw shapes of contiguous 
segments. 
Tip: To constrain the shape of the arc when using the pencil tool, hold down the Shift key as 
you draw arcs.

See also
Drawing freeform shapes
Drawing lines and arcs
Drawing shapes with several segments



Arrange Icons

Window menu, stencil window

Note: This command is available only when you have an original stencil open.
Arranges master shape icons in the stencil window into rows. The stencil window must be 
active.

See also
Auto Arrange
Creating a master shape from a shape in a drawing
Creating a master shape from scratch
Displaying and arranging master shape icons
New Master



Auto Arrange

View menu, stencil window

Note: This command is available only when you have an original stencil open.

When Auto Arrange is checked, master shape icons are automatically rearranged in the 
stencil window after the window is resized or when icons are added to or deleted from a 
stencil. The stencil window must be active.

See also
Arrange Icons
Creating a master shape from scratch
Creating a master shape icon
Deleting a master shape from a stencil



Behavior

Format menu, drawing and ShapeSheet windows
Opens a dialog box where you can specify options for shape behavior. You can set options for
whether a shape behaves as a 1-D or a 2-D shape, the way a shape is displayed, and how a 
shape or other object resizes in a group.

Click to display information about the dialog box.

See also
Changing 1-D and 2-D behavior
Custom Properties
Setting a group's sizing behavior



Makes the selected shape a 1-D shape. 1-D shapes behave like a line. 1-D shapes have 
endpoints and are often used to connect two or more 2-D shapes.



Makes the selected shape a 2-D shape. 2-D shapes behave like a box. 2-D shapes have eight
selection handles; you can drag a corner selection handle to size the shape proportionally.



The selected shape sizes with the group it belongs to. This is typical behavior for shapes in a
group.



The selected shape inherits the setting specified for the group.



The selected shape keeps its original size as you size a group that includes the shape. For 
example, if you select a group and specify Reposition Only, the shapes that use the group's 
setting will only reposition when you size the group.



Identifies whether a shape acts like a 1-D or a 2-D shape. By default the interaction style for 
a single line or arc is Line (1-D); any other shape's interaction style is Box (2-D). Changing a 
shape's interaction style changes its behavior, not the shape itself.



Controls whether the shape shows selection handles, control handles, or a selection 
rectangle. Important: If you uncheck all of these options, you won't be able to tell when the
shape is selected.



Controls how a shape in a group resizes when the group is resized.



Controls whether the selected shape prints.



Bring Forward 

Shape menu, drawing window
Moves selected shapes forward one position in the stacking order. If multiple shapes are 
selected, they all move closer to the front and keep their original stacking order in relation to
each other.

See also
Bring To Front
Changing the stacking order of shapes
Layer
Layer Properties
Send Backward
Send To Back



Bring To Front (Ctrl+F)

Shape menu, drawing window
Moves selected shapes to the front of the stacking order for shapes on a page. If multiple 
shapes are selected, they all move to the front and keep their original stacking order in 
relation to each other.

See also
Bring Forward
Changing the stacking order of shapes
Layer
Layer Properties
Send Backward
Send To Back



Cascade (Alt+F7)

Window menu
Arranges open windows so the title bar of each window is visible. Stencil windows (that are 
open as copies or originals or that are floating) stack on the left; drawing and ShapeSheet 
windows stack on the right. To activate a window and bring it to the front, click its title bar.

See also
1, 2, 3, 4 More Windows
Arranging Visio windows
Tile



Center Drawing

Tools menu, drawing window
Centers the entire drawing on the page, regardless of whether shapes are selected.

See also
Centering a drawing on the page
Setting margins



Change Row Type

Edit menu, ShapeSheet window
Opens a dialog box where you can change the type of a selected row in a Geometry section 
of a ShapeSheet. Changing the row type changes the type of the segment the row refers to. 
If you select a Controls cell, this command toggles between displaying and hiding the control
handle ToolTips.

DIALOG BOX OPTIONS
Row Type. Displays the current type for the selected row. Choose a different option to 
change the row type.

LineTo. Changes the segment into a line. The endpoints are defined by the X and Y 
cells in the Geometry section row.
ArcTo. Changes the segment into a circular arc. The endpoints are defined by the X 
and Y cells, and the bow is defined by the A cell in the Geometry section row.
EllipticalArcTo. Changes the segment into an elliptical arc. The endpoints are defined
by the X and Y cells, the A and B cells indicate the coordinates of the segment's control
point, the C cell specifies an angle between 0 and 180 degrees for orientation, and the 
D cell specifies the ratio of the major to minor axis, which is usually one or greater 
(must be greater than zero).
SplineStart. Changes the segment into a spline start. The X and Y cells define the 
spline's second control point. (The spline's first control point is defined by the X and Y 
cells in the row preceding the SplineStart row). The A, B, and C cells indicate the 
spline's first, second, and last knot, respectively. The D cell indicates the degree of the 
spline, which controls the curvature of the spline with respect to its control polygon.
SplineKnot. Changes the segment into a spline knot. The X and Y cells define the 
control point for the row. The A cell indicates a spline knot.

See also
Adding and deleting sections
Row
Row After



Change Source dialog box

Links dialog box
Choose this option in the Links dialog box to change the reference for a linked file. For 
example, you can update a link if the filename or path has changed.

DIALOG BOX OPTIONS
Source. Determines the file to which you want to link the object. You can choose an item in 
the Files Of Type and Folder lists to locate the file. You can change a linked object's file 
reference to any other file of the same format.
Directories. Displays the current folder.
List Files Of Type. Displays files of the same file format as the original linked file.
Drives. Displays the current drive.

See also
Linking or embedding an object into a Visio drawing
Viewing and updating links



Clear (Del key)

Edit menu (not in print preview window)
Deletes selected shapes or text. To restore a deleted item, use the Undo command. You 
cannot use the Paste command to restore a shape that has been deleted using the Clear 
command.

See also
Cut
Deleting text
Paste



Close

File menu and Windows system menu
Closes the file in the active window. If you changed a Visio file but did not save it before 
choosing the Close command on the File menu, Visio asks if you want to save the changes. 
Choose Yes to save the changes, No to close the file without saving changes, or Cancel to 
keep the file open and cancel the Close command. If you choose Yes and have not saved the
file, Visio opens the Save As dialog box so you can save the file.
You can also click the Close button on the Print Preview toolbar.

See also
Exit
Quitting Visio



Close (stencil)

Right-click a docked stencil's title bar
Closes the stencil. If the stencil is floating, you can click  to close it.

See also
Arranging master shapes in a stencil
Arranging stencils
Arranging Visio windows



Color Palette

Tools menu, drawing window
Opens a dialog box that displays the current color palette. You can customize the color 
palette for the active drawing file or choose a different color palette to use for the file.
Visio uses solid colors for lines. For fills that don't have a pattern (item 0 or 1 in the pattern 
lists in the Fill dialog box), Visio uses the dithered version of the foreground color you specify.
For patterned fills (patterns 2 through 24), Visio uses the solid color for the foreground and 
background colors you specify.
You can edit the colors in a color palette. If shapes in the file use a color that you edit, the 
shapes change to the new color. The colors you define appear in the color lists in the Fill, 
Font, and Line dialog boxes.

DIALOG BOX OPTIONS
Color Solid. Displays the 24 colors in the drawing file's color palette. The left side of each 
color bar shows the color when dithered; the right side shows the closest solid color. (If you 
are running in 16 colors, you will see dithered color. If you're running in 256 colors or higher, 
you may not see any dithered colors.)
Copy Colors From. Displays a list of open template and drawing files and predefined color 
palettes. By choosing from the list, you can copy a new color palette to the active drawing 
file.
Edit. Choose this button to edit the color selected in the Color Palette. Visio opens the Edit 
Color dialog box so you can edit the color.
Apply. Choose this button to apply color changes without closing the dialog box. Visio 
applies the new colors.

See also
Choosing a color palette



Combine

Shape menu, Operations submenu, drawing window
Creates a new shape from selected shapes. If the selected shapes overlap, Visio cuts out, or 
discards, the area where they overlap, which creates holes in the new shape. Use this 
command to create picture frames, windows, and other shapes that you want to see 
through.
The combined shape inherits the formatting and text of the first shape you select when you 
combine the shapes. The combined shape also has a single ShapeSheet, which contains the 
Geometry rows from each component shape's ShapeSheet.

See also
Combining shapes
Fragment
Group
Intersect
Subtract
Union



Connect Shapes (Ctrl+K)

Tools menu, drawing window
Connects selected 2-D shapes (or other objects) in the order you select them. The shapes 
are connected with an instance of the connector master shape selected in the stencil. If no 
master shape is selected, Visio creates an instance of the Universal connector to connect the
shapes.
You can also use the Connect Shapes button. Use ToolTips to identify the button.

See also
Connecting a series of shapes automatically
Connection Points
Snap & Glue



 Connection point tool (Ctrl+8)

Connection tool menu
Use the connection point tool to add, move, or delete connection points. 
To add a new connection point, select the shape, hold down the Ctrl key (the pointer should 
display an X above it), and click the shape where you want to add the connection point.
To select a connection point, position the mouse pointer over the connection point (the 
pointer is a four-headed arrow), and then click. The connection point turns magenta when it 
is selected.
To delete a connection point, select it, then press the Delete key.
To move a connection point, select the connection point, and then drag it to a new location. 
The connection point turns magenta when it is selected.

Display options
Connection points appear as blue Xs on shapes. To display connection points, make sure 
Connection Points is checked on the View menu.

See also
Creating and deleting connection points
Displaying connection points
Using the connector tool to connect two shapes



Connection Points

View menu, drawing window
Toggles the display of connection points on and off. When this command is checked, Visio 
displays connection points as small blue Xs. When you select a connection point, it turns 
magenta.
Display connection points to verify their locations and to see where you can glue shapes 
together.

See also
Creating and deleting connection points
Displaying connection points
Snap & Glue



 Connector tool

Connector tool menu
Use the connector tool to automatically connect two shapes. To connect shapes, select the 
connector tool, and then drag 2-D shapes from the stencil to the drawing page. The shapes 
are connected with a Universal connector.
To connect shapes manually, drag the shapes you want to connect to the drawing page, 
select the connector tool, point to one of the shape's connection points, and then drag to 
one of the other shape's connection points.
When you've successfully connected two shapes, the endpoints of the connector turn red 
when the connection is selected.

See also
Creating and deleting connection points
Displaying connection points
Using the connector tool to connect two shapes



Convert To Group

Shape menu, Grouping submenu, drawing window
Changes a selected Windows metafile (.WMF) or an object from another program into a group 
so you can edit it. If you want to separate the group into individual shapes, use the Ungroup 
command on the Shape menu.

Bitmaps
A metafile can either contain a bitmap or consist solely of a bitmap. Visio cannot convert 
bitmaps into shapes. However, a metafile that consists of a single bitmap sometimes stores 
the bitmap in separate segments. In that case, the Convert To Group command converts 
each segment of the metafile into an individual bitmap object.

Linked objects
If an object from another program is linked, converting the object to a group breaks the 
object's link to its original file so you can no longer edit the object in its original program.

See also
Add To Group
Converting an object to Visio shapes
Group
Remove From Group



Convert <OLE object>, <OLE object> Convert

Edit menu, Object submenu, drawing window
Converts an OLE object to another format. Use this command to display the OLE object as an
icon in a drawing. The command appears on a submenu when you choose the Object 
command from the Edit menu.

DIALOG BOX OPTIONS
Current Type. Specifies the current type of embedded object.
Convert To. Displays the Object Type list.
Activate As. Displays the Treat As list.
Result. Displays a message that describes the results of converting the object.
Display As Icon. Displays the OLE object as an icon in a drawing.
Change Icon. Opens a dialog box where you can specify a custom icon and change the icon
label. (This option is available only when Display As Icon is checked.)

See also
Converting an object to Visio shapes
Edit <OLE Object>
Linking or embedding an object into a Visio drawing



Copy, Copy Drawing (Ctrl+C)

Edit menu (not in print preview window)
Places a copy of selected shapes or text onto the Clipboard. When the drawing window is 
active and nothing in it is selected, the Copy command changes to Copy Drawing. Copy 
Drawing places a copy of the entire drawing on the Clipboard.
The information remains on the Clipboard until you use the Copy or Cut command again. Use
the Paste command to paste as many copies as you want from the Clipboard. If both 
programs support OLE, pasting an object from another program embeds it.
You can also use the Copy button. (If you are using an alternate toolbar, you may not have 
this button. Use ToolTips to identify the button.)

See also
Copying shapes in the current drawing
Duplicate



Corners

Format menu, drawing and ShapeSheet windows
Applies formats to corners. You can choose from options for rounded corners or enter a value
for a custom corner.
You can also use the Corner Roundings button. Use ToolTips to identify the button.
Note: If you use the Union, Combine, Fragment, Intersect, or Subtract command, round 
corners are replaced by arcs.

DIALOG BOX OPTIONS
Round Corners. Displays icons from which you can choose a corner roundness.
Rounding. Displays a numeric value for each corner option. You can also enter a value.
Apply. Applies formatting without closing the Corners dialog box.

See also
Applying styles from the Style dialog box
Changing the line color, weight, and pattern
Line



 Crop tool 

Rotation and crop tool menu
Use the crop tool to size the border that encloses an object from another program or to 
move the object within the border. The object itself is not sized, but the amount of the object
that is visible is reduced or enlarged. Drag the object's selection handles to crop, or drag 
inside the border to pan the object.

See also
Editing an object from another program
Scaling, cropping, or panning an object



Custom Properties

Shape menu, drawing and ShapeSheet windows
Opens a box in which you can edit a shape's ShapeSheet custom properties. The contents of
this box change depending on the shape you select and the custom properties set for that 
shape in its ShapeSheet.
This command is available only when a shape's ShapeSheet contains custom properties.

See also
Adding and deleting sections
Associating data with shapes
Displaying a ShapeSheet
Performing calculations on shape properties



Cut (Ctrl+X)

Edit menu (not in print preview window)
Deletes selected shapes or text and places them on the Clipboard. The items remain on the 
Clipboard until you use the Cut or Copy command again.
You can also use the Cut button. (If you are using an alternate toolbar, you may not have this
button. Use ToolTips to identify the button.)

See also
Clear
Deleting shapes



Define Styles

Format menu, drawing window
Opens a dialog box where you can create, edit, rename, and delete styles. Before using the 
Define Styles command, you can select one or more shapes and apply the newly created or 
edited style to the shapes.

Click to display information about the dialog box.

Tip: If you apply local formatting to selected characters in a shape's text block after 
applying a style to the shape, the link between the shape's text and the style is broken. The 
shape will still respond to changes in the style's definition of line and fill attributes.

See also
Creating a style
Editing a style
Fill
Font
Line



Displays a list of existing styles, as well as New style. If a shape is selected, the style for that
shape is highlighted in the list.



Displays the style that the style displayed in the Style box is based on.



Indicates whether the style includes attributes for lines, fills, or text.



Includes buttons that open the Font, Line, and Fill dialog boxes in which you define attributes
for the style. If a style is selected in the Style box, the dialog boxes display the current 
style's attributes; if no style is selected, they display default attributes or attributes for the 
style in the Based On box. Choosing OK in the Line, Fill, or Text dialog box returns you to the 
Define Styles dialog box.



If checked, prevents the style's attributes from replacing formatting you applied directly to 
the shape. Uncheck Preserve Local Formatting On Apply if you want the style to replace all 
previous formatting.



Applies the style to selected shapes and closes the dialog box. To apply changes without 
closing the dialog box, use the Change button.



Discards only those changes specified the last time you chose the Apply, Add, Change, or 
Delete button.



When you finish defining a new style or revising a style, Visio adds a new style to the style 
lists or changes a style without closing the dialog box so you can continue creating and 
editing styles. The style is not applied to the selected shape until you use the Apply button.



Deletes the style selected in the Style list. A shape previously formatted with the deleted 
style becomes linked to and formatted with the Based On style, and may change in 
appearance as a result. Any local formatting that had been applied to the shape is 
preserved.



Opens the Rename dialog box, which displays the name of the style selected in the Style list.
If you previously applied the style to shapes, Visio updates the link to the renamed style.



Delete

Edit menu, Drawing Page submenu, drawing window
Lists the pages in a drawing file so you can choose the pages to delete. You can restore a 
page you delete by using the Undo command.

DIALOG BOX OPTIONS
Select Pages. Lists the pages in the drawing file.
Update Page Names. Check this option to renumber the remaining pages. This option 
applies only to pages that use default names.

See also
Deleting a page
Layer Properties
Page
Ruler & Grid



Delete Row

Edit menu, ShapeSheet window
Deletes the selected ShapeSheet row. You can restore a row you've deleted by using the 
Undo command. Deleting a row in a ShapeSheet may change the shape's behavior.

See also
Adding and deleting rows
Row
Row After



Delete Section

Edit menu, ShapeSheet window
Deletes the selected ShapeSheet section. You can restore a section you delete by using the 
Undo command. Deleting a section can change a shape's behavior.

See also
Adding and deleting sections
Section



Distribute Shapes

Tools menu, drawing window
Places three or more selected shapes at regular intervals on the drawing page. Choose from 
horizontal and vertical distribution options. The order in which you select shapes is not 
relevant when distributing shapes.
You can also use the Distribute Shapes button to display distribution options. Use ToolTips to 
identify the button.

Click to display information about the dialog box.

See also
Aligning shapes to rulers
Distributing shapes
Selecting shapes



Displays options for distributing shapes horizontally.



Distributes shapes horizontally so there is a uniform space between shapes.



Distributes shapes so their left edges are uniformly spaced.



Distributes shapes horizontally so their centers are uniformly spaced.



Displays options for distributing shapes vertically.



Distributes shapes so their right edges are uniformly spaced.



Distributes shapes vertically so there is a uniform space between shapes.



Distributes shapes so their top edges are uniformly spaced.



Distributes shapes vertically so their centers are uniformly spaced.



Distributes shapes so their bottom edges are uniformly spaced.



If checked, creates guides to retain the distribution of the shapes. Select and move the 
outermost guides to move the shapes without changing their distribution.



Double-Click

Format menu, drawing and ShapeSheet windows
Opens a dialog box where you can assign an action to be performed when a shape is double-
clicked.

Click to display information about the dialog box.

See also
Displaying a ShapeSheet
Special
Specifying a shape's double-click behavior



Activates the default action for the shape.



Takes no action.



Opens the shape's text block.



Opens a group in the group window.



Opens the ShapeSheet window.



Activates OLE options, such as Edit, when an OLE object is double-clicked.



Activates the add-on selected in the add-on list.



Opens an online Help topic. Uses the same syntax as described in the Special dialog box.



Displays a particular drawing page.



Displays the drawing page in a new window.



Performs custom double-click behavior.



Duplicate (Ctrl+D)

Edit menu, drawing and stencil windows
Places a copy of selected shapes offset to the lower right of the original shapes.
Tip: To duplicate the shape at a specific distance from the original, select the shape, hold 
down the Ctrl key, and drag to the location where you want the new shape. To make copies 
quickly, duplicate one shape, and then press F4 to duplicate others.

Note: To view this command for a stencil, you must have an original stencil open.

See also
Copy
Copying shapes in the current drawing
Paste



Background

Edit menu, Go To submenu, drawing and print preview windows
Displays the background page assigned to the page displayed in the drawing window. This 
command is available only when the displayed page has a background assigned to it. 
Choose Foreground to return to the foreground page of a drawing.

See also
Assigning and canceling a background page
Creating a background page
Layer
Layer Properties
Next Page
Previous Page
Switching to a background page



Edit Color dialog box

Tools menu, Color Palette dialog box
Opens a dialog box where you can edit the basic color palette and create up to 16 custom 
colors.

DIALOG BOX OPTIONS
Basic Colors. Displays the Microsoft Windows basic color palette. Select any of the colors 
and use the Color Selector Palette to change the default color.
Custom Colors. Specifies up to 16 custom colors.
Define Custom Colors. This button is dimmed because the Edit Color dialog box is already 
in custom color mode.
Add To Custom Colors. Use the Color Selector Palette to create a custom color by 
adjusting the hue, saturation, and luminosity of the color. Alternatively, specify its red, 
green, and blue values. Once you're satisfied with the color displayed in the Color/Solid box, 
choose the Add To Custom Colors option.

See also
Choosing a color palette



Find

Edit menu, drawing window
Searches for specified text in shapes, stencils, the Properties dialog box, and data fields in 
the active drawing file.

Click to display information about the dialog box.

See also
Inserting fields into text
Searching and replacing text



Specifies the text you want to find. You can type or paste text into this field. To search using 
text you previously searched for, click the down arrow, then choose the text from the list.



Displays a list of special characters on which you can search: Tab Character, Manual Return, 
Optional Hyphen, Caret Character, or Any Character.



Specifies the range of the search.



Specifies to search only the current selection.



Specifies to search only the current page.



Specifies to search all pages in the open diagram.



Finds only those occurrences with the exact combination of uppercase and lowercase letters 
specified in the Find What box. Visio uses the case of letters as they were originally typed, 
regardless of whether the text has been formatted using Small Caps or All Caps formatting. 



Finds occurrences that are words and not parts of larger words. For example, if you type for" 
in the Find What box, Visio finds all instances of for" but ignores foreign." 



Finds and selects the next occurrence of the text in the Find What box.



Foreground

Edit menu, Go To submenu, drawing and print preview windows
Displays the foreground page for a drawing. Available only when a background page is 
displayed.
To cycle through the background pages in a drawing, from the Edit menu, choose Go To, then
choose Background.
Tip: Although you can see shapes on a background page when a foreground page is 
displayed, you can't edit the shapes on the background unless you display the background 
page.

See also
Assigning and canceling a background page
Next Page
Previous Page
Switching to a background page



Edit Icon

Master menu, stencil window
Opens the edit icon window, where you can edit the icon for the master shape selected in 
the stencil window. The window, whose title bar identifies the stencil and master shape, 
displays the icon as a bitmap, which you can edit pixel by pixel.
Tip: Before choosing Edit Icon, use the Properties command (on the Master menu) to specify
the size of the icon. The icon's size determines the size of the area available for editing the 
icon. You should also choose Manual as the Update option in the Properties or New Master 
dialog box, so you don't accidentally overwrite the customized icon each time you change 
the master shape.

See also
Creating a master shape icon
Editing parts of a master shape icon



Edit Master

Master menu, stencil window
Displays a selected master shape in the master shape drawing window, so you can edit the 
master shape. You can choose to have changes you make to the master shape be applied to 
future instances. The Edit Master command is available only when you open an original 
stencil.
You can also open the master shape drawing window by double-clicking a master shape icon
when an original stencil is opened.
To close the master shape drawing window, click the X box in the upper-right corner of the 
window.

See also
Creating a master shape from a shape in a drawing
Creating a master shape from scratch
Edit Icon
Editing a master shape in a stand-alone stencil
Opening a stencil
Properties



Edit Text (F2)

Shape menu, drawing window
Controls the text block for the selected shape. If a shape is selected with a tool other than 
the text tool, choosing Edit Text opens the shape's text block so you can edit text. If a shape 
is selected with the text tool, choosing Edit Text selects the shape's text block so you can 
move, rotate, or size the text block independently of the shape.

See also
Changing font attributes
Selecting text
Text block tool
Text tool



Edit <OLE object>, <OLE object> Edit

Edit menu, drawing window
Opens an OLE object in its original program so you can edit it. Appears on a submenu when 
you choose the Object command from the Edit menu. For example, if you select a Windows 
Paintbrush object, the command changes to Paintbrush Object. If a group is selected, the 
command in this position is Open Group. If nothing is selected, the command in this position 
is Object.

You can modify a linked or embedded object in its original program without leaving Visio. 
Changes you save in the original program appear immediately in the Visio drawing.

See also
Converting an object to Visio shapes
Linking or embedding an object into a Visio drawing



 Ellipse tool (Ctrl+6)

Drawing tool menu
Use the ellipse tool to draw ellipses and circles. Drag diagonally to draw an ellipse. As you 
drag, hold down the Shift key to draw a circle. Both ellipses and circles are closed shapes, 
consisting of two arc segments. To size an ellipse or circle, drag a selection handle. Drag a 
corner handle to preserve the shape's original proportions. 
To manipulate the arc segments of the ellipse, select the ellipse with the pencil tool to 
display vertexes and control points that you can drag.
To apply a fill style or fill format to an ellipse, use the Fill command.

See also
Drawing ellipses and circles
Drawing freeform shapes
Drawing rectangles and squares



Exit

File menu
Closes Visio windows and exits Visio. If you have changed a Visio file but did not save it 
before choosing the Exit command, a message asks if you want to save the changes before 
closing.

See also
Close
Quitting Visio



Fill (F3)

Format menu, drawing and ShapeSheet windows
Opens a dialog box where you apply fills and shadows to selected shapes. Closed shapes can
have fills and shadows. Open shapes can have shadows but no fill.
You can also use fill formatting buttons on the toolbar. Use ToolTips to identify the button.
The numbers preceding the patterns and colors in the Pattern, Foreground, and Background 
lists act as labels. As you work with the ShapeSheet, these numbers provide a shorthand for 
identifying patterns and colors.

Patterns
For both Fill and Shadow, you can specify a pattern that is blank (transparent), solid, or a 
bitmap pattern. Each bitmap pattern has two components: a foreground color applied to the 
dots and lines making up the pattern, and a background color. You can specify different 
colors in the Foreground and Background lists, and Visio changes the display of the Pattern 
list according to your color choices.

Colors
Some colors in the Foreground and Background lists are quite dark. For those colors, the left 
half of the color sample shows how the color will look as a solid (pattern 1). The right side 
shows how the color will appear in any bitmap pattern.

Click to display information about the dialog box.

See also
Creating patterned fills and shadows
Formatting fills and shadows



Displays the current pattern, foreground color, and background color for the selected 
shape's fill. 



Choose a pattern, which can be blank or transparent (None or pattern 0), solid (pattern 1), or
a bitmap pattern (patterns 2 through 24). Choosing None in the Pattern list creates a 
transparent shape. Visio ignores the foreground and background colors.



Choose a color that is applied to the dots and lines making the pattern.



Choose a color that is behind the dots and lines making the pattern.



Displays the current pattern, foreground color, and background color for the selected 
shape's shadow.



Choose a pattern, which can be blank or transparent (None or pattern 0), solid (pattern 1), or
a bitmap pattern (patterns 2 through 24). Choosing None in the Pattern list deletes an 
existing shadow, and Visio ignores the foreground and background colors.



Applies formats without closing the dialog box.



Applies changes, closes the Fill dialog box, and displays the Line dialog box.



Applies changes, closes the Fill dialog box, and displays the Font dialog box.



File Paths dialog box

Tools menu, Options dialog box
Determines the default file paths for Visio's files. This dialog box is displayed by choosing the
File Paths button in the Options dialog box. To change the default path, select the option you 
want to change and type a new path.

DIALOG BOX OPTIONS
Drawings. Displays the default drawings folder: drawings.
Templates. Displays the default templates folder.
Stencils. Displays the default stencil folder.
Help. Displays the default help files folder: help;template.
Add-ons. Displays the default add-ons folder: add-ons.
StartUp. Displays the folder for add-ons opened when you start Visio: add-ons\startup.
Filters. Displays the default filters folder: filters.
Tip: You can specify multiple paths by separating them with semicolons. For example, in the 
Add-ons option you can type:

add-ons;c:\templates
so Visio will look in both folders for add-ons.

See also
Creating a template
Opening a template to modify or copy it
Saving a new drawing file
Special command



First Tile

Print preview toolbar
Displays the first printed page or tile in the drawing.

See also
Previewing a drawing before you print
Print preview window
Showing page breaks
Tiling a large drawing onto multiple sheets of paper



Flip Horizontal (Ctrl+H)

Shape menu, drawing window
Transposes the left and right sides of selected shapes.
You can also use the Flip Horizontal button. (If you are using an alternate toolbar, the Flip 
Horizontal button may look slightly different or may not be available. Use ToolTips to identify 
the button.)

See also
Flip Vertical
Flipping and reversing shapes
Reverse Ends
Rotate Left
Rotate Right
Size & Position



Flip Vertical (Ctrl+J)

Shape menu, drawing window
Transposes the top and bottom sides of selected shapes.
You can also use the Flip Vertical button. (If you are using an alternate toolbar, the Flip 
Vertical button may look slightly different or may not be available. Use ToolTips to identify 
the button.)

See also
Flip Horizontal
Flipping and reversing shapes
Reverse Ends
Rotate Left
Rotate Right
Size & Position



Float

Right-click a docked stencil's title bar
Makes the stencil float. By default, stencils are docked.

See also
Arranging master shapes in a stencil
Arranging stencils
Arranging Visio windows



Font (F11)

Format menu, drawing and ShapeSheet windows
Applies formatting to selected text or to all text in the text blocks of selected shapes.
To format selected text, use the text tool to open the text block and then select the text you 
want to format. To apply formatting to all text in a shape's text block, select the shape.
Tip: If the selected text contains more than one setting for any format (for example, more 
than one font), the Font dialog box displays the formatting of the first character in the 
selection.
Within the Font dialog box, you can open other dialog boxes for formatting text and shapes.
You can also use the Increase Font Size and Decrease Font Size buttons. Use ToolTips to 
identify the button.
Alternatively, use the Font box and the Font Size box on the toolbar.

DIALOG BOX OPTIONS
Font. Displays a list of all the enabled fonts installed in Microsoft Windows. To change the 
font, choose from the list, which includes all fonts installed and enabled on your computer.
The symbol TT precedes TrueType fonts. A printer icon precedes printer fonts that are not 
TrueType fonts. Fonts with neither icon are Windows fonts but not TrueType, so they may not 
size or print as well as TrueType or printer fonts.
Size. Determines the point size of selected text.
Case. Determines whether text appears in uppercase or lowercase as you type text, or as all
uppercase or initial capitals regardless of how you typed the text.
Color. Determines the text color.
Position. Determines whether text is displayed in normal, superscript, or subscript position.
Language. When you choose a language (such as French) from this box, when you use 
Spelling, Visio uses the appropriate dictionary (such as the French dictionary) to check the 
spelling of the formatted text. 
Style. Determines whether text is displayed in bold, italic, underline, or small caps style.
Paragraph. Applies formatting, closes the Font dialog box, and displays the Paragraph 
dialog box.
Tabs. Applies formatting, closes the Font dialog box, and displays the Tabs dialog box.
Block. Applies formatting, closes the Font dialog box, and displays the Text Block dialog box.
Apply. Applies formatting without closing the Font dialog box.
Fill. Applies formatting, closes the Font dialog box, and displays the Fill dialog box.
Line. Applies formatting, closes the Font dialog box, and displays the Line dialog box.

See also
Changing font attributes
Checking the spelling of text
Creating a style
Setting text block margins



Displays all characters as uppercase, regardless of whether you typed lowercase or 
uppercase letters. (For small caps, choose that option in the Style section.)



Displays the font as you first typed it¾uppercase, lowercase, or a mixture of characters.



Displays the first character of every word as an uppercase letter, with all other characters 
lowercase, regardless of whether you typed lowercase or uppercase letters.



Aligns text horizontally on the baseline.



Raises text slightly above the baseline and reduces the point size.



Drops text slightly below the baseline and reduces the point size.



Makes the font heavier.



Makes the font slanted.



Draws a line under the text.



Displays all lowercase characters as small capital letters (smaller than the specified point 
size), leaving uppercase characters full-size.



Format painter tool

If you're pleased with the formatting of a particular shape, you can quickly transfer the 
formatting (such as line, fill, and text styles) to another shape instead of starting from 
scratch.
Note: This button is available only on the Microsoft Office toolbar. 

See also
Copying and applying shape formatting
Copying shapes in the current drawing



Fragment

Shape menu, Operations submenu, drawing window
Breaks selected shapes into smaller shapes. For example, you can draw lines through a 2-D 
shape where you want to break the shape, select the 2-D shape and the lines, and then 
choose Fragment to break the shape where the lines intersect it.
When you fragment shapes, Visio creates a new ShapeSheet for each of the new shapes.
When you fragment overlapping 2-D shapes, new shapes are formed from both the areas 
where the original shapes overlap and the areas where they do not overlap.
When you fragment three or more intersecting lines, the enclosed spaces become new 
shapes. 

See also
Combine
Fragmenting shapes
Intersect
Subtract
Union



 Freeform tool

Drawing tool menu
Draws smooth curves (also called splines). For example, you can draw a flower bed with an 
irregular border that is smooth, not jagged.

See also
Adding segments to shapes
Changing shape angles by dragging a vertex
Deleting segments from shapes
Drawing freeform shapes
Drawing lines and arcs
Drawing shapes with several segments



Formulas

View menu, ShapeSheet window, formula bar
Displays cell formulas in the ShapeSheet. To display values instead of formulas, use the 
Values command.

See also
Displaying values and formulas in cells
Formulas overview



Function

Insert menu, ShapeSheet window
Opens a dialog box where you select a function to paste into a formula for a ShapeSheet 
cell. Visio pastes the function at the insertion point in the formula bar. (The command is 
dimmed until you click in the formula bar to place an insertion point.)

DIALOG BOX OPTIONS
Select Function. Lists functions you can paste into a formula. When you select a function, 
the function and its arguments appear below the Select Function list.
Paste Arguments. Check this box if you want to paste placeholders for a function's 
arguments. Uncheck this box to paste only the function.

See also
Building a formula by pasting
Creating formulas



Grid 

View menu, drawing window
When checked, displays the grid. The grid helps you position shapes visually. You can also 
snap shapes to the grid.
The intervals of the grid correspond to the unit of measure you set in the Options dialog box.
You control the size of the intervals in the Ruler & Grid dialog box.

See also
Properties
Setting page display options
Snap & Glue
Snapping shapes into place



Page (F5)

Edit menu, Go To submenu, drawing and print preview windows
Opens a dialog box where you can choose a page to display in the drawing window. 

DIALOG BOX OPTIONS
Select Page. Displays a list of background and foreground pages in the drawing file. 
Foreground pages are listed in bold type; background pages are listed in normal type. The 
current page is dimmed.
New. Displays the Page dialog box so that you can create and go to a new page.
Open Page In New Window. Displays the selected page in a new window.

See also
Deleting a page
Displaying pages
Rearranging foreground pages



Group (Ctrl+G)

Shape menu, Grouping submenu, drawing window
Creates a group from the shapes and objects from other programs selected on the drawing 
page. Group members keep their original spatial relationships to each other and also retain 
their original ShapeSheets. Visio also creates a new ShapeSheet for the group.

See also
Add To Group
Adding and removing shapes in groups
Convert To Group
Converting an object to Visio shapes
Editing and formatting a group
Grouping and ungrouping shapes
Remove From Group
Ungroup
Updating a group's selection rectangle



Guides 

View menu, drawing window
When checked, displays guides and guide points. Rulers must be visible if you want to create
guides and guide points.

See also
Align shapes
Aligning shapes to guides
Creating guide points
Creating guides
Distributing shapes
Gluing shapes to guides
Grid
Rulers
Setting page display options
Snap & Glue



 Icon pencil tool

Edit icon toolbar, edit icon window
Use the icon pencil tool to change the color of a pixel in a bitmap. Assign the color you want 
to the left or right mouse button by clicking in the color palette, and then with the same 
mouse button, click the pixel you want to change.

See also
Changing the colors for a master shape icon
Editing parts of a master shape icon



Icons And Names

View menu, stencil window

Note: This command is available only when you have an original stencil open.
When checked, displays master shape icons and their names in the stencil window.
You can also use the Icons And Names button. Use ToolTips to identify the button.

See also
Arrange Icons
Arranging master shapes in a stencil
Creating a master shape icon
Icons Only
Names Only



Icons Only

View menu, stencil window

Note: This command is available only when you have an original stencil open.
When checked, displays master shape icons without their names in the stencil window.
You can also use the Icons Only button. Use ToolTips to identify the button.
Tip: Even though the names aren't visible when Icons Only is checked, you can display the 
master shape's name by placing the pointer over a master shape icon. A ToolTip containing 
the master shape's name appears. (If you've turned off toolbar ToolTips with the toolbar 
shortcut menu, these ToolTips are also turned off.)

See also
Arrange Icons
Arranging master shapes in a stencil
Creating a master shape icon
Icons And Names
Names Only



Intersect

Shape menu, Operations submenu, drawing window
Creates one closed shape from the area in which two shapes overlap or intersect. The new 
shape inherits the text and formatting of the first shape you select.
When you intersect two or more shapes, the ShapeSheet for the shapes you intersected are 
deleted, and Visio creates a ShapeSheet for the new shape.

See also
Combine
Group
Intersecting shapes
Union



Picture

Insert menu, drawing window
Displays a list of files saved in graphic formats that you can import into a Visio drawing. Visio
creates a placeholder in the drawing to hold the graphic.
Visio can import files from these formats: Adobe Illustrator File Format (.AI), Computer 
Graphics Metafile (.CGM), CorelDraw Drawing File Format, version 3.0, 4.0, and 5.0 (.CDR), 
Encapsulated PostScript (.EPS), Initial Graphics Exchange Specification (.IGS), Macintosh 
Picture File Format (.PCT), Micrografx Designer Version 3.1 File Format (.DRW), Tag Image File 
Format (.TIF), Windows Bitmap (.BMP, .DIB), Windows Metafile (.WMF), and ZSoft PC PaintBrush 
Bitmap (.PCX).
The imported file is linked to the original file unless it is a .BMP, .DIB, or .WMF file. For those 
three formats, Visio pastes the contents of the file into the drawing and centers the imported
file in the current view.
Tip: You can import and convert ABC FlowCharter and CorelFlow files to Visio using the Open
command on the File menu. If you have Visio Technical, you can also convert AutoCAD files 
into Visio format.

DIALOG BOX OPTIONS
Look In. Displays the current folder.
Up One Level. Moves the Look In folder up one level in the hierarchy.
Create New Folder. Creates a new folder in the current level in the hierarchy.
List. Displays the list as an icon and a label.
Details. Displays the list as the name, size, type, and modified date.
File Name. List files that are in the format selected in the File Type list.
Files Of Type. Lists the file formats you can import in the folder you chose.
Open. Opens the selected file. 
When you choose a filter to convert a file you're importing, Visio may respond with a dialog 
box that contains options for setting Color Translation. If you import .CGM, .EPS, or .PCT files,
the dialog box also has options for Retain Background, Emulate Line Styles, and Color 
Translation.
Retain Background. When checked, preserves the background color of the original image. 
To do this, Visio draws a background rectangle in that color.
Emulate Line Styles. When checked, draws thick or patterned lines as polygons rather 
than as lines to ensure they match the lines of the original file.
Color Translation. Lists five options for displaying color: normal, inverse, inverse grays 
only, gray scale, and inverse gray scale.

See also
Convert To Group
Creating objects in another program from within Visio
Editing an object from another program
Importing a file into a Visio drawing
Linking or embedding an object into a Visio drawing
Ungroup





Matches the color of the original image.



Inverts the colors (for example, what was black becomes white).



Inverts only the black, white, and gray shades, matching all other colors to the original file.



Converts all colors to gray shades (useful if you plan to print on a monochrome printer).



Converts all colors to grays and inverts them.



Object 

Insert menu, drawing window
Inserts objects from other programs into a Visio drawing. You can either open another 
program from within Visio and create a new object or insert an existing file into Visio.

DIALOG BOX OPTIONS
Object Type. Lists the types of objects that you can link or embed from an OLE-compatible 
program. The items in the list depend on which OLE-compatible programs are installed on 
your computer. Some programs installed on your system appear as commands on the Page 
menu. Choose the program's command to insert an object created in that program.
Create New. Opens the corresponding program and creates the object you want to insert.
Create From File. Inserts an existing file. To link the object to Visio, choose Link.
Display As Icon. Displays the program's icon in Visio.
Change Icon. Displays the Change Icon option. When Display As Icon is checked, you can 
choose between the current icon, a default icon, or an icon from a bitmap file. You can also 
change the icon Label.
Result. Displays a message detailing what happens when you click OK.

See also
Converting an object to Visio shapes
Creating objects in another program from within Visio
Exporting a drawing into another file format



 Lasso tool

Edit icon toolbar, edit icon window
Use the lasso tool to select a non-rectangular area of a master shape icon. The area can be 
any size or contour. Drag the lasso tool to select the area you want. You can then drag the 
selected area to move it or use commands on the Edit menu to change the selected area.

See also
Editing parts of a master shape icon



Last Tile

Print preview toolbar
Displays the last printed page or tile in the drawing.

See also
Previewing a drawing before you print
Print preview window
Showing page breaks
Tiling a large drawing onto multiple sheets of paper



Last Zoom

View menu, drawing window
Toggles between the current view and the most recent view. 
You can also choose Last from the Zoom box on the toolbar. Use ToolTips to identify the 
button.

See also
Zooming in and out of a drawing



Layer Properties

View menu, drawing and print preview windows
Creates and modifies layers in a diagram. By assigning shapes to different layers, you can 
selectively view, print, and lock layers, as well as control whether shapes on a layer can be 
snapped to or glued to. 
Note: Some templates, such as the Office Layout template, contain shapes that are already 
assigned to pre-existing layers.

Click to display information about the dialog box.

See also
Adding layers
Assigning a shape to a layer
Deleting layers
Setting shapes on a layer to appear in a color
Viewing layers



Specifies the name of the layers in the diagram. Clicking this button opens the Rename 
Layer box, in which you can change the name of the selected layer.



Displays the number of shapes assigned to each layer.



Specifies whether the shapes on a layer are visible or hidden. Check to show the layer and 
uncheck to hide the layer.



Specifies whether to print the shapes on a layer. Check to have the layer print; uncheck this 
option so that the layer does not print.



Specifies the active layer to which shapes without a pre-assigned layer are automatically 
assigned. Check to make the layer active or uncheck to deactivate the layer.



Prevents shapes on a layer from being selected or altered. Check to lock the layer or 
uncheck to unlock the layer. If a layer is locked, its Visible, Print, Active, Snap, Glue, or Color 
properties cannot be changed.



Specifies whether other shapes can snap to shapes assigned to the layer. A shape on a layer
that has Snap unchecked can still snap to other shapes, but other shapes cannot snap to it.



Specifies whether other shapes can glue to shapes assigned to the layer. A shape on a layer 
that has Glue unchecked can still glue to other shapes, but other shapes cannot glue to it.



Specifies that all shapes assigned to the layer appear in the specified color; this option does 
not permanently change the shape colors. Check to override each shape's original color in 
favor of the layer color. Uncheck to return shapes to their original colors.



Applies the current settings of the box to the drawing page without closing the box.



Adds a new layer and opens the New Layer dialog box, in which you can type a name for a 
new layer.



Deletes the selected layer. All shapes that are assigned to only the selected layer are 
deleted.



Opens the Rename Layer dialog box, in which you can rename the selected layer.



Removes all layers that do not have shapes on them.



Adds color to a layer so that all objects assigned to the selected layer appear in the layer 
color.



Layer

Format menu, drawing and ShapeSheet windows
Assigns the selected shape to one or more layers, or removes a shape's layer assignment.

DIALOG BOX OPTIONS
Member Of Layer(s). Assigns the selected shape to one or more layers. You can assign a 
shape to multiple layers.
Preserve Group Member Layers. Specifies that individual shapes in a group retain their 
current layer assignments. For example, you might assign a desk to the furniture layer and a
computer to the electronics layer, then group them. If you then assign the group to the den 
layer, the desk and computer retain their previous layer assignments as well. When this 
option is unchecked, when you assign a group to a layer, all of the group members become 
members of the new layer. Their previous layer assignment is canceled. 
All. Assigns the selected shape to all layers.
None. Assigns the selected shape to no layers.
New. Opens the New Layer box, in which you can type a name to create a new layer.

See also
Adding layers
Assigning a shape to a layer
Setting options for layers



 Left Color box

Edit icon toolbar, edit icon window
Displays the color assigned to the left mouse button in the edit icon window. Choose the icon
pencil or paint bucket tool and click with the left mouse button to change the pixels in the 
icon to this color. To change the assigned color, click with the left mouse button in the color 
palette.

See also
Editing parts of a master shape icon



Line (Shift+F3)

Format menu, drawing and ShapeSheet windows
Applies formatting such as line pattern, line weight, line ends, and corner rounding to lines 
and arcs in the selected shape.
You can also use line formatting buttons or the Line style box. Use ToolTips to identify the 
button.

Click to display information about the dialog box.

See also
Changing line color, weight, and pattern
Color Palette
Define Styles
Fill
Font
Style



Displays line end options for the shape's beginning point.



Displays line end options for the shape's ending point.



Displays options for the size of line ends.



Displays options to change the shape's formatting.



Choose among none, solid, or dashed lines.



Choose among various line thicknesses.



Choose among colors that are set in the Color Palette dialog box.



Choose between round and square line caps.



Displays options for line ends such as arrowheads for the endpoints of an open shape.



Choose among various corner formats.



Displays the numeric equivalent for the roundness of the corner¾the higher the number, the
rounder the corners.



Applies formats without closing the dialog box.



Applies changes, closes the Line dialog box, and displays the Fill dialog box.



Applies changes, closes the Line dialog box, and displays the Font dialog box.



 Line tool (Ctrl+3)

Drawing tool menu
Use the line tool to draw straight line segments in any direction. As you drag, hold down the 
Shift key to constrain the line to angles at 45-degree intervals. A single line is a 1-D shape 
when you first draw it. Adding other line or arc segments creates a 2-D shape.

Endpoints
Any selected 1-D shape displays two square endpoints: the beginning point contains an X, 
and the ending point contains a plus sign (+). To move a 1-D line or arc segment, drag a 
portion of the line other than an endpoint with the pointer tool. To size a 1-D line or arc 
segment, drag an endpoint with the pointer tool.

Arc/line segment
To change a line to an arc or to edit a line segment in a 2-D shape, use the pencil tool. You 
can switch between the arc tool, line tool, pencil tool, and freeform tool to draw shapes 
consisting of contiguous segments.

See also
Drawing freeform shapes
Drawing lines and arcs
Drawing shapes with several segments



Links 

Edit menu, drawing window
Opens a dialog box where you can manage links between objects from other programs in 
Visio drawings and their original files. You can view the links and choose whether to update 
the object manually or automatically as you use the original program to edit the linked file. 
You can also open a dialog box where you can change the file reference for the linked object.

DIALOG BOX OPTIONS
Links. Lists the object's folder path, the original OLE program used to create the linked 
object, and the update option you specified: Automatic or Manual. To change information for 
a linked file, choose it from the list. You can then change its update option or use the Change
Source button to change the file reference.
Source. Lists the folder path.
Type. Lists the original OLE program used to create the linked object.
Update. Specifies when Visio updates the linked object. Choose Automatic or Manual.
Update Now. Checks the file reference. If changes have been made since you last updated,
Visio applies those changes to the object.
Open Source. Opens the OLE program used to create the linked object.
Change Source. Opens the Change Source dialog box, where you can change the file 
reference to the correct file.
Break Link. Breaks the link between the object and the original file. Future changes to the 
original file will not affect the object on the drawing page, which Visio changes to a Windows 
metafile. As a result, you don't have to provide any additional files when giving someone a 
Visio drawing on disk.

See also
Viewing and updating links



Updates the object when you open the drawing it is linked to.



Updates the object in the drawing when you choose the Update Now button.



Lotus Notes Field

File menu
Opens a dialog box where you can create and display Lotus Notes Field for the active 
drawing.
If you create a field in Lotus Notes, you need to create a corresponding field in the Lotus 
Notes Field dialog box in order for Visio to read the field. Once you create a field in Visio, you
can embed a Visio object into a Lotus Notes document.
Fields created using the Lotus Notes Field command are also displayed in the Field dialog 
box.

DIALOG BOX OPTIONS
Field Name And Direction. Displays the field name. Indicates whether the field is read 
from Lotus Notes or written to Lotus Notes.
If Read From Notes is checked, choose from Text, Time, and Number.
If Write To Notes is checked, choose from:

Text. Choose from Text, Name, Data 1, Data 2, Data 3 and Help.
Time. Enter a custom formula that returns a time or date.
Number. Enter a custom formula.

Data Type. Lists three data types for the field: Text, Time, Number. Also lists available 
shape fields.
Custom Formula. Use this section to enter a custom formula for a field.

See also
Creating formulas
Inserting fields into text
Reading information from Lotus Notes and displaying it in Visio



Lotus SmartSuite

Toolbar shortcut menu
Displays a Visio toolbar that is similar to the Lotus SmartSuite toolbar. The toolbar provides 
buttons you can use as shortcuts for choosing menu commands. To switch the toolbar, right-
click the toolbar, then choose Lotus SmartSuite from the shortcut menu.
Note: Your toolbar may vary depending on the display resolution of your monitor, the size of
your window, and which window is active. 

See also
Getting quick access to common commands
Switching toolbar sets



Microsoft Office

Toolbar shortcut menu
Displays a Visio toolbar that is similar to the Microsoft Office toolbar. This is the default Visio 
toolbar. The toolbar provides buttons you can use as shortcuts for choosing menu 
commands. To switch the toolbar, right-click the toolbar, then choose Microsoft Office from 
the shortcut menu.
Note: Your toolbar may vary depending on the display resolution of your monitor, the size of
your window, and which window is active. 

See also
Getting quick access to common commands
Switching toolbar sets



Name

Insert menu, ShapeSheet window
Opens a dialog box where you select a cell name to paste into a formula for a ShapeSheet 
cell. Visio pastes the cell name at the insertion point in the formula bar. (The command 
remains dimmed until you place an insertion point by clicking in the formula bar.)

DIALOG BOX OPTIONS
Select Name. Lists the names of cells in the open ShapeSheet.
Insert. Pastes the selected cell name into the formula. You can paste one cell name after 
another at the insertion point.
Close. Cancels all changes made since you opened the dialog box.

See also
Alphabetical list of ShapeSheet cells
Building a formula by pasting
Cell reference syntax
Creating formulas
Function



Names Only 

View menu, stencil window

Note: This command is available only when you have an original stencil open.
When checked, displays the names of master shapes in the stencil window. 
You can also use the Names Only button. Use ToolTips to identify the button.

See also
Arrange Icons
Arranging master shapes in a stencil
Creating a master shape icon
Icons And Names
Icons Only



New (Ctrl+N)

File menu
Creates a new drawing or stencil file, or starts one of Visio's Wizards. You can:

base a new drawing on a template or start it from scratch.
base a new stencil on an existing stencil or start it from scratch. 
start a Visio Wizard to automate a task.

To open additional stencils while you are working on a drawing, use the Stencils command 
on the File menu.
You can also use the New button. Use ToolTips to identify the button.

DIALOG BOX OPTIONS
Based On. Lists templates, stencils, and Wizards, depending on the option chosen in the 
New section. Templates are marked with blue icons and names, and stencils with green icons
and names. Choose No Template to open a blank, untitled drawing window. Choose No 
Stencil to open a blank stencil window.
New. Determines whether templates or stencils appear in the Based On list. Drawing (the 
default) lists all template files in the default templates folder, as well as available Wizards. 
Stencil lists all stencil files in the default stencils folder. You can specify the paths for both 
options in the File Paths dialog box.
Description. Displays information about the selected template, stencil, or Wizard.
Filename. Displays the path and filename for the selected template, stencil, or Wizard.
Open. Displays the Open box so you can open an existing file.

See also
Opening a stencil
Starting a new drawing with a template
Starting a new drawing without a template



Next Page

Edit menu, Go To submenu, print preview window
Displays the next page in the current drawing file.
You can also use the Next Page button. Use ToolTips to identify the button.

See also
Getting quick access to common commands
Switching toolbar sets



Page

Insert menu, drawing window
Creates a new page and opens a dialog box where you can change page settings. To create 
a new page or a background with the same settings as the page currently displayed, leave 
the settings as shown, and then click OK in the Page dialog box.
The Page command displays a dialog box similar to that displayed by the Properties 
command. Use the Page command to create and set options for a new page. Use Page Setup
to change the settings for the displayed page.
Visio stores the new page directly after the page that was displayed when you created it. You
can change the page order by using the Reorder command on the Page menu.

DIALOG BOX OPTIONS
Page Properties. Specifies the page type, name, any background assigned to it, and 
measurement of the rulers.
Shape Shadow Offset. Specifies the position of shadows in relation to shapes. All shapes 
on a page that are formatted with shadows have the same shadow offset. By default, 
shadows appear 0.125 inches down and to the right of the shape. Type new distances after 
Right and Down to change the shadow offset. To position shadows above or to the left of a 
shape, type negative numbers.
Drawing Size/Scale. Identifies the page size and scale. To change either, choose the 
Size/Scale button.
Size/Scale. Displays the Size & Scale.
Save Preview Picture. Saves a picture of the file, so that when you open a file or view it 
with Quick View, you can see a picture of the first page in the drawing.

See also
Changing the shadow offset
Creating a background page
Creating a new page
Setting a drawing scale
Setting page display options



Lists properties for either the drawing page or the background page.



Displays the name of the drawing page. Page names can contain up to 31 characters.



Lists the name of the background page in the drawing.



Displays the unit of measure Visio's rulers should display on the page. Unless you specify 
different units here, the ruler units will be those specified for the drawing scale.



Specifies the current page size.



Specifies the ratio of the printed drawing to the drawing page.



Choose Fine, Normal, or Coarse.



Choose Fine, Normal, or Coarse.



New Master 

Master menu, stencil window
Creates and displays a blank master shape icon for a new master shape. Use the command 
to specify the new master shape's name, icon size, icon update method, and master shape 
prompt. When you double-click the blank icon, Visio opens the master shape drawing 
window, where you can draw the new master shape.

DIALOG BOX OPTIONS
Master Name. Displays the name that appears under the master icon in the stencil 
window. Master shape names can contain up to 31 characters. To specify how the name is 
aligned below the icon, choose Left, Center, or Right.
Icon. Specifies the icon size and when Visio should update the icon.

Size. Choose Normal, Tall, Wide, or Double. The default icon size is Normal. Tall is the 
same width, but twice the height; Wide is the same height, but twice the width. Double
is twice as wide and twice as tall as Normal. Choose the Edit Icon command on the 
Master menu to adjust the icon to fit a larger size.
Update. Updates the master shape icon automatically each time you edit the drawing 
of the master shape. Manually updates a master shape icon when you choose Update 
Icon from the Master menu.

Prompt. Displays the text that appears when you point to the master icon in the stencil 
window. To change the text, type new text in the Prompt box.
Match Master By Name On Drop. If you've created a stencil, preserves the formatting 
you've applied to the stencil's master shapes. For example, you've modified the shapes in 
the Office Layout stencil, created a stencil called My Office, then you drop a shape from the 
Office Layout stencil into the drawing.

If Match Master By Name On Drop is checked for the shapes on the My Office stencil, 
when you drop a shape into the drawing, Visio checks to see if the shape you're 
dropping matches any of the master shapes in the My Office stencil. If it finds a match,
Visio formats the shape with the changes you made to the My Office master shape. 
If Match Master By Name On Drop is unchecked for the shapes on the My Office stencil,
when you drop a shape from the Office Layout stencil, the shape is added to the 
drawing file with the default Office Layout formatting.

See also
Creating a master shape from a shape in a drawing
Creating a master shape icon
Opening a stencil
Update Icon



New Window

Window menu
Opens a copy of the active window (stencil, drawing, or ShapeSheet) in a new window.

See also
Arranging Visio windows
Zooming in and out of a drawing



Next Tile

View menu, print preview window
Displays the next printed page or tile in the drawing. 
You can use the Previous Tile command on the View menu to display the previous tile.
You can also use the Next Tile button. Use ToolTips to identify the button.

See also
Previewing a drawing before you print
Print preview window
Showing page breaks
Tiling a large drawing onto multiple sheets of paper



Novell PerfectOffice

Toolbar shortcut menu
Displays a Visio toolbar that is similar to the Novell PerfectOffice toolbar. The toolbar 
provides buttons you can use as shortcuts for choosing menu commands. To switch the 
toolbar, right-click the toolbar, then choose Novell PerfectOffice from the shortcut menu.
Note: Your toolbar may vary depending on the display resolution of your monitor, the size of
your window, and which window is active. 

See also
Getting quick access to common commands
Switching toolbar sets



Object 

Edit menu, drawing window
Displays the submenu of commands that you use to work with objects from another 
program. Usually the submenu contains the <OLE object> Edit  and the <OLE object> 
Convert commands. In some cases, the submenu may contain the Open command.
Tip: This command is available only when an OLE object is selected.
If you select an object from another program, the command's name reflects the type of 
object. For example, if you select a Windows Paintbrush object, the command's name 
appears as Paintbrush Object.

See also
Converting an object to Visio shapes
Creating objects in another program from within Visio
Linking or embedding an object into a Visio drawing



Open (Ctrl+O)

File menu
Displays a dialog box where you can open an existing drawing file, stencil, template, or 
workspace.
You can also use the Open button. Use ToolTips to identify the button.

DIALOG BOX OPTIONS
Look In. Displays the current folder. In the list, double-click the folder you want to open.
Up One Level. Moves the Look In folder up one level in the hierarchy.
Create New Folder. Creates a new folder in the current level in the hierarchy.
List. Displays the list as an icon and a label.
Details. Displays the list as the name, size, type, and modified date.
File Name. Lists files of the type specified in the List Files Of Type box. To open a file, 
choose from the list, or type a path and filename in the box.
Files Of Type. Lists the file types you can open, identified by their filename extension: All 
Files (.VS*), Drawings (.VSD), Stencils (.VSS), Templates (.VST), Workspaces (.VSW), ABC 
FlowCharter (*.AF3, *.AF2), CorelFlow (*.CFL). To change the type, choose from the list.
Description. Displays information about the selected file. This information comes from the 
Description box in the Properties dialog box.
Open button. Opens the selected file.
Open. Determines whether the file is opened as an original, a copy, or a read-only version 
of the file.
Preview. Displays a preview of the selected file if a preview has been saved for the file in 
the Properties dialog box.

File Preview. Turns file preview on or off.

See also
Editing a template file
Opening a stencil
Opening a template to modify or copy it
Opening an existing drawing file



Opens the original file so you can edit it. If this option is dimmed when opening a stencil file,
it means the original stencil is already open.



Opens an untitled copy of the selected file. You can edit the file, and then use the Save As 
command on the File menu to name and save it. You cannot save it with its original name 
(default for a template).



Opens a read-only file. Read-only templates or drawing files are identified in the title bar 
with brackets. Use this option to open a stencil that you don't expect to modify.



Open Group, Open <group name> 

Edit menu, drawing window
Opens the selected group and displays its component shapes in the group window. (If you 
have named the group by using the Special command, the group name follows the 
command Open; otherwise, the command reads Open Group.)
Whether or not the group is rotated on the drawing page, it appears unrotated in the group 
window. Shapes appear as if they were independent, not grouped. The group window 
displays a page just large enough to hold the shapes. You can edit the shapes in the same 
way as you edit shapes in the drawing window. Changes you make in the group window are 
reflected in the drawing window.
Tip: After editing the shapes in a group in the group window, you might need to readjust the
width and height of the group so its selection rectangle contains all the group's shapes. To 
do this, select the group, and choose Update Alignment Box from the Tools menu.

See also
Editing the shapes in a group



Open In Visio

View menu, in-place window only
Opens Visio in its own window when working with Visio in place in an OLE container program.
When Visio is open in its own window, you can open original stencil files so you can add or 
delete shapes from a stencil.
Note: When Visio is open in its own window, the File and Window menus are updated to 
include additional commands.

See also
Editing an embedded object in place



Organization Chart Wizard

Tools menu, Run Add-on submenu, drawing window
Automates creating an organization chart. You can create one from scratch or base it on an 
existing Microsoft Excel worksheet or a text file.
By default, Visio looks for these column headings:

Name Position Reports To Departme
nt

Telephon
e

Master Shape

If they're in a different order, you can rearrange them in the Wizard.

See also
Starting a new drawing with a template



Stencils

File menu
Opens a stencil in the stencil window. Generally you start a new drawing with a template 
that opens at least one stencil for you. Use the Stencils command to open additional stencils
or to open an original stencil file so you can add or modify master shapes.
You can also use the Stencils button. Use ToolTips to identify the button.

DIALOG BOX OPTIONS
Select Stencil. Lists stencils (.VSS extension) next to green file icons. Select which stencil 
you want to open and click OK.
Browse. Displays the Open dialog box, where you can search folders to find a stencil file.
Open. Determines whether the file opens as an original or a read-only version.
Description. Displays information about the selected file. This information comes from the 
Description box in the Properties dialog box.
Filename. Displays the Windows path for the filename.

See also
Creating a new stencil
Opening a stencil
Opening an original stencil



Options

Tools menu
Opens a dialog box where you can set the units of measure, the file format for saving files, 
and other options.

DIALOG BOX OPTIONS
Default Units Of Measure. Specifies the units of measure for page dimensions, text, and 
angles.
General. Specifies to prompt for document information automatically when saving a file, 
and specifies the user name.
Freeform Drawing. For a shape drawn with the freeform tool, the Precision bar controls 
how many points there are in the shape, and Smoothing controls how precisely Visio 
smoothes the mouse movements.
File Paths. Opens the File Paths dialog box.
Spelling. Opens the Spelling Options dialog box in which you can set where Visio searches 
(selection, current page, or all pages) and the dictionary Visio uses.

See also
Properties
Saving a new drawing file
Saving changes to an open file
Snapping shapes into place
Units of measure



Specifies the units of measure for a page's dimensions, margins, drawing size, scale, and 
other features. 



Specifies the units of measure for indents, line spacing, and other text measurements. The 
default unit for type size is points (1 point = 1/72 in.). You can enter type size in another unit 
of measure (for example, 1 ft. or 12 in.), but you can't change the default unit for type size.



Specifies the units for the angle of rotation.



Page Breaks

View menu, drawing window
Displays page breaks for a drawing. Page breaks are displayed where the document tiles 
when printed. Page breaks are determined by settings in the Page Setup dialog box.

See also
Previewing a drawing before you print
Showing page breaks



Page Layout Wizard

Tools menu, Run Add-on submenu, drawing window
Automates setting up the page and adding title or border details.

See also
Starting a new drawing with a template



Previous Page

Edit menu, Go To submenu, print preview window
Displays the previous page in the current drawing file.
You can also use the Previous Page button. Use ToolTips to identify the button.

See also
Getting quick access to common commands
Switching toolbar sets



Properties (Shift+F5)

Edit menu, Drawing Page submenu, drawing and print preview windows
Opens a dialog box where you can change the size, scale, and other settings for a drawing 
page.

DIALOG BOX OPTIONS
Page Properties. Specifies the page type and name, whether a background is assigned to 
it, and the unit of measurement of the rulers.
Shape Shadow Offset. Specifies the position of shadows in relation to shapes. All shapes 
on a page that are formatted with shadows have the same shadow offset. By default, 
shadows appear 0.125 inches down and to the right of the shape. Type new distances after 
Right and Down to change the shadow offset. To position shadows above or to the left of a 
shape, type negative numbers.
Drawing Size/Scale. Displays the page size and scale. To change either, choose the 
Size/Scale button.
Size/Scale. Opens the Size & Scale where you set options for the drawing page size and the
drawing scale.

See also
Changing the size of the drawing page
Formatting fills and shadows
Layer Properties
Ruler & Grid
Setting display options
Setting page display options



To change the name of the drawing page, type a name containing up to 31 characters.



Lists the name of the background page in the drawing.



Choose the unit of measure Visio's rulers should display on the page. Unless you specify 
different units here, the ruler units will be those specified in the drawing scale.



Specifies the current page size.



Specifies the ratio of the printed drawing to the drawing page.



Page Width

View menu, drawing window
Displays the entire width of the page in the drawing window.
You can also adjust width view by using the Actual Size command. 
You can also choose Width from the Zoom box on the toolbar. Use ToolTips to identify the 
button.

See also
Zooming in and out of a drawing



 Paint bucket tool

Edit icon toolbar, edit icon window
Use the paint bucket tool to change the color of an area of a master shape icon (a bitmap). 
Assign the color you want to the left or right mouse button by clicking in the color palette. 
Then click a pixel in the area you want to change with the same mouse button. The new 
color is applied to all contiguous pixels of the same color in the area you clicked.

See also
Editing parts of a master shape icon



Paragraph (Shift+F11)

Format menu, drawing and ShapeSheet windows
Specifies alignment, indentation, and spacing for selected paragraphs or the selected 
shape's entire text block.

DIALOG BOX OPTIONS
Horizontal Alignment. Displays the current horizontal alignment of the text in relation to 
the text block margin. Choose Left, Right, Center, Justify, or Force Justify.
Indents. Displays the current indentation from the text block margins.
Spacing. Displays the current paragraph and line spacing. Type values for Before, After, and
Line.
Apply. Applies formatting without closing the dialog box. 
Font. Applies formatting, closes the Paragraph dialog box, and displays the Font dialog box.

See also
Aligning and indenting paragraphs
Define Styles
Setting line spacing
Zooming in and out of a drawing



Starts each line of text at the left margin. The right side of the text is ragged.



Centers each line of text between the left and right margins.



Positions the last character in each line at the right margin. The left side of the text is 
ragged.



Adjusts the spacing between words and characters so each line of text (except the last line 
of the paragraph) fills the space between the left and right margins.



Adjusts the spacing between words and characters so each line of text (including the last 
line of the paragraph) fills the space between the left and right margins.



Specifies the space Visio inserts before a paragraph (except for the first paragraph in the 
text block). Traditionally, vertical spacing is measured in points. One point (abbreviated as 
pt.) equals 1/72 inch. You can type new values using any unit of measure.



Specifies the space Visio inserts after a paragraph (except for the last paragraph in the text 
block). If you specified a value for Before, the amount of space between paragraphs will 
equal the sum of the Before and After values. Traditionally, vertical spacing is measured in 
points. One point (abbreviated as pt.) equals 1/72 inch. You can type new values using any 
unit of measure.



Specifies the space Visio inserts between lines in a paragraph. You can specify a percentage 
of the type size; the default setting of 120 percent ensures that characters do not touch the 
line below. Otherwise, you can type an absolute size (for example, for 12-point type with two
extra points inserted between lines, set line spacing to 14 points).



Paste (Ctrl+V)

Edit menu (not in print preview window)
Pastes the shape, object, or text stored on the Clipboard into the center of the active 
drawing window. If a text block is open, text is pasted at the insertion point. The pasted item
remains on the Clipboard until you use the Copy or Cut command again.
If both programs support OLE, pasting embeds the object. Many Windows programs put 
objects on the Clipboard in several formats. The Paste command automatically chooses a 
preferred format. To select a particular format, choose the Paste Special command from the 
Edit menu. 
You can also use the Paste button. (If you are using an alternate toolbar, you may not have 
this button. Use ToolTips to identify the button.)

See also
Adding and replacing text
Copying shapes in the current drawing
Duplicate
Linking or embedding an object into a Visio drawing



Paste Special

Edit menu, drawing window
Pastes an object on the Clipboard into a Visio drawing in the format you choose.
Many Windows programs put information on the Clipboard in several formats. With this 
command, you can choose which format you want. For example, Visio automatically embeds
objects from OLE-compatible programs, but you can use the Paste Special command to 
paste the object as a non-editable bitmap.

DIALOG BOX OPTIONS
Source. Identifies the program used to create information on the Clipboard. If the program 
is unknown, displays Unknown.
As. Lists the default format and other formats that Visio can use. Usually these include 
Bitmap, Picture (a Windows metafile), and Text. Choose the format you want from this list.
Paste. Pastes the Clipboard contents onto the page in the specified format. Depending on 
the program that created the object, pasting may embed the object in Visio.
Paste Link. Pastes the Clipboard contents onto the page in the specified format and 
establishes a link to the original file.
Result. Displays a message of what happens when you click OK.
Display As Icon. Displays the OLE object as an icon in a drawing.
Tip: You can convert a Visio shape into a Windows metafile with the Paste Special command.
Select the shape, copy it to the Clipboard with the Cut command, and then use the Paste 
Special command to paste the shape as a metafile.

See also
Creating objects in another program from within Visio
Linking or embedding an object into a Visio drawing
Pasting information in a particular format



 Pencil tool (Ctrl+2)

Drawing tool menu
Use the pencil tool to draw both line and arc segments. You also use the pencil tool to edit 
shapes by dragging an endpoint, a control point, or a vertex. Drawing with the pencil tool 
relies on gesture recognition.

Line segment
To draw a line segment, drag the pencil tool in a straight line in any direction. The pointer 
displays a small line. Hold down the Shift key as you drag to draw lines at 45-degree 
intervals.

Arc segment
To draw an arc segment, drag the pencil tool along a curve. The pointer displays a small arc.
Tip: To constrain the shape of the arc, hold down the Shift key as you draw arcs.

See also
Adding segments to shapes
Changing shape angles by dragging a vertex
Deleting segments from shapes
Drawing freeform shapes
Drawing lines and arcs
Drawing shapes with several segments



 Pointer tool (Ctrl+1)

Use the pointer tool (on the toolbar) to select shapes so you can move, format, and size 
them. You also use the pointer tool to drag master shapes from stencils and drop them in the
drawing. When you move the pointer tool over a shape that you can select, the pointer turns
white.

Selection net
You can select more than one shape by dragging the pointer tool to form a selection net that
encloses all the shapes you want to select. The shape that is first in the stacking order 
becomes the primary selection.

Selection handles
The number of handles on a selected shape depends on its type and size. A 1-D arc or line 
segment has handles at each endpoint and one in between. A 2-D shape displays at least 
four handles and can display eight selection handles at a large enough view.

See also
Changing the size of a 1-D shape
Changing the size of a 2-D shape
Closing a shape
Selecting shapes



Previous Tile

View menu, print preview window
Displays the previous page or tile in the drawing.
You can use the Next Tile command on the View menu to display the next tile.
You can also use the Previous Tile button. Use ToolTips to identify the button.

See also
Previewing a drawing before you print
Print preview window
Showing page breaks
Tiling a large drawing onto multiple sheets of paper



Project Timeline Wizard

Tools menu, Run Add-on submenu, drawing window
Automates creating a project timeline in the Gantt chart style. You can create a timeline, 
then fill in the data after the Wizard is finished, or you can base the timeline on an existing 
Microsoft Excel worksheet or a text file.
By default, Visio looks for these column headings:

Task # Task Name Duratio
n

Start 
Date

End 
Date

Dependenc
y

Resource

If they're in a different order, you can rearrange them in the Wizard.

See also
Starting a new drawing with a template



Print (Ctrl+P)

File menu, drawing and print preview windows
Opens a dialog box where you specify which pages to print and other print options. Choosing
the OK button sends the drawing file to the selected printer.
You can also use the Print button to print the current page. Use ToolTips to identify the 
button.

DIALOG BOX OPTIONS
Printer. Displays the name and port of the current printer. To change the printer, choose 
Page Setup.

Properties. Specifies the resolution the printer should use. Depending on the printer, 
this list specifies the available resolutions as dots per inch (dpi), or as High, Medium, 
Low, or Draft. The higher the resolution, the better the print quality. For details, see the
documentation for your printer.
Print To File. Opens a dialog box in which you name a file where Visio will store all the
printer instructions necessary to print the drawing file. Visio saves this file on disk, 
rather than immediately sending it to the printer. You can use this file to print from any
computer connected to the type of printer specified for the drawing file, even if Visio is
not installed on the computer. 
Color As Black. If checked, Visio prints all colors as black to ensure that all shapes are
visible in the printed drawing. This is useful if a monochrome printer translates very 
light colors in a drawing to white rather than a shade of gray.

Print Range. Specifies which drawing pages to print. Choose All Pages or Current Page, or 
specify a range of pages.
Copies. Specifies the number of copies.

See also
Previewing a drawing before you print
Printing a background page
Printing a drawing
Printing a drawing to a file
Printing a page without its background
Showing page breaks



Prints every page in the drawing file in the order in which the foreground pages are stored in
the file. This is the default setting.



Prints the currently displayed drawing. If the page is a foreground, Visio prints the entire 
drawing. If the page is a background, Visio prints the background and the backgrounds on 
lower layers in the drawing, but does not print the foreground and backgrounds on higher 
layers in the drawing.



Prints only the specific range of pages identified by the values you type in the From and To 
boxes.



Tells Visio how many copies to print (default is 1).



Print Preview

File menu, drawing and print preview windows
Opens the print preview window and displays a drawing as it will appear when printed. When
you preview a drawing in the print preview window, Visio displays the drawing within the 
margins and tiles the drawing if the drawing page is larger than the page size. 
Note: If the Print Preview command is checked on the menu, choosing this command 
displays the drawing window.
You can use the Previous Tile and Next Tile commands to move from tile to tile or page to 
page.
To exit the print preview window, click the Close button or press the Esc key.
You can also use the Print Preview button. (If you are using an alternate toolbar, the Print 
Preview button may look slightly different or may not be available. Use ToolTips to identify 
the button.)

See also
Previewing a drawing before you print
Showing page breaks



Page Setup

File menu, drawing and print preview windows
Opens a dialog box where you specify a printer, change paper size and orientation, and set 
other print options.
To set up the drawing page, use the Properties dialog box. To automate setting up the 
drawing page, use the Page Layout Wizard.

DIALOG BOX OPTIONS
Paper. Identifies the paper size and source. For details about options, see your printer 
documentation.
Orientation. Specifies the page orientation as either portrait or landscape.
Margins. Defines an area that Visio can use to position the drawing on the paper. Enter 
values for Left, Top, Right, Bottom, and Center.
Reduce/Enlarge. Reduces or enlarges drawings for printing only. (The settings affect all 
drawings you select to be printed.) Choose either Scale or Fit On. This is not the same as 
scaling the drawing in the Properties Size & Scale dialog box, which affects only the current 
drawing. If the drawing page is the same size as the paper, typing a 1 in each box ensures 
that the drawing fits within the margins on the printed page.
Printer. Opens a dialog box in which you can choose either the default Printer or any of the 
printers listed in the specific printers list.

See also
Choosing a printer
Print
Setting margins



Identifies the printer specified in Windows as the default printer.



Lists all printers and output devices for which you have installed a driver. If you don't want 
to use the default printer, you can choose another from this list to print the current file 
without changing the default printer.



Specifies that a page be taller than it is wide.



Specifies that a page be wider than it is tall.



Lists the paper sizes available for the specified printer. Changing the paper size also affects 
the drawing page size if you check Same As Page Setup in the Size & Scale dialog box.



Lists paper trays, cassettes, manual feed, and other paper sources specific to the specified 
printer.



Specifies the distance from the left edge of the paper to the left margin.



Specifies the distance from the top edge of the paper to the top margin.



Specifies the distance from the right edge of the paper to the right margin.



Specifies the distance from the bottom edge of the paper to the bottom margin.



Centers a printed drawing that is smaller than the paper. Check Left/Right to center the 
drawing between the left and right margins or edges of the paper, and Up/Down to center 
the drawing between the top and bottom margins or edges of the paper.



Specifies how much to enlarge or reduce the drawings for printing. For example, type 75 to 
print drawings at three-quarters of their actual size.



Fits each drawing in the print job on the specified number of sheets across and down. 
Depending on the number of pages and the margins you specify, Visio enlarges or reduces 
the drawing. If the pages across and down are not proportional to the drawing's dimensions, 
Visio uses only those sheets needed to maintain the drawing's proportions.



Properties 

Master menu, stencil window
Changes the name, icon size, update status, and prompt for the selected master shape. 
Available only when a stencil is open as an original and the stencil window is active.

Click to display information about the dialog box.

See also
Opening a stencil
Specifying master shape characteristics



Displays the name that appears under the master icon in the stencil window. Master shape 
names can contain up to 31 characters.



Specifies how the name is aligned below the icon.



Specifies the icon size and when Visio should update the icon.



 Determines the icon's size. All icons in the stencils shipped with Visio are the default Normal
size. Tall is the same width, but twice the height; Wide is the same height, but twice the 
width. Double is twice as wide and twice as tall as Normal.



Determines when the master shape icon is updated. Automatic updates the master shape 
icon each time you edit the drawing of the master shape. Manual updates a master shape 
icon only when you choose Update Icon from the Master menu.



Displays the text that appears when you point to the master shape icon in the stencil 
window.



If you've created a stencil, preserves the formatting you've applied to the stencil's master 
shapes. For example, you've modified the shapes in the Office Layout stencil, created a 
stencil called My Office, then you drop a shape from the Office Layout stencil into the 
drawing.

If Match Master By Name On Drop is checked for the shapes on the My Office stencil, 
when you drop a shape into the drawing, Visio checks to see if the shape you're dropping 
matches any of the master shapes in the My Office stencil. If it finds a match, Visio 
formats the shape with the changes you made to the My Office master shape. 
If Match Master By Name On Drop is unchecked for the shapes on the My Office stencil, 
when you drop a shape from the Office Layout stencil, the shape is added to the drawing 
file with the default Office Layout formatting.



Properties

File menu
Opens a dialog box where you can type information that describes a file.
The description you type appears in the Open, New, and Stencils dialog boxes when you 
select a drawing file, template, or stencil to open. Entering a detailed description in the 
dialog box can help you locate and keep track of files more easily, especially if you work with
many files over a network or share them with a work group.
To add information, type it in the appropriate box. To edit information, select and then delete
or replace text.

Note: To view this command for a stencil, you must have an original stencil open.

DIALOG BOX OPTIONS
File Name. Displays the file's name if the file has been named and saved.
Folder. Identifies the path for the folder where the file is stored.
Based On. Lists the template on which the file is based.
Title. Displays a descriptive title for the file. You can type up to 63 characters.
Subject. Describes the contents of the file. You can type up to 63 characters.
Creator. Identifies the person who created or last updated the file. You can type up to 63 
characters.
Keywords. Displays words (up to a total of 63 characters) that identify general topics or 
other important information about the file, such as project name, client name, or version 
number.
Description. Displays important information (up to 191 characters) about the file, such as 
its purpose, recent changes, pending changes, and so on.
Save Preview Picture. Specifies to save a preview picture of the first page in the file to be 
used in the Open box and in Quick View.
You can use the Field command to create text fields that display file summary information 
entered in the dialog box. Any changes you make to information in the dialog box carry over 
to the fields.

See also
Lotus Notes Field
Saving a new drawing file



Properties Reporter Wizard

Tools menu, Run Add-on submenu, drawing window
Calculates values for custom properties that have been assigned in the Custom Properties 
dialog box.

See also
Starting a new drawing with a template



Protect Document 

Tools menu, drawing window
Protects document features from unauthorized changes. Other users can open the file to 
look at drawings, but they cannot edit the features you protect. You can protect individual 
features and also set a password.
Note: Use the Protect Document command to apply protection to all shapes in the drawing 
file. To protect individual shapes, use the Protection command.

DIALOG BOX OPTIONS
Password. Provides a text box where you can type a password. If you do, the Protect 
Document command changes to Unprotect Document. To turn off protection, choose 
Unprotect Document from the Tools menu, and enter the password. Be sure to make a note 
of your password so you don't forget it.
Protect. Lists features you can lock. Choose from styles, backgrounds, shapes, and master 
shapes.

See also
Protecting a file



Prevents users from creating and editing styles, although users still can apply styles.



Prevents users from deleting or editing background pages.



Prevents users from deleting or editing shapes if From Selection is also checked in the 
Protection dialog box.



Prevents users from creating, editing, or deleting master shapes, although they can still 
create instances of master shapes.



Protection 

Format menu, drawing and ShapeSheet windows
Opens a dialog box where you choose characteristics of a selected shape you want to lock. 
For example, if you lock a shape's dimensions, you cannot change the size of the shape.

DIALOG BOX OPTIONS
Protect. Lists characteristics you can lock on the selected shape. When an item is checked, 
the characteristic is locked against changes. You can choose as many of the characteristics 
as you want: Width, Height, Aspect Ratio, X-Position, Y-Position, Rotation, Begin Point, End 
Point, From Deletion, and From Selection.
All. Locks all options in the Protect section. The Protection section in the ShapeSheet 
includes protection options not available in the Protection dialog box, such as locking against
cropping, editing with any drawing tool, text editing and formatting, group editing, and 
recalculation of height and width when you size the shape.
None. Unlocks all options in the Protect section.

See also
Custom Properties
Displaying the ShapeSheet
Protecting shapes



Locks the shape's width against sizing. To lock a 1-D shape against rotation, you must lock 
its width.



Locks the shape's height against sizing.



Locks the ratio between a shape's height and width so its proportions won't change when 
you size it.



Locks the x (horizontal) position.



Locks the y (vertical) position.



Locks a shape against rotation using the rotation tool. A 1-D shape can still be rotated by 
dragging its endpoints. To lock a 1-D shape against rotation, you must lock its width.



Locks the beginning point of a 1-D shape to a specific location.



Locks the ending point of a 1-D shape to a specific location.



Locks the shape so it cannot be deleted.



Locks the shape so it cannot be selected. For this setting to take effect, you must also check 
Shapes in the Protect Document dialog box.



Quick Tour 

Help menu
Starts an introductory online tour of Visio. 



 Rectangle tool (Ctrl+5)

Drawing tool menu
Use the rectangle tool to draw rectangles or squares. Drag diagonally to draw a rectangle. 
Hold down the Shift key as you drag to draw a square. Both rectangles and squares are 
closed shapes.

Editing options
To size a rectangle or square, select it with the pointer tool and drag a selection handle. Drag
a corner handle to size the shape proportionally.
To edit the component line segments, select the rectangle with the pencil tool and then drag
vertexes and control points.

Fill styles
To apply a fill style or fill format to a rectangle, use the Fill command.

See also
Drawing ellipses and circles
Drawing freeform shapes
Drawing rectangles and squares



Redo (Ctrl+Y)

Edit menu
Reverses the most recent Undo command. If the action cannot be redone, the command is 
dimmed, or Visio beeps when you press the button.
Tip: You can use the Undo command to reverse the action of the Redo command.
You can also use the Redo button. (If you are using an alternate toolbar, you may not have 
this button. Use ToolTips to identify the button.)

See also
Duplicate
Paste
Repeat



Remove From Group

Shape menu, Grouping submenu, drawing window
Removes the selected shape(s) from the selected group without affecting the rest of the 
group in other ways. The removed shape remains in its current location.
First, select the group, and then click to select the shape you want to remove. The group 
displays green selection handles, but the shape has gray handles. When you choose Remove
From Group, the handles of the selected shape turn green, because it is now independent of 
the group.
Note: The group's selection rectangle is automatically updated when you remove a shape 
from a group. 

See also
Add To Group
Adding and removing shapes in groups
Convert To Group
Converting an object to Visio shapes
Editing and formatting a group
Group
Grouping and ungrouping shapes
Ungroup
Updating a group's selection rectangle



Reorder 

Edit menu, Drawing Page submenu, drawing window
Opens a dialog box where you can change the sequence of the drawing pages in the 
drawing file.

DIALOG BOX OPTIONS
Page. Lists all foreground pages by name in the order stored in the drawing file. Choose the 
page you want to move.
Update Page Names. When checked, renumbers pages that use default names (for 
example, Page-1, Page-2, and so on). Visio renumbers the pages to match the new order. 
This option doesn't affect pages you've renamed.
Move Up. Moves the page closer to the beginning of the file.
Move Down. Moves the page farther from the beginning of the file.

See also
Layer Properties
Rearranging foreground pages
Ruler & Grid



Repeat (F4)

Edit menu
Repeats the most recent action. If an action cannot be repeated, Visio dims the command 
and changes it to Can't Repeat.
Tip: To create evenly spaced copies of a shape, select the shape, and then press the Ctrl key
and drag to create the first copy and place it where you want. To space other copies evenly, 
press F4 for each additional copy.

See also
Duplicate
Paste
Redo



Replace

Edit menu, drawing window
Searches for and replaces specified text in shapes, stencils, the Properties dialog box, and 
data fields in the active drawing file.

Click to display information about the dialog box.

See also
Inserting fields into text
Searching and replacing text
Typing text into shapes



Specifies the text you want to find. You can type or paste text into this field. To search using 
text you previously searched for, click the down arrow, then choose the text from the list.



Specifies the text to use as replacement text. You can type or paste text into this field. To 
use text you previously used as Replace With text, click the down arrow, then choose the 
text from the list. To delete the text in the Find What box from the drawing file, leave the 
Replace With box empty.



Displays a list of special characters on which you can search: Tab Character, Manual Return, 
Optional Hyphen, Caret Character, or Any Character.



Specifies the range of the search.



Specifies to search only the current selection.



Specifies to search only the current page.



Specifies to search all pages in the open diagram.



Finds only those occurrences with the exact combination of uppercase and lowercase letters 
specified in the Find What box. Visio uses the case of letters as they were originally typed, 
regardless of whether the text has been formatted using Small Caps or All Caps formatting. 



Finds occurrences that are words and not parts of larger words. For example, if you type for" 
in the Find What box, Visio finds all instances of for" but ignores foreign." 



Finds and selects the next occurrence of the text in the Find What box.



Replaces the Find What text with the Replace With text, and then finds the next occurrence.



Replaces all occurrences of the Find What text with the Replace With text. To undo a Replace 
All, choose Undo from the Edit menu.



Reverse Ends

Shape menu, drawing window
Flips selected shapes horizontally and vertically. What was at the top appears at the bottom,
and what was on the left appears on the right.

See also
Flip Horizontal
Flip Vertical
Flipping and reversing shapes
Rotation tool
Size & Position



 Right Color box

Edit icon toolbar, edit icon window
Displays the color assigned to the right mouse button in the edit icon window. Choose the 
icon pencil or paint bucket tool and click with the right mouse button to change the pixels in 
the icon to this color. To change the assigned color, click with the right mouse button in the 
color palette.

See also
Editing parts of a master shape icon



Rotate Left (Ctrl+L)

Shape menu, drawing window
Rotates selected shapes (including freestanding text blocks) counterclockwise by 90-
degrees. A shape's text usually rotates with the shape. Use the Rotate Right command to 
rotate a shape clockwise. You can also use the rotation tool to rotate a shape by any 
increment.
You can also use the Rotate Left button and the Rotate Right button. Use ToolTips to identify 
the button.

See also
Flip Horizontal
Flip Vertical
Reverse Ends
Rotating shapes by 90-degree increments
Rotating shapes with the rotation tool
Size & Position



Rotate Right (Ctrl+R)

Shape menu, drawing window
Rotates selected shapes (including freestanding text blocks) clockwise by 90-degrees. A 
shape's text usually rotates with the shape. Use the Rotate Left command to rotate a shape 
counterclockwise. You can also use the rotation tool to rotate a shape by any increment.
You can also use the Rotate Left button and the Rotate Right button. Use ToolTips to identify 
the button.

See also
Flip Horizontal
Flip Vertical
Reverse Ends
Rotating shapes by 90-degree increments
Rotating shapes with the rotation tool
Size & Position



 Rotation tool

Rotation and crop tool menu
Use the rotation tool to rotate a shape by any amount. To rotate a shape, select it with the 
rotation tool, and then drag a round rotation handle. For finer control, drag the handle 
farther out from the shape. As you drag, the angle of rotation appears in the status bar at 
the bottom of the drawing page.
By dragging the center of rotation to a new location, you can rotate the shape around a 
point other than its center.
To rotate a shape by 90-degree increments, use the Rotate Left and Rotate Right commands.
You can also rotate a 1-D shape by using the pointer tool to drag one of its endpoints.

See also
Flipping and reversing shapes
Moving a 2-D shape's center of rotation
Rotating shapes by 90-degree increments
Rotating shapes with the rotation tool



Row

Insert menu, ShapeSheet window
Inserts a ShapeSheet row before the selected row. For example, to add a segment to a 
shape, insert a row in the Geometry section; to define a new connection point, insert a row 
in the Connection Points section.
To insert a row after the selected row, use the Row After command.

See also
Adding and deleting rows
Delete Row



Row After

Insert menu, ShapeSheet window
Inserts a ShapeSheet row after the selected row. For example, to add a segment to a shape, 
insert a row in the Geometry section; to define a new connection point, insert a row in the 
Connection Points section.
To insert a row before the selected row, use the Row command.

See also
Adding and deleting rows
Delete Row



Ruler & Grid

Tools menu, drawing window
Specifies the settings for the rulers and the grid lines. You can have separate settings for the
horizontal and vertical rulers and grid lines.

DIALOG BOX OPTIONS
Rulers. Specifies the ruler settings.

Subdivisions. Specifies how many tick marks are on the vertical or horizontal ruler. 
You can choose Fine, Normal, or Coarse.
Ruler Zero. Specifies the location of zero on the horizontal and vertical ruler. By 
default, the horizontal ruler's zero point is the top-left corner of the page, and the 
vertical ruler's zero point is the bottom-left corner of the page. For example, if you 
specify 3 inches for both rulers, the ruler zero is positioned to the right (for the 
horizontal ruler) and 3 inches toward the top (for the vertical ruler).

Grid. Specifies the grid lines settings.
Grid Spacing. Specifies how far apart the grid lines are. You can choose Fine, Normal, 
Coarse, or Fixed. Fine, Normal, and Coarse set the grid to a variable grid: the grid 
spacing changes as you zoom in and out. Fixed sets the grid to a fixed grid; if you 
zoom in or out, the spacing between grid lines does not change.
Minimum Spacing. For Fine, Normal, or Coarse, specifies the minimum grid lines. For 
Fixed, specifies how far apart the grid lines are.
Grid Origin. Specifies where to place the grid origin. For example, you could move the
grid in increments different from the ruler to align the grid with a shape or part of the 
diagram. By default, the grid origin is in the lower-left corner.

See also
Setting page display options



 Stamp tool

Connection tool menu
Use the stamp tool to create instances of the selected master shape in a drawing.
To stamp a shape, choose the stamp tool, and then select the master shape in the stencil. 
Click the drawing page where you want to position the center of the shape.
To create multiple shapes, drag a master shape to the drawing page, select the stamp tool, 
and then click on the page to make copies of the original shape.

See also
Copying shapes in the current drawing
Stamping master shapes



Rulers 

View menu, drawing and print preview windows
Hides or displays the rulers. When rulers are displayed, they appear along the top and left 
sides of the drawing window.
The intervals of the ruler correspond to the unit of measure you set in the Options dialog 
box. You control the subdivisions for the rulers in the Ruler & Grid dialog box.
Tip: To create guides and guide points, rulers must be visible.

See also
Changing the size of the drawing page
Ruler & Grid
Snapping shapes into place



Add-ons

Tools menu, Run Add-on submenu
Runs a Wizard or a special program that performs tasks and other operations in Visio. Some 
add-ons perform tasks immediately (such as the AutoCAD add-ons), while others run behind 
the scenes, giving you more options with Visio. 

DIALOG BOX OPTIONS
Select Add-on. Lists all add-ons in the Visio add-ons folder. Select the add-on you want to 
use.
About. Displays information about the selected add-on in a separate dialog box.

See also
Running add-ons



Save (Ctrl+S)

File menu
Saves changes to the file in the active window. If the file is new and you haven't saved and 
named it yet, Visio displays the Save As dialog box.
You can also use the Save button. (If you are using an alternate toolbar, the Save button 
may look slightly different. Use ToolTips to identify the button.)

See also
Opening an existing drawing file
Saving a new drawing file
Saving changes to an open file



Save As (F12)

File menu
The first time you save a file, this dialog box appears. After you name the file and click Save,
the Properties dialog box appears where you add file information and save a preview of the 
first page in the file (which is used in the Open dialog box and in Quick View).
You can also use this dialog box to:

· Name and save a drawing, stencil, or template file.
· Change the name or format of the open file.
· Save a file to a different disk location.
· Make a copy of a file, naming and saving the copy as a new file while leaving the 

original version intact.
· Save the workspace within a drawing, stencil, or template file.
· Export a Visio drawing or the selected shapes for use by another program. If you have 

appropriate export filters installed, Visio uses a matching filter to convert the drawing 
from its original format (.VSD) to the format you choose. The exported file will not be 
linked to a Visio file. You can export an entire Visio page or export selected shapes. 

After you save the file, it remains open. Use the Close command to close the file or the Exit 
command to quit Visio. To name and save all open windows, use the Save Workspace 
command.

DIALOG BOX OPTIONS
Save In. Displays the current folder. To change the folder, choose from the list.
Up One Level. Moves the Look In folder up one level in the hierarchy.
Create New Folder. Creates a new folder in the current level in the hierarchy.
List. Displays the list as an icon and a label.
Details. Displays the list as the name, size, type, and modified date.
File Name. Names the file. Change the name or create a new name by typing up to eight 
characters, followed by the filename extension. If you don't type an extension, Visio enters 
the extension displayed in the File Type box.
Save As. Lists formats for these files: Stencil (.VSS), Drawing (.VSD), Template (.VST), Visio 2.0 
Stencil (.VSS), Visio 2.0 Drawing (.VSD), and Visio 2.0 Template (.VST).
Save button. Saves the file with the selected options.
Save. Lists additional options for saving the file. Choose the Workspace and Read Only 
options.

See also
Exporting a drawing into another file format
Saving a file with the workspace option
Saving a new drawing file



Creates a new file that retains the positions of the open windows.



Saves the file so that it opens as read-only or can be opened as a copy. You cannot open the 
original file. Check this option to protect a file from changes.



Save Workspace (Alt+F12)

File menu
Opens a dialog box where you can name and save a workspace file. Workspace files save the
arrangement of windows currently open in the Visio window. Save a workspace when you 
have not finished a drawing file but need to close the file. When you want to resume work, 
Visio opens the workspace¾not just the drawing file¾so all windows are open and ready for 
you to continue where you left off.
Important: Before saving a workspace, you must use the Save As or Save command from 
the File menu to name and save any unnamed open files¾including the drawing file you're 
working on. If unnamed files are open, Visio asks if you want to save the workspace without 
them.

DIALOG BOX OPTIONS
Save In. Displays the current folder.
Up One Level. Moves the Look In folder up one level in the hierarchy.
Create New Folder. Creates a new folder in the current level in the hierarchy.
List. Displays the list as an icon and a label.
Details. Displays the list as the name, size, type, and modified date.
File Name. Names the workspace file. Filenames can be up to eight characters; Visio adds 
the .VSW filename extension to identify the file as a workspace.
Save As. Lists the filename extension for a workspace (.VSW).
Save. Saves the file with the selected options.

See also
Saving a file with the Workspace option



Section

Insert menu, ShapeSheet window
Opens a dialog box where you can choose which type of section to add to a ShapeSheet. 
Each section controls the behavior and appearance of some aspect of a shape.
By default, each ShapeSheet has at least one section that provides general positioning 
information. Visio builds in other sections required for a specific shape. Each ShapeSheet can
contain only one of each type of section except for Geometry sections.
Each path in a shape is represented by a Geometry section, which Visio numbers 
sequentially (Geometry 1, Geometry 2, and so on). You can add sections to modify a shape. 
Which sections are visible or hidden in the ShapeSheet depends on which sections are 
checked in the Sections dialog box.

DIALOG BOX OPTIONS
Show Sections. Lists the sections you can add to a ShapeSheet. Sections already included 
in the ShapeSheet of the selected shape and sections that are not available for the selected 
shape are dimmed.

Text Transform. Used to position text in relation to its shape. Without this section, 
text can only be positioned within the shape. With the Text Transform section, you can 
move the text; for example, you can rotate text independently of its shape.
Geometry. Lists the vertexes for a path in a shape. Each path requires its own 
Geometry section. Within each Geometry section, a row describes each line and each 
arc segment in the path.
Connection Points. Specifies the x- and y-coordinates for each connection point on a 
shape.
Controls. Specifies the x- and y-coordinates, behavior, and anchor point for each 
control handle defined for a shape.
Scratch. Contains cells where you can enter and test formulas or calculate 
intermediate values that can be referred to in other sections.
Text Fields. Contains formulas inserted in a shape's text block using the Field 
command. The formulas appear in this section in the same order as in the text block.
Actions. Inserts a section from which you can add an action to a shape or page.
Layer Membership. For a shape, inserts a section in which you can change the 
shape's layer assignment.
Layers. For the page, inserts a section in which you can view the page's layer 
properties.
User-Defined Cells. Inserts a section in which you can add user-defined cells for a 
shape or page.
Custom Properties. Inserts a section in which you can add custom properties for a 
shape or page.
Ruler & Grid. Inserts a section in which you can enter values for the page's ruler and 
grid.

See also
Adding and deleting sections



Custom Properties section
Delete Section
Layer Properties section
Sections
Sections overview
Show ShapeSheet



Sections

View menu, ShapeSheet window
Opens a dialog box where you choose which ShapeSheet sections are displayed for the 
selected shape.

DIALOG BOX OPTIONS
Section. Indicates the sections you want to display. Check to display and uncheck to hide 
any number of sections. (Sections not available for the selected shape are dimmed.) When 
you activate the ShapeSheet window, all the checked sections included in the ShapeSheet 
are visible.
All. Displays all sections.
None. Displays no sections.
You can also collapse and expand a section by clicking its title. When a section is collapsed, 
you see only its title; when it is expanded, you see all of its rows.
Tip: If you use the Section command to add a section to the ShapeSheet, but you don't see 
the section in the ShapeSheet window, use the Sections command to make sure the section 
is set to display.

See also
Collapsing and expanding sections
Showing and hiding sections



Select All (Ctrl+A)

Edit menu; drawing, stencil, and edit icon windows
Selects all shapes, guides, and objects from other programs on a drawing page. To select all 
of a particular kind of item, use the Select Special command.

Note: To view this command for a stencil, you must have an original stencil open.

See also
Selecting shapes



Select Special 

Edit menu, drawing window
Opens a dialog box where you can choose one or more types of items you want to select. 
When you click OK, Visio selects all items of the specified type(s) on the page.

DIALOG BOX OPTIONS
Select By. Specifies the type of objects you want to select.

Shape Type. Lists the types of items you can select all at once. Select any number of 
these types: Shapes, Groups, Guides, OLE Objects, Metafiles, Bitmaps.
Layer. Lists the available layers from which you can select.

All. Click this button to select all types in the Select By list.
None. Click this button to uncheck all types in the Select By list.

See also
Select All
Selecting shapes



Selects all shapes on the page.



Selects all groups on the page.



Selects all the guides and guide points on the page.



Selects all objects from other programs saved in the .WMF (Windows metafile) format or 
objects inserted into Visio by selecting Windows Metafile Data in Paste Special.



Selects all objects from other programs saved as bitmaps.



Selects all linked or embedded objects to a container.



 Selection net tool

Edit icon toolbar, edit icon window
Use the selection net tool to select a rectangular area of a master shape icon. Drag a 
selection net around the area of the bitmap you want to select. You can then drag to move 
the selected area or use the commands on the Edit menu to manipulate the selected area.

See also
Editing parts of a master shape icon
Pointer tool



Send

File menu, drawing and print preview windows
Sends Visio drawings through electronic mail programs that support Messaging Application 
Program Interface (MAPI) or Common Messaging Call (CMC).

See also
Sending Visio drawings through electronic mail



Send Backward 

Shape menu, drawing window
Moves selected shapes back one position in the stacking order. If multiple shapes are 
selected, they all move back one position and keep their original stacking order in relation to
each other.

See also
Bring Forward
Bring To Front
Changing the stacking order of shapes
Send To Back



Send To Back (Ctrl+B)

Shape menu, drawing window
Moves selected shapes behind other shapes in the stacking order. If multiple shapes are 
selected, they keep their original stacking order in relation to each other.

See also
Bring Forward
Bring To Front
Changing the stacking order of shapes
Send Backward



Shadow

Format menu, drawing and stencil windows
Applies or changes the shadow for selected shapes. 
You can also use the Shadow button. Use ToolTips to identify the button.

DIALOG BOX OPTIONS
Pattern. Determines the shadow pattern. Choosing None deletes a shadow.
Foreground. Determines the shadow foreground color. For example, in a grid pattern, the 
grid displays the foreground color.
Background. Determines the shadow background color. For example, in a grid pattern, the 
spaces between the grid show the background color.
Apply. Applies a shadow format without closing the dialog box.
To change the distance and angle that a shadow is offset from the shape, use the Properties 
command on the Tools menu.

See also
Changing the shadow offset
Fill
Formatting fills and shadows



Shape Help

Stencil master and shape shortcut menus
Displays online Help for a specific shape in a stencil. This command is available only when a 
Windows online Help topic is associated with the shape.
You can activate the Shape Help command by entering syntax in the Special dialog box. For 
information on developing Microsoft Windows online Help, see the Microsoft Software 
Development Kit (SDK) documentation.
To associate a help topic to a double-click action, use the Double-Click command on the 
Format menu.

See also
Getting quick access to common commands
Specifying a shape's double-click behavior



Shape Report

Tools menu, drawing window
Generates an inventory based on the shapes in a diagram and the fields associated with the 
shapes. 

DIALOG BOX OPTIONS
Destination. Specifies where you want the inventory to be generated.

Clipboard. Copies the inventory to the Windows Clipboard.
File. Saves the inventory as a text file that can be exported. 
Browse. Displays a box in which you can find an existing file.

Format. Specifies the Text Delimiter and Field Separator options that the program you're 
exporting the inventory to can read.

Text Delimiter. Specifies to enclose text in double-quotes or single-quotes or to use 
no delimiter.
Field Separator. Specifies to insert a separator (such as a tab) between data.

Options. Specifies column heading and inventory total options.
Display Column Headings. Displays field names at the top of the report columns.
Total Identical Items. When checked, finds the total number of duplicate shapes. 
When unchecked, lists each shape individually.
Select. Displays the Select box in which you can select the fields to include in the 
inventory.

See also
Adjusting the data format
Choosing inventory content
Generating an inventory



Show Drawing Page

Window menu, stencil window

Note: This command is available only when you have an original stencil open.
Opens a dialog box that lists current drawing pages. Choose a page to display in the drawing
window. Show Drawing Page is available only when a stencil window is active.

DIALOG BOX OPTIONS
Select Page. Displays a list of background and foreground pages in the drawing file. 
Foreground pages are listed in bold type; background pages are listed in normal type.

See also
New Window
Opening an original stencil



Show Master Shapes

Window menu, drawing window
Opens the drawing file stencil for the current drawing file. The drawing file stencil contains a 
copy of every master shape that appears in the current drawing file. Instances in a drawing 
file remain linked to their master shapes in the drawing file stencil (unless you ungroup the 
instance or delete the master).
To use the command, make sure the drawing window is active by clicking the title bar of the 
drawing window. The drawing file stencil window displays the name of the drawing file, 
followed by "Stencil."
When you select a master shape in a drawing file stencil, you can use the Edit Master 
command to edit a master shape. Visio updates all instances of the master in the drawing 
file.

See also
Editing a master shape in the drawing file stencil
New Master



Show ShapeSheet 

Window menu, drawing window
Opens the ShapeSheet for the selected shape or the page.
Every shape you draw with Visio or object you insert from another program has a 
ShapeSheet. When you group shapes, Visio retains the ShapeSheet for each shape in the 
group and creates a separate ShapeSheet for the group.
When you open the ShapeSheet window, the menu bar changes and displays menus and 
commands for working in the ShapeSheet. What you see in a ShapeSheet depends on which 
shape is selected and how you have set ShapeSheet display options with the Values, 
Formulas, and Sections commands.

See also
Displaying a ShapeSheet
Sections overview



Single Tile

View menu, print preview window
Displays a single page or tile of a drawing as it appears when printed. You can view the 
entire drawing by choosing Whole Page from the View menu.
You can also use the Single Tile button. Use ToolTips to identify the button.
Alternatively, you can use the Zoom In and Zoom Out buttons.

See also
Previewing a drawing before you print
Print preview window
Showing page breaks
Tiling a large drawing onto multiple sheets of paper



Size & Position 

Shape menu, drawing and stencil windows
Determines the selected shape's position on the page, its dimensions, and its degree of 
rotation. The dialog box options vary depending on whether a 1-D or 2-D shape is selected.
For a 1-D shape, the options in the Parameters section vary depending on which option you 
choose in the Show section. You can change the size and position of a 1-D shape by 
changing values in the Parameters section of the dialog box.

Click to display information about the dialog box options for a 1-D shape.

Click to display information about the dialog box options for a 2-D shape.

Tip: When a shape's size and position are displayed on the status bar, you can click the 
status bar to open the Size & Position dialog box.
See also
Determining a 1-D shape's size and location
Determining a 2-D shape's size and location
Object Transform section



Displays the shape's beginning and ending points and its height in the Parameters section.



Displays the shape's beginning point, angle of rotation, length, and height in the Parameters 
section. Visio calculates the ending point. 



Displays the shape's ending point, angle of rotation, length, and height in the Parameters 
section. Visio calculates the beginning point.



The x-coordinate of the beginning point of the 1-D shape in relation to the origin of its 
parent.



The y-coordinate of the beginning point of the 1-D shape in relation to the origin of its 
parent.



The x-coordinate of the ending point of the 1-D shape in relation to the origin of its parent.



The y-coordinate of the ending point of the 1-D shape in relation to the origin of its parent.



The height of the shape.



The shape's current angle of rotation in relation to its parent.



Applies a setting without closing the dialog box.



Specifies the width, height, and angle of the shape. Enter a new value to resize the shape.



The width of the shape.



When checked, flips the shape horizontally.



When checked, flips the shape vertically.



Specifies the position of the x- and y-coordinates of the shape's local pin (center of rotation) 
in relation to the page. Enter a new value to change the position of the pin.



Specifies the position of the x-coordinate of the shape's local pin (center of rotation) in 
relation to the page. Enter a new value to change the position of the pin.



Specifies the position of the y-coordinate of the shape's local pin (center of rotation) in 
relation to the page. Enter a new value to change the position of the pin.



Changes the location of the shape's local pin (center of rotation) in relation to the page. 
Choose a section to change the pin location.



Size & Scale

Edit menu, Drawing Page submenu, drawing page
Determines the drawing page size and scale. You can also display this dialog box by 
choosing the Size/Scale button in the Properties dialog box.

Click to display information about the dialog box.

Note: If you choose No Scale in the Size & Scale dialog box and also choose 100% scale in 
the Page Setup dialog box, the printed drawing will be the same size as the drawing page. 
Changing the scale of a drawing page does not change the scale of a background page 
assigned to it.
Tip: If you specify a scale other than No Scale, you can specify the size of the drawing in 
scaled units (shown in Visio's rulers) by setting dimensions in the Drawing Size option. You 
can specify the size of the drawing page in units by choosing Custom in the Page Size 
option. For example, If you want the drawing to be 40 feet by 50 feet in scaled units, specify 
a scale of 1 inch = 1 foot. Then, you can type either 40 feet by 50 feet in the Dimensions 
option or 40 inches by 50 inches in the Custom option.
See also
Changing the size of the drawing page
Setting a drawing scale



Specifies the size of the drawing page. Changing the orientation of the drawing page by 
changing its size does not change the paper orientation specified with the Page Setup 
command. Make sure the drawing page size and orientation you choose will fit on the 
specified paper size and orientation.



Select Tall to make the page taller than it is wide. Or select Wide to make the page wider 
than it is tall.



Selects a size from a list of standard English and metric page sizes. Options in the list reflect 
page orientation as well as size. The width is listed first and then the height. 



Changes the list in the Page Size box to include English standard paper sizes, such as letter, 
legal, and so on.



Changes the list in the Page Size box to include Metric standard paper sizes, such as 210mm
x 149mm.



Changes the list in the Page Size box to include ANSI Engineering standard paper sizes, such
as 8.5in x 11in.



Changes the list in the Page Size box to include ANSI Architectural standard paper sizes, 
such as 9in x 12in.



Matches the paper size specified in the Page Setup dialog box. 



Specifies a custom width and height for the page.



Creates a drawing page just large enough to contain the shapes.



Lets you enter a custom drawing size in the Page Size box.



Specifies the ratio of the printed drawing to the drawing page. 



If the drawing should print at its actual size, choose No Scale. If you specify No Scale and 
chose Same As Printer in the Drawing Size section, the drawing page and printed drawing 
are the size specified for paper with the Page Setup command on the File menu.



Changes the list in the Scale box to include Metric standard scales, such as 1:100.



 Changes the list in the Scale box to include English measurements such as 3/32" = 1' 0".



Changes the list in the Scale box to include English measurements such as 1" = 10' 0".



Changes the list in the Scale box to include English measurements such as 1/32:1.



Sets a custom ratio of page size to drawing size. For example, at 1 inch = 25 feet, a shape 
which measures 1 inch (when printed at 100 percent) measures 25 feet on Visio's rulers.



Changes the page size to match the size of the drawing page specified in the Drawing Page 
Properties command on the Edit menu.



SmartShape Wizard

Tools menu, Run Add-on submenu, drawing window
Automates adding smart behavior to shapes you create, including text behavior, control 
handle connectors, hidden notes, custom properties, and special protection options.

See also
Starting a new drawing with a template



Snap & Glue (Alt+F9)

Tools menu, drawing window
Specifies whether snap and glue are active and what to snap and glue shapes to. You can 
change these settings at any time without affecting shapes that are already positioned or 
glued. You can check any number of items to snap and glue to. For aligning shapes, the most
useful options are ruler subdivisions, grid, and guides. The other options are most useful 
when you are gluing shapes.
You can change the snap and glue strength setting in the Options dialog box.
Tip: Press F9 to toggle glue on or off, and press Shift+F9 to toggle snap on or off.
You can also use the Snap and Glue buttons to turn snap and glue on or off. Use ToolTips to 
identify the button.

Click to display information about the dialog box.

See also
Setting glue options
Snapping shapes into place



Activates snapping so shapes snap to items checked in the Snap To section.



Activates glue so shapes glue to items checked in the Glue To section.



When checked, you can snap to these items.



When checked, you can glue to these items.



Specifies the distance in pixels that the grid, guides, rulers, or points (connection points, 
vertexes, handles) pull when snapping or gluing is on.



Select dialog box

Tools menu, Shape Report dialog box
Specifies the fields to include in an inventory.

DIALOG BOX OPTIONS
Available Fields. Lists the fields you can inventory, including custom property fields you 
entered in the ShapeSheet. The list includes data you associated with a shape using the 
Special command on the Format menu.
Add>>. Moves selected fields from the Available Fields list to the Inventory Fields list.
<<Remove. Removes selected fields from the Inventory Fields list.
Up. In the Inventory Fields list, moves a field up in the selected fields order.
Down. In the Inventory Fields list, moves a field down in the selected fields order.
Inventory Fields. Lists the inventory fields you've chosen to include.
Field. Specifies the field used for sorting.

Name. Specifies the name of the field used for sorting.
Sort. Sorts the inventory by the selected field.

See also
Adjusting the data format
Choosing inventory content
Generating an inventory



Spelling (F7)

Tools menu, drawing window
Checks the spelling of text in shapes, stencils, summary information, and data fields in the 
active drawing file.
You can also use the Spelling button or press F7. (If you are using an alternative toolbar, the 
Spelling button may look slightly different or may not be available. Use ToolTips to identify 
the button.)

DIALOG BOX OPTIONS
Not In Dictionary. Displays a word not found in the open dictionaries.
Change To. Type or select a word from the Suggestions list to replace the misspelled word.
Suggestions. Lists replacement words from the open dictionaries.
Add Words To. Select the dictionary to which you want to add the word. For example, a 
person's name might not be in the dictionary.
Ignore. Ignores the word and continues checking.
Change. Changes the word to the one in the Change To box.
Add. Adds the word to the dictionary selected in the Add Words To box.
Ignore All. Ignores all instances of the word and continues checking.
Change All. Changes all instances of the word to the one in the Change To box.
Options. Displays the Spelling Options box, in which you can specify default settings for the
Spelling command.
Cancel. Closes the Spelling box, but does not reverse any changes you have made.

See also
Checking the spelling of text
Searching and replacing text
Typing text into shapes



Spelling Options dialog box

Tools menu, Spelling dialog box
Specifies default settings for the Spelling command.

DIALOG BOX OPTIONS
Search. Specifies where Visio checks the spelling of text.

Selection. Specifies to check the spelling of only the current selection.
Page. Specifies to check the spelling of only the current page.
All Pages. Specifies to check the spelling of the entire drawing file.

User Dictionaries. Specifies the dictionaries Visio uses to check the spelling of text.
Active. Specifies the dictionaries Visio is currently using to check the spelling of text.
Add. Opens the Add User Dictionary box, in which you can add a new dictionary to the
list of active dictionaries.
Remove. Removes a dictionary from the list of active dictionaries.

Use MS Word Dictionaries. If you have Microsoft Word installed, check this option to use 
its dictionary.
Ignore Words With Numbers. Check this option if you want Visio to ignore words that 
have numbers in them.

See also
Checking the spelling of text
Searching and replacing text
Typing text into shapes



Special

Format menu, drawing and ShapeSheet windows
Opens a dialog box that identifies the selected shape and provides three text boxes where 
you can type information about the shape.

DIALOG BOX OPTIONS
ID. The sequential ID number Visio assigns to the selected shape. The number is based on 
the order in which shapes are created. The first shape you create in the drawing is 1, the 
second is 2, and so on.
Master. Displays the name of the master shape if the shape is an instance of a master. If a 
shape is a component shape in a master shape, the section displays the name of the master
and the name or number of the component shape.
Type. Identifies the type of shape or other object.
Name. Identifies the shape by its default Visio name or a name you assign. You can type up 
to 31 characters for the name. Note: You cannot use the open rounded bracket ( { ) as the 
first character of a shape name.
Help. Enables the Shape Help command by associating the selected shape with a help 
keyword. The syntax is:

FILENAME.HLP!keyword or FILENAME.HLP!#Number
where filename is the Windows help file, keyword is the index term associated with 
the help topic, and number is a numeric ID which is referenced in the MAP section of 
the help project file (HPJ). For information on developing Microsoft Windows online 
Help, see the Microsoft Software Development Kit (SDK) documentation.

Copyright. Displays copyright information for the selected shape.
Data 1, Data 2, and Data 3. Provides room for information you want to supply about the 
shape. You can type up to 63 characters in each box.
Note: The default path for shape and stencil help files is the Visio Help folder, although 
VISIO.HLP resides in Visio's main folder. You can change the default path in the File Paths 
dialog box, which remains in effect until you set it again.
To enter descriptive information about the file, use the Properties command.
If you use the Field command to create a text field, one of the category options is Object 
Info. The Object Info fields (Data 1, Data 2, Data 3, ID, Master, Name, and Type) display the 
information you enter in the Special dialog box. Any changes you make to information in the 
Special dialog box are displayed in the fields.

See also 
Custom Properties
Inserting fields into text



Status Bar 

View menu; drawing, stencil, and print preview windows
Displays or hides the status bar at the bottom of the Visio window. The status bar is 
displayed when the command is checked.
The status bar provides information related to the task you are doing. For example, when 
you point to a master shape on a stencil, the status bar shows a brief description of the 
master shape. As you drag a shape, the status bar displays the shape's position.

See also
Setting display options



Stencil Report Wizard

Tools menu, Run Add-on submenu, drawing window
Automates creating a report showing all shapes on a stencil, creating a catalog of shapes.

See also
Starting a new drawing with a template



Style

Format menu, drawing window
Applies styles to selected shapes. The styles listed in the dialog box are the same as those 
listed in the style boxes.

DIALOG BOX OPTIONS
Text Style. Lists styles that contain text formats.
Line Style. Lists styles that contain line formats.
Fill Style. Lists styles that contain fill formats.
Preserve Local Formatting. When checked, this option prevents attributes defined in a 
style from overriding formatting applied directly to selected shapes. For example, if a text 
style specifies italic text, and you've already used the Bold button to make the text bold, 
Visio leaves the text bold but also makes it italic.
Apply. Choose this button to apply styles without closing the dialog box. If necessary, drag 
the dialog box by its title bar to make selected shapes visible on the page.

See also
Applying styles from a style list
Define Styles



Subtract

Shape menu, Operations submenu, drawing window
The Subtract command works like a cookie cutter. Overlap two shapes, select the first one, 
and then the second. Choose Subtract to delete the second shape you selected, leaving its 
shape cut into the first. (The overlapping segment of the second shape is "subtracted" from 
the first.)
When you use this command on two or more shapes, Visio creates a ShapeSheet for the new
shape and deletes the ShapeSheets of the original shapes.

See also
Combine
Fragment
Subtracting shapes



Switch Sides

Right-click a docked stencil's title bar
Docks the stencil on the opposite side of the drawing window.

See also
Arranging master shapes in a stencil
Arranging stencils
Arranging Visio windows



Tabs (Ctrl+F11)

Format menu, drawing and ShapeSheet windows
Adds, deletes, and adjusts tab stops for paragraphs or for a selected shape's entire text 
block.
You can add up to 10 tab stops and delete tabs you no longer want. To move a tab, change 
the settings in the Edit Tab section. To define a new tab, type the tab's position in the 
Position box, and then select the alignment from the Alignment list.

Click to display information about the dialog box.

See also
Adding and deleting tabs



Lists the current tab stops. The left side of the box lists tab positions, and tab alignment is 
listed on the right.



Sets or modifies tab position and alignment. If no tab is selected, the settings are blank.



Shows the distance of the tab stop from the left margin. To move the tab, change the 
setting.



Shows the alignment of the selected tab. To change the alignment, choose between Left (the
left side of the text aligns with the tab stop), Center (centers the text on the tab stop), or 
Right (the right side of the text aligns).



Adds a tab stop at the specified Position and Align settings. The new tab appears in the Tab 
Stops list.



Deletes the tab stop selected in the Tab Stops list.



Applies all the tabs in the Tab Stops list to the selected text without closing the dialog box.



Applies changes, closes the Tabs dialog box, and displays the Font dialog box. To apply 
changes without closing the Tabs dialog box, use the Apply button.



Text Block (Alt+F11)

Format menu, drawing and ShapeSheet windows
Sets the vertical alignment, margins, and background color for the selected text block.
You can also use text alignment buttons (available only when text is selected). Use ToolTips 
to identify the button.

DIALOG BOX OPTIONS
Vertical Alignment. Specifies the vertical position of the text in relation to the top and 
bottom margins of the text block. Choose from Top, Middle, or Bottom.
Margins. Specifies the distance between the text and each edge of the text block. To 
change margins, type a number in the appropriate box: Top, Left, Bottom, or Right.
Text Background. Specifies whether the text block is transparent or opaque. For an 
invisible background that reveals shapes behind the text, choose None (Transparent).
Apply. Applies text block formats to the selected shapes without closing the dialog box.
Font. Applies formats, closes the Text Block dialog box, and displays the Font dialog box.

See also
Aligning text in the text block
Text tool



Aligns the top line of text with the top margin.



Centers the text between the top and bottom margins so the distance from the top line to 
the top margin equals the distance from the bottom line to the bottom margin.



Aligns the bottom line of text with the bottom margin.



 Text block tool

Text tool menu
Use the text block tool to select a shape's text block. You can size, move, and rotate the text
block independently of its shape.
To rotate a text block, select one of the rotation handles, and then drag. To move a shape, 
click inside the center of the shape or on the green border, and then drag. To size a shape, 
click one of the selection handles, and then drag.

See also
Aligning and indenting paragraphs
Aligning text in the text block
Moving a text block
Rotating a text block
Setting line spacing
Setting text block margins
Setting the text block background color
Sizing a text block



Field (Ctrl+F9)

Insert menu, drawing window
Inserts a text field into a text block. Visio inserts a field at the insertion point or, if a shape is 
selected but its text block is not open, replaces the shape's existing text with the field.

Click to display information about the dialog box.

Tip: Some field categories, such as Date/Time, are useful for providing up-to-the-minute 
information in final drawings. Other field categories, such as Document Info, help you keep 
track of information as you work on a drawing.

See also
Building a formula by pasting
Inserting fields into text
Lotus Notes Field
Properties
Special
Using a custom formula in a field



Lists the field categories. Insert a text field to display information in drawings.



Lists the fields within the selected category. For example, if you choose Geometry, the Field 
box displays options for Height, Width, and Angle.



Determines the format of the selected field. For example, if you chose Angle in the Field box,
you can choose from the General, Radians, and Degrees options.



If you chose Custom Formula as the category, enter the formula in the formula box. To 
create a formula, use the same functions you use in the ShapeSheet.



Enter ShapeSheet functions to create a formula.



Uses system information to track the Creation Date, Creation Time, Current Date, Current 
Time, Last Edit Date, Last Edit Time, Print Date, and Print Time.



Uses information entered in the Properties dialog box to track Creator, Description, Folder, 
Filename, Keywords, Subject, and Title.



Uses the shape's width, height, and angle information. Use the Width field for dimension 
lines, or the Angle field to show how far a shape is rotated from its original position. Use any 
Geometry field to automatically update technical specifications in a drawing.



Uses information entered in the Special dialog box to track Data 1, Data 2, Data 3, ID, 
Master, Name, and Type.



Uses information entered in the Properties or Page dialog box to track Background Name, 
Number of Pages, and Page Number.



Uses information entered in the Lotus Notes Field dialog box to manage information such as 
shape details, shape measurements, and date of creation.



 Text tool 

Text tool menu
Use the text tool to create a freestanding text block (the shape is invisible) or activate an 
existing text block so you can edit the text. To create new freestanding text, choose the text 
tool to place an insertion point, and then type.
If you want the text block to have a certain line length, drag to create an area of the width 
you want, and then type.
Tip: To add text to a shape or replace all of a shape's text with new text, select the shape 
with any tool and start typing.

See also
Adding independent text to a drawing
Changing font attributes
Pointer tool
Text block tool
Typing text into shapes



Tile 

Window menu
Sizes and arranges open windows side by side so that all windows are visible. 
Shortcut: Press Shift+F7 to tile horizontally, or press Ctrl+Shift+F7 to tile vertically.
Tip: To enlarge the active window so it fills the screen, choose the Maximize button in the 
upper-right corner of the window. Choose the Restore button to return the window to its 
previous tiled size.

See also
1, 2, 3, 4 More Windows
Arranging Visio windows
Cascade



Toolbars

View menu; drawing, stencil, and print preview windows
Changes the Visio toolbar.
DIALOG BOX OPTIONS:
Style. Choose the toolbar style you want displayed by Visio. Options include Microsoft 
Office, Lotus SmartSuite, and Novell PerfectOffice.
Display Options. Choose display options for the toolbar. Options include Color Buttons, 
Large Buttons, and Show ToolTips.
Tip: Right-click anywhere on the toolbar to change display options.

See also
Lotus SmartSuite
Microsoft Office
Novell PerfectOffice
Switching toolbar sets



Undo (Ctrl+Z)

Edit menu
Reverses the most recent action. You can reverse up to ten actions, one at a time.
You can also use the Undo button. (If you are using an alternate toolbar, you may not have 
this button. Use ToolTips to identify the button.)
You can undo most but not all actions. If an action can be undone, the command is Undo, 
followed by the type of action. When you cannot undo an action, this command changes to 
Can't Undo. You can reverse an undo action by using the Redo command from the Edit 
menu.

See also
Redo



Ungroup (Ctrl+U)

Shape menu, Grouping submenu, drawing window
Ungroups the selected group, leaving the individual shapes that belong to the group 
selected. Also, converts a pasted or imported Windows metafile (.WMF) or an OLE object into 
individual shapes.
When you ungroup a group, Visio deletes the group's ShapeSheet and leaves the individual 
shapes' ShapeSheets intact.
Tip: If a shape within the group is a group, it remains a group, and you must select and 
ungroup it to make individual shapes of its components.

See also
Add To Group
Convert To Group
Group
Grouping and ungrouping shapes
Remove From Group



Union 

Shape menu, Operations submenu, drawing window
Creates one closed shape from overlapping shapes, which inherits the text and formatting of
the first shape you select. If the shapes do not overlap, Visio creates a single shape that 
looks the same as the shapes you united, except that it uses the text and formatting of the 
shape you selected first.
When you unite two or more shapes, the ShapeSheets for the shapes you unite are deleted, 
and Visio creates a ShapeSheet for the new shape.

See also
Combine
Fragment
Intersect
Subtract
Uniting shapes



Unprotect Document 

Tools menu, drawing window
Opens a dialog box where you can cancel the protection options set in the Protect Document
dialog box. Available only if you used the Protect Document command previously to lock a 
drawing file from editing.

DIALOG BOX OPTIONS
Password. Type the password that was entered in the Protect Document dialog box. If you 
used a password, you must type it to cancel the protection.

See also
Protecting a file



Update Alignment Box

Tools menu, drawing window
Adjusts the selection rectangle of a group to fit its new dimensions. You can use this 
command after deleting or adding a shape to a group, or changing the size of a shape in the 
group, in the group window. You can also use this command after editing the vertexes of a 
shape in the ShapeSheet.

See also
Adding and removing shapes in groups
Editing and formatting a group
Editing the shapes in a group
Updating a group's selection rectangle



Update Icon 

Master menu, stencil window
Updates the selected master shape icon to look like the master shape. 
If you specify automatic updating for the icon in the Properties or New Master dialog box, 
Visio automatically changes the master shape icon to look like a miniature of the master 
shape when you change the master shape.
If you specify manual updating in the Properties or New Master dialog box and create a 
custom master shape icon, you can use the Edit Icon command to make the icon look 
different from the master shape. At any point, you can use the Update Icon command to 
change a custom icon to a miniature of the master drawing.

See also
Creating a master shape icon
Editing a master shape in a stand-alone stencil
Opening a stencil



Values

View menu, ShapeSheet window
Displays the values of ShapeSheet cells instead of formulas. To display formulas instead of 
values, use the Formulas command.

See also
Displaying values and formulas in cells



Whole Page (Ctrl+W)

View menu, drawing and print preview windows
Displays the entire page in the drawing or print preview window.
You can also use the Whole Page button in the print preview window. Use ToolTips to identify 
the button.
Or, while working in the drawing window, you can choose Page from the Zoom box on the 
toolbar.

See also
Zooming in and out of a drawing



Zoom (Custom) (F6)

View menu, Zoom submenu, drawing window
Adjusts the view of a page. You can choose from percentage options to display a page in 
proportion to its actual size (which corresponds to the 100% option) or choose Custom and 
type a percentage to specify the view. The range of the view depends on the drawing size.
Zoom to the size that best suits your work; for example, viewing a very small drawing 
probably requires magnification.
You can also use the Zoom box on the toolbar. Use ToolTips to identify the button.

DIALOG BOX OPTIONS
Magnification. Choose Whole Page to display the entire page and part of the surrounding 
pasteboard. Standard percentages from 50 to 400 percent, as well as Whole Page and Page 
Width, are available with the Zoom command or in the Zoom box; or type a number in the 
Percent box.
Options. Specifies zoom options.

Zoom When Editing Text. When this option is checked, Visio zooms in on text 
automatically (depending on the font size and the current view) when you select a 
shape and type, double-click instances of certain master shapes, or select a shape with
the text tool or text block tool.
Center Selection In Window. If any shapes are selected when you adjust the view, 
Visio zooms in on the center of the selection. If nothing is selected, Visio centers the 
new view in the center of the previous view.

Tip: When you hold down the Ctrl+Shift keys, the pointer turns into a magnifying glass. 
Clicking the left mouse button enlarges the view; clicking the right mouse button reduces 
the view. Whether you enlarge or reduce, Visio centers the new view wherever you click.

See also
Actual Size
Zooming in and out of a drawing



Zoom In

View menu, print preview window
Magnifies the page or tile to its actual size in the print preview window. Zoom to the size 
that best suits your work; for example, viewing a very small drawing probably requires 
increased magnification.
You can also use the Zoom In button. Use ToolTips to identify the button.

See also
Previewing a drawing before you print
Print preview window
Zooming in and out of a drawing



Zoom Out

View menu, print preview window
Returns the page or tile to the Whole Page view in the print preview window. Zoom to the 
size that best suits your work; for example, viewing a very large drawing probably requires 
decreased magnification.
You can also use the Zoom Out button. Use ToolTips to identify the button.

See also
Previewing a drawing before you print
Print preview window
Zooming in and out of a drawing



 



Starting, quitting, and setting up Visio
         Related procedures

Starting Visio
To open Visio:
· In Windows 95, click Start, choose Programs, then choose Visio.
· In Windows 3.1, double-click the Visio icon in Program Manager.
The New dialog box appears, where you can choose to start with either a template or a 
Wizard. When you start with a template, Visio opens a stencil and a new drawing file and 
copies styles and other settings to the file. 
To start a new drawing:
· In Windows 95, click Start, choose Programs, choose New Visio Diagram, then choose 

one of the drawing types in the list.

Quitting Visio
When you finish working in Visio, quit Visio before you quit Windows. If an unsaved file is 
open when you quit Visio, Visio prompts you to save the file before quitting.

Changing the Visio setup
After you install Visio, you might need to change the way Visio is set up on the computer.
You can use the Visio setup to:
· Install Visio files that you have not installed previously.
· Reinstall files that you have deleted.
· Restore template and stencil files that have been changed accidentally.
If you need to make room on your hard disk, you can also remove some Visio files to 
increase disk space.



Adding Visio files after installation
Making room on your hard disk
Quitting Visio
Starting Visio



Starting Visio



Starting Visio

      Overview  

To start Visio:
1. Start Windows.
2. In Windows 95, click Start, choose Programs, then choose Visio.

In Windows 3.1, double-click the Visio icon in Program Manager.
3. In the New dialog box, choose a template you want to use for a drawing or choose a 

Wizard.
If you want to open an existing file, click Start, choose Programs, then choose Visio. In
the New dialog box, click the Open button, locate the file you need, then click OK.

See also
Opening a stencil
Opening an existing drawing file
Starting a new drawing with a template
Starting a new drawing without a template



Quitting Visio



Quitting Visio

      Overview  

To quit Visio:
1. From the File menu, choose Exit.

Alternatively, click  to close the main 
Visio window.

2. If an unsaved file is open when you quit Visio, Visio prompts you to save the file 
before quitting. Click Yes to save changes, click No to quit Visio without saving 
changes, or click Cancel to cancel the Exit command and continue working in Visio.



See also
Closing a file
Saving a new drawing file



Adding Visio files after installation



Adding Visio files after installation

      Overview  

To add files after installation:
1. Insert Disk 1-Setup into a disk drive.
2. In Windows Explorer, go to your floppy drive, then double-click Setup.
3. In the Visio Setup dialog box, choose Complete/Custom.
4. In the Visio Setup Options dialog box, choose the files you want to add.
5. Choose Continue and follow the instructions on the screen.



Making room on your hard disk



Making room on your hard disk

      Overview  

If you need to increase disk space, consider deleting these Visio files:
· VISTUTOR.EXE (located in the Help folder), if you do not want to run the Quick Tour.
· README.TXT and NETWORK.TXT (located in the main Visio folder), after you have read or 

printed these files.
· Sample drawing files that you don't need (located in the Samples folder).
· Import and export filters that you don't need (located in the System\Filters folder).
· Registration Wizard, after you've registered Visio (REGWIZRD.EXE and REG_FAX.VSD located in 

the System\Filters folder).
Important: The files VISIO.EXE and VISIOLIB.DLL are necessary for running Visio. Do not delete 
these files.



Starting a drawing in Visio

    Related procedures

Visio comes with templates, stencils, and Wizards that you can use to create drawings 
quickly and easily.

Templates
A template is like a kit for building a particular kind of drawing. For example, to create a 
flowchart, use the Flowchart template. 
The advantages of using a template are:
· It opens one or more stencils containing related shapes.
· It sets up a new drawing page using a uniform grid and measurement system.
· It copies related styles to the drawing file.

Stencils
Each template opens one or more stencils. For example, the Flowchart template opens two 
stencils that contain shapes that you can drag and drop to create a flowchart. You can also 
open stencils independently. You don't need to open a template to open a stencil.
Wizards
When you start with a Wizard, Visio opens the appropriate template, then prompts you for 
information about the drawing. For example, if you are creating a timeline, you could 
automate your work by starting with the Project Timeline Wizard, which opens the Project 
Timeline template and the Wizard, and then prompts you for project information.
No template
You can also create a drawing in Visio without using a template. When you create a drawing 
without using a template, Visio opens a blank foreground page and provides default styles 
and page settings.



Starting a new drawing with a template
Starting a new drawing without a template



Starting a new drawing with a template



Starting a new drawing with a template

      Overview  

You can start Visio and open a new drawing file based on a template provided with Visio. 
When Visio is running, you can open new drawing files by using the New command on the 
File menu.

To open a new drawing file based on a
template:

1. From the File menu, choose New.
If Visio isn't already running, in Windows 95, click Start, choose Programs, choose 
New Visio Diagram, then choose one of the drawing types in the list.

2. In the New section, make sure Drawing is checked.
3. From the Based On list, choose a template or a Wizard.
4. If the template file you need is not listed, choose the Open button and locate the file.
5. Click OK.

See also
Creating a new page
Creating a new stencil
Starting a new drawing without a template





Starting a new drawing without a template



Starting a new drawing without a template

      Overview  

To create a drawing without a 
template:

1. From the File menu, choose New.
You can also use the New button.

2. In the New section, make sure Drawing is checked.
3. From the Based On list, choose No Template.



4. Click OK.

See also
Changing the drawing size and scale
Creating a new page
Creating a new stencil
Opening a stencil
Starting a new drawing with a template



Arranging the Visio workplace

    Related procedures

The Visio workplace contains the windows, menus, and tools that you use to create 
drawings. You can arrange the Visio workplace to fit your needs.
You can change the display and arrangement of:
· The size and position of Visio windows.
· The size and position of Visio stencils.
· How master shape icons appear in the stencil.
· The page view.
· Rulers, grid lines, connection points, and guides.
· The toolbar and status bar.



Arranging stencils
Arranging Visio windows
Displaying and arranging master shape icons
Getting quick access to common commands
Setting display options
Switching toolbar sets
Zooming in and out of a drawing



Arranging Visio windows



Arranging Visio windows

      Overview  

By default, the Visio main window usually contains a drawing page and one or more stencils.
You can undock stencils to make them float. 
If you have more than one drawing open, you can arrange and resize the windows to see 
them all.



To arrange windows so each window 
is visible:

1. From the Window menu, choose Tile.

To arrange windows to see the title 
bar of each window:

1. From the Window menu, choose Cascade.

To size a window:
1. Drag a window border.

Tip: For details about other ways to arrange windows, see your Windows documentation.

See also
Arranging stencils



Arranging stencils



Arranging stencils

      Overview  

You can view stencils as either docked or floating. By default, stencils are docked.



To make a stencil float:
1. Click inside the stencil where there are no buttons or icons, then drag it away from its

docked position.
Or, right-click the stencil title bar, then choose Float from the menu.
Tip: When a stencil is floating, to view just the stencil's title bar, click the minimize 
button on the stencil title bar. To expand the stencil again, click the maximize button 
on the stencil's title bar.

To dock a stencil:
1. Click inside the stencil where there are no buttons or icons, then drag the stencil to 

the left or right side of the drawing window.
2. Release the mouse button when an outline of the stencil appears.

The stencil snaps to its docked position.

To move a stencil from one side of the



drawing window to another:
1. Right-click the stencil title bar, then choose Switch Sides from the menu.

To switch between stencils:
1. When stencils are docked, click the name of the stencil to switch to that stencil.

To close a stencil:
1. Right-click the stencil title bar, then choose Close from the menu.

See also
Arranging Visio windows



Displaying and arranging master shape icons



Displaying and arranging master shape icons



      Overview  

You can change how master shape icons are displayed in the stencil. You can also arrange 
the icons after you resize the stencil window or add or delete a master shape.

To change the stencil window display:
1. Right-click the stencil, then choose one of the following:

Icons And Names, to display both master shape icons and names.
Icons Only, to display only master shape icons.
Names Only, to display only the master shape names.

If you create your own stencil, when you drag and drop shapes onto the stencil, the master 
shape icons may not be neatly arranged. 

To arrange stencil master shape 
icons:



1. Right-click the stencil, then choose Arrange Icons.
When you check Auto     Arrange   on the shortcut menu, master shape icons are 
rearranged automatically when you resize the stencil window or add or delete master
shapes.

See also
Zooming in and out of a drawing



Zooming in and out of a drawing





Zooming in and out of a drawing

      Overview  

You can magnify a part of the drawing to work on details or change the view to see the 
entire drawing in the drawing window.

To zoom in and out of a drawing:
1. If you want to zoom in on a particular area of a drawing, select a shape in that area.
2. Press Ctrl+Shift+left mouse button to zoom in.
3. Press Ctrl+Shift+right mouse button to zoom out.

You can also choose Last Zoom, Actual Size, Page Width, or Whole Page from the View menu.
Or, use a magnification percentage in the Zoom box.

See also
Arranging Visio windows



Setting display options





Setting display options

      Overview  

You can change the display of the drawing page by setting display options. You can set 
display options to show or hide the status bar, the toolbar, rulers, grid lines, connection 
points, and guides. These settings are saved by Visio and remain in effect until you set them
again.

To set display options:
1. From the View menu, choose the command for the display element you want to show 

or hide:
Rulers
Grid
Guides
Connection Points
Page Breaks
Status Bar
Toolbars

A check mark beside the command indicates the element is showing.

See also
Setting page display options
Setting shape display options
Switching toolbar sets





Switching toolbar sets





Switching toolbar sets

      Overview  

Visio lets you choose the working environment that's most familiar to you. You can use the 
Microsoft Office toolbar, or you can use toolbars that resemble the ones in the Lotus 
SmartSuite or Novell PerfectOffice program.

To switch the toolbar:
1. From the View menu, choose Toolbars.

Or, right-click the toolbar, then choose an option from the shortcut menu.
2. In the Style box, choose the toolbar you want.
3. In the Display Options box, choose whether or not you want to display color buttons, 

large buttons, and ToolTips.
4. Click OK.

See also
Getting quick access to common commands



Getting quick access to common commands





Getting quick access to common commands

      Overview  

You can quickly display a menu of common commands that relate to tasks you are doing. For
example, when a shape is selected, you can right-click the shape to display a shortcut menu 
of commands for copying the shape, editing the shape's text, formatting the shape, viewing 
custom properties, and adjusting the view of the drawing. You can also display a shortcut 
menu for the stencil window or the drawing page.

To display the shortcut menu:
1. Right-click the shape, stencil, or drawing page.
2. From the shortcut menu, choose the command you need.

See also
Setting display options
Zooming in and out of a drawing



Working with Visio files

    Related procedures

Opening files
When you start a new drawing, you usually open a template file, which opens a stencil and a
drawing page for you. Visio uses four types of files: templates, stencils, drawings, and 
workspaces. You can identify a file's type by its filename extension. Template filenames have
a .VST extension, stencil filenames have a .VSS extension, drawing filenames have a .VSD 
extension, and workspace filenames have a .VSW extension.
When you open a file, you can choose an option for how to open it. The option you choose 
and which type of file you open depend on the kind of work you want to do.
You can open:
· The original file to edit the file.
· A copy to make changes to a file it without affecting the original.
· A read-only version to look at the file but not change it.
Note: When you open a file as read-only, its name appears in brackets in the window title 
bar.

Saving files
When you have done substantial work on a drawing, you should save the drawing file. When 
you change a stencil or template, you should also save these files.
If you need to distribute the file, but you don't want anyone to make changes to it, save it as
read-only. Your recipients can only open and read the file; they cannot make changes.

Save options
By default, Visio saves existing files in the format in which they were created. You can save 
Visio files in additional formats, including earlier versions of Visio, using the Save As 
command.

Saving a workspace
When you save a workspace file, by default you save the arrangement of open files. When 
you open a workspace, Visio re-creates the arrangement of files and windows.
You can save a workspace either by checking the Workspace option in the Save As dialog 
box when working with a drawing, stencil, or template (usually within a drawing file) or by 
saving a workspace file using the Save Workspace command, which has a .VSW extension.





Closing a file
Creating a file summary
Displaying a drawing file stencil
Opening a stencil
Opening a template to modify or copy it
Opening an existing drawing file
Protecting a file
Saving a file as read-only
Saving a file with the Workspace option
Saving a new drawing file
Saving changes to an open file



Opening an existing drawing file





Opening an existing drawing file

      Overview  

You can open an existing drawing file to update or make changes to a drawing.

To open an existing file:
1. From the File menu, choose Open.

You can also use the Open button.
2. In the File Name box, type or choose the name of the file you want.

If the file you want to open is not listed, choose a different type of file in the Files Of 
Type box, or choose a different folder from Look In.

3. In the Open section, check an option to open the original file, a copy of the file, or a 
read-only version of the file.

4. Click Open.

See also
Opening a stencil
Opening a template to modify or copy it
Saving a file as read-only
Saving a new drawing file



Opening a template to modify or copy it





Opening a template to modify or copy it

      Overview  

You usually create a new drawing by opening a template from the New dialog box. If you 
want to modify or copy a template, you can open it from the Open dialog box, just as you 
would other files.

To open a template file to modify or 
copy it:

1. From the File menu, choose Open.
The Open dialog box appears.

2. Under Files Of Type, select Template (*.VST).
3. If necessary, under Look In, open the Template folder, then open the folder in which 

the template is located.
4. In the Look In list, choose the name of the template you want.
5. In the Open section, choose an option for how to open the file.

By default, a template is opened as a copy.
6. Click OK.

See also
Creating a template
Opening a stencil
Opening an existing drawing file



Opening a stencil





Opening a stencil

      Overview  

If you want to use shapes from several stencils in a drawing, you can open stencil files 
without opening a template.

To open a stencil:
1. From the File menu, choose Stencils.

You can also use the Stencils button.
2. From the Select Stencil list, choose the name of the stencil you want to open.

If you don't see the stencil name, click Browse and locate the stencil file you need. 
(You may need to open one of the stencil folders.) 

3. When you've located the file, click OK.

See also
Creating a new stencil
Opening a template to modify or copy it
Opening an existing drawing file
Opening an original stencil



Saving a new drawing file





Saving a new drawing file

      Overview  

To save a new file:
1. From the File menu, choose Save or Save As.
2. In the File Name box, type a filename for the drawing file.
3. Under Save In, open the folder where you want to save the file.
4. If you want to save a workspace, make sure Workspace is checked in the Save 

section.
5. If necessary, choose a file format from the Save As list.

For example, you can save a Visio 4.0 drawing file in Visio 3.0 or 2.0 format by 
choosing Visio 3 or 2 drawing (*.VSD) from the list.

6. Click Save.
7. If necessary, enter property information, then click OK to close the Properties dialog 

box.

See also
Saving a file as read-only
Saving a file with the Workspace option



 Saving changes to an open file





Saving changes to an open file

      Overview  

You can save changes to an open file and continue working in Visio.

To save changes to an open file:
1. From the File menu, choose Save.

You can also use the Save button.
By default, Visio saves existing files in the same format.

See also
Saving a file as read-only
Saving a file with the Workspace option



Saving a file as read-only





Saving a file as read-only

      Overview  

You can prevent unauthorized or accidental changes to a file by saving the file as read-only. 
You can open and edit a copy of a read-only file, but the original file cannot be edited. 
Tip: After you have saved a file as read-only, to make the file read-write again, use the Save
As command to save the file to another name.

To save a file as read-only:
1. From the File menu, choose Save As.
2. In the Save section of the dialog box, check Read Only.
3. In the File Name box, type a filename for the drawing file.
4. In the Save In box, choose the folder where you want to save the file.
5. Click Save.

See also
Protecting a file
Saving a new drawing file



 Saving a file with the Workspace option





Saving a file with the Workspace option

      Overview  

You can save your own arrangement of stencils in your drawing file.
· If you have specific stencils you want to open with a drawing, use the Save As command,

then check the Workspace option. 
· If you like to have two drawing files open at a time, as well as multiple stencils, use the 

Save Workspace command on the File menu.

To save a drawing file with the Save 
As Workspace option:

1. From the File menu, choose Save As.
2. In the Save section, check Workspace.
3. In the File Name box, type a filename for the drawing file.
4. In the Save In box, choose the folder where you want to save the file.
5. Click Save.



To save a drawing file with the Save 
Workspace command:

1. Save the files you have edited.
2. From the File menu, choose Save Workspace.
3. In the File Name box, type a filename for the drawing file.
4. In the Save In box, choose the folder where you want to save the file.
5. Click Save.

See also
Saving a new drawing file



Protecting a file





Protecting a file

      Overview  

To protect a file, you can:
· Lock styles, background pages, shapes (including objects from other programs), and 

master shapes to prevent changes.
· Password to protect a file. For example, if you had sensitive information, such as salaries,

in a file, you might want to protect the file.

To protect a file:
1. From the Tools menu, choose Protect Document.
2. Do one or more of the following:

In the Protect Document dialog box, type a password. 
If you use a password to protect a document, remember it or write it down. The 
password is not visible after you close the dialog box.
Check the items that you want to protect.

3. Click OK.

When you no longer need to protect a file, you can remove the protection.



To remove protection from a file:
1. From the Tools menu, choose Unprotect Document.
2. Do one or more of the following:

Type the password for the file, if you used one.
Uncheck the items you protected.

3. Click OK.

See also
Protecting shapes
Saving a file as read-only



 Creating a file summary





Creating a file summary

      Overview  

You can create a summary for a Visio file so you and others can identify the file more easily. 
Information about the file appears in the Description section of the New, Open, or Stencils 
dialog box when you choose the file's name.

To create or edit file properties:
1. Make sure the file you want to summarize is open in the active window.
2. From the File menu, choose Properties.
3. In the dialog box, enter the file title, the subject, the creator, keywords, and a 

description.
4. Check Save Preview Picture to save a picture of the first page in the drawing to be 

used in the Open dialog boxes Preview section, as well as in Quick View.
5. Click OK.

By default, Visio prompts you for property information when you save a new file. To remove 
the prompt, choose Options from the Tools menu, then uncheck the Prompt For Document 
Properties On Save option. 
Tip: You can include the text entered in the Properties dialog box in the Visio drawing file by 
inserting it as a Visio field. For details, see Inserting fields into text.

See also
Inserting fields into text
Text Field



Closing a file





Closing a file

      Overview  

When you finish working with a file, you can close the file without quitting Visio. If you have 
changed the file since you last saved it, Visio prompts you to save the file before closing it.

To close a file:
1. From the File menu, choose Close.

Or, click  to close the file.
2. If the file has unsaved changes, Visio prompts you to save the file before closing it. 

Choose Yes to save changes, choose No to close the file without saving changes, or 
choose Cancel to cancel the Close command and continue working with the file.

See also
Quitting Visio



Saving a new drawing file



Displaying a drawing file stencil





Displaying a drawing file stencil

      Overview  

The first time you drag or stamp a master shape into a drawing file, Visio places a copy of 
the master in the drawing file stencil.
When you edit a master shape stored in the drawing file stencil, you can update all instances
of the master in that drawing file at the same time. An instance within the drawing file 
inherits characteristics from the master on the drawing file stencil unless you ungroup the 
instance or delete the master from the drawing file stencil.

To view the drawing file stencil:
1. From the Window menu, choose Show Master Shapes.

The drawing file stencil appears.

Tip: Choose Tile from the Window menu so that you can see both the drawing page and the 
drawing file stencil window. 



To close a drawing file stencil:

1. Click  to close the stencil.

See also
Creating a master shape from a shape in a drawing
Modifying a master shape in the drawing file stencil
 



 Understanding ShapeSheets

    Related procedures

A ShapeSheet is a spreadsheet that contains information about a shape. For example, a 
ShapeSheet displays a shape's dimensions, its angle and center of rotation, and the 
attributes that determine the shape's appearance. ShapeSheets also contain formulas that 
define the ways a shape behaves when it is moved or sized.

How shapes look in the ShapeSheet
When you draw a shape, Visio records the shape as a collection of horizontal and vertical 
locations. These locations (called vertexes) are stored in the ShapeSheet and are measured 
from a point of origin on the page and connected with line segments.
Visio records each shape vertex as a set of x- and y-coordinates. When you move the shape 
or change its size, Visio automatically records changes in the ShapeSheet.
Every page, shape, group, master shape, object from another program, guide, and guide 
point has a ShapeSheet that you can view. A group and each shape or object in the group 
has its own ShapeSheet.

The ShapeSheet window
When the ShapeSheet window is active, the menu bar changes to display menus and 
commands you use to work in the ShapeSheet. When a ShapeSheet cell is selected, a 
formula bar appears, which you use to enter and edit ShapeSheet formulas.

Sections, cells, and formulas
Each ShapeSheet is divided into sections that control a particular aspect of a shape's 
behavior or appearance¾for example, its geometry or its formatting. Each section consists 
of cells that contain formulas. These can be default formulas created by Visio or formulas 
you create. A formula might be simple and always evaluate to the same value for the cell, or
the formula might be built from functions, operators, and other elements that evaluate to 
different values depending on the circumstances.



Adding and deleting rows
Adding and deleting sections
Collapsing and expanding sections
Displaying a ShapeSheet
Displaying values and formulas in cells
Moving around the ShapeSheet
Showing and hiding sections
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Displaying a ShapeSheet

      Overview  

ShapeSheets are displayed in the ShapeSheet window within the drawing page.

To display a shape's ShapeSheet:
1. Select the shape or object.

To select a shape within a group, open the group window and select the shape. To 
select a master shape, open its original stencil, double-click the master to open the 
master shape drawing window, and then select the shape.

2. From the Window menu, choose Show ShapeSheet.
3. If you want, choose Tile from the Window menu to see both the drawing page and the

ShapeSheet window.

To display a page's ShapeSheet:
1. Make sure nothing is selected on the page.



2. From the Window menu, choose Show ShapeSheet.
Tip: Press the Ctrl key and choose Tile from the Window menu to horizontally tile all open 
windows.

To close a ShapeSheet window:

1. Click  to close the ShapeSheet 
window.

See also
Displaying values and formulas in cells
Editing and formatting a group
Opening an original stencil
Showing and hiding sections



Displaying values and formulas in cells





Displaying values and formulas in cells

      Overview  

You can display either formulas or values in ShapeSheet cells. Display formulas when you 
are entering new formulas or editing existing ones or to see how formulas in cells relate to 
each other. A value is the result you get when Visio evaluates a cell's formula. You can 
display values in cells to see the result of an evaluation.

To display formulas in cells:
1. From the View menu, choose Formulas.

Visio displays formulas in the cells; some long formulas are truncated.

To display values in cells:
1. From the View menu, choose Values.

See also



Building a formula by pasting
Creating formulas
Editing formulas
Showing and hiding sections
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Showing and hiding sections

      Overview  

To display the sections you need in a ShapeSheet, use the Sections command. You can also 
hide sections you don't need.

To show or hide sections:
1. From the View menu, choose Sections.
2. Check the sections you want to show, or uncheck the sections you want to hide.

If a section is dimmed in the dialog box, it is not available for the selected shape. For 
example, the Image Info section is available only for objects from other programs.
You can also choose All to show all the sections, or choose None to hide all the 
sections.

3. Click OK.

See also
Adding and deleting sections
Collapsing and expanding sections
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Collapsing and expanding sections

      Overview  

You can change the display of sections in the ShapeSheet. You can hide the cells in a section 
but leave the section heading visible, and you can expand the section to see its cells again.

To collapse or expand a section:
1. Point to the section title.

If the mouse pointer changes to a minus sign, you can collapse the section.
If the mouse pointer changes to a plus sign, you can expand the section.

2. Click the section title.
Visio changes the display to either hide or show the section's cells.

See also
Adding and deleting sections
Showing and hiding sections
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Moving around the ShapeSheet

      Overview  

To move from cell to cell in the ShapeSheet, use the arrow and Tab keys. You can also click a 
cell to activate it or scroll through the ShapeSheet without changing the active cell.

To: Do this:
Activate a cell Click the cell with the mouse

pointer
Select a numbered 
row of cells

Click the row number

Move left one cell Press the Left Arrow key or 
Shift+Tab

Move right one cell Press the Right Arrow key or 
Tab

Move up one cell Press the Up Arrow key
Move down one cell Press the Down Arrow key
Move to the last cell 
in a row

Press the End key

Move to the first cell 
in a row

Press the Home key

Scroll down one 
screen

Press the Page Down key

Scroll up one screen Press the Page Up key
Scroll right one 
screen

Press Ctrl+Page Down

Scroll left one screen Press Ctrl+Page Up
Scroll to the 
ShapeSheet's lower-
right corner

Press Ctrl+End

Scroll to the 
ShapeSheet's upper-
right corner

Press Ctrl+Home

See also
Copying and pasting formulas between cells
Creating formulas
Editing formulas
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Adding and deleting sections

      Overview  

By adding new sections to the ShapeSheet, you can add new characteristics to the shape. 
For example, you can add a Connection Points section to create connection points. When 
you no longer need a section, you can delete it.

To add a section:
1. From the Insert menu, choose Section.
2. Choose the sections you want to add.

If a section is dimmed in the dialog box, it is already included in the ShapeSheet or is 
not available for the selected shape. If the shape is a group, you may need to open 
the group in the group window and subselect the shape whose ShapeSheet you want 
to change.

3. Click OK.
If you use the Section command to add a section to the ShapeSheet, but you don't see the 
new section in the ShapeSheet window, use the Sections command to make sure the section
is set to display.
You can delete a section from a ShapeSheet by using the Delete Section command. You must
select a cell in the section before you can delete it.



To delete a section:
1. Select a cell in the section you want to delete.
2. From the Edit menu, choose Delete Section.

Important: There are certain sections that cannot be deleted. For example, you cannot 
delete the Object Transform section because it specifies a shape's position. If you cannot 
delete a section, Delete Section is dimmed on the menu.

See also
Adding and deleting rows
Showing and hiding sections
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Adding and deleting rows

      Overview  

You can add rows to ShapeSheet sections to hold additional formulas or to change a shape's 
appearance. For example, you can add a row to a Geometry section to add a segment to a 
shape. Similarly, you can delete rows you no longer need.

To add a new row before an existing 
row:

1. Select a cell in the row in the position you want the new row.
2. From the Insert menu, choose Row.

To add a new row after an existing 
row:

1. Select a cell in the row that's one row above the position you want the new row.
2. From the Insert menu, choose Row After.



To delete a row:
1. Select a cell in the row you want to delete.
2. From the Edit menu, choose Delete Row.

Visio removes the selected row and moves any following rows up one row in the 
section.

See also
Adding and deleting sections
Showing and hiding sections



Working with formulas

    Related procedures

Visio formulas are similar to typical spreadsheet formulas in many ways. Like most 
spreadsheet programs, Visio regards anything in a cell as a formula, even if it's a numeric 
value or simple cell reference. Every formula begins with an equal sign (=) when it is 
entered in the formula bar.
Visio supports standard mathematical and comparison operators as well as a full set of 
mathematical, trigonometric, statistical, and date and time functions and many unique 
functions. Formulas can contain references to other cells in the ShapeSheet and to cells in 
other ShapeSheets.

Default formulas
When you create a shape, Visio automatically creates default formulas. To see what the 
default formulas are, draw a simple shape (such as a rectangle, ellipse, or line) and display 
its ShapeSheet.

Automatic updates
Visio automatically updates certain cells whenever you change the shape in a drawing. This 
means that under some circumstances the formulas can be replaced with formulas from 
Visio. For example, if you drag a corner handle to resize the shape, Visio resets formulas in 
the PinX, PinY, Width, and Height cells.

Inherited formulas
Each cell in a ShapeSheet can be defined with a local formula, or it can inherit its formula 
from the shape's master or style. Visio uses color in the ShapeSheet to indicate whether a 
cell's formula is local: local formulas are blue and inherited formulas are black.
Visio uses inherited formulas whenever possible. An instance of a master shape uses the 
formulas in its master rather than making local copies of them. Using inherited formulas 
requires less memory and results in uniform behavior. If you add local overrides¾for 
example, if you format an instance of a master shape¾you are adding local formulas to the 
shape. After you add a local override, changing the master no longer changes the local value
for the overridden cell¾the value comes from the local formula instead.



Building a formula by pasting
Copying and pasting formulas between cells
Creating formulas
Editing formulas
Using inherited formulas



Creating formulas





Creating formulas

      Overview  

You can type formulas in the formula bar, much as you do in a spreadsheet. If you don't want
to replace an entire formula, you can select and edit the part you want to change. For 
details, see Editing formulas.

To type a new formula for a cell:
1. In the ShapeSheet, click the cell to select it.

The cell's formula appears in the formula bar.
2. Type the formula.

The formula you type replaces the cell's previous formula.
If you type a number but don't supply units of measure, Visio uses the units from the 
cell's previous value if there was one. Otherwise, if the cell requires units, Visio uses 
the default units of measure for the cell.

3. To accept the formula, click the Enter box (marked with a check mark) in the formula 
bar or press the Enter key.
If the number or formula contains an error, Visio displays a message and then 
highlights the error in the formula bar. Correct the error and click the Enter box or 
press the Enter key to accept the correction.
To cancel the changes, click the Cancel box (marked with an X) in the formula bar, or 
press the Esc key.

See also
Building a formula by pasting
Copying and pasting formulas between cells
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Editing formulas

      Overview  

You can edit formulas in the formula bar, much as you do in a spreadsheet.

To edit a selected part of a formula:
1. In the ShapeSheet, select the cell you want.
2. In the formula bar, edit the formula using the following techniques.

To: Do this:
Place the insertion 
point

Click where you want the 
insertion point to appear

Move the insertion 
point

Press the Left or Right Arrow 
key

Delete the character to 
the left

Press the Backspace key

Delete the character to 
the right

Press the Delete key

Select text Drag the mouse over the 
text

Extend the selection to 
the left

Press Shift+Left Arrow

Extend the selection to 
the right

Press Shift+Right Arrow

Select a word Press Ctrl+Shift+Right Arrow
or double-click

Select to the end Press Shift+End
Select to the beginning Press Shift+Home



Replace selected text Type the new text
Delete selected text Press the Delete key or 

choose Cut or Clear from the
Edit menu

See also
Building a formula by pasting
Copying and pasting formulas between cells
Displaying values and formulas in cells
Using inherited formulas
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Building a formula by pasting

      Overview  

You can enter formulas in the ShapeSheet by typing, but Visio also has commands for 
pasting cell names and functions into a formula.

To paste a cell name into a formula:
1. In the formula bar, place the insertion point where you want to paste the name.

Until you place the insertion point, the Name command is unavailable.
2. From the Insert menu, choose Name.
3. Choose the name you want from the list.
4. When the formula is finished, click the Enter box in the formula bar to accept the 

formula, or click the Cancel box to cancel the changes.

Alternatively, you can paste the name of a cell into a formula by placing the insertion point 
in the formula bar, then clicking the cell you want. Visio inserts the name of the cell at the 
insertion point.



To paste a function into a formula:
1. In the formula bar, place the insertion point where you want to paste the function.

Until you place the insertion point, the Function command is unavailable.
2. From the Insert menu, choose Function.
3. Choose the function you want from the list.
4. If you want Visio to include the syntax for the function's arguments, check Insert 

Arguments.
5. Click OK.
6. Supply the arguments you want for the function by typing them, by clicking cells in 

the ShapeSheet, or by using the Name command.
7. When the formula is finished, click the Enter box in the formula bar to accept the 

formula, or click the Cancel box to cancel the changes.

See also
Editing formulas
Using inherited formulas
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Copying and pasting formulas between cells

      Overview  

Often the formula you want is similar to a formula in another cell, either in the same 
ShapeSheet or in another ShapeSheet. Rather than retype the formula, you can save time by
copying and pasting it into a cell and then editing the formula if needed.

To copy and paste a formula:
1. In the ShapeSheet, select the cell you want to copy.
2. In the formula bar, select the formula.
3. From the Edit menu, choose Copy.

Visio copies the formula to the Clipboard.
4. Cancel the activation of the source cell by clicking the Cancel box or pressing the Esc 

key.
If you don't cancel the source cell, the cell reference of the next cell you click will be 
added to the source cell's formula.

5. Select the cell where you want to paste the formula.
6. In the formula bar, select the formula, or click in the formula bar if it is blank.
7. From the Edit menu, choose Paste.

Visio pastes the formula into the formula bar.
8. Click the Enter box or press the Enter key to accept the formula.

To discard the formula, click the Cancel box or press the Esc key.



See also
Building a formula by pasting
Using inherited formulas
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Using inherited formulas

      Overview  

To use an inherited formula, you can delete the local formula by entering an "empty" one in 
the cell.

To enter an empty formula:
1. In the ShapeSheet, select the cell.
2. In the formula bar, delete the formula's text.
3. Press the Enter key.

Tip: Try this in a Scratch cell after inserting a local formula. It reverts to No Formula, 
because there's no formula to inherit from the master. If No Formula is displayed in a cell 
other than a Scratch cell, you've probably made a mistake¾choose Undo from the Edit menu
to restore the previous formula.

Deleting all local formulas
An easy way to delete all local formulas in a format section (line, fill, text, character, or 
paragraph) is to apply an appropriate style to the shape. Applying a style deletes all local 
formulas in the related cells unless the Preserve Local Formatting option is checked in the 
Style dialog box when the style is applied.

See also
Building a formula by pasting
 



 Creating and editing master shapes

    Related procedures

To create and edit master shapes, you use commands on the appropriate stencil's Master 
menu. The Master menu is only available when a copy or an original (not read-only) of a 
stencil is open.
You can use objects from other programs as master shapes. However, you may not be able 
to edit an object from another program in all the ways that you can edit a Visio shape. You 
can also create a master shape from a group.

Edit originals or copies of stencils
By default, stencils open read-only to prevent changes. 

To edit master shapes or to add new master shapes to a stencil, open an original stencil 
file. When an original stencil is open, it opens in its own window, and the menus and 
toolbars change to display the stencil window.
To revise a stencil but maintain the original, open a copy of the stencil.

Edit in the master shape drawing window
You create and edit master shapes in the master shape drawing window. You use the same 
tools and techniques that you use to create and edit shapes in a drawing. To edit master 
shape icons, use the edit icon window.



Changing the text attributes of a master shape
Creating a master shape from a shape in a drawing
Creating a master shape from scratch
Editing a master shape in a stand-alone stencil
Editing a master shape in the drawing file stencil
Specifying master shape characteristics



Creating a master shape from a shape in a drawing





Creating a master shape from a shape in a drawing

      Overview  

By dragging a shape from a drawing to a stencil, you can create a master shape. When you 
drag a shape to a stencil, a master shape icon based on the shape and a default name for 
the master shape appear in the stencil window.
You can add shapes to a stencil only when the original or a copy of a stencil is open. After 
creating a master shape, you can name the master shape, align its name, choose options for
the icon size, and write a prompt that provides information about how to use the master 
shape.

To create a master shape from a 
shape in a drawing:

1. In the drawing window, display the shape you want to use to create a master shape, 
or draw the shape you want to use.

2. Open the stencil file in which you want to store the new master shape.
Make sure to open the original stencil or a copy.

3. With the pointer tool, point to the shape you want to use as a master.
4. Drag the shape from the drawing into the stencil window and release the mouse 

button.
You can create a copy of the shape by holding down the Ctrl key while you drag.

5. From the File menu, choose Save to save the changes to the stencil.
You can also click the Save button.

Tip: To realign icons after adding a master shape, right-click the stencil, then choose 



Arrange Icons from the shortcut menu.

See also
Creating a master shape from scratch
Creating a new stencil
Editing a master shape in a stand-alone stencil
Opening an original stencil
Specifying master shape characteristics
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Specifying master shape characteristics

      Overview  

You can change or specify characteristics for the way a master shape is displayed in a 
stencil. You can choose options for aligning a master shape's name, the size of its icon, and 
how the icon is updated. You can also rename the master shape or write or edit the prompt 
that provides information about the master shape.

To specify master shape 
characteristics:

1. Select the master shape icon.
Make sure to open the original stencil or a copy and to activate the stencil window.

2. From the Master menu, choose Properties.
3. In the Master Name section, type or change the name for the master, and choose an 

option to align the master shape name.
4. In the Icon section, choose an option for the icon size.

The default size is Normal. You can also choose Tall, Wide, or Double.
5. In the Icon section, choose an option to update the master shape icon.

Choose Automatic if you want the icon to automatically reflect changes you make to 
the master shape it represents. Choose Manual if you want to update the icon 
manually with the Update Icon command.
If you plan to create a custom icon for the master shape, choose Manual, so you 
won't accidentally replace the custom icon when you edit the master shape.

6. In the Prompt section, type information that will appear when you point to the master
shape icon.



7. Check Match Master By Name On Drop to preserve the formatting you've applied to 
the stencil's master shapes. For details, see Properties.

8. Click OK.
9. From the File menu, choose Save to save the changes to the stencil.

You can also click the Save button.

See also
Creating a master shape from a shape in a drawing
Editing a master shape in a stand-alone stencil
Opening an original stencil
Updating master shape icons
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Changing the text attributes of a master shape

      Overview  

To change the attributes associated with a master shape's text (for example, its font color or 
size), you must edit the style the master shape uses.

To change the text attributes of a 
master shape:

1. Drag a master shape from the stencil into the drawing window.
2. From the Format menu, choose Define Styles.
3. Under Includes, ensure Text is checked.
4. Click the Text button in the Change section of the dialog box.
5. Choose the text formatting options you want to apply, and then click OK to close the 

Font dialog box.
6. Click Apply to apply the change to the selected shape and the style and to close the 

dialog box.
Each current instance of the master shape and all subsequent instances in that 
drawing display the new attributes.

Note: In many of the Visio templates, the same style controls the look of many of the 
master shapes in the stencil. If you change the attributes associated with one master 
shape's style, you will also change the default look of any other master shapes in the 
drawing that use that style.

See also
Creating a master shape from a shape in a drawing



Specifying master shape characteristics
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Creating a master shape from scratch

      Overview  

To create a master shape from 
scratch:

1. Open the stencil file to which you want to add a master shape, or open a blank 
stencil.
Make sure to open the original stencil or a copy. For details, see Opening an original 
stencil.

2. With the stencil selected, choose New Master from the Master menu.
3. In the New Master dialog box, specify characteristics for the master shape:

In the Master Name section, specify the name of the new master shape and how to 
align the name.
In the Icon section, choose an option for the size and how to update the master 
shape icon.
In the Prompt section, type information about the master shape that appears when 
you point to it.
For Match Master By Name On Drop, check to preserve the formatting you've applied 
to the stencil's master shapes. For details, see Properties.

4. Click OK.
A blank master shape icon appears in the stencil window. (You may need to scroll to 
see it.)

5. From the Master menu, choose Edit Master, or double-click the master shape to open 
the master shape drawing window. 



6. Draw the master shape.

7. Click  to close the master shape 
drawing window.
8. When prompted to update the master shape, click Yes.
9. From the File menu, choose Save to save the changes to the drawing file 

stencil.
You can also click the Save button.

See also
Creating a master shape from a shape in a drawing
Opening an original stencil
Specifying master shape characteristics
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Editing a master shape in a stand-alone stencil

      Overview  

To edit a master shape:
1. Open the stencil file that contains the master shape you want to edit.

Make sure to open the original stencil or a copy. For details, see Opening an original 
stencil.

2. In the stencil window, select the master shape. 
3. From the Master menu, choose Edit Master, or double-click the master shape you 

want to edit.
The master shape drawing window opens.

4. Edit the master shape.

5. Click  to close the master shape 



drawing window.
6. Visio prompts you to update the master shape. Click Yes to save changes to 

the master shape, or click No to close the master shape drawing window without saving 
changes.

7. From the File menu, choose Save to save changes to the stencil.
You can also click the Save button.

See also
Opening an original stencil
Selecting shapes



 Editing a master shape in the drawing file stencil





Editing a master shape in the drawing file stencil

      Overview  

The quickest way to modify every instance of a master shape in a drawing is to edit the 
master shape stored in the drawing file stencil. When you edit the master shape, you 
change each instance of the shape in the drawing file. You do not, however, change the 
master shape in any stand-alone stencil you may have used to create the drawing.

To edit a master shape in a drawing 
file stencil:

1. Make sure the drawing window is active by clicking the title bar.
2. From the Window menu, choose Show Master Shapes to display the drawing file 

stencil.
3. In the drawing file stencil, double-click the icon for the master shape you want to 

edit.
4. In the master shape drawing window, edit the master shape.



5. Click  to close the master shape 
drawing window.
6. Visio prompts you to update the master and its instances. Click Yes to make 

the changes.
7. From the File menu, choose Save to save changes to the stencil.

See also
Opening an original stencil
Saving a drawing file stencil as a stand-alone stencil
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Updating master shape icons

      Overview  

When you edit a master shape, you can update the icon automatically so it reflects changes 
to the master shape. You can also control when a master shape icon is updated. For 
example, if you create a custom icon that does not resemble the master shape, you can 
make changes to the master shape without updating the master shape icon.

To automatically update a master 
shape icon:

1. Open the stencil file with the master shape whose icon you want to update. 
Make sure to open the original stencil or a copy. For details, see Opening an original 
stencil.

2. Select the master shape icon.
3 From the Master menu, choose Properties.
4. In the Icon Update section, choose Automatic, and then click OK.

Each time changes are made to the master shape, the master shape icon is updated.

By setting the update option to Manual, you can choose to update the icon at specific times.



To set a master shape icon to update 
manually:

1. Open the stencil file with the master shape whose icon you want to update. 
Make sure to open the original stencil or a copy. For details, see Opening an original 
stencil.

2. Select the master shape icon.
3 From the Master menu, choose Properties.
4. In the Icon Update section, choose Manual, and then click OK.
5. To update the master shape icon, choose Update Icon from the Master menu.

Visio updates the icon with a miniature version of the master shape.

See also
Editing a master shape in a stand-alone stencil
Opening an original stencil
Specifying master shape characteristics



Working with master shape icons

    Related procedures

When you create a master shape, Visio creates an icon that resembles the master shape. 
You can also create a custom master shape icon.
You can create master shape icons or edit the icon Visio creates in the edit icon window.

Icon editing
To make changes to a master shape icon, open the original stencil that contains the master 
shape, select the master shape, and then open the edit icon window.
Use the icon pencil tool and the paint bucket tool to change the colors of an icon. When 
using these tools, you can assign one color to the left mouse button and a second color to 
the right mouse button. You can use the mouse buttons to apply the color.
To change the size and shape of a master shape icon, or to move, copy, or delete selected 
areas of the icon, use the lasso tool and the selection net tool. 
You cannot cancel changes you make to an icon after you close the edit icon window. 
However, you can use the Undo command to undo changes to the icon while the edit icon 
window is still open.

Icon options
Before you create a custom master shape icon, you should choose options for the icon's size 
and how to update the icon. The size of the icon determines the size of the area that you can
use to create the icon in the edit icon window. The update option controls how Visio updates 
the master shape icon. If you are creating a custom icon, choose Manual as the update 
option so you don't accidentally replace the custom icon when you edit the master shape.



Changing the colors for a master shape icon
Creating a master shape icon
Editing parts of a master shape icon
Updating master shape icons
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Creating a master shape icon

      Overview  

To create a master shape icon:
1. Make sure an original or copy of the stencil is open and that the stencil window is 

active. For details, see Opening an original stencil.
2. Select the master shape whose icon you want to create.
3. From the Master menu, choose Edit Icon.

The edit icon window opens. If an icon exists for the master, the icon appears in the 
window. The icon editing tools appear on the toolbar. 

4. Edit the icon or create a new icon. For details, see Editing parts of a master shape 
icon.

5. Click  to close the master shape 
drawing window.



6. From the File menu, choose Save.
You can also click the Save button.

See also
Changing the colors for a master shape icon
Editing parts of a master shape icon
Opening an original stencil
Updating master shape icons
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Editing parts of a master shape icon

      Overview  

Using tools in the edit icon window, you can edit and move parts of a master shape icon.

To open the icon edit window:
1. Make sure an original or copy of the stencil is open and the stencil window is active. 

For details, see Opening an original stencil.
2. Select the master shape whose icon you want to create.
3. From the Master menu, choose Edit Icon.

The edit icon window opens. If an icon exists for the master, the icon appears in the 
window. The icon editing tools appear on the toolbar. 

To move part of an icon:
1. In the edit icon window, choose the lasso tool or selection net tool.



2. Select the area you want to move.
3. Drag the selection to where you want it.

The area from which the icon part was moved is replaced with the stencil background
color.

4. Click  to close the master shape 
drawing window.

5. From the File menu, choose Save.

To delete part of an icon:
1. In the edit icon window, choose the lasso tool or selection net tool.
2. Select the area you want to delete.
3. From the Edit menu, choose Cut.

The deleted area is replaced with the stencil background color.



4. Click  to close the master shape 
drawing window.

5. From the File menu, choose Save.

See also
Changing the colors for a master shape icon
Creating a master shape from a shape in a drawing
Editing a master shape in a stand-alone stencil
Opening an original stencil
Updating master shape icons
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Changing the colors for a master shape icon

      Overview  

To open the icon edit window:
1. Make sure an original or copy of the stencil is open and that the stencil window is 

active. For details, see Opening an original stencil.
2. Select the master shape whose icon you want to create.
3. From the Master menu, choose Edit Icon.

The edit icon window opens. If an icon exists for the master, the icon appears in the 
window. The icon editing tools appear on the toolbar. 

To change the color one pixel at a 
time:

1. In the edit icon window, choose the icon pencil tool.
2. In the color palette, point to the color you want to use.



3. Click the color with the left or right mouse button.
The color appears in the Left Color box or the Right Color box on the toolbar.

4. Point to the pixel you want to change.
5. Click the pixel with the mouse button that is assigned the color you want.

6. Click  to close the master shape 
drawing window.

7. From the File menu, choose Save.

Tip: If you want to create icons that appear to have holes cut in them, use the stencil 
background color.

To change an area of color:
1. In the edit icon window, choose the paint bucket tool.
2. In the color palette, point to the color you want to use.
3. Click the color with the left or right mouse button.

The color appears in the Left Color or Right Color box on the toolbar.
4. Click a pixel in the area you want to change with the mouse button that is assigned 

the color you want.
Visio colors the pixel you clicked and all pixels of the same color within the 
contiguous area. 



5. Click  to close the master shape 
drawing window.

6. From the File menu, choose Save.

See also
Creating a master shape from a shape in a drawing
Editing a master shape in a stand-alone stencil
Editing parts of a master shape icon
Opening an original stencil



Creating your own templates

    Related procedures

You can create your own templates or revise the templates that come with Visio. 
Templates can include:
· One or more stencils, which are opened when you open a new drawing file with the 

template.
· One or more drawing pages, including background pages. Each page can contain a 

drawing and can use a different size and scale.
· Print settings from the Page Setup dialog box.
· Styles for lines, text, and fills.
· Snap and glue options set in the Snap & Glue dialog box.
· A color palette from the Color Palette dialog box.
· Window sizes and positions.
When you create templates, keep these things in mind:
· The scale of a drawing page is set by a template. The scale of a master shape is set by 

the scale at which the master shape is drawn. To avoid unexpected behavior, master 
shapes and drawing pages should use the same scale, or one scale should be no more 
than eight times greater than the other.

· You can create a template from a new drawing file. Open the drawing file, set the options
and open the stencils you want, and then save the new drawing file as a template.

· You can also create a template from a drawing file that's already set up the way you 
want. If you don't want to include drawings in the template, open a copy of the drawing 
file, and then delete the drawings and the master shapes on the drawing file stencil. 
Save the copy of the drawing file as a template.



Creating a template
Editing a template file
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Creating a template

      Overview  

By creating a template, you can store stencils, styles, a color palette, and page settings so 
you can use them at any time. You create a template by saving a drawing file with the 
settings you want for the template.

To create a template:
1. Open the drawing file on which you want to base the template.
2. If you want the template to open one or more stencils, open the stencils.
3. Arrange the stencil and drawing windows as you want them to appear when you open

a new drawing file with the template.
4. Change or define options and settings that you want to include in the template.

A template usually includes settings for items such as styles, page display options, 
and the drawing scale.

5. From the File menu, choose Save As.
6. In the Save section, make sure Workspace is checked.
7. From Save As, choose Template (*.VST).

You may want to choose a different folder in which to save the file.
8. In the File Name box, enter a name for the template, click Save, then click OK in the 

Properties dialog box.

See also
Creating a new stencil
Creating a style
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Editing a template file

      Overview  

You can edit an original template file to make changes to the template settings. If you want 
to make changes to a template and preserve the original settings, you can open and edit a 
copy of a template.

To edit a template file:
1. From the File menu, choose Open.
2. In the File Name box, type or choose the template file you want to open.

If you don't see the filename, choose Template (*.VST) from the Save As list, or choose 
a different folder.

3. In the Open section, choose Original to open the original template, or choose Copy to 
open a copy of the template.

4. Click OK.
5. Change settings and options for the template, such as styles, drawing scale, and 

page display options.
6. From the File menu, choose Save.

You can also click the Save button.

See also
Creating a template



Working with stencils

    Related procedures

There are two types of stencils:
· A stand-alone stencil is a stencil file with the extension .VSS that can be opened 

separately or by a template.
· A drawing file stencil is a stencil stored in a drawing file. It contains copies of the master 

shapes used in that drawing file.
When you add or edit master shapes in a stand-alone stencil, the new or revised master 
shapes become available for any new drawing you create using that stencil or a template 
that opens the stencil. Instances of the master shapes in existing drawings are not affected.
When you add or edit master shapes in a drawing file stencil, the changes affect only that 
drawing file. The master shapes are linked to their instances in the drawing, so changes you 
make to master shapes in a drawing file stencil are reflected in each instance of the shape in
the drawing. 



Arranging master shapes in a stencil
Creating a new stencil
Deleting a master shape from a stencil
Opening an original stencil
Saving a drawing file stencil as a stand-alone stencil
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Opening an original stencil

      Overview  

To create and edit master shapes in a stencil, you need to open the original stencil file. When
an original stencil file is open, its name appears without brackets in the stencil window title 
bar. You cannot open an original stencil if a read-only copy of the stencil is open already. If a 
read-only copy of a stencil is open, close the copy, and then open the original.

To open an original stencil file:
1. From the File menu, choose Stencils.

You can also click the Stencils button.
2. From the Select Stencil list, choose the name of the stencil you want to open.
3. In the Open section, choose Original.
4. Click OK.



To open a copy of a stencil:
1. From the File menu, choose Open.
2. Under Files Of Type, select Stencil (*.VSS).
3. In the Look In box, open the Stencils folder, then open the folder in which the stencil 

is located.
4. Select the stencil you want.
5. Under Open, click Copy.
6. Click the Open button.

See also
Creating a master shape from scratch
Editing a master shape in a stand-alone stencil
Specifying master shape characteristics
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Creating a new stencil

      Overview  

You can base a new stencil on an existing stencil or create a new blank stencil and add 
master shapes to it. By creating new stencils, you can store master shapes from several 
stencils in one stencil or store a set of master shapes for a particular type of drawing.

To create a new stencil:
1. From the File menu, choose New.
2. In the New section, choose Stencil.
3. From the Based On list, choose No Stencil to create a blank stencil, or choose the 

stencil on which you want to base the new stencil.
4. Click OK.
5. Create master shapes, or drag and drop master shapes from other stencils you want 

to store in the new stencil.
6. From the File menu, choose Save As.
7. In the Save As section, make sure Stencil (*.VSS) is chosen.
8. In the File Name box, type a name for the stencil file.
9. If you want to protect the stencil from accidental changes, check Read Only in the 

Save section.
You may want to choose a different folder in which to save the file.

10. Click Save.

See also



Creating a template
Displaying a drawing file stencil
Opening a stencil
Saving a drawing file stencil as a stand-alone stencil
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Saving a drawing file stencil as a stand-alone stencil

      Overview  

You can save a copy of a drawing file stencil as a stand-alone stencil. After saving the 
drawing file stencil, you can use its master shapes in other drawings.

To create a stand-alone stencil from a
drawing file stencil:

1. From the File menu, choose Open.
2. From the File Name list, choose the drawing file you want to use as the basis of the 

new stencil.
3. In the Open section, choose Copy, and then click OK.
4. From the Window menu, choose Show Master Shapes.
5. Make sure the drawing window is active. From the Edit menu, choose Drawing Page, 

then choose Delete from the Page menu.
6. In the Delete dialog box, click a page, hold down the Shift key and choose all other 

pages, and then click OK.
7. From the File menu, choose Save As.
8. From the Save As list, choose Stencil (*.VSS).

You may want to choose a different folder in which to save the file.
9. Type a name for the new stencil file, and then click Save.

See also
Opening a stencil





Deleting a master shape from a stencil



 



Deleting a master shape from a stencil

      Overview  

If you no longer need a master shape, you can delete it. Deleting a master shape breaks the 
connection between the master and any instances in a drawing.

To delete a master shape:
1. Open the stencil file that contains the master shape you want to delete.

Make sure to open the original stencil or a copy. For details, see Opening an original 
stencil.

2. In the stencil window, select the master shape.
3. From the Edit menu, choose Clear.

Note: Before you delete a master shape from a drawing file stencil, Visio warns you 
that deleting the master shape breaks the connection between the master and its 
instances. Click OK to delete the master, or click Cancel to cancel deletion.

4. From the File menu, choose Save.
You can also click the Save button.

See also
Arranging master shapes in a stencil
Deleting shapes
Opening an original stencil
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Arranging master shapes in a stencil

      Overview  

You can change the order of master shapes in a stencil to make the shapes you use 
frequently more accessible. You can also arrange master shapes after you modify or delete 
master shapes in a stencil.

To change the order of master 
shapes:

1. Open the stencil file that contains the master shape you want to arrange.
Make sure to open the original stencil or a copy. For details, see Opening an original 
stencil.

2. Drag each master shape icon to arrange them in the order you want.
3. From the File menu, choose Save.

You can also click the Save button.

Tip: To automatically arrange master shapes when you modify a stencil, right-click the 
stencil, then choose Auto Arrange from the shortcut menu. If Auto Arrange is not checked, 
choose Arrange Icons from the shortcut menu.

See also
Opening an original stencil
Updating master shape icons



 



Visio and OLE Automation

    Related procedures

You can use a programming language that supports OLE Automation, such as Visual Basic 
3.0, to write programs that control Visio shapes and drawings. A program can use OLE 
Automation to incorporate the drawing and diagramming capabilities of Visio or automate 
simple repetitive tasks. For example, a program might generate an organization chart from a
list of names and positions or print all of the master shapes on a stencil.
A program controls Visio by accessing its objects and then using their properties and 
methods:
· Objects represent items you work with in Visio, such as documents, drawing pages, 

shapes, and formulas.
· Methods are actions that can be performed with an object. For instance, a program can 

use the Copy method of a Window object to copy a selected shape to the Clipboard. This 
method is equivalent to selecting a shape on the drawing page and using the Copy 
command on the Edit menu in Visio.

· Properties are attributes that determine the appearance or behavior of objects. For 
example, a Shape object has a Name property, which represents the name of that shape.

For complete information about writing programs to control Visio, see Developing Visio 
Solutions (published by Visio Corporation). For information about Visio objects, methods, and
properties, see the online OLE Automation reference, supplied with Visio Technical and with 
the disk that accompanies Developing Visio Solutions.



Running add-ons
Viewing a sample program
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Running add-ons

      Overview  

An add-on is a program that adds functionality to Visio. Exactly how you run an add-on 
depends on the context for which it was designed. If an add-on is designed to be run 
externally to Visio, you run it like any Windows program (for example, by double-clicking an 
icon on the Desktop). For details, see your Windows documentation.
If a program is designed to be run in Visio, you might run it in either of these ways:
· Choose the add-on from Visio's Run Add-on submenu or dialog box. The program's .EXE 

file must be in Visio's Add-ons folder to appear on this menu or in the dialog box.
· Double-click a shape associated with the add-on. The program must be selected in the 

Run Add-on option of the Double-Click dialog box for the shape.

To run an add-on from Visio's Tools 
menu:

1. From the Tools menu, choose Run Add-on.
2. From the Run Add-on submenu, choose the program to run. If the program doesn't 

appear on the submenu, choose Add-ons and choose the program in the dialog box, 
then click OK.



To associate an add-on with a shape 
and run the add-on:

1. Select the shape.
2. From the Format menu, choose Double-Click.
3. In the Double-Click dialog box, choose the Run Add-on option.
4. From the list of add-ons, select the one you want to run.
5. Click OK.
6. Double-click the shape to run the program.

You can also associate an add-on with a shape by entering a formula that uses the 
RUNADDON or RUNADDONWARGS function in the EventDblClick cell in the ShapeSheet.

See also
Viewing a sample program
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Viewing a sample program

      Overview  

This sample Visual Basic program examines the open drawings in Visio and then prints the 
name of each drawing file, followed by the names of the pages in the drawing. 

The program does the following:
1. Finds a drawing file that is open in Visio.
2. Prints the path of the drawing file. 
3. Prints the name of each page in the drawing file.
4. Repeats steps 1 through 3 until all open drawing files have been listed.

The program looks like this:
This Visual Basic code Does this
Sub ShowNames () Variable declarations
   Dim iDoc As Integer, iPag As Integer
   Dim appVisio As Object
   Dim pagObj As Object, docObj As Object
   Dim docsObj As Object
   Set appVisio = GetObject(,"visio.application")
   Set docsObj = appVisio.Documents Gets all open drawings
    For iDoc = 1 To docsObj.Count
       Set docObj = docsObj(iDoc) Gets one drawing
       Printer.Print docObj.Name Prints its name
         For iPag = 1 To docObj.Pages.Count
           Set pag = docObj.Pages(iPag) Gets a page
           Printer.Print Tab(5); pagObj.Name Prints its name



         Next iPag
    Next iDoc
    Printer.EndDoc
End Sub
Here's an example of the program's output:

Sample output Description
c:\drawings\pages.vsd The name of the first drawing
     Background-1      The name of page 1
     Background-2      The name of page 2
c:\drawings\recycle.vsd The name of the second drawing
     Page-1      The name of page 1
     Page-2      The name of page 2
     Page-3      The name of page 3
See also
Running add-ons
 



Drag and drop drawing

    Related procedures

Dragging and dropping master shapes
The easiest way to create drawings is to drag master shapes from stencils and drop them on
the drawing page. This is called drag and drop drawing. When you drag a master shape into 
a drawing, you create an instance of the master shape. You can drag and drop a master 
shape with drawing tools, but it's easiest to use the pointer tool.
As you drag, a line (representing a 1-D shape) or a box (representing a 2-D shape) shows the
shape's location on the page. If you pause while dragging, you'll see the shape instead of a 
line or box, so you can position the shape more precisely.
For drawings such as flowcharts, organization charts, and network diagrams, you'll need to 
connect shapes. You can connect shapes in a variety of ways, including dragging and 
dropping connector master shapes.

Drawing file stencil
The first time you create an instance of a master in a drawing, Visio creates a copy of the 
master in the drawing file stencil. When you edit a master shape stored in the drawing file 
stencil, you can update all instances of the master in that drawing file at the same time.



Dragging and dropping connector shapes
Dragging and dropping master shapes



Drawing shapes

    Related procedures

Visio comes with a variety of drawing tools. You can use the pencil tool to draw both lines 
and arcs. As you begin to draw with the pencil tool, Visio quickly calculates the path the 
mouse is traveling and draws a line if the path is straight or an arc if the path curves.
You can also use the line tool, arc tool, ellipse tool, rectangle tool, or freeform tool to draw 
shapes.
When drawing shapes, it's often helpful to use guides and grid lines to help you position the 
shapes. When creating complex shapes, use the Union, Combine, Fragment, Intersect, or 
Subtract commands (on the Shape menu and Operations submenu) to help you join and 
break up simpler shapes.



Closing a shape
Drawing ellipses and circles
Drawing freeform shapes
Drawing lines and arcs
Drawing rectangles and squares
Drawing shapes with several segments
Undoing segments while drawing
What is a shape?
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What is a shape?

      Overview  

When you create a drawing in Visio, you can drag master shapes from stencils or draw your 
own shapes on the drawing page. A shape is one line or arc, a series of line and arc 
segments, or several shapes grouped together. A single line, for example, is a shape, and so 
is a drawing of several shapes grouped together.

1-D and 2-D shapes
A Visio shape can be either one-dimensional (1-D) or two-dimensional (2-D).
A 1-D shape has endpoints and behaves like a line. 1-D shapes are often used as connectors 
between two 2-D shapes. When you select a 1-D shape with the pencil tool, you'll also see 
the control point. You can drag the control point to change lines to arcs and arcs to lines. You
can also use the control point to change the bow of an arc.
A 2-D shape displays vertexes (rather than endpoints) at the ends of segments. When a 2-D 
shape is selected with the pencil tool, each segment displays a control point.
You can convert a shape from 2-D to 1-D so you can use it as a connector, or you can 
convert a 1-D shape to a 2-D shape, which lets you size it proportionally by dragging its 
corner handles.

Closed and open shapes
A shape is either closed or open. Shapes like rectangles or circles are closed shapes. Lines, 
half-circles, or zigzag shapes are open shapes. You can fill closed shapes with colors and 
patterns. You can format the ends of open shapes. For example, any open shape can have 
an arrowhead at each end.

See also
Changing 1-D and 2-D behavior
Dragging and dropping master shapes
Drawing rectangles and squares
Drawing shapes with several segments
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Dragging and dropping master shapes

      Overview  

The easiest way to create a drawing is to drag master shapes from stencils and drop them 
into drawings.

To drag a master shape into a 
drawing:

1. From the toolbar, choose the pointer tool.
2. In the stencil window, point to the icon for the master shape.
3. Hold down the left mouse button and drag the master shape from the stencil to the 

drawing page.
4. Release the mouse button to drop an instance of the master shape in the drawing.

See also
Dragging and dropping connector shapes
Stamping master shapes
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Dragging and dropping connector shapes

      Overview  

You can drag and drop connector master shapes to connect shapes in a drawing. To connect 
shapes, you drag the connector to the shape you want to glue it to. The connections are 
made at connection points, which appear as blue Xs on the screen. 
Connection points can be on a shape's perimeter, inside the shape, or even outside the 
shape. You can glue the endpoint of a 1-D shape to points on 2-D shapes and to groups, to 
objects from other programs, or to an endpoint or connection point on another one-
dimensional shape.

To glue a connector shape using the 
drag and drop technique:

1. Drag the shapes you want to connect into position on the drawing page.
2. Drag the connector shape from the stencil window into the drawing window.

You can use any 1-D shape as a connector. When you are using a stencil that contains
the Universal connector master shape, it's best to use that shape.

3. Drag an endpoint of the connector shape to the connection point you want to glue it 
to.
If the glue is successful, the endpoint turns red.

4. Drag the other connector shape endpoint to the point you want to glue it to.

To glue a connector shape to points other than connection points on other shapes, you need 
to set glue options in the Snap & Glue dialog box.
Tip: You can also connect shapes as you drag them from the stencil and drop them on the 
page. For details, see Connecting a series of shapes automatically.



See also
Creating and deleting connection points
Setting glue options
Stamping master shapes
Using the connector tool to connect two shapes 
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Drawing ellipses and circles

      Overview  

To draw an ellipse or a circle:
1. From the drawing tool menu, choose the ellipse tool.
2. Point to where you want to start drawing the shape.
3. Drag until the shape is the size you want.

For a circle, hold down the Shift key as you drag.
4. Release the mouse button.

See also
Changing 1-D and 2-D behavior
Drawing lines and arcs
Moving shapes by dragging
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Drawing freeform shapes

      Overview  

The freeform tool draws smooth curves. For example, you can draw network wiring that is 
smooth, not jagged.

To draw a freeform shape:
1. From the drawing tool menu, choose the freeform tool.
2. Hold down the left mouse button as you drag in various directions to draw a freeform 

shape, then release the mouse button.
To connect another freeform shape to the end of the first one, place the cursor over 
the end of the first freeform shape, then click and drag the second freeform shape.

3. To edit a freeform shape while it is still selected, click and drag a control point.
To edit more than one control point at a time, press the Shift key while clicking 
multiple control points.
To delete a control point, select it, then press the Del key.
To add a control point, press the Ctrl key while clicking the freeform shape.
To resize a freeform shape, select the shape with the pointer, then drag a selection 
handle.
Note: If the freeform shape is not selected, from the drawing tool menu, choose the 
pencil tool, then click a control point.

4. When you're finished, choose the pointer or another tool from the toolbar to continue 
working on the diagram.

To change freeform shape defaults, choose Options from the Tools menu, then edit the 



Freeform Drawing section.

See also
Changing 1-D and 2-D behavior
Changing shape angles by dragging a vertex
Drawing lines and arcs
Moving shapes by dragging
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Drawing rectangles and squares

      Overview  

To draw a rectangle or square:
1. From the drawing tool menu, choose the rectangle tool.
2. Point to where you want a corner of the shape.
3. Drag until the shape is the size you want.

To draw a square, hold down the Shift key as you drag.
4. Release the mouse button.

See also
Drawing freeform shapes
Drawing lines and arcs
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Drawing lines and arcs

      Overview  

To draw a line or an arc:
1. From the drawing tool menu, choose the pencil tool.

Alternatively, choose the line tool or the arc tool.
2. Point to where you want to start the line or arc.
3. Drag to draw the line or arc.

To draw lines at 45 intervals, hold down the Shift key as you draw lines.
To constrain the shape of the arc, hold down the Shift key as you draw arcs.

4. Release the mouse button.

Note: Arcs differ depending on which tool you use to draw them. An arc you draw with the 
pencil tool is a portion of a circle. The portion and size of the circle vary depending on how 
you move the mouse. An arc you draw with the arc tool is always a quarter of an ellipse.

See also
Changing 1-D and 2-D behavior
Changing an arc's eccentricity
Changing shape angles by dragging a vertex
Drawing ellipses and circles
Drawing freeform shapes
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Drawing shapes with several segments

      Overview  

To draw a shape with more than one segment, start each new segment at one of the 
endpoints or at a vertex on another segment. You can delete a segment you draw by 
choosing Undo from the Edit menu. You can also adjust, add, and delete segments after you 
complete the shape.

To draw a shape with several 
segments:

1. From the drawing tool menu, choose the pencil tool.
Alternatively, choose the line tool, arc tool, or freeform tool.

2. Point to where you want to start the shape.
3. Drag to create the first segment and release the mouse button.
4. Point to one of the endpoints of the first segment, and then drag to draw the next 

segment. When you finish, release the mouse button.
Be careful not to click the endpoint of the first segment. If you select an endpoint, it 
turns magenta. If you drag an endpoint, Visio resizes the existing segment instead of 
starting a new one (if you resize a segment rather than draw a new one, choose Undo
from the Edit menu).

5. To draw additional segments, point to a vertex on one of the segments you've drawn, 
and then drag to draw the next segment.

See also
Closing a shape
Drawing freeform shapes



Undoing segments while drawing
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Closing a shape

      Overview  

To close a shape in Visio, drag the last vertex of the shape so that it meets the first vertex.

To close a shape:
1. Drag the last segment of the shape until the mouse pointer is over the last open 

vertex for the shape.
2. Release the mouse button.

See also
Adding segments to shapes
Deleting segments from shapes
Undoing segments while drawing
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Undoing segments while drawing

      Overview  

If you need to change or delete a segment while drawing with the pencil tool, line tool, arc 
tool, or freeform tool, you can start a segment over before you finish drawing it or undo 
segments one at a time.

To start a segment over:
1. Before you release the mouse button at the end of a segment, drag back to the 

vertex at the beginning of the segment.
Make sure you hit the vertex precisely or you may not delete the segment 
completely.

2. Redraw the segment.

Tip: To zoom in for a closer look, choose a percentage from the Zoom box, or press 
Ctrl+Shift+left mouse button.



To undo segments one at a time:
1. After you draw segments, but before you perform other actions, choose Undo from 

the Edit menu.

See also
Adding segments to shapes
Changing shape angles by dragging a vertex
Deleting segments from shapes
Grouping and ungrouping shapes



Copying, duplicating, and deleting shapes

    Related procedures

You can use commands to copy, cut, paste, and duplicate shapes. By indicating exactly 
where you want Visio to place a copy of a shape, you can quickly create borders or evenly 
spaced boxes in organization charts.
You can also copy and move shapes from one drawing to another by selecting shapes and 
copying them to the Windows Clipboard or by dragging shapes from one drawing to another.
If you no longer need a shape in a drawing, you can delete it from the drawing.



Copying shapes in the current drawing
Copying shapes to another drawing
Deleting shapes
Dragging shapes to another drawing
Stamping master shapes
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Copying shapes in the current drawing

      Overview  

You can copy a shape at a standard distance from the original shape or drag a copy of a 
shape exactly where you want it. After copying a shape, you can quickly create additional 
copies¾each additional copy is offset from the previous copy by the same amount as the 
first copy is offset from the original.

To duplicate a shape:
1. Select the shape.
2. From the Edit menu, choose Duplicate.
3. To create additional copies equally spaced apart, press F4 for each additional copy 

you want to create.

To copy a shape at a specific location:
1. Select the shape.



2. Hold down the Ctrl key and drag the shape where you want the copy.
3. Release the mouse button.

The copy appears where you release the mouse button.
4. To create additional copies equally spaced apart, press F4 for each copy you want.

Note: You can also use the Copy and Paste commands to duplicate shapes in a drawing; 
however, the Duplicate command is quicker and easier.

See also
Copying and applying shape formatting
Copying shapes into another drawing
Deleting shapes
Embedding Visio shapes in another document
Pasting information in a particular format
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Deleting shapes

      Overview  

To delete a shape from a drawing:
1. Select the shape.
2. From the Edit menu, do one of the following:

· To delete the shape from the drawing, choose Clear.
· To delete the shape and place a copy on the Clipboard, choose Cut or click the Cut 

button on the toolbar.

See also
Adding and removing shapes in groups
Adding segments to shapes
Copying shapes into another drawing
Deleting segments from shapes



Joining and fragmenting shapes

    Related procedures

You can create complex shapes by drawing simple components and then using an 
Operations command to create a complex shape.

Use this 
command:

To do this:

Combine Combine shapes to create 
shapes with holes in them (such 
as picture frame shapes and 
doughnut shapes) and shapes 
with multiple paths.

Fragment Break a closed shape into 
smaller parts.
Create a new closed shape 
where two or more closed 
shapes overlap.
Create a new closed shape from 
the enclosed area of two or 
more lines, arcs, or smooth 
curves (splines).

Intersect Create a new shape that is the 
intersected area of two or more 
shapes.

Subtract Create a new shape by 
subtracting one or more shapes 
from an existing shape.

Union Unite two or more overlapping 
closed shapes to create one 
shape from the perimeters of 
other shapes.

When you create new shapes with the Combine, Subtract, or Union command, the new 
shape inherits the formats and text of the first shape you select. The formats and text of 
other shapes are discarded.
Note: When you unite, combine, intersect, or subtract shapes, you change their 
ShapeSheets. Each original shape has a ShapeSheet, but after the shapes are united or 
combined, only the new shape has a ShapeSheet.





Combining shapes
Fragmenting shapes
Intersecting shapes
Subtracting shapes
Uniting shapes
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Uniting shapes

      Overview  

You can unite two or more overlapping closed shapes to create one shape from their 
perimeters.

To unite shapes:
1. Arrange the shapes that you want to unite on the drawing page.
2. Select the shapes.
3. From the Shape menu, choose Operations, then choose Union.

If the shapes do not overlap, the Union command creates one shape, but the shapes appear 
unchanged. If a shape is open, Visio discards the open shape when you choose Union.

See also
Combining shapes
Fragmenting shapes
Grouping and ungrouping shapes
Intersecting shapes
Subtracting shapes
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Fragmenting shapes

      Overview  

By using the Fragment command, you can break a shape into smaller parts. You can also 
create new shapes from 2-D shapes that overlap or from intersecting lines. The Fragment 
command provides an ideal way to create Venn diagrams and marketing pyramids.

To break a 2-D shape into smaller 
parts:

1. Draw lines through the shape where you want to break it.
2. Select the shape and the lines.
3. From the Shape menu, choose Operations, then choose Fragment.

To create new shapes where 2-D 
shapes overlap:

1. Select the overlapping shapes.



2. From the Shape menu, choose Operations, then choose Fragment.

To create a new shape from 
intersecting lines:

1. Select the intersecting lines.
2. From the Shape menu, choose Operations, then choose Fragment.

Tip: After you fragment shapes, delete the pieces you don't need.

See also
Combining shapes
Grouping and ungrouping shapes
Intersecting shapes
Subtracting shapes
Uniting shapes
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Intersecting shapes

      Overview  

You can create one closed shape from the area in which two shapes overlap or intersect. The
new shape inherits the text and formatting of the first shape you select. 
Note: When you intersect two or more shapes, Visio creates a ShapeSheet for the new 
shape and deletes the ShapeSheets of the original shapes.

To intersect shapes:
1. Arrange the shapes you want to intersect on the drawing page.
2. Select the shapes.
3. From the Shape menu, choose Operations, then choose Intersect.

See also
Combining shapes
Fragmenting shapes
Grouping and ungrouping shapes
Subtracting shapes
Uniting shapes



Subtracting shapes





Subtracting shapes

      Overview  

The Subtract command works like a cookie cutter. Overlap two shapes, select the first one, 
and then the second. Choose Subtract to delete the second shape you selected, leaving its 
shape cut into the first. (The overlapping segment of the second shape is "subtracted" from 
the first.)
When you use this command on two or more shapes, Visio creates a ShapeSheet for the new
shape and deletes the ShapeSheets of the original shapes.

To subtract shapes:
1. Arrange the shapes you want to subtract on the drawing page.
2. Select the shapes.
3. From the Shape menu, choose Operations, then choose Subtract.

See also
Combining shapes
Fragmenting shapes
Grouping and ungrouping shapes
Intersecting shapes
Uniting shapes



 Stamping master shapes





Stamping master shapes

      Overview  

You can use the stamp tool to quickly create copies of a master shape.

To stamp a master shape:
1. From the connection tool menu, choose the stamp tool.
2. In the stencil window, click the icon for the master shape.
3. In the drawing window, place the pointer where you want the center of the shape.
4. Click the left mouse button.

Tip: If you want to glue an endpoint of a 1-D shape to a point on another shape, select a 1-D
master shape and drag the stamp tool between the points you want to connect. If an 
endpoint of a 1-D shape is successfully glued to a point on another shape, the endpoint 
turns red.

See also
Connecting shapes with the stamp tool
Dragging and dropping connector shapes
Dragging and dropping master shapes



Copying shapes to another drawing





Copying shapes to another drawing

      Overview  

To copy a shape and paste it in 
another drawing:

1. Select the shape.
2. From the Edit menu, choose Copy, or click the Copy button on the toolbar.
3. Display the drawing that you want to paste the shape into.

If the drawing is in the same drawing file as the current drawing, from the Edit menu, 
choose Go To, then choose Page. Choose the page you need. If the drawing is in a 
different file, open the file and display the correct page.

4. From the Edit menu, choose Paste, or click the Paste button on the toolbar.
The shape is pasted into the middle of the page.

See also
Copying and applying shape formatting
Copying shapes in the current drawing
Creating a new page
Dragging shapes to another drawing



Dragging shapes to another drawing





Dragging shapes to another drawing

      Overview  

By dragging shapes, you can move or copy shapes from one drawing to another.

To move shapes by dragging:
1. Display the drawing page with the shape you want to move. 
2. In a separate window, display the drawing page you want to move the shape to.
3. Point to the shape you want to move.
4. Drag the shape to the other drawing window.

The shape is deleted from the original drawing and appears in the second drawing.

To copy shapes by dragging:
1. Display the drawing page that contains the shape you want to copy. 
2. In a separate window, display the drawing page you want to copy the shape to.



3. Point to the shape you want to copy.
4. Hold down the Ctrl key and drag the shape to the other drawing window.

A copy of the shape appears in the second drawing.

See also
Copying shapes in the current drawing
Creating a new page
Deleting shapes
Embedding Visio shapes in another document
Pasting information in a particular format



Combining shapes





Combining shapes

      Overview  

You can use the Combine command to create shapes with holes in them (such as picture 
frame shapes and doughnut shapes) and other shapes with multiple paths. For example, to 
create a doughnut shape, place a small circle in the middle of a larger one, and then 
combine the shapes.

To combine shapes:
1. Arrange the shapes you want to combine on the drawing page.
2. Select the shapes.
3. From the Shape menu, choose Operations, then choose Combine.

You can also combine 1-D shapes with each other and combine 1-D and 2-D shapes together.
In these cases, Visio creates one shape from the selected shapes, but the new shape might 
not look different from the old ones. The new shape has one ShapeSheet with multiple 
sections. When you apply a style, such as a fill, the style formats the entire shape.

See also
Fragmenting shapes
Grouping and ungrouping shapes
Intersecting shapes
Subtracting shapes
Uniting shapes



 



Sizing and reshaping shapes

    Related procedures

By sizing and reshaping shapes, you can:
· Make 1-D shapes shorter, longer, or taller.
· Change the width and height of 2-D shapes.
· Add segments to and delete segments from shapes.
· Change the angle where two segments meet.
· Edit arcs (drawn with the arc tool, pencil tool, or freeform tool) with the pencil tool.
Every arc (drawn with the arc tool) follows the perimeter of an invisible circle or an ellipse. 
You can change the bow of an arc so the arc becomes a larger or smaller portion of the circle
or ellipse¾even flatten an arc to make it a line. You can also edit an arc by using its 
eccentricity handles to reshape the ellipse on which the arc is based and to change the 
angle at which the arc leans.



Adding segments to shapes
Changing an arc's eccentricity
Changing shape angles by dragging a vertex
Changing the size of a 1-D shape
Changing the size of a 2-D shape
Deleting segments from shapes
Reshaping arcs



Changing the size of a 1-D shape





Changing the size of a 1-D shape

      Overview  

You can change the size of a 1-D shape by dragging one of its endpoints. 1-D shapes that are
not straight lines have selection handles you can use to size the shape.

To make a 1-D shape longer or 
shorter:

1. With the pointer tool, select the shape.
2. Place the pointer over an endpoint until it changes to a four-headed arrow, then drag 

to make the shape the length you want.
3. Release the mouse button.

To make a 1-D shape thicker or 
thinner:

1. With the pointer tool, select the shape.



2. Place the pointer over a selection handle until it changes to a two-headed arrow, then
drag until the shape is the height you want.

3. Release the mouse button.

See also
Changing 1-D and 2-D behavior
Determining a 1-D shape's size and location
Moving shapes by dragging



Changing the size of a 2-D shape





Changing the size of a 2-D shape

      Overview  

You can change the width and height of a 2-D shape by dragging a selection handle. You can
size a 2-D shape in one direction at a time or size the shape in both directions at once to 
preserve the shape's proportions.

To size a 2-D shape:
1. With the pointer tool, select the shape.
2. Drag a selection handle until the shape is the size you want. To size the shape 

proportionately, drag a corner handle.

Tip: If you see fewer than eight handles on a 2-D shape, zoom in on the drawing to see the 
rest of the handles and to size the shape more accurately.

See also
Changing 1-D and 2-D behavior
Changing shape angles by dragging a vertex
Determining a 2-D shape's size and location
Selecting shapes



Adding segments to shapes





Adding segments to shapes

      Overview  

You can add segments to shapes to change the way shapes look. For example, you can turn 
a triangle into a rectangle. When you add a segment, Visio creates a new vertex where one 
end of the new segment meets the end of an existing segment.

To add a new segment to a shape:
1. With the pencil tool, select the shape.
2. Point to where you want to add the segment.
3. Hold down the Ctrl key and click.

Tip: Adding segments is sometimes easier when snap is turned off. It's also helpful to zoom 
into the drawing so you can clearly see when the pencil is over a line or arc segment.
After you add a segment, you may need to adjust the shape by dragging vertexes and 
control points to make the shape look the way you want.

See also
Changing shape angles by dragging a vertex
Deleting segments from shapes



Deleting segments from shapes





Deleting segments from shapes

      Overview  

If you want fewer segments in a shape, you can delete segments you don't want. For 
example, you can delete a segment from a rectangle to make it a triangle.
When you delete a segment, Visio redraws the shape on the basis of the order in which the 
shape's segments were created, whether a vertex is at the beginning or end of an open 
shape, and whether the segment that follows the one you delete is a line or an arc.

To delete a segment:
1. With the pencil tool, select the shape.
2. Point to a vertex on the segment you want to delete.

When the pointer is directly over a vertex, it changes from a pencil to a four-headed 
arrow. When the vertex is selected, it turns magenta.

3. Click the vertex to select it.
4. Press the Delete key, or choose Clear from the Edit menu.

After you delete segments, you may need to adjust the shape by dragging vertexes and 
control points to make the shape look the way you want.

See also
Adding segments to shapes
Changing shape angles by dragging a vertex
Undoing segments while drawing



Changing shape angles by dragging a vertex





Changing shape angles by dragging a vertex

      Overview  

By dragging a vertex, you can change the angle where two segments meet. Dragging a 
vertex often makes a segment longer or shorter. You can also select several vertexes and 
drag them all at the same time. The selected vertexes maintain their position in relation to 
each other and move in relation to the rest of the shape.

To reshape angles by dragging a 
vertex:

1. With the pencil tool, select the shape.
2. Click the vertex whose position you want to change.

When the pointer is directly over the vertex, it changes to a four-headed arrow. When
the vertex is selected, it turns magenta.

3. Drag the vertex to its new position.



To reshape angles by dragging 
multiple vertexes:

1. With the pencil tool, select the shape.
2. Click a vertex that you want to move, and then hold down the Shift key and click the 

other vertexes whose position you want to change.
3. Place the pointer over one of the selected vertexes, and then drag.

The selected vertexes move together, maintaining their relationship to one another.

See also
Adding segments to shapes
Deleting segments from shapes
Drawing freeform shapes
Drawing lines and arcs
Reshaping arcs 



Reshaping arcs





Reshaping arcs

      Overview  

You can change the bow of an arc, flatten an arc until it becomes a line, or reshape a line to 
make it an arc. An arc has an invisible snap point in the middle of an invisible line between 
its two endpoints. When you drag the control point to that snap point, the arc becomes a 
line.

To reshape an arc:
1. With the pencil tool, select the arc or the shape that contains the arc.
2. Point to the arc's control point.
3. Drag the control point until the arc looks the way you want.

See also
Adding segments to shapes
Changing an arc's eccentricity
Changing shape angles by dragging a vertex
Deleting segments from shapes
Determining a 2-D shape's size and location
Drawing lines and arcs



Changing an arc's eccentricity





Changing an arc's eccentricity

      Overview  

By dragging an arc's eccentricity handles, you can reshape the invisible ellipse the arc is 
based on. You can change the flatness of an arc (the arc's magnitude of eccentricity) or 
change the way an arc leans (the arc's angle of eccentricity).

To change an arc's eccentricity:
1. With the pencil tool, select the arc or shape that contains the arc.
2. Click the control point on the arc to display the eccentricity handles.

On circular arcs, the eccentricity handles are under the control point.
If you don't see the eccentricity handles, hold down the Ctrl key and drag the pointer 
slightly away from the control point to display the eccentricity handles.

3. Edit the arc by doing the following:
To change the arc's magnitude of eccentricity, drag an eccentricity handle farther 
from or closer to the control point.
To change the arc's angle of eccentricity, drag an eccentricity handle around the 
control point.

See also
Adding segments to shapes
Changing shape angles by dragging a vertex
Drawing lines and arcs
Reshaping arcs



 Grouping shapes

    Related procedures

Consider grouping shapes that you use together regularly. A group can be formatted, moved,
and sized as a single shape, but you can also format and edit the shapes in a group 
individually. You can group any shapes on the same drawing page, regardless of their 
distance from each other.
You can work with groups in the group window. By opening the group window, you can add 
or remove shapes from a group, rotate shapes in a group, or edit the shapes in a group 
individually.
Keep these things in mind as you work with groups:
· You cannot edit a group with the pencil tool in the drawing window. However, when you 

open the group in the group window, you can edit the shapes in the group with the pencil
tool or with the other commands and tools you use to edit shapes in the drawing window.

· A group can include guides and objects from other programs. A group has a ShapeSheet, 
as does each shape and each object in the group.

· If you add a guide and the shapes glued to it to a group, be sure to select both the guide 
and shapes before you add them to the group; otherwise the glue breaks. You can only 
add guides to rotated groups when the group is displayed in the group window.

· If you want to rotate a group's shapes individually, open the group in the group window. 
Bitmaps or other imported objects will not rotate even when you rotate the group they 
are included in. To rotate an imported object, first convert it to a Visio group.

· If you want to size, move, or rotate a text block for a shape in a group, open the group in 
the group window, and then select the text block with the text block tool.



Adding and removing shapes in groups
Editing and formatting a group
Editing the shapes in a group
Formatting and adding text to a shape in a group
Grouping and ungrouping shapes
Setting a group's sizing behavior
Updating a group's selection rectangle



Grouping and ungrouping shapes





Grouping and ungrouping shapes

      Overview  

To group shapes:
1. Select the shapes you want to include in the group.
2. From the Shape menu, choose Grouping, then choose Group.

To ungroup shapes:
1. Select the group.
2. From the Shape menu, choose Grouping, then choose Ungroup.

When you ungroup shapes, Visio discards the group's ShapeSheet.
If you ungroup an instance of a master shape, the instance no longer inherits characteristics 
from the master shape in the drawing file stencil.



See also
Combining shapes
Editing and formatting a group
Editing the shapes in a group
Uniting shapes



Adding and removing shapes in groups





Adding and removing shapes in groups

      Overview  

You can add shapes to or remove shapes from a group.

To add shapes to or remove shapes 
from a group:

1. Select the group.
2. Hold down the Shift key and select the shapes you want to add to or remove from the

group.
3. From the Shape menu, choose Grouping, then choose Add To Group or Remove From 

Group.

You can also add and remove shapes without ungrouping the group. To add a shape to a 
group, select the group, and then choose Open Group from the Edit menu to open the group 
window. Select the shape you want to add to the group, and then drag it into the group 
window.
To remove a shape from a group, open the group window and delete the shape you want to 
remove from the group.

See also
Editing and formatting a group
Editing the shapes in a group
Grouping and ungrouping shapes
Updating a group's selection rectangle



Editing and formatting a group





Editing and formatting a group

      Overview  

You can size, move, rotate, and format a group without opening the group in the group 
window. You edit and format a group in much the same way as you do other shapes.
When you format the entire group, the formatting affects all the shapes in the group. When 
you add text to a group, the text appears on the shape at the front of the stacking order in 
the group.

To edit or format a group:
1. Select the group.
2. Size, move, rotate, format, or add text to the group as you would for other shapes.

See also
Editing the shapes in a group
Formatting fills and shadows
Moving shapes by dragging
Rotating shapes with the rotation tool



Updating a group's selection rectangle





Updating a group's selection rectangle

      Overview  

After you edit groups in the group window¾for example, after you change the contents of a 
group or reshape a shape in a group¾you can update the group's selection rectangle in the 
drawing window to fit the new dimensions.

To adjust a group's selection 
rectangle:

1. Select the group.
2. From the Tools menu, choose Update Alignment Box.

Note: Some master shapes included with Visio have unusually large or small selection 
rectangles that are specifically designed to match the selection rectangles on related 
shapes. You should not adjust selection rectangles on instances of these shapes unless you 
plan not to use the shape with another related shape.

See also
Editing the shapes in a group
Flipping and reversing shapes
Grouping and ungrouping shapes



Editing the shapes in a group





Editing the shapes in a group

      Overview  

You can edit the shapes in a group individually by opening the group in the group window. In
the group window, the group is not rotated even if it is rotated on the drawing page, so you 
can align shapes with grid lines and ruler intervals.

To open the group window and edit a 
shape:

1. Select the group.
2. From the Edit menu, choose Open Group.
3. Edit the shapes in the group as you would edit ungrouped shapes on the drawing 

page.
As you make changes, you can see the changes in both the group window and the 
drawing window.

4. To close the group window, click the X box in the upper-right corner of the window.

Note: By default, when you double-click a group, the group window opens. However, 
double-clicking a group may cause different behavior if the group's double-click action has 
been changed.

See also
Adding and removing shapes in groups
Editing and formatting a group
Specifying a shape's double-click behavior



Formatting and adding text to a shape in a group





Formatting and adding text to a shape in a group

      Overview  

You can format and add text to shapes in a group without opening the group window.

To format or add text to a shape in a 
group:

1. Select the group, then pause.
Green selection handles appear on the group.

2. Click the shape you want to work with to subselect it.
Gray selection handles appear on the shape.

3. Format or add text to the shape, just as you would to an ungrouped shape.

Tip: If you want to size, move, or rotate a text block for a shape in a group, first open the 
group in the group window, and then select the text block with the text block tool.

See also
Checking the spelling of text
Editing and formatting a group
Editing the shapes in a group
Typing text into shapes



Setting a group's sizing behavior





Setting a group's sizing behavior

      Overview  

When you resize a group, a shape in the group either resizes with the group or maintains its 
original size. Each shape in a group can be set to resize differently.

To set the sizing behavior for a group:
1. Select the group.
2. From the Format menu, choose Behavior.
3. In the Resize Behavior section, choose the option you want. 
4. Click OK.

To set the sizing behavior for a shape 
in a group:

1. Select the group.



2. From the Edit menu, choose Open Group to open the group in the group window.
3. Select the shape.
4. From the Format menu, choose Behavior.
5. In the Resize Behavior section, choose one of the following options:

Scale With Group, to resize the shape when the group is resized. This is the normal 
behavior for shapes in a group.
Reposition Only, to keep the shape's original size when the group is sized. 
Use Group's Setting, if you want the shape to inherit the sizing behavior that you set 
for the group.

6. Click OK.
7. To close the group window, click the X box in the upper-right corner of the window.

See also
Determining a 2-D shape's size and location
Setting shape display options



Changing shape behavior

    Related procedures

Most of the shapes that come with Visio are SmartShapes. A SmartShape behaves as you 
expect it to, so you won't often need to change its behavior. However, if you need a shape to
behave in a specific way, you can change the behavior of a master shape or of a shape you 
create.
In Visio, you can:
· Protect shapes.
· Use control handles to modify a shape.
· Set a shape's double-click behavior.
· Set shape display options.
· Change a 1-D shape to a 2-D shape, or a 2-D shape to a 1-D shape.
· Add custom properties to a shape.
You can also change shape behavior by changing formulas in the ShapeSheet.



Associating data with shapes
Changing 1-D and 2-D behavior
Creating a nonprinting shape
Protecting shapes
Setting shape display options
Specifying a shape's double-click behavior
Working with control handles



 Working with control handles





Working with control handles

      Overview  

Some master shapes have control handles that let you work with shapes in ways you can't 
with standard 1-D and 2-D shapes. 
Tip: Shapes with control handles have control handle help: select the shape, then place the 
pointer over the control handles to display the handle's ToolTips.
Control handles work differently depending on the design and purpose of a shape. For 
example, you might use a control handle to adjust a rounded corner or reshape an arrow or 
to pull a connector directly out of a shape.
When you use a control handle on one shape to create another shape (such as a text block 
or a connector), the shapes may behave differently from how they would if you had created 
them separately. For example, if you select a shape from which you've dragged a connector, 
the connector is also selected.

See also
Connecting a series of shapes automatically
Quickly creating an organization chart and similar drawings
Setting shape display options



Changing 1-D and 2-D behavior





Changing 1-D and 2-D behavior

      Overview  

You can change a 2-D shape to a 1-D shape so you can use it as a connector. You can also 
change a 1-D shape to a 2-D shape so you can size the shape proportionately when you drag
its corner handles.

To set a shape's behavior as 1-D or 2-
D:

1. Select the shape.
2. From the Format menu, choose Behavior.
3. In the Interaction Style section, choose Line (1-Dimensional) or Box (2-Dimensional).
4. Click OK.

Important: Changing 1-D and 2-D behavior for a shape may produce unexpected results. 
For example, if a 1-D shape is glued to another shape, changing the 1-D shape to a 2-D 
shape will break the glue.

See also
Setting a group's sizing behavior
Working with control handles



Specifying a shape's double-click behavior





Specifying a shape's double-click behavior

      Overview  

You can modify shapes so they behave in a special way when they are double-clicked. By 
default, a shape's double-click behavior is to open the shape's text block. However, you 
could change the double-click behavior to display a page in a multipage drawing file or open
the shape's ShapeSheet.
Note: The default double-click behavior for a group is to open the group window.

To specify a shape's double-click 
behavior:

1. Select the shape.
2. From the Format menu, choose Double-Click.
3. In the dialog box, choose a double-click action for the shape.
4. Click OK.

See also
Adding and replacing text
Displaying pages
Running add-ons



Protecting shapes





Protecting shapes

      Overview  

You can protect a shape from changes by locking it with the Protection command. When a 
shape is locked, it displays padlocks that indicate that the protected behavior cannot be 
performed. Protected behaviors cannot be performed or changed until you unlock the shape.

To lock or unlock shape behaviors:
1. Select the shape.
2. From the Format menu, choose Protection.
3. Choose the shape behaviors that you want to lock or unlock.

When a behavior is checked, it is locked. For example, to ensure that no one can 
select a shape, in the Protection dialog box, check From Selection, then in the Protect 
Document dialog box, check Shapes. 

4. Click OK.

Note: Several of the master shapes that come with Visio are locked to protect their angles 
and dimensions. Unlocking and changing these shapes may cause them to behave in 
unexpected ways.

See also
Protecting a file
Setting page display options
Setting shape display options



Setting shape display options





Setting shape display options

      Overview  

When working with shapes, you choose options to display or hide shape handles, control 
handles, and selection rectangles.

To show or hide shape display 
options:

1. Select the shape.
2. From the Format menu, choose Behavior.
3. In the Selection Highlighting section, choose the options you want:

· To show or hide selection handles, choose Show Shape Handles.
· To show or hide control handles, choose Show Control Handles.
· To show or hide the shape's selection rectangle, choose Show Alignment Box.

4. Click OK.

Note: If you uncheck all three options, you won't be able to tell if a shape is selected.

See also
Protecting shapes
Setting display options
Setting page display options
Viewing layers



Creating a nonprinting shape





Creating a nonprinting shape

      Overview  

Sometimes you may want to print a drawing without printing certain shapes, for example, if 
you include a shape that is only for reference, such as a parts list or other list of 
specifications. By choosing settings in the Behavior dialog box, you can create a nonprinting 
shape.
In addition, you can use the Layer Properties dialog box to print layers you specify.

To create a shape that doesn't print:
1. Select the shape.
2. From the Format menu, choose Behavior.
3. In the dialog box, check Non-Printing Shape.
4. Click OK.

See also
Printing layers
Protecting shapes
Setting display options
Setting shape display options
 



Selecting and moving shapes

    Related procedures

Selecting shapes
In most cases you select shapes using the pointer tool. However, you can use other tools. 
For example, when you want to rotate a shape, you select it with the rotation tool.
When you select a shape with the pointer tool, green selection handles and a selection 
rectangle appear on the shape. When you select multiple shapes, the first shape you select 
displays green selection handles and the other shapes display blue handles. You can also 
select shapes by dragging the pointer tool to create a selection net.

Stacking order
Shapes have a stacking order on the page. The first shape you draw or drop on the page is 
at the back of the stack; the most recently created shape is at the front.
If you drag a selection net around several shapes, the shape at the front of the stacking 
order is the first shape selected and displays green handles.

Moving shapes
You move shapes by dragging them. You can also rotate shapes, flip shapes vertically or 
horizontally, or reverse a shape's ends.
As you drag a shape, a box (representing a 2-D shape) or a line (representing a 1-D shape) 
shows the shape's location on the page. If you pause while moving a shape and continue to 
hold down the left mouse button, you'll see an outline of the shape instead of the box or line 
that represents the shape, so you can position the shape more precisely.
Faint lines on each ruler indicate the shape's location. You can also use the grid to help you 
position shapes.



Changing the snap strength
Changing the stacking order of shapes
Flipping and reversing shapes
Moving a 2-D shape's center of rotation
Moving shapes by dragging
Rotating shapes by 90-degree increments
Rotating shapes with the rotation tool
Selecting shapes
Snapping shapes into place



Selecting shapes





Selecting shapes

      Overview  

When the mouse pointer is over a shape, it changes from a black arrow to a white arrow. 
When the arrow is white, you can click to select a shape.

To: Do this:
Select one shape Click the shape with the 

pointer tool.
Select several shapes
by clicking

Select the first shape, 
hold down the Shift key, 
and then click to select 
the other shapes one at 
a time.

Select several shapes
by dragging

With the pointer tool, 
drag a selection net 
around the shapes you 
want to select.

Select all the shapes 
on a page

Choose Select All from 
the Edit menu.

Select all of a 
particular item, such 
as shapes, groups, or 
guides

Choose Select Special 
from the Edit menu, and
then choose the type of 
items you want to 
select.

Cancel a selection Click away from 
selected shapes.

Cancel the selection 
of a shape or other 
item when several 
are selected

Hold down the Shift key 
and click the shape or 
item.

Select a vertex on a 
shape

Click the shape with the 
pencil tool, and then 
click the vertex.

Select a shape in a 
group

Click the group, and 
then click the shape.

See also
Copying shapes
Deleting shapes



Grouping and ungrouping shapes



Moving shapes by dragging





Moving shapes by dragging

      Overview  

To move a shape, drag it to where you want it. Use the grid lines and rulers to help place the
shape.

To move a shape:
1. With the pointer tool, point to the shape.

The pointer turns white.
2. Press the left mouse button, and then drag the shape to where you want it.

If snapping is on, the shape may jump into place.

Tip: Be careful not to point to a handle. If you accidentally resize a shape, choose Undo from
the Edit menu.

See also
Changing the stacking order of shapes
Dragging and dropping master shapes
Moving shapes after you glue them
Snapping shapes into place



Snapping shapes into place





Snapping shapes into place

      Overview  

Snapping pulls shapes toward the item you want to align them with. You can determine 
when you want to snap, what to snap to, and the snap strength. When you set snap options, 
set only the options you need. For example, if you want to snap to guides, you do not need 
to set the Grid Lines option.

To turn snapping on or off:
1. From the Tools menu, choose Snap & Glue.

You can also click the Snap button.
2. In the Currently Active section, check Snap.
3. Click OK.

To set snap options:



1. From the Tools menu, choose Snap & Glue.
2. In the Snap To section of the dialog box, check the options you want.

The Ruler Subdivisions, Grid, and Guides options are useful for aligning shapes. 
The Shape Handles (selection handles), Shape Vertexes, and Connection Points 
options are useful for gluing shapes together.

3. Make sure the Snap option is checked in the Currently Active section.
4. Click OK.

Tip: To place shapes as precisely as possible, set the snap strength to a high setting, zoom 
into the drawing, then move shapes into place.

See also
Aligning shapes to other shapes
Aligning shapes to rulers
Changing the snap strength
Moving shapes after you glue them
Moving shapes by dragging



Changing the snap strength





Changing the snap strength

      Overview  

You can change the snap strength for each item you can snap to. When you increase the 
snap strength, Visio pulls a shape toward the item from farther away.

To change the snap strength:
1. From the Tools menu, choose Snap & Glue.
2. In the Snap & Glue Strength section of the dialog box, drag the scroll box to adjust 

the snap strength for rulers, grid, or guides. Use the Points bar to control the snap 
strength of selection handles, vertexes, and connection points.

3. Click OK.

See also
Aligning shapes to other shapes
Aligning shapes to rulers
Snapping shapes in place
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Flipping and reversing shapes

      Overview  

To flip or reverse a shape:
1. Select the shape.
2. From the Shape menu, choose the command you want:

Flip Vertical
Flip Horizontal
Reverse Ends
You can also use the Flip Vertical and Flip Horizontal buttons.

Note: Some shapes based on actual objects are locked against being flipped.

See also
Moving a 2-D shape's center of rotation
Rotating shapes by 90-degree increments
Rotating shapes with the rotation tool
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Rotating shapes by 90-degree increments

      Overview  

You can rotate shapes by 90-degree increments by using the Rotate Left or Rotate Right 
commands.

To rotate a shape 90-degrees:
1. Select the shape.
2. From the Shape menu, choose the command you need:

Choose Rotate Left to rotate the shape 90-degrees counter-clockwise.
Choose Rotate Right to rotate the shape 90-degrees clockwise.
You can also use the Rotate Left and Rotate Right buttons on the toolbar.

See also
Flipping and reversing shapes
Moving a 2-D shape's center of rotation
Rotating shapes with the rotation tool
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Rotating shapes with the rotation tool

      Overview  

You can rotate shapes to any angle by using the rotation tool. 

To rotate a shape any amount:
1. From the toolbar, choose the rotation tool.
2. Select the shape you want to rotate.

When you select a shape with the rotation tool, rotation handles appear on the 
shape. 

3. Press the mouse button and drag a rotation handle.
When you point to rotation handles, the mouse pointer changes to two arrows 
forming a circle.
When you rotate a shape, a line appears through the shape's center of rotation and 
the pointer, showing the shape's angle of rotation. The shape's alignment box shows 
its orientation on the page, and the status bar shows the angle of rotation in the unit 
of measure for the drawing. For finer control, drag the pointer farther from the shape.

4. Release the mouse button.

Tip: You can also rotate a 1-D shape by dragging one of its endpoints. Be careful not to size 
the shape as you rotate it.

See also
Flipping and reversing shapes
Moving a 2-D shape's center of rotation
Moving shapes by dragging



Rotating shapes by 90-degree increments



 Moving a 2-D shape's center of rotation





Moving a 2-D shape's center of rotation

      Overview  

On a 2-D shape, a plus sign in a circle appears at the center of rotation (which is usually at 
the center of the shape's selection rectangle). You can move the center of rotation to rotate 
a 2-D shape around any point in the drawing window.

To move the center of rotation:
1. With the rotation tool, select the shape.
2. Place the rotation tool over the center of rotation, and then drag the center of 

rotation to the position you want it.

See also
Determining a 1-D shape's size and location
Determining a 2-D shape's size and location
Flipping and reversing shapes
Rotating a text block



Determining a shape's size and location

    Related procedures

You can determine the exact size and location of a shape by choosing the Size & Position 
command. You can also use options in the Size & Position dialog box to move and size a 
shape. Options in the dialog box depend on whether you're working with a 1-D or 2-D shape.
For a 1-D shape, use the Size & Position command to:
· Resize the shape vertically, horizontally, or in both directions.
· Change the position of the shape's beginning point while keeping the ending point 

stationary.
· Change the position of the shape's ending point while keeping the beginning point 

stationary.
· Change the height or angle of rotation of the shape.
For a 2-D shape, use the Size & Position command to:
· Change the width and height of the shape.
· Change the shape's angle of rotation.
· Flip the shape vertically or horizontally.
· Move a shape by changing the position and location of the shape's center of rotation.
The status bar displays information about a shape's size and position. You can also 
determine the size and position for a shape by displaying the shape's ShapeSheet.



Determining a 1-D shape's size and location
Determining a 2-D shape's size and location



 Determining a 1-D shape's size and location





Determining a 1-D shape's size and location

      Overview  

When you use the Size & Position dialog box to work with a 1-D shape, the option you 
choose in the Show section displays the options you set in the Parameters section to change
the size and position of the shape.

To change the size and position of a 
1-D shape:

1. Select the shape.
2. From the Shape menu, choose Size & Position.
3. In the Show section, choose one of the following options:

Begin and End Points (the default option) to change the position of the shape's 
beginning and ending points or to change the shape's height.
Begin, Length, Angle to change the position of the shape's beginning point (the 
ending point remains stationary) or to change the length, angle of rotation, or height 
of the shape.
End, Length, Angle to change the position of the shape's ending point (the beginning 
point remains stationary) or to change the length, angle of rotation, or height of the 
shape.

4. In the Parameters section, specify values for any or all of the options:
If you chose Begin and End Points in the Show section, specify a value in the Begin X 
or End X box to resize the shape horizontally; specify a value in the Begin Y or End Y 
box to resize the shape vertically; or specify a value in the Height box to change the 
shape's height.



If you chose Begin, Length, Angle in the Show section, specify a value in the Begin X 
or Begin Y box to change the position of the shape's beginning point, or specify a 
value in the Length, Angle, or Height box to change the size and position of the 
shape.
If you chose End, Length, Angle in the Show section, specify a value in the End X or 
End Y box to change the position of the shape's ending point, or specify a value in the
Length, Angle, or Height box to change the size and position of the shape.

5. Click Apply to see the results before you close the dialog box, or click OK to apply the 
changes and close the dialog box.

Tip: To move a shape without resizing or rotating it, change the values in the Begin X and 
End X or Begin Y and End Y boxes by the same amount. For example, to move a shape down 
one inch, decrease the values of Begin Y and End Y by one inch each. To resize and rotate 
the shape at the same time, enter new values for both the x- and y-coordinates.

See also
1-D Endpoints section
Changing the size of a 1-D shape
Determining a 2-D shape's size and location
Displaying a ShapeSheet



Determining a 2-D shape's size and location





Determining a 2-D shape's size and location

      Overview  

Using options in the Size & Position dialog box, you can specify exact dimensions for a 2-D 
shape. You can also rotate a 2-D shape or move a shape by changing the position and 
location of the shape's center of rotation.

To change the size and position of a 
2-D shape:

1. Select the shape.
2. From the Shape menu, choose Size & Position.
3. In the Size section, specify values for the shape's width, height, and angle of rotation.

You can also check options to flip the shape vertically or horizontally.
4. Click Apply to see the results without closing the dialog box, or click OK to apply the 

changes and close the dialog box.



To specify a new location for a 2-D 
shape:

1. Select the shape.
2. From the Shape menu, choose Size & Position.
3. To move the shape by changing the coordinates for its center of rotation, specify 

values in the X and Y boxes in the Position section.
4. To move the shape by changing the location of its center of rotation, click a section of

the shape diagram. The center of rotation is repositioned at that point on the shape, 
and the shape moves so its center of rotation is at the coordinates specified in the X 
and Y boxes.

5. Click Apply to see the results without closing the dialog box, or click OK to apply the 
changes and close the dialog box.

See also
Changing the size of a 2-D shape
Determining a 1-D shape's size and location
Displaying a ShapeSheet
Object Transform section
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Changing the stacking order of shapes

      Overview  

By changing the stacking order of shapes, you can change which shapes appear in front of 
or behind other shapes.

To change the stacking order of 
shapes:

1. Select the shape you want to change.
2. From the Shape menu, choose the command you need:

Bring Forward
Bring To Front
Send Backward
Send To Back

Shapes on a background always appear behind shapes on a foreground. Layers, however, 
have no effect on stacking order.
Tip: When you select multiple shapes with a selection net, the frontmost shape in the 
stacking order has green handles and the other shapes have blue handles. The handle-color 
distinction is helpful when you align shapes. The frontmost shape is used to align the other 
shapes.

See also
Assigning a shape to a layer
Editing and formatting a group
Grouping and ungrouping shapes



Moving shapes by dragging



 Aligning and distributing shapes

    Related procedures

As you move shapes, you can align them with ruler intervals and grid lines.
You can also:
· Create guides or guide points and align shapes to them.
· Align shapes to other shapes. You can align the tops, bottoms, left sides, right sides, or 

centers of shapes.
· Distribute three or more shapes to create an equal distance between the ends or centers

of shapes.
The stacking order affects how shapes are aligned when you use the Align Shapes 
command. If you drag a selection net around several shapes, the top shape in the stacking 
order is the first shape selected (primary selection¾or the shape with the green handles). 
The other shapes in the selection are aligned in relation to the location of the primary shape.



Aligning shapes to guides
Aligning shapes to other shapes
Aligning shapes to rulers
Aligning the centers of shapes
Centering a drawing on the page
Creating guide points
Creating guides
Distributing shapes



Distributing shapes





Distributing shapes

      Overview  

You can distribute three or more shapes to create an equal distance between the ends or 
centers of the shapes. When you distribute shapes vertically, the top and bottom shapes in 
the selection define the boundaries of the distribution. For horizontal distribution, the 
boundaries are defined by the leftmost and rightmost shapes.

To distribute shapes:
1. Shift+click to select three or more shapes.
2. From the Tools menu, choose Distribute Shapes.

You can also use the Distribute Shapes button and choose a distribution option.
3. In the dialog box, choose a distribution option.
4. To create guides and glue the shapes to them, check Create Guides And Glue Shapes 

To Them.
If you choose this option, you can select and move the outermost guides to move the
shapes without changing the distribution.

5. Click OK.

See also
Aligning shapes to guides
Aligning shapes to other shapes
Aligning the centers of shapes
Creating guide points



 Aligning shapes to other shapes





Aligning shapes to other shapes

      Overview  

With the Align Shapes command, you can align selected shapes with the first shape you 
select. You can also create a guide automatically, so you can move the shapes with the 
guide and maintain their alignment.

To align shapes to the primary 
selection:

1. Select the shape that you want to align other shapes to.
2. Shift+click to select the shapes you want to align.
3. From the Tools menu, choose Align Shapes.

You can also use the Align Shapes button and choose an alignment option.
4. In the dialog box, choose the alignment options you want.

Each alignment option is represented by an illustration. Choose one Up/Down 
Alignment and one Left/Right Alignment option. To cancel the selection of Up/Down 
Alignment or the Left/Right Alignment options, choose the red X in that section.

5. To create a guide and glue shapes to it, check Create Guide And Glue Shapes To It.
6. Click OK.

See also
Aligning the centers of shapes
Creating guides
Distributing shapes
Gluing shapes to guides
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Aligning the centers of shapes

      Overview  

By choosing options for vertical and horizontal alignment, you can align the centers of 
shapes.

To align the centers of shapes:
1. Select the shapes.
2. From the Tools menu, choose Align Shapes.
3. Choose the vertical center alignment option.
4. Choose the horizontal center alignment option.
5. Click OK.

See also
Aligning shapes to other shapes
Aligning shapes to rulers
Creating guides
Distributing shapes
Gluing shapes to guides
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Aligning shapes to rulers

      Overview  

By default, rulers appear along the edges of Visio's drawing window. The rulers indicate the 
scale of the drawing and are helpful for aligning shapes on the page. If you don't see the 
rulers, make sure Rulers is checked in the View menu.

Zero point
Sometimes it's useful to change the position of the zero point on the rulers. For example, 
you might want to measure the distances between shapes that aren't near the current zero 
point.

To move the zero point on both rulers
at once:

1. Hold down the Ctrl key and point to the crossbar at the intersection of the two rulers.
2. Drag to position the zero point at the location you want.

Or, choose Rulers & Grid from the Tools menu.



To move the zero point on the 
horizontal ruler:

1. Hold down the Ctrl key and point to the ruler at the left of the drawing window.
2. Drag the zero point to the location you want.

Or, choose Rulers & Grid from the Tools menu.

To move the zero point on the vertical
ruler:

1. Hold down Ctrl and point to the ruler at the top of the drawing window.
2. Drag the zero point to the location you want.

Or, choose Rulers & Grid from the Tools menu.

See also
Aligning shapes to other shapes
Creating guides
Distributing shapes
Setting glue options
Setting page display options
Snapping shapes into place



Creating guides





Creating guides

      Overview  

Guides are helpful in ways that rulers and grid lines are not. For example, you can place 
guides anywhere on the page and glue shapes to them. When you move the guides, the 
shapes move with them.
Before you create guides, make sure both Guides and Rulers are checked on the View menu.

To create a guide:
1. Point to the ruler from which you want to drag a guide.

To create a horizontal guide, point to the ruler at the top of the drawing window.
To create a vertical guide, point to the ruler at the left of the drawing window.

2. Drag the guide where you want to place it.
3. Release the mouse button.

Tip: You can't create diagonal guides. To align shapes diagonally, draw a diagonal line, drag 
the shapes to the line and align them manually, and delete the line when you're finished.

You delete guides the same way you delete shapes.



To delete a guide:
1. Select the guide.
2. From the Edit menu, choose Clear, or press the Delete key.

See also
Aligning shapes to guides
Creating guide points
Distributing shapes
Gluing shapes to guides
Moving shapes after you glue them



Creating guide points





Creating guide points

      Overview  

Guide points are crossbar-shaped guides that you drag from the intersection of the rulers. 
You can align a shape's endpoint or sides to a guide point.

To create a guide point:
1. In the upper-left corner of the drawing window, point to the crossbar at the 

intersection of the two rulers.
2. Drag to where you want the guide point.
3. When the guide point is where you want it, release the mouse button.

To delete a guide point:
1. Click the guide point to select it.

You may need to zoom in to see it. Guide points on the primary selection turn green 
when selected; all others turn blue.



2. From the Edit menu, choose Clear, or press the Delete key.

See also
Aligning shapes to guides
Aligning shapes to rulers
Creating guides
Gluing shapes to guides
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Aligning shapes to guides

      Overview  

You can align shapes to guides and guide points by dragging the shapes to the guides. To 
align shapes to a guide point, position the corner of a 2-D shape's selection rectangle or an 
endpoint of a 1-D shape on the guide point.

To align shapes with guides or guide 
points:

1. Create a guide or guide point where you want to align shapes.
2. Drag the shapes to the guides.

You can use the Align Shapes command to create a guide and glue shapes to it. 

See also
Creating guide points
Distributing shapes
Gluing shapes to guides
Setting glue options
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Centering a drawing on the page

      Overview  

In some cases, you may find that the finished drawings are not centered on the page. For 
example, you might create an organization chart block by block and find that the finished 
chart extends off one side of the page and onto the pasteboard. 

To center the drawing on the page:
1. From the Tools menu, choose Center Drawing.

Visio shifts the drawing to the center of the drawing page.

Note: If you are using the grid to align shapes in the drawing, the shapes may no longer be 
aligned with the grid units after using this command.

See also
Aligning shapes to other shapes
Moving shapes by dragging
Reducing or enlarging a drawing for printing



Techniques for connecting shapes

    Related procedures

By dragging and dropping connector master shapes, you can connect shapes in any type of 
drawing. Visio also provides several techniques for connecting shapes that make specific 
drawing tasks faster and easier.

To: Do this:
Connect shapes in a 
flowchart

Drag and drop 2-D shapes 
using the connector tool. 
Connectors are glued 
automatically from one shape 
to another.

Connect shapes in an 
organization chart

Drag control handles to create 
connectors, or use the 
connector tool to draw 
connectors between specific 
points on 2-D shapes.

Connect a series of 
shapes

Select two or more shapes, 
then choose Connect Shapes 
from the Tools menu.

Connect a callout or 
connector line to a 
shape

Drag and drop callout master 
shapes and glue them to 2-D 
shapes.

SmartConnectors
Many of the stencils that come with Visio include SmartConnector master shapes that you 
can drag and drop to connect shapes. The most useful connector shape is the Universal 
connector, which bends to create any connection you need. 
You can use the Universal connector to connect any point on one shape to any point on 
another. You can also let the connector calculate the shortest path between two shapes for 
you. You can adjust the way the connector bends by dragging its control handles. The 
number of control handles varies depending on the number of bends in the shape.
Important: If you adjust a control handle on a Universal connector shape and then move 
the shape it's connected to, the Universal connector loses its ability to calculate the best 
possible connection. To reestablish its smart behavior, hold down the Ctrl key, drag the 
endpoints away from the shapes they're connected to, and then reconnect the endpoints to 
the shapes.



Connections and glue
When you drag the connector tool between connection points on 2-D shapes, Visio glues a 
connector solidly to the connection points. If you move the shapes, the connector stays 
connected to those points.
When you use the Connect Shapes command, or hold down the Ctrl key and drag the 
connector tool from one shape to another, Visio glues a connector to the shapes using 
dynamic glue.
In a standard connection, the connector's beginning point is marked by an X, and the ending
point is marked by a plus sign. Both endpoints also have borders. In a connection that uses 
dynamic glue, the endpoints are not marked or surrounded by a border.
Several connector shapes, including the Universal connector, are designed to connect 
shapes with dynamic glue. Connectors designed to connect specific points on 2-D shapes 
(for example Top to Top, Top to Side, Bottom to Top, and similarly named shapes) are 
programmed to create solid (non-dynamic) connections.
No matter which technique you use to connect shapes, you can always switch between a 
solid connection and dynamic glue, as long as the connector is designed to work with 
dynamic glue.



Connecting a series of shapes automatically
Connecting shapes quickly in a flowchart
Connecting shapes with the stamp tool
Gluing shapes to guides
Moving shapes after you glue them
Quickly creating an organization chart and similar drawings
Using the connector tool to connect two shapes
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Using the connector tool to connect two shapes

      Overview  

You often glue the endpoint of a connector shape to a specific point on a 2-D shape. An easy 
way to glue a connector between two specific points is to use the connector tool.

To glue a connector between two 
points:

1. Drag the 2-D shapes where you want them on the drawing page.
2. From the connection tool menu, choose the connector tool.
3. If you'd like, choose a connector shape from the stencil.

This is an optional step. If you don't choose a connector, Visio uses the Universal 
connector.

4. On the first shape, position the pointer over the connection point to which you want 
to glue the beginning point of the connector shape.
Visio displays a box around the connection point.

5. Drag the pointer to the second shape and position the pointer over the connection 
point to which you want to glue the connector's ending point.

6. Release the mouse button.
Note: Some master shapes have connection points at their centers that you can glue 
connectors to. However, if you position the connector tool over the middle of a shape that 
does not contain a center connection point, Visio displays a box around the entire shape to 
indicate that you're using dynamic glue.
When 2-D shapes are in position on the drawing page, you can also use the connector tool to
connect them with dynamic glue.



To connect shapes that are already on
the drawing page:

1. From the connection tool menu, choose the connector tool.
2. If you'd like, choose a connector shape from the stencil.

This is an optional step. If you don't choose a connector, Visio uses the Universal 
connector. If you do choose a connector, be sure it's one that can work with dynamic 
glue.

3. Hold down the Ctrl key and position the pointer over one of the shapes you want to 
connect.
Visio displays a box around the shape to indicate that you're creating a dynamic 
connection.

4. Click and drag from the first shape to the second shape.
5. Release the mouse button.

Visio creates an instance of the connector and connects it to the points using 
dynamic glue.

Tip: If you need to modify a drawing in which shapes are connected with a Universal 
connector, move the 2-D shapes first. Then, if necessary, use control handles on the 
Universal connector to adjust the connector's bends.

See also
Connecting a series of shapes automatically
Creating and deleting connection points
Dragging and dropping connector shapes
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Connecting a series of shapes automatically

      Overview  

The Connect Shapes command provides a quick way to connect a series of 2-D  shapes. The 
shapes are connected in the order you select them.

To connect a series of shapes with 
the Connect Shapes command:

1. Select the 2-D shapes in the order that you want to connect them.
Select the shapes by clicking the first shape, and then press the Shift key and click 
the other shapes. (If you select by dragging, the shapes will be connected according 
to their stacking order, from front to back.)

2. If you'd like, choose a connector shape from the stencil.
This is an optional step. If you don't choose a connector, Visio uses the Universal 
connector.

3. From the Tools menu, choose Connect Shapes.
You can also use the Connect Shapes button.
Visio creates an instance of the connector and uses dynamic glue to connect the 
shapes, providing the connector you are using can use dynamic glue.

See also
Dragging and dropping connector shapes
Dragging and dropping master shapes
Moving shapes after you glue them
Selecting shapes
Using the connector tool to connect two shapes
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Gluing shapes to guides

      Overview  

By gluing shapes to a guide or guide point, you can move the guide, and all the shapes 
glued to the guide move with it. You can glue an endpoint of a 1-D shape to a guide or guide 
point, or you can glue selection handles of a 2-D shape to a guide or guide point.

To glue a shape to a guide:
1. Make sure glue options are set appropriately in the Snap & Glue dialog box (on the 

Tools menu).
2. Point to the shape that you want to glue to a guide.
3. Drag the shape to the place on the guide you want to glue it to:

· If you're gluing a 1-D shape, drag an endpoint to the guide. When the shape is 
successfully glued, the endpoint turns red.

· If you're gluing a 2-D shape, drag the shape toward the guide. When the shape is 
successfully glued, the selection handles on the part of the shape that is glued to 
the guide turn red.

See also
Aligning shapes to guides
Creating guide points
Dragging and dropping connector shapes
Moving shapes after you glue them
Setting glue options
Snapping shapes into place
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Connecting shapes quickly in a flowchart

      Overview  

The fastest and easiest way to connect shapes in a flowchart is to drag and drop shapes with
the connector tool. As each shape is dropped onto the drawing page, it is automatically 
connected to the previous shape with a connector.

To automatically connect shapes:
1. From the connection tool menu, choose the connector tool.
2. Drag and drop a 2-D shape from the stencil onto the drawing page.
3. With the first shape still selected, drag and drop another 2-D shape onto the drawing 

page.
Visio automatically connects the shapes with an instance of the Universal connector.

As long as the connector tool is selected, Visio adds a connector between the shape selected
on the page and the shape dropped onto the drawing page. To create new branches in the 
chart, click the drawing page to deselect the last shape you dropped, select the shape you 
want to branch from, and then drag a new shape onto the drawing page. Visio adds a 
connector between the selected shape and the new shape.

See also
Connecting a series of shapes automatically
Dragging and dropping connector shapes
Quickly creating an organization chart and similar drawings
Using the connector tool to connect two shapes
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Quickly creating an organization chart and similar drawings

      Overview  

Many of the shapes designed to create an organization chart or a network diagram have 
control handles that you can drag to create connectors. You can often tell which shapes 
produce connectors by looking at the master shape icon. Connectors appear as yellow lines 
extending from the main shape.

To use a control handle to connect 
shapes:

1. Drag the organization chart shapes into position on the drawing page.
2. Select a shape and position the pointer over the shape's control handle.
3. Drag the control handle and glue it to a connection point on the shape you want to 

connect to.
Visio glues the end of the connector to the connection point. If you move the shape 
the connector is glued to, the connector remains attached to that point.

Tip: You can also use the Org Chart Wizard to automate creating an organization chart. 
(From the File menu, choose New, select Org Chart Wizard, then click OK. Follow the 
instructions on screen.)

See also
Connecting a series of shapes automatically
Connecting shapes quickly in a flowchart
Dragging and dropping connector shapes
Using the connector tool to connect two shapes



Connecting shapes with the stamp tool





Connecting shapes with the stamp tool

      Overview  

The stamp tool, which is typically used for duplicating master shapes on a drawing page, is 
also handy for gluing connectors to specific points on 2-D shapes.

To stamp a connector master shape 
between shapes:

1. Position 2-D shapes on the drawing page.
2. From the connection tool menu, choose the stamp tool.
3. In the stencil window, select a connector master shape.
4. In the drawing window, position the stamp tool over a connection point on one of the 

2-D shapes.
5. Hold down the left mouse button and drag to a connection point on another shape.
6. Release the mouse button.

Visio adds an instance of the connector you selected between the points on the 2-D 
shapes.

Tip: The stamp tool does not use dynamic glue, but you can convert the connection's glue 
type.

See also
Connecting a series of shapes automatically
Converting the glue
Dragging and dropping connector shapes
Stamping master shapes
Using the connector tool to connect two shapes
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Moving shapes after you glue them

      Overview  

After shapes are glued, you can move the shape that has another shape glued to it without 
breaking the glue. For example, if you glue a connector to a box, you can move the box 
without breaking the glue, but there are restrictions on the ways you can move the 
connector.
The following actions do not break glued connections:
· Moving a shape or guide that has other shapes glued to it.
· Moving the free endpoint of a 1-D shape whose other endpoint is glued to a shape.
· Reversing a shape using Reverse Ends.

These actions break glued connections:
· Moving the glued endpoint of a 1-D shape.
· Moving a shape glued to a guide away from the guide.
· Flipping or rotating a shape that is glued to another shape.

See also
Connecting a series of shapes automatically
Connecting shapes quickly in a flowchart
Dragging and dropping connector shapes
Quickly creating an organization chart and similar drawings
Using the connector tool to connect two shapes



Adjusting connectors and glue settings

    Related procedures

Once shapes are connected in a drawing, you can adjust connector shapes and the shapes 
the connectors are glued to.
You can:
· Adjust the bend in a Universal connector shape.
· Move shapes after you glue them.
· Switch between a solid connector and dynamic glue.
· Display, create, and delete connection points.
· Format the line ends of a connector shape.



Adjusting the bends in a Universal connector
Converting the glue
Creating and deleting connection points
Displaying connection points
Formatting connector shapes
Setting glue options
See also
Aligning and distributing shapes
Determining a shape's size and location
Selecting and moving shapes
Techniques for connecting shapes
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Converting the glue

      Overview  

No matter which technique you use to glue shapes in the drawing, you can switch between a
solid connection and dynamic glue providing the connector shape you're using is designed 
to work with dynamic glue. When you have shapes in their final positions, you can also 
switch from dynamic glue to a solid connection.

To switch from a solid connection to 
dynamic glue:

1. Choose the pointer tool and select the connector in the drawing.
2. Hold down the Ctrl key.
3. Drag each endpoint of the connector away from the connection point it is glued to.
4. Drag the endpoints back to the shape to glue the endpoints with dynamic glue.

Visio displays a box around the shape to indicate that you are creating a dynamic 
connection.



To switch from dynamic glue to a 
solid connection:

1. Drag the endpoints of the connector shape away from the connection points.
2. Drag the endpoints back to the connection points.

See also
Connecting a series of shapes automatically
Dragging and dropping connector shapes
Using the connector tool to connect two shapes
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Adjusting the bends in a Universal connector

      Overview  

When connecting 2-D shapes, the Universal connector uses the geometry of the shapes and 
the location of the connection points to calculate the most direct route between the shapes. 
When you move the shapes the connector is attached to, the connector adjusts itself to 
avoid crossing over the shapes it connects. Once the 2-D shapes are in position, you can use
control handles on the connector to fine-tune the location of the connector's bends.

To adjust the bends in a Universal 
connector:

1. Select the Universal connector shape.
2. Drag a control handle to adjust the bends in the connector.

The number of control handles varies depending on the number of bends in the 
shape.

If you use control handles to adjust the position of the Universal connector, the connector 
maintains that position and will not reposition itself if you move the shapes it is connected 
to. You can reactivate the Universal connector so it regains its self-adjusting behavior. 



To reactivate the Universal connector:
1. Select the Universal connector shape.
2. Hold down the Ctrl key and drag the connector's endpoints away from the shapes 

they're connected to. Release the Ctrl key.
3. Drag the endpoints back to reconnect them to the shapes.

See also
Connecting a series of shapes automatically
Dragging and dropping connector shapes
Using the connector tool to connect two shapes



Formatting connector shapes





Formatting connector shapes

      Overview  

Connector master shapes are formatted with a template-based style that is designed to 
match the requirements of the drawing type. For example, the connector shapes in 
flowchart-related stencils have arrowheads; the connector shapes in organization chart-
related stencils do not. You can change the style or location of the arrowhead by applying 
line formatting to the connector. In some cases, you may need to adjust the direction of the 
connector shape. For example, you may draw a connector and find that the arrowhead is 
pointing at the wrong shape.

To add or delete arrowheads for a 
connector shape:

1. Select the connector.
2. From the Format menu, choose Line.
3. In the Arrows section, change the appropriate settings.

To add an arrowhead to the beginning point, the ending point, or both, choose an 
arrowhead style from the Begin and End lists. To delete an arrowhead from the 
beginning or ending points, choose None from the Begin and End lists. To switch the 
arrowhead from one end to the other, choose None in the Begin list and choose an 
arrowhead style from the End list.

4. Click OK.

Alternatively, select the connector shape and click the Line Ends button. The button adds 
and deletes arrowheads from each end of the connector shape with each consecutive click.

See also



Connecting a series of shapes automatically
Connecting shapes quickly in a flowchart
Dragging and dropping connector shapes
Quickly creating an organization chart and similar drawings
Using the connector tool to connect two shapes



Setting glue options





Setting glue options

      Overview  

Before you glue shapes, you may need to specify glue settings. Glue settings apply when 
you connect shapes by dragging and dropping and when you use the stamp tool to connect 
shapes. You do not need to set glue options to use the Connect Shapes command or the 
connector tool. 

To set glue options:
1. From the Tools menu, choose Snap & Glue.
2. In the Currently Active section, check the Glue option.
3. In the Glue To section, check the options you want.

Check as many items as you want. If you want to glue the endpoints of 1-D shapes to
the endpoints on other 1-D shapes, check either Shape Handles or Shape Vertexes. If 
you want to glue to selection handles on shapes, groups, and objects from other 
programs, choose Shape Handles.

4. Click OK.

Tip: To glue to guides, handles, or connection points, make sure these items are visible. If 
guides or connection points are not displayed, choose the Guides or the Connection Points 
command on the View menu. If selection handles are not displayed, from the Format menu, 
choose Smarts, then choose Behavior; check Show Shape Handles in the Selection 
Highlighting section.

See also
Dragging and dropping master shapes
Moving shapes after you glue them



Moving shapes by dragging
Stamping master shapes



 Displaying connection points





Displaying connection points

      Overview  

Connection points appear on shapes as blue Xs. A connection point can be on the perimeter 
of a shape, inside a shape, or even outside a shape.

To display connection points:
1. From the View menu, choose Connection Points.

When the command is checked, the item is visible.
Note: Connection points do not print.

See also
Creating and deleting connection points
Dragging and dropping connector shapes
Dragging and dropping master shapes
Moving shapes by dragging
Setting display options



 Creating and deleting connection points





Creating and deleting connection points

      Overview  

When you glue something to a shape's vertex or selection handle, Visio creates a connection
point. You can also create connection points at other locations on a shape or even outside a 
shape's boundaries. If you don't need a connection point, you can delete it.

To add a new connection point to a 
shape:

1. Select the shape.
2. From the connection tool menu, choose the connection point tool.
3. Hold down the Ctrl key and click where you want to add the connection point.

You can click on, inside, or outside the shape's perimeter. Visio adds an X to that 
location to show the new connection point.

To delete a connection point from a 



shape:
1. From the connection tool menu, choose the connection point tool.
2. Select the connection point you want to delete.

It turns magenta when it's selected.
3. From the Edit menu, choose Clear, or press the Delete key.

See also
Connecting a series of shapes automatically
Connection point section
Displaying connection points



 



Understanding local formatting and styles

    Related procedures

There are two ways to change the look of a shape: local formatting and styles. Local 
formatting means applying individual attributes such as line width, fill color, and font size to 
a shape. Local formatting is most useful when you want to give a unique look to one or just a
few shapes. Styles are combinations of formatting attributes; they are most useful when you
want to apply more than one attribute at a time, or to give many or all shapes a consistent 
look.
You can change the following attributes:
· Line pattern (solid, dashed, or none), line weight, and line color.
· Line ends (arrowheads, dots, or boxes) and line caps (rounded or square).
· Corners (to make them more or less rounded).
· Fill color and pattern.
· Shadow color, pattern, and location.
· Text font, size, color, position, case, style (bold, italic), alignment, indentation, spacing, 

margins, and background color of the text block.
Tip: You can apply the formatting of one shape to another by selecting the shape you like, 
clicking the Format Painter on the toolbar, then selecting the shape you want to format.



Applying formats to shapes

    Related procedures

To format shapes, select the shape or shapes you want to format, then choose the command
you need. You can also use buttons on the toolbar to format shapes. To apply the formatting 
of one shape to another, you can use the Format Painter button on the toolbar.

Menu commands
When applying local formatting, choose commands from the Format menu:
· Line
· Corners
· Fill
· Shadow
· Font, Paragraph, Tabs, or Text Block

You can format more than one shape at a time.
To: Do this:
Format all the 
shapes in a group

Select the group, then the 
style or attribute.

Format several 
shapes at once

Select all the shapes, then 
the style or attribute.

Apply the formatting 
of one shape to 
another 

Select the shape you like, 
click the Format Painter on 
the toolbar, then select the
shape you want to format.

Quickly repeat 
formatting

Format one shape, select 
other shapes, then press 
F4.

To see the effects of the formatting in greater detail, you can zoom in on the drawing, print 
the page, or change display options.



Changing line color, weight, and pattern
Changing the shadow offset
Choosing a color palette
Copying and applying shape formatting
Creating a transparent shape
Creating dashed lines
Creating line ends
Creating patterned fills and shadows
Creating round corners
Formatting fills and shadows
Removing shape borders



Choose the Line command to format line ends, line caps, corners, and line weight, color, and
pattern.



Choose the Corners command to format corner rounding.



Choose the Fill command to format a shape's fill color and pattern and to apply shadows to 
shapes.



Choose the Shadow command to format the color and pattern for a shape's shadow.



Choose one of the text formatting commands to format a shape's text, including font, font 
size, paragraph alignment, and tabs.



Removing shape borders





Removing shape borders

      Overview  

You can remove the border on a shape to make the outline of the shape invisible.

To remove shape borders:
1. Select the shape.
2. From the Format menu, choose Line.
3. In the Line section, choose None from the Pattern list.
4. Click Apply to apply the formatting and view the change before closing the dialog 

box, or click OK to apply the formatting and close the dialog box.

See also
Changing line color, weight, and pattern
Creating a transparent shape



Creating dashed lines





Creating dashed lines

      Overview  

To apply a dashed-line pattern:
1. Select the shape.
2. From the Format menu, choose Line.
3. In the Line section, choose a dashed-line pattern from the Pattern list.
4. Click Apply to apply the formatting and view the change before closing the dialog 

box, or click OK to apply the formatting and close the dialog box.

See also
Changing line color, weight, and pattern
Creating line ends



Creating round corners





Creating round corners

      Overview  

To round the corners where two segments meet, choose a setting in the Corners dialog box 
or from the Round Corners section in the Line dialog box. You can also enter a value to 
specify corner roundness.

To change corner roundness:
1. Select the shape.
2. From the Format menu, choose Corners.
3. In the Round Corners section, choose an option, or type a value in the Rounding box 

to specify corner roundness.
4. Click OK.

You can also change the roundness of corners by using the Line command or the Corner 
Roundings button on the toolbar.
Note: If you combine, fragment, intersect, subtract, or unite shapes, round corners are 
replaced by elliptical arcs.

See also
Changing line color, weight, and pattern
Creating dashed lines
Creating patterned fills and shadows
Formatting fills and shadows



Creating line ends





Creating line ends

      Overview  

By applying line ends, you can turn any line or other open shape into an arrow. You can 
apply an arrowhead or other line end to the beginning point, the ending point, or both 
endpoints of a shape. You can also choose options for the size of line ends.

To apply a line end to a shape:
1. Select the shape.
2. From the Format menu, choose Line.
3. In the Line Ends section, choose line end options:

In the Begin box, choose a line end for the beginning point.
In the End box, choose a line end for the ending point.
In the Size box, choose an option for the size of the line ends.

4. Click Apply to apply the line ends and view the change before closing the dialog box, 
or click OK to apply the line ends and close the dialog box.

You can also use the Line Ends button on the toolbar.

See also
Changing line color, weight, and pattern
Creating dashed lines
Creating round corners
Removing shape borders



Creating a transparent shape





Creating a transparent shape

      Overview  

To create a transparent shape:
1. Select the shape.
2. From the Format menu, choose Fill.
3. In the Fill section, choose None from the Pattern list.
4. Click Apply to view the change before closing the dialog box, or click OK to change 

the pattern and close the dialog box.

Tip: To hide a shape completely, create a transparent shape, then choose None from the 
Pattern list in the Line dialog box. You can also create shapes with transparent holes by using
the Combine command. To temporarily hide a shape, assign the shape to a layer, then make 
the layer invisible in the Layer Properties dialog box.

See also
Removing shape borders
Viewing layers



Creating patterned fills and shadows





Creating patterned fills and shadows

      Overview  

You can apply a patterned fill or shadow to a shape and specify the color for the foreground 
and background of the pattern.

To create a patterned fill or shadow:
1. Select the shape.
2. From the Format menu, choose Fill.
3. From the Pattern list for fills or shadows, choose a pattern other than 0 or 1.
4. From the Foreground list, choose a color for the detail in the pattern.
5. From the Background list, choose a color for the pattern background.
6. To format shadows, choose options from the Shadow section.
7. Click OK.

See also
Changing line color, weight, and pattern
Changing the shadow offset
Choosing a color palette
Formatting fills and shadows



Changing line color, weight, and pattern





Changing line color, weight, and pattern

      Overview  

To change line color, weight, and 
pattern:

1. Select the shape.
2. From the Format menu, choose Line.
3. In the Line section, choose options from the Pattern, Weight, and Color lists.
4. Click Apply to view the change before closing the dialog box, or click OK to apply the 

formatting and close the dialog box.

See also
Creating dashed lines
Creating round corners
Removing shape borders



Formatting fills and shadows





Formatting fills and shadows

      Overview  

To apply a fill and shadow:
1. Select the shape.
2. From the Format menu, choose Fill.
3. In the Fill section, choose options from the Pattern, Foreground, and Background lists.
4. In the Shadow section, choose options from the Pattern, Foreground, and Background 

lists.
5. Click OK.

To apply just a shadow:
1. Select the shape.
2. From the Format menu, choose Shadow.



You can also use the Shadow button.
3. In the Shadow section, choose options from the Pattern, Foreground, and Background 

lists.
4. Click OK.

Tip: To delete a shadow, choose None from the shadow pattern list.

See also
Choosing a color palette
Creating a transparent shape
Creating dashed lines
Creating line ends
Creating patterned fills and shadows



Changing the shadow offset





Changing the shadow offset

      Overview  

Shadows on shapes can be a different color and pattern, but all shadows on the same page 
are offset from their shapes by the same distance. You can change the size and angle of the 
shadow offset for all the shapes on a page.

To change the shadow offset for a 
page:

1. From the Edit menu, choose Drawing Page, then choose Properties.
2. In the Shape Shadow Offset section, type values for the shadow offset in the Right 

and Down boxes.
To move shadows to the left or top of shapes, use negative values.

3. Click OK.

See also
Creating patterned fills and shadows
Formatting fills and shadows



Choosing a color palette





Choosing a color palette

      Overview  

The templates provided with Visio use the Windows default color palette. You can choose a 
different color palette for a template or a drawing file by choosing another color palette 
provided with Visio or by copying a color palette from another file. You can also create a 
custom color palette or modify an existing one.

To choose a color palette:
1. Open the file with the color palette you want to use.
2. From the Tools menu, choose Color Palette.
3. From the Copy Colors From list, choose one of the listed color palettes or a filename. 

Choosing a filename copies the color palette for that file to the current drawing. Only 
the names of open files appear in the list.

4. Click OK.



To create a custom color palette:
1. From the Tools menu, choose Color Palette.
2. From the list of colors, choose the color you want to change.
3. Choose Edit.

The Color dialog box appears.
4. In the Color dialog box, edit the color.
5. Click OK.
6. In the Color Palette dialog box, click OK.

For details about editing colors, see the Windows documentation.
Note: When you edit a color in a color palette, shapes formatted with that color change to 
reflect the new color.

See also
Changing line color, weight, and pattern
Creating patterned fills and shadows
Formatting fills and shadows



Copying and applying shape formatting





Copying and applying shape formatting

      Overview  

If you're pleased with the formatting of a particular shape, you can quickly transfer the 
formatting (such as line, fill, and text styles) to another shape.

To copy a shape's formatting and 
apply it to another shape:

1. Select the shape that has the formatting you like.
To copy and apply only the text formatting of a shape, double-click the shape that has
the text formatting you like, then select the text in the shape.

2. Click the Format Painter button on the toolbar.
The pointer changes to an arrow with a paint brush.

3. Click the shape you want to format.
Tip: To format multiple shapes, double-click the Format Painter button. When you're 
finished formatting shapes, click the pointer tool on the toolbar. (You cannot use this 
method to copy and apply just text formatting.)

See also
Copying shapes in the current drawing
Copying shapes to another drawing



Using styles

    Related procedures

The easiest way to give shapes a uniform look is with styles. Using styles, you can apply a 
set of line, fill, and text attributes to several shapes at the same time.
You can apply all the attributes (line, fill, and text) defined in a style in one of two ways:
· Choosing a style from the Line, Fill, or Text style list on the status bar.
· Choosing a style from lists in the Style dialog box.

Applying multiple attributes
Some styles include attributes for line, fill, and text. When you choose one of these styles 
from a style list, a dialog box appears asking if you want to apply all the attributes in the 
style or only those for the item you have chosen. Click Yes to apply all attributes, or click No 
to apply only the attributes for the item you chose.

Preserving local formatting
Unless you specify otherwise, when you apply a style to a shape, the attributes defined in 
the style replace local formatting applied to the shape. For example, if you've applied 
arrowheads to a line using the Line Ends button or the Lines command, and you then apply a
style that specifies no line ends, the arrowheads are deleted when you apply the style. You 
can preserve local formatting by checking the Preserve Local Formatting option in the Style 
dialog box before applying a style. Some of the styles that come with Visio are defined to 
preserve local formatting.

Home team wins rule
If a master shape and a drawing file each contain a style with the same name, but the styles
are defined differently, a master shape you drag into a drawing will use the style as it is 
defined in the drawing file.



Applying styles from a style list
Applying styles from the Style dialog box
Protecting local formatting
Reverting to a master shape's style



Editing and creating styles

    Related procedures

You can edit and create styles in the Define Styles dialog box. When you edit or create a 
style in a template, new drawing files based on that template can use the new style. If you 
edit or create a style in a drawing file, only that drawing file can use the new style.
When you define a new style, its name appears in style lists and in the Style dialog box.

Default values in styles
Visio uses a set of default attributes for text, line, and fill. When Text, Line, or Fill are checked
in the Includes section of the Define Styles dialog box, a new style contains the default 
attributes for that item unless the attributes are defined differently in the style. To include 
the default attributes in the style, check the appropriate item. To exclude the attributes, 
make sure the item is not checked.

Style tips
· One style can be based on another style. If you change a style, all styles based on that 

style also change.
· Many of the styles defined in templates include attributes for only line, fill, or text. These 

styles are usually based on the template's Normal style.
· Styles with more than one attribute are often based on one basic style for the template. 

For example, an organization chart template might have a basic style called Org Normal. 
The names of other styles that are based on Org Normal will also start with Org, such as 
Org Exec.

· If you have the same style names in both a drawing file and stencils associated with a 
template, make sure that the styles' definitions are the same. If they aren't, shapes may 
behave in unexpected ways when you drag them from a stencil to a drawing.



Creating a style
Deleting a style
Editing a style
Renaming a style



Creating a style





Creating a style

      Overview  

You can create a style from scratch or create a style that is based on another style. In the 
new style, you can define attributes for line, fill, or text, or for all three.

To create a style:
1. From the Format menu, choose Define Styles.
2. In the Style box, type a name for the new style.
3. From the Based On list, choose the style on which you want to base the new style, or 

choose No Style to create a new style from scratch.
4. In the Includes section, uncheck the items you do not want to include in the style. 

If you leave an item checked, the new style will include the default attributes for that 
item unless you define new attributes in the style.

5. In the Change section, click the Text, Line, or Fill button to define or change attributes
for the items you want to include in the new style.
When you change text, line, or fill formats, a green line appears under the 
corresponding button in the Change section.

6. In the dialog boxes for the items included in the style, change or define the attributes
for the items, then click OK.

7. When the style contains the attributes you want, choose one of the following:
· Click OK to save the new style and close the dialog box.
· Click Add to save the new style and leave the Define Styles dialog box open for 

more work.



· Click Apply to apply the style to any selected shapes and close the dialog box. The
Apply button appears only when a shape is selected in the drawing.

Tip: If you select shapes before defining a style, you can apply the new style to the shapes 
and preserve local formatting by checking the Preserve Local Formatting On Apply option.

See also
Applying styles from a style list
Applying styles from the Style dialog box



Applying styles from a style list





Applying styles from a style list

      Overview  

You can choose a style from the Line, Fill, or Text style list to apply more than one attribute 
to a shape.

To apply a style from a style list:
1. Select the shape you want to format.
2. From a style list on the toolbar, choose a style from the Line, Fill, or Text style list.
3. If the style contains attributes for two or three items, a dialog box appears asking if 

you want to apply the other attributes for the style. Click Yes to apply all attributes in 
the style, or click No to apply only the attributes for the item indicated by the style 
list name (either Line, Fill, or Text).

See also
Applying styles from the Style dialog box
Creating a style
Editing a style
Fill
Font
Line



Applying styles from the Style dialog box





Applying styles from the Style dialog box

      Overview  

By using the Style dialog box, you can apply the same style to a shape's line, fill, and text, or
choose a different style for each aspect of a shape.

To apply styles from the Style dialog 
box:

1. Select the shape.
2. From the Format menu, choose Style.
3. Choose styles for the shape's text, line, and fill.
4. To preserve local formatting for the shape, check Preserve Local Formatting.
5. To view the style before you close the dialog box, click Apply.
6. Click OK.

See also
Applying styles from a style list



Editing a style





Editing a style

      Overview  

Editing styles is a quick way to change the look of multiple shapes. When you edit a style, 
changes are reflected in each shape that uses that style in a drawing.

To edit a style:
1. From the Format menu, choose Define Styles.
2. From the Style list, choose the name of the style you want to edit.
3. In the Change section, click the Text, Fill, or Line button.
4. In the Font, Line, or Fill dialog box, change the style's definition, then click OK.
5. In the Define Styles dialog box, click Change.
6. Click OK.

See also
Applying styles from a style list
Applying styles from the Style dialog box



Renaming a style





Renaming a style

      Overview  

To rename a style:
1. From the Format menu, choose Define Styles.
2. In the Style list, choose the name of the style you want to rename.
3. Click Rename.
4. Type a new name for the style.
5. Click OK.
6. In the Define Styles dialog box, click OK.

See also
Applying styles from a style list
Applying styles from the Style dialog box
Creating a style



Deleting a style





Deleting a style

      Overview  

To delete a style:
1. From the Format menu, choose Define Styles.
2. In the Style list, choose the name of the style you want to delete.
3. Click Delete.
4. Click OK.

Note: All shapes that use the deleted style are changed to the style in the Based On box.

See also
Applying styles from a style list
Applying styles from the Style dialog box



Reverting to a master shape's styles





Reverting to a master shape's styles

      Overview  

If you applied local formatting to an instance of a master shape without using styles, you can
revert to the master shape's original styles.

To revert to a master shape's styles:
1. Select the shape.
2. From the Format menu, choose Style.
3. In the Style dialog box, choose Use Master's Format from the Text, Line, or Fill style 

lists. 
4. Click OK.

Tip: The Use Master's Format item appears at the top of each style list; you may need to 
scroll up to see it.

See also
Applying styles from a style list
Applying styles from the Style dialog box



Protecting local formatting





Protecting local formatting

      Overview  

You can apply styles to shapes without changing local formatting that you have applied to 
the shapes. For example, if you applied a line end format to a shape and want to apply a 
style that specifies no line ends, you can preserve local formatting to apply the style and 
retain the line end format.

To apply a style and protect local 
formatting:

1. From the Format menu, choose Style.
2. Choose the styles you want to apply.
3. Check Preserve Local Formatting.
4. Click OK.

Note: You can also preserve local formatting when applying a style from the Define Styles 
dialog box. Check the Preserve Local Formatting On Apply option before applying the style.

See also
Applying styles from a style list
Applying styles from the Style dialog box
 



Adding and editing text

    Related procedures

Many drawings require labels, legends, and titles. You can add text to any shape (including 
lines and connectors) and add independent text to a drawing. You can select, edit, and check
the spelling of text, and search for and replace text much as you do with many word-
processing programs. You can also copy text, then paste it in another shape.
When you work with text, you use the text tool and the text block tool. When a shape's text 
block is open, the style toolbar changes to the text toolbar, which contains the buttons and 
lists you use to edit and format text.
To move the insertion point in a text block, you can use these shortcuts:

To move the 
insertion point to:

Press:

Beginning of text 
block

Ctrl+Home

End of text block Ctrl+End
Beginning of 
paragraph

Ctrl+Up Arrow

End of paragraph Ctrl+Down Arrow
Preceding line Up Arrow
Following line Down Arrow
Beginning of line Home
End of line End
Beginning of word Ctrl+Left Arrow
End of word Ctrl+Right Arrow
Character to left Left Arrow
Character to right Right Arrow

Adding and replacing text
Adding independent text to a drawing
Checking the spelling of text
Cutting, copying, and pasting text
Deleting text
Searching and replacing text
Selecting text
Typing special characters



Typing text into shapes



Typing text into shapes





Typing text into shapes

      Overview  

To add text to a shape, select the shape and type the text. When you start typing, Visio 
opens the shape's text block. If the shape contains text, the existing text is replaced by the 
text you type.
If you add text to a group, the text appears on the frontmost shape in the group. If you 
subselect a shape in a group, the text you add appears on that shape.

To type text into a shape:
1. Select the shape.
2. Type the text.

Visio automatically zooms in on the drawing so that you can see what you are typing.
3. When you finish typing, press the Esc key or click outside the text block.

See also
Adding and replacing text
Adding independent text to a drawing
Moving a text block
Zooming in and out of a drawing



Typing special characters





Typing special characters

      Overview  

You can insert ANSI characters into text. The ANSI character set consists of 256 characters 
established by the American National Standards Institute. The appearance of ANSI 
characters depends on which font you are using.

To type ANSI characters:
1. Hold down the Alt key. Using the keys on the numeric keypad, type 0, then the ANSI 

code for the character you want.
For example, to type an em dash (¾), hold down the Alt key and type 0151.

See also
Adding and replacing text
Adding independent text to a drawing
Selecting text
Typing text into shapes



Searching and replacing text





Searching and replacing text

      Overview  

You can search for and replace text in a drawing file, including text in shapes on a page, in 
the drawing file stencil, in the Properties box, or in data fields.

To search for text:
1. From the Edit menu, choose Find.
2. In the Find What box, enter the text you want to find.

To search for special characters, click Special, then select the character you want to 
find.
To limit the search range, under Search, choose Selection, Current Page, or All pages.
To limit the text searched, check Match Case or Find Whole Words Only.

3. Click Find Next to find an occurrence of the word.



To search for and replace text:
1. From the Edit menu, choose Replace.
2. In the Find What box, enter the text you want to find.
3. In the Replace With box, enter the text you want to replace it with.

To search for special characters, click Special, then select the character you want to 
find.
To limit the search range, under Search, choose Selection, Current Page, or All Pages.
To limit the text searched, check Match Case or Find Whole Words Only.

3. Click Find Next to find an occurrence of the word.
4. Click Replace to replace just that occurrence of the specified text, or click Replace All 

to change all occurrences of the specified text.

See also
Adding and replacing text
Checking the spelling of text
Typing text into shapes



Checking the spelling of text





Checking the spelling of text

      Overview  

You can check the spelling of text in shapes, stencil shapes, Properties information, and data
fields in the active drawing file.
Note: By default, Visio just checks the current page. To have Visio check the entire file, see 
the "To set spelling defaults" procedure below.

To check spelling:
1. From the Tools menu, choose Spelling.

You can also click the Spelling button.
When Visio finds a word that isn't in the current dictionary, it highlights the word and 
lists suggestions. 

2. To use a suggestion, select it, then click Change To. To change all occurrences of the 
word to the suggestion, click Change All.
To type the word you want, select the word in the Change To box, then type a word.
To have Visio move on without changing the word, click Ignore. To ignore all 
occurrences of the word, click Ignore All.
To add a word to the dictionary, click Add Words To, then select the dictionary to 
which you want to add the word.



To set spelling defaults:
1. From the Tools menu, choose Options.
2. Click Spelling to open the Spelling Options dialog box. 
3. Under Search, specify whether you want Visio to search the selection, a single page, 

or all pages by default.
4. Under User Dictionary, specify the dictionary you want to use. 

See also
Adding and replacing text
Searching and replacing text
Typing text into shapes



Adding independent text to a drawing





Adding independent text to a drawing

      Overview  

When you add independent text such as a title to a drawing, Visio creates an invisible shape 
to hold the text. If you want to specify the size of an independent text block, you can do so 
before you type.

To type independent text:
1. From the text tool menu, choose the text tool.
2. With the text tool, click where you want to start typing.
3. Type.

Visio automatically zooms in on the drawing so that you can see what you are typing.
As soon as you start typing, Visio creates an invisible shape and opens its text block. 

4. When you finish typing, press the Esc key or click outside the shape.



To specify the width of an 
independent text block:

1. With the text tool, point to where you want to start the independent text block.
2. Click and drag down and to the left or right until the text block is the width you want.
3. Release the mouse button, then type.

Tip: Although you can't type text in an object from another program, you can type text over 
the object by creating an independent text block.

See also
Adding and replacing text
Moving a text block
Typing text into shapes
Zooming in and out of a drawing



Adding and replacing text





Adding and replacing text

      Overview  

To edit text in a shape, or to add text to existing text, you first open the shape's text block, 
then edit the text as you do in most word-processing programs.

To add or edit text in a shape:
1. Double-click the shape to open the text block, or click the text with the text tool.

Visio automatically zooms in on the drawing so that you can see what you are typing.
2. Click where you want to place the insertion point.
3. Type the new text.
4. Press the Esc key.

Note: You can move the insertion point by clicking anywhere in the text block. You can also 
move the insertion point by using the arrow keys on the keyboard.

See also
Cutting, copying, and pasting text
Selecting text
Typing text into shapes



Selecting text





Selecting text

      Overview  

Before you copy, delete, paste, or format text, you need to open a shape's text block and 
select the text you want to work with. If no text is selected, the changes you make affect the
entire text block.

To select text:
1. Double-click the shape to open the text block, or click the text with the text tool.

2. To: Do this:
Select all text Choose Select All 

from the Edit 
menu

Select characters Click and drag
Select a word Double-click
Select a paragraph Triple-click

See also
Cutting, copying, and pasting text
Selecting a text block
Typing text into shapes



Cutting, copying, and pasting text





Cutting, copying, and pasting text

      Overview  

You copy, cut, or paste text in Visio in the same way you do in many word-processing 
programs. You can also reverse text changes by using the Undo command.

To copy or cut selected text:
1. Double-click the shape to open the text block, or click the text with the text tool.
2. Select the text you want to copy or cut.
3. From the Edit menu, choose the command you need:

Choose Copy or click the Copy button on the toolbar to copy the text to the 
Clipboard.
Choose Cut or click the Cut button on the toolbar to delete the text and move it to 
the Clipboard.



To paste text:
1. Double-click the shape to open the text block, or click the text with the text tool.
2. Place the insertion point where you want to paste the text.
3. From the Edit menu, choose Paste, or click the Paste button on the toolbar.

To paste text in an independent text block, drag the text tool to create the text block, then 
choose Paste from the Edit menu.
Tip: You can quickly repeat an action such as pasting text by pressing the F4 key.

See also
Typing text into shapes



Deleting text





Deleting text

      Overview  

To delete text:
1. Double-click the shape to open the text block, or click the text with the text tool.
2. Select the text you want to delete.
3. From the Edit menu, choose Clear, or press the Delete key.

See also
Adding and replacing text
Cutting, copying, and pasting text
Selecting text



Formatting text

    Related procedures

You format text in Visio in much the same way as you format text with many word-
processing programs.
Visio has four text formatting dialog boxes: Font, Paragraph, Tabs, and Text Block. Each 
controls an attribute of text. You can also format text using the Style dialog box and the Text 
style list, the Font list, and toolbar buttons.
To apply a character, paragraph, or tab formatting to a portion of a shape's text, select a 
range of text at least one character long.
To apply a paragraph or tab formatting to a paragraph, triple-click to select the paragraph, 
then apply the formatting.
To format text, you can use these shortcuts.

To format text as: Press:
Bold Ctrl+Shift+B
Italic Ctrl+Shift+I
Small caps Ctrl+Shift+Y
Subscript Ctrl+Shift+X
Superscript Ctrl+Shift+Z
Underline Ctrl+Shift+U

Adding and deleting tabs
Aligning and indenting paragraphs
Aligning text in the text block
Changing font attributes
Setting line spacing
Setting text block margins
Setting the text block background color



Setting the text block background color





Setting the text block background color

      Overview  

The background color of the text block can be different from that of the shape.

To color the text block background:
1. Select the shape.
2. From the Format menu, choose Text Block.
3. In the Text Background section of the dialog box, choose a color from the Solid Color 

list.
Note: The text block background color only appears when the shape contains text.

4. Click OK.

See also
Adding and replacing text
Selecting shapes



Changing font attributes





Changing font attributes

      Overview  

You can change font attributes such as color and size for an entire text block or for selected 
text. For example, you can select text and make that text bold.

To change and apply font attributes:
1. Double-click the shape to open the text block, or click the text with the text tool.
2. To format a specific word, select the text you want to format.
3. From the Format menu, choose Font.
4. In the dialog box, choose options for the formats you want.

You can choose options for the font, font size, color, case, position, and language.
5. Click Apply to apply the formats without closing the dialog box, or click OK to apply 

the formats and close the dialog box.

See also
Adding and deleting tabs
Aligning and indenting paragraphs
Aligning text in the text block
Selecting text
Setting line spacing
Setting text block margins
Setting the text block background color



Adding and deleting tabs





Adding and deleting tabs

      Overview  

You can add and delete tabs to easily align text at the center, left, or right of the text block, 
or to create decimal tabs to align columns of numbers. The position of tab reflects the width 
of a shape's text block, not the position of the shape on the page.

To specify tab indentations for 
selected paragraphs:

1. Double-click the shape to open the text block, or click the text with the text tool.
To set a tab for an entire text block, select the shape.    

2. Select the paragraph you want to format.
3. From the Format menu, choose Tabs.
4. In the Edit Tab section, type the position you want for a tab stop in the Position box.
5. From the Align list, choose an alignment option for the tab.
6. In the Edit Tab section, click Add.
7. Click OK.



To delete a tab stop:
1. Select the shape.
2. From the Format menu, choose Tabs.
3. In the Tab Stop section, choose the tab stop you want to delete.
4. In the Edit Tab section, click Delete.
5. Click OK.

See also
Aligning and indenting paragraphs
Aligning text in the text block
Setting line spacing
Setting text block margins



Aligning and indenting paragraphs





Aligning and indenting paragraphs

      Overview  

To align and indent paragraphs:
1. Double-click the shape to open the text block, or click the text with the text tool.
2. Select the paragraph you want to format.
3. From the Format menu, choose Paragraph.
4. To set the horizontal alignment for a paragraph, choose an option from the Horizontal

Alignment list.
5. To indent a paragraph, enter values in the Indents boxes.
6. Click Apply to apply the formats without closing the dialog box, or click OK to apply 

the formats and close the dialog box.

See also
Adding and deleting tabs
Aligning text in the text block
Setting line spacing
Setting text block margins



Setting line spacing





Setting line spacing

      Overview  

You can adjust the amount of space before each new paragraph, after each paragraph, and 
between the lines in a paragraph in a text block.

To set line spacing:
1. Double-click the shape to open the text block, or click the text with the text tool.
2. Select the paragraph or text block you want to format.
3. From the Format menu, choose Paragraph.
4. In the Spacing section, specify the line spacing you need:

· To specify the spacing before each paragraph, type a value in the Before box.
· To specify the spacing after each paragraph, type a value in the After box.
· To specify the spacing between lines of a paragraph, type a value in the Line box.

5. Click OK.

See also
Adding and deleting tabs
Aligning and indenting paragraphs
Aligning text in the text block
Setting text block margins



Setting text block margins





Setting text block margins

      Overview  

To set text block margins:
1. Select the shape you want to format.
2. From the Format menu, choose Text Block.
3. In the Margins section, specify values in the Top, Bottom, Right, and Left boxes to set 

the text block margins.
4. Click OK.

See also
Adding and deleting tabs
Aligning and indenting paragraphs
Aligning text in the text block
Setting line spacing



Aligning text in the text block





Aligning text in the text block

      Overview  

You can align a text block with the top, middle, or bottom of text block margins.

To align text in the text block:
1. Select the shape you want to format.
2. From the Format menu, choose Text Block.
3. From the Vertical Alignment list, choose a text alignment option.
4. Click OK.

See also
Adding and deleting tabs
Aligning and indenting paragraphs
Setting line spacing
Setting text block margins



Selecting, sizing, and moving text blocks

    Related procedures

When you size, rotate, or move a shape, its text block sizes, rotates, or moves with it. You 
can also size, rotate, and move a text block separately from its shape.
By moving a text block away from its shape, you can create a label that moves with the 
shape. You can move a shape's text block partially or completely outside the shape's 
borders. Even if the text block is not touching the shape, the text block moves, rotates, and 
sizes with the shape.
Before you size, rotate, or move a text block, you need to select the text block with the text 
block tool. When a text block is selected, it displays selection handles. Text blocks for 2-D 
shapes also display rotation handles at their corners. When you select the text block of a 
line, it appears that the line itself is selected, but it's really the text block that's selected.



Moving a text block
Rotating a text block
Selecting a text block
Sizing a text block



Selecting a text block





Selecting a text block

      Overview  

Before you can size, move, or rotate a text block, you need to select it first.

To select a text block:
1. From the text tool menu, choose the text block tool.
2. Click the shape whose text block you want to select.

Alternatively, select the shape with the text tool, then press F2 to select the text 
block.

See also
Moving a text block
Rotating a text block
Sizing a text block



Moving a text block





Moving a text block

      Overview  

To move a text block independently of
its shape:

1. From the text tool menu, choose the text block tool. 
2. Click the shape to select its text block.
3. Point to the dotted green line that indicates that the text block is selected.

When the pointer is over the dotted line, it changes to a double rectangle.
4. Drag the text block to where you want it.

Note: If a shape is grouped, use the Open Group command to view it and move the text 
block.

See also
Rotating a text block
Sizing a text block



Sizing a text block





Sizing a text block

      Overview  

When you type text in a shape, the text block's width is determined by the shape's width. 
When you type independent text, Visio uses a default text block width unless you specify a 
different width before you type.
A text block's height is determined by how much text you type and the text block's width. 
You can change the size of a text block without changing the size of the shape.

To change the text block width or 
height:

1. From the text tool menu, choose the text block tool. 
2. Click the shape to select its text block.
3. Drag a selection handle until the text block is the width or height you want.

See also
Moving a text block
Rotating a text block



Rotating a text block





Rotating a text block

      Overview  

To rotate text independently of its 
shape:

1. From the text tool menu, choose the text block tool. 
2. Click the shape to select its text block.
3. Drag a rotation handle.

If the text box is so small that you don't see rotation handles, resize the text box until
you see the rotation handles.
When the pointer is over a rotation handle, it changes to a pair of arrows forming a 
circle.

See also
Flipping and reversing shapes
Moving a text block
Sizing a text block



Using fields

    Related procedures

A field is a placeholder in text that displays information such as a date, time, or 
measurement. Information in fields changes automatically when you update a drawing. You 
can use fields to add dimension lines, callouts, and legends that reflect a drawing's current 
state. For example, if you insert the Current Date field, the current system date is displayed 
in the format you choose.
A text block can contain as many fields as you want. Use fields from existing categories or 
create your own formulas for fields. You can format or delete fields just as you format or 
delete other text.
Visio includes the following field categories:
Custom Formula
Date/Time
Document Info
Geometry
Object Info
Page Info
Lotus Notes
Tip: You can also associate custom data with shapes using the Custom Properties section of 
the ShapeSheet and the Custom Properties dialog box.



Inserting fields into text
Using a custom formula in a field



Inserting fields into text





Inserting fields into text

      Overview  

When you insert a field in text, Visio inserts the field at the insertion point.

To insert a field into text:
1. Double-click the shape to open the text block (or click the text with the text tool), 

then click where you want to insert the field.
If you want the field to replace the text in the shape, select the shape. You don't need
to open the text block and place the insertion point.

2. From the Insert menu, choose Field.
3. In the Category section, choose a field category.
4. In the Field section, choose a field.
5. In the Format section, choose a format for the field information.
6. Click OK.

Tip: Consider adding phrases before or after fields. For example, before the Current Date 
field, you might type the phrase "Today's date is," followed by a space.
Note: When you cut or copy a field and then paste it, the pasted text is no longer a field. 
The field text becomes static.

See also
Building a formula by pasting
Moving a text block
Rotating a text block
Sizing a text block



Writing information from Visio to Lotus Notes



Using a custom formula in a field





Using a custom formula in a field

      Overview  

You can insert a custom formula in a text block. To create a custom formula, you work with 
the functions and syntax used for creating ShapeSheet formulas.

To use a custom formula in a field:
1. Double-click the shape to open the text block (or click the text with the text tool), 

then click where you want to insert the field.
If you want the field to replace the text in the shape, select the shape. You don't need
to open the text block and place the insertion point.

2. From the Insert menu, choose Field.
3. In the Category section, choose Custom Formula.
4. In the Custom Formula box, enter the formula.
5. Click OK.

See also
Displaying the ShapeSheet
Functions
Performing calculations on shape properties
Writing information from Visio to Lotus Notes



 



Working with pages and their backgrounds

    Related procedures

Each Visio drawing contains at least one page: its foreground page. A drawing may also 
contain one or more background pages. You can assign background pages to other pages in 
the Properties dialog box.
Visio provides two methods for displaying information on multiple planes: backgrounds and 
layers. The method you should use depends on the requirements of your drawing.
· When you want the same text or shape on multiple pages within the same file, use a 

background page. For example, you can have a corporate logo and name on every page 
that shares the background.

· When you need to have multiple depths of text and shapes within the same page, use 
layers. For example, an architectural drawing of a house can be composed of a wall 
layer, plumbing layer, electrical layer, and so on. 

You can assign only one background page to a foreground page, but each background page 
can also have a background. You can create a layered effect using background pages. 
However, using layers instead of backgrounds is usually preferable because they provide 
better ways of working with separate information. 
When a foreground page is displayed, you can see the shapes on all the backgrounds in the 
drawing. To edit the shapes on a background page, first display that background page in the 
drawing window, and then edit the same way you would edit a foreground page.



Assigning and canceling a background page
Creating a background page
Creating a new page
Deleting a page
Displaying pages
Modifying a background page
Rearranging foreground pages
Setting page display options
Switching to a background page



Modifying a background page





Modifying a background page

      Overview  

You edit the shapes on a background page in the same way you edit the shapes on a 
foreground page. You can display the background in one window and the page it's assigned 
to in another window, so you can see how the changes affect the whole drawing. You cannot 
edit shapes on the background page in the window that displays the foreground page.

To display a page and its background 
in separate windows:

1. Display the page to which the background is assigned.
2. From the Edit menu, choose Go To, then choose Page.
3. Choose the background name and check Open Page In New Window.
4. Click OK.
5. From the Window menu, choose Tile.

Tip: To switch between a foreground and a background page for a drawing, from the Edit 
menu, choose Go To, then choose Foreground and Background.

See also
Adding layers
Assigning a shape to a layer
Assigning and canceling a background page
Creating a background page
Working with pages and their backgrounds



Switching to a background page





Switching to a background page

      Overview  

To switch between a foreground page
and a background page:

1. Display the background's drawing page.
2. From the Edit menu, choose Go To, then choose Background.
3. To return to the foreground page, choose Foreground.

See also
Adding layers
Assigning a shape to a layer
Assigning and canceling a background page
Creating a background page
Displaying pages
Modifying a background page



 Creating a new page





Creating a new page

      Overview  

You can easily create and add pages to a drawing. By default, a new page uses the same 
settings as the page displayed in the drawing window. You can change page settings if you 
need to when creating a new page.

To create a new page:
1. From the Insert menu, choose Page.
2. Type a name for the page, or use the default name provided by Visio.
3. If necessary, click Size/Scale to change the page size or scale for the new page.
4. Click OK.

Tip: When naming pages, it's helpful to use the default names provided by Visio. By using 
default page names, you can rearrange pages more easily.

See also
Adding layers
Assigning a shape to a layer
Changing the size of the drawing page
Displaying pages
Rearranging foreground pages
Working with pages and their backgrounds



Displaying pages





Displaying pages

      Overview  

Visio displays one drawing page at a time in the drawing window. You can display a different 
page in the active drawing window by using the Go To submenu. You can also open more 
than one drawing window to display multiple views of the same page or to view multiple 
pages at the same time.

To display a page in the drawing 
window:

1. From the Edit menu, choose Go To, then choose the page that you want to display in 
the active window.

To open a new drawing window and 
display a page in it:

1. From the Window menu, choose New Window.
If you choose New Window when a drawing window is open, the new window contains



a duplicate of the open window's contents. If no drawing window is open, New 
Window opens a copy of the active stencil window.

2. To see all the open windows, choose Tile from the Window menu.

Tip: You can also display a page in a new window: from the Edit menu, choose Go To, then 
choose Page. Select the page, check Open Page In New Window, then click OK.

See also
Adding layers
Arranging Visio windows
Assigning a shape to a layer
Working with pages and their backgrounds



Deleting a page





Deleting a page

      Overview  

You can delete pages you no longer need. However, you cannot delete a background page 
that is assigned to another page. To delete a background page, you first need to cancel its 
assignment. If you delete the last page in a file, Visio replaces that page with a blank page. 

To delete a page:
1. From the Edit menu, choose Drawing Page, then choose Delete.
2. In the dialog box, choose the page or pages you want to delete.

To delete a range of pages, choose a page, hold down the Shift key, and then choose 
another page. The pages you choose and the pages between them are deleted.
To delete non-consecutive pages, choose a page, hold down the Ctrl key, and then 
choose another page. Each page you choose is deleted.

3. To update default page names to reflect the new page order, check Update Page 
Names.
If a page has a name other than its default name, checking this option has no effect.

4. Click OK.

See also
Assigning and canceling a background page
Displaying pages
Setting page display options



Creating a background page





Creating a background page

      Overview  

You can create a new page as a background page or convert a foreground page to a 
background page. When you create a background page, Visio adds the page name to the 
Background list in the Page and Property dialog boxes.

To create a background page:
1. From the Insert menu, choose Page.
2. In the Type section, choose Background.
3. If necessary, click Size/Scale to change the page size or scale for the new 

background.
4. Click OK.

To convert a foreground page to a 



background page:
1. Display the foreground page you want to convert to a background page.
2. From the Edit menu, choose Drawing Page, then choose Properties.
3. In the Type section, choose Background.
4. Click OK.

See also
Adding layers
Assigning a shape to a layer
Assigning and canceling a background page
Creating a new page
Modifying a background page
Setting page display options



Assigning and canceling a background page





Assigning and canceling a background page

      Overview  

You can assign one background page to each page in a drawing. You can assign the same 
background to as many pages as you want. If you no longer want a background page 
assigned to a particular page, you can cancel the assignment.

To assign a background to a page:
1. Display the page you want to assign the background to.
2. From the Edit menu, choose Drawing Page, then choose Properties.
3. From the Background list, choose the name of the background page that you want to 

assign.
4. Click OK.

To cancel a page's background 



assignment:
1. Display the page the background is assigned to.
2. From the Edit menu, choose Drawing Page, then choose Properties.
3. From the Background list, choose None.
4. Click OK.

Tip: You can assign a background page to a new page by choosing a background from the 
Background list in the Page dialog box.

See also
Adding layers
Assigning a shape to a layer
Creating a background page
Modifying a background page
Setting page display options



Rearranging foreground pages





Rearranging foreground pages

      Overview  

Visio stores foreground pages in the order the pages are created. You can view and change 
the order of foreground pages by choosing the Reorder command.

To change the order of foreground 
pages:

1. From the Edit menu, choose Drawing Page, then choose Reorder.
2. In the dialog box, choose the page you want to move.

The list displays the page names in the order they are stored in the file.
3. Click Move Up or Move Down to change the position of the page.
4. To update default page names to reflect the new page order, check Update Page 

Names.
Checking this option has no effect on pages without default names.

5. Click OK.

See also
Adding layers
Assigning a shape to a layer
Assigning and canceling a background page
Creating a new page
Displaying pages
Setting page display options



About layers

    Related procedures

By assigning shapes to different layers, you can selectively view, print, and lock layers, as 
well as control whether shapes on a layer can be snapped to or glued to. 
For example, if you're drawing an office layout, you can assign walls, doors, and windows to 
one layer, electrical outlets to another layer, and furniture to a third layer. That way, when 
you plan the electrical system, you don't have to worry about accidentally rearranging the 
walls. 
After locking the wall and electrical outlet layers, you could distribute the office layout to 
coworkers, who could arrange the furniture in their offices without disturbing the foundation.
Shapes in the Office Layout template are already assigned to pre-existing layers. 
If you want to use layers with shapes from other stencils, you need to create the layers and 
assign shapes to them. 



Adding layers
Assigning a shape to a layer
Deleting layers
Renaming layers
Setting options for layers
Setting shapes on a layer to appear in a color
Viewing layers



Adding layers 





Adding layers

      Overview  

You can add shapes and layers to a drawing.

To add a layer:
1. From the View menu, choose Layer Properties. 
2. In the Layer Properties box, click New. 
3. In the New box, type a name for the layer, then click OK. 
4. In the Layer Properties box, check the properties you want the layer to have, then 

click OK.

See also
Assigning a shape to a layer
Creating a background page
Creating a new page
Deleting layers
Printing layers
Renaming layers
Setting options for layers
Viewing layers



Assigning a shape to a layer





Assigning a shape to a layer

      Overview  

You can add shapes to a drawing, then assign the shapes to layers. For example, you can 
add walls and furniture, then assign them to layers.

To assign a shape to a layer:
1. Select the shape. 
2. From the Format menu, choose Layer.
3. In the Layer box, choose the layer you want to assign the shape to, then click OK. 

To assign a shape to more than one layer, press the Ctrl key to choose multiple 
layers.

Tip: You can automatically add new shapes to a specific layer by making it active. For 
example, if you're working on the furniture layer, make that layer Active using the Layer 
Properties dialog box; as you drag and drop shapes, they are automatically added to the 
furniture layer. (Shapes with pre-assigned layers are not added to the active layer.)

See also
Adding layers
Creating a background page
Creating a new page
Viewing layers



Deleting layers





Deleting layers

      Overview  

If you find you don't need a layer, you can delete it.
Note: All shapes that are assigned to only the selected layer are deleted.

To delete a layer:
1. From the View menu, choose Layer Properties.
2. In the Layer Properties box, select the layer you want to delete, then click Remove. 
3. Click OK.

Tip: To delete all unused layers, check Remove Unreferenced Layers.

See also
Adding layers
Printing layers
Renaming layers
Setting options for layers
Viewing layers



Viewing layers





Viewing layers

      Overview  

You can view specific layers. For example, you can view just the wall layer to fine-tune it. Or, 
in a garden diagram, you can view the flowerbed layer and the spring-blooming plants layer 
to see what will be blooming in the spring. In this case, the summer-blooming plants layer 
and fall-blooming plants layer would be hidden.

To view individual layers:
1. From the View menu, choose Layer Properties.
2. Under Visible, uncheck the layers you want to hide and ensure that the layers you 

want to view are checked.
3. Click OK.

Only the layers that are checked under Visible appear on the drawing page.



To identify shapes on a specific layer:
1. Ensure that no shapes are selected.
2. From the Edit menu, choose Select Special.
3. Under Layer, select the layer with the shapes you want to select, then click OK.

All shapes on the specified layer are selected.

See also
Adding layers
Assigning a shape to a layer
Printing layers
Setting options for layers
Setting shapes on a layer to appear in a color



Renaming layers





Renaming layers

      Overview  

In some templates, layers have default names that you can change.

To rename a layer:
1. From the View menu, choose Layer Properties.
2. In the Layer Properties box, select the layer you want to rename, then click Rename.
3. Under Layer Name, type a new name, then click OK.
4. Click OK.

See also
Adding layers
Assigning a shape to a layer
Setting options for layers
Setting shapes on a layer to appear in a color
Viewing layers



Setting shapes on a layer to appear in a color





Setting shapes on a layer to appear in a color

      Overview  

You can have all shapes assigned to a specific layer appear in a specific color. For example, 
in an organization chart, you could make editing easier by assigning each department to a 
different layer that has a unique color.
Note: The color you assign to shapes on a layer overrides each shape's original color; 
however, if you turn off the layer color (by unchecking the Color option), the shape returns 
to its original color.

To make all shapes on a layer appear 
in one color:

1. From the View menu, choose Layer Properties.
2. In the Layer Properties box, select the layer for which you want to set options.
3. Under Color, check or uncheck a layer to have all shapes assigned to a specific layer 

appear in a specific color. To determine the color, choose a color from the Layer Color 
box.

4. Click OK.

Note: If you have assigned a shape to more than one layer, the shape will not use the layer 
color but will appear in its original color.

See also
Adding layers
Assigning a shape to a layer
Deleting layers
Printing layers



Renaming layers
Setting options for layers
Viewing layers



Setting options for layers





Setting options for layers

      Overview  

To fine-tune layers, you can:
Choose an active layer. All new shapes that don't have pre-defined layers are 
automatically added to this layer.
Lock shapes on a layer so they cannot be selected or moved.
Specify whether shapes on a layer can be snapped or glued to.

To set options for a layer:
1. From the View menu, choose Layer Properties.
2. In the Layer Properties box, select the layer for which you want to set options.
3. Under Active, check a layer to have new shapes automatically added to that layer.

Under Lock, check a layer so that the shapes on the layer cannot be selected or 
moved.
Under Glue, check a layer to set whether shapes on a layer can be glued to.
Under Snap, check a layer to set whether shapes on a layer can be snapped to.
To have Visio remove all layers that have no shapes assigned to them, check Remove
Unreferenced Layers.

4. Click OK.

See also
Adding layers



Assigning a shape to a layer
Deleting layers
Printing layers
Renaming layers
Setting shapes on a layer to appear in a color
Viewing layers



Taking an inventory of your drawing

    Related procedures

Using the Shape Report command on the Tools menu, you can generate shape information 
to create an inventory.

To take an inventory, follow these 
steps:

1. Associate each shape with data, such as serial numbers or company location 
numbers.

2. Choose what information to include in the inventory list.
3. Choose whether you want to display the inventory on the screen, place it in the 

Windows clipboard, or save it as a text file you can export to a spreadsheet or 
database program.

4. Generate the inventory.

Take an inventory when, for example, you want to develop a bill of materials for a project, 
keep track of the location of equipment and furniture in an office, or account for every 
model, printer, computer, and server in a computer network. 
In addition, if you add numerical properties (such as cost) to shapes, you can perform 
calculations using custom properties.
If you have a multi-page diagram, remember that you can generate an inventory for only 
one page at a time. Even if certain shapes are selected when you generate the inventory, it 
will include data for all the shapes on a page.



Adjusting the data format
Associating data with shapes
Choosing inventory content
Generating an inventory
Performing calculations on shape properties
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Associating data with shapes

      Overview  

Shapes automatically have some data associated with them. For example, each shape has a 
name and is a certain height and width. If you want to generate custom reports, you can 
associate custom data with shapes.
To associate custom properties with a shape, you need to add a custom properties section to
the shape's ShapeSheet. Then, you can enter values for the properties in the Custom 
Properties box.
Shapes from some stencils already have custom properties. If those are the properties you 
want to use to generate a report, all you need to do is enter values for the properties.

To associate a shape with custom 
properties:

1. Open a Visio drawing and select a shape with which you want to associate data.
2. From the Tools menu, choose Run Add-on, then choose SmartShape Wizard 

(SHPSMART.EXE).
3. In the Wizard box, choose Custom Properties, then click Change Options.
4. Follow the instructions onscreen to add the properties you want.
5. When the summary screen appears, accept the changes you've made or return to the

Wizard to make revisions.



To assign values to a shape's custom 
properties:

1. Select the shape to which you want to assign values.
2. From the Shape menu, choose Custom Properties.
3. In the Custom Properties box, enter values for the properties associated with the 

shape.

See also
Adjusting the data format
Choosing inventory content
Generating an inventory
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Choosing inventory content

      Overview  

You can choose what data fields to include in an inventory. Unless you add additional fields, 
an inventory will include only Quantity (Qty) and Master fields. Qty lists the number of times 
a specific shape appears in a drawing. Master lists the shape names.
Qty and Master data are automatically assigned to Visio shapes. Other data automatically 
assigned include ID, Name, Height, Width, and Type. 
The inventory can also include fields for custom data, such as serial numbers, that you've 
associated with shapes.

To choose inventory content:
1. If you haven't already, associate shapes with data. For details, see Associating data 

with shapes.
2. From the Tools menu, choose Shape Report.
3. In the Shape Report box, click Select.
4. In the Select box, select fields in the Available Fields list and click Add to add them to 

the Inventory Fields list.
5. Select fields in the Inventory Fields list and click Up or Down to determine the order in

which they appear in the inventory.
6. For Field, select a field you want to sort on, select the sorting order, then click OK.
7. Generate an inventory. For details, see Generating an inventory.

See also
Adjusting the data format



Associating data with shapes
Generating an inventory
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Generating an inventory

      Overview  

You can generate an inventory in two ways:
· Copy the inventory to the Windows Clipboard so you can paste it into another program.
· Save the inventory as a text file so you can export it to a spreadsheet or database.
If you intend to export an inventory, set text delimiters and field separators for the data so 
the destination program can read the inventory. For details, see the documentation for the 
destination program.
Before you generate an inventory, decide how you want it to look. For example, you can 
choose to display field names at the top of each inventory column. The inventory can list 
each shape individually, or list all instances of a master shape as one item.

To generate an inventory:
1. If you haven't already, choose the inventory content. For details, see Choosing 

inventory content.
2. From the Tools menu, choose Shape Report.
3. In the Shape Report box, under Destination, click Screen, Clipboard, or File.
4. If you clicked File, click Browse to choose a location and name for the text file.
5. If you're exporting the inventory, select the Format options appropriate for the 

destination program.
6. Check the Options you want for displaying the inventory, then click OK.

See also



Adjusting the data format
Associating data with shapes
Choosing inventory content
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Adjusting the data format

      Overview  

If you plan to export the inventory to another program, you may need to change the text 
delimiter and field separator characters so that the other program can read the inventory 
list. For details, see the destination program's documentation.

To adjust the data format:
1. From the Tools menu, choose Shape Report.
2. Under Format, choose the text delimiter and field separator you want.

Typically, it's only important to choose a text delimiter character if you plan to export 
the inventory to a spreadsheet or database program.
If you choose {space} in the Field Separator box, choose double-quote ( " ) or single-
quote ( ' ) in the Text Delimiter box. Choose whichever character does not appear 
within text strings. For example, if text strings contain single-quotes, choose the 
double-quote character as the text delimiter.
If you choose {tab} in the Field Separator box, you may need to delimit text strings 
with double or single-quotes. Some programs always interpret spaces as field 
separators, even if you specify an alternative character for this purpose. See the 
destination program's documentation for details.

See also
Associating data with shapes
Choosing inventory content
Generating an inventory
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Performing calculations on shape properties

      Overview  

If you add custom properties¾such as cost, duration, or resources (number of people)¾to a 
diagram's shapes, you can use the Property Reporting Wizard (REPORTER.EXE) to perform 
calculations using those properties. For example, you could calculate the total cost of a 
computer network.
In addition, you can take an inventory of information associated with shapes. For example, 
you can generate a bill of materials for a project, keep track of the location of equipment 
and furniture in an office, or account for every model, printer, computer, and server in a 
computer network.

To perform calculations, follow these 
steps:

1. Create a diagram by dragging and dropping shapes onto the drawing page.
2. Associate the shapes with numerical data on which you want to perform calculations. 

For details, see Associating data with shapes.
3. Select the shapes you want to calculate.
4. From the Tools menu, choose Run Add-on, then choose REPORTER.EXE.

Tip: Some templates (such as Total Quality Management and Flowchart) include a 
Property Reporting shape on the stencil. Drag and drop the shape, right-click it, then 
choose Run Property Reporting to run the Property Reporting Wizard.

5. Follow the instructions on screen in the Property Reporting Wizard boxes.

See also
Generating an inventory





Changing the page size and drawing scale

    Related procedures

Understanding how to use the drawing page, printed drawing, and paper size is important 
when you want to adjust the size or scale of a drawing or to change settings that affect how 
a drawing prints.

The drawing page and the printed drawing
The drawing page is the page in the drawing window. The rulers indicate its size. The printed
drawing is the same size as the drawing page unless you specify a drawing scale other than 
one to one or you reduce or enlarge the drawing when you print it. The drawing page and 
printed drawing are the same size as the paper unless you specify a different size for the 
drawing page.
When you open a new file without a template (or if the template you use doesn't change the
drawing scale or page size), the drawing scale is one to one. The drawing page, printed 
drawing, and paper size reflect the default paper size settings in Windows. These settings 
are displayed in the Page Setup dialog box.

Changing the drawing page, printed drawing, and paper size
You can change the size of the drawing page, printed drawing, and paper by changing 
settings in the Page Setup dialog box.
Three dialog boxes affect these settings:
· Page Setup (on the File menu).
· Properties (on the Edit menu, then Drawing Page submenu).
· Size & Scale (on the Edit menu, then Drawing Page submenu).
To match the drawing page to the paper size specified in the Page Setup dialog box: from the
Edit menu, choose Drawing Page, choose Size & Scale dialog box, then check Same As 
Printer.
When you change the drawing page size in relation to the paper size, keep in mind that:
· Changing the drawing page orientation by changing its size does not change the 

orientation of the paper. Mismatched orientations can cause the drawing to print 
incorrectly. To change the orientation, change settings in the Page Setup dialog box.

· Changing the size of a drawing page does not change the size of a background page 
assigned to it. You must change the size of a background separately.

· The printed drawing is the same size as the drawing page unless you set a drawing scale



other than one to one or reduce or enlarge the drawing for printing.
· If you choose Fit Page To Drawing Contents in the Size & Scale dialog box and then edit 

the drawing, the page may no longer tightly enclose the shapes. 
To resize the page so it fits the shapes again: from the Edit menu, choose Drawing Page, 
choose Size & Scale, choose Fit Page To Drawing Contents, then click OK to reapply the 
option.

Changing the drawing scale
When you change the drawing scale, keep in mind that:
· The units of measure displayed on the ruler are the same as those specified in the 

drawing scale unless you specify different units in the Measurements list in the Properties
dialog box.

· Changing the scale of a drawing page does not change the scale of a background page 
assigned to it.

· Most master shapes are designed for drawings with a scale of one to one. Visio 
compensates for an instance whose scale differs greatly from the scale of the drawing. In
some cases, however, if you drag a master into a scaled drawing, an instance (or part of 
an instance) might be too large or too small.



Changing the drawing page and print settings together
Changing the size of the drawing page
Setting a drawing scale



 Changing the drawing page and print settings together





Changing the drawing page and print settings together

      Overview  

Visio saves printer settings with each drawing file. A new drawing file uses the default 
printer settings or the printer and page settings for the template you used to start the 
drawing. A drawing page uses the current printer settings unless you specify different 
settings for the page.

To change the drawing page, printed 
page, and paper size:

1. From the File menu, choose Page Setup.
2. In the Orientation section, choose Portrait or Landscape.
3. From the Paper list, choose a paper size.
4. Click OK.

Changing settings in the Page Setup dialog box affects a drawing page only when Same As 
Printer is checked in the Size & Scale dialog box. The printed drawing, drawing page, and 
paper size are the same size if the drawing scale is one to one and if you do not reduce or 
enlarge the page during printing.



To match the drawing page and 
printed drawing with Page Setup settings:

1. Display the drawing page.
2. From the Edit menu, choose Drawing Page, then choose Size & Scale.
3. In the Page Size section, check Same As Printer.
4. In the Drawing Scale section, check No Scale (1:1).
5. Click OK.

See also
Changing the size of the drawing page
Choosing a printer
Reducing or enlarging a drawing for printing



Changing the size of the drawing page





Changing the size of the drawing page

      Overview  

You can create drawing pages that are a different size from the paper size specified in the 
Page Setup dialog box. When a large drawing page is printed, it is tiled and printed on 
multiple sheets of paper. A small drawing page prints easily at various locations on a sheet 
of paper.

To size a drawing page independently
of the paper size:

1. Display the drawing page.
2. From the Edit menu, choose Drawing Page, then choose Size & Scale.
3. In the Page Size section, choose an option other than Same As Printer.
4. Click OK.

The Standard list reflects page orientation as well as size. The first measurement is the 
sheet's width and the second is the height. To change a letter-size drawing page from tall to 
wide, choose Letter Wide (11 in. x 8.5 in.).

See also
Assigning and canceling a background page
Printing a drawing
Reducing or enlarging a drawing for printing
Setting a drawing scale
Showing page breaks
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Setting a drawing scale

      Overview  

To create accurate architectural, engineering, and scientific drawings, you need to draw 
them to scale. The drawing scale determines the relationship of the drawing page to the 
printed drawing (unless you also reduce or enlarge the printed drawing).

To set a drawing scale:
1. Display the drawing page.
2. From the Edit menu, choose Drawing Page, then choose Size & Scale.
3. In the Drawing Scale section, choose a standard architectural or engineering scale or 

enter a custom scale.
4. Click OK.

See also
Assigning and canceling a background page
Changing the size of the drawing page
Printing a drawing
Reducing or enlarging a drawing for printing
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Setting page display options

      Overview  

You can change the display of the ruler and the grid. For example, you can change the units 
of measure for rulers and adjust the spacing of subdivisions for rulers and grid lines.

To change page display options:
1. From the Edit menu, choose Drawing Page, then choose Properties.
2. To set the unit of measure, choose an option from the Measurements list.
3. To set grid line and ruler subdivisions, choose Ruler & Grid from the Tools menu.
4. In the Subdivisions section, choose Fixed, Fine, Normal, or Coarse for grid line and 

ruler subdivisions.
5. Click OK.

Important: Setting a drawing scale often changes the units of measure on the ruler.

See also
Aligning shapes to rulers
Changing the size of the drawing page



 



Printing drawings

    Related procedures

For most drawings, you can use default printer settings or the settings that a template 
provides. For other drawings, you may need to adjust margins, set the way color prints on 
monochrome printers, or reduce or enlarge the drawing.
Before you print a drawing, you can preview it on the screen to see how shapes and other 
information will be displayed when you print the drawing. When you are working with a large
drawing that will print over several pages, you can view page breaks and adjust the drawing 
so it is arranged on the pages as you want.
You can choose to print an entire drawing, a range of pages, only the page that's displayed 
in the drawing window, or specific layers in the diagram. You can also print a drawing to a 
file, which enables you to print the drawing on another computer.
For complete details about printers and printing in Microsoft Windows, see your Windows 
documentation.



Choosing a printer
Editing a drawing while in Print Preview
Previewing a drawing before you print
Printing a background page
Printing a drawing
Printing a drawing to a file
Printing a page without its background
Printing color drawings on monochrome printers
Printing layers
Showing page breaks



Printing a drawing





Printing a drawing

      Overview  

To print a drawing:
1. From the File menu, choose Print.
2. In the Print Range section, choose an option for which pages to print:

Choose All or Current Page, or specify a range of pages in the Pages From and To 
boxes.
If a foreground page is displayed, choosing the Current Page option prints the 
foreground page and any background pages. If a background is displayed, Current 
Page prints that background page and all other background pages assigned to that 
background.

3. In the Copies section, enter the number of copies you want.
4. In the Printer section, specify to print to a file, or to print all colors as black.
5. Click OK.



To print the current page:
1. Click the Print button on the toolbar.

Visio prints the page currently displayed.

See also
Choosing a printer
Previewing a drawing before you print
Printing a page without its background
Reducing or enlarging a drawing for printing



Printing a page without its background





Printing a page without its background

      Overview  

By canceling the assignment of a background page, you can print a drawing page without its
background.

To print a page without its 
background:

1. Display the page you want to print.
2. From the Edit menu, choose Drawing Page, then choose Properties.
3. From the Background list, choose None.
4. Click OK.
5. From the File menu, choose Print.
6. In the Print dialog box, choose the printing options you want.
7. Click OK.

See also
Assigning and canceling a background page
Previewing a drawing before you print
Printing a background page
Printing a drawing



Printing a background page





Printing a background page

      Overview  

To print a background page:
1. Display the background page in an open window.
2. From the File menu, choose Print.

You can also click the Print button.
3. Choose the Current Page option, and then click OK.

Note: This prints the background page and any background pages assigned to it.

See also
Assigning and canceling a background page
Printing a drawing
Printing a page without its background
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Printing a drawing to a file

      Overview  

To print to a file:
1. From the File menu, choose Print.
2. In the Printer section, check Print To File.
3. Click OK.
4. Type a filename and choose a location for the print file.
5. Click OK.

To send a print file to a printer:
1. Click the Windows Start button, choose Programs, then choose MS-DOS prompt.
2. At the DOS prompt, type a command to send the file to the printer. For example:



copy /b c:\project\pfile lpt1:
where copy /b copies the entire file, c:\project is the path where the file is stored, 
pfile is the file you are printing, and lpt1: is the port your printer is connected to.

3. Click the X button to close the DOS window.

See also
Changing the drawing page and print settings together
Choosing a printer
Previewing a drawing before you print
Printing a drawing
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Printing color drawings on monochrome printers

      Overview  

When you print on a monochrome printer, Visio translates the colors on the screen into gray 
tones on the printed page. White prints as no color, and black prints as black.
Some printer drivers provide gray-scale options. You can experiment with gray-scale options 
to find which one works best.

To specify a gray-scale option:
1. From the File menu, choose Page Setup.
2. In the Page Setup dialog box, click Printer, then click Properties.
3. In the Properties dialog box, set printing options that control the gray scale. 

This dialog box is printer-specific.
4. Click OK, then click OK.
5. In the Page Setup dialog box, click OK.

Tip: For the best gray tones in a printed drawing, use the grays in the Visio default color 
palette. If you use patterned fills, try using a solid color for the fill background and a shade 
of gray for the foreground. These patterns print better than some other patterns.
If a shape doesn't appear in a printed drawing, Visio may have translated the color of the 
shape's line and fill as white.
To correct this problem:
· Change the color of the shape's line or fill to a darker color. Visio translates the color as a

darker gray, so the shape appears in the printed drawing.



· In the Print dialog box, check Color As Black. Visio prints the lines and fills of all shapes 
as black, so shapes are visible in the printed drawing. This is helpful if you can't 
determine which shapes are missing from the printed drawing.

See also
Choosing a printer
Formatting fills and shadows
Printing a drawing
Printing a drawing to a file
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Previewing a drawing before you print

      Overview  

Before you print a drawing, you can check to see how the drawing will appear on the printed
page. Visio uses current settings in the Page Setup dialog box to create the preview.

To preview the printed version of a 
drawing:

1. From the File menu, choose Print Preview.
You can also click the Print Preview button.
Visio displays the print preview window, which contains an image of the printed 
drawing.

2. To return to the drawing window, click the Close button on the print preview toolbar.
If the drawing is smaller than the specified paper size, the print preview window shows 
where the drawing will print on the page. If the drawing is larger than the specified paper 
size, Visio displays the drawing as it will be tiled when printed. 
You can move between tiles by choosing the Next Tile and Previous Tile commands from the 
View menu.

See also
Choosing a printer
Editing a drawing while in Print Preview
Printing a drawing
Showing page breaks
Tiling a large drawing onto multiple sheets of paper



Showing page breaks





Showing page breaks

      Overview  

You can quickly determine whether a drawing fits within the printable area. Visio uses the 
current printer settings in the Page Setup dialog box to create an outline of the margins in 
the drawing window.

To preview page breaks:
1. From the View menu, choose Page Breaks.

Visio outlines the margins of the sheets of paper on which the drawing will print.

See also
Previewing a drawing before you print
Printing a drawing
Tiling a large drawing onto multiple sheets of paper



Editing a drawing while in Print Preview





Editing a drawing while in Print Preview

      Overview  

When viewing a drawing in the print preview window, you can also display the drawing 
window and edit the drawing. Changes you make to the drawing are reflected in the print 
preview window.

To edit a drawing while previewing it:
1. In the print preview window, choose New Window from the Window menu.

Visio opens a new drawing window and displays the drawing.
2. From the Window menu, choose Tile.

Visio displays the drawing in the print preview window and the drawing window.
3. In the drawing window, edit the drawing using Visio's tools and commands.

Changes you make to the drawing are displayed in the print preview window.

See also
Previewing a drawing before you print
Printing a drawing
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Printing layers

      Overview  

You can print specific layers and not print others. 

To print individual layers:
1. From the View menu, choose Layer Properties. 
2. Under Print, uncheck the layers you do not want to print and ensure that the layers 

you want to print are checked.
3. Click OK.
4. From the File menu, choose Print, then click OK.

Visio prints only the layers that are checked under Print.

See also
Adding layers
Deleting layers
Renaming layers
Setting options for layers
Viewing layers



Making printing adjustments

    Related procedures

Before you print, you may need to adjust certain settings. You may want to change the 
margins for a page or choose a particular printer. When you are working with large drawings,
you can view page breaks and adjust the drawing to fit in the printable area.
Since most printers do not print to the edge of the paper, you may need to determine how 
close to the edge of the paper your printer can print. There are several ways to adjust the 
drawing to fit in the printable area:
· In the drawing window, move shapes away from the edges of the drawing page. 

Alternatively, choose Center Drawing from the Tools menu to center the drawing on the 
page.

· Reduce the drawing before you print.
· Set margins, and then specify that you want to fit the printed drawing on one page.



Reducing or enlarging a drawing for printing
Setting margins
Tiling a large drawing onto multiple sheets of paper
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Choosing a printer

      Overview  

To choose a printer:
1. From the File menu, choose Page Setup.
2. Click Printer, then choose the default printer, or choose a printer from the list.
3. Click OK, then click OK again.

See also
Changing the drawing page and print settings together
Printing a drawing



Setting margins





Setting margins

      Overview  

By setting margins you can create a nonprinting area around a tiled drawing and increase 
the area where the tiles overlap. You can also create a nonprinting area around a drawing 
that prints on one sheet of paper, or move a small drawing to various locations on the page.

To set margins:
1. From the File menu, choose Page Setup.
2. In the Margins section, type a number in the Left, Right, Top, and Bottom boxes to 

specify the size of each margin.
3. If you are printing a drawing page that is the same size as the paper, type 1 in the Fit 

On boxes in the Reduce/Enlarge section.
4. Click OK.

Note: Visio never clips a drawing at the margins. When you print on a sheet of paper that is 
the same size as the drawing page, setting margins has no effect unless you also specify to 
print the drawing on a single sheet of paper. When you specify that you want to print on a 
single sheet, Visio reduces the drawing (if necessary) to fit within the margins.

See also
Changing the drawing page and print settings together
Printing a drawing
Reducing or enlarging a drawing for printing
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Reducing or enlarging a drawing for printing

      Overview  

To print a drawing at various sizes, or to fit a drawing within the printable area of the paper, 
you can reduce or enlarge a drawing for printing. You can also specify the number of sheets 
on which to print a drawing, and Visio reduces or enlarges the drawing to fit the number you 
specify.

To reduce or enlarge a drawing:
1. From the File menu, choose Page Setup.
2. In the Reduce/Enlarge section, choose one of the following options:

To specify a percentage, choose Scale, and then type the percentage by which you 
want to enlarge or reduce the drawing. To reduce a drawing, type a number less than 
100. To enlarge a drawing, type a number greater than 100.
To specify the number of pages to print on, choose Fit On, and then specify the 
number of pages.

3. Click OK.

See also
Changing the drawing page and print settings together
Previewing a drawing before you print
Printing a drawing
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Tiling a large drawing onto multiple sheets of paper

      Overview  

To print a large drawing, you can specify the number of sheets of paper on which to print. 
Visio reduces or enlarges the drawing to fit the number of sheets you specify.

To specify the number of sheets for a 
tiled drawing:

1. From the File menu, choose Page Setup.
2. In the Reduce/Enlarge section, choose Fit On.
3. In the Fit On boxes, specify the number of sheets across and down.
4. Click OK.

Note: The number of sheets down and across must represent an area proportionate to the 
drawing page. For example, if the drawing is square and you specify two sheets down and 
four sheets across, Visio reduces or enlarges the drawing to fit an area that is no more than 
two sheets either way. The drawing does not print on the unnecessary sheets.

See also
Changing the drawing page and print settings together
Previewing a drawing before you print
Reducing or enlarging a drawing for printing



 



Importing, exporting, linking, and embedding overview

    Related procedures

Linking, embedding, importing, and exporting¾as well as copying and pasting¾are methods 
of integrating a Visio shape or drawing with another program. You can use these features to 
put a shape or drawing created in Visio into a document created in another program or to 
bring objects from another program into a Visio drawing. 
The following table summarizes the ways to integrate a Visio shape or drawing with another 
program. Which method you use depends on the capabilities of the other program and how 
you want to use the material at its destination.

To: Do this: Limitations:
Transfer text or graphics to 
or from a program that 
supports the Windows 
Clipboard

Copy and paste You might not be able to 
update the pasted 
information, depending on 
the other program.

Update multiple instances of 
an object automatically

Link information Both programs must support 
OLE. You need to update a 
link if a file is renamed, 
moved, or copied to another 
folder.

Link to an external file so 
you can use it with other 
programs or drawings

Link information Both programs must support 
OLE.

Create an object that you 
want in only one instance

Embed 
information

Both programs must support 
OLE. The document is larger 
because it contains a copy of 
the embedded information.

Paste an object without 
maintaining an external file 
on disk

Embed 
information

Both programs must support 
OLE.

Quickly move, copy, or paste
an object from one program 
to another to embed or link 
the object

Drag and drop Both programs must support 
OLE and the drag and drop 
method.

Send a file to another 
computer

Mail a file Works with MAPI and CMC 
mail systems, such as 
Microsoft Mail.

Create an OLE object in a Create an object Both programs must support 



program you start within 
Visio, or create a Visio shape 
or drawing from within 
another program

from another 
program

OLE.

Bring a file in another format
into a Visio drawing

Import a file You must have the 
appropriate import filters 
installed.

Convert a Visio drawing into 
another file format 

Export a file 
using the Save 
As command

You must have the 
appropriate export filters 
installed.

Tip: In Microsoft Office for Windows 95, you can use the use the Microsoft Office Binder 
program to create a file that combines pages from multiple programs. For example, a single 
file can include pages from Microsoft Word, Visio, and Microsoft Excel. For details, see your 
Microsoft Office documentation.



Understanding linking and embedding

    Related procedures

Both linking and embedding establish an active link between the program that creates the 
OLE object and the OLE   container  . When you embed or link objects, the document contains 
or refers to data created in different programs. You can edit this data from within the 
document. For example, say you've created a Visio drawing of an organization chart. By 
linking or embedding the organization chart into an OLE container program, you can update 
the chart from within that program.
Note: Visio supports OLE 2, which lets you edit an object in Visio in place and drag and drop 
objects from one program to another.

Linking versus embedding
When you link to information in another program, you store a reference to the information, 
not the information itself. When you embed information in another program, the information 
itself is stored in the program. For example, if you link a Visio drawing to another program, 
the program contains only a reference to the Visio drawing file. If you embed a drawing, the 
drawing is stored in the other program's file. Because linking and embedding differ in where 
the actual data is stored, whether you choose to link or embed an object depends on how 
you intend to work with it.

When to link information
If you need to use the same information in more than one document and it's important that 
the most current version be used, link the information rather than embed it. Linked 
information can be updated every time you open the document that contains the reference 
to the source data. Any changes made to the original file appear in documents that are 
linked to it.
Linked information can take a little more care to maintain than embedded information 
because the original file must be available for the container program to update the 
information. If the original file is renamed or moved to a different folder, the link to the 
document may need to be updated. This also means that if you copy a linked document to 
another system, you must also copy the original file, and you may need to update the link. 
The link may have to be updated the first time the document is opened on that system.

When to embed information
Documents with embedded information can be easier to work with because there are no 
links to maintain and the document does not need access to other files. You can copy the 
document to another system without having to copy additional files. Because the 
information is not linked, changes to the original file are not reflected in the document. 



Embedding information makes the document larger because the document contains a copy 
of the information itself rather than a reference to another file. You can also edit embedded 
objects without leaving the container program.

What Visio needs to link or embed information
Visio can link or embed information from any Windows OLE object. Information from Visio 
can be linked to or embedded in any Windows program that supports OLE. For details about 
a particular program's capabilities for object linking and embedding, see its documentation.
Tip: If you want to take advantage of OLE, make sure your system has enough RAM for the 
OLE object program and the container program to run simultaneously.



Creating objects in another program from within Visio
Dragging and dropping a Visio object into other programs
Editing an embedded Visio object in place
Embedding Visio shapes in another document
Linking or embedding a drawing into another document
Linking or embedding a larger area of the drawing
Linking or embedding an object into a Visio drawing
Sending Visio drawings through electronic mail



Linking or embedding a larger area of the drawing





Linking or embedding a larger area of the drawing

      Overview  

To include a border around the drawing, you can increase the area Visio copies by creating a 
rectangle that covers the area you want.

To link or embed a larger area of the 
drawing:

1. In Visio, draw a rectangle that encloses the area you want to embed or link.
2. Make the rectangle transparent by applying the fill style None to the rectangle, or 

move it behind the shapes by choosing Send To Back from the Shape menu.
3. If you don't want the drawing to have a border, make the border transparent by 

applying the line style None to the rectangle.
4. From the Edit menu, choose Select All, then choose Copy or click the Copy button on 

the toolbar.
Even if you are finished using Visio, don't close it. In order to embed shapes, the 
other program needs certain information that is more quickly obtained if Visio is still 
running.

5. In the other program, display the document in which you want to embed the shapes.
6. Choose the command, usually on the Edit menu, used by that program to embed 

objects in its documents.
This command is usually Paste, but may be Paste Special, Paste Object, or a 
command unique to the program. For details, see the OLE documentation for that 
program.

You can also extend the area around embedded Visio shapes or around the entire drawing: 



from the Edit menu, choose Drawing Page, then choose Size & Scale. Type the width and 
height of the drawing in the Drawing Size boxes.
If you are editing a Visio object in place, you can enlarge the drawing area by dragging a 
handle on the border.
Tip: To link multiple shapes, select the shapes you want (using Shift+click), then link them 
to the other program.

See also
Editing an embedded Visio object in place
Embedding Visio shapes in another document
Exporting a drawing into another file format
Linking or embedding a drawing into another document
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Editing an embedded Visio object in place

      Overview  

You can edit an embedded Visio object without leaving the OLE 2 container program. A 
special set of Visio menus and toolbars temporarily replaces most of the menus and controls
in the active window while you are editing the Visio object.

To edit an embedded Visio object in 
place:

1. In the container program, double-click the embedded object.
A special set of Visio menus and controls appears.

2. Edit the object.
3. Click anywhere outside the drawing window to exit the in-place editing controls.

Note: You cannot edit an object embedded in Visio in place.

See also
Editing an object from another program
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Dragging and dropping a Visio object into other programs

      Overview  

As an alternative to cutting¾or copying¾and pasting, you can drag and drop one or more 
shapes from one program to another. When the Visio shapes are in another program, they 
are treated as one object. You can use this method only if both the OLE object and OLE 
container programs support OLE 2. In dragging and dropping an object, you do not use the 
Clipboard, so information on the Clipboard is not affected. When you drag and drop an object
from one program to another it will be embedded, linked, or pasted into the container 
program depending on what keys you hold down as you move the object and what file 
formats the other program supports.

To move an object from Visio to 
another program:

1. Hold down the Shift key as you drag an object from Visio to the container program.
The object will be embedded in the container program and deleted from Visio. If you 
do not want to delete the object from Visio, choose Undo from the Edit menu after 
moving the object. 



To copy an object from Visio to 
another program:

1. Hold down the Ctrl key as you drag an object from Visio to the container program.
The object will be embedded in the container program but not deleted from Visio.

To link an object from Visio to another
program:

1. Select the object.
2. While pressing the mouse button, hold down the Ctrl and Shift keys as you drag an 

object from Visio to the container program.

Note: You cannot move an object from a read-only Visio file, and you cannot move a master 
shape from a stencil to another program, removing it from its stencil. However, you can copy
a master shape from a stencil to another program.

Mouse pointer
Depending on whether you are moving, copying, or linking a file, the mouse pointer changes
to indicate the action. The mouse pointer will also change to indicate if the program does 
not support drag and drop embedding or linking.

Mouse 
pointer

Action

Cut and paste
Copy and paste
Link
Unable to link or embed file



See also
Embedding Visio shapes in another document
Linking or embedding a drawing into another document
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Sending Visio drawings through electronic mail

      Overview  

You can quickly send a Visio drawing through an electronic mail program that supports 
Messaging Application Program Interface (MAPI) or the Common Messaging Call (CMC) 
protocol.

To send a drawing file by mail:
1. While the drawing file is open, from the File menu, choose Send.

If your mail program hasn't been running, it starts, then a mail message containing 
the Visio icon and the filename appears.

2. Address the message, type any accompanying information, and send the mail 
message as you would any other message.

To view a Visio file sent by mail:
1. Open the mail message, then double-click the Visio icon.



See also
Embedding Visio shapes in another document
Linking or embedding a drawing into another document
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Linking or embedding an object into a Visio drawing

      Overview  

If a program supports OLE, you can embed the object in Visio. The embedded object doesn't 
retain an association with its original file, so changes to the original don't affect the 
embedded object in the Visio drawing.

To embed an object from another 
program into a Visio drawing:

1. Display the document that contains the information you want in its program window.
2. In the document, select the information you want to embed in the Visio drawing.
3. Choose the command used by that program to place information on the Clipboard.

This is usually the Copy command on the Edit menu.
4. Display the drawing in which you want to embed the object in the Visio window.
5. From the Edit menu, choose Paste or click the Paste button on the toolbar.

Visio pastes the information from the Clipboard into the drawing as an object. The 
object will be placed in the center of the view, but you can select and move the 
object just like a Visio shape.

A linked OLE object can be updated automatically every time you open the drawing or only 
when you explicitly request it. Any time a link is updated, changes made to the object in its 
original file appear in the document that the file is linked to.



To link a file to a drawing:
1. Save the original file.

Because a link consists of a reference to the original file, you must save the file 
before you can link to it.

2. In the original file, select the information you want in the Visio drawing.
3. Choose the command used by the OLE object program to place information on the 

Clipboard.
This is usually the Copy command on the Edit menu.

4. Display the Visio drawing you want to link the file to.
5. From the Edit menu in Visio, choose Paste Special.
6. In the Paste Special dialog box, choose Paste Link.
7. Click OK.

See also
Converting an object to Visio shapes
Creating objects in another program from within Visio
Editing an object from another program
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Creating objects in another program from within Visio

      Overview  

Because Visio supports OLE, you can create objects in other programs from within a Visio 
drawing. (However, you cannot edit an object embedded in Visio in place.) For example, if 
you are working in Visio you can open Microsoft Excel and create a spreadsheet without 
leaving Visio. You can run another program from within Visio and either create a new object 
or open an existing file. When you create a new Visio object in another program, the Visio 
object is always embedded. When you use an existing Visio file in another program, you can 
either link or embed it.

To create a new object in another 
program:

1. From the Insert menu, choose Object.
2. In the Insert Object dialog box, choose Create New.
3. From the Object Type list, choose the type of object you want to create, and then click

OK.
Visio runs the program for creating that object.

4. Create the object you want.
5. From the File menu in the program, choose Exit.



To create an object from a file:
1. From the Insert menu, choose Object.
2. In the Insert Object dialog box, choose Create From File.
3. Check Link if you want to link the file to the Visio drawing.
4. Type a path and filename in the text box. Alternatively, click Browse, and then choose

the name of the file you want.
5. Click OK.

Display As Icon
Depending on the OLE object program, objects or files that are linked or embedded through 
the Object command may appear as icons. You can have a file appear as an icon by 
selecting Display As Icon in the Object dialog box.

See also
Converting an object to Visio shapes
Linking or embedding an object into a Visio drawing
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Embedding Visio shapes in another document

      Overview  

You can embed shapes from a Visio drawing into another document by copying the shapes 
to the Clipboard and then pasting them into the container program. 
You can also embed Visio shapes by dragging and dropping them into another OLE 2 
container program. For details, see Dragging and dropping a Visio object into other 
programs.

To embed selected shapes into 
another document:

1. In the drawing, select the shapes you want to embed in the other document.
2. From the Edit menu, choose Copy or click the Copy button on the toolbar.

Even if you are finished using Visio, don't close it. To embed shapes, the other 
program needs certain information that is more quickly obtained if Visio is still 
running.

3. In the other program, display the document in which you want to embed the shapes.
4. Choose the command used by that program to embed objects in its documents.

This command is usually Paste on the Edit menu, but it may be Paste Special, Paste 
Object, or a command unique to the program. For details, see the OLE documentation
for that program.

See also
Exporting a drawing into another file format
Linking or embedding a drawing into another document
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Linking or embedding a drawing into another document

      Overview  

If you want to use an entire page of a Visio drawing in another document, you can embed 
the page in much the same way as you embed selected shapes, or you can link the Visio file 
that contains the page to the other document. When you embed or link an entire page, only 
an area large enough to hold all the shapes on the page is displayed in the other document. 
Tip: For details about linking or embedding the page with more space around the shapes, 
see Linking or embedding a larger area of the drawing.

To link or embed a drawing into 
another document:

1. Make sure nothing is selected in the drawing.
If any shapes are selected, Visio will link or embed only those shapes in the other 
document, rather than the whole drawing.

2. If you want to create a link to the drawing rather than just embed a copy of it, save 
the drawing file.
Because a link consists of a reference to the original file, you must save the file 
before you can link to it.

3. From the Edit menu, choose Copy Drawing.
Even if you are finished using Visio, don't close it. To embed or link the drawing, the 
other program needs certain information that is more quickly obtained if Visio is still 
running.

4. Display the document in which you want to embed or link the Visio drawing.
5. Choose the command used by that program to embed or link objects.



For embedding, this command is usually Paste on the Edit menu. For linking, this 
command may be Paste Special or another command unique to the program. For 
details, see the OLE and Clipboard documentation for the program.

See also
Embedding Visio shapes in another document
Exporting a drawing into another file format
Linking or embedding a larger area of the drawing



Managing links

    Related procedures

Links refer to other files, so they can take a little work to maintain. A link's file reference 
consists of the complete folder path to the file on disk. If a file is renamed, deleted, or 
moved to another folder, Visio can't find the file to update the linked object, and you'll have 
to change the link to refer to the file in its new location or cancel the link if the file no longer 
exists. 
For example, if you copy a drawing and its linked files to another computer with Visio, Visio 
will not be able to update the linked objects unless all of the files are copied to the same, or 
relative, folder path as on your system.
When you open a drawing that contains a linked object, Visio may display a message asking 
you whether to update links in the document. This message appears when the drawing 
contains a link and the OLE object program for that linked object is unavailable.    If the OLE 
object program is not available¾for example, if you open a drawing on a system that doesn't
have that program installed¾Visio displays a message to that effect. The visible 
representation of the object in the drawing is not affected, but you cannot edit the object.



Breaking links
Viewing and updating links



OLE 2 supports relative linking so you can move the linked files between corresponding 
folder paths. For example, if the original linked files were in c:\projects\homeplan.vsd and c:\
budget.xls you can move them to a:\projects\homeplan.vsd and a:\budget.xls.



Viewing and updating links





Viewing and updating links

      Overview  

You can view all of the links for a drawing and set a link to be manually or automatically 
updated. If Visio cannot find the file to update a link, you can change the file reference to 
the correct file.

To view the links between a drawing 
and other files:

1. From the Edit menu, choose Links.

To change a link:
1. In the Links dialog box, choose the link you want to change.
2. If you want Visio to update the link automatically, choose Automatic. If you want to 

update the link by using the Links command, choose Manual.
3. If you want to change the link, click Change Source and select a new file reference in 



the Change Source dialog box.
4. When you finish viewing and changing links, click OK in the Change Source dialog 

box, and then click Close in the Links dialog box.

You can change a link's file reference to any other file of the same format as the original file. 
For example, you can change the link to a .BMP file to a different .BMP file to display its image 
in a drawing, or change the link for an Excel spreadsheet to display the same range of cells 
from a completely different spreadsheet file. 
You can update manual or automatic links at any time by using the Links command.

To update a link manually:
1. From the Edit menu, choose Links.
2. Choose the link you want to update.
3. Click Update Now, then click Close.

See also
Breaking links
Converting an object to Visio shapes
Linking or embedding an object into a Visio drawing
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Breaking links

      Overview  

You may want to break the link between an object in a drawing and another file. Perhaps you
want to give the drawing to someone without having to provide the linked files with it, or the
information in the linked file has stabilized and you don't need to update the object in the 
drawing any more. You can break a link between an object and a file by canceling the link.

To break a link between a drawing 
and another file:

1. From the Edit menu, choose Links.
2. In the Links dialog box, choose the link you want to break.
3. Click Break Link.

Visio converts the object to a Windows Metafile in the drawing and discards the 
reference to its original file.

Note: You can also break a link between an object and its original file by converting the 
object to a Visio group. Usually converting the object to a Windows Metafile reduces the size 
of the drawing file. 

See also
Converting an object to Visio shapes
Linking or embedding an object into a Visio drawing
Viewing and updating links



Importing and exporting

    Related procedures

If the program you want to exchange information with doesn't support copying and pasting 
or linking and embedding, Visio also supports importing and exporting.
Importing brings a file in another format into a Visio drawing. Visio creates a placeholder in 
the drawing to hold the imported information. You can import an entire file into a Visio 
drawing.

Import formats
Visio can import files in these formats:
· Adobe Illustrator File Format (.AI)

· Computer Graphics Metafile (.CGM)

· CorelDraw Drawing File Format, version 3.0, 4.0, and 5.0 (.CDR)

· Encapsulated PostScript (.EPS)

· Initial Graphics Exchange Specification (.IGS)

· Macintosh Picture File Format (.PCT)

· Micrografx Designer Version 3.1 File Format (.DRW)

· Tag Image File Format (.TIF)

· Windows Bitmap (.BMP, .DIB)

· Windows Metafile (.WMF)

· ZSoft PC PaintBrush Bitmap (.PCX)

Tip: You can import and convert ABC FlowCharter and CorelFlow files to Visio using the Open
command on the File menu. If you have Visio Technical, you can also convert AutoCAD files 
into Visio format.

Export formats
Visio can export files into these formats:
· Adobe Illustrator File Format (.AI)

· Computer Graphics Metafile (.CGM)

· Encapsulated PostScript (.EPS)

· Initial Graphics Exchange Specification (.IGS)



· Macintosh Picture File Format (.PCT)

· Tag Image File Format (.TIF)

· Windows Bitmap (.BMP, .DIB)
· ZSoft PC PaintBrush Bitmap (.PCX).

How imported files are displayed
For files imported with an import filter, you can control some aspects of the way an imported
file is displayed in the drawing. When you import such a file, Visio displays the Graphic 
Import dialog box.

To specify graphic import options:
Option Description
Retain Gradients Retains gradient fills.
Retain Background Retains the background specified in the 

original program by creating a rectangle of
that color.

Emulate Line Styles Draws thick or patterned lines as polygons 
to more closely represent how they appear
in the image, rather than using the line 
style and width capabilities of the display 
or printer driver.

Normal Uses colors exactly as specified in the 
image file.

Inverse Inverts all colors. For example, black 
becomes white and white becomes black 
to create the effect of a photographic 
negative.

Inverse Grays Only Inverts only black, white, and grays; all 
other colors retain their original color. This 
is useful for accentuating shading or 
patterns.

Gray Scale Converts all colors to shades of gray.
Inverse Gray Scale Converts all colors to shades of gray and 

then inverts them to create the effect of a 
black-and-white photographic negative.

Converting an object to Visio shapes
Editing an object from another program



Exporting a drawing into another file format
Formatting an object from another program
Importing a file into a Visio drawing
Pasting information in a particular format
Scaling, cropping, or panning an object
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Pasting information in a particular format

      Overview  

Most programs place information on the Clipboard in more than one format to make the 
information usable by more programs. When you paste information from the Clipboard into a
program, it uses only one of the available formats by default.
However, you may want to use a different format. For example, you may want to paste 
something as a bitmap or a Windows Metafile, rather than embed it in the drawing. You can 
paste information from the Clipboard in a particular format by using the Paste Special 
command instead of Paste.

To paste information from the 
Clipboard in a particular format:

1. Copy the information you want to the Clipboard.
2. Display the Visio drawing into which you want to paste the information.
3. From the Edit menu, choose Paste Special.
4. In the Paste As box, choose the format you want.
5. Click OK.

See also
Linking or embedding an object into a Visio drawing
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Importing a file into a Visio drawing

      Overview  

When you import a file, its contents appear in the center of the view. However, you can 
select and move the object just like any other Visio shape.

To import a file into a Visio drawing:
1. From the Insert menu, choose Picture.

The import filters installed with Visio determine the types of files you can import.
2. In the File Type list, choose the format you want.

Visio lists the files in that format. If the file you want is not in the list, change to the 
folder that contains the file.

3. In the File Name box, choose the file you want.
4. Click OK.

Depending on the type of file you are importing, Visio may ask you to choose options 
that affect the file's appearance. 

Tip: You can also import and convert ABC FlowCharter and CorelFlow files to Visio using the 
Open command on the File menu. If you have Visio Technical, you can also convert AutoCAD 
files into Visio format.

See also
Converting an object to Visio shapes
Pasting information in a particular format
Scaling, cropping, or panning an object
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Scaling, cropping, or panning an object

      Overview  

After you paste an OLE object into a Visio drawing or import a picture, you'll probably want 
to adjust its appearance. You may want to make the object larger or smaller, or you may 
want to see only part of it. When you paste an object into a Visio drawing, the object initially 
is the same size as in its original program. 

To adjust the object, you can:
· Size the object's dimensions.
· Crop or expand the object's borders without altering its appearance.
· Pan the object to move it within its borders.

To size an object from another 
program:

1. With the pointer tool, select the object.
2. Drag one of the selection handles until the object is the size you want.

Drag a corner handle to size the object proportionally. Drag a side handle to stretch 
or shrink the object vertically or horizontally.



To crop an object from another 
program:

1. From the rotation and crop tool menu, choose the crop tool.
2. Select the object.
3. Drag a selection handle until the object's borders are the size you want.

A smaller portion of the object appears; however, Visio retains the entire object so 
you can crop it differently if you want.

Although you don't see the cropped parts of an object, they're still present in the drawing 
and can occupy valuable memory when you print. For more efficient printing, try to bring 
objects in at approximately the size you want, instead of cropping large areas of the object.

To pan or scroll an object from 
another program:

1. From the rotation and crop tool menu, choose the crop tool.
2. Point inside the object and press the left mouse button.
3. Drag until the object is positioned the way you want inside its borders.

See also
Linking or embedding an object into a Visio drawing
Moving shapes by dragging
Selecting shapes
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Converting an object to Visio shapes

      Overview  

You can convert some embedded objects to other file formats if the program of the 
embedded file supports the other file format. You can also specify that an object appear as 
an icon by selecting Display As Icon.

To convert an embedded object to 
another format:

1. Select the embedded object you want to convert.
2. From the Edit menu, choose the command to convert the object.

This command will usually be Convert on the <OLE object> submenu.

Windows metafiles
You can convert a pasted or imported Windows metafile into a Visio group or shape. If a 
linked or embedded object is represented by a metafile, you can also convert the object to a 
Visio group or shape, although doing so breaks the object's link to its original file and its 
ability to be edited in its original program. 
You can convert a metafile to a Visio group or shape in two ways:
· To preserve the relationship of the shapes to each other, use the Convert To Group 

command from the Shape menu to change the metafile into a Visio group.
· To separate the metafile into individual shapes, use the Ungroup command. You don't 

need to convert the metafile to a group first before ungrouping it.
Note: A metafile may contain a bitmap as a component, or a metafile may consist solely of 
a bitmap. Bitmaps cannot be converted to Visio shapes. However, a metafile that consists of 



a single bitmap usually stores the bitmap in segments. When you convert such a metafile to 
Visio shapes, each segment of the metafile becomes an individual bitmap object, and you 
will probably want to convert the metafile to a group to keep the bitmaps together.

See also
Editing and formatting a group
Grouping and ungrouping shapes
Linking or embedding an object into a Visio drawing
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Editing an object from another program

      Overview  

You can modify an embedded or linked object in its original program from within the Visio 
drawing. If you modify an embedded file, you are modifying a copy of the original file. If you 
modify a linked file, you are changing the original file. The OLE object program provides a 
command on the Visio Edit menu especially for editing its objects.
Most programs provide a submenu of actions you can perform on an OLE object. Usually the 
command for editing an OLE object is Edit. Whatever the command is, the submenu usually 
appears below the Links command on the Edit menu in Visio.

To edit an embedded or linked object:
1. Select the object you want to edit.
2. From the Edit menu in Visio, choose the command to edit the object.

This command will usually be <OLE object> Edit.
As a shortcut, you can select and edit the object by double-clicking the object in the 
drawing.
Windows runs the OLE object program and displays the object in the program 
window. If the object is linked, the program opens the original file that contains the 
object.

See also
Converting an object to Visio shapes
Editing an embedded Visio object in place
Linking or embedding an object into a Visio drawing
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Formatting an object from another program

      Overview  

You can format an object from another program in the following ways:
· You can apply a line style or attribute to change the appearance of the object's border. 

For example, you might choose a distinctive outline for embedded or linked objects to 
indicate they can be edited from within a drawing.

· You can apply a fill style or attribute to change the fill color and pattern of the object. In 
order to see the fill color and pattern of an object, there must be some empty space 
around the object within its border.

See also
Changing line color, weight, and pattern
Converting an object to Visio shapes
Editing an embedded Visio object in place
Formatting fills and shadows
Scaling, cropping, or panning an object
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Exporting a drawing into another file format

      Overview  

You can export specific shapes or a page from a Visio drawing into another document using 
the Save As command. When you use Save As to export a page, the Save As command does
not affect the current document.

To export shapes or a drawing to 
another file format:

1. To export a page, display the page you want to export.
To export specific shapes, select the shapes you want to export. (Use Shift+click to 
select more than one shape.)

2. From the File menu, choose Save As.
3. Under Save As, choose the format you want.
4. In the File Name box, type a filename for the file.
5. Click Save.

Visio exports the shapes or page in the format you chose. You can use the file in any 
program that can read files in that format.

Note: You can use Visio to convert a file from one format to another by importing the file 
into Visio and then exporting it to the format you want.

See also
Embedding Visio shapes in another document
Importing a file into a Visio drawing
Linking or embedding a drawing into another document





About using Lotus Notes with Visio

    Related procedures

To include a Visio drawing in Lotus Notes, you embed it as a record in the Lotus Notes 
database.
In addition, when you have a Visio drawing embedded in Lotus Notes, you can use Notes/FX, 
which allows Visio and Lotus Notes to pass data back and forth. You can:

Write information from a Visio shape, custom formula, or the Properties box to a Lotus 
Notes field.
For example, you can combine Lotus Notes and Visio to keep track of a company's 
processes, such as writing and prototyping specifications, and so on. To make this as 
easy to use as possible, in Lotus Notes, you embed a Visio diagram for each process. 
Then, you create a table that shows just the titles of the processes (which is data you 
wrote from Visio to Lotus Notes). Anyone who needs to see the process can click the 
flowchart's title to see the embedded Visio diagram. Then, to edit it, the user can double-
click the embedded Visio diagram to start Visio.
Read data from a Lotus Notes Field and display it in Visio. 
For example, in a timeline, you can have a Lotus Notes date field automatically update 
the Visio timeline. 

Note: Lotus Notes version 3.x uses OLE 1. Therefore, you cannot edit objects in place or 
dynamically pass data back and forth between Visio and Lotus Notes. In OLE 1, data is 
passed between programs when a program is exited or when you choose Update from the 
File menu.



Reading information from Lotus Notes and displaying it in Visio
Tips for using Lotus Notes with Visio
Writing information from Visio to Lotus Notes
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Writing information from Visio to Lotus Notes

      Overview  

You can pass data from a Visio diagram to a Lotus Notes database field. Each field in Lotus 
Notes that you want to fill in with Visio data is based on either the Visio diagram's Properties 
box, a shape, or a custom formula. 
Note: Make sure the fields in both programs have exactly the same name.

To write information from Visio to 
Lotus Notes:

1. In Lotus Notes, set up the fields you want to fill in with Visio data. Note the names of 
these fields, because you will use them in Visio.

2. In Visio, set up the drawing template.
3. If the Lotus Notes fields are not based on the diagram's Properties box, add the 

shapes that will be associated with the Lotus Notes fields.
4. Select one of the shapes that will be associated with a Lotus Notes field, then choose 

Special from the Format menu and note the shape's ID (you'll use it in step 9).
Complete this step for each shape that will be associated with a Lotus Notes field.

5. From the Insert menu, choose Lotus Notes Fields.
6. In the Field Name and Direction section, type a name for the field that exactly 

matches the name of the field you defined in Lotus Notes.
7. Check Write To Notes.
8. In the Data Type section, select the type of data you want to exchange: Text, Time, or

Number.



9. If you selected Text under Data Type, type the ID you got from step 4 in the Shape ID 
box. The data you write to Lotus Notes can be the shape's name, text entered in the 
shape, or data you entered for the shape in the Special box (on the Format menu).
If you selected Time or Number, enter a custom formula in the Custom Formula box. 
For details, see Using a custom formula in a field.

10. Click Add, then click OK.
To view the information in Lotus Notes, choose Exit from the Visio File menu. 

To write the Properties box 
information from Visio to Lotus Notes:

1. In Lotus Notes, use the field names from the Visio Properties box in the Lotus Notes 
database to automatically include that Visio information.
The Properties box fields are Title, Subject, Creator, Keywords, and Descriptions.

See also
Creating objects in another program from within Visio
Inserting fields into text
Reading information from Lotus Notes and displaying it in Visio
Tips for using Lotus Notes with Visio



Reading information from Lotus Notes and displaying it in Visio





Reading information from Lotus Notes and displaying it in Visio

      Overview  

You can read information from a Lotus Notes database field, then display it in a Visio 
diagram. You can also use the Lotus Notes field data in formulas.
Tip: You may want to lock the Visio shape in which you place information from Lotus Notes 
so that users cannot edit it.

To read information from Lotus Notes 
and display it in Visio:

1. In Lotus Notes, set up the fields you will read into Visio. Make sure you note the 
names of these fields, because you will use them in Visio.

2. In Visio, set up the drawing template.
3. From the Insert menu, choose Lotus Notes Fields.
4. In the Field Name and Direction section, type a name for the field that exactly 

matches the name of the field you defined in Lotus Notes.
5. Check Read From Notes.
6. In the Data Type section, select the type of data you want to exchange: Text, Time, or

Number.
For Number, choose the units for the number (such as inches) so that the user knows 
how to interpret the number. For example, a number might represent inches or 
centimeters; the distinction for the user may be very significant. 

7. Click Add, then click OK.
8. Follow one of the next procedures to either insert the Lotus Notes field in a shape as 

a field or insert it in a shape's ShapeSheet.



To insert a Lotus Notes field in a 
shape as a text field:

1. Add the shape in which you will insert the Lotus Notes data.
2. Select the shape.
3. Double-click the shape to open its text block, then place the insertion point where 

you want to insert the information.
4. From the Insert menu, choose Field. 
5. Under Category, select Lotus Notes Field. Under Field, select the specific Lotus Notes 

field. Under Format, select the way you want to view the data, then click OK.
Data is passed between Visio and Lotus Notes when the programs are started, so the 
next time you open this Visio drawing file, these fields will include data from the 
Lotus Notes fields you inserted.

To insert a Lotus Notes field into a 
shape's ShapeSheet:

1. From the Window menu, choose Show ShapeSheet. 
2. Select the cell in which you want to insert the Lotus Notes field.
3. Place the insertion point in the formula bar, then choose Function from the Insert 

menu. 
4. Under Select Function, choose LOTUSNOTES, then click OK. 
5. In the edit area, for "notename" type the name of the Lotus Notes field.

Data is passed between Visio and Lotus Notes when the programs are started, so the 
next time you open this Visio drawing file, the ShapeSheet will include data from 
Lotus Notes.



See also
Creating objects in another program from within Visio
Inserting fields into text
Protecting shapes
Tips for using Lotus Notes with Visio
Writing information from Visio to Lotus Notes
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Tips for using Lotus Notes with Visio

      Overview  

Tips for writing information from Visio to Lotus Notes
Any "Write To Notes" field can send back calculations. If you choose Number, then enter a 
formula in Custom Formula. In the following example, "sheet.1" is a office plan's walls. The 
office plan is set up in inches. The formula multiplies the width and height of the walls, then 
divides by 144 to get the square footage of the office.

=sheet.1!Width*sheet.1!Height/144"

Tips for reading information from Lotus Notes and displaying it in Visio
Any "Read From Notes" field can be used in a formula. For example, in an office planning 
Lotus Notes database, you can include the dimensions of each person's office. Then, in Visio,
you can include the Lotus Notes data in the walls shape formula to automatically size them 
to the exact dimensions entered in Lotus Notes.
In this example, the walls ShapeSheet would include the following information, where 
"width" and "height" are the names of the Lotus Notes fields.

Width LOTUSNOTES("width")
Height LOTUSNOTES("height")

When you do this, it's a good idea to protect the shape so that the user cannot resize it and 
erase the formula.

See also
Creating objects in another program from within Visio
Inserting fields into text
Protecting shapes
Reading information from Lotus Notes and displaying it in Visio
Writing information from Visio to Lotus Notes



 



 Visio Help Topics

Using Visio
Overviews and step-by-step 
procedures to help you complete 
tasks.
Drawing help
Step-by-step procedures for creating 
specific drawing types.
Reference
Commands and tools, keyboard 
shortcuts, and ShapeSheet reference.
Technical support
Customer service and technical 
support information.

Using Visio

Getting started with Visio
Adding and creating shapes
Modifying shapes
Arranging shapes
Formatting shapes
Working with text
Working with drawing pages
Printing
Using Visio with other programs
Creating master shapes, stencils, and templates
Working with the ShapeSheet
Using programs to control Visio



Using Visio

Getting started with Visio
Starting, quitting, and setting up Visio

Adding Visio files after installation
Making room on your hard disk
Quitting Visio
Starting Visio

Starting a drawing in Visio
Starting a new drawing with a template
Starting a new drawing without a template

Working with Visio files
Closing a file
Creating a file summary
Displaying a drawing file stencil
Opening a stencil
Opening a template to modify or copy it
Opening an existing drawing file
Protecting a file
Saving a file as read-only
Saving a file with the Workspace option
Saving a new drawing file
Saving changes to an open file

Arranging the Visio workplace
Arranging stencils
Arranging Visio windows
Displaying and arranging master shape icons
Getting quick access to common commands
Setting display options
Switching toolbar sets
Zooming in and out of a drawing

Adding and creating shapes
Modifying shapes
Arranging shapes
Formatting shapes
Working with text
Working with drawing pages
Printing
Using Visio with other programs
Creating master shapes, stencils, and templates
Working with the ShapeSheet
Using programs to control Visio



Using Visio

Getting started with Visio
Adding and creating shapes

Drag and drop drawing
Dragging and dropping connector shapes
Dragging and dropping master shapes

Drawing shapes
Closing a shape
Drawing ellipses and circles
Drawing freeform shapes
Drawing lines and arcs
Drawing rectangles and squares
Drawing shapes with several segments
Undoing segments while drawing
What is a shape?

Copying, duplicating, and deleting shapes
Copying shapes in the current drawing
Copying shapes to another drawing
Deleting shapes
Dragging shapes to another drawing
Stamping master shapes

Joining and fragmenting shapes
Combining shapes
Fragmenting shapes
Intersecting shapes
Subtracting shapes
Uniting shapes

Modifying shapes
Arranging shapes
Formatting shapes
Working with text
Working with drawing pages
Printing
Using Visio with other programs
Creating master shapes, stencils, and templates
Working with the ShapeSheet
Using programs to control Visio



Using Visio

Getting started with Visio
Adding and creating shapes
Modifying shapes

Sizing and reshaping shapes
Adding segments to shapes
Changing an arc's eccentricity
Changing shape angles by dragging a vertex
Changing the size of a 1-D shape
Changing the size of a 2-D shape
Deleting segments from shapes
Reshaping arcs

Grouping shapes
Adding and removing shapes in groups
Editing and formatting a group
Editing the shapes in a group
Formatting and adding text to a shape in a group
Grouping and ungrouping shapes
Setting a group's sizing behavior
Updating a group's selection rectangle

Changing shape behavior
Changing 1-D and 2-D behavior
Creating a nonprinting shape
Protecting shapes
Setting shape display options
Specifying a shape's double-click behavior
Working with control handles

Arranging shapes
Formatting shapes
Working with text
Working with drawing pages
Printing
Using Visio with other programs
Creating master shapes, stencils, and templates
Working with the ShapeSheet
Using programs to control Visio



Using Visio

Getting started with Visio
Adding and creating shapes
Modifying shapes
Arranging shapes

Selecting and moving shapes
Changing the snap strength
Changing the stacking order of shapes
Flipping and reversing shapes
Moving a 2-D shape's center of rotation
Moving shapes by dragging
Rotating shapes by 90-degree increments
Rotating shapes with the rotation tool
Selecting shapes
Snapping shapes into place

Aligning and distributing shapes
Aligning shapes to guides
Aligning shapes to other shapes
Aligning shapes to rulers
Aligning the centers of shapes
Centering a drawing on the page
Creating guide points
Creating guides
Distributing shapes

Techniques for connecting shapes
Connecting a series of shapes automatically
Connecting shapes quickly in a flowchart
Connecting shapes with the stamp tool
Gluing shapes to guides
Moving shapes after you glue them
Quickly creating an organization chart and similar drawings
Using the connector tool to connect two shapes

Adjusting connectors and glue settings
Adjusting the bends in a Universal connector
Converting the glue
Creating and deleting connection points
Displaying connection points
Formatting connector shapes
Setting glue options

Determining a shape's size and location
Determining a 1-D shape's size and location
Determining a 2-D shape's size and location

Formatting shapes
Working with text
Working with drawing pages
Printing
Using Visio with other programs
Creating master shapes, stencils, and templates
Working with the ShapeSheet
Using programs to control Visio



Using Visio

Getting started with Visio
Adding and creating shapes
Modifying shapes
Arranging shapes
Formatting shapes

Understanding local formatting and styles
Applying formats to shapes

Changing line color, weight, and pattern
Changing the shadow offset
Choosing a color palette
Copying and applying shape formatting
Creating a transparent shape
Creating dashed lines
Creating line ends
Creating patterned fills and shadows
Creating round corners
Formatting fills and shadows
Removing shape borders

Using styles
Applying styles from a style list
Applying styles from the Style dialog box
Protecting local formatting
Reverting to a master shape's styles

Editing and creating styles
Creating a style
Deleting a style
Editing a style
Renaming a style

Working with text
Working with drawing pages
Printing
Using Visio with other programs
Creating master shapes, stencils, and templates
Working with the ShapeSheet
Using programs to control Visio



Using Visio

Getting started with Visio
Adding and creating shapes
Modifying shapes
Arranging shapes
Formatting shapes
Working with text

Adding and editing text
Adding and replacing text
Adding independent text to a drawing
Checking the spelling of text
Cutting, copying, and pasting text
Deleting text
Searching and replacing text
Selecting text
Typing special characters
Typing text into shapes

Selecting, sizing, and moving text blocks
Moving a text block
Rotating a text block
Selecting a text block
Sizing a text block

Formatting text
Adding and deleting tabs
Aligning and indenting paragraphs
Aligning text in the text block
Changing font attributes
Setting line spacing
Setting text block margins
Setting the text block background color

Using fields
Inserting fields into text
Using a custom formula in a field

Working with drawing pages
Printing
Using Visio with other programs
Creating master shapes, stencils, and templates
Working with the ShapeSheet
Using programs to control Visio



Using Visio

Getting started with Visio
Adding and creating shapes
Modifying shapes
Arranging shapes
Formatting shapes
Working with text
Working with drawing pages

About layers
Adding layers
Assigning a shape to a layer
Deleting layers
Renaming layers
Setting options for layers
Setting shapes on a layer to appear in a color
Viewing layers

Working with pages and their backgrounds
Assigning and canceling a background page
Creating a background page
Creating a new page
Deleting a page
Displaying pages
Modifying a background page
Rearranging foreground pages
Setting page display options
Switching to a background page

Taking an inventory of your drawing
Adjusting the data format
Associating data with shapes
Choosing inventory content
Generating an inventory
Performing calculations on shape properties

Changing the page size and drawing scale
Changing the drawing page and print settings together
Changing the size of the drawing page
Setting a drawing scale

Printing
Using Visio with other programs
Creating master shapes, stencils, and templates
Working with the ShapeSheet
Using programs to control Visio



Using Visio

Getting started with Visio
Adding and creating shapes
Modifying shapes
Arranging shapes
Formatting shapes
Working with text
Working with drawing pages
Printing

Printing drawings
Choosing a printer
Editing a drawing while in Print Preview
Previewing a drawing before you print
Printing a background page
Printing a drawing to a file
Printing a drawing
Printing a page without its background
Printing color drawings on monochrome printers
Printing layers
Showing page breaks

Making printing adjustments
Reducing or enlarging a drawing for printing
Setting margins
Tiling a large drawing onto multiple sheets of paper

Using Visio with other programs
Creating master shapes, stencils, and templates
Working with the ShapeSheet
Using programs to control Visio



Using Visio

Getting started with Visio
Adding and creating shapes
Modifying shapes
Arranging shapes
Formatting shapes
Working with text
Working with drawing pages
Printing
Using Visio with other programs

Importing, exporting, linking, and embedding overview
Understanding linking and embedding

Creating objects in another program from within Visio
Dragging and dropping a Visio object into other programs
Editing an embedded Visio object in place
Embedding Visio shapes in another document
Linking or embedding a drawing into another document
Linking or embedding a larger area of the drawing
Linking or embedding an object into a Visio drawing
Sending Visio drawings through electronic mail

Managing links
Breaking links
Viewing and updating links

Importing and exporting
Converting an object to Visio shapes
Editing an object from another program
Exporting a drawing into another file format
Formatting an object from another program
Importing a file into a Visio drawing
Pasting information in a particular format
Scaling, cropping, or panning an object

About using Lotus Notes with Visio
Reading information from Lotus Notes and displaying it in Visio
Tips for using Lotus Notes with Visio
Writing information from Visio to Lotus Notes

Creating master shapes, stencils, and templates
Working with the ShapeSheet
Using programs to control Visio



Using Visio

Getting started with Visio
Adding and creating shapes
Modifying shapes
Arranging shapes
Formatting shapes
Working with text
Working with drawing pages
Printing
Using Visio with other programs
Creating master shapes, stencils, and templates

Creating your own templates
Creating a template
Editing a template file

Working with stencils
Arranging master shapes in a stencil
Creating a new stencil
Deleting a master shape from a stencil
Opening an original stencil
Saving a drawing file stencil as a stand-alone stencil

Creating and editing master shapes
Changing the text attributes of a master shape
Creating a master shape from a shape in a drawing
Creating a master shape from scratch
Editing a master shape in a stand-alone stencil
Editing a master shape in the drawing file stencil
Specifying master shape characteristics

Working with master shape icons
Changing the colors for a master shape icon
Creating a master shape icon
Editing parts of a master shape icon
Updating master shape icons

Working with the ShapeSheet
Using programs to control Visio



Using Visio

Getting started with Visio
Adding and creating shapes
Modifying shapes
Arranging shapes
Formatting shapes
Working with text
Working with drawing pages
Printing
Using Visio with other programs
Creating master shapes, stencils, and templates
Working with the ShapeSheet

Understanding ShapeSheets
Adding and deleting rows
Adding and deleting sections
Collapsing and expanding sections
Displaying a ShapeSheet
Displaying values and formulas in cells
Moving around the ShapeSheet
Showing and hiding sections

Working with formulas
Building a formula by pasting
Copying and pasting formulas between cells
Creating formulas
Editing formulas
Using inherited formulas

Using programs to control Visio



Using Visio

Getting started with Visio
Adding and creating shapes
Modifying shapes
Arranging shapes
Formatting shapes
Working with text
Working with drawing pages
Printing
Using Visio with other programs
Creating master shapes, stencils, and templates
Working with the ShapeSheet
Using programs to control Visio

Visio and OLE Automation
Running add-ons
Viewing a sample program



Reference

Screen elements
Keyboard shortcuts
Developer reference



Reference

Screen elements
Commands and tools (alphabetical list)
Drawing window
Edit icon window
Group window
Print preview window
ShapeSheet window
Stencil window
Visio main window

Keyboard shortcuts
Developer reference



Reference

Screen elements
Keyboard shortcuts

ANSI extended characters
Command shortcuts
Drawing tools
Special characters

Developer reference



Reference

Screen elements
Keyboard shortcuts
Developer reference

ShapeSheets
Functions



Using Visio Help

To display the Contents for the Visio online Help, click the Contents button. For information 
about accessing help on specific shapes, see Getting help on shapes.

Help windows
Visio online Help contains these windows (each window has the bold name below in its title 
bar):
· Visio 4.0 Online Help, the main help window, displays contents, alphabetical lists, and 

reference topics.
· Step-by-step procedures displays procedures in a window designed to stay on top of 

the Visio window, so you can follow the numbered steps while working in Visio.
· Glossary includes a list of terms that display a definition when clicked. The glossary 

terms are also defined throughout the help.

ToolTips
When you pause with the pointer (without the mouse button pressed) over either an item on
the toolbar or a master shape icon when the stencil window is set to display icons only, a 
ToolTip appears.
Shapes with control handles have control handle help: select the shape, then place the 
pointer over the control handles to display the handle's ToolTips.
To turn off ToolTips, choose the Toolbars command on the View menu, and then uncheck the 
Show ToolTips option.

Searching
To search for a particular term:
· In the help Contents tab, click the Index tab and follow the instructions.

Scrolling
Some help topics contain more information than can fit in the help window at one time. To 
see more information, scroll through the topic in the help window.
To scroll in the help window:
· Press the Up Arrow () or Down Arrow (¯) key

or
· Use the scroll bars with the mouse.
To return to the previous topic:
· Click the Back button or press the B key.
To browse through topics:
· Click the << and >> buttons or press the < and > keys.

Exiting help
To close the help window:
· From the help window's File menu (not Visio's), choose Exit.



Context-sensitive help
While working in Visio, you can access help at your fingertips for menu commands, dialog 
boxes, toolbar buttons, and other screen elements.

To display help for a toolbar button or
other screen element:

1. Choose the Help button on the toolbar and click anywhere on the screen.

    Help button

To display help for a menu command:
1. Highlight the menu command using the keyboard (press the Alt key followed by the 

underlined letter in the menu name, and then press the arrow keys to highlight the 
command).

2. Press F1.

To display help for a dialog box:



1. Choose a menu command that opens a dialog box.
2. Press F1 or choose the Help button.

For additional instructions on how to use help, press F1, or choose How To Use Help from the 
Help menu (while the help window is active).



Getting help on shapes

You can quickly find out what a shape does and how you can use it.

To get help on shapes:
1. Right-click the shape (on the stencil or on the drawing page).
2. Choose Shape Help from the shortcut menu.

A popup window appears containing information about the shape.
3. To close Shape Help, click away from the popup window.
4. To print or copy the information, right-click inside the popup window, then choose 

Copy or Print Topic from the shortcut menu.

Tip: Shapes with control handles have control handle help: select the shape, then place the 
pointer over the control handles to display the handle's ToolTips.



These topics were added as a workaround for the Aftermarket Shapes 
product help. They're duplicates of topics found in us_prsx.doc. See the @ 
comment to see the procedure name if it's different than the one in this file.



Getting started with Visio

Starting Visio
To start Visio:
· In Windows 95, click Start, choose Programs, then choose Visio. 
· In Windows 3.1, double-click the Visio icon in Program Manager to start Visio.
The New dialog box appears, where you can choose to start with either a template or a 
Wizard. When you start with a template, Visio opens a stencil and a new drawing file and 
copies styles and other settings to the file. 

Quitting Visio
When you finish working in Visio, quit Visio before you quit Windows. If an unsaved file is 
open when you quit Visio, Visio prompts you to save the file before quitting.

Changing the Visio setup
After you install Visio, you might need to change the way Visio is set up on the computer.
You can use the Visio setup to:
· Install Visio files that you have not installed previously.
· Reinstall files that you have deleted.
· Restore template and stencil files that have been changed accidentally.
If you need to make room on your hard disk, you can also remove some Visio files to 
increase disk space.



Starting a new drawing based on a template

You can start Visio and open a new drawing file based on a template provided with Visio. 
When Visio is running, you can open new drawing files by using the New command on the 
File menu.

To open a new drawing file based on a
template:

1. From the File menu, choose New.
You can also use the New button.

2. In the New section, make sure Drawing is checked.
3. From the Based On list, choose a template or a Wizard.
4. If the template file you need is not listed, choose the Open button and locate the file.
5. Click OK.



Starting a new drawing without a template

To create a drawing without a 
template:

1. From the File menu, choose New.
You can also use the New button.

2. In the New section, make sure Drawing is checked.
3. From the Based On list, choose No Template.
4. Click OK.



Opening a template

You can open an original template file to make changes to the template settings. If you want 
to make changes to a template and preserve the original settings, you can open and edit a 
copy of a template.

To edit a template file:
1. From the File menu, choose Open.
2. In the File Name box, type or choose the template file you want to open.

If you don't see the filename, choose Templates (.VST) from the Save As list, or choose 
a different folder.

3. In the Open section, choose Original to open the original template, or choose Copy to 
open a copy of the template.

4. Click OK.
5. Change settings and options for the template, such as styles, drawing scale, and 

page display options.
6. From the File menu, choose Save.

You can also click the Save button.



Opening a stencil

If you want to use shapes from several stencils in a drawing, you can open stencil files 
without opening a template.

To open a stencil:
1. From the File menu, choose Stencils.

You can also use the Stencils button.
2. From the Select Stencil list, choose the name of the stencil you want to open.

If you don't see the stencil name, click Browse and locate the stencil file you need. 
(You may need to open the Stencils folder.) 

3. When you've located the file, click OK.



Saving a drawing file

To save a new file:
1. From the File menu, choose Save or Save As.
2. In the File Name box, type a filename for the drawing file.
3. Under Save In, open the folder where you want to save the file.
4. If you want to save a workspace, make sure Workspace is checked in the Save 

section.
5. If necessary, choose a file format from the Save As list.

For example, you can save a Visio 4.0 drawing file in Visio 3.0 or 2.0 format by 
choosing Visio 3 or 2 drawing (*.VSD) from the List.

6. Click Save.
7. If necessary, enter property information, then click OK to close the Properties dialog 

box.



Arranging Visio windows

By default, the Visio main window usually contains a drawing page and one or more stencils.
You can undock stencils to make them float. 
If you have more than one drawing open, you can arrange and resize the windows to see 
them all.

To arrange windows so each window 
is visible:

1. From the Window menu, choose Tile.

To arrange windows to see the title 
bar of each window:

1. From the Window menu, choose Cascade.



To size a window:
1. Drag a window border.

Tip: For details about other ways to arrange windows, see your Windows documentation.



Dragging and dropping master shapes

The easiest way to create a drawing is to drag master shapes from stencils and drop them 
into drawings.

To drag a master shape into a 
drawing:

1. From the toolbar, choose the pointer tool.
2. In the stencil window, point to the icon for the master shape.
3. Hold down the left mouse button and drag the master shape from the stencil to the 

drawing page.
4. Release the mouse button to drop an instance of the master shape in the drawing.



 



 Functions

Alphabetical list of functions
Mathematical functions
ABS(number)
CEILING(number,multiple)
FLOOR(number,multiple)
INT(number)
INTUP(number)
LN(number)
LOG10(number)
MOD(number,divisor)
MODULUS(number,divisor)
PI( )
POW(number,exponent)
RAND( )
ROUND(number,number-of-digits)
SIGN(number,fuzz)
SQRT(number)
SUM(number1,number2...number14)
TRUNC(number,number-of-digits)
Trigonometric functions
ACOS(number)
ANG360(angle)
ASIN(number)
ATAN(number)
ATAN2(y,x)
COS(angle)
COSH(angle)
DEG(angle)
LOC(point)
PAR(point)
PNT(x,y)
PNTX(point)
PNTY(point)
RAD(angle)
SIN(angle)
SINH(angle)
TAN(angle)
TANH(angle)
Window management functions
GOTOPAGE("pagename")
OPENFILE("filename")
OPENGROUPWIN( )
OPENPAGE("pagename")
OPENSHEETWIN( )
OPENTEXTWIN( )
Logical functions
AND(logical-expression1,logical-expression2,...)
BITAND(binary-number1,binary-number2)
BITNOT(binary-number)
BITOR(binary-number1,binary-number2)



BITXOR(binary-number1,binary-number2)
IF(logical-expression,value-if-true,value-if-false)
ISERR
ISERRNA
ISERROR
ISERRVALUE
NOT(logical-expression)
OR(logical-expression1,logical-expression2,...)
Date and time functions
DATE(year,month,day)
NOW( )
TIME(hour,minute,second)
Statistical functions
MAX(number1,number2,...)
MIN(number1,number2,...)
Text functions
CHAR(number)
EVALTEXT(shapename!TheText)
FORMAT(expression,"format")
TEXTHEIGHT(theText,maximum-width)
TEXTWIDTH(theText,maximum-width)
Miscellaneous functions
DEFAULTEVENT( )
DEPENDSON(cellref[,cellref2,...])
DOOLEVERB("verb")
GRAVITY(angle,limit1,limit2)
GUARD(expression)
HELP("filename.hlp!keyword")
INDEX(index,list[,[delimiter][,[error-value]]])
LOOKUP(key,list[,delimiter])
LOTUSNOTES(field)
MAGNITUDE(constantA,A,constantB,B)
NA( )
PLAYSOUND("filename"|"alias",isAlias,doBeepOnFail,synch)
RECTSECT(width,height,x,y,option)
REF( )
RUNADDON("filename")
RUNADDONWARGS("filename",ARG1[,ARG2])
SETF("cell",formula)
USERUI(state,default-expression,user-expression)



 Alphabetical list of functions
Click a letter to search for a function

A
ABS(number)
ACOS(number)
AND(logical-expression1,logical-expression2,...)
ANG360(angle)
ASIN(number)
ATAN(number)
ATAN2(y,x)

B
BITAND(binary-number1,binary-number2)
BITNOT(binary-number)
BITOR(binary-number1,binary-number2)
BITXOR(binary-number1,binary-number2)

C
CEILING(number,multiple)
CHAR(number)
COS(angle)
COSH(angle)

D
DATE(year,month,day)
DEFAULTEVENT( )
DEG(angle)
DEPENDSON(cellref,cellref2,...)
DOOLEVERB("verb")

E
EVALTEXT(shape!TheText)

F
FLOOR(number,multiple)
FORMAT(expression,"format")

G
GOTOPAGE("pagename")
GRAVITY(angle,limit1,limit2)
GUARD(expression)

H
HELP("filename.hlp!keyword")

I
IF(logical-expression,value-if-true,value-if-false)
INDEX(index,list[,[delimiter][,[error-value]]])
INT(number)



INTUP(number)
ISERR(cellref)
ISERRNA(cellref)
ISERROR(cellref)
ISERRVALUE(cellref)

L
LN(number)
LOC(point)
LOG10(number)
LOOKUP(key,list[,delimiter])
LOTUSNOTES(field)

M
MAGNITUDE(constantA,A,constantB,B)
MAX(number1,number2,...)
MIN(number1,number2,...)
MOD(number,divisor)
MODULUS(number,divisor)

N
NA( )
NOT(logical-expression)
NOW( )

O
OPENFILE("filename")
OPENGROUPWIN( )
OPENPAGE("pagename")
OPENSHEETWIN( )
OPENTEXTWIN( )
OR(logical-expression1,logical-expression2,...)

P
PAR(point)
PI( )
PLAYSOUND("filename"|"alias",isAlias,beep,synch)
PNT(x,y)
PNTX(point)
PNTY(point)
POW(number,exponent)

R
RAD(angle)
RAND( )
RECTSECT(width,height,x,y,option)
REF( )
ROUND(number,number-of-digits)
RUNADDON("filename")
RUNADDONWARGS("filename",ARG1,ARG2)

S
SETF("cell",formula)
SIGN(number,fuzz)



SIN(angle)
SINH(angle)
SQRT(number)
SUM(number1,number2,...number14)

T
TAN(angle)
TANH(angle)
TEXTHEIGHT(theText,maximum-width)
TEXTWIDTH(theText,maximum-width)
TIME(hour,minute,second)
TRUNC(number,number-of-digits)

U
USERUI(state,default-expression,user-expression)



 ABS

Syntax ABS(number)
Returns the absolute value of number.
Example ABS(-1.24)
Returns 1.24.

See also
INT



 AND

Syntax AND(logical-expression1,logical-expression2,...,logical expression14)
Returns 1 if all of the logical expressions supplied are true. (Any expression that evaluates
to a non-zero value is considered to be true.) If any of the logical expressions are false or 
equal 0, AND returns 0.
Example AND(Height > 1,PinX > 1)
Returns 1 if both expressions are true. Returns 0 if either expression is false.

See also 
NOT
OR



 ANG360

Syntax ANG360(angle)
Normalizes an angle's range to be 0 <= result < 2PI radians (0 <= result < 360 deg.). If 
angle is not specified using angular units, it is interpreted as radians. If angle cannot be 
converted to a value, a #VALUE! error is returned.
Examples ANG360(395 deg.) equals 35 deg.

ANG360(-9.8 rad.) equals 2.7664 rad.
ANG360(45) equals 58.31 deg. (1.0177 rad.)

See also
MODULUS
ROUND



 ACOS

Syntax ACOS(number)
Returns the arccosine of number; for example, the angle whose cosine is number. The 
input value must be in the range -1 <= number <= 1, or a #NUM! error is returned. The 
resulting angle is in the range 0 <= angle <= PI radians (0 <= angle <= 180 degrees).
Example ACOS(0) equals 90 deg.

See also
ASIN
ATAN
ATAN2
COS
PI



 ASIN

Syntax ASIN(number)
Returns the arcsine of number; for example, the angle whose sine is number. The input 
value must be in the range -1 <= number <= 1, or a #NUM! error is returned. The resulting 
angle is in the range -PI/2 <= angle <= PI/2 radians (-90 <= angle <= 90 degrees).
Example ASIN(1) equals 90 deg.

See also
ACOS
ATAN
ATAN2
PI
SIN



 ATAN

Syntax ATAN(number)
Returns the arctangent of number; for example, the angle whose tangent is number. The 
resulting angle is in the range -PI/2 <= angle <= PI/2 radians (-90 <= angle <= 90 
degrees).
Example ATAN(1) equals 45 deg.

See also
ACOS
ASIN
ATAN2
PI
TAN



 ATAN2

Syntax ATAN2(y,x)
Returns the arctangent of the point represented by x and y. The result is a number in the 
current unit of measure for angles. 
The arctangent is the angle measured counterclockwise from the positive x-axis to a line 
that intersects the origin (0,0) and the point represented by x and y. In Visio, ATAN2(0,0) 
returns 0. To force the result of ATAN2 into a different angular measurement, use DEG or 
RAD.
The ATAN2 function is the antifunction of the TAN function. ATAN2 returns the angle whose 
angle is equal to y divided by x. If ATAN2(y,x) represents an angle in a right triangle, then y 
is the proverbial "opposite side" and x is the "adjacent side," so the function could be 
written as ATAN2(opposite,adjacent).
Example 1 ATAN2(1.25,2.25)
Returns 29.0456 degrees.
Example 2 ATAN2(1,SQRT(3))
Returns 30 degrees.
Example 3 ATAN2(1,1)
Returns 45 degrees.

See also 
ATAN
PI
TAN



 BITAND

Syntax BITAND(binary-number1,binary-number2)
Returns a binary number in which each bit is set to 1 only if the corresponding bit in both 
binary-number1 and binary-number2 is 1. Otherwise the bit is set to 0. This function can 
be used to test and change properties of a shape that are stored as bit masks, for example, 
the shape's text format.
Example BITAND(12,6)
Returns 4. The 12 = 0...01100. The 6 = 0...00110. Therefore BITAND(12,6) = 0...00100.

See also 
BITNOT
BITOR
BITXOR



 BITNOT

Syntax BITNOT(binary-number)
Returns a binary number in which each bit is set to 1 only if the corresponding bit in binary-
number is 0; otherwise the bit is set to 0.
Example BITNOT(6)
Returns 65529. The 6 = 0...00110. Therefore BITNOT(6) = 1...11001.

See also
BITAND
BITOR
BITXOR



 BITOR

Syntax BITOR(binary-number1,binary-number2)
Returns a binary number in which each bit is set to 1 if the corresponding bit in either 
binary-number1 or binary-number2 is 1. The bit is set to 0 only if the corresponding bit is
0 in both binary-number1 and binary-number2.
Example BITOR(12,6)
Returns 14. The 12 = 0...01100. The 6 = 0...00110. Therefore BITOR(12,6) = 0...01110.

See also
BITAND
BITNOT
BITXOR



 BITXOR

Syntax BITXOR(binary-number1,binary-number2)
Returns a binary number in which each bit is set to 1 if the corresponding bit in either but 
not both binary-number1 and binary-number2 is 1. Otherwise the bit is set to 0.
Example BITXOR(12,6)
Returns 10. The 12 = 0...01100. The 6 = 0...00110. Therefore BITXOR(12,6) = 0...01010.

See also 
BITAND
BITNOT
BITXOR



 CEILING

Syntax CEILING(number,multiple)
Rounds number away from zero or to the next instance of multiple. If multiple is not 
specified, the number rounds away from zero to the next integer.
Number and multiple must have the same signs or a #NUM! error is returned. If either 
number or multiple cannot be converted to a value, a #VALUE! error is returned. If either 
number or multiple is zero, the result is zero.
Examples CEILING(3.7) equals 4.

CEILING(-3.7) equals -4.
CEILING(3.7, 0.5) equals 4.

See also
FLOOR
INT
INTUP
ROUND



 CHAR

Syntax CHAR(number)
Returns the ANSI character for number.
The resulting string is one character in length. The number must be an integer between 1 
and 255 (inclusive), or the function returns an error.
Example CHAR(9)
Returns the tab character.

See also
FORMAT



 COS

Syntax COS(angle)
Returns the cosine of angle. Uses radians unless a unit of measure is specified with angle.
Example COS(45 degrees)
Returns 0.7071.

See also 
ACOS
COSH
PI
SIN



 COSH

Syntax COSH(angle)
Returns the hyperbolic cosine of angle. Uses radians unless a unit of measure is specified 
with angle.
Example COSH(45 degrees)
Returns 1.3246.

See also 
COS
PI
SINH



 DATE

Syntax DATE(year,month,day)
Returns the date represented by year, month, and day as a single numeric value.
Example DATE(1995,6,7)
Returns 34857.

See also 
NOW
TIME



DEFAULTEVENT

Syntax DEFAULTEVENT( )
Performs the default event associated with the object.
Object Default event
Shape Edit text
Group Open group editing window
OLE Do primary verb
Other Do nothing
In earlier versions of Visio, this function appears as _DEFAULTEVENT. Visio 4.0 accepts either 
style.



 DEG

Syntax DEG(angle)
Converts the value of angle from radians to degrees.
Example DEG(PI( )/4)
Returns 45.

See also 
RAD



DEPENDSON

Syntax DEPENDSON(cellref[,cellref2,...])
Creates a cell reference dependency. This function always returns FALSE. DEPENDSON has 
no effect when used in an Event row or an Action cell.
Example OpenTextWin() + DependsOn(PinX,PinY)
Opens the text block for a shape whenever the shape is moved.



DOOLEVERB

Syntax DOOLEVERB("verb")
Executes a verb for the OLE object.
Example DOOLEVERB("edit")
Runs the OLE object program and displays the linked or embedded object so that it can be 
edited.
In earlier versions of Visio, this function appears as _DOOLEVERB. Visio 4.0 accepts either 
style.



EVALTEXT

Syntax EVALTEXT(shapename!theText)
Evaluates the text in shapename as if it were a formula and returns the result. If there is no
text, the result is zero. If the text cannot be evaluated, returns an error.
TheText is a cell that refers to all of the text contained in a shape's text block. Shapename! 
can be used to refer to the text of a shape other than the current shape. 
Example EVALTEXT(Line.2!theText)
Evaluates the text contained in the shape Line.2. For example, if Line.2 contains "4 ft. + 0.5 
ft.", returns the value 4.5 ft.

See also 
TEXTHEIGHT
TEXTWIDTH



 FLOOR

Syntax FLOOR(number,multiple)
Rounds number toward zero or to the next instance of multiple. If multiple is not 
specified, the number rounds toward zero to the next integer.
Number and multiple must have the same signs or a #NUM! error is returned. If either 
number or multiple cannot be converted to a value, a #VALUE! error is returned. If either 
number or multiple is zero, the result is zero.
Examples FLOOR(3.7) equals 3.

FLOOR(-3.7) equals -3.
FLOOR(3.7, 0.5) equals 3.5.

See also
CEILING
INT
INTUP
ROUND



FORMAT

Syntax FORMAT(expression,"format")
Returns the result of expression as a string formatted according to format. The type of the
expression and the type specified in the format code govern the behavior of the returned 
string. The format must be appropriate for the type of expression.
Returns an error if the result of expression and the type expected in format are of a 
different kind or if there are syntax errors in format.
The following codes are valid for format:

# 0 (zero) . (period)
, (comma) E- E+ e- e+ "text"
'text' / (fraction) / (date)
u or U uu or UU uuu or UUU
$ space \ 

(backslash)
: (colon) @ d
dd ddd or w dddd or ww
ddddd dddddd M
MM MMM MMMM
yy yyyy h
hh H HH
m mm s
ss t tt
T

Example FORMAT(1 deg. 2 min. 3.2 sec.,"0.## u") displays 1 ° 2 ' 3 ".
FORMAT(0ft. 8.67in.," # #/#") displays 8 2/3.
FORMAT(0ft. 11.25in.,"0.000 UU") displays 0 FEET 11.250 INCHES.



GOTOPAGE

Syntax GOTOPAGE("pagename")
Displays pagename in the currently active window. If a window is already displaying 
pagename, that window becomes active. If pagename does not exist, or if Visio is acting 
as an in-place server, GOTOPAGE has no effect.
In earlier versions of Visio, this function appears as _GOTOPAGE. Visio 4.0 accepts either 
style.

See also
OPENPAGE



 GRAVITY

Syntax GRAVITY(angle,limit1,limit2)
Calculates the text block's correct angle of rotation for the indicated shape rotation¾it 
prevents the text from turning upside-down. GRAVITY is usually used in the TxtAngle cell in 
the ShapeSheet. The value returned is 180 degrees if angle is between the angles specified 
by limit1 and limit2; otherwise the value returned is 0 degrees. The arguments limit1 and 
limit2 are optional, and the default limits are 90 and 270 degrees.
All of the arguments are automatically normalized between zero and 360 degrees by the 
function. If an argument does not specify units, radians are assumed.
Examples GRAVITY(Angle) returns 180 degrees if Angle is between 90 and 270 degrees; 

otherwise, returns 0 degrees.
GRAVITY(2) returns 180 degrees, since 2 radians is between 90 and 270 
degrees.
GRAVITY(100 deg., 110 deg., 290 deg.) returns 0 deg.
GRAVITY(100 deg., 290 deg., 110 deg.) returns 0 deg.



 GUARD

Syntax GUARD(expression)
Protects expression from deletion and change by actions performed in the drawing window,
for example, moving, sizing, grouping, or ungrouping shapes. The cells most often affected 
are Width, Height, PinX, and PinY. 
Guarding a formula in any cell prevents that cell's value from being changed by actions in 
the drawing window. However, one action in the drawing window can affect several cells, 
and each of these cells must be guarded if you want to prevent unexpected changes to the 
shape's appearance. This function cannot protect an expression in a formatting cell such as 
Char.Size from change when a user applies a style.
Example GUARD(TEXTWIDTH(theText) + 0.5 in)
This expression in the Width cell of a shape's Geometry section prevents the expression 
(TEXTWIDTH(theText) + 0.5 in) from being replaced with another value when the shape's 
width is changed in the drawing window. TheText is a Visio page formula that refers to all of 
the text contained in a shape's text block.



HELP

Syntax HELP("filename.hlp!keyword")
HELP("filename.hlp!#number")

Opens the help file filename.hlp and displays the Search dialog box with the selected 
keyword. Or displays the help topic associated with number, a numeric ID referenced in 
the MAP section of the help project file (.HPJ). For information on developing Microsoft 
Windows online Help, see the Microsoft Windows Software Development Kit (SDK) 
documentation.
If no keyword or ID is specified, opens the contents page of the help file.
Example 1 HELP("visio.hlp!shapesheet")
Opens the file VISIO.HLP and displays the topic whose keyword is shapesheet.
Example 2 HELP("shape.hlp!#9000")
Opens the file SHAPE.HLP and displays the topic associated with the ID 9000.



 IF

Syntax IF(logical-expression,value-if-true,value-if-false)
Returns value-if-true if logical-expression is true. Otherwise, returns value-if-false.
Example IF(Height > 1.25 in.,5,7)
Returns 5 if the shape's height is greater than 1.25 inches. Returns 7 if the shape's height is 
less than or equal to 1.25 inches.

See also 
NOT
OR



INDEX

Syntax INDEX(index,"list"[,[delimiter][,[error-value]]])
Returns the substring at the zero-based location index in the list delimited by delimiter. Or
returns -1 if not found.
Delimiters can be more than one character in length and include multibyte characters. The 
default is a semicolon. If the list begins or ends with a delimiter, a null string is assumed to 
exist before or after the list. Consecutive delimiters imply a null string in between.
If the index is out of range, Visio returns an empty string or the optional token provided as 
the error-value argument.
Example 1 INDEX(3,"cat;rat;;goat")
Returns "goat".
Example 2 INDEX(4,";1;2;3;",,"ERROR")
Returns ERROR.

See also
LOOKUP



 INTUP

Syntax INTUP(number)
Rounds number up to the next integer.
Examples INTUP(3.2) equals 4.

INTUP(-3.2) equals -3.
INTUP(3) equals 3.

See also
CEILING
FLOOR
INT
ROUND



 INT

Syntax INT(number)
Rounds number down to the next integer.
Example 1 INT(7.2)
Returns 7.
Example 2 INT(-7.2)
Returns -8.

See also 
ABS
CEILING
FLOOR
INTUP
ROUND



 ISERR

Syntax ISERR(cellref)
Returns TRUE if the value of cellref is any error type except #N/A; otherwise returns FALSE.
The ISERR function is used in formulas that refer to another cell.

Example 1
Cell Formula Value Returned
 Scratch.A1 =NA( ) #N/A!
Scratch.B1 =ISERR(Scratch.A1) FALSE

Returns FALSE because the #N/A! error is not recognized by the ISERR function. Use 
ISERROR to find all error types.

Example 2
Cell Formula Value Returned
 Scratch.X1 ="House" #VALUE!
Scratch.A1 =ISERR(Scratch.X1) TRUE

Returns TRUE because the #VALUE! error is recognized by the ISERR function.

See also
Cell reference syntax
Error values
ISERRNA
ISERROR
ISERRVALUE



 ISERRNA

Syntax ISERRNA(cellref)
Returns TRUE if the value of cellref is error type #N/A! (not available); otherwise returns 
FALSE.
The ISERRNA function is used in formulas that refer to another cell.

Example

Cell Formula Value Returned
Scratch.A1 ="5 + 3" "8"
Scratch.B1 =ISERRNA(Scratch.A1) FALSE

Returns FALSE because the value returned is available.

Cell Formula Value Returned
Scratch.A1 =NA( ) #N/A!
Scratch.B1 =ISERRNA(Scratch.A1) TRUE

Returns TRUE because the value returned is error type #N/A!

See also
Cell reference syntax
Error values
ISERR
ISERROR
ISERRVALUE



 ISERROR

Syntax ISERROR(cellref)
Returns TRUE if the value of cellref is any error type; otherwise returns FALSE.
The ISERROR function is used in formulas that refer to another cell.

Example 1
Cell Formula Value Returned
 Scratch.A1 =NA( ) #N/A!
Scratch.B1 =ISERROR(Scratch.A1) TRUE

Returns TRUE because the #N/A! error is recognized by the ISERROR function. You can use 
ISERR to find all types but the #N/A! error. 

Example 2
Cell Formula Value Returned
 Scratch.X1 ="House" #VALUE!
Scratch.B1 =ISERR(Scratch.X1) TRUE

Returns TRUE because the #VALUE! error is recognized by the ISERROR function. To build an 
expression based on the #VALUE! error, use the ISERRVALUE function.

See also
Cell reference syntax
Error values
ISERR
ISERRNA
ISERRVALUE



 ISERRVALUE

Syntax ISERRVALUE(cellref)
Returns TRUE if the value of cellref is error type #VALUE, where an argument in the formula
is the wrong type.
The ISERRVALUE function is used in logical expressions that refer to another cell.

Example 1

Cell Formula Value Returned
Scratch.X1 ="House" #VALUE!
Scratch.A1 =If 

(ISERRVALUE(Scratch.X1),2,Scratch.X1)
2

Note: Scratch cells A through D won't return a #VALUE! error because the formula can 
contain numbers and letters in the same string. Cells X and Y must contain numbers only.
Returns 2 because the value returned is a #VALUE! error, and the expression instructs Visio 
to return a 2 in place of the error.

Example 2
Cell Formula Value Returned
Scratch.A1 ="5 + 7" 5 + 7
Scratch.B1 =If 

(ISERRVALUE(Scratch.A1),2,Scratch.A1)
5 + 7

Returns 12 because the value returned is not a #VALUE! error, and the expression instructs 
Visio to return the value of the original cell.

See also
Cell reference syntax
Error values
ISERR
ISERRNA
ISERROR



 LN

Syntax LN(number)
Returns the natural logarithm of number. Number must be positive or LN returns the error 
value #NUM.
Example LN(42)
Returns 3.7377.

See also
LOG10



 LOC

Syntax LOC(point)
Returns the x,y coordinates of point measured from the lower-left corner of the shape's 
selection rectangle. In Visio, a point is a single value that embodies a pair of x- and y-
coordinates. 
Example LOC(PNT(Sheet.5!LocPinX, Sheet.5!LocPinY))
In this expression, PNT converts a set of coordinates in the ShapeSheet of Sheet.5 to a point.
(Sheet.5 is another shape on the same drawing page.) LOC then converts the point to a set 
of coordinates in relation to the lower-left corner of the selection rectangle of the current 
shape.
The 5 in Sheet.5 is the ID number for the shape, which is displayed in the Special dialog box.

See also
PAR
PNT
PNTX
PNTY



 LOG10

Syntax LOG10(number)
Returns the base 10 logarithm of number. Number must be positive or LOG10 returns the 
error value #NUM.
Example LOG10(42)
Returns 1.6232.

See also
LN



LOOKUP

Syntax LOOKUP("key","list"[,"delimiter"])
Returns a zero-based index that indicates the location of the substring key in a list, or 
returns -1 if the target string contains the delimiter. Uses a case-insensitive search. If the 
list begins or ends with a delimiter, a null string is assumed to exist before or after the list. 
Consecutive delimiters imply a null string in between.
Delimiters may be more than one character in length and may include multibyte characters. 
The default delimiter is the semicolon. All the arguments must be strings or able to be 
converted to strings. If they are not, an empty string is substituted for the offending 
argument.
Example 1 LOOKUP("rat","cat;rat;;goat")
Returns 1.
Example 2 LOOKUP("",";cat;rat;;goat")
Returns 0.
Example 3 LOOKUP("t","cat;rat;;goat","a")
Returns 3.

See also
INDEX



LOTUSNOTES

Syntax LOTUSNOTES(field)
Returns the most recent information read from Lotus Notes.
If you create a field in Lotus Notes, you need to create a corresponding field in the Lotus 
Notes Fields dialog box. In order for Visio to read this value, you need to define the field in a 
Lotus Notes document and check Read From Lotus Notes in the Lotus Notes Fields dialog 
box.
Example LOTUSNOTES ("BoxWidth") returns the value of the Lotus Notes field 

"BoxWidth"
Returns 12 inches.



 MAGNITUDE

Syntax MAGNITUDE(constantA,A,constantB,B)
Returns the magnitude of the vector whose rise is A and whose run is B, multiplied by the 
respective constants constantA and constantB. MAGNITUDE is calculated according to the 
following formula:

SQRT((constantA * A)^2 + (constantB * B)^2)
Example MAGNITUDE(1, 3, 1, 4)
Returns 5.



 MAX

Syntax MAX(number1,number2,...,number14)
Returns the largest number from a list of up to 14 numbers.
Example MAX(13 in.,1 ft, 20 cm)
Returns 13 in.

See also 
MIN



 MIN

Syntax MIN(number1,number2,...,number14)
Returns the smallest number from a list of up to 14 numbers.
Example MIN(13 in.,1 ft, 20 cm)
Returns 20 cm.

See also 
MAX



 MODULUS

Syntax MODULUS(number,divisor)

Returns the remainder (modulus) resulting when number is divided by divisor. The result 
has the same sign as divisor. A #DIV/0! error is returned if divisor is zero.
In almost all situations, the MODULUS function should be used rather than the MOD function.
Examples MODULUS(5, 1.4) returns 0.8

MODULUS(5, -1.4) returns -0.6
MODULUS(-5, 1.4) returns 0.6
MODULUS(-5, -1.4) returns -0.8

See also
ANG360
MOD



 MOD

Syntax MOD(number,divisor)
Returns the remainder that results when number is divided by divisor. The MOD function 
supplied with earlier versions of Visio is supported for backward compatibility. The MODULUS
function should be used in new formulas.

See also
ANG360
MODULUS



NA

Syntax NA( )
Returns the error value #NA!. NA is the error value that means "no value available." Use the 
NA function in a ShapeSheet cell where information is missing, so that the cell's default 
value is not used in calculations.

See also
Cell reference syntax
Error values
ISERR
ISERRNA
ISERROR
ISERRVALUE



 NOT

Syntax NOT(logical-expression)
Returns 1 if logical-expression is false. Otherwise, NOT returns 0.
Example NOT(Height > 0.75 in.)
Returns 1 if Height is less than or equal to 0.75 inches. Returns 0 if Height is greater than 
0.75 inches.

See also 
AND
OR



 NOW

Syntax NOW( )
Returns today's date and time as a single numeric value. The integer portion of the result 
represents the date and the decimal portion represents the time.
Example NOW( )
Returns 34880.6337 if the current date and time is 6/30/95 3:13:00 PM.

See also 
DATE
TIME



OPENFILE

Syntax OPENFILE("filename")
Opens the specified Visio document if not already open. Transfers focus to and activates the 
target document window at the completion of the command. 
Multiple OpenFile requests are queued and executed in order of evaluation at the completion
of a command, with the last named document receiving final focus. If the current Visio 
document is activated for visual (in-place) editing, a new instance of Visio is launched with 
the requested filename. This function always returns FALSE.
In earlier versions of Visio, this function appears as _OPENFILE. Visio 4.0 accepts either style.
Example OPENFILE("basic.vss")
Opens the specified stencil file BASIC.VSS in a new window and gives that window the focus.

See also 
OPENGROUPWIN
OPENPAGE
OPENSHEETWIN
OPENTEXTWIN



OPENGROUPWIN

Syntax OPENGROUPWIN( )
Opens the group in the group editing window. If the object is not a group, OPENGROUPWIN 
does nothing.
In earlier versions of Visio, this function appears as _OPENGROUPWIN. Visio 4.0 accepts 
either style.

See also 
OPENFILE
OPENPAGE
OPENSHEETWIN
OPENTEXTWIN



OPENPAGE

Syntax OPENPAGE("pagename")
Displays pagename in new window. If a window is already displaying pagename, that 
window becomes active. If the pagename does not exist, or if Visio is acting as an in-place 
server, OPENPAGE has no effect.
In earlier versions of Visio, this function appears as _OPENPAGE. Visio 4.0 accepts either 
style.

See also 
GOTOPAGE
OPENFILE
OPENGROUPWIN
OPENSHEETWIN
OPENTEXTWIN



OPENSHEETWIN

Syntax OPENSHEETWIN( )
Opens the ShapeSheet in a new window.
In earlier versions of Visio, this function appears as _OPENSHEETWIN. Visio 4.0 accepts 
either style.

See also 
OPENFILE
OPENGROUPWIN
OPENPAGE
OPENTEXTWIN



OPENTEXTWIN

Syntax OPENTEXTWIN( )
Opens the shape's text block so that the text can be edited.
In earlier versions of Visio, this function appears as _OPENTEXTWIN. Visio 4.0 accepts either 
style.

See also 
OPENFILE
OPENGROUPWIN
OPENPAGE
OPENSHEETWIN



 OR

Syntax OR(logical-expression1,logical-expression2,...,logical-expression14)
Returns 1 if any of the logical expressions is true. Any expression that evaluates to a non-
zero value is considered true. If all of the logical expressions are false or equal 0, OR returns 
0.
Example OR(Height > 1,PinX > 1)
Returns 1 if either expression is true. Returns 0 only if both expressions are false.

See also 
AND
NOT



 PAR

Syntax PAR(point)
Returns the x,y coordinates of point in the coordinate system of the shape's parent. In 
Visio, a point is a single value that embodies a pair of x- and y-coordinates. If the shape is 
in a group, its parent is the group. If the shape is not in a group, its parent is the page the 
shape is on.
Example PAR(PNT(PinX,PinY)
In this expression, PNT converts a pair of coordinates in the ShapeSheet of the current shape
into a point. PAR then converts the point into a pair of coordinates in relation to the lower-
left corner of the page that contains the current shape. 

See also 
LOC
PNT
PNTX
PNTY



 PI

Syntax PI( )
Returns the mathematical constant pi which is 3.1415926535898. 
Example (14 in. / 2)^2 * PI( )
Returns 153.9380 in., the area of a circle whose diameter is 14 inches.

See also 
COS
SIN
TAN



PLAYSOUND

Syntax PLAYSOUND("filename"|"alias",isAlias,beep,synch)
On systems with a sound card, plays the sound recorded in filename, or plays the system 
sound identified by alias if isAlias is nonzero. If the sound cannot be played, Visio beeps if 
beep is a nonzero number.
Sounds should usually be played asynchronously (synch=0) so Visio can continue 
processing while the sound is being played. To string several sounds together, play them 
synchronously (synch = nonzero number), or some might fail to play.
Example 1 PLAYSOUND("chord.wav", 0, 0, 0)
Plays the wave audio file chord.wav asynchronously with no warning beep.
Example 2 PLAYSOUND("SystemExclamation", 1, 0, 0)
Plays the system exclamation sound asynchronously with no warning beep.



 PNT

Syntax PNT(x,y)
Returns the point represented by the coordinates x and y as a single value. Converting 
coordinates to points allows you to change a shape's geometry without having to manipulate
x- and y-coordinates separately. 
Example PNT(PinX,PinY)
Returns the point represented by PinX and PinY.

See also 
LOC
PAR
PNTX
PNTY



 PNTX

Syntax PNTX(point)
Returns the x-coordinate of point measured from the lower-left corner of the shape's 
selection rectangle.

Example PNTX(PNT(7,12))
Returns 7.

See also 
LOC
PAR
PNT
PNTY



 PNTY

Syntax PNTY(point)
Returns the y-coordinate of point measured from the lower-left corner of the shape's 
selection rectangle.
Example PNTY(PNT(7,12))
Returns 12.

See also 
LOC
PAR
PNT
PNTX



 POW

Syntax POW(number,exponent)
Returns number raised to the power of exponent. Both number and exponent may be 
non-integers, and they may be negative. If number is not zero and exponent is zero, POW 
returns 1. If number is zero and exponent is negative, POW returns 0.0. If both number 
and exponent are zero, or if number is negative and exponent is not an integer, POW 
returns 0.0.
Example POW(5,2)
Returns 25.



 RAD

Syntax RAD(angle)
Converts the value of angle from degrees to radians. 
Example RAD(45)
Returns 0.7854.

See also 
DEG



 RAND

Syntax RAND( )
Returns a random number from 0 to 1 (inclusive) with 15 digits of precision. Returns a 
different number each time the function is evaluated, which is once per minute according to 
the system clock. Use RAND to create animation effects by setting shapes' properties to 
random values.
Example RAND( )
Returns a decimal fraction such as 0.3503.



 RECTSECT

Syntax RECTSECT(width,height,x,y,option)
Calculates the sector of a rectangle associated with x and y and returns an integer 0 to 4, 
indicating the sector.
Consider a rectangle that has a width and a height, and a point (x,y) from the center point 
of the rectangle. Draw diagonal lines through the corners of the rectangle to divide it into 
four sectors and a center point. The sectors are:

0 = the center point of the rectangle
1 = the sector containing the right side of the rectangle
2 = the sector containing the top side of the rectangle
3 = the sector containing the left side of the rectangle
4 = the sector containing the bottom side of the rectangle

Option is used to specify how points that fall on the diagonals are treated.
Option Treatment

0 Use the left and right sectors for points on a diagonal
1 Use the top and bottom sectors for points on a diagonal

Example RECTSECT(1 in., 2 in., 1 in., -7 in., 0) 
Returns 4.



 REF

Syntax REF( )
Returns the error value #REF!
Example REF( )
Returns #REF!



ROUND

Syntax ROUND(number,number-of-digits)

Rounds number to the precision represented by number-of-digits. If number-of-digits is 
greater than 0, number is rounded by number-of-digits to the right of the decimal. If 
number-of-digits is 0, number is rounded to the integer. If number-of-digits is less than 
0, number is rounded by number-of-digits to the left of the decimal.
Example 1 ROUND(123.654,2)
Returns 123.65.
Example 2 ROUND(123.654,0)
Returns 124.
Example 3 ROUND(123.654,-1)
Returns 120.

See also 
INT
TRUNC



RUNADDON

Syntax RUNADDON("filename")
Runs the filename add-on program. Use the RUNADDON function to bind a program, such 
as an add-on, to an Actions or Events cell.
In earlier versions of Visio, this function appears as _RUNADDON. Visio 4.0 accepts either 
style.
Example RUNADDON("calendar.exe")
Launches the CALENDAR.EXE add-on.

See also
RUNADDONWARGS



RUNADDONWARGS

Syntax RUNADDONWARGS("filename","argument")
Runs the filename add-on program and passes the command line arguments to the 
program as a string. In practice, argument should be 50 characters or less. Use the 
RUNADDONWARGS function to bind a program, such as an add-on, to an Actions or Events 
cell.
In earlier versions of Visio, this function appears as _RUNADDONWARGS. Visio 4.0 accepts 
either style.
Example RUNADDONWARGS("GRAPHMKR.EXE","/GraphMaker=Stack")
Launches the add-on GRAPHMKR.EXE and pass it the argument /GraphMaker=Stack.

See also
RUNADDON



SETF

Syntax SETF("cell",formula)
SETF("cell","formula")
SETF("cell","""formula""")

When evaluated, the result of the expression in formula becomes the new formula in cell. If
formula is enclosed in quotation marks, the quoted expression is written to cell. To set cell 
to a string, enclose formula in three sets of quotation marks.
If cell is not a string, the function returns an error, and no cell's formula is changed. If 
formula contains a syntax error, the function returns an error, and the formula in cell is not 
changed.
Example 1 SETF("Scratch.A1", 1.5in.*6+1ft.)
Sets the formula of Scratch.A1 to 21 in.
Example 2 SETF("Scratch.A1", "1.5in.*6+1ft.")
Sets the formula of Scratch. A1 to the expression 1.5 in.*6+1ft.
Example 3 SETF("Scratch.A1", """Say """"ahh""""""")
Sets the formula of Scratch.A1 to the string "Say ""ahh""" which evaluates to Say "ahh".



 SIGN

Syntax SIGN(number,fuzz)
Returns 1, 0, or -1 depending on if number is positive, zero, or negative. Fuzz is an optional
argument that specifies how close to zero number must be in order to be considered equal 
to zero. Fuzz helps avoid floating-point roundoff errors when a calculation is almost zero. If 
you do not specify a fuzz value, Visio uses 1E-9 (0.000000001). You may want to supply a 
different value when you scale drawings or when you want an exact comparison.
Examples SIGN(-5) equals -1

SIGN(0) equals 0
SIGN(0.00000000001) equals 0
SIGN(0.00000000001,0) equals 1



 SIN

Syntax SIN(angle)
Returns the sine of angle. Uses radians unless a unit of measure is specified with angle.
Example SIN(45 degrees)
Returns 0.7071.

See also 
ASIN
COS
PI
SINH



 SINH

Syntax SINH(angle)
Returns the hyperbolic sine of angle. Uses radians unless a unit of measure is specified with
angle.
Example SINH(45 degrees)
Returns 0.8687.

See also 
COSH
PI
SIN



 SQRT

Syntax SQRT(number)
Returns the square root of number. If number is negative, SQRT returns the error value 
#NUM!
Example SQRT(2)
Returns 1.4142.



 SUM

Syntax SUM(number1,number2,...,number14)
Returns the sum of a list of up to 14 numbers.
Example SUM(5,7,12)
Returns 24.



 TAN

Syntax TAN(angle)
Returns the tangent of angle. Uses radians unless a unit of measure is specified with angle.
Example TAN(45 degrees)
Returns 1.

See also 
COS
PI
SIN



 TANH

Syntax TANH(angle)
Returns the hyperbolic tangent of angle. Uses radians unless a unit of measure is specified 
with angle.
Example TANH(45)
Returns -.6558.

See also 
ATAN
COSH
PI
SINH



 TEXTHEIGHT

Syntax TEXTHEIGHT(shapename!theText,maximum-width)
Returns the height of the composed text in a shape where no text line exceeds maximum-
width. The returned value includes the height of the text including the space before and 
after text, the line spacing in text, and the top and bottom text block margins. TEXTHEIGHT 
is commonly used to adjust the height of a shape to fit the text it contains.
TheText is a Visio page formula that refers to all of the text contained in a shape's text block.
Shapename! can be used to refer to the text of a shape other than the current shape.
Example TEXTHEIGHT(theText,(Width - 0.5 in.))
Returns the height of the text when wrapped to the width of the shape minus 0.5 inches. 

See also 
TEXTWIDTH



 TEXTWIDTH

Syntax TEXTWIDTH(shapename!theText,maximum-width)
Returns the width of the composed text in a shape. TEXTWIDTH is commonly used to adjust 
the width of a shape to fit the text it contains.
TheText is a Visio page formula that refers to all of the text contained in a shape's text block.
If maximum-width is specified, the result is the longest line of text that fits within 
maximum-width. If maximum-width is omitted, the result is the total width of the text. 
Shapename! can be used to refer to the text of a shape other than the current shape. 
Example TEXTWIDTH(theText)
Returns the total length of the text in the current shape.

See also 
TEXTHEIGHT



 TIME

Syntax TIME(hour,minute,second)
Returns the time represented by hour, minute, and second as a single numeric value.
Example TIME(15,30,30)
Returns 0.6462.

See also 
DATE
NOW



 TRUNC

Syntax TRUNC(number,number-of-digits)
Returns number truncated by number-of-digits.
Example 1 TRUNC(123.654,2)
Returns 123.65.
Example 2 TRUNC(123.654,0)
Returns 123.
Example 3 TRUNC(123.654,-1)
Returns 120.

See also 
INT
ROUND



 USERUI

Syntax USERUI(state,default-expression,user-expression)

Evaluates one of the two expressions depending on the value of state. If state is 0, 
evaluates the default-expression. Otherwise, if state is 1, evaluates the user-
expression.
Example USERUI(1,if(Width>6in.,6in.,Width),Width*0.75)
Evaluates the expression Width*.075 and returns the result.



#
Digit placeholder. Displays either a digit or 
nothing. Leading and trailing zeroes are not 
displayed. If more digits than placeholders are to
the left of the decimal, all digits are displayed. If 
more digits than placeholders are to the right of 
the decimal, the fraction is rounded to the 
number of placeholders. For a dimension, if the 
placeholder is the leftmost digit, subunits that 
are zero are not displayed. For example, 
FORMAT(0ft. 11.25in.,"#.##u") displays 11.25in.

0 (zero)
Digit placeholder. Displays either a digit or 
nothing. Leading and trailing zeroes are 
displayed. If more digits than placeholders are to
the left of the decimal, all digits are displayed. If 
more digits than placeholders are to the right of 
the decimal, the fraction is rounded to the 
number of placeholders. For a dimension, 
subunits that are zero are displayed. For 
example, FORMAT(2ft. 11.33in.,"0.## u") 
displays 2 ft. 11.33 in.

. 
Decimal placeholder. Determines how many 
digits are displayed to the left and right of the 
decimal position. In a multipart unit, the decimal 
is used in the smallest (rightmost) subunit. 
Displays the decimal character defined under the
International options of the control panel. For 
example, FORMAT(250 cm.,"0.000 u") displays 
250.000cm.

,
Thousands separator. If surrounded by digit 
placeholders (# or 0), the separator separates 
thousands from hundreds within a number that 
has four or more digits to the left of the decimal. 
Displays the thousands separator defined under 
the International options of the control panel.

E- E+ e- e+
Scientific format. If the format contains at least 
one digit placeholder to the right of these 
symbols, the number is displayed in scientific 
format. Inserts the E or e between the number 
and its exponent. For E+ or e+, displays the + 
sign before positive exponents and the - sign 
before negative exponents. For E- or e-, displays 
the - sign only when the exponent is negative. 
For example, FORMAT(12345.67,"###.#e+#") 
results in .123.5e+2.



"text" or 'text'
Displays the text enclosed in quotes as is. See 
also \ (backslash).

\ 
Display the next character as is. To display the 
backslash character, type \\. See also "text".

u or U
Short label placeholder. Inserts abbreviated unit 
labels after each subunit. For example: in., ft., 
deg. The u placeholder inserts lowercase labels, 
and U inserts uppercase labels. Inserts the same 
number of spaces before the label as before the 
placeholder. For example, FORMAT(12ciceros 13 
didots,"#u") displays 12c13.

uu or UU
Long label placeholder. Inserts unit labels after 
each subunit. For example: inches, feet, degrees.
The u placeholder inserts lowercase labels, and U
inserts uppercase labels. Inserts the same 
number of spaces before the label as before the 
placeholder. For example, FORMAT(12.43in.,"# 
#/4 UU") displays 12 2/4 INCHES.

uuu or UUU
Universal label placeholder. Inserts the universal 
(internal to Visio) form of unit labels after each 
subunit. The u placeholder inserts lowercase 
labels, and U inserts uppercase labels. Inserts 
the same number of spaces before the label as 
before the placeholder.

/ (fraction)
Fraction placeholder. Displays expression as a 
whole number with fraction if a leading digit 
placeholder is present. Otherwise, displays only 
the whole number in the numerator. If a number 
follows the digit placeholder in the denominator, 
rounds the fraction to the nearest fraction whose
numerator is 1 and simplifies it. If a number is 
specified in the denominator without the digit 
placeholder, rounds to the nearest fraction but 
does not simplify it. For example, 
FORMAT(12.43,"# #/4") displays 12 2/4.

/ (date)
Date separator. If the expression is a date, 
separates the date components. Displays the 
date separator defined in the International 
options of the control panel.

$



Currency symbol. Displays the currency symbol 
defined in the International options of the control
panel.

space
Displays a space character in the formatted 
output. To display another character, use the \ 
(backslash) character.

@
Text placeholder. Replaces a string if the value of 
expression is a string. For example, 
FORMAT("Hello", "You entered (@')'" ) results in 
"You entered (Hello)".

: 
Time separator. Displays the time defined in the 
International options of the control panel.

d
Day placeholder. Displays the day as a number 
(1-31) without a leading zero.

dd
Day placeholder. Displays the day as a number 
(01-31) with a leading zero.

ddd or w
Short day of week placeholder. Displays the day 
as an abbreviation (Sun-Sat).

dddd or ww
Long day of week placeholder. Displays the day 
as a full name (Sunday-Saturday)

ddddd
Short date placeholder. Displays a date in the 
short form defined in the International options of 
the control panel.

dddddd
Long date placeholder. Displays a date in the 
long form defined under the International options
of the control panel.

M
Month placeholder. Displays the month as a 
number (1-12) without a leading zero. See also m
(minute placeholder).

MM
Month placeholder. Displays the month as a 
number (01-12) with a leading zero. See also mm



(minute placeholder).

MMM
Month placeholder. Displays the month in 
abbreviated form (Jan-Dec).

MMMM
Month placeholder. Displays the full name of the 
month (January-December).

yy
Year placeholder. Displays the year as a two-digit
number (00-99).

yyyy
Year placeholder. Displays the year as a four-digit
number (1900-2078).

h
Hour placeholder. Displays the hour without a 
leading zero in 12-hour form (0-12).

hh
Hour placeholder. Displays the hour with a 
leading zero in 12-hour form (00-12).

H
Hour placeholder. Displays the hour without a 
leading zero in 24-hour form (0-24).

HH
Hour placeholder. Displays the hour with a 
leading zero in 24-hour form (00-24).

m
Minute placeholder. Displays the minutes without
a leading zero (0-59).

mm
Minute placeholder. Displays the minutes with a 
leading zero (00-59).

s
Seconds placeholder. Displays the seconds 
without a leading zero (0-59).

ss
Seconds placeholder. Displays the seconds with a
leading zero (00-59).

t
AM/PM abbreviation. Displays the abbreviation 
defined in the International options of the control



panel.

tt
AM/PM designator. Displays the full designator 
defined in the International options of the control
panel.

T
General time format.

 



 Click a letter to search for a term

A
Alignment box
Attribute

B
Background
Bitmap

C
Center of rotation
Clipboard
Connection point
Connector
Container
Control handle
Control point
Coordinates
Crop
Custom property

D
Docked stencil
Drag and drop drawing
Drawing
Drawing file
Drawing file stencil
Drawing unit
Dynamic glue

E
Eccentricity handle
Endpoint
Expression

F
Field



Fill
Floating stencil
Foreground
Format

G
Gesture recognition
Glue
Grid
Grid lines
Group
Guide, guide point

H
Handle

I
In place
Insertion point
Instance

L
Layer
Link

M
Master shape

O
Object
Object linking and embedding (OLE)
One-dimensional (1-D) shape
Origin

P
Page
Page unit
Pan
Parent
Paste
Pasteboard
Path
Pixel
Point

R
Rotation handle

S
Scale
Segment
Selection
Selection handle



Selection net
Selection rectangle
Shape
ShapeSheet
Size
SmartConnector
SmartShape
Snap
Stacking order
Stamp
Stand-alone stencil
Stencil
Style
Subdivision

T
Template
Text block
Tile
Toolbar
ToolTip
Two-dimensional (2-D) shape

U
Units of measure
Universal Connector

V
Vertex, Vertexes

W
Wizard
Workspace

Z
Zoom



Alignment box
The rectangle that appears around shapes and 
objects from other applications as you move 
them. See also selection rectangle.

Attribute
Individual formatting elements, such as line 
color, fill color, and line weight, that you can 
apply to shapes. A style can have several 
attributes. See also format, style.

Background
A page that you can assign to another page to 
create multiple layers in a drawing. You can see 
shapes on a background when the page it is 
assigned to is displayed, but you can't select or 
edit the background's shapes without displaying 
the background. See also foreground page, layer.

Bitmap
An image stored as a pattern of dots. A scanned 
photograph or graphic that you create in a paint 
program is usually stored as a bitmap.

Center of rotation
The point around which a shape or text block 
rotates. When you select a 2-D shape with the 
rotation tool, its center of rotation is marked by a
circle with a plus sign inside it. By default, the 
center of rotation is at the center of the shape. 
You can move the center of rotation by dragging 
it with the rotation tool.

Clipboard
A temporary storage area in Windows that is 
used to transfer data between documents and 
applications. You can use the Clipboard to copy 
shapes and text and to copy shapes between 
drawings in Visio or between Visio and other 
Windows applications.

Connection point
A point on a shape where a connector can be 
glued to a shape. You can create new connection 
points inside, outside, or on the perimeter of a 
shape by using the connection point tool. Each of
a shape's connection points is marked with a 
blue X when Connection Points is checked on the 
View menu.

Connector
Any one-dimensional shape that can be glued 
between two shapes in a drawing to connect the 
shapes. Some master shapes are connectors. You
can also use lines and other shapes you draw as 



connectors. See also SmartConnector.

Container
An OLE application in which you embed or link 
information. For example, if you insert a Visio 
drawing into a Microsoft Word document, 
Microsoft Word is the container application. A 
container application is also known as a client. 
See also OLE.

Control handle
A handle that makes shapes behave in special 
ways. For example, you might use a control 
handle to adjust the roundness of a shape's 
corners, to reshape an arrow, or to drag a 
connector directly out of another shape.

Control point
The circle that appears on a line or an arc (or a 
line or an arc segment) when the line or arc is 
selected with the pencil tool. You can drag a 
control point to change the curvature of an arc or
ellipse.

Coordinates
A pair of numbers that indicates the position of a
point in relation to the origin of a shape, a group,
or the page. The x-coordinate indicates the 
horizontal distance and the y-coordinate 
indicates the vertical distance of the point. See 
also origin.

Crop
To reduce or expand an object from another 
application used in a Visio drawing. Although 
cropping appears to clip off parts of the object, 
Visio retains the clipped portions of the object in 
memory. You crop an object by selecting it with 
the crop tool and dragging one of its handles.

Drag and drop drawing
Creating an instance of a master shape in a 
drawing by dragging the master shape from a 
stencil to the drawing. To drag a master shape, 
point to it with the mouse and hold down the left 
mouse button. Move the mouse until the shape is
where you want it in the drawing, and then 
release the mouse button to drop the shape.

Drawing
All the shapes on the foreground page together 
with all the shapes on optional background 
pages.

Drawing file



A Visio file that contains Visio drawings. A 
drawing file can be based on a template. You can
create a new drawing file by opening a Visio 
template or by using the New command on the 
File menu. Every drawing file has its own stencil, 
which contains an inventory of all the master 
shapes used in all of the drawings in the file.

Drawing file stencil
A stencil stored in a drawing file, which contains 
an inventory of the master shapes used in all of 
the drawings in the file. Master shapes on the 
drawing file stencil are linked to their instances 
in the drawings. To display the drawing file 
stencil for the current drawing file, choose Show 
Master Shapes from the Window menu. See also 
stand-alone stencil.

Dynamic glue
A type of glue that allows the endpoint of a 
connector shape to move from one connection 
point to another as the connected shapes are 
moved. (When shapes are connected without 
dynamic glue, the endpoints of the connector are
attached to specific connection points; in that 
case, instead of jumping to a new connection 
point, the connector will change shape to avoid 
crossing over the shapes when they're moved.)

Eccentricity handle
The circle that appears at each end of a dotted 
line when a control point of an elliptical arc is 
selected with the pencil tool. Eccentricity handles
are dragged to change the angle and magnitude 
of an arc's eccentricity.

Endpoint
Either of the square handles that appear at the 
beginning or end of a selected line, arc, or other 
one-dimensional shape. The endpoint at the 
beginning of the shape (beginning point) is 
marked by an X. The endpoint at the end of the 
shape (ending point) is marked by a plus sign 
(+). See also vertex, vertexes.

Expression
A combination of values, operators, functions, 
and sheet references that results in a value. A 
logical expression compares two values and 
yields a true or false result. 

Field
A placeholder in text that displays information 
such as dimensions, dates, and times. A field 
might display the date and time a drawing is 



printed, a shape's angle of rotation, or the result 
of a formula you write. Fields are automatically 
updated when you change a drawing. A field can 
also read information from Lotus Notes.

Fill
The color and pattern inside a closed shape. 
Visio's default fill is solid white.

Foreground
The top page of a drawing. Shapes on the 
foreground page appear in front of shapes on the
background page and are not visible when you 
edit the background of the drawing. See also 
background.

Format
To affect the visual appearance of a shape (such 
as the thickness and color of its lines, the color 
and pattern inside the shape, and its font) either 
by using a style or by applying individual 
attributes. See also attribute, style.

Gesture recognition
A feature of the pencil tool. As you begin to 
move the mouse, Visio quickly calculates the 
path the mouse pointer travels. If the path of the
mouse is straight, the pencil tool draws a straight
line segment. If the path curves, the pencil tool 
draws an arc.

Glue
A property of shapes that causes them to stay 
connected even when one of the shapes is 
moved. When you attach a connector to a shape,
you are gluing the connector. If you move the 
shape, Visio adjusts the connector as needed. If 
you move the connector, the glue is broken and 
the shapes are no longer connected.    See also 
dynamic glue.

Grid
Grids are non-printing horizontal and vertical 
lines displayed at regular intervals on the page. 

Grid lines
The faint vertical and horizontal lines that appear
in the drawing window when the grid is turned 
on. You can use grid lines to help position shapes
precisely.

Group
A shape that is composed of two or more shapes.
A group can also include other groups and 
objects from other applications. A group can be 



moved and sized as a single shape, but its 
members retain their original appearance and 
properties.

Guide, guide point
A reference line that can be dragged into the 
drawing window to help position shapes 
precisely. A horizontal guide is dragged from the 
horizontal ruler, a vertical guide from the vertical
ruler, and a guide point from the upper-left 
corner of the drawing window, where the 
horizontal and vertical rulers meet.

Handle
A control that appears when you select a shape. 
You can use handles to alter a shape. Handles 
vary with the type of shape and the tool you use 
to select it. For example, when you select a 
shape with the pointer tool, it displays selection 
handles that you can drag to change the shape's 
size and proportions. When you select a shape 
with the rotation tool, the shape displays rotation
handles that you can drag to rotate the shape. 
See also control handle, eccentricity handle, 
rotation handle.

In place
Visio opens in place when you run it from within 
a container application. When you work in place, 
Visio menus and toolbars appear and replace 
some of the container's menus and toolbars.

Insertion point
The blinking vertical line that appears in text 
when you select a shape with the text tool and 
click the text with the mouse. Text you type 
appears at the insertion point. You can move the 
insertion point by clicking another location with 
the mouse or by pressing the arrow keys.

Instance
A copy of a master shape, which you create by 
dragging the master shape from a stencil to a 
drawing.

Link
To establish a dynamic connection between an 
object in a Visio drawing and another 
application's file through the object linking and 
embedding (OLE) protocol. When changes are 
made to the original file, you can update the link 
so that the most current version of the object 
appears in the linked file. See also OLE.

Master shape



A shape in a stencil. You drag and drop a master 
shape from a stencil into a drawing to create an 
instance of the master shape. Many of the 
master shapes in the stencils provided with Visio 
are SmartShapes¾shapes with programming that
controls how the shape behaves when it is 
moved or sized.

Object
Information created in another application and 
imported, embedded, or linked in a Visio 
drawing. The term object is used to refer to 
objects from other applications and OLE objects. 
The application that the object is created in is 
known as the server application. See also OLE.

Object linking and embedding (OLE)
A Windows protocol that makes it possible to 
embed an object created in one Windows 
application into a document created in a different
Windows application, or to link an object to a file 
that contains the original object.

One-dimensional (1-D) shape
A straight line or arc you draw in Visio, a 
connector on a stencil, or any shape you define 
as a one-dimensional shape. A one-dimensional 
shape has a beginning point and an ending point 
and can be glued between two shapes to 
connect them. See also two-dimensional (2-D) 
shape.

Origin
The lower-left corner of the selection rectangle of
a shape, of a group, or of the drawing page. The 
x- and y-coordinates of the origin are always 0,0. 
Dimensions of a shape, such as its width and 
height, and the center of rotation are measured 
from its origin. The location of a shape in relation
to its parent (a group or the page) is measured 
from the parent's origin. See also coordinates.

Page
The printable area in a drawing window that 
contains a drawing. A page can be either a 
foreground or a background page. Each page has
a size, which usually corresponds to a standard 
paper size, and it has a scale. See also 
background, foreground, layer

Pan
To move an OLE object with the crop tool by 
holding down the left mouse button and shifting 
the object within the object's border. See also 
handle, object linking and embedding (OLE).



Parent
The group that contains a shape is the shape's 
parent. If the shape is not in a group, its parent is
the page.

Paste
To insert information from the Windows Clipboard
into a Visio drawing or another Windows 
application.

Pasteboard
The area that surrounds a page in the drawing 
window. You can store shapes on the pasteboard.
Each page has its own pasteboard.

Path
A series of contiguous line or arc segments in a 
shape. A shape can have more than one path. 
See also segment.

Pixel
An individual block of display information. The 
term pixel is derived from the phrase "picture 
element."

Point
A single value that embodies a set of x- and y-
coordinates for greater convenience in 
calculations.

Rotation handle
One of the round handles that appear at a corner
of a shape's selection rectangle when you select 
the shape with the rotation tool.

Scale
A measure of the relationship between actual 
distances and distances represented in a Visio 
drawing. For example, a floor plan might have a 
scale of one foot of actual distance to one inch in
the drawing. 

Segment
A straight line or curve that is part of a more 
complex shape.

Selection
Shapes in a drawing that are the focus of your 
next action. Selected shapes display handles. 
Selection also refers to text selected in a text 
block. Selected text is highlighted.

Selection handle
A square handle that appears on a shape 



selected with the pointer tool. Selection handles 
indicate that you can size or move the shape.

Selection net
A means of selecting more than one shape at a 
time by dragging the pointer tool to define a 
rectangular area that encloses all the shapes to 
be selected.

Selection rectangle
The dotted line that surrounds selected shapes 
or objects from other applications. See also 
alignment box.

Shape
A line, arc, ellipse, freeform, or rectangle; a 
closed or open series of line and arc segments; 
or a group. You create a shape in Visio by 
dragging and dropping a master shape from a 
stencil into a drawing, by using Visio's drawing 
tools, by grouping other shapes, or by converting
an object from another application into a Visio 
shape.

ShapeSheet
The spreadsheet that contains information about 
a shape¾for example its dimensions, its angle 
and center of rotation, and the styles that 
determine the shape's appearance. ShapeSheets
can contain formulas that define how the shape 
behaves when it is moved or sized.

Size
To change the dimensions of a shape by 
dragging one of its handles after it has been 
selected with the pointer tool.

SmartConnector
A 1-D shape that behaves intelligently when it's 
used to connect other shapes. For example, if 
you use a SmartConnector to connect two 
shapes and you move one of the shapes, the 
SmartConnector repositions itself and in some 
cases can change its shape to avoid crossing 
over the shapes it connects. See also one-
dimensional (1-D) shape, Universal connector.

SmartShape
A shape that is programmed to behave 
predictably when you move or size it.

Snap
The ability of shapes, guides, grid lines, and 
other elements in Visio to pull shapes and other 
elements into position when they are moved and



sized.

Stacking order
Determines how shapes overlap other shapes on 
the page and the order in which shapes are 
selected. You can change the stacking order of 
shapes by using the Bring To Front, Bring 
Forward, Send To Back, and Send Backward 
commands on the Shape menu.

Stamp
To create an instance of a master shape with the 
stamp tool. To stamp a master shape, select the 
master shape in the stencil, choose the stamp 
tool, and click to where you want the instance to 
appear. To glue a connector with the stamp tool, 
select the connector in the stencil, and then drag
between connection points on the shapes you 
want to connect.

Stand-alone stencil
A Visio file with a .VSS filename extension that 
contains a collection of master shapes and is 
usually referred to simply as a stencil. Unlike a 
drawing file stencil, a stand-alone stencil usually 
does not have an accompanying drawing. See 
drawing file stencil, stencil.

Stencil
A collection of master shapes that you can drag 
and drop into a drawing. Stencils are stored in 
stencil files, which are opened when you create a
new drawing based on the stencil's associated 
template. By default, stencils appear docked on 
the right-side of the drawing window. You can 
also open a stencil file independently of a 
template. See also template.

Style
A collection of attributes that has a name and is 
saved with a template or drawing file. You can 
use a style to apply a set of attributes to a shape
with a single action. Many of Visio's templates 
have styles that are included in the new 
drawings you create from a template. See also 
attribute.

Subdivision
The division between grid lines and between 
intervals of the ruler. This option is set using the 
Ruler & Grid command. The choices are Fine, 
Normal, and Coarse.

Template
A Visio file that opens one or more stencils and 



can contain styles and settings for a particular 
kind of drawing, for example, the appropriate 
scale and grid. You can create a new drawing 
with a template's styles and settings by opening 
the template. See also stencil.

Text block
The text area associated with a shape that 
appears when you click the shape with the text 
tool or select the shape and start typing. You can
size a text block and move a text block in 
relation to its shape.

Tile
A printing technique whereby oversized drawing 
pages are printed on multiple sheets of paper. 
Also, a command on the Window menu that 
arranges open windows side by side in the Visio 
main window.

Toolbar
The row of boxes, buttons, and tools that 
appears below the menu bar in the Visio window.
On the toolbar, you can choose styles from lists, 
options such as snap and glue on or off, and 
tools to create and modify shapes.

ToolTip
When you pause with the pointer (without the mouse 
button pressed) over either an item on the toolbar or a 
master shape icon when the stencil window is set to 
display icons only, a ToolTip appears. To turn off ToolTips, 
choose the Toolbars command on the View menu, and 
then uncheck the Show ToolTips option.

Two-dimensional (2-D) shape
A shape that has corner selection handles that 
you can use to size the shape proportionally. 
Most rectangles, ellipses, and freeform shapes 
are defined as two-dimensional. See also one-
dimensional (1-D) shape.

Units of measure
The type of measurement system used in a 
drawing. You specify a unit of measure (inches, 
feet, miles, points, meters, and so on) in the 
Options box.

Universal connector
A master shape that is programmed to connect 
any two points without crossing over the shapes 
it connects. By default, an instance of the 
Universal Connector is created when you use the
connector tool and the Connect Shapes 
command. See also connector, SmartConnector.



Vertex, vertexes
One of the diamond-shaped handles that 
appears between two segments on a multiple-
segment shape or at the end of a segment when 
you select a shape with the pencil tool. You can 
reshape a shape by dragging its vertexes. See 
also endpoint.

Workspace
A Visio file that contains information about the 
size and position of drawings and stencils at the 
time you save the workspace. When you open a 
workspace, Visio recreates the arrangement of 
stencil and drawing windows for you. You can 
store a workspace with a drawing file or save a 
workspace as a workspace (.VSW) file.

Zoom
To increase or decrease the display size of a 
drawing in the drawing window. A display size of 
100% (or Actual Size) displays the drawing at the
same size it will be when it is printed, unless you 
reduce or enlarge the printed output in the Page 
Setup dialog box.

Docked stencil
A stencil that is attached to the side of the 
drawing window. By default, stencils are docked 
on the left side of the window. You can make 
stencils float, or you can dock them on the right 
side of the drawing window. See also floating 
stencil.

Floating stencil
A stencil that appears in the size and location 
you choose. By default, stencils are docked on 
the left side of the window. You can make stencils
float, or you can dock them on the right side of 
the drawing window. See also docked stencil.

Custom property
A method of associating data with an individual 
shape. Some stencil masters have predefined 
custom properties. 
To add custom properties to a shape, use the 
Custom Properties section of the ShapeSheet and
the Custom Properties command on the Tools 
menu. See also ShapeSheet.

Drawing unit
Drawing units are sizes in the real world, and 
page units are sizes on the printed page. For 
example, in an architectural drawing that uses 
the scale 1/4 inch = 1 foot, 1 foot is the drawing 



unit and 1/4 inch is the page unit. The ratio of 
page units to drawing units is the drawing scale.

Page unit
Page units are sizes on the printed page, and 
drawing units are sizes in the real world. For 
example, in an architectural drawing that uses 
the scale 1/4 inch = 1 foot, 1 foot is the drawing 
unit and 1/4 inch is the page unit. The ratio of 
page units to drawing units is the drawing scale.

Wizard
A Visio tool that automates common tasks. For 
example, you can use the Org Chart Wizard to 
automate creating an organization chart.
To view Wizards, choose New from the File menu,
or choose Run Add-on from the Tools menu.

Layer
A named category of shapes. You can organize 
shapes in your drawing by assigning them to 
layers. You can selectively view, edit, print, or 
lock layers, as well as control whether shapes on 
a layer can be snapped to or glued to. See also 
background.

 



Command shortcuts

Keyboard shortcuts for some commands are listed on Visio's menus.
To choose this command: Press:
Actual Size Ctrl+I
Align Shapes F8
Bring To Front Ctrl+F
Cascade Alt+F7
Connect Shapes Ctrl+K
Copy Ctrl+C
Cut Ctrl+X
Duplicate Ctrl+D
Field Ctrl+F9
Fill F3
Flip Horizontal Ctrl+H
Flip Vertical Ctrl+J
Font F11
Glue (toggles on or 
off)

F9

Group Ctrl+G
Help, display online 
Help

F1

Line Shift+F3
New Ctrl+N
Open Ctrl+O
Page F5
Paragraph Shift+F11
Paste Ctrl+V
Print Ctrl+P
Properties (Page) Shift+F5
Redo Ctrl+Y
Repeat F4
Rotate Left Ctrl+L
Rotate Right Ctrl+R
Save Ctrl+S
Save As F12
Save Workspace Alt+F12
Select All Ctrl+A
Send To Back Ctrl+B
Snap (toggles on or 
off)

Shift+F9

Snap & Glue Alt+F9
Spelling F7
Tabs Ctrl+F11
Text Block Alt+F11
Tile Horizontally Shift+F7
Tile Vertically Ctrl+Shift+F7



Undo Ctrl+Z
Ungroup Ctrl+U
Whole Page Ctrl+W
Zoom F6

Tip: To activate the menu bar, press Alt or F10.
You can use these shortcuts with text:

To insert a field in 
text:

Press:

Height field Ctrl+Shift+H
Rotation angle field Ctrl+Shift+A
Width field Ctrl+Shift+W

Tip: To select a shape's text block if the text tool is selected or to toggle between text edit 
and shape selection mode, press F2.



Drawing tools

Keyboard shortcuts for Visio's drawing tools are as follows:
To choose this tool: Press:
Arc Ctrl+4
Connection point Ctrl+8
Connector Ctrl+7
Ellipse Ctrl+6
Line Ctrl+3
Pencil Ctrl+2
Pointer Ctrl+1
Rectangle Ctrl+5
Rotation Ctrl+Ø
Text Ctrl+9

See also
Drawing ellipses and circles
Drawing freeform shapes
Drawing lines and arcs
Drawing rectangles and squares



Special characters

Use these key combinations to type commonly used special characters in text:
To type: Press:
Beginning single-
quote

Ctrl+[

Ending single-quote Ctrl+]
Beginning double-
quote

Ctrl+Shift+[

Ending double-quote Ctrl+Shift+]
Bullet Ctrl+Shift+8
En dash Ctrl+=
Em dash Ctrl+Shift+=
Discretionary hyphen Ctrl+hyphen
Non-breaking hyphen Ctrl+Shift+hyphen
Non-breaking slash Ctrl+Shift+/
Non-breaking 
backslash

Ctrl+Shift+\

Section marker Ctrl+Shift+6
Paragraph marker Ctrl+Shift+7
Copyright symbol Ctrl+Shift+C
Registered trademark Ctrl+Shift+R
See also
Typing special characters
Typing text into shapes



ANSI extended characters

You can type characters from the ANSI extended character set by using the numeric keypad 
on the keyboard. To type ANSI characters, hold down the Alt key, then using the keys on the 
numeric keypad, type 0 and the ANSI code for the character you want.
The following table lists codes for extended characters from the ANSI character set:

Character ANSI code Character ANSI code
‚ 130 Ë 203
ƒ 131 Ì 204
„ 132 Í 205
… 133 Î 206
† 134 Ï 207
‡ 135 Ð 208
ˆ 136 Ñ 209
‰ 137 Ò 210
Š 138 Ó 211
‹ 139 Ô 212
Œ 140 Õ 213
· 149 Ö 214
¡ 161 × 215
¢ 162 Ø 216
£ 163 Ù 217
¤ 164 Ú 218
¥ 165 Û 219
¦ 166 Ü 220
§ 167 Ý 221
¨ 168 Þ 222
© 169 ß 223
ª 170 à 224
« 171 á 225
¬ 172 â 226

173 ã 227
® 174 ä 228
¯ 175 å 229
° 176 æ 230
± 177 ç 231
² 178 è 232
³ 179 é 233
' 180 ê 234
µ 181 ë 235
¶ 182 ì 236
¸ 184 í 237
¹ 185 î 238
º 186 ï 239
» 187 ð 240
¼ 188 ñ 241
½ 189 ò 242



¾ 190 ó 243
¿ 191 ô 244
À 192 õ 245
Á 193 ö 246
Â 194 ÷ 247
Ã 195 ø 248
Ä 196 ù 249
Å 197 ú 250
Æ 198 û 251
Ç 199 ü 252
È 200 ý 253
É 201 þ 254
Ê 202 ÿ 255

See also
Typing special characters
Typing text into shapes



 



ShapeSheets

Alphabetical list of ShapeSheet cells
Sections overview
ShapeSheet sections
1-D Endpoints section
Actions section
Alignment section
Character section
Connection Points section
Controls section
Custom Properties section
Events section
Fill Format section
Geometry section
Glue Info section
Guide Info section
Image Info section
Layer Membership section
Layer Properties section
Line Format section
Miscellaneous section
Object Transform section
Page Properties section
Paragraph section
Protection section
Ruler & Grid section
Scratch section
Text Block Format section
Text Fields section
Text Transform section
User-Defined Cells section
ShapeSheet formulas
Cell reference syntax
Error values
Formulas overview
Functions
Local and inherited formulas
Operators
Units of measure



Alphabetical list of ShapeSheet cells
Click a letter to search for a cell

A
Action
Active
AlignBottom
AlignCenter
AlignLeft
AlignMiddle
AlignRight
AlignTop
Angle
ArcTo
ArrowSize
Ask

B
BegTrigger
BeginArrow
BeginX
BeginY
BottomMargin

C
Can Glue
Case
Color (Character)
Color (Layer Properties)

D
DrawingScale
DynFeedback

E
EllipticalArcTo
EndArrow
EndTrigger
EndX
EndY
EventDblClick
EventDrop
EventXFMod

F
FillBkgnd
FillForegnd
FillPattern
FlipX
FlipY
Font



Format

G
Glue
GlueType
GuideFlags 
GuidePosX
GuidePosY

H
HAlign
Height
HelpTopic
HideText

I
ImgHeight
ImgOffsetX
ImgOffsetY 
ImgWidth
IndFirst
IndLeft
IndRight
Invisible

L
Label
Layer Properties
LeftMargin
LineCap
LineColor
LinePattern
LineTo
LineWeight
Lock
LockAspect
LockBegin
LockCalcWH
LockCrop
LockDelete
LockEnd
LockFormat
LockGroup
LockHeight
LockMoveX
LockMoveY
LockRotate
LockSelect
LockTextEdit
LockVtxEdit
LockWidth
LocPinX
LocPinY



M
Menu

N
NoAlignBox
NoCtrlHandles
NoFill
NoObjHandles
NonPrinting
NoShow

P
PageHeight
PageScale
PageWidth
PinX
PinY
Pos.
Print
Prompt (Actions)
Prompt (Custom Properties)
Prompt (User-Defined Cells)
Prop.Row

R
ResizeMode
RightMargin
Rounding

S
ShdwBkgnd
ShdwForegnd
ShdwOffsetX
ShdwOffsetY
ShdwPattern
Size
Snap
SortKey
SpAfter
SpBefore
SpLine
SplineKnot
SplineStart
Start
Style

T
TextBkgnd
TheData
TheText
TopMargin
TxtAngle
TxtHeight
TxtLocPinX



TxtLocPinY
TxtPinX
TxtPinY
TxtWidth
Type

U
UpdateAlignBox
User.Row

V
Value (Custom Properties)
Value (User-Defined Cells)
VerticalAlign
Visible

W
WalkPreference
Width

X
X
X Behavior
X Dynamics
XGridDensity
XGridOrigin
XGridSpacing
XRulerDensity
XRulerOrigin

Y
Y
Y Behavior
Y Dynamics
YGridDensity
YGridOrigin
YGridSpacing
YRulerDensity
YRulerOrigin



Sections overview

Each ShapeSheet is divided into sections that control a particular aspect of a shape's 
behavior or appearance¾for example, its geometry or its formatting.
The sections that appear in a ShapeSheet depend on the shape itself and the sections you 
choose to display. Most ShapeSheets have an Object Transform section, which contains 
general positioning information for the shape. (Guides and guide points have a Guide Info 
section.) Visio builds in other sections required for the shape as it is drawn. A ShapeSheet for
a particular shape may not have every possible section. For example, a 2-D shape doesn't 
have a 1-D Endpoints section, and only an object from another program has an Image Info 
section.

Cells and formulas
Each section consists of cells that contain formulas, which can be default formulas created 
by Visio or formulas you create. You change a shape's behavior by editing formulas in cells. 
Editing formulas in a ShapeSheet provides a way to change a shape with greater precision 
than is possible in the drawing window. This is how you turn ordinary shapes into 
SmartShapes.

See also
Adding and deleting sections
Creating formulas
Editing formulas
Understanding ShapeSheets



Formulas overview

A formula in a cell can be Visio's default formula, one that is inherited from a master shape, 
or one you create by entering it in a ShapeSheet cell. Cells are used in much the same way 
as in a spreadsheet program. Editing a cell's formula changes the way the value of the cell is
calculated, so it changes a particular behavior of the shape. A formula always starts with an 
equal sign, which Visio inserts automatically.

Default formulas
When you create a shape, Visio automatically creates default formulas. To see what the 
default formulas are, draw a simple shape (such as a rectangle, ellipse, or straight line) and 
take a look at its ShapeSheet.

Automatic updates
Visio automatically updates certain cells whenever you change a shape in a drawing. This 
means that under some circumstances formulas you enter can be replaced with formulas 
from Visio. For example, if you drag a corner handle to resize the shape, Visio resets 
formulas in the PinX, PinY, Width, and Height cells.
If necessary, you can protect formulas against changes using the GUARD function.

Elements
A formula can contain the following elements:
Coordinates: Used to refer to positions of vertexes with respect to the origin of a shape and
to the origin of the group or page that contains the shape. Most formulas are expressed as 
coordinates for controlling the position and size of a shape.
Numbers: Used in formulas to specify a wide range of values, such as measurements, 
angles, styles, and colors. A number can include a plus or a minus sign and can be entered 
in exponential notation (for example, 1.2E-6) or as a fraction (for example, 5 9/16).
Units of measure: Used after a number to specify the unit of measure that the number 
represents. If you don't specify a unit of measure, Visio uses default units of measure in cells
that require a unit of measure.
Cell references: Used in formulas to calculate the value of one cell on the basis of the value 
of another cell.
Functions: Used for a variety of purposes in formulas. Visio includes mathematical, 
trigonometric, logical, date and time, statistical, and miscellaneous functions.
Operators and parentheses: Used to create mathematical expressions in formulas.
Inherited formulas: Used when an instance of a shape inherits formulas from its master 
rather than making local copies of them.
Local formulas: Used when an inherited formula has been edited or overwritten by actions in
the drawing page.

See also
Creating formulas
Editing formulas



Units of measure

When you insert fields into text or build formulas in ShapeSheets, you'll often specify units of
measure for the values you type. Units of measure affect how a value is displayed, not how 
it is stored.

Values
Visio stores all values internally in a single format and converts the value to the specified 
unit of measure for display. This allows you to easily convert a value from one system of 
measurement to another by typing the units you want.
If you don't specify a unit of measure, Visio uses the default unit for that cell. If you have 
already specified units of measure for a cell, Visio displays values in those units until you 
change them.
You can type units of measure in full or use these abbreviations:

To specify units You can type an abbreviation
centimeters centimeters, cm., or cm
ciceros ciceros, cicero, ci., ci, or c
ciceros and didots cicero/didot
degrees degrees, degree, deg., deg, or °
degrees, minutes, 
and seconds

dms, degrees, deg, or °

didots didots, didot, di., di, or d
feet feet, foot, ft., ft, f, or '
feet and inches feet/inch
inches inches, inch, in., in, i, or "
kilometers kilometers, km., or km
meters meters, meter, metres, metre, m., or 

m
miles miles, mile, mi., or mi
millimeters millimeters, mm., or mm
minutes minutes, minute, min., min, or '
percent %
picas picas, pica, or p
picas and points picapoints
points points, point, pt., or pt
radians radians, radian, rad., or rad
seconds seconds, second, sec., sec, or "
yards yards, yard, yds., yds, yd., or yd

To enter units implicitly, use this syntax when specifying a number and unit of measure:
number [unit, flag]

where:
number The original value, such as 3.7, 1.7E-4, or 5 1/2

unit The units in which number is originally expressed
flag A letter (either uppercase or lowercase) indicating the measurement system 

that should be used when the implicit value-unit is displayed:
d Drawing measurements
p Page measurements



t Type measurements
a Angular measurements

See also
Creating formulas



Operators

You can use Visio's operators in expressions in formulas to perform arithmetic operations or 
logical comparisons. You can also alter the order of evaluation in a formula by enclosing 
expressions in parentheses. Use the ampersand operator to combine character strings.



Ampersand operator

The ampersand operator returns a new character string. You can create compound words 
and phrases.
Syntax "string1" & "string2"
Example "dog" & "house"
Returns "doghouse".



Arithmetic operators

Arithmetic operators perform operations on numbers. The + and - operators can be used 
alone as unary operators to establish the sign of a number. The % operator is also a unary 
operator that identifies the number as a percentage.

Operator Action Example Result
+ Positive +37 +37
- Negative -37 -37
% Percentage 37% 37%
^ Exponentiation 5^2 25
* Multiplication 5*2 10
/ Division 5/2 2.5
+ Addition 5+2 7
- Subtraction 5-2 3

Comparison operators

Comparison operators are used to construct logical expressions. A logical expression 
evaluates to either TRUE or FALSE.

Operato
r

Alternativ
e

Action Example Result

> _GT_ Greater 
than

5 > 2 TRUE

< _LT_ Less than 5 < 2 FALSE
>= _GE_ Greater 

than or 
equal to

5 >= 2 TRUE

<= _LE_ Less than or
equal to

5 <= 2 FALSE

= _EQ_ Equal to 5 = 2 FALSE
<> _NE_ Not equal 

to
5 <> 2 TRUE

The symbolic comparison operators (>, <, and so forth) are the best choice for most 
comparisons. The alternative operators (_GT_, _LT_, and so forth) perform an exact 
comparison to the full 15 digits of precision that Visio uses to store values internally. 
When you compare rounded or calculated values by using the alternative operators, Visio 
might return FALSE when for all practical purposes the expression should evaluate to TRUE.
When you compare text strings, Visio converts the string to a value. Text strings that cannot 
be converted return a value of zero, therefore comparisons vary and may not produce the 
results you expect.



Order of evaluation

When a formula contains more than one expression, the expressions are evaluated in order 
according to the operation being performed. In Visio, the order of evaluation of operators is:

Order Action Operator
First Positive +

Negative -
Percent %

Second Exponentiation ^
Third Multiplication *

Division /
Fourth Addition +

Subtraction -
Fifth String 

concatenation
&

Sixth Greater than >
Greater than or 
equal to

 =>

Less than  <
Less than or 
equal to

<=

Seventh Equal =
Not equal <>

You can change the order of evaluation by enclosing expressions in parentheses. Visio 
evaluates expressions within parentheses first, from left to right. For example:

4+5*6 = 4+30 = 34
(4+5)*6 = 9*6 = 54

If expressions in parentheses are nested, Visio evaluates the expression in the innermost set
of parentheses first.



Cell reference syntax

In a cell's formula, you can refer to a ShapeSheet cells of either the current shape or another
shape on the same page so that Visio calculates a value for one cell based on another cell's 
value.
Cell references can include shape IDs or names. You can always refer to any shape on the 
page by its ID, whether the shape is named or not. If a shape hasn't been named, its default 
name is Sheet.n, where n is the shape ID. The ID is assigned by Visio when the shape is 
created and does not change unless you move the shape to another page or document. 
If more than one shape on a page has the same name, you must include the ID assigned by 
Visio. To display the ID or enter a name, use the Special command.
Whether you can refer to a shape by name, and the exact syntax you'll use, depends on 
where the shape is in relation to the shape whose formula contains the reference. These 
general rules apply:

· If a shape is a peer of the shape whose formula you are editing, you can refer to that 
shape by name. If the peer shape is a group, you can refer by name to the group, but 
not its members. Neither can you refer by name to a shape's parent or its parent's 
peers.

· You can use Sheet.ID syntax to refer to any shape on the page, whether the shape is in
a group or is a parent of the shape.

ShapeSheet Cell reference Example
 Same shape Cellname Width
Named shape, group, or 
guide

Shapename!Cellname Star!Angle

Named shape, group, or 
guide in which more than 
one shape at the same level 
has the same name

Shapename.ID!Cellname Executive.2!TheText

Any shape on the page Sheet.ID!Cellname Sheet.8!FillForegnd
A cell in a particular column 
and row of a section

Section.ColumnRow Scratch.A5

A cell in a section with 
indexed rows

Section.Column[index] Char.Font[3]

A cell in the ShapeSheet of 
the page

ThePage!Cellreference ThePage!
User.Vanishing_Point

Sections, columns, and rows
Visio identifies rows with numbers and columns with letters. Unlike a conventional 
spreadsheet, however, the first two columns are X and Y. Visio identifies columns with A 
starting with the third column through W. Visio skips X and Y. Columns after Z are identified 
as in a conventional spreadsheet: AA, AB, through AZ, and so forth, but these cells can be 
accessed only programmatically, not through the ShapeSheet.



Local and inherited formulas

The formula you see in a cell can be one that is inherited from a master or a style, or a local 
formula that you enter in the cell. Visio uses inherited formulas whenever possible.
Rather than make a local copy of every formula in the ShapeSheet, an instance inherits 
formulas from its master on the local stencil and inherits formatting from the style definition 
stored with the drawing. This behavior results in smaller files, but also allows changes to the 
masters formulas or the style definition to be propagated to all instances.

Cells
Black text in a cell indicates an inherited formula. Blue text indicates a local formula, either 
the result of editing the formula in the ShapeSheet or some change to the shape that caused
Visio to reset the formula for that cell.

Local formulas
When you write a local formula in the ShapeSheet of an instance, you are replacing the 
inherited formula in the cell, which then no longer inherits its value from the master. An 
exception is when you apply a style, which always writes new values into the ShapeSheet 
and so can overwrite even locally edited cells. 

See also
Using inherited formulas



Error values

Visio displays error values in cells that have incorrect formulas for that cell.
If a formula references a cell that contains an error value, that formula also displays an error 
value. You can use the functions ISERR, ISERRNA, ISERROR, or ISERRVALUE to look for error 
values.

Error values
If the cell 
displays

The formula includes Example

#DIV/0! Division by zero 10/0
#VALUE! An argument or operand 

of the wrong type
5 + "House"

#REF! A reference to a cell that 
does not exist

A cell that refers to another 
cell that no longer exists

#NUM! An invalid number Square root of a negative 
number

#N/A! Not available value NA( ) function

See also
Cell reference syntax



Object Transform section

The Object Transform section contains general positioning information about a shape, for 
example, its width, height, angle, and center of rotation (pin); whether the shape has been 
flipped; and how the shape should behave when resized within a group.
The Object Transform section includes these cells:
Angle
FlipX
FlipY
Height
LocPinX
LocPinY
PinX
PinY
ResizeMode
Width



Width (Object Transform section)

Contains the width of the selected shape in drawing units. Visio's default formula for 
determining the width of a 1-D shape is: 

=SQRT((EndX-BeginX)^2+(EndY-BeginY)^2)



Height (Object Transform section)

The height of the shape in drawing units.



 Angle (Object Transform section)

The shape's current angle of rotation in relation to its parent. Visio's default formula for 
determining the rotation angle of a 1-D shape is: 

=ATAN2(EndY-BeginY,EndX-BeginX)



FlipX (Object Transform section)

Indicates whether the shape has been flipped horizontally. 
non-0 The shape has been flipped
0 The shape has not been flipped



FlipY (Object Transform section)

Indicates whether the shape has been flipped vertically. 
non-0 The shape has been flipped
0 The shape has not been flipped



PinX (Object Transform section)

The x-coordinate of the shape's pin (center of rotation) in relation to the origin of its parent. 



PinY (Object Transform section)

The y-coordinate of the shape's pin (center of rotation) in relation to the origin of its parent. 



LocPinX (Object Transform section)

The x-coordinate of the shape's pin (center of rotation) in relation to the origin of the shape. 
Visio's default formula for determining LocPinX is: 

=Width * 0.5



LocPinY (Object Transform section)

The y-coordinate of the shape's pin (center of rotation) in relation to the origin of the shape. 
Visio's default formula for determining LocPinY is: 

=Height * 0.5



ResizeMode (Object Transform section)

Shows the current resize behavior setting for the shape. For details, see the Behavior 
command. 

0 Use Group's Setting
1 Reposition Only
2 Scale With Group



Geometry section

The ShapeSheet's Geometry section lists the coordinates of the vertexes for the lines and 
arcs that make up the shape. If the shape has more than one path, the ShapeSheet contains 
a Geometry section for each path. To add this section to a ShapeSheet, use the Section 
command.
The Geometry section can include these cells:
ArcTo
EllipticalArcTo
LineTo
NoFill
NoShow
SplineKnot
SplineStart
Start



Start (Geometry section)

The x- and y-coordinates of the first vertex for the shape. Usually this is the first vertex 
placed when the shape was drawn, and it does not necessarily correspond to the beginning 
point of a 1-D shape.



LineTo (Geometry section)

The x-and y-coordinates of the ending vertex of a straight line segment.



EllipticalArcTo (Geometry section)

The x- and y-coordinates, control points, angle of eccentricity, and ratio of major and minor 
axes of an elliptical arc. 

X The x-coordinate of the ending vertex on the arc.
Y The y-coordinate of the ending vertex on the arc.
A The x-coordinate of the arc's control point¾the point through which the curve of the 

arc passes. The control point is best located between the beginning and ending 
vertexes of the arc. Otherwise, the arc may grow to an extreme size in order to pass 
through the control point, with unpredictable results. 

B The y-coordinate of the arc's control point.
C The angle of the arc's major axis relative to the drawing page. If the arc has not been 

rotated, this value is 0.
D The ratio of the arc's major axis to its minor axis. Ordinarily this value is greater than 

1, representing a major axis that is longer than the minor axis. If this value is less 
than 1, the major axis is shorter than the minor axis. Setting this cell to a value less 
than or equal to zero or greater than 1000 can lead to unpredictable results.



ArcTo (Geometry section)

The x- and y-coordinates and bow of a circular arc. When you first draw an arc in Visio, it is 
an elliptical arc, even if it is based on a circle. In the ShapeSheet the arc is indicated by an 
EllipticalArcTo row. The eccentricity handles of an elliptical arc are based on its height and 
width, so the arc changes shape when you drag the eccentricity handle.
To convert an elliptical arc to a circular arc, change the EllipticalArcTo to an ArcTo row using 
the Change Row Type command. When you drag the beginning or ending vertex of a circular 
arc, the arc changes size, but always remains the same portion of a circle.

X The x-coordinate of the ending vertex of the arc.
Y The y-coordinate of the ending vertex of the arc.
A The distance from the arc's bisector to the bow point, which is the point on the arc 

halfway between the arc's beginning vertex and ending vertex. 



NoFill (Geometry section)

The third cell in the Start row of a Geometry section. The NoFill cell indicates whether or not 
a shape can be filled. If TRUE, the shape's paths are open, so it cannot be filled. If FALSE, its 
paths are closed, so it can be filled.
The cell that appears to be GeometryN.A1 is actually GeometryN.NoFill (formerly 
GeometryN.X0). For compatibility with earlier versions of Visio, you can refer to this cell by 
either name (GeometryN.NoFill or GeometryN.X0.)



NoShow (Geometry section)

The fourth cell in the Start row of a Geometry section. The NoShow cell indicates whether or 
not a shape is displayed on the drawing page. If TRUE, the shape is hidden. If FALSE, the 
shape is shown.
The cell that appears to be GeometryN.B1 is actually GeometryN.NoShow (formerly 
GeometryN.A0). For compatibility with earlier versions of Visio, you can refer to this cell by 
either name (GeometryN.NoShow or GeometryN.A0.)



SplineKnot (Geometry section)

The x- and y-coordinates of the spline knots.
X The x-coordinate of a control point.
Y The y-coordinate of a control point.
A The location of the third or greater spline knot.

See also
SplineStart



SplineStart (Geometry section)

The x- and y-coordinates of the second control point of a spline.
The SplineStart row must be preceded by another kind of row, such as a Start row, to 
indicate the first control point of the spline. The preceding row can be a LineTo, ArcTo, or 
EllipticalArcTo row if the spline follows a segment of that type.

X The x-coordinate of the spline's second control point.
Y The y-coordinate of the spline's second control point.
A The second knot of the spline.
B The first knot of the spline.
C The last knot of the spline.
D The degree of the spline (an integer from 1 to 9).

See also
SplineKnot



Protection section

The Protection section shows the current lock settings set with the Protection command plus 
a few additional locks that can be set only in the ShapeSheet. Locking helps prevent 
inadvertent changes to the shape but does not prevent Visio from resetting values in other 
circumstances. It also does not protect against changes made in the ShapeSheet. 
To protect a formula from being changed by Visio under any circumstances, use the 
GUARD( ) function.
The Protection section includes these cells:
LockAspect
LockBegin
LockCalcWH
LockCrop
LockDelete
LockEnd
LockFormat
LockGroup
LockHeight
LockMoveX
LockMoveY
LockRotate
LockSelect
LockTextEdit
LockVtxEdit
LockWidth



 LockWidth (Protection section)

Locks the width of the shape so that its width remains unchanged when the shape is sized.
non-0 Width is locked 
0 Width is not locked



 LockHeight (Protection section)

Locks the height of the shape so that its height remains unchanged when the shape is sized.
non-0 Height is locked 
0 Height is not locked



 LockMoveX (Protection section)

Locks the horizontal position of the shape so it cannot be moved horizontally.
non-0 Horizontal position is locked 
0 Horizontal position is not locked



 LockMoveY (Protection section)

Locks the vertical position of the shape so it cannot be moved vertically.
non-0 Vertical position is locked 
0 Vertical position is not locked



 LockAspect (Protection section)

Locks the aspect ratio of the shape so the shape can only be sized proportionally; it cannot 
be sized in a single dimension.

non-0 Aspect ratio is locked
0 Aspect ratio is not locked



LockDelete (Protection section)

Locks the shape against being deleted. 
non-0 Shape cannot be deleted
0 Shape can be deleted



LockBegin (Protection section)

Locks the beginning point (BeginX and BeginY) of a 1-D shape to a specific location.
non-0 Beginning point is locked
0 Beginning is not locked



LockEnd (Protection section)

Locks the ending point (EndX and EndY) of a 1-D shape to a specific location.
non-0 Ending point is locked
0 Ending point is not locked



LockRotate (Protection section)

Locks the shape against being rotated with the rotation tool or the Rotate Left or Rotate 
Right command.

non-0 Shape cannot be rotated
0 Shape can be rotated

LockRotate does not prevent a 1-D shape from being rotated by dragging an endpoint. To 
lock a 1-D shape against rotation, set LockWidth to a non-zero value.



 LockCrop (Protection section)

Locks an object from another program against being cropped with the crop tool.
non-0 Shape cannot be cropped
0 Shape can be cropped



LockVtxEdit (Protection section)

Locks the vertexes of a shape so they cannot be edited with any tools on the toolbar.
non-0 Vertexes cannot be edited
0 Vertexes can be edited



LockTextEdit (Protection section)

Locks the text of a shape so it cannot be edited. However, the text may still be formatted by 
applying a style using the Font style list.

non-0 Text cannot be edited
0 Text can be edited



LockFormat (Protection section)

Locks the formatting of a shape so it cannot be changed.
non-0 Formatting cannot be changed
0 Formatting can be changed



LockGroup (Protection section)

Locks a group against editing.
non-0 Group cannot be edited
0 Group can be edited



LockCalcWH (Protection section)

Locks a shape's selection rectangle so it cannot be recalculated when a vertex is edited or a 
row type is changed in the Geometry section.

non-0 Width and height cannot be recalculated
0 Width and height can be recalculated



 LockSelect (Protection section)

Prevents a shape from being selected. In order for LockSelect to take effect, the Objects 
option must be checked in the Protect Document dialog box.

non-0 Shape cannot be selected
0 Shape can be selected



Line Format section

The Line Format section shows the current line formatting attributes for the shape, including 
pattern, weight, and color; whether the line ends are formatted (for example, with an 
arrowhead); the size of line end formats; the radius of the rounding circle applied to the line; 
and line cap style (round or square). Line formats can be set with the Line command, by 
applying a line style, or by entering a formula in a Line Format cell.
The Line Format section includes these cells:
ArrowSize
BeginArrow
EndArrow
LineCap
LineColor
LinePattern
LineWeight
Rounding



LineCap (Line Format section)

Indicates whether a line has rounded or square line caps. To set the line caps, type one of 
these numbers or use the Line command.

0 Rounded ends
1 Square ends



LinePattern (Line Format section)

The line pattern of the shape. To set the line pattern, type one of these numbers or use the 
Line command.

0 None
1 Solid
2 Dashed
3 Dotted
4 Dash-dot-dash
5 Dash-dot-dot-dash



LineWeight (Line Format section)

The line weight of the shape. To set the line weight, enter a number with valid units of 
measure or use the Line command. If the unit of measure is not entered, then the unit of 
measure for text specified in the Options dialog box is used. The line weight is independent 
of the scale of the drawing. If the drawing is scaled, the line weight remains the same.



LineColor (Line Format section)

The line color of the shape, identified by the number assigned to that color in the Color 
Palette dialog box. To set the line color, enter a number from 0 to 23 or use the Line 
command. To switch to a different color palette, use the Color Palette command.



BeginArrow (Line Format section)

Indicates whether a line has an arrowhead or other line end format at its first vertex. Enter a 
number from 0 to 11, or use the Line command. The size of the arrowhead is set in the 
ArrowSize cell.

0 No arrowhead
1 - 8 Assorted arrowhead styles
9 Slash 
10 Ball 
11 Square



EndArrow (Line Format section)

Indicates whether a line has an arrowhead or other line end format at its last vertex. Enter a 
number from 0 to 11, or use the Line command. The size of the arrowhead is set in the 
ArrowSize cell.

0 No arrowhead
1 - 8 Assorted arrowhead styles
9 Slash 
10 Ball 
11 Square



ArrowSize (Line Format section)

Indicates the size of the arrowhead set in BeginArrow and EndArrow. Enter a number from 0 
to 4, or use the Line command. 

0 Very small
1 Small
2 Medium
3 Large
4 Extra large



Rounding (Line Format section)

Indicates the radius of the rounding circle applied where two straight segments of a shape 
meet. For example, rounding can be used to give a rectangle rounded corners. To set 
rounding, enter a value with units of measure, or use the Line command. 



Fill Format section

The Fill Format section shows the current fill formatting attributes for the shape and the 
shape's drop shadow, including pattern, foreground color, and background color. Fill formats 
can be set with the Fill command, by applying a fill style, or by making an entry in a Fill 
Format cell.
The Fill Format section includes these cells:
FillBkgnd
FillForegnd
FillPattern
ShdwBkgnd
ShdwForegnd
ShdwPattern



 FillPattern (Fill Format section)

The fill pattern for the shape. To set the fill pattern, type one of these numbers or use the Fill
command.

0 None (transparent fill)
1 Solid foreground color
2 - 24 Assorted patterns



FillForegnd (Fill Format section)

The color used for the foreground (stroke) of the shape's fill pattern. To set the color, enter a 
number from 0 to 23. The number corresponds to a color in the current color palette, which 
is set with the Color Palette command.



FillBkgnd (Fill Format section)

The color used for the background (fill) of the shape's fill pattern. To set the color, enter a 
number from 0 to 23. The number corresponds to a color in the current color palette, which 
is set with the Color Palette command.



ShdwPattern (Fill Format section)

The fill pattern for the shape's drop shadow. To set the fill pattern, type one of these 
numbers or use the Fill command.

0 None (transparent fill)
1 Solid foreground color
2 - 24 Assorted patterns



ShdwForegnd (Fill Format section)

The color used for the foreground (stroke) of the shape's drop shadow fill pattern. To set the 
color, enter a number from 0 to 23. The number corresponds to a color in the current color 
palette, which is set with the Color Palette command.



ShdwBkgnd (Fill Format section)

The color used for the background (fill) of the shape's drop shadow fill pattern. To set the 
color, enter a number from 0 to 23. The number corresponds to a color in the current color 
palette, which is set with the Color Palette command.



Character section

The Character section shows the formatting attributes for the shape's text, including font, 
color, text style, case, position relative to the baseline, and point size. Text formats can be 
set with the Font command, by applying a text style, or by making an entry in a Character 
section cell.
The Character section includes these cells:
Case
Color
Font
Pos
Size
Style



Font (Character section)

The number of the font used to format the text. Font numbers vary according to the fonts 
installed on your system. The number 0 represents Visio's default font, which is Arial, unless 
you change the default font in the VISIO.INI file.



 Color (Character section)

The color used for the shape's text. To set the color, enter a number from 0 to 23. The 
number corresponds to a color in the current color palette, which is set with the Color Palette
command.



Style (Character section)

Shows the character formatting applied to the text in the shape's text block. The value 
represents a binary number in which each bit indicates a character style.

Bit: 8 4 2 1
Style: Small caps Underline Italic Bold

For example, a value of 3 represents text formatted in both italic and bold. If the value of 
Style is 0, the text is plain, or unformatted.
To test for a particular format, use the Boolean functions BITAND( ), BITNOT( ), BITOR( ),or 
BITXOR( ).



Case (Character section)

The case of a shape's text. All capitals (1) and initial capitals (2) do not change the 
appearance of text that was entered in all capital letters. The text must be entered in 
lowercase letters for these options to show an effect.

0 Normal case
1 All capital (uppercase) letters
2 Initial capital letters only



Pos (Character section)

The position of the shape's text relative to the baseline.
0 Normal position
1 Superscript
2 Subscript



Size (Character section)

The size of the text in the shape's text block, in the default units for text set in the Options 
dialog box. The text's size is independent of the scale of the drawing. If the drawing is 
scaled, the text size remains the same.



 Paragraph section

The Paragraph section shows the paragraph formatting attributes for the shape's text, 
including indents, line spacing, and horizontal alignment of paragraphs. Paragraph formats 
can be set with the Paragraph command, by applying a text style, or by making an entry in a
Paragraph section cell.
The Paragraph section includes these cells:
HAlign
IndFirst
IndLeft
IndRight
SpAfter
SpBefore
SpLine

The Paragraph section does not include cells for tab settings. To set tabs for a shape's text, 
use the Tabs command.



IndFirst (Paragraph section)

The distance the first line of each paragraph in the shape's text block is indented from the 
left indent of the paragraph. This value is independent of the scale of the drawing. If the 
drawing is scaled, the first line indent remains the same.



IndLeft (Paragraph section)

The distance all lines of text in each paragraph are indented from the left margin of the text 
block. This value is independent of the scale of the drawing. If the drawing is scaled, the left 
indent remains the same.



IndRight (Paragraph section)

The distance all lines of text in each paragraph are indented from the right margin of the 
text block. This value is independent of the scale of the drawing. If the drawing is scaled, the
right indent remains the same.



SpLine (Paragraph section)

The distance between one line of text and the next, expressed as a percentage, where 100%
is the height of a text line. SpLine can have these values:

>0 Absolute spacing, regardless of type size
=0 Set solid (spacing = 100% of type size)
<0 A percentage of type size (for example, -120% yields 120% spacing)

If SpLine is less than 100%, lines of text overlap. This value is independent of the scale of 
the drawing. If the drawing is scaled, the line spacing remains the same.



SpBefore (Paragraph section)

The amount of space inserted before each paragraph in the shape's text block, in addition to
any space from SpLine and, if it is the first paragraph in a text block, TopMargin. This value is
independent of the scale of the drawing. If the drawing is scaled, the Space Before setting 
remains the same.



SpAfter (Paragraph section)

The amount of space inserted after each paragraph in the shape's text block, in addition to 
any space from SpLine and, if it is the first paragraph in a text block, BottomMargin. This 
value is independent of the scale of the drawing. If the drawing is scaled, the Space After 
setting remains the same.



 HAlign (Paragraph section)

The horizontal alignment of text in the shape's text block. HAlign can have these values:
0 Left align
1 Center
2 Right align
3 Justify
4 Force justify

Justify adds spaces between words in every line of the paragraph except the last line to 
make both the left and right sides of text flush with the margins. Force justify justifies every 
line in the paragraph, including the last.



Text Block Format section

The Text Block Format section shows the alignment and margins of text in a shape's text 
block and includes these cells:
BottomMargin
LeftMargin
RightMargin
TextBkgnd
TopMargin
VerticalAlign



VerticalAlign (Text Block Format section)

The vertical alignment of text within the text block. VerticalAlign can have these values:
0 Top
1 Middle
2 Bottom



TopMargin (Text Block Format section)

The distance between the top border of the text block and the first line of text it contains. 
The default is 0.1 inches. This value is independent of the scale of the drawing. If the 
drawing is scaled, the top margin remains the same.



BottomMargin (Text Block Format section)

The distance between the bottom border of the text block and the last line of text it 
contains. The default is 0.1 inches. This value is independent of the scale of the drawing. If 
the drawing is scaled, the bottom margin remains the same.



 LeftMargin (Text Block Format section)

The distance between the left border of the text block and the text it contains. The default is
0.1 inch. This value is independent of the scale of the drawing. If the drawing is scaled, the 
left margin remains the same.



 RightMargin (Text Block Format section)

The distance between the right border of the text block and the text it contains. Visio's 
default is 0.1 inch. This value is independent of the scale of the drawing. If the drawing is 
scaled, the right margin remains the same.



TextBkgnd (Text Block Format Section)

The text background color for a shape. TextBkgnd can have any value between 0 and 24, or 
255. (0 and 255 indicate a transparent text background.) To select a color value, add 1 to 
the value displayed in the Color Palette dialog box.



Text Fields section

The Text Fields section displays custom formulas inserted in the shape's text using the Text 
Field command. Formulas appear in the Text Fields section in the order they were created, 
not the order they appear in the text. To add this section in the ShapeSheet, use the Section 
command.



 Text Transform section

The Text Transform section contains positioning information about a shape's text block. To 
add this section in the ShapeSheet, use the Section command.
The Text Transform section includes these cells:
TxtAngle
TxtHeight
TxtLocPinX
TxtLocPinY
TxtPinX
TxtPinY
TxtWidth



TxtWidth (Text Transform section)

The width of the text block. Visio's default formula is:
= Width*1

which evaluates to the width of the shape.



TxtHeight (Text Transform section)

The height of the text block. Visio's default formula is:
= Height*1

which evaluates to the height of the shape.



TxtAngle (Text Transform section)

The text block's current angle of rotation in relation to the x-axis of the shape. The default is 
0 degrees.



TxtPinX (Text Transform section)

The x-coordinate of the text block's center of rotation in relation to the origin of the shape. 
Visio's default formula is:

= Width*0.5 
which evaluates to the horizontal center of the shape.

See also
LocPinX
PinX
TxtLocPinX



TxtPinY (Text Transform section)

The y-coordinate of the text block's center of rotation in relation to the origin of the shape. 
Visio's default formula is:

= Height*0.5 
which evaluates to the vertical center of the shape.

See also
LocPinY
PinY
TxtLocPinY



TxtLocPinX (Text Transform section)

The x-coordinate of the text block's center of rotation in relation to the origin of the text 
block. Visio's default formula is:

= TxtWidth*0.5
which evaluates to the horizontal center of the text block.

See also
LocPinX
PinX
TxtLocPinY



TxtLocPinY (Text Transform section)

The y-coordinate of the text block's center of rotation relative to the origin of the text block. 
Visio's default formula is:

= TxtHeight*0.5
which evaluates to the vertical center of the text block.

See also
LocPinY
PinY
TxtLocPinX



 Scratch section

The Scratch section is a work area for entering and testing formulas that are referred to by 
other cells. To add this section in the ShapeSheet, use the Section command.
Cells in the Scratch section use units in two different ways. X and Y cells use drawing units; 
A through D cells are unitless. (In C programmers' jargon, X and Y cells are "typed" and cells 
A through D are "void.") The Scratch X and Y cells are often used for deriving x- and y-
coordinates, such as PinX and PinY, or the X and Y cells found in a Geometry section cell. 
Scratch cells A through D can display whatever units you specify.
A further difference is the way these cells store point values. A point in Visio is a single data 
package for an (x,y) coordinate. When a formula returns a point value, that value is 
interpreted in one of three ways, depending on the ShapeSheet cell the formula is in. Cells 
that relate to x-coordinates (for example, PinX, or cells in the X column of a Geometry 
section) extract just the x-coordinate part of a point value. Cells that relate to y-coordinates 
extract just the y-coordinate part of a point value. A cell that is unitless extracts the distance
from (0,0) to the point.
For example, Visio extracts the formula PNT(3,4) in these three ways:

Cell If you enter Visio treats it 
like

Result

X PNT(3,4) PNTX(PNT(3,4)) 3
Y PNT(3,4) PNTY(PNT(3,4)) 4
A-D PNT(3,4) SQRT(3^2+4^2) 5

Connection Points section

The Connection Points section contains cells for the x- and y-coordinates of each connection 
point defined for the shape. Coordinates of connection points are measured from the origin 
of the shape. To add this section in the ShapeSheet, use the Section command.



Controls section

The Controls section contains cells for the x- and y-coordinates of each control handle 
defined for a shape and cells that specify the way the control handle should behave.
The Controls section includes these cells:
Can Glue
X
X Behavior
X Dynamics
Y
Y Behavior
Y Dynamics



X (Controls section)

The x-coordinate that indicates the location of a shape's control handle.



Y (Controls section)

The y-coordinate that indicates the location of a shape's control handle.



X Dynamics (Controls section)

The x-coordinate for a control handle's anchor point. The anchor point is used for rubber-
banding during dynamics.

See also
X Behavior
Y Behavior
Y Dynamics



Y Dynamics (Controls section)

The y-coordinate for a control handle's anchor point. The anchor point is used for rubber-
banding during dynamics.

See also
X Behavior
X Dynamics
Y Behavior



X Behavior (Controls section)

Controls the type of behavior the x-coordinate of the control handle will exhibit after the 
handle is moved. These formulas are available:

Value Behavior Example 
formula

Definition

0 Proportional =Width * .33 The control handle can be moved, and it also
moves in proportion with the shape when it 
is stretched.

1 Proportional 
locked

=Width * .33 The control handle moves in proportion with 
the shape but the control handle itself 
cannot be moved.

2 Offset from 
left edge

=.3 The control handle is offset a constant 
distance from the left side of the shape.

3 Offset from 
center

Width/2 + .2 The control handle is offset a constant 
distance from the center of the shape.

4 Offset from 
right edge

Width - .4 The control handle is offset a constant 
distance from the right side of the shape.

See also
Y Behavior



Y Behavior (Controls section)

Controls the type of behavior the y-coordinate of the control handle will exhibit after the 
handle is moved. These formulas are available:

Value Behavior Sample 
formula

Definition

0 Proportional =Height*.33 The control handle can be moved, and it also
moves in proportion with the shape when it 
is stretched.

1 Proportional 
locked

=Height*.33 The control handle moves in proportion with 
the shape but the control handle itself 
cannot be moved.

2 Offset from 
bottom edge

=.3 The control handle is offset a constant 
distance from the bottom side of the shape.

3 Offset from 
center

Height/2 + .2 The control handle is offset a constant 
distance from the center of the shape.

4 Offset from 
top edge

Height - .4 The control handle is offset a constant 
distance from the top of the shape.

See also
X Behavior



Can Glue (Controls section)

Controls whether or not a control handle can be glued to other shapes.    
non-0 Control handle can be glued
0 Control handle cannot be glued



1-D Endpoints section

The 1-D Endpoints section contains x- and y-coordinates of the beginning point and ending 
point of a 1-D shape. This section appears in the ShapeSheet for 1-D shapes only.
BeginX
BeginY
EndX
EndY



BeginX (1-D Endpoints section)

The x-coordinate of the beginning point of the 1-D shape, in relation to the origin of its 
parent.

See also
Start



BeginY (1-D Endpoints section)

The y-coordinate of the beginning point of the 1-D shape, in relation to the origin of its 
parent.

See also
Start



 EndX (1-D Endpoints section)

The x-coordinate of the ending point of the 1-D shape, in relation to the origin of its parent.



 EndY (1-D Endpoints section)

The y-coordinate of the ending point of the 1-D shape, in relation to the origin of its parent.



Alignment section

The Alignment section indicates the alignment of a shape with respect to the guide or guide 
point to which the shape is glued. The Alignment section appears only in the ShapeSheets of
shapes that are glued to guides.
Formulas in this section refer to the Guide Info section of the ShapeSheet for the guide to 
which the shape is glued.
The Alignment section includes these cells:
AlignBottom
AlignCenter
AlignLeft
AlignMiddle
AlignRight
AlignTop



AlignLeft (Alignment section)

The horizontal position, relative to the origin of its parent, of a vertical guide or guide point 
to which the shape's left border is aligned.



 AlignCenter (Alignment section)

The horizontal position, relative to the origin of its parent, of a vertical guide or guide point 
to which the shape's horizontal center is aligned.



AlignRight (Alignment section)

The horizontal position, relative to the origin of its parent, of a vertical guide or guide point 
to which the shape's right border is aligned.



AlignTop (Alignment section)

The vertical position, relative to the origin of its parent, of a horizontal guide or guide point 
to which the shape's top border is aligned.



 AlignMiddle (Alignment section)

The vertical position, relative to the origin of its parent, of a horizontal guide or guide point 
to which the shape's vertical center is aligned.



AlignBottom (Alignment section)

The vertical position, relative to the origin of its parent, of a horizontal guide or guide point 
to which the shape's bottom border is aligned.



Guide Info section

The Guide Info section contains the x- and y-coordinates of a guide or guide point. Shapes 
that are aligned to the guide or guide point refer to its Guide Info section for their values.
The Guide Info section includes these cells:
GuideFlags
GuidePosX
GuidePosY



GuidePosX (Guide Info section)

The x-coordinate of a vertical guide or guide point relative to the origin of its parent. For a 
horizontal guide, this value is ignored.



GuidePosY (Guide Info section)

The y-coordinate of a horizontal guide or guide point relative to the origin of its parent. For a 
vertical guide, this value is ignored.



GuideFlags (Guide Info section)

Indicates whether the guide is vertical, horizontal, or a guide point. To change the guide's 
orientation, enter one of these values:

1024 Vertical guide
2048 Horizontal guide
3072 Guide point



 Image Info section

The Image Info section contains the width and height of an object from another program 
used in a Visio drawing and appears only in the ShapeSheet for such objects. It also 
indicates the distance the object's image is offset within its borders.
The Image Info section includes these cells:
ImgHeight
ImgOffsetX
ImgOffsetY
ImgWidth



ImgWidth (Image Info section)

The width of the object's image within its border. Visio's default formula is:
= Width*1. 

Cropping the object changes the factor by which Width is multiplied.



ImgHeight (Image Info section)

The height of the object's image within its border. Visio's default formula is:
= Height*1. 

Cropping the object changes the factor by which Height is multiplied.



ImgOffsetX (Image Info section)

The distance the object is offset horizontally from the origin of the object's border. The 
default is 0. Panning the object with the crop tool changes this value.



ImgOffsetY (Image Info section)

The distance the object is offset vertically from the origin of the object's border. The default 
is 0. Panning the object with the crop tool changes this value.



Events section

The Events section contains formulas that control shape events. Event cells are evaluated 
only when the event occurs, not upon formula entry.
The Events section includes these cells:
EventDblClick
EventDrop
EventXFMod
TheData
TheText



TheText (Events section)

An event cell associated with changes to a shape's text. The cell refers to the current shape 
unless it is preceded by a reference to another shape on the page.
TheText is reevaluated whenever the shape's text changes and can be used to trigger 
recalculations (for example, to recalculate the text width and height with the TEXTWIDTH( ) 
and TEXTHEIGHT( ) functions).
Note: Event cells are evaluated only when the event occurs, not upon formula entry.

See also
EventDblClick
EventDrop
EventXFMod
TheData



EventDblClick (Events section)

An event cell associated with a shape being double-clicked. The cell refers to the current 
shape unless it is preceded by a reference to another shape on the page.
Note: Event cells are evaluated only when the event occurs, not upon formula entry.

See also
EventDrop
EventXFMod
TheData
TheText



EventXFMod (Events section)

An event cell associated with a change in a shape's position or orientation on the page. The 
cell refers to the current shape unless it is preceded by a reference to another shape on the 
page.
Note: Event cells are evaluated only when the event occurs, not upon formula entry.
See also
EventDblClick
EventDrop
TheData
TheText



EventDrop (Events section)

An event cell associated with a shape being dropped on the drawing page, either as an 
instance or when a shape is duplicated or pasted. The cell refers to the current shape unless 
it is preceded by a reference to another shape on the page.
Note: Event cells are evaluated only when the event occurs, not upon formula entry.

See also
EventDblClick
EventXFMod
TheData
TheText



TheData (Events section)

TheData is reserved for future use.

See also
EventDblClick
EventDrop
EventXFMod
TheText



Miscellaneous section

The Miscellaneous section contains object properties for the selected shape, including 
selection highlighting and visibility. 
The Miscellaneous section includes these cells:
DynFeedback
HideText
NoAlignBox
NoCtrlHandles
NoObjHandles
NonPrinting
UpdateAlignBox



DynFeedback (Miscellaneous section)

Indicates the type of connector to display as you drag, showing the connector as it will 
appear when the mouse button is released.

0 Any connector other than a Universal Connector
1 The 3-legged Universal connector
2 The 5-legged Universal connector



NoObjHandles (Miscellaneous section)

Toggles the display of selection handles on and off for the selected shape. Upon setting this 
cell to a non-zero value (TRUE), the selection handles will not be displayed when the shape 
is selected.

non-0 Selection handles not displayed
0 Selection handles displayed



NoCtrlHandles (Miscellaneous section)

Toggles the display of control handles on and off for the selected shape. Upon setting this 
cell to a non-zero value (TRUE), the control handles will not be displayed when the shape is 
selected.

non-0 Control handles not displayed
0 Control handles displayed



NoAlignBox (Miscellaneous section)

Toggles the display of the selection rectangle on and off for the selected shape. Upon setting
this cell to a non-zero value (TRUE), the selection rectangle will not be displayed when the 
shape is selected.

non-0 Selection rectangle not displayed
0 Selection rectangle displayed



NonPrinting (Miscellaneous section)

Toggles printing on and off for the selected shape. Upon setting this cell to a non-zero value 
(TRUE), the shape will be displayed in the drawing window but will not print.

non-0 Printing disabled
0 Printing enabled



UpdateAlignBox (Miscellaneous section)

Recalculates the selection rectangle whenever a control handle is moved.

See also
NoAlignBox



HideText (Miscellaneous section)

Hides the text for a shape. Upon setting this cell to a non-zero value (TRUE), the text does 
not appear on the screen and does not print. You can view text, edit properties, and apply 
styles to the text in the text block, although the changes will not appear until you reset 
HideText to 0 (FALSE).

non-0 Text is hidden
0 Text is not hidden

See also
TEXTHEIGHT( )
TEXTWIDTH( )





Glue Info section

The Glue Info section contains formulas generated for a 1-D shape by Visio when the 1-D 
shape is glued to other shapes. The section contains the following cells:
BegTrigger
EndTrigger
GlueType
WalkPreference



GlueType (Glue Info section)

Determines whether a 1-D shape uses static (point-to-point) or dynamic (shape-to-shape) 
glue when it is glued to another shape.

0 Uses static glue.
1 Unassigned.
2 Unassigned.
3 Uses dynamic glue. Visio writes default formulas in the BegTrigger and 

EndTrigger cells.

See also
BegTrigger
EndTrigger



WalkPreference (Glue Info section)

Determines whether an endpoint of a 1-D shape moves to a horizontal or vertical connection
point on the shape it is glued to, using dynamic glue, when the shape is moved to an 
ambiguous position.

0 Both endpoints of the 1-D shape move to horizontal connection points (side-
to-side connections).

1 The begin point of the 1-D shape moves to a vertical connection point, and the
end point moves to a horizontal connection point (top-to-side or bottom-to-
side connections).

2 The begin point of the 1-D shape moves to a horizontal connection point, and 
the end point moves to a vertical connection point (side-to-top or side-to-
bottom connections).

3 Both endpoints of the 1-D shape move to vertical connection points (top-to-
bottom connections).



BegTrigger (Glue Info section)

Contains a trigger formula generated by Visio that determines whether to move the begin 
point of a 1-D shape to maintain its connection to another shape.
When you glue a 1-D shape to another shape using dynamic glue, Visio generates a formula 
that refers to the EventXFMod cell of the other shape. When that shape is changed, Visio 
recalculates any formula that refers to its EventXFMod cell, including the formula in the 
BegTrigger cell. Other formulas in the ShapeSheet for the 1-D shape refer to the BegTrigger 
cell and move the begin point of the 1-D shape or alter the shape as needed.

See also
End Trigger



EndTrigger (Glue Info section)

Contains a trigger formula generated by Visio that determines whether to move the end 
point of a 1-D    shape to maintain its connection to another shape.
When you glue a 1-D shape to another shape using dynamic glue, Visio generates a formula 
that refers to the EventXFMod cell of the other shape. When that shape is changed, Visio 
recalculates any formula that refers to its EventXFMod cell, including the formula in the 
EndTrigger cell. Other formulas in the ShapeSheet of the 1-D shape refer to the EndTrigger 
cell and move the end point of the 1-D shape or alter the shape as needed.

See also
Beg Trigger



Actions section

The Actions section defines a custom command name that appears on a shape's or page's 
shortcut menu and specifies the action that the command takes. 
The section contains the following cells:
Action
HelpTopic
Menu
Prompt



Action (Actions section)

Contains the formula to be executed when a user chooses the command name defined in 
the corresponding Menu cell.
Note: Action cells are evaluated only when the action occurs, not upon formula entry.

See also
HelpTopic
Menu
Prompt



HelpTopic (Actions section)

Determines the help topic to be displayed for the shortcut menu command. To display help, 
enter a formula using one of the following syntaxes:

filename.hlp!keyword
filename.hlp!#number

Filename is the Windows help file, keyword is the index term associated with the help 
topic, and number is a numeric ID that is referenced in the MAP section of the help project 
file (HPJ). 
For information on developing Microsoft Windows online Help, see the Microsoft Software 
Development Kit (SDK) documentation.
Note: Action cells are evaluated only when the action occurs, not upon formula entry.

See also
Action
Menu
Prompt



Menu (Actions section)

Defines the name of the command that appears on a shape's or page's shortcut menu. 
Prefix the command name with an underscore character (_) to display a divider bar above 
the command in the menu. Prefix the name with a percent character (%) to display the 
command at the bottom of the shortcut menu.
Note: Action cells are evaluated only when the action occurs, not upon formula entry.

See also
Action
HelpTopic
Prompt



Prompt (Actions section)

Specifies a descriptive prompt that appears in the status bar when a user selects the 
corresponding shortcut command.
Note: Action cells are evaluated only when the action occurs, not upon formula entry.

See also
Action
HelpTopic
Menu



Custom Properties section

The Custom Properties section contains cells for associating data with a shape. 
The section contains the following cells:
Ask
Format
Invisible
Label
Prompt
Prop.Row
SortKey
Type
Value



Ask (Custom Properties section)

Determines whether a user is queried to enter custom property information for a shape 
when an instance is created or the shape is duplicated or copied. If true, Visio displays the 
Custom Properties dialog box every time any of these events is triggered.

non-0 Ask user to enter custom property data
0 Do not ask user to enter data

See also
Format
Invisible
Label
Prompt
Prop.Row
SortKey
Type
Value



Format (Custom Properties section)

Specifies the formatting of custom property whose data type is string (Type = 0), number 
(Type = 2), fixed list (Type = 1), or variable list (Type = 4).
"format" If the value of the Type cell is 0 or 2 (string or number), specify any formatting

code that is valid syntax for the FORMAT function.
"item;...;item"If the value of the Type cell is 1 or 4 (fixed or variable list), specify the items to

appear in the list, separated by semicolons.

See also
Ask
Invisible
Label
Prompt
Prop.Row
SortKey
Type
Value



Invisible (Custom Properties section)

Specifies whether the custom property is visible in the Custom Properties dialog box.
non-0 Custom property is not visible
0 Custom property is visible

See also
Ask
Format
Label
Prompt
Prop.Row
SortKey
Type
Value



Label (Custom Properties section)

Specifies the label that appears to users in the Custom Properties dialog box. A label 
consists of alphanumeric characters, including the underscore (_) character.
Visio automatically encloses the Label string in quotation marks in the ShapeSheet, but the 
quotation marks are not displayed in the dialog box.
If no label text is found, Visio displays the row name (Prop.Row) in the dialog box.

See also
Ask
Format
Invisible
Prompt
Prop.Row
SortKey
Type
Value



Prompt (Custom Properties section)

Specifies descriptive or instructional text that appears to users in the Custom Properties 
dialog box when the property is selected.

See also
Ask
Format
Invisible
Label
Prop.Row
SortKey
Type
Value



Prop.Row (Custom Properties section)

Specifies the row label, which appears in the ShapeSheet window in red text. For example, 
type Price in the formula bar to create the custom property Prop.Price. 
You can use this name in cell references to refer to the value in the Value cell of the 
corresponding row. You can also use this name to reference other cells in the same row by 
including their column name, for example, Prop.Price.Prompt.

See also
Ask
Format
Invisible
Label
Prompt
SortKey
Type
Value



SortKey (Custom Properties section)

Specifies a key by which items in the Custom Properties dialog box are listed. The sort is 
locale specific, case insensitive and descending. The sort key is a string, which Visio 
automatically encloses in quotation marks.
For example, enter the following sort keys to display the custom properties in the dialog box 
in the order Item Number, Quantity, Price:

Row Label SortKey
Prop.Item Item 

Number
1

Prop.Price Price 3
Prop.Quan Quantity 2

See also
Ask
Format
Invisible
Label
Prompt
Prop.Row
Type
Value



Type (Custom Properties section)

Specifies a data type for the custom property value.
0 String. This is the default.
1 Fixed list. Visio displays the list items in a dropdown combo box in the Custom 

Properties dialog box. Specify the list items in the Format cell. Users can select
only one item from the list.

2 Number. Specify a number format in the Format cell.
3 Boolean. Visio displays FALSE and TRUE as items users can select from a 

dropdown list box in the Custom Properties dialog box.
4 Variable list. Visio displays the list items in a dropdown combo box in the 

Custom Properties dialog box. Specify the list items in the Format cell. Users 
can select a list item or enter a new item that will be added to the current list 
in the Format cell.

See also
Ask
Format
Invisible
Label
Prompt
SortKey
Value



Value (Custom Properties section)

Contains the property's value as entered in the Custom Properties dialog box. 
You can enter a formula in this cell, but its value will be overwritten by the value entered in 
the Custom Properties dialog box, even if you use the GUARD function to protect the 
formula.

See also
Ask
Format
Invisible
Label
Prompt
Prop.Row
SortKey
Type



Layer Membership section

The Layer Membership section contains one row that lists each layer to which the shape is 
assigned. 
The layer assignment is shown as an index to the list of layers on the page. The layer index 
corresponds to a layer name in the Layers dialog box. The first name in the dialog box is 
layer 0, the second is layer 1, and so forth. 
If a shape is assigned to more than one layer, each layer index appears in the Layer 
Membership cell separated by a semicolon.

See also
Layer Properties



Layer Properties section

The Layer Properties section shows all layers defined for the page and the properties set for 
each layer. This section is a page property that can be viewed only in the ShapeSheet of a 
page. It contains the following cells, which correspond to the options in the Layer Properties 
dialog box:
Active
Color
Glue
Lock
Print
Snap
Visible



Active (Layer Properties section)

Specifies whether the layer is the default active layer. Shapes without preassigned layers are
assigned to the active layer when dropped on the drawing page. Corresponds to the Active 
option in the Layer Properties dialog box.

non-0 Active layer
0 Not an active layer

See also
Color
Glue
Lock
Print
Snap
Visible



Color (Layer Properties section)

Specifies the index of the color used to display the layer. Corresponds to the Layer Color 
option in the Layer Properties dialog box.

See also
Active
Glue
Lock
Print
Snap
Visible



Glue (Layer Properties section)

Specifies whether shapes belonging to the layer can be glued. Corresponds to the Glue 
option in the Layer Properties dialog box.

non-0 Glue is enabled
0 Glue is disabled

See also
Active
Color
Lock
Print
Snap
Visible



Lock (Layer Properties section)

Specifies whether shapes belonging to the layer are locked against being selected or edited. 
Corresponds to the Lock option in the Layer Properties dialog box.

non-0 Shapes are locked
0 Shapes are not locked

See also
Active
Color
Glue
Print
Snap
Visible



Print (Layer Properties section)

Specifies whether shapes belonging to the layer can be printed. Corresponds to the Print 
option in the Layer Properties dialog box.

non-0 Shapes can be printed
0 Shapes cannot be printed

See also
Active
Color
Glue
Lock
Snap
Visible



Snap (Layer Properties section)

Specifies whether shapes belonging to the layer snap to the grid. Corresponds to the Snap 
option in the Layer Properties dialog box.

non-0 Shapes snap to grid
0 Shapes do not snap to grid

See also
Active
Color
Glue
Lock
Print
Visible



Visible (Layer Properties section)

Specifies whether shapes belonging to the layer are visible on the drawing page. 
Corresponds to the Visible option in the Layer Properties dialog box.

non-0 Shapes are visible
0 Shapes are hidden

See also
Active
Color
Glue
Lock
Print
Snap



Ruler & Grid section

The Ruler & Grid section shows the current settings of the page's rulers and grid. This 
section is a page property that can be viewed only in the ShapeSheet of a page. It contains 
the following cells, which correspond to the settings in the Ruler & Grid dialog box:
XGridDensity
XGridOrigin
XGridSpacing
XRulerDensity
XRulerOrigin
YGridDensity
YGridOrigin
YGridSpacing
YRulerDensity
YRulerOrigin



XGridDensity (Ruler & Grid section)

Specifies the type of horizontal grid to use. Corresponds to the Horizontal Grid Spacing 
option in the Ruler & Grid dialog box.

2 Coarse
4 Normal (default)
8 Fine
0 Fixed

Note: If an invalid value is entered, it functions the same as 4.

See also
XGridOrigin
XGridSpacing
XRulerDensity
XRulerOrigin
YGridDensity
YGridOrigin
YGridSpacing
YRulerDensity
YRulerOrigin



XGridSpacing (Ruler & Grid section)

Specifies the distance between horizontal lines in a fixed grid (XGridDensity = 0). 
Corresponds to the Horizontal Minimum Spacing option in the Ruler & Grid dialog box.

See also
XGridDensity
XGridOrigin
XRulerDensity
XRulerOrigin
YGridDensity
YGridOrigin
YGridSpacing
YRulerDensity
YRulerOrigin



XGridOrigin (Ruler & Grid section)

Specifies the horizontal coordinate of the grid origin. Corresponds to the Horizontal Grid 
Origin option in the Ruler & Grid dialog box.

See also
XGridDensity
XGridSpacing
XRulerDensity
XRulerOrigin
YGridDensity
YGridOrigin
YGridSpacing
YRulerDensity
YRulerOrigin



XRulerDensity (Ruler & Grid section)

Specifies the horizontal subdivisions on the ruler for the page. Corresponds to the Horizontal 
Subdivision option in the Ruler & Grid dialog box.

32 Fine
16 Normal
8 Coarse

Note: If an invalid value or no value is entered, it functions the same as 16.

See also
XGridDensity
XGridOrigin
XGridSpacing
XRulerOrigin
YGridDensity
YGridOrigin
YGridSpacing
YRulerDensity
YRulerOrigin



XRulerOrigin (Ruler & Grid section)

Specifies the zero point on the x-axis ruler for the page. Corresponds to the Horizontal Ruler 
Zero option in the Ruler & Grid dialog box.

See also
XGridDensity
XGridOrigin
XGridSpacing
XRulerDensity
YGridDensity
YGridOrigin
YGridSpacing
YRulerDensity
YRulerOrigin



YGridDensity (Ruler & Grid section)

Specifies the type of vertical grid to use. Corresponds to the Vertical Grid Spacing option in 
the Ruler & Grid dialog box.

2 Coarse
4 Normal
8 Fine
0 Fixed

Note: If an invalid value is entered, it functions the same as 4.

See also
XGridDensity
XGridOrigin
XGridSpacing
XRulerDensity
XRulerOrigin
YGridOrigin
YGridSpacing
YRulerDensity
YRulerOrigin



YGridOrigin (Ruler & Grid section)

Specifies the vertical origin of the grid. Corresponds to the Vertical Grid option in the Ruler &
Grid dialog box.

See also
XGridDensity
XGridOrigin
XGridSpacing
XRulerDensity
XRulerOrigin
YGridDensity
YGridSpacing
YRulerDensity
YRulerOrigin



YGridSpacing (Ruler & Grid section)

Specifies the distance between vertical lines in a fixed grid (YGridDensity = 0). Corresponds 
to the Vertical Minimum Spacing option in the Ruler & Grid dialog box.

See also
XGridDensity
XGridOrigin
XGridSpacing
XRulerDensity
XRulerOrigin
YGridDensity
YGridOrigin
YRulerDensity
YRulerOrigin



YRulerDensity (Ruler & Grid section)

Specifies the vertical subdivisions on the ruler for the page. Corresponds to the Vertical 
Subdivision option in the Ruler & Grid dialog box.

32 Fine
16 Normal
8 Coarse

Note: If an invalid value or no value is entered, it functions the same as 16.

See also
XGridDensity
XGridOrigin
XGridSpacing
XRulerDensity
XRulerOrigin
YGridDensity
YGridOrigin
YGridSpacing
YRulerOrigin



YRulerOrigin (Ruler & Grid section)

Specifies the zero point on the y-axis ruler for the page. Corresponds to the Vertical Ruler 
Zero option in the Ruler & Grid dialog box.

See also
XGridDensity
XGridOrigin
XGridSpacing
XRulerDensity
XRulerOrigin
YGridDensity
YGridOrigin
YGridSpacing
YRulerDensity



Page Properties section

The Page Properties section describes page attributes. 
The section contains the following cells:
DrawingScale
PageHeight
PageScale
PageWidth
ShdwOffsetX
ShdwOffsetY



DrawingScale (Page Properties section)

The value of the drawing unit in the current drawing scale. The drawing scale for the page is 
the ratio of the page unit shown in the PageScale cell to the drawing unit. This cell 
corresponds to the settings in the Size & Scale dialog box.

See also
PageHeight
PageScale
PageWidth
ShdwOffsetX
ShdwOffsetY



PageHeight (Page Properties section)

The height of the printed page in drawing units as set in the Size & Scale dialog box.

See also
DrawingScale
PageScale
PageWidth
ShdwOffsetX
ShdwOffsetY



PageScale (Page Properties section)

The value of the page unit in the current drawing scale. The drawing scale for the page is 
the ratio of the page unit to the drawing unit shown in the DrawingScale cell. This cell 
corresponds to the settings in the Size & Scale dialog box.

See also
DrawingScale
PageHeight
PageWidth
ShdwOffsetX
ShdwOffsetY



PageWidth (Page Properties section)

The width of the printed page drawing units as set in the Size & Scale dialog box.

See also
DrawingScale
PageHeight
PageScale
ShdwOffsetX
ShdwOffsetY



ShdwOffsetX (Page Properties section)

The distance in page units that a shape's drop shadow is offset horizontally from the shape. 
This value is set in the Page Properties dialog box.

See also
DrawingScale
PageHeight
PageScale
PageWidth
ShdwOffsetY



ShdwOffsetY (Page Properties section)

The distance in page units that a shape's drop shadow is offset vertically from the shape. 
This value is set in the Page Properties dialog box.

See also
DrawingScale
PageHeight
PageScale
PageWidth
ShdwOffsetX



User-Defined Cells section

The User-Defined Cells section is a work area for entering and testing formulas that are 
referred to by other cells and add-ons. The section contains the following cells:
Prompt
User.Row
Value



Value (User-Defined Cells section)

Specifies a value for the corresponding user-defined cell. To refer to this value in another 
cell, specify the user-defined name entered in the row label User.Row.

See also
Prompt
User.Row



Prompt (User-Defined Cells section)

Specifies a descriptive prompt or comment for the user-defined cell. Visio automatically 
encloses the prompt text in quotation marks (" ") to indicate that it is a text string.
If you type an equal sign (=) and omit the quotation marks, you can enter a formula in this 
cell that Visio evaluates.

See also
User.Row
Value



User.Row (User-Defined Cells section)

Specifies the user-defined cell name for the value contained in the Value cell of the same 
row. The cell name you enter must be unique within the section. For example, type Offset in 
the formula bar to create the cell name User.Offset.

See also
Prompt
Value

 



The Visio main window

When you start Visio, the Visio main window appears. 
· If you started Visio from the Visio 4.0 command on the Start menu, Visio also displays the

New dialog box, in which you can choose options to create a drawing or stencil file or 
open an existing file. If you choose to create a drawing based on a template, the drawing
window contains a stencil and a drawing page.

· If you started Visio from a template on the Start menu, the drawing window contains a 
stencil and a drawing page.

Menu bar and toolbar
The menu bar contains menus of commands that you can use to create and change 
drawings. The toolbar contains buttons that set and change Visio options and tools you can 
use to create and format shapes and text.
The toolbar and menu bar vary depending on the currently active window (drawing, 
ShapeSheet, stencil, edit icon, or print preview). In addition, the toolbar can vary depending 
on the display resolution of your monitor, which tools you are using, the size of the main 
window, and which toolbar you are using (Microsoft Office, Lotus SmartSuite, or Novell 
PerfectOffice).

ToolTips
A ToolTip appears when you pause with the pointer over items on the toolbar, status bar, 
control handles on a shape, or master shapes on a stencil window when the stencil is set to 
display icons only.
You can turn the display of ToolTips on and off by using the Toolbars command on the View 
menu.

Status bar
The status bar at the bottom of the main window displays a status prompt. When the pointer
is over the stencil window or when a menu is open, the status bar suggests possible actions 
that you can perform in Visio and displays information about what you are doing. Check the 
status bar frequently for helpful messages, such as information about a shape's position and
angle.

Standard Windows features
The Visio main window has standard features such as the Close button

 and the Minimize/Maximize button at the 



upper-right corner. You can also use scroll bars to scroll through a large drawing in the 
drawing window. For details about these and other standard Windows features, see your 
Windows documentation.

See also
Arranging Visio windows
Quitting Visio
Starting Visio



Drawing window

You create a drawing in the drawing window. The drawing window displays a single drawing 
page on a blue background called the pasteboard. 

Drawing tools
You create a drawing by dragging and dropping master shapes from stencils or by using the 
drawing tools on the toolbar to create your own shapes.

Toolbars
You can format text and graphics quickly by using tools on Visio's toolbars. The content of 
the toolbar varies depending on whether a drawing or stencil window is active, the display 
resolution of your monitor, which tools you are using, the size of the main window, and 
whether you're using the Microsoft Office, Lotus SmartSuite, or Novell PerfectOffice toolbar.

Rulers and grids
The drawing window has rulers that show measurements at the scale of the drawing. You 
can also use the rulers as a source for guides and guide points. The drawing page displays 
the grid like those on traditional quadrille paper.
You can turn the display of rulers and the grid on and off with the Rulers and Grid commands
on the View menu. Intervals on the grid correspond to the unit of measure you set with the 
Options command on the Tools menu. You control the size of the intervals using the Ruler & 
Grid command on the Tools menu. 

See also
Arranging Visio windows
Dragging and dropping master shapes
Opening a stencil
Stamping master shapes
Starting a new drawing with a template
Starting a new drawing without a template



 Stencil window

The stencil looks much like a traditional stencil. Master shape icons¾small representations of
master shapes that you drag and drop into the drawing¾are displayed in rows on the 
stencil's characteristic green background. By default, stencils open as read-only and docked.
You can view stencils as docked (on the right or left side of the drawing window) or as 
floating.

Modifying stencils
If you want to modify master shapes, you need to open a copy or original stencil. To open an 
original stencil, choose the Stencils command from the File menu and choose Original in the 
Open option. To open a copy, choose Open from the File menu, then choose Copy in the 
Open option. When you open an original or a copy of a stencil file and activate the stencil 
window, commands for the stencil window are available.

Closing stencils
To close a stencil, right-click the stencil title bar, then choose Close from the menu.

Master shapes and icons
Many of the master shapes in Visio stencils are SmartShapes. To find out how to use a 
shape, right-click it (on the drawing page or the stencil), then choose Shape Help from the 
shortcut menu.
Master shape icons provide clues about how to use the shape:
· A yellow background identifies a connector¾a 1-D shape that is designed for connecting 

two 2-D shapes.

Menu commands
View menu
Icons And Names
Icons Only
Names Only
Auto Arrange
Master menu
New Master
Edit Master
Properties
Edit Icon
Update Icon
Window menu
Arrange Icons
Show Drawing Page
See also
Arranging master shapes in a stencil
Arranging stencils
Arranging Visio windows
Creating a master shape from a shape in a drawing
Creating a new stencil
Dragging and dropping master shapes
Opening a stencil
Opening an original stencil



Specifying a shape's double-click behavior



ShapeSheet window

When you select a shape or an object from another program and choose Show ShapeSheet 
from the Window menu, Visio opens the ShapeSheet window.
When the ShapeSheet window is active, menus display commands for programming shape 
behavior and controlling formulas that the ShapeSheet displays.
What you see in the ShapeSheet window depends on the shape itself and what you have set 
to display. When a ShapeSheet cell is selected, a formula bar appears, which you use to 
enter and edit ShapeSheet formulas.

ShapeSheet formula bar
Every shape you draw with Visio and object you insert from another program has a 
ShapeSheet. When you create a group, Visio retains the ShapeSheet for each shape or 
object in the group and creates a separate ShapeSheet for the group. In the ShapeSheet you
can change Visio's default formulas and set other properties to control the way the shape or 
object behaves.

Menu commands
Edit menu
Delete Section
Delete Row
Change Row Type
Action
View menu
Values
Formulas
Sections
Insert menu
Section
Row
Row After
Name
Function
Shape menu
Custom Properties
See also
Arranging Visio windows
Creating formulas
Displaying a ShapeSheet
Understanding ShapeSheets



The Enter box accepts changes you make to a formula.



The Cancel box cancels changes you make to a formula.



Visio displays formulas in the formula bar. To change a formula, click a cell and type.



 Edit icon window

When you choose Edit Icon from the Master menu, Visio opens a window where you can edit 
the icon for the master shape selected in the stencil window. The window's title bar identifies
the stencil and master shape.

Icon bitmaps
The window displays the master shape icon as a bitmap that you can edit pixel by pixel. As 
you edit the icon, changes appear in the stencil window. When you finish editing the icon, 

click  to close the window.

Window details and tools
The edit icon window displays the solid colors defined in Visio's default color palette plus the 
stencil background color. (The stencil background color is green unless you change it in the 
VISIO.INI file.) To edit an icon, use these tools:
Left Color box
Right Color box
Icon pencil tool
Paint bucket tool
Lasso tool
Selection net tool
See also
Changing the colors for a master shape icon
Creating a master shape icon



Group window

When you select a group and choose the Open Group command from the Edit menu, Visio 
displays the group in the group window. The group is displayed as if it were an entire 
drawing of independent shapes. The shapes appear without rotation applied to the group so 
you can use the grid, guides, and rulers.
You can select and edit the shapes individually by using the same menus and tools as in the 
drawing window. Changes you make in the group window appear in the drawing window.
To readjust the width and height of the group so its selection rectangle contains all the 
group's shapes, choose Update Alignment Box from the Tools menu.

See also
Editing and formatting a group
Editing the shapes in a group
Formatting and adding text to a shape in a group
Grouping and ungrouping shapes



Print preview window

When you choose Print Preview from the File menu, Visio displays the active drawing page in
the print preview window. Visio displays the drawing within the margins you set in the Page 
Setup dialog box.
If the drawing size is larger than the page size, the drawing is tiled and page breaks are 
displayed at the tile borders. To view a single tile, click the tile you want to see.
You can use the First Tile, Previous Tile, Next Tile, and Last Tile commands to move from tile 
to tile or page to page.
To exit the print preview window, click the Close button or press the Esc key.

Toolbars
When the print preview window is active, the toolbar displays buttons you can use to change
the display of the window.
For details about the toolbar buttons and tools, pause with the pointer over a button to 
display a ToolTip. 
Or, click the Help button on the toolbar, then click the toolbar button you want.

Help button
Menu commands
View menu
Single Tile
Zoom In
Zoom Out
Previous Tile
Next Tile
See also
Arranging Visio windows
Previewing a drawing before you print
Setting margins
Showing page breaks
 



Toolbar

The toolbar provides buttons you can use as shortcuts for choosing menu commands. To 
switch between the Microsoft Office, Lotus SmartSuite, and Novell PerfectOffice toolbars, 
right-click anywhere on the toolbar.
To display help about a specific button, choose the Help button, and then click a toolbar 
button.

See also
Switching toolbar sets



Status Bar

The status bar displays information about shapes and a status prompt. When you select a 
shape, the status bar displays its dimensions. When you pause the pointer over a shape on 
the stencil, the status bar displays a description about the shape.
For additional information about how to use a shape, right-click a shape (on the drawing 
page or a stencil), then choose Shape Help from the shortcut menu.

See also
Setting display options



Scroll bars

Use scroll bars to scroll through a large drawing or to display more shapes in a stencil. The 
box on the scroll bars tells you where you are in the drawing.

See also
Zooming in and out of a drawing



Drawing page

You create a drawing on the drawing page, which is contained in the drawing window. The 
drawing page is surrounded by a blue background called the pasteboard. The drawing page 
can display a grid, which consists of grid lines like those on traditional quadrille paper.
The drawing page titlebar is located at the top of the drawing window. The title bar lists the 
page name and number. If you maximize the drawing window, the page name and number 
are displayed in the Visio main window.

See also
Setting page display options
Starting a new drawing with a template



Rulers

The rulers show measurements at the scale of the drawing. You can also use the rulers as a 
source for guides and guide points.

See also
Ruler & Grid
Setting display options



Stencil

Stencils contain master shapes. You create drawings in Visio by dragging shapes from a 
stencil and dropping them onto the drawing page.
Many of the master shapes in Visio stencils are SmartShapes. These shapes are designed to 
act the way you need them to in a particular context.

      SmartShapes
By default, stencils open as read-only and docked. You can view stencils as docked or 
floating.
To close a stencil, right-click the stencil title bar, then choose Close from the menu.
Tip: To find out how to use a shape on a stencil, right-click it, then choose Shape Help from 
the shortcut menu.
If you open a copy or original stencil, Visio opens it in the stencil window.

See also
Opening an original stencil
Opening stencils



Visio title bar

The title bar has standard features such as the Close button

 and the Minimize/Maximize button at the 
upper-right corner.

See also
Arranging Visio windows
Quitting Visio



Pasteboard

The pasteboard is the blue background located behind a drawing page in the drawing 
window. You can use the pasteboard to store shapes. Each page has its own pasteboard.

See also
Dragging shapes to another drawing
Drawing window



Text block

The box with a dashed line and a flashing I-beam cursor indicates the shape's text block is 
open. To close the text block, click away from the shape or press the Esc key. 
You can add text to any shape (including lines and connectors). To add text to a shape, 
select the shape and type. If the shape contains text, the existing text is replaced by the 
text you type.
You can also select, edit, copy, and paste text from one shape to another, check the spelling 
of text, and search for and replace text much as you do with many word-processing 
programs. 

See also
Aligning text in the text block
Typing text into shapes



Drawing placeholder

When you have no drawings open, the gray area is a placeholder for a new or existing 
drawing.
See also
Starting a new drawing with a template
Starting a new drawing without a template



 




