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Introducing the Visio Flowchart Converter

You've switched to Visio, the premier all-purpose business drawing tool. Now, you're 
wondering what to do with all the charts you've created using a specialized charting 
program such as ABC FlowCharterÔ or CorelFLOWÔ. That's where the Visio Flowchart 
Converter comes in.
Using the Flowchart Converter, you can open ABC FlowCharter version 2.0, 3.0, and 4.0 files 
and CorelFLOW version 2.0 files from within Visio and convert them to Visio drawings. Once 
you save the converted drawings within Visio, you can use all of Visio's powerful features to 
modify them.
When you convert, the essential features of your charts are preserved:

· Shapes that were connected in the original charts remain connected.
· Text from the originals appears in the converted drawings.
· Page numbers and page sizes stay the same.
· Clip art and custom shapes are placed in Visio as graphic images.
· ABC FlowCharter shapes that are linked to documents are still linked in the converted 

drawings.
Visio includes stencils filled with shapes that match all of the shapes that ship with ABC 
FlowCharter 3.0 and many of the shapes that ship with CorelFLOW. Because matching 
shapes exist in Visio, you have the option of converting ABC FlowCharter or CorelFLOW 
shapes to Visio SmartShapes, shapes that behave intelligently.

See also
Converting ABC FlowCharter charts
Converting CorelFLOW charts



Converting ABC FlowCharter charts

Visio Flowchart Converter converts ABC FlowCharter 2.0, 3.0, or 4.0 files to Visio drawings.
To convert an ABC FlowCharter chart to a Visio drawing:

1. From the File menu, choose Open, and then under List Files Of Type, choose ABC 
FlowCharter (.AF2 or.AF3), and select the file.

2. Select the conversion option you want, click Retain Shape Numbers if you want shape 
numbers in the converted file, and then click OK.
Visio monitors the progress and lets you know when the conversion is complete.

3. The converted diagram opens in Visio. From the File menu, choose Save. In the Save 
box, name the converted Visio file.

See also
How Visio converts ABC FlowCharter shapes
When ABC FlowCharter conversion results aren't what you expect



Converting CorelFLOW charts

Visio Flowchart Converter converts CorelFLOW 2.0 files to Visio drawings.
To convert a CorelFLOW chart to a Visio drawing:

1. From the File menu, choose Open, and then under List Files Of Type, choose CorelFLOW
(.CLF), and select the file.

2. Select the conversion option you want, and then click OK.
Visio monitors the progress and lets you know when the conversion is complete.

3. The converted drawing opens in Visio. From the File menu, choose Save. In the Save 
box, name the converted Visio file.

See also
How Visio converts CorelFLOW shapes
When CorelFLOW conversion results aren't what you expect



Learning to speak Visio

Some Visio terms may be new to ABC FlowCharter users. The following table matches ABC 
FlowCharter terms to corresponding Visio terms.

ABC term: Visio term:
charts drawings
palettes stencils

See also
Converting ABC FlowCharter charts
How Visio converts ABC FlowCharter shapes
When ABC FlowCharter conversion results aren't what you expect



Learning to speak Visio

Some Visio terms may be new to CorelFLOW users. The following table matches CorelFLOW 
terms to corresponding Visio terms.

Corel term: Visio term:
charts drawings
smart libraries stencils
symbols shapes

See also
Converting CorelFLOW charts
How Visio converts CorelFLOW shapes
When CorelFLOW conversion results aren't what you expect



How Visio converts ABC FlowCharter shapes

When you convert an ABC FlowCharter chart that uses shapes from the palettes, you have 
the option of converting these shapes to Visio SmartShapes rather than Windows Metafiles. 
If you create custom shapes with ABC FlowCharter that do not have matching Visio shapes, 
they convert to Windows Metafiles instead of Visio SmartShapes.
Windows Metafiles look almost exactly like the original ABC FlowCharter shapes, but there 
are benefits to converting ABC FlowCharter shapes to Visio SmartShapes:

· SmartShapes behave intelligently when they are moved or resized. For example, when 
you lengthen an arrow in Visio, the arrowhead won't resize. 

· You can modify SmartShapes using any of Visio's editing tools. For example, you can 
add patterns, fills, colors, and text to SmartShapes and you can flip, rotate, and resize 
them.

See also
Converting ABC FlowCharter charts



How Visio converts CorelFLOW shapes

When you convert a CorelFLOW chart that uses only symbols from the flowchart, 
organization chart, or network diagram smart libraries, you have the option of converting 
these CorelFLOW symbols to Visio SmartShapes.
If your CorelFLOW chart uses symbols from other smart libraries or custom symbols you've 
created yourself, matching shapes won't exist in Visio. These unmatched symbols will 
convert to graphic images, however, and you can edit these graphic images the same way 
you can edit Visio SmartShapes; they just don't behave intelligently in the same way Visio 
SmartShapes do.

See also
Converting CorelFLOW charts



When ABC FlowCharter conversion results aren't what you expect

Click on any of the following topics to solve your conversion problems.

Chart name, date, or time
Colors
Fields
Fonts
Guides
Line nodes and line crossovers
Links
OLE objects
Patterns
Shape numbers
Strikethrough text



Chart name, date, or time

My chart name, date, and time look different in the Visio drawing.
ABC FlowCharter chart names convert into Visio text fields that update automatically when 
you move Visio drawings to new locations. ABC FlowCharter dates and times convert into 
Visio date and time fields that update whenever you edit the Visio drawing.



Colors

The colors from my chart don't look the same in the Visio drawing.
ABC FlowCharter colors convert to the closest available color on the Visio color palette. You 
can create new or modify existing color palettes in Visio.
To learn how to create custom colors in Visio, see the topic "Choosing a color palette" in Visio
online Help.



Fields

The fields from my ABC FlowCharter version 4.0 chart disappeared when I 
converted.
Fields do not convert and will not appear in the converted Visio drawing.



Fonts

The fonts from my ABC FlowCharter version 4.0 chart appear in Arial.
If a font in the ABC FlowCharter chart isn't installed on your computer, it will default to Arial.



Guides

The guides in my ABC FlowCharter chart disappeared when I converted.
Guides do not convert. Reset the guides in the Visio drawing.



Line nodes and line crossovers

The line nodes and line crossovers from my ABC FlowCharter chart disappeared.
Line nodes and line crossovers do not convert and will not appear in the converted Visio 
drawing.



Links

I had a link from one of my ABC FlowCharter shapes to another ABC FlowCharter 
chart. The link was broken when I converted.
If a shape in an ABC FlowCharter chart is linked to another ABC FlowCharter chart, both the 
chart the shape is in and the chart it is linked to must be converted to Visio drawings for the 
link to be preserved in Visio.

See also
Linking to other pages and documents



OLE objects

The OLE linked or embedded object in my ABC FlowCharter chart disappeared 
when I converted.
OLE embedded or linked objects do not convert. Re-embed or re-link them from within Visio.



Patterns

The patterns from my chart don't look the same in the Visio drawing.
Patterned fills convert to the most similar available pattern in Visio.



Shape numbers

Shape numbers from my ABC FlowCharter shapes appear in different places in the
Visio shapes.
When you convert an ABC FlowCharter shape with a shape number, the number becomes 
the first line of text in the text block in the corresponding Visio shape.
To learn how to draw an independent Visio text block, see the topic "Adding independent 
text to a drawing" in Visio online Help.



Strikethrough text

The strikethrough text I used in my ABC FlowCharter chart disappeared.
Visio does not support strikethrough text. If your original chart includes strikethrough text, it 
converts to regular text in a Visio drawing.



When CorelFLOW conversion results aren't what you expect

Click the category into which your conversion problem fits.
Arrowheads
Colors
Layers
OLE objects
Shapes
Strikethrough text



Arrowheads

The arrowheads on my arrows don't look the same in Visio as they did in 
CorelFLOW.
Line ends, such as arrowheads, convert to the most similar line end available in Visio, if 
there is a similar one. If no similar line end is available, line ends convert to plain lines to 
which you can add Visio line ends.



Colors

The colors from my chart don't look the same in the Visio drawing.
Custom colors you created in CorelFLOW convert to the closest available color on the Visio 
color palette. You can create new or modify existing color palettes in Visio.
To learn how to create custom colors in Visio, see the topic "Choosing a color palette" in Visio
online Help.



Layers

My symbols were on different layers in my CorelFLOW chart. In the Visio drawing, 
they're all on the same page.
Layers do not convert. Every symbol from a CorelFLOW chart is placed on one layer in Visio. 
If you want the Visio shapes on different layers, place them on Visio's different layers.



OLE objects

The OLE linked or embedded object in my CorelFLOW chart disappeared when I 
converted.
OLE embedded or linked objects do not convert. Re-embed or re-link them from within Visio.



Shapes

Even though I chose the "Visio drawing with SmartShapes" conversion option, my 
CorelFLOW shapes converted to graphic images.
When you installed Visio, you may not have installed all of the stencils. To allow CorelFLOW 
shapes to convert to Visio SmartShapes, you need to run Visio SETUP.EXE, choose a custom 
installation, and install all the templates.



Strikethrough text

The strikethrough text I used in my CorelFLOW chart disappeared.
Visio does not support strikethrough text. If your original chart includes strikethrough text, it 
converts to regular text in a Visio drawing.



A Visio shape or connector that behaves intelligently when you move or resize it. For 
example, the arrowhead on this shape won't resize if the arrow is stretched. In Visio, you can
program any shape to behave predictably.



Linking to other pages and documents

Shapes in ABC FlowCharter charts can be linked to other documents. In general, these links 
are preserved when you convert ABC FlowCharter files to Visio files.
If the link is to another ABC FlowCharter document, that document must also be converted 
to a Visio document or the link will be lost.
Once you've converted an ABC FlowCharter chart to a Visio diagram, you can add and 
modify links. You can also link a shape to another page in your Visio drawing.

To add or modify a document link:
1. Select a shape on the Visio drawing page.
2. From the Tools menu, choose Run Add-on.
3. Choose Link To Document.
4. Select the file in the Link To Document dialog box, and then choose OK.

To add a link to another page:
1. Select a shape on the Visio drawing page.
2. From the Tools menu, Run Add-on submenu, choose then Link To Page from the list.
3. Choose the page you want to link to in the Page Name list, and then click OK.

To activate a link:
1. Double-click a shape in a Visio diagram to go to the linked page or to open the linked 

document.
Note: Visio does not convert Ctrl+double-click links or OLE-embedded links.

See also
Converting ABC FlowCharter charts



Visio Flowchart Converter

You can convert the shapes that ship with ABC FlowCharter 2.0, 3.0, or 4.0 to either Visio 
SmartShapes or Windows Metafiles (.WMF). By default, Visio converts ABC FlowCharter shapes
it recognizes to Visio SmartShapes and custom-made shapes it doesn't recognize to 
Windows Metafiles.

DIALOG BOX OPTIONS
Visio Drawing With SmartShapes. Converts ABC FlowCharter shapes into Visio 
SmartShapes. Visio SmartShapes behave intelligently, and you can format, rotate, and size 
them, as well as edit them in other ways.
Visio Drawing With Graphic Images. Converts ABC FlowCharter shapes to Windows 
Metafiles, which look almost exactly like the original shapes. Windows Metafiles don't 
behave intelligently, and the ways you can edit them are limited. The Visio Flowchart 
Converter adds a text block to each Windows Metafile so you can add or modify existing 
text.
Retain Shape Numbers. Check this option to bring numbers associated with ABC 
FlowCharter shapes into the converted Visio drawing.
Note: In Visio, you can't apply fills or formats to Windows Metafiles. Also, Windows Metafiles 
cannot be flipped or rotated. For more information about Windows Metafiles, see the Visio 
online Help.

See also
Converting ABC FlowCharter charts
How Visio converts ABC FlowCharter shapes
When ABC FlowCharter conversion results aren't what you expect



Visio Flowchart Converter

You can convert many of the shapes that ship with CorelFLOW 2.0 to either Visio 
SmartShapes or graphic images. By default, Visio converts CorelFLOW shapes it recognizes 
to Visio SmartShapes and custom-made shapes it doesn't recognize to graphic images.

DIALOG BOX OPTIONS
Visio Drawing With SmartShapes. Converts your CorelFLOW shapes into Visio 
SmartShapes you can edit.
Visio Drawing With Graphic Images. Converts your CorelFLOW symbols into Visio shapes
without the intelligence of Visio SmartShapes. You can edit the graphic images the same 
way you edit SmartShapes; they just don't behave intelligently the way SmartShapes do.

See also
Converting CorelFLOW charts
How Visio converts CorelFLOW shapes
When CorelFLOW conversion results aren't what you expect



Link To Document 

DIALOG BOX OPTIONS
File Name. Lists files of the type specified in the List Files Of Type box. To link to a file, 
choose from the list, or type a path and filename in the box.
Directories. Displays the current directory. Double-click the directory you want to open (or 
double-click to return to a parent directory).
List Files Of Type. Lists the file types you can link to, identified by their filename 
extension: Visio Drawing (.VSD), ABC FlowCharter Files (.AF*), All Programs (.EXE), and All Files 
(*.*). To change the type, choose from the list.
Drives. Displays the current drive. To change the drive, choose from the list.

See also
Linking to other pages and documents

 




