
Introducing Visio

This booklet shows you the basics of creating diagrams in the
Visio® drawing application. It assumes you are using Microsoft®
Windows® 95. If you’re using Windows 3.x or Windows NT, what
you see onscreen may differ slightly from the pictures in this booklet,
but the steps you take in Visio are the same. For more details about
working in Visio, see the online Help or Creating Business Diagrams
with Visio.

Table of Contents

The Big Picture ..................................................................................... 3

Starting a Diagram ............................................................................... 4

Adding and Arranging Shapes ............................................................. 6

Opening More Stencils ......................................................................... 8

Connecting Shapes ............................................................................. 10

Adding Text ......................................................................................... 12

Drawing Your Own Shapes ................................................................ 14

Modifying Shapes ............................................................................... 16

Working Smart.................................................................................... 18

Previewing and Printing Your Diagram ............................................ 20

Saving and Closing a File .................................................................... 21

More Visio Tips ................................................................................... 22

Read Me
For instructions on using Acrobat, choose Acrobat Reader Help from the Help menu.Printing We recommend that you print this document in sections. Printing the entire document may cause printing errors due to insufficient memory.If you're printing to a Laserjet 4 using a HP Laserjet 4 printer driver, you need to change these printer options: 1. From the File menu, choose Print Setup.2. In the Print Setup dialog box, click the Options button.3. In the Graphics Mode section, choose the Raster option.4. Click OK to exit the Options dialog box.5. Click OK.Note: Acrobat only supports PostScript and PCL printers.





I N T R O D U C I N G   V I S I O   3

T H E  B I G  P I C T U R E
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Start a diagram by opening
a template.

Arrange shapes to create the
diagram you want.

Add text to shapes and inde-
pendent text for titles.

Modify the look of shapes.

For diagrams such as flowcharts,
glue shapes so that they remain
connected regardless of where the
shapes are located.

Add shapes by dragging them
from the stencil and dropping
them on the drawing page.

Draw your own shapes.

Include your diagram in another pro-
gram or print it.
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S T A R T I N G  A  D I A G R A M

When you create a diagram in Visio, you generally begin by opening
a template. A template is like a kit for building a particular type of
diagram.

Templates open stencils you’ll need to create a diagram. Stencils con-
tain master shapes that are typically used to create the selected
diagram. For example, when you open the Office Layout template,
Visio opens a stencil containing shapes used to create office layouts—
desks, tables, computers, modular panels, and so on.

Templates also open and set up drawing pages, styles, and the draw-
ing scale for a particular type of diagram. Using a template is
especially important when you’re creating a scaled diagram, such as
an office layout, where shapes represent real objects.

Tip: You can automate creating many diagram types using one of
Visio’s Wizards. For details, see the online Help: press F1, click
Search, then type “wizards” to view a list of related topics.
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Start Visio
1. If you’re using Windows 95, click Start,

choose Programs, choose Visio.

If you’re using Windows 3.x, double-
click the Visio icon in the Windows
Program Manager.

2. From the New box, under Based On,
choose a template, then click OK.

The Visio window
A Toolbar

B Stencil

C Master shape

D Rulers

E Drawing page

F Status bar

G Scroll bars

A

E

F

When you open a template, Visio opens a stencil and a drawing window
that contains a blank drawing page.

B
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G
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Add a shape to a diagram
1. With a template open, point to a

master shape in the stencil window
and press the left mouse button.

2. Hold down the mouse button and drag
the shape to the drawing page, then
release the mouse button.

A D D I N G  A N D  A R R A N G I N G  S H A P E S

To use a shape, drag the shape from the stencil and drop it on the
drawing page. If you don’t know what a shape is or how to use it,
right-click it, then choose Shape Help from the shortcut menu.

After you add a shape, you can move it to the location you want and
change its size. For example, you can add a wall, move it to where you
want, and then resize it to the correct length. Some shapes cannot
be sized because they must be proportional to other shapes in
a diagram.

For details, see the online Help: press F1, click Search, then type
“shapes” or “handles” to view a list of related topics.

�

Begin your diagram by dragging
shapes from the stencil to the
drawing page.

�
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�

Move and size a shape
1. With a template open, drag a shape

from the stencil and drop it on the
drawing page.

2. To move the shape, point inside it on
the drawing page, select it by pressing
the left mouse button, drag it to
where you want, then release the
mouse button.

The pointer turns white when it’s over
a shape.

3. To size a selected shape, point to a
selection handle until the pointer
changes to a double arrow, then drag
the handle to change the size.

Get help on a shape
1. Right-click a shape (on the stencil or

drawing page), then choose Shape Help
from the shortcut menu.

Click anywhere away from the Shape
Help window to close it.

�

Drag a corner handle to resize a shape proportionally.

�

Shape Help opens a window that tells
you how to use a shape.

�
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O P E N I N G  M O R E  S T E N C I L S

You can use any stencil you want to add shapes to your diagram; you
aren’t limited to the stencil that’s opened by the template you start
with. Open stencils can be:

• Docked, so they are attached to the left or right side of the
drawing window.

• Floating, so that you can move them anywhere on the screen.

When you open multiple stencils, they are docked by default on the
left side of the drawing window, and the stencil names are stacked in
a column. To view the shapes on a stencil, click the stencil’s name.

For details, see the online Help: press F1, click Search, then type
“stencils” to view a list of related topics.
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Open another stencil
1. From the File menu, choose Stencils.

Or, click the Stencils button on the
toolbar.

2. Under Select Stencil, choose a stencil,
then click OK.

3. To switch stencils, click the name of
the stencil you want to view.

4. To close a stencil, right-click its title
bar, then choose Close from the
shortcut menu.

� �

�

The stencils switch order so you can see the one you clicked.

�

Tip: To make a stencil float, right-click its title bar, then choose Float
from the shortcut menu.
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C O N N E C T I N G  S H A P E S

For certain types of diagrams, connecting shapes is a must. You can
glue shapes so that they stay connected even when a shape is moved.
For example, when shapes in an organization chart are connected,
you can arrange the shapes on a page without changing the hierarchy
established by the connections.

If you know how shapes should be arranged and connected, you can
connect as you drag. Or, you can drag and drop the shapes you want,
arrange them, and then connect them.

For details, see the online Help: press F1, click Search, then type
“connecting shapes” to view a list of related topics.

Lorem
Ipsum

Dolor
Amet

Nonummy
Nibh

Ad
Minim

Original organization chart

Lorem
Ipsum Dolor

Amet

Nonummy
Nibh

Ad
Minim

Organization chart rearranged, but with the same connections
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Connect shapes as you drag
1. With a template open, choose the

connector tool from the toolbar.

2. Drag a shape from the stencil and
drop it on the drawing page.

3. While the shape is still selected, drag
another shape from the stencil and
drop it on the drawing page.

The shapes are automatically connected.

Connect existing shapes
1. Use the pointer tool to drag two

shapes you want from the stencil and
drop them on the drawing page.

2. From the stencil, drag a connector
shape and drop it on the drawing
page.

3. Drag one of the connector’s endpoints
to a connection point on a shape, then
drag the other endpoint to a
connection point on the other shape.

The connection points turn red when
they’re glued.

When the pointer tool is over an
endpoint, it changes to a four-headed
arrow.

� �

� Shapes remain connected even
if you change their position
on the page.

�

�

�
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Type text in a shape
1. With a template open, drag a shape

from the stencil and drop it on the
drawing page.

2. With the shape selected, type the text
you want.

If the shape is not selected, click it to
select it, then type.

3. When you’re finished, press the Esc
key or click away from the shape.

Tip: If you are viewing a reduced page,
Visio zooms by default to 100% when you
type text.

A D D I N G  T E X T

Every shape, including lines and connectors, can have text, and the
text can be formatted to suit your needs. To add text to a shape, you
click the shape and then type. To add a title or other text not associ-
ated with a shape, you click with the text tool where you want to start
the text and then type.

When you rotate or move a shape, its text rotates and moves with it.

To quickly change the look of a shape’s text, select the shape, then
choose an option from a style list or click a text style button on the
toolbar. You can also use the commands on the Format menu.

Also, Visio provides several kinds of fields that update automatically.
You can include fields in a diagram to hold information that’s diffi-
cult to update by hand. For example, a field can contain the current
date or time.

For details, see the online Help: press F1, click Search, then type “text
and text blocks” or “fields” to view a list of related topics.

LoremLorem

Click the shape and type.

�

�

Lorem ip
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Change the format of text
1. With a template open, use the pointer

tool to drag a shape from the stencil
and drop it on the drawing page.

2. From the Format menu, choose Font,
choose the settings you want, then
click OK.

Type independent text
1. From the toolbar, choose the text tool.

2. Click the drawing page where you want
the text to start, then type.

� �

Lorem ip

Create independent text to title your diagram.

�

�

Format text’s size, font, and style. Lorem
ipsum
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D R A W I N G  Y O U R  O W N  S H A P E S

Visio takes the frustration out of drawing by hand. You can choose
from a variety of easy-to-use drawing tools.

This tool Draws this shape

Pencil tool

Line tool

Arc tool

Freeform tool

Rectangle tool

Ellipse tool
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Draw a square
1. Point to the pencil tool on the toolbar

and hold down the left mouse button.

2. Choose the rectangle tool from the
drawing tool menu.

3. Press the Shift key while you drag
diagonally to draw a square, and then
release the mouse button.

Draw a freeform shape
1. To draw a freeform shape, choose the

freeform tool from the drawing tool
menu.

2. Drag in various directions to draw a
freeform shape, then release the mouse
button.

3. To edit the freeform shape, while the
shape is still selected, point to a
control point, then drag.

You can also use the pencil tool to
edit any shape.

� � �

SHIFT

Drawing tool menu

� �

Rectangle tool

�
Control points

When you first draw a shape with any tool, don’t be concerned
if it doesn’t look exactly right. You can edit the shape later
using the pencil tool.
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Change the look of a shape
1. With a template open, drag a shape

from the stencil and drop it on the
drawing page.

2. With the shape selected, choose a new
color from the Fill style list on the
toolbar.

3. From the Line style list on the toolbar,
choose a new line style.

M O D I F Y I N G  S H A P E S

You can quickly modify a shape by changing the look of its line, fill,
or text or by flipping or rotating the shape.

The boxes in the style toolbar show the shape’s current text, line, and
fill styles, and you choose new styles from the toolbar style lists.

Text style list

Fill style list
Click the box to
display the style
list to choose a
different style.

Line style list

For details, see the online Help: press F1, click Search, then type “for-
matting shapes” to view a list of related topics.

�

� �
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Flip a shape horizontally
1. With a template open, drag an

asymmetrical shape from the stencil
and drop it on the drawing page.

2. From the Shape menu, choose Flip
Horizontal.

Or, click the Flip Horizontal button on
the toolbar.

Rotate a shape
1. With a template open, drag a shape

from the stencil and drop it on the
drawing page.

2. From the toolbar, choose the rotation
tool, then select the shape.

As the pointer moves over a rotation
handle, the pointer changes to a round
arrow.

3. Drag a rotation handle to rotate the
shape.

�

�

You can flip, reverse, or rotate shapes so
they face the proper direction.

�

�

�
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Add smarts to a shape
1. Draw a shape with the drawing tools.

2. Select the shape, then, from the Tools
menu, choose Run Add-on, then choose
SmartShape Wizard (Shpsmart).

3. Follow the instructions onscreen.

Tip: You can also use the SmartShape
Wizard to modify the existing smarts of a
Visio shape.

Visio adds smarts to a copy of your shape
and also retains the original shape.

W O R K I N G  S M A R T

You can create your own stencils and templates, in addition to those
that come with Visio. Create your own stencils if you want to mix
and match shapes from several stencils and store them in one place,
store a new set of shapes for a particular type of diagram unique to
your business, or store a shape that you’ve modified.

Create your own template if you frequently use the same stencils,
styles, and page settings in your diagrams.

Many shapes that come with Visio have special behavior, such as ar-
rows with heads that keep their shape even when you stretch the
arrow. Every shape, including the shapes you draw, is backed by a
ShapeSheet. You can enter formulas in the ShapeSheet to create spe-
cialized “smart” behavior. The SmartShape Wizard automates some
of this work for you.

For details, see the online Help: press F1, click Search, then type
“templates,” “stencils,” or “shapesheets” to view a list of related topics.

� �

�
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� �

Create a new stencil
1. Draw a shape using the drawing tools.

2. From the File menu, choose New.

3. Under New, click Stencil. From Based
On, choose No Stencil, then click OK.

4. From the Window menu, choose Tile.

5. Drag the shape from the drawing page
onto the new stencil.

6. With the stencil selected, and with the
shape selected on the stencil, choose
Properties from the Master menu.

7. Under Master Name, type a name, then
click OK.

8. Click the stencil title bar, then choose
Save from the File menu.

9. Type a name for the stencil, choose
where you want to save it, then click
Save. Enter properties information, then
click OK.

�

� �

�

� �

�



20 V I S I O   B A S I C S

P R E V I E W I N G  A N D  P R I N T I N G  Y O U R  D I A G R A M

It’s a good idea to preview your diagram before you print to ensure
you’ll get the results you want. For a large drawing, Visio automati-
cally tiles the diagram across multiple pages.

Tip: In Visio, you can set the page and printer orientation separately.
If they are different and you print, you may not get the results you
expected. To set them to match, from the Edit menu, choose Draw-
ing Page, then choose Size & Scale. Under Drawing Size, choose Same
As Printer, then click OK.

For details, see the online Help: press F1, click Search, then type “pre-
viewing printed drawings” to view a list of related topics.

Preview and print your diagram
1. Open a file you want to preview

and print.

2. From the File menu, choose Print
Preview.

3. When you’re finished, click the Close
button on the toolbar.

4. From the File menu, choose Print,
then click OK.

�

The preview image reflects the current settings
in the Page Setup dialog box.

� � �
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S A V I N G  A N D  C L O S I N G  A  F I L E

When you have done substantial work on a diagram, you should save
the file. When you change a stencil or template, you should also save
these files.

In addition, if you want a file to always open specific stencils in a par-
ticular arrangement, you can save your workspace. You can save a
workspace within a drawing, stencil, or template file or as a
workspace file.

For details, see the online Help: press F1, click Search, then type
“saving files” to view a list of related topics.

Save and close the diagram
1. After you have created a new file,

choose Save from the File menu.

2. Type a name for the file, click Save,
enter properties information, then click
OK.

3. From the File menu, choose Close.

�

�

�
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M O R E  V I S I O  T I P S

This booklet touches on just a few of the many powerful features in
Visio. Here are a few more features you may want to explore.

Copying and applying formatting

If you’re pleased with the formatting of a particular shape, you can
quickly transfer the formatting (such as line, fill, and text styles) to
another shape instead of starting from scratch. Select the shape that
has the formatting you like, click the Format Painter button on the
toolbar, and then select the shape you want to format.

For details, see the online Help: press F1, click Search, then type “for-
mat painter tool” to view a list of related topics.

Checking the spelling of text

To ensure a professional diagram, check the spelling of text in shapes,
independent text, and stencil shape names. (From the Tools menu,
choose Spelling.)

For details, see the online Help: press F1, click Search, then type
“spelling check” to view a list of related topics.

Creating evenly spaced shapes

To quickly duplicate a shape at a specific distance from the original,
point to the shape on the drawing page, hold down the Ctrl key, and
then drag the shape. To make another copy, duplicating the offset
(the space between the shapes), press F4.

Finding and replacing text

Make global changes to your diagram by finding and replacing text in
shapes, stencil shapes, file properties, and data fields. (From the Edit
menu, choose Find or Replace.)

For details, see the online Help: press F1, click Search, then type
“finding text” or “replacing text” to view a list of related topics.
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Using backgrounds and layers

A background is a page that appears behind another page. A layer
is a way of organizing shapes in your drawing. Backgrounds and
layers can be used in similar ways.

Use a background page when you want the same text or shape on
multiple pages within the same file. For example, you can have
your corporate logo on every page that shares the background. For
details see the online Help: press F1, click Search, then type
“background pages” to view a list of related topics.

Use layers when you want to have categories of text and shapes
within the same page. For example, an architectural drawing of a
house can be composed of a wall layer, plumbing layer, and
electrical layer. In addition, you can view and print specific layers.
For details see the online Help: press F1, click Search, then type
“layers on pages” to view a list of related topics.

For details, see the online Help: press F1, click Search, then type
“foreground pages,” “background pages,” or “layers” to view a list of
related topics.

Using Visio with the Microsoft Office Binder

In Microsoft Office for Windows 95, you can create a file that com-
bines pages from multiple programs. For example, a single file can
include pages from Microsoft Word, Visio, and Microsoft Excel.

For details, see your Microsoft Office online Help.

Including Visio in other documents

Use object linking and embedding (OLE) to include a Visio diagram
in another program, such as Microsoft Word, and to include objects
from other programs in your Visio file.

For details, see the online Help: press F1, click Search, then type “ole
objects” to view a list of related topics.
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Converting ABC FlowCharter and CorelFlow diagrams to Visio

If you created diagrams in ABC FlowCharter (2.0, 3.0, or 4.0) or
CorelFlow 2.0, you can open them in Visio and convert them to Visio
diagrams.

For details, see the online Help: press F1, click Search, then type
“converting” to view a list of related topics.

Adding database information to a shape

You can add database information to a shape by defining fields in its
ShapeSheet and then entering data using the Custom Properties dia-
log box (on the Shape menu). For example, you can add price and
item number information to a Chair master shape.

For details, see the online Help: press F1, click Search, then type “cus-
tom properties” to view a list of related topics.

Using OLE Automation to control Visio

More advanced users, such as developers or program managers, can
customize the Visio user interface as well as use OLE Automation to
control Visio.

For details, see the online Help: press F1, click Search, then type “ole
automation” to view a list of related topics.
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