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It is our sincere hope that this help system is beneficial to you.    Many people have 
been frustrated with help screens and we at Rentek have tried to give WinPaint a 
system that is more help-full.    We have tried to avoid stating the obvious and to focus in
on the not-so-obvious.    It is designed to be simple and easy-to-read, with a lighthearted
touch.    May it prove useful to you!
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 Summary of Features
WinPaint is not an all-encompassing, feature-packed, deluxe graphics package.    On 
the contrary, WinPaint is a fairly simple bitmap editor, intended to build upon the good-
natured qualities of Microsoft Paintbrush and fill in some of the gaps.

WinPaint offers:

Multiple bitmaps open at the same time.
Multiple views of the same bitmap.
Direct Open and Save to the Clipboard (no more fighting with Copy/Paste 
commands).
Quick Restore command to reload bitmaps from disk.
All features available in zoomed views.
Touch-up corrections to lines or shapes drawn out of place, in the wrong color, 
etc.    Even accidental clicks of the mouse can be easily reversed (e.g. Undo).
Extensive keyboard support.

We strongly recommend that you read through the Tips and Tricks topic, which points 
out some of the more subtle features of WinPaint.



 Tips and Tricks
Some features of WinPaint shine most when they are used together.    This topic is 
meant to help you get into "high gear" with WinPaint.

When you work in a zoomed view, you may want to see the picture in normal mode at 
the same time.    Just open a second view of the same bitmap.    Each view has its own 
zoom setting.    If you want to maximize the close up view and still see the normal view, 
just pin-up the normal view.    It will stay on top of the zoomed view (and everything else 
as well) so you can see them both.

WinPaint has a special button on the Color Palette which is Clear.    Like normal color 
buttons, the Clear button can be used for the foreground, background, or both.    
However, it's really not a color, it is the lack of a color.    Several of the modes available 
in Microsoft Paintbrush have been eliminated in WinPaint with the Clear button.    If 
you're wondering where these modes went, read through the Modes topic.

WinPaint provides keyboard support for scrolling the screen and moving the cursor.    
Also, when you draw a line (or box, etc.) you can use the TAB key to jump the cursor 
between the two ends.    This means you can draw a shape in rough form with the 
mouse, then adjust the ends to their    exact positions with the keyboard.    When you 
drag an outlined area across the screen, put it into the general area and then use the 
keyboard to nudge it into place.

Sometimes you may want to draw a line or box, or outline an area which is bigger than 
the whole screen.    One way to do this is to drag the cursor off the edge of the screen 
and invoke automatic scrolling.    But there is another way.    While you hold down the 
mouse button, scroll the screen with the keyboard!    This can also be done when 
dragging an outlined area.    Think of it as moving the screen while the outline holds still,
instead of moving the outline while the screen holds still.



 Confusion and Chaos
YES, there are some tricky sides to WinPaint.    This topic deals with some frustrating 
situations that can and do occur for new users of WinPaint.

WinPaint's adjustment phase takes some getting used to.    When you draw a series of 
several lines, you may find a time when you draw from point A to point B, then from 
point B to point C and you get a surprise!    The result is a single line from point A to 
point C.    When you click on point B to begin the second line, WinPaint thinks you are 
adjusting the first line rather than drawing a second line.    You need to hit the Enter key 
to tell WinPaint you're done with line A-B and moving on to line B-C.

The same problem from another angle is when you draw a series of lines with different 
colors.    Let's say you select red from the color palette and draw a line, then select blue 
and draw another.    What will you get?    2 blue lines!    When WinPaint notices the 
change of color the first line is still adjustable, so the color change is applied to the first 
line.    Again, hit Enter to indicate the first line is finished.

The above might happen accidentally sometimes but intentionally at other times.    This 
example is not done on purpose.    Let's suppose you want to nudge an outlined area 
into place on the screen with the keyboard., but you're having some trouble.    About 
every 3 or 4 pixels, the whole image slips one way or the other.    What could cause 
this?    Since your mouse is still active, a slight brush of the mouse with your wrist or 
elbow will effect the image.    Also, make sure your mouse is on a level surface so it 
doesn't slide if your desk gets bumped.

These problems are difficult to eliminate because they are side effects of desirable 
features.    If you have a solution to offer, please send us a letter.    We welcome ideas 
for future upgrades.



 The Shareware Thing
WinPaint is being released as shareware.    Therefore, we encourage you to give copies
of the software to your friends, coworkers, etc. 

Shareware is not free software!    It is copyright protected in exactly the same way as 
commercial software.    The only difference is that you get to try out shareware programs
before buying.    You pay for a shareware program after a trial use period, and only if you
decide to continue using the program.    If WinPaint doesn't suit your needs, delete it 
from your hard drive and that's that.    If you like it and use it:    you're obligated to pay for
it.    (See Registration for details).

Yes, there are people who "try out" shareware programs for years without registering.    
Unfortunately, they spoil things for the rest of us.    As you might expect, if everyone's 
uses WinPaint without paying for it, Rentek will be unable to pursue WinPaint upgrades 
or new shareware products.



 About the Authors

WinPaint was developed by M. David Holden, Product Development Manager at 
Rentek, Incorporated of Detroit Michigan as an in-house Research and Development 
effort.    Our staff enjoyed using WinPaint so much, we thought perhaps the public might 
feel the same way.

Rentek, Inc. is a Software Consulting Firm established in 1974 and incorporated in 
1979.    Originally Rentek was predominantly involved in the large scale main frame 
arena.    In the early 90s Rentek made the transition to PCs and Networks, and is 
currently involved in consulting and client support, as well as custom software design, 
development and publication.

If your business is in need of software development, analysis, or consulting support, 
please feel free to contact me at:

Rentek, Incorporated
Attn: D. Holden
8623 N. Wayne Road Suite 102
Westland, MI    48185



 Registration
When you purchase a registered version of WinPaint, you will receive:

 The most current version of the program
 A bound and printed manual
 The right to telephone support for the program

To register WinPaint, fill out the Registration screen (press the "Register" button on the 
"Help : About WinPaint" screen), print out the order form, and send it along with a check
or money order to:

Rentek, Inc.
Attn: WinPaint Mgr.
PO Box 12
New Hudson, MI    48165-0012

 For a single user registration, the price is TWENTY DOLLARS ($20).
 For networks with 10 or fewer users, the price is FIFTY DOLLARS ($50).
 For larger networks, the price is ONE HUNDRED DOLLARS ($100).    

With a Network registration you will receive three copies of the printed manual.    We ask
that you establish a single person responsible for handling questions about WinPaint 
when you contact Rentek.

WinPaint (like most shareware programs) has some "incentive to register" aspects 
designed into the unregistered version.    For instance, the "Help : About WinPaint" 
screen is always presented before starting WinPaint, and it clearly states that you're 
using an unregistered version.    

Also, WinPaint counts the number of times you have used the Save command from 
within the program, and in the unregistered version it shows you this count each time 
you save.    If the count reaches 100 or more, it is certainly time to conclude your 
evaluation of WinPaint.

WinPaint does not create hidden tattletale files, nor perform any form of reprisal for 
extended non-registered use.



 Upgrades
When you register WinPaint you receive a disk with the most current version of the 
software (along with a manual, etc.).    If this is a newer version than the trial version you
originally had, you will have purchased an upgrade!    Because the purchase price for 
WinPaint is so low, the upgrade prices are the same as the original registration prices.    
Upgrade packages contain the same materials as registration packages.

Upgrades to WinPaint may be available about every 6 months or so.    Each new version
will contain new features and enhancements.    As a registered user, you will receive a 
notification when an upgrade is available and information about the enhancements 
offered.

New releases of the current version of WinPaint will be made available via the major 
bulletin board services, or by sending a blank diskette to Rentek, Inc. along with a self 
addressed stamped envelope.    New releases are not the same as upgrades.    They 
contain corrections for newly discovered problems.    If you have a registered copy of the
current version of WinPaint, you may install a new release of this same version without 
affecting your registration.



 License Agreement

This is the general LEGALESE section, including legal authorizations, warranties, and 
of course the usual disclaimers.

Rentek Inc. is not responsible for anything at all.    Nothing.    Even if held responsible, 
the limit of our liability is the licensing fee you've paid if you are a registered user.

WinPaint is not and has never been public domain software, nor is it free software.    
Non-registered users are granted a limited license to use WinPaint on a trial basis for 
the purpose of determining whether the software is suitable for their needs.    Any other 
use of WinPaint requires registration.

A single user registration permits a user to use one copy of WinPaint on a single non-
networked computer.    A single user registration may only be used upon a networked 
computer if the disk drive it is installed upon is a non-networked disk drive.

A network registration permits a user to use one copy of WinPaint on a single network
drive upon a single network.    A network registration cannot be used upon a non-
networked computer or upon a non-networked drive.

This license agreement pertains to version 1.1 of WinPaint.    If a user obtains a copy of 
a different version of WinPaint, it will include a license agreement pertaining to it.

No one may modify or patch any of our executable files in any way, including but not 
limited to decompiling, disassembling, or otherwise reverse engineering WinPaint.    
WinPaint maintains installation specific information in parameter files, some of which is 
protected via encryption.    Tampering with this information is considered an alteration to 
WinPaint, and is prohibited.

A limited license is granted to copy and distribute WinPaint only for the trial use of 
others, subject to the above limitations, and also the following: 

1) The software must be copied in unmodified form, complete with the file containing 
this license information.

2) Our software may not be distributed in conjunction with any other    product without a
specific license to do so from Rentek, Inc.

3) No fee, charge, or other compensation may be requested or accepted, except as 
authorized below:

A) Operators of electronic bulletin board systems (sysops) may make our products 
available for downloading only as long as the above conditions are met.    An 
overall or time-dependent charge for the use of the bulletin board system is 
permitted as long as there is not a specific charge for the download of WinPaint.



B) Vendors of user-supported or shareware software may distribute our products 
only after obtaining written permission from Rentek, Inc.    Such permission is 
usually granted.    Please write for details (enclose your catalog).    Vendors may 
charge a disk duplication and handling fee, which, when pro-rated to each 
individual product, may not exceed eight dollars.

C) Non-profit user groups may distribute copies of our products to their members, 
subject to the above conditions, without specific permission.    Non-profit groups 
may collect a disk duplication fee not to exceed five dollars.

LIMITED WARRANTY

Rentek, Inc. warrants that all disks provided by Rentek, Inc. are free from defects in 
material and workmanship, assuming normal use, for a period of 90 days from the date 
of purchase.

Rentek, Inc. warrants that WinPaint will perform in substantial compliance with the 
documentation included.    If a significant defect is found, the purchaser may return the 
product for a refund or replacement at Rentek's discretion.    In no event will such a 
refund exceed the purchase price.

EXCEPT AS PROVIDED ABOVE, RENTEK INCORPORATED DISCLAIMS ALL 
WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE, WITH RESPECT TO THE PRODUCT.    SHOULD THE PROGRAM PROVE
DEFECTIVE, THE PURCHASER ASSUMES THE RISK OF PAYING THE ENTIRE 
COST OF ALL NECESSARY SERVICING, REPAIR, OR CORRECTION AND ANY 
INCIDENTAL OR CONSEQUENTIAL DAMAGES.    IN NO EVENT WILL RENTEK 
INCORPORATED BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING 
WITHOUT LIMITATION DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS 
INTERRUPTION, LOSS OF BUSINESS INFORMATION AND THE LIKE) ARISING 
OUT OF THE USE OR THE INABILITY TO USE THIS PRODUCT EVEN IF RENTEK 
INCORPORATED HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Use of this product for any period of time constitutes your acceptance of this agreement 
and subjects you to its contents.

U.S. GOVERNMENT RESTRICTED RIGHTS

Use, duplication, or disclosure by the Government is subject to restrictions as set forth 
in subdivision (b)(3)(ii) of the Rights in Technical Data and Computer Software clause at
252.227-7013.    Contractor/manufacturer is Rentek, Inc.    8623 N. Wayne Rd /suite 102/
Westland, MI 48185

TRADEMARKS



Microsoft and MS-DOS are registered trademarks of Microsoft Corporation.
Windows is a trademark of Microsoft Corporation.
WinPaint and WinPaint256 are trademarks of Rentek, Incorporated.



 Using the Mouse
If you're familiar with other paint programs, this topic will probably be nothing new to 
you.    Even so, you really should take a look at the keyboard support topic:    you may 
be surprised at what you find!

Some of the Editing Modes in WinPaint utilize only the left mouse button, but some use 
both buttons.    The choice of mouse buttons involves Color Selection. For example, if 
you're in Dot by Dot mode, you can draw with either the foreground or background color,
so therefore you can use either button.    If you're in Draw Box mode, both colors are 
used to draw the box (outline and interior) so there's no meaning WinPaint could give to 
the right button.    In the Editing Modes    topic, each mode describes how the colors are 
applied.

WinPaint uses the standard rubber-banding mechanism (like most paint programs) to 
draw lines, boxes, outlines, etc.    You can click the mouse and stretch your shape off 
the edge of the window to tell WinPaint to scroll for you while you hold down the mouse 
button.    WinPaint provides a Scroll Lock control, however, to turn off this mechanism.    
We felt it was important because it's fairly common to accidentally cross the window 
edge boundary.    Having the screen start to scroll "all by itself" can be very frustrating.



 Using the Keyboard
The shortage of keyboard support in Microsoft Paintbrush was one of the main reasons 
why WinPaint was developed.    However, WinPaint does require the use of a mouse!

Like most Windows programs, WinPaint provides keyboard support in the nature of hot 
keys on pull down menus, shortcut keys for common commands, etc.    Pull down the 
menus one by one to see the hot keys and shortcut keys.    Getting to know these 
keystrokes may take time now but will save you time in the long run.

You can scroll the current view up or down using the Page-Up and Page-Down keys, or 
left and right using the Home and End keys.    Normally they only move the view in small
steps.    To scroll in larger steps, use the same keys while holding down the Control key. 
You can move the cursor itself with the arrow keys one logical pixel at a time (in zoomed
views a logical pixel can get pretty big!) or 8 logical pixels at a time with the Control key 
held down.

WinPaint uses the keyboard to emulate the mouse.    This is accomplished by using the 
space bar as a replacement for the left mouse button and the arrow keys for movement. 
For example, to draw a line with the mouse you move the cursor to the starting point, 
click and hold the mouse button, slide the mouse to the ending position, then release 
the button.    To do the same thing with the keyboard, move the cursor to the starting 
point with the arrow keys, press and hold the space bar, slide the cursor to the ending 
position with the arrow keys, then release the space bar.    (The keyboard doesn't 
emulate the right mouse button).

The final important keyboard command is the Tab key.    When you draw a line or box, 
WinPaint remembers the starting and ending points until you accept or reject the 
change (or move on to some other action).    If you want to adjust these points, you 
simply click and drag them with the mouse.    On the keyboard, when you press the Tab 
key once, the cursor will jump to the exact starting point of the shape.    Pressing Tab 
again will jump the cursor to the next, and so on.    You can then adjust the point with the
keyboard mouse emulation described above or simply use the mouse normally.



 The Menu Bar
Click on the items below to view the choices within each menu.

The File Menu
The Edit Menu
The Line Menu
The Outline Menu
The Text Menu
The Window Menu
The Help Menu



 The Command Buttons
Across the top margin of the screen is a series of buttons.    They are generally grouped 
into three zones:

The Quick Access Commands
The Mode Buttons
The Toggle Buttons and Current Settings

The Command buttons provide a quick way to use features normally available from the 
pull down menus.    There is no difference between these buttons and the menus.

Open on the File menu
Save on the File menu (or Save As if the file name is unknown)
Print on the File menu

The Mode Buttons are discussed in a separate Help topic.    However, be aware that 
when you click on a mode button, it presses immediately, with no release phase as with 
normal buttons.

The Toggle buttons:

Pin Up from the Window menu (Toggle button:    UP or DOWN)
Grid Lines from the Window menu (Toggle button)
Scroll Chained from the Window menu (Toggle button)

Lock Auto-Scroll from the Window menu (Toggle button)

The Current Staus Settings:

Line Attributes Information.    The number indicates the 
current line thickness, and the key word next to it 
indicates the style.    Also accessible via the Line menu.
Zoom Level for the current view.    Also accessible via 
the Window menu.

 The Mode Buttons
The Mode Buttons are the life blood of WinPaint.    They tell WinPaint what you wish to 
do what a mouse click means.    Each Button is shown with both UP and DOWN 
images, so you can see the difference between off and on.

Outline Area mode.    Used for clipping out areas to drag 
across the screen.    This mode is used for Copy / Paste 
commands from the Edit menu.    The Print command from the



File menu also has a special reference to Outlined Areas.    
When you outline an area to drag, first set the background 
color to indicate the portions of the area you want to be 
transparent during the operation.    If you set the background 
color to clear, then you will be dragging a copy of the outlined 
area, and no portions of it will be transparent.
Text mode.    When you first enter Text mode, a text window 
appears into which you can type and/or paste text from the 
Clipboard.    If you have a large amount of text in this window, 
but only want to paste part of it into your bitmap, highlight the 
portion desired.    See the topic on the Text Menu for other 
special options.
Draw (Dot by Dot) mode.    You can draw with either the 
foreground or background color, using either left or right 
mouse buttons.    WinPaint ignores the Line Thickness Setting 
in Draw mode and always draws one dot at a time.
Erase mode.    Actually a Replace mode, because only the 
foreground color is erased, which essentially means replaced,
with the background color.    If the foreground is Clear, then all 
dots touched will be changed to the background color.    The 
size of the Erase zone around the cursor is dependent upon 
the line thickness setting.
Paint (Area Fill) mode.    In this mode, a single click of the 
mouse will pour the desired color onto the bitmap, replacing 
all contiguous dots of the same color as the dot clicked.    You 
can paint with either the foreground or background color, 
using either left or right mouse buttons.    The Reject 
command can be used to undo Painted areas.    The area 
effected by the paint command could encompass the entire 
bitmap, regardless of how much is visible in the current view.
Line Draw mode.    Click at the starting point, hold down the 
mouse button and stretch out the line, then release the mouse
button at the ending point for the line.    You can use either the 
foreground or background color, using either left or right 
mouse buttons.
Box Draw mode.    As with Line mode, stretch out the box as 
desired.    If you set the background color to clear, only the 
box outline will be drawn.    Otherwise, the interior of the box 
will be filled with the background color.    If you don't want an 
outline on the box, set the foreground color to clear.
Irregular Shape mode.    This mode allows you to draw from 
point to point, up to 64 lines, until eventually you connect back
to the beginning point.    Before Accepting the shape, you can 
tweak any and all of the points along the outline.    See Box 
Draw mode above for color options.
Circle Draw mode.    This is really an ellipse draw mode.    In 



WinPaint the only way to draw a perfect circle is to watch the 
Message Line and to see when the width and height are 
equal.    See Box Draw mode above for color options.

 The Color Palette
WinPaint has a color palette along the left hand margin of the screen which includes 4 
types of buttons:

Normal SOLID colors (16)
The CLEAR color (1)
MIXED DOT colors (4)
CUSTOM colors (4)

Two of these buttons are selected at all times:    Foreground and Background.    The 
current foreground button will look pressed and have a DOT in the center of the color 
block.    The current background button will also look pressed and have a CIRCLE in the
color block.    You can select the same color for both foreground and background.



 The Accept / Reject Buttons
The ability to adjust edits before they become final is one of WinPaint's strongest 
features.    It can also be a frustrating feature (see Confusion and Chaos).    It's as a 
double edged sword,    all the better to cut with once you get the hang of it.

The buttons themselves look like this  and are located at the bottom left corner of 
the screen.    The green check means Accept, the red cross out means Reject.    The 
Enter and Escape keys are a faster way to do the same job.    These commands can 
also be accessed via the Edit menu.

One big advantage of the adjustment phase is that get a moment to let go of the mouse 
and switch over to the keyboard.    See the topic on Keyboard Support for more 
information.

The Dot by Dot Draw mode has no adjustment phase.    After all, how do you "adjust" an
edit for a single dot?    The same applies to Erase mode and Paint mode.    In these 
modes, edits are accumulated until they're Accepted or Rejected all at once.    The other
modes draw one object at a time.    For instance, when you draw a line, you don't draw 
another until the first one is either Accepted or Rejected.    Don't worry!    WinPaint 
automatically performs an Accept for you when you start the second line, as it does 
when you change the current mode, or when you do a Save or Restore, or when you 
switch over to another bitmap view window.

There is an important point to make here.    WinPaint does an automatic Accept only if 
you switch to a different bitmap Image.    If you open two or more view windows for the 
same bitmap, you can switch freely between them.    This means you can draw a line in 
one view, then tweak the tips in another.



 The Message Area
The Message Area is located along the bottom margin of the screen.    WinPaint does 
not make this optional (as do some paint programs).    WinPaint goes further than 
merely showing the current pixel position of the cursor.    It also shows the position 
where an edit began, where it ended (or will end), and the distance between these two 
points.

Each display box has its own caption, and contains two values separated by commas.    
The first number is the horizontal pixel value measured from the left side of the bitmap.   
The second number is    the vertical pixel value measured from the top.

The three position type displays show distance from the edge, so naturally the first dot 
is zero (not at all distant).    The size display box acts differently.    It does not measures 
from left to right or right to left.    It measures the difference.    Also, the values are shown
one dot more than actual.    For example, if you draw a horizontal line, the difference in 
height between the two tips is zero (none at all), but there is still 1 dot in height to this 
line.    If the line were drawn 2 pixels wide, the difference would be 1 but the width would
be 2 (Two dots side by side are one dot apart).



 Bitmap View Windows
WinPaint uses what the software industry calls "The Multiple Document Interface" 
(MDI).    This is a standard way of gathering together many windows under the umbrella 
of a single main window.    MDI is used by the Program Manager, The File Manager, 
Microsoft Word,    Microsoft Excel, and many other major programs.

You can shrink (Minimize) a view window to an icon, or Maximize them to use all of the 
desktop space.    Use the Tab key while Control is held down to rapidly switch between 
multiple view windows.    You can close a view by making it Current, then hitting F4 with 
Control held down (Alt F4 closes the WinPaint main window, the same as selecting Exit 
from the File menu).



 Pinned Up Views
The Pin Up feature in WinPaint replaces the keyhole view presented most other paint 
programs when in Zoom Mode.    Instead, you open two (or more) views of the same 
Bitmap and Pin Up one of them, so you are free to work within the other, even in 
minimized mode.

Pinned-Up views stay on top of everything on the screen.    They can be moved right off 
of the WinPaint screen (or over the top of the Command Buttons, the Color Palette, 
etc.).    The intention is to let you decide what to do and how.    Pinned-Up views can do 
everything normal views can. 

Be aware, however, that Pinned-Up windows have some slightly odd behavior.    First, 
when you make a Pinned-Up view the Current view, you will see the main WinPaint 
window caption bar across the top turn dark (inactive).    This is an unsought a side 
effect.    Second, there is also a small problem accessing the Menu Bar via the keyboard
when the current view is Pinned-Up.    We hope to address these quirks in future 
upgrades.



 Scroll Chained Views
Scroll Chaining is a special mechanism in WinPaint to make it easier to use multiple 
views of the same bitmap.    When Scroll Chaining is turned on, it applies to all view 
windows for the given bitmap.    Whenever you scroll one view of this bitmap, all views 
for it will scroll the same amount (in logical pixels) so they will stay focused on the same
part of the image.

Do not confuse Scroll Chaining with Auto-Scroll Locking.    Locking doesn't mean the 
view can't scroll, it just means the cursor won't slip off the edge and cause WinPaint to 
scroll the image automatically.





Definition: Emulate
Emulate means "to imitate in both manner and purpose".    The word is very close in 
meaning to Simulate.    The keyboard can emulate the mouse by doing the same things 
with key strokes that the mouse does with movements and clicks.



Definition: Dithering
Dithering is the process of mixing together dots of varying shades to produce an overall 
impression of a color which can not be created directly.    An example of dithering is 
laying down a pattern of red and white dots to make a pink area.    There is another kind 
of dithering, depending upon the context of discussion.    Dithering also can be the use 
of off-color dots along the fringe area where two colors meet.    For example, a black line
on a white area often looks jagged.    With dithering, you add gray dots along the edge 
of the line.    To the eye, these dots seem half black and half white.    The results can be 
breathtaking.



File Menu
New Bitmap Opens a view onto a blank bitmap.
Open File Opens an existing bitmap file.
Open Another View Opens another view window for the current 

bitmap.
Open From Clipboard Gets the bitmap from the Clipboard (if there is 

one), and opens a view window for it.
Save Directly saves the current bitmap.
Save As Saves the current bitmap using a new file name.
Save to Clipboard Puts a copy of the current bitmap on the 

Clipboard.
Revert Reloads the bitmap or PCX file from disk.
Print Prints the current bitmap with selected options.
Exit Shuts down WinPaint.
1. File Name The four most recently accessed files are listed 

here.    Selecting one of these four file names 
opens the file for editing.

File: New Bitmap
Creates a blank bitmap and opens a view window for it.    When you are through with it, 
you may close the view and destroy the bitmap, or you may save it to disk.    The bitmap
is initially created at the same size as the screen, so if you wish to set the bitmap 
dimensions, you should immediately use the Bitmap Size command from the Edit menu.



File: Open
This command uses the standard Windows file-name dialog to provide a way for you to 
locate the bitmap (*.BMP) or PCX (*.PCX) file you want.    If this dialog isn't adequate, 
try using the Drag and Drop mechanism built into MS Window File Manager!    All you 
have to do is run WinPaint and File Manager at the same time (both windows at least 
partially visible), locate the file you want, then "drag" it from the File Manager screen 
and "drop" it on the WinPaint Screen!    For further explanations of this feature, refer to 
the File Manager Help System or MS Windows manual.



File: Save As
This command uses the standard Windows file-name dialog to provide a way for you to 
enter the file-name and select the drive and directory where the image will be saved.    If
you do not specify a file name extension (xxx.EXT) then one will automatically be 
applied depending upon the file type field (in the lower left corner of the dialog screen).   
If you DO provide an extension, but it is neither BMP nor PCX, the file type field should 
indicate the format in which to save the file.    Note:    Images created by the New 
command or Open From Clipboard command do not have a file-name initially, so the 
Save command for these images is automatically converted into a Save As command.



File: Print
Before printing your bitmap, WinPaint opens a dialog screen, which allows you to select 
the printer to use, access the printer setup options (dot resolution, orientation, gray 
scale mode, etc.), set the margins, and select additional options.    If you have outlined a
portion of the current bitmap, you may choose to print only this portion.



Edit Menu
Cut Copies the outlined area to the Clipboard and then 

deletes it from the bitmap.
Copy Copies the outlined area to the Clipboard.
Paste Retrieves the bitmap on the Clipboard (if any) and 

"drops" it onto the current view.    You may then "drag" it
into the desired position.

Accept Changes Causes the current edit(s), which are still adjustable, to 
become "permanent".

Reject Changes Performs an UNDO for the most recent edit(s).
Bitmap Size Allows you to resize the current bitmap, and optionally 

stretch or shrink the image as well.
Mode One way of setting the Current Mode.
Color Patterns One way of accessing the Color Setup Screens. 

Edit: Paste
A copy of the image previously placed on the Clipboard is dropped into the current view 
in the center of the visible area.    The Paste command will automatically switch you to 
Outline Mode.    If there are any edits in the adjustment phase, they will automatically be
accepted at this time.    You may still UNDO the Paste command by hitting Escape, or 
pressing the Reject button with the mouse.    The background "see through" effect 
occurs as usual for Outline mode, so you should set the background color before using 
this command.        This function has no effect if there is no bitmap image on the 
Clipboard.



Line Menu
Thicker Increases the current line width setting.
Thinner Decreases the current line width setting.
Solid Sets the current line drawing style.
Dotted Sets the current line drawing style.
Dashed Sets the current line drawing style.
Dot Dash Sets the current line drawing style.

Outline Menu
Flip Horizontal Changes the currently outlined area into a mirror image

flipped over from side to side.
Flip Vertical Changes the currently outlined area into a mirror image

flipped over from top to bottom.
Turn Upside-down Turns the currently outlined area 180 degrees.
Turn Left Turns the currently outlined area 90 degrees counter-

clockwise.
Turn Right Turns the currently outlined area 90 degrees clockwise.

Text Menu
Font Brings up the standard font selection dialog box.
Normal Text displays left to right.
Upside-down Text displays right to left and upside-down.
Upward Text displays vertically, reading bottom to top.
Downward Text displays vertically, reading top to bottom.
Level Not raised or sunken.
Raised Text will have a white accent and a gray shadow.
Sunken Text will have a white counter-accent.

Window Menu
Tile All view windows will be arranged to use as much 

space as possible and still show all windows.
Cascade All view windows will be set to a medium size and 

arranged so that all title bars are visible.
256 Color Palette Opens the 256 Color Palette selector window for 

editing the 16 Solid Colors of the Color Palette.    
Only available if your video display driver is 
configured for 256 color mode.

Pin Up Allows a view window to stay on top of all other 
windows. (Toggle switch).

Grid Lines Allows a view window to have pixels demarcated by
black lines when in Zoom mode. (Toggle switch).

Zoom In Increases the magnification one step.
Zoom Out Decreases the magnification one step.
Zoom Settings Allows control of each magnification step.
Scroll Chained Allows simultaneous scrolling of all view windows 

for a given bitmap.    Useful for zoomed and non-



zoomed window pairs. (Toggle switch).
Lock Auto-Scroll Prevents the cursor from accidentally dragging an 

outline or shape off the edge of the screen, thereby 
causing the screen to scroll. (Toggle switch).

1. Bitmap View Name Selecting this type of entry is one way of making the
chosen view become the current view window.

Help Menu
Index Brings up the "Front Door" to this Help System.
Using Help Brings up the "Windows Help" file, which is included with 

all versions of Microsoft Windows.    Once you have 
selected this help option, you will be viewing a separate 
help file which is not related to the file you are currently 
viewing.

Registration Brings up Registration information about WinPaint.
Commands Brings up information regarding the pull down menus.
About WinPaint Tells you the program version number, your Registration 

Number, and a variety of other useful bits of information.

Definition: Contiguous
Simply put, it means "all together, adjacent, touching".    This does NOT included dots 
which touch on the diagonal (corner to corner).    If you have an area filled with a dot mix
(dithering) you could have difficulties because even though you MADE these dots with a
"single" color, once they are in place there isn't any way to know they are related.    As 
far as WinPaint is concerned, only the 16 solid colors are replaceable as contiguous 
dots.



Normal SOLID colors
The 16 solid colors represent the actual colors available in the Windows color palette.    
In a standard VGA setup, there are only 16 real solid colors.    However, if you have a 
Super VGA monitor and it is configured to run in 256 color mode, then the 16 solid color 
buttons represent 16 of the 256 available solid colors.    You can double click on one of 
these buttons to bring up the 256 Color Palette to pick a different shade for that button.   
A shortcut for setting the shades of the Solid Color buttons is to hold down the Shift and 
Control keys while clicking on the desired color directly in your bitmap image.    Using 
this method, you can set either the foreground or background buttons using the left and 
right mouse buttons respectively.



The CLEAR color
The Clear button isn't really a color.    It is the LACK OF color.    The simplest example of 
using clear is when you draw a box, but want only the outline of the rectangle.    
Normally WinPaint fills the box with the background color.    If you set the background to 
clear, you're telling WinPaint "I don't have a background color", so the area will not be 
filled at all.

Take time to experiment with the different modes and combinations of the Clear button 
as the foreground or background while thinking about the concept of "not having" a 
color.



MIXED DOT colors
We use the name "Mixed Dot", though the actual term for these 4 buttons is Dithered.    
The Mixed Dot colors are adjustable in the same way as with Microsoft Paintbrush and 
most other paint programs.    You can dial in the red, green, and blue aspects in a range 
from 0 to 255.    Access the edit window for one of these colors by simply double clicking
on its button, or via the Edit Menu.



CUSTOM colors
The Custom colors aren't really colors at all!    They are actually patterns.    WinPaint 
provides 4 of these buttons, and it remembers them from session to session, so you 
don't have to constantly recreate them.    When you double click on one of these buttons
(or use the Edit Menu), WinPaint opens a view window with an image 8 by 8 pixels in 
size.    You can draw anything you want on this tiny image, and when you save it, you 
are making this pattern a part of the color palette.    Think of it as wallpaper!    You 
cannot draw lines with this "color," since it isn't really a color, but you can use it in Paint 
mode, or as a fill color for boxes, circles and irregular shapes.



256 Color Palette
WinPaint provides a preset collection of 256 shades for use in 256 color mode.    The 
256 Color Palette selection window divides colors into three general areas.    They are 
the 16 standard VGA colors, a grid of 216 evenly graduated shades (mixing red, green 
and blue), and a collection of miscellaneous shades.    There are some overlaps, so 
don't be surprised to see pure white in all three categories!

When you select a shade from the 256 color palette, you are choosing a shade to use in
the WinPaint color palette.    You may use either the left or right mouse button to select 
foreground or background respectively.    With the keyboard, normal arrow key 
movements apply to the foreground.    When the shift key is held down, they apply to the
background.    Only the 16 Solid Color buttons may be altered with the 256 color palette.






