
     VT100 Help

VT100 allows you to log on to a remote host via the TELNET protocol and process 
commands as if you were at a directly connected terminal.    VT100 provides terminal 
emulation so that communication and presentation of data are made in an 
understandable manner both for you and the remote host.    VT100 provides 
emulation of VT100/101/102 terminals.
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    Preferences Menu
The Preferences menu allows you to set the following options for your Telnet session:

    

 

 

    

    

Many of the settings you select may be saved for use in future sessions.      To save settings, choose Save
or Save As from the File menu.    These settings are stored as a profile.    To retrieve saved settings, use 
Open from the File menu.    For a complete list of settings that are saved, see:



    Options Tab
Chose Preferences, Options to view the following tabs:

    

    

    

    

    

    

    



Double clicking this control closes the application.



The title bar identifies the remote host to which you are connected.



These controls are used to minimize/maximize the application.



The File menu allows you to print and log sessions, as well as save and load 
configuration settings.



The Edit menu allows you to copy and paste text using the Windows Clipboard.



The Connect menu allows you to connect or disconnect from a remote host.



The Preferences menu allows you to set various configuration settings such as fonts, 
colors, and emulation type.



The Window menu allows you to control various attributes of the main application 
window.



The Help menu provides access to the help file you are currently reading.



The button bar provides access to the most frequently used functions.    Click on any 
button at left to display a description.



The display of text in the main window may be adjusted for font, color, column size, 
tabstops, etc.



The scroll bars may be used to view text that cannot fit within the main application 
window.      Display of the scroll bars may be toggled using the Window menu.



An utterly useless portion of the screen.    Clicking here has absolutely no effect.    So 
why are you doing it?



Double clicking on this control closes the Auxiliary Keypad.    It may be reopened 
using the Window menu.



The Auxiliary Keypad contains VT keys not present on the PC keyboard.    You may 
"press" a VT key in the Auxiliary Keypad by clicking on it using the mouse.



This portion of the status bar displays information regarding the feature you have 
currently selected.    "Connected" will be displayed here when you connect to a 
remote host.    "Connection Closed" will be displayed when you disconnect.



This portion of the status bar identifies the remote host to which you are connected.    
"Disconnected" will be displayed here when you disconnect.



When Caps Lock is on, CAPS is displayed his portion of the status bar.



When Num Lock is on, NUM is displayed his portion of the status bar.



This portion of the status bar displays the current vertical position of the cursor.



This portion of the status bar displays the current horizontal position of the cursor.



    Button Bar Setup
The button bar provides quick access to the most frequently used functions.    For your
convenience, the button bar may be moved around the window and the buttons 
themselves' appearances may be configured as described below:

Button Properties

Place your cursor in any of the gray space in the button bar and double click to 
access the button bar configuration dialog box.

Show Button Image

Check this box to cause the buttons to contain an icon evocative of their 
function.    See the display below.

Show Button Text

Check this box to cause the buttons to contain a text description of their 
function.

Text At Right Side of Image

Check this box to cause the text description to appear to the right of the icon 
image on the button.

Enlarge Image

Check this box to enlarge the buttons.

Button Box Properties

Left

Click this radio button to cause the button bar to be oriented vertically down 
the left side of the window.

Right

Click this radio button to cause the button bar to be oriented vertically down 
the right side of the window.

Top

Click this radio button to place the button bar horizontally across the top of 
the window.

Bottom

Click this radio button to place the button bar horizontally across the bottom 
of the window.

Floating

Click this radio button to cause the button bar to take the shape of a box that 



can be placed anywhere in the window.    Click on the box, hold the mouse 
button down and drag the box to the desired location.

Show Caption

If you have selected the floating button bar, you can check this box to 
display a title on the button bar.



    Using the Button Bar
The VT100 button bar provides fast access to the most frequently used functions (the
menu commands that provide access to these functions are shown below in 
parentheses).    Note that the Fit Fonts to Window button is available only under 
Windows 3.1 and later.

Connect      ("Connect, Connect")
Disconnect      ("Connect, Disconnect")
Color Selection      ("Preferences, Colors")
Font Selection      ("Preferences, Fonts")
FTC Font      ("Preferences, Fonts")
Fit Fonts to Window      ("Preferences, Fonts")
Log      ("File, Log")
Continuous Log      ("File, Continuous Log")
Print      ("File, Print")
Continuous Print      ("File, Continuous Print")
Auto Scroll On      ("Window, Auto Scroll")
Auto Scroll Off      ("Window, Auto Scroll")
Exit VT100      ("File, Exit")



Click the Connect button to specify a remote host to which you wish to connect.



Click the Disconnect button to disconnect from the remote host to which you are 
connected.    Note that you should first properly log off the remote host.



Click the Color Selection button to specify a text and background color combination.



Click the Font Selection button to specify a font style and size for displayed text.



Click the FTC Font button to select the FTC-San Serif Font, which supports graphics 
characters (such as those in the DEC special graphics character set) and proper 
graphical representations of control codes.



Click the Fit Fonts to Window button to enable automatic scaling of fonts to fit the 
current VT100 window size.    Note that the automatic scaling feature is disabled for 
raster fonts.    Note also that the automatic scaling feature is not supported in 
Windows 3.0.



Click the 132 Column button to display 132 characters on a single line of your screen.
If your monitor does not allow 132 columns to be visible at one time, horizontal scroll 
bars allow you to view the remaining characters.



Click the 80 Column button to display 80 characters on a single line of your screen.



Click the Auto Scroll On button to enable Auto Scroll mode.    If Auto Scroll mode is 
set, whenever the cursor goes beyond the boundary limits of your terminal screen, 
the screen is automatically scrolled so that the cursor always remains visible.



Click the Auto Scroll Off button to disable Auto Scroll mode.    If Auto Scroll is off, the 
display is not automatically scrolled when the cursor goes beyond the boundary limits
of your terminal screen.



Click the Exit button to close the application.    Note that you should first properly log 
off the remote host.



Click the Log button to log screen data to a file.



Click the Continuous Log button to toggle continuous logging of data to a file.



Click the Print button to print screen data.



Click the Continuous Print to toggle continuous printing of screen data.



    Composing Characters
To generate special characters which cannot be generated directly from your 
keyboard, you must compose them by pressing the Compose key.    You can then 
type a valid compose sequence to generate a compose character.

Because the Compose key is not directly available on the PC keyboard, the function 
key F6 on the PC keyboard can be mapped to the Compose key.

For more information see 

To compose characters not directly available from the keyboard, follows these steps:
Use Fonts on the Preferences menu to select a language other than US.    Be sure to select 

National Mode using the checkbox.    For more information on this procedure, see: 

.
On your actual keyboard, press F6 key.
Using the table provided below, generate the desired character by pressing the corresponding 

key sequence from the Sequence column.    The order of these keys is not important, except for those 
characters noted by a "*".

Character Sequence

Á    (A acute) A'

á    (a acute) a'

Â    (A circumflex) A^

â    (a circumflex) a^

À    (A grave) A`

à    (a grave) a`

Å    (A ring) A*

å    (a ring) a*

Ã    (A tilde) A~

ã    (a tilde) a~

Ä    (A umlaut) A"

ä    (a umlaut) a"

Æ    (AE ligature) * AE

æ    (ae ligature) * ae



Ç    (C cedilla) C,

ç    (c cedilla) c,

É    (E acute) E'

é    (e acute) e'

Ê    (E circumflex) E^

ê    (e circumflex) e^

È    (E grave) E`

è    (e grave) e`

Ë    (E umlaut) E"

ë    (e umlaut) e"

Í    (I acute) I'

í    (i acute) i'

Î    (I circumflex) I^

î    (i circumflex) i^

Ì    (I grave) I`

ì    (i grave) i`

Ï    (I umlaut) I"

ï    (i umlaut) i"

Ñ    (N tilde) N~

ñ    (n tilde) n~

Ó    (O acute) O'

ó    (o acute) o'

Ô    (O circumflex) O^

ô    (o circumflex) o^

Ò    (O grave) O`

ò    (o grave) o`

Ø    (O slash) O/

ø    (o slash) o/



Õ    (O tilde) O~

õ    (o tilde) o~

Ö    (O umlaut) O"

ö    (o umlaut) o"

×    (OE ligature) * OE

÷    (oe ligature) * oe

ß    (German sharp s) ss

Ú    (U acute) U'

ú    (u acute) u'

Û    (U circumflex) U^

û    (u circumflex) u^

Ù    (U grave) U`

ù    (u grave) u`

Ü    (U umlaut) U"

ü    (u umlaut) u"

Ý    (Y umlaut) Y"

ÿ    (y umlaut) y"

¡    (inverted !) !!

¢    (cent sign) c/ or C/ or c| or C|

£    (pound sign) l- or L- or l= or L= 

¥    (yen sign) y- or Y- or y= or Y=

§    (section sign) so or SO or s! or S! or s0 or S0

¨    (currency sign) xo or XO or x0 or X0

©    (copyright sign) co or CO or c0 or C0

ª    (feminine ordinal indicator) a_ or A_

«    (angle quotation mark left) <<

»    (angle quotation mark right) >>

°    (degree sign) 0^



±    (plus minus sign) +-

¹    (superscript 1) 1^

²    (superscript 2) 2^

³    (superscript 3) 3^

µ    (micro sign) * /u or /U

¶    (paragraph sign) p! or P!

·    (middle dot) .^

º    (masculine ordinal indicator) o_ or O_

¼    (one-quarter fraction) * 14

½    (one-half fraction) * 12

¿    (inverted ?) ??

* sequence must be entered in the order indicated

Related Topics



    Profiles
A profile (or configuration) is all the settings used for a particular session.    Creating 
new profiles, opening existing profiles, saving profiles, and deleting profiles can be 
done using the File menu.

A profile includes the following settings:

Accelerator keys ON/OFF

Automatic scaling of fonts ON/OFF

Auto Scroll

Auto Wrap

Auxiliary keypad ON/OFF

BS sends

Button Bar Status

Color

Column Width

Continuous Print Mode

Cursor Key Mode

Disable Bell

Display control characters

(Emulator) Id

End of line

Enter sends

Exit VT100 on Disconnect

Font Information

Force Telnet negotiation

HorizontalTextCentering

Hostname

Insert Mode

Keyboard Mappings



Keypad Mode

Local Echo

Lock is

Lock Keyboard

Local Mode

Local Xon/Xoff

Log file name

Log Style

Margin Bell

Mapping of function keys to protocol keys

Mouse Positions Cursor

Number of Scrollback lines

Origin Mode

Port

Prompt on Disconnect

Reverse Video

Scrollbar ON/OFF

Status Window Settings

Tab Settings

VerticalTextCentering

Viewport size

Window Position

Window Size

Window State MINIMIZED/MAXIMIZED/RESTORED

Profiles can be created from the default factory settings as well as from an existing 
profile, so you can start a new profile from scratch or base it on an existing profile.    
Profiles names can be as simple or descriptive as you like, as long as they are 
unique, making the method of connecting to the remote host very "user-friendly".    
(Note that profile names are case-insensitive, so Name and name would not be 
considered unique).



Complete access to the list of profiles is available through the File menu or through 
the Connect dialog.    This allows settings to be changed quickly and easily, letting 
you switch from one session to the next just by choosing a new profile.    If any 
changes are made to the loaded profile (i.e., any of the above settings are modified), 
you will be prompted to save them whenever you attempt to load a different profile, 
create a new one, or exit the application.    A profile can also be deleted, providing it is
not currently in use by another instance of the application.

Related Topics

    

    



    Soft Terminal Reset States
The following default states are restored by a Reset Terminal:

Auto-Wrap Off

Cursor Key Mode Normal

Insert/Replace Mode Replace

Keyboard Action Mode Unlocked

Keypad Mode Numeric

Origin Absolute

Selective Erase Normal

Text Cursor ON

Saved Cursor State Home



    File Menu
New

Used to load an (Untitled) profile having default factory settings.

Open

Used to load a previously created profile.

Save

Used to save the currently loaded profile.    If the currently loaded profile is 
(Untitled), then a name must first be assigned to the profile; thus, the SAVE will 
function as a SAVE AS (see below).

Save As

Used to save an (Untitled) profile or to save the currently loaded profile with a 
new name.    This can be used to make a copy of the currently loaded profile.

Delete

Used to delete a particular profile.    If the currently loaded profile is deleted, an 
(Untitled) profile is loaded.    An instance of the application cannot delete a profile 
which is currently being used by another instance of the application.

Log

Used to log screen data to a file.    The application provides a default log file 
name when you log for the first time.    You may changed the name if you desire.   
Thereafter, it will log to the chosen file.    The data will be stored according to the 
features selected using Log Setup.

Continuous Log

Used to start continuous logging of data to a file.    If you have not already 
selected a log file name, you will be prompted to select one.    To stop continuous 
logging, issue this command again.

Log Playback

Used to playback the previously recorded log.    (Note that the Log Playback 
command is greyed when On-line Mode is enabled and you are not connected to 
a remote host.)

Log Setup

Used to set options for logging data to a file.    For more information:

Print



Use this command to print data as directed by the selections made using the 
"Print Setup" command.

Continuous Print

Used to start continuous printing of screen data.    The printing will be done in 
accordance to the parameter selections made using the "Print Setup" command.  
This option can only be used only if you have chosen either the Auto Print mode 
or the Print Controller Mode from the Print Setup.    To stop continuous printing, 
issue this command again.

Print Setup

Used to set options for printing.    For more information see:

Exit

Exits the application.    You have the option of saving the current settings.

Open and Delete can only be used if 
there are one or more profiles 
available to the application.

Related Topics

    



    Edit Menu
Copy

This command copies the selected data to the clipboard.    Data is normally 
selected using the mouse.    You may also select the entire screen or entire buffer
using the Select Entire Screen or Select Entire Buffer commands.

Paste

Pastes data from the clipboard to the current insertion point.    If the data in the 
clipboard is of type bit-map then this command is not available.    The command 
is also unavailable if there is nothing in the clipboard which can be pasted.

Select Entire Screen

Selects the entire screen for a clipboard operation.

Select Entire Buffer

Selects the entire buffer for a clipboard operation.



    Window Menu
Clear Screen

Erases the entire VT100 Window.    This also clears up the visible part of the 
scroll-back buffer.

Clear Buffer

Erases the entire scroll-back buffer along with the entire screen.

Reset Terminal

Performs a soft reset of the terminal.    For more information, see

Auto Scroll

Used to enable Auto Scroll mode.    If Auto Scroll mode is set, whenever the 
cursor goes beyond the boundary limits of your terminal screen, the screen is 
automatically scrolled so that the cursor always remains visible.    If Auto Scroll is 
off, the display is not automatically scrolled.    Special icons on the Status Bar 
indicate the current mode of Auto Scroll.

Show Scroll Bars

Shows or hides the vertical and horizontal scroll bars.

Show Auxiliary Keypad

Shows or hides the Auxiliary Keypad which contains all the VT100 keys not 
present on the PC keyboard as well as all the function keys F11 to F13, PF1 to 
PF4 compose key. You may "press" a VT100 key in the Auxiliary Keypad by 
clicking on it using the mouse.

Show Button Bar

Shows or hides the Button Bar which provides fast access to the most frequently 
used menu functions.    For more information, see:

Center Text Horizontally

Centers or left-aligns the text horizontally within the workspace.

Center Text Vertically

Centers or bottom-aligns the text vertically within the workspace.

Set Extents

By default, the VT100 window size is limited to a Standard size of 24/25 lines, the
size of the active VT100 screen.    When the Standard size is selected, the scroll 



bars must be used to view the VT100 scrollback buffer.    However, when the 
extents are set to Unlimited, the VT100 window can be sized to show more than 
the 24/25 lines of the VT100 screen, including the scrollback buffer.

Related Topics



    Connect Menu
Connect

Allows you to connect to a remote host to establish a Telnet session.    You can 
load a profile by selecting its name from the list of available profiles, or you can 
use the Default profile.    You also need to enter the hostname or Internet address
of the remote host to which you wish to connect.    The default port for a Telnet 
session is the standard Telnet port (port 23).    The hostname used will 
automatically be added to the system's database for future sessions.

Disconnect

Disconnects the currently established Telnet session.

Are You There

Used to find out if the connection with the remote host is still valid.    If it is, the 
title bar will flash and you will hear a bell sound.    Some hosts also send a 
message (e.g.    "[Yes]").    Issuing the Are You There command sends the AYT 
(Are You There) Telnet sequence.

Abort Output

Instructs the remote host to flush the output buffer.    Use this command if you do 
not want to see the remaining output of the current process.

Interrupt Process

Instructs the remote host to terminate the process which is currently running.

Break

Sends a Telnet Break sequence to the remote host.

Related Topics

    



    Terminal Tab
Use the Preferences, Terminal tab to alter the following terminal parameters:

End of Line

Allows you to set the end of line character.    CR/LF moves the cursor to the first 
column of the next line.    CR Only moves the cursor to the first column on the 
same line.    LF Only moves the cursor to the same column of the next line.

Column Width

Controls the number of characters that can be displayed on a single line of your 
screen.    The VT100 terminal may be set to a screen width of 80 columns or 132 
columns.    If your monitor does not allow 132 columns to be visible at one time, 
horizontal scroll bars allow you to view the remaining characters.

Autowrap

When Autowrap mode is enabled, characters typed when the cursor is at the right
margin appear on the next line.    When Autowrap is disabled, the character at the
right margin is overwritten by the new character typed.

Insert Mode

Used to toggle Insert / Replace mode.    When the Insert mode is set, new display
characters received by the terminal move existing display characters to the right.  
When Replace mode is set, new display characters replace existing display 
characters at the cursor position.

Display Control Characters

Checking this box causes control codes to be displayed as graphic characters for
debugging purposes.    Control codes are displayed graphically, but are not 
executed (except for CR, LF, FF, VT, and codes used for flow control).

Reverse Video

Allows you to view the screen with foreground and background colors 
interchanged.

Disable Bell

Checking this box prevents the terminal from beeping when it receives a BELL 
(0x07) character.

Number of Scrollback Lines

Allows you to specify the number of lines (0-456) to be held by the scroll-back 
buffer.    The scroll-back buffer is used to hold previous contents of the screen 
and may be viewed using the vertical scroll-bars.

Telnet (default) port.

Screen Scroll



You may alter the screen scroll options to adjust how the data is displayed as it is
received from the remote host.

Smooth

If you click this option, you will see the data scrolled as soon as a full line is 
received.    For example, if 16 lines were received at once, you would see the 
screen scrolled 16 times, 1 line at a time.

Jump

If you click this option, you will see the data scrolled once up to four lines are 
received.    For example, if 16 lines were received at once, you would see the 
screen scrolled 4 times, 4 lines at a time.

Hyper

If you click this option, you will see the data scrolled as many lines as are 
received at once.    For example, if 16 lines were received at once, you would 
see the screen scrolled 1 time, with all 16 lines appearing simultaneously.



    Profiles Tab
Use the Preferences, Profile tab to chose your preferred method of updating your 
profiles.

Prompt Before Saving Changes

Click here if you want to be prompted before changes to your profile are saved.

Save Changes Automatically

Click here if you want to save changes to your profiles automatically.

Ignore Changes

Click here if you never want to save changes to your profiles.



    Communication Tab
Use the Preferences, Communication tab to alter the following communication 
parameters:

Answer Back

Allows you to specify an answer to be sent by the terminal in response to the 
enquiry character ENQ (0x05).    Enter an answer back Message, then check the 
Enable checkbox.    The Conceal checkbox is provided for security purposes.    
Concealed messages are displayed and echoed as asterisks and cannot be 
changed once they are concealed.    To erase a concealed message, uncheck the
Conceal checkbox.

Local Mode

Selecting this mode puts the remote host on "hold".    Data entered at the 
keyboard is sent to the screen but not to the remote.    Data received from the 
remote is stored and sent to the screen only after you put the terminal back to 
On-line mode.

On-line Mode

Selecting this mode lets the terminal communicate with the remote host.

Local    Echo

When this box is checked, characters entered at the keyboard are displayed on 
your screen before they are sent to the remote host.    Local Echo should be used
when the remote host is not echoing characters.    If echoing is done both locally 
and by the remote host, your screen may display alternate blank lines or two 
characters for each character typed or may not display any characters when a 
key is pressed, even though the remote application is responding properly.

Local XON/XOFF

When this box is checked, Ctrl+S and Ctrl+Q are not sent to the remote host; 
instead, they are handled internally.    When this box is not checked, Ctrl+S and 
Ctrl+Q are sent to the remote host. Ctrl+S and Ctrl+Q are used for handshaking.

Emulator Type

Operating Mode

VT100 Mode

Limits data characters to 7 bits and limits the use of the keyboard to 
VT100 keys.    Supports ASCII, National Replacement characters and 
special Graphic characters.

Primary DA / ID

Used to inform the remote host of the capabilities (Device Attributes) of your 
terminal.    The operation of some remote host applications may depend on 
this information.    Available Terminal Ids are VT100, VT101, and VT102.    



You may select from DEC or non-DEC varieties.



    Keyboard Tab
Use the Preferences, Keyboard tab to alter the following keyboard settings:

Cursor Key Mode

Used to set the sequences sent to the remote host when you press one of the 
cursor keys.    In Normal mode, normal cursor positioning sequences are sent to 
the remote.    In Application mode, special application control function sequences 
are sent to the remote.    Remote applications may automatically set this mode.

Keypad Mode

Used to set the sequences sent to the remote host when you press one of the 
keys on the numeric keypad.    In Numeric mode, normal numeric sequences are 
sent to the remote.    In Application mode, special application control function 
sequences are sent to the remote.    Remote applications may automatically set 
this mode.    Keypad keys include 0-9, comma, decimal, minus, Enter and PF1 
through PF4.    If not available on your keyboard, these keys may be accessed 
using the Show Auxiliary Keypad option from the Window menu.

Enter Sends

Allows you to set the "Enter" key to send either a CR character or a CR-LF 
combination.

Mouse Positions Cursor

To enable positioning of the cursor using a mouse select this option.

Lock Keyboard

This checkbox allows you to lock or unlock the keyboard.    When the keyboard is 
locked, input from the keyboard is not accepted.    The remote host can also 
direct the terminal to lock its keyboard.    When the keyboard is locked you may 
still access menu items using the mouse or using the appropriate Alt-keys.

Lock UDKs

Checking this box prevents redefinition of the User Defined Keys (UDK's) by the 
remote.    UDK's consist of the keys F6 - F14, Do, Help, and F17 - F20.

Margin Bell

Checking this box enables a bell to be sounded when you type beyond the right 
margin.    If the column width is 80, the bell sounds when the cursor crosses the 
75th column (127th column in the case of 132 column mode).

Backspace Sends

Allows you to set the "Backspace" key to send either the BS (0x080) character or 
the DEL (0x7F) character.    You may use Ctrl-BS to send the opposite of what the
BS key is currently set for.    For example, if you have Backspace Sends set to 
the BS key, Ctrl-BS may be used to send the DEL key.



Lock Is

The "Caps Lock" key on the PC keyboard is taken as the "Lock" key of the VT100
keyboard.    You can choose this "Lock" to behave as a plain "Caps Lock" or as a 
"Shift Lock".    Using the Shift key with either "Shift Lock" or "Caps Lock" on 
cancels the effect of the lock.

Related Topics

    

 



    Tab Stops Tab
Use the Preferences, Tab Stops tab to alter the tab stops.    In this tab, you may set or
clear tab stops at different column positions.    A set tab is indicated by a "T" at the 
column number.    To set or clear a tab stop at a particular column position, double-
click the mouse at that position.    

Clear All

To clear all tab settings, click the Clear All button.

Interval

Set tab stops uniformly at a specified interval, enter the appropriate Interval and 
click the Set Interval button.    Some remote applications may automatically set 
tab settings.



    Fonts Tab
To set the current font for your VT100 session, use "Preferences, Fonts".    VT100 
supports fonts present in the Windows system resources.    Any of the available fonts 
and point sizes may be selected.

Font

Used to select the current font from the fonts present in the Windows system 
resources.    In addition, VT100 provides the FTC fonts which support graphics 
characters such as those in the DEC special graphics character set.    Proper 
graphical representations of the control codes in the Display Control mode are 
available only in the "FTC-SansSerif" font.

Note: Choosing a font which is application specific and non-standard (so far as 
Windows is concerned) might lead to unpredictable visual effects.

Size

Used to select the point size of the currently selected font.    (See above for a 
description of FTC font sizes.)

Language

Used to set VT100 for operation with a national character set.    You should first 
set up your version of Windows to recognize your keyboard as a national 
keyboard.    This is done through International settings in the Windows Control 
Panel.

National Mode

If you select to work in non-National Mode, VT100 generates DEC multinational 
codes to correspond to your national set.    If you select National Mode, VT100 
generates DEC National Replaceable codes.    This choice may be dictated by 
the application you are using.    Note that National Mode must be selected for the 
Compose Characters feature to function properly.

Sample

Displays a text sample using the currently selected font and font size.

Fit Font to Window At

This feature allows you to enable automatic scaling of fonts to fit the current 
VT100 window size.    You can also set the number of columns that are to fit in 
the VT100 window when automatic scaling of fonts is enabled.    Note that the 
automatic scaling feature is disabled for raster fonts.    Note also that the 
automatic scaling feature is not supported in Windows 3.0.

Related Topics

    





    Colors
To set the current color combination for your VT100 session, use "Preferences, 
Colors".    VT100 supports custom color combinations, including colors set as defaults
through the Windows Control Panel.

Sample

Displays a sample that shows window text against window background using the 
color combination currently selected.

Follow Control Panel Settings

When this box is checked, VT100 will use the default text color and default 
background color set through the Windows Control Panel.    To edit this color 
combination for VT100, uncheck this box - the editing controls described below 
will be enabled.

Window Text

Click here if you wish to begin modifying the color of the window text.

Window Text Background

Click here if you wish to begin modifying the color of the window text background.

Workspace Background

Click here if you wish to begin modifying the color of the workspace background.

Workspace Pattern

Click here if you wish to begin modifying the color of the workspace pattern color.

Workspace Pattern Style

Used to select one of the following pattern styles for your workspace:

Cross

Dark Shade

Diagonal

Diagonal Cross Hatch

Downward Hatch 

Horizontal Hatch

Light Shade

Solid

Vertical Hatch.



Red / Green / Blue

Used to change the Red/Green/Blue mixture used to form a color.



    Command Line Parameters
If you frequently need to run VT100 with the same default parameters, you may 
create additional VT100 icons for connecting to various hosts and specify different 
default parameters for each.    Follow these steps:

Click once on the VT100 icon.

Select Copy from the File menu of Program Manager and choose New 
Program Item to create a new copy of the VT100 icon.

Select Properties from the File menu of Program Manager to change the 
Command Line and Description for the new icon.

The VT100 command line has the following syntax:

VTTERM [-d<profile-name>] [-h<hostname>] [-p<port-no>] ]-t]

where

<profile-name> Name of the profile to load on startup.    The profile-name
must already exist.    If a profile-name is not specified, an
(Untitled) profile having the default factory settings is 
loaded.    Note that even if there is a hostname 
associated with the given profile, a connection will not 
automatically be attempted to that host; the optional 
<hostname> parameter must be specified as well.

<hostname> The hostname or Internet address of the remote host to 
which you wish to connect.    If a valid <hostname> is 
specified on the command line, connection occurs 
immediately.    Otherwise, no automatic connection 
attempt will be made.

<port-no> The port number to use when connecting.    A port 
number may be specified on the command line without a
hostname when a special port is needed for several 
sessions but a different host is to be used for each.    If 
no port number is specified, the default Telnet port (port 
23) is assumed.

The -t flag specifies whether Telnet negotiation will be done on a non-Telnet port; i.e., 
a port other than the default of 23.    This option is only necessary when connecting to
a Telnet server on a non-Telnet port.    This option applies only to non-Telnet ports 
because Telnet negotiation will always be done on the Telnet port.    If this option is 
not specified, the default is to use Telnet negotiation on the Telnet port, and not to use
negotiation on all other ports.





    Establishing a A VT100 Session
You may establish a VT100 session using the Connect command on the Connect 
menu, or by pressing the Connect button on the button bar.

Hostname

Enter the name of the remote host to which you wish to connect, or use the drop-
down listbox to select a name from those previously entered.    The name must be
a valid hostname, alias, or IP address on the network.

Profile

Enter a profile name or select one from the drop-down listbox.

If the profile you select has a 
hostname and/or port number 
associated with it that DIFFERS 
from the hostname and/or port you 
have entered manually, your 
choices will be overridden by those
of the profile.

If you select the Default profile, the factory settings will be loaded.    For more 
information, see:

Port

Enter a port number to be used for the connection.    The default port number is 
the standard Telnet port (port 23).

Note that spontaneous disconnection may occur if the Telnet connection is lost.    
Some remote hosts may abort the connection if you fail to log in within a specific 
time.    Some hosts will abort the connection immediately after you log out - if you 
wish to log in as another user you may have to connect once again.

Related Topics



    Positioning Cursor Using Mouse
Selecting Keyboard Settings from the Preferences menu allows you to select "Mouse 
Positions Cursor".    If this item is selected, you may double-click the mouse at the 
position you want to place the cursor.    Appropriate cursor positioning sequences are 
sent to the remote host.

Related Topics



    Pausing the Screen Display
When you are connected to a remote host, you may freeze the terminal display by 
using the Pause button on your keyboard or by using Ctrl+S.    To resume the screen 
display, press the Pause key again or use Ctrl+Q.    Pausing the screen is typically 
done when a large amount of data is being continuously displayed and it is rapidly 
scrolled off.    Pausing the screen will put a temporary "hold" on incoming data.    The 
title bar will indicate the "paused" status.    To view data that has already scrolled off 
the screen, use the vertical scroll bar.

If the remote host needs to be able to receive Ctrl+S or Ctrl+Q, then you must 
disable the Local XON/XOFF option, which can be done by selecting Terminal 
Params from the Preferences menu.

Related Topics



    Glossary
Clipboard

Compose Character

Scroll Back Buffer

Soft Reset



    Printing Tab
VT100 supports continuous printing as well as non-continuous "snapshot" printing.    
To activate continuous printing, select either Print Controller Mode or Auto Print 
Mode, then choose the Continuous Print option under the File Menu.    When 
continuous printing is on, this option will appear checked.    Continuous Printing is 
automatically disabled if neither of the two modes are selected, or if there is an error 
during printing.    If there is an error during continuous printing, rectify the cause of the
problem, then resume continuous printing by reselecting the Continuous Print option.

Non-Continuous Print Extent

For non-continuous "snapshot" printing, you may choose how much data is to be 
printed.    The choices are:

Selected Text - Selected portion of the screen.

Entire Screen - Entire screen (24 lines) starting from the first visible line in the
window.

Entire Buffer    -    The entire scroll-back buffer.

Non-Continuous Print Style

For non-continuous "snapshot" printing, you may choose from the plain text or 
bitmap styles of printing.    Print Style governs the style of printing for your print 
requests as well as requests received from the remote.    If the bitmap style is 
selected, you may choose "Reverse Video" (using "Preferences, Terminal 
Parameters") to print data with foreground and background colors swapped.    If 
Continuous Printing is enabled and you switch to bitmap style, any further 
change to the Print Style will be effective only after Continuous Printing is 
stopped.

Continuous Print Mode

Print Controller Mode

If this mode of continuous printing is selected, characters are sent to the 
printer without being displayed on the screen.    The characters NUL, XON, 
XOFF and those sequences that set and reset this mode are not sent to the 
printer.    If both Auto Print Mode and Print Controller Mode are selected, the 
latter takes precedence.

Auto-Print Mode

If this mode of continuous printing is selected, display lines are automatically 
printed when you move the cursor to the next line (using a line-feed, form-
feed, vertical tab or autowrap).

Setup

Click this button to access the Windows Printer Setup dialogs.    At least one 
printer must be properly configured.



Related Topics

    



    Prompt on Disconnect
This item on the Preferences menu toggles whether VT100 will prompt you for 
confirmation prior to disconnecting from a remote host.    VT100 will not prompt for 
confirmation if the Prompt on Disconnect menu item is unchecked.

Related Topics

 



    Exit VT100 on Disconnect
This item on the Preferences menu toggles whether or not VT100 will close 
automatically when you disconnect from the remote host.    When this menu item is 
checked, VT100 will automatically close whenever you disconnect from a remote 
host.

Related Topics

 



    Enable 'CTRL+KEY' Accelerators
This item on the Preferences menu toggles whether or not 'Ctrl+Key' Accelerators are
enabled.    When this menu item is checked, Ctrl+C will function as an accelerator 
key for the "Edit, Copy" command.    When this menu item is not checked, Ctrl+C will 
send a Ctrl+C to the remote host.

Related Topics



    Logging Tab
The following options may be set for logging data to a file.

Non-Continuous Log Extent

For non-continuous "snapshot" logging, you may choose how much data is to be 
put in the log file.

Selected Text - Selected portion of the screen.

Entire Screen - Entire screen (24 lines) starting from the first visible line in the
window.

Entire Buffer    -    The entire scroll-back buffer.

Log Style

For continuous logging, you may choose from two logging styles: all characters 
or display characters only.    If Continuous Logging is enabled (on the File menu) 
and you switch Log Styles, any further change to the Log Style will be effective 
only after Continuous Logging is stopped.

File

Clicking this button allows you to specify the name of the file to be used for 
logging.    You may select an existing file or enter the name of a file to be created.

Related Topics



Clipboard

A temporary storage area for copying text or graphics.    Only text may be pasted to 
an insertion point specified by the cursor.



Compose character

Pressing the compose character key starts a compose sequence.    It is used to 
create characters that cannot be typed directly from the keyboard.



Scroll-back buffer

The scroll-back buffer is used to hold data that has scrolled past the top of your 
screen.    You may view the contents of the scroll-back buffer by using the vertical 
scroll bar at the right of the application window.



Soft Reset

A soft reset sets the terminal to its power-up default states.    This sequence can be 
sent by the remote host or issued via "Reset Terminal" on the Window menu.



Recall

The Recall facility allows you to retrieve the name of a remote host to which you have
previously tried to connect (with the "Set Recall" facility enabled).




