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Overview
µVision for Windows is an integrated software development platform that supports the Keil Software 
development tools for the 8051, 251, and 166 microcontrollers.    µVision includes features such as a 
windowed user interface, a fullfunction editor, a project manager, a make facility, and an integrated help 
system.

This manual is written for experienced programmers who are already familiar with the Windows operating 
system, microprocessor architecture, and programming using the C programming language.

You use the builtin features of µVision as well as external tools to create and edit your source files, create 
a project file (with automatic make information), and build a target (usually an absolute object file).    The 
rest of this chapter briefly lists the features of µVision that help you do this and also explains how to start 
the µVision programming environment.

Related Topics:
Basic Features



Basic Features
To help expedite the software development process, µVision offers numerous features like:

· A pulldown menu system,

· Multiple file editing capability,

· Fullfunction editor with color syntax highlighting, userdefinable key sequences, and editor 
functions,

· Application manager for accessing external programs,

· Project manager and automated make facility for building target files,

· Dialog Boxes for all environment and development tool settings,

· Help System that describes details of µVision program operation.

These features, as well as many more, are described throughout the remainder of this manual.



Program and Data Files
µVision comes with a number of program and configuration files.    These files are listed in the following 
table.

Filename Description
UVWIN.EXE The µVision for Windows executable program.
UVWIN.INI Initialization data file for µVision.    This file contains the option 

settings that are restored each time you use µVision.    µVision 
attempts to load UVWIN.INI from the directory where 
UVWIN.EXE is located.

UVWIN.HLP Help file for µVision.    This file contains the help text that you 
may access through the Help menu.

UVWIN.TPL Editor template file.    This file contains the template replacement 
text that µVision uses.    µVision attempts to load UVWIN.TPL 
from the directory where UVWIN.EXE is located.

WINRUN.EXE The MSDOS executor for the assembler, compiler, and other 
DOSbased tools.    This program runs and traps error messages 
from the development tools.

WINRUN.PIF The Windows program information file (PIF) for WINRUN.EXE.
*.DLL Tool set support library.    DLLs are provided for supporting the 

Keil 8051, 251, and 166 development tools.
*.HLP Help files for µVision and the 8051, 251, and 166 tools.
????XLAT.EXE Error translator programs.    These programs converts error 

output data into µVision compatible error data.

Screen Components
You use µVision to create and maintain the source files, configuration files, and initialization files that 
compose your project.    Specifically, you use the menu commands, tool bar, status bar, and other screen 
components to manipulate the text in a window.



The µVision screen provides you with a menu bar for command entry, a tool bar where you can rapidly 
select command buttons, and one or more windows for source files, dialog boxes, and information 
displays.

Related Topics:
Menu Conventions
Using the Tool Bar
Using the Status Bar



Horizontal Scroll Bar
Scrolls the contents of the source window left and right.



Vertical Scroll Bar
Scrolls the contents of the source window up and down.



Tool Bar
Contains buttons for the most frequently used commands.



Status Bar
Lists information about the source window.



Source Window
Displays the contents of a file.    You use this window to enter text and make changes to a source file 
using the mouse and the keyboard.    Text you type in this window is inserted in the the corresponding 
source file.



Source Window Title
Displays the file that is associated with a source window.



Title Bar
Displays "µVision", the name of the tool set supported, and the name of the active project.



Menu Bar
Shows the menus available.



Menu Conventions
Commands listed in the menus may invoke editor functions or they may present dialog boxes.    The 
following table lists the conventions used for the command names in the menus.

Menu Convention Description
A key combination listed to 
the right of a command

Indicates a shortcut for this menu command.    You 
may use this key combination to execute this menu 
command without opening the menu.    You may 
change key combinations for most commands from 
the Key Assignments dialog box.

An ellipses (...) following a 
menu command

Indicates the command opens a dialog box.

A dimmed out menu 
command

Indicates that the command is not available in the 
current context.    For example, the cut and copy 
commands in the edit menu are dim until a text block 
is selected.

Using the Tool Bar
You can quickly access many of the features of µVision using the buttons on the tool bar.

Click on a button for more information.



New File
Opens an empty source window.    You may enter text in this window and save it.



Open
Opens the File Open dialog box where you may select a file to open.



Save
Saves the contents of the active window.



Print
Prints the contents of the active window or prints the selected text block from the active window.



Find
Opens the Search dialog box where you may specify text to find.



Repeat Find
Searches for the most recently specified search criterion.



Compile
Compiles or assembles a file.



Update
Updates a project.    Use this command to compile and assemble only those files that are out of date.



Build All
Forces a build of all components of a project.    Use this command to compile and assemble all files in a 
project.



Tile Horizontally
Tiles source windows horizontally.



Tile Vertically
Tiles source windows vertically.



Color Syntax Highlighting
Enables or disables color syntax highlighting for all source windows.



Show Occurrences
Shows or hides all occurrences of the search criterion specifies in the Search dialog box.



Help
Opens the on-line help system.



Paste Text
Inserts text from the clipboard.



Copy Selected Text
Copies selected text to the clipboard.



Cut Selected Text
Copies selected text to the clipboard and removes it from the active window.



Using the Status Bar
The status bar displays information about the active window and about the mode in which µVision 
operates.

Click on part of the status bar for more information.



Message Area
Displays menu command descriptions, error messages, and other information messages.



Overwrite Mode
Displays OVR when overwrite mode is active.    In overwrite mode, text you type replace existing text.    
This area is blank when insert mode is active.    In insert mode, text you type is inserted before existing 
text.



Read-Only Mode
Displays RDONLY when the file in a source window may not be modified.



Caps Lock
Displays CAPS when Caps Lock mode is enabled.



Num Lock
Displays NUM when Num Lock mode is enabled.



Line Number
Displays the line number of the insertion point.



Column Number
Displays the column position of the insertion point.



Configuring the Editor
You configure the editor in µVision using the Editor Options, the Editor Color, and the Key Assignments 
dialog boxes available from the Options menu.    These dialog boxes let you set editor preferences, color 
settings, and keys used to access editor functions.

Related Topics:
Editor Options
Editor Font
Editor Colors
Key Assignments



Editor Options
The Editor Options dialog box lets you configure how µVision's built-in editor operates.    Use the controls 
in this dialog box to change options for sounds, source files, and editing.

Click on a control for more information.



Beep for Errors
Selects whether or not µVision generates a beep when errors are encountered.    If you select this check 
box,    µVision generates error beeps.    If you clear this check box, no error beeps are generated.



Beep for Prompts
Selects whether or not µVision generates a beep when important input prompts are displayed.    If you 
select this check box, µVision generates prompt beeps.    If you leave this check box blank, no prompt 
beeps are generated.



Create Backup Files
Automatically creates backup files (.BAK) for all your edited and saved files.



Keep Error Files
Retains compiler and assembler error files for future use.    If this check box is blank, error files are 
deleted.



Save Files Before Shell
Saves all modified files before running make.    When this check box is not selected, files are not saved 
before running make.



Restore Last Session
Restores the text files and project open during your last session.    If this check box is left blank, files are 
not reloaded.



Color Syntax Highlighting
Selects whether or not µVision colors C language elements using the colors defined in the Editor Colors 
dialog box.    If this check box is selected, µVision applies different colors to the elements of the C 
language.    If this check box is not selected, color syntax highlighting is disabled.

You may use the Color Syntax Highlighting Button on the tool bar to quickly toggle syntax highlighting.

    Color Syntax Highlighting Button



Auto-Indent
Automatically indents the insertion point to the column position of the first character on the previous line.   
If the previous line is blank, the insertion point returns to column 1.



Insert Spaces for Tabs
Inserts spaces, rather than a tab character, when the Tab key is pressed.



Windows-style text marking
Enables Microsoft Windows-style text marking.    You may use the Shift and the Cursor keys to rapidly 
mark a text block.



Tabs
Sets tab stops.    µVision supports programmable tab spacing.    Use this control to specify what column 
positions to use for tab stops.    Each number specified must be separated by one or more spaces.    
µVision automatically repeats the width of the last tab.

Columns in the editor start at 1, not 0.    So, for example, if you want tabs every 8 columns, the Tabs input 
field should be "9, 17, 25".    Since the last tab width is repeated, tab stops are also set at 33, 41, 49, 57, 
65, 

µVision defaults to tab positions every 8 columns.



Editor Font
The Font dialog box lets you select the typeface used in the edit windows.

Click on a control for more information.



Font
Selects fixed point fonts installed on your computer.    You may select system fonts and fixed point 
TrueType fonts.



Font Style
Selects the style of the font.    Available styles depend on the font.    Regular, italic, bold, and bold italic 
are typical.



Size
Selects the size of the font.



Sample
Shows a sample of text displayed using the selected font.



Editor Colors
The Editor Colors dialog box lets you select the colors used by µVision for the edit windows, output 
windows, and syntax highlighting used for your C source files.

Related Topics:
Editor Colors: Edit Window
Editor Colors: Output Window
Editor Colors: Color Syntax



Editor Colors: Edit Window
The Edit Window thumb tab in the Editor Colors dialog box lets you change the colors associated with the
edit window.

The color elements you may configure are described in the following table.
Element Description
Default Text Normal text displayed in edit windows.
Highlighted Text Text in a text block.
Error Selection Text that caused a compiler or assembler error.

Editor Colors: Output Window
The Output Window thumb tab in the Editor Colors dialog box lets you change the colors associated with 
the error window and other output related windows.

The color elements you may configure are described in the following table.
Element Description
Output Text Normal text in the error window.
Error Selection Selected text in the error window.



Editor Colors: Color Syntax
The Color Syntax thumb tab in the Editor Colors dialog box lets you change the colors associated with 
syntax highlighting.

The color elements you may configure are described in the following table.
Element Description
Comment A comment in the source file.
Reserved Word A reserved word like int, for, or while.
Identifier A variable name or a function name.
Symbol A symbol character like +, *, or >>.
String A string enclosed within double quotes ("").
Decimal Const A decimal number.
Float Const A floating-point number.
Octal Const An octal number.
Hex Const A hexadecimal number.
Char Const A character constant like 'a'.
Preprocessor Cmd A preprocessor command like #include.
Syntax Error Any character that generates a syntax error.

Element
Shows the elements whose colors may be changed.



Sample
Shows the color combination for the selected element.



Foreground
Displays the available foreground colors.



Background
Displays the available background colors.



Key Assignments
The Key Assignments dialog box lets you assign key strokes to editor functions, identify assigned keys, 
change or clear key assignments,.and save and restore key schemes.



Function
Lists the available editor functions.



Identify Key Sequence
Displays the Identify Key Sequence dialog box where you may type a sequence of key strokes for which 
to search.



Assignment
Displays the active key assignment.



Change
Changes the active key assignment.



Clear
Clears the active key assignment.



Schemes
Displays the active key assignment scheme.



Save
Saves a key assignment scheme.



Remove
Removes a key assignment scheme.



Editing Files
The primary function of µVision is to provide a method of creating and changing source files.    When you 
read a source file into µVision, the file is displayed in an edit window.    Using the builtin editor functions, 
you can make changes to the text in the edit window.    When finished, you can save the contents of the 
edit window back to disk.

Related Topics:
Opening a Window
Making Changes
Saving Changes
Closing a Window



Opening a Window
µVision lets you open an edit window for a new file or an existing file.

· To open an edit window for a new file, use the New command in the File menu.

· To open an edit window for an existing file, use the Open command the File menu.

Both of these methods are explained below.

Related Topics:
Creating New Files
Opening a File



Creating New Files
To open an edit window for a new file, you must select the New command from the File menu.

To open an edit window for a new file using the mouse…

1. Click on the File    menu.    The menu displays.

2. Click on the New command.

To open an edit window for a new file using the keyboard…

1. Press Alt+F to open the File menu.

2. Press N to select the New command.

The name of the file associated with a window is centered on the title bar of the window.    New edit 
windows are not associated with a filename (until you save the contents of the window) and are initially 
given the name <Untitled>.

You may use the New Button on the tool bar to quickly create a new file.

    New Button



Opening a File
To open an edit window for a file that already exists, select the Open command from the File menu and 
use the controls in the Open dialog box to select the file you want to edit.

To access the File Open dialog box using the mouse…

1. Click on the File menu.    The menu displays.

2. Click on the Open command.

To access the File Open dialog box using the keyboard…

1. Press Alt+F to open the File menu.

2. Press O to select the Open command.

You may use the Open Button on the tool bar to quickly open a file.

    Open Button



Making Changes
To change the text in an edit window, you use the keyboard and the mouse to select the text you want to 
alter and the keyboard to type in the changes.

To change the text in an edit window using the mouse…

1. Use the mouse to position the cursor on the screen at the text you want to change and click.    If 
the text you want to change is not displayed in the window, scroll the contents of the window up 
or down using the vertical scroll bar, then select the text.

2. Type the changes you want to make on the keyboard.

To change the text in an edit window using the keyboard…

1. Use the cursor keys and the PgUp, PgDn, Home, and End keys to move the cursor to the part of
the text file you want to change.

2. Type the changes you want to make to the text file.



Saving Changes
When you save changes to an edit window, µVision writes the entire file to the disk.    If there is a filename
already associated with the edit window, µVision overwrites that file with the new data.    If the edit window
was opened using the New command, µVision prompts you with the Save As dialog box.    Here, you must
specify a filename in which to save the window contents.

To save changes to an edit window using the mouse…

1. Click on the File menu.    The menu displays.

2. Click on the Save command.

To save changes to an edit window using the keyboard…

1. Press Alt+F to open the File menu.

2. Press S to select the Save command.

You may use the Save Button on the tool bar to quickly save a file.

    Save Button



Closing a Window
To close an edit window, select the Close command from the File menu.    If you changed the contents of 
the edit window, µVision prompts you to save the file before closing it.



Using Editor Functions
The following functions are available in the µVision editor.

Related Topics:
Beginning of File
Beginning of Line
Beginning of Page
Cascade Windows
Case Sensitivity Toggle
Check C Braces
Close File
Copy to Clipboard
Copy to File
Cursor Down
Cursor Left
Cursor Right
Cursor Up
Cut to Clipboard
Decrease Hex Value
Delete
Delete Line
Delete to End of Line
Destructive Backspace
End of File
End of Line
End of Page
Exclusive Mark
Exit
Forward Replace
Full Search
Hex/ASCII Switch
Increase Hex Value
Insert Template
Insert/Overwrite Toggle
Jump to Line
Mark Block
Mark Columns
Mark Lines



New File
Next Error
Next Window
Open File
Page Down
Page Up
Paste from Clipboard
Paste from File
Previous Error
Previous Window
Print File
Project, Build
Project, Update
Repeat Last Replace
Repeat Last Search
Revert to Saved File
Run Translator
Save All
Save As
Save current file
Show/Hide Search
Tab Left
Tab Right
Tile Horizontally
Tile Vertically
Undo
Word Left
Word Right



Beginning of File
Keys: Ctrl+Home
Menu: None

The Beginning of File editor function moves the cursor to the beginning of the file.



Beginning of Line
Keys: Home
Menu: None

The Beginning of Line editor function moves the cursor to the beginning of the line.



Beginning of Page
Keys: None
Menu: None

The Beginning of Page editor function moves the cursor to the top line of the window.



Cascade Windows
Keys: None
Menu: Window

The Cascade Windows editor function arranges windows so that the title of each is visible on the screen.



Case Sensitivity Toggle
Keys: Ctrl+F5
Menu: None

The Case Sensitivity Toggle editor function toggles between case sensitivity and case insensitivity for 
the quick search editor functions.



Check C Braces
Keys: Ctrl+[
Menu: Tools

The Check C Braces editor function checks braces ({) and (}) in C files to make sure they match.    If the 
braces in the file do not match, µVision displays a dialog box with a warning messageand positions the 
insertion point at the mismatched brace.    If the braces do match, µVision displays a dialog box indicating 
so.



Close File
Keys: Ctrl+F4
Menu: File

The Close File editor function closes the active window.



Copy to Clipboard
Keys: Ctrl+C
Menu: Edit

The Copy to Clipboard editor function copies a marked text block to the clipboard.

Use the Copy Button on the tool bar to quickly copy text from the active file.

    Copy Button



Copy to File
Keys: None
Menu: None

The Copy to File editor function copies a marked text block to a file.



Cursor Down
Keys: Cursor Down
Menu: None

The Cursor Down editor function moves the cursor down one line.



Cursor Left
Keys: Cursor Left
Menu: None

The Cursor Left editor function moves the cursor left one column but does not wrap around to the end of 
the previous line.



Cursor Right
Keys: Cursor Right
Menu: None

The Cursor Right editor function moves the cursor right one column but does not wrap around to the 
beginning of the following line.



Cursor Up
Keys: Cursor Up
Menu: None

The Cursor Up editor function moves the cursor up one line.



Cut to Clipboard
Keys: Ctrl+X
Menu: Edit

The Cut to Clipboard editor function copies a marked block to the clipboard and deletes the block from 
the window.

Use the Cut Button on the tool bar to quickly cut text from the active file.

    Cut Button



Decrease Hex Value
Keys: None
Menu: None

The Decrease Hex Value editor function subtracts 1 from the hexadecimal value shown in hex edit mode.
This editor function is only available in hex edit mode.



Delete
Keys: Del
Menu: None

The Delete editor function erases the character to the right of the cursor.    If a block is marked, the Delete
function erases the entire block.



Delete Line
Keys: Ctrl+Y
Menu: None

The Delete Line editor function deletes the line at the cursor.



Delete to End of Line
Keys: Ctrl+T
Menu: None

The Delete to End of Line editor function erases the text from the current cursor position to the end of 
the line.



Destructive Backspace
Keys: Bksp
Menu: None

The Destructive Backspace editor function erases the character to the left of the cursor but does not 
wrap around to the end of the previous line.



End of File
Keys: Ctrl+End
Menu: None

The End of File editor function moves the cursor to the end of the file.



End of Line
Keys: End
Menu: None

The End of Line editor function moves the cursor to the end of the current line.



End of Page
Keys: None
Menu: None

The End of Page editor function moves the cursor to the bottom line of the window.



Exclusive Mark
Keys: None
Menu: None

The Exclusive Mark editor function marks a block of text, but does not include the character at the end of
the block.

To mark a block using the mouse…

1. Move the mouse pointer to the first character of the block you wish to mark.

2. Drag the mouse cursor past the last character you wish to mark.

3. Release the Mouse button.



Exit
Keys: None
Menu: File

The Exit editor function exits µVision.



Forward Replace
Keys: None
Menu: Edit

The Forward Replace editor function searches forward for an occurrence of specified text and optionally 
replaces the located text with a replacement string.    When invoked, the Forward Replace editor function 
displays the Replace dialog box.    This is where you enter the text for which you want to search and the 
replacement text.

Each time the Forward Replace editor function locates the specified search text, µVision prompts you to 
verify the replacement.



Text to search for
Specifies the text to search for.



Replacement Text
Specifies the replacement text.



Case Sensitivity
Specifies that the search should match the case of the search string.



Whole words only
Specifies that only whole words should be replacement.



Forward search
Specifies that the replacement proceed to the end of the file.



Backward search
Specifies that the replacement proceed to the beginning of the file.



From cursor
Specifies that the replacement begin from the current insertion point.



From top of tile
Specifies that the replacement begin from the beginning of the file.



Full Search
Keys: Alt+F3
Menu: Edit

The Full Search editor function searches forward for an occurrence of specified text.    Options are 
provided to control search parameters.    When this function is invoked, the Search dialog box displays.    
This is where you enter the text for which you want to search.    In this box, you also specify the options 
that control the search parameters.

When you begin a search, µVision moves the cursor to the location of the next string in your text that 
matches the search criteria in the Search dialog box.

After locating the first matching search string, you may use the Repeat Last Search editor function to find
the next matching string.



Text to search for
Specifies the text to serach for.



Case Sensitivity
Specifies that the search shoudl match the case of the search string.



Whole words only
Specifies that only whole words should be compared.



Mark All occurrences
Specifies that the search should mark all occurrences of the search string.



Forward search
Specifies that the search proceed to the end of the file.



Backward search
Specifies that the search proceed to the beginning of the file.



From cursor
Specifies that the search begin from the current insertion point.



From top of tile
Specifies that the search begin from the beginning of the file.



Hex/ASCII Switch
Keys: Ctrl+H
Menu: Window

The Hex/ASCII Switch editor function toggles the text file between ASCII and hex edit modes.



Increase Hex Value
Keys: None
Menu: None

The Increase Hex Value editor function adds 1 to the hexadecimal value shown in hex edit mode.    This 
editor function is only available in hex edit mode.



Insert Template
Keys: Shift+F2
Menu: None

The Insert Template editor function replaces text with template text from the template file.



Insert/Overwrite Toggle
Keys: Ins
Menu: None

The Insert/Overwrite Toggle editor function toggles between insert mode (new text inserts between 
existing text) and overwrite mode (new text types over existing text).



Jump to Line
Keys: Alt+G
Menu: Edit

The Jump to Line editor function displays the Goto dialog box and waits for you to enter a line number or
a file offset.

This editor function then moves the cursor to the specified line (in ASCII mode) or to the specified file 
offset (in hex edit mode).



Mark Block
Keys: None
Menu: None

The Mark Block editor function marks a block of text starting at the current cursor position.

To mark a block using the mouse…

1. Move the mouse pointer to the first character of the block you wish to mark.

2. Drag the mouse cursor past the last character you wish to mark.

3. Release the Mouse button.

To mark a block using the keyboard…

1. Use the cursor keys to position the cursor to the beginning of the block.

2. Press Alt+M to invoke the Mark Block editor function.

3. Move the cursor to the end of the block.



Mark Columns
Keys: Alt+C
Menu: None

The Mark Columns editor function marks one or more columns of text starting at the current cursor 
position.

To mark a column using the mouse…

1. Press and hold the Ctrl key.

2. Move the mouse pointer to the first character of the column you wish to mark.

3. Drag the mouse cursor to the last character of the column you wish to mark.

4. Release the Mouse button.

To mark a column using the keyboard…

1. Use the cursor keys to position the cursor to the beginning of the column.

2. Press Alt+C to invoke the Mark Column editor function.

3. Move the cursor to the end of the column.



Mark Lines
Keys: Alt+L
Menu: None

The Mark Lines editor function marks one or more lines of text start at the current insertion point.

To mark lines using the mouse…

1. Press and hold the Shift key.

2. Move the mouse pointer to the first line you wish to mark.

3. Drag the mouse cursor to the last line you wish to mark.

4. Release the Mouse button.

To mark lines using the keyboard…

1. Use the cursor keys to position the cursor to the first line.

2. Press Alt+L to invoke the Mark Lines editor function.

3. Move the cursor to the last line.



New File
Keys: Ctrl+N
Menu: File

The New File editor function creates a new edit window.

You may use the New Button on the tool bar to quickly create a new file.

    New Button



Next Error
Keys: F4
Menu: Edit

The Next Error editor function positions the insertion point at the line where the next error was 
encountered.



Next Window
Keys: F6
Menu: None

The Next Window editor function makes the next window in the window list the active window.



Open File
Keys: Ctrl+O
Menu: File

The Open File editor function displays the Open dialog box and lets you select a file to edit.

You may use the Open Button on the tool bar to quickly open a file.

    Open Button



Page Down
Keys: PgDn
Menu: None

The Page Down editor function moves the cursor down the file one page.



Page Up
Keys: PgUp
Menu: None

The Page Up editor function moves the cursor up the file one page.



Paste from Clipboard
Keys: Ctrl+V
Menu: Edit

The Paste from Clipboard editor function copies text from the clipboard to the insertion point.

Use the Paste Button on the tool bar to quickly paste text into the active file.

    Paste Button



Paste from File
Keys: Ctrl+R
Menu: None

The Paste from File editor function copies text from a file to the insertion point.



Previous Error
Keys: Shift+F4
Menu: Edit

The Previous Error editor function positions the cursor at the line where the previous error was 
encountered.



Previous Window
Keys: Shift+F6
Menu: None

The Previous Window editor function makes the previous window in the window list the active window.



Print File
Keys: Ctrl+P
Menu: File

The Print File editor function prints the contents of the selected window.    If a text block is marked, the 
Print File editor function prints only the text in the block.

You may use the Print Button on the tool bar to quickly print a file.

    Print Button



Project, Build
Keys: Alt+F8
Menu: Project

The Project, Build editor function compiles and assembles all source files in a project and rebuilds the 
output target file.

You may use the Build All Button on the tool bar to quickly build all files in the project..

    Build All Button



Project, Update
Keys: Shift+F8
Menu: Project

The Project, Update editor function compiles and assembles a project's source files that have changed 
and rebuilds the output target file.

You may use the Update Button on the tool bar to quickly update the changed files the project.

    Update Button



Repeat Last Replace
Keys: None
Menu: Edit

The Repeat Last Replace editor function repeats the last Replace.



Repeat Last Search
Keys: F3
Menu: Edit

The Repeat Last Search editor function repeats the last Search.



Revert to Saved File
Keys: None
Menu: File

The Revert to Saved File editor function abandons changes to the current file and reloads the file from 
disk.



Run Translator
Keys: Ctrl+F8
Menu: Project

The Run Translator editor function invokes the compiler or assembler for the active window.

You may use the Compile Button on the tool bar to quickly compile the active source file.

    Compile Button



Save All
Keys: None
Menu: File

The Save All editor function saves all modified files.



Save As
Keys: None
Menu: File

The Save As editor function displays the Save As dialog box and lets you save the contents of the active 
window in the specified file.



Save current file
Keys: Alt+S
Menu: File

The Save current file editor function saves the contents of the selected window.

You may use the Save Button on the tool bar to quickly save a file.

    Save Button



Show/Hide Search
Keys: None
Menu: Edit

The Show/Hide Search editor function toggles the display of search string matches in a source file.

Use the Show Occurrences Button on the tool bar to quickly highlight all occurrences of the search text.

    Show Occurrences Button



Tab Left
Keys: Shift+Tab
Menu: None

In insert and overwrite mode, the Tab Left editor function moves the cursor one tab stop to the left without
erasing tabs or characters.



Tab Right
Keys: Tab
Menu: None

In overwrite mode, the Tab Right editor function moves the cursor one tab stop to the right.    In insert 
mode, the Tab Right editor function inserts a tab character into the text file.



Tile Horizontally
Keys: None
Menu: Window

The Tile Horizontally editor function displays all windows so that they do not overlap.    Windows are 
displayed with emphasis given to the width of the window.

Use the Tile Horizontally Button on the tool bar to quickly tile all windows horizontally.

    Tile Horizontally Button



Tile Vertically
Keys: None
Menu: Window

The Tile Vertically editor function displays all windows so that they do not overlap.    Windows are 
displayed with emphasis given to the height of the window.

Use the Tile Vertically Button on the tool bar to quickly tile all windows vertically.

    Tile Vertically Button



Undo
Keys: Ctrl+Z
Menu: Edit

The Undo editor function cancels the previous edit operations.    This function lets you to undo all your 
edits.    Undo reverses the effect of editor functions one at a time in a last-in-first-out fashion.    Undo 
information is stored only from the last save in an edit session.    All but the following operations on a text 
window can be undone:

· saving files,

· printing files,

· compiling files,

· starting µVision,

· exiting µVision.

You can even use Undo as a temporary bookmark if you want to take a look at another part of the file.    
To do this, move to the part of the file you want to see, examine the code there, and use the Undo editor 
function to return you to your original position in the file.

µVision stores undo information in disk files.    This allows the size of the undo buffer to be virtually 
unlimited.    A new undo file is created for each file you have open.    Undo files are given the filename $
$EDUNDO.??? where ??? is a number from 000 to 999.



Word Left
Keys: Ctrl+Cursor Left
Menu: None

The Word Left editor function moves the cursor to the beginning of the word on the left.    If the cursor is 
at the left side of the window, the cursor moves to the last word on the previous line.



Word Right
Keys: Ctrl+Cursor Right
Menu: None

The Word Right editor function moves the cursor to the beginning of the word on the right.    If the cursor 
is at the end of the line, the cursor moves to the first word on the following line.



Operational Modes
Read-Only Mode
Hex Edit Mode
Insert Mode and Overwrite Mode



Read-Only Mode
Files that have the read-only file attribute set or files that you specifically open as read-only may not be 
modified by µVision.    To make changes to a read-only file, you must save the file with a different name 
using the Save As command.    You may also copy text from the file to the clipboard and copy the 
clipboard contents to a new edit window.

µVision displays the RDONLY indicator in the status bar if a file is read-only.



Hex Edit Mode
It is often necessary to insert extended ASCII characters into a file.    Hex edit mode lets you edit a file 
using a mixed ASCII/hex display.    Hexadecimal data is displayed on the left side of the window, and the 
equivalent ASCII characters are displayed on the right side of the window.

In hex edit mode, most editor functions work as they do in normal text mode with the exception that you 
now have ASCII and hexadecimal data displayed simultaneously.    You msy use the Tab key to move 
between the ASCII characters on the right and their hexadecimal representations on the left.



Insert Mode and Overwrite Mode
The editor in µVision operates in either insert mode or overwrite mode.    The current mode is displayed 
on the status bar.    You may switch between insert and overwrite mode using the Insert/Overwrite 
Toggle editor function.

When µVision is in insert mode, text you type is inserted into the current file.    Each character typed 
inserts itself in front of the character that is at the insertion point.

When µVision is in overwrite mode, text you type replaces existing text in the current file.    Each character
typed replaces the character that is at the insertion point.



File Menu
The File menu contains commands that open, save, and close files as well as commands to print and exit 
µVision.

Related Topics:
New Command (File Menu)
Open Command (File Menu)
Save Command (File Menu)
Save As Command (File Menu)
Save All Command (File Menu)
Reopen Command (File Menu)
Close Command (File Menu)
Tool Set Command (File Menu)
Print Command (File Menu)
Print Setup Command (File Menu)
Exit Command (File Menu)



New Command (File Menu)
Opens a new file.    Use this command to create a new, empty file for your source programs.    If you want 
to open an existing file, use the Open Command.

You may use the New Button on the tool bar to quickly create a new file.

    New Button

See Also:
Creating New Files



Open Command (File Menu)
Opens an existing file.    Use this command to open an existing source file.    µVision keeps track of 
recently opened files.    You may select one of them from the bottom of the File Menu.    To create new 
files, use the New Command.

You may use the Open Button on the tool bar to quickly open a file.

    Open Button

See Also:
Opening a File



Save Command (File Menu)
Saves the active file.    Use this command to save changes to a file.    If you want to save to a different file,
use the Save As Command.

You may use the Save Button on the tool bar to quickly save a file.

    Save Button

See Also:
Saving Changes



Save As Command (File Menu)
Displays the Save As dialog box where you may specify the name under which to save the active file.    If 
you want to save the file using its current name, use the Save Command.



Save All Command (File Menu)
Saves all open files.    Use this command to save all files at once.



Reopen Command (File Menu)
Reopens the active file.    This command is available only if the active file has been changed.    µVision 
prompts you before reopening the file.    If you revert to the saved version of the file, all changes are lost.



Close Command (File Menu)
Closes the active file.    If there are changes that have not been saved, µVision asks you if you wish to 
save the changes.    When you close a file without saving it, all changes are lost.

See Also:
Closing a Window



Tool Set Command (File Menu)
Displays the Tool Set Selection dialog box where you may select the tool set µVision uses.    The selected 
tool set determines which option dialog boxes are listed in the Options menu.

Use this command to select the tool set to use for the active project.

See Also:
Tool Set Selection



Print Command (File Menu)
Displays the Print dialog box where you may print the active file.    µVision lets you select whether the 
entire file or only the selected area is printed.    Use the Print Setup Command to select the printer to use.

You may use the Print Button on the tool bar to quickly print a file.

    Print Button



Print Setup Command (File Menu)
Displays the Print Setup dialog box where you may select the printer to use when you print files in 
µVision.    Use the Print Command to print the file.



Exit Command (File Menu)
Ends a µVision session.    When you select this command, µVision prompts you to save files that have 
been changed.



Edit Menu
The Edit menu contains commands that let you manipulating text within the active window.

Related Topics:
Undo Command (Edit Menu)
Cut Command (Edit Menu)
Copy Command (Edit Menu)
Paste Command (Edit Menu)
Delete Command (Edit Menu)
Search Command (Edit Menu)
Search Again Command (Edit Menu)
Replace Command (Edit Menu)
Show Occurrences Command (Edit Menu)
Go To Command (Edit Menu)
Next Error Command (Edit Menu)
Previous Error Command (Edit Menu)



Undo Command (Edit Menu)
Reverses changes to the active file made since the last save.



Cut Command (Edit Menu)
Removes selected text from the active file and puts it on the clipboard.    This command is available only 
when you have selected a text block.    You may paste text you have put on the clipboard using the Paste 
Command.

Use the Cut Button on the tool bar to quickly cut text from the active file.

    Cut Button



Copy Command (Edit Menu)
Copies selected text from the active file and puts is on the clipboard.    This command is available only 
when you have selected a text block.    You may paste text you have put on the clipboard using the Paste 
Command.

Use the Copy Button on the tool bar to quickly copy text from the active file.

    Copy Button



Paste Command (Edit Menu)
Copies text from the clipboard and puts it in the active file at the insertion point.    If a text block in the 
active window is selected, the text from the clipboard replaces it.    Use the Cut Command and the Copy 
Command to put text on the clipboard.

Use the Paste Button on the tool bar to quickly paste text into the active file.

    Paste Button



Delete Command (Edit Menu)
Removes selected text from the active file.    This command is available only when you have selected a 
text block.    Text deleted from a file may only be restored using the Undo Command.



Search Command (Edit Menu)
Displays the Search dialog box where you may specify a text string.    µVision then searches for an 
occurrence of the text string in the active window.    Use this command to position the insertion point at 
specified search string in your text file.    Use the Find Button on the tool bar to quickly open the Search 
dialog box.

    Find Button



Search Again Command (Edit Menu)
Repeats the last search.    Use this menu item to repeat searching for the last string specified in the 
Search dialog box.    Use the Repeat Find Button on the tool bar to quickly repeat a search.

    Repeat Find Button



Replace Command (Edit Menu)
Displays the Replace dialog box where you may specify a string to search for and replace.    This 
command searches for a text string and replaces it with another text string.



Show Occurrences Command (Edit Menu)
Highlights all occurrences of the search string specified in the Search dialog box.    Use this command to 
enable highlighting for strings in your text file that match the specified search string.    Use the Show 
Occurrences Button on the tool bar to quickly highlight all occurrences of the search text.

    Show Occurrences Button



Go To Command (Edit Menu)
Displays the Go To dialog box where you may specify the current line number for the active window.    Use
this command to move the insertion point position to the specified line number.

See Also:
Jump to Line



Next Error Command (Edit Menu)
Moves to the line in the active window containing the next error.    Use this command to move the insertion
point to subsequent errors in your source file.



Previous Error Command (Edit Menu)
Moves to the line in the active window containing the previous error.    Use this command to move the 
insertion point to previous errors in your source file.



Project Menu
The Project menu contains commands to open, edit, save, and close project files; compile source files; 
build or update a project; and download project target files.

Related Topics:
Compile File Command (Project Menu)
Make: Update Project Command (Project Menu)
Make: Build Project Command (Project Menu)
Download to ProROM Command (Project Menu)
New Project Command (Project Menu)
Open Project Command (Project Menu)
Edit Project Command (Project Menu)
Close Project Command (Project Menu)



Compile File Command (Project Menu)
Compiles the file in the active window.    Use this command when you are ready to compile or assemble 
your source file.

You may use the Compile Button on the tool bar to quickly compile the active source file.

    Compile Button



Make: Update Project Command (Project Menu)
Re-compiles or re-assembles files in the project that have been modified.    Use this command to re-build 
only those files from your project that have changed.

You may use the Update Button on the tool bar to quickly update the changed files the project.

    Update Button



Make: Build Project Command (Project Menu)
Builds all files in the project.    Use this command to re-compile and re-assemble all files in your project.

You may use the Build All Button on the tool bar to quickly build all files in the project..

    Build All Button



Download to ProROM Command (Project Menu)
Downloads a program to the ProROM EPROM emulator.    Use this command to download and test your 
application program using ProROM.



New Project Command (Project Menu)
Displays the Create New Project dialog box where you specify the name of a project file to create.

See Also:
Creating a New Project File



Open Project Command (Project Menu)
Displays the Open Project dialog box where you specify the name of the existing project file to open.

See Also:
Opening a Project File



Edit Project Command (Project Menu)
Displays the Project dialog box where you may change the files included in the project.    You may also 
change the options for each file in the project from this dialog box.



Close Project Command (Project Menu)
Closes the project file.    Use this command to close your project.

See Also:
Closing a Project File



Run Menu
The Run menu provides commands for running external application programs and for adding application 
programs to the Run menu using the Application Manager.    Other commands specific to the selected tool
set may be included in this menu as well.

Related Topics:
Run Program Command (Run Menu)
Application Manager Command (Run Menu)



Run Program Command (Run Menu)
Displays the Run Program dialog box where you may specify a program to run.    This is similar to the Run
command in the Program Manager's File menu.

See Also:
Running External Programs



Application Manager Command (Run Menu)
Displays the Application Manager dialog box where you may define additional application programs to link
to the Run menu.    These programs are invoked when you select them from the menu.

See Also:
Application Manager



Options Menu
The Options menu includes comands for setting editor, color, and key assignment options.    In addition, 
commands specific to the selected tool set may be included in this menu.    This includes assembler, 
compiler, linker, and debugger settings.

Related Topics:
Editor Colors Command (Options Menu)
Editor Command (Options Menu)
Key Assignments Command (Options Menu)



Editor Colors Command (Options Menu)
Displays the Editor Colors dialog box where you may select the colors for the edit window, the output 
window, and color syntax highlighting.

See Also:
Editor Colors



Editor Command (Options Menu)
Displays the Editor Options dialog box where you set uptions that controls how µVision's built-in editor 
operates.    You may also specify the defaul text font for the edit windows.

See Also:
Editor Options
Editor Font



Key Assignments Command (Options Menu)
Displays the Key Assignments dialog box where you may specify key sequences to associate with the 
various editor functions.

See Also:
Key Assignments



Tools Menu
The Tools menu provides commands that access many of the tools that are builtin to µVision.

Related Topics:
Check C Braces Command (Tools Menu)
Insert Template Command (Tools Menu)



Check C Braces Command (Tools Menu)
Checks the active window for matching braces.    Use this command to check the braces in your C source 
files.

See Also:
Check C Braces



Insert Template Command (Tools Menu)
Inserts a template.    Use this command to insert template text for a template tag.

See Also:
Insert Template



Window Menu
The Window menu provides commands that let you manipulate the windows on the screen.    Windows 
can be cascaded, tiled, or closed.

Related Topics:
Cascade Command (Window Menu)
Tile Horizontally Command (Window Menu)
Tile Vertically Command (Window Menu)
Close All Command (Window Menu)
Toolbar Command (Window Menu)
Status Bar Command (Window Menu)
Hex/ASCII Switch Command (Window Menu)



Cascade Command (Window Menu)
Displays all windows overlapped so that the title bar of each window is visible.



Tile Horizontally Command (Window Menu)
Displays all windows so that they do not overlap.    Windows are displayed with emphasis given to the 
width of the window.    Use the Tile Horizontally Button on the tool bar to quickly tile all windows 
horizontally.

    Tile Horizontally Button



Tile Vertically Command (Window Menu)
Displays all windows so that they do not overlap.    Windows are displayed with emphasis given to the 
height of the window. Use the Tile Vertically Button on the tool bar to quickly tile all windows vertically.

    Tile Vertically Button



Close All Command (Window Menu)
Closes all windows.    If there are changes that have not been saved, µVision asks you if you wish to save 
the changes.    When you close a file without saving it, all changes are lost.



Toolbar Command (Window Menu)
Toggles the toolbar on or off.    When this command is checked, the tool bar is displayed.

See Also:
Using the Tool Bar



Status Bar Command (Window Menu)
Toggles the status bar on or off.    When this command is checked, the status bar is displayed.

See Also:
Using the Status Bar



Hex/ASCII Switch Command (Window Menu)
Toggles between the ASCII text editor and the hexadecimal editor or Hex Edit Mode.    Use this menu item
to switch into and out of Hex Edit Mode.

See Also:
Hex Edit Mode



Help Menu
The Help menu provides commands that access the on-line help for µVision.

Related Topics:
Contents Command (Help Menu)
Index Command (Help Menu)
Search for Topic Command (Help Menu)
How to use Help Command (Help Menu)



Contents Command (Help Menu)
Displays the µVision on-line help system contents page which provides an outline of the available help 
topics.



Index Command (Help Menu)
Displays an index for the µVision on-line help system.



Search for Topic Command (Help Menu)
Displays the Search dialog box for the µVision on-line help system.    Here, you may specify a topic to 
search for in the help system.



How to use Help Command (Help Menu)
Displays information that describes how to use the Windows help system.



Overview
µVision lets you manage your software development projects in a number of ways.    During development 
or testing, you may wish to compile a single source file to locate warnings and errors.    Later you may 
want to create an absolute object or Intel HEX file for generating your target program.    µVision supports 
both of these development processes.

Before you begin, you must select a tool set to use for your development.    The tool set you choose 
determines which compiler, assembler, linker, and other tools are included in the environment.

Related Topics:
Tool Set Selection



Tool Set Selection
The Tool Set Selection dialog box determines which tool set is included in µVision.    This selection also 
determines which compiler and assembler are used by the make facility.

Select the Tool Set command from the File menu to open the Tool Set Selection dialog box.



Tool Set
Displays the tool sets that are installed on your computer.



Description
Displays the description of the selected tool set.



Single File Support
µVision provides the Compile File command in the Project menu to help you compile and test individual 
source files.    To compile the file in the active window, select the Compile File command.

You may use the Compile Button on the tool bar to quickly compile the active source file.

    Compile Button

µVision uses the file extensions specified in the Make Options dialog box to determine which compiler or 
assembler to use.

To compile or assemble an individual source file, open the file using the Open command in the File menu. 
Then, use the Compile File command from the Project menu.    The Project Status message box displays 
the status of the compilation.

If no errors or warnings are encountered, the Project Status message box displays a status message 
indicating the compilation was successful.



Project File Support
Most embedded programs are composed of many source files.    Some files may require compilation 
using a compiler, some may require assembly using an assembler, and some may require custom 
translation in the process required to build your target program.

To accommodate the intricacies of project maintenance, µVision includes a project manager, which:

· maintains a project file that stores all information about your project,

· keeps a sequenced list of all source files required to build your target file,

· saves the options for the tools,

· checks dependencies of your source files (by scanning your include files) and determines which 
source files are current and which need to be rebuilt,

· compiles and assembles the source files into object files that compose your target file,

· combines object files into a library, absolute object module, or banked object module,

· and, converts created object modules into Intel HEX files.

Essentially, the project manager provides you with a method of maintaining a project so that the target 
program is always uptodate.    All aspects of a project are saved in a project file including:

· a list of the source files that make up the target program,

· the compiler, assembler, and linker commandline options,

· and, the debugger and simulator options; and the make facility options.

Project files end with the PRJ extension.

Related Topics:
Creating a New Project File
Opening a Project File
Editing a Project File
Closing a Project File



Creating a New Project File
To open a new project file, select the New Project command from the Project menu.    This command 
displays the Create New Project dialog box.

To create a new project file, select the drive and directory into which you want to place the new project 
file, enter the name of the project in the File Name text box, and select the OK pushbutton.



Opening a Project File
To open an existing project file, select the Open Project command from the Project menu.    This 
command displays the Open Project dialog box.

To open an existing project file:

1. Select the drive that the file is in from the Drives list box,

2. Select the directory that the file is in from the Directories list box,

3. Select the project filename from the File Name list box.

4. Select the OK phsubutton.



Editing a Project File
Use the Edit Project command from the Project menu to edit the properties for the current project.

The Edit Project command opens the Project dialog box where project source files and options are listed.



Closing a Project File
Use the Close Project command in the Project menu to to close the current project file.    When you close 
a project file, you remove the options and the project file list from memory.    The tool set options are 
restored to the defaults saved in the µVision INI file.



Running External Programs
The Run Program dialog box lets you run external programs.

Open the Run Program dialog box from the Run menu.    This dialog box displays a Command line and 
argument list for the application.

Click on a control for more information.



Command
Lists the full path name to the program.    You may use the Brose pushbutton to rapidly select the 
command.



Arguments
Lists arguments to pass on the command line.



Run Minimized
Reduces the program to an icon when it runs.



Browse
Displays the Run Program dialog box where you may select the drive, directory, and file name for the 
program to run.



Application Manager
The Application Manager lets you link external programs into the Run menu.

Open the Application Manager dialog box from the Run menu.    This dialog box displays a list of 
userdefined programs (applications).    You may insert, remove, or change settings for the applications.    
You may also move applications up or down in the list.    Up to nine external applications may be added.

Related Topics:
Adding an Application
Editing an Application
Removing an Application
Moving an Application
Running an Application



Adding an Application
Before you can invoke an application from the Run menu, use must add it using the Application Mangaer 
dialog box.

To add a program to the application list…

1. Select the Insert pushbutton.

2. Use the Add Application dialog box to select the Application to add.

HINT
You may type Alt+I to rapidly select the Insert pushbutton.

µVision automatically fills in the Menu Text, Initial Directory, and File Name.    You must enter the 
Arguments and select which prompts to use.

Make sure you select the Save pushbutton when you are through making changes.



Editing an Application
After a program has been added to the application list, you may decide to change some of its properties.

To change the properties for a program in the application list…

1. Select the application whose properties you wish to change.

2. Enter the correct information in the Menu Text, Initial Directory, File Name, and Arguments text 
boxes at the bottom of the dialog box.

Make sure you select the Save pushbutton when you are through making changes.



Removing an Application
You may remove unnecessary programs from the application list.

To remove a program from the application list…

1. Select the application you want to remove.

2. Select the Remove pushbutton.

NOTE
The remove operation cannot be undone.    Make sure you select the correct program before you 
proceed.

Make sure you select the Save pushbutton when you are through making changes.



Moving an Application
The application manager lets you move the programs in the application list.

To move a program in the application list…

1. Select the application you want to move.

2. Select the Move Up pushbutton to move the application up one position in the list.

3. Select the Move Down pushbutton to move the application down one position in the list.

HINT
You may type Alt+U to move the application up or Alt+D to move the application down.

Make sure you select the Save pushbutton when you are through making changes.



Running an Application
Programs you add to the application list in the Application Manager dialog box are included in the Run 
menu and may be selected just like any other menu command.



Application List
Lists the application program that have been added to the Application Manager.    Details about each 
application are listed at the bottom of the dialog box.



Insert
Adds a new program to the application list.



Remove
Removes the selected program from the application list.



Move Up
Moves the selected program up in the application list.



Move Down
Moves the selected program down in the application list.



Menu Text
Lists the text displayed in the Run menu for the selected application.    You may use the ampersand 
character (&) in the menu text to specify an accelerator key for the application.



Initial Directory
Lists the initial directory used for the application.



File Name
Lists the filename of the application program.



Arguments
Lists the command-line arguments for the application program.



Prompt for Parameters
Prompts for command-line arguments before running the program.



Prompt before Returning
Prompts for input when the program has completed.



Glossary of Terms
Application Manager
Color Syntax Highlighting
Hex Edit Mode
Insert Mode
Insertion Point
Make
Menu Bar
Overwrite Mode
Project Manager
ProROM
Read-Only Mode
Status Bar
Template
Text Block
Tool Bar



Application Manager
Adds external programs to the Run menu.    Use the application manager to link programs like your in-
circuit emulator, EPROM programmer, or conversion utilities into the µVision menu system.



Color Syntax Highlighting
A method of displaying source files where the different program elements display using different colors.    
This technique helps you visually debug your program before it is compiled.    By coloring different 
program elements, you can easily tell when you have left a comment open or when you have mistyped 
the name of a type specifier.



Hex Edit Mode
An edit mode where you may edit a text file using a mixed ASCII/hex display.    Hexadecimal data is 
displayed on the left side of the window, and the equivalent ASCII characters are displayed on the right 
side of the window.

In hex edit mode, most editor functions work as they do in normal text mode with the exception that you 
now have ASCII and hexadecimal data displayed simultaneously.    Use Tab to move between the ASCII 
characters on the right and their hexadecimal representations on the left.



Insert Mode
An edit mode in which text you type is inserted into the active window.    Each character typed inserts itself
in front of the character at the insertion point.    The Status Bar indicates whether or not you are in insert 
mode..



Insertion Point
Shows where you are in a text file.    The insertion points marks where text is inserted into the active 
window.



Make
Compiles the source files in your project and builds the target file.    Use the make commands (Compile, 
Update, and Build All) to compile or assemble individual files, to update the files in your project which 
have changed, and to completely rebuild an entire project.



Menu Bar
A narrow window below the title bar that contains the names for the menus in µVision.



Overwrite Mode
An edit mode in which text you type replaces existing text in the active window.    Each character typed 
replaces the character at the insertion point.    The Status Bar indicates whether or not you are in 
overwrite mode.



Project Manager
Controls the source files included in your project.    Use the project manager to specify the files in your 
project as well as the order in which they are processed.    You may also add custom tools, user 
programs, and documents to the project.



ProROM
An EPROM emulator that connects between the parallel printer port of your PC and the EPROM socket of
your target hardware.    You download program code (HEX or BINARY) to ProROM to run in your target.    
This eliminates the necessity of erasing and programming a memory device each time you change your 
application.



Read-Only Mode
An edit mode in which the contents of the active window cannot be modified by µVision.    You may specify
that a file is read-only when you open it using the Open dialog box.    µVision automatically opens read-
only files in read-only mode.

To make changes to these files, you must save the file with a different name (using the Save As 
command).    You may also copy text from the file to paste into another edit window.

The Status Bar indicates whether or not you are in read-only mode.



Status Bar
A narrow window at the bottom of the screen that contains status information about the active window.



Template
Text defined in the UVWIN.TPL file.    µVision supports a feature called template editing.    You use the 
features of template editing to rapidly insert repetitive blocks of text using a few keystrokes.    Typically, 
you use this to insert language constructs like for blocks, while blocks, do blocks, or switch blocks.    
However, µVision gives you complete control over the template data that is inserted as well as the name 
or tag that references the template.



Text Block
A selected portion of the active window.    Use the mouse or keyboard to select a line block, column block,
or a character block.    You may cut, copy, delete, and print selected blocks.



Tool Bar
A narrow window below the menu bar that contains buttons for frequently used commands.    You may 
enable or disable the Tool Bar from the Window menu.




