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OrCAD Layout for Windows—introduction

Introduction

Welcome to the OrCAD Layout for Windows Demo, an
interactive tutorial for learning and evaluating OrCAD
Layout for Windows software.

OrCAD Layout for Windows is a family of Windows 3.1,
Windows NT, and Windows 95 printed circuit board (PCB)
design tools. Each package provides a powerful, easy-to-
use solution for PCB design. The OrCAD Layout for
Windows product family was developed from Massteck’s
award-winning MaxEDA PCB Layout System.

The OrCAD Layout for Windows Demo uses many of
OrCAD Layout for Windows’ innovative features, but is
intended only as a product overview. The software included
with this package is a demonstration version; you cannot
save a board design or generate photoplot files from the
board files provided. The files are structured to guide you
through each step in the Layout design flow.

The OrCAD Layout for Windows Demo Guide tells you
which design file to open for each section. Every page of
the guide includes pictures, explanations, and instructions
that correspond to each activity.

Online help is also provided with the OrCAD Layout for
Windows Demo. A complete product documentation set is
provided with your OrCAD Layout for Windows purchase.
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OrCAD Layout for Windows—product family

OrCAD Layout for Windows product family

• OrCAD Layout Plus for Windows

• OrCAD Layout for Windows

• OrCAD Layout Ltd. for Windows
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OrCAD Layout for Windows—product family

OrCAD Layout product family features Layout Plus Layout Layout Ltd.

Placement

Cluster placement •

Density graph •

Manual placement • • •

Matrix placement •

Shove component •
Routing

16-layer batch router • •

Add/delete connection interactively • • •

AutoDFM • •

AutoPath •

Replicate connections • • •

Interactive push-n-shove • •

Online DRC • • •

Single-layer autorouter •
Post processing

23 standard reports • • •

80+ user-configurable reports • • •

Automatic aperture generation • • •

Gerber previewer • • •
Other features

Auto test point generation • •

AutoECO • • •

Intelligent copper pour • • •

DXF in and out • • •

Standard Windows print driver • • •

1000-Connection/350 Component Limit •
PCB translators

PADS, PCAD, Tango, CadStar, OrCAD PCB
386+, PROTEL

• • •

Schematic netlist interfaces

OrCAD SDT, OrCAD Capture, Futurenet,
Viewlogic, DATA I/O SCS

• • •
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OrCAD Layout for Windows—productivity flow

The OrCAD Layout for Windows productivity flow



___________________________
OrCAD Layout for Windows

6

OrCAD Layout for Windows—demo files

Demo design files

Below is a list of the demo design files provided with the
OrCAD Layout for Windows Demo. Each file corresponds
to one or more activity sets in the demo guide. Open the
design files as instructed in the demo guide and perform the
corresponding exercises. You can open the files and
perform the exercises in any order. Keep in mind that when
you exit a file, you cannot save any changes you have made
to the design.

OrCAD has provided two sets of design files with the
OrCAD Layout for Windows Demo: a board design with
two routing layers (these files have a 2 in the file name), and
a board design with four routing layers (these files have a 4
in the file name). You need a minimum of 8 MB of RAM to
run the design with two routing layers, and a minimum of
16 MB of RAM to run the design with four routing layers.

DSTART2.MAX or DSTART4.MAX

These boards contain components and nets that are ready
for interactive or batch placement.

DPLACE2.MAX or DPLACE4.MAX

These boards are partially placed. You may use them for
batch placement or routing.

DROUTE2.MAX or DROUTE4.MAX

These boards are placed and ready for via dispersion and
interactive or batch routing.

FINISH2.MAX or FINISH4.MAX

These boards are completely routed and can be used for
post processing.

RENAME2.MAX and RENAME4.MAX

These boards can be used for performing back annotation to
Capture.
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OrCAD Layout for Windows—demo files

Benchmark design files

Below are the results of two benchmarks that OrCAD has
run. Use these results to evaluate board size versus routing
time. Both of the designs were routed using a Pentium P90
with 32 MB of RAM and running under Windows NT 3.5

Benchmark design files

Statistics Benchmark 1 Benchmark 2

Board area 31.60 232.10

Equivalent IC’s (16-pin) 100.70 488.40

Number of route layers 4 4

Percent routed 100% 100%

Connections 770 3932

Number of vias 686 2930

Total route time 1 hour 16 minutes 7 hours 41 minutes
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OrCAD Layout for Windows—environment

OrCAD Layout for Windows design environment

Before you begin running the demonstration, review this
section to familiarize yourself with the Layout design
environment, including the Design window, the toolbar, and
the menus. To view the environment, you can open the
demo file DSTART2.MAX or DSTART4.MAX.

Note    You need a minimum of 16 MB of RAM to run
DSTART4.MAX.

Note    If the system prompts you to add a new netlist, choose No.

When you open the file, you will see the Layout Design
window. The toolbar runs across the top of the window.
The buttons on the toolbar provides access to the most
frequently used Layout commands.

Toolbar

Tool Name Description

Design Rules Check Enable online design rules checking for
interactive routing or component
editing.

Component Tool Insert, move, edit, or delete components
in the design.

Connection Tool Insert or delete connections in the
design.

Pin Tool Insert, move, edit, or delete pins in the
design.

Obstacle Tool Insert, move, edit, or delete obstacles
such as electrical copper or lines.

Text Tool Insert, move, edit, or delete text.

Error Tool Find and query spacing and design rule
violations.

Tools on the toolbar (1 of 2).
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OrCAD Layout for Windows—environment

Tool Name Description

Manual Route with
Shove

Route interactively using the shove
algorithm.

Manual Route DRC enabled - Route interactively
without using the shove algorithm.
DRC disabled - manual routing.

Initialize Color Change or check the color of a layer, or
make a layer invisible.

Initialize Query Change or check an object’s attributes.

Spreadsheet Tool List the available spreadsheets.

Post Processing List the post processing options,
including the Post Process spreadsheet.

Refresh Copper Pour Recalculate the copper pour based on
changes made to the board since the last
copper pour operation.

Find Find coordinates or components by
name.

Modify Display an editor that allows you to
modify a selected item.

Insert Copy a selected item.

Delete Delete a selected item.

Reconnect Enabled Enable the instantaneous reconnect
environment (Layout Plus only).

Auto Path Route automatically using the shove
algorithm while placing vias manually
(Layout Plus only).

Tools on the toolbar (2 of 2).
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OrCAD Layout for Windows—environment

In addition to the command buttons, the toolbar also
provides information about
the status of the board.

Current screen
coordinates

The coordinates that
correspond to the current location of the cursor display on
the toolbar making it easy to locate and place objects.

Current grid

The current grid spacing displays on the
toolbar.

Current layer

The active layer (the layer on which you
are currently working) and its color
display on the toolbar.

Postage stamp view

A miniature outline of the board, used to determine
your current view in relation to the PCB, also
displays in the toolbar. You can change the view by
pressing the left mouse button and dragging across the area
that you want to view.

Menus

You can access OrCAD
Layout for Windows
commands using
convenient popup and
pull-down menus.

Layout displays unique
popup menus for each
tool selected.

Popup menu
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OrCAD Layout for Windows—environment

• • Display popup menus using a two-button mouse.

If you are using a two-button mouse, display popup menus
by pressing the right mouse button.

• • Display popup menus using a three-button mouse.

Layout assumes that you are using a two-button mouse.
You can specify that you are using a three-button mouse by
choosing User Preferences from the Options menu and
selecting the Massteck Legacy mouse style option.

If you are using a three-button mouse, display popup menus
by pressing the middle mouse button.

Pull-down menu

Go to the next chapter.

Go to the table of contents.



Chapter 2
Footprint library

Go to the table of contents.

Go to the last page of the previous chapter.
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OrCAD Layout for Windows—footprint library

Creating footprints

This portion of the demonstration shows you how easy it is
to create physical footprints for the components used in the
PCB layout process. Footprints consist of three basic types
of objects: thrucodes (padstacks), obstacles (silkscreens,
assembly drawing data, keep-outs, etc.), and text.

Opening the footprint library

•• Open Layout.

You can open Layout by double-clicking on the OrCAD
Layout for Windows demo icon.

•• In the Layout frame, choose Edit Footprint from the Tools menu.
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OrCAD Layout for Windows—footprint library

•• Open the library.

In the Load Footprint Library dialog box, select the file
GUIDE.LIB and choose the OK button.

Note    If the system prompts you to add a new netlist, choose No.

Layout’s libraries are built on sheets. Each sheet may
contain similar footprints, such as resistors, or all the
footprints for a specific project.
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OrCAD Layout for Windows—footprint library

Viewing footprints

There are two ways to view a footprint during the design
process. You can look at it graphically in the Library
window, or you can look at the data associated with the
footprint using the spreadsheets. One method may be more
convenient than the other depending on the type of activity
you are performing. Typically, when creating footprints or
editing their obstacles or text, use the Library window.
When editing multiple pad locations or thrucodes, use the
spreadsheets.

•• View the footprints in the spreadsheets.

Choose the Spreadsheets toolbar
button. Choose the Footprints,
Components, or Thrucodes
spreadsheet to view footprint data.
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OrCAD Layout for Windows—footprint library

•• View the footprints in the Library
window.

Choose Graphics Windows
from the Window menu and
select the Library option
from the Select Graphic
Window dialog box.
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OrCAD Layout for Windows—footprint library

Creating a new footprint

In Layout, you can create custom footprints to add to your
library by following the steps below.

• Create a matrix to house the new part.

• Set up system grids for placement and routing.

• Add and identify the pins.

• Add silkscreen and other outlines.

• Add text.

• Choose the insertion datum.
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OrCAD Layout for Windows—footprint library

•• Zoom in to the target location.

Choose Zoom In from
the View menu and
zoom in to the top
right corner of the
library sheet.
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OrCAD Layout for Windows—footprint library

•• Create a matrix.

Each library sheet is divided into a user-defined matrix. A
single footprint exists within each cell.

Choose Matrix from the Tool menu to begin creating the
matrix. Place the cursor in the upper left corner of the
magnified area. Pressing the left mouse button, drag the
cursor diagonally to the lower right corner and release.

Click in the matrix and drag the cursor. Notice that as you
move the cursor, new lines appear within the defined block
enabling you to add as many cells to the area as you wish.
Click with the left mouse button when you have created
four matrix cells as shown below.
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OrCAD Layout for Windows—footprint library

•• Select system grids.

In Layout, you can set several system grids to facilitate the
design process. The Routing and Via grids are used for
place and route. The Dot, Place, and Detail grids are used
throughout the design process.

The Routing Grid establishes a grid for routing.

The Via Grid establishes the grid on which vias are placed.
It usually has the same value as the routing grid.

The Dot Grid is a visual reference grid that can be turned on
and off by the user.

The Place Grid is the grid on which the pins are placed. It is
also used for moving parts on the board.

The Detail Grid is the grid on which you create and move
the graphics for a footprint such as the silkscreen and
assembly data.

It is important to establish the grid you are going to use for
pins before you begin creating the footprint. To set the grids
for the design, choose Grids from the Options menu, and
enter the following values in the System Grids dialog box:

• Set the Place Grid to 100.

• Set the Dot Grid
to 50.

• Set the Detail
Grid to 25.
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OrCAD Layout for Windows—footprint library

Adding pins to the footprint

•• Create the first pin.

Choose the Component toolbar button and place the cursor
within one of the matrix cells you have defined. From the
popup menu, choose Insert. The Create Footprint dialog
box displays.

In the Create Footprint dialog box, enter test1 as the
footprint name, and enter T2 as the default thrucode. The
matrix cell is labeled with the footprint name you enter. All
of the graphics, thrucodes, and text within that cell become
a part of that footprint. Choose the OK button to exit the
dialog box.
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OrCAD Layout for Windows—footprint library

• • Place the first pin.

Position the pin over the desired location and click the left
mouse button to place it.
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OrCAD Layout for Windows—footprint library

•• Create the next pin.

Choose the Pin toolbar button. Pressing the SHIFT key,
select the first pin you created by clicking on it with the left
mouse button.

Choose Insert from the popup menu again. You now have a
second pin attached to the cursor.

•• Place the next pin.

Position the new pin 500 mil in the X direction as measured
from the first pin. At the bottom of the screen, the status bar
displays the coordinates for the new pin, DX:500, DY:0,
DIST:500.

In Layout, pin names can be numeric, alpha, or
alphanumeric, and can be placed in any order. For example,
you can name the pads 1, 7, 8, and 14 to fit a 4-pin
oscillator that is numbered for a 14-pin part. Pin names must
correspond to the pin names used in the schematic parts.

Note    By default, Layout names the pins in numerical order
beginning with the number 1. You must change the pin names in
Layout to match the pin names in the schematic.
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OrCAD Layout for Windows—footprint library

Viewing the pins on the footprint

•• Magnify the pin area.

Choose Zoom In from the View menu.

•• View the pin coordinates in the status bar.

When you place your cursor on a pin, the status bar displays
the footprint’s name and coordinates.

Now, there are two pins on the footprint.

PIN1 at X 0, Y 0

PIN2 at X .500, Y 0.



___________________________
OrCAD Layout for Windows

25

OrCAD Layout for Windows—footprint library

Editing the component pad

•• Edit the component pad.

Using the Edit Pad dialog box, you can assign a thrucode to
the pad. You can also specify exact coordinates for the pad,
a powerful feature for parts that have pins spaced on a fine
or irregular grid. For rectangular surface mount pads, you
can restrict the route entrance to the long end only.

Pressing the SHIFT key, select the second pin you created by
clicking on it with the left mouse button. Then, press the
ENTER key. The Edit Pad dialog box appears.

Select thrucode T2 from the Thrucode Name drop list. By
selecting thrucode T2, you change Pin 2 from square to
round.
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OrCAD Layout for Windows—footprint library

Setting display preferences for the footprint

In Layout you can set a variety of user preferences and save
them with the board design.

•• Open the User Preferences
dialog box.

Choose User Preferences
from the Options menu.

•• Edit the options to set your display
preferences.

Change the following settings and choose the OK button to
apply them.

• If you prefer solid pads, deselect the Hollow Pads check
box.

• To display a width for all lines on the board that are five
millimeters wide or greater, enter 5 in the Minimum
True Width text box.

• To see component heights in your library, select the 3D
Effects check box.
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OrCAD Layout for Windows—footprint library

Creating silkscreens, assembly drawings, and placement
outlines

In OrCAD Layout for Windows, you create silkscreens,
assembly drawings, and placement outlines for your
footprint using obstacles.

•• Begin drawing the obstacle.

Choose the Obstacle toolbar button. Place the cursor in the
Library window. From the popup menu, choose Insert.

Click the left mouse button to begin drawing. Use the arrow
keys to move the cursor, drawing the obstacle. Press the
SPACEBAR to stop drawing.
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OrCAD Layout for Windows—footprint library

•• Define the obstacle.

As you input an obstacle, you must specify the type of
obstacle that you want to create and the target layer for the
obstacle.

Choose Modify from the popup menu to display the Edit
Obstacle dialog box.
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OrCAD Layout for Windows—footprint library

Using the Edit Obstacle dialog box, select the type of
obstacle you want to create, including those used by the
placement and routing routines and those used for
silkscreens and assembly drawings. You can also set
physical attributes such as width, layer, and hatch pattern.

 Specify the following options to create a silkscreen obstacle
for components that appear on the top layer of the board.

• Select Detail from Obstacle Type drop list.

• Set the Obstacle Width to 10.

• Select SSTOP from the Obstacle Layer drop list.

 Specify the following options to create an assembly drawing
for components that appear on the top layer of the board.

• Select Detail from the Obstacle Type drop list.

• Set the Obstacle Width to 10

• Select ASTOP from the Obstacle Layer drop list.
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OrCAD Layout for Windows—footprint library

•• Create a placement outline.

Layout’s interactive and automatic placement utilities look
for a placement outline. The outline is used to maintain a
specified distance between parts.

For surface mount parts, this outline should be large enough
to provide sufficient space between parts, eliminating solder
shadowing and facilitating the post-assembly inspection
process.

A placement outline is created using the same method that
you used to create the silkscreen and assembly drawing.

Begin drawing an obstacle, select it, and choose Modify
from the popup menu. Modify the options in the Edit
Obstacle dialog box to create the outline.

• Select Place Outline from the Obstacle Type drop list.

• Change the target layer option. You can draw the
placement outline on the top layer, the bottom layer, the
top and bottom layers, or on Conn (all layers).
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OrCAD Layout for Windows—footprint library

Adding text to components

•• Add a reference designator.

Choose the Text toolbar button. Position your cursor over
the Library window and choose Insert from the popup
menu. Modify the options in the Text Edit dialog box to
create the text.

• For the text type, select Comp Name

• Specify a text width of 10.

• Specify a text height of 100.

• Select the silkscreen top layer (SST) from the Layer
drop list.

You now have the text string &Comp attached to your
cursor. Position it above the footprint and click the left
mouse button to place it.

When the component is placed on the design, the text string
&Comp is replaced with the appropriate reference
designator.
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OrCAD Layout for Windows—footprint library

•• Create additional labels for the footprint.

To create additional labels for the footprint, modify the text
type and layer options in the Text Edit dialog box as
described in the previous exercise, Add a reference
designator.

The reference designators (represented here by the keyword
&Comp) can be placed in different locations and can be
different sizes.

Note    The text string &Pack or No Package may appear instead of
the package label.
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OrCAD Layout for Windows—footprint library

Setting an insertion origin

In OrCAD Layout for Windows, you must specify an
insertion origin as well as a graphic origin. The location of
the part as specified in the insertion report is calculated
using the insertion origin.

For a through-hole part, the graphic origin is typically pin 1.

Note    In the surface mount footprints supplied by OrCAD, the
graphic origin is at the centroid of the part by default.

•• Locate the footprint.

Press the TAB key and enter the footprint name SSOP48.

•• Specify the insertion origin.

Choose Move Datum from the Tool menu. Position the
small cursor at the desired location for the insertion datum
and choose Move Insertion Origin from the popup menu.

Position the cursor at the desired location and click the left
mouse button.
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OrCAD Layout for Windows—footprint library

Managing the footprint library

Once you create the first footprint, you can build the library
and use it to organize and manage footprints. Using the
footprint library, you can do the following.

• Copy footprints to create new footprints.

• View footprints.

• Use Query and the Footprints spreadsheet to access and
modify footprint data.

Copying footprints

The easiest way to create another component footprint is to
copy and modify an existing footprint.

•• Zoom out.

Choose Zoom Out from the View menu and click once on
the screen so that you can see the footprint and an empty
matrix cell.
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OrCAD Layout for Windows—footprint library

• • Copy the footprint.

Choose the Component toolbar button. Select the footprint
and choose Modify from the popup menu.

In the Create Footprint dialog box, accept the default name
for the new footprint or enter a new name.

Click the left mouse button to place the copy of the
footprint within a blank cell. Press the HOME key to redraw
the screen.
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OrCAD Layout for Windows—footprint library

Viewing obstacle types in the library

There are many types of obstacles available to view in the
demo library, DGUIDE.LIB. This section illustrates and
describes some of these obstacles.

•• View an insertion outline.

An insertion outline is added to a footprint to represent the
size of the auto-insertion head.

Choose the Obstacle toolbar button. Press the TAB key to
display the Find Coordinate or Component Name dialog
box. Enter the component name DO900
(d,o,nine,zero,zero) and choose the OK button. The screen
scrolls to the component in the demo library and centers it
on the screen.

In the component, the odd-shaped obstacle that surrounds
pin 1 is an insertion outline. Pressing the SHIFT key, select
the insertion outline and choose Move On/Off from the
popup menu. Move the insertion outline away from the
component so that you can see it clearly. Click the left
mouse button to place it.
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OrCAD Layout for Windows—footprint library

•• View a via keep-out.

Via keep-outs are used to restrict vias from being placed
under surface-mount discrete parts.

Similar obstacles, called route keep-outs are added to a
footprint to restrict tracks. For example, you may want to
avoid tracks under a component on the top layer of the
board, but may want to route under the component on all
other layers.

To view the via keep-out, choose the Obstacle toolbar
button. Press the TAB key to display the Find Coordinate or
Component Name dialog box. Enter the component name
6032 and choose the OK button. The screen scrolls to the
component and centers it on the screen.

The small rectangle between the pads is the via keep-out.

Pressing the SHIFT key, select the via keep-out and choose
Move On/Off from the popup menu. Move the via keep-out
away from the component so that you can see it clearly.
Click the left mouse button to place it.
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OrCAD Layout for Windows—footprint library

•• View a copper obstacle.

When attached to a pad, copper can create a heatsink under
a power part. Or, copper can create an odd-shaped pad for
a special application.

When the copper is attached to the pad it becomes an
integral part of the pad. If the pad is moved the copper
moves with it. If the pad is attached to a net, then the
copper automatically becomes part of that net.

Choose the Obstacle toolbar button. Press the TAB key to
display the Find Coordinate or Component Name dialog
box. Enter the component name Toroid and choose the OK
button. The screen scrolls to the component and centers it
on the screen.

Choose the Pin toolbar button. Select PIN3 (the larger pin)
and move it. Notice that the copper obstacle moves with the
pin.
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OrCAD Layout for Windows—footprint library

•• View a component height obstacle.

For designs in which components with height restrictions
need to be restricted to specific areas of the board, you can
create component keep-outs to keep those components out
of areas where they do not fit. Component height keep-in
and keep-out obstacles are defined in the footprint library.

Choose the Obstacle toolbar button. Press the TAB key to
display the Find Coordinate or Component Name dialog
box. Enter the component name DP32W600 and choose the
OK button. The screen scrolls to the component and centers
it on the screen.

The grayed area on the footprint is a component height that
can be built into a library part.
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OrCAD Layout for Windows—footprint library

Using the Query tool

One of the most advanced features in OrCAD Layout for
Windows is Query. Using Query, you can access and edit
almost any element in the board design.

•• Query a footprint.

For footprints, the Query window displays information such
as quantity, pad labels, thrucodes, and location.

Choose the Query toolbar button. The Query window
appears in the upper left corner the graphics window.

Choose the Component toolbar button and select the Toroid
footprint in the library. Information about the footprint
appears in the Query window.

•• Choose End Command from the popup menu.

You must choose End Command from the popup menu
before you do the next exercise.
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•• Use Query to edit a component thrucode.

You can edit a single thrucode layer or all thrucode layers
from the Query window by accessing the Edit Thrucode
Layer and Edit Thrucode dialog boxes. OrCAD Layout for
Windows offers a variety of pad shapes as well as the ability
to offset the drill from the center of the pad.

In the Query window, select 62R38. Then, select
62R38.TOP.

Note    When selecting items in the Query window, click on the
word in quotation marks. Any data in quotation marks can be
modified.

Tip    If you scroll down, you can see a list of footprints using this
thrucode.

Press the ENTER
key to display the
Edit Thrucode
Layer dialog box.
Change the
thrucode to 75x50
Oblong.
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•• Use Query to view obstacle data.

From the Query window, it is also possible to check the
coordinates and parameters of any obstacle attached to a
footprint.

• Again, select the
Thrucode 62R38 in
the Query window.

• Scroll down and
select Attached to
footprint “TO-92A.”

• Select 62, which is
the Place Outline
obstacle.
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Using the Footprints spreadsheet to edit footprints

As OrCAD Layout for Windows and its predecessor
MaxEDA have always been Windows programs, the full
functionality of spreadsheets is available. Using spreadsheets
makes it easy to perform tedious tasks such as moving
entire rows of pads in slight increments.

•• Open the Footprints spreadsheet.

Choose the Spreadsheets toolbar button
and choose Footprints from the menu that
appears.

•• Select a footprint.

Press the TAB key and enter SSOP48.
Pressing the left mouse button, drag the
cursor to select several pads in the Y Loc
column.
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• • Edit the footprint pads.

Press the ENTER key or choose Modify from the popup
menu. In the Edit Pad dialog box, notice that the number of
pads selected appears at the top of the editor. Any change
you make affects all of the selected pads. As you selected
the pads in the Y Loc column, the cursor is blinking within
the Y location field. If you desire, you can now move the
selected pads in increments as small as a few thousandths of
an inch.
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Working with application windows in Layout

OrCAD Layout for Windows is a Windows-based design
tool. Therefore, most of the functions of the graphic
windows within the software follow standard Windows
convention.

•• Tile the windows on the screen.

Choose Tile from the window menu.

•• Reset the windows on the screen.

Choose Reset All from the Window menu to close the
Footprints spreadsheet and return the graphics design
window to full display.
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Exiting the library

When you have finished with the Footprint library, choose
Exit from the File menu.

Go to the next chapter.

Go to the table of contents.



Chapter 3
Component placement

Go to the table of contents.

Go to the last page of the previous chapter.
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Component placement

You are now ready to create a Printed Circuit Board (PCB).
OrCAD Layout for Windows provides users with the most
advanced layout features available on the market today.

In Layout, the designer has the ability to specify design rules
in the schematic, such as component locations, net spacing
criteria, component group information, net widths, and
routing layers.

Note    If you wish to skip the interactive placement section of the
demo and use only the autoplacement section, skip to Autoplacement
in this chapter.
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Opening a new design

• • Choose New Design from the Tools menu.

• • Select a technology file.

When you create a new design in Layout, you must select a
set of design instructions called a technology file. A
technology file can include design rules, drawing formats,
dimensions, preplaced components, tooling holes, and the
board outline. Technology files save time, especially when
designing multiple boards that share common formats and
design rules. They can serve as a company standard for
design rules such as layer stacks, padstacks, track widths
and spacing, Gerber output standards, and report formats.
Virtually any design rule that is common to some or all of
your projects can be included in a technology file.

For the demo, select the technology file DGUIDE2.TCH or
DGUIDE4.TCH when prompted.

Note    You need a minimum of 16 MB of RAM to run DGUIDE4.TCH.

Note    If you do not want to go through the process of creating a
new design, choose Design from the menu bar and select the
DPLACE2.MAX or DPLACE4.MAX file from the list presented. Then,
skip to the section Preparing to place components on the board in
this chapter.
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• • Select a design netlist.

The design netlist is extracted from the schematic. For this
demo, select DGUIDE.MNL from the list presented in the
Load Netlist source dialog box.

Note    If the system prompts you to add a new netlist, choose No.

• • Name the design.

By default, the design assumes the name of the netlist
source. Choose OK to choose the default name for the
design.



___________________________
OrCAD Layout for Windows

51

OrCAD Layout for Windows—component placement

• • Review the AutoECO report.

When you create a design, Layout saves an ASCII report file
generated from the AutoECO (Automatic Engineering
Change Order) utility. Any errors that occur during the data
merge are reported in the file.

Open the report DGUIDE.LIS in an editor such as Notepad.
Take a moment to scan the report.

Note    The message, “Pin in footprint wasn’t defined by package”
refers to an unused pin.
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Preparing to place components on the board

When a netlist is loaded, the parts are located in a pile in the
lower left hand corner of the board, just outside the outline.
Layout offers a variety of options to place the parts on the
board.

• • Check your system grids.

Before you begin placing the components, make sure you
have specified grids for placement and routing.

Choose Grids from the Options menu to display the System
Grids dialog box.

• Set the Dot Grid to 100.

• Set the Place Grid to 25.

See    For information the grids used in OrCAD Layout for
Windows, see Creating a footprint in Chapter 2: Footprint library.
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• • Select display units.

In OrCAD Layout for Windows, it is
possible to select one of several unit
values for the design. The unit value
used can be changed at any time. For
example, you can route the board in
mils and then confirm pad locations
within footprints in millimeters.

To set the current unit value, choose
Units from the Options menu to display
the Display Units dialog box. For the
purpose of the demo, do not change the value from the
default Mils.

• • View the board outline.

The board outline serves as a component and route keep-in
on all layers. Separate keep-ins and keep-outs can be added
to any or all layers to meet specific needs.

For example, if there is a hole in the middle of your board,
you can use keep-outs to prevent components and routes
from being placed in that area. You can also use a route
keep-in or keep-out to make sure digital signals do not
route through the middle of an analog circuit.

See    For information on component and route keep-ins and keep-
outs, see Creating obstacles in Chapter 2: Footprint library.

Board outline



___________________________
OrCAD Layout for Windows

54

OrCAD Layout for Windows—component placement

Placing components individually

The first interactive option described involves placing parts
individually.

Before you begin, turn off the ratsnest display by choosing
the Reconnect/Connect toolbar button (it is the second
toolbar button from the left). It is important to turn off the
ratsnest during interactive placement. Some interactive
placement commands do not work properly if the ratsnest is
enabled. When disabled, the ratsnest is only visible while
components are being moved.

• • Select components to place individually.

Choose the Component
toolbar button. Place your
cursor in the Design window
and choose Select Criteria
from the popup menu. Enter
the letter U* in the Comp
Name text field to specify all components that begin with U.

• • Place the components.

Choose Next Comp (next component) from the popup
menu, or press the N key. Each time you choose the Next
Comp command, one component beginning with the letter
U snaps to the cursor in the order in which they are
specified in the schematic netlist.

To practice placing components, drag a couple of
components outside of the board outline and click the left
mouse button to place them.
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Placing components in groups

The schematic netlist that you are using for this demo
includes an attribute that has assigned some components to
groups. In Layout, you can use this attribute to place parts
by the group number assigned in the schematic. When you
specify a group number in the Component Selection Criteria
dialog box, the parts assigned to the group snap to the
cursor, allowing you to place them on the board.

• • Select components to place as a group.

Choose the Component toolbar button. Place your cursor in
the Design window and choose Select Criteria from the
popup menu. Enter 5 in the Group Number text field to
specify group 5 for placement. The group of parts snaps to
the cursor.

• • Place the group of components.

Dragging the cursor, position the group of components to
the right of the matrix pattern in the top right corner of the
PCB. Click the left mouse button to place the components.
You will use these components for the next exercise.
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Placing components using a matrix

In Layout, you can also place parts in a matrix. The matrix
placement algorithm is useful for placing groups such as
memory arrays and discrete components.

You can create a matrix of any size, anywhere on the board.
For information on creating a matrix, follow the directions
in Preparing to create a new footprint in Chapter 2:
Footprint Library.

For the purposes of this demo, use the matrix created for
this exercise, which is located in the upper right corner of
the board.

• • Select the components to place in the matrix.

Choose the Component toolbar button. Pressing the left
mouse button, drag a box around the group of components
you placed to the right of the board in the previous exercise.



___________________________
OrCAD Layout for Windows

57

OrCAD Layout for Windows—component placement

• • Place the components in the matrix.

Choose Matrix Place from the popup menu or press the X
key to place the selected components within the matrix
defined in the upper right section of the board.
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Placing components using clusters

Another OrCAD Layout for Windows component
placement tool is cluster placement.

Using clusters is a fast and intelligent way to place a board.
Clusters are component groups that are formed to simplify
placement. As with groups, clusters allow you to move
multiple parts at once. If clusters are created manually, then,
like groups, they can represent specific circuits and can be
placed quickly in the appropriate area of the board.

The size of the circle that displays to represent a cluster
equals the combined area of all of the components within
that cluster. Use the circle as a visual aid to ensure that
there is enough room to place the cluster in a given area of
the board.

Note    On the PCB, you can select any group of parts that were
assigned to a component group in the schematic. Clusters and groups
may also be assigned manually using the Components spreadsheet.

Note    If you have not done so, turn off the ratsnest display by
choosing the Reconnect/Connect toolbar button. Cluster placement
does not work properly with the ratsnest enabled.

• • Select the components to place as a cluster.

Choose Select from the popup menu or press the S key to
display the Component Selection Criteria dialog box.

Enter group number 3 in the Group Number text box. Then
choose Cluster from the popup menu, or press the C key to
place the parts in a cluster.
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• • Place the cluster.

Position the cluster near the J3 component and click the left
mouse button to place it.

• • Place a second cluster.

Repeat the process using group number 4 and place the
second cluster above the first, near J2.

Clusters on
the board.
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Placing components using the Quick Place command

Once the clusters or groups are placed on the board, Quick
Place can unstack and arrange the parts while maintaining
minimum separation based on the place outline.

• • Select the clusters.

Pressing the SHIFT key, select the two clusters, U1 and U2,
by clicking on them with the left mouse button.

• • Unpack the clusters.

Choose Quick Place from the popup menu, or press the P
key to unpack the clusters. This results in a fast, general
placement.

Note    Your components may be placed differently than the
components shown here, depending on where you placed the clusters
on the board.
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Arranging components on the board

Now that you have placed the clusters, you can arrange
them efficiently. As you begin to arrange the components,
there are several interactive placement options available for
you to use in OrCAD Layout for Windows. Experiment
with some of the available commands as described in this
section.

Note    To perform these commands on a group of components, first
select them by pressing the left mouse button and dragging a window
around them.

• • Magnify the board area.

Choose Zoom In from the View menu and click on the
screen to magnify the lower right corner of the design.
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• • Shove the component.

One placement option is the Shove Comp (shove
component) command. The Shove Comp command moves
components out of the way, clearing the place outline you
inserted when you created the footprint in Chapter 2:
Footprint Library.

Select a through-hole discrete component with the left
mouse button and move it so that it overlaps another
through-hole discrete component. Choose Shove Comp
(shove component) from the popup menu, or press the H
key.

• • Rotate the component.

You can rotate parts individually or as a group. The
increment of rotation defaults to 90 degrees, but it can be
changed to any value. To set the increment of rotation,
choose Grids from the Options menu.

To rotate the component, select a surface-mount IC and
choose Rotate from the popup menu, or press the R key.

Note    With group selection, the components will rotate one time
for each time you select them. You must reselect them as a group to
rotate them again.
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• • Mirror the component.

Parts can be mirrored to the opposite side of the board
either individually or as a group.

Choose Opposite from the popup menu, or press the O key
to mirror a part to the bottom side of the board.

• • Design the board layout.

Study the sample placement of the board shown below. Try
to place the components similarly using the commands we
have described.
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Autoplacement

In OrCAD’s Layout Plus for Windows, you can access
many options to place components on a board. You used
some of the interactive placement options in the previous
section. In this section, you will use the autoplacement
option which includes advanced placement capabilities such
as component push-n-shove and automatic cluster
placement.

Note    The autoplacement capability is only available in the OrCAD
Layout Plus for Windows package.

Groups and clusters play an important role in automatic
placement. To achieve effective component placement, it is
wise to group the components based on their functionality
or connectivity. You can do this at the schematic level, or in
Layout Plus’ Components spreadsheet.

The board you are designing for the demo should resemble
the one shown below. If you skipped the interactive
placement section, or if your board does not resemble the
one shown below, choose Design from the OrCAD frame
and open the demo design file DPLACE2.MAX or
DPLACE4.MAX.

Note    You need a minimum of 16 MB of RAM to run
DPLACE4.MAX.

Note    If the system prompts you to add a new netlist, choose No.
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Locking components on the board

When using autoplacement in Layout Plus, you must first
secure the components on the board using the Lock and Fix
commands.

The Lock command is temporary; the user can easily
override the command.

The Fix command, on the other hand, must be disabled in
the Edit Component dialog box. The Edit Component
dialog box can be accessed by selecting a component and
choosing Modify from the popup menu. The Fix command
is intended for parts such as connectors and mounting holes
that need to be placed permanently in specific locations.

• • Lock the components on the board.

Select the memory array in the upper right corner of the
board and choose Lock Comp from the popup menu or
press the L key.

Repeat this procedure for all of the parts in the lower right
area of the board.

• • Display the lock override dialog box.

Select one of the parts in the matrix. A dialog box appears,
asking if you want to override the lock. Choose No. The
part remains locked.
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Loading a strategy file

There are several placement strategy files defined for you in
Layout Plus. Some of the strategy files feature quick
placement to test for adequate board space. Others are
designed for extensive component, pin, and gate swapping.
When using strategy files, components are placed on the
design for you.

For the purposes of this demo, a strategy file has been
created using the Layout Plus default settings for
autoplacement. These strategies assign components to
clusters and place the clusters on the board taking into
account any preplaced clusters or fixed components already
on the board.

Layout Plus automatically groups components for
placement using connectivity, unless the groups are
specified by the user in the schematic or at board-level in the
Components spreadsheet.

Clusters are then created from the groups to maximize the
connectivity between the components. Cluster placement
groups heavily interconnected components with the goal of
minimizing track length and the number of vias needed to
route the connections between the components.

• • Load the strategy file.

From the File menu, choose Load
Strategy to load a placement strategy
for this board design.

When the popup menu appears, select
PL-GUIDE.SF from the list.
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Disabling the power and ground signals

• • Display the Nets spreadsheet.

Choose the Spreadsheets toolbar
button and choose Nets from the list.

• • Disable the power and ground signals.

Because you are placing the
components emphasizing circuit
functionality, you must disable the
power and ground nets. You will
reenable these nets before you route the power and ground
planes.

Pressing the SHIFT key, click the left mouse button to select
the following nets in the spreadsheet: AGND, GND, GND
EARTH, V+12, V12N, and VCC.

Then, choose Enable <->Disable from the popup menu to
disable the selected signals. When the power and ground
signals are disabled, No displays in the corresponding
Routing Enabled column.
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Using autoplacement

OrCAD’s Layout Plus for Windows’ autoplacement utility
attempts five phases of component placement.

Assign clusters.    Takes components that are not locked or
fixed and places them in clusters based on their
interconnectivity.

Place clusters.    Places clusters on the board based on their
connectivity.

Proximity place.    Places components in approximate
locations.

Swap components.    Swaps components within a group or
with components in neighboring groups in order to improve
placement.

Adjust components.    Moves components to avoid
overlaps.

• • Begin autoplacement.

When you are ready to begin
autoplacement, choose Batch
Place from the Auto menu.
The autoplacement routine
works through the five phases
of component placement.
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Using interactive commands to optimize autoplacement

Once you have placed the components on the board using
autoplacement, use the interactive placement commands
discussed earlier to optimize the design.

• • Edit a component.

Select a component and choose Modify from the popup
menu to edit the component name, lock or fix components,
or change the footprint used for that component.

• • Use the shove component command.

Select a component and choose Shove Comp from the
popup menu to move other components out of the way.

• • Rotate a component.

Select a component and choose Rotate from the popup
menu to shorten connections or eliminate crossovers.

• • Place a component on the opposite side of the board.

Select a component and choose the Opposite command
from the popup menu to place components on the opposite
side of the board.
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Using the density graph

Layout Plus features an innovative density graph, a
powerful tool for analyzing the degree of difficulty that will
be faced in routing the board using different routing
strategies and technologies.

Note    The density graph is only available in the OrCAD Layout
Plus for Windows package.

The density graph considers a variety of design rules,
including the number of routing layers, track widths, DRC
settings, and whether surface mount parts are present on
both sides of the design, or if the board has predispersed
vias for routing.

Three kinds of data are shown on the density graph. The
board display shows the board density at each location.
(Board density refers to the number of pads and connections
in a given area of the board). The bar graphs at the top and
right show the channel counts in each direction and their
density.

• • Open the Density Graph window.

Choose Graphics Windows from the Window menu. Then
select the Density Graph radio button.
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• • Test routing layer strategies using the density graph.

The density graph in OrCAD Layout Plus for Windows
analyzes all routing layers, preroutes, widths of routes, and
connections when calculating the available routing channels.

By disabling routing layers, you can test the potential results
of routing the board with fewer layers. This testing
capability can save days
or weeks in the design
process.

Choose Strategy and
Route Layer from the
Spreadsheets toolbar
button to display the
Route Layer
spreadsheet.

In the
Win/Comp/Manual
section, double-click on
TOP to display the Edit Layer Strategy dialog box. Deselect
the Routing Enabled check box, turning off routing on the
top layer.
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When you close the spreadsheet, the density graph redraws
itself. You can see new parameters, resulting from turning
off routing on the top layer.

• • Load a routing strategy file.

Choose Load Strategy from the File menu and select
DROUTE2.SF or DROUTE4.SF (depending on which board file
you are using). Notice the change in the density graph.
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Exiting the placement file

You have finished placing components on the board.

If you want to continue now with Chapter 4: Interactive
Routing and Autorouting, choose Graphics Windows from
the Window menu. In the Select Graphic Window dialog
box, choose Design.

If you want to stop, choose Exit from the File menu. Keep
in mind that you cannot save the board with the current
placement. However, the OrCAD Layout for Windows
Demo includes a file with a pre-placed board that is ready
for routing. When you are ready to continue with the demo,
follow the instructions in Chapter 4: Interactive Routing
and Autorouting.

Go to the next chapter.

Go to the table of contents.



Chapter 4
Interactive routing
and autorouting

Go to the table of contents.

Go to the last page of the previous chapter.
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Interactive routing

OrCAD Layout for Windows is the most productive tool
you will find at any price for PCB editing and routing.
Layout uses sweep technology to complete the most
difficult portions of the board, and then quickly routes the
rest of the board. OrCAD’s shove technology minimizes
vias and clears paths for tracks. By using Layout’s
interactive routing commands, you can access all of
Layout’s automatic power without sacrificing control.

Some of the interactive capabilities you can use in this demo
include an AutoPath completion mode, interactive push-n-
shove for track input, manual routing with DRC on or off,
and batch routing.

If you exited the placed board created in Chapter 3:
Component Placement, choose Design from the Layout
frame and select DROUTE2.MAX or DROUTE4.MAX to open
the routing portion of the demo.

Note    You need a minimum of 16 MB of RAM to run
DROUTE4.MAX.

Note    If the system prompts you to add a new netlist, choose No.

If you are continuing from Chapter 3: Component
Placement without exiting, open the Design window.
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Loading a routing strategy file

When all of the components are placed, you can begin
routing the board. Layout has tools that will route one
signal at a time, one component at a time, an area of the
board, or the entire board.

To autoroute an entire board, you must select a routing
strategy, set the spacing requirements, and disable for
routing all nets on plane layers.

Predefined strategy files are available in the OrCAD Layout
for Windows package and as a part of the demo. The files
are optimized for specific types of boards based on the type
of components on the board, the number of layers enabled
for routing, and the preferred track direction on the top
layer.

• • Load the strategy file.

Choose Load Strategy from the file menu.

If you are routing a 2 layer board (using the file
DROUTE2.MAX or the equivalent) select DROUTE2.SF from
the list. If you are routing a 4 layer board (using the file
DROUTE4.MAX or the equivalent), select DROUTE4.SF from
the list.
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Editing nets

Most net data is established on the schematic level.
However, these rules can be enhanced or modified at any
time during the design process.

• • Open the Nets spreadsheet.

Choose the Spreadsheet toolbar button and choose Nets, or
press the SHIFT and N keys to display the Nets spreadsheet.

• • Change the color of the ratsnest.

On the design, the ratsnest is highlighted in yellow. Pressing
the SHIFT key, select VD [0-7] and choose Change Color
from the popup menu. Select a color from the palette that
displays.

It is also possible to highlight the entire net’s ratsnest. This
can be useful for following a critical line, such as a clock
line. This is different than highlighting routed tracks on the
design.
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• • Edit the nets.

In OrCAD Layout for Windows, you can set net rules on a
net-by-net basis.

Select a net in the Nets spreadsheet and choose Modify
from the popup menu to display the Edit Net dialog box.

In the Edit Net dialog box, you can set the following rules:

• Net weight is the priority a net is given for routing. The
higher the weight, the sooner it will be routed.

• Share Enabled allows T-connections to be used on the
board. Disabling this option forces nets to go to pads
only.

• Shove Enabled allows the selected net to be moved to
create space for other tracks.

• Retry Enabled allows the router to reroute the net to
create room for another track. (If Retry and Shove are
both disabled, then the tracks for this net are essentially
locked in place).
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• • Enable layers for routing.

In the Levels Enabled for Routing dialog box, you can
specify the layer(s) on which you want to route a track. You
can also assign a net to a plane layer.

This option is very valuable for nets that can only be routed
on certain layers. If you specify those layers here, then the
autorouter will not put a track on a disabled layer. Also, the
Design Rule Check will flag any net that is interactively
routed on a disabled layer.

To access the Levels Enabled for Routing dialog box, click
on the Net levels button. For the purposes of the demo,
close the dialog box without editing the options by clicking
on the Cancel button.

• • Set net widths by layer.

In the Net Width by Layer dialog box, you can set a specific
track width for each layer for each net. This feature is
especially useful for impedance controlled boards.

If the width of a net differs from this value, the Design Rule
Check reports the discrepancy as an error.

To access the Net Widths by Layer dialog box, click on the
Width by layer button. For the purposes of the demo, close
the dialog box without editing the options by clicking on the
Cancel button.
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• • Set net spacing by layer.

Using the Net Spacing By Layer dialog box, you can select
a minimum track-to-track setting that is larger than the
global DRC parameters. This function is useful for analog
boards and boards that must recognize UL-type
requirements. The Design Rule Check issues an error
message if the specified minimum is violated.

To access the Net Spacing By Layer dialog box, click on
the Nets Spacing button. For the purposes of the demo,
close the dialog box without editing the options by clicking
the Cancel button.
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• • Set signal routing order.

You control the signal routing order using the Reconnection
Type dialog box.

• Use the None option to maintain the schematic net
order.

• Use the Std. Orthog option for analog boards on which
line length is more critical than maintaining a specific
direction.

• Use the High speed option to route a signal from the
source through the loads, and finally, to the terminator.
Pins must be specified as source, load, and terminator in
the schematic.

To access the Reconnection Type dialog box, click on the
Net Reconn button. For the purposes of this demo, close
the dialog box without editing the options by clicking the
Cancel button.

• • Close the Nets spreadsheet.

Once net parameters have been set, individual nets can be
routed using one of the several routing tools Layout
provides.
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Using the Manual Route with Shove command

The Manual Route with Shove command uses OrCAD
Layout for Window’s push-n-shove technology, which
simplifies routing by moving tracks to clear the design rules.
Since the router will push several tracks at once, tracks are
routed more quickly.

• • Locate and magnify the area to route.

Choose the Manual Route with Shove toolbar button.

Choose Zoom In from the View menu. Using the left mouse
button, click on the screen to magnify the components in the
center of the board, just below the PLCC.

Note    By default, the DRC (Design Rules Check) is always on for
routing. If for some reason you need to temporarily disable Design
Rules Checking, choose the DRC off toolbar button (it is the first
toolbar icon on the left).

Route the
ratnests here
using the
Manual Route
with Shove
tool.
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• • Route the first track.

Select a ratsnest with the left mouse button. The ratsnest is
attached to the cursor when it is selected. Drag the cursor
to draw the track on the board.

Click the left mouse button to create vertices (corners) in
the track. Near the last segment for the connection, the tool
automatically finishes the connection to the center of the
pad. A complete connection is indicated by the cursor
changing size (bigger) and the ratsnest disappearing from
the cursor.

Tip    You can add a vertex by positioning the cursor at the desired
position and pressing the SPACEBAR.

The first track.
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• • Route the remaining tracks.

Input tracks from the PLCC to the surface mount (SMT)
part.

As you input the tracks, notice how the push-n-shove utility
moves the other tracks out of the way.

You can delete a routed segment by placing the cursor over
a segment of the net and pressing the DELETE key.



___________________________
OrCAD Layout for Windows

85

OrCAD Layout for Windows—interactive routing

• • Experiment with different manual route strategies.

You can control the amount of shove you wish the router to
use when you are routing tracks.

To achieve more control over
the shove capability, choose
Manual Route/Shove Rules
from the Options menu.
From the Manual Route
Strategy dialog box, select
Medium Power or Low
Power. Experiment with the
settings.

High Power.    The router may rip-up, shove, and re-route
tracks as you add new tracks.

Medium Power.    The router shoves tracks and may even
push routes over other items such as pads and around other
tracks.

Low Power.    The router moves tracks only slightly.

Whether or not a via is used to make a connection depends
on the Via Cost selection you set in the Manual Route
Strategy dialog box.
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• • Lock the routes.

The Lock Route command locks all of
the corners of the track, from the
current segment to the pad, or if the
track is complete, the entire track.

A track or net that is locked cannot be
moved by the autorouter, but the lock
can be overridden during interactive
routing. It is especially helpful to lock
critical tracks that are routed along a
specific path.

On each of the tracks you have
inserted, select a segment and choose
Lock Route from the popup menu, or press the L key, to
lock the routes.

Entire nets can also be locked from the Nets spreadsheet.

Note    Other commands are also available for use with Manual
Route with Shove. Choose the Manual Route with Shove toolbar
button and display the popup menu to view the commands. This
menu is also shown above.
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Performing manual routing using AutoPath

In AutoPath, the router creates the routing path for the
selected net. In other words, the router shows you a way to
get to the target location rather than you creating the path
by drawing it with the cursor.

Using AutoPath, you can focus on the direction of the route
while the system automatically decides the best location for
corners. This tool is a fast way to route individual tracks.

• • Use AutoPath to create a route.

Choose the AutoPath toolbar button. There are three ways
to complete a track using AutoPath.

• Select a net and move the cursor on the screen. Click
the left mouse button or press the SPACEBAR to add a
vertex.
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• Using the left mouse button, select a net on the IC that
lies just to the upper right of the tracks you have
entered. From the popup menu, choose Finish.

• Double-click on the net using the left mouse button. The
router works in combination with the push-n-shove
algorithm to complete the connection.

The AutoPath,
tool creates
the path for
the route.
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Changing layers

As tracks are manually routed, it
is important to be able to change
layers easily during routing. In
Layout, a simple key stroke
changes the routing layer, and
vias are added automatically.

You can see the current layer in
the Layer drop list located in the
middle of the toolbar. The numbers that correspond to the
layers are keystrokes that you can use to display layers
quickly during board layout.
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• • Change the routing layer.

Change to the Bottom layer by selecting 2 BOT from the
layer drop list or by pressing the 2 key. Then, choose the
Manual Route with Shove toolbar button.

• • Create vias.

To the right of the ICs you routed first, there are four
resistors on the solder side, or bottom, of the board. Select
a ratsnest track from one of the resistors. Begin routing the
track by dragging the cursor to the left.

Click the left mouse button. Then, press the 1 (one) key to
change the routing layer to TOP. Continue dragging the
cursor to the left. Click the left mouse button to place the
track on the pad.

Repeat the process for the other three resistors. When you
are finished, you will have created four vias.
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Changing widths

Earlier, you learned how to change the width of nets using
the Edit Net dialog box. You can also easily set or change a
track width directly from the board, either before or after
you input the track.

For a pre-existing track, you have three options: you can
change the width of a segment, the width of the connection
between two pads, or the width of the entire net.

• • Change the width of a new net.

Place the cursor in the design window
and press the W key. Enter 25 in the
New Width text box. Drag the cursor
to begin drawing a track and click the
left mouse button to create a vertex.
Again, press the W key. This time,
enter a value of 8 in the text box. The track will have two
segments: one with a width of 8, and one with a width of
25.

A net with
two track
widths.
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• • Change the width of an existing net.

Select a net and press the W key. Enter
25 in the New Width text box. In the
Segment group box, apply the width to
a segment, connection, or the entire
net.
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Moving segments

In OrCAD Layout for Windows, there are several ways to
edit existing tracks. For example, segments can be moved or
added. These options make track editing and board cleanup
fast and easy.

• • Move a segment.

Choose the Manual Route with Shove toolbar button. Then,
select an existing track with the left mouse button.

Choose Segment from the popup menu or press the S key
to move the segment. Drag the cursor until you have
created the desired shape. Click the mouse button to place
the segment. Neighboring tracks are shoved to make room
for the new segment.

Draw the
segment.

Other
segments
are shoved
out of the
way.
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Creating duplicate connections

In the Design window you have the ability to insert a
duplicate connection from a node (pad), a vertex, or a
corner. Using this ability, you can insert guard ring
connections for shielding, special routing requirements, or
to split nets.

• • Magnify the target pads.

Choose Zoom In from the View menu and click on the
screen with the left mouse button to magnify the lower right
hand corner of the board. Continue to zoom in until you see
the pad J2 or J3 as shown below.

• • Set a net width.

Choose the Manual Route with Shove toolbar button.

Select a connection with the left mouse button and choose
Change Width from the popup menu or press the W key.
Enter a new width value of 25.

• • Draw the track.

Begin inserting a track to the right of the node by dragging
the cursor. Click the left mouse button to create vertices.
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• • Establish a duplicate connection.

Choose Insert from the popup menu or press the INSERT key
to establish a duplicate connection



___________________________
OrCAD Layout for Windows

96

OrCAD Layout for Windows—interactive routing

• • Create a duplicate track.

Continue to input the track. As you now have a duplicate
connection displayed from the original pin, you can select
that connection and draw another track around the left of
the large pads.
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Creating nets interactively

In OrCAD Layout for Windows, you can create nets
interactively. This is “true” manual routing.

• • Create a net.

Choose the Create/Modify
Nets toolbar button and
choose Add Connection
to Netlist from the popup
menu.

Note    When you select this option, Layout reminds you that,
although you are adding the net to the board in Layout, the change
will not be reflected back to the schematic design.

Select a pin from the J2 component, for example, pin 4.
Select a pin that is in the signal GND EARTH, for example, J2,
pin 2 or J3, pin 2.

If the nodes are already in a signal, you receive a message
asking you to confirm the combined nets. Once you
confirm, you are asked to assign a net name to the new nets.
You can confirm or cancel at this time.

If you type a net name that already exists, you receive a
message: “Net already exists. Do you wish to tie to it?”
Choose the Yes button. The system automatically ties the
pin to the net.

Net created
interactively.
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Splitting nets

You can also separate a net into two separate nets
interactively.

• • Split a net.

Choose Delete Connection from Netlist from the popup
menu.

In the board design, select a net to split into two separate
nets. (Do not select a pin at the end of the signal.)

Layout asks you to confirm your decision to delete the
connection. If you answer Yes, you are asked to name the
new nets individually.
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Disconnecting pins

In OrCAD Layout for Windows, you can easily remove pins
from a net without splitting the net.

• • Disconnect a pin from the net.

Choose Disconnect Pin from Netlist from the popup menu.
Select the pin you connected to the GND signal, J2, pin 4.

The system asks if you want to disconnect the selected pin
from the net. Choose the Yes button to disconnect or delete
the pin from the net.
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Autorouting

We will now demonstrate autorouting in OrCAD Layout for
Windows.

Note    If you wish to stop before continuing with autorouting,
choose Exit from the file menu. Reload DROUTE2.MAX or
DROUTE4.MAX when you are ready to begin autorouting.

Loading a strategy file

Routing strategies can be used to provide part of the
autorouting solution. Layout includes several strategy files
that are optimized for specific types of boards based on the
types of components used, the number of board layers, and
the preferred track direction for the top layer.

• • Load the strategy file.

Choose Load Strategy from the File menu.

As the demo design has a power and a ground layer, you
must first disperse the vias to these planes to complete the
necessary connections. Select the strategy file, GDISPER.SF,
which has been defined for the dispersion of vias for the
power and ground planes.
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Dispersing vias

Once net parameters are set, individual nets can be routed
using one of the several routing tools Layout provides.

During the placement section of the demo, you disabled the
power and ground layers for routing. Open the Nets
spreadsheet to check the status of these signals. There
should be a No in the Route Enable column for all of the
power and ground signals: AGND, EARTH GND, GND, V+12,
V12N, and VCC. If the signals are not disabled, do so as
described in Chapter 3: Component Placement.

• • Enable routing on only the power and
ground nets.

To disperse the vias, you must
switch the nets for routing, enabling
the power and ground nets for
routing and disabling all others.

In the Nets spreadsheet, select the
entire Routing Enabled column.
Choose Enable <-> Disable from the
popup menu.

Now, the power and ground signals should be the only nets
with YES in the Routing Enabled column. The only ratsnest
of signals you should see on the screen are the power and
ground signals

Note    The ratsnest for the GND and POWER signals are displayed in
the color assigned to that plane layer.
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• • Minimize the connections on the power and ground planes.

To ensure that the board design has the shortest possible
connection within each signal, you can minimize the
connections using the Mincon command.

Mincon evaluates the connections within a signal and finds
the shortest route for the signal based on the placement of
the pins or components.

In other words, as the components are now placed, it may
be easier to route the track from U1-2 to U16-20 to U3-2
instead of following the order as it appears in the schematic
netlist.

Choose the Component toolbar button. Place the cursor in
the Design window and choose Mincon from the popup
menu.
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• • Disperse the vias.

Since you have enabled only
the power and ground signals
for routing, and the strategy
you selected restricts the
routing routine to short
connections, you can disperse
all of the signals, through vias,
to the appropriate plane.

Choose Batch Route from the
Auto menu.

When the message, “All
Sweeps Completed [or disabled]” appears, choose the OK
button. Only the power and ground signals should be
routed.

Note    In some instances, not all of the signals experience successful
via dispersion. The system checks the design rules and the
component layout to determine where vias can be placed. Circles
indicate areas in which it is not possible to place vias. You can then
insert vias interactively, or reset the dispersion strategies and run the
Batch process again.

Note    Signals can be assigned to planes at the schematic level. Or,
you can select power or ground in the Nets spreadsheet and set the
appropriate signal using the net layer parameter.



___________________________
OrCAD Layout for Windows

104

OrCAD Layout for Windows—autorouting

Autorouting the entire board

To autoroute an entire board, you must disable the plane
layer nets for routing, set the spacing requirements, and
select a routing strategy.

• • Enable the layers for routing.

Open the Nets spreadsheet and select the Routing Enabled
column. Choose Enable<->Disable from the popup menu.
Now the nets to the plane layers are disabled for routing,
and the other nets are enabled for routing.

• • Minimize connections.

Position the cursor in the Design window, and choose
Mincon from the popup menu.

• • Load a strategy file.

Choose Load Strategy from the File menu. Select
DROUTE2.SF or DROUTE4.SF.
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• • Autoroute the board.

Choose Batch Route from the Auto menu to autoroute the
rest of the board.

Note    If you wish to stop the routing process at any time, press the
ESC key.
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Running Design for Manufacturability (DFM) tests

Layout uses shove technology to minimize vias for the
efficient use of board space. After the board is routed, you
can run via reduction passes to reduce the vias even further.
Via counts are typically 30% to 50% lower with Layout
than with other PCB design programs.

There are also design management utilities that you can run
to enhance a design’s manufacturability: Board Space
Check, Board Design Check, Board AutoCDE, and Board
AutoDFM.

• • Run Board Space Check.

Board Space Check verifies board
spacing. Layout does not allow
for spacing errors while
performing interactive or
automatic routing. If you have
turned off DRC at any point in
the interactive process, you
should run Board Space Check.
Any problems are marked by a
circle and can be queried using
the Error tool.

To run Board Space Check,
choose Board Space Check from
the Auto menu.
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• • Run Board Design Check.

Board Design Check verifies that the design adheres to
specific rules specified in the Design Rules dialog box. For
example, nets are checked for dispersion to the plane. The
utility also checks for proper pad exits for routing.

To run the Board Design Check, choose Board Design
Check from the Auto menu. In the Design Rules dialog box,
select the type of checks you wish to run.

Via Location Errors.    Checks for vias in via-restricted
areas.

Copper Continuity.    Checks for copper areas that are not
attached to a net.

SMT Dispersion.    Ensures that surface mount pads
connected to nets on plane layers have vias to get to the
plane.

Pad Exit Errors.    Checks for problems such as tracks
exiting the sides of surface mount IC pads.

Net Rule Violations.    Checks for discrepancies in layers
or widths between what exists and what is specified in the
Nets spreadsheet.

Check Test Points.    Confirms that any net that has been
designated to have a test point has a test point.
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• • Run Board AutoCDE.

Board AutoCDE automatically sweeps through the entire
design and rips up any routing that violates design rules. By
running Board AutoCDE, you can assess the impact of
ECO changes and create a clean design for rerouting.

To run Board AutoCDE, choose Board AutoCDE from the
Auto menu.

• • Run Board AutoDFM.

Board AutoDFM automatically
smoothes, miters corners, and
checks for aesthetics and
manufacturing problems. The
problems that are checked for and
corrected include off-grid 90
degree angles, acute angles, bad
copper share, pad exits, and
overlapping vias. Any problem
DFM cannot fix is marked with an
error circle.

To run Board AutoDFM, choose
Board AutoDFM from the Auto
menu.
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Exiting the routing file

You have finished routing the board.

You may continue now with Chapter 5: Thermal Reliefs
and Copper Pour Zones or, if you want to stop, choose Exit
from the File menu.

Keep in mind that you cannot save the routed board.
However, the OrCAD Layout for Windows Demo includes
a file with a fully routed board that you can use for
subsequent activities. When you are ready to continue with
the demo, follow the instructions in Chapter 5: Thermal
Reliefs and Copper Pour Zones.

Go to the next chapter.

Go to the table of contents.



Chapter 5
Thermal reliefs and
copper pour zones

Go to the table of contents.

Go to the last page of the previous chapter.
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Thermal reliefs

In OrCAD Layout for Windows, you control the placement
of thermal relief connections. For example, some companies
require that ICs receive power directly from capacitors and
not from the plane. If a track is routed between a capacitor
and the IC power pin, you can choose which pin connects to
the plane. You set these rules in the footprint library.

Viewing thermal relief planes

In OrCAD Layout for Windows, thermal reliefs are created
automatically when a net is assigned to a plane. You can
view the plane connections on the screen without any kind
of post processing function, making it easy to confirm them.

To view the thermal relief plane, you need to make the
plane layer visible and the other layers in the design
invisible. You can choose to view certain layers by assigning
colors to the layers or designating them as visible or
invisible.

• • Open a design file.

Open the file FINISH2.MAX or FINISH4.MAX.

• • Magnify the area to view.

Choose Zoom In from the View menu and magnify the
lower right corner of the board.
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• • Make the top, bottom, and silkscreen layers invisible.

Choose the Color toolbar button.

In the Color spreadsheet, select the top, bottom (inner
layers if you are using four routing layers), and silkscreen
(SST and SSB) layers. Choose Modify from the popup menu.

In the Edit Color dialog box, select the Invisible check box,
and from the palette, select a color for the layers.
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• • Make the GND plane visible.

In the Colors spreadsheet, select the GND layer. Again,
choose Modify from the popup menu. In the Edit Color
dialog box, deselect the Invisible check box and from the
palette, select a color for the GND layer.

When you close the Color spreadsheet, the thermal relief
connections are displayed on the GND plane.

• • Choose to view the top layer only.

Next, you will create copper pour zones on the board. It is
easiest to view the copper pour zones with only the top
layer visible. When you have finished viewing the thermal
reliefs, make the top layer visible and the GND layer
invisible.
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Copper pour zones

A copper pour zone is used to place copper in designated
areas. Copper pour also places thermal reliefs on pads and
eliminates copper islands. A copper pour zone can be placed
on any layer (except the plane layer), can be solid or cross
hatched, and can be attached to any net. Copper pour
attached to a net assumes the attributes of that net.

There are three types of copper pour zones:

Copper zone.    You can use copper zones to create
custom pad shapes. Isolation rules do not apply to copper
zones.

Copper pour zone.    Copper pour zones avoid pins and
tracks but attach to pins with a thermal relief.

Anti-copper zone.    Use anti-copper zones to create non-
copper areas within copper pour zones.

Creating copper pour zones

In OrCAD Layout for Windows, you can create a copper
pour zone by drawing and modifying an obstacle.

• • View the top layer.

Select Top from the layer drop list on the toolbar.
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• • Designate a seed point.

When you are creating a copper pour zone in OrCAD
Layout for Windows, you must designate a seed point. The
seed point is the point from which the copper pours.

Choose the Pin toolbar button. Select a pin attached to the
net to which you want to attach the copper pour zone. From
the popup menu, choose Toggle Copper Pour Seed to set
the copper pour seedpoint.

• • Create the copper pour obstacle.

Choose the Obstacle toolbar button. Then, choose Insert
from the popup menu.

Pressing the left mouse button, drag to create a rectangle in
the bottom right corner of the board as shown below.

Create the
copper pour
obstacle.
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• • Define the copper pour obstacle.

While pressing the SHIFT key, select the obstacle that you
have drawn by clicking on it with the left mouse button.
Choose Modify from the popup menu.

In the Edit Obstacle dialog box specify the following
parameters for the copper pour zone.

• From the Obstacle Type drop list, select Copper Pour.

• From the Obstacle layer drop list, select Top.

• Change the Obstacle Width to 10.

• In the Net attachment text box, enter AGND. Copper
Pour attached to a net assumes the attributes of that net.
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• • Set rules for the copper pour zone.

In OrCAD Layout for Windows, you should set rules to
govern copper pour. You set the rules in the Copper pour
rules group box in the Edit Obstacle dialog box.

Copper pour clearance.    Designates the absolute
clearance between a particular piece of copper pour and all
other objects.

Isolate all routes.    Attaches copper into only pads of a net
using thermal reliefs. Tracks remain isolated.

Seed only from designated object.    Specifies that the
copper pours into as much area as is possible, contiguously
from the seed point. Tracks and vias are not used to seed
the pour.

For the purpose of the demo, set the following copper pour
zone rules.

• Change the Copper Pour Clearance to 10.

• Select the Seed only from designated object check box.

• • Select a hatch pattern for the copper pour zone.

Copper and copper pour zones can be solid, a single line, or
crossed hatched.

Choose the Hatch pattern button. Select the Solid option
and set the Hatch grid to 10.
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• • Pour the copper.

Choose End Command from the popup menu to release the
obstacle from the cursor. The copper pour zone forms on
the screen.

• • View the thermal reliefs.

Choose Zoom In from the View menu to observe an area in
which thermal reliefs have been automatically added to the
signal pads for AGND.

View the
thermal relief.
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Redrawing the copper pour zone

In OrCAD Layout for Windows, you can edit the board
inside a copper pour zone, and then easily repour the copper
to accommodate your changes.

• • Insert a part into the copper pour zone.

Choose the Component toolbar button and select a discrete
through-hole part. Press the INSERT key.

Move the part into the an open area in the copper pour
zone. Choose the Manual Route with Shove toolbar button
to edit the track as desired.

Inserting a
new
component.
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• • Refresh the copper pour zone.

Choose the Refresh Copper Pour toolbar button to redraw
the copper.

Refresh the
copper pour.
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Creating odd-shaped copper pour zones

Copper pour can be any shape. It is just as simple to create
a round copper pour zone as it is to create a rectangular
one.

• • Designate a seed point.

When you are creating a copper pour zone in OrCAD
Layout for Windows, you must designate a seed point. The
seed point is the point from which the copper pours.

Choose the Pin toolbar button. Select a pin attached to the
net to which you want to attach the copper pour zone. From
the popup menu, choose Toggle Copper Pour Seed to set
the copper pour seedpoint.

• • Insert and define a new obstacle.

Choose the Obstacle toolbar button. Press the INSERT key to
create a new obstacle.

Choose Modify from the popup menu. Specify the obstacle
as copper pour and set the rules and parameters as
explained in Creating a copper pour zones in this chapter.



___________________________
OrCAD Layout for Windows

122

OrCAD Layout for Windows—copper pour

• • Create an arc.

Click the left mouse button at desired center for your
circular copper pour zone. Choose Arc from the popup
menu or press the A key. Drag the cursor to begin creating
a circle. Click the left mouse button to stop drawing.
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Changing the hatch pattern

Layout supports any combination of solid and cross hatch
pour areas. The cross hatch can be set to any angle.

• • Select a copper pour zone.

Select the circular copper pour zone you just created and
choose Modify from the popup menu.

• • Change the hatch pattern.

In the Edit Obstacle dialog box, choose the Hatch pattern
button. Select the Cross-Hatch option. Change the Hatch
grid to 50, and the Hatch rotation to 45.
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Exiting the design file

When you have finished with this section, you can either
exit the design file by selecting Exit from the File menu, or
continue with the Chapter 6: Post processing.

Go to the next chapter.

Go to the table of contents.



Chapter 6
Post processing

Go to the table of contents.

Go to the last page of the previous chapter.
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Post processing

The final task in creating a board is to generate output files.

From Layout, it is possible to extract Gerber files (274D),
Extended Gerber files (274X), DXF files, and printer output
such as HPGL, HP laser, and dot matrix. Each of these files
can be created individually or as a group.

The aperture list for Gerber extraction can be created
automatically as the Gerber files are created, or a standard
user-defined aperture file can be used.

• • Open the design file.

Choose Open from the File menu. Select FINISH2.MAX or
FINISH4.MAX from the list presented.

• • Display the Post Process spreadsheet.

Choose the Post Proc. toolbar button. Then choose Setup
Batch from the menu that appears. The Post Process
spreadsheet displays.
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Using the Gerber previewer

Layout includes a Gerber previewer. The previewer is useful
for configuring Gerber output. The previewer displays
exactly what will be output.

• • Tile the windows.

Choose the Initialize Color toolbar button. Choose Tile
from the Window menu to tile the Post Process spreadsheet,
the Design window, and the Color spreadsheet on the
screen.

Note    You only need to tile the windows if there are objects on the
photoplot that do not appear in the preview window.

• • View the Gerber preview.

Select the *.TOP column in the Post Process spreadsheet
and choose Preview from the popup menu or press the P
key to preview the Gerber file setup.
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Modifying output

To modify a layer setup, you can turn layers on and off in
the Color spreadsheet.

• • Make the board outline visible.

In the Color spreadsheet, select Board Outline. From the
popup menu, choose the toggling Invisible command to
make the layer visible.

• • Save the changes.

In the Post Process spreadsheet, choose Update Colors
from the popup menu to save the changes.

• • View the board outline in the Gerber previewer.

Select *.TOP from Post Process spreadsheet and choose
Preview from the popup menu. You will now see the board
outline.
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Creating Gerber output

You create Gerber files using the Run Batch command.

When you run the batch process, the system asks you if you
want to create the aperture list for the plot(s).

Note    As the demo files cannot be saved, you cannot actually run
the Gerber files at this time.

• • Create Gerber output.

Gerber output is not supported by this demo. But, creating
Gerber output in Layout is easy. You would simply select
the *.TOP column in the Post Process spreadsheet and
choose Run Batch from the popup menu.
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Generating reports

In OrCAD Layout for Windows, a variety of standard
reports can be created including netlists, net length reports,
insertion lists, drill files, and parts lists.

Custom reports can be created to include attributes passed
forward from the schematic, as well as attributes originating
within Layout.

• • View the possible reports to generate.

Choose the Post Proc. toolbar button
and choose Reports from the menu
that appears. Scan the list of possible
reports in the Generate Reports dialog
box.
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Exiting the design file

When you are finished with post processing, you can exit
the design file by choosing Exit from the File menu or you
can continue with the Chapter 7: Using OrCAD Layout for
Windows with Capture for Windows.

Go to the next chapter.

Go to the table of contents.



Chapter 7
Using Layout with OrCAD

Capture for Windows

Go to the table of contents.

Go to the last page of the previous chapter.
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Annotation and cross probing

OrCAD Layout for Windows has the ability to communicate
interactively with OrCAD’s Capture for Windows.

Layout’s AutoECO utility automatically forward annotates
all schematic attributes, component information, and netlist
changes to a PCB from Capture for Windows. AutoECO
also resolves pin-to-pin conflicts that arise due to pins that
are missing from a footprint, or from pins that are named
differently in the schematic than they are in Layout. And,
when you make changes to your board, AutoECO can back
annotate the changes to the Capture netlist.

Forward annotating Capture netlist data to your board

This section demonstrates how to bring netlist data into the
board design from OrCAD’s Capture for Windows.

Note    In the demo, we are not actually making changes to the
schematic in Capture; therefore, the following process is only a
description of the process, and does not actually modify the board
file.

• • Open the Capture for Windows schematic design.

Choose Open and Design from the File menu, and select
DGUIDE.DSN from the list presented.

• • Change to physical view.

Choose Physical from the View menu as
this is a hierarchical design.
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• • Create the netlist.

In Capture, choose Create
Netlist from the Tools menu.
In the Create Netlist dialog
box, choose the Layout tab.

In the PCB Footprint group
box, enter {FOOTPRINT} in
the Combined Property String
text box. Type FOOTPRINT
in capital letters and include
the brackets {}.

Ensure that the full path to the
netlist file DGUIDE.MNL appears in the Netlist File text box
as shown below.

Choose the OK button to process the netlist.

Enter
{FOOTPRINT}
here.

Enter full path to
DGUIDE.MNL
here.

Note    You may choose to exit Capture at this time. It is not
necessary to run Capture and Layout simultaneously to take
advantage of forward annotation; you must have a minimum of 16
MB of RAM to run Capture and Layout at the same time.
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• • Open the design in Layout.

Choose Design from the OrCAD frame. Select the file
RENAME2.MAX or RENAME4.MAX from the list presented.

As the netlist for the design has changed, Layout asks if you
want to load the new netlist for the design. Choose the Yes
button. Layout updates the board design to reflect any
changes made in the schematic.



___________________________
OrCAD Layout for Windows

136

OrCAD Layout for Windows—using with OrCAD Capture

Back annotating information to Capture from Layout

This section demonstrates how to send design data back to
Capture from Layout.

Note    It is not necessary to run Capture and Layout simultaneously
to take advantage of back annotation; you must have 16 MB of RAM
to run Capture and Layout at the same time.

• • Rename the components on the
design.

In Layout, choose Manual
Place/Rename Rules from
the Options menu. In the
Manual Place rules dialog
box, choose the Rename
directions button to display the Rename Directions dialog
box. Choose Right, Down to rename the components from
the upper left corner of the board to the lower right corner
of the board. From the Auto menu, choose Rename
Components. Layout renames the components.
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• • View the updated reference designators on the PCB.

Choose Zoom In from the View menu to magnify the three
components on the left side of the board near the connector.
The rename components command has updated the
component reference designators.

Three
components.

• • Create a swap (.SWP) file for back annotation.

Choose the Post Proc. toolbar button.
Then, choose Reports from the pull-
down menu. In the Generate Reports
dialog box choose the OrCAD Back
annotation File (.SWP). Choose the OK
button to create the file.

Note   When Layout creates the swap (.SWP) file, it attempts to save
a backup of the design file called BACKANNO.MAX.
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• • Open the Capture design.

If Capture is not currently running, choose Open and Design
from the file menu and select DGUIDE.DSN from the list
presented. Choose Physical from the View menu. If your
system resources allow you to run Capture and Layout
simultaneously, resize the Capture and Layout application
windows to view the schematic and the board side-by-side.
It may help to choose Half Screen from the Window menu
in Layout.

• • Update the Capture schematic.

In Capture, choose Gate and
Pin Swap from the Tools
menu. Locate and select the
swap (.SWP) file you created in
Layout, which is probably
called RENAME2.SWP or
RENAME4.SWP. If the file does
not appear by default in the
Swap File text box, use the
Browse button to search for it.
The file should have the same
name and should be located in the same directory as your
PCB design.

Choose the OK button. When you restart Capture and
reopen the schematic design, it is updated to reflect the
changes you made to your board design.
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• • View the updated reference designators on the Capture schematic.

In the Capture Design Manager, double-click on the
Evaluation folder to display the schematic hierarchy. Then
double-click on Eval Pg 1 to open page 1 of the Capture
schematic. Zoom in to view the reference designators that
you modified in Layout. They have also changed on the
schematic.
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Cross probing between Capture and Layout

In cross probing, selecting a part, component, or net on a
Capture schematic or Layout board causes the
corresponding component to be highlighted in the other
application.

Note    It is necessary to run Capture and Layout simultaneously to
take advantage of cross probing; you must have a minimum of 16 MB
of RAM to perform cross probing using this demo.

• • View the updated reference designators on the PCB.

In Layout, choose Zoom In from the View menu to magnify
the three components on the left side of the board near the
connector.

• • View page 1 of the Capture schematic.

In the Capture Design Manager, double-click on the
Evaluation folder to display the schematic hierarchy. Then
double-click on Eval Pg 1 to open page 1.

• • View the Capture schematic and the Layout board on the screen.

Resize the Capture and Layout windows on the screen.
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• • Highlight a component in Layout using cross probing.

In Capture, select a part on page 1. The corresponding
component is highlighted on the board in Layout.

2. To
highlight this
component in
Layout.

1. Select this
part in
Capture.
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• • Locate a resistor in Capture using cross probing.

In Layout, choose the Component toolbar button. Select
one of the terminating resistors in the center of the bottom
of the board.

In Capture, the schematic automatically opens and displays
the schematic page on which the corresponding symbol is
located. Scroll the window until the highlighted symbol is
visible.

1. Select one
of these
resistors.

2. Capture
opens the
appropriate
schematic
page.
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• • Select a signal in Capture to highlight the corresponding net in
Layout.

You can experiment with highlighting by selecting lines in
Capture or tracks in Layout.

For example, in Capture, select the ground or VCC signal on
the schematic. All of the connections of the corresponding
net are highlighted on the board in Layout.
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Exiting the design file

When you are finished with this section, you can exit the
board file by choosing Exit from the File menu. You can run
any part of the OrCAD Layout for Windows Demo again by
reading the appropriate chapter in the demo guide and
opening the corresponding demo board file.

Go to the table of contents.


