
About OrCAD Capture for Windows Help
OrCAD's first experiments with online help were conducted by Nanci Hamilton, Director of 
Technical Publications and Support, using Doc-to-Help to translate the existing SDT (DOS and
386+) reference guides into a single Microsoft Word for Windows v2.0c source file.
On February 2, 1994, responsibility for Capture's online Help passed to David M. Brown, 
Senior Technical Writer. Over the following fifteen months, he created the graphic elements, 
wrote the overviews and many of the more abstract topics, and provided technical and 
editorial assistance as well as guidance to the other writers who joined him on the Help 
development project.
Technical writers Kathy Blago and Mark Maneely made huge contributions to this Help file. 
The sections on Processes, Commands and tools, and Help for SDT users, in particular, 
reflect their intense efforts to ensure accuracy of information and completeness of coverage.
Documentation Manager Cindy Easton contributed significantly to the design and 
development of OrCAD Capture for Windows. Much of its behavior and appearance are a 
direct result of her commitment to the user. She led the design and development of the 
entire documentation set, which comprises the following components:

OrCAD Capture for Windows Help (created by David Brown, Kathy Blago, and 
Mark Maneely)

Learning Capture, the online tutorial (created by Greg Thompson, Senior Technical 
Writer, with editorial and programming assistance from David Brown)

OrCAD Capture for Windows User's Guide (created by Cindy Easton, with assistance 
from Kimberly Keyes, Senior Technical Writer)
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Registration information
To help us support your new product, please register your OrCAD software by filling out the 
registration card and mailing it to us within 90 days of purchase. Your registration card is 
inside the sealed packet containing your program disks.

We want you to get the most out of your software. As a registered customer, you have a 
staff of trained Technical Support and Customer Service specialists waiting to help you. By 
registering your software you receive these benefits:

Access to OrCAD's twenty-four hour bulletin board system
One year's free subscription to the OrCAD Pointer---OrCAD's quarterly technical 

newsletter
Unlimited free phone and technical support, provided your registered version of 

Capture is current

Related topic
License aggreement
When you have a question



If you enter the registration number when you install the software, the number is always 
available using the About Capture command (ALT, H, A).



Previous versions of Capture will be supported for 120 days after a new release of Capture.



License agreement
AS PRINTED ON THE DISK PACKET

By opening the sealed disk packet and/or by using the software, you (either an individual or 
an entity) agree to be bound by the terms of this Agreement. If you do not agree to all the 
terms of this Agreement, OrCAD, Inc. ("OrCAD") is unwilling to license the software programs
to you, in which event you should promptly return the unopened disk packet and all 
accompanying items (including manuals, binders or other containers and any other printed 
materials) to OrCAD (or an authorized OrCAD reseller) within 30 days of receipt for a full 
refund (including shipping costs).
This License Agreement is your proof of license. Please treat it as valuable property.

OrCAD PRODUCT LICENSE
1 GRANT OF LICENSE. So long as you comply with the terms of this LICENSE, OrCAD grants 

to you the nonexclusive right to use the enclosed OrCAD software product and 
documentation ("OrCAD PRODUCT"). OrCAD reserves the right to terminate your rights 
under this LICENSE and to seek any other legal remedies if you violate any provisions 
hereof and, in the event of such termination, you agree to return the enclosed OrCAD 
PRODUCT to OrCAD. The OrCAD PRODUCT is the sole and exclusive property of OrCAD.
The software portion of the OrCAD PRODUCT ("SOFTWARE"), which may include user 
documentation provided in the SOFTWARE or in electronic form, is licensed as a single 
product. The component parts of the SOFTWARE may not be separated for use on more 
than one computer or by more than one user at any time.
A SINGLE USER LICENSE. If you have a single LICENSE for the SOFTWARE, as indicated on

the invoice, then OrCAD grants to you the nonexclusive right to use one copy of the 
OrCAD PRODUCT on any single computer at a single location. However, if the 
SOFTWARE is permanently installed on the hard disk or other storage device of a single
computer (other than a network server) and one person uses that computer more than 
80% of the time it is in use, then that person may also use a copy of the SOFTWARE on 
a portable or home computer provided that the SOFTWARE may not be used for 
purposes beyond the scope of that person's employment with you, the licensee of the 
SOFTWARE.

B MULTI-USER AND NETWORK LICENSES. If you have multiple LICENSES for the 
SOFTWARE, as indicated on the invoice(s), then OrCAD grants to you the nonexclusive 
right to have, at any time, as many copies of the SOFTWARE "in use" as you have 
LICENSES. The number of copies of SOFTWARE "in use" includes copies loaded into the 
CPU memory (i.e. RAM), but does not include copies loaded on a network server for the 
sole purpose of distribution to other computers. You agree to have a reasonable 
mechanism or process in place to ensure that the number of persons using the 
SOFTWARE concurrently does not exceed the number of LICENSES.

2 UPGRADES and UPDATES. If the SOFTWARE is an upgrade from or update to another 
version of OrCAD software, you agree to use the upgraded or updated software only in 
accordance with this LICENSE. This LICENSE supersedes any prior license to the prior 
version of the software.

3 COPYRIGHT. This OrCAD PRODUCT and any copies thereof are owned by OrCAD and are 
protected by United States copyright laws and international treaty provisions. Therefore, 
you must treat the OrCAD PRODUCT, including the SOFTWARE, like any other copyrighted 
material (e.g., a book or musical recording) except that you may (a) make no more than 
one (1) copy of the SOFTWARE solely for backup or archival purposes, or (b) copy the 
SOFTWARE to a single hard disk or other permanent memory provided you keep the 
original and no more than one other copy solely for backup or archival purposes.
You must label any copies with all information included on the original diskette label. You 



agree not to distribute copies of the enclosed OrCAD PRODUCT to others. You further 
agree to take all reasonable steps and to exercise due diligence to protect the enclosed 
OrCAD PRODUCT from unauthorized reproduction, publication or distribution. If the 
SOFTWARE is copied to or used on a computer attached to a network, you must have a 
reasonable mechanism in place to insure that the SOFTWARE may not be used or copied 
by unlicensed persons.

4 OTHER RESTRICTIONS.
YOU AGREE NOT TO USE, COPY, MODIFY OR TRANSFER THE ENCLOSED OrCAD PRODUCT 
OR ANY COPY, IN WHOLE OR IN PART, EXCEPT AS EXPRESSLY PROVIDED FOR IN THIS 
LICENSE.
You agree not to rent, lease or sell this OrCAD PRODUCT. You agree not to transfer this 
LICENSE without notifying OrCAD in writing of the registration information for the 
transferee as specified by OrCAD, and the transferee must agree to the terms of this 
LICENSE. You agree not to reverse engineer, decompile, disassemble or make any attempt
to discover the source code to the SOFTWARE.

LIMITED WARRANTY

THE ENCLOSED OrCAD PRODUCT IS SOLD "AS IS" WITHOUT WARRANTY, EXPRESS OR 
IMPLIED, AS TO PERFORMANCE, MERCHANTABILITY, OR FITNESS FOR ANY PARTICULAR 
PURPOSE. THE ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE OF THE OrCAD 
PRODUCT IS ASSUMED BY YOU.
However, to you only, and provided you send to OrCAD the signed limited warranty 
registration card, OrCAD warrants the magnetic diskette(s), on which the SOFTWARE is 
recorded, to be free from defects in materials and workmanship under normal use for a 
period of ninety (90) days from the date you paid for the LICENSE. If during this ninety-day 
period the diskette(s) should become defective, you may return the defective diskette(s) to 
OrCAD postage prepaid, with proof of purchase for replacement without charge or, at 
OrCAD's option, a full refund of the LICENSE fee.
Your sole and exclusive remedy in the event of a defect is expressly limited to the 
replacement of the diskette(s) or refund of the LICENSE fee as provided above. If failure of 
the diskette(s) has resulted from accident, abuse, or misapplication, OrCAD shall have no 
responsibility to replace the diskette(s) under the terms of this limited warranty.
This warranty gives you specific legal rights, and you may also have other rights which vary 
from state to state. You and OrCAD agree that the enclosed OrCAD PRODUCT is not intended
as a "consumer good" or "consumer product" under state or federal warranty laws.

LIMITATION OF LIABILITY

TO THE MAXIMUM EXTENT PERMITTED BY LAW, IN NO EVENT SHALL OrCAD OR ANYONE ELSE
INVOLVED IN THE CREATION, PRODUCTION, DELIVERY, OR LICENSING OF THE OrCAD 
PRODUCT BE LIABLE TO YOU OR ANY THIRD PARTY FOR ANY INCIDENTAL, INDIRECT, SPECIAL
OR CONSEQUENTIAL DAMAGES, OR ANY OTHER DAMAGES WHATSOEVER (INCLUDING, 
WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS 
INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR OTHER PECUNIARY LOSS) ARISING 
OUT OF THE USE OR INABILITY TO USE THIS OrCAD PRODUCT, WHETHER OR NOT THE 
POSSIBILITY OR CAUSE OF SUCH DAMAGES WAS KNOWN TO OrCAD. IN NO EVENT SHALL 
OrCAD's LIABILITY IN CONNECTION WITH THE OrCAD PRODUCT EXCEED THE LICENSE FEE 
PAID FOR THE OrCAD PRODUCT.

U.S. GOVERNMENT RESTRICTED RIGHTS

The SOFTWARE and documentation are provided with RESTRICTED RIGHTS. Use, duplication,



or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(l)
(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 
(48 CFR 252.227-7013) and subparagraphs (c)(1) and (2) of the Commercial Computer 
Software---Restricted Rights at 48 CFR 52.227-19, as applicable. Manufacturer is OrCAD, Inc.,
9300 SW Nimbus Avenue, Beaverton, Oregon  97008-7137  USA.

EXPORT LAWS

You acknowledge that the laws and regulations of the United States restrict the export and 
re-export of commodities and technical data of United States origin including the SOFTWARE
and any medium containing it. You agree that you will not export or re-export the OrCAD 
PRODUCT or any copy thereof, including manuals, in any form without the appropriate 
United States and foreign government license or permit, as necessary. You also agree that 
your obligations under this Section will survive and continue after any termination or 
revocation of rights under this Agreement.

MISCELLANEOUS

In the event legal action is brought by either you or OrCAD to enforce the terms of this 
Agreement, the prevailing party shall be entitled to recover reasonable attorney fees and 
expenses for any proceeding, at or before trial and upon appeal, in addition to any other 
relief deemed appropriate by the court.
You agree to submit to exclusive jurisdiction in the federal and state courts of Oregon, USA in
the event of a dispute. This Agreement shall be interpreted pursuant to Oregon law without 
regard to conflict of laws.
The invalidity or unenforceability of any provision hereof shall in no way affect the validity or
enforceability of any other provision.
This Agreement constitutes the complete agreement between you and OrCAD, and may not 
be modified unless a written amendment is signed by a corporate officer of OrCAD.
If you have any questions concerning this Agreement, or if you desire to contact OrCAD for 
any reason, please contact in writing:

Customer Sales and Service
OrCAD, Inc.
9300 SW Nimbus Avenue
Beaverton, Oregon  97008-7137
USA

OrCAD is a registered trademark, and Design Desktop is a trademark, of OrCAD, Inc. All 
other product names mentioned herein are trademarks of their respective owners.
Copyright © 1995 by OrCAD, Inc.  All rights reserved.

Related topic
Getting in touch
When you have a question



When you have a question

Technical support
Help with technical questions

Customer service
Registration, order status, and product support agreements

Sales and product information
OrCAD D  IRECT   sales  
International sales and service

Main switchboard and fax
Administration
Fax

24-hour bulletin board system
Updates, technical notes, and more



How to reach OrCAD
Technical support (503) 671-9400

Internet:    techsupport@orcad.com
Bulletin board system (503) 671-9401
Administration (503) 671-9500
Fax (503) 671-9501
O  R  CAD D  IRECT   sales  (800) 671-9505

Internet:    info@orcad.com
O  R  CAD D  IRECT   customer   
service

(800) 671-9511

International sales and 
service

(503) 671-9500
Internet:    intl@orcad.com

Technical support: (503) 671-9400
6:00 A.M TO 4:00 P.M. PACIFIC TIME

Call this number for help with technical questions. Please have your registration number 
ready for the operator. You can expedite your call by having the following information ready 
for the technical support engineer:

Registration number
System type and configuration
Program version number
Computer type or model
DOS and Windows version numbers
Memory and free disk space (including size of swap file)
Copy of the session log
 
 

Before calling Technical Support
1 Check to see if your hardware meets the minimum system requirements for the software 

you are using.
2 Check the documentation that accompanies your software. It should answer most 

questions. For answers to common questions about Capture and Windows, see 
Troubleshooting. For explanations of many Capture messages, see Error messages.

3 Read and print the session log.
4 Exit Capture and Windows, and reboot your computer. Then restart both Windows and 

Capture, and try the problem operation over again.

Related topics
24-hour bulletin board system
Fax
Troubleshooting
Error messages
Getting in touch



You can print the contents of the session log by saving it as a text file. Then, open up the 
file in any text editor, and choose the Print command from the File menu.



To run Capture effectively, you need at least a 20 MB swap file.



Bulletin board system: (503) 671-9401
24 HOURS A DAY

Call this number by modem to leave technical questions and messages, upload and 
download files, and use the technical support Q&A database.

Related topics
BBS system requirements and configuration
BBS availability
BBS logon instructions
Registering on the BBS
Downloading files from the BBS
Uploading files to the BBS
Getting in touch



Administration: (503) 671-9500
8:00 A.M TO 5:00 P.M. PACIFIC TIME

Related topic
Fax
Getting in touch



Fax: (503) 671-9501
24 HOURS A DAY

Related topic
Getting in touch



OrCAD DIRECT sales: (800) 671-9505
6:00 A.M TO 5:00 P.M. PACIFIC TIME

Call on weekdays between 8:00 A.M. and 5:00 P.M. Pacific Time to:
Order OrCAD products
Receive information about OrCAD products and services

Related topic
Fax
Getting in touch



International sales and service: (503) 671-9500
8:00 A.M TO 5:00 P.M. PACIFIC TIME

Call this number for information on the OrCAD value-added reseller nearest you. OrCAD has 
a network of sales and service representatives in the following countries.

Australia India Portugal
Austria Indonesia Russia
Belgium Ireland Singapore
Colombia Israel South Africa
Czech Republic Italy Spain
Denmark Japan Sweden
Finland Korea Switzerland
France The Netherlands Taiwan
Germany New Zealand Thailand
Greece Norway Turkey
Hungary Poland United Kingdom

Related topic
Fax
24-hour bulletin board system
Getting in touch



OrCAD DIRECT customer service: (800) 671-9511
6:00 A.M TO 5:00 P.M. PACIFIC TIME

Call this number:
For help registering the product
To check the status of your order or update

Related topic
Fax
Getting in touch



BBS system requirements and configuration
To access the OrCAD bulletin board you need:

A 300-, 1200-, 2400-, or 14,400-baud modem set for eight data bits, one stop bit, and
no parity.

Any communications software. You may wish to use software which supports ANSI 
graphics.
Set your communications software to send and receive data using an error-correcting 
protocol such as XMODEM, YMODEM, SEAlink, KERMIT, or SuperKERMIT. These protocols 
send and receive binary information or data containing control characters. You can also 
exchange plain ASCII files using the bulletin board.



BBS availability
The bulletin board operates twenty-four hours a day, except when it is shut down for 
maintenance. If you are not able to establish communications after a few rings, the bulletin 
board may be down for maintenance, and you should call back later.



BBS logon instructions
The first time you log on to the bulletin board, you can use many, but not all, bulletin board 
features. First, you must register and enter a password.
The bulletin board prompts you to enter all the necessary information. Allow two to three 
working days for OrCAD to upgrade your access level.
Once OrCAD changes your access level to "registered user," you can use all of the bulletin 
board's features. We encourage you to explore what is available.

Related topics
Registering on the BBS
Downloading files from technical support
Uploading files to technical support



Registering on the BBS

To register on the BBS
    1 Call OrCAD's bulletin board system at (503) 671-9401
    2 Enter your first name.
    3 Enter your last name. The OrCAD BBS assumes that each name is unique in the system. 

If you are asked to verify where you are calling from after entering your last name, enter 
N and repeat steps 2 and 3, entering your name differently like only an initial for your 
first or last name.

    4 Enter your location. For example, this could be the city and state from which you are 
calling or that of your home office.

    5 Verify your name and location. If they are not correct, enter N and make changes as 
needed.

    6 Enter the number of characters per line (10--132) that your display allows.
    7 Select the type of terminal you are using to access the BBS. If your system is not listed, 

press ENTER and answer the following questions:
Can your terminal print lower case?
Does your terminal need line feeds?
How many nulls (1--50, normally 0)?
Can your terminal display ANSI codes?
Can your terminal display IBM graphics characters?

    8 Verify your entries for Terminal Profile Setup. If the information is not correct, enter N and
make changes as needed.

    9 Enter Y or N to indicate whether you want transmissions to pause between pages of 
data.

10 Enter the number of lines per display page (10--80) that your monitor will allow.
11 Enter the password to be used to access this registration.
12 Re-enter the password from step 11 to verify it.
13 After the welcome message, choose R (Re-register) to continue.
14 Enter your full name. Be sure to spell it as you did in steps 2 and 3.
15 Enter your company name.
16 Enter your phone number.
17 Press ENTER at the prompts for your:

Schematic Design Tools (SDT) technical support number
Verification and Simulation Tools (VST) technical support number
PC Board Layout Tools (PCB) technical support number
Programmable Logic Devices (PLD) technical support number
PLD Modeling Tools (MOD) technical support number

18 Enter your Capture registration number. If you are not registered for Capture technical 
support, press ENTER.

19 Verify that your product registration information is correct. If the information is not 
correct, enter N and make your changes.



Downloading files from the BBS

To download files from technical support
1 Sign on to the BBS. The number is (503) 671-9401.
2 Select O (Obtain Technical Support File).
3 Select R (Reverse Multiple).
4 Select Y (Yes).
5 Enter the number of the message, if you know it. Otherwise, press enter to view all 

messages.
6 Select E (End) to download enclosed file.
7 Enter the letter of the desired protocol.
8 Enter the download command for your modem software.



Uploading files to the BBS

To upload files to technical support
1 Use PKZip to compress the required files into one file with the recipient's name and a .ZIP 

extension.
The required files usually include any .DSN and .OLB files involved with the problem, and 
a brief text file explaining how to reach you, the problem you are having, the exact 
wording of any error messages you may have encountered, and when they were 
displayed.

2 Call the BBS at (503) 671-9401. Once communications have been established, new BBS 
users will be prompted to register. If you are not a new user, type in your name, confirm 
your location, and then enter your password.

3 Select S (Schematic Design Tools area), and then U (Upload file).
4 At the prompt, enter the name of the .ZIP file you created in step 1.
5 Enter 1--6 lines of description. Indicate who the file is for.
6 If prompted, select a protocol.
7 Instruct your modem software to send the file.
8 To leave the BBS, choose - (Return to previous menu), then choose G (Goodbye).



Troubleshooting
The session log displays a record of events that have occurred during this session of Capture
for Windows. You can search for a text string, print the log, and save it as a text file.
The session log is replaced every time you start Capture.
To display the session log

Choose Session Log from the Window menu.

Answers to common questions

Here are several common questions about Capture and Windows. Before you call technical 
support, take a few minutes to check the answers to these questions. The information you 
find here may save you a call.

What should I do if I receive a message that my system is out of memory? ANSWER
How can I help prevent system crashes? ANSWER
Why am I getting a GROWSTUB error when I run Capture? ANSWER
Why am I getting a Win32s error saying library initialization failed? ANSWER
After I installed Capture and restarted my computer, I got the following message:
There is no room to expand the PATH environment variable with the 
mapping:
     "INS S1:=ORCAD\SYS:\PUBLIC"

What should I do? ANSWER
How do I set Capture up to run over a network? ANSWER
How can I free memory so I can run more applications with Capture? ANSWER
How can I increase the amount of environment space available to non-Windows 

applications? ANSWER
Why do my libraries take so long to load? ANSWER
When I try to open an SDT 386+ schematic, I get the following messages:
Window's TEMP environment variable not found.
Capture temp files created at design's directory.

What should I do? ANSWER
Why don't my schematic pages show up in the design manager when I save my 

design? ANSWER
How can I restore the original settings in the Preferences and Design Template dialog 

boxes? ANSWER
Update Part References worked fine once, but when I used it again, nothing 

happened. What went wrong? ANSWER
I receive an error message about a failed initialization of dynamic linked libraries 

while trying to run Capture. The message says one or more components is old. How can I 
update these files? ANSWER

How can I globally change the fonts in my design? ANSWER
How do I get a pure black-and-white print with no dithering or gray-scale? ANSWER
I've lost the color to my jumps and pop-ups in my help files. How can I get them 

back? ANSWER
How can I prevent Win32s errors while translating SDT libraries into Capture? 

ANSWER
How can I prevent Capture from freezing or hanging up in the middle of translating an

SDT library? ANSWER
How can I prevent errors due to off-page connectors that send bus signals across 

schematic pages? ANSWER



Why doesn't Capture plot text correctly? ANSWER
Why doesn't Capture create the same timestamps as SDT? ANSWER
Capture says that my design has duplicate references to a part, but I don't see any. 

What is the problem? ANSWER
How can I get Capture to translate my thick wires from SDT? ANSWER
How can I save a design or translated design without a system generated name? 

ANSWER

Related topic
Error messages



To view the answer to one of these questions, choose the word "ANSWER" which follows it.



Q What should I do if I receive a message that my system is out of memory?

A Several problems can generate an "out of memory" message in Windows. A few of them 
are described here. See your Windows documentation for more information on 
troubleshooting, memory management, and system performance.
Disk drivers

Make sure the disk driver software, hard disk controller, and hard disk in your computer 
are compatible. Also, make sure they are capable of the configuration specified in the 
Enhanced control panel (the 386 icon, typically in the Main program group of the Program 
Manager).
Swap files

Permanent swap files generally improve the performance of enhanced-mode applications 
such as Capture. Like any file, though, swap files can be damaged, or "corrupted." 
Windows may not readily detect a damaged swap file.
If you suspect the swap file on your system may be damaged, follow these steps to delete
it and create a new swap file:
1 In the Enhanced control Panel, choose the Virtual Memory button and then choose the 

Change button.
2 In the New Swapfile Settings area, set Type to None and then choose the OK button.
3 Choose the Restart Windows button.
4 After Windows restarts, open the Enhanced control panel again.
5 Repeat steps 1 through 3, setting Type to Permanent (at step 2).
Duplicate filenames

The files THREED.VBX and VBRUN300.DLL are included with many Windows applications, 
including Capture's tutorial, and you may have different versions in several local or 
network directories. Some applications require a specific version of one or both of these 
files, even though that version is outdated.
Once you've run an application that uses one of these files, the file remains in memory. 
Running another application that uses a different version of the file doesn't replace the 
version in memory.
You may have to restart Windows and run the application before any other that uses 
THREED.VBX or VBRUN300.DLL, then restart Windows again before you run an application
that requires a different version.
You can get a list of all the copies of these files in the Program Manager or at the DOS 
command prompt. See your DOS or Windows documentation for more information. The 
following directories are typical locations of .VBX and .DLL files:

The directory that contains the executable
The WINDOWS directory
The WINDOWS\SYSTEM directory
Directories named in the PATH environment variable, typically defined in the 

AUTOEXEC.BAT file in the root directory (\) of your computer's start-up disk

Related topics
GROWSTUB error
"Cannot expand PATH" message
Increasing environment space for non-Windows applications



Common questions



Q How can I help prevent system crashes?

A If you use Windows for Workgroups v3.11, add the following line to the [386Enh] section 
of the file SYSTEM.INI in the \WINDOWS directory:

MaxBPS=768

Related topic
Common questions



Q Why am I getting a GROWSTUB error when I run Capture?

A This problem is caused by a bug in GROWSTUB, which is part of the Microsoft mouse 
driver. Version 9.01b of the driver corrects this problem. It's available from Microsoft.
You can correct this problem by any of the following methods:

Replace the driver with version 9.01b of the file POINTER.DLL from Microsoft.
or

Switch to a different mouse driver.
or
1 Exit all applications.
2 Open the file WIN.INI in the \WINDOWS directory, and find the load= line.
3 Remove POINTER.EXE from the line.
4 Save WIN.INI in text format.
5 Restart both Windows and Capture.

Related topic
Common questions



Q Why am I getting a Win32s error saying library initialization failed?

A If you're installing Capture under a non-English version of Windows, this error is caused by
a bug in version 1.20 of WIN32S.EXE. If you are using version 1.20, contact Microsoft and 
request version 1.25. You can find out which version of WIN32S.EXE you're using by one of
the following methods:

WIN32S.INI file
Open the WIN32S.INI file in the WINDOWS\SYSTEM directory. The version number appears in 
the [Win32s] section of the .INI file.

Windows for Workgroups
In the File Manager, select the WIN32S16.DLL file in the WINDOWS\SYSTEM directory; then 
from the File menu, choose Properties. The Version entry shows the major version and the 
build number (m.mm.bbb.b).

Other Windows versions
In the WINDOWS\SYSTEM directory, open the WIN32S.INI file in any text editor. The Version 
line shows the major version and the build number (m.mm.bbb.b). This line should be 
updated by any application that installs WIN32S.EXE on your system. However, it is up to 
application vendors to update this value when installing WIN32S.EXE, so the value may not 
be accurate.
If you install version 1.25 of WIN32S.EXE and you still see the error message, you may have 
an outdated version of the file COMPOBJ.DLL. Check the WINDOWS directory---if you find the 
file, rename it and restart Windows.

Related topic
Common questions



Q After I installed Capture and restarted my computer, I got the following 
message:

There is no room to expand the PATH environment variable with the 
mapping:

"INS S1:=ORCAD\SYS:\PUBLIC"
What should I do?

A You do not have enough memory allocated for environment variables. You need to modify 
or add the SHELL command in your CONFIG.SYS file to instruct the system to allocate 
more. CONFIG.SYS is located in the root directory (\) of your computer's start-up disk.
1 Open the CONFIG.SYS file in a text editor, and find or add the SHELL command. Make 

sure it looks like this:
SHELL=COMMAND.COM /p /e:n

/p causes COMMAND.COM to run AUTOEXEC.BAT and remain loaded.
/e: specifies the number of bytes to allocate to the environment space.
n is a decimal integer in the range 160--32768. Between 700 and 800 bytes is usually 
plenty.
For more information about the SHELL command, see your Windows or DOS 
documentation.

2 Save the file in text format.
3 Restart your system and start Capture.

Related topics
"Out of memory" message
Increasing environment space for non-Windows applications
"TEMP not found" message
Common questions



Q How do I set up Capture to run over a network?

A Setting up Capture for network use involves two steps:
The network administrator must install the full version of Capture on a network drive.
Each network user must install the network-user version of Capture on a local drive.
The easiest method is to use the Capture installation program. You can also set up 

your system to run Capture over the network by following these steps:
1 Create a directory on a local drive where you have write access.
2 In the Program Manager, create a program group called OrCAD Design Desktop. See 

your Windows documentation for more information.
3 Add three program items to the OrCAD Design Desktop group, as described in the 

following table. See your Windows documentation for more information.

Description Command line Working directory
Capture netPath\CAPTURE.EXE -I localPath netPath
Capture Help netPath\CAPTURE.HLP netPath
Capture Tutorial netPath\TUTORIAL\CAPTUTOR.EXE -I localPath netPath\TUTORIAL

Notes
netPath is the full path of the Capture directory on your network. For example:

Z:\PUBLIC\TOOLS\EDA\ORCADWIN\CAPTURE
localPath is the full path to a local directory where you have write access. It is the 
directory you created in step 1. For example:

C:\ORCADWIN\CAPTURE
Neither netPath nor locPath may include a trailing backslash (\).

Related topic
Common questions



If you wish to run Capture over a network without creating a program group, use the Run 
command from the Program Manager's File menu, and enter the appropriate command line,
as shown in the table.



Q How can I free memory so I can run more applications with Capture?

A Just save your work. Capture removes any closed schematic pages from memory, making 
more memory available to other applications.

Related topics
"Out of memory" message
Increasing environment space for non-Windows applications
Common questions



Q How can I increase the amount of environment space available to non-Windows 
applications?

A Add the following line to the [NonWindowsApp] section of the file SYSTEM.INI in the \
WINDOWS directory:

CommandEnvSize=1024

Related topics
"Out of memory" message
"Cannot expand PATH" message
Common questions



Q Why do my libraries take so long to load?

A Library size is limited only by the amount of space on your system's hard disk; however 
large libraries take longer to load. If speed becomes an issue, consider creating several 
smaller libraries, instead.

Related topic
Common questions



Q When I try to open an SDT 386+ schematic, I get the following messages:
Window's TEMP environment variable not found.
Capture temp files created at design's directory.

What should I do?

A You may not have a TEMP environment variable defined, or it points to the wrong 
directory. You need to modify or add the SET TEMP command in your AUTOEXEC.BAT file 
to instruct Windows where to create temporary files. AUTOEXEC.BAT is located in the root 
directory (\) of your computer's start-up disk.
1 Open the AUTOEXEC.BAT file in a text editor, and find or add the SET TEMP command. 

Make sure it looks like this:
SET TEMP=C:\WINDOWS\TEMP

If you run Windows from a different drive, change C to the appropriate drive letter.
2 Save the file in text format.
3 Restart your system and start Capture.

Related topics
"Out of memory" message
"Cannot expand PATH" message
Increasing environment space for non-Windows applications
Common questions



Q Why don't my schematic pages show up in the design manager when I save my 
design?

A You are running Windows 3.1 and WIN32S.EXE without running SHARE.EXE. Add the 
following line to your AUTOEXEC.BAT file:

C:\DOS\SHARE.EXE
If you are running Windows for Workgroups, this line is not necessary.

Related topic
Common questions



Q How can I restore the original settings in the Preferences and Design Template 
dialog boxes?

A Quit Capture and delete the CAPTURE.INI file. Depending on your access to various 
directories, CAPTURE.INI may be located in the \WINDOWS directory, the directory that 
contains CAPTURE.EXE, or the directory you specified during installation. When you run 
Capture again, a new CAPTURE.INI file is created with the original settings.
This has no effect on designs and libraries you've already created. Use the Design 
Properties, Schematic Page Properties, Part Properties, and Package Properties commands
to change the settings for existing designs and libraries.

Related topic
Common questions



Q Update Part References worked fine once, but when I used it again, nothing 
happened. What went wrong?

A Normally, Capture updates part references incrementally; that is, it updates only those 
parts with a question mark (?) in the Part Reference property. If none of the parts has a 
question mark in the Part Reference property when you use Update Part References, 
nothing changes. If you really want to update all the part references, regardless of their 
current values, be sure to select the Unconditional reference update option.

Related topic
Common questions



Q I receive an error message about a failed initialization of dynamic linked 
libraries while trying to run Capture. The message says one or more 
components is old. How can I update these files?

A This error is not caused by Capture, but by a file not being replaced when the Win32s 
installation proceeds. Follow these steps to correct the problem:
1 Place the Win32s installation disk in drive A.
2 Search for the files in the following table, and delete them from every directory except 

C:\WINDOWS\SYSTEM.

File File size
COMPOBJ.DLL 109056
OLE2.DLL 304640
OLE2CONV.DLL 57328
OLE2DISP.DLL 163408
OLE2NLS.DLL 124512
OLE2PROX.DLL 51712
STDOLE.TLB 5472
STORAGE.DLL 157696
TYPELIB.DLL 177744

3 In the C:\WINDOWS\SYSTEM directory, rename all the files listed in the table with 
a .DLL file externsion to a .125 file extension.

4 Rename STDOLE.TLB to STDOLE.125.
5 Exit Windows.
6 At the DOS prompt, enter the following line:

EXPAND A:\OLE2.DL_
7 DOS will prompt you for the destination and file name for the file. Enter the following 

line:
C:\WINDOWS\SYSTEM\OLE2.DLL

8 Repeat steps 5 and 6 for the remaining files in the table.
9 Compare the file sizes of the files listed in the table with those in the C:\WINDOWS\

SYSTEM directory. The sizes should be the same. If they are not, repeat steps 5 and 6 
as necessary.

10Restart Windows.

Related topic
Common questions



Q How can I globally change the fonts in my design?

A Once a design is created, use the Design Properties command on the Options menu to 
change properties stored with a design. This includes informations such as fonts. Any text 
that has been individually altered from the default settings wont be affected by changing 
the text properties in the Design Properties dialog box.

Related topic
Common questions



It is a good idea to set up the Design Template the way you want all new designs to work 
before doing any design work. This will save you some time later on in the design process.



Q How do I get a pure black-and-white print with no dithering or gray-scale?

A You need to set up your printer driver to get a pure black-and-white print without 
dithering and gray-scale. See your driver documentation for more information. Generally 
speaking, you should follow these guidelines:

If the driver has an all colors to black option, choose it.
If the driver has a dithering radio button, choose None or Coarse.
If the driver has an intensity slider, slide it to the darkest setting.

If you change the driver settings from within Capture using the Print Setup command, the 
changes will remain until you quit Capture. If the changes are made from the Control 
Panel, they will become the defaults for all applications that use the driver.

Related topics
Common questions
Plotter pen colors
Print preview
Printing and plotting
Printing or plotting one schematic page
Scaling a print or plot
Special considerations for plotting
Print To File dialog box
Print Preview command
Print command
Print Setup command



Q I've lost the color to my jumps and pop-ups in my help files. How can I get them
back?

A Some video drivers only support jump and pop-up colors while running Windows at color 
depths of 256 or less. Try configuring your video driver to a 256 color depth (or less). If 
this doesn't work, try a different video driver.

Related topic
Common questions



Q How can I prevent Win32s errors while translating SDT libraries into Capture?

A This error will occur if your SDT library has pins without pin names. Follow these steps to 
correct this problem:
1 Decompile the SDT library.
2 In an ASCII text editor, search for two single quotes.
3 Add an appropriate pin name.
4 Recompile the library.
5 Repeat steps 2 through 4 until all cases have been corrected.
or

Correct the problem in LIBEDIT.

Related topic
Common questions



Q How can I prevent Capture from freezing or hanging up in the middle of 
translating an SDT library?

A This problem occurs when Capture encounters a library part whose vectors are only a 
reference to another part. While Capture searches through the library's parts for the 
referenced vectors, it stops translating if it encounters a power symbol. Use one of the 
following solutions to fix your problem:

Transfer the power symbol parts to their own library, and remove them from the 
original library. This solution may be preferable if there is only one power symbol and many 
parts pointing to vectors for other parts.

Substitute the actual vector commands for their reference. This solution may be 
preferable if there are many power symbols but only one vector reference.

Related topic
Common questions



Q How can I prevent errors due to off-page connectors that send bus signals 
across schematic pages?

A You can fix the problem by doing one of the following steps:
Replace the off-page connector with a hierarchical port. The hierarchical port will 

function exactly the same as the off-page connector should.
or

Use bus entries to break the bus down into individual signals between the off-page 
connectors and the bus. You will need to add one or more off-page connectors, one for each 
signal in the bus.

Related topic
Common questions



Q Why doesn't Capture plot text correctly?

A Capture uses the plotter driver's internal font if the font is Courier New or a non TrueType 
font. The plotter doesn't print these fonts when rotated, but Capture allows you to rotate 
Courier New. If you want to plot schematics containing rotated text with Courier New 
fonts, you need to get either a large-format laser printer, a raster-plotter, or a third party 
pen plotter driver.

Related topic
Common questions



Q Why doesn't Capture create the same timestamps as SDT?

A SDT uses the oldest timestamp for the part or parts on the root sheet instead of using the 
oldest timestamp in the entire package. Capture, on the other hand, uses the oldest 
timestamp in the entire package. If you want SDT to behave like Capture, create a root 
sheet that simply points to the original root sheet.

Related topic
Common questions



Q Capture says that my design has duplicate references to a part, but I don't see 
any. What is the problem?

A This problem can occur if you are using a flat netlist formatter, such as Tango, while in 
logical view. Flat netlist formatters use physical view to generate netlists. If you check 
your physical view, you will likely see the duplicate references Capture has reported.
To avoid this problem, remove duplicate references in both logical and physical view 
before generating a netlist.



Q How can I get Capture to translate my thick wires from SDT?

A Capture uses one size for wires, and one size for buses. Delete the "thick" wires from your
translated designs, and use either the wire tool or bus tool as appropriate.

Related topic
Common questions



Q How can I save a design or translated design without a system generated 
name?

A This problem arises when the path and filename you assign exceeds 21 characters. Do 
one of the following to name the file as you need:

Go ahead and let Capture create a system generated filename. After the file is saved,
find the file using the Windows File Manager, and rename the document.

Save the file in a different directory where the filename and path combined is less 
than 21 characters. You can then use the File Manager to move the file to a different 
directory, if necessary.

Related topic
Common questions



About parts
Parts are the basic building blocks of a design. A part may represent one or more physical 
components; or it may represent a function, a simulation model, or a text description for use
by an external application. The part's behavior is described somehow, whether by a SPICE 
model, an attached schematic, HDL statements, or other means.
Parts usually correspond to physical objects---gates, chips, connectors, and so on---which 
come in packages of one or more parts. You can think of these packages as physical parts 
and the parts you place on a schematic page as logical parts. Physical parts that comprise 
more than one logical part are sometimes referred to as "multiple-part packages." For 
simplicity, Capture usually refers to both as "parts."
Each logical part has graphics, pins, and properties that describe it. As you place the logical 
parts in a package to suit your design requirements, Capture maintains the identity of the 
single physical part---the package---for back annotation, netlisting, bills of materials, and 
processes that require it. The logical part inherits this information from the physical package.
You specify physical packaging information when you create a part. You can also change it in
the part editor (from the View menu, choose Package; then, from the Options menu, choose 
Package Properties).
The logical parts in a package may have different pin assignments, graphics, and user 
properties. If all the logical parts in a package are identical except for the pin names and 
numbers, the package is homogeneous. If the logical parts in a package have different 
graphics, numbers of pins, or properties, the package is heterogeneous. For example, a hex 
inverter is homogeneous: the six inverters are identical, except for their pin numbers. A 
relay, which has a normally opened switch, a normally closed switch, and a coil, is 
heterogeneous: the three physical parts differ in graphics, number of pins, and properties.
When you place a part on a schematic page, you actually create an instance of the part. A 
part instance is like a "snapshot" of the part in the library; that is, it inherits all the 
properties of the library part. Once a part instance is on the schematic page, you can edit 
the properties of that instance without changing the properties of any other instance. The 
instance values of those properties supersede the values of any identical properties that 
exist on the library part.
When you look at a schematic page in physical view, you see occurrences of the part 
instances you placed in logical view. You can edit or add properties to part occurrences, and 
the occurrence values of those properties supersede the values of any identical properties 
that exist on the part instance.

Related topics
About the design cache
About part instances
About primitive and nonprimitive parts
About power and ground pins
Establishing connectivity between schematic pages



Don't confuse physical parts and logical parts with part occurrences and part instances. A 
physical part is a package, and a logical part is one device in that package. By contrast, a 
part instance is a part placed on a schematic page as seen in logical view, and a part 
occurrence is the same part on the schematic page as seen in physical view.



About the design cache
When you place the first instance of a part in a design, a copy of the part is created in the 
design cache. The design cache stores one copy of every part used in the design---you can 
think of it as an "embedded library." Normally, all instances of the part refer to this copy in 
the design cache.
A cache part also retains a link to the library part on which it is based, so you can update all 
of the parts in the design cache to synchronize them with the parts in the libraries. For more 
information see About part instances.
The design manager updates the display of the design cache every time you open the 
cache. Just click on the design cache icon in the design structure pane to close or open the 
design cache.

Related topics
About parts
About part instances
About primitive and nonprimitive parts
About power and ground pins



About part instances
A part instance is a part you have placed on a schematic page. You place part instances in 
logical view. If you change to physical view, you see occurrences of the part instances.
If you edit a part in a library, your changes don't affect instances of the part in any design 
until you want them to. You use the Update Cache or Replace Cache command to bring 
library changes into a design.
You can also edit part instances in the schematic page editor, by selecting a part instance 
and choosing the Part command from the Edit menu. Once you finish editing the part 
instance, you can apply the changes to every instance in the design or just the single 
(current) part instance.
If you update all instances of the part, the new part replaces the old in the design cache, and
the link with the original library is broken. If you update only the current part instance, you 
create a new part in the design cache, and the new part has no link to the original library. In 
either case:

The edited part doesn't exist in a library, so the only way to place a copy of it is to 
use the Copy and Paste commands on the schematic page editor's Edit menu.

It has no link with the original library, so it's not affected by the Update Cache 
command.

To restore its link with the original library, you must choose the Replace Cache 
command from the design manager's Design menu. For more information, see Replacing a 
part in a design.

Related topics
About parts
About the design cache
About primitive and nonprimitive parts
About power and ground pins



When you edit a part instance, its link with the original library is lost, and you create a new 
part in the design cache. This means that:

The edited part doesn't exist in a library, so the only way to place a copy of it is to 
use the Copy and Paste commands on the schematic page editor's Edit menu.

It has no link with the original library, so it's not affected by the Update Cache 
command.

To restore its link with the original library, you must choose the Replace Cache 
command from the design manager's Design menu. For more information, see Replacing a 
part in a design.



About primitive and nonprimitive parts
A part or hierarchical block may have an underlying hierarchical description, such as an 
attached schematic. If it does, it's called a nonprimitive. A part or hierarchical block that has 
no underlying hierarchical description is called a primitive. In Capture, this characteristic is 
defined in a property, called Primitive, on every part instance. You can change the Primitive 
property as often as you like during the design process. When a part or hierarchical block is 
marked as primitive, all of Capture's tools treat it as such. You cannot descend into a part or 
hierarchical block that is marked as primitive, even if it has an attached schematic.
For example, you might create a part and attach a schematic that describes its gates and 
wiring, and then attach schematics to some of those parts to describe their transistors. 
Before you create a netlist for simulation, you would specify those parts as nonprimitive, so 
Create Netlist can descend far enough to find the transistor-level descriptions. Before you 
create a netlist for board layout, you would specify the parts as primitive, so Create Netlist 
stops at the gate-level descriptions. Bill of Materials and Cross Reference work similarly.
For part instances that have their Primitive property set to Default, you can configure 
Capture to treat them as either primitive or nonprimitive on a design-wide basis, using the 
Design Template and Design Properties commands on the Options menu. This is useful when
you are describing and simulating your design at varying levels of abstraction (as in top-
down design).
 

Related topics
About parts
About part instances
About the design cache
About power and ground pins



If you attach a schematic to a homogeneous part, it is attached to each part in the 
package, not the package itself. You cannot attach a schematic to a heterogeneous part.



About shared pins
Both homogeneous and heterogeneous parts may have shared pins. A common use of 
shared pins is for supply (power or ground) pins, which are referred to in Capture as "power 
pins."
On heterogeneous parts, power pins may not appear on every part in the package. If the 
pins are visible, they must be placed on at least one part in the package, and that part must 
be placed in the design in order for the power connections to appear in the netlist.
On homogeneous parts, power pins appear on every part in the package. The pin names are 
filled in automatically, but you must set the pin numbers. For the pins to be shared, make 
sure that both the pin names and the numbers are the same for every part in the package.

 

Related topics
About power and ground pins
About the design cache
About parts
About part instances



If you place the same pin on multiple parts in the package, you can inadvertently short two 
nets. Use caution, and always run Design Rules Check before creating a netlist to avoid this
problem.



If you place the same pin on multiple parts in the package, you can inadvertently short two 
nets. Use caution, and always run Design Rules Check before creating a netlist to avoid this
problem.



Pin names are shared, but not pin numbers.



About power and ground pins
In Capture, power and ground supply pins are referred generically as "power pins." Normally,
power pins are invisible, and thus global---that is, they are connected to like-named power 
pins, power objects, and power nets throughout the design. If you create a part with visible 
power pins, or if you edit a part instance and set its power pins visible, the pins are not 
global. You must connect them to a net, using a hierarchical port, off-page connector, or 
power or ground object.
Capture can also display invisible power pins on individual part instances, or throughout a 
design. Merely displaying an invisible power pin does not change its global nature. But 
connecting a wire or other electrical object to an invisible power pin isolates it from the 
design-wide (global) net.
To display invisible power pins

Invisible power pins are always displayed in the part editor. The method by which you 
display invisible power pins in the schematic page editor determines whether you can 
connect wires and other electrical objects to them.

On a part instance: Select the part and then, from the Edit menu, choose 
Properties. Select the Power Pins Visible option, and choose OK.

If you connect a wire or other electrical object to a power pin made visible by this 
method, that pin is isolated from the design-wide power net.

Throughout a design: From the design manager's Options menu, choose Design 
Properties, and then choose the Miscellaneous tab. Select the Display Invisible Power Pins 
(for documentation purposes only) option, and choose OK.

You cannot connect to a power pin made visible by this method.
To make power pins visible

Any power pin you make visible by one of these methods is not global---you must connect 
that pin to a wire or other electrical object.

On a new part: From the Place menu, select Pin. Select the Pin Visible option, 
choose OK, and place the pin. For a pin already placed, select the pin, choose Properties 
from the Edit menu, select the Pin Visible option, and choose OK.

On a part instance: Select the part; then, from the Edit menu, choose Part. For 
each power pin you want to make visible, select the pin, choose Properties from the Edit 
menu, select the Pin Visible option, and choose OK. When you finish, close the part editor 
window, and choose whether to apply your changes to all instances of the part in this design
or only the selected (current) instance.

Related topics
Isolating power or ground
About shared pins
About parts
About part instances
About the design cache
About primitive and nonprimitive parts



About off-page connectors
Off-page connectors provide connection between schematic pages within the same 
schematic. An off-page connector is connected by name to other off-page connectors within 
the same schematic. Like-named off-page connectors in different schematics are not 
connected.
 

To connect schematic pages laterally (within the schematic)
1 From the Place menu, choose Off-Page Connector.
2 Select a symbol (standard or user-created), enter a name, and choose OK.
3 Place the symbol anywhere on the schematic page.
4 Repeat steps 1 through 3 for the other schematic pages (within the same schematic) you 

wish to connect.

Related topics
About hierarchical blocks
About hierarchical ports
Establishing connectivity between schematic pages



Free-standing hierarchical ports also connect schematic pages laterally---they are 
connected by name to off-page connectors and other free-standing hierarchical ports within
the same schematic.



About hierarchical blocks
A hierarchical block is a representation of a schematic, which is attached to the hierarchical 
block. It provides vertical (downward-pointing) connection only. The hierarchical ports in a 
hierarchical block act as points of attachment for electrical connections between the 
hierarchical block and other electrical objects in the attached schematic. A hierarchical block
functions just like a part with an attached schematic.

 
 
 
 

To connect schematics vertically
1 From the Place menu, choose Hierarchical Block.
2 Enter a name, and choose the Attach Schematic button.
3 Enter the name of the schematic to attach.
4 If the attached schematic is not in the current design, enter the path of the library or 

design that contains it.
5 Choose the OK button twice to return to the schematic page editor.
6 Draw the hierarchical block symbol. Position the pointer at the upper left corner of your 

intended hierarchical block, press and hold the left mouse button while you move the 
pointer to the lower right corner. 

6 Place a hierarchical port inside the hierarchical block and another on the attached 
schematic (see About hierarchical ports for instructions).

Related topics
About off-page connectors
About hierarchical ports
Establishing connectivity between schematic pages



Be careful not to create recursion in your design. Capture cannot prevent recursion, and the
Design Rules Check command does not report it.

Recursion causes Capture to process infinitely as it tries to expand the design (when you 
switch to physical view, for example), resulting in the loss of any changes you've made to 
your design since it was last saved.



Be careful not to create recursion in your design. Capture cannot prevent recursion, and the
Design Rules Check command does not report it.

Recursion causes Capture to process infinitely as it tries to expand the design (when you 
switch to physical view, for example), resulting in the loss of any changes you've made to 
your design since it was last saved.



If you attach external schematics or other files to hierarchical blocks in a design or parts in 
a library, be sure to include the attachments when you pass the design or library to a board
fabrication house or to another engineer. Attached schematics and other files are not 
carried along automatically when you copy or move a part, schematic, or schematic page 
to another library, design, or schematic. Only the "pointers" to the attached schematics 
and files---that is, their names and the names of the designs or libraries that contain 
them---are carried along.

Attached files work much like their counterparts in email---they do not provide an 
alternative definition of the part (as do attached schematics).



If you attach external schematics or other files to hierarchical blocks in a design or parts in 
a library, be sure to include the attachments when you pass the design or library to a board
fabrication house or to another engineer. Attached schematics and other files are not 
carried along automatically when you copy or move a part, schematic, or schematic page 
to another library, design, or schematic. Only the "pointers" to the attached schematics 
and files---that is, their names and the names of the designs or libraries that contain 
them---are carried along.

Attached files work much like their counterparts in email---they do not provide an 
alternative definition of the part (as do attached schematics).



A part with an attached schematic functions exactly as described for hierarchical blocks, 
and pins on such a part function exactly as described for hierarchical ports within a 
hierarchical block. You can use the same attached schematic for either method of defining 
a hierarchy. The only difference between the two methods is that a part with an attached 
schematic is easier to reuse. See Creating a part for related information.

If you choose the Descend Hierarchy command on a nonprimitive part or hierarchical block,
and Capture cannot find the attached schematic, Capture creates a schematic in the active 
design.



Before you create or resize a hierarchical block, make sure the Snap to grid option is turned
on (from the schematic page editor's Options menu, choose Preferences). If the hierarchical
block is off grid, then hierarchical ports inside it are also off grid---even if you change the 
Snap to grid setting before you place them---and it may be difficult to connect to these off-
grid hierarchical ports.



When you attach a schematic to a part or hierarchical block, you can specify a full path and
filename in the Library text box. So, although you can specify a library that hasn't been 
saved, you should not try to descend into the attached schematic until the library that 
contains the schematic has been saved.

If you don't specify a full path and filename in the Library text box, Capture expects to find 
the attached schematic in the same design as the part of hierarchical block to which it is 
attached. If the specified schematic doesn't exist in either the design or library, Capture 
creates the schematic when you descend hierarchy on the part or hierarchical block.

For compatibility with future versions of Windows, Capture preserves the case of the path 
and filename as you specify them in the Library text box.



About hierarchical ports
Hierarchical ports provide connection between schematics and between schematic pages.
Inside a hierarchical block, a hierarchical port provides vertical (downward-pointing) 
connection only. It is connected by name to hierarchical ports on schematic pages within the
attached schematic. You can think of its function as bringing a net "up" from the attached 
schematic into the hierarchical block (but not out onto the schematic page).
Outside a hierarchical block, a hierarchical port provides vertical (upward-pointing) and 
lateral connection. It's connected vertically to the like-named hierarchical port inside any 
hierarchical block to which it is attached. It's connected laterally to like-named nets, 
hierarchical ports, and off-page connectors within the same schematic. You can think of its 
function as carrying a net out of the schematic.

 
 
 
 
 

To connect pages vertically (through a hierarchical block)
If necessary, place the hierarchical block and attach the schematic (see About hierarchical 
blocks for instructions). Then complete these steps:

Bring the net into the hierarchical block:
1 Select the hierarchical block.
2 From the Place menu, choose Hierarchical Port.
3 Enter a name and choose OK.
4 Place the symbol within the boundaries of the selected hierarchical block.

This hierarchical port is downward-pointing---it is connected to any like-named 
hierarchical port on any schematic page in the attached schematic.

Carry the net up to the hierarchical block:
1 Open a schematic page contained in the schematic attached to the hierarchical block 

mentioned above.
2 Make sure no hierarchical block is selected.
3 From the Place menu, choose Hierarchical Port.
4 Select a symbol, enter the name used in step 3 of the preceding sequence, and choose 

OK.
5 Place the symbol anywhere (except inside a hierarchical block) on the schematic page.

This hierarchical port is upward-pointing---it is connected to any like-named hierarchical
port inside any hierarchical block to which it is attached.

6 If necessary, use off-page connectors to carry the net to other schematic pages in the 
same schematic (see About off-page connectors for instructions).

 

Related topics
About off-page connectors
About hierarchical blocks
Establishing connectivity between schematic pages



The Select Entire Net command is restricted to the active schematic page---it doesn't follow
hierarchical blocks, hierarchical ports, or off-page connectors across schematics or 
schematic pages. For more information, see Tracing a net.

Remember that nets on a schematic page are electrically connected by name, by alias, or 
by connection to a named hierarchical port or off-page connector.



You can use the copy and paste keyboard shortcuts (CTRL+C and CTRL+V) to enter the same 
name in the Name text field of both dialog boxes.



The next seven topics are driven by the Demo button on the Establishing connectivity 
between schematic pages topic.



This figure shows two schematics, A and B, with two schematic pages each. The schematic 
marked with a backslash (\) is called the root schematic. In this demonstration, you see how 
to create a simple hierarchy.



To establish the hierarchy with schematic A "above" schematic B:
1 Place a hierarchical block on schematic page 1.
2 Attach schematic B.



To carry a net between schematics A and B:
Select the hierarchical block on schematic page 1 and place a hierarchical port 

named X inside it.
This hierarchical port is like a pin---it is a point of attachment for electrical 

connections between the hierarchical block and other objects on schematic page 1.
Place another hierarchical port named X on schematic page 3.
This hierarchical port is a point of attachment for electrical connections between 

schematic page 3 and other schematic pages. It is connected by name to the hierarchical 
port inside the hierarchical block on schematic page 1.



Free-standing hierarchical ports generally carry a net "up" through a hierarchy. In the root 
schematic, they usually represent external signals such as physical connectors on a PC 
board.
Note that these free-standing hierarchical ports in schematic A are electrically connected by 
name, so any like-named electrical objects on schematic pages 1 and 2 are part of a single 
net named Y. You could make either one (but not both) of these hierarchical ports an off-
page connector without affecting the electrical connections.



To connect the schematic pages in schematic B, place an off-page connector named X on 
schematic page 4. Any like-named electrical objects on schematic pages 3 and 4 are part of 
a single net named X.



To connect the X and Y nets, it is not enough simply to rename one set of objects, as shown 
here. Again, the hierarchical port inside the hierarchical block on schematic page 1 is like a 
pin---it doesn't bring the "green" net X out of the hierarchical block and onto the schematic 
page.



When you physically connect any part of the "blue" net X to the hierarchical port inside the 
hierarchical block, the nets are joined.



Processing your design
The design process typically involves placing and connecting parts; specifying how they're to
be packaged; uniquely identifying them; adding information for simulation, synthesis, board 
layout, purchasing, or other external functions; and incorporating information from external 
functions.
Once you finish a first pass at placing and connecting parts, use the commands on the Tools 
menu in the design manager to complete the process. Click on the command names in the 
figure for information about the tool commands.
As shown in the figure, you use Update Part References, Design Rules Check, and Cross 
Reference to package the parts in your design and make sure there are no unconnected 
parts, unwanted connections, or other invalid design conditions. In practice, you might run 
these tools several times before moving on to the next phase.
You can add properties or change their values at any point, and there are several ways to do 
this. If you want to change the value of one or two properties, just edit them on the 
schematic page. To edit properties on many parts at the same time, use Update Properties 
or Capture's built-in spreadsheet editor (from the Edit menu, choose Browse and then Parts).
If you're more comfortable editing in a full-featured spreadsheet or database program, use 
Export Properties to write design data out and Import Properties to read the changes back in.
Once you're satisfied with your design, use Create Netlist to create a netlist in any of the 
formats supported by Capture. This is often the point at which you use Bill of Materials to 
create a list of parts used in the design or Extract PLD to create device files for use with 
OrCAD's PLD 386+.
Use Gate and Pin Swap to incorporate any packaging changes necessary because of routing 
or manufacturing constraints. You may need to add or modify properties again or make other
changes in the design, as shown in the figure.

Related topics
Assigning unique part references
Back annotating a schematic
Updating part or net properties
Update Properties sample report file
Checking design rules
Design Rules Check sample report file
Creating a cross reference report
Cross Reference sample report file
Creating a bill of materials
Bill of Materials sample report file
Extracting PLD code from a design
Extract; PLD sample .PLD file
Importing part and pin properties
Exporting part and pin properties
Choosing between views
Working in both views
Creating a netlist
About netlist format, view, and design structure





Update Part References
Packages parts by resolving part references and pin numbers, or removes packaging 
information by resetting part references to their unassigned values.



Gate and Pin Swap
Swaps pins or gates, or changes part references and packaging, based on a swap file your 
board layout program or you create.



Update Properties
Adds properties, or changes the values of properties, based on an update file you create.



Design Rules Check
Reports and flags violations of electrical rules and other design constraints, including 
identical part references, unconnected electrical objects, part type mismatches, off-grid 
parts, and more; starts by removing existing DRC markers.



Create Netlist
Creates a netlist in your choice of more than thirty standard formats.



Cross Reference
Reports the schematic page and location of every part, for use in developing or 
documenting the design.



Bill of Materials
Creates a formatted list of electrical and other parts in the design; optionally adds 
information, based on an include file you create.



Extract PLD
Creates a source file---for use with OrCAD's PLD 386+---for each programmable logic device
in the design, based on text descriptions placed on the schematic page; optionally creates 
a list of the source files created.



Export Properties
Creates a tab-delimited list---for manipulation in a spreadsheet or database program---of 
properties and values for every part you select in the design or library.



Import Properties
Adds properties, or changes the values of properties, based on a tab-delimited list in the 
format created by the Export Properties command.



Choosing between logical and physical view
In logical view, you see only one instance of each schematic in your design; in physical view,
you see every occurrence of those schematics and their relationship to one another. The 
effect of a processing command such as Update Part References or Create Netlist reflects 
the view---logical or physical---that's active when you choose the command from the Tools 
menu. In other words, the command processes what's visible in the design manager.
With a flat design or a simple hierarchical design, it may not matter which view is active, 
because there's only one occurrence of each schematic, and they're all visible in either view.
With a complex hierarchy, though, most of the tools produce different results in different 
views.
Here are some guidelines:

If you use one tool in a given view, use all the tools you need in that same view.
Back annotate a complex hierarchical design in physical view only.
Run Update Part References in the current view, and run it again if you change views.
If you work in both views, use Gate and Pin Swap in physical view only.

For example, consider a complex hierarchy in which you place a part at three locations in 
one schematic and use the schematic twice in your design. In physical view, the tools 
recognize and act upon all six occurrences of the part; but in logical view, they see only the 
three instances in the one visible instance of the schematic. If the parts are packaged in 
fours, then a bill of materials produced in physical view shows you need two packages, but a
bill of materials produced in logical view shows you need only one.
Likewise, Cross Reference documents only the three instances of the part in logical view, but
all six occurrences in physical view. The same is true for most of the other tools.

Related topics
Working in both views
Switching between logical and physical view
Processing your design
About netlist format, view, and design structure



Extract PLD would produce the same information in either view. To reduce confusion, this 
command is available only in logical view.

For libraries, only the Update Properties, Export Properties, and Import Properties 
commands are available. The concept of view does not apply to libraries, and the 
commands on the View menu are unavailable.



Working in both logical and physical view
You will probably find that you do most of your design processing in one view or the other. 
Some designs lend themselves to a complex hierarchy, others do not. Also, people think of 
similar designs in different ways. But there are some situations in which you might want to 
work on a single design in both views.
Consider a circuit board you design as a complex hierarchy. You must be in physical view 
when you create a netlist for the board layout program. But most simulators accept complex
hierarchies, so you can create a simulation netlist in logical view. Here's how you might use 
this technique.
Capture your design and update part references in logical view. Create a netlist in VHDL, 
Verilog, or EDIF 2 0 0 format to send to a simulator. Use the simulation results to refine the 
logic of your design. When you are satisfied with the basic logic, switch to physical view.
In physical view, update part references again---you must have unique part references 
before you go on. Next, create another netlist in PCB, OHDL, or one of the other flat netlist 
formats to send to your board layout program. After the board is laid out and routed, use 
Gate and Pin Swap and Update Properties to modify parts and pins and to add timing 
information.
Still in physical view, create a new netlist in VHDL, Verilog, or EDIF 2 0 0 format to send back
to the simulator. On this pass, the simulator tests the timing of the final board as well as the 
basic design logic.

Related topics
Processing your design
Choosing between logical and physical view
Switching between logical and physical view
About netlist format, view, and design structure



Logical view and physical view
You can look at the schematics of a design in one of two views. In logical view, each unique 
schematic of the design appears once, but the relationship among the schematics is not 
shown. Physical view shows every occurrence of every schematic and shows their 
hierarchical relationship.
For example, a filter circuit might have four applications within your design. In Capture, you 
can represent the filter circuit schematic as a hierarchical block at four locations in the 
design. The four hierarchical blocks point to a single schematic, but the filter will be present 
in four locations when the product is manufactured. In logical view, Capture shows the filter 
schematic once; in physical view, you see all four occurrences of the filter schematic.
The view you select affects the schematic page editor. For example, you might, while looking
at three occurrences of a schematic page in physical view, activate the design manager 
window and select the logical view. The three schematic page editor windows close, and the 
schematic page editor opens one logical view of the page in their place.
If you want to change the filter circuit to affect all four locations, you use logical view. To 
change the filter circuit at one location, you use physical view. You can edit or add properties
in either view, but you can edit net names or pins only in physical view and you have access 
to the tool palette only in logical view.
To switch between logical view and physical view
1 Activate the design manager window.
2 From the View menu, select Logical (ALT, V, L) or Physical (ALT, V, P).

Related topics
Choosing between logical and physical view
Logical View command
Physical View command
About netlist format, view, and design structure



About netlist format, view, and design structure
Netlist output is affected by the structure of your design (flat or hierarchical), the active view
(logical or physical), and the netlist format you choose, as shown in the table. For one job, 
you might structure the design for compatibility with a required netlist format; for another 
job, you might choose a netlist format that can handle the design's inherent structure; for 
another job, you might switch between logical and physical view, creating different netlists 
for different parts of the process.

EDIF 2 0 0, SPICE, VHDL, 
Verilog, and VST tabs

PCB, OHDL, Layout, and 
Other tabs

Design structure Logical or physical view Logical or physical view
Flat Flat netlist Flat netlist
Hierarchical Hierarchical netlist Flat netlist

Keep these general points in mind as you weigh your options:
The EDIF 2 0 0, SPICE, VHDL, Verilog, and VST formats create netlists that have the 

same structure as the design, regardless of the active view.
The PCB, PLD, Layout, and other formats create flat netlists only, regardless of the 

active view. If the design is hierarchical, the netlist reflects the design in physical view, even 
if the netlist is generated in logical view.

Related topics
Create Netlist dialog box
Choosing between views
Working in both views
Processing your design



About title blocks
There are two types of title blocks: default and optional. Capture places one default title 
block---which you specify on the Title Block tab in the Design Template dialog box---in the 
lower right corner of each schematic page. You may place any number of optional title 
blocks anywhere on the schematic page, using the Title Block command on the Place menu.
The default title block displays information found in the design template; the same 
information is included in reports created by the command on the Tools menu. Optional title 
blocks display information that you define in the library as property values for the title block 
symbol.
Not all of the avaliable default title blocks provide the same information. For Example, 
TitleBlock0 doesn't provide any fields for the organization name and address, while 
TitleBlock5 provides all five organization name and address fields. You must specify which 
title block you want for the default in the Design Template.
Designs translated from SDT use a title block that most closely matches the information 
contained in the SDT title block.
The properties that define the default title block fields are as follows:

Doc. Specifies the document number.
RevCode. Specifies the revision.
CAGE Code. Specifies the Cage Code.
Title. Specifies the title.
OrgName. Specifies the organization name.
OrgAddr1. Specifies the first line of the organization's address.
OrgAddr2. Specifies the second line of the organization's address.
OrgAddr3. Specifies the third line of the organization's address.
OrgAddr4. Specifies the fourth line of the organization's address.

You can set the default title block to be visible or invisible either on a specific schematic 
page (on the Grid Reference tab in the Design Template dialog box) or across the entire 
design (on the Grid References tab in the Schematic Page Properties dialog box).
Capture provides default title block symbols in the CAPSYM.OLB library. You may also create 
custom title block symbols and store them in a library. The following figure shows one of the 
default title blocks in CAPSYM.OLB.

Related topics
Editing title block information
Controlling title block or grid reference visibility
Setting up the default title block
Creating a custom title block
Defining schematic page characteristics
Placing multiple title or revision blocks
Title Block command



About bus connections
A bus is a group of scalar signals (wires), and is never connected to a net. Once the bus 
acquires a valid name or alias, then that name or alias defines the signals carried by the bus
and connects those signals to the corresponding nets. For example, the alias A[0:3] defines 
a four-signal bus and connects the four signals it carries---A[0], A[1], A[2], and A[3]---with 
nets A0, A1, A2, and A3.
Like wires, buses can acquire names and aliases by two means:

Direct application of a valid bus name
Electrical connection to a hierarchical port, off-page connector, or global bus pin with 

a valid bus name or alias
In addition to the usual rules by which netnames are resolved, bus names and aliases follow 
these general rules:

If one alias defines a subset of the signals defined by another, like-named signals are 
connected. For example:

Given aliases A[0..2] and A'[0..5]:
A[0] connects to A'[0], A[1] connects to A'[1], and A[2] connects to A'[2].

If the base names differ, or if neither alias defines a subset of the signals defined by 
the other, signals are connected in a bitwise manner (m to m,. . . , n to n). For example:

Given aliases A[0..2] and A'[1..3]:
A[0] connects to A'[1], A[1] connects to A'[2], and A[2] connects to A'[3].

Given aliases A[0..2] and B[5..0]:
A[0] connects to B[5], A[1] connects to B[4], and A[2] connects to B[3].

Related topics
Netname resolution
Establishing bus connectivity
Establishing wire connectivity



You can place one pin on a part that represents all the pins for a bus. Such a pin is called a 
bus pin. Bus pins use the same naming convention as buses.



Bus names and aliases have the form X[m..n].
X represents the "base name" (how you think of the bus, perhaps).
m..nrepresents the range of signals carried by the bus.
Note that m may be less than or greater than n. In other words, both A[0..3] and 

A[3..0] are valid bus aliases. You can use two periods (..), a colon (:), or a dash (-) to 
separate m and n.

Note that Capture ignores any spaces between the basename and the left bracket ([). For 
example, ADDR[0..31], ADDR [0:31], and ADDR  [0-31] represent the same bus.



As you place buses and wires, remember the following points:
A bus and a wire can be connected only by name.
If you begin or end a bus segment on a segment of a wire, a vertex is added to the 

wire, but no junction displays---the bus and wire are not connected.
If you begin or end a wire segment on a segment of a bus, a vertex is added to the 

bus, but no junction displays---the wire and bus are not connected.
Two buses or two wires can be connected physically.
If you begin or end a bus segment on a segment of another bus, a vertex is added to 

the second bus, and a junction displays---the buses are connected (as described in About 
bus connections).

If you begin or end a wire segment on a segment of another wire, a vertex is added to 
the second wire, and a junction displays---the wires are connected.



As you place buses and wires, remember the following points:
A bus and a wire can be connected only by name.
If you begin or end a bus segment on a segment of a wire, a vertex is added to the 

wire, but no junction displays---the bus and wire are not connected.
If you begin or end a wire segment on a segment of a bus, a vertex is added to the 

bus, but no junction displays---the wire and bus are not connected.
Two buses or two wires can be connected physically.
If you begin or end a bus segment on a segment of another bus, a vertex is added to 

the second bus, and a junction displays---the buses are connected (as described in About 
bus connections).

If you begin or end a wire segment on a segment of another wire, a vertex is added to 
the second wire, and a junction displays---the wires are connected.



Processes
Using Capture

Working with designs, schematics and schematic pages
Browsing a design or a library
Configuring Capture
Processing your design
Working with multiple windows
Printing and plotting
Displaying your registration number
Using the session log
Shortcuts

Working with schematic pages
Using the schematic page editor
Opening a schematic page
Defining schematic page characteristics
Using the schematic page editor
Choosing between logical and physical view
Working in both logical and physical view
Saving schematic changes
Establishing connectivity between schematic pages

Working with parts and libraries
Using the part editor
Opening a library
Working with libraries
Searching for a part in the libraries
Updating part properties in a library
Opening a library created in SDT
Editing a part on a schematic page
Editing library parts
Editing a part as you place it
Creating a part
Creating multiple-part packages
Creating a part convert
Saving library changes
Saving part changes
Switching to a different open part

Actions common to both editors
Selecting and deselecting objects
Moving objects
Mirroring objects
Rotating objects
Copying selected objects
Deleting objects
Undoing and repeating actions
Searching a design
Undoing and repeating actions
Working with graphics, text, and bitmaps
Working with properties
Editing properties
Replacing user-defined properties
Changing your view



Using Capture with other OrCAD Design Desktop applications
Using Capture with FPGA vendor interface kits 
Enabling ITC capabilities for Capture and Simulate 
Displaying simulation states on your Capture schematic 
Selecting signals for display from a Capture schematic 
Enabling ITC capabilities for Capture and Layout 
Cross probing between Capture and Layout 
Moving designs between Capture and Layout 
AutoECO 



Opening a schematic page
To open an existing schematic page
1 Open the design that contains the schematic page, as described in Opening an existing 

Capture design.
2 In the design structure pane of the design manager, double-click on the schematic to 

display the schematic pages.
3 In the design structure pane of the design manager, double-click on the schematic page. 

The schematic page opens in the schematic page editor.
To create a schematic page
1 In the design manager, select the schematic to which the new page belongs.
2 From the Design menu, choose the New Schematic Page command (ALT, D, P).

Related topics
Opening several schematic pages at once
Switching to a different open schematic page
Creating a schematic or schematic page in an existing design
Creating a multiple-page schematic
Defining schematic page characteristics
Creating a custom title block
Opening a schematic created in SDT
New Schematic command
New Schematic Page command



Opening several schematic pages at once
The only limit to the number of schematic pages you may have open is the resources 
available to your computer. When you open an existing schematic page, it initially occupies 
a single window. A new design occupies two windows initially.

For each page you wish to open, follow the instructions for Opening a schematic 
page.

Related topics
Opening a schematic page
Switching to a different open schematic page
1, 2, . . . command



Switching to a different open schematic page
Click anywhere on the schematic page editor window that holds the schematic page.

or
Choose the name of the schematic page from the Window menu (ALT, W, n).

or
Double-click on the page in the design manager.

Related topic
1, 2, . . . command



Saving schematic page changes
Changes you make to a schematic page are temporary until you save the page or the design
to disk using one of the commands of the File menu. If you save one schematic page, only 
the changes to that page are saved; if you save a design while you have several pages open
in schematic page editor windows, changes you have made to any of them are saved, as 
well as any changes made by the Capture tools.
To save one schematic page

From the File menu of the schematic page editor, choose the Save command 
(ALT, F, S). If the design is new and has not yet been saved, the Save As dialog box displays, 
giving you the opportunity to specify a drive and replace the system-generated name.
To save one design

From the File menu of the design manager , choose the Save command (ALT, F, S). If 
the design is new and has not yet been saved, the Save As dialog box displays, giving you 
the opportunity to specify a drive and replace the system-generated name.

Shortcut
Toolbar:

To save all open designs
From the File menu of the design manager, choose the Save All command (ALT, F, E). 

Open designs or libraries that have been modified are saved.
 

Related topics
Moving schematic pages between schematics
Moving schematics between designs
Moving schematic pages between designs
Copying a schematic to or from a library
Copying a schematic page to a library
Renaming a document
Save command
Save As command
Save All command



Moving schematic pages between schematics
You use schematics to organize a design, grouping schematic pages in ways that make the 
most sense for your purposes. If you change your mind, you can easily transfer schematic 
pages from one schematic to another. You can also place copies of pages in several 
schematics.
A schematic page that is open in an editor cannot be moved or copied.
To move schematic pages from one schematic to another
1 Verify that the pages are not open in the schematic page editor or the spreadsheet editor.
2 In the design manager, select the schematic pages you wish to move.
3 From the Edit menu, choose the Cut (ALT, E, T) command. If you wish to have a copy of the 

pages in both schematics, select the Copy (ALT, E, C) command.
4 Select the schematic that will hold the pages.
5 From the Edit menu, choose the Paste (ALT, E, P) command.
or
1 Verify that the pages are not open in the schematic page editor or the spreadsheet editor.
2 Select the schematic pages that you wish to move, then drag them to the appropriate 

schematic. If you wish to have a copy of the pages in both schematics, press and hold CTRL
while you are dragging.

Related topic
Renaming a document
Working with designs, schematics, and schematic pages
Tracing a net
Copying a schematic to or from a library
Copying a schematic page to a library
Copy command
Paste command



Creating a multiple-page schematic
1 From the Design menu of the design manager, choose New Schematic (ALT, D, S). The New 

Schematic dialog box displays.
2 Enter the name for the schematic and choose the OK button. The schematic name is 

listed in the design structure pane.
3 Select the new schematic and from the Design menu, choose New Schematic Page 

(ALT, D, P). The New Schematic Page dialog box displays
4 Enter the name for the schematic page and choose the OK button. The page name is 

listed below the schematic name.
5 Repeat steps 3 and 4 for each page of the schematic.
6 Place off-page connectors, hierarchical ports, and hierarchical blocks to establish 

connectivity between schematic pages.

Related topics
Renaming a document
Opening a schematic page
Establishing connectivity between schematic pages
New Schematic Page command
Off-Page Connector command
Hierarchical Block command
Hierarchical Port command



Defining schematic page characteristics
Using the design template, you can establish schematic page characteristics for an entire 
design; you can also override these defaults and establish characteristics for a particular 
schematic page using the Schematic Page Properties or Design Properties command.
Capture will create a schematic page size to suit your printer or plotter. You can choose from
five standard page sizes or specify a custom size.
The default title block symbol, default title block information, border, and grid references 
can all be established for each design. Title block visibility can be specified for the entire 
design or for each schematic page.
To define grid references for new designs and schematic pages
1 From the Options menu, choose the Design Template command (ALT, O, D), then choose the

Grid Reference tab.
2 Make selections for the horizontal and vertical grid references and then choose the OK 

button to dismiss the Design Template dialog box. Until you change the Grid Reference 
tab, any designs or schematic pages you create reflect these selections.

To change grid references for an existing page
1 Activate the schematic page editor for the schematic page.
2 From the Options menu, choose the Schematic Page Properties command (ALT, O, R), then 

choose the Grid Reference tab.
3 Make selections for the horizontal and vertical grid references and then choose the OK 

button to dismiss the Schematic Page Properties dialog box. The selections are reflected 
in the active schematic page.

To define schematic page size for new designs and schematic pages
1 From the Options menu, choose the Design Template command, then choose the Page 

Size tab.
2 Select Inches or Millimeters as your unit of measure.
3 Select a page size.

If you choose inches, the choices are A, B, C, D, E, and Custom.
If you choose millimeters, the choices are A4, A3, A2, A1, A0, and Custom.

4 Enter a value for pin-to-pin spacing, and choose the OK button to dismiss the Design 
Template dialog box. Until you change the Page Size tab, any designs or schematic pages 
you create reflect these selections.

Related topics
About title blocks
Opening a schematic page
Creating a schematic or schematic page in an existing design
Editing title block information
Configuring Capture
Printing and plotting
Setting up the default title block
Creating a custom title block
Controlling title block or grid reference visibility
Controlling grid display



Editing information in the default title block
You can use the Design Template command of the Options menu to specify information for 
the default title block. In addition, you can edit title block information in the schematic page 
editor.
To edit title block information
1 Select the information string that needs to change.
2 From the Edit menu, choose the Properties command (ALT, E, S).
3 In the dialog box that displays, replace the old information with the new and choose the 

OK button. The schematic page editor displays with the new information in the title block.
or
1 Select the title block, and choose Properties from the Edit menu.
2 Select the property you want to change.
3 Change the value of the property in the text box where the value appears, and then 

choose OK. The schematic page editor displays with the new information in the title block.
To change the display of title block information
1 Select the information string that needs to change.
2 From the Edit menu, choose the Properties command.
3 In the Display Properties dialog box, choose the Change button. The Fonts dialog box 

displays.
4 In the Fonts dialog box, change the display properties, and choose the OK button twice.

Shortcuts
Double-click on the information string to display the Display Properties dialog box, or 
double-click on the title block to display the User Properties display dialog box.

Related topics
About title block
Opening a schematic page
Creating a schematic or schematic page in an existing design
Configuring Capture
Printing and plotting
Creating a custom title block
Controlling title block visibility



Controlling title block or grid reference visibility
To specify default title block or grid reference visibility for new designs
1 From the schematic page editor's Options menu, choose the Design Template command 

(ALT, O, D), then choose the Grid Reference tab.
2 In the Grid References Visible or Title Block Visible group, click the left mouse button on 

the Displayed or Printed option to change the visibility.
To change title block or grid references visibility for one schematic page
1 From the schematic page editor's Options menu, choose the Schematic Page Properties 

command (ALT, O, R), then choose the Grid Reference tab.
2 In the Grid References Visible or Title Block Visible group, click the left mouse button on 

the Displayed or Printed option to change the visibility.
To specify grid reference width
1 From the schematic page editor's Options menu, choose the Schematic Page Properties 

command (ALT, O, R), then choose the Grid Reference tab.
2 In the Horizontal or Vertical group, enter the desired width (in inches or metric units) in 

the Width text box.

Related topics
Controlling grid display
Configuring Capture
About title block
Editing title block information
Defining schematic page characteristics



Controlling grid display
You can configure Capture to hide the grid or display it as dots or lines, and to constrain the 
pointer to the grid. Note that the grid size is defined by the pin-to-pin spacing preference.
To specify grid style and visibility
1 From the Options menu, choose the Preferences command (ALT, O, P), then choose the Grid 

Display tab.
2 Choose the grid style, and click the left mouse button on the Displayed or Printed option 

to change the visibility.
To change snap to grid
1 From the Options menu, choose the Preferences command (ALT, O, P), then choose the Grid 

Display tab.
2 Choose the grid style, and click the left mouse button on the Displayed or Printed option 

to change the visibility.

Related topics
Controlling title block and grid reference visibility
Configuring Capture
About title block
Editing title block information
Defining schematic page characteristics



Creating a custom title block
Capture provides ANSI, and OrCAD title blocks in the CAPSYM.OLB library. In addition, you 
can create your own title block and store it in a library for future use. There are two types of 
title blocks:

A default title block is placed by Capture at the lower right corner of each schematic 
page; information that you specify in the Title Block tab of the Design Template dialog box is 
incorporated into the title block fields. This information is also included in reports from 
Capture tools.

You can place any number of optional title blocks at any locations you choose. The 
text that displays is a result of visible properties that you define when you create the symbol
or after you place the title block.
When you make an optional title block, you create its graphic symbol, then define and place 
visible properties. When you make a new default title block, you create its graphic symbol, 
add one or more properties to define the information fields, then you provide the information
that will appear in the fields.
The properties that define the default title block fields are as follows:

Doc. Specifies the document number.
RevCode. Specifies the revision.
CAGE Code. Specifies the Cage Code.
Title. Specifies the title.
OrgName. Specifies the organization name.
OrgAddr1. Specifies the first line of the organization's address.
OrgAddr2. Specifies the second line of the organization's address.
OrgAddr3. Specifies the third line of the organization's address.
OrgAddr4. Specifies the fourth line of the organization's address.

To create a custom title block symbol
1 In the design manager, open the library in which you will store the title block symbol.
2 From the Design menu, choose the New Symbol command (ALT, D, L). The New Symbol 

dialog box opens.
3 Enter a name and select Title Block as the Symbol Type, then choose the OK button. The 

part editor opens with an empty part boundary box.
4 Use the graphics tools to create the title block. See Creating graphics. The part boundary 

box will stretch to accommodate your graphic objects.
To create fields that are automatically filled on a default title block
1 With the title block graphic symbol displayed in the part editor, double-click an area 

where there are no objects in order to display the User Properties dialog box.
2 Choose the New button. The New Property dialog box displays.
3 Enter one of the properties listed above in both the Name and Value text boxes, then 

choose the OK button to dismiss the New Property dialog box.
4 In the Properties dialog box, choose the Display button, then select the Visible option.
5 Choose the OK button to dismiss the Display Properties dialog box, then choose OK again 

to dismiss the User Properties dialog box. The part editor displays with the property 
representation visible.

6 Use the mouse to move the property representation to the appropriate location and click 
the left mouse button to place the representation. This property representation, which 
serves as a place holder, displays in the selection color.

7 Repeat steps 2 through 6 for each property of your title block.
8 Save the title block.



To provide information for the fields of a custom default title block
1 From the Options menu, choose the Design Template command (ALT, O, D), then choose the

Title Block tab.
2 For each of the nine properties listed above that you have added to your title block 

symbol, enter the text that will appear in your title block.
3 Enter the library name and the distinctive name of the title block.
4 Choose the OK button.
 

Related topics
About title blocks
Saving library changes
New Symbol command
Setting up the default title block
Editing title block information
Placing multiple title or revision blocks
Defining properties
Editing properties



Setting up the default title block
In Capture, each schematic page has a default title block in the lower right corner. Title block
information that you provide in the Design Template is written into the fields of the title 
block. You may choose the title block that Capture provides in the CAPSYM.OLB library or you
may create a custom title block.
Selections that you make following these instructions are reflected in schematic pages you 
create subsequently, but do not affect existing schematic pages.
To specify information for title block fields
1 From the Options menu, choose the Design Template command (ALT, O, D), then choose the

Title Block tab.
2 Enter the information for the nine fields that display. This information appears in the title 

block and in reports generated by the Capture tools.
To select a default title block symbol
1 From the Options menu, choose the Design Template command (ALT, O, D), and then 

choose the Title Block tab.
2 Specify a path and library.
3 Specify the name of the title block, maintaining the case of the original name.
4 Choose the OK button to dismiss the Design Template.
 

Related topics
About title block
Creating a custom title block
Editing title block information
Title Block command
Design Template command



If you are using CAPSYM.OLB and you have maintained the directory structure that OrCAD 
provides, you can leave the Library Name text box empty.



If Capture does not find a title block with the name you specify (the case of letters must 
match) in the library and path you specify, no default title block is placed.



Placing multiple title or revision blocks
Capture places a default title block at the lower right corner of every schematic page; in 
addition, you may place any number of optional title blocks at any location on the schematic
page. Optional title blocks, unlike default title blocks, do not include information from the 
design template, but you can define and place visible properties on the title block.
Information placed as properties in optional title blocks will not appear in reports or netlists 
created by Capture; only the information in the default title block will be used.
To place optional title blocks
1 From the Place menu, choose the Title Block command (ALT, P, K). The Place Title Block 

dialog box displays.
2 In the Symbol text box, enter the name---you can use the standard "*" and "?" wildcard 

characters. Capture scans the selected libraries and lists all symbols that match the name
or wildcard.

3 If the title block name is not listed, see Searching for a part in the libraries for further 
information.

4 Click on a title block name in the list for a preview, or double-click on it to place the title 
block. You can also select the title block name and choose the OK button to place the title 
block.

Related topics
About title blocks
Setting up the default title block
Editing title block information
Defining properties
Specifying text font and size
Moving and rotating text
Creating a custom title block



Using the schematic page editor

General concepts
Schematic page editor window
Selecting and deselecting objects
Moving objects
Mirroring objects
Rotating objects
Copying selected objects
Deleting objects
Undoing and repeating actions
Searching a design
Choosing between logical and physical view
Working in both logical and physical view
Editing properties
Changing your view
Working with graphics, text, and bitmaps
Printing and plotting

Parts
Placing a part instance 
Searching for a part in the libraries
Editing a part on a schematic page
Finding parts in a design
Replacing a part in a design
Editing a part on a schematic page
Editing a part as you place it

Wires, nets, busses, and electrical objects
Placing wires
Net operations
Placing busses
Connecting to power or ground
Establishing connectivity between schematic pages
Isolating power or ground
About power and ground pins
Editing wires and busses
Tracing a net



Editing wires and busses
To move a segment
1 Select the segment.
2 Drag the segment to the new location. The wire or bus stretches to maintain connectivity.
To move a vertex
1 Select a wire segment next to the vertex.
2 Drag the vertex to the new location. The wire or bus adds segments and vertices to itself 

as needed to reach the new location.
To break connectivity while moving a wire or bus
1 Select the wire or bus.
2 Press ALT while you move the wire or bus.
To delete a wire or bus
1 Using the selection tool, create a box around a portion of the wire.
2 Press the DELETE or BACKSPACE key.
To delete a segment
1 Select the segment.
2 Press the DELETE or BACKSPACE key.
To delete a net
1 Select one segment of the net.
2 Click the right mouse button. A popup menu displays.
3 From the popup menu, choose the Select Entire Net command.
4 Press the DELETE or BACKSPACE key.
To edit wire properties

Select the wire or bus, then from the Edit menu, choose the Properties command 
(ALT, E, S). The Net Properties dialog box displays.

Related topics
Placing wires
Selecting and deselecting objects
Editing properties
Moving objects
Mirroring objects
Rotating objects
Establishing wire connectivity
Net Properties dialog box



This method only deletes the segments and vertices of the wire or bus between its 
beginning and ending vertices. If multiple wires or busses connect through junctions, then 
only a portion of the net is deleted.



Connecting to power or ground
When you place a part that has power and ground pins, that part is automatically connected 
to like-named global power and ground nets of the schematic. If you need to isolate one 
power or ground pin from the others, you can assign it a unique netname.
To place power or ground symbols
1 From the Place menu, choose Power (ALT, P, P) or Ground (ALT, P, G). The Place Power Symbol

or Place Ground Symbol dialog box displays.
2 In the Place Power dialog box, select a power symbol and choose the OK button.

or
In the Place Ground dialog box, select a ground symbol and choose the OK button.

3 Use the mouse to move the symbol to the appropriate location and click the left mouse 
button. The symbol displays in the selection color.

4 Select the selection tool, or press ESC, to dismiss the power or ground tool.
5 Click an area where there are no parts or objects in order to deselect the symbol.

Shortcut
Tool palette:

To rotate power or ground symbols
1 Select the symbol.
2 From the Edit menu, choose the Rotate command (ALT, E, O). The symbol rotates 90 

degrees counterclockwise.
3 Repeat step 2 as necessary.
4 Click an area where there are no parts or objects in order to deselect the symbol.
To create a power or ground symbol
1 Open the library that is to hold the new symbol.
2 From the Design menu, choose the New Symbol command (ALT, D, L). The New Symbol 

dialog box displays.
3 Enter a name and select Power as the Symbol Type, then choose the OK button. The part 

editor opens with an empty part boundary box.
4 Use the graphics tools to create the symbol; the part boundary box dimensions change to 

accommodate the graphic elements. See Creating graphics.

Related topics
About power and ground pins
Power command
Ground command
New Symbol command
Isolating power or ground



Isolating power or ground
Power and ground pins are normally invisible, and thus global. This means that they are 
connected, on a design-wide basis, to all pins, power objects, and nets of the same name.
You can isolate a power or ground net in either of two ways: by making the pin visible, in 
which case you must create direct connections for the pin, or by displaying the pin and then 
connecting it to a net or power object.
For information on making power pins visible and on displaying invisible power pins, see 
About power and ground pins.
To isolate a power net to a schematic page

Place a power symbol and attach it to a hierarchical port.
To isolate a power net to a schematic

Place a power symbol and attach it to an off-page connector.
When Capture resolves netname conflicts, the name of the off-page connector takes 

precedence over the name of the power object, and the off-page connector's scope is limited
to the schematic. All pins on the same page that are connected by name or by wire to the 
power symbol are connected to the isolated power net.

For example, say you want to isolate your analog and digital grounds and then 
connect them at one point when you make a printed circuit board. You place your analog 
circuitry on a separate schematic. On each page in the analog schematic, you place a 
ground symbol with the name GND. This implicitly connects all the pins named GND to 
ground. Then you connect that power symbol to an off-page connector named AGND. To 
connect AGND to the digital ground (GND), you can create a part whose footprint is a strip of
copper with two pads, GND and AGND.

Related topics
Rules for resolving name conflicts in a netlist
About power and ground pins
Power command
Ground command



Placing busses
To create a bus
1 From the Place menu, choose Bus (ALT, P, B).
2 Click the left mouse button to start the bus.
3 Use the mouse to draw the bus.
4 Click the left mouse button to place a vertex and change directions. The vertex is 

constrained to a multiple of 90 degrees.
5 Double-click to end the bus.
6 Enter the net alias, following the naming conventions for busses, in the dialog box that 

displays, then choose the OK button. The bus displays in the selection color.
7 Select the selection tool to dismiss the bus tool or repeat from step 2 to place additional 

busses.
To place a nonorthogonal bus

Hold the SHIFT key while you draw the bus. There is no constraint on vertex angles.

Shortcut
Tool palette:

Related topics
Establishing bus connectivity
About bus connections
Labeling a net, bus, or bus member
Bus naming conventions



Establishing bus connectivity
In order to make connections to a bus, you label the bus, label the signals that are members 
of the bus, and assign an alias to each signal entering and leaving the bus. Each signal bears
an alias that is within the bus range. For example, if the bus alias is ADDR[0..3], the four bus
members must bear aliases ADDR0, ADDR1, ADDR2, and ADDR3.
In Capture, you can use an alias to connect a signal from one area of your schematic page to
another without placing a bus between the areas.
For example, suppose you have placed the bus TIMING[1..4] on your schematic page and 
you want to connect it to another object at the opposite corner of the schematic page. 
Instead of drawing a bus from TIMING[1..4] to the other object, you can assign the alias 
TIMING[1..4] to the other object.
To provide a visual cue that a signal is tied to a bus, you can physically connect the signal to 
the bus. It is recommended that you use a bus entry for this connection. The advantage of 
using a bus entry is that two bus entries can be connected at the same point on a bus 
without connecting the signals. If two wires are run directly to a bus at the same location, 
the signals are connected.
To connect single-signal nets to a bus
1 Place the bus and assign it a name.
2 From the Place menu, choose the Bus Entry command (ALT, P, E). The bus entry symbol is 

attached to your pointer.
3 If the entry is not at the angle you need, then from the Edit menu, choose the Rotate 

command (ALT, E, O) to rotate the entry 90 degrees counterclockwise.
4 Use the mouse to position one end of the entry on the bus, then click the left mouse 

button to place the bus entry.
5 Repeat step 4 until all bus entries are placed. If you place the bus entries at regular 

intervals, you can simplify connecting the single-signal nets to the bus entries.
6 Place a wire to connect the first bus entry to one net, and place an alias, taking care to 

assign this bus member the lowest value in the bus range.
7 Make a selection set of the wire and the alias text, then press CTRL and drag a copy a 

specific distance so that it connects the next net to the bus. The alias value is increased 
by one.

8 From the Edit menu, choose the Repeat command (ALT, E, R). The wire and the incremented
alias are placed at the specified distance from the previous set.

9 Repeat step 8 for every net in the bus or repeat steps 7 and 8 as needed, then select the 
selection tool to dismiss the set.

 

Shortcut
Tool palette:

Related topics
About bus connections
Placing busses
Labeling a net, bus, or bus member
Bus naming conventions
Net operations
Selecting and deselecting objects



Connectivity differences between Capture and SDT 
Repeat Command



Labeling a net, bus, or bus member
You use aliases to connect electrical objects.
To place an alias
1 From the Place menu, choose Net Alias (ALT, P, N).
2 Enter the net alias text, following the naming conventions for busses and bus members, 

then choose the OK button. A rectangle representing the alias text is attached to the 
pointer.

3 Use the mouse to move the alias text and click the left mouse button directly on the wire 
or bus. The alias text displays in the selection color.

4 Select the selection tool, or press ESC, to dismiss the net alias tool.
To label a series of bus members
1 Use the Repeat command to place the bus members at regular intervals.
2 On the first bus member, place one alias, taking care to assign this bus member the 

lowest value in the bus range.
3 Place a net alias, using the left mouse button, on each member of the series.
4 Select the selection tool, or press ESC, to dismiss the net alias tool.

Shortcut
Tool palette:

To edit net alias text
1 Select the net alias.
2 From the Edit menu, choose the Properties command (ALT, E, S).
3 In the dialog box that displays, you can change the color, the font, the rotation, or the 

alias.
4 Choose the OK button to dismiss the dialog box.
To move net alias text

Select the net alias text and drag it to another location.
 

Related topics
Using net aliases
Placing busses
About bus connections
Bus naming conventions
Establishing bus connectivity
Net operations
Selecting and deselecting objects
Net Alias command
Repeat command



Naming conventions

For a bus

A bus name must have the form basename[x..y] where x..y specifies a range of decimal 
integers representing the signal numbers of bus members. There are (y - x + 1) wires in the 
bus. You can use two periods (..), a colon (:), or a dash (-) between m and n.
Examples:

ADDR[0..31] (32 members)
DATA[16:31] (16 members)
CONTROL[4-1] (4 members)
A[100..190] (91 members)

Note that Capture ignores any spaces between the basename and the left bracket ([). For 
example, ADDR[0..31], ADDR [0:31], and ADDR  [0-31] represent the same bus.

For a bus member

The name of a bus member must have the form basenameN where N is the bus member's 
signal number in the bus. The signal can have additional aliases, but it must have this name 
in order to be connected to the bus.
 

Related topics
About bus connections
Labeling a net, bus, or bus member
Rules for resolving name conflicts in a netlist
Establishing bus connectivity
Repeat command



Net operations
A net is one or more wires that are physically connected or that have been connected by a 
net alias, a hierarchical port, or an off-page connector. In addition, all like-named power pins,
power objects, and attached wires throughout the design constitute a net, unless they have 
been isolated.
You can edit a discrete wire, a wire segment, or you can edit the net as a whole. You can also
easily edit or add to the properties of multiple nets. See Updating part or net properties for 
more information.
To find and select a net
1 In the design manager, select the schematic or schematic pages that you wish to search.
2 From the Edit menu, choose the Browse command, and then select Nets from the pull 

right menu (ALT, E, B, N). The browse pane of the design manager displays a list of all nets 
by name and by alias.
or
From the Edit menu, choose the Find command (ALT, E, F), and then type an asterisk (*) in 
the Find What text box and choose OK. The browse pane of the design manager displays a
list of all nets by name and by alias.

3 From the list, double-click on the name of the desired net. The schematic page editor 
opens with the net displayed in the selection color.

4 Press the right mouse button to display the popup menu.
5 From the menu, choose the Select Entire Net command. All net segments on the active 

page display in the selection color.

To edit a net's properties
1 Select a segment on the net.
2 From the Edit menu, choose the Properties command (ALT, E, S). In the Net Properties 

dialog box you can change the Name.
3 Choose the User Properties button to display the User Properties dialog box where you 

can change the color or the netname or any user-defined properties you have created.
To delete a net
1 Select the net.
2 Press the right mouse button.
3 From the context-sensitive menu that displays, select the Select Entire Net command..
4 Press the DELETE or BACKSPACE key.
 

Related topics
About bus connections
Isolating power or ground
Selecting and deselecting objects
Editing properties
Establishing wire connectivity
Establishing bus connectivity
Labeling a net, bus, or bus member
Updating part or net properties
New Property dialog box
Rules for resolving name conflicts in a netlist



Tracing a net



Using net aliases
A net is not required to have an alias, but by using an alias, you can establish connectivity.
Within a schematic page, a net with an alias is connected to any net with the same alias, or 
to any off-page connector, hierarchical port, or global pin with the same name.
A net alias differs from a netname in that a net can have numerous aliases, but it can have 
only one name. When the Create Netlist tool resolves the conflict between the various 
aliases attached to a net, the net alias has the highest priority; so by assigning a netname, 
you can determine the final name of your net.
When you place a wire, it is assigned a system-generated name. When you place a net alias 
on the wire, the system-generated name is replaced by the alias.
A net's alias is visible at the location where you place the alias, You may find it useful to 
label the net throughout your design.
To display the net alias at multiple locations
1 Select the portion of net where you want the alias to be visible.
2 From the Edit menu, choose the Properties command (ALT, E, S). The Net Properties dialog 

box opens.
3 Choose the User Properties button. The User Properties dialog box opens.
4 Choose the New button. The New Property dialog box opens.
5 Assign a name, maybe NAME1, to the new property. Do not assign a value at this time. 

Choose the OK button to dismiss the New Property dialog box.
6 In the User Properties dialog box, choose the Display button, then enable the Visible 

check box and choose the OK button.
7 Choose the OK button twice to dismiss the User Properties and Net Properties dialog 

boxes.
8 Repeat steps 1 through 8 for each location where you want the alias displayed, assigning 

another property name (NAME2, NAME3 . . .) at each location.
9 Use the Update Properties tool (see Updating part or net properties) to assign the net's 

alias as the value to the properties NAME1, NAME2, NAME3 . . . .

Related topics
About bus connections
Establishing wire connectivity
Establishing bus connectivity
Labeling a net, bus, or bus member
Rules for resolving name conflicts in a netlist
Labeling a net, bus, or bus member
Net Alias command



Placing wires
The purpose of wires, of course, is to create connections. When you connect a wire to a pin, 
Capture provides visual confirmation: the unconnected pin box on the pin disappears. If two 
wires cross at 90 degrees, they are not electrically connected unless you create a junction 
by clicking the left mouse button on one wire as you draw the other to it.
When a wire forms a "T" intersection with a pin or another wire, a visible junction is shown. If
the two objects don't intersect, like when a wire ends at a pin or where the next wire begins, 
then no junction is displayed.
When you place a wire, it is assigned a system-generated netname. You can replace the 
system-generated name by assigning an alias or a netname. If you connect a wire to an 
existing net, the wire assumes the name of that net. For more information, see Establishing 
wire connectivity.
To place a wire
1 From the Place menu, choose Wire (ALT, P, W).
2 Click the left mouse button to start the wire.
3 Use the mouse to draw the wire. Click the left mouse button to place a vertex and change

directions. The vertex is constrained to multiples of 90 degrees.
4 If the wire ends at a pin or another wire, click the left mouse button to end the wire. The 

wire displays in the selection color.
or
If the wire doesn't connect to anything, double-click to end the wire. The wire displays in 
the selection color.

5 Select the selection tool to dismiss the wire tool.
To place a nonorthogonal wire

Hold down the SHIFT key while you draw the wire. There is no constraint on vertex 
angles.
 
 
 

Shortcut
Tool palette:

Related topics
Establishing wire connectivity
Editing wires and busses
About bus connections
Net operations



Establishing wire connectivity
In Capture, you can establish connectivity either with wires or aliases.
Two perpendicular wires or busses are connected if either one ends at the intersection (that 
is, if they form a "T" intersection), or if a junction is placed where they cross. If they simply 
cross at 90 degrees, they are not electrically connected, unless you click the left mouse 
button on one wire (or bus) as you draw the other across it.
You can also use an alias to connect a signal from one area of your schematic page to 
another. For example, suppose you have placed an object on your schematic page and you 
want to connect it to another object at the opposite corner of the schematic page. Instead of
drawing a wire from the first object to the second object, you can assign a single net alias to 
both objects.
A net can have any number of aliases plus one optional netname. The only purpose of the 
netname is to give highest priority to one of a net's aliases. When you assign a name to a 
net, you force Capture to resolve netname conflicts in favor of a particular alias.
 
 

To attach a wire to a net
Begin or end the wire on the net.

or
Click the left mouse button as you draw the wire over the net.

or
Create a net alias as described below, assigning the alias of the net to this wire. 

Within a schematic page, wires with the same name or alias are electrically connected.
To create a net alias
1 From the Place menu, choose Net Alias (ALT, P, N).
2 Enter the net alias text in the dialog box that displays, then choose the OK button. A 

rectangle representing the net alias is attached to the pointer.
3 Use the mouse to move the net alias and click the left mouse button on the wire to place 

the net alias. The net alias displays in the selection color.
4 Select the selection tool to dismiss the net alias tool. The alias is added to the alias list for

the net.

Shortcut
Tool palette:

To assign a netname
1 Select the wire.
2 From the Edit menu, choose the Properties command (ALT, E, S). The Net Properties dialog 

box displays.
3 Change the entry in the Name text box to one of the existing net aliases and choose the 

OK button.
To edit a net alias
1 Select the net alias.
2 From the Edit menu, choose the Properties command (ALT, E, S).
3 In the dialog box that displays, you can change the color, the font, the rotation and the 

alias itself.



4 Choose the OK button to dismiss the dialog box.
To move net alias text

Select the net alias text and drag it to another location.

Related topics
Selecting and deselecting objects
Rules for resolving name conflicts in a netlist
About bus connections
Connectivity differences between Capture and SDT 
Wire command
Net Alias command
Part command



If you place parts so that two pins meet end to end, the pins are connected.



Using no connects
The Design Rules Check tool checks for unconnected pins. If you intentionally leave a pin 
unconnected in a schematic page, it needs a no connect symbol. The Design Rules Check 
tool ignores unconnected pins with no connect symbols.
If a pin with a no connect symbol is connected to a net, the no connect symbol has no effect 
on the pin and becomes invisible. If the pin is later disconnected from the net, the no 
connect symbol becomes visible again.
No connects cannot be deleted with the Delete command.
To place a no connect symbol
1 From the Place menu, choose No Connect (ALT, P, C).
2 Position the mouse pointer over the pin, and click the left mouse button. The end of the 

pin changes from a square (unconnected) to an X (not connected).
or
1 Select the pin.
2 From the Edit menu, choose Properties (ALT, E, S). The Pin Properties dialog box displays.
3 Choose the User Properties button. The User Properties dialog box displays.
4 Select the Is No Connect property, and change its value from FALSE to TRUE in the drop down

box.
5 Choose OK twice, and click the left mouse button in any open space in the schematic. The

end of the pin changes from a square (unconnected) to an X (not connected).
To remove a no connect symbol
1 Select the pin.
2 From the Edit menu, choose Properties (ALT, E, S). The Pin Properties dialog box displays.
3 Choose the User Properties button. The User Properties dialog box displays.
4 Select the Is No Connect property, and change its value from TRUE to FALSE in the drop down

box.
5 Choose OK twice, and click the left mouse button in any open space in the schematic. The

end of the pin changes from an X (not connected) to a square (unconnected).

Related topics
Checking for design rule violations
Interpreting Design Rules Check reports
Placing a part instance 
Editing properties
No Connect command
Properties command



Establishing connectivity between schematic pages
In Capture, you connect schematics and schematic pages by extending nets between them, 
using off-page connectors, hierarchical blocks, and hierarchical ports. Off-page connectors 
carry nets between schematic pages within a single schematic. Hierarchical blocks and 
hierarchical ports carry nets between schematics.

Click the Demo button to see an example of how to set up a simple hierarchy.
The following topics describe how the connections work and how you use them:

About off-page connectors
About hierarchical blocks
About hierarchical ports

 
 
 
 

To extend a net across schematic pages within a single schematic
1 Open the schematic page editor on a page that contains the net.
2 From the Place menu, choose the Off-Page Connector command (ALT, P, F).
3 Select a symbol and enter a name in the Name text box; then choose the OK button.
4 Connect the off-page connector to the net, either by name or by wire.
5 For each schematic page on which the net resides (and within the same schematic), 

repeat steps 1 through 4, using the same name for each off-page connector you place.
To extend a net through a hierarchy
1 Open the schematic page editor on the parent page.
2 Place a hierarchical block, then assign a name to the hierarchical block.

or
Place a nonprimitive part.

3 If necessary, attach a schematic to the hierarchical block or part.
4 If you placed a hierarchical block in step 2, then from the Place menu, choose the 

Hierarchical Port command (ALT, P, I) and assign the port a name.
5 Open a schematic page in the attached schematic.
6 Place a hierarchical port with the same name you used in step 4, then place wires to 

connect the hierarchical port to the net.
7 Repeat steps 4 through 6 for each hierarchical port in the hierarchical block, or for each 

pin on the part.
 

Shortcuts
Tool palette:
                        

To connect hierarchical ports or off-page connectors with nets



Extend the net to the hierarchical port or off-page connector by placing a wire or bus.
or
1 Select the hierarchical port or off-page connector and choose Properties (ALT, E, S) 
from the Edit menu.

or
Select the hierarchical port or off-page connector's name and choose Properties from 

the Edit menu.
2 In the Name text box or Value text box, type the name of the net, and choose OK.

Related topics
About bus connections
Establishing wire connectivity
Net operations
Attaching a schematic
Rules for resolving name conflicts in a netlist
Establishing bus connectivity
Labeling a net, bus, or bus member
Net Alias command
Tracing a net
Pin shapes and types
Place Hierarchical Port dialog box (inside hierarchical blocks)
Place Hierarchical Port dialog box (outside hierarchical blocks)
Off-Page Connector command
Hierarchical Block command
Hierarchical Port command



Attaching a schematic
You attach a schematic in order to extend net connections between schematics. The 
attached schematic is the child schematic in a hierarchy.
A schematic can be attached to a nonprimitive library part, a nonprimitive part instance on a
schematic page, or a hierarchical block.
To attach a schematic to a hierarchical block
1 Open the schematic page editor on the parent page.
2 From the Place menu, choose the Hierarchical Block command (ALT, P, H).
3 Assign a name to the hierarchical block.
4 Choose the Attach Schematic button. The Attach Schematic dialog box displays.
5 In the Schematic text box, enter the name of the child schematic.
6 If the child schematic is not in the current design, specify the path and library where the 

schematic is located.
7 Choose the OK button twice. The parent schematic page displays.

To attach a schematic to a part
1 Create a new part.

or
Select the part on the parent schematic page and then from the Edit menu, choose the 
Properties command (ALT, E, S).

2 Choose the Attach Schematic button. The Attach Schematic dialog box displays.
3 In the Schematic text box, enter the name of the child schematic.
4 If the child schematic is not in the current design, specify the path and library where the 

schematic is located.
5 Choose the OK button twice. The parent schematic page displays.
 
 
 
 

Related topics
Establishing connectivity between schematic pages



Tracing a net
When you need to trace a net, you may not know all the net aliases or how many schematic 
pages the net touches. Using Capture, you can overcome these problems and find every 
portion of the net. You'll need to start with a portion of the net selected in the schematic 
page editor, or with a netname, an off-page connector name, or a hierarchical port name. If 
you start with a name, use the Find command of the design manager to locate a portion of 
the net.
The actions involved in tracing a net can be done in any order. Typically, you locate a part of 
the net, highlight all portions of the net on the same schematic page, follow the net onto 
other schematic pages in the same schematic, and then follow the net onto other 
schematics.
To find a net using a name
1 In the design structure pane of the design manager, select the schematic that holds the 

name. If you do not know which schematic holds this portion of the net, select all 
schematics (press CTRL while you click on a schematic to add it to the selection set).

2 From the Edit menu, choose the Find command (ALT, E, F). The Find dialog box opens.
3 Enter the name, with wildcards if you wish, in the Find What text box and specify that this 

is the name of a net, an off-page connector, or a hierarchical port.
4 Choose the OK button to initiate the search. A list of all objects which match your search 

criteria displays in the browse pane.
5 Double-click on an item in the browse pane. The schematic page editor opens with the net

or off-page connector or hierarchical port selected.
To locate and highlight all wires of a net on a single page
1 Click over a wire of the net to select the wire.
2 Click the right mouse button to display the popup menu.
3 From the menu, chose Select Entire Net. All wires of the net display in the selection color. 

You may need to zoom out to see the entire net.
To trace a net across pages of a schematic
1 Locate and highlight all wires of the net on one page.
2 Scan the selected net for off-page connectors and for hierarchical ports not inside a 

hierarchical block. For each off-page connector or hierarchical port,
Note the name.
Activate the design manager and select the current schematic.
From the Edit menu, choose Find.
Enter the name, select Off-Page Connectors, then choose OK. The browse pane 

displays a list of off-page connectors with the specified name.
For each entry in the browse pane, double-click on the entry. The schematic page 

editor opens with the off-page connector displayed in the selection color.
Repeat step 2, selecting Hierarchical Ports in the Find dialog box.

To trace a net between schematics
1 Locate and highlight all wires of the net on one page.
2 Scan the selected net for hierarchical ports not inside a hierarchical block. For each port,

Note the name.
Activate the design manager and select all schematics except the active one.
From the Edit menu, choose Find.
Enter the name, select Hierarchical Ports, then choose OK. The browse pane displays 

a list of hierarchical ports with the specified name.



For each entry in the browse pane, double-click on the entry. The schematic page 
editor opens with the hierarchical port displayed in the selection color.
 
 

Related topics
Net operations
Establishing connectivity between schematic pages
About bus connections
Off-Page Connectors command
Ports command



Capture preserves the case of part names and netnames, but ignores the case when 
comparing names for electrical connection. That means you may use uppercase or 
lowercase letters as you wish, but you need not remember the case.



Searching for a part in the libraries
Capture provides more than 20,000 parts in more than 80 libraries. You'll find the part you 
need using the Place Part dialog box.
The Place Part dialog box displays the names of parts that reside in the selected libraries. In 
the Place Part dialog box, you can use the Add Library and Remove Library buttons to specify
the search libraries; you can filter the list of parts by typing a selective search string with 
wildcards; and you can even browse parts graphically.
To search for a part by name
1 From the Place menu of the schematic page editor, choose the Part command (ALT, P, R). 

The Place Part dialog box displays.
2 In the Part text box, enter the name---you can use the standard "*" and "?" wildcard 

characters. Capture scans the selected libraries and lists all parts that match the name or 
wildcard.

3 Click on a part in the list for a preview then choose the OK button to place the part, or 
double-click on it to place the part.

To browse parts graphically
1 From the Place menu of the schematic page editor, choose the Part command (ALT, P, R). 

The Place Part dialog box displays.
2 Select the library or libraries you wish to browse, then select the part from the part list. 

The selected part displays in the preview box. You can use the up and down scroll buttons,
or the arrow keys, to traverse the list, viewing each part in turn.

3 Choose the OK button to dismiss the dialog box and place the part.
To search multiple libraries
1 From the Place menu of the schematic page editor, choose the Part command (ALT, P, R). 

The Place Part dialog box displays.
2 Choose the Add Library button. The Browse File dialog box opens.
3 If the library you wish to search is not listed in the File Name box, do one or more of the 

following:
In the Drives box, select a new drive.
In the Directory box, select a new directory.
In the List Files of Types box, select the type of file you wish to search.
In the File Name text box, enter the extension of the library you wish to search

4 Select a library from the File Name box and choose the OK button. The library name 
displays in the Libraries box of the Place Part dialog box.

5 Repeat steps 2 through 4 until all the libraries you wish to search are displayed in the 
Libraries box.

6 In the Libraries box, select the libraries you wish to search.
.

Shortcut
Tool palette:

Related topics
Placing a part instance 
Selecting and deselecting objects
Searching for specific pins or text on a part



Opening a library created in SDT
Find command
Open command



Searching for pins or text in the part editor
In Capture, you can search for specific comment text on a part and you can search for a pin 
by name or by one of its property values.
To search for text or pins
1 Open the part in the part editor.
2 From the Edit menu, choose the Find command. The Find dialog box displays.
3 Enter a text string that defines the object you seek; for a pin, enter the pin name or a 

property value. You can use question marks (?) or asterisks (*) as wildcards.
4 Verify that the Match Case option is as you want it.
5 Select Pin or Text as the object type, then choose the OK button. The object displays in 

the selection color.

Related topics
Searching for a part in the libraries
Searching a design
Defining the part body
Placing pins



Placing a part instance
Parts are stored in libraries. Capture has more than 20,000 parts in more than 80 libraries 
and you may wish to create your own parts in custom libraries. Some library parts have a 
convert as well as the normal graphical representation. Many packages contain more than 
one part, in which case you may need to specify which of the parts you wish to place.
The first time a part instance is placed, a copy of the part is created in the design cache. In 
this design, all instances of the part refer to the part in the design cache.
To place a part
1 From the Place menu, choose the Part command. The Place Part dialog box displays. For 

more information, see Searching for a part in the libraries.
2 From the Parts list, select the part you wish to place. Keep the following information in 

mind as you select the part:
If you wish to place a convert version of the part, select Convert in the Graphic group 

box. 
If the package contains more than one part, select one of the parts from the drop list 

in the Packaging group box. The part displays in the preview box.
If the part is a heterogeneous part, you need to decide which part in the package you

want now, because you wont be able to change the part in the package after the part is 
placed.

If the part is a heterogeneous part, and you are placing multiple copies of the same 
part in the package, then you need to specify the part number now. Otherwise, Capture will 
display an illegal package grouping error message when you try to run Update Part 
References.
3 Choose the OK button. An image of the part is attached to the pointer.
4 Move the part image and click the left mouse button to place the part.
5 For each instance of the part you want to place, repeat step 4.
6 Select the selection tool to dismiss the part that's attached to the pointer.
 
 

Shortcut
Tool palette: 

Related topics
About parts
Using the part editor
Using no connects
Editing a part on a schematic page
Editing library parts
Editing a part as you place it
Creating a part
Part command
Edit Part dialog box



You can place a part in the middle of a wire segment without redrawing the wire. Simply 
place the part over the wire such that two pins on the part connect with the wire segment. 
Then click the left mouse button over the part with the TAB key pressed until just the 
overlapping wire segment is selected. Finally, delete the wire segment.



Editing a part on a schematic page
On a schematic page, you can change the location or orientation of a part, and you can use 
the part editor to edit the graphic representation of the part. When you edit the graphic 
representation on a schematic page, you make a local part that differs from the part in the 
library and exists only in this design; the only way to place another copy of this part is to use
the Copy command on the Edit menu.
After you complete edits to the graphic representation, you close the part editor window. 
Capture gives you a choice of updating the single instance, or updating all instances in the 
design. If you update only the single instance, Capture creates a new part in the design 
cache. If you update all instances, Capture replaces the library part in the design cache with 
your edited part.
You can also edit the part's properties. If you wish to edit the properties of several parts, use 
the Update Properties or Export Properties command on the Tools menu or the spreadsheet 
editor.
To change a part's location

Select the part, then drag the part to the new location.
To change a part's orientation

Select the part, then press the right mouse button to display the popup menu. See 
Mirroring objects and Rotating objects for more information.
To review or edit pin properties
1 Select the pin in the schematic page editor.
2 From the Edit menu, choose the Properties command. The Pin Properties dialog box 

displays with the pin's name, number, type, and width.
3 If you need to edit the pin, choose the User Properties button to bring up the User 

Properties dialog box.
4 Make the needed changes in the dialog box.
5 Choose the OK button twice to return to the schematic page editor.
 

To edit a part instance
1 Select the part in the schematic page editor.
2 From the Edit menu, choose the Part command. The part editor opens with the selected 

part displayed.
3 Edit the part to suit your needs. See Defining the part body for more information.
4 From the File menu, choose the Close command, then select the appropriate update 

button. The part editor window closes and the updated part displays in the schematic 
page editor.

 
 

Related topics
About parts
Defining the part body
Editing a part as you place it
Placing a part instance 
Updating part or net properties
Exporting part and pin properties
Using the spreadsheet editor



Editing library parts
Pin shapes and types
Edit Part dialog box
New Part command



Properties with the R (read-only) attribute cannot be edited on a schematic page.



When you open the part editor from the schematic page editor, the part you are editing 
cannot be selected on the schematic page. After you close the part editor window, the part 
can be selected.



When you edit a part's graphic representation on a schematic page, you break the 
connection between the part and the library; if you want to reverse your edits, you use the 
Replace Cache command of the Design menu. For more information, see Replacing a part in
a design.



Editing part properties
When you need to edit properties of individual parts, follow the instructions below; when you
need to edit properties of several parts, you can save time by using the spreadsheet editor 
or the Update Properties, or Export Properties commands on the Tools menu.
A part's properties and its property values are not necessarily identical for the part 
occurrence, the part instance, and the library part. The properties of the library part apply to
the part instance and the part occurrence unless you edit them in the schematic page 
editor. The properties of the part instance apply to the part occurrence unless you edit them 
in physical view.
If you add a user-defined property to one part in a homogeneous multiple-part package, all 
parts in the package inherit the property and its value. If you add a user-defined property to 
one part in a heterogeneous multiple-part package, the other parts in the package are not 
affected.
You can also edit properties on part packages, in which case the changes appear on every 
part in the package, and on every part instance. You cannot add user-defined properties to 
packages.
Whether you are editing the properties of a library part, a part instance, or a part 
occurrence, you work in the Edit Part dialog box. In this dialog box you can add or remove 
user-defined properties or change the values for the following properties:

Part Value
Part Reference
Primitive
Graphic
Packaging
PCB Footprint
Power Pin Visibility
User properties

To edit properties of a library part
1 With the part open in the part editor, double-click anywhere in the part editor window 

except on a graphic object, or choose the Part Properties command from the Options 
menu. The Edit Part dialog box.

2 Make your changes in the dialog box and choose the OK button. The changes are 
reflected in the library, but they are not permanent until you save the part.

To edit properties of a part in a design
1 If you are editing a part instance, verify that you are in logical view.

or
If you are editing a part occurrence, verify that you are in physical view.

2 On the schematic page, select the part.
3 From the Edit menu, choose the Properties command. The Edit Part dialog box.
4 Make your changes in the dialog box and choose the OK button. You can change, among 

other things, the number of parts in the package, the PCB footprint, and the visibility of 
power pins. The changes are reflected on the schematic page, but they are not 
permanent until you save the schematic page.

Related topics
Updating part or net properties
Exporting part and pin properties



Edit Part dialog box
Editing package properties
Editing properties
New Property dialog box
Defining properties
Working with properties



Editing package properties
As with part properties, you can edit package properties in the library or on the schematic 
page. If you edit package properties on the schematic page, the changes affect only the 
parts in the design; you are, in effect, creating a new part which is not stored in a library.
Package properties are inherited by every part in the package and by every part instance. 
Packages do not support user-defined properties.
All packages include the following properties:

Name
Alphabetic or numeric part numbering
Homogenous or heterogeneous type
Number of parts per package
Part reference prefix
Printed Circuit Board footprint
Alias

To edit package properties
1 From the View menu of the part editor, choose the Package command.
2 From the Options menu, choose the Package Properties command. The Edit Part 

Properties dialog box displays.
3 Make your changes in the dialog box and choose the OK button to dismiss the dialog box. 

You can change, among other things, the number of parts in the package, the PCB 
footprint, and the part reference prefix. The changes are reflected in the part editor, but 
they are not permanent until you save the design.

Related Topic
Working with properties
Editing part properties



Finding parts in a design
Using the Find command and a part property value, you can locate a part in a schematic or 
on a page. In the Find dialog box, you enter a property value string and you specify that you 
want to find a part. Capture searches all the parts to find those with a property value that 
matches the string. You can use question marks (?) or asterisks (*) as wildcards in the 
property value string.
To find a part on a schematic page
1 Open the schematic page.
2 From the Edit menu, choose the Find command.
3 Enter the property value string that defines the part you seek.
4 Select Parts from the object types.
5 Choose the OK button to start the search. Parts that have a property value matching the 

property value string of step 3 are selected.
To locate a part in a design
1 In the design structure pane of the design manager, select the schematics or schematic 

pages you want to search.
2 From the Edit menu, choose the Find command.
3 Enter the property value string that defines the part you seek.
4 Select Parts from the object types.
5 Choose the OK button to start the search. Parts that have a property value matching the 

property value string of step 3 are listed in the browse pane.
6 Double-click on the part in the browse pane list to open the schematic page editor with 

that part displayed and selected.

Related topics
Editing a part on a schematic page
Editing library parts
Editing a part as you place it
Placing a part instance 



Replacing a part in a design
If you need to replace a part in your design with another, you could activate the schematic 
page editor to find and delete each instance of the part, then place the replacement part. If 
your design includes many instances of this part, you can more easily achieve the same end 
with the Replace Cache command.
You would also use the Replace Cache command after you edit a part on a schematic page if
you want to undo the edits and restore the part's link to its library.
When you delete a part, all of its properties are deleted also. When you use the Replace 
Cache command, properties of the part instance are attached to the replacement part; 
however, the pin properties are lost.
 
 

To replace a part throughout a design
1 From the design cache, select the part you want to replace.
2 From the Design menu, choose the Replace Cache command.
3 In the dialog box that displays, enter the name of the replacement part and of the library 

that contains it.
4 Choose the OK button. When the design manager displays again, double-click on the 

design cache to verify that the replacement part is listed instead of the original part.

Related topics
Editing a part on a schematic page
Editing library parts
Editing a part as you place it
Synchronizing parts in a design with library parts
Placing a part instance 
Find command
Update Cache command
Replace Cache command



If you need to know a part's library of origin, you can select the part in the design structure 
pane, then select Replace Cache from the Edit menu. The part name plus the library and 
path are listed in the dialog box that displays. Choose the Cancel button to return to the 
design manager.

You can discover the library of origin for multiple parts by creating a cross reference report.



When you use the Replace Cache or Update Cache command, all properties of the part are 
retained, but the pin reflects the properties of the library part. This means you lose any 
changes made to pin properties after the part was placed, including those made by the 
Gate and Pin Swap or the Update Part References tools.



When you use the Replace Cache or Update Cache command, all properties of the part are 
retained, but the pin reflects the properties of the library part. This means you lose any 
changes made to pin properties after the part was placed, including those made by the 
Gate and Pin Swap or the Update Part References tools.



Synchronizing parts in a design with parts in libraries
Capture gives you the power to place part instances in a design, alter the parts in the 
library, then update the design so that all instances of the altered parts reflect the changes 
you have made in the library. You use the Update Cache command on the Design menu to do
this.
When you use the Update Cache command, properties of the part instance are retained; 
however, the pin properties of the part instance are lost.
To update a part in the design cache so it matches a part in the library
1 In the library, edit the parts to suit your needs.
2 Activate the design manager window for the design.
3 Select the parts in the design structure pane.
4 From the Design menu, choose the Update Cache command. The design cache and all 

part instances are updated to match the library part.
 
 

Related topics
Replacing a part in a design
Replace Cache command
Update Cache command



If you move a library after you place a part instance, the connection between the part 
instance and its library is broken. In this case, the Update Cache command will not find the 
library; you'll need to use the Replace Cache command and specify the new path to the 
library.



Updating part properties in a library
If there is some information, like stock number or supplier, that is needed on your parts, you 
can add a property and set the property value in the library. Later, when you place the part 
in a design, the information is present; there's no need to add information to the placed part.
You certainly can edit parts individually in the part editor, but when you wish to update 
properties of a number of parts, the Update Properties tool is very convenient. You can use 
the Update Properties tool to edit any properties except part value and part reference.
Before you run the Update Properties tool, you create an update file as described in Creating
an update file. To identify the parts you wish to update, you specify an identifying property 
or combination of properties called a combined property string. For each combined property 
string you use, you must create a separate update file and run the Update Properties tool.
To update part properties
1 Using a text editor, create an update file.
2 Open the library which holds the parts.
3 From the Tools menu, choose the Update Properties command (ALT, T, P). The Update 

Properties dialog box displays.
4 In the Action area, select Parts.
5 Verify that the other dialog box selections are just the way you want them, then choose 

the OK button to run Update Properties. Unless you select the button to Unconditionally 
update the property, properties that currently hold a property value are not updated.

Related topics
Updating part or net properties
Creating an update file
Editing properties
Defining properties
Working with properties



Copying a schematic to or from a library
If you have a circuit that you use in many designs, you can put that circuit in a separate 
schematic, save it in a library, and attach it to a part that you can place in any design. It is 
good design practice to keep the part and the attached schematic in the same library.
When you save a schematic in a library, Capture puts the circuit's parts in the library cache.
A schematic or schematic page that is open in an editor cannot be moved or copied.
To save a copy of a schematic as a library object
1 Verify that no Capture editor is open on any part of the schematic.
2 In the design manager, select the schematic you wish to save.
3 From the Edit menu, choose the Copy command (ALT, E, C).
4 Activate the design manager window of the library in which you want to store the 

schematic.
5 From the Edit menu, choose the Paste command (ALT, E, P).
6 From the File menu, choose the Save command (ALT, F, S).
or
1 Verify that no Capture editor is open on any part of the schematic.
2 Drag and resize the design manager windows for the design and the library so that each 

is visible.
3 Select the schematic you wish to save.
4 Press and hold CTRL while you drag the schematic to the design structure pane of the 

library's design manager window.
5 From the File menu, choose the Save command.
 

To copy a schematic from a library to a design
1 Open the library containing the schematic you wish to copy, and select the schematic.
2 From the Edit menu, choose the Copy command.
3 Open the design in which you want to use the schematic.
4 From the Edit menu, choose the Paste command.
5 From the File menu, choose the Save command.
or
1 Open the library and the design, and from the Window menu choose the Tile Horizontally 

command (ALT, W, H).
2 Select the schematic you wish to copy.
3 Press and hold CTRL while you drag the schematic to the design structure pane of the 

design's design manager window.
4 From the File menu, choose the Save command.
You can also attach the schematic to a part or hierarchical block without copying the 
schematic to the design, but this method affects design portability. For more information, 
see Attaching a schematic.

Related topics
Copying a schematic page to a library
Copying a part from the design cache to a library 
Moving schematic pages between schematics
Moving schematics between designs



Moving schematic pages between designs
Opening a library
Attaching a schematic



Copying a schematic page to a library
If you have a small circuit that you use in many designs, you can put that circuit on a 
separate schematic page, save it in a library, and attach it to a part that you can place in 
any design. It is a good idea to keep the attached schematic and the part in the same library.
In order to save a schematic page in a library, you must first move the page into a 
schematic.
When you save a schematic page in a library, Capture puts the circuit's parts in the library 
cache.
A schematic or schematic page that is open in an editor cannot be moved or copied.
To save one schematic page in a library
1 Verify that the page is not open in the schematic page editor or the spreadsheet editor.
2 In the design's design manager, create a schematic to hold the page.
3 In the design manager, select the schematic page you wish to save. then copy or move 

the page into the new schematic. Leave the new schematic selected.
4 From the Edit menu, choose the Copy command.
5 Activate the design manager of the library in which you want to store the schematic.
6 From the Edit menu, choose the Paste command.
or
1 Verify that the page is not open in the schematic page editor or the spreadsheet editor.
2 In the design's design manager, create a schematic to hold the page.
3 Drag and resize the design manager windows for the design and the library so that each 

is visible.
4 In the design manager, select the schematic page you wish to save. then copy or move 

the page into the new schematic. Leave the new schematic selected.
5 Press and hold CTRL while you drag the schematic page to the design structure pane of the

library's design manager window.
 

Related topics
Copying a schematic to or from a library
Copying a part from the design cache to a library 
Moving schematic pages between schematics
Moving schematic pages between designs
Opening a library
Attaching a schematic



Copying a part from the design cache to a library
You can copy parts from the design cache to a library. This is useful if you have modified a 
part through the schematic page editor, and want a permanent copy of the part.
To save a design cache part in a library
3 In the design manager, select the part you wish to save.
4 From the Edit menu, choose the Copy command.
5 Activate the library in which you want to store the part.
6 From the Edit menu, choose the Paste command.
or
3 Drag and resize the design manager windows for the design and the library so that each 

is visible.
4 In the design manager, select the part you wish to save.
5 Drag the part to the design structure pane of the library's design manager window.
 

Related topics
Using drag and drop with documents 
Moving parts or symbols between libraries 
Copying a schematic page to a library 
Copying a schematic to or from a library
Working with libraries 
Working with designs, schematics, and schematic pages 
Working with multiple windows 
Opening a library
Attaching a schematic



Working with schematics and schematic pages in libraries
Schematics and schematic pages behave almost identically in libraries as they do in designs.
The primary differences are:

Schematics and schematic pages cannot be created in libraries. If you want to add a 
schematic or schematic page to a library, you must create it in a design and then move it 
over to the library. For more information, see Copying a schematic to or from a library and 
Copying a schematic page to a library.

Schematics and schematic pages are limited to the library tool set, namely updating 
properties, exporting properties, and importing properties.

The Update Cache and Replace Cache commands are not available when parts are 
selected in the library cache.
You can open a library stored schematic page in a schematic page editor, and edit it exactly 
the same as if you had opened it from a design; however, it is recommended that you edit a 
schematic page in a design. If a schematic stored in a library is the child of another 
schematic in a design, the Descend Hierarchy command in the parent schematic opens both 
the library containing the child schematic, and a schematic page editor containing the 
schematic page.

Related topics
Copying a schematic to or from a library
Copying a schematic page to a library
Copying a part from the design cache to a library 
Working with libraries



Before editing a schematic page stored in a library, you should find out which designs call 
upon the schematic. Editing a library stored schematic may create problems for other 
designs which use the library stored schematic page.



Before editing a schematic page stored in a library, you should find out which designs call 
upon the schematic. Editing a library stored schematic may create problems for other 
designs which use the library stored schematic page.



Creating a hierarchical port or off-page connector symbol
1 Open the library that will hold the new symbol.
2 From the Design menu, choose New Symbol. The New Symbol Properties dialog box 

displays.
3 Enter a name and select Off-Page Connector or Hierarchical Port as the symbol type, then 

choose the OK button. The part editor opens with an empty part boundary box.
4 Use the graphics tools to create the symbol. The symbol dimensions expand automatically

to accommodate the graphics.
5 From the File menu, choose Save (ALT, F, S). If you are creating this symbol in a new library 

that has not yet been saved, the Save As dialog box displays, giving you the opportunity 
to name the library file.

 
 

Related topics
About hierarchical ports
About off-page connectors
Editing a part on a schematic page
Editing library parts
Working with graphics, text, and bitmaps
Establishing connectivity between schematic pages
Pin shapes and types
New Symbol command



Creating a part
In Capture, you can create a part and add it to a new or existing library. The part may be a 
single part or a multiple-part package. It can contain graphics, which must be inside the part
body border, as well as IEEE symbols and text, which can be either inside or outside the part
body border. For any part that you create, you can also create a part convert.
Creating a part involves three processes: defining the part in the Part Properties dialog box, 
defining the part body, and placing pins on the part body.
To create a part
1 Make the design manager the active window for the library to contain the part.
2 From the Design menu, choose the New Part command. The Part Properties dialog box 

displays.
3 Complete the Part Properties dialog box and choose the OK button. The part editor opens 

with an empty part outline.
4 Use the graphics tools to define the part graphically, then add pins.
5 From the File menu, choose Save (ALT, F, S). If you are creating this part in a new library 

that has not yet been saved, the Save As dialog box displays, giving you the opportunity 
to name the library file.

 
 
 
 
 
 

Related topics
About parts
Creating a part alias
Creating multiple-part packages
Creating a part convert
Defining the part body
Placing pins
Attaching a schematic
Moving parts between libraries
Pin shapes and types
Part Properties dialog box
New Part command



The size of a part or a symbol is limited to 32 by 32 inches.



Editing a part as you place it
When you edit a part as described below, you are editing the part in the library. Your 
changes are reflected in the library part. If you edit the part after you place it on the 
schematic page, the changes are reflected only in the part instance.
To edit a part before you place it
1 From the Place menu in the schematic page editor, choose the Part command (ALT, P, P). 

The Place Part dialog box opens.
2 Select the part (see Searching for a part in the libraries).
3 Choose the Edit Part button. The part editor opens with the selected part displayed.
4 Make changes to the part body definition using graphics, text, and bitmaps.
5 Make the needed changes to pins. You can move pins after you select them or add pins. 

To edit pin properties, double-click on the pin.
6 From the File menu, choose the Save command. Capture saves the changes you have 

made in the library.
 

Related topics
About parts
Editing a part on a schematic page
Placing a part instance 
Searching for a part in the libraries
Saving library changes
Edit Part dialog box



Editing library parts
If you have a library part that is very nearly perfect, you can tailor the original part so that it 
suits your design. You can edit the part's properties and you can change its graphical 
representation or its pins.
To edit a library part
1 Open the library containing the part.
2 In the design structure pane of the design manager, double-click on the part. The part 

editor opens with the part displayed.
3 Make changes to the part body definition using graphics, text, and bitmaps.
4 Make the needed changes to pins. You can move pins after you select them or add pins. 

To edit pin properties, double-click on the pin.
5 From the File menu, choose the Save command.
 
 

Related topics
About parts
Editing a part on a schematic page
Updating part properties in a library
Updating part or net properties
Creating a part
Creating a library
Saving library changes
Creating multiple-part packages
Searching for a part in the libraries



You can use an existing part as a model for a new part by moving a copy of the part to a 
second library and then editing the copy. If you wish to have the new part in the original 
library, rename the new part, then move it to the original library.



Part view and package view
In the part editor, you may look at a single part or at a package. You use the part view to 
edit, add, or remove part properties, edit pin properties, and change the display of the part 
reference. Use the package view to edit package properties such as part numbering, part 
aliases, number of parts, and PCB footprint.
Properties are handled differently for parts and packages, and for homogeneous parts and 
heterogeneous parts. Package properties appear on every part in the package, and have the
same value. A package cannot have user-defined properties. Properties in homogeneous 
parts appear on every part in the package, and also have the same value. Properties in 
homogeneous parts appear only on the given part in the package. If you add an identical 
property to another part in a heterogeneous package, the two properties values are 
independent of each other.
You can edit the part's graphic representation in part view, but not in package view; the tool 
palette is invisible in package view.
To switch between part view and package view

From the View menu of the part editor, choose the Part command or the Package 
command.

Related topics
Editing package properties
Editing part properties
Part command
Package command



Creating multiple-part packages

To create a multiple-part package
1 Open the library which will hold the part.
2 From the Design menu, choose the New Part command. The New Part Properties dialog 

box displays.
3 Enter the number of parts in the package (up to 128), and specify whether they are all the

same (homogeneous) or different (heterogeneous).
4 Fill in the other fields in the dialog box and choose the OK button. The part editor opens 

with an empty part outline.
5 Use the graphics tools to define the part body, and then add pins.
6 If you are creating a heterogeneous package, choose Next Part from the View menu, then 

repeat steps 4 and 5 for each part.
or
If you are creating a homogeneous package, choose Next Part from the View menu, then 
assign pin numbers for each part.

7 From the File menu, choose Save (ALT, F, S). If you are creating this part in a new library 
that has not yet been saved, the Save As dialog box displays, giving you the opportunity 
to name the library file.

 

Related topics
About parts
Switching to a different open part
Defining the part body
Creating a shared pin
Placing pins
Placing an array of pins
Creating a part
Part view and package view
Part command
Package command
Next Part command
Previous Part command
New Part command



After a part is created, you can add to the number of parts in the package, even if the part 
starts out as a package of one. You can decrease the number of parts in a homogeneous 
package, but not a heterogeneous package.



Creating a part convert
If you wish, you may store a part convert with a library part. You may, then, place the normal
view of the part or its convert.
To add a convert while you are creating a part
1 From the Design menu of the library's design manager window, choose New Part. The Part

Properties dialog box displays.
2 In the Edit Part Properties dialog box, enable Create Convert View.
3 Fill out the rest of the dialog box and choose the OK button. For more information, see 

Creating a part.
4 From View menu choose the Convert command.
5 Define the equivalent part and add the pins.
6 From the View menu, choose Package to see the convert.
7 From the File menu, choose Save (ALT, F, S).
To add a convert to an existing part
1 Open the part editor on the part.
2 From the View menu, choose the Package command.
3 From the Options menu, choose Package Properties. The Edit Part Properties dialog box 

displays.
4 Enable the Create Convert View option and choose the OK button.
5 From the View menu, choose the Convert command.
6 Define the equivalent part and add the pins.
7 From the View menu, choose Package to see the convert.
8 Save the part.

Related topics
About parts
Creating a part
Viewing converts
Creating multiple-part packages
Switching to a different open part
New Part command
Convert command



Creating a part alias
A part may come in several speed ratings or be made by several manufacturers. If all the 
variations have a common graphic and PCB footprint, you don't have to take the time and 
space to create and store a different library part for each variation. Instead, create a single 
library part, and assign it multiple aliases.
To create or add a part alias
1 From the design manager's Design menu, choose the New Part command (ALT, D, T).

or
From the part editor's Options menu, in package view, choose the Package Properties 
command (ALT, O, P).

2 Choose the Part Aliases button, then choose the New button.
3 Enter the new part alias in the Name text box,, and choose the OK button.
4 Choose the OK button as needed to dismiss the remaining open dialog boxes.



Switching between parts in a package
1 From the View menu, choose the Package command.
2 Double-click on the part you wish to edit.
or
1 From the View menu, choose the Part command.
2 From the View menu, choose the Next Part or Previous Part command.

Related topics
Creating multiple-part packages
Creating a part convert
New Part command



Using the part editor
In the part editor you can create or alter a part, symbol, or title block. The part editor is 
available to edit parts in a library or in a design.

General concepts
About parts
Part editor window
Part view and package view
Changing your view
Placing pins
Creating a shared pin
Placing an array of pins
Viewing parts in a package
Viewing converts
Printing and plotting
Printing or plotting a part
Editing a part on a schematic page
Editing library parts
Editing a part as you place it
Undoing and repeating actions
Creating multiple-part packages
Creating a part convert
Switching to a different open part
Searching for a part in the libraries
Opening a library created in SDT

Part properties
Working with properties
Defining properties
Editing properties
Using the spreadsheet editor
Exporting part and pin properties
Importing part and pin properties

Part graphics
Working with graphics, text, and bitmaps
Moving objects
Mirroring objects
Rotating objects
Selecting and deselecting objects
Copying selected objects
Deleting objects
Defining the part body



Defining the part body
When you create a new part, the part editor opens with an empty, rectangular part outline 
(the part body border) visible. The part body border expands to accommodate the graphic 
elements of the part body, and pins are constrained to the part body border.
If you want to change the size or shape of the part body border, you can select the border 
and drag the selection handles until the part body border is as you want it.
Pins, when you place them, are constrained to the part body border. If the edge of the part 
body coincides with this border, the pins are directly attached to the part body, but if the 
part body is inside this border, you must draw a line from the pin to the part body. You may 
place individual pins, or you may place an array of pins.
You define the part body using the tools available on the tool palette. All of these tools are 
also available on the Place menu. Using the Selection tool, you can select a placed element 
for editing.
To connect a pin to a non-rectangular part body
1 Place the pin on the part body border.
2 From the Options menu, choose the Preferences command, then choose the Grid Display 

tab.
3 In the Part and Symbol Editor group box, disable the Cursor Snap to Grid option.
4 Draw a line between the pin and the part body.
5 If the line does not look like the pin, edit the line's style and width.
6 From the Options menu, choose the Preferences command, then choose the Grid Display 

tab.
7 In the Part and Symbol Editor group box, enable the Cursor Snap to Grid option.
 
 

Related topics
Placing and editing text
Specifying text font and size
Moving and rotating text
Placing bitmaps
Creating graphics
Editing graphics
Drawing lines
Drawing rectangles and squares
Drawing circles and ellipses
Drawing arcs
Drawing polylines
Placing pins
Placing an array of pins



You can draw part bodies thicker than pins and the rest of the part by setting the line style 
on the graphic objects you want to be thicker.



You cannot move pin names or pin number text, but you can make all the pin names on a 
part invisible. In the part editor, double-click within the part editor, but not on any graphic 
element, in order to bring up the Edit Part dialog box. Change Pin Names Visible from True 
to False.



Creating a shared pin
You can make power and ground pins visible, and you can connect wires and other electrical 
objects to visible power and ground pins. This is a powerful capability, but may not be 
desirable in every case. To prevent power and ground pins from appearing on every part in a
multiple-part package, you can share them among the parts in the package. Capture 
displays shared pins only on the first part in the package.
To create a package of parts with shared pins
1 Create a multiple-part package.
2 Place the power and ground pins.
3 Assign the same name and number to pins you want to share.

For example, name the power pin POWER and make it pin number 1, and name the 
ground pin GROUND and make it pin number 0, on every part in the package.

Related topics
About shared pins
About power and ground pins
Creating multiple-part packages
Placing pins



Placing pins
When you place a pin, you can describe it completely. In order to place pins, you need to be 
in the Part view of the part editor.
If you want to place several identical pins that are not sequentially numbered on the part 
body border, the Pin tool is ideal. See Placing an array of pins if you wish to create multiple 
identical pins that are numbered sequentially on the part body border.
Pins, when you place them, are constrained to the part body border. If the edge of the part 
body coincides with this border, the pins are directly attached to the part body, but if the 
part body is inside this border, you must draw a line from the pin to the part body.
To place a pin
1 Verify that you are in the part view of the part editor.
2 From the Place menu, choose Pin (ALT, P, I). The Place Pin dialog box displays.
3 Edit the values as necessary.

Name The name can be up to 128 characters long and may include any character. If 
you place multiple copies of the pin and the name ends with a numeric 
component, that final numeric component increments by one with each 
successive pin you place.

Number The number can be up to 128 characters long and may include any character. 
If you place multiple copies of the pin and the number ends with a numeric 
component, that final numeric component increments by one with each 
successive pin you place.

Shape Select one; the choices are CLOCK, DOT, DOT CLOCK, LINE, SHORT, and ZERO 
LENGTH. If you select a pin type of POWER, the pin shape automatically is set 
to ZERO LENGTH.

Type Select one; the choices are 3STATE, BIDIRECTIONAL, INPUT, OPEN COLLECTOR,
OPEN EMITTER, OUTPUT, PASSIVE, and POWER. Pin type is used by the Design 
Rules Check tool to check electrical rules.

Width Select Scalar or Bus. If you choose Bus, the pin name must be of the form 
basename[m..n] where m..n specifies a range of decimal integers 
representing the number of bus members. For more information see Bus 
naming conventions.

Visibility If you are placing a power pin, you can select the Pin Visible box to cause the 
pin to cancel the pin's global attribute. This is useful if you want to create an 
isolated power net. If a power pin is visible, it must be connected to a wire. For
more information see About power and ground pins or Isolating power or 
ground.

4 When you have completely defined the pin, choose the OK button to dismiss the Pin 
Properties dialog box. The pin displays attached to the periphery of the part.

5 Use the mouse to move the pin to its intended location and click the left mouse button to 
place it. The pin displays in the selection color until you move the pointer.

6 If you want to place additional pins, repeat step 5. As you place successive pins, any final 
numeric component of the pin name or pin number increases by one. If you need to edit 
pin properties, leave the pin selected, then from the Edit menu choose the Properties 
command, make the changes in the Pin Properties dialog box, and choose the OK button.

7 When your pins are placed, select the selection tool, or press ESC, to dismiss the pin tool.
8 If the part body does not coincide with the part body border, draw a line from the pin's 

connection point to the part body. You may need to temporarily turn off the Snap to grid 



option (Options menu, Preferences command, Grid Display tab) while you draw the line.
 
 

Shortcut:
Tool palette:

Related topics
Defining properties
Placing an array of pins
Bus naming conventions
Editing properties
Working with properties
Pin shapes and types
New Property dialog box
Netlist format descriptions



Some netlist formats do not accept certain characters in pin names. See the description for 
the netlist format you want to use.



If you want an overbar over a signal name, follow each character in the name with a 
backslash (\).



Placing an array of pins
If the part you are creating includes a series of pins that vary only in pin number, placing a 
pin array is very convenient. A pin array is defined by a single set of electrical 
characteristics. If you wish to create multiple pins with identical properties and place them 
so that the pin numbers and names are sequentially arranged on the part body border, this 
tool is ideal.
Pins, when you place them, are constrained to the part body border. If the edge of the part 
body coincides with this border, the pins are directly attached to the part body, but if the 
part body is inside this border, you must draw a line from the pin to the part body.
To place a pin array
1 Verify that you are in the Part view of the part editor.
2 From the Place menu, choose Pin Array . The Place Pin Array dialog box displays.
3 Edit the values as necessary.

Starting name The starting name can be up to 128 characters long and may include 
any character. The leftmost or upper pin of the array is assigned the 
starting name. If the starting name ends with a numeric component, 
that component increments by the increment amount from top to 
bottom and from left to right.

Starting number The starting number can be up to 128 characters long and may 
include any character. The leftmost or upper pin of the array is 
assigned the starting number. If the final component of the starting 
number is numeric, the pin numbers change by the increment 
amount from top to bottom and from left to right

Number of pins An integer
Increment A positive or negative integer. Pin names and pin numbers that end 

with a numeric component are affected by the increment value. The 
numeric portion of the pin name or pin number changes by this 
amount from top to bottom or from left to right.

Pin spacing A positive value. The distance between the pins is measured in grid 
units.

Shape Select one; the choices are CLOCK, DOT, DOT CLOCK, LINE, SHORT, 
ZERO LENGTH. If you select a pin type of POWER, the pin shape 
automatically is set to ZERO LENGTH.

Type Select one; the choices are 3STATE, BIDIRECTIONAL, INPUT, OPEN 
COLLECTOR, OPEN EMITTER, OUTPUT, PASSIVE, POWER. Pin type is 
used by the Design Rules Check tool to check electrical rules.

4 When you have completely defined the array, choose the OK button to dismiss the Pin 
Properties dialog box. The array is attached to the periphery of the part; the part body 
border automatically increases in size if necessary.

5 Use the mouse to move the array to its intended location and click the left mouse button 
to place it. The array displays in the selection color until you move the pointer.

6 Select the selection tool to dismiss the pin tool.
8 If the part body does not coincide with the part body border, draw a line from the pins' 

connection points to the part body. You may need to temporarily turn off the Snap to grid 
option (Options menu, Preferences command, Grid Display tab) while you draw the lines.

 
 



Shortcut:
Tool palette:

Related topics
Defining properties
Placing pins
Pin shapes and types
Editing properties
Working with properties
New Property dialog box



You might want to use the Pin Array tool for placing large numbers of pins even though the 
properties or pin numbers vary. After placing the pins, you can select those you want to 
change, then from the Edit menu, choose the Properties command; this brings up the 
spreadsheet editor where you can easily edit the properties of many pins.



Viewing parts in a package
In this view, you can add and edit package properties, though parts are not available for 
editing. Use this view if you want to add properties that are the same for all parts in the 
package.
All packages include the following properties:

Name
Alphabetic or numeric part numbering
Homogeneous or heterogeneous type
Number of parts per package
Part reference prefix
Printed Circuit Board footprint
Aliases

To view all parts in a package
From the View menu, choose the Package command. An image of all parts in the 

package displays.

Related topic
About parts
Package command
Creating multiple-part packages
Editing package properties



Viewing part converts
You can use the convert of a part when one is available. If the part has no convert, the menu
item is unavailable. You can view a part convert in either part view or package view.
To view a part convert

From the part editor's View menu, choose Convert (ALT, V, C).
or
1 From the schematic page editor's Edit menu, choose Properties (ALT, E, S).
2 Select the Convert option, and choose the OK button.

Related topic
Creating a part convert
Convert command



Exporting part and pin properties
The Export Properties and Import Properties commands provide a means to edit properties of
parts and pins in a spreadsheet or database program, or in a text editor that preserves tab 
characters. You first export the properties to a property file, edit the property file in the 
application of your choice, then import the edited properties. See Editing property files for 
important information about the format and contents of a property file.
 
 

For a design, you can export all parts or just the parts in selected schematics and schematic 
pages. For a library, you can export all parts or just selected parts, but you cannot export 
part aliases. If you export and edit properties of a part which has aliases, the aliases reflect 
the changes.
You cannot select parts in the design cache or library cache for export.
You can add comments to document a property file; any text to the right of a semicolon (;) 
is ignored by the Import Properties tool.
To export part properties or part and pin properties
1 Open the library or design that holds the parts.
2 For a design, select the schematics or schematic pages containing the part you want to 

export.
or
For a library, select the parts to export.

3 From the Tools menu, choose the Export Properties command. The Export Properties 
dialog box displays.

4 In the dialog box, specify whether the property file is to include all parts or just those that 
are selected, and whether you want to export properties for pins as well as parts.

5 Choose the OK button to create the property file.

Related topics
Editing property files
Importing part and pin properties
Editing properties
Working with properties
Defining properties
Using the spreadsheet editor
Placing pins
Placing an array of pins
Pin shapes and types
Pin command
Export Properties command
Import Properties command



Importing part and pin properties
After you create a property file using the Export Properties command, you can use a 
spreadsheet, database, or word processing application to edit property values or to add or 
delete properties. See Editing property files for important information about the format and 
contents of a property file.
 
 
 

To import part properties or part and pin properties
1 Open the library or the design that holds the parts.
2 From the Tools menu, choose the Import Properties command. The Import Properties 

dialog box displays.
3 Select the property file. If the property file is not listed, do one or more of the following:

In the Drives box, select a new drive.
In the Directory box, select a new directory.
In the List Files of Types box, select the type of file you wish to open.

4 Choose the OK button to apply the properties.

Related topics
Editing property files
Exporting part and pin properties
Working with properties
Export Properties command



When you import the edited properties, Capture expects to find the schematic pages and 
parts unchanged. After you export properties, do not edit the design or library from which 
the properties were exported until after you import the changed properties. If you do, the 
Import Properties command will fail, and you will have to export and edit the properties 
again.



When you import the edited properties, Capture expects to find the schematic pages and 
parts unchanged. After you export properties, do not edit the design or library from which 
the properties were exported until after you import the changed properties. If you do, the 
Import Properties command will fail, and you will have to export and edit the properties 
again.



You can change part references by editing the References column of the property file, but in
a multiple-part package, the final element of the reference does not change. That is, 
changing U1A to U2B will result in the part reference U2A. This means that the designation 
of the part within the package does not change.



If Capture finds errors in the property file, the design or library remains unchanged. There is
no risk that some parts will be changed and others not.



Editing property files
When you export properties, Capture creates a tab-delimited list of keywords, identifiers, 
and properties, each of which is enclosed in double quotation marks. You can edit this file in 
a spreadsheet or database program, or even in a text editor (as long as the editor doesn't 
convert the tabs to spaces). Depending on which tool you use, you may see the property file
as rows and columns of cells or fields or as lines of text.
The property file starts with a line identifying the document as either a design or library. 
Most subsequent lines begin with a keyword and an identifier. There are a few restrictions on
the changes you can make in the property file:

You must not change or delete the first line.
You must not change or delete the first two fields in any line.
In logical view, you must not change the sequence or number of lines;

it is also a good idea not to change the sequence or number of lines in physical view or for 
libraries.

Do not delete a field from a HEADER line without also deleting the corresponding 
fields from subsequent lines.
 

Keeping these restrictions in mind, you can generally make the following changes:
Add a field to a HEADER line and subsequent lines (add a column).
Adds a property to parts and pins with a value in this field. The name of the property 

is the string in the HEADER line. The value assigned to the part or pin is the string in the 
corresponding field. If the corresponding field is empty, Capture adds a property with no 
value and displays the property name as a place holder.

Delete a field from a HEADER line and subsequent lines (delete a column).
Has no effect on any part or pin. Deleting columns for properties you don't want to 
change may make the property file easier to edit.
If you delete a field from a HEADER line without also deleting the corresponding fields 
from subsequent lines, Capture reports an error when you import the property file.

Change the value of a field.
Resets the value of the property on all parts or pins with that property.

Part or pin has
the property

Part or pin does not
have the property

Field is
not empty

Property gets 
specified value

Property is added
with specified value

Field is empty Capture shows 
{Property Name}
as place holder
(when the property
is visible)

Part or pin is not affected

 
 

Related topics
Property file keywords
Sample property files



If you add, delete, or reorder lines in a design property file created in logical view, the file 
cannot be imported.

If you move a PART line in a design property file created in physical view or in a library 
property file, be sure to move all the PIN lines associated with it, and keep them in the 
same order; otherwise, importing the file may fail or cause unwanted changes to your 
design or library.

In every case, it is much safer to make changes without adding, deleting, or reordering the 
lines in a property file.



If you add, delete, or reorder lines in a design property file created in logical view, the file 
cannot be imported.

If you move a PART line in a design property file created in physical view or in a library 
property file, be sure to move all the PIN lines associated with it, and keep them in the 
same order; otherwise, importing the file may fail or cause unwanted changes to your 
design or library.

In every case, it is much safer to make changes without adding, deleting, or reordering the 
lines in a property file.



It is a good idea to update part references in the active view (logical or physical) before you
export properties.

Because various popular spreadsheet and database applications behave differently, 
Capture can import properties with or without enclosing quotation marks around each field 
in the property file. The fields must be tab-delimited, though---all other characters, 
including commas and leading and trailing spaces, are treated as part of a field's text. Be 
sure your spreadsheet or database program can save in this format.



Be sure the same view is active when you import properties as when you export them.



Be sure the same view is active when you import properties as when you export them.



Property file keywords
Capture property files contain the following keywords:

DESIGN
Identifies the property file as describing a design; specifies the path and filename of the 
design; identifies the view active when the properties were exported.

LIBRARY
Identifies the property file as describing a library; specifies the path and filename of the 
library.

HEADER
In physical view, lists all the properties for the parts and pins in the design.
In logical view, lists all the properties for the parts and pins on the current schematic 
page---there is a new HEADER line for each schematic page.

PAGE
In logical view, identifies the current schematic page.
(Not present in physical view.)

PART
Identifies the current part and lists its properties. A column without a value signifies that 
the property does not apply to the part, or that no value is assigned.

PIN
Identifies a pin on the current part and lists its properties. A column without a value 
represents either a missing property or a property with an empty string for the value. A 
column without a value signifies that the property does not apply to the pin, or that no 
value is assigned.

SYMBOL
Identifies a symbol and lists its properties. A column without a value signifies that the 
property does not apply to the symbol, or that no value is assigned.

Related topics
Sample property files
Editing property files
Editing properties



Sample property files

For a design (in logical view)

In logical view, Capture reports a schematic page only once, no matter how many places it is
used in the design; Capture reports a part only as many places as it is used in each page. In 
this example, there are four instances of the FULLADD part, because it is used in four places 
on the 4BIT page, and two instances of the HALFADD part, because it is used in two places 
on the FULLADD page. Note the separate HEADER line for each page. (Compare physical-
view design property files. See also library property files.)

"DESIGN" "C:\CAPTURE\SAMPLES\4BIT.DSN" "LOGICAL"
"PAGE" "1" "4BIT"
"HEADER" "ID" "Reference" "Value"
"PART" "INS10" "fulladd_1" "FULLADD"
"PIN" "0{X}"
"PIN" "1{Y}"
"PIN" "2{SUM}"
"PIN" "3{CARRY_IN}"
"PIN" "4{CARRY_OUT}"
"PART" "INS99" "fulladd_2" "FULLADD"
"PIN" "0{Y}"
"PIN" "1{CARRY_OUT}"
"PIN" "2{SUM}"
"PIN" "3{CARRY_IN}"
"PIN" "4{X}"
"PART" "INS100" "fulladd_3" "FULLADD"
"PIN" ...
  :
"PART" "INS101" "fulladd_4" "FULLADD"
"PIN" ...
  :
"PAGE" "1" "FULLADD"
"HEADER" "ID" "Reference" "Value"
"PART" "INS10" "halfadd_A" "HALFADD"
"PIN" ...
  :
"PART" "INS11" "halfadd_B" "HALFADD"
"PIN" ...
  :
"PAGE" "1" "HALFADD"
"HEADER" "ID" "Reference" "Value"
"PART" "INS10" "U?" "74LS04"
"PIN" ...
  :

For a design (in physical view)

In physical view, Capture reports a part once for each place it is used in the design. In this 
example, there are four occurrences of the FULLADD part and eight occurrences of the 
HALFADD part. Note that there is no concept of pages in physical view, so one HEADER line 
applies to the entire design. (Compare logical-view design property files. See also library 
property files.)

"DESIGN" "C:\CAPTURE\SAMPLES\4BIT.DSN" "PHYSICAL"
"HEADER" "ID" "Reference" "Value"



"PART" "32" "fulladd_1" "FULLADD"
"PIN" "0{X}"
"PIN" "1{Y}"
"PIN" "2{SUM}"
"PIN" "3{CARRY_IN}"
"PIN" "4{CARRY_OUT}"
"PART" "152" "fulladd_4" "FULLADD"
"PIN" "0{X}"
"PIN" "1{Y}"
"PIN" "2{CARRY_OUT}"
"PIN" "3{CARRY_IN}"
"PIN" "4{SUM}"
"PART" "272" "fulladd_3" "FULLADD"
"PIN" ...
  :
"PART" "392" "fulladd_2" "FULLADD"
"PIN" ...
  :
"PART" "54" "halfadd_B" "HALFADD"
"PIN" ...
  :
"PART" "103" "halfadd_A" "HALFADD"
"PIN" ...
  :
"PART" "69" "U?" "74LS04"
"PIN" ...
  :
"PART" "74" "U?" "74LS08"
"PIN" ...
  :
"PART" "80" "U?" "74LS04"
"PIN" ...
  :
"PART" "85" "U?" "74LS32"
"PIN" ...
  :
"PART" "174" "halfadd_B" "HALFADD"
"PIN" ...
  :
"PART" "223" "halfadd_A" "HALFADD"
"PIN" ...
  :
"PART" "189" "U?" "74LS04"
"PIN" ...
  :
"PART" "194" "U?" "74LS08"
"PIN" ...
  :
"PART" "200" "U?" "74LS04"
"PIN" ...
  :
"PART" "294" "halfadd_B" "HALFADD"
"PIN" ...
  :
"PART" "343" "halfadd_A" "HALFADD"
"PIN" ...



  :
"PART" "309" "U?" "74LS04"
"PIN" ...
  :
"PART" "314" "U?" "74LS08"
"PIN" ...
  :
"PART" "414" "halfadd_B" "HALFADD"
"PIN" ...
  :
"PART" "463" "halfadd_A" "HALFADD"
"PIN" ...
  :
"PART" "429" "U?" "74LS04"
"PIN" ...
  :

For a library

For a library, Capture reports each part in the library. (See also logical-view design property 
files and physical-view design property files.)

"LIBRARY""C:\CAPTURE\SAMPLES\INTEL.OLB"
"HEADER" "ID" "Reference"
"PART" "80186.Normal"
"PIN" "X1"
"PIN" "X2"
"PIN" ...
  :
"PART" "80188.Normal"
"PIN" "X1"
"PIN" ...
  :
"PART" "80286.Normal"
"PIN" ...
  :
"PART" "80287.Normal"
"PIN" ...
  :
"PART" "8031.Normal"
"PIN" ...
  :
"PART" "8032.Normal"
"PIN" ...
  :
"PART" "80386.Normal"
"PIN" ..
  :
"PART" "80386SX.Normal"
"PIN" ...
  :

Related topics
Keywords
Editing property files



This abbreviated sample of a property file is formatted for presentation. As plain text, the 
columns do not actually line up as shown. In a spreadsheet or database program, fields 
may wrap or appear to be truncated.



Working with libraries
In Capture, a library is a file that stores parts, symbols, title blocks, and schematics. Capture 
provides more than 80 libraries, and you can create additional custom libraries to store any 
combination of items. If you edit a library provided by Capture, you should give it a custom 
name so that you will not copy over your changes when you receive updated libraries.
You can, for example, create a library to hold all your programmable logic devices, or to hold
schematic pages that you use often. There is no need to create a library for a particular 
design, because the design cache holds all the parts and symbols used in the design.
Because a library is a file, you can work with it in the Windows File Manager as well as in 
Capture.
It is recommended that, rather than editing parts in libraries provided by OrCAD, you copy 
the part and make the changes in a custom library. If you do edit a library provided by 
OrCAD, it is important that you assign a new library name (from the File menu, choose Save 
As) so that your changes are not overwritten when you update or upgrade your software.
 

Related topics
Working with designs, schematics and schematic pages
Browsing a design or a library
Creating a library
Creating a part
Saving library changes
Creating connectivity symbols
Creating a custom title block
Moving parts or symbols between libraries 
Copying a part from the design cache to a library 
Saving in SDT format
Open Library command
New Library command



Schematics and schematic pages cannot be created in a library, but can be copied or 
moved to a library from a design. Schematics and schematic pages can also be edited in a 
library.



Creating a library
Libraries store parts, symbols, custom title blocks, as well as schematics and the schematic 
pages contained in them. With Capture, you can have as many libraries as you wish to suit 
any purpose, and you can specify the name and storage location of your library. Each library 
is available to any design.
Library size is limited only by the amount of space on your system's hard disk; however 
large libraries take longer to load. If speed becomes an issue, consider creating several 
smaller libraries, instead.
To create a new library

From the File menu, choose New, then select Library (ALT, F, N, L). The design manager 
displays a new library with a system-generated name. The first time you save the library, 
the Save As dialog box displays, giving you the opportunity to specify a drive and replace 
the system-generated name.
To rename a library
1 In the design manager's design structure pane, select the library.
2 From the File menu, choose Save As (ALT, F, A).
3 Enter a name in the File Name text box. A filename can contain up to eight characters and

an extension of up to three characters. OLB is the recommended extension for library 
files.

4 Choose the OK button to return to the design manager.
or

Use the Windows File Manager.
To specify the storage location for a library
1 In the design manager's design structure pane, select the library.
2 From the File menu, choose Save As.
3 Select the drive and directory in which you want to store the library.
4 Choose the OK button to return to the design manager.
 

Related topics
Editing library parts
Editing a part as you place it
Creating a part
Creating connectivity symbols
Creating a custom title block
Saving library changes
Saving in SDT format
New Library command



Opening a library
To open a library
1 From the File menu, choose the Open command, then choose the Library command. The 

Open Library dialog box displays.
2 Select the library you wish to open. If the library file is not listed, do one or more of the 

following:
In the Drives box, select a new drive.
In the Directory box, select a new directory.
In the List Files of Types box, select the type of file you wish to open.

3 Choose the OK button. The design manager window opens; the library parts are displayed
in the design structure pane.

To open a recently used library
From the File menu, choose the name of the library you want to open.

 

Shortcut
Tool palette:

Related topics
Opening a library created in SDT
Open Library command
1, 2, . . . command



If you open an SDT library, Capture prompts you to save the library.



Saving library changes
Changes you make to a part are temporary until you save the part or the library to disk 
using one of the commands of the File menu. When you save a library, you are saving all the
parts and symbols residing in the library. If you have several parts or symbols open in the 
part editor, changes you have made to any of them are saved.
If the library is new and has not yet been saved, the Save As dialog box displays, giving you 
the opportunity to specify a drive and replace the system-generated name.
To save a part or symbol

From the File menu of the part editor, choose the Save command (ALT, F, S). The active
library or the library that holds the active part is saved.
To save a library

From the File menu of the design manager, choose the Save command (ALT, F, S). The 
active library or the library that holds the active part is saved.
To save all open libraries

From the File menu, choose the Save All command. Any open libraries that have been
modified, and any open designs, are saved.
To rename a part
1 In the design manager, select the part.
2 From the Design menu, choose the Rename command. The Rename dialog box displays.
3 Enter the new name and choose the OK button.
 
 

Related topics
Moving parts between libraries
Renaming a document
Copying a schematic to or from a library
Copying a schematic page to a library
Saving in SDT format
Creating a library



The Save All command is available only if an open design or library has been modified.



Moving parts or symbols between libraries
You can store parts or symbols in any library you wish. You can create libraries that have a 
special purpose. You may wish to transfer some parts or symbols from one library to another
and you may wish to store some parts or symbols in multiple libraries. If you move a part 
that has part aliases, the part aliases also move.
A part that is open in an editor cannot be moved or copied.
To move parts between libraries
1 Verify that the parts are not open in the part editor or the spreadsheet editor.
2 In the design manager, select the parts you wish to move.
3 From the Edit menu, choose the Cut command, or if you wish to have a copy of the parts 

in both libraries, choose the Copy command.
4 Open the library that will hold the part and click the left mouse button in the design 

structure pane.
5 From the Edit menu, choose the Paste command.
or
1 Verify that the parts are not open in the part editor or the spreadsheet editor.
2 In the design manager, open both libraries.
3 Drag and resize the two design manager windows so that each is visible.
4 Select the parts that you wish to move, then drag them to the design structure pane of 

the second library's design manager window. If you wish to have a copy of the parts in 
both libraries, press and hold CTRL while you are dragging.

To create a part using an existing part
1 Follow the procedure above to create a copy of the part in another library.
2 If you want to move the new part to the same library as the original:

From the Design menu, choose the Rename command and give the new part's a 
different name.

Follow the procedure above to drag the new part to the original library.

Related topics
Renaming a document
Using drag and drop with documents
Copying a part from the design cache to a library 
Cut command
Copy command
Paste command



If you edit a library provided by OrCAD, it is important that you assign a new library name 
so that your changes are not overwritten when you upgrade or update your software.



If you edit a library provided by OrCAD, it is important that you assign a new library name 
so that your changes are not overwritten when you upgrade or update your software.



Saving part changes
Changes you make to a part or a symbol are temporary until you use one of the Save 
commands of the File menu to save to disk. If you save one part, only the changes to that 
part are saved; if you save a library while you have several parts open in part editor 
windows, changes you have made to any of them are saved
To save a part or symbol

From the File menu of the part editor, choose the Save command.
To save a library

From the File menu of the library's design manager window, choose the Save 
command.
 

Related topics
Moving parts between libraries
Save command
Save As command





Selecting and deselecting objects
You select objects to edit, move, or alter them in any way. You can simultaneously alter 
multiple objects if they are all in the selection set. Objects that are selected display in the 
selection color.
To select an object

Position the pointer on the object, then click the left mouse button or press the space 
bar. The object displays in the selection color.
 

To add another object to a selection set
Position the pointer over the object and press CTRL while you click the left mouse 

button. All objects in the selection set display in the selection color. In the spreadsheet 
editor, this selection method is unavailable because the selection set is limited to contiguous
cells.
To select all objects in an area
1 From the tool palette, choose the selection tool.
2 Move the pointer to one corner of the area. Press and hold the left mouse button while 

you drag the pointer to the opposite corner, then release the left mouse button. Every 
object in the selection set displays in the selection color and the set behaves as one 
object.

To select an entire contiguous wire or polyline
1 From the tool palette, choose the selection tool.
2 Press and hold the left mouse button while you drag the pointer to select an area that 

includes some portion of the line or wire.
To select all objects on a schematic page or a part

From the Edit menu, choose the Select All command (ALT, E, L).
To select from among overlapping objects

Position the pointer over the stack and press the TAB key while you click the left 
mouse button. This cycles through the objects in the stack.
To select all portions of a net on one schematic page
1 Select one segment of the net.

The segment changes color.
2 Click the right mouse button to display a context-sensitive menu.
3 From the popup menu, choose the Select Entire Net command.
To select all contiguous segments of a net
1 Select the selection tool.
2 Press and hold the left mouse button while you create a block that encloses any portion of

the net.
To deselect the selected objects

Click an area where there is no object or part. Note that a part occupies a rectangular
area encompassing all its graphics and property text; this means that a part may occupy a 
larger area than is apparent.

To add or remove an object from the selection set
Move the pointer over the object, and press CTRL while you click the left mouse 



button.
To change the selection color
1 From the Options menu, choose Preferences (ALT, O, P) and then choose the Colors tab.
2 Click the left mouse button over the Selection color. The color palette window opens.
3 Select the new color and choose the OK button to dismiss the color palette.
4 Choose the OK button to dismiss the dialog box.

Related topics
Group command
Ungroup command
Delete command
Select All command
Preferences command
Select Entire Net command



You may wish to group the selection set. A selection set that is grouped cannot be 
accidentally deselected and broken apart. Note that when you move grouped objects, you 
break any physical connections to objects outside the group.



If you select a wire by a vertex, the entire contiguous wire is highlighted and the selected 
vertex is double highlighted. If you select a wire by a segment, the contiguous wire is 
highlighted with the two adjacent vertices double highlighted.



You can specify whether the selection set includes all objects intersected by your selection 
rectangle or only those objects fully enclosed by the selection rectangle. From the Options 
menu, choose the Preferences command, and then choose the Select tab.



When you click on a wire, all the graphical handles (vertices) on the wire are highlighted, 
but only the segment on which you click is actually selected.



To deselect an object that you have just placed, you must select the selection tool or press 
ESC before clicking the mouse.



Moving objects
You can easily change the location of objects in the schematic page editor or the part editor. 
Immediately after you place an object, you need to select the selection tool or press ESC 
before you perform the steps below.
To move an object using the mouse

Position the pointer on the object. Press the left mouse button and drag the object to 
the new location.
To move objects using the Cut command
1 Select the object or objects.
2 From the Edit menu, choose the Cut command (ALT, E, T). The object is placed on the 

Clipboard.
3 If the object is to be moved to another window, open that window.
4 From the Edit menu, choose Paste (ALT, E, P). The object is attached to the pointer.
5 Move the pointer to the location where you wish to place the object and click the left 

mouse button. The object displays in the selection color.
6 Click an area where there are no parts or objects in order to deselect the object.

Related topics
Selecting and deselecting objects
Rotating objects
Mirroring objects
Cut command
Paste command
Rotate command
Mirror command



If there are electrically connected objects, the connects are rubberbanded. To break the 
connections, press ALT and hold it down while you move the objects, or group the objects 
before you move them---connections to objects outside the group are broken.



Mirroring objects
Capture objects can be mirrored horizontally, vertically, or both horizontally and vertically. 
Some objects, such as text and bitmaps, cannot be mirrored.
To mirror objects
1 Select the objects.
2 From the Edit menu, choose Mirror (ALT, E, M). If the commands of the pull-right menu are 

not available, the objects cannot be mirrored.
3 Choose Horizontally, Vertically or Both. The objects flip in the indicated direction.

Related topics
Selecting and deselecting objects
Moving objects
Rotating objects
Rotate command
Mirror command



Rotating objects
Capture objects can be rotated by 90 degree increments. Some objects, such as bitmaps, 
cannot be rotated.
To rotate objects
1 Select the objects.
2 From the Edit menu, choose Rotate (ALT, E , O). The selection set rotates 90 degrees 

counterclockwise. If the Rotate command does not appear on the Edit menu, the objects 
cannot be rotated.

Related topics
Selecting and deselecting objects
Moving objects
Moving and rotating text
Mirroring objects
Rotate command
Mirror command



Copying selected objects
Capture uses the Windows Clipboard to support the standard Cut, Copy, and Paste functions.
You can cut, copy and paste information across schematic page or part windows. You can 
copy text from other Windows applications and paste it into Capture text boxes using the 
Clipboard. You can also copy a section of your schematic page to another Windows 
application.
To copy objects using the mouse
1 Select the object or objects.
2 Press and hold both CTRL and the left mouse button while you drag the object to its second

location.
3 Release the left mouse button to place the copy.
To copy objects using the Copy command on the Edit menu
1 Select the object or objects.
2 From the Edit menu, choose the Copy command (ALT, E, C). The object is placed on the 

Clipboard.
3 If the object is to be copied to another window, open that window.
4 From the Edit menu, choose Paste (ALT, E, P). The object is attached to the pointer.
5 Move the pointer to the location where you wish to place the object and click the left 

mouse button. The object displays in the selection color.
6 Click an area where there are no parts or objects in order to deselect the object.
7 If you want to place another copy of the object, repeat steps 4, 5, and 6 above.
To copy text or graphics into other Windows applications
1 Select the text or graphic.
2 From the Edit menu, choose Copy. The selected objects are copied to the clipboard
3 Open the other Windows application and use that application's Paste command to place 

the clipboard contents.

Shortcuts
Toolbar:

Related topics
Selecting and deselecting objects
Editing graphics
Importing text
Placing and editing text
Repeat command



Deleting objects
To delete objects

Select the objects and press DELETE or BACKSPACE.
or
1 Select the objects.
2 From the Edit menu, choose the Delete command (ALT, E, D).
To delete a schematic, schematic page, or part
1 Select the document or documents in the design structure pane of the design manager.
2 From the Design menu, choose the Delete command.

or
Press DELETE or BACKSPACE.

Related topics
Selecting and deselecting objects
Delete command (Design menu)



Undoing and repeating actions
If you make a mistake, you can use the Undo command. If you change your mind again, you 
can use the Redo command. If you want to repeat an edit, you can use the Repeat 
command. For example, let's say you move a selected object 5 grid units. Then you realize 
you also need to move a different object the same distance and direction---just select the 
second object and choose the Repeat command.
You can also use the Repeat to simplify multiple-step processes. For example, to tie into a 
sixteen-signal bus, you must place and name sixteen wires. With the Repeat command, this 
is easier than it sounds. Place one wire, and name it as the first signal in the bus. Then 
select the wire and the alias, and hold the CTRL key down as you drag a copy a small distance
away. Capture increments the numeric portion of the alias automatically. Then use the 
Repeat command fourteen times to place the rest of the wires. You can use the Repeat 
command to place sixteen bus entries, too.
You can use the Undo, Redo, and Repeat commands on the following actions:

Placing objects (except no-connects)
Deleting objects (Undo and Redo commands only)
Copying objects
Moving objects
Resizing objects
Rotating objects
Mirroring objects

To undo an action
From the Edit menu, choose Undo (ALT, E, U).

To undo an Undo command
From the Edit menu, choose Redo (ALT, E, E).

To repeat a command
Perform the command once, then choose Repeat from the Edit menu (ALT, E, R).

To repeat a place operation
1 Place the first object or set of objects at the first location.
2 Select the objects to copy, press CTRL, and drag the selection set to the second location.

or
Skip this step---Capture will offset the copy by one grid unit.

3 Leave the object selected.
4 From the Edit menu, choose the Repeat command. Another copy is placed at the same 

offset.
5 Repeat step 4 for any additional copies you want.

Shortcut
Toolbar:  (Undo)

 (Redo)

Related topics
About bus connections
Bus naming conventions
Labeling a net, bus, or bus member
Eliminating unique properties of your physical view



Removing part reference assignments
Undo command
Redo command
Repeat command



Searching a design
In Capture, you can browse a design-wide list of all objects of one type; you can search for 
an object by name, or by one of its property values; and you can search a specific schematic
page or an entire design.
In the design manager window, Capture will browse for the following object types:

Parts
Nets
Hierarchical ports
Off-page connectors
Bookmarks
DRC markers

The Find command searches for these object types or for comment text.
To list all objects of one type
1 In the design manager's design structure pane, select the documents you want to search. 

To search the entire design, select all schematics.
2 From the Edit menu, choose the Browse command (ALT, E, B), then choose the object type 

from the pull-right menu. The browse pane displays a list of all objects of the selected 
type.

3 If you wish to display an object, double-click on the entry in the browse pane. The 
schematic page editor opens and the object displays in the selection color.
or
If you wish to edit the properties of one or more listed objects, then from the Edit menu 
choose the Properties command to display the spreadsheet editor.

To limit the list of objects
1 In the design manager's design structure pane, select the documents you want to search. 

To search the entire design, select all schematics.
2 From the Edit menu, choose the Find command (ALT, E, F). The Find dialog box displays.
3 Enter a text string that defines the object you seek. This could be the name, alias, or 

property value. You can use the standard "*" and "?" wildcard characters.
4 Verify that the Match Case option is as you want it.
5 Select the object type and choose the OK button. The browse pane displays a list of a 

objects that meet the criteria you've specified.
6 If you wish to display an object, double-click on the entry in the browse pane. The 

schematic page editor opens and the object displays in the selection color.
or
If you wish to edit the properties of one or more listed objects, then from the Edit menu 
choose the Properties command (ALT, E, S) to display the spreadsheet editor.

To search a schematic page
1 Open the schematic page editor on the schematic page.
2 From the Edit menu, choose the Find command. The Find dialog box displays.
3 Enter a text string that defines the object you seek. This could be the name, alias, or 

property value. You can use the standard "*" and "?" wildcard characters.
4 Verify that the Match Case option is as you want it.
5 Select the object type and choose the OK button. The object displays in the selection 

color.



Related topics
Browsing a design or a library
Searching for a part in the libraries
Searching for part text or pins
Using the spreadsheet editor



Working with graphics, text, and bitmaps
In Capture, you can easily create and change symbolic elements of your design. You can 
place comment text, create graphics, or incorporate images into your part or your schematic
page. In the schematic page editor, these editing capabilities are available only in logical 
view.

Working with text
Placing and editing text
Specifying text font and size
Moving and rotating text
Importing text
Exporting text
Placing bitmaps

Working with graphic elements
Overview of graphics creation
Drawing lines
Drawing rectangles and squares
Drawing circles and ellipses
Drawing arcs
Drawing polylines
Placing bitmaps
Editing graphics
Moving objects
Rotating objects
Mirroring objects
Copying selected objects



Placing and editing text
You may have comment text, in the font of your choice, on a schematic page or a part. Use 
the text tool to document your schematic or to place the logic definition for a programmable 
logic device.
To add comment text to a part or a schematic page
1 From the Place menu, choose Text (ALT, P, T).
2 Enter the text in the dialog box that displays.
3 Complete the dialog box selections; you can specify the font, color, or rotation.
4 Choose the OK button to dismiss the dialog box. A rectangle representing the text is 

attached to the pointer.
5 Use the mouse to move the text. Click the left mouse button to place the text at the 

desired location.
 

Shortcut
Tool palette:

To edit text display properties
1 Select the text.
2 From the Edit menu, choose the Properties command (ALT, E, S).
3 In the dialog box that displays, change the font, color, or rotation, then choose the OK 

button.

Shortcut
Mouse: Double-click the text you wish to edit.

Related topics
Moving and rotating text
Specifying text font and size
Replacing text
Text command



You can place multiple copies of the text. Just click the left mouse button at each location 
where you would like text. When you are through placing text, select the selection tool or 
press ESC.



You can create multiple lines within a text object by pressing CTRL+ENTER to create the 
new line. This is useful for creating piped PLD commands without having to place multiple 
lines of text. Piped SPICE commands must be placed as separately placed lines of text.



Specifying text font and size
You may want text to have a distinctive appearance, or to fit a specific space. Capture 
supports TrueType fonts. You can preview a sample of the selected font before you choose it.
You can also select the default font that you have established in the Fonts tab of the Design 
Template dialog box.
To specify font
1 If you are placing the text, then from the Place menu, choose Text (ALT, P, T). The Place Text

dialog box displays.
or
If the text has already been placed, then double-click on the text. The Edit Text dialog box 
displays.

2 In the Font group box, choose the Change button. The Font dialog box displays.
3 Select a font, a font style, or a size. Sample text displays in the Sample group box.
4 Choose the OK button to close the Font dialog box.

Shortcut
Tool palette:

Related topics
Moving and rotating text
Placing and editing text



Moving and rotating text
You can change the location and the orientation of comment text at any time.
To move text
1 Select the text.
2 Drag the text to the new location.
3 Click an area where there are no parts or objects in order to deselect the text.
To rotate text
1 Select the text.
2 From the Edit menu select Rotate (ALT, E, O). The text rotates 90 degrees counterclockwise.
3 Repeat step 2 as necessary.
4 Click an area where there are no parts or objects in order to deselect the text.

Related topics
Specifying text font and size
Placing and editing text



Replacing text
The content of text that you place in the schematic page editor or the part editor can be 
easily changed. You can enter the replacement text using the keyboard, or if you wish, you 
may copy the replacement text from another application.
To replace text
1 Select the text you want to replace.
2 From the Edit menu, choose the Properties command (ALT, E, S). The Edit Text dialog box 

displays with the text highlighted.
3 Enter the replacement text or press CTRL+V to paste text from the clip board, then choose 

the OK button.

Related topics
Placing and editing text
Specifying text font and size
Shortcuts
Copy command



Importing text
You can import text from any Windows program that copies text to the Clipboard. This is 
especially useful to simplify creation of a programmable logic device.
To copy text from other Windows applications
1 In the other Windows application, copy the text to the clipboard using that program's 

Copy command.
2 Activate the Capture schematic page editor or part editor.
3 From the Place menu, choose the Text command (ALT, P, T). The Place Text dialog box 

displays.
4 Press CTRL+V to paste the text into the text box, then verify that the color, font, and 

rotation are as you want them and choose the OK button. A rectangle representing the 
text is attached to your pointer.

5 Use the mouse to move the text. Click the left mouse button to place the text at the 
desired location.

Related topics
Placing and editing text
Exporting text
Shortcuts
Cut command
Copy command
Paste command



Exporting text
You can export Capture text to any application that features the Windows Clipboard.
To export text using the clipboard
1 In Capture, select the text you wish to export.
2 From the Edit menu, choose the Cut (ALT, E, T) or Copy (ALT, E, C) command. The text is 

placed on the Windows clipboard.
3 Activate the other Windows application and use that application's Paste command to 

place the text.

Related topics
Importing text
Export Selection command
Import Selection command
Placing and editing text
Cut command
Copy command
Paste command



Editing graphic elements
When you find that a graphic is not just as you would wish, you need not delete it and start 
from scratch; you can edit it. A selected object displays in the selection color and has edit 
handles at the four corners. You can resize the object by moving a corner or change its 
location by moving a side.
To change the dimensions of a graphic object
1 Select the object. The object displays in the selection color with edit handles at the 

corners or ends.
2 Position the pointer over an edit handle and drag the edit handle. The object's size and 

shape change to accommodate the new corner or end location.
To move a graphic object
1 Select the object. The object displays in the selection color with edit handles at the 

corners or ends.
2 Position the pointer over the object or it's selection box, but not over an edit handle, and 

drag the object to the new location.
To edit the properties of a graphic object
1 Select the object. The object displays in the selection color.
2 From the Edit menu, choose the Properties command (ALT, E, S).
3 In the dialog box that displays, make the changes you want then choose the OK button to 

dismiss the dialog box.

Shortcut
Mouse: Double-click

Related topics
Selecting and deselecting objects
Creating graphics
Drawing lines
Drawing rectangles and squares
Drawing circles and ellipses
Drawing arcs
Drawing polylines
Moving objects
Rotating objects
Mirroring objects



If you want to move a point and constrain the object by the orthogonality rules, select the 
point and drag it while holding down the SHIFT key.



Creating graphics
You can create a wide variety of graphic shapes for your parts or to add to your schematic 
page. You can work with the snap-to-grid option turned on or turned off. For close work, you 
may want to try zooming in on your graphic. To draw very precisely, use the Go To command
on the View menu.
Before you begin drawing, you may want to specify default line and fill styles because all 
lines and shapes you draw adopt the current line style and closed shapes adopt the current 
fill style. You can use a variety of line or fill styles for any schematic page or part.
To change the snap-to-grid option

From the Options menu, choose the Preferences command (ALT, O, P), then choose the 
Grid Display tab. You set the option separately for the schematic page editor and the part 
editor.
To set a default line style
1 From the Options menu, choose the Preferences command and then choose the 

Miscellaneous tab.
2 Click on the Line Style and Width drop box to display the options. Note that you can 

specify separate options for the schematic page editor and the part editor.
3 Select one of the options and choose the OK button. Any lines or shapes you draw will 

have this line style.
To define a default fill
1 From the Options menu, choose the Preferences command and then choose the 

Miscellaneous tab.
2 Click on the Fill Style drop box to display the options. Note that you can specify separate 

options for the schematic page editor and the part editor.
3 Select one of the options and choose the OK button. Any closed shapes you draw will 

have this fill style.
To edit line style or fill style of a placed object
1 Select the object.
2 From the Edit menu, choose the Properties (ALT, E, S) command.
3 Select another line style or fill style in the dialog box that displays, then choose the OK 

button.
To draw an object
1 From the Place menu, choose the appropriate drawing command or select the appropriate

drawing tool from the tool palette.
2 Use the mouse to draw the object. To constrain the object by the orthogonality rules, 

press and hold the SHIFT key while you draw. For specific drawing instructions, see the 
Related topics below.

Related topics
Drawing lines
Drawing rectangles and squares
Drawing circles and ellipses
Drawing arcs
Drawing polylines
Placing bitmaps
Placing and editing text



Drawing lines
You use the line tool to draw a single line. The line you draw adopts the current line style. For
information on setting the line style, see Creating graphics.
If you wish to draw a line with multiple contiguous segments, the polyline tool is very 
convenient.
To draw a line segment
1 From the Place menu, choose Line (ALT P, L).
2 Move the pointer to the line's beginning.
3 Press and hold the left mouse button while moving the mouse to draw the line. To 

constrain the line orientation to multiples of 90 degrees, press SHIFT while you draw.
4 Release the left mouse button to end the line. The line displays in the selection color.
5 Click an area where there are no parts or objects in order to deselect the line.
6 Select the selection tool or press ESC to dismiss the line tool.

Shortcut
Tool palette:

Related topics
Creating graphics
Drawing polylines
Drawing rectangles and squares
Drawing circles and ellipses
Drawing arcs
Line command



Drawing rectangles and squares
You use the rectangle tool to create orthogonal shapes; if you wish to create a polygon, use 
the polyline tool. You can create a square simply by pressing SHIFT while you are drawing.
Any rectangles or squares you create will have the current fill style and line style. For 
information concerning line style and fill style, see Creating graphics.
To draw a rectangle or a square
1 From the Place menu, choose Rectangle (ALT P, R).
2 Move the pointer to one corner of the intended rectangle.
3 Press and hold the left mouse button while you drag the mouse. The rectangle will change

shape as you move the mouse. Release the left mouse button when you have the right 
shape. If you want to draw a square, hold the SHIFT key while you perform this step. The 
rectangle displays in the selection color.

4 Click an area where there are no parts or objects in order to deselect the rectangle.
5 Select the selection tool or press ESC to dismiss the line tool.

Shortcut
Tool palette:

Related topics
Creating graphics
Drawing circles and ellipses
Drawing arcs
Drawing polylines
Placing bitmaps
Drawing lines
Rectangle command



Drawing circles and ellipses
You use the ellipse tool to draw a full circle; if you wish to draw an arc, use the arc tool. To 
constrain the ellipse to a circle, you simply hold SHIFT while you drag the mouse.
Because they are closed shapes, circles and ellipses will have the current fill style. They will 
also have the current line style. For information concerning line style and fill style, see 
Creating graphics.
To draw an ellipse or a circle
1 From the Place menu, choose Ellipse (ALT P, S).
2 Move the pointer to an edge of the intended ellipse.
3 Press and hold the left mouse button while dragging the mouse. The ellipse will change 

shape as you move the mouse. If you wish to draw a circle, hold the SHIFT key while you 
perform this step. Release the left mouse button when you have the right shape. The 
ellipse appears in the selection color.

4 Click an area where there are no parts or objects in order to deselect the ellipse.
5 Select the selection tool or press ESC to dismiss the line tool.

Shortcut
Tool palette:

Related topics
Creating graphics
Drawing arcs
Drawing lines
Drawing polylines
Drawing rectangles and squares
Ellipse command



Drawing arcs
You create an arc of any angle using the arc tool. If you wish to create a full circle, you can 
use the ellipse tool. Because it is a line, the arc adopts the current line style. For more 
information about setting line styles, see Creating graphics.
To draw an arc
1 From the Place menu, choose Arc (ALT, P, A).
2 Move the pointer to the center of the arc and click the left mouse button.
3 Use the mouse to establish the radius of the arc and the location of one end of the arc; 

click the left mouse button to accept each point. The arc is drawn counterclockwise from 
the end point.

4 Use the mouse to establish the other end of the arc; click the left mouse button to accept 
the arc. The arc displays in the selection color.

4 Click an area where there are no parts or objects in order to deselect the arc.
5 Select the selection tool or press ESC to dismiss the arc tool.

Shortcut
Tool palette:

Related topics
Creating graphics
Drawing circles and ellipses
Drawing lines
Drawing polylines
Drawing rectangles and squares
Arc command



Drawing polylines
When you wish to draw a line with multiple contiguous segments, the polyline tool is very 
convenient. The line you draw adopts the current line style. Polygons can be created with 
the polyline tool; these polygons adopt the current fill style. For information on setting the 
line style, see Creating graphics.
You can create a polyline with square corners simply by holding SHIFT while you draw.
To draw a polyline
1 From the Place menu, choose Polyline (ALT, P, Y).
2 Click the left mouse button to begin drawing, click to change directions, and double-click 

to end the final segment. To constrain the direction changes to multiples of 90 degrees, 
press SHIFT. After you double-click, the polyline displays in the selection color.

3 Click an area where there are no parts or objects in order to deselect the polyline.
4 Select the selection tool or press ESC to dismiss the polyline tool.
To draw a polygon

Follow the instructions above, ending the line with a single mouse-button click at the 
beginning point. The polygon adopts the current line and fill style.

Shortcut
Tool palette:

Related topics
Creating graphics
Drawing lines
Drawing rectangles and squares
Drawing arcs
Drawing circles and ellipses
Editing graphics
Polyline command



Placing bitmaps
You can create a bitmap in another application and place it on a schematic page or library 
part, or in a custom title block.
To place a bitmap
1 From the Place menu, choose Picture (ALT, P, U). The Open dialog box displays.
2 Select the bitmap file. If the file is not listed in the File Name box, do one or more of the 

following:
In the Drives box, select a new drive.
In the Directory box, select a new directory.
In the List Files of Types box, select the type of file you wish to open.

3 Choose the OK button. A rectangle representing the bitmap image is attached to the 
pointer.

4 Use the mouse to move the bitmap and click the left mouse button to place the bitmap at 
the desired location. If you wish to place multiple copies of the bitmap, simply repeat this 
step.

5 Select the selection tool to dismiss the bitmap tool.

Related topics
Creating graphics
Drawing lines
Drawing rectangles and squares
Drawing arcs
Drawing circles and ellipses
Picture command



Placing IEEE symbols
To place an IEEE symbol
1 From the Place menu, choose the IEEE Symbol command (ALT, P, E). The Place IEEE Symbol 

dialog box displays.
2 From the Symbols list, select a symbol. The symbol displays in the preview box.
3 When the appropriate symbol is selected, choose the OK button. The symbol is attached 

to your pointer.
4 Use the mouse to move the symbol and click the left mouse button to place the symbol.
5 Select the selection tool to dismiss the symbol tool or repeat step 4 to place additional 

symbols.

Shortcut
Tool palette:

Related topics
Creating graphics
Drawing lines
Drawing rectangles and squares
Drawing arcs
Drawing circles and ellipses
IEEE Symbol command





Working with properties
Capture uses properties to describe objects. Imagine a ceramic capacitor that is brown and 
measures 6 millimeters in height. Type, color, and height are properties, while ceramic, 
brown, and 6 millimeters are property values. Every Capture object is made up of such 
name-and-value pairs.
Some properties, called inherent properties, are an essential part of the object; others, 
called user-defined properties, are not used by Capture, but may be used by another tool. 
For example, if you want your schematic to include the supplier and the price per hundred 
for all parts, you simply create two properties for parts. You can add as many user-defined 
properties to objects as you like, and you can remove user-defined properties when you find 
that you don't need them. Graphic objects (such as lines, ellipses, and rectangles) do not 
accept user-defined properties.
Because you can add properties to objects, the properties of a library part are not 
necessarily identical to those of a part instance or to those of a part occurrence. For 
example, you can add a property, such as stock number, to a library part, because this 
information is required on all parts used by your company, but you may not want to assign it
a value in the library. You might add a user-defined property for price quotes to an instance 
of the part and another property for power expenditure to a particular occurrence of the 
part.
You use properties for differently purposes in logical and physical view. For example, you 
would assign wire sizes in logical view so that all power nets are alike; but you would assign 
timing parameters in physical view, because the timing is different at different locations on 
the physical product.
When you create a property, you can make the property name visible and specify the font 
and location of the property value text, even before you specify the property value. The 
property name acts as a place holder until you supply the property value.

Related topics
Editing properties
New Property dialog box
Combined property strings
Defining properties



Editing properties
All objects in Capture have attributes, or properties. Examples include object type (such as 
text, wire, or title block,), part reference, color, font, and visibility. Some properties are 
essential to Capture---you cannot remove these inherent properties, though you can change 
the value of some of them. Other properties may be needed by external tools---they are not 
used by Capture, so you can add and modify these user-defined properties to suit your 
purpose.
For editing the properties of a set of objects, see Using the spreadsheet editor. If you want to
edit the properties of a part, see Editing part properties.
To edit an object's properties

Double-click on the object.
or
1 Select the object.
2 From the Edit menu, choose the Properties command (ALT, E, S).
To edit the properties of one pin
1 In the part editor or the schematic page editor, select the pin.
2 From the Edit menu, choose the Properties command (ALT, E, S). The Pin Properties dialog 

box displays; you can change the pin name, number, shape, type, and for a power pin, 
the visibility.

To edit properties associated with a net, wire, or bus
Select the net, wire, or bus, then from the Edit menu, choose the Properties 

command (ALT, E, S). The Net Properties dialog box displays.
To edit properties associated with comment text
1 Select the text you want to edit.
2 From the Edit menu, choose the Properties command (ALT, E, S). In the Display Properties 

dialog box, you can change the text content and its font, rotation, color, and visibility.
To add a property
1 In the Properties dialog box, choose the New button. The Add Property dialog box 

displays.
2 Enter a name and value for the new property. You may enter any name you wish, except 

that property names cannot be duplicated on a single object. Both the name and value 
are limited to 256 characters.

3 Choose the OK button to close the Add Property dialog box.
To change the visibility of property text
1 In the User Properties dialog box, select the property, and then choose the Display button.

The Display Properties dialog box opens.
2 Select or deselect the Visible option, and then change the color, rotation, or font if you 

wish.
3 Choose the OK button to dismiss the Display Properties dialog box.
To edit the name of a property

Delete the property and add a new one. This may be done most easily using the 
spreadsheet editor.
To delete a property

In the Properties dialog box, select the properties to delete and choose the Remove 
button.



Only user-defined properties can be removed.

Related topics
Working with properties
Inherent properties
Net operations
New Property dialog box
Combined property strings
Defining properties
Using the spreadsheet editor
Updating part or net properties
Using no connects
Pin shapes and types
User Properties dialog box.
Export Properties command
Import Properties command
Gate and Pin Swap command
Update Properties command



Inherent properties
Certain properties can be edited, but not removed. These are called inherent properties.

Object type Properties
Arcs Line width and style, color
Bookmarks Name
Bitmaps (pictures) (None)
Bus entries (None)
Busses Name
DRC markers (None)
Ellipses Fill style, line width and style, 

color
Ground symbols Name
Hierarchical Ports 
inside hierarchical blocks

Name, pin type and width

Hierarchical Ports 
outside hierarchical blocks

Name, pin type

Hierarchical Blocks Name, primitivity, attached 
schematic and library, attached 
file, color, part reference, value

IEEE symbols Symbol
Lines Line width and style, color
Net alias Alias name, color, rotation, font
No connects (None)
Off-page connectors Name
Part instances Part value, part reference, 

primitivity, view (normal or 
convert), part in package, PCB 
footprint, power pin visibility, 
attached schematic and library, 
attached file, color, name

Pictures (bitmaps) (None)
Pins in part editor Name, number, width, shape, type
Pins in schematic page 
editor

Name, status (no-connect?)

Polygons Fill style, line width and style, 
color

Polylines Line width and style, color
Power symbols Name
Rectangles Fill style, line width and style, 

color
Title blocks Color, date, name, organization 

address lines, organization name, 
page count, page number, 
revision code, sheet size



Text Text content, color, rotation, font
Visible properties Value (of most properties), 

visibility, color, font, rotation
Wires Name

Using the spreadsheet editor
The properties of a group of similar objects can be edited using the spreadsheet editor. In 
the spreadsheet editor, you can edit homogeneous sets of the following object types:

Part instances
Pins on part instances
Hierarchical ports
Busses
Wires
Off-page connectors
DRC markers
Bookmarks

To use the spreadsheet editor
1 Select the group of objects. For instructions, see Selecting and deselecting objects
2 From the Edit menu, choose the Properties command (ALT, E ,S). Note that if the selection 

set cannot be edited in the spreadsheet editor, the Properties command is unavailable.
3 In the spreadsheet editor that displays, you can perform these operations:

Click the left mouse button on a cell to select the cell for copying or pasting, or 
double-click to select the cell for editing.

Click on a row or column heading to select the entire row or column.
With one or more cells selected for copying or pasting, press and hold the SHIFT key 

while you click on a cell adjacent to extend the selection set.
Choose the New button to display the New Property dialog box. Enter the property 

name. If you want all the selected cells to have a particular value, enter the value before you
choose the OK button.
 

Related topics
Updating part or net properties
Selecting and deselecting objects



Some inherent properties that Capture displays in the spreadsheet editor cannot be edited. 
These properties display as white on black when you select them.



If you want to assign one cell's value to all the cells within the same column, select the cell,
then from the Edit menu, choose the Copy command. Click on the column heading, then 
from the Edit menu, select the Paste command.



Defining properties
All objects are described by properties to which you can assign values to suit your needs. In 
addition, you can add to the set of properties for the object types listed below.

Parts
Part instances and occurrences
Hierarchical blocks
Pins on library parts and part instances
Busses
Nets

For nets, you actually select a wire segment and add a property; but the property exists on 
the net, rather than the individual wire segment.
Note that you cannot add properties to graphic objects, bookmarks, IEEE symbols, no-
connect objects, net aliases, power and ground symbols, off-page connectors, hierarchical 
ports, or bus entries.
You can add a property and specify the color, visibility, and font of the property text without 
assigning a value. The property name, which serves as a placeholder, appears next to the 
object and is enclosed in braces.
To add a user-defined property
1 Select the object.
2 From the Edit menu, choose the Properties command (ALT, E, S).
3 Choose the User Properties button.
4 In the dialog box that displays, choose the New button. The Add Property dialog box 

displays.
5 Enter a name for the new property. You may assign any name you wish, except that 

property names cannot be duplicated on a single object.
6 Enter a value for the new property.

or
Wait until another time to assign a value. Until then, Capture displays the property name, 
in braces, as a placeholder.

7 Choose the OK button to close the New Property dialog box.
8 If you wish to make the property text visible, choose the Display button to open the 

Display Properties dialog box where you can specify color, rotation, and font. Complete 
your selections, and choose the OK button.

9 Choose the OK button twice to close the two dialog boxes.
or

Use the spreadsheet editor, as described in Using the spreadsheet editor.
or
1 Use the Export Properties command to create a property file.
2 Edit the property file.
3 Use the Import Properties command to apply your changes.

Shortcut
Mouse: Double-click on the object

Related topics
Editing properties
Editing property files



Working with properties
New Property dialog box
Export Properties command
Import Properties command



Property names and values can have up to 256 characters each.



Replacing user-defined properties
If you want to replace a property value, you need to open the spreadsheet editor on all the 
objects with that value, then paste the new value into the appropriate cells.
To replace properties values
1 Select the objects whose properties you wish to edit. For more information see Searching 

a design or Searching a library.
2 From the Edit menu, choose the Properties command (ALT, E, S). The spreadsheet editor 

displays.
3 Double-click on a cell which holds the value you wish to replace, and then enter the new 

value.
4 At the bottom of the Edit properties window, choose the Copy button.
5 Select the cells which are to receive the replacement value.
6 At the bottom of the Edit properties window, choose the Paste button. The replacement 

value appears in the selected cells.
7 Choose the OK button to dismiss the spreadsheet editor.

Related topics
Working with properties
Editing properties
Using the spreadsheet editor



Changing your view

Viewing a different area
Scrolling
Panning
Moving to a location, reference, or bookmark

Zooming
Zooming in
Zooming out
Zooming to a specific scale
Changing the zoom factor
Viewing the entire schematic page or part
Viewing a specific area
Centering the view
Refreshing the display



Scrolling
In Capture, you can scroll up or down or to the left or the right in order to focus on a different
portion of the active window. Some objects on the Place menu are attached to your pointer 
while you place them; it is useful to know that you can scroll while the object is attached to 
your pointer.

Click on either side of the scroll button to scroll the panning distance in the 
corresponding direction---up or down using the vertical scroll bar, right or left using the 
horizontal scroll bar.

Click on the up, down, right, or left arrow to scroll one grid unit in the corresponding 
direction.

Drag the horizontal or vertical scroll button to scroll the window dynamically.
Press PAGE UP to scroll the panning distance up.
Press PAGE DOWN to scroll the panning distance down.
Press CTRL+PAGE UP to scroll the panning distance to the left
Press CTRL+PAGE DOWN to scroll the panning distance to the right.

Related topics
Panning
Zooming in
Zooming out
Zooming to a specific scale
Viewing the entire schematic page or part
Viewing a specific area
Centering the view
Moving to a location, reference, or bookmark
Refreshing the display



Panning
When you position the pointer within a certain distance of the window's edge, the focus of 
the display changes so that you are viewing a different region of the drawing area.
You can configure the distance by which the display changes and the location at which the 
pointer triggers the change. The distance by which the display changes is the panning 
distance; the distance from window's edge at which the pointer triggers the change is the 
panning border.
To change the display region

While drawing, placing, or moving objects, move the pointer to the edge of the 
window. If there is more schematic page or part to display, the window scrolls in the 
corresponding direction.
To configure panning distance
1 From the Options menu, choose Preferences (ALT, O, P), and then choose the Pan and Zoom

tab.
2 In the Scroll Percent text box, enter the percent of the window's horizontal or vertical 

dimension by which the display will scroll. Note that you can specify separate values for 
the schematic page editor and the part editor.

3 Choose the OK button.
To configure the panning border
1 From the Options menu, choose Preferences (ALT, O, P), and then choose the Pan and Zoom

tab.
2 In the Border text box, enter the distance in pixels. Note that you can specify separate 

values for the schematic page editor and the part editor.
3 Choose the OK button.

Related topics
Scrolling
Zooming in
Zooming out
Zooming to a specific scale
Viewing the entire schematic page or part
Viewing a specific area
Centering the view
Moving to a location, reference, or bookmark
Refreshing the display
Working with multiple windows 
Preferences command



Moving to a location, reference, or bookmark
The X and Y coordinates of your pointer's current location are displayed at the right of the 
status bar. Grid references are marked on the left and upper edges of the drawing board in 
the schematic page editor.
To move to a specific location
1 From the View menu, choose Go To (ALT, V, G).
2 Choose the Location tab.
3 Enter the X and Y values, select the Absolute option, and then choose the OK button. The 

coordinates are measured in inches or metric units, depending on what you have 
configured in the Page Size dialog box of the design template. Your pointer moves to the 
new coordinates.

To move a specific distance
1 From the View menu, choose the Go To command (ALT, V, G).
2 Choose the Location tab.
3 Enter the X and Y values that you want the pointer to move, select the Relative option, 

and then choose the OK button. The jump distance is measured in inches or metric units, 
depending on what you have configured in the Page Size dialog box of the design 
template. Your pointer moves the specified distance.

To move to a specific grid reference
1 From the View menu, choose Go To (ALT, V, G).
2 Choose the Reference tab.
3 Enter the grid reference and choose the OK button.
To move to a specific bookmark
1 Choose Go To from the View menu (ALT, V, G).
2 Choose the Bookmark tab.
3 Enter the name of the bookmark and choose the OK button.

Related topics
Setting a bookmark
Panning
Scrolling
Zooming in
Zooming out
Zooming to a specific scale
Viewing the entire schematic page or part
Viewing a specific area
Centering the view
Configuring Capture
Grid References command (View menu)
Grid Reference dialog box tab (Schematic Page Properties)



Zooming in
In the schematic page editor and the part editor, you can look very closely at a particular 
area. When you press SHIFT+I (or simply I) to zoom in, Capture centers your view on the 
current pointer position, if possible. If the pointer is outside the window, or if you choose the 
Zoom In command or toolbar button, Capture centers your view on any selected objects. 
Otherwise, Capture zooms in on the center of the active window.

From the View menu, choose Zoom and then choose In (ALT, V, Z, I). The current zoom 
scale is multiplied by the zoom factor. With a zoom factor of 2, zooming in makes the image 
twice as large and displays half the area of the previous view.
To change the zoom factor
1 From the Options menu, choose Preferences (ALT, O, P), then choose the Pan and Zoom tab.
2 In the Zoom Factor text box, enter the new zoom factor. Note that you can specify 

separate values for the schematic page editor and the part editor.
3 Choose the OK button.

Shortcut
Toolbar:

Keyboard:     SHIFT+I    or just I

Related topics
Zooming out
Changing your view
Changing the zoom factor
Panning
Scrolling
Zooming to a specific scale
Viewing the entire schematic page or part
Viewing a specific area
Centering the view
Refreshing the display



Zooming out
In the schematic page editor and the part editor, you can change your viewing perspective 
to increase the portion of the drawing board that is visible.

From the View menu, choose Zoom and then choose Out (ALT, V, Z, O). The current 
zoom scale is divided by the zoom factor. With a zoom factor of 2, zooming out halves the 
image size and shows twice the area of the previous view.
To change the zoom factor
1 From the Options menu, choose Preferences (ALT, P, P), then choose the Pan and Zoom tab.
2 In the Zoom Factor text box, enter the new zoom factor. Note that you can specify 

separate values for the schematic page editor and the part editor.
3 Choose the OK button.

Shortcut
Toolbar:

Keyboard:       SHIFT+O    or just O

Related topics
Zooming in
Changing your view
Changing the zoom factor
Zooming to a specific scale
Viewing the entire schematic page or part
Viewing a specific area
Centering the view
Panning
Scrolling
Refreshing the display



At certain zoom scales, Capture substitutes filled rectangles for text that is too small to 
display. These placeholders are for display only---the text prints correctly.



Zooming to a specific scale
To view a part or schematic page at a specific scale
1 Choose Zoom from the View menu, and then choose Scale (ALT, V, Z, S).
2 Select a preset scale or enter a custom scale, and click OK.

Related topics
Zooming in
Zooming out
Viewing the entire schematic page or part
Viewing a specific area
Centering the view
Refreshing the display
Panning
Scrolling



Viewing the entire schematic page or part
You can view the entire part or schematic page at once. For a schematic page, Capture uses 
the dimensions set on the Page Size tab in the Schematic Page Properties dialog box.

Choose Zoom from the View menu, and then choose All (ALT, V, Z, L). The entire 
schematic page or part is reduced to fit the window.

Shortcut
Toolbar:

Related topics
Zooming in
Zooming out
Zooming to a specific scale
Viewing a specific area
Centering the view
Panning
Scrolling
Refreshing the display
Schematic Page Properties command
All command



Viewing a specific area
To view an area of the part or schematic page
1 Choose Zoom from the View menu, and then choose Area (ALT, V, Z, A). The pointer displays

as a magnifying glass.
2 Move the pointer to one corner of the rectangular area to enlarge.
3 Press the left mouse button and hold it down as you move the pointer to the opposite 

corner.
4 Release the mouse button. The selected area fills the window.

Shortcut
Toolbar:

Related topics
Zooming in
Zooming out
Zooming to a specific scale
Viewing the entire schematic page or part
Centering the view
Panning
Scrolling
Refreshing the display
Area command



Centering the view
In Capture, you can center the view on your pointer or you can focus the view on a specific 
object.
To center the view on a specific object

Select objects or an area. From the View menu select Zoom and then choose 
Selection (ALT, V, Z, E). The display scrolls so that the selected objects or selected area is in 
the center of the window. The zoom factor does not change.
To center the view on your pointer

Press SHIFT+C (or simply C).

Related topics
Zooming in
Zooming out
Zooming to a specific scale
Viewing the entire schematic page or part
Viewing a specific area
Panning
Scrolling
Refreshing the display



Refreshing the display
From the View menu select Zoom and then choose the Redraw command (ALT, V, Z, W),

or press F5.

Related topics
Zooming in
Zooming out
Zooming to a specific scale
Viewing the entire schematic page or part
Viewing a specific area
Centering the view
Panning
Scrolling
Redraw command



Changing the zoom factor
When you zoom in or out, the zoom scale is multiplied or divided by a zoom factor that you 
can set to suit your needs. Furthermore, you can set one zoom factor for the schematic page
editor and another for the part editor.
To change the zoom factor
1 From the Options menu select the Preferences command (ALT, O, P).
2 Select the Zoom and Pan tab.
3 Enter the new zoom factor and choose the OK button.

Related topics
Zooming in
Zooming out
Zooming to a specific scale
Viewing the entire schematic page or part
Viewing a specific area
Centering the view
Refreshing the display
Panning
Scrolling
Zoom In command
Zoom Out command



Setting a bookmark
If you find that you need to return repeatedly to a specific area of a schematic page, or if 
you need to direct attention to a particular location, a bookmark is very convenient. When 
you set a bookmark, you assign it a name. You can then use the Go To command to return to
the location, and you can use the bookmark name to direct another member of your team to
the location.
To place a bookmark
1 From the Place menu, choose the Bookmark command (ALT, P, M).
2 Enter the name of the bookmark, then choose the OK button to dismiss the bookmark 

dialog box.
3 Position the pointer where you want the bookmark and click the left mouse button. The 

bookmark displays in the selection color.
4 Click an area where there are no parts or objects in order to deselect the bookmark.
To rename a bookmark
1 Select the bookmark.
2 From the Edit menu choose the Properties command (ALT, E, S). The Rename Bookmark 

dialog box displays.
3 Enter a new name in the text box and choose the OK button.

Related topics
Moving to a location, reference, or bookmark
Bookmarks command (Edit menu, Browse command)
Go To command
Bookmark command (Place menu)
Bookmarks



The Go To command is always available on the context-sensitive menus that pop up when 
you click the right mouse button in the part editor and schematic page editor. The Go To 
command, with the Relative option selected, is particularly useful for precise placement 
and spacing.



Printing and plotting
Whether you wish to send output to a printer, a plotter, or an encapsulated PostScript file, 
you work with the standard Windows dialog boxes. Capture can send output to any driver 
that Windows supports.
In the Print dialog box, you make choices for a print job. The choices you establish are used 
for previewing and for creating output. For additional information on printing and plotting, 
see your Windows documentation.
To configure the output device
1 Choose the Setup button to select a different printer or plotter or to change printer 

settings.
2 If you need to set up your printer or plotter, see the documentation that accompanies the 

printer or plotter. For access to additional printer settings, use the Printers control panel in
the Windows File Manager.

To print or plot
1 In the design manager, select the documents you wish to print.

or
Open the schematic page, part, or symbol you wish to print.

2 From the File menu, choose the Print command (ALT, F, P).
Documents can be printed as indicated in the following table:

Document to print
From

design mgr.
From

sch. pg. editor
From

part editor
Single schematic page Yes Yes ---
Multiple schematic pages Yes --- ---
Entire schematic Yes --- ---
Single part or symbol Yes --- Yes
Multiple parts and symbols Yes --- Yes (a)
Entire package Yes --- Yes (b)
Notes
a Multiple-part package in package view, only.
b In package view.

Shortcut
Toolbar:

Related topics
Print preview
Scaling a print or plot
Plotter pen colors
Special considerations for plotting
Printing or plotting one schematic page
Printing or plotting a part
Print To File dialog box
Print Preview command
Print command
Print Setup command



Printing or plotting one schematic page
With the schematic page editor active and open to a specific schematic page, you can 
create a print or a plot of that page. You can also print a page from the design manager.
To print or plot one page
1 If you are working in the schematic page editor, activate the window for the page you 

wish to print.
or
If you are working in the design manager window, then in the design structure pane, 
select the schematic page.

2 From the File menu, choose the Print command (ALT, F, P). The Print dialog box opens.
3 Select the scale, the print quality, and the number of copies, then choose the OK button.

Shortcut
Toolbar:

Related topics
Print preview
Printing and plotting
Scaling a print or plot
Plotter pen colors
Special considerations for plotting
Printing or plotting a part



Windows normally sets the printer to Portrait mode. You can use the Print Preview 
command to check output before sending it to the printer or plotter.



Printing or plotting a part
With the part editor active and open to a specific part, you can create a print or a plot of that
part. You can also print a part from the design manager.
To print or plot a part
1 Select the part in the design structure pane of the design manager window.

or
Open the part you wish to print.

2 From the File menu, choose the Print command (ALT, F, P). The Print dialog box opens.
3 Select the scale, the print quality, and the number of copies, then choose the OK button.
To print or plot a multiple-part package
1 Select the part in the design structure pane of the design manager window.

or
Open the part, and from the View menu choose the Package command (ALT, V, K).

2 From the File menu, choose the Print command (ALT, F, P). The Print dialog box opens.
3 Select the scale, the print quality, and the number of copies, then choose the OK button.

Shortcut
Toolbar:

Related topics
Print preview
Printing and plotting
Scaling a print or plot
Plotter pen colors
Special considerations for plotting
Printing or plotting one schematic page
Print command



Previewing print output
Using the Print Preview command, you can make sure that your schematic or schematic 
page is complete and that its appearance is what you want before you commit it to paper.
To preview print output
1 In the design structure pane of the design manager window, select the documents you 

wish to print or plot.
or
Select the entire design or library you wish to print or plot.
or
Open the single part or schematic page you wish to print or plot.

2 From the File menu, choose Print Preview (ALT, F, V). The Print dialog box displays.
3 Edit the values as necessary. See Print Preview command for an explanation of the 

parameters.
4 Choose the OK button to begin. The "Printing Now" message displays and after a moment,

the Print Preview window opens with a display of your schematic page. If this schematic 
page requires multiple printer pages, scroll through them using the scroll bar.

5 Use the Previous page and Next page buttons to look at additional printer pages of this 
schematic page.

6 To zoom in, move the magnifier pointer to a specific area and click the left mouse button.
7 When you finish, choose the Close button to dismiss the Print Preview window.

Related topics
Printing and plotting
Scaling a print or plot
Plotter pen colors
Special considerations for plotting
Printing or plotting one schematic page
Printing or plotting a part
Print command
Print To File dialog box
Print Preview command
Print Setup command



Scaling a print or plot
You can manually scale or have Capture automatically scale prints and plots to fit the paper 
size you choose.
To scale a print or a plot
1 From the File menu, choose Print (ALT, F, P). The Print dialog box displays.
2 Select one of the three radio buttons in the Scale box.

The Auto scale option scales each schematic page to fit a single sheet of paper.
The Scale to sheet size option scales your schematic pages to the sheet size you 

select in the Scale to size box. This will result in multiple sheets of paper if you select a 
sheet size larger than your printer paper.

The Scale by factor option scales your schematic pages to a factor of your choice. 
The acceptance range of factors is 0.100 to 10.000.
3 If you select the Scale to sheet size option above, the Scale to size list becomes available.

Your schematic page is scaled to the sheet size you select. This will result in multiple 
sheets of paper if you select a sheet size larger than your printer paper.

4 Choose the OK button to send the image to the output device.

Shortcut
Toolbar:

Related topics
Printing and plotting
Print preview
Plotter pen colors
Special considerations for plotting
Printing or plotting one schematic page
Printing or plotting a part
Print command



Plotter pen colors
The plotter driver maps your color choice to the closest available pen color as established in 
your plotter driver configuration. See your plotter's driver setup and documentation for more
details. For access to additional printer settings, use the Printers control panel in the 
Windows File Manager.

Related topics
Special considerations for plotting
Printing and plotting
Print preview
Scaling a print or plot
Printing or plotting one schematic page
Printing or plotting a part
Print command



Special considerations for plotting
Plotters do not support bitmaps directly. If you are sending Capture output to a plotter, your 
bitmaps will not be plotted.
The Capture setup command may not give you access to all your plotter's setup options. For 
access to additional printer settings, use the Printers control panel in the Windows File 
Manager.
Many plotters do not have drivers that ship with Windows. If you do not see the plotter you 
are looking for in the list of available drivers, contact your plotter manufacturer and ask for a
Windows driver. If your plotter will emulate HPGL and you are using Windows 3.1 or Windows
95, an alternative solution is to use the HPGL driver.

Related topics
Print preview
Printing and plotting
Scaling a print or plot
Plotter pen colors
Printing or plotting one schematic page
Printing or plotting a part
Print command



Using the session log
The session log contains a record of events that have occurred during the current Capture 
session. You can use the Edit menu's Find command to search for specific information and 
copy session log text to the Clipboard.
If a tool encounters a problem, it displays a message stating that it did not complete 
successfully. Error or warning messages generated by Capture or the Capture tools are sent 
to the session log.
The information in the session log is useful for troubleshooting and especially valuable if you
call the OrCAD technical support staff.
To display the session log

Double-click on the icon.
or

From the Window menu, choose the Session command.
To save the session log as a file
1 Display the session log,
2 From the File menu, choose the Save command (ALT, F, S).
To clear the session log contents

Press CTRL+DEL.

Related topic
Troubleshooting
Session log window
Overview of error messages
Error messages



Assigning unique part references
When you place parts on a schematic page, all parts of the same type are assigned the 
same part reference. For example, C? is assigned to all capacitors. Regardless of the 
ultimate purpose of your schematic design, each part needs a unique identifier. You can 
assign part references by editing individual parts in the part editor or by creating a swap file 
to use with the Gate and Pin Swap tool, but for uniquely identifying parts, it is more 
convenient to use the Update Part References command on the Tools menu.
The Update Part References tool assigns unique alphanumeric part references, assigns 
individual parts to a package, and assigns unique pin numbers to each part in a multiple-
part package. References are assigned in order from top to bottom and left to right; parts 
located at the top of the page have the lowest numerical designation, if two parts share a 
vertical coordinate, the part further to the left has the lower numerical designation. If you 
add parts after you've assigned part references, you can easily remove part reference 
assignments and run the Update Part References tool again.
In general, you use Update Part References after you've placed all parts and before you use 
other Capture tools. See Processing your design for an overview of the design processing 
tools.
You can update references incrementally, so that previously assigned part references are not
changed, or you can update unconditionally. See Forcing parts into the same physical 
package for further instructions.
To uniquely identify parts
1 In the design manager window, choose logical or physical view as appropriate, and select 

schematics or schematic pages if you wish to process only part of the design.
2 From the Tools menu, choose the Update Part References command.
3 Verify that the dialog box selections are just the way you want them. In the dialog box, 

you specify whether to update the entire design or only the schematics or pages selected 
in the design manager, and you choose to assign part references to all parts, or to only 
those that have not been previously updated, or to return all the part references to the 
unassigned state (such as C? or U?A). If you choose to reset reference numbers to begin 
at 1 in each schematic page, it is possible that part references will be duplicated within a 
schematic that contains multiple pages.

4 Choose the OK button to run Update Part References.

Shortcut
Toolbar:

Related topics
Forcing parts into the same physical package
Processing your design
Removing part reference assignments
Combined property strings
Creating multiple-part packages 



Updating part or net properties
Using properties, you can conveniently store part and net information. To change part 
properties on a single part instance (or on every instance of the part in a design), edit the 
part instance in the schematic page editor. To set part properties on every instance of the 
part that you place, edit the part in the part editor. If you want to make changes to a 
number of parts or nets, the Update Properties command on the Tools menu is a convenient 
method.
You can use Update Properties to edit any properties except part value, part reference, and 
netname, and you can update the properties of parts in a design or in a library.
Before you run the Update Properties tool, you create an update file. To identify the parts or 
nets you wish to update, you specify an identifying property or combination of properties. 
For each identifier you use, you must create a separate update file and run the Update 
Properties tool.
If you wish to update part instance properties, select Logical from the View menu; if you wish
to update part occurrence properties, select Physical from the View menu.
You can update references incrementally, so that previously assigned part references are not
changed, or you can update part references unconditionally, changing all the parts across all
the schematic pages processed.
To update part or net properties
1 Using a text editor, create an update file. See Creating an update file for further 

information.
2 In the design manager window, choose logical or physical view as appropriate, and select 

schematics or schematic pages if you wish to process only part of the design.
3 From the Tools menu, choose the Update Properties command. The Update Properties 

dialog box displays.
4 Verify that the dialog box selections are just the way you want them. In the dialog box you

specify, among other things, whether you are updating nets or parts, whether you want to
overwrite existing property values, plus the location and name of the update file.

5 Choose the OK button to run Update Properties.
 

Related topics
Working with properties
Editing part properties
Editing package properties
Updating part properties in a library
Update Properties sample report file
Combined property strings
Processing your design
Creating an update file



Creating an update file
The update file tells Update Properties which objects to change, which of the objects' 
properties are affected, and what values those properties get. You can create an update 
(.UPD) file using any text editor that allows you to save the file in ASCII format. The file can 
include comments; any text to the right of a semicolon is ignored by the Update Properties 
tool.
Except for the comments, strings in the update file must be enclosed in quotation marks and
cannot exceed 124 characters. You can use spaces and tab characters to format the update 
file in rows and columns, as shown in the following example.
The first line of the update file is a header line. It starts with a combined property string that 
identifies which properties to compare for a match. In the example, only the Net Name 
property is compared. The other strings on the first line specify which properties to update 
when a match is found.
The rest of the file contains a line for each match string to be compared and the values to be
recorded in the updated properties.
In the following example, the combined property string is {Net Name}. For every object 
whose Net Name property value matches one of the strings in the first (left) column, the 
object's Track Width, Net Spacing, and Routing Priority properties are updated with the 
corresponding values. For example, every object whose Net Name property is set to VCC will
be updated as follows: the Track Width property will be set to 0.04, the Net Spacing property
to 0.035, and the Routing Priority property to 3.

Sample update file
"{Net Name}" "Track Width" "Net Spacing" "Routing Priority"
"VCC"        "0.04"        "0.035"       "3" ; Any text to the right
"CLK"        "0.01"        "0.025"       "1" ;   of a semicolon is
"CLR"        "0.01"        "0.025"       "3" ;   ignored by the
"RESET"      "0.01"        "0.025"       "3" ;   Update Properties
"GND"        "0.04"        "0.035"       "2" ;   tool.

Related topics
Inherent properties
Combined property strings
Creating a combined swap and update file 
Processing your design
Updating part or net properties
Update Properties command



Except for the header line, update files for Capture have the same format as the update 
files used by Update Field Contents in SDT. Once you add the appropriate header line, you 
can use an SDT update file without modification to change individual property values using 
Update Properties. You can also build on an SDT update file for a more elaborate property 
update, because Capture can update multiple properties in a single pass.

Do not create an empty string---two consecutive double quotation marks without 
intervening characters---in the header line. Update Properties reports an empty string as an
error.



Forcing multiple parts into one physical package
If you need to make sure that two or more parts in your design are in the same package, 
Capture has a tool that will help you. First, choose a property that all the parts share and 
make sure that they all have the same value for that property, then use the Update Part 
Reference tool.
For example, you might have many NANDs in a schematic and four that are in close 
proximity in the final product. For each of the four NANDs, create a user-defined property 
called Group and set the property's value to 1. In the Combined Property String box of the 
Update Part Reference dialog box, enter {Group}.
To force multiple parts into a single package
1 Choose one property that the parts share and assign the same value to that property for 

each part. You may wish to add a user-defined property to each part.
2 In the design manager window, choose logical or physical view as appropriate, and select 

schematics or schematic pages if you wish to process only part of the design.
3 From the Tools menu, choose the Update Part References command (ALT, T, U). The Update 

Part References dialog box displays.
4 In the Combined Property String box, enter the property name. The name must be 

enclosed in braces ("{" and "}").
5 Verify that the remaining dialog box selections are just the way you want them. In the 

dialog box you specify, among other things, whether you are unconditionally updating all 
references or only those that are set to the unassigned (?) reference.

6 Choose the OK button to run Update Part References.

Shortcut
Toolbar:

Related topics
Combined property strings
Processing your design
Defining properties
Editing properties
New Property dialog box



Removing part reference assignments
If you want to incrementally update a design in which some of the schematic pages have 
already been updated, you can use the Update Part References command to remove part 
references from those schematic pages.
To remove part references
1 In the design manager window, choose logical or physical view as appropriate, and select 

schematics or schematic pages if you wish to process only part of the design.
2 From the Tools menu, choose the Update Part References command. The Update Part 

References dialog box displays.
3 Among the Action options, select Reset part references to "?" and make other selections 

as appropriate, then choose the OK button.

Shortcut
Toolbar:

Related topics
Update Part References command
Processing your design
Logical view and physical view
Logical View command
Physical View command
Rebuild Physical View command



Back annotating a schematic
When you need to transfer packaging information to your schematic from other EDA tools, 
the Gate and Pin Swap command is an ideal method. When you need to back annotate 
properties, use the Update Properties tool (see Updating part or net properties). Using Gate 
and Pin Swap, you can import changes created by external tools such as PCB Layout 
packages. Capture uses a simple file format to provide support for gate swapping, for pin 
swapping, plus for changing or adding properties on parts, pins, or nets. If the external tool 
creates a back annotation file, edit the file to match the format described in Creating a swap
file.
Why would you use Gate and Pin Swap? After you've completed your schematic and while 
you are routing a printed circuit board, you might discover that you could greatly reduce via 
count, track length, or routing complexity by exchanging two of the gates or pins on a part. 
For example, say you use your board layout application to rewire the board, exchanging the 
connections of U1A and U1B.
To ensure that your schematic reflects the changes, you use a text editor to create a swap 
file, and then run the Gate And Pin Swap command. The next time you look at the design, 
you see that where U1A    and U1B have traded places.
To back annotate part packaging information
1 Using a text editor, create a swap file. See Creating a swap file for instructions.
2 In the design manager window, choose logical or physical view as appropriate. Back 

annotate a complex hierarchical design in physical view only.
3 Select schematics or schematic pages, if you wish to process only part of the design
4 From the Tools menu, choose Gate and Pin Swap. The Gate and Pin Swap dialog box 

displays.
5 Verify that the dialog box selections are just the way you want them. In the dialog box you

specify whether you want to process the entire design or only the selected schematics or 
schematic pages and you specify the location and name of the swap file.

6 Choose the OK button to initiate the back annotation.

Shortcut
Toolbar:

Related topics
Combined property strings
Creating a swap file
Processing your design
Gate and Pin Swap command
Update Part References
Update Properties command
Design Rules Check



Creating a combined swap and update file
You can create a file that combines swap file and update file information. Run Gate and Pin 
Swap to use a combined swap and update file. Swap and update files should have the 
same .SWP file extension as normal swap files.
A swap and update file is divided up into sections. Each section uses the following general 
form:

.label utility-name utility-parameters
section-information

.End
where

label
Specifies the name of a section. A label can be any string combination of letters and 
numbers, but must always start with a dot (.).

utility-name
Specifies the utility Capture uses for the section. The acceptable utilities are: Flags, 
GateAndPinSwap, and UpdateProperties
Flags The flags section marks the view of the design, and the design 

name and path.
GateAndPinSwap A section using this utility behaves identically to a Gate and Pin 

Swap file.
UpdateProperties A section using this utility behaves identically to an Update 

Properties file.

utility-parameters
Specifies the parameters of the utility for the section. All utility parameters only apply to 
UpdateProperties.
Parts Specifies only parts are updated. If both Parts and Nets are 

specified as parameters, Nets overrides Parts.
Nets Specifies only nets are updated. If both Parts and Nets are 

specified as parameters, Nets overrides Parts.
OnlyStuffEmpties Specifies that only empty properties are updated. If a property 

already contains a value, then it is not modified. If this parameter 
is not specified, UpdateProperties unconditionally updates all 
properties.

UppercaseCombinedSpecifies that a case insensitive match is to be attempted when 
comparing the match string with the combined property string.

UppercaseStuffString Specifies that the update string will be uppercased before 
updating the property, but after string matching.

section-information
Specifies the actions the utility performs for the section. If the utility is GateAndPinSwap, 
these lines use the normal Gate and Pin Swap file format. If the utility is 
UpdateProperties, these lines use the normal Update Properties file format. If the utility is
Flags, the section contains the following lines:

View = design-view
DesignName = path



where design-view is either Logical or Physical, and path specifies the design file 
name and path.

Sample swap and update file
.Label1 Flags
   View = Physical
   DesignName = C:\ORCADWIN\CAPTURE\DESIGN\FULLADD.DSN
.End

.Label2 GateAndPinSwap
   GateSwap            R1     R2
   PinSwap             R3     "1"     "2"
   ChangeRef           R4     R10
.End 

.Label3 UpdateProperties Parts
   "{Part Reference}"  "Notes"
   "R10"               "This used to be R4"
   "R3"                "Notice pins 1 and 2 are swapped"
   "R1"                "This used to be R2"
   "R2"                "This used to be R1"
.End

.Label4 UpdateProperties Nets
   "{Net Name}"        "Trace Width"
   "VCC_WAVE"          "0.040"
   "GND Power"         "0.040"
.End

Related topics
Types of swap specifications
Inherent properties
Combined property strings
Error messages
Gate and Pin Swap command
Processing your design
Updating part or net properties
Update Part References
Update Properties command
Design Rules Check



Creating a swap file
A swap file is a text file containing old and new part references for use with the Gate and Pin
Swap command. Swap files are typically created by another application, such as OrCAD's 
PCB 386+ or Layout for Windows. You can also create a swap (.SWP) file using any text 
editor that allows you to save the file in ASCII format. The file can include comments; any 
text to the right of a semicolon is ignored by the Gate and Pin Swap tool.
In a swap file, each line (unless preceded by a semicolon) causes one action. The elements 
of each line may be separated with any number of space or tab characters. In general, the 
first element of the line specifies the type of swap. If no swap type is specified, CHANGEREF 
is assumed. The other swap types are GATESWAP and PINSWAP. For more information on the 
types of swaps, see Types of swap specifications.
When you are creating a swap file, include only the changes from the present state of the 
schematic design to the state you want it to have. For example, you might place a part as 
U1 in the schematic design, and change it in a PCB layout package first to U2, then to U3. 
The swap file should reflect the change from U1 to U3; do not include the intermediate step 
involving U2.
For gate swaps, make sure that the gates being swapped are of the same type. If they are 
not, you may get incorrect results.
For pin swaps, an additional element---the part reference---must be specified before the old 
and new values, as shown in the following example. Pin swap is limited to pins of the same 
type and shape on the same part. For example, you can swap data pins on U5B, but you 
cannot swap a pin on U5B with a pin on U5C.

Sample swap file
CHANGEREF U1  U2         ; Change part reference U1 to U2
CHANGEREF U1A U1B        ; Change part reference U1A to U1B
          U1C U2B        ; Change part reference U1C to U2B
GATESWAP  U1  U2         ; Change part U1 to U2 and part U2 to U1
GATESWAP  U1A U1B        ; Swap gates U1A and U1B
PINSWAP   U7  1    2     ; Swap pins 1 and 2 on U7
PINSWAP   U5B "D0" "D1"  ; Swap the pins named D0 and D1 on U5B
PINSWAP   U3  5    6     ; Swap pins 5 and 6 on U3

 

Related topics
Types of swap specifications
Combined property strings
Error messages
Creating a combined swap and update file 
Gate and Pin Swap command
Processing your design
Update Part References
Update Properties command
Design Rules Check



Gate and Pin Swap does not check part types before performing the specified swap. If you 
swap gates between parts of different types (as shown in the following example), you may 
see unwanted results in your design.
GATESWAP  U1C U2B        ; Swap gates U1C and U2B



Gate and Pin Swap does not check part types before performing the specified swap. If you 
swap gates between parts of different types (as shown in the following example), you may 
see unwanted results in your design.
GATESWAP  U1C U2B        ; Swap gates U1C and U2B



Swap files created by OrCAD's PCB 386+ are called "was/is" files. These files contain no 
swap keywords, so each line is treated as a CHANGEREF specification. The third line of the 
example shows how changes are specified in a was/is file created by PCB 386+.



Types of swap specifications
Gate and Pin Swap recognizes three keywords. An omitted keyword is treated as an implied 
CHANGEREF.

CHANGEREF
Changes the specified part's reference.
Examples

CHANGEREF U1  U2         ; Change part reference U1 to U2
CHANGEREF U1A U1B        ; Change part reference U1A to U1B
          U1C U2B        ; Change part reference U1C to U2B

GATESWAP
Swaps the specified parts or packages. If U1 and U2 are multiple-part packages, then all 
the devices in U1 will change to U2, and vice versa---U1A, U1B, and U1C change to U2A, 
U2B, and U2C, respectively; U2A, U2B, and U2C change to U1A, U1B, and U1C, 
respectively.
Examples

GATESWAP  U1  U2         ; Change part U1 to U2 and  
               ;   part U2 to U1

GATESWAP  U1A U1B        ; Swap gates A and B on U1
GATESWAP  U1C U2B        ; Swap gates U1C and U2B

PINSWAP
Swaps two pins on the specified part. Only pins of the same type and shape on the same 
part can be swapped. The pins can be identified by name or number. Pin names must be 
enclosed in double quotation marks. PINSWAP can be used multiple times on the same 
pins in a swap file.
Examples

PINSWAP   U5B "D0" "D1"  ; Swap the pins named D0 and D1 on U5B
PINSWAP   U3  5    6     ; Swap pins 5 and 6 on U3

CHANGEPIN
Changes the first pin with the second pin. Only pins of the same type and shape on the 
same part can be swapped. The pins can be identified by name or number. Pin names 
must be enclosed in double quotation marks. CHANGEPIN can only be used once on each
pin in a swap file.
Examples

CHANGEPIN   U5B "D0" "D1"  ; Changes pin D0 to D1 on U5B
CHANGEPIN   U3  5    6     ; Changes pin 5 to pin 6 on U3 

Related topics
Error messages
Gate and Pin Swap command



Checking for design rule violations
The Design Rules Check tool scans schematics to verify that a design conforms to design 
rules; it generates a report of error and warning messages and places markers on the 
schematic page to help you locate problems. You can specify the conditions that cause error 
or warning messages. The Design Rules Check tool is ideal for catching problems such as 
bus contention or shorted power pins before you reach simulation or synthesis tools.
Optional checks performed by Design Rules Check include off-grid parts; connected aliases, 
hierarchical ports and off-page connectors; unconnected wires, pins, ports, and off-page 
connectors; identical part references; type mismatch parts; and constructs that are not 
portable to SDT.
To set up and run the design rule checker
1 In the design manager window, choose logical or physical view as appropriate, and select 

schematics or schematic pages if you wish to process only part of the design.
2 From the Tools menu, choose the Design Rules Check command (ALT, T, D), then choose the

Design Rules Check tab. The Design Rules Check dialog box opens.
3 From the list of conditions in the Report group box, enable those you want Design Rules 

Check to include in the report and provide a name for the report file. You'll also need to 
select the Check design rules button.

4 Choose the ERC Matrix tab.
Each cell in the matrix refers to an electrical connection between the signal types that 
intersect in the cell. If a cell contains a "W," Design Rules Check generates a warning 
message when it encounters the specified connection. An "E" in a cell tells Design Rules 
Check to generate an error message. If you leave a cell empty, Design Rules Check issues
no warning for connections.

5 Place the pointer over a cell and click the left mouse button to change from "W" to "E" to 
empty and back to "W." An error marks a condition which must be fixed, while a warning 
marks a condition which may or may not be acceptable in your design.

6 When the matrix is just as you wish it to be, choose the OK button to initiate the check.
 

Shortcut
Toolbar:

Related topics
Processing your design
Interpreting Design Rules Check reports
Design Rules Check sample report file
Design Rules Check back annotation
View DRC Marker dialog box
Using no connects
Error messages



If you request a design rules check of a single schematic page, Capture checks the entire 
schematic. This insures that all nets on the page are valid.

If you request a check of hierarchical ports, Capture checks the attached schematics.



Interpreting Design Rules Check reports
When you run the Design Rules Check tool, Capture creates a report (.DRC) of warning and 
error messages. You can view the report in a text editor. These messages also appear in the 
session log. See Error messages for explanations of the messages.
In addition to the report, the Design Rules Check tool places error markers on the schematic 
pages, and places warning markers if you select the Create DRC markers for warnings option
on the dialog box. For more information, see Design Rules Check back annotation.

Related topic
Design Rules Check sample report file
Checking design rules
Design Rules Check back annotation
View DRC Marker dialog box
Using no connects
Design Rules Check command



Design Rules Check back annotation
When you run the Design Rules Check tool, any errors are marked directly on your schematic
pages. Warnings are also marked if you select the option to Create DRC markers for 
warnings. A list of the markers can be displayed in the browse pane of the design manager 
and you can search for specific errors or warnings.
Each time you run the Design Rules Check tool, any existing markers are removed. This 
means that you are always looking at the latest results. You can remove all markers from 
your schematic pages by running Design Rules Check and selecting the option to Delete 
existing DRC markers.
To browse DRC markers
1 In the design structure pane of the design manager, select the schematic or schematic 

page which you wish to browse.
2 From the Edit menu, choose Browse, then choose DRC Markers (ALT, E, B, D). A list of DRC 

markers displays in the browse pane.
3 Double-click on any list element. The schematic page editor opens with the marker 

displayed and highlighted.
To search for specific DRC markers

In the design manger, choose the Browse command (ALT, E, B).
or

1 From the Edit menu, choose the Find command (ALT, E, F).The Find dialog box opens.
2 In the Find What text box, enter the DRC Error.
3 In the Scope group box, select DRC Markers, and then choose the OK button. The 
schematic page editor opens with the DRC marker displayed in the selection color.

Related topic
Checking design rules
Design Rules Check sample report file
Interpreting DRC reports
View DRC Marker dialog box
Design Rules Check command



Creating a bill of materials
Using the Bill of Materials command, you can create a standard tab-delimited part list, or 
you can create a custom bill of materials showing properties that you specify. With either of 
these formats, you can add information about any part by merging an include file with your 
bill of materials. The standard bill of materials includes the item, quantity, part reference, 
and part value.
You can create nonelectrical parts---such as screws, washers, sockets---that appear in the bill
of materials, but not in a netlist because they don't have pins. Any part that has no pins is 
considered nonelectrical.
You may specify any header information you wish. The header of a bill of materials usually 
contains information such as the design name, the date, document number, revision code, 
report name, page number, and the time the report is created. If you enter nothing in the 
Header text box, there is no header.
To create a bill of materials
1 In the design manager window, choose logical or physical view as appropriate, and select 

schematics or schematic pages if you wish to process only part of the design.
2 From the Tools menu, choose the Bill of Materials command (ALT, T, B). The Bill of Materials 

dialog box displays.
3 Verify that the dialog box selections are just the way you want them. If you want to 

customize the information contained in the bill of materials report, fill in the information in
the Line Item Definition group box.

4 Choose the OK button to create a bill of materials.
To merge information from an external database
1 Create an include file (see Creating an include file for instructions).
2 Perform the steps above. In the dialog box, you need to check the Merge an include file 

with report check box and specify the name of the include file.
To create a custom bill of materials
1 From the Tools menu, choose the Bill of Materials command (ALT, T, B). The Bill of Materials 

dialog box displays.
2 Enter the header you want in the "Header" text box. If you enter nothing in the Header 

text box, there is no header.
3 In the "Contents combined property string" text box, list the names of the properties you 

want in the report. If you want the property values to be separated by literals, include the 
literals in the text box. See Combined property strings for more information.

4 Make other selections to suit your needs, then choose the OK button to create a bill of 
materials.

Shortcut
Toolbar:

Related topics
Combined property strings
Creating an include file
Bill of Materials sample report file
Processing your design
Bill of Materials command





Creating an include file
You can use an include file to have Create Bill of Materials add information that's not in the 
schematic to the final bill of materials. You can create an include (.INC) file using any text 
editor that allows you to save the file in ASCII format.
The first line of the include file is a header. The bill of materials is normally keyed to the part 
value, so the first line begins with a pair of single quotes with no spaces or other characters 
between them. The rest of the first line contains any information you want to include to 
make the file and the bill of materials more readable---this usually consists of headers for 
the values in the rest of the file.
The rest of the file contains a separate line for each part. Each line must begin with the 
property value (as specified in the Combined property string in the Include File area of the 
Bill of Materials dialog box) enclosed in single quotes. Following the property value (and on 
the same line) is the information that you want to add to the bill of materials. You can 
separate the part value from the additional information by any number of spaces or tab 
characters---Capture will align the first nonblank character in each line when it creates the 
bill of materials.

Sample include file
''     DESCRIPTION             PART ORDER CODE
'1K'   Resistor 1/4 Watt 5%    10000111003
'4.7K' Resistor 1/4 Watt 5%    10000114703
'22K'  Resistor 1/4 Watt 5%    10000112204
'1uF'  Capacitor Ceramic Disk  10000211006
'.1uF' Capacitor Ceramic Disk  10000211007

Related topics
Bill of Materials sample report file
Combined property strings
Error messages
Bill of Materials command
Processing your design



Note that screws, washers, and other hardware appear in a bill of materials, but not in a 
netlist. Netlists include only objects with pins.



Include files for Capture have the same format as the include files used by Create Bill of 
Materials in OrCAD's SDT 386+. You can use an SDT 386+ include file without modification 
to create a bill of materials in Capture.



Creating a cross reference report
The Cross Reference tool creates a report, indexed by schematic page, of all parts with their 
part references, part names and libraries. You may specify that the report also list the 
unused parts in multiple-part packages and the coordinates of all parts.
To create a cross reference report
1 In the design manager window, choose logical or physical view as appropriate, and select 

schematics or schematic pages if you wish to process only part of the design.
2 From the Tools menu, choose the Cross Reference command (ALT, T, C). The Cross 

Reference Parts dialog box displays.
3 Configure the dialog box to suit your project. In the dialog box, you specify a name for the

report file and whether the parts are listed in order by part value or by part reference.
4 Choose the OK button to create a cross reference report.

Shortcut
Toolbar:

Related topics
Cross Reference sample report file
Processing your design
Combined property strings
Cross Reference command



Using Capture with PLD 386+
There are two methods for using Capture to design a programmable logic device for 
Programmable Logic Design Tools 386+. One is to draft the internal logic of a programmable 
logic device as a schematic, then convert the schematic to an OrCAD Hardware Description 
Language (OHDL) file that is used by the PLD logic compiler. The other method is to place 
the logic definition directly on a schematic, then extract signal placement and source 
statements from the schematic to create one or multiple unique OHDL files. For more 
information about using PLD 386+, see the Overview in the Programmable Logic Design 
Tools User's Guide.

To convert schematic logic to an OHDL file
1 Create a schematic of the logic design using the TTL or PLDGATES schematic symbol 

libraries. For more information, see Placing a part instance.
2 Use pad symbols from the PLDGATES library to declare external signals. The Create Netlist

(ALT, T, N) command on the Tools menu derives external signal names from the label 
adjacent to the pad symbol.

3 Place hierarchical ports or off-page connectors to transmit signals across the boundaries 
of schematic pages.

4 Place pipe-PLD and/or VECTORS text on the schematic. Pipe-PLD and VECTORS text is 
used to document OHDL source code that cannot be expressed by the schematic circuit. 
These might include the architecture specification, Open-PLA property keywords, and test 
vector commands.

5 Use the Update Part References (ALT, T, U) command on the Tools menu to assign unique 
part references to all components of the design.

6 Use the Create Netlist command on the Tools menu to create an OHDL netlist in the 
OrCAD Hardware Description Language format. To do this, you choose the OHDL tab in the
Create Netlist dialog box.

To extract PLD source code from a schematic

The logic definition for the PLD consists of a series of text objects placed on the board-level 
schematic.
1 Create a schematic that contains the PLD logic you wish to extract. Use the MEMORY.OLB 

library or your own custom libraries to place symbols of programmable devices.
2 Edit the part name and pin names of each programmable device to suit the logic design. 

The part values must be eight or fewer characters. For more information, see Editing part 
instances.

3 Use the Text command (ALT, P, T) on the Place menu to place PLD source statements 
directly on the schematic page. See Placing and editing text for instructions and follow 
the rules below.

Each programmable device on a schematic must have a set of source statements.
For each programmable device, the first line of text associates the OHDL source 

statements with the part and has the form |PLD part name (the vertical bar, or pipe, followed
by "PLD," a space, and the part name).

Place source statements in a single text object; press CTRL+ENTER in the text box to 
align source statements by forcing line breaks.

The pipe character (|) precedes each source statement; comment lines do not start 
with the pipe character and are ignored by the Extract PLD command.

For each programmable device, the pipe characters that precede the source 
statements must be vertically aligned.
4 On the View menu, verify that you are in the logical view.
5 From the design manager's Tools menu, choose the Extract PLD (ALT, T, X) command to 



display the Extract PLD dialog box. If you choose the Extract all parts option, Extract PLD 
creates an OHDL (*.PLD) compiler directive file for each programmable device. If you 
choose the Produce a report listing extracted file option, Extract PLD creates a file (*.RPT) 
that lists the extracted files.

Related topics
Placing a part instance 
Editing part instances
OrCAD Hardware Description Language netlist format
Processing your design
Extract PLD command
Extract; PLD sample .PLD file
Combined property strings
Placing and editing text
Update Part References command
Create Netlist command



Using Capture with PCB 386+
You can use Capture design a PC board for layout in PC Board Layout Tools 386+. Capture 
can also read PCB 386+ Was/Is files. For information about PCB 386+, see the PC Board 
Layout Tools 386+ Reference Guide and User's Guide.

To create a netlist for use with PCB 386+
1 From the design manager's Tools menu, choose the Create Netlist command (ALT, T, N).
2 Choose the PCB tab, enter the netlist filename, and choose the OK button.
To read a PCB 386+ Was/Is file
1 From the design manager's Tools menu, choose the Gate and Pin Swap command ().
2 Specify the name of the Was/Is file created in PCB 386+, and choose the OK button.

Related topics
Types of swap specifications
Creating a swap file 
Processing your design
PCB tab
Create Netlist command
Gate and Pin Swap command



Using Capture with VST 386+
Capture can be used in conjunction with Digital Simulation Tools 386+ to capture a logic 
design as a schematic or to capture a simulation model design as a schematic.
To prepare a design for simulation in Digital Simulation Tools 386+
1 Determine what devices can be simulated in VST 386+. To do this, run VST 386+ and 

refer to MODEL.LST in View Reference Material.
2 Draw the schematic.
3 Add a user-defined property called Trace to pins, wires, and busses that you want to view 

in the simulator.
4 Add a user-defined property called Stimulus to pins and wires that you want to stimulate 

in the simulator.
5 Add a user-defined property called Vector to pins, wires, and busses that you want to 

associate with a particular column of values in a test vector file.
6 Use the Design Rules Check command (ALT, T, D) on the Tools menu to clean up the 

schematic page.
7 Use the Create Netlist command (ALT, T, N) on the Tools menu to create one or more OrCAD

Digital Simulation Tools Model netlists.

Related topics
Combined property strings
Processing your design
Create Netlist command
Design Rules Check command
VST Model netlist format





Working with designs, schematics, and schematic pages
All the schematics and parts for one project are stored in a single file called a design. A 
design contains a design cache plus one or more schematics. The design cache acts like an 
embedded library; it contains a copy of all the parts used in the design. A schematic is a 
container for one or more schematic pages. The schematic page is analogous a sheet of 
drafting paper.
For example, you might have a simple widget project composed of input, processing, and 
output circuits. It is possible that the output circuit will not fit on your plotter paper but is 
conveniently divided into display, gain, and power circuits. In this case, the design is Widget 
and the file is WIDGET.DSN. Widget contains three schematics: Input, Processing, and 
Output. Input, and Processing contain one schematic page each, while Output contains three
schematic pages: Display, Gain, and Power. The design cache for Widget contains all the 
parts that are on the five schematic pages.
As a design contains schematic and schematic pages, so does a library contain parts, 
symbols and title blocks. Libraries can also contain schematics. Each design can access any 
number of libraries, and any library can supply parts to any number of designs. Designs and 
libraries are files, so you can work with them in the Windows File Manager as well as in 
Capture.

Related topics
Browsing a design or a library
Logical view and physical view
Using the session log
Creating a design
Creating a schematic or schematic page in an existing design
Opening an existing design
Moving schematics between designs
Moving schematic pages between designs
Copying a schematic to or from a library
Renaming a document
Eliminating unique properties of your physical view
Logical View command
Physical View command
Rebuild Physical View command



Creating a design
Because a new design inherits characteristics from the design template, it is recommended 
that you check the design template before you create a design.
The first time you save a new design, the Save As dialog box displays, giving you the 
opportunity to specify a drive and replace the system-generated name.
To create a new design

From the File menu in the design manager, choose the New command, and then 
choose the Design command (ALT, F, N, D). The design manager displays a new design 
containing one schematic that contains one schematic page. The schematic icon is marked 
with a backslash character (\) to signify that it is the root schematic. All of these documents 
have system-generated names.
 

Shortcut
Toolbar:

Related topics
Creating a schematic or schematic page in an existing design
Moving schematics between designs
Moving schematic pages between designs
Renaming a document
Closing a design or library
Creating a part
Creating a library
Opening an existing design
Copying a schematic to or from a library
Configuring Capture
Creating a multiple-page schematic
New Design command



Opening an existing design
To open an existing design
1 From the File Menu, choose Open, and then choose Design (ALT, F, O, D)The Open Design 

dialog box displays.
2 If the design you wish to open is not listed in the File Name text box, do one or more of 

the following:
In the Drives box, select a new drive.
In the Directory box, select a new directory.
In the Saved File Type box, select another type of file.
In the File Name text box, enter a portion of the file name---you can use the standard 

"*" and "?" wildcard characters
3 Select the design or type the name in the File Name text box, and choose the OK button. 

The design opens in a design manager window.
To open a recently used design

From the File menu, choose the design either by name or by number (ALT, F, n). The 
design opens in a design manager window.

Related topics
Creating a design
Open command
1, 2, . . . command
Closing a design or library



Closing a design or library
When you close a design or library, Capture offers to save any changes.
To close a design or library

From the File menu of the design manager, choose the Close command (ALT, F, C).

Related topics
Open command
1, 2, . . . command
Close command



Saving a design
When you save a design, you are saving all the schematics and schematic pages residing in 
the design. If you have several pages open in schematic page editor windows, changes you 
have made to any of them are saved. In addition, changes made by the Capture tools are 
saved to disk.
To save one design

From the File menu of the design manager, choose the Save command (ALT, F, S). If the
design is new and has not yet been saved, the Save As dialog box displays, giving you the 
opportunity to specify a drive and replace the system-generated name.
To save all open designs

From the File menu of the design manager, choose the Save All command (ALT, F, A). 
Any open designs or libraries that have been modified are saved.
 

Related topics
Saving in SDT format
Save All command
Save As command
Closing a design or library
Save command



When you save a design or a library, Capture automatically creates a backup with a .BAK 
file extension. If you save only a schematic page or a part, no backup is generated.



Working with multiple designs and libraries
Each design and library you open displays in its own design manager window. You can move 
schematics or schematic pages from one design to another by dragging them from one 
window to the next. To copy pages from one design to another, you simply press the CTRL key
while you drag the pages from one window to another. You can bring a window to the top 
and make it active by clicking on

Related topics
Using drag and drop with documents
Working with multiple windows
Moving schematics between designs
Moving schematic pages between designs
Renaming a document
Creating a schematic or schematic page in an existing design
Cut command
Copy command
Paste command



Moving schematics between designs
If you are working in one design and you want to use one or more schematics that are in 
another design, that's not a problem. You can transfer schematics from one design to 
another, or you can create a copy for use in multiple designs. You cannot, however, move or 
copy a schematic into the design cache of any design.
A schematic that is open in an editor cannot be moved or copied.
To move schematics from one design to another
1 Verify that no Capture editor is open on any part of the schematic.
2 In the design manager, select the schematics you wish to move.
3 From the Edit menu, select the Cut command (ALT, E, T). If you wish to have a copy of the 

schematic in both designs, select the Copy command (ALT, E, C).
4 Open the design in which you want to use the schematics.
5 From the Edit menu, select the Paste command (ALT, E, P).
6 From the File menu, choose the Save command (ALT, F, S). Do this for both designs.
or
1 Verify that no Capture editor is open on any part of the schematic.
2 In the design manager, open both designs.
3 Drag and resize the two design manager windows so that each is visible.
4 Select the schematics that you wish to move, then drag the schematic or schematic page 

to the second design manager window. If you wish to have a copy of the schematic in 
both designs, press and hold CTRL while you are dragging.

5 From the File menu, choose the Save command (ALT, F, S). Do this for both designs.
 
 

Related topics
Using drag and drop with documents
Working with multiple windows
Moving schematic pages between designs 
Creating a schematic or schematic page in an existing design
Renaming a document
Copy command
Cut command
Paste command



If you move or copy a parent schematic or schematic page from one design into a second 
design, Capture remembers the name and directory of the file containing the child 
schematic or schematics. This information is stored in the Attach Schematic dialog box for 
each hierarchical block and nonprimitive part.



Moving schematic pages between designs
If one of your designs has one or more schematic pages that solve a problem of a second 
design, you can easily transfer the pages from one design to another, or you can place 
copies in both designs. Because all schematic pages must be contained in a schematic, a 
schematic to hold the pages must exist in the second design before you can place the 
pages.
A schematic page that is open in an editor cannot be moved or copied.
To move schematic pages from one design to another
1 Verify that the pages are not open in the schematic page editor or the spreadsheet editor.
2 In the design manager, select the schematic pages you wish to move.
3 From the Edit menu, select the Cut command (ALT, E, T). If you wish to have a copy of the 

pages in both designs, select the Copy command (ALT, E, C).
4 Open the design in which you want to use the schematic pages.
5 Select the schematic that will hold the pages.
6 From the Edit menu, select the Paste command (ALT, E, P).
7 From the File menu, select the Save command (ALT, F, S). Do this for both designs.
or
1 Verify that the pages are not open in the schematic page editor or the spreadsheet editor.
2 In the design manager, open both designs.
3 Drag and resize the two design manager windows so that each is visible.
4 Select the schematic pages that you wish to move, then drag them to the appropriate 

schematic in the second design manager window. If you wish to have a copy of the pages 
in both designs, press and hold CTRL while you are dragging.

5 From the File menu, select the Save command (ALT, F, S). Do this for both designs.
 
 

Related topics
Using drag and drop with documents
Working with multiple windows
Moving schematics between designs
Renaming a document
Copy command
Cut command
Paste command



If you copy or move a document from one design or library to another, you should save the 
destination design or library immediately. If you do not, you may lose data if you open the 
moved document in the schematic page editor or part editor and then close the editor 
without saving the document.



If you copy or move a document from one design or library to another, you should save the 
destination design or library immediately. If you do not, you may lose data if you open the 
moved document in the schematic page editor or part editor and then close the editor 
without saving the document.



Using drag and drop with documents
You can use the standard Windows drag-and-drop operation to move or copy Capture 
documents in the design manager windows. If you wish to copy rather than move, you 
simply press and hold the CTRL key while you drag the document.
If you drag a part that has alias parts, the alias parts also move. In the context of dragging 
and dropping, a symbol behaves just as a part does---as shown in the table below, a symbol 
can be dragged from a library and dropped in another library.
A document that is open in an editor, or one that contains any open elements, cannot be 
dragged.
Documents can be dragged as indicated in the following table:

Drag from . . . Part Sch.
Page

Schemati
c

Design to design --- Yes Yes
Design to library Yes Yes Yes
Schematic to 
schematic

--- Yes ---

Library to design --- --- Yes
Library to library Yes --- Yes

Related topics
Moving schematic pages between schematics
Moving parts between libraries
Working with multiple windows
Working with multiple designs
Moving schematics between designs
Moving schematic pages between designs
Copying a schematic to or from a library
Copying a schematic page to a library
Copying a part from the design cache to a library 



Renaming a document
In Capture, the windows in which you work have headings based upon the name of the open 
document. You can simplify your search through a set of open windows by not using identical
names for several documents.
When you create a new part, symbol, schematic, schematic page, design, or library, you can
specify a name or accept the unique name Capture assigns it.
To rename a schematic page, symbol, or part
1 In the design structure pane of the design manager, select the document you wish to 

rename.
2 From the Design menu, select the Rename command (ALT, D, R).
3 In the dialog box that displays, enter the new name and choose the OK button. The name 

change is in effect immediately.
To rename a schematic
1 In the design structure pane of the design manager, select the schematic you wish to 

rename.
2 From the Design menu, select the Rename command (ALT, D, R).
3 In the dialog box that displays, enter the new name and choose the OK button. The name 

change is in effect immediately.
To rename a design or library

Use the Windows File Manager to rename the design or library file.
To save a design or library under a different filename
1 Open or activate the design manager window for the design or library.
2 From the File menu, choose the Save As command (ALT, F, A).
3 Enter the new filename in the File Name text box, and choose the OK button.

Related topics
Rename command
Save As command



In Capture, the windows in which you work have headings based upon the name of the 
open document.



Renaming a library in this manner breaks the links between the library and parts selected 
from it, so the Update Cache command does not work. Such libraries also are not listed in 
the CAPTURE.INI file for configuration.



Creating a schematic or schematic page in an existing design
A newly-created design contains a schematic that holds one schematic page. After you 
create a schematic, you can move existing pages into it, and you can create new pages in it.
To create a schematic
1 Open the design that will hold the new schematic.
2 From the Design menu, choose the New Schematic command (ALT, D, S)
3 Enter the schematic name and choose the OK button. The new schematic is listed in the 

design structure pane of the design manager window.
To create a schematic page
1 In the design manager window, select the schematic that will hold the new schematic 

page or any schematic page in that schematic.
2 From the Design menu, choose the New Schematic Page command (ALT, D, P).
3 Enter the page name and choose the OK button. The new schematic page is listed under 

the schematic in the design structure pane of the design manager window.
 
 

Related topics
Renaming a document
Creating a design
Moving schematics between designs
Moving schematic pages between designs
New Schematic command
New Schematic Page command
Make Root Schematic command



If you are editing a schematic page, just click the New button on the toolbar to open a new 
schematic page in the same schematic. For more information, see The toolbar.



Browsing a design or a library
Using the design manager, you can list objects and sort them with the press of a button. This
makes it easy to find, select, and edit objects.
For example, you can list the parts in your design and sort them by part reference or part 
value; you can list all objects by part value, then add a footprint property to all parts with 
the same value; when you are debugging your design, you can list all of the error markers 
and jump to them one by one.
To browse a design

From the Edit menu, choose the Browse (ALT, E, B) command, then choose the browse 
category from the pull-right menu. For each category, the parameters given below display in
the browse pane of the design manager.

Parts Reference, value, source part, source library, page
Nets Name, netname, page, schematic
Hierarchical ports Port name, page, schematic
Off-page connectors Connector name, page, schematic
Bookmarks Bookmark name, page, schematic
DRC markers DRC error, DRC detail, DRC location, page, schematic

If you double-click an item in the browse pane, the schematic page opens with that item 
selected. Or you can select several items, then select the Properties command from the Edit 
menu to open the spreadsheet editor.
To display a list of parts in a library

Open the library. A list of parts displays in the design structure pane of the design 
manager window.
or

From the schematic page editor's Place menu, choose the Part command (ALT, P, P).
To display a list of parts in the design cache

In the design structure pane of the design manager, double-click on the Design 
Cache icon.

Shortcut
Toolbar:

Related topics
Sorting the browse results
Searching for a part in the libraries
Design manager window
Browse Parts command
Browse Nets command
Browse Ports command
Browse Off-Page Connectors command
Browse Bookmarks command
Browse DRC Markers command
Find command



Eliminating unique properties of your physical view
Within a design, you can use the circuitry of one schematic in several locations by simply 
placing hierarchical blocks that refer to the schematic. When you place the hierarchical 
blocks, the circuitry and all its properties are identical.
In the physical view, you can assign or edit properties to distinguish one occurrence of an 
object from its counterparts. If you want to eliminate that uniqueness and revert to a 
condition in which all occurrences match the single instance, then you reset the physical 
view of your document.
To reset the physical view
1 From the View menu, choose the Physical View command (ALT, V, P).
2 From the Design menu, choose the Rebuild Physical View command (ALT, D, V).

Related topics
Rebuild Physical View command
Logical View command
Physical View command



Displaying your registration number
Because your Capture registration number is your key to technical support, it's good to have
easy access to the number.

From the Help menu, choose the About Capture command (ALT, H, A).

Related topic
About Capture command
Product support



Working with multiple windows
In Capture, each document that you open is in a separate window. You may open as many 
windows as your computer's resources can handle. If you wish to work with three schematic 
pages or three parts, each opens in its own window. If you are working simultaneously with 
several designs, each opens in its own design manager window.
Sometimes it is useful to have more than one view of a document. You might display 
different areas of the document at different zoom scales, or copy items from one location to 
another. Capture maintains and displays the selection set across all views of a part or 
schematic page.
For example, you might open a schematic page and then use the New Window command 
(ALT, W, N) to open it in a second window, shrink that window, and use the Zoom command 
and then the All command (ALT,V, Z, L) to create a bird's eye view of the schematic page. 
Anything you select in this window is also selected in the "close-up" window. In that window, 
you could use the Zoom command and then the Selection command (ALT,V, Z, E) to zoom in 
on the selected objects.
Similarly, you can use the splitter bars to split your view, and then move objects across the 
splitter bar and place wires, busses, arcs, and polylines that span the splitter bar. This is very
useful for working on large schematic pages.
To open a window on the active document

From the Window menu, choose the New Window command (ALT, W, N).
To open a window on another document

From the File menu, choose the New command, and then choose the Design 
(ALT, F, N, D) or Library (ALT, F, N, L) command.
or

From the File menu, choose the name of a recently used file (ALT, F, n).
To switch to a different open window

From the Window menu, select the window that you wish to make active.
To switch to the design manager for the active document

Click on the Design Manager button on the toolbar.
To save all open windows

From the File menu of the design manager, select the Save All command (ALT, F, A). All 
designs or libraries that have been modified are saved.

Related topics
1, 2, 3, 4 command
New Window command



Configuring Capture
Capture provides different levels of configuration. Using commands on the Options menu, 
you can:

Customize the working environment specific to your system (set preferences).
Create default settings for new designs (define the design template). These settings 

stay with the design even if it is moved to another system with different preferences.
Override design template settings in individual designs (set design properties) or 

individual schematic pages (set schematic page properties).
Create default settings for new parts (set part properties).
Override default properties on individual parts (set package properties).

No matter where you are in Capture, the Options menu always has a Preferences command 
and a Design Template command. In addition, the Options menu contains a command 
specific to the current active window. For example, the design manager's Options menu 
contains the Design Properties command, while the schematic page editor's Options menu 
contains the Schematic Page Properties command.
The settings on the Preferences dialog box determine how Capture works on your system 
and persist from one Capture session to the next. In other words, if you pass a design to 
another person, she doesn't inherit your preference settings. This means that you can set 
colors, grid display, pan and zoom, and other things to your liking, and they won't change if 
you work on a design created on another system.
The Design Template dialog box determines the characteristics of all the designs created on 
your system. Because a new design inherits characteristics from the current design 
template, it's a good idea to check the design template before you create a new design.
Once you begin working on a design, you can customize its particular characteristics by 
choosing Design Properties from the Options menu when you are in the design manager, or 
Schematic Page Properties when you are in the schematic page editor.
Similarly, you use the Part Properties and Package Properties commands on the part editor's 
Options menu to set default part properties and customize those settings for individual 
parts.

Related topics
Preferences command
Design Template command
Design Properties command
Schematic Page Properties command
Part Properties command
Package Properties command
Viewing the toolbar
Viewing the tool palette
Viewing the status bar



Viewing the toolbar
The toolbar is located near the upper edge of your Capture window and provides easy 
access to common actions. If you need more clear space on the screen to view your work, 
you can hide the toolbar temporarily and display it again when you wish to use one of the 
tools. All the tools on the toolbar are available as menu commands.
To display the toolbar

From the View menu, choose the Toolbar command (ALT, V, T).

Related topics
The toolbar
Toolbar command
Viewing the tool palette



Viewing the tool palette
The tool palette displays on the schematic page editor and the part editor to provide you 
easy access to editing tools. If you need more clear space on the screen to view your work, 
you can hide the tool palette temporarily and display it again when you wish to use one of 
the tools. With the exception of the selection tool in the upper left corner, all the tools on the
tool palette are available as menu commands.
The tool palette is invisible in the physical view of the schematic page editor and in the 
package view of the part editor.
To display the tool palette

From the View menu, choose Tool Palette (ALT, V, P).
To hide the tool palette

From the View menu, choose Tool Palette (ALT, V, P).
or

Click on the tool palette's control box (in the upper left corner).
On the Select tab in the Preferences dialog box, you can specify whether the tool palette 
displays when you open the schematic page editor or part editor. For more information, see .

Related topics
Schematic page editor tool palette
Part editor tool palette
Select tab (Preferences dialog box)
Tool Palette command
Viewing the toolbar



Viewing the status bar
The status bar displays at the bottom of the Capture window and reports on current actions, 
pointer location, and zoom scale. If you need more clear space on the screen to view your 
work, you can hide the status bar temporarily.
To display the status bar

From the View menu, choose Status Bar (ALT, V, U).

Related topic
The status bar
Status Bar command
Viewing the toolbar
Viewing the tool palette





Commands and Tools
Menu commands and shortcuts

Design manager
Schematic page editor
Part editor
Session log
Shortcuts

Tool buttons
Schematic page editor tool palette
Part editor tool palette
Toolbar

Information
Capture information
Status bar
Design manager window
Part editor window
Session frame window
Session log window
Schematic page editor window



Design manager menu commands

File menu
New
Open
Close
Save
Save As
Save All
Print Preview
Print
Print Setup
Exit
1, 2, 3, 4

Design menu
New Schematic
New Schematic Page
New Part
New Symbol
Rename
Delete
Rebuild Physical View
Make Root Schematic
Replace Cache
Update Cache

Edit menu
Cut
Copy
Paste
Properties
Browse
Find

 View menu
Logical View
Physical View

Tools menu
Update Part References
Gate and Pin Swap
Update Properties
Design Rules Check
Create Netlist
Cross Reference
Bill of Materials
Extract PLD
Export Properties
Import Properties

Options menu
Preferences
Design Template



Design Properties

Window menu
New Window
Cascade
Tile Horizontally
Tile Vertically
Arrange Icons
1, 2, . . .

Help menu
Contents
Search for Help On
Processes
Commands and Tools
Reference
How to Use Help
Learning Capture
Product Support
Help for SDT Users
About Capture



Schematic page editor menu commands

File menu
New
Open
Close
Save
Export Selection
Import Selection
Print Preview
Print
Print Setup
Exit
1, 2, 3, 4

Edit menu
Undo
Redo
Repeat
Cut
Copy
Paste
Delete
Select All
Properties
Part
Mirror
Rotate
Group
Ungroup
Find

View menu
Ascend Hierarchy
Descend Hierarchy
Go To
Zoom
Tool Palette
Toolbar
Status Bar
Grid
Grid References

Place menu
Part
Wire
Bus
Bus Entry
Net Alias
Power
Ground
Off-Page Connector
Hierarchical Block
Hierarchical Port



No Connect
Title Block
Bookmark
Text
Line
Rectangle
Ellipse
Arc
Polyline
Picture

Options menu
Preferences
Design Template
Schematic Page Properties

Window menu
New Window
Cascade
Tile Horizontally
Tile Vertically
Arrange Icons
1, 2, . . .

Help menu
Contents
Search for Help On
Processes
Commands and Tools
Reference
How to Use Help
Learning Capture
Product Support
Help for SDT Users
About Capture

Pop-up menu
Mirror Horizontal
Mirror Vertical
Rotate
Edit Part
Edit
Select Entire Net
Descend Hierarchy
Zoom In
Zoom Out
Go To
Delete



To use the context-sensitive menu commands, select one of more items and then press the 
right mouse button. The contents of the menu depend on the objects selected.



Part editor menu commands

File menu
New
Open
Close
Save
Print Preview
Print
Print Setup
Exit
1, 2, 3, 4

Edit menu
Undo
Redo
Repeat
Cut
Copy
Paste
Delete
Select All
Properties
Mirror
Rotate
Group
Ungroup
Find

View menu
Normal
Convert
Part
Package
Next Part
Previous Part
Go To
Zoom
Tool Palette
Toolbar
Status Bar
Grid

Place menu
Pin
Pin Array
IEEE Symbol
Text
Line
Rectangle
Ellipse
Arc
Polyline
Picture



Options menu
Preferences
Design Template
Part Properties
Package Properties

Window menu
New Window
Cascade
Tile Horizontally
Tile Vertically
Arrange Icons
1, 2, . . .

Help menu
Contents
Search for Help On
Processes
Commands and Tools
Reference
How to Use Help
Learning Capture
Product Support
Help for SDT Users
About Capture

Pop-up menu
Mirror Horizontal
Mirror Vertical
Rotate
Edit
Zoom In
Zoom Out
Go To
Delete



Session log menu commands

File menu
New
Open
Save
Save As
Exit
1, 2, 3, 4

Edit menu
Find

Options menu
Preferences
Design Template

Window menu
Cascade
Tile Horizontally
Tile Vertically
Arrange Icons
1, 2, . . .

Help menu
Contents
Search for Help On
Processes
Commands and Tools
Reference
How to Use Help
Learning Capture
Product Support
Help for SDT Users
About Capture



Shortcuts
In addition to providing menu accelerator keys for menu commands, Capture provides 
shortcut keys for miscellaneous actions like scrolling across an editor's window. An example 
of an accelerator key is ALT, E, T for the Cut command on the Edit menu. Shortcut keys include
CTRL keys (like CTRL+DELETE to delete), SHIFT keys (like SHIFT+P to place a part), and function keys 
(like F4 to repeat a command).
 
 
 
 

All Capture windows
ALT+F4 Exit
ALT, F, X Exit
ALT, SPACEBAR, C Exit

Schematic page editor
CTRL+A Ascend hierarchy
CTRL+D Descend hierarchy
SHIFT+B Place bus
SHIFT+E Place bus entry
SHIFT+N Place net alias
SHIFT+P Place part
SHIFT+W Place wire
SHIFT+Y Place polyline
F6 Go to

Part editor
CTRL+B Previous part
CTRL+N Next part

Schematic page and part editors
CTRL+C Copy
CTRL+E Edit properties
CTRL+F Find
CTRL+G Group
CTRL+P Print
CTRL+R Rotate
CTRL+S Save
CTRL+U Ungroup
CTRL+V Paste
CTRL+X Cut
CTRL+Z Undo
F4 Repeat

DEL Delete (Design and Edit menus)
DELETE Delete (Design and Edit menus)
BACKSPACE Delete (Design and Edit menus)
ENTER Double-click left mouse button
ESCAPE Switch to selection tool (arrow pointer)
SPACE Click left mouse button

UP ARROW Move 1 grid up (grid on) or 0.1 grid up (grid off)



DOWN ARROW Move 1 grid down (grid on) or 0.1 grid down (grid off)
LEFT ARROW Move 1 grid left (grid on) or 0.1 grid left (grid off)
RIGHT ARROW Move 1 grid right (grid on) or 0.1 grid right (grid off)
CTRL+UP ARROW Snap pointer to nearest grid and then move 5 grids up
CTRL+DOWN ARROW Snap pointer to nearest grid and then move 5 grids down
CTRL+LEFT ARROW Snap pointer to nearest grid and then move 5 grids left
CTRL+RIGHT ARROW Snap pointer to nearest grid and then move 5 grids right
PAGE UP Pan up
PAGE DOWN Pan down
CTRL+PAGE UP Pan left
CTRL+PAGE DOWN Pan right

F5 Redraw
SHIFT+C Center the view at the pointer's current position
SHIFT+H Mirror horizontal
SHIFT+I Zoom in
SHIFT+O Zoom out
SHIFT+R Rotate
SHIFT+V Mirror vertical

SHIFT+B Begin a wire, bus, or polyline (corresponding tool active)
SHIFT+E End a wire, bus, or polyline (corresponding tool active)

Session log
CTRL+DEL Clears the session log
CTRL+DELETE Clears the session log

Text boxes
BACKSPACE Delete the selected text
DEL Delete the selected text
DELETE Delete the selected text
CTRL+C Copy the selected text to the Clipboard
CTRL+V Paste the Clipboard contents
CTRL+X Cut the selected text to the Clipboard
CTRL+Z Undo the last edit
DOUBLE CLICK Select the word and any following space
SHIFT+CLICK Extend selection from the insertion point to cursor
CTRL+RIGHT ARROW Jump right one word
CTRL+LEFT ARROW Jump left one word
HOME Jump to the beginning of the line
END Jump to the end of the line
CTRL+HOME Jump to the beginning of the text box
CTRL+END Jump to the end of the text box
SHIFT+HOME Extend selection from the insertion point to the beginning of the 

multiple-line text box
SHIFT+END Extend selection from the insertion point to the end of the multiple-

line text box

Related topics
Toolbar
Schematic page editor tool palette
Part editor tool palette
Schematic page editor pop-up menu commands
Part editor pop-up menu commands
Place Bus command



Place Polyline command
Place Wire command



When you select a tool in the part editor or schematic page editor, the tool palette 
becomes active. As a result, many keyboard shortcuts are not available until you make the 
editor window active again.

The easiest way to do this is to click in the title bar of the editor window as soon as you 
have the tool selected.



You don't have to press the SHIFT key to use most of the SHIFT+ shortcuts. For example, both P
and SHIFT+P produce the same result. They are marked with SHIFT in Help and on Capture 
menus for visibility.



The description of each menu command includes keyboard, mouse, and other shortcuts.



Many shortcuts are available while you use another command. For example, you can use 
SHIFT+I and SHIFT+O to zoom in and out while you move and place objects.



New command (File menu)
Use this command to open a new design or library. Choose a command from the menu that 
displays:

Design
Library

A new design contains one schematic with one schematic page, which Capture opens in the 
schematic page editor. A new library contains no parts or symbols.
The number of open windows you can have in Capture is only limited by your available 
system resources. You can use the Window menu to switch among open Capture windows 
(see 1, 2, . . . command).
You can open an existing design or library with the Open command on the File menu.

Shortcuts
Toolbar:

Keyboard: ALT, F, N

Related topics
Configuring Capture
Connecting to power or ground
Creating a design
Creating a multiple-page schematic
Creating a custom title block
Creating a hierarchical port or off-page connector symbol
Creating a schematic or schematic page in an existing design
Creating a part
Opening a schematic page
1, 2, . . . command
Design Template command
Open command



When you click the New button on the toolbar, Capture creates either a new design or a 
new library, depending on the active window. If you are editing a part or managing a 
library, Capture opens a new library in the design manager. If you are editing a schematic 
page or managing a design, Capture opens a new design and opens the initial schematic 
page in the schematic page editor.



Design command (File menu, New command)
Use this command to open a new design in a design manager window. This is where you 
manage your designs and hierarchies.
You can open an existing design with the Open command on the File menu.

Shortcuts
Toolbar:

Keyboard: ALT, F, N, D

Related topics
Configuring Capture
Creating a design
Design manager menu commands
Design manager window
Design Template command
Open command



Library command (File menu, New command)
Use this command to open a new part or symbol in a part editor window. 
You can open an existing library with the Open command on the File menu.

Shortcuts
Toolbar:

Keyboard: ALT, F, N, L

Related topics
Creating a library
Design manager window
New Part command
New Symbol command
Open command



Open command (File menu)
Use this command to open an existing design or library in a new window. Choose a 
command from the menu that displays:

Design
Library

The number of open windows you can have in Capture is only limited by your available 
system resources. You can use the Window menu to switch among open windows (see 1, 
2, . . . command).
You can open a new design or library with the New command on the File menu.

Shortcuts
Toolbar:

Keyboard: ALT, F, O

Related topics
Editing library parts
Opening a schematic page
Opening several schematic pages at once
1, 2, . . . command (Window menu)
1, 2, 3, 4 command (File menu)
New command



When you click the Open button on the toolbar, Capture asks you to choose a design or 
library. You can specify an SDT design or library by entering *.SCH or *.LIB in the File Name 
text box.



Design command (File menu, Open command)
Use this command to open an existing design in a design manager window. This is where 
you manage your design and hierarchies. 
You can open a new design with the New command on the File menu.

Shortcuts
Toolbar:

Keyboard: ALT, F, O, D

Dialog box options
This command displays a standard Windows dialog box for opening files.

Related topics
Design manager window
Opening a schematic created in SDT
Opening an existing Capture design
New command



Library command (File menu, Open command)
Use this command to open an existing library.
You can open a new library with the New command on the File menu.

Shortcuts
Toolbar:

Keyboard: ALT, F, O, L

Dialog box options
This command displays a standard Windows dialog box for opening files.

Related topics
Creating a part
Design manager window
Opening a library
Opening a library created in SDT
New command



Close command (File menu)
Use this command to close the active design, library, schematic page, or part. If necessary, 
Capture asks if you want to save your changes first.
If you open a part editor via the Part command on the Edit menu, modify the part, and then 
close it, Capture asks if you want to update the current part only, update all parts of this 
type in the design, discard your changes, or cancel the Close command.
You can close any window with the Close command on the document Control menu.

Shortcut
Keyboard: ALT, F, C

Related topic
Closing a design or library



Save command (File menu)
Use this command to save the active document. 
In the design manager, you can save all open modified designs and libraries with the Save 
All command on the File menu. You can save a design, library, or session log under a 
different name with the Save As command on the File menu.

Shortcuts
Toolbar:

Keyboard: ALT, F, S
CTRL+S

Related topics
Copying a schematic to or from a library
Copying a schematic page to a library
Moving parts or symbols between libraries
Moving schematic pages between schematics
Saving library changes
Saving schematic page changes
Preferences command
Save All command
Save As command



Save As command (File menu)
Use this command to save the active design, library, or session log under a different name 
or to save a new, unnamed design, library, or session log. You can save a design, library, 
schematic page, part, or session log with the Save command on the File menu. You can save 
all open modified designs and libraries with the Save All command on the File menu. The 
Save As command opens a standard Windows dialog box to save files.
You can save designs and libraries in Capture, SDT 386+, and SDT Release IV formats with 
this command.

Shortcut
Keyboard: ALT, F, A

Dialog box options
This command displays a standard Windows dialog box for saving files.

Related topics
Renaming a document
Saving in SDT format
Saving library changes
Saving schematic page changes
Translating files
Save command
Save All command



Save All command (File menu)
Use this command to save all open modified designs and libraries. You can save just the 
active design, library, schematic page, part, or session log with the Save command on the 
File menu. You can save a design, library, or session log under a different name with the 
Save As command on the File menu.
The Save All command is available when an open design or library has been modified in any 
way.

Shortcut
Keyboard: ALT, F, E

Related topics
Saving library changes
Saving schematic page changes
Working with multiple windows
Save command
Save As command



Export Selection command (File menu)
Use this command to export the selected objects on a schematic page to a design or library. 
You can later import them onto a schematic page using the Import Selection command on 
the File menu.
This is useful if you have portions of a schematic page that you want to use on different 
schematic pages

Shortcut
Keyboard: ALT, F, E

Dialog box options

Export Selection Name
Specifies the export name of the selected object or objects.

Library
Specifies a path, and a design or library name for the export selection.

Browse
Displays a standard Windows dialog box for selecting files.

Related topics
Copying selected objects
Import Selection command



Import Selection command (File menu)
Use this command to import the contents of a file created with the Export Selection 
command on the File menu to the active schematic page.

Shortcut
Keyboard: ALT, F, I

Dialog box options

Import Selection Name
Specifies the name of the selection to import.

Library
Specifies the library containing the import selection.

Browse
Displays a standard Windows dialog box for selecting files.

Related topics
Copying selected objects
Translating files
Export Selection command



Print Preview command (File menu)
Use this command to see how a schematic page or part will look when printed.
After setting the options in the Print Preview dialog box, choose OK to preview the printed 
document. You can use the buttons at the top of the window to view different pages and to 
zoom in and out.

Shortcut
Keyboard: ALT, F, V

Dialog box options

Default printer
Displays the active printer and printer connection.

Scale
Specifies the scaling factor to print by, or let Capture automatically scale. For more 
information, see Scaling a print or plot.

Page size
If scale to page size is selected, specifies a sheet size for scaling. Choose one of the 
standard page sizes, or a custom size defined in the Schematic Page Properties dialog 
box under the Page Size tab.

Print offsets
Specifies horizontal and vertical printing relative locations.

Print quality
Specifies the resolution of the print in dots per inch.

Print to file
Specifies to print the preview to a file. If you select this option, the Print To File dialog box
displays after you click on OK.

Copies
Type or select the number of copies you want to print.

Collate copies
Prints copies organized in order of page numbers.

Setup
Displays a standard windows dialog box for configuring your printer or plotter.

Related topics
Print preview
Print To File dialog box
Print command
Print Setup command



Be prepared to wait if you attempt to print multiple pages or parts. Depending on the 
number and size of the pages or parts you are previewing, Capture may require extra time 
to display the selection.



Be prepared to wait if you attempt to print multiple pages or parts. Depending on the 
number and size of the pages or parts you are previewing, Capture may require extra time 
to display the selection.



Print command (File menu)
Use this command to print the active schematic page, the active part, or the selected items 
in the design manager.

Shortcuts
Toolbar:

Keyboard: ALT, F, P
CTRL+P

Dialog box options

Default printer
Displays the active printer and printer connection.

Scale
Specifies the scaling factor to print by, or let Capture automatically scale.

Page size
If scale to page size is selected, specifies a sheet size for scaling. Choose one of the 
standard page sizes, or a custom size defined in the Schematic Page Properties dialog 
box under the Page Size tab.

Print offsets
Specifies horizontal and vertical printing offsets.

Print quality
Specify the quality of the print in dots per inch.

Print to file
Specifies to print the preview to a file. If you select this option, the Print To File dialog box
displays after you click on OK.

Copies
Type or select the number of copies you want to print.

Collate copies
Prints copies organized in order of page numbers.

Setup
Displays a standard windows dialog box for configuring your printer or plotter.

Related topics
Plotter pen colors
Print preview
Printing and plotting
Printing or plotting one schematic page
Scaling a print or plot
Special considerations for plotting
Print To File dialog box
Print Preview command
Print Setup command



When you print multiple copies, the copies are grouped together by page, not sorted by 
copy.



Print Setup command (File menu)
Use this command to choose a printer, paper source, and orientation before printing. For 
more information on setting up printers and plotters, refer to the documentation for your 
configured printer driver.

Shortcut
Keyboard: ALT, F, R

Dialog box options
Displays a standard windows dialog box for configuring your printer or plotter.

Related topics
Printing and plotting
Print command
Print Preview command



Many times, the options for your printer are not available in the standard setup dialog. If 
you do not find the options you need, try the printer setup in the Windows Control Panel.



Exit command (File menu)
Use this command to exit Capture. If necessary, Capture asks if you want to save any 
changes before exiting.
You can also exit Capture by choosing the Close command on Capture's session frame 
Control menu (ALT, SPACEBAR, C).

Shortcuts
Keyboard: ALT, F, X

ALT, SPACEBAR, C
ALT+F4



1, 2, 3, or 4 command (File menu)
Use the numbers listed at the bottom of the File menu to open one of the last four designs 
and libraries. Choose the file you want to open.

Shortcut
Keyboard: ALT, F, n (n = 1, 2, 3, or 4)

Related topics
1, 2, . . . commands
Open command



New Schematic command (Design menu)
Use this command to create a schematic in the active design. 
You can add a new schematic page to the selected schematic using the New Schematic Page
command on the Design menu.

Shortcut
Keyboard: ALT, D, S

Dialog box option

Name
Specifies the new schematic's name.

Related topics
Creating a schematic or schematic page in an existing design
New Part command
New Schematic Page command
New Symbol command



Schematic, schematic page, part, part alias, and symbol names are completely case 
sensitive. It is possible to have a part named "XYZ" and another one named "xyz," and 
Capture's tools will treat the two separately.



New Schematic Page command (Design menu)
Use this command to add a new schematic page to the selected schematic. 
You can add a new schematic to the active design using the New Schematic command on 
the Design menu.

Shortcut
Keyboard: ALT, D, P

Dialog box option

Name
Specifies the new schematic page's name.

Related topics
Creating a schematic or schematic page in an existing design
New Part command
New Schematic command
New Symbol command
Schematic Page Properties command



New Part command (Design menu)
Use this command to create a part in the active library. Part aliases are created at the same 
time as the original part and show up in the library independently from the original part, but 
are represented in the design manager by a part icon with a horizontal line through the 
center. You can add part aliases to a library after the original part is created using the 
Package Properties command.
 

Shortcut
Keyboard: ALT, D, T

Dialog box options

Name
Specifies the part's name. This is used as the default part value when the part is placed 
on a schematic page. Part names can be up to 31 characters long.

Part Numbering
If the part is a multiple-part package, specifies whether parts in the package are 
identified by letter or number. For example:

U?A (alphabetic)
U?1 (numeric)

Packaging
If the part is a package, specifies whether all the parts in the package have the same 
graphical representation (homogeneous) or different graphical representations 
(heterogeneous).

Parts per Pkg
If there are multiple parts in the package, specifies the number of part in the package.

Part Reference Prefix
Specifies the part reference prefix, such as "C" for capacitor or "R" for resistor. For 
example:

C?1(capacitor)
R?1 (resistor)

PCB Footprint
Specifies the PCB module name to be included for this part in the netlist. Contains a 
value for a device consisting of zero or more pads, other objects, and a name.

Library
Shows path and filename of the library that contains the part.

Part Aliases
Displays the Part Aliases dialog box to add or remove aliases. Part aliases show up in a 
library represented by the part symbol with a horizontal line through the center.

Attach Schematic
Displays the Attach Schematic dialog box where you specify the name of a schematic, 
and a library or design that defines this homogeneous part if the schematic is not in the 
design. You attach a schematic to create a descendable part or schematic. For more 
information on attaching schematics, see About hierarchical blocks. You cannot attach 



schematics to heterogeneous parts.
 

Attach File
Displays the Attach File dialog box where you specify the text file, such as PLD source 
code, that defines this part. There are no format restrictions for attached files.

 

Create Convert View
Specifies whether the part has a convert. You might use the convert to define a 
DeMorgan equivalent. A part with this option specified will have two views (a normal and 
a convert) you can switch between once the part is placed.

Related topics
About hierarchical blocks
About parts
About primitive and nonprimitive parts
Browsing a design or a library
Creating a part
Attach File dialog box
Attach Schematic dialog box
Part Aliases dialog box
Package Properties command



Once you have attached a file and associated a text editor with it, you can use the Descend
Hierarchy command to open that file. If you have an attached schematic as well as an 
attached file, Descend Hierarchy opens the schematic and not the file.



You can access this dialog box after the new part to change the parameters by changing to 
package view and choosing the Package Properties command from the Options menu.



New Symbol command (Design menu)
Use this command to create a symbol in the active library.

Shortcut
Keyboard: ALT, D, L

Dialog box options

Name
Specifies the new symbol's name. Symbol names can be up to 31 characters long.

Symbol Type
Select the symbol type. Symbols may be one of the following: 

Power
Off-Page Connector
Hierarchical Port
Title Block

Related topics
Browsing a design or library
Connecting to power or ground
Creating a custom title block
Creating a hierarchical port or off-page connector symbol
Creating graphics



Rename command (Design menu)
Use this command to change the name of the selected schematic, schematic page, or part.

Shortcut
Keyboard: ALT, D, R

Dialog box option

Name
Specifies the name of the selected schematic, schematic page, or part. The current name
of the part is selected.

Related topic
Renaming a document



Delete command (Design menu)
Use this command to delete the selected schematics, schematic pages, parts, and symbols 
that are listed in the design manager window.

Shortcuts
Keyboard: ALT, D, D

BACKSPACE
DEL
DELETE

Related topic
Deleting objects



Deleting schematics, schematic pages, parts and symbols is permanent. You cannot use 
the Undo command to bring back deleted items from the design manager.



Deleting schematics, schematic pages, parts and symbols is permanent. You cannot use 
the Undo command to bring back deleted items from the design manager.



Rebuild Physical View command (Design menu)
Use this command to reset physical view properties to be the same as the logical view 
properties. In other words, when you choose this command, Capture deletes the physical 
view and recreates it from the logical view. Any changes to inherent properties, any user-
defined properties, and any gate or pin swaps unique to the physical view are lost.
This command is available only in logical view.

Shortcut
Keyboard: ALT, D, V

Related topic
Eliminating unique properties of your physical view
Logical view and physical view
Physical View command



Make Root Schematic command (Design menu)
Use this command to designate the selected schematic as the root schematic of the 
hierarchy.

Shortcut
Keyboard: ALT, D, M

Related topics
Establishing connectivity between pages
Creating a netlist
Logical view and physical view
Logical View command
Physical View command



Replace Cache command (Design menu)
Use this command to replace the selected part in the design cache, based on its current 
definitions in any library. You can also use this command to replace the selected part in the 
cache with a different part. This command works when a single part is selected.
When you replace a part in the design cache, you replace all instances and occurrences of 
the part in the active design. If the replaced part appears on an open schematic page, the 
instances and occurrences of the part on that page do not change until the page is closed 
and reopened.
 

Shortcut
Keyboard: ALT, D, C

Dialog box options

Part Name
Specifies the part's name. The current name appears in the text box. Enter the name of 
the part to replace the selected part.

Part Library
Specifies the path and library containing the replacement part. The current path and 
library appear in the text box.

Browse
Displays a standard Windows dialog box for selecting files.

Related topics
About part instances
About the design cache
Editing a part on a schematic page
Replacing a part in a design
Synchronizing parts in a design with parts in libraries
Update Cache command



The Replace Cache and Update Cache commands are very similar, but they have the 
following differences:

You can have only one part selected in the design cache when you use Replace 
Cache; you can have multiple parts selected in the cache when you use Update Cache.

You can modify the part's link to the library (part name, path, and library) with 
Replace Cache; you cannot modify the part's link with Update Cache.

You cannot use Replace Cache or Update Cache on symbols in the design cache.



Update Cache command (Design menu)
Use this command to update the selected parts in the design cache, based on their current 
definitions in their original libraries. This command works when one or more parts are 
selected.
When you change a part in the design cache, you change all instances and occurrences of 
the part in the active design. Part properties are retained, but pin properties are not. If the 
modified part appears on an open schematic page, the instances and occurrences of the 
part on that page do not change until the page is closed and reopened.
 

Shortcut
Keyboard: ALT, D, U

Related topics
About part instances
About the design cache
Editing a part on a schematic page
Synchronizing parts in a design with parts in libraries
Replace Cache command



Undo command (Edit menu)
Use this command to reverse the effect of the last operation, if possible. The name of this 
command changes, depending on what the last reversible operation was---for example, 
Undo Rotate or Undo Delete.

Shortcuts
Toolbar:

Keyboard: ALT, E, U
CTRL+Z

Related topics
Undoing and repeating actions
Redo command
Repeat command



Redo command (Edit menu)
Use this command to reverse the effect of the most recent Undo command. The name of the
command changes, depending on what the undone operation was---for example, Redo 
Rotate or Redo Delete.

Shortcuts
Toolbar:

Keyboard: ALT, E, E

Related topics
Undoing and repeating actions
Repeat command
Undo command



Repeat command (Edit menu)
Use this command to repeat the last operation on the currently selected object, when the 
last operation can be repeated. The name of the command changes, depending on what the 
last repeatable operation was---for example, Repeat Rotate or Repeat Paste. This command 
is most useful for placing objects and creating arrays of objects quickly.
You can control the spacing between placed objects using the Repeat command by pressing 
the CTRL key and dragging a copy of the object to a new location before using the Repeat 
command.

Shortcuts
Keyboard: ALT, E, R

F4

Related topics
Undoing and repeating actions
Redo command
Undo command



The Undo, Redo, and Repeat commands apply to the following actions.

Undo Redo Repeat
Placing
Deleting ---
Copying
Moving
Resizing
Rotating
Mirroring
Grouping --- --- ---

Cut command (Edit menu)
Use this command to remove the selected objects from the schematic page or part and put 
them on the Clipboard. This command is available only if an object is selected.
Cutting objects to the Clipboard replaces any objects previously stored there. Use the Paste 
command to copy objects to another page or part, or to another windows application which 
supports pasting from the clipboard.

Shortcuts
Toolbar:

Keyboard: ALT, E, T
CTRL+X

Related topics
Using drag and drop with documents
Moving parts or symbols between libraries
Moving schematic pages between schematics
Moving schematics between designs
Moving schematic pages between designs
Copying a schematic to or from a library
Copying a schematic page to a library
Moving objects
Copy command
Paste command



Copy command (Edit menu)
Use this command to copy the selected objects to the Clipboard without removing them 
from the schematic page, part, or session log. This command is available only if an object is 
selected.
You can also use this command to copy selected schematics, schematic pages, parts, and 
symbols from one design, schematic, or library to another.
Copying objects to the Clipboard replaces any objects previously stored there. Use the Paste 
command to copy objects to another page or part, or to another windows application which 
supports pasting from the clipboard.

Shortcuts
Toolbar:

Keyboard: ALT, E, C
CTRL+C

Related topics
Using drag and drop with documents
Moving parts or symbols between libraries
Moving schematic pages between schematics
Moving schematics between designs
Moving schematic pages between designs
Copying a schematic to or from a library
Copying a schematic page to a library
Copying selected objects
Cut command
Paste command



The Cut and Copy commands are unavailable in the part editor when you have one or more
pins selected with other objects (such as an arcs and lines).



Paste command (Edit menu)
Use this command to place any objects stored on the Clipboard on the active schematic 
page or part. This command is unavailable if the Clipboard is empty.
You can also use this command to place copied schematics, schematic pages, parts, and 
symbols into a design, schematic, or library.
Pasting objects from the Clipboard does not affect the Clipboard's contents. Use Paste to 
copy objects to another page or part, or to another windows application which supports 
pasting from the clipboard. You can only paste text into text boxes.

Shortcuts
Toolbar:

Keyboard: ALT, E, P
CTRL+V

Related topics
Using drag and drop with documents
Moving parts or symbols between libraries
Moving schematic pages between schematics
Moving schematics between designs
Moving schematic pages between designs
Copying a schematic to or from a library
Copying a schematic page to a library
Moving objects
Copying selected objects
Copy command
Cut command



Delete command (Edit menu)
Use this command to remove the selected objects from the schematic page or part without 
putting them on the Clipboard. This command is available only if an object is selected.
Deleting objects does not affect the Clipboard's contents.

Shortcuts
Keyboard: ALT, E, D

BACKSPACE
DEL
DELETE

Pop-up menu: Delete

Related topic
Deleting objects
Moving objects
Cut command



Select All command (Edit menu)
Use this command to select every object on the schematic page or part in the active 
window.

Shortcut
Keyboard: ALT, E, L

Related topic
Selecting all objects on a schematic page or part



Properties command (Edit menu)
Use this command to edit properties and other data for the selected objects.

Shortcuts
Keyboard: ALT, E, S

CTRL+E
Mouse: Double-click on a part
Pop-up menu: Edit

Dialog box options
The properties you can edit depend on the selected objects. The following lists the 
inherent properties you can edit and the dialog boxes in which you edit them:

Objects Dialog box
Arcs Edit Comment Graphic dialog box
Bitmaps (pictures) Not applicable
Bookmarks Rename Bookmark dialog box
Busses Net Properties dialog box
Bus entries User Properties dialog box
DRC markers View DRC Marker dialog box
Ellipses Edit Filled Comment Graphic dialog box
Hierarchical blocks Edit Hierarchical Block dialog box
Hierarchical ports (inside hier'l. 
blocks)

Edit Hierarchical Port dialog box

Hierarchical ports (outside hier'l. 
blocks)

Edit Port dialog box

IEEE symbols IEEE Symbol Properties dialog box
Lines Edit Comment Graphic dialog box
Multiple objects Edit Properties dialog box

Nets (wires and busses) Net Properties dialog box
Net aliases Rename Alias dialog box
No connects Not applicable
Off-page connectors Edit Off-Page Connector dialog box
Parts Edit Part dialog box
Pictures (bitmaps) Not applicable
Part body borders Not applicable
Pins (part editor) Pin Properties dialog box
Pins (schematic page editor) Pin Properties dialog box
Polygons Edit Filled Comment Graphic dialog box
Polylines Edit Comment Graphic dialog box
Power, ground Rename Global dialog box
Rectangles Edit Filled Comment Graphic dialog box



Text Place Text dialog box
Title blocks User Properties dialog box
Wires Net Properties dialog box

Related topic
Editing properties



You can edit homogeneous sets of the following objects in the spreadsheet editor:
Bookmarks
DRC markers
Hierarchical ports
Nets
Off-page connectors
Parts
Pins



Part command (Edit menu)
Use this command to open the selected part instance in a part editor window.
The part command edits the part in the design cache.    After saving the part, you have the 
option to apply your changes to just one instance or all instances in the design.    If you edit 
the one instance only, a new part is created in the cache and all other instances of the part 
are left unchanged. Otherwise, the changes are applied to the part in the cache. To replace a
part in the cache with another part, use the Replace Cache command.

Shortcuts
Keyboard: ALT, E, A
Pop-up menu: Edit Part

Related topics
About part instances
Editing the graphic representation of a part
Editing part properties
Part editor window
Synchronizing parts in a design with parts in libraries
Replace Cache command



Browse command (Edit menu)
Use this command in the design manager to specify which items to search for and how to 
sort the results. Choose a command from the menu that displays:

Parts
Nets
Hierarchical Ports
Off-Page Connectors
Bookmarks
DRC Markers

In the browse pane of the design manager, you can open a schematic page or part by 
double clicking on the selected item. You can also choose properties to edit and change one 
or more of them.

Shortcut
Keyboard: ALT, E, B

Related topics
Browsing a design or a library
Design manager window
Searching a design
Find command



Parts command (Edit menu, Browse command)
Use this command to list the parts of the selected schematic pages in the browse pane of 
the design manager. You can sort the parts by clicking on the button at the top of each 
column in the browse pane of the design manager.
You can select single or multiple parts and edit them with the Properties command. When 
you edit one part, a part editor window opens. When you select multiple parts, the Edit 
Properties dialog box opens.
Double-click on a part to view it in the schematic page editor.

Shortcut
Keyboard: ALT, E, B, P

Related topics
Edit Properties dialog box
Browsing a design or a library
Properties command



Nets command (Edit menu, Browse command)
Use this command to list the nets of the selected schematic pages in the browse pane of the
design manager.
You can select single or multiple nets and edit them with the Properties command. When you
edit one part, the Net Properties dialog box opens. When you select multiple nets, the Edit 
Properties dialog box opens.
Double-click on a net to view it in the schematic page editor.

Shortcut
Keyboard: ALT, E, B, N

Related topics
Net operations
Tracing a net
Browsing a design or a library
Edit Properties dialog box



Hierarchical Ports command (Edit menu, Browse command)
Use this command to list the hierarchical ports of the selected schematic pages in the 
browse pane of the design manager. You can use this command to follow ports through a 
hierarchy when tracing problems in a hierarchical design.
You can select single or multiple hierarchical ports and edit them with the Properties 
command. When you edit one hierarchical port, either the Edit Hierarchical Port dialog box or
Edit Port dialog box opens (depending upon if the hierarchical port is inside or outside a 
hierarchical block). When you select multiple hierarchical ports, the Edit Properties dialog 
box opens.
Double-click on a hierarchical port to view it in the schematic page editor.

Shortcut
Keyboard: ALT, E, B, H

Related topic
Browsing a design or a library
Edit Properties dialog box



Off-Page Connectors command (Edit menu, Browse command)
Use this command to list the off-page connectors of the selected schematic pages in the 
browse pane of the design manager. You can use this command to follow nets as they travel 
through off-page connectors to other pages.
You can select single or multiple off-page connectors and edit them with the Properties 
command. When you edit one off-page connector, the Edit Off-Page Connector dialog box 
opens. When you select multiple off-page connectors, the Edit Properties dialog box opens.
Double-click on an off-page connector to view it in the schematic page editor.

Shortcut
Keyboard: ALT, E, B, O

Related topics
Browsing a design or a library
Place Off-Page Connector command
Edit Properties dialog box



Bookmarks command (Edit menu, Browse command)
Use this command to list the bookmarks of the selected schematic pages in the browse pane
of the design manager. Bookmarks are useful for marking a particular spot in your design.
You can select single or multiple bookmarks and edit them with the Properties command. 
When you edit one bookmark, the Rename Bookmark dialog box opens. When you select 
multiple bookmarks, the Edit Properties dialog box opens.
Double-click on a bookmark to view it in the schematic page editor.

Shortcut
Keyboard: ALT, E, B, B

Related topics
Setting a bookmark
Browsing a design or a library
Bookmark command (Place menu)
Go To command



DRC Markers command (Edit menu, Browse command)
Use this command to list the DRC markers of the selected schematic pages in the browse 
pane of the design manager. DRC markers are placed on pages by the Design Rules Check 
tool. They are useful when troubleshooting your design before creating a netlist.
You can select single or multiple DRC markers and edit them with the Properties command. 
When you edit one DRC marker, the View DRC Marker dialog box opens. When you select 
multiple DRC markers, the Edit Properties dialog box opens.
Double-click on an DRC marker to view it in the schematic page editor.

Shortcut
Keyboard: ALT, E, B, D

Related topics
Design Rules Check back annotation
Browsing a design or a library
Design Rules Check command
Edit Properties dialog box



Mirror command (Edit menu)
Use this command to mirror selected items in the schematic page editor or the part editor. 
Choose a command from the menu that displays:

Horizontal
Vertical
Both

 

Shortcut
Keyboard: ALT, E, M

Related topics
Mirroring objects
Rotating objects



Multiple selected objects are mirrored and rotated as a group. They do not mirror or rotate 
around their individual axes. Multiple selected objects need not be grouped together using 
the Group command.



Horizontal command (Edit menu, Mirror command)
Use this command to mirror selected objects from side to side (across the Y axis).
 

Shortcuts
Keyboard: ALT, E, M, H

SHIFT+H
Pop-up menu: Mirror Horizontally

Related topic
Mirroring objects



Vertical command (Edit menu, Mirror command)
Use this command to mirror selected objects from top to bottom and from bottom to top 
(across the X axis).
 

Shortcuts
Keyboard: ALT, E, M, V

SHIFT+V
Pop-up menu: Mirror Vertically

Related topic
Mirroring objects



Both command (Edit menu, Mirror command)
Use this command to mirror selected objects both horizontally and vertically. This is 
equivalent to rotating the objects by 180 degrees.
 

Shortcut
Keyboard: ALT, E, M, B

Related topics
Mirroring objects
Rotate command



Rotate command (Edit menu)
Use this command to rotate selected objects counterclockwise in 90-degree increments. 
Selected objects rotate as a set, not as individual objects rotating in place.
 
 

Shortcuts
Keyboard: ALT, E, O

CTRL+R
SHIFT+R

Pop-up menu: Rotate

Related topics
Rotating objects
Mirror, Both command



Non-TrueType fonts cannot be rotated.



Group command (Edit menu)
Use this command to make a selectable unit of the selected objects. This is a convenient 
way to maintain the relationship among several objects while moving them to another 
location. You can "nest" groups, meaning a group can contain other groups as well as 
objects.
This command is available only when multiple objects are selected. This command 
terminates the previous command. The Undo and Repeat commands do not apply to this 
command.

Objects remain grouped until you ungroup them or close all windows displaying the 
schematic page or part that contains them.

Shortcuts
Keyboard: ALT, E, G

CTRL+G

Related topics
Moving objects
Selecting and deselecting objects
Ungroup command (Edit menu)



Ungroup command (Edit menu)
Use this command to revert a group of objects to the individual objects (and groups) it 
comprises. This command is available only when a group is selected.
This command terminates the previous command. The Undo and Repeat commands do not 
apply to this command.

Objects are ungrouped automatically when you close all windows on the schematic page or 
part that contains them.

Shortcuts
Keyboard: ALT, E, U

CTRL+U

Related topics
Moving objects
Selecting and deselecting objects
Group command



Find command (Edit menu)
Use this command to find objects that contain a specific text string in the name or value of a
property. In the schematic page and part editors, this command is constrained to the active 
schematic page or part. In the session log, use this command to find a specific string. 
The Find command supports wildcard searches. Use an asterisk (*) to match any string of 
characters, and a question mark (?) to match any single character.
In the schematic page editor, part editor, and design manager, the Find command will find 
all instances of the specified text search string. In the session log, the Find command will 
find the next occurrence of the specified text search string from the current position.

Shortcut
Keyboard: ALT, E, F

CTRL+F

Dialog box options

Find What
Specifies the search string. Use an asterisk (*) to match any string of characters, and a 
question mark (?) to match any single character.

Match Case
Specifies if the search must match the case of the string. If this is not specified, 
lowercase and uppercase letters will be viewed the same in the search.

Scope
Specifies the properties to search for. Multiple properties may be selected. You may 
specify any of the following scopes in design managers and schematic page editors:

Parts
Nets
Off-page connectors
Hierarchical ports
Bookmarks
DRC markers
Text

You may specify one of the following scopes in part editors:
Pins
Text

Direction
Specifies the direction of the search from the cursor location. This option is only available
in the session log.

Find Next
Search for the next occurrence of the specified string. This option is only available in the 
session log.

Related topics
Finding parts in a design
Searching a design
Searching for part text or pins



Tracing a net
Browse command
Properties command



The available Find dialog box options depend on the active window.



Logical View command (View menu)
Use this command in the design manager to view design instances. Logical view is the view 
in which you typically edit schematic pages. A dot next to this command indicates the active
design is displayed in the logical view.
The logical view of a design displays the design as "a container" and each schematic 
instance is shown only once, even if it is referenced more than once. If you have two 
occurrences of a schematic, you would only see one instance of them in logical view. This is 
the view you want to edit the schematics in.

Shortcut
Keyboard: ALT, V, L

Related topics
About part instances
About parts
Eliminating unique properties of your physical view
Logical view and physical view
Choosing between logical and physical view
Working in both logical and physical view
Physical View command



Physical View command (View menu)
Use this command in the design manager to view design occurrences. Physical view displays
gate and pin swaps, occurrence-specific properties, and (where appropriate) the unfolded 
hierarchy. A dot next to this command indicates the active design is displayed in the physical
view.
In the physical view, every object has unique properties. These can be thought of as 
"overlays" on the instances.
Objects appear gray in this view because you can't edit, move, or delete them, except to 
modify properties.

Shortcut
Keyboard: ALT, V, P

Related topics
About part instances
About parts
Eliminating unique properties of your physical view
Logical view and physical view
Logical View command
Choosing between logical and physical view
Working in both logical and physical view
Rebuild Physical View command



Ascend Hierarchy command (View menu)
Use this command to view the parent of the active schematic page. This command is 
available only when you have descended from a part instance or hierarchical block into the 
schematic.
If the parent schematic page is open in another window, that window becomes active, 
otherwise it opens in a new schematic page editor window.
You can view and traverse the hierarchy in the design manager.

Shortcuts
Keyboard: ALT, V, A

CTRL+A

Related topics
About primitive and nonprimitive parts
Attaching a schematic
Descend Hierarchy command
Design Template command
Hierarchical Block command



Descend Hierarchy command (View menu)
Use this command to view the schematic page represented by an instance on the active 
schematic page. This command is available only when the selected part or hierarchical block
has an attached schematic or file.    If the attached schematic has not yet been created, this 
command creates a new page. If the child schematic is open in another window, that window
becomes active. Otherwise, it opens in a new schematic page editor window.
You can view and traverse the hierarchy in the design manager.

Shortcuts
Keyboard: ALT, V, D

CTRL+D
Pop-up menu: Descend Hierarchy

Related topics
About primitive and nonprimitive parts
Ascend Hierarchy command
Attaching a schematic
Hierarchical Block command



Normal command (View menu)
Use this command to display the active part editor window's normal view of the part. A dot 
next to this command indicates that the normal form is displayed for the part editor.

Shortcut
Keyboard: ALT, V, N

Related topics
Creating a part convert
Viewing converts
Convert command 
Package command
Part command



Convert command (View menu)
Use this command to display the active part editor window's convert view. This command is 
available only when the parts in the package have convert views. A dot next to this 
command indicates that the convert views are displayed in the part editor.

Shortcut
Keyboard: ALT, V, C

Related topics
Creating a part convert
Viewing converts
Normal command
Package command
Part command



Part command (View menu)
Use this command to display a single part in a multiple part package.    You can edit the part 
in this view.

Shortcut
Keyboard: ALT, V, A

Related topics
Creating multiple-part packages
Next Part command
Package command
Previous Part command



Package command (View menu)
Use this command in the part editor to view all the parts in a package. Parts cannot be 
edited in package view.

Shortcut
Keyboard: ALT, V, K

Related topics
Creating multiple-part packages
Next Part command
Part command
Package Properties command
Previous Part command



Next Part command (View menu)
Use this command to view the next part in the package. In Part View, this command displays
the next part of the package in the part editor. In Package View, this command selects the 
next part in the package.

Shortcuts
Keyboard: ALT, V, X

CTRL+N
TAB (PACKAGE VIEW ONLY)

Related topics
Creating multiple-part packages
Package command
Part command
Previous Part command



Previous Part command (View menu)
Use this command to view the previous part in the package. In Part View, this command 
displays the previous part of the package in the part editor. In Package View, this command 
selects the previous part in the package.

Shortcuts
Keyboard: ALT, V, V

CTRL+B
SHIFT+TAB (PACKAGE VIEW ONLY)

Related topics
Creating multiple-part packages
Next Part command
Package command
Part command



Go To command (View menu)
Use this command to center the view on a specific location, grid reference, or bookmark.

Shortcuts
Keyboard: ALT, V, G

F6
Pop-up menu: Go To

Location Tab dialog box options

X and Y
Specifies the X and Y coordinates for the jump.

Absolute and Relative
Specifies if the jump is absolute (to the indicated coordinates), or relative (using the 
coordinates as an offset to the pointer's current position).

Grid Reference tab dialog box options

Horizontal
Specifies a horizontal grid reference.

Vertical
Specifies a vertical grid reference.

Bookmark tab dialog box options

Name
Specifies a jump to a bookmark. Bookmarks are made using the Bookmark command on 
the Place menu.

Related topics
Moving to a location, reference, or bookmark
Setting a bookmark
Status bar
Bookmark command
Design Template command
Schematic Page Properties command



The grid reference and bookmark options are unavailable in the part editor.



Zoom (View menu)
Use this command to change your view of the schematic or part. Choose one of the 
commands listed:

In
Out
Scale
Area
All
Selection
Redraw

Shortcut
Keyboard: ALT, V, Z

Related topics
Centering the view
Refreshing the display
Viewing a specific area
Viewing the entire schematic page or part
Zooming in
Zooming out
Zooming to a specific scale



In command (View menu, Zoom command)
Use this command to zoom in on the schematic page or part. The zoom scale is multiplied 
by the current zoom factor.
Capture uses the following order to determine where the view of the zoom centers:
1 On the pointer location
2 On the selected item or items
3 In the center of the window (not the center of the schematic page or part)

Shortcuts
Toolbar:

Keyboard: ALT, V, Z, I
SHIFT+I

Pop-up menu: Zoom In

Related topics
Changing the zoom factor
Zooming in
All command
Area command
Out command
Redraw command
Scale command
Selection command



Out command (View menu, Zoom command)
Use this command to zoom out from the schematic page or part. The zoom scale is divided 
by the current zoom factor.

Shortcuts
Toolbar:

Keyboard: ALT, V, Z, O
SHIFT+O

Pop-up menu: Zoom Out

Related topics
Changing the zoom factor
Zooming out
All command
Area command
In command
Redraw command
Scale command
Selection command



Scale command (View menu, Zoom command)
Use this command to zoom to a preset or user-defined scale. The new view centers on the 
selected objects, the pointer location, or the center of the previous view.

Shortcut
Keyboard: ALT, V, Z, S

Dialog box options
Specifies a zoom scale. You can choose one of the pre-defined zoom scales ranging from 
25% to 400%, or choose a custom zoom scale.

Related topics
Zooming to a specific scale
All command
Area command
In command
Out command
Redraw command
Selection command



Area command (View menu, Zoom command)
Use this command to make a specific area of the document as large as will fit in the window. 
You define the area by dragging a rectangle around it.

Shortcuts
Toolbar:

Keyboard: ALT, V, Z, A

Related topics
Viewing a specific area
All command
In command
Out command
Redraw command
Scale command
Selection command



All command (View menu, Zoom command)
Use this command to view the entire document in the active window. This command uses 
the size of the work area, not the limits of the objects.

Shortcuts
Toolbar:

Keyboard: ALT, V, Z, L

Related topics
Viewing the entire schematic page or part
Area command
In command
Out command
Redraw command
Scale command
Selection command



Selection command (View menu, Zoom command)
Use this command to view all selected objects.

Shortcut
Keyboard: ALT, V, Z, E

Related topics
Centering the view
All command
Area command
In command
Out command
Redraw command
Scale command



Redraw command (View menu, Zoom command)
Use this command to refresh the display.

Shortcuts
Keyboard: ALT, V, Z, R

F5

Related topics
Refreshing the display
All command
Area command
In command
Out command
Scale command
Selection command



Tool Palette command (View menu)
Use this command to show or hide the tool palette. This setting is stored in your 
CAPTURE.INI file and thus affects the visibility of the palette in subsequent sessions.
The schematic page editor tool palette is unavailable in physical view, and the part editor 
tool palette is unavailable in package view.

Shortcut
Keyboard: ALT, V, P

Related topics
Part editor tool palette
Schematic editor tool palette
Viewing the tool palette



Toolbar command (View menu)
Use this command to show or hide the toolbar. This setting is stored in your CAPTURE.INI file 
and thus affects the visibility of the toolbar in subsequent sessions.

Shortcut
Keyboard: ALT, V, T

Related topic
Toolbar
Viewing the toolbar



Status Bar command (View menu)
Use this command to show or hide the status bar. This setting is stored in your CAPTURE.INI 
file and thus affects the visibility of the status bar in subsequent sessions.

Shortcut
Keyboard: ALT, V, S

Related topic
Status bar
Viewing the status bar



Grid command (View menu)
Use this command to show or hide the grid dots. You can show or hide the grid 
independently in each schematic page and part you have open.
You can also set the grid dots to show or hide in the Preferences dialog box.

Shortcut
Keyboard: ALT, V, I

Related topics
Design Template command
Preferences command
Schematic Page Properties command



Grid References command (View menu)
Use this command to show or hide the grid references.
You can also set the grid references to show or hide in the    Design Template dialog box and 
the Schematic Page Properties dialog box.

Shortcut
Keyboard: ALT, V, R

Related topics
Defining schematic page characteristics
Design Properties command
Design Template command
Schematic Page Properties command



Part command (Place menu)
Use this command to place a part you select in the Place Part dialog box.
In the Place Part dialog box, you choose a part by selecting libraries to view. You may view 
parts from both Capture and SDT libraries. If you choose a part from an SDT library, Capture 
translates the library for you.

Shortcuts
Tool palette:

Keyboard: ALT, P, P
SHIFT+P

Dialog box options

Part
Specifies the name of the part. Use an asterisk (*) to match any string of characters, and 
a question mark (?) to match any single character.

Part List
Displays a list of parts in the libraries selected in the Libraries list box that match what's 
entered in the Part text box. When you select a part in this list, its name displays in the 
Part text box, and its graphic displays in the preview box. Select a part from the list of 
parts available in the selected libraries.

Libraries
Select one or more libraries from the list of available libraries. The part list displays the 
parts from the selected libraries. You also select libraries from the Libraries list box to 
remove them from the list.

Graphic
Select either Normal or Convert view. All parts have a normal view. Some parts have a 
convert view that can be used for things such as a DeMorgan equivalent part.

Packaging
Parts per Pkg Displays the number of parts in the package.
Part Select which part in the package to place on the schematic page.

Preview box
Displays the graphic of the selected part.

Add Library
Displays a standard open dialog box for adding a library to the Libraries list box. You can 
add a library in SDT format. If you do, you can save the library in the Capture format 
(.OLB).

Remove Library
Removes the selected library or libraries from the libraries list box.

Edit Part
Opens a part editor window for the selected part, and a design manager window for the 
part's library.

Related topics
About parts



About the design cache
Opening a library created in SDT
Placing a part instance 
Searching for a part in the libraries



Wire command (Place menu)
Use this command to place a wire. When placing a wire, you click the left mouse button to 
start the wire. Click the left mouse button to change the wire's direction or create a junction 
with another wire. Double-click the left mouse button or press ESC to end the wire, and place 
another wire. Press ESC again to exit the wire tool.
When placing wires, you are constrained to 90 degree angles. If you want to draw non-
orthogonal wires, hold the SHIFT key down while placing the wire.
You may also use the keys B and E to start and end wires.

Shortcuts
Tool palette:

Keyboard: ALT, P, W
SHIFT+W

Related topics
About bus connections
Establishing wire connectivity
Labeling a net, bus, or a bus member
Placing wires



Bus command (Place menu)
Use this command to place a bus. When placing a bus, you click the left mouse button to 
start the bus. Click the left mouse button to change the bus's direction or create a junction 
with another bus. Double-click the left mouse button or press ESC to end the bus, and place 
another bus. Press ESC again to exit the bus tool.
When placing busses, you are constrained to 90 degree angles. If you want to draw non-
orthogonal busses, hold the SHIFT key down while placing the bus.
You may also use the keys B and E to start and end busses.
 

Shortcuts
Tool palette:

Keyboard: ALT, P, B
SHIFT+B

Related topics
About bus connections
Establishing bus connectivity
Labeling a net, bus, or a bus member
Placing busses
Repeat command



Bus Entry command (Place menu)
Use this command to place a bus entry.

Shortcuts
Tool palette:

Keyboard: ALT, P, E
SHIFT+E

Related topics
About bus connections
Establishing bus connectivity
Repeat command



Net Alias command (Place menu)
Use this command to place a net alias on the selected object. To quit placing net aliases, 
press ESC or choose the selection tool.

Shortcuts
Tool palette:

Keyboard: ALT, P, N
SHIFT+N

Dialog box options

Alias
Specifies the net alias name. Enter the net alias in the text box.

Color
Specifies the color of the net alias.

Rotation
Specifies the rotation of the net alias or text.

Font
Change Displays a dialog box so you can select a font.
Use Default Changes the font to the default font specified in the Design Template 

dialog box.

Related topic
Establishing bus connectivity
Establishing wire connectivity
Labeling a net, bus, or a bus member
Design Template command



Power command (Place menu)
Use this command to place a power symbol.

Shortcuts
Tool palette:

Keyboard: ALT, P, O

Dialog box options

Symbol
Specifies a symbol to select and view. Use an asterisk (*) to match any string of 
characters, and a question mark (?) to match any single character.

Symbol List
Displays a list of power objects in the libraries selected in the Libraries list box that 
match what's entered in the Symbol text box. When you select a power object in this list,
its name displays in the Symbol text box, and its graphic displays in the preview box. 
Select a power object from the list of symbols available in the selected libraries.

Libraries
Select one or more libraries from the list of available libraries. The symbol list displays 
the power objects from the selected libraries. You also select libraries from the Libraries 
list box to remove them from the list.

Preview box
Displays the graphic of the selected symbol.

Name
Specifies the symbol's name. This is the name of the power net. All power pins with this 
name in the design connect to this net.

Add Library
Displays a standard open dialog box for adding a library to the Libraries list box. You can 
add a library in SDT format. If you do, you can save the library in the Capture format 
(.OLB).

Remove Library
Removes the selected library or libraries from the libraries list box.

Related topic
About power and ground pins
Connecting to power or ground
Isolating power or ground



Ground command (Place menu)
Use this command to place a ground symbol.

Shortcuts
Tool palette:

Keyboard: ALT, P, G

Dialog box options

Symbol
Specifies a symbol to select and view. Use an asterisk (*) to match any string of 
characters, and a question mark (?) to match any single character.

Symbol List
Displays a list of ground objects in the libraries selected in the Libraries list box that 
match what's entered in the Symbol text box. When you select a ground object in this 
list, its name displays in the Symbol text box, and its graphic displays in the preview box.
Select a ground object from the list of symbols available in the selected libraries.

Libraries
Select one or more libraries from the list of available libraries. The symbol list displays 
the ground objects from the selected libraries. You also select libraries from the Libraries 
list box to remove them from the list.

Preview box
Displays the graphic of the selected symbol.

Name
Specifies the symbol's name. This is the name of the ground net. All ground pins with this
name in the design connect to this net.

Add Library
Displays a standard open dialog box for adding a library to the Libraries list box. You can 
add a library in SDT format. If you do, you can save the library in the Capture format 
(.OLB).

Remove Library
Removes the selected library or libraries from the libraries list box.

Related topic
About power and ground pins
Connecting to power or ground
Isolating power or ground



Off-Page Connector command (Place menu)
Use this command to place an off-page connector, which connects to another page in the 
schematic, and to isolate power to a schematic. Net aliases of the same name connect wires
to these nets.

Shortcuts
Tool palette:

Keyboard: ALT, P, F

Dialog box options

Symbol
Specifies a symbol to select and view. Use an asterisk (*) to match any string of 
characters, and a question mark (?) to match any single character.

Symbol List
Displays a list of off-page connectors in the libraries selected in the Libraries list box that 
match what's entered in the Symbol text box. When you select an off-page connector in 
this list, its name displays in the Symbol text box, and its graphic displays in the preview 
box. Select an off-page connector from the list of symbols available in the selected 
libraries.

Libraries
Select one or more libraries from the list of available libraries. The symbol list displays 
the off-page connectors from the selected libraries. You also select libraries from the 
Libraries list box to remove them from the list.

Preview box
Displays the graphic of the selected symbol.

Name
Specifies the symbol's name.

Add Library
Displays a standard open dialog box for adding a library to the Libraries list box. You can 
add a library in SDT format. If you do, you can save the library in the Capture format 
(.OLB).

Remove Library
Removes the selected library or libraries from the libraries list box.

Related topics
About off-page connectors
Establishing connectivity between pages



Hierarchical Block command (Place menu)
Use this command to place a hierarchical block. A hierarchical block maps to a schematic, 
not a schematic page.

Shortcuts
Tool palette:

Keyboard: ALT, P, H

Dialog box options

Name
Specifies the hierarchical block's name.

Primitive
Default Indicates the hierarchical block uses the default primitive setting. The default 

setting for hierarchical blocks is nonprimitive. The default setting for 
hierarchical blocks is set in the Hierarchy tab of the Design Template dialog 
box (see Design Template and Design Properties commands).

Yes Indicates the hierarchical block is a primitive.
No Indicates the hierarchical block is nonprimitive and descends in hierarchy.

User Properties
Displays the User Properties dialog box so you can modify the hierarchical block's user 
defined properties.

Attach File
Displays the Attach File dialog box where you specify the text file, such as PLD source 
code, that defines this part. There are no format restrictions for attached files.

 

Attach Schematic
Displays the Attach Schematic dialog box where you specify the name of a schematic, 
and a library or design that defines this homogeneous part if the schematic is not in the 
design. You attach a schematic to create a descendable part or schematic. For more 
information on attaching schematics, see About hierarchical blocks.

 

Related topics
About hierarchical blocks
Attach File dialog box
User Properties dialog box
Properties command



Hierarchical Port command (Place menu)
Use this command to place a hierarchical port. If you have a hierarchical block selected 
when you choose this command, you may only place the hierarchical port within the 
hierarchical block. Otherwise, you may place the hierarchical port anywhere on the page.
A hierarchical port inside a hierarchical block is electrically connected to any hierarchical 
port in the schematic attached to that hierarchical block. A hierarchical port outside a 
hierarchical block is electrically connected by name to a pin or signal "above" the schematic 
page.

Shortcut
Tool palette:

Keyboard: ALT, P, I

Dialog box options
See Place Hierarchical Port dialog box (inside hierarchical blocks) for placing hierarchical 

ports inside hierarchical blocks.
See Place Hierarchical Port dialog box (outside hierarchical blocks) for placing 

hierarchical ports outside hierarchical blocks.

Related topics
About hierarchical ports
Properties command



No Connect command (Place menu)
Use this command to place a no connect symbol. This object causes unused pins to be 
ignored by reports that show unconnected pins. Design rule checks and netlists won't report 
errors for pins with no connects placed on them. No connects do not affect connected pins, 
even if the Is No Connect property is set to TRUE. If the No Connect property is set to TRUE and 
the pin is unconnected, an X appears on the pin.
No connects can also be placed by setting the Is No Connect property of a pin to TRUE. No 
connects cannot be deleted using the Delete command. You must either set the pin property
to FALSE, or connect a wire to the pin.

Shortcuts
Tool palette:

Keyboard: ALT, P, C

Related topics
Checking for design rule violations
Editing properties
Interpreting Design Rules Check reports
Using no connects



Pin command (Place menu)
Use this command to place one or more pins on a part. A pin is placed with each click of the 
left mouse button. Press ESC or choose the selection tool to stop placing pins.
To place an array of parts, use the Pin Array command.

Shortcuts
Tool palette:

Keyboard: ALT, P, P

Dialog box options

Name
Specifies the pin name. If the name ends with a digit (0--9), each pin is incremented by 
the one every time you place a pin. You can make a pin name with an overbar by adding 
a backslash (\) after every letter in the pin name.

Number
Specifies the pin number. The pin number doesn't need to be a number; it can be 
alphabetic. If it ends in a number, it is incremented by one after each pin is placed.

Width
Specifies whether the pin connects to a bus or a wire. If bus is specified, the pin must 
connect to a bus, otherwise, it must connect to a wire.

 

Shape
Select the pin shape from the list of pin shapes. For more information about pin shapes, 
see Pin shapes and types.

Type
Select the pin type from the list of pin types. For more information about pin types, see 
Pin shapes and types.

Pin Visible
Specifies the pin visibility on the schematic. Only power pins can be set to not visible.

 

User Properties
Displays the User Properties dialog box so you can add and edit the pin properties.

Related topics
About power and ground pins
ERC matrix tab (Design Rules Check dialog box)
Pin shapes and types
Placing pins
User Properties dialog box
Pin Array command



Bus pins cannot be used directly as netlisting pins. Their main purpose is to make it 
possible to use nonprimitive parts easier by connecting large numbers of signals to a child 
schematic.



Bus pins cannot be used directly as netlisting pins. Their main purpose is to make it 
possible to use nonprimitive parts easier by connecting large numbers of signals to a child 
schematic.



Pin Array command (Place menu)
Use this command to place an array of pins.

Shortcuts
Tool palette:

Keyboard: ALT, P, Y

Dialog box options

Starting Name
Specifies the name for the pin array. If the name ends with a digit (0--9), each pin in the 
array is incremented by the value specified in the Increment text box. You can make a 
pin name with an overbar by adding a backslash (\) after every letter in the pin name.

Starting Number
Specifies the starting number for the pin array. Pin numbers don't need to be numbers. If 
a pin number ends in a number, it is it is incremented by the value specified in the 
Increment text box.

Number of Pins
Specifies the number of pins in the pin array.

Increment
Specifies the increment between pin numbers for the pin array.

Pin Spacing
Specifies the spacing between pins for the pin array.

Shape
Select the pin shape from the list of pin shapes. For more information about pin shapes, 
see Pin shapes and types.

Type
Select the pin type from the list of pin types. For more information about pin types, see 
Pin shapes and types.

Related topics
About power and ground pins
ERC matrix tab (Design Rules Check dialog box)
Pin shapes and types
Placing an array of pins
Placing pins
Pin command



IEEE Symbol command (Place menu)
Use this command to place an IEEE symbol. When you select this command, a dialog box is 
displayed for you to select a symbol to place. Press ESC, or click on the selection tool, to quit 
placing the selected symbol.
Click the left mouse button to place an IEEE symbol once you have selected a symbol. You 
can choose the Properties command from the edit menu, or the Edit command from the right
mouse button pop-up menu, to change the IEEE symbol without having to quit the IEEE 
symbol tool.

Shortcuts
Tool palette:

Keyboard: ALT, P, E

Dialog box options

Symbols
Select a symbol from the list of available symbols.

Preview box
Displays the graphic of the selected symbol.

Related topics
Editing graphic elements
Placing IEEE symbols



Title Block command (Place menu)
Use this command to place optional title blocks.
You can set title block visibility in the Design Template and Schematic Page Properties dialog 
boxes.

Shortcut
Keyboard: ALT, P, K

Dialog box options

Symbol
Specifies a symbol to select and view. Use an asterisk (*) to match any string of 
characters, and a question mark (?) to match any single character.

Symbol List
Displays a list of title blocks in the libraries selected in the Libraries list box that match 
what's entered in the Symbol text box. When you select a title block in this list, its name 
displays in the Symbol text box, and its graphic displays in the preview box. Select a title 
block from the list of symbols available in the selected libraries.

Libraries
Select one or more libraries from the list of available libraries. The symbol list displays 
the title blocks from the selected libraries. You also select libraries from the Libraries list 
box to remove them from the list.

Preview box
Displays the graphic of the selected symbol.

Name
Specifies the symbol's name.

Add Library
Displays a standard open dialog box for adding a library to the Libraries list box. You can 
add a library in SDT format. If you do, you can save the library in the Capture format 
(.OLB).

Remove Library
Removes the selected library or libraries from the libraries list box.

Related topics
About title blocks
Setting up the default title block
Controlling title block or grid reference visibility
Creating a custom title block
Design Template command
Editing title block information
Placing multiple title or revision blocks
Schematic Page Properties command



Title blocks and text cannot be mirrored or rotated.



Bookmark command (Place menu)
Use this command to place a bookmark. A bookmark is a reference point on a schematic 
page for finding a location.

Shortcut
Keyboard: ALT, P, M

Dialog box option

Name
Specifies the bookmark's name.

Related topics
Moving to a location, reference, or bookmark
Setting a bookmark
Bookmarks command (Edit menu, Browse command)
Go To command



Text command (Place menu)
Use this command to place comment text on the schematic page or part. To quit placing 
text, press ESC or choose the selection tool.

Shortcuts
Tool palette:

Keyboard: ALT, P, T
SHIFT+T

Dialog box options

Text
Specifies the text to display. Enter the text in the text box.

Color
Specifies the color of the text.

Rotation
Specifies the rotation of the text.

Font
Change Displays a dialog box so you can select a font.
Use Default Changes the font to the default font specified in the Design Template 

dialog box.

Related topics
Placing and editing text
Specifying text font and size
Moving and rotating text
Importing text
Exporting text
Replacing text
Specifying text font and size



Line command (Place menu)
Use this command to draw a line. To place a line, you press the left mouse button to start 
the line. Without releasing the left mouse button, drag the pointer to the other end point for 
the line. Release the left mouse button.
Holding the SHIFT key down while placing lines constrains the lines to 90 degree angles.
You may also use the keys B and E to start and end lines.

Shortcuts
Tool palette:

Keyboard: ALT, P, L

Related topics
Creating graphics
Drawing lines
Editing graphics



Rectangle command (Place menu)
Use this command to draw a rectangle. Press the left mouse button and drag the pointer to 
define the rectangle. To quit drawing rectangles, press ESC, or click on the selection tool.
Hold the SHIFT key down while placing rectangles constrains them to squares.

Shortcuts
Tool palette:

Keyboard: ALT, P, R

Related topics
Creating graphics
Drawing rectangles and squares
Editing graphics



Ellipse command (Place menu)
Use this command to draw an ellipse. Press the left mouse button and drag the pointer to 
define the ellipse. To quit drawing ellipses, press ESC, or click on the selection tool.
Holding the SHIFT key down while placing ellipses constrains them to circles.

Shortcuts
Tool palette:

Keyboard: ALT, P, S

Related topics
Creating graphics
Drawing circles and ellipses
Editing graphics



Arc command (Place menu)
Use this command to draw an arc. To quit drawing arcs, press ESC, or click on the selection 
tool.
When drawing an arc, click the left mouse button to place the center of the arc. You can then
move the pointer to increase or decrease the arc radius. Click the left mouse button a 
second time to set the radius size. You can now move the pointer to increase or decrease the
arc length. Rotate the pointer counter-clockwise to increase the arc length. Click the left 
mouse button again to set the arc length.
Holding the SHIFT key down while setting the arc length constrains the arc to the set radius.

Shortcuts
Tool palette:

Keyboard: ALT, P, A

Related topics
Creating graphics
Drawing arcs
Editing graphics



Polyline command (Place menu)
Use this command to draw a polyline or polygon. To quit drawing polylines, press ESC, or click
on the selection tool. Click the left mouse button once to place one segment of the line and 
start another. Double-click the left mouse button to end the line while drawing open poly 
shapes, or single-click the left mouse button to end the line while drawing closed poly 
shapes.
Holding the SHIFT key down when placing polylines constrains the lines to 90 degree angles.
You may also use the keys B and E to start and end polylines.

Shortcuts
Tool palette:

Keyboard: ALT, P, Y
SHIFT+Y

Related topics
Creating graphics
Drawing polylines
Editing graphic elements



Picture command (Place menu)
Use this command to place bitmaps. The Picture command opens a standard Windows dialog
box where you choose the file that contains the picture.
After you select a bitmap, it appears attached to the pointer. Click the left mouse button to 
place the bitmap.

Shortcut
Keyboard: ALT, P, U

Related topic
Placing bitmaps
Special considerations for plotting



Update Part References command (Tools menu)
Use this command to update part references in the active design. You specify the scope and 
parameters of the update in the Update Part References dialog box.

Shortcuts
Toolbar:

Keyboard: ALT, T, U

Dialog box options

Scope
Specifies whether to update all the part references in the design (or library), or just the 
selected schematic pages.

Action
Specifies whether to incrementally update parts (those with a question mark in the part 
reference), unconditionally update all the parts in the selected schematic pages, or to 
reset all the part references to "U?" An unconditional update changes both the part 
reference, and the part in the package. Resetting all part references to "U?" also changes
the part in the package to "A" (where applicable).

Physical Packaging
Specifies the properties that must match for Capture to group parts in a single package.
For example, say your design uses both Tantalum capacitors and ceramic disk capacitors.
You could define a user property called "Voltage" for all capacitors in the design, and 
assign it the value "100V" or "25V" as appropriate. Assign ".01uF" to the Part Value 
property for all the capacitors.
To update part references in    your design, type "{Part Value} {Voltage}" (without the 
quotation marks) in the Part Value property combine text box.
Capture groups the parts with "C?" as the part reference, and ".01uF" as the part value, 
but it separates the 100V Tantalum capacitors from the 25V ceramic disk capacitors.

Reset reference numbers to begin at 1 in each schematic
Specifies whether to number parts within the context of the schematic. When this option 
is selected, Capture begins numbering parts at 1 for every selected schematic. 
Otherwise, Capture continues numbering after the highest referenced part in the 
selected schematic pages.

Do not change the page number
Specifies whether to renumber the schematic pages as part of the part reference update 
process.

Related topics
Assigning unique part references
Combined property strings
Forcing multiple parts into one physical package
Removing part reference assignments
Processing your design
Choosing between logical and physical view
Working in both logical and physical view



If your design contains multiple heterogeneous parts that are the same part in the package,
you will need to update their part reference after every time you reset all part references to
"U?".



If your design contains multiple heterogeneous parts that are the same part in the package,
you will need to update their part reference after every time you reset all part references to
"U?".



Gate and Pin Swap command (Tools menu)
Use this command to swap parts in a package, part references, and pins in the active design
based on the contents of a swap file created by you or your PC board layout software. 
Capture swap files use a .SWP file extension.

Shortcuts
Toolbar:

Keyboard: ALT, T, G

Dialog box options

Scope
Specifies whether to process all the part references in the design or just in the selected 
schematic page or pages.

Swap File
Specifies the swap file as described above. For more information about swap files, see 
Creating a swap file.

Browse
Displays a standard Windows dialog box for selecting the include file.

Related topics
Back annotating a schematic
Creating a swap file
Creating a combined swap and update file 
Processing your design
Choosing between logical and physical view
Working in both logical and physical view



Swap files are not true transaction swap files. If you a swap file contains the following lines:
SWAP U1 U2
SWAP U2 U3
SWAP U3 U4

the original U1 is changed to U2. It does not change to U3 or U4, as it would in a pure 
transaction system.



Update Properties command (Tools menu)
Use this command to update properties based on an update file. This command constructs a
combined property string for a part or net. Then, if that string matches a string in the update
file, it replaces the specified properties of the combined property string with the update 
string properties. Capture update files use a .UPD file extension.
If you are updating net properties, Capture will update all of the nets on the schematic even 
if only one schematic page is selected. Capture updates all of the nets on the schematic 
because a single net can appear on more than one schematic page within the schematic. 
Capture only updates the selected schematics and schematic pages when updating part 
properties.
You can update properties of parts in libraries as well as update properties of parts in 
designs.

Shortcut
Keyboard: ALT, T, P

Dialog box options

Scope
Specifies whether to process all the properties in the design or just the in selected 
schematic page or pages.

Update parts and Update nets
Specifies whether to update the properties of parts or nets.

Convert the resulting combined property to uppercase
Converts the case of the combined property to uppercase when matching update 
properties.

Convert the update property to uppercase
Converts the case of characters in the update property to upper case. The update file 
itself remains unchanged.

Unconditionally update the property
Unconditionally changes the specified property. By default, a property is only updated if 
it is empty. That is, properties with values already in them are not updated.

Create a report file
Specifies if Capture creates a report file. 

Report file
Specifies a report file and path. For an example of a report file, see Update Properties 
sample report file. For more information on report files, see Sample report files.

Property update file
Specifies an update file. The update file must be in ASCII format. For more information 
about update files, see Creating an update file.

Browse
Displays a standard Windows dialog box for selecting files.

Related topics



Combined property strings
Creating an update file
Creating a combined swap and update file 
Update Properties sample report file
Updating part or net properties
Updating part properties in a library
Processing your design
Choosing between logical and physical view
Working in both logical and physical view



Capture report files are text files, and can be opened in any text editor. You may want to 
use the tab alignment capability of your word processor to line reports up correctly. 
Spreadsheets will automatically align the columns of Capture-generated report files.



Design Rules Check command (Tools menu)
Use this command to check a design for violations of design rules. Capture places DRC error 
markers on schematic pages as needed. You can search for the markers by using the 
Browse, DRC Markers command on the Edit menu.
 
 

Shortcuts
Toolbar:

Keyboard: ALT, T, D

Design Rules Check tab dialog box options

Scope
Select the scope of the cross referencing. The scope can cover the entire design, or 
selected schematics and pages.

Action
Specifies either a design rules check or deletion of existing DRC markers. The DRC 
markers are automatically deleted when you run a design rules check.

Report
Select the report information you want Capture to check for in the design, or related 
schematics and pages. Also, select the objects you want Capture to report to you in a file
you specify. For more information on report options, see DRC report options. For an 
example of a report file, see Design Rules Check sample report file.

Browse
Displays a standard Windows dialog box for selecting files.

ERC Matrix tab dialog box options

Allows you to set the rules that the Design Rules Check uses when testing connections 
between pins, hierarchical blocks, and hierarchical ports.
The pins, hierarchical ports, and off-page connectors are listed in columns and rows in the 
table. A test is represented by the intersection of a row and column. Either the intersection 
of a row and column is empty, or it contains a "W" or an "E." An empty intersection 
represents a valid connection, a "W" is a warning, and an "E" represents an error. You can 
switch through these three settings by pointing to an intersection and clicking the mouse 
button until the desired setting appears. You can also type W for warning, E for error, and N 
for an empty intersection. In addition to these keys, the arrow keys allow you to select other 
intersections. For more information, see Pin shapes and types.

Restore defaults
Restores the ERC matrix to its default values.

Related topics
Browsing a design or a library
Checking for design rule violations
Design Rules Check sample report file
Design Rules Check back annotation
Design Rules Check report options



Interpreting Design Rules Check reports
Pin shapes and types
Processing your design
Choosing between logical and physical view
Working in both logical and physical view
Browse command
Browse, DRC Markers command
Go To command



Generally, you should run Design Rules Check before you generate a netlist to verify your 
schematic design. It warns you if certain conditions exist in your design. The severity of the
specific problem may prevent completion of the design. Other conditions are subject to 
your judgment and may be of no consequence. This allows for more efficient netlist 
creation, and also allows you to concentrate on netlist-specific problems if they should 
occur during the Create Netlist process. Once you are satisfied with the results of design 
tests like Design Rules Check, then proceed with the creation of a netlist.

Design Rules Check uses the decision matrix located in the Configure Schematic Tools 
menu. It also uses a set of pre-determined rules, which are part of the executable code.

Use Design Rules Check as a guide to verify the integrity of your design. It is only a guide. It
is possible to generate a valid netlist even if Design Rules Check reports errors.



Design Rules Check report options
All options leave messages and reports in the session log. Selected report options also print 
to the specified report file. By default, the DRC report file uses the same name as the design,
but with a .DRC file extension. This file contains information reported from a design rules 
check.

Create DRC markers for warnings
Places DRC symbols on the schematic page for warnings in addition to the errors. You can
remove DRC markers by running a design rules check with the action set to remove DRC 
markers.

Check hierarchical port connections
Verifies that hierarchical ports in a hierarchical block match those in the child schematic. 
Errors are generated if the number of hierarchical ports differs between the parent and 
child schematics. Also generates errors if the type of hierarchical ports are not identical 
between the two schematics.

Check off-page connector connections
Verifies that off-page connector nets on a schematic page match those on other 
schematic pages.

Report identical reference designators
Checks for unique part references, and reports parts with duplicate part references.

Report type mismatch parts
Checks for and reports part references which display the wrong part in the package. For 
example, this option would report a part with the reference designator "U1A" if it is "B" in
the package.

Report hierarchical ports and off-page connectors
Lists all hierarchical ports and off-page connectors in the report file.

Check unconnected nets
Checks for and reports all unconnected nets.

Check SDT compatibility
Checks for SDT compatibility. For more information about SDT compatibility, see Saving 
in SDT format.

Report off-grid objects
Lists all objects that are off grid in the report file.

Report all net names
Lists the names of all nets in the report file.

Related topics
Checking for design rule violations
Saving in SDT format
Processing your design
Choosing between logical and physical view
Working in both logical and physical view
DRC Markers (Browse command)



Create Netlist command (Tools menu)
Use this command to create a netlist from the selected documents. This command displays 
the Create Netlist dialog box, a tabbed dialog box that allows you to choose a netlist format. 
You must save your design before creating a netlist.
Netlist formatters that only produce flat netlists, only work on designs with one schematic 
(although it may contain many schematic pages).
If you have translated a design with multiple schematics, use Update Part References (and 
check for duplicate references) before netlisting.
 
 

Shortcuts
Toolbar:

Keyboard: ALT, T, N

Dialog box options
EDIF     2     0     0 tab  
SPICE tab
VHDL tab
Verilog tab
Layout
PCB tab
VST tab
OHDL tab
Other tab

Related topics
Combined property strings
Creating a netlist
Processing your design
Choosing between logical and physical view
Working in both logical and physical view



Other tab
The Others tab of the Create Netlist dialog box covers the netlist formats not covered in the 
other eight tabs, as well as some of the netlist formats on the first eight tabs. The options 
available depend on the selected format. The following is a list of available formats:

Algorex (ALGOREX.DLL)
Allegro (ALLEGRO.DLL)
Altera ADF (ALTERAAD.DLL)
AppliconBRAVO (APPLBRAV.DLL)
AppliconLEAP (APPLLEAP.DLL)
Cadnetix (CADNETIX.DLL)
Calay (CALAY.DLL)
Calay 90 (CALAY90.DLL)
Case (CASE.DLL)
CBDS (CBDS.DLL)
ComputerVision (COMPVISN.DLL)
DUMP (DUMP.DLL)
EDIF (EDIF.DLL)
EEDesigner (EEDESIGN.DLL)
FutureNet (FUTURE.DLL)
HiLo (HILO.DLL)
Intel ADF (INTELADF.DLL)
Intergraph (INTERGRA.DLL)
Mentor (MENTOR.DLL)
MultiWire (MULTIWIR.DLL)
OHDL Net (OHDLNET.DLL)
PADS 2000 (PADS2K.DLL)
PADS-PCB (PADSPCB.DLL)
PCAD (PCAD.DLL)
PCADnlt (PCADNLT.DLL)
PCBII (PCBII.DLL)
PCBIIL (PCBIIL.DLL)
PDUMP (PDUMP.DLL)
PLD (PLDNET.DLL)
RacalRedac (RACALRED.DLL)
Scicards (SCICARDS.DLL)
SPICE (SPICE.DLL)
Tango (TANGO.DLL)
Telesis (TELESIS.DLL)
Vectron (VECTRON.DLL)
VST Model (VSTMODEL.DLL)
WireList (VIRELIST.DLL)



Cross Reference command (Tools menu)
Use this command to create a cross-reference listing telling you where each part is located, 
and the library it comes from.

Shortcuts
Toolbar:

Keyboard: ALT, T, C

Dialog box options

Scope
Specifies whether to cross-reference the entire design or just the selected schematic 
page or pages.

Sorting
Specifies whether to sort output by part value or part reference first.

Report
Report the X and Y coordinates of all parts

Includes the X and Y coordinates of all parts in the cross reference report file.
Report unused parts in multiple part packages

Includes unused part in multiple part packages, in the report file.
Report file

Specifies the path and file name for the report. For an example of a cross reference 
report file, see Cross Reference sample report file.

Browse
Displays a standard Windows dialog box for selecting files.

Related topics
Cross Reference sample report file
Creating a cross reference report
Processing your design
Choosing between logical and physical view
Working in both logical and physical view



Bill of Materials command (Tools menu)
Use this command to create a summary list of all parts used in the design. You can also use 
an include file to add information to the bill of materials. By default, Capture include files use
a .INC file extension.
 

Shortcuts
Toolbar:

Keyboard: ALT, T, B

Dialog box options

Scope
Select the scope of the bill of materials. The scope can cover the entire design, or the 
selected schematics and pages.

Header
Specifies a header that Capture inserts on each page. If this is left blank, Capture 
assumes there is no header. Typically, this text box contains information such as title of 
the design, the date, the document number, the revision code, the report name, the 
page number, and the time the report is created.

Combined property string
Specifies the properties that must match for Capture to group them in the bill of 
materials. Typically this text box should be set to "{Part Value}" (without the quotation 
marks). 

To insert a tab, use the \t character sequence. For example, "{Reference}\t{Value}" 
prints a part's reference, a tab character, and the part's value.

To create separate listings for 100V and 25V .01uF capacitors, for example, set the Part 
Value combined property string to "{Part Value} {Voltage}" (without the quotation 
marks), where Voltage is a user property in which you store the appropriate voltage 
values. 

Place each part entry on a separate line
Specifies that each part entry appears on a separate line in the bill of materials report 
file. When this option is selected, the quantity of parts sharing the same Part Value 
appears on one line, with each part uniquely listed below. When this option is not 
selected, all the parts with the same Part Value are listed on one line.

Include File
Merge an include file with report

Specifies whether to merge an include file with the report. For more information 
about include files, see Creating an include file.

Combined property string
Specifies a lookup string to match in the include file.

Include file
Specifies the path and name of the include file.

Report
Specifies the bill-of-materials output file. For an example of a cross reference report file, 



see Bill of Materials sample report file.

Browse
Displays a standard Windows dialog box for selecting files.

Related topics
Bill of Materials sample report file
Combined property strings
Creating an include file
Generating a bill of materials
Processing your design
Choosing between logical and physical view
Working in both logical and physical view



Reference designators should not exceed 24 characters. When Bill of Materials encounters 
a reference designator that is longer than 24 characters, an error occurs and the bill of 
materials isn't generated.



Reference designators should not exceed 24 characters. When Bill of Materials encounters 
a reference designator that is longer than 24 characters, an error occurs and the bill of 
materials isn't generated.



Extract PLD command (Tools menu)
Use this command to create PLD source files for parts in a package found in the active 
design.

Shortcuts
Keyboard: ALT, T, X

Dialog box options

Scope
Specifies whether to cover the entire design, or just the selected schematic page or 
pages.

Action
Specifies whether to extract information for one part or all parts in the package.

PLD Part
Specifies which of the part fields holds the PLD part names.

PLD Type
Specifies which of the part fields holds the part architecture.

Report
Specifies whether to produce a report listing the extracted files. Also specifies a file for 
the report. The following is an example of an extract PLD report file (.RPT file extension):
C:\CAPTURE\DESIGN\T1_1800C.pld
C:\CAPTURE\DESIGN\T2_1800C.pld

Browse
Displays a standard Windows dialog box for selecting files.

Related topics
Combined property strings
Extract; PLD sample .PLD file
OrCAD Programmable Logic Design Tools
PLD netlist contents
PLD netlist example
Using Capture with PLD 386+
Processing your design
Choosing between logical and physical view
Working in both logical and physical view



Export Properties command (Tools menu)
Use this command to write the properties of the selected documents to an ASCII text file. 
Properties are delimited by tabs so the file is suitable for manipulation by spreadsheet or 
database software. You can export properties from a design or library.
For more information on property files see Editing property files.
 

Shortcut
Keyboard: ALT, T, E

Dialog box options

Scope
Specifies whether to process the entire design or just the selected documents.

Contents
Specifies whether to export part properties or part and pin properties.

Export File
Specifies the name of the export output file. For more information about property files 
see Editing property files.

Browse
Displays a standard Windows dialog box for selecting files.

Related topics
Editing properties
Exporting part and pin properties
Editing property files
Property file keywords
Sample property files
Import Properties command
Processing your design
Choosing between logical and physical view
Working in both logical and physical view



Import Properties command (Tools menu)
Use this command to import the contents of a tab-delimited property file. The imported 
properties may add to or supersede existing properties. The property file must be in the 
format used by Capture when you choose the Export Properties command from the Tools 
menu. You can import properties to a design or library.
For more information on property files see Editing property files.
 
 

Shortcut
Keyboard: ALT, T, I

Dialog box options
The Import Properties command opens a standard Windows dialog box for opening files.

Related topics
Editing properties
Editing property files
Property file keywords
Sample property files
Export Properties command
Processing your design
Choosing between logical and physical view
Working in both logical and physical view



Preferences command (Options menu)
Use this command to set options in Capture. The options you specify affect Capture's 
behavior, and are saved in the CAPTURE.INI file.

Shortcut
Keyboard: ALT, O, P

Colors tab dialog box options
Defines the default color of objects like aliases, wires, and pins. A standard Windows 
Default Color dialog box opens when you click on the color of an item.

Grid Display tab dialog box options
Controls the behavior and appearance of the grid display for both the schematic page 
editor and the part editor. See Grid display tab (Preferences dialog box) for more 
information.

Pan And Zoom tab dialog box options
Sets auto scrolling options and zoom factor for both the schematic page editor and the 
part editors. See Pan and Zoom tab (Preferences dialog box) for more information.

Select tab dialog box options
Specifies selection options, change the maximum number of objects you can drag, and 
set tool palette visibility for both the schematic page editor and the part editor. For more 
information, see Select tab (Preferences dialog box).

Miscellaneous tab dialog box options
Specifies the fill style, line style, and line width for both the schematic page editor and 
the part editor. Also specifies the line color for the schematic page editor. You can also 
define an incremental save for Capture tools, and define the session log font. For more 
information, see Miscellaneous tab (Preferences dialog box).

Related topics
Configuring Capture
Grid display tab (Preferences    dialog box)
Pan and Zoom tab (Preferences dialog box)
Select tab (Preferences dialog box)
Miscellaneous tab (Preferences dialog box)



The border and grid references of schematic pages use the color specified for title blocks.



Grid display tab (Preferences dialog box)
The options described in this topic are identical for the schematic page editor, and the part 
and symbol editor.

Visible
Displayed Specifies whether the schematic page or part's grid is visible or hidden on

the screen.
Printed Specifies whether the schematic page or part's grid is visible or hidden 

when printed.

Grid Style
Specifies whether the grid appears as grid dots or lines in the editor.

Cursor Snap To Grid
Specifies whether the pointer snaps to the grid in the editor.



When you place a part off grid, it remains off-grid through any cut-and-paste and drag-and-
drop operations.



Pan and Zoom tab (Preferences dialog box)
The options described in this topic are identical for the schematic page editor, and the part 
and symbol editor.

Autoscroll
Scroll Percent Specifies how much of the schematic page or part scrolls across

the screen when the    pointer drags a selected object into the 
border area of the editor.

Border Width (Pixels) Specifies how large the border area of the editor is, in pixels.

Zoom Factor
Specifies the zoom factor for the editor.



Select tab (Preferences dialog box)
The options described in this topic are identical for the schematic page editor, and the part 
and symbol editor.

Area Select
Specifies whether objects are selected when the selection area border intersects them, 
or if the objects are selected only when they are completely enclosed in the selection 
area.

Maximum number of objects to display at high resolution while dragging
Specifies the maximum number of objects which are visible at high resolution while 
performing a drag and drop operation. When you drag a number of objects greater than 
this value, a rectangular place holder appears in lieu of the selected objects.

Show Palette
Specifies whether the tool palette is visible or hidden.



Miscellaneous tab (Preferences dialog box)
The options described in this topic are identical for the schematic page editor, and the part 
and symbol editor, except where noted.

Fill Style
Specifies a fill pattern for rectangles, ellipses, and closed poly shapes.

Line Style and Width
Specifies both line style and line width for lines, polylines, rectangles, ellipses, and arcs.

Color
Specifies the color of lines, rectangles, and ellipses. Polylines and arcs use the default 
color of objects set in the Colors tab. This option is only available in the schematic page 
editor.

Design Manager and Session Log Font
Specifies the font for the session log. If you click on this box, a standard Windows dialog 
box for font selection displays. This option is neither a schematic page nor a part editor 
option.

Enable intertool communication
Enables intertool communication with Simulate. For more information about intertool 
communication, see the OrCAD Simulate Help File. This option is neither a schematic 
page nor a part editor option.



You can change the fill style, line and width style, and color on individual objects using the 
Properties command on the Edit menu.



Design Template command (Options menu)
Use this command to specify default settings for new designs and schematic pages. The 
values specified in this dialog box do not affect existing designs. The Design Options dialog 
box for a library contains only the Fonts tab options.

Shortcut
Keyboard: ALT, O, D

Fonts tab dialog box options
Allows you to change the fonts for objects with text. A standard Windows Font dialog box 
opens when you click on the font display of an object. These options are set once per 
design. Once a design is created, use the Design Properties command to change these 
options for that particular design.

Title Block tab dialog box options 
Allows you to type in the title, organization name and address, document number, 
revision, and CAGE code into the title block. Also allows you to enter the path and 
filename of the library containing the title block, and the title block name. These options 
affect each new page. The OrCAD supplied title block resides in the CAPSYM.OLB library. 
For more information about title blocks, see Setting up the default title block.

Page Size tab dialog box options
Allows you to specify the units of measure used in the schematic page editor. Also allows 
you to change width and height of a schematic page, as well as spacing between pins in 
a design. For more information, see Page Size tab (Design Template dialog box).

Grid Reference tab dialog box options
Allows you to choose between alphabetic and numeric, and between ascending and 
descending for both horizontal and vertical grid references. Also allows you to set the 
grid count for both horizontal and vertical grid references, set the width or length of the 
grid references, and set title block visibility. For more information, see Grid Reference tab
(Design Template dialog box).

Hierarchy tab dialog box options
Allows you to specify default settings of primitive or nonprimitive for hierarchical blocks 
and parts for future designs. These options are set once per design, and affect parts and 
hierarchical blocks that have the Primitive property set to Default. When parts are    
marked as primitive, you cannot descend into them, even if they have attached 
schematics.

SDT Compatibility tab dialog box options
Defines the mapping to use when saving designs in SDT format. It can be changed for 
individual design in the SDT Compatibility tab of the Design Properties dialog box. The 
Part Field to Property mapping fields are used only when you save a Capture design in an
SDT format. To make SDT part fields carry over into Capture properties, you need to 
specify them in the SDT.CFG file. For more information on part fields, see Saving in SDT 
format and Translating part fields.

Related topics
About primitive and nonprimitive parts
Saving in SDT format
Setting up the default title block
Configuring Capture



Translating files
Translating part fields
Design Properties command
Page Size tab (Design Template dialog box)
Grid Reference tab (Design Template dialog box)



To change the properties of an active design, use the Design Properties command. To 
change the properties of an active schematic page, use the Schematic Page Properties 
command. You cannot change the default title block of an active schematic page.



Page Size tab (Design Template dialog box)
Set these options for future schematic pages. Changing these options won't affect schematic
pages you've already created.

Units
Specifies the unit of measurement for future designs. Select either inches or millimeters. 
This only affects the schematic page editor. It doesn't affect the part editor, which is 
always measured in grid units.

New Page Size
Specifies the size of schematic pages for future designs. The first five choices are A to E 
if the unit measurement is inches, or A4 to A0 if the unit measurement is millimeters.

Width
Specifies the width of future schematic pages in the indicated unit measurement. The 
values specified here for page sizes A to E and A4 to A0 are set values in the Page 
Properties dialog box.

Height
Specifies the height of future schematic pages in the indicated unit measurement. The 
values specified here for page sizes A to E and A4 to A0 are set values in the Page 
Properties dialog box.

Pin-to-Pin Spacing
Specifies the spacing between pins in the indicated unit measurement. Also specifies grid
spacing. For example, a pin-to-pin spacing of 0.1 inches means that the dots or lines on 
your grid will be 0.1 inches apart.



Grid Reference tab (Design Template dialog box)
Set these options for future schematic pages. Changing these options won't affect schematic
pages you've already created.

Horizontal and Vertical
Count Specifies the number of divisions in the horizontal or 

vertical grid reference.
Alphabetic and Numeric Specifies whether the grid references are alphabetic or 

numeric.
Ascending and Descending Specifies whether the grid references ascend or 

descend.
Width Specifies the width of the grid reference division. The 

width here is not the distance between grid reference 
division, but the amount of space taken up in the 
schematic page editor.

Border Visible
Displayed Specifies whether the border is visible on the screen.
Printed Specifies whether the border is visible on paper.

Grid References Visible
Displayed Specifies whether the grid references are visible on the 

screen.
Printed Specifies whether the grid references are visible on 

paper.

Title Block Visible
Displayed Specifies whether the title block is visible on the screen.
Printed Specifies whether the title block is visible on paper.



Design Properties command (Options menu)
Use this command in the design manager to globally set design related options throughout a
design. This command is unavailable in physical view.

Shortcut
Keyboard: ALT, O, R

Fonts tab dialog box options
Allows you to change the fonts for objects with text. A standard Windows Font dialog box 
opens when you click on the font display of an item.

Hierarchy tab dialog box options
Allows you to specify default settings of primitive or nonprimitive for hierarchical blocks 
and parts. These options affect parts and hierarchical blocks that have the Primitive 
property set to Default. When parts are    marked as primitive, you cannot descend into 
them, even if they have attached schematics.

SDT Compatibility tab dialog box options
Defines the mapping to use when saving designs in SDT format. The initial specified 
values are inherited from the SDT Compatibility tab of the Design Template dialog box, or
from the SDT.CFG file when you open an SDT schematic (.SCH) file in Capture. The Part 
Field to Property mapping is used only when you save a Capture design in an SDT format.
To make SDT part fields carry over into Capture properties, you need to specify them in 
the SDT.CFG file. For more information on part fields, see Saving in SDT format and 
Translating part fields.

Miscellaneous tab dialog box options
Specifies visibility of power pins in the design. Also displays the design name and other 
related information.

Related topic
Translating files
Saving in SDT format
Design Template command



To change the properties for objects in new designs, use the Design Template command.



Schematic Page Properties command (Options menu)
Use this command in the schematic page editor to set schematic page related options.

Shortcut
Keyboard: ALT, O, R

Page Size tab dialog box options
Allows you to specify the measuring scale used. Also allows you to change width and 
height of a schematic, and set spacing between pins on a schematic page. For more 
information, see Page Size dialog box tab (Schematic Page Properties).

Grid References tab dialog box options
Allows you to choose between alphabetic and numeric, and between ascending and 
descending for both horizontal and vertical grid references. Also allows you to set the 
grid count for both horizontal and vertical grid references, and set the width or length of 
grid references. For more information, see Grid Reference dialog box    tab (Schematic 
Page Properties).

Miscellaneous tab dialog box options
Displays the schematic's creation time, last modification time, and the number of the 
schematic page being viewed in the schematic page editor.

Related topics
Defining schematic page characteristics
Page Size dialog box tab (Schematic Page Properties)
Grid Reference dialog box    tab (Schematic Page Properties)



Page Size dialog box tab (Schematic Page Properties)

Units
Specifies the unit of measurement future designs are measured in. Select either inches 
or millimeters. This only affects the schematic page editor. It doesn't affect the part 
editor, which is always measured in grid units.

New Page Size
Specifies the size of new schematic pages in the current design. The first five choices are
A to E if the unit measurement is inches, or A4 to A0 if the unit measurement is 
millimeters.

Width
Displays the width of new schematic pages in the indicated unit measurement. You may 
specify the width of the custom schematic page. All other schematic page widths are 
permanently set for the current design.

Height
Specifies the height of new schematic pages in the indicated unit measurement. You may
specify the height of the custom schematic page. All other schematic page heights are 
permanently set for the current design.

Pin-to-Pin Spacing
Displays the pin-to-pin spacing in the indicated unit measurement.



Grid Reference tab (Schematic Page Properties dialog box)

Horizontal and Vertical
Count Specifies the number of divisions in the horizontal or 

vertical grid reference.
Alphabetic and Numeric Specifies whether the grid references are alphabetic or 

numeric.
Ascending and Descending Specifies whether the grid references ascend or 

descend.
Width Specifies the width of the grid reference division.

Border Visible
Displayed Specifies whether the border is visible on the screen.
Printed Specifies if the border is visible on paper.

Grid References Visible
Displayed Specifies whether the grid references are visible on the 

screen.
Printed Specifies whether the grid references are visible on 

paper.

Title Block Visible
Displayed Specifies if the title block is visible on the screen.
Printed Specifies if the title block is visible on paper.



Part Properties command (Options menu)
Use this command in the part editor to set part properties.

Default Part Properties
Name Specifies both the name and normal or convert view of the part. 

The part name appears to the left of the period, and the view 
appears to the right. This property is read-only.

Part Reference Specifies both the part reference prefix and the reference 
designator. The reference designator for parts in libraries is a 
question mark (?), indicating an unanotated part reference. This 
property is read-only.

Pin Names Rotate Specifies if the pin names rotate with the pins.
Pin Names Visible Specifies if the pin names are visible in the schematic page editor. 

You may choose either True or False.
Reference Specifies the part reference prefix. This property is read-only.
Schematic Specifies the name of a part's schematic. This property is read-only 

in the part editor. It is an editable user property on parts in the 
schematic page editor.

Schematic Library Specifies the name of a schematic's library. This property is read-
only in the part editor. It is an editable user property on parts in the
schematic page editor.

Value Specifies the part value. If this is not specified when you place the 
part in a schematic, Capture uses the part name.

Shortcut
Keyboard: ALT, O, P

Dialog box options
See User Properties dialog box.

Related topics
Creating a part 
Editing part properties 



You cannot remove a read-only property, but you can make it visible or invisible.



Package Properties command (Options menu)
Use this command in the part editor to set package properties.

Shortcut
Keyboard: ALT, O, P

Dialog box options
See the dialog box options in the New Part command.

Related topic
About parts
New Part command



New Window command (Window menu)
Use this command to display the active schematic page or part in another window.

Shortcut
Keyboard: ALT, W, N



Cascade command (Window menu)
Use this command to "stack" all open Capture windows so that just their title bars are 
visible. The active window stays on top.

Shortcut
Keyboard: ALT, W, C



Tile Horizontally command (Window menu)
Use this command to arrange open Capture windows, one above another, so that all are 
visible.

Shortcut
Keyboard: ALT, W, H



Tile Vertically command (Window menu)
Use this command to arrange open Capture windows, one beside another, so that all are 
visible.

Shortcut
Keyboard: ALT, W, V



Arrange Icons command (Window menu)
Use this command to arrange the icons for minimized Capture windows across the bottom of
the Capture session frame.

Shortcut
Keyboard: ALT, W, A



1, 2, . . . command (Window menu)
Use this command to make the named document window active. Open windows are listed 
alphabetically, with schematic pages and parts grouped under the designs or libraries that 
contain them.
Choose the name or number of the window you want to activate. A check mark indicates the
active window.

Shortcut
Keyboard: ALT, W, n (n = 1, 2, . . .)

Related topics
Design manager window
Part editor window
Session log window
Schematic page editor window
1, 2, 3, 4



Contents command (Help menu)
Use this command to display the main Help window, also called the Contents window. When 
Help is the active window, press C to display the Contents window.

Shortcuts
Keyboard: ALT, H, C

F1



Search for Help On command (Help menu)
Use this command to search for a topic in Help. When Help is the active window, press S to 
search for a topic.

Shortcut
Keyboard: ALT, H, S



Processes command (Help menu)
Use this command to find out how to perform a task in Capture for Windows.

Shortcut
Keyboard: ALT, H, P

Related topic
Processes



Commands and Tools command (Help menu)
Use this command to find out about menu commands and the status bar, toolbar, and tool 
palettes in Capture for Windows.

Shortcut
Keyboard: ALT, H, O

Related topic
Commands and tools



Reference command (Help menu)
Use this command to find out about netlist formats, error messages, design and file 
structure, and terms used in Capture for Windows.

Shortcut
Keyboard: ALT, H, R

Related topic
Reference



How to Use Help command (Help menu)
Use this command to find out how to use Windows Help. This command is available when 
either Capture or Help is the active window.

Shortcut
Keyboard: ALT, H, H



Learning Capture command (Help menu)
Use this command to run the online, interactive tutorial.

Shortcut
Keyboard: ALT, H, L

Related topic
Learning Capture



The related topic above runs the Capture tutorial if the tutorial is located in the 
subdirectory \TUTORIAL of the Capture executable.



Product Support command (Help menu)
Use this command to find out how to reach OrCAD to get answers to your questions.

Shortcut
Keyboard: ALT, H, U

Related topic
Product support



Help for SDT Users command (Help menu)
Use this command to learn about Capture for Windows by applying what you already know 
about Schematic Design Tools.

Shortcut
Keyboard: ALT, H, D

Related topic
Help for SDT users



About Capture command (Help menu)
Use this command to get the software version number, registration number, user 
information, and available Windows resources.

Shortcut
Keyboard: ALT, H, A

Dialog box information
This dialog displays the following information:

Capture version
Copyright information
Technical support, bulletin board, and FAX numbers
Licensing information
Registration number
Available memory and disk space

Related topic
Displaying your registration number



If you are unfamiliar with Windows Help, select How to Use Help from the Help menu 
(ALT, H, H).



Select Entire Net command (pop-up menu)
Use this command to select the entire net associated with the selected wire or bus. To select
an entire net, you must first select a single wire or bus. The Select Entire Net command only 
works on the active schematic page.

Related topic
Selecting an entire net



Design manager window
You manage designs and libraries in the design manager window. The window is divided into 
two sections: the design structure pane on the left, and the browse pane on the right. You 
can control the viewing area of both panes by dragging the splitter to the left or right.
You use the design manager window to create new schematics and schematic pages in a 
design, to create new parts and symbols in a library, and to copy or move parts, symbols, 
schematics, and schematic pages between designs and libraries.

Design structure pane

The design structure pane shows the design structure. In logical view, the design structure 
pane shows you the instances of schematics and schematic pages. The hierarchy is not 
shown in this view, but the root schematic is identified with a backslash (\). This view also 
shows the design cache. Schematics and schematic pages are sorted alpha-numerically in 
this view. In physical view, the design structure pane shows you the occurrences of the 
schematics and schematic pages. In this view, the hierarchy is shown, but the design cache 
is not.
Schematics and parts are listed alpha-numerically in libraries, but schematics are always 
listed before parts.
You can open schematic pages and parts from the design structure pane by double-clicking 
on them. You can also browse a design by selecting documents in this pane and choosing 
the Browse command from the Edit menu.

Browse pane

When you have selected documents in the design structure pane, you can browse them for 
parts, nets, hierarchical ports, off-page connectors, bookmarks, and DRC markers. You see 
the results of the search in the browse pane. To view a specific object, double-click on the 
item in the browse pane. You can sort the browse results by choosing one of the sorting 
buttons at the top of the browse pane. The sorting buttons available vary with the type of 
object you browse for. For more information on sorting order, see Sorting the browse results. 
To add, delete, or change properties, select objects in the browse pane, and then choose the 
Properties command from the Edit menu.
The browse pane is initially empty, and remains empty until you browse a selection.

Logical View

In this view, you can edit every aspect of a design.

Physical View

In this view, you are limited to the following actions:
Checking design rules
Creating a netlist
Editing user properties
Exporting properties
Gate and pin swapping
Importing properties
Updating part references
Updating properties

Related topics



Logical view and physical view
Browsing a design or library
Sorting the browse results
Ascend Hierarchy command
Browse command
Descend Hierarchy command
Logical View command
Physical View command
Properties command



Sorting the browse results
When you browse a design or library, you can sort the results using the buttons at the top of 
the browse pane. Each type of object offers a different set of buttons. When you click on one
of these buttons, Capture alphabetically sorts the selection by the value of the 
corresponding property.

Parts
Reference Order by part reference.
Value Order by the part value. If the part has no alias, this column is 

identical to Source Part
Source Part Order by the source part. If the part is an alias, this column shows 

the original part.
Source Library Order by source library. This column shows the path and library 

where the part exists.
Page Order by schematic page the part appears in.
Schematic Order by the schematic the part appears in.

Nets
Name Order by net alias name.
Net Name Order by net name.
Page Order by schematic page the net appears in.
Schematic Order by the schematic the net appears in.

Hierarchical ports
Port Name Order by hierarchical port name.
Port Type Order by hierarchical port type.
Page Order by schematic page the hierarchical port appears in.
Schematic Order by the schematic the hierarchical port appears in.

Off-page connectors
Off-Page Name Order by off-page connector name.
Page Order by schematic page the off-page connector appears in.
Schematic Order by the schematic the off-page connector appears in.

Bookmarks
Bookmark Name Order by bookmark name.
Page Order by schematic page the bookmark appears in.
Schematic Order by the schematic the bookmark appears in.

DRC markers
DRC Error Order by DRC error message text. This is the text that appears in 

the session log, the DRC report, and the View DRC Marker dialog 
box.

DRC Detail Order by object generating the error.
DRC Location Order by the absolute location of the error.
Page Order by schematic page the DRC marker appears in.
Schematic Order by the schematic the DRC marker appears in.



Related topics
Browsing a design or library
Design manager window
Browse command
View DRC Marker dialog box



Schematic page editor window
You edit schematic pages in the schematic page editor window. This window has two view 
splitters. The splitter at the upper right divides the view horizontally. The splitter at the lower
left divides the view vertically. Each view has its own scroll bars, so you can view separate 
areas on the same page.
If you have multiple occurrences of a schematic open while in physical view, Capture closes 
all of these editors, and opens the instance of the schematic when you switch to logical 
view.

Logical View

When you edit a schematic in logical view, your changes are reflected in every occurrence of
the schematic in the active design. Properties unique to a specific occurrence are not 
accessible in the logical view.

Physical View

When you edit a schematic in physical view, your changes affect only that occurrence, and 
are not accessible in the logical view. Properties applied in the logical view, however, are 
accessible in physical view.
The schematic page editor tool palette is unavailable in this view.

Related topics
Logical view and physical view
Using the schematic page editor



Part editor window
You edit parts and symbols in the part editor window. This window has two view splitters. 
The splitter at the upper right divides the view horizontally. The splitter at the lower left 
divides the view vertically. Each view has its own scroll bars, so you can view separate areas 
on the same part.
You can create parts up to 32 by 32 inches.

Part View

You edit parts in this view.

Package View

You see the entire package in this view. You cannot edit parts in this view, but you can select
parts to edit. This view has no view splitters.
The part editor tool palette is unavailable in this view.

Related topic
Using the part editor



Session log window
The session log contains a record of events that occur during the current session of Capture 
for Windows. This window has a view splitter, located in the upper right corner of the 
window, so you can view separate areas in the session log.
The session log also includes results and messages from Capture utilities, found on the Tools 
menu.
The session log is replaced every time you start Capture, so it is initially empty. You can clear
the session log at any time by pressing CTRL+DEL.
You can save the session log as an ASCII text file, and you can copy text from the session log
onto the Clipboard. You cannot load a saved session log into Capture, and you cannot cut or 
paste text in the session log.

Related topics
Error messages
Using the session log
Shortcuts 



The following Capture utilities are found on the Tools menu:
Update Part References
Gate and Pin Swap
Update Properties
Design Rules Check
Create Netlist
Cross Reference
Bill of Materials
Extract PLD
Export Properties
Import Properties



Session frame window
The session frame contains the following components of Capture:

Session log
Design managers
Schematic page editors
Part editors

As with other true Windows applications, each of these components of Capture can be 
reduced to an icon (minimized), opened (maximized), and resized. For more information on 
using Windows applications, see your Windows documentation.

Related topics
Design manager window
Schematic page editor window
Part editor window
Session log window



Toolbar
The toolbar provides shortcuts for many of the most frequently used commands. You can 
only show and hide the toolbar in the schematic page and part editors.

CLICK A TOOL BUTTON FOR INFORMATION ABOUT THE RELATED COMMAND OR ACTION.

Related topics
Toolbar command
Viewing the toolbar



Open a new design or library---similar to choosing New on the File menu.



Open an existing design or library---similar to choosing Open on the File menu.



Save the active document---same as choosing Save on the File menu.



Print the active document---same as choosing Print on the File menu.



Cut the selected objects to the Clipboard---same as choosing Cut on the Edit menu.



Copy the selected objects to the Clipboard---same as choosing Copy on the Edit menu.



Paste the Clipboard's contents---same as choosing Paste on the Edit menu.



Undo the last command performed, if possible---same as choosing Undo on the Edit menu.



Redo the last command performed, if possible---same as choosing Redo on the Edit menu.



Zoom in on the active schematic page or part---same as choosing Zoom on the View menu 
and then choosing In.



Zoom out from the active schematic page or part---same as choosing Zoom on the View 
menu and then choosing Out.



View a specific area of the active schematic page or part---same as choosing Zoom on the 
View menu and then choosing Area.



View the entire schematic page or part---same as choosing Zoom on the View menu and 
then choosing All.



Update part references in the active design---same as choosing Update Part References on 
the Tools menu.



Back annotate the active design---same as choosing Gate and Pin Swap on the Tools menu.



Check the active schematic page for design rules violations---same as choosing Design 
Rules Check on the Tools menu.



Create a netlist from the active schematic page---same as choosing Create Netlist on the 
Tools menu.



Create a cross reference of the active design---same as choosing Cross Reference on the 
Tools menu.



Create a bill of materials from the active schematic page---same as choosing Bill of 
Materials on the Tools menu.



Display a design manager window for the active document---same as choosing the 
appropriate design manager window by number from the Window menu (see 1,     2,     .     .     .   
command).



Schematic page editor tool palette
The schematic page editor tool palette has both electrical tools (in the upper section) and 
drawing tools (in the lower section). The drawing tools are also found on the part editor tool 
palette.
The schematic page editor tool palette is unavailable in physical view.

CLICK A TOOL BUTTON FOR INFORMATION ABOUT THE RELATED COMMAND OR ACTION.

Related topics
Tool Palette command
Viewing the tool palette



Part editor tool palette
The part editor tool palette has basic drawing tools to create a part body (in the lower 
section) and tools to add pins and symbols (in the upper section). The drawing tools are also 
found on the schematic page editor tool palette.

CLICK A TOOL BUTTON FOR INFORMATION ABOUT THE RELATED COMMAND OR ACTION.

Related topics
Tool Palette command
Viewing the tool palette



The following tools are available only on the schematic page editor tool palette.



Selection tool---this is the normal mode. See Selection tool for more information.



Place a part---same as the Part command on the Place menu.



Place a wire---same as the Wire command on the Place menu. 



Place a net alias---same as the Net Alias command on the Place menu.



Place a bus---similar to the Bus command on the Place menu.



Place a bus entry---same as the Bus Entry command on the Place menu.



Place a power symbol---same as the Power command on the Place menu.



Place a ground symbol---same as the Ground command on the Place menu.



Place a hierarchical block---same as the Hierarchical Block command on the Place menu.



Place a hierarchical port---same as the Hierarchical Port command on the Place menu.



Place an off-page connector---same as the Off-Page Connector command on the Place 
menu.



Place a no connect symbol---same as the No Connect command on the Place menu.



The following tools are available only on the part editor tool palette.



Place an IEEE symbol---same as the IEEE Symbol command on the Place menu.



Place a pin---same as the Pin command on the Place menu.



Place a pin array---same as the Pin Array command on the Place menu.



The following tools are available only on both the schematic page editor tool palette and 
the part editor tool palette.



Place a line---same as the Line command on the Place menu.



Place a polyline---same as the Polyline command on the Place menu.



Place a rectangle---same as the Rectangle command on the Place menu.



Place an ellipse---same as the Ellipse command on the Place menu.



Place an arc---same as the Arc command on the Place menu.



Place text---same as the Text command on the Place menu.



Selection tool

Use this tool to select objects on the schematic page or part. When you finish an action or 
click over "open space," the selection tool becomes active.



Status bar
The status bar displays information about the active window. You can only show and hide the
status bar in the schematic page and part editors.

Left field
Description of selected tool or menu item, prompts, status, etc.

Center field
Current mode (such as "Line Tool" and "View Area") or number of items selected.

Right field
Scale and location (such as "Scale=50% X=10.0 Y=5.0"). The location in schematic page
editors is measured in either inches or millimeters depending on the Units settings on 
the Page Size tab of the Schematic Page Properties dialog box. The location in part 
editors is measured in grid units.

Related topics
Status Bar command
Viewing the status bar



When the session log or a design manager window is active, the center field of the status 
bar is empty.



Add Alias dialog box
The Add Alias dialog box opens when you click on the New button in the Part Aliases dialog 
box.

Name
Specifies the name of the new alias.

Related topic
Part Aliases dialog box



Attach File dialog box
The Attach File dialog box opens when you click on the Attach File button from the Edit 
Hierarchical Block dialog box, the Edit Part dialog box, or the New Part Properties dialog box 
(see New Part command).

File
Specifies the path and name of the external file. The pan and filename show up in the 
Filename user property of the User Properties dialog box.

 

Related topics
Edit Hierarchical Block dialog box
Edit Part dialog box
User Properties dialog box
New Part command



Attach Schematic dialog box
The Attach Schematic dialog box opens when you click on the Attach Schematic button from 
another dialog box.

Schematic Name
Specifies the name of the schematic to attach to the part or hierarchical block.

Library
Specifies the path and name of the associated library, or design, to locate the attached 
schematic. If this is left blank, Capture assumes the schematic resides in the current 
design.

Related topic
About hierarchical blocks



Display Properties dialog box
The Display Properties dialog box opens when you click on the Display button in the User 
Properties dialog box.

Name
Specifies the property name.

Value
Specifies the property's value.

Visible
Specifies the property's visibility.

Color
Specifies the property's color.

Font
Font name Shows the current font used.
Font size Shows the current font size used.
Change Displays a standard Windows dialog box so you can change the font, font 

style, and font size of the property.
Use Default Specifies use of default value for property. The default value is set in the 

Design Template dialog box (see Design Template command).

Rotation
Specifies the rotation of the property.

Related topic
User Properties dialog box



Edit Graphic dialog box
The Edit Graphic dialog box opens when you double-click on a line, or when you select a line 
and choose Properties from the Edit menu.

Line Style & Width
Specifies the line style and width.

Color
Specifies the color of the line.

Related topic
Properties command



Edit Filled Graphic dialog box
The Edit Filled Comment Graphic dialog box opens when you double-click on a closed 
polyline, an ellipse, a rectangle, or when you select a closed object and choose Properties 
from the Edit menu.

Fill Style
Specifies the fill style.

Line Style & Width
Specifies the line style and width.

Color
Specifies the color of the line.

Related topic
Properties command



Edit Hierarchical Port dialog box
The Edit Hierarchical Port dialog box opens when you select a hierarchical port in a 
hierarchical block, or when you select a part and choose Properties    from the Edit menu.

Name
Specifies the name of the hierarchical block.

Type
Select the hierarchical port type from the list of pin types. For more information about pin
types, see Pin shapes and types.

Width
Specifies if the pin connects to a bus or a wire. If bus is specified, the hierarchical port 
must connect to a bus, otherwise, it must connect to a wire.

 

User Properties
Displays the User Properties dialog box so you can modify the hierarchical port's 
properties.

Related topics
Pin shapes and types
User Properties dialog box



Edit Off-Page Connector dialog box
The Edit Off-Page Connector dialog box opens when you select an off-page connector, and 
choose Properties from the Edit menu.

Name
Specifies the name of the off-page connector.

Related topic
Properties command



Edit Part dialog box
The Edit Part dialog box opens when you double-click a part instance or choose Properties 
from the Edit menu.

Part Value
Specifies the part value name.

Part Reference
Specifies the part reference.

Primitive
Default Indicates the part uses the default primitive setting. The default setting is 

set in the Hierarchy tab of the Design Template dialog box (see Design 
Template command).

Yes Indicates the part is a primitive.
No Indicates the part is nonprimitive and descends in hierarchy.

Library
Shows the library that contains the part.

Graphic
Select the graphic to be displayed from a list of options.

Packaging
Part Count Indicates the number of parts in the package.
Part Select a part from the package list.

PCB Footprint
Specifies the part module name, if necessary.

Power Pins Visible
Specifies the visibility of the part's power pins.

User Properties
Displays the User Properties dialog box so you can modify the part's properties.

Attach File
Displays the Attach File dialog box where you specify the text file, such as PLD source 
code, that defines this part. There are no format restrictions for attached files.

 

Attach Schematic
Displays the Attach Schematic dialog box where you specify the name of a schematic, 
and a library or design that defines this homogeneous part if the schematic is not in the 
design. You attach a schematic to create a descendable part or schematic. For more 
information on attaching schematics, see About hierarchical blocks.

 

Related topics
About hierarchical blocks
About parts
About primitive and nonprimitive parts



Editing part properties
Editing properties
Attach File dialog box
Attach Schematic dialog box
User Properties dialog box
Design Template command
Properties command



Edit Port dialog box
The Edit Port dialog box opens when you select a free-standing hierarchical port, and choose
Properties from the Edit menu.

Name
Specifies the name of the hierarchical port.

Type
Select the hierarchical port type from the list of pin types. For more information about pin
types, see Pin shapes and types.

Related topics
Pin shapes and types
Properties command



Edit Properties dialog box
The Edit Properties dialog box opens when you select multiple items, and choose Properties 
from the Edit menu. The selected items must be of a similar nature to bring up this 
spreadsheet editor.

Example

To select an item in the spreadsheet editor, click on the corresponding row number. To select
a common property of the items in the spreadsheet, click on the column heading which 
contains the desired property. To select a single property of one item, click on the cell 
containing the property. To edit a single property of one item, double-click on the cell.

Dialog box options

New
Displays the New Property dialog box so you can add new properties to the items in the 
spreadsheet.

Remove
Removes a property shared by the items in the spreadsheet. You cannot remove or edit 
read only properties.

Copy
Copies the selected cell. The selected cell is copied to the clipboard, but in a format 
which cannot be displayed.

Paste
Pastes the cell currently in the clipboard over the selected cell or column to unify or set 
all properties in a column to the same value).

Related topics
Using the spreadsheet editor
New Property dialog box
Properties command



Net Properties dialog box
The Net properties dialog box opens when you double-click on a wire, or choose Properties 
from the Edit menu.

Name
Specifies the name of the net.

Aliases
Displays all aliases of the net.

User Properties
Displays the User Properties dialog box so you can modify the net's user defined 
properties.

Related topics
User Properties dialog box
Properties command



New Property dialog box
The New Property dialog box opens when you click on the New button in the User Properties 
dialog box or the New button in the Edit Properties dialog box.

Name
Specifies the new property's name.

Value
Specifies the new property's value.

Related topics
Edit Properties dialog box
User Properties dialog box



Part Aliases dialog box
The Part Aliases dialog box opens when you click on the Part Aliases button in the New Part 
Properties dialog box (see New Part command).

Alias Names
Select an alias name from the aliases displayed.

New
Displays the Add Alias dialog box to add new aliases.

Delete
Deletes the selected alias from the list.

Related topics
Add Alias dialog box
New Part command



Pin Properties dialog box
The Pin Properties dialog box opens when you select a pin, and then choose Properties from 
the Edit menu.

Name
Displays the pin name.

Number
Displays the pin number.

Type
Displays the pin type. For more information about pin types, see Pin shapes and types.

Width
Specifies if the pin connects to a bus or a wire. If bus is specified, the pin should connect 
to a bus, otherwise, it should connect to a wire.

 

User Properties
Displays the User Properties dialog box so you can edit the pin properties.

Related topics
Pin shapes and types
User Properties dialog box



Place Hierarchical Port dialog box (inside hierarchical blocks)
The Place Hierarchical Port dialog box opens when you select a hierarchical block, and then 
choose Hierarchical Port from the Place menu.

Name
Specifies the hierarchical port's name.

Type
Select the pin type from the list of pin types. For more information on pin types, see Pin 
shapes and types.

Width
Specifies if the pin connects to a bus or a wire. If bus is specified, the hierarchical port 
must connect to a bus, otherwise, it must connect to a wire.

 

User Properties
Displays the User Properties dialog box so you can edit the pin properties.

Related topics
Pin shapes and types
User Properties dialog box



Place Hierarchical Port dialog box (outside hierarchical blocks)
The Place Hierarchical Port dialog box opens when you choose Hierarchical Port from the 
Place menu.

Symbol
Specifies a symbol to select and view. Use an asterisk (*) to match any string of 
characters, and a question mark (?) to match any single character.

Symbol List
Displays a list of hierarchical ports in the libraries selected in the Libraries list box that 
match what's entered in the Symbol text box. When you select a hierarchical port in this 
list, its name displays in the Symbol text box, and its graphic displays in the preview box.
Select a hierarchical port from the list of symbols available in the selected libraries.

Libraries
Select one or more libraries from the list of available libraries. The symbol list displays 
the hierarchical ports from the selected libraries. You also select libraries from the 
Libraries list box to remove them from the list.

Preview box
Displays the graphic of the selected symbol.

Name
Specifies the symbol's name.

Add Library
Displays a standard open dialog box for adding a library to the Libraries list box. You can 
add a library in SDT format. If you do, you can save the library in the Capture format 
(.OLB).

Remove Library
Removes the selected library or libraries from the libraries list box.



Print To File dialog box
The Print To File dialog box opens when you select the Print to file option and then click on 
OK in either the Print or Print Preview dialog boxes.

Output file name
Specifies the name of the output file.



Rename Alias dialog box
The Rename dialog box opens when you choose the Properties command from the Edit 
menu.

Name
Specifies the name of the net alias.

Related topic
Properties command



Rename Bookmark dialog box
The Rename dialog box opens when you choose the Properties command from the Edit 
menu.

Name
Specifies the name of the bookmark.

Related topic
Properties command



Rename Global dialog box
The Rename Global dialog box opens when you choose the Properties command from the 
Edit menu.

Name
Specifies the name of the symbol.

Related topic
Properties command



User Properties dialog box
The User Properties dialog box opens when you click on the User Properties button, or 
choose the Part Properties command from the Options menu.

Object
Displays the item's name.

Properties
Displays a three column region listing the item's properties.

Name Lists the item's properties.
Value Shows the value of each property.
Attributes Shows the attributes of each property. An "R" indicates the property is 

read-only, and a "V" represents the property is visible to the user.    You 
cannot remove or change the values of read-only properties, but you can 
set their visibility.

Name
Specifies a value of the selected property.

New
Displays the New Property dialog box so you can create a property for the item.

Remove
Removes the selected property from the item's property list.

Display
Displays the Display Properties dialog box so you can change the appearance of the 
selected property.

Related topics
Display Properties dialog box
New Property dialog box
Part Properties command



View DRC Marker dialog box
The View DRC Marker dialog box opens when you select a DRC marker and choose Properties
from the Edit menu.

DRC Marker text box
Displays the DRC marker number and message. This is the same message that appears 
in the session log and the DRC report.

Related topics
Error messages
Session log window
Browsing a design or library
DRC report options
Interpreting DRC reports
Browse, DRC Markers command



Pin shapes and types

Pin shapes

Clock Clock symbol.

Dot Inversion bubble.

Dot-Clock Clock symbol with inversion bubble.

Line Normal pin with lead three grid units in length.

Short Normal pin with lead one grid unit in length.

Zero length Normal pin with lead zero grid units in length.

Pin types
3 State A 3-state pin has three possible states: low, high, and high impedance. 

When it's in its high impedance state, a state pin looks like an open circuit.
For example, the 74LS373 latch has 3-state pins.

Bidirectional A bidirectional pin is either an input or an output. For example, pin 2 on 
the 74LS245 bus transceiver is a bidirectional pin. The value at pin 1 (an 
input) determines the active type of pin 2 as well as others.

Input An input pin is one to which you apply a signal. For example, pins 1 and 2 
on the 74LS00 NAND gate are input pins.

Open Collector An open collector gate omits the collector pull-up. Use an open collector to
make "wire-OF" connections between the collectors of several gates and to
connect with a single pull-up resistor. For example, pin 1 on the 74LS01 
NAND gate is an open collector gate.

Open Emitter An open emitter gate omits the emitter pull-down. The proper resistance is
added externally. ECL logic uses an open emitter gate and is analogous to 
an open collector gate. For example, the MC10100 has an open emitter 
gate.

Output An output pin is one to which the part applies a signal. For example, pin 3 
on the 74LS00 NAND gate is an output.

Passive A passive pin is typically connected to a passive device. A passive device 
does not have a source of energy. For example, a resistor lead is a passive 
pin.

Power A power pin expects either a supply voltage or ground. For example, on 
the 74LS00 NAND gate, pin 14 is VCC and pin 7 is GND. It is not a good 
idea to use overbars above power pin names; if you do, any netlists that 
you create will have invalid power pin names. Power pins are invisible.

Related topic
About power and ground pins
ERC matrix tab (Design Rules Check dialog box)



Only pins of type Power can be made invisible. The Pin Visible option is inactive unless 
Power is the selected pin type. For more information see About power and ground pins.





Reference
Netlist formats

Formats supported, example schematics, and corresponding netlist output

Messages
Warnings, errors, and other messages displayed by Capture

Glossary
Terms used in Capture documentation

Report files
Sample output from Capture tools

Capture directory structure
Files and directories installed by Capture



Netlist formats
OrCAD provides a number of netlist format files. You choose a netlist format in the Create 
Netlist dialog box.

Related topics
Creating a netlist
Create Netlist command
Algorex
Allegro
AlteraADF
AppliconBRAVO
AppliconLEAP
Cadnetix
Calay
Calay 90
Case
CBDS
ComputerVision
DUMP
EDIF     2     0     0  
EEDesigner
FutureNet
HiLo
Intel ADF
Intergraph
Layout
Mentor
MultiWire
OHDL
PADS 2000
PADS-PCB
PCAD
PCADnlt
PCB (PCBII and PCBIIL)
PDUMP
PLD
RacalRedac
Scicards
SPICE
Tango
Telesis
Vectron
Verilog
VHDL
VST
VST Model
WireList



The Capture netlist format files are not the same as those shipped with SDT 386+. It is 
important that you keep both versions of the netlist format files installed if you plan on 
using both Capture and SDT 386+.



Creating a netlist
After you design a schematic in Capture, you create a netlist in order to exchange schematic
information with other EDA tools. You can choose from more than 30 industry-recognized 
netlist formats. Your choice of netlist format is determined by the application that you intend
to use.
Netlist formatters that only produce flat netlists, only work on designs with one schematic 
(although it may contain many schematic pages).
If you have translated a design with multiple schematics, use Update Part References (and 
check for duplicate references) before netlisting.
To create a netlist
1 From the File menu, choose Save or Save As to save your design. You cannot create a 

netlist if you have any unsaved edits in your design.
2 From the View menu, select the appropriate view:

If you want a flat design output, choose Physical and use any format.
or
If you want a hierarchical design output, choose Logical. Use one of the following formats 
for a hierarchical design:

EDIF 2 0 0
SPICE
VHDL
Verilog
VST

3 From the Tools menu, choose Create Netlist.
4 Select a netlist format.
5 In the Destination1 text box, enter a name for the output file. If the selected format 

creates an additional file (such as a map file or pinlist file), enter the filename in the 
second text box.

6 Set the Part Value and PCB Footprint combined property strings to reflect the information 
you want in the netlist output. For more information about combined property strings, see
Combined property strings,

7 If necessary, choose the Options button, set the format-specific options, and choose OK to
close the Netlist Options dialog box.

8 Choose OK to close the Create Netlist dialog box and create the netlist.

Related topics
Netlist formats
About netlist format, view, and design structure
Combined property strings
Netname resolution
Create Netlist command
Rebuild Physical View command



Netname resolution
When you are drawing schematics, you can assign a variety of aliases to signals that are 
ultimately connected, but the netlist needs exactly one name for each net.
If Create Netlist encounters multiple names for a single net, higher priority aliases override 
lower priority aliases. Priority is determined by the source of the name, ranked as follows:

Lowest: System-generated names
Aliases
Power object names
Off-page connectors
Hierarchical port names

Highest: Named nets
Any remaining conflicts among netnames are resolved according to the following rules:

The netname closest to the "root" of the design takes precedence over those further 
away.

If the net is a bus, the net alias assigned to the greatest number of bus members has 
highest priority.

Among netnames of equal precedence, priority follows alphabetical order.
As you can see, a net may change names several times as Create Netlist works. For 
example, the net may start with an alias of Battery on one page, be renamed ToBattery from
an off-page connector, change again to become DC as a port is encountered, and finally 
change to BatteryBackup when Create Netlist finds a named net closer to the root 
schematic. Once the netlist is created, you can select any piece of the net anywhere in the 
design and see the net's name as it is recorded in the netlist (BatteryBackup), not as it 
appears at that particular location.

Related topics
Assigning a netname
Create Netlist command



Combined property strings
With many of the tools in Capture, such as Create Netlist and Update Part References, you 
use combined property strings to convey information to the tool or to limit the tool's action.
A combined property string consists of one or more property names, enclosed in braces, and
can also contain literal text. Capture combines the values of the named properties with any 
literal text to create a string. An example is:

{Part Value}{Part Reference}
where "Part Value" and "Part Reference" are property names. Using this combined property 
string and a part with a part value of 74LS32 and a part reference of U?A, Capture creates 
the string:

74LS32U?A
You can include spaces and other characters in the combined property string, as in this 
example:

Part: {Part Value} ({Part Reference})
Using this combined property string and the same part, Capture creates the string:

Part: 74LS32 (U?A)
Different tools use combined property strings in different ways. For example, Update Part 
References uses one to compare parts---if one part's combined property string matches 
another part's combined property string, it packages the parts together.

Related topics
Update Part References command
Update Properties command
Create Netlist command
Bill of Materials command
Extract PLD command
Working with properties
Editing properties
Defining properties
New Property dialog box



You can include tabs in combined property strings, so that the output file can be 
manipulated in a spreadsheet or database application. Tabs also help format report files, 
such as those created by the Bill of Materials command.

Wherever you want to have a tab in the output file, insert the characters \t (a backslash 
and a lowercase "t") in the combined property string.



This example was created with the combined property strings for Create Netlist set to their 
default values, as shown below:

   



This example was created with the combined property string for Create Netlist set to its 
default value, as shown below:

   



This example was created with the combined property string and other options for Create 
Netlist set to their default values, as shown below:

   



Most flat netlist examples

 
 



ADF examples

 
 



VST Model netlist example

 
 



PLD netlist example

 
 



OHDL netlist example



 
 





SPICE netlist example (flat)



EDIF netlist example (logical view)
CLICK ON A HIERARCHICAL BLOCK TO VIEW THE LEAF SCHEMATIC.

  



EDIF netlist example (logical view)
CLICK ON THE ASCEND HIERARCHY BUTTON TO VIEW THE ROOT SCHEMATIC.

  



EDIF netlist example (physical view)
CLICK ON A HIERARCHICAL BLOCK TO VIEW THE LEAF SCHEMATIC.

  



EDIF netlist example (physical view)
CLICK ON THE ASCEND HIERARCHY BUTTON TO VIEW THE ROOT SCHEMATIC.

  



EDIF netlist example (physical view)
CLICK ON THE ASCEND HIERARCHY BUTTON TO VIEW THE ROOT SCHEMATIC.

  



SPICE, VHDL, and Verilog netlist examples (logical view)
CLICK ON A HIERARCHICAL BLOCK TO VIEW THE LEAF SCHEMATIC.

 
 



SPICE, VHDL, and Verilog netlist examples (logical view)
CLICK ON THE ASCEND HIERARCHY BUTTON TO VIEW THE ROOT SCHEMATIC.

 
 



SPICE, VHDL, and Verilog netlist examples (physical view)
CLICK ON A HIERARCHICAL BLOCK TO VIEW THE LEAF SCHEMATIC.

 
 



SPICE, VHDL, and Verilog netlist examples (physical view)
CLICK ON THE ASCEND HIERARCHY BUTTON TO VIEW THE ROOT SCHEMATIC.

 
 



SPICE, VHDL, and Verilog netlist examples (physical view)
CLICK ON THE ASCEND HIERARCHY BUTTON TO VIEW THE ROOT SCHEMATIC.

 
 



Algorex
The Algorex format has these characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers are limited to six digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
Algorex netlist example
About netlist format, view, and design structure
Other netlist formats



Algorex netlist example
The contents specified by the PCB Footprint combined property string are shown in purple. 
Algorex netlists normally have a .NET file extension.
 

CLOCK
         U1 (14DIP300)-2
A
         U1 (14DIP300)-9,
         U1 (14DIP300)-10
Q
         U1 (14DIP300)-1,
         U1 (14DIP300)-6,
         U2 (14DIP300)-2
N00037
         U1 (14DIP300)-3,
         U1 (14DIP300)-5
N00039
         U2 (14DIP300)-1,
         U1 (14DIP300)-8
VCC
         U1 (14DIP300)-14,
         U2 (14DIP300)-14
GND
         U1 (14DIP300)-7,
         U2 (14DIP300)-7
B
         U1 (14DIP300)-4
OUT
         U2 (14DIP300)-3

Related topic
Other netlist formats



Allegro
The Allegro format has these characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
Allegro netlist example
About netlist format, view, and design structure
Other netlist formats



Allegro netlist example
The contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple. Allegro netlists 
normally have a .NET file extension.
 

$PACKAGES
14DIP300! 74LS00; U1
14DIP300! 74LS32; U2
$NETS
CLOCK;  U1.2
A;  U1.9 U1.10
Q;  U1.1 U1.6 U2.2
N00037;  U1.3 U1.5
N00039;  U2.1 U1.8
VCC;  U1.14 U2.14
GND;  U1.7 U2.7
B;  U1.4
OUT;  U2.3
$END

Related topic
Other netlist formats



AlteraADF
The AlteraADF format has these characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

All ASCII characters are legal.

Dialog box options
Suppress comments
Include unconnected pins
Part Value
PCB Footprint
View output
Part Value
PCB Footprint
View output

Related topics
AlteraADF pipe commands
AlteraADF title block
AlteraADF netlist constraints
AlteraADF netlist example
About netlist format, view, and design structure
Other netlist formats



AlteraADF title block information
Title block information is placed in the first 10 lines of the netlist. The following table shows 
an example netlist header and the title block information from which the header was 
extracted. Header information in bold is text entered in the schematic's title block.

Line Example Header Title Block Field
1 ADF Example Title of schematic page
1 May 15, 1995 Date
2 OrCAD-02 Document Number
2 A Revision Code
3 OrCAD Organization Name
4 9300 SW Nimbus Avenue 1st Address Line
6 Turbo = ON 3rd Address Line
7 5C031 4th Address Line

Title block information in AlteraADF netlists.

Related topic
Other netlist formats



AlteraADF pipe commands
You can place equations in your schematic to be included in the netlist. To place these 
equations on the schematic page, select the Text command from the Place menu (ALT, P, T).
Each equation must start with the pipe character (|). The first line must be: 

|EQUATIONS
This tells Capture that some AlteraADF equations need to be included in the netlist. The 
equations can contain any information you want to include in the netlist.

Related topic
Other netlist formats



AlteraADF netlist constraints
When you create an AlteraADF netlist, you must include the OrCAD-supplied ALTERA_P.OLB 
and ALTERA_M.OLB libraries in your design. You can use only the parts in these two libraries 
to create the schematic.
Inputs and outputs are handled differently in Capture and the Altera software. Capture 
defines inputs and outputs with hierarchical ports and an input/output library object. Altera 
defines inputs and outputs with a library object which is then tagged with the appropriate 
pin number. In the example schematic, the CLOCK signal is an input and the STROBE signal 
is an output
Additionally, library objects with unused pins default to predefined levels in the Altera 
software. Because Capture does not default unconnected pins to any particular level, you 
must tie all unused pins to the appropriate level.

Related topic
Other netlist formats



AlteraADF netlist example
This netlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue. AlteraADF netlists normally have a .NET file 
extension.
 

                                              Revised: May 31, 1995
C:\RD\TEST\PUBS\ADF.DSN                       Revision: 
OrCAD
9300 SW Nimbus Ave.
Beaverton, OR 97008
TURBO = ON
5C031

OPTIONS:TURBO = ON
PART:5C031

INPUTS:
    ENABLE
    RESET
    COINDROP
    CUPFULL
    CLOCK

OUTPUTS:
    DROPCUP
    POURDRNK
    STROBE

NETWORK:
M=INP(COINDROP) % SYM 1 %
B=XOR(E,F) % SYM 2 %
C=NOT(D) % SYM 3 %
D=INP(CLOCK) % SYM 4 %
N=INP(CUPFULL) % SYM 5 %
L=NOT(N) % SYM 6 %
I=INP(RESET) % SYM 7 %
J=INP(ENABLE) % SYM 8 %
R=NOT(E) % SYM 9 %
K=NOT(F) % SYM 10 %
Q=AND(F,R) % SYM 11 %
H=AND(F,E) % SYM 12 %
G=AND(K,L,M) % SYM 13 %
P=AND(K,E,L) % SYM 14 %
O=OR(P,Q) % SYM 15 %
DROPCUP,F=RORF(G,D,H,I,J) % SYM 16 %
POURDRNK,E=RORF(O,D,H,I,J) % SYM 17 %
STROBE=CONF(A,VCC) % SYM 18 %
A=AND(B,C) % SYM 19 %

EQUATIONS:
G = (K & L & M);
H = (F & E);



O = (P # Q);
END$

Related topic
Other netlist formats



AppliconBRAVO
AppliconBRAVO netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
AppliconBRAVO netlist example
About netlist format, view, and design structure
Other netlist formats



AppliconBRAVO netlist example
The contents specified by the PCB Footprint combined property string are shown in purple. 
AppliconBRAVO netlists normally have a .NET file extension.
 

*** Desig 14DIP300
U1
*** Desig 14DIP300
U2
*** NET CLOCK
U1 2
*** NET A
U1 9
U1 10
*** NET Q
U1 1
U1 6
U2 2
*** NET N00037
U1 3
U1 5
*** NET N00039
U2 1
U1 8
*** NET VCC
U1 14
U2 14
*** NET GND
U1 7
U2 7
*** NET B
U1 4
*** NET OUT
U2 3

Related topic
Other netlist formats



AppliconLEAP
AppliconLEAP netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
AppliconLEAP netlist example
About netlist format, view, and design structure
Other netlist formats



AppliconLEAP netlist example
The contents specified by the PCB Footprint combined property string are shown in purple. 
AppliconLEAP netlists normally have a .NET file extension.
 

*** NET CLOCK
U1 2 14DIP300
*** NET A
U1 9 14DIP300
U1 10 14DIP300
*** NET Q
U1 1 14DIP300
U1 6 14DIP300
U2 2 14DIP300
*** NET N00037
U1 3 14DIP300
U1 5 14DIP300
*** NET N00039
U2 1 14DIP300
U1 8 14DIP300
*** NET VCC
U1 14 14DIP300
U2 14 14DIP300
*** NET GND
U1 7 14DIP300
U2 7 14DIP300
*** NET B
U1 4 14DIP300
*** NET OUT
U2 3 14DIP300

Related topic
Other netlist formats



Cadnetix
Cadnetix netlists have the following characteristics:

Part names can contain up to 17 characters.
Module names can contain up to 15 characters.
Reference strings plus pin numbers can contain up to 12 characters.
Node names can contain up to 16 characters.
Pin numbers can contain up to 3 digits.
Pin names are not used.
Node numbers are not checked for length.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
Cadnetix netlist example
About netlist format, view, and design structure
Other netlist formats



Cadnetix netlist example
The contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple. Cadnetix 
netlists normally have a .NET file extension.
 

PARTS LIST

74LS00            14DIP300        U1
74LS32            14DIP300        U2
EOS
NET LIST

NODENAME CLOCK            $
    U1         2
NODENAME A                $
    U1         9  U1        10
NODENAME Q                $
    U1         1  U1         6  U2         2
NODENAME N00037           $
    U1         3  U1         5
NODENAME N00039           $
    U2         1  U1         8
NODENAME VCC              $
    U1        14  U2        14
NODENAME GND              $
    U1         7  U2         7
NODENAME B                $
    U1         4
NODENAME OUT              $
    U2         3
EOS

Related topic
Other netlist formats



Calay
This is the older of two Calay netlist formats. The newer Calay format is Calay     90  .
Calay netlists have the following characteristics:

Part names, module names, and reference strings can each contain up to 19 
characters. 

Node names can contain up to eight characters. Legal characters for node names 
are:

+   -   0..9   A..Z   a..z
Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
Pin numbers are not checked for length.
All ASCII characters are legal except as noted for node names.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
Calay files
Calay netlist example
Calay component file example
About netlist format, view, and design structure
Other netlist formats



Calay files
The Calay format creates two files: the netlist file and a component file. You must enter the 
component filename in the Destination 2 text box on the Create Netlist dialog box.

Related topic
Other netlist formats



Calay netlist example 
Calay netlists normally have a .NET file extension.
 

/CLOCK    U1(2);
/A        U1(9) U1(10);
/Q        U1(1) U1(6) U2(2);
/N00037   U1(3) U1(5);
/N00039   U2(1) U1(8);
/VCC      U1(14) U2(14);
/GND      U1(7) U2(7);
/B        U1(4);
/OUT      U2(3);

Related topic
Other netlist formats



Calay component file example
The contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple.
 

74LS00          U1           14DIP300          000     000     0
74LS32          U2           14DIP300          000     000     0

Related topic
Other netlist formats



Calay 90
Calay 90 netlists have the following characteristics:

Part names, module names, and reference strings can each contain up to 19 
characters. 

Node names can contain up to eight characters. Legal characters for node names 
are:

+   -   0..9   A..Z   a..z
Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
Pin numbers are not checked for length.
All ASCII characters are legal except as noted for node names.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
Calay 90 files
Calay 90 netlist example
Calay 90 component file example
About netlist format, view, and design structure
Other netlist formats



Calay 90 files
The Calay 90 format creates two files: the netlist file and a component file. You must enter 
the component filename in the Destination 2 text box on the Create Netlist dialog box.

Related topic
Other netlist formats



Calay 90 netlist example
Calay 90 netlists normally have a .NET file extension.
 

CLOCK    U1('2);
A        U1('9) U1('10);
Q        U1('1) U1('6) U2('2);
N00037   U1('3) U1('5);
N00039   U2('1) U1('8);
VCC      U1('14) U2('14);
GND      U1('7) U2('7);
B        U1('4);
OUT      U2('3);

Related topic
Other netlist formats



Calay 90 component file example
The contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple.
 

74LS00         U1           14DIP300         000     000     0
74LS32         U2           14DIP300         000     000     0

Related topic
Other netlist formats



Case
Case netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box option
Include unconnected pins
Part Value
PCB Footprint
View output

Related topics
Case netlist example
About netlist format, view, and design structure
Other netlist formats



Case netlist example
This netlist was created with no options selected. The contents specified by the PCB 
Footprint combined property string are shown in purple. Case netlists normally have a .NET 
file extension.
 

ASSERTIONS=OFF;VERSION=400;LOCATION=LOC;
 [SIZE=1;TIMES=1;LOC=(U1);PLOC=U1;SHAPE=14DIP300]
 1=Q;
 2=CLOCK;
 3=N00037;
 4=B;
 5=N00037;
 6=Q;
 7=GND;
 8=N00039;
 9=A;
 10=A;
 11=NC;
 12=NC;
 13=NC;
 14=VCC;
 ;
 [SIZE=1;TIMES=1;LOC=(U2);PLOC=U2;SHAPE=14DIP300]
 1=N00039;
 2=Q;
 3=OUT;
 4=NC;
 5=NC;
 6=NC;
 7=GND;
 8=NC;
 9=NC;
 10=NC;
 11=NC;
 12=NC;
 13=NC;
 14=VCC;
 ;
;

Related topic
Other netlist formats



CBDS
CDBS netlists have the following characteristics:

Part names, module names, reference strings, and pin numbers are not checked for 
length. 

Node names can contain up to 20 characters. These characters are legal: 
/   -   0..9   a..z   A..Z

Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal except as noted for node names.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
CBDS netlist example
About netlist format, view, and design structure
Other netlist formats



CBDS netlist example
The contents specified by the PCB Footprint combined property string are shown in purple. 
CBDS netlists normally have a .NET file extension.
 

.SEARCH P,C

.DD  U1 14DIP300

.DD  U2 14DIP300

.S,CLOCK,U1,2

.S,A,U1,9,U1,10

.S,Q,U1,1,U1,6,U2,2

.S,N00037,U1,3,U1,5

.S,N00039,U2,1,U1,8

.S,VCC,U1,14,U2,14

.S,GND,U1,7,U2,7

.S,B,U1,4

.S,OUT,U2,3

Related topic
Other netlist formats



ComputerVision
ComputerVision netlists have the following characteristics:

Part names, module names, reference strings, and pin numbers are not checked for 
length. 

Node names can contain up to 19 characters. 
Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
ComputerVision netlist example
About netlist format, view, and design structure
Other netlist formats



ComputerVision netlist example
ComputerVision netlists normally have a .NET file extension.
 

0001 CLOCK                U1-2
0002 A                    U1-9  U1-10
0003 Q                    U1-1  U1-6  U2-2
0004 N00037               U1-3  U1-5
0005 N00039               U2-1  U1-8
0006 VCC                  U1-14  U2-14
0007 GND                  U1-7  U2-7
0008 B                    U1-4
0009 OUT                  U2-3

Related topic
Other netlist formats



DUMP
This format produces a flat netlist containing all the information on the schematic pages. No 
information is omitted or changed. You can use this netlist format when troubleshooting a 
design.

Dialog box options
Part Value
PCB Footprint
View output

Related topic
About netlist format, view, and design structure
Other netlist formats



EDIF 2 0 0
EDIF 2 0 0 netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers are limited to five digits following the "N" prefix.
Legal characters are:

0..9   a..z   A..Z   _ (underscore)
Case is not significant. When Capture encounters an illegal character, it issues a warning 
and makes the following changes:

Changes "-" to "MINUS"
Changes "+" to "PLUS"
Changes "\" and "/" to "BAR"
Changes all other illegal characters to "_"

The EDIF formats

Capture provides two EDIF netlist formats. The first format produces either hierarchical or 
flat netlist output, depending on your design structure and the active view. It is accessible 
from the EDIF 2 0 0 tab on the Create Netlist dialog box. The second format produces only 
flat netlists, and is accessible through the Other tab on the Create Netlist dialog box.
Use the EDIF 2 0 0 tab if:

You want to include net, part, or pin properties.
You want a hierarchical netlist.

Use the Other tab if:
You want a flat netlist of a simple hierarchical design.

Hierarchical designs in EDIF

Capture manages the hierarchy by turning pages in the schematic into CELLs in the main 
LIBRARY. These cells can then be referred to by INSTANCE where needed. Because EDIF 
requires a define-before-use philosophy, the hierarchy appears to be inverted in the netlist 
(the root schematic page is the last CELL in the main LIBRARY).

Hierarchical EDIF dialog box options (from the EDIF 2 0 0 tab)
Allow nonEDIF characters
Output pin names (instead of pin numbers)
Do not create "external" library declaration
Output net properties
Output part properties
Output pin properties
Part Value
PCB Footprint
View output

Flat EDIF dialog box options (from the Other tab)
Allow nonEDIF characters
Extract the property names from the property values
Only output the Value and PCB Footprint properties
Output pin names (instead of pin numbers)
Do not create "external" library declaration
Part Value



PCB Footprint
View output

Related topics
Flat EDIF netlist example (Other tab)
Logical view hierarchical EDIF netlist example (EDIF 2     0     0 tab)  
Physical view hierarchical EDIF netlist example (EDIF 2     0     0 tab)  
About netlist format, view, and design structure
Other netlist formats



Some of the options specific to the EDIF netlist format are included to support PC Board 
Layout Tools 386+. If you are creating a netlist for use with PCB 386+, select this option:

Allow nonEDIF characters

If you are creating a netlist for use with any other EDIF reader, you may want to select 
these options:

Extract the property names from the property values
Only output the Value and PCB Footprint properties
Output pin names (instead of pin numbers)



Flat EDIF netlist example
This netlist was created with the Only output the Value and PCB Footprint properties option 
selected. The contents specified by the Part Value combined property string are shown in 
blue; those specified by the PCB Footprint combined property string are shown in purple. 
Flat EDIF netlists normally have a .NET file extension.
 

(edif &MOST
 (edifVersion 2 0 0)
 (edifLevel 0)
 (keywordMap (keywordLevel 0))
 (status
  (written
   (timeStamp 0 0 0 0 0 0)
   (program "EDIF.DLL")
   (comment "Original data from OrCAD CAPTURE schematic"))
  (comment "Generic Netlist Example")
  (comment "August 28, 1995")
  (comment "OrCAD-01")
  (comment "A")
  (comment "OrCAD")
  (comment "9300 SW Nimbus Ave.")
  (comment "Beaverton, OR  97008")
  (comment "")
  (comment ""))
 (external OrCAD_LIB
  (edifLevel 0)
  (technology
   (numberDefinition
    (scale 1 1 (unit distance))))
  (cell &74LS00
   (cellType generic)
   (comment "From OrCAD library FIG_B-01.LIB")
   (view NetlistView
    (viewType netlist)
    (interface
     (port &1 (direction INPUT))
     (port &2 (direction INPUT))
     (port &3 (direction OUTPUT))
     (port &4 (direction INPUT))
     (port &5 (direction INPUT))
     (port &6 (direction OUTPUT))
     (port &7 (direction INPUT))
     (port &8 (direction OUTPUT))
     (port &9 (direction INPUT))
     (port &10 (direction INPUT))
     (port &11 (direction OUTPUT))
     (port &12 (direction INPUT))
     (port &13 (direction INPUT))
     (port &14 (direction INPUT)))))
  (cell &74LS32
   (cellType generic)
   (comment "From OrCAD library FIG_B-01.LIB")
   (view NetlistView
    (viewType netlist)



    (interface
     (port &1 (direction INPUT))
     (port &2 (direction INPUT))
     (port &3 (direction OUTPUT))
     (port &4 (direction INPUT))
     (port &5 (direction INPUT))
     (port &6 (direction OUTPUT))
     (port &7 (direction INPUT))
     (port &8 (direction OUTPUT))
     (port &9 (direction INPUT))
     (port &10 (direction INPUT))
     (port &11 (direction OUTPUT))
     (port &12 (direction INPUT))
     (port &13 (direction INPUT))
     (port &14 (direction INPUT))))))
 (library MAIN_LIB
  (edifLevel 0)
  (technology
   (numberDefinition
    (scale 1 1 (unit distance))))
  (cell &MOST
   (cellType generic)
   (view NetlistView
    (viewType netlist)
    (interface
     (port &CLOCK (direction INPUT))
     (port &OUT (direction OUTPUT))
     (port &B (direction INPUT))
     (port &A (direction INPUT)))
    (contents
     (instance &U1
      (viewRef NetlistView
       (cellRef &74LS00
        (libraryRef OrCAD_LIB)))
      (property PartValue (string "74LS00"))
      (property ModuleValue (string "74LS00"))
      (property TimeStampValue (string "6CB84CB9"))
      (property Field1Value (string "14DIP300"))
      (property Field2Value (string ""))
      (property Field3Value (string ""))
      (property Field4Value (string ""))
      (property Field5Value (string ""))
      (property Field6Value (string ""))
      (property Field7Value (string ""))
      (property Field8Value (string "")))
     (instance &U2
      (viewRef NetlistView
       (cellRef &74LS32
        (libraryRef OrCAD_LIB)))
      (property PartValue (string "74LS32"))
      (property ModuleValue (string "74LS32"))
      (property TimeStampValue (string "6E46169D"))
      (property Field1Value (string "14DIP300"))
      (property Field2Value (string ""))
      (property Field3Value (string ""))
      (property Field4Value (string ""))



      (property Field5Value (string ""))
      (property Field6Value (string ""))
      (property Field7Value (string ""))
      (property Field8Value (string "")))
     (net &N00026
      (joined
       (portRef &3 (instanceRef &U1))
       (portRef &5 (instanceRef &U1))))
     (net &CLOCK
      (joined
       (portRef &CLOCK)
       (portRef &2 (instanceRef &U1))))
     (net &OUT
      (joined
       (portRef &OUT)
       (portRef &3 (instanceRef &U2))))
     (net &B
      (joined
       (portRef &B)
       (portRef &4 (instanceRef &U1))))
     (net &N00030
      (joined
       (portRef &1 (instanceRef &U2))
       (portRef &8 (instanceRef &U1))))
     (net &A
      (joined
       (portRef &A)
       (portRef &9 (instanceRef &U1))
       (portRef &10 (instanceRef &U1))))
     (net &Q
      (joined
       (portRef &1 (instanceRef &U1))
       (portRef &6 (instanceRef &U1))
       (portRef &2 (instanceRef &U2))))
     (net &VCC
      (joined
       (portRef &14 (instanceRef &U1))
       (portRef &14 (instanceRef &U2))))
     (net &GND
      (joined
       (portRef &7 (instanceRef &U1))
       (portRef &7 (instanceRef &U2))))))))
 (design &MOST
  (cellRef &MOST
   (libraryRef MAIN_LIB))))

Related topic
Other netlist formats



Hierarchical EDIF netlist example (logical view)
This netlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue; those specified by the PCB Footprint combined 
property string are shown in purple. EDIF netlists normally have an .EDN file extension.
 

(edif FULLADD
 (edifVersion 2 0 0)
 (edifLevel 0)
 (keywordMap (keywordLevel 0))
 (status
  (written
   (timeStamp 1995 09 14 14 38 17)
   (program "CAPTURE.EXE" (Version "Version X6.10"))
   (comment "Original data from OrCAD/CAPTURE schematic"))
  (comment "Hierarchy (Complex) Example")
  (comment "Thursday, September 14, 1995")
  (comment "OrCAD-06")
  (comment "A")
  (comment "OrCAD")
  (comment "9300 SW Nimbus Ave.")
  (comment "Beaverton, OR 97008")
  (comment "(503) 671-9500 Sales & Administration")
  (comment "(503) 671-9400 Technical Support"))
 (external OrCAD_LIB
  (edifLevel 0)
  (technology
   (numberDefinition
    (scale 1 1 (unit distance))))
  (cell &74LS32
   (cellType generic)
   (comment "From OrCAD library FIG_B-52.OLB")
   (view NetlistView
    (viewType netlist)
    (interface
     (port &1 (direction INPUT))
     (port &2 (direction INPUT))
     (port &3 (direction OUTPUT))
     (port &14 (direction INPUT))
     (port &7 (direction INPUT))
     (port &4 (direction INPUT))
     (port &5 (direction INPUT))
     (port &6 (direction OUTPUT))
     (port &9 (direction INPUT))
     (port &10 (direction INPUT))
     (port &8 (direction OUTPUT))
     (port &12 (direction INPUT))
     (port &13 (direction INPUT))
     (port &11 (direction OUTPUT)))))
  (cell &74LS04
   (cellType generic)
   (comment "From OrCAD library FIG_B-52.OLB")
   (view NetlistView
    (viewType netlist)
    (interface



     (port &1 (direction INPUT))
     (port &2 (direction OUTPUT))
     (port &14 (direction INPUT))
     (port &7 (direction INPUT))
     (port &3 (direction INPUT))
     (port &4 (direction OUTPUT))
     (port &5 (direction INPUT))
     (port &6 (direction OUTPUT))
     (port &9 (direction INPUT))
     (port &8 (direction OUTPUT))
     (port &11 (direction INPUT))
     (port &10 (direction OUTPUT))
     (port &13 (direction INPUT))
     (port &12 (direction OUTPUT)))))
  (cell &74LS08
   (cellType generic)
   (comment "From OrCAD library FIG_B-52.OLB")
   (view NetlistView
    (viewType netlist)
    (interface
     (port &1 (direction INPUT))
     (port &2 (direction INPUT))
     (port &3 (direction OUTPUT))
     (port &14 (direction INPUT))
     (port &7 (direction INPUT))
     (port &4 (direction INPUT))
     (port &5 (direction INPUT))
     (port &6 (direction OUTPUT))
     (port &9 (direction INPUT))
     (port &10 (direction INPUT))
     (port &8 (direction OUTPUT))
     (port &12 (direction INPUT))
     (port &13 (direction INPUT))
     (port &11 (direction OUTPUT))))))
 (library MAIN_LIB
  (edifLevel 0)
  (technology
   (numberDefinition
    (scale 1 1 (unit distance))))
  (cell HALFADD
   (cellType generic)
   (view NetlistView
    (viewType netlist)
    (interface
     (port X (direction INPUT))
     (port Y (direction INPUT))
     (port CARRY (direction OUTPUT))
     (port SUM (direction OUTPUT)))
    (contents
     (instance U1
      (viewRef NetlistView
       (cellRef &74LS32
        (libraryRef OrCAD_LIB))))
     (instance U2
      (viewRef NetlistView
       (cellRef &74LS04



        (libraryRef OrCAD_LIB))))
     (instance U3
      (viewRef NetlistView
       (cellRef &74LS08
        (libraryRef OrCAD_LIB))))
     (instance U4
      (viewRef NetlistView
       (cellRef &74LS08
        (libraryRef OrCAD_LIB))))
     (net N00035
      (joined
       (portRef &8 (instanceRef U2))
       (portRef &13 (instanceRef U3))))
     (net VCC
      (joined
       (portRef &14 (instanceRef U2))
       (portRef &14 (instanceRef U3))
       (portRef &14 (instanceRef U4))
       (portRef &14 (instanceRef U1))))
     (net GND
      (joined
       (portRef &7 (instanceRef U2))
       (portRef &7 (instanceRef U3))
       (portRef &7 (instanceRef U4))
       (portRef &7 (instanceRef U1))))
     (net Y
      (joined
       (portRef &9 (instanceRef U2))
       (portRef &1 (instanceRef U4))
       (portRef &4 (instanceRef U4))
       (portRef Y)))
     (net CARRY
      (joined
       (portRef &6 (instanceRef U4))
       (portRef CARRY)))
     (net X
      (joined
       (portRef &5 (instanceRef U2))
       (portRef &12 (instanceRef U3))
       (portRef &5 (instanceRef U4))
       (portRef X)))
     (net N00027
      (joined
       (portRef &11 (instanceRef U3))
       (portRef &9 (instanceRef U1))))
     (net N00026
      (joined
       (portRef &3 (instanceRef U4))
       (portRef &10 (instanceRef U1))))
     (net SUM
      (joined
       (portRef &8 (instanceRef U1))
       (portRef SUM)))
     (net X_BAR
      (joined
       (portRef &6 (instanceRef U2))



       (portRef &2 (instanceRef U4)))))))
  (cell FULLADD
   (cellType generic)
   (view NetlistView
    (viewType netlist)
    (interface
     (port X (direction INPUT))
     (port Y (direction INPUT))
     (port CARRY_IN (direction INPUT))
     (port CARRY_OUT (direction OUTPUT))
     (port SUM (direction OUTPUT)))
    (contents
     (instance U1
      (viewRef NetlistView
       (cellRef &74LS32
        (libraryRef OrCAD_LIB))))
     (instance halfadd_A
      (viewRef NetlistView
       (cellRef HALFADD)))
     (instance halfadd_B
      (viewRef NetlistView
       (cellRef HALFADD)))
     (net CARRY_OUT
      (joined
       (portRef &3 (instanceRef U1))
       (portRef CARRY_OUT)))
     (net VCC
      (joined
       (portRef &14 (instanceRef U1))))
     (net X
      (joined
       (portRef X (instanceRef halfadd_B))
       (portRef X)))
     (net Y
      (joined
       (portRef Y (instanceRef halfadd_B))
       (portRef Y)))
     (net N00023
      (joined
       (portRef CARRY (instanceRef halfadd_B))
       (portRef &2 (instanceRef U1))))
     (net CARRY_IN
      (joined
       (portRef X (instanceRef halfadd_A))
       (portRef CARRY_IN)))
     (net N00069
      (joined
       (portRef &1 (instanceRef U1))
       (portRef CARRY (instanceRef halfadd_A))))
     (net N00068
      (joined
       (portRef SUM (instanceRef halfadd_B))
       (portRef Y (instanceRef halfadd_A))))
     (net SUM
      (joined
       (portRef SUM (instanceRef halfadd_A))



       (portRef SUM)))
     (net GND
      (joined
       (portRef &7 (instanceRef U1))))))))
 (design FULLADD
  (cellRef FULLADD
   (libraryRef MAIN_LIB))))

Related topic
Other netlist formats



Hierarchical EDIF netlist example (physical view)
This netlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue; those specified by the PCB Footprint combined 
property string are shown in purple. EDIF netlists normally have an .EDN file extension.
 

(edif FULLADD
 (edifVersion 2 0 0)
 (edifLevel 0)
 (keywordMap (keywordLevel 0))
 (status
  (written
   (timeStamp 1995 09 14 14 38 37)
   (program "CAPTURE.EXE" (Version "Version X6.10"))
   (comment "Original data from OrCAD/CAPTURE schematic"))
  (comment "Hierarchy (Complex) Example")
  (comment "Thursday, September 14, 1995")
  (comment "OrCAD-06")
  (comment "A")
  (comment "OrCAD")
  (comment "9300 SW Nimbus Ave.")
  (comment "Beaverton, OR 97008")
  (comment "(503) 671-9500 Sales & Administration")
  (comment "(503) 671-9400 Technical Support"))
 (external OrCAD_LIB
  (edifLevel 0)
  (technology
   (numberDefinition
    (scale 1 1 (unit distance))))
  (cell &74LS32
   (cellType generic)
   (comment "From OrCAD library FIG_B-52.OLB")
   (view NetlistView
    (viewType netlist)
    (interface
     (port &1 (direction INPUT))
     (port &2 (direction INPUT))
     (port &3 (direction OUTPUT))
     (port &14 (direction INPUT))
     (port &7 (direction INPUT))
     (port &4 (direction INPUT))
     (port &5 (direction INPUT))
     (port &6 (direction OUTPUT))
     (port &9 (direction INPUT))
     (port &10 (direction INPUT))
     (port &8 (direction OUTPUT))
     (port &12 (direction INPUT))
     (port &13 (direction INPUT))
     (port &11 (direction OUTPUT)))))
  (cell &74LS04
   (cellType generic)
   (comment "From OrCAD library FIG_B-52.OLB")
   (view NetlistView
    (viewType netlist)
    (interface



     (port &1 (direction INPUT))
     (port &2 (direction OUTPUT))
     (port &14 (direction INPUT))
     (port &7 (direction INPUT))
     (port &3 (direction INPUT))
     (port &4 (direction OUTPUT))
     (port &5 (direction INPUT))
     (port &6 (direction OUTPUT))
     (port &9 (direction INPUT))
     (port &8 (direction OUTPUT))
     (port &11 (direction INPUT))
     (port &10 (direction OUTPUT))
     (port &13 (direction INPUT))
     (port &12 (direction OUTPUT)))))
  (cell &74LS08
   (cellType generic)
   (comment "From OrCAD library FIG_B-52.OLB")
   (view NetlistView
    (viewType netlist)
    (interface
     (port &1 (direction INPUT))
     (port &2 (direction INPUT))
     (port &3 (direction OUTPUT))
     (port &14 (direction INPUT))
     (port &7 (direction INPUT))
     (port &4 (direction INPUT))
     (port &5 (direction INPUT))
     (port &6 (direction OUTPUT))
     (port &9 (direction INPUT))
     (port &10 (direction INPUT))
     (port &8 (direction OUTPUT))
     (port &12 (direction INPUT))
     (port &13 (direction INPUT))
     (port &11 (direction OUTPUT))))))
 (library MAIN_LIB
  (edifLevel 0)
  (technology
   (numberDefinition
    (scale 1 1 (unit distance))))
  (cell halfadd_A
   (cellType generic)
   (view NetlistView
    (viewType netlist)
    (interface
     (port X (direction INPUT))
     (port Y (direction INPUT))
     (port CARRY (direction OUTPUT))
     (port SUM (direction OUTPUT)))
    (contents
     (instance U1
      (viewRef NetlistView
       (cellRef &74LS32
        (libraryRef OrCAD_LIB))))
     (instance U2
      (viewRef NetlistView
       (cellRef &74LS04



        (libraryRef OrCAD_LIB))))
     (instance U3
      (viewRef NetlistView
       (cellRef &74LS08
        (libraryRef OrCAD_LIB))))
     (instance U4
      (viewRef NetlistView
       (cellRef &74LS08
        (libraryRef OrCAD_LIB))))
     (net N00035
      (joined
       (portRef &8 (instanceRef U2))
       (portRef &13 (instanceRef U3))))
     (net VCC
      (joined
       (portRef &14 (instanceRef U2))
       (portRef &14 (instanceRef U3))
       (portRef &14 (instanceRef U4))
       (portRef &14 (instanceRef U1))))
     (net GND
      (joined
       (portRef &7 (instanceRef U2))
       (portRef &7 (instanceRef U3))
       (portRef &7 (instanceRef U4))
       (portRef &7 (instanceRef U1))))
     (net Y
      (joined
       (portRef &9 (instanceRef U2))
       (portRef &1 (instanceRef U4))
       (portRef &4 (instanceRef U4))
       (portRef Y)))
     (net CARRY
      (joined
       (portRef &6 (instanceRef U4))
       (portRef CARRY)))
     (net X
      (joined
       (portRef &5 (instanceRef U2))
       (portRef &12 (instanceRef U3))
       (portRef &5 (instanceRef U4))
       (portRef X)))
     (net N00027
      (joined
       (portRef &11 (instanceRef U3))
       (portRef &9 (instanceRef U1))))
     (net N00026
      (joined
       (portRef &3 (instanceRef U4))
       (portRef &10 (instanceRef U1))))
     (net SUM
      (joined
       (portRef &8 (instanceRef U1))
       (portRef SUM)))
     (net X_BAR
      (joined
       (portRef &6 (instanceRef U2))



       (portRef &2 (instanceRef U4)))))))
  (cell halfadd_B
   (cellType generic)
   (view NetlistView
    (viewType netlist)
    (interface
     (port X (direction INPUT))
     (port Y (direction INPUT))
     (port CARRY (direction OUTPUT))
     (port SUM (direction OUTPUT)))
    (contents
     (instance U1
      (viewRef NetlistView
       (cellRef &74LS32
        (libraryRef OrCAD_LIB))))
     (instance U2
      (viewRef NetlistView
       (cellRef &74LS04
        (libraryRef OrCAD_LIB))))
     (instance U3
      (viewRef NetlistView
       (cellRef &74LS08
        (libraryRef OrCAD_LIB))))
     (instance U4
      (viewRef NetlistView
       (cellRef &74LS08
        (libraryRef OrCAD_LIB))))
     (net N00035
      (joined
       (portRef &8 (instanceRef U2))
       (portRef &13 (instanceRef U3))))
     (net VCC
      (joined
       (portRef &14 (instanceRef U2))
       (portRef &14 (instanceRef U3))
       (portRef &14 (instanceRef U4))
       (portRef &14 (instanceRef U1))))
     (net GND
      (joined
       (portRef &7 (instanceRef U2))
       (portRef &7 (instanceRef U3))
       (portRef &7 (instanceRef U4))
       (portRef &7 (instanceRef U1))))
     (net Y
      (joined
       (portRef &9 (instanceRef U2))
       (portRef &1 (instanceRef U4))
       (portRef &4 (instanceRef U4))
       (portRef Y)))
     (net CARRY
      (joined
       (portRef &6 (instanceRef U4))
       (portRef CARRY)))
     (net X
      (joined
       (portRef &5 (instanceRef U2))



       (portRef &12 (instanceRef U3))
       (portRef &5 (instanceRef U4))
       (portRef X)))
     (net N00027
      (joined
       (portRef &11 (instanceRef U3))
       (portRef &9 (instanceRef U1))))
     (net N00026
      (joined
       (portRef &3 (instanceRef U4))
       (portRef &10 (instanceRef U1))))
     (net SUM
      (joined
       (portRef &8 (instanceRef U1))
       (portRef SUM)))
     (net X_BAR
      (joined
       (portRef &6 (instanceRef U2))
       (portRef &2 (instanceRef U4)))))))
  (cell FULLADD
   (cellType generic)
   (view NetlistView
    (viewType netlist)
    (interface
     (port X (direction INPUT))
     (port Y (direction INPUT))
     (port CARRY_IN (direction INPUT))
     (port CARRY_OUT (direction OUTPUT))
     (port SUM (direction OUTPUT)))
    (contents
     (instance U1
      (viewRef NetlistView
       (cellRef &74LS32
        (libraryRef OrCAD_LIB))))
     (instance halfadd_A
      (viewRef NetlistView
       (cellRef halfadd_A)))
     (instance halfadd_B
      (viewRef NetlistView
       (cellRef halfadd_B)))
     (net CARRY_OUT
      (joined
       (portRef &3 (instanceRef U1))
       (portRef CARRY_OUT)))
     (net VCC
      (joined
       (portRef &14 (instanceRef U1))))
     (net X
      (joined
       (portRef X (instanceRef halfadd_B))
       (portRef X)))
     (net Y
      (joined
       (portRef Y (instanceRef halfadd_B))
       (portRef Y)))
     (net N00023



      (joined
       (portRef CARRY (instanceRef halfadd_B))
       (portRef &2 (instanceRef U1))))
     (net CARRY_IN
      (joined
       (portRef X (instanceRef halfadd_A))
       (portRef CARRY_IN)))
     (net N00069
      (joined
       (portRef &1 (instanceRef U1))
       (portRef CARRY (instanceRef halfadd_A))))
     (net N00068
      (joined
       (portRef SUM (instanceRef halfadd_B))
       (portRef Y (instanceRef halfadd_A))))
     (net SUM
      (joined
       (portRef SUM (instanceRef halfadd_A))
       (portRef SUM)))
     (net GND
      (joined
       (portRef &7 (instanceRef U1))))))))
 (design FULLADD
  (cellRef FULLADD
   (libraryRef MAIN_LIB))))

Related topic
Other netlist formats



EEDesigner
EEDesigner netlists have the following characteristics:

Part names, module names, and pin numbers are not checked for length.
Reference strings are limited to eight characters.
Node names are not supported.
Node numbers are limited to three digits following the "UN" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
EEDesigner netlist example
About netlist format, view, and design structure
Other netlist formats



EEDesigner netlist example
The contents specified by the PCB Footprint combined property string are shown in purple. 
EEDesigner netlists normally have a .NET file extension.
 

(PATH,OrCAD()
(COMPONENTS
U1      ,14DIP300
U2      ,14DIP300
)
(NODES
(UN001
U1      , 2
)
(UN002
U1      , 9
U1      , 10
)
(UN003
U1      , 1
U1      , 6
U2      , 2
)
(UN004
U1      , 3
U1      , 5
)
(UN005
U2      , 1
U1      , 8
)
(UN006
U1      , 14
U2      , 14
)
(UN007
U1      , 7
U2      , 7
)
(UN008
U1      , 4
)
(UN009
U2      , 3
)
)
),OrCAD

Related topic
Other netlist formats



FutureNet
FutureNet netlists have the following characteristics:

Part names are limited to 16 characters.
Module names, node names, and pin numbers are not checked for length.
Reference strings are limited to six characters.
Node numbers are limited to eight digits following the "***" prefix.
Characters are not checked for legality.

Dialog box options
Create a netlist (instead of a pinlist)
Output pin numbers (instead of pin names)
Assign SIG* attributes to off-page connectors
Create CON* symbols for off-page connectors
Assign FutureNet power attributes to power objects
Part Value
PCB Footprint
View output

Related topics
FutureNet pinlist example
FutureNet netlist example
About netlist format, view, and design structure
Other netlist formats



FutureNet pinlist example
This pinlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue; those specified by the PCB Footprint combined 
property string are shown in purple.
 

PINLIST,2
(DRAWING,ORCAD.PIN,1-1
(SYM,1
DATA,2,U1
DATA,3,74LS00
DATA,4,14DIP300
PIN,,Q,1-1,5,23,I0_A
PIN,,CLOCK,1-1,5,23,I1_A
PIN,,N00037,1-1,5,21,O_A
PIN,,B,1-1,5,23,I0_B
PIN,,N00037,1-1,5,23,I1_B
PIN,,Q,1-1,5,21,O_B
PIN,,GND,1-1,5,23,GND_A
PIN,,N00039,1-1,5,21,O_C
PIN,,A,1-1,5,23,I0_C
PIN,,A,1-1,5,23,I1_C
PIN,,UN000001,1-1,5,23,O_D
PIN,,UN000002,1-1,5,23,I0_D
PIN,,UN000003,1-1,5,23,I1_D
PIN,,VCC,1-1,5,23,VCC_A
)
(SYM,2
DATA,2,U2
DATA,3,74LS32
DATA,4,14DIP300
PIN,,N00039,1-1,5,23,I0_A
PIN,,Q,1-1,5,23,I1_A
PIN,,OUT,1-1,5,21,O_A
PIN,,UN000004,1-1,5,23,I0_B
PIN,,UN000005,1-1,5,23,I1_B
PIN,,UN000006,1-1,5,23,O_B
PIN,,GND,1-1,5,23,GND_A
PIN,,UN000007,1-1,5,23,O_C
PIN,,UN000008,1-1,5,23,I0_C
PIN,,UN000009,1-1,5,23,I1_C
PIN,,UN000010,1-1,5,23,O_D
PIN,,UN000011,1-1,5,23,I0_D
PIN,,UN000012,1-1,5,23,I1_D
PIN,,VCC,1-1,5,23,VCC_A
)
SIG,CLOCK,1-1,5,CLOCK
SIG,A,1-1,5,A
SIG,Q,1-1,5,Q
SIG,N00037,1-1,5,N00037
SIG,N00039,1-1,5,N00039
SIG,VCC,1-1,5,VCC
SIG,GND,1-1,5,GND
SIG,B,1-1,5,B
SIG,OUT,1-1,5,OUT



)

Related topic
Other netlist formats



FutureNet netlist example
This netlist was created with the Create a netlist (instead of a pinlist) option selected. The 
contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple. FutureNet 
netlists normally have a .NET file extension.
 

NETLIST,2
(DRAWING,ORCAD.NET,1-1
DATA,50,
DATA,51,C:\RD\TEST\PUBS\MOST.DSN
DATA,52,
DATA,54,May 30, 1995
)
(SYM,1-1,1
DATA,2,U1
DATA,3,74LS00
DATA,4,14DIP300
DATA,23,I0_A
DATA,23,I1_A
DATA,21,O_A
DATA,23,I0_B
DATA,23,I1_B
DATA,21,O_B
DATA,23,GND_A
DATA,21,O_C
DATA,23,I0_C
DATA,23,I1_C
DATA,23,O_D
DATA,23,I0_D
DATA,23,I1_D
DATA,23,VCC_A
)
(SYM,1-1,2
DATA,2,U2
DATA,3,74LS32
DATA,4,14DIP300
DATA,23,I0_A
DATA,23,I1_A
DATA,21,O_A
DATA,23,I0_B
DATA,23,I1_B
DATA,23,O_B
DATA,23,GND_A
DATA,23,O_C
DATA,23,I0_C
DATA,23,I1_C
DATA,23,O_D
DATA,23,I0_D
DATA,23,I1_D
DATA,23,VCC_A
)
(SIG,,CLOCK,1-1,5,CLOCK
PIN,1-1,1,U1,23,I1_A
)



(SIG,,A,1-1,5,A
PIN,1-1,1,U1,23,I0_C
PIN,1-1,1,U1,23,I1_C
)
(SIG,,Q,1-1,5,Q
PIN,1-1,1,U1,23,I0_A
PIN,1-1,1,U1,21,O_B
PIN,1-1,2,U2,23,I1_A
)
(SIG,,N00037,1-1,5,N00037
PIN,1-1,1,U1,21,O_A
PIN,1-1,1,U1,23,I1_B
)
(SIG,,N00039,1-1,5,N00039
PIN,1-1,2,U2,23,I0_A
PIN,1-1,1,U1,21,O_C
)
(SIG,,VCC,1-1,5,VCC
PIN,1-1,1,U1,23,VCC_A
PIN,1-1,2,U2,23,VCC_A
)
(SIG,,GND,1-1,5,GND
PIN,1-1,1,U1,23,GND_A
PIN,1-1,2,U2,23,GND_A
)
(SIG,,B,1-1,5,B
PIN,1-1,1,U1,23,I0_B
)
(SIG,,OUT,1-1,5,OUT
PIN,1-1,2,U2,21,O_A
)

Related topic
Other netlist formats



HiLo
HiLo netlists have the following characteristics:

Part names, module names, reference strings, and pin numbers are not checked for 
length.

Node names are limited to 14 characters.
Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Include unconnected pins
Part Value
PCB Footprint
View output

Related topics
HiLo netlist example
About netlist format, view, and design structure
Other netlist formats



HiLo netlist example
This netlist was created with no options selected. The contents specified by the PCB 
Footprint combined property string are shown in purple. HiLo netlists normally have a .NET 
file extension.
 

**                                               Revised: May 31, 
1995
** C:\RD\TEST\PUBS\MOST.DSN                      Revision: 
** OrCAD
** 9300 SW Nimbus Ave.
** Beaverton, OR 97008
** 
** 
CCT ORCAD (
** Please put your circuit interface definition here
          );
14DIP300
U1 (
     Q,
     CLOCK,
     N00037,
     B,
     N00037,
     Q,
     GND,
     N00039,
     A,
     A,
     ,
     ,
     ,
     VCC
     );

14DIP300
U2 (
     N00039,
     Q,
     OUT,
     ,
     ,
     ,
     GND,
     ,
     ,
     ,
     ,
     ,
     ,
     VCC
     );

Related topic
Other netlist formats





Intel ADF
Intel ADF netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers are not used.
All ASCII characters are legal.

Dialog box options
Suppress comments
Include unconnected pins
Part Value
PCB Footprint
View output

Related topics
Intel ADF title block
Intel ADF pipe commands
Intel ADF netlist constraints
Intel ADF netlist example
About netlist format, view, and design structure
Other netlist formats



Intel ADF title block information
Title block information is placed in the first 10 lines of the netlist. The following table shows 
an example netlist header and the title block information from which the header was 
extracted. Header information in bold is text you enter in the schematic's title block.

Line Example Header Title Block Field
1 ADF Example Title of schematic page
1 May 15, 1995 Date
2 OrCAD-02 Document Number
2 A Revision Code
3 OrCAD Organization Name
4 9300 SW Nimbus Avenue 1st Address Line
6 Turbo = ON 3rd Address Line
7 5C031 4th Address Line

Title block information in Intel ADF netlists.

Related topic
Other netlist formats



Intel ADF pipe commands
You can place equations in your schematic to be included in the netlist. To place these 
equations on the schematic page, select the Text command from the Place menu (ALT, P, T).
Each equation must start with the pipe character (|). The first line must be: 

|EQUATIONS
This tells Capture that some Intel ADF equations need to be included in the netlist. The 
equations can contain any information you want to include in the netlist.

Related topic
Other netlist formats



Intel ADF netlist constraints
When you create an Intel ADF netlist, you must include the OrCAD-supplied ALTERA_P.OLB 
and ALTERA_M.OLB libraries in your design. You can use only the parts in these two libraries 
to create the schematic.
Inputs and outputs are handled differently in Capture and the Altera software. Capture 
defines inputs and outputs with hierarchical ports and an input/output library object. Altera 
defines inputs and outputs with a library object which is then tagged with the appropriate 
pin number. In the example schematic, the CLOCK signal is an input and the STROBE signal 
is an output.
Also, library objects with unused pins default to predefined levels in the Altera software. 
Because Capture does not default unconnected pins to any particular level, you must tie all 
unused pins to the appropriate level.

Related topic
Other netlist formats



Intel ADF netlist example
This netlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue. Intel ADF netlists normally have a .NET file 
extension.
 

                                              Revised: May 31, 1995
C:\RD\TEST\PUBS\ADF.DSN                       Revision: 
OrCAD
9300 SW Nimbus Ave.
Beaverton, OR 97008
TURBO = ON
5C031

OPTIONS:TURBO = ON
PART:5C031

INPUTS:
    ENABLE
    RESET
    COINDROP
    CUPFULL
    CLOCK

OUTPUTS:
    DROPCUP
    POURDRNK
    STROBE

NETWORK:
M=INP(COINDROP) % SYM 1 %
B=XOR(E,F) % SYM 2 %
C=NOT(D) % SYM 3 %
D=INP(CLOCK) % SYM 4 %
N=INP(CUPFULL) % SYM 5 %
L=NOT(N) % SYM 6 %
I=INP(RESET) % SYM 7 %
J=INP(ENABLE) % SYM 8 %
R=NOT(E) % SYM 9 %
K=NOT(F) % SYM 10 %
Q=AND(F,R) % SYM 11 %
H=AND(F,E) % SYM 12 %
G=AND(K,L,M) % SYM 13 %
P=AND(K,E,L) % SYM 14 %
O=OR(P,Q) % SYM 15 %
DROPCUP,F=RORF(G,D,H,I,J) % SYM 16 %
POURDRNK,E=RORF(O,D,H,I,J) % SYM 17 %
STROBE=CONF(A,VCC) % SYM 18 %
A=AND(B,C) % SYM 19 %

EQUATIONS:
G = (K & L & M);
H = (F & E);
O = (P # Q);
END$



Related topic
Other netlist formats



Intergraph
Intergraph netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers can have up to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
Intergraph netlist example
About netlist format, view, and design structure
Other netlist formats



Intergraph netlist example
The contents specified by the PCB Footprint combined property string are shown in purple. 
Intergraph netlists normally have a .NET file extension.
 

%PART
14DIP300        U1
14DIP300        U2
%NET
CLOCK                   U1-2
A                       U1-9 U1-10
Q                       U1-1 U1-6 U2-2
N00037                  U1-3 U1-5
N00039                  U2-1 U1-8
VCC                     U1-14 U2-14
GND                     U1-7 U2-7
B                       U1-4
OUT                     U2-3
$

Related topic
Other netlist formats



Layout
This format file produces .MNL files for use with OrCAD's Layout. See the MaxEDA Tutorial 
Manual or the OrCAD Layout for Windows User's Guide for details.
.MNL files are not ASCII text files.

Dialog box options
Run ECO to Layout
Part Value
PCB Footprint

Related topics
About netlist format, view, and design structure
Other netlist formats



Mentor
Mentor netlists have the following characteristics:

Part names, module names, and reference strings are limited to nineteen characters.
Node names and pin numbers are not checked for length.
Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
Mentor files
Mentor netlist example
Mentor component file example
About netlist format, view, and design structure
Other netlist formats



Mentor files
Capture creates two files: a netlist file and a component file. You must enter a component 
filename in the Destination 2 text box in the Create Netlist dialog box.



Mentor netlist example
Mentor netlists normally have a .NET file extension.
 

NET 'CLOCK' U1-2
NET 'A' U1-9 U1-10
NET 'Q' U1-1 U1-6 U2-2
NET 'N00037' U1-3 U1-5
NET 'N00039' U2-1 U1-8
NET 'VCC' U1-14 U2-14
NET 'GND' U1-7 U2-7
NET 'B' U1-4
NET 'OUT' U2-3

Related topic
Other netlist formats



Mentor component file example
The contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple.
 

# OrCAD Formatted Netlist for MENTOR Board Station V6
# Reference              Value Field         Module Field
U1                       PART 74LS00         14DIP300
U2                       PART 74LS32         14DIP300

Related topic
Other netlist formats



MultiWire
MultiWire netlists have the following characteristics:

Part names and module names are not checked for length.
Reference strings and pin numbers together are limited to thirty-two characters.
Node names are limited to sixteen characters.
Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
MultiWire netlist example
About netlist format, view, and design structure
Other netlist formats



MultiWire netlist example
MultiWire netlists normally have a .NET file extension.
 

CLOCK             U1                             2
A                 U1                             9
A                 U1                            10
Q                 U1                             1
Q                 U1                             6
Q                 U2                             2
N00037            U1                             3
N00037            U1                             5
N00039            U2                             1
N00039            U1                             8
VCC               U1                            14
VCC               U2                            14
GND               U1                             7
GND               U2                             7
B                 U1                             4
OUT               U2                             3
-1

Related topic
Other netlist formats



OHDL
OHDL netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
View output

Related topics
OHDL netlist constraints
OHDL netlist example
About netlist format, view, and design structure
Other netlist formats



OHDL netlist constraints
The OHDL netlist format uses the OrCAD-supplied PLDGATES.OLB and TTL.OLB libraries. Be 
sure you include one of these libraries in your design.

Related topic
Other netlist formats



OHDL netlist example
OHDL netlists normally have a .PLD file extension.
 

|| CNTMUX (Example for MACH 110)                 Revised: August 28, 1995
|| C:\ORCADWIN\CAPTURE\DESIGN\DESIGN2.DSN        Revision: 
|| OrCAD
|| 
|| 
|| 
|| 
|| 
| Type: "IFX780_132"
|
|
|  Netlist:
|  {
|   PAD (I10,"IN")  | PAD1
|   PAD (I8,"IN")  | PAD10
|   PAD (I9,"IN")  | PAD11
|   PAD (I11,"IN")  | PAD12
|   PAD (I12,"IN")  | PAD13
|   PAD (I13,"IN")  | PAD14
|   PAD (I14,"IN")  | PAD15
|   PAD (I15,"IN")  | PAD16
|   PAD (LOAD,"IN")  | PAD17
|   PAD (CLK,"IN")  | PAD18
|   PAD (UP,"IN")  | PAD19
|   PAD (I0,"IN")  | PAD2
|   PAD (COUNT,"IN")  | PAD20
|   PAD (SELECT,"IN")  | PAD21
|   PAD (I1,"IN")  | PAD3
|   PAD (O0,"OUT")  | PAD38
|   PAD (O1,"OUT")  | PAD39
|   PAD (I2,"IN")  | PAD4
|   PAD (O2,"OUT")  | PAD40
|   PAD (O3,"OUT")  | PAD41
|   PAD (O4,"OUT")  | PAD42
|   PAD (O5,"OUT")  | PAD43
|   PAD (O6,"OUT")  | PAD44
|   PAD (O7,"OUT")  | PAD45
|   PAD (O8,"OUT")  | PAD46
|   PAD (O9,"OUT")  | PAD47
|   PAD (O10,"OUT")  | PAD48
|   PAD (O11,"OUT")  | PAD49
|   PAD (I3,"IN")  | PAD5
|   PAD (O12,"OUT")  | PAD50
|   PAD (O13,"OUT")  | PAD51
|   PAD (O14,"OUT")  | PAD52
|   PAD (O15,"OUT")  | PAD53
|   PAD (I4,"IN")  | PAD6
|   PAD (I5,"IN")  | PAD7
|   PAD (I6,"IN")  | PAD8
|   PAD (I7,"IN")  | PAD9
|   G169 (UP,CLK,I0,I1,I2,I3,GND,-,N00283,N00272,Q3,Q2,Q1,Q0,N00292)  | U1



|   G04 (LOAD,N00283)  | U10
|   G169 (UP,CLK,I4,I5,I6,I7,GND,-,N00283,N00292,Q7,Q6,Q5,Q4,-)  | U2
|   G169 (UP,CLK,I8,I9,I10,I11,GND,-,N00283,N00272,Q11,Q10,Q9,Q8,N00327)  | U3
|   G169 (UP,CLK,I12,I13,I14,I15,GND,-,N00283,N00327,Q15,Q14,Q13,Q12,-)  | U4
|   G257 (SELECT,Q0,I0,O0,Q1,I1,O1,-,O2,I2,Q2,O3,I3,Q3,GND)  | U5
|   G257 (SELECT,Q4,I4,O4,Q5,I5,O5,-,O6,I6,Q6,O7,I7,Q7,GND)  | U6
|   G257 (SELECT,Q8,I8,O8,Q9,I9,O9,-,O10,I10,Q10,O11,I11,Q11,GND)  | U7
|   G257 (SELECT,Q12,I12,O12,Q13,I13,O13,-,O14,I14,Q14,O15,I15,Q15,GND)  | U8
|   G04 (COUNT,N00272)  | U9
|  }
|
|Vectors:
|{ Display COUNT, LOAD, SELECT, CLK, \
|           (I[15..8])d, (O[15..8])d, \
|           (I[7..0])d,   (O[7..0])d
|
| Test LOAD=1; CLK
| Test LOAD=0; COUNT=1; UP=1; CLK=25(0,1)
| Set  I[15..8] = 10
| Set  I[7..0]  = 11
| Test SELECT=1,0
| Test LOAD=0; COUNT=1; UP=0; CLK=25(0,1)
| Test SELECT=1,0
| End }

Related topic
Other netlist formats



PADS 2000
PADS 2000 netlists have the following characteristics:

Part names, module names, and pin numbers are not checked for length.
Reference strings are limited to six characters.
Node names are limited to forty-seven characters.
Legal characters for reference strings and node names are limited to:

~   !   #   $   %   _   -   =   
+   |   /   .   :   ;   <   >   
A..Z   a..z   0..9

Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal except as noted for reference strings and node names.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
PADS 2000 netlist example
About netlist format, view, and design structure
Other netlist formats



PADS 2000 netlist example
The contents specified by the PCB Footprint combined property string are shown in purple. 
PADS 2000 netlists normally have a .NET file extension.
 

*PADS2000*
*PART*
U1     14DIP300
U2     14DIP300

*NET*
*SIGNAL* CLOCK
U1.2
*SIGNAL* A
U1.9 U1.10
*SIGNAL* Q
U1.1 U1.6 U2.2
*SIGNAL* N00037
U1.3 U1.5
*SIGNAL* N00039
U2.1 U1.8
*SIGNAL* VCC
U1.14 U2.14
*SIGNAL* GND
U1.7 U2.7
*SIGNAL* B
U1.4
*SIGNAL* OUT
U2.3
*END*

Related topic
Other netlist formats



PADS-PCB
PADS-PCB netlists have the following characteristics:

Part names, module names, and pin numbers are not checked for length.
Reference strings are limited to six characters.
Node names are limited to twelve characters.
Legal characters for reference strings and node names are limited to:
~   !   #   $   %   _   -   =   

+   |   /   .   :   ;   <   >   
A..Z   a..z   0..9

Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal except as noted for reference strings and node names.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
PADS-PCB netlist example
About netlist format, view, and design structure
Other netlist formats



PADS-PCB netlist example
The contents specified by the PCB Footprint combined property string are shown in purple. 
PADS-PCB netlists normally have a .NET file extension.
 

*PADS-PCB*
*PART*
U1     14DIP300
U2     14DIP300

*NET*
*SIGNAL* CLOCK
U1.2
*SIGNAL* A
U1.9 U1.10
*SIGNAL* Q
U1.1 U1.6 U2.2
*SIGNAL* N00037
U1.3 U1.5
*SIGNAL* N00039
U2.1 U1.8
*SIGNAL* VCC
U1.14 U2.14
*SIGNAL* GND
U1.7 U2.7
*SIGNAL* B
U1.4
*SIGNAL* OUT
U2.3
*END*

Related topics
Other netlist formats



PCAD
PCAD netlists have the following characteristics:

Part names, module names, reference strings, and pin numbers are not checked for 
length.

Node names are limited to eight characters.
Node numbers are limited to five digits following the "NET" prefix.
Pin names are not used.
Characters are not checked for legality.

Dialog box options
Include unconnected pins
Part Value
PCB Footprint
View output

Related topics
PCAD netlist example
About netlist format, view, and design structure
Other netlist formats



PCAD netlist example
This netlist was created with no options selected. The contents specified by the PCB 
Footprint combined property string are shown in purple. PCAD netlists normally have a .NET 
file extension.
 

{COMPONENT ORCAD.PCB
 {ENVIRONMENT LAYS.PCB}
  {PDIFvrev 1.30}
  {DETAIL
   {SUBCOMP
{I 14DIP300.PRT U1
{CN
    1 Q
    2 CLOCK
    3 N00037
    4 B
    5 N00037
    6 Q
    7 GND
    8 N00039
    9 A
   10 A
   11 UN00001
   12 UN00002
   13 UN00003
   14 VCC
}
}
{I 14DIP300.PRT U2
{CN
    1 N00039
    2 Q
    3 OUT
    4 UN00004
    5 UN00005
    6 UN00006
    7 GND
    8 UN00007
    9 UN00008
   10 UN00009
   11 UN00010
   12 UN00011
   13 UN00012
   14 VCC
}
}
}
}
}

Related topic
Other netlist formats



PCADnlt
PCADnlt netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Legal characters for node names are limited to:
$   -   +   _ (underscore)
A..Z   a..z   0..9   

Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal except as noted for node names.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
PCADnlt netlist example
About netlist format, view, and design structure
Other netlist formats



PCADnlt netlist example
The contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple. PCADnlt 
netlists normally have a .NET file extension.
 

%                                               Revised: May 31, 
1995
% C:\RD\TEST\PUBS\MOST.DSN                      Revision: 
% OrCAD
% 9300 SW Nimbus Ave.
% Beaverton, OR 97008
% 
% 
BOARD = ORCAD.PCB;

PARTS
14DIP300        = U1,   % 74LS00
                  U2;   % 74LS32

NETS

B         = U1/4 ;
OUT       = U2/3 ;
N00039    = U2/1 U1/8 ;
VCC       = U1/14 U2/14 ;
GND       = U1/7 U2/7 ;
CLOCK     = U1/2 ;
A         = U1/9 U1/10 ;
Q         = U1/1 U1/6 U2/2 ;
N00037    = U1/3 U1/5 ;

Related topic
Other netlist formats



PCB
PCB netlists are used with OrCAD's PC Board Layout Tools 386+. See the PC Board Layout 
Tools 386+ User's Guide for details.
PCB netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers are limited to five digits following the "N" prefix.
All ASCII characters are legal.
PCB footprint names are limited to eight characters.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
PCB netlist example
About netlist format, view, and design structure
Other netlist formats



The PCB tab netlist formatter and the PCBII netlist formatter on the Other tab are identical.

The PCBII.DLL and PCBIIL.DLL netlist formatter are identical with the following exception: 
the PCBIIL.DLL netlist formatter has no restrictions on net name length.



PCB netlist example
The contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple. PCB netlists 
normally have a .NET file extension.
 

(edif &MOST
 (edifVersion 2 0 0)
 (edifLevel 0)
 (keywordMap (keywordLevel 0))
 (status
  (written
   (timeStamp 0 0 0 0 0 0)
   (program "EDIF.DLL")
   (comment "Original data from OrCAD CAPTURE schematic"))
  (comment "")
  (comment "May 31, 1995")
  (comment "C:\RD\TEST\PUBS\MOST.DSN")
  (comment "")
  (comment "OrCAD")
  (comment "9300 SW Nimbus Ave.")
  (comment "Beaverton, OR 97008")
  (comment "")
  (comment ""))
 (external OrCAD_LIB
  (edifLevel 0)
  (technology
   (numberDefinition
    (scale 1 1 (unit distance))))
  (cell &74LS00
   (cellType generic)
   (comment "From OrCAD library TTL.LIB")
   (view NetlistView
    (viewType netlist)
    (interface
     (port &1 (direction INPUT))
     (port &2 (direction INPUT))
     (port &3 (direction OUTPUT))
     (port &4 (direction INPUT))
     (port &5 (direction INPUT))
     (port &6 (direction OUTPUT))
     (port &7 (direction INPUT))
     (port &8 (direction OUTPUT))
     (port &9 (direction INPUT))
     (port &10 (direction INPUT))
     (port &11 (direction INPUT))
     (port &12 (direction INPUT))
     (port &13 (direction INPUT))
     (port &14 (direction INPUT)))))
  (cell &74LS32
   (cellType generic)
   (comment "From OrCAD library TTL.LIB")
   (view NetlistView
    (viewType netlist)
    (interface



     (port &1 (direction INPUT))
     (port &2 (direction INPUT))
     (port &3 (direction OUTPUT))
     (port &4 (direction INPUT))
     (port &5 (direction INPUT))
     (port &6 (direction INPUT))
     (port &7 (direction INPUT))
     (port &8 (direction INPUT))
     (port &9 (direction INPUT))
     (port &10 (direction INPUT))
     (port &11 (direction INPUT))
     (port &12 (direction INPUT))
     (port &13 (direction INPUT))
     (port &14 (direction INPUT))))))
 (library MAIN_LIB
  (edifLevel 0)
  (technology
   (numberDefinition
    (scale 1 1 (unit distance))))
  (cell &MOST
   (cellType generic)
   (view NetlistView
    (viewType netlist)
    (interface
     (port &B (direction INPUT))
     (port &OUT (direction OUTPUT))
     (port &CLOCK (direction INPUT))
     (port &A (direction INPUT)))
    (contents
     (instance &U1
      (viewRef NetlistView
       (cellRef &74LS00
        (libraryRef OrCAD_LIB)))
      (property PartValue (string "74LS00"))
      (property ModuleValue (string "14DIP300"))
      (property TimeStampValue (string "6CB84CBA"))
      (property Field1Value (string "14DIP300"))
      (property Field2Value (string ""))
      (property Field3Value (string ""))
      (property Field4Value (string ""))
      (property Field5Value (string ""))
      (property Field6Value (string ""))
      (property Field7Value (string ""))
      (property Field8Value (string "")))
     (instance &U2
      (viewRef NetlistView
       (cellRef &74LS32
        (libraryRef OrCAD_LIB)))
      (property PartValue (string "74LS32"))
      (property ModuleValue (string "14DIP300"))
      (property TimeStampValue (string "6E46169D"))
      (property Field1Value (string "14DIP300"))
      (property Field2Value (string ""))
      (property Field3Value (string ""))
      (property Field4Value (string ""))
      (property Field5Value (string ""))



      (property Field6Value (string ""))
      (property Field7Value (string ""))
      (property Field8Value (string "")))
     (net &B
      (joined
       (portRef &B)
       (portRef &4 (instanceRef &U1))))
     (net &OUT
      (joined
       (portRef &OUT)
       (portRef &3 (instanceRef &U2))))
     (net &N00039
      (joined
       (portRef &1 (instanceRef &U2))
       (portRef &8 (instanceRef &U1))))
     (net &VCC
      (joined
       (portRef &14 (instanceRef &U1))
       (portRef &14 (instanceRef &U2))))
     (net &GND
      (joined
       (portRef &7 (instanceRef &U1))
       (portRef &7 (instanceRef &U2))))
     (net &CLOCK
      (joined
       (portRef &CLOCK)
       (portRef &2 (instanceRef &U1))))
     (net &A
      (joined
       (portRef &A)
       (portRef &9 (instanceRef &U1))
       (portRef &10 (instanceRef &U1))))
     (net &Q
      (joined
       (portRef &1 (instanceRef &U1))
       (portRef &6 (instanceRef &U1))
       (portRef &2 (instanceRef &U2))))
     (net &N00037
      (joined
       (portRef &3 (instanceRef &U1))
       (portRef &5 (instanceRef &U1))))))))
 (design &MOST
  (cellRef &MOST
   (libraryRef MAIN_LIB))))

PDUMP
This format produces a parts list containing all the information on the schematic pages. No 
information is omitted or changed. You can use this netlist format when troubleshooting a 
design.

Dialog box options
Part Value
PCB Footprint



View output

Related topics
About netlist format, view, and design structure
Other netlist formats



PLD
This file produces netlists that define logic for use with Programmable Logic Design 
Tools 386+. See the Programmable Logic Design Tools User's Guide and the Programmable 
Logic Design Tools Reference Guide for details.
PLD netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Pin names are not used.
All ASCII characters are legal.

Dialog box options
Create a complete PLD source file
Only use 'pins' and 'nodes' keywords (do not use 'in', 'out', and 'i/o')
Part Value
PCB Footprint
View output

Related topics
PLD netlist constraints
PLD netlist example
About netlist format, view, and design structure
Other netlist formats



PLD netlist constraints
When you create a PLD netlist, be sure to include the OrCAD-supplied PLDGATES.OLB library 
in your design. You can use only the parts in PLDGATES.OLB, DEVICE.OLB (VCC, POWER, GND), 
and TTL.OLB (most 74LSxx) in a schematic to be netlisted for PLD.

Related topic
Other netlist formats



PLD netlist example
This netlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue. PLD netlists normally have a .NET file extension.
 

||                                               Revised: May 31, 
1995
|| C:\RD\TEST\PUBS\PLDNET.DSN                    Revision: 
|| OrCAD
|| 9300 SW Nimbus Ave.
|| Beaverton, OR 97008
|| 
|| 
|| 
| Netlist:  B1,A0,A1,B0
|           -> 
|           Y2,Y3,Y0,Y1
|  {
|   G04 (A0,N00158)  | U1
|   G11 (B1,N00076,-,-,-,-,-,-,-,-,-,N00078,A0)  | U10
|   G11 (N00088,B0,-,-,-,-,-,-,-,-,-,N00180,A1)  | U11
|   G11 (B1,A1,-,-,-,-,-,-,-,-,-,N00174,N00112)  | U12
|   G11 (B1,N00126,-,-,-,-,-,-,-,-,-,N00176,A1)  | U13
|   G21 (A0,A1,-,B0,B1,Y3)  | U14
|   G32 (N00174,N00176,Y2)  | U15
|   G32 (N00078,N00180,N00184)  | U16
|   G32 (N00178,N00058,N00182)  | U17
|   G32 (N00182,N00184,Y1)  | U18
|   G04 (A1,N00056)  | U2
|   G04 (B0,N00076)  | U3
|   G04 (B1,N00088)  | U4
|   G04 (A0,N00112)  | U5
|   G04 (B0,N00126)  | U6
|   G08 (B0,A0,Y0)  | U7
|   G11 (N00158,B0,-,-,-,-,-,-,-,-,-,N00178,A1)  | U8
|   G11 (B1,N00056,-,-,-,-,-,-,-,-,-,N00058,A0)  | U9
|  }

Related topic
Other netlist formats



RacalRedac
RacalRedac netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
RacalRedac files
RacalRedac netlist example
RacalRedac component file example
About netlist format, view, and design structure
Other netlist formats



RacalRedac files
In addition to the netlist file, Capture also creates a component file when you select the 
RacalRedac format. You must enter a second filename in the Destination 2 text box on the 
Netlist Format dialog box.

Related topic
Other netlist formats



RacalRedac netlist example
RacalRedac netlists normally have a .NET file extension.
 

.PCB

.REM Generic Netlist Example                Revised: August 28, 1995

.REM OrCAD-01                               Revision: A

.REM OrCAD

.REM 9300 SW Nimbus Ave.

.REM Beaverton, OR  97008

.REM (503) 671-9500 Sales & Administration

.REM (503) 671-9400 Technical Support

.CON

.COD 2

.REM N00026
U1 3 U1 5 
.REM CLOCK
U1 2 
.REM OUT
U2 3 
.REM B
U1 4 
.REM N00030
U2 1 U1 8 
.REM A
U1 9 U1 10 
.REM Q
U1 1 U1 6 U2 2 
.REM VCC
U1 14 U2 14 
.REM GND
U1 7 U2 7 
.EOD

Related topic
Other netlist formats



RacalRedac component file example
The contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple.
 

.PCB

.REM Generic Netlist Example    Revised:   June 19, 1994

.REM OrCAD-01                   Revision: A

.REM OrCAD

.REM 9300 SW Nimbus Avenue

.REM Beaverton, OR 97008-7137

.REM (503) 671-9500 Sales & Administration

.REM (503) 671-9400 Technical Support

.COM

.REF

.REM 74LS00
U1   14DIP300
.REM 74LS32
U2   14DIP300
.EOD

Related topic
Other netlist formats



Scicards
Scicards netlists have the following characteristics:

Part names are limited to seventeen characters.
Module names are limited to fifteen characters.
Reference strings and pin numbers combined are limited to twelve characters.
Pin numbers are limited to three characters.
Node names are limited to eight characters.
Node numbers are not checked for length.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
Scicards netlist example
About netlist format, view, and design structure
Other netlist formats



Scicards netlist example
The contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple. Scicards 
netlists normally have a .NET file extension.
 

PARTS LIST

74LS00            14DIP300        U1
74LS32            14DIP300        U2
EOS
NET LIST

NODENAME B                $
    U1         4
NODENAME OUT              $
    U2         3
NODENAME N00039           $
    U2         1  U1         8
NODENAME VCC              $
    U1        14  U2        14
NODENAME GND              $
    U1         7  U2         7
NODENAME CLOCK            $
    U1         2
NODENAME A                $
    U1         9  U1        10
NODENAME Q                $
    U1         1  U1         6  U2         2
NODENAME N00037           $
    U1         3  U1         5
EOS

Related topic
Other netlist formats



SPICE
SPICE netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers are limited to five characters
If the Use net names option is selected, legal characters for node names are limited 

to:
0..9   A..Z   a..z   $   _ (underscore)

All ASCII characters are legal except as noted for node names.

The SPICE formats

Capture provides two SPICE netlist formats. The first format produces either hierarchical or 
flat netlist output, depending on your design structure and the active view. It is accessible 
from the SPICE tab on the Create Netlist dialog box. The second format produces only flat 
netlists, and is accessible through the Other tab on the Create Netlist dialog box.
Use the SPICE tab if:

You want to include net, part, and pin properties.
You want a hierarchical netlist.

Use the Other tab if:
You want a flat netlist of a simple hierarchical design.

Hierarchical designs in SPICE

For hierarchical designs, the SPICE format produces netlists with subcircuit (.SUBCKT) 
definitions for schematic pages in the hierarchy. These subcircuits are called by the X 
command (subcircuit call). Since SPICE does not require the subcircuits to be defined before 
use, the hierarchy appears in normal form in the netlist with the root page at the top of the 
file.

Dialog box options
Include unconnected pins
Use net names
Part Value
PCB Footprint
View output

Related topics
SPICE files
SPICE pipe commands
SPICE netlist constraints
Flat SPICE netlist example
Logical view hierarchical SPICE netlist example
Physical view hierarchical SPICE netlist example
Flat SPICE map file example
Logical view hierarchical SPICE map file example
Physical view hierarchical SPICE map file example
About netlist format, view, and design structure
Other netlist formats



SPICE files
In addition to the netlist file, Capture also creates a map file when you select the SPICE 
format. The node numbers created by Capture are placed in the .MAP file so you can cross-
reference the SPICE node numbers with the node names that you specified on your 
schematic. You must enter the map filename in the Map File text box on the Create Netlist 
dialog box.

Related topic
Other netlist formats



If you select the Use net names option, the map file may contain erroneous results.



SPICE pipe commands
You can place lines of text in your schematic, to be included in the SPICE netlist. Select the 
Text command on the Place menu (ALT, P, T) to place the text in your schematic.
Each line of text must start with the pipe character (|). The first line must be:

|SPICE
This tells Capture to extract the information in the following lines of text when generating a 
SPICE netlist. The remaining lines can contain any information you want to include in the 
netlist. The lines following |SPICE are placed at the top of the netlist.

Related topic
Text command
Other netlist formats



SPICE netlist constraints
Capture can create netlists larger than most PC-based SPICE programs accept. Consult your 
SPICE manual for the limits. If your PC meets SPICE's memory requirements, you can 
generate the largest netlist allowed.
The part value is used to pass modeling information to the netlist. For instance, resistor RS1 
in the example flat schematic has a value of 1K Ohms; in the example hierarchical 
schematic R1 has a value of 6.8K Ohms.
Use the special PSPICE.OLB or SPICE.OLB libraries supplied by OrCAD when generating a 
SPICE netlist. These libraries already have pin numbers on the parts and are compatible with
most versions of SPICE. The PSPICE.OLB contains many specific part types, such as a 
2N2222 NPN transistor, that are not provided in the generic SPICE.OLB.
All library part pin names should be changed to reflect the model node index. To find out the 
proper node ordering, see your SPICE manual.
As an example of what to change, the OrCAD-supplied NPN transistor has the pin names 
defined as base, emitter, and collector in the DEVICE.OLB library. For SPICE to understand 
the nodal information, the pin names must be changed from base, emitter, and collector to 
2, 3, and 1 (as defined in the SPICE manual). Therefore, the library source file for an NPN 
transistor that is compatible with the SPICE pin numbering convention is as follows:

'NPN'
REFERENCE  'Q'
{X Size =} 2  {Y Size =} 2 {Parts per Package =} 0
L1   SHORT   IN    '2'
B2   SHORT   IN    '3'
T2   SHORT   IN    '1'
{  0}..##.#
{  1}        ##         # 
       .
       .
       .
Library source file for the NPN transistor.

Related topic
Other netlist formats



Flat SPICE netlist example
This netlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue. SPICE netlists normally have a .NET file 
extension.
 

*                                               Revised: May 31, 
1995
* C:\RD\TEST\PUBS\EX4.DSN                       Revision: 
* OrCAD
* 9300 SW Nimbus Ave.
* Beaverton, OR 97008
* 
* 
.OPTIONS ACCT LIST NODE OPTS NOPAGE RELTOL=.001
.WIDTH OUT=80
.DC VIN -0.25 0.25 0.005
.AC DEC 10 1 10GHZ
.TRAN/OP 5NS 500NS
.MODEL QNL NPN (BF=80 RB=100 CJS=2PF
+     TF=0.3NS TR=6NS VAF=50)
.PRINT DC V(4) V(5)
.PLOT DC IC(Q2)
.PROBE
VCC 10004 0 DC 12
VEE 10005 0 DC -12
VIN 10006 0 AC 1 SIN(0 0.1 5MEG)
CLOAD1 10008 10010 5PF
Q1 10009 10007 10005 QNL
Q2 10008 10002 10009 QNL
Q3 10010 10003 10009 QNL
Q4 10007 10007 10005 QNL
RBIAS1 10004 10007 20K
RC1 10004 10008 10K
RC2 10004 10010 10K
RS1 10003 0 1K
RS2 10006 10002 1K
.END

Related topic
Other netlist formats



Hierarchical SPICE netlist example (logical view)
This netlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue. SPICE netlists normally have a .NET file 
extension.
 

*                                               Revised: Thursday, June 01, 1995
* C:\SHARED\DESIGNS\SPICEL.DSN                  Revision: 
* OrCAD
* 9300 SW Nimbus Ave.
* Beaverton, OR  97008
* (503) 671-9500 Sales & Administration
* (503) 671-9400 Technical Support
|SPICE
|.OPTIONS ACCT NODE OPTS NOPAGE
|.MODEL DMOD D (VJ=0.6)
|.MODEL QMOD NPN (BF=80 RB=100 TR=6NS TF=0.3NS)
|.DC LIN Vinput -5 20 0.25
|.PLOT DC I(R7)
|Comparator1
|+ 200k 300K 200uf
|+ more params
|EX7B
|+ params
|Comparator2
|+ more params
|+ gobs of params
VINPUT 9 0 DC 1V
VCC 2 0 DC 15V
R1 6 5 6.8K
R2 2 6 47K
R3 0 5 47K
R4 9 8 100K
R5 9 7 100K
R6 2 3 3.9K
R7 2 1 670
Q1 3 0 1 QMOD
XComparator1 3 4 8 6 2 COMPARATOR
XComparator2 3 4 7 5 2 COMPARATOR
.SUBCKT COMPARATOR 109 104 105 108 110
D6 103 108 DMOD
D7 103 110 DMOD
D8 102 110 DMOD
D9 102 105 DMOD
Q10 106 104 110 QMOD
Q11 110 104 109 QMOD
Q12 107 104 106 QMOD
Q13 110 110 107 QMOD
Q14 107 104 107 QMOD
Q15 110 110 106 QMOD
Q16 108 104 110 QMOD
Q17 105 104 110 QMOD
.ENDS
.SUBCKT COMPARATOR 55 50 51 54 56
D6 49 54 DMOD



D7 49 56 DMOD
D8 48 56 DMOD
D9 48 51 DMOD
Q10 52 50 56 QMOD
Q11 56 50 55 QMOD
Q12 53 50 52 QMOD
Q13 56 56 53 QMOD
Q14 53 50 53 QMOD
Q15 56 56 52 QMOD
Q16 54 50 56 QMOD
Q17 51 50 56 QMOD
.ENDS
.END

Related topic
Other netlist formats



Hierarchical SPICE netlist example (physical view)
This netlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue. SPICE netlists normally have a .NET file 
extension.
 

*                                               Revised: Thursday, June 01, 1995
* C:\SHARED\DESIGNS\SPICEP.DSN                  Revision: 
* OrCAD
* 9300 SW Nimbus Ave.
* Beaverton, OR  97008
* (503) 671-9500 Sales & Administration
* (503) 671-9400 Technical Support
|SPICE
|.OPTIONS ACCT NODE OPTS NOPAGE
|.MODEL DMOD D (VJ=0.6)
|.MODEL QMOD NPN (BF=80 RB=100 TR=6NS TF=0.3NS)
|.DC LIN Vinput -5 20 0.25
|.PLOT DC I(R7)
|Comparator1
|+ 200k 300K 200uf
|+ more params
|EX7B
|EX7B
|+ params
|+ params
|Comparator2
|+ more params
|+ more params
|+ gobs of params
VCC 2 0 DC 15V
VINPUT 9 0 DC 1V
R1 2 6 47K
R2 2 3 3.9K
R3 2 1 670
R4 9 8 100K
R5 6 5 6.8K
R6 9 7 100K
R7 0 5 47K
Q1 3 0 1 QMOD
XComparator1 3 4 8 6 2 COMPARATOR
XComparator2 3 4 7 5 2 COMPARATOR
.SUBCKT COMPARATOR 84 79 80 83 85
D5 78 83 DMOD
D6 78 85 DMOD
D7 77 85 DMOD
D8 77 80 DMOD
Q10 85 85 82 QMOD
Q11 85 85 81 QMOD
Q12 85 79 84 QMOD
Q13 83 79 85 QMOD
Q14 80 79 85 QMOD
Q15 81 79 85 QMOD
Q16 82 79 82 QMOD
Q17 82 79 81 QMOD



.ENDS

.SUBCKT COMPARATOR 24 19 20 23 25
Q6 20 19 25 QMOD
Q7 21 19 25 QMOD
Q8 22 19 22 QMOD
Q9 22 19 21 QMOD
D1 18 23 DMOD
D2 18 25 DMOD
D3 17 25 DMOD
D4 17 20 DMOD
Q2 25 25 22 QMOD
Q3 25 25 21 QMOD
Q4 25 19 24 QMOD
Q5 23 19 25 QMOD
.ENDS
.END

Related topic
Other netlist formats



Flat SPICE map file example
This map file was created with no options selected.
 

    0 GND
10002 N00020
10003 N00027
10004 VCC DC 12
10005 VEE DC -12
10006 VIN AC 1 SIN(0 0.1 5MEG)
10007 7
10008 4
10009 6
10010 5

Related topic
Other netlist formats



Hierarchical SPICE map file example (logical view)
This map file was created with no options selected.
 

6 VUPPER
7 N00060
8 N00050
9 VINPUT
1 N00096
2 VCC
3 N00092
0 GND
5 VLOWER
102 N00010
103 N00007
104 VMINUS
105 VINMINUS
106 N00058
107 N00056
108 VINPLUS
109 VOUT
110 VPLUS
48 N00010
49 N00007
50 VMINUS
51 VINMINUS
52 N00058
53 N00056
54 VINPLUS
55 VOUT
56 VPLUS

Related topic
Other netlist formats



Hierarchical SPICE map file example (physical view)
This map file was created with no options selected.
 

1 N00096
2 VCC
3 N00092
0 GND
5 VLOWER
6 VUPPER
7 N00060
8 N00050
9 VINPUT
77 N00010
78 N00007
79 VMINUS
80 VINMINUS
81 N00058
82 N00056
83 VINPLUS
84 VOUT
85 VPLUS
17 N00010
18 N00007
19 VMINUS
20 VINMINUS
21 N00058
22 N00056
23 VINPLUS
24 VOUT
25 VPLUS

Related topic
Other netlist formats



Tango
Tango netlists have the following characteristics:

Part names, module names, reference strings, and node names are limited to sixteen 
characters.

Node numbers are limited to five digits following the "N" prefix.
Pin numbers are not checked for length.
Pin names are not used.
Reference strings and module names must be uppercase characters.
All ASCII characters are legal except:

(   )   [   ]   - (dash)   , (comma)
and as noted for reference strings and module names.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
Tango netlist example
About netlist format, view, and design structure
Other netlist formats



Tango netlist example
The contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple. Tango netlists 
normally have a .NET file extension.
 

                                              Revised: May 31, 1995
C:\RD\TEST\PUBS\MOST.DSN                      Revision: 
OrCAD
9300 SW Nimbus Ave.
Beaverton, OR 97008

[
U1
14DIP300
74LS00

]
[
U2
14DIP300
74LS32

]
(
B
U1,4
)
(
OUT
U2,3
)
(
N00039
U2,1
U1,8
)
(
VCC
U1,14
U2,14
)
(
GND
U1,7
U2,7
)
(
CLOCK



U1,2
)
(
A
U1,9
U1,10
)
(
Q
U1,1
U1,6
U2,2
)
(
N00037
U1,3
U1,5
)

Related topic
Other netlist formats



Telesis
Telesis netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
Telesis netlist example
About netlist format, view, and design structure
Other netlist formats



Telesis netlist example
The contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple. Telesis netlists 
normally have a .NET file extension.
 

$PACKAGES
14DIP300! 74LS00; U1
14DIP300! 74LS32; U2
$NETS
B;  U1.4
OUT;  U2.3
N00039;  U2.1 U1.8
VCC;  U1.14 U2.14
GND;  U1.7 U2.7
CLOCK;  U1.2
A;  U1.9 U1.10
Q;  U1.1 U1.6 U2.2
N00037;  U1.3 U1.5
$END

Related topic
Other netlist formats



Vectron
Vectron netlists have the following characteristics:

Part names, module names, and pin numbers are not checked for length.
Reference strings are limited to eight characters.
Node names are limited to twelve characters.
Node numbers are limited to five digits following the "N" prefix.
Pin names are not used.
All ASCII characters are legal.

Dialog box options
Part Value
PCB Footprint
View output

Related topics
Vectron files
Vectron netlist example
Vectron part list example
About netlist format, view, and design structure
Other netlist formats



Vectron files
In addition to the netlist file, Capture also creates a part list file when you select the Vectron 
netlist format. You must enter a second filename in the Destination 2 text box on the Netlist 
Format dialog box.

Related topic
Other netlist formats



Vectron netlist example
Vectron netlists normally have a .NET file extension.
 

*B            U1 4
*OUT          U2 3
*N00039       U2 1 U1 8
*VCC          U1 14 U2 14
*GND          U1 7 U2 7
*CLOCK        U1 2
*A            U1 9 U1 10
*Q            U1 1 U1 6 U2 2
*N00037       U1 3 U1 5

Related topic
Other netlist formats



Vectron part list example
The contents specified by the PCB Footprint combined property string are shown in purple.
 

U1       14DIP300
U2       14DIP300

Related topic
Other netlist formats



Verilog
Verilog netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Part names, module names, reference strings, node names, and pin numbers must 
begin with a letter.

Legal characters for part names, module names, reference strings, node names, and 
pin numbers are limited to:

A..Z   a..z   0..9   

Dialog box options
Part Value
View output

Related topics
Verilog netlist constraints
Logical view hierarchical Verilog netlist example
Physical view hierarchical Verilog netlist example
About netlist format, view, and design structure
Other netlist formats



Verilog netlist constraints

Parts, modules, part references, nodes, pins, and nets may not be named the same to avoid 
a conflict with any Verilog reserved word. See the Verilog specification for a list of reserved 
words.

Related topic
Other netlist formats



Hierarchical Verilog netlist example (logical view)
The contents specified by the Part Value combined property string are shown in blue. Verilog 
netlists normally have a .V file extension.
 

module COMPARATORComparator1( Vout, VMinus, VinMinus, VinPlus, 
VPlus);

output Vout;
input VMinus;
input VinMinus;
input VinPlus;
input VPlus;

//    SIGNALS

wire N00010;
wire N00007;
wire N00058;
wire N00056;

// GATE INSTANCES

DIODE D6( 
.1( N00007 ) , 
.2( VINPLUS ) 

 ) ;
DIODE D7( 

.1( N00007 ) , 

.2( VPLUS ) 
 ) ;
DIODE D8( 

.1( N00010 ) , 

.2( VPLUS ) 
 ) ;
DIODE D9( 

.1( N00010 ) , 

.2( VINMINUS ) 
 ) ;
NPN Q10( 

.2( N00058 ) , 

.3( VMINUS ) , 

.1( VPLUS ) 
 ) ;
NPN Q11( 

.2( VPLUS ) , 

.3( VMINUS ) , 

.1( VOUT ) 
 ) ;
NPN Q12( 

.2( N00056 ) , 

.3( VMINUS ) , 

.1( N00058 ) 



 ) ;
PNP Q13( 

.2( VPLUS ) , 

.3( VPLUS ) , 

.1( N00056 ) 
 ) ;
NPN Q14( 

.2( N00056 ) , 

.3( VMINUS ) , 

.1( N00056 ) 
 ) ;
PNP Q15( 

.2( VPLUS ) , 

.3( VPLUS ) , 

.1( N00058 ) 
 ) ;
NPN Q16( 

.2( VINPLUS ) , 

.3( VMINUS ) , 

.1( VPLUS ) 
 ) ;
NPN Q17( 

.2( VINMINUS ) , 

.3( VMINUS ) , 

.1( VPLUS ) 
 ) ;
endmodule

module COMPARATORComparator2( Vout, VMinus, VinMinus, VinPlus, 
VPlus);

output Vout;
input VMinus;
input VinMinus;
input VinPlus;
input VPlus;

//    SIGNALS

wire N00010;
wire N00007;
wire N00058;
wire N00056;

// GATE INSTANCES

DIODE D6( 
.1( N00007 ) , 
.2( VINPLUS ) 

 ) ;
DIODE D7( 

.1( N00007 ) , 

.2( VPLUS ) 



 ) ;
DIODE D8( 

.1( N00010 ) , 

.2( VPLUS ) 
 ) ;
DIODE D9( 

.1( N00010 ) , 

.2( VINMINUS ) 
 ) ;
NPN Q10( 

.2( N00058 ) , 

.3( VMINUS ) , 

.1( VPLUS ) 
 ) ;
NPN Q11( 

.2( VPLUS ) , 

.3( VMINUS ) , 

.1( VOUT ) 
 ) ;
NPN Q12( 

.2( N00056 ) , 

.3( VMINUS ) , 

.1( N00058 ) 
 ) ;
PNP Q13( 

.2( VPLUS ) , 

.3( VPLUS ) , 

.1( N00056 ) 
 ) ;
NPN Q14( 

.2( N00056 ) , 

.3( VMINUS ) , 

.1( N00056 ) 
 ) ;
PNP Q15( 

.2( VPLUS ) , 

.3( VPLUS ) , 

.1( N00058 ) 
 ) ;
NPN Q16( 

.2( VINPLUS ) , 

.3( VMINUS ) , 

.1( VPLUS ) 
 ) ;
NPN Q17( 

.2( VINMINUS ) , 

.3( VMINUS ) , 

.1( VPLUS ) 
 ) ;
endmodule

module SPICE( );



//    SIGNALS

wire VUPPER;
wire N00060;
wire N00050;
wire VINPUT DC 1V;
wire N00096;
wire VCC DC 15V;
wire N00092;
wire GND;
wire VLOWER;

// GATE INSTANCES

RESISTOR R1( 
.1( VUPPER ) , 
.2( VLOWER ) 

 ) ;
RESISTOR R2( 

.1( VCC DC 15V ) , 

.2( VUPPER ) 
 ) ;
RESISTOR R3( 

.1( GND ) , 

.2( VLOWER ) 
 ) ;
RESISTOR R4( 

.1( VINPUT DC 1V ) , 

.2( N00050 ) 
 ) ;
RESISTOR R5( 

.1( VINPUT DC 1V ) , 

.2( N00060 ) 
 ) ;
RESISTOR R6( 

.1( VCC DC 15V ) , 

.2( N00092 ) 
 ) ;
RESISTOR R7( 

.1( VCC DC 15V ) , 

.2( N00096 ) 
 ) ;
NPN Q1( 

.2( N00092 ) , 

.3( GND ) , 

.1( N00096 ) 
 ) ;
COMPARATORComparator1 ( 

.Vout( N00092 ) , 

.VMinus( GND ) , 

.VinMinus( N00050 ) , 

.VinPlus( VUPPER ) , 

.VPlus( VCC DC 15V ) 
);
COMPARATORComparator2 ( 



.Vout( N00092 ) , 

.VMinus( GND ) , 

.VinMinus( N00060 ) , 

.VinPlus( VLOWER ) , 

.VPlus( VCC DC 15V ) 
);
endmodule

top C:\SHARED\DESIGNS\SPICEL.DSN;
endmodule

Related topic
Other netlist formats



Hierarchical Verilog netlist example (physical view)
The contents specified by the Part Value combined property string are shown in blue. Verilog 
netlists normally have a .V file extension.
 

module COMPARATORComparator1( Vout, VMinus, VinMinus,
VinPlus, VPlus);

output Vout;
input VMinus;
input VinMinus;
input VinPlus;
input VPlus;

//    SIGNALS

wire N00010;
wire N00007;
wire N00058;
wire N00056;

// GATE INSTANCES

DIODE D5( 
.1( N00007 ) , 
.2( VINPLUS ) 

 ) ;
DIODE D6( 

.1( N00007 ) , 

.2( VPLUS ) 
 ) ;
DIODE D7( 

.1( N00010 ) , 

.2( VPLUS ) 
 ) ;
DIODE D8( 

.1( N00010 ) , 

.2( VINMINUS ) 
 ) ;
PNP Q10( 

.2( VPLUS ) , 

.3( VPLUS ) , 

.1( N00056 ) 
 ) ;
PNP Q11( 

.2( VPLUS ) , 

.3( VPLUS ) , 

.1( N00058 ) 
 ) ;
NPN Q12( 

.2( VPLUS ) , 

.3( VMINUS ) , 

.1( VOUT ) 



 ) ;
NPN Q13( 

.2( VINPLUS ) , 

.3( VMINUS ) , 

.1( VPLUS ) 
 ) ;
NPN Q14( 

.2( VINMINUS ) , 

.3( VMINUS ) , 

.1( VPLUS ) 
 ) ;
NPN Q15( 

.2( N00058 ) , 

.3( VMINUS ) , 

.1( VPLUS ) 
 ) ;
NPN Q16( 

.2( N00056 ) , 

.3( VMINUS ) , 

.1( N00056 ) 
 ) ;
NPN Q17( 

.2( N00056 ) , 

.3( VMINUS ) , 

.1( N00058 ) 
 ) ;
endmodule

module COMPARATORComparator2( Vout, VMinus, VinMinus,
VinPlus, VPlus);

output Vout;
input VMinus;
input VinMinus;
input VinPlus;
input VPlus;

//    SIGNALS

wire N00010;
wire N00007;
wire N00058;
wire N00056;

// GATE INSTANCES

NPN Q6( 
.2( VINMINUS ) , 
.3( VMINUS ) , 
.1( VPLUS ) 

 ) ;
NPN Q7( 

.2( N00058 ) , 



.3( VMINUS ) , 

.1( VPLUS ) 
 ) ;
NPN Q8( 

.2( N00056 ) , 

.3( VMINUS ) , 

.1( N00056 ) 
 ) ;
NPN Q9( 

.2( N00056 ) , 

.3( VMINUS ) , 

.1( N00058 ) 
 ) ;
DIODE D1( 

.1( N00007 ) , 

.2( VINPLUS ) 
 ) ;
DIODE D2( 

.1( N00007 ) , 

.2( VPLUS ) 
 ) ;
DIODE D3( 

.1( N00010 ) , 

.2( VPLUS ) 
 ) ;
DIODE D4( 

.1( N00010 ) , 

.2( VINMINUS ) 
 ) ;
PNP Q2( 

.2( VPLUS ) , 

.3( VPLUS ) , 

.1( N00056 ) 
 ) ;
PNP Q3( 

.2( VPLUS ) , 

.3( VPLUS ) , 

.1( N00058 ) 
 ) ;
NPN Q4( 

.2( VPLUS ) , 

.3( VMINUS ) , 

.1( VOUT ) 
 ) ;
NPN Q5( 

.2( VINPLUS ) , 

.3( VMINUS ) , 

.1( VPLUS ) 
 ) ;
endmodule

module SPICE( );



//    SIGNALS

wire N00096;
wire VCC DC 15V;
wire N00092;
wire GND;
wire VLOWER;
wire VUPPER;
wire N00060;
wire N00050;
wire VINPUT DC 1V;

// GATE INSTANCES

RESISTOR R1( 
.1( VCC DC 15V ) , 
.2( VUPPER ) 

 ) ;
RESISTOR R2( 

.1( VCC DC 15V ) , 

.2( N00092 ) 
 ) ;
RESISTOR R3( 

.1( VCC DC 15V ) , 

.2( N00096 ) 
 ) ;
RESISTOR R4( 

.1( VINPUT DC 1V ) , 

.2( N00050 ) 
 ) ;
RESISTOR R5( 

.1( VUPPER ) , 

.2( VLOWER ) 
 ) ;
RESISTOR R6( 

.1( VINPUT DC 1V ) , 

.2( N00060 ) 
 ) ;
RESISTOR R7( 

.1( GND ) , 

.2( VLOWER ) 
 ) ;
NPN Q1( 

.2( N00092 ) , 

.3( GND ) , 

.1( N00096 ) 
 ) ;
COMPARATORComparator1 ( 

.Vout( N00092 ) , 

.VMinus( GND ) , 

.VinMinus( N00050 ) , 

.VinPlus( VUPPER ) , 

.VPlus( VCC DC 15V ) 
);
COMPARATORComparator2 ( 



.Vout( N00092 ) , 

.VMinus( GND ) , 

.VinMinus( N00060 ) , 

.VinPlus( VLOWER ) , 

.VPlus( VCC DC 15V ) 
);
endmodule

top C:\SHARED\DESIGNS\SPICEP.DSN;
endmodule

Related topic
Other netlist formats



VHDL
VHDL netlists have the following characteristics:

If the 1076-87 VHDL standard is selected, legal characters for node names are limited
to:

0..9   A..Z   a..z   _ (underscore)
with the following limitations:

The first character is limited to:      A..Z  a..z
The last character restricted from: _ (underscore)
If the 1076-93 VHDL standard is selected, you can use special characters, VHDL 

reserved words, and names that begin with digits. To do so, delimit the name with 
backslashes (\) and precede any special characters---including "internal" backslashes (not 
the delimiters)---with a backslash. The following table contains some examples.

Object Name Problem Solution
Node signal Reserved word \signal\
Node SIGNAL Case sensitivity \SIGNAL\
Pin Q\ Overbar \Q\\\
Pin R\E\S\E\T\ Overbar \R\\E\\S\\E\\T\\\
Pin 12-GND Leading digit, 

hyphen
\12\-GND\

For more information, see the 1076-93 VHDL standard.

Dialog box options
Entity Architecture Header
Signal Type
VHDL Standard
Part Value
PCB Footprint
View output

Related topics
VHDL reserved words
Logical view hierarchical VHDL netlist example
Physical view hierarchical VHDL netlist example
About netlist format, view, and design structure
Other netlist formats



VHDL reserved words
The 1076-93 VHDL standard lists the following reserved words. For complete information, 
see the specification and associated documents.

abs else nand select
access elsif new severity
after end next signal
alias enitity nor subtype
all exit not
and null then
architecture file to
array for of transport
assert function on type
attribute open

generate or units
begin generic others until
block guarded out use
body
buffer if package variable
bus in port

inout procedure wait
case is process when
component while
configuration label range with
constant library record

linkage register xor
disconnect loop rem
downto report

map return
mod

Related topic
Other netlist formats



Hierarchical VHDL netlist example (logical view)
This netlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue. VHDL netlists normally have a .VHD file 
extension.
 

LIBRARY IEEE;
USE IEEE.std_logic_1164.all;

ENTITY COMPARATOR IS PORT (
VOUT : OUT std_logic;
VMINUS : IN std_logic;
VINMINUS : IN std_logic;
VINPLUS : IN std_logic;
VPLUS : IN std_logic

); END COMPARATOR;

ARCHITECTURE STRUCTURE OF COMPARATOR IS

-- COMPONENTS

COMPONENT DIODE PORT (
P1 : INOUT std_logic;
P2 : INOUT std_logic

); END COMPONENT;

COMPONENT NPN PORT (
P2 : IN std_logic;
P3 : IN std_logic;
P1 : IN std_logic

); END COMPONENT;

COMPONENT PNP PORT (
P2 : IN std_logic;
P3 : IN std_logic;
P1 : IN std_logic

); END COMPONENT;

-- SIGNALS

SIGNAL N00010 : std_logic;
SIGNAL N00007 : std_logic;
SIGNAL N00058 : std_logic;
SIGNAL N00056 : std_logic;

-- GATE INSTANCES

BEGIN
D6 : DIODE PORT MAP(

P1 => N00007, 
P2 => VINPLUS

);



D7 : DIODE PORT MAP(
P1 => N00007, 
P2 => VPLUS

);
D8 : DIODE PORT MAP(

P1 => N00010, 
P2 => VPLUS

);
D9 : DIODE PORT MAP(

P1 => N00010, 
P2 => VINMINUS

);
Q10 : NPN PORT MAP(

P2 => N00058, 
P3 => VMINUS, 
P1 => VPLUS

);
Q11 : NPN PORT MAP(

P2 => VPLUS, 
P3 => VMINUS, 
P1 => VOUT

);
Q12 : NPN PORT MAP(

P2 => N00056, 
P3 => VMINUS, 
P1 => N00058

);
Q13 : PNP PORT MAP(

P2 => VPLUS, 
P3 => VPLUS, 
P1 => N00056

);
Q14 : NPN PORT MAP(

P2 => N00056, 
P3 => VMINUS, 
P1 => N00056

);
Q15 : PNP PORT MAP(

P2 => VPLUS, 
P3 => VPLUS, 
P1 => N00058

);
Q16 : NPN PORT MAP(

P2 => VINPLUS, 
P3 => VMINUS, 
P1 => VPLUS

);
Q17 : NPN PORT MAP(

P2 => VINMINUS, 
P3 => VMINUS, 
P1 => VPLUS

);
END STRUCTURE;

LIBRARY IEEE;
USE IEEE.std_logic_1164.all;



ENTITY COMPARATOR IS PORT (
VOUT : OUT std_logic;
VMINUS : IN std_logic;
VINMINUS : IN std_logic;
VINPLUS : IN std_logic;
VPLUS : IN std_logic

); END COMPARATOR;

ARCHITECTURE STRUCTURE OF COMPARATOR IS

-- COMPONENTS

COMPONENT DIODE PORT (
P1 : INOUT std_logic;
P2 : INOUT std_logic

); END COMPONENT;

COMPONENT NPN PORT (
P2 : IN std_logic;
P3 : IN std_logic;
P1 : IN std_logic

); END COMPONENT;

COMPONENT PNP PORT (
P2 : IN std_logic;
P3 : IN std_logic;
P1 : IN std_logic

); END COMPONENT;

-- SIGNALS

SIGNAL N00010 : std_logic;
SIGNAL N00007 : std_logic;
SIGNAL N00058 : std_logic;
SIGNAL N00056 : std_logic;

-- GATE INSTANCES

BEGIN
D6 : DIODE PORT MAP(

P1 => N00007, 
P2 => VINPLUS

);
D7 : DIODE PORT MAP(

P1 => N00007, 
P2 => VPLUS

);
D8 : DIODE PORT MAP(

P1 => N00010, 
P2 => VPLUS

);
D9 : DIODE PORT MAP(

P1 => N00010, 



P2 => VINMINUS
);
Q10 : NPN PORT MAP(

P2 => N00058, 
P3 => VMINUS, 
P1 => VPLUS

);
Q11 : NPN PORT MAP(

P2 => VPLUS, 
P3 => VMINUS, 
P1 => VOUT

);
Q12 : NPN PORT MAP(

P2 => N00056, 
P3 => VMINUS, 
P1 => N00058

);
Q13 : PNP PORT MAP(

P2 => VPLUS, 
P3 => VPLUS, 
P1 => N00056

);
Q14 : NPN PORT MAP(

P2 => N00056, 
P3 => VMINUS, 
P1 => N00056

);
Q15 : PNP PORT MAP(

P2 => VPLUS, 
P3 => VPLUS, 
P1 => N00058

);
Q16 : NPN PORT MAP(

P2 => VINPLUS, 
P3 => VMINUS, 
P1 => VPLUS

);
Q17 : NPN PORT MAP(

P2 => VINMINUS, 
P3 => VMINUS, 
P1 => VPLUS

);
END STRUCTURE;

LIBRARY IEEE;
USE IEEE.std_logic_1164.all;

ENTITY SPICE IS END SPICE;

ARCHITECTURE STRUCTURE OF SPICE IS

-- COMPONENTS

COMPONENT RESISTOR PORT (



P1 : INOUT std_logic;
P2 : INOUT std_logic

); END COMPONENT;

COMPONENT NPN PORT (
P2 : IN std_logic;
P3 : IN std_logic;
P1 : IN std_logic

); END COMPONENT;

COMPONENT COMPARATOR PORT (
VOUT : OUT std_logic;
VMINUS : IN std_logic;
VINMINUS : IN std_logic;
VINPLUS : IN std_logic;
VPLUS : IN std_logic

); END COMPONENT;

-- SIGNALS

SIGNAL VUPPER : std_logic;
SIGNAL N00060 : std_logic;
SIGNAL N00050 : std_logic;
SIGNAL VINPUT_32_DC_32_1V : std_logic;
SIGNAL N00096 : std_logic;
SIGNAL VCC_32_DC_32_15V : std_logic;
SIGNAL N00092 : std_logic;
SIGNAL GND : std_logic;
SIGNAL VLOWER : std_logic;

-- GATE INSTANCES

BEGIN
R1 : RESISTOR PORT MAP(

P1 => VUPPER, 
P2 => VLOWER

);
R2 : RESISTOR PORT MAP(

P1 => VCC_32_DC_32_15V, 
P2 => VUPPER

);
R3 : RESISTOR PORT MAP(

P1 => GND, 
P2 => VLOWER

);
R4 : RESISTOR PORT MAP(

P1 => VINPUT_32_DC_32_1V, 
P2 => N00050

);
R5 : RESISTOR PORT MAP(

P1 => VINPUT_32_DC_32_1V, 
P2 => N00060

);
R6 : RESISTOR PORT MAP(

P1 => VCC_32_DC_32_15V, 
P2 => N00092



);
R7 : RESISTOR PORT MAP(

P1 => VCC_32_DC_32_15V, 
P2 => N00096

);
Q1 : NPN PORT MAP(

P2 => N00092, 
P3 => GND, 
P1 => N00096

);
COMPARATOR1 : COMPARATOR PORT MAP(

VOUT => N00092, 
VMINUS => GND, 
VINMINUS => N00050, 
VINPLUS => VUPPER, 
VPLUS => VCC_32_DC_32_15V

);
COMPARATOR2 : COMPARATOR PORT MAP(

VOUT => N00092, 
VMINUS => GND, 
VINMINUS => N00060, 
VINPLUS => VLOWER, 
VPLUS => VCC_32_DC_32_15V

);
END STRUCTURE;

Related topic
Other netlist formats



Hierarchical VHDL netlist example (physical view)
This netlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue. VHDL netlists normally have a .VHD file 
extension.
 

LIBRARY IEEE;
USE IEEE.std_logic_1164.all;

ENTITY COMPARATOR IS PORT (
VOUT : OUT std_logic;
VMINUS : IN std_logic;
VINMINUS : IN std_logic;
VINPLUS : IN std_logic;
VPLUS : IN std_logic

); END COMPARATOR;

ARCHITECTURE STRUCTURE OF COMPARATOR IS

-- COMPONENTS

COMPONENT DIODE PORT (
P1 : INOUT std_logic;
P2 : INOUT std_logic

); END COMPONENT;

COMPONENT PNP PORT (
P2 : IN std_logic;
P3 : IN std_logic;
P1 : IN std_logic

); END COMPONENT;

COMPONENT NPN PORT (
P2 : IN std_logic;
P3 : IN std_logic;
P1 : IN std_logic

); END COMPONENT;

-- SIGNALS

SIGNAL N00010 : std_logic;
SIGNAL N00007 : std_logic;
SIGNAL N00058 : std_logic;
SIGNAL N00056 : std_logic;

-- GATE INSTANCES

BEGIN
D5 : DIODE PORT MAP(

P1 => N00007, 
P2 => VINPLUS

);



D6 : DIODE PORT MAP(
P1 => N00007, 
P2 => VPLUS

);
D7 : DIODE PORT MAP(

P1 => N00010, 
P2 => VPLUS

);
D8 : DIODE PORT MAP(

P1 => N00010, 
P2 => VINMINUS

);
Q10 : PNP PORT MAP(

P2 => VPLUS, 
P3 => VPLUS, 
P1 => N00056

);
Q11 : PNP PORT MAP(

P2 => VPLUS, 
P3 => VPLUS, 
P1 => N00058

);
Q12 : NPN PORT MAP(

P2 => VPLUS, 
P3 => VMINUS, 
P1 => VOUT

);
Q13 : NPN PORT MAP(

P2 => VINPLUS, 
P3 => VMINUS, 
P1 => VPLUS

);
Q14 : NPN PORT MAP(

P2 => VINMINUS, 
P3 => VMINUS, 
P1 => VPLUS

);
Q15 : NPN PORT MAP(

P2 => N00058, 
P3 => VMINUS, 
P1 => VPLUS

);
Q16 : NPN PORT MAP(

P2 => N00056, 
P3 => VMINUS, 
P1 => N00056

);
Q17 : NPN PORT MAP(

P2 => N00056, 
P3 => VMINUS, 
P1 => N00058

);
END STRUCTURE;

LIBRARY IEEE;
USE IEEE.std_logic_1164.all;



ENTITY COMPARATOR IS PORT (
VOUT : OUT std_logic;
VMINUS : IN std_logic;
VINMINUS : IN std_logic;
VINPLUS : IN std_logic;
VPLUS : IN std_logic

); END COMPARATOR;

ARCHITECTURE STRUCTURE OF COMPARATOR IS

-- COMPONENTS

COMPONENT NPN PORT (
P2 : IN std_logic;
P3 : IN std_logic;
P1 : IN std_logic

); END COMPONENT;

COMPONENT DIODE PORT (
P1 : INOUT std_logic;
P2 : INOUT std_logic

); END COMPONENT;

COMPONENT PNP PORT (
P2 : IN std_logic;
P3 : IN std_logic;
P1 : IN std_logic

); END COMPONENT;

-- SIGNALS

SIGNAL N00010 : std_logic;
SIGNAL N00007 : std_logic;
SIGNAL N00058 : std_logic;
SIGNAL N00056 : std_logic;

-- GATE INSTANCES

BEGIN
Q6 : NPN PORT MAP(

P2 => VINMINUS, 
P3 => VMINUS, 
P1 => VPLUS

);
Q7 : NPN PORT MAP(

P2 => N00058, 
P3 => VMINUS, 
P1 => VPLUS

);
Q8 : NPN PORT MAP(

P2 => N00056, 
P3 => VMINUS, 
P1 => N00056



);
Q9 : NPN PORT MAP(

P2 => N00056, 
P3 => VMINUS, 
P1 => N00058

);
D1 : DIODE PORT MAP(

P1 => N00007, 
P2 => VINPLUS

);
D2 : DIODE PORT MAP(

P1 => N00007, 
P2 => VPLUS

);
D3 : DIODE PORT MAP(

P1 => N00010, 
P2 => VPLUS

);
D4 : DIODE PORT MAP(

P1 => N00010, 
P2 => VINMINUS

);
Q2 : PNP PORT MAP(

P2 => VPLUS, 
P3 => VPLUS, 
P1 => N00056

);
Q3 : PNP PORT MAP(

P2 => VPLUS, 
P3 => VPLUS, 
P1 => N00058

);
Q4 : NPN PORT MAP(

P2 => VPLUS, 
P3 => VMINUS, 
P1 => VOUT

);
Q5 : NPN PORT MAP(

P2 => VINPLUS, 
P3 => VMINUS, 
P1 => VPLUS

);
END STRUCTURE;

LIBRARY IEEE;
USE IEEE.std_logic_1164.all;

ENTITY SPICE IS END SPICE;

ARCHITECTURE STRUCTURE OF SPICE IS

-- COMPONENTS

COMPONENT RESISTOR PORT (



P1 : INOUT std_logic;
P2 : INOUT std_logic

); END COMPONENT;

COMPONENT NPN PORT (
P2 : IN std_logic;
P3 : IN std_logic;
P1 : IN std_logic

); END COMPONENT;

COMPONENT COMPARATOR PORT (
VOUT : OUT std_logic;
VMINUS : IN std_logic;
VINMINUS : IN std_logic;
VINPLUS : IN std_logic;
VPLUS : IN std_logic

); END COMPONENT;

-- SIGNALS

SIGNAL N00096 : std_logic;
SIGNAL VCC_32_DC_32_15V : std_logic;
SIGNAL N00092 : std_logic;
SIGNAL GND : std_logic;
SIGNAL VLOWER : std_logic;
SIGNAL VUPPER : std_logic;
SIGNAL N00060 : std_logic;
SIGNAL N00050 : std_logic;
SIGNAL VINPUT_32_DC_32_1V : std_logic;

-- GATE INSTANCES

BEGIN
R1 : RESISTOR PORT MAP(

P1 => VCC_32_DC_32_15V, 
P2 => VUPPER

);
R2 : RESISTOR PORT MAP(

P1 => VCC_32_DC_32_15V, 
P2 => N00092

);
R3 : RESISTOR PORT MAP(

P1 => VCC_32_DC_32_15V, 
P2 => N00096

);
R4 : RESISTOR PORT MAP(

P1 => VINPUT_32_DC_32_1V, 
P2 => N00050

);
R5 : RESISTOR PORT MAP(

P1 => VUPPER, 
P2 => VLOWER

);
R6 : RESISTOR PORT MAP(

P1 => VINPUT_32_DC_32_1V, 
P2 => N00060



);
R7 : RESISTOR PORT MAP(

P1 => GND, 
P2 => VLOWER

);
Q1 : NPN PORT MAP(

P2 => N00092, 
P3 => GND, 
P1 => N00096

);
COMPARATOR1 : COMPARATOR PORT MAP(

VOUT => N00092, 
VMINUS => GND, 
VINMINUS => N00050, 
VINPLUS => VUPPER, 
VPLUS => VCC_32_DC_32_15V

);
COMPARATOR2 : COMPARATOR PORT MAP(

VOUT => N00092, 
VMINUS => GND, 
VINMINUS => N00060, 
VINPLUS => VLOWER, 
VPLUS => VCC_32_DC_32_15V

);
END STRUCTURE;

Related topic
Other netlist formats



VST
This format file produces .INF files for use with OrCAD's Digital Simulation Tools 386+. See 
the Digital Simulation Tools User's Guide for details.
If you attach a file to any nonprimitive part or hierarchical block, Capture treats the file as a 
schematic external to the design. When this formatter uses such an external file, it wont 
generate the netlist for the child .INF file. Instead, Capture assumes that this file will be 
supplied by someone else.
.INF files are not ASCII text files.

Dialog box options
Part Value
View output

Related topics
VST pipe commands
VST netlist constraints
VST netlist example
About netlist format, view, and design structure
Other netlist formats



VST pipe commands
Lines of text may be placed in your schematic, to be included in the VST Model netlist. 
Select the Text command from the Place menu (ALT, P, T) to place the text on a schematic 
page.
Each line of text must start with the pipe character (|). The first line must be:

|VST_MODEL
This tells Capture to extract the information in the following lines of text when generating a 
VST Model netlist. The remaining lines can contain a header, comments, and directives 
compatible with OrCAD's Digital Simulation Tools 386+ Add Device Model device modeling 
language. For details on the Add Device Model Language, see the Digital Simulation Tools 
User's Guide.

Related topic
Other netlist formats



VST netlist constraints
When you create a VST Model netlist, be sure you include the OrCAD-supplied 
VSTGATES.OLB, VSTRAM.OLB, VSTROM.OLB, and VSTOTHER.OLB part libraries in your 
design. You can use only the parts provided in these libraries to create the schematic.

Related topic
Other netlist formats



VST netlist example
The contents specified by the Part Value combined property string are shown in blue; those 
specified by the PCB Footprint combined property string are shown in purple. VST netlists 
normally have an .INF file extension.
 

`F  1.00 FIG_B-01
`B "1" "1" "A" "Wednesday, May 31, 1995" "C:\RD\TEST\PUBS\MOST.DSN" ""
"" "OrCAD"
"9300 SW Nimbus Ave."
"Beaverton, OR 97008"
""
""
`P I "CLOCK"
`P O "OUT"
`P I "A"
`P I "B"
`P S "VCC"
`P S "GND"
`S "N00039" 47
`S "N00037" 48
`S "Q" 49
`E TTL.LIB
`I R "74LS00" TTL.LIB "74LS00" 00000041 U1  [1110]
"14DIP300" "" "" "" "" "" "" "" "14DIP300"
( "I0_A" 1 I ) ( "I1_A" 2 I ) ( "O_A" 3 O ) ( "VCC_A" 14 S ) ( "GND_A" 7 S ) 
( "I0_B" 4 I ) ( "I1_B" 5 I ) ( "O_B" 6 O ) ( "I0_C" 9 I ) ( "I1_C" 10 I ) 
( "O_C" 8 O ) ( "I0_D" 12 I ) ( "I1_D" 13 I ) ( "O_D" 11 O ) 
`I R "74LS32" TTL.LIB "74LS32" 00000047 U2  [1000]
"14DIP300" "" "" "" "" "" "" "" "14DIP300"
( "I0_A" 1 I ) ( "I1_A" 2 I ) ( "O_A" 3 O ) ( "VCC_A" 14 S ) ( "GND_A" 7 S ) 
( "I0_B" 4 I ) ( "I1_B" 5 I ) ( "O_B" 6 O ) ( "I0_C" 9 I ) ( "I1_C" 10 I ) 
( "O_C" 8 O ) ( "I0_D" 12 I ) ( "I1_D" 13 I ) ( "O_D" 11 O ) 
`J ( P S "GND" ) ( R U1 7 S ) ( R U2 7 S ) 
`J ( P S "VCC" ) ( R U1 14 S ) ( R U2 14 S ) 
`J ( R U2 1 I ) ( R U1 8 O ) ( S "N00039" 1 ) 
`J ( R U1 3 O ) ( R U1 5 I ) ( S "N00037" 1 ) 
`J ( R U1 1 I ) ( R U1 6 O ) ( R U2 2 I ) ( S "Q" 1 ) 
`J ( P I "A" ) ( R U1 9 I ) ( R U1 10 I ) 
`J ( P I "CLOCK" ) ( R U1 2 I ) 
`J ( P O "OUT" ) ( R U2 3 O ) 
`J ( P I "B" ) ( R U1 4 I ) 

Related topic
Other netlist formats



VST Model
This format file produces netlists for modeling with OrCAD's Digital Simulation Tools 386+. 
See the Digital Simulation Tools User's Guide for details.
VST Model netlists have the following characteristics:

Part names, module names, reference strings, node names, and pin numbers are not 
checked for length.

Node numbers and pin names are not used.
All ASCII characters are legal.

Dialog box options
Suppress comments
Part Value
PCB Footprint
View output

Related topics
VST Model pipe commands
VST Model netlist constraints
VST Model netlist example
About netlist format, view, and design structure
Other netlist formats



VST Model pipe commands
Lines of text may be placed in your schematic, to be included in the VST Model netlist. 
Select the Text command from the Place menu (ALT, P, T) to place the text on a schematic 
page.
Each line of text must start with the pipe character (|). The first line must be:

|VST_MODEL
This tells Capture to extract the information in the following lines of text when generating a 
VST Model netlist. The remaining lines can contain a header, comments, and directives 
compatible with OrCAD's Digital Simulation Tools 386+ Add Device Model device modeling 
language. For details on the Add Device Model language, see the Digital Simulation Tools 
User's Guide.

Related topic
Other netlist formats



VST Model netlist constraints
When you create a VST Model netlist, be sure you include the OrCAD-supplied 
VSTGATES.OLB, VSTRAM.OLB, VSTROM.OLB, and VSTOTHER.OLB libraries in your design. You
can use only the parts provided in these libraries to create the schematic.

Related topic
Other netlist formats



VST Model netlist example
This netlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue. VST Model netlists normally have a .DSF file 
extension.
 

;
;2 TO 1 MULTIPLEXOR
;
:21MUX        MY_LIB     4
LINV(P3;L1);M1
LAND(P2,P1;L2);M2
LNOR(L1,P1;L3);M3
SET(RHIGH)
OR(L2,L3;P4;10,50,15,50);M4
%

Related topic
Other netlist formats



WireList
WireList netlists have the following characteristics:

Part and node names are not checked for length.
Module names are limited to twenty-nine characters.
Reference strings are limited to nine characters.
Node numbers are limited to five digits following the "N" prefix.
Pin numbers are limited to seven characters.
Pin names are limited to fifteen characters.
Legal characters for node numbers are 0..9.
Legal characters for pin numbers are 0..9, unless the option Do not output pin 

numbers for Grid Array parts is selected. If it is selected, any ASCII character is legal.
All ASCII characters are legal except as noted for node numbers and pin numbers.

Dialog box options
Do not output pin numbers for Grid Array parts
Abbreviate label descriptions
Part Value
PCB Footprint
View output

Related topics
WireList netlist example
About netlist format, view, and design structure
Other netlist formats



WireList netlist example
This netlist was created with no options selected. The contents specified by the Part Value 
combined property string are shown in blue; those specified by the PCB Footprint combined 
property string are shown in purple. WireList netlists normally have a .NET file extension.
 

Wire List

                                              Revised: May 31, 1995
C:\RD\TEST\PUBS\MOST.DSN                      Revision: 
OrCAD
9300 SW Nimbus Ave.
Beaverton, OR 97008

<<< Component List >>>
74LS00                        U1        14DIP300
74LS32                        U2        14DIP300

<<< Wire List >>>

  NODE  REFERENCE  PIN #   PIN NAME       PIN TYPE    PART VALUE

[00001] B
        U1         4       I0_B           Input       74LS00

[00002] OUT
        U2         3       O_A            Output      74LS32

[00003] N00039
        U2         1       I0_A           Input       74LS32
        U1         8       O_C            Output      74LS00

[00004] VCC
        U1         14      VCC            Power       74LS00
        U2         14      VCC            Power       74LS32

[00005] GND
        U1         7       GND            Power       74LS00
        U2         7       GND            Power       74LS32

[00006] CLOCK
        U1         2       I1_A           Input       74LS00

[00007] A
        U1         9       I0_C           Input       74LS00
        U1         10      I1_C           Input       74LS00

[00008] Q
        U1         1       I0_A           Input       74LS00
        U1         6       O_B            Output      74LS00
        U2         2       I1_A           Input       74LS32



[00009] N00037
        U1         3       O_A            Output      74LS00
        U1         5       I1_B           Input       74LS00

Related topic
Other netlist formats



The following popup topics describe the various format-specific and dialog box options 
mentioned in the netlist format topics.



If you select this option, Capture creates a persistent netname (.PNN) file. If the .PNN file 
already exists, Capture compares any unnamed nets in the two versions. For each 
unnamed net in the new file, if more than half of the nodes in that net are in a single 
unnamed net in the old file, Capture assigns that new net the same name as its 
counterpart in the old file.

If you do not select this option, Capture does not create a .PNN file or check for an 
existing .PNN file. Instead, Capture generates names for any unnamed nets as they are 
found.



Select this option if you are creating a netlist for PC Board Layout Tools 386+ or another 
EDIF reader that allows non-EDIF characters.

If you select this option, the EDIF formatter does not check for legal EDIF characters.



Select this option if you are creating a netlist for some EDIF reader other than PC Board 
Layout Tools 386+.

If you select this option, Capture extracts the property name from the property value, and 
creates a new property named after the value. You must create a property using the form:
Xth Part Field

where Xth is 1ST, 2ND, 3RD, 4TH, 5TH, 6TH, 7TH, or 8TH.

The value contained in this property must be of the form:
PropertyName=Value

where PropertyName is the name of the new property, and Value is the value of this new 
property. Do not use a space on either side of the equal sign character.



Use this option with caution.

If you select this option, Capture merges objects with the same name or alias on different 
schematic pages into one net. You typically select this option only when the design consists
of a single schematic page.

If you do not select this option, Capture appends a slash (/) and the page number to all net
names.



Use this option with caution.

If you select this option, Capture merges objects with the same name or alias on different 
schematic pages into one net. You typically select this option only when the design consists
of a single schematic page.

If you do not select this option, Capture appends a period (.) and the page number to all 
net names.



Use this option with caution.

If you select this option, Capture merges objects with the same name or alias on different 
schematic pages into one net. You typically select this option only when the design consists
of a single schematic page.

If you do not select this option, Capture appends an underscore (_) and the page number to
all net names.



Use this option with caution.

If you select this option, Capture merges objects with the same name or alias on different 
schematic pages into one net. You typically select this option only when the design consists
of a single schematic page.

If you do not select this option, Capture appends a dollar sign ($) and the page number to 
all net names.



If you select this option, Capture does not put comments in the netlist file. Comments in 
the AlteraADF and Intel ADF formats are delimited by the percent (%) character.



If you select this option, Capture does not append the primitive's part reference to the end 
of the statement (see VST Model netlist example).



If you select this option, Capture uses the node names you placed on the schematic (via 
aliases and hierarchical ports) where available. Not all versions of SPICE support 
alphanumeric node names. Check your SPICE manual for details. If your version of SPICE 
does not allow alphanumeric node names, you can still give them numeric names such as 
"17." These numeric names do not interfere with the ones generated by Capture, since the 
node numbers it generates begin at 10000 (except GND, which is always 0).



If you select this option, Capture assigns all unconnected pins a unique net.

If you do not select this option, Capture does not assign a net and reports a warning.



If you select this option, Capture assigns node numbers to all unconnected pins. Node 
numbers for unconnected pins begin at 32767 and decrease in value.

If you do not select this option and there are unconnected pins on your schematic, they are
assigned a space character and Capture displays a warning.



Select this option if you are creating a netlist for use with an EDIF reader that doesn't 
require properties.

If you select this option, Capture outputs only the Part Value and PCB Footprint, so it takes 
less time and creates a smaller netlist file.

Do not select this option to create a netlist for PC Board Layout Tools 386+.



Select this option if you want the netlist to contain pin names instead of pin numbers. Most 
EDIF readers expect pin names instead of pin numbers.

Do not select this option to create a netlist for PC Board Layout Tools 386+.



If you select this option, Capture does not create an EDIF external statement in the netlist 
file.

If you do not select this option, Capture uses external statements to identify OrCAD as the
source of the library parts in the netlist, but some EDIF readers do not accept external 
statements.



The FutureNet system has two connectivity output formats: a netlist and a pinlist. The 
netlist format lists each net in the schematic and the part pins that belong in that net. The 
pinlist format is a list of each pin on a part, and the net in which that pin belongs. The 
FutureNet format can create both netlists and pinlists.

The two formats contain the same information, so neither has any inherent advantages 
over the other. You need to decide which format is best suited to your needs.



Not all parts have both pin numbers and pin names defined.

If you select this option and a pin without a number is found, then the pin name is used. If 
you need a netlist consisting entirely of pin numbers, you may need to modify the OrCAD-
supplied libraries, which is explained in the SPICE netlist topic.



Normally, all off-page connectors (input, output, and bidirectional) are assigned the 
attribute of 5 (signal name).

If you select this option, Capture substitutes the more precise attributes 10, 11, and 12 
(input signal, output signal, and bidirectional signal, respectively) for the generic signal 
attribute 5. 



If you select this option, Capture creates FutureNet SYMbol objects for the off-page 
connectors. The new SYMbol objects (input, output, and bidirectional) are assigned the 
attributes 24, 25, and 26, respectively; they also have the names CONI, CONO, and CONB, 
respectively, assigned in their data fields.



If you select this option, Capture assigns FutureNet power attributes to Capture power 
objects. The pins on the following Capture power objects (which are matched by name) are 
assigned FutureNet power attributes.

OrCAD Pin Value FutureNet Attribute
GND 100
+5V 101
+12V 105
-12V 106
VEE 107

FutureNet power attribute equivalents.



If you select this option, Capture creates a PLD source file in addition to a netlist. Any PLD 
vectors extracted from the schematic are placed in the PLD source file.



If you select this option, Capture uses only pins and nodes as keywords in the PLD source 
file; Capture also creates a complete PLD source file, as if you had also selected the Create 
a complete PLD source file option.

If you do not select this option, Capture uses pins, nodes, in, out, and i/o as keywords.



If you select this option, Capture skips nonnumerical pin numbers, such as those on grid 
array parts.



If you select this option, Capture shortens alias descriptions.



This text box allows you to specify default procedures which appear at the beginning of the 
netlist output file.



This entry specifies a signal type anywhere a signal needs to be defined with a type.



Select a VHDL standard which drives the naming function.



If you select this option, Capture outputs net properties in addition to the normal netlist.



If you select this option, Capture outputs part properties in addition to the normal netlist.



If you select this option, Capture outputs pin properties in addition to the normal netlist.



According to the PSPICE manual on page108, the X subcircuit general form is:
X name [nodes] subcircuit-name

where:
name Specifies a unique name for the device.
nodes Specifies the list of nets that attach to the device in the same order 

as the .SUBCKT definition used by the device.
subcircuit-name Specifies the name of a .SUBSCKT definition that the X device uses.

The following is an example of an X subcircuit call:
XBUF 13 15 UNITAMP

PSPICE. Irvine: MicroSim Corporation, 1989, p. 108.



If you select this option, Capture automatically loads the new MNL netlist file in Layout. The
corresponding board file must already be loaded in Layout, or it will ignore the MNL file.



Specifies the value for the Part Value in the netlist, using a combined property string. Most 
Part Values are specified using the following combined property string:
{Value}



Specifies the value for the PCB Footprint in the netlist, using a combined property string. 
Most PCB Footprints are specified using the following combined property string:
{PCB Footprint}



Specifies to display the generated netlist in an editor. Before you can use this option 
effectively, you must associate the netlist file type with an editor using the File Manager. 
For example, if you wanted to view a VHDL netlist in Notepad using this option, you would 
need to associate *.VHD file with Notepad in the File Manager.



Messages
Messages that appear in the session log also appear in report files. For specific information 
about a session log message, match the three letters of the warning or error with one of the 
topics listed below. Then scroll to the specific warning or error message indicated by the four
digit number.

Session log messages
[ANN  nnnn  ]  
[BOM  nnnn  ]  
[CAP  nnnn  ]  
[DBO  nnnn  ]  
[DRC  nnnn  ]  
[DSM  nnnn  ]  
[EXP  nnnn  ]  
[EXT  nnnn  ]  
[GAT  nnnn  ]  
[IMP  nnnn  ]  
[NET  nnnn  ]  
[UPD  nnnn  ]  
[XLT  nnnn  ]  

Report file messages
Report file messages

Related topics
Session log window
Sample report files
Troubleshooting



[ANNnnnn] error messages
[ANN0001] Unable to allocate additional memory for the partRef. This error arises 
when the tool runs out of room to allocate memory for buffer enlargement. Free up some 
memory and rerun.
[ANN0002] Memory limit, unable to complete updating references. A memory limit 
was encountered while processing. Currently this is only encountered while organizing the 
parts on the page for the annotation order. Free up some memory and rerun.
[ANN0003] An attempt was made to change PartRefPkg to PartPkg, however it is a
PartRefPkg part per package device. This error arises when Update Part References 
tried to change the Part Reference's package value to use the part's package as the suffix, 
but the part's package does not exist as a valid suffix to change to. This problem may be 
caused by an improperly configured combined property string in the Update Properties 
dialog box.
[ANN0005] Cannot perform update on reference of heterogeneous part 'partRef', 
part has not been uniquely grouped or which device has not been chosen. This 
error arises when the tool encounters a second heterogeneous part with an identical part 
reference to the first part. Group the parts into two different packages. You can avoid this 
error by annotating all heterogeneous parts before running the tool.



[BOMnnnn] error messages
[BOM0002] No parts were found in design. This error arises when the tool finds no 
parts in the selected schematic pages.
[BOM0003] Line lineNum of include file is incomplete, ignoring this line. This 
warning arises when the tool encounters an incomplete or incorrect line in the include file. 
For example, you will get this message if you have the quoted match string at the beginning 
of the line    but not the include information.
[BOM0004] Part has duplicate References partName partRef. This error arises when 
the tool encounters a duplicate part reference while building its Part Table. Eliminate 
duplicate references and rerun the tool.
[BOM0005] Part has Reference but no Part Value partRef. This error arises when the 
tool finds a part with a valid part reference, but no part value. Enter a part value and rerun 
the tool.
[BOM0006] Part has Part Value but no Reference partRef. This error arises when the 
tool finds a part with a valid part value, but no part reference. Enter a part reference and 
rerun the tool.
[BOM0007] Unable to read from source file. This error arises when the tool encounters 
a corrupted file, an unexpected EOF, or some other critical system error.
[BOM0008] Missing open quote, line lineNum. This error arises when the tool reads an 
include file and one of the lines is missing the opening quote. Add the mark and rerun the 
tool. Blank lines do not generate this message.
[BOM0009] Missing closing quote, line lineNum. This error arises when the tool reads 
an include file and one of the lines is missing the closing quote. Add the mark and rerun the 
tool.
[BOM0010] Name is too long, line lineNum. This error arises when the tool reads an 
include file and the name (typically the Part Value) field is longer than 255 characters. 
Reduce the length of the name field and rerun the tool.
[BOM0011] Line is too long, line lineNum. This error arises when the tool reads an 
include file and a line is longer than 255 characters. Reduce the length of the line and rerun 
the tool.
[BOM0012] Part Count Overflow partRef. This error arises when the tool is creating a 
report of unused parts and finds more than 4096 parts in a package.
[BOM0013] Duplicate Reference partRef. This error arises when the tool, while creating 
an report of unused parts, finds a duplicate part reference. Eliminate the duplicate part 
reference and rerun the tool.
[BOM0014] Parts used greater than parts in package. This error arises when the tool, 
while creating a report of unused parts, finds a part that is outside the limits for the number 
of parts in the package. For example, if U1 is a four-part package and the tool encounters 
the part reference U1H, it reports an error because it expects only U1A, U1B, U1C, and U1D. 
Eliminate the problem and rerun the tool.
[BOM0015] Unable to close the include file. This error arises when the tool is trying to 
close the include file and encounters a system critical error (such as having a floppy disk 
removed).



[BOM0016] Unable to write to report file. This error arises when a system error 
prevents the tool from writing data to the report file.
[BOM0017] Unexpected exception. This error arises when the tool encounters a problem
in the database.
[BOM0018] Include file has duplicate match field - partRef, line lineNum. This 
warning arises when the tool encounters duplicate match keys in the include file.
[BOM0019] Include file match key not found partRef, line lineNum. This warning 
arises when a match key in the include file could not be located in the design.
[BOM0020] Reference Designator is longer than 24 characters. This error arises 
when the combination of the part reference and package exceeds 24 characters. Check the 
length of the part reference.
[BOM0021] There is no Title Block for this design.    Headers were omitted. This 
warning arises when there is no title block for the design. Capture responds by omitting the 
headers from the bill of materials and cross reference reports. To include these headers, 
check the design for a title block.



[CAPnnnn] error messages
The [CAPnnnn] messages are general Capture errors and warnings. Each of these messages 
may be caused by more than one type of problem, but end up with the same result. In 
general, you should check to make sure that all files you work with are not read-only or 
corrupted. For parts, pins, nets, and properties, check that you are using valid character 
names. If Capture is unable to create new objects or documents, or if Capture is unable to 
allocate memory for a task, check to see if you have sufficient system resources for Capture.
You may need to close down applications that you are not using.



[DBOnnnn] error messages
The [DBOnnnn] messages are database errors and warnings. Check that your hardware is 
functioning properly. You should also check that    you are following procedures correctly. 
Capture will often warn you if you are attempting an illegal operation, such as giving two 
parts the same name within a library, and naming a non-bus object with a bus name. You 
should also check property names and values for correctness.
In general, you should check to make sure that all files you work with are not read-only or 
corrupted. For parts, pins, nets, and properties, check that you are using valid character 
names. If Capture is unable to create new objects or documents, or if Capture is unable to 
allocate memory for a task, check to see if you have sufficient system resources for Capture.
You may need to close down applications that you are not using.



[DRCnnnn] error messages
The [DRCnnnn] messages are design rule check errors and warnings. Check to see if you are 
following the procedures correctly to perform a specific action. You should also check to see 
if all the design rule check options you want specified are selected. Verify that busses 
connect to bussed pins, and wires connect to scalar pins. If you are creating a design to be 
translated back to SDT, check that you have followed the rules for creating an SDT 
compatible design.

Related topics
Checking design rules 
Interpreting Design Rules Check reports 
Saving in SDT format 
Design Rules Check back annotation 
Design Rules Check command 
DRC report options 



[DSMnnnn] error messages
The [DSMnnnn] messages are design manager window errors and warnings. Check to see if 
you are following the procedures correctly to perform a specific action.
In general, you should check to make sure that all files you work with are not read-only or 
corrupted. For parts, pins, nets, and properties, check that you are using valid character 
names. If Capture is unable to create new objects or documents, or if Capture is unable to 
allocate memory for a task, check to see if you have sufficient system resources for Capture.
You may need to close down applications that you are not using.

Related topics
Design manager window 
Design manager menus 



[EXPnnnn] error messages
[EXP0001] Cannot open the file for output. This error arises when Capture is unable to 
open the selected export file for output. Check that the file is not read-only.
[EXP0003] Errors occurred in Export Properties. This message occurs when Capture 
encounters errors while attempting to export properties. Check the session log for details.



[EXTnnnn] error messages
[EXT0001] Unable to open source file while making backup file. This error arises 
when one of the tools cannot locate the original file that it needs to be backed up. It is 
probably due to an invalid path or file name.
[EXT0002] Unable to create destination file while making backup file. This error 
arises when one of the tools cannot create a backup file. This is probably due to insufficient 
disk space, empty floppy disk drive, or lack of write access.
[EXT0003] Problems writing to destination file while making backup file. This error 
arises when one of the tools cannot write to a backup file. This is probably due to insufficient
space, empty floppy disk drive, or lack of write access.
[EXT0004] Unable to close source file while making backup file. This error arises 
when one of the tools cannot close the file being backed up. This is caused by a critical 
system error.
[EXT0005] Unable to close destination file while making backup file. This error 
arises when one of the tools cannot close the backup file. This is caused by a critical system 
error.
[EXT0006] Unable to delete the source file while making backup file. This error 
arises when one of the tools cannot delete an existing version of the backup file. This is 
probably due to lack of delete access (especially on a network drive).
[EXT0007] File not found fileName. This error arises when one of the tools cannot find 
the file to be backed up. This is usually due to an invalid path or file name.
[EXT0008] Cannot close .BAK file. This error arises when a critical system error prevents 
the tool from creating a backup of the existing .PLD file.
[EXT0009] Unable to delete .BAK file (Read Only File). This error arises when the 
Read-only attribute is set on an existing .BAK file, or when some other problem prevents the 
tool from deleting the old .BAK file.
[EXT0010] Unable to allocate additional memory for the name table. This error 
arises when Cross Reference cannot allocate additional conventional memory for the named 
data table. Free up memory by removing unneeded drivers, closing other applications, and 
so on.
[EXT0011] Unable to create report file. This error arises when Cross Reference 
encounters a problem while trying to create a report file. Typical causes include insufficient 
disk space, lack of write access, and empty floppy disk drive.
[EXT0012] Unable to open file fileName. This error arises when Extract PLD cannot open
the specified file. This is typically due to a typographical error in the path or filename.
[EXT0013] Part Value is longer than 8 characters, may cause duplicate file names. 
This error arises when Extract PLD extracts PLD information from a schematic and a Part 
Value is longer than eight characters. The eight character limitation is imposed because this 
name is used to create a filename with a .PLD extension. If your Part Value is unique in the 
ninth character or later, you may end up with duplicate filenames, causing Extract PLD to 
overwrite the same file multiple times. For example, part values of MULTIPLE1, MULTIPLE2, 
and MULTIPLE3 create a file called MULTIPLE.PLD, and will only contain the information from 
MULTIPLE3.
[EXT0014] Unable to create file fileName. This error arises when Extract PLD 



encounters a problem creating a file. Typical causes include insufficient disk space, lack of 
write access, and empty floppy disk drive.
[EXT0015] Cannot close .PLD file. This error arises when Extract PLD cannot close 
the .PLD file that it is creating. It may be caused by insufficient disk space or some other 
system error.
[EXT0016] Cannot write string to .PLD file. This error arises when Extract PLD cannot 
write data to the .PLD file because of insufficient disk space or some other critical system 
error.
[EXT0017] Cannot write to .PLD file. This error arises when Extract PLD cannot write 
data to the .PLD file because of insufficient disk space or some other critical system error.
[EXT0018] Part pin has no name for partName. This error arises when Extract PLD 
encounters an unnamed pin on a part. The files that Extract PLD creates require both a pin 
number and a pin name.
[EXT0019] Cannot close report file. This error arises when Extract PLD cannot close the 
report file. It may be caused by insufficient disk space or some other system error.
[EXT0020] Cannot find the part name. This error arises when Extract PLD cannot locate 
the specified part for a single-part extraction.
[EXT0021] |PLD text is too short, cannot find Part Value. This error arises when 
Extract PLD cannot locate the part with the specified Part Value. Probably due to a 
typographical or similar error.



[GATnnnn] error messages
[GAT0001] Expecting a reference designator -- swapSpec. An incomplete swap 
specification is found. The swap specification (swapSpec) may be missing the first part 
reference. In the case that the swap specification is a gate swap or reference change, the 
second part reference may be missing.
[GAT0002] Unterminated string -- swapSpec. A string begins with a quote but does not 
end with a quote, or swapSpec (including the quotation marks) is greater than 126 
characters. An extremely long part reference or pin number that has been quoted by 
mistake can also cause the error.
[GAT0003] Expecting a pin identifier -- swapSpec. An incomplete pin swap 
specification is found. Two pins are expected in a pin swap specification after the part 
reference; one or both of these pin identifiers were missing.
[GAT0004] Misplaced VERSION keyword, VERSION is only allowed as the first 
keyword in a swap file. The VERSION keyword is found somewhere other than the first 
line. Gate and Pin Swap ignores the VERSION keyword anywhere else in the swap file.
[GAT0005] Ignoring extra tokens on line -- swapSpec. Extra tokens are found on a 
swap specification line. The swap specifications typically consist of a keyword followed by 
either two part references, or a part reference and two pins. The additional tokens are 
ignored.
[GAT0006] Swap file is empty. There are no swap specification lines in the swap file.
[GAT0007] Unable to open 'fileName'. The swap file is not found, or there is a problem 
opening it.
[GAT0008] Memory limit occurred while allocating data space. Gate and Pin Swap is 
unable to obtain sufficient memory to start. Free up some system memory, and then run 
Gate and Pin Swap again.
[GAT0009] Memory limit occurred while enlarging internal data space. Gate and Pin
Swap is unable to obtain sufficient memory to continue. Free up system memory, and then 
run Gate and Pin Swap again.
[GAT0010] Duplicate swap specification, reference (partRef) has already been 
swapped or changed. The part reference shown (partRef) is listed more than once. If a 
part reference is changed in either a GATESWAP or CHANGEREF specification, then another 
GATESWAP or CHANGEREF specification with the same part reference is not allowed in the 
same swap file.
For example, the following two swap specifications would not be allowed in the same swap 
file:

GATESWAP  U1  U2    ; U1 appears in two specifications
CHANGEREF U1  U10   ; in the same swap file.

However, a device within a package can be swapped along with the package. For example, 
the following specification is legal:

GATESWAP  U1A U1B   ; Swap gates A and B on U1.
CHANGEREF U1  U2    ; Swap U1 and U2.

[GAT0011] Cannot swap pins pin1 and pin2 of partRef because they are not 
located on the same device. One or both pins listed are not on the part shown (partRef). 



The pins must be on the same part.
[GAT0014] Pins pin1 and pin2 of partRef have different types/shapes, the pins will
not be swapped. The two pins differ in type or shape. Only pins of identical type and shape
can be swapped.
[GAT0016] Unable to change partRef1 to partRef2 because partRef1 was not 
found. A GATESWAP or CHANGEREF specification is not performed, typically because the 
part (partRef) is not found in the selected schematic pages.
[GAT0017] Unable to swap pins pin1 and pin2 of partRef because partRef was not 
found. A PINSWAP specification is not performed, because the part (partRef) is not found in 
the selected schematic pages.
[GAT0018] Unable to perform pinswap because pins pin1 and pin2 were not found 
on partRef. A PINSWAP specification is not performed, because the pins listed (pin1 and 
pin2) are not found in the part shown (partRef).
[GAT0019] ERROR (Line lineNum) Multi and single part per package swap is 
illegal -- swapSpec. A GATESWAP or CHANGEREF specification attempts to change a 
multiple-part package with a single-part package. The following example swap specification 
causes this error:

CHANGEREF U1A U2
[GAT0020] Multiple pins contain the same name, cannot swap 'pinName1' on 
'partRef' by pin name, swap by pin number instead. A PINSWAP specification refers to 
a pin by name, but the device contains multiple pins with the same name (differing only by 
pin number). To specify the pin unambiguously, refer to it by pin number.
[GAT0021] Unable to change partRef1 to partRef2 because partRef does not 
contain a device with a suffix of 'partRefSuffix'. One of the part references (partRef) 
refers to a device (partRefSuffix) that does not exist in the package definition. The following 
example swap specification causes this error by attempting to swap devices A and E on a 
quad NAND gate which defines suffixes A through D only:

CHANGEREF U1A U1E   ; Quad NAND gate
[GAT0022] A file must be selected in order to perform gate and pin swaps. This 
error arises when a swap file has not been selected in the Gate and Pin Swap dialog box. 
Select a swap file before choosing OK in the dialog box.
[GAT0023] Unable to perform pinswap, multiple pins contain pin number %1 on 
%2, swap using pin name instead. This error arises when the tool encounters two or 
more pins on a part with identical pin numbers. Capture responds by swapping the pin 
names instead. To avoid this problem, check that all pins on parts have unique pin numbers.
[GAT0024] Cannot perform gate swaps on a heterogeneous part, 'partName' will 
not be changed. This error arises when Capture attempts to swap gates on a 
heterogeneous part. Gate swaps can only be performed on homogeneous parts. Find and 
remove lines in the swap file attempting to swap gates on heterogeneous parts.
[GAT0025] (line %d) No valid update type parameter was found, either 
"parameter1" or "parameter2" must be specified as a parameter. This error occurs 
when a swap file includes update properties information, and the swap file attempts an 
update without specifying either parts or nets. In the swap file, find the section attempting 
an unspecified properties update, and add the appropriate parameter (Parts or Nets).
[GAT0026] Current view is incorrect for backannotations.    Change view and 



reprocess annotations. This error arises when the swap file is created for one view, but 
the design is currently in the other view. For example, this message is generated if the 
design is in physical view, but the swap file was written for the design in logical view. 
Change the view of the design.
[GAT0027] Possibly incorrect design loaded.    Current design is design1Name, 
back annotations are for design2Name. This error occurs when the current design name
doesn't match the name Capture stores in memory. For example, this message is generated 
when the design is renamed (using the Save As command on the File menu), and then 
Capture attempts to swap gates or pins. Avoid renaming a design just before using Gate and
Pin Swap. If the design has been renamed, close it, and reopen the design.



[IMPnnnn] error messages
The [IMPnnnn] messages are import property errors and warnings. Check that the export file 
exists and is not corrupted. Also check that you have followed the file format for export 
properties. Finally, check that you have not changed anything in the schematic or design 
since you created the export file, such as adding parts or changing from logical view to 
physical view.

Related topic
Editing property files 



[NETnnnn] error messages
[NET0002] Unable to get working directory of design. Capture was unable to get the 
current working directory for the design. This error can occur if the directory was deleted or 
renamed after the design was loaded into Capture.
[NET0003] Unable to change directory to that of design. Capture could not change to 
the current working directory for the design. This error can occur if the directory was deleted
or renamed after the design was loaded into Capture.
[NET0004] Unable to change drive to that of design. Capture could not access the 
drive that the design is located on. This error can occur if the directory was deleted or 
renamed after the design was loaded into Capture.
[NET0005] Unable to change back to starting directory. Capture cannot change back 
to the original directory it started in because the directory does not exist, or some other 
system error has occurred.
[NET0006] Unable to change back to starting drive. Capture cannot change back to 
the original drive it started on because the drive does not exist, or some other system error 
has occurred.
[NET0007] Out of memory or corrupt executable file. Capture attempted to launch 
IFORM while on Windows NT.
[NET0009] Not enough memory to start formatter. There are not enough system 
resources to launch IFORM.EXE.
[NET0010] Unable to run formatter. Capture was unable to run IFORM.EXE.
[NET0011] Netlist Failed. Capture was unsuccessful in generating a netlist.
[NET0014] Invalid hierarchy type. The check for a logical or physical design type failed. 
This error can occur when the design is corrupt.
[NET0015] Insufficient memory to start fileName. The system does not have enough 
memory left to open the specified netlist file with its associated editor.
[NET0016] There is no association for file fileName. The specified netlist file has no 
editor association in the File Manager. Go to the File Manager and create an association for 
the file.
[NET0017] Unable to open fileName. Capture could not open the specified netlist file 
with its associated editor.
[NET0018] Design is not annotated. Aborting. The design is not annotated.
[NET0019] Empty device designator encountered. Aborting. The entire design is not 
annotated.
[NET0020] Memory exhausted while loading parts. Capture ran out of memory while 
building the part table for netlisting.
[NET0021] Cannot get part. The netlister was unable to get a part instance while creating
is packing table. This error can occur when the design file is corrupt.
[NET0022] Cannot get UNIQUE part. A database error or corrupted design file prevented 
Capture from getting a unique part while building the part table.



[NET0023] Unrecognized string id. A database error, corrupted design file, or changed 
string ID prevented the netlist formatter from updating part properties.
[NET0024] Out of Memory during GetNexPartPin. Capture ran out of memory while 
trying to walk the pins on a part.
[NET0025] Invalid child. A database problem occurred when Capture retrieved the child 
instance and received an unexpected result.
[NET0026] Problem while retrieving part declarations. Capture encountered a 
corrupted part instance or similar database problem.
[NET0027] Problem getting child name. Capture encountered an instance of a child 
lacking an associated name. Check to see if you have a part non-primitive part without an 
attached schematic.
[NET0028] Unable to push onto sheet-stack. Capture ran out of system memory while 
creating the stack of sheet names.
[NET0029] Unable to load design hierarchy. The design failed to identify if it was in 
logical or physical view. Check to see if the design file is corrupt.
[NET0030] Unable to update flat nets. The database failed to produce a flat net. Check 
to see if the design file is corrupt.
[NET0031] Wrong object type for netlisting. The netlist formatter encountered an 
invalid object type. Check to see if you are netlisting a design and not a library. Also, check 
to see if the design file is corrupt.
[NET0032] Unable to create header structure. The netlist formatter encountered a 
problem with a title block. Check to see if the title block exists, and that it is complete.
[NET0033] Unable to create globals table. Capture ran out of memory while creating 
the table of global nets.
[NET0034] Initialization aborted. Capture was unable to complete the netlist.
[NET0035] Problem while loading parts table. Capture encountered a memory or 
database error while trying to load parts from the database into the part map. Check to see 
if the design file is corrupt.
[NET0036] Unable to load table of globals. Capture encountered a memory or database
error while trying to load parts from the database into the part map. Check to see if the 
design file is corrupt.
[NET0037] Unable to get next module port. Capture encountered a problem while 
traversing the list of module ports in the design. Check to see if the design file is corrupt.
[NET0038] Unable to get next net. Capture encountered a problem while getting nets, 
due to a database problem or system error. Check to see if the design file is corrupt.
[NET0039] Unable to get next port on node. Capture encountered a problem while 
getting nets, due to a database problem or system error. Check to see if the design file is 
corrupt.
[NET0040] Unable to get next pin on node. Capture encountered a problem while 
getting nets, due to a database problem or system error. Check to see if the design file is 
corrupt.
[NET0041] Unable to get property value. The database is corrupt or is missing a 



property. For example, this error would occur if your PCB Footprint property combine string 
was {PCB Footprint}{Foo} where Foo didn't exist. Check to see if all part properties exist, 
and if the design file is corrupt.
[NET0042] Unable to get next global. Capture failed to get the next global net from the 
database, and the database didn't indicate it was at the end of the list. Check to see if the 
design file is corrupt.
[NET0043] Unable to get next flat net. Capture failed to get the next global net from the
database, and the database didn't indicate it was at the end of the list. Check to see if the 
design file is corrupt.
[NET0044] Unable to get next port on current flat net. Capture failed to get the next 
global net from the database, and the database didn't indicate it was at the end of the list. 
Check to see if the design file is corrupt.
[NET0045] Unable to get next global on current flat net. Capture failed to get the 
next global net from the database, and the database didn't indicate it was at the end of the 
list. Check to see if the design file is corrupt.
[NET0046] Unable to create parts table. This error arises when Capture tries to allocate 
more memory for the part information table than what is available. Try closing down other 
applications that are running.
[NET0047] Cannot use BUSed pins in SPICE SUBCKT call. This error arises when the 
netlister encounters a part with a pin set to bus width. Replace the part with one that 
doesn't use a part with bussed pins.
[NET0048] Encountered reserved word reservedWord. This error arises when the 
netlister encounters the use of a reserved word for an object name in the schematic. Change
the object's name.
[NET0050] Design does not have a root schematic. This error arises when the netlister 
cannot find the root schematic. For example, this message is generated if the root schematic
is deleted from the design prior to creating the netlist. Choose Make Root Schematic from 
the Design menu in the design manager to set one of the schematics to the root.
[NET0051] Duplicate reference found 'patRef'. This error arises when the netlister 
encounters a duplicate reference in the design. Check the design for duplicate part 
references using Design Rules Check before creating the netlist.
[NET0052] Part partName does not have a    Value or Schematic (primitive 
hierarchical block). This error arises when a primitive hierarchical block is connected to a 
wire or net in a design. Set the hierarchical block's primitivity either to Default or No.
[NET0053] Unnamed bus for pin pinName. This will be unconnected in the netlist! 
This error arises when a bus doesn't have a name, or a valid range. This error can occur 
when an SDT design containing an unnamed bus is translated into Capture and then 
netlisted.
[NET0054] Part partName of type partRef is packaged incorrectly with parts of 
another type in the partRef package. This error arises when the netlister encounters 
one type of part that is packaged with another type of part. For example, this error is 
generated if a 74LS00
[NET0055] Illegal character in string:    charString. This error arises when the netlister 
encounters an invalid character in a particular string. For example, this error is generated if 
the character "#" appears in the name of a part while creating a Verilog netlist. Find and 



remove the illegal character.
[NET0056] Pin does not contain a number or a name.    partName may cause an 
invalid netlist. This error occurs when a pin doesn't have either a number or a name. Add a
pin number, a pin name, or both.
[NET0057] Netlist Canceled. This message occurs when the netlist is canceled by the 
Cancel button on the Netlist Generation dialog box.



[UPDnnnn] error messages
The [UPDnnnn] messages are update properties errors and warnings. Check that the export 
file exists and is not corrupted. Also check that you have followed the file format for update 
properties. You should also check that the combined property string of the first line will 
actually match up with properties in your design. For example, {PCB Footprint} and 
{Footprint} are not the same thing.

Related topics
Creating an update file 
Creating a combined swap and update file 
Combined property strings 
Update Properties command 



[XLTnnnn] error messages
[XLT0001] FileName is expected to be in SDT 386+ format. This error occurs when 
Capture expects the selected file to be in SDT 386+ format, but the file is of another format. 
Check to see if you selected the correct file, or that the file isn't corrupt.
[XLT0002] Reading SDT 386+ configuration file failed. This error occurs when Capture 
attempts to read SDT.CFG and encounters a problem. Check the SDT.CFG file to make sure it 
isn't corrupt.
[XLT0003] FileName is already open. Please close it before re-translating. This error
occurs when Capture attempts to translate the file, but the destination exists and is in use 
by another application. Close the file out of the other application and translate again.
[XLT0004] Translator encountered errors. Please check the Session Log. One or 
more errors or warnings occurred during the translation. Check the session log for more 
information.
[XLT0005] FileName is not a 386+ export block file. This error occurs when Capture 
attempts to translate the selected file when the file is not a 386+ export block file. Check to 
see that you selected the correct file, it is in the correct format, and that the file isn't 
corrupt.
[XLT0006] FileName is already open. Please close it before re-translating. This error
occurs when Capture attempts to translate the file, but the destination exists and is in use 
by another application. Close the file out of the other application and translate again.
[XLT0007] FileName, the runtime library cannot be accessed or created. This error 
arises when Capture cannot find or create CAPSYM.OLB.
[XLT0008] Cannot go back to SDT Release IV. Translate back to SDT 386+, then 
run 32TO16.EXE. This error occurs when Capture is unable to translate the design back to 
a Release IV schematic. Translate the Capture design into an SDT 386+ schematic first, and 
then run 32TO16.EXE to complete the translation.
[XLT0009] Cannot go back to SDT Release IV. Translate to SDT 386+, then run 
DECOMP.EXE to obtain an ASCII library source file. Then run Release IV's 
COMPOSER.EXE. This error occurs when Capture is unable to translate the library back to a
Release IV library. Translate the Capture library into an SDT 386+ library. Using the 
schematic, run DECOMP.EXE to obtain an ASCII library source file. Finally, run Release IV's 
COMPOSER.EXE to create the Release IV library.
[XLT0010] Release IV Export Block Files are not supported. This error occurs when 
Capture detects an attempt to translate a Release IV export block. Translation of Release IV 
export blocks are not supported by Capture.
[XLT0011] Translation was canceled by the user. Translation of the design or library 
was canceled before completion by the user. The design or library was not translated as a 
result.
[XLT0012] Capture library FileName exists. Please delete it and re-translate. This 
error occurs when Capture detects the existence of the specified library in the destination 
directory during a translation. Delete the library and translate again.
[XLT0013] Window's TEMP environment variable was not found. Capture 
temporary files will be created at design's directory. This error occurs when Capture 
cannot find the Window's TEMP environment variable during translation. Capture creates its 
temporary file in the design's specified directory as a result. To correct this problem, check 



to see if the TEMP environment variable is specified in your AUTOEXEC.BAT file. If it isn't, add
the following line and restart Windows:

SET TEMP=C:\WINDOWS\TEMP\
[XLT0014] 16bit Translator cannot find required EXE file: FileName. This error occurs
when Capture is unable to find the EXE file required to complete the translation. Locate the 
file and move it to the same directory as CAPTURE.EXE.
[XLT0015] 16bit Translator cannot find SDT.BCF or SDT.CFG files in the design 
directory or the TEMPLATE directory. Please provide one. This error occurs when 
Capture cannot find either an SDT.BCF or SDT.CFG file in the design directory or the 
TEMPLATE directory. Capture requires one of these files for a sample during translation. 
Locate one of these files and copy it into either the design directory or the TEMPLATE 
(destination) directory.
[XLT0016] Environment Variable envVar is not set. This error occurs when Capture 
requires the environment variable to be set. Check your AUTOEXEC.BAT file to see if the 
environment variable has been set. If the environment variable isn't set, add any necessary 
lines to the AUTOEXEC.BAT file, and restart Windows.
[XLT0017] Cannot change directory to dirPath. This error arises during translation of an
SDT Release IV design (or library), and Capture cannot save to the specified directory. Check 
the directory's properties to make sure it isn't a read-only directory.
[XLT0018] Cannot find FileName. This error arises when Capture cannot find the file 
SDT.CFG.
[XLT 0019] Cannot change drive to driveName. This error occurs when Capture cannot 
change to the specified drive to save the design or library.
[XLT0021] Cannot find symbol library FileName. A temporary one was created. This
message occurs when Capture could not find the file CAPSYM.OLB, so it created a temporary
one.
[XLT0022] Batch process failed. Please check SESSION LOG. This error occurs when 
Capture is unable to translate the file due to a problem with one of the translation programs.
This message often appears with another message like [XLT0014].
[XLT0023] Cannot save the input file to itself FileName. This error occurs when 
Capture attempts to save a translated file using the same filename and path. Save the file 
under a different name, path, or both.
[XLT0024] Not a pure SDT design. Subsheet file FileName, of Capture format will 
be left blank. This error occurs when Capture attempts to translate a design into SDT 
format when the file is not SDT compatible. Capture omits the schematics that violate SDT 
rules. You should run Design Rules Check with the Check SDT compatibility option set before 
translating a design or library to SDT.
[XLT0025] Cannot replace FileName, in use in memory. This error occurs when 
Capture attempts to save the file while it is in use by another application. Close the file out 
of all other applications.
[XLT0026] Failed allocating sufficient memory FileName. This error occurs when 
Capture fails to create a buffer for translating a design back to SDT, due to a lack of memory.
[XLT0027] Skipped design without root FileName. This error arises when Capture 
attempts to translate a design to SDT format, but the design has lost its root schematic. For 
example, this message is generated if you delete the root schematic, and then attempt to 



save the design in SDT format. Check that all designs have a root schematic before 
translating.
[XLT0028] Skipped design without view FileName. This error occurs when Capture 
attempts to translate a design that has no schematics. Check the design for schematics.
[XLT0029] The design lost its view FileName, which is an unrecoverable error. 
Please retry the translation. This error arises when an internal problem occurs during 
translation. Try translating the design or library again.
[XLT0030] Skipped heterogeneous part FileName. This type of part cannot be 
translated to SDT 386+. This error occurs when Capture encounters a heterogeneous part
during translation. Heterogeneous parts are not supported in SDT 386+. Capture doesn't 
translate the part. You should use Design Rules Check and specify Check SDT compatibility 
before translating a design or library back to SDT, and correct any incompatible objects.
[XLT0031] PartField FileName in SDT.CFG exceeds SDT 386+ length limit. The 
string was truncated. This error occurs when the specified part field in the SDT.CFG file 
exceeds the limit set for SDT 386+. Capture truncates the part field to fit within the limit.
[XLT0032] A wire auto-connection occurred. Please examine Wire (x1,y1) to 
(x2,y2) on page: pageName. This warning occurs when Capture auto-connects a wire to 
another wire or part during translation. Check the indicated wire to see if the connection is 
correct.
[XLT0033] An unconnected bus entry or a bus entry that connects to an unnamed 
bus was replaced by busName. This warning arises when a bus uses a bus entry to turn a
corner in an SDT design. Capture replaces the bus entry with a bus.
[XLT0035] FileName's partName does not exist. Please validate library translation.
This error arises when Capture cannot find a part while translating from SDT to Capture. For 
example, this message is generated when a part in an SDT file is corrupted. Check the files 
for corrupted parts.
[XLT0036] Release IV Library Translation failed. DOS Prompt did not log 
translation errors. Please run: COMP16.EXE %1. This error arises when Capture fails to 
completely translate a library to SDT Release IV. Complete the translation by running 
COMP16.EXE on the specified file.
[XLT0037] FileName not found. This warning occurs when Capture is unable to find one 
of the library files listed in the configuration file. Check all the schematic pages in the design
to make sure the translation was complete. If parts are missing from the design, locate the 
indicated library, and move it to the specified directory.
[XLT0038] [libName] not found. This error arises when Capture cannot find a library 
listed in the configuration file. Check SDT.CFG, PLDSDT.CFG, and VSTSDT.CFG (as 
appropriate) for the library. If it isn't present in the required configuration file, add it.



Report file messages
ERROR: Could not obtain include line. This error arises when Bill of Materials cannot get 
the next line from the include file. This could result from an unexpected EOF situation or 
some other critical error.
WARNING: Part is not in include file partName. This warning arises when Bill of 
Materials cannot find a match in the include file for a part in the design. This situation does 
not need to be fixed for Bill of Materials to function, but the warning may remind the user to 
add additional information to the include file.



Capture directory map
Capture's installation program creates the following directory structure.

CLICK ON A DIRECTORY 
FOR INFORMATION 
ABOUT ITS CONTENTS.
If necessary, Capture's installation program creates a directory in the WINDOWS\SYSTEM 
directory for WIN32S.EXE and related files:

CLICK ON A DIRECTORY 
FOR INFORMATION 
ABOUT ITS CONTENTS.

CAPTURE directory contents
CAPTURE.EXE
CAPTURE.HLP
CAPTURE.INI
*.EXE, *.PIF, *.DLL, and *.NT



Contains the OrCAD-supplied library (.OLB) files, including the CAPSYM.OLB symbol library.



Contains the netlist format files used by Capture.



Contains sample designs and SDT schematics and libraries.



Contains:
CAPTUTOR.EXE, Capture's tutorial---appears in the OrCAD Design Desktop program 

group as Tutorial
CAPTUTOR.HLP, the tutorial's online help
THREED.VBX
VBRUN300.DLL
Additional files required for the tutorial exercises



The Capture executable. It appears in the OrCAD Design Desktop program group as 
Capture.



Capture's online Help. It appears in the OrCAD Design Desktop program group as Capture 
On-line Help.



Capture's initialization file.



Executable files, program information files, and other files required by Capture.



Contains WIN32S.EXE and the related files required by Capture.



Sample report files
Report files contain useful information generated from the design tools. The specific type of 
information depends upon the tool used.

Report files
Update Properties
Design Rules Check
Cross Reference
Bill of Materials
Extract PLD

Output file
Sample .PLD file

Related topic
Report file messages



Update Properties sample report file

U1:  PCB Footprint   STUFFEDPlacedInstance I00002
U3:  PCB Footprint   STUFFEDPlacedInstance I00005
U2:  PCB Footprint   STUFFEDPlacedInstance I00006
U3:  PCB Footprint   STUFFEDPlacedInstance I00008
U2:  PCB Footprint   STUFFEDPlacedInstance I00010
U2:  PCB Footprint   STUFFEDPlacedInstance I00011

 

Related topics
Update Properties command
Sample report files



This report file was created using the following update file:
"{Value}""PCB Footprint"
"74LS04" "14DIP300"
"74LS08" "14DIP300"
"74LS32" "14DIP300"

The Update Properties command generates report files with .RPT file extensions. Update 
files typically have .UPD file extensions.



Design Rules Check sample report file

Design Rules Check

----------------------------------------
Checking Schematic: FULLADD
----------------------------------------
Checking Electrical Rules 
ERROR:  [DRC0004]  Possible pin type conflict halfadd_A,SUM Output Connected to Bidirectional Port

Checking for Unconnected Wires

Checking Pin to Port Connections
WARNING:  [DRC0013]  Port has no matching pin in part instance above Z
WARNING:  [DRC0013]  Port has no matching pin in part instance above Z

Checking for Duplicate References

Checking for Compatibility with SDT

Reporting Ports
    X
    Y
    CARRY_IN
    CARRY_OUT
    SUM

Reporting Globals
    VCC
    GND

Reporting Net Names
    N00032
    N00030
    N00028
    Y
    X
    SUM
    CARRY_IN
    GND
    VCC
    CARRY_OUT

----------------------------------------
Checking Schematic: HALFADD
----------------------------------------
Checking Electrical Rules 
ERROR:  [DRC0004]  Possible pin type conflict U2A,O Output Connected to Input Port
WARNING:  [DRC0005]  Unconnected pin U2A,I1

Checking for Unconnected Wires
WARNING:  [DRC0007]  Net has no driving source N00041
WARNING:  [DRC0006]  Net has fewer than two connections N00041

Checking Pin to Port Connections



Checking for Duplicate References
WARNING:  [DRC10]  Duplicate reference U2A

Checking for Compatibility with SDT
ERROR:  [DRC0025]  The comment graphic is not a single dashed line I00042
ERROR:  [DRC0025]  The comment graphic is not a single dashed line I00052

Reporting Ports
    X
    Y
    Z
    CARRY
    SUM

Reporting Globals
    VCC
    GND

Reporting Net Names
    Z
    N00067
    X
    N00041
    N00035
    X_BAR
    Y
    CARRY
    SUM
    N00007
    GND
    VCC

Related topics
Design Rules Check command
Sample report files



The Design Rules Check command generates report files with .DRC extensions.



Cross Reference sample report file

1 Bit Full Adder Hierarchy  (COMPLEX)  Revised:  March    31, 1995

OrCAD

Design Name:  C:\CAPTURE\DESIGN\FULLADD.DSN

Cross Reference      March   31, 1995 16:15:54 Page    1

 Item   Part     Reference  SchematicName       Sheet     Library
____________________________________________________________________________

    1   74LS04    U3A         HALFADD            1       C:\WINDOWS\TEMP\TTL.OLB
    2   74LS04    U3B         HALFADD            1       C:\WINDOWS\TEMP\TTL.OLB
    3   74LS08    U2A         HALFADD            1       C:\WINDOWS\TEMP\TTL.OLB
    4   74LS08    U2B         HALFADD            1       C:\WINDOWS\TEMP\TTL.OLB
    5   74LS08    U2C         HALFADD            1       C:\WINDOWS\TEMP\TTL.OLB
    6   74LS32    U1B         HALFADD            1       C:\WINDOWS\TEMP\TTL.OLB

Related topics
Cross Reference command
Sample report files



The Cross Reference command generates report files with .XRF extensions.



Bill of Materials sample report file

1 Bit Full Adder Hierarchy  (COMPLEX)  Revised:  March    31, 1995

OrCAD

Bill Of Materials     March   31, 1995 16:50:31 Page    1

 Item  Quantity  Reference Part    
______________________________________________

    1     1 U1 74LS32
    2     3 U2 74LS08

 U2 74LS08
U2 74LS08

    3     2 U3 74LS04
U3 74LS04

Related topics
Bill of Materials command
Sample report files



The Bill of Materials command generates report files with .BOM extensions.



Extract PLD sample .PLD file
|"T1_1800C" 14:I1,
|           15:I2,
|           16:I3,
|           20:I4,
|           21:I5,
|           22:I6,
|           56:I7,
|           55:I8,
|           2:AIO1,
|           3:AIO2,
|           4:AIO3,
|           5:AIO4,
|           6:AIO5,
|           7:AIO6,
|           8:AIO7,
|           9:AIO8,
|           10:AIO9,
|           11:AIO10,
|           12:AIO11,
|           13:AIO12,
|           23:BIO13,
|           24:BIO14,
|           25:BIO15,
|           26:BIO16,
|           27:BIO17,
|           28:BIO18,
|           29:BIO19,
|           30:BIO20,
|           31:BIO21,
|           32:BIO22,
|           33:BIO23,
|           34:BIO24,
|           36:CIO25,
|           37:CIO26,
|           38:CIO27,
|           39:CIO28,
|           40:CIO29,
|           41:CIO30,
|           42:CIO31,
|           44:CIO33,
|           45:CIO34,
|           46:CIO35\,
|           47:CIO36,
|           57:DIO37,
|           58:DIO38,
|           59:DIO39,
|           60:DIO40,
|           61:DIO41,
|           62:DIO42,
|           63:DIO43,
|           64:DIO44,
|           65:DIO45,
|           66:DIO46,
|           67:DIO47,



|           68:DIO48,
|           43:CIO32,
|           54:I9,
|           50:I10,
|           49:I11,
|           48:I12,
|           17:CLK1,
|           19:CLK2,
|           51:CLK3,
|           53:CLK4
|
|Value:   "T1_1800C"
|Type:    "T1_1800C"
|Part:    "T1_1800C"
|Library: ""
|
|Title:   "Test Equations for the EP1800 EPLD"
|Title:   "      March 31, 1995"
|Title:   "900513-A"
|Title:   "Revision  1"
|Title:   "Testing and Special Projects"
|Title:   "OrCAD Inc."
|Title:   "9300 SW Nimbus Avenue"
|Title:   "Portland, OR 97008-7137"
|

This PLD file provides a Basic Funtion test
for COLUMN placement for the INPUT pins.
This PLD file should also provide a test for
automatic REGISTER BYPASS and THREE-STATE
buffering as well as disabling the ASYNC. CLEAR
product term.

|Active-HIGH: I[1~12], CLK[1~4]
| Active-LOW: AIO[1~12],
|             BIO[13~24],
|             CIO[25~36],
|             DIO[37~48]

|AIO1  = CLK1 ## I1
|AIO2  = CLK1 ## I2
|AIO3  = CLK1 ## I3
|AIO4  = CLK1 ## I4
|AIO5  = CLK1 ## I5
|AIO6  = CLK1 ## I6
|AIO7  = CLK1 ## I7
|AIO8  = CLK1 ## I8
|AIO9  = CLK1 ## I9
|AIO10 = CLK1 ## I10
|AIO11 = CLK1 ## I11
|AIO12 = CLK1 ## I12

|BIO13 = CLK2 ## I1
|BIO14 = CLK2 ## I2
|BIO15 = CLK2 ## I3
|BIO16 = CLK2 ## I4



|BIO17 = CLK2 ## I5
|BIO18 = CLK2 ## I6
|BIO19 = CLK2 ## I7
|BIO20 = CLK2 ## I8
|BIO21 = CLK2 ## I9
|BIO22 = CLK2 ## I10
|BIO23 = CLK2 ## I11
|BIO24 = CLK2 ## I12

|CIO25 = CLK3 ## I1
|CIO26 = CLK3 ## I2
|CIO27 = CLK3 ## I3
|CIO28 = CLK3 ## I4
|CIO29 = CLK3 ## I5
|CIO30 = CLK3 ## I6
|CIO31 = CLK3 ## I7
|CIO32 = CLK3 ## I8
|CIO33 = CLK3 ## I9
|CIO34 = CLK3 ## I10
|CIO35 = CLK3 ## I11
|CIO36 = CLK3 ## I12

|DIO37 = CLK4 ## I1
|DIO38 = CLK4 ## I2
|DIO39 = CLK4 ## I3
|DIO40 = CLK4 ## I4
|DIO41 = CLK4 ## I5
|DIO42 = CLK4 ## I6
|DIO43 = CLK4 ## I7
|DIO44 = CLK4 ## I8
|DIO45 = CLK4 ## I9
|DIO46 = CLK4 ## I10
|DIO47 = CLK4 ## I11
|DIO48 = CLK4 ## I12

Related topics
Extract PLD command
Sample report files





Glossary
CHOOSE A LETTER BUTTON, OR SCROLL TO THE WORD YOU WANT.

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A
alias
ANSI
arrow keys
ascend
ASCII

B
back annotate
BBS



bookmark
browse pane
bulletin board system

C
CAGE code
child
Clipboard
complex hierarchy
convert

D
DeMorgan equivalent
descend
design
design cache
design manager
design structure pane
device-fitter
document
DRC

E
equivalent
ERC

F
flat design

G
graphic object
grid reference

H
heterogeneous part
hierarchical block
hierarchical port
hierarchical design
homogeneous part

I
inherent property
instance
instance property

J-K
K
kilobyte

L
library
location
logical view

M



macrofunction
MB
megabyte
mirror

N
net
net alias
netlist
nonprimitive

O
occurrence
occurrence property
off-page connector

P
package
pan
parent
part alias
part editor
part instance
part primitive
PCB
physical view
place and route
PLD
port
primitive
property
programmable logic device

Q-R
RAM
random access memory
recursive design
root schematic

S
scalar
schematic
schematic page
schematic page editor
session frame
session log
simple hierarchy
spreadsheet editor

T
tabbed dialog box

U
user-defined property



V-Z
zoom
zoom factor
zoom scale



alias
See net alias, part alias.



ANSI
Pronounced "ansee." Acronym for American National Standards Institute, an organization 
formed by industry and the U.S. government to develop trade and communication 
standards. Internationally, ANSI is the American representative to the ISO (International 
Standards Organization). See also ASCII.



arrow keys
On your computer keyboard, the keys you use to navigate around your screen. Each key is 
marked with an arrow and is named for the direction in which the arrow points. There is an 
up arrow, down arrow, left arrow, and right arrow key. Also known as direction keys.



ascend
In a hierarchical design, to move from a child schematic page to its parent schematic page.
This is done in the schematic page editor using the Ascend Hierarchy command on the 
View menu. See also descend.



ASCII
Pronounced "askee." Acronym for American Standard Code for Information Interchange; a 
seven-bit code---based on the first 128 characters of the ANSI character set---that assigns 
numeric values to letters of the alphabet, the ten decimal digits, punctuation marks, and 
other characters such as Backspace, Carriage Return, and Line Feed. ASCII is the most 
widely used character-coding set, and as such enables different applications and computers
to exchange information.



back annotate
To apply modifications to part properties in a schematic, such as updating part references 
and pin numbers, swapping gates, or swapping pins. Properties are back annotated in the 
design manager, using the Gate and Pin Swap command or the Update Properties 
command on the Tools menu.



BBS
See bulletin board system.



bookmark
Just as you can place bookmarks in a book to mark a specific place, you can place 
bookmarks on a schematic page to indicate a location you would like to return to 
frequently. To place a bookmark, use the Bookmark command on the Place menu in the 
schematic page editor. To go to a bookmark when in the schematic page editor, use the Go 
To command on the View menu. To go to a bookmark when in the design manager, use the 
Browse command on the Edit menu to display bookmarks in the browse pane, and then 
choose the bookmark.



browse pane
The right pane of the design manager window. This pane displays the results of queries 
done using the Browse or Find commands on the Edit menu. You can double-click on an 
object in the browse pane to go to that item on a schematic page. See also design structure
pane.



bulletin board system
A computer system equipped with one or more modems that serves as an information and 
message-passing center for dial-in users. Abbreviated BBS.



bus pin
A pin width that can carry multiple signals, as opposed to a scalar that carries only one 
signal.



CAGE code
Abbreviation for Commercial and Government Entity Code. A number---provided by the 
federal government to its suppliers---that can be present in the title block of a schematic 
page.



child
In a hierarchical design, a schematic whose circuitry is represented by a hierarchical block 
in the parent schematic page. To move from parent to child is to descend the hierarchy. 
This is done in the schematic page editor by selecting the hierarchical block representing 
the child, and then choosing the Descend Hierarchy command on the View menu. A child 
contains circuitry referenced by its parent. The child may contain hierarchical ports that 
connect its signals to signals on the parent or to signals on other pages of the schematic. 
See also ascend.



Clipboard
A temporary storage location used to transfer data between files and between applications.
You transfer data to the Clipboard by using the Copy or Cut command on the Edit menu, 
and you insert data from the Clipboard by using the Paste command on the Edit menu.



complex hierarchy
A design in which two or more hierarchical blocks (or parts with attached schematics) 
reference the same schematic. In the design manager, you can view a complex hierarchy 
two ways: In the logical view, you see one schematic that represents all references to that 
schematic, while in the physical view, you see a separate schematic for each reference to 
that schematic. See also hierarchical design, simple hierarchy.



convert
An alternate form---such as a DeMorgan equivalent---that can be stored with each part.



DeMorgan equivalent
An electrically-equivalent part based on the DeMorgan rules of equivalence. These rules 
represent the duality of AND and OR in Boolean expressions: if all AND operations are 
changed to OR operations, all OR operations are changed to AND operations, and all 
variables and constants are negated, then the value of the expression remains unchanged. 
A DeMorgan equivalent can be stored in the convert of a part.



descend
In a hierarchical design, to open and view the child schematic represented by a hierarchical
block in the parent schematic. To descend a hierarchical design, you select a hierarchical 
block in the schematic page editor, and then choose the Descend Hierarchy command from
the View menu. See also ascend.



design
In Capture, a single file that includes all of the schematics, schematic pages, parts, and 
symbols that make up a design. You can view these design elements in the design 
manager. A basic design contains one schematic and one schematic page, while a 
complicated design may contain a virtually unlimited number of schematics, each with 
many schematic pages.



design cache
A local library contained in each design that contains all the parts and symbols used in the 
design.



design manager
The Capture window used to perform design-wide tasks, such as locating groups of objects 
or specific objects, creating a netlist, or generating reports.



design structure pane
The left pane of the design manager window. This pane displays the structure of the 
schematics and schematic pages contained in a design. You can view the design structure 
in logical view (which shows one schematic page that represents all references to that 
schematic page) or in physical view (which shows a separate schematic page for each 
reference to that schematic page). See also browse pane, hierarchical design, complex 
hierarchy, simple hierarchy.



device-fitter
A software tool to implement a logic design (usually recorded as an Open-PLA or gate-level 
netlist) into the physical resources of a CPLD.



document
A design, schematic page, library, part, or symbol. Each of these is part of a design file or a 
library file.



DRC
The abbreviation for Design Rules Check, a tool found on the Tools menu in the design 
manager. This tool checks a design (or a subset of the design) for conformance to a set of 
configurable design criteria and electrical rules for creating netlists.



equivalent
See convert, DeMorgan equivalent.



ERC
The abbreviation for Electrical Rules Check, a subset of the Design Rules Check tool found 
on the Tools menu in the design manager. The ERC matrix is the decision matrix that tells 
the Design Rules Check tool the conditions to check for when evaluating connections 
between pins, hierarchical ports, and off-page connectors.



flat design
A schematic structure without hierarchy (no hierarchical blocks or ports; no parts with 
attached schematics). A flat design can include schematic pages in which output lines of 
one schematic page connect laterally to input lines of another schematic page through 
objects called off-page connectors. You place this object using the Off-Page Connector 
command on the Place menu in the schematic page editor. Flat designs are practical for 
small designs with few schematic pages. See also hierarchical design, complex hierarchy, 
simple hierarchy.



graphic object
An object drawn or placed on a schematic page or part---such as an arc, line, rectangle, 
ellipse, polygon, bitmap, or text---that has no electrical connectivity.



grid references
The border around a schematic page, providing a visual reference to the grid. Grid 
references can be used as a destination for the Go To command on the View menu. Grid 
references can be set to visible or hidden in both the Design Template and Schematic Page 
Properties commands on the Options menu.



heterogeneous part
A package with multiple parts that are graphically different or contain different numbers of 
pins (for example, a relay). See also homogeneous part.



hierarchical block
A symbol that refers to a child schematic in a design. The connection points on a 
hierarchical block are called hierarchical ports. You place a hierarchical block using the 
Hierarchical Block command on the Place menu.



hierarchical design
A design structure in which schematics are interconnected vertically with hierarchical 
blocks. At least one schematic page, the root, contains symbols representing other 
schematics. See also complex hierarchy, simple hierarchy, flat design.



hierarchical port
A symbol that specifies that a signal on one schematic page connects to a signal on 
another schematic page. A hierarchical port includes a name and a type (either scalar or 
bus), and may be part of a hierarchical block. You place a hierarchical port using the 
Hierarchical Port command on the Place menu.



homogeneous part
A package with multiple parts that are graphically identical. See also heterogeneous part.



inherent property
One of the set of properties required for a given object. Unlike user-defined properties, 
inherent properties cannot be removed.



instance
A part or symbol placed on a schematic page. You place part instances in logical view. If 
you change to physical view, you see occurrences of the part instances.



instance property
A property that is attached to an instance, as opposed to a property that is attached to an 
occurrence or added to a part in a library. You edit instance properties in logical view. 
Instance properties can be overridden by occurrence properties, which are not reflected on 
the instance.



K
The abbreviation for kilobyte.



kilobyte
2  (1,024) bytes. The prefix kilo is taken from the metric system, where it stands for "one 
thousand." Abbreviated K.



library
A collection of often-used parts, graphics, schematic pages, and symbols.



location
An X, Y coordinate on the schematic page or part. You can move to a location using the Go 
To command on the View menu.



logical view
A view that displays the "folded" view of a design, and thus part references and pin 
numbers on part instances. Note that logical view doesn't reflect any changes made to 
occurrences in physical view. To display the logical view of a design, use the Logical 
command on the View menu in the design manager. See also instance.



macrofunction
A high-level building block made of two or more primitives. Muxes, counters, and adders 
are examples of macrofunctions.



MB
The abbreviation for megabyte.



megabyte
2  (1,048,576) bytes. The prefix mega is taken from the metric system, where it stands for 
"one million." Abbreviated MB.



mirror
To flip along the X (horizontal) or Y (vertical) axis, or both.



net
All of the wires, buses, parts, and symbols that are logically connected via net names, net 
aliases, off-page connectors, and hierarchical ports.



net alias
A name used to specify signal connections between unconnected wires or buses. For 
example, if you have wires in two remote locations in a schematic, you can assign each 
wire an alias such as "ABC" to connect the signals without physically drawing a wire 
between them.



netlist
An ASCII file that lists the interconnections of a schematic by the names of the connected 
signals, parts, and pins.



nonprimitive
A part with an underlying hierarchy, such as an attached schematic.



occurrence
An instance, placed on a schematic page, as displayed in physical view. You can edit 
properties on occurrences, but you cannot edit an occurrence's physical appearance (such 
as the shape of a hierarchical block).



occurrence property
A property that is attached to an occurrence, as opposed to a property that is attached to 
an instance or added to a part in a library. You edit occurrence properties in physical view. 
Occurrence properties override instance properties, but are not reflected on the instance.



off-page connector
An object that conducts signals between schematic pages within a schematic. See also flat 
design, hierarchical port.



package
A physical part that contains more than one logical part. For example, a 2N3905 transistor, 
a fuse, and a 74LS00 are packages. Each part in a package has a unique part reference 
comprised of a prefix common to all the parts in the package, and a letter unique to each 
part. For example, a 74LS00 whose part reference prefix is U15 would have four parts 
whose part references are U15A, U15B, U15C, and U15D. See also homogeneous part, 
heterogeneous part.



pan
To change the portion of the schematic page or part being viewed by dragging objects from
one location to another. As you drag the object, the schematic page or part pans across the
active window.



parent
A schematic that contains a hierarchical block that refers to another schematic (called a 
child).



part alias
A duplicate copy of a part using a different name in a library. A part alias uses the same 
graphics, attached schematics, and properties as the original, with the exception of the 
part value.



part editor
The editor used to create and edit parts and symbols.



part instance
An instance of a part.



part primitive
See primitive.



PCB
Abbreviation for printed circuit board.



physical view
A view that displays the "unfolded" view of a design, and thus part references, pin 
numbers, or properties on occurrences of part instances. Since changes made to part 
references and pin numbers on occurrences of part instances override the values on the 
original part instance, this view gives you an opportunity to customize specific part 
instance occurrences without affecting the original part instance. To display the physical 
view of a design, use the Physical command on the View menu in the design manager. See 
also instance, logical view.



place-and-route
A software tool to implement a logic design (usually recorded as a gate-level netlist) into 
the physical resources of an FPGA.



PLD
Abbreviation for programmable logic device.



port
See hierarchical port.



primitive
A part or hierarchical block with no underlying hierarchy.



property
A characteristic of an object that can be edited. A property consists of a name and a value. 
Examples of property names are part value and color. Their respective property values can 
be something such as capacitor and red.



programmable logic device
A type of integrated circuit whose behavior can be determined by programming it. 
Abbreviated PLD.



RAM
The acronym for random access memory.



random access memory
The memory that can be used by applications to perform necessary tasks while the 
computer is on. When you turn the computer off, all information in random access memory 
is lost. Abbreviated RAM.



recursive design
A hierarchical design in which a schematic in the hierarchy is attached to a part instance or
hierarchical block placed "higher" in the hierarchy. The simplest case of recursion is some 
schematic X containing a part instance or hierarchical block to which schematic X is 
attached. For related information, see Establishing connectivity between schematic pages.



root schematic
The schematic at the top of a flat or hierarchical design. The root schematic contains a 
backslash ( \ ) in its icon in the design manager. A design has only one root schematic.



scalar
A pin width that carries only one signal, as opposed to a bus pin that can carry multiple 
signals.



schematic
A graphical representation of a circuit using a standard set of electronics symbols. In 
Capture, a collection of all schematic pages at the same level of hierarchy in a design. In 
the design manager, a schematic behaves like a container or DOS directory. See also flat 
design, hierarchical design, schematic page, root schematic.



schematic page
The sheets of paper on which schematics are drawn. Schematic pages appear in a window, 
called the schematic page editor, in which you can place parts and draw wires.



schematic page editor
The editor used to create and edit schematic pages.



session frame
The Capture application window in which the various components of Capture---such as the 
session log, design manager, schematic page editor, and part editor---run.



session log
A window that displays text messages generated by Capture, such as errors and 
informational messages. The session log starts empty with each new Capture session, but 
you can save its contents to a text file.



simple hierarchy
A design in which there is a one-to-one correspondence between hierarchical blocks (or 
parts with attached schematics) and the schematic pages they reference. Each hierarchical
block (or part with attached schematic) represents a unique schematic page. See also 
hierarchical design, complex hierarchy.



spreadsheet editor
A window used to edit the properties of multiple objects at once.



tabbed dialog box
A dialog box that has different views you can display by clicking on tabs at the top of the 
dialog box.



user-defined property
A property you add to an object. Unlike inherent properties, user-defined properties can be 
removed.



zoom
To change the view of a window, making objects appear larger or smaller. When you zoom 
out, objects are smaller, and you see more of the schematic page or part. When you zoom 
in, objects are larger, but you only see a small portion of the schematic page or part.



zoom factor
The amount by which the zoom scale is multiplied or divided when you choose Zoom In or 
Zoom Out on the View menu. The Zoom factor is normally 2, but you can change it using 
the Preferences command on the Options menu. For example, a zoom scale of two makes 
the image on the screen twice as large when you zoom in and half as large when you zoom 
out.



zoom scale
The relative size of the image on the screen, as a percentage of the normal size. For 
example, a zoom scale of 250% means the image on the screen is two and one-half times 
as large as normal.



End of the Glossary.



Help for SDT users
Translating files

Translating SDT     386+ and Release     IV schematics and libraries  

Mapping Design Management Tools and SDT tasks to Capture commands
Mapping ESP and SDT tools and commands to Capture commands

Mapping SDT objects to Capture objects
Help understanding Capture objects

Mapping SDT terms to Capture terms
Help understanding new terms in Capture for Windows

Connectivitity differences between Capture and SDT
Help understanding SDT and Capture connectivity differences



Translating files
Capture can translate SDT files and libraries in SDT 386+ and Release IV formats to the 
Capture format. Capture can also translate its own designs and libraries into SDT 386+ and 
Release IV formats.

Opening SDT files
Opening a schematic created in SDT
Opening a library created in SDT
Creating a library with sheetpath parts

Creating SDT files
Saving in SDT format

Reusing supplemental files
Creating a swap file (Was/Is file)
Creating an update file
Creating an include file

SDT Part fields
Translating part fields



Opening a schematic created in SDT
OrCAD Capture for Windows can translate flat and hierarchical designs created in SDT 
Release IV and SDT 386+.

Translation requirements

Capture includes the following DOS utilities, which it uses to translate a design from SDT:
16TO32.EXE
DECOMP16.EXE
COMPOSER.EXE
SDT_C.EXE

These utilities must be located in one of the following areas:
The current directory
The directory that contains the design
The directory that contains CAPTURE.EXE
The directory specified by the ORCADPROJ environment variable

Either an SDT.CFG file or an SDT.BCF file (Release IV) must exist in one of the following 
places:

The current directory
The directory that contains the design
The directory specified by the ORCADPROJ environment variable

All necessary libraries (.LIB files) must be present in of the following places:
The current directory
The directory that contains the design

 

To translate from SDT to Capture
1 If you need to change the name of a part field, open the design's configuration file and 

make the necessary changes. See Translating part fields for more information.
2 Specify any user properties you want created from SDT part fields in the SDT 

Compatibility tab of the Design Template dialog box. For more information on translating 
part fields in Capture, see Translating part fields.

3 From the File Menu, choose Open, and then choose Design (ALT, F, O, D).
The Open Design dialog displays.

4 In the List Files of Type box, select SDT Design (*.SCH) or select All Files (*.*).
5 If the schematic name is not listed in the File Name box, do one or both of the following:

In the Drives box, select a new drive.
In the Directory box, select a new directory.

6 Select the schematic and click OK.
The schematic structure of the translated schematic displays in the design structure pane.

Any sheet parts and sheetpath parts are converted to hierarchical blocks, which you 
can display by choosing Descend Hierarchy on the View menu.

Any module ports are converted to off-page connectors (for a flat design) or 
hierarchical ports (for a hierarchical design).

Any |LINK statements and comments are converted to text. Connectivity is not 
maintained by |LINK statements.

Related topics
Translating part fields



Connectivity differences between Capture and SDT 
Descend Hierarchy command



You do not need to move any files (including DOS utilities) if your design is correctly 
specified for SDT, to translate SDT designs into Capture.



If you have changed your environment, it may be useful to keep your .LIB files in the same 
directory as their associated SDT.CFG and SDT.BCF files.



Before the design or library is translated, the Save As dialog box appears. Do not choose 
the Cancel button, unless you want to abandon the translation. If you do choose the Cancel
button, Capture will not translate the design or library.



Before the design or library is translated, the Save As dialog box appears. Do not choose 
the Cancel button, unless you want to abandon the translation. If you do choose the Cancel
button, Capture will not translate the design or library.



Opening a library created in SDT
OrCAD Capture for Windows can translate libraries created in SDT Release IV and SDT 386+.

Translation requirements

Capture requires the following DOS utilities to translate a design from SDT:
32TO16.EXE
DECOMP.EXE
COMP16.EXE

These utilities must be located in one of the following areas:
The current directory
The design directory (if different from the current directory)
The CAPTURE.EXE directory
A directory specified by the ORCADPROJ environment variable

The library to be translated must be in one of the following places:
The current directory
The design directory (if different from the current directory)

To translate from SDT to Capture
1 If you need to change the name of a part field, open the design's configuration file and 

make the necessary changes. See Translating part fields for more information.
2 From the File Menu, choose Open, and then choose Library (ALT, F, O, L).

The Open Library dialog box displays. 
3 In the List Files of Type box, select the library type SDT Library (*.LIB) or select All Files 

(*.*). 
4 If the library name is not listed in the File Name box, do one or both of the following:

In the Drives box, select a new drive.
In the Directory box, select a new directory.

5 Select the library file to open or type the name in the File Name entry box, and click OK.

SDT Release IV and SDT 386+ ASCII (.SRC) libraries

Capture translates the ASCII (.SRC) file to SDT 386+ (.LIB) format, and then translates that 
to OrCAD Capture for Windows (.OLB) format.
The structure of the translated library displays in the design structure pane.

SDT Release IV binary (.LIB) libraries

Capture translates the SDT Release IV (.LIB) file to ASCII (.SRC) format. Capture then 
translates that to SDT 386+ (.LIB) format. Finally, Capture translates that to OrCAD Capture 
for Windows (.OLB) format. Capture translates bitmap parts to vectors.
The structure of the translated library displays in the design structure pane.

SDT 386+ binary (.lib) libraries

Capture translates the SDT 386+ (.LIB) file to OrCAD Capture for Windows (.OLB) format.
The structure of the translated library displays in the design structure pane.



Creating a library with sheetpath parts
When you translate a design from SDT to Capture, any sheetpath parts become non-
primitive parts which descend into another schematic. This schematic is also contained in 
the Capture design. When you translate an SDT library with references to other schematics, 
Capture translates these schematics and stores them in the library.
You can set up your Capture design to act similar in regards to sheetpath parts.
To set up a design to emulate sheetpath part behavior
1 Translate the SDT design.
2 Translate the SDT library that contains the sheetpath parts.
3 In the design, remove all schematics that correspond to the sheetpath part schematics.
4 Open the schematic pages with the translated sheetpath parts, and select one of these 

parts.
5 From the Edit menu, choose Properties.
6 Choose Attach Schematic.
7 Enter the name and path of the library containing the schematic emulating the sheetpath 

part.
8 Choose OK twice.
9 Select another part, and repeat steps 5 through 9 until all of the necessary parts have 

attached schematics.

Processing guidelines

Once you have set up your design, follow these guidelines for processing it:
Set your design's part primitivity to default on the Hierarchy tab of the Design 

Properties dialog box when updating part references. This prevents Capture from annotating 
the schematics stored in your library.

Set your design's part primitivity to nonprimitive on the Hierarchy tab of the Design 
Properties dialog box when netlisting. This allows the netlist formatter to descend the 
hierarchy into the schematics stored in your library.

Related topics
Opening a schematic created in SDT 
Opening a library created in SDT 
About hierarchical blocks 
Design Properties command



Before you translate an SDT library containing sheetpath parts, the SDT.CFG file must be 
present in the directory where translated library will be saved.

The PLIB line in SDT.CFG should contain the valid path where the source libraries are 
present.



Before you translate an SDT library containing sheetpath parts, the SDT.CFG file must be 
present in the directory where translated library will be saved.

The PLIB line in SDT.CFG should contain the valid path where the source libraries are 
present.



Saving in SDT format
Capture can translate designs and libraries to SDT 386+ and SDT Release IV format.

Guidelines for creating an SDT compatible design

Not all designs you make in Capture are compatible with SDT. If you want to make your 
Capture design SDT compatible, follow these rules:

Do not place bus-width pins on part instances.
Do not create heterogeneous parts.
Do not create packages with more than sixteen parts.
Do not create parts or part instances with more than seven user-defined properties.
Do not put properties on wires, hierarchical ports, power or ground pins, or off-page 

connectors.
Do not create hierarchical blocks with hierarchical ports on top or bottom.
Do not use numeric pin numbers greater than 255.
Use one title block only.
Do not create a multiple-page schematic in a multiple-level design. In other words, 

you can use either off-page connectors or hierarchical blocks, but not both. (If you use 
hierarchical blocks, each must be mapped to a schematic containing a single schematic 
page.)

Do not use graphics. (You can use lines of text characters, instead.)
Use eight characters or fewer (not including extensions) for schematic page names.
Do not move net aliases off of wires or busses. If you do, the wire or bus will be 

disconnected.
When you run a design rules check on your design with the Check SDT compatibility option 
selected, Capture checks for violations of these rules.
In addition to following these guidelines, an SDT.CFG file must exist in the same directory as 
your design or in the directory specified by your ORCADPROJ environment variable.

To save a design or library in SDT format
1 Run a design rules check on your design using the Check SDT compatibility option.

If Capture reports any errors, correct them before saving the design or library in SDT 
format. For more information about design rules check messages, see Error messages.

2 In the Design Properties dialog box, specify which properties you want mapped to each 
SDT part field. For more information, see Translating part fields.

3 From the design manager's File menu, choose Save As (ALT, F, S). The Save As dialog box 
displays.

4 In the Save File as Type box, select either SDT 386+ or SDT Release IV (.SCH for 
schematic or .LIB for library).

5 Type the name in the File Name entry box, and choose OK.

Related topics
Checking for design rule violations
Error messages
Design Rules Check back annotation
Interpreting Design Rules Check reports
Translating part fields
Design rules check command



Capture truncates schematic page names to eight characters. Before you save a design or 
library in SDT format, make sure schematic page names are unique within the first eight 
characters.



Capture truncates schematic page names to eight characters. Before you save a design or 
library in SDT format, make sure schematic page names are unique within the first eight 
characters.



Translating part fields
Capture uses the SDT compatibility options in the Design Template dialog box when you 
save a Capture design in SDT format. Capture sets the SDT compatibility options in the 
Design Properties dialog box when you open an SDT schematic (.SCH) file in Capture.

Setting up the design template

When you create a new design, the SDT compatibility options are inherited from the design 
template. Follow these steps to set up the design template for SDT compatibility:
1 From the Options menu, choose Design Template, and choose the SDT Compatibility tab.
2 Specify the properties you want to map to the SDT part fields for future designs.

Changing the SDT compatibility options for a single design

When you save a design in SDT format, Capture uses the SDT compatibility options in the 
Design Properties dialog box. Follow these steps to change a design's SDT compatibility 
options:
1 From the Options menu, choose Design Properties, and choose the SDT Compatibility tab.
2 Specify the properties you want to map to the SDT part fields for the active design.

Translating part fields from SDT to Capture properties

Capture translates SDT part fields into properties. If you want to change the user property 
names before translation, follow these steps:
1 Open the design's SDT.CFG file in any text editor.
2 Locate the lines that specify the part field names, and change them to suit your needs.
3 Save your changes, and exit the editor.

Translating Capture properties to SDT part fields

You can specify properties for Capture to translate into SDT part fields by following these 
steps:
1 From the Options menu, choose Design Properties, and select SDT Compatibility.
2 Specify the properties you want to map to the SDT part fields.

Related topics
Configuring Capture
Translating files
Worksheet objects map
Design Properties command
Design Template command



Mapping ESP and SDT tools and commands to Capture commands

A guide to the right command to perform a familiar Design Management Tools 
task.

Mapping Design Management Tools to Capture commands

A guide to the right command to perform a familiar SDT task.
Mapping SDT tool buttons to Capture commands

A guide to the right command to perform a familiar Draft task.
Mapping Draft commands to Capture commands

A guide to the right command to perform a familiar Edit Library task.
Mapping Edit Library commands to Capture commands

A guide to setup your Capture environment similar to your ESP and SDT 
environments.

Mapping ESP SDT configurations to Capture configurations



Command map
Design Management Tool Capture command, tool, or process
Backup Design Capture automatically backs up designs 

and libraries with a .BAK file extension
Complex to Simple On the View menu, Logical View and 

Physical View
Copy Design and Copy File Use the File Manager---see your 

Windows documentation on how to use 
the File Manager

Create Design On the Design menu, New, Design
Delete Design and Delete File Use the File Manager---see your 

Windows documentation on how to use 
the File Manager

Edit File Use any text editor
Rename File On the Design menu, Rename to rename

schematics; to rename a file, use the 
File Manager---see your Windows 
documentation on how to use the File 
Manager

Restore Design Use the File Manager---see your 
Windows documentation on how to use 
the File Manager

Suspend to System Not applicable---Capture does this 
automatically when you open another 
Window's program

Update ESP Data See Configuring Capture

Command map
SDT tool button Capture command, tool, or process
Annotate Schematic On the Tools menu, Update Part 

References
Archive Parts in Schematic On the Design menu, Replace Cache or 

Update Cache
Back Annotate On the Tools menu, Gate and Pin Swap
Check Design Integrity On the Tools menu, Design Rules Check
Check Electrical Rules On the Tools menu, Design Rules Check
Cleanup Schematic Not applicable
Compile Library Not applicable
Convert Plot to IGES Not applicable
Create Bill of Materials On the Tools menu, Bill of Materials
Create Hierarchical Netlist On the Tools menu, Create Netlist
Create Netlist On the Tools menu, Create Netlist
Cross Reference Parts On the Tools menu, Cross Reference
Decompile Library Not applicable
Draft On the File menu, Open, Design or New, 

Design



Edit File Use any text editor
Edit Library Part editor (choose the Part Selector 

tool, 
Part on the Place menu, or either Open, 
Library or New, Library on the File menu)
to edit parts

List Library Browsing a design or library
Plot Schematic On the File menu, Print, Print Setup, or 

Print Preview commands
Print Schematic On the File menu, Print, Print Setup, or 

Print Preview
Select Field View Editing properties
Show Design Structure Browsing a design or library
To Digital Simulation Not applicable
To Layout Not applicable
To Main Not applicable
To PLD Not applicable
Update Field Contents On the Tools menu, Update Properties
View Reference Use any text editor

Command map
Draft command Capture command ,tool, or process
AGAIN Not applicable
BLOCK Move Selecting and deselecting objects and 

Moving objects
BLOCK Drag Selecting and deselecting objects and 

Moving objects
BLOCK Fixup On the Place menu, Wire and Bus
BLOCK Get On the Edit menu, Cut, Copy, and Paste
BLOCK Save On the Edit menu, Cut, Copy, and Paste
BLOCK Import On the File menu, Import Selection
BLOCK Export On the File menu, Export Selection
BLOCK ASCII Import On the Edit menu, Paste
BLOCK Text Export On the Edit menu, Copy
CONDITIONS Help, About Capture
DELETE Object Selection tool (select object to delete, 

then press DELETE or choose Delete on 
the Edit menu)

DELETE Block Selection tool (enclose objects to delete,
then press DELETE or choose Delete on 
the Edit menu)

DELETE Undo On the Edit menu, Undo
EDIT Editing Properties or Rename on the 

Design menu
FIND On the Edit menu, Find



GET Part selector tool or Part on the Place 
menu

HARDCOPY Destination On the Print menu, Print Setup, and 
Printing and plotting

HARDCOPY File Mode On the Print menu, Print Setup, and 
Printing and plotting

HARDCOPY Make Hardcopy On the Print menu, Print, and Printing 
and plotting

HARDCOPY Width of Paper On the Print menu, Print Setup, and 
Printing and plotting

INQUIRE Editing Properties
JUMP A, B, C, D, E, F, G, H Tag On the View menu, Go To
JUMP Reference On the View menu, Go To
JUMP X-Location On the View menu, Go To
JUMP Y-Location On the View menu, Go To
LIBRARY Directory Searching for a part in the libraries
LIBRARY Browse Searching for a part in the libraries
MACRO Capture Not applicable---Use Window's Recorder 

found in the Accessories program group.
See the Recorder on-line help for more 
information.

MACRO Delete Not applicable---Use Window's Recorder 
found in the Accessories program group.
See the Recorder on-line help for more 
information.

MACRO Initialize Not applicable---Use Window's Recorder 
found in the Accessories program group.
See the Recorder on-line help for more 
information.

MACRO List Not applicable---Use Window's Recorder 
found in the Accessories program group.
See the Recorder on-line help for more 
information.

MACRO Read Not applicable---Use Window's Recorder 
found in the Accessories program group.
See the Recorder on-line help for more 
information.

MACRO Write Not applicable---Use Window's Recorder 
found in the Accessories program group.
See the Recorder on-line help for more 
information.

PLACE Wire Wire tool or Wire on the Place menu
PLACE Bus Bus tool or Bus on the Place menu
PLACE Junction Wire tool or Wire on the Place menu
PLACE Entry (Bus) Bus Entry tool or Bus Entry on the Place 

menu
PLACE Label On the Place menu, Net Alias
PLACE Module Port Hierarchical Port tool or Off-Page 



Connector tool, or Hierarchical Port or 
Off-Page Connector on the Place menu

PLACE Power Power tool or Power on the Place menu
PLACE Sheet Hierarchical Block tool, or Hierarchical 

Block on the Place menu
PLACE Text Text tool or Text on the Place menu
PLACE Dashed Line Creating graphics
PLACE Trace Name Editing properties
PLACE Vector Editing properties
PLACE Stimulus Editing properties
PLACE NoConnect No Connect tool, or No Connect on the 

Place menu
QUIT Enter Sheet On the View menu, Descend Hierarchy
QUIT Leave Sheet On the View menu, Ascend Hierarchy
QUIT Update File On the File menu, Save
QUIT Write to File On the File menu, Save
QUIT Initialize On the File menu, Open, Design or New, 

Design
QUIT Suspend to System Not applicable---Capture does this 

automatically when you open another 
Windows program

QUIT Abandon Edits On the File menu, Exit
QUIT Run User Commands Not applicable
REPEAT On the Edit menu, Repeat
SET Auto Pan Panning
SET Backup File Not applicable-Capture backs up files 

automatically
SET Drag Buses Not applicable---Capture drags busses 

automatically
SET Error Bell Not applicable
SET Left Button Not applicable
SET Macro Prompts Not applicable
SET Orthogonal Not applicable
SET Show Pin Numbers Editing properties
SET Title Block Placing multiple title or revision blocks
SET Worksheet Size Defining schematic page characteristics
SET X,Y Display On the View menu, Grid References, and

Status Bar
SET Grid Parameters On the View menu, Grid and Grid 

References, and Status Bar
SET Repeat Parameters Not applicable
SET Visible Lettering Editing properties
TAG On the Place menu, Bookmark
ZOOM Center Position pointer and press SHIFT+C (see 

Shortcuts)



ZOOM In On the View menu, Zoom, In
ZOOM Out On the View menu, Zoom, Out
ZOOM Select On the View menu, Zoom, Scale

Command map
Edit Library command Capture command or tool
AGAIN On the Edit menu, Repeat
BODY Kind of Part? Not applicable
BODY Kind of Part? Block Not applicable
BODY Kind of Part? Graphic Not applicable
BODY Kind of Part? IEEE Not applicable
BODY <Block> Not applicable
BODY <Graphic> Line Line tool or Line on the Place menu
BODY <Graphic> Circle Ellipse tool or Ellipse on the Place menu
BODY <Graphic> Arc Arc tool or Arc on the Place menu
BODY <Graphic> Text Text tool or Text on the Place menu
BODY <Graphic> IEEE Symbol Symbol tool or IEEE Symbol on the Place

menu
BODY <Graphic> Fill Creating graphics
BODY <Graphic> Delete On the Edit menu, Delete
BODY <Graphic> Erase Body On the Edit menu, Delete
BODY <Graphic> Size of Body Defining the part body
BODY <Graphic> Kind of Part Not applicable
BODY <IEEE> Line Line tool or Line on the Place menu
BODY <IEEE> Circle Ellipse tool or Ellipse on the Place menu
BODY <IEEE> Text Text tool or Text on the Place menu
BODY <IEEE> IEEE Symbol Symbol tool or IEEE Symbol on the Place

menu
BODY <IEEE> Delete Selection tool (select graphic to delete, 

then press DELETE or choose Delete on 
the Edit menu)

BODY <IEEE> Erase Body Not applicable
BODY <IEEE> Size of Body Not applicable
BODY <IEEE> Kind of Part Not applicable
CONDITIONS On the Help menu, About Capture
EXPORT Moving parts or symbols between 

libraries
GET PART Part Selector tool or Part on the Place 

menu
IMPORT Moving parts or symbols between 

libraries
JUMP A, B, C, D, E, F, G, H Tag On the View menu, Go To
JUMP X-Location On the View menu, Go To
JUMP Y-Location On the View menu, Go To



LIBRARY Update Current On the File menu, Save
LIBRARY List Directory Browsing a design or library
LIBRARY Browse Part Selector tool, Part on the Place 

menu, or Browse Parts on the Edit menu
LIBRARY Delete Part Browsing a design or library
LIBRARY Prefix Editing properties
MACRO Not applicable---Use Window's Recorder 

found in the Accessories program group.
See the Recorder on-line help for more 
information.

NAME Add Defining properties
NAME Delete Editing properties
NAME Edit Editing properties
NAME Prefix Editing properties
ORIGIN Not applicable
PIN Add Pin tool or Pin on the Place menu
PIN Delete Selection tool (select pin to delete, then 

press DELETE or choose Delete on the Edit
menu)

PIN Name Editing properties
PIN Pin-Number Editing properties
PIN Type Editing properties
PIN Shape Editing properties
PIN Move Selection tool (drag pin to new location)
QUIT Update File On the File menu, Save
QUIT Write to File On the File menu, Save
QUIT Initialize On the File menu, Open, Design or New, 

Design
QUIT Suspend to System Not applicable---Capture does this 

automatically when you open another 
Window's program

QUIT Abandon Edits On the File menu, Exit
REFERENCE Editing properties
SET Auto Pan Panning
SET Backup File Not applicable
SET Error Bell Not applicable
SET Left Button Not applicable
SET Macro Prompts Not applicable
SET Power Pins Visible Placing pins
SET Show Body Outline Editing properties
SET Visible Grid Dots Configuring Capture
TAG On the Place menu, Bookmark
ZOOM Center Position pointer and press SHIFT+C (see 

Shortcuts)
ZOOM In On the View menu, Zoom, In



ZOOM Out On the View menu, Zoom, Out
ZOOM Select On the View menu, Zoom, Scale

Configuration map
ESP and SDT configurations Capture configuration
Local configurations Local configurations of Capture tools are

found in the dialog box options of the 
tools---For more information, see SDT 
tool button command map

Tool sets (drivers, library, work 
area, macros, and display drivers)

Use Windows drivers---See your 
Windows documentation for more 
information

Drivers (display, printer, and 
plotter)

Use Windows drivers---See your 
Windows documentation for more 
information

Design options, Print screen 
options, Prefix options, and 
Redirection options

Not applicable

Check Electrical Rules matrix See Design Rules Check command (ERC 
Matrix tab)

Color Use the Color tab on the Preferences 
dialog box---For more information, see 
Preferences command

Editor Use any text editor
Hierarchy Not applicable
Key fields See Combined property strings
Library options See Library options map
Macros Not applicable---Use Window's Recorder 

found in the Accessories program group.
See the Recorder on-line help for more 
information.

Mouse See your Windows documentation
Template table See Page Size tabs of Design Template 

and Design Properties dialog boxes for 
Spacing Ratio--everything else is not 
applicable

Worksheet See Design Template command (Title 
Block tab)

Library options
SDT item or object Capture object
Active Library---library that 
contains information about each 
part on the schematic

Translated into parts that appear in the 
design cache

Reference Library---contains 
information about each configured
library

Not translated





Capture translates only the library parts in the schematic, and refers to the SDT libraries. 
Library configurations are not translate.



Object map
SDT item or object Capture object
Title blocks See Title block map
Macro files Not translated
Color of Objects on worksheet Not translated
Template table information See Template table information map
Key fields Not translated

Objects and attributes (excluding 
parts)

See Worksheet objects map

Parts See Parts map

Title block map
SDT item or object Capture object
Default sizes A, B, C, D, and E Translated
ANSI sizes A4, A3, A2, A1, and A0 Translated
Sheet size Translated into display properties of the 

title block object
Document Number Translated into display properties of the 

title block object
Revision Translated into display properties of the 

title block object
Title Translated into display properties of the 

title block object
Organization Name Translated into display properties of the 

title block object
Organization Address (up to the 
maximum number of lines)

Translated into display properties of the 
title block object

Sheet number Translated into display properties of the 
title block object

Total sheet numbers Translated into display properties of the 
title block object---may change 
depending if you update part references
in Capture; if you don't update part 
references, the total will be the total 
number of schematic pages for that 
schematic; if you do update part 
references, the total will be the total 
number of pages in the design.

Template table information map
SDT item or object Capture object
File name of save template table 
information

Not translated

Horizontal X Translated
Vertical Y Translated



Pin-to-Pin Translated
Global text size Translated---large text strings will be 

matched as close as possible
Pin Number Not translated
Pin Name Not translated
Part Reference Not translated
Part Value Not translated
1st Part Field Not translated
2nd Part Field Not translated
3rd Part Field Not translated
4th Part Field Not translated
5th Part Field Not translated
6th Part Field Not translated
7th Part Field Not translated
Module value Not translated
Power text Not translated
Sheet Name Not translated
Sheet Net Not translated
Module Text Not translated
Label Not translated
Comment Text Not translated
Title Block Not translated
Border Text Not translated
X Border width Not translated---configure these in your 

CAPTURE.INI file
Y Border width Not translated---configure these in your 

CAPTURE.INI file
Plot X offset Not translated
Plot Y offset Not translated
Roll form size Not translated
Spacing ratio Translated

Worksheet objects map
SDT item or object Capture object
Part body Translated into a part instance
Pin number Translated into the pin number property,

and set visible
Pin name Translated into the pin name property, 

and set visible
Part Reference Translated into an attribute of an 

instance, and set visible
Part Value Translated into an attribute of an 

instance, and set visible
1st Part Field Translated into a user property with 



name 1stPartField, unless user changes 
default value

2nd Part Field Translated into a user property with 
name 2ndPartField, unless user changes 
default value

3rd Part Field Translated into a user property with 
name 3rdPartField, unless user changes 
default value

4th Part Field Translated into a user property with 
name 4thPartField, unless user changes 
default value

5th Part Field Translated into a user property with 
name 5thPartField, unless user changes 
default value

6th Part Field Translated into a user property with 
name 6thPartField, unless user changes 
default value

7th Part Field Translated into a user property with 
name 7thPartField, unless user changes 
default value

Module value Translated into a user property with 
name ModuleValue, unless user changes
default value

wire Translated
bus Translated
bus entry Translated with width shown
junction Not translated---junctions are computed,

and don't exist as objects
Power object Translated into global objects---they 

appear the same or similar to SDT 386+
Power text Translated into a property of a global 

object
Sheet body Translated into a hierarchical block
Sheet name Translated into a user property attribute 

of the hierarchical block
Sheet net Translated into a user property attribute 

of the hierarchical block
Sheet Filename Translated into an attached schematic 

attribute of the hierarchical block
Module port

Input
Output
Bi-directional
Unspecified

Translated into either an off-page 
connector (with no type), or a 
hierarchical port (with type)

Module text Translated into a user property attribute 
of a part

Label Translated into a net alias
Comment text Translated---scaling is mapped, and 



stacked (vertical) text is translated into 
rotated text; columns no longer exist

Dashed line Translated into a line with a dashed line 
style

Title block Translated 
Title text Translated into a user property 

attributes of the title block
Command prompt Not applicable
Grid dots Not translated---configure these in your 

CAPTURE.INI file
Trace Name object Translated into a user property 

attribute---this is no longer an object
Test Vector object Translated into a user property 

attribute---this is no longer an object
Stimulus object Translated into a user property 

attribute---this is no longer an object
Error object Translated into a DRC object
No connect object Translated into a pin property
Layout object Translated into user properties of a 

net---graphics are not translated
Tags Translated into a bookmark

Parts map
SDT item or object Capture object
Block Translated into a library part
IEEE Translated into a library part
Graphic Translated into a library part
Grid Array Translated into a library part
Parts with moved properties Location of moved properties is 

preserved
Pin 0 Translated
Power Pins Translated into global pins
Sheetparts/Sheetpath parts Translated into schematic pages or parts
IEEE symbols Translated
Fills Translated
Release IV libraries Translated---first translated into 386+ 

libraries, and then into Capture
Extended ASCII Translated---large text strings will be 

matched as close as possible

Term map
SDT term Capture terms
annotate update part references
back annotate swap gates or pins, back annotate
module port off-page connector, hierarchical port



multiple-element part package
reference designator part reference
sheet schematic page
sheet net hierarchical port
sheet part hierarchical block
sheet path part hierarchical block
sheet symbol hierarchical block
Was/Is file swap file
worksheet schematic page

Connectivitity differences between Capture and SDT
Capture uses a slightly different set of connectivity rules than SDT. The following cases 
explain the differences:

Case 1

The bus is split with like members connecting before and after the split.

Situation A The bus is split using a junction.
SDT Yes
Capture No---busses connected through a junction must contain the same number 

of signals.

Situation B The bus is split using a bus entry.
SDT Yes
Capture Yes

Situation C The bus is split without any visible connection, but is connected through 
name.

SDT Yes
Capture Yes

Case 2



The hierarchical port connects to the hierarchical block through a wire.
SDT Yes
Capture No---wires in Capture are for single signals only.

Case 3

The wire connects to the power symbol.
SDT No
Capture Yes

Case 4

Wire 1 connects to Wire 2 through a label hotpoint.
SDT Yes
Capture No---wires are connected only if they connect through a junction, or if they 

share an alias.

Case 5

The hanging wire connected to a pin causes a single node net in netlists.
SDT No
Capture Yes

Case 6



Busses routed through bus entries are connected to the target object.
SDT Yes
Capture No---you should not use bus entries to route a bus to its target. Use the left 

mouse button to create turns in the bus route.

Case 7

Unlike bus members are connected. 
SDT No
Capture Yes

Related topics
About bus connections 
Editing wires and busses 
Placing busses 
Placing wires 
Establishing bus connectivity 
Establishing connectivity between pages 
Connecting to power or ground 
Opening a schematic created in SDT
Bus command (Place menu) 
Bus Entry command (Place menu ) 
Wire command (Place menu) 



Using Capture with FPGA vendor interface kits
A schematic can be used to represent the internal logic of a programmable device like an 
FPGA or CPLD. The schematic can contain silicon-vendor provided primitive and 
macrofunction symbols, as well as user created macrofunction symbols.
FPGA and CPLD vendors (Actel, Lattice, Xilinx, etc.) provide a CAE Interface Package which 
contains schematic symbols that provide you with the building blocks to create a structural 
design description of an FPGA or CPLD, and simulation models so a functional and timing 
based simulation can be performed on the design.
Some vendors allow you to merge design modules created in a Hardware Description 
Language like VHDL or OHDL with the schematic description. External View or Properties can
record the file name of the module.
Capture's netlist formatters create reports of the design and any HDL modules to a standard 
format like EDIF or OrCAD INF. FPGA place-and-route tools or CPLD device-fitters read the 
design netlist and implement the logic into the physical constraints of the device.

Related topic
Netlist formats 



Enabling ITC between Capture and Simulate
Simulate can communicate interactively with OrCAD's Capture for Windows. That is, with 
your Capture design in physical view, you can see the specific state for nets reflected on the 
schematic sheet as Simulate resolves the simulation. This is especially useful for 
interactively debugging design logic problems. Signals you select to view in Simulate are 
highlighted in Capture. In addition, you can select nets on your Capture schematic, then 
display and analyze the signals associated with those nets in Simulate. You can also modify 
your schematic, generate a new netlist, and reload the Simulate project without exiting 
either tool.
To use this interactive communication, you must have created a simulation project for your 
design.
To turn on ITC in Capture
1 Choose Preferences from Capture's Options menu. Capture displays the Preferences 

dialog box.
2 Choose the Miscellaneous tab.
3 Specify Enable intertool communication and choose the OK button.
To turn on ITC in Simulate
1 Choose Preferences command from Simulate's Options menu. Simulate displays the 

Preferences dialog box.
2 Choose the Run tab.
3 Specify Enable intertool communication and choose the OK button. Capture and Simulate 

are now ready to exchange information.

Related topic
Displaying simulation states on your Capture schematic 



You must use the same design in both Capture and Simulate for ITC to work. If you have 
trouble establishing communication, check the session log in either application for 
messages relating to ITC.



Displaying simulation states on your Capture schematic
Using ITC, you can view selected signals in Capture as their states change during simulation.
You can also select signals on a schematic and use that selection set to set up wave, list, 
and watch windows. At the end of a run, Simulate displays all the signal states on the 
schematic. However, Simulate displays signal history only for those signals displayed in a list
or wave window.
Before following these steps, you must enable ITC between Capture and Simulate.
1 From the Capture File menu, choose Open and then select the design that contains the 

schematic for which you want to display simulation states.
2 Choose Physical from the View menu. Capture displays the design hierarchy in physical 

view.
3 Open the schematic sheet on which you wish to display the simulation states.
4 Position the Capture and Simulate windows so that you can see both.
5 From the Simulate File menu, choose Open to open the simulate project for the design you

wish to debug. The Capture design and the Simulate Project must have the same 
filename, not including the file extensions.

6 From the Run menu, choose Start. The states for each node at the current simulation time
are reflected on the schematic sheet as well as in any list or wave windows. 

7 Position the time cursor anywhere in the wave window and click the left mouse button. 
Capture updates the schematic sheet to reflect the state values for those nodes displayed
in a wave, list, or watch window (only) at the selected simulation time.

Depending upon the time cursor's location in step 7, the number of signal values may vary 
between Capture and Simulate. Simulate keeps past values for only those signals in a trace 
or list window, but has signal values available for all nets and pins at the current simulation 
time. Thus, at the end of a simulation run, or when the time cursor is positioned at or 
beyond the end of the run time, the values for all signals are available. If the time cursor is 
placed before the end of the run time, only the values of signals that were selected for Wave
and List windows are displayed in Capture.
Use this capability to verify the functionality of your design. If you determine that there is a 
problem with your design logic, you can modify your Capture schematic and the 
corresponding Simulate project without exiting either tool.

Related topic
Enabling ITC between Capture and Simulate



Selecting signals for display from a Capture schematic
You can select nodes on a Capture schematic and add the signals associated with those 
nodes to a wave, list or watch window, or set breakpoints for those signals. The signals 
associated with nodes in a Capture schematic belong to the ITC context in the Simulate 
environment.
Before following these steps, you must enable ITC between Capture and Simulate.
To select signals for display in Simulate from a Capture schematic
1 Invoke Capture on the design.
2 From within Capture, choose Physical from the View menu. Capture displays the design 

hierarchy in physical view.
3 Open the schematic sheet you wish to debug.
4 Select the pin or net that you want to add to the simulation display.
5 In Simulate, follow the signal selection procedure outlined in Simulate's help topic 

"Identifying signals for display." When you select a signal context, choose ITC. The items 
selected in Capture appear in the ITC context and are shown in the Signals in Context 
listbox.    From that point you can use the ">"    and ">>" buttons to add entries to the 
Selected Signals listbox.

Related topics
Enabling ITC between Capture and Simulate
Displaying simulation states on your Capture schematic    



Enabling ITC between Capture and Layout
To use cross probing, you must have both Layout and Capture, or another schematic capture
application, open on the same design. You may have them open in Layout's Half Screen 
window, or in separate windows. You must be in physical view (in Capture) in order for cross 
probing to function correctly.
To turn on ITC in Capture
1 Choose Preferences from Capture's Options menu. Capture displays the Preferences 

dialog box.
2 Choose the Miscellaneous tab.
3 Specify Enable intertool communication and choose the OK button.
To turn on ITC in Layout
You don't need to perform any actions in Layout, since cross probing is always active.

Related topics
Cross probing between Capture and Layout 
AutoECO 



Cross probing between Capture and Layout
Cross probing allows you to select an object in Layout or Capture, and have the 
corresponding object highlighted in the other tool. For example, with cross probing enabled, 
by selecting a net in a Capture schematic, you cause Layout to highlight the corresponding 
net in the board representation.
Before you can cross probe between Capture and Layout, intertool communication must be 
enabled. For more information, see Enabling ITC capabilities for Capture and Layout.
Cross probing from Capture to Layout

When you select certain items in your Capture schematic, cross probing highlights the 
corresponding components of your Layout board representation. That is, when you select a 
part or gate in a multi-part package, cross probing highlights the corresponding module on 
the board. When you select a wire segment or net, cross probing highlights the 
corresponding net (in its entirety) on the board representation.
Any action you perform to select an object in your Capture schematic (selecting via the 
mouse, by using the Find command, or by performing a Browse of parts) causes the 
corresponding object in the Layout board representation to be highlighted. For more 
information, see the following table:

Selecting this in Capture Highlights this in Layout
Part Corresponding module
Gate (multiple parts per package) Corresponding module
Wire segment Corresponding single route
Net All routes for the net
Pin on part Corresponding pad on the module
Block selection of parts, pins, and wires Last item selected in the block is 

highlighted (part or net)

Capture needs to be in physical view for cross probing to work.
Cross probing from Layout to Capture
When cross probing is enabled, selecting objects in your board representation causes 
Capture to highlight the corresponding items in the schematic. Specifically, selecting a 
module (or a module pad) causes Capture to highlight all the schematic parts included in 
that module. Selecting a route or net causes Capture to highlight the corresponding 
schematic net.
Any action you perform to select an object in your Layout board representation (selecting via
the mouse, from the Query window, or via the Find command) causes the corresponding 
object in the Capture schematic to be highlighted. For more information, see the following 
table:

Selecting this in Layout Highlights this in Capture
Module All parts in the package
Route Corresponding wire connection
Net Corresponding nets
Pad on module Corresponding pin on part
Block selection Corresponding parts and wires



Related topic
Enabling ITC capabilities for Capture and Layout



When you use block selection in Capture, cross probing only highlights the last item 
selected in the block. Since there is no way to predict the order in which items are selected 
in a block selection, you should be cautious in using them when cross probing is enabled.



Moving designs between Capture and Layout
Moving a design from Capture into Layout is a three-part process. First, you must create a 
valid Capture design with footprints or part values that are supported by Layout. Second, 
you must generate a netlist in the Layout format. And finally, you must create a Layout 
board file. If you want to transmit net and part data from Capture to Layout, you must create
named properties and assign values to them.
To prepare a Capture design for Layout
1 Create a design in Capture.
2 If you want to transmit part or net information, add a user defined property with a name 

from the property tables below, and assign a value to the property. The property name 
must be uppercase as shown in the tables. The property value, though assigned in 
Capture, is interpreted with its Layout meaning.

User defined part 
property name Description
FPLIST Comma-delimited list of alternate footprints.
MIRRORFOOTPRINT Defines an explicit mirror shape.
COMPLOC Part location on the PC board as X and Y 

coordinates. Use the following format:
[X,Y]

where X and Y represent the coordinates, and both 
must be integers in mils or microns.

COMPROT Part rotation in degrees and minutes from the 
orientation defined in the Layout footprint library. 
Use a period (.) to separate degrees and minutes.

COMPGROUP Integer between 1 and 100 assigning the part to a 
group for placement.

COMPKEY If value is "YES," the part is permanently fixed to 
the board.

COMPFIXED If value is "YES," the part is temporarily locked in 
position.

COMPLOCKED If value is "YES," the part is temporarily locked in 
position.

User defined net 
property name Description
ROUTELAYERS Comma-delimited list assigning net to specific 

layers.
THERMALLAYERS Comma-delimited list assigning net to specific 

thermal planes.
NETWEIGHT Integer between 1 and 100 assigns relative priority 

to the net; default is 50.
VIAPERNET Via types allowed for net.
WIDTH Value is assigned to MINWIDTH, MAXWIDTH, and 

CONNWIDTH attributes unless overwridden.
CONNWIDTH Sets the track width.



MINWIDTH Sets the minimum track width.
MAXWIDTH Sets the maximum track width.
WIDTHBYLAYER Net width for one or more layers, for example 

TOP=6,BOT=13.
SPACINGBYLAYER Net spacing for one or more layers, for example 

TOP=12,BOT=8.
RECONNTYPE Specifies the reconnect rules for each type of 

reconnect. Values may be STD, HORZ, VERT, MIN, or
ECL.

TESTPOINT If value is "YES," test point is automatically 
assigned.

HIGHLIGHT If value is "YES," net is highlighted.

3 Assign PCB footprints to each of your schematic parts. Use only Layout footprints selected
from the MaxEDA Tutorial Manual, from the OrCAD Footprint Libraries, or from your 
custom footprint libraries.

4 If you are using parts from libraries other than LAYOUT.OLB, such as discrete parts and 
custom footprints, you need to make sure that the pin numbers of your schematic part 
match the pad numbers of our Layout footprint. To do this, you may need to work with the
part editor or Layout's footprint libraries.

5 From the Tools menu, choose Design Rules Check to eliminate design errors.
To create a netlist for Layout
1 From the View menu, choose Physical.
2 From the Tools menu, choose Create Netlist, and choose the Layout tab.
3 Verify the destination filename and directory, then choose the OK button to create 

an .MNL netlist file.
To create a Layout board file
1 Double-click on the Layout icon to start the Layout shell.
2 From the Tools menu, choose New Design.
3 In the Load Technology dialog box, verify that List Files of Type is set for Technology 

(*.TCH). Then select a specific file using the guidelines in section 10.1.1 of the MaxEDA 
Tutorial Manual, or in the "Understanding technology files" section of the OrCAD Layout 
for Windows Autorouter User's Guide.

4 In the Load Netlist Source dialog box, select the .MNL file that you created in Capture.
5 In the Save Massteck Binary dialog box, select the directory in which you want to store 

the .MAX board file. Choose the OK button. AutoECO creates the .MAX file and displays 
the board in the Design shell.

To back annotate Layout board information to a Capture schematic
1 After you have made changes to the design in Layout, choose the Reports command from 

Layout's File menu to display the Generate Reports dialog box.
2 If you have reannotated the names of parts in Layout v6.3, choose OrCAD Rename (.SWP)

to create a swap file. If you have altered parts or nets in Layout v6.3, choose OrCAD Part 
Properties (.OPT) or OrCAD Net Properties (.ONT) to create an update file. Choose the OK 
button to create the file.
or
If you have reannotated the names of parts, or altered parts or nets in Layout v6.4, 



choose OrCAD Backannotation File (.SWP). The file Layout generates contains all the part 
reference back annotations, and part and net update properties Capture needs.

3 From Capture's view menu, choose Physical View.
4 If you have Layout v6.3, from the Tools menu, choose Gate and Pin Swap to back annotate

part references. Choose Update Properties to back annotate part or net properties. 
Choose the Browse button to find the report you just created in the directory which holds 
the Layout design.
or
If you have Layout v6.4, from the Tools menu, choose Gate and Pin Swap to back annotate
part references, and part and net properties. Choose the Browse button to find the report 
you just created in the directory which holds the Layout design.



If you create a part properties update file (.OPT) in Layout v6.3, you need to change the 
following part of the first line from:

{Part Reference}
to:
{Reference}

If you create a swap file (.SWP) in Layout v6.3, you need to change the following items in 
the file:

Exchange the second and third columns of all GATESWAP lines.
Change all GATESWAP commands to CHANGEREF commands.
Change all PINSWAP commands to CHANGEPIN commands.



If you create a part properties update file (.OPT) in Layout v6.3, you need to change the 
following part of the first line from:
{Part Reference}

to:
{Reference}

If you create a swap file (.SWP) in Layout v6.3, you need to change the following items in 
the file:

Exchange the second and third columns of all GATESWAP lines.
Change all GATESWAP commands to CHANGEREF commands.
Change all PINSWAP commands to CHANGEPIN commands.



If AutoECO finds errors, it displays an .ERR file with explanations of the errors. To correct pin
problems, you may return to Capture and change pin numbering, then repeat this entire 
procedure. Or, you may prefer to edit the footprint in Layout's footprint library, then re-
create the board file.



Layout cannot accept PCB footprint names or part values that include spaces. Check your 
design to eliminate space characters or tabs in these property values. The spreadsheet 
editor is very useful for this.



AutoECO
AutoECO enables you to forward annotate a printed circuit board (PCB) from Capture to 
OrCAD Layout for Windows. AutoECO also resolves "pin-to-pin" conflicts that may arise due 
to pins that are missing from a chosen footprint, or pins that are named differently in the 
design capture package than they are in Layout (for example, a diode may have pins named
pin A and pin C in Capture, but named pin 1 and pin 2 in Layout).
To forward annotate a board from Capture to Layout
1 In Capture's design manager, open the design for which you are going to create a netlist.
2 From the View menu, choose Physical.
3 From the Tools menu, choose Create Netlist.
4 In the Create Netlist dialog box, choose the Layout tab.
5 Select the Run ECO to Layout option.
6 In the Netlist File entry box, enter a name and path for the output file using a .MNL file 

extension.
7 Choose OK to close the dialog box and create the .MNL file.
8 In Layout, choose AutoECO from the Tools menu on the OrCAD shell.
9 In the File A (original components and nets) dialog box that appears, select an input file 

with a .MAX file extension, and choose OK.
10In the File B (new components and nets) dialog box that appears, select the netlist file 

with the .MNL extension that you created in step 7, and choose OK.
11In the Merged Output Binary dialog box, select a name for a new output file with a .MAX 

file extension, and choose OK.
If AutoECO is unable to find a designated footprint, a dialog box allowing you to link 
footprints with components will appear. For more information on this dialog box, see the 
Layout help topic "Link Footprint to Component dialog box."

Related topics
Layout netlist format 
Combined property strings



AutoECO is note intended to act as a full-time library management tool for adding or 
deleting large numbers of libraries to and from the (FF_LIB) section of MASSTECL.INI. It is 
meant to be used as an on-the-fly aid to completing an ECO successfully. However, if in the 
general course of using Layout you create a new library, using AutoECO frees you from 
having to manually edit MASSTECK.INI in order to add your new library.




