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Ping Application
Ping sends ICMP echo request packets to the specified host(s) and measures the elapsed 
time between the transmission of the request and the receipt of the reply back at your host. 
If a host cannot be reached, a message appears indicating so. Short elapsed times indicate 
that the destination is relatively few hops away. Longer elapsed times can indicate a variety 
of conditions including: the network is congested, the destination is many hops away, or that
the destination can only be reached by a satellite link or by transoceanic link.

Click graphic fields for more information.



File Menu
The File menu lets you store Ping output in a file, print output, or exit the Ping application.



Host Menu
The Host menu starts and stops the Ping application, and verifies host names:



Options Menu
The Options menu lets you enable or disable the display of the toolbar, bubble help, or 
status line.



Help Menu
The Help menu lets you view useful information about the Ping application and how to use 
the Help facility.



File Menu
The File menu contains these commands:
Save As

Saves host statistics for the Ping selected in the Hosts window to a file.    (Ping limits the 
Host Statistics window to 25 KB of data, so if your Ping produced more than 25 KB of 
output, only the last 25 KB can be saved or printed.)    The shortcut button is:

Print
Prints host statistics for the Ping selected in the Hosts window.    The shortcut button is:

Exit
Exits the Ping application.    The shortcut button is:



Save As Dialog Box
The Save As dialog box lets you save host statistics to a file:
File Name

The name of the file in which to save the host statistics.
Save File As Type

The file format for the file.
Directories

The directory for the file.
Drives

The drive for storing the file.
Network

Connects to another network location so you can assign it a new drive letter.



Print Dialog Box
The Print dialog box lets you print Ping output:
Printer

Shows the active printer and printer connection.    Click the Setup button to change the 
printer and printer connection.

Print Range group
Lets you specify the pages you want to print:    All pages; just the data you selected in 
the Host Statistics window; or a specific page range.

Print Quality
Determines how clear the printout is, based on the capabilities of your printer.

Copies
The number of copies you want to print.

Collate Copies
Whether you want each copy printed in page number order (checked), or whether you 
want all copies of each page printed together, so that, for example, all page ones are 
printed first before printing page two (unchecked).

Setup button
Lets you select a printer and set other printer options using the Print Setup dialog box.



Print Setup Dialog Box
The Print Setup dialog box lets you select a printer, page orientation and dimensions, paper 
source and other options:
Printer group

Lets you select either the default printer, or another printer that you have installed.
Orientation group

Determines whether the printout is in portrait or landscape orientation.
Paper group

Determines the size of the paper and the paper tray that is used.
Options button

Additional options that you can set for the selected printer.
Network button

Lets you connect to a printer on your network.



Save As Button
The Save As button, or Save As from the File 
menu, saves host statistics for the Ping selected in
the Hosts window to a file.    (Ping limits the Host 
Statistics window to 25 KB of data, so if your Ping 
produced more than 25 KB of output, only the last 
25 KB can be saved or printed.)

Print Button
The Print button, or Print from the file menu, prints 
host statistics for the Ping selected in the Hosts 
window.    (Ping limits the Host Statistics window to 
25 KB of data, so if your Ping produced more than 
25 KB of output, only the last 25 KB can be saved 
or printed.)

Exit Button
The Exit button, or Exit from the File menu, exits 
the Ping application.

Host Menu
The Host menu contains these commands:
Ping

Starts a Ping session using the Ping dialog box.    The shortcut button is:

Stop
Stops the Ping selected in the Hosts window.    The shortcut button is:

Clear
Stops and clears the output for the Ping selected in the Hosts window.    The shortcut 
button is:

Clear All
Stops and clears the output for all Pings from the Hosts and Host Statistics windows.

Host Lookup
Looks up information about a host given the hosts name or IP address.    The shortcut 
button is:



Ping Button
The Ping Host button, or Ping from the Host menu, 
starts a Ping session.

Ping Dialog Box
The Ping dialog box lets you start a Ping session, store host names in the Host List, and 
specify packet characteristics:
Host List

Displays a list of host profiles you saved.    Add hosts to the list automatically by checking
Save on OK.    Or, click the Save button after entering information for a host.    You can 
Ping multiple hosts at once by selecting them from this list:    use drag or Shift-drag to 
select several hosts that appear consecutively in the list, and Ctrl-click to choose 
individual hosts. Hosts are stored with all specified options such as the number of 
packets, data length, and packet information options.

Host Name
The name or IP address of a host.    For hosts on the local network, a single word can be 
used for the host name, such as PINE. If the host is at another site, enter the fully-
qualified domain name, such as OAK.YOYODYNE.COM.

Save on OK
Determines whether this host is saved to the host list automatically when you click the 
OK button.    If you uncheck this, you must click the Save button to save the host to the 
host list.

Number of Packets
The number of ICMP echo request packets to send to the other host.    Specify a numeric 
value; to Ping a host indefinitely, use 0 (zero).    If Ping runs indefinitely, use the Stop 
button to terminate the session.

Data Length
The number of bytes of data to attach to the ICMP Echo Request packets.    Increase the 
data length to check for gateways that do not fragment IP packets correctly.    The data 
length ranges from 0 to 16384 bytes.    If the data length is set to a value less than 8, 
Ping does not measure the elapsed time during the Ping session.

Save button
Saves the host name to the Host List. All specified options are stored with the host name.

Delete button
Deletes the selected hosts from the Host List.

Advanced button
Displays the Packet Information group, which lets you specify the contents of the data 
portion of ICMP echo request packets sent by Ping to the target host.

Packet Information group
Determines the contents of the data portion of the ICMP echo request packet.    These 
options are helpful if you are using a local area network protocol analyzer like the 
Network General Sniffer or the TCPDump software tool.    Protocol analyzers allow you to 
display the contents of packets as they traverse the network.
Default

The packet data is sequential ASCII numbers starting with 1 and extending the length
of the packet data area.    Packet data begins after the time stamp and sequencing 



information in the first 12 bytes of a packet.    A default packet starts with 
"1,2,3,4,5,6,7" and so on.

All Zeros
The packet data is all zeros, such as 00000000000.

All Ones
The packet data is all ones, such as 11111111111.

Alternating Ones and Zeros
The packet data is alternating ones and zeros, such as 010101010101.

User Defined
The packet data is what you enter in the associated edit box.    The string is repeated 
as many times as necessary to fill the packet.    Put a space at the end of your 
alphanumeric string so that you can easily see the end of one string and the 
beginning of the next.



Number of Packets Edit Box
The Number of Packets edit box lets you enter the number of ICMP echo request packets to 
send to the other host. Specify a numeric value; to Ping a host indefinitely, use 0 (zero).    If 
Ping runs indefinitely, use the Stop button to terminate the session. 
Note:

Ping displays a total of 25 kilobytes of information in the Host Statistics window. If Ping runs 
indefinitely, previous information is truncated to maintain the 25 kilobyte limit.    Also, 
excessive numbers of packets can degrade network performance. 



Data Length Edit Box
The Data Length edit box lets you enter the number of bytes of data to attach to the ICMP 
Echo Request packets. Increase the data length to check for gateways that do not fragment 
IP packets correctly. The data length ranges from 0 to 16384 bytes.    If the data length is set 
to a value less than 8, Ping does not measure the elapsed time during the Ping session.



Stop Button
The Stop button, or Stop from the Host menu, stops 
the Ping selected in the Hosts window if it is still 
running.

Clear or Remove Button
The Clear or Remove button, or Clear from the Host
menu, stops the Ping selected in the Hosts window 
and clears the output from that Ping from the Host 
Statistics window.

Host Lookup Button
The Host Lookup button, or Host Lookup from the 
Host menu, lets you determine if a host exists, or 
lets you determine the host name assigned to an 
IP address, or IP address assigned to a host name.

Host Lookup Dialog Box
The Host Lookup dialog box displays information about a host, including host name, IP 
address, and CPU and operating system type (if configured in your local host table or in 
DNS).
Host Name/IP Address

The name or IP address of the host about which you are looking for information.
Return Information

Information that Host Lookup could find out about the host.
Lookup button

Starts looking for information about the host.    Click this button once you fill in the host 
name or IP address.



Options Menu
The Options menu contains these commands:
Toolbar

Displays or hides the toolbar, which is the bar of shortcut buttons beneath the menu.
Bubble Help

Enables or disables bubble help, which is the quick popup help you get when moving the 
cursor over the toolbar buttons.

Status Bar
Displays or hides the status bar at the bottom of the main window.



Status Bar
The status bar displays a help reminder and the current date and time.



Help Menu
The Help menu contains these commands:
Contents

Displays the contents page of this help file.
Search for Help on

Searches this help files index.
How to Use Help

Displays help information for using the Windows help system.
About Ping

Displays version information for the application.



Ping Toolbar
The Ping toolbar provides shortcut buttons to start and stop Ping sessions, connect quickly 
to a host, display a host name, save Ping statistics in a file, print Ping statistics, and quit 
Ping.
The toolbar is:



Quick Connect Button
The Quick Connect button lets you quickly Ping to a
host you have already saved to the host list.    Click
the host you want to Ping from the displayed list.

Quick Connect List
The Quick Connect list shows the hosts saved in the Hosts List window. Hosts are saved in 
the Hosts List window using the Ping dialog box.    All specified options are stored with the 
host names.
Click the desired host name or IP address.    A Ping session immediately starts using the 
options specified in the Ping dialog box.



Hosts Window
The Hosts window displays information from the current and recent Ping sessions. Use the 
Ping button or the Ping from the Host menu to start a Ping session.
The display columns are:
Host Name

Displays the host names from Ping sessions.
Status

The status of a Ping session.    Possible values are "Ping", when Ping sends requests to 
the host, "Finished", when a session completes, or "Error", when an error occurs during 
the Ping session.    If "Error" appears, additional information appears in the Host Statistics
window.

S/R/%Loss
Displays the number of sent and received packets, and the percentage of packets lost 
during transmission.

RTT Min/Avg/Max
Displays the minimum, average, and maximum round-trip times (RTT) calculated from 
ICMP packets sent between your host and the other host.



Host Statistics
The Host Statistics table displays host statistics generated during a Ping session. The 
following example illustrates how information appears in the table:
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 Understanding Ping
Use the Ping (Packet Internet Groper) application to verify that a host can be reached across 
the network.
Why Ping is Used

Use Ping to determine if an application is working correctly. If a Ping session succeeds, but 
an application fails, the host may be having problems with its server or a problem may exist 
in the application itself. If Ping fails, ensure that the Cisco TCP/IP Suite Master Server is 
running and that all hardware connections are correct. The messages that appear when a 
Ping session fails provide additional insight.
When Ping Fails

When Ping fails, it provides informational messages that start with:

Unable to ping host.
Error return of [message].

Common message values are:
Connection timed out Low-level packet transmission cannot be 

accomplished between your host and the
other host.

Host not found The host name is misspelled, not found in
the DNS or host tables, or the Master 
Server is not running.

No buffer space available Restart Ping or close other network 
applications.    Use the Cisco TCP/IP Suite 
Monitor application's Buffer Statistics 
information to determine how many 
memory buffers are in use.

Network is down Results when two hosts on the same 
network are assigned IP addresses with 
different network numbers, or the default
route in the Cisco TCP/IP Suite 
Configuration Utility is incorrectly set.



 Pinging a Host
To start a Ping session:

1. Click the Ping button, or choose Ping from the Host menu.    The Ping dialog box appears.
2. Enter a host name in the Host Name edit box.    To Ping your own host, use 127.0.0.1.    

Unless you need to perform special tests with alternate packet counts, sizes, or data 
contents, use the initial Ping setup. 

3. To start the Ping session, click OK.    
4. Once a Ping session starts, it will self-terminate.    Alternately, click the Stop button, or 

choose the Stop from the Host menu.

Alternately, use the Quick Connect button to start a Ping session.



Performing a Host Lookup
To look up a host by host name or by IP address:

1. Click the Host Lookup button, or choose Host Lookup... from the Host menu.    The Host 
Lookup dialog box appears.

2. Enter a host name or IP address for the host lookup.
3. Click the Lookup button to display the results of the inquiry.
4. Click the Cancel button to return to the Ping application window.



Changing Ping Parameters
To change Ping parameters for the number of packets to send, the data length, or 
the format of packet data:

1. Click the Ping button, or choose Ping from the Host menu.    The Ping dialog box appears.
2. Change the Number of Packets or Data Length to the desired settings, and click the 

Advanced button if you want to change the contents of the data packets.



Storing Ping Output in a File
To store Ping statistics in a file:

1. Select the Ping whose output you want to save in the Hosts window.
2. Click the Save button, or choose Save As from the File menu.
3. Specify the name of the file you want to use and click OK.



 Printing Ping Information
To print Ping statistics:

1. Select the Ping whose output you want to save in the Hosts window.
2. Click the Print button, or choose Print from the File menu.
3. Choose your printer and click OK.



Adding Host Names to the Host List
To add a host name to the Host List window:

1. Click the Ping button, or choose Ping from the Host menu.    The Ping dialog box appears.
2. Enter the name of the host in the Host Name box.
3. If Save on OK is checked, then any new host name is saved in the Host List when you 

click OK.    Alternately, you can save the host name by clicking the Save button.    To 
delete an entry from the Host List window, select the entry and click the Delete button.
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 Ping Concepts
The Cisco TCP/IP Suite Ping application lets you determine if a host can be accessed. Ping 
sends ICMP echo request packets to the specified host and measures the time that elapses 
from the time the packet is sent to the host until it is received back at your host. The greater
the time that elapses, the greater the possibility of a network problem.    If a host cannot be 
reached, a message appears indicating so.      



For More Information
Recommended Reading

For an excellent conceptual overview of Ping (and a complete discussion of TCP/IP 
networking concepts), we recommend the following books:

Comer, Douglas E., Internetworking with TCP/IP, Volumes I and II, Prentice Hall
Black, Uyless D., TCP/IP and Related Protocols, McGraw-Hill
Stevens, W. Richard, TCP/IP Illustrated, Volume 1

Recommended books for users of all levels.




