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Click a letter to go to that section.

To display help for a command while working in Visio, pause the pointer over the command, and then 
press the F1 key. You can also click the Help button in most dialog boxes.

A - D
Align To/Match Wall
Area Analysis
Array Shapes
AutoCAD Drawing

E - I
Extend To Wall

J - L
Join Walls

M
Measure
Mechanical Parts Library
Move
Move To Wall

N - R
Netlist Generator

S - U



Set wall dimensions

V
Valve Builder

W - Z
Wall Utility



Align To/Match Wall
    Related Topics

Tools > Macro > AEC > Wall Utility

Tools > Macro > Macros > Wall Utility
Aligns certain door and window shapes to the wall shape and matches the thickness, reference line 
offset, and angle of the door or window to the wall. 

When used with like shapes, such as only with doors or only with walls, matches a shape's wall thickness 
and reference line offset to those of the first shape selected, without altering the position or angle.



Extend To Wall
    Related Topics

Tools > Macro > AEC > Wall Utility

Tools > Macro > Macros > Wall Utility
Extends one or more selected double line wall(s) along its current angle until it abuts another primary wall
to form a "T-joint" at any angle.



Join Walls
    Related Topics

Tools > Macro > AEC > Wall Utility

Tools > Macro > Macros > Wall Utility
Joins two Double Line Wall shapes of similar or different wall settings, creating a corner joint at any angle.
If more than two abutting walls are selected, the utility will continue to create a corner at all coincident 
locations.



Measure
    Related Topics

Tools > Macro > Visio Extras

Tools > Macro > Macros
Automatically measures the total perimeter and area of any closed shape drawn with the drawing tools, 
such as a shape that outlines the floor area of a floor plan. You can use this information to keep track of 
square footage in a building plan or to calculate the cross-sectional area of a structural member.

DIALOG BOX OPTIONS
Total Area    Specifies the unit of measure you prefer for the area.

Total Perimeter    Specifies the unit of measure you prefer for the perimeter.

Compute    Calculates the area and perimeter.

Show    Highlights the areas used in the calculation.

Copy    Copies the value to the Clipboard.



Mechanical Parts Library
    Related Topics

File > New > Mechanical Engineering
Creates over 15,000 bolts, fasteners, and steel sections from a library of shapes that are linked to a 
comprehensive parts database.

When you drop the shapes on the page, the Hardware Editor dialog box opens. Using the Hardware 
Editor, you can adjust the shape, type, length, size, view, and thread style (if applicable) of shapes from 
the Mechanical Parts Library.

DIALOG BOX OPTIONS
Type    Specifies an industry standard type, such as ANSI/ASME, ASTM, AS, BSI, DIN, ISO, or JIS.

Size    Specifies a standard size.

Length    Specifies a custom or standard length.

View    Specifies the view you want to use to view the shape.



Move
    Related Topics

Tools > Macro > AEC

Tools > Macro > Macros
Moves shapes on the drawing page a precise distance using x-, y-displacement or polar angle and offset 
or displacement values.

DIALOG BOX OPTIONS
X    Specifies the distance to move the shape in the x axis (horizontal direction) with respect to the page or
local coordinate system. This option is available only when X-Y is checked.

Y    Specifies the distance to move the shape in the y axis (vertical direction) with respect to the page or 
local coordinate system. This option is available only when X-Y is checked.

Length    Specifies the radial distance to move the shape. This option is available only when Polar is 
checked.

Angle    Specifies the angle along which the shape is moved. For example, an angle of 0 degrees moves 
the shape horizontally along the x axis to the right. Angles are measured positively in a counter clockwise 
direction. This option is available only when Polar is checked.

Relative To    Specifies the origin's coordinate system.

Page    Changes the text boxes so that they specify the distance to move horizontally (X) or vertically 
(Y) with respect to the page.

Local    Changes the text boxes so that they specify the distance to move in the x- or y-direction with 
respect to the shape's local coordinates. For example, if a shape is rotated 90 degrees, local-x is up, 
and local-y is to the left.

Coordinates    Specifies the coordinate system used to move the shape.

X, Y    Changes the text boxes so that they specify a distance along the x- (horizontal) or y- (vertical) 
axis.

Polar    Changes the text boxes so that they specify a distance along an angle to move the shape.

Duplicate    Moves a copy of the selected shape and keeps the original shape in its original position.



Move To Wall
    Related Topics

Tools > Macro > AEC > Wall Utility

Tools > Macro > Macros > Wall Utility
Moves a selected wall along its current orientation until it abuts your primary wall selection, without 
changing the wall length. The selected wall moves in the direction in which it is currently oriented to form 
a "T" intersection at a selected angle. This button works only with Double Line Wall shapes.    



Set Wall Dimensions
    Related Topics

Right-click a selected Double Line Wall shape, then choose Set Wall Dimensions
Sets a wall's properties to change the thickness of a wall or the amount to offset its reference line.

DIALOG BOX OPTIONS
Wall Thickness    Specifies the thickness of the wall.

Reference Line Offset    Specifies the distance from the inside of the wall.



Wall Utility
    Related Topics

Tools > Macro > AEC

Tools > Macro > Macros
Works with wall shapes on the Walls, Shell and Structure stencil to form T-joints or corner joints between 
walls, extend walls to meet others, and match doors and windows to wall thicknesses and angles.

NOTE    When you open the Home, Space, Security, or Warehouse templates, Visio Technical displays a 
toolbar that contains toolbar buttons with the same functionality as the Wall Utility dialog box.

OPTIONS
Join Walls    Joins two Double Line Wall shapes of similar or different wall settings, creating a corner joint 
at any angle. If more than two abutting walls are selected, the utility will continue to create a corner at all 
coincident locations.

Move To Wall    Moves a selected wall along its current orientation until it abuts your primary wall 
selection, without changing the wall length. The selected wall moves in the direction in which it is currently
oriented to form a "T" intersection at a selected angle. This button works only with Double Line Wall 
shapes.

Align To/Match Wall    Aligns certain door and window shapes to the wall shape and matches the 
thickness, reference line offset, and angle of the door or window to the wall. When used with like shapes, 
such as only with doors or only with walls, matches a shape's thickness and reference line offset to those 
of the first shape selected, without altering the position or angle.

Extend To Wall    Extends one or more selected double line wall(s) along its current angle until it abuts 
another primary wall to form a "T-joint" at any angle.



About Visio Technical sample drawings
    Related Topics

With its many job-specific stencils and more than 3,000 SmartShapes masters, Visio Technical provides a
solution for most technical drawing needs¾HVAC diagrams, residential designs, engineering schematics, 
space plans, mechanical engineering drawings, and more. 

This section provides sample Visio Technical drawings and diagrams that you can use as a starting point 
for your work or as a source of ideas. The template and types of shapes used for each sample drawing 
are specified above the drawing. 

Sample drawings created using Visio Technical

To view these or similar sample drawings online:

· Choose File > New > Browse Sample Drawings.

· Choose Help > Visio On The Web > Visio Home Page.

TIP    To display template-specific Help on any template, choose Help > Template Help, then select the 
template name.

Click the sample you want to see:

Creating an interior elevation
Creating a floor plan
Creating an HVAC ductwork drawing with HVAC equipment and controls
Creating a security monitoring control systems drawing
Creating an electrical schematics diagram
Creating a pneumatic or hydraulic control system drawing
Creating a process plant design
Creating a site plan



Creating an interior elevation
    Related Topics

To create an interior elevation, choose File > New > Facilities Management > Interior Elevations. The 
stencils for this template contain annotations, and interior elevation shapes.

 
Smart annotation shapes stay connected. Drag and drop dimension lines automatically display real-world 
measurements.



Creating a floor plan
    Related Topics

To create a floor plan, choose File > New > Facilities Management > Space Plan - Building Area; or 
choose AEC > Home - Large Plan or Home - Small Plan. When you open a Space Plan or Home 
Template, Visio Technical displays the Wall Utility toolbar. You can use the toolbar buttons with the Double
Line Wall and other shapes on the Walls, Shell And Structure stencil to perform a wide variety of tasks, 
including joining two Double Line Wall shapes, creating a corner joint, and moving a wall without changing
the wall length.

TIP    Gluing wall shapes to guides or guide intersections allows accurate placement of walls and greater 
flexibility because all shapes glued to a guide will move with the guide when it is moved.

Scaled drawings are a snap when you start with a template. You can change the drawing scale and even set a 
different scale for each page in multiple-page drawings.



Creating an HVAC ductwork drawing with HVAC equipment and controls
    Related Topics

To create an HVAC ductwork drawing, choose File > New > AEC > HVAC Layout. The stencils for this 
template contain ductwork, pipes, and valves for use in creating single- and double-line HVAC plans.

TIP    If you lay out the ductwork equipment as a separate, unique layer in a space plan, you can run the 
Property Reporting Wizard to generate a bill of materials on just the shapes on that layer. 

For HVAC and many other shapes, you can quickly configure some of the pipe and valve shapes by right-clicking 
them and choosing the appropriate command from the shortcut menu. For example, to change an In-line Valve shape
to a 3-Way Valve, right-click the shape, then choose 3-Way.



Creating a security monitoring control systems drawing
    Related Topics

To create a security systems drawing, choose File > New > AEC > Security Systems. The stencils for this 
template contain shapes for alarm and access control, video surveillance, and initiation and annunciation.

TIP    1) If you lay out the security system as a separate, unique layer in a space plan, you can run the 
Property Reporting Wizard to generate a bill of materials on just the shapes on that layer. 2) If you have 
an existing drawing of a floor plan in AutoCAD .dwg or .dxf format, you can insert it into your Visio 
Technical drawing page by choosing Insert > AutoCAD Drawing. Then drag and drop your Security 
Systems shapes on top of the existing drawing.

Many Security Systems shapes include built-in custom-property data that you can change by right-clicking the shape 
and choosing Properties from the shortcut menu. 



Creating an electrical schematics diagram
    Related Topics

To create an electrical schematics diagram, choose File > New > Electrical And Electronic > EE - 
Systems. The stencils for this template include shapes for composite assemblies, maintenance symbols, 
maps and charts, switches and relays, and telecom switches.

TIP    1) If you associate custom-property data with your Electrical And Electronic shapes, you can run the 
Property Reporting Wizard to generate inventory or numerical reports based on the data. 2) If you want to
check circuit connections or feed the circuit data into an external analysis program, choose Tools > 
Macro > Electrical And Electronic > Netlist Generator to output circuit data in Spice format.

When you drop some of the Electrical And Electronic shapes on the drawing page, Visio Technical prompts you for 
information about the shape characteristics so that you can, for example, choose the number of pins on a chip. 



Creating a pneumatic or hydraulic control system drawing
    Related Topics

To create a pneumatic or hydraulic control system drawing, choose File > New > Mechanical 
Engineering > Fluid Power - All Stencils. The stencils for this template include shapes for equipment, 
valves, valve assembly, annotations, and connectors. 

TIP    To facilitate the assembly of custom valves, choose Tools > Macro > Macros > Valve Builder. Or 
drag and drop the Valve Builder shape from the Fluid Power - Valves stencil.

To create valve shapes quickly without having to drag many separate shapes, each with its own settings, use the new
Valve Builder tool. Choose Tools > Macro > Mechanical Engineering > Valve Builder.



Creating a process plant design
    Related Topics

To create a process plant design, choose File > New > Industrial Process > Process Plant Facilities. The 
stencils for this template include shapes for machines and equipment, storage and distribution, and 
warehouse shipping and receiving. 

TIP    To create the background floor plan, use the shapes from the Walls, Shell And Structure or Building 
Core stencil. Or insert an existing AutoCAD drawing (.dwg or .dxf format) by choosing Insert > AutoCAD 
Drawing.

The Visio Technical Industrial Process solutions provide all the shapes you need to create a detailed process plant 
design.



Creating a site plan
    Related Topics

To create a site plan, choose File > New > Facilities Management > Site Plan. The stencils for this 
template include shapes for vehicles, annotations, accessories, parking, roads, and irrigation or watering. 

You can use the new parking stall shapes to quickly choose stall width, length, and angle precisely to scale.



About Visio Technical new features
    Related Topics

For a complete list of new content, tools, and features, see New and improved features for Visio Technical
5.0 and New and improved features for Visio Technical 4.5. 

For a list of developer tools new to version 5.0, see Developing Visio Solutions. 



New and improved features for Visio Technical 5.0
    Related Topics

If you are upgrading from Visio Technical 4.5 to 5.0, the following table can assist you with descriptions of 
the features and functionality that are new or improved in Visio Technical 5.0. Separate tables exist for 
Drawing environment, Compatibility, Tools, and Content so you can go directly to the features you need 
most.

Drawing environment
Feature Description

New!    
Drawing page 
behavior

Resize the drawing page by 
holding down the Ctrl key while 
placing the pointer over an edge 
of the page and dragging.

New!    Custom
fill patterns, 
line patterns, 
and line ends

Create your own custom fill 
patterns, line patterns, and line 
ends, then easily apply them to 
shapes.

New!    Rotated
page and 
guides 

Rotate the page to assist in 
assembling any aspect of the 
drawing that is at an angle to 
normal page orientation.

Improved!    
Toolbar

Organization    Access the 
toolbar buttons more easily now 
that they're grouped by function.

Independent display    Show or 
hide groups of toolbars as you 
work.

Pop-up palettes    Select colors, 
patterns, and other attributes 
from pop-up palettes associated 
with toolbar buttons, such as Fill 
Color, Fill Pattern, or Line 
Weight.

Discoverability    Locate the 
tools on a toolbar quickly, 
because now all the tools appear
when you display a 
toolbar¾they're not hidden on 
drop-down lists.

Compatibility
Feature Description

New!    
Microsoft 
Office 97 
compatibility

Send To support    From within 
Visio Technical, route and send 
drawings through e-mail to other 
recipients.

Binder support    Add headers 



and footers to Visio Technical 
drawings included in Microsoft 
Binder files and view the 
drawings in Print Preview mode.

Microsoft Outlook journaling    
Automatically record time you 
spend working on Visio Technical
drawings in your Outlook journal.

New!    In-place
editing

Edit objects you embed in your 
drawings without leaving Visio 
Technical.

Improved!    
AutoCAD 
compatibility

Use the updated DWG converter 
and new display component that 
enables AutoCAD compatibility 
from Release 10 through 13. 

Display and control layers more 
efficiently.

Tools
Feature Description

New!    
Connector 
technology

Fewer connectors    Choose 
from fewer but more powerful 
connectors that make creating 
your drawing easier.

Dynamic routing    Use 
connectors that reroute around 
shapes when you drop or move 
them.

New!    Offset 
capability

For a specified line or curve in 
Visio Technical, implement the 
offset as a pair of lines that are 
equidistant from the original line 
or curve.

New!    
Automated 
tools

Area Analysis tool    Use to 
calculate the area of a room or 
space created using the Double 
Line Wall shape.

Valve Builder    Use to create 
fluid power valve shapes more 
efficiently. 

Mechanical Parts Library    Use 
to create over 15,000 bolts, 
fasteners, and structural sections
from a compact library of shapes 
that are linked to a 
comprehensive parts database.

Netlist Generator tool Use to 
create a component connection 



list from electrical circuit 
diagrams in a Visio Technical 
drawing. Output the list in Spice 
format for external analysis. 

New!    Full-
screen preview

View drawings in full-screen or 
presentation mode without 
toolbars or other interface 
elements, and navigate from 
page to page using the mouse 
buttons or arrow keys.

New!    ODMA 
support

Handle Visio Technical drawings 
as part of your Document 
Management System (DMS). 
When Visio Technical detects the
presence of the Open Document 
Management API (ODMA), it 
hands file management 
operations to the ODMA 
program.

New!    Shape 
Explorer

Search for and catalog shapes, 
stencils, or templates stored on 
your own computer or on the 
Visio Web site.

New!    Faster 
report creation 

Generate inventory and numeric 
reports quickly with the improved
Property Reporting Wizard, even 
for very large drawings that 
include shapes with many 
custom-property fields.

Improved!  
Web tools

Add hyperlinks    Efficiently add 
hyperlinks to Visio Technical 
shapes and drawing pages so 
you can jump to other drawing 
pages or files, documents 
created in other applications, or 
to Web sites (URLs). Link to a 
specific location within a 
document or on a Web page.

Save drawings as HTML files    
Use the improved interface for 
saving Visio Technical drawings 
as HTML files you can publish on
the Web. 

Use Microsoft Internet 
Explorer to open and edit Visio
Technical files    Open and edit 
Visio Technical files in Internet 
Explorer. Use the browser's 
Forward and Back buttons to 
move between Visio Technical 
drawings, Web pages, and other 



files open in Internet Explorer.

Improved!    
Graphics/file 
support

Import enhanced metafiles, 
CorelDRAW 7 .cdr format files, 
and AutoCAD .dwg and .dxf 
format files. Export Visio 
Technical drawings as enhanced 
metafiles.

Improved!    
Database 
Wizard

Database Wizard    Now 
supports more ODBC drivers and
new custom-property types. Use 
to control some ODBC settings 
from within Visio Technical.

Drawing monitor    Control when
the drawing monitor starts. Add 
an action to a drawing page so 
you can start the drawing monitor
by right-clicking the page.

Content
Feature Description

New!    AEC 
solutions

Security Systems shapes    
Includes shapes that meet the 
SIA/IAPSC standards.

HVAC Double Line (ductwork) 
stencil    Improved to provide 
more functionality.

New!    
Mechanical 
Engineering 
solutions

Valve Builder    Use to efficiently 
create fluid power valve shapes.

Mechanical Parts Library    
Create over 15,000 bolts, 
fasteners, and steel sections 
from a compact library of shapes 
that are linked to a 
comprehensive parts database.

New!    
Process Plant 
Facility 
solutions

Shop Floor shapes    Includes 
machine and equipment shapes, 
such as drill press, generator, 
compressor, and conveyor 
shapes. Also includes storage 
and distribution shapes. 

Warehouse shapes    Includes 
shipping and receiving shapes, 
such as loading bays, waste 
handling, gas handling 
compounds, and site storage 
shapes.

New and Area Analysis tool    Use to 



improved!    
Facilities 
Management 
solutions

calculate the area of a room or 
space created using the Double 
Line Wall shape.

New Interior Elevations shapes
Includes shapes for commercial 
office interior wall elevations 
such as doors, windows, wall 
lights, washroom/restroom 
shapes, and emergency and life 
safety signs.

Site - Accessories shapes    
Includes solid waste enclosures, 
site lights, and drains.

Site - Parking And Roads 
shapes    Includes commercial 
parking layout shapes for parking
lots, sidewalks, and drive aisles.

Vehicles    Shapes for 
commercial vehicles including 
turn sweep radius.

Walls, Shell And Structure 
shapes    Includes shapes for 
exterior walls and openings, and 
structural elements such as 
columns.

New and 
improved!    
Electrical 
Engineering 
solutions

Netlist Generator tool    Creates
a component connection list from
electrical circuit diagrams in a 
Visio Technical drawing. Outputs 
the list in Spice format for 
external analysis. 

Revised Electrical Engineering
shapes    Align with grids more 
effectively.

New!    
Marketing 
shapes

New marketing stencils enable 
quick, customizable creation of 
colorful and informative 
marketing presentations that 
include 3-D pyramids, process 
and feature comparison charts, 
matrices, clip art, and more.

Improved!    
Project 
Timeline 
Solution

Synchronized date information
Tied to Timeline position on the 
chart.

Ability to read and write 
Microsoft Project files



New and improved features for Visio Technical 4.5
    Related Topics

If you are upgrading from Visio Technical 4.1 to 5.0, the following tables describe additional new features 
and functionality that were added in Visio Technical 4.5.

Tools
Feature Description

New!  
Microsoft 
Visual Basic 
for 
Applications 
(VBA) 
development 
environment

Built-in VBA and Automation for 
developing custom solutions. 
Benefits of an embedded VBA 
file include faster performance 
and easier distribution of files.

New!    Internet
tools

Hyperlinks    Use the new 
Hyperlinking wizard to 
automatically create hyperlinks to
a page, document, or URL.

HTML    Publish Visio Technical 
drawings on the Internet or an 
intranet by saving them in HTML 
format with image map 
capabilities. URL links 
associated with a shape are 
preserved.

Drawing formats    Export Visio 
Technical drawings to the most 
common Internet raster formats 
(.gif, .jpg, and .png).

New!    
Advanced 
formatting 
tools

Automatic layout    Work faster 
and get better looking flowcharts 
and block diagrams with 
automatic placement of shapes 
and connecting lines.

Custom colors    In addition to 
allowing custom color selection, 
you can include formula-driven 
customizable color behavior. 

Gradient fills    Add polish to 
drawings and diagrams with 
gradient fills. 

Improved!    
Database 
Wizard

Database Wizard now supports 
the SQL Server and Oracle 
databases¾and not only 
database tables, but also views, 
system tables, and aliases.

Improved!    Switchable interface    Visio 



Windows 
integration

Technical 4.5 is designed for 
Windows NT 4.0 and Windows 
95. The switchable Visio 
Technical user interface now 
includes the Microsoft Office 97 
look.

Enhanced 32-bit performance   

Content
Feature Description

New and 
improved!    
Shapes

HVAC Industrial Controls    
Shapes include symbolic 
ductwork, sensor, and equipment
commonly used in the HVAC 
industry. Use to schematically 
represent common HVAC 
equipment and controls. 

Building Wall    Advanced wall 
shapes and utilities to join, move,
and align walls and related 
shapes such as windows and 
doors. New double-line geometry
based on variable reference line 
layout. Uses SmartShapes 
technology to resolve the most 
common intersection geometry.



About drawing tips for Visio Technical
    Related Topics

You can use Visio Technical for many drawing tasks, including applying new custom patterns, redlining 
drawings, adding text to drawings, using pages and layers to structure a drawing, drawing precisely to 
scale, and working with multiple pages. 

For specific tips and techniques, see Related Topics.

For general information on drawing in Visio, see the Using Visio Products manual.



Working with fill patterns, line patterns, and line ends
    Related Topics

Visio Technical provides a multitude of fill patterns, line patterns, and line ends, many of which are familiar
to AutoCAD users. In addition to the numerous new patterns included in Visio Technical, you can also 
design your own custom line and fill patterns and line ends that you can reuse later in Visio Technical 
drawings. 

Design your own fill pattern to reuse in your drawings.

Visio Technical includes a number of stencils that contain over 200 new fill and line patterns, including 
architectural and ANSI-standard hatch and fill patterns. When you open these stencils, the patterns they 
contain appear as a choice in the Line or Fill dialog box. For example, you can open a custom pattern 
stencil and then apply those patterns as fills from the Fill dialog box. The custom patterns don't appear as 
masters on the stencil because patterns are not true shapes, but attributes that you apply to shapes. If 
you open the drawing's local stencil as original, which gives you read/write access, then you can see the 
fill pattern shapes and edit or delete them.

Once you create a pattern, you can select it and see a preview in the Fill or Line dialog box, including all 
formatting attributes such as color and shadow. 

To apply a line or fill pattern:    Select the shape to which you want to apply the pattern. Choose 
Format > Line to apply a line or line end pattern. Choose Format > Fill to apply a fill pattern.





Adding text to drawings
    Related Topics

You may need to include a substantial amount of text for title blocks, labels, or annotations in your 
technical drawings. Visio Technical simplifies the task of putting text where you want it. Click most shapes
and just start typing to add text. In addition, many shapes already include appropriate text or labels that 
you can quickly customize.

Many shapes have a control handle that allows you to move text easily. For finer control over text, you 
can use the text ( ) and text block (

) tools on the Standard toolbar. Select a shape with the text tool to open its text block and highlight the 
contents. Then you can edit the text, change its formatting, or change the color of the text or its 
background.

Use the text block tool to rotate, move, and resize a shape's text block.

Adding a title block to a technical drawing
Title blocks are essential to almost all technical drawings. In Visio Technical, the quickest way to add a 
title block to a drawing is to use shapes from the General - Title Blocks stencil, which includes

· Entire title blocks and labels that conform to appropriate standards for various paper sizes.

· Ruled columns.

· Date, description, revision, page number, and other individual blocks with which you can build a title 
block of your own.

If the title blocks stencil is not already displayed, choose File > Stencils > Annotation > General - Title Blocks. Drag a 
title block shape onto the drawing page, and then start typing.



TIP    Place title block shapes on a background page of your drawing. That way, if your drawing has 
multiple pages, each of which requires a title block, you can assign the background containing your title 
block shapes to each drawing page that needs to use it. You can also change the scale of the drawing 
page without affecting the title blocks.

Adding labels and annotations to technical drawings
In Visio Technical, you can add labels and annotations to drawings.

· To add a text label to a shape, select the shape, then type.

· To add annotations, choose File > Stencils > Annotation, then choose one or more of the following 
annotation stencils: General - Annotation; General - Connectors; General - Dimensioning,; General - 
Drawing Tool Shapes; General - Title Blocks. Or choose File > Stencils > Mechanical Engineering > 
Mech Eng - Welding for a stencil of annotation shapes for welding.

NOTE    With many shapes on the annotation stencils, you can glue the endpoints of the shapes to 
connection points on drawing shapes, so the annotation stays connected if you move the shape to which 
it's glued.



Using pages and layers to structure a drawing and its shapes
    Related Topics

You can structure a single drawing by using multiple pages, layering, and backgrounds.

Working with multiple pages
For some drawing projects, you may want to create a single drawing file that contains many drawing 
pages. For example, a file could represent a construction project with the overall floor plan on one 
drawing page, interior elevations on another page, and details for walls and doors on another page. New 
drawings in Visio Technical open with only one drawing page, but you can add as many new pages as 
you need. 

Each page in a multiple-page drawing can have its own settings, for example, each can have a different drawing 
scale.

When you create a new drawing page, by default it inherits the size, orientation, scale, measurement unit,
shadow offset, ruler, and grid settings of the page currently displayed in the drawing window. You can 
then change the settings for the new page, if necessary.

To create a new page:    Display a page you want to base the new page on, then choose Insert > Page. 
In the Page dialog box, name the page or use the name Visio Technical assigns. Set measurement units 
and shape shadow offsets if you want, then click OK.

To navigate between pages:    Click the Next Page button ( ) or the Previous Page button (

) on the Page toolbar, or choose Edit > Go To, and then select the page you want.
Creating layers and backgrounds in Visio Technical
You can set up your drawing more efficiently by assigning shapes to layers or by placing shapes on a 
background page. A layer is a category of shapes on a page. A background is a page that appears behind
another page. Both layers and backgrounds help you organize information in your drawing, but you use 
them for different reasons:

· Create layers when you want to organize categories of shapes and text on the same drawing page.

· Create a background when you want the same shape to appear on more than one drawing page, or if 
you want it to appear at a different scale than the foreground. 



Assign shapes to layers so that you can selectively view, edit, print, or lock the shapes against editing based on their 
layer assignments. For example, this drawing has an Interior Walls layer (A), a Work Stations layer (B), and a Vertical
Circulation layer (C).

Visio Technical drawings are different from many CAD drawings, in which you always use layers. In Visio 
Technical, you don't have to use layers, but when you do, you can easily create and delete layers and 
assign and reassign shapes to them. You can even assign the same shape to many different layers.



Positioning shapes using rotated pages and guides
    Related Topics

In Visio Technical you can work on every detail of the design of your drawing in an orthogonal (horizontal 
and vertical) manner. You can rotate the contents of the page for any aspect of the drawing that is at an 
angle to the rest of the drawing. The rulers and grid remain parallel to the window frame, but any guides 
on the page move with the rotated page. 

NOTE    Rotating the page affects the screen view only¾it does not affect the actual drawing or the the 
orientation in which it prints.

Rotating the page
You can rotate the page like any other shape, with the zero point on the ruler as the center of rotation. 
The status bar displays the degree of the rotation. 

        

        

Rotating the contents of the page makes it easy to work on every aspect of the drawing in an orthogonal manner.

 



When you move the rotation tool over a page corner, it becomes a round rotation pointer (A). The page's drop 
shadow indicates that the page is unrotated. A rotated page has no drop shadow. When you drag the round rotation 
pointer, the page rotates around the zero point (B), which is in the lower-left corner by default. 

To rotate a page:    Display the page you want to rotate, and then choose the Rotation tool ( ) from the 
Standard toolbar. Position the cursor over any corner of the page. The cursor changes to a round rotation 
pointer (

). Drag the corner of the page to the rotation angle you want, then release the mouse button. 
TIP    To quickly rotate an angled section of your drawing so that it's orthogonal, right-click an angled guide
and choose View As Horizontal or View As Vertical.

Rotating guides precisely
In architectural layouts, the precision provided by the rotation tool (0.1 degree) is adequate. However, 
some technical drawings, such as those produced in mechanical parts drafting, may require that you 
specify a precise angle of rotation.

To rotate guides precisely:    Select the guide(s) you want to rotate and choose Shape > Size & 
Position. Under Guide Orientation, choose Rotated. Under Guide Parameters, type a value for Angle to 
set the angle of rotation.

NOTE    Guides are visible at any angle. A guide is constrained to always move in a direction 
perpendicular to the guide. This ensures that objects glued to the rotated guide continue to move on its 
axis.



Drawing precisely to scale
    Related Topics

Whenever you need to create the exact spatial relationships of very small or very large objects in the 
space of a drawing page, you need to set a drawing scale. For example, in an architectural floor plan, the 
scale might be 1:50 (metric), or ¼" = 1' 0" (imperial); in a drawing of a bolt, the scale might be 1:5.

In Visio Technical, drawing units are sizes in the real world. Page units are sizes on the printed page. The 
ratio of page units to drawing units is the drawing scale.

When you set a drawing scale, ruler units reflect scale units. To set ruler units that differ from scale units, choose 
File > Page Setup > Drawing Scale. 

All Visio Technical templates that are designed for measured diagrams are set up with the appropriate 
drawing scale.    If you want to work with a different drawing scale, you can change the setting.

Scale is a page property. In a multiple-page Visio Technical drawing, each page can have a different scale. 

To set a drawing scale:    Display the page for which you want to set a scale. Choose File > Page Setup, 
then click the Drawing Scale tab. Choose a standard architectural or engineering scale, or under Drawing 
Scale, enter a custom scale, and then click OK. Visio Technical redraws the page and adjusts the rulers to
reflect the new settings.



Moving a shape a specified distance
    Related Topics

You can move a shape or a duplicate of a shape a specified distance using the Move tool. With this tool, 
you can specify the direction, distance, coordinates, and angle along which a shape is moved. 

To move a shape a specified distance:    Choose Tools > Macro > Macros. From the list in the Macros 
dialog box, choose Move, then click Run. For X, specify the distance to move the shape in the horizontal 
direction with respect to the page or local coordinate system. For Y, specify the distance to move the 
shape in the vertical direction with respect to the page or local coordinate system. Complete the 
remaining options as needed. 

TIP    If your drawing is based on an AEC or Facilities Management template, you can access the Move 
tool through the Move X/Y ( ) and Move Polar (

) buttons on the Wall Utility toolbar.

A Move local y

B Move page y

C Move local x

D Move page x

A Distance to move

B Angle at which to move



Setting the offset for a shape
    Related Topics

Offset, a basic drawing operation in most CAD systems, is now available in Visio Technical. For a 
specified line or curve, Visio Technical implements the offset as a pair of lines or curves that are 
equidistant from the original line or curve. The offset shape types that are produced typically match the 
original shape. However, if the offset to a curve is not a line, arc, or elliptical arc, then the offset produced 
is a spline, or series of splines that approximate the offset of the curve. This approximation comes as 
close as possible to fitting all the points that are a specified distance from a curve.

To set the offset distance for a shape's geometry:    Select the shape and choose Shape > 
Operations > Offset. In the Offset dialog box, enter the distance you want. The offset distance you set last
appears as the default offset distance the next time you open the dialog box.

Visio Technical generates offsets on both sides for all the paths in the selected shapes. The result is that 
two new lines appear¾one to the left of the original line, and one to the right. You can then choose to 
delete a line if necessary, even the original, which is always positioned in the center.

NOTE    Offset shapes inherit line patterns from the original shapes. They do not inherit any fill patterns or 
text that is included in the original shapes.

A Original line and curve

B The offset line and curve on the inside are trimmed to miter corners.

C The offset line and curve on the outside are extended to miter corners.



Setting a redlining layer
    Related Topics

During the life cycle of a particular technical drawing, an engineer or architect may forward the file to a 
manager, client, or quality assurance person, who marks changes to be made. Using Visio Technical, you 
can streamline this markup or redlining process by creating a separate layer for review comments. 
Placing the comments on a layer by themselves makes them easy to view, print, and color separately 
from the rest of the drawing.

To set a redlining layer:    Display the drawing for which you want to create a redlining layer, then choose
View > Layer Properties. In the Layer Properties dialog box, click New, type Redlining, then click OK. 
Select the Redlining layer, then click the Active cell or the Color cell. If you click the Active cell, a check 
mark appears next to Redlining in the Active column. If you click the Color cell, choose a color from the 
Layer Color list at the bottom of the dialog box.

TIP    If more than one person is reviewing the drawing, create a redlining layer for each reviewer and 
assign each layer a different display color. 



Printing large drawings
    Related Topics

If the size of a drawing is larger than the paper in your printer, you can reduce the drawing before you 
print. Otherwise, Visio Technical tiles the drawing¾that is, the drawing prints across several sheets of 
paper. Visio Technical never crops a drawing to fit within the margins you have set. 

A drawing on a large drawing page prints by tiling across several sheets of printer paper.

To determine whether a drawing will tile:    Choose View > Page Breaks. Gray lines appear on the 
drawing page, indicating the printed page size and margins selected in the Print Setup dialog box.

To increase the area where tiled drawings overlap:    Choose File > Page Setup > Print Setup. In the 
Print Setup dialog box, type larger amounts for the margin settings, then click OK. The larger the margins,
the greater the overlap.

Previewing your drawing
To see the effect of changes you make to page settings, you can preview your drawing before you print. 
Previewing shows you whether the objects that appear on your drawing page onscreen will fit as you 
intend on the currently selected paper size. 

To see how a drawing will appear when it's printed:    Choose File > Print Preview. If, after previewing 
your drawing, you want to make changes to the drawing page or printer settings, such as orientation, size,
margins, and so on, choose File > Page Setup.

NOTE    Visio Technical supports printing to any plotter that has a Windows driver. For best results, 
however, make sure you are using the most recent plotter driver for your version of Windows. Otherwise, 
your drawing may not plot as expected. 



About Visio Technical solutions, templates, and stencils
    Related Topics

To create a drawing in Visio Technical, you usually open a solution folder. Each solution consists of a 
number of templates: a file that serves as the container for the shapes, drawing page, and tools you use 
to create a drawing. Each template includes one or more stencils with SmartShapes masters¾shapes 
that are programmed to act the way you need them to in a particular context¾appropriate styles, and a 
drawing scale. You can drag the shapes from the stencils to the drawing page to create your drawing, or 
you can draw your own shapes by using the Visio drawing tools on the toolbar.

When you choose template from a Visio Technical solution folder, you actually open a template file that includes 
shapes on stencils, a drawing page, styles, and other tools. 



TIP    To quickly search for shapes, stencils, templates, and wizards in Visio Technical, or in other Visio 
products you have on your computer, use Visio Shape Explorer. Choose Tools > Macro > Shape Explorer,
then type a word or phrase that describes the item you want to find. Shape Explorer categorizes the 
search results by shape, stencil, template, wizard, and product.



Templates and stencils in Visio Technical 5.0
    Related Topics

The following table, which is organized by drawing type, lists the Visio Technical solutions and the 
templates and stencils each solution contains.

AEC Solutions
    Templates     Stencils

HVAC Layout Annotations, Connectors, Pipes 
1, Pipes 2, Valves 1, Valves 2, 
HVAC Double Line, HVAC Single
Line

Plumbing Annotations, Connectors, Pipes 
1, Pipes 2, Valves 1, Valves 2, 
Plumbing

Home - Bath 
And Kitchen 
Plan

Electrical And Telecom; 
Annotations; Walls, Shell And 
Structure; Appliance; Bath And 
Kitchen; Cabinets

Home - Large 
Plan

Electrical And Telecom: 
Annotations; Walls, Shell And 
Structure; Appliance; Bath And 
Kitchen; Cabinets; Furniture; 
Building Core

Home - Small 
Plan

Electrical And Telecom; 
Annotations; Walls, Shell And 
Structure; Appliance; Bath And 
Kitchen; Cabinets; Furniture; 
Building Core

HVAC Control 
Schematics

HVAC Controls, HVAC 
Equipment

Security 
Systems

Alarm And Access Control; Video
Surveillance; Initiation And 
Annunciation; Walls, Shell And 
Structure; Building Core; 
Annotations

Landscape - L
arge Plan

Plants; Watering; Site; 
Recreation; Annotations; 

Landscape - S
mall Plan

Plants; Watering; Site; 
Recreation; Annotations

Annotation Solutions
    Templates     Stencils

None Annotations; Connectors; 
Drawing Tool Shapes; Title 
Blocks 

Block Diagram Solutions
    Templates     Stencils



Basic Diagram Basic Shapes

Block Diagram
With 
Perspective

Blocks With Perspective

Block Diagram Blocks (Raised), Blocks 

Business Diagram Solutions
    Templates     Stencils

Charts And 
Graphs

Charting Shapes

Form Design Forms Shapes

Marketing 
Charts And 
Diagrams

Marketing Diagrams, Marketing 
Clipart, Charting Shapes

Office Layout Office Layout Shapes

Organization 
Chart

Organization Chart Shapes

Project 
Timeline

Project Timeline Shapes

Electrical and Electronic Solutions
    Templates     Stencils

None Qualifying Symbols

EE - Circuits 
And Logic

Analog And Digital Logic, 
Terminals And Connectors, 
Transmission Paths, Integrated 
Circuit Components

EE - General Fundamental Items, 
Transmission Paths, 
Semiconductors And Electron 
Tubes, Switches And Relays

EE - Industrial 
Control 
Systems

Fundamental Items, 
Transmission Paths, Switches 
And Relays, Terminals And 
Connectors, Transformers And 
Windings, Rotating Equipment 
And Mech Functions, 
Annotations, Connectors

EE - Systems Composite Assemblies; 
Maintenance Symbols; Maps 
And Charts; Switches And 
Relays; Telecom Switching And 
Peripheral Equipment; Terminals 
And Connectors; Transformers 
And Windings; Transmission 
Paths; VHF,  UHF, SHF

Facilities Management Solutions



    Templates     Stencils
Interior 
Elevations

Annotations; Interior Elevations

Site Plan Vehicles; Watering; Annotations; 
Accessories; Parking And Roads;
Landscape Plants

Space 
Plan - Building 
Area

Electrical And Telecom; Walls, 
Shell And Structure; Annotations; 
Office Desks; Services; Office 
Furniture; Building Core

Space 
Plan - Room 
Plan

Electrical And Telecom; Walls, 
Shell And Structure; Annotations;
Office Desks; Services; Office 
Furniture; Modular Office 
Furniture; Modular Wall Panels; 
Accessories

Flowchart Solutions
    Templates     Stencils

Audit Diagram Audit, Connectors And Callouts

Data Flow 
Diagram

Data Flow

Flowchart - Ad
vanced

Audit, Connectors And Callouts, 
Data Flow, Miscellaneous, SDL, 
Total Quality Management, Work 
Flow

Flowchart - Ba
sic

Flowchart, Flowchart (Additional)

Mind Mapping 
Diagram

Mind Mapping Shapes

IDEF0 
Diagram

IDEF0 Diagram Shapes

SDL Diagram SDL, Connectors And Callouts

TQM Diagram Total Quality Management

Work Flow 
Diagram

Work Flow, Connectors And 
Callouts

Industrial Process Solutions
    Templates     Stencils

Pipes And 
Valves - All 
Stencils

Pipes 1, Pipes 2, Valves 1, 
Valves 2, Connectors, 
Annotations

Process 
Flow - All 
Stencils

Valves 1, Pipes 1, 
Instrumentation, Pumps And 
Compressors, Heat Equipment, 
Vessels, Equipment, Connectors

Process Plant Machines And Equipment; 



Facilities Storage And Distribution; 
Warehouse - Shipping And 
Receiving; Walls, Shell And 
Structure; Vehicles

Maps Solutions
    Templates     Stencils

None Flags

Directional 
Map

Directional Map Shapes

Geographic 
Maps

Maps Of Africa, Maps Of Asia, 
Maps Of The Middle East, Maps 
Of N. And S. America, Maps Of 
The World, Maps Of Europe, 
Maps of U.S. And Canada

Mechanical Engineering Solutions
    Templates     Stencils

None Fasteners 1, Fasteners 2, 
Geometric Dimensioning And 
Tolerancing, Welding

Mechanical 
Parts Library

Nuts - Bolts - Screws, Fasteners,
Steel And Aluminum Shapes, 
Bearings And Washers, Seals

Fluid 
Power - All 
Stencils

Equipment, Valves, Valve 
Assembly, Annotations, 
Connectors

Mech 
Eng - General 
Working 
Drawing

Annotations; Title Block; Drawing
Tool Shapes; 

Network Diagram Solutions
    Templates     Stencils

Basic Network Basic Network, Basic Network 
(Additional)

Visio Extras Solutions
    Templates     Stencils

None Custom Patterns (Scaled), 
Custom Patterns (Unscaled), 
Custom Line Patterns, Borders, 
Callouts, Clipart, Connectors, 
Symbols



About wizards and other automated tools
    Related Topics

Wizards and other automated tools in Visio Technical automate routine tasks, perform unique functions, 
and create special drawing types from scratch. The following list describes what each tool helps you 
accomplish.

TIP    Many wizards and automated tools include a Help or More Info button. Click one of these buttons 
when you need background information or help understanding the options on a screen.

Wizards and automated tools in Visio Technical
Name What it does How to run

it

Area Analysis Allows you to 
calculate the area of 
a room or space 
created using the 
Double Line Wall 
shape.

Tools > 
Macro > 
Facilities 
Manageme
nt > Area 
Analysis

Array Shapes Creates and 
arranges multiple 
copies of a shape at 
regular intervals. 
You can specify the 
number of rows and 
columns in the array 
and the amount of 
space between each
shape.

Tools > 
Array 
Shapes

Build Region Assembles selected 
geographic shapes 
into a region. You 
can designate an 
anchor shape to 
control the position 
and size of other 
shapes in the region.

Tools > 
Macro > 
Maps > 
Build 
Region

Chart Shape 
Wizard

Creates stackable 
and extendable 
shapes you can use 
to add special 
effects to charts.

Tools > 
Macro > 
Business 
Diagram > 
Chart 
Shape 
Wizard

Convert 
AutoCAD 
Drawings

Converts multiple 
AutoCAD drawings 
into Visio Technical 
drawings.

Tools > 
Macro > 
Visio 
Extras > 
Convert 
AutoCAD 
Drawings



Convert 
AutoCAD 
Library

Converts symbol 
libraries in AutoCAD 
to Visio Technical 
masters on a stencil.

Tools > 
Macro > 
Visio 
Extras > 
Convert 
AutoCAD 
Library

Custom 
Properties 
Editor

Edits, adds, or 
deletes custom-
property data from 
masters on a 
standalone stencil or
that you've used in a
particular drawing.

Tools > 
Macro > 
Custom 
Properties 
Editor

Database 
Wizard

Links Visio shapes 
and drawings to 
databases created in
ODBC-compliant 
database programs. 

Tools > 
Macro > 
Database >
Database 
Wizard

Flowchart-
TQM Diagram
Wizard

Guides you through 
the process of laying
out and formatting a 
Cause/Effect, Force 
Field, Top Down, or 
Cross Functional 
(Rummler-Brache) 
diagram.

Tools > 
Macro > 
Flowchart >
Flowchart - 
TQM 
Diagram 
Wizard

Measure Calculates the total 
perimeter and area 
of any closed shape,
such as a shape that
outlines the floor 
area of a floor plan. 

Tools > 
Macro > 
Visio 
Extras > 
Measure

Mechanical 
Parts Library

Allows you to create 
over 15,000 bolts, 
fasteners, and 
structural sections 
from a library of 
shapes that are 
linked to a 
comprehensive parts
database.

File > New 
> 
Mechanical
Engineerin
g > 
Mechanical
Parts 
Library 

Move Moves shapes on 
the drawing page a 
precise distance 
using x-, y-, or polar 
coordinates. 

Tools > 
Macro > 
AEC  > 
Move

Netlist 
Generator

Performs a circuit 
analysis of electrical 
circuit diagrams in a 
Visio Technical 

Tools > 
Macro > 
Electrical 
and 



drawing and 
generates a netlist 
for analysis in Spice 
format. 

Electronic >
Netlist 
Generator

Office Layout 
Wizard

Guides you through 
the process of 
setting the drawing 
scale, choosing the 
page size and 
orientation, and 
creating the basic 
wall structure for an 
office layout 
diagram.

Tools > 
Macro > 
Business 
Diagram > 
Office 
Layout 
Wizard

Organization 
Chart Wizard

Generates an 
organization chart 
from a    variety of 
file formats.

Tools > 
Macro > 
Business 
Diagram > 
Organizatio
n Chart 
Wizard

Page Layout 
Wizard

Automates the setup
for the page size, 
orientation, and 
scale for a drawing. 
Assists you in 
adding a title block 
and border to the 
pages in a new or 
existing drawing.

Tools > 
Macro > 
Visio 
Extras > 
Page 
Layout 
Wizard

Print 
ShapeSheet

Prints all values and 
formulas in a 
ShapeSheet 
spreadsheet. 

Tools > 
Macro > 
Visio 
Extras > 
Print 
ShapeShee
t

Project 
Timeline 
Wizard

Generates a project 
timeline from a data 
file in Microsoft 
Excel (.xls), comma-
or tab-delimited text,
or Microsoft Project 
Exchange (.mpx) 
format. Or generates
a project timeline 
structure into which 
you can enter data.

Tools > 
Macro > 
Business 
Diagram > 
Project 
Timeline 
Wizard

Property 
Reporting 
Wizard

Generates inventory 
reports, such as bills
of materials or 
equipment and 

Tools > 
Property 
Report



furniture inventories,
and numeric reports,
such as cost totals 
or averages, from 
shapes which have 
data in their custom-
property fields.

Shape 
Explorer

Locates specific 
shapes and stencils 
in Visio products. 

Tools > 
Macro > 
Shape 
Explorer

SmartShape 
Wizard

Customizes the 
appearance or 
behavior of a 
selected shape's 
text, connectors, 
notes, or protection.

Tools > 
Macro > 
Visio 
Extras > 
SmartShap
e Wizard

Stencil Report
Wizard

Generates a Visio 
Technical drawing of
the masters on a 
selected stencil. You
can choose how 
many masters 
appear on a page, 
whether the page 
includes a header or
footer, and whether 
or not to list each 
master's name and 
status bar prompt.

Tools > 
Macro > 
Visio 
Extras > 
Stencil 
Report 
Wizard

Valve Builder Facilitates more 
efficient creation of 
valve shapes. You 
can select basic 
valves and 
assembly-required 
controls from a 
dialog box.

Tools > 
Macro > 
Mechanical
Engineerin
g > Valve 
Builder; or 
File > 
Stencils > 
Mechanical
Engineerin
g > Fluid 
Power - 
Valves, 
then drag 
the Valve 
Builder 
shortcut 
shape to 
the drawing
page

Wall Utility Displays a toolbar 
that works with 

Tools > 
Macro > 



shapes on the Walls,
Shell And Structure 
stencil to form T-
joints or corner joints
between walls, 
extend walls to meet
others, and match 
doors and windows 
to wall thicknesses 
and angles. 

AEC  > 
Wall Utility



About creating custom solutions
    How To
    Related Topics

By taking advantage of the Visio SmartShapes® technology and open architecture, you can create 
specialized shapes, develop combinations of shapes and programs that model the real world and solve 
specific drawing problems, and customize the user interface.

The following tools are available to you in the Visio Technical development environment:

· The ShapeSheet spreadsheet, which takes you under the surface of shapes to create formulas for 
specific shape behavior.

· Microsoft Visual Basic for Applications (VBA), with which you can create macros and control Visio 
Technical through Automation.

· The Visio Type Library, which contains Automation descriptions of the objects, properties, methods, 
events, and constants that Visio Technical exposes to Automation controllers.

The book Developing Visio Solutions, which comes with Visio Technical, contains everything you need to 
know about Visio Technical as a development platform, including sample code, tips, and techniques. In 
addition, you can view the online Automation Reference by choosing Help > Automation Reference in 
Visio Technical.

You can also visit the Visio Solutions Development section of the Visio Corporation Web site 
(http://www.visio.com/devweb/), where you can learn more about Visio Technical as a development 
platform and find other developer resources.



Working with the ShapeSheet spreadsheet



Working with the ShapeSheet spreadsheet
When you want to use specialized shapes that model the behavior and appearance of the real-world 
objects they represent, you can create them by working with formulas in the shapes' ShapeSheet 
spreadsheets.

Behind each Visio shape or shape you draw using the Visio drawing tools is a ShapeSheet spreadsheet 
containing formulas that determine how a shape behaves. When you make changes to a shape on the 
drawing page, you update its ShapeSheet formulas. You can also make changes directly in the 
ShapeSheet spreadsheet, where you have more precise control over a shape's appearance and 
behavior. For example, you can add formulas that create a control handle, change a shape's fill color if it 
reaches a certain size, or make one shape's behavior dependent upon the behavior of another shape on 
the drawing page.

The ShapeSheet spreadsheet contains sections, each of which controls part of the shape.

To display a shape's ShapeSheet spreadsheet:

· Select the shape, then choose Window > Show ShapeSheet.

Once you've created specialized shapes, you can make the shapes part of a drawing solution by storing 
them on new stencils and distributing the shapes and stencils in a template.

    Overview



Working with the Automation



Working with Automation
You can take advantage of the Visio open architecture to solve graphics problems and create custom 
solutions. Open architecture means that Visio Technical exposes its objects, such as windows, drawing 
pages, shapes, layers, menus, and toolbars, through a well-structured Automation interface. Using a 
development environment that supports Automation, you can write programs to control Visio objects. For 
example, you can automatically update drawings you create from data that changes from day to day. Or, 
you can automate routine shape development tasks that you perform over and over.

To write the programs, or macros, that control Visio objects, you can use the fully-licensed version of 
Microsoft Visual Basic for Applications (VBA) that comes with Visio Technical, or you can use Visual 
Basic, C/C++, or any other Automation controller.

Visio Technical includes a type library¾a file that contains Automation descriptions of the objects, 
properties, methods, events, and constants that Visio Technical exposes to Automation controllers. Visio 
object types can help you write code more effectively because you can view Visio Automation 
descriptions in and copy code templates from the Object Browser.

To open the Visual Basic Editor and create, debug, or run VBA programs:

· Choose Tools > Macro > Visual Basic Editor.

TIP    You can also press Alt+F11 to open the Visual Basic Editor.
    Overview



Additional sources of Visio Technical information
    Related Topics

The following table lists places you can find information about Visio Technical and describes the type of 
information you'll find in each place.

More information on Visio Technical
Source Type of information

Using Visio 
Products 

A good place to start if you've 
never used Visio products 
before.

Covers tasks common to Visio 
Standard, Visio Technical, and 
Visio Professional.

Developing 
Visio Solutions

Contains information about the 
Visio program as a development 
platform, including sample code, 
tips, and techniques.

Online 
Automation 
Reference

Describes the Visio objects, 
properties, and methods that you
can access from an external 
program.

Choose Help > Automation 
Reference.

More Info 
buttons on 
Visio Technical
wizard screens

Opens a window of information 
about the options on a wizard 
screen, or about Visio features 
relevant to the task the wizard 
helps you complete.

Click More Info on a wizard 
screen.

Screen tips Toolbar buttons    Float the 
pointer over a toolbar button for a
moment to see a tip about what 
the button does.

Control handles    Float the 
pointer over a control handle ( ) 
on a shape for a moment to see 
a tip about what dragging the 
handle accomplishes.

Online help An online version of the 
information in Using Visio 
Technical and in Using Visio 
Products, and an explanation of 
every Visio command and dialog 
box option. You can search the 
file by keyword.

To look in online help, choose 



Help > Visio Help.

To learn about options in a dialog
box, click the Help button in the 
dialog box.

Template help Provides information about how 
to create specific drawing types, 
including the most efficient 
sequence in which to work, how 
shapes work together, and tips 
and tricks.

Choose Help > Template Help, 
double-click Visio Templates, and
then double-click a drawing type.

Shape help A window of information that 
explains how to use a shape.

Right-click any shape, then 
choose Shape Help.

Technical 
support

Choose Help > Visio On The 
Web > Online Support.

Visio 
Corporation 
Web site

Includes information about Visio 
Corporation and its products, 
such as:

Case studies that describe how 
corporations have used Visio 
products.

White papers that describe in 
detail certain Visio features or 
functionality.

Downloadable files for updates 
and programs that can help you 
use Visio more effectively.

Developer tips and tools.

Choose Help > Visio On The 
Web > Visio Home Page.

Drawing 
Resources 
Web page

A Web page on the Visio 
Corporation Web site that 
contains links to resources 
related to drawing types Visio 
Technical supports.

Choose Help > Visio On The 
Web > Drawing Resources.

Visio Solutions
Library

A section of the Visio Corporation
Web site where you can learn 
about and purchase job-specific 
shapes, time-saving utilities, and 
other custom drawing solutions.



Choose Help > Visio On The 
Web > Visio Solutions Library.




