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Introduction

Introducing Visio Technical

Whether you use technical drawings to design new products, improve manu-
facturing productivity, manage facilities, or improve processes and procedures,
the Visio® Technical drawing program can help you efficiently create and man-
age your technical drawings.

With Visio Technical, you can create and share technical schematics efficiently
and accurately, without the learning curve that can be associated with
computer-aided design (CAD) software. If you’re accustomed to thinking of
drawings as a collection of vector-based graphics, Visio Technical lets you think
about graphics in an entirely new way. You can assemble schematics using pre-
drawn, task-specific SmartShapes® masters that are programmed to behave like
the real-world objects they represent.

You can then integrate Visio Technical drawings into reports, proposals, presen-
tations, spreadsheets, and technical documentation created with other
Microsoft Windows programs. In addition, you can include word-processed
text or spreadsheet data in your technical drawings.

Visio Technical 5.0 provides

• More than 3,000 SmartShapes masters.

• Powerful wizards and other tools that automate tasks such as linking shapes
and drawings to databases dynamically, inserting hyperlinks, or creating re-
ports such as a bill of materials based on shapes in a drawing.

• The ability to import and export your existing Autodesk AutoCAD files
(Release 10 through Release 13) and other graphic file formats.

• The ability to save drawings as HTML files and publish them on an intranet
or the Internet.

• Built-in support for Microsoft Exchange, Microsoft Mail, and Lotus Notes.

• Integration with the Windows Desktop and Microsoft Office 97.

• Visio solutions that can be customized and programmed to suit your needs
using Automation and ActiveX controls.
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About this manual

This manual provides information specific to Visio Technical. For information
about tasks and tools common to Visio Technical, Visio Professional, and
Visio Standard, see the Using Visio Products: For Use with Visio Standard,
Visio Professional, and Visio Technical manual. For information about designing
custom shapes and solutions, see the Developing Visio Solutions manual.

Contents of Using Visio Technical

Chapter Description

1 Introduces Visio Technical 5.0.

2 Includes instructions and minimum requirements for installing
Visio Technical.

3 Shows sample Visio Technical drawings and the templates and
stencils used to create them.

4 Summarizes new features of Visio Technical 5.0 and 4.5.

5 Includes drawing tips, such as how to add text to drawings, set up
a drawing scale, redline drawings, and print multiple pages.

6 Discusses how you can use templates and stencils to create
drawings quickly, and lists all templates and stencils provided in
Visio Technical 5.0

7 Lists all wizards and other automated tools in Visio Technical 5.0.

8 Discusses displaying AutoCAD files in Visio Technical, and
converting AutoCAD files to and from Visio Technical format.

9 Provides an introductory look at creating custom solutions and
working with ShapeSheet technology.

10 Describes where to find more information about Visio Technical
including using online Help and Visio sites on the World Wide
Web, and where to locate more sample drawings.
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Installation

Installing Visio Technical

This section includes information about installing Visio Technical and where to
go for help if you have installation problems.

System configuration
Required:

• Microsoft Windows 95 or Microsoft Windows NT 4.0

• VGA or better display

• Mouse

• CD-ROM drive for installation

Recommended:

• Pentium, Pentium Pro, or Pentium II PC with 16 MB or more RAM for
Windows 95, and 24 MB or more RAM for Windows NT

• Up to 105 MB of hard disk space required for a full installation; 15 MB for
minimum installation

Optional:

• Windows-compatible printer or plotter

• Modem and Internet access

• Local area network (volume licenses available)
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How to prepare for installation
• Close all programs and turn off virus protection software to prevent installa-

tion conflicts.

• If you have another version of Visio installed on your computer and do not
want to overwrite that version, change the default installation folder for
Visio Technical during installation setup.

• To avoid overwriting stencils or templates you’ve customized or created,
place them into a separate folder before you install.

Installing electronic versions
of the manuals and other supplementary files
During installation, you have the option of installing the .pdf format files for
the following manuals:

• Using Visio Products

• Using Visio Technical

• Developing Visio Solutions

If you work in a corporate environment where most users don’t receive printed
copies of the manuals, you can make these electronic copies available on the
corporate network or intranet.

To open, read, or print the .pdf files, you need to install the Adobe Acrobat
Reader on your computer. You can install the Acrobat Reader by double-
clicking the Setup.exe file located in the Acrobat Reader folder on the Visio
Technical CD.

If you choose not to install the .pdf files during installation, you can still copy
them to your computer. The .pdf files are located in the Docs folder on the Visio
Technical CD.
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Installing Visio Technical from the CD
You must be running Microsoft Windows 95 or Microsoft Windows NT 4.0 to
install Visio Technical.

Installation starts automatically when you insert the Visio Technical CD into
your CD-ROM drive. If installation does not start automatically, you can install
Visio Technical using the following procedure.

To install Visio Technical on Windows 95 or Windows NT 4.0:

1. Insert the Visio Technical CD into your CD-ROM drive.

2. From the Start menu, choose Run.

3. In the Run dialog box, type d:\setup, where d is the letter assigned to your
CD-ROM drive.

4. Click OK, then follow the instructions on your screen.

The Setup program guides you through the installation process.

Installing Visio Technical on a network
There are two ways to set up Visio Technical on a network server:

• Install a copy on a network server so that multiple workstations can run it
from the server.

• Place the Visio Technical files on a network server so the program can be
copied onto the hard disks of individual workstations.

For information about network administrator installation options, see
Network.txt at the root of your Visio Technical CD.

If you need help with installation
If you encounter problems while installing Visio Technical, call Technical Sup-
port (see Using Visio Products for the correct number for your area). For help
with technical issues, see the Visio Corporation Web site, which you can access
from within Visio by choosing Help > Visio On The Web > Online Support; or
point your Web browser to http://www.Visio.com/.
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Visio Technical
sample drawings

About Visio Technical sample drawings

With its many job-specific stencils and more than 3,000 SmartShapes masters,
Visio Technical provides a solution for most technical drawing needs—HVAC
diagrams, residential designs, engineering schematics, space plans, mechanical
engineering drawings, and more.

This section provides sample Visio Technical drawings and diagrams that you can
use as a starting point for your work or as a source of ideas. The template and
types of shapes used for each sample drawing are specified above the drawing.
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Sample drawings created using Visio Technical
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To view these or similar sample drawings online:

• Choose File > New > Browse Sample Drawings.

• Choose Help > Visio On The Web > Visio Home Page.

TIP  To display template-specific Help on any template, choose Help > Template
Help, then select the template name.

Related topics
About Visio Technical solutions, templates, and stencils ......................................... 37
About wizards and other automated tools ................................................................ 43
Basing new drawings on templates ........................................... Using Visio Products  9

Creating an interior elevation

To create an interior elevation, choose File > New > Facilities Management >
Interior Elevations. The stencils for this template contain annotations, dimen-
sioning (architectural), and interior elevation shapes.
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Smart annotation shapes stay connected. Drag and drop dimension lines automatically
display real-world measurements.



V I S I O  T E C H N I C A L  S A M P L E  D R A W I N G S 9

Creating a floor plan

To create a floor plan, choose File > New > Facilities Management > Space
Plan - Building Area; or choose AEC > Home - Large Plan or Home - Small
Plan. When you open a Space Plan or Home Template, Visio Technical displays
the Wall Utility toolbar. You can use the toolbar buttons with the Double Line
Wall and other shapes on the Walls, Shell and Structure stencil to perform a
wide variety of tasks, including joining two Double Line Wall shapes, creating a
corner joint, and moving a wall without changing the wall length.

TIP  Gluing wall shapes to guides or guide intersections allows accurate place-
ment of walls and greater flexibility because all shapes glued to a guide will
move with the guide when it is moved.
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Scaled drawings are a snap when you start with a template. You can change the drawing
scale and even set a different scale for each page in multiple-page drawings.
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Creating an HVAC ductwork drawing with
HVAC equipment and controls

To create an HVAC ductwork drawing, choose File > New > AEC > HVAC
Layout. The stencils for this template contain ductwork, pipes, and valves for
use in creating single- and double-line HVAC plans.

TIP  If you lay out the ductwork equipment as a separate, unique layer in a space
plan, you can run the Property Reporting Wizard to generate a bill of materials
on just the shapes on that layer.
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For HVAC and many other shapes, you can quickly configure some of the pipe and valve
shapes by right-clicking them and choosing the appropriate command from the shortcut
menu. For example, to change an In-line Valve shape to a 3-Way Valve, right-click the shape,
then choose 3-Way.
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Creating a security monitoring control systems drawing

To create a security systems drawing, choose File > New > AEC > Security
Systems. The stencils for this template contain shapes for alarm and access
control, video surveillance, and initiation and annunciation.

TIPS  1) If you lay out the security system as a separate, unique layer in a space
plan, you can run the Property Reporting Wizard to generate a bill of materials
on just the shapes on that layer.  2) If you have an existing drawing of a floor
plan in AutoCAD .dwg or .dxf format, you can insert it into your Visio Technical
drawing page using Insert > AutoCAD Drawing. Then drag and drop your
Security Systems shape on top of the existing drawing.
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Many Security System shapes include built-in custom-property data that you can change by
right-clicking the shape and choosing Properties from the shortcut menu.
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Creating an electrical schematics diagram

To create an electrical schematics diagram, choose File > New > Electrical And
Electronic > EE - Systems. The stencils for this template include shapes for
composite assemblies, maintenance symbols, maps and charts, switches and
relays, and telecom switches.

TIPS  1) If you associate custom-property data with your electrical and elec-
tronic systems shapes, you can run the Property Reporting Wizard to generate
inventory or numerical reports based on the data.  2) If you want to check cir-
cuit connections or feed the circuit data into an external analysis program,
choose Tools > Macro > Electrical And Electronic > Netlist Generator to output
circuit data in Spice format.

C 1
1 0

1

2

3

4

8

7

6

5

OSC./
TIMER

R 1
1 0 K

R 2
53 .6K

R 3
2 0 K

L 3
5 0 µ H

C 2
2 0 0 p F

C 3
.022

C 4
.001

T P 2

R 4
6 .2K

R 5
3 .3K

C 5
.001

L 1
0 . 4 7 µ H

Q 1
M P S H 1 1

R 6
2 2 0

X T A L 1
49 .89  MHz

C 6
2 7 p F

T 1

L 2
0 . 0 6 µ H

1 - M E T E R
W H I P
A N T E N N A

C 7
1 8 0 p F

L 4
5 0 µ H

S 1
C 8

.001

L 5
5 0 µ H

T O
6-15

V O L T S
D C

S H I E L D

When you drop some of the Electrical And Electronic shapes on the drawing page,
Visio Technical prompts you for information about the shape characteristics so that
you can, for example, choose the number of pins on a chip.
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Creating a pneumatic or hydraulic control system drawing

To create a pneumatic or hydraulic control system drawing, choose File >
New > Mechanical Engineering > Fluid Power - All Stencils. The stencils for
this template include shapes for equipment, valves, valve assembly, annotations,
and connectors.

TIP  To facilitate the assembly of custom valves, choose Tools > Macro >
Macros > Valve Builder. Or drag and drop the Valve Builder shape from the
Fluid Power - Valves stencil.
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To create valve shapes quickly without having to drag many separate shapes, each with its
own settings, use the new Valve Builder tool. Choose Tools > Macro > Mechanical
Engineering > Valve Builder.
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Creating a process plant design

To create a process plant design, choose File > New > Industrial Process >
Process Plant Facilities. The stencils for this template include shapes for
machines and equipment, storage and distribution, and warehouse shipping
and receiving.

TIP  To create the background floor plan, use the shapes from the Walls, Shell
And Structure or Building Core stencil. Or insert an existing AutoCAD drawing
(.dwg or .dxf format) by choosing Insert > AutoCAD Drawing.
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The Visio Technical Industrial Process solutions provide all the shapes you need to create a
detailed process plant design.
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Creating a site plan

To create a site plan, choose File > New > Facilities Management > Site Plan.
The stencils for this template include shapes for vehicles, annotations, dimen-
sioning (architectural), accessories, parking, roads, and irrigation or watering.
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You can use the new parking stall shapes to quickly choose stall width, length, and angle
precisely to scale.
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New and
improved features

About Visio Technical new features

Visio Technical provides new and improved tools, smarter shapes, improve-
ments to the drawing environment, and smooth integration with Microsoft
Office 97 applications. In addition, Visio Technical offers improved AutoCAD
compatibility and enhanced Internet support.

For a complete list of new content, tools, and features, see the tables in the fol-
lowing topics.

For a list of developer tools new to version 5.0, see Developing Visio Solutions.

Related topics
About Visio Technical solutions, templates, and stencils ......................................... 37
New and improved features for Visio Technical 5.0 ................................................. 18
New and improved features for Visio Technical 4.5 ................................................. 21
New features for developers ............................................ Developing Visio Solutions  5
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New and improved features for Visio Technical 5.0

If you are upgrading from Visio Technical 4.5 to 5.0, the following table can as-
sist you with descriptions of the features and functionality that are new or
improved in Visio Technical 5.0. Separate tables exist for Drawing environment,
Compatibility, Tools, and Content so you can go directly to the features you
need most.

Drawing environment

Feature Description

New!  Drawing page behavior Resize the drawing page by holding down the Ctrl key while placing the pointer
over an edge of the page and dragging.

New!  Custom fill patterns, Create your own custom fill patterns, line patterns, and line ends, then easily apply
line patterns, and line ends them to shapes.

New!  Rotated page and guides Rotate the page to assist in assembling any aspect of the drawing that is at an angle
to normal page orientation.

Improved!  Toolbar Organization  Access the toolbar buttons more easily now that they’re grouped by
function.

Independent display  Show or hide groups of toolbars as you work.

Pop-up palettes  Select colors, patterns, and other attributes from pop-up palettes
associated with toolbar buttons, such as Fill Color, Fill Pattern, or Line Weight.

Discoverability  Locate the tools on a toolbar quickly, because now all the tools
appear when you display a toolbar—they’re not hidden on drop-down lists.

Compatibility

Feature Description

New!  Microsoft Office 97 compatibility Send To support  From within Visio Technical, route and send drawings through
e-mail to other recipients.

Binder support  Add headers and footers to Visio Technical drawings included in
Microsoft Binder files and view the drawings in Print Preview mode.

Microsoft Outlook journaling  Automatically record time you spend working on
Visio Technical drawings in your Outlook journal.

New!  In-place editing Edit objects you embed in your drawings without leaving Visio Technical.

Improved!  AutoCAD compatibility Use the updated DWG converter and new display component that enables
AutoCAD compatibility from Release 10 through 13.

Display and control layers more efficiently.
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Tools

Feature Description

New!  Connector technology Fewer connectors  Choose from fewer but more powerful connectors that make
creating your drawing easier.

Dynamic routing  Use connectors that reroute around shapes when you drop or
move them.

New!  Offset capability For a specified line or curve in Visio Technical, implement the offset as a pair of
lines that are equidistant from the original line or curve.

New!  Automated tools Area Analysis  Use to calculate the area of a room or space created using the
Double Line Wall shape.

Valve Builder  Use to create fluid power valve shapes more efficiently.

Mechanical Parts Library  Use to create over 15,000 bolts, fasteners, and steel
sections from a compact library of shapes that are linked to a comprehensive parts
database.

Netlist Generator Use to create a component connection list from electrical circuit
diagrams in a Visio Technical drawing. Output the list in Spice format for external
analysis.

New!  Full-screen preview View drawings in full-screen or presentation mode without toolbars or other
interface elements, and navigate from page to page using the mouse buttons or
arrow keys.

New!  ODMA support Handle Visio Technical drawings as part of your Document Management
System (DMS). When Visio Technical detects the presence of the Open Document
Management API (ODMA), it hands file management operations to the ODMA
program.

New!  Faster report creation Generate inventory and numeric reports quickly with the improved Property
Reporting Wizard, even for very large drawings that include shapes with many
custom-property fields.

Improved!  Web tools Add hyperlinks  Efficiently add hyperlinks to Visio Technical shapes and drawing
pages so you can jump to other drawing pages or files, documents created in other
applications, or to Web sites (URLs). Link to a specific location within a document
or on a Web page.

Save drawings as HTML files  Use the improved interface for saving Visio
Technical drawings as HTML files you can publish on the Web.

Use Microsoft Internet Explorer to open and edit Visio Technical files  Open
and edit Visio Techncial files in Internet Explorer. Use the browser’s Forward and
Back buttons to move between Visio Technical drawings, Web pages, and other
files open in Internet Explorer.

Table continued on next page.
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Tools (continued)

Feature Description

New!  Shape Explorer Search for and catalog shapes, stencils, or templates stored on your own computer
or on the Visio Web site.

Improved!  Graphics/file support Import enhanced metafiles, CorelDRAW 7 .cdr format files, and AutoCAD .dwg
and .dxf format files. Export Visio Technical drawings as enhanced metafiles.

Improved!  Database Wizard Database Wizard  Now supports more ODBC drivers and new custom property
types. Use to control some ODBC settings from within Visio Technical.

Drawing monitor  Control when the drawing monitor starts. Add an action to a
drawing page so you can start the drawing monitor by right-clicking the page.

Content

Feature Description

New!  AEC solutions Security Systems shapes  Includes shapes that meet the SIA/IAPSC standards.

HVAC Double Line (ductwork) stencil  Improved to provide more functionality.

New!  Mechanical Engineering solutions Valve Builder  Use to efficiently create fluid power valve shapes.

Mechanical Parts Library  Create over 15,000 bolts, fasteners, and structural
sections from a compact library of shapes that are linked to a comprehensive
parts database.

New!  Process Plant Facility solutions Shop Floor shapes  Includes machine and equipment shapes, such as drill press,
generator, compressor, and conveyor shapes. Also includes storage and distribu-
tion shapes.

Warehouse shapes  Includes shipping and receiving shapes, such as loading bays,
waste handling, gas handling compounds, and site storage shapes.

New and improved! Area Analysis tool  Use to calculate the area of a room or space created using the
Facilities Management solutions Double Line Wall shape.

New Interior Elevations shapes  Includes shapes for commercial office interior
wall elevations such as doors, windows, wall lights, washroom/restroom shapes,
and emergency and life safety signs.

Site - Accessories shapes  Includes solid waste enclosures, site lights, and drains.

Site - Parking And Roads shapes  Includes commercial parking layout shapes for
parking lots, sidewalks, and drive aisles.

Vehicles  Shapes for commercial vehicles including turn sweep radius.

Walls, Shell And Structure shapes  Includes shapes for exterior walls and
openings, and structural elements such as columns.
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Feature Description

New and improved!  Electrical Netlist Generator tool  Creates a component connections list from electrical
Engineering solutions circuit diagrams in a Visio Technical drawing. Outputs the list in Spice format

for external analysis.

Revised Electrical Engineering shapes  Align with grids more effectively.

New!  Marketing shapes New marketing stencils enable quick, customizable creation of colorful and
informative marketing presentations that include 3-D pyramids, process and
feature comparison charts, matrices, clip art, and more.

Improved!  Project Timeline Solution Synchronized date information  Tied to Timeline position on the chart.

Ability to read and write Microsoft Project files

New and improved features for Visio Technical 4.5

If you are upgrading from Visio Technical 4.1 to 5.0, the following tables
describe additional new features and functionality that were added in Visio
Technical 4.5.

Tools

Feature Description

New!  Microsoft Visual Basic for Built-in VBA and Automation for developing custom solutions. Benefits of an
Applications (VBA) development embedded VBA file include faster performance and easier distribution of files.
environment

New!  Internet tools Hyperlinks  Use the new Hyperlinking wizard to automatically create hyperlinks to
a page, document, or URL.

HTML  Publish Visio Technical drawings on the Internet or an intranet by saving
them in HTML format with image map capabilities. URL links associated with a
shape are preserved.

Drawing formats  Export Visio Technical drawings to the most common Internet
raster formats (.gif, .jpg, and .png).

New!  Advanced formatting tools Automatic layout  Work faster and get better looking flowcharts and block
diagrams with automatic placement of shapes and connecting lines.

Custom colors  In addition to allowing custom color selection, you can include
formula-driven customizable color behavior.

Gradient fills  Add polish to drawings and diagrams with gradient fills.

Table continued on next page.
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Tools (continued)

Feature Description

Improved!  Database Wizard Database Wizard now supports the SQL Server and Oracle databases—and not
only database tables, but also views, system tables, and aliases.

Improved!  Windows integration Switchable interface  Visio Technical 4.5 is designed for Windows NT 4.0 and
Windows 95. The switchable Visio Technical user interface now includes the
Microsoft Office 97 look.

Enhanced 32-bit performance

Content

Feature Description

New and improved!  Shapes HVAC Industrial Controls  Shapes include symbolic ductwork, sensor, and
equipment commonly used in the HVAC industry. Use to schematically represent
common HVAC equipment and controls.

Building Wall  Advanced wall shapes and utilities to join, move, and align walls
and related shapes such as windows and doors. New double-line geometry based
on variable reference line layout. Uses SmartShapes technology to resolve the most
common intersection geometry.
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Drawing tips
for Visio Technical

About drawing tips for Visio Technical

You can use Visio Technical for many drawing tasks, including applying new
custom patterns, redlining drawings, adding text to drawings, using pages and
layers to structure a drawing, drawing precisely to scale, and working with mul-
tiple pages.

For specific tips and techniques, see the following topics.

For general information on drawing in Visio, see the Using Visio Products manual.

Working with fill patterns, line patterns, and line ends

Visio Technical provides a multitude of fill patterns, line patterns, and line ends,
many of which are familiar to AutoCAD users. In addition to the numerous new
patterns included in Visio Technical, you can also design your own custom line
and fill patterns and line ends that you can reuse later in Visio Technical drawings.

Design your own fill pattern to reuse in your drawings.
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Visio Technical includes a number of stencils that contain over 200 new fill and
line patterns, including architectural and ANSI-standard hatch and fill patterns.
When you open these stencils, the patterns they contain appear as a choice in
the Line or Fill dialog box. For example, you can open a custom pattern stencil
and then apply those patterns as fills from the Fill dialog box. The custom pat-
terns don’t appear as masters on the stencil because patterns are not true
shapes, but attributes that you apply to shapes. If you open the drawing’s local
stencil as original, which gives you read/write access, then you can see the fill
pattern shapes and edit or delete them.

Once you create a pattern, you can select it and see a preview in the Fill or Line
dialog box, including all formatting attributes such as color and shadow.

To apply a line or fill pattern:  Select the shape to which you want to apply the
pattern. Choose Format > Line to apply a line or line end pattern. Choose
Format > Fill to apply a fill pattern.

Related topics
Creating custom patterns ............................................ Developing Visio Solutions  150
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Adding text to drawings

You may need to include a substantial amount of text for title blocks, labels, or
annotations in your technical drawings. Visio Technical simplifies the task of
putting text where you want it. Click most shapes and just start typing to add
text. In addition, many shapes already include appropriate text or labels that
you can quickly customize.

Many shapes have a control handle that allows you to move text easily. For finer

control over text, you can use the text ( ) and text block ( ) tools on the
Standard toolbar. Select a shape with the text tool to open its text block and
highlight the contents. Then you can edit the text, change its formatting, or
change the color of the text or its background.

eros
et

accu
msan

eros et
accumsan

Use the text block tool to rotate, move, and resize a shape’s text block.

Adding a title block to a technical drawing
Title blocks are essential to almost all technical drawings. In Visio Technical,
the quickest way to add a title block to a drawing is to use shapes from the
General - Title Blocks stencil, which includes

• Entire title blocks and labels that conform to appropriate standards for vari-
ous paper sizes.

• Ruled columns.

• Date, description, revision, page number, and other individual blocks with
which you can build a title block of your own.
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If the title blocks stencil is not already displayed, choose File > Stencils > Annotation >
General - Title Blocks. Drag a title block shape onto the drawing page, and then start typing.

TIP  Place title block shapes on a background page of your drawing. That way, if
your drawing has multiple pages, each of which requires a title block, you can
assign the background containing your title block shapes to each drawing page
that needs to use it. You can also change the scale of the drawing page without
affecting the title blocks.

Adding labels and annotations to technical drawings
In Visio Technical, you can add labels and annotations to drawings.

• To add a text label to a shape, select the shape, then type.

• To add annotations, choose File > Stencils > Annotation, then choose
one or more of the following annotation stencils: General - Annotation;
General - Connectors; General - Dimensioning, Architectural; General -
Dimensioning, Engineering; General - Drawing Tool Shapes; General - Title
Blocks. Or choose File > Stencils > Mechanical Engineering > Mech Eng -
Welding for a stencil of annotation shapes for welding.

NOTE  With many shapes on the annotation stencils, you can glue the endpoints
of the shapes to connection points on drawing shapes, so the annotation stays
connected if you move the shape to which it’s glued.

Related topics
About customizing text behavior ................................................................. Visio Help
About storing data in shapes ................................................. Using Visio Products  177
About working with text ......................................................... Using Visio Products  75
Adding annotation layers to drawings .................................... Using Visio Products  84
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Using pages and layers to structure a drawing and its shapes

You can structure a single drawing by using multiple pages, layering, and
backgrounds.

Working with multiple pages
For some drawing projects, you may want to create a single drawing file that
contains many drawing pages. For example, a file could represent a construc-
tion project with the overall floor plan on one drawing page, interior elevations
on another page, and details for walls and doors on another page. New draw-
ings in Visio Technical open with only one drawing page, but you can add as
many new pages as you need.
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Each page in a multiple-page drawing can have its own settings, for example, each can have
a different drawing scale.

When you create a new drawing page, by default it inherits the size, orientation,
scale, measurement unit, shadow offset, ruler, and grid settings of the page cur-
rently displayed in the drawing window. You can then change the settings for
the new page, if necessary.

To create a new page:  Display a page you want to base the new page on, then
choose Insert > Page. In the Page dialog box, name the page or use the name
Visio Technical assigns. Set measurement units and shape shadow offsets if you
want, then click OK.

To navigate between pages:  Click the Next Page button ( ) or the Previous
Page button ( ) on the Page toolbar, or choose Edit > Go To, and then select
the page you want.
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Creating layers and backgrounds in Visio Technical
You can set up your drawing more efficiently by assigning shapes to layers or by
placing shapes on a background page. A layer is a category of shapes on a page.
A background is a page that appears behind another page. Both layers and
backgrounds help you organize information in your drawing, but you use them
for different reasons:

• Create layers when you want to organize categories of shapes and text on the
same drawing page.

• Create a background when you want the same shape to appear on more than
one drawing page, or if you want it to appear at a different scale than the
foreground.
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Assign shapes to layers so that you can selectively view, edit, print, or lock the shapes
against editing based on their layer assignments. For example, this drawing has an Interior
Walls layer (A), a Work Stations layer (B), and a Vertical Circulation layer (C).

Visio Technical drawings are different from many CAD drawings, in which you
always use layers. In Visio Technical, you don’t have to use layers, but when you
do, you can easily create and delete layers and assign and reassign shapes to
them. You can even assign the same shape to many different layers.

Related topics
About layers ............................................................................ Using Visio Products  143
Creating multiple-page drawings ........................................... Using Visio Products  23
Using backgrounds for common page elements .................... Using Visio Products  26
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Positioning shapes using rotated pages and guides

In Visio Technical you can work on every detail of the design of your drawing in
an orthogonal (horizontal and vertical) manner. You can rotate the contents of
the page for any aspect of the drawing that is at an angle to the rest of the draw-
ing. The rulers and grid remain parallel to the window frame, but any guides on
the page move with the rotated page.

NOTE  Rotating the page affects the screen view only—it does not affect the
actual drawing or the orientation in which it prints.

Rotating the page
You can rotate the page like any other shape, with the zero point on the ruler as
the center of rotation. The status bar displays the degree of the rotation.

Rotating the contents of the page makes it easy to work on every aspect of the drawing in an
orthogonal manner.

A

                

B

When you move the rotation tool over a page corner, it becomes a round rotation pointer (A).
The page’s drop shadow indicates that the page is unrotated. A rotated page has no drop
shadow. When you drag the round rotation pointer, the page rotates around the zero point
(B), which is in the lower-left corner by default.
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To rotate a page:  Display the page you want to rotate, and then choose the
Rotation tool ( ) from the Standard toolbar. Position the cursor over any corner

of the page. The cursor changes to a round rotation pointer ( ). Drag the cor-
ner of the page to the rotation angle you want, then release the mouse button.

TIP  To quickly rotate an angled section of your drawing so that it’s orthogonal,
right-click an angled guide and choose View As Horizontal or View As Vertical.

Rotating guides precisely
In architectural layouts, the precision provided by the rotation tool (0.1 degree)
is adequate. However, some technical drawings, such as those produced in me-
chanical parts drafting, may require that you specify a precise angle of rotation.

To rotate guides precisely:  Select the guide(s) you want to rotate and choose
Shape > Size & Position. Under Guide Orientation, choose Rotated. Under
Guide Parameters, type a value for Angle to set the angle of rotation.

NOTE  Guides are visible at any angle. A guide is constrained to always move in
a direction perpendicular to the guide. This ensures that objects glued to the
rotated guide continue to move on its axis.

Related topics
About positioning shapes precisely ...................................... Using Visio Products  155
Rotating and resizing pages ..................................................... Using Visio Products  19
Snapping shapes for automatic alignment ........................... Using Visio Products  156
Specifying exact size and position for shapes and guides ... Using Visio Products  162
Using guides to reposition multiple shapes ......................... Using Visio Products  162

Drawing precisely to scale

Whenever you need to create the exact spatial relationships of very small or
very large objects in the space of a drawing page, you need to set a drawing
scale. For example, in an architectural floor plan, the scale might be 1:50 (met-
ric), or ¼" = 1' 0" (imperial); in a drawing of a bolt, the scale might be 1:5.

In Visio Technical, drawing units are sizes in the real world. Page units are sizes on
the printed page. The ratio of page units to drawing units is the drawing scale.
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When you set a drawing scale, ruler units reflect scale units. To set ruler units that differ from
scale units, choose File > Page Setup > Drawing Scale.

All Visio Technical templates that are designed for measured diagrams are set
up with the appropriate drawing scale.  If you want to work with a different
drawing scale, you can change the setting.

¼" = 1' 1"

1:25

1:1

Scale is a page property. In a multiple-page Visio Technical drawing, each page can have a
different scale.

To set a drawing scale:  Display the page for which you want to set a scale.
Choose File > Page Setup, then click the Drawing Scale tab. Choose a standard
architectural or engineering scale, or under Drawing Scale, enter a custom scale,
and then click OK. Visio Technical redraws the page and adjusts the rulers to
reflect the new settings.

Related topics
About measuring and scaling in drawings ........................... Using Visio Products  169
Controlling grid spacing and origin ..................................... Using Visio Products  159
Setting drawing scales ............................................................ Using Visio Products  170
Using backgrounds for common page elements .................... Using Visio Products  26
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Moving a shape a specified distance

You can move a shape or a duplicate of a shape a specified distance using the
Move tool. With this tool, you can specify the direction, distance, coordinates,
and angle along which a shape is moved.

To move a shape a specified distance:  Choose Tools > Macro > Macros. From
the list in the Macros dialog box, choose Move, then click Run. For X, specify
the distance to move the shape in the horizontal direction with respect to the
page or local coordinate system. For Y, specify the distance to move the shape in
the vertical direction with respect to the page or local coordinate system. Com-
plete the remaining options as needed.

TIP  If your drawing is based on an AEC or Facilities Management template, you
can access the Move tool through the Move X/Y ( ) and Move Polar ( )
buttons on the Wall Utility toolbar.
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A Move local y A Distance to move
B Move page y B Angle at which to move
C Move local x
D Move page x

Related topics
About positioning shapes precisely ...................................... Using Visio Products  155
Setting the offset for a shape ...................................................................................... 33
Snapping shapes for automatic alignment ........................... Using Visio Products  156
Specifying exact size and position for shapes and guides ... Using Visio Products  162
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Setting the offset for a shape

Offset, a basic drawing operation in most CAD systems, is now available in
Visio Technical. For a specified line or curve, Visio Technical implements the
offset as a pair of lines or curves that are equidistant from the original line or
curve. The offset shape types that are produced typically match the original
shape. However, if the offset to a curve is not a line, arc, or elliptical arc, then the
offset produced is a spline, or series of splines that approximate the offset of the
curve. This approximation comes as close as possible to fitting all the points
that are a specified distance from a curve.

To set the offset distance for a shape’s geometry:  Select the shape and choose
Shape > Operations > Offset. In the Offset dialog box, enter the distance you
want. The offset distance you set last appears as the default offset distance the
next time you open the dialog box.

Visio Technical generates offsets on both sides for all the paths in the selected
shapes. The result is that two new lines appear—one to the left of the original
line, and one to the right. You can then choose to delete a line if necessary, even
the original, which is always positioned in the center.

NOTE  Offset shapes inherit line patterns from the original shapes. They do not
inherit any fill patterns or text that is included in the original shapes.

A

B

C

A

A Original line and curve
B The offset line and curve on the inside are trimmed to miter corners.
C The offset line and curve on the outside are extended to miter corners.

Related topics
About positioning shapes precisely ...................................... Using Visio Products  155
Moving a shape a specified distance .......................................................................... 32
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Setting a redlining layer

During the life cycle of a particular technical drawing, an engineer or architect
may forward the file to a manager, client, or quality assurance person, who
marks changes to be made. Using Visio Technical, you can streamline this
markup or redlining process by creating a separate layer for review comments.
Placing the comments on a layer by themselves makes them easy to view, print,
and color separately from the rest of the drawing.

To set a redlining layer:  Display the drawing for which you want to create a
redlining layer, then choose View > Layer Properties. In the Layer Properties
dialog box, click New, type Redlining, then click OK. Select the Redlining layer,
then click the Active cell or the Color cell. If you click the Active cell, a check
mark appears next to Redlining in the Active column. If you click the Color cell,
choose a color from the Layer Color list at the bottom of the dialog box.

TIP  If more than one person is reviewing the drawing, create a redlining layer
for each reviewer and assign each layer a different display color.

Related topics
About layers ............................................................................ Using Visio Products  143
Adding annotation layers to drawings .................................... Using Visio Products  84
Converting a Visio Technical file to AutoCAD format ............................................. 57

Printing large drawings

If the size of a drawing is larger than the paper in your printer, you can reduce
the drawing before you print. Otherwise, Visio Technical tiles the drawing—
that is, the drawing prints across several sheets of paper. Visio Technical never
crops a drawing to fit within the margins you have set.

A drawing on a large drawing page prints by tiling across several sheets of printer paper.
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To determine whether a drawing will tile:  Choose View > Page Breaks. Gray
lines appear on the drawing page, indicating the printed page size and margins
selected in the Print Setup dialog box.

To increase the area where tiled drawings overlap:  Choose File > Page Setup >
Print Setup. In the Print Setup dialog box, type larger amounts for the margin
settings, then click OK. The larger the margins, the greater the overlap.

Previewing your drawing
To see the effect of changes you make to page settings, you can preview your
drawing before you print. Previewing shows you whether the objects that ap-
pear on your drawing page onscreen will fit as you intend on the currently
selected paper size.

To see how a drawing will appear when it’s printed:  Choose File > Print Pre-
view. If, after previewing your drawing, you want to make changes to the
drawing page or printer settings, such as orientation, size, margins, and so on,
choose File > Page Setup.

NOTE  Visio Technical supports printing to any plotter that has a Windows
driver. For best results, however, make sure you are using the most recent plot-
ter driver for your version of Windows. Otherwise, your drawing may not plot
as expected.

Related topics
About printing drawings ....................................................... Using Visio Products  107
Creating multiple-page drawings ........................................... Using Visio Products  23
Previewing drawings before you print ................................. Using Visio Products  108
Printing headers, footers, and page numbers ....................... Using Visio Products  116
Printing selected shapes or pages .......................................... Using Visio Products  115





6
Visio Technical solutions,
templates, and stencils

About Visio Technical solutions, templates, and stencils

To create a drawing in Visio Technical, you usually open a solution folder. Each
solution consists of a number of templates: a file that serves as the container for
the shapes, drawing page, and tools you use to create a drawing. Each template
includes one or more stencils with SmartShapes masters—shapes that are pro-
grammed to act the way you need them to in a particular context—appropriate
styles, and a drawing scale. You can drag the shapes from the stencils to the
drawing page to create your drawing, or you can draw your own shapes by us-
ing the Visio drawing tools on the toolbar.
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Stencil:
Pipes and Valves - Valves 1.vss

Drawing page

Template:
Process Flow - All Stencils.vst

Shape:
In-line valve

When you choose template from a Visio Technical solution folder, you actually open a
template file that includes shapes on stencils, a drawing page, styles, and other tools.

TIP  To quickly search for shapes, stencils, templates, and wizards in Visio
Technical, or in other Visio products you have on your computer, use Visio
Shape Explorer. Choose Tools > Macro > Shape Explorer, then type a word or
phrase that describes the item you want to find. Shape Explorer categorizes the
search results by shape, stencil, template, wizard, and product.

Related topics
About wizards and other automated tools ................................................................ 43

Basing new drawings on templates ........................................... Using Visio Products  9
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Templates and stencils in Visio Technical 5.0

The following table, which is organized by drawing type, lists the Visio
Technical solutions and the templates and stencils each solution contains.

AEC Solutions

  Templates   Stencils

HVAC Layout Annotations, Connectors, Pipes 1, Pipes 2, Valves 1, Valves 2, HVAC Double Line,
HVAC Single Line

Plumbing Annotations, Connectors, Pipes 1, Pipes 2, Valves 1, Valves 2, Plumbing

Home - Bath And Kitchen Plan Electrical And Telecom; Dimensioning, Architectural; Annotations; Walls, Shell
And Structure; Appliance; Bath And Kitchen; Cabinets

Home - Large Plan Electrical And Telecom; Dimensioning, Architectural; Annotations; Walls, Shell
And Structure; Appliance; Bath And Kitchen; Cabinets; Furniture; Building Core

Home - Small Plan Electrical And Telecom; Dimensioning, Architectural; Annotations; Walls, Shell
And Structure; Appliance; Bath And Kitchen; Cabinets; Furniture; Building Core

HVAC Control Schematics HVAC Controls, HVAC Equipment

Security Systems Alarm And Access Control; Video Surveillance; Initiation And Annunciation;
Walls, Shell And Structure; Building Core; Annotations

Landscape - Large Plan Plants; Watering; Site; Recreation; Annotations; Dimensioning, Architectural

Landscape - Small Plan Plants; Watering; Site; Recreation; Annotations; Dimensioning, Architectural

Annotation Solutions

  Templates   Stencils

None Annotations; Connectors; Dimensioning, Architectural; Dimensioning,
Engineering; Drawing Tool Shapes; Title Blocks

Block Diagram Solutions

  Templates   Stencils

Basic Diagram Basic Shapes

Block Diagram With Perspective Blocks With Perspective

Block Diagram Blocks (Raised), Blocks



4 0 C H A P T E R  6

Business Diagram Solutions

  Templates   Stencils

Charts And Graphs Charting Shapes

Form Design Forms Shapes

Marketing Charts and Diagrams Marketing Diagrams, Marketing Clipart, Charting Shapes

Office Layout Office Layout Shapes

Organization Chart Organization Chart Shapes

Project Timeline Project Timeline Shapes

Electrical and Electronic Solutions

  Templates   Stencils

None Qualifying Symbols

EE - Circuits And Logic Analog And Digital Logic, Terminals And Connectors, Transmission Paths,
Integrated Circuit Components

EE - General Fundamental Items, Transmission Paths, Semiconductors And Electron Tubes,
Switches And Relays

EE - Industrial Control Systems Fundamental Items, Transmission Paths, Switches And Relays, Terminals And
Connectors, Transformers And Windings, Rotating Equipment And Mech
Functions, Annotations, Connectors

EE - Systems Composite Assemblies; Maintenance Symbols; Maps And Charts; Switches And
Relays; Telecom Switching And Peripheral Equipment; Terminals And Connec-
tors; Transformers And Windings; Transmission Paths; VHF, UHF, SHF

Facilities Management Solutions

  Templates   Stencils

Interior Elevations Annotations; Dimensioning, Architectural; Interior Elevations

Site Plan Vehicles; Watering; Annotations; Dimensioning, Engineering; Accessories; Parking
And Roads; Landscape Plants

Space Plan - Building Area Electrical And Telecom; Walls, Shell And Structure; Annotations; Dimensioning,
Architectural; Office Desks; Services; Office Furniture; Building Core

Space Plan - Room Plan Electrical And Telecom; Walls, Shell And Structure; Annotations; Dimensioning,
Architectural; Office Desks; Services; Office Furniture; Modular Office Furniture;
Modular Wall Panels; Accessories
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Flowchart Solutions

  Templates   Stencils

Audit Diagram Audit, Connectors And Callouts

Data Flow Diagram Data Flow

Flowchart - Advanced Audit, Connectors And Callouts, Data Flow, Miscellaneous, SDL,
Total Quality Management, Work Flow

Flowchart - Basic Flowchart, Flowchart (Additional)

Mind Mapping Diagram Mind Mapping Shapes

IDEF0 Diagram IDEF0 Diagram Shapes

SDL Diagram SDL, Connectors And Callouts

TQM Diagram Total Quality Management

Work Flow Diagram Work Flow, Connectors And Callouts

Industrial Process Solutions

  Templates   Stencils

Pipes and Valves - All Stencils Pipes 1, Pipes 2, Valves 1, Valves 2, Connectors, Annotations

Process Flow - All Stencils Valves 1, Pipes 1, Instrumentation, Pumps And Compressors, Heat Equipment,
Vessels, Equipment, Connectors

Process Plant Facilities Machines And Equipment; Storage And Distribution; Warehouse - Shipping And
Receiving; Walls, Shell And Structure; Vehicles

Maps Solutions

  Templates   Stencils

None Flags

Directional Map Directional Map Shapes

Geographic Maps Maps Of Africa, Maps Of Asia, Maps Of The Middle East, Maps Of
N. and S. America, Maps Of The World, Maps Of Europe, Maps Of
U.S. And Canada



4 2 C H A P T E R  6

Mechanical Engineering Solutions

  Templates   Stencils

None Fasteners 1, Fasteners 2, Geometric Dimensioning And Tolerancing, Welding

Mechanical Parts Library Nuts - Bolts - Screws, Fasteners, Steel And Aluminum Shapes,
Bearings And Washers, Seals

Fluid Power - All Stencils Equipment, Valves, Valve Assembly, Annotations, Connectors

Mech Eng - General Working Drawing Annotations; Title Block; Drawing Tool Shapes; Dimensioning, Engineering

Network Diagram Solutions

  Templates   Stencils

Basic Network Basic Network, Basic Network (Additional)

Visio Extras Solutions

  Templates   Stencils

None Custom Patterns (Scaled), Custom Patterns (Unscaled), Custom Line Patterns,
Borders, Callouts, Clipart, Connectors, Symbols
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Wizards and other
automated tools

About wizards and other automated tools

Wizards and other automated tools in Visio Technical automate routine tasks,
perform unique functions, and create special drawing types from scratch. The
following list describes what each tool helps you accomplish.

TIP  Many wizards and automated tools include a Help or More Info button.
Click one of these buttons when you need background information or help un-
derstanding the options on a screen.

Wizards and automated tools in Visio Technical

Name What it does How to run it

Area Analysis Allows you to calculate the area of a Tools > Macro > Facilities
room or space created using the Double Management > Area Analysis
Line Wall shape.

Array Shapes Creates and arranges multiple copies of Tools > Array Shapes
a shape at regular intervals. You can
specify the number of rows and columns
in the array and the amount of space
between each shape.

Build Region Assembles selected geographic shapes Tools > Macro > Maps > Build Region
into a region. You can designate an
anchor shape to control the position
and size of other shapes in the region.

Chart Shape Wizard Creates stackable and extendable Tools > Macro > Business Diagram >
shapes you can use to add special Chart Shape Wizard
effects to charts.

Table continued on next page.
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Wizards and automated tools in Visio Technical (continued)

Name What it does How to run it

Convert AutoCAD Drawings Converts multiple AutoCAD drawings Tools > Macro > Visio Extras >
into Visio Technical drawings. Convert AutoCAD Drawings

Convert AutoCAD Library Converts symbol libraries in AutoCAD Tools > Macro > Visio Extras >
to Visio Technical masters on a stencil. Convert AutoCAD Library

Custom Properties Editor Edits, adds, or deletes custom-property Tools > Macro > Custom Properties
data from masters on a standalone Editor
stencil or that you’ve used in a
particular drawing.

Database Wizard Links Visio shapes and drawings to Tools > Macro > Database > Database
databases created in ODBC-compliant Wizard
database programs.

Flowchart-TQM Diagram Wizard Guides you through the process of laying Tools > Macro > Flowchart >
out and formatting a Cause/Effect, Flowchart - TQM Diagram Wizard
Force Field, Top Down, or Cross
Functional (Rummler-Brache) diagram.

Measure Calculates the total perimeter and area Tools > Macro > Visio Extras >
of any closed shape, such as a shape that Measure
outlines the floor area of a floor plan.

Mechanical Parts Library Allows you to create over 15,000 bolts, File > New > Mechanical
fasteners, and structural sections from a Engineering > Mechanical Parts Library
library of shapes that are linked to a
comprehensive parts database.

Move Moves shapes on the drawing page a Tools > Macro > AEC  > Move
precise distance using x-, y-, or polar
coordinates.

Netlist Generator Performs a circuit analysis of electrical Tools > Macro > Electrical and
circuit diagrams in a Visio Technical Electronic > Netlist Generator
drawing and generates a netlist for
analysis in Spice format.

Office Layout Wizard Guides you through the process of Tools > Macro > Business Diagram >
setting the drawing scale, choosing the Office Layout Wizard
page size and orientation, and creating
the basic wall structure for an office
layout diagram.

Organization Chart Wizard Generates an organization chart from a Tools > Macro > Business Diagram >
variety of file formats. Organization Chart Wizard
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Name What it does How to run it

Page Layout Wizard Automates the setup for the page size, Tools > Macro > Visio Extras > Page
orientation, and scale for a drawing. Layout Wizard
Assists you in adding a title block and
border to the pages in a new or existing
drawing.

Print ShapeSheet Prints all values and formulas in a Tools > Macro > Visio Extras > Print
ShapeSheet spreadsheet. ShapeSheet

Project Timeline Wizard Generates a project timeline from a data Tools > Macro > Business Diagram >
file in Microsoft Excel (.xls), comma- Project Timeline Wizard
or tab-delimited text, or Microsoft
Project Exchange (.mpx) format. Or
generates a project timeline structure
into which you can enter data.

Property Line Draws a shape based on the legal Tools > Macro > AEC > Property Line
description you provide for a piece of
real estate.

Property Reporting Wizard Generates inventory reports, such as Tools > Property Report
bills of materials or equipment and
furniture inventories, and numeric
reports, such as cost totals or averages,
from shapes which have data in their
custom-property fields.

Shape Explorer Locates specific shapes and stencils in Tools > Macro > Shape Explorer
Visio products.

SmartShape Wizard Customizes the appearance or behavior Tools > Macro > Visio Extras >
of a selected shape’s text, connectors, SmartShape Wizard
notes, or protection.

Stencil Report Wizard Generates a Visio Technical drawing of Tools > Macro > Visio Extras > Stencil
the masters on a selected stencil. You Report Wizard
can choose how many masters appear
on a page, whether the page includes a
header or footer, and whether or not to
list each master’s name and status bar
prompt.

Table continued on next page.
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Wizards and automated tools in Visio Technical (continued)

Name What it does How to run it

Valve Builder Facilitates more efficient creation of Tools > Macro > Mechanical
valve shapes. You can select basic valves Engineering > Valve Builder; or
and assembly-required controls from a File > Stencils > Mechanical
dialog box. Engineering > Fluid Power - Valves,

then drag the Valve Builder shape to
the drawing page.

Wall Utility Displays a toolbar that works with Tools > Macro > AEC  > Wall Utility
shapes on the Walls, Shell And Structure
stencil to form T-joints or corner joints
between walls, extend walls to meet
others, and match doors and windows to
wall thicknesses and angles.

Related topics
About Visio Technical solutions, templates, and stencils ......................................... 37
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About working with AutoCAD files

If you create drawings using AutoCAD and other CAD programs, you can work
with those drawings in Visio Technical either by displaying them in Visio
Technical or converting them to Visio Technical format. You can also convert
your Visio Technical drawings to AutoCAD format.

Visio Technical can both read from and write to the .dwg and .dxf file formats,
but converting drawings works best in one direction: either from AutoCAD to
Visio Technical, or from Visio Technical to AutoCAD. Because each file format
supports capabilities unique to its program, converting a file only once from
one format to the other best maintains data integrity.

This section discusses the different ways to open AutoCAD files created in Re-
lease 10 through Release 13 in Visio Technical, how to customize the template
that controls file conversion, and how to work with a Visio Technical drawing in
AutoCAD.

Related topics
About including other programs’ data in Visio drawings ..... Using Visio Products  95
Controlling AutoCAD file conversion results ........................................................... 56
Converting a Visio Technical file to AutoCAD format ............................................. 57
Converting AutoCAD and other file formats to Visio Technical ............................. 52
Displaying AutoCAD files in Visio Technical ............................................................ 50
Importing non-Visio files as graphic images ....................... Using Visio Products  103
Working with AutoCAD files in Visio Technical ...................................................... 48



4 8 C H A P T E R  8

Working with AutoCAD files in Visio Technical

You can view an AutoCAD drawing file in Visio Technical  or convert it to Visio
Technical file format. When you display a file, the displayed (non-editable) lay-
ers that you select for the AutoCAD file appear on the Visio Technical page
background.

When you convert a drawing to editable layers, Visio Technical converts blocks
into masters, block inserts into instances, and entities into drawn shapes. You
can then edit and format these shapes using all the standard Visio Technical
tools and techniques.

About comparing AutoCAD terminology and
Visio Technical terminology
The following table describes several AutoCAD terms and how they correspond
to Visio Technical elements.

AutoCAD and Visio Technical terminology

AutoCAD term Visio Technical term Details

Block Master A block is a collection of entities that forms a single object and can be
used multiple times. You insert a block reference in an AutoCAD drawing.
A master is a predefined shape contained in a stencil from which you can
create an instance in a drawing.

Entity Drawn shape An entity is a single graphic object you create using text, lines, polylines,
dimensions, and so on. A drawn shape is created with Visio Technical
drawing tools.

Attribute Custom-property field A block definition can contain attributes, or data fields. When you convert
an AutoCAD drawing, its attributes are converted to custom-property
fields. When you export, custom-property fields are converted to
AutoCAD attributes.

About the conversion process for AutoCAD files
To convert the fonts, line styles, page size, and scale of the original .dwg or .dxf
file, Visio Technical uses the settings defined in its AutoCAD Converter Tem-
plate (_dwgcnvt.vst), located in the Visio Tech\Solutions\Visio Extras folder.
If you are converting many files of the same size and scale, you can edit this
template to change default settings used during the conversion process.

NOTE  AutoCAD 3-D entities, viewports, and paperspace cannot be converted
to Visio Technical format. However, 3-D views and named views can be incor-
porated into a Visio drawing as display-only.
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Visio Technical and AutoCAD use different methods to determine the size of a
drawing. As a result, you may need to adjust the drawing scale or size during the
conversion process to ensure that the converted drawing fits within the Visio
Technical printable area (the drawing page). When converting an AutoCAD file,
Visio Technical reads the size of the AutoCAD drawing extents to determine if
the drawing can fit on the drawing page.

If you convert an AutoCAD file with drawing extents that exceed the Visio
Technical drawing page size, the portions of the drawing that fall outside the
page won’t print. When you attempt to convert such a drawing, the Page Size/
Scale dialog box that appears includes a warning that the AutoCAD drawing ex-
ceeds the Visio Technical page extents. You can:

• Do nothing and proceed with the conversion; parts of the drawing will fall
outside of the printable drawing page.

• Set a different drawing scale.

• Choose a larger paper size.

Other differences between AutoCAD and
Visio Technical
CAD programs feature the idea of “model space” or world coordinate system, in
which you create a model. In Visio Technical, you can think of the drawing page
as a single, two-dimensional viewport into model space. In a sense, the Visio
Technical drawing page is a model of a piece of paper in the two-dimensional
world with a coordinate system measured in drawing units. For example, if
you’re drawing a town map, the Visio Technical drawing page can be 20 km
wide in drawing units.

In AutoCAD you draw in the real-world units of the world coordinate system.
In Visio Technical, you draw in drawing units that you specify. A Visio drawing
scale is the ratio of real-world units to drawing units. For example, a path in a
town map appears onscreen on the drawing page to be 10 m long in drawing
units. To print the map, the path must fit on a piece of paper that may be only
21 cm wide in real-world units. So, in Visio Technical, you can specify a drawing
scale where 1 cm in the real-world equals 10 m in drawing units, or a drawing
scale of 1:1000.

Related topics
About working with AutoCAD files .......................................................................... 47
Controlling AutoCAD file conversion results ........................................................... 56
Converting AutoCAD and other file formats to Visio Technical ............................. 52
Displaying AutoCAD files in Visio Technical ............................................................ 50
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Displaying AutoCAD files in Visio Technical

You can save time by displaying and working with AutoCAD drawings in Visio
Technical without converting them to Visio Technical format.

After the file is opened as display-only, you can work with the drawing in Visio
Technical. For example, you can redline, annotate, or drag shapes onto the page
without inadvertently modifying the original content.

If you want to display an AutoCAD drawing without converting it,
move all layers to the Displayed Layers box.

To display an AutoCAD file in Visio Technical without converting it:

1. Choose File > Open.

2. Under Files Of Type, choose AutoCAD (*.dwg, *.dxf). Select a file, then click
Open.

3. In the AutoCAD Drawing Layer Status dialog box, select the layers you want
to view as displayed, then click OK.

4. In the Page Size/Scale dialog box, select the page and scale settings you want.

5. Click OK to display the drawing.

When you are finished making changes to the drawing, you can save it as
a Visio Technical or an AutoCAD drawing by choosing File > Save As, then
selecting the appropriate file type under Save As Type.



W O R K I N G  W I T H  A U T O C A D  F I L E S 5 1

Setting the properties for an AutoCAD drawing
When you’re viewing the AutoCAD drawing (.dwg or .dxf) in Visio Technical,
you can view the drawing’s properties and change them if necessary. For ex-
ample, you can change the page scale or which layers are visible.

In the Drawing Explorer window, you can change the view and layers
you want to display in Visio Technical.

To set the properties for an AutoCAD drawing:

1. Place the pointer over the AutoCAD drawing, then right-click the drawing.

2. Choose Visio DWG Display Object > Properties, then click the View tab.

3. In the Drawing Explorer window, select the layers and view you want to dis-
play in Visio Technical.

You can select only one view.

4. Under Page Scale, click the scale you want to use.

When Use Visio Rulers is selected, the AutoCAD drawing is sized and posi-
tioned to be consistent with Visio Technical scaled drawing rulers. If you do
not select Use Visio Rulers or a predefined scale such as an architectural
scale, you can specify the size of the drawing page in other units by choosing
Custom under the Page Scale option.

5. Click OK to accept the new settings.

Related topics
About working with AutoCAD files .......................................................................... 47
Controlling AutoCAD file conversion results ........................................................... 56
Converting AutoCAD and other file formats to Visio Technical ............................. 52
Converting a Visio Technical file to AutoCAD format ............................................. 57
Working with AutoCAD files in Visio Technical ...................................................... 48
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Converting AutoCAD and other file formats to Visio Technical

Visio Technical supports import and export of files in the latest versions of
most graphic file formats, including the following:

• CorelDRAW version 7 .cdr format (import)

• AutoCAD .dwf format (import, export)

• AutoCAD Release 10 through 13 .dxf format (import, export)

• AutoCAD Release 10 through 13 .dwg format (import, export)

• Scaled .dwg and .dxf format backgrounds (import for display only)

NOTE  It takes more time to convert an AutoCAD file to editable layers, so un-
less you need to revise the drawing in Visio Technical, convert your drawing as
display-only layers. Visio Technical may not be able to convert all elements in a
drawing file from .dwg or .dxf format. However, you can still view these items
by importing them as displayed layers.

You can work with an AutoCAD (.dwg or .dxf) file in Visio Technical as follows:

• View objects on specific layers of a single AutoCAD file created in Release 10
through Release 13 for display only or to fully editable shapes and layers in a
new Visio Technical drawing (.vsd).

• Convert one or more AutoCAD files into fully editable Visio Technical draw-
ings. Each AutoCAD file, and all its layers, is converted to a new Visio
Technical drawing file.

• Convert AutoCAD symbol libraries to Visio Technical masters. 

Converting a single AutoCAD drawing file
When you convert a single AutoCAD drawing created in Release 10 through
Release 13, convert only the layers you need to change to editable layers, and
convert the rest as display-only.

If you want to convert all the layers of an AutoCAD drawing, move
all layers to the Editable Layers box.
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To convert an AutoCAD (.dwg or .dxf) file:

1. Choose File > Open.

2. Under List Files Of Type, choose AutoCAD (*.dwg, *.dxf). Select the file you
want, then click Open.

Or to insert the AutoCAD drawing into the current Visio Technical drawing
(merging the two drawings and masters), choose Insert > AutoCAD Draw-
ing. Select the file you want, then click Open.

3. In the AutoCAD Drawing Layer Status dialog box, select the layers you want
to convert.

4. To change conversion options, click Options. When you’re finished, click
OK. In the AutoCAD Drawing Layer Status dialog box, click OK to continue.

5. In the Page Size/Scale dialog box, verify page settings in the Drawing Dimen-
sions box.

6. Click OK to convert the AutoCAD drawing.

The drawing is converted to a Visio Technical file with one drawing page. If any
layers are editable, the drawing includes one stencil containing masters created
from the blocks or symbols (or no masters if the original drawing had no
blocks). The masters are stored in the new file’s local stencil, and the shapes on
the page are instances of the masters.

NOTE  Visio Technical converts AutoCAD blocks to shapes with a stacking or-
der. This means that shapes can appear on top of other shapes. If the top shape
is transparent, or does not contain a fill, the bottom shape shows through. To
adjust which shape appears on top of another in Visio Technical, change the
shapes’ stacking order using the commands on the Shape menu (Bring To
Front, Send To Back, Bring Forward, Send Backward).

If a converted AutoCAD object appears transparent in Visio Technical and you
want it to look solid, you can edit the ShapeSheet spreadsheet so that the shape
can be filled. Select the converted shape, choose Window > Show ShapeSheet,
then set the Geometry.A1 cell to FALSE. Now the shape is a closed path and you
can apply a fill. For details about entering shape formulas, search online help
for “shapesheet.”
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Converting multiple AutoCAD drawing files
When you convert multiple AutoCAD (.dwg or .dxf) files at once, Visio Techni-
cal reads all the layers in each drawing to create a .vsd file for each AutoCAD
file. The converted files are stored in the folder you specify.

Type the full path of the location in which you want Visio Technical to save the
converted files.

To convert several AutoCAD files at once:

1. Choose Tools > Macro > Visio Extras > Convert AutoCAD Drawings.

2. In the Convert AutoCAD Drawings dialog box, press Ctrl+click to select the
files you want to convert, then click Open.

3. In the AutoCAD Converter Options dialog box, under Destination Folder,
type the path where you want Visio Technical to save the converted files,
then click OK.

4. In the Page Size/Scale dialog box, verify page settings in the Drawing Dimen-
sions box.

5. Click OK to convert the AutoCAD drawings.

Visio Technical converts the files to .vsd format and stores them in the speci-
fied destination folder. A message appears informing you where Visio
Technical wrote a log file of information, such as any errors that occurred
during the conversion process.
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Converting symbol libraries
If you frequently use particular symbol libraries in AutoCAD drawings, you can
convert the symbols to Visio Technical masters on a stencil. A symbol library is
composed of multiple symbol files (usually .dwg files). Visio Technical converts
each symbol file into a single master. When you convert multiple symbol files at
once, Visio Technical places all the masters on the same stencil.

You can open and use the stencil in other Visio Technical drawings, or as a new
converter template for AutoCAD drawings. This converter template would con-
tain masters of symbols you use. If you specify this template when you next
convert a drawing, Visio Technical creates instances of these masters instead of
converting each block insert—which saves considerable time during the con-
version process.

To convert AutoCAD symbols to Visio Technical masters:

1. Choose Tools > Macro > Visio Extras > Convert AutoCAD Library.

2. In the Convert AutoCAD Library dialog box, press Ctrl+click to select the
symbol files you want to convert, then click Open.

Visio Technical converts each symbol file you select to a single master and
places it on the drawing’s local stencil. Each master is named for its corre-
sponding symbol file.

3. To display the local stencil, choose Window > Show Master Shapes.

4. To save the converted symbols as a new stencil or template, click the title bar
of the stencil to make it the active window, then choose File > Save As.

5. In the Save As dialog box, under File Type, choose Stencil (.vss) or Template
(.vst).

Visio Technical creates a new stencil or template file with the name you
specify, and saves it in the folder you specify.

Related topics
About including other programs’ data in Visio drawings ..... Using Visio Products  95
About working with AutoCAD files .......................................................................... 47
Controlling AutoCAD file conversion results ........................................................... 56
Converting a Visio Technical file to AutoCAD format ............................................. 57
Displaying AutoCAD files in Visio Technical ............................................................ 50
Importing non-Visio files as graphic images ....................... Using Visio Products  103
Working with AutoCAD files in Visio Technical ...................................................... 48
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Controlling AutoCAD file conversion results

You can control the results of the AutoCAD file conversion process by editing
the Visio AutoCAD Converter Template (_dwgcnvt.vst). When Visio Technical
converts AutoCAD data, it reads the drawing line and text style information for
each AutoCAD object and matches it to a style with the same name in the
AutoCAD Converter Template. You don’t have to open the converter template
to convert a drawing in the way you open a template to start a drawing. Visio
Technical automatically uses the template. You open the template when you
want to edit style information.

When you edit the converter template, you can save your changes as a new, cus-
tom template that you can tell Visio Technical to use during file conversion. You
can edit the converter template in the following ways:

• Modify style definitions to specify the line styles and fonts to use for each
AutoCAD element.

• Define custom fill patterns that can be used later to enhance the converted
drawing.

• Specify the page size and drawing scale to use.

• Create new styles to match the font and line attributes of custom AutoCAD
drawing attributes.

• Add custom masters to the template’s stencil. Visio Technical can then use
the masters, which is faster than converting AutoCAD symbol libraries or
blocks.

To modify the AutoCAD Converter Template or create a custom
converter template:

1. Choose File > Open, then select AutoCAD Converter Template
(_dwgcnvt.vst) from the Visio Tech\Solutions\Visio Extras folder.

2. In the Open dialog box, check Original, then click Open.

3. Choose Format > Define Styles. From the Style list, select a style to modify,
choose the options you want, then click OK.

4. To create a new style, choose Format > Define Styles. In the Style box, type
the new style’s name, choose the options you want, then click OK.

NOTE  Visio Technical fill styles don’t affect how AutoCAD objects are
converted.
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5. Choose File > Page Setup. On the Page Size tab, choose a paper size, orienta-
tion, and drawing scale, then click OK.

6. To add a master to the template’s stencil, drag the shape you want into the
stencil window.

7. Save and close the template. Or choose File > Save As and specify a name for
a custom converter template.

To specify the new converter template when you are converting AutoCAD
files, enter the template name in the AutoCAD Converter Options dialog
box, which appears after you choose the file or files you want to convert.

Related topics
About working with AutoCAD files .......................................................................... 47
Converting AutoCAD and other file formats to Visio Technical ............................. 52
Displaying AutoCAD files in Visio Technical ............................................................ 50
Working with AutoCAD files in Visio Technical ...................................................... 48

Converting a Visio Technical file to AutoCAD format

You can convert, or export, a Visio Technical drawing to a .dwg or .dxf format
file by using the Save As command. For best results when saving a Visio
Technical drawing to AutoCAD format, assign all Visio Technical shapes to a
layer, and no shape to more than one layer.

Depending on the type of drawing you are saving, the conversion procedure has
the following results:

• If a Visio Technical page contains Visio shapes only, Visio Technical converts
it to a .dwg or .dxf file.

• If a Visio page contains a single embedded .dwg or .dxf file (Release 10
through Release 12) and you’ve placed Visio shapes on top of it, Visio
Technical saves the file as an AutoCAD file and appends Visio Technical data
to the file as AutoCAD layers. Where a Visio page contains a .dwg or .dxf file
originally created in Release 13, Visio Technical saves the appended file
in Release 12 format. The units from the embedded AutoCAD file are
maintained.

NOTE  If you convert an AutoCAD drawing as a fully editable Visio Technical
drawing, and then save the file back to AutoCAD format, you may lose Visio
Technical formatting that AutoCAD does not support. Converting a drawing
works best in one direction: either from AutoCAD to Visio Technical, or from
Visio Technical to AutoCAD.
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To save a Visio Technical drawing as an AutoCAD drawing:

1. Choose File > Save As.

2. Under Save As Type, select either AutoCAD Drawing (*.dwg) or AutoCAD
Interchange (*.dxf), then click Save.

3. In the Visio Drawing Layer Status dialog box, select the layers you want to
export.

4. To set options, click Options, select the options you want, and then click OK.

5. Click OK to save the drawing.

Related topics
About working with AutoCAD files .......................................................................... 47
Working with AutoCAD files in Visio Technical ...................................................... 48

Saving files with embedded AutoCAD drawings to
previous versions of Visio Technical

With Visio Technical 5.0 you can save drawings as Visio Technical 5.0, 4.5, or 4.0
files. The ability to save files as previous versions of Visio Technical facilitates
the process of sharing drawings with others. However, embedded AutoCAD
drawings cannot be viewed in versions prior to 5.0.

To save Visio Technical files with embedded AutoCAD drawings:

1. Choose File > Save As.

2. In the File Name box, type a file name for the drawing file.

3. For Save File As Type, choose the version of Visio Technical you want.

4. Under Save In, open the folder in which you want to save the file.

5. Click Save.
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Creating
custom solutions

About creating custom solutions

By taking advantage of the Visio SmartShapes® technology and open architec-
ture, you can create specialized shapes, develop combinations of shapes and
programs that model the real world and solve specific drawing problems, and
customize the user interface.

The following tools are available to you in the Visio Technical development
environment:

• The ShapeSheet spreadsheet, which takes you under the surface of shapes to
create formulas for specific shape behavior.

• Microsoft Visual Basic for Applications (VBA), with which you can create
macros and control Visio Technical through Automation.

• The Visio Type Library, which contains Automation descriptions of the
objects, properties, methods, events, and constants that Visio Technical
exposes to Automation controllers.

The book Developing Visio Solutions, which comes with Visio Technical, con-
tains everything you need to know about Visio Technical as a development
platform, including sample code, tips, and techniques. In addition, you can
view the online Automation Reference by choosing Help > Automation
Reference in Visio Technical.

You can also visit the Visio Solutions Development section of the Visio
Corporation Web site (http://www.visio.com/devweb/), where you can learn
more about Visio Technical as a development platform and find other
developer resources.
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Working with the ShapeSheet spreadsheet
When you want to use specialized shapes that model the behavior and appear-
ance of the real-world objects they represent, you can create them by working
with formulas in the shapes’ ShapeSheet spreadsheets.

Behind each Visio shape or shape you draw using the Visio drawing tools is a
ShapeSheet spreadsheet containing formulas that determine how a shape be-
haves. When you make changes to a shape on the drawing page, you update its
ShapeSheet formulas. You can also make changes directly in the ShapeSheet
spreadsheet, where you have more precise control over a shape’s appearance
and behavior. For example, you can add formulas that create a control handle,
change a shape’s fill color if it reaches a certain size, or make one shape’s behav-
ior dependent upon the behavior of another shape on the drawing page.

The ShapeSheet spreadsheet contains sections, each of which controls part of the shape.

To display a shape’s ShapeSheet spreadsheet:

• Select the shape, then choose Window > Show ShapeSheet.

Once you’ve created specialized shapes, you can make the shapes part of a draw-
ing solution by storing them on new stencils and distributing the shapes and
stencils in a template.

For more information about ShapeSheet spreadsheets, press F1 in Visio
Technical, click Index, then type “shapesheets.”
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Working with Automation
You can take advantage of the Visio open architecture to solve graphics prob-
lems and create custom solutions. Open architecture means that Visio Technical
exposes its objects, such as windows, drawing pages, shapes, layers, menus, and
toolbars, through a well-structured Automation interface. Using a development
environment that supports Automation, you can write programs to control
Visio objects. For example, you can automatically update drawings you create
from data that changes from day to day. Or, you can automate routine shape
development tasks that you perform over and over.

To write the programs, or macros, that control Visio objects, you can use the
fully-licensed version of Microsoft Visual Basic for Applications (VBA) that
comes with Visio Technical, or you can use Visual Basic, C/C++, or any other
Automation controller.

Visio Technical includes a type library—a file that contains Automation de-
scriptions of the objects, properties, methods, events, and constants that Visio
Technical exposes to Automation controllers. Visio object types can help you
write code more effectively because you can view Visio Automation descrip-
tions in and copy code templates from the Object Browser.

To open the Visual Basic Editor and create, debug, or run
VBA programs:

• Choose Tools > Macro > Visual Basic Editor.

TIP  You can also press Alt+F11 to open the Visual Basic Editor.

For details about using the Visual Basic Editor, press F1 in Visio Technical, click
Index, then type “Visual Basic Editor.”

Related topics
About creating your own shapes .......................................... Using Visio Products  207
About customizing shape behavior .............................................................. Visio Help
About Visio Technical sample drawings ...................................................................... 7
Creating masters and stencils ........................................ Developing Visio Solutions  31
Creating new templates ......................................................... Using Visio Products  142
Programming Visio with Visual Basic for Applications ... Developing Visio Solutions  379
Working with the ShapeSheet window ........................ Developing Visio Solutions  24
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Where to go
from here

This book focuses on features and tools unique to Visio Technical. You can
learn more about working with Visio products from several other sources.

For example, if you’re new to Visio products, you might want to start with Using
Visio Products, which includes chapters on creating and saving drawings, work-
ing with shapes and text, and printing. Or, if you’re a developer and your focus
is Visio as a development platform, Developing Visio Solutions contains the in-
formation you need.

If you prefer to get help from online sources, you can access an electronic ver-
sion of the information in this manual and in Using Visio Products, or access
certain Visio reference tools that are available only in online form. The Visio
Corporation Web site at http://www.Visio.com/ also includes information and
downloadable files that can help you get the most out of Visio Technical.

For a complete list of information sources, see the table in the following topic.

Related topics
About Visio Technical solutions, templates, and stencils ......................................... 37
Additional sources of Visio Technical information .................................................. 64
Installation .................................................................................................................... 3
Introduction .................................................................................................................. 1
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Additional sources of Visio Technical information

The following table lists places you can find information about Visio Technical
and describes the type of information you’ll find in each place.

More information on Visio Technical

Source Type of information

Using Visio Products A good place to start if you’ve never used Visio products before.

Covers tasks common to Visio Standard, Visio Technical, and Visio Professional.

Developing Visio Solutions Contains information about the Visio program as a development platform,
including sample code, tips, and techniques.

Online Automation Reference Describes the Visio objects, properties, and methods that you can access from an
external program.

Choose Help > Automation Reference.

More Info buttons on Visio Technical Opens a window of information about the options on a wizard screen, or about
wizard screens Visio features relevant to the task the wizard helps you complete.

Click More Info on a wizard screen.

Screen tips Toolbar buttons  Float the pointer over a toolbar button for a moment to see a tip
about what the button does.

Control handles  Float the pointer over a control handle ( ) on a shape for a
moment to see a tip about what dragging the handle accomplishes.

Online help An online version of the information in Using Visio Technical and in Using Visio
Products, and an explanation of every Visio command and dialog box option. You
can search the file by keyword.

To look in online help, choose Help > Visio Help.

To learn about options in a dialog box, click the Help button in the dialog box.

Template help Provides information about how to create specific drawing types, including the
most efficient sequence in which to work, how shapes work together, and tips and
tricks.

Choose Help > Template Help, double-click Visio Templates, and then double-
click a drawing type.
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Source Type of information

Shape help A window of information that explains how to use a shape.

Right-click any shape, then choose Shape Help.

Technical support Choose Help > Visio On The Web > Online Support.

Visio Corporation Web site Includes information about Visio Corporation and its products, such as:

Case studies that describe how corporations have used Visio products.

White papers that describe in detail certain Visio features or functionality.

Downloadable files for updates and programs that can help you use Visio more
effectively.

Developer tips and tools.

Choose Help > Visio On The Web > Visio Home Page.

Drawing Resources Web page A Web page on the Visio Corporation Web site that contains links to resources
related to drawing types Visio Technical supports.

Choose Help > Visio On The Web > Drawing Resources.

Visio Solutions Library A section of the Visio Corporation Web site where you can learn about and
purchase job-specific shapes, time-saving utilities, and other custom drawing
solutions.

Choose Help > Visio On The Web > Visio Solutions Library.

Related topics
About Visio Technical solutions, templates, and stencils ......................................... 37
Installation .................................................................................................................... 3
Introduction .................................................................................................................. 1
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