Harmonogram zadań

Harmonogramu zadań możesz używać do planowania uruchamiania poleceń, programów lub skryptów w określonym czasie:

  • Przed użyciem Harmonogramu zadań obejrzyj stronę Lista kontrolna.
  • Pomoc dotyczącą określonych zadań znajdziesz na stronie Jak to zrobić?.
  • Ogólne najważniejsze informacje znajdziesz na stronie Wstęp.
  • Instrukcje rozwiązywania problemów znajdziesz na stronie Rozwiązywanie problemów.


Lista kontrolna Harmonogramu zadań

Lista kontrolna

Następująca tabela zawiera listę czynności wykonywanych najczęściej przy pomocy Harmonogramu zadań. Aby zapoznać się z pełną listą instrukcji działania Harmonogramu zadań, zobacz Jak to zrobić?.

Krok | Instrukcja
Zanim zaplanujesz zadanie do uruchomienia, musisz dodać to zadanie. | Planowanie nowych zadań
Po utworzeniu zaplanowanego zdania, możesz zmieniać uruchamiany program, harmonogram lub inne parametry określonego zadania. | Modyfikowanie zaplanowanych zadań
Zaplanowane zadania, które nie są już potrzebne, możesz całkowicie usunąć. | Usuwanie zaplanowanych zadań
W wypadku, gdy zaplanowane zadanie rozpoczyna się w chwili, gdy używasz komputera, możesz zatrzymać je i uruchomić ponownie później. | Zakończenie zaplanowanego zadania, które jest aktualnie uruchomione
Możesz czasowo zatrzymać lub wstrzymać uruchomienie wszystkich zaplanowanych zadań i wznowić je później. | Czasowe wyłączanie wszystkich zaplanowanych zadań


Jak to zrobić?

  • Planowanie zadań
  • Zarządzanie harmonogramem zadań


Planowanie zadań
  • Uruchamianie Harmonogramu zadań
  • Planowanie zadań
  • Modyfikowanie zaplanowanych zadań
  • Usuwanie zaplanowanych zadań
  • Zakończenie zaplanowanego zadania, które jest aktualnie uruchomione
  • Natychmiastowe uruchamianie zadań


Uruchamianie Harmonogramu zadań

Aby uruchomić Harmonogram zadań

  • Harmonogram zadań możesz uruchomić klikając dwukrotnie ikonę Mój komputer, a następnie klikając dwukrotnie pozycję Zaplanowane zadania.
  • Kliknij dwukrotnie pozycję Zaplanowane zadania, a następnie kliknij dwukrotnie pozycję Dodaj zaplanowane zadanie, aby otworzyć Kreatora dodawania zaplanowanych zadań, który przeprowadzi Cię przez proces planowania zadań.


Planowanie zadań

Aby zaplanować nowe zadanie
  1. Uruchom program Harmonogram zadań.
  2. Kliknij dwukrotnie pozycję Dodaj zaplanowane zadanie.
  3. Wykonuj instrukcje Kreatora dodawania zaplanowanych zadań.

Notki

  • Jeśli chcesz określić zaawansowane ustawienia zadania, zaznacz pole wyboru Otwórz zaawansowane właściwości tego zadania, gdy klikam przycisk Zakończ na ostatnim ekranie kreatora.
  • Aby nowe zadanie było powtarzane cyklicznie po każdym uruchomieniu, na ostatnim ekranie kreatora zaznacz pole wyboru Otwórz zaawansowane właściwości tego zadania, gdy klikam przycisk Zakończ, a następnie kliknij kartę Harmonogram i kliknij przycisk Zaawansowane.
  • Jeśli program zadania wymaga parametrów, na ostatnim ekranie kreatora zaznacz pole wyboru Otwórz zaawansowane właściwości tego zadania, gdy klikam przycisk Zakończ, a następnie kliknij kartę Zadanie i wpisz parametry w polu Uruchom, po ścieżce zadania.
  • Upewnij się, że data i godzina systemowa komputera są poprawne. Harmonogram zadań korzysta z tych informacji w celu uruchamiania zaplanowanych zadań. Aby sprawdzić lub zmienić datę i godzinę, kliknij dwukrotnie godzinę na pasku zadań.


Modyfikowanie zaplanowanych zadań

Aby zmodyfikować zaplanowane zadanie
  1. Uruchom program Harmonogramu zadań.
  2. Kliknij prawym przyciskiem myszy zadanie, które chcesz zmodyfikować, a następnie kliknij polecenie Właściwości.
  3. Wykonaj jedną z następujących czynności:
    • Aby zmienić program, który chcesz uruchamiać, w polu Uruchom wpisz ścieżkę dla zadania.
    • Aby zmienić harmonogram zadania, kliknij kartę Harmonogram.
    • Aby dostosować ustawienia zadania, kliknij kartę Ustawienia.

Notki

  • Jeśli zmienisz konto użytkownika lub uruchamiany program, musisz podać hasło tego konta użytkownika.
  • Jeśli program zadania wymaga określenia opcji w wierszu poleceń, wpisz je w polu Uruchom, po ścieżce zadania.
  • Jeśli ścieżka do programu zadania zawiera spacje, ujmij ją w cudzysłów ("").
  • Upewnij się, że data i godzina systemowa komputera są poprawne. Harmonogram zadań korzysta z tych informacji w celu uruchamiania zaplanowanych zadań. Aby sprawdzić lub zmienić datę i godzinę, kliknij dwukrotnie godzinę na pasku zadań.


Usuwanie zaplanowanych zadań

Aby usunąć zaplanowane zadanie
  1. Uruchom program Harmonogram zadań.
  2. Kliknij prawym przyciskiem myszy zadanie, które chcesz usunąć, a następnie kliknij polecenie Usuń.

Notki

  • Usunięcie zaplanowanego zadania powoduje usunięcie go z listy zaplanowanych zadań. Plik programu nie jest usuwany z dysku twardego.
  • Harmonogram wybranego zadania możesz również usunąć, naciskając klawisz DEL.


Zakończenie zaplanowanego zadania, które jest aktualnie uruchomione

Aby zakończyć zaplanowane zadanie, które jest aktualnie uruchomione
  1. Uruchom program Harmonogram zadań.
  2. Kliknij prawym przyciskiem myszy zadanie, które chcesz zatrzymać, a następnie kliknij polecenie Zakończ zadanie.

Notki

  • Jeśli zaplanowane zadanie powoduje uruchomienie innego programu, polecenie to zatrzyma tylko oryginalnie zaplanowane zadanie, a nie drugie zadanie.
  • Aby ponownie uruchomić zadanie, kliknij zadanie prawym przyciskiem myszy, a następnie kliknij polecenie Uruchom.


Natychmiastowe uruchamianie zadań

Aby natychmiast uruchomić zadanie
  1. Uruchom program Harmonogram zadań.
  2. Kliknij prawym przyciskiem myszy zadanie, które chcesz uruchomić, a następnie kliknij polecenie Uruchom.

Notki

  • Zadanie możesz zakończyć, klikając menu Plik, a następnie klikając polecenie Zakończ zadanie.
  • Jeśli zadanie powinno zostać uruchomione, a nie zostało, sprawdź możliwe przyczyny w dzienniku: W menu Zaawansowane kliknij polecenie Pokaż dziennik.


Zarządzanie harmonogramem zadań
  • Oglądanie dziennika zadań zaplanowanych w przeszłości
  • Oglądanie zaplanowanych zadań na komputerze zdalnym
  • Czasowe wyłączanie wszystkich zaplanowanych zadań
  • Wyłączanie Harmonogramu zadań
  • Ustawianie konta usługi AT


Oglądanie dziennika zadań zaplanowanych w przeszłości

Aby obejrzeć dziennik zadań zaplanowanych w przeszłości
  1. Uruchom program Harmonogram zadań.
  2. W menu Zaawansowane kliknij polecenie Pokaż dziennik.


Oglądanie zaplanowanych zadań na komputerze zdalnym

Aby obejrzeć zaplanowane zadania na komputerze zdalnym
  1. Na pulpicie kliknij dwukrotnie ikonę Otoczenie sieciowe.
  2. Kliknij dwukrotnie komputer, na którym chcesz przeglądać zaplanowane zadania.
  3. Kliknij dwukrotnie folder Zaplanowane zadania.

Notki

  • Zadania na komputerze zdalnym z uruchomionym systemem Windows NT możesz przeglądać tylko wówczas, jeśli jesteś administratorem tego komputera.
  • Zadania na komputerze zdalnym z uruchomionym systemem Windows 95 lub nowszym możesz edytować tylko wówczas, jeśli na komputerze tym zainstalowano oprogramowanie do zarządzania rejestrem zdalnym oraz jeśli komputer ten współużytkuje udział x$, gdzie x oznacza dysk twardy, na którym rezyduje folder Zaplanowane zadania. Jeśli korzystasz z komputera z uruchomionym systemem Windows, Twoje konto użytkownika musi ponadto być wymienione na specjalnej liście kont mających dostęp do rejestru zdalnego. Aby określić, którzy użytkownicy mogą mieć dostęp do rejestru zdalnego komputera z uruchomionym systemem Windows, kliknij dwukrotnie ikonę Hasła w Panelu sterowania.


Czasowe wyłączanie wszystkich zaplanowanych zadań

Aby czasowo wyłączyć wszystkie zaplanowane zadania
  1. Uruchom program Harmonogram zadań.

  2. W menu Zaawansowane kliknij polecenie Wstrzymaj pracę Harmonogramu zadań.

Notki

  • To polecenie jest użyteczne, gdy uruchamiasz inny program (na przykład grę) lub instalujesz oprogramowanie, i nie chcesz w tym samym czasie uruchamiać zaplanowanych zadań.
  • Zadania, które powinny zostać uruchomione podczas wstrzymania pracy Harmonogramu zadań, zostaną uruchomione dopiero po nadejściu kolejnego zaplanowanego dla nich terminu.
  • Aby wznowić harmonogramy dla wszystkich zadań, w menu Zaawansowane kliknij polecenie Wznów pracę Harmonogramu zadań.


Wyłączanie Harmonogramu zadań

Aby wyłączyć Harmonogram zadań
  1. Uruchom program Harmonogram zadań.
  2. W menu Zaawansowane kliknij polecenie Zatrzymaj pracę Harmonogramu zadań.

Notka

  • Po wyłączeniu Harmonogramu zadań zaplanowane zadania nie będą uruchamiane, a przy następnym uruchomieniu systemu Windows Harmonogram zadań nie zostanie uruchomiony automatycznie.


Ustawianie konta usługi AT

Aby ustawić konto usługi AT
  1. Uruchom program Harmonogram zadań.
  2. W menu Zaawansowane kliknij polecenie Konto usługi AT.
  3. Kliknij opcję To konto, a następnie wpisz konto użytkownika, które będzie używane do uruchamiania zadań zaplanowanych za pomocą polecenia at.
  4. W polach Hasło i Potwierdź hasło wpisz poprawne hasło dla konta.

Notki

  • Usługa AT jest dostępna tylko w systemie Windows NT.
  • Opcjonalnie możesz kliknąć opcję Konto systemowe. Zadania zaplanowane za pomocą polecenia at będą uruchamiane przy użyciu konta LocalSystem, które wymaga uprawnień administratora.

  • Aby móc uruchamiać zadania zaplanowane za pomocą polecenia at, określone konto musi mieć wystarczające uprawnienia. Na przykład, jeśli planujesz uruchamianie programów, które mogą być uruchamiane tylko przez administratorów, podane konto musi być kontem administratora.


Harmonogram zadań - wstęp

Wstęp

W tej części umieszczono ogólne podstawowe informacje na temat Harmonogramu zadań:

  • Wprowadzenie do Harmonogramu zadań
  • Używanie Harmonogramu zadań
  • Harmonogram zadań a polecenie At
  • Harmonogram zadań a zabezpieczenia
  • Rozwiązywanie problemów


Przegląd Harmonogramu zadań

Harmonogram zadań jest narzędziem pozwalającym planować różne zadania (np. programu Defragmentator dysków) tak, aby system uruchamiał je zgodnie z Twoimi wymaganiami. Harmonogram zadań jest uruchamiany przy każdym uruchomieniu systemu Windows i działa w tle.

Otwarcie Harmonogramu zadań umożliwia:

  • Zaplanowanie zadania tak, aby było uruchamiane codziennie, co tydzień, co miesiąc lub w określonym czasie (np. po uruchomieniu komputera).
  • Zmianę harmonogramu zadania.
  • Wyłączenie istniejącego zadania.
  • Dostosowanie sposobu uruchamiania zadania w zaplanowanym czasie.


Używanie Harmonogram zadań

System operacyjny Windows instaluje Harmonogram zadań automatycznie. Aby skorzystać z usług planowania, kliknij dwukrotnie folder Zaplanowane zadania w oknie Mój komputer.

Możesz dodać zadania klikając dwukrotnie ikonę Dodaj zaplanowane zadanie, co uruchamia Kreatora dodawania zaplanowanych zadań. Zadania możesz dodać także przeciągając skrypty, programy lub dokumenty z okna Eksploratora systemu Windows do okna Zaplanowane zadania.

Harmonogramu zadań możesz również używać do modyfikowania, usuwania, wstrzymywania lub zatrzymywania zaplanowanych zadań, do oglądania dziennika zadań planowanych w przeszłości, lub do oglądania zadań zaplanowanych na zdalnym komputerze.

Aby uzyskać więcej instrukcji na temat używania Harmonogramu zadań, zobacz Jak to zrobić?.

Wskazówki dotyczące używania Harmonogramu zadań

W systemie operacyjnym Windows możesz używać Harmonogramu zadań, aby zaplanować uruchomienie dowolnej aplikacji. Aby jak najlepiej skorzystać z możliwości Harmonogramu zadań, upewnij się, że data i czas systemowy Twojego komputera są poprawne, zanim dodasz zadanie.


Używanie Harmonogramu zadań i polecenia At

Oprócz Harmonogramu zadań, automatyczne sporządzanie harmonogramu zadań umożliwia także polecenie at.

Harmonogram zadań nie jest tym samym co polecenie at, niemniej jednak narzędzia te współdziałają ze sobą. Po zaplanowaniu zadania za pomocą polecenia at, zadanie to pojawia się na liście zadań w oknie Harmonogramu zadań.

Za pomocą Harmonogramu zadań możesz modyfikować właściwości zadania zaplanowanego przy użyciu polecenia at. Niemniej jednak, aby uzyskać dostęp do zadania, musisz nadal korzystać z Harmonogramu zadań. Dostęp do zadania za pomocą polecenia at nie będzie już możliwy.

Aby określić konto użytkownika, które będzie używane do uruchamiania zadań zaplanowanych za pomocą polecenia at, kliknij dwukrotnie ikonę Mój komputer, kliknij dwukrotnie folder Zaplanowane zadania, a następnie w menu Zaawansowane kliknij polecenie Konto usługi AT.

Notka

  • Usługa at jest dostępna tylko na komputerach z systemem Windows NT.


Zabezpieczenia harmonogramu zadań

Harmonogram zadań a zabezpieczenia

W Harmonogramie zadań możesz ustawić poziom zabezpieczeń przypisując nazwę użytkownika i hasło określonemu zadaniu. Po ustawieniu nazwy użytkownika i hasła, zadanie nie może zostać anulowane ani usunięte przez innnego użytkownika.

Notki

  • Funkcja zabezpieczeń jest dostępna tylko w systemie Windows NT.
  • Zanim będzie można kontynuować planowanie zadania, musisz wpisać nazwę użytkownika w kreatorze zaplanowanych zadań. Hasła nie są wymagane.
  • Możesz zmienić hasło lub ustawić nowe, zaznaczając pole wyboru Otwórz zaawansowane właściwości tego zadania, gdy klikam przycisk Zakończ na końcowym ekranie Kreatora.


Rozwiązywanie problemów z Harmonogramem zadań

Jeśli zaplanowane zadanie nie jest uruchamiane wtedy, kiedy tego oczekujesz, kliknij je prawym przyciskiem myszy na liście zadań, a następnie kliknij polecenie Właściwości. Na karcie Zadanie upewnij się, że zaznaczono pole wyboru Włączone. Na karcie Harmonogram sprawdź, czy harmonogram jest ustawiony poprawnie.

Jeśli program zadania nie jest uruchamiany poprawnie, być może w poleceniu musisz określić niezbędne argumenty. Aby dowiedzieć się więcej o programie i jego argumentach, spróbuj wykonać jedną z poniższych czynności:

  • Jeśli program wyposażono w pomoc online, zajrzyj do niej.

  • W wierszu poleceń spróbuj wpisać następujący tekst, gdzie program jest nazwą programu

    • program /?


Składnik systemu Windows NT nie został zainstalowany

Nie można uruchomić programu.

Możliwe przyczyny:

    • Program został usunięty przez administratora systemu.
    • Administrator systemu znienił uprawnienia skojarzone z tym plikiem.
    • Program nie został zainstalowany na komputerze.
    • Program został przypadkowo usunięty.
    • Plik jest uszkodzony.

Jeśli komputer znajduje się pod kontrolą administratora systemu, skontaktuj się z nim, aby dowiedzieć się, dlaczego nie możesz uruchomić programu.