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Introduction (Introduction)

The TommySoftware® CAD/DRAW Tutorial contains a whole host of illustrated and detailed examples 
which will show you how to fully exploit the capabilities of the program.

This tutorial is a supplement to the information provided by the TommySoftware® CAD/DRAW 
Reference (the on-line help system) and the TommySoftware® CAD/DRAW Tour (a self-running demo 
that shows all the program's basic features). See What You Should Do First for further details.

Working with the Tutorial
Different people learn in different ways. Mostly people start learning a new application by playing with it.
And this is certainly a good way that we support. TommySoftware® CAD/DRAW 4 complies with the 
Windows user interface guidelines and offers a lot of functions which were especially developed to make 
the first steps as easy as possible. But there will be a point where you recognize that it is quite difficult to 
go further just by playing and that is exactly the point where the tutorial comes into play.

This tutorial is intended to be used side by side with the application. You can use the ALT+TAB key 
combination to switch between application and tutorial. When you work through chapter "Practical 
Examples" you will switch frequently between the tutorial and the application. Because the best way to 
learn from these examples is to go through them by redrawing them yourself.

TommySoftware® CAD/DRAW 4 is a flexible program. There are several ways of carrying out 
commands and you can use various drawing methods to create a drawing. For this reason, you should 
start by trying all the different ways of accomplishing a task to see which one suits you best. 

To get the latest version of this tutorial and for other information visit our World Wide Web site 
(http://www.tommysoftware.com).
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What You Should Do First (Introduction)

We strongly recommend that you watch the TommySoftware® CAD/DRAW Tour (a self-running demo 
that shows all the program's basic features) before you start reading this tutorial.

And it is also good idea to browse through some of the chapters in the CAD/DRAW Reference (the on-
line help system), e.g. "Procedures", "In-Depth View", and "Screen Elements". Of course you do not need
to read them all at once before starting with the tutorial. But these chapters are important because they 
give you an overall comprehension of the application's functionality which you would probably not find 
by trial and error or simply by going through the practical examples. You'll be able to use only a fraction 
of the program's power without a thorough understanding of the basic concepts of TommySoftware® 
CAD/DRAW 4.

To start the CAD/DRAW Tour or the CAD/DRAW Reference double-click the corresponding icon in the 
CAD/DRAW group or select the relevant command from the "Help" menu.



Conventions in This Tutorial (Introduction)
The following conventions are used throughout the tutorial:

Very important: You should really read this!

Note

Tips & Tricks

Click The word click by itself means click the left mouse button once (sometimes also called left-click).
Otherwise we say right-click, or double-click.

SHIFT This means the Shift key.

KEY1+KEY2 This means press KEY1 and KEY2 at the same time. For example, ALT+TAB means 
hold down the ALT key while you press the TAB key.

x+100+2/3 User input, e.g. text in edit controls.

Italic Strengthening of single words or phrases.

RELEASE4.T4G File name.

"Options" When referring to elements in dialog boxes the element names are 
displayed in quotation marks (e.g. "Options" button).

Shape>Modify Objects This means the command "Modify Objects" in the "Shape" menu of 
TommySoftware® CAD/DRAW 4.

The Rectangle Underlined, colored text marks a jump to another topic. This topic can 
also lie in another help system, e.g. the CAD/DRAW 4 Reference. To 
return to the previous topic apply the "Back" button.



Data Display (Appendix)
CAD/DRAW 4 is a vector oriented technical drawing and illustration system. The term "vector oriented" 
refers to a particular method of displaying data and objects which, because of its high precision and 
independence from the screen and output resolution is always used for CAD systems and illustration 
programs.

A line in CAD/DRAW 4 is described by the coordinates of its starting and ending points. A 2D coordinate
consists of X and Y values:

Figure 1: Mathematical display of a line

A vector is uniquely defined by its length and direction. These details can be used to give each point 
within a layer a unique description.

Figure 2: Mathematical display of a rectangle

A rectangle is described by the coordinates of two diametrically opposite corner points (figure 2). This 
shows one of the important characteristics of vector graphics: the number and complexity of the objects in
a drawing and not their size is responsible for the file size.

For output on your screen or printer, the object data is recalculated by the driver according to the relevant 



resolution.

Data in memory

Data on screen/printer

Figure 3: Recalculation to the output resolution

This procedure may seem unneccesarily complicated, but it has the great advantage of only carrying out 
the data conversion immediately before output. The points can be calculated with much greater precision 
within the computer than they can be displayed or printed with. This ensures that each graphic can be 
handled with the maximum precision (depending on the resolution of the output device).

A further advantage of this method is that objects can be modified without problems. In a vector graphic 
for example it is easy to scale a circle by changing the radius. In a bitmap graphic on the other hand, the 
"old" circle has to be deleted and a new one has to be drawn. Or you have to scale the area that contains 
the circle. But bitmap scaling always yields poor results, e.g. jagged outlines etc.



Coordinate Systems (Appendix)

The basis for screen display is a method of describing the position of each point in your drawing. To do 
this, a coordinate system has to be defined. With the help of a coordinate system, each point in a drawing 
can be given a unique description. The best known type of coordinate system is the cartesian coordinate 
system. This consists of a coordinate origin and two coordinate axes at right angles to one another which 
meet at the origin. Usually, these axes are drawn horizontally and vertically. The horizontal axis is known 
as the X-axis and the vertical axis as the Y-axis (figure 1).

Figure 1: Cartesian coordinate system

CAD/DRAW 4 offers distorted forms of coordinate system to aid drawing in isometric and dimetric 
perspectives. These coordinate systems differ mainly by having a predetermined rotation angle and an 
altered height/width ratio. Further information on these coordinate systems can be obtained from the 
reference and the example on dimetric drawing.

Determination of Coordinates
Further observations confine themselves to cartesian coordinate systems. Figure 1 shows such a 
coordinate system. The X-axis is numbered from left to right, and the Y-axis from bottom to top. In the 
standard CAD/DRAW 4 drawing window, the origin (that is, the point at which X and Y are 0) at the 
bottom left of the page. The area available to you is the area which is shaded on the graph. The origin can 
be moved to another point on the page which will make it possible to draw in the other areas.

Various ways can be used to identify a point uniquely. The simplest way is the use of absolute 
coordinates. Absolute coordinates specify the precise X and Y values of a point (Figure 2).



Figure 2: Absolute coordinates

It is possible to identify a point by specifying its position relative to another point. These are called 
relative coordinates. The first point is treated as if it were the origin and the distance between the X and Y
values of each point is given. In mathematics, this is often abbreviated as dx and dy. When (x1;y1) are the
absolute coordinates of the first point and (x2;y2) are the absolute coordinates of the second point, the 
position of the second point relative to the first can also be described as follows: (x2;y2)=(x1+dx;y1+dy) 
(Figure 3).

Figure 3: Relative coordinates

A third method is the use of polar coordinates. These coordinates are described by distance from the 
origin and angle from the zero-angle. The mathematical zero-angle (that is, 0°) is along the positive X-
Axis, that is, at the "three o' clock" position (Figure 4).



Figure 4: Mathematical zero-angle

Angles are measured in an anticlockwise direction. This form also describes the position of each point 
uniquely (Figure 5).

Figure 5: Polar coordinates



Before you start (Examples)
Rules
The first part of this chapter explains, step by step, how to make a drawing. A requirement to follow this 
example through is an identical system configuration. Therefore we recommend that you import the file 
elements "Page Format", "Line Sequences", "Coordinate Systems", "Pens", "Line Patterns", and "Layers" 
from the TUTORIAL.T4G configuration file by means of the command File>Import>TVG 4.2. If other 
settings are needed, this is made clear at the start of the example.

The file TUTORIAL.T4G along with other sample files is located in the TUTORIAL directory in your 
CAD/DRAW 4 directory. In case you have downloaded the tutorial from our CompuServe library or our 
WWW site then you should copy the downloaded drawing files (*.T4G) into the TUTORIAL directory 
in your CAD/DRAW 4 directory. The file TUTORIAL.HLP should be always located directly in the 
CAD/DRAW 4 directory.

Standards
All of these examples are based on DIN 15 (DIN = Deutsche Industrienorm, German Standard). This 
standard lays down, amongst other things, which line type is used for which purpose. In technical 
drawing, 2 line groups are used most of the time, identified by their full line widths. These are the line 
groups 0.5 and 0.7. Only lines from one line group should be used in each drawing.

The choice of line group should be made according to the type of part to be drawn. Simple, large parts 
should be drawn using the 0.7 group and smaller more detailed ones with the 0.5 group.

Representation
In the examples, the geometry is shown as a dotted line. Drawn objects are shown with the relevant pen 
properties.

Defaults
For certain object types (dimensions, dimension numbers and text) it is possible to specify the pens to be 
used before starting the drawing. These defaults are set by choosing Configuration>Pens>Defaults. If the 
line group 0.5 is usually used, the pen "0.5 mm\Solid Line Narrow" should be assigned to these object 
types as the default. This saves the need to change pens when adding a dimension; the program does it 
automatically.



The Rectangle (Examples)

Figure 1: The Rectangle

Aim
A rectangle of fixed size is to be drawn, measured, hatched and centered on the page.

Settings
TUTORIAL.T4G

Firstly, draw the rectangle to size. Choose the pen "0.5 mm\Solid Line Wide", which has the correct set of
properties (solid line, 0.5 mm) for object edges. 

Choose Polygon>Rectangle from the Draw menu. The status line gives you information about the 
progress of the command. Follow the prompt "Enter Corner 1" and click the left mouse button at the 
upper left of the page. It can be released immediately. The position of this point is not really important as 
the rectangle is to be centered on the page anyway. This mouse click has provisionally marked the upper 
left corner of the rectangle.

The status line now prompts you to enter the second corner point. As this point is to be at a precisely 
determined x and y distance (also called a relative distance) from the first corner point, enter this distance 
with the keyboard by pressing the ENTER key. In the status line, a field with an insertion mark appears. 
Move the field and the insertion mark to the dx field of the status line by pressing the TAB key multiple 
times, type 100 , move the mark to the next field, type -50 and press ENTER again.

Figure 2: Direct Input

This tells the program to enter the second corner point 100 mm in the x direction and -50 mm in the y 
direction from the first corner point. Now you have a rectangle of the right dimensions (Figure 3). The 
dimensions can be checked by measuring the object.



Figure 3

If you have already chosen a pen for dimensions using Configuration>Pens>Defaults it is not necessary to
change pens. If this is not the case, choose the pen "0.25 mm\Solid Line Narrow" from the panel.

Choose the command Dimension>Length, Object from the Lettering menu. The dialog contains 
dimension parameters for most situations. Confirm these settings by clicking on "OK". The status line 
now prompts you to identify a reference line. This line is the line which is to be measured. Click on the 
upper horizontal line of the rectangle with the left mouse button. This identifies the line. Next, specify the
dimension line position by moving the mouse vertically (perpendicular to the reference line). You will see
that the dimension line always moves in fixed increments. Click the left mouse button when the line has 
jumped one position upwards. This completes the first measurement. 

Without re-starting the command (it is still active) you can measure the right (vertical) side of the 
rectangle in the same way (Figure 4).

Figure 4

Next, apply a hatching to the rectangle. Activate the pen "0.25 mm\Solid Line Narrow" and choose the 
Hatching>Objects command from the Drawing menu. To apply the hatching, identify the rectangle by 
clicking on its edge (Figure 5).



Figure 5

Finally, choose Shape>Align Objects>Centered, Page Both and press F10 to center the whole drawing 
relative to the page margins. Choosing Configuration>Zoom>Page allows you to see the effect properly.

To save your first drawing, choose File>Save As, enter a file name e.g. DRAWING1.T4G and click on 
"OK". You can then enter a full description of the drawing in a further dialog and carry out the save by 
clicking on "OK".



Snapping Functions and Compound Measurements 
(Examples)

This chapter uses some commands that are only available in Level 2 of CAD/DRAW 4!

Aim
The following example shows ways in which the geometry and snapping functions can be used and in 
addition how to set dimension parameters to cope with making complicated measurements.

Settings
TUTORIAL.T4G

Procedure
First of all, the rectangles are drawn and hatched, then rotated and measured.

This drawing does not contain any information about the height of the rectangles. You can choose any 
height you want as the principle remains the same. However, it is necessary to stick to a predetermined 
width and this is done with the help of the Geometry. Use the command Geometry>Line>Vertical to place
a first vertical geometry line at the left of your page.

Use the command Geometry>Line>Parallel, Numerical to insert another vertical line parallel to the 



existing one. After choosing the command, a dialog appears in which you can enter the required spacing. 
Enter 40 mm (the width of the first rectangle) and identify the previously drawn vertical. Move the 
crosshair to the right until the red line separates from the identified line and jumps 40 mm to the right. 
Confirm this by clicking the left mouse button and then click the right mouse button to end the command 
sequence.

Because the parallel lines are placed in the correct positions automatically, snapping must remain turned 
off during this command. Otherwise, conflicts can arise between the different positioning techniques. If 
the result of the poisoning leads to a conflict, the loudspeaker beeps.

To reactivate the Geometry>Line>Parallel, Numerical command, press SHIFT and ESC at the same time. 
The same dialog as before appears and you can set the value 20mm for the second line's spacing. Proceed 
as previously: identify the last line and move the crosshair until the red line jumps 20 mm to the right. 
Click the mouse button to confirm this and move the crosshair again until the line jumps another 20 mm, 
click the left mouse button to confirm the command and then click the right mouse button to end the 
command sequence.

After pressing SHIFT+ESC again, enter the last interval of 50 mm and proceed as previously.

Figure 1: Geometry

To finish constructing the geometry use the command Geometry>Line>Horizontal to place a horizontal 
line in the lower part of the page. The geometry should resemble Figure 1.

To draw the first rectangle, activate snapping and the "Geometry" snapping mode.
Choose Draw>Polygon>Rectangle and click on the intersection of the left geometry line with the 
horizontal geometry line (Point 1, Figure 2).

Because you can choose the height of the rectangle freely and only have to place the rectangles second 



corner on the second vertical line, activate the "Edge" snapping mode and then place the second corner 
point on the vertical geometry line which you previously placed exactly 40 mm to the right. (Point 2, 
Figure 2).

Use a similar method to draw the second, third and fourth rectangles (Figure 2).

Figure 2: Basic elements

Next, hatch the rectangles. Apart form the standard hatching in rectangles 2 and 4, it's neccesary to define 
a narrower -45° hatching for rectangles 1 and 3.

First, choose Draw>Hatching>Edit Line Sequences and create a new line sequence by clicking on the 
"New" button. Enter Solid Line, 2.5 mm , click on "OK" and then click on the "Edit" button to edit
this line sequence and set all distances to 2.5 mm. Close both dialogs by clicking "OK".

Now, choose Draw>Hatching>Edit Hatching Types and create a new hatching type by clicking on the 
"New" button. Enter Hatching Two , click on "OK" and then click on the "Edit" button to specify the 
new hatching's properties. The only alterations needed are to change the first line sequence to "Solid Line,
2.5 mm" and the angle to -45°. Close the top-level dialog by clicking on "OK", then the main dialog by 
clicking on "Activate".

The new hatching becomes the current hatching. Choose Draw>Hatching>Objects and click on the first 
and third rectangle (Figure 3).



Figure 3: First hatching

To re-select standard hatching, choose Draw>Hatching>Hatching Type List and select "*Standard" 
hatching type from the list which appears.

Rectangles 2 and 4 can now also be hatched easily by choosing Draw>Hatching>Objects (also available 
from the command list, simply press the key H) and clicking on them (Figure 4).

Figure 4: Second hatching

Next, all the objects are to be rotated by 32°. To do this, choose Shape>Rotate Objects>Center. and 
identify the objects to be rotated. In this case all the objects on the page are to be rotated, and it is easiest 
to identify them all by using the function key F10 (or the keyboard combination SHIFT+Q). Alternatively,
you can hold down the SHIFT key and drag a frame around all the objects. Enter "32" into the dialog 
which appears and click on "OK" (Figure 5).



As the geometry is not required any more, it can be turned off by pressing the F9 key or clicking on the 
relevant button in the panel. This makes the drawing clearer.

Figure 5: Objects after rotation

The dimensions are now applied. The starting point is to be the longest rectangle. The dimension should 
be at least 10 mm from the top edge of the highest rectangle. All the other dimensions will align 
themselves to this dimension. Choose Lettering>Dimension>Length, Object. Now, press SHIFT+ESC.

This calls a dialog (Figure 6) where you can specify various options for the appearance and positioning of
the dimension line, the start and end points and the positioning of the dimension figure.



Figure 6: Dialog "Dimension>Dimension>Length, Object"

Identify the segment to be measured and move the mouse towards the dimension line until it blends with 
the red dimension line. Confirm this by clicking the left mouse button (Figure 7).

Figure 7: Measuring the first rectangle
 



It is necessary to alter the settings for the subsequent measurements. Either call the command 
Lettering>Dimension>Length,Object again or press SHIFT+ESC. This key combination restarts the 
command and calls the dialog again. To align the dimension lines correctly, it is not possible to use a fixed
distance; choose the icon for user-defined spacing (see picture) and close the dialog by clicking on "OK".

Figure 8: Icon for user-defined spacing

Identify one of the three lengths which still has to be measured. The dimension line can be moved freely. 
To position it accurately, choose "Corner/Endpoint" snapping mode from the panel and press the F6 key 
to turn snapping on. Four small lines marking the snapping radius appear round on the crosshairs. Click 
on the intersection of the existing dimension line and the existing extension line to position the new 
dimension line (Figure 9). 

Figure 9: Zoom of the snap point

The new dimension line will snap into place correctly aligned with the other dimension line. Proceed in a 
similar way for the remaining dimension lines. You can now turn snapping off again, either by pressing 
F6 or by clicking on the button in the panel. In many cases, it can make more sense to temporarily turn 
snapping on or off by holding down the SHIFT key. Try both methods. Your drawing should now look 
like this:



Figure 10

Next the base line will be drawn in. This is done in two steps. Choose Draw>Line>Horizontal and specify
the starting point of the line. After clicking on the satatus line or pressing the F8 (ENTER) key a field 
appears into which a coordinate length or radius can be entered. By default, a "sensible" value is already 
entered. Enter 50 mm as the length. Choose Shape>Move Objects>Standard and identify the horizontal 
line which you have just drawn. Next it is necessary to enter a reference point. To place this exactly in the 
middle of the line, activate "Midpoint" snapping mode and click on the line. You have "grabbed hold" of 
the center of the line and can move it about. The line's mid-point should be placed on the bottom corner of
the first rectangle. Activate "Corner/Endpoint" snapping mode (the old snapping mode will be turned off 
automatically as Midpoint and Corner/End snapping cannot be used at the same time) and click on the 
corner (Figure 11).



Figure 11: Baseline

Finally, the angle between the baseline and the rectangle will be added to the drawing. Choose 
Lettering>Dimension>Angle, Line - Line and identify the ends of the two lines enclosing the angle. You 
can now choose from multiple angles by moving the crosshair. If you want to dimension an angle larger 
than 180°, keep the CTRL key pressed.

In a similar way to measuring lengths, a extension line appears at a fixed radius from the center of the 
angle. Confirm the dimension line position 40 mm from the center of the angle (one "jump" = 10 mm) 
(Figure 12). 



#Figure 12: Angle between the baseline and the rectangle

Save your drawing using File>Save Drawing as.



The Eccentric (Examples)

This chapter uses some commands that are only available in Level 2 of CAD/DRAW 4!

Aim
This drawing of an eccentric is intended to show the use of the geometry. Various construction procedures
and measurements with differing parameters are used. You will learn how to generate and hatch surfaces 
and to merge objects from other drawings. To remove parts of the background, erasers are used as aids to 
drawing. 

Settings
TUTORIAL.T4G

Remarks
Descriptions of choosing commands and working procedures are briefer than in the previous example. 
Entry of precise values is always done by pressing the F8 key or by clicking on the status line. The 
relevant values are entered in a field in the status line if the chosen command does not have its own dialog
for the entry of values.

You should already be familiar with the snapping functions and procedures for identifying objects.



Page Format
The eccentric is to be drawn on a landscape DIN A3 page in the scale 1:2. Choose Configuration>Page 
format and click on the entry for "DIN A3" in the list of formats. Click on the icon for "Landscape" and 
then click on "OK".

Use the command Configuration>Coordinate Systems>Edit. to set the scale. Click on the "View" button 
and then on Reduction Sales: 1:2 button. Close the dialog by clicking on "OK".

Because the drawing consists of a part with two views which use a common geometry, it can make sense 
to insert an alignment mark before beginning drawing to make it easier to put the geometry and the 
objects in the correct relationship. Alignment marks are used in the printing industry for example to line 
up printing films or plates precisely. In this example, the geometry is on one film and the objects are on 
the other. If objects have to be moved during drawing, it is important to move the geometry by the same 
amount. Alignment marks help you to do this. The coordinate system's origin, normally the bottom left of 
the sheet, is a good place for an alignment mark. 

Choose Geometry>Geometry Circle>Standard, press the F8 key and enter the coordinate 0 and 0 into 
the status line. This places the center of the geometry circle on the origin. Pressing F8 again and entering 
2 in the status line sets the geometry circle's radius to 2 mm. Choose Geometry>Markings, press F8 
again and enter 0 and 0 to place a marking at the center of the geometry circle.

You can move the geometry to agree with the position of the drawing by choosing Shape>Move 
Objects>Standard and grabbing hold of the marking with "Midpoint" snapping mode active and letting go
of it on the marking with "Marking" snapping mode active.

Alignment
The starting point of the drawing is to be the plan, the left part of the drawing. To guarantee horizontal 
alignment, place a horizontal geometry line across the center of the page by choosing 
Geometry>Geometry Line>Horizontal, pressing F8 and entering the term (_pt+_pb)/2 into the field 
y. This will make the program work out the y-coordinates for horizontal geometry lines from the 
coordinates of the page's upper and lower edges. If the coordinate system origin is on the page's bottom 
edge, the same as the default settings in RELEASE4.T4G, then _pb/2 is all that has to be entered. This 
entry places the horizontal geometry line half way up the page.

The Plan
In addition, place a vertical geometry line approximately one third of the way across the page using 
Geometry>Geometry Line>Vertical The resulting intersection marks the provisional center of the plan 
(Figure 1). The final alignment is done at the end.

Choose the pen "0.5 mm\Solid Line Wide" and use Draw>Circle>Standard to draw a circle centered on 
the intersection of the geometry lines. Whilst doing this, briefly activate the "Geometry" snapping mode 
using the SHIFT key. After specifying the center, press F8 and specify a radius of 190 mm.

Choose Draw>Circle>Concentric and identify the previously drawn circle. Enter a radius of 180 mm for 
the new circle. Your drawing should now look similar to this:



Figure 1

The Bearing
The center of the eccentric bearing is specified next. It lies 90 mm below the intersection of the geometry 
lines. Choose Geometry>Geometry Line>Parallel, numerical, enter 90 mm as the distance and identify 
the existing horizontal line as the reference line. Place the parallel line underneath the reference line. The 
Intersection of this new line and the vertical line (Point Z) is the center of the bearing. (Figure 2).



Figure 2

Using this new intersection as the center, use Geometry>Geometry Circle>Standard to draw a geometry 
circle with a radius of 52mm. Use Geometry>Geometry Circle>Concentric to draw 2 further circles with 
radius of 78 mm and 90 mm (Figure 2).

The two circles can be drawn in the same command sequence. Instead of clicking the right mouse button 
after entering the first radius, press F8 again, enter the second radius and then click the right mouse 
button.

The Spring Nut
These geometry lines are used to determine the position of the spring nut. Use Geometry>Geometry 
Line>Parallel, numerical to draw two parallel vertical lines 16 mm on either side of the existing parallel 
line. This can be done in one step by first identifying the vertical line then clicking with the left mouse 
button to the left of the reference line and clicking with the left mouse button to the right of the reference 
line, finishing the command sequence by clicking the right mouse button.

To determine the depth of the nut, a horizontal geometry line is placed through the lower quadrant of the 
innermost geometry circle. Choose "Quadrant" snapping mode and draw a horizontal line through the 
lower quadrant using Geometry>Geometry Line>Horizontal with the SHIFT key held down. The spring 
nut is 110.4 mm from this line. Geometry>Geometry Line>Parallel, numerical is used to specify the 
distance exactly and draw the geometry line.



The outline of the bearing is found from the intersections. Turn on the "Geometry" snapping mode and 
use Draw>Line>Polyline to draw the bearing's sprung nut by using the intersections (A, B, C and D in 
Figure 3) as the corners of the polyline. End the command sequence by clicking the right mouse button 
after entering the fourth corner point.

If you misplace one of the corner points, then you can take it back by pressing the ESC key before ending
the command.

Figure 3

Complete the bearing by drawing the remaining arc using Draw>Arc>On Circle Identify the geometry 
circle on which the arc is to be drawn and then choose as start and end points the ends of the polyline. 
You can have the "Corner/Endpoint", or "Geometry" snapping modes, or both, active.

If the arc runs in the wrong direction, you can easily change it during drawing using the relevant button 
from the panel. If you have finished drawing the arc in the wrong direction, change it by using the 
command Trim>Transform Object to>Inverted Object 

Use Draw>Circle>On Circle to complete the middle concentric circle (see Figure 4).



Figure 4

The Blank Spaces
The blank spaces in the eccentric are still missing. Only one has to be drawn: the other can be created 
using mirroring with the duplicate function turned on. The outline of each cut-out consists of the five 
circle parts (3×1, 2, and 4) as well as a line (3) (Figure 5). Of the circle parts 2 and 4 as well as the line 3, 
only the position of the geometry on which they sit is known. The start and end points are not known.



Figure 5

The three circle parts 1 have a known radius, but their center points are not known. Their position must 
therefore be worked out from further information. This extra condition is that each of the three circle parts
ends tangential to two further objects.

First it is necessary to draw the missing geometry. Geometry circle 1 already exists. Use 
Geometry>Geometry Circle>Concentric to draw a geometry circle with a radius of 140 mm to use for 
circle part 2. In addition, use Geometry>Geometry Line>Parallel, numerical to draw a line 30 mm distant 
from the vertical geometry line. The line (3) from the cut-out will be drawn there later.

Begin to construct circle part 1 with Draw>Arc>Radius - Object - Object . Enter the radius 20 mm in the 
dialog field. Now identify both the geometry elements to which the arc should be tangent. For the upmost 
arc, these are the last-drawn vertical geometry line and geometry circle two. The program will offer a 
choice of the arcs which it can draw. Click on the "Forwards" button until the variant which you want 
appears and then click on "OK". Repeat the process to draw the other two arcs 1 (Figure 6).



Figure 6

Because the tangential points are now determined, the elements two, three and four can be drawn on top 
of the existing geometry. Choose Draw>Line>Standard and draw the missing straight line by clicking on 
the two arcs' endpoints with "Corner/ Endpoint" snapping mode active.

Choose Draw>Arc>On Circle and draw the missing arc by identifying the relevant geometry element and 
clicking on the two arcs' endpoints with "Corner/Endpoint" snapping mode active (Figure 7).



Figure 7

The outline for the right cut-out is now complete. Choose Shape>Reflect Objects>Line. To be able to 
mirror and duplicate the cut-out in one move, press and hold down the CTRL key and identify each of the 
elements in the cut-out's outline. Holding down the CTRL key makes it possible to identify more than one
object for manipulation at the same time. Release the CTRL key after identifying all the elements in the 
outline. Next, it is necessary to identify the axis of reflection. Press the CTRL key again to activate the 
duplicate function. You will know that it is active because a "+" appears on the crosshair. Identify the 
vertical geometry line running through the center of the circle as the rotation axis by clicking on it. The 
reflection should now appear symmetric to the original (Figure 8).



Figure 8

Apart from the mid lines, the section indicator and the dimensions, the plan is now complete. Before they 
are added to the drawing, the section drawing should be drawn.

The Section View
To make drawing the section as easy as possible, the most important points from the eccentric are to the 
side view with the help of the geometry. With the "Quadrant" snapping mode active, use 
Geometry>Geometry Line>Horizontal to insert horizontal geometry lines at the upper and lower 
quadrants of the three outermost concentric circles and the two inner bearing circles. This produces a total
of nine new horizontal geometry lines. The innermost bearing circle already has a geometry line in its 
lower quadrant which does not have to be drawn again (Figure 9).



Figure 9

Use Geometry>Line>Parallel, numerical to place a vertical geometry line 360 mm to the right of the 
eccentric's central vertical geometry line. This line is the central vertical of the sectional drawing. If it 
proves necessary to move the view to get space, we remind you of the tip concerning moving the 
geometry at the start of this chapter.

The page should now look like this:



Figure 10

Because the sectional view is completely symmetrical, it is enough to draw half of it and then mirror all 
the objects about the center line with the duplicate function turned on. You have already used this function
whilst drawing the cut-outs in the plan view.

Choose Geometry>Geometry Line>Parallel, numerical and place three vertical lines 23 mm, 33 mm and 
55 mm to the right of the axis of rotation. The easiest way of doing this is to press SHIFT+ESC (N) to 
restart the command and enter a new value.

All the intersections needed to draw the sectional view are now in place. Nest, the rounded shapes for the 
bearing are drawn. They both have a radius of 12 mm and are tangent to two geometry lines. Choose 
Draw>Arc>Radius - Object - Object, enter the radius 12 mm and identify the tangential geometry lines. 
Choose the desired variant.



Figure 11

Now the remaining intersections are joined using a polyline drawn using Draw>Line>Polyline and the 
"Geometry" snapping mode turned on (Figure 12).



Figure 12

Choose Shape>Reflect Objects>Line and, holding down the SHIFT key, drag out a rectangle around all 
parts of the sectional drawing. Release the key. This has identified the objects for the following operation.
Press and hold down the CTRL key to activate the duplicate function and identify the left of the four 
vertical geometry lines as the reference line (axis of rotation).

To complete the outline, draw the five horizontal lines using Draw>Line>Standard with both 
"Intersection" and "Geometry" snapping modes active. This is needed to ensure that the lines snap 
correctly to the intersection points on the reflected side of the drawing as the objects intersect with both 
horizontal and vertical geometry lines (Figure 13).



Figure 13

Surfaces and Hatchings
The geometry is not needed during the next step. It is best if you turn it off with the button in the panel or 
with Geometry>Display Geometry.

Three areas in the sectional view need to be hatched. It is necessary to temporarily generate a surface 
from the objects surrounding the areas to be hatched. To generate a surface, all the objects surrounding the
surface have to be identified. Make sure that the button for "Inside" area mode is pushed in. Change to the
pen "0.25 mm\Solid Line Narrow" and choose Draw>Hatching>Generated Surface and, holding down the
SHIFT key, drag a box around the surface which is to be generated. The future surface must lie 
completely within the box, or all the line parts may not be identified. Specify a reference point inside the 
area of the new surface.

Carry out a similar procedure for the other two surfaces (Figure 14).



Figure 14

Additions
Now, the symmetry lines are added. Turn the geometry on, choose the pen "0.25 mm\\Dash-Dot Line 
Narrow" and draw the symmetry lines on the geometry lines in the sectional view using Draw>Line>On 
Line. The lines should extend a little way beyond the eccentric's edge.

The center lines on the plan view are drawn simply by choosing Draw>Line>Center Cross and identifying
the outermost circle. The horizontal center line of the bearing is also drawn using Draw>Line>On Line. 
The geometry can now be finally turned off (Figure 15).



Figure 15

Adding Dimensions to the Sectional View
Choose the pen "0.25 mm\Solid Line Narrow". With the exception of the radius, all the dimensions are 
applied to the sectional view using Lettering>Dimension>Length, Point The preset parameters can be 
used for the dimensions outside the objects. To work out the start and end points of the lengths, activate 
the "Corner/ Endpoint" snapping mode. For the dimensions inside the body, restart the command using 
SHIFT+ESC and clear the "Center Dimension" check box. This makes it possible to position the 
dimension to the left of the central vertical line. For the 66 mm width dimension turn off the check box 
for extension lines as well and snap to the lower corners of the topmost surface. Because there are no 
extension lines, the dimension can be moved downwards as far as wished.

Next, choose Lettering>Dimension>Radius Object, identify the radius and place the dimension in the 
hatching.



Figure 16

The Eraser
To clear an area for the radius' dimension in the hatching, use the eraser. Every object which is drawn has 
a position relative to the objects drawn before and after it. You can think of the objects as playing cards, 
which, when placed on the pack, partly or completely cover the underlying cards.

Use the command Draw>Polygon>Arbitrary to place a surface over the dimension which will "rub out" 
the background and only allow those objects to appear which are "above" that surface (i.e. drawn later). 
Then, choose the command Shape>Edit Properties, identify the previously drawn surface and set its 
filling mode to "Eraser" (the fourth of the five available filling modes).

Objects can be brought to the front or sent to the back. This is necessary in this case because the eraser - 
to allow calculation of the dimension - was the last-drawn object. Choose Shape>Change Order>To Front
and click in the center of the erasing surface, under which the dimension lies. (It is also possible to use 
Shape>Change Order>To Back and move first of all the erasing surface and then the hatching to the 
back.) Bear in mind that the erasing surface must be identified at its edge. The erasing surface should now
block out part of the hatching and the dimension should be clearly visible (Figure 17).



Figure 17

Add the 'Ø' symbol to the vertical dimensions by choosing Shape>Edit Text identifying each dimension in
turn and entering the 'Ø' symbol in the Pre-Text field (do this by clicking on the relevant button) and 
clicking on "OK".

Adding Measurements to the Plan View
Now, measurements are added to the plan view. Firstly, apply measurements to the 20 mm radii in the 
left-hand cut-out. Choose Lettering>Dimension>Radius, Object and deactivate the "Center Dimension" 
check box in the parameter dialog (accessible by pressing SHIFT+ESC). This makes it possible to place 
the dimension at a suitable point on the dimension line. Identify a radius, choose the dimension line 
direction between the center point and the radius and place the end of the line at the center by clicking on 
the circle's edge with "Midpoint" snapping mode turned on. Pull the dimension to the correct position.

Proceed in the same way with the cut-out's 90 mm and 140 mm radii. The "Center Dimension" check box 
should also be turned off when applying dimensioning to the inside diameter of the bearing. This is 
neccesary because a separate set of parameters is stored for each dimensioning variant. For the inner 
radius choose Lettering>Dimension>Diameter, Object, to put the 'Ø' character in the Pre-Text 
automatically (Figure 18).



Figure 18

Next, the length measurements are applied. Because none of the measurements is concerned with a single 
object, the command Lettering>Dimension>Length, Point must be used. The corners at which the 32 mm 
and 60 mm extension lines begin are used as snapping points. The dimension also has to be positioned by 
hand in this case. Do not forget to turn the extension lines on again. To measure the 32 mm distance, 
activate the Tolerances check box in the dimension parameters dialog so that you can enter P9 as the 
upper tolerance in the Tolerance dialog which appears later.

To apply a dimension of 110.4 mm to the sprung nut in the drawing, use the top intersection of the nut 
with the central vertical line and the and the quadrant point of the circle (or the intersection of the circle 
and the central vertical line) as snapping points.

Finally, the distance from the midpoint to the center of the eccentric (90 mm) is added. So as not to cover 
the dash-dot symmetry line, the extension lines can only start at the ends of the two dash-dot lines. It is 
neccesary to keep the dimension lines vertical. Do this by activating the "Center Dimension text" and 
"Adapt Dimension text" check boxes in the Dimension dialog, activate "Corner/Endpoint" snapping mode
and click on both ends of the dash-dot line. You can now set the dimension line's orientation. Press the F8 
key and enter 90°. Now you have only to position the dimension line in the usual manner (Figure 19).



Figure 19

Drawing Frame and Text Box
Now a standard template is to be added. Select all the objects in the drawing with Extra>Permanent 
Selection>Set and pressing F10. This makes it possible, after loading the template, to move the selected 
objects but not the newly added ones. For a DIN A3 page, choose File>Import>TVG 4.2 and choose the 
file 6771_6_3.T4G from the DRAWING\FORMS directory. This is the standard frame for an A3 
drawing. Carry out the command again, this time choosing the text box from the file 6771_1_4.T4G . 
This text box has to be positioned against the drawing frame.

Choose Shape>Move Objects>Standard and press the F11 key to repeat the last identification. After 
merging objects, this affects all the "new" objects. Click on the lower right corner of the text box and, 
with the help of the snapping function, move all the objects to the lower right corner of the drawing.

Before the next step, you should make sure that you placed one of the pass marks referred to earlier 
otherwise it will be much harder to align the geometry after the centering. Center all the selected objects 
in the free drawing area using Shape>Align Objects>Center, Frame    Both. To identify all the selected 
objects (but not the merged objects) press the F12 key and choose as the area in which everything should 
be centered the inner upper left corner of the drawing frame and the upper right corner of the text box. All
the selected objects can now be deselected by choosing Extra>Permanent Selection>Clear and pressing 
F10.

Finally you can use the command Lettering>Text>Standard to generate the necessary text to go in the text



box. Save the drawing using File>Save Drawing as.

Alternative Construction Methods
The sprung nut and the cut-outs can also be constructed by using standard objects and trimming them. Try
to draw the eccentric without referring to the tutorial. Use your own ideas and in case of difficulty, refer 
to the electronic reference.



The Ballhead (Examples)

This chapter uses some commands that are only available in Level 2 of CAD/DRAW 4!

Aim
This example should make both principle methods of drawing using the geometry and trimming 
functions. Note that in practice using just one method of construction is very rare.

Settings
TUTORIAL.T4G



The Ballhead (Geometry)
Use Geometry>Geometry Line>Horizontal and Geometry>Geometry Line>Vertical to draw to lines (A 
and B) whose intersection places the center of the ball head as close as possible to the center of the page.

Next, draw a geometry circle with a radius of 35 mm using the intersection as the center 
(Geometry>Geometry Circle>Standard). Use Geometry>Geometry Line>Horizontal) to draw a horizontal
geometry line through the upper quadrant point of the geometry circle.

Use Geometry>Geometry Line>Parallel, numerical) to draw horizontal geometry lines 102 mm below the
geometry line through the upper quadrant point and 38 mm below the horizontal center geometry line. 
The geometry should now look like Figure 1.

Figure 1

Next, construct parallels 12mm and 18 mm to the right and left of the central vertical geometry line 
(Figure 2).



Figure 2

Draw a parallel geometry line 2mm above the bottom horizontal geometry line. Use the key combination 
SHIFT+ESC to restart the command. This new geometry line will be used later when drawing the 
chamfered section.

Use Geometry>Geometry Line>Angle to Line to draw a line at 45° on the right side and -45° on the left 
side to indicate the position of the chamfer. Use the intersection of the 12 mm vertical geometry line with 
the new horizontal geometry line (S) as the snapping point. Repeat the process with the angle of 45° on 
the opposite side (Figure 3).



Figure 3

Draw a horizontal geometry line 24 mm above the horizontal symmetry line using Geometry>Geometry 
Line>Parallel, numerical.

The left hand intersection of this new geometry line with the geometry circle is one end of the center line 
of the ball head's blank space (Figure 4, K). The other end of this center line lies at the center of the circle 
(M). Use Geometry>Geometry Line>Standard.



Figure 4

Use Geometry>Geometry Line>Parallel, numerical to draw lines 10 mm above and below this line 
(Figure 5).



Figure 5

To determine the depth of the blank space, use Geometry>Geometry Line>Angle to line to draw a line at 
90° to the center line M which passes through the intersection of the center line M with the geometry 
circle. Use Geometry>Geometry Line>Parallel, numerical) to draw parallel B 45 mm from the new 
geometry line (Figure 6).

Figure 6

From the Geometry to the Objects
So far, you have drawn a rather complex geometry. It contains all the intersections and elements needed to
draw the objects. Now you can begin to draw the objects themselves. Make use not only of the 
"Geometry" snapping mode, but also of the zoom functions, as some of the intersections are close 
together.

Choose the pen "0.5 mm\Solid Line Wide" and begin to draw the two circle parts using the command 
Draw>Arc>On Circle (Figure 7).



Figure 7

The next step is to draw the two rectangles underneath the ball head using the command 
Draw>Polygon>Rectangle Check the position of the rectangles against the original drawing (Figure 8).



Figure 8

Complete the object by drawing the missing line sections (the blank space and the chamfered section) 
using Draw>Line>Polyline. Note that the bottom corner point of the blank space does not lie on the 
central vertical geometry line but is a product of the two diagonal geometry lines (Zoom in on this area 
before locating the intersection) See Figure 9.

Figure 9

Next, the central lines are drawn. Select the pen "0.25 mm\\Dash-Dot Line Narrow" and draw the missing
circle part (in the blank space) 
using Draw>Arc>On Circle .

Use Draw>Line>Center Cross to add the ball head's horizontal and vertical center lines at the same time. 
To extend the vertical line below the bottom of the object, choose Trim>Trim Object>Length / Radius to 
Point, identify the lower part of the line and click on the point to which the line is to be extended. Use 
Draw>Line>On Line to draw the blank space's center line.

The geometry can now be turned off using the button in the panel or by pressing F9 (Figure 10).



Figure 10

The 24 mm and 36 mm dimensions can be added using Dimension>Dimension>Length, Object and 
simple identification. Choose whatever distance you wish from the object in the parameters dialog 
(accessible by pressing SHIFT+ESC). To place the 36 mm dimension turn the "center dimension" check 
box off.

The 20 mm width of the blank space is measured using the command Dimension>Dimension>Distance, 
Object·Object. To make the dimension arrows point inwards choose the Orientation: Rotated setting in the
parameters dialog.

All of the other dimensions are added using Dimension>Dimension>Distance, Object·Point. Choose the 
dimension line's orientation from the icons in the dialog box.

Your drawing should now look like figure 11.



Figure 11

Finally, add the missing text and symbols using Shape>Edit text. If the chamfer dimension text (2.0×45º) 
lies within the dimension lines, you can correct this using the command Dimension>Edit 
Dimension>Position by clicking first on the dimension text and then on its new position (Figure 12).

Figure 12

In conclusion, as in the previous example of the eccentric cam a frame can be placed around the drawing, 
a text box added and the ballhead centered in the frame.

The Ballhead (Trimming)



When working with trimming functions, in general complete objects are drawn and then cut to size using 
the trimming functions. Even if you prefer to work using geometry functions, it is a good idea to work 
through the following example as it explains several important principles for working with trimming 
functions.

Choose the pen "0.5 mm\Solid Line Wide" and draw a rectangle 38 mm high and 36 mm wide 
approximately in the center of the page using the command Draw>Polygon>Rectangle. Now construct a 
circle centered on the midpoint of the top side of the rectangle with a radius of 35 mm using the command
Draw>Circle>Standard and with "Midpoint" snapping mode active (Figure 13).

Figure 13

After choosing Trim>Trim Object>Cut Out click inside the part of the circle which overlaps the rectangle 
and then, with "Intersection" snapping mode on, click on the two points where the circle and rectangle 
intersect. Your drawing should now look like this:

Figure 14

Now use Trim>Trim Object>Resolve Completely to split the rectangle into individual lines. Press the 
DEL key (this activates the Shape>Delete objects command) and click on the top edge of the rectangle. If 
the complete rectangle disappears, then the rectangle was not split up properly; use the UNDO command 
(Edit>Undo) to restore the rectangle (Figure 15).



Figure 15

Join the ends of the arc by using Draw>Line>Standard with "Corner/Endpoint" snapping mode active. 
Trim the vertical lines to the new horizontal line using the command Trim>Trim object>Length / Radius 
to Object. To do this, click first on the upper part of the line to be trimmed and then on the object, until 
the line is the correct length.

Figure 16

For the lower part of the ball head, draw a rectangle 24 mm wide and 102 mm minus 35 mm minus 38 
mm ( 29 mm) high somewhere on the page. This is the height of the ballhead minus the height of the parts
already drawn. This sum can be entered directly into the status line as simple mathematical operations are 
allowed here. Choose "Midpoint" snapping mode and the Shape>Move Objects>Standard command. 
Place the reference point on the middle of the rectangle's top edge and move it to the middle of the 
previously drawn object's bottom edge (Figure 17).



Figure 17

Use Draw>Line>Parallel, numerical to draw a line 2mm below the last drawn rectangle using "Edge" 
snapping mode to get the ends of the line in the right place (Figure 18).

Figure 18

The next step is to create the chamfer at the bottom of the ballhead. Using Draw>Line>Angle to Line 
draw a 45° line in the corner. Turn on "Corner/ Endpoint" snapping mode when specifying the start point. 
When the start point has been chosen, the program will show a dialog allowing you to choose a reference 
line, shown during the process. This geometry line lies on the previously specified line whose endpoint 
still has to be specified. All the intersections of this reference line can be snapped to using a combination 
of "Intersection" and "Geometry" snapping modes. Use the intersection of the reference line with the 
lower edge of the ballhead as the snapping point. The reference line is automatically turned off when the 
command has been carried out. Carry out the same procedure for the second chamfer, but using an angle 
of -45° (Figure 19).



Figure 19

Now it is necessary to remove the corners next to the chamfers. Remember that these corners are actually 
part of the surrounding rectangle. To trim them, the rectangle must first of all be split into individual lines.
Choose Trim>Trim Object>Resolve Completely and click on the rectangle. Before proceeding further, it 
is a good idea to zoom in on the area using Configuration>Zoom>Section.

After choosing Trim>Trim object>Length / Radius to Object click first on the end of the line to be 
shortened and then on the object to which it is to be shortened (Figure 20).

Figure 20

The construction of the blank area is more complex. In order to get some necessary intersections, the 
symmetry lines are drawn in at this stage. Change to the pen "0.25 mm\\Dash-Dot Line Narrow" and use 
Draw>Line>Center Cross to draw the arc's center cross. Make the vertical line longer using Trim>Trim 
Object>Length / Radius to Point (Figure 21).



Figure 21

Change back to the pen "0.5 mm\Solid Line Wide" for the remaining steps. Using Draw>Line>Parallel, 
numerical draw a short line 24 mm above the horizontal line so as to create an intersection with the arc's 
left side. Join this intersection to the center using the command Draw>Line>Standard). See Figure 22.

Figure 22

Remove the short horizontal line using Shape>Delete Objects (or by using the DEL key) and make the 
diagonal line longer by choosing Trim>Trim Object>Length/Radius to Point. Identify the lower part of 
the line, press F8 and enter 45 mm as the length (Figure 23).



Figure 23

The edges of the blank area are generated next using the symmetry axis just drawn as a model. Choose 
Shape>Move>Perpendicular and activate the duplicate function by pressing F7 or clicking on the button 
in the panel. Identify the diagonal as the object to be moved and as the reference object. The reference 
point can be placed as desired. Press F8 and enter 10mm as the distance. (Note the direction of the arrow 
in the status line. It shows the direction of movement.) Repeat the process using a distance of -10 mm 
(Figure 24).

Figure 24

Use the command Draw>Line>Standard with the "Corner/Endpoint" snapping mode turned on, to draw a 
line joining the ends of the new lines. Trim the upper ends of the lines to the arc radius using Trim>Trim 
Objects>Length / Radius to Object). See Figure 25.



Figure 25

Now, change the pen properties of the middle diagonal line from pen "0.5 mm\Solid Line Wide" to pen 
"0.25 mm\\Dash-Dot Line Narrow" with Shape>Edit Properties. The "Fixed" check box is enabled 
automatically after choosing this command. Extend the blank space's symmetry line outside the edges of 
the blank area using Trim>Trim Object>Length / Radius to point (Figure 26).

Figure 26

The rest of the procedure, such as adding dimensions and text and centering the drawing, follows the 
same methods as when the geometry is used. Finally, save the drawing with File>Save Drawing as.



Using Surfaces in construction (Examples)

This chapter uses some commands that are only available in Level 2 of CAD/DRAW 4!

Settings
TUTORIAL.T4G

Aim
This example illustrates the use of surface operations alongside the geometry and trim functions when 
constructing a drawing. The object will be drawn solely with the addition and subtraction of surface 
objects and after that will have dimensions applied to it.

Surfaces
Choose A4 page size with the command Configuration>Page Formats. In order to make the example 
clearer, the final shape is shown as a thin dotted line in the illustrations. This is to help make it clear 
which part you are drawing at any time. Whenever possible, use the F8 (ENTER) key and enter 
dimensions directly to the status line.

Choose the pen "0.5 mm\Solid Line Wide" and use Draw>Polygon>Rectangle) to draw a rectangle 140 
mm × 70 mm (Figure 1).



Figure 1

Draw another rectangle 200 mm × 30 mm, whose bottom left corner is at the same place as the bottom 
left corner of the first rectangle. Use "Corner/ Endpoint" snapping mode to ensure this. To align the two 
rectangles, choose Shape>Align Objects>Centered, Frame Horizontal. Identify the second rectangle and, 
using "Corner/Endpoint" snapping mode, draw a frame exactly on top of the first rectangle. The second 
rectangle will automatically be aligned to this frame (Figure 2).

Figure 2

The two rectangles are now merged into one object using Trim>Trim Surface>Union (A=A+B) The two 
rectangles must be identified one after another. Your drawing should now look like Figure 3.



Figure 3

The next step is to add the outline of a triangle. You can see from the finished drawing that this is a right-
angled triangle with a 120 mm hypotenuse (long side) (Figure 4). There are two possible ways of 
constructing the triangle: graphic and mathematical.

Figure 4

The Graphical Method
Draw a rectangle 120 mm × 120 mm anywhere on the page. Draw in the two diagonals as geometry lines 
using Geometry>Geometry Line>Standard with "Corner/Endpoint" snapping mode active. You can 
determine the outline of the rectangle from this construction (Figure 5).



Figure 5

Choose Draw>Polygon>Triangle and place the corners on the two lower corners of the rectangle (1) and 
(2) and the intersection of the two geometry lines (3). After you have drawn the triangle, you can delete 
both the square and the geometry lines using Shape>Delete Objects.

The Mathematical Method
This method requires a little more knowledge about the mathematical construction of triangles, but is 
faster. Choose Draw>Polygon>Triangle. Click the mouse button to place the first point of the triangle on 
the page. Press the F8 key and use polar coordinates to enter the length and angle of the hypotenuse. 
Assuming the first point is the lower left angle, the following values have to be entered: l=120 a=0 . 
This tells TommySoftware® CAD/DRAW 4 to place a point 120 mm from the first one at a direction of 
0°. Press ENTER and then F8 again to enter the position of the third point. The angle of the right side A 
and its length are calculated using Pythagoras" formula: The height is identical to half the hypotenuse C, 
as can be seen from Figure 6.

Figure 6

In the status line enter l=sqrt(60^2+60^2) a=135 .



Back to the Outline
To align the triangle correctly with the existing outline, draw a horizontal geometry line 20 mm below the
bottom line of the outline. Do this by choosing Geometry>Geometry Line>Parallel, numerical and 
entering 20 mm as the distance. Use Shape>Move Objects>Standard and activate "Edge" snapping mode 
to move the triangle onto the new line. The triangle is horizontally aligned with the outline using the 
Shape>Align Objects>Centered, Frame Horizontal in the same way as the two rectangles were aligned 
earlier.

Figure 7

These two outlines are also merged with the command Trim>Trim Surface>Union(A=A+B).

Figure 8

Further areas have to be removed from the outline. Draw a rectangle 100 mm × 20 mm with its bottom 
left corner on outline corner 1 (see Figure 9).



Figure 9

This rectangle has to be aligned horizontally using Shape>Center Objects>Frame, Horizontal). Use the 
two symmetrical points in the outline as the corner points of the frame. Use Trim>Trim 
Surface>Difference (A=A-B) to unify the objects. Identify both objects one after another. A hole appears 
in the place of the last-drawn rectangle. This change is not visible if the larger object is filled.

You can easily check the alterations to the outline by choosing Shape>Edit Properties and changing the 
fill mode to "both". You will see the blank space. Objects behind the outline will now be visible through 
the hole.

One further rectangle is to be removed. Draw a 60 mm × 40 mm rectangle and position it using 
Shape>Move Objects>Standard so that it covers areas approximately the same are above and below the 
upper part of the outline. Center the rectangle horizontally using Shape>Align Objects>Centered, Frame 
Horizontal).

Figure 10

Use Trim>Trim Surface>Difference (A=A-B) to unify the objects (Figure 11).



Figure 11

Use Draw>Circle>Standard to draw a circle with a radius of 14 mm and its center at outline corner point 
1 (Figure 11). Center the circle horizontally using Shape>Align Objects>Centered, Frame Horizontal. 
This object is also cut away using the command Trim>Trim Surface>Difference (A=A-B) (Figure 12).

Figure 12

Draw a further rectangle 10 mm × 30mm and align it centrally using Shape>Align Object>Centered, 
Frame Both between the points 1 and 2 (Figure 13).



Figure 13

You can now use Shape>Move Object>Relative. to mirror the positioned rectangle about the center. 
Enable the "Duplicate" check box in the dialog and enter a value for the copy position of 170 mm 
horizontally.

The command Shape>Reflect Object>Line cannot be used because an axis would have to be identified 
and there is no axis present.

These two rectangles also have to be merged with the larger outline. However a difference does not have 
to be created, but they have to be combined with the large outline. This will keep the upper and lower 
outlines intact. Choose Trim>Trim Surface>Combine Outlines and identify all the objects to be 
combined. Either hold down the CTRL key and click on each object in turn or hold down the SHIFT key 
and drag a rectangle around all the objects. The result of this operation will not be immediately visible, 
however you can test it (as previously) by coloring the object using Shape>Edit Properties einfärben 
(Figure 14).

Figure 14

Choose the pen "0.25 mm\Solid Line Narrow". Hatch the whole outline using the command 
Draw>Hatching> Objects (Figure 15).



Figure 15

Now the symmetry lines in the circle and the cut-throughs at left and right should be added. Click on the 
pen "0.25 mm\\Dash-Dot Line Narrow" and choose Draw>Line>Center Cross and then click on the circle
to draw a center cross which extends beyond the boundary of the circle. Use Trim>Trim Object>Length / 
Radius to Point to extend the vertical line upwards to roughly level with the object's upper edge.

In the cut-out on the left, turn on "Midpoint" snapping mode and use Draw>Line>Vertical to draw a 
vertical line. Use Trim>Trim Objects>Length / Radius to Point to extend the line upwards by 5 mm. To 
do this, press the F8 key after identifying the line and enter 35 mm (30 mm existing line, 5 mm extension.
Repeat the process with the other end, entering 40 mm (35 mm line plus 5 mm extension).

Copy this vertical line to the other cut-out by using Shape>Reflect Object>Line with the duplicate 
function (F7) turned on. Identify the line to be copied and then click on the vertical line running through 
the circle which is the whole outline's symmetry axis. You could also use the command Shape>Move 
Objects>Relative (Figure 16).

Figure 16

Finally add the dimensions. Apart from the circle diameter these can all be added using 
Dimension>Dimension>Length, Point or Dimension>Dimension>Length, Objects To be able to position 
the diameter dimension better, after choosing Dimension>Dimension>Diameter, Object turn off the 
"Close" and "Center" settings In the dimension parameters dialog (accessible by pressing SHIFT+ESC).

Place an erasing surface behind the hole's dimension and remove the diameter sign from this dimension 
using Shape>Edit Text). Your drawing should now look like Figure 17.

Figure 17

Do not forget that there can be problems using Trim Surface>Union, Trim Surface>Intersection and Trim 
Surface>Difference if adjacent surface edges are parallel and lie on top of each other. If possible, avoid 



this by making objects overlap. Further information about this can be found in the electronic reference.



Gear Housing (Examples)

This chapter uses some commands that are only available in Level 2 of CAD/DRAW 4!

Aim
Drawing the gear housing should illustrate generating complex and nested surfaces. Layers are used in 
order to keep the drawing manageable. Layers can be used to make parts of the drawing which have 
already been finished invisible.

Settings
Again, the settings contained in TUTORIAL.T4G are used.

The drawing will be done on an A4 portrait page, which means that the page settings do not have to be 
changed. Extra layers will, however, be needed. Choose Configuration>Layers>Edit Layers and alter the 
name of layer "Drawing" to "Inner Housing Wall" (using the "Name..." button) and then click on "New" 
and create a new layer with the name "Outer Housing Wall". Reselect the layer "Inner Housing Wall" and 
leave the dialog with the button "Activate".

Begin the drawing with two geometry lines running horizontally and vertically through the center of the 
page (Geometry>Line>Horizontal and Geometry>Line>Vertical). Direct input of coordinates using F8 
(ENTER) ensures exact positioning. For the horizontal line enter the y-coordinate (_pb+_pt)/2 , for 
the vertical line enter the x-coordinate (_pl+_pr)/2 .

The centers of the inner housing circles are 66.5 mm apart. To determine the center positions precisely, 
add parallel geometry lines 33.25 mm above and below the horizontal geometry line. The intersections of 
these lines with the vertical geometry line mark the center points of the circles. After choosing the pen 
"0.25 mm\\Dash-Dot Line Narrow", activate "Geometry" snapping mode to snap to the intersections and 
draw two circles (Draw>Circle>Standard) with a diameter of 56 mm (Figure 1).



Figure 1

Two geometry circles with a radius of 75 mm to mark the outline around the circles are now added using 
Geometry>Circle>Concentric and entering the new radius using F8 (ENTER) (Figure 2).



Figure 2

To work out the center position of the third circle which makes up part of the outline, add a parallel 
geometry line 42.0 mm to the left of the existing vertical geometry line (Geometry>Line>Parallel, 
numerical). A further horizontal geometry line 42.5 mm below the horizontal geometry line running 
through the center of the upper circle determines the center of the third circle part. Draw a geometry circle
with a radius of 16 mm from this point. In addition you can add two parallel geometry lines 6.5 mm on 
either side of the vertical center geometry line. These two lines mark the distance between the inner and 
outer walls (Figure 3).



Figure 3

The geometry circles are joined using arcs with a radius of 6 mm. Add these arcs to the drawing using 
Draw>Circular Arc>Radius - Object - Object. After entering the radius identify the relevant geometry 
circles and click on the "Forwards" key in the "Choose object" window until the arc you want to add 
appears on screen, and then click on OK.

Repeat the process until all the arcs have been added (Figure 4).



Figure 4

Add the missing circular arcs between the 6 mm connecting arcs using the command Draw>Circular 
Arc>On Circle. To do this, identify each of the relevant geometry circles in turn and snap to the ends of 
the existing circular arcs using "Corner/ Endpoint" snapping mode (Figure 5).



Figure 5

In order to be able to construct the correct transition from the inner to the outer wall, draw a geometry 
circle concentric with the upper large geometry circle with a radius of 52 mm and a geometry circle 
concentric with the lower large geometry circle with a radius of 50 mm (Geometry>Circle>Concentric). 
This value is calculated from the radii of the outer wall outline (56 mm / 58 mm) minus the thickness of 
the wall (6 mm) (see Figure 6).



Figure 6

The missing circular arcs with a 4 mm radius are added next, again using Draw>Circular Arc>Radius -
Object - Object. The circular arcs are tangential to the just-constructed geometry circles and the vertical 
geometry lines 6.5 mm from the central vertical geometry line. Activate "Corner/ Endpoint" snapping 
mode and join the 4 mm arcs to the relevant 6 mm arcs using Draw>Line>Standard). (Figure 7).



Figure 7

This completes the inner housing wall. You can now remove all of the existing geometry to make it easier 
to get an overview of the drawing. To do this, choose Shape>Delete Objects and click onto all geometry 
lines.

To keep a reference for the rest of the drawing, use the command Geometry>Line>Center Cross and click
on circle A to draw its center cross. In addition, draw geometry circles with a radii of 58 mm concentric to
circle A, 56 mm concentric to circle B and 40 mm concentric to circle C (see Figure 8).



Figure 8

It is not neccesary to display the inner housing wall while constructing the outer outline. Choose 
Configure>Layers>Edit and in the dialog which appears choose the "Inner housing wall" layer. 
Deactivate the "Display" check box in the "Selected Layer" section. Make "Outer housing wall" the active
layer and click on "Activate". The inner housing wall is now hidden from view and will not get in the way
when working on the outer housing wall.

Lines must now be added to the geometry. Using Geometry>Line>Parallel, numerical draw geometry 
lines 67 mm to the right of the central vertical line, 53mm above and 116 mm below the central horizontal
geometry line (Figure 9).



Figure 9

To describe the outer outlines of the wall, the roundings at the top and bottom on the right edge are 
missing. Their radii and positions tangential to the geometry lines are known. You can add the circle using
Geometry>Circle>Radius - Object - Object and a radius of 2.5 mm. This is shown in Figure 10.



Figure 10

The outer outline consists of circular arcs and tangents to the arcs. Next, because the start and end points 
of the circular arcs are not known, draw the tangents to the geometry circles which describe the outline. 
Choose Draw>Tangent>Object - Object and identify, one after another, both points on two circles which 
the line should be tangent to. You can see from Figure 11 which geometry circles the lines should be 
tangential to.



Figure 11

It is a good idea to work with various zoom levels to place the tangent points accurately on the last drawn 
small circle and to view things clearly. Use Configuration>Zoom>Section.

Using Draw>Circular Arc>On Circle with "Corner/ Endpoint" snapping mode active to draw the missing 
circular arcs and create a closed outline (Figure 12).



Figure 12

To construct a housing wall with a thickness of 6 mm, choose Draw>Line>Equidistant. Enter 6 mm in the
dialog which appears. To draw an equidistant line, first of all identify the reference element and then 
specify which side of the reference element the equidistant line should run. Do this for all of the elements 
which require it. The exceptions are the two circular arcs on the right and the right-hand vertical line 
between them. Draw an equidistant line 9 mm to the inside of this line (Figure 13).



Figure 13

In the area where the 9 mm equidistant line and the 6 mm equidistant line intersect, both lines have to be 
rounded with a 4 mm radius. This is done using Trim>Round Edge, Outer Arc>Object - Object. Enter 4 
mm into the dialog and identify both lines at the end to be rounded (Figure 14).



Figure 14

This completes drawing of the gear housing wall. In order to hatch it, choose the 
Draw>Hatching>Generated Surface command.

Now, identify all the visible objects. Either press F10 (SHIFT+Q) or press the SHIFT key and drag a 
rectangle round all the objects. For each contour to be recognized, a reference point has to be placed near 
to it. So place one reference point close inside the inner housing wall, and one point close outside the 
outer housing wall. Press the right mouse button to terminate the point entry. The area between the two 
housing walls will now be hatched (see figure 15).

Figure 15

The geometry can now be turned off using the button in the Panel (Figure 16). Then, use the 
Configuration>Layer>Edit command to display the layer "Inner housing wall" again.



Figure 16

Remember that the hatching is on a layer of its own and can be turned on and off. Layer settings for 
specified objects are set using Configuration>Layers>Defaults.

Next, draw the circles' symmetry lines with Draw>Line>Center Cross using the pen "0.25 mm\\Dash-Dot 
Line Narrow". Extend the larger circle's vertical symmetry line outside the outer housing wall using 
Trim>Trim Object>Length / Radius to Point.

Dimension centering should be turned off for all the following dimensions by clearing the appropriate 
check box in the dialog. In addition, reduce the text size for all dimensions to 3.5 mm with the 
Lettering>Dimension Parameters command. Dimensions are applied to the radii using 
Lettering>Dimension>Radius, Object. The diameters can be measured by choosing 
Lettering>Dimension>Diameter, Objects. The distances between the walls are best measured using 
Lettering>Dimension>Distance, Object - Object. The remaining lengths can be measured using 
Lettering>Dimension>Length, Points.



Figure 17

Choose Shape>Edit Text to remove unwanted diameter symbols and then add a drawing frame and text 
fields. Finally, save the drawing with File>Save Drawing as.



Tables and Parts Lists (Examples)

This chapter uses some commands that are only available in Level 2 of CAD/DRAW 4!

Aim
This example should explain how to generate parts lists and tables. You will get to know the various 
methods of making multiple copies and how to align text into predetermined areas. In addition it goes into
the process of exporting graphics for use in other applications (e.g. word processors). The example is the 
table which you already know from the introduction to the chapter on the pen and layer concept. 
Generating parts lists and text boxes for technical drawings follows a similar procedure.

Settings
TUTORIAL.T4G

Basics
The procedure for producing a table is determined by the type of table. Parts lists for technical drawings 
make use of a predetermined grid, tables in technical documentation usually cannot exceed certain 
dimensions. This example has an inner frame measurement of 140 × 70 mm. This is a precondition.

Begin with the pen "0.25 mm\Solid Line Narrow" and use Draw>Polygon>Rectangle to draw a rectangle 
140×70 mm. Use Trim>Trim Object>Resolve Completely to split the rectangle into individual lines.

Choose Geometry>Multiple Copy>Object. This makes it possible to copy a specified object to the outline
of another object. In the example, seven equally spaced horizontal lines are to be added. This means that 
the top horizontal line is to be copied seven times in the vertical distance. Identify the top line, and with 
"Corner/Endpoint" snapping mode on, place a reference point at the start point of the top horizontal line. 
Identify the vertical line as a reference object. Choose "linear" in the dialog and enter seven as the value. 
Close the dialog with OK. Seven horizontal fields should appear on the page (Figure 1).



Figure 1

The process used means that there are eight copies of the original object in the specified area. This also 
means that copies are placed at the start and end points of the specified reference object. However, there 
are already lines there (the top and bottom edges of the rectangle). To avoid being continually asked by 
the program which line you wish to use (e.g. during identification), remove one of the lines from the top 
and bottom using Shape>Delete Objects or by using the DEL key. Identify one of the top lines and answer
"OK" to the program's "Choose Objects" question. Repeat the process for the bottom line.

To generate the vertical lines on the right hand side, use Geometry>Multiple Copy>Length. Identify the 
right hand line and specify the corner point A (with "Corner/Endpoint" snapping mode active) as the 
reference point. The start point also lies at point A and the end point is the mid-point M (specified with 
"Midpoint" snapping mode active) of the upper horizontal line. Five sections should be created (six lines);
once again, there are two lines on top of each other at the left, one of which has to be deleted (Figure 2).

Figure 2

To shorten the column dividing lines in the top section to 2mm, add a geometry line whose intersections 
with the vertical lines will be used later as trim points. Choose Geometry>Geometry Line>Parallel, 
numerical and enter a distance of 2 mm. Identify the second horizontal line from the top and place the 
geometry line above it (Figure 3).



Figure 3

Use Trim>Trim Object>Length / Radius to Object you can shorten the middle four vertical lines to the 
geometry line. Identify the upper part of each line and then click on the geometry line. Repeat this for 
each of the four lines (Figure 4).

Figure 4

The basic structure of the table has now been set out. Next, put a line of text into the upper left cell. Use 
Lettering>Text>Standard and enter Line Type . The text should be left-aligned and 5 mm high (in the 
example, the Arial TrueType font is used). Close the dialog by clicking on OK and position the text the 
desired distance from the left edge. To align the text vertically, choose Shape>Align Objects>Centered, 
Frame Vvertical. Identify the text and (with "Corner/ Endpoint" and "Midpoint" snapping modes active) 
click on the top right and bottom right corners of the box surrounding the text (see Figure 5)

Figure 5



This text can be used as a template and be copied into all the relevant cells using Geometry>Multiple 
Copy>Gradual Identify the existing piece of text and choose the upper left corner of the field as the 
reference point. The start point also lies at the top left corner (A) and the finishing point lies at the field's 
lower right corner (B). Choose six linear steps and click on OK (Figure 6).

Figure 6

Use Lettering>Text>Standard and enter Line Width / Line Groups . Set the text alignment to 
"Centered", the text size to 4 mm and the text style to bold italic. Position the text in the space meant for it
and use Shape>Align Objects>Centered, Frame Both to center it in the frame. Use the intersection of the 
geometry line with the right hand vertical line as the lower right corner of the frame (Figure 7).

Figure 7

Use the same method to place the figure 0, centered in the top left number field. It should be 5 mm 
high and use the standard font. Copy this text into all the other number fields. Choose Geometry>Multiple
Copy>Array and identify the text object. The reference point is the upper left of the field (A). This point 
is also the first corner point. Corner point 2 is at the top left corner of the bottom left number field (B) and
corner point 3 at the upper left corner point of the bottom right number field (C). In the first dialog box 
enter 5 for the number of linear segments (six copies) and in the second dialog box enter 4 (five 
copies) for the number of horizontal segments. See Figure 8.



Figure 8

You can now use Shape>Edit Text to alter each piece of text to the correct value. Identify and alter each 
piece of text separately (see Figure 9).

Figure 9

Alter the properties of the Line Types piece of text. Do this with Shape>Edit Properties. After 
identifying the text, click on the "Special" button and alter the text style to "Bold Italic".

Finally, the tables appearance is improved by adding differing line widths and shading. Choose the pen 
"0.5 mm\Solid Line Wide" and (with "Corner/Endpoint" snapping mode active) draw the outer frame. 
Change back to the pen "0.25 mm\Solid Line Narrow" and use Draw>Line>Equidistant to draw a thin 
line 0.7 mm outside the last-drawn rectangle. To do this, identify the rectangle and click outside the 
surface. The corners should not be rounded (Figure 10).



Figure 10

The dividing line in the middle of the table can be given the properties of the pen "0.5 mm\Solid Line 
Wide" using Shape>Edit Properties. To do this the relevant entry from the list in the dialog is chosen and 
enable the "Fix" check box.

To draw attention to the 0.5 and 0.7 line groups, a gray grid is placed behind them. Choose the pen "0.5 
mm\Solid Line Wide" and draw a rectangle around the area to be shaded gray. Use the snapping function. 
Using Shape>Edit Properties , set the rectangle's filling style to "Filling & Outline", click on the "Color" 
field and choose gray (or any other color) for the background (Figure 11).

Figure 11

Because the rectangle was drawn last, it is on top of the other elements in the table. Use Shape>Change 
Order>To Back to place the rectangle in the background (Figure 12).

Figure 12



Export
Clipboard
There are various ways to make this graphic available for use in other programs. The usual way is to copy
it to Windows' Clipboard using Edit>Copy. It can now be pasted into any program which uses vector 
graphics.

EMF
You can copy objects to an enhanced metafile using File>Export>Enhanced Metafile. The current output 
properties are used. Most 32bit Windows applications which work with vector data can read EMFs.

To import an enhanced metafile into TommySoftware® CAD/DRAW 4, use the File>Import>Enhanced 
Metafile command.

If you have the choice to use either EMF or WMF, you should always prefer EMF files. They use 32bit 
coordinates, complex surface descriptions including Bézier curves, nested outlines and further high-level 
structures that result in high-resolution, device-independent data.

WMF
Alternatively, you can copy objects to a windows metafile using File>Export>Windows Metafile. The 
current output properties are used. Most 16bit Windows applications which work with vector data can 
read WMFs.

To import a windows metafile into TommySoftware® CAD/DRAW 4, use the File>Import>Windows 
Metafile command.

BMP
A further possibility is export to a Windows Bitmap file. These can be read by many programs which 
handle bitmap graphics. Choose File>Export>Windows Bitmap to export to a bitmap.

To import a windows bitmap into TommySoftware® CAD/DRAW 4, use the File>Import>Windows 
Bitmap command.

Settings
It is also possible to export parts of the drawing such as geometry lines, markings and grids. This can be 
useful, for example, in technical documentation. Many of the graphics used in this tutorial were one with 
TommySoftware® CAD/DRAW 4 and exported using suitable extra output parameters (markings and 
geometry lines). The output parameters are set in a dialog called with Configuration>Settings>Output. 
These settings can also be altered at the last minute by clicking on the "Options" button in the File>Print 
Drawing dialog.

In order to export parts of the current drawings to a TVG 4.2 file, choose the File>Export>TVG 4.2 
command.



If the program to which you wish to export TommySoftware® CAD/DRAW 4 graphics cannot handle 
TrueType fonts, enable the "TrueType As Surface" check box in the output parameters dialog. This setting
converts all characters into surfaces before output to the Clipboard, a WMF or the printer. This procedure 
can also be useful if TrueType fonts do not print correctly on your printer.



Diagrams (Examples)

This chapter uses some commands that are only available in Level 2 of CAD/DRAW 4!

Aim
TommySoftware® CAD/DRAW 4 makes it possible to draw complicated technical drawings for various 
technical purposes. In this example a double logarithmic resistance diagram showing Ohmic conductor 
resistance against conductor width

Settings
TUTORIAL.T4G, with the page set to landscape orientation.

Set the boundaries of the diagram. Using the pen "0.25 mm\Solid Line Narrow" or a self-defined thin pen,
draw the left and bottom boundaries of the diagram with Draw>Line>Horizontal and Draw>Line>Vertical
Leave enough space to add further text. You can resize the diagram at a later stage, but getting it right 
now will save work later. So that the diagram looks tidy, use "Corner/Endpoint" snapping mode to make 
sure that the vertical lines do not extend below the intersections (Figure 1).



Figure 1

The diagram is divided into four decades in the X-direction and 3 decades in the Y-direction. To draw the 
grid lines use the command Geometry>Multiple Copy>Length. Begin with the X-divisions. Identify the 
vertical line and (with "Intersection" snapping mode on) choose the intersection of both lines as the 
reference point. This is also the start point; the end point is the end of the horizontal line. Click on the 
Logarithmic radio button and enter 4 as the number of decades. Close the dialog by clicking on OK 
(Figure 2).



Figure 2

Proceed in a similar way to make the multiple copy of the vertical line. The start point is the same, but the
end point is the top of the vertical line and there are three decades (Figure 3).

Figure 3



You have now created a piece of logarithmic graph paper as the grid for the diagram.
Next, label the axes at the appropriate points with appropriate values. In the example, 4 mm high text is 
used. The X axis labelling can also be placed rotated by 90°. To do this enter the rotation angle in the 
Dimension>Text>Standard To align the labelling with a line, draw a vertical and a horizontal geometry 
line parallel to the relevant axis. You can place the label text on these lines making use of "Edge" 
snapping mode (Figure 4)

Figure 4

Now you can begin to draw the graph lines using the pen "0.5 mm\Solid Line Wide". This can be done 
with the help of bases and Bézier curves or Splines, or, as here, with a straight line through defined points.
Begin with the line (20 µm) through the points (9000/0.1) and (30/30). These points are already present as
intersections in the diagram. Turn "Intersection" snapping mode on and click on the relevant intersections.
To extend the line to the edge of the grid, use Trim>Trim Object>Length / Radius to Object, identify the 
upper part of the last-drawn line and click on the uppermost horizontal line as the reference line (Figure 
5).



Figure 5

Because all the graphs in the example or parallel lines, the line has to be duplicated running through the 
new reference points. Activate the duplicate function by pressing F7 and use Shape>Move 
Object>Perpendicular. to move the line. Identify the graph line and choose any vertical gridline as the 
reference line. The point chosen as the reference point is very important. A point should be chosen which 
brings the new graph line onto an intersection or a previously placed mark. This point now has to be 
moved to the new target position. For the first copy, choose the lower corner point and move it to 
(5000/0.1). Do the same for the other graph lines. You can take suitable reference points from the example
diagram (Figure 6).



Figure 6

So that the lines can be labelled with text running at the correct angle, the line angle has to be measured. 
Use Lettering>Dimension>Angle, Line - Line to measure the angle between the graph line and the 
horizontal grid lines. The parameters are not important because after noting the angle, the dimension is 
immediately removed by using Edit>Undo (BACKSPACE).

Enter the angle, preceded by a minus sign (-) (the text is rotated clockwise, mathematically negative) into 
the Lettering>Text>Standard dialog. In the example 3 mm high text is used. Place the text up against the 
graph line in the diagram. It is not necessary to go through the whole process for each new piece of text - 
it is enough to restart the command using SHIFT+ESC (N) and enter a new text (Figure 7).



Figure 7

The texts are directly above the lines and are difficult to read. To make them easier to read, place an 
erasing surface behind each piece of text to hide the grid lines. Use Draw>Polygon>Arbitrary to draw a 
surface covering a piece of text, set its filling mode to "Eraser" using Shape>Edit Properties and then use 
Shape>Change Order>To Front to bring the text to the front (Figure 8).



Figure 8

Finally, label the axes. Enter the text using Lettering>Text>Standard The Omega symbol is from a 
different font and is added separately. The arrows are straight dimension lines. To align them correctly 
place a geometry line (Geometry>Line>Horizontal) in the middle of the X-axis label. Using 
Lettering>Dimension Line>Straight with "Edge" snapping mode active, the dimension arrow can be 
aligned exactly horizontally. Proceed in a similar way for the vertical dimension arrow (Figure 9).



Figure 9

Alternative Forms of Diagrams
Linear or logarithmic diagrams can easily be created in the same way. During the multiple copy process, a
linear division is used for one or both axes.

Non-linear graph lines, of which only coordinate points are known, are approximated using splines or 
Bézier curves. This is explained in the following example (the Trouser Leg).



Trouser Leg (Examples)

This chapter uses some commands that are only available in Level 2 of CAD/DRAW 4!

Aim
This example demonstrates the use of spline curves in technical drawing and further dimension 
measurement techniques.

Settings
TUTORIAL.T4G, with the page set to landscape orientation.

Basics
The most important parts of the design are three curves which determine the outline. The curves have 
defined fixed points and during drawing a spline curve is passed through those points. As the drawing is 
virtually symmetrical, it is only necessary at this time to draw the left hand side, which can then be 
mirrored with the duplicate function active.
Begin the drawing by using Configuration>Coordinate System>Set Origin to place the drawing origin in 



the page's bottom left corner. This is not absolutely necessary but it makes the representation easier, as 
some of the points would either lie on the edge of the page or would have to have an offset value added to
their coordinates.

The points are set using markings, Choose Geometry>Markings, press F8 and enter the first point's 
coordinates. Use the values from the drawing at the beginning of this chapter. A reference point 
measurement is chosen, and the values are relative to the origin. For your convenience, so-called 
redundant measurements, calculated from existing measurements, are given in brackets. If possible, the 
use of these measurements in drawings should be avoided.

For the lower curve, the following points have to be entered using markings: (39; 0) (60; 0.8) (75; 3.0) 
(105;3.7). See Figure 1.

Figure 1

Proceed in the same way for all the points in the left half. To specify the position of the upper curve, 
use the formula y=120-a where a is the distance to the highest point of the curve (Figure 2).



Figure 2

The outline of the left side of the trouser leg consists of three curves: AB, BC, DE and a line CD. Note 
that the curves AB and BC are two separate objects. They must not be drawn as a single object as they 
form a corner at point B. Corners cannot be defined within a spline curve. The command must be ended at
point B and then restarted at the same point.
Choose the pen "0.5 mm\Solid Line Wide" to draw the rest of the objects. Activate "Markings" snapping 
mode and join the points with a spline curve (Draw>Spline). o finish drawing a spline, click the right 
mouse button. Join points C and D using Draw>Line>Standard with "Markings" snapping mode active 
(Figure 3).



Figure 3

Next, the symmetry axis is drawn between points A and E. You can now mirror and duplicate the outline 
using Shape>Reflect Objects>Line Hold the CTRL key down whilst identifying the four objects. Release 
it and then press it again. This activates the duplicate function. Now identify the symmetry axis to reflect 
and duplicate all the selected objects (Figure 4).

Figure 4

UTo draw the tongue on the right hand side, move the existing line by 6 mm parallel to itself with the 
duplicate function active. Choose Shape>Move Objects>Perpendicular and identify the line on the right. 
Choose the line itself as the reference line. Press F7 to turn on the duplicate function and then press F8 
(ENTER) and enter 6 mm. Notice the arrow direction in the status line. This shows the positive 
measurement direction - for example, if the arrow is pointing down and to the left, then you have to enter 
-6 mm as the distance to avoid copying in the negative coordinate direction.
Choose the pen "0.5 mm\Solid Line Wide" and join the endpoints of both lines using 
Draw>Line>Standard. To indicate a fold line, use Shape>Edit Properties to change the inner line from 
pen "0.5 mm\Solid Line Wide" to pen "0.25 mm\Solid Line Narrow". This completes the outline of the 
trouser leg (Figure 5).



Figure 5

It is best to add the dimensions to the left hand side first. Begin by using Lettering>Dimension Parameters
to set the text size to 3 mm so that the dimension text will fit within the shorter measurements. To help 
with aligning the dimension texts use Geometry>Line>Vertical at the X-position -13 mm. In addition use 
Geometry>Line>Horizontal to draw horizontal geometry lines throw all the markings on the left hand 
spline curves. The dimension lines are placed using the intersections of these geometry lines as reference 
points (Figure 6).

Figure 6

Start by measuring the distances between the curve points of the left-hand curve. Because there are no 
objects to use as references, use Lettering>Dimension>Distance, Point.

In the dimension parameter dialog (accessible with SHIFT+ESC), specify an open circle as the start 
symbol for the dimension line, but leave the end symbol as a filled arrow. In addition, click on the icon 



for vertical dimension line alignment and enter 5 mm as the distance. Deactivate the "Center" and "Close"
check boxes (to enable hand-centering of the dimension text) and activate the "Rotate" check box.

The start point for each of the vertical dimensions is point B. This is also the reference point for the 
distance. The end point is the corresponding marking on the curve. Pull all the dimension lines out by the 
same distance so that they form a continuous line. This should be to the left of point C so that the upper 
part of the outline is not cut. To position the dimension text, snap to the to the geometry intersection 
which lies at the same height as the marking at the end point of the extension line. Enter the dimension 
text's rotation angle (0°) into the status line after pressing F8 (ENTER).

The last dimension, 120 mm, is an exception. The end point for this measurement is placed on the 
reflection of point D (F), to create a longer extension line. It is not neccesary to draw a further line later 
on (Figure 7)

Figure 7

Proceed in a similar manner for the horizontal sections on the top and bottom of the outline. Use point C 
as the starting point (see Figure 8).



Figure 8

Next, the missing overall dimensions are added. When drawing the vertical height measurement of 122 
mm it is important to place the starting point on point B as the intersections of extension lines for 
measurements drawn later will be placed there. Remember to set the start symbol back to an arrow in the 
dimension parameters dialog. The check box "Close" can be reactivated, and the check box for rotating 
the dimension text can be deactivated.

To have the right separation distances available for all the dimensions, reduce the dimension line distance 
to 5 mm in the dialog. Use Lettering>Dimension>Distance, Object·Object. to apply the 6 mm dimension 
to the tongue. In this case, it is not necessary to use snapping as you only have to identify the objects 
(Figure 9).



Figure 9

To add the distances from the curve points to an imaginary rectangle enclosing the outline, use the 
command Lettering>Dimension>Length, Point. again. Choose the filled arrowhead as both starting and 
end points of the dimension line and deactivate the "Center" check box. Turn snapping on, and click on 
the marking and the corresponding intersection of the section measurement with the adjacent extension 
line (see Figure 10).



Figure 10

Finally, use Shape>Edit Properties to alter the general parameters for the redundant measurements to no 
decimal places. This can be carried out in one operation, by clicking on each of the affected 
measurements in turn holding down the CTRL key. In the Edit properties dialog, click on the "Special" 
button to get the general properties. Each individually identified dimension can then be placed in brackets
to mark it as a geometry dimension. Do this by using Shape>Edit Text. Use Lettering>Text>Standard to 
place the text t=1 (a note about the thickness of the metal to use) in the middle of the right hand side. 
(Figure 11).



Figure 11

Lastly the drawing can be centered on the page by choosing Shape>Align Objects>Centered, Page Both 
and pressing F10, then it can be saved using File>Save Drawing as.



Libraries (Examples)
Concepts
Groups
In drawings, the same elements are often used repeatedly. The element can be either a single object or 
several objects placed together in a group. The easiest way of managing objects which belong together in 
a drawing is to use a group. Groups are made by using Shape>Group>Group Objects. Objects which have
been included in a group can only be altered or moved together. The advantage is that you do not have to 
identify each individual object before altering the group's properties. The program recognizes 
automatically that it is dealing with a group and reacts accordingly.

If you make a number of objects into a group, TommySoftware® CAD/DRAW 4 puts the objects into 
memory and substitutes a reference to these objects in the drawing. A reference like this is known as an 
instance. The original objects no longer exist on the page. Only an image of them is present. The 
advantage of this procedure becomes clear when you make a copy of the objects. Each further copy of the
group consists of an instance, that is, a reference to the group held in memory. Each instance requires only
the same small amount of memory. This makes it possible to manage several large (memory intensive) 
groups in a drawing using the least possible amount of memory. Instances are saved, along with the 
group's object information, in drawing files.

When groups are manipulated, this structure is usually not disturbed. Like other objects, each instance has
its own set of properties. When an instance is manipulated, only the on-screen representation, not the 
original objects, are changed. TommySoftware® CAD/DRAW 4 only applies the alterations to the original
objects when an instance is resolved and the original objects are pasted into its place from memory. If the 
group contains further instances, the changed properties are applied to the relevant instances and fixed 
into the resolved objects.

Example
Use a simple example to see how a group behaves. Draw an element made up of three basic objects and 
make them into a group using Shape>Group>Group Objects. To create a group, identify each object to be 
included in the group in turn. Manipulate this group with commands from the Shape menu. The title bar 
of the Shape>Edit Properties dialog shows information about the type of object. You can use 
Shape>Group>Ungroup to break the group up into its individual objects.

Internal Blocks
It is awkward to manage large numbers of repetitive groups, and so TommySoftware® CAD/DRAW 4 
makes it possible to name groups and include them in a list. Each named group can be called as an 
independent element from the list. These named groups are called internal blocks. Internal blocks are read
into a library using Library>Block>Create (Insertion Point) or Library>Block>Create (Frame) As for the 
command Shape>Group>Group Objects the relevant objects must be identified. To read in an internal 
block, the library "* Internal Blocks" must be chosen in the dialog, that is, the path must begin with "* 
Internal Blocks". This is the description for a block which will be saved with the drawing. You can enter a
name with up to 64 characters for the block in the "Block:" field. You can then specify using a check box 
whether the objects which make up the newly saved internal block should remain in the drawing or be 
replaced by an instance.

To place a block from the list into the drawing, choose Library>Block>Insert and choose an internal block
from the list. Make sure that the "* Internal Blocks" library has been selected. Before clicking on OK, you



can enter a custom rotation angle and/or scaling factor for the block. The chosen block now "hangs" at the
cursor. If the block was read in via frame, then the insertion point will always be in one of the insertion 
frame's corners. During insertion, the insertion point always lies at the center of the cursor. You should 
bear this in mind while reading in the block and use a distinctive point as the insertion point. Use 
snapping when you insert blocks into the drawing.

External Blocks
If a block is stored in an external library, a separate file, then it is known as an external block. Before an 
external block can be created, a library must be opened or created using Library>Libraries. and clicking 
on either "New" or "Open" and then entering either a new or existing library name. Click on OK to either 
open the existing library or create a new library. You can now read a new external block into the library in
much the same way as reading in an internal block. You can make use of the commands 
Library>Block>Create (Insertion Point) or Library>Block>Create (Frame). You must set the correct path 
to the library in the dialog which appears.

To more clearly arrange internal and external blocks, a hierarchical folder structure, similar to that used 
for file directories, can be created. To create a folder, the folder name must be entered at the same time as 
the block name. It is separated from the block name with a backslash ("\"). If the folder does not exist, it 
is created automatically. Moving around the folder structure is carried out in the same way as moving 
about the directory structure. Change to a folder by double-clicking on its name; leave it by double-
clicking on "[..]". The available folders are shown in the dialog between the library descriptions and the 
block names.

Groups, internal and external blocks

It is only possible to change the properties of instances in a drawing. The original, in memory, remains 
unchanged. TommySoftware® CAD/DRAW 4 does however make it possible to change the properties of 
blocks directly. Using Library>Block>Edit you can alter the original (not an instance of the block). Such 
an alteration will be visible immediately, because any instances in the drawing are based on the altered 
original in memory. If individual instances in a drawing may not change you can either convert external to



internal blocks (Library>Convert External Blocks to Internal), resolve blocks (Library>Resolve 
Instances) or make a copy of the relevant library block (Library>Block>Edit, subdialog "Copy").

Comparison
Groups are the simplest, but most inconvenient way to manage objects which belong together. They are 
used to protect objects temporarily from alteration or to create simple structures during drawing.

Internal blocks should be used in drawings when it is important to work independently of libraries. 
Whenever external blocks are used in drawings, it is important to make the corresponding libraries 
available as well. Internal blocks make it easy to manage elements and prevent the drawing from being 
changed by accidentally altering a library. Basically, an internal block should be used if an object is only 
used in one drawing.

External blocks should be used whenever the same block is used in several drawings. Using external 
blocks ensures consistency, because if an external block is altered then that change is automatically 
applied to all Instances of that external block in all drawings. After altering an external block, drawings 
only have to be printed again to get the correct, altered drawings. In addition, the use of external blocks 
referring to libraries reduces the size of the saved drawing file.

The external blocks in all drawings change, without any form of checking, control, or notification, if the 
libraries which contain the block definitions are altered. Because of this, the use of external blocks should
be thought about carefully!



Circuit Diagram (Examples)

Aim
This example illustrates the practical use of libraries in a drawing. You will practise creating a new 
library, merging and altering elements in the library. In addition, methods for working with simple 
background grids are introduced. This example is drawn from the world of electronics, but the same 
techniques can be used in similar ways in other specialisms and areas of work.

Settings
TUTORIAL.T4G

Basics
A circuit diagram consists largely of repetitive elements (yellow parts of figure 1) which, when they have 
been draw once, can be used again in other drawings.



Figure 1

In order to make these elements as widely usable as possible, they should be drawn in accordance with 
recognized standards. For example, there is a DIN Standard for the background grid behind the drawing 
elements. In this example the size of the background grid should be set to M=2 mm. To create universally 
usable elements on this grid junctions should always lie at 2M (i.e. 4 mm).

Preparations
Before beginning drawing, turn on the display grid using the F3 key or the button in the Panel. Select 4 
mm grid size so that only every other grid point, that is the points to which the crosshair snaps are 
displayed. The grid size can be set in the dialog called with Coordinates>Coordinate Systems>Edit - 
"Display Grid" or by clicking the right mouse button on the corresponding button in the Panel. Choosing 
2M as the grid spacing has the advantage that screen redraws are quicker and you can also see exactly 
which points the connections between components lie on. In addition, turn on the position grid by 
pressing F4 or clicking on the button in the Panel. The position grid size should be set to 2 mm. The 
position grid settings can be specified in a dialog called with Configuration>Coordinate Systems>Edit - 
"Position Grid" or by clicking the right mouse button on the corresponding button in the Panel.

Begin by creating a new library. Choose Library>Libraries to call a dialog. Click on the "New" button and
enter ELECTRO.T4L into the "Library Name" field. After closing the dialog by clicking on "OK", enter
Electronics Library as a description for the library. This title will be used later in the list of 
libraries. Next, find the new library in the list of libraries. It will still be prefixed by an 'N' to remind you 
that this is a new library whose contents are determined after leaving the dialog. Leave the dialog by 
clicking on "OK". The new library has been created, but it is still empty.

Choose a suitable zoom level (one which gives a good view of each component) to work on the 
components. For example, try a zoom factor of 4.



Our simple circuit diagram contains four basic library elements: resistors, capacitors, transistors and 
contact points. Start with the simplest component.

Resistor

Figure 2

The resistor consists of a rectangle and two short lines. Take the dimensions from the diagram. You do not
need to use snapping as the position grid is active. The crosshair can only be moved in 2 mm increments. 
Every grid point displayed on screen is 4 mm from the next grid point because the display grid is set to 4 
mm.

Once you have drawn the resistor with three objects, read it in to the library using 
Library>Block>Generate (Insertion Point). To do this, identify all the objects and click on the contact 
point at E as the insertion point. Choose the new "Electronics Library" in the Path section of the dialog 
which appears. Enter Resistor as the component name and leave the dialog by clicking on "OK". You
have now added the first component to the library.

Capacitor

Figure 3

The capacitor is also relatively easily drawn from three lines and a rectangle. Be careful to ensure that all 
the connectors lie on grid points. Use the same procedure to read the capacitor into the library as for the 
resistor. The name of that block should be Capacitor .

Transistor

Figure 4



Begin by drawing the connections. The line with the arrow is drawn using Lettering>Dimension 
Line>Straight Make sure that the "Not rotated" setting in the dimension line parameter dialog (accessible 
via SHIFT+SCR) is enabled or the arrow will be pointing in the wrong direction. Finally, draw the 
surrounding circle using Draw>Circle>Standard. The center of the circle is the display grid point marked 
with an M (Figure 4). 

The radius of the circle is the point of the arrow just drawn. Choose connector E as the insertion point and
read the component into the Library using the same procedure as for the resistor. To avoid confusion with 
other transistors which might be added to the Library later, give this transistor the name NPN-
Transistor .

Contact points

Figure 5

The contact point is a circle with a 0.5 mm radius circle. Draw it on top of a grid point using 
Draw>Circle>Standard and use the direct entry method (F8) to enter the radius 0.5 mm. Read this object 
into the Library with the name Open Contact Point .

Next alter the circle's properties with Shape>Edit Properties to solid fill (Figure 6).

Figure 6

Save this object as Closed Contact Point . The insertion point should be in the center of the circle.

Circuit
All the required components are now stored in the library. Before you draw further, make sure the blocks 
are saved. Do this with Library>Libraries. Select the file to be saved, "Electronics Library", from the 
dialog and click on the "Save" button. An 'S' now appears in front of the library name. Leave the dialog 
by clicking on OK. The library is saved when leaving the dialog.

Use the command File>New Drawing to start drawing the circuit diagram. Activate the position and 
display grids with the same values used when drawing the components (2 mm position grid and 4 mm 
display grid). Use Configuration>Page Formats to choose A4 landscape format and choose a zoom factor 
of 2 with Configuration>Zoom>Factor.

Even though not strictly needed as the diagram is not very complicated, the use of the block list window 
is introduced at this point. Choose Configuration>Window>Block List on/off. The block list window will 
now appear on the right of your screen. Frequently used blocks can be stored here. They can be activated 



by clicking on them in the block list window in a similar way to choosing a command from the toolbox 
window.

To place a block into the block list window, click the right mouse button on one of the buttons in the 
block list window. This calls a dialog which is the same as the one called with Library>Block>Insert. 
Choose the library which you wish to use. Then click on the block name and choose a rotation angle and 
enlargement factor. As the components in the library just created are already the right size, only the 
rotation angle needs altering. Begin by choosing the transistor; leave the dialog by clicking on OK 
without altering the rotation angle. The NPN transistor should now appear in one of the block list window
buttons. Proceed in the same way for the other components. Add the resistor again, but rotated by 90°. If 
the blocks' rotation angles are not displayed, choose Configuration>Settings>Block List and enable the 
"Rotation" checkbox.

Start by positioning the more complicated blocks. In this diagram this means the transistors. First, 
position transistor V1. Click on the transistor icon in the block list window. The component "hangs" from 
the crosshair. The insertion point lies at the center of the crosshair. If the grid is active, this guarantees that
the block will be inserted with its end on a grid point. Insert the element by clicking the left mouse button.

Next choose the vertical version of the resistor and place it twice on the page aligned with the upper and 
lower connectors of the transistor (resistors R1 and R5). You only need to position them approximately as 
they can easily be moved using Shape>Move Objects>Standard If the grid is on, the movement is 
restricted so that the components always jump to the grid points and there is no need to use the snapping 



functions. Use the same method to position capacitor C1.

Insert transistor V2 at its approximate position. The insertion point should be a little higher than the upper
connector of V1 and enough space should be left between the two transistors for R4 and C3. The resistors 
R2 and R6 are positioned in a similar way to R1 and R5. Next, place the horizontal resistors R3 and R4 
into the drawing. A suitable block is already available in the block list window.

The capacitors C3 and C2 are rotated by 90° and 180° respectively and therefore are not in the block list 
window. Choose Library>Block>Insert and choose the "Electronic Library" as the path. Click on the 
"Capacitor" block and choose 90° as the rotation angle. Close the dialog with "OK". The block is now 
available. Insert it into the diagram and carry out the same procedure for the second capacitor (180° 
rotation) (Figure 7).

Figure 7

Use Draw>Line>Polyline to draw connecting lines with 90° corners, for example between V1 and R3, on 
the grid. The other, short, connection lines can be added using Draw>Line>Standard.



Figure 8

Remember that a polyline is actually a curve on which some operations can not be carried out. To 
manipulate the polyline, it must first be converted to a series of individual lines with Trim>Trim 
Objects>Resolve Completely, which can then be manipulated easily.

Next, place the block "Closed contact point" on the junctions. Place an "Open contact point" on the free 
ends of the capacitors C1 and C2. Finally, use Lettering>Text>Standard. to label the components. In the 
example, 4 mm high Times New Roman is used.

To enter a special character into the text, you can either hold down the ALT key and type the ANSI code 
for the relevant character on the numeric keypad and then release the ALT key, or start the Windows 
Character Map accessory, choose the character required, copy it to the Clipboard and then paste it into the
TommySoftware® CAD/DRAW 4 text field by using CTRL+V (or SHIFT+INS). This is how you add the 
µ symbol to the labels for the capacitors.

Figure 9

To conclude this example, the working of libraries with respect to changes is explained again. Before 
carrying out the further exercises, save the drawing with the name CIRCUIT.T4G using File>Save 
Drawing as.

Updating
One advantage when libraries are used is the easy maintenance of drawings. If the block is changed after 



the creation of a library, then all occurrences of that block in all drawings are updated as well. Test this by
using the library which you created for the circuit diagram. Make a copy of the library with the name 
Electronics Library Copy by using the command Library>Libraries - "Copy". Later you will be 
able to copy the new library back to the original, undoing the changes. Before starting the exercises, start 
a new drawing by choosing File>New Drawing.

There are two main methods of placing new or altered blocks which will replace blocks in existing 
drawings into a library.

Method 1
The altered block is saved under a new, different name. This method makes it possible to only alter those 
blocks which you really want to change. It is the safest method and should therefore be used most of the 
time. Its disadvantage is that a relatively high amount of effort is required, because each block must be 
altered in each drawing.

In the example, if the standard for depicting a transistor changes, it would be necessary to make a 
corresponding alteration in the library. The new representation is different from the old one in that the 
circle around the block is no longer used. To change the representation, place the "Transistor" block on 
the page and use Library>Resolve Instances to break it into objects. Remove the circle using 
Shape>Delete Objects (or the DELETE key). Read the altered block back into the "Electronic Library" 
using Library>Block>Create (Insertion Point). If you did not have the grid active, activate 
"Corner/Endpoint" snapping mode to put the insertion point at the left-hand connector. Give the block the 
name NPN Transistor (New) to distinguish it from the old one. Save the altered version of the 
library by choosing Library>Libraries and choosing "Save" in the dialog.

Load your drawing CIRCUIT.T4G . Using the command Library>Replace Block you can specify which 
block in the loaded drawing should be replaced by the new block. Choose the blocks by clicking on 
"Choose" and then selecting the blocks in the library dialog. All blocks with the old name will 
automatically be replaced by the new block. This operation can be restricted to permanently selected 
objects by activating the "Selection Only" check box.

Method 2
The second method is to directly overwrite the old block with the new one. This has the risk that blocks 
which you did not mean to alter will be altered. One advantage is that when the drawing is opened, it will 
already have been altered automatically.

The procedure is similar to the first method, except that the altered block is saved under the same name as
the old one; it is not saved separately. After loading the drawing, you will see that the substitution has 
already been made.

Transforming
Remove the "Electronics Library" from memory by choosing Library>Libraries and clicking on the 
"Remove" button then leaving the dialog by clicking on "OK". The block name and library name for each 
block will be displayed on screen because the program cannot call on the library any more. Without the 
library, the circuit diagram cannot be displayed or printed properly, because the drawing only holds 
references to the original blocks in the library. After loading the library (with Library>Libraries - "Open")
the blocks will be displayed again.



To make the drawing library-independent, either transform all the external to internal blocks with the 
command Library>Transform External Block to Internal or making the blocks into objects again using 
Library>Resolve Instances.

Transforming external blocks to internal has the advantage that all the instances are kept intact and the 
blocks are saved with the drawing. Change the external blocks to internal and remove the library from 
memory. As expected, the drawing retains its original appearance. After saving the drawing, the blocks 
are contained, independent of the library, in the drawing.

Attributes
Each block can have unique properties (also known as Attributes). The block properties can be the same 
for all components or be different from component to component. TommySoftware® CAD/DRAW 4 
allows attributes to be attached to blocks and then output later in a parts list. Attributes which do not 
change for the same block are called Global Attributes. Individual properties, specified when a block is 
inserted into a drawing, are known as Local Attributes. Attributes should be set when a block is read in to 
a library.



Dimetric and Isometric Drawing (Examples)

Aim
This example shows the main methods of working with dimetric and isometric views. You will learn the 
basic method for creating a 3-D view, using the example of a cube. We only explain dimetric projection 
because isometric projection uses the same methods.

Settings
TUTORIAL.T4G

To see the three additional views as well as the standard view, choose Configuration>Settings>Screen and
choose the last-but-one icon from the top row. This gives you an extra three small windows arranged 
vertically at the right of the program window in which you can see different views. Click on "OK" to 
confirm your choice and close the dialog.

Basics
Dimetric and isometric projections are used to draw 3-D views of objects. TommySoftware® 
CAD/DRAW 4 makes it possible to see each of the three views in the overview. This means that you can 
draw each side view in the same way as the two dimensional examples. However, circles appear as 
ellipses in isometric and dimetric drawing and must be drawn using Draw>Ellipse>Standard In a similar 
way, squares should be drawn as polygons using Draw>Polygon>Parallelogram The reason for this is that



the program only makes the current view available as an aid to drawing. You are actually drawing in the 
dimetric view and have to use the commands which draw objects correctly in this view.

The Cube
Coordinate Systems
Each drawing window uses a different coordinate system. These systems must first be set up. Do this by 
choosing Configuration>Coordinate Systems>Edit. Click on "New" to set up a new coordinate system. 
Give the first system the number 2 and the description Dimetric 1, left view . Create a further 
two systems, numbered 3 and 4, named Dimetric 1, right view and Dimetric 1, plan 
view . Next you have to apply the coordinate systems to the different windows. Click on a name and then
on the "View" button. You can then choose the corresponding dimetric representation. The names of the 
coordinate systems are the same as the representations.

Figure 1

After you have have generated all three new coordinate systems, choose coordinate system 1, "Drawing &
Dimension" and leave the dialog. In order to apply the newly generated coordinate systems to the small 
windows, click on the upper left corner of the relevant window. The window number is displayed there in 
[square brackets]. The ruler display shows which window is active. After activating one of the small 
windows, you can apply a coordinate system to it by choosing Configuration>Coordinate System>Edit 
and setting the coordinate system to the desired one in the dialog. Activate the dimetric views for 
windows 2-4.

Windows
Working with windows is relatively easy. You can easily choose the window you wish to work in. You can



tell which window is active because the crosshair appears completely in that window, whereas in the 
others just a small cross showing its position appears. Even at high resolution, windows 2-4 do not offer 
much drawing space and you can swap the contents of a small window into the main drawing window to 
make life easier. Do this by holding down the SHIFT key and pressing the number of the window whose 
contents you want to see in the main window. For example, SHIFT+3 will swap the contents of window 3
into the main window. The main window has the number 1. This makes it easy to put the view of your 
choice into the main window (Figure 2).



Figure 2

It is a good idea to always put the dimetric window back in its original place. This gauruntees a better 
overview of the views. Otherwise, the left and right views (especially when working with isometric 



projection) can easily be swapped accidentally. If you have the left dimetric view in the main window and
wish to change this with the right dimetric view, firstly put the left dimetric view back in window 2 (the 
uppermost of the three small windows) using SHIFT+2 and then bring the right dimetric view into the 
main window with SHIFT+3. 

Grid
To make constructing the cube easier, turn on the position grid (size 5 mm) and the display grid (size 10 
mm) for all three dimetric views. This is done most easily with the buttons in the panel. Activate the grids 
by left-clicking on the button and specify the grid size in the dialog called by right-clicking on the button.

The Drawing
Construct the dimetric left view in the main window first (check that you have the correct coordinate 
system in the dialog called by right-clicking on the ruler or choosing Configuration>Coordinate 
Systems>Edit.) Begin by drawing a square with sides 100 mm (that is, 10 grid points) long, using the pen 
"0.5 mm\Solid Line Wide". Use Draw>Polygon>Parallelogram. to do this. To have the same origin for the
grid in the other views, set the zero-point to the upper right corner of the square. Do this with 
Configuration>Coordinate System>Set Origin. Place a marking (U) on this point using 
Geometry>Markings (Figure 3).



Figure 3

Put the dimetric left view back into window 2 and put the dimetric right view into the main window 
(Figure 4).



Figure 4

This is the right side of the cube. One of the horizontal sides has already been drawn. Draw another 
square using Draw>Polygon>Parallelogram, placing the first two points on the previously-drawn vertical 
line and dragging the square's outline right by 100 mm (10 grid points) (Figure 5).



Figure 5

Keep an eye on what is going on in the window with the standard view. A parallelogram is drawn here 
showing one of the cube's other surfaces.



Put the right view back into window 3 and put the plan view from window 4 into the main window. 
Again, draw a square on the grid with sides of 100 mm length on the grid. Once again, begin at the 
marked zero-point and use the vertical line as a guide. You can now see a complete cube in the standard 
view (Figure 6).

Figure 6



You can use the plan view in the main window for the next step. Choose Draw>Ellipse>Distorted. Click 
at the mid-point of the last-drawn square to specify the center of the ellipse (1). Set the other two points 
by clicking on the mid-point of the upper horizontal line (2) and the right hand vertical lline (3) 
respectively. In the plan view, a circle will now have been drawn (Figure 7). 

Figure 7

Choose the pen "0.25 mm\\Dash-Dot Line Narrow" and use Draw>Line>Standard to draw horizontal and 
vertical symmetry lines extending 5 mm beyond the square's edges (that is, one position grid point or half 
a display point from the edge). Join the corners with diagonals.
Your page should now look like figure 8:



Figure 8

You can now change the view displayed in the main window again and use the same procedure to draw 
the circle and symmetry lines in the other views.

The finished drawing will now look (depending where you started) something like this:



Figure 9

Finally, center the object using Shape>Align Objects>Centered, Page Both) and the F10 key, then save it 
using File>Save Drawing as (Figure 10).



Figure 10

The creation of a drawing in isometric representation or in type 2 dimetric representation (view from the 
right side) works similar. The only difference is in the views that are chosen for the windows' coordinate 
systems.

If your screen resolution is high enough, you should use the advantages of multiple window display for 
all types of drawings. Each window can display another detail of the drawing, allowing fast copy-and-
paste operations. For activation of any desired window, simply press SHIFT+(Window Number) on your 
keyboard.

In case you want to save the multiple window environment for isometric representation or other purposes,
create a special INF file using Configuration>Settings>Save as.




