
TommySoftware® CAD/DRAW 4

This text contains some very important information on TommySoftware® CAD/DRAW 4! You should 
take the time and read this text carefully before continuing, even if you might already be familiar with this
application. It can spare you a lot of problems later on!

Update from Previous Versions
For information on how to update from previous unlocked versions of CAD/DRAW 4, please click here!

If you do not follow these instructions, it is possible that the new version will not be unlocked and you 
cannot use the new version of CAD/DRAW 4 and its plug-ins!

Creating and Modifying Objects
CAD/DRAW 4 lets you quickly and easily create technical illustrations and drawings that require a high 
degree of accuracy. To ensure this accuracy, it has a different approach to creating and modifying objects 
than artistically oriented graphic applications.

For more information on this subject, please click here!

New Functions and Modifications
For a list of changes and extensions since the initial release of CAD/DRAW 4, please click here!

Questions & Answers
For a list of frequently asked questions on CAD/DRAW 4 and their answers, please click here!

Annual Art Contest
TommySoftware® organizes an annual art contest for all registered users of CAD/DRAW 4. For further 
information and the entry form, please click here!

TommySoftware® Inhouse Training
If you want to get information about our trainings which will enable you to use this application fast and 
effective, please click here!

Upgrade from other TommySoftware® Applications
For information on how to convert files from other TommySoftware® applications like CAD/DRAW 2 
and CAD/DRAW 3, please click here!
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Update from Previous Versions
This version of CAD/DRAW 4 contains a lot of improvements and enhancements towards previous 
versions. Despite all these changes that increase the power of this application significantly, we decided to 
offer an update to this version for free.

We hope that, keeping that in mind, you will understand that due to these changes, the update process is 
not as easy as it might be. Please read and follow the following update instructions carefully.

Instructions for all CAD/DRAW 4 users having Versions 4.20 or higher
If you have already installed an unlocked version 4.20 of CAD/DRAW 4, you can simply install the new 
version over the old version. The unlock data will be maintained so that the new version will be unlocked,
too.

Instructions for all CAD/DRAW 4 users having Versions before 4.20
If you update from a prior unlocked version of CAD/DRAW 4, you may have to preserve the 
RELEASE4.SYS file. Please call the Help > About CAD/DRAW 4 command of the old version and take 
a look at the unlock code or serial number displayed there. If you should already have removed the old 
version from your system, please re-install it into a different directory and check the unlock code or serial 
number of that old version.

The unlock code or serial number begins with either 04000 or 04200 (the product code) and a hyphen, 
followed by the version number of the program that generated the code. The version number should either
be 04.01, 04.10 or 04.11.

If the version number is 04.01 , you have a version that requires the file RELEASE4.SYS . This file 
contains your registration information and is required to unlock the new version. If you have installed the 
new version over the old version, the RELEASE4.SYS file should still be available, and CAD/DRAW 4 
will automatically be unlocked. If you have installed the new version into a different directory, you will 
have to manually copy that RELEASE4.SYS file from the old version's directory into the new version's 
directory.

If the version number is 04.10 or 04.11, you have a version that does no longer require the file 
RELEASE4.SYS , even though it might still exist. In this case, please write down the user name and 
unlock code displayed in the Help > About CAD/DRAW 4 dialog for later reference. Please note that the 
user name is case-sensitive and that all punctuation and spaces must be preserved precisely! After you 
have installed version 4.20 or higher, call the command Help > Order & Unlock there and enter the 
previously noted user name and unlock code there to unlock the new version.

Additional Instructions for all CAD/DRAW 4 Level 2 users having Versions before 4.20
If you update from a prior unlocked version of CAD/DRAW 4 Level 2, you will notice that your old plug-
ins will no longer work. This was necessary due to a change in the plug-in interface.

As a registered user of CAD/DRAW 4 Level 2, you will receive a new set of plug-ins and the required 
unlock codes for free in either of the following ways:

- If you have an e-mail address, please send an e-mail to L2update@tommysoftware.com that 
states your email address and both the user name and the unlock code of your CAD/DRAW 4 Level 2. 
You will find this information in the Help > About CAD/DRAW 4 dialog.
We will then send you the plug-ins themselves and a list of unlock codes for these plug-ins via e-mail. 
Please note that for this service, you have to be able to decode e-mails in MIME format! This service 
usually takes only one or two days.



- If you do not have an email-address, please send us a fax to either ++1 415 566 6589 (USA) or 
+49 30 621 4064 (Germany), or a letter to one of our adresses. In any case, state your complete mail 
address and both the user name and the unlock code of your CAD/DRAW 4 Level 2. You will find this 
information in the Help > About CAD/DRAW 4 dialog.
We will then send you a disk containing the plug-ins and list of unlock codes for these plug-ins via 
mail. The mail delivery may take up to four weeks!

Please note that this service is only available for registered users of CAD/DRAW 4 Level 2!



Creating and Modifying Objects
Most manipulations in CAD/DRAW are based on exact numerical parameters. However, the command 
Shape > Modify Objects offers a direct method to modify objects using the mouse. In cooperation with 
the Property Window, this command also allows the direct editing of object properties like color and line 
type.

Another difference involves the way you select objects. When you use an artistically oriented graphic 
application to illustrate something that does not require precision, you usually first select the objects, 
choose the command, and then execute the command to modify the objects. With TommySoftware® 
CAD/DRAW 4, however, you select the command first and then the objects to be modified before the 
command is executed.

This different approach to creating and modifying objects in CAD/DRAW has several advantages. One is 
that you can use a single command selection to manipulate several objects after another without having to
repeat the command selection sequence. For example, by selecting Move Objects you could move 
several objects or object groups without having to select another command, such as Select Objects, or the
same command repeatedly until you have moved all objects. This can save time when you are making 
several changes.

Another advantage is that selecting the objects after the command makes it possible for the application to 
know at any time what command to apply to the selected objects. It can therefore inform you immediately
when you cannot perform that command on the object.

If you have ever worked with computer-aided design (CAD) software, you will be familiar with this 
approach and you will be able to start work immediately. If you have never used a CAD application, this 
approach will be unfamiliar, but as long as you remember to select the command first and then the objects
to be modified, you will soon see how easy it is to work quickly and still produce precise technical 
illustrations and graphics.

To select an object, click on it with the mouse. You can select multiple objects by keeping the CTRL key 
pressed while clicking on several objects, or you can select whole object areas by keeping the SHIFT key 
pressed and entering the corner points of the area. After once selecting a group of objects, you can select 
the objects again to further modify them by pressing the F11 key.

For further information on selecting objects, see the description of any command that requires an object 
selection. At any time, you can display the currently active command's description by pressing the F1 key.
More information about basic methods of TommySoftware® CAD/DRAW 4 can be found in the 
electronic tutorial that is part of each full version of TommySoftware® CAD/DRAW 4.



New Functions and Modifications
This text lists all major modifications that have been done since the initial release of TommySoftware® 
CAD/DRAW 4. Small bug fixes or performance increases happen all the time and will not explicitly be 
noted.

These modifications have mostly not been applied to the tutorial and tour, so some methods described in 
the tutorial and tour might be out-of-date as a faster or easier way exists now. Anyway, they will still be 
possible.

Version 4.25 (Release July 1997)
- Using the command Draw > Line > Equidistant, Bézier curves are now always resolved into polylines 

to achieve a higher accuracy.

Version 4.24 (Release June 1997)
- When creating a block that was named equal to a block in another library, the old block was no longer 

accessible until restart. Same applied when renaming a complete library by editing its title.

- The user-dependent local settings have not been saved correctly in the registry on most Windows 95 
systems.

- The dialog windows for text creation and editing have been enlarged to minimize the need for scrolling.

- The calculation of intersection points, especially during snap, has been modified to increase 
performance.

- When trying to snap intersection points of a curve or surface with itself, some points were not found if 
the curve was rather complex.

- The calculation of the surrounding rectangle of curves and surfaces was incorrect and did normally 
include the page center into the surrounding rectangle.

- The command Draw > Line > Equidistant has been recoded, it now works more reliable. If the 
equidistant calculation locates a problem, a message appears, but the equidistant curve is created 
anyway.

- It has not been possible to active the option "Encrypt with password" at Configuration > Optionen > 
File Options on Windows 95 systems.

Version 4.23 (Release April 1997)
- The print dialog now allows scaling factors from 1e-10 to 1e10. In addition, some minor problems with 

the print preview have been fixed.

- When importing T4G drawings with the option "Merge", errors occured when importing both objects 
and object-related elements like layers, pens and line types.

- The DXF import now allows to choose whether or not to convert DOS characters into ANSI characters. 
This option should only be used when importing DXF drawings generated by non-windows 
applications.

- 256 color bitmaps that had less than 256 colors in their palette were not stored correctly as "embedded" 
bitmaps.

Version 4.22 (Release March 1997)



- All external import and export filters now own a joint set of standard paths which can be edited with 
Configuration > Options > Paths and used inside the file selection dialog.

- The DXF import filter now import 3D-polylines, ignoring the Z coordinate.

- The screen display of "curved" elements like circles, ellipses and curves is now completely done using 
Bézier curves, even when zooming in extremely, improving the redraw speed and accurary 
significantly.

- The commands Draw>Ellipse>Rotated and Geometry>Ellipse>Rotated did not work properly.

- The calculation of intersection points with and distances to Bézier curves is now done using a new 
numeric approximation that provides a much higher accuracy while requiring less calculation time.

- The calculation of a tangent to two circles was inaccurate if both circles had nearly the same radius.

- The DXF import had problems with the positioning of texts that were not left-justified. In addition, the 
slope angle of texts was accidentially ignored.

- The WMF import now handles the META_EXTTEXTOUT element in addition to META_TEXTOUT.

- Using the WMF import, the object could accidentially be mirrored, resulting in inverted circle and 
ellipse arcs.

Version 4.21 (Release January 1997)
- The new command File > Import > Embed Bitmaps allows to convert bitmap objects from "external 

reference" to "embedded bitmap", which means that the bitmap data is stored within the drawing.

- CAD/DRAW 4 now uses the new file selection dialog of Windows 95 and Windows NT 4.0 which 
allows to rename files and create new directories. All our extensions to that dialog, like e.g. the favorite 
paths, are still available.

- Using Windows NT 4.0, copying to the clipboard and exporting to EMF did not work properly for 
circles, ellipses and some texts. It seems like a operation system's function works differently in 
Windows NT 4.0 compared to Windows NT 3.51, even though no change is documented.

- The automatic conversion of circular arcs to bezier curves during modification failed in some cases.

- The calculation of an equidistant has been optimized, an error in euqidistant calculation of curves has 
been removed.

- Nested external blocks that resided completely in the same library were not handled and resolved 
correctly.

- The export to WMF, EMF and BMP always used all objects, not only those the user selected.

- The export of texts in WMF files was faulty, characters were oversized by factor 20.

- When creating a new pen or layer whose name ends with a backslash (Ansi 92), the application 
stopped.

Version 4.20 (Release December 1996)
- The drawing frames and title blocks that were previously contained in seven drawing files titled 
6771_?_?.T4G have now been moved into a new library titled FORMS.T4L which is located in the 
standard library directory.

- Import filters can now hook onto the File > Open command. As a result, it is now possible to open non-
TVG drawings by draging & droping them onto CAD/DRAW 4, by calling CAD/DRAW 4 with their 



file name in the command line, and of course by opening them with the standard File > Open command.

- Export filters can now hook onto the File > Save As command. As a result, it is now possible to save 
non-TVG drawings by means of the standard File > Save As command. Simply select the desired file 
type of the corresponding list.

- The DXF import filter has been enhanced, it now offers several new options that allow to specify which
line patterns and layers from the DXF file shall be maintained. This helps to avoid a large increase in 
the number of line patterns and/or layers when importing multiple DXF files into one drawing.

- The DXF export filter has been enhanced, it now offers several new options: The "Output for NC" 
option results in an output consisting of single lines, circles and circular arcs instead of complex 
polylines. This speeds up many NC systems. The "Resolve Texts..." option allows to select whether to 
resolve texts into outlines or export plain text. And it is now possible to specify the number of fractional
digits to be used for floating point numbers.

- The standard property set of all objects has been enhanced by the "Line End Style" and "Line Join 
Mode" setting. This allows to set these values indepently for each object. As a matter of fact, these new 
properties are also available for pens and layers.

- The display mode "Dimetric View 2, right side" was faulty, it overscaled the image by factor 2.

- Dimension parameters have been enhanced: The dimension text can now be placed inside the 
dimension line, which will be interrupted in that case. The distance between the extension lines and the 
referenced object can now be specified separately for each dimension.

- Most standard commands from the Draw and Geometry menus have been revised. They do now work 
"as intended" in non-standard views like the Isometric and Dimetric view. Vertical is vertical, horizontal
is horizontal, perpendicular is perpendicular, rectangles are rectangular, rectangular ellipses are 
rectangular ellipses. Only the circle commands have not been modified, you still have to use ellipses 
instead of circles in non-standard views.

- The two not yet assigned function keys have now been assigned: Shift+F7 calls the hatching type list, 
Shift+F8 calls the line type list.

- Drawings can now be saved in compressed mode, using standard ZIP compression. This option can be 
toggled on and off using different file type settings in the File > Save Drawing as dialog. Compressed 
drawings can be secured using a password that is edited and activated using the Configuration > 
Options > File Options command.

- In the dialog of the Configuration > Settings > Screen command, the new "Object Numbers" option was
added. If it is activated, a running numer will be displayed for each (partially) visible object according 
to the display order. For surfaces and curves, an additional index number displays the order of the 
subcontours.

- Massive extensions to the Toso Interface, its version number was set to 4.2.

- Bitmaps can now be embedded into the drawing. After executing the File > Import > Windows Bitmap 
(*.BMP) command, a dialog appears which offers the choice between creating a reference to the bitmap
file or embedding the bitmap data into the drawing.

Version 4.11 (Release August 1996)
- In the dialog of the Configuration > Settings > Screen command, the new "Orientation Arrows" option 

was added. If it is activated, the starting point and orientation of each sensible object will be displayed 
by means of a small arrow.

- The new command Trimming > Trim Object > Invert Orientation allows to invert the orientation of an 



object. This is important when passing data to NC machines or when using the data in applications 
where the orientation is of importance.

- The new command Trimming > Trim Surface > Set Starting Point allows to set the starting point of a 
surface's outline to a specific location. This is important when passing data to NC machines or when 
using the data in applications where the display sequence is of importance.

- When printing monochrome bitmaps, colors transmitted by the bitmap object were not reproduced 
correctly even tough the display was correct.

- The command Configuration > Layer Management > Concentrate on now automatically activates the 
first of the layers selected for concentration.

- The command Draw > Line > Equidistant has been completely recoded. It now works with much more 
complicated outlines and avoids "loops" when creating rounded corners.

- The settings the ortho-mode have not been saved correctly. This could possibly lead to errors when 
editing those settings.

- The command Configuration > Trim Surface > Split Into Outlines now marks all created outlines as 
"Previous Selection".

- Using Windows NT 4.0, the title bar of the popup menu was accidentially overwritten.

Version 4.10 (Release May 1996)
- The names of American paper sizes were wrong.

- Direct modification of objects inside the view window did not work.

- When inserting a new object into a layer that is currently invisible, a dialog window allows to cancel 
this process.

- The command Library > Block > Edit offers a new button which allows the creation of a new, empty 
folder that can subsequently be filled with blocks.

- Support of Digitizers was added to Level 2. CAD/DRAW 4 Level 2 supports all Digitizers that work 
with the WINTAB driver from LCS/Telegraphics (e.g. CalComp, Wacom, etc.).

- From this version on, a comprehensive tutorial is included which shows some complete examples 
illustrating basic and advanced procedures for the application. In the TUTORIAL directory, you will 
find some files containing the resulting drawings of those examples.

- The reference was completely revised, now offering more general information than before. Also, the 
description of basic procedures (like selection) is no longer repeated on and on. Instead, there is a link 
to a chapter describing that procedure in depth.

- The display of the used memory amount in the status window now includes the memory used for all 
currently used bitmaps.

- Copying geometry objects only to the clipboard was only possible if the geometry output was activated 
at Configuration > Settings > Output.

- When exporting WMF files, erasing surfaces where always exported with a black filling.

- The display of erasing surfaces in Windows 95 was faulty, especially the display color could not be 
modified.

- The import of WMF files was sometimes cancelled without further explanation. This was due to objects
that were neither framed nor filled.



- The Configuration > Layers > Edit dialog was revised, now featuring icons before each entry which 
show the status of the five available layer options. In addition, two new buttons offer the following 
functionality: "Selection" offers a selection filter, allowing to select or deselect layers based on 
keywords contained in their names. "Settings" offers the possibility to export and import the complete 
layer settings, by means of which its easily possible to work with several oftenly-used layer states.

- The Library > Convert External Blocks command did not work correctly with nested blocks.

Version 4.02 (Release December 1995)
- When creating blocks with the "Resolve Properties" option set, only pen properties were resolved, but 

not layer properties.

- The commands Draw > Curve and Draw > Surface did not work properly when using circular arcs or 
relative values during input.

- The commands Draw > Line > Parallel, Draw > Line > Parallel, numerical and Draw > Line > Angle to 
Line have been modified. They do now expect an additional point, allowing to first place the reference 
straight line and the entering the line's start-point.

- When creating a group out of other groups or blocks, the time require to finish that task was extremely 
long in some cases due to a possible internal feedback.

- The command Trimming > Trim Edge was extended to be able to trim any combination of line and 
circular arc.

- The import of very large WMF or EMF files sometimes caused an stack overflow due to incorrect 
parameter handling.

- Most setting and option dialogues have been combined into property sheets. This allows fast access to 
all settings and options without chosing several commands. The previous key codes are still valid, 
anyway.

- When importing WMF-files, in some rotated texts characters were rotated in the wrong direction.

- When entering the section at File > Export > Bitmap, Section (*.BMP) beginning with the lower right 
corner, the section was calculated wrong.

Version 4.01 (Release September 1995)
- Some Windows 95 printer drivers refused to print. This was caused by a difference in printer handling 

between Windows NT and Windows 95.

Version 4.00 (Release September 1995)
- Initial release.



Questions & Answers
When I copy some objects to the Clipboard in TommySoftware® CAD/DRAW 4, an area of about 5 

millimeters around the objects remains blank. Why?

When copying to the clipboard (or when printing), the application uses the output parameters that can
be edited using the command Configure>Settings>Output. One of those settings determines whether the 
output area in calculated based on the objects' surrounding frame or based on the current page size. By 
default, the setting "Object Frame" is active, with an additional blank frame of 5 millimeters. To remove 
this blank frame, set the value of "Offset" to 0 millimeters.
As you will see, the output settings can influence all output results (printer, plotter, clipboard and bitmap) 
in several ways.

How can I prepare TommySoftware® CAD/DRAW 4 for using either Imperial or Metric units?

The English release of TommySoftware® CAD/DRAW 4 should by default use Imperial units. Here is
a description of how to setup TommySoftware® CAD/DRAW 4 for the use of Imperial or Metric units:
Create a new drawing. Select the command Configure>Coordinate Systems>Edit, select the coordinate 
system "Drawing & Dimensioning" and press the "Units" button. In the appearing dialog, select either 
"Inch" (for Imperial) or "Millimeter" (for Metric) in the "Length:" list. This sets the unit used for all scale-
dependent lengths like coordinates, lengths, dimensions, etc. You may also select either "Inch" (for 
Imperial) or "Millimeter" (for Metric) in the "Line:" list. This sets the unit used for scale-independent 
measures like line widths, font sizes, etc. End this dialog by pressing "OK".
Now, press the "Numbers" button. In the appearing dialog, select an appropriate number display form in 
the "Length Display:" list. For Imperial units, this could by "Yard Foot Inch (Floating Point)", resulting in
outputs like 1yd 2' 3.5" , or "Yard Foot Inch (Fraction)", resulting in outputs like 1yd 2' 3 1/2"
. For Metric units, select "Standard (Floating Point)". End both dialogs by pressing "OK", then select the 
command Configure>Save Elements as Default to save these settings permanently.

Note: These settings are drawing-dependent, i.e. if you want to change the unit settings in an existing 
drawing, you have to load that drawing and perform the steps described above. Instead of selecting 
Configure>Save Elements as Default, simply save the modified drawing.

How does one create a drawing at an Imperial scale of, for example, 1/8"=1' or 1/4"= 1' ? I can figure 
out how to change from metric to Imperial coordinates, but can only find reduction factors geared to units
of 10.

You can easily enter such a scale by using the "Current Scale" edit fields at the command 
Configure>Coordinate Systems>Edit, button "View". In these fields, you can enter values that are 
combined with units, so you may e.g. enter (1/8)in in the first field and 1ft in the second field. 
This will result in the correct scale of 1=96.

When I export a drawing that has been created using CAD/DRAW 4 to the DXF file format (by 
means of the DXF export filter), all fillings get lost. How can I avoid that?

In the DXF file format, standard objects like circles or polygons cannot be filled. Due to this 
limitation, all CAD/DRAW 4 objects are converted to outlined objects.



If you want to export filled objects to other application, use the Clipboard or the WMF file format. 
Alternatively, you can also create a PostScript® file by using a PostScript printer driver and redirecting its 
output to a file.

CAD/DRAW 4 does not print TrueType fonts. What can I do?

Some printer drivers are not able to print TrueType fonts correctly in all situations. This problem is 
especially common with rotated text. In this case, enable the "TrueType as Surface" check box in the 
Configure>Settings>Output.
Most printer drivers also have a setting determining how TrueType fonts are handled. Usually, there is a 
"Print TrueType as Graphic" check box in the printer setup "Options…" dialog; try printing with the box 
enabled and disabled.

CAD/DRAW 4 sometimes displays the message "The operation is too complex or not enough system 
memory reserved". What's the reason for this message?

 Insufficient memory causes this message to appear. The system memory is used for temporary data 
during complex calculations (e.g. hatching, or generating surfaces.). If this message appears you should 
use the command Configure>Options>General to increase the amount of internal memory.



Annual Art Contest
TommySoftware® organizes an annual international art contest for all registered users of 
TommySoftware® CAD/DRAW 4. In order to participate, submit your best illustrations and graphics on a 
floppy disk along with this entry form (printed out, filled in and signed) to:

North America, Inc. Germany
1843 10th Avenue Selchower Straße 32
San Francisco, CA 94122 D-12049 Berlin
U. S. A. Germany

The illustrations and graphics must be created with TommySoftware® CAD/DRAW 4 and must be 
submitted as genuine T4G files. If special fonts have been used in a file, please submit that file in two 
versions with one version having all texts resolved (see command Lettering > Text > Resolve).

The winners will be chosen once a year and announced on May 1st. To be considered, entries must be 
received until March 31st of the current contest year. Awards will be paid cash, they will be: first place 
US$ 200, second place US$ 100, third place US$ 50, fourth and fifth place US$ 20. If we receive less 
than 10 entries within one year, the contest will be suspended for one year, all received entries will 
automatically participate in next year's contest.

The decisions of the judges are final. All entry materials (disks, paper, etc.) become the property of 
TommySoftware®. Of course you retain the copyright to your art work. Only registered users of 
TommySoftware® CAD/DRAW 4 may participate!

Name:

Address:

Phone:

Fax:

Email Address:

File Names:

These drawings are being submitted for the TommySoftware® CAD/DRAW 4 Annual Art Contest. I 
certify that these are original works and that I am the artist. I understand that all entry materials (disks, 
paper, etc.) become the property of TommySoftware® and cannot be returned.

As copyright owner of the art work, if I am a winner I grant TommySoftware® the non-exclusive right to 
make unlimited printed or electronic copies of the submitted drawings. I also permit TommySoftware® to 
use my name and likeness with copies of the drawings and in any publicity related to the contest.

Date: Signature:



Comments:



TommySoftware® Inhouse Training
TommySoftware® offers training courses on all TommySoftware® CAD and graphic software, whether for
beginners or advanced users. The TommySoftware® trainers that were involved in the applications' 
development will introduce you at your place (inhouse trainings for several employees of your company) 
to everything you need to know.

To enable you to get to know a powerful CAD package like TommySoftware® CAD/DRAW 4 in the most
effective and efficient way (whether you are a first time user of this package, have acquired an update or 
alternatively a power user familiar with it’s entirety), TommySoftware® offers you in-house training in 
connection with experienced software tutors. We enable you to learn your TommySoftware® product in 
the shortest possible time and support you in gaining an in-depth knowledge of how your ideas can be 
easily transferred into a technical drawing with the help of our CAD system.

Our specialists with their many years of training experience come to your workplace and train you on the 
computers you are familiar with. As well as a general introduction of the way your TommySoftware® 
product works we also include dealing with your own specific daily tasks    in the training. We aim to give
you solutions to your challenges not just convey the basics of the package. The transition between 
learning and production can be achieved without downtime because the participants can employ the skills 
they have learnt straight away.

Our tutors work directly with the TommySoftware® development department so you will obtain the most 
up to date information. Your suggestions are taken directly from the training to the development 
department to enable us to enhance our program development for the future.

The advantages of TommySoftware® training are obvious:
- The contents of the training are personally designed and adapted to the needs of your company. The 

resulting level of knowledge of the participants guarantees high effectivity/productivity
- Small training groups have extensive individual support
- Loss of productivity, overtime, out of house training difficulties on new equipment, travel and expense 

costs are eliminated
- Your CAD system will be optimally configured and set up as part of the training
- As a result the CAD system is operational immediately to meet the objectives and goals your company 

wants to achieve

We offer trainings for the following TommySoftware® products:
- CAD/DRAW 2
- CAD/DRAW 3
- CAD/DRAW 4 Level 1
- CAD/DRAW 4 Level 2

Training can be from 1 to 5 days depending on your requirements. Additional days can be requested to 
either refresh the employees or to give specific training in solving new difficulties. These training can 
either be in English or German, please specify which best meets your requirements when corresponding 
with our tutors.

The costs for our in-house seminars are independent of the number of participants, and the type of 
program you have, they are costed on a per day basis. We recommend a maximum of eight participants 
and to be most beneficial there should be no more than 2 persons per computer.

For further information on trainings and the current prices, please call our office in San Francisco, or visit 
the "Support" section of our WWW site at http://www.tommysoftware.com .



Upgrade from other TommySoftware® Applications
When upgrading from other TommySoftware® applications to CAD/DRAW 4, you will want to use your 
old drawings and libraries. In order to use those files, you will have to convert them using a single or 
multiple file conversion programs. The conversion programs usually ship with CAD/DRAW 4, they all 
have similar names of the form XXX_YYY.EXE , where XXX is the source file type extension and YYY 
is the destination file type extension. T3G_T4G.EXE e.g. will convert T3G files into T4G files.

If you have a large number of files to convert, copy the source files into a single empty directory and use 
the "Convert Directory" command in the conversion programs. The intermediate files possibly created 
during multiple conversion can be deleted after the conversion was been finished successfully.

If a required conversion program is not delivered with this application, you can download a complete set 
of conversion programs from out WWW site at http://www.tommysoftware.com or call one of 
our offices for a conversion program disk.

Upgrade from CAD/DRAW 1 or 2
If you have upgraded from CAD/DRAW 1 or 2, you will have drawing files with the *.MPG extension, 
and library files with the *.TVL extension.

For drawing files (MPG), the conversion sequence is MPG -> T2G, T2G -> T3G, T3G -> T4G.

For library files (TVL), the conversion sequence is TVL -> T2L, T2L -> T3L, T3L -> T4L.

Upgrade from CAD/DRAW Professional
If you have upgraded from CAD/DRAW Professional, you will have drawing files with the *.T2G 
extension and library files with the *.T2L extension.

For drawing files (T2G), the conversion sequence is T2G -> T3G, T3G -> T4G.

For library files (T2L), the conversion sequence is T2L -> T3L, T3L -> T4L.

Upgrade from CAD/DRAW 3 or Tek Illustrator
If you have upgraded from CAD/DRAW 3 or Tek Illustrator, you will have drawing files with the *.T2G 
extension and library files with the *.T3L extension.

For drawing files (T3G), the conversion sequence is T3G -> T4G.

For library files (T3L), the conversion sequence is T3L -> T4L.




