
active style
The style that is used when you draw an element or copy it. You can change the active style to one of the styles 
listed in the Style box on the ribbon bar.



angular dimension
A dimension that measures the sweep angle of an arc, the angle between an origin and a line, the angle between
two lines, or the angle among three key points.



annotation
Text, graphics, or symbols that give you more information about a drawing.

 
(A) Leader line
(B) Break line
(C) Terminator
(D) Annotation

aspect ratio
The ratio of width to height of geometry.



associative
A condition in which an element is related to another element.



associative dimension
A dimension that is updated when the measurement of the element it refers to changes.



associativity
The concept that embraces all techniques for capturing design intent, including variational design, parametric 
design, and feature-based modeling.



background sheet
A component of a drawing sheet. The background sheet is used for graphics that you want to display on more 
than one drawing, such as a border, title block, logo, or raster background picture (watermark). A background 
sheet can be displayed and printed along with any working sheet it is attached to.



balloon
A type of annotation that consists of a closed shape that contains text. A balloon defines individual parts in 
assemblies and    field notes on drawings.



baseline
1 The area between a line and text. 
2 The process that freezes a document from any further modification. When you baseline a document, you also 

freeze any documents that are linked to the baselined document.



callout
A type of annotation that consists of a text box with a leader.



center point
The middle of a circle or arc.



centerline
An annotation on a mechanical drawing that marks the center position of a hole or other feature on a part.



chained dimension group
A series of dimensions that are arranged in a straight line. A chained dimension group measures locations from 
element to element.



chamfer
A corner that has been cut at an angle.



closed curve
A curve whose end points meet. A closed curve encloses an area.



closed element
An element whose end points meet. A closed element encloses an area.



coincident relationship
A relationship that specifies that two points have the same location.



colinear relationship
A relationship that ensures that a set of identified points or lines lie in a straight line.



command
A tool designed to complete a single task, such as create an arc or a line.



compound document
A document that contains files with various formats. For example, a document composed of AutoCAD and 
MicroStation documents.



container
A document that contains documents created with other applications. Through OLE you can access the 
application that created the document and link and embed a document created by another application.



cross hatching
An annotation on a drawing that designates the fill area of a model; a fill.



coordinate dimension group
A group of dimensions that measure locations from a common origin.



curve
An element type that is not linear.



cusp node
A type of vertex on a curve. A curve with a cusp node bends sharply at the node. A handle can be attached to a 
cusp node for editing. 



design data
Real world objects that you draw in a computer drawing. Typically these items must be scaled in the drawing 
sheet.



diameter dimension
A dimension that measures the diameter of a circle or arc.



dimension
A control that assigns and maintains a dimensional value to an individual element or establishes a dimensional 
relationship among multiple elements. A label with text, lines, and arrows graphically represents a dimension.



dimension axis
An axis for dimension orientation that you define by selecting a line. You can place linear dimensions that run 
parallel or perpendicular to the axis. By default, dimensions are placed horizontally or vertically.



dimension group
A series of dimensions. You can place a chained dimension group, a coordinate dimension group, or a stacked 
dimension group.



dimensional value
The text that indicates the value of a dimensional measurement, such as distance, length, or angle.



display filter
A tool that allows you to display selected layers in a drawing.



document data
Annotations, such as dimensions, text boxes, callouts, balloons, and centerlines, that are used to describe 
design data.



drawing sheet
The area of the application window that you draw in. There are two types of drawing sheets: working sheets and 
background sheets. Both types of sheets display a border, called a sheet outline, that shows the size, orientation,
and printable region of the current sheet.



drawing sheet tab
Drawing sheet tabs are located at the bottom of the drawing sheets in your document. There is a drawing sheet 
tab for each drawing sheet.

The drawing sheet tabs allow you to change the active drawing sheet, create new drawing sheets, delete 
drawing sheets, and copy drawing sheets. 



drawing tool
A tool that helps in the process of creating, modifying, or manipulating elements. For example, PinPoint and 
SmartSketch.



drawing view
A 2-D representation of a 3-D part or assembly. You can manipulate drawing views to display the part or 
assembly on a drawing sheet at a specified scale and orientation.



driven dimension
A dimension with a value that depends on the value of other dimensions or elements.



driving dimension
A dimension with a value that controls the size, orientation, or location of an element.



edge point
A location on the boundary of an element. For example, edge points can be used to define the circumference of 
a circle.



element
A simple, selectable unit in a drawing. You can select geometric elements, dimensions, annotations, objects 
placed in the drawing through OLE, and so forth. The type of element that can be selected is determined by 
command context.



embed
A method for inserting information from a source document into the active document. Once embedded, the 
information becomes part of the active document; if changes are made to the source document, the updates are 
not reflected in the active document.



end point
The end of an element.



equation
The algebraic relationship between dimensions and/or numeric properties.



file locking
The ability to prevent updates to a document.



fill
A pattern or solid color placed inside a closed boundary.



free space
An area that is not on or inside an element or object on a drawing sheet.



FreeForm
A drawing tool that allows you to use the mouse to sketch curves. As you press and hold the mouse button and 
drag the pointer across the drawing sheet, a rough sketch of your design appears. When you release the mouse 
button, the software turns your sketch into smooth curves.



FreeSketch
A drawing tool that allows you to use the mouse to sketch lines, arcs, circles, and rectangles. As you press and 
hold the mouse button and drag the pointer across the drawing sheet, a rough sketch of your design appears. 
When you release the mouse button, the software recognizes the shapes in your sketch and turns them into a 
precise drawing.



from point
The starting point for an action. For example, when you rotate elements, the from point determines where you 
want the rotation to begin.



geometric element
A point, line, arc, circle, or other simple geometry unit.



group
A collection of objects that you can manipulate as a single item. 



handle
Solid or hollow squares that are displayed at significant positions on a geometric element when you select the 
element. You can manipulate an element with a handle.



help lines
The dashed coordinate axes displayed by PinPoint. The help lines extend from the target point to the current 
pointer location. They are dynamically updated as you move the cursor. You can turn the help line display on or 
off.



horizontal relationship
A relationship that specifies that the end points of a line, or two key points, are level with each other along the x 
axis.



image
A raster image, which can be a .TIFF, .GIF, .JFIF, .BMP, .COT, .CIT, or .RLE document.



intent zone
A quadrant divided into four pie-shaped wedges that determines the behavior of an element's relationship to 
either a circle or arc. Intent zones allow you to specify where you want to draw an element in relation to an arc or
circle. For example, as you draw an arc, you can change the arc's direction by moving the cursor to a different 
position within the intent zone. You can define the size of the intent zone by specifying the number of pixels in it.



key point
A recognizable point on an element. Key points include vertices, mid points, center points, and so forth.



layer
A logical grouping of elements or objects on a drawing sheet. You can have several layers in a drawing sheet.



linear dimension
A dimension that measures the linear distance between two or more elements, the length of a line, or the arc 
length of an arc.



link
The connection between an inserted image or object, known as the source document, and the active document. 
Changes made in the source document are reflected in the active document when the active document is 
updated.



locate zone
A circular area at the center of the crosshair cursor or at the end of the arrow cursor. The locate zone specifies 
how close the cursor must be to an element you want to recognize or select. You can define the size of the locate
zone with the SmartSketch command on the Tools menu.



lock
A relationship that makes the position of an element or key point, or the value of a driving dimension, stationary.



macro
A sequence of actions or commands that can be named and stored. When you run the macro, the software 
performs the actions or runs the commands. You can create the macros in Visual Basic or other OLE-aware 
programming applications. Some of the OLE-aware programming applications are VBA (inside of Excel), Visual 
C++ Delphi, Visual Basic, and so forth.



midpoint
The middle point of an element.



mirror axis
The line about which the selection set is mirrored. When you select the Mirror command, the software displays 
horizontal and vertical mirror axes that go through the center of the selection set. You can display other mirror 
axes by locating linear elements.



modification
The act of changing the size, position, or orientation of an element by modifying the element or its handles.



pointer
The screen device that you use to select elements, commands, and other items in the software.



nested symbol
A symbol that is placed into a document which is then placed as a symbol in another document. Symbols that are
public display across different documents. Symbols that are private only display in the first document.



node
A vertex on a curve. An exterior node has one handle, and an interior node has two handles. A curve can have 
one or more smooth, cusp, or symmetric nodes. The type of node a curve has affects how you modify the curve.



object
1 Information that can be linked or embedded into an OLE-compliant product.
2 A group of elements that represent a real-world object. An object can also be made up of a single element.



OLE
The way Microsoft uses the Common Object Modeler (COM).    It is a mechanism to make data work 
independently.



open curve
A curve whose end points do not meet.



open element
An element whose end points do not meet.



parallel relationship
A relationship that specifies that the orientation of one line is identical to that of another line.



perpendicular relationship
A relationship that specifies that the orientation of a line or end point of an arc is at a right angle to the orientation
of another line, arc, circle, or curve.



PickQuick
An automatic software tool that allows you to select an element when several elements overlap. When you place 
the pointer over a set of overlapping elements, three small circles appear at the bottom right of the cursor. When 
you click, a small toolbar with the number of selectable elements appears. You can move the pointer over the 
numbers; and, when the element that you want highlights, you can click on the corresponding number to select it.



PinPoint
A tool that allows you to place, move, and modify elements with precision, relative to a reference point.



precision input
The method of defining the position of a point in space by using precise coordinates or by using a value to 
describe the point’s position from the coordinates of another point.



primary axis
The axis that defines the rotation angle of the ellipse. Zero degrees is horizontal to the x axis; the angle 
increases in the counterclockwise direction. The primary axis is defined first and can be shorter than the 
secondary axis.



property
A unique characteristic of an element, object, symbol, or document. You can display document properties in the 
Windows Explorer or by clicking Properties on the File menu or Edit menu. 

Properties for elements or objects have three different types, as defined on the Properties dialog box: 
Style properties, as specified on the Format tab. Style properties affect the format of the element.                      
Size properties, as specified on the Info. Size properties affect characteristics of the element, such as the 

length. 
User-defined properties, as created on the User tab. User-defined properties are usually in the form of a text

notation, such as cost, manufacturer, and so forth You can change user-defined properties, but these changes have 
no affect on the appearance of the element or object.

For example, a valve symbol's style properties can include color, line style, and width. Other user-defined 
properties stored with the symbol can include the manufacturer, cost, or material. User-defined properties are 
displayed in the Attribute Viewer when you select the valve symbol. 



radial dimension
A dimension that measures the radius of an arc, circle, ellipse, or curve.



reference file
Any file not native to SmartSketch that is linked or embedded and used for reference information. You click 
Insert > Object to link or embed a reference file, or you can drag or drop it with Windows Explorer.



relationship
A condition that exists for an individual element or between elements. You can establish relationships as you 
place new elements or between elements already on the drawing sheet. If Maintain Relationships is set, then 
the relationship controls the modification behavior of the related elements. For example, if two lines have a 
parallel relationship, they remain parallel when one of the lines is moved.

SmartSketch recognizes potential relationships as you draw. Relationship handles are placed on related 
elements to represent maintained relationships.



relationship handle
A graphic used to represent a geometric relationship between elements, key points, and dimensions, or between 
key points and elements. The relationship handle shows that the designated relationship is being maintained.
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relationship indicator
A graphic that is displayed at the pointer when the software recognizes a SmartSketch relationship.
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rotation angle
The angle between 0—180 degrees that an element is rotated in either direction. Zero degrees is horizontal to 
the x axis; the angle increases in the counterclockwise direction. 



rotation angle
The angle at which the rectangle is oriented. Zero degrees is defined by the positional angle. The angle 
increases in the counterclockwise direction.



rotation axis
A temporary line that shows the rotation angle with respect to the rotation reference axis. Zero degrees is defined
by the positional angle; the angle increases in the counterclockwise direction.



rotation reference axis
A temporary line defined by the center of rotation and the rotation from point. Zero degrees is horizontal; the 
angle increases in the counterclockwise direction. The rotation angle is measured from this line.



scale origin
The starting point from which an object is scaled along the x and y axes.



secondary axis
The axis that is perpendicular to the primary axis of an ellipse. The secondary axis is defined after the primary 
axis and can be longer than the primary axis.



Select Tool
A tool that allows you to select elements before you run a command on them. 



selection set
A single selected object or a group of selected objects.



share embed
A document copied directly into a drawing. When you embed the same document more than once in the same 
document, the document elements are copied each time. When you share embed the same document more than
once in the same document, the documents are not copied each time. Instead, the other documents reference 
the initial placement of the document.



shortcut menu
A menu that gives you quick access to commands that are related to the item you are working with. The 
commands available on the shortcut menu depend upon the selected element or active command. To activate 
the shortcut menu, click the right mouse button.



sketch
The process of creating a rough drawing that approximates the size or shape of a real-world object.



smooth node
A type of vertex on a curve. A curve with a smooth node has a different curvature on each side of the node. The 
start point and end point of a curve is always a smooth node. A handle can be attached to a smooth node for 
editing.



source document
A document that provides data, graphics, or other information to another document through a link.



stacked dimension group
A series of individual dimensions that are arranged at different levels from the smallest value to the largest. A 
stacked dimension group measures locations from a common origin.



style
1 The appearance of geometry and annotations on the drawing sheet. For example, an element's color and line 

weight, the font used in a text box, and so forth. 
2 A collection of formats or properties that you name and store as a group. When you apply a style to a selected

item, the software applies all the formats or properties in the style to the element. The style types include: fill, 
dimension, line, and text.



sweep angle
The angle that defines the length of an arc.



symbol
A document placed in a drawing. You can override and edit the properties and style of the symbol. A document 
can be linked, or    embedded.



symmetric node
A type of vertex on a curve. A curve with a symmetric node has the same curvature on each side of the node. A 
handle can be attached to a symmetric node for editing.



tangent relationship
A relationship between an arc or circle and another geometric element. The elements share a common point that
is not intersecting.



target point
The origin for coordinate measurements displayed by PinPoint. You can position the target point anywhere on 
the drawing sheet.



template
A default set of properties that defines what a new document will look like. You can use a template to set 
standards for a group of users or to define your own preferences.



terminator
A graphic symbol, such as an arrow or dot, placed at the end of a leader.



text box
A rectangular element that contains text or symbols; you can place text boxes on drawing sheets.



to point
The ending point for an action. For example, when you rotate elements, the to point determines where you want 
the rotation to stop.



toolbar
Toolbars are graphic menus with buttons that allow you to quickly access commands. You can define custom 
toolbars or use the toolbars delivered with the software.



tools
A set of commands that can be activated from a menu, toolbar, or keyboard shortcut. Tools are self-contained, 
designed for specific tasks, and can be used in any compatible environment.



user property
A unique characteristic of an element or object in a file. You can assign unique values to an element or object 
with the Properties command on the Edit menu.



variable
A value that can be referenced and changed.



vertex
The highest point or apex of a figure, the intersection of lines or curves, or the end point of an element.



vertical relationship
A relationship that specifies that the end points of a line, or two key points, are level with each other along the y 
axis.



window
An area defined by a standard border and buttons that is used to display information in an application.



wireframe element
A 2-D, graphic representation of simple geometry; wireframe elements include points, lines, circles, arcs, conic 
curves, freeform curves, and composite curves.



working sheet
A component of a drawing sheet. The working sheet is where you create design data and document data. You 
can apply a scale to document and design data and attach a background sheet to the working sheet.





Microsoft Office 97 Compatible
{button Related Topics,AL("oc high;with oc high;working with Microsoft Office high",0,`NOT_FOUND')}

The software is a Microsoft Office 97 Compatible product, which means that many of its basic features (including 
toolbars, menus, and accelerator keys) are similar to those used by Microsoft Office. If you are already using 
Microsoft Office, which includes Microsoft Excel, Word, Access, and PowerPoint, or another Office 97 
Compatible product, then many of the tasks you have learned to complete in Office can be completed in a similar
manner in the software. These similarities will make it easier for you to use Office 97 Compatible products 
together. 

Look for the Microsoft Office 97 Compatible logo when purchasing software. For more information about the 
Microsoft Office Compatible program, and for a complete listing of Microsoft Office 97 Compatible products, see 
our web site at http://www.microsoft.com/office/compatible or call Microsoft Customer Service at 1-800-426-9400.
Customers outside the United States should call their local Microsoft Office.



Using SmartSketch with Microsoft Office
{button Related Topics,AL("ms oc high;oc high;working with Microsoft Office high;intellimouse high 
",0,`NOT_FOUND')}

SmartSketch uses familiar Microsoft tools and methods:
Object Linking and Embedding (OLE) technology from Microsoft allows you to use Intergraph SmartSketch 

drawings with Microsoft Word documents, Microsoft Excel spreadsheets, and Microsoft PowerPoint presentations.
You can use Microsoft Office tools to insert data, such as spreadsheets, into SmartSketch documents.
With automation capabilities, you can create simple macros that automatically place graphic data from 

Microsoft Excel spreadsheets into SmartSketch. You can also list SmartSketch graphic data in a Microsoft Excel 
spreadsheet.

You can use the IntelliMouse pointing device with SmartSketch to pan and zoom. For more information 
about other mouse actions, click the Related Topics button.

You can also use SmartSketch with Microsoft Internet Explorer, because SmartSketch is Internet-ready. 
Because SmartSketch documents are ActiveX objects, you can view them inside Internet Explorer.



Office Compatible Features Supported By SmartSketch
{button Related Topics,AL("ms oc high;with oc high;working with Microsoft Office high;intellimouse 
high",0,`NOT_FOUND')}

SmartSketch includes the following Office Compatible features:

Office Compatible Toolbars and Menus
SmartSketch contains toolbars that are similar to the ones in Microsoft Office software. For example, you 

can print a document by clicking the Print button on the Main toolbar. You can configure the SmartSketch toolbars 
using the Toolbar command on the View menu.

The SmartSketch Main toolbar has a similar configuration as the Main toolbars in 
Microsoft Office software. You can configure the toolbars using the Toolbar command on the View menu.

You will find the Main toolbar buttons similar to the ones in Microsoft Office software in 
size, appearance, color, and location.

You can easily see the function of each toolbar button just by simply parking the mouse on
the button. This activates a ToolTip that displays the name of the button.

The Main menu bar is similar to the ones in Microsoft Office software. The drop-down 
menus, such as File, Edit, and Help; their menu items; their short-cut keys; and their accelerator keys are also 
exactly the same as those in Microsoft Office software.

You can use the Microsoft IntelliMouse with SmartSketch.

Additional Features

SmartSketch has added several features to the standard Microsoft Office software features:



You will find the following buttons on the Main toolbar: Undo, Redo, Label, Change, 
PinPoint, and Symbol. You may also find other software-specific command buttons.

The Main menu bar contains additional menus such as View, Insert, Format, Tools, and 
Window, which are available in many Microsoft Office products. You may also find other software-specific menus 
positioned before the Window menu.

The Edit menu includes Undo and Redo commands in addition to the standard Microsoft 
Office menu commands.

The Help menu includes learning tools such as Tip of the Day in addition to the standard 
Help menu items.




