
Using SmartSketch with Mathcad

You will need Mathcad 8 Professional, Standard, or Professional Academic (including the latest Service 
Pack) to use the SmartSketch Component for Mathcad.

Using SmartSketch with Mathcad 8

With Mathcad and SmartSketch you can enjoy full interoperability without having to do any scripting or 
programming.  You can quickly make changes from within either application and can easily turn your 
design ideas into precise, finished drawings. In seconds you can drive design dimensions from Mathcad and
animate 2D CAD mechanisms. A few common usage scenarios represented by examples appearing in this 
folder are outlined below.

1. Static illustration of Mathcad computations using SmartSketch
In this simplest usage scenario, a SmartSketch drawing can be embedded into a Mathcad worksheet 
as an illustration. SmartSketch does not participate in the computational flow of the Mathcad 
worksheet, but the drawing can be edited in-place via standard OLE in-place activation mechanism. 
Creating a Static Drawing section below explains how to create a static SmartSketch drawing in 
Mathcad. An example of this usage can be found in file Belt.mcd.

2. Dynamic illustration of Mathcad computations using SmartSketch
In this scenario, inputs are passed from Mathcad into SmartSketch, and the SmartSketch drawing 
adjusts accordingly based on the passed parameters and constraints that are intrinsic to the drawing. 
The drawing is thus an "active," context-sensitive illustration of the calculations performed within 
the Mathcad worksheet. An example of this usage mode can be found in file SimpleBeam.mcd.

3. SmartSketch drawings as a data source for Mathcad calculations
A SmartSketch drawing can also act as a data source for Mathcad calculations. An example of this 
usage is file WindLoad.mcd, where the geometry of a building (height, roof angle, etc.) is extracted
from the drawing, letting you calculate (using Mathcad) whether the wind pressures are within limits
defined by the appropriate ASCE standard. (Note: WindLoad.mcd will run in Mathcad 8 
Professional only.) Another good example of this usage is Ditch.mcd, in which the amount of water 
that can be accommodated by a SmartSketch-drawn ditch is calculated in Mathcad.

4. Using Mathcad and SmartSketch to simulate mechanical systems (Mathcad Professional only)
Mathcad, MathConnex, and SmartSketch together can be used to simulate mechanical systems. 
Probably the best example of this usage mode is the scotch yoke example (Yoke.mxp). Instead of 
solving the scotch yoke mechanism analytically, we use MathConnex and SmartSketch to simulate it
dynamically, and then we use Mathcad to take the derivative of displacement to calculate angular 
velocity of the yoke. While the scotch yoke mechanism would be relatively easy to solve 
analytically, a more complex mechanism could be much harder to solve. SmartSketch+Mathconnex 
dynamic simulations become indispensable as the complexity of the mechanical system to be 
simulated increases. BackHoe.mxp is another good example that falls into this category.

5. Automated validation and verification of SmartSketch designs
It is often important to determine whether the mechanical system or structure conforms to particular 
specifications. The structure can be drawn in SmartSketch, its parameters can then be extracted into 
Mathcad, where the spec verification calculation can then be performed. If the spec is not met, the 
design can be adjusted interactively by in-place activating the SmartSketch drawing, and the 
Mathcad validation portion of the worksheet will recalculate automatically for the new design 
parameters. The WindLoad.mcd file mentioned above is one example of this usage. Another good 
example is Belt.mcd, where the minimal force required for the belt not to slip is calculated in 



Mathcad for a two-pulley system drawn in SmartSketch.

6. Compliance -- creating drawings from standard specifications
This scenario is reciprocal with respect to the previous one. Suppose we want to generate a drawing 
of a mechanical design that is subject to some specifications. We can use Mathcad to calculate the 
drawing parameters that will be in compliance with the specifications, and then feed these 
parameters to SmartSketch. SmartSketch will then dimension the drawing to precisely match the 
specs.

7.  Displaying calculations on a SmartSketch drawing sheet
In this scenario SmartSketch is the container and the Mathcad calculations are embedded in the 
drawing sheet.  Using the variable table and a user defined VB Script function the calculations are 
automatically updated each time the geometry is changed.  See the Samples\Mathcad\Ditch\
Ditch.igr example in the SmartSketch folder.

Note:  VB Script 5 or higher is required for this scenario, but is not delivered with SmartSketch.  It 
can be downloaded from http://www.microsoft.com/vbscript.

The following sections explain how to use SmartSketch in conjunction with Mathcad to achieve the usage 
scenarios outlined above.

Creating a static drawing

You can insert a SmartSketch drawing into a Mathcad worksheet simply by:

1. Creating the drawing in SmartSketch (or opening an existing drawing from a file),
2. Drag-selecting the portion of the drawing that you want to use in your Mathcad worksheet,
3. Copying and pasting (or dragging and dropping) it into your Mathcad worksheet.

To create a static SmartSketch drawing from within Mathcad, insert an SmartSketch object into your 
worksheet. To do so:

1. Click in a blank spot in your Mathcad worksheet.
2. Choose Object from the Insert menu.
3. Choose SmartSketch Document and click "OK."
4. Use the SmartSketch menus and toolbars to create a drawing.

If you want to create a static drawing from within Mathcad from a previously created file:

1. Click "Create from File" in the Insert Object dialog box.
2. Type the path to the object file or click "Browse" to locate it.
3. Check "Link" to insert a linked object. Otherwise, the object is embedded.
4. Click "OK."

Creating a new drawing that is computationally linked to your Mathcad worksheet

Although static drawings can add meaning to a Mathcad worksheet, you may find that you want your 
Mathcad equations and the drawing to be linked together. For example, you may want your Mathcad 
equations to drive the size or shape of a drawing. To create drawings that are linked to the variables in a 
Mathcad worksheet, use the SmartSketch component.

The SmartSketch component retrieves input from one or more Mathcad variables, uses them in the 
drawing, and may return output to one or more Mathcad variables. "Input" is data passed to the 

http://www.microsoft.com/vbscript


SmartSketch drawing from an "input variable" in the Mathcad worksheet. "Output" is data passed to the 
Mathcad worksheet from the SmartSketch drawing and assigned to an "output variable."

To insert an SmartSketch component into your Mathcad worksheet:

1. Click in a blank spot in your worksheet. If you want to send values to the SmartSketch drawing 
from a Mathcad variable defined in your worksheet, click below or to the right of the variable 
definition.

2. Choose Component from the Insert menu. Select SmartSketch and click "Next." The first page of
the SmartSketch component Wizard appears:

3. To insert an SmartSketch drawing you've already created, choose "From Existing File," and type 
the path name in the text box or use the Browse button to locate the file; then click "Open." 
Otherwise, choose "New SmartSketch Document." The next page of the Wizard appears:



4. Specify the number of inputs and outputs. If you are using an existing file, also specify the names 
of the variables or dimensions in the drawing to send input to and retrieve output from. Use the 
drop-down menus in the text boxes next to In1, In2, etc. and Out1, Out2, etc.

5. Click "Finish." The SmartSketch component appears in your worksheet with placeholders for the 
input and output variables, such as those shown here:

6. Enter the names of Mathcad input variables in the bottom placeholders. Enter the output variables 
in the placeholders to the left of the:=. 

If you are creating a new SmartSketch document, double-click on the component and use SmartSketch's 
menus and toolbars to create a drawing. Use the Dimensions toolbar to add dimensions to your drawing. 
Choose Variables from the Tools menu to define variables or edit dimensions. Close the Variable Table 
before clicking back in the Mathcad worksheet.

NOTE: Input values that do not have units attached are passed in SI units. For example, if you send 2.0 as 
input for a length, it is assumed to be 2.0 meters. SmartSketch, by default, converts this to the display units 
(inches by default) and creates the drawing. Set your Mathcad worksheet to the SI unit system before using 
the SmartSketch component. To do so, choose Options from the Math menu and click on the Unit System 
tab. 

After creating a new drawing, you need to bind variables and/or dimensions to the inputs and/or outputs. To
do so, click on the component with the right mouse button and choose Properties from the pop-up menu. 
Use the Properties dialog to specify:

 Input names.  The dimension or variable names used in the SmartSketch drawing that are controlled 
by the inputs to the SmartSketch component. Choose a dimension or variable name from the drop-
down list. 

 Output names.  The dimension or variable names used in the SmartSketch drawing that define the 
output variables in Mathcad. Choose a dimension or variable name from the drop-down list. 

When you click outside the component, input values are sent to the SmartSketch drawing from Mathcad 
and values are returned to Mathcad as output. The figure below shows an example of a SmartSketch 
drawing connected to variables in a Mathcad worksheet. 



NOTE: In order for the dimensions in a drawing to resize parametrically, there should be a check next to 
the Maintain Relationships option under the Tools menu in SmartSketch. To verify this, double-click on 
the component and choose Tools from the menu bar.

Computationally linking a existing SmartSketch drawing to your Mathcad 
worksheet

The sample file TRIANGLE.IGR (located in \Samples\CAD\SmartSketch under the Mathcad folder) is a 
sample SmartSketch drawing you can use to practice with the SmartSketch component. This example is a 
drawing of a right triangle whose dimensions are two legs, a hypotenuse, and the angle between the 
hypotenuse and the horizontal leg. 

Follow the steps below to use TRIANGLE.IGR to:
 Send one input from a Mathcad input variable S to the drawing. 
 Retrieve an output value from the drawing and send it to a Mathcad output variable called A.

To begin:

1. Define an input variable in the Mathcad worksheet. Type S:=1.063*in

2. Click in a blank spot in your worksheet. 

3. Choose Component from the Insert menu and select SmartSketch. Click "Next." 

4. Click "From Existing File."

5. Click the Browse button and navigate to the file TRIANGLE.IGR located in \Samples\CAD\
SmartSketch under the Mathcad folder. Then click "Open." The Properties page of the Wizard 
appears.

6. Specify the number of inputs and outputs. For this example, specify 1 input and 1 output. 



Next, specify the names of the input and output variables. In TRIANGLE.IGR, the horizontal leg of the 
triangle is called "Length." SmartSketch calculates "Angle" which is the size of the angle between the 
horizontal leg and the hypotenuse. To send input to "Length" and send the value of "Angle" as output:

1. For In1, choose "Length" from the drop-down list. For Out1, choose "Angle" from the drop-down 
list. The dialog should look like this:

2. Click "Finish." The SmartSketch component appears in your worksheet with one placeholder for 
the input variable and one placeholder for the output variable.

3. Type S in the bottom placeholder. Type A into the placeholder to the left of the :=. 

When you click outside the component, 1.063 inches is sent as input to the SmartSketch drawing and used 
to calculate the value of the angle; that value is sent as output to the Mathcad variable A.



To understand how the variables in a SmartSketch drawing are defined, examine SmartSketch's Variable 
Table. To do so:

1. Double-click the SmartSketch component in the Mathcad worksheet. Menus and toolbars change 
to SmartSketch's menus and toolbars.

2. Choose Variables from the Tools menu. For TRIANGLE.IGR, the Variable Table looks like:

3. Close the Variable Table.



Accessing SmartSketch

After inserting the SmartSketch component into a Mathcad worksheet, you can use the component to edit 
and create drawings in SmartSketch, provided you have SmartSketch installed on your system. To do so:

1. Double-click the SmartSketch component in the Mathcad worksheet. Menus and toolbars change 
to SmartSketch's menus and toolbars.

2. Edit the SmartSketch drawing however you'd like.

3. Click back in the Mathcad worksheet to have the component recalculate and to resume working in 
Mathcad.

NOTE: Changes you make to an existing SmartSketch document using the SmartSketch component do not 
affect the actual SmartSketch document from which it was created.

Changing the inputs and outputs

To add or remove inputs and outputs:

 Click on the component with the right mouse button and choose Add Input Variable or Add Output 
Variable. To eliminate an input or output choose Remove Input Variable or Remove Output 
Variable.

To change the input variables and output variables used from the SmartSketch drawing:

 Click on the component with the right mouse button and choose Properties from the pop-up menu. 
Use the drop-down choices in the text boxes next to In1, In2, etc. and Out1, Out2, etc.

More information and technical support

For more information on the Mathcad components, refer to "Exchanging data with other applications" in 
Chapter 16 of the Mathcad User's Guide.

For more information on SmartSketch, refer to the tutorials and documentation available by choosing from 
the Help menu in SmartSketch. 

Sample Mathcad files containing SmartSketch components are located in the \Samples\Mathcad folder 
under SmartSketch.  For more details on Mathcad and additional specific examples, please visit MathSoft’s
web site at http://www.mathsoft.com or http://www.SmartSketch.com.

For technical support or additional information on other MathSoft products, please visit 
http://www.mathsoft.com, or visit MathSoft’s Webstore at http://www.mathsoft.com/webstore. You can 
also contact MathSoft directly by emailing support@mathsoft.com or calling them at 617-577-1778.

http://www.SmartSketch.com/
http://www.mathsoft.com/

