
AutoSave Command (Tools Menu)
{button Related Topics,AL("autosave high;add-ins overview high",0,`NOT_FOUND')} {button How 
To,AL("autosave how",0,`NOT_FOUND')}

Automatically saves open documents at the interval you specify.
Tip    If you do not have an AutoSave option on the Tools menu, the AutoSave add-in has not been installed. 
Click the Related Topics button for more information.

AutoSave Dialog Box



Bearing and Azimuth Command (View Menu)
{button Related Topics,AL("bearing azimuth high",0,`NOT_FOUND')} {button How To,AL("set bearing azimuth 
how ",0,`NOT_FOUND')}

Allows you to determine how to display the angle for the selected element.

Tip    The Bearing and Azimuth command is available only if you use the Customize command on the Tools 
menu to place it on a toolbar or menu. On the Toolbars tab of the Customize dialog box, click the Tools 
category to access the command.

Set Bearing     Dialog Box  



Symbol Explorer Command (Main Toolbar)
{button Related Topics,AL("placing symbols high;Symbol Explorer high;symbols cmd;av high",0,`NOT_FOUND')}

{button How To,AL("symbols how;Symbol Explorer how",0,`NOT_FOUND')}

Activates the Symbol Explorer window and the Attribute Viewer. The Symbol Explorer window allows you to 
organize and manage documents and symbols. You can browse document directories on the computer hard 
drive or the network. You can also view HTML pages on the Internet, the computer hard drive, or CD-ROM drive.

Symbol Explorer Window

 



Delete Favorite Command (Shortcut Menu)
{button Related Topics,AL("Symbol explorer high;Symbol explorer db",0,`NOT_FOUND')}{button How 
To,AL("delete favorite how",0,`NOT_FOUND')}

Deletes the selected bar from the Symbol Explorer window and removes the item from the list of favorites.
Tip    To access this command, pause the pointer over the favorite directory, HTML page, or file in the Symbol 
Explorer window and right-click.



Set Document Home Command (Shortcut Menu)
{button Related Topics,AL("Symbol Explorer db;Symbol Explorer cm;Symbol Explorer high",0,`NOT_FOUND')}

{button How To,AL("set home page for Symbol Explorer how",0,`NOT_FOUND')}

Sets the home address for the current document. When you open a document and then open the Symbol 
Explorer and click the Home button, the Symbol Explorer goes to the address that you enter here. The 
address can be any address that you would use in a web browser, such as Microsoft Internet Explorer or 
Netscape; for example, you can type http://www.ingr.com.

If you want to set the Symbol Explorer to always look at symbols on your computer, you can type the following 
syntax in the Address box: <application.path>\..\<path of symbols>. For example, you could enter 
<application.path>\..\symbols\arch.htm.
Tip    To access this command, pause the pointer in the Symbol Explorer window and right-click.



View File Type Command (Shortcut Menu)
{button Related Topics,AL("Symbol Explorer db;Symbol Explorer cm;Symbol Explorer high",0,`NOT_FOUND')}

{button How To,AL("view documents with Symbol Explorer how",0,`NOT_FOUND')}

Filters the view in the Symbol Explorer window according to the document type that you select. For example, if 
you want to see only AutoCAD documents, you could select the AutoCAD option for .dwg documents. When you 
set this option, the Symbol Explorer window displays only .dwg documents.
Tip    To access this command, pause the pointer in the Symbol Explorer window and right-click.



Show Favorites Command (Shortcut Menu)
{button Related Topics,AL("Symbol explorer high",0,`NOT_FOUND')} {button How To,AL("show favorites 
how",0,`NOT_FOUND')}

Shows bars in the Symbol Explorer window that point to documents or web pages that you added to the list of 
favorites. When you click a bar, the Symbol Explorer displays the associated documents or web pages.
Tip    To access this command, pause the pointer in the Symbol Explorer window and right-click.



Add To Favorites Command (Shortcut    Menu)
{button Related Topics,AL("Symbol explorer high",0,`NOT_FOUND')} {button How To,AL("add to favorites 
how",0,`NOT_FOUND')}

Adds a shortcut bar to the Symbol Explorer window when you select a document or web page in the window. 
When you click this bar, the window displays the document or web page.
Tip    To access this command, pause the pointer in the Symbol Explorer window and right-click.



Explore Elsewhere Command (Shortcut Menu)
{button Related Topics,AL("Symbol Explorer db;Symbol Explorer cm;Symbol Explorer high",0,`NOT_FOUND')}

{button How To,AL("view documents with Symbol Explorer how",0,`NOT_FOUND')}

Accesses the Browse for Folder dialog box so that you can locate another directory for the Symbol Explorer to
look in. You can use the dialog box to look in directories on your hard drive or a network drive.
Tip    To access this command, pause the pointer in the Symbol Explorer window and click the right mouse 
button.



Connector Command (Draw Toolbar)
{button Related Topics,AL("connector rb;connect high",0,`NOT_FOUND')} {button How To,AL("place 
connector how;modify connector how",0,`NOT_FOUND')}

Connects two elements together. 

Using a connector, you can connect to an element by connecting to:
Key points. Hollow gray circles indicate potential key points (such as endpoint, midpoint, and others) on an 

element, when the element is located by the pointer.
Connect points. Hollow red circles indicate potential connect points on a symbol.
Any point on an element. A solid red filled circle is displayed when the pointer locates an element at a point 

other than its key points.
Tip    You must click the Connector command before you see the points for connecting on the element.

You can also access this command on the Schematic toolbar.

Connector Ribbon Bar



Hyperlink Command (File Menu)
{button Related Topics,AL("hyperlink high",0,`NOT_FOUND')} {button How To,AL("insert hyperlink how;edit 
hyperlink how;delete hyperlink how;find hyperlink how",0,`NOT_FOUND')}

Adds hyperlinks to objects, symbols, text, connectors, and elements, such as lines, circles, ellipses, and groups. 
You can enter a link to a file or a web page on the Internet.



Add Link Command (Shortcut Menu)
{button Related Topics,AL("hyperlink high",0,`NOT_FOUND')} {button How To,AL("insert hyperlink how;find 
hyperlink how",0,`NOT_FOUND')}

Allows you to add a hyperlink on the Enter Link Source dialog box. You can enter a link to a file or a web page 
on the Internet. For example, you can type the following path:    D:\myfile.html.
Tip    To see the shortcut menu, you must first click the Hyperlink button on the Main toolbar. You can then right-
click. 



Exit Hyperlink Command (Shortcut Menu)
{button Related Topics,AL("hyperlink high",0,`NOT_FOUND')} {button How To,AL("insert hyperlink how;edit 
hyperlink how",0,`NOT_FOUND')}

Allows you to stop the Hyperlink command.
Tip    To access this command, you must first click the Hyperlink button on the Main toolbar and then right-click. 



Show Links Command (Shortcut Menu)
{button Related Topics,AL("hyperlink high",0,`NOT_FOUND')} {button How To,AL("insert hyperlink how;find 
hyperlink how",0,`NOT_FOUND')}

Displays all the hyperlinks in a document. When you click this command, all the elements or objects that have a 
hyperlink are highlighted.
Tip    To access this command, you must first click the Hyperlink button on the Main toolbar and then right-click. 



Edit Link Command (Shortcut Menu)
{button Related Topics,AL("hyperlink high",0,`NOT_FOUND')} {button How To,AL("insert hyperlink how;edit 
hyperlink how;find hyperlink how",0,`NOT_FOUND')}

Allows you to change the web addresses or paths for hyperlinks that are applied to objects, symbols, text, 
connectors, and elements, such as lines, circles, ellipses, and groups.
Tip    To see the shortcut menu, you must first click the Hyperlink button on the Main toolbar. You can then click 
the right mouse button. 



Remove Link Command (Shortcut Menu)
{button Related Topics,AL("hyperlink high",0,`NOT_FOUND')} {button How To,AL("insert hyperlink how;delete 
hyperlink how;find hyperlink how",0,`NOT_FOUND')}

Removes hyperlinks from objects, symbols, text, connectors, and elements, such as lines, circles, ellipses, and 
groups.
Tip    To see the shortcut menu, you must first click the Hyperlink button on the Main toolbar. You can then click 
the right mouse button. 



Follow Link Command (Shortcut Menu)
{button Related Topics,AL("hyperlink high",0,`NOT_FOUND')} {button How To,AL("insert hyperlink how;edit 
hyperlink how;delete hyperlink how;find hyperlink how",0,`NOT_FOUND')}

Allows you to open the web page or file at which the hyperlink is pointing.
Tip    To see the shortcut menu, you must first click the Hyperlink button on the Main toolbar. You can then click 
the right mouse button. 



Isometric Circle Command 
{button Related Topics,AL("iso high",0,`NOT_FOUND')} {button How To,AL("iso circle how;add button to 
toolbar how",0,`NOT_FOUND')}

Allows you to draw an isometric circle. You can use this button to create 2D circles that look like 3D circles.

 
Tip    To access this command, you must place it on a toolbar or menu with the Customize command on the 
Tools menu. On the Toolbars tab of the Customize dialog box, click the Draw category.

Isometric Circle Ribbon Bar



Isometric Line Command 
{button Related Topics,AL("iso high",0,`NOT_FOUND')} {button How To,AL("iso line how;add button to 
toolbar how",0,`NOT_FOUND')}

Allows you to draw lines that appear at 30, 60, or 90 degrees in an isometric drawing. This button creates 2D 
lines that look like they are in a 3D plane.

 
Tip    To access this command, you must place it on a toolbar or menu with the Customize command on the 
Tools menu. On the Toolbars tab of the Customize dialog box, click the Draw category.

Isometric Line Ribbon Bar



Isometric Rectangle Command 
{button Related Topics,AL("iso high",0,`NOT_FOUND')} {button How To,AL("iso rectangle how;add button 
to toolbar how",0,`NOT_FOUND')}

Allows you to draw an isometric rectangle. You can use this button to create 2D rectangles that look like 3D 
rectangles.

 
Tip    To access this command, you must place it on a toolbar or menu with the Customize command on the 
Tools menu. On the Toolbars tab of the Customize dialog box, click the Draw category.

Isometric Rectangle Ribbon Bar



Edit Text Properties Command (Shortcut Menu)
{button Related Topics,AL("labels high",0,`NOT_FOUND')} {button How To,AL("labels how",0,`NOT_FOUND')}

Allows you to edit the properties of the text in a Smart Label.

Tip    You must select a Smart Label before you can select this command on the shortcut menu.

Text Properties Dialog Box



Edit Graphic Properties Command (Shortcut Menu)
{button Related Topics,AL("labels high",0,`NOT_FOUND')} {button How To,AL("labels how",0,`NOT_FOUND')}

Allows you to edit the properties of the elements in a Smart Label.

Tip    You must select a Smart Label before you can select this command on the shortcut menu.

Element Properties Dialog Box
Fill Properties Dialog Box
Balloon Properties Dialog Box
Group Properties Dialog Box
SmartFrame Properties Dialog Box



Move Sheet Border Command (File Menu)
{button Related Topics,AL("drawing sheets high;drawing sheets high;new sheet cmd",0,`NOT_FOUND')}

{button How To,AL("move sheet how",0,`NOT_FOUND')}

Moves the active working sheet to reposition, scale, and select paper size.

Move Sheet Dialog Box



Relationships Command (Main Toolbar)
{button Related Topics,AL("relating elements high",0,`NOT_FOUND')} {button How To,AL("display relationship 
toolbar how",0,`NOT_FOUND')}

Displays the Relationship toolbar. You can use the commands on this toolbar to create relationships between 
two drawing elements.
Tip    To maintain the relationship between elements when you modify either one of the elements, you must set 
Maintain Relationships on the Tools menu.



Create Symbol Command (Draw Toolbar)
{button Related Topics,AL("symbols high;Content Explorer high",0,`NOT_FOUND')} {button How 
To,AL("symbols how",0,`NOT_FOUND')}

Allows you to create a symbol. 
Tip This button is available only when you select elements.

 



Stamp Here Command (Shortcut Menu)
{button Related Topics,AL("placing symbols high;symbols cmd",0,`NOT_FOUND')} {button How 
To,AL("place multiple symbols how",0,`NOT_FOUND')}

Places more than one instance of a symbol as you drag a symbol into a document. This command allows you to 
copy a symbol quickly and easily as you place it.        
Tip    You can access this command by dragging a symbol into a document with the right mouse button.



Place Here Command (Shortcut Menu)
{button Related Topics,AL("placing symbols high;symbols cmd",0,`NOT_FOUND')} {button How 
To,AL("place multiple symbols how",0,`NOT_FOUND')}

Places one instance of a symbol as you drag a symbol into a document. 
Tip    You can access this command by dragging and dropping a symbol into a document with the right mouse 
button.



Place Doubleline Command (Draw Toolbar)
{button Related Topics,AL("freesketch high;smartsketch high;line high;dubline high",0,`NOT_FOUND')}

{button How To,AL("line how",0,`NOT_FOUND')}

Draws a doubleline or a series of connected doublelines. When you draw a series of lines, the second point of 
one line is the first point of the next line.

This button is most effective if you use it in a document based on one of the architectural templates in the AEC 
category.
{mci_left NOMENU,DUBLINE1.AVI}
Tip    This button appears on a set of fly-out buttons. If you cannot locate this button, click and hold the Line/Arc 
Continuous button on the Draw toolbar.

Doubleline Ribbon Bar



Segmented Style Command 
{button Related Topics,AL("line high",0,`NOT_FOUND')} {button How To,AL("segmented style how;add 
button to toolbar how",0,`NOT_FOUND')}

Applies a line type, line weight, or color to part of an element. When you apply the line type, line weight, or color, 
the format extends to the next element that crosses or bounds the element to which you are applying the line 
type or color. This is handy if you want to change the appearance of just part of an element. 

 
Caution If you change the size of the element, you must re-apply the line type or color with the Segmented 
Style command. The Segmented Style command does not recognize symbols as a bounding element. 
Tip    To access this command, you must place it on a toolbar or menu with the Customize command on the 
Tools menu. On the Toolbars tab of the Customize dialog box, click the Draw category.

Line Ribbon Bar



About SmartSketch Command (Help Menu)
{button Related Topics,AL("help high",0,`NOT_FOUND')} {button How To,AL("about how",0,`NOT_FOUND')}

Displays information about your copy of the software, including the version number and the copyright, legal, and 
licensing notices.



Add-Ins Command (Tools Menu)
{button Related Topics,AL("add-ins overview high;add-ins included high",0,`NOT_FOUND')} {button How 
To,AL("add-in how",0,`NOT_FOUND')}

Allows you to select add-ins that are automatically available and ready to use when you start the software. With 
the Add-Ins command, you can install or remove:

Add-ins that come with the software.
Add-ins that you create.

Add-Ins Available

Lists the available add-ins. You can select or clear the add-in check boxes to install or remove add-ins in the 
software.

Browse

Lists the available drives and directories from which you can select an add-in to install in the software



Leader Command (Dimension Toolbar)
{button Related Topics,AL(`annotations high',0,`NOT_FOUND')} {button How To,AL(`leader 
how',0,`NOT_FOUND')}

Adds a leader to an annotation or to another leader.    You can place either end of the leader first: the annotation 
end or the terminator end.

You can attach the annotation end of a leader to one of the following:
Text box
Balloon
Another leader on a dimension or annotation

You can place the terminator end of a leader in one of the following ways:
Attach it to an element.
Place it in free space.

Leader Ribbon Bar



Alignment Indicator Command (Tools Menu)
{button Related Topics,AL("tools high;smartsketch high",0,`NOT_FOUND')} {button How To,AL("smartsketch 
how",0,`NOT_FOUND')}

Displays dashed lines to show horizontal or vertical alignment while you draw or modify elements. Alignment 
indicators work similarly to relationship indicators. If you click when a horizontal or vertical indicator line is 
displayed, the element you are drawing or modifying will be horizontally or vertically aligned with the element the 
indicator line leads to.



Dimension Command (Main Toolbar)
{button Related Topics,AL("annotations high",0,`NOT_FOUND')} {button How To,AL("display Dimension 
Toolbar how",0,`NOT_FOUND')}

Displays the Dimension Toolbar.    You can use the commands on this toolbar to place and modify dimensions 
and annotations.



Balloon Command (Dimension Toolbar)
{button Related Topics,AL(`annotations high;annotations cmd',0,`NOT_FOUND')} {button How 
To,AL(`balloon how;insert vertex how',0,`NOT_FOUND')}

Places a balloon containing text.    You can use balloons to refer to an element or a point in free space.    You can 
set options for controlling the size and shape of the balloon, text presentation, and leader display.

Balloon Ribbon Bar



Bring to Front Command (Change Toolbar)
{button Related Topics,AL("display order high;display order cmd;",0,`NOT_FOUND')} {button How 
To,AL("bring to front how",0,`NOT_FOUND')}

Moves one or more selected elements or element groups to the front of the display order.
{mci_left NOMENU,BFRONT.AVI} 



Tangent Command (Relationship Toolbar)
{button Related Topics,AL("draw high;relationship handles high;relating elements high",0,`NOT_FOUND')}

{button How To,AL("make tangent how",0,`NOT_FOUND')}

Makes two elements tangent. You can make two circles or arcs tangent. You can also make a circle, or an arc, 
and a line tangent.
{mci_left NOMENU,CHAN10C.AVI} 



Relationship Handles Command (Tools Menu)
{button Related Topics,AL("draw high;relating elements high",0,`NOT_FOUND')} {button How 
To,AL("show relationship handle how;delete relationship handle how",0,`NOT_FOUND')}

Displays any relationship handles on elements.



Maintain Relationships Command (Tools Menu)
{button Related Topics,AL("dimensions high;relationship handles cmd;draw high;relating elements 
high",0,`NOT_FOUND')} {button How To,AL("maintain relationships how",0,`NOT_FOUND')}

Places relationship handles as you draw.    When this option is set, the software places relationship handles for 
relationships that the software recognizes, and for relationships that you apply using the buttons on the 
Relationship toolbar.



Concentric Command (Relationship Toolbar)
{button Related Topics,AL("draw high;relationship handles high;relating elements high",0,`NOT_FOUND')}

{button How To,AL("make concentric how",0,`NOT_FOUND')}

Makes an arc or circle concentric with another arc or circle.
{mci_left NOMENU,CHAN1C.AVI} 



Colinear Command (Relationship Toolbar)
{button Related Topics,AL("draw high;relationship handles high;relating elements high",0,`NOT_FOUND')}

{button How To,AL("make colinear how ",0,`NOT_FOUND')}

Makes two lines colinear.
{mci_left NOMENU,CHAN2C.AVI} 



Equal Command (Relationship Toolbar)
{button Related Topics,AL("draw high;relationship handles high;relating elements high",0,`NOT_FOUND')}

{button How To,AL("make equal how",0,`NOT_FOUND')}

Makes elements or dimension values equal.    You can make the length of lines, the radius of arcs and circles, 
and the values of dimensions equal.
{mci_left NOMENU,CHAN3C.AVI} 



Lock Command (Relationship Toolbar)
{button Related Topics,AL("draw high;relationship handles high;relating elements high",0,`NOT_FOUND')}

{button How To,AL("lock how",0,`NOT_FOUND')}

Controls elements so they cannot be modified. When you use this button, you can lock the length, angle, radius, 
or position of an element. You can also lock keypoints on elements, such as endpoints of a line or the center of a 
circle, in their absolute positions.

{mci_left NOMENU,CHAN4C.AVI}    



Horizontal/Vertical Command (Relationship Toolbar)
{button Related Topics,AL("draw high;relationship handles high;relationships high;relating elements 
high",0,`NOT_FOUND')} {button How To,AL("make horizontal vertical how",0,`NOT_FOUND')}

Makes a line horizontal or vertical, or horizontally or vertically aligns two key points.
{mci_left NOMENU,CHAN5C.AVI} 

{mci_left NOMENU,CHAN5C_B.AVI}    



Connect Command (Relationship Toolbar)
{button Related Topics,AL("draw high;relationship handles high;relating elements high",0,`NOT_FOUND')}

{button How To,AL("connect how",0,`NOT_FOUND')}

Connects two elements or key points at one point.    This command also connects a key point on an element to a 
position that you select on another element.
{mci_left NOMENU,CHAN6C.AVI} 



Parallel Command (Relationship Toolbar)
{button Related Topics,AL("draw high;relationship handles high;relating elements high",0,`NOT_FOUND')}

{button How To,AL("make parallel how",0,`NOT_FOUND')}

Makes two lines parallel.
{mci_left NOMENU,CHAN7C.AVI} 



Perpendicular Command (Relationship Toolbar)
{button Related Topics,AL("relationships high;draw high;relating elements high",0,`NOT_FOUND')}

{button How To,AL("make perpendicular how",0,`NOT_FOUND')}

Makes two elements perpendicular.    You can make two lines, a line and an arc, or a line and a circle 
perpendicular.
{mci_left NOMENU,CHAN8C.AVI} 



Symmetric Command (Relationship Toolbar)
{button Related Topics,AL("draw high;relationship handles high;relating elements high",0,`NOT_FOUND')}

{button How To,AL("make symmetric how",0,`NOT_FOUND')}

Makes elements symmetric about an axis. The characteristics of the elements on each side of the axis, such as 
size and position, are maintained by the symmetric relationship.
{mci_left NOMENU,CHAN9C.AVI} 



Change Command (Main Toolbar)
{button Related Topics,AL("relating elements high",0,`NOT_FOUND')} {button How To,AL("display change 
toolbar how",0,`NOT_FOUND')}

Displays the Change toolbar. You can use the commands on this toolbar to manipulate elements.



Chamfer Command (Draw Toolbar)
{button Related Topics,AL("draw high;freesketch high;smartsketch high;extending or trimming 
high",0,`NOT_FOUND')} {button How To,AL("chamfer how;",0,`NOT_FOUND')}

Draws a chamfer, or bevel, between two linear elements. You can control the chamfer angle and the setback 
distances for both elements.

{mci_left NOMENU,CHMFER1C.AVI} 

Chamfer Ribbon Bar



Circular Pattern Command (Change Toolbar)
{button Related Topics,AL("patterns high;pattern cmd",0,`NOT_FOUND')} {button How To,AL("circular 
pattern how",0,`NOT_FOUND')}

Arranges selected elements in a circular pattern on the drawing sheet.
{mci_left NOMENU,CIRCPTN1.AVI}

Circular Pattern Ribbon Bar



Close Command (File Menu)
{button Related Topics,AL("document high;document cmd",0,`NOT_FOUND')} {button How To,AL("close 
document how",0,`NOT_FOUND')}

Closes the active document. If you have made changes since the document was last saved or if you have never 
saved a new document, you are prompted to indicate if you want to save your changes. If you do not want to 
save your changes, click the No button. If you want to save the changes, click the Yes button. If you do not want 
to close the document, click the Cancel button. If you click the Yes button, the Save As dialog box is displayed 
so that you can give the document a name and specify a directory and format to save it to. 

Save As Dialog Box



Close and Return Command (File Menu)
{button Related Topics,AL("revert imag cmd",0,`NOT_FOUND')} {button How To,AL("close return imag 
how",0,`NOT_FOUND')}

Saves changes to the SmartSketch document, closes it, and returns to the SmartSketch environment.
Note    When you use the Close and Return command, you are not asked to save the document until you exit 
SmartSketch.



Help Command (Main Toolbar)
{button Related Topics,AL("help high",0,`NOT_FOUND')} {button How To,AL("context help 
how",0,`NOT_FOUND')}

Displays context-sensitive Help on an item in the current window. You can use this command to get help on any 
item even when the item is not active. When this command is active, the pointer changes to a northwest arrow 
with a question mark.
Note    You can press Shift + F1 to get context-sensitive Help on an active command.



Convert Command (Symbols Shortcut Menu)
{button Related Topics,AL("symbols high",0,`NOT_FOUND')} {button How To,AL("edit symbols 
how",0,`NOT_FOUND')}

Converts the selected object to another file format. For example, if you select a symbol and click this command, 
the symbol is converted to a group of elements on the drawing sheet.
Note    You must place a symbol in a document at the default scale (1:1) if you want to use the Convert 
command. If you scale the symbol, you cannot convert the symbol to individual elements.



Copy Command (Edit Menu)
{button Related Topics,AL("edit high;cutting high;link and embed high;copy high",0,`NOT_FOUND')}

{button How To,AL("copy how",0,`NOT_FOUND')}

Copies selected elements and their associated relationships to the Clipboard. When you use this command, it 
replaces the previous contents of the Clipboard with the new contents.

When you copy more than one element at a time, all relationships shared among the elements are also copied. 
However, when you copy an element that shares a relationship with an element that you are not copying, the 
relationship is not copied.



Trim Corner Command (Draw Toolbar)
{button Related Topics,AL("draw high;extending or trimming high",0,`NOT_FOUND')} {button How 
To,AL("corner trim how",0,`NOT_FOUND')}

Draws a corner by extending and/or trimming two selected open elements.



Customize Command (Tools Menu)
{button Related Topics,AL("customize high",0,`NOT_FOUND')} {button How To,AL("customize 
how;restore toolbar how",0,`NOT_FOUND')}

Allows you to customize toolbars or menus to fit your workflow.

Customize   Dialog Box  



Cut Command (Edit Menu)
{button Related Topics,AL("cutting high;select high",0,`NOT_FOUND')} {button How To,AL("cut 
how",0,`NOT_FOUND')}

Cuts selected elements from the document and pastes them to the Clipboard. The selected elements replace 
the previous contents of the Clipboard.



Arc by 3 Points Command (Draw Toolbar)
{button Related Topics,AL("arc cmd;freesketch high;smartsketch high;circle high",0,`NOT_FOUND')}

{button How To,AL("arcs how",0,`NOT_FOUND')}

Draws an arc using three points. The first point defines an end point. You can then either define a point on the 
arc and then the end point, or the end point and then a point on the arc. The end points are not tangent or 
perpendicular to other elements.
{mci_left NOMENU,ARCBY3_1.AVI}

Arc Ribbon Bar



Arc By Center Point Command (Draw Toolbar)
{button Related Topics,AL("arc cmd;freesketch high;smartsketch high;circle high",0,`NOT_FOUND')}

{button How To,AL("arcs how",0,`NOT_FOUND')}

Draws an arc using three points. The first point defines the center of the arc and the next two points define the 
sweep.
{mci_left NOMENU,ARCBYCEN.AVI}

Arc Ribbon Bar



Tangent Arc Command (Draw Toolbar)
{button Related Topics,AL("arc cmd;freesketch high;smartsketch high;circle high",0,`NOT_FOUND')}

{button How To,AL("arcs how",0,`NOT_FOUND')}

Draws an arc tangent or perpendicular to one or two elements. The first point defines one end of the arc. If you 
place the first point on a key point of an element you want the arc to be tangent or perpendicular to, then the 
second point defines the sweep.
{mci_left NOMENU,TANARC1.AVI} 

If you place the first point in free space, then this command works like the Arc by 3 Points command. In this 
case the first point defines an end point. You can then either define a point on the arc and then the end point, or 
the end point and then a point on the arc.
Note    While in dynamics for the second point, you can set the orientation of the arc by passing the pointer 
through one of the four quadrants of the first point's intent zone.

Arc Ribbon Bar



Circle by 3 Points Command (Draw Toolbar)
{button Related Topics,AL("circle cmd;freesketch high;smartsketch high;circle high",0,`NOT_FOUND')}

{button How To,AL("circle by 3 how",0,`NOT_FOUND')}

Draws a circle using three points that define the circumference.
{mci_left NOMENU,CIRBY3.AVI}

Circle Ribbon Bar



Circle by Center Point Command (Draw Toolbar)
{button Related Topics,AL("circle cmd;freesketch high;smartsketch high;circle high",0,`NOT_FOUND')}

{button How To,AL("circle by center how;circle freesketch how",0,`NOT_FOUND')}

Draws a circle using a center point and radius.
{mci_left NOMENU,CIRBCEN.AVI}

Circle Ribbon Bar



Tangent Circle Command (Draw Toolbar)
{button Related Topics,AL("circle cmd;freesketch high;smartsketch high;circle high",0,`NOT_FOUND')}

{button How To,AL("tangent circle how;circle freesketch how",0,`NOT_FOUND')}

Draws a circle tangent to one or two elements.
{mci_left NOMENU,TANCIRC1.AVI} 

Circle Ribbon Bar



Curve Command (Draw Toolbar)
{button Related Topics,AL("node;freeform high;circle high;draw high",0,`NOT_FOUND')} {button How 
To,AL("curve how",0,`NOT_FOUND')}

Draws a smooth, open or closed curve. A series of curves can have smooth, symmetric. and cusp nodes. The 
node at the start point and the node at the end point of a curve are always smooth.
{mci_left NOMENU,CURVE1.AVI}

Curve Ribbon Bar



Delete Command (Edit Menu)
{button Related Topics,AL("cutting high;select high",0,`NOT_FOUND')} {button How To,AL("delete element 
how",0,`NOT_FOUND')}

Deletes the selected element and any relationships and dimensions that have been placed on it. You cannot 
reinsert or paste elements deleted with this command. However, you can retrieve the data by immediately 
clicking the Undo command. 

You can also access this command on the Schematic toolbar.



Ellipse by 3 Points Command (Draw Toolbar)
{button Related Topics,AL("ellipse cmd;freesketch high;smartsketch high;circle high ",0,`NOT_FOUND')}

{button How To,AL("ellipse by 3 how;ellipse freesketch how",0,`NOT_FOUND')}

Draws an ellipse using three edge points.    The first two points define the length of the primary axis and the 
rotation angle. The last point defines the secondary axis.
{mci_left NOMENU,ELLBY3_1.AVI}

Ellipse Ribbon Bar



Ellipse by Center Point Command (Draw Toolbar)
{button Related Topics,AL("ellipse cmd;freesketch high;smartsketch high;circle high ",0,`NOT_FOUND')}

{button How To,AL("ellipse by center how;ellipse freesketch how ",0,`NOT_FOUND')}

Draws an ellipse using the center point and two edge points.    The center point and the next point define half the 
length of the primary axis and the rotation angle.    The last point defines the secondary axis.
{mci_left NOMENU,ELLBYCEN.AVI}

Ellipse Ribbon Bar



FreeForm Command (Draw Toolbar)
{button Related Topics,AL("freeform high;draw high",0,`NOT_FOUND')} {button How To,AL("freeform 
how",0,`NOT_FOUND')}

Draws freeform curves, or splines. 

{mci_left NOMENU,DFRFRM1C.AVI} 

FreeForm Ribbon Bar



FreeSketch Command (Draw Toolbar)
{button Related topics,AL("draw high;freesketch high",0,`NOT_FOUND')} {button How To,AL("freesketch 
how",0,`NOT_FOUND')}

Draws lines, arcs, rectangles, and circles by converting a sketch into a precision drawing.    You can specify 
which of these elements you want to draw using the ribbon bar. 
{mci_left NOMENU,DFRSKC1C.AVI} 

FreeSketch Ribbon Bar



Angle Between Command (Dimension Toolbar)
{button Related Topics,AL("group dimensions high;dimensions high",0,`NOT_FOUND')} {button How To,AL("add
dimension how;dimension group how;place dimension between two how",0,`NOT_FOUND')}

Places a dimension that measures the angle between elements or key points.    You can place angular 
dimensions in stacked or chained dimension groups.    

You can also add angular dimensions to existing dimension groups.

Dimension Ribbon Bar



Coordinate Dimension Command (Dimension Toolbar)
{button Related Topics,AL("coordinate dimensions high;dimensions high",0,`NOT_FOUND')} {button How 
To,AL("add dimension to group how;place dimension group how",0,`NOT_FOUND')}

Places a dimension that measures the distance from a common origin to one or more key points or elements.    
The coordinate dimensions that refer to the common origin are members of a coordinate dimension group.

You can place coordinate dimensions in any order and on either side of the origin with respect to the dimension 
axis. You can also add additional coordinate dimensions to existing coordinate dimension groups.
{mci_left NOMENU,COORDIM1.AVI}

Dimension Ribbon Bar



Axis Command (Dimension Toolbar)
{button Related Topics,AL(`dimensions high',0,`NOT_FOUND')} {button How To,AL(`set dimension axis 
how;place dimension group how;place dimension between two how',0,`NOT_FOUND')}

Sets a dimension axis for a drawing.    A dimension axis allows you to place dimensions that are perpendicular to 
or parallel to an element.

The default axis in a drawing is perpendicular or parallel to the horizontal axis of a drawing sheet.    Dimensions 
placed along the default axis look like this:

After you set a dimension axis with the Axis command, you can now place a dimension that runs parallel or 
perpendicular to the dimension axis that you have defined. To use the axis that you have just specified, you must
set the type of dimension axis that you want to use on the dimension ribbon bar. You do this by clicking the 
Distance Between or Coordinate Dimension buttons on the Dimension Toolbar. Then, you click Explicit in 
the Dimension Axis box on the ribbon bar so that you can use the dimension axis that you set with the Axis 
command.



Distance Between Command (Dimension Toolbar)
{button Related Topics,AL("dimension groups high;dimension cmd;dimensions high;element properties 
cmd",0,`NOT_FOUND')} {button How To,AL("dimension between how;add dimension 
how",0,`NOT_FOUND')}

Places a linear dimension that measures the distance between elements or key points. You can place linear 
dimensions in stacked dimension groups. 

You can place chained dimension groups. 

You can also add linear dimensions to existing linear dimension groups.

Dimension Ribbon Bar



Measure Area Command (Tools Menu)
{button Related Topics,AL("measure high;dimensions high",0,`NOT_FOUND')} {button How To,AL("measure 
area how",0,`NOT_FOUND')}

Measures the area inside a closed boundary. You can use the Measure Area command when you are in the 
middle of another task.

The following measurements appear next to the pointer:

Area

Displays the most recently selected area of the boundary in the current units.

Total

Displays the total area of all selected boundaries in the current document units. You press the Shift key to display
this value.



Measure Distance Command (Tools Menu)
{button Related Topics,AL("measure high cmd;dimensions high",0,`NOT_FOUND')} {button How 
To,AL("measure distance how",0,`NOT_FOUND')}

Measures the distance between points in free space or between key points. When you are in the middle of a 
task, you can measure distances with the Measure Distance command at any time.

When you move the pointer over a key point, the distance between the current location of the pointer and the last
point you clicked appears, along with the delta values. The delta values are the distances, as measured along 
the x and y axes.

When you click a third point, the cumulative distance between the first and last point that you clicked appears 
next to the pointer.

 



Not To Scale Command (Shortcut Menu)
{button Related Topics,AL("dimension cmd;dimensions high",0,`NOT_FOUND')} {button How To,AL("return dim to
actual value how",0,`NOT_FOUND')}

Returns a driven dimension to its actual value. You can use this command only on a dimensional value that has 
been edited. Editing a dimensional value overrides the original value and makes the dimension not-to-scale. For 
example, if you override the dimensional value that is 15 millimeters to be 30 millimeters, the actual size of the 
line that you see would still be 15 millimeters.

Note    Before you can select this command from the shortcut menu, you must select a dimension.



SmartDimension Command (Dimension Toolbar)
{button Related Topics,AL("dimensions high",0,`NOT_FOUND')} {button How To,AL("place dimension 
how",0,`NOT_FOUND')}

Places a dimension for the following:
Length and angle of a line

Radius and diameter of a circle

Length, angle, radius, and diameter of an arc

Radius of an ellipse or curve 

Dimension Ribbon Bar



Symmetric Diameter Command (Dimension Toolbar)
{button Related Topics,AL("dimension groups high;dimensions high",0,`NOT_FOUND')} {button How 
To,AL("place symmetric diameter how;add dimension to group how",0,`NOT_FOUND')}

Places a dimension that measures the distance between a center line and another element or key point, 
multiplies the distance by two, and displays the value as a diameter.    You can place dimensions that measure 
the symmetric diameter of elements in a dimension group.

You can also add additional symmetric diameter dimensions to an existing dimension group.

Dimension Ribbon Bar



Line/Arc Continuous Command (Draw Toolbar)
{button Related Topics,AL("freesketch high;smartsketch high;line high",0,`NOT_FOUND')} {button How 
To,AL("line how",0,`NOT_FOUND')}

Draws one line or a series of connected lines. When you draw a series of lines, the second point of one line is 
the first point of the next line.
{mci_left NOMENU,LINE1.AVI}

You can also draw a continuous series of lines and arcs that can be perpendicular or tangent to each other. You 
can create an open or closed shape by drawing lines and arcs in any combination. The last point of the line or 
arc is the first point of the next line or arc.
{mci_left NOMENU,DLNARC1C.AVI}

Line Ribbon Bar



Delete Node Command (Shortcut Menu)
{button Related Topics,AL("curve cmd;freeform high",0,`NOT_FOUND')} {button How To,AL("curve 
how",0,`NOT_FOUND')}

Deletes a node from a curve. 
Note    Before you can select this command from the shortcut menu, you must locate a curve. 

Curve Ribbon Bar



Insert Node Command (Shortcut Menu)
{button Related Topics,AL("curve cmd;freeform high",0,`NOT_FOUND')} {button How To,AL("curve 
how",0,`NOT_FOUND')}

Adds a node to a curve.
Note    Before you can select this command from the shortcut menu, you must locate the curve.

Curve Ribbon Bar



Point Command
{button Related Topics,AL("freesketch high;smartsketch high;draw high;customize high ",0,`NOT_FOUND')}

{button How To,AL("point how;customize toolbar how",0,`NOT_FOUND')}

Draws a point.    The point is displayed as a filled rectangle.

Note    The Point command is available only if you use the Customize command to place it on a toolbar or 
menu.

Point Ribbon Bar



Rectangle Command (Draw Toolbar)
{button Related Topics,AL("freeform high;smartsketch high;draw high;rectangle high",0,`NOT_FOUND')}

{button How To,AL("rectangle how;rectangle freeform how",0,`NOT_FOUND')}

Draws a rectangle using three points. The first two points define the width and rotation angle of the rectangle, 
and the third point defines the height. You can also draw a square with this command.
{mci_left NOMENU,RECT1.AVI}

Rectangle Ribbon Bar



Drop Complex String Command (Shortcut Menu)
{button Related Topics,AL("circle high",0,`NOT_FOUND')}

Breaks a complex string of elements into individual elements, such as individual arcs, lines, and circles.

To access the Drop Complex String command, point to the complex string and right-click. After you select the 
command from the shortcut menu that appears, the complex string divides into individual elements.



Drop Line String Command (Shortcut Menu)
{button Related Topics,AL("circle high;line high",0,`NOT_FOUND')}

Divides a line string into individual line segments.

To access the Drop Line String command, point to line string and right click. After you select the command from 
the shortcut menu that appears, the line string is divided into individual line segments.



Properties Command (Edit Menu)
{button Related Topics,AL(`edit properties cmd;edit high;applying unique formats high;formatting elements 
high',0,`NOT_FOUND')} {button How To,AL(`format how',0,`NOT_FOUND')}

Edits the properties of a selected element, group, symbol, dimension, or annotation.    If you select a group of 
elements, you can edit only the common properties of that group. You can also edit the properties of a border 
around an inserted object, called a SmartFrame.
Note    Before you can select this command from the shortcut menu, you must locate an element and then click 
the right mouse button.

Element Properties Dialog Box
Dimension Properties Dialog Box
Text Properties Dialog Box
Symbol Properties Dialog Box
Leader Properties Dialog Box
Fill Properties Dialog Box
Balloon Properties Dialog Box
Group Properties Dialog Box
SmartFrame Properties Dialog Box



Open Source Command (Shortcut Menu)
{button Related Topics,AL("variables high;variables cmd",0,`NOT_FOUND')} {button How To,AL("variables 
how",0,`NOT_FOUND')}

Opens a spreadsheet in the Variable Table that has been linked to it with the Paste Link command.
Note    Before you can select this command from the shortcut menu, you must select the Variables command on 
the Tools menu.



Paste Link Command (Shortcut Menu)
{button Related Topics,AL("variables high;variables cmd;paste link cmd",0,`NOT_FOUND')} {button How 
To,AL("variables how",0,`NOT_FOUND')}

Links data in a document to a cell in the Variable Table.
Note    Before you can select this command from the shortcut menu, you must select the Variables command on 
the Tools menu.



Variables Command (Tools Menu)
{button Related Topics,AL("variables high;variables cmd;functions high",0,`NOT_FOUND')} {button How 
To,AL("variables how",0,`NOT_FOUND')}

Accesses the Variable Table, which operates much like a software spreadsheet.    The Variable Table allows 
you to define and manipulate drawing variables and their values, as well as establish functional relationships 
between the design variables.    For example, you can use the Variable Table to create expressions for 
dimensional values.

Variable Table



Filter Command (Shortcut Menu)
{button Related Topics,AL("variables high;variables cmd",0,`NOT_FOUND')} {button How To,AL("variables 
how",0,`NOT_FOUND')}

Restricts the display in the Variable Table to variables that you select on the Filter dialog box.
Note    To select this command from the shortcut menu, you must first select the Variables command on the 
Tools menu and then pause the mouse cursor in the Variable Table window.

Filter Dialog Box



Exit Command (File Menu)
{button Related Topics,AL("save high",0,`NOT_FOUND')} {button How To,AL("close document 
how",0,`NOT_FOUND')}

Closes all open documents and exits the software. If you have made changes since the document was last 
saved or if you have never saved a new document, you are prompted to indicate if you want to save your 
changes. If you do not want to save your changes, click the No button. If you want to save the changes, click the 
Yes button. If you do not want to close the document, click the Cancel button. If you click the Yes button, the 
Save As dialog box is displayed so that you can give the document a name and specify a directory and format to
save it to. 

Save As Dialog Box



Extend to Next Command (Draw Toolbar)
{button Related Topics,AL("extending or trimming high;draw high",0,`NOT_FOUND')} {button How 
To,AL("extend to next how",0,`NOT_FOUND')}

Extends one or more open elements until they intersect with the nearest element in the active window. The 
extension direction is determined by the position where you select the element to extend. For example, if you 
select a horizontal line to the right of its midpoint, the line extends to the right.
{mci_left NOMENU,EXTNXT1C.AVI} 

If there is no possible intersection between the element you want to extend and any other element in the view, 
the command does not extend the element.



Dimension Command (Format Menu)
{button Related Topics,AL("dimensions high;formatting high",0,`NOT_FOUND')} {button How To,AL("format 
dimension how",0,`NOT_FOUND')}

Formats a new dimension as you place it.

Format Dimension Dialog Box



Fill Command (Draw Toolbar)
{button Related Topics,AL("fill cmd;fill high;element properties cmd",0,`NOT_FOUND')} {button How To,AL("fill 
how",0,`NOT_FOUND')}

Places a fill inside a closed boundary.    You can modify fill properties with the Fill ribbon bar.

You can also access this command on the Schematic toolbar.

Fill Ribbon Bar



Layers Command (Tools Menu)
{button Related Topics,AL("layers high;display manager cmd",0,`NOT_FOUND')} {button How 
To,AL(`layers how;filter how',0,`NOT_FOUND')}

Displays or hides layers.    This command also sets the active layer and changes the layer of an element.
Note You can set display criteria for all the sheets and their associated layers in the current document with the 
Display Manager command on the Tools menu.    

Layers Ribbon Bar



Layer Groups Command (Tools Menu)
{button Related Topics,AL("layers high;layers cmd ",0,`NOT_FOUND')} {button How To,AL(`layer groups 
how',0,`NOT_FOUND')}

Creates, modifies, or deletes layers and layer groups. You can only work with layers on the current working 
sheet.

Groups Dialog Box



Fillet Command (Draw Toolbar)
{button Related Topics,AL("draw high;extending or trimming high",0,`NOT_FOUND')} {button How 
To,AL("fillet how",0,`NOT_FOUND')}

Draws a fillet between two elements. The elements can be arcs, lines, circles, ellipses, or curves.
{mci_left NOMENU,FILLET1C.AVI} 

Fillet Ribbon Bar



Display Manager Command (Tools Menu)
{button Related Topics,AL(`layer cmd;layers high',0,`NOT_FOUND')} {button How To,AL(`filter how;layers 
how',0,`NOT_FOUND')}

Specifies the way elements or objects appear in a window for all drawing sheets and their associated layers in 
the document.
Note You can quickly set display options for the current drawing sheet on the Layer Display dialog box. You can 
access the Layer Display dialog box with the Layers command on the Tools menu.

Display Manager Dialog Box



Fit Command (View Menu)
{button Related Topics,AL("views high",0,`NOT_FOUND')} {button How To,AL("fit how",0,`NOT_FOUND')}

Fits all visible elements in the active view. 
Tip    You can also click the right mouse button to access the Fit command on the shortcut menu.



Line Command (Format Menu)
{button Related Topics,AL("styles cmd;line cmd;styles high;formatting elements",0,`NOT_FOUND')}

{button How To,AL("format line how",0,`NOT_FOUND')}

Formats a new line as you place it.

Format Line Dialog Box



Character Map Command (Tools Menu)
{button Related Topics,AL("annotations high",0,`NOT_FOUND')} {button How To,AL("insert font character 
into text box how;place text box how",0,`NOT_FOUND')}

Inserts a character into a text box using a different font. You can also insert special characters that do not have 
corresponding keys on the keyboard. You can use this command when you type or edit text in a text box.
Note    If you are running Windows 95 or a higher version and this command is not available, you must install the 
Character Map accessory. You can add it by clicking the Control Panel icon and then the Add/Remove Programs 
icon. While adding the software, you can find the Character Map software in the Accessories category. For 
detailed instructions on how to add the Character Map accessory, see the Windows 95 on-line Help for 
Add/Remove Programs.    

Unicode Character Map Dialog Box



Text Box Command (Format Menu)
{button Related Topics,AL("text cmd;text high;styles high;formatting elements",0,`NOT_FOUND')} {button How 
To,AL("text how",0,`NOT_FOUND')}

Formats a new text box as you place it.

Format Text Box Dialog Box



Grid Display Command (View Menu)
{button Related Topics,AL("view high;pinpoint high;draw high;grid cmd;grid high",0,`NOT_FOUND')}

{button How To,AL("grid how",0,`NOT_FOUND')}

Displays a grid so that you can place elements with precision. The grid is not part of the document and does not 
print.

{mci_left NOMENU,GRID2.AVI} 
You can also access this command on the Schematic toolbar.
Tip You can also access the Grid Display command by clicking the right mouse button. You can change the grid
display from static to dynamic by setting options on the View tab of the Options dialog box. 



Grid Snap Command (View Menu)
{button Related Topics,AL("view high;pinpoint high;draw high;grid cmd;grid high",0,`NOT_FOUND')}

{button How To,AL("grid how",0,`NOT_FOUND')}

Aligns elements with the grid. The grid is an invisible set of lines in the document that helps you align elements. 
When you set the Grid Snap option, elements always align with the grid lines or nearest intersection of the grid 
lines. Grid lines do not print.

{mci_left NOMENU,GRID1.AVI} 
You can also access this command on the Schematic toolbar.
Tip You can also access the Grid Snap command by clicking the right mouse button. You can change the grid 
display by setting options on the View tab of the Options dialog box.

Relationship and alignment indicators override the grid snap. You can suppress the indicators by holding down 
the Alt key on the keyboard.
Caution    You cannot place elements with the Pinpoint button on the Main toolbar if you are using the Grid 
Snap command.

 



Group Command (Change Toolbar)
{button Related Topics,AL("groups high;group cmd",0,`NOT_FOUND')} {button How To,AL("group 
how",0,`NOT_FOUND')}

Binds elements so you can locate, select, and manipulate them as a unit. Grouped elements are usually related, 
such as the holes and center lines of a bolt hole pattern. When you select a group, the Group ribbon bar is 
displayed so you can edit the entire group or any of its members.

Group Ribbon Bar



Restore Command (Control Menu)
{button Related Topics,AL("ui high",0,`NOT_FOUND')}

Restores the window to its previous size and location.



Close Command (Control Menu)
{button Related Topics,AL("ui high",0,`NOT_FOUND')}

Closes the active program or document. If the open document contains unsaved changes, you will be prompted 
to save the changes.



Maximize Command (Control Menu)
{button Related Topics,AL("ui high",0,`NOT_FOUND')}

Enlarges the application or document window to fill the screen. Double-click the title bar to restore the window to 
its previous size and location.



Move Command (Control Menu)
{button Related Topics,AL("ui high",0,`NOT_FOUND')}

Allows you to use the arrow keys on the keyboard to change the location of the application or document window.



Size Command (Control Menu)
{button Related Topics,AL("ui high",0,`NOT_FOUND')}

Activates the arrow keys so that you can change the size of the application or document window. 



Minimize Command (Control Menu)
{button Related Topics,AL("ui high",0,`NOT_FOUND')}

Reduces a program or window to a button on the taskbar. To restore the window to its previous size and location,
click the button on the taskbar.



Next Command (Control Menu)
{button Related Topics,AL("ui high",0,`NOT_FOUND')}

Allows you to switch to the next document.



SmartSketch Help Topics Command (Help Menu)
{button Related Topics,AL("help high",0,`NOT_FOUND')} {button How To,AL("topics how",0,`NOT_FOUND')}

Displays the table of contents for the SmartSketch Help topics, which include step-by-step instructions for using 
the software, reference information, examples of features, and technical support information. It also provides 
access to the Help index and full-text search.



Image Command (Insert Menu)
{button Related Topics,AL("raster high",0,`NOT_FOUND')} {button How To,AL("insert raster image 
how",0,`NOT_FOUND')}

Places a raster image into a SmartSketch document.

Tip    To use this command, you must first install ImageScape LT with Add-Ins on the Tools menu. If you do not 
see the add-in listed in the Add-In Manager, you must run Setup again and select the Custom installation. You 
can then select an option for the add-in. 



Object Command (Insert Menu)
{button Related Topics,AL("importing objects high;ole high;raster high",0,`NOT_FOUND')} {button How 
To,AL("insert raster image how;ole how",0,`NOT_FOUND')}

Inserts objects into a document through linking and embedding. The difference between linking and embedding 
is how data is stored and updated. The Object command inserts any OLE 2.0 enabled object, such as a Word or
.AVI document, or CAD document, such as a .dwg document. The inserted object can then be edited by double-
clicking it.

When you link an object to a document, the document stores information about where the object is located—
the object is not stored in the document. When you embed an object in a document, a copy of the object is stored in 
the document.

When you make changes to a linked object, all documents that have links to that object update. When you 
make changes to an embedded object, only the copy of the object that is stored in the document updates.

Insert Object Dialog Box



SmartSketch on the Web Command (Help Menu)
{button Related Topics,AL("help high;internet high",0,`NOT_FOUND')} {button How To,AL("internet community 
how",0,`NOT_FOUND')}

Activates your World Wide Web browser and opens the SmartSketch World Wide Web page. On this page, you 
can access registration and support information, learning tools, and other items to help you use SmartSketch 
more efficiently.



Links Command (Edit Menu)
{button Related Topics,AL("links cmd;links high;ole high",0,`NOT_FOUND')} {button How To,AL("edit link 
how;unload how",0,`NOT_FOUND')}

Edits or updates links to objects in another document.

Links Dialog Box



Macro Command (Tools Menu)
{button Related Topics,AL("customize high",0,`NOT_FOUND')} {button How To,AL("macro 
how",0,`NOT_FOUND')}

Runs a macro.

Run Macro Dialog Box



Mirror Command (Change Toolbar)
{button Related Topics,AL("mirroring elements high;draw high",0,`NOT_FOUND')} {button How 
To,AL("mirror how",0,`NOT_FOUND')}

Mirrors one or more selected elements about a line or axis that you define. You can mirror without copying, or 
mirror and copy.
{mci_left NOMENU,MIRROR1C.AVI} 

Mirror Ribbon Bar



Linked Object Edit Command (Edit Menu)
{button Related Topics,AL("link and embed high ",0,`NOT_FOUND')} {button How To,AL("foreign data how ;ole 
how ",0,`NOT_FOUND')}

Opens the selected linked document for editing.



Linked Object Open Command (Edit Menu)
{button Related Topics,AL("link and embed high",0,`NOT_FOUND')} {button How To,AL("foreign data how;ole 
how",0,`NOT_FOUND')}

Opens the selected document and activates the software used to create it.



Most Recently Used Files Command (File Menu)
{button Related Topics,AL("documents high",0,`NOT_FOUND')} {button How To,AL("open 
how",0,`NOT_FOUND')}

Opens one of the documents that you worked on most recently. The file names are listed near the bottom of the 
File menu. You can change the number of files listed on the menu with the Options command.



Move Command (Change Toolbar)
{button Related Topics,AL("moving elements high",0,`NOT_FOUND')} {button How To,AL("move element 
how",0,`NOT_FOUND')}

Moves elements from one location to another. You can specify the locations by clicking on the drawing sheet or 
by entering values in the ribbon bar. You can move one or more elements at a time, and you can move element 
groups. 

Move Ribbon Bar



New Command (File Menu)
{button Related Topics,AL("files high;documents high;",0,`NOT_FOUND')} {button How To,AL("create 
document how",0,`NOT_FOUND')}

Creates a new document or template. You can use a template to create the document.

File New Dialog Box



Office Compatible Command (Help Menu)
{button Related Topics,AL("help high",0,`NOT_FOUND')} {button How To,AL("office how",0,`NOT_FOUND')}

Displays Help topics that describe the compatibility of SmartSketch with Microsoft Office.    It provides information
on important Microsoft Office compatibility features, compares those features between SmartSketch and 
Microsoft Office, and describes how SmartSketch can be used with Microsoft Office.



Offset Command
{button Related Topics,AL("copy high",0,`NOT_FOUND')} {button How To,AL("offset how",0,`NOT_FOUND')} 

Draws an offset copy of an element or a set of contiguous elements. This command copies elements while 
maintaining characteristics such as the angle of lines and the center point of arcs and circles.

Offset copies the original element at a specified distance. Offsetting outside the perimeter of the original element
creates a larger element. Offsetting inside the perimeter of the original element creates a smaller element.

Elements are transitioned as necessary during the offset operation.

Offset Ribbon Bar



Open Command (File Menu)
{button Related Topics,AL("open cmd;documents high;files high",0,`NOT_FOUND')} {button How 
To,AL("open how;open AutoCAD or MicroStation document how",0,`NOT_FOUND')}

Opens an existing document or template in a new window.

File Open Dialog Box



Options Command (Tools Menu)
{button Related Topics,AL("customize high;ole high",0,`NOT_FOUND')} {button How To,AL("options 
how",0,`NOT_FOUND')}

Changes settings that control document translation, screen appearance, document location, user information, 
and so forth. You can set options for bringing MicroStation or AutoCAD documents into the software. 

Options Dialog Box



Pan Command (View Menu)
{button Related Topics,AL("views high",0,`NOT_FOUND')} {button How To,AL("pan views 
how",0,`NOT_FOUND')}

Allows you to move in any direction from a specific point in a document to see other areas of the drawing or 
model.
Tip    You can also right click to access the Pan command on the shortcut menu.



Paste Command (Edit Menu)
{button Related Topics,AL("cutting high",0,`NOT_FOUND')} {button How To,AL("paste how",0,`NOT_FOUND')}

Inserts the Clipboard contents at the same coordinates the elements had in the source document. The 
command is not available if the Clipboard is empty.



PinPoint Command (Tools Menu)
{button Related Topics,AL("pinpoint high;draw high",0,`NOT_FOUND')}{button How To,AL("pinpoint 
how",0,`NOT_FOUND')}

Helps you draw elements with precision by displaying coordinate data at the pointer. The displayed coordinates 
are relative to a target position that you set—you can reset the target position at any time.

Using PinPoint, you can draw elements at known locations on the drawing sheet, draw elements known 
distances apart, and so forth. You can use PinPoint with all drawing commands
Caution    You cannot place elements with the Pinpoint button on the Main toolbar if you are using the Grid 
Snap command.

PinPoint Ribbon Bar



Position Command (Shortcut Menu)
{button Related Topics,AL("raster high",0,`NOT_FOUND')} {button How To,AL("position 
how",0,`NOT_FOUND')}

Positions an image in a document. You can move, scale, rotate, and skew a source image to match a target 
image or vector frame. All alignment modifications are made by placing up to three source points and three target
points. You can define source points by clicking and dragging or by a single click on the source image.
Note    To select this command on the shortcut menu, you must first select a raster image and then click the right 
mouse button.



Previous Command (View Menu)
{button Related Topics,AL("views high",0,`NOT_FOUND')} {button How To,AL("restore views 
how",0,`NOT_FOUND')}

Restores the previous view.
Tip    You can also click the right mouse button to access the Previous command on the shortcut menu.



Print Command (File Menu)
{button Related Topics,AL("print high;documents high",0,`NOT_FOUND')} {button How To,AL("print 
how",0,`NOT_FOUND')}

Sends a copy of the active document to a specified plotter, printer, or file. Options are available for defining the 
printing area, range, number of copies, and other printing characteristics.

Before using this command, you must install and select a printer. For help on installing a printer, see the 
Windows documentation.

Print Dialog Box



Programming with SmartSketch Command (Help Menu)
{button Related Topics,AL("custom high;help high",0,`NOT_FOUND')} {button How To,AL("programming 
how",0,`NOT_FOUND')}

Displays Help topics that help you learn to customize the software using Visual Basic. The Help topics also 
provide reference information for the objects, methods, properties, and events (custom controls only) exposed by
the product. 

The topics include sample Visual Basic code, as well as selectable automation object models, illustrations, 
descriptions, and syntax details.



Properties Command (File Menu)
{button Related Topics,AL("properties cmd;file properties high",0,`NOT_FOUND')} {button How 
To,AL("properties how",0,`NOT_FOUND')}

Accesses general information about the current document. You can review and edit the following document 
information: the document summary, statistics, and Browser properties. If a symbol document (.sym) is open, 
you can review and edit the general, unit, and specific symbol properties for the document.

Properties Dialog Box



Paste Special Command (Edit Menu)
{button Related Topics,AL("ole high;copy high",0,`NOT_FOUND')} {button How To,AL("paste special 
how",0,`NOT_FOUND')}

Inserts the Clipboard contents into a document using a selected format.

Paste Special Dialog Box



Pull Up Command (Change Toolbar)
{button Related Topics,AL("display order high;display order cmd ",0,`NOT_FOUND')} {button How To,AL("pull
up how;send to front how",0,`NOT_FOUND')}

Moves one or more selected elements or element groups up one position in the display order.
{mci_left NOMENU,PULLUP.AVI}

If more than one element overlaps the selected elements, the selected elements do not move all the way to the 
front. To quickly move elements to the front, click the Bring To Front button.



Push Down Command (Change Toolbar)
{button Related Topics,AL("display order high;display order cmd ",0,`NOT_FOUND')} {button How 
To,AL("push down how;send to back how",0,`NOT_FOUND')}

Moves one or more selected elements or element groups down one position in the display order.

{mci_left NOMENU,PUSHDOWN.AVI}

If the selected elements overlap more than one other element, the selected elements do not move all the way to 
the back. To quickly move elements to the back, click the Send To Back button.



Rectangular Pattern Command (Change Toolbar)
{button Related Topics,AL("patterns high;pattern cmd",0,`NOT_FOUND')} {button How To,AL("rectangular 
pattern how",0,`NOT_FOUND')}

Copies selected elements in a rectangular pattern on the drawing sheet.
{mci_left NOMENU,RECPTN1.AVI}

Rectangular Pattern Ribbon Bar



Redo Command (Edit Menu)
{button Related Topics,AL("draw high",0,`NOT_FOUND')} {button How To,AL("redo action 
how",0,`NOT_FOUND')}

Repeats the most recent action taken or reverses the most recent "undo". For example, Repeat Typing displays 
in the Edit menu if you just typed something in the document. 
Note  You can place the Undo List or Redo List buttons on the Main toolbar by clicking the Customize 
command on the Tools menu.



Register Command (Help Menu)
{button Related Topics,AL("help high",0,`NOT_FOUND')} {button How To,AL("register 
how",0,`NOT_FOUND')}

Allows you to register the software from a web page.



Redo List Command (Edit Menu)
{button Related Topics,AL("draw high;options cmd",0,`NOT_FOUND')} {button How To,AL("redo action 
how",0,`NOT_FOUND')}

Repeats the most recent action taken based on what you select on the list.
Note  To use the Redo List command, you must place it on the Main toolbar or Edit menu by clicking the 
Customize command on the Tools menu. You must click the Edit category.



Revert Command (File Menu)
{button Related Topics,AL("ole high",0,`NOT_FOUND')} {button How To,AL("revert imag 
how",0,`NOT_FOUND')}

Closes a document opened by double-clicking on it without saving any changes to the document.



Rotate Command (Change Toolbar)
{button Related Topics,AL("rotating elements high",0,`NOT_FOUND')} {button How To,AL("rotate element 
how",0,`NOT_FOUND')}

Rotates one or more elements a precise distance or angle about a specified point.
{mci_left NOMENU,ROTATE1.AVI}

Rotate Ribbon Bar



Save Command (File Menu)
{button Related Topics,AL("save high;documents high",0,`NOT_FOUND')} {button How To,AL("save 
how",0,`NOT_FOUND')}

Saves the active document with its currently defined name, directory, and format.    If you are saving the 
document for the first time, the Save As dialog box is displayed so that you can give the document a name and 
specify a directory and format to save it to.

Save As Dialog Box



Save As Command (File Menu)
{button Related Topics,AL("save high;documents high",0,`NOT_FOUND')} {button How To,AL("save 
how",0,`NOT_FOUND')}

Saves the active document to a new name, directory, and format.

Save As Dialog Box



Save As Template Command (File Menu)
{button Related Topics,AL("save high;documents high",0,`NOT_FOUND')} {button How To,AL("save 
how",0,`NOT_FOUND')}

Saves a document as a template. The template is stored in the TEMPLATE directory in the directory where you 
installed the software.

Save As Dialog Box

 



Save As Web Page Command (File Menu)
{button Related Topics,AL("save high;documents high",0,`NOT_FOUND')} {button How To,AL("save 
how",0,`NOT_FOUND')}

Saves the current document as a .cgm graphic embedded in an HTML document. You can view the HTML 
document as a web page in any Internet browser, such as Netscape Navigator™ or Internet Explorer.

This command starts a wizard that steps you through the process of saving your document as an HTML page.

Save As Dialog Box

 



Scale Command (Change Toolbar)
{button Related Topics,AL("scaling elements high",0,`NOT_FOUND')} {button How To,AL("scale how 
",0,`NOT_FOUND')}

Reduces or enlarges selected elements by a scale factor that you define. The scale factor is the same along the 
X and Y axes.    Scalable elements include framed elements, such as text boxes.    You can use the Scale 
command to scale, or to simultaneously scale and copy.

Scale Ribbon Bar



Select All Command (Edit Menu)
{button Related Topics,AL("object element selection high",0,`NOT_FOUND')} {button How To,AL("select 
element how ",0,`NOT_FOUND')}

Selects all visible elements in a window.
Tip    You can also access this command when you position the pointer in the document and click the right mouse
button.



Select Tool (Draw Toolbar)
{button Related Topics,AL("object element selection high;select cmd",0,`NOT_FOUND')} {button How 
To,AL("select how",0,`NOT_FOUND')}

Changes the pointer to the arrow-shaped selection cursor so that you can select, modify, and manipulate 
elements.    The circle at the end of the pointer arrow is the locate zone.

Select Tool Ribbon Bar



Send Command (File Menu)
{button Related Topics,AL("send cmd;file high;documents high;save high",0,`NOT_FOUND')} {button How 
To,AL("send how",0,`NOT_FOUND')}

Activates your electronic mail application so you can send a mail message with the active document attached.



Delete Sheet Command (Edit Menu)
{button Related Topics,AL("drawing sheets high;drawing sheet tabs high",0,`NOT_FOUND')} {button How 
To,AL("delete drawing sheet how",0,`NOT_FOUND')}

Deletes the active drawing sheet and any other sheets whose tabs are selected.

You can delete either a working sheet or a background sheet with this command.    To delete a background sheet,
set the Background Sheets toggle on the View menu before selecting the Delete Sheet command.    To delete 
a working sheet, clear the Background Sheets toggle before selecting Delete Sheet.



Background Sheets Command (View Menu)
{button Related Topics,AL("drawing sheets high;sheet setup cmd",0,`NOT_FOUND')} {button How 
To,AL("sheets how",0,`NOT_FOUND')}

Switches the view from a working sheet to the background sheet. When you set this toggle, all of the background
sheets in the document are displayed as tabs at the bottom of window. All working sheet tabs are hidden. You 
can use a background sheet to draw graphics that you want to display on more than one drawing sheet. For 
example, you can draw borders and title blocks that contain your company logo, your name, and information 
about the drawings.

You can display background sheet graphics on any or all working sheets, using the Sheet Setup command.



New Sheet Command (Insert Menu)
{button Related Topics,AL("drawing sheets high;drawing sheet tabs high",0,`NOT_FOUND')} {button How 
To,AL("create a new drawing sheet how;change background sheet how",0,`NOT_FOUND')}

Creates a new drawing sheet in the document using the default drawing sheet settings.    You can change the 
default settings using the Sheet Setup command.

You can create either a working sheet or a background sheet with this command.    To create a background 
sheet, set the Background Sheets toggle on the View menu before selecting the New Sheet command.    To 
create a working sheet, clear the Background Sheets toggle before selecting New Sheet.

Sheet Setup Dialog Box



Working Sheets Command (View Menu)
{button Related Topics,AL("drawing sheets high;drawing sheet tabs high",0,`NOT_FOUND')} {button How 
To,AL("sheets how",0,`NOT_FOUND')}

Displays all working sheets in a document.    If a background sheet is attached to the working sheet, the graphics 
on the background sheet are displayed on the working sheet.    When you attach a background sheet to a 
working sheet, the software automatically adjusts the size and the margin of the working sheet to match the size 
and margin of the background sheet.



Sheet Setup Command (File Menu)
{button Related Topics,AL("drawing sheets high",0,`NOT_FOUND')} {button How To,AL("sheets how;rename 
drawing sheet how",0,`NOT_FOUND')}

Defines the properties of the working sheet. You can display and modify the following properties: the name, size, 
and scale used in the working sheet; and the properties of the working sheet margin.    You can also select the 
background sheet you want to use.

You can save settings only for the active working sheet. These settings can also be saved so that they are used 
when you add a new working sheet to the document. To display a working sheet, use the Working Sheets 
command.

Sheet Setup Dialog Box



Rename Command (Shortcut Menu)
{button Related Topics,AL("drawing sheets high;drawing sheet tabs high",0,`NOT_FOUND')} {button How 
To,AL("create a new drawing sheet how;rename drawing sheet how",0,`NOT_FOUND')}

Renames a sheet.
Note    Before you can select this command from the shortcut menu, you must move the pointer over a drawing 
sheet tab. 

Rename Dialog Box



Select All Sheets (Shortcut Menu)
{button Related Topics,AL("drawing sheets high",0,`NOT_FOUND')} {button How To,AL("display sheets 
how",0,`NOT_FOUND')}

Selects all the drawing sheets in the document.    When you select all the sheets, all elements in the document 
are displayed at once.    

Note    Before you can select this command from the shortcut menu, you must move the pointer over a drawing 
sheet tab. 



Insert (Shortcut Menu)
{button Related Topics,AL("drawing sheets high;drawing sheet tabs high",0,`NOT_FOUND')} {button How 
To,AL("create new drawing sheet how;change background sheet how",0,`NOT_FOUND')}

Inserts a new drawing sheet in the document.    

Note    Before you can select this command from the shortcut menu, you must move the pointer over a drawing 
sheet tab and click the right mouse button. 



SmartSketch Settings Command (Tools Menu)
{button Related Topics,AL("smartsketch high",0,`NOT_FOUND')} {button How To,AL("smartsketch 
how",0,`NOT_FOUND')} {button How To,AL("smartsketch ex",0,`NOT_FOUND')}

Sets up what relatinships are recognized by the software.    The relationships selected on the SmartSketch 
dialog box are recognized as you draw.    

SmartSketch Dialog Box



Send To Back Command (Change Toolbar)
{button Related Topics,AL("display order high;display order cmd",0,`NOT_FOUND')} {button How 
To,AL("send to back how",0,`NOT_FOUND')}

Moves one or more selected elements or element groups to the back of the display order.

{mci_left NOMENU,SBACK.AVI} 



Style Command (Format Menu)
{button Related Topics,AL("style cmds;styles high",0,`NOT_FOUND')} {button How To,AL("style 
how",0,`NOT_FOUND')}

Modifies, creates, deletes, or applies styles.

Style Dialog Box



Save Copy As Command (File Menu)
{button Related Topics,AL("save high;ole high",0,`NOT_FOUND')} {button How To,AL("save 
how",0,`NOT_FOUND')}

Saves the active document to a new name, directory, and format. This command appears on the File menu 
when you double-click an inserted object on the drawing sheet.

Save As Dialog Box



Text Box Command (Draw Toolbar)
{button Related Topics,AL("text cmd;annotations high",0,`NOT_FOUND')} {button How To,AL("text 
how",0,`NOT_FOUND')}

Places a text box in a document.

You can find this command in the following locations:
Draw toolbar
Schematic toolbar

Text Box Ribbon Bar



Tip of the Day Command (Help Menu)
{button Related Topics,AL("help high",0,`NOT_FOUND')} {button How To,AL("tip how",0,`NOT_FOUND')}

Displays tips about using features in the software.    This command also offers a tip each time you start the 
software.

Tip of the Day   Dialog Box  



Toolbars Command (View Menu)
{button Related Topics,AL("views high;customize high",0,`NOT_FOUND')} {button How To,AL("display 
toolbar how;customize toolbar how",0,`NOT_FOUND')}

Creates new toolbars and displays or hides selected toolbars.    You can also change toolbar color schemes and 
button sizes.

Toolbars   Dialog Box  



Trim Command (Draw Toolbar)
{button Related Topics,AL("extending or trimming high",0,`NOT_FOUND')} {button How To,AL("trim how 
",0,`NOT_FOUND')}

Trims open and closed elements to the closest intersection in both directions.
{mci_left NOMENU,TRIM1C.AVI} 



Learning Center Command (Help Menu)
{button Related Topics,AL("help high",0,`NOT_FOUND')} {button How To,AL("tutorials 
how",0,`NOT_FOUND')}

Accesses a set of multi-media tutorials to help you get up and running with the software.



Undo Command (Edit Menu)
{button Related Topics,AL("draw high;options cmd",0,`NOT_FOUND')} {button How To,AL("undo action 
how;undo image how",0,`NOT_FOUND')}

Reverses an action. You can change the number of actions that can be undone using the Options command. 
You then click the General tab on the Options dialog box.
Note  You can place the Undo List or Redo List buttons on the Main toolbar by clicking the Customize 
command on the Tools menu.



UnGroup Command (Change Toolbar)
{button Related Topics,AL("groups high;group cmd",0,`NOT_FOUND')} {button How To,AL("group 
how",0,`NOT_FOUND')}

Removes elements from groups that were defined with the Group command. You can remove individual 
elements from a group.



Undo List Command (Edit Menu)
{button Related Topics,AL("draw high;options cmd",0,`NOT_FOUND')} {button How To,AL("undo action 
how;undo image how",0,`NOT_FOUND')}

Reverses an action based on what you select on the list.
You can change the number of actions that can be undone using the Options command.
View manipulations are not included in the action list.

Note  To use the Undo List command, you must place it on a toolbar or menu by clicking the Customize 
command on the Tools menu. You must click the Edit category.



Update Command (File Menu)
{button Related Topics,AL("save high;ole high",0,`NOT_FOUND')} {button How To,AL("save 
how",0,`NOT_FOUND')}

Updates the active document with the information that you just placed in the document for the object. This 
command appears on the File menu when you double-click an inserted object in a document.



New Window Command (Window Menu)
{button Related Topics,AL("window cmd;views high",0,`NOT_FOUND')} {button How To,AL("window 
how",0,`NOT_FOUND')}

Opens a new window that displays the same document as the active window. The new window appears on top of
all the other windows and becomes the active window. If you change the contents of the open document in one 
window, the other windows that contain the same document reflect the changes.



Window List Command (Window Menu)
{button Related Topics,AL("window cmd;views high",0,`NOT_FOUND')} {button How To,AL("window 
how",0,`NOT_FOUND')}

Displays an alphabetical list of open document windows below the commands on the Window menu. You can 
easily access another open document by clicking one of the window names on the list.



Tile Horizontal Command (Window Menu)
{button Related Topics,AL("window cmd;views high",0,`NOT_FOUND')} {button How To,AL("window 
how",0,`NOT_FOUND')}

Arranges windows to fit horizontally on the screen. All the windows appear at an even distance from each other 
on the screen.



Tile Vertical Command (Window Menu)
{button Related Topics,AL("window cmd;views high",0,`NOT_FOUND')} {button How To,AL("window 
how",0,`NOT_FOUND')}

Arranges windows to fit vertically on the screen. All the windows appear at an even distance from each other on 
the screen.



Cascade Command (Window Menu)
{button Related Topics,AL("window cmd;views high",0,`NOT_FOUND')} {button How To,AL("window 
how",0,`NOT_FOUND')}

Overlaps windows diagonally across the screen.



Zoom Area Command (View Menu)
{button Related Topics,AL("views high",0,`NOT_FOUND')} {button How To,AL("zoom in on area how 
",0,`NOT_FOUND')}

Enlarges the display of elements in the active window.

Tips
If you have an IntelliMouse or a three-button mouse, you can zoom an area by holding the Ctrl key, pressing

the mouse wheel or middle mouse button, and dragging the pointer. To stop the repainting of elements in the window,
press Esc. This feature is convenient if you are working with a large document. To refresh the window, press F5.

You can also right click to access the Zoom Area command on the shortcut menu.



Zoom In Command (View Menu)
{button Related Topics,AL("views high",0,`NOT_FOUND')} {button How To,AL("zoom in views how 
",0,`NOT_FOUND')}

Enlarges the display of elements around a specified point in the active window.

Tips
If you have an IntelliMouse or a three-button mouse, you can zoom in by rolling the wheel of the 

IntelliMouse. To stop the repainting of elements in the window, press Esc. This feature is convenient if you are 
working with a large document. To refresh the window, press F5.

You can also click the right mouse button to access the Zoom In command on the shortcut menu.



Zoom Out Command (View Menu)
{button Related Topics,AL("views high",0,`NOT_FOUND')} {button How To,AL("zoom out views 
how",0,`NOT_FOUND')}

Reduces the display of elements around a specified point in the active window.

Tips
You can also zoom out by rolling the wheel of the IntelliMouse. To stop the repainting of elements in the 

window, press Esc. This feature is convenient if you are working with a large document. To refresh the window, press 
F5.

You can also click the right mouse button to access the Zoom Out command on the shortcut menu.



Attribute Viewer
{button Related Topics,AL("av high",0,`NOT_FOUND')} {button How To,AL("attribute 
how",0,`NOT_FOUND')}

Displays user-defined properties and parameters of an element,symbol, or inserted document. The viewer 
displays two columns, one for the name of the attribute and one for the value. User-defined properties appear in 
plain text. Parameters appear in bold text.

You can specify user-defined properties on the User tab of the Properties dialog box for an element or symbol.

Dialog Box Options

Name

Displays the name of a user-defined property or parameter. Parameters are displayed in bold text. The Name is 
read-only.

Value

Displays the value of a property or parameter. Parameters are displayed in bold text. You can change the value.



AutoSave Dialog Box
{button Related Topics,AL("autosave high;autosave cmd",0,`NOT_FOUND')} {button How To,AL("autosave 
how",0,`NOT_FOUND')}

AutoSave Options

Automatic Save Every __ Minutes

Automatically saves open documents at the interval you specify.

Save Options

Saves either the active document or all documents that are open.

Save Active Document Only

Saves only the active document.

The Save As dialog box appears if the document has not yet been saved.

Save All Open Documents

Saves all documents that are open.

The Save As dialog box appears for each document that has not yet been saved.

Prompt Before Saving

Displays a dialog box whenever AutoSave begins saving documents. You can click one of the following buttons 
to answer the dialog box question: "Save changes in <document name>?"

Save

Saves the document.

Skip

Skips to the next document. Does not save the current document. Available only when Save All Open 
Documents is selected.

Cancel

Cancels the current AutoSave session.



Set Bearing Dialog Box
{button Related Topics,AL("bearing azimuth high;bearing azimuth cmd",0,`NOT_FOUND')} {button How 
To,AL("set bearing azimuth how",0,`NOT_FOUND')}

Controls the selection of Default, Bearing, and Azimuth angle settings. Also controls the azimuth settings for 
Base Bearing and Direction.

Tip    The Bearing and Azimuth command is available only if you use the Customize command on the Tools 
menu to place it on a toolbar or menu. On the Toolbars tab of the Customize dialog box, click the Tools 
category to access the command.

Dialog Box Options

Default

Sets defaults for bearing and azimuth.

Bearing

Determination of position to refer to an angle. 

Azimuth

Horizontal direction expressed as an angle, progressing from a fixed point, based on a circle. 

Base Bearing

Direction (North, South, East, West) bearing to refer to an angle. 

Direction

Clockwise or counterclockwise indicator for the angle bearing. 



Browse Dialog Box
{button Related Topics,AL("open cmd",0,`NOT_FOUND')} {button How To,AL("open how",0,`NOT_FOUND')}

Controls how a document is opened.

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.

When you position the pointer in this dialog box and right-click, you can access a variety of standard commands 
that help you manage your documents more efficiently. For example, if you select a document in the list and then
right-click, you can then click the Select command on the shortcut menu to automatically open the document. 
You can also create shortcuts, send the document somewhere else, and other activities.
 
 



Symbol Explorer Window
{button Related Topics,AL("placing symbols high;Symbol Explorer high;symbols cmd;Symbol Explorer 
cmd;attribute viewer db;av high",0,`NOT_FOUND')} {button How To,AL("symbols how;Symbol Explorer 
how",0,`NOT_FOUND')}

Displays files in a directory or World Wide Web pages (HTML pages). You can use the Symbol Explorer window
just like you would the Windows Explorer or Windows Internet Explorer. You can also use the Symbol Explorer 
to drag symbols (.sym) from the Symbol Explorer window to the current document.
Tip    Within the Symbol Explorer window, you can access several commands that allow you to change or filter 
the view in the window. For example, you can change the window to show only symbols. You can also add 
directories or web addresses to a list of favorites. If you want to place several copies of a symbol, you can click 
the Stamp Here command. To access these commands, place the pointer in the Symbol Explorer window and 
right-click.

Window Options

Back

Takes you backward to the previous location of the Symbol Explorer, either a web page or a directory path.

Forward

Takes you forward to the previous location of the Symbol Explorer, either a web page or a directory path.

Stop

Halts the loading of an HTML page.

Refresh

Reloads the current HTML page or directory.

Home

Takes the Symbol Explorer back to the home page that you set with the Properties command on the File 
menu. If you do not set the home page with this command, the Symbol Explorer opens the symbols directory 
associated with the template that the active document is based on.

Explore Elsewhere

Accesses the Browse for Folder dialog box so that you can locate another directory for the Symbol Explorer to
look in. You can use the dialog box to look in directories on your hard drive or a network drive.

Address 

Sets the current location for the Symbol Explorer. You can type in a directory or a World Wide Web address and
then press Enter. Some examples of what you can type in are as follows:

http://www.ingr.com

C:\PROGRAM FILES\DRAWINGS\
Tip    If you want to view an HTML page on your hard drive, you must enter the entire path and filename in the 
address box.

If you set the path of the Symbol Explorer to point to a directory, you'll see a tree view, the contents of the 
directory, and the Attribute Viewer. If you set the path to an HTML page, you'll see the contents of that page, if 
Microsoft Internet Explorer 3.0 or later is loaded on the box. If Internet Explorer is not loaded, then the 



software prompts you to load it.



Connector Ribbon Bar
{button Related Topics,AL("connector command",0,`NOT_FOUND')} {button How To,AL("place connector 
how;modify connector how",0,`NOT_FOUND')}

When you click the Connector command on the Draw toolbar, you can place a connector. When you select a 
connector, you can change it. 

Most of the options on the Connector ribbon bar are the same whether you are placing or modifying a 
connector. The only difference is when you select a connector for modification. When you modify a connector, an
additional option is available to insert a segment into the selected connector. This last option is Insert Segment 
Mode (Shift).

Ribbon Box Options

Style

Sets the line style for the connector.

Line Color

Sets the line color for the connector. You can click the More option to define custom colors with the Colors dialog
box.

Line Type

Sets the connector line type and style.

Line Width

Sets the line width for the connector.

Line Start Terminator

Sets the terminator for starting the connector.

Line End Terminator

Sets the terminator for ending the connector.
Tip    Terminators are compatible with any of the linear styles.

Clearance

Specifies the amount of space that is maintained between the connector and the connected element. (Also 
known as range avoidance.)

Diagonal Mode (Alt)

Allows you to either place or modify a connector.

Placing a Connector

Switches the connector placement between drawing horizontal and vertical line segments or drawing 
diagonal line segments when you place a connector. 
Tip  To alternate between drawing horizontal and vertical line segments or drawing diagonal line segments, 
you can also press the Alt key. 

Modifying a Connector

Inserts a vertex in a line segment of the connector when you are modifying a selected connector. 
Tip    This option is active only when you click the Diagonal Mode (Alt) button or when you press the Alt 
key. 

Insert Segment Mode (Shift) 

Inserts line segments into the connector. This option is available only when you are modifying a connector. 
Tip    This option is active when you click the Insert Segment Mode (Shift) button or when you press the Shift 
key.



Isometric Circle Ribbon Bar
{button Related Topics,AL("iso circle cmd;iso high",0,`NOT_FOUND')} {button How To,AL("iso circle 
how",0,`NOT_FOUND')}

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Top

Allows you to draw the circle on the top plane.

 

Right

Allows you to draw the circle on the right plane.

 

Left

Allows you to draw the circle on the left plane.

 

Diameter

Sets the diameter of the isometric circle.

Radius 

Defines the radius of the isometric circle. 



Isometric Line Ribbon Bar
{button Related Topics,AL("iso high;iso line cmd",0,`NOT_FOUND')} {button How To,AL("iso line 
how",0,`NOT_FOUND')}

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Length

Sets the length of the isometric line.

Angle 

Sets the angle of the isometric line.



Isometric Rectangle Ribbon Bar
{button Related Topics,AL("iso high;iso rectangle cmd",0,`NOT_FOUND')} {button How To,AL("iso rectangle
how",0,`NOT_FOUND')}

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Top

Allows you to draw the rectangle on the top plane.

 

Right

Allows you to draw the rectangle on the right plane.

 

Left

Allows you to draw the rectangle on the left plane.

 

Width

Sets the width of the isometric rectangle.

Height 

Sets the height of the isometric rectangle.



Move Sheet Border Dialog Box
{button Related Topics,AL("sheet setup db;move sheet setup size;sheet origin location db",0,`NOT_FOUND')}

{button How To,AL("move sheet how;setup sheet how",0,`NOT_FOUND')}

Allows you to reposition or scale a working sheet and selects paper size. 
Tip    When you click the settings that you want on this dialog box, you can click the Apply button to preview your
settings. When you click the Apply button, the settings update the active sheet. However, the settings are not 
final until you click the OK button. 

Dialog Box Options

Sheet Origin Location

Specifies the X and Y coordinates for the sheet origin. The sheet origin is the lower left corner of the drawing 
sheet. After setting these coordinates, click Apply. 

Interactive Move

Allows you to use the pointer to identify a location for the lower left corner of the sheet. Selecting this option 
automatically attaches the drawing sheet border to the pointer. Click once and the sheet is in the location that 
you want. You must click the Apply button for your changes to start.
Caution    While you are moving the sheet border with the pointer, the Move Sheet Border dialog box is not 
displayed. It appears again after you click the pointer to complete the move.

Drawing Scale

Sets options for the scale of the drawing sheet.

Scale (1:1)

Sets the drawing scale to a 1:1 ratio. This ratio means that the representation of the objects on the 
drawing sheet is the same size as the real-world elements contained in the document. 

Select Scale

Sets the drawing scale to a standard ratio. 
Tip    The Fit to Sheet option determines a drawing sheet scale that fits the reference file within the 
sheet, but allows you to specify where to insert the file by clicking the drawing sheet.

The specified ratio defines the size of the drawing in relation to the size of the real-world object. For a 1:2 
ratio, the 1 represents the distance of the drawing sheet and the 2 represents the real-world distance. 
That is, every centimeter of paper is equal to two centimeters of real-world distance. Thus, the largest 
real-world element that you can represent on an 21.59 x 27.94 cm drawing sheet is 43.18 x 55.88 cm.
Tip    When the first value is smaller than the second value, the sheet size is usually increased. When the 
first number is larger than the second number, the sheet size is usually reduced.

Custom

Defines a custom or scale ratio. The first value defines the distance on the drawing sheet and the second
value defines what this distance is equal to in the real world.

Sheet Size

Sets the size for the drawing sheet.

Same As Print Setup

Sets the drawing sheet size using the settings for the default system printer. For example, if the printer is 
set up as 27.94 x 43.18 cm paper, the drawing sheet size is set to 27.94 x 43.18 cm.

Standard

Defines the drawing sheet size from a list of standard ANSI and ISO paper sizes.

Custom

Defines the drawing sheet size according to the entered x and y values.

Previous



Clears the last set of options that you applied to the drawing sheet.

 



Save As Dialog Box
{button Related Topics,AL("save cmd;save copy as cmd",0,`NOT_FOUND')} {button How To,AL("save 
how",0,`NOT_FOUND')}

Specifies the name of, location of, and format for a document when you save it.

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.

When you position the pointer in this dialog box and right-click, you can access a variety of standard commands 
that help you manage your documents more efficiently. For example, if you select a document in the list and then
right-click, you can then click the Select command on the shortcut menu to automatically open the document. 
You can also create shortcuts, send the document somewhere else, and other activities.



Symbol Properties Dialog Box
{button Related Topics,AL("editing symbols high;dc high;edit properties cmd;element properties cmd;av 
high",0,`NOT_FOUND')} {button How To,AL("edit symbol how",0,`NOT_FOUND')}

Defines the properties of a symbol.

Tabs

Info Tab

Behavior Tab

User Tab

Parametric Tab



Info Tab
{button Related Topics,AL("symbol properties db;av high",0,`NOT_FOUND')} {button How To,AL("edit symbol 
how",0,`NOT_FOUND')}

Displays and allows you to set symbol placement options such as the symbol angle, layer on which you want to 
place the symbol, and coordinates for the symbol.

Tab Options

Name

Displays the name of the parent document of the symbol.

Layer

Specifies the layer on which you place the symbol.    When you place a symbol, it is placed on the active layer.

X Origin

Specifies the X coordinate of the symbol origin.

Y Origin

Specifies the Y coordinate of the symbol origin.

Angle

Displays the current angle of the symbol. You can specify a new angle. The number of degrees increases in the 
counterclockwise direction. For example, 90 degrees is at the top of the screen.



Behavior Tab
{button Related Topics,AL("symbol properties db",0,`NOT_FOUND')} {button How To,AL("edit symbol 
how",0,`NOT_FOUND')}

Tab Options

Insertion Type

Specifies the insertion type for a symbol. You can set the insertion type by clicking the Options command on the 
Tools menu and then clicking the Symbols tab on the Options dialog box. After you set an insertion type for a 
symbol, you cannot change the type. 

Update

Displays the type of update for the link on the symbol. To change the update status of a link, click Automatic. To 
prevent updating the link, click Frozen. You can select Automatic when you want the document to automatically 
reflect any changes to the symbol document. You can select Frozen when you do not want the symbol in the 
current document to change at all.

Scale Factor

Specifies the scale factor that the symbol uses when you drag it into the active document. The scale factor used 
is relative to the model units of the symbol. For example, if you set the scale factor to 2 and the symbol has 1 cm 
square in model units, it displays 2 cm square when you drag it into the active document.

Lock Scale

Specifies if you can scale the symbol, after you place it in a document.
Tip    You can scale a symbol by clicking the Scale button on the Change toolbar or by dragging the symbol 
handles.

Allow Rotation By Relationships

Allows a symbol to change its orientation on the drawing sheet according to the applied relationships . If you 
clear the check box, the symbol does not change its orientation regardless of changes to its relationships. 

This check box is available only when the symbol is an open document. You can open the symbol document 
(.sym) with the Open command on the File menu. When you set or clear this check box and close the symbol 
document, the setting affects the behavior of the symbol when it is dragged from the Symbol Explorer onto the 
drawing sheet.

The check box is clear by default. When the check box is clear, a symbol maintains its orientation to the drawing 
sheet when you move the symbol or other elements that are related to it. In the following example, the line and 
symbol share a dimensional relationship. The lower end of the symbol is grounded in place with a lock 
relationship.

 

If you edit the dimensional value of the driving dimension between the line and symbol to modify the position of 
the elements, the symbol does not change its orientation on the drawing sheet. The driving dimension changes 
to a driven dimension that is not to scale, as indicated by the underlined dimensional value.

 



When you set the Allow Rotation By Relationships check box, the symbol changes orientation on the drawing 
sheet according to the applied relationships. In the example, when you edit the dimensional value of the driving 
dimension to change the position of the elements, the symbol changes orientation on the drawing sheet, 
maintaining the dimensional relationships.

 

Nested Display

Defines the behavior of nested symbols.    The options are Public and Private. When you open a document that 
contains nested symbols, the public option displays these symbols, but the private option hides these symbols.



User Tab
{button Related Topics,AL("symbols high;dc high",0,`NOT_FOUND')} {button How To,AL("edit symbol 
how",0,`NOT_FOUND')}

Displays and allows you to set property options for each symbol that you place.    This feature provides an 
administrative tool for tracking property information, such as the serial number of label text, for each placement 
of a symbol.

Tab Options

Name

Defines a property name.

Type

Specifies the property type you want to define for the symbol property name. You can choose from character, 
number, money, or date.

Value

Specifies a value for the symbol. For example, you can assign a manufacturer name, a serial number, or other 
descriptive information as a value.

Properties

The properties table lists all the properties currently defined for the symbol.

Add

Creates an attribute for the symbol.

Delete

Deletes the attribute that you select in the Properties box.



Parametric Tab
{button Related Topics,AL("symbol properties db",0,`NOT_FOUND')} {button How To,AL("edit symbol 
how",0,`NOT_FOUND')}

Displays information about the parameters in the symbol. The parameters that appear on this tab are the same 
items that appear in the Attribute Viewer when you select the symbol. 

You can change the name of the value of the parameter, but not the name. When you change the value, you 
must click the Apply button for the change to take effect on the symbol.



Place Doubleline Ribbon Bar
{button Related Topics,AL("draw high;line cmd;dubline high;dubline cmd",0,`NOT_FOUND')} {button How 
To,AL("line how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Left Primary Line

Indicates that you are drawing the doubleline from the left side. 

Right Primary Line

Indicates that you are drawing the doubleline from the right side. 

Center Primary Line

Indicates that you are drawing the doubleline from the center. 

Length

Sets the length of a line. This box accepts only positive values.

Angle

Sets the angle of a line. This box accepts positive or negative values. A positive value is counterclockwise from 
the x axis, and a negative value is clockwise from the x axis.

Thickness

Determines the thickness of the doubleline. This thickness is the distance between each of the doublelines. To 
change the thickness of each of the individual lines, use the Line Width option.



Leader Ribbon Bar
{button Related Topics,AL(`add leader cmd',0,`NOT_FOUND')} {button How To,AL(`leader 
how',0,`NOT_FOUND')}

Note    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Dimension Style

Lists and applies the available styles.

Break Line

Displays a horizontal break line at the annotation end of a leader.



Leader Properties Dialog Box
{button Related Topics,AL(`annotations high;element properties cmd;add leader cmd',0,`NOT_FOUND')}

{button How To,AL(`leader how',0,`NOT_FOUND')}

Edits the properties of an element to which you have added a leader using the Add Leader command.

Tab

Text and Leader Tab



Text and Leader Tab
{button Related Topics,AL("leader properties db;balloon properties db;feature control frame properties db;datum 
frame properties db;weld properties db;surface texture symbol properties db;text properties 
db",0,`NOT_FOUND')} {button How To,AL("format dimension how",0,`NOT_FOUND')}

Tab Options

Text

Specifies how the text appears in an annotation.

Font

Specifies the font to use for the text in the annotation.

Font Style

Specifies the font style to use, such as bold or italic, for the text in the annotation.

Font Size

Lists and applies the available text sizes.

Leader And Projection Line

Specifies how the leader and projection line are displayed.

Break Line

Displays a horizontal break line where the leader line meets the annotation text. For example, when 
break line is set to 1, the break line looks like the following picture.

 

Element Gap

Sets the distance that the projection line is set back from the element you want to attach the leader to. 
This value is a ratio of the font size.

Extension

Sets the distance that the leader line extends beyond the dimension. This value is a ratio of the font size.

Color

Sets the color of an annotation.

Line Width

Sets the line width of all lines in an annotation.

Terminator

Specifies how the terminator is displayed on the leader.

Type

Sets the terminator type. Click different parts of the following picture to find out which terminator type you 
want to use.



 

Length

Sets the length of the terminator. This value is a ratio of the font size. For example, in the following 
picture, the length is set to three times the size of the font.

    



Balloon Ribbon Bar
{button Related Topics,AL(`balloon cmd',0,`NOT_FOUND')} {button How To,AL(`balloon how;insert vertex 
how',0,`NOT_FOUND')}

Determines the size and shape of the balloon and the text within the balloon.
Note    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the 
ToolTip.

Ribbon Bar Options

Dimension Style

Lists and applies the available styles.

Leader

Displays the leader line. 

Break Line 

Places a break line on the leader.

Height

Specifies the height of the balloon. The value you enter is a ratio of the text height defined in the dimension style.
The actual height of the balloon is the value you enter multiplied by the dimension text height.

Text

Specifies the text you want inside the balloon.

Shape

Specifies which balloon shape you want from the list of available shapes.



Balloon Properties Dialog Box
{button Related Topics,AL(`element properties cmd',0,`NOT_FOUND')}{button How To,AL(`format dimension 
how;insert vertex how',0,`NOT_FOUND')}

Sets the properties of a balloon.

Tabs

General Tab

Text and Leader Tab



General Tab
{button Related Topics,AL(`balloon properties db',0,`NOT_FOUND')} {button How To,AL(`format dimension 
how;insert vertex how',0,`NOT_FOUND')}

Tab Options

Balloon Text

Enters text in the balloon. 

Balloon Height

Specifies the height of the balloon. The value you enter is a ratio of the text height defined in the dimension style.
The actual height of the balloon is the value you enter multiplied by the dimension text height.

Balloon Shape

Specifies which balloon shape you want from the list of available shapes.

Number Of Sides

Sets the number of sides of an n-sided balloon shape. You must click N-Sides in the Shape list to use this 
option. You can then type the value you want.



Change Source Dialog Box
{button Related Topics,AL("links cmd",0,`NOT_FOUND')} {button How To,AL("edit link how;unload 
how",0,`NOT_FOUND')}

You can access the Change Source dialog box by pressing the Change Source button on the Links dialog box.

Note    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.

 



Chamfer Ribbon Bar
{button Related Topics,AL("chamfer cmd ",0,`NOT_FOUND')} {button How To,AL("chamfer 
how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors   dialog box  .

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Angle

Measures the angle between the chamfer and the first linear element.

Setback A

Specifies the distance from the corner to the beginning of the chamfer on the first linear element you select.

Setback B

Specifies the distance from the corner to the beginning of the chamfer on the second linear element you select.



Circular Pattern Ribbon Bar
{button Related Topics,AL("circular pattern cmd",0,`NOT_FOUND')} {button How To,AL("circular pattern 
how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Options

Displays the Circular Pattern Options   dialog box.  

Count

Sets the number of copies in the pattern.

Rows

Sets the number of arc-shaped rows in the pattern. This option is available only when the Rows option on the 
Circular Pattern Options dialog box is set to Multiple Inward or Multiple Outward.

Angle

Sets the angle of the pattern. This box sets the sweep angle between pattern members when the Pattern 
Control option on the Circular Pattern Options dialog box is set to Incremental Array. This box also sets the 
total sweep angle when the Pattern Control option is set to Fit To Arc.

Row Spacing

Sets the distance between adjacent arc-shaped rows in the pattern, as measured from the bottom of one row to 
the bottom of the next. The bottom is the side closest to the center point of the circular pattern.



Circular Pattern Options Dialog Box
{button Related Topics,AL("circular pattern rb;circular pattern cmd",0,`NOT_FOUND')} {button How 
To,AL("circular pattern how",0,`NOT_FOUND')}

Dialog Box Options

Pattern Control

Specifies how the pattern is constructed.
Incremental Array—Draws a pattern with a set sweep angle between members.
Fit To Arc—Draws a pattern by evenly spacing members along an arc.

Rows

Controls how pattern rows are arranged.

Single Row

Draws a single row of pattern members.

Multiple Inward

Draws multiple rows, each one closer to the pattern center than the last.

Multiple Outward

Draws multiple rows, each one farther away from the pattern center than the last.

Preview

Displays the range of the graphic to print on the printer paper.



Ribbon Bar
{button Related Topics,AL("draw high;groups high;smartsketch high;freesketch high;circle high;line 
high;rectangle high",0,`NOT_FOUND')} {button How To,AL("draw how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors   dialog box  .

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.



Customize Dialog Box
{button Related Topics,AL("customize cmd;toolbars cmd",0,`NOT_FOUND')} {button How To,AL("customize 
how ",0,`NOT_FOUND')}

Customizes toolbar buttons and menus.

Tabs

Menu Tab

Toolbars Tab



Toolbars Tab
{button Related Topics,AL("toolbars db",0,`NOT_FOUND')} {button How To,AL("customize 
how",0,`NOT_FOUND')}

Adds or removes commands from toolbars.

Tab Options

Categories

Specifies the category that you want to customize.

Buttons

Specifies which button from the active category you want to add to a toolbar.

 Description

Describes the selected button displayed in the Buttons box.



Menu Tab
{button Related Topics,AL("toolbars db",0,`NOT_FOUND')} {button How To,AL("customize 
how",0,`NOT_FOUND')}

Adds or removes commands from menus or the main menu bar. You can add a command to an existing menu or 
build a custom menu with the commands that you want.

Tab Options

Categories

Sets the category that you want to select a command or macro from to add to the menu or main menu bar. When
you select the title of a group of commands in this box, you can click the title of a command in the 
Commands/Macros box. When you select Macros in the Categories box, you can click a macro document in 
the Commands/Macros box.

Commands/Macros

Sets the command or macro that you want to add to the menu. If you select a macro, you can also click the 
Browse button and change the directory for macros. When you change the directory, the macro list in the 
Commands/Macros box displays a list of macros in the current directory.

List

Lists the menus. Double-click on a menu name to see all the commands on a menu. When you click Add 
Command, Add Menu, Place Into Selected Menu, or Remove, the changes show up on this list. This list also 
changes to allow you type in a name for the new menu that you want to add.

Place Into Selected Menu

Places a command or macro that you selected in the Commands/Macros box on the menu that you selected in 
the List. If you do not set this option, then the macros or commands that you are adding are placed before or 
after the command or menu that you selected in the List box. 

Reset All

Restores all menus and the main menu bar to the original settings.

Add Command 

Places a command on a menu or the main menu bar. This button is available only when you select a command 
or macro in the Commands/Macros box.

Add Menu

Places a menu on an existing menu or the main menu bar. When you add a menu with this option, you can add 
commands to the new menu later. If you add a menu to an existing menu, this creates a cascading menu. After 
you click this button, you can type the name that you want in the List box and then click away from the name to 
enter it.

Remove

Removes the command or menu that you selected in the List box.

Description

Displays a description or result of the options that you selected before you apply them to a menu.

Browse

Changes the directory for macros with the Select Macro Directory dialog box. The Browse button appears only 
when you click the Macros option in the Categories box. The Select Macro Directory dialog box changes the 
directory for listing macros on the Customize dialog box. When you change the directory and click OK, the 
Commands/Macros box lists the macros for the directory that you selected.        

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.

When you position the pointer in this dialog box and right-click, you can access a variety of standard commands 
that help you manage your documents more efficiently. For example, if you select a document in the list and then



right-click, you can then click the Select command on the shortcut menu to automatically open the document. 
You can also create shortcuts, send the document somewhere else, and other activities.



Arc Ribbon Bar
{button Related Topics,AL("arc cmd;draw high",1)} {button How To,AL("arcs how",1)}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Radius

Sets the radius.

Sweep

Sets the sweep angle.



Circle Ribbon Bar
{button Related Topics,AL("draw high;circle cmd",0,`NOT_FOUND')} {button How To,AL("circle 
how",0,`NOT_FOUND')}

Sets options for placing circles.
Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Diameter

Sets the diameter of the circle.

Radius

Sets the radius.



Curve Ribbon Bar
{button Related Topics,AL("draw high;curve cmd",0,`NOT_FOUND')} {button How To,AL("curve 
how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Open

Sets the curve type to open.

Closed

Sets the curve type to closed.

Previous Node

Activates the previous node on the curve. This button is available only when you have selected a curve to edit. 

Next Node

Activates the next node on the curve. This button is available only when you have selected a curve to edit. 

Symmetric

Gives a curve the same curvature on each side of the selected node. This button is available only when you 
have selected a curve to edit.

Smooth

Gives a curve a different curvature on each side of the selected node. The start point and end point of a curve is 
always a smooth node. This button is available only when you have selected a curve to edit.



Cusp

Makes a curve bend sharply at the selected node. This button is available only when you have selected a curve 
to edit.



Ellipse Ribbon Bar
{button Related Topics,AL("draw high;ellipse cmd",0,`NOT_FOUND')} {button How To,AL("ellipse 
how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Primary

Sets the length of the primary axis. The ellipse orientation is based on the primary axis.

Secondary

Sets the length of the secondary axis. The secondary axis is perpendicular to the primary axis.

Rotation

Sets the angle of the primary axis of the ellipse. Zero degrees is horizontal to the x axis. The angle increases in 
the counterclockwise direction.



FreeForm Ribbon Bar
{button Related Topics,AL("draw high;freeform cmd",0,`NOT_FOUND')} {button How To,AL("freeform 
how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Smoothing On

Draws cusp, smooth, and symmetric curves in the precision drawing by recognizing these shapes in the rough 
sketch.

Smoothing Off

Draws elements that closely resemble the movements of your pointer, without smoothing them into cusp, 
smooth, and symmetric curves.



FreeSketch Ribbon Bar
{button Related Topics,AL("draw high;freesketch cmd ",0,`NOT_FOUND')} {button How To,AL("freesketch 
how ",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Adjust On

Draws all lines recognized in the rough sketch as horizontal or vertical in the precision drawing, and draws all 
arcs recognized in the rough sketch as tangent in the precision drawing.

Adjust Off

Does not adjust the orientation of lines and arcs in your rough sketch.

Line

Draws lines in the precision drawing by recognizing them in the rough sketch.

Arc

Draws arcs in the precision drawing by recognizing them in the rough sketch.

Circle

Draws circles in the precision drawing by recognizing them in the rough sketch.

Rectangle

Draw rectangles in the precision drawing by recognizing them in the rough sketch.



Dimension Prefix Dialog Box
{button Related Topics,AL("dimension rb",0,`NOT_FOUND')} {button How To,AL("edit dimension prefix 
how",0,`NOT_FOUND')}

Adds prefix, suffix, superfix, and subfix text to a dimensional value. You can use this dialog box while you place 
or edit a dimension.

(A) Superfix
(B) Prefix
(C) Value
(D) Suffix
(E) Subfix

Dialog Box Options

Prefix

Specifies prefix information.

Suffix

Specifies suffix information.

Superfix

Specifies superfix information.

Subfix

Specifies subfix information.

Apply

Applies the prefix to the dimension. 

Special Characters

Applies a font character to the dimension prefix. You can use the buttons to apply font characters, such as a 
diameter, counterbore, depth, and initial length.



Dimension Properties Dialog Box
{button Related Topics,AL("element properties cmd",0,`NOT_FOUND')} {button How To,AL("format 
dimension how",0,`NOT_FOUND')}

Sets the properties of a dimension or dimension style. You can point to a dimension and right-click to access this 
dialog box from the Properties command on the shortcut menu.

Tabs

General Tab

Units Tab

Secondary Units Tab

Text Tab

Spacing Tab

Terminator and Symbol Tab

Lines and Coordinate Tab



Lines and Coordinate Tab
{button Related Topics,AL("dimension db;dimension properties db;new dimension style db;modify dimension 
style db",0,`NOT_FOUND')} {button How To,AL("format dimension how",0,`NOT_FOUND')}

Tab Options

Dimension Lines

Sets options for dimension lines.

Connect

Controls if the dimension line extends between both terminators when you place the dimension text and 
terminators outside the projection lines.

Width

Sets the width of the dimension line.

Stack Pitch

Sets the distance between stacked dimensions. The value is a ratio of the dimension text size.

Break Line

Sets the size of the break line for the dimension line. This value is a ratio of the text size.

Coordinate

Sets options for coordinate dimensions.

Auto-Jog

Turns the jog control on or off on the Dimension ribbon bar. You can use this option only when you place 
a coordinate or radial dimension. If you set Auto-Jog and the distance between two dimensions is less 
than the value set for Stack Pitch, then you can place the dimension with a jog in the projection line. 

Stack Pitch

Sets the distance between stacked dimensions. The value is a ratio of the dimension text size.

Common Origin

Sets the symbol type for the common origin on coordinate dimensions. You can set the symbol type to 
dot, circle, or none.

Text Position

Positions text in a coordinate dimension.

Projection Line

Sets options for the projection line of a dimension.

Display

Controls the display of projection lines on linear dimensions. You can set the display to none (off), origin, 
measurement, or origin and measurement. You can use this option to hide projection lines when they 
overlap and you are using a pen plotter.

Element Gap

Sets the distance that the projection line is set back from the element you want to dimension. This value 
is a ratio of the dimension text size.

Extension

Sets the distance that the dimension line extends beyond the dimension. This value is a ratio of the 
dimension text size.

Angle

Sets the slant angle of the projection lines on dimensions. This option is useful when you need to place a 



dimension on isometric drawings.

Center Mark

Places a center line automatically when you dimension a nonlinear element.

Extend Center Mark

Displays projection lines on center marks.

Align Groups

Sets the length of all projection lines in a dimension group to equal the shortest projection line in the 
group.



General Tab
{button Related Topics,AL("dimension db;dimension properties db;new dimension style db;modify dimension 
style db",0,`NOT_FOUND')} {button How To,AL("format dimension how",0,`NOT_FOUND')}

Sets general properties for dimensions.

Tab Options

Color

Sets colors for a driving, driven, or error dimension.

Driving Dimension

Sets the color used for driving dimensions.

Driven Dimension

Sets the color used for driven dimensions.

Error Dimension

Sets the color for error dimensions. Error dimensions are driving or driven dimensions that the software 
cannot recalculate correctly after parametric attributes on driving dimensions are changed.

Scale Mode

Sets the scale mode to automatic or manual.

Automatic

Determines a correct dimensional value based on the scale set in the drawing view.

Manual

Scales a dimensional value. The scale value determines the dimensional value.



Units Tab
{button Related Topics,AL("dimension db;dimension properties db;new dimension style db;modify dimension 
style db",0,`NOT_FOUND')} {button How To,AL("format dimension how",0,`NOT_FOUND')}

Sets the primary units for dimensions. 

Tab Options

Linear

Specifies the unit settings for a linear dimension.

Units

Sets the primary units for linear dimensions.

Unit Label

Sets the unit label. You can type up to 20 characters for a unit label.

Subunit Label

Sets the subunit label. You can type up to 20 characters for a subunit label.

Round-Off

Sets the round-off for the value. This control is sensitive to the unit setting (decimal or fractional) and 
contains values as appropriate for the unit. This control is also sensitive to the dimension that you place 
and contains values as appropriate for the dimension.

Maximum Subunits

Sets the maximum subunits value. You can type a value up to 18. This value applies to feet and inches. 
For example, if you type 13, the dimension appears as 13 inches and not 1 foot and 1 inch.

Angular

Sets the units for an angular dimension.

Units

Sets the primary units for angular dimensions.

Round-Off

Sets the round-off for the value. This control is sensitive to the unit setting (decimal or fractional) and 
contains values as appropriate for the unit. This control is also sensitive to the dimension that you place 
and contains values as appropriate for the dimension.

Zeroes

Specifies if a zero is on the left or right of the decimal in a dimension.

Leading

Places a zero to the left of the decimal point if no numbers appear to the left.

Trailing

Places zeros to the right of the decimal point. The number of zeros placed is based on the active setting 
for Round-Off. For example, if the dimensional value is .5, and the round-off setting is .1234, the 
dimensional value appears as .5000.

Delimiter

Specifies the decimal delimiter for a dimension.

Period

Sets a period as the decimal delimiter.

Comma

Sets a comma as the decimal delimiter.



Space

Sets a space as the decimal delimiter.



Secondary Units Tab
{button Related Topics,AL("dimension db;dimension properties db;new dimension style db;modify dimension 
style db",0,`NOT_FOUND')} {button How To,AL(`format dimension how',0,`NOT_FOUND')}

Sets the secondary units for dimensions.

Tab Options

Linear

Specifies the unit settings for a linear dimension.

Units

Sets the secondary units in drawings with dual unit display. For example, the primary unit can be inches, 
while the secondary unit can be millimeters. When you place the dimension, it displays both units. The 
software derives the secondary unit by converting the primary unit.

Unit Label

Sets the secondary units label in drawings with dual unit display. You can type up to 20 characters.

Subunit Label

Sets the secondary subunit label in drawings with dual unit display. You can type up to 20 characters.

Round-Off

Sets the round-off value for secondary units in drawings with dual unit display. Click the Secondary 
Units tab to set the Dual Unit Display check box.

Maximum Subunits

Sets the maximum subunits used for secondary subunits in drawings with dual unit display.

Zeroes

Specifies if a zero appears on the left or right of the decimal in a dimension.

Leading

Places a zero to the left of the decimal point if no numbers appear to the left.

Trailing

Places zeros to the right of the decimal point. The number of zeros placed is based on the active setting 
for Round-Off. For example, if the dimensional value is .5, and the round-off setting is .1234, the 
dimensional value appears as .5000.

Dual Unit Display

Displays secondary units for dimensions in drawings. For example, the primary unit can be inches, while the 
secondary unit is millimeters. Both units display when you place the dimension. The software derives the 
secondary unit by converting the primary unit.



Terminator And Symbol Tab
{button Related Topics,AL("dimension db;dimension properties db;new dimension style db;modify dimension 
style db",0,`NOT_FOUND')} {button How To,AL("format dimension how",0,`NOT_FOUND')}

Sets terminator and symbol options for dimensions.

Tab Options

Terminator

Sets options for terminators.

Type

Sets the terminator type for all terminators. Click the various dimensions in the following picture to see 
the different types.

 

 Freespace Type

Sets the terminator type for a dimension with a terminator placed in free space.

Size

Sets the size of the terminator. The value is a ratio of the dimension text size. For example, if you set the 
Font Size option on the Text tab to be .2 cm and the Size option to be 2, the terminator is twice the size 
of the dimension text.

 

Origin Type

Sets the terminator type used on the origin of a linear dimension.

Inside Limit

Sets the inside limit for the terminator. The value is a ratio of the dimension text size. This setting controls
when the terminators appear on the outside of the projection lines according to the options that you set.

Datum Type

Sets the terminator type for datum frames. If you select Normal, the datum frame uses the active 
terminator type for dimensions. If you select Anchor, the datum frame uses an anchor terminator. 

Display

Specifies which end of the terminator displays or if both ends display. You can set the display to none 
(off), origin, measurement, or both origin and measurement. The following picture shows the display 
when you select the Origin option and the Measurement option.

 

Symbol

Sets options for symbols in dimensions.



Placement

Sets the placement position for the symbol on diameter and radial dimensions and linear dimensions for 
an arc. You can place the symbol before or after the dimension. You can also hide the symbol.

Suppress Diameter

Suppresses the diameter symbol on diameter dimensions.

Not To Scale

Displays an underline, zigzag, or no indicator on driven dimensions with overridden values. You can use 
the zigzag option only on linear dimensions. You can override a driven dimension value by typing a new 
value in the Edit Value box on a dimension ribbon bar. 
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Text Tab
{button Related Topics,AL("dimension db;dimension properties db;new dimension style db;modify dimension 
style db",0,`NOT_FOUND')} {button How To,AL("format dimension how",0,`NOT_FOUND')}

Sets the text options for dimensions.

Tab Options

Text

Sets text options for a dimension.

Font

Sets the font type for the dimension text.

Font Style

Specifies the font style to use for the text in a dimension.

Font Size

Sets the size for text in a dimension.

Orientation

Sets the orientation for the text on a dimension. For example, the dimension text looks like the following 
picture when you select Vertical.

Position

Sets the position where text appears in relation to the base line. The base line is an imaginary horizontal 
line directly under a line of text. For example, when you select Above, the dimension text looks like the 
following picture.

 

Tolerance Text

Sets options for text in certain types of dimensions that have related tolerances. You can set the dimension type 
on the dimension ribbon bar.

Size

Sets the size of the text for tolerance text. The value is a ratio of the dimension text size. For example, if 
you enter .5, the size of the tolerance text will be half the size of the dimension text.

Limit Arrangement

Sets the text arrangement on limit dimensions.



Spacing Tab
{button Related Topics,AL("dimension db;dimension properties db;new dimension style db;modify dimension 
style db",0,`NOT_FOUND')} {button How To,AL("format dimension how",0,`NOT_FOUND')}

Sets dimension spacing options. All options are a ratio of the dimension text value.

Tab Options

Text Clearance Gap

Sets the space between the text and the dimension line.

Dual Display Vertical Gap

Sets the space between the primary and secondary units when dual unit display is active. You can set the Dual 
Unit Display option on the Secondary Units tab so that dimensions display two units.

Line Spacing

Sets the amount of space between the superfix or subfix and the dimension text.

Dimension Above Line Gap

Sets the space between the dimension text and the dimension line.

Horizontal Tolerance Gap

Sets the space between the dimensional value and the tolerance on dimensions.

Vertical Tolerance Gap

Sets the space between the upper and lower tolerance value on dimensions.

Vertical Limits Gap

Sets the space between the upper and lower dimensional values on limit dimensions.

Symbol Gap

Sets the space between the symbol and the dimension line. You can also set the space between the symbol and 
the dimension text.

Prefix/Suffix Gap

Sets the amount of space between the prefix or suffix and the dimension text.

Horizontal Box Gap

Sets the space between the dimension text and the horizontal edges of the box on dimensions.

Vertical Box Gap

Sets the space between the dimension text and the vertical edges of the box on dimensions.



Dimension Ribbon Bar
{button Related Topics,AL("smartdimension cmd;distance between cmd;angle between cmd;dimension 
coordinate cmd;symmetric diameter cmd",0,`NOT_FOUND')} {button How To,AL("edit dimensional value 
how;toggle dimension how;use smartdimension how",0,`NOT_FOUND')}

Sets options for dimensions. Some options on this toolbar are not available until you select an element on the 
drawing sheet.
Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Dimension Style

Lists and applies the available dimension styles.

Round-Off

Sets the round-off for the value. This control is sensitive to the unit setting (decimal or fractional) and contains 
values as appropriate for the unit. This control is also sensitive to the dimension being placed and contains 
values as appropriate for the dimension.

Dimension Value

Sets the dimensional value.

Driving/Driven

Toggles the selected dimension between a driving and driven state. If you want to set this option before you 
place a dimension, you must set the Maintain Relationships option on the Tools menu.

Auto Center Mark

Places a center line crosshair at the center of the radius of curvature being measured by the dimension.

Jog

Offsets the projection line of a coordinate or radial dimension. You can use this option to prevent the projection 
line that you are placing from overlapping other dimensions.

Dimension Axis

Sets the orientation of dimensions placed by the Distance Between or Coordinate Dimension button. This 
option is not available until you select one of those buttons. This option is not available after you select the origin 
element. 

When you click Default, the dimensions that 
you place are parallel or perpendicular to the
horizontal edge of the drawing sheet.
When you click Implicit, the dimensions that 
you place are parallel or perpendicular to the
element that you are dimensioning.
When you click Explicit, the dimensions that 
you place are parallel or perpendicular to the
element that you set the dimension axis to 
with the Axis button on the Dimension 
Toolbar. You can use Explicit when the 
default horizontal and vertical axes are not 
appropriate for the geometry that you are 
dimensioning.



Complement

Places an angular dimension at the 360 degree complement.

Half/Full

Toggles between half and full. When you toggle this option, the symmetric diameter appears as half or full.

The following options are available only if you click the SmartDimension button on the Dimension 
toolbar and select an element:

Length

Places a linear dimension for the following:
The length of a line
The arc length of an arc
The horizontal or vertical distance between the end points of a line

Angle

Places an angular dimension for the angle of a line or the sweep angle of an arc.

Radius

Places a radial dimension for the following:
Arc
Circle
Ellipse
Curve



Diameter

Places a diameter dimension for an arc or circle.

Prefix

Opens or closes the Dimension Prefix dialog box for specifying prefix, suffix, superfix, and subfix information.

Dimension Type

Specifies the dimension type and the related tolerances. 
Note In the following picture, you can click each palette option to see the type of dimension and an example of 
what the dimension will look like.

Upper Tolerance

Sets the primary upper tolerance value. This option is available for tolerance or limits dimension types only.

Lower Tolerance

Sets the primary lower tolerance value. This option is available for tolerance or limits dimension types only.

Class

Sets the tolerance class. This option is available for the class dimension type only. You can set the deviation 
(letters) and the grade (numbers).



Line Ribbon Bar
{button Related Topics,AL("draw high;line cmd",0,`NOT_FOUND')} {button How To,AL("line 
how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Line

Switches the drawing mode from line to arc.

Arc

Switches the drawing mode from arc to line.

Length

Sets the length of a line. This box accepts only positive values.

Angle

Sets the angle of a line. This box accepts positive or negative values. A positive value is counterclockwise from 
the x axis, and a negative value is clockwise from the x axis.



Point Ribbon Bar
{button Related Topics,AL("draw high;point cmd",0,`NOT_FOUND')} {button How To,AL("point 
how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 

Y

Sets a value for the y coordinate. You can use this option by itself or with the X option.



Element Properties Dialog Box
{button Related Topics,AL("element properties cmd",0,`NOT_FOUND')} {button How To,AL("format line 
how",0,`NOT_FOUND')}

Sets the display properties and user-defined properties for elements.

Tabs

Info Tab

Format Tab

User Tab



Format Tab
{button Related Topics,AL("line properties db",0,`NOT_FOUND')} {button How To,AL("format line 
how",0,`NOT_FOUND')}

Tab Options

Style

Sets the drawing style.

Color

Sets the drawing color.

Width

Sets the line width.

Type

Sets the drawing line type and style.



Info Tab
{button Related Topics,AL("line properties db",0,`NOT_FOUND')} {button How To,AL("format line 
how",0,`NOT_FOUND')}

The contents of this tab varies depending on whether you selected or highlighted one of the following types of 
elements:

Line
Arc
Circle
Curve
Ellipse
Point
Fillet
Chamfer
Rectangle
Connector

Line Tab Options

Type

Displays the type of the selected element. You cannot edit the type.

Sheet

Displays the name of the drawing sheet that contains the element. You cannot edit the name of the drawing 
sheet.

Layer

Sets the layer that contains the element.

Start Point

Sets the X and Y values for the start point of the element.

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 

Y

Sets a value for the y coordinate. You can use this option by itself or with the X option.

End Point 

Sets the x and y values for the end point of an element.

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 

Y

Sets a value for the y coordinate. You can use this option by itself or with the X option.

Length

Displays the length of a curve. You cannot edit this value.

Angle

Sets the angle of a line.

Arc Tab Options

Type

Displays the type of the selected element. You cannot edit the type.

Sheet



Displays the name of the drawing sheet that contains the element. You cannot edit the name of the drawing 
sheet.

Layer

Sets the layer that contains the element.

Start Point

Sets the x and y values for the start point of the element.

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 

Y

Sets a value for the y coordinate. You can use this option by itself or with the X option.

Center Point

Sets the x and y values for the center point of a closed element.

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 

Y

Sets a value for the y coordinate. You can use this option by itself or with the X option.

End Point 

Sets the x and y values for the end point of an element.

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 

Y

Sets a value for the y coordinate. You can use this option by itself or with the X option.

Radius

Sets the radius.

Start Angle

Displays the angle formed by the x axis and the first point of the sweep angle. Zero degrees is horizontal to the x 
axis.

Sweep Angle

Sets the sweep angle.

Circle Tab Options

Type

Displays the type of the selected element. You cannot edit the type.

Sheet

Displays the name of the drawing sheet that contains the element. You cannot edit the name of the drawing 
sheet.

Layer

Sets the layer that contains the element.

Center Point

Sets the x and y values for the center point of a closed element.

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 



Y

Sets a value for the y coordinate. You can use this option by itself or with the X option.

Radius

Sets the radius.

Diameter

Sets the diameter of the circle.

Circumference

Displays the circumference of a closed element. Although you cannot edit the circumference, the box 
automatically updates when you edit the geometry.

Area

Displays the area of a closed element. Although you cannot edit the area, the box automatically updates when 
you edit the geometry.

Curve Tab Options

Type

Displays the type of the selected element. You cannot edit the type.

Sheet

Displays the name of the drawing sheet that contains the element. You cannot edit the name of the drawing 
sheet.

Layer

Sets the layer that contains the element.

Curve Type

Displays the type of curve (open or closed). You cannot edit this field.

Order

Displays the number of nodes of a curve.

Vertices

Sets the coordinates of the nodes on the curve.

Nodes

Lists the nodes on a selected curve. When you select a node from the list, its x and y values are displayed so 
you can edit them. The node type is also displayed.

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 

 Y

Sets a value for the y coordinate. You can use this option by itself or with the X option.

Length

Displays the length of a curve. You cannot edit this value.

Area

Displays the area of a closed curve. Although you cannot edit the area, the box automatically updates when you 
edit the geometry.

Ellipse Tab Options

Type

Displays the type of the selected element. You cannot edit the type.



Sheet

Displays the name of the drawing sheet that contains the element. You cannot edit the name of the drawing 
sheet.

Layer

Sets the layer that contains the element.

Center Point

Sets the x and y values for the center point of a closed element.

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 

Y

Sets a value for the y coordinate. You can use this option by itself or with the X option.

Primary Axis

Sets the length of the primary axis. The ellipse orientation is based on the primary axis.

Secondary Axis

Sets the length of the secondary axis. The secondary axis is perpendicular to the primary axis.

Rotation Angle

Sets the angle of the primary axis of the ellipse. Zero degrees is horizontal to the x axis. The angle increases in 
the counterclockwise direction.

Circumference

Displays the circumference of a closed element. Although you cannot edit the circumference, the box 
automatically updates when you edit the geometry.

Area

Displays the area of a closed element. Although you cannot edit the area, the box automatically updates when 
you edit the geometry.

Point Tab Options

Type

Displays the type of the selected element. You cannot edit the type.

Sheet

Displays the name of the drawing sheet that contains the element. You cannot edit the name of the drawing 
sheet.

Layer

Sets the layer that contains the element.

Coordinate 

Sets the x and y values for an element.

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 

Y

Sets a value for the y coordinate. You can use this option by itself or with the X option.

Fillet Tab Options

Type



Displays the type of the selected element. You cannot edit the type.

Sheet

Displays the name of the drawing sheet that contains the element. You cannot edit the name of the drawing 
sheet.

Layer

Sets the layer that contains the element.

Radius

Specifies the radius between the two elements you want to use to create the fillet.

Chamfer Tab Options

Type

Displays the type of the selected element. You cannot edit the type.

Sheet

Displays the name of the drawing sheet that contains the element. You cannot edit the name of the drawing 
sheet.

Layer

Sets the layer that contains the element.

Angle

Measures the angle between the chamfer and the first linear element.

Setback A

Specifies the distance from the corner to the beginning of the chamfer on the first linear element you select.

Setback B

Specifies the distance from the corner to the beginning of the chamfer on the second linear element you select.

Rectangle Tab Options

Type

Displays the type of the selected element. You cannot edit the type.

Sheet

Displays the name of the drawing sheet that contains the element. You cannot edit the name of the drawing 
sheet.

Layer

Sets the layer that contains the element.

Centroid

Defines the exact center of the rectangle with X and Y coordinates.

Height

Sets the height of the rectangle or square.

Width

Sets the width of the rectangle or square. 

Angle

Sets the orientation angle of the element. Zero degrees is horizontal to the x axis. The angle increases in the 
counterclockwise direction. 

Circumference



Displays the circumference of a closed element. Although you cannot edit the circumference, the box 
automatically updates when you edit the geometry.

Area

Displays the area of a closed element. Although you cannot edit the area, the box automatically updates when 
you edit the geometry.

Connector Tab Options

Type

Displays the type of the selected element. You cannot edit the type.

Sheet

Displays the name of the drawing sheet that contains the element. You cannot edit the name of the drawing 
sheet.

Layer

Sets the layer that contains the element.

Start Point

Sets the x and y values for the start point of the connector.

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 

Y

Sets a value for the y coordinate. You can use this option by itself or with the X option.

End Point 

Sets the x and y values for the end point of a connector.

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 

# Vertices

Sets the number of vertices for a connector.



Rectangle Ribbon Bar
{button Related Topics,AL("draw high;rectangle cmd",0,`NOT_FOUND')} {button How To,AL("rectangle 
how;rectangle freeform how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Width

Sets the width of the rectangle or square. 

Height

Sets the height of the rectangle or square.

Angle

Sets the orientation angle of the element. Zero degrees is horizontal to the x axis. The angle increases in the 
counterclockwise direction. 



Variable Table 
{button Related Topics,AL("variables high;variable cmd;variable table high;functions high;filter db 
",0,`NOT_FOUND')} {button How To,AL("variables how",0,`NOT_FOUND')}

Displays, defines, and manipulates design variables and functional relationships between the variables. This 
table operates much like a software spreadsheet. The design variables can be dimensions in the document or 
variables defined with the Variable Table. The table consists of the following columns:    Type, Name, Value, 
Formula. Each row of the table displays a variable.

Table Options

Unit Type

Specifies the unit of measure for the variable entered in the Variable Table. The box is located in the top left 
corner of the Variable Table. The default type is distance which means that any expression created will be a 
distance parameter. For example, if you want to create a variable to control an angular dimensions, you should 
change the unit type to angular. Then, the variable created will be an angular type, which can be used to control 
an angular dimensional relationship.

Enter

Accepts the edits you have made in the cell.

Cancel

Clears the contents of the cell and returns the cell to its previous value.

Filter

Access the Filter dialog box so that you can restrict the display of variables in the Variable Table window.

Function Wizard

Accesses the Function Wizard dialog box.

The following items describe the columns in the Variable Table:

Type

Displays the variable type, generally the type of a dimension, such as DIM, VAR, SCALAR, and so forth. DIM 
refers to a dimensional relationship. VAR refers to a variable that you have created. This option is read-only.

Name

Names the variable. By default, the software places the name of a dimension in this column. These names can 
be renamed to a more logical one, if you want. You must always name user-defined variables when you create 
them. A variable must be named if you want to refer to it in the Formula column of another row. You can change 
the name by editing the Name cell and then selecting the Check button at the top of the Variable Table.

Variable names should meet the following requirements:
They must begin with a letter.
They must contain only letters, numbers, and the underscore character; you cannot use punctuation 

characters and spaces.
They must be forty characters or less.

Value

Displays the current value of the variable. A variable always has a value. You cannot edit the value of a variable 
that has formula. You can edit driving dimensions with the Variable Table.

Formula

Displays the function or relation that defines the value of the variable. You can enter a mathematical expression 



in a cell in this column to calculate the value for a corresponding dimension. If the Formula cell is empty, then 
the variable value is independent of other variables.

When using variable names within a formula, the names are case sensitive. For example, the names var1 and 
Var1 reference two different variables.

If a value is defined by a formula, the formula appears in the Formula cell. You can enter an algebraic 
expression in the formula cell to define the value of the variable. The single line expression must be in standard 
Visual Basic syntax. The formula can include any available function. The resulting value of the formula is shown 
in the Value column of the variable. 

The software provides a set of standard mathematical functions. You can also select Visual Basic functions that 
you wrote and saved. The functions can be typed in with the proper syntax or you can use the Function Wizard 
to select and define the inputs to the function. If the function does not contain proper syntax, the software 
displays a message indicating that there is an error in the formula.



Function Wizard Step 1 of 2 Dialog Box
{button Related Topics,AL("variables high;variable cmd;variable table high;functions high",0,`NOT_FOUND')}

{button How To,AL("variables how",0,`NOT_FOUND')}

Selects the function you want to enter.

Dialog Box Options

Function Category

Selects subsets of all available functions. If you click the All in the Function Category box, all the available 
functions appear. If you select any other category, only those functions that belong to that category appear. 

Custom functions that you define are included under their assigned categories, or in the user-defined category if 
no other categories are assigned. See the alphabetical list of functions.

Function Name

Lists all built-in and custom functions that are available in the selected category. Also lists built-in and custom 
macro functions if a macro sheet is active. The display area describes the selected function.

Next

Moves to the next dialog box of the Function Wizard. You should click Next after you have selected the function
you want to insert into the Formula Bar or the selected cell. After you finish typing values into the appropriate 
fields, the Function Wizard Step 2 Of 2 dialog box is displayed. This dialog box appears first if you are entering a 
math and trig function.
Note    If you select a function that you defined using Visual Basic, a dialog box appears first that allows you to 
open the document that contains the function. After you open the document, the Function Wizard Step 2 Of 2 
dialog box is displayed.

Finish

Inserts the function into the Formula Bar. If you do not enter an argument, the software inserts the argument 
names as placeholders in the formula.

Cancel

Closes the Function Wizard dialog box without entering anything into the Formula Bar or into the selected cell.



Alphabetical List of Functions
{button Related Topics,AL("variables high;variable cmd;variable table high;functions high",0,`NOT_FOUND')}

{button How To,AL("variables how",0,`NOT_FOUND')}

The following functions are available in the Variable Table. They are referred to as math and trig functions.
ABS Returns the absolute value of a number
ATN Returns the arctangent of a number
COS Returns the cosine of a number
EXP Returns e raised to the power of a given number
FIX Returns the integer portion of a number.
INT Rounds a number down to the nearest integer
LOG Returns the natural algorithm of a number
RND Rounds a number to a specified number of digits
SGN Returns an integer indicating the sign of a number
SIN Returns the sine of the given angle
SQR Returns the square root of number.
TAN Returns the tangent of an angle

The following functions are also available in the Variable Table.
User, Visual 
Basic

Relates variables through a user function, usually defined 
with Visual Basic.



Function Wizard Step 2 of 2 Dialog Box
{button Related Topics,AL("variables high;variable cmd;variable table high;function wizard step 1 of 2 
db;functions high",0,`NOT_FOUND')} {button How To,AL("variables how",0,`NOT_FOUND')}

Enters values, references, names, formulas, and other functions into the fields. The dialog box changes 
according to the function you select in the Function Wizard Step 1 of 2 dialog box. Your entries must produce 
valid values for the arguments. If an argument is required for the function to be entered successfully, the word 
"required" appears in brackets in the display area.

Dialog Box Options

FuncName

Displays the name of the function.

FnSummary

Displays a summary of the function.

Number

Displays the number of the function.

First Arg

Displays the argument of the variable. In the Function Wizard Step 1 of 2 dialog box, if the selected variable is a
subroutine that you defined, more than one box appears on the Function Wizard Step 2 of 2 dialog box. The 
checkbox to the right of the field indicates whether the variable is an input or output argument.

Back

Moves from the current Function Wizard dialog box to the preceding one.

Finish

Enters the completed function in the Variable Table.



Filter Dialog Box
{button Related Topics,AL("variable table cmd;variable table high;filter cmd",0,`NOT_FOUND')} {button How 
To,AL("variable table how",0,`NOT_FOUND')}

Controls which variables appear in the Variable Table.

Dialog Box Options

Type

Specifies the type of variables that are displayed in the Variable Table. If you click Dimension, then only 
dimension variables are displayed in the Variable Table; these variables directly control elements of a design. If 
you click User Variables, then only logical variables that you created are displayed. This variable type cannot 
directly control a design. A user variable must be set equal to a value or mathematical expression; for example, 
PI = 3.14159. Variables can control dimensional relationships by setting the dimensional relationship equal to the
variable.

Named By

Controls the view in the Variable Table so that only named variables are displayed.

User

Displays only variables that you have named.

System

Displays only variables, usually the dimensions, that the software has created. 

Both

Displays all variables that are named.

Graphics In

Displays variables that are associated with elements in the current document, active window, or group of 
elements that you have selected.

Last Selected Window

Displays variables that are associated with elements in the active window.

Select Set

Displays variables that are associated with elements in a group that you have selected in the document.

File

Displays variables that are associated with elements in the current document.



Format Dimension Dialog Box
{button Related Topics,AL("format dimension cmd",0,`NOT_FOUND')} {button How To,AL("format dimension 
how",0,`NOT_FOUND')}

Sets options for placing dimensions. You can access this dialog box with the    Dimension command on the 
Format menu.    You can define dimension styles with the Style command on the Format menu.

Tabs

General Tab

Units Tab

Secondary Units Tab

Text Tab

Spacing Tab

Terminator and Symbol Tab

Lines and Coordinate Tab



Colors Dialog Box
{button Related Topics,AL("fill rb;custom color name db;display manager db;custom color name 
db",0,`NOT_FOUND')} {button How To,AL("create color how",0,`NOT_FOUND')}

Creates colors that you define by mixing a combination of hue, saturation, and luminosity values or red, green, 
and blue values. After you click the Define Custom Colors button, the easiest way to experiment with different 
colors is to drag the pointer around on the color matrix.

After you create a color and close the dialog box, the Custom Color Name dialog box appears, allowing you to 
save the custom color with a name.

To change the settings for a custom color, you can click a custom color box and then specify a different color. To 
define a new custom color, click an empty custom color box, specify a new color, and then click Add To Custom 
Colors.

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.



Custom Color Name Dialog Box
{button Related Topics,AL("fill rb;colors db;color db;display manager db",0,`NOT_FOUND')} {button How 
To,AL("create color how",0,`NOT_FOUND')}

Saves a color that you created with a name.    This dialog box appears after you create a color with the Colors 
dialog box.

Dialog Box Options

Color Name

Specifies the name of the color that you created on the Colors dialog box. After you save the custom color with a
name, the name appears on the color palette.



Fill Ribbon Bar
{button Related Topics,AL("fill cmd",0,`NOT_FOUND')} {button How To,AL("fill how",0,`NOT_FOUND')}

Displays the active settings for a fill.
Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Options

Style

Lists and applies the available styles. To define a new fill style, you can type a name in the box. The new style 
uses the current settings on the ribbon bar.

Pattern Color

Applies a pattern line color for pattern fills. If you select none, the background will be transparent. Filled elements
cover other elements when they overlap. You can click the More option to define custom colors with the Colors     
dialog box.

Solid Color

Applies a system color to set the background color for the fill. If you select none, the background will be 
transparent. Filled elements cover other elements when they overlap. You can click the More option to define 
custom colors with the Colors   dialog box  .
Tip    The blank fill color takes on the background color of the document. This is useful for creating symbols that 
can cover an element on which the symbol is placed. Incorporating a fill with blank color into the symbol allows 
the symbol, when placed, to mask out elements such as lines or connectors that intersect the symbol.

Redo Fill

Re-applies a fill to a filled area when the boundary changes. A fill can become disabled, and change color, if you 
modify its boundary by drawing another element or moving part of the existing boundary. If you click Redo Fill, 
the area surrounding the fill handle is filled again.

Angle

Sets the angle of the fill in the active unit. Zero degrees is horizontal to the x axis, and the angle (A) increases in 
a counterclockwise direction with zero on the positive side (B) of the x axis. If you type a negative value, the 
software displays the equivalent positive value.

Spacing

Adjusts the spacing of the pattern lines in a fill.



Layers Ribbon Bar
{button Related Topics,AL(`layers cmd;layers high',0,`NOT_FOUND')} {button How To,AL(`filter how;layers 
how',0,`NOT_FOUND')}

Note    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the 
ToolTip.

Ribbon Bar Options

Layer

Displays the active layer on the drawing sheet. You can change the active layer by selecting from a list of all the 
layers on the active sheet. Typing a new layer name creates a new layer.

Change Layer

Accesses the Change Layer   dialog box   so that you can change the layer of elements. This option is available 
only when you have selected a set of elements on the drawing.

Layer Status

Accesses the Layer Display   dialog box  . This dialog box has a Layer list that you can use to display or hide 
layers on the drawing sheet.



Groups Dialog Box
{button Related Topics,AL(`layer groups cmd',0,`NOT_FOUND')} {button How To,AL(`layer groups 
how',0,`NOT_FOUND')}

Creates, modifies, or deletes layers and layer groups. You can only work with layers for the active sheet in the 
active window. You cannot delete the active layer or a layer that has elements placed on it. 
Dialog Box Options

Layers

Displays a list of all the layers on the current drawing sheet. so that you can create new layers. You can type the 
name of a layer in the Layers box to create a new layer. You can also add or remove layers in a layer group with 
the Layers table. When you select a group in the Groups table, the check boxes in the Grouped column of the 
Layers table indicate the status of the layers. If the check box is set, the layer is a member of the group that you 
selected in the Groups table. If the check box is cleared, the layer is not a member of the group.

Groups

Displays all layer groups for the current sheet. You can define a new group by typing a name in the Groups box. 
You can select a group from the Groups table to display the layers in the group in the Groups table. To select a 
group, you must click the button on the left side of the row for a group. You can use the Description column to 
add a description to the layer group. Typing a name of an existing layer group makes that group active. You can 
then add or remove layers in a group.



Layer Display Dialog Box
{button Related Topics,AL(`layers cmd;layers high',0,`NOT_FOUND')} {button How To,AL(`filter how;layers 
how',0,`NOT_FOUND')}

Sets display criteria for the layers in the current drawing sheet.
Note You can set display criteria for all the sheets in the current document with the Display Manager command 
on the Tools menu.    

Dialog Box Options

Active Layer Only

Displays the active layer. If this option is set and the active layer changes, then the new active layer is displayed 
and the previous active layer is hidden.

Layers

Displays a list of layers on the active drawing sheet. Bold, black text shows that the layer is displayed on the 
drawing sheet. Plain, gray text shows the layer is hidden. Bold, red text preceded by a bullet shows that the layer
is active.

Occupied Only

Lists only layers containing elements. Empty layers do not appear on the list.

Groups

Displays or hides the layer groups list on the dialog box. When you click this button, the dialog box displays a list 
of all layer groups for the active drawing sheet. You can select a group from the list to display or hide these 
layers on the drawing sheet.

On

Displays the layers in the selected layer group.

Off

Hides the layers in the selected layer group.

Apply

Applies the current display settings to all windows.



Change Layer Dialog Box
{button Related Topics,AL(`layers cmd',0,`NOT_FOUND')} {button How To,AL(`filter how;layers 
how',0,`NOT_FOUND')}

Dialog Box Options

Current Layers

Lists the layers for all the selected elements. 

Change All To

Lists all the layers for the active sheet. Selecting a layer from the list changes the layer for all the elements in the 
selection set.



Fillet Ribbon Bar
{button Related Topics,AL("fillet cmd;extending or trimming high",0,`NOT_FOUND')} {button How 
To,AL("fillet how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Sets the drawing style.

Line Color

Sets the drawing color. You can click the More option to define custom colors with the Colors   dialog box  .

Line Type

Sets the drawing line type and style.

Line Width

Sets the line width.

Radius

Specifies the radius between the two elements you want to use to create the fillet.



Fill Properties Dialog Box
{button Related Topics,AL("element properties cmd",0,`NOT_FOUND')} {button How To,AL("format fill 
how",0,`NOT_FOUND')}

Sets the properties of a fill.    

Tab

Fill Tab



Fill Tab
{button Related Topics,AL("fill properties db;new fill style db;modify fill style db",0,`NOT_FOUND')}{button How 
To,AL("format fill how",0,`NOT_FOUND')}

Formats a fill. This tab is available only if you have selected a fill or an element with a fill.

Tab Options

Style

Displays the name of the style applied to the element. 

Solid Color

Applies a system color to set the background color for the fill. If you select none, the background will be 
transparent. Filled elements cover other elements when they overlap. You can click the More option to define 
custom colors with the Colors dialog box.

Pattern Color

Applies a pattern line color for pattern fills. If you select none, the background will be transparent. Filled elements
cover other elements when they overlap. You can click the More option to define custom colors with the Colors 
Dialog Box.

Line Width

Sets the line width.

Pattern Spacing

Adjusts the spacing of the pattern lines in a fill.

Pattern Angle

Sets the angle of the fill in the active unit. Zero degrees is horizontal to the x axis, and the angle (A) increases in 
a counterclockwise direction with zero on the positive side (B) of the x axis. If you type a negative value, the 
software displays the equivalent positive value.

Preview

Displays the range of the graphic to print on the printer paper.



Display Manager Dialog Box
{button Related Topics,AL(`display manager cmd',0,`NOT_FOUND')} {button How To,AL(`filter 
how',0,`NOT_FOUND')}

Specifies the way elements or objects appear in a window for all drawing sheets and their associated layers in 
the document.
Note You can set display options for the current drawing sheet on the Layer Display dialog box. You can access
the Layer Display dialog box with the Layers command on the Tools menu.

Tabs

Sheets Tab

Layers Tab



Sheets Tab
{button Related Topics,AL(`display manager db',0,`NOT_FOUND')} {button How To,AL(`filter 
how',0,`NOT_FOUND')}

Controls the way elements or objects appear on a drawing sheet.

Tab Options

Row Button

Specifies at what level you want to display or hide items. When you click a button to the left of a row, an arrow 
appears by that row. 

Clicking this button selects the drawing sheet or element so that you can modify its display. If you select a 
drawing sheet, any options you set on the Layer tab of the Display Manager dialog box are applied to the sheet 
that you selected.

Sheets

Displays a list of sheets in the current document. An arrow appears by the active drawing sheet by default. You 
can control the display of each sheet by setting the options you want in the Display, Lock, Color, Type, or 
Width columns. 

Display

Displays the elements listed on the Layers tab. If you set the box next to the element, the element is displayed in
the active document (if its layer is displayed).

A check appears in each box when you first access the Layers tab. 
You can set the box next to each element to display all the elements. 
On the Layers tab, you cannot turn the active layer off. 

Lock

Locks or unlocks elements and layers in a view to control whether the software can locate them. If an element or 
layer is locked, you can still see it on the screen, but you cannot locate it or perform actions on it. You cannot 
lock the active layer.

If the lock beside a sheet or layer appears locked, you cannot locate the element or layer in the active 
document or drawing sheet. 

If the lock beside a sheet or layer appears unlocked, the element or layer is not locked and you can locate it.

Color

Overrides the color for a drawing sheet or element or applies another color to an element. You can select a color 
from the list. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Overrides a line type for a drawing sheet or embedded object and sets another line style for an element or linked 
object. 

Width

Overrides a line width for all elements on a drawing sheet.

Clear

Removes all overrides from the selected row. You must select a row before you can click this button. You can 
clear settings from only one row at a time.

Apply

Applies the current display settings.



Layers Tab
{button Related Topics,AL(`display manager db',0,`NOT_FOUND')} {button How To,AL(`filter how;layers 
how',0,`NOT_FOUND')}

Controls the way layers and layer groups appear in a window.    

Tab Options

Row Button

Shows the active layer. The active layer cannot be changed. 

Layers

Controls the display using layers and layers groups. The Layers column displays an alphabetical list of layers 
and layer groups for the active drawing sheet. 

Layer groups appear first in the list followed by individual layers. You can control the display of each layer by 
setting the options    you want in the Display, Lock, Color, Type, or Width columns.

Display

Displays the elements listed on the Layers tab. If you set the box next to the element, the element is displayed in
the active document (if its layer is displayed).

A check appears in each box when you first access the Layers tab. 
You can set the box next to each element to display all the elements. 
On the Layers tab, you cannot turn the active layer off. 

Lock

Locks or unlocks elements and layers in a view to control whether the software can locate them. If an element or 
layer is locked, you can still see it on the screen, but you cannot locate it or perform actions on it. You cannot 
lock the active layer.

If the lock beside a sheet or layer appears locked, you cannot locate the element or layer in the active 
document or drawing sheet. 

If the lock beside a sheet or layer appears unlocked, the element or layer is not locked and you can locate it.

Color

Overrides the color for a layer or layer group or applies another color to an element. You can select a color from 
the list. You can click the More option to define custom colors with the Colors dialog box.

Line Type

Overrides a line type for a drawing sheet or embedded object and sets another line style for an element or linked 
object. 

Width

Selects another line width for layer or layer group.

Clear

Removes all overrides from the selected row. You must select a row before you can click this button. You can 
clear settings from only one row at a time.

Apply

Applies the current display settings.



Format Line Dialog Box
{button Related Topics,AL("format line cmd",0,`NOT_FOUND')} {button How To,AL("format line 
how",0,`NOT_FOUND')}

Sets options for placing lines. You can access this dialog box by clicking Line on the Format menu. You define 
line styles by clicking Style on the Format menu.

Tabs

General Tab



Unicode Character Map Dialog Box
{button Related Topics,AL("text cmd;annotations high",0,`NOT_FOUND')} {button How To,AL("insert font 
character into text box how",0,`NOT_FOUND')}

Selects special characters for inserting into a text box.

Dialog Box Options

Font

Lists the available fonts.

Subset

Lists the subsets for a particular font.

Next

Displays the next subset in the Subset list for a font.

Previous

Displays the previous subset in the Subset list for a font.

Characters To Copy

Displays selected characters to copy to the Clipboard.

Select

Copies selected characters to the Characters To Copy box.

Copy

Copies the selected characters from the Characters To Copy box to the Clipboard.



Format Text Box Dialog Box
{button Related Topics,AL("text cmd",0,`NOT_FOUND')} {button How To,AL("format text 
how",0,`NOT_FOUND')}

Sets options for placing text boxes. You can access this dialog box by clicking Text Box on the Format menu.    
You define text styles by clicking Style on the Format menu.

Tab

Paragraph Tab



Group Properties Dialog Box
{button Related Topics,AL("groups high;group cmd",0,`NOT_FOUND')} {button How To,AL("group 
how",0,`NOT_FOUND')}

Displays the properties of the selected group.

Dialog Box Tabs

Info Tab



Group Ribbon Bar
{button Related Topics,AL("groups high;group cmd",0,`NOT_FOUND')} {button How To,AL("group 
how",0,`NOT_FOUND')}

Note    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the 
ToolTip.

Ribbon Bar Options

Style

Sets the style for all of the elements in a group.

Color

Sets the color for all of the elements in a group.

Line Type

Sets the line types and styles for all of the elements in a group.

Width

Sets the line width for all of the elements in a group.

Name

Displays the name of the group. The software names the group when you create it.

Properties

Accesses the Properties   dialog box   for the group.



Info Tab
{button Related Topics,AL("groups high;group properties db;element properties cmd",0,`NOT_FOUND')}

{button How To,AL("group how",0,`NOT_FOUND')}

Tab Options

Type

Displays the type of the selected element. You cannot edit the type.

Sheet

Displays the name of the drawing sheet the element is on. You cannot edit the name of the drawing sheet.

Name

Displays the name of the group. The software names the group when you create it.

Number Of Items

Displays the number of elements in the group. This box updates automatically when you add elements to or 
delete elements from the group.

Is Nested Within Another Group

Shows whether the group is nested within another group. This box updates automatically when you nest a group 
with the Group command or ungroup a group with the Ungroup command.

Contains Nested Groups

Displays whether or not the selected group contains nested groups.

Closed

Shows whether the members of the group are primitive elements, such as lines, arcs, and curves; whether the 
end points of these elements are connected; and whether the members of the group form a closed region. 

This box updates automatically when you add elements to or delete elements from the group.

End-Point Connected

Shows whether the members of the group are primitive elements, such as lines, arcs, and curves, and whether 
the end points of these elements are connected. This box updates automatically when you add elements to or 
delete elements from the group.



Tip of the Day Dialog Box
{button Related Topics,AL("tip of the day cmd",0,`NOT_FOUND')} {button How To,AL("tip 
how",0,`NOT_FOUND')}

Displays a tip each time you start the software. You can also activate this dialog box by choosing the Tip of the 
Day command from the Help menu.

Dialog Box Options

Did You Know

Displays a tip about using a feature.

More Tips

Displays a list of available tips.

Next Tip

Displays the next tip in the list.

Show Tips At Startup

Displays a tip every time you start the software. If you do not want to display tips when you start the software, 
clear this option.



Insert Object Dialog Box
{button Related Topics,AL("insert cmd;ole high;",0,`NOT_FOUND')} {button How To,AL("embed object 
how;link object how",0,`NOT_FOUND')}

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.



Links Dialog Box
{button Related Topics,AL("links high;links cmd;ole high",0,`NOT_FOUND')} {button How To,AL("link how;ole 
how",0,`NOT_FOUND')}

Displays information about links in a document including file name, file location, and whether the link is 
automatically updated.

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.



Run Macro Dialog Box
{button Related Topics,AL("macro cmd",0,`NOT_FOUND')} {button How To,AL("macro 
how",0,`NOT_FOUND')}

Selects the macro that you want to run.

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.

When you position the pointer in this dialog box and right-click, you can access a variety of standard commands 
that help you manage your documents more efficiently. For example, if you select a document in the list and then
right-click, you can then click the Select command on the shortcut menu to automatically open the document. 
You can also create shortcuts, send the document somewhere else, and other activities.



Mirror Ribbon Bar
{button Related Topics,AL("mirror cmd",0,`NOT_FOUND')} {button How To,AL("mirror how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Copy

Mirrors and copies the elements in the selection set.

Position Angle

Sets the angle of the mirror axis. The origin of the angle measurement is the point you clicked for the beginning 
of the mirror axis. Setting the position angle to 0 extends the axis horizontally to the right of the screen, 90 
extends the axis vertically to the top, 180 extends the axis horizontally to the left, and 270 extends the axis 
vertically to the bottom.



Move Ribbon Bar
{button Related Topics,AL("move cmd",0,`NOT_FOUND')} {button How To,AL("move element 
how",0,`NOT_FOUND')}

Specifies the from point and to point when you move objects or elements.
Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

X

Sets a value for the x coordinate. You can use this option by itself or with the Y option. 

Y

Sets a value for the y coordinate. You can use this option by itself or with the X option.

Copy

Copies the elements in the selection set. 

Step Value

Increments or decrements the value displayed in the ribbon bar boxes. For example, typing a step value of 0.25 
and moving the pointer away from the from point would increment the distance from 0.25 to 0.5, 0.75, and so 
forth.



Map Network Drive Dialog Box
{button Related Topics,AL("map network drive cmd;documents high",0,`NOT_FOUND')} {button How To,AL("set 
file location how",0,`NOT_FOUND')}

Connects to shared directories on the network.

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.



Disconnect Network Drive Dialog Box
{button Related Topics,AL("disconnect network drive cmd",0,`NOT_FOUND')} {button How To,AL("disconnect 
how",0,`NOT_FOUND')}

Disconnects your computer from a shared directory on the network.

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.



File New Dialog Box
{button Related Topics,AL("new cmd;templates high",0,`NOT_FOUND')} {button How To,AL("create 
document how",0,`NOT_FOUND')}

Creates a new document or template. For information about each template, click the Related Topics button.

Dialog Box Options

Templates

Lists the templates available in the TEMPLATE directory that is located in the directory where you installed the 
software. Select the template that you want to use to create a new document or template.
Tip    You can change the directory where templates are stored by selecting the Options command on the Tools 
menu and setting the directory that you want on the File Locations tab of the Options dialog box. If you change 
this setting, the Templates list on the File New dialog box displays a list of the templates in the directory that you
specified.



Offset Ribbon Bar
{button Related Topics,AL("offset cmd",0,`NOT_FOUND')} {button How To,AL("offset how;copy 
how",0,`NOT_FOUND')}

Ribbon Bar Options

Offset Chain

Selects a chain of continuous elements. 

If this option is not selected, Offset selects only an individual element.

Step Distance

Sets the distance from the base element to the offset copy.

Cumulative Offset

Sets the total distance of the current offset graphic element from the original graphic element.

The following graphic illustrates the difference between step distance (A) and cumulative offset (B).



File Open Dialog Box
{button Related Topics,AL("open cmd",0,`NOT_FOUND')} {button How To,AL("open how",0,`NOT_FOUND')}

Controls how a document is opened.

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.

When you position the pointer in this dialog box and right-click, you can access a variety of standard commands 
that help you manage your documents more efficiently. For example, if you select a document in the list and then
right-click, you can then click the Select command on the shortcut menu to automatically open the document. 
You can also create shortcuts, send the document somewhere else, and other activities.
 



Options Dialog Box
{button Related Topics,AL("options cmd",0,`NOT_FOUND')} {button How To,AL("options how;ole 
how",0,`NOT_FOUND')}

Sets options for the current document. For example, you can set the grid display by clicking the View tab.

Tabs

Colors Tab

General Tab

File Locations Tab

View Tab

Symbols Tab

Reference Files Tab



Colors Tab
{button Related Topics,AL("options db",0,`NOT_FOUND')} {button How To,AL("options 
how",0,`NOT_FOUND')}

Controls color settings for the active document.

Tab Options

Sheet

Sets the default color of all drawing sheets in the active document.

Highlight

Sets the highlight color.

Selected Element

Sets the color of selected elements.

Disabled Elements

Sets the color of disabled elements.

Handles

Sets the color of handles when an element is selected.



Reference Files Tab
{button Related Topics,AL("options db",0,`NOT_FOUND')} {button How To,AL("options how;ms 
how",0,`NOT_FOUND')}

Tab Options

Scale

Sets a scale option for importing a document.

Coincident

Brings in a reference file, also known as an inserted object, at full scale (1:1) and coincident to its original 
coordinate position. The setting shifts the drawing sheet to the lower left of the document graphic range 
and then determines a drawing sheet scale that fits the reference file within the sheet. If the current 
document already contains graphics, the drawing sheet shifts to include those graphics. 
Note    If you use the Coincident setting, the reference file does not appear when you drag the pointer.

Select Scale

Sets the drawing scale to a standard ratio. The specified ratio defines the size of the drawing in relation to
the size of the real-world object. For a 2:1 ratio, 2 represents the size of the drawing and 1 represents the
size of the real-world object.
Note    The Fit to Sheet option determines a drawing sheet scale that fits the reference file within the 
sheet, but allows you to specify where to insert the file by clicking on the drawing sheet.

Custom Scale

Sets the scale that you type in the boxes for a document that you insert or drag. For example, when you 
type in 3 and 2 in each of the respective boxes, the scale of the foreign document is one-and-a-half times
its original size.



Foreign Data Tab
{button Related Topics,AL("options db",0,`NOT_FOUND')} {button How To,AL("options how;ms 
how",0,`NOT_FOUND')}

Sets options for moving information into the current document by dragging a document or by clicking one of the 
following commands:

Paste Special command on the Edit menu 
Object command on the Insert menu
Open command on the File menu.

Tab Options

Format

Sets the type of format that you can use for importing or saving a document. When you click MicroStation or 
AutoCAD and then click the appropriate Options button, you can access a specific dialog box to set options for 
importing or saving AutoCAD (.dxf, .dwg) or MicroStation (.dgn) documents.

Import

Sets options for importing an AutoCAD or MicroStation document.

File Units

Sets the units for the document you want to import. When you insert or drag a document into the drawing 
sheet, the software uses this setting only when the document has units assigned that the software does 
not recognize.

Orientation

Sets the orientation for the document that you want to import.

Options

Accesses one of the dialog boxes for importing an AutoCAD or MicroStation document.

Export

Sets options for saving a document as an AutoCAD or MicroStation document.

Options

Accesses one of the dialog boxes for exporting an AutoCAD or MicroStation document.



General Tab
{button Related Topics,AL("options db",0,`NOT_FOUND')} {button How To,AL("options 
how",0,`NOT_FOUND')}

Controls settings such as the display of 3-D effects and the number of entries in the list of recently used files.

Tab Options

Update Links Automatically At Open

Updates links automatically when the document is open and this option is set.

Recently Used Files List

Sets the number of entries for the Recent Files area of the File menu when the Recent Files area is set.

Dimension Keyin Values Automatically

Places dimensions for recognized step values or for values you type in a ribbon bar field.

Display Unit Of Measurement Labels

Displays the units of measurement in the value field.

Undo Steps

Sets the number of operations that can be undone.



File Locations Tab
{button Related Topics,AL("options db",0,`NOT_FOUND')} {button How To,AL("options 
how",0,`NOT_FOUND')}

Specifies the default location for documents, templates, and other objects you create or use in the software. You 
can use the following types of documents:

Documents
User-defined templates
Fonts
Macros
MicroStation references
AutoCAD references

Tab Options

File Types

Indicates the file type for which you want to specify a location.

Location

Displays the designated location for each file type.

Modify

Accesses the Modify Location dialog box. The directory selected with the dialog box is displayed in the 
Location column on this tab. After you select a location, you can delete it later by selecting the location in the 
Location column and pressing Delete.



View Tab
{button Related Topics,AL("options db",0,`NOT_FOUND')} {button How To,AL("options 
how",0,`NOT_FOUND')}

Controls the appearance of the software and document window, such as the display of the graph paper, ruler, 
and scroll bar.

Tab Options

Display As Printed

Displays the document as it appears on paper.

Window

Controls the window display.

Status Bar

Displays the status bar of the application.

Horizontal Scroll Bar

Displays the horizontal scroll bar of the active window.

Vertical Scroll Bar

Displays the vertical scroll bar of the active window.

Sheet Tabs

Displays the drawing sheet tabs.

Grid

Allows you to set options for the grid.

Grid Display

Displays a grid so that you can place elements with precision. The grid lines are not considered part of 
the document and do not print.

Grid Snap

Aligns elements with the grid. The grid is an invisible set of lines in the document that helps you align 
elements. When you set the Grid Snap option, elements always align with the grid lines or nearest 
intersection of the grid lines. 

Grid Style

Changes the format of the grid lines to either static or dynamic. 

When you zoom in or out, the software dynamically generates the grid lines for a dynamic grid . You can 
set dynamic grid lines to appear at fine, medium, or coarse levels. The grid lines appear at common 
major measurement increments. A dynamic grid displays index lines that intersect with the darker, solid 
grid lines.

A static grid displays solid grid lines that do not move as you zoom in or out. The grid maintains a 
constant minimum spacing.

Grid Spacing

Sets the spacing of the major grid lines. This option is available only if you select Static in the Grid Style 
list box. The selected options on the Units tab of the Properties dialog box determine the units that you 
can enter, such as inches or centimeters.
Tip    You can open the Properties dialog box by clicking Properties on the File menu.

Grid Index

Determines the number of index grid lines, also known as minor grid lines, to be equally spaced between 
the major grid lines. This option is available only if you select Static in the Grid Style list box.



Grid Density

Changes the number of dashes in the index lines, or minor grid lines, between intersections with the grid 
lines. This option is available only if you select Dynamic in the Grid Style list box.



Symbols Tab
{button Related Topics,AL("options db",0,`NOT_FOUND')} {button How To,AL("options how;place symbol 
how",0,`NOT_FOUND')}

Determines the default actions when you drag a symbol into the document. You can override the settings on this 
tab when you drag a symbol. You can press Ctrl to embed the symbol or Ctrl + Shift to link the symbol.

Tab Options

Drag and Drop Default

Specifies actions when you drag a symbol into the document.

Embed

Sets the default action so that the symbol embeds when you drag it on the drawing sheet. Embedding the 
symbol means that the software places a copy of the symbol in the document. If you edit one instance of the 
embedded symbol in a document, all copies of that symbol within the current document reflect those changes.

Link

Sets the default action so that the symbol is linked when you drag it into the document. Linking the symbol allows
you to edit the original symbol document. The symbol that you placed on the drawing sheet updates 
automatically. If you edit the symbol inside the active document, those changes are saved in the .sym document 
on your computer.



PinPoint Ribbon Bar
{button Related Topics,AL("pinpoint cmd ",0,`NOT_FOUND')} {button How To,AL("pinpoint 
how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

On/Off (F9)

Displays or hides the PinPoint help lines and distance values.

Reposition Target (F12)

Attaches the target point to the pointer so that you can reposition the target point. Click where you want the 
target point to be.

Step

Specifies the PinPoint step value. The step value is an incremental distance along the PinPoint coordinate 
axes. When the distance between the target position and the current pointer location is an increment of the step 
value, the related coordinate value and help line become bold.

Angle

Specifies the angle of the PinPoint x help line relative to its default horizontal orientation. Positive values rotate 
the horizontal line counterclockwise. Negative values rotate the horizontal line clockwise.

X

Locks the horizontal distance between the target point and the current pointer location to the value you type.

Y

Locks the vertical distance between the target point and the current pointer location to the value you type.



Print Dialog Box
{button Related Topics,AL("print cmd",0,`NOT_FOUND')} {button How To,AL("print document how;preview 
document how;print to file how",0,`NOT_FOUND')}

Controls the way a document prints.

Dialog Box Options

Name

Specifies the printer that you want to use. You can select from a list of all the configured printers available for 
printing.

Properties

Accesses the Printer Document Properties   dialog box.  

Status

Displays the current status of the selected printer. This area is read-only.

Type

Displays the type of printer currently selected. This area is read-only.

Where

Displays the printer path or location for the currently selected printer. This area is read-only.

Comment

Displays any comments you input during printer configuration. This area is read-only.

Print To File

Prints the document to a file, instead of a printer. You specify the file's name on the Print To File dialog box after 
you set the check box and click OK on the Print dialog box. This saves a document to a file instead of routing it 
directly to a printer or plotter. Then, you can print from a computer that does not have the application installed or 
print to a printer other than the one you currently have installed.

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.

When you position the pointer in this dialog box and right-click, you can access a variety of standard commands 
that help you manage your documents more efficiently. For example, if you select a document in the list and then
right-click, you can then click the Select command on the shortcut menu to automatically open the document. 
You can also create shortcuts, send the document somewhere else, and other activities.

Print Range

Displays options for selecting the print range.

All Sheets

Prints all drawing sheets in the active document.

Selected Sheets

Prints all the sheets that you selected as a composite document, as layers all on one sheet of paper.

Sheets

Specifies the range of pages that you want to print. You can enter the starting page you want to print    as 
the "From" value and the ending page you want to print as the "To" value. In the Sheets box, type a 
range with a hyphen between the sheet numbers. For example, to print sheets 3 through 7, type 3-7. This
prints each sheet on a separate piece of paper.

Print Area

Accesses the Print Area   dialog box.   When you click this option and then click OK on the dialog box, a 
set of crosshairs appears. You drag the crosshairs to define the area that you want to print. Then, the 
Print Area dialog box automatically appears so that you can set various options for printing the area that 



you selected.

Copies

Sets options for the number of copies you want to print.

Number Of Copies

Specifies the number of copies you want to print.

Collate

Organizes sheets when you print multiple copies.

Pure Black and White

Prints a black and white document.

Settings

Accesses the Settings   dialog box.  



Printer Document Properties Dialog Box
{button Related Topics,AL("print cmd;print db",0,`NOT_FOUND')} {button How To,AL("print document 
how;preview document how",0,`NOT_FOUND')}

Sets properties for the current printer that you selected on the Print dialog box. The settings available on this 
dialog box depend on the type of printer that you selected. 

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.

When you position the pointer in this dialog box and right-click, you can access a variety of standard commands 
that help you manage your documents more efficiently. For example, if you select a document in the list and then
right-click, you can then click the Select command on the shortcut menu to automatically open the document. 
You can also create shortcuts, send the document somewhere else, and other activities.

 



Properties Dialog Box
{button Related Topics,AL("properties cmd",0,`NOT_FOUND')} {button How To,AL("properties 
how",0,`NOT_FOUND')}

Tracks information about the properties of a document.
Note    You must save the document before you can access the Statistics and Summary tabs of the Properties 
dialog box. If a symbol document (.sym) is open, the only tabs that appear are the General, Units, and Symbols
tabs.

Tabs

General Tab

Summary Tab

Statistics Tab

Units Tab

Browser Tab

Symbols Tab

Behavior Tab



General Tab
{button Related Topics,AL("properties db",0,`NOT_FOUND')} {button How To,AL("properties 
how",0,`NOT_FOUND')}

Displays general information about the current document.
Note    If some of the following information is not available, the boxes display "Unknown."

Tab Options

Filename

Displays the name of the document.

Type

Displays the type of document. The type is based on the application used to create the document.

Location

Displays the directory containing the document.

Size

Displays the size of the document in bytes, kilobytes, and megabytes.

MS-DOS Name

Displays the name of the document as it would appear in a File Allocation Table file naming system. These types 
of documents have an eight-character name and three-character extension.

Created

Displays the date and time the document was created or copied.

Modified

Displays the date and time the document was last modified.

Accessed

Displays the date that the document was last opened or copied.

Attributes

Displays the attributes of the current document. These settings are read-only.

Read-Only

Indicates that the document is read-only. You cannot open a read-only file for writing. You cannot create a
file with the same name as a read-only file.

Archive

Shows that the document is an archive document.

Hidden

Indicates that the document is a hidden document. You usually cannot see this document in the Windows
Explorer.

System

Shows that the document is a system document. You usually cannot see this document unless you 
change the options in the Internet Explorer.



Browser Tab
{button Related Topics,AL("properties db",0,`NOT_FOUND')} {button How To,AL("properties how;browser 
how",0,`NOT_FOUND')}

Sets the home address for the active document. Every time you open this document and click the Home button 
on the Symbol Explorer, the Symbol Explorer goes to the address in the Address box. This tab is available 
only for documents that are symbols and have an .sym extension.

Tab Options

Address

Sets the home address for the current document. When you open a document and then open the Symbol 
Explorer and click the Home button, the Symbol Explorer goes to the address that you type here. You can any 
address that you use in a web browser, such as Microsoft Internet Explorer; for example, you can type 
http://www.ingr.com.

If you want to set the Symbol Explorer to always look at symbols on your computer, you can enter the following 
syntax in the Address box: <application.path>\..\<path of symbols. For example, you could enter 
<application.path>\..\symbols\arch.htm.

Browse

Accesses the Modify Location dialog box so that you can set another directory for the Symbol Explorer to look
in. You can set the dialog box to look in directories on your computer or a network drive. 



Symbol Tab
{button Related Topics,AL("properties db;av high",0,`NOT_FOUND')} {button How To,AL("properties 
how;attribute how;edit symbols how ",0,`NOT_FOUND')}

Defines the symbol properties for an .sym document. With this tab, you can assign descriptive information that 
identifies the symbol. When you drag the symbol into a document, these values appear in the Attribute Viewer.

For example, if you wanted to define a bill of materials, you can assign manufacturing information on this tab for 
a door symbol, place the symbol in a document, and then create a report that displays the manufacturing 
information.

Tab Options

Name

Defines a property name.

Type

Specifies the property type you want to define for the symbol property name. You can choose from Character, 
Number, Money, or Date.

Value

Specifies a value for the symbol. For example, you can assign a manufacturer's name, a serial number, or other 
descriptive information as a value.

Properties

The properties table lists all the properties currently defined for the symbol.



Units Tab
{button Related Topics,AL("properties db",0,`NOT_FOUND')} {button How To,AL("properties 
how",0,`NOT_FOUND')}

Sets up units of measure and precision readout for the length, area, or angle values in a drawing. 

The precision readout sets the number of significant figures to display. It sets the accuracy of the unit readout 
value. The precision setting does not alter the numbers that you type into the fields, only the display of the 
numbers in the field. Values ending in 5 are rounded up. For example, if the precision readout is .123 and you 
draw a line that is 2.1056 inches long, then the line value length is rounded. The length value appears as 2.106 
inches long. If you are using mm as your drawing sheet units, you can have the values display in the fields as 3.5
mm or 3.50 mm.
Note    When you set options on this tab for the units in a document,    the settings do not affect the dimensional 
values for the document. You can set options for the dimensional value by selecting a dimension and clicking the 
Properties command on the Edit menu. You can also set the units by modifying a dimension style with the Style
command on the Format menu.

Tab Options

Length Readout

Sets the unit of measure and precision readout for the length values in a document.

Angle Readout

Sets the unit of measure and precision readout for the angle values in a document.

Area Readout

Sets the unit of measure and precision readout for the area values in a document.



Summary Tab
{button Related Topics,AL("properties db",0,`NOT_FOUND')} {button How To,AL("properties 
how",0,`NOT_FOUND')}

Displays the title and author, if available, along with keywords and comments for the current document. The 
software generates the author and template information when you create, save, or print the document. You can 
also edit these properties, with the exception of the template, unless the document is write-protected.

Tab Options

Title

Specifies the title of the current document.

Subject

Gives a general description of the current document.

Author

Displays the name of the person who created the document.

Keywords

Displays a list of words that identify the document when you browse or search documents.

Comments

Specifies comments about the current document.

Template

Displays the name of the document template that was used to create the document.



Statistics Tab
{button Related Topics,AL("properties db",0,`NOT_FOUND')} {button How To,AL("properties 
how",0,`NOT_FOUND')}

Displays detailed information about the current document. The software automatically generates these properties
when you create, save, or print the document.

Tab Options

Created

Displays the date and time the document was created or copied.

Creating Application

Displays the name of the application that created the document.

Modified

Displays the date and time the document was last modified.

Accessed

Displays the date that the document was last opened or copied.

Last Saved By

Displays the name of the person who last saved the document.

Saving Application

Displays the name of the application that most recently saved the document.

Currently Opened By

Displays the name of the person who has the document open.



User Tab
{button Related Topics,AL("element properties cmd;formatting elements high",0,`NOT_FOUND')} {button How 
To,AL("format how",0,`NOT_FOUND')}

Tab Options

Attribute Set

Names a group of attributes. You can type a name in the box and press Enter.

Attributes

Sets the name, type, and value of the attribute set. You can type a name in the box and press Enter.

Name

Sets the name of a unique attribute in the attribute set.

Type

Sets the type for the attribute, such as double, text, number, money, or date.

Value

Sets the value for the attribute. The value that you can enter is based on the type that you selected in the Type 
box.

Add

Adds an attribute to the attribute set. After you click the Add button, the attribute appears in the table.

Delete

Removes an attribute from the attribute set. You can select an attribute by clicking a row in the table.

Apply

Places the attribute set on the element that you selected.

Remove

Removes the attribute set from the element that you selected.



Print Area Dialog Box
{button Related Topics,AL("print cmd;print db",0,`NOT_FOUND')} {button How To,AL("print 
how",0,`NOT_FOUND')}

Specifies the area that you want to print.

Dialog Box Options

Scale

Controls the scale applied to the print area in a document.

Best Fit

Scales the selected drawing sheets or print area to fit the printer paper for the configured device.

Manual Scale

Specifies the scale value to apply to the print range during printing. For example, if the print range is a 
rectangle at 12 cm by 12 cm and you set a manual scale of 1:12, then the printed range appears as 1 cm 
by 1 cm on the printer paper.

If you want a 1:1 drawing of the current sheet scale, you can set the paper length to 1 and the design 
length to 1.

Tip    If you type values in the Paper Length and Design Length boxes, the red, blue, and black boxes in
the Preview area change to reflect the values.

Paper Length

Specifies the paper length for the document you want to print.

Design Length

Specifies a design length.

Origin

Adjusts the location of the effective print area on the printer paper.

Center

Positions the print area center to the center of the printer paper. If you do not set this option, then the 
paper positions at bottom left to bottom left.

X

Sets a shift in the X direction from the origin.

Y

Sets a shift in the Y direction from the origin.

Preview

Displays the range of the graphic to print on the printer paper.

XY Range

Clears the previous defined print area and prompts you to define a new print area.



Paste Special Dialog Box
{button Related Topics,AL("ole high;copy high",0,`NOT_FOUND')} {button How To,AL("paste special 
how",0,`NOT_FOUND')}

Inserts the Clipboard contents into a document using a selected format.

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.



Rectangular Pattern Ribbon Bar
{button Related Topics,AL("rectangular pattern cmd",0,`NOT_FOUND')} {button How To,AL("rectangular 
pattern how ",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Options

Displays the Rectangular Pattern Options dialog box.

X Count

Sets the number of pattern members along the x axis of the pattern rectangle.

Y Count

Sets the number of pattern members along the y axis of the pattern rectangle.

X Offset

Sets the distance between adjacent rows in the pattern, measured along the x axis of the pattern rectangle.

Y Offset

Sets the distance between adjacent rows in the pattern, measured along the y axis of the pattern rectangle.

Angle
Sets the rotation angle of the pattern rectangle.

Finish

Completes the pattern. When you click this button, the pattern is created on the drawing sheet and you can 
select other elements.



Rectangular Pattern Options Dialog Box
{button Related Topics,AL("rectangular pattern cmd",0,`NOT_FOUND')} {button How To,AL("rectangular 
pattern how ",0,`NOT_FOUND')}

Dialog Box Options

Pattern Control

Specifies how the pattern is constructed.
Incremental Array—Draws a pattern with a set offset between members.
Fit To Rectangle—Draws a pattern by evenly spacing members along the x and y axes of the pattern 

rectangle.

Stagger

Controls whether pattern members are arranged in a straight matrix, or whether every other row or column is 
offset from its default position. Options are None, for a straight matrix, Rows, to offset alternate pattern rows, and
Columns, to offset alternate pattern columns.

Stagger

Sets the row or column stagger distance to the specified distance.

Stagger Offset/2

Sets the row or column stagger distance to half the X Offset or Y Offset value.

Include Last Column

Controls whether to include the last staggered column in the pattern or to exclude the last column.

Preview

Displays the range of the graphic to print on the printer paper.



Rotate Ribbon Bar
{button Related Topics,AL("rotate cmd",0,`NOT_FOUND')} {button How To,AL("rotate element 
how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Copy

Creates a copy of the element that you are rotating. If you do not want a copy of the rotated element, then clear 
this option.

Step Angle

Specifies the rotation step angle. The step angle specifies the increments, in degrees, that an element rotates 
from a temporary axis. The temporary axis is the line between the element's center of rotation (A) and the point 
that you rotate the element from (B).

 

You can enter increments in the Step Angle box if you want to dynamically view the results of the rotation. For 
example, if the box is set to 30.0, the rotation is displayed in 30 degree increments. The default setting is 0 
degrees so that the rotation is fully dynamic. 

Rotation Angle

Defines the rotation angle. The rotation angle is the angle between the point that you rotate from and the point 
that you rotate to. In the following picture, the center of rotation (A) is shown with the point that you rotate the 
element from (B). 
 

The rotation angle (C) is the angle of change between the old and new positions of the rotated element. The 
value is always positive.

Position Angle

Displays the angle between the horizontal axis through the center of rotation (A) and the point that you rotate 
from (B). Then, if you rotate the element, the position angle (C) changes to become the angle between the 
horizontal axis and the point that you rotate to. The position angle is always a positive value that is measured 
counter-clockwise from the axis.



 



Save As Dialog Box
{button Related Topics,AL("save cmd;save copy as cmd",0,`NOT_FOUND')} {button How To,AL("save 
how",0,`NOT_FOUND')}

Specifies the name of, location of, and format for a document when you save it.

Tip    To get Help for various items on the dialog box, click the Question Mark  in the upper right corner of the 
dialog box and click the control that you want information about.

When you position the pointer in this dialog box and right-click, you can access a variety of standard commands 
that help you manage your documents more efficiently. For example, if you select a document in the list and then
right-click, you can then click the Select command on the shortcut menu to automatically open the document. 
You can also create shortcuts, send the document somewhere else, and other activities.



Scale Ribbon Bar
{button Related Topics,AL("scale cmd ",0,`NOT_FOUND')} {button How To,AL("scale how",0,`NOT_FOUND')}

Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Copy

Scales and copies the elements in the selection set.

Step

Specifies the step value for the Scale Factor. The step value causes the Scale Factor to be decreased or 
increased in increments as you move the pointer toward or away from the scale origin. For example, if you set 
the step value to 0.25, the scale increases in increments of 0.25 as you move the pointer away from the scale 
origin.

Scale Factor

Specifies how much the software reduces or enlarges the element. A scale factor between zero and one 
reduces; a scale factor greater than one enlarges.

Reference

Specifies how long the dynamic line from the scale origin to the pointer has to be in order to achieve a Scale 
Factor of 1.

For example, if you set Reference to 1, for every inch you move the pointer away from the scale origin, the scale
factor increases by one. If you set Reference to 2, for every two inches you move the pointer away from the 
scale origin, the scale factor increases by one.



Select Tool Ribbon Bar
{button Related Topics,AL("select tool cmd",0,`NOT_FOUND')} {button How To,AL("select 
how",0,`NOT_FOUND')}

The default selection ribbon bar is displayed only when nothing is selected. Once you select an object, the 
selection ribbon bar is replaced with a ribbon bar for editing the selected object.
Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Inside

Specifies that elements inside the fence are selected.

Overlapping

Specifies that elements overlapped by the fence are selected, as well as elements inside the fence.

Top Down

Specifies that groups of elements are located as opposed to individual elements in a group.

Bottom Up

Specifies that individual elements in a group are located as opposed to the whole group.

Expand

Displays another ribbon bar depending on the items that you selected on the drawing sheet. This button appears 
when you select ten or more items on the drawing sheet. When you click it, another ribbon bar appears. 

The options that appear depend on the types of elements that you selected. For example, if you select eleven 
lines, then the Line ribbon bar appears. If you select several types of items, then only the common properties for 
those types of elements appear on the Select Tool ribbon bar. For example, if you select nine lines and a circle, 
then the ribbon bar displays the Style, Line Type, Width, and Color options. For more information about the 
options that appear, see the Help topic for the selected element's ribbon bar.

If the items that you selected have no common properties, then no options will appear if you click the Expand 
button. For example, if you select a dimension and ten lines and then click the Expand button, a ribbon bar does 
not appear.



Settings Dialog Box
{button Related Topics,AL("print cmd;print db",0,`NOT_FOUND')} {button How To,AL("print 
how",0,`NOT_FOUND')}

Controls the print area of a selected sheet.

Dialog Box Options

Print Range

Displays the X and Y values of the part of the drawing sheet that you want to print or plot.

X

Displays a value for the range in the X direction, horizontal to the bottom of the screen, for the area that 
you want to print.

Y

Displays a value for the range in the Y direction, vertical to the bottom of the screen, for the area that you 
want to print.

Scale

Controls the scale applied to the print area in a document.

Best Fit

Scales the selected drawing sheets or print area to fit the printer paper for the configured device.

Manual Scale

Specifies the scale value to apply to the print range during printing. For example, if the print range is a 
rectangle at 12 cm by 12 cm and you set a manual scale of 1:12, then the printed range appears as 1 cm 
by 1 cm on the printer paper.

If you want a 1:1 drawing of the current sheet scale, you can set the paper length to 1 and the design 
length to 1.

Tip    If you type values in the Paper Length and Design Length boxes, the red, blue, and black boxes in
the Preview area change to reflect the values.

Paper Length

Specifies the paper length for the document you want to print.

Design Length

Specifies a design length.

Origin

Adjusts the location of the effective print area on the printer paper.

Center

Positions the print area center to the center of the printer paper. If you do not set this option, then the 
paper positions at bottom left to bottom left.

X

Sets a shift in the X direction from the origin.

Y

Sets a shift in the Y direction from the origin.

Preview

Displays the range of the graphic to print on the printer paper.
Tip    If you click Manual Scale and enter values in the Paper Length and Design Length boxes, the red, blue, 
and black boxes change to reflect the values.    



Effective Plotting Area

Specifies the plotting area for the document.



Properties Dialog Box
{button Related Topics,AL("element properties cmd",0,`NOT_FOUND')} {button How To,AL("embed 
object how;link object how",0,`NOT_FOUND')}

Sets properties for a frame, called a SmartFrame, that provides a border for an object when you insert or paste 
the object into the current document. You can scale the object by dragging one of the handles on the frame. Or, 
you can crop the object by pressing the Shift key and dragging one of the handles.

Tabs

Info Tab

Format Tab



Info Tab
{button Related Topics,AL("smartframe properties db",0,`NOT_FOUND')} {button How To,AL("embed 
object how;link object how",0,`NOT_FOUND')}

Provides information about frames around objects, such as raster images or drawings from other applications.

Tab Options

Type

Displays the category of the selected element. You cannot edit the type.

Origin

Specifies the coordinates, or location, of an element along the X and Y-axes.

Link:

Determines the way that the object links with a SmartFrame. This option is available only for linked objects.

As Part of the Model (Public)

Allows the linked object to publicly appear in any document that links to the current document. Therefore, 
if you link an object to the current drawing and then link to the current drawing from another document, 
the current drawing and the linked object appear in the other document. For example, this setting is 
useful if you link comments from a Word document to the current drawing and you want other documents 
to appear in the current drawing with the comments.

As Reference Only (Private)

Restricts the linked object from being displayed in any document that links to the current document. If the 
current drawing is linked to another document, the linked object does not appear in the other document. 
For example, this setting could be useful if you want to link comments from a Word document to the 
current drawing and you want other documents to display the drawing, but not the comments. 

Scale (1:1)

Sets the drawing scale to a 1:1 ratio. This means that the representation of the objects on the drawing sheet is 
the same size as the real-world object being described.

Select Scale

Sets the drawing scale to a standard ratio. The specified ratio defines the size of the drawing in relation to the 
size of the real-world object. For a 2:1 ratio, the “2” represents the size of the drawing and the “1” represents the
size of the real-world object.
Note    The Fit to Sheet option determines a drawing sheet scale that fits the reference file within the sheet, but 
allows you to specify where to insert the file by clicking the drawing sheet.

Custom

Defines a custom or scale ratio. The first value defines the distance on the drawing sheet and the second value 
defines this distance in a real-world value.



Format Tab
{button Related Topics,AL("smartframe properties db",0,`NOT_FOUND')} {button How To,AL("embed 
object how;link object how",0,`NOT_FOUND')}

Allows you to format frames around objects, such as raster images or drawings from other applications.            

Tab Options

Show Border

Displays the frame border around the object.

Line Width

Sets the line width.

Line Type

Overrides a line type for a drawing sheet or embedded object and sets another line style for an element or linked 
object. 

Frame Shape

Sets the frame shape around the object.

Rectangular

Sets the shape as rectangular.

Elliptical

Sets the shape as an ellipse.



Sheet Setup Dialog Box
{button Related Topics,AL("drawing sheets cmd",0,`NOT_FOUND')} {button How To,AL("setup sheet 
how",0,`NOT_FOUND')}

Defines the properties of the active drawing sheet.

Tabs

Size and Scale Tab

Background Tab

Name Tab



Rename Dialog Box
{button Related Topics,AL("drawing sheets high;drawing sheet tabs high",0,`NOT_FOUND')} {button How 
To,AL("create a new drawing sheet how;change background sheet how",0,`NOT_FOUND')}

Renames a drawing sheet.

Dialog Box Options

New Name

Renames the active sheet when you type a new name.



Size and Scale Tab
{button Related Topics,AL("sheet setup db",0,`NOT_FOUND')} {button How To,AL("setup sheet 
how",0,`NOT_FOUND')}

Defines details for the drawing sheet size, scale, and print setup information.

Tab Options

Sheet Size

Sets the size for the drawing sheet.

Same As Print Setup

Sets the drawing sheet size using the current print setup definition. For example, if the printer is set up as
8 1/2 X 11, the drawing sheet size is set up as 8 1/2 X 11.

Standard

Defines the drawing sheet size from a list of standard ANSI and ISO paper sizes.

Custom

Defines the drawing sheet size according to the entered x and y values.

Drawing Scale

Sets options for the scale of the drawing sheet.

Scale (1:1)

Sets the drawing scale to a 1:1 ratio. As a result, the representation of the objects on the drawing sheet is
the same size as the real-world object being described.

Select Scale

Sets the drawing scale to a standard ratio. The specified ratio defines the size of the drawing in relation to
the size of the real-world object. For a 2:1 ratio, the 2 represents the size of the drawing and the 1 
represents the size of the real-world object.

Custom

Defines a custom or scale ratio. The first value defines the distance on the drawing sheet and the second
value defines what this distance is equal to in the real world.

Paper Units

Sets the paper units for the drawing sheet.

Units

Controls the display of numeric values in dialog boxes that define the size of non-scaled objects. Some 
examples of non-scaled object values are text height and line width. This setting does not affect 
dimension units. 

Only value boxes use this option. For example, if you are working in feet and inches, you can specify that
you want to read and enter values for text height in fractional inches. (1/8" instead of 0.00'-0.125" )
Note    When printing or plotting a drawing sheet, the non-scaled items appear on the printed document 
with the exact size that you specify. 

Precision

Sets the number of significant figures to display, or the accuracy of the unit readout value. The precision 
setting does not change the numbers that you can type in the fields, only the display of the numbers in 
the field. Values ending in 5 are rounded up to the next whole number. 

For example, if you set this control to .001 and you draw a line that is 2.1056 inches, then the line length 
value is rounded. The length value appears as 2.106 inches. If you set this control to 0.01 and you type a 
line length value of 3.5 mm, the length value appears as 3.50 mm.





Background Tab
{button Related Topics,AL("sheet setup db",0,`NOT_FOUND')} {button How To,AL("setup sheet 
how",0,`NOT_FOUND')}

Defines the color, margin settings and background sheet display information.

Tab Options

Background Sheet

Specifies the background sheet that you want to use for the working sheet. If you have not created a background
sheet, this box does not display any options. You must first create a background sheet before you can select it 
from the list.

All graphics on the background sheet display on the working sheet. Changing the background sheet updates the 
size and margin settings of the working sheet to the values defined by the selected background sheet.

Show Background

Displays the background sheet graphics on the selected working sheet.

Preview

Displays the range of the graphic to print on the printer paper.



Name Tab
{button Related Topics,AL("sheet setup db",0,`NOT_FOUND')} {button How To,AL("rename drawing 
sheet how;setup sheet how",0,`NOT_FOUND')}

Defines the name of a drawing sheet.    You can also change the name of a drawing sheet.

Tab Options

Sheet Name

Specifies a name for the drawing sheet. You can also use this box to rename a drawing sheet by selecting the 
sheet in the document before clicking Sheet Setup on the File menu.



SmartSketch Dialog Box
{button Related Topics,AL("smartsketch cmd",0,`NOT_FOUND')} {button How To,AL("smartsketch 
how",0,`NOT_FOUND')}

Customizes the operation of the software in recognizing and placing relationships. You can set pointer behavior 
and specify which relationships are recognized as you draw.

Tabs

Relationships Tab

Cursor Tab



Relationships Tab
{button Related Topics,AL("smartsketch db",0,`NOT_FOUND')} {button How To,AL("smartsketch 
how",0,`NOT_FOUND')}

Sets which relationships are recognized by the software as you draw. Set the relationships you want to 
recognize, and clear the relationships you do not want to recognize. Clear all relationships so that the software 
does not place relationship handles..



Cursor Tab
{button Related Topics,AL("smartsketch db;intent zone high",0,`NOT_FOUND')} {button How To,AL("smartsketch 
how",0,`NOT_FOUND')}

Tab Options

Cursor Setup 

Sets the sizes of the Locate Zone and Intent Zone around the pointer.

 Locate Zone

Sets the size of the locate zone radius. The locate zone is a region around the pointer.

The software recognizes relationships based on elements within the locate zone so that you do not have 
to move the cursor to an exact position. For example, if part of an element is within the locate zone, the 
software recognizes a Point On relationship.

The size of the locate zone is indicated by a circle around the center of the pointer crosshair. Values from 
3 to 12 pixels are valid.

 #Intent Zone

Sets the size of the intent zone radius. Intent zones allow drawing commands to interpret your intentions 
as you draw. Values from 3 to 12 pixels are valid.

Preview

Shows the size of the locate zone and the symbol for the selected relationship.



Reapply Style Dialog Box
{button Related Topics,AL("style high;styles high",0,`NOT_FOUND')} {button How To,AL("apply style 
how",0,`NOT_FOUND')}

Redefines a style according to the formatting of selected element, or returns the formatting of selected element 
to that of the style currently applied to it.

Dialog Box Options

Style

Displays the name of the style that is currently applied to the selected element .

Do You Want To Redefine The Style Using The Selection As An Example?

Changes the formatting of the current style to the formatting applied to the element that you selected.

Do You Want To Return The Formatting Of The Selection To The Style?

Applies the formatting of the current style to the element that you selected.



Style Resources Dialog Box
{button Related Topics,AL("style cmd;style db",0,`NOT_FOUND')} {button How To,AL("style resource 
how",0,`NOT_FOUND')}

Lists style resource documents that are available to the current document. Resources can be any .igr document 
or MicroStation line style resource with an .RSC extension. The styles in the style resource document are 
available for use in the current document.

Dialog Box Options

Style Resource Files

Lists the style resource documents that are attached to the current document. When you attach one of these 
documents to a template, the styles in the document appear on the Style dropdown list of the ribbon bar in the 
current document. A style is copied into the current document from the style resource document when you select 
this style on the ribbon bar. A style is also copied when you apply the style to an element or annotation on the 
drawing sheet. For example, if you attach DIMENSION.igr to the document, the dimension styles in 
DIMENSION.igr appear on the dropdown list when you select a dimension on the drawing sheet of the active 
document. You can then apply any of the styles to the dimension. The dimension style that you applied is then 
copied from DIMENSION.igr into the active document when you save it.

Add

Allows you to add a style resource document to the Style Resource Files list with the Add Style Resource 
dialog box. This dialog box allows you to select .RSC or .igr documents and add them to the Style Resource 
Files list on the Style Resources dialog box.

Remove

Removes a style resource document from the Style Resource Files list. You must first select a document in that 
list.



Modify Dimension Style Dialog Box
{button Related Topics,AL(`style cmd',0,`NOT_FOUND')} {button How To,AL(`use style 
how',0,`NOT_FOUND')}

Modifies a dimension style.

Tabs

Name Tab

General Tab

Units Tab

Secondary Units Tab

Text Tab

Spacing Tab

Terminator and Symbol Tab

Lines and Coordinate Tab



General Tab
{button Related Topics,AL("modify line style db;new line style db",0,`NOT_FOUND')} {button How 
To,AL("format line how",0,`NOT_FOUND')}

Sets formats for a line.

Tab Options

Style

Displays the name of the style that is currently applied to the selected element .

Color

Sets the drawing color.

Width

Sets the line width.

Type

Defines how the line appears.

Description

Displays a description of the formatting options.



Modify Line Style Dialog Box
{button Related Topics,AL("styles db",0,`NOT_FOUND')} {button How To,AL("use style 
how",0,`NOT_FOUND')}

Modifies a line style by allowing you to specify new characteristics or a dash definition.

Tabs

Name Tab

General Tab



Name Tab
{button Related Topics,AL("styles db",0,`NOT_FOUND')} {button How To,AL("use style 
how",0,`NOT_FOUND')}

Names a style when you create or modify a style.    This tab appears only when you click the New or Modify 
button on the Styles dialog box.

Tab Options

Name

Names the style. Style names can contain up to 253 characters (including aliases and separators) and can 
include any combination of characters and spaces, except the backslash character (\), semicolon (;), and braces 
({ }). Style names are case sensitive.

Based On

Displays the name of the style that the current style is based on.

Description

Displays a description of the formatting options.



Modify Text Box Style Dialog Box
{button Related Topics,AL("style cmd;styles db;text cmd",0,`NOT_FOUND')} {button How To,AL("use style 
how",0,`NOT_FOUND')}

Modifies a style by allowing you to specify new characteristics.

Tabs

Name Tab

Paragraph Tab



Style Dialog Box
{button Related Topics,AL("style cmd",0,`NOT_FOUND')} {button How To,AL("use style how;apply style 
how",0,`NOT_FOUND')}

Specifies the name of the style, the formats defined for the style, and other options for working with styles.
Note    You cannot create or modify a fill style with this dialog box.    To create a new fill style, you can type a 
name for a fill style in the Style box on the Fill ribbon bar.    The new style is saved with the current settings on 
the Fill ribbon bar. 

The sample macro, PATTERN.DLL, allows you to browse through AutoCAD .PAT files and add the patterns to 
the active document. You can place this macro on a toolbar or menu with the Customize command on the Tools
menu; or you can access it by clicking the Macro command on the Tools menu. The PATTERN.DLL macro is 
located in the \Smartsketch\CUSTOM\BIN\OLESVR.
Note If you cannot find the CUSTOM directory, you must run the Setup program again. In the Setup program, 
you must select the Custom setup.

Dialog Box Options

Style Type

Specifies the style type. If you are placing a new element, you can specify the style by clicking the appropriate 
style type in this box and then clicking the style that you want in the Styles box. You can also change the style of 
an existing element by selecting the element and then clicking the Styles command on the Format menu to set 
these options.

Styles

Specifies the style. Before selecting an item on this list, you must first select the appropriate style type in the 
Style Type box.

List

Specifies which styles appear in the Styles list. You can list only the styles in use, styles that you defined, or all 
styles.
Tip    The only styles that are appear in the list are styles that are saved in the current document. The styles 
saved in a styles resource document are not listed. However, if you click the New button, you can select a style 
from a style resource document to use as a base style for the new style that you are creating. 

Description

Displays a description of the settings in the style.

Delete

Deletes the selected style from the document or template.

Apply

Applies the style selected in the Styles box to elements that you selected. Applying a new style to elements that 
you selected removes the current formats for the element.

New

Accesses one of the New Style dialog boxes so that you can create a new style.

Modify

Accesses one of the Modify Style dialog boxes. so that you can modify the style that you selected in the Styles 
list.

Resources

Allows you to add style resource documents to the current template with the Style Resources dialog box.



New Dimension Style Dialog Box
{button Related Topics,AL(`style cmd',0,`NOT_FOUND')} {button How To,AL(`use style 
how',0,`NOT_FOUND')}

Creates a new dimension style.

Tabs

Name Tab

General Tab

Units Tab

Secondary Units Tab

Text Tab

Spacing Tab

Terminator and Symbol Tab

Lines and Coordinate Tab



New Line Style Dialog Box
{button Related Topics,AL("styles db",0,`NOT_FOUND')} {button How To,AL("use style 
how",0,`NOT_FOUND')}

Creates a line style by allowing you to specify new characteristics.    You can also define a new dash definition.

Tabs

Name Tab

General Tab



New Text Box Style Dialog Box
{button Related Topics,AL("style cmd;styles db;text cmd",0,`NOT_FOUND')} {button How To,AL("use style 
how",0,`NOT_FOUND')}

Specifies the name of the style, the formats defined for the style, and other characteristics.

Tabs

Name Tab

Paragraph Tab



Text Box Ribbon Bar
{button Related Topics,AL("text cmd",0,`NOT_FOUND')} {button How To,AL("text how",0,`NOT_FOUND')}

Formats a text box.
Tip    To find out the name of an option on the ribbon bar, pause the pointer over an option and read the ToolTip.

Ribbon Bar Options

Style

Lists and applies the available styles.

Font

Lists and applies the available fonts.

Font Size

Applies a text size.

Text Color

Sets the color of the font.

Bold

Makes text bold.

Italic

Italicizes text.

Underline

Underlines text.

Paragraph Alignment

Positions the paragraph to the left, center, or right of the text area edges in edit mode.
Tip    You can also align the paragraph after you select text.

Border

Displays three options for setting borders. These options allow you to either display no border, display a border, 
or display a border with a shadow.

More

Displays more options on the ribbon bar.

Height 

Sets the height of the text box.

Width

Sets the width of the text box. 
Tips

If you select text in the text box, Height and Width are not available because the text is driving the 
dimension.

If you select a text box and Height is not available, the text is driving Height with the Auto Save option. The
same is true for Width. 

If you place a text box with a single point, both Height and Width are not available. If you drag a text box, 
Width is not available. 

Angle

Sets the angle of the text box.

Horizontal Text Orientation

Specifies that the text is oriented horizontally on or in the document.



Vertical Text Orientation

Specifies that the text is oriented vertically on or in the document.

Left To Right

Specifies that the characters in a text box are displayed from left to right, as you would see in an English 
paragraph. 

Right To Left

Specifies that the characters in a text box are displayed from right to left, as you would see in an Arabic or 
Japanese paragraph. 



Text Box Properties Dialog Box
{button Related Topics,AL("element properties cmd;texthand high",0,`NOT_FOUND')} {button How 
To,AL("format text how",0,`NOT_FOUND')}

Formats the font, paragraph, borders, or shading of a text box.

Tabs

Info Tab

Paragraph Tab

Border and Fill Tab



Info Tab
{button Related Topics,AL("new text style db;modify text style db;text properties db;text db;paper units 
high;texthand high",0,`NOT_FOUND')} {button How To,AL(`format text how',0,`NOT_FOUND')}

Tab Options

Sheet

Shows the drawing sheet for an element.

Layer

Shows the layer on which an element appears in a drawing sheet.

Origin

Specifies the coordinates, or location, of a text box along the x and y axes.
Tip    All metrics on the text box are either in paper units or world units except origin. Origin is always in world 
units.

Width

Sets the width of the text box to either At Least (at least the value you specify), Auto (the text drives the width), 
or Exactly (exactly at the value you specify) in the At: field.

Height

Sets the height of the text box to either At Least (at least the value you specify), Auto (the text drives the 
height), or Exactly (exactly at the value you specify) in the At: field.

Angle

Sets the angle of the text box.
Tip    The text box always rotates about the origin.

Text Orientation

Sets the orientation of the text either horizontally or vertically.

Units Space

Sets the text box units to either paper units or to world units.

Paper units represent units on an actual sheet of paper. Paper units are set in inches. Other units are also 
available.

World units indicate real world distances, but can be scaled down to fit a sheet of paper.

Text Flow

Determines the direction in which the characters are displayed in a text box.

Left To Right

Specifies that the characters in a text box are displayed from left to right, as you would see in an English 
paragraph. 

Right To Left

Specifies that the characters in a text box are displayed from right to left, as you would see in an Arabic 
or Japanese paragraph. 

Justification

Specifies the placement relationship between the origin and the shape (text box) according to the horizontal and 
vertical components. 

The inside text area is an area that the margins of the text box define. That is, margins are inside the outside 
edges of the text box.

The following graphic illustrates top (1), right (2), bottom (3) and left (4) margins around the text box for 
horizontal justification (A) and vertical justification (B).



The maximum cap height of the first formatted text line of each line defines the text area capline, even if the line 
has been clipped out of the text box.

The line baseline is a font metric that describes an imaginary line for location of characters. The largest 
descender for any font on the line defines the baseline. Therefore, the largest descender of the fonts used on the
last line defines the text area baseline, even if the line is clipped out of the text box.

The following graphic illustrates text cap area (a) and text baseline (b) for horizontal justification (A) and vertical 
justification (B).

You must define horizontal and vertical components together. These components apply to both single-line and 
multi-line text. For multi-line text, the cap height of the first line is used for the capline of the text, and the 
descender of the last line is used for the baseline of the text.

Horizontal

Specifies horizontal placement at six options based on shape (text box), text area, and the text within the 
text box at left, center, and right positions.

Vertical

Specifies vertical placement at 10 options based on shape (text box), text area, and the text within the 
text box.
Text Baseline—Specifies the text area baseline. 
Text Top—Specifies the top of the text area, which begins at the bottom of the top margin. 
Text Capline—Specifies the text area capline.
Text Half Ascender—Specifies half the distance from the text area baseline to the top of the text area.
Text Half Cap—Specifies the distance half way between the text area capline and baseline.
Text Center—Specifies the center of the text area. 
Text Bottom—Specifies the bottom of the text area. 
Shape Top—Specifies the top edge of the shape. 
Shape Center—Specifies center of the shape. 
Shape Bottom—Specifies the bottom of the shape. 

Text Alignment



Specifies the placement of formatted text within the shape (text box).

You must define horizontal and vertical components together.

Horizontal

Specifies how each paragraph is aligned within the block of formatted text. Values for horizontal 
alignment include Left, Center, and Right.

If Text Orientation is horizontal, you modify all the paragraph alignment properties for all paragraphs 
within the text box. (These properties appear in the Text Alignment area of the Info tab.)

If Text Orientation is vertical, you modify the shape alignment properties. (These properties appear in 
the Text Alignment area of the Info tab.)

Vertical

Places the block of formatted text at Top, Center, Bottom, or Justify area of the text box.

If Text Orientation is horizontal, you modify the shape alignment properties. (These properties appear in 
the Text Alignment area of the Info tab.)

If Text Orientation is vertical, you modify all the paragraph alignment properties for all paragraphs within 
the text box. (These properties appear in the Text Alignment area of the Info tab.)

Horizontal Paragraph Alignment Properties
Left—Places the edge of the first line of text at the left of the text area. 
Center—Places the formatted text in the center of the text area. 
Right—Places the formatted text in the right of the text area. 

Vertical Paragraph Alignment Properties
Top—Places the edge of the first line of text at the top of the text area. 
Center—Places the formatted text in the center of the text area. 
Bottom—Places the formatted text in the bottom of the text area. 
Shape Alignment Properties
Positions the text within the text area.
Top—Places the edge of the first line of text at the top of the text area. 
Center—Places the formatted text in the center of the text area. 
Bottom—Places the formatted text in the bottom of the text area. 
Justified—Places the first line of the first paragraph at the top of the text area. 

Places the last line of the last paragraph at the bottom of the text area. 

Places remaining paragraphs at equal distance between the first and last paragraphs.

Margins

Sets the distance between the edge of the shape and the edge of the text area. Margins are in the same units as
the text box. 

Top

Sets the distance between the top edge of the shape and the top edge of the text area.

Bottom

Sets the distance between the bottom edge of the shape and the bottom edge of the text area.

Left

Sets the distance between the left edge of the shape and the left edge of the text area.

Right

Sets the distance between the right edge of the shape and the right edge of the text area.



Border and Fill Tab
{button Related Topics,AL("new text style db;modify text style db;text properties db;text db",0,`NOT_FOUND')}

{button How To,AL("format text how;text how",0,`NOT_FOUND')}

Tab Options

Border

Specifies the appearance of a border around a text box.

Show Border

Displays the outline of the text box.

Linestyle

Sets the linestyle for the text box.

Border Color

Sets the color of the border.

Line Width

Specifies the width of the border in paper or world units of the text box. 

Shadow

Places a shadow around the borders of text in a text box.

Shadow Offset

Specifies a distance to offset the shadow in paper or world units of the text box.

Fill Color

Displays the color of a solid fill on an element boundary. This value overrides the style of the fill. Transparent is 
the default. When you set the fill color to transparent, no fill is visible on the boundary. You can also apply a fill 
color option with a fill pattern. Filled elements always cover other elements when they overlap. A fill color always 
appears behind the fill pattern when you apply both to the same boundary.



Paragraph Tab
{button Related Topics,AL("new text style db;modify text style db;text properties db;text db",0,`NOT_FOUND')}

{button How To,AL("format text how",0,`NOT_FOUND')}

Tab Options

Text Style

Displays the style for a text box.

Font

Lists and applies the available fonts.

Font Size

Applies a text size.

Font Style

Lists the available font styles.

Underline

Underlines text.

Language

Lists and applies a language for text in a text box. If you use text characters from more than one language in a 
text box, the option you specify in this box determines the way the lines wrap in the paragraph.

Units Space

Sets the paragraph to paper units or to world units. You can change this control only when you are creating new 
styles from the Format Styles dialog box. When you view this control from the Properties dialog box, it is read-
only. You can change the control from the Info tab because all paragraphs contained within a text box must exist 
in the same units. 

Text Color

Sets the color of the font.

Spacing

Determines the amount of space between lines and paragraphs in a text box.

Text Alignment

Specifies alignment for each paragraph within the block of formatted text. Values for horizontal alignment include 
Left, Center, and Right. 

If Text Orientation is horizontal, you modify all the paragraph alignment properties for all paragraphs within the 
text box. (These properties appear in the Text Alignment area of the Info tab.) 

If Text Orientation is vertical, you modify the shape alignment properties. (These properties appear in the Text 
Alignment area of the Info tab. 

Paragraph

Specifies the amount of space before and after paragraphs. No spacing exists before the first paragraph and or 
after the last paragraph.

Before

Adds space before a paragraph. This value is set in the current working units, not in points.

After

Adds space after a paragraph. This value is set in the current working units, not in points. You can set the
units with the Units command on the Format menu.

Line



Lists and applies the amount of vertical space between lines of text.
Single sets the line spacing for each line to display the largest font in the line. 
1.5 sets the line space for the line to one-and-a-half that of single lines. 
Double sets the line spacing for the line to twice that of single lines.



Toolbars Dialog Box
{button Related Topics,AL("customize db",0,`NOT_FOUND')} {button How To,AL("customize toolbar 
how;toolbars how",0,`NOT_FOUND')}

Sets options for displaying, hiding, or changing toolbars.

Dialog Box Options

Toolbars

Lists the available toolbars. You can select the box next to the toolbar you want to display, hide, or change.

Toolbar Name

Displays the name of the toolbar that you have selected.

New

Accesses the New Toolbar dialog box.

Customize

Adds buttons to or removes buttons from built-in toolbars with the Customize dialog box.

Reset

Resets the selected toolbar to the original icons.

Color Buttons

Adds color to the toolbar buttons. If this option is cleared, toolbar buttons are black and white.

Large Buttons

Enlarges toolbar buttons so that they are easier to see.

Show ToolTips

Displays on-screen descriptions of a toolbar button when the pointer pauses over it.



New Toolbar Dialog Box
{button Related Topics,AL("toolbars db",0,`NOT_FOUND')} {button How To,AL("customize toolbar 
how;toolbars how",0,`NOT_FOUND')}

Names a toolbar that you selected on the Toolbars dialog box. You can type the name of the new toolbar in the 
box.



Example: Create a Kinematics Animation
1 Click File > New.
2 Select the Mechanical Imperial template.

Note    Selecting the Mechanical Imperial template creates a document with a C-wide sheet and a 1:1 scale.
3 On the Main toolbar, click the Symbol Explorer button.

4 Browse to the directory with the field pump symbols.
5 From the Symbol Explorer, drag the foundation symbol in the lower left area of the document.
6 From the Symbol Explorer, drag the pendulum, donkey head, beam rod, and pump thread symbols so that 

these do not overlap each other or the foundation.

 

To connect the parts
1 On the Tools menu, set the Maintain Relationships option. Your action confirms that the relationships are 

maintained when you move    parts of the drawing.
2 On the Relationship toolbar, click the Lock button.

3 To lock the foundation, select one of the end points of the line on the lower right side. This action keeps the 
foundation stationary when you attach the other components or animate the movement.
{mci_left NOMENU,ANIMAT4.AVI}

To connect the pendulum to the motor on the foundation
1 On the Relationship toolbar, click the Concentric button.

2 Select the circle on the left end of the pendulum arm as the first element.
3 Select the small circle on the motor as the next element. The pendulum moves so that the circles align and are 

concentric.
{mci_left NOMENU,ANIMAT5.AVI}
Tip  The pendulum appears on top of the motor and the foundation. If the pendulum does not do this, select 
the pendulum with the Select tool on the Draw toolbar. You can then click the Bring To Front button on the 
Change toolbar. This action ensures that the pendulum is on top of the motor and foundation.

To connect the donkey head to the top of the foundation
1 On the Relationship toolbar, click the Concentric button.
2 Select the circle at the center of the donkey head for the first element.
3 Select the circle at the top of the A-frame of the foundation symbol for the second element. The donkey head 

moves so it appears balanced on top of the A-frame and the circles align.
{mci_left NOMENU,ANIMAT6.AVI}



To connect the beam rod to the pendulum
1 On the Relationship toolbar, click the Concentric button.
2 Select the lower circle on the beam rod for the first element.
3 Select the right-most circle on the pendulum arm for the second element. This circle is almost centered on the 

pendulum. The rod moves and connects with the pendulum.
{mci_left NOMENU,ANIMAT7.AVI}

To connect the beam rod to the donkey head
1 On the Relationship toolbar, click the Concentric button.
2 Select the circle on top of the beam rod for the first element.
3 Select the circle on the left side of the donkey head for the second element. 
4 The pendulum, donkey head, and beam rod now move so that the connections are complete.

Tip  The beam rod appears on top of the pendulum. Otherwise, click the Select Tool on the Draw toolbar. 
You can then click the Bring To Front button on the Change toolbar. This action ensures that the beam rod 
appears on top of the other parts.
{mci_left NOMENU,ANIMT8.AVI}

To connect the pump thread to the donkey head
1 On the Relationship toolbar, click the Connect button. 

2 Click the top of the line on the pump thread.
3 For the second element, select the endpoint of the small line embedded along the right edge of the donkey head.

The thread moves and attaches to the head.
Tip    You can zoom on the edge of the head to find this line, because it is very small. On the Main toolbar, 
click the Zoom Area button.

{mci_left NOMENU,ANIMAT9.AVI}

To place a dimension on the pendulum for controlling the rotation angle
1 Click Tools > SmartSketch Settings.
2 On the Relationships tab of the SmartSketch dialog box, ensure the Midpoint check box is set.
3 On the Dimension toolbar, click the Angle Between button to place the dimension. The dimension is driving, so 

it appears in black.

Tip    To select the circle on the pendulum where it connects to the motor, zoom in close enough to see the 
entire pendulum in full view. On the Main toolbar, click the Zoom Area button.
Caution    You must select the right circle to ensure that a driving dimension is placed. If you use the wrong 
circle, the dimension will be a driven dimension, shown as green. If this should occur, delete the dimension 
and try again.

4 Pass the pointer over the circle where the pendulum connects to the motor. You see three ellipses appear next to
the pointer.

5 Click to see a box. This is PickQuick. The box has two numbers. This PickQuick box indicates how many 
elements you can select at this location in the window. In this case, you can select only two elements.

6 Click the number 2 square. 
Tip    You can see three squares in the PickQuick box, depending on the zoom distance when you see the 
ellipses. If you see more than two squares, dismiss the PickQuick box by selecting the X in the upper right, 
and then zoom in closer and try again. On the Main toolbar, click Zoom Area. After you can see only two 
numbered squares in the PickQuick box, select the number two square. This action selects the circle 
associated with box number two as the first point of the dimension. 
Tip    If PickQuick does not appear, you can also click the Bring To Front button and click the motor symbol 
to bring it to the front to try the previous steps. You need to click the Send To Back button after you complete 
the steps to bring the pendulum back to the front.

7 Pass the pointer over the line on the right end of the pendulum and move slowly toward the mid-point of the line. 



When you see the midpoint indicator, click for the second point of the dimension. Place the dimension to the right
of the pendulum. Location is not important. This dimension drives the animation of the pump.
{mci_left NOMENU,ANIMAT10.AVI}

To drive the model
After you place the dimension, you can select the dimension with the Select Tool and change the value in 

the ribbon bar. When the dimension changes, the angle of the pendulum changes and all of the other parts change 
accordingly.

{mci_left NOMENU,ANIMAT11.AVI}

{button Related Topics,AL("animate high;symbols high",0,`NOT_FOUND')}

    



Example:    Dimension the Length of a Line
1 On the Dimension toolbar, click the SmartDimension button.

2 Click a line. SmartDimension dynamically displays a linear dimension.

3 Position the dimension, and then click to place it.



Example:    Dimension the Diameter of a Circle
1 On the Dimension toolbar, click the SmartDimension button.

2 Click a circle. SmartDimension dynamically displays a diameter dimension.

3 Position the dimension, and then click to place it.



Example:    Measure the Length of a Line
Even when you are in the middle of a task, you can measure distances with the Measure Distance command.    
For example, consider the following workflow.
1 On the Draw toolbar, select the Line/Arc Continuous button and draw a line.

 
2 On the Tools menu, click the Measure Distance command and measure a distance.

Note    You do not need to exit the Line/Arc Continuous command before measuring a distance.

 
3 To exit the Measure Distance command, click the right mouse button.    The Line/Arc Continuous command is 

still active—you can pick up where you left off and continue using the Line/Arc Continuous command.



Example: Draw a Horizontal Line
You can use relationships to draw a line that is exactly horizontal. You can apply a horizontal relationship as you 
draw the line, or draw the line without a horizontal relationship. 

 
1 Click Tools > SmartSketch Settings.
2 On the Relationships tab, set the Horizontal Or Vertical option, and then click OK.
3 On the Draw toolbar, click the Line/Arc Continuous button.
4 Click where you want to place the first end point of the line, anywhere in the application window.

 
5 Move the pointer around in the window. Notice that the dynamic line display always extends from the end 

point you just placed to the current cursor position. You may also see relationship indicators displayed at the 
cursor.

 
6 Move the pointer to make the dynamic line approximately horizontal.
7 When the horizontal relationship indicator is displayed at the pointer, click to place the second end point.

If the Maintain Relationships option on the Tools menu is set, the software places a horizontal relationship 
handle on the new line. 

 

If you do not want to place a horizontal relationship, you can follow the same procedure with the Maintain 
Relationships option cleared. The line will still be exactly horizontal when you draw it.
Note    Relationship handles can be displayed or hidden with the Relationship Handles button on the 
Relationship toolbar.



Example: Draw a Line
You can use relationships to connect an element you are drawing with an existing element. You can apply a 
connect relationship as you draw the lines, or draw the line without a connect relationship.    

 
1 Click Tools > SmartSketch Settings.
2 On the Relationships tab, set the End Point option, and then click OK.
3 On the Draw toolbar, click the Line/Arc Continuous button.
4 Move the pointer to the end of a line in the application window. The software displays the End Point 

relationship indicator at the cursor.
5 While the software displays the relationship indicator, click to place the first end point of the new line. This end

point is connected to the end point of the previous line.

 
6 Click where you want to place the second end point of the new line.
7 The new line and the previous line have connected end points.

 
If the Maintain Relationships option on the Tools menu is set, the software places a connect relationship 
handle at the point where the two lines connect. 

 
If you do not want to place a connect relationship, you can follow the same procedure with the Maintain 
Relationships option cleared. The end points of the two lines will still be exactly coincident when you draw 
them.
Note    Relationship handles can be displayed or hidden with the Relationship Handles button on the 
Relationship toolbar.



Example: Draw a Line
You can use PinPoint to draw a line starting at a specific x and y distance from a known position in your 
drawing.    
1 On the Main toolbar, click the PinPoint button.

2 Click where you want the target point to be.
3 Change the step value in the PinPoint Ribbon Bar if it is not already set to a value that is appropriate for the 

operation.
4 On the Draw toolbar, click the Line/Arc Continuous    button.

5 Move the pointer around on the drawing sheet. PinPoint displays at the cursor its current x and y positions in 
relation to the target point.

6 Click when the pointer is positioned where you want the line to begin.
7 Click where you want the second point of the line to be, or type the length and/or angle on the Line/Arc 

Continuous    ribbon bar and then click to draw the line.

{button Related Topics,AL("pinpoint cmd;line cmd",0,`NOT_FOUND')}



Example: Draw a Line
1 On the Draw toolbar, click the Line/Arc Continuous button.

2 Click where you want a new line to begin.

3 Move the pointer around on the drawing sheet. Notice that the line follows the movement of the cursor. At the 
same time, the pointer recognizes any relationships it encounters, such as a horizontal relationship. When the 
cursor finds a relationship, a relationship indicator appears at the pointer.

4 Click to place the end point of the line according to the displayed relationships.



Example: Draw an Arc
1 On the Draw toolbar, click the Arc By Center Point button.

2 Click where you want to place the center point.

3 Move the pointer horizontally, to a position where the software recognizes step angle alignment with the center 
point.

4 Click where you want the sweep to begin.
5 Move the pointer to a position where the software identifies the step angle you want to use for the sweep.

6 While the step angle relationship indicator is displayed at the pointer, click to define the end of the sweep.



Example: Case Where a Relationship Is Not Maintained
Relationships cannot be maintained in certain cases, as in the following example.
1 On the Draw toolbar, click the Arc By 3 Points button.

2 Click where you want the sweep of the arc to begin.

3 Move the cursor to a position where the software recognizes a point on element relationship with a line on the 
drawing sheet.

4 When the Point On relationship indicator is displayed at the pointer, click to define the second input point for the 
arc.

5 Move the cursor past the line and click. The position of this input point defines it as the end of the sweep, making
the point in the middle a key point that cannot have relationships. The software recognizes this, and does not 
maintain the point on element relationship.

If the third input point for the arc had been between the first two points, then it would have been interpreted as
the arc midpoint, making the second input point one end of the arc sweep. In this case, the point would have 
been constrainable, and the software would have maintained the point on element relationship.



Example: Connect Points While Drawing a Line
1 On the Draw toolbar, click the Line/Arc Continuous button.

2 Click where you want the line to begin.

3 Move the pointer to a position where the software recognizes the end point of a line on the drawing sheet.

4 When the point on relationship indicator is displayed at the pointer, click to define the end of the line.

If the Maintain Relationships option is set, the software places a connect relationship handle where the two 
lines meet.



Example: Connect Points While Modifying a Line
1 Select the line you want to modify.

2 Position the Select Tool over the handle at the end of the line you want to modify. The pointer changes to a plus 
(+) shape to indicate that you have located the handle.

3 Drag the handle to a position where the software recognizes the end point of another line on the drawing sheet.

4 Release the mouse button to place the end point of the line you are modifying at the end point of the stationary 
line.

If the Maintain Relationships option is set, the software places a connect relationship handle where the two 
lines meet.



Example: Establish More Than One Relationship
1 On the Draw toolbar, click the Line/Arc Continuous button.

2 Click where you want the line to begin.

3 Move the pointer to recognize point on element and tangent relationships with a circle on the drawing sheet.

4 While the point on element and tangent relationship indicators are displayed at the pointer, click to define the end
point of the line.

If the Maintain Relationships option is set, the software places a relationship handle for each recognized 
relationship.



Example:    Formatting a New Drawing
You can use styles to make new drawings conform to your company's standards. For example, the software 
provides line styles with names such as Normal. You have decided to apply the Normal style to hidden lines. 
The Normal style has a line type that looks like a dashed line. 

 

Your company standard may require that a hidden line look like a dotted line. 
 

To change the Normal line style to conform to your company’s standards, you can follow these steps:
1 Click Format > Style.
2 On the Style dialog box, click the line style type in the Style Type box.
3 In the Styles list box, click the Normal line style.
4 Click Modify to access the Modify Line Style dialog box.
5 On the General tab, in the Type box, select the line type that looks like a dotted line.

All the lines that you draw while the Normal style is selected on the ribbon bar will conform to your company’s 
standards: hidden lines will appear as dotted lines. You can save the style to a template with the Style command 
on the Format menu. This allows you to use the style again in other drawings.



Example:    Formatting an Existing Drawing
You can use styles to make existing drawings conform to your company's standards. Suppose you receive a 
drawing from another company, and all the hidden lines are continuous. 

 

Your company standard indicates that hidden lines should be a line type that is dashed. You have been using a 
line style, called Dashed, to conform to the standards used by your company.

 

To change the hidden lines in the drawing quickly and efficiently, you can follow these steps:
1 Open the drawing that you received from the other company.
2 Select all the lines that you want to change.
3 On the ribbon bar, select Dashed in the Style list box to change all the lines that you have selected. All the lines 

now appear as dashed lines, instead of continuous lines.



active style
The style that is used when you draw an element or copy it. You can change the active style to one of the styles 
listed in the Style box on the ribbon bar.



angular dimension
A dimension that measures the sweep angle of an arc, the angle between an origin and a line, the angle between
two lines, or the angle among three key points.



annotation
Text, graphics, or symbols that give you more information about a drawing.

 
(A) Leader line
(B) Break line
(C) Terminator
(D) Annotation

aspect ratio
The ratio of width to height of geometry.



associative
A condition in which an element is related to another element.



associative dimension
A dimension that is updated when the measurement of the element it refers to changes.



associativity
The concept that embraces all techniques for capturing design intent, including variational design, parametric 
design, and feature-based modeling.



background sheet
A component of a drawing sheet. The background sheet is used for graphics that you want to display on more 
than one drawing, such as a border, title block, logo, or raster background picture (watermark). A background 
sheet can be displayed and printed along with any working sheet it is attached to.



balloon
A type of annotation that consists of a closed shape that contains text. A balloon defines individual parts in 
assemblies and    field notes on drawings.



baseline
1 The area between a line and text. 
2 The process that freezes a document from any further modification. When you baseline a document, you also 

freeze any documents that are linked to the baselined document.



callout
A type of annotation that consists of a text box with a leader.



center point
The middle of a circle or arc.



centerline
An annotation on a mechanical drawing that marks the center position of a hole or other feature on a part.



chained dimension group
A series of dimensions that are arranged in a straight line. A chained dimension group measures locations from 
element to element.



chamfer
A corner that has been cut at an angle.



closed curve
A curve whose end points meet. A closed curve encloses an area.



closed element
An element whose end points meet. A closed element encloses an area.



coincident relationship
A relationship that specifies that two points have the same location.



colinear relationship
A relationship that ensures that a set of identified points or lines lie in a straight line.



command
A tool designed to complete a single task, such as create an arc or a line.



compound document
A document that contains files with various formats. For example, a document composed of AutoCAD and 
MicroStation documents.



container
A document that contains documents created with other applications. Through OLE you can access the 
application that created the document and link and embed a document created by another application.



cross hatching
An annotation on a drawing that designates the fill area of a model; a fill.



coordinate dimension group
A group of dimensions that measure locations from a common origin.



curve
An element type that is not linear.



cusp node
A type of vertex on a curve. A curve with a cusp node bends sharply at the node. A handle can be attached to a 
cusp node for editing. 



design data
Real world objects that you draw in a computer drawing. Typically these items must be scaled in the drawing 
sheet.



diameter dimension
A dimension that measures the diameter of a circle or arc.



dimension
A control that assigns and maintains a dimensional value to an individual element or establishes a dimensional 
relationship among multiple elements. A label with text, lines, and arrows graphically represents a dimension.



dimension axis
An axis for dimension orientation that you define by selecting a line. You can place linear dimensions that run 
parallel or perpendicular to the axis. By default, dimensions are placed horizontally or vertically.



dimension group
A series of dimensions. You can place a chained dimension group, a coordinate dimension group, or a stacked 
dimension group.



dimensional value
The text that indicates the value of a dimensional measurement, such as distance, length, or angle.



display filter
A tool that allows you to display selected layers in a drawing.



document data
Annotations, such as dimensions, text boxes, callouts, balloons, and centerlines, that are used to describe 
design data.



drawing sheet
The area of the application window that you draw in. There are two types of drawing sheets: working sheets and 
background sheets. Both types of sheets display a border, called a sheet outline, that shows the size, orientation,
and printable region of the current sheet.



drawing sheet tab
Drawing sheet tabs are located at the bottom of the drawing sheets in your document. There is a drawing sheet 
tab for each drawing sheet.

The drawing sheet tabs allow you to change the active drawing sheet, create new drawing sheets, delete 
drawing sheets, and copy drawing sheets. 



drawing tool
A tool that helps in the process of creating, modifying, or manipulating elements. For example, PinPoint and 
SmartSketch.



drawing view
A 2-D representation of a 3-D part or assembly. You can manipulate drawing views to display the part or 
assembly on a drawing sheet at a specified scale and orientation.



driven dimension
A dimension with a value that depends on the value of other dimensions or elements.



driving dimension
A dimension with a value that controls the size, orientation, or location of an element.



edge point
A location on the boundary of an element. For example, edge points can be used to define the circumference of 
a circle.



element
A simple, selectable unit in a drawing. You can select geometric elements, dimensions, annotations, objects 
placed in the drawing through OLE, and so forth. The type of element that can be selected is determined by 
command context.



embed
A method for inserting information from a source document into the active document. Once embedded, the 
information becomes part of the active document; if changes are made to the source document, the updates are 
not reflected in the active document.



end point
The end of an element.



equation
The algebraic relationship between dimensions and/or numeric properties.



file locking
The ability to prevent updates to a document.



fill
A pattern or solid color placed inside a closed boundary.



free space
An area that is not on or inside an element or object on a drawing sheet.



FreeForm
A drawing tool that allows you to use the mouse to sketch curves. As you press and hold the mouse button and 
drag the pointer across the drawing sheet, a rough sketch of your design appears. When you release the mouse 
button, the software turns your sketch into smooth curves.



FreeSketch
A drawing tool that allows you to use the mouse to sketch lines, arcs, circles, and rectangles. As you press and 
hold the mouse button and drag the pointer across the drawing sheet, a rough sketch of your design appears. 
When you release the mouse button, the software recognizes the shapes in your sketch and turns them into a 
precise drawing.



from point
The starting point for an action. For example, when you rotate elements, the from point determines where you 
want the rotation to begin.



geometric element
A point, line, arc, circle, or other simple geometry unit.



group
A collection of objects that you can manipulate as a single item. 



handle
Solid or hollow squares that are displayed at significant positions on a geometric element when you select the 
element. You can manipulate an element with a handle.



help lines
The dashed coordinate axes displayed by PinPoint. The help lines extend from the target point to the current 
pointer location. They are dynamically updated as you move the cursor. You can turn the help line display on or 
off.



horizontal relationship
A relationship that specifies that the end points of a line, or two key points, are level with each other along the x 
axis.



image
A raster image, which can be a .TIFF, .GIF, .JFIF, .BMP, .COT, .CIT, or .RLE document.



intent zone
A quadrant divided into four pie-shaped wedges that determines the behavior of an element's relationship to 
either a circle or arc. Intent zones allow you to specify where you want to draw an element in relation to an arc or
circle. For example, as you draw an arc, you can change the arc's direction by moving the cursor to a different 
position within the intent zone. You can define the size of the intent zone by specifying the number of pixels in it.



key point
A recognizable point on an element. Key points include vertices, mid points, center points, and so forth.



layer
A logical grouping of elements or objects on a drawing sheet. You can have several layers in a drawing sheet.



linear dimension
A dimension that measures the linear distance between two or more elements, the length of a line, or the arc 
length of an arc.



link
The connection between an inserted image or object, known as the source document, and the active document. 
Changes made in the source document are reflected in the active document when the active document is 
updated.



locate zone
A circular area at the center of the crosshair cursor or at the end of the arrow cursor. The locate zone specifies 
how close the cursor must be to an element you want to recognize or select. You can define the size of the locate
zone with the SmartSketch command on the Tools menu.



lock
A relationship that makes the position of an element or key point, or the value of a driving dimension, stationary.



macro
A sequence of actions or commands that can be named and stored. When you run the macro, the software 
performs the actions or runs the commands. You can create the macros in Visual Basic or other OLE-aware 
programming applications. Some of the OLE-aware programming applications are VBA (inside of Excel), Visual 
C++ Delphi, Visual Basic, and so forth.



midpoint
The middle point of an element.



mirror axis
The line about which the selection set is mirrored. When you select the Mirror command, the software displays 
horizontal and vertical mirror axes that go through the center of the selection set. You can display other mirror 
axes by locating linear elements.



modification
The act of changing the size, position, or orientation of an element by modifying the element or its handles.



pointer
The screen device that you use to select elements, commands, and other items in the software.



nested symbol
A symbol that is placed into a document which is then placed as a symbol in another document. Symbols that are
public display across different documents. Symbols that are private only display in the first document.



node
A vertex on a curve. An exterior node has one handle, and an interior node has two handles. A curve can have 
one or more smooth, cusp, or symmetric nodes. The type of node a curve has affects how you modify the curve.



object
1 Information that can be linked or embedded into an OLE-compliant product.
2 A group of elements that represent a real-world object. An object can also be made up of a single element.



OLE
The way Microsoft uses the Common Object Modeler (COM).    It is a mechanism to make data work 
independently.



open curve
A curve whose end points do not meet.



open element
An element whose end points do not meet.



parallel relationship
A relationship that specifies that the orientation of one line is identical to that of another line.



perpendicular relationship
A relationship that specifies that the orientation of a line or end point of an arc is at a right angle to the orientation
of another line, arc, circle, or curve.



PickQuick
An automatic software tool that allows you to select an element when several elements overlap. When you place 
the pointer over a set of overlapping elements, three small circles appear at the bottom right of the cursor. When 
you click, a small toolbar with the number of selectable elements appears. You can move the pointer over the 
numbers; and, when the element that you want highlights, you can click on the corresponding number to select it.



PinPoint
A tool that allows you to place, move, and modify elements with precision, relative to a reference point.



precision input
The method of defining the position of a point in space by using precise coordinates or by using a value to 
describe the point’s position from the coordinates of another point.



primary axis
The axis that defines the rotation angle of the ellipse. Zero degrees is horizontal to the x axis; the angle 
increases in the counterclockwise direction. The primary axis is defined first and can be shorter than the 
secondary axis.



property
A unique characteristic of an element, object, symbol, or document. You can display document properties in the 
Windows Explorer or by clicking Properties on the File menu or Edit menu. 

Properties for elements or objects have three different types, as defined on the Properties dialog box: 
Style properties, as specified on the Format tab. Style properties affect the format of the element.                      
Size properties, as specified on the Info. Size properties affect characteristics of the element, such as the 

length. 
User-defined properties, as created on the User tab. User-defined properties are usually in the form of a text

notation, such as cost, manufacturer, and so forth You can change user-defined properties, but these changes have 
no affect on the appearance of the element or object.

For example, a valve symbol's style properties can include color, line style, and width. Other user-defined 
properties stored with the symbol can include the manufacturer, cost, or material. User-defined properties are 
displayed in the Attribute Viewer when you select the valve symbol. 



radial dimension
A dimension that measures the radius of an arc, circle, ellipse, or curve.



reference file
Any file not native to SmartSketch that is linked or embedded and used for reference information. You click 
Insert > Object to link or embed a reference file, or you can drag or drop it with Windows Explorer.



relationship
A condition that exists for an individual element or between elements. You can establish relationships as you 
place new elements or between elements already on the drawing sheet. If Maintain Relationships is set, then 
the relationship controls the modification behavior of the related elements. For example, if two lines have a 
parallel relationship, they remain parallel when one of the lines is moved.

SmartSketch recognizes potential relationships as you draw. Relationship handles are placed on related 
elements to represent maintained relationships.



relationship handle
A graphic used to represent a geometric relationship between elements, key points, and dimensions, or between 
key points and elements. The relationship handle shows that the designated relationship is being maintained.

Command Relationship Handle

Colinear

Connect

 

Concentric

Equal

Horizontal/Vertical

Tangent

Symmetric

Parallel

Perpendicular

Lock

relationship indicator
A graphic that is displayed at the pointer when the software recognizes a SmartSketch relationship.

Relationship Relationship Indicator

Endpoint

Midpoint

Intersection

Horizontal

Vertical

Point On Element

Perpendicular

Parallel



Tangent

Center

rotation angle
The angle between 0—180 degrees that an element is rotated in either direction. Zero degrees is horizontal to 
the x axis; the angle increases in the counterclockwise direction. 



rotation angle
The angle at which the rectangle is oriented. Zero degrees is defined by the positional angle. The angle 
increases in the counterclockwise direction.



rotation axis
A temporary line that shows the rotation angle with respect to the rotation reference axis. Zero degrees is defined
by the positional angle; the angle increases in the counterclockwise direction.



rotation reference axis
A temporary line defined by the center of rotation and the rotation from point. Zero degrees is horizontal; the 
angle increases in the counterclockwise direction. The rotation angle is measured from this line.



scale origin
The starting point from which an object is scaled along the x and y axes.



secondary axis
The axis that is perpendicular to the primary axis of an ellipse. The secondary axis is defined after the primary 
axis and can be longer than the primary axis.



Select Tool
A tool that allows you to select elements before you run a command on them. 



selection set
A single selected object or a group of selected objects.



share embed
A document copied directly into a drawing. When you embed the same document more than once in the same 
document, the document elements are copied each time. When you share embed the same document more than
once in the same document, the documents are not copied each time. Instead, the other documents reference 
the initial placement of the document.



shortcut menu
A menu that gives you quick access to commands that are related to the item you are working with. The 
commands available on the shortcut menu depend upon the selected element or active command. To activate 
the shortcut menu, click the right mouse button.



sketch
The process of creating a rough drawing that approximates the size or shape of a real-world object.



smooth node
A type of vertex on a curve. A curve with a smooth node has a different curvature on each side of the node. The 
start point and end point of a curve is always a smooth node. A handle can be attached to a smooth node for 
editing.



source document
A document that provides data, graphics, or other information to another document through a link.



stacked dimension group
A series of individual dimensions that are arranged at different levels from the smallest value to the largest. A 
stacked dimension group measures locations from a common origin.



style
1 The appearance of geometry and annotations on the drawing sheet. For example, an element's color and line 

weight, the font used in a text box, and so forth. 
2 A collection of formats or properties that you name and store as a group. When you apply a style to a selected

item, the software applies all the formats or properties in the style to the element. The style types include: fill, 
dimension, line, and text.



sweep angle
The angle that defines the length of an arc.



symbol
A document placed in a drawing. You can override and edit the properties and style of the symbol. A document 
can be linked, or    embedded.



symmetric node
A type of vertex on a curve. A curve with a symmetric node has the same curvature on each side of the node. A 
handle can be attached to a symmetric node for editing.



tangent relationship
A relationship between an arc or circle and another geometric element. The elements share a common point that
is not intersecting.



target point
The origin for coordinate measurements displayed by PinPoint. You can position the target point anywhere on 
the drawing sheet.



template
A default set of properties that defines what a new document will look like. You can use a template to set 
standards for a group of users or to define your own preferences.



terminator
A graphic symbol, such as an arrow or dot, placed at the end of a leader.



text box
A rectangular element that contains text or symbols; you can place text boxes on drawing sheets.



to point
The ending point for an action. For example, when you rotate elements, the to point determines where you want 
the rotation to stop.



toolbar
Toolbars are graphic menus with buttons that allow you to quickly access commands. You can define custom 
toolbars or use the toolbars delivered with the software.



tools
A set of commands that can be activated from a menu, toolbar, or keyboard shortcut. Tools are self-contained, 
designed for specific tasks, and can be used in any compatible environment.



user property
A unique characteristic of an element or object in a file. You can assign unique values to an element or object 
with the Properties command on the Edit menu.



variable
A value that can be referenced and changed.



vertex
The highest point or apex of a figure, the intersection of lines or curves, or the end point of an element.



vertical relationship
A relationship that specifies that the end points of a line, or two key points, are level with each other along the y 
axis.



window
An area defined by a standard border and buttons that is used to display information in an application.



wireframe element
A 2-D, graphic representation of simple geometry; wireframe elements include points, lines, circles, arcs, conic 
curves, freeform curves, and composite curves.



working sheet
A component of a drawing sheet. The working sheet is where you create design data and document data. You 
can apply a scale to document and design data and attach a background sheet to the working sheet.





style type
A type of style that is based on the type of element that the style affects.    The style types include: fill, dimension,
line, and text.



style resource document
Any .igr or .RSC document that contains styles native to that document. A template or document can reference 
several style resource documents. These styles are copied into the current document when the styles are 
actually applied to elements or annotations in the document.





attribute
A user-defined property or parameter assigned to an element, object, or document. A parameter refers to 
variables in a symbol document that drive dimensional values. You can display attributes with the Attribute 
Viewer.



parameter
An attribute assigned to an element or object, usually a numerical value representing a dimension. A parameter 
is a mechanism to change a property. A parameter refers to variables in a symbol document that drive 
dimensional values. Parameters appear as bold characters in the Attribute Viewer. 



Smart Label
A label that is associated to the attributes on an element or object. Smart Labels are created with the tools on the
Symbol Authoring Tools toolbar.



bearing
A determination of position to refer to an angle



azimuth
A horizontal direction expressed as an angle, progressing from a fixed point, based on a circle.



base bearing
Direction (North, South, East, West) bearing to refer to an angle. 



direction
Clockwise or counterclockwise indicator for the angle bearing.



isometric drawing
A drawing represented as the object or element is actually projected on a plane of projection: a 3D drawing 
represented in 2D.



parametric symbol
A symbol that contains geometry constrained together using relationships, with driving dimensions that are 
defined as adjustable parameters.



user-defined property
A type of property created on the User tab of the Properties dialog box for the element or object. User-defined 
properties are usually in the form of a text notation, such as cost, manufacturer, and so forth You can change 
user-defined properties, but these changes have no affect on the appearance of the element or object.

For example, user-defined properties stored with a valve symbol can include the manufacturer, cost, or material. 
User-defined properties are displayed in the Attribute Viewer when you select the valve symbol.



hyperlink
Colored and underlined text or a graphic that you click to go to a file, a location in a file, an HTML page on the 
World Wide Web, or an HTML page on an intranet. Hyperlinks can also go to Gopher, telnet, newsgroup, and 
FTP sites.





Draw an Arc
What Do You Want To Do?

Draw an arc by defining its center point and sweep.
Draw an arc by defining three points of its sweep. 
Draw an arc tangent to one or two elements. 



Draw a Circle
What Do You Want To Do?

Draw a circle by defining its center point and radius.
Draw a circle by defining three points on its circumference. 
Draw a circle tangent to one or two elements. 



Draw or Modify a Curve
What Do You Want To Do?

Draw a curve.
Insert a node into a curve. 
Change the curve type. 
Change the node type. 
Delete a node from a curve. 



Draw an Ellipse
What Do You Want To Do?

Draw an ellipse by defining its center point and axes.
Draw an ellipse by defining its axes. 



Draw with FreeSketch and FreeForm
What Do You Want To Do?

Draw lines, arcs, circles, and rectangles.
Draw connected lines and arcs. 
Draw a line. 
Draw an arc. 
Draw a circle. 
Draw a rectangle or square. 
Draw curves. 



Draw a Line
What Do You Want To Do?

Draw a line.
Draw connected Lines and Arcs. 



Display the Attribute Viewer
1 Select an object or element.
2 On the Main toolbar, click the Symbol Explorer button. If the selected item has assigned attributes, the 

Attribute Viewer opens and displays the properties and parameters. 

Tips
If the Symbol Explorer window is open, you can display or hide the Attribute Viewer. To display or hide the

viewer, place the pointer over a toolbar at the top of the document window and right-click. On the shortcut menu, 
select or clear the Attribute Viewer command.

You can drag the splitter bar between the Symbol Explorer and the Attribute Viewer to display or hide the 
viewer.

If you close the Attribute Viewer, you can open it again by pausing the pointer in the toolbar area, right-
clicking, and clicking Attribute Viewer on the shortcut menu.

{button Related Topics,AL("av high;attribute cmd;attribute viewer db;symbol explorer high",0,`NOT_FOUND')}



Move the Attribute Viewer
Drag the title of the Attribute Viewer to move the viewer. 

You can dock or undock the viewer inside the Symbol Explorer and place the viewer at a different location.

Tips
To resize the Attribute Viewer like any document window, you can double-click the title bar of the viewer to 

undock it. Then, you can drag the sides of the viewer to resize. 
The position of the Attribute Viewer does not stay the same if you close the software and then start it again.

The viewer appears docked in the default position inside the Symbol Explorer.

{button Related Topics,AL("av high;attribute cmd;symbol explorer high",0,`NOT_FOUND')}



Edit Cells in the Attribute Viewer
1 Click a cell in the Attribute Viewer. 
2 Type new information or change existing information. 

Tips
You can delete text in the Attribute Viewer by pressing Delete on the keyboard.
Double-click to highlight the whole word.
Drag to highlight the word.
You can resize cells in the viewer by using the splitter bar between each cell at the top of the viewer.

{button Related Topics,AL("av high;attribute cmd;symbol explorer high",0,`NOT_FOUND')}



Edit Attributes
1 Select a symbol, object, or element.
2 On the Main toolbar, click the Symbol Explorer button.

3 If the item that you selected has attributes, the Attribute Viewer appears in the Symbol Explorer window.

Tips
You can use the Attribute Viewer to view a symbol's user properties and parameters. These properties 

include the dimensions of the symbol and other items. To open the Attribute Viewer, double-click a symbol. You can 
also select a symbol and then click the Symbol Explorer button on the Main toolbar.

In the Attribute Viewer, the user properties appear in plain text. The parameters appear in bold text. You 
cannot edit the names of the parameters in the Name column. To change the values, click in the Value 
column, type the information that you want, and press Enter.

If the Symbol Explorer window is open, you can display or hide the Attribute Viewer. To display or hide the
viewer, point to a toolbar at the top of the document window and right-click. On the shortcut menu, select or clear the 
Attribute Viewer command.

You can drag the splitter bar between the Symbol Explorer and the Attribute Viewer to display or hide the 
viewer.

You can edit the parameters of a parametric symbol to automatically change the dimensions of the symbol.

{button Related Topics,AL("av high;attribute cmd;symbol explorer high;scale symbol how",0,`NOT_FOUND')}



Setting AutoSave Options
Tip    You must install the AutoSave add-in with the Add-Ins command on the Tools menu before you set 
AutoSave options.
1 Click Tools > AutoSave.
2 Select the options you want from the AutoSave dialog box.
3 Click OK.

{button Related Topics,AL("autosave high;autosave cmd;autosave db",0,`NOT_FOUND')}



Set Bearing and Azimuth
1  On the Main toolbar, click the Bearing and Azimuth button.

Tip    The Bearing and Azimuth command is available only if you use the Customize command to place it on
a toolbar or menu.

2 Click Default,Bearing, or Azimuth to select the orientation for the drawing or element.
3 When you select Azimuth, you can change the current settings of Base Bearing and Direction.

{button Related Topics,AL("bearing azimuth high;bearing azimuth cmd;set bearing dialog ",0,`NOT_FOUND')}



View a Web Page with the Symbol Explorer
1 On the Main toolbar, click the Symbol Explorer button. The Symbol Explorer opens on the right of the main 

window.

2 At the top of the Symbol Explorer, in the Address Box, type the name of the HTTP address and press Enter. 
For example, you could type the following: http://www.ingr.com. The World Wide Web page appears inside the 
Symbol Explorer.
Tip    If you cannot see the entire Web page, you can double-click the bar at the top of the Symbol Explorer 
to undock it. You can then resize the Symbol Explorer window so that you can see the entire page.

Tips
You can use many of the same tools to view web pages that are available in the Windows Internet Explorer. 

For example, if you click the Back button at the top of the Symbol Explorer, the Symbol Explorer returns to the 
previous page.

If you open or create a document while the Symbol Explorer is open, you must click the Home button to 
display the symbols directory associated with the current document.

{button Related Topics,AL("Symbol Explorer db;Symbol Explorer cmd;Symbol Explorer high",0,`NOT_FOUND')}



View Documents with the Symbol Explorer
1 On the Main toolbar, click the Symbol Explorer button. The Symbol Explorer opens on the right of the main 

window.

2 At the top of the Symbol Explorer, in the Address Box, type the name of the directory to go to and press Enter.
For example, you could type the following: C:\DRAWING FILES.
Note You can also change the directory by clicking the Browse button at the top of the Symbol Explorer to 
display the Modify Location dialog box. You can then enter another directory for the Symbol Explorer to 
look in.

Tips
You can filter the view of documents in the Symbol Explorer.    If you want to view just one type of 

document, such as symbols, pause the pointer in the Symbol Explorer window and right-click. On the shortcut 
menu, click View, and then File Type. 

If you double-click a document in the Symbol Explorer, the software that created the document opens and 
displays the document. For example, if you double-click the SYMBOL.sym document, the software opens and 
displays the SYMBOL.sym document. Or, if you double-click a document with an .htm extension, the Microsoft 
Internet Explorer opens.

If you open or create a document while the Symbol Explorer is open, you must click the Home button to 
display the symbols directory associated with the current document.

You can filter the view in the Symbol Explorer window to display only certain types of documents, such as 
MicroStation, AutoCAD, or other types. You can click the View File Type command on the shortcut menu in the 
Symbol Explorer window. 

For example, to display only AutoCAD documents, you can select the AutoCAD option for .dwg documents. 
When you set this option, the Symbol Explorer window displays only .dwg documents.

If you set the path of the Symbol Explorer to a directory, you can see a tree view, a shell view, and the 
Attribute Viewer. If you set the path to an HTML page, you can see the symbols of that page in the style of the 
Microsoft Internet Explorer 4.01 or earlier, if that version is installed. If Microsoft Internet Explorer is not installed, the 
software prompts you to install it.

{button Related Topics,AL("Symbol Explorer db;Symbol Explorer cm;Symbol Explorer high;view file type 
cmd",0,`NOT_FOUND')}



Close the Symbol Explorer
On the Main toolbar, click the Symbol Explorer button.

Tips
You can also close the Symbol Explorer by clicking the Toolbars command on the View menu. On the 

Toolbars dialog box, you should clear the Symbol Explorer check box.

{button Related Topics,AL("Symbol Explorer db;Symbol Explorer cm;Symbol Explorer high",0,`NOT_FOUND')}



Open Documents from the Symbol Explorer
1 On the Main toolbar, click the Symbol Explorer button. The Symbol Explorer opens on the right side of the 

main window.

2 At the top of the Symbol Explorer, in the Address Box, type the name of the directory that you want to go to 
and press Enter. For example, you could type the following: C:\PROGRAM FILES\DRAWINGS\.
Note You can also change the directory by clicking the Browse button at the top of the Symbol Explorer to 
display the Modify Location dialog box. You can then enter another directory for the Symbol Explorer to 
look in.

3 Double-click a document in the Symbol Explorer. The software that created the document opens and displays 
the document. For example, if you double-click on the SYMBOL.sym document, the software opens and displays
the SYMBOL.sym document. Or, if you double-click a document with an .htm extension, the Microsoft Internet 
Explorer opens.

Tips
If you double-click on a directory in the Symbol Explorer, a separate window for the Windows Explorer 

opens. You must click the Browse button to select a new directory for the Symbol Explorer.
You can drag any document that supports OLE 2.0 from the Symbol Explorer to the drawing sheet.
If you set the path of the Symbol Explorer to a directory, you can see a tree view, a shell view, and the 

Attribute Viewer. If you set the path to an HTML page, you can see the symbols of that page in the style of the 
Microsoft Internet Explorer 4.01 or earlier, if that version is installed. If Microsoft Internet Explorer is not installed, then
the software prompts you to install it.

{button Related Topics,AL("Symbol Explorer db;Symbol Explorer cm;Symbol Explorer high",0,`NOT_FOUND')}



Set the Home Page for the Symbol Explorer
1 Click File > Properties.
2 On the Behavior tab of the Properties dialog box, type the HTTP address of the home page that you want for 

the Symbol Explorer. In the Symbol Explorer, when you click the Home button, the Symbol Explorer displays
the Web page for the address that you typed.
Note    The address that you enter on the Behavior tab of the Properties dialog box is saved with the current 
template and document.

Tips
You can also set the home page while the Symbol Explorer is open. In the Symbol Explorer window, right-

click and, on the shortcut menu, select the Set Document Home command.
If you do not set the home page for the Symbol Explorer, the Symbol Explorer displays the symbol 

directory that is associated with the template that the active document is based on.
If you open or create a document while the Symbol Explorer is open, you must click the Home button to 

display the symbols directory associated with the current document.
If you want to set the Symbol Explorer to always look at symbols on your computer, you can type the 

following syntax in the Address box: <application.path>\..\<path of symbols. For example, you could enter 
<application.path>\..\symbols\arch.htm.

{button Related Topics,AL("Symbol Explorer db;Symbol Explorer cmd;Symbol Explorer high;file properties db;file 
properties cmd;set document home cmd",0,`NOT_FOUND')}



Move the Symbol Explorer
1 On the Main toolbar, click the Symbol Explorer button. The Symbol Explorer opens on the right of the main 

window.

2 Double-click the bar at the top of the Symbol Explorer to display it as a separate window from the main window.
You can now drag the Symbol Explorer and relocate it. You can also resize the Symbol Explorer window.

Tips
If the Symbol Explorer is displayed as a separate window from the main window, double-click the bar at the

top to make it part of the main window again. You can dock the Symbol Explorer at any place in the window.
If you resize the Symbol Explorer and the double-click it to make it part of the main window, the Symbol 

Explorer size remains the same.

{button Related Topics,AL("Symbol Explorer db;Symbol Explorer cmd;Symbol Explorer high",0,`NOT_FOUND')}



Show a List of Favorites in the Symbol Explorer
1 On the Main toolbar, click the Symbol Explorer button. The Symbol Explorer appears on the right of the main 

window.

3 In the Symbol Explorer window, on the shortcut menu, click the Show Favorites command. A bar appears at 
the top of the bottom pane. You can click one of these bars to go to a favorite document or directory.

{button Related Topics,AL("Symbol explorer cmd;show favorites cmd",0,`NOT_FOUND')}



Add to the Favorites List in the Symbol Explorer
1 On the Main toolbar, click the Symbol Explorer button. The Symbol Explorer opens on the right of the main 

window.

2 In the Symbol Explorer window, select the directory or document that you want to add to a list of favorites.
3 In the Symbol Explorer window, right-click and then click the Add To Favorites command. 

A bar appears at the top of the bottom pane. You can click this bar to go to a favorite document or directory.

{button Related Topics,AL("Symbol explorer cmd;add favorites cmd",0,`NOT_FOUND')}



Delete From a List of Favorites in the Symbol Explorer
1 On the Main toolbar, click the Symbol Explorer button. The Symbol Explorer opens on the right of the main 

window.

2 In the Symbol Explorer window, select the bar in the bottom pane that you want to delete.
Tip    You can also select a favorite directory, HTML page, or file in the Symbol Explorer window.

3 Right-click, and, then on the shortcut menu, click the Delete Favorite command.

{button Related Topics,AL("Symbol explorer cmd;delete favorite cmd",0,`NOT_FOUND')}



Place a Connector
1 On the Draw toolbar, click the Connector button.

2 Click to begin drawing the connector or move the pointer over the element to highlight the potential key points or 
connect points.
The connect points appear as red circles with Xs. The keypoints appear as gray circles with Xs. The active 
point along the element is a filled red circle. You can connect to any point on the element.
Tip    If you press the Alt key while drawing a connector, the connector attaches to a connect point at any 
angle.

3 After you select a starting point, the direction in which you move from that point determines the angle at which 
the connector is drawn. 
The following picture shows that the pointer has been moved away from the initial point in a downward 
direction. 

Tips
You can generate two or more line segments with each click. When the pointer crosses the current line 

segment, the software automatically generates another segment.
The following graphic shows a connector with three line segments although you clicked only once.

To switch between drawing horizontal and vertical line segments or drawing diagonal line segments, click 
Diagonal Mode (Alt).

If the element itself is rotated, the takeoff angle is adjusted appropriately so that the connector is 
perpendicular to the element.

If you are connecting to a symbol, the connect point may have a pre-defined angle to which the connector 
must connect.

To create a connector path
After you select a point to move from, you can click points to force a connector to go to a certain path. 

To end the connector

You can end a connector in the following ways:
After you place one or more connector line segments, right click to end the connector. 
To attach the connector to another element, move the pointer over the element to display the potential 

connect points. However, you can connect to any point on the element. 
When the point closest to the pointer is highlighted, you can click to define the end of the connector. The pointer 
snaps to connect points. 

Tips
The software calculates the angle for the ending the connection point, based on how you approach the 

element.
If the calculated angle is not correct when you move the pointer away from the point, you can move the 

pointer back over the point and try again.
As you drag connected elements or symbols, the connections are maintained.



{button Related Topics,AL("connector command;connector rb;connect points high;connect points how;place 
connector how ",0,`NOT_FOUND')} 



Modify a Connector
To modify a connector, select the connector, using the Select Tool. You can then change the connector in 

several ways.

To move a line segment
To move a line segment, first move the pointer over a horizontal line segment or a vertical line segment. 

Then click the segment and drag it to the location you want.

To insert a vertex
To insert a vertex, first click the Diagonal Mode (Alt) button on the ribbon bar, or press the Alt key. 
Move the pointer over a horizontal line segment or a vertical line segment to which you want to add the 

vertex, and drag the segment to a new location.
The pointer changes to a directional arrow.
As you drag the segment, the software inserts a vertex.
In the following graphic a vertex has been inserted in a horizontal line segment.

To move a vertex
To move a vertex, move the pointer over the vertex. Then drag the vertex to move it.

Tips
When Diagonal mode is not active, you can move the vertex only in a horizontal or vertical direction.

The following graphic shows that moving the vertex (A) results in line segments that are horizontal or vertical. 

When Diagonal mode is active, you can move the vertex in any direction. This action means that connector 
line segments are not limited to horizontal or vertical orientation.

The following graphic shows that moving the vertex (A) results in line segments that are no longer horizontal 
or vertical. 



To insert a line segment
To insert a line segment into the connector, click the Insert Segment Mode (Shift) button on the ribbon bar, 

or press the Shift key.
The pointer changes to a directional arrow when the command is in Insert Segment mode, and the pointer is 
positioned over a connector segment.

Drag the pointer diagonally to define the shape of the segment.
The following graphic shows the connector dynamics display as you drag the pointer (A).

When you release the drag, the segment is inserted as part of the connector.

To move an element with a connector
To move an element that is connected, select the element with the connector and move it.

The connector moves with the element. 
Tip    To find out how to move an element, click the Related Topics button. 

To modify end points

You modify end points to move a connector from one connect point to another or to move a connector point to 
another location.

To move a connector, first select the connector. Then click the connector and drag it to a connect point or 
another location. 

Tip    After you connect a point, you can drag it to another connect point.

{button Related Topics,AL("connector command;connector rb;connect points high;connect points how;move 
element how;place connector how ",0,`NOT_FOUND')}



Format a Connector
To format a connector
1 Select a connector.
2 On the Connector ribbon bar, set the options you want.

Tips
On the shortcut menu, click Properties. Then, on the Element Properties dialog box, set the options you 

want. 
You can also format a connector before you attach it by setting options on the ribbon bar.
Changing the current style settings on the ribbon bar or Properties dialog box overrides the line style 

formats.
To change a line style, click the Style list on the ribbon bar, and select a style.
To change clearance, type a value in the Clearance box on the ribbon bar.

{button Related Topics,AL("connect high;connector command;connector rb ",0,`NOT_FOUND')}



Format a Fill
1 Select a fill.
2 On the Fill ribbon bar, click the settings that you want to update the fill.

Tips
You can format a fill before you place it by setting options on the ribbon bar or the Properties command on 

the Edit menu. 
You can apply several formats at once by clicking a new fill style in the Style list box on the ribbon bar.
You cannot modify an existing fill style, but you can create a new fill style by typing a new name in the Style 

list box on the Fill ribbon bar.    The new style uses the settings on the ribbon bar as the formats for the style.
If you want to copy a fill style from document to another, just create a fill, apply a style, and then copy the fill 

to a new document. The fill style appears in a dropdown list on the Fill ribbon bar in the new document.
The blank color on the Fill ribbon bar takes on the background color of the document. This is useful for 

creating symbols that can cover an element on which the symbol is placed. Incorporating a fill with blank color into 
the symbol allows the symbol, when placed, to mask out elements such as lines or connectors that intersect the 
symbol.

{button Related Topics,AL("fill cmd;style cmd;element properties cmd;formatting elements 
high",0,`NOT_FOUND')}



Format a Geometric Element
1 Select a geometric element, such as a line, arc, or circle.
2 Do one of the following:

On the ribbon bar, set the options you want.
On the shortcut menu, click Properties.    Then, on the Element Properties dialog box, set the options you 

want. 

Tips
You can also format an element before you draw it by clicking the Line/Arc Continuous command on the 

Format menu or by setting options on the ribbon bar.
Changing the current style settings on the ribbon bar or Properties dialog box overrides the line style 

formats.
You can change the definition of a line style with the Style dialog box.

{button Related Topics,AL("line cmd format menu;style cmd;element properties cmd;formatting elements 
high;line properties db",0,`NOT_FOUND')}



Draw a Flowchart
1 Click File > New.
2 Select one of the Technical Drawing templates in the General Diagramming category on which to base your 

new document.
3 On the Draw toolbar, click the Line/Arc Continuous button.

4 On the Line ribbon bar, in the Style box, click the special style that you want to create lines with arrows. These 
styles include Flow Arrow, Open Flow Arrow, and Bi-directional Flow Arrow.

5 On the Main toolbar, click the Symbol Explorer button. 

6 In the Symbol Explorer, drag symbols that you want to use to create your flowchart.

{button Related Topics,AL("flowchart high;line cmd;symbol cmd",0,`NOT_FOUND')}



Format a Text Box
1 Select a text box.
2 Do one of the following:

On the ribbon bar, set the options you want. To apply several formats at once, click a style on the ribbon bar.
On the shortcut menu, click Properties. Then, on the Text Box Properties dialog box, set the options you 

want. 
Tips

You can format a text box before you place it by using the Text Box command on the Format menu or by 
setting options on the ribbon bar.

To format a group of text boxes quickly and easily, select several text boxes and apply a text style by clicking
a style on the ribbon bar. You can modify a text style with the Style command on the Format menu.

If you apply a text style, you can override the formats of the style by setting options on the ribbon bar or Text
Box Properties dialog box.

To apply a border to a text box, you click an option on the ribbon bar. To change the settings for the border, 
you must select the text and then set options with the Properties command on the shortcut menu.

{button Related Topics,AL("text db;text high;text cmd format menu;element properties cmd;formatting 
elements;test properties db;test rb",0,`NOT_FOUND')}



Add Your Own Tutorials
1 Create a text file called ADDTUTOR.TXT in one of the following formats:                                      

The following format adds a root level topic: 
 
root:K::Additional Tutorials:1:

root 'Identifies this as a root level topic.
: 'A delimiter.
K 'Identifies the directory of the additional tutorial relative to the tutorials directory in the software.
: 'A delimiter.
: 'A delimiter.
Additional Tutorials - The topic title that is displayed.
: 'A delimiter.
1 'Represents a Book icon.
: 'A delimiter.

The following format adds a sub-root level topic.
subroot:K:K:Creating a Schematic drawing:5:Full

subroot - Identifies this as a subroot level topic.
: 'A delimiter.
K 'Identifies this topic as a relative topic to the root topic.
: 'A delimiter.
K 'Identifies the directory of the additional tutorial relative to the tutorials directory in the software.
: 'A delimiter.
Creating a Schematic drawing 'The topic title that is displayed.
: 'A delimiter.
5 'Represents a Page icon.
Full 'Identifies the use of an AVI for the Show Me button and also indicates to play entire movie.

The following format adds a root level topic.
sub:K:K:First step:5:0;19

sub 'Identifies this as a sub level topic.
: 'A delimiter.
K 'Identifies this topic as a relative topic to the subroot topic.
: 'A delimiter.
K 'Identifies the directory of the additional tutorial relative to the tutorials directory in the software.
: 'A delimiter.
First step    'The topic title that is displayed.
: 'A delimiter.
5 'Represents a Page icon.
0;19    'Identifies the use of an AVI for the Show Me button and also indicates to play entire movie.

{button Related Topics,AL("help high;adding tutorials high",0,`NOT_FOUND')}



Insert a Hyperlink
1 On the Main toolbar, click the Hyperlink button.

Tip    You can also select this command from the Insert menu. You can press the Esc key on the keyboard to 
stop the command. For more information about the command, you can read the software prompts in the lower
left of the window.

2 Click the object or element to insert a hyperlink.
3 On the Enter Link Source dialog box, in the box, type the address () or file path (file:D:\…).

Tip  You can also link to files on the intranet or your computer. For example, you can type the following path:   
D:\MYFILE.htm.

4 Click the Apply button to create the link.

Tips
You cannot add hyperlinks to dimensions, elements contained in nested symbols, or fills.
You can add up to five hyperlinks, URL addresses, or file paths to an element or object. If you add more than

one hyperlink, you must choose a link as the default.
If the hyperlink points to a SmartSketch document, then SmartSketch opens the document. The browser 

opens all other documents.

{button Related Topics,AL("hyperlink high;hyperlink cmd;edit hyperlink how",0,`NOT_FOUND')}



Edit a Hyperlink
1 On the Main toolbar, click the Hyperlink button.

Tip    You can also select this command from the Insert menu. You can press the Esc key on the keyboard to 
stop the command.

2 Pause the pointer over the object or element with a hyperlink.
Tip    The pointer changes to a hand icon if a hyperlink exists.

3 On the shortcut menu, click Edit Link.
Tip    Right-click to display the shortcut menu. On the shortcut menu, you can also use the Add Link, 
Remove Link, and Follow Link commands to modify the hyperlink. 

4 On the Select Link To Edit dialog box, click the hyperlink to edit.
5 Click Edit.
6 On the Enter Link Source dialog box, type your changes to the hyperlink.
7 Click Apply.

{button Related Topics,AL("hyperlink high;hyperlink cmd;edit hyperlink cmd",0,`NOT_FOUND')}



Delete a Hyperlink
1 On the Main toolbar, click the Hyperlink button.

Tip    You can also select this command from the Insert menu. You can press the Esc key on the keyboard to 
stop the command.

2 Pause the pointer over the object or element with a hyperlink.
Tip    The pointer changes to a hand icon if a hyperlink exists.

3 On the shortcut menu, click Remove Link.
4 On the Select Link To Remove dialog box, click the hyperlink that you want to remove.
5 Click Remove.

{button Related Topics,AL("hyperlink high;hyperlink cmd;remove hyperlink cmd",0,`NOT_FOUND')}



Follow a Hyperlink
1 On the Main toolbar, click the Hyperlink button.

Tip    You can also select this command from the Insert menu. You can press the Esc key on the keyboard to 
stop the command.

2 Pause the pointer over the object or element with a hyperlink.
Tip    The pointer changes to a hand icon if a hyperlink exists. You can also click Show Links on the shortcut 
menu. All the elements or objects with hyperlinks highlight.

3 On the shortcut menu, click Follow Link.
Tip    To see the shortcut menu, right-click as you highlight the element or object. This action displays other 
commands in addition to Follow Link, such as Add Link, Edit Link, and Remove Link.

4 Click the hyperlink that you want to follow.

Tips
You can also click the element to follow the hyperlink, without accessing the command on the shortcut 

menu.
If the hyperlink points to a SmartSketch document, then SmartSketch opens the document. The browser 

opens all other documents.

{button Related Topics,AL("hyperlink high;hyperlink cmd;follow hyperlink cmd;show hyperlink 
cmd",0,`NOT_FOUND')}



Draw an Isometric Circle

Tip    To access this command, you must place the command on a toolbar or menu with the Customize 
command on the Tools menu. On the Toolbars tab of the Customize dialog box, click the Draw category.
            How?  

1 Click the Isometric Circle button.

2 Click a point to define the center point of the isometric circle.
3 Click a second point to complete the circle.

Caution    You cannot drag the pointer to draw the circle.

Tips
You can set the plane on which to place the circle by setting options on the ribbon bar.

{button Related Topics,AL("iso high;iso circle cmd;iso circle rib",0,`NOT_FOUND')}



Draw an Isometric Line

Tip    To access this command, you must place it on a toolbar or menu with the Customize command on the 
Tools menu. On the Toolbars tab of the Customize dialog box, click the Draw category.
            How?  

1 Click the Isometric Line button.

2 Click a point to start the line.
3 Click a point to complete the line.

Caution    You cannot drag the pointer to draw the line.

Tips
You can set the angle for placing the line by setting options on the ribbon bar.

{button Related Topics,AL("iso line cmd;iso high;iso line rib",0,`NOT_FOUND')}



Draw an Isometric Rectangle

Tip    To access this command, you must place it on a toolbar or menu with the Customize command on the 
Tools menu. On the Toolbars tab of the Customize dialog box, click the Draw category.
            How?  

1 Click the Isometric Rectangle button.

Caution    To confirm that the isometric rectangle consists of lines that remain connected when you move 
them, turn on the Maintain Relationships option on the Tools menu. If this option is not on, the Isometric 
Rectangle button creates a rectangle composed of four separate lines that do not stay connected when you 
move each line.

2 Click a point to start defining the rectangle base.
3 Click a second point to complete the rectangle base.
4 Click a third point to complete the rectangle.

Caution    You cannot drag the pointer to draw the rectangle.

Tips
To set the plane on which to place the rectangle, you can set options on the ribbon bar.

{button Related Topics,AL("iso high;iso rectangle cmd;iso rectangle rib",0,`NOT_FOUND')}



Move a Label
If a text label or Smart Label is associated with an element or object, drag the element or object. The label 

moves with the element or object.
If a label is not associated with an element or object, drag the label. 

{button Related Topics,AL("labels high",0,`NOT_FOUND')}



Place a Smart Label
1 On the Main toolbar, click the Symbol Explorer button.
 

2 Browse to the directory.
3 Drag the Smart Label into the document. If you place the Smart Label near an element in the document, the 

Smart Label is associated with that element.

{button Related Topics,AL("labels high",0,`NOT_FOUND')}



Create a Text Label
1 Double-click an element or object. A small, blinking pointer appears below the element or object. For a closed 

element, the pointer appears in the center of that element
2 Type the text in the label.
3 Click outside the label to complete it. The text label rotates to align with the element or object to which it is 

associated.

 

Tips
You can edit a text label like a text box. 

{button Related Topics,AL("labels high",0,`NOT_FOUND')}



Make a Label Non-Associative
1 Select a text label or Smart Label that is associated with an element or object.
2 Right-click and select Drop Association. The label now moves independently of the element or object to which it

was attached.

{button Related Topics,AL("labels high",0,`NOT_FOUND')}



Edit a Text Label
1 Double-click the label. 
2 Type the text in the label.
3 Click a point outside the label to complete the operation. The text label rotates to align with the element or object 

to which it is associated.

Tips
You can format a text label like a text box. Select the label and right-click. On the shortcut menu, click the 

Edit Text Properties command.

{button Related Topics,AL("labels high",0,`NOT_FOUND')}



Edit a Smart Label
1 Double-click an element or object.
2 In the Attribute Viewer, type the values that you want for the label. 

Tips
You can edit the properties or parameters of a Smart Label.
You can also edit the properties of the elements or text in the Smart Label. Select the Smart Label and then 

click Edit Graphic Properties or Edit Text Properties on the shortcut menu.
If you place a symbol with a Smart Label in a document, you cannot select or open the Smart Label to edit it 

like most symbols. You must create a new Smart Label.

{button Related Topics,AL("labels high;edit graphic properties cmd;edit text properties cmd",0,`NOT_FOUND')}



Move Sheet Border
1 Click File > Move Sheet Border.
2 Specify the options to move, scale, and select the paper size for the sheet.

Tips
To access the Move Sheet Border dialog box, right-click in the active working sheet.
When you open a foreign data file and the software creates the graphic objects relative to their original X, Y 

positions, the objects often position off the existing sheet.
Your changes to the sheet scale and size appear in the Sheet Setup dialog box.
When you click the settings that you want on the Move Sheet Border dialog box, you can click the Apply 

button to preview your settings. When you click the Apply button, the settings apply to the active sheet. However, the
settings are not final until you click the OK button. 

{button Related Topics,AL("drawing sheets high",0,`NOT_FOUND')}



Print Several Documents Simultaneously
Caution    The command line that you type to print several documents simultaneously uses the options that you 
set in the software, except for printer selection and the number of copies. Before you begin, review the options 
on the Print dialog box. On that dialog box, click the Settings button to review the options on the Settings dialog
box. 
1 On the Windows Taskbar, in the Programs menu, click MS-DOS Prompt.
2 In the DOS Window, type a command line with the following syntax:

smartsketch.exe<space>-p<space>-q<space><printer path><space>-c<space><integer for number of 
copies><space><document path><space><document path><space><document path, and so forth>
Example    smartsketch.exe –p –q \\print1\laserjet –c 2 “c:\temp\first file.igr” c:\temp\second_file.igr
Tip    Spaces separate the document paths. If the filename contains a space, you must use double quotes.

3 Press Enter to print the documents.

Tips
You can use the command line locally or remotely when the Windows NT Server Resource Kit is installed. 

You can print from local and network printers and plotters.
You can also print multiple documents with an asterisk ( * ) in the file name as a wildcard.
The software is compatible with AIM—PWV (Asset and Information Management—Print Without View).

{button Related Topics,AL("print high",0,`NOT_FOUND')}



Display the Relationship Toolbar
On the Relationship toolbar, click Main > Relationships.

{button Related Topics,AL("relationship cmd ",0,`NOT_FOUND')}



Edit Symbol Properties
1 Click a symbol in a drawing.
2 Click Edit > Properties.
3 On the Properties dialog box, set the options you want to use.

Tips
You can use the Attribute Viewer to view user properties and parameters of a symbol. These properties 

include the dimensions and other items. To open the Attribute Viewer, double-click a symbol. You can also select a 
symbol and then click the Symbol Explorer button on the Main toolbar.

In the Attribute Viewer, the user properties appear in plain text. The parameters appear in bold text. You 
cannot edit the names of the parameters in the Name column. To change the values, click the Value column, 
type the information that you want, and press Enter.

{button Related Topics,AL("editing symbols high;symbols cmd;element properties cmd;av 
high",0,`NOT_FOUND')}



Manipulate a Symbol 
1 Click a symbol in the document.
2 Use any element manipulation command like Move, Copy, or Scale to manipulate the symbol in the drawing. 

Tips
You can edit a symbol by selecting the symbol and clicking Open on the shortcut menu.
You can manipulate only the symbol, not its individual elements. You can convert the symbol to individual 

elements on the drawing sheet by selecting the symbol and clicking the Convert command on the shortcut menu.
You can change the size of a symbol by selecting the symbol and then dragging one of the handles. 

Note  If you cannot scale the symbol with this procedure, select the symbol and click the Properties 
command on the shortcut menu. Then, on the Behavior tab of the Symbol Properties dialog box, clear the 
Lock Scale option.

{button Related Topics,AL("manipulating symbols high;symbol handles high;symbols cmd",0,`NOT_FOUND')}



Mirror a Symbol
1 Select a symbol in the document.
2 Click the mirror handle that appears as a green plus sign at the top right of the symbol's range box.
3 Drag the mirror handle in the direction that you want to mirror the symbol.

{mci_left NOMENU,MIRRORSYM1.AVI}

{button Related Topics,AL("mirroring symbols high;symbols cmd",0,`NOT_FOUND')}



Scale a Symbol 
1 Click a symbol in the document.
2 Drag one of the scale handles that appears as a black box on each corner of the symbol range box. 

{mci_left NOMENU,SCALESYM1.AVI}

Tips
You can scale a part of a parametric symbol. Drag one of the standard parameter handles. These handles 

appear as black boxes in the middle of each side of the symbol range box. Note that only one dimension of the 
symbol changes. For example, if you click the lower parametric handle on a box, only the height changes, not the 
width.

{mci_left NOMENU,PARASYM1.AVI}
You can also change the size of a parametric symbol by selecting it and changing the values in the 

Attribute Viewer. 
You can also change the size of a parametric symbol by selecting it and right-clicking. On the Parametrics 

tab of the Symbol Properties dialog box, enter the value that you want and click the Apply button. 

{button Related Topics,AL("scaling symbols high;symbols cmd",0,`NOT_FOUND')}



Attach a Connector to a Symbol
1 Open a document.
2 Place a symbol in the document. 
            How?  

3 On the Draw toolbar, click the Connector button. 
 

4 Click to start the connector. 
5 Pass the pointer over the target symbol. 

Tip    The connector can attach at keypoints on the symbol or predefined connect points. The connect points 
appear as red circles with Xs. The keypoints appear as gray circles with Xs.

6 Click the symbol to place the connector. 
Tip The connector attaches to the connect point that is nearest to the point that you clicked. Otherwise, the 
connector attaches to a keypoint or any point along the elements in the symbol.
{mci_left NOMENU,CONNPTSYM1.AVI}

Tips
A connector can attach to a symbol in several different places:
On a keypoint, represented by gray circles with Xs.
On a connect point, represented by red circles with Xs.
Anywhere along an element, such a line or circle, represented by a red dot following the pointer.

{button Related Topics,AL("connectors and symbols high;manipulating symbols high;symbol handles 
high;symbols cmd;modify connector how;connector cmd",0,`NOT_FOUND')}



Place Copies of a Symbol
1 On the Main toolbar, click the Symbol Explorer button. The Symbol Explorer automatically displays the symbol

library associated with the template or document.

Caution  For some documents, you need to click the Home button in the Symbol Explorer. You can edit the 
Home value by clicking the Browser tab of the File Properties dialog box.

2 In the Symbol Explorer window, go to the directory that contains the symbols that you want.
3 Select a symbol while pressing the right mouse button.
4 While pressing the right mouse button, drag the symbol into the document.
5 On the shortcut menu, click Stamp Here.
6 Click a point in the document to place the symbol
7 Click another point in the document to place a copy of the symbol. You can click as many points as you want to 

place multiple copies of the same symbol.

Tips
If you decide that you do not want to place several copies of a symbol, you can click Place Here on the 

shortcut menu. This places one instance of the symbol.

{button Related Topics,AL("placing symbols high;symbols cmd",0,`NOT_FOUND')}



Unlock a Symbol From an Element
1 Select the symbol.
2 Click the green lock handle to unlock the symbol.
3 Drag the symbol away from the element.

{mci_left NOMENU,UNLOCK2.AVI}

Tips
If you want to unlock the symbol from the element, you can select the symbol and click the lock handle to 

unlock it. You can then move the symbol away from the target element. 
At this point, if you want to associate the symbol and target element again, you can click the lock handle 
again. The symbol stays in the new position, but is now associated to the target element again. If you select 
another element or command after unlocking the symbol and moving it, you cannot re-establish the 
association with the target element.                                              

{button Related Topics,AL("symbol handles high",0,`NOT_FOUND')}



Associate a Symbol with an Element
Drag the symbol to a position near the target element. The symbol automatically aligns itself with the 

element. 
The symbol is now associated with the element. If you move the element, the symbol moves along the 
element. 
If you move the symbol, it moves along the element, but not away from it.
{mci_left NOMENU,UNLOCK1.AVI}

Tips
If you want to unlock the symbol from the element, you can select the symbol and click the lock handle to 

unlock it. You can then move the symbol away from the target element. 
{mci_left NOMENU,UNLOCK2.AVI}
At this point, if you want to associate the symbol and target element again, you can click the lock handle 
again. The symbol stays in the new position, but is now associated to the target element again. If you select 
another element or command after unlocking the symbol and moving it, you cannot re-establish the 
association with the target element.                                              

 

{button Related Topics,AL("symbol handles high",0,`NOT_FOUND')}



Attach a Symbol to Another Symbol with Drop Points
Using a drag point, drag a symbol to another symbol. The available drop points appear as red dots.

{mci_left NOMENU,DROPPTSYM1.AVI}

{button Related Topics,AL("symbols high;place symbol how",0,`NOT_FOUND')}

 



Create a Symbol
1 On the Draw toolbar, click the Create Symbol button.

2 Select a set of elements on the drawing sheet.
Tip    When creating a symbol using different elements, press the Ctrl key while choosing elements with the 
Select tool.

3 Click a point on the drawing sheet to define the origin of the symbol.
Caution    The Save As dialog box automatically appears at this point. You do not need to use the Save As 
command on the File menu to open this dialog box.

4 On the Save As dialog box, select the directory where you want to save the symbol.
5 Type the name that you want for the symbol. The software saves the document with an .sym extension.

{button Related Topics,AL("creating symbols high;Symbol Explorer high;symbols cmd;create parametric symbol 
how",0,`NOT_FOUND')}



Place a Symbol
Tip    Before you place a symbol, you can set an option to link or embed the symbol with the Options command 
on the Tools menu.
1 On the Main toolbar, click the Symbol Explorer button. The Symbol Explorer automatically displays the symbol

library associated with the template or document.

Caution  For some documents, you might need to click the Home button in the Symbol Explorer. The Home
path is stored on the Browser tab of the File Properties dialog box.

2 In the Symbol Explorer window, go to the directory that contains the symbols that you want.
3 Drag the symbol from the Symbol Explorer window into the active document.

Tips
You can filter the view of documents in the Symbol Explorer.    If you want to view just one type of 

document, such as symbols, pause the pointer in the Symbol Explorer window and right-click. On the shortcut 
menu, click View, then click File Type. 

If you use a certain symbol library for many different documents, you can access the library quickly by 
adding it to your list of favorites in the Symbol Explorer. Position the pointer in the Symbol Explorer window, right-
click, and click the Add To Favorites command.

To place several copies of a symbol, you can click the Stamp Here command on the shortcut menu. For 
more information on how to use this command, click the Related Topics button.

You can also place a symbol by dragging it from the Windows Explorer. You can set the default option to 
link or embed the symbol when you drag it with the Options command on the Tools menu. You set the option on the 
Symbol tab of the Options dialog box.

If you press Ctrl while you drag a symbol, the symbol is embedded. If you press Ctrl + Shift, the symbol is 
linked. 

Note    Pressing the keys overrides the option that you set for dragging symbols on the Options dialog box.
Sometimes when you place a symbol that contains dimensions in a document, the dimensions are not 

displayed. This behavior depends on what options were set when the symbol was created. However, if you open the 
symbol to edit it, the dimensions appear.

If you open or create a document while the Symbol Explorer is open, you must click the Home button to 
display the symbol directory associated with the current document or template.

{button Related Topics,AL("placing symbols high;symbols cmd;place multiple symbols how;manipulating symbols
high",0,`NOT_FOUND')}



Edit a Symbol
The way that you edit a symbol depends on if the symbol is linked or embedded. You can determine whether to 
link or embed the symbol by setting an option with the Options command on the Tools menu before you place 
the symbol on the drawing sheet. 

To Edit a Symbol Document Directly
1 Click File > Open. 
2 Select the symbol document that you want to edit. The document has an .sym extension.
3 Edit the symbol.
4 Click File > Save.

Caution    You cannot edit the connect points, drag points, handles, or other properties of a symbol directly. 
Tip    If you want to quickly edit a symbol, you can open the Symbol Explorer and double-click any symbol to 
for editing.

To Edit an Embedded Symbol
1 Select the symbol.
2 Click Open on the shortcut menu.
3 Edit the symbol.
4 Click File > Update. The software changes the symbol in the current document.
5 Click File > Close to close the symbol document and return to the document that contains the symbol.

Tip    If you change a linked symbol, the software also records those changes in the source document on your 
computer and the instance of the symbol in the current document.

To Edit Elements in a Symbol

If you want to edit individual elements of a symbol, you must convert the symbol to elements in the current 
document.
1 Select the symbol on the drawing sheet.
2 On the shortcut menu, click Convert to convert the symbol to a group of elements.

Tip    You must insert a symbol at the default scale (1:1) if you want to use the Convert command. If you scale
the symbol, you cannot convert the symbol to individual elements.

3 On the Change toolbar, click the Ungroup button to separate the elements so that you can edit them 
individually. You can now edit the symbol elements just like ones that you created with one of the drawing 
commands.

Tips
If a symbol containing a Smart Label is placed into a document, you cannot select the Smart Label and open

it to edit it like most symbols. You must create a new Smart Label.

{button Related Topics,AL("editing symbols high;symbols cmd;file properties cmd;convert cmd;ungroup 
cmd",0,`NOT_FOUND')}



Open a Symbol Library
Before you place a symbol on the drawing sheet, you can set an option to link or embed the symbol with the 
Options command on the Tools menu. On the Options dialog box, click the Symbols tab to set the option. 

Before you open a symbol library, you must either have installed the needed symbols or place the CD-ROM for 
installing the software in the appropriate drive.
1 Click File > Open.
2 Select a template or create a document. 

Tip    For example, if you want to open a symbol library of architectural symbols, you can click an architectural 
template to create a document based on that template.

3 On the Main toolbar, click the Symbol Explorer button. The Symbol Explorer automatically displays the 
symbols library associated with the template.

4 Drag the symbols from the Symbol Explorer window into the document.

Tips
If you open or create a document while the Symbol Explorer is open, you must click the Home button to 

display the symbol directory associated with the current document or template.
You can also use links from a web page to navigate in a symbol library. Sometimes a web page appears 

depending on the template for the current document.

{button Related Topics,AL("placing symbols high;Symbol Explorer high;Symbol Explorer cmd",0,`NOT_FOUND')}



Rotate a Symbol
1 Select a symbol in the document.
2 On the Change toolbar, click the Rotate button.

Tips
You can also rotate a symbol about its center with the appropriate handle. Click the green circle at the right 

of the range box for the symbol. Drag the rotate handle closer to or further from the center of the range box for the 
symbol.

{mci_left NOMENU,ROTATESYM1.AVI}
Select the symbol and press the left or right arrow keys to rotate the symbol in predefined increments. The 

rotation angle can vary depending on how you created the symbol. 

{button Related Topics,AL("rotating symbols high;symbols cmd",0,`NOT_FOUND')}



Draw a Doubleline
1 On the Draw toolbar, click the Place Doubleline button.

2 Click the point to begin the doubleline.
3 Click the point to end the doubleline. This action defines the length and rotation angle of the doubleline.
4 Do one of the following:

Right-click to end the doubleline.
To draw a series of connected doublelines, click the points to end each doubleline segment, and then right-

click.
Tip    If you close the shape, the command restarts so you begin drawing again. 
{mci_left NOMENU,DUBLINE1.AVI}

Tips
The Pinpoint command in conjunction with the Place Doubleline command allows you to place the 

doubleline relative to a known point. 
You can use driven dimensions to determine distances between doubleline elements. 
Instead of clicking to draw the end points, you can type values on the ribbon bar to place precise lines. You 

can also use a combination of graphic and ribbon bar input.
You can press the Esc key to end a doubleline or a doubleline segment.
If the Maintain Relationships option is set, SmartSketch creates relationships between the endpoints of 

the lines.
If the Maintain Relationships option is set, you can use the Selection tool to select portions of the drawing 

to be moved while the relationships are maintained.
When you use the SmartSketch Point On option, you can draw a doubleline tangent to two curved 

elements. First, click the curved element, then move the pointer through the tangent intent zone on the first element. 
Use SmartSketch to establish a tangent relationship to the other element.

Tip    If you do not use the tangent intent zone, the line connects to the elements, but is not tangent to them.
You can use SmartSketch to make an end point of a doubleline tangent or perpendicular to the key point or 

end point of another element.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit a doubleline.

{button Related Topics,AL("dubline high;dubline cmd;dubline rb;smartsketch high",0,`NOT_FOUND')}



Place a Doubleline Precisely
1 On the Tools menu, set the Pinpoint option on.

Tip    You can click the Reposition Target button on the Pinpoint toolbar or press F12 key to change the 
location of the target point to the current position.

2 On the Draw toolbar, click the Place Doubleline button.
3 Click a point to start the doubleline.
4 Click a point to end the doubleline. This action defines the length and rotation angle of the doubleline.
5 To end the doubleline, right-click. 
6 Pause over the doubleline, and press the F12 key to reposition the target point and to precisely determine the 

starting point of the next doubleline. 
7 Place the second doubleline relative to a known point on the first one.

Tips
You can also press the F9 key to set Pinpoint on or off. 
Instead of clicking to draw the end points, you can type values on the ribbon bar.    You can also use a 

combination of graphic and ribbon bar input. 
You can press the Esc key to end a doubleline or a doubleline segment. 
If the Maintain Relationships option is set, SmartSketch creates relationships between the endpoints of 

the lines. 
You can use SmartSketch to create an end point of a doubleline tangent or perpendicular to the key point or

end point of another element.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit a doubleline.

{button Related Topics,AL("dubline high;dubline cmd;pinpoint high;pinpoint cmd;draw with pinpoint how;dubline 
rb;doubleline how;smartsketch high",0,`NOT_FOUND')}



Create a Symbol Report
Caution    You must have Microsoft® Excel™ 97 or later installed on your computer.    
1 Open the Symbol Explorer. 
2 Drag symbols from one of the following directories into the document:

 <drive letter>:\PROGRAM FILES\SMARTSKETCH\
SYMBOLS\PROCESS\PFD (INTERGRAPH).                        

<drive letter>:\PROGRAM FILES\SMARTSKETCH\
SYMBOLS\PROCESS\P&ID (INTERGRAPH).

<drive letter>:\PROGRAM FILES\SMARTSKETCH\
SYMBOLS\DIAGRAMMING\NETWORK.

3 In the Symbol Explorer, browse to one of the following directories, depending on the symbols you placed in the 
document:

<drive letter>:\PROGRAM FILES\SMARTSKETCH\
SYMBOLS\PROCESS\PFD (INTERGRAPH)\REPORTS.                        

<drive letter>:\PROGRAM FILES\SMARTSKETCH\
SYMBOLS\PROCESS\P&ID (INTERGRAPH)\REPORTS.

<drive letter>:\PROGRAM FILES\SMARTSKETCH\
SYMBOLS\DIAGRAMMING\NETWORK\REPORTS.                    

4 Drag a * REPORT.sym document into the document. 
The software prompts you to update the report and, if you click OK, the software creates the report 
automatically.

{button Related Topics,AL("reports high;symbols high;attributes high",0,`NOT_FOUND')}



Update a Symbol Report
Caution    You must have Microsoft® Excel™ 97 or later installed on your computer. 

Double-click the report to update it.

{button Related Topics,AL("reports high;symbols high;attributes high;create report how",0,`NOT_FOUND')}



Format Part of an Element
Tip    To access this command, you must place it on a toolbar or menu with the Customize command on the 
Tools menu. On the Toolbars tab of the Customize dialog box, click the Draw category.
            How?  

1 Click the Segmented Style button.
 

2 On the ribbon bar, click the style or colors that you want to apply to part of an element.
3 Click the element to which you want to apply the style. The format extends to the next element that crosses or 

bounds the element to which you are applying the line type or color.
 

Tips
The Segmented Style button does not recognize symbols as a bounding element. 
If you change the size of the element, you must re-apply the line type or color with the Segmented Style 

button.

{button Related Topics,AL("segmented style cmd",0,`NOT_FOUND')}



Install or Remove an Add-In
1 Click Tools > Add-Ins.
2 To install an add-in, select the associated check box. 

Tip    The add-ins you install are active until you remove them.

Tips
To remove, clear the check box associated with the add-in. The software removes the add-ins the next time 

you start this application.
If the add-in you want to install is not listed in the Add-Ins dialog box, choose the Browse button and locate 

the drive, directory, and filename for the add-in.

{button Related Topics,AL("add-ins cmd;add-ins overview high",0,`NOT_FOUND')}



Add a Leader

 
1 Click Label > Leader.

2 Click a text box, callout, or another leader to place the annotation end of the leader.

3 Click any element to place the terminator end of the leader, or click in free space.

Tips
You can place either end of a leader first. 
After you place one end of the leader, the command only allows you to select an element that is valid for 

placing the other end of the leader. For example, if you add the annotation end of the leader to a text box, the 
command then allows you to select only elements that are valid for placing the terminator end of a leader. You could 
select a circle, but not another text box.

If you want to add a leader to a balloon, you can set an option on the Balloon ribbon bar. To select an 
existing balloon, you must click the leader of the balloon.

{button Related Topics,AL("add leader cmd;annotations high;add leader rb",0,`NOT_FOUND')}



Move an Annotation
1 Select an annotation to display its handles. As you move the pointer over the parts of the annotation, the cursor 

changes to show whether you are on a part of the annotation or a handle.    
Note    To select a balloon, you must click the leader of the balloon. You can move only a balloon with a jog in 
its leader line.

 

 
2 Click a handle and drag the leader or annotation to its new location.

The previous procedure describes the general steps you can use to move an annotation. The following 
descriptions explain how to move specific parts of an annotation.

To move a terminator
When a terminator is connected to an element, drag the terminator handle to a new location along the 

element. If you drag the handle off the end of an open element, such as a line, an extension line automatically 
appears. The annotation and break line do not move.

When a terminator is connected to an element, disconnect the terminator by holding the Alt key while you 
drag the terminator handle. The terminator type automatically changes to the active setting for a terminator in free 
space.

To reconnect a terminator to an element, drag the terminator handle to an element. The terminator type 
automatically changes to the active setting for a terminator connected to an element.

To move a leader line



Click a leader line and then drag the break line of a leader. The break line and annotation move and the 
leader line changes in length, but not orientation.

If a leader was placed with the Leader command, you can move the leader away from the annotation and 
attach it to another annotation or element. Click the leader line and then drag the handle to the annotation or leader 
that you want to connect to. 

To move a handle
Click a leader line and do one of the following: 
Drag the handle closest to the annotation to move the annotation. 

Drag the handle on a break line to move the leader line and annotation. 

Drag a vertex handle to a new location.

{button Related Topics,AL("annotations high;add leader cmd;add leader rb",0,`NOT_FOUND')}



Insert a Vertex in a Leader

1 Select a leader to display its handles. As you move the pointer over the leader, the cursor changes to show 
whether you are on a leader or a handle.

2 Position the pointer over the leader where you want to insert a vertex. 
3 Hold the Alt key and click. 

4 Drag the handle to position the new vertex.

Tips
You cannot insert a vertex on the horizontal break line of a leader.

{button Related Topics,AL("annotations high;add leader cmd",0,`NOT_FOUND')}



Delete a Vertex from a Leader
1 Select the leader that has the vertex you want to delete. This displays its handles. As you move the pointer over 

the leader, the cursor changes to show whether you are on a leader or a handle.

2 Position the pointer over the vertex you want to delete.

3 Hold the Alt key and click the handle on the vertex.

{button Related Topics,AL("annotations high;add leader cmd",0,`NOT_FOUND')}



Display the Dimension Toolbar
On the Main toolbar, click Dimension.

{button Related Topics,AL("annotations high;label cmd",0,`NOT_FOUND')}



Place a Balloon
1 Click Label > Balloon.

2 On the ribbon bar, set the options you want. In the Balloon Text box, type the text you want to appear in the 
balloon.

3 To place a balloon with a leader, click where you want to place the terminator end of the leader. The terminator 
end can be on an element or a point in free space.

4 Click where you want to place the balloon end of the leader.

Tips
To place a balloon without a leader, click on an element that you want to attach the balloon to. You can also 

click a point in free space.

{button Related Topics,AL(`annotations high;balloon cmd;balloon rb;insert vertex how',0,`NOT_FOUND')}



Display or Hide Relationship Handles
On the Relationship toolbar, click the Relationship Handles button.

{button Related Topics,AL("relating elements high;relationship handles cmd;draw high",0,`NOT_FOUND')}



Connect Elements
1 On the Relationship toolbar, click the Connect button.

2 Click an element at a key point.

3 Click another element or key point. One element moves to connect the elements.

Tips
The order in which you select the elements might determine which element moves to a new location.

{button Related Topics,AL("relating elements high;connect cmd;relationships high;relationship handles;draw 
high",0,`NOT_FOUND')}



Make Elements Symmetric About an Axis
1 On the Relationship toolbar, click the Symmetric button.

2 Click a line that you want to use as a symmetry axis.
3 Click an element.
4 Click another element. The two elements become symmetrical about the axis.

{mci_left NOMENU,CHAN9C.AVI} 

Tips
The order in which you select the elements might determine which element moves to a new location.

{button Related Topics,AL("relating elements high;symmetric cmd;relationship handles;relationships high;draw 
high",0,`NOT_FOUND')}



Make Elements Concentric
1 On the Relationship toolbar, click the Concentric button.

2 Click an arc or circle.

3 Click another arc or circle. One element moves to make the two elements concentric.

Tips
The order in which you select the elements might determine which element moves to a new location.

{button Related Topics,AL("relating elements high;concentric cmd;relationships high;relationship handles;draw 
high",0,`NOT_FOUND')}



Maintain Relationships
Click Tools > Maintain Relationships.

When Maintain Relationships is set and you apply relationships to new or existing elements, the software 
places relationship handles. on the elements. Elements that share relationships are associative; when you 
move an element, the other elements on the drawing sheet move according to the relationships they have 
with the element that you moved. Click the Related Topics button for more information about relationships.

{button Related Topics,AL("relating elements high;maintain relationships cmd;draw high;relationship handles 
high;smartsketch",0,`NOT_FOUND')}



Delete a Relationship
Note    If the relationship handles are hidden, click the Relationship Handles button on the Relationship toolbar
to display them.
1 Select a relationship handle.
2 Press the Delete key.

{button Related Topics,AL("relating elements high;relationship handles cmd;draw high;relationships 
high",0,`NOT_FOUND')}



Make Elements Parallel
1 On the Relationship toolbar, click the Parallel button.

2 Click a line.
3 Click another line. One line moves to make the two lines parallel.

{mci_left NOMENU,CHAN7C.AVI} 

Tips
The order in which you select the elements might determine which element moves to a new location.

{button Related Topics,AL("relating elements high;parallel cmd;relationships high;relationship handles;draw 
high",0,`NOT_FOUND')}



Lock an Element or Key Point
1 On the Relationship toolbar, click the Lock button.

2 Click an element or key point to lock the element and prevent it from being modified. 
{mci_left NOMENU,CHAN4C.AVI} 

{button Related Topics,AL("relating elements high;lock cmd;relationship handles;draw high",0,`NOT_FOUND')}



Make Elements Equal
1 On the Relationship toolbar, click the Equal button.

2 Click an element.
3 Click another element. The elements become equal.

{mci_left NOMENU,CHAN3C.AVI} 
Tips

You can make the following elements equal:    two lines, two arcs, two circles, and an arc and a circle.
You cannot make a line equal to an arc or circle. 

{button Related Topics,AL("relating elements high;equal cmd;relationships high;relationship handles;draw 
high",0,`NOT_FOUND')}



Make Elements or Key Points Horizontal or Vertical
1 On the Relationship toolbar, click the Horizontal/Vertical button.

2 Do one of the following:
To make a line horizontal or vertical, click the line.

{mci_left NOMENU,CHAN5C.AVI} 
To make two key points horizontal or vertical, click a key point, and then click another key point.

{mci_left NOMENU,CHAN5C_B.AVI} 
Tips

The current orientation of the line determines how it is positioned after you select it. For example, if a line is 
closer to a horizontal orientation than a vertical orientation, the line becomes horizontal. 

{button Related Topics,AL("relating elements high;horizontal/vertical cmd;draw high;relationships 
high;relationship handles",0,`NOT_FOUND')}



Make Elements Colinear
1 On the Relationship toolbar, click the Colinear button.

2 Click a line, and then click another line. One line moves to become colinear with the other.
{mci_left NOMENU,CHAN2C.AVI} 

Tips
The order in which you select the elements might determine which element moves to a new location.

{button Related Topics,AL("relating elements high;colinear cmd;relationships high;relationship handles;draw 
high",0,`NOT_FOUND')}



Make Elements Perpendicular
1 On the Relationship toolbar, click the Perpendicular button.

2 Click a line.
3 Click a line, arc, or circle. One line moves to make the two elements perpendicular.

{mci_left NOMENU,CHAN8C.AVI} 

Tips
The order in which you select the elements might determine which element moves to a new location.

{button Related Topics,AL("relating elements high;perpendicular cmd;relationships high;relationship 
handles;draw high",0,`NOT_FOUND')}



Make Elements Tangent
You can make two elements tangent.
To make elements tangent where their end points meet
1 On the Relationship toolbar, click the Tangent button.

2 Click at a point where two end points meet. The elements are adjusted to make the two elements tangent.

To make elements tangent that are not connected at an end point 
1 On the Relationship toolbar, click the Tangent button.
2 Click an element.
3 Click another element.

One element moves to make the two elements tangent.
{mci_left NOMENU,CHAN10C.AVI} 

Tips
The order in which you select the elements might determine which element moves to a new location.

{button Related Topics,AL("relating elements high;tangent cmd;relationships high;relationship handles;draw 
high",0,`NOT_FOUND')}



Display the Change Toolbar
On the Main toolbar, click the Change button.

{button Related Topics,AL("manipulate high;change cmd",0,`NOT_FOUND')}



Draw a Chamfer

Note    You can draw a chamfer only between linear elements.
1 On the Draw toolbar, click the Chamfer button.

2 On the ribbon bar, type a distance value in the Setback A box. The first linear element will be set back this 
distance from the corner.

3 Do one of the following:
To define the setback distance for the second linear element, type a value in the Setback B box on the 

ribbon bar.
To define the chamfer angle, type a value in the Angle box on the ribbon bar.

4 Click the linear element to which you want to apply the Setback A value.
5 Click the linear element to which you want to apply the Setback B value or the chamfer angle value.

Note    The lines that you select do not need to intersect, but they cannot be parallel.
6 Click to draw the chamfer.

{mci_left NOMENU,CHMFER1C.AVI} 

Tips
When two lines intersect, you can draw a chamfer simply by clicking the corner and then moving the pointer 

in the distance that you want. A final click on the drawing sheet places the chamfer.

You can draw a chamfer with equal chamfer angles. Click the two linear elements you want to use. When 
the chamfer is displayed dynamically, move the pointer until the setback distance you want to use is displayed, then 
click.

You can switch the setback values for the linear elements. After you click the linear elements you want to 
use, move the mouse cursor to one side or the other of the temporary line display, then click.

When the elements you want to use cross each other, you can draw the    chamfer in any of the quadrants. 
The software trims the remaining elements at the end points of the chamfer.



You can easily draw more than one 45 degree chamfer with the same setback distance. On the ribbon bar, 
type a value in the Setback A or Setback B box. The value in the setback box is active until you change it, so you 
can click one corner after another to draw equivalent chamfers.

You can draw a chamfer by dragging the pointer over the two elements that you want to draw the chamfer 
between. When you use this method, the setback distance and angle boxes on the ribbon bar are not active.

{button Related Topics,AL("chamfer cmd;chamfer rb",0,`NOT_FOUND')}



Draw a Circular Pattern
{mci_left NOMENU,CIRCPTN1.AVI}
1 Select one or more elements to pattern.

 
2 On the Change toolbar, click the Circular Pattern button.

3 Click where you want the center of the circular pattern to be.
4 Use the ribbon bar boxes and the Circular Pattern Options dialog box to define other characteristics of the 

pattern, such as the number of pattern members and rows.
5 To finish creating the pattern, click the Finish button on the ribbon bar.

 

Tips
If you do not like the results of the pattern, you can click the Undo button on the Main toolbar.

{button Related Topics,AL("circular pattern rb;circular pattern cmd;circular pattern db;rectangular pattern 
db;select high;patterns high",1)}



Close a Document
1 Click File > Close.
2 If you have made changes since the document was last saved or if you have never saved a new document, you 

are prompted to indicate if you want to save your changes. Do one of the following:
If you do not want to save your changes, click the No button. 
If you want to save the changes, click the Yes button. If you click the Yes button, the Save As dialog box is 

displayed so that you can give the document a name and specify a directory and format to save it to.
If you do not want to close the document, click the Cancel button.

{button Related Topics,AL("document high;close cmd;save as db",0,`NOT_FOUND')}



Close an Object's Document and Save the Changes
The Close and Return command is available only after you double-click an object and edit it.

Click File > Close > Return. The changes you made to the object are saved to memory.

Tips
When you use the Close and Return command, you are not asked to save the document until you exit 

SmartSketch.
You can use the Revert command to close the document without saving your changes.

{button Related Topics,AL("revert imag cmd",0,`NOT_FOUND')}



Copy an Element
1 Select an element.
2 On the Main toolbar, click the Copy button.
 

Tips
After you copy an element and its relationships, they are placed on the Clipboard. You can then use the 

Paste command to paste them into the current document, or into other documents.
When you paste the element, it is pasted on top of the element you copied. To see the pasted element, you 

must drag it.

{button Related Topics,AL("copy high;working with microsoft office high;copy cmd",0,`NOT_FOUND')}



 Create a Document
1 On the Main toolbar, click the New button.
 

2 On the File New dialog box, click the Document option.
3 In the Templates list, select the template you want to use to create the document.

Tips
If you want to create a template, you can simply save the document to the TEMPLATE directory located in 

the directory where you installed the software. A different filename extension is not needed. 
You can change the directory where templates are saved by selecting the Options command on the Tools 

menu and setting the directory that you want on the File Locations tab of the Options dialog box.

{button Related Topics,AL("new cmd;documents high",0,`NOT_FOUND')}



Draw a Corner by Trimming and Extending Elements 
1 On the Draw toolbar, click the Trim Corner button.

2 Do one of the following:
Click each element you want to trim or extend.

Drag the pointer over one or more elements, then release the mouse button.    The parts of the element over 
which you dragged the mouse remain—other parts are trimmed or extended as necessary.

Note    You can draw only one corner at a time by dragging the pointer.

{button Related Topics,AL("corner trim cmd;extending or trimming high",0,`NOT_FOUND')}



Customize the Software with the Options Command
You can use the Options command on the Tools menu to customize the software. You can change such things 
as the screen appearance, document location, and display colors.
1 Click Tools > Options.
2 On the Options dialog box, select the tab containing the information you want to customize.
3 Use the controls on the Options dialog box to make the appropriate changes.

{button Related Topics,AL("options cmd",0,`NOT_FOUND')}



Add a Button to a Toolbar
1 Click Tools > Customize.
2 On the Toolbars tab, click the category that contains the command you want to add.
3 Drag the command button from the Buttons display area to the toolbar.

{button Related Topics,AL("customize high;customize cmd;customize db",0,`NOT_FOUND')}



Create a New Toolbar
1 Click View > Toolbars.
2 On the Toolbars dialog box, click the New button.
3 On the New Toolbars dialog box, type the name of the new toolbar. When you click OK, the Customize dialog 

box appears so that you can add buttons to the new toolbar.
4 On the Toolbars tab, click the category that contains the command you want to add.
5 Drag the command button from the Buttons display area to the toolbar.

Tip    When you create a new toolbar, the changes that you made appear only if a document is open.

{button Related Topics,AL("customize high;customize cmd;customize db",0,`NOT_FOUND')}



Delete a Command From a Menu
1 Click Tools > Customize.
2 On the Menu tab, double-click a menu in the List box. The List box expands to show the commands on the 

existing menu.
3 Click the name of an existing menu or command that you want to remove from the menu or the main menu bar.
4 Click the Remove button.

Tip    When you delete a command from a menu, the changes that you made appear only if a document is 
open.

{button Related Topics,AL("customize high;customize cmd;customize db",0,`NOT_FOUND')}



Remove a Command from a Toolbar
1 Click Tools > Customize.
2 On the Toolbars tab, drag the button you want to remove from the toolbar and drop it outside the toolbar 

boundary.
Tip    When you remove commands from the toolbars, the changes that you made appear only if a document 
is open.

{button Related Topics,AL("customize high;customize cmd;customize db",0,`NOT_FOUND')}



Create a New Menu
1  Click Tools > Customize.
2 On the Menu tab, click the command category that you want in the Categories box.
3 In the List box, click the name of an existing menu.
4 Click the Add Menu button. The new menu is added after the existing menu.

Tip    If you want to add a menu to an existing menu, set the Place Into Selected Menu check box before you
click the Add Menu button. You can add commands to the new menu later to create a cascading menu.

5 In the List box, type the name of the menu and click anywhere away from the name to enter it.
Tip    When you create menus, the changes that you made appear only if a document is open.

{button Related Topics,AL("customize high;customize cmd;customize db",0,`NOT_FOUND')}



Add a Command to a Menu
1 Click Tools > Customize.
2 On the Menu tab, click the command category that you want in the Categories box.
3 In the Commands/Macros box, click the name of the command that you want to add.
4 In the List box, double-click the name of an existing menu that you want to add a command to. The List box 

expands to show the commands on the existing menu.
5 Click the name of the command that you want the new command to appear after.
6 Set the Place Into Selected Menu check box.

Caution    If you want to add the new command to the main menu bar, do not set the Place Into Selected 
Menu check box. The name of the new command will be added to the main menu bar after the existing menu 
that you selected in the List box.

7 Click the Add Command button. The new command is added after the existing command.
Tip    When you add buttons to the menus, the changes that you made appear only if a document is open.

{button Related Topics,AL("customize high;customize cmd;customize db",0,`NOT_FOUND')}



Restore All Built-in Menus to the Original Settings
1 Click Tools > Customize.
2 On the Menu tab, click the Reset All button.

Tips
If you remove the Customize command from the Tools menu, you can restore it by positioning the pointer 

over a toolbar and, on the shortcut menu, clicking the Customize command.

{button Related Topics,AL("customize high;customize cmd;customize db",0,`NOT_FOUND')}



Cut an Element
1 Select an element.
2 On the Main toolbar, click the Cut button.
 

Tips
After you cut an element and its relationships from a document, they are placed on    the Clipboard.    You 

can then use the Paste command to paste them into the current document, or into other documents.
When relationships exist between elements, cutting the elements from a document deletes the relationships.

If there is a relationship between a selected element and an unselected element, you can do one of the following:
Cut and paste only the selected element.
Cut and paste both elements and their relationship.
Cut and paste only the selected element and the relationship, then reconnect the relationship to another 

element.

{button Related Topics,AL("cutting high;cut cmd;edit high;paste cmd;delete cmd",0,`NOT_FOUND')}



Delete an Element
1 Select an element.
2 Click Edit > Delete or press Delete.
Note    When you delete an element and its relationships, the relationships are not pasted to the Clipboard and 
cannot be reinserted. However, you can restore an element and its relationships by immediately using the Undo 
command.

{button Related Topics,AL("cutting high;delete high;element high;edit high;cut cmd;delete 
cmd",0,`NOT_FOUND')}



Edit a Dimension Prefix
1 Select a dimension.
2 On the ribbon bar, click the Prefix button.

3 On the Dimension Prefix dialog box, type the characters that you want to appear as prefix, superfix, suffix, and 
subfix information in the appropriate boxes.
Note    While you type information in one of the boxes, you can also click a symbol at the top of the dialog box 
to add symbols to the prefix, superfix, suffix, and subfix information.

4 Click Apply to change the dimension that you selected.

Tips
You can also use the Dimension Prefix dialog box while you place a dimension.
You can change the prefix or suffix gap by selecting a dimension. Then, you can click Properties on the 

Edit menu. On the Spacing tab of the Dimension Properties dialog box, change the prefix or suffix gap. You can 
also set the superfix or subfix gap on this tab.

{button Related Topics,AL("dimension prefix db;dimensions high",0,`NOT_FOUND')}



Change a Driven Dimension to a Driving Dimension
1 On the Tools menu, set the Maintain Relationships command.
2 Select the driven dimension you want to change.
3 On the ribbon bar, click the Toggle Driving button.    The color of the dimension changes to indicate a driving 

dimension.

Tips    
To place a driving dimension, you must set Maintain Relationships on the Tools menu, select an element, 

and then click a dimension command on the Dimension toolbar; the dimension that you place by default is a driving 
dimension.

To change a driving dimension to a driven dimension, select a driving dimension and click the 
Driving/Driven button.

To set the colors for driving and driven dimensions, select the dimension and click Properties on the 
shortcut menu.    Then set the options you want on the Properties dialog box.

{button Related Topics,AL("dimension cmd;dimension cmds;dimensions high",0,`NOT_FOUND')}



Set a Dimension Axis
1 On the Dimension toolbar, click the Axis button.

2 Click an element to which you want the dimension axis to be parallel or perpendicular.

3 Click to place a dimension axis. You can now place a dimension that runs parallel or perpendicular to the 
dimension axis that you have defined.

4 To use the dimension axis that you set with the Axis button, click the Distance Between or Coordinate 
Dimension buttons on the Dimension toolbar.

5 On the ribbon bar, set Explicit in the Dimension Axis box. After you define the dimension axis, you can place 
dimensions that run parallel to or perpendicular to the dimension axis.

{button Related Topics,AL("dimension axis cmd;group dimensions high;dimensions high",0,`NOT_FOUND')}



Place a Dimension Group
{mci_left NOMENU,COORDIM1.AVI}
1 On the Dimension toolbar, click one of the following buttons:

Distance Between

Angle Between

Symmetric Diameter

Coordinate Dimension

2 Click an element that you want to measure.

 
3 Click to place the dimension.

 
4 Click another element that you want to measure.

 
5 Click to place the dimension in the dimension group. 

 

Tips
The first dimension that you place in a dimension group is the origin dimension.
The Coordinate Dimension button places coordinate dimensions. Coordinate dimensions can only be 

placed in a group. You can place coordinate dimensions in any order and on any side of the elements that you want 
to dimension. 

 

{button Related Topics,AL("dimension distance between cmd;dimension angle between cmd;dimension 
symmetric diameter cmd;dimension coordinate cmd;dimension groups high;dimensions 



high",0,`NOT_FOUND')}



Place a Symmetric Diameter Dimension
1 On the Dimension toolbar, click the Symmetric Diameter button.

2 Click an element or key point. This element or key point is the origin.

3 Click an element to measure or a key point to measure to.

4 Move the pointer where you want to place the dimension. The dimension dynamically follows the movement of 
the pointer.

5 Click to place the dimension.

6 To place another dimension, click another element to measure or key point to measure to. 
Note    The origin element for this dimension is the first element or key point that you selected.

7 Click to place the dimension.

Tips
To use a different origin element for additional dimensions, right-click to resume editing.
After you click the two elements that you want to dimension between, the dimension changes depending on 

where you move the cursor.



Turn on the Half option on the ribbon, and the dimensions appear as half.    Turn off the Half option on the 
ribbon, and the dimensions appear as full.

{button Related Topics,AL("symmetric diameter cmd;dimension groups high;dimensions high",0,`NOT_FOUND')}



Add a Dimension to a Dimension Group
1 On the Dimension toolbar, click one of the following buttons:

Distance Between

Angle Between

Symmetric Diameter

Coordinate Dimension

2 Click a dimension in a dimension group.

3 Click the element that the dimension measures.

4 Click a point for the dimension. This action adds the dimension to the dimension group.

Tips
If you change a dimension group, the group updates automatically.
If you delete a dimension from the middle of a chained dimension group, the group splits into two groups.
If you place a dimension group using the Axis button and then delete the first or middle dimension from the 

group, this action deletes all the dimensions after the removed dimension.

{button Related Topics,AL("dimension distance between cmd;dimension angle between cmd;dimension 
symmetric diameter cmd;dimension coordinate cmd;dimension groups high;dimensions high",0,`NOT_FOUND')}



Place a Driving Dimension
1 On the Tools menu, set the Maintain Relationships option.
2 Select an element.
3 On the Dimension toolbar, click one of the following commands:

SmartDimension

Distance Between

Angle Between

The dimensions that you place will be driving dimensions by default.

Tips    
To change a driving dimension to a driven dimension, select a driving dimension and, on the ribbon bar, click

the Driving/Driven button.
To set the colors for driving and driven dimensions, select the dimension and click Properties on the 

shortcut menu.    Then set the options you want on the Properties dialog box.

{button Related Topics,AL("dimension cmd;dimensions high",0,`NOT_FOUND')}



Place a Linear, Angular, or Radial Dimension
You can place the following types of dimensions with SmartDimension:

Linear dimension
Angular dimension
Radial dimension
Diameter dimension

1 On the Dimension toolbar, click the SmartDimension button.

2 Click an element. 
Tip    The command determines the type of dimension to place, depending on the type of element you select, 
and displays the dimension dynamically so you can position it.

3 Position the dimension, and then click a point to place it.

Tips
The SmartDimension command automatically determines the type of dimension to place based on the 

element that you select, such as linear, radial, or angular. However, you can specify a different dimension type. For 
example, if you click the SmartDimension button and then select a circle, the Diameter button on the ribbon bar is 
active; you then place a diameter dimension. If you want to place a radial dimension instead, you can click the Radial
button on the ribbon bar before you click to place the dimension.

To place a driving dimension, you must set Maintain Relationships on the Tools menu, select an element, 
and then click a dimension command on the Dimension toolbar; the dimension that you place is a driving dimension 
by default.

You can change a dimension to driving or driven by selecting it and then clicking the Driving/Driven button 
on the ribbon bar. 

To place a linear dimension between the end points of a line, you must press the Shift key. 

{button Related Topics,AL("linear dimensions high;smartdimension cmd;dimensions high",0,`NOT_FOUND')} 
{button Show Me,AL("dimension length of line ex;dimension diameter of circle ex",0,`NOT_FOUND')}



Set the Dimension Units
1 Select a dimension.
2 On the shortcut menu, click Properties.
3 On the Dimension Properties dialog box, click the Units tab.
4 Set the options you want to use for the dimension unit.

Tips
You can set the dimension units for a dimension that you are about to place using the Dimension command

on the Format menu.
You can save the dimension unit settings in a dimension style using the Style command on the Format 

menu.

{button Related Topics,AL("dimensions high;dimension cmd;dimension properties db;properties 
cmd",0,`NOT_FOUND')}



Measure an Area
1 On the Dimension toolbar, click the Measure Area button. 

2 Click inside a closed boundary to measure its area. 
The area measurement for the closed boundary appears next to the pointer. The measured area appears as a
gray fill.

Note    As you click points, press the Shift key to display the total area by the pointer.

Tips    
If you are measuring multiple areas and want to clear a measurement, click inside one of the filled, closed 

boundaries that you have measured while pressing the Shift key.
When you are drawing elements or modifying a drawing, you can measure an area with the Measure Area 

button at any time.
You can press the Tab key to move between the area and total area. You can also press Ctrl + C to copy 

the value to the Clipboard. You can then press Ctrl + V to paste the value to a text box or ribbon bar field.

{button Related Topics,AL("measure area cmd;measure area rb;measure high",0,`NOT_FOUND')}



Return Dimension Text to the Actual Value of the Element
When you override the value of a driven dimension by editing the dimensional value, the resulting dimension is 
not-to-scale. For example, if you override the dimensional value of 15 millimeters to 30 millimeters, the actual 
size of the visible line remains 15 millimeters. Only the dimension text is changed; the line remains unchanged.

1 Select a driven dimension.
Note    A color that you set with the Style command on the Format menu indicates a driven dimension. You 
can also set the color by selecting a dimension and clicking the Properties command on the Edit menu.

2 On the ribbon bar, delete the dimensional value from the Value box and type a new value.

Tips
Another way to return a dimension to its actual value is to select a dimension and use the Not to Scale 

command on the shortcut menu.
You can show dimensions that are not-to-scale by using the Styles command on the Format menu. This 

option places a zig-zag or straight line under the dimensional values that are not-to-scale.
To return the dimensional value to the value of the element it actually measures, delete all the characters 

from the Value box on the ribbon bar. You can also select a dimension and clear the Not To Scale option on the 
shortcut menu.

{button Related Topics,AL("override dimension value how;not to scale cmd;dimensions high",0,`NOT_FOUND')}



Move a Dimension
1 Click part of the dimension that you want to move.
2 Drag the dimension to a new location.

The previous procedure describes the general steps you can use to move a dimension.    The following 
descriptions explain how to move specific parts of a dimension.

To move the dimension line
Click the dimension line and drag the dimension.

To move the dimension text
1 Click the dimension text. Drag the dimension to one of the following positions:

2 Drag the dimension to one of the following positions:
Along the dimension line

Outside of the dimension line

Outside of the projection line

To move the terminator



Click the terminator and drag it.

To move the projection line
Click the projection line and drag it.    

Note    You can lengthen or shorten the projection line.

To move the leader break line
For radial dimensions, you can move the break line of the leader line. Click the dimension text. Then, drag 

the text while pressing the Shift key.

{button Related Topics,AL("dimensions high;dimension types high",0,`NOT_FOUND')}



Place a Dimension Between Two Elements or Key Points
1 On the Dimension toolbar, click one of the following buttons.

Distance Between

Angle Between

2 Click an element or key point to identify the origin element.

3 Click an element or key point to measure to.

4 Move the pointer where you want to place the dimension.    The dimension dynamically follows the movement of 
the pointer.

5 Click to place the dimension.

6 If you want to place another dimension, click another element or key point to select the next measurement 
element.    
Note    The origin element for this dimension is the element that you selected in step 2.

7 Click to place the next dimension.

Tips
After placing several dimensions, if you want to use a different origin element for additional dimensions, click

the right mouse button to start over.
After you click the two elements that you want to place the dimension between, the orientation of the 

dimension changes depending on where you move the cursor.

Before you place a dimension between two elements or keypoints, you can use the Axis command to set 
the orientation of the dimension axis on the drawing sheet. You can use the new dimension axis, rather than the 
default axis of the drawing sheet, while you are using the Distance Between command. After you define the 
dimension axis, you can place dimensions that run parallel to or perpendicular to the dimension axis. Click the 
Related Topics button for more information.

{button Related Topics,AL("dimension between cmd;dimension angle between cmd;dimensions high;set 
dimension axis how",0,`NOT_FOUND')}



Set the Dimension Type
Dimension types control how the dimension displays.    You can set the dimension type before or after you place 
a dimension.

On the ribbon bar, on the Dimension Type list, click one of the options on the palette to set the dimension 
type. 

Note In the following picture, you can click each palette option to see the type of dimension and an example 
of what the dimension will look like.

{button Related Topics,AL("dimensions high;smartdimension rb",0,`NOT_FOUND') }



Nominal

Shows the dimension based on the current active parameters.



Tolerance

Shows the dimension along with the variance allowed.



Class

Shows the dimension along with the user-defined class.



Limit

Shows the upper and lower dimensions based on the user-defined tolerances.



Basic

Shows a dimension with a border.



Reference

Shows the dimension within parentheses.



Inspection

Shows the dimension inside a balloon.



Measure a Distance
1 On the Dimension toolbar, click the Measure Distance button. 

2 Click in free space or click a key point. This identifies the point to measure from.

3 Click a point to measure to. The distance between the two points appears next to the pointer.
4 Click another point to measure to. The distance between the last two points and the distance between the first 

point and the last point appear next to the pointer.

Tips
When you move the pointer over a key point, the distance between the current location of the pointer and 

the last point you clicked appears, along with the delta values. The delta values are the distances, as measured along
the X and Y axes.

When you click a third point, the cumulative distance between the first and last point that you clicked appears 
next to the pointer.

When you are in the middle of a task, you can use the Measure Distance command at any time.
You can press the Tab key to move between the distance and total distance. You can also press Ctrl + C to 

copy the value to the Clipboard. You can then press Ctrl + V to paste the value to a text box or ribbon bar field.

{button Related Topics,AL("measure distance cmd;measure high",0,`NOT_FOUND')}



Draw Connected Lines and Arcs

1 On the Draw toolbar, click the Line/Arc Continuous button. 

This command starts in line mode by default. If you want to start by drawing an arc, press the A key.
2 Click the location to begin the line or arc.
3 Click the location to end the line or arc. You can use intent zones to specify if you want to draw a tangent or 

perpendicular arc.
4 If you are drawing an arc, click a point on the arc to define the radius.

Note    After you draw an arc, the command switches back to line mode automatically. You can switch back to 
arc mode if you want to draw another arc.

5 Continue drawing lines or arcs, pressing the A key to switch to arc mode and the L key to switch to line mode.
6 Right-click to finish.

Note    If you close the shape, the command restarts so you begin drawing again.
{mci_left NOMENU,DLNARC1C.AVI}    

Tips
Instead of pressing L or A to switch modes, you can use the Line or Arc mode buttons on the ribbon bar.
You can make the first line or arc tangent or perpendicular to an element. First, move the pointer to the 

element you want to be tangent to. When the software recognizes a Point On relationship, click. Then use the intent 
zones to indicate if you want the line to be tangent or perpendicular.

Instead of clicking locations on the drawing sheet, you can type values on the ribbon bar. You can also use a
combination of graphic and ribbon bar input.

Using the ribbon bar boxes to type values does not affect the setting of the Line or Arc mode buttons.

{button Related Topics,AL("line arc cmd ;line cmd;arc cmd;smartsketch high;draw high;intent zones high 
",0,`NOT_FOUND')}



Draw Connected Lines and Arcs with FreeSketch

1 On the Draw toolbar, click the FreeSketch button.

2 On the ribbon bar, set the line and arc Element Type buttons and clear the other Element Type buttons.
3 Drag to draw a line or arc. When you stop moving the pointer, do not release the mouse button.
4 Drag to draw a series of line segments and arcs, continuing to hold the mouse button as you draw each line and 

arc.
Note    If you release the mouse button while you are drawing, you can start drawing at the last end point you 
entered. Confirm that the End Point option is set on the SmartSketch dialog box.

5 When you have finished, release the mouse button.

Tips
The Adjust option allows the software to adjust the geometry you draw.
When the Adjust option is set, the software interprets the exact movements of your cursor.
When the Adjust option is cleared, the software interprets the lines as horizontal or    vertical and the arcs as

tangent to the connected elements. If the Maintain Relationships option is set, the software places relationship 
handles.

The software recognizes relationships at the start point and end point of the line. If the Maintain 
Relationships option is set, the software places relationship handles.

You can use the boxes on the ribbon bar and the commands on the shortcut menu to edit a line or an arc.

{button Related Topics,AL("line cmd;freesketch cmd;arc cmd;draw high;smartsketch high",0,`NOT_FOUND')}



Send an Element to the Back of the Display Order
1 Select one or more elements.
2 On the Change toolbar, click the Send To Back button.

Tips
When you select a single element, the element moves to the back of the display. 

{mci_left NOMENU,SBACK.AVI} 
When you send more than one element or an element group to the back of the display order, the elements 

retain their display order within the selection set or group. 

{button Related Topics,AL("display order high;bring to front how;bring to front cmd;send to back cmd;push down 
cmd;pull up cmd",0,`NOT_FOUND')}



Pull an Element Up in the Display Order
1 Select one or more elements.
2 On the Change toolbar, click the Pull Up button.

{mci_left NOMENU,PULLUP.AVI} 

Tips
When you pull more than one element or an element group up one position in the display order, the 

elements retain their display order within the selection set or group.

{button Related Topics,AL("display order high;pull up cmd;push down cmd;push down how;bring to front 
cmd;send to back cmd",0,`NOT_FOUND')}



Push an Element Down in the Display Order
1 Select one or more elements.
2 On the Change toolbar, click the Push Down button.

{mci_left NOMENU,PUSHDOWN.AVI} 

Tips
When you push more than one element or an element group down one position in the display order, the 

elements retain their display order within the selection set or group.

{button Related Topics,AL("display order high;push down cmd;pull up cmd;pull up how;send to back cmd;bring to
front cmd",0,`NOT_FOUND')}



Bring an Element to the Front of the Display Order
1 Select one or more elements.
2 On the Change toolbar, click the Bring To Front button.

Tips
When you select a single element, the element moves to the front of the display.

{mci_left NOMENU,BFRONT.AVI} 
When you bring more than one element or an element group to the front of the display order, the elements 

retain their display order within the selection set or group.

{button Related Topics,AL("display order high;send to back how;send to back cmd;bring to front cmd;pull up 
cmd;push down cmd",0,`NOT_FOUND')}



Draw a Circle with FreeSketch

Note    The Point On or End Point options on the SmartSketch dialog box must be set to draw circles that are 
tangent to other elements.
1 On the Draw toolbar, click the FreeSketch button.

2 On the ribbon bar, set the Circle element type button and clear the other element type buttons.
3 Drag to sketch the shape of the circle or the diameter of the circle.

Tips
The Adjust option allows the software to adjust the geometry you draw.
When the Adjust option is off, the software interprets the exact movements of your cursor.
When the Adjust option is on, the software interprets your cursor movements as a circle.
If the Maintain Relationships option is set, the software places relationship handles. 
You can use the options on the ribbon bar and the commands on the shortcut menu to edit a circle.

{button Related Topics,AL("circle cmd;freesketch cmd;circle high",0,`NOT_FOUND')}



Draw a Circle Tangent to One or Two Elements
Note    You must set the Point On Element or End Point on the SmartSketch dialog box to draw circles that are
tangent to other elements.
1 On the Draw toolbar, click the Tangent Circle button.

2 Move the pointer along an element until the software recognizes a point on element relationship or a key point.
3 Click to make the circle tangent.

{mci_left NOMENU,TANCIRC1.AVI} 
4 Do one of the following to define the radius:

Move the pointer until the circle is in the position that you want, and then click.
Move the pointer until the software recognizes a tangent or key point relationship with another element, and 

then click.

Tips
Instead of clicking to define the radius, you can type values in the ribbon bar. You can also use a 

combination of graphic and ribbon bar input.
Instead of clicking several different points to draw a circle, you can draw a diagonal line, and the software 

automatically changes it to a circle.
You can define the radius first to make a circle tangent to the first element, but not fixed in one position on it.
After you type a value in the Diameter or Radius box, move the pointer along the element until the software 

recognizes a point on element relationship, and then click. The circle is then displayed dynamically, and you can 
move it along the element freely until you make it tangent to another element or key point.

If you use the Tangent Circle command when the Point On and End Point options on the SmartSketch 
dialog box are not set, you can draw a non-tangent circle by clicking two points that represent the diameter.

If the Maintain Relationships option is set, the software places relationship handles.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit a circle.

{button Related Topics,AL("tangent circle cmd;circle rb;circle high;smartsketch high",0,`NOT_FOUND')}



Draw a Circle by Center Point
{mci_left NOMENU,CIRBCEN.AVI}
1 On the Draw toolbar, click the Circle By Center button.

2 Click the location where you want the center point.
3 Click to define the radius.

Tips
Instead of clicking to define the radius, you can type values on the ribbon bar. You can also use a 

combination of graphic and ribbon bar input.
Instead of clicking several different points to draw a circle, you can draw a diagonal line and the software 

automatically changes it to a circle.
If the Maintain Relationships option is set, SmartSketch places relationship handles.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit a circle.

{button Related Topics,AL("circle by center cmd;circle rb;circle high",0,`NOT_FOUND')}



Draw with FreeSketch
1 On the Draw toolbar, click the FreeSketch button.

2 On the ribbon bar, set the element type buttons for the types of shapes you want to draw.
3 Drag to draw a shape and then release the mouse button.

 
FreeSketch interprets your sketch and places arcs, lines, circles, and rectangles when you release the 
mouse button. You can go on to draw more complex drawings with the FreeSketch button.

 

Tips
The Adjust option allows the software to adjust the geometry you draw.
When the Adjust option is off, the software interprets the exact movements of your cursor.
When the Adjust option is on, the software interprets lines as horizontal or vertical and arcs as tangent to 

the connected elements. 
The software recognizes relationships at the start points and end points of elements. If the Maintain 

Relationships option is set, the software places relationship handles.
You can use the End Point on the SmartSketch dialog box to begin or end your drawing using the end 

point or key point of an element, and the Point On option to begin or end your drawing at any point on an element.
You can set any combination of element type buttons to specify if you want to draw lines, arcs, circles, and 

rectangles or any combination.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit geometry that 

you have drawn with FreeSketch.

{button Related Topics,AL("freesketch cmd;circle high;freesketch high;smartsketch high ",0,`NOT_FOUND')}



Draw an Arc Tangent to Two Elements

Note    You must set the Point On or End Point on the SmartSketch dialog box to draw arcs that are tangent to 
other elements. You must set the SmartSketch Tangent option on the SmartSketch dialog box to draw an arc 
tangent to two elements. You can set these options by clicking the SmartSketch Settings command on the 
Tools menu.
1 On the Draw toolbar, click the Tangent Arc button.

2 Click an element to which you want the new arc to be tangent. You can click the end point of a line or curved 
element, or any point on the element.

3 Move the pointer through one of the intent zones displayed at the position you just clicked. 
If the command dynamics show an arc perpendicular to the existing element, move the pointer back to the 
intent zones and exit through a different quadrant.

4 When the command dynamics show an arc that is tangent to the first element, move the pointer to a position 
where the software recognizes the tangent relationship with another element and then click.
{mci_left NOMENU,TANARC2.AVI} 

Tips
Instead of clicking to define the radius and sweep of the arc, you can type values on the ribbon bar. You can 

also use a combination of graphic and ribbon bar input.
If the Maintain Relationships option on the SmartSketch dialog box is set, the software places relationship

handles.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit an arc.

{button Related Topics,AL("tangent arc cmd;arc rb;circle high ",0,`NOT_FOUND')}



Draw an Arc with FreeSketch

Note    You must set the Point On or End Point options on the SmartSketch dialog box to draw arcs that are 
tangent to other elements. You can set these options by clicking the SmartSketch Settings command on the 
Tools menu.
1 On the Draw toolbar, click the FreeSketch button.

2 On the ribbon bar, set the Arc element type button and clear the other element type buttons.
3 Drag to draw an arc.

Tips
The Adjust option allows the software to adjust the geometry you draw.
When the Adjust option is off, the software interprets the exact movements of your cursor.
When the Adjust option is on, the software interprets arcs as tangent to the connected elements. If the 

Maintain Relationships option is set, the software places relationship handles.
The software recognizes relationships at the start point and end point of the arc. If the Maintain 

Relationships option is set, the software places relationship handles.
When you set the Line and Arc element type buttons, you can draw connected lines and arcs.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit an arc.

{button Related Topics,AL("freesketch cmd;circle high;freesketch high;smartsketch high",0,`NOT_FOUND')}



Draw an Arc by Center Point
{mci_left NOMENU,ARCBYCEN.AVI}
1 On the Draw toolbar, click the Arc by Center Point button.

2 Click the point where you want the center point.
3 Click where you want to begin and end the sweep of the arc.

Note    You can change the arc direction by moving the pointer.

Tips
Instead of clicking to define the radius, you can type a value on the ribbon bar. You can also use a 

combination of graphic and ribbon bar input. 
Instead of clicking several different points to draw an arc, you can draw a diagonal line and the software 

automatically changes it to an arc.
If the Maintain Relationships option is set, SmartSketch places relationship handles.
You can use the boxes on the ribbon bar and the commands on the shortcut menu to edit an arc.

{button Related Topics,AL("arc by center cmd;arc rb;circle high;intent zones high ",0,`NOT_FOUND')}



Insert a Node into a Curve
1 Locate the curve and right-click to display the shortcut menu.
2 On the shortcut menu, click Insert Node.
3 Position the cursor at the location to add a node.

4 Click to insert the node.

Tips
You can use the Delete Node command on the shortcut menu to delete nodes from a curve.

{button Related Topics,AL("curve cmd;curve rb;draw curve how;circle high",0,`NOT_FOUND')}



Change the Node Type
1 Select the curve.
2 Select the node you want to change.
3 On the ribbon bar, click the button for the node type you want to change the node to: Smooth, Symmetric, or 

Cusp.

Tips
You can use the arrows on the ribbon bar to select a node.
You can use the Insert Node command on the shortcut menu to add nodes to a curve.
You can use the Delete Node command on the shortcut menu to delete nodes from a curve.

{button Related Topics,AL("curve cmd;curve rb;draw curve how",0,`NOT_FOUND')}



Change the Curve Type
1 Select the curve.
2 Do one of the following:

To change an open curve to a closed curve, set the Curve Type box on the ribbon bar to Closed.
To change a closed curve to an open curve, select the node you want to open, and then set the Curve Type 

box on the ribbon bar to Open. 

If you do not select a node, the software opens the curve at the node that was automatically activated when you 
selected the curve.

Tips
You can use the arrows on the ribbon bar to select a node.
You can use the Insert Node command on the shortcut menu to add nodes to a curve.
You can use the Delete Node command on the shortcut menu to delete nodes from a curve.

{button Related Topics,AL("curve cmd;curve rb;draw curve how;circle high",0,`NOT_FOUND')}



Draw a Rectangle or Square with FreeSketch

1 On the Draw toolbar, click the FreeSketch button.

2 On the ribbon bar, set the rectangle Element Type button and clear the other Element Type buttons.
3 Drag the pointer to sketch the diagonal of the rectangle.

Tips
The Adjust option allows the software to adjust the geometry you draw.
When the Adjust option is off, the software interprets the exact movements of your cursor.
When the Adjust option is on, the software interprets the diagonal as a rectangle or square.
You can use the buttons on the ribbon bar and shortcut menu to edit a rectangle or square.

{button Related Topics,AL("rectangle cmd;freesketch cmd;freeform high",0,`NOT_FOUND')}



Draw a Rectangle or Square
{mci_left NOMENU,RECT1.AVI}
1 On the Draw toolbar, click the Rectangle button.

2 Click the location for one corner of the rectangle or square.

3 Click to define the rotation angle and the width of the rectangle or square.
4 Do one of the following:

To draw a rectangle, click to define the height.
To draw a square, hold the Shift key, and then click. The command automatically makes the height equal to 

the width.

Tips
Instead of clicking to draw the rectangle or square, you can type values in the Width, Height, and Angle 

boxes on the ribbon bar. You can also use a combination of graphic and ribbon bar input.
Instead of clicking several different points to draw a rectangle, you can draw a diagonal line and the software

automatically changes it to a rectangle.

You can use the options on the ribbon bar and the commands on the shortcut menu to edit a rectangle or 
square.

If you place dimensions on a rectangle, they are always driven dimensions. 
You cannot ungroup a rectangle into individual lines.

{button Related Topics,AL("rectangle cmd;rectangle high ",0,`NOT_FOUND')}



Draw a Curve with FreeForm
1 On the Draw toolbar, click the FreeForm button.

2 Drag to draw a curve.

Tips
The Smooth option allows the software to adjust the geometry you draw.
When the Smooth option is off, the software interprets the exact movements of your cursor.
When the Smooth option is on, the software creates smooth, symmetric, or cusp curves.
You can use relationships to draw a curve that is tangent or perpendicular at its start point and end point. 

If the Maintain Relationships option is set, the software places relationship handles.
You can begin or end your drawing using the end point or key point of an element.
You can use the Insert Node command on the shortcut menu to add nodes to a curve.
You can use the Delete Node command on the shortcut menu to delete nodes from a curve.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit a curve.

{button Related Topics,AL("draw curve cmd;freeform cmd;draw high;curve how ;smartsketch high;freeform 
high",0,`NOT_FOUND')}



Delete a Node from a Curve

1 Locate the curve and right-click to display the shortcut menu.
2 On the shortcut menu, click Delete Node.
3 Select the node you want to delete.

Tips
You can use the arrows on the ribbon bar to select a node.
You can use the Insert Node command on the shortcut menu to add nodes to a curve.

{button Related Topics,AL("curve cmd;curve rb;draw curve how;circle high",0,`NOT_FOUND')}



Draw a Line
{mci_left NOMENU,LINE1.AVI}
1 On the Draw toolbar, click the Line/Arc Continuous button.

2 Click the point where you want the line to begin.
3 Click the point where you want the line to end.    This action defines the length and rotation angle of the line.
4 Do one of the following:

Right-click to end the line.
To draw a series of connected lines, click at the point where you want each line segment to end, and then 

right-click.
Note    If you close the shape, the command restarts so you begin drawing again. 

Tips
Instead of clicking to draw the end points, you can type values on the ribbon bar.    You can also use a 

combination of graphic and ribbon bar input.
Instead of clicking several different points to draw a line, you can drag the pointer to draw a line.
You can press the Esc key to end a line or a line segment.
If the Maintain Relationships option is set, the software places relationship handles.
When you use the Point On option on the SmartSketch dialog box, you can draw a line tangent to two 

curved elements.    First, click the curved element, then move the pointer through the tangent intent zone on the first 
element. Use the SmartSketch dialog box options to establish a tangent relationship to the other element.

Note    If you do not use the tangent intent zone, the line connects to the elements, but is not tangent to them.
You can use relationships to make an end point of a line tangent or perpendicular to the key point or end 

point of another element.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit a line.

{button Related Topics,AL("line high;line cmd;line rb;smartsketch high ",0,`NOT_FOUND')}



Draw a Line with FreeSketch

1 On the Draw toolbar, click the FreeSketch button. 

2 On the ribbon bar, set the Line element type button and clear the other element type buttons.
3 Drag to draw a line or a series of connected lines.

Tips
The Adjust option allows the software to adjust the geometry you draw.
When the Adjust option is off, the software interprets the exact movements of your cursor.
When the Adjust option is on, the software interprets the lines as horizontal or vertical when you finish 

drawing. If the Maintain Relationships option is set, the software places relationship handles.
The software recognizes relationships at the start point and end point of the line. If the Maintain 

Relationships option is set, the software places relationship handles.
When you set the Line and Arc element type buttons, you can draw connected lines and arcs.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit a line.

{button Related Topics,AL("freesketch high;freesketch rb;freesketch cmd;smartsketch high",0,`NOT_FOUND')}



Draw an Arc by Defining Three Points
{mci_left NOMENU,ARCBY3_1.AVI}
1 On the Draw toolbar, click the Arc by 3 Points button.

2 Click the location to begin the sweep of the arc.
3 Do one of the following:

Click the location that you want as midpoint of the arc, and then click the location that you want to end the 
sweep of the arc.

Click the location that you want to end the sweep of the arc, and then click the location that you want as 
midpoint of the arc.

Note    Use the intent zones at the first and second points to specify if the third point is between the first two or
beyond one of the first two.

Tips
Instead of clicking to define the sweep and the midpoint, you can type values on the ribbon bar. You can also

use a combination of graphic and ribbon bar input. 
Instead of clicking several different points to draw an arc, you can draw a diagonal line and the software 

automatically changes it to an arc.
If the Maintain Relationships option is set, the software places relationship handles.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit an arc.

{button Related Topics,AL("arc by 3 points cmd;arc rb;circle high;intent zones high ",0,`NOT_FOUND')}



Draw a Circle by Defining 3 Points
{mci_left NOMENU,CIRBY3.AVI}
1 On the Draw toolbar, click the Circle By 3 Points button.

2 Click three points on the circumference of the circle.

Tips
Instead of clicking several different points to draw a circle, you can draw a diagonal line and the software 

automatically changes it to a circle.
Instead of clicking to define the circumference of the circle, you can type values on the ribbon bar. You can 

also use a combination of graphic and ribbon bar input.
If the Maintain Relationships option is set, SmartSketch places relationship handles.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit a circle.

{button Related Topics,AL("circle by 3 points cmd;circle rb;circle high;intent zones high",0,`NOT_FOUND')}



Draw a Curve
{mci_left NOMENU,CURVE1.AVI}
1 On the Draw toolbar, click the Curve button.

2 Do one of the following:
To draw an open curve, set the Curve Type box on the ribbon bar to Open.

To draw a closed curve, set the Curve Type box on the ribbon bar to Closed.

3 Click three or more points on the drawing sheet. These points represent nodes on the curve.
Note    You must place at least three points to draw a curve.

4 Right-click to end the curve.

Tips
You can drag the pointer to draw the shape of a curve. Instead of clicking several different points to draw a 

curve, you can draw a diagonal line and the software automatically changes it to a curve.
The nodes at the start point and end point of a curve are always smooth. 
You can use the Insert Node command on the shortcut menu to add nodes to a curve.
You can use the Delete Node command on the shortcut menu to delete nodes from a curve.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit a curve.

{button Related Topics,AL("draw curve cmd;curve rb;circle high;curve how",0,`NOT_FOUND')}



Draw a Point
Note    The Point command is available only if you use the Customize command to place it on a toolbar or 
menu.
1 On your customized toolbar, click the Point button.

2 Click to place a point.

Tips
Instead of clicking to place the point, you can type values in the coordinate boxes on the ribbon bar. You can

also use a combination of graphic and ribbon bar input. 
The coordinate origin is located at the bottom left corner of the window.

You can use the options on the ribbon bar and the commands on the shortcut menu to edit a point.

{button Related Topics,AL("point cmd;draw high;customize toolbar how ",0,`NOT_FOUND')}



Draw an Ellipse by Center Point
1 On the Draw toolbar, click the Ellipse by Center button.

2 Click the location for the center of the primary axis.
3 Click the location to end the primary axis. This action defines the length of the primary axis and the rotation 

angle.
4 Click a location on one side of the primary axis. This action defines the secondary axis.

Note    The primary axis can be shorter than the secondary axis.
{mci_left NOMENU,ELLBYCEN.AVI}

Tips
Instead of clicking to define the axes and rotation angle of the ellipse, you can type values on the ribbon bar.

You can also use a combination of graphic and ribbon bar input.
Instead of clicking several different points to draw an ellipse, you can draw a diagonal line and the software 

automatically changes it to an ellipse.
If the Maintain Relationships option is set, SmartSketch places relationship handles.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit an ellipse.

{button Related Topics,AL("ellipse by center cmd;circle high",0,`NOT_FOUND')}



Draw an Ellipse by Defining 3 Points
{mci_left NOMENU,ELLBY3_1.AVI}
1 On the Draw toolbar, click the Ellipse By 3 Points button.

2 Click the location to begin the primary axis.

3 Click the location to end the primary axis. This action defines the length of the primary axis and the rotation 
angle.

4 Click a location on one side of the primary axis. This action defines the secondary axis. 
Note    The primary axis can be shorter than the secondary axis.

Tips
Instead of clicking to define the primary and secondary axes of an ellipse, you can type values on the ribbon 

bar. You can also use a combination of graphic and ribbon bar input.
Instead of clicking several different points to draw an ellipse, you can draw a diagonal line, and the software 

automatically changes it to an ellipse.
If the Maintain Relationships option is set, the software places relationship handles.
You can use the options on the ribbon bar and the commands on the shortcut menu to edit an ellipse.

{button Related Topics,AL("ellipse by 3 points cmd;circle high ",0,`NOT_FOUND')}



Edit a Link
1 Click Edit > Links.
2 On the Links dialog box, click the link you want to edit.
3 If the link does not appear in the list, click the Change Source button and use the Change Source dialog box to 

search for the link you want to edit.
4 Click the Open Source button.
5 Make the changes you want in the source file.
6 Click File > Save to save the changes in the source file.

{button Related Topics,AL("ole high;documents high",0,`NOT_FOUND')}



Create a Variable Using a Function or Subroutine
1 Click Tools > Variables.
2 In the Variable Table, in the Unit Type list, select the unit type. This is the unit type for the variables value. The 

default type is Distance. 
Note    To store a value without units, select Scalar from the list.

3 In the Name column, click an empty cell.
4 Type a name for the variable that you want to create. Press Enter.
5 In the same row, in the Formula column, click a cell.
6 Click the Function Wizard button.
7 Click the function that you want in the Function Wizard dialog box.
8 Enter the appropriate values in the dialog box. The Function Wizard dialog box displays the available functions 

and appropriate input. For example, if the variables Var1 and Var2 already exist, some valid formulas using 
functions are as follows:
Sqr(Var1) * Sin(Var2)
Sqr( Var1^2 + Var2^2 )
Note    References to existing variables in a formula are case-sensitive. For example, if you create the 
variable Var1, you cannot reference it using var1.

Tips    
You can write external functions and subroutines in BASIC and use them as variable formulas. You can write

these functions in Visual Basic, or any text editor, and save them in a .BAS file. The Function Wizard steps you 
through the process of selecting the BASIC module, the specific function, and the necessary input and output.

If you type a function and you cannot remember the argument list, press Ctrl + A after you have typed the 
equal sign, function name, and opening parenthesis. This activates the Function Wizard with the function already 
selected for you.

You can also enter expressions with functions directly in the cell in the Formula column.

{button Related Topics,AL("variables cmd;Variable Table ",0,`NOT_FOUND')}



Edit an Existing Variable
1 In the document, select the dimensions that you want to appear in the Variable Table.
2 Click Tools > Variables.
3 The Variable Table automatically displays the dimensions that are selected in the document. To see other 

dimensions and variables, click the Filter button on the Variable Table window.
Note    To access Filters on the shortcut menu, put the mouse cursor in the white area of the Variable Table 
and click the right mouse button.

4 On the Filter dialog box, set the following options to specify which variables or dimensions are displayed in the 
Variable Table. For example, to see all the dimensions and variables in the Variable Table, set the following 
options:    

In the Type box, select Dimensions and User Variables.
In the Named By box, select Both.
In the Graphics In box, select File.

Note    When you click OK, the settings are saved, so the next time you use the Filter button, the last settings 
are used. A convenient method of limiting the number of variables and dimensions displayed is to name the 
ones you use frequently. Then, on the Filter dialog box, in the Named By box, click Users to display the 
named variables and dimensions.

5 Once a variable is displayed in the Variable Table, you can change any of its attributes, except its type and the 
unit type. On the Variable Table, in the Value column of a variable, enter a new value to change the variable.

6 In the Formula column, click the cell and use one of several methods to create a new formula.
{button How?,AL("create variable how",0,`NOT_FOUND')}

{button Related Topics,AL("variables cmd;variable table;create variable how",0,`NOT_FOUND')}



Edit a Formula Containing a Function
1 Click Tools > Variables.
2 In the Variable Table, click a cell that contains a formula that has a function.
3 Select a function that you want to replace.
4 Click the Function Wizard button. The Function Wizard dialog box displays the function you selected.
5 Type a new function to replace the existing function.
6 Click Next.
7 Click the Finish button to replace the function in the formula.

{button Related Topics,AL("variable table high;variables high;function wizard db",0,`NOT_FOUND')}



Create a Variable with a Value or Expression
1 Click Tools > Variables.
2 In the Variable Table, in the Unit Type list, select the unit type for the variables value. The default type is 

Distance, which means that any expression created will be for a distance. For example, if you want to create a 
variable to control an angular dimension, you must select Angular. 
Note    To store a value without units, select Scalar from the list.

3 In the Name column, click an empty cell.
4 Type a name for the variable that you want to create. Press Enter.
5 In the same row, in the Formula column, do one of the following:

Type the value that you want for the variable.
Type a simple expression for the variable. A simple expression consists of using basic mathematical 

operators to set up an equation using values and other variables. For example, if variables Var1 and Var2 already 
exist, you can type the following formulas when creating a new variable:    

Var1 * Var2
Var1 / 3.0
(Var2 + 5.0) * Var1
Var2 ^ 2

Note    References to existing variables in a formula are case-sensitive. For example, if you create the 
variable Var1, you cannot reference it using var1.

6 Click the Enter button to create the variable.

{button Related Topics,AL("variables cmd;Variable Table ",0,`NOT_FOUND')}



Format a Column
1 Click Tools > Variables.
2 Drag the appropriate grid lines to adjust the column width.

{button Related Topics,AL("variable table high;variables high",0,`NOT_FOUND')}



Insert a Function Into a Formula
1 Click Tools > Variables.
2 In the Variable Table, click the function cell in which you want to enter the formula.
3 Click the Function Wizard button.
4 Click the function category and the function name.
5 Click the Next button. The Function Wizard dialog box displays the arguments for the function.
6 Type the values for the arguments.
7 Click the Finish button to enter the completed function into your formula.

Tips    
You can enter values, references, names, formulas, and other functions into the boxes on the Function 

Wizard dialog box. These entries must produce valid values for the argument. 
If an argument is required, the word "required" appears in the display area on the Function Wizard Step 2 of 
2 dialog box.

{button Related Topics,AL("variable table high;variables high;function wizard db",0,`NOT_FOUND')}



Create a Variable with a Link to a Spreadsheet
You can use Microsoft Excel to link a variable to a spreadsheet. Besides Excel, you can use other spreadsheet 
software that can link or embed objects. Before you can link a variable to a spreadsheet, you must first create the
variables you want in the design document. Click the Related Topics button for more information about how to 
create a variable.
1 In another application, such as Excel, open the document that contains the spreadsheet you want to link to. The 

spreadsheet should contain the appropriate values for dimensional relationships.
Note    You can edit this link with the Links command on the Edit menu.

2 Open the design document that you want to link to and, on the Tools menu, click Variables. Arrange the 
windows of the spreadsheet document and the Variable Table in the design document so that you can see the 
appropriate cells in both documents.

3 In the spreadsheet, select the cell that you want to link to. It can be a single cell or two adjacent cells, where the 
first cell contains the value and the second cell contains the units.

A B

1 3.75 in
4 Copy the selected cells. For example, if you are using Excel, click Copy on the Edit menu.
5 In the Variable Table, in the Formula column, click the cell of the variable that you want to link the spreadsheet 

to.
6 On the shortcut menu, click Paste Link.

Note To access the shortcut menu, put the mouse cursor in the white area of the Variable Table and click the 
right mouse button.

7 Select the Enter button to accept the value you pasted. When you edit the value in the spreadsheet, the variable 
in the Variable Table updates as well. For example, when you link the dimensions in the design document to an 
Excel spreadsheet, you can change the dimensions of the design by editing the corresponding values in the 
Excel spreadsheet. The design document automatically updates.

Tips    
You can edit the links with the Edit Links command on the shortcut menu.

{button Related Topics,AL("variables cmd;variable table;create variable how",0,`NOT_FOUND')}



Extend an Element
1 On the Draw toolbar, click the Extend to Next button.

2 Do one of the following:
To extend one element at a time, click each element near the end you want to extend.

{mci_left NOMENU,EXTNXT1C.AVI} 
To extend more than one element at the same time, drag the pointer over the elements near the end you 

want to extend. When you release the mouse button, all the elements are extended.
{mci_left NOMENU,EXTNXT1C_B.AVI} 

Tips
Before you select an element to extend, you can use PickQuick to see the possible extensions. When you 

move the pointer over elements, PickQuick displays the extension that will be drawn if you click.

If an element does not extend in the direction you want it to, move your pointer closer to the end of the 
element you want to extend.

{button Related Topics,AL("extend to next cmd",0,`NOT_FOUND')}



Format a Dimension or Annotation
1 Select a dimension or annotation.
2 On the shortcut menu, click Properties. 
3 On the Properties dialog box, set the options you want.

Tip    For more information about the options, click the Related Topics button.

Tips
You can format a dimension or annotation before you place it by using the Dimension command on the 

Format menu, or by setting options on the ribbon bar.
You can also set formatting options on the Dimension ribbon bar.
You can also change a dimension style with the Style command on the Format menu. Dimension styles 

apply to dimensions and all annotations, except text boxes and callouts.
If you want to format an existing balloon, you must click to select the leader line of the balloon. Then, you 

can change the formats of the balloon.

{button Related Topics,AL("dimension db;dimensions high;dimension cmd;element properties cmd;formatting 
elements",0,`NOT_FOUND')}



Create a Fill Color
When you change a fill by setting options on the ribbon bar, you can create custom colors for the fill.
1 Select a fill.
2 On the Fill ribbon bar, click Solid Color or Pattern Color.
3 At the bottom of the palette, click More.
4 On the Colors dialog box, click Define Custom Colors and set the options you want to create a new color.
5 Click Add to Custom Colors.
6 On the Custom Color Name dialog box, type the name that you want for the color you created.    This name 

appears on the palettes for Solid Color or Pattern Color on the Fill ribbon bar.

{button Related Topics,AL("fill cmd;fill rb;colors db;custom color name db",0,`NOT_FOUND')}



Place a Fill
You can place a fill only inside a closed boundary.
1 On the Draw toolbar, click the Fill button.

2 On the Fill ribbon bar, click the settings you want.
3 Click inside one or more closed boundaries that you want to fill.

Tips
When you change a filled boundary by drawing another element, the fill does not automatically update to fit 

the new boundary. You can refill the new boundary by selecting the fill handle, then clicking Redo Fill on the ribbon 
bar to apply the fill to the new boundary. You can also refill an area by dragging the handle to the new area.

To fill a boundary quickly, you can zoom in on it first using the Zoom Area command on the View menu.
You cannot modify an existing fill style, but you can create a new fill style by typing a new name in the Style 

box on the Fill ribbon bar. The new style uses the settings on the ribbon bar as the formats for the style.

{button Related Topics,AL("fill cmd;fill high;refill how",0,`NOT_FOUND')}



Refill a Modified Boundary
When you change a filled boundary by drawing another element, the fill does not automatically update to fit the 
new boundary.
1 Select the fill handle inside the fill.
2 On the Fill ribbon bar, click Redo Fill to apply the fill to the new boundary.

Tips
You can also refill an area by dragging the fill handle to the new area.

{button Related Topics,AL("fill cmd;fill high;refill cmd",0,`NOT_FOUND')}



Create a Layer
1 On the Main toolbar, click Layers.
 

2 On the Layers ribbon bar, type the name of the new layer in the Layer box and press Enter.

Tips
You can also create a layer with the Layer Groups command on the Tools menu. On the Groups dialog 

box, you type the name of a new layer in the Layers box and press Enter. The name of the new layer is displayed at 
the bottom of the Layers table.

You cannot give the same name to two layers on the same drawing sheet.
You can create as many layers on a drawing sheet as you need.

{button Related Topics,AL(`layers high;layers cmd;layer groups cmd',0,`NOT_FOUND')}



Change the Name of a Layer or Layer Group
1 Click Tools > Layer Groups.
2 On the Groups dialog box, click a group in the Groups table.

Note    You should click directly on the Group name to change it. The name then highlights and a blinking 
pointer appears, allowing you to type the new name.

3 Do one of the following:
To change the name of a group, type the new name and press Enter.
To change the name of a layer, click the name of the layer you want to change in the Layers table. Then, 

type a new name and press Enter.

{button Related Topics,AL("layers high;layer groups cmd;layer groups db",0,`NOT_FOUND')}



Display or Hide Layers
1 On the Main toolbar, click Layers.
 

2 On the Layers ribbon bar, click the Layer Status button. On the Layer Display dialog box, the layers that 
appear in bold text are displayed on the current drawing sheet. The layers that appear in gray text are hidden. 
The layer that appears in red text is the active layer.

3 Click a layer name to display or hide the layer on the drawing sheet.
4 Click the Apply button.

Tips
If you want to display or hide layers for drawing sheets other than the current sheet, you can use the 

Display Manager command on the Tools menu. On the Display Manager dialog box, on the Sheets tab, click the 
sheet you want. Then, on the Layers tab, in the Layers column, click the layers you want to display or hide. These 
settings override the settings on the Layer Display dialog box.

{button Related Topics,AL(`layers high;layers cmd;layer groups cmd',0,`NOT_FOUND')}



Change the Layer of an Element
An element can be assigned to only one layer.
1 Select the elements whose layer you want to change.
2 On the Main toolbar, click Layers.
 

3 On the Layers ribbon bar, click the Change Layer button.
4 On the Change Layer dialog box, in the Change All To list, click the layer to change the elements to.

Tips
You can also change the layer of an element by selecting the element and clicking Properties on the Edit 

menu.

{button Related Topics,AL(`layers high;display manager db;display manager cmd;layers cmd',0,`NOT_FOUND')}



Change the Active Layer
1 On the Main toolbar, click Layers.
 

2 On the Layers ribbon bar, type or select the name of another layer in the Layer box.

Tips
If you type the name of a layer that does not exist, a new layer is created.

{button Related Topics,AL(`layers high;display manager db;display manager cmd;layers cmd',0,`NOT_FOUND')}



Create a Layer Group
1 Click Tools > Layer Groups.
2 On the Groups dialog box, in the Groups box, type the name of the new group and press Enter.
3 In the Layers table, in the Grouped column, click each box to include the layers in the group.    

Tips
In the Grouped column, if the check box beside the layer name already has a check mark, the layer is a 

member of the current layer group.
You cannot give the same name to two layers on the same drawing sheet.

{button Related Topics,AL("layers high;layer groups cmd;layer groups db",0,`NOT_FOUND')}



Modify Layers in a Layer Group
1 Click Tools > Layer Groups.
2 On the Groups dialog box, in the Groups table, select the group you want to change by clicking the button on 

the left side of the row.    In the Layers table, if the check box by the layer name is set, the layer is in the layer 
group.

3 In the Layers table, set or clear the check box of each layer to add or remove it from the layer group.

{button Related Topics,AL("layers high;layer groups cmd;layer groups db",0,`NOT_FOUND')}



Delete a Layer Group
1 Click Tools > Layer Groups.
2 On the Groups dialog box, in the Groups table, click on the layer group you want to delete.
3 Press the Delete key.

{button Related Topics,AL("layers high;layer groups cmd;layer groups db",0,`NOT_FOUND')}



Draw a Fillet

1 On the Draw toolbar, click the Fillet button.
2 On the ribbon bar, type a radius in the Radius box.
3 Click one of the elements that you want to draw the fillet between. You can draw a fillet between arcs, lines, 

circles, ellipses, and curves.
4 Click the other element.
5 Click to draw the fillet.

{mci_left NOMENU,FILLET1C.AVI} 

Tips
You can draw a fillet without typing a radius. Click the two elements you want to use, move the cursor to a 

position that defines the radius, and then click.

When the elements you want to use cross each other, you can draw a fillet at any of the quadrants. The 
software trims the remaining elements at the end points of the fillet.

You can draw a fillet at a corner with one click. On the ribbon bar, type a value in the Radius box. Position 
the pointer over a corner, then click. 

The value in the Radius box is active until you change it, so you can click one corner after another to draw 
fillets with the same radius.

You can draw a fillet by dragging the pointer over the two elements that you want to draw the fillet between. 
When you use this method, the Radius box on the ribbon bar is not active.

{button Related Topics,AL("fillet cmd;fillet rb;extending or trimming high",0,`NOT_FOUND')}



Control the Display of Elements in a Window
1 Click Tools > Display Manager.
2 On the Sheets tab, set the options you want to use for displaying elements in a window. The color, line type, and 

width settings are applied to all the elements on the sheet.
Note    To set the display for a specific layer on a sheet, select the sheet on the Sheets tab. The layers that 
are in that sheet are displayed on the Layers tab. You can specify display settings for each layer in a sheet by
clicking the Layers tab and setting the options you want.

Tips
If you want to quickly display or hide layers for the current drawing sheet, you can click Layers on the Tools 

menu. Then, on the Layers ribbon bar, you can click the Layer Status button to display or hide layers. 

{button Related Topics,AL(`display manager cmd;display manager db;layers high',0,`NOT_FOUND')}



Create a Color for Displaying Sheets or Layers
When you use the Display Manager to control the way elements or objects appear in window, you can create 
custom colors for the display of sheets or layers.
1 Click Tools > Display Manager.
2 On the Display Manager dialog box, click the row of the layer or sheet you want to change the color of.
3 Click the cell in the Color column.
4 At the bottom of the palette, click More.
5 On the Colors dialog box, click Define Custom Colors and set the options you want to create a new color.
6 Click Add to Custom Colors.
7 On the Custom Color Name dialog box, type the name that you want for the color you created.    This name 

appears on the palette that you access when you click a cell in the Color column.

{button Related Topics,AL("display manager cmd;display manager db;colors db;custom color name 
db",0,`NOT_FOUND')}



Fit All Elements in the Active View
On the Main toolbar, click Fit.

 

Tips
You can hold the Shift key as you click the Fit command to fit the view to the document.
If you have a Microsoft IntelliMouse, you can press Shift and click the mouse wheel to fit the view.

{button Related Topics,AL("views high;fit cmd",0,`NOT_FOUND')}



Insert a Font Character into a Text Box
1 On the Draw toolbar, click the Text Box button and place a text box.

2 On the Dimension toolbar, click the Character Map button.

3 On the font character chart, click the character you want to insert.
4 Click Select.
5 Continue to click the characters you want, clicking Select after you click each character.
6 On the Unicode Character Map dialog box, click Copy to copy the characters to the Clipboard.
7 Click inside the text box where you want to paste the characters.
8 On the keyboard, press Ctrl-V to paste.

{button Related Topics,AL("font character cmd;character map cmd;text how",0,`NOT_FOUND')}



Use Function Keys
Certain function keys work only when the appropriate command is active. For instance, F9 through F12 are only 
available when you use the PinPoint command.

The following table shows the function keys that you can use in the software:
Function Key Shift + 

Function Key
Ctrl + 
Function Key

Alt + Function Key

F1 Help Help
F2
F3
F4 Close File Exit 
F5 Update Active

View
Previous Zoom Level

F6
F7 Paste From 

Clipboard
F8
F9 Toggle 

PinPoint 
Display

Cut to 
Clipboard

F10 PinPoint Lock
X axis

Select First 
Menu Item

F11 PinPoint Lock
Y axis

F12 Reset 
PinPoint 
Home

ESC Causes the 
Select Tool 
to be 
selected.



Place Elements With a Grid
{mci_left NOMENU,GRID1.AVI} 
1 Click View > Grid Display.

Tip    This step is optional. You do not have to display the grid in order to align elements with it.
2 On the View menu, select the Grid Snap option. 
3 Place the elements that you want with the grid. 

Caution    You cannot place elements with the Pinpoint button on the Main toolbar if you are using the Grid 
Snap command.

Tips
You can change the grid display by setting options on the View tab of the Options dialog box.
A set of red crosshairs appears at the pointer showing where an element's points are placed when you click.

Elements align with the grid lines or nearest intersection of the grid lines.
Grid snap does not work while you identify elements that are aligned along grid lines. To override this, press 

the Alt key while identifying these elements.                                                
Relationship and alignment indicators override the grid snap. You can suppress the indicators by pressing 

the Alt key.

{button Related Topics,AL("grid cmd;grid high",0,`NOT_FOUND')}

 



Group or Ungroup Elements
Grouping elements allows you to work with them as a unit. The elements must reside in the same document and 
drawing sheet.

To group elements
1 Select two or more elements.

Note    You cannot select an element that is already a member of a group.
2 On the Change toolbar, click the Group button.

To ungroup elements
1 Select a group.
2 On the Change toolbar, click the Ungroup button.

To remove one element from a group
1 Use PickQuick to select the element you want to remove from the group.
2 On the Change toolbar, click the Ungroup button.

Tips
You can nest groups by selecting two or more groups. You can then ungroup the entire group or any of its 

members.
You can select a group and other elements and use the Group button to group them.
You can perform tasks on all members of a group by selecting the group and then selecting the command or

ribbon bar option you want to use.
You can use PickQuick to select and edit one or more members of a group.
You can use the bottom-up selection method, instead of PickQuick, to select individual group members. Set

the Bottom Up button on the Select tool ribbon bar.
You can use the Properties dialog box to find out if an element is part of a group. Select the element and 

then, on the shortcut menu, click Properties.

{button Related Topics,AL("groups high;group cmd;group properties db;group rb;ungroup cmd;select 
high",0,`NOT_FOUND')}



Display Frequently Asked Questions
1 Click Help > SmartSketch on the Web.
2 Follow the instructions on the HTML page to navigate within the site and to leave the site.
3 Return to the SmartSketch product at any time by clicking the SmartSketch icon on the bottom of your screen.

{button Related Topics,AL("faq cmd;help high",0,`NOT_FOUND')}



Access Online Tutorials
1 Click Help > Tutorials.
2 Follow the instructions on the Learning Center to navigate within the site and to leave the site.
3 Return to the product at anytime by clicking the SmartSketch icon on the bottom of your screen.

{button Related Topics,AL("online tutorials cmd;help high",0,`NOT_FOUND')}



Access Technical Documents
1 Click Help > SmartSketch on the Web.
2 Follow the instructions on the web page to navigate within the site and to leave the site.
3 Return to the SmartSketch product at anytime by clicking the SmartSketch icon on the bottom of your screen.

{button Related Topics,AL("tech doc cmd;help high",0,`NOT_FOUND')}



Open Product News
1 Click Help > SmartSketch on the Web.
2 Follow the instructions on the web page to navigate within the site and to leave the site.
3 Return to the SmartSketch product at anytime by clicking the SmartSketch icon on the bottom of your screen.

{button Related Topics,AL("product news cmd;help high",0,`NOT_FOUND')}



Send Feedback
1 Click Help > SmartSketch on the Web.
2 Follow the instructions on the web page to supply the necessary information.
3 Return to the SmartSketch product at anytime by clicking the SmartSketch icon on the bottom of your screen.

{button Related Topics,AL("send feedback cmd;help high",0,`NOT_FOUND')}



Register the Software
1 Click Help > Register.
2 Follow the instructions on the web page.
3 Return to the software at anytime by clicking the icon for the software at the bottom of your screen.

{button Related Topics,AL("register cmd;help high",0,`NOT_FOUND')}



Open Intergraph Home Page
1 Click Help > SmartSketch on the Web.
2 Follow the instructions on the web page to navigate within the site and to leave the site.
3 Return to the SmartSketch product at anytime by clicking the SmartSketch icon on the bottom of your screen.

{button Related Topics,AL("ingr home page cmd;help high",0,`NOT_FOUND')}



Access the Getting Started Guide
Browse to the Getting Started Guide directory on the CD (CD-ROM drive:\SmartSketch\Getting Started 

Guide).
Tip    You can print out the Getting Started portable document format (pdf files). 

{button Related Topics,AL("help topics cmd;help high ",0,`NOT_FOUND')}



Display the Tip of the Day
Click Help > Tip of the Day.

Tips
If you want to turn off Tip of the Day, set the check box on the Tip of the Day dialog box that appears when

you start the software. 
To turn Tip of the Day back on, you can click the Tip of the Day command on the Help menu. Then, on the 
Tip of the Day dialog box, set the Show Tips at Startup check box.

{button Related Topics,AL("tip of the day cmd;help high ",0,`NOT_FOUND')}



Display SmartSketch Help Topics
Click Help > SmartSketch Help Topics.

{button Related Topics,AL("help topics cmd;help high ",0,`NOT_FOUND')}



Turn the Tip of the Day On or Off
You can turn off Tip of the Day by clicking the Tip of the Day command on the Help menu. Then, you clear 

the Show Tips at Startup check box.
To turn on Tip of the Day, you can click the Tip of the Day command on the Help menu. Then, on the Tip 

of the Day dialog box, set the Show Tips at Startup check box.

{button Related Topics,AL("tip of the day cmd;help high ",0,`NOT_FOUND')}



Display Context-Sensitive Help
1 On the Main toolbar, click the Help button. The pointer changes to a northwest arrow with a question mark.
 

2 Click an item on the SmartSketch window.

Tip
You can also press Shift + F1 to activate the Help command and then click an item on the window.
To get Help for options on certain dialog boxes, such as the Insert Object or New dialog boxes, you can 

click the Question Mark 
 in the upper right corner of the dialog box, and click the option for which you want information. Or, you can position

the pointer over the option, and right-click for Help.

{button Related Topics,AL("context help cmd;help high",0,`NOT_FOUND')}



Display Information about SmartSketch
Click Help > About SmartSketch.

{button Related Topics,AL("about cmd;help high ",0,`NOT_FOUND')}



Display Office Compatible Help Topics
Click Help > Office Compatible.

{button Related Topics,AL("office cmd;help high ",0,`NOT_FOUND')}



Display Help for Programming with SmartSketch
Click Help > Programming with SmartSketch.

{button Related Topics,AL("programming cmd;help high ",0,`NOT_FOUND')}



Open the SmartSketch Home Page
1 Click Help > SmartSketch on the Web.
2 Follow the instructions on the SmartSketch web page to navigate within the site and to leave the site.
3 Return to the SmartSketch product at anytime by clicking the SmartSketch icon on the bottom of your screen.

{button Related Topics,AL("product home page cmd;help high",0,`NOT_FOUND')}



Access Online Support
1 Click Help > SmartSketch on the Web.
2 Follow the instructions on the web page to navigate within the site and to leave the site.
3 Return to the SmartSketch product at anytime by clicking the SmartSketch icon on the bottom of your screen.

{button Related Topics,AL("online support cmd;help high",0,`NOT_FOUND')}



Insert a Raster Image
To insert a raster image, you must first install ImageScape LT with the Add-Ins command on the Tools menu. If 
you do not see the add-in listed in the Add-In Manager, you must run Setup again and select the Custom 
installation. You can then select an option for the add-in.
1  Click Insert > Image.
2 In the Look In field, select the directory containing the raster image you want to insert.
3 In the File Name field, type the name of the raster image or select it from the list of raster images.

Tips
You can only link an image; you cannot embed one.

{button Related Topics,AL("raster high;insert image cmd",0,`NOT_FOUND')}



Exclude Universal Scrolling with the IntelliMouse
1 Click Start > Settings > Control Panel.
2 Select the Mouse icon.
3 On the Mouse Properties dialog box, click the Wheel tab.
4 In the Universal Scrolling area of the dialog box, click Exceptions.
5 On the Exceptions for Universal Scrolling dialog box, click Add.
6 On the Add Exception for Universal Scrolling dialog box, click to open the Program Files folder. Next, click 

SmartSketch > Program > draft.exe. Then click Open.
7 Accept the new settings.

{button Related Topics,AL("intellimouse high",0,`NOT_FOUND')}



Access the SmartSketch World Wide Web Page
Click Help > SmartSketch on the Web to go to the SmartSketch World Wide Web page. On this page, you 

can access a variety of tools to help you learn and use SmartSketch more efficiently.

{button Related Topics,AL("internet community cmd;help high",0,`NOT_FOUND')}



Open a SmartSketch Document Inside the Internet Explorer
1 In the Internet Explorer, click File > Open.
2 On the dialog box, select the SmartSketch document that you want to open inside the Internet Explorer. Because

SmartSketch is an ActiveX document, its toolbars and menus appear inside the Internet Explorer, along with the 
contents of the document that you selected.

Tips
You can also drag a SmartSketch document from the Windows Explorer to the Internet Explorer. The 

document automatically opens inside the Explorer. 

{button Related Topics,AL("internet high",0,`NOT_FOUND')}



Run a Macro
1 Click Tools > Macro.
2 On the Run Macro dialog box, click the macro you want to run.
3 Click the Run button.

Tips
You can create macros with any programming tool that supports OLE automation, such as Microsoft Visual

Basic.

{button Related Topics,AL(`macro cmd;customize high',0,`NOT_FOUND')}



Mirror an Element

You can mirror elements by defining a mirror axis or by using a linear element as a mirror axis. You can also 
mirror and copy elements.

To mirror about an existing mirror axis or linear element
1 Select one or more elements.
2 On the Change toolbar, click the Mirror button.

3 If you want to copy the mirrored elements, click the Copy button on the ribbon bar.
4 Locate a mirror axis. The mirrored elements are displayed dynamically on the other side of the mirror axis.

Note    If you locate a linear element, the element can be part of the selection set or separate from the 
selection set.
{mci_left NOMENU,MIRROR1C.AVI} 

5 Position the pointer so that the mirrored elements are where you want them, then click.

To mirror about a mirror axis that you define
1 Select one or more elements.
2 On the Change toolbar, click the Mirror button.
3 If you want to copy the mirrored elements, click the Copy button on the ribbon bar.
4 Define one end of the mirror axis by click in free space or by clicking a key point. The software displays the mirror

axis and mirrored elements dynamically.
{mci_left NOMENU,MIRROR1C_B.AVI} 

5 Move the pointer until the mirror axis and the mirrored elements where you want them to be, then click.

Tips
If the Maintain Relationships option is set, the software places a symmetric relationship when you mirror 

and copy elements. The mirror axis is used as the symmetry axis.
Relationships within the selection set are copied to the mirrored elements if they are still applicable.
You can click the Mirror command before you select elements to mirror. 
Instead of using the Copy button on the ribbon bar to mirror and copy, you can hold the Ctrl key while you 

click to position the elements.
Instead of positioning the mirror axis dynamically, you can use the Position Angle box on the ribbon bar.
You can use relationship indicators to define a mirror axis.
You can use other view manipulation commands, such as Zoom and Pan, while you are using the Mirror 

command.
When you finish manipulating the view, the software returns you to the Mirror command at the point where 
you left off.

{button Related Topics,AL("mirror cmd;mirroring elements high;mirror rb;mirror how",0,`NOT_FOUND')}



Set File Locations
1 Click Tools > Options.
2 On the Options dialog box, click the File Locations tab.
3 Select one of the file types in the list.
4 Click the Modify button and, on the Modify Location dialog box, select the directory where you want the 

software to look for the file type.

Tips
You can set the software to look for files on another machine. To connect to another machine, click the 

Network button on the Modify Location dialog box to access the Map Network Drive dialog box.

{button Related Topics,AL("modify location db;options cmd;map db",0,`NOT_FOUND')}

 



Move an Element
1 Select one or more elements.
2 On the Change toolbar, click the Move button.
 

3 If you want to copy the elements, click the Copy button on the ribbon bar.
4 Click to define the from point.
5 Click to define the to point. After the elements move, the relationships with other elements are not maintained.

Tips
You can click the Move command before you select elements to move.
You can use drag to move elements. Select the elements, then drag them to their new location and drop.
Instead of using the Copy button on the ribbon bar to copy elements, you can hold the Ctrl key while you 

click to position the elements.
You can use the ribbon bar boxes to specify the to point. The values are relative distances along the x and y 

axes—you must click to specify which quadrant you want to move or copy the selection set to.
When you move or copy elements, the to point becomes the next from point.
Relationships within the select set are maintained if they are still applicable after the elements have been 

moved or copied.
You can use other view manipulation commands, such as Zoom, Fit, and Pan, while you are using the 

Move command.
When you finish manipulating the view, the software returns you to the Move command at the point where you
left off.

{button Related Topics,AL("moving elements high;move cmd;move rb;move how",0,`NOT_FOUND')}



 Offset Elements
You can select elements to be offset before you select the Offset command. Or you can select the Offset 
command before you select the elements.
{mci_left NOMENU,OFFSET1C.AVI}
1 On the Change toolbar, click the Offset button.

2 Click the element or elements that you want to offset.
3 In the Step Distance box on the ribbon bar, type the distance that you want to offset the selected elements.
4 Click to define the direction in which you want to offset the elements.

Tips
If the Change toolbar is not displayed, click the Change button on the Main toolbar.
To select a chain of connected elements, select the Offset Chain button. 

{button Related Topics,AL("offset cmd;offset rb",0,`NOT_FOUND')}



Embed an Object
To Embed a New Object
1 Click Insert > Object.
2 On the Insert Object dialog box, click the Create New option. 
3 In the Object Type box, click the type that describes the software in which you want to create the object, and 

then click the OK button.
The contents of the list depend on which applications installed on your computer support linking and 
embedding.

4 To return to SmartSketch, do one of the following:
If the object was created in another application that is in a separate window, click Exit or Update on the File 

menu in that application. If a message appears asking if you want to update the document, click the Yes button.
If the software temporarily replaces some of the SmartSketch menus and toolbars, click anywhere outside 

the embedded object.
5 When you return to SmartSketch, a box the size of the object appears beside the pointer. You can click on the 

drawing sheet to place the object that you edited or created. 
Note    While the box appears beside the pointer, if you hit ESCAPE, the object will be placed at the default 
location. You can set the default location with the Options command on the Tools menu. You enter the 
location on the File Locations tab of the Options dialog box.

To Embed an Existing Object
1 Click Insert > Object.
2 On the Insert Object dialog box, click the Create From File option. 
3 In the File Name box, type or click the name of the object you want to embed, and then click the OK button.

Note    If you do not see the file that you want to embed, click a different drive or volume, directory or folder.
4 A box the size of the object appears beside the pointer. You can click on the drawing sheet to place the object 

that you edited or created. 
Note    While the box appears beside the pointer, if you hit ESCAPE, the object will be placed at the default 
location. You can set the default location with the Options command on the Tools menu. You enter the 
location on the File Locations tab of the Options dialog box.

Tips
If you are working in the source software, you can embed an existing object with the Paste Special 

command on the Edit menu.
You can also embed an object by dragging and dropping a document from the Windows Explorer into a 

SmartSketch document.
If you insert    a SmartSketch document into the current document, the terminators, spaces, text, and styles 

appear in paper units relative to the source document. The dimension lines and extension lines scale as though they 
are in real-world units. This behavior can cause the dimensions and text to appear very large or small in the container
document.

{button Related Topics,AL("object cmd;ole high;paste special cmd",0,`NOT_FOUND')}



Break a Link
1 Click Edit > Links.
2 In the Source File box, click the link or links you want to break.
3 Click the Break Link button. When the software asks you to confirm that you want to break the link, click the Yes

button.
4 Click the Close button.

{button Related Topics,AL("links cmd;ole high;links db",0,`NOT_FOUND')}



Change a Link
1 Click Edit > Links.
2 Click the link you want to change.

Note To click multiple links, hold down Ctrl while you click on each link.
3 Click the Change Source button.
4 In the File Name box, type or click the name of the file to which you want to change the link.

Tips
If you do not see the file you want to open, click a different drive, directory, or folder.
If you have other links to the same source file, make sure you change all links from the previous source file 

to the new source file.

{button Related Topics,AL("links cmd;ole high",0,`NOT_FOUND')}



Link an Object 
Make sure that you save the source document before you link the information.

To create a link to another document
1 In the software in which the information you want to link was created, open the source document and then select 

the information that you want to link.
2 Click Edit > Copy.
3 Switch to the SmartSketch document.
4 Click Edit > Paste Special.
5 Click the Paste Link option.

Note    This option is available only if the software that created the document supports OLE.
6 Under As, click the option you want.

To create a link to another document without leaving the software
1 Click Insert > Object.
2 Click the Create From File option.
3 In the File Name box, type or select the name and directory path of the document to which you want to link. 
4 Click the Link To File check box.

Note    With this procedure, you can create a link only to an entire document; you cannot link to a selection in 
a document.

Tips
SmartSketch creates links as automatic links by default. SmartSketch updates automatic links each time you

open the document and each time the data in the source document changes, whereas it updates manual links only 
when you specify. To change the way SmartSketch updates links, see Update a Link.

You can also link information by dragging and dropping a document from the Windows Explorer or 
SmartSketch Explorer onto the drawing sheet. You must press the Ctrl + Shift keys while dragging and dropping to 
link the information. If you do not press a key, the information will be embedded.

If you insert an .igr or .sym document into the document, the terminators, spaces, text, and styles appear in 
paper units relative to the source document. The dimension lines and extension lines scale as though they are in real-
world units. This behavior can cause the dimensions and text to appear very large or small in the container 
document.

{button Related Topics,AL("links cmd;links db;ole high;object cmd;copy cmd;paste special cmd;update link 
how",0,`NOT_FOUND')}



Edit an Embedded Object with the Source Software
1 Double-click the embedded object.
2 Edit the object.
3 Do one of the following:

If you are editing the object in a separate application window, click either Exit or Update on the File menu to
return to SmartSketch.

If you are editing the object in software that temporarily replaces the SmartSketch menus and toolbars, click
anywhere outside the embedded object to return to SmartSketch.

{button Related Topics,AL("links cmd;ole high;object cmd;copy cmd;paste special cmd",0,`NOT_FOUND')}



Open a Document
To Open a Document without Leaving the Software
1 On the Main toolbar, click the Open button.
 

2 Select the directory containing the document you want to open.
3 Type the name of the document or select it from the list of documents.
4 On the File Open dialog box, click OK.

To Drag and Drop a Document
1 Open the Windows Explorer and select the document that you want.
2 Drag the document into the current document.

Tips
You can open one of the last documents you worked on by selecting from the list at the bottom of the File 

menu.
In the File Open dialog box, you can double-click the document name for the document to open the 

document.
If you do not see the document you want to open, make sure the drive, directory, and type are correct.
If you do not know the location of the document, you can look for the document. On the Windows Taskbar, 

click the Start button and then click the Find command.

{button Related Topics,AL("open high;documents high",0,`NOT_FOUND')}



Paste an Element
You can place elements on the Clipboard with the Copy or Cut command, then paste the elements into the 
current document or another document. 
1 Open the document in which you want to paste the contents of the Clipboard.
2 On the Main toolbar, click the Paste button.
 

Tip    You can also click the right mouse button and click the Paste command.

Tips
The contents of the Clipboard remain unchanged until you use the Copy or Cut command again.
You cannot run the Paste command if the Clipboard is empty.
You can use the Undo command to reverse the results of the Paste command.    
Pasted text and elements remain selected after you use the Paste command. 

{button Related Topics,AL("paste cmd;copy cmd;cut cmd;edit high",0,`NOT_FOUND')}



Draw with PinPoint
{mci_left NOMENU,PPOINT.AVI}
1 On the Main toolbar, click the PinPoint button.

2 Click where you want the target point to be.
{mci_left NOMENU,PINPNT1.AVI} 

3 Run any drawing command. As you move the pointer, PinPoint displays the coordinates of the current mouse 
location in relation to the target point. To provide precision input to the current command, click when the 
coordinate display indicates that the cursor is in the correct position or type coordinate values in the X and Y 
ribbon bar boxes.
{mci_left NOMENU,PINPNT2.AVI} 
Caution    You cannot place elements with the Pinpoint button on the Main toolbar if you are using the Grid 
Snap command.

Tips
When the pointer reaches a distance from the target point that is a multiple of the Step Value set on the 

ribbon bar, the related coordinate value and help line become bold.
If you know the exact x and y distances from the target point that you want to use as command input, you 

can type the values in the X and Y ribbon bar boxes.
You can type a known x or y value into the X or Y ribbon bar box to lock one axis position, then graphically 

define the coordinate for the other axis.
You can move the target point at any time. Click the Reposition button on the ribbon bar, then click where 

you want the target point to be.
You can re-orient the PinPoint x axis. Type a positive value in the Angle box on the PinPoint ribbon bar to 

rotate the axis counterclockwise, or a negative value to rotate the axis clockwise.

{button Related Topics,AL("pinpoint cmd;pinpoint high",0,`NOT_FOUND')} {button Show Me,AL("pinpoint 
line ex",0,`NOT_FOUND')}



Re-Orient PinPoint
The default PinPoint orientation is with the PinPoint x axis horizontal. To re-orient the PinPoint x axis, type an 
angle in the ribbon bar Angle box. A positive value rotates the horizontal axis counterclockwise. A negative value
rotates the axis clockwise. The y axis is automatically repositioned to remain perpendicular to the x axis.

{button Related Topics,AL("pinpoint high;pinpoint how",0,`NOT_FOUND')}



Reposition the PinPoint Target Point
Do one of the following:

On the PinPoint ribbon bar, click the Reposition button. The target point is attached to the pointer. Click 
where you want the target point to be.

Press the F12 button on the keyboard. The target point moves to the current cursor location.

{button Related Topics,AL("pinpoint cmd;pinpoint high",0,`NOT_FOUND')}



Move an Element Precisely
You can use PinPoint with the Select Tool to move an element a precise distance in X and Y relative to a known
position in your drawing.
1 On the Draw toolbar, click the Select Tool button.

2 On the Main toolbar, click the PinPoint button.

3 Click the location that you want for the PinPoint target point to be.
4 Using the Select tool, point to the element that you want to move. Relationship indicators appear next to the 

pointer to indicate keypoints on the element.
5 When the relationship indicators identify the key point you want, drag the element. PinPoint displays the 

distance between the cursor and the reference point as you drag.
6 Release the mouse button when the element is where you want it.

{button Related Topics,AL("pinpoint high;pinpoint how;select high ",0,`NOT_FOUND')}



Position an Image
After you insert a raster image into a document, you can use the Position command to align the image with a 
vector element or a group of elements. You can move, scale, rotate, and skew a source image to match a target 
image or vector frame. All alignment modifications are made by placing up to three source points and three target
points. You can define source points by clicking and dragging or by a single click on the source image.

To use the Position command, select an image and then click Position on the shortcut menu.

Defining Source and Target Points by Clicking and Dragging

Clicking and dragging produces an outline of the source image that contains a crosshair, representing the source
image being dragged to the target image. The target image can be an actual image, a vector element, or nothing 
at all. The second point entered on the source image enables you to scale and rotate the image by clicking and 
dragging. The third point enables you to skew the image by clicking and dragging. The third point is also the "end
point."

During a drag operation, you can hold down the Shift key to restrict movement to 45 degree increments for 
placing the second target point. You can also hold down the Ctrl key to restrict movement for placing the second 
target point.

Position an image by drag:
1 Click on the image for source point one.
2 Drag the displayed outline to the appropriate position and release the mouse button at target point one.
3 Click on the image again for source point two.
4 Drag the mouse to scale and rotate the image to the appropriate angle and release the mouse for target point 

two.
5 Click on the image again for source point three.
6 Drag the mouse to skew the image to register it appropriately and release the mouse for target point three.

Defining Source and Target Points Using a Single Click

When you define source points using single clicks, you must also use single clicks to define the target points. 
Depending on where the source and target points are placed, you can use this method to move, scale, rotate, 
and skew the source image to match a target image. When you use single clicks, the image is not moved into 
position until the third target point is defined or you double-click to exit the command. 

Position an Image by a single click:
1 Click on the source image for source point one.
2 Click on the target image for target point one.
3 Click on the source image again for source point two.
4 Click another area on the target area for target point two.
5 Click a third area on the source image for source point three.
6 Click a third area on the target image for target point three.



Tips
You can hold down the Shift key and click to restrict the second target point movement to 45 degree 

increments.
You can hold down the Ctrl key and click to restrict the second target point movement to 30 degree 

increments.
You can hold down the Alt key to place the target point in any direction.
You can hold down the Shift + Alt keys to restrict the third target point movement to 45 degree increments.
You can hold down the Ctrl + Alt keys to restrict the third target point movement to 30 degree increments.

{button Related Topics,AL("position cmd",0,`NOT_FOUND')}



Set Printing Options
1 On the Main toolbar, click the Print button.
 

2 Do one of the following:
To print Do this

A selected area of a 
sheet

Under Print Range, click Print Area 
and then click the OK button. A set of
crosshairs appears that you can drag
to define the area. The Print Area 
dialog box automatically appears so 
that you can set options for printing 
the area.

A range of 
continuous sheets

In the Sheets box, type a range with 
a hyphen between the sheet 
numbers. For example, to print 
sheets 3 through 7, type 3-7. This 
prints each sheet on a separate 
piece of paper.

Non–continuous 
sheets

In the Sheets box, type the sheet 
numbers, separated by commas. For
example, to print pages 1 and 6, type
1,6.

Selected sheets In the document, select the sheets 
you want to print; then, on the Print 
dialog box, click the Selected 
Sheets option. 
This prints the selected sheets as a 
composite drawing, like layers on a 
single sheet of paper. The software 
uses the scale, paper size, and 
orientation of the active sheet for 
printing the final document.

An entire document Click the All Sheets option. This is 
recommended only when all the 
sheets have the same orientation 
and paper size.

Multiple copies of 
the entire document

In the Number of Copies box, type 
or select a number of copies. To sort 
the sheets by sheet number, select 
the Collate Copies check box.

Tips
When you select several sheets and then click the Selected Sheets option on the Print dialog box, all the 

selected sheets are printed as one composite drawing, like layers on top of one another. 
You can set other options for the printer by clicking the Properties button or the Settings button on the 

Print dialog box. You can set the paper size, source, and orientation.
Click the Sheet Setup command on the File menu to specify the drawing sheet size and scale.

{button Related Topics,AL("print cmds;print how;set printing options how;print high;drawing sheet manipulation 
how ",0,`NOT_FOUND')}



Print an Area of a Drawing Sheet
Because the available fonts available on the selected printer affect both display and printing, select the printer to 
use before you begin working on a document.

Before you can print for the first time, you must connect the printer to the computer or network, install a printer 
driver, and select the printer to print the document. For more information about installing a printer, see the printer 
documentation. To set options for an installed printer, click Print on the File menu, and then click the Properties 
button.
1 On the Main toolbar, click the Print button.
 

2 On the Print dialog box in the Name box, select the printer you want to use.
3 In the Number Of Copies box, type the number of copies you want.
4 In the Print Range box, click the Print Area option and click OK.
5 When a set of crosshairs appears, drag them to define the area that you want to print.
6 On the Print Area dialog box, set the options to print the area that you selected.

Tips
You can set other options for the printer by clicking the Properties or Settings buttons on the Print dialog 

box. You can set the paper size, source, and orientation.
When you select several sheets and then click the Selected Sheets option on the Print dialog box, all the 

selected sheets print as one composite drawing, like layers on top of one another. The software uses the scale, paper
size, and orientation of the active sheet for printing the final document.

Click the Sheet Setup command on the File menu to specify the drawing sheet size and scale.
Saving your document before you print it is a good idea. This way, if a printer error or other problem occurs, 

you will not lose any work completed since the last time you saved the document.
You can display the document as it will be printed. Click the Options command on Tools menu. Then, on 

the View tab, click the Display As Printed check box.

{button Related Topics,AL("print cmds;print cmd;set printing options how;print high;drawing sheet manipulation 
how",0,`NOT_FOUND')}



View the Properties of a Document
1 Click File > Properties.
2 On the Properties dialog box, click the tab that contains the information you want to see. 

Note    You must save the document before you can set or view the document statistics or summary 
information on the Statistics and Summary tabs of the Properties dialog box.

Tips
The Properties dialog box displays information about the current condition of the active document. If the 

document has unsaved changes, you must save the document to update the property information. 

{button Related Topics,AL("document properties high;properties cmd;file properties db;display av 
how",0,`NOT_FOUND')}



Set the Unit of Measure
1 Click File > Properties.
2 On the Properties dialog box, click the Units tab.    You can set the units for the length, area, or angle of a 

drawing.
Note    This setting does not set units for dimensions on the drawing sheet. To set the units for dimensions, 
click the Style command on the Format menu and set the units for a dimension style. Or, you can click the 
Properties command on the Edit menu and set the units for dimensions that you are about to place.

3 On the Units tab, set the options you want.

{button Related Topics,AL("properties db;unit readout db;properties cmd;measure high",0,`NOT_FOUND')}



Set Document Properties
1 Click File > Properties.
2 On the Properties dialog box, set the options that you want, such as summary information or keywords.    

Tips
You must save the document before you can set or view the document statistics or summary information on 

the Statistics and Summary tabs of the Properties dialog box.

{button Related Topics,AL("document properties high;properties cmd;file properties db",0,`NOT_FOUND')}



Print a Document
Because the fonts available on the selected printer affect both display and printing, select the printer you will use 
before you begin working on a document.

Before you can print for the first time, you must connect the printer to the computer or network, install a printer 
driver, and select the printer you will use to print the document. For more information about how to install a 
printer, see the printer's documentation. To set options for an installed printer, click Print on the File menu and 
then click the Properties button.
1 Click Main > Print button.
 

2 On the Print dialog box, in the Name box, select the printer you want to use.
3 In the Number Of Copies box, type the number of copies you want.
4 In the Print range box, specify the range of pages you want to print.

Tips
You can set other options for the printer by clicking the Properties button or the Settings button on the 

Print dialog box.
It is a good idea to save your document before you print it. This way, if a printer error or other problem 

occurs, you will not lose any work completed since the last time you saved the document.
You can display the document as it will be printed. Click the Options command on Tools menu. Then, on 

the View tab, click the Display As Printed check box.

{button Related Topics,AL("print cmds;print how",0,`NOT_FOUND')}



Print to a File
1 On the Main toolbar, click the Print button.
 

2 On the Print dialog box, set the Print to file option.
3 Click the OK button.
4 On the Print to file dialog box, type the name of the file and select the directory that you want to print to.

{button Related Topics,AL("print cmds;print how",0,`NOT_FOUND')}



Paste an Element with a Different Format
1 Cut or copy the element you want to paste.
2 Click Edit > Paste Special.
3 To embed the information, click the Paste option.
4 To link the information, click the Paste Link option.
5 In the As box, select the format that you want to use to paste the information
6 To paste the information into the lower left corner of the current document, click OK.

Tips
The contents of the Clipboard remain unchanged until you use the Paste Special command again.
You cannot run the Paste Special command if the Clipboard is empty.
If you select an element as the insertion point and that element cannot be replaced, the Clipboard contents 

are not pasted at the insertion point.
You can use the Undo command to reverse the results of the Paste Special command.    
You can use the Repeat command to repeatedly paste the contents of the Clipboard at the insertion point.
If the Clipboard contains data, and you have selected data in the document, the software replaces the 

selected data with the contents of the Clipboard.
Pasted text and elements remain selected after you use the Paste Special command. 

{button Related Topics,AL("paste special cmd",0,`NOT_FOUND')}



Draw a Rectangular Pattern
{mci_left NOMENU,RECPTN1.AVI}
1 Select one or more elements to pattern.

2 On the Change toolbar, click the Rectangular Pattern button.

3 To define a rectangular area for the pattern, click the Pattern Options button on the ribbon bar. 
4 On the Rectangular Pattern Options dialog box, set the Fit to Rectangle option. 

Note Use the ribbon bar boxes and the Rectangular Pattern Options dialog box to define other 
characteristics of the pattern, such as the number of pattern members and rows.

5 On the drawing sheet, click to identify one corner of the pattern and click to identify the opposite corner of the 
pattern. 

6 To finish creating the pattern, click the Finish button on the ribbon bar.

Tips
If you do not like the results of the pattern, you can click the Undo button on the Main toolbar.

{button Related Topics,AL("circular pattern rb;rectangular pattern rb;rectangular pattern cmd;rectangular pattern 
db;select high;patterns high",0,`NOT_FOUND')}



Redo Actions
Do one of the following:

To redo the most recent action, on the Main toolbar, click the Redo button.

To redo more than one action, click the down arrow next to the Redo button on the Main toolbar, and select 
the actions you want to undo or redo.

Note  You can do this action only if you have placed the Redo List button on the Main toolbar. You can place 
the button by clicking the Customize command on the Tools menu.

{button Related Topics,AL("edit high;redo cmd;draw high",0,`NOT_FOUND')}



Repeat a Command
Click Edit > Repeat.

{button Related Topics,AL("repeat cmd;draw high",0,`NOT_FOUND')}



Restore a Customized Toolbar to Default Settings
If you customize a toolbar, you can restore the toolbar to the original settings.
1 Click View > Toolbars.
2 In the Toolbars dialog box, select the toolbar you want to restore.
3 Click the Reset button.
4 Select the OK button.

{button Related Topics,AL("customize how;customize cmd",0,`NOT_FOUND')}



Close a Document Without Saving Changes
Note The Revert command is available after you select a document by double-clicking it.

Click File > Revert.
Note The changes you made to the document are not saved.

Tips
You can use the Close and Return command to save any changes you made to the document.

{button Related Topics,AL("revert imag cmd",0,`NOT_FOUND')}



Set an Option on a Ribbon Bar
When you start a command, the software often provides a ribbon bar.    The ribbon bar contains option buttons, 
check boxes, text boxes, and list boxes that you can use to tell the software how you want to complete a task.

To set an option
Enter the information you want the command to use.

To select or clear an option

Do one of the following:
Click the option button, check box, or list item.
Click the down arrow to display a list and then click the item you want.

{button Related Topics,AL("ui high;ribbon bars high",0,`NOT_FOUND')}



Rotate an Element
1 Select one or more elements.
2 On the Change toolbar, click the Rotate button.

3 If you want to copy the rotated elements, click the Copy button on the ribbon bar.
4 Click where you want the center of rotation to be. The software dynamically displays a reference axis for the 

rotation.
5 Click to define the other end of the reference axis. The software dynamically displays the rotation axis and 

elements being rotated.    The location and position of the reference axis defines the rotation from point.
6 Position the elements where you want them and then click to define the rotation to point.

{mci_left NOMENU,ROTATE.AVI}

Tips
To rotate by increments, type a value in the Step Angle box on the ribbon bar.
You can click the Rotate command before you select elements to rotate.
You can use relationship indicators to define the rotation from and to points.
Instead of using the Copy button on the ribbon bar to copy the rotated elements, you can hold the Ctrl key 

while you click to define the to point.
Relationships between elements within the selection set are maintained if the relationships still apply after 

the elements have been rotated.
You can use other view manipulation commands, such as Zoom and Pan, while you are using the Rotate 

command.
When you finish manipulating the view, the software returns you to the Rotate command at the point where 
you left off. 

{button Related Topics,AL("rotating elements high;rotate cmd;rotate how;rotate rb",0,`NOT_FOUND')}



Save a Document
If you save a document that has not previously been saved, the software automatically prompts you to indicate if 
you want to save the changes.

To save the active document
1 Click File > Save.
2 If you have made changes since the document was last saved or if you have never saved the active document, 

you are prompted to indicate if you want to save your changes. Do one of the following:
If you do not want to save your changes, click the No button. 
If you want to save the changes, click the Yes button. If you click the Yes button, the Save As dialog box is 

displayed so that you can give the document a name and specify a directory and format to save it to.
If you do not want to close the document, click the Cancel button.

To save a document in a different format
1 Click File > Save As.
2 Select the drive and directory for the new document.
3 In the File Name box, type a new name for the document.
4 In the Save As Type box, select the document format you want to use.

To save a document that was created in a different format
1 Click File > Save As.
2 Select the drive and directory for the new document.
3 In the File Name box, type a new name for the document.
4 In the Save As Type box, select the document format you want to use.

Tips
If the active document is read-only, you can save changes only by saving the document with a new name.
You can save a document to .cgm or .HTML format if you want to make the document available for viewing 

on the Internet. You can use the Save As Web Page command on the File menu.
You can also save a document as a template with the Save As Template command on the File menu. 

{button Related Topics,AL("save cmds;document high;save high",0,`NOT_FOUND')}



Scale an Element
1 Select one or more elements.
2 On the Change toolbar, click the Scale button.
 

3 If you want to copy the scaled elements, click the Copy button on the ribbon bar.
4 Click where you want the scale origin to be. The software displays a crosshair at the scale origin, and 

dynamically displays a line between the scale origin and the pointer.

5 Move the pointer until the elements are the size you want and then click.

Tips
Relationships within the selection set are maintained if the relationships are still applicable after the 

elements have been scaled.
You can click the Scale command before you select elements to scale.
Instead of clicking to define the new scale, you can use the Scale Factor box on the ribbon bar.
Instead of using the Copy button on the ribbon bar to scale and copy, you can hold the Ctrl key while you 

click to define the new scale.
You can use relationship indicators with this command.
You can use the Step box on the ribbon bar to make the Scale Factor increase or decrease incrementally 

as you move the mouse. 
You can use the Reference box on the ribbon bar to change how the command dynamics correspond to the 

Scale Factor.
To change the overall size of the graphics with respect to the paper size, use Sheet Setup on the File 

menu.

{button Related Topics,AL("scaling elements high;scale cmd;scale how;scale rb",0,`NOT_FOUND')}



Fit a Sketch Drawn in Real-World Units on the Drawing Sheet
1 Click File > Sheet Setup.
2 On the Size and Scale tab of the Sheet Setup dialog box, select the sheet size that you want. After you close the

dialog box, the correct sheet size is displayed.
3 Draw the elements that you want using real-world units. Do not worry if the elements do not fit on the sheet.
4 On the File menu, click Sheet Setup to check the ratio of the sheet size to the overall drawing size.
5 On the Sheet Setup dialog box, on the Size and Scale tab, click the Custom radio button. You should use the 

ratio of the drawing to the drawing sheet to determine the custom scale for the drawing sheet. After you close the
dialog box, the drawing scales to the scale that you selected. All dimensions appear in real-world units. 
Caution    If you insert an .igr or .sym document into the drawing sheet, the terminators, spaces, text, and 
styles appear in paper units relative to the source document. The dimension lines and extension lines scale 
as though they are in real-world units. This behavior can cause the dimensions and text to appear very large 
or small in the container document.

Tips
If you use the Scale button on the Change toolbar to scale the drawing, the dimensions are scaled to 

compensate for the change in size. The Scale button changes the size of one set of geometry to another set of 
geometry in the document. To change the overall size of the graphics with respect to the paper size, use Sheet 
Setup on the File menu.

{button Related Topics,AL("sheet setup cmd;sheets high;paper high",0,`NOT_FOUND')}



Scale an Inserted Object Back to Its Original Model Size
When you insert an AutoCAD or MicroStation document into a drawing sheet with the Object command on the 
Insert menu, the object is automatically scaled to fit the print area of the drawing sheet. The print area size 
changes depending on the selected working sheet. In some cases, you might want to work in model space and 
not paper space. 
1 Click Insert > Object to insert an AutoCAD or MicroStation object.
2 Highlight the inserted object with the Select tool.
3 On the shortcut menu, click Properties.
4 On the Properties dialog box, on the Info tab, click the Scale (1:1) radio button. After you close the dialog box, 

the inserted object changes back to the original model size.

Tips
If an inserted object was scaled before bringing it into the drawing sheet, you might need to adjust the scale 

on the Properties dialog box to get the results you want.
After inserting an AutoCAD or MicroStation document, if you have not performed any other actions, you can 

click Undo on the Edit menu to change the object back to the original model size.

{button Related Topics,AL("object cmd;properties cmd",0,`NOT_FOUND')}



Scale an Element with Its Handles
You can use handles to scale framed elements such as text boxes, symbols, and linked or embedded objects.
1 Select an element.
2 Position the pointer over one of its handles.
3 Drag the handle to scale the element or object.

Tips
You can also click the Scale button on the Change toolbar to scale the drawing; the dimensions are scaled 

to compensate for the change in size. The Scale button changes the size of one set of geometry to another set of 
geometry in the document. To change the overall size of the graphics with respect to the paper size, use Sheet 
Setup on the File menu.

Relationships within the selection set are maintained if the relationships are still applicable after the 
elements have been scaled.

{button Related Topics,AL("scaling elements high;scale cmd;scale how;scale rb",0,`NOT_FOUND')}



Open an OLE Object for Editing
1 Select an OLE object.
2 Do one of the following:

If the object is linked, click the right mouse button to display the shortcut menu and click Open to open the 
application the object was created in.

If the object is embedded, double-click the object to edit it.

{button Related Topics,AL("object element selection high;ole high;select cmd",0,`NOT_FOUND')}



Copy an Element with the Select Tool
1 On the Draw toolbar, click the Select Tool button.
 

2 Select one or more elements.
3 Position the pointer over the element, but not over any of the element's handles. The pointer changes to show 

that the element can now be copied.
4 Hold the Ctrl key and drag the copy to its new location.

{button Related Topics,AL("object element selection high;select cmd;copy cmd;copy high",0,`NOT_FOUND')}



Select an Element
1 On the Main toolbar, click the Select Tool button.
2 Do one of the following:

To select one element, click it.
To select more than one element hold the Shift or Ctrl key and click each element.
To select more than one element at once, drag to fence the objects.
To select one of several overlapping elements, use PickQuick.

Tip    You can also click the right mouse button and click the Select All command.

To select an element with PickQuick

PickQuick helps you to select elements that overlap each other.
1 Position the pointer over the element you want to select and pause the pointer there.
2 When the cursor changes to an ellipsis (three dots), click. The software displays the PickQuick toolbar near the 

cursor, with a button for each selectable element.

3 Move the cursor over the PickQuick buttons, without clicking, to highlight the corresponding elements.

4 When the element you want to select is highlighted, click the corresponding button on the PickQuick toolbar.

To clear a selection
Do one of the following:
Click in free space.
Click the right mouse button in free space.
Select another element without holding the Shift or Ctrl key.
To clear the selection of one element and leave other elements selected, click the element while holding the 

Shift key.

Tips
When the Select Tool is active, selectable elements highlight as you pass the pointer over them. When the 

element you want to select is highlighted, click to select it.
You can use the ribbon bar buttons to set element selection options.
You can change the element highlight and selection colors with the Options command on the Tools menu. 



{button Related Topics,AL("object element selection high;select cmd",0,`NOT_FOUND')}



Modify an Element with the Select Tool
1 On the Draw toolbar, click the Select Tool button.
2 Select an element.
3 Position the pointer over one of the element's handles. The pointer changes to show that the element can now 

be modified.
4 Drag the element handle to reposition it.    You can use relationships to position the handle precisely.

Tips
To retain the angle or aspect ratio of the element you are modifying, hold the Shift key while you drag the 

element's handle.
To suspend the effect of relationship handles so that you can modify the element more freely, hold the Alt 

key while you drag the handle.    The software maintains relationships as appropriate for the modified element.

{button Related Topics,AL("object element selection high;select cmd;modify cmd;smartsketch 
cmd",0,`NOT_FOUND')}



Move an Element with the Select Tool
1 On the Main toolbar, click the Select Tool button.
2 Position the pointer over the element, but not over any of the element's handles.
3 Drag the element to its new position.

To move an element with precision
1 On the Main toolbar, click the Select Tool button.
2 Position the pointer over the element you want to move, at a location where the software recognizes a key point.
3 Begin to drag the element.
4 Release the element when the software recognizes the key point of another element, or a relationship between 

the element you are moving and another element.

Tips
If you want to move a selected element, make sure to position the pointer away from any of the element's 

handles.    Dragging a handle modifies the element instead of moving it.

{button Related Topics,AL("object element selection high;move cmd;select cmd;smartsketch 
cmd",0,`NOT_FOUND')}



Send a Document to Others
1 Open the document you want to send.
2 Click File > Send.
3 Select the recipients using your electronic mail application's dialog box.
4 Type the subject and the accompanying message.
5 Send the message with the document attached.

{button Related Topics,AL("send cmd;documents high;documents routing;save high",0,`NOT_FOUND')}



Set an Option on a Dialog Box
To select a dialog box tab

In the dialog box, click the tab that contains the options you want.

To set an option
Enter the information you want the command to use and press Enter.

To select or clear an option

Do one of the following:
Click the option button, check box, or list item.
Click the down arrow to display a list, and then click the item you want.

{button Related Topics,AL("ui high",0,`NOT_FOUND')}



Display Background Sheets
Click View > Background Sheets.

{button Related Topics,AL("drawing sheets high;background sheets cmd;sheet setup cmd ",0,`NOT_FOUND')}



Create a Background Sheet
1 Click View > Background Sheets.
2 Click Insert > New Sheet.    The background sheet is created using the default drawing sheet settings.
3 Click File > Sheet Setup.
4 On the Sheet Setup dialog box, set the options you want.
5 On the new background sheet, draw any graphics, such as title blocks and borders, that you want to appear on 

your working sheets.
6 Click View > Working Sheets. 
7 Click File > Sheet Setup.
8 On the Sheet Setup dialog box, click the Background tab.
9 Click the Background Sheet list box and select the name of the background sheet you just created to attach the

new background sheet to the working sheet.

Tips
You can double-click any tab to access the Sheet Setup dialog box. You can also access the Sheet Setup 

dialog box by moving the pointer over a drawing sheet tab, clicking the right mouse button to activate the shortcut 
menu, and clicking the Sheet Setup command.

{button Related Topics,AL("drawing sheets high;background sheets cmd ;new sheet cmd;working sheet 
cmd",0,`NOT_FOUND')}



Delete a Drawing Sheet
1 Click Edit > Delete Sheet.
2 Confirm the selection.

Tips
The Delete Sheet command deletes the active drawing sheet and any drawing sheets whose drawing sheet

tabs are selected.

{button Related Topics,AL("drawing sheets high;delete sheet cmd ",0,`NOT_FOUND')}



Create a New Drawing Sheet
Click Insert > New Sheet.    The new sheet is inserted after the active drawing sheet.

Tips
You can attach a background sheet to any drawing sheet using the Sheet Setup command on the File 

menu.    Click the Background tab on the Sheet Setup dialog box to find the background sheet settings.

{button Related Topics,AL("drawing sheets high;new sheet cmd ",0,`NOT_FOUND')}



Change the Background Sheet
1 Click File > Sheet Setup.
2 On the Sheet Setup dialog box, click the Background tab.
3 Select a new background sheet from the list.

Note    If a background sheet has not been created, the list does not display any options.

Tips
When you change the background sheet, the size and margins of your working sheet equal the settings of 

the selected background sheet.
You can double-click any tab to access the Sheet Setup dialog box. You can also access the Sheet Setup 

dialog box by moving the pointer over a drawing sheet tab, clicking the right mouse button to activate the shortcut 
menu, and clicking the Sheet Setup command.

{button Related Topics,AL("drawing sheets high;sheet setup cmd ",0,`NOT_FOUND')}



Activate a Drawing Sheet
Click the tab of the drawing sheet you want to activate.

Tips
You can display a shortcut menu available by clicking the right mouse button while the cursor is over a 

drawing sheet tab.
You can double-click any tab to access the Sheet Setup dialog box. You can also access the Sheet Setup 

dialog box by moving the pointer over a drawing sheet tab, clicking the right mouse button to activate the shortcut 
menu, and clicking the Sheet Setup command.

{button Related Topics,AL("drawing sheets high",0,`NOT_FOUND')}



Set Up a Drawing Sheet
1 Click File > Sheet Setup.
2 On the Sheet Setup dialog box, set the options you want.

Note    If you want to set up a background sheet, click the Background tab and set the options you want.

Tips
You can save the sheet setup as a default using the Save Defaults button on the Sheet Setup dialog box.    

The current settings will then be used as the default settings for any new drawing sheets you create in the document.
You can set up options for an existing drawing sheet by double-clicking any tab to access the Sheet Setup 

dialog box. You can also access the Sheet Setup dialog box by moving the pointer over a drawing sheet tab, clicking 
the right mouse button to activate the shortcut menu, and clicking the Sheet Setup command.

{button Related Topics,AL("drawing sheets high;drawing sheet tabs high;sheet setup cmd",0,`NOT_FOUND')}



Rename a Drawing Sheet
1 On the drawing sheet, click the tab of the sheet you want to rename.
2 Click File > Sheet Setup. 
3 On the Sheet Setup dialog box, click the Name tab and type a new name for the sheet you selected. 

Tips
You can also rename a drawing sheet with the Rename command on the shortcut menu.    You can get the 

shortcut menu by moving the pointer over a drawing sheet tab and clicking the right mouse button.

{button Related Topics,AL("sheet setup db;rename sheets cmd;sheet setup cmd",0,`NOT_FOUND')}



Select and Manipulate Drawing Sheets
To display or manipulate a drawing sheet, you must click a drawing sheet tab. Drawing sheet tabs are displayed 
at the bottom of the work space. There is a tab for each drawing sheet in your document. 

To select a drawing sheet
Click a drawing sheet tab at the bottom of the drawing sheet. The drawing sheet is displayed and the name 

of the drawing sheet appears in bold.    This drawing sheet becomes the working sheet.

To select several drawing sheets
Press and hold Ctrl and click one or more tabs.

Note To de-select several drawing sheets, press and hold Ctrl and click one or more current drawing sheet 
tabs. 

To select a range of drawing sheets
Click the first tab in the range, hold Shift, and then click the last tab in the range.

Note To de-select all of the drawing sheets in a range, click any tab that is not part of the range.

To select all drawing sheets at once
On the shortcut menu, click Select All Sheets.

Note    To access this command, you must hold the pointer over one of the drawing sheet tabs and click the 
right mouse button. 

Tips
When you select several sheets and then click the Selected Sheets option on the Print dialog box, all the 

selected sheets are printed as one composite drawing, like layers on top of one another. The software uses the scale,
paper size, and orientation of the active sheet for printing the final document.

 

{button Related Topics,AL("drawing sheets high;documents high;sheet setup db;scroll tabs 
how",0,`NOT_FOUND')}



Scroll Through Drawing Sheet Tabs
On the current drawing sheet, click a scroll button next to the drawing sheet tabs. Clicking a scroll button 

displays the drawing sheet tabs so that you can access them easily and select a drawing sheet. Click the scroll 
buttons of the following picture to find out what each button does:

Note    Clicking a scroll button does not display a different drawing sheet. If the document has only a few 
drawing sheets, the scroll buttons might not be available.

{button Related Topics,AL("drawing sheets high;documents high;sheet setup db;display sheets 
how",0,`NOT_FOUND')}



Scrolls to the first tab.



Scrolls to the previous tab. You can also scroll through several tabs by holding Shift and clicking this button.



Scrolls to the next tab. You can also scroll through several tabs by holding Shift and clicking this button.



Scrolls to the last tab.





Draw with Relationships
1 Set the SmartSketch options so that the software recognizes the relationships you want to use. You can set the 

options with the SmartSketch Settings command on the Tools menu.
2 On the Draw toolbar, click a drawing command button.
3 Move the pointer around on the drawing sheet to find relationships.
4 Click when the software recognizes a relationship you want to use for the element you are drawing. When you 

click with a relationship indicator displayed at the pointer, the relationship is established in the drawing.

Tips
If the Maintain Relationships option is set, the software places relationship handles as you draw. These 

relationships are maintained when you modify the drawing.

{button Related Topics,AL("smartsketch high;smartsketch cmd;relationships high;maintain relationships 
cmd",0,`NOT_FOUND')} {button Show Me,AL("draw a line ex;draw an arc ex;smartsketch 
ex",0,`NOT_FOUND')}



Establish a Relationship with the SmartSketch Command 
1 Click Tools > Maintain Relationships.
2 Draw as usual. The software automatically establishes recognized relationships. For each relationship, a 

relationship handle is placed on the related elements.

Tips
Relationships cannot be established in certain cases. 

{button Related Topics,AL("smartsketch high;smartsketch cmd;relationships high;maintain relationships cmd 
",0,`NOT_FOUND')} {button Show Me,AL("connect points while placing line ex;connect points while 
modifying line ex;establish multiple relationships ex;case where relationship not maintained ex 
",0,`NOT_FOUND')}



Suspend Relationships
1 Hold the Alt key on the keyboard. The software does not recognize any relationships while you hold this key.
2 Release the Alt key to re-activate the software's ability to recognize relationships.

{button Related Topics,AL("smartsketch high;smartsketch cmd",0,`NOT_FOUND')}



Apply a Style
1 Select the element you want to format.
2 Click Format > Style.
3 On the Style dialog box, in the Styles list, click the style you want to apply.
4 Click the Apply button.

Tips
If you have formatted an element with the Properties command or by setting options on the active ribbon 

bar, these formats are removed when you apply a style.

{button Related Topics,AL("style cmd;styles high;styles db;reapply style db",0,`NOT_FOUND')}



Rename a Style
1 Click Format > Style.
2 On the Style dialog box, in the Style Types field, click the style type you want.
3 In the Style box, click the style you want to rename.
4 Click the Modify button.
5 In the Name box, type the new name for the style.

{button Related Topics,AL("styles db;styles high",0,`NOT_FOUND')}



Apply a Style to a Group of Elements
1 Select two or more elements.
2 Click Format > Style.
3 On the Style dialog box, in the Style Type box, click the style type that you want.

Note If you have selected several elements from different style types, the Style Type box is blank.
4 In the Style box, click the style that you want to apply to the elements.
5 Click Apply to change all the elements that you selected.

Tips    
If you select different types of elements, you can apply a style only to the elements that are in the style type 

that you selected on the Style dialog box.    
For example, if you select several lines and dimensions on a drawing, you can apply a line style only to the 
lines.    You cannot apply a line style to the dimensions. 

{button Related Topics,AL("style cmd;style db;styles high",0,`NOT_FOUND')}



Delete a Style
1 Click Format > Style.
2 On the Style dialog box, in the Style Types field, click the style type you want.
3 In the Style box, click the style you want to delete.
4 Click the Delete button. 
5 Confirm that you want to delete the style.

{button Related Topics,AL("styles db;styles high",0,`NOT_FOUND')}



Create a Style Using a Formatted Element
1 Select an element.
2 Apply the formats you want to save as a style by setting the options you want on the ribbon bar.
3 On the ribbon bar, click the Style box to select the current style name of the element.
4 Type a new name to create a style using the formats applied to the element.
5 Press the Enter key.

Note If you create a new style using the Style box on the ribbon bar, you cannot base the new style on any 
other style.

{button Related Topics,AL("styles high;reapply style db",0,`NOT_FOUND')}



Create a Style with the Style Command
1 Click Format > Style.
2 On the Style dialog box, in the Style Types field, click the style type you want.
3 Click the New button to open a dialog box based upon the style type you clicked.
4 On the Name tab, in the Name box, type a name for the new style.
5 To base the style on an existing style, click a style from the list in the Based On field.
6 Click the other tabs on the dialog box and set the options you want to apply to the new style.

{button Related Topics,AL("style cmd;styles high;new dimension style db;new line style db;new fill style db;new 
text style db;new view style db",0,`NOT_FOUND')}



Save a Style to a Template
1 Open a document template. 
2 Click Format > Style. 
3 On the Style dialog box, select the style you want to save to the template of the active document.
4 Click the New or Modify button.
5 On the dialog box that appears, on the Name tab, click the Save To Template check box.

{button Related Topics,AL("style cmd;styles cmd;styles high",0,`NOT_FOUND')}



Change the Formats of a Style
1 Click Format > Style.
2 On the Style dialog box, in the Style Types field, click the style type you want.
3 In the Style box, click the style you want to change.
4 Click the Modify button to open a dialog box based upon the style type you clicked. 
5 To base the style on an existing style, click a style from the list in the Based On field.
6 Click the other tabs on the dialog box and set the options you want to modify. 

After you close the dialog box, the software updates all elements formatted with the modified style throughout 
the document.

Tips
If an element has a style, you can override the style by editing the element's properties with the Properties 

command on the Edit menu.
You can remove style overrides by re-applying a style.
You can modify one or more styles with the Style command on the Format menu.

{button Related Topics,AL("style cmd;styles high;modify dimension style db;modify line style db;modify text style 
db;modify fill style db;modify view style db;reapply style style db",0,`NOT_FOUND')}



Create a Template
1 Click File > New.
2 On the File New dialog box, click the Template option.
3 Click OK to open the template.
4 Complete any changes to the template.
5 Click File > Save As.
6 In the Save In box, specify the directory in which to save the new template.
7 In the File Name box, type a unique name for the new template. The template will be saved in the TEMPLATE 

directory located in the directory where you installed the software.
Note    You can use the extension .igr. A different one is not needed.

Tips
You can change the default directory where templates are saved by selecting the Options command on the 

Tools menu and setting the directory that you want on the File Locations tab of the Options dialog box.

{button Related Topics,AL("templates cmd;templates high;style resource how",0,`NOT_FOUND')}



Add Styles to the Current Document
You can reference a style resource document from any template or document.
1 Click File > Open and open the document that you want to add a style resource document to.
2 Click Format > Style.
3 On the Style dialog box, click the Resources button.
4 On the Style Resources dialog box, click the Add button.
5 On the Add Style Resources dialog box, select the name of the style resources document that you want to add 

to the template.
6 Click OK on each dialog box.
7 When you close the document, click OK when you are prompted to indicate whether you want to save changes 

to document. 
The styles in the style resource document are referenced from the template or document that you just saved. 
If you open a document that references a style resource document, the styles in the style resource document 
will be available on the Styles list of the current document's ribbon bar. If you open a document that is based 
on a template with references to style resource documents, the styles will also be available in the same 
manner. You can then apply the styles in the style resource document to elements or annotations in the 
current document.
Note    The line styles are copied from the style resource document into the current document. The font styles 
are not copied. So, if you want another person to be able to view the same fonts in the document and that 
person's system does not have the same fonts installed, you should give that person a copy of the template 
along with the document. 

Tips
Sometimes you might attach several style resource documents that contain styles with duplicate names. In 

these cases, the style in the style resource document that is listed first in the Style Resources list takes precedence 
and will be listed on the ribbon bar of the active document.                                                

{button Related Topics,AL("styles high;style cmd;style resource db;add style resource db",0,`NOT_FOUND')}



Place a Text Box
1 On the Draw toolbar, click the Text Box button.

2 To place a text box, drag to define the location and size of the text box. To see the text box, begin typing text. 
When you place text by this method, the width measures exactly between the two points. Text is wrapped, if 
necessary.
The height measures at least the height between the two points. If necessary, the height of the text box 
increases to fit all of the text.

Tips
To place a text box, you can also click a point, and begin typing text.

When you place text by this method, the height and width are set to Auto mode. The size of the text 
increases automatically to contain all of the text. The text does not wrap.

You can also place a text box by double-clicking any element. A blinking pointer appears below or in the 
center of the element.

You can press Enter to create a new line in a text box.
When you are in edit mode, a border appears around the text box.
To place a callout, you can add a leader to the text box with the Leader command on the Dimension 

toolbar.

{button Related Topics,AL("text box cmd;text rb;annotations high;texthand high",0,`NOT_FOUND')}



Delete Text in a Text Box
1 Select the text that you want to delete in the text box.
2 Press the Delete key.

{button Related Topics,AL("text box cmd;text rb;annotations high",0,`NOT_FOUND')}



Move a Text Box
Drag the text box to the location that you want.

Tips
If handles of the text box are displayed, drag the highlighted border of the text box (or anywhere inside of the

text box) to move it—dragging one of the solid square handles resizes it.

{button Related Topics,AL("text box cmd;text rb;annotations high;texthand high",0,`NOT_FOUND')}



Resize a Text Box
1 Click a text box to display its handles.
2 Drag a handle until the text box is the size you want.

Tip    You cannot drag hollow handles.

{button Related Topics,AL("text box cmd;text rb;annotations high;texthand high",0,`NOT_FOUND')}



Apply a Border to a Text Box
1 Select the text box to which you want to apply a border.
2 On the shortcut menu, click Properties.
3 On the Border and Fill tab of the Text Box Properties dialog box, set the options for the type of border that you 

want.

Tips
You can also apply a border by selecting a text box and clicking the Border button on the ribbon bar.
To see a text box border that is greater than 2 mm, set Display As Printed on the View tab of the Options 

dialog box.

{button Related Topics,AL("text box cmd;text rb;text properties db;annotations high",0,`NOT_FOUND')}



Edit a Text Box
1 Select the text box that you want to edit.
2 Double-click the box.
3 Point to the location to edit the text and type the text that you want.

{button Related Topics,AL("text box cmd;text rb;annotations high",0,`NOT_FOUND')}



Trim an Element
1 On the Draw toolbar, click the Trim button.

2 Do one of the following:
To trim one element at a time, click each element you want to trim.

{mci_left NOMENU,TRIM1C.AVI} 
To trim more than one element at the same time, drag the pointer over the elements.    When you release the

mouse button, all the elements are trimmed.

Tips
Before you click an element to trim, you can use PickQuick to see which portion of the element will be 

trimmed.    When you move the pointer over the elements, PickQuick highlights the portion of the element that will be
trimmed if you click.

If you trim an element that does not intersect any other elements, the command trims the entire element, 
effectively deleting the element.

{button Related Topics,AL("trim cmd;extending or trimming high",0,`NOT_FOUND')}



Start the Tutorials
Click Help > Learning Center.

{button Related Topics,AL("help high;tutorials cmd",0,`NOT_FOUND')}

 



Undo Actions
Do one of the following:

To undo the most recent action, on the Main toolbar, click the Undo button.

To undo more than one action, click the down arrow next to the Undo button on the Main toolbar, and select 
the actions you want to undo.

Note  You can do this action only if you have placed the Undo List button on the Main toolbar. You can place 
the button by clicking the Customize command on the Tools menu.

Tips
You cannot restore broken links with the Undo command.

{button Related Topics,AL("edit high;undo cmd;draw high",0,`NOT_FOUND')}



Restore a View
Click View > Previous. 

Tips
You can also press Alt and click the Microsoft IntelliMouse wheel to restore the view.
To stop the repainting of elements in the window, press ESC. This is convenient if you are working with a 

large document. To refresh the window, press <F5>.

{button Related Topics,AL("views high;previous view cmd",0,`NOT_FOUND')}



Zoom Out 
1 On the Main toolbar, click Zoom Out.
 

2 Click the view.

Tips
You can drag to dynamically zoom out of the view.
When you roll the Microsoft IntelliMouse wheel backward, the view zooms out at the current pointer location.
To go back to the previous view, click Previous on the View menu.
To stop the repainting of elements in the window, press ESC. This is convenient if you are working with a 

large document. To refresh the window, press <F5>.
To exit the command, click the right mouse button or press ESC.

{button Related Topics,AL("views high;zoom out cmd;zoom in on area how;zoom in views how;area 
cmd",0,`NOT_FOUND')}



Pan a View
1 On the Main toolbar, click Pan.

2 Click in the view you want to pan.
3 Click in the view again to show how far you want to pan.

Tips
You can also drag the pointer to pan the view.
When you drag the Microsoft IntelliMouse wheel, the view pans. When you press and drag the mouse wheel

and move the pointer from one location to another, the view pans from one location to another.
To go back to the previous view, click Previous on the View menu.
To stop the repainting of elements in the window, press ESC. This is convenient if you are working with a 

large document. To refresh the window, press <F5>.
To exit the command, click the right mouse button or press ESC.

{button Related Topics,AL("views high;pan cmd",0,`NOT_FOUND')}



Zoom Area
1 On the Main toolbar, click Zoom Area.
 

2 On the drawing sheet, drag around the area that you want to zoom in on. The view zooms in on the area you 
fenced with the pointer.

Tips
When you roll the Microsoft IntelliMouse wheel forward, the view zooms in at the current pointer location. 

You can also press Ctrl and drag the mouse wheel to zoom an area or window.
To go back to the previous view, click Previous on the View menu.
To stop the repainting of elements in the window, press ESC. This is convenient if you are working with a 

large document. To refresh the window, press <F5>.
To exit the command, click the right mouse button or press ESC.

{button Related Topics,AL("views high;area cmd;zoom out cmd;zoom in views how;zoom out views 
how",0,`NOT_FOUND')}



Zoom In 
1 On the Main toolbar, click Zoom In.
 

2 Click the view.

Tips
You can drag to dynamically zoom in the view.
When you roll the Microsoft IntelliMouse wheel forward, the view zooms in at the current pointer location.
To go back to the previous view, click Previous on the View menu.
To stop the repainting of elements in the window, press ESC. This is convenient if you are working with a 

large document. To refresh the window, press <F5>.
To exit the command, click the right mouse button or press ESC.

{button Related Topics,AL("views high;zoom out cmd;zoom in on area how;zoom out views how;area 
cmd",0,`NOT_FOUND')}



Switch to Another Open Document
Do one of the following:

If you can see a portion of the document that you want to switch to, click its window.
On the Window menu, click the document you want to work in. The document is displayed on top of other 

open documents.

{button Related Topics,AL("window cmd",0,`NOT_FOUND')}



Mechanism Modeling
{button Related Topics,AL("symbols high",0,`NOT_FOUND')} {button How To,AL("symbols 
how",0,`NOT_FOUND')} {button Show Me,AL("animate ex",0,`NOT_FOUND')}

You can use mechanism modeling to check for clearances on moving parts. Mechanism modeling is a set of 
elements that are related to each other so that one group of geometry moves relative to another when the 
dimensions change. You can use any kind of elements for mechanism modeling, but symbols are the easiest 
elements to use.

Symbols are easy to use because they act as one piece of geometry when you want to reposition them. For 
example, if you draw four lines that form a rectangle, you might want to connect the lines so that the rectangle 
has predictable behavior when rotated by a dimensional change. To do this, you must connect every line. The 
length of each line, the connections of the end points, and the angle between each line and its adjacent line must
be defined as shown in the picture.
{mci_left NOMENU,ANIMAT1.AVI} 

If the same four lines were constructed and made into a symbol, the orientation and length of each line would 
always remain constant regardless of the orientation of the symbol. No relationships or dimensions for the 
geometry making up the symbol would be necessary as shown in the picture. If you change the angle from 90 
degrees to 45 degrees, the geometry stays together with the symbol as a rigid body.
{mci_left NOMENU,ANIMAT2.AVI}

The easiest way to create a mechanism is to use rigid body symbols and constrain the symbols to move like you 
want. Symbols can have two behaviors: rotating and non-rotating. The default behavior, non-rotating, means that
the symbol cannot be rotated. The other behavior, rotating, allows rotation by relationships. This allows the 
symbol to rotate.

Example

The field pump mechanism serves as a good example of a kinematics animation. The mechanism is made up of 
five symbols and only one dimension to control the mechanism movement. If you select the dimension and 
change the value of the dimension from 12 degree to 60 degrees, all the geometry moves together. The other 
symbols that are connected to each other move to their proper position based on the angle applied and 
relationships to the symbols and the behavior applied to each symbol. 

{mci_left NOMENU,ANIMAT11.AVI}



Adding Text to Documents 
{button Related Topics,AL("engineering fonts high;vector fonts high;labels high;annotations high 
",0,`NOT_FOUND')} {button How To,AL("create text box how;balloon how;leader how;labels 
how",0,`NOT_FOUND')}

You can add text to documents using two different types of tools:
Annotations, such as text boxes and balloons. 
Labels, such as text labels and Smart Labels.

Click the Related Topics button for more information about each of these tools.



Attributes
{button Related Topics,AL("formatting elements high;symbols high",0,`NOT_FOUND')} {button How 
To,AL("attribute how;edit symbols how",0,`NOT_FOUND')}

Attributes can help you work more efficiently by allowing you to enter and edit values for a symbol, object, or 
element. Attributes can include such items as the manufacturer, price, and other data. Attributes include user-
defined properties and parameters. 

A user-defined property is an attribute assigned to an element or object that defines a characteristic about that 
element or object. A property is usually in the form of a text notation, such as cost, weight, color, and so forth. 
You can change user-defined properties, but these changes have no affect on the appearance of the element or 
object.

A parameter is a mechanism to change a property. A parameter is an attribute assigned to an element or object, 
usually a numerical value representing a dimension. Parameters are usually used in symbols to resize the length
or width of a symbol.

The Attribute Viewer displays the user-defined properties and parameters for a selected item. The viewer also 
allows you to edit the values of the properties or parameters. 

 

 
Tip    User-defined properties also appear on the User tab of the Properties dialog box. Parameters appear only 
in the Attribute Viewer.

You cannot edit the names of attributes; you can edit only their values. The viewer displays two columns, one for 
the name of the attribute and one for the value. User-defined properties appear in plain text. Parameters appear 
in bold text.

When editing attributes, you can only work on one element or object at a time. When more than one item in the 
document is selected, no attributes are displayed in the Attribute Viewer.



Saving a Document Automatically
{button Related Topics,AL("autosave cmd;autosave db;add-ins overview high;save cmd",0,`NOT_FOUND')}

{button How To,AL("autosave how",0,`NOT_FOUND')}

You can set option to automatically save open documents at the interval that you specify. This safety feature 
prevents you from losing work in case of an unexpected system shutdown. You can set several options for 
AutoSave, including how often to save, which documents to save, and whether to be prompted for each save. 
You can use AutoSave when you have one or more documents open. 
Caution  If the AutoSave option does not appear on the Tools menu, you must install it by clicking Add-Ins on 
the Tools menu.



Bearing and Azimuth
{button Related Topics,AL("bearing azimuth cmd",0,`NOT_FOUND')} {button How To,AL("set bearing azimuth 
how",0,`NOT_FOUND')}

You may want to orient your drawing in an environment with a specific bearing and azimuth. This tool may be 
useful for applications such as civil engineering. 

Tip    The Bearing and Azimuth command is available only if you use the Customize command on the Tools 
menu to place it on a toolbar or menu. On the Toolbars tab of the Customize dialog box, click the Tools 
category to access the command.



The Symbol Explorer
{button Related Topics,AL("Symbol Explorer cmd;symbols high;av high;symbol explorer db",0,`NOT_FOUND')}

{button How To,AL("Symbol Explorer how;attributes how",0,`NOT_FOUND')}

You can use the Symbol Explorer to drag symbols from a directory to the current document. You can also use 
the Symbol Explorer to view document directories on your computer or a network drive. The Symbol Explorer 
can also display HTML pages on the World Wide Web or your computer. 

When you click the Symbol Explorer button on the Main toolbar, the Symbol Explorer is displayed on the right 
side of the main window. The buttons on the Symbol Explorer are similar to the ones in the Windows Explorer. 
For example, you can click a Favorites button to go to one of your favorite web sites.

 

If you set the path of the Symbol Explorer to point to a directory, you see a tree view, the contents of the 
directory, and the Attribute Viewer. If you set the path to an HTML page, you see the contents of that page, if 
Microsoft Internet Explorer 3.0 or later is installed. If Internet Explorer is not installed, then the software 
prompts you to install it.

Placing Symbols

The main use of the Symbol Explorer is to drag symbols from a directory to the current document. The Symbol 
Explorer acts much like the Windows Explorer. To view symbols, you can type the name of the directory in the 
Address Box at the top of the Symbol Explorer; or you can click the Explore Elsewhere button and set the 
directory path that the Symbol Explorer looks in. 

If you click the Home button at the top of the Symbol Explorer, it displays the home page for the symbols that 
are associated with the template on which the active document is based. You can override this property by 
setting a new address with the Properties command on the File menu. On the Properties dialog box, you click 
the Browser tab to set the option.

After the Symbol Explorer displays the symbols, you can drag a symbol from the Symbol Explorer to the 
current document.

Displaying HTML Pages

The Symbol Explorer can display HTML pages on the World Wide Web or your computer. To view an HTML 
page in the Symbol Explorer, you must enter the entire directory path and filename in the Address Box at the 
top of the Symbol Explorer.

To view HTML pages on the World Wide Web, you must type the HTTP address in the Address Box at the top of
the Symbol Explorer. When you do this, the Symbol Explorer displays the HTML page of the address you 
entered. The Symbol Explorer can display any web site that you have permissions to access.
Caution    HTML pages appear only if Microsoft Internet Explorer 3.0 or later is installed.

Searching Document Directories

You can view the Symbols of any directory on your computer or the network with the Symbol Explorer. You can 
type the path of the directory in the Address Box; or you can click the Browse button and set the directory path 
on the dialog box. 

After the Symbol Explorer displays the symbols of the directory that you want, you can double-click any 
document, much like the Windows Explorer, and the software that created the document opens and displays the 
document for editing.

You can drag any document created by software that supports OLE 2.0 into the current document. These 
documents can include .igr, .dgn, .dwg, and .dxf types.

Symbol Explorer Settings

When you set options for the Symbol Explorer, the current document stores and uses these the next time you 
open the document. You can define a different home page for each document in the Symbol Explorer with the 
Properties command on the File menu. 

On the Properties dialog box, you click the Browser tab to set the option. When you set the address for the 
home page on the Properties dialog box, the Symbol Explorer goes to that address when you click the Home 
button at the top of the Symbol Explorer.



Tip    The address can be a directory on a local or network drive or an HTTP address to a web page.



Connecting Elements
{button Related Topics,AL("connector command;connector rb",0,`NOT_FOUND')} {button How 
To,AL("place connector how;modify connector how",0,`NOT_FOUND')}

You can use a connector to join two elements together. The Connector button on the Schematic toolbar or 
Draw toolbar provides a convenient way to draw schematic diagrams and other types of drawings. 

 

The Connector button allows you to place connectors anywhere you need. You can connect lines, circles, 
symbols, or points in free space. 
{mci_left NOMENU,CONNPTSYM1.AVI} 

When you point to an element or symbol, the connect points appear as red circles with Xs. The keypoints appear
as gray circles with Xs.

You can also modify the connector after you place it by inserting or moving a line segment, inserting or moving a 
vertex, or moving an element with a connector.

There are special connector styles that you can use in the diagram. On the Connector ribbon bar, you can click 
the style that you want in the Style box. You can then draw a connector that displays the line style that you 
selected. For example, in documents based on the Process Block Diagram template, you can select Future and 
Phantom in the Line Style box on the ribbon bar. When you select Future and draw a connector, the connector 
appears as a dashed line.

 

When you select Phantom and draw a connector, it appears grayed out; the connector is highlighted when you 
point to it.

 

Besides line styles, you can also select line start and line end terminators on the Connector ribbon bar. The 
following connectors display some of the different types of terminators that you can apply.

 



Formatting Overview
{button Related Topics,AL("applying unique formats high;styles high;fill high;av high",0,`NOT_FOUND')}

{button How To,AL("format how",0,`NOT_FOUND')}

The software provides several different methods for formatting one or more geometric elements, such as lines, 
arcs, and circles. You can also format dimensions, annotations, and fills. 

Styles

To make elements that are the same type look alike, you can use styles to apply several formats at once. Styles 
are a collection of formats that are saved under a name. Styles allow you to save several formats so you can use
them again and again. Using styles guarantees consistency in a drawing.

To make an element look unique, you can select it and then format it directly. Formatting a few elements at a 
time takes more time than applying styles, but gives you greater flexibility.

The software provides fills that you can apply to closed boundaries. A fill floods a closed boundary with a solid 
color or pattern.

Besides fills, the software provides line types such as continuous, dash, chain, continuous chain, double chain, 
dot, and end gap. New line types can be created through Visual Basic automation. 

The software provides several other tools for consistent drawings. You can save styles and background sheets in
a template so that you can use them in other drawings.

Properties and Parameters

You can edit the properties of an element, symbol, or object by selecting it and then changing properties on the 
ribbon bar. You can also right click and select the Properties command on the shortcut menu. 

A property unique characteristic of an element, object, symbol, or document. You can display document 
properties in the Windows Explorer or by clicking Properties on the File menu or Edit menu. 

Properties for elements or objects have three different types, as defined on the Properties dialog box: 
Style properties, as specified on the Format tab. Style properties affect the format of the element.
Size properties, as specified on the Info. Size properties affect characteristics of the element, such as the 

length. 
User-defined properties, as created on the User tab. User-defined properties are usually in the form of a text

notation, such as cost, manufacturer, and so forth You can change user-defined properties, but these changes have 
no affect on the appearance of the element or object.

For example, a valve symbol's style properties can include color, line style, and width. Other user-defined 
properties stored with the symbol can include the manufacturer, cost, or material. User-defined properties are 
displayed in the Attribute Viewer when you select the valve symbol. 



Adding Your Own Tutorials
{button Related Topics,AL("help high",0,`NOT_FOUND')} {button How To,AL("add tutorial 
how",0,`NOT_FOUND')}

If you want to customize the learning tools in SmartSketch, you can add your own tutorials to the files that are 
automatically delivered with the software. You might want to develop your own macro using the SmartSketch 
type library and then explain how to use the macro. 

When you add tutorials, you must list the titles of each tutorial in a text file and create the content of the tutorial in
HTML.

After you add your own tutorials, they appear in the SmartSketch Learning Center Window.



Isometric Drawings
{button Related Topics,AL("draw high;iso circle cmd;iso rectangle cmd;iso line cmd",0,`NOT_FOUND')}

{button How To,AL("iso how",0,`NOT_FOUND')}

If you want to create 2D drawings that represent 3D elements, such as cubes, you can create an isometric 
drawing. An isometric drawing is not a true 3D drawing, because you cannot view the drawing in perspective or 
from another angle. However, you can create a 3D effect by aligning the elements and objects in a drawing along
three major axes. 

 

The software supplies several tools to create these types of documents:
Isometric Rectangle button
Isometric Circle button
Isometric Line button
Segmented Styles button

Tip    To access these commands, you must place them on a toolbar or menu with the Customize command on 
the Tools menu. On the Toolbars tab of the Customize dialog box, click the Draw category.

You can also access dimension styles that you configure to appear at an angle for isometric drawings. These 
styles are available for any type of dimension, except for chained dimensions and angular dimensions. You can 
create a document based on one of the Technical Drawing templates and access these dimension styles.

Special fonts for isometric drawings are also available in any template. These fonts are displayed at an angle. 
The fonts are stored in a resource file in the following location: <Drive Letter>:\PROGRAM FILES\
SMARTSKETCH\TEMPLATE\STYLES\ISOFONTS.RSC. You must set the location for these fonts on the File 
Locations tab of the Options dialog box.



Labels
{button Related Topics,AL("label cmd;annotations high",0,`NOT_FOUND')} {button How To,AL("labels 
how;text how",0,`NOT_FOUND')}

Technical drawings often have many labels that display important information about the objects or elements in 
the document. There are two types of labels: text labels and Smart Labels. 
Tip      For more information about adding associative text to a document, click the Related Topics button or 
How To buttons.

Text labels are associated with an element or object. If you move the element or object, the text label moves with
it. You can create text labels in a document by double-clicking an element or object. A text label appears near the
element so that you can type text. The default position of the label is bottom center on all elements, except for 
closed elements, such as a circle or rectangle. The default position on closed elements is the center of the 
element. When you enter the text that you want, the text label orients itself with the element.
 

Another kind of label, a Smart Label, can be associated to an object or element's text attributes. A Smart Label is
often distinguished by a question mark in the display.

 

A Smart Label displays the attributes of the element or object as text in the document. You can drag Smart 
Labels from the Symbol Explorer into the current document. Smart Labels have an .sym extension. As you 
change an element's or object's attributes in the Attribute Viewer or the Properties dialog box, the Smart 
Label's text displays those changes.
 
 

If an element or object has no attributes, and you drag a Smart Label to it, the element or object picks up the 
attributes of the Smart Label. For example, you might want to assign attributes to a valve, such as pressure and 
material type. If the Smart Label has the pressure and material type defined, and the valve does not, the Smart 
Label's pressure and material type are copied to the valve. 

If an element already has values assigned to its attributes, a Smart Label placed on the element displays the 
values that are already assigned to the element. The values for the Smart Label are erased. For example, if the 
valve already has values for pressure and material type attributes, the values of those attributes override any 
values for a Smart Label placed on the valve.

A Smart Label can contain graphics, such as a circle, ellipse, parametric symbol, and so forth.
Tip    Not all Smart Labels assume the text attributes of an element or object. Some Smart Labels contain shapes
that grow automatically if you add text to the Smart Label.



Smart Labels
{button Related Topics,AL("label cmd;reports high",0,`NOT_FOUND')} {button How To,AL("labels how;text 
how",0,`NOT_FOUND')}

Technical drawings often have many labels that display important information about the objects or elements in 
the document. There are two types of labels: text labels and Smart Labels. 

A Smart Label is associated to an object or element's text attributes. A Smart Label sometimes displays a 
question mark, indicating that you can edit the text in the question mark position.
 

A Smart Label displays the attributes of the element or object as text in the document. You can drag Smart 
Labels from the Symbol Explorer into the current document. Smart Labels have an .sym extension. As you 
change an element's or object's attributes in the Attribute Viewer or the Properties dialog box, the Smart 
Label's text displays those changes.
 
 

If an element or object has no attributes, and you drag a Smart Label to it, the element or object picks up the 
attributes of the Smart Label. For example, you might want to assign attributes to a heat exchanger, such as 
pressure and material type. If the Smart Label has the pressure and material type defined, and the heat 
exchanger does not, the Smart Label's pressure and material type are copied to the heat exchanger. 

 

If an element already has values assigned to its attributes, a Smart Label placed on the element displays the 
values that are already assigned to the element. The values for the Smart Label are erased. For example, if the 
heat exchanger already has values for pressure and material type attributes, the values of those attributes 
override any values for a Smart Label placed on the heat exchanger.
Tip    Not all Smart Labels assume the text attributes of an element or object. Some Smart Labels contain shapes
that grow automatically if you add text to the Smart Label.



There are no related 
Help topics. You must 
install the appropriate 
add-in by clicking 
Add-in on the Tools 
menu.



Scaling Symbols
{button Related Topics,AL("symbols cmd;symbol label how;Symbol Explorer high;animate high;labels 
high;symbol overview high ",0,`NOT_FOUND')} {button How To,AL("scale symbol how",0,`NOT_FOUND')}

You can use scale handles on a symbol to resize it. Four black scale handles are displayed on the corners of the 
range box of a symbol. You can drag any of the four handles up or down. 
{mci_left NOMENU,SCALESYM1.AVI}

You can also change the size of the symbol by clicking the Scale button on the Change toolbar.

You can modify different parts of some symbols with parametric handles. Standard parameter handles represent 
up to four driving dimensions that have been applied to the graphics in a symbol. The four standard positions 
where parameter handles can appear are top center, bottom center, left center, and right center of a symbol's 
range box. Dragging a parameter handle changes the value of the dimension by the length readout precision set 
on the Units tab of the Properties dialog box when the symbol is created.
{mci_left NOMENU,PARASYM1.AVI}

You can also scale a parametric symbol by selecting the symbol and then editing the values in the Attribute 
Viewer. The Attribute Viewer automatically appears when you select the symbol. For example, if you select the 
Para Tower symbol, you can change the Top attribute from 7.29 to 9.00 so that the height of the symbol 
increases. 



Mirroring Symbols
{button Related Topics,AL("symbols cmd;symbol label how;Symbol Explorer high;animate high;labels 
high;symbol overview high ",0,`NOT_FOUND')} {button How To,AL("mirror symbol how",0,`NOT_FOUND')}

You can use mirror handles to mirror a symbol about its center. The mirror handle appears at the right center of a
symbol's range box. Dragging the mirror handle across the center of a symbol's range box causes the symbol to 
mirror about its center in dynamics. A center line for the X and Y axis appears through the range box of the 
symbol. The axes appear as solid when the pointer crosses one or both axes. 
{mci_left NOMENU,MIRRORSYM1.AVI}

When you manipulate a symbol, you see the same behaviors unique to that symbol that existed when you placed
the symbol in the document.



Connectors and Symbols
{button Related Topics,AL("symbols cmd;symbol label how;Symbol Explorer high;animate high;labels 
high;symbol overview high ",0,`NOT_FOUND')} {button How To,AL("connector to symbol 
how",0,`NOT_FOUND')}

Some symbols are created with connect points. When you attach a connector to a connect point, the connector 
automatically attaches to the point at a predefined angle. Otherwise, the connector locates and attaches to a 
keypoint or point along any elements in the symbol. 

The connect points appear as red circles with Xs. The keypoints appear as gray circles with Xs.
{mci_left NOMENU,CONNPTSYM1.AVI} 
Tip    If you press the Alt key while drawing a connector, the connector attaches to a connect point at any angle.

 



Symbols Overview
{button Related Topics,AL("symbols cmd;symbol label how;Symbol Explorer high;animate high;labels 
high;symbols high",0,`NOT_FOUND')} {button How To,AL("symbols how",0,`NOT_FOUND')}

Symbols increase drawing productivity because they allow you to access existing graphic data quickly and easily.
With a symbol, you can place graphic information repeatedly without re-creating it. Symbols save you time by 
eliminating the need to re-create information, as well as help you maintain accurate graphic data throughout a 
project. Symbols are contained in documents with an .sym extension.
 

Parametric symbols are also available. You can modify these symbols by changing a parameter value.

Click the Related Topics button for more information about placing, creating, editing, manipulating, and rotating 
symbols.



Creating Symbols
{button Related Topics,AL("symbols cmd;symbol label how;Symbol Explorer high;animate high;labels 
high;symbol overview high",0,`NOT_FOUND')} {button How To,AL("create symbol how",0,`NOT_FOUND')}

A symbol is a document with an .sym extension. You can create a symbol by selecting any geometry and clicking
the Create Symbol button on the Draw toolbar. You must then define the origin by clicking the point that you 
want in the select set. After defining the origin, you can save the select set as a symbol with the Save As dialog 
box. 

Symbols that you create display the following default behaviors:
90 degree rotation angles 
Automatic alignment with a target element or object when the symbol is placed in a document
Automatic association with a target element or object.



Rotating Symbols
{button Related Topics,AL("symbols cmd;symbol label how;Symbol Explorer high;animate high;labels 
high;symbol overview high",0,`NOT_FOUND')} {button How To,AL("rotate symbol how",0,`NOT_FOUND')}

You can rotate a symbol by using one of the following methods: 
Clicking the Rotate button.
Selecting the symbol's rotate handle to turn it.
Using a rotation angle.
Using relationships applied to the symbol.

Rotate Button

To rotate a symbol, you can select the symbol and click the Rotate button on the Change toolbar.

Rotate Handles

You can also rotate a symbol about its center with the appropriate handle. The rotate handle appears as a green 
circle to the right of the symbol. Dragging the rotate handle closer to the center of a symbol's range box causes 
the symbol to rotate at larger angles. Dragging the rotate handle further away from a symbol's center causes the 
symbol to rotate at smaller angles.
{mci_left NOMENU,ROTATESYM1.AVI}

Rotation Angle

You can also rotate a symbol by the rotation angle. When you drag a symbol or align it to an element, you can 
press the left or right arrow keys on the keyboard. This rotates the symbol in 15 degree increments by default. 
Some symbols are designed to rotate at different increments. 

If the symbol is created with a rotation angle other than zero, you can rotate it by the defined step angle using the
left and right arrow keys.

Relationships

By default, when you rotate a symbol, it maintains its orientation on the drawing sheet. In the following example, 
the line and symbol share a dimensional relationship. The lower end of the symbol is set in place with a lock 
relationship. When you edit the dimensional value of the driving dimension, the symbol does not change its 
orientation. The driving dimension changes to a driven dimension that is not to scale. 

You can also allow symbols to change orientation on the drawing sheet according to the relationships applied to 
them. This is handy if you want to change the orientation of whole sets of geometry with one driving dimension or
relationship. In the example, when you edit the driving dimension between the line and symbol, the symbol 
changes orientation on the drawing sheet, maintaining the relationships applied to it.

For a symbol to rotate according to the relationships applied to it, you must first set an option by opening the 
symbol document (.sym) directly. You can open the document with the Open command on the File menu. Then, 
you must click the Properties command on the File menu. On the Behavior tab, you must set the Allow 
Rotation By Relationships check box. After saving and closing the symbol document, you can drag the symbol 
into a document.

You can create kinematics animations by editing dimensional relationships between elements and symbols. For 
more information about kinematics animation, click the Related Topics button and select the Mechanism 
Modeling topic.



Editing Symbols
{button Related Topics,AL("symbols cmd;symbol label how;Symbol Explorer high;animate high;labels 
high;symbol overview high ",0,`NOT_FOUND')} {button How To,AL("edit symbol how",0,`NOT_FOUND')}

To edit a symbol, you should select it and click Open on the shortcut menu. 
Tip    To display the shortcut menu, you can highlight a symbol with the pointer and then click the right mouse 
button. 

For some special symbols, you can also edit the properties and parameters to change the symbol. When you 
drag these special symbols into a document, the Attribute Viewer automatically displays the properties and 
parameters. The properties are in plain text. The parameters are identified with bold text. You cannot edit the 
names of the parameters.
Tip    If the Symbol Explorer is closed, you can also access the properties and parameters of a symbol by 
selecting it and clicking the Symbol Explorer button.

Editing Embedded or Linked Symbols

If the symbol is linked, you can open the symbol and edit it. The symbol that you placed on the drawing sheet 
updates automatically. Those same changes are saved in the .sym document on the hard drive.

You can also edit the symbol while viewing the other drawing graphics by using the Object Edit command on the
Edit menu. As you edit, all graphics except the symbol become disabled until you finish editing the symbol. 
When you want to stop editing, you can click Update on the File menu to update the document that contains the 
symbol and then click Close to close the symbol document. 

Embedding the symbol means that a copy of the symbol was placed in the document. If you edit one instance of 
the embedded symbol in a document, all copies of that symbol within the current document reflect those 
changes.
Tip    Before placing a symbol, you can set an option to link or embed the symbol when you drag the symbol into 
the document. You can do this by clicking the Options command on the Tools menu and then setting the option 
you want on the Symbols tab. 

Editing Parts of a Symbol

To edit parts of a symbol as individual elements on the drawing sheet, you can convert the symbol to a group of 
individual graphics. To do this, you place the symbol on a drawing sheet, select it, and then click the Convert 
command on the shortcut menu to convert the symbol into an element group. To ungroup the elements so that 
you can edit them individually, you can click the Ungroup button on the Change toolbar. You can now edit the 
individual elements.
Tip    You must place a symbol in a document at the default scale (1:1) if you want to use the Convert command.
If you scale the symbol, you cannot convert the symbol to individual elements.

Symbol Labels

To create a label, you can double-click the symbol. A blinking pointer appears below the symbol so that you can 
start typing the text that you want.

Formatting a Symbol

You can change the attributes of a symbol with the Attribute Viewer or the Parameters tab on the Properties 
dialog box. You can change the value of the symbol attribute, but you cannot change the name of the attribute or 
add an attribute. 



Manipulating Symbols
{button Related Topics,AL("symbols cmd;symbol label how;Symbol Explorer high;animate high;labels 
high;symbol overview high;symbol behavior high",0,`NOT_FOUND')} {button How To,AL("manipulate symbol 
how",0,`NOT_FOUND')}

You can manipulate a symbol just like you would manipulate other graphics. For example, you can edit symbol 
properties, apply relationships, move it, or copy it. When you manipulate a symbol, it behaves as a single unit. 
You can view properties for the symbol in the Attribute Viewer that appears at the bottom of the Symbol 
Explorer. 

You can click any part of a symbol to move it around in a document. 

Some symbols are created with drag points that appear as green dots on the symbol. When you move the 
symbol around in the document, the pointer automatically attaches to the drag point that you used most recently. 
You can change drag points by pressing the Up and Down arrow keys on the keyboard. 
{mci_left NOMENU,DRAGPOINT1.AVI}

If you drag a symbol on an element in the document, the symbol is automatically associated with that element. 
When the element moves, the symbol moves with it. You must click one of the green drag points on the symbol 
and then move the symbol to the element.
Tip    Some symbols cannot be associated with an element depending on what options were set when the 
symbol was created. 

Aligning a Symbol with an Element

Many symbols align automatically with elements in the document. 
{mci_left NOMENU,SYMALIGN1.AVI}

When associated with an element, these symbols display a green lock handle. When the element moves, the 
symbol moves with it. 
{mci_left NOMENU,UNLOCK1.AVI}

You can click the lock handle to free the symbol from the associated element. When you unlock the handle, you 
can move the symbol away from the element. If you move the element, the symbols stays in its original position. 
{mci_left NOMENU,UNLOCK2.AVI}

You can use the lock behavior in many ways. For example, you can ensure that a door symbol moves with the 
wall to which it is attached if the lock handle on the door symbol is locked. If you want to move the wall, and not 
the door, you must click the lock handle on the symbol to unlock the door symbol from the wall. The door now 
remains in its current position when you drag the wall away from it.

Aligning a Symbol with Another Symbol

Some symbols can be placed only on other symbols. These symbols are created with drop points that allow you 
to align the symbol to a precise point on another symbol. You cannot place a symbol with drop points on an 
element, such as line, arc, or circle.

When a symbol has drop points, red dots appear to indicate the drop points defined on the symbol. These drop 
points let you know where you can place the symbol on the target symbol. When you click a drag point on a 
symbol and drag it over another symbol, the drop points appear as red dots. A bull's eye appears when the drag 
point and drop point are exactly aligned. You can then attach the symbol to the other with precision.
{mci_left NOMENU,DROPPTSYM1.AVI}



Placing Symbols
{button Related Topics,AL("symbols cmd;symbol label how;Symbol Explorer high;animate high;labels 
high;symbol overview high;symbols handles high",0,`NOT_FOUND')} {button How To,AL("place symbol 
how",0,`NOT_FOUND')}

To place a symbol, you can drag the symbol from the Symbol Explorer or Windows Explorer into the current 
document. 

Symbol Libraries

After starting the software, you can open a template or document. For most standard templates, the Symbol 
Explorer automatically opens and displays a default directory for all the symbols that would be appropriate to 
use with that template. For example, templates in the Process category point to directories with process diagram
symbols. 
Tip    To open the Symbol Explorer, you can also click the Symbol Explorer button on the Main toolbar. You 
might need to click the Home button in the Symbol Explorer. The Home path is stored on the Browser tab of 
the File Properties dialog box.

Dragging a Symbol

When you click a symbol in the Symbol Explorer to drag it into a document, the pointer attaches to the origin of 
the symbol by default to drag it in. At that instance, the origin is the drag point. 

{mci_left NOMENU,PLACESYM1.AVI}

Some symbols contain more than one drag point. These appear as green dots on the symbol. These drag points 
are useful if you want to place a symbol using a particular part of the symbol.    You can change to another drag 
point by pressing the Up and Down arrow keys on the keyboard.
By default, every element in a symbol does not appear when you place the symbol in a document. For example, 
if you place a symbol that contains dimensions in a document, the dimensions are not displayed. 



Discovering Symbol Behavior and Handles
{button Related Topics,AL("symbols cmd;symbol label how;Symbol Explorer high;animate high;labels 
high;symbol overview high;placing symbols high",0,`NOT_FOUND')} {button How To,AL("symbols 
how",0,`NOT_FOUND')}

Symbols can display different types of behavior depending on how the symbol was created. When you drag a 
symbol into a document, you can check out different characteristics of the symbol to see what it can do. 

Depending on how the symbol was created, some symbols automatically ungroup into individual elements in the 
document when you place the symbol. For example, if you place a symbol that contains a circle and a rectangle 
in a document, the symbol immediately ungroups. The parts of the symbol, the circle and rectangle, act as a 
separate circle and rectangle, not a symbol.

Labels

Some symbols have a label that appears as a question mark under the symbol. To change the text in the label, 
you can double-click the question mark. When the Attribute Viewer appears, you can then edit the text in the 
Value column and press Enter. 

Commands on the Shortcut Menu

While the symbol is selected, right-click and look at the shortcut menu. Some symbols have special commands 
on the shortcut menu that run custom processes for the symbol. If the shortcut menu has a Help command, you 
can access a Help file that displays special information about the symbol.

Commands on the shortcut menu can also activate different representations of the same symbol. For example, 
you can access different representations of the same valve symbol, with a flanged globe, a welded globe, and so
forth.

 

 

Drop Points

You can move the symbol around in the document with the Select Tool. You can discover special behaviors by 
dragging the symbol over an element or another symbol. 

Some symbols automatically connect to other symbols. These symbols were created with drop points for symbol-
to-symbol connections. When you click a drag point on a symbol and drag it over another symbol, the drop points
appear as red dots. A bull's eye appears when you exactly align the drag point and drop point. You can then 
attach the symbol to the other at a precision point. 
{mci_left NOMENU,DROPPTSYM1.AVI}

ToolTips

If you pass the pointer over the drop points on a symbol, you might see ToolTips. These ToolTips display special 
information about different parts or points on the symbol. For example, the serial number for networking 
diagramming equipment can appear in a ToolTip.



 

Custom Processes

Some symbols actually run special processes when you drag them, double-click them, or perform other actions. 
If you select the symbol and click the right mouse button, you might also see special custom commands for the 
symbol on the shortcut menu.

Displaying Attributes on an Element

Some symbols can display attributes that are assigned to an element. When you drag the symbol to the element 
with attributes, the symbol automatically displays the values of those attributes. 

Handles

When you select a symbol, different handles appear on the symbol. 

Some symbols have several different kinds of handles:

 
Black boxes on the outside corners of the range box lines represent scale handles (A). You can drag a scale

handle to resize the entire symbol.
Yellow boxes in the middle of the range box lines represent standard parametric handles (B). You can drag a

parametric handle to resize part of the symbol.
A green plus sign represents a mirror handle (C). You can drag a mirror handle to create a copy of the 

symbol directly horizontal or vertical to the original symbol.
A large green circle represents a rotate handle (D). You can drag this handle to rotate the entire symbol. 

Specific increments are displayed by the pointer while you rotate the symbol.
A series of small green circles represents drag points (E). You can use these points to attach the symbol at a

precise point to another symbol or element.
A small green lock represents a lock handle (F). You can click the lock handle to unlock the symbol. 

Unlocking allows you to move a symbol away from the element to which the symbol was associated.
Tip    A lock handle appears only if you drag the symbol to an element with one of the drag points on the 
symbol. 

For more information about the way these handles work, click the Related Topics button.



 HVAC Templates Overview
{button Related Topics,AL("properties cmd;properties db;document cmd;drawing sheet high;paper high;styles 
high",0,`NOT_FOUND')} {button How To,AL("properties how;open how;document 
how",0,`NOT_FOUND')}

You use these precision templates to produce HVAC designs and drawings according to accepted industry 
standards. 

HVAC (Imperial)—This template has imperial units in feet and inches, ANSI and Architectural sheet sizes 
and borders, and Architectural fill styles. It provides symbols based on ASHRAE and ISO standards for residential 
and commercial designs.

HVAC (Metric)—This template has metric units in meters and centimeters, ISO standard Architectural sheet 
sizes and borders, and Architectural fill styles. It provides symbols based on ASHRAE and ISO standards for 
residential and commercial designs.

The ANSI, DIN, BSI, ISO, and JIS dimensioning standards are also available in these templates. When you open
these templates, the Draw toolbar appears, containing tools to help you create precision drawings.

Production Drafting Workflow for Double Line Duct Layout

You can produce full sets of production drawings according to the AIA standards.
Tip    To produce a fairly complex production drawing, you should set Maintain Relationships off. 
1 Set up the sheet.

Select an appropriate sheet size and scale that allow you to draw the design. The default scale is 1/4" = 1', 
which is appropriate for the average plan on a D-Size sheet.

2 Reference a floor plan or open one.
Reference a floor plan by using the Object command on the Insert menu or by dragging and dropping in the 
reference file. Or click File on the Open menu to open (translate) the file.
Tip    Any MicroStation, AutoCAD, dxf, or igr document can be a reference file.

3 Place duct symbols.
Using the Symbol Explorer, select the Double Line Duct folder from the HVAC folder in the tree view. Drag 
the duct symbols over the reference file, connecting one to another. Use the bold parameters that appear in 
the Attribute Viewer to change the size of the duct. 
Tip    You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 
Ctrl key and use the left mouse button to place multiple copies of the symbol.

4 Annotate the drawing.
Use text and dimensioning commands to annotate the drawing. Text is entered in paper units regardless of 
the sheet scale. To label double line ducts, use the labels that automatically appear on symbols when you 
double-click them. 

5 Select a border or create one.
The HVAC templates are delivered with ten border sizes. 
Select the borders with the Sheet Setup command on the File menu so that they appear in the current 
design. On the Background tab, select the background sheet to display with the working sheet. Use the 
Select Tool to position the graphics appropriately in the border.
Note    The borders were designed from guidelines from the Construction Specifications Institute (CSI).

The following symbol sets aid in production drafting.
Content Description 

HVAC (Intergraph) HVAC symbols designed to best fit 
Double Line Duct and Single Line Duct 
Layout workflows. Several of these 
symbols are designed with special 
behaviors and parametric properties.



HVAC (ASHRAE) HVAC symbols designed to ASHRAE 
standards.



Landscape Templates Overview
{button Related Topics,AL("properties cmd;properties db;document cmd;drawing sheet high;paper high;styles 
high",0,`NOT_FOUND')} {button How To,AL("properties how;open how;document 
how",0,`NOT_FOUND')}

Use these precision templates to produce landscape designs and drawings according to accepted industry 
standards. 

Landscape (Imperial)—This template has imperial units in feet and inches, ANSI and architectural sheet 
sizes and borders, and architectural fill styles. It provides symbols based AIA    standards for residential and 
commercial designs.

Landscape (Metric)—This template has metric units in meters and centimeters, ISO standard architectural 
sheet sizes and borders, and architectural fill styles. It provides symbols based on AIA standards for residential and 
commercial designs.

The ANSI, DIN, BSI, ISO, and JIS dimensioning standards are also available in these two templates. When you 
open these templates, the Draw toolbar appears, containing tools to help you create precision drawings.

Production Drafting Workflow for Landscape Designs

You can produce full sets of production drawings according to the AIA standards.
Tip    To produce a fairly complex production drawing, you should set Maintain Relationships off. 
1 Set up the sheet.

Choose an appropriate sheet size and scale for the design. The default scale is ¼ inches = 1 foot, which is 
appropriate for the average plan on a D Size sheet.

2 Reference a floor plan or open one.
Reference a floor plan by using the Object command on the Insert menu or by dragging and dropping in the 
reference file. Or use the Open command on the File menu to open (translate) the file.
Tip    Any MicroStation, AutoCAD, dxf, or igr document can be a reference file. 

3 Create a foot print.
If you reference the plan, using the drawing tools on the Draw tool bar, you can trace the outer perimeter of 
the reference plan to create the outline shape of the building. Either delete or move the reference file to a 
layer and turn it off.    

4 Place symbols.
Drag the landscape symbols into the document in the appropriate positions. 
You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 
Ctrl key and use the left mouse button to place multiple copies of the symbol.

5 Annotate the drawing
Use text and dimensioning to annotate the drawing. Text is entered in paper units regardless of the sheet 
scale. To label landscape symbols, use the labels that automatically appear on symbols when you double-
click them. 

6 Select a border or create one.
The Landscape templates are delivered with ten border sizes. 
Select the borders with the Sheet Setup command so that they appear in the current design. On the 
Background tab, select the background sheet to display with the working sheet. 
You should use the Select Tool to position the graphics appropriately in the border.
Note    The borders were designed from guidelines from the Construction Specifications Institute (CSI).

The following symbol sets aid in production drafting.
Content Description 

Elevations Symbols Provide AIA and Intergraph standard 
elevation symbols for commercial and 



residential Landscape design.    
Plan Symbols Provide AIA and Intergraph standard 

plan symbols for commercial and 
residential Landscape design.



Flowchart Templates Overview
{button Related Topics,AL("properties cmd;properties db;document cmd;drawing sheet high;paper high;styles 
high",0,`NOT_FOUND')} {button How To,AL("properties how;document how",0,`NOT_FOUND')}

You use these templates to produce flowcharts and diagrams. 
Imperial Template—This template has imperial units in decimal inches, ANSI sheet sizes, ANSI 

dimensioning and Arial text. 
Metric Template—This template has metric units in millimeters, ISO sheet sizes, ISO dimensioning, and Arial

text. 

Flowchart, Audit, Dataflow, and TQM symbols are available in the Symbol Explorer for these templates. The 
Schematic toolbar containing tools to create flowcharts and diagrams appears on the left of the drawing window.

Setting Up a Flowchart 
Tip    You can create flowcharts and diagrams with Maintain Relationships set on or off. 
1 Set up the sheet.

Select an appropriate sheet size and scale that allow enough paper space to draw. The default scale is 1:1.
2 Prepare to draw.

Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid Display, and Grid Snap 
commands. 
For more grid options, click the View tab after you click the Options command on the Tools menu to set the 
grid style to either dynamic or static, and set the static grid to the preferred grid spacing. 

These settings provide visual feedback to you to improve the workflow while you draw. To create clean 
diagrams, use Grid Snap with a static grid displayed.

Placing symbols and connectors on a static grid produces high quality results. 
You can set grid display and snap by right clicking. 

Drawing a Simple Flowchart and Diagram
1 Drag symbols from the Symbol Explorer.
2 Use the Connector command to connect symbols.
3 Double-click each symbol to add text.

Drawing an Optimal Flowchart and Diagram
1 Place flowchart and diagram symbols by dragging from the Symbol Explorer. 

While dragging a symbol for placement, use the left/right arrow keys on the keyboard to rotate the symbol 
dynamically before placement. 
Use the up/down arrow keys to select different drag points on the symbol before placement. If you press the 
Alt key during symbol placement, the alignment indicators are temporarily disabled, allowing symbol 
placement with grid snap or visual alignment.
You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 
Ctrl key and use the left mouse button to place multiple copies of the symbol.

2 Connect the symbols by using the Connector command. 
When drawing connectors, you should set Clearance. Type the minimum distance from the symbols that you 
would like the first turn in the connectors to occur. This action allows you to control the visual consistency of 
connectors that make right-angle turns just before they attach to a symbol.
When you draw a connector to a symbol, approach the symbol from the direction you want the connector 
placed. As the pointer intent zone nears the symbol, suggested targets for the connector appear. 
The connector end point can be located on a target or any other symbol geometry. If you press the Alt key 
while drawing a connector, the diagonal drawing mode will be temporarily activated, allowing the connector to 
be drawn at any angle with or without grid snap. 
3 Double-click symbols to place text in the center of the symbols. 
The active text settings in the file are used. To highlight existing text for properties editing or moving, pause 



the pointer over text until the PickQuick indicator appears. 
Then click and select the numbered box that represents the text. Right-click on the highlighted text to edit 
properties. To move the highlighted text, click the green lock to unlock. 
Then with the pointer drag the text to a new position. Note that text is entered in paper units regardless of the 
sheet scale.

4 Finish the diagram.
Use color to modify the symbols and connectors to enhance the drawing. 

The following symbol sets are provided to aid in drawing diagrams.
Content Description 

\Program Files\
SmartSketch
\Symbols\Diagramming
\Flowchart

Flowchart, Audit, Dataflow, and TQM 
symbols. You can double-click these 
symbols to place text. These symbols 
also have special behaviors for enhanced
placement and modification.



Workflow Diagram Templates Overview
{button Related Topics,AL("properties cmd;properties db;document cmd;drawing sheet high;paper high;styles 
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You use these templates to produce workflow diagrams. 
Imperial Template—This template has imperial units in decimal inches, ANSI sheet sizes, ANSI 

dimensioning, and Arial text. 
Metric Template—This template has metric units in millimeters, ISO sheet sizes, ISO dimensioning, and Arial

text.

Work flow symbols are available in the Symbol Explorer for these templates. The Schematic toolbar containing
tools to create workflow diagrams appears on the left of the drawing window.    

Schematic Workflow
Tip    You can create workflow diagrams with Maintain Relationships set on or off. 
1 Set up the sheet.

Select an appropriate sheet size and scale that allow enough paper space to draw. The default scale is 1:1.
2 Prepare to draw.

Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid Display, and Grid Snap 
commands. 
For more grid settings, click the View tab after you click the Options command on the Tools menu to set the 
grid style to either dynamic or static, and set the static grid to the preferred grid spacing. 

These settings provide visual feedback to you to improve the workflow while you draw. To create clean 
diagrams, use Grid Snap with a static grid displayed.

Placing symbols and connectors on a static grid produces high quality results. 
You can set grid display and snap by right clicking. 

Drawing a Simple Workflow Diagram
1 Drag symbols from the Symbol Explorer.
2 Use the Connector command to connect symbols.
3 Double-click each symbol to add text.

Drawing an Optimal Workflow Diagram
1 Place symbols.

Place symbols by using the pointer to drag symbols from the Symbol Explorer. 
While dragging a symbol, use the left/right arrow keys on the keyboard to rotate the symbol dynamically 
before placement. 
Use the up/down arrow keys to select different drag points on the symbol before placement. 
If you press the Alt key during symbol placement, the alignment indicators are temporarily disabled, allowing 
you to place a symbol using the Grid Snap command or visual alignment. 
You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 
Ctrl key and use the left mouse button to place multiple copies of the symbol.

2 Connect the symbols.
Use the Connector command. When you draw a connector that is not straight, you should set Clearance on 
the ribbon bar to the minimum distance from the symbol where the first turn in the connector occurs. 
When you draw a connector to a symbol, approach the symbol from the direction you want the connector 
placed. As the pointer intent zone nears the symbol, suggested targets for the connector appear. 
If you press the Alt key while drawing a connector, the diagonal mode is temporarily invoked and the 
alignment indicators are temporarily disabled, allowing the connector to be drawn with or without grid snap.

3 Place text.



Double-click symbols to edit text labels at the bottom of the symbols. To highlight existing text for properties 
editing or moving, pause the pointer over text until the PickQuick indicator appears. Then click and select the 
numbered box that represents the text. Right-click on the highlighted text to edit properties. 
To move the highlighted text, click the green lock to unlock. Move the text to a new position. Note that text is 
entered in paper units regardless of the sheet scale.

4 Finish the diagram.
Use color to modify the symbols and connectors to enhance the drawing.

The following symbol sets aid in drawing workflow diagrams.
Content Description 

\Program Files\
SmartSketch
\Symbols\Diagramming
\Workflow Diagram

Workflow Diagram symbols. These 
symbols have special behaviors for 
enhanced placement and modification.



PFD and P&ID Templates Overview
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You use these schematic templates to produce process flow diagrams according to accepted industry standards.
PFD (Intergraph) Template—This template is set up to be a schematic template to create process flow 

diagrams. The default symbol set is a subset of the Intergraph SP2D symbol set. The delivered set draws most 
PFDs. If you need other Intergraph symbols, you can copy them from the P&ID (Intergraph) symbol set.

PFD ANSI Template—This template is set up to be a schematic template to create process flow diagrams 
based on ANSI Process Flow Standards. ASA Z32.2.3-1949.

PFD ISO Template—This template is set up to be a schematic template to create process flow diagrams 
based on ISO Process Flow Standards. (General Rules—Flow Diagrams for Process Plants - ISO 10628)

P&ID (Intergraph) Template—This template is set up to be a schematic template to create process flow 
diagrams and P&ID diagrams. The symbol set is the Intergraph SP2D symbol set, consisting of approximately 1000 
symbols. You can reconfigure the symbol locations and directories to your specification for easy location.

PFD and P&ID Workflow
Tip    You should create schematic drawings with Maintain Relationships cleared. 
1 Set up the sheet. 

Select an appropriate sheet size and scale that allow you to draw the schematic drawing. The default scale is 
1:1, which is appropriate for the symbol sizes. 

2 Place symbols.
Drag in the major components of the PFD and place them at locations on the sheet. 
These components usually include vessels, pumps, and heat exchangers.
You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 
Ctrl key and use the left mouse button to place multiple copies of the symbol.

3 Enter attribute information for the individual components. 
To enter data in the attributes, select the symbol and add the information in the Attribute Viewer.

4 Attach nozzles to major equipment. 
Nozzles are automatically aligned and can be placed anywhere on the major equipment.

5 From the Schematic toolbar select the Connector command. 
Connect the major components together at the locations you want on each symbol.

Each symbol has predefined connect points; however, the connector can connect to any graphic location on 
the symbol.

The connector routes itself away from the original symbol and toward the target symbol.
You can attach connectors to connectors.
A connector being placed or modified can have its starting or ending point anywhere along another 

connector.
6 Set connector flow direction at any time. 

There are two methods to set the flow direction:
When you place the connector, you can use the options on the connector toolbar to select the starting and 

ending terminator for the connector.
You can drag an arrowhead symbol from the browser and connect it to the end of the connector.

7 Drag inline symbol components such as valves onto the connectors. 
The valve symbols have automated aligning turned on. This means that the valve automatically aligns to the 
direction of the connector. 
Note that the valve is placed on top of the connector and hides the portion of the connector that the valve 
covers.

8 To associate a text box with a symbol that does not already have associated text. 



Double-click the symbol. 
Then, type in text.

Moving the symbol causes the text to move and maintain its relative location to the symbol. 
If a symbol already has associated text, double-clicking the symbol allows you to edit the text. 

9 After you have placed components and connectors, you can modify the symbols and/or connectors by selecting 
and dragging them to a new location. 

You can select and drag multiple symbols to a new location.
You can select and modify single connectors.
You can adjust segments of connectors to new locations or move and reattach endpoints.

The following symbol sets aid in schematic drawings of PFDs and P&IDs.
Content Description 

P&ID (Intergraph) Intergraph Symbol set containing 
symbols needed for creating PFDs, 
P&IDs, and Material Handling drawings.

PFD (Intergraph) Symbol set that is a subset of the P&ID 
(Intergraph) set. Symbols are adequate 
to create most PFDs. Other symbols 
from P&ID or other symbol sets can be 
copied to the PFD directory and are 
displayed for selection.

PFD (ISO Standard) Symbol set based on the ISO 10628 
standard. General rules for flow 
diagrams for process plants.

PFD (ANSI) Symbol set based on ASA Z32.2.3-1949
ASME Y32.2.2.3 Graphical symbols for 
pipe fittings, valves and piping.



Ortho Piping Template Overview
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You use this precision template to produce orthographic piping drawings, using common sized components and 
pipes.

Ortho Piping Template—This template has imperial units in feet and inches, with a precision of 1/32”. The 
sheet scale is set to 1/2” = 1’. 

ANSI, ISO, DIN, BSI, and JIS dimensioning standards are available in the template. The default dimension type 
is ANSI. When you open this template, the Draw toolbar appears, containing tools to help you create precision 
drawings.

Ortho Piping Workflow 1 (Small Layouts)
You can create small layouts with Maintain Relationships set on. 
Select Midpoint from the SmartSketch Settings options.

1 Set up the sheet.
Select an appropriate sheet size. The default scale is 1/2” = 1’.

2 From the Symbol Explorer, select the size of piping to be placed. A list of folders containing appropriate 
components for that size of pipe is displayed. 

3 Place a line. 
On the Draw toolbar, click Line/Arc Continuous. On the ribbon bar, select the appropriate line style. Click to 
place the line.

4 Drag one of the piping components into the document close to the end of the pipe where it is placed. Example 
150# Gate Valve with flanges. If the orientation of the valve is not correct relative to the pipe, use the left or right 
arrow keys to rotate as needed. Click the symbol.

5 To display the Relationships toolbar, click    Relationships on the Main toolbar
6 On the Relationships toolbar, click Connect. 
7 Identify the center on one end of the valve as the first point to connect to. You can see the midpoint indicator as 

the pointer moves over the center of the end of the valve.
8 Identify the end of the line placed previously as the other end to connect. The valve moves to the end of the pipe.

If Maintain Relationships is set on, the valve remains connected when modifications are made.
9 Place another line from the other end of the valve. Select the midpoint of the end of the valve from which to start.

Place the line an approximate length. 
10 From the 4” Els directory select the 90 degree elbow and drag it into the file. Use the rotate keys to rotate to a 

correct orientation. Connect the midpoint of the elbow to the end point of the 4” line.
11 Repeat the process as needed until the layout is complete.
12 Place dimensions between key components of the layout. 
Note    Workflow method 1 is recommended for small layouts because the constraints needed to handle a large 
piping layout may make the system too slow for practical use.

Ortho Piping Workflow 2 (Large Layouts)
You should create large piping layouts with Maintain Relationships set off. 
Be sure to select Midpoint from the SmartSketch Settings options.

1 To set up the sheet, select an appropriate sheet size and scale that allow you to draw the piping layout. The 
default scale is 1/2” = 1’. 
2 From the Symbol Explorer, select the size of components to be placed. A list of folders containing 
appropriate components for that size of pipe is displayed.

3 On the Draw toolbar, click Line/Arc Continuous. Draw a single line, centerline, layout of the piping system to be
drawn. Placing centerlines on a different layer is recommended.

4 From the Symbol Explorer, select the proper sized components to be placed, and drag the components onto 
the line. 

5 When the components are placed in their proper locations, turn off the centerline layer.
6 Select the Place Doubleline command, a flyout on the Line/Arc Continuous command. Set the placement 

option on the toolbar to Center Primary Line; then select a width.
7 Use relationship indicators to locate the midpoint of one of the components, and click the left mouse button. Use 



midpoint to locate the end of the next component that has been placed, and click the right mouse button. A 
doubleline representing the size of the pipe is placed.

8 Continue connecting components in this manner until all components are connected.
Note    To show pipes crossing, the doubleline representing the pipe on top can be filled or patterned with a blank
color. The pipe that is to be displayed below can be selected and pushed to the bottom in the display. To select 
and push the pipe to the bottom, click Send to Back on the Change toolbar. 
Tip    You can place pipes using the method in Workflow 1 with the Line/Arc Continuous command instead of 
using the Place Doubleline command.

The following symbol sets aid in Ortho Piping layouts.
Content Description 

Orthographic Piping 
Symbols
Sizes 1,2,3,4,6,8,10,12
Inches

Each Size contains the following:
150# Valves
300# Valves
Actuators
Annotation
Els
Olet
Reducers
Welds

1 and 2 Inch sizes also include 600# and 
800#    valves.



Control Loop Template Overview
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You use this schematic template to produce control loop diagrams using Intergraph supplied symbols according 
to accepted industry standards. 

Imperial Template—This template defaults to a B size sheet. The sheet background consists of two sections 
divided into two categories. The main sections are Field and I/O Building. 

The Field section is divided into Instrument and Junction Box categories.
The I/O Building is divided into Termination Rack and I/O Cabinet categories.

Tip    If you need a different configuration for the background, click Background Sheets on the View menu, and 
select a sheet and modify as needed. Then click Working Sheets on the View menu. The working sheet 
displays the changes that were made in the background sheet.

Control Loop Workflow
Tip  You should create schematic drawings with Maintain Relationships cleared. 
1 Set up the sheet.

Select an appropriate sheet size. The default sheet size is B with a scale of 1:1.
2 Place symbols.

The Symbol Explorer defaults to the Control Loop symbol set. The set is divided into logical components 
such as controllers, recorder, terminal strips, transmitters and others. Select a component and drag it to the 
location you want.
Tip  A typical configuration might be as follows: Field—Instrument—Thermocouple, Junction Box- 3 Wire 
Terminal Strip; I/O Building—Termination Rack—3 Wire Terminal Strip w/ground and I/O Cabinet—Electrical 
Recorder. 

3 Click Connector and connect the components together as you want. 
Connect points have been placed on each component where typical connections can be made.

4 Edit attributes.
Some components have attributes associated with them that change the text associated with them. Select the
component, and change the attributes you want to change in the Symbol Explorer. The text labels are 
updated to display the input values.

The following symbol sets to aid in control loop diagramming.
Content Description 

Control Loop Diagrams Control Loop symbols categorized into 
the following groupings: Controllers, Flow 
Elements, Indicators, Positioners, 
Recorders, Switches, Temperature 
Elements, Terminal Strips, Transmitters 
and Valves.



Atlas Mapping Templates Overview
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You use these templates to produce maps. 
Imperial Template—This template has imperial units in decimal inches, ANSI sheet sizes, ANSI 

dimensioning, and Arial text.
Metric Template—This template has metric units in millimeters, ISO sheet sizes, ISO dimensioning, and Arial

text.

Atlas Map symbols for the United States are available in the Symbol Explorer for these templates. The Draw 
toolbar containing tools to create maps appears on the left of the drawing window.    

Mapping Workflow
Tip  You can create maps with Maintain Relationships set on or off. 
1 Set up the sheet.

Select an appropriate sheet size. The default scale is 1:1.
2 Draw the map.

Place map symbols by using the mouse to drag from the Symbol Explorer. While dragging a symbol for 
placement, use the left/right arrow keys on the keyboard to rotate the symbol dynamically before placement. 
Use the up/down arrow keys to select different drag points on the symbol before placement. If you press the 
Alt key during symbol placement, the alignment indicators are temporarily disabled, allowing symbol 
placement with grid snap or visual alignment.
You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 
Ctrl key and use the left mouse button to place multiple copies of the symbol.

When you drag and pause a symbol over an existing map symbol drop point, a tool tip appears, identifying the
state to be placed adjacently. Dropping the symbol on the drop point ensures that the state boundaries match 
perfectly. 

3 Place text.
Double-click symbols to place text in the center of the symbol. The active text settings in the file are used. 
To highlight existing text for properties editing or moving, pause the pointer over text until the PickQuick 
indicator appears. Then click and select the numbered box that represents the text. Right-click on the 
highlighted text to edit properties. 
To move the highlighted text, click the green lock to unlock. Move the text to a new position. Note that text is 
entered in paper units regardless of the sheet scale.

4 Finish the drawing.
Finish the map by drawing details, adding text, or modifying the symbols to enhance the map.

The following symbol sets aid in drawing maps.
Content Description 

\Program Files\
SmartSketch
\Symbols\Diagramming
\Atlas Map\US States

United States Map symbols. These 
symbols have drag points as well as 
special behaviors for enhanced 
placement and modification.



Templates Overview
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A template is used as a starting point in creating a document. A template is a file that provides tools such as text, 
formats, geometry, dimensions, units of measurement, toolbars, and styles that are used to produce a new 
document that uses a specified format. 

The template that you use depends on the type of information you want to put in the document. For example, if 
you want to create a drawing that contains a schematic of an electrical component, you can use an electrical 
schematic template.

When you base a document on a particular template, that template automatically points to the symbols that you 
would most likely use for that type of document. The Symbol Explorer displays the appropriate symbol set for 
the task.

When you select a specific template, tools are available that allow you to create either a schematic diagram or a 
precision drawing.

Schematic diagrams are primarily created using symbols, connectors, and text at a 1:1 scale. Schematic 
diagrams do not represent a logical flow. The Schematic toolbar is available when you select a template 
designed to create a schematic diagram.

Precision drawings represent physical elements such as lines, arcs, curves, and rectangles that you draw 
precisely with the Draw toolbar. Precision drawings are created at real-world scale, and you can maintain 
relationships between elements in precision drawings.



Directional Mapping Templates Overview
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You use these templates to produce directional maps. 
Imperial Template—This template has imperial units in decimal inches, ANSI sheet sizes, ANSI 

dimensioning, and Arial text.
Metric Template—This template has metric units in millimeters, ISO sheet sizes, ISO dimensioning, and Arial

text.

Directional Map symbols are available in the Symbol Explorer for these templates. The Draw toolbar containing
tools to create maps appears on the left of the drawing window.    

Directional Mapping Workflow
Tip    You can create maps with Maintain Relationships set on or off. 
1 Set up the sheet.

Select an appropriate sheet size. The default scale is 1:1.
2 Draw a directional map.

Draw transportation routes, first using the Line/Arc Continuous command or the Curve command. Select 
the command from the Draw toolbar. Select a linestyle such as Rural Road or Railroad.

When you use the Line/Arc Continuous command, click A on the keyboard to draw an arc. To turn line 
mode back on, click L on the keyboard.

When you use the Curve command, press the left mouse button as you draw.
You can label transportation routes by double-clicking the line and typing the name of the road or railroad. 

The text automatically aligns to linear elements.
3 Place symbols.

Place directional map symbols to represent landmarks by dragging from the Symbol Explorer. 
While dragging a symbol, use the left/right arrow keys on the keyboard to rotate the symbol dynamically 
before placement. Use the up/down arrow keys to select different drag points on the symbol before 
placement. If you press the Alt key during symbol placement, the alignment indicators are temporarily 
disabled, allowing symbol placement with grid snap or visual alignment.
You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 
Ctrl key and use the left mouse button to place multiple copies of the symbol.

4 Place text.
Double-click symbols or lines to place text. 
The active text settings in the file are used. To highlight existing text for repositioning or editing text properties 
or moving properties, pause the pointer over text until the PickQuick indicator appears. Then click and select 
the numbered box that represents the text. 
Right-click the highlighted text to edit properties. 
To move the highlighted text, click the green lock to unlock. Move the text to a new position. Note that text is 
entered in paper units regardless of the sheet scale.

5 Finish the map.
Draw details and modify the color or linestyles of the symbols to enhance the map.

The following symbol sets aid in drawing directional maps.
Content Description 

\Program Files\
SmartSketch
\Symbols\Diagramming
\Directional Map

Directional Map symbols have special 
behaviors for enhanced placement and 
modification.





Architectural Templates Overview
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You use these precision templates to produce architectural designs and drawings according to accepted industry
standards. 

Architectural (Imperial)—This template has imperial units in feet and inches, ANSI and architectural sheet 
sizes and borders, architectural fill styles, and provides symbols based on AIA standards for residential and 
commercial designs.

Architectural (Metric)—This template has metric units in meters and centimeters, ISO standard architectural 
sheet sizes and borders, architectural fill styles, and provides symbols based on AIA standards for residential and 
commercial designs.

The ANSI, DIN, BSI, ISO, and JIS dimensioning standards are also available in these templates. When you open
these templates, the Draw toolbar appears, containing tools to help you create precision drawings.

Production Drafting Workflow for Floor Plans

You can produce full sets of production drawings according to the AIA standards. 
1 Set up the sheet.

Select an appropriate sheet size and scale that allow you to draw the design. The default scale is 1/4" = 1', 
which is appropriate for the average plan on a D-Size sheet.

2 Select a border or create one.
The Architectural templates are delivered with ten border sizes. Select the borders from the Sheet Setup 
command on the File menu so that they appear in the current design. On the Background tab, select the 
background sheet to display with the working sheet. Use the Select Tool to position the graphics 
appropriately in the border.
Note    The borders were designed from guidelines from the Construction Specifications Institute (CSI).

3 From the View tab on the Options dialog box, set the grid settings to Grid style to Static, Grid spacing to 1, 
and Grid index to 1. 

4 Draw the perimeter walls.
Workflow A:    Draw the approximate perimeter walls of the floor plan, using the Place Doubleline and 
SmartSketch commands. Use the Trim, Trim to Corner, and Extend to Next commands for any intersection
cleanup between elements where walls overlap or do not intersect cleanly.
Workflow B:    Verify on the Tools menu that Maintain Relationships is set on. Draw the approximate 
perimeter walls of the floor plan, using the Place Doubleline, SmartSketch Settings, and PinPoint 
commands. Then adjust the distance between walls (doubleline graphics) using the Select Tool on the Draw 
toolbar to make precision distances with the PinPoint command. Use the Trim, Trim Corner, and Extend to 
Next commands for any intersection cleanup between elements. 

Short cut keys F9 and F12 for PinPoint are useful when you draw walls.
Avoid trimming for openings, doors, or windows.
Press and hold the Shift key while using the Place Doubleline command; this action prevents a beginning 

or end cap from being placed. (Pressing and holding the Shift key while using the Place Doubleline command is 
useful for tracing.)

5 Draw the interior walls.
Using the same techniques and commands you used to draw the perimeter walls, add the appropriate interior 
walls and adjust accordingly. 

6 Place door and window symbols.
Using the Symbol Explorer, select the Doors folder from the Plan Symbols folder in the tree view. Drag the 
door symbols onto the represented wall elements, and use the bold parameters that appear in the Attribute 
Viewer to change the size of the door and the handles that appear to orient the door to the position you want. 
Repeat the same steps you used to place doors for placing windows and all other types of symbols.
You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 



Ctrl key and use the left mouse button to place multiple copies of the symbol.
7 Annotate the drawing.

Use text and dimensioning commands to annotate the drawing. Text is entered in paper units regardless of 
the sheet scale. To label windows and doors, use the labels that automatically appear on symbols when you 
double-click them. Or use labels provided in the Label directory in the Plan Symbols directory.

The following symbol sets aid in production drafting.
Content Description 

Elevation Symbols Symbols of typical elevation view 
content based on AIA standards and 
other common designs.

Plan Symbols Symbols of typical plan view content 
based on AIA standards and other 
common designs. Some symbols such 
as doors and windows can be modified 
by parameters that appear when the 
symbols are placed.



 Basic Diagramming Templates Overview
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You use these templates to produce business diagrams. 
Imperial Template—This template has imperial units in decimal inches, ANSI sheet sizes, ANSI 

dimensioning and ANSI text.
Metric Template—This template has metric units in millimeters, ISO sheet sizes, ISO dimensioning, and ISO 

text.

Basic diagramming symbols are available in the Symbol Explorer for these templates. The Schematic toolbar 
containing tools to create diagrams appears on the left of the drawing window. 

Setting Up a Basic Diagram
Tip    You can create business diagrams with Maintain Relationships set on or off. 
1 Set up the sheet.

Select an appropriate sheet size and scale that allow enough paper space to draw. The default scale is 1:1.
2 Prepare to draw.

Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid Display, and Grid Snap 
commands. 
For more grid options click the View tab on the Options dialog box to set the grid style to either dynamic or 
static, and set the static grid to the preferred grid spacing. 

These settings provide visual feedback to you to improve the workflow while you draw. To create clean 
diagrams, use Grid Snap with a static grid displayed.

Placing symbols and connectors on a static grid produces high quality results. 
You can set grid display and snap by right clicking.

Simple Diagramming Workflow
1 Drag symbols from the Symbol Explorer.
2 Use the Connector command to connect symbols.
3 Double-click each symbol to add text.

Optimal Diagramming Workflow
1 Place basic diagramming symbols by using the mouse to drag from the Symbol Explorer. 

While dragging a symbol, use the left/right arrow keys on the keyboard to rotate the symbol dynamically 
during placement. 
Use the up/down arrow keys to select different drag points on the symbol before placement. 
If you press the Alt key during symbol placement, the alignment indicators are temporarily disabled, allowing 
you to place a symbol using grid snap or visual alignment. 
You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 
Ctrl key and use the left mouse button to place multiple copies of the symbol.

2 Connect the symbols by using the Connector command. 
When drawing connectors, you should set Clearance. Type the minimum distance from the symbols that you 
would like the first turn in the connectors to occur. This action allows you to control the visual consistency of 
connectors that make right-angle turns just before they attach to a symbol.
When you draw a connector to a symbol, approach the symbol from the direction you want the connector 
placed. As the pointer intent zone nears the symbol, suggested targets for the connector appear. 
The connector end point can be located on a target or any other symbol geometry. 
If you press the Alt key while drawing a connector, the diagonal drawing mode will be temporarily activated, 
allowing the connector to be drawn at any angle with or without grid snap. 

3 Place text.



Double-click symbols to place text in the center of the symbol. 
The active text settings in the file are used. 
To highlight existing text for properties editing or moving, pause the pointer over text until the PickQuick 
indicator appears. Then click and select the numbered box that represents the text. 
Right-click on the highlighted text to edit properties. 
To move the highlighted text, click the green lock to unlock. Move the text to a new position. Note that text is 
entered in paper units regardless of the sheet scale. 

4 Finish the diagram.
Use color to modify the symbols and connectors to enhance the drawing. 

The following symbol sets are aid in drawing diagrams.
Content Description

\Program Files\
SmartSketch
\Symbols\Diagramming
\Basic

Common business diagramming 
symbols. You can double-click these 
symbols to place text. These symbols 
also have special behaviors for 
enhanced placement and modification.



 Site Templates Overview
{button Related Topics,AL("properties cmd;properties db;document cmd;drawing sheet high;paper high;styles 
high",0,`NOT_FOUND')} {button How To,AL("properties how;open how;document 
how",0,`NOT_FOUND')}

You use these precision templates to produce site designs and drawings according to accepted industry 
standards. 

Site (Imperial)—This template has imperial units in feet and inches, ANSI and architectural sheet sizes and 
borders, and architectural fill styles. It also provides symbols based on AIA standards for residential and commercial 
designs.

Site (Metric)—This template has metric units in meters and centimeters, ISO standard architectural sheet 
sizes and borders, and architectural fill styles. It also provides symbols based on AIA standards for residential and 
commercial designs.

The ANSI, DIN, BSI, ISO, and JIS dimensioning standards are also available in these two templates. When you 
open these templates, the Draw toolbar appears, containing tools to help you create precision drawings.

Production Drafting Workflow for Site Designs

You can produce full sets of production drawings according to the AIA standards.
Tip    To produce a fairly complex production drawing, you should set Maintain Relationships off. 
1 Set up the sheet.

Select an appropriate sheet size. The default scale is 1/4" = 1', which is appropriate for the average plan on a 
D-Size sheet.

2 Reference a floor plan or open one.
Reference a floor plan by using the Object command on the Insert menu or by dragging and dropping in the 
reference file. Or click the Open command to open (translate) the file.
Tip    Any MicroStation, AutoCAD, dxf, or igr document can be a reference file. 

3 Create a foot print.
If you reference the plan, using the drawing tools on the Draw toolbar, you can trace the outer perimeter of 
the reference plan to create the outline shape of the building. Either delete or move the reference file to a 
layer and turn it off.    

4 Place symbols.
Drag the landscape symbols into the document in the appropriate positions. 
You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 
Ctrl key and use the left mouse button to place multiple copies of the symbol.

5 Annotate the drawing.
Use text and dimensioning to annotate the drawing. Text is entered in paper units regardless of the sheet 
scale. To label site symbols, use the labels that automatically appear on symbols when you double-click them.

6 Select a border or create one.
The Site templates are delivered with ten border sizes. Select the borders with the Sheet Setup command so 
that they appear in the current design. On the Background tab of the Sheet Setup dialog box, select the 
background sheet to display with the working sheet. You should use the Select Tool to position the graphics 
appropriately in the border.
Note    The borders were designed from guidelines from the Construction Specifications Institute (CSI).

The following symbol sets aid in production drafting.
Content Description 

Elevations Symbols Provide AIA and Intergraph standard 
elevation symbols for commercial and 
residential Site design.    

Plan Symbols Provide AIA and Intergraph standard 



plan symbols for commercial and 
residential Site design.



Plot Plan Templates Overview
{button Related Topics,AL("properties cmd;properties db;document cmd;drawing sheet high;paper high;styles 
high",0,`NOT_FOUND')} {button How To,AL("properties how;open how;document 
how",0,`NOT_FOUND')}

You use these precision templates to produce plot plan and equipment layout drawings. 
Plot Plan (Imperial) Template—This template has imperial units in decimal inches, ANSI sheet sizes and 

borders.
Plot Plan (Metric) Template—This template has metric units in millimeters, ISO sheet sizes and borders, and

implements the ISO dimensioning.

The DIN, BSI, and JIS dimensioning standards are also available in these two templates. When you open these 
templates, the Draw toolbar appears, containing tools to help you create precision drawings.

Plot Plan Workflow

You can draw plot plans associatively or non-associatively. The default behavior is non-associative. To draw the 
plot plan associatively, set Maintain Relationships on.
1 Set up the sheet.

Select an appropriate sheet size. The default sheet scale is 1 in:100 ft. for imperial and 1mm:1000mm for 
metric.

2 Sketch the layout.
Draw the geometry for roads, buildings or equipment, using the tools from the Draw toolbar and SmartSketch
Settings. As you draw, relationships are established that capture your design intent. As an example, with 
Maintain Relationships set on, the software remembers when you draw a line horizontally, vertically, or 
parallel to another line and maintains that information when you modify the drawing.

3 Drag any symbols that are needed for the drawing. 
You can place symbols precisely, relative to other components using PinPoint or the precision Move 
command.

4 Dimension the part.
Use SmartDimension and the other dimensioning tools to dimension the layout. If Maintain Relationships is
set on, these dimensions are driving dimensions that can be changed to iterate your design. Redundant 
dimensions are shown through the driven elements. 

5 Finish the drawing.
Select individual dimensions and change the values to iterate your design. 

The following symbol sets aid in construction of plot plan drawings.
Content Description 

Plot Plan Assorted symbols to aid in the 
construction of Plot Plans. Symbols 
include direction arrow, buildings, 
vessels, tanks, vehicles, and others. 
Some of the symbols are parametric 
and can be changed in the content 
explorer.



 Process Block Diagramming Templates Overview
{button Related Topics,AL("properties cmd;properties db;document cmd;drawing sheet high;paper high;styles 
high",0,`NOT_FOUND')} {button How To,AL("properties how;open how;document 
how",0,`NOT_FOUND')}

You use these templates to produce process block diagrams. 
Imperial Template—This template has imperial units in decimal inches, ANSI sheet sizes, ANSI 

dimensioning and ANSI text. 
Metric Template—This template has metric units in millimeters, ISO sheet sizes, ISO dimensioning, and ISO 

text. 

Basic Diagramming symbols are available in the Symbol Explorer for these two templates. The Schematic 
toolbar containing tools to create diagrams appears on the left of the drawing window. 

Setting Up a Process Block Diagram
Tip You can create block diagrams with Maintain Relationships set on or off. It is suggested that you accept the
default, Maintain Relationships set off. 
1 Set up the sheet.

Choose an appropriate sheet size and scale that allow enough paper space to draw. The default scale is 1:1.
2 Prepare to draw.

Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid Display, and Grid Snap 
commands. For more grid options, click the View tab on the Options dialog box to set the grid style to either 
dynamic or static, and set the static grid to the preferred grid spacing. 

These settings provide visual feedback to you to improve the workflow while you draw. To create clean 
diagrams, use Grid Snap with a static grid displayed.

Placing symbols and connectors on a static grid produces high quality results. 
You can set grid display and snap by right clicking.

Drawing a Simple Diagram
1 Drag symbols from the Symbol Explorer.
2 Use the Connector command to connect symbols.
3 Double-click each symbol to add text.

Drawing an Optimal Diagram
1 Place basic diagramming symbols by using the pointer to drag from the Symbol Explorer. 

Place multiple copies of a symbol by using the right mouse button to drag and by selecting the Stamp Here 
option. 
While dragging a symbol for placement, use the left/right arrow keys on the keyboard to rotate the symbol 
dynamically before placement. Use the up/down arrow keys to select different drag points on the symbol 
before placement. 
If you press the Alt key during symbol placement, the alignment indicators are temporarily disabled, allowing 
symbol placement with grid snap or visual alignment. 

2 Connect the symbols by using the Connector command. 
When you draw a connector that is not straight, you should set Clearance: to the minimum distance from the 
symbol so that the first turn in the connector appears. 
When you draw a connector to a symbol, approach the symbol from the direction you want the connector 
placed. As the pointer intent zone nears the symbol, suggested targets for the connector appear. 
The connector end point can be located on a target or any other symbol geometry. If you press the Alt key 
while drawing a connector, the alignment indicators are temporarily be disabled, allowing the connector to be 
drawn with or without grid snap.

3 Double-click symbols to place text in the center of the symbol. 
The active text settings in the file are used. To highlight existing text for properties editing or moving, pause 
the pointer over text until the PickQuick indicator appears. 
Then click and select the numbered box that represents the text. Right-click on the highlighted text to edit 
properties. 
To move the highlighted text, click the green lock to unlock. Then with the pointer drag the text to a new 
position. Note that text is entered in paper units regardless of the sheet scale.



4 Finish the diagram.
Use fills and modify the elements in symbols and connectors to enhance the drawing.

The following symbol sets aid in drawing diagrams.
Content Description 

Process Block 
Diagrams

Common Basic diagramming symbols. 
You can double-click these symbols to 
place text. These symbols also have 
special behaviors for enhanced 
placement and modification.



Technical Drawing Templates Overview
{button Related Topics,AL("properties cmd;properties db;document cmd;drawing sheet high;paper high;styles 
high",0,`NOT_FOUND')} {button How To,AL("properties how;open how;document 
how",0,`NOT_FOUND')}

You use these templates to produce technical drawings, sketches, and illustrations. 
Imperial Template—This template has imperial units in decimal inches, ANSI sheet sizes, ANSI 

dimensioning and ANSI text.
Metric Template—This template has metric units in millimeters, ISO sheet sizes, ISO dimensioning, and ISO 

text.

A set of simple drawing elements is also available in the Symbol Explorer for these templates. The Draw 
toolbar containing tools to create precision drawings appears on the left of the drawing window.    

Drawing/Sketching Workflow
Tip    You can create technical drawings with Maintain Relationships set on or off. 
1 Set up the sheet.

Select an appropriate sheet size and scale that allow you to enough paper space to draw. The default scale is
1:1. 

2 Draw elements.
Use the tools on the Draw toolbar and the SmartSketch Settings command or drag symbols available in the 
Symbol Explorer. 
Place multiple copies of symbols by using the right mouse button to drag and by selecting the Stamp Here 
option, or by pressing the Ctrl key while dragging a symbol from the Symbol Explorer. 
If Maintain Relationships is set on, relationships between drawn objects are established. As an example the 
system remembers when you draw a line horizontally, vertically, or parallel to another line and maintains that 
information when you modify the drawing. 
You can use the Trim, Extend to Next, and Fillet commands to efficiently modify drawn geometry. 

3 Annotate the drawing.
Use text, dimensioning, and labels to annotate the drawing. Double-clicking on any drawn object (except fills, 
dimensions, and leaders) creates an associative text box. Note that text is entered in paper units regardless of
the sheet scale.

4 Finish the drawing.
Use patterns and fills and modify the symbols to enhance the drawing. 

The following symbol sets aid in production drafting.
Content Description 

\ProgramFiles\
SmartSketch\Symbols\
Drawing

Commonly drawn elements such as 
line, rectangle, ellipse, circle, and 
others are provided to quickly begin a 
drawing. These symbols become 
drawing elements when placed so they
are easily edited along with drawn 
elements.



ActiveCGM®
{button Related Topics,AL("save high;documents high;save as HTML cmd",0,`NOT_FOUND')} {button How 
To,AL("save how",0,`NOT_FOUND')}

If you want to place a SmartSketch document on an HTML page for viewing on the Web, you can save the 
document to .cgm format. Computer Graphic Metafile (cgm), a standard file format for vector and raster data, is 
an ideal format for publishing 2D vector drawings on the Web. This format requires little storage space, displays 
quickly in a web browser, and has the ability to zoom and display more detail. cgm documents can also contain 
embedded hotspots, hyperlinks, and database links, allowing you to access information outside the document 
instantly. 

You can save a document as a .cgm graphic embedded in a web page with the Save As Web Page command 
on the File menu. You can also save to .cgm with the Save As command.

Definition of cgm

cgm supports the definition of graphic objects bound to non-graphic attributes. The cgm file format is defined by 
ANSI/ISO 8632-1992 (American National Standards Institute/International Standards Organization) and MIL-
STD-2301 (Military Standard). cgm is the international standard that defines a hybrid (raster, vector, and text) 
graphics format. Definition of graphical objects is supported at any arbitrary level of abstraction through a tagging
mechanism similar to SGML and HTML.

Definition of ActiveCGM

ActiveCGM® technology converts 2D design files, such as construction drawings, into cgm files to link non-
graphical data into graphical elements.    For example, you can navigate an intelligent drawing using a Web 
browser. ActiveCGM provides rapid, accurate, enterprise-wide access and display of graphic information. It 
allows hyperlinking of vector and raster graphics defined in the Version 4.0 Computer Graphics Metafile format. 
ActiveCGM products based on ActiveCGM technology support zooming, panning, magnification, navigation of 
cgm graphics.



Drawing Doublelines
{button Related Topics,AL("draw high;line cmd;dubline cmd",0,`NOT_FOUND')} {button How To,AL("dubline 
how",0,`NOT_FOUND')}

You can use the Place Doubleline command to place a doubleline as you draw and clean corners as you place 
the lines. This command is very useful in drawing an architectural floor plan for a house or a factory. 

Place Doubleline also miters joints and trims as it you draw. It puts endcaps on single lines.

On the Place Doubleline toolbar, you can define the thickness of the doubleline and whether you draw the 
doubleline from the left, right, or center. 



Reports
{button Related Topics,AL("symbols high;attributes high",0,`NOT_FOUND')} {button How To,AL("report 
how",0,`NOT_FOUND')}

The software delivers some reports that you can update automatically when you add symbols to a document. 
The reports work with symbols that have specific attributes assigned to them. You must have Microsoft® Excel™ 
97 or later installed on your computer. The software includes several sample reports. 

When you open a template, that specific template displays a default directory of symbols in the Symbol 
Explorer. You can find reports in the Reports directory of the default symbol directory. Examples that you can 
drag into your document include the following reports:

Network Reports—In the Network template, you can drag in reports listing network equipment contacts and 
reports inventorying equipment.

Process Reports—In the Process Flow template, you can drag in heat exchanger, pump and tower 
equipment reports and a stream report.

The software prompts you to update the report when you add it to a document. After you add more symbols to 
the document, you can update the existing report by double-clicking it. 



Adding Additional Tools to the Software
{button Related Topics,AL("add-ins included high;add-ins cmd",0,`NOT_FOUND')} {button How 
To,AL("add-in how",0,`NOT_FOUND')}

Add-ins are commands or functions that add special capabilities the software. To install an add-in, choose the 
Add-Ins command from the Tools menu. After you install an add-in, its commands or functions become an 
integrated part of the software until you remove the add-in.



Annotations
{button Related Topics,AL("text cmd;leader cmd;engineering fonts high;vector fonts high;texthand 
high;Dimensions high",0,`NOT_FOUND')} {button How To,AL("create text box how;balloon how;leader 
how;Dimensions how",0,`NOT_FOUND')}

An essential part of the drawing process is adding text, notes, and annotations. Annotations are text and 
graphics that give information about a drawing. You can add this information quickly and easily with the text and 
annotation commands in the software. 

To place annotations in a document, you can click one of the following buttons:
Text Box button on the Draw toolbar

Balloon button on the Dimension toolbar
 

Tip      For more information about adding associative text to a document, click the Related Topics button or 
How To button.

Annotations with Leaders

When you create a balloon, you can place it with a leader by setting options on the ribbon bar. The leader can 
point to another element or be placed in free space. Annotations with leaders have the following components:
 

(A) Leader line
(B) Break line
(C) Terminator
(D) Annotation

You can manipulate the annotation by selecting the leader and moving parts of it. You can control the display of a
leader break line and terminator and insert or delete vertices on a leader.

Adding Leaders

You can add a leader to an annotation with the Leader command. An annotation can have more than one leader.
The terminator end of the annotation can point to an element or be placed in free space. The annotation end of a
new leader must connect to an annotation or the leader on an annotation.

 

You can create a callout by placing a text box and adding a leader to it with the Leader command.

Annotations and Associations

Annotations can be associative or non-associative. An associative annotation moves when its associated 



element moves. Text boxes differ from the other annotations in that they are always non-associative. 

If you attach the terminator of a leader to an element, the annotation moves with the element.

 

If you point the terminator of a leader to free space, the annotation is not associative to any element in the 
drawing. To make an annotation associative, you can select the terminator of the leader and drag it to an 
element.

Formatting Annotations

You can format an annotation several ways. If you want several annotations to look the same, you can apply a 
style by selecting it on the ribbon bar. You can apply dimension styles to balloons, but not text boxes. You can 
apply text styles to text boxes.
Tip  If you want to format an existing balloon, you must click the balloon leader to select the balloon. Then, you 
can change the formats of the balloon.

If you want annotations to look unique, you can select an annotation and edit its properties with the ribbon bar or 
the Properties command on the Edit menu.



Moving Elements
{button Related Topics,AL("draw high;relationships high;change cmd;move cmd",0,`NOT_FOUND')}

{button How To,AL("move how",0,`NOT_FOUND')}

You can move elements on the drawing sheet with one of several methods: 
Dragging elements with the Select Tool.
Specifying precision points with the Move button on the Change toolbar.

Tip    You can also click the Scale and Rotate buttons on the Change toolbar to move elements.

Using the Select Tool

To move an element, you must first select it with the Select Tool on the Draw toolbar. You can drag the selected 
element to move it without changing its shape.

Tip    The element's handles do not need to be displayed for you to move it. If they are displayed, and you want 
to move the element and not modify it, position the pointer so it is not over a handle.

You can move an element with precision if you use the relationships indicators.

When you modify a drawing, elements with maintained relationships automatically update to honor the 
relationship. For example, if you move an element that shares a maintained parallel relationship with another 
element, the other element moves as needed to remain parallel. If a line and an arc share a maintained tangent 
relationship, they remain tangent when either is modified.

Moving Elements by Specifying Precision Points

You can move a line that shares a tangent relationship with an arc if you select the line and click the Move button
on the Change toolbar. As you move the line, the line moves without maintaining the relationship with the arc. 
You can then specify a from point and a to point by clicking on the drawing sheet or by entering values in the 
ribbon bar. You can move any element by specifying precision points with the Move button.



Cutting or Deleting Elements
{button Related Topics,AL("cut cmd;delete cmd",0,`NOT_FOUND')} {button How To,AL("cut how;delete 
how",0,`NOT_FOUND')}

You can delete elements by selecting them and clicking the Cut button on the Main toolbar or by pressing 
Delete. Clicking the Cut button allows you to paste the element in another location. Pressing Delete removes the
element permanently. 

Relationships that are no longer applicable after you delete an element are automatically deleted. For example, if
you delete one of a pair of parallel lines, the parallel relationship is deleted from the remaining line.



Copying Elements
{button Related Topics,AL("draw high;relationships high;copy cmd;select cmd;offset cmd",0,`NOT_FOUND')}

{button How To,AL("copy how",0,`NOT_FOUND')}

You can copy any element, dimension, or object by selecting it and using the Copy button on the Main toolbar. 
Copying places the selected item on the Clipboard. When you click the Paste button on the Main toolbar, the 
item is placed on the drawing sheet. 

You can also copy an element with the Select Tool. You click the Select Tool on the Draw toolbar, select the 
element, and press Ctrl as you drag the element across the drawing sheet. You can also copy several selected 
elements in the same manner.

When you copy elements that have relationships, the relationships are copied and retained when possible. For 
example, if you make a copy of two related lines, the relationship is also copied. However, if you copy one of two 
lines that are related to each other, the relationship is not copied.
Tip    You can also click the Offset, Move, Scale, and Rotate buttons on the Change toolbar to create copies.



Creating Patterns
{button Related Topics,AL("rectangular pattern cmd;circular pattern cmd",0,`NOT_FOUND')} {button How 
To,AL("circular pattern how;rectangular pattern how",0,`NOT_FOUND')}

Patterns are useful if you want to create several elements quickly that are the same without using several 
commands. You can create patterns by selecting one or more elements and making several copies of it with the 
Rectangular Pattern or Circular Pattern button on the Change toolbar. 

To modify individual members of the pattern, you can select an individual member of the pattern and change it 
the way you would any other element.



Dimensions Overview
{button Related Topics,AL("dimension types high;relationships high;smartdimension cmd;dimension groups 
high",0,`NOT_FOUND')} {button How To,AL("dimension how;create variable with value 
how",0,`NOT_FOUND')}

Dimensions supply information about the size, location, and orientation of elements, such as the length of a line, 
the distance between points, or the angle of a line. Dimensions are associative to the elements they refer to, so 
you can make design changes easily. 

 

You can use the commands on the Dimension toolbar to place the following types of dimensions:
(A) Linear dimensions    
(B) Angular dimensions    
(C) Diameter dimensions    
(D) Radial dimensions    
(E) Dimension groups

Dimension commands on the Dimension toolbar have a ribbon bar that sets options for placing the dimension. 
When you select a dimension in the drawing, the same ribbon bar options appear. You can use the options to 
change the selected dimension.

Placing Dimensions

To dimension elements, you can use a dimension command on the Dimension toolbar, such as 
SmartDimension, and then select the elements you want to dimension.

As you place dimensions, the software shows a temporary, dynamic display of the dimension you are placing. 
This temporary display shows what the new dimension will look like if you click at the current pointer position. 
The dimension orientation changes depending on where you move the pointer.

For example, when you click Distance Between on the Dimension toolbar and select an origin element and an 
element to measure to, the dimension dynamically adjusts its orientation depending on where you position your 
pointer.



 

 

Because you can dynamically control the orientation of a dimension during placement, you can place dimensions
quickly and efficiently without having to use several commands. Each of the dimension commands uses 
placement dynamics that allow you to control how the dimension will look before you place it.

Placing Dimensions with the Dimension Axis

The Axis button on the Dimension toolbar sets the orientation of the dimension axis on the drawing sheet. You 
can use the new dimension axis, rather than the default axis of the drawing sheet, while you are using the 
Distance Between or Coordinate Dimension command. You must set the Explicit option on the Dimension 
ribbon bar to place dimensions that are perpendicular or parallel to new dimension axis.

Dimensioning While You Draw

To dimension elements as you draw them, you can set Dimension Keyin Values Automatically with the 
Options command on the Tools menu. Although placing dimensions as you draw is convenient, it might be 
necessary to delete unneeded dimensions when you have finished your design.
Note    Dimensions placed with this option are only driven dimensions.

Using Dimensions to Drive Elements

You can place a dimension that controls the size or location of the element to which it refers. This type of 
dimension is known as a driving dimension. If you use the ribbon bar to change the dimensional value of a 
driving dimension, the element updates.

Dimensions that are not driving dimensions are called driven dimensions. The value of a driven dimension is 
controlled by the element it refers to. If the element changes, the dimensional value updates.

Because both driving and driven dimensions are associative to the element they refer to, you can change the 
design more easily without having to delete and re-apply elements or dimensions when you update the design.

If you want to create a driving dimension, you must first set the Maintain Relationships command on the Tools 
menu. When you are placing dimensions, an option on the ribbon bar allows you to specify whether a dimension 
is driving or driven. A driving dimension and a driven dimension are distinguished by color. There are different 
colors for driving dimensions and driven dimensions in a dimension style.

Not-to-Scale Dimensions

You can override the value of a driven dimension by editing its dimensional value. This makes the dimension not-
to-scale. For example, if you override the dimensional value that is 15 millimeters to be 30 millimeters, the actual 
size of the line that you see would still be 15 millimeters.



Formatting Dimensions

If you want two or more dimensions to look the same, you can select the dimensions and apply a style with the 
ribbon bar. If you want to format dimensions so that they look unique, you can select a dimension and edit its 
formats on the ribbon bar or with the Properties command on the Edit menu.

Using Expressions in Dimensions

There are many instances when the dimensions of individual features in a design are related. For example, the 
bend radius used to manufacture a sheet metal part is usually a function of the stock thickness. You can define 
and automate these types of design relationships with expressions. You can select a dimension and then use the
Variables command on the Tools menu to enter a formula. When the formula is solved, the dimensional value 
changes to the value that the formula calculates. 

You might want to use dimensions with expressions for the following purposes:
Drive a dimension by another dimension; Dimension A = Dimension B
Drive a dimension by a formula; Dimension A = pi * 3.5
Drive a dimension by a formula and another dimension; Dimension A = pi * Dimension B

Setting or Modifying Units of Measure

To set the units of measure for a dimension, you can use the Properties command on the Edit menu. To set the 
units of measure for a document, you can click the Properties command on the File menu and then click the 
Units tab.



Types of Dimensions
{button Related Topics,AL("dimension distance between cmd;dimension length of cmd;smartdimension 
cmd",0,`NOT_FOUND')} {button How To,AL("place dimension how;modify dimension how;use 
smartdimension how",0,`NOT_FOUND')}

A linear dimension measures the length of a line or the distance between two points or elements. You can place 
linear dimensions with the Distance Between and SmartDimension commands. 

An angular dimension measures the angle of a line, the sweep angle of an arc, or the angle between two or more
lines or points. You can place angular dimensions with the Angle Between and SmartDimension commands.

A radial dimension measures the radius of elements, such as arcs, circles, ellipses, or curves.    You can place a 
radial dimension with the SmartDimension command.

A diameter dimension measures the diameter of elements, such as circles and ellipses. You can place a 
diameter dimension with the SmartDimension command.

The components of a dimension are as follows:

 

 

(A) Projection line (E) Break line
(B) Dimension line (F) Symbol
(C
)

Dimensional value (G
)

Connect line

(D
)

Terminator



Dimension Groups
{button Related Topics,AL(`dimension distance between cmd;dimension angle between cmd;dimensions 
high;symmetric diameter cmd;dimension coordinate cmd',0,`NOT_FOUND')} {button How To,AL(`place 
dimension group how;add dimension to group how;place symmetric diameter how',0,`NOT_FOUND')}

You can place dimensions in dimension groups with several commands. This makes the dimensions easier to 
manipulate on the drawing sheet. All members of a stacked or chained dimension group share the same 
dimension axis. 

Stacked dimension group 

Chained dimension group 

A coordinate dimension group is another type of dimension group. Coordinate dimensions measure the position 
of key points or elements from a common origin. All the dimensions within the group measure from a common 
origin. You should use coordinate dimensions when you want to dimension elements in relation to a common 
origin or zero point.

When you are placing dimension groups with the Distance Between or Angle Between commands, the cursor 
position determines what type of dimension group will be placed. After you place the first dimension in a group 
and click the second element you want to measure, if the cursor is below the first dimension, then the dimension 
group will be a chained group.

If the cursor is above the first dimension, then the dimension group will be a stacked group.

You can place dimension groups with the following buttons on the Dimension toolbar:
Distance Between



Angle Between

Symmetric Diameter

Coordinate Dimension



Element Display Priority
{button Related Topics,AL("select high;pull up cmd;push down cmd;send back cmd;bring to 
front",0,`NOT_FOUND')} {button How To,AL("display order how",0,`NOT_FOUND')}

When 2-D elements overlap, their display priority determines which is in front. The first element you draw is 
displayed behind all other elements—it has the lowest display priority. A newly created element is displayed in 
front of all other elements—it has the highest display priority. 

For example, if you draw a circle, then an ellipse, and then a rectangle, the circle is displayed in back. The ellipse
is displayed between the circle and the rectangle, and the rectangle is displayed in front.

Changing the Element Display Priority

You can change an element's display priority by pulling it up one position, pushing it down one position, sending 
it to the back, or bringing it to the front. One click on the striped box changes the display priority. 

You can change the display priority of a group the same way. The display priority of elements within the group 
does not change.



Drawing Basic Elements
{button Related Topics,AL("groups high;smartsketch high;freesketch high;circle high;line high;rectangle 
high",0,`NOT_FOUND')} {button How To,AL("draw how",0,`NOT_FOUND')}

An element is any line, circle, or other part of the drawing. The Draw toolbar on the left side of the drawing sheet 
contains most of the buttons that you can use to draw any type of basic geometric element—freeform shapes, 
lines, arcs, circles, and so forth. 

 

You can place most basic elements with just a few clicks. For example, if you want to place a line, you can click 
the Line/Arc Continuous button on the Draw toolbar. Then, you click two points to indicate where to start and 
finish the line. If you do not want to place another line, you click the right mouse button to end the operation. 
Tip    Clicking the right mouse button ends most operations in the software.

You can also place the line by clicking the Line/Arc Continuous button and then clicking and dragging the 
pointer. When you release the mouse, the line appears on the drawing sheet. With this method, you drag the 
cursor as if it were a pen. You can draw most elements, such as rectangles, circles, and arcs, with this method, 
sometimes called mouse-down drawing. The mouse-down method is typically used to place most elements in 
conceptual sketching and modification.

If you want to place a precise line, you can click the Line/Arc Continuous button, type values into the ribbon bar
that appears, and then press Enter. You can then click on the drawing sheet to place the line. This method, 
sometimes called mouse-up drawing, is typically used for precision placement and when you want to draw 
elements that are related to each other.

In some cases, you might want to click points on the drawing sheet and type values in the ribbon bar to place an 
element. For example, you can click the Line/Arc Continuous button and then type 3.0 in the Length box on 
the ribbon bar box and press Enter to lock the length value.

 

When a line that is three inches long appears next to the pointer, you can click anywhere on the drawing sheet to
indicate where to place one end of the line. Then, you move the line around and click again to set the line's 
orientation angle.

If you do not like the results of what you drew, you can click the Undo button on the Main toolbar. If you want to 
repeat an action, you click the Redo button on the Main toolbar. 

                                                                                                                                  



Drawing Lines
{button Related Topics,AL("draw high;line cmd",0,`NOT_FOUND')} {button How To,AL("line 
how",0,`NOT_FOUND')}

If you want to place a line, you click the Line/Arc Continuous button on the Draw toolbar. Then, you click a 
point on the drawing sheet to indicate where to start the line. You click a second point to indicate where to end 
the line. If you do not want to place another line, you click the right mouse button to end the operation.

You can also place the line by clicking the Line/Arc Continuous button and then clicking and dragging the 
pointer. When you release the mouse, the line appears on the drawing sheet. 

If you want to place a precise line, you can click the Line/Arc Continuous button, type values into the ribbon bar
that appears, and then press Enter. You then click on the drawing sheet to place the line.

You can also use a combination of clicks and ribbon bar input to place the line. For example, you can type a line 
length in the ribbon bar box to lock the length value and then set the line's orientation angle graphically. You can 
set the color and line type by clicking a style in the Style list box.

 



Drawing Circles, Arcs, and Ellipses
{button Related Topics,AL("circle cmd;arc cmd;ellipses cmd;draw high",0,`NOT_FOUND')} {button How 
To,AL("circle how;arcs how;ellipses how",0,`NOT_FOUND')}

If you want to draw a circle, you can click the Circle By Center Point button on the Draw toolbar. Then, you click
a point to define the center of the circle. To place the circle, you click a second point to define the distance of the 
circle radius from the first point. You can use other commands on the Draw toolbar to place arcs, ellipses, and 
other types of circles. 

 
 

Besides clicking the pointer, you can also place circles by clicking the Circle By Center Point button and then 
holding the mouse button down and drawing freehand. After you close the loop, the circle appears. 

You can also place a precise circle by clicking the Circle By Center Point button and then typing values into the 
ribbon bar. After you press Enter, a circle appears around the pointer. You can then place the defined circle by 
clicking the point you want on the drawing sheet.



Drawing Squares and Rectangles
{button Related Topics,AL("draw high;rectangle cmd",0,`NOT_FOUND')} {button How To,AL("rectangle 
how",0,`NOT_FOUND')}

To draw a rectangle or square, you click the Rectangle button on the Draw toolbar. Then, you click two different 
points to define the rectangle. If you want to precisely define the dimensions of the square, you can type values 
into the ribbon bar and press Enter. 

If you place dimensions on a rectangle, these are always driven dimensions. This means that if you edit the 
dimensional value of the dimension, the rectangle does not change. You need to edit the values on the rectangle 
ribbon bar to change the rectangle. Also, you cannot ungroup a rectangle into individual lines.

Tip    If you want to place a rectangle that has driving dimensions, you need to place four separate lines in the 
shape of a rectangle by selecting the Line/Arc Continuous button on the Draw toolbar.



Drawing FreeForm Shapes
{button Related Topics,AL("draw high;freesketch cmd;freeform cmd",0,`NOT_FOUND')} {button How 
To,AL("freesketch how;freeform how",0,`NOT_FOUND')}

As you draw, you can place precisely defined lines, arcs, and circles by clicking and typing values in the ribbon 
bar. You can also use tools to quickly sketch a design and let the software convert it into a precision drawing. 

FreeSketch and FreeForm allow you to quickly place fluid lines and let the software convert these into precision 
shapes. FreeSketch draws lines, arcs, circles, and rectangles, and FreeForm draws curves (splines).
 

You can begin sketching anywhere on the drawing sheet. You can draw in free space or use key points or end 
points of elements as reference points.

How FreeSketch and FreeForm Work

As you drag the pointer, a rough sketch of your design appears. When you release the pointer, the software 
recognizes the shapes in your sketch and turns the sketch into a precise drawing. You can control the accuracy 
of the shape recognition using the ribbon bar options.

FreeSketch and FreeForm Options

The FreeSketch Adjust options control how closely FreeSketch interprets mouse movements. When Adjust 
On is set, the software interprets all lines as either horizontal or vertical, and all arcs as tangent. The first figure 
shows how the software interprets a rough sketch when Adjust On is set.

The next figure shows how the software interprets a rough sketch when Adjust Off is set.

The FreeForm Smoothing options controls how closely the software interprets mouse movements when 
drawing curves. The first figure shows how FreeForm interprets a rough sketch when Smoothing On is set.

The next figure shows how the software interprets a rough sketch when Smoothing Off is set.



Variables
{button Related Topics,AL("variables cmd;variable table db;using variables high;arguments 
high",0,`NOT_FOUND')} {button How To,AL("variables how",0,`NOT_FOUND')} {button Show 
Me,AL("using variables ex",0,`NOT_FOUND')}

You can use the Variable Table to define and edit functional relationships between the dimensions of a design in 
a familiar spreadsheet format. The Variable Table is accessed with the Variables command on the Tools menu. 
There are two types of variables: dimensions displayed in the design and variables you create directly in the 
Variable Table. Dimension variables directly control elements of a design. A user variable must be set equal to a 
value or mathematical expression; for example, PI = 3.14159. 

You can use variables to do the following:
Drive a dimension with another dimension; Dimension A = Dimension B
Define a constant; pi=3.14
Drive a dimension with a formula; Dimension A = pi * 3.5
Drive a dimension with a formula and another dimension; Dimension A = pi * Dimension B
Drive a dimension with a formula that includes a function;    Dimension A = Dimension B + cos(Dimension C)
Drive a dimension with a value from a spreadsheet, such as a Microsoft Excel document, by copying the 

value from the spreadsheet into the Variable Table. Besides Excel, you can use any other spreadsheet software that 
can link or embed objects.

Drive a dimension with a value from a spreadsheet, such as a Microsoft Excel document, by copying the 
value from the spreadsheet into the Variable Table. Besides Excel, you can use any other spreadsheet software that 
can link or embed objects.

Accessing the Variable Table

Once you select the Variables command on the Tools menu, a table appears with the following columns:    Type,
Name, Value, and Formula. Each row of the table displays a variable.

Entering Data into the Variable Table

When you open the Variable Table in the document, all the dimensional values for the dimensions on the 
drawing sheet appear in the columns. The name that appears in the Name column is automatically generated by 
the software. You can change the name to something more logical if you want. 

Restricting the Display of Variables

You can restrict the display of variables in the table with the Filter button on the Variable Table window:
You can display only the variables for dimensions that the software created. 
You can also display variables that are associated with elements in the current document or the active 

window
You can also display a set of elements that you have selected in the document.

Creating Expressions

The system provides a set of standard mathematical functions. The functions can be typed in with the proper 
syntax or you can use the Function Wizard to select and define the function. The Function Wizard is 
convenient when you forget the proper syntax for a math function. You start the Function Wizard by clicking the 
Fx button in the Variable Table. The function is written in the Formula column of the selected row.

Examples

Suppose you draw a sheet metal bracket and you want to build a relationship between the bend radius and stock
thickness. You can use a formula in the Variable Table to build and manage this relationship. The following 
example illustrates how the Variable Table would look if you built a relationship that changes the bend radius 
when the stock thickness changes.

Type Name Value Formula



 

Variable Stock_thickness .25

Dimension Bend_radius .375 1.5 * stock_thickness

Here are some more examples of how you might set up the Variable Table:
Type Name Value

 

Formula

Variable c 2.0 kg

Variable d 10.0 rad @c:\bearing.xls!sheet1!R6C3

Variable e 20 mm @c:\bearing.xls!sheet1R!6C3

Argument Conventions

The following argument conventions are used in the Variable Table:
In the syntax line, required arguments are bold and optional arguments are not.
Argument names should follow the rules for Visual Basic.
In the text where functions and arguments are defined, required and optional arguments are not bold. Use 

the format in the syntax line to determine whether an argument is required or optional.



Example:    Using Variables to Calculate Dimensional Values
You can use the Variable Table to create expressions that change dimensions in the drawing when you change 
the expressions. 
1 Open a drawing document.
2 On the Tools menu, click the Variables command. The Variable Table appears in a window.
3 On the Variable Table window, click the Filter button and define which variables you want to display in the 

Variable Table. For example, on the Filter dialog box, if you select Dimensions in Type and then select 
Window, this displays all the dimensions that appear in the active window.

4 In the Variable Table, click the Formula cell that displays the dimension that you want to edit and type an 
arithmetic expression to calculate the value of the dimension: V681/2. When you type an entry in the cell, the 
entry also appears in the Formula Bar.

Type Name Value Formula

Dimension V680 4.25 mm V681/2
Dimension V681 3.00 mm

5 On the Formula Bar, click the Enter button or press Enter to calculate the result of the expression. In this 
example, when V681 is modified, V680 is automatically updated to reflect the relationship.

Type Name Value Formula

Dimension V680 1.50 mm V681/2
Dimension V681 3.00    mm



Example:    Creating a Variable with an External Function or Subroutine
The following example uses a following function and subroutine written in BASIC. They are stored in a document 
called FUNCTIONS.BAS. To see the syntax of the function and subroutine, click the Function button.
{button Function,PI(`',`EX_FUNCTION')}

In FUNCTIONS.BAS, the function AddTwo takes two numbers as input, adds them, and outputs a single value. 
A function can take any number of arguments as input, but can only output a single value. When using a function
as the formula of a variable, the result of the function is the value of the variable. The input to the function can be
specific value or other variables.

The subroutine Normalize takes three values as input and outputs three values. Output variables need to be 
specified by using the ByRef keyword. Using ByRef specifies that the variable is being passed in as reference 
and can be modified by the subroutine. Since a subroutine can have multiple output values, it can be used as the
formula for several variables. 

To use the document FUNCTIONS.BAS in a Variable Table, you can take the following steps: 
1 On the Tools menu, click Variables.
2 In the Variable Table, in the Unit Type list, select Distance. 
3 In appropriate cells, type the following entries to create three input variables.

Type Name Value Formula

Var Var1 5.50 in
Var Var2 3.25 in
Var Var3 7.80 in

4 In appropriate cells, type three more entries to create three output variables with any value: X, Y, and Z.
Type Name Value Formula

Var Var1 5.50 in
Var Var2 3.25 in
Var Var3 7.80 in
Var X 0.00 in
Var Y 0.00 in
Var Z 0.00 in

5 Select any of the output variables (X, Y, or Z) and click the Fx button to start the Function Wizard.
6 On the Function Wizard - Step 1 of 2 dialog box, in the Function Category list, select User Defined.
7 On the Open dialog box, select the functions.bas document to open it.
8 On the Function Wizard - Step 1 of 2 dialog box, in the Function Category box, click Visual Basic. In the 

Function Name box, click Functions.Normalize to select the function that you want to use from the 
functions.bas document.

9 Click Next.
10 On the Function Wizard - Step 2 of 2 dialog box, type the entries shown to specify the value or variable that is 

to be used as input for each input argument and the variable to be used for each output argument.
In this box Type this

InX As Double Var1
InY As Double Var2
InZ As Double Var3
ByRef OutX As Double X
ByRef OutY As Double Y
ByRef OutZ As Double Z

11 Click Finish.
The result within the Variable Table is shown below. The function is assigned as the formula to all of the 
variable that were specified to be output of the function. If any of the input values, (Var1, Var2, or Var3), 
change, the function is automatically run and the output variables are updated.

Type Name Value Formula



Var Var1 5.50 in
Var Var2 3.25
Var Var3 7.80
Var X 0.55 Functions.Normalize(Var1,

Var2,Var3,X,Y,Z)
Var Y 0.32 Functions.Normalize(Var1,

Var2,Var3,X,Y,Z)
Var Z 0.77 Functions.Normalize(Var1,

Var2,Var3,X,Y,Z)

Function and Subroutine in FUNCTIONS.BAS
Function AddTwo(InOne As Double, InTwo As Double) As Double

AddTwo = InOne + InTwo

End Function

Sub Normalize(InX As Double, InY As Double, InZ As Double, ByRef OutX As Double, ByRef OutY As Double, 
ByRef OutZ As Double)

Dim Dist As Double

Dist = InX * InX + InY * InY + InZ * InZ

Dist = Sqr(Dist)

OutX = InX / Dist

OutY = InY / Dist

OutZ = InZ / Dist

End Sub



Example:    Linking Variables to a Spreadsheet
Before you can link a variable to a spreadsheet, you must first create the variables you want in the design 
document. You can link to a spreadsheet created in Microsoft Excel or other spreadsheet software that can link 
or embed objects.
1 In the current document, create a rectangle and dimensions as shown.

 
2 On the Tools menu, click Variables to display the dimensions you defined. 

Type Name Value Formula

Dim _V112 30.00 mm
Dim _V114 60.00 mm
Note    Although the values that appear in the Name column are automatically generated by the software, you 
can edit the names.

3 In Excel, create and save a document that contains the spreadsheet you want to link to. The spreadsheet should 
contain the appropriate values for dimensional relationships as follows:
 A B

1 height 35
2 width 65

4 Arrange the windows of the Excel document and the SmartSketch document so that you can see the appropriate
cells in both documents.

5 In the Excel document, select the cell that you want to link to.
6 On the Edit menu, click Copy to copy the selected cells.
7 Click on the SmartSketch document so that it becomes the active document.
8 In the Variable Table, in the Formula column, click the cell of the variable that you want to link the spreadsheet 

to.
9 On the shortcut menu, click Paste Link.

Note To access the shortcut menu, put the mouse cursor in the white area of the Variable Table and click the 
right mouse button.

10 Click the Enter button to accept the value you pasted.
11 Repeat the previous steps as needed for the other values. The resulting Variable Table should update as 

follows:
Type Name Value Formula

Dim _V112 35.00 mm @C:\variable\part1.xls!Sheet!R1C2
Dim _V114 65.00 mm @C:\variable\part1.xls!SheetR2C2
When you edit the value in the Excel document, the variable in the Variable Table updates as well. When you
link the dimensions in the SmartSketch document to the Excel document, you can change the dimensions of 
the SmartSketch document by editing the corresponding values in the Excel document. The SmartSketch 
document automatically updates.



The Web browser cannot start
You cannot view this information if you do not have Web browser software. To load a Web browser, you can run 
Setup again and choose an option to load Internet Explorer from the CD-ROM that came with your software. 
Then, you can click the link in the Read Me Help document again to activate the Internet Explorer and view the 
HTML page.



The Web browser cannot start
You cannot view this information for one of the following reasons:

You do not have Web browser software. To load a Web browser, you can run Setup again and choose an 
option to load Internet Explorer from the CD-ROM that came with your software. Then, you can click the link in the 
Read Me Help document again to activate the Internet Explorer and view the HTML page.

You do not have an Internet connection. To get a connection, you can call an Internet service provider.
Your modem is not connected to the Internet. You should connect first and then click the link again to view 

this information. 



Cannot start e-mail
If you do not have e-mail software loaded or do not have a connection to the Internet, you cannot click this button
to send e-mail messages. To obtain a connection to the Internet, you should contact a local Internet provider.

If your e-mail software does not start, you can follow the instructions, To Create Your Own Request, in the E-mail 
Help topic.



SBL2.HLP cannot start
If you loaded on-line Help to your hard drive, open the Windows Explorer and double-click on this document: \
PROGRAM FILES\Smartsketch\PROGRAM\RESDLLS\009\SBL2.HLP. If you did not load Help to your hard 
drive, you can double-click the SBL2.HLP document from the software CD-ROM.



Applying Colors and Patterns to Closed Boundaries
{button Related Topics,AL(`fill cmd;formatting elements high',0,`NOT_FOUND')} {button How To,AL(`fill 
how',0,`NOT_FOUND')}

You can fill a boundary with a pattern or a solid color using the Fill command on the Draw toolbar. A fill is like 
other elements in that you can format it and move it around, but the fill is always associated with a boundary. The
boundary can be made up of more than one element. The following figure shows a pattern fill and solid fill. 

The software provides styles for fills for various engineering standards, such as ANSI, ISO, and AIA.

Modifying Fills

A fill is associative, which means it maintains its original orientation to an element regardless of the way you 
manipulate the element. For example, if you move the boundary, the fill moves with it. If you change the 
boundary, the fill changes to conform to the new boundary area.

A fill can exist only inside a closed boundary. If you drag a fill to another region, the fill assumes the shape of the 
region where you dragged it. If you open a closed boundary, the fill changes color to indicate that it is disabled. If 
you close the boundary again, the fill changes color to show that it is now active.

Formatting Fills

Formatting a fill is similar to applying formats to an element. You can apply unique formats to fills with the 
Properties command on the Edit menu or by setting options on the ribbon bar. To make several fills look the 
same, you can apply a fill style by selecting the style on the ribbon bar.
Tip    The blank color on the Fill ribbon bar takes on the background color of the document. This is useful for 
creating symbols that can cover an element on which the symbol is placed. Incorporating a fill with blank color 
into the symbol allows the symbol, when placed, to mask out elements such as lines or connectors that intersect 
the symbol.

You cannot modify an existing fill style, but you can create a new fill style by typing a new name in the Style box 
on the Fill ribbon bar. The new style uses the settings on the ribbon bar as the formats for the style.
Tip If you want to copy a fill style from document to another, just create a fill, apply a style, and then copy the fill 
to a new document. The fill style appears in a dropdown list on the Fill ribbon bar in the new document.



Using Layers to Arrange Elements
{button Related Topics,AL(`display manager cmd;layers cmd',0,`NOT_FOUND')} {button How 
To,AL(`layers how;filter how',0,`NOT_FOUND')}

Layers and display settings can help you group elements so that you can manipulate them more easily on a 
drawing sheet. Layers and display settings also make it easier to keep track of different types of elements. Each 
drawing sheet in a document can contain several layers. 

When you draw an element, it is assigned to the active layer. To see which layer is active, or to change the active
layer, you can use the Layers button on the Main toolbar.

Controlling the Display of Elements and Objects

After assigning an element or object to a layer, you can set display criteria to control the way items appear in a 
window with the Display Manager command on the Tools menu. With this command, you can set display 
criteria for any sheet and its associated layers in the current document. The display settings can include the color
or line type and line width of elements or objects. 
Tip    If two windows are open for the same document, the display settings that you select with the Display 
Manager dialog box affect every window view of the drawing sheet.

Displaying Layers

To view elements on specific layers, you can turn on one or more layers with the Layers button. When you turn 
layers off, you cannot see the elements assigned to the layers on the drawing sheet. For example, you can 
assign lines to one layer and closed elements to another layer. Then, if you turn off the layer for closed elements 
and turn on the layer for lines, you see only lines on the drawing sheet. 

You can still see relationships between elements that are assigned to different layers on a drawing sheet. For 
example, suppose a line and a circle are tangent and they are assigned to different layers. If the line's layer is 
displayed and the circle's layer is hidden, you can still see the tangent relationship handle on the line. If the line's 
layer is hidden as well, the tangent relationship handle is hidden.

With the Display Manager command on the Tools menu, you can control the way elements appear on sheets or
layers by changing settings, such as the line type or color. You can also create custom colors for the display.

Layers and Layer Groups

While layers provide a way to control the display of elements on a drawing sheet, layer groups give you another 
way to control the display of elements on drawing sheets. You can use the Layer Groups command on the 
Tools menu to define layer groups. 

Creating New Layers

You can create new layers with the Layer Groups command or by typing a new layer name on the ribbon bar. 



You cannot give the same name to two layers on the same drawing sheet. 

Assigning Elements to Layers

Although you can assign an element to only one layer, you can change the layer to which an element is 
assigned. You can find out which layer an element is assigned to by selecting it and using the Properties 
command on the Edit menu. 



Applying Unique Formats
{button Related Topics,AL("format cmd;styles high;element properties cmd;format painter high;edit properties 
cmd",0,`NOT_FOUND')} {button How To,AL("format how",0,`NOT_FOUND')}

At times, you may want to make geometric elements, dimensions, fills, or annotations look different from other 
ones on the drawing. To do this, you can edit the formats of the element directly. When you do this, the formats 
are applied only to the selected element or the one you are about to draw. This overrides whatever settings are 
applied to it by the style, without changing the style. 

Formatting Individual Elements

Before you place or draw an element, you can set unique formats with the ribbon bar, without changing the style. 
The commands on the Format menu, except for the Style command, can also be used to set an element's 
formats before you place or draw it.

For example, if you click the Text Box command, a style appears in the Style box on the ribbon bar. The style 
contains a format for bold fonts. If you turn off the Bold option on the ribbon bar, the text box that you place will 
not display bold text.

You can also apply unique formats to an existing element, dimension, fill, or annotation. You can select the 
element and then edit the formats with the ribbon bar or the Properties command on the Edit menu. 

For example, if you select a text box that has a style that displays borders, you can remove the borders with the 
Properties command on the Edit menu. Since you are changing the element's format, and not its style, the style
of the text box still contains borders. If you apply this style to any other text box, it will still display borders.

Formatting More Than One Element

You can change the format of more than one element at a time by selecting the elements and formatting them 
the same way you would format an individual element. However, all the elements that you select must be of the 
same type. For example, if you select several text boxes, you can apply settings to all of them at once. You 
cannot apply the same settings to a dimension and a text box by selecting both of them at once.



Placing Elements with a Grid
{button Related Topics,AL("view high;pinpoint high;draw high;grid cmd;grid high",0,`NOT_FOUND')}

{button How To,AL("grid how",0,`NOT_FOUND')}

The grid and its grid lines allow you to place elements in the document by aligning them with the grid lines or 
nearest intersection of the grid lines. You can use the grid if you want the elements to line up at regular intervals 
in the document.    

The grid is an invisible set of lines in the document. When you set the Grid Snap option on the View menu, 
elements always align with the grid lines or nearest intersection of the grid lines. You can view the grid by clicking
the Grid Display option on the View menu. The grid lines do not print.
{mci_left NOMENU,GRID1.AVI} 

You can change the display of the grid from static to dynamic by setting options on the View tab of the Options 
dialog box.

When you zoom in or out, the grid lines for a dynamic grid are generated dynamically. You can set dynamic grid 
lines to appear at fine, medium, or coarse levels.    The grid lines appear at common major measurement 
increments. A dynamic grid displays index lines that intersect with the darker, solid grid lines.

A static grid displays solid grid lines that do not move as you zoom in or out. You can set up the increment 
settings on the View tab of the Options dialog box.



Element Groups
{button Related Topics,AL("draw high;moving elements high;group cmd;ungroup cmd",0,`NOT_FOUND')}

{button How To,AL("group how",0,`NOT_FOUND')}

A group is a set of elements that you have selected. The set behaves like any other select set. Grouping 
elements allows you to work with them as a unit. For example, you could place the holes and center lines of a 
bolt hole pattern into a group. This would allow you to move, copy, or delete the entire pattern at once, as if it 
were a single element. 

The following list describes some of the properties of groups:
An element can be a member of only one group.
Grouped elements must reside in the same document and be on the same drawing sheet. 
Any locatable element can be grouped. 
Any combination of elements, such as lines, text, circles, and so forth, can be grouped.

You can use the Group command to nest two or more entire groups within a larger group, or you can nest 
individual elements and groups within a larger group.

Once elements are grouped, you can use the Ungroup command to ungroup all of the elements at the same 
time. You can also use the Ungroup command and PickQuick to remove one or more elements from a group.

Selecting Groups and Members of Groups

The options on the Select Tool ribbon bar allow you to select an entire group or individual members of a group. 
If you set the bottom-up option, you can select individual members. If you select the top down option, you can 
select all the members.

You can also use PickQuick to select one or more group members or an entire group.

Performing Tasks on Groups

Once you select a group, you can use a command or ribbon bar option on all of its members. For example, when
you move, copy, or delete a group, all of its members are moved, copied, or deleted. You can move or apply 
relationships to a member of a group and the changes do not affect the position of the other members of the 
group.

When you copy an entire group, all of its members are copied, including nested groups. The software creates a 
new group that contains all of the members of the original group. When you copy one member of a group, only 
that member is copied.

If you use PickQuick to select a member of a group, you can perform tasks on the member individually, without 
affecting other members.



Exploring the Window with Your Mouse
{button Related Topics,AL("label cmd;change cmd;ribbon bars high;intellimouse high;gui cmd",0,`NOT_FOUND')}

{button How To,AL("ui how;select how",0,`NOT_FOUND')}

The window consists of several components. Click a part of the following window to get information about the 
components.

Using the Mouse

You can use the Microsoft IntelliMouse™ or the middle button of a three-button mouse with the software so that 
you can manipulate different views of the drawing sheet faster and more efficiently. For more information, click 
the Related Topics button.

You can use the left mouse button to do the following: 
Select multiple elements by dragging to fence them.
Drag a selected element.
Click or drag to draw an element.
Select a menu or toolbar command.
Double-click to activate an embedded or linked object.

You can use the right mouse button to do the following:
Restart a command. 
Display a shortcut menu. Shortcut menus are context-sensitive. The commands on the menu depend upon 

your mouse location and which elements, if any, are selected.



You can also use the mouse to locate objects. As you move the pointer around on the drawing sheet, objects 
under the mouse change to a highlight color to indicate that they have been located. When you move the mouse 
away from a highlighted object, the object returns to its original color.

Using Ribbon Bars and Dialog Boxes

Because the software is Office-Compatible, you will find the ribbon bars and dialog boxes work just like those in 
Windows. A unique ribbon bar appears when you click a specific command or when you select an element. 
These ribbon bars help you control various settings for the active command. You can place a ribbon bar only at 
the top or the bottom of the window. You can drag a ribbon bar to the top or the bottom, but not to the sides, of 
the window    The following figure shows a ribbon bar.

Ribbon bars and dialog boxes contain one or more of the following tools:

A check box sets or clears an option. When you click the check box, an X appears to show that the option is set. 
Clicking the check box again clears it.

Some options give you two or more choices. You can click an option to activate it.

A box accepts a value when you type it and press Tab or Enter. You can edit the text by highlighting it with the 
mouse and then pressing Backspace or Delete.

A drop-down list box gives you several options to select from. In some cases, you can also type a value in the 
field.

A list box allows you to select an item from a list. You can scroll through the list using the scroll bar and double-
click an item. Or, you can click an option on the list and then click the OK button on the dialog box.



Using Toolbars

The toolbars give you quick access to commands. You can place a toolbar anywhere within the application 
window, either docked at the top, bottom, right, or left, or floating anywhere in your workspace. 

On a toolbar, some command buttons display fly-outs when you click and hold the command button. Fly-outs 
access commands that are closely associated with the button that you clicked. These types of buttons have a 
small black arrow in the bottom right corner.

Arranging Your Work Space

You can arrange the workspace in several ways: 
Move windows around on the screen.
Display, hide, or customize toolbars using the Toolbars command on the View menu or the buttons on the 

Main toolbar.
Move a ribbon bar to the top or bottom of the drawing sheet.
Set viewing options for the active window by clicking Options on the Tools menu and setting the options 

you want on the dialog box.



Menu Bar

The menu bar contains the names of all the menus. You can click a menu name to display a list of commands.



Main Toolbar

The Main toolbar has many of the commands you will use to perform common Windows functions. The toolbar 
also contains commands that you can use frequently.



Ribbon Bar

The ribbon bar is a dynamic toolbar that displays different options depending on which command you are using. 
The options on each ribbon bar operate much like the options on standard Windows dialog boxes.



Vertical Scroll Bar

The vertical scroll bar allows you to pan the active window from side to side.



Drawing Sheet

The large portion of the window is the drawing sheet. 



Horizontal Scroll Bar

The horizontal scroll bar allows you to pan the active window from top to bottom.



Tabs

The tabs allow you to display a sheet in your drawing when you click the tab you want. The name of the active 
sheet is bold. 



Tab Scrolling Buttons

Tab scrolling buttons scroll through the sheets in your drawing. 



Draw Toolbar

The Draw toolbar contains many of the commands you can use to draw elements.

The Select Tool button is at the top of the Draw toolbar. The Select Tool allows you to select elements on the 
drawing sheet.



Control Menu

The Control menu accesses standard Windows commands for minimizing, maximizing, and switching between 
applications.



Title Bar

The title bar displays the name of the active document. You can also use the title bar to move the window around
on the screen.



Maximize, Minimize Buttons

The maximize and minimize buttons expand the document window or collapse the document window to an icon.



Status Bar

The status bar shows information and messages at the bottom of the window. Some of the information is about 
what a particular command does or what action you should take.



Sheet Outline

The sheet outline shows the orientation of the drawing sheet and the printable region of the sheet.



User Assistance
{button Related Topics,AL("help cmd",0,`NOT_FOUND')} {button How To,AL("topics how;examples 
how;about how;jump how;office how;programming how;tip how;tutorials how;context help how;internet 
community how",0,`NOT_FOUND')}

SmartSketch user assistance supplies command information as you perform tasks. You can access different 
kinds of information any time you are running the software. This information could include reference topics, 
narrative descriptions, or instructional material.

In addition, SmartSketch provides several learning tools that you can activate from the on-line Help menu. You 
can also find on-line Help and other learning tools in the SmartSketch program menu on the Taskbar.

SmartSketch offers the following important user assistance features:

On-line Help
Complete command descriptions give you more information. When you click the Help button or press Shift +

F1, the pointer changes to a northwest arrow with a question mark. You can then get context-sensitive Help for any 
command by clicking the toolbar button or by clicking the menu command at the top of the window.

To get Help for options on certain dialog boxes, such as the Insert Object dialog box, you can click the 
Question Mark 

 in the upper right corner of the dialog box and click the item for which you want information. Or, you can position 
the pointer over the item and right-click to get on-line reference information. 

A structured table of contents, an index, and full-text search capabilities provide easy access to Help topics. 
Press F1 any time you need on-line Help during a design session. When a command is active, the Help topic for that 
command appears. If no command is active, then the table of contents for the Help topics appears. 

You can also access the table of contents by clicking SmartSketch Help Topics on the Help menu.

Learning Tools
To learn to use SmartSketch more efficiently, explore the Tutorials available on the Help menu.
To access the World Wide Web for more support tools for SmartSketch more efficiently, click SmartSketch 

on the Web from the Help menu. These commands activate your World Wide Web browser and put you directly on 
the web page for SmartSketch. On this page, you can access registration and support information and more learning 
tools.

Every time you activate SmartSketch, a Tip of the Day dialog box displays a helpful tip. You can use the 
More Tips button on the dialog box, or the Tip of the Day command on the Help menu, to display more tips. 

You can use the About SmartSketch command on the Help menu to see your software version and license
information.

User Interface Features
ToolTips help you find command names. When you pause the pointer on the command button on the 

toolbar, a yellow label displays the command's name.
Brief command descriptions show you the basic function of a command. When you point the pointer at the 

command button on the toolbar, the description appears in the Status Bar at the bottom of the window. Also, 
messages that explain your actions for each step of the command appear in the Status Bar.



Microsoft IntelliMouse Pointing Device
{button Related Topics,AL("views high;ms oc high",0,`NOT_FOUND')} {button How To,AL("view how;window 
how;views how;exclude universal scrolling how",0,`NOT_FOUND')}

You can use the Microsoft IntelliMouse® with the software so that you can manipulate different views of the 
document faster and more efficiently. 
Caution    The newest version of Microsoft IntelliPoint Drivers (2.2) supports universal scrolling. Universal 
scrolling allows you to scroll up and down in any window that displays scroll bars by using the wheel button on 
the IntelliMouse. Universal scrolling prohibits the recognition of the scrolling behavior defined for the software. 
You must, therefore, identify the name of the software and any other applications as exceptions to universal 
scrolling.
            How?  

When you do this: The view does this:

Rotate the wheel button forward Zooms in at the current pointer
location

Rotate the wheel button 
backwards

Zooms out at the current 
pointer location

Drag the wheel button Pans from one location to 
another

Press Ctrl and drag the wheel 
button

Zooms the area of the window 
that you defined by dragging 
the pointer

Press Shift and click the wheel 
button

Fits the graphics on the 
document to the window

Press Alt and click the wheel 
button

Restores the previous view

Tip    You can perform any of these actions with a three-button mouse; you click the middle mouse button, 
instead of the wheel button. No action occurs when you click the wheel button just one time.



How Linking Works
{button Related Topics,AL("documents high;open cmd;paste special cmd;insert object cmd",0,`NOT_FOUND')}

{button How To,AL("open how;ole how",0,`NOT_FOUND')}

Suppose you are sketching a drawing with SmartSketch and you want to include it in an engineering change 
request that was created in Word. You are going to update the drawing several times and want the change 
request to reflect the latest updates. A good way to keep the updates current is to link the drawing to the Word 
document and then periodically update the link. 

When you link to another document, the destination document stores the information from the source document 
in a field code. You can then see the linked information in the destination document.

Creating a Link

You can create links between documents as easily as you cut and paste information. To create a link to an entire 
document, you can insert information into the destination document with the Object command on the Insert 
menu. This is convenient when you do not want to switch away from the document in which you are currently 
working. 

You can also link information by dragging and dropping the document from the Windows Explorer or the 
software's Explorer into    a SmartSketch document. You must press the Ctrl + Shift keys while dragging and 
dropping the document. If you do not press the keys, the document is embedded.

To create a link to just part of a document, you can copy the information in the source document and then use 
the Paste Special command in the destination document to create the link. You must save the document before 
the link is established. The software that created both documents must support OLE.

Reconnecting or Changing a Link

When you move a document around or rename the source document, the links in the destination document are 
sometimes broken. To reconnect the link to the source document or change the link to another document, you 
can click the Links command on the Edit menu.

Updating a Link

Suppose you linked revision notes in a Word document to your SmartSketch drawing. You have revised your 
notes in Word since you first created the link. You must now update the link in the SmartSketch document so that
it displays the latest revisions to your notes. You can specify whether the updates happen automatically when 
you change the Word notes or if you must manually update the link in the SmartSketch document. First, click the 
Links command on the Edit menu and then, on the Links dialog box, select the link you want to set. You can 
then click the Automatic or Manual option. With Automatic set, SmartSketch updates the links every time you 
open the document. With Manual set, SmartSketch updates the links only when you click the Update Now 
button on the Links dialog box.

Editing Linked Information

The best way to edit linked information is to change it in the source document, not in the destination document 
where the information is displayed. To edit the linked information, double-click on the linked object.

Breaking a Link

If you do not need to automatically update the information displayed in the destination document, you can break 
the link with the Links command on the Edit menu. Once the link is broken, the information still appears in the 
destination document, but you cannot update the information or reconnect the link. You must create a new link 
instead.



Measuring Distances and Areas
{button Related Topics,AL("measure distance cmd;measure area cmd;dimensions high;document properties 
high",0,`NOT_FOUND')} {button How To,AL("measure distance how;measure area 
how",0,`NOT_FOUND')} {button Show Me,AL("measuring distance ex",0,`NOT_FOUND')}

You can also measure the length of a line or the diameter of a circle by selecting the element and looking at the 
value on the ribbon bar. For more detailed work, the software provides commands for measuring distances or 
areas in a drawing. Even when you are in the middle of a task, you can measure distances or areas with these 
commands. 

The Measure Distance command measures the distance between points on elements and points in free 
space.    

 
The Measure Area command measures the area inside one or more closed boundaries. 

 

The distances are shown using the current units of measure for the document.    To set the units for measuring 
distances or areas, you can use the Properties command on the File menu.



Using Feedback from the Pointer as You Draw
{button Related Topics,AL("draw high;smartsketch cmd",0,`NOT_FOUND')} {button How To,AL("smartsketch 
how;maintain relationships how",0,`NOT_FOUND')} {button Show Me,AL("draw horizontal line smartsketch 
ex;draw line connected to another line smartsketch ex",0,`NOT_FOUND')}

As you move the pointer, the software automatically updates values in the ribbon bar, giving you constant 
feedback on the size and position of the element you are drawing. As you draw, the software shows a temporary,
dynamic display of the element you are drawing by the pointer––this feedback is called a relationship indicator. 
This temporary display shows the look of the elements if you place the element at the current location. 

 

 

The software gives you more information about the element that you are drawing by displaying relationships 
between the temporary, dynamic element and the following items:

Other elements in the drawing
Horizontal and vertical orientations
Origin of the element that you are drawing

When the software recognizes a relationship, it displays a relationship indicator at the pointer. As you move the 
pointer, the software updates the indicator to show new relationships. If a relationship indicator appears by the 
pointer when you click to draw the element, the software applies that relationship to the element. 

Relationship Relationship Indicator

End point

Midpoint

Intersection

Horizontal

Vertical

Point On Element

Perpendicular

Parallel

Tangent

Center

For example, if the horizontal relationship indicator appears when you click to place the second end point of a 
line, then the line is exactly horizontal.



 

Relationships

You can set the types of relationships you want the software to recognize with the SmartSketch Settings 
command on the Tools menu. The software can recognize one or two relationships at a time. When the software
recognizes two relationships, it displays both relationship indicators at the cursor.

 

Locate Zone

You do not have to move the pointer to an exact position for the software to recognize a relationship. The 
software recognizes relationships for any element within the locate zone of the pointer. The circle around the 
pointer crosshair or at the end of the pointer arrow indicates the locate zone. You can change the size of the 
locate zone with the SmartSketch Settings command on the Tools menu.

 

Infinite Elements

The software recognizes the Point On Element relationship for lines and arcs as if these elements were infinite. 
In the following example, the software recognizes a Point On Element relationship when you position the pointer 
directly over an element and also when you move the pointer off the element.

 



Intent Zones
{button Related Topics,AL("draw high;select high;smartsketch cmd",0,`NOT_FOUND')} {button How 
To,AL("select element how;draw arcs by three points how ;tangent arcs how ;line how ",0,`NOT_FOUND')}

As you draw and modify elements, small quadrants called intent zones appear next to the pointer. The software 
uses intent zones to interpret your intentions as you draw. Intent zones allow you to draw and modify elements 
many ways using few commands. You do not need to select a different command for every type of element. 

How Intent Zones Work

When you click to begin drawing certain elements, the software divides the region around the clicked position 
into intent zones. By moving the pointer into one of these intent zones on the way to your next click location, you 
can tell the software what you want to do next. 

The last intent zone you move the pointer into is the active zone. To change the active intent zone, move the 
mouse cursor into the zone you want to use, then move it to the position where you want to click next. You can 
change the size of the intent zones with the SmartSketch Settings command on the Tools menu.

Drawing Tangent or Perpendicular Arcs

You can use intent zones to change the result of the Tangent Arc command. To draw an arc tangent to a line, 
first click a point on the line to place the first end point of the arc. Then move the pointer through the tangent 
intent zone and click to place the second end point of the arc.

If you want to draw a perpendicular arc instead, you can move the pointer back into the intent zone region and 
out through the perpendicular zone before clicking to place the second end point of the arc. The arc is then 
perpendicular to the line.

You can also use intent zones to define the arc direction. 

Drawing Arcs by Three Points

When you use the Arc by 3 Points command, intent zones allow you to input the three points in any order. You 
can also use intent zones to change the arc direction.

Drawing Lines Tangent or Connected to Curved Elements

Using intent zones with the Line/Arc Continuous command, you can draw a line tangent to a circle or arc. Or 
you can draw a line that is connected to the circle or arc, but not tangent to it. 





Using Relationships as You Draw
{button Related Topics,AL("draw high;smartsketch cmd;smartsketch high;freesketch high;intent zones 
high;pinpoint high",0,`NOT_FOUND')} {button How To,AL("draw how;maintain relationships 
how",0,`NOT_FOUND')} {button Show Me,AL("draw horizontal line smartsketch ex;draw line connected to 
another line smartsketch ex",0,`NOT_FOUND')}

You can use relationships to capture and remember your design intent as your sketch. You can make your 
drawings associative by applying those relationships—or you can sketch designs that do not use relationships. 

How Relationships Affect a Drawing

You can move and change an element that does not use relationships in various ways without affecting other 
parts of the design. For example, when no relationships exist between two lines, you can move and change each
line without affecting the other.
{mci_left NOMENU,RELWORK1.AVI} 

When you modify a part of a drawing that has a relationship to another part of the drawing, the other part 
updates automatically. For example, if you apply a perpendicular relationship between the two lines and move 
one line, the other line moves with it. The software remembers the relationship between these two elements and 
always maintains the perpendicular relationship between the lines. You can manipulate either of the two lines 
and the software will move or modify the line automatically to maintain the relationship.
{mci_left NOMENU,RELWORK2.AVI} 

Applying and maintaining relationships in the design simplifies changes to the design later. In the following 
drawing, all the relationships were automatically established as the design took shape on the drawing sheet. If 
you want to change the design, you simply modify one segment of it and all the relationships are maintained.
{mci_left NOMENU,RELPART3.AVI} 

Applying and Maintaining Relationships

You can place elements that are related to each other as you draw. First, you must set the Maintain 
Relationships option on the Tools menu. Then, as you click commands on the Draw toolbar and place lines, 
arcs, and circles, you should watch the relationship indicators that appear by the pointer. When a relationship 
indicator appears by the pointer, you can click to apply that relationship to the element that you are drawing.

Visualizing Maintained Relationships. 

When you apply relationships, relationship handles appear on the related elements. The handles are symbols 
that show how elements are related. You can display or hide the relationship handles in your drawings by setting 
or clearing the Relationship Handles option on the Tools menu. 

Relationship Relationship Handle

Colinear

Connect

Concentric

Equal

Horizontal/Vertical

Tangent

Symmetric

Parallel

Perpendicular



Lock

For example, the following four lines appear with relationship handles (A) turned off and with relationship handles
(B) displayed.

 

Applying Relationships to Existing Geometry

You can apply relationships to geometry after you place it with the buttons on the Relationship toolbar. These 
buttons include parallel, tangent, connect, and so on. You can use relationships created with these buttons if you 
set the Maintain Relationships option on the Tools menu.

Removing Relationships

You can quit using all the relationships that you have applied to the drawing if you clear the Maintain 
Relationships option. You can also remove individual relationships by selecting a relationship handle and 
deleting it. Clearing the Relationship Handles option on the Tools menu hides the handles, but the 
relationships are still maintained and used in the design.

When to Maintain Relationships

Maintaining relationships makes designing more productive and revisions much easier. However, relationships 
can slow drawing and changes on large data sets. You should decide whether to use relationships depending on 
the speed of your computer and the importance of easy revision. 

For conceptual sketching and diagrams, you might want to use relationships by setting the Maintain 
Relationships option. This method allows you to quickly get your ideas on paper and revise them easily using 
direct modification and driving dimensions. The kinds of projects in which you might want to use relationships 
include mechanical concepts, architectural details, layouts, and schematic diagrams.

When to Design Without Relationships

For more complex projects where you initially need to draw with precision, you should not use relationships in the
document. You can then draw with precision by using the PinPoint tool and entering values on ribbon bars. You 
can still use relationships within symbols. The kinds of projects in which you might want to draw without 
relationships include multiple-view drawings, floor plans, maps, and detailed designs.
Note    If you switch between using relationships and not using them while you draw, you can receive confusing 
results.



There are no related Help
topics



Working with Microsoft Office Documents
{button Related Topics,AL("solid edge high;documents high;open cmd;paste special cmd;insert object cmd;link 
and embed high",0,`NOT_FOUND')} {button How To,AL("open how;ole how",0,`NOT_FOUND')}

SmartSketch is fully compatible with Microsoft Office software. You can transfer text, numbers, sound bites, or 
intelligent graphics between documents that were created with SmartSketch and other Microsoft Office 
applications. You can move whole documents around or just parts of a document that you selected. The 
information that you move is called an object. 

For example, you can use Microsoft Word to create a materials report and then display the report in your 
SmartSketch document. You can also link a Microsoft Excel spreadsheet to the Variable Table in a SmartSketch 
document. You can then use the value in the spreadsheet to control the dimensions in the SmartSketch drawing. 
You can even create a document that contains a drawing created by SmartSketch, notes from Microsoft Word, 
and a spreadsheet created by Excel.

You can move information around with one of many methods:
Cutting and pasting deletes data from one location and places it in another location.
Copying and pasting duplicates the information and places it into a new location. The original information 

does not change.
Linking stores data in one location and places a copy in another location. When you change the original 

data, the copied data automatically updates.
Embedding copies information and stores the information in another document that was created in a 

different application. If you change the copied information, the original information does not change.

Cutting or Copying and Pasting

You can move information between documents or between locations in the same document with several different
methods. The easiest way is to use the Cut, Copy, and Paste commands on the Edit menu in any Office-
compatible software. You can also insert an entire document into another document with the Object command 
on the Insert menu.

You can also move information between SmartSketch and other Office software by selecting the information in a 
document or a document in the Windows Explorer and dragging it to another location or another document. With 
drag, you simply select the information that you want to move, hold the left mouse button, and drag the 
document to a location inside SmartSketch or another Office application. To finish the operation, you release the 
left mouse button. 

If you want to copy the information, and not move it, you should press the Alt key while using drag. When you 
drop the information, a shortcut menu appears beside the cursor. The options on the shortcut menu allow you to 
select how you want to place the information in the destination document, such as pasting, linking, and so forth.

If the software that you are copying or pasting to cannot edit the information, it will automatically store, or embed,
the information in the document. You can then edit the embedded information with the software that created it. If 
you cannot edit the information, the information is displayed as a static picture.

Linking or Embedding

An object is data from one application that is inserted in a document that was created with a different application.
You can link or embed information between documents that were created with SmartSketch and Microsoft Office 
software. Object linking and embedding (OLE) is a way of linking and embedding information.

Linking stores data in one location and places a copy in another location. Linked data is stored in the source 
document where it was created. The document that displays the linked or embedded information is called the 
destination document. When you paste the information in the destination document with the Link option set, a 
reference point, or field, is inserted into the destination document. This field displays the information that you 
pasted. When you change the original data, the pasted data automatically updates. You can edit the linked 
information by opening the source document. You can insert linked information with the Paste Special command
on the Edit menu. You can link an entire document to another document by inserting the information with the 
Object command on the Insert menu.

Embedding copies data in one document and stores the information in another document. If you change the 
copied data, the original information does not change. Embedded information is stored in the destination 
document. You can embed information with the Paste Special command on the Edit menu. You can embed an 
entire document inside another document by inserting the information with the Object command on the Insert 
menu.



When Do I Link or Embed?

If you want to keep the document's size small, then you should link the data to another document. Linked 
information increases the document's size only by the size of the displayed image, not by the size of the data 
itself. Linking is also useful when you want to share information in many different places and have that 
information update automatically. For example, if you wanted to display a SmartSketch drawing in several 
different reports that you created in Word, you could link the drawing inside the documents that contained the 
reports. Then, later, you could update the drawing by editing the SmartSketch drawing. Each report would 
automatically display the results of the drawing updates.

If the document's size is not an important factor, then you might want to use embedding. Embedded objects 
make the file size larger. Embedding is useful when the person viewing the document with the information does 
not have access to the software that created the information. The person can still view the information if it is 
embedded in the document. For example, if you wanted to send out several drawings for review, you could 
embed each SmartSketch drawing into a Word document and mail the Word document to each reviewer. 

Embedded information is also a good choice if the information does not need updating frequently. If you want to 
embed an object or edit an embedded object, you must have access to the software that created it.

For more information about linking and embedding, click the Related Topics button.



How Embedding Works
{button Related Topics,AL("documents high;open cmd;paste special cmd;insert object cmd",0,`NOT_FOUND')}

{button How To,AL("open how;ole how",0,`NOT_FOUND')}

Embedding means that you store information in a document as an object. The object becomes part of the 
document. When you double-click an embedded object in SmartSketch, this opens the software in which the 
object was created so that you can edit it. When you go back to SmartSketch, the object updates automatically 
with the changes that you made. 

You can embed existing information or create a new object and then embed it. When you embed objects, the 
size of the document increases. However, other users can view the object's information without having to access 
the software that created the object. This is useful when you need to send the same information to several 
different people who might not have the same software that you do.

Embedding an Object

Suppose you want to use Word to add comments to a SmartSketch sketch. First, you click the Object command 
on the Insert menu. On the dialog box, click the Create New option and then click Microsoft Word in the list. 
After you click OK, Word opens so that you can edit the object. If Word is already open, the new document 
creates a new window in Word. After you type your notes, you click the Update command on the File menu in 
Word. You should then switch back to the SmartSketch document. A box the size of the object appears beside 
the pointer. You can then click on the drawing sheet to place the Word object and display your notes on the 
drawing sheet. You can use this same process with any documents created with Office-compatible or OLE-aware
software.

If you want to insert some notes that you already had in a Word document, you can use the Object command on
the Insert menu. On the dialog box, you should select the Create From File option and then enter the name of 
the Word document to insert the entire document into the SmartSketch document. 
Tip    If you want to embed the object, you should make sure the Link check box is not set.

You can also embed information that you copied from another document. Copy the information and then switch 
to the SmartSketch document. Use the Paste Special command to paste the information as an embedded 
object.

If you want to use a mouse to embed objects, you can select the information in the source software and then 
drag it into another document. You can also drag the document that you want to embed from the Windows 
Explorer or SmartSketch Explorer into a SmartSketch document. The object is placed with the mouse drop point
at the center of the object's range box. 

When dropping SmartSketch documents, you can place the object coincident with the coordinate system of the 
container document. To do this, you select the Coincident option on the Reference Files tab of the Options 
dialog box. 

Editing an Embedded Object

To edit an embedded object, you can double-click the object to open the software that created the object. The 
menus and toolbars of the current software are temporarily replaced by the menus and toolbars of the software 
that just opened. 
Tip    The software that created both documents must support OLE.

You can also click commands on the shortcut menu to activate the software that created the object. To get the 
shortcut menu, select the embedded object and click the right mouse button.



Setting Up Documents and Using Templates
{button Related Topics,AL("properties cmd;properties db;document cmd;drawing sheet high;paper high;styles 
high",0,`NOT_FOUND')} {button How To,AL("properties how;open how;open AutoCAD or 
MicroStation document how;document how",0,`NOT_FOUND')}

You can create new documents in the following ways: 
Open the software, which uses NORMAL.igr as a starting template, and create a new document.
Use the New command and choose the template you want to use to create the document.

When you start the software, a new, blank document opens. You can format each new document you create or 
use a pre-formatted template as a starting point for a new document. You can work in the blank or pre-formatted 
document and save the changes when you are finished.

When you create a document, the document is displayed on your screen. You can use the commands on 
toolbars and in menus to add information to your document, and you can use edit commands to modify the 
information in your document.

Any changes you make are temporarily stored in memory. You have to save the document to preserve the 
changes to your document. You can also save documents in a specific format.

Using Templates as a Starting Point

Regardless of the method you use to create a document, a template is used as a starting point in creating the 
document. A template is a file that provides tools such as text, formats, geometry, dimensions, units of 
measurement, and styles that will be used to produce a new document that uses a specified format. You can also
edit the property set of the template to include default values for some of the properties as well as the additional 
custom properties you need to manage your documents. 

The template that you use depends on the type of information you want to put in the document. For example, you
would use an electrical schematic template to create a drawing that contains a schematic of an electrical 
component.

Opening Existing Documents

The Open command on the File menu opens existing documents. The software keeps track of the documents 
you worked on last. These documents are listed at the bottom of the File menu. To open one of these 
documents, you can choose it from the list. The Options command on the Tools menu allows you to set the 
number of entries displayed in the list.

Setting Up Properties for a Document

Once you create a new document or open an existing one, you might want to set document properties so that 
you can easily find the document later. You might also want to set up the units of measure that the document will 
use. With document properties, you can store document information with the document itself, instead of in a 
separate database. To set the properties, you can click the Properties command on the File menu. 

With the Properties command, you can view, edit, and store properties for a document. Document properties 
can include the title, the author, and keywords that identify important information. These properties also can 
include document statistics, such as document size and the date that a document was created and last modified.
Some properties are updated automatically by the software, such as the date the document was last modified.
Setting the Document's Units of Measure

The unit of measure settings for a document are stored as a property. If you set the units of measure, all the 
measurements in the drawing are affected. For example, if you set the length unit of measure to inches, then all 
the measurements in the drawing display in inches. 

You can set units of measure in both English and metric units for values such as length, area, or angles. You can
change the unit of measure at any time while you are drawing, and the document still retains complete accuracy 
of the measurements in the drawing. 

The precision readout sets the number of significant figures to display. It sets the accuracy of the unit readout 
value. The precision setting does not alter the numbers that you type into the fields, only the display of the 
numbers in the field. Values ending in 5 are rounded up. For example, if the precision readout is .123 and you 
draw a line that is 2.1056 inches long, then the line value length is rounded. The length value appears as 2.106 
inches long. If you are using mm as your drawing sheet units, you can have the values display in the fields as 3.5
mm or 3.50 mm.



Tip    When you set the units of measure for a document, the settings do not affect the dimensional values for the
document. You can set units for the dimensional values with the Dimension Properties dialog box. You can 
access this dialog box by selecting a dimension and then clicking the Properties command on the shortcut 
menu. You can also set the dimension units by editing a dimension style with the Dimension command on the 
Format menu.

Saving a Document as a Template

Sometimes you might want to make a copy of the same document as a starting point for creating other 
documents. In these cases, you can create a template to use as a starting point for many different drawings. A 
template is a collection of settings that you use over and over in different drawings. The settings might include 
drawing sheet settings, scales, actual elements that you draw, and a background sheet. 

To create a template, just save the current document with the Save As Template command on the File menu. 
This command saves the document in the TEMPLATE directory located in the directory where you installed the 
software. A different file extension in the name of the document is not necessary. To base new documents on the 
template, choose the New command on the File menu and select the template from the list. You can also open 
the template and save the document under another name.
Tip    You can change the directory where templates are saved by selecting the Options command on the Tools 
menu and setting the directory that you want on the File Locations tab of the Options dialog box.

Working with Several Open Documents

Several documents can remain open in the same session. You can use the Cut, Copy, and Paste commands to 
move or copy information between the documents or within one open document. You can use commands on the 
Window menu to arrange all the open documents so that you can view them easily.

You can also use the Object command on the Insert menu to import objects, such as drawings, spreadsheets, 
or text created in other software, into an open document. You can link or embed the imported objects. You can 
also drag information from another document into an open document.



Paper and Model Units
{button Related Topics,AL("drawing sheets high;dimensions high;annotations high",0,`NOT_FOUND')}
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Each document has both paper and model units. Paper units represent units on an actual sheet of paper. Model 
units indicate real-world distances and can fit a sheet of paper. 

The paper units manage the printable size of dimensions, annotations, and styles. The paper units always 
appear at a 1:1 scale. The model units represent the scaleable geometry in its real-world size. Both paper and 
model unit elements are displayed at the same time.                    

Because the drawing sheet dimensions, annotations, and styles use paper units by default, scaling issues can 
arise as you set the sheet scale for the model unit geometry. 

Dimension text and annotations do not scale when you use the Scale command on the Change toolbar; the 
scale of dimension text and annotations is based on the sheet size that you select with the Sheet Setup 
command on the File menu. 
Tip  If you insert an .igr or .sym document into the drawing sheet with the Object command, the terminators, 
spaces, text, and styles appear in paper units relative to the source document. The dimension lines and 
extension lines scale as though they are in real-world units. This behavior can cause the dimensions and text to 
appear very large or small in the container document.

You can set or change the size for dimension text and annotations by clicking the Style command on the Format
menu. On the Style dialog box, you select the type of style you want to set or modify (dimension or text), and 
then click the New or Modify button to set the font size for dimension text or a text box. Changing the font size of
dimension-text style or a text-box style changes only the dimension text or annotations with the modified style 
applied to them. 

You can also set the font size for individual dimension text or annotations by overriding the style that you applied.
You do this by selecting the dimension or text box and editing its properties with the Properties command on the
shortcut menu or from the Edit menu.

You can adjust how the model units fit within the printable sheet area by clicking the Sheet Setup command on 
the File menu. On the Size and Scale tab, you can select a scale setting by clicking an item on the Select Scale
dropdown list. The value that you select causes the model to resize within the printable area, but neither the 
paper unit information (dimensions and annotations) or model unit information is scaled.



Placing Elements in Precise Locations
{button Related Topics,AL("pinpoint cmd;draw high;grid cmd;grid high",0,`NOT_FOUND')} {button How 
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PinPoint is a tool that helps you draw and modify elements relative to known positions in a drawing. You can 
place a target point and then the software dynamically displays the horizontal and vertical distance between the 
cursor and the target point. You can use PinPoint with all element drawing commands. You can run PinPoint 
from the Tools menu or the Main toolbar. 

How PinPoint Works

PinPoint allows you to provide coordinate input to commands as you draw. The x and y coordinates are relative 
to a target point that you can position anywhere in the window. You can change the location of the target point at 
any time by clicking the Reposition Target button on the ribbon bar and then clicking a new position in the 
window.

As you move the pointer around, PinPoint dynamically displays the horizontal and vertical distance between the 
cursor position and the target point. Help lines show the PinPoint x and y axes and the PinPoint orientation.
{mci_left NOMENU,PPOINT.AVI}

Locking and Freeing Values

You can lock the x coordinate or the y coordinate using the X and Y boxes on the ribbon bar. When one 
coordinate value is locked, you can position the other coordinate by clicking a position in the window. Or you can 
set both values using the ribbon bar boxes. If you want to free the dynamics for a locked value, you can clear the
value box by double-clicking in the box and pressing the Backspace or Delete key.

PinPoint Orientation

In its default orientation, PinPoint's x axis is horizontal. You can re-orient the x axis to any angle by setting the 
angle on the PinPoint ribbon bar. The figure shows the PinPoint angle set to 20 degrees.

 



Printing Documents
{button Related Topics,AL("files high;print cmd",0,`NOT_FOUND')} {button How To,AL("print 
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You can print your documents on many different devices ranging from dot matrix printers to high-end laser 
printers. Except for the color settings and a few special effects, your drawing prints exactly as it appears on the 
drawing sheet.

Preparing to Print

The printer you use affects the way the current document prints and displays text on the screen. Before you print 
a document, you must install and select the printer that you want to use. For more information about installation, 
see your printer documentation. 

Before you print, you will want to choose a printer and the settings for it. To do this, click the Print command on 
the File menu and then click the printer that you want to use. You can set properties for the printer by clicking the
Properties button. To set the print range and scale, click the Settings button.

Printing a Document

As you work on a document, you might need to send a copy of it to a specified printer, plotter, or file.    You can 
click the Print command on the File menu to do the following:

Print an entire document or specific sheets from a document.
Print a draft copy of a document.
Set printing options, such as the range of sheets or number of copies to print.

The software supports WSYWIG plotting, using standard Windows NT plotting capabilities. The software also 
supports pen plotters, subject to the limitations of the device driver. Elements appear the same on the screen 
and in the printed document. 

However, the fonts that you choose can affect the match between what you see on the screen and what appears 
on the printed page. Three kinds of fonts affect your work: scalable fonts, printer fonts, and screen fonts. Use 
scalable fonts, such as TrueType® fonts, to confirm that what you see on the screen is what appears on the 
printed page. If you use printer fonts, you must have a corresponding screen font and font size to display each 
font on the screen. If each screen font you use has a matching printer font, the screen display of the document 
will closely match the printed document.

Printing Part of a Document

You can print selected sheets in a document or a selected area. This practice is handy if you are working on a 
complex drawing and you want to print only certain parts to proof them. 

To print selected sheets, you should first select sheets in the document to make them active. To do this, you can 
click the drawing sheet tabs of the sheets that you want while pressing Ctrl. Then, you select the Print command
on the File menu and click the Selected Sheets option on the dialog box.

When you select several sheets and then click the Selected Sheets option on the Print dialog box, all the 
selected sheets are printed as one composite drawing, like layers on top of one another. The software uses the 
scale, paper size, and orientation of the active sheet for printing the final document.

To print a selected area, you should first select the drawing sheets that you want to print. Then, you select the 
Print command on the File menu and click the Print Area option on the dialog box. After you click the OK 
button, a set of crosshairs appears. You drag over the area that you want to print. The Print Area dialog box then
automatically appears and allows you to set options for printing the selected area. 

Printing Time

Required time for printing varies by document. Expect longer print times when you have drawings that contain a 
large number of the following items:

Curved elements
Many fills that have complex colors, patterns, or textures
Large bitmaps
Links to various documents

The type of printer that you have also affects the printing time. PostScript® printers print faster than LaserJet 
printers because they can calculate faster. Some older versions of PostScript printers are slower when compared
to the newer ones. The type of controller boards and the amount of RAM in the printer also affect your printing 



times.



Working with Raster Images
{button Related Topics,AL("save image as cmd;rectangle select cmd;paint color cmd;erase color cmd;control 
brightness cmd;invert raster cmd;fill area cmd;insert image cmd",0,`NOT_FOUND')} {button How 
To,AL("insert raster image how",0,`NOT_FOUND')}

Images created by lines of pixels are called raster images, and the code that represents the pixels in the raster 
image is called raster data. The format of the raster data in the document determines how the pixels are 
arranged when the image is displayed. You can edit raster data

Differences Between Raster Data and Vector Data

Raster data is unintelligent. A line segment in a raster image cannot be manipulated as a line segment. Rather, it 
must be manipulated as the collection of pixels that form the line segment.

A vector data document is a collection of coherent, geometric elements. Vector data is intelligent. A line segment 
in a vector file can be manipulated as a line segment.

A vector data object is an indivisible entity. A raster image, by contrast, is composed of pixels, arranged to give 
the appearance of lines, shapes, and characters. When zoomed out, a raster image appears as contiguous lines 
and shapes. However, if you zoom in, it becomes apparent that a raster image consists of individual foreground 
pixels, represented as small squares on the screen.

Displaying Raster Images

ImageScape™ LT allows you to display and manipulate raster images along with the vector data on the drawing 
sheet. When you save the current document, which contains vector graphics, you can save a link to a raster 
image along with it. 

This structure can be useful in many ways. For example, if a shopping center is planned for a piece of property, 
and proposals are sought for the design of the shopping center, an aerial photograph may be taken of the 
property. The photograph can then be converted into a raster image. Proposals can be submitted as vector 
documents that each contain a link to the original raster image. In this way, different proposals for the shopping 
center can be easily evaluated, with each proposal starting from the same raster image of the property.

Inserting an Image

To insert a raster image, you must first install ImageScape LT with the Add-Ins command on the Tools menu. If 
you do not see the add-in listed in the Add-In Manager, you must run Setup again and select the Custom 
installation. You can then select an option for the add-in.

After installing ImageScape LT, you can then insert the raster image with the Image command on the Insert 
menu. You can only link the image; you cannot embed it. To edit various properties of the image border, you can 
select the image and click the Properties command on the shortcut menu.

Use the Position command to move, scale, rotate, and skew a source image to match a target image or vector 
frame. All alignment modifications are made by placing up to three source points and three target points. You can
define source points by clicking and dragging or by a single click on the source image.

Expanding the Raster Capabilities

You can expand the capabilities of the software with another Intergraph product called ImageScape™. 
ImageScape allows efficient and productive use of scanned drawings, aerial photographs, and rendered images.
With ImageScape, you can do the following:

Clean up and modify scanned drawings, maps, and images.
Revise old scanned drawings with powerful drawing tools in the software.
Display raster or vector data transparently over an image backdrop.
Place images in a precise position.
Warp images or scanned drawings to correct for geometric distortions in the original image.
Produce and print hybrid raster or vector drawings for more effective presentations and proposals.



Ribbon Bars
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Ribbon bars help you control various settings for the active command.    A unique ribbon bar appears when you 
select the command or when you select an element. You can use the same ribbon bar for creating an element or 
modifying it.    For example, if you place a line or select an existing line to modify it, the same ribbon bar is active.

The options on a ribbon bar work like options on dialog boxes.    Any options that you set affect the active 
command.    For example, after you click the Balloon button on the Dimension toolbar, before you place a 
balloon, you can set a style for it on the ribbon bar.

You can drag a ribbon bar to the top or the bottom, but not to the sides, of the drawing sheet.



Saving Documents
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When you first save a new document, the software provides a default name and directory location. You can give 
the document a meaningful name and specify where you want to store the document on the disk. 

When you open an existing document, the software copies the document from the disk and displays it on the 
screen. As you work, the changes you make to the document are displayed on your screen. To preserve these 
changes, you must save the document. When you save the document with the Save command, the changes are 
copied to the document on the disk. 
Tip    You can quickly save changes to an open document by clicking the Save button on the Main toolbar.

After you have saved a document, it remains displayed on the screen. You can use the Close command to close 
the document and clear it from your screen, or you can use the Exit command to close the document and exit 
the software.

Saving a Copy

If you need to make a copy of your work, you can click the Save As command on the File menu. You should type
a different name for the document in the Save As dialog box.

Saving a Document as a Template

Sometimes you might want to make a copy of the same document as a starting point for creating other 
documents. In these cases, you can create a template to use as a starting point for many different drawings. A 
template is a collection of settings that you use over and over in different drawings. The settings might include 
drawing sheet settings, scales, actual elements that you draw, and a background sheet. 

To create a template, just save the current document with the Save As Template command on the File menu. 
This command saves the document in the TEMPLATE directory located in the directory where you installed the 
software. A different file extension in the name of the document is not necessary. To base new documents on the 
template, choose the New command on the File menu and select the template from the list. You can also open 
the template and save the document under another name.
Tip    You can change the directory where templates are saved by selecting the Options command on the Tools 
menu and setting the directory that you want on the File Locations tab of the Options dialog box.

Saving Documents to cgm Format

The Computer Graphics Metafile (.cgm) provides an efficient way to make information available on the Internet. 
You can use the Save As command to save documents in .cgm format. Once in .cgm format, you can place the 
graphics on a web page (.html or .htm) and view them with browsers such as the Internet Explorer or Netscape 
Navigator. 

cgm is an efficient format for publishing 2D vector drawings on the Web because it takes up little storage space, 
renders quickly, and has the ability to zoom and achieve more detail. These types of drawings can contain 
embedded hyperlinks, allowing quick access to information outside the drawing. 

Saving Documents to HTML Format

In addition to the cgm format, you can use the Save As Web Page command to save documents in .html format. 
This command saves the document in an HTML document; the graphics in the document are embedded in the 
HTML as .cgm graphics. You can then view the document with browsers such as the Internet Explorer or 
Netscape Navigator. 

Closing a Document

If you want to close a document without saving your work, click the Close command on the File menu and then, 
when prompted to save your work, click the No button. If you want to save your work, you can click the Yes 
button instead. If you decide not to close the document at all, you can click the Cancel button.

Sending a Document to Others

After you finish drawing a sketch or adding notes to it, you can send the document to other users by clicking the 
Send command on the File menu. An e-mail message appears, allowing you to attach the drawing to the 
message. You can also embed or link the drawing to a Word document and send the document in e-mail to other
users. 





Selecting Elements
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To select an element, you must use the Select Tool at the top of the Draw toolbar. You can select lines, arcs, or 
annotations, such as dimensions or fills. You can also select element groups, embedded or linked objects, 
symbols, or handles on elements that indicate relationships. 

Selecting Single Elements

To select an element, you can click the Select Tool on the Draw toolbar.

When you click the Select Tool button, the pointer changes to an arrow with a locate zone indicator at the end. 
As you move the pointer, any element that the locate zone passes over is displayed in the highlight color. When 
an element is highlighted, you can click to select it.

When you select an individual element, the following things happen:
The element changes to the selection color. You can change the selection color with the Options command 

on the Tools menu.
The element's handles are displayed. Handles are solid squares at significant positions on a selected 

element, such as end points and center points. Handles allow you to directly modify the element—drag a handle to 
change the element's shape. Although you can select more than one element at a time, only one element can have 
handles at a time.

The element's important properties are displayed on a ribbon bar.
If the element is linked or embedded into the current document, selecting it allows you to double-click it for 

editing.

When you select multiple elements or grouped elements, they change to the selection color.

Selecting Multiple Elements

You can select more than one element at a time by clicking the Select Tool and then holding the Shift or Ctrl 
key as you click the elements you want to select. Or, you can click the Select Tool and then drag the mouse to 
fence elements. 

You can use the ribbon bar to select whether you want only elements completely enclosed by the fence to be 
selected or any element that is partly enclosed by the fence. Many manipulation commands, like delete, move, 
copy, and rotate, act upon all elements in the selection set.

Selecting an Element That Overlaps Other Elements

If you want to select an element that overlaps other elements, and you cannot highlight the element you want by 
moving the cursor over it, you can use a tool called PickQuick. To use it, you should move the pointer over the 
elements and pause the mouse. When the software displays an ellipsis, or three small circles, by the pointer, you
can click the left or right mouse button to display a small toolbar that shows the number of selectable elements. 
You can move the pointer over the numbers; and, when the element that you want highlights, you can click on 
the corresponding number to select it.

Deselecting Elements

To deselect an element or group of elements, you can click any point on the drawing sheet.



Managing Multi-sheet Documents
{button Related Topics,AL("sheets cmd;drawing sheet tabs high;document management high;paper units 
high;title block high",0,`NOT_FOUND')} {button How To,AL("sheets how;title block how",0,`NOT_FOUND')}

Drawing sheets are similar to pages in a notebook. You can place different sketches or drawings on different 
drawing sheets in the document. For example, you can draw one idea for a design on one drawing sheet and 
another idea on another drawing sheet. Both drawings are saved in the same document. There is no limit to the 
number of sheets you can have in a document. 

When you create a new document, a default sheet appears with a border and a title box. You can modify the 
default settings with the Sheet Setup command on the File menu. For example, you might want to give a 
specific name to a sheet by setting options with this command. If you want to insert new sheets, click the New 
Sheet command on the Insert menu.

Sheets essentially act like separate drawings. Individual sheets can have different scales and sheet borders. If 
you want to be able to locate or use relationships between elements, you should place the elements on the same
sheet. 

You can display a number of drawing sheets on top of each other and simultaneously view the drawings on all of 
the drawing sheets, much as you would view a stack of transparencies.



Areas of a Drawing Sheet

A drawing sheet has two areas that affect the way you work. The sheet outline (A) shows the orientation of the 
sheet and the default print region of the sheet. You can change the size and orientation of the sheet outline with 
the Sheet Setup command on the File menu.

You can draw new elements on the sheet outline or outside the borders of the outline. All new graphics that you 
create are placed on the active drawing sheet.

Setting Up a Drawing Sheet

You can set up a drawing sheet with the Sheet Setup command on the File menu. The sheet where you will 
create most of your graphics is called a working sheet. In a document, you can create as many working sheets 
as you need to plan your project. A working sheet can have a single background sheet attached to it.

Choosing a Sheet Size

You can modify a drawing sheet’s characteristics, such as the size and scale of the sheet, with the Sheet Setup 
command on the File menu. On the Sheet Setup dialog box, you can click the Size and Scale tab and select a 
standard sheet size or set a custom size. The dialog box also allows you to set the defaults for all new working 
sheets created in the document. You can do this by setting the options you want and then clicking the Save as 
Default button.

Drawing Sheet Scale

Drawing sheets allow you to use a specified scale as you draw. When you specify the scale with the Sheet 
Setup command on the File menu, everything on the drawing sheet is scaled except for dimensions and 
annotations. For example, if the scale is one inch to ten inches and you place a line 30 inches long, the line is 
three inches long in proportion to the drawing sheet and three inches long when printed. However, a dimension 
measures the length of the line as 30 inches.

The dimension and annotation sizes in your working sheets are independent of the drawing view scale. For 
example, when you define the height and size of dimension text, these values specify how you want the 
dimensions to appear when you print the drawing.

The graphics on the attached background sheet are displayed at a 1:1 scale. They are not affected by the scale 
set with the Sheet Setup command on the File menu.

Manipulating Drawing Sheets

At the bottom of the drawing sheet, you can see drawing sheet tabs that allow you to manipulate and display the 
drawing sheets in your document. When you open a document or create a new one, the tabs are displayed at the
bottom of the work space. There is a tab for each drawing sheet in your document.

Attaching a Background Sheet



After you set up the drawing sheet, you might want to attach a background sheet. A background sheet is used as
a backdrop to the working sheet. For example, you can add borders to a drawing, draw a title block, insert a 
raster image, or draw geometry. You can make one background sheet and attach the same background sheet to 
several different drawing sheets.

When you attach a background sheet to a working sheet with the Sheet Setup command, the items on the 
background sheet are displayed and printed. The size of the working sheet is automatically set to the size of the 
background sheet you attach. This is so the paper sizes and graphics on both sheets line up.

Background sheets allow you to customize your borders and title blocks so that they match your company's 
standards and requirements. You can use the background sheet delivered in a template or design your own 
background sheet. You can create tailor-made background sheets by adding your company's logo, creating any 
other graphics that you need, and using various styles and options. A typical customization scheme would be to 
have a different background sheet for each standard-sized drawing (A, B, C, D; or A0, A1, A2, A3, A4).

Sheets and Document Templates

You can re-use your sheets by creating and saving them in a document template. When you create a new 
document based on a template, all of the drawing sheets that are part of the template are copied into your new 
document. 



Applying Formats with Styles
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If you want elements that are the same type to look alike, you should use styles, a collection of formats that can 
be applied to the following items: 

Geometric elements
Dimensions
Annotations
Fills

Using styles ensures consistency. If you place or draw one or more elements, the formats in the style are applied
directly to the elements. You do not have to spend time formatting as you draw. You can apply the formats in 
each style again and again.

The software provides styles that you can apply to elements so that they conform to an engineering standard, 
such as ISO or ANSI.

Managing Styles

Using the Style command on the Format menu, you can create several styles so that elements in a drawing 
appear the way you want. You can use or modify the styles delivered with the software, or you can set up new 
ones that conform to your unique requirements. One or more styles can be stored in a template so that you can 
use them in other drawings.

The software divides styles into types, such as text, dimension, line, and fill. A style type contains one or more 
styles. You can create styles for each style type.

When you create a new document based on a template, the template is copied. The copy includes any styles 
that are in the template. Fonts are never copied into a document. If you want someone to view the fonts, and that
person's system does not have the same fonts installed, you should give that person the fonts along with the 
document.

Including Styles from Other Documents in a Template

If you want to make styles from other documents available in the current document, you can reference the styles 
with style resource documents. You can reference a style resource document from the active template or 
document by clicking the Resources button on the Styles dialog box. The Style Resources dialog box allows 
you to add style resource documents to the current template or document. Style resource documents can be any
.igr document or .RSC line style file that contains styles native to that document.

If you create a document based on a template, any style resource documents attached to the template are 
attached to the new document as well. When you reference a style resource document from the current 
document or template, the styles in the resource document are added to the Style dropdown list on the active 
document's ribbon bar. When you apply one of the line, dimension, or fill styles to an element on the drawing 
sheet, the style is copied from the style resource document to the current document. The fonts are added to the 
dropdown list on the ribbon bar as well, but are not copied into the current document.

Applying Styles

The style type determines what type of item to which you can apply a style. A text style can be applied to text 
within a text box. A fill style can be applied to a fill. A line style can be applied to any geometric element such as a
line, arc, circle, or ellipse. A dimension style can be applied to a dimension or balloon.

When you place dimensions or annotations, or draw elements, the formats from their default styles are applied 
automatically. For example, if you click SmartDimension on the Dimension toolbar, the ANSI style appears on 
the ribbon bar. Each dimension that you place receives the ANSI style. To apply a different style, you can change
the style name on the ribbon bar before or after you draw or place an element.

Applying Styles to More Than One Element

Selecting more than one element and then applying the same style to them removes any previous formats—the 
elements now all have the same formats from the style that you applied. To do this, you must select elements 
that are in the same style type, such as text, dimension, fill, or line. For example, you cannot apply a line style to 
a dimension.





Text Box Handles
{button Related Topics,AL("text properties db;text info tab;annotations high",0,`NOT_FOUND')} {button How 
To,AL("create text box how;move text box how;resize text box how ",0,`NOT_FOUND')}

Text box handles manipulate the origin or the size of the text box while maintaining the relationship between 
origin and justification.

Handles on text boxes appear as an X square, a hollow square, or a solid square.

An X handle indicates the origin of the text box. Selecting an X handle modifies the origin. 
If you select a hollow handle, you move the text box; therefore, you are moving the origin of the text box.
You select a solid handle to modify the text box along at least one axis. You do not modify the origin.
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Changing the Shape of an Element
{button Related Topics,AL("draw high;relationships high;change cmd",0,`NOT_FOUND')} {button How 
To,AL("manipulate how;modify how;select how",0,`NOT_FOUND')} 

You can change the size, position, or orientation of an element with your pointer. When you select an element 
with the Select Tool, its handles are displayed at key positions. 

You can change the shape of a selected element by dragging one of its handles. The first figure shows the effect 
of dragging an end point handle. The second figure shows the effect of dragging the mid point handle.



Scaling Elements
{button Related Topics,AL("draw high;relationships high;scale cmd",0,`NOT_FOUND')} {button How 
To,AL("scale how ",0,`NOT_FOUND')}

The Scale command on the Change toolbar reduces or enlarges selected elements by a scale factor that you 
define. The scale factor is the same along the x and y axes. Scalable elements include framed elements, such as
text boxes. You cannot use the Scale command to scale or scale and copy elements in a drawing view because 
a scale factor has already been applied to the drawing view. 

Relationships within the selection set are maintained if the relationships are still applicable after the elements 
have been scaled. If not, the relationships are deleted.

To define the new scale, you can click points on the drawing sheet or you can type a value in the Scale Factor 
box on the ribbon bar. You can also use the Step box on the ribbon bar to make the Scale Factor increase or 
decrease incrementally as you move the mouse.



Using Dimensions to Change Existing Elements
{button Related Topics,AL("draw high;relationships high;dimensions high",0,`NOT_FOUND')} {button How 
To,AL("driving dimension how",0,`NOT_FOUND')}

You can change dimensions on the drawing sheet to change existing elements. Driving dimensions are 
relationships that allow you to maintain characteristics such as the size, orientation, and position of elements. 
When you place a driving dimension on or between elements, you can change the measured elements by editing
their dimensional values—you do not have to delete or redraw elements at different sizes. 

For example, dimensioning the radius of an arc maintains its size. Editing the value of the radius dimension 
changes its size.

 

To create dimensional relationships, select a dimension command and click the elements you want to relate. 
Tip  You must set the Maintain Relationships option on the Tools menu before drawing the elements or 
applying your dimensions.



Applying Relationships to Change Existing Elements
{button Related Topics,AL("draw high;relationships high;change cmd",0,`NOT_FOUND')} {button How 
To,AL("relationship how",0,`NOT_FOUND')}

You can apply relationships as you draw and place elements by using the relationship indicators that appear by 
the pointer. You can also apply relationships to elements that you have already placed on the drawing sheet.

Applying Relationships to Existing Elements

To apply relationships to elements that you have already placed on the drawing sheet, click a button on the 
Relationship toolbar and then select the elements you want to relate. When you apply a relationship between 
elements, the elements are modified to reflect the relationship. If Maintain Relationships is set when you use 
the commands on the Relationship toolbar to add relationships to your drawing, the added relationships will be 
maintained. 

For example, selecting the Equal command and clicking two circles makes the circles equal in size. 

If a line and arc are not tangent, applying a tangent relationship modifies one or both elements to make them 
tangent.

When you use commands on the Relationship toolbar, the software allows you to select only elements that are 
valid input for that command. For example, when you use the Concentric command, the command allows you to
select only circles, arcs, and ellipses.

Perhaps you begin designing with a few key design parameters. You would usually draw known elements in 
relation to one another and then draw additional elements to fill in the blanks. 

 

As you draw and add elements to the drawing, the relationships are maintained and additional relationships are 
applied.



 

Modifying Elements That Share Relationships

If two elements share a relationship, the relationship is maintained when you modify either one of the elements. 
For example, if you move a circle that has a tangent relationship with a line, the line also moves. The elements 
remain tangent.
{mci_left NOMENU,DRWMETH1.AVI} 

If you move a circle that does not have a tangent relationship with a line, the line does not move.

Other elements that share relationships maintain them in the following ways:
If a line and an arc share a tangent relationship, they remain tangent when either is modified.

If a line and arc share a connect relationship, they remain connected when either is modified.

If two lines are horizontal, they remain horizontal even if you change the position and length of one of the 
lines.



Deleting Relationships

You can delete a relationship as you would delete any other element. You select a relationship handle, and then 
select the Delete command. Relationships are automatically deleted when their deletion is necessary to allow a 
modification to occur. For example, if you rotate an element that has a horizontal relationship applied to it, the 
relationship is automatically deleted.

If you want to change an element by adding or removing a relationship, and the element does not change the 
way you expect, it may be controlled by a driving dimension. You can toggle the dimension from driving to driven,
then make the change.



Extending or Trimming Elements
{button Related Topics,AL("draw high;relationships high;change cmd;trim cmd;extend cmd;chamfer cmd;fillet 
cmd",0,`NOT_FOUND')} {button How To,AL("extend how;trim how;chamfer how;fillet 
how",0,`NOT_FOUND')}

You can trim or extend elements with buttons on the Draw toolbar.    You can also add fillets or chamfers by 
clicking the Fillet or Chamfer buttons on the Draw toolbar. 

Relationships are added or removed as necessary when you trim or extend an element. For example, if you trim 
part of a circle and more than one arc remains, concentric and equal relationships are applied between the 
remaining arcs.

You can also draw a chamfer on two different elements with the Chamfer button on the Draw toolbar. The 
elements must be linear, but do not have to intersect. The elements cannot be parallel to each other. 

When two lines intersect, you can draw a chamfer simply by clicking the corner and then moving the pointer in 
the distance that you want. A final click on the drawing sheet places the chamfer (B).

To place a fillet, you can click the Fillet button on the Draw toolbar and then select the elements you want to 
modify. As with any command, you can use a combination of clicks and ribbon bar input. 



Rotating Elements
{button Related Topics,AL("draw high;relationships high;rotate cmd",0,`NOT_FOUND')} {button How 
To,AL("rotate element how",0,`NOT_FOUND')}

With the Rotate button on the Change toolbar, you can rotate one or more elements a precise angle about a 
specified point. 
{mci_left NOMENU,ROTATE1.AVI}

You can first select the element and then click the Rotate button or you can click the button and then the 
element.

As you click to define the reference points for the rotation, the software dynamically displays a reference axis for 
the rotation. If you want to define a precise location for the rotation, you can enter values in the ribbon bar. You 
can enter increments in the Step Angle box if you want to dynamically view the results of the rotation. For 
example, if the box is set to 30.0, the rotation is displayed in 30 degree increments. The default setting is 0 
degrees so that the rotation is fully dynamic. 

The Rotation Angle box on the ribbon bar displays the angle of change between the old and new positions with 
a positive value. The Position Angle box displays an absolute angle of the new position of the rotation. You can 
type values in both of these boxes and preview the results. You then click to complete the rotation of the element.

By default, a copy is made of the element when you rotate it. If you do not want a copy, you should clear the 
Copy option on the ribbon bar. 



Mirroring Elements
{button Related Topics,AL("draw high;mirror cmd",0,`NOT_FOUND')} {button How To,AL("mirror 
how",0,`NOT_FOUND')}

To mirror an element, you can click the Mirror button on the Change toolbar. The software mirrors one or more 
selected elements about a line or axis that you define. You can mirror with or without making a copy. 



Viewing Your Work
{button Related Topics,AL("drawing sheets high;layers high;intellimouse high;grid high",0,`NOT_FOUND')}

{button How To,AL("view how;window how;views how;create layer how;sheet setup how;filter 
how",0,`NOT_FOUND')}

You can manipulate windows and views to affect how you see a document on the computer screen. A window 
can be compared to a camera. When you look through a camera, you see a view of a real-world object. When 
you look through a window on the computer screen, you see a view of the objects in the document. In both 
cases, you can change the view by zooming in and out, and focusing on different parts of the document. You can
also use the Microsoft IntelliMouse to zoom or pan views. 

Windows

When you start    the software, the application window displays a blank document. You can use commands on the
File menu to create a new document or open an existing one. 

With the commands on the Window menu, you can create and arrange new windows that allow you to see more
than one section of a document or more than one document. You can minimize open windows and display them 
as icons in the application work space.

Views

Views are what you see in software windows. With the view commands, you can do the following:
Use the Zoom Area command to set the zoom area to see more detail in the document.

 Use the Zoom In command to enlarge the display of elements around a specified point in the document.
Use the Zoom Out command to reduce the display of elements around a specified point in the document.
Use the Pan command to position another part of the document in the center of a view, fit all of the 

document in a view, or identify the area of the document you want to see.
Use the Fit command to restore the previous view of the document.
Use the Previous command to restore the previous view.
Use the Toolbars command to display or hide toolbars in the application window.

Drawing Sheets

With drawing sheets, you can place different drawings on different sheets in a document. Working sheets are the
drawing sheets on which you place most of your graphics. Background sheets are drawing sheets that allow you 
to define and display the border of a drawing sheet. 

Layers

Within each drawing sheet, you can place several layers so that you can group elements. Layers allow you to 
keep track of elements in the document and manipulate them more easily. You can also specify the way you 
want elements to be displayed in a window.

Click the Related Topics button for more information about drawing sheets and layers.



Intergraph Policy Against Software Piracy
When you purchase or lease Intergraph software, Intergraph retains ownership of the product.    You become the 
licensee of the product and obtain the right to use the product solely in accordance with the terms of the 
Intergraph Software License Agreement and the provisions of the various copyright laws.

You must have a valid license for each working copy of the product.    You may also make one archival copy of 
the software to protect from inadvertent destruction of the original software, but you are not permitted to use the 
archival copy for any other purpose.    An upgrade replaces the original license.    Any use of working copies of 
the product for which there is no valid Intergraph Software License Agreement constitutes Software Piracy for 
which there are very severe penalties.    All Intergraph software products are protected by copyright laws and 
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If you have questions regarding software piracy or the legal use of Intergraph software products, please call the 
Intergraph Legal Department at 256-730-2333 in the U.S. or 31-2503-66397 in Europe.
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Add-Ins Included with the Software
{button Related Topics,AL("add-ins overview high;add-ins cmd",0,`NOT_FOUND')} {button How 
To,AL("add-in how",0,`NOT_FOUND')}

The following add-in is included with the software and is located in the \Addins directory or one of its 
subdirectories. If you cannot locate the add-in on your hard disk or network drive, you can select the Macro 
Library option or other add-in option in the Setup program to install this add-in.

Add-in Description

Auto Save Automatically saves open documents at 
the interval you specify.



Hyperlinks
{button Related Topics,AL("hyperlink cmd;internet high",0,`NOT_FOUND')} {button How To,AL("hyperlink 
how",0,`NOT_FOUND')}

You may want to link an element or object in a document to other documents, such as a web page. The 
Hyperlink button on the Main toolbar is used to create, edit and follow hyperlink addresses attached to objects 
in a document. 



Using the Internet and Intranet
{button Related Topics,AL("internet community cmd;browser high;symbols high;hyperlink high;cgm 
high",0,`NOT_FOUND')} {button How To,AL("internet community how;browser 
how",0,`NOT_FOUND')}

SmartSketch is an excellent tool for publishing on the Internet. While you work on a document in the software, 
you can access the Internet and Intranet, which allows you to share design information within and across 
organizational boundaries. 

Viewing the Web

You can view the World Wide Web from within SmartSketch with a special tool called the Symbol Explorer. The 
Symbol Explorer is available only if you have installed Internet Explorer 3.0 or later. After you click the Symbol 
Explorer button on the Main toolbar, the Symbol Explorer appears on the right of document window. You can 
type the URL or directory path of an HTML page in the Address Box and press Enter to view the HTML page. 

Accessing the Internet Without Leaving SmartSketch

If you want to access the Internet, you must first be connected to the Internet with a modem. Then, you can 
access the Internet without leaving SmartSketch by clicking the SmartSketch on the Web command on the 
Help menu. 
Tip    The SmartSketch on the Web command displays in your system default web browser. If you do not have a
web browser, you can install Internet Explorer. SmartSketch on the Web works with any web browser, but you 
do get extra settings and hot links by using Internet Explorer.

From the SmartSketch on the Web web pages, you can access a myriad of tools to help you use SmartSketch 
more efficiently, keep up-to-date on product happenings, view a Web gallery of SmartSketch drawings, and 
contact Intergraph.

You can also access information from your computer or from the SmartSketch CD. So, you do not have to 
connect to the Internet to use the SmartSketch on the Web. Some of the types of information you can access 
locally are tutorials, gallery documents, and a symbol library.

Publishing Customer Drawings on the SmartSketch Web Gallery

The SmartSketch on the Web HTML page also has links to a Web Gallery that displays a collection of 
customer drawings produced with SmartSketch. The Web Gallery shows drawings from each industry: 
mechanical, civil, utilities, and so forth. 

You can submit your own drawings to the Web Gallery by following the instructions on the Web Gallery HTML 
page. Just follow the links from the SmartSketch on the Web page.



This component is not available in SmartSketch® LE. It is, however, available in SmartSketch®, the full product.



SmartSketch LE Overview
SmartSketch® LE is a technical drawing and diagramming product. It is the baseline for a line of add-ins and 
solutions for the technical drawing, CAD, and professional/business diagramming marketplace. SmartSketch® 
LE is a limited edition of the full product. It gives you the power to create quick sketches, engineering designs, 
production drawings, schematics, business diagrams, and more.

Industry solution templates with over 1,000 symbols
Sketch ideas spontaneously and accurately, instantly transforming them into precise CAD geometry
What-if scenarios and testing real-world models reduce prototyping time
Add text and spreadsheets from Word, Excel, and PowerPoint; integrate with popular databases

Industry Solutions 

Get a quick start in projects with workflow templates tailored to different industries including:
Electrical Schematics
Business Diagrams: Workflow Diagramming, Basic Diagramming, Office Layout, Flowcharts, Organization 

Charts, Network Diagrams, Atlas Mapping, and Directional Mapping
Network Diagram
Technical Drawing
Mechanical:    Mechanical Drawings (ANSI & ISO)



Customization
{button Related Topics,AL("customize cmd;toolbars cmd",0,`NOT_FOUND')} {button How To,AL("macro 
how;customize how",0,`NOT_FOUND')} {button Show Me,AL("customizing ex",0,`NOT_FOUND')}

Customization allows you to modify and enhance the software to meet your specific needs. You can use your 
favorite standard Windows programming tools and languages that are OLE-aware, such as Microsoft Visual 
Basic. There are several ways to customize the software: 

You can add built-in commands or macros to the toolbars and menus in the software.
You can go a step further and create your own macros in Visual Basic or other OLE-aware programming 

applications. Macros can automate a series of tasks and speed up your work. 

Customizing with Built-In Commands

You can add built-in commands or macros to the toolbars and menus in the software. For example, the Text Box
button is on the Dimension toolbar. If you use the Text Box button more frequently than any other button on the 
toolbar, you could add the Text Box button to the Main toolbar. If you want to offset elements, you can add an 
Offset button to any toolbar that you want.

You can also add button commands to a menu or a menu command to a toolbar. For example, you can place the
Sheet Setup command on the Main toolbar as a button.

To add a button to a toolbar or a command to a menu, you click the Customize command on the Tools menu. 
From there, you can click the Menu or Toolbars tab and click the options that you want.

If you want to create a new toolbar that does not exist in the software, you can start by clicking the Toolbars 
command on the View menu. You then click the New button and type the name of the new toolbar on the New 
Toolbar dialog box. After you click OK, the Customize dialog box automatically appears so that you can add 
buttons to the new toolbar.
Tip    When you add commands or buttons to the menus or toolbars in the software, the changes that you made 
appear only if a document is open.

Customizing with Macros

Not only can you add built-in commands or buttons to the software, you can also create your own macros that 
can be added to the menus and toolbars in the same manner. The Customize command on the Tools menu 
allows you to add macros to software's standard menus and toolbars. You can also run the macros directly by 
clicking the Macro command on the Tools menu and selecting the macro. 



Example: Customizing a Toolbar
With the Extend to Next button on the Draw toolbar, you can extend one line to the next line. This command is 
easy and intuitive to use. However, sometimes you might want to extend a line a specific distance that does not 
depend on the location of another element.
1 In the document, place two lines that are not connected, but are perpendicular.
2 On the Tools menu, click Customize.
3 On the Customize dialog box, click the Toolbars tab.
4 In the Categories box, click Macros.
5 Click the Browse button.
6 On the Select Macro Directory dialog box, click EXTEND.EXE in the \PROGRAM FILES\SMARTSKETCH\

CUSTOM\BIN\OLESVR directory.
Note If you cannot find the Custom directory, you must run the Setup program again and select the Custom 
option.

7 Click OK.
8 On the Customize dialog box, in the Macros box, drag the EXTEND.EXE filename out of the dialog box.
9 On the Custom Button dialog box, in the Buttons box, click the yellow happy face button. 
10 Click the Assign button.
11 The new button appears on a separate floating toolbar. Drag this toolbar over to the top of the window and place 

it beside the Main toolbar.
12 On the new toolbar, click the happy face button.
13 On the Extend by Distance dialog box, in the Distance box, type 10 and press Enter. The dialog box 

automatically converts whatever you type into the units of measure that are set for the current document. You 
can set the units with the Properties command on the File menu.

14 In the document, drag the mouse over the line that you want to extend. A preview of what the line will look like 
shows up in a red color.

15 Click the line to set the distance.
16 On the Extend by Distance dialog box, click Close.



Organizational Chart Templates Overview
{button Related Topics,AL("properties cmd;properties db;document cmd;drawing sheet high;paper high;styles 
high",0,`NOT_FOUND')} {button How To,AL("properties how;open how;document 
how",0,`NOT_FOUND')}

You use these templates to produce organizational charts. 
Imperial Template—This template has imperial units in decimal inches, ANSI sheet sizes, ANSI 

dimensioning, and Arial text. 
Metric Template—This template has metric units in millimeters, ISO sheet sizes, ISO dimensioning, and Arial

text.

Org Chart symbols are available in the Symbol Explorer for these templates. The Schematic toolbar containing
tools to create organizational charts appears on the left of the drawing window.    

Organizational Chart Workflow
Tip    You can create organizational charts with Maintain Relationships set on or off. 
1 Set up the sheet.

Select an appropriate sheet size and scale that allow enough paper space to draw. The default scale is 1:1.
2 Prepare to draw.

Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid Display, and Grid Snap 
commands. For more grid options, click the View tab after you click the Options command on the Tools 
menu to set the grid style to either dynamic or static, and set the static grid to the preferred grid spacing. 

These settings provide visual feedback to you to improve the workflow while you draw. To create clean 
diagrams, use Grid Snap with a static grid displayed.

Placing symbols and connectors on a static grid produces high quality results. 
You can set grid display and snap by right clicking. 

Simple Workflow Diagram 
1 Drag symbols from the Symbol Explorer.
2 Use the Connector command to connect symbols.
3 Double-click each symbol to add text.

Optimal Workflow Diagram 
1 Place Org Chart symbols by dragging them from the Symbol Explorer. 

While dragging a symbol for placement, use the left/right arrow keys on the keyboard to rotate the symbol 
dynamically before placement. Use the up/down arrow keys to select different drag points on the symbol 
before placement. 
If you press the Alt key during symbol placement, the alignment indicators are temporarily disabled, allowing 
symbol placement with grid snap or visual alignment. 
These symbols automatically expand to the size of the text. You can also size them by using the yellow 
handles.
Tip    You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 
Ctrl key and use the left mouse button to place multiple copies of the symbol.

2 Connect the symbols by using the Connector command. 
When you draw a connector that is not straight, you should set Clearance: to the minimum distance from the 
symbol where the first turn in the connector appears. 
When you draw a connector to a symbol, approach the symbol from the direction you want the connector 
placed. As the pointer intent zone nears the symbol, suggested targets for the connector appear. 
The connector end point can be located on a target or any other symbol geometry. If you press the Alt key 
while drawing a connector, the diagonal mode is temporarily invoked and the alignment indicators are 
temporarily disabled, allowing the connector to be drawn with or without grid snap.

3 Double-click symbols to place text in the center of the symbol. 



The active text settings in the file are used. To highlight existing text for editing properties, pause the pointer 
over text until the PickQuick indicator appears. 
Then click and select the numbered box that represents the text. Right-click the highlighted text to edit 
properties. 
Note that text is entered in paper units regardless of the sheet scale.

4 Finish the organizational chart. 
Use color to modify the symbols and use connectors to enhance the drawing.

The following symbol sets aid in drawing organizational charts.
Content Description 

\Program Files\
SmartSketch
\Symbols\Diagramming
\Org Chart

Organizational Chart symbols. You can 
double-click these symbols to place text. 
These symbols also have special 
behaviors for enhanced placement and 
modification.



Drawing Diagrams
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You can create diagrams quickly and easily with the software. To do this, you can use the following tools:
Industry solution templates
Symbols
Connectors
Annotations

Tip    You can learn how to draw a diagram with a tutorial in the Learning Center. Click the Help menu and then 
click Learning Center.

 

Templates

When you first open the software, you can select a template based on the industry solution that you need. The 
best templates to select for drawing diagrams are in the General Diagramming template folder. For example, you
can select the Network Diagram (Imperial) template.

When you open the Network Diagram (Imperial) template, the Schematic toolbar automatically displays the 
buttons that you would need most often to create a diagram. These commands include Connector, Grid 
Display, Grid Snap, Text Box, and others. 
Tip    You can still draw lines, circles, and so forth with buttons on the Draw toolbar. To display the Draw toolbar, 
you can click Toolbars on the View menu.

Connectors

The Connector button on the Schematic toolbar allows you to place connectors anywhere you need. You can 
connect lines, circles, symbols, or points in free space. 

There are special connector styles that you can use in the diagram. Some examples in the Network Diagram 
template include Thick, Normal, and Dashed. On the Connector ribbon bar, you can click the style that you want
in the Style box.

 

On the Connector ribbon bar, you can also select the line start and line end terminators that you want. The 
following connectors display some of the different types of terminators that you can apply.
 

Symbols

The template automatically displays the symbols that you need for a diagram in the Symbol Explorer. For 
example, the Network Diagram template offers you many kinds of symbols to include modems, servers, 
annotation, and others. 



 

To place these symbols, you can drag them from the Symbol Explorer into the document.

You can manipulate symbols with special handles that appear when you select the symbol. Some symbols have 
several different kinds of handles:

 
Black boxes on the outside corners of the range box lines represent scale handles (A). You can drag a scale

handle to resize the entire symbol.
Yellow boxes in the middle of the range box lines represent standard parametric handles (B). You can drag a

parametric handle to resize part of the symbol.
A green plus sign represents a mirror handle (C). You can drag a mirror handle to create a copy of the 

symbol directly horizontal or vertical to the original symbol.
A large green circle represents a rotate handle (D). You can drag this handle to rotate the entire symbol. 

Specific increments are displayed by the pointer while you rotate the symbol.
A series of small green circles represents drag points (E). You can use these points to attach the symbol at a

precise point to another symbol or element.
A small green lock represents a lock handle (F). You can click the lock handle to unlock the symbol. 

Unlocking allows you to move a symbol away from the element to which the symbol was associated.
Tip    A lock handle appears only if you drag the symbol to an element with one of the drag points on the 
symbol. 

Text and Labels

You can also drag labels from the Symbol Explorer. For example, the Network Diagram template offers a 
collection of Smart Labels in the \Modems folder. 

Some Smart Labels display a question mark in the Symbol Explorer. You can also double-click on some Smart 
Labels and edit the text.

 

Smart Labels can assume the attributes of the element or symbol that you drag the Smart Label to. You can edit 
the attributes of the Smart Label in the Attribute Viewer.

 

If you want to quickly add text that is associated to an element, you can double-click any element in the diagram. 



A text label appears in the center or below the element. When you type in text and press Enter, the text label 
orients itself with the element. When you move the element, the text label moves with it.
Tip    To add text that is not associated to an element, you can click the Text Box button on the Schematic 
toolbar.

Grids

You can use a grid view and grid snap to place the items in your diagram at precise intervals. You can view the 
grid by clicking the Grid Display option on the View menu. When you set the Grid Snap option on the View 
menu, elements always align with the grid lines or nearest intersection of the grid lines. 



Mechanical Templates Overview
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ANSI Template—This template has imperial units in decimal inches, ANSI sheet sizes and borders, and 
implements the ANSI Y14.5 dimensioning standard. 

ISO Template—This template has metric units in millimeters, ISO sheet sizes and borders, and implements 
the ISO dimensioning standard. 

The DIN, BSI, and JIS dimensioning standards are also available in these two templates.

When you open these templates, the Draw toolbar appears, containing tools to help you create precision 
drawings.

Part Design Workflow
Tip    You should design individual parts with Maintain Relationships turned on. 
1 Set up the sheet.

Select an appropriate sheet size. The default scale is 1:1, which is appropriate for small parts.
2 Sketch the part.

Draw the elements, using the tools from the Draw toolbar and the SmartSketch Settings command. As you 
draw, relationships are established that capture your design intent.
Tip    As an example the system remembers when you draw a line horizontally, vertically, or parallel to another
line and maintains that information when you modify the drawing. You do not need to give much attention to 
the exact size of the part; it is often easier to dimension the part and change the dimensions later. 

3 Dimension the part.
Use SmartDimension and the other dimensioning tools to dimension the part. These dimensions drive 
dimensions that can be changed to iterate your design. Redundant dimensions are shown through the driven 
elements. 

4 Refine the drawing.
Select individual dimensions and change the values to iterate your design.
If you plan to use the part in a mechanism or assembly, then select all of the geometry and create a symbol 
with an appropriate name.

Mechanism Modeling Workflow
You can design mechanisms, using rigid body symbols.
You should set Maintain Relationships on in the mechanism file. 

1 Prepare the parts.
You must save each part in the mechanism as a symbol and turn Allow Rotation by Relationships on, using
the Symbol Authoring tools, so the parts can act as a rigid body in the mechanism. 

2 Start a new drawing.
You should create the mechanism in a new drawing with an appropriate sheet scale for the whole mechanism.
Set the symbol browser to the location of the components. 

3 Drag the parts.
Drag the parts into their rough location on the sheet, but do not give much attention to precision placement or 
orientation. 

4 Connect the parts.
Use the tools on the Relationship toolbar to establish the relationships between the parts in the mechanism. 
Connect allows you to connect a specific location on one part to a specific location on another part. Use 
relationship indicators to determine the connection type, such as end point to center point or end point to 
midpoint. You can also use specific tools to establish other relationships, such as tangent, parallel, 
perpendicular, colinear, concentric, and others. 

5 Create driving dimensions.
Use SmartDimension or other dimensioning tools to establish the controlling dimensions for the mechanism. 

6 Move the mechanism.
Select a driving dimension and change the value to move the mechanism into a specific configuration. 



Production Drafting Workflow

You can produce full sets of production drawings according to the ANSI standards. 
Tip    To produce a fairly complex production drawing, set Maintain Relationships off. 
1 Set up the sheet.

Choose an appropriate sheet size and scale that allow you to draw the part. The default scale is 1:1, which is 
appropriate for small parts on an A-Size sheet.

2 Draw the views.
Draw a principle view of the part using the draw tools (with precision key-in values on the ribbon bar), 
SmartSketch Settings, and PinPoint. Draw other views using SmartSketch Settings to align key edges 
from each view. 

3 Annotate the drawing.
Use the text and dimensioning to annotate the drawing. Note that text is entered in paper units regardless of 
the sheet scale. 



Electrical Templates Overview
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You use these schematic templates to produce electrical drawings according to accepted industry standards. 
Imperial Template—This template is defined with ANSI sheet sizes and borders. The default sheet size is C 

with a 1:1 scale.
Metric Template—This template is defined with ISO sheet sizes and borders. The default sheet size is A1 

with a 1:1 scale.

Both templates point to the electrical symbol sets. The electrical symbols include main classifications of the 
following: Fundamental Items, Logic Gates, Semiconductors, Switches, Terminals and Connectors, Transformers
and Inductors, and Transmission Path.
Tip    You should design schematic drawings with Maintain Relationships set off (default setting). 

Electrical Workflow 1
1 Set up the sheet.

Select an appropriate sheet size and scale. 
2 Place an initial symbol correctly rotated. 
3 Route a connector from that symbol to form a rough outline of the circuit. 
4 From the Symbol Explorer, select the type of symbol or component needed, and drag the component onto the 

sheet and over the connector. 
The connector is highlighted when the pointer moves over the element. Most of the components automatically
align to the connector. 
Drop the symbol, and it is placed, associated to the connector. Or, if the orientation of the symbol is not 
correct, use the left or right arrows to rotate the symbol to a new orientation. When the symbol is dropped, it 
maintains the orientation.

5 Enter any attribute information that you want in the Attribute Viewer. 
When the information is changed in the viewer, the text information on the symbol also changes. If you do not 
want the attribute text, you can select the text box and delete text from the symbol.

6 Continue adding or modifying connectors and adding components until the circuit is complete.

Electrical Workflow 2
1 Set up the sheet.

Select an appropriate sheet size and scale. 
2 From the Symbol Explorer, drag the component onto the sheet to the location you want. 

Or, if the orientation of the symbol is not correct, use the left or right arrows to rotate the symbol to a new 
orientation. When the symbol is dropped, it maintains the orientation.

3 Enter any attribute information that you want in the Attribute Viewer. 
When the information is changed in the viewer, the text information on the symbol also changes. If you do not 
want the attribute text, you can select the text box and delete text from the symbol.

4 Continue dragging and dropping components as needed to complete the circuit.
5 Using the Connector command, connect the individual components.
6 Continue adding components and connecting them together until the circuit is complete.

Differences in Workflow 1 and 2
Workflow 1 places the symbol or component on the connector or wire. It does not break the wire. It only 

masks out the connector beneath it. In this case the components are glued to the connector. To modify the circuit in 
such a case, you move the connector, and the symbols follow it to the new location.

Workflow 2 places a connector or wire between the components that are placed. Workflow 2 is more of a 
real-world flow. In this case, you can select and move the components, and the connector or wires move to adjust to 
the new component location.

You can combine the workflows. You must, however, remember which is the parent and which is the child 
when you combine the two.

The following symbol sets aid in electrical schematic creation.



Content Description 

Electrical Symbols Fundamental Items
Logic Gates
Semiconductors
            Diodes
          Thyristors
          Transistors
Switches
Terminal & Connectors
Transformers & Inductors
Transmission Path



Network Diagram Templates Overview
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You use these templates to produce network diagrams. 
Imperial Template—This template has imperial units in decimal inches, ANSI sheet sizes, ANSI 

dimensioning, and ANSI text. 
Metric Template—This template has metric units in millimeters, ISO sheet sizes, ISO dimensioning, and ISO 

text. 

Network Diagram symbols are available in the Symbol Explorer for these templates. The Schematic toolbar 
containing tools to create network diagrams appears on the left of the drawing window.    

Network Diagram Workflow
Tip  You can create network diagrams with Maintain Relationships set on or off. 
1 Set up the sheet.

Select an appropriate sheet size. The network symbols are accurately scaled to 1/10th of their true size so 
you should leave the sheet scale at 1:1, the default.

2 Prepare to draw.
Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid Display, and Grid Snap 
commands. For more grid options click the View tab after you click Options on the Tools menu to set the grid
style to either dynamic or static. Set the static grid to the preferred grid spacing. 
These settings provide visual feedback to you to improve the workflow while you draw. 

Simple Network Diagram 
1 Drag symbols from the Symbol Explorer.
2 Use the Connector command to connect symbols.
3 Double-click each symbol to add text.

Optimal Network Diagram 
1 Place network diagram symbols by dragging from the Symbol Explorer. 

While dragging a symbol, use the left/right arrow keys on the keyboard to rotate the symbol dynamically 
before placement. Use the up/down arrow keys to select different drag points on the symbol before 
placement. 
If you press the Alt key during symbol placement, the alignment indicators are temporarily disabled, allowing 
symbol placement with grid snap or visual alignment.
You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 
Ctrl key and use the left mouse button to place multiple copies of the symbol.

Some network symbols mount into the rack or chassis symbols when you drag the symbol into a rack or 
chassis. When you pause over a drop point in a chassis or rack, a tool tip appears; for example, Attach 
Module. 
When you move a symbol, all associated symbols follow. To independently move an associated symbol, 
select the symbol and click the green lock. This frees the symbol from the element. A symbol is not associated
to an element if a green lock is not displayed when you select the symbol. 

2 Add attributes to the network symbols by selecting the symbol and editing fields in the Attribute Viewer.
3 Connect the symbols by using the Connector command or by dragging in Cable symbols and then connecting 

the endpoints to network symbols. The result is a symbolized connector with attribution.
When drawing connectors, you should set Clearance. Type the minimum distance from the symbols that you 
would like the first turn in the connectors to occur. This action allows you to control the visual consistency of 
connectors that make right-angle turns just before they attach to a symbol.
When you draw a connector to a symbol, approach the symbol from the direction you want the connector 



placed. As the pointer intent zone nears the symbol, suggested targets for the connector appear. The 
connector end point can be placed on a target or any of the symbol vector geometry. If you press the Alt key 
while drawing a connector, the diagonal mode is temporarily invoked and the alignment indicators are 
temporarily disabled.
Note the connect points display a tool tip when the connector end point is drawn or modified over a port on 
the network symbol. 
You can edit attribute information on the connector and the network symbols in the Attribute Viewer.    
Smart Labels are provided for network symbols and cables. These Smart Labels appear in the Symbol 
Explorer in the network symbol directories. When you drag a network Smart Label over the drag point 
(usually the lower left corner) of a network symbol, the label associates to the symbol and accesses the 
symbol attribute information. 
The description attribute data is displayed in the label. The cable labels display the type and the speed-type of
the cable. 

4 Place text. 
Double-click on the symbols to place text below the symbol or connector. The active text settings in the file 
are used. 
Right click on text to edit properties. 
To move the text, select and highlight the text. 
Click the green lock to unlock; then with the pointer, drag the text to a new position. Note that text is entered in
paper units regardless of the sheet scale.

The following symbol sets aid in drawing diagrams.
Content Description 

\Program Files\
SmartSketch
\Symbols\Diagramming
\Network Diagram

Network diagram symbols that include 
Cables, Chassis, Cards, Modules, Input-
Output Devices, Intelligent Network 
Devices, Network Accessories, Non-
intelligent Network Devices, Physical 
Plant, and Servers and Storage devices. 
These symbols have attribution and 
special behaviors for enhanced 
placement and modification.



Office Layout Templates Overview
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You use these templates to produce Office Layout drawings. 
Imperial Template—This template has imperial units in decimal inches, ANSI sheet sizes, ASA dimensioning,

and Architectural text.
Metric Template—This template has metric units in millimeters, ISO sheet sizes, ISO dimensioning, and ISO 

text.

Office layout symbols are available in the Symbol Explorer for these templates. The Draw toolbar containing 
tools to create office layout drawings appears on the left of the drawing window.    

Office Layout Workflow
Tip    You should create office layout drawings with Maintain Relationships set on. 
1 Set up the sheet.

Select an appropriate sheet size and scale that allow you to draw the design. The default scale is 1/4" = 1' for 
the Imperial template and 1:50 for the Metric template.

2 Prepare to draw.
Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid Display, and Grid Snap 
commands.
For more grid options, click the View tab on the Options dialog box to set the grid style to either dynamic or 
static, and set the static grid to the preferred grid spacing. 

These settings provide visual feedback to you to improve the workflow while you draw. To create clean 
diagrams, use Grid Snap with a static grid displayed.

Placing symbols and connectors on a static grid produces high quality results. 
You can set grid display and snap by right clicking. 

Note    You can begin by drawing the office walls or by referencing or opening a floor plan drawing.
3 Draw walls.

Click the Place Doubleline command on the Draw toolbar and set the thickness of the walls to be drawn in 
the ribbon bar. 
Click the appropriate button on the ribbon bar to indicate whether you draw from the center of the wall or one 
of the edges (primary line buttons). 
Draw the walls first. 
Next use the Trim, Trim Corner, and Extend to Next commands for any intersection cleanup.

If you press the Alt key while drawing, the alignment indicators are temporarily disabled.
When you draw the walls, you may want to select a neutral gray for the line color. After you draw the walls, 

you can avoid cleaning the intersections by color filling the walls with a solid fill of the same neutral gray color.
Use the door and window symbols to complete the floor plan. These symbols automatically align to the wall 

and can be mirrored, scaled and rotated after placement.
Note    You can also use the Place Doubleline command for drawing office partitions, along-wall working 
surfaces, counter tops, work benches, stockroom shelves, custom bookcases, custom desks, and cat walks. If
you press and hold the Shift key when you draw with the Place Doubleline command, the end caps do not 
automatically merge into another section of doubleline. This feature is useful for drawing partitions 
perpendicular to walls. You can use the Fillet command to round the corners of counter tops. 

4 Reference or open an existing floor plan.
Reference a floor plan by using Object command on the Insert menu or by dragging the existing file into the 
drawing window. Or click the Open command on the File menu to open an existing floor plan file.

5 Place office layout symbols.
Drag symbols from the Symbol Explorer. While dragging a symbol, use the left/right arrow keys on the 
keyboard to rotate the symbol dynamically before placement. Use the up/down arrow keys to select different 
drag points on the symbol before placement. 
If you press the Alt key during symbol placement, the alignment indicators are temporarily disabled, allowing 
symbol placement with grid snap or visual alignment. 
Office Layout symbols can be physically associated to walls or other symbols. When you move a symbol or a 



wall, all associated symbols follow. 
To independently move an associated symbol, select the symbol and click the green lock to unlock the 
association. A symbol is not associated if a green lock is not displayed when the symbol is selected.
You can use two methods to place multiple copies of the same symbol:

Holding down the right mouse button, drag the symbol into the template. When you release the right mouse 
button to place the symbol, you are prompted with two options. Click Stamp Here, and use the left mouse button to 
place multiple copies of the symbol.

Press the Ctrl key on the keyboard as you drag in a symbol with the left mouse button. Place the first 
instance of the symbol while holding down the Ctrl key. Once you have placed the first symbol, you can release the 
Ctrl key and use the left mouse button to place multiple copies of the symbol. 

6 Annotate the drawing.
Use text and dimensioning commands to annotate the drawing. To label, double-click symbols, walls, or other 
drawn elements. The active text settings in the file are used for labels that you double-click. 
To edit existing text properties, right-click text and select properties from the pop-up menu. To move text, click 
to select; then click the green lock to unlock. 
Move by dragging the text to a new position. Note that text is entered in paper units regardless of the sheet 
scale.

7 Finish the drawing. 
Change the color of symbols to enhance furniture or identify existing and new equipment. You can also use 
connectors to enhance the drawing by adding communication and computer networking lines.

The following symbol sets aid in creating office layout drawings.
Content Description 

\Program Files\
SmartSketch
\Symbols\Diagramming
\Office Layout

Office Layout symbols have special 
behaviors for enhanced placement and 
modification.



Engineering Fonts
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The engineering fonts delivered with the software contain industry-specific fonts, special characters, and symbols
that you can use to annotate engineering drawings. These fonts include degree symbols, diameter symbols, and 
other special characters and symbols that are not usually included in a typical word processing package. 

Your choice of font should be based on the industry for which you are creating engineering drawings.

The software provides TrueType® fonts; with TrueType fonts, what you see on the screen is what appears on the
printed page. The screen display of the document closely matches the printed document. 




