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License Agreement 
 

1. GRANT OF LICENSE.  Natara Software, Inc. ("Natara"), grants to you, the end user, a personal, nonexclusive license to use a 
single copy of this software program, including any updates, additional modules, or additional software provided by Natara in 
connection therewith (the "Software"), solely for your own use, and solely in accordance with the terms and conditions of this license 
agreement.  You may copy the Software into the memory of any computer, solely as necessary to use the Software in accordance with 
this license agreement. 
 
2. INSTALLATIONS AND USE.  Natara Bonsai is licensed to you in one of two potential configurations: (1) Single User License and 
(2) Evaluation License.  You may install and use (in he manner provided) only those configuration(s) for which you have obtained a 
license. Licenses for Natara Bonsai are individual named user licenses. No license may be shared, in any capacity, by more than one 
individual end user.   

 
(1) Single User License.  You may install and use a single copy of the Software on a single computer and handheld device.  You may 
access the Software from a hard disk, over a network, or by any other method; strictly in accordance with the terms hereof.  You may 
use each licensed copy of the Software only on a single computer and handheld device. 
 
(2) Evaluation License.  You may use one copy of the Software on a single computer and handheld device, for a period not to exceed 
thirty (30) days.  You are acquiring only the limited right to use a single copy of the Software for evaluation purposes. You are not 
acquiring any rights to the Software itself. 
  
3. COPYRIGHT AND COPIES.  The Software (including any copy thereof), is owned by Natara or its suppliers and is protected by 
United States copyright and patent laws and international treaty provisions.  The Software copy is licensed, not sold to you, and you 
are not an owner of any copy thereof.  You may either (a) make one copy of the Software solely for backup or archival purposes, or (b) 
transfer the Software to a single hard disk provided you keep the original solely or backup or archival purposes.  You may not 
otherwise copy the Software except as expressly authorized by applicable law, and you may not copy the written materials 
accompanying the Software.  Natara hereby reserves all rights not explicitly granted in this software license agreement. 
  
4. OTHER RESTRICTIONS.  You may not rent, lease or transfer the Software.  You may not reverse engineer, decompile or 
disassemble the Software, except to the extent expressly authorized by applicable law.   
  
5. LIMITED WARRANTY AND REMEDY.  Natara warrants the physical media (e.g. diskette(s) or CD-ROM), and the physical 
documentation, to be free of defects in materials and workmanship for a period of 90 days from the original purchase date.  If Natara 
receives notification within this warranty period of any such defects and such notification is determined to be correct, Natara will, at its 
sole option and discretion, repair or replace the media or documentation, or provide you a full refund.  The foregoing is your sole and 
exclusive remedy and states Natara’s and its suppliers’ entire liability arising out of this warranty.  This limited warranty is void if the 
damage or defect has resulted from accident, abuse or misapplication.   
  
6. NO OTHER WARRANTIES.  THE LIMITED WARRANTY ABOVE IS EXCLUSIVE AND IN LIEU OF ALL OTHER CONDITIONS 
AND WARRANTIES FOR THE SOFTWARE AND DOCUMENTATION.  NATARA AND ITS SUPPLIERS MAKE NO OTHER 
CONDITIONS OR WARRANTIES, EXPRESS, IMPLIED, STATUTORY OR OTHERWISE, AND EXPRESSLY DISCLAIM ALL OTHER 
CONDITIONS AND WARRANTIES, INCLUDING BUT NOT LIMITED TO IMPLIED CONDITIONS OR WARRANTIES OF 
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NONINFRINGEMENT FOR THE SOFTWARE AND 
DOCUMENTATION, TO THE FULLEST EXTENT PERMITTED BY APPLCABLE LAW.   
  
7. LIMITED LIABILITY.  TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT AND UNDER NO LEGAL 
THEORY SHALL NATARA OR ITS SUPPLIERS BE LIABLE TO YOU FOR ANY COSTS OF SUBSTITUTE PRODUCTS, OR FOR 
ANY CONSEQUENTIAL, SPECIAL, INCIDENTAL, PUNITIVE OR INDIRECT DAMAGES OF ANY KIND ARISING OUT OF THE 
LICENSE OF, USE OF, OR INABILITY TO USE ANY NATARA SOFTWARE OR DOCUMENTATION, EVEN IF NATARA HAS BEEN 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  IN NO EVENT SHALL NATARA’S OR ITS SUPPLIERS’ LIABILITY EXCEED 
THE LICENSE FEE PAID BY YOU.  THIS LIMITATION OF LIABILITY AND RISKS IS REFLECTED IN THE PRICE OF THE 
SOFTWARE LICENSE.   
  
8. TERM.  This license is effective until terminated.    You may terminate it at any time by destroying the Software together with all 
copies, modifications and merged portions in any form.  It will also terminate automatically upon your failure o comply with any term or 
condition of this Agreement.  In the event of such termination, you agree to promptly destroy the Software together with all copies, 
modifications and merged portions in any form.  
  
9. MISCELLANEOUS. This is the entire Agreement between you and Natara, and supersedes any prior agreement, whether written or 
oral, relating to the subject matter of this Agreement.  This Agreement is governed by the laws of the State of Illinois, U.S.A., without 
reference to conflict of laws principles.  All disputes arising out of this Agreement shall be litigated or otherwise resolved exclusively in 
the state of Illinois.  If any provision of this Agreement is ruled invalid, such invalidity shall not affect the validity of the remaining 
portions of this Agreement.  
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Chapter 1 Chapter 1 Chapter 1 Chapter 1     IntroductionIntroductionIntroductionIntroduction    

Natara Bonsai is a Palm OS outliner application that synchronizes with your 
Windows desktop.  Use it to outline ideas, create checklists, or perform simple 
project management tasks. 
 
Bonsai has true one step synchronization. 
 
 
Key features: 

• Both Palm OS and Windows applications 
• True one-step synchronization using HotSync technology 
• Create simple outlines, to do lists or projects 
• Multi-line in place editing of text 
• Wide range of display options 
• Drag to move or change indentation 
• Sort on any attribute 
• Filter based on multiple criteria 
• Supports both a local and the Palm OS find command 
• Color (Palm IIIc, Visor Prism) support 
• Attach notes to items 
• Link items to the built-in To Do database 
• Beam outlines to other Palm OS devices 
• Stowaway  portable keyboard support 
• TealPrint  and PalmPrint  Palm OS print driver support 
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1.1 Installation 
Extract the distribution files to a temporary directory. Run the setup.exe (or run 
the self-extracting download) and an InstallShield  application will guide you 
through the installation process. 
 
Perform these steps after installing to create and synchronize your first outline. 
 

• The install script finishes with the option to run the Bonsai.  If you 
unchecked this option and Bonsai is not already running, start it using the 
Windows Start menu.  There is a Bonsai entry under the Natara Software 
group. 

• Type in an outline. 
• Save your outline using the Save command on the File Menu.  The name 

you give the file will be used as the name of the outline on your Palm 
device. 

• Respond ‘Yes’ when prompted if you want to synchronize this outline. 
• Perform a synchronization to install the Bonsai application on your Palm 

OS device. 
• Perform a second synchronization.  The Bonsai conduit will be run since 

the Bonsai application was found on your Palm device. 
• Tap on the Bonsai icon on the applications screen. 
• Tap on the outline name, and tap open to view your outline. 

 
The license agreement allows you to evaluate Bonsai for 30 days before 
purchase.  After 30 days of use, Bonsai will allow you to view outlines, but not 
make changes or synchronize with your desktop outlines. 
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1.2 Purchasing Natara Bonsai 
You can purchase a license for Bonsai from one of several online retailers.  Links 
to these retailers can be found on the Natara website at http://www.natara.com. 
 
After purchasing a Bonsai license, you will receive a registration number by email 
(usually within 36 hours).  Follow the instructions in the email to enter your 
registration number in the registration number dialog. 
 

 
 
If you misplace your registration number, visit the Natara web site 
http://www.natara.com/Support.cfm to request your registration number. 
 

http://www.natara.com/
http://www.natara.com/Support.cfm


Natara Bonsai Outliner – User Manual 7

1.3 Running Natara Bonsai 

On the Palm Device 
Tap on the Bonsai icon to start Bonsai.  Bonsai will return to the outline that you 
were last working on. 
 

 

On the Desktop 
Double-click an existing outline file, or select Bonsai from the Natara Software 
group on the Windows Start menu. 
 

 
 
Bonsai starts a new outline when started without opening an existing outline.  
The desktop application can have several outlines open at once. 
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Chapter 2 Chapter 2 Chapter 2 Chapter 2     Requirements and LimitationsRequirements and LimitationsRequirements and LimitationsRequirements and Limitations    

2.1 Palm OS Device System Requirements 
• Palm OS 3.X or greater. 
 

2.2 Windows Desktop Requirements 
• Windows 98, NT 4.0, Windows 2000, and Windows ME. 
• HotSync Manager version 3.0 or greater 

 

2.3 Limitations 
• Each item in the outline is limited to 140 characters. 
• The outline depth is limited to 10 levels. 
• Notes attached to items are limited to 32 KB. 
• Limit of 15 user defined category names for each outline.  
• Total number of outlines and each outline size is limited to available Palm 

memory. 
• File names used for outlines that are synchronized must be unique within 

the first 28 characters. 
• Synchronizing an outline to more than one desktop machine is not 

supported. 
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Chapter 3 Chapter 3 Chapter 3 Chapter 3     Setting PreferencesSetting PreferencesSetting PreferencesSetting Preferences    

The preferences dialog is available from the Options menu on the Palm OS 
application and the File menu on the desktop.  Note that each outline has its own 
set of preferences.  Be sure to have the correct outline open when you modify 
the preferences.  
 
The initial value for the preferences is taken from a set of defaults.  The next 
section describes how to change those default preferences. 
 

 
Switch between the 2 pages by tapping on the More button. 
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Preference Description 

Numbering Pick the style of numbering to be used for the 
outline. 

Show Completion Status When checked, checkboxes and progress bars are 
shown for each item 

Show Priority When checked, the priority of each item is 
displayed. 

Show Notes When checked, if an item has a note, an icon is 
displayed towards the right side of the view (left side 
for the Windows application). 

Show Links to Built-in To Do When checked, if an item is linked to a built-in To 
Do an icon is displayed towards the right side of the 
view.  This preference is not available for the 
Windows application, where linked items are always 
displayed with gray text. 

Dates When Start Due or Complete is selected, the 
corresponding date of each item is shown on the 
right hand side of the view (left side for Windows 
application). 

Roll up Completion Status When checked, the change in the status of an item 
(checked off, percent complete change, or a change 
to a date) will be used to compute the status and 
dates of its parent items.   

Type Select the type initially assigned to new items. 
Priority Select the priority initially assigned to new items. 
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3.1 Default Preferences for New Outlines 
Each outline has its own preference settings that determine how it looks and 
behaves.  Once an outline is created, these settings can be modified without 
affecting other outlines. 
 
Bonsai has a set of initial preferences that are given to all new outlines.  A 
separate set is available on both the Palm device and the desktop. 

On the Palm Device 
The preferences dialog displayed from the view that shows the names of outlines 
is used to define the settings for new outlines.  Changing a setting in this dialog 
does not affect any existing outlines. 
 

 
 

On the Desktop 
Use the Defaults command on the File menu to display the default settings for 
new outlines. 
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3.2 Other Settings 
There are additional Bonsai settings on the Palm device.  Since most of the 
delete operations cannot be undone (unlike with the Windows application), 
confirmation prompts are displayed.  These prompts can selectively be disabled. 
 
Storage can also be at a premium on a Palm OS device.  By default, items left in 
the clipboard are deleted when Bonsai exits.  If you want to make those items 
available the next time you run Bonsai, uncheck this setting.  This does not effect 
text selections in the clipboard. 
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Chapter 4 Chapter 4 Chapter 4 Chapter 4     Outline FundamentalsOutline FundamentalsOutline FundamentalsOutline Fundamentals    

Each item in the outline has a type. Bonsai supports 3 types: Simple, To Do, and 
Task. 

• Simple items only have the text. 
• To do’s have dates (start, due, and completed), and a done/not done 

status. 
• Tasks have dates and a percent complete status. 
 

An outline can have items of mixed types.  When the preference to show 
completion status is enabled, a different symbol is shown for each item type. 
 

 
 
Items in the outline are arranged in a hierarchy.  Bonsai does not enforce a strict 
hierarchy. You are allowed to indent more than one level at a time.  Diamond 
symbols are used for items that do not have child items.  Triangle symbols are 
used to indicate items that have children items.  The triangles point to the right 
when the branch is collapsed. 
 

 
 
Many of the commands operate on the current item.  The current item is the item 
that contains the blinking insertion caret.  
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4.1 Expanding and Collapsing the Hierarchy 
Tap on the triangle symbols to expand and collapse that branch of the outline.  
There are also menu commands that will expand or collapse the current item, or 
the entire tree.  
 
 

 
The Palm application persists the expand-collapse state of the outline. 
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Chapter 5 Chapter 5 Chapter 5 Chapter 5     Creating a New OutlineCreating a New OutlineCreating a New OutlineCreating a New Outline    

On the Palm Device 
Tap the New button on the outline list view and enter the name for the outline.  
 

 
 
The name given to the outline will be used for the file name on the desktop 
during synchronization. 

On the Desktop 
From within the Bonsai application, click on the new outline icon, or use the New 
command on the File menu.  
 
When you start the Bonsai application, other than by opening an existing outline, 
it will automatically start a new outline. 
 
Use the Save command on the File menu to save the outline.  The file extension 
given to outline files is “OTL”.  Bonsai creates a file association so double-
clicking on an outline file will run Bonsai. 
 
 

Note: 
Although Windows supports very long file names, only the first 28 
characters of the file name will be used when naming the outline on 
the Palm device. 
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5.1 Using an Outline as a Template 

On the Palm Device 
Tap and highlight the outline you use as a template. Use the Copy command 
from the Outline menu to start a new outline. 
 

On the Desktop 
Open the outline file you use as a template.  Use the Save As command on the 
File menu to make a copy of the template.  You can also copy outline files to 
create new outlines. 
 

5.2 Outline Details 
A view is provided by the Palm application that shows some of the attributes of 
the outline and is used for setting the outline’s category. 
 

 
 
The popup menu of actions is displayed when you tap and hold on an outline 
name. 
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Chapter 6 Chapter 6 Chapter 6 Chapter 6     Synchronizing an OutlineSynchronizing an OutlineSynchronizing an OutlineSynchronizing an Outline    

Once a new outline has been created on the Palm device or the desktop it is 
ready to be synchronized.  During the first synchronization after the outline is 
created, the Bonsai conduit will create a matching outline on the other platform.  
During subsequent synchronizations the conduit will synchronize changes from 
both outlines into the other.  
 
Synchronization is performed at the item attribute level.  For example, if you 
make a change to the text of one item on the desktop, and check-off the same 
item as completed on the Palm device, both changes will be propagated to the 
other platform. 
 
If you change the same attribute on both platforms (e.g., modify the same text) 
the conduit will display a dialog box during synchronization to alert you to the 
conflict. 

6.1 New Outlines on the Palm OS Device 
Outlines created on the Palm device will automatically be synchronized to the 
desktop.  The file name for the outline is taken from the outline name.  The 
outline is created in the directory configured during installation. 
 
Removing the check on the synchronization option, located on the outline details 
dialog, will disable synchronization of the outline.  

6.2 New Outlines on the Desktop 
When you save a new outline, you are given the choice to configure the outline to 
synchronize. The synchronization status is shown on the status line. 
 

 
 
If you no longer want to synchronize an outline, use the Synchronize command 
on the File menu to toggle synchronization off.  You are also given the option to 
remove the outline from your Palm device during the next synchronization. 
 
 

Note: 
Close all outlines on the desktop when synchronizing. 
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6.3 Setting Synchronization Action 
Use the HotSync Manager Custom dialog to configure the synchronization action 
for the Bonsai conduit.  For normal operation, the configuration should always be 
set to ‘Synchronize the files’. 
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Chapter 7 Chapter 7 Chapter 7 Chapter 7     Grouping OutlinesGrouping OutlinesGrouping OutlinesGrouping Outlines    

7.1 On the Palm Device 
Use the category capability of Bonsai to group related outlines.  You can filter 
your outlines by category on the outline list view.  If one of the hard application 
buttons is assigned to Bonsai, pushing the button will cycle through the 
categories on this view. 
 

 

7.2 On the Desktop 
Bonsai allows you to create outline files in the directory of your choice.  You can 
group outlines by placing them in subdirectories with your other related 
documents. 
 
If you move an outline from one directory to another, use the Synchronize 
command on the File menu to update the location of the outline.  The checkmark 
indicates if the outline will be synchronized. 
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Chapter 8 Chapter 8 Chapter 8 Chapter 8     Deleting an OutlineDeleting an OutlineDeleting an OutlineDeleting an Outline    

8.1 From the Palm OS Device 

Deleting Both Copies of the Outline 
To delete an outline, tap on the outline name, and then tap the delete button.  
The outline on the desktop will be deleted during the next synchronization. 
 

 

Leaving the Outline on the Desktop 
Use the Archive command to delete the outline only the Palm device.  The 
outline on the desktop will be set to not synchronize. 

8.2 Removing from the Desktop 
Each outline is stored in a file.  So deleting an outline is as simple as deleting a 
file.  If the outline is left on the Palm OS device, the outline will be created on the 
desktop during the next synchronization.  To prevent this from happening, clear 
the option to synchronize the outline on the Palm device.  The option is located 
on the outline details dialog. 
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Chapter 9 Chapter 9 Chapter 9 Chapter 9     Renaming an OutlineRenaming an OutlineRenaming an OutlineRenaming an Outline    

Outlines can be renamed on the Palm device from the list of outlines.  Select the 
outline to be renamed, tap and hold to bring up the context menu.  During the 
next synchronization, the outline on the desktop will be renamed. 
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Chapter 10 Chapter 10 Chapter 10 Chapter 10     Adding ItemsAdding ItemsAdding ItemsAdding Items    

Bonsai is designed for quick data entry on both the Palm OS device and your 
Windows desktop machine.  As you compose your outline and finish one item, 
type (or graffiti) a return to start the next item.  The new item will be inserted at a 
level that is appropriate for the current state of the outline.  On the desktop, Shift-
Enter will give priority to inserting the new item one level below the current item. 
 
There is a preference that controls the type (Simple, To Do, Task) given to new 
items.  When starting a new outline, it is best to configure this preference for the 
most common type of item that will be added to the outline. 
 
If you paste text from another application that is composed of several lines, 
Bonsai will create an item for each line of text. 
 
 

Note: 
If an active filter will hide a new item, the filter is cleared so the new 
item will be shown. 
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Chapter 11 Chapter 11 Chapter 11 Chapter 11     Item DetailsItem DetailsItem DetailsItem Details    

Besides its text, each item has an additional set of attributes.  When not 
displayed on the outline view, these attributes can be viewed and set on the 
details dialog. 
 
The information shown on the details dialog is dependent on the item’s type. 
 

 
When using the Windows application, Alt-Enter displays the details dialog. 
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11.1 Item Types 
Each item in an outline is one of 3 types: simple, to do, and task.  The type 
assigned to an item when it is added to the outline is controlled by a preference.  
The type can then be changed from the details view. When using a portable 
keyboard, the item type can be changed using the tab key. 
 
A Simple item can be changed to either a To Do or a Task by tapping (or right 
click) on the status icon and selecting the type from the popup menu.  With the 
desktop application, right click on the completion status to display the item type 
menu. 
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11.2 Status 
Items of type To Do and Task have a completion status.  To do’s are either done, 
or not done.  Tasks have a completion status between 0% and 100%.  The status 
can be set directly on the details dialog.  The hard scroll buttons will change the 
percent complete of a task by 10% for each press. 
 
The status of an item can also be set from the outline view when the completion 
status is shown (a preference setting).  Tap (or left click) on the progress bar and 
drag left and right to change the percent complete. 
  
On both the desktop and Palm device, command and shortcuts are provided that 
toggle the completion status 
 

 
When you change the completion status of an item, the completion status of its 
parent items is recalculated.  A preference setting is available to disable this 
behavior. 
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11.3 Item Dates 
Items of type To Do and Task also have a Start, Due and Completion date.  
When a To Do is checked completed, or a Task is marked 100%, the completion 
date is set to the current date.  The completion date can also be manually set to 
another date. 
 
Besides the ability to select a date from the calendar, the Palm application 
provides a menu of quick dates.  The entries on the menu are specific to the 
start, due, and completion date uses. The pop-up menu is available from both the 
details dialog and the outline view (when a column of dates is shown). 
 
The popup menu on the outline view is also used to switch the display to one of 
the other dates. 
 

 
 
When you change the start or due date of an item, the start and due dates of its 
parent items are recalculated.  A preference setting is available to disable this 
behavior. 
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11.4 Priority 
Each item has a priority from 1 to 5, or no assigned priority.  Priority 1 is 
considered the most important.  You can filter the outline with a priority.  The 
priority of an item can be set from the outline view when the priority is shown (a 
preference setting). 
 
 

 
 
The priority assigned to new items can be set in the preferences. 
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11.5 Category 
Categories provide a customizable attribute that can be used as desired.  Each 
item in the outline can be assigned to a category, or left unfiled.   
 
The outline can be filtered on category.  For example, you could use the 
categories with a To Do list to indicate the best time of day to perform the work.  
You could then filter your To Do list on time of day. 
 
 

 
 

Note: 
Categories use the Palm OS category feature, and are limited to 15 
user-defined categories. 
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11.6 Link to Built-in To Do’s 
A check in this checkbox indicates that the item is linked to a To Do in the built-in 
To Do database. 
 
Checking this attribute will create a new To Do in the built-in To Do database 
using the attributes of the item (Name, Note, Priority, Due Date, Completion 
Status, Category).  
 
Removing the checkmark will break the link to the To Do.  The To Do is not 
removed from the database. 
 
For the Palm application, the presence of a To Do link is show with an icon on 
the right hand side of the screen.  A preference setting controls display of the 
icon.  Tapping on the link icon will jump to the To Do application. 
 
For the Windows application, the text of an item is grayed when it is linked to a 
To Do.  With the exception of the Start Date and the Completion Date, an item 
with a To Do link cannot be modified on the desktop. 
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11.7 Notes 
Tap on the note button to display and edit the note.  Each item can have a note 
up to 32K. 
 

 
 
A note icon can be displayed on the outline view (preference setting) to show 
what items have notes.  Tap on the icon to display or edit the note.  The desktop 
application shows notes in a separate window.  The note for the current item 
(where the caret is displayed) is shown in the window. 
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Chapter 12 Chapter 12 Chapter 12 Chapter 12     Deleting Items from the OutlineDeleting Items from the OutlineDeleting Items from the OutlineDeleting Items from the Outline    

To delete an item, position the caret in the item’s text and use the Delete 
command from the Record menu (Item menu on the desktop).  You can also use 
the Cut Branch command from the Edit menu. 
 
If you backspace (or Del) on an empty item, the item is deleted. 
 
 

Note: 
Deleting a parent item will delete the entire branch. 

 

12.1 Deleting Notes 
The Palm OS application has a Delete command on the Note menu to quickly 
remove a note from an item. 
 

 
On the desktop, select the entire note and type backspace. 
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Chapter 13 Chapter 13 Chapter 13 Chapter 13     Arranging ItemsArranging ItemsArranging ItemsArranging Items    

13.1 Managing the Hierarchy 
Both the Palm OS and the Windows applications support the management of the 
hierarchy through dragging and cut-paste operations.  To drag a branch, tap and 
hold on the expand symbol or diamond and drag the items. During a drag on with 
Palm OS application, a box is drawn around the branch being moved.  
 

 
 
When using cut-paste, tap on the item’s text so the insertion caret is on the item 
to be moved.  Then use the menu Cut Branch or Copy Branch commands. 

13.2 Moving Items Up or Down 
When dragging, you can scroll the view to an off screen location by positioning 
you stylus at the top (title area) of bottom (button area) of the view. 
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13.3 Changing the Indentation 
Tab and Shift-Tab can be used to quickly change the indentation of an item.  This 
is the quickest way to change indentation when using a keyboard. 
 
When using a stylus or mouse, tap/click and hold as with vertical dragging, but 
shift the item in or out.  With the Palm application, the next-field, previous-field 
graffiti strokes also change the indentation of an item. 
 
The Windows application uses a vertical line to show the indentation level.  The 
Palm OS application will redraw the item as it is shifted. 
 

 
 

13.4 Moving Items to Another Outline 
Use a cut-paste or copy-paste operation to move items from one outline to 
another.  This is supported by both Palm OS application and the Windows 
application. 
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Chapter 14 Chapter 14 Chapter 14 Chapter 14     SortingSortingSortingSorting    

The Palm application supports sorting branches by any of the item attributes.  
The outline can be sorted by 2 attributes, so that if items are equal on the first 
attribute, the second attribute is used.  The current branch (where the insertion 
caret is positioned) of the outline is sorted.  
 
There are 2 options for the scope of the sort. 

• The sort is only performed on the level of the current item 
• Besides the current level, all levels below on the current branch are 

sorted. 
 
When the current item is on the first level, and the second option is selected, the 
entire outline is sorted. 
 
The Sort Branch command is located on the Edit menu. 
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Chapter 15 Chapter 15 Chapter 15 Chapter 15     Clearing Status FieldsClearing Status FieldsClearing Status FieldsClearing Status Fields    

The Palm application has a command to clear the status for all items in an 
outline.  The Reset command is on the Outline menu on the view that shows the 
outline names.  The operations performed on the outline are: 
 

• Clear all To Do checkboxes 
• Set percentage complete of all tasks to 0%. 
• Set all dates (start, due, completed) to the ‘no date’ value 

 
There is an option to not clear the date fields. 
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Chapter 16 Chapter 16 Chapter 16 Chapter 16     FilteringFilteringFilteringFiltering    

The Palm OS application can filter what items of an outline are displayed.  The 
filter dialog is displayed by tapping on the funnel icon or by using the Filter menu 
item on the View menu. 
 
Several attributes can be filtered at one time.  Only items that match all the 
selected attributes will be displayed.  For example, it is possible to filter for 
priority 1 incomplete items from the business category.  Several of the attributes 
are mutually exclusive (e.g., Completed and Incomplete) and will toggle each 
other on and off. 
 
The outline maintains the hierarchy by displaying parent items of any item that 
matches the filter, even when the parent does not match the filter. 
 
Bonsai remembers that last filter configuration.  After clearing the filter, you can 
set the filter to this previous state by tapping on the Restore button. 
 

 
 
 

Attribute When checked  only these items are included 
Completed To Do’s and Tasks that are checked completed or 100% complete. 
Incomplete To Do’s and Tasks that are not complete. 
Late Start Tasks past their start date with a 0% complete status. 
In Progress Tasks with a percent complete greater than 0% and less than 100%. 
Unstarted Tasks with a percent complete of 0%. 
Late Finish To Do’s and Tasks at or beyond their due date that are not checked 

complete or 100% complete. 
Date To Do’s and Tasks where the date falls between the start and due 

date inclusive. 
Priority Items with a priority at least as high as the selected priority. 
Category Items with the selected category. 
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When the filter is active, the funnel icon is highlighted. 
 

 
 

Note: 
The filter is automatically cleared if none of the items in the outline 
match the filter. 
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Bonsai supports both the global Palm OS find application and an internal find 
command. 
 

17.1 Internal Find Command 
Tapping on the magnifying glass icon starts the internal find command.  There 
are also Find and Find Again commands on the View menu. 
 
When the search text is found in the outline, the view is positioned to the item 
and the text is highlighted.  The magnifying glass icon is then changed to include 
a plus sign.  Tapping again will find the next occurrence of the search string. 
 
The internal find command only searches the current outline. 
 

 
 
 

Note: 
The find text string is not case sensitive. 

 



Natara Bonsai Outliner – User Manual 40

17.2 Palm OS Find Application 
The Palm OS find application searches all applications on the Palm device.  
Bonsai supports this feature and will return outlines that contain the search text.   
 

 
 
When you tap on one of the matches, Bonsai will display the outline and place 
the caret at the search text. 

17.3 Desktop Find Command 
The desktop application Find command is located on the Edit menu.  The 
command searches the current outline for the text. 
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18.1 Importing from Other Outline Applications 
An import tool is available to import BrainForest  outlines.  The Bonsai setup 
program installed the import tool (ImportToBonsai.PRC) into the Bonsai 
installation directory.  If you need to import old outlines, install the application 
onto your Palm device using the Palm Install Tool.  An icon for the Bonsai import 
tool is added to your application screen.   
 
 

 
 

• Tap the “Bonsai Imp” icon to run the import tool. 
• Select the outline to import from the dropdown list. 
• Tap the Import Now button. 
• A message is displayed when the import completes. 

 
When you are done importing, delete the import tool using the Delete common 
on the App menu to free up memory on your Palm device. 
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Beam outlines using the Beam command from the list of outlines.  Select the 
outline to beam from the list of outlines. 
 

 
The Bonsai application can also be beamed to another Palm device.  Bonsai will 
run on the new device in the 30-day trial mode.  The command is located on the 
Options menu. 
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20.1 On the Palm Device 

Export to a Memo 
Once you have created an outline for a document and want to work on the body, 
you may want to export your outline to the memo application.  Bonsai provides 
an export command that can format a memo from your outline. 
 
The Export command is found on the Outline menu of the view that lists the 
outline names.  The export dialog has several settings for attributes to be 
included in the memo. 
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Filing Items in DayNotez 
When a Bonsai outline is used as a To Do list, it’s convenient to be able to file 
away completed items where they can be referred to in the future.  Natara 
DayNotez journal provides a great place to file the completed tasks. 
 
Use the File in DayNotez command on the Record menu to move the information 
from a completed To Do to DayNotez.  The DayNotez entry is created using the 
following information: 
 

• Item text and note 
• Category (if matching category is found) 
• Completed Date (if not set, then uses current date) 

 
After the entry is added to DayNotez, the item is deleted from the outline. 
 

 
 
 

Note: 
Only leaf items can be filed to DayNotez. 
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Creating To Do’s 
An item can be used to create a To Do in the built in To Do database.  Position 
the caret on the item to export.  Use the Create To Do command on the Record 
menu.  If the item has a note, the note will be attached to the new To Do.  The 
due date and priority are also used in creating the To Do. 
 
An item’s note can also be used to create a To Do.  Select a portion of a note 
and use the Create To Do command on the Note menu. 
 

Exporting to Memos 
Text from notes can be exported to the built in memo database.  The entire note 
can be exported, or make a selection to export a portion of the note. 
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20.2 On the Desktop 
There are several export formats supported by the desktop application.  The 
export commands are found on the Export menu off the File menu.  A dialog is 
available to setting options for the Text and HTML exports.  The dialog is 
displayed by the Options command on the same menu. 
 
Export Type Description 
CSV Creates a comma-delimited file suitable for importing into databases or 

Microsoft Excel.  The fields exported in order are: 
• Text 
• Unique identifier 
• Outline depth 
• Percent complete 
• Priority 
• Create date 
• Start date 
• Due date 
• Completed date 
• Category 
• Note 

HTML Create a web page.   
Text Creates a flat text file. 
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21.1 Printing on the Palm OS Device 
Bonsai has support for two print engines: 
 

• PalmPrint Palm OS print driver from Stevens Creek Software 
• TealPrint Palm OS print driver from TealPoint Software 

 
Using PalmPrint or TealPrint you can print your outline on compatible printers 
directly from your Palm device. For example, you can walk up to an infrared 
equipped printer, select an outline or note, and out comes your hard copy. 
 
The print command on the Palm OS application prints the outline as shown.  You 
can expand and collapse and use the filter to print the desired items. 
 
Visit the Stevens Creek web site at http://www.stevenscreek.com/pilot for more 
information about PalmPrint. 
 
Visit the TealPoint web site at http://www.tealpoint.com/softhome.htm for more 
information about TealPrint. 

21.2 Printing from the Desktop 
The print command on the desktop will print the outline as shown.  You can 
expand and collapse the outline to print the level of detail required. 
 
You can also export to HTML and print the outline from your browser. 
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