Überblick

Falls Sie schon einmal einen Ausflug ins Internet unternommen haben, dann wird Ihnen sicherlich schon einmal das bekannte Zip-Archivformat unter die Augen gekommen sein. Denn wenn man aus dem Internet Dateien herunterladen (auf den eigenen PC) will, kommt man nicht am Zip oder auch anderen Archivformaten vorbei. ZipFlash ist ein Programm das Ihnen bei der Arbeit mit Archiven behilflich ist und bietet viele nützliche Features.

  • ZipFlash kann folgende Archivformate lesen: ZIP, ZIP SFX, BH (Blak Hole), BH SFX, ZOO, ZOO SFX, RAR, ARJ, ARJ SFX, ARC, ARC SFX, CAB, HA, LHA, LHA SFX, LZH, LZH SFX, PAK, PAK SFX, TAR, GZIP, Z und außerdem noch die Kodierformate: UUE, XXE, ENC. ZipFlash unterstützt diese Formate ohne zusätziche Dos Programme. Alle Formate sind in ZipFlash integiert.
  • Entpacken lassen sich Archive der Formate: ZIP, ZIP SFX, BH (Blak Hole), BH SFX, ZOO, ZOO SFX, RAR, ARJ, ARJ SFX, ARC, ARC SFX, UUE, XXE, ENC.

  • ZipFlash kann Archive in den folgenden Formaten schreiben: ZIP, ZIP SFX, BH (Blak Hole) und außerdem die Kodierformate: UUE, XXE.

  • Mit dem Programm-Modul SFXFlash steht Ihnen eine komfortabele Möglichkeit zur Verfügung um ZIP SFX-Archive zu erstellen.Sie können den Fenstertext des selbstentpackenden Archives frei wählen, außerdem können Sie optional ein Autorun Archiv erstellen (Datei nach dem Entpacken direkt ausführen).

  • Mit BlowFlash steht Ihnen ein Werkzeug zur Verfügung, mit dem Sie Ihre E-Mails und Dateien verschlüsseln können. Zur Verschlüsselung wird der bekannte und sichere Blowfish Algorithmus verwendet. Wem das DOS Komando DEL nicht ausreicht, kann Dateien nach der Empfehlung des D.o.D (U.S.Amerikanisches Verteidigungs Ministerinum) vernichten lassen. (Die Daten werden dreimal mit unterschiedlichen Bits überschrieben).Vorsicht: Dateien die Sie mit Blowflash vernichtet haben, können nich t wieder hergestellt werden.

  • ZipFlash kodiert Ihre Archive mit dem UUE ,XXE und ENC, um sie als E-Mail verschicken zu konnen.Mit dem ENC Format sind Sie auch in der Lage, UUE und XXE kodierte Archive und Dateien in beliebig große Fragmente zu splitten und auch wieder zusammen zusetzen.

  • Mit der Archiv suchen Funktion finden Sie jedes verlegte Archiv auf Ihrer Festplatte in Sekunden wieder.

  • Internet Support bietet ZipFlash durch seine ARJ, ARC Unterstützung und die UUE und XXE Kodierung.

  • Falls ein Archiv ein Softwareinstallations Programm (setup.exe,install.exe) enthält, können Sie aus dem Archiv heraus automatisch die Installation ausführen ohne das Archiv entpacken zu müssen.

  • Die Windows eigenen Programme:Explorer, MSBackup und der Cleanmannager (Win98) können aus ZipFlash heraus gestartet werden.

Durch die sehr einfache Bedienung wird die Arbeit mit ZipFlash zum Kinderspiel. Archive öffnen sie einfach mit einem Doppelkilck, sobald ein Archiv geöffnet ist, haben Sie die Möglichkeit Dateien und ganze Ordner per Drag and Drop zuzufügen. Für erfahrene Anwender steht eine Wildcard Funktion zur Verfügung.

Nutzen Sie die verbilligte Update Möglichkeit auf ZipFlash Version 1.1.


Archjve entpacken

Archive entpacken

Um ein Archiv zu entpacken öffnen Sie das gewünschte Archiv und drücken in den Knopfleiste auf Entpacken. In dem Dialog der sich jetzt öffnet wird der Pfad angegeben und/ oder ob vorhandene Dateien überschrieben werden sollen.Wenn jetzt der Knopf Entpacken gedrückt wird, dann wird das Archiv entpackt.


Archive öffnen

Um ein Archiv zu öffnen haben Sie drei Möglichkeiten. Der einfachste Weg führt über die Buttonleiste. Einfach öffnen drücken und Archiv auswählen. Die zweite Möglichkeit ist das Menü und die dritte über das Kontextmenü.


Dateien einsehen

Dateien einsehen oder ausführen

Mit dem Button Einsehen können Dateien eingesehen oder ausgeführt werden. Ausführbare Dateien(*.exe) sollten Sie besser nicht ausführen ohne das ganze Archiv zu entpacken, denn viele Exe Dateien brauchen zum korrekten Betrieb weitere Dateien. Die Dateien werden mit der in Windows verknüpften Anwendung gestartet.Wenn der Dateityp nicht verknüpft ist, zeigt Zip Flash die Datei im Notepad an.


Dateien zufügen

Archive neu erstellen und Dateien zufügen und entfernen

Um ein neues Archiv zu erstellen, drückt man in der Buttonleiste auf Neu! Daraufhin öffnet sich der Dateien zufügen Dialog, indem jetzt Dateien oder Ordner ausgesucht werden.Wenn Sie Ihre Wahl getroffen haben, dann drücken Sie Fertigstellen und die Dateien werden zugefügt. Als modernes 32 Bit Windows Programm unterstützt ZipFlash auch das zufügen von Dateien per Drag and Drop.Um Dateien zu entfernen, markieren Sie einfach die Dateien, die Sie aus dem Archiv entfernen möchten.Wenn Sie jetzt Entfernen drücken, werden die markierten Dateien gelöscht.


Archive suchen

Durch die integrierte Archivsuchvorrichtung finden Sie Archive, egal wo Sie sich auf Ihrem PC befinden. Um Archive suchen zu benutzen drücken Sie im Tools Menü Archive suchen und der Suchdialog öffnet sich. Nachdem Sie ein Laufwerk und ein Archiv Format gewählt haben drücken Sie auf Suchen. Jetzt durchsucht ZipFlash ihr Laufwerk nach dem gewählten Archiv Typ und zeigt alle gefundenen Dateien in einer Liste an.Um ein Archiv zu öffnen markieren Sie ein Archiv und drücken Öffnen und das Archiv wird geöffnet. Sie können auch das gewählte Archiv doppel klicken, dies hat den selben Efekt.


Internet

Internet Formate

Als zeitgemäßer Packer unterstützt ZipFlash natürlich auch E-Mail Kodier Formate wie UUe, XXe und das von vielen UUencodern benutzte Enc Format.
Um ein Archiv UUe oder XXe zu kodieren, drücken Sie einfach im Internetmenüpunkt UUE oder XXE und die kodierte Datei wird im gleichen Verzeichnis abgelegt wie die Ursprungs-Datei.


SFXFlash

Mit dem SFXFlash Light Modul sind Sie in der Lage selbstentpackende Archive im Zipformat zu erstellen. Ein selbstentpackendes Archiv ist ein Archiv, das sich auch auf einem Pc auf dem kein ZipFlash oder kompatiebeler Packer installiert ist, selbst entpacken kann. Um ein solches Archiv zu erzeugen, rufen sie über das Zipflash Toolsmenü SFXFlash auf. In dem Fenster das sich daraufhin öffnet, geben Sie ein vorhandenes Zip Archiv an und drücken auf weiter. Im nächsten Schritt geben Sie einen Fensternamen und den Pfad auf dem ZielComputer an.Wenn das Archiv auf dem Zielrechner ins Temp Verzeichnis entpackt werden soll, müssen Sie das Kästchen ankreutzen.. Im jetzt folgenden Schritt legen Sie fest, ob bereits vorhandene Dateien standardmäßig überschrieben werden sollen oder nicht. Nachdem Sie auf weiter gedrückt haben müssen Sie sich entscheiden, ob der Anwender Ihrer SFX Archive Zugriff auf die Dateiauswahl haben soll oder nicht. Außerdem müssen Sie sich entscheiden ob der Anwender entscheiden darf ob Dateien überschrieben werden oder nicht. Im nächsten Schritt müssen Sie sich entscheiden, ob Sie ein Autorun Archiv erstellen wollen oder ob Sie die Möglichkeit einer Komandozeile geben.Für ein Autorun Archiv müssen beide Kästchen angekreutzt werden und eine Komandozeile eingegeben werden.

Für die Komandozeile wird folgende Zeichen gebraucht.
Kommt in der Komandozeile das zeichen >< vor ersetzt es den Pfad zum Archiv.
z.B. ><readme.txt startet readme.txt direkt nach der Installation.

Das Zeichen | trennt den Programm Parameter vom Aufruf.
z.B.><setup\setup.exe|><install.inf startet ...\setup\setupexe mit den Parametern aus ...\setup\install.inf (Die drei Punkte stehen für das Verzeichnis indas entpackt wurde)

Weitere Beispiele

notepad|><readme.txt startet das Windows Notepad und zeig ...\Readme.txt an.

><readme.txt startet Readme.txt mit dem Programm das mit TXT Dateien verknüpft ist.

><setup.exe startet drekt nach dem Entpacken die Software Installation.

Nachdem Sie eine Komandozeile eingetragen haben drucken Sie SFX Erzeugen und ihr Archiv wird umgewandelt.


BlowFlash

Das Blowflash Modul dient der Datensicherheit und ist in der Lage Dateien mit dem bekanten Blowfish Algorithmus zu verschlüsseln und sicher von Ihrer Festplatte zu löschen. Die Arbeit mit BlowFlash gestaltet sich sehr einfach. Nachdem Sie den Namen der Datei die verschlüsselt werden soll angegeben haben und auf weiter gedrückt haben, müssen Sie sich nur noch für ein Passwort entscheiden (je länger desto besser). Jetzt drücken Sie einfach Verschlüsseln und die Datei wird verschlüsselt. Das Entschlüsseln einer Datei verläuft genau so, nur das als Ausgangs Datei eine verschlüsselte Datei dient. Um Dateien restlos von Ihrer Festplatte zu entfernen rufen Sie die Registerkarte Dateivernichtung auf, wählen die Datei aus und das war´s auch schon .Die Dateien werden nach der enpfohlenen Methode des U.S amerikanischen Verteidigungsministerium (D.o.D.) verschlüsselt. Bei dieser Methode werden die Dateien dreimal überschrieben. Sie können Dateien aber auch nur einmal überschreiben lassen. Das Schlüsselsystem von BlowFlash arbeitet mit dem sicheren Sha1 Algorithmus.

Vorsicht: Dateien die Sie mit Blowflash löschen können Sie nicht wieder herstellen.
Vorsicht: Es besteht keine Möglichkeit verschlüsselte Daten ohne Passwort wieder herzustellen.


Möglichkeit zum Erwerb einer verbilligten Updatelizenz

***************************************************************
Den Lesern der Typemania Zeitschriften stellen wir die
Möglichkeit zur Verfügung sich für die Version 1.1 von
ZipFlash verbilligt registrieren zu lassen. Der Preis
einer Update-Einzellizenz beträgt 35,- DM (inklusive
Schlüsselversand). Der reguläre Preis einer Einzel-
lizenz beträgt 40,-DM. Sie sparen also immerhin 5,- DM.
Bitte benutzen Sie das beiliegende Bestellformular für
Ihre Bestellung.

***************************************************************
Zusätzliche Features von ZipFlash 1.1

* Zusätzliche Formate schreiben: LHA/LZH (*.lzh), Cabinet(*.cab),
ENC(*.enc);

* Zusätzliche Formate entpacken: Unixformate TAR(*.tar) und GZIP(*.gz), Cabient(*.cab),LZH(*.lzh),LZHSFX(*.exe),LHA(*.lha),LHASFX(*.exe);

* Verbesserte Programmoberflache: Treeview (Mit Hilfe des
Treeviews können Sie Archive mit nur einem Mausklick öffnen,
außerdem können Sie über den Treeview sogar Archive öffnen
und bearbeiten die sich schon im Windows Papierkorb befinden.);
Zwei weitere Symbolleisten zu schnellen Zugriff auf alle
wichtigen Funktionen.

* Funktionen zum Test und Reparieren von beschädigten Archiven.

* Entpacken per Drag and Drop, so haben Sie nach dem Öffnen direkt
vollen Zugriff auf die komprimierten Dateien.

* Auf Wunsch fügt sich ZipFlash in den Explorer ein so ist ein
blitzschnelles Entpacken gewährleistet.

* Sie können jede Datei zum ver oder entschlüsseln über das Sentto-Menü
im Explorer an BlowFlash schicken.

* BlowFlash bietet eine Schlüssellänge von 64Bit.

* Zugriff auf weitere Windows Systemprogramme.(Anwendungen starten oder
Disketten formatieren.

* Erstellen von Multivolume Archiven.(Verteilen von Archiven auf Disketten)

* E-Mail Dateisplitting ermöglicht das aufsplitten von Dateien auf Fragmente
beliebiger Größe.

* Außerdem lassen sich aus ZipFlash heraus die beiden großen Browser starten.

**************************************************************

Die aktuelle Version von ZipFlash finden Sie im Inter-
net unter: http://www.flash-systems.de

Falls Sie noch Fragen haben, wenden Sie sich bitte an:
E-Mail: info@flash-systems.de


Lizenzvereinbarungen

ZipFlash Light Version 1.01 Copyright (c) 1999 SWE von Schleusen

**************************************************************************

Wichtige Information!

Bei ZipFlash Light handelt es sich um ein Lightware-Produkt.

Es ist den gestattet, die Lightware-Version von ZipFlash Light

kostenlos zu nutzen.

Sie dürfen ZipFlash Light auf einem Einzelcomputer benutzen

und eine Kopie zu Archivierungszwecken erstellen.

Es ist untersagt ZipFlash Light ganz oder teilweise zu verleihen, zu

vermieten oder Unterlizenzen zu vergeben.

Auf keinen Fall dürfen Sie die ZipFlash Light dekompilieren, disassemblieren

oder zurückentwickeln (Reverse Engineering) oder auf andere Weise

versuchen, den Quellcode des Programmes zugänglich zu machen.

Außerdem dürfen Sie das Programm nicht verändern oder übersetzen und

keine davon abgeleiteten Produkte erstellen oder vertreiben.

**************************************************************************

SFXFlash Light

Die mit SFXFlash erstellten selbstextrahierenden ZIP-Archive

enthalten unter anderem einen Teil des SFXFlash Modules.

("Dekomprimierungs-Software")

Diese Software unterliegt den selben Schutzbestimmungen

wie ZipFlash Light.

***************************************************************************

Ausschluß von Gewährleistungen

ZipFlash Light und die dazugehörigen Dateien werden ohne Garantieleistungen

vertrieben. Es wird keine Gewährleistung für den Einsatz von ZipFlash Light

zu einem speziellen Zweck übernommen, da ZipFlash Light unter vielen verschiedenen

Hardware und Softwareumgebungen installiert werden kann. Ein gründlicher Test der

Software mit unkritischen Daten sollte dem endgültigen Einsatz vorausgehen,

um Datenverluste zu vermeiden. Der ZipFlash Light-Anwender trägt selbst jedes

Risiko. SWE von Schleusen übernimmt keinerlei Haftung für Funktion oder Richtigkeit

dieses Programms (ZipFlash und Module) oder der Anleitung. Weiterhin ist

SWE von Schleusen keinerlei Schäden oder ähnliches haftbar, die mit dem Programm

in Verbindung stehen sollten!

Der Benutzer gewährleistet, daß er mit der Benutzung von ZipFlash Light (BlowFlash Light)

nicht gegen geltendes Recht verstößt.