Smilers help

Smilers

This is the smilers help file..

How to play

Hints

Credits

Visit also the Smilers website!


Smilers help - credits

Credits

Programming by Kimmo Lahtinen
 kimmo.lahtinen@finnishgames.com
kimmol@sci.fi
http://kimmo.finnishgames.com
http://www.sci.fi/~kimmol

Graphics by Pekka Palmu
 pekka.palmu@finnishgames.com
http://pekka.finnishgames.com

Sound by Tommi Lahtinen
 tompa.lahtinen@sci.fi
http://www.sci.fi/~kimmol/tompa

Feel free to contact if necessary.

Visit also the Smilers website!

back


Smilers help - hints

Hints

Every level in the game has been completed and tested throughly, so every level can be completed. Don't give up!

Diamonds that you can't get without getting stuck?

There is one level in which the only way to continue is to take all the diamonds that are falling on you by pressing the reach button down and pressing upwards, so every diamond that falls on you gets collected. Helpful to know.

Absolutely stuck?

If absolutely stuck with no idea how on earth to continue you can rename the levels so that the level you're stuck in switches places with some easier level you've played before and know how to complete. Just complete that level and you're free to continue. Although this isn't the most sofisticated solution to the problem, it works! Also renaming in any other way works, the program finds it's levels so that it first checks the last level you've completed and then loads the next one in the numerical order until there isn't any more levels available when it asks if you'd like to start over again.

back


Smilers help - how to play

The goal

The goal is to reach the door with either of your smilers in the given time and collect the amount of diamonds required.

Keys

Keys for the green player:

Use A,S,D,W to move the smiler
TAB for "reach"

Keys for the yellow player:

Use arrows to move the smiler
SPACE for "reach"

Pieces

These are the brave heroes you control to make it through the numerous of interesting puzzles!

Basic dirt that you'll be constantly digging through.

A diamond, you're supposed to collect enough these to complete levels.

The rock, very heavy piece of granite that squashes you instantly if it falls on you. Also can be used to detonate explosives by dropping on them. They can also be blown up.

The door. End your level here after you've collected the required diamonds.

Bricks. Simple walls that can be blown up.

These and everything else not mentioned in the help are undestructable pieces just to exist there to block your way around and make the levels look a bit better.

Explosives, the dynamite explodes on a 3x3 area and the spikey thingie on a devastating 5x5 area.

The fearsome monster! Though not very brilliant, it still kills you on contact. Stay away from these buddies. They also can be killed and turned to diamonds by blowing them up or squashing them with a rock. Can sometimes act unexpected, so be careful!

Slime, undestructable and constantly spreading. Don't give these thingies much air, or you'll be in trouble soon.

Teleports that land you somewhere in the level. If there are more teleports of the same color, they'll all land you to the same place.

The switch and the gate it's supposed to be opening. There can be a maximum of 3 different switches in one level.

back