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File menu commands

The File menu offers the following commands:

New Creates a new session file.
Open Opens an existing session file.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Exit Exits Session Guru!.

Edit menu commands

The Edit menu offers the following commands:

Undo Reverse previous editing operation.
Cut Deletes data from the document and moves it to the 

clipboard.
Copy Copies data from the document to the clipboard.
Paste Pastes data from the clipboard into the document.

View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Session menu commands

The Session menu offers the following commands, which enable you to modify the contents 
of a work session and to launch the files listed in the session:

Add item... Let you select a new program or document file to insert before 
the item selected in the list (if any).

Delete item Remove the item currently selected in the session
Launch all Open each document in the session generating a .LOG file.
Optional 
parameters...

Used to edit command line options

Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays the version number of this application.

New command (File menu)

Use this command to create a new document in Session Guru!.

You can open an existing document with the Open command.



Shortcuts

Toolbar:
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing document in a new window.

You can create new documents with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
Session Guru! document files .SGU

Drives
Select the drive in which Session Guru! stores the file that you want to open. 

Directories
Select the directory in which Session Guru! stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Save command (File menu)

Use this command to save the active document to its current name and directory.    When 
you save a document for the first time, Session Guru! displays the Save As dialog box so you
can name your document.    If you want to change the name and directory of an existing 
document before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active document.    Session Guru! displays the Save
As dialog box so you can name your document.    

To save a document with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save a document with a different name.    A filename can contain 
up to eight characters and an extension of up to three characters.    Session Guru! adds 
the extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
documents you closed. Choose the number that corresponds with the document you want to
open.



Exit command (File menu)

Use this command to end your Session Guru! session.    You can also use the Close command
on the application Control menu.    Session Guru! prompts you to save documents with 
unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Undo/Can't Undo command (Edit menu)

Use this command to reverse the last editing action, if possible.      The name of the 
command changes, depending on what the last action was.    The Undo command changes to
Can't Undo on the menu if you cannot reverse your last action.

Shortcuts

Toolbar:
Keys: CTRL+Z or

ALT-BACKSPACE



Cut command (Edit menu)

Use this command to remove the currently selected data from the document and put it on 
the clipboard.    This command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+X



Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is unavailable if
there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point.    This 
command is unavailable if the clipboard is empty.

Shortcuts

Toolbar:
Keys: CTRL+V



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in Session Guru!, such as File Open.    A check mark appears next 
to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in Session Guru!,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Open a new document.

Open an existing document.    Session Guru! displays the Open dialog box, in which 
you can locate and open the desired file.

Save the active document or template with its current name.    If you have not named
the document, Session Guru! displays the Save As dialog box.

Remove selected data from the document and stores it on the clipboard.

Copy the selection to the clipboard.

Insert the contents of the clipboard at the insertion point.

Add an item to the active document.

Delete the item currently selected.

Open (execute) the files listed in the session.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the Session Guru! window.    To display or hide 
the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using Session Guru! and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of 
Session Guru!.



Context Help command 

Use the Context Help command to obtain help on some portion of Session Guru!.    When you
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and 
question mark.    Then click somewhere in the Session Guru! window, such as another 
Toolbar button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

Session Guru! title bar contains the following elements:
Application Control-menu button
Minimize button
Name of the application
Name of the document



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.



Size command (System menu)

Session Guru! uses fixed size documents and does not let you size its window.

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the Session Guru! window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: ALT+F4 closes the Session window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Modifying the Document

A Session is modified either by adding or deleting items, or by supplying additional 
parameters for an item.

Use the Session menu command Add item... to insert a new item in a session.
Clicking this icon will execute the Add item command.

Use the Session menu command Delete item to remove from the list the item selected.
Clicking this icon will execute the Delete item command.

Double clicking on any item of the list will bring up the additionnal parameters dialog.



No Help Available

No help is available for this area of the window.



Add item... command (Session menu)

This command brings up an "open file" dialog that lets you select one file to add to the 
active session. This file can be a program (with .EXE, .COM, .BAT or .PIF extension) or it can 
be a document. 

If you select a document, it must be "known" by the Windows shell. In other words, some 
kind of association must exist between this type of document and a program. It will be either
a registration database entry (see Regedit.exe) or a File Manager association. In both cases, 
if double clicking the document in the file manager open it, it will be possible for Session 
Guru! to find its owner. 

Another easy method to add files to the session is called "Drag and Drop". You must open 
the File Manager and Session Guru!. In the file manager, select the files that you wish to 
add, click on one of the files and drag it above the Session Guru! window. The cursor shape 
will change indicating that Session Guru! is "Drag and Drop" aware, you can safely release 
the mouse button. Session Guru! will automatically add the files to the active session.

Shortcuts

Toolbar:



Delete item command (Session menu)

This command will delete the selected list entry from the active session. To activate this 
command an item of the session must be selected.

Shortcuts

Toolbar:



Launch all command (Session menu)

This command will open all the documents and programs listed in the session. It will also 
generate a report with the name of the files launched as well as the return value. If this 
return value is greater than 32, then everything went fine. Else, you should have a look at 
the error codes section to understand what happened.

Shortcuts

Toolbar:
Keys: F10



Optional parameters... command (Session menu)

This command will open a dialog for the selected pathname. This dialog will let you modify 
the command line created by Session Guru!. See Edit additional parameters for more 
information.

Shortcuts
Mouse: Double-click the selected item in the session pathname's list



Error codes meaning

If an error happened launching a document or program, the return value is less than 32. See 
the table bellow for a complete description of each error code.

0 System was out of memory, executable file was corrupt, or 
relocations were invalid.

2 File was not found.
3 Path was not found.
5 Attempt was made to dynamically link to a task, or there was a 

sharing or network-protection error.
6 Library required separate data segments for each task.
8 There was insufficient memory to start the application.
10 Windows version was incorrect.
11 Executable file was invalid. Either it was not a Windows 

application or there was an error in the .EXE image.
12 Application was designed for a different operating system.
13 Application was designed for MS-DOS 4.0.
14 Type of executable file was unknown.
15 Attempt was made to load a real-mode application (developed for

an earlier version of Windows).
16 Attempt was made to load a second instance of an executable file

containing multiple data segments that were not marked read-
only.

19 Attempt was made to load a compressed executable file. The file 
must be decompressed before it can be loaded.

20 Dynamic-link library (DLL) file was invalid. One of the DLLs 
required to run this application was corrupt.

21 Application requires Microsoft Windows 32-bit extensions.

Defining a Session

Session Guru! is a very simple software, its goal is to create and manage Sessions.

What is a Session?
A session is a set of programs active in the same time.
I often use my computer with several programs interacting (for example a word processor, a 
spreadsheet and a database), and thus I launch each program, open the needed documents 
and after these operations, I can work. It can be a heavy procedure in case you use many 
programs. It can be a real loss of time if you have a wide range of activities that brings you 
to change several times a day of programs sets.

What is the limit for the contents of a session ?
Each session can hold as many programs and documents as the memory of your PC can. 
The idea beyond Session Guru! is providing a flexible tool to set up and launch sessions in a 
snap. Because a computer can be shared by several people or because you might need 
several different sessions, Session Guru! provides the interface needed to store, retrieve and
edit your sessions.

How to use Session Guru!
Just double click the session document icon and click the Launch all icon.
 I have made a group in the Program Manager called "Sessions", and added to this group the
various sessions that I need. Whenever I need a given configuration of my PC, I just Double 
click the icon of the session. It opens the program (Session Guru!) and the session is loaded. 
If I need a change in my session I can modify it (Add or Delete items) before to click on the 



Launch all button to set up my work environment. 



Copyright

Session Guru! is a Freeware. It means that you can freely use this software, make as many 
copies as you want and GIVE them away, provided you do not modify the presentation, or 
the composition of the package. My goal is to supply Microsoft Windows users with a useful 
(at least I hope so!) tool, for FREE. If you like this product, make a copy for your friends and 
colleagues. Feel free to contact me to report problems or suggestions.

On the other hand : The commercial use of this product is not permitted by the author. In 
other words no person, nor company, is allowed to make profits with this product without the
prior written permission of the author. This copyright applies to all countries.

Copyright © Pierre-Eric Colin, 1993. 
2 rue Servien 
92190 Meudon
France. 
E-Mail : CompuServe 100121,2155



Installation

The session files, created by Session Guru! use the following extension : .SGU 
In the program folder, you will find the following files :
SGURU.EXE The program file.
SGURU.HLP The program help file - The file that you are currently 

consulting.
SGURU.LOG The log file, that reports the result of the last Launch all 

command.
README.TXT Last minute information and comments that couldn't be 

included in this help file.

In the Windows directory, you will also find the file named:
SGURU.INI The program initialization data.

In the System subdirectory of the Windows directory, you will also find the file named:
CTL3DV2.DLL Dynamic Link Library.

Testing procedure

Session Guru! uses the standard Microsoft Windows Launching routines, thus each launch 
command is fully protected by the Windows Shell. The process is usually very safe but, to 
avoid crashes (always painful), I recommend that you perform basic testing before to add a 
program file to your session.

Each program installed by Session Guru! can bring in several styles of problems. The first 
problem source would be the lack of memory, it may also happen that a program is 
incompatible with another program in the session (low probability), may be a program has a 
special running convention unknown to Session Guru! or may be it is not compatible with 
Microsoft Windows (especially with DOS programs). Or more simply, may be the sprite 
running the machine is in a bad mood, who knows?...

My experience shows that it is more wise to add programs to the session after a simple but 
serious test process. I recommend that you add the items in the list one by one, testing each
time. I know that this is not fun and that it is a time consuming process... same as backing 
up your disks... until your hard drive crashes!

1) Start with a new session, then, add the file you want to put in your session, then, Launch 
all. Check the log file, if everything is OK, step #1 is completed. If not, see the error codes 
for a better understanding of what went wrong.

2) Open the session in which you plan to add the program (or document), Add the program 
to the list and Launch all. Check your log file as in step #1. Then go to the Program Manager
and activate the About... item in the Help menu, to check if the system has sufficient 
resources left. if everything is OK, step #2 is completed.
 
3) You can now Add your program to the session and Save as a new session. Step #3 is 
completed, you can use your session.

If you reached step #3 you can now launch your session in a single operation.

In addition, if you are trying to open a document, you must take care of a few other things :
* Take care with programs that cannot be launched more than once, don't try to launch them
several times. (Single instance programs) 
* Take care with single documents programs (don't try to open several documents). 



* Use the file extensions as defined in the [EXTENSIONS] section of the Win.ini file.
* Avoid opening several times the same document (Sharing violation).

Important Notice : During the test process, you must not open documents without backups 
into your programs, in case of compatibility problems, system could crash, ending in a loss 
of data.



Edit additional parameters

Some program can receive and understand additional parameters. These additional 
parameters are different from a document name. They can tell a program whether it should 
start with a new document or not, or maximized, or minimized and so on. All these options 
are changing from one program to the other. You should refer to the program documentation
regarding the use of these parameters.

The popular /? used under MS-DOS is an example of additional parameter, this option, 
happended to a command name was usually displaying the command syntax and 
miscellaneous options. For example, under Windows, EXCEL.EXE /M will open the famous 
spreadsheet with a new Macro document instead of a new spreadsheet.

You can edit the "command line" for your programs by double clicking on the program entry 
in the session list. It will bring up the dialog above. This dialog supports the CTRL+X, 
CTRL+C, CTRL+V, for cut, copy and paste, as well as all standard editing commands. You 
just have to type in the additional parameters on the command line, as you would type the 
using the Windows File menu Run command.

It is safer that you do not modify the first part of the command line (the one built 
automatically during Add item or drag and drop). This command line contains the full 
pathname to the application. If this information was changed to an invalid pathname, errors 
could occur.

IMPORTANT : You must ABSOLUTELY leave a "space" character between the program or 
document name and the first option. Otherwise, Session Guru! will not recognize the name 
of the item to be launched.

Good EXCEL.EXE /M The program will be launched without error
Bad EXCEL.EXE/M Session Guru! will be looking for a file with an incorrect

name (5 characters extension) and will fail

Maximize command (System menu)

Session Guru! uses fixed size documents and does not let you maximize its window.

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.






