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"Lock em out of your Windows applications."        Applock prevents unauthorized use of any Windows 
applications by presenting the user with a password access dialog.    Applock, when used as an 
adjunct to OverSeer PMS or KDeskTop, provides complete control over access to all Windows 
programs.
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System Requirements
· PC running 386 or higher processor
· MS-DOS 5.0 or later
· Microsoft Windows 3.1
· Mouse preferred but not necessary
· Speaker or sound card for sound capabilities
· Common knowledge of Windows environment



Introduction

Figure 1

Applock allows you to lock out or restrict the use of Windows applications and therefore keeps out 
unauthorized users.    When trying to launch an application, the password must be entered correctly 
or access is denied.    Applock, when used with Program Managers' restrictions or as an adjunct to 
KDeskTop or OverSeer PMS, provides complete control over access to all Windows programs.    See
Program Manager Security for more information on how to protect your Program Manager setup.

Once you have configured Program Manager to protect your applications, these    applications cannot
be started without a password.    Use ALSetup immediately to set your new password. The DEFAULT
password is SENTRY. 

When Applock appears, the name of the restricted program or file is displayed below the window title 
as follows:    Waiting to launch: "restricted program".(See Figure 1.)    Enter your password and click 
the OK button and "restricted program" is launched with a little message from Applock. (Unregistered
version only)    If you type the wrong password, the title bar displays " Sorry, Try Again" and a 
wavefile is sounded if you have your system set up for sound.    Hit the Cancel button to abort the 
procedure.

Getting Started
Protecting Programs
Program Manager Security
General Program Manager Setup Reference



Startup Information
What's New with version 1.1:
· Built-in registration routine has been added.
· Applock is fully integrated with and configurable via KDeskTop.

Let's Get Started!
1 After running the install program and viewing the Read1st.txt.    Please read this help file. Then 

proceed as noted below.
2 Once Applock has been installed, run ALSetup to change the password from the default "sentry" 

to the password of your choice.
3 ALSetup uses the same password that is used by Applock.
4 Protect the documents or programs that you want to have restricted access. Any icon in Program

Manager can be protected.    See protecting programs for more information on how to protect an 
item or icon.

5 Protect Program Manager by modifying progman.ini as noted in the Program Manager Security 
topic.    Use notepad or your favorite text editor to add the necessary changes.(Be sure to make a
backup of progman.ini before making any changes.)    OR    Download KDeskTop or OverSeer 
PMS, to automate this    task.

6 The files necessary to use Applock are: Applock.exe, ALSetup.exe, Ctl3d.dll.



Protecting Programs

Figure 2

Protecting your Program Manager items with Applock
Applock must be used with a command line argument to do something useful. If you run this program
without a command line argument, Applock will simply dismiss itself after the password is entered. 
Once again, Applock does nothing but look pretty if you just double-click its' icon. Therefore, Applock 
was not placed in a Program Manager group during installation. Follow these steps to make Applock 
work for you.

1 Make sure Applock is in your Windows directory.(Done with install program)
2 In Program Manager, open a group and select an Icon (item) to protect.
3 Select File|Properties or double-click the icon while holding down the Alt key.
4 Insert 'applock' plus a space at the beginning of the command line as shown in Figure 2.
5 Do not change the 'Working Directory'.
6 Click the OK button. The application is now protected.
7 The next time the application is started, Applock will greet the user requesting a password.
It is recommended that several items in the Main Group be protected (i.e. File Manager, MS-DOS 
Prompt, Control Panel, Windows Setup, PIF Editor and SysEdit(if you have it).    Also CONSIDER 
making your important .ini files 'read-only' to help protect your setup

Notice that the protected application's icon has changed.    The Applock LOCK icon is present.    You 
can leave the LOCK icon in place as a reminder that an application is protected or you can change to
the original application icon.

Changing Icons



Changing to the default Icon

Figure 3

Changing the protected programs' icon
When applock is assigned to protect a program or file it changes the icon for that file to the Applock 
LOCK. To change to the default program or file icon do as follows.

1 In Program Manager select File|Properties from the menu or double-click the appropriate icon 
while holding down the Alt key.

2 Take note of the command line. You need this information in step 4.
3 With the Program Item Properties dialog open, click the 'Change Icon' button.
4 Click the 'Browse' button and switch to the appropriate directory.
5 Select the programs' executable file (ex: winfile.exe) and highlight the icon you wish to use.
6 Click OK to close the 'Change Icon' then click OK again to close the Properties dialog. The new 

icon is now set.
Protecting Programs



PM Security - [restrictions]
Print this topic for a handy reference
The Program Manager initialization file, PROGMAN.INI, usually has entries for [settings] and 
[groups] sections, which describe what is to appear in the Program Manager window when you run 
Program Manager. Anyone wishing to protect their setup and restrict program use might choose to 
add a third section, [restrictions], for a custom installation. 

For added security add a [restrictions] section to PROGMAN.INI to restrict user actions. Be sure to 
make a backup of PROGMAN.INI before you proceed.    The [restrictions] section can have these 
entries:

[restrictions]
NoRun=
NoClose=
NoSaveSettings=
NoFileMenu= 
EditLevel=

NoRun=1    disables the Run command on the File menu. The Run command appears dimmed on 
the File menu and the user cannot run applications from Program Manager unless the applications 
are set up as icons in a group.

NoClose=1    disables the Exit Windows command on the File menu. Users cannot quit Program 
Manager through the File Menu or the Control menu (the Exit Windows and Close commands are 
dimmed), or by using ALT+F4.

NoSaveSettings=1      disables the Save Settings on Exit command on the Options menu. The Save 
Settings command appears dimmed on the Options menu and any changes that the user makes to 
the arrangement of windows and icons are not saved when Windows is restarted. This setting 
overrides the SaveSettings= entry in the [settings] section of the PROGMAN.INI file.

NoFileMenu=1    removes the File menu from Program Manager. All of the commands on that menu 
are unavailable. Users can start the applications in groups by selecting them and pressing ENTER, 
or by double-clicking the icon. Unless you have also disabled the Exit Windows command, users can
still quit Windows by using the Control menu or ALT+F4.

EditLevel=      Sets restrictions for what users can modify in Program Manager. You can specify one 
of the following values: 0,1,2,3,4.

0    allows the user to make any change. (This is the default.)

1    prevents the user from creating, deleting, or renaming groups. If you specify this value, the New, 
Move, Copy, and Delete commands on the File menu are not available when a group is selected.

2    sets all restrictions in EditLevel= 1, plus prevents the user from creating or deleting program 
items. If you specify this value, the New, Move, Copy, and Delete commands on the File menu are 
not available.

3    sets all restrictions in EditLevel= 2, plus prevents the user from changing command lines for 
program items. If you specify this value, the text in the Command Line box in the Properties dialog 
box cannot be changed. 
 
4    sets all restrictions in EditLevel= 3, plus prevents the user from changing any program item 
information. If you specify this value, none of the areas in the Properties dialog box can be modified. 



The user can view the dialog box, but all of the areas are dimmed.

 To enable any of the commands or remove any of the EditLevel= restrictions, either remove the 
entry from the PROGMAN.INI file, or set the value to 0. Any changes you make take effect 
immediately. The [group] section in PROGMAN.INI and the related .GRP file are updated to save the 
changes.

Examples:
1.    If you don't want users to run any programs from Windows other than ones that you set up in 
Program Manager groups, specify the following entries in PROGMAN.INI:
      [restrictions]
      NoRun=1
      EditLevel=4
This setting is an excellent method of limiting program access. Make these changes after setting up 
your restricted programs with Applock. Be sure to include File Manager as a restricted item. 

2.    If you don't want a user to exit Program Manager, specify the following entries in PROGMAN.INI:
        [restrictions]
        NoClose=1

3.    User cannot change or group, item, command line, or other property
        [Restrictions]
        EditLevel=4

Some applications, like File Manager, allow users to start other applications. If you do not want users
to start other applications, Protect them with Applock or make sure you do not include them in 
Program Manager groups.



PM Setup Reference
The Program Manager initialization file, PROGMAN.INI, usually has entries for [settings] and 
[groups] sections, which describe what is to appear in the Program Manager window when you run 
Program Manager. To change the appearance and behavior of Program Manager, use the Program 
Manager menu commands.

The [settings] section usually has these entries:
[Settings]
Window= 60 28 565 388 
SaveSettings=1 
MinOnRun= 0
AutoArrange= 1
Startup=
Order= 4 2 3 5 1 6

Window= Four numbers that indicate the position of the window when Program Manager is opened, 
followed by a 1 if the window is maximized.

SaveSettings= 1 if the Save Settings On Exit command on the Options menu is checked in Program 
Manager. In this case, Program Manager saves the current configuration when you close Windows.

MinOnRun= 1 if the Minimize On Use command is checked on the Options menu in Program 
Manager. In this case, the Program Manager is shown as an icon when you run another application.

AutoArrange=1 if the AutoArrange command is checked on the Options menu in Program Manager. 
In this case, the icons in each group are automatically arranged when you run Program Manager.

Startup= Name of the group that serves as the “startup” group. If this entry is blank, the Startup 
group created in Windows Setup is the startup group.

Order=    A list of numbers separated with spaces, indicating the order in which the groups are drawn 
in the window.

[groups]

The PROGMAN.INI file also has a section named [groups], which has entries such as these:
[Groups]
Group1=C:\WINDOWS\ACCESSOR.GRP
Group2=C:\WINDOWS\GAMES.GRP
Group4=C:\WINDOWS\MAIN.GRP
Group5=C:\WINDOWS\STARTUP.GRP
Group6=C:\WINDOWS\APPLICAT.GRP

Groupx= A filename (with full path) for the .GRP file that contains the group created during Setup, or 
created when an application was installed, or that you created in Program Manager. To change these
settings, we recommend that you use the commands on the Program Manager menu.



ALSetup - Applock Configuration Utility
Applock can also be configured with KDeskTop

Figure 3

Using ALSetup
This version of ALSetup has three purposes - to change Applocks' password, to allow you to register 
Applock, and to open this help file.    To start ALSetup use File|Run from the menu or double-click the 
Applock icon.    Enter your password when the security dialog appears.    The dialog in Figure 3 
appears.    Click the 'Change Password' button and enter your new password.    The new password 
will be echoed back to you to allow you to check your spelling and confirm your choice.    Exit 
ALSetup and record your password in a safe place. Click the 'Register' button to enter your 
registration codes.

· The about box lists the name of the registered user.

Registration
Getting Started
Protecting Programs



Registration
Use one of the following methods to register
All of our products are available via the following methods.
To Use CompuServe Shareware Registration Database:
GO SWREG on CompuServe.    Select 'Register Shareware".    Use ID # 4267 and follow the on-
screen instructions.

To Register by Credit Card:
"CREDIT CARD ORDERS ONLY - Request Applock by name.    USE ITEM # 11759

"You can order with MC, Visa, Amex, or Discover from Public (software) Library by calling 800-2424-
PsL or 713-524-6394 or by FAX to 713-524-6398 or by CIS Email to 71355,470. You can also mail 
credit card orders to PsL at P.O. Box 35705, Houston, TX 77235-5705. If you order by mail or fax, 
don' t forget to include your credit card expiration date.

"THE ABOVE NUMBERS ARE FOR CREDIT CARD ORDERS ONLY.    "THE AUTHOR OF THIS 
PROGRAM CANNOT BE REACHED AT THESE NUMBERS.

IMPORTANT:
"Any questions about the status of the shipment of the order, refunds, registration options, product 
details, technical support, volume discounts, dealer pricing, site licenses, non-credit card orders, etc.,
must be directed to: ANAPLASTIC SOFTWARE 1870 HIGH RD. ROSCOMMON, MI    48653 or VIA 
COMPUSERVE E-MAIL    @ 72123, 2012 or AMERICA ONLINE @ TERATOMA. 

"To insure that you get the latest version, PsL will notify us the day of your order and we will ship the 
product directly to you."

To Register by Mail:
Print and send in the completed order form available in the Applock directory or the zip archive as 
order.frm or use the form within this help file.

Entering your registration codes:
1 Obtain registration numbers as above.
2 Enter your Name.
3 Enter your Company.
4 Enter your Registration code exactly as provided to you.
5 Enter your Control Number exactly as provided to you.
6 Click '?' for brief help or 'More Info' for extended help.
7 Click OK to complete registration or Cancel to dismiss the dialog.
8 The next time Applock or AlSetup is run all references to unregistered shareware will be gone.    

The 'Register' button will be disabled.



Applock Tips & Tidbits
Taskman protection:
 Applock Tip# 1:    For extra security, after making of backup copy of system.ini, insert applock in the 
Taskman.exe line in the (boot) section of system.ini as follows:    TaskMan.exe=applock c:\windows\
taskman.exe.    This is another way to reduce access to running applications. The taskman is 
accessed by double-clicking the Windows desktop or from any system (control) menu. 

Protect files in File Manager:
Applock Tip #2:    Applock can be used to prevent unauthorized users from accessing certain file 
types.    For instance, you can lock out all files with the extension *.txt or *.ini or *.doc or *.wav in File 
Manager.    To do this you must edit a Windows configuration file - reg.dat - the registry file in the 
Windows directory.    Let's say that you want to protect all .TXT and .INI files in File Manager.    To do 
this you have to edit reg.dat as follows: FIRST MAKE A BACKUP COPY OF REG.DAT ( If you don't 
know how to do this forget the whole thing.)    Type regedit.exe /v in a File|Run dialog box and click 
OK. With Regedit up and running click Search|Find Key... and type in 'txtfile'. You should then see a 
line like this txtfile = Text File.    3 lines below you see the line 'command = notepad.exe %1'.    Click 
on this line to select the value into the Value box at the top of Regedit. Insert 'applock ' and change 
the line as follows: 'command = applock notepad.exe %1'.    Now click File|Save Changes and exit    
Regedit.      Now start File Manager and select any file with .ini or .txt as an extension.    You will 
encounter Applock.    You can do the same with    any file type you see in Regedit that is in the format 
'command = path\anyapp.exe'. 

A word about Windows security
Windows 3.x is not security oriented as is Windows NT.    Therefore security is a relative thing when 
using an operating environment like Win 3.x that lives in a DOS world.    Most all files Windows uses 
can be altered in DOS. The best way to make Windows as secure as possible is to try to make DOS 
unavailable to the users of your machine.    To start add WIN to the end of your autoexec.bat. This will
boot you straight into Windows.    Include the lines BREAK=OFF and SWITCHES= /N in your 
config.sys file to disable MS-DOS F5 and F8 options. (F5 bypasses the config files, F8 allows you to 
step through each command in autoexec.bat and config.sys. BREAK=OFF disables Ctrl+C which 
stops an on-going action such as processing a batch file, etc. 

If you have a password protected CMOS/BIOS as in most laptops and portables, enable this option.   
See your computer manual for more information.

Also CONSIDER making your important INI files read-only.(These are some of the most important ini
files: progman.ini, system.ini, win.ini, control.ini, winfile.ini )    To make a file read-only, select the 
desired file in File Manager then from the menu click File|Properties. Check the Read Only box and 
click OK to complete the task. If you find that a program installation needs to modify your system 
files, you can make a file read-write by un-checking the Read Only box in the same manner as 
above. 

Encrypt important files to keep prying eyes out of your business.    Of course, backup all needed files 
regularly.

Products like Keepout and KDeskTop that password protect your Windows environment and disable 
Ctrl+Alt+Del as well as products like OverSeer PMS that protect your Program Manager setup all 
help to make your Windows computing environment safer and more secure. 



Support
Send us a note by CompuServe or America Online E-mail or write us a note if you have any 
problems with this product.    Limited support is available to non-registered users. Registered user will
receive first priority unlimited support.

Uninstalling
To un-install Applock, delete the directory that holds Applocks' files (ex: c:\applock) and delete 
Applock.exe, Applock.ini and sorry.wav from your windows directory. Remove the references to 
Applock in the Program Manager properties dialog for each application that is protected by Applock.   
Delete the group or icons in Program Manager that reflect Applock files.    Ctl3d.dll, the Microsoft 3D 
control, in the \windows\system directory should probably be left in place as other applications will 
use it.



Security Products From Anaplastic Software

Available on CompuServe and America Online
Order Form

Keepout - Password Protection Utility for Windows
Keepout is a simple password program.    Keepout prevents unauthorized access to the single non-
networked Windows computing environment.    It has a configurable password, program sound and 
window title. (Made possible with KSetup, the accompanying setup program.)    Keepout v 3.0 now 
disables Ctrl+Alt+Del for increased security. Fully functional shareware.

KDeskTop - Total DeskTop Security for Windows
KDeskTop Utility - a multipurpose desktop utility and security program. KDeskTop combines the 
features of Keepout and OverSeer plus adds many quickly accessible features.    KDeskTop can be 
used in conjunction with Keepout (included) or as a stand alone program. If configured appropriately, 
KDeskTop is launched by Keepout at Windows startup.    KDeskTop can be used as a toolbar or a 
desktop icon. From KDeskTop, you can start the Windows SCREENSAVER, show the TIME and 
DATE, display SYSTEM RESOURCES, LOCKOUT Windows with Keepout or a password protected 
screensaver, DISABLE CTRL+ALT+DEL, EXIT OR QUICK REBOOT WINDOWS, and have a 
DESKTOP TRASHCAN at your disposal (pun intended!).    Keepout and Applock can be configured 
from within KDeskTop and a quick Windows Exit or Restart is available. KDeskTop INCLUDES 
Applock v1.1 and Keepout v3.0.    Fully functional shareware available in January, 1995.

OverSeer PMS - Program Manager Sentry
Protect your Program Manager setup with OverSeer PMS, an easy to use and practical PM sentry. 
OverSeer allows the primary PM user to guard his setup via a list of user-selected options, which 
modify progman.ini settings. OverSeer PMS keeps your Program Manager groups and items safe 
and can even prevent users from exiting Windows.    It is useful at home or at work or anywhere that 
more than one user has access to the same Windows environment.    OverSeer PMS is fully 
functional shareware.

Applock - Application Password Protection
Applock allows you to lock out or restrict the use of Windows applications and therefore keeps out 
unauthorized users.    Perfect when used in combination with OverSeer PMS or KDeskTop to improve
your Windows security.



Applock v 1.1 Order Form
Registration
          Why not order a copy for a friend.    To obtain a copy of Applock send $10.00 for registration 
numbers or $12.50($10.00 + $2.50 S&H)    for a disk to the address below.      Please register if you 
find this useful and use it beyond 21 days.    Registration provides: Unlimited support, free minor 
version upgrades, discounts on full version upgrades.    Disk includes sample wavefiles and 
shareware versions of our other products.

Contents

· Anaplastic Software
· 1870 High Rd
· Roscommon, MI      48653

Print out and complete this form or provide the requested information on a card.    You can also make
your request by contacting me through CompuServe mail. (72123,2012) or America Online 
(Teratoma).    

1 Name:________________________________________________
2 Company: ____________________________________________
3 Address : _____________________________________________
4 Suite or Apt No.: _______________________________________
5 City, State: ____________________________________________
6 Country: _______________________________________________
7 Zip Code: ______________________________________________
8 Disk size:        3.5"___    5.25"___
9 CompuServe or America Online ID: __________________________
10 Comments: _____________________________________________
· _______________________________________________________
· Where did you get this copy of Applock?______________________
· Would you like information about Keepout, KDeskTop or OverSeer?    Yes___ No____
· Applock v1.1 $10.00    X no. copies___ for REGISTRATION NUMBERS ONLY = $______
· Applock v1.1 $10.00    X no. copies___ for REGISTRATION NUMBERS ONLY = $______
· Also Available:
· KDeskTop    $27.50    X no. copies___ for REGISTRATION NUMBERS ONLY        = $______
· OR KDeskTop    $30.00 ($27.50 + $2.50 S&H)    X    no. disks____                             = $______
· OR Upgrade from Keepout, OverSeer, or Applock
· KDeskTop    $15.00 X no. copies____                  Disks will be sent                                                    = 

$______
·  Keepout 3.0    $15.00    X no. copies__ for REGISTRATION NUMBERS ONLY = $______
· OR Keepout 3.0    $17.50 ($15.00 + $2.50 S&H)    X    no. disks____                                        = 

$______
·                                                                                                       TOTAL ENCLOSED (US FUNDS ONLY)    = 

$_______
You will receive the latest versions of Applock. Registration Numbers will be sent by the fastest 



means possible.    Please allow 3-4 weeks for shipping of disks.

Thank you and Good-bye



APPLOCK    v 1.1    © 1994-1995    Anaplastic Software.        "A small and unobtrusive password utility 
is hard to find." , they said.    Applock is one solution to that problem.    We can be contacted through 
E-mail on CompuServe @ 72123,2012 or America Online care of "Teratoma".

Please register Applock if you continue to use it beyond 21 days. On CompuServe Go SWREG.    
Registration    # 4267



ALSetup
<ALSetup>



America Online
Our ID = TERATOMA



Anaplastic
Developing without form or structure



Applock
Applock v 1.1        Part of the KDeskTop Security System for Windows.    Copyright 1994-1995    
Anaplastic Software.    All Rights Reserved.



command line argument
A command line argument allows a program to start with a file loaded or run with a specified setup.    For 
example, if you go to the File|Run menu item in File Manager and type 'control desktop' the Control 
Panel will load with the Desktop settings dialog open.



CompuServe
Our ID # 72123,2012



groups
<PM Reference>



important .ini files
progman.ini, system.ini, win.ini, control.ini, winfile.ini      To make a file Read Only, select the desired file 
in File Manager then from the menu click File|Properties. Check the Read Only box and click OK    to 
complete the task.



KDeskTop
<Other Products>



Keepout
<Other Products>



MS-DOS
MS-DOS ® Microsoft Corporation



other products
<Other Products>



OverSeer PMS
<Other Products>



OverSeer
<Other Products>



PATH
See MS-DOS help regarding the PATH statement in autoexec.bat.



Program Manager Security
<PM Security>



protecting programs
<Protecting Programs>



support is available
Registered users and those trying our products can receive support as follows: On CompuServe, contact
us @ 72123,2012. On America Online, use TERATOMA. By mail, write to the address on the order form.
Registered users will receive first priority unlimited support.



WinCim
CompuServe Information Manager for Windows © CompuServe Incorporated



Windows
Microsoft Windows    ® Microsoft Corporation



write us a note
Send it to : Anaplastic Software    1870 High Rd. Roscommon, MI 48653






