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What are File Libraries?

Many business-run Worldgroup systems, and most government-run ones, provide document 
and program files which you can download to your PC.    Some systems may charge for the 
privilege of downloading files.    Others are happy to let you copy tons of useful files free of 
charge.    

A single Worldgroup may offer several gigabytes (1024 megs) of files, hopefully categorized 
by subject into separate libraries.    

If you are looking for something in particular, Find Files lets you search across some or all 
libraries for a file name, a date, a keyword, or for how often certain files have been 
requested by others.    

If you're just wandering, Browse lets you scan the file listing of a library, usually with brief 
descriptions by each file.    

Once you've located files of interest, you can download them from the Worldgroup server to 
your PC.    

Some systems encourage you to upload files from your PC to the Worldgroup server.    

You'll need to be online when you actually download or upload files.    You'll also need to be 
online when you request lists of available files.    

It is possible, though, for you to save file listings in special (.gfl) files on your PC and 
examine them offline later.    You can read the file descriptions in those saved lists, and tag 
files which you wish to download later.    When you've finished tagging the saved lists, you 
can go online, download all the files you've tagged, and go offline again.    

See also Contents.    



Toolbar for File Libraries

Find Files in one or more libraries, 
searching by date, keyword, file 
name or popularity.    Same as the 
File menu's Find.    
Browse one Library for recently 
added items of interest.    Same as
the File menu's Browse.    
Upload to a Library lets you copy 
files from your PC to the 
Worldgroup server.    Some 
systems do not accept uploads.    
Same as the File menu's Upload.    
Open lets you examine a library's 
contents while offline.    Same as 
the File menu's Saved Lists.    

File Menu

Find
Select any or all libraries and search for specific files by date, keywords, file name or 
in order of popularity.    

Browse
Select one library and scan through its file listing for recent acquisitions which catch 
your interest.    

Upload
Some Worldgroup systems permit you to upload files from your PC to a library.    

Download All
Once you've found or browsed a list of files, this lets you download every file on the 
list.    

Saved Lists
Examine file listings you found or browsed earlier and saved to your PC.    From a 
saved list, you can tag files to be downloaded without being online (instead, you're 
on deck).    

Exit
Close the File Libraries module.    



Find Files

This is where you can search through some or all of a Worldgroup server's libraries to find 
specific files.    Select the libraries you wish to check, define a search by Date, Keywords, File 
Name or in order of Popularity, then click List Files to begin the search.    The result will be a 
File Listing.    

To reach this window, from the File menu select Find.    

Include Libraries
Each library available on this Worldgroup server is listed here.    

The leftmost field on each line is a check box.    If the box is checked, this library will 
be included in the search you are about to make.    If the box is not checked, this 
library will be left out of the search.    To check or uncheck a box, single-click directly 
on it.    

The middle field on each line is the name of the library.    
The rightmost field on each line is a brief (and optional) description of the library.    
Double-clicking on either the library's name or description has the same effect as 
highlighting the line and clicking Details: you get a list of various statistics for the 
library as a whole.    

Search by Date
Finds files in all selected libraries which match the choice you select under Criteria.    
Criteria
All Dates all files, sorted by date, 

beginning with the most 
recently added, practically 
identical to Browse except that 
you can search more than one 
library this way

Past Week files added within the week, 
beginning with the most 
recently added

Past Month files added within the month, 
beginning with the most 
recently added

New Files all files added since the last 
time you used New Files to find
files

Search by Keywords
Finds files whose descriptions or names contain the keyword(s) you specify under 
Criteria.    
Criteria
A keyword can be an entire word or the beginning of a word.    Searching for a single 
keyword is the most rapid way to find files, and the most likely to find something.    



You can use the following symbols and words to combine more than one keyword, but
be aware that combination searches can take a very long time to tell you that nothing
matched the combination of keywords:

and & Searches for files whose 
names and descriptions 
contain both keywordA and 
keywordB.    Same as using a
Space: keywordA    keywordB
This will also find 
occurrences of keywordB    
keywordA.    You can reduce 
search time by putting the 
less common word in first 
place.    

or ¦
(pipe)

Searches for files whose 
names and descriptions 
contain either keywordA or 
keywordB, plus those which 
contain both.

xor ^ Searches for files whose 
names and descriptions 
contain either keywordA or 
keywordB, but do not 
contain both.    

not ! Searches for files whose 
names and descriptions do 
not contain keywordA

( ) ( ) Forces the search to resolve 
the keyword or combination 
within the (parentheses) 
before resolving the rest of 
the keyword string.    
Parentheses can be used to 
search for a part of a word 
other than its beginning.    
For example, (le) will find 
example while le by itself 
would not.    

Single-keyword searches are the least time-consuming.    And searches are only 
slightly slower.    Or, xor, not and ( ) searches can be very time-consuming.    Another
side-effect of symbol logic is that you cannot search for occurrences of the words 
and, or, xor, and not.    

Search by File Name
Finds files matching the file name or filter you enter under Criteria.    

Criteria
Enter the name of the file you wish to find, or enter a wildcard filter.    Examples:

*.* any name and any extension



fs-wait4.* name fs-wait4 and any 
extension

*.zip extension .zip
*.? any single-character extension
*.h* any extension beginning with h

Search by Popularity
Orders files by the number of times other users have downloaded them, from the 
most often requested to the least.    

The first information the Worldgroup server sends you will be a list of the top 20-50 
most often downloaded files.    By using the up/down scroll bar, you can request the 
rest of the list.    



The X Library

This lists various statistics for a particular library.    

To reach this window, from the File menu select Find.    Then double-click on a library's name 
or description as listed under Include Libraries.    

You'll find general information on a library here: current number of files in the library, how 
many of those were added recently, the byte-size of the library, the Lib-Op, etc.    



Library Operator (Lib-Op)
A Library Operator, or Lib-Op, is the manager of a Worldgroup library.    

In smaller systems, the Sysop is usually the Library Operator as well.    In larger systems, 
each library may be the responsibility of a different Lib-Op.    



File Listing

This is the result of a search: a list of files which match your search criteria, any or all of 
which you can download from the Worldgroup server to your PC.    

To fill this window with all files residing in one library, from the File menu select Browse and 
double-click on the library of your choice.    

To fill this window with files matching a particular file name, keyword(s), date, or in order of 
popularity, from the File menu select Find, enter your search criteria, and click List Files.    

The Details button displays information including a full description (if available) for the 
currently highlighted file.    You can also summon the File Information window by double-
clicking on the file name.    

To download one file, highlight it and click Download.    You'll be asked where on your PC you 
want to save this file.    You can immediately download the file, or tag it for download later.    

To download every file in the File Listing, from File Libraries'    File menu select Download All.   
You'll be asked where on your PC you want to save these files.    You can immediately 
download them all, or tag them for download later.    

The Save button lets you record the currently displayed list on your PC so that you can 
examine it in depth after logging off but while still on deck.    Be sure to save the list with 
extension .gfl.    Saving it as text (.txt) is possible, and useful for importing into other 
programs, but a text list cannot be used to tag downloads.    

Information Fields for Each File
Not all of these field columns may be visible on the File Listing window as it's 
currently configured.    

To select which fields you wish to see, from the Options menu select List.    
File Name
The filename.ext of each file found
Library
The library in which each file was found (usually not displayed in Browse results)
Popularity    (# D/L)
The number of downloads so far requested for this file
Date Added
The date when this file was added to this library
Size
The number of bytes contained within the file, useful as a rough gauge of download 
time
File Date
The date the file was created (identical to the dates which appear alongside files on 
your PC when you pull up a directory listing)
Cost
The number of credits which will be deducted from your account when you download 
this file.    This is important to you only if this Worldgroup is one which charges for 



access.    
Some Sysops use credit accounting as a way to trace user activity without actually 
charging you money for your actions.    Thus, it's quite possible you may see numbers
in this column if you display Cost on a free-access Worldgroup.    
Description
The first few dozen characters of a description which may (or may not) exist for each 
file found.    You can read the complete description by clicking the Details button 
beneath the list of files.    



File Information

Displays detailed information on a particular file.    

To reach this window, from the File Listing window click Details.    

Use the Close button to return to the File Listing window if, after examining the full 
information, you realize that this file does not interest you.    

The Download button lets you select where on your PC you want to save this file.    It then 
offers you the option of immediately downloading the file, or tagging it for download later.    

The View button displays the contents of the file in a window without downloading it to you 
as an intact file.    This is especially useful when you are browsing a library containing text 
status reports or the like.    



View Compressed (Zip) File Contents

This is where you can list the contents of a compressed (zipped) file without downloading it.  

To reach this window, first find a compressed file (.zip) through either the File menu's Find or
Browse commands.    This will result in a File Listing.    Once you have a list of found files, 
highlight the file which you wish to examine and click Details.    This brings up the File 
Information window for that file.    Click the View button.    

The Close button returns you to the File Information window.    



View Text File Contents

This is where you can display and read the contents of a text file without downloading it.    

To reach this window, first find a text file through either the File menu's Find or Browse 
commands.    This will result in a File Listing.    Once you have a list of found files, highlight 
the file which you wish to examine and click Details.    This brings up the File Information 
window for that file.    Click the View button.    

Use the scroll bar to scan up and down the text file.    

The Download button lets you copy the file to your PC for later reading, or for importing into 
your word processor or other software.    

The Close button returns you to the File Information window.    



Browse a Library

This is where you select which library you wish to browse.    Browsing means to glance down 
the entire list of files in one library for files whose names or descriptions catch your interest. 

To reach this window, from the File menu select Browse.    

The list box displays all currently available libraries.    The Details button displays general 
information on the highlighted library.    

Browse a library by double-clicking on it, or single-clicking on it and clicking the OK button.    
You will receive a File Listing of every file in the library.    Files will be sorted by date added to 
the library, with the most recently added at the top of the list.    This is because most 
browsers are looking for recent additions.    

If you prefer an alphabetical sort, or keyword search, or popularity ordering, use Find Files.    



Upload to a Library

Some Worldgroup systems permit you to upload files from your PC to a library.    

To reach this window, from the File menu select Upload.    

The list box displays all currently available libraries.    Choose the library you wish to upload 
to by double-clicking on it, or single-clicking on it and clicking the OK button.    The system 
will next ask which file you wish to upload.    

The Details button displays general information on the highlighted library.    This is helpful in 
deciding which library is most appropriate for the file you wish to submit.    



Uploading a File: Enter Description

Once you've selected a file on your PC for uploading, you need to describe its contents 
and/or purpose.    This description will be stored in the library alongside the file.    

To reach this window, from the File menu select Upload, select a destination library, then 
select the file you wish to send.    

It's important that each file in a library be accompanied by a description.    Get a directory 
listing of your own \windows\system subdirectory if you want to see why filename.ext is 
usually not enough of an explanation.    

The least complicated way for you to type in a description is as one long paragraph with no 
carriage returns and no blank lines like the one between the words you're reading now

and the ones you're reading now.    

You can use the Enter key to type multiple lines.    However, to maintain backwards 
compatibility with the File Libraries' storage system of The Major BBS, the description must 
be:

no more than 49 characters per line
no more than 15 lines

If you type in a line which has more than 49 characters, the word which contains the 50th 
character will become the first word on the next line.    This is why typing in a single 
paragraph without using the Enter key is generally the best approach.    

Here's the complication when using Enter: if you type in 15 lines, the first of which has 50 
characters, the last word on your 1st line will be saved as line #2.    Your 2nd line will be 
saved as line #3, . . . , and your 14th line will be saved as line #15.    Your 15th line will be 
discarded.    

In a nutshell, either type in one long paragraph or don't make any lines more than 49 
characters.    

To begin transmitting both the file and the description, click OK.    

To abort the upload, click Cancel.    



Open File Listing

Once you've opened a saved list file, this allows you to examine the list offline (on deck).    

To reach this window, from the File menu select Saved Lists and open a Galacticomm File List
(????????.gfl) file.    

With old-style terminal software, you have no choice but to be online while examining a 
library and deciding what to download.    With WGM's client/server approach, you can save 
the results of a search (Find Files or Browse) to a file on your PC.    

This window lets you open a saved list and examine its contents later, most likely after 
you've logged off.    While you are on deck but still offline, from a saved list you can select 
which files you wish downloaded to which location(s) on your PC.    

The Download button lets you select where on your PC you want to save this file.    It does 
not try to connect with the Worldgroup server.    The window which comes up offers you the 
option of immediately downloading the file, or tagging it for download later.    To remain 
offline and simply build up a list, select Download Later.    

You can also summon the Download window by double-clicking on the file name.    

The Details button displays information including a full description (if available) for the 
currently highlighted file.    It does try to connect with the Worldgroup server, so avoid it if 
you're trying to remain offline.    

When you are ready to go online, unminimize the Download Manager icon, pull down its File 
menu, and select Resume All.    Worldgroup Manager will immediately connect to the 
Worldgroup server, log you on, and begin downloading files.    

Saved lists are especially handy with systems which limit you to a certain number of minutes
online per session, or per day.    You spend your decision-making time offline, studying a 
saved list.    You go online only to download the files you've already chosen.    

If you run out of time with files yet to be downloaded, those requests will remain in the 
Download Manager, labeled Waiting to Download.    You can finish downloading them the 
next time you log on.    

Information Fields for Each File
Not all of these field columns may be visible on the File Listing window as it's 
currently configured.    

To select which fields you wish to see, from the Options menu select List.    
File Name
The filename.ext of each file found
Library
The library in which each file was found (usually not displayed in Browse results)
Popularity    (# D/L)
The number of downloads so far requested for this file
Date Added
The date when this file was added to this library



Size
The number of bytes contained within the file, useful as a rough gauge of download 
time
File Date
The date the file was created (identical to the dates which appear alongside files on 
your PC when you pull up a directory listing)
Cost
The number of credits which will be deducted from your account when you download 
this file.    This is important to you only if this Worldgroup is one which charges for 
access.    
Some Sysops use credit accounting as a way to trace user activity without actually 
charging you money for your actions.    Thus, it's quite possible you may see numbers
in this column if you display Cost on a free-access Worldgroup.    
Description
The first few dozen characters of a description which may (or may not) exist for each 
file found.    You can read the complete description by clicking the Details button 
beneath the list of files.    



View Menu

Toolbar
Activates or deactivates the button toolbar.    



Options Menu

List
Lets you set which information fields (file name, description, etc.) will be displayed for
File Listing.    



List Options

This is where you set which information fields will be displayed in File Listings when you run 
various types of searches.    

To reach this window, from the Options menu select List.    

Search by
This dropdown list box lets you choose which type of search you are about to adjust.   
They are the same four choices offered in the File Listing window.    

Select to List
By checking any box below, you are telling the File Listing window to display its field 
of information for each file found.    By unchecking any box below, you are telling the 
File Listing window not to display its field.    
File Name
The filename.ext of each file found
Popularity
The number of downloads (# D/L) so far requested for this file
Date Added
The date when this file was added to this library
Size
The number of bytes contained within the file, useful as a rough gauge of download 
time
File Date
The date the file was created (identical to the dates which appear alongside files on 
your PC when you pull up a directory listing)
Cost
The number of credits which will be deducted from your account when you download 
this file.    This is important to you only if this Worldgroup is one which charges for 
access.    
Some Sysops use credit accounting as a way to trace user activity without actually 
charging you money for your actions.    Thus, it's quite possible you may see numbers
in this column if you display Cost on a free-access Worldgroup.    
Description
The first few dozen characters of a description which may (or may not) exist for each 
file found.    

 



Download a File

You've just requested that a file be downloaded from the Worldgroup server to your PC.    You
can either immediately download the file or simply tag it to be downloaded later.    This 
window sets the drive:\path\filename.ext where you wish the file to be placed on your PC, 
and sets whether you want the file to be automatically opened/run once it arrives.    

In either event, the request is sent to the Download Manager (part of the Worldgroup 
Manager program) which will keep track of the request until either the file is downloaded or 
until you delete the request.    

Download Now
Adds this file to the Download Manager's list.    If no other download is currently in 
progress, it will be assigned a status of Downloading (or Launching) and begin 
transferring the file to your PC.    

Download Later
Adds this file to the Download Manager's list but assigns it a status of Waiting for 
Download (or Launch).    The request will remain suspended until you open Download 
Manager and either delete the request or set it to download/launch.    

Launch File
If this box is not    checked, the file will simply be downloaded.    

If this box is    checked, once the file arrives on your PC it will be immediately 
opened/run using whatever Windows application is associated with the extension on 
this filename.    

For example, if .TXT is associated with Wordpad on your PC, checking Launch File 
when downloading any filename.TXT will cause Wordpad to be run, automatically 
opening filename.TXT into it for viewing/editing.    

File Name
The text box presently suggesting the filename.ext by which the file is stored on the 
server.    You can manually enter the entire drive:\directory\...\filename.ext if you wish.

You are welcome to save the file on your PC under a different filename, but you 
should leave the extension the same.    For example, if the file is labeled 
<something>.zip on the server, it's most likely been compressed using PKzip.    Even if 
you save it to <something>.bat on your PC, the file itself will still be a zip and you'll 
have to explain the unexpected extension (.bat) to PKunzip in order to uncompress 
the file.    

The standard list box below the text box displays all files in the current drive:\
directory.    This helps you avoid name collisions.    

Of course, you may want to save the new file over top of an existing file.    In that 
case, you can save yourself a few keystrokes by double-clicking on the file you wish 
overwritten.    



Directories
The list box displays the directory tree of the drive:\ selected below in Drives.    The 
current directory is the one whose folder icon is open and darkened within.    Any 
folders listed below it are children subdirectories of the current directory.    Any folders
listed above it are parent directories.    Between the list box and the title line 
Directories: you will see displayed in text the current directory's drive:\path, 
possibly abbreviated.    

Double-click on a directory to switch to it.    If the directory you seek is not visible, 
double-click on the directory which you know to be its parent.    This list box does not 
display the entire tree at once, but limits itself instead to the parentage and children 
of the current directory.    

Drives
This dropdown list box selects the drive letter you wish displayed.    Depending on 
your PC's setup, it may display volume names in [brackets] to the right of each drive 
letter.    

A single click selects a drive letter.    The Directories and File Name list boxes will 
change to display the new drive's current directory and files.    

 



Find...
This function helps you find the correct spelling of a person's User-ID.    

Although people commonly use their full names as User-IDs, you need to remember that a 
User-ID is a single string.    That is, the User-ID "Carolyn G." will appear before the User-ID 
"Kelly B." because the letter C comes before the letter K.      

Type your best guess in the User: field    
As with almost everything in Worldgroup, UPPER/lower case doesn't matter:    "Tyler" 
equals "TYLER" equals "tyler".    

Click on the Search button    
If the function finds any matches, the window will enlarge to display a list of possible 
matches.    Select the one you wish either by double-clicking it, or by single-clicking it 
then clicking the OK button.    The selected User-ID will be returned to the window 
from which you called Find...    

If the function does not find a match, try a shorter string in the User: field.    Although 
you can type in a full name, it's generally better not to.    If you ask for "reginald" but 
he signed up as "Reggie", the search won't find him.    You're better off searching for 
"reg".    

Notice that you can search for a person by last name, or even partial last name.    It 
will not find "Ann Owen" if you type in "we", however.    The search string in User: 
must be the beginning of a word if not a whole word.    



Glossary

The following definitions are available:

Bitmap File
C/S (Client/Server) Mode
Client Side
Dumb Terminal
File Transfer Protocol
Metafile
Online, Offline, On Deck
Password
Worldgroup server
Server Side
Sysop
Terminal Mode
User Account
User-ID



Bitmap File
A bitmap is a way to store a graphical image as a rectangular grid of dots (pixels).    

For example, this is a bitmap graphic:    

Here it is again 4 times as 
large.    Bitmaps don't enlarge 
very well because the 
information that is stored 
within them is only accurate 
down to the size of a single 
pixel (dot).    Enlarge a bitmap 
and you get big dots.      

On the other hand, bitmaps work very well when they store information which is not meant 
to be enlarged, reshaped or otherwise manipulated.    Windows icons are bitmaps (stored as
.ico files or embedded in .exe files).    Windows wallpaper designs are bitmaps (.bmp).    

The Windows program Paintbrush can manipulate .bmp files.    

See also Metafile.    



C/S (Client/Server) Mode

Two-sided computing: your PC and the Worldgroup server PC both work to satisfy your 
requests.    Your PC's processing power is not ignored (as with a terminal mode BBS).    In fact,
your PC ends up doing most of the work.    C/S mode minimizes wasted time online by letting
you do many tasks on deck.    

Client/server means that one program (the client) can ask another program (the server) for 
assistance.    The two programs often run on separate computers connected by a 
communications link (a network, the telephone system, etc.).    

WGM is a client program running on your PC.    

The Worldgroup server is a server program running on a remote PC.    



Client side
Your PC running WGM is the client side of a client/server relationship.    The remote PC 
running Worldgroup server software is the server side of the relationship.    The term client 
side includes:

1) any programs which run on your PC
2) any data, documents, or other files which are stored on your PC

The client side can do many tasks itself, and calls on the server side for tasks it cannot do 
(exchanging messages with other clients, looking up centralized information, etc.).    



Dumb Terminal
A device which has a keyboard, a monitor, possibly a mouse, but has no ability to process 
data by itself.    A dumb terminal has to be connected to a computer in order to do anything.  

Old-style user-side modem programs are known as terminal programs because they make 
your PC mimic a dumb terminal (thereby wasting your PC's processing power).    



File Transfer Protocol
A language for exchanging files between two computers and confirming that what arrives is 
the same as what was sent.    Common protocols for terminal-mode transfers include 
ZMODEM, XMODEM, YMODEM-Batch, and Kermit.    

WGM in C/S mode uses its own information transfer protocol, GCSP, which uses Dynapaks to 
exchange all forms of data including files.    



Metafile
A metafile is a way to store a graphical image as a collection of shapes, angles, and relative 
distances.    

For example, this drawing is a metafile:    

Here it is again 8 times 
as large.    Note that its 
curved edges are far 
smoother than would 
be a bitmap of the 
same size.    Stretched 
large or small, a 
metafile is recalculated
to provide the most 
accurate image 
possible.    

Because PC monitors in use today may be set to any of a dozen different resolutions (so 
many pixels tall, so many pixels wide), we have used metafiles within WGM's help files 
wherever possible.    This makes it more likely that graphics will appear properly on your 
display.    

The Windows program Paintbrush cannot manipulate .wmf files.    

See also Bitmap File.    



Online
Connected.    
Your PC is online whenever it is connected to a Worldgroup server.    

Offline
Disconnected.    
Your PC is offline whenever it is not connected to a Worldgroup server.    

On Deck
Disconnected but able to perform tasks.    
Your PC is on deck whenever WGM is running the client-side program for a 
Worldgroup service but your PC is not yet connected to the online service.    



Password
The private half of your identification, seen only by the Worldgroup server software and the 
Sysop.    

A password is the confirmation that you are who your User-ID says you are.    Without 
passwords, someone else could log on using your User-ID and do things that you would be 
blamed for.    Keep your password secret.    

Avoid obvious, easily guessed, passwords.    Make up something that is not your mother's 
maiden name, not your job title, in fact not anything related to your work.    

Don't use a completely random string of characters, though.    "NE1410S" will be hard to 
remember.    Instead, an effective middle choice is to run two words together which are 
easily remembered by you but not easily guessed by others.    "Twosun" for example.    



Worldgroup Server
Any online service running Worldgroup server software by Galacticomm, Inc.    

Online services running other software are not servers in the client/server sense.    WGM 
drops back to terminal mode in order to communicate with them.    



Server side
The remote PC running Worldgroup is the server side of a client/server relationship.    Your PC
is the client side of the relationship.    The term server side includes:

1) any programs which run on the Worldgroup server PC
2) any data, documents, or other files which are stored on the Worldgroup server PC

The server side exists solely to do tasks which the client side cannot do itself (exchanging 
messages with other clients, looking up centralized information, etc.).    



Sysop
A System Operator, or Sysop, is the manager of a Worldgroup system.    



Terminal Mode
One-sided computing: the software running on the remote computer insists on doing all of 
the work, so the user's PC might as well be a dumb terminal.    This mindset made sense 
when computing power was prohibitively expensive.    Today, though, your PC may well be 
more powerful than the PC running the online service you call.    Even if it isn't, your PC is 
closer to you than the service's PC.    It can do things without delay, if the software at both 
ends permits.    Client/server mode permits this.    Terminal mode does not.    

WGM falls back from C/S mode to terminal mode in order to communicate with non-
Worldgroup online services.    



User Account
A list of information including your full name, your mailing address, your telephone number, 
etc.    In a for-profit online service, the user account may include your credit card number or 
other method of payment.    

User account information is private, seen only by you and by the Sysop.    

Your user account is identified by your User-ID and password.    



User-ID
The public half of your identification, seen by the software and by other users.    

A User-ID is a string of 3 to 29 characters.    On business systems, it is often your full name.    
On social systems, it is often a nickname or "handle."    In some situations, a User-ID may be 
assigned to you, but in most cases you have creative control.    

Your User-ID is verified by the password you associate with it.    



I never metafile I didn't like
            (Stryker said I could do it! --Marc)
 



Open
This function helps you locate a file on your PC and load it into the program you are currently
running.    

Of course, the file has to be of a type which is meaningful to the program.    For example, you
can try to load a text file into File Libraries when it asks for a saved list.    However, it won't 
know what to do with the text file because it isn't in the expected format (.gfl).    

File Name
The text box lets you manually enter the drive:\directory\...\filename.ext of the file 
which you wish to open.    

The standard list box below the text box displays all files in the current drive:\
directory which are of the type selected by List Files of Type.    

The fastest way to select a file, once it's visible in the list box, is to double-click it.    

List Files of Type
The dropdown list box lets you limit the files displayed under File Name to those of a 
particular type.    This is helpful when a program can make use of only one type of 
file.    If List Files of Type doesn't offer the filter you require, you can manually enter 
your own under File Name.    

For example:

° Text files are often *.txt.
° Word processor documents are often 

*.doc.
° DOS Batch files are *.bat.    
° Programs are either *.com (command) or 

*.exe (executable).    
° Common Windows graphics formats are 

*.bmp (bitmap) and *.wmf (metafile), 
although there are more than a dozen 
other popular graphics formats.    

° The File Libraries module can save a file 
listing to your PC as *.gfl.    This can be 
opened by File Libraries while you are 
offline, letting you examine a library's 
"card catalog" without being online.    

Other forms of data will come with extensions appropriate to them.    The normal 
default is to *.* for all files.    

Directories
The list box displays the directory tree of the drive:\ selected below in Drives.    The 
current directory is the one whose folder icon is open and darkened within.    Any 
folders listed below it are children subdirectories of the current directory.    Any folders



listed above it are parent directories.    Between the list box and the title line 
Directories: you will see displayed in text the current directory's drive:\path, 
possibly abbreviated.    

Double-click on a directory to switch to it.    If the directory you seek is not visible, 
double-click on the directory which you know to be its parent.    This list box does not 
display the entire tree at once, but limits itself instead to the parentage and children 
of the current directory.    

Drives
This dropdown list box selects the drive letter you wish displayed.    Depending on 
your PC's setup, it may display volume names in [brackets] to the right of each drive 
letter.    

A single click selects a drive letter.    The Directories and File Name list boxes will 
change to display the new drive's current directory and files.    
 



Save / Save As
This function lets you record information to a disk file on your PC.    

File Name
The text box lets you manually enter the drive:\directory\...\filename.ext into which 
you wish to save the information.    Set the appropriate file type in Save File as Type.    

The standard list box below the text box displays all files in the current drive:\
directory which are of the type selected by Save File as Type.    

If you wish to save over top of an existing file which is visible in the list box, you can 
double-click on it, or highlight it then click on OK.    

Save File as Type
The dropdown list box lets you choose the way you wish the information to be 
recorded in the file.    

For example:

° Text is usually saved as .txt (ASCII text).    
° DOS Batch files are usually saved as .bat. 

Text and Batch files can be safely viewed.   
The following file types are machine 
readable only and so should not be viewed
as text:

° Programs are usually saved as .com 
(command) or .exe (executable).    

° Graphics are often stored as .bmp 
(bitmap) or .wmf (metafile).    

° Files are often compressed and packaged 
into a single file for quicker and simpler 
delivery.    Such compressed packages are 
most commonly stored as .zip (PKware 
format).    In order to extract a zipped file's
contents, you need the program 
PKunzip.exe.    

° The results of searches in File Libraries 
should be saved as .gfl (Galacticomm's 
file library format) if you wish to use the 
list to tag files to be downloaded.    

Other forms of data will come with choices appropriate to them.    

Directories
The list box displays the directory tree of the drive:\ selected below in Drives.    The 
current directory is the one whose folder icon is open and darkened within.    Any 
folders listed below it are children subdirectories of the current directory.    Any folders
listed above it are parent directories.    Between the list box and the title line 



Directories: you will see displayed in text the current directory's drive:\path, 
possibly abbreviated.    

Double-click on a directory to switch to it.    If the directory you seek is not visible, 
double-click on the directory which you know to be its parent.    This list box does not 
display the entire tree at once, but limits itself instead to the parentage and children 
of the current directory.    

Drives
This dropdown list box selects the drive letter you wish displayed.    Depending on 
your PC's setup, it may display volume names in [brackets] to the right of each drive 
letter.    

A single click selects a drive letter.    The Directories and File Name list boxes will 
change to display the new drive's current directory and files.    
 



Upload
Which file on your PC do you wish to copy up to the Worldgroup server PC?    

File Name
The text box lets you manually enter the drive:\directory\...\filename.ext of the file 
which you wish to upload to the Worldgroup server.    

The standard list box below the text box displays all files in the current drive:\
directory which are of the type selected by List Files of Type.    

The fastest way to select a file, once it's visible in the list box, is to double-click it.    

List Files of Type
The dropdown list box lets you limit the files displayed under File Name to those of a 
particular type.    This is helpful when a directory on your PC has dozens of files but 
only a handful of the type you wish to upload.    If List Files of Type doesn't offer the 
filter you require, you can manually enter your own under File Name.    

For example:

° Text files are often *.txt.
° Word processor documents are often 

*.doc.
° DOS Batch files are *.bat.    
° Programs are either *.com (command) or 

*.exe (executable).    
° Common Windows graphics formats are 

*.bmp (bitmap) and *.wmf (metafile), 
although there are more than a dozen 
other popular graphics formats.    

° Files are often compressed and packaged 
into a single file for quicker and simpler 
delivery.    Such compressed packages are 
most commonly stored as *.zip (PKware 
format).    In order to create a zip file, you 
need the program PKzip.exe.    

Other forms of data will come with extensions appropriate to them.    The normal 
default is to *.* for all files.    

Directories
The list box displays the directory tree of the drive:\ selected below in Drives.    The 
current directory is the one whose folder icon is open and darkened within.    Any 
folders listed below it are children subdirectories of the current directory.    Any folders
listed above it are parent directories.    Between the list box and the title line 
Directories: you will see displayed in text the current directory's drive:\path, 
possibly abbreviated.    



Double-click on a directory to switch to it.    If the directory you seek is not visible, 
double-click on the directory which you know to be its parent.    This list box does not 
display the entire tree at once, but limits itself instead to the parentage and children 
of the current directory.    

Drives
This dropdown list box selects the drive letter you wish displayed.    Depending on 
your PC's setup, it may display volume names in [brackets] to the right of each drive 
letter.    

A single click selects a drive letter.    The Directories and File Name list boxes will 
change to display the new drive's current directory and files.    
 



Edit Toolbar

This window lets you choose which buttons are displayed on the toolbar and which are not.    
Notice that not all of the buttons you add will necessarily appear immediately after you save
your edits.    It may be inappropriate to display a particular button at this moment but, when 
it becomes appropriate, the button will be displayed.    

Add/Remove a Button
A single mouse click on any of the buttons listed here, or on the description beside it, 
will toggle between displaying the button on the toolbar and not displaying it.    
Highlighted means the button has been included/added to the current toolbar.    Not 
highlighted means the button has been excluded/removed from the current toolbar.    

Add All
This button highlights every button in the list, including/adding all of them.    

Remove All
This button unhighlights every button in the list, excluding/removing all of them.    

Save
Once you've edited this toolbar to your satisfaction, click this button to save your 
changes.    Not all of the buttons you add will necessarily appear immediately.    It may
be inappropriate to display a particular button at this moment but, when it becomes 
appropriate, the button will be displayed.    

 




