
Click on an item above to go to a different screen.

Book Settings 
shows settings for your book.

Title - type the title of your book here.    The title will be displayed in the caption bar of the 
WinBook window and used when WinBook refers to your Book. It is recommended to keep 
the title short.

Cover File - put the location of the cover file here.    The cover file may be either a RTF or 
BMP file and will be displayed when the book is first opened.

RTF is recommended because it is smaller and it may be produced with the Compiler.
BMP is a Windows Bitmap.    Use a graphics program to produce the BMP file.    The 

graphic will be centered in the WinBook window.    
Click on the "..." button to open a dialog box to find the cover file or to produce a new

RTF cover file.    If no file is entered here, no cover will be displayed.

Copyright Statement - type the copyright statement here.    The Copyright Statement 
appears at the bottom of the WinBook window.    If you want to include the copyright symbol 
at the beginning of the statement, check the Show Copyright Symbol checkbox.    If you do 
not want to put a copyright message here, you may put another type of message here or 
nothing at all.    If the message is too long it may be cut off by WinBook depending on how 
big the user has the WinBook window.

Here is a standard copyright statement: Copyright 1998 by Ray Geide - All Rights 
Reserved.

Show Copyright Symbol - displays the copyright symbol at the beginning of the Copyright 
Statement.

About File - put the location of the about file here.    The about file is displayed when the 
reader selects the About item in the Help menu of your WinBook.    It may be a Windows 
Bitmap (.bmp) or a Rich Text Format (.rtf) file.    Use a graphics program to produce a bmp 
file.    The Compiler may be used to make a RTF file.

Click on the "..." button to open a dialog to find the About file or to open a window in 
which to make a RTF file.    

If no file is entered here, no About item will be in the Help menu.

About Caption - type what you want the About item to read in the Help menu.



Click on an item above to go to a different screen.

Page Settings
shows settings for individual pages.

Pages Dropdown box - shows the current page.    Clicking on the dropdown arrow displays a 
list of all of the pages.    Selecting a different page will load that page and bring it to the 
front.

Add Page button - adds a page to the book.    A dialog box will appear asking if you want to 
load the new page from a file.    If you answer yes, the file you select will be added to the 
book.    If you answer no, a blank page will be added.

Save Page button - saves the current page from the book.

Remove Page button - removes the current page from the book.    This will only remove the 
page from the pages list of your book, it will not delete the actual file.

Change Order of Page - The number displayed is the position of the current page.    To 
change the position, select the position you want to move the current page to.    For 
example, if the current page is the fourth page of the book, the Change Order of Page 
dropdown box will show a 4.    If you want this page to be the second page, click on the down
arrow and select 2.    The current page will then be the second page.

Page Title - type the title of the current page here.    Super WinBook puts a default title here 
when a page is first added to the book.    It is recommended to change the title to something 
more appropriate.

Allow Printing - leave this box unchecked if you do not want the reader to be able to print out
the current page.    If you want to let the reader print out the current page then check this 
box.    If this box is not checked, when the page is displayed in the WinBook viewer, the Print 
button will be disabled, otherwise it will be enabled.

FileName - shows the File Name of the current page.    If you want to load a different file into 
the current page, click on the "..." button and select a different file.

Background Music - put the file name of the music (.mid), sound (.wav), or video (.avi) here 
that you want played when this page is displayed.    Mid files are recommended over wav 
files because they are much smaller.

Clicking on the "..." button will open the Sound window which will let you find files 
and listen or watch them.    If you find a file and click on OK, the file name will be placed in 
the Background Music box.    

If you do not wish to have anything played, leave this blank and nothing will be 
played.





Click on an item above to go to a different screen.

Text Settings
allows the changing of the selected text or the current paragraph.    Icons represent the

following operations.    Most text settings may also be found in the Format Menu.

Font Dropdown Box - displays the current font and allows the user to change it by selecting 
the desired font.    When a font is selected from the dropdown box all text selected or in the 
current paragraph is changed to that font.
Size Dropdown Box - displays the current font size and allows the user to select the desired 
size.    Size is in points.
Text Color Dropdown Box - displays the current text color and allows the user to select a 
different color.
Text Background Color Dropdown Box - displays the current color behind the text and allows 
the user to select a different color.
Paragraph Background Color Dropdown Box - displays the color behind the paragraph and 
allows the user to select a different color.

Normal - changes selected text back to normal.
Bold - changes selected text to bold.
Italics - changes selected text to italics.
Underline - underlines the selected text.
StrikeOut - puts a line through the selected text.
Super Script - shifts the text up above the baseline.
Subscript - shifts the text down below the baseline.

Cut - cuts the selected text to the clipboard.
Copy - copies the selected text to the clipboard.
Paste - pastes the contents of the clipboard to the cursor.
Select All - highlights all of the text in the current window.

Find - finds a word or phrase in the current window.
Find and Replace - finds a word in the current window and replaces it with a different word.

Left Justified - lines up the selected text to the left margin.
Centered - centers the selected text between the margins.
Right Justified - lines up the selected text to the right margin.
Flush Justified - lines up the selected text to both the left and right margins.

Printer Setup - allows selection of printer, paper size, and paper orientation.
Print - prints the current window.

Insert Picture - inserts a Windows Bitmap in the text at the cursor position.    A dialog box
opens to help find and insert the picture.



Insert Table - inserts a table in the text at the cursor position.    A dialog box opens to set the
number of columns and rows and to choose whether the lines are visible or not.

Create HyperLink - makes a hyperlink out of the selected text.    A hyperlink may be linked to
another location in the book, email, or a website.    A dialog box opens to configure the

hyperlink.



Click on an item above to go to a different screen.

Reply Form
a page placed at the end of the WinBook that can be filled out and sent by email or printed

out and sent by postal mail.

Add Form button - adds a blank page to be used as a reply form to the back of the book.

Show Form button - if the book has a reply form already set up, this button opens and shows
the form.

Delete Form button - removes the reply form from the book.

Form Title - title that appears in the Table of Contents to identify the Reply Form.

Form FileName - the filename of the reply form.

Email Address - email address that the reply form will be sent to by the reader.    
If you add "?subject:" plus a subject to the end of the email address, the subject box 

will be filled in with whatever you have designated.    For example, "book@superwin.com?
subject:I want to buy 10 WinBooks" will send the email to book@superwin.com with "I want 
to buy 10 WinBooks" in the subject box.



Click on an item above to go to a different screen.

Compiler
compiles all of the necessary book files into one compressed file.

Project Directory - displays and allows the user to change the directory in which the 
compressed book file and initiation file is placed.

 Sound on Page Turn - displays the sound file that will be played when the page is turned.    
Press the "..." button to select a sound.

File Name for Book - enter eight or less letters to be used as the name of the compressed 
book file.

Compile button - press the Compile button to compile and compress all of the book files into 
one file.



Click on an item above to go to a different screen.

Deployer
copies the selected files to a directory, diskette, zip file, or self-extracting executable, so that

they can be distributed.

Copy to Destination Directory - choose and check which files you want to be copied to the 
directory specified in the Destination Directory text box.    Any combination of the files may 
be selected depending on your needs.

Your book - the compressed book file.

Read Me - the readme.rtf file in the Project directory.

WinBook Viewer - the winbook.exe file that is used to view WinBooks.

WinBook Setup - setup.exe, _setup.dll and setup.fls that install the other files to the reader's 
computer.    Note - WinBook does not need to be installed.    It can run directly from it's initial 
location.

If you would like a different graphic to be used in the beginning Setup screen, create 
one, name it image.bmp, and put it in the Compiler directory.

If you would like a description of your winbook in the About screen of the Setup 
program, create a text file, name it aboutme.txt, and put it in the Compiler directory.

If you would like licensing information (terms of freeware, shareware, or copyright) 
displayed in the Agreement screen of the Setup program, create a text file, name it 
license.txt, and put it in the Compiler directory.

If any of these files (image.bmp, aboutme.txt, or license.txt) are in the Compiler 
directory and WinBook Setup is checked, when the Deploy button is pressed, these files will 
be copied to the destination and used by the Setup program.

Destination Directory - the directory or drive to which you want the checked files copied.

Default Installation Directory - the default directory specified by setup to install the book on 
the reader's computer.    For example, "c:".

Copy Files to:
Directory - copies the checked distribution files to the Destination directory.    
Zip - copies and compresses the checked distribution files into a zip file (*.zip) and 

places the zip file in the Destination directory.
Exe - copies and compresses the checked distribution files into a self extracting 

executable file (*.exe) and places it in the Destination directory.    When the user runs this file
it will install the distribution files onto the user's hard drive. 

Copy Button - pressing this button performs the chosen action under "Copy Files to".





Menu
the menu is at the top of the Compiler window and consists of seven menu groups: File, Edit,

View, Insert, Format, Window, and Help.



File Menu

New Project - starts a new project.    The current project will be closed.
Open Project - opens a project.    The current project will be closed.
Save Project - saves the current project.
Save As Project - saves the current project under a different name.

Add Page - adds a page to the book.
Remove Page - removes the current page from the book.    The actual file is not deleted.
Save Page - saves the current page (the window on top).
Save As Page - saves the current page with a different name.
Save All - saves all of the open pages.

Print Page Setup - allows you to change the size of the paper and margins to be printed on.
Print Preview - shows what the current window will look like printed on the designated paper 
size.
Print - prints the current window.

Exit - exits the WinBook Compiler.



Edit Menu

Undo - undoes the last change to the current window.

Cut - cuts the selected text to the clipboard.
Copy - copies the selected text to the clipboard.
Paste - pastes the text in the clipboard to the cursor.
Delete - deletes the selected text in the current window.
Select All - highlights all of the text in the current window.

Find - finds a word or phrase in the current window.
Find Next - finds the next occurrance of the designated word or phrase.
Find and Replace - finds a word or phrase in the current window and replaces it with a 
different word.



View Menu

Book Settings - changes the toolbar to the book settings.
Pages Settings - changes the toolbar to the pages settings.
Text Settings - changes the toolbar to the text settings.
Reply Form Settings - changes the toolbar to the reply form settings.
Compiler Settings - changes the toolbar to the compiler settings.
Deployer Settings - changes the toolbar to the deployer settings.



Insert Menu

HyperLink - inserts a hyperlink that can be linked to another location in the book, to email, 
or to a website.
Table - inserts a table of rows and columns.
Picture - inserts a picture at the cursor.
Text File - inserts a text from another file into the current window.

Cover - creates an empty cover or loads one from a file.
About - creates an empty about screen or loads one from a file.
Reply Form - creates an empty reply form or loads one from a file.



Format Menu

Font Characteristics - opens a dialog box for changing most of the characteristics of the 
selected font.    Characteristics include font, size, style, effects, and font color.
Paragraph Spacing - opens a dialog box for changing paragraph spacing and indentation.    
Most of the spacing is easier to accomplish by using the ruler above the text.
Paragraph Borders - opens a dialog box for putting lines around paragraphs.
Set Background Colors - changes the background color for the cover, the about screen, or all
pages.



Window Menu

Cascade - if more than one window is open, offsets each window down and to the right of 
the previous window.

Tile Vertically - if more than one window is open, divides the desktop vertically by the 
number of windows open and sizes each window to fit in the allotted space.

Tile Horizontally - if more than one window is open, divides the desktop horizontally by the 
number of windows open and sizes each window to fit in the allotted space.

Arrange Icons - arranges the minimized windows along the bottom of the desktop.

Close All - closes all of the windows.



Help Menu

Contents - displays the Table of Contents of this Help file.

Topic Search - displays Index of this Help file.

How To Use Help - displays instructions on how to use and configure Help.

About... - displays information about Super WinBook 98 Compiler.



Limitations

There are some size limitations to Super WinBook 98 and its Compiler.

Pages - a WinBook may have up to 100 pages.

Individual Page - a WinBook and the Compiler work best if the size of the page is less than 
312kb.    If the page is bigger, loading of the page may take a long time.

Open Pages - the Compiler works best if the total size of open pages is less than 312kb.    So 
if you have five pages open in the Compiler of 100kbs each, you will have problems.    All you
have to do is click on the X in the upper right hand corner of the page window.    This will 
close the page window, but the page will still be in the WinBook.    If you want to view the 
page again, just select it in the pages dropdown box and it will open.

If you are having problems with opening a page, compiling or copying, try closing the 
pages first.



How to Create a WinBook

Creating a WinBook is simple.    

Start with the Book tab.
Type in the name of the book in the Title textbox.
To produce a cover, click on the "..." button next to the Cover File textbox.    You can load a BMP or RTF file 

or produce a new RTF file for the cover.    If nothing is entered here, your book will not have a cover.
Type in a copyright message and check if you want the copyright symbol to appear before the copyright 

message.
Select what to have on the About screen, just as you did with the Cover.    The About screen appears when 

the reader selects the About... item in the Help menu.    If nothing is entered here, the About... item will not be 
present in the Help menu.

Enter what you want the About... item to say, in the About Caption textbox.

Go to the Pages tab.
Press the Add Page button.    You can either load a page from a file (RTF or TXT) or make a new one.
Change the Page Title to the name of the Page.
Check the Allow Printing checkbox if you want to allow the reader to print out the page.
If you want music to be played while the page is displayed in the WinBook, press the "..." button next to 

the Background Music textbox and select a music file.
Continue adding pages in this manner until all pages are added.
If you want to change the order of a page select the new position of the page from the Change Order 

dropdown box.
To go to a different page select the page from the top dropdown box.

Use the Text tab or the Format Menu to format the text of the Page.

If you want a reply form as the last page of your book, go to the Reply Form tab.
Press the Add button to add a reply form.
Enter a Title for the reply form and an email address.

When you book is finished, go to the Compiler tab.
The first and last textbox should be already filled in.    If you want to change them, you may.
If you want a page turning sound, click on the "..." button and pick out a sound.
Press on the Compile button when everything is ready.    This will compile and compress all of the files and 

allow you to have a first glimpse of your book.
If you want to change something in the book, do so and then press the Compile button again.

When everything is perfect, go to the Deployer tab.
Select which files you want to distribute.
If you are distributing the book over the internet, you may want to keep it small.    In this case, you could 

just check the Your Book checkbox and point the reader to a website to download the Viewer.
If the Read Me checkbox is checked, the Readme.rtf file in the Project directory will be added to the files 

distributed.    If a readme.rtf file is not found in the Project directory, the one in the Compiler directory is copied.    
You may change this file to say whatever you want it to say.

If the WinBook Setup checkbox is checked, a setup program is included that will setup all of the other 
checked files on the user's computer.    Be sure to type in a Default Installation Directory (for example, c:), if this 
checkbox is checked.

By default the Destination Directory is the Bookssubdirectory of the Compiler directory.    The Destination 
Directory may be changed.    If this directory does not exist, it will be created.

Select in which form you want to deploy your winbook: separate files, a compressed zip file, or a self-
extracting executable.

Press the Copy button to produce the file or files to distribute.

Now distribute your book and make millions of dollars!!




