Inhalt

Die Menüpunkte

Das Menü Datei

Das Menü Bearbeiten

Das Menü Ansicht

Das Menü Projekt

Das Menü Fenster

Das Menü Hilfe

Elemente der Formularsprache

Syntax und Schlüsselwörter

Allgemeine Druckbefehle

Druckbefehle der Lexware-Anwendungen

Alphabetische Befehlsreferenz

Befehlsreferenz


Das Menü Datei

Neu | Erstellen eines neuen Formulars
Öffnen | Öffnen eines bestehenden Formulars
Schließen | Schließen eines geöffneten Formulars
Speichern | Speichern des geöffneten Formulars unter seinem bereits bestehenden Dateinamen
Speichern unter | Speichern des geöffneten Formulars unter einem benutzerdefinierten Dateinamen
Drucken | Ausdruck des geöffneten Formulars
Seitenansicht | Visuelle Darstellung des Formulars am Bildschirm
Druckereinrichtung | Auswahl eines installierten Druckers
Beenden | Beenden des Programms DruckNT-IDE


Datei/Neu

Über diesen Befehl können Sie ein neues Formular in DruckNT erstellen.

Im folgenden Dialogfeld geben Sie an, welchen Formulartyp Sie anlegen möchten:

Formular Neues Formular

Interface Schnittstellendefinitionen (Neues Interface)

Beschreibung

In einer Schnittstellendefinition sind alle Funktionen hinterlegt, die die Applikation bearbeiten kann.

Diese werden programmspezifisch mit ausgeliefert.

Abkürzungen

Symbolleiste:

Tastatur: STRG+N

Zum Öffnen einer bereits bestehenden Datei dient der Befehl Öffnen


Datei/Schließen

Verwenden Sie diesen Befehl um geöffnete Formulare zu schließen. DruckNT schlägt Ihnen dabei vor, die Änderungen an Ihrem Formular vor dem Schließen zu speichern. Falls Sie ein Formular ohne zu speichern schließen, gehen alle Änderungen verloren, die Sie seit dem letzten Speichern des Formulars vorgenommen haben. Bevor ein Formular ohne Titel geschlossen wird, zeigt DruckNT das Dialogfeld Speichern unter an und schlägt vor, das Formular zu benennen und zu speichern.


Datei/Speichern

Mit diesem Befehl können Sie das aktive Formular unter seinem momentanen aktuellen Namen und Verzeichnis speichern. Beim ersten Speichern eines Formulars zeigt DruckNT dazu das Speichern unter an, so dass Sie Ihr Formular benennen können. Wenn Sie den Namen und das Verzeichnis eines bestehenden Formulars ändern wollen, können Sie ebenfalls den Speichern unter wählen.

Abkürzungen

Symbolleiste:

Tastatur: STRG+S


Datei/Speichern unter

Verwenden Sie diesen Befehl, um das aktive Formular zu speichern und zu benennen. DruckNT zeigt das Dialogfeld Speichern unter an, so dass Sie einen Namen für Ihr Formular angeben können.

Zur Speicherung eines Formulars unter seinem bestehenden Namen und Verzeichnis dient der Befehl Speichern .


Datei/Drucken

Verwenden Sie diesen Befehl zum Ausdrucken eines Formulars. Es wird lediglich das am Bildschirm angezeigte Formular ausgedruckt, nicht das damit zu erstellende Dokument!

Bei Auswahl des Befehls erscheint das Dialogfeld Drucken , in dem Sie den zu druckenden Seitenbereich, die Anzahl der Kopien, den Zieldrucker und andere Optionen zur Druckereinstellung angeben können.

Abkürzungen

Symbolleiste:

Tastatur: STRG+P


Datei/Seitenansicht

Verwenden Sie diesen Befehl, um das aktive Formular so anzuzeigen, wie es gedruckt aussehen würde.

Es wird lediglich das Formular ausgedruckt, nicht das damit zu erstellende Dokument!

Bei der Auswahl dieses Befehls wird das Hauptfenster durch ein Seitenansichtsfenster ersetzt, in dem ein oder zwei Seiten im Druckformat dargestellt werden. In der Symbolleiste der Seitenansicht haben Sie die Möglichkeit festzulegen, ob Sie eine oder zwei Seiten gleichzeitig betrachten wollen. Weiterhin können Sie sich im Dokument vor- und zurückbewegen, Seiten vergrößert und verkleinert darstellen lassen oder einen Druckauftrag starten.


Seitenansichts-Symbolleiste

Symbolleiste der Seitenansicht

In der Symbolleiste der Seitenansicht stehen Ihnen die folgenden Optionen zur Verfügung:

Drucken

Hiermit gelangen Sie in das Dialogfeld Drucken, in dem Sie einen Druckauftrag starten können.

Nächste Seite

Zeigt die Ansicht der nächsten Druckseite an.

Vorherige Seite

Zeigt die Ansicht der vorherigen Druckseite an.

Eine Seite/Zwei Seiten

Bestimmt, ob eine oder zwei Seiten gleichzeitig sichtbar sein sollen.

Vergrößern

Mit dieser Option können Sie die Seite näher betrachten.

Verkleinern

Gibt Ihnen einen größeren Überblick über die Druckseite.

Schließen

Kehrt von der Seitenansicht wieder in das Bearbeitungsfenster zurück.


Datei/Beenden

Verwenden Sie diesen Befehl zum Beenden Ihrer Sitzung mit DruckNT. Alternativ dazu können Sie aus dem Systemmenü der Anwendung den Befehl Schließen wählen. DruckNT fragt nach, ob Sie Formulare mit nicht gesicherten Änderungen speichern wollen.

Abkürzungen

Maus: Doppelklicken Sie auf das Systemmenü der Anwendung.

Tastatur: ALT+F4


Der Befehl Druckereinrichtung

Verwenden Sie diesen Befehl, um einen Drucker und einen Druckeranschluss zu bestimmen. Nach Auswahl des Befehls erscheint das Dialogfeld Druckereinrichtung , in dem Sie den Drucker und seinen Anschluss festlegen können.


Datei/Druckereinrichtung

Mit den folgenden Optionen können Sie den Drucker und seinen Anschluss festlegen:

Drucker

Wählen Sie hier den Drucker aus, den Sie benutzen wollen. Wählen Sie entweder den "Standarddrucker", oder verwenden Sie die Option "Spezieller Drucker" und wählen dann einen der installierten Drucker aus dem Feld aus. Zum Installieren von Druckern und Einstellen von Druckeranschlüssen verwenden Sie die Systemsteuerung von Windows.

Format

Wählen Sie Hoch- oder Querformat.

Papier/Größe

Wählen Sie die Größe des Papiers, auf dem das Dokument gedruckt werden soll.

Papier/Zufuhr

Einige Drucker besitzen mehrere Schächte für verschiedene Arten der Papierzufuhr. Geben Sie hier den Schacht an.

Optionen

Zeigt ein Dialogfeld an, in dem Sie zusätzliche Auswahlmöglichkeiten haben, die spezifisch für den von Ihnen ausgesuchten Drucker sind.

Netzwerk...

Verwenden Sie diese Schaltfläche, um einem Laufwerkbuchstaben eine Verbindung zu einem Netzwerklaufwerk zuzuweisen.


Das Dialogfeld Drucken

Die folgenden Optionen ermöglichen es Ihnen anzugeben, wie das Dokument gedruckt werden soll:

Drucker

Hier wird der aktive Drucker und Druckeranschluss angezeigt. Wählen Sie die Option "Einrichten", um den Drucker und den Druckeranschluss zu ändern.

Einrichten

Zeigt ein Dialogfeld Druckereinrichtung an, in dem Sie einen Drucker und einen Druckeranschluss wählen können.

Druckbereich

Geben Sie die Seiten an, die Sie ausdrucken wollen:

Alles | Druckt das gesamte Dokument
Markierung | Druckt den markierten Text
Seiten | Druckt den Seitenbereich, den Sie in den Feldern "Von" und "Bis" angeben

Kopien

Geben Sie an, wie viele Kopien vom oben eingestellten Seitenbereich gedruckt werden sollen.

Kopien sortieren

Druckt die Kopien in der Reihenfolge der Seitennummern, statt getrennt für jede Seite mehrere Kopien zu drucken.

Druckqualität

Wählt die Druckqualität aus. Im allgemeinen benötigt der Druckvorgang um so weniger Zeit, je niedriger die Druckqualität ist.


Das Dialogfeld: Datei/Speichern unter

Die folgenden Optionen ermöglichen es Ihnen, Namen und Ort der Datei festzulegen, die Sie speichern möchten:

Dateiname

Geben Sie einen neuen Dateinamen ein, um ein Formular unter einem anderen Namen abzuspeichern. Ein Dateiname kann aus bis zu acht Zeichen zuzüglich einer Dateierweiterung von bis zu drei Zeichen bestehen. DruckNT fügt dem Namen die von Ihnen im Feld "Dateityp" festgelegte Erweiterung hinzu.

Laufwerke

Wählen Sie das Laufwerk, auf dem die Datei gespeichert werden soll.

Verzeichnisse

Wählen Sie das Verzeichnis, in dem Sie das Formular speichern wollen.

Netzwerk...

Verwenden Sie diese Schaltfläche, um einem Laufwerkbuchstaben eine Verbindung zu einem Netzlaufwerk zuzuweisen.


Datei/Öffnen

Mit diesem Befehl können Sie ein bereits bestehendes Formular öffnen. In der Dialogbox "Öffnen" geben Sie bitte den Namen des zu öffnenden Formulars ein.

Es lassen sich mehrere Fenster gleichzeitig öffnen. Mit Hilfe des Menüs Fenster schalten Sie zwischen mehreren geöffneten Formularen um.

Abkürzungen

Symbolleiste:

Tastatur: STRG+O

Neue Formulare können Sie mit dem Befehl_Neu erstellen.


Das Menü Bearbeiten

Rückgängig | Rückgängig machen der letzten Bearbeitungsoperation
Wiederholen | Wiederholen der letzten Bearbeitungsoperation
Ausschneiden | Löschen von Daten aus dem Formular und Übertragung in die Zwischenablage
Kopieren | Kopieren von Daten aus dem Formular in die Zwischenablage
Einfügen | Einfügen von Daten aus der Zwischenablage in das aktuelle Formular
Suchen | Suchen nach einer Zeichenkette im aktuellen Formular
Ersetzen | Ersetzen einer Zeichenkette durch eine andere im aktuellen Formular
Alles_markieren | Markieren des gesamten Text im aktuellen Formular


Bearbeiten/Rückgängig

Verwenden Sie diese Option, um die letzte Bearbeitungsaktion rückgängig zu machen, wenn dies möglich ist. Abhängig von der zuletzt ausgeführten Aktion verändert sich der Name dieses Befehls.

Abkürzungen

Tastatur: STRG+Z oder ALT-RÜCKTASTE


Bearbeiten/Wiederholen

Der letzte Vorgang wird nochmals durchgeführt. Ist eine Wiederholung des letzten Befehls oder Eingabe nicht möglich, ändert sich der Befehlsname in Wiederholen: Nicht möglich.

Abkürzungen

Tastatur: STRG+Y


Bearbeiten/Ausschneiden

Verwenden Sie diesen Befehl, um die aktuell markierten Daten aus dem Formular zu entfernen und in die Zwischenablage zu übertragen. Der Befehl kann nicht ausgewählt werden, wenn momentan keine Daten markiert sind.

Das Ausschneiden und Übertragen von Daten in die Zwischenablage ersetzt die Daten, die sich zuvor dort befanden.

Abkürzungen

Symbolleiste:

Tastatur: STRG+X


Bearbeiten/Kopieren

Verwenden Sie diesen Befehl, um markierte Daten in die Zwischenablage zu kopieren. Der Befehl kann nicht ausgewählt werden, wenn momentan keine Daten markiert sind.

Das Kopieren von Daten in die Zwischenablage ersetzt die Daten, die sich zuvor darin befanden.

Abkürzungen

Symbolleiste:

Tastatur: STRG+C


Bearbeiten/Einfügen

Verwenden Sie diesen Befehl, um eine Kopie des Inhalts der Zwischenablage an der Einfügestelle einzufügen. Dieser Befehl steht nicht zur Verfügung, wenn die Zwischenablage leer ist.

Abkürzungen

Symbolleiste:

Tastatur: STRG+V


Bearbeiten/Ersetzen

Verwenden Sie diesen Befehl, um eine Zeichenkette durch eine andere innerhalb des aktuellen Formulars zu ersetzen. Es öffnet sich ein Ersetzens-Dialog in den Sie die zu suchende und die neue Zeichenkette eingeben können.

Abkürzungen

Tastatur: STRG+H


Bearbeiten/Alles markieren

Möchten Sie den gesamten Text des Formulars löschen oder kopieren, wählen Sie diesen Befehl und führen anschließend die gewünschte Aktion aus. Einzelne Bereiche des Formulars können Sie bei gedrückter linken Maustaste und Ziehen des Mauszeigers über den Text markieren.

Abkürzungen

Tastatur: STRG+A


Bearbeiten/Suchen

Verwenden Sie diesen Befehl, um nach einer Zeichenkette innerhalb des aktuellen Formulars zu suchen. Es öffnet sich ein Suchen-Dialog in den Sie die zu suchende Zeichenkette eingeben können.

Abkürzungen

Tastatur: STRG+F


Das Menü Ansicht

Symbolleisten | Ein- oder ausblenden der Symbolleiste
Statusleiste | Ein- oder ausblenden der Statusleiste
Ausgabefenster | Ein- oder ausblenden des Ausgabefenster


Der Befehl Ansicht/Symbolleisten

Verwenden Sie diesen Befehl zum Ein- oder Ausblenden der Symbolleisten. Die Symbolleiste Standard enthält einige Schaltflächen der gebräuchlichsten Befehle von DruckNT, wie zum Beispiel Datei Öffnen. Mit der Symbolleiste Text können Eingaben rückgängig gemacht oder wiederholt werden. Auch die Suchfunktion kann über das entsprechende Symbol aufgerufen werden. Wenn die Symbolleiste angezeigt wird, erscheint ein Häkchen neben diesem Menüeintrag.

Hilfe zum Gebrauch der Symbolleisten Standard und Text finden Sie unter Die Symbolleisten


Die Symbolleisten

Symbolleiste Standard

Symbolleiste Standard

Die Symbolleisten werden horizontal oben im Anwendungsfenster unterhalb der Menüleiste angezeigt. Sie stellen per Mausklick einen schnellen Zugriff auf viele Tools von DruckNT dar.

Um die Symbolleiste ein- oder auszublenden, können Sie aus dem Menü Ansicht den Befehl Symbolleiste auswählen (ALT,A,S).

Funktionen der einzelnen Symbole der Symbolleiste Standard

Öffnet ein neues Formular

Öffnet ein bestehendes Formular. DruckNT zeigt das Dialogfeld Öffnen an, in dem Sie die gewünschte Datei finden und öffnen können

Speichert das aktive Formular oder die aktive Vorlage unter dem aktuellen Namen. Wenn Sie das Formular noch nicht benannt haben, zeigt DruckNT das Dialogfeld Speichern unter an

Entfernt die markierten Daten aus dem Formular und überträgt sie in die Zwischenablage

Kopiert die markierten Daten in die Zwischenablage

Fügt den Inhalt der Zwischenablage an der Einfügestelle ein

Druckt das aktive Formular.

Legt das Hauptformular fest.

Übersetzt das aktuelle Hauptformular

Zeigt die DruckNT Hilfethemen an

Funktionen der einzelnen Symbole der Symbolleiste Text


Ansicht/Statusleiste

Verwenden Sie diesen Befehl, um die Statusleiste ein- oder auszublenden. Die Statusleiste beschreibt die Aktion, die vom ausgewählten Menüeintrag oder einer gedrückten Schaltfläche der Symbolleiste ausgeführt wird und zeigt den Zustand der feststellbaren Tasten an. Falls die Statusleiste angezeigt wird, erscheint ein Häkchen neben dem Menüeintrag dieses Befehls.

Hilfe zur Verwendung der Statusleiste finden Sie unter Statusleiste .


Die Statusleiste

Die Statusleiste wird am unteren Rand des Fensters von DruckNT angezeigt. Sie können die Statusleiste im Menü Ansicht mit dem Befehl Statusleiste ein- oder ausblenden.

Während Sie sich mit den RICHTUNGSTASTEN durch Menüs bewegen, beschreibt der linke Bereich der Statusleiste die Funktion der Menüeinträge. Entsprechend dazu werden in diesem Bereich auch Beschreibungen zur Wirkung der Schaltflächen der Symbolleiste angezeigt, wenn Sie den Mauszeiger kurz auf dem Symbol ruhen lassen.

In den rechten Bereichen der Statusleiste wird angezeigt, welche der folgenden Tasten festgestellt sind:

Anzeige Beschreibung

CAP Die FESTSTELLTASTE ist aktiviert

NUM Die Taste NUM ist festgestellt

SCRL Die Taste ROLLEN ist festgestellt


Das Ausgabefenster

Im Ausgabefenster wird während des Kompilierens Meldungen über den Fortgang angezeigt. Tritt während des Kompilierens ein Fehler auf, wird die betroffene Datei und die entsprechende Fehlerart angezeigt. Kann das Programm übersetzt werden erscheint im Ausgabefenster das Ergebnis und weitere Informationen zum Übersetzungsvorgang.


Das Menü Projekt

Das Menü Projekt bietet folgende Befehle, um das aktuelle Hauptformular festzulegen und zu übersetzen:

Formular | Öffnen des aktuellen Hauptformulars zur Bearbeitung
Kompilieren | Starten der Übersetzung des Hauptformulars (Kompilieren)
Ausführen | Ausführen des übersetzten Hauptformulars


Projekt/Formular

Verwenden Sie diesen Befehl, um ein Hauptformular festzulegen. Gleichzeitig wird dieses Hauptformular in den Editor geladen.

Bei einem Übersetzungsvorgang wird immer nur das unter diesem Menüpunkt festgelegte Hauptformular verwendet, gleichgültig welches Formular gerade das Aktive im Editor ist.

D.h. wenn Sie ein Formular ändern bzw. bearbeiten möchten, müssen Sie dies zuvor als Hauptformular öffnen.

Abkürzungen

Symbolleiste:

Tastatur: keine


Projekt/Kompilieren

Verwenden Sie diesen Befehl, um das aktuelle Hauptformular zu übersetzen.

Beim Übersetzen wird die ".vmb"-Datei erstellt, die zum Drucken im Programm erforderlich ist.

Beachten Sie, dass das Hauptformular nicht mit dem im Editor angezeigten Formular identisch sein muss. Um das aktuelle Hauptformular zu definieren wählen Sie den Menübefehl Formular .

Abkürzungen

Symbolleiste:

Tastatur: F7


Projekt/Ausführen

Unter diesem Menüpunkt können Sie sich die Ergebnisse des kompilierten Formulars ansehen. Voraussetzung dafür ist jedoch, dass Sie im Formular keine Variablen verwenden.

Abkürzungen

Tastatur: F5


Das Menü Fenster

Das Menü Fenster bietet folgende Befehle, die Ihnen erlauben, mehrere Ansichten von mehreren Formularen im Anwendungsfenster einzurichten:

Überlappend | Ordnet die Fenster überlappend an
Übereinander | Ordnet die Fenster übereinander an
Nebeneinander | Ordnet die Fenster nebeneinander an
Symbole anordnen | Ordnet die zu Symbolen verkleinerten Fenster an
Fenster 1, 2, ... | Schaltet in das angegebene Fenster um


Das Menü Hilfe

Das Menü Hilfe enthält folgende Befehle, die Ihnen Unterstützung für diese Anwendung bereitstellen:

DruckNT-Hilfethemen | Anzeige des Inhaltsverzeichnisses über die Themen, zu denen eine Hilfe zur Verfügung steht.
Suchen | Anzeige des Indexes der Hilfe
Hilfe benutzen | Anzeige allgemeiner Themen zur Verwendung der Hilfe
Info | Anzeige der Versionsnummer dieser Anwendung


Syntax und Schlüsselwörter der Formularsprache

Schlüsselwörter

Include | Einfügen einer anderen Formulardatei in das aktuelle Formular
Const | Ersetzen eines Textes durch einen anderen
Declare external | Deklariert (beschreibt) eine Funktion, die vom Programm über die Schnittstelle angeboten wird.
Dim | Definiert eine neue Variable
Function, End Function | Definiert eine Funktion innerhalb des Formulars
While, End While | Erzeugt eine Programmschleife
If, End If | Erzeugt eine bedingte Programmausführung
Description | Setzt den Wert einer Beschreibungsvariablen

Syntax

Wertzuweisung | Setzen des Wertes einer Variablen
Identifikator | Name, der eine Funktion, eine Variable oder eine Konstante bezeichnet
Parameterliste | Zur Definition einer Funktion und zur Beschreibung einer Schnittstellenfunktion
Referenzen | Zur Übergabe von Parametern an Funktionen
Datentypen | Zur Definition des Variabelentyps (Bsp.: Text, Wert, Datum)
Ausdruck | Formel zur Berechnung eines Wertes
Operatoren | Zur Verknüpfung von Werten innerhalb eines Ausdrucks


Namen von Beschreibungen

Folgende Beschreibungen sind vordefiniert und werden können verwendet werden.

Form_Description

Beschreibung der Formulardatei

Form_Code

Kennung des Formulars

Page_Orientation

Seitenorientierung, kann folgende Werte haben

PAGE_LANDSCAPE, PAGE_PORTRAIT, PAGE_STANDARD

PAGE_LANDSCAPE | Ausdruck erfolgt im Querformat
PAGE_PORTRAIT | Ausdruck erfolgt im Hochformat
PAGE_STANDARD | Ausdruck erfolgt in dem Format, das zum Ausdruckszeitpunkt im Drucker hinterlegt ist.

Wichtig:

Der Description-Identifikator Page_Orientation wirkt sich nur bei Verwendung des Standarddruckers aus. Werden hingegen mit dem Befehl SetPrintDevice() spezielle Druckereinstellungen aufgerufen, so haben diese Priorität.

Beispiel

Description Form_Description as "Stammdaten drucken"

Description Form_Code as "Stammdaten"

Description Page_Orientation as PAGE_PORTRAIT

Description Form_Description as "Stammdaten drucken" | Beschreibung der Formulardatei
Description Form_Code as "Stammdaten" | Kennung des Formulars
Description Page_Orientation as PAGE_PORTRAIT | Seitenorientierung (hier Hochformat)

Siehe auch

Description , Seitenkonstanten , SetPrintDevice()


Wertzuweisung

Identifikator = Ausdruck

Setzen des Wertes einer Variablen.

Beschreibung

Der Datentyp der Variablen muss mit dem Datentyp des aus dem Ausdruck resultierenden Wertes übereinstimmen andernfalls meldet der Compiler einen Fehler wegen falscher Datentypen in einer Zuweisung.

Beispiel für eine falsche Zuweisung

Dim n as Numeric

n = "Meier"

richtig ist

Dim n as Numeric

n = 1

Im Falle von Funktionen, die einen Rückgabewert besitzen, kann eine Zuweisung an den Namen der Funktion erfolgen, um den Rückgabewert zu definieren.

Beispiel

Dim n as Numeric | Festlegen des Datentyps der Variablen n Bei numerischen Variablen wird der Wert gleichzeitig auf 0 gesetzt
n = n + 1 | Die Variable n bekommt den Wert n (0,00) + 1, also die 1

Dim s as String | Festlegen des Datentyps der Variablen s
s = "Frau " | Die Variable beinhaltet den Text "Frau"
s = s + "Meier" | Die Variable s bekommt den Inhalt "Frau Meier"

Siehe auch

Datentypen , Identifikator , Ausdruck


Identifikator

Ein Name (Bezeichner), der eine Funktion, eine Variable oder eine Konstante bezeichnet. Ein Identifikator darf nicht mit einer Zahl beginnen und keine Leerstellen oder Sonderzeichen beinhalten.


Parameterliste

Eine Parameterliste wird bei der Definition einer Funktion verwendet. Sie deklariert die Datentypen, der an die Funktion zu übergebenden Parameter und bestimmt die innerhalb der Funktion gültigen Namen der Parameter.

Syntax

Identifikator1 as Datentyp1, Identifikator2 as Datentyp2,...

Beschreibung

Eine Parameterliste kann auch leer sein. In diesem Fall werden keine Parameter für die entsprechende Funktion definiert.

Beispiel

Function DruckeDaten(Person as String, Datum as Numeric) as Bool

Person | Identifikator1
as | als
String | Datentyp1 (Zeichenkette)
Datum | Identifikator2
as | als
Numeric | Datentyp2

Siehe auch

Datentypen , Funktionen , Schnittstellenfunktionen


Referenzen

Referenzen treten bei der Übergabe von Parametern an Funktionen auf. Eine Referenz ist eine Variable, die in der Parameterliste definiert wurde und auf die beim Aufruf übergebene Variable verweist. Referenzen können nur von Variablen erzeugt werden und nicht von Konstanten oder Funktionen. In diesem Fall würde der Compiler einen Fehler bei der Übergabe von Parametern, beim Funktionsaufruf melden.

Beispiel

Function GetName (s ref String)

s = "Name"

End Function

Dim v as String

GetName(v) è Diese Variable v beinhaltet nach dem Aufruf den durch s übergebenen Wert

"Name"

Siehe auch

Funktionen , Schnittstellenfunktionen


Datentypen

Jeder Wert innerhalb eines Formulars hat einen bestimmten Datentyp. Bei Variablen und Rückgabewerten wird der Datentyp bei der entsprechenden Definition festgelegt

Folgende Datentypen können verwendet werden

String

Zeichenkette, die durch Anführungszeichen eingeschlossen ist.

Beispiel: "Meier"

Numeric

Numerischer Wert mit Nachkommastellen.

Beispiel: 10,001

Bool

Wahrheitswert, wahr(TRUE) oder falsch (FALSE)

Beispiel: True

CellType

Identifikator für Tabellenzellen (ist intern vom Typ Numeric)

Beispiel:  Dim c as CellType

  c = CreateCell(300, 200)

Object

Datentyp, über den eine COM-Schnittstelle angesprochen werden kann.

à COM - Schnittstelle

Beispiel:

Dim Excel as Object

Excel = CreateObject("Excel.Application")

Siehe auch

Dim , Parameterliste


Ausdruck

Ein Ausdruck ist eine Formel zur Berechnung eines Wertes. In dieser Formel werden Funktionen (eigentlich deren Rückgabewerte), Konstanten und Variablen mit Hilfe von Operatoren verknüpft. Als Resultat bleibt ein Wert, der einen bestimmten Datentyp hat. Für die Steuerung der Bearbeitungsreihenfolge von Ausdrücken können Klammern gesetzt werden.

Beispiel

(n + 1) * 10

n | Zuvor definierte Variable as Numeric (Zahl)
+ 1 | Auf den Wert der Variable n wird +1 aufaddiert
* 10 | Die Summe n + 1 wird mit dem Faktor 10 multipliziert

Beispiel

Dim n as Numeric = 3

a=(n + 1) * 10

Die Variable n beinhaltet nach der Berechnung immer noch den Wert 3. Die Variable a beinhaltet das Ergebnis 40

Siehe auch

Zuweisung , Bedingung , Schleife , Operatoren


Operatoren

Operatoren verknüpfen Werte innerhalb eines Ausdrucks. Für die einzelnen Datentypen existieren unterschiedliche Operationen.

String

+ : hängt zwei Strings aneinander. Das Ergebnis ist wiederum ein String.

= : vergleicht zwei Strings und ergibt damit einen Bool-Wert

<> : vergleicht zwei Strings auf Ungleichheit und ergibt einen Bool-Wert

Numeric

+, -, *, / : Addition, Subtraktion, Multiplikation und Division zweier Werte. Das Ergebnis ist wieder ein Numeric-Wert.

=, <, >, <=, >=, <> : vergleichen zweier Numeric-Werte. Das Ergebnis ist vom Typ Bool.

Bool

And : logisches Und zweier Bool-Werte. Das Ergebnis ist vom Typ Bool.

Or : logisches Oder zweier Bool-Werte. Das Ergebnis ist vom Typ Bool.

Not : Negation eines Bool-Werts.

Siehe auch

Ausdrücke , Datentypen


Include

Include "Formulardatei"

Einfügen einer anderen Formulardatei in das aktuelle Formular.

Parameter

Formulardatei

Name der einzufügenden Formulardatei

Beschreibung

Der Include-Befehl ermöglicht das Aufspalten eines Formulars in mehrere kleine Formulardateien und kann an jeder Stelle des Formulars eingefügt werden.

Ein Formular kann so aus einzelnen Komponenten aufgebaut werden, die wiederum in mehreren Formularen eingebunden sind. Ein typisches Beispiel für eine derartige Komponente ist der Kopf oder Fuß einer Seite, der so nur einmal erstellt werden muss und dann in jedem Ausdruck verwendet werden kann und immer gleich aussieht.

Es ist möglich mehrere, unterschiedliche Kopf- oder Fußzeilen als Formular zu erstellen.

Beispiel

Include "Kopf.lsf"

Include | Befehl
"Kopf.lsf" | Name der einzufügenden Formulardatei


Const

Const Identifikator as Wert

Ersetzen eines Textes durch einen anderen.

Parameter

Identifikator Name des Identifikators

Wert Zeichen, die den Identifikator im Formular ersetzen

Beschreibung

Der Wert-Parameter ist eine einfache Zeichenfolge, die bis zum Zeilenende eingelesen wird. Jedes Vorkommen des Textes im nachfolgenden Formulartext wird ohne Prüfung durch seinen Wert ersetzt.

D.h. jedes Vorkommen des Bezeichners wird durch dessen Wert ersetzt.

Vorsicht

Definieren Sie keine bereits im Sprachumfang enthaltenen Identifikatoren erneut. Das hat unvorhersehbare Auswirkungen auf das gesamte Formular.

Am Ende einer Const-Zeile dürfen keine anwenderspezifische Kommentare (Bsp.: Beschreibung der Funktion) hinterlegt werden. Möglich ist dies in der nächsten Zeile.

Beispiel

Const NORMALE_SCHRIFT as "Arial", 12, FONT_NORMAL, COLOR_BLACK

...

SetFont( NORMALE_SCHRIFT )

Const NORMALE_SCHRIFT | Identifikator (Bezeichner)
as | Durch was soll der Bezeichner ersetzt werden
"Arial", 12, "FONT_NORMAL, COLOR_BLACK | Wert

Siehe auch

Identifikator


Declare external

Declare external Identifikator( Parameterliste ) as Typ des Rückgabewertes

Deklariert (beschreibt) eine Funktion, die vom Programm über die Schnittstelle angeboten wird.

Parameter

Identifikator

Name der Funktion

Parameterliste - optional

Liste der Form:

Identifikator1 as Datentyp1, Identifikator2 as Datentyp2, ...

Typ des Rückgabewertes - optional

Hat die Funktion einen Rückgabewert, dann bestimmt dieser Parameter dessen Datentyp

Beschreibung

Die Parameterliste kann komplett entfallen, falls die Funktion keine Parameter hat. Gibt die Funktion keinen Rückgabewert an das Formular zurück, dann können das Schlüsselwort as und der Datentyp ebenfalls entfallen.

Wenn Sie bereits Programmiererfahrung haben, werden Sie wahrscheinlich Referenzparameter schon kennen. Wird eine Variable an einen Referenzparameter übergeben, dann hat er nach dem Funktionsaufruf den Wert, den der entsprechende Parameter innerhalb der Funktion hatte. Dadurch ist es möglich, dass eine Funktion mehrere Rückgabewerte an den Aufrufer übergibt.

Vorsicht

Die vom Programm zur Verfügung gestellten Funktionen sind fest vorgegeben. Normalerweise müssen Sie keine eigenen Deklarationen von Funktionen vornehmen.

Beispiele

Declare external GetDate() as Numeric

oder

Declare external GetName( Nummer as Numeric ) as String

oder

Declare external PageBreak()

Declare external GetDate () | Bekanntmachung (Beschreibung) der Funktion
as | Als welcher Dateityp soll der Wert zurückgegeben werden
(Nummer as Numeric) | Parameter, welcher der Funktion übergeben werden kann
String | Rückgabewert
Numeric | Numerischer Wert

Siehe auch

Identifikator , Parameterliste , Variabelendefinition , Referenzen


Dim

Dim Identifikator as Datentyp

Definiert eine neue Variable.

Parameter

Identifikator

Name der Variablen

Datentyp

Datentyp der neuen Variablen

Beschreibung

Um innerhalb eines Formulars Berechnungen durchzuführen, können Sie eigene Variablen definieren.

Eine Variable, die innerhalb einer Funktion definiert wurde, ist nur innerhalb dieser Funktion gültig. Alle anderen Variablen sind global gültig und können somit auch in einer Funktion angesprochen werden. Zwar werden bei gleichnamigen Variablen, die global und innerhalb einer Funktion definiert sind, die innerhalb der Funktion definierten vorrangig bearbeitet, dennoch sollten Sie nach Möglichkeit Doppelbelegungen vermeiden.

Eine neu definierte Variable wird mit einem zum Datentyp passenden Standardwert initialisiert. Für die Datentypen gelten folgende Standardwerte:

String – leerer String ("")

Numeric – 0.00

Bool - False

Beispiel

Dim Name as String

...

Name = "Meier"

Dim | Definiert eine neue Variable
Name | Neue Variable
as | als
String | Datentyp

Siehe auch

Identifikator , Datentypen


Function

Function Identifikator( Parameterliste ) as Typ des Rückgabewertes

...

Funktionsrumpf

...

End Function

Definiert eine Funktion innerhalb des Formulars.

Parameter

Identifikator

Name der Funktion

Parameterliste - optional

Liste der Form

Identifikator1 as Datentyp1, Identifikator2 as Datentyp2, ...

Typ des Rückgabewertes - optional

Hat die Funktion einen Rückgabewert, dann bestimmt dieser Parameter dessen Datentyp

Funktionsrumpf

Block von Anweisungen, die bei jedem Funktionsaufruf ausgeführt werden

Beschreibung

Funktionen bilden eine abgeschlossene Einheit in einem Formular. So lässt sich ein Formular aus mehreren Funktionen zusammenbauen und damit modularisieren.

Die Parameterliste kann komplett entfallen, falls die Funktion keine Parameter hat. Gibt die Funktion keinen Rückgabewert an das Formular zurück, dann können das Schlüsselwort as und der Datentyp ebenfalls entfallen. Die Zuweisung eines Wertes an eine Variable, die den gleichen Namen hat wie die Funktion selbst, definiert den Rückgabewert.

Wenn Sie bereits Programmiererfahrung haben, werden Sie wahrscheinlich Referenzparameter schon kennen. Wird eine Variable an einen Referenzparameter übergeben, dann hat er nach dem Funktionsaufruf den Wert, den der entsprechende Parameter innerhalb der Funktion hatte. Dadurch ist es möglich, dass eine Funktion mehrere Rückgabewerte an den Aufrufer übergibt.

Zu jedem Funktionskopf muss es ein zugehöriges Funktionsende geben. Der Programmtext zwischen Kopf und Ende bildet den Funktionsrumpf. Innerhalb der Funktion können lokale Variablen definiert werden, die nur im Funktionsrumpf gültig sind.

Beispiel

Function DruckeDaten(Person as String, Datum as Numeric) as Bool

 ...

 DruckeDaten = TRUE

End Function

...

Dim ok as Bool

ok = DruckeDaten( "Meier", Now() )

Function | Funktionsbeginn
DruckeDaten | Name der Funktion
(Person as String, Datum als Numeric) | Parameterliste: Person hat den Datentyp Zeichenkette, Datum hat den Datentyp Zahl.
Bool | Bool kann die Werte wahr oder unwahr annehmen.
End Function | Ende der Funktion
Dim ok as Bool | Anlegen einer Variable vom Typ Bool
ok | Angelegte Variable (Kann vom Benutzer frei gewählt werden)
ok = DruckeDaten ( "Meier", Now() ) | Ok hat danach den Rückgabewert der Funktion "DruckeDaten"

Siehe auch

Identifikator , Parameterliste , Variabelendefinition, Referenzen


While, End While

While Bedingung do

 ...

 Schleifenrumpf

 ...

End While

Erzeugt eine Programmschleife.

Parameter

Bedingung

Schleifenbedingung

Schleifenrumpf

Block von Anweisungen, die bei jedem Schleifendurchlauf ausgeführt werden

Beschreibung

Die Schleife wird solange durchlaufen, bis der Wert des Bool-Ausdrucks False ergibt.

Vorsicht

Es muss sichergestellt sein, dass die Schleife irgendwann beendet wird. Ist dies nicht der Fall, dann handelt es sich um eine Endlos-Schleife und Sie können beim Aufbereiten des Ausdrucks nur noch die Schaltfläche "Abbrechen" betätigen.

Beispiel

Dim n as Numeric

While n < 10 do

 n = n + 1

 ...

End While

Dim n as Numeric | legt die Variable n als numerisch fest und setzt sie gleichzeitig auf 0,00
While n < 10 do | Es wird geprüft, ob die Variable n kleiner als 10 ist, solange das der Fall ist, werden die folgenden Anweisungen durchgeführt, wenn nicht, wird die Schleife übersprungen, das Formular wird nach dem Befehl "End While" weiter abgearbeitet.
n = n + 1 | Zähler hochsetzen, indem die Variable, die zur Schleifenkontrolle und Begrenzung eingesetzt ist, um 1 erhöht wird
... | durchzuführende Anweisung
End While | Ende der Schleife

Siehe auch

Ausdruck


If, Else, End If

If Bedingung then

 ...

 If-Anweisungsblock

 ...

Else

 ...

 Else-Anweisungsblock

 ...

End If

Erzeugt eine bedingte Programmausführung.

Parameter

Bool-Ausdruck

Bedingung

If-Anweisungsblock

Block von Anweisungen, die nur ausgeführt werden, wenn die Bedingung erfüllt wird.

Else-Anweisungsblock - optional

Block von Anweisungen, die ausgeführt werden, falls die Bedingung nicht erfüllt wird.

Beschreibung

Der Else-block kann auch komplett entfallen.

Beispiel

Dim n as Numeric

If n < 10 then

 n = n + 1

 ...

Else

 n = n – 1

 ...

End If

Dim n as Numeric | legt die Variable n als numerisch fest
If n < 10 then | Es wird geprüft, ob die Variable n kleiner als 10 ist, solange das der Fall ist, werden die folgenden Anweisungen durchgeführt, wenn nicht, wird die bedingte Programmausführung übersprungen, das Formular wird nach dem Befehl "Else" weiter abgearbeitet.
n = n + 1 | Zähler hochsetzen, indem die Variable, die zur Bedingungskontrolle und Begrenzung eingesetzt ist, um 1 erhöht wird
.... | durchzuführende Anweisung
Else | Wird die Bedingung nicht erfüllt, soll die nachfolgende Anweisung ausgeführt werden.
n = n - 1 | Zähler vermindern, indem die Variable, die zur Bedingungskontrolle und Begrenzung eingesetzt ist, um 1 vermindert wird
... | durchzuführende Anweisung
End If | Ende der Bedingung

Siehe auch

Ausdruck


Description

Description Description-Identifikator as String-Wert

Setzt den Wert einer Beschreibungsvariablen.

Parameter

Description-Identifikator

Name der Beschreibung

String-Wert

Neuer Wert der Beschreibung

Beschreibung

Beschreibungsvariablen werden direkt in die ausführbare Datei übernommen und können vom Programm ausgelesen werden, ohne die Ausführung des Formulars zu starten.

Diese Beschreibungen werden zum Beispiel verwendet, um bei der Auswahl eines Formulars im jeweiligen Programm eine Beschreibung anzeigen zu können.

Beispiel

Description Form_Description as "Stammdaten drucken"

Description Form_Description | Befehl zur Beschreibung der Formulardatei
as | als
"Stammdaten drucken" | Beschreibung der Formulardatei (Der Name kann vom Benutzer frei definiert werden).

Siehe auch

Namen von Beschreibungen


Allgemeine Druckbefehle

Die allgemeine Befehlsliste beschreibt alle Druckbefehle, die unabhängig vom eingesetzten Lexware Programm gültig sind. Zusätzlich kann jedes Lexware-Programm weitere Befehle zur Verfügung stellen, die zumeist dem Datenaustausch dienen. Diese Befehle werden im Formulareditor nicht automatisch eingefärbt und sollten möglichst nicht verändert werden. Eine Auswahl dieser Befehle ist unter Druckbefehle der Lexware Anwendungen beschrieben.

Konstanten

Allgemeine Konstanten

Ereigniskonstanten

Schriftkonstanten

Farbkonstanten

Stiftkonstanten

Seitenkonstanten

Linienkonstanten

Zellkonstanten

Ereignisse

SetEventHandler

DeleteEventHandler

Ausgabeposition

SetPos

GetPos

GetPosX

GetPosY

Schriftart

SetFont

SetFontName

SetFontSize

SetFontType

SetFontColor

CreateFont

SelectFont

Stifte

SetPen

SetPenType

SetPenColor

CreatePen

SelectPen

Seiteneigenschaften

SetBodyMargin

SetHeaderMargin

SetFooterMargin

PageBreak

Tabulatoren

SetTabs

RemoveTab

RemoveAllTabs

Druckstatus

GetPageNumber

GetAreaLength

GetAreaWidth

Now

GetLineHeight

GetLineHeight

SetPrintDevice

Programm- und Formularinformationen

GetProgramName

GetProgramVersion

GetFormFileName

Formatierung und Typwandlung

FormatNumeric

FormatString

FormatDate

SetFormatNumericOptions

Text

DrawText

DrawTextLn

DrawTextExt

SetWordWrap

Linien

DrawLine

DrawLineExt

Rechtecke

DrawRect

DrawRectExt

Tabellen

CreateCell

DeleteCell

DeleteCellChildren

SetCellParent

DuplicateCell

SetHeaderCell

SetFooterCell

SetCellFlags

SetCellSize

SetCellFont

SetCellBackground

SetCellClip

SetCellBorder

SetCellText

SetCellAlign

SetCellTextBorder

DrawCell

GetCellWidth

GetCellHeight

CreateCellEx

CreateCellTemplate

CreateCellFromTemplate

GetCellByIndex

SelectCellFont

Berechnungen

Modulo

Ausgabe verschiedener Grafikformate

DrawBitmap

DrawGIF

DrawJPG

LXPLAYMETAFILE


Konstanten

Manche Funktionen von DruckNT benötigen Parameter, um die Ausgabeeigenschaften zu setzen. Diese Eigenschaften werden codiert in einem Numeric-Wert angegeben. Zur besseren Lesbarkeit dieser Codierungen werden häufig Konstanten eingesetzt. Die Konstanten gehören fest zu einer Gruppe von Funktionen und können nicht im Zusammenhang mit anderen Funktionen verwendet werden. Eine Ausnahme bildet die Konstante NULL. Sie wird immer dann angegeben, wenn keine Eigenschaften gesetzt werden sollen und dennoch ein Parameter von der jeweiligen Funktion benötigt wird.

Siehe auch

Ereigniskonstanten , Schriftkonstanten , Farbkonstanten , Stiftkonstanten , Seitenkonstanten , Linienkonstanten , Zellkonstanten


Ereigniskonstanten

Die Ereigniskonstanten werden von den Funktionen SetEventHandler und DeleteEventHandler verwendet. Lesen Sie hierzu auch unter , SetEventHandler , DeleteEventHandler .

Folgende Konstanten für Ereignisse existieren

EVENT_PRINT_HEADER

Dieses Ereignis tritt ein, falls die Kopfzeile einer Seite gedruckt werden soll

EVENT_PRINT_FOOTER

Tritt ein, falls die Fußzeile gedruckt werden soll

EVENT_START_PAGE

Tritt zu Beginn einer neuen Seite ein.

EVENT_END_PAGE

Tritt ein, wenn die Bearbeitung einer Seite abgeschlossen ist.

EVENT_BREAK_TABLE

Tritt ein, falls innerhalb einer Tabelle ein Seitenumbruch stattfindet.

EVENT_END_TABLE

Tritt ein, falls die letzte Zeile einer Tabelle gedruckt wurde.

Siehe auch

Konstanten , SetEventHandler , DeleteEventHandler


Schriftkonstanten

Die Schriftkonstanten werden bei den Funktionen SetFont, SetFontType und SetCellFont verwendet.

Folgende Konstanten für Schriften existieren:

FONT_NORMAL

Normale Schrift (nicht Fett und nicht Kursiv)

FONT_BOLD

Fettschrift

FONT_ITALIC

Kursivschrift

FONT_BOLD_ITALIC

fette und kursive Schrift

Siehe auch

Konstanten , SetFont , SetFontType


Farbkonstanten

Die Farbkonstanten werden bei den Funktionen SetFont, SetFontColor, SetPen, SetPenColor, SetCellBorder, SetCellFont, SetCellBackground verwendet.

Folgende Konstanten für Farben existieren:

COLOR_TRANSPARENT

COLOR_BLACK

COLOR_WHITE

COLOR_RED

COLOR_GREEN

COLOR_BLUE

COLOR_LIGHTGREY

Bemerkung

Die Farbkonstanten können dazu verwendet werden, um neue Farben zu mischen. Dazu kann man einfach die Anteile rot, grün und blau an der gewünschten Farbe mit Hilfe der Konstanten aufaddieren. Die Farbe COLOR_TRANSPARENT wird verwendet, um etwas unsichtbar zu machen.

Siehe auch

Konstanten , SetFont , SetFontColor , SetPen , SetPenColor , SetCellBorder , SetCellFont , SetCellBackground


Stiftkonstanten

Die Stiftkonstanten werden bei den Funktionen SetPen, SetPenType und SetCellBorder verwendet. Mit diesen Konstanten können Sie die Darstellung der zu zeichnenden Linien bestimmen.

Folgende Konstanten für Stifte existieren:

PEN_SOLID

Volle Linie

PEN_DOT

gepunktete Linie

PEN_DASH

gestrichelte Linie

PEN_NULL

keine Linie

Weiterhin sind global gültige Identifikatoren für Stifte definiert, die bereits mit CreatePen erzeugt wurden. Diese können von den Befehlen SelectPen und SelectCellBorder verwendet werden.

hNullPen

Identifikator keiner Linie

hSolidPen

Identifikator einer durchgezogenen Linie

hDotPen

Identifikator einer gepunkteten Linie

Fettgedruckte Linien werden über die Punktgröße definiert.

Siehe auch

Konstanten , SetPen , SetPenType , SetCellBorder

SelectPen , SelectCellBorder


Seitenkonstanten

Die Seitenkonstanten werden von der Beschreibung Page_Orientation verwendet.

Folgende Konstanten für die Seite existieren:

PAGE_PORTRAIT

Hochformat der Seite

PAGE_LANDSCAPE

Querformat der Seite

PAGE_STANDARD

Die aktuelle Seitenorientierung des Druckers wird verwendet

Beispiel

Description Page_Orientation as PAGE_LANDSCAPE

Diese Anweisung erfolgt gleich zu Beginn eines Formulars.

Wichtig:

Der Description-Identifikator Page_Orientation wirkt sich nur bei Verwendung des Standarddruckers aus. Werden hingegen mit dem Befehl SetPrintDevice() spezielle Druckereinstellungen aufgerufen, so haben diese Priorität.

Siehe auch

Konstanten , Description , SetPrintDevice()


Linienkonstanten

Linienkonstanten werden von der Funktion DrawHorzLine verwendet.

Folgende Konstanten für Linien existieren

LINE_BOTTOM

Linie unter die momentane Zeile

LINE_TOP

Linie oberhalb der momentanen Zeile

Beispiel

DrawHorzLine(LINE_BOTTOM) Zeichne eine horizontale Linie unter die momentane Zeile

Siehe auch

Konstanten , DrawHorzLine


Zellkonstanten

Zellkonstanten werden von den Funktionen CreateCell, SetCellBorder und SetCellAlign verwendet.

Folgende Konstanten für Zellen existieren:

CELL_ROOT

Die entsprechende Zelle hat in der Hierarchie keinen Vorgänger, bildet also die Wurzel

CELL_BORDER_TOP

oberer Rand

CELL_BORDER_BOTTOM

unterer Rand

CELL_BORDER_LEFT

linker Rand

CELL_BORDER_RIGHT

rechter Rand

CELL_BORDER_ALL

alle Ränder sind gemeint

Cell_TEXT_LEFT

Der Zellentext wird linksbündig ausgerichtet (Standardeinstellung).

Cell_TEXT_RIGHT

Der Zellentext wird rechtsbündig ausgerichtet.

Cell_TEXT_CENTER

Der Zellentext wird zentriert.

CELL_TYPE_DYNHORZ

Die Zelle hat in horizontaler Richtung eine flexible Größe

CELL_TYPE_DYNVERT

Die Zelle hat in vertikaler Richtung eine flexible Größe

CELL_TYPE_HORZ

Die Nachfolger dieser Zelle sind horizontal angeordnet

CELL_TYPE_VERT

Die Nachfolger der Zelle sind vertikal angeordnet

CELL_TYPE_CLIP

Die Ausgabe des Inhalts wird auf die Ausmaße der Zelle beschränkt, der Rest wird abgeschnitten.

CELL_LINE_SEPARATOR

Nach jeder Textzeile innerhalb einer Zelle wird eine Trennlinie gezeichnet. Außerdem werden die Abstände von den Zellrändern eingehalten.

Cell_Word_Wrap

Der Zellentext wird durch Zeilenumbruch an die feste Breite der Zelle angepasst.

Nur wirksam, wenn das Flag Cell_TYPE_DYNHORZ nicht gesetzt ist !


SetEventHandler

SetEventHandler(eventID as Numeric, handlerFunc as Pointer)

Setzen einer Funktion zur Ereignisbehandlung.

Parameter

eventID

ID des Ereignisses. Mögliche Werte sind die vordefinierten Ereigniskonstanten , z.B. Event_Print_Header,....

handlerFunc

Funktion, die bei Eintritt des Ereignisses aufgerufen wird

Beschreibung

Ereignisse werden hauptsächlich beim Drucken von Kopf- und Fußzeilen verwendet. In diesem Fall tritt ein Ereignis EVENT_PRINT_HEADER bzw. EVENT_PRINT_FOOTER ein.

Beispiel

Function OnPrintHeader () Definition einer Kopfzeile

TL ("Hallo") Inhalt der Kopfzeile

End Function Ende der Funktion

SetEventHandler (EVENT_PRINT_HEADER, OnPrintHeader)

Die Funktion OnPrintHeader wird als Funktion zur Ausgabe der Kopfzeile definiert.

Wird im Formular diese Funktion nicht hinterlegt, erfolgt kein Ausdruck der Kopfzeile.

Function OnPrintFooter () Definition einer Fußzeile

TL ("Müller GmbH") Inhalt der Fußzeile

End Function Ende der Funktion

SetEventHandler (EVENT_PRINT_FOOTER, OnPrintFooter) Die Funktion OnPrintFooter

wird als Funktion zur Ausgabe der Fußzeile definiert.

Wird im Formular diese Funktion nicht hinterlegt, erfolgt kein Ausdruck der Kopfzeile.

Siehe auch

Ereigniskonstanten , DeleteEventHandler


DeleteEventHandler

DeleteEventHandler(eventID as Numeric)

Löscht die Zuweisung einer Funktion zur Bearbeitung eines Ereignisses.

Parameter

eventID

ID des Ereignisses. Mögliche Werte sind die vordefinierten Ereigniskonstanten , z.B. Event_Print_Header,....

Beispiel

DeleteEventHandler (EVENT_PRINT_HEADER)

DeleteEventHandler (EVENT_PRINT_FOOTER)

Die Zuordnung des EVENT_PRINT_HEADER wird aufgehoben (Kopfzeile).

Die Zuordnung des EVENT_PRINT_FOOTER wird aufgehoben (Fußzeile).

Siehe auch

Ereigniskonstanten , SetEventHandler


CellType

Dieser Datentyp ist eigentlich kein eigenständiger Datentyp, sondern ein Numeric-Wert. Allerdings vereinfacht die Einführung eines speziellen Typs für Zell-Identifikatoren die Lesbarkeit des Formulars.


CellTemplateType

Dieser Datentyp ist eigentlich kein eigenständiger Datentyp, sondern ein Numeric-Wert. Allerdings vereinfacht die Einführung eines speziellen Typs für Zelltemplate-Identifikatoren die Lesbarkeit des Formulars.


CreateCell

CreateCell(width as Numeric, height as Numeric, flags as Numeric) as CellType

Erzeugt eine neue Zelle.

Parameter

width

minimale Breite der Zelle

height

minimale Höhe der Zelle

flags

Parameter zum setzen von Eigenschaften

Rückgabewert

ID der neuen Zelle

Beschreibung

Eine Tabelle wird aus mehreren Zeilen zusammengebaut, die in ihrer Struktur identisch sind. Eine solche Zeile ist eine Ansammlung von Zellen, die horizontal und vertikal angeordnet sein können. Zur eindeutigen Anordnung der Zellen werden diese in einer Hierarchie strukturiert. Eine Zelle kann mehrere Nachfolger haben. Diese Nachfolger werden entweder vertikal oder horizontal angeordnet.

Der Parameter flags bestimmt die Eigenschaften der Zelle. Er kann aus mehreren Konstanten zusammengesetzt sein. Dazu werden die Konstanten mit einer Addition verknüpft. Folgende Konstanten sind für diesen Parameter erlaubt:

CELL_TYPE_DYNHORZ

Die Zelle hat in horizontaler Richtung eine flexible Größe

CELL_TYPE_DYNVERT

Die Zelle hat in vertikaler Richtung eine flexible Größe

CELL_TYPE_HORZ

Die Nachfolger dieser Zelle sind horizontal angeordnet

CELL_TYPE_VERT

Die Nachfolger der Zelle sind vertikal angeordnet

CELL_TYPE_CLIP

Die Ausgabe des Inhalts wird auf die Ausmaße der Zelle beschränkt. Der Rest wird abgeschnitten

CELL_LINE_SEPARATOR

Nach jeder Textzeile innerhalb einer Zelle wird eine Trennlinie gezeichnet. Außerdem werden die Abstände von den Zellrändern eingehalten.

CELL_WORD_WRAP

ist nur erlaubt, falls die Zelle eine feste Breite hat. Der Text wird am rechten Rand umgebrochen. Die Trennstelle ist immer ein Leerzeichen. Das heißt es werden nur ganze Wörter umgebrochen. Ein automatischer Zeilenumbruch funktioniert nur bei linksbündig ausgerichteten Zellen

Beispiel

Dim c as CellType

c = CreateCell(300, 200, CELL_TYPE_DYNVERT + CELL_TYPE_HORZ + CELL_TYPE_WORD_WRAP)

Dim c as CellType | Definiert c als Zelle
c = CreateCell | Erzeugt die Zelle
300, | minimale Breite der Zelle
200, | minimale Höhe der Zelle
CELL_TYPE_DYNVERT | Die Zelle soll in vertikaler Richtung eine flexible Größe haben
CELL_TYPE_HORZ | Die Kinder dieser Zelle sind horizontal angeordnet

Dim CT_titel as CellType

CT_titel = CreateCell(2640, 0, CELL_TYPE_HORZ + CELL_TYPE_DYNVERT)

Dim CT_titel as CellType | Definiert CT_titel als Zelle
CT_titel = CreateCell | Erzeugt die Zelle
2640, | minimale Breite der Zelle
0, | minimale Höhe der Zelle
CELL_TYPE_HORZ | Die Kinder dieser Zelle sind horizontal angeordnet
CLL_TYPE_DYNVERT | Die Zelle soll in vertikaler Richtung eine flexible Größe haben

Siehe auch

CreateCellEx , Zellkonstanten , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


CreateCellEx

CreateCellEx(parent as CellType, width as Numeric, height as Numeric, flags as Numeric, text as String, font as FontType, align as Numeric, color as Numeric, pLeft as PenType, pTop as PenType, pRight as PenType, pBottom as PenType, pSep as PenType, bLeft as Numeric, bTop as Numeric, bRight as Numeric, bBottom as Numeric) as CellType

Erzeugt eine neue Zelle mit allen möglichen Attributen.

Parameter

parent

Vater der Zelle

width

minimale Breite der Zelle

height

minimale Höhe der Zelle

flags

Parameter zum Setzen von Eigenschaften

text

Inhalt der Zelle

font

Schriftart

align

Ausrichtung des Textes

color

Hintergrund der Zelle

pLeft, pTop, pRight, pBottom, pSep

Liniearten der Zellränder und Zwischenlinien

bLeft, bTop, bRight, bBottom

Abstände des Textes zu den Rändern

Rückgabewert

ID der neuen Zelle

Beschreibung

Siehe Beschreibung zu CreateCell und den anderen entsprechenden Funktionen.


CreateCellFromTemplate

CreateCellFromTemplate(id as CellTemplateType , parent as CellType , text as String) as CellType

Erzeugt eine Zelle anhand einer Vorlage.

Parameter

id

Vorlagen ID

parent

Vater Zelle

text

Inhalt der Zelle

Rückgabewert

ID der neuen Zelle

Beschreibung

Die Vorlagen ID muss zuvor mit CreateCellTemplate erzeugt worden sein.

Beispiel

CreateCellFromTemplate (CT_PNR, CT_TITLE, "123")

CreateCellFromTemplate | Erzeugt die Zelle anhand der
CT_PNR | zuvor erzeugten Vorlage
CT_TITLE | Vaterzelle
"123" | Inhalt der Zelle

Siehe auch

CreateCell , CreateCellTemplate , Zellkonstanten , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , CellTemplateType , GetCellWidth , GetCellHeight


CreateCellTemplate

CreateCellTemplate(width as Numeric, height as Numeric, flags as Numeric, font as FontType, align as Numeric, color as Numeric, pLeft as PenType, pTop as PenType, pRight as PenType, pBottom as PenType, pSep as PenType, bLeft as Numeric, bTop as Numeric, bRight as Numeric, bBottom as Numeric) as CellTemplateType

Erzeugt eine Vorlage für Zellen.

Parameter

width

minimale Breite der Zelle

height

minimale Höhe der Zelle

flags

Parameter zum Setzen von Eigenschaften

font

Schriftart

align

Ausrichtung des Textes

color

Hintergrund der Zelle

pLeft, pTop, pRight, pBottom, pSep

Linienarten der Zellränder und Zwischenlinien

bLeft, bTop, bRight, bBottom

Abstände des Textes zu den Rändern

Rückgabewert

ID der neuen Zellvorlage

Beschreibung

Eine Vorlage definiert alle Eigenschaften einer Zelle. Anhand einer Vorlage lassen sich Zellen erzeugen, die alle die gleichen Eigenschaften besitzen. Zellenvorlagen sollen die Definition von Zellen verkürzen. Neue Zellen werden mit CreateCellFromTemplate erzeugt.

Siehe auch Beschreibung zu CreateCell und den anderen entsprechenden Funktionen.


GetCellByIndex

GetCellByIndex(id as CellType, index as Numeric) as CellType

Ermitteln eines Kindes einer Zelle anhand dessen Index.

Parameter

id

ID der Zelle

index

Position der Zelle in der Elternzelle

Beschreibung

Eine Tabelle wird aus hierarchisch angeordneten Zellen zusammengesetzt. Durch GetCellByIndex kann man auf die einzelnen Zellen innerhalb einer Vaterzelle zugreifen.

Beispiel

CT_PNR = GetCellByIndex (CT_TITLE, 1)

CT_PNR | Nimmt die Kinderzelle auf
GetCellByIndex | Befehl zum Ermitteln einer Kindzelle
CT_Title, 1 | Index der Vaterzelle davon die erste (1) Zelle = Kindzelle

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


DeleteCell

DeleteCell(id as CellType, delChildren as Bool)

Löschen einer Zelle.

Parameter

id

ID der Zelle

delChildren

TRUE, falls die untergeordneten Zellen ebenfalls gelöscht werden sollen.

Beispiel

DeleteCell (CT_TITLE, TRUE)

Löschen der Definition der Zelle CT_TITLE.

True bedeutet, dass die zugehörigen Definitionen der Kinderzellen mit gelöscht werden.

DeleteCell (CT_TITLE, FALSE)

Löschen der Definition der Zelle CT_TITLE

False bedeutet, dass die zugehörigen Definitionen der Kinderzellen nicht mit gelöscht werden.

Siehe auch

Zellkonstanten , CreateCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


DeleteCellChildren

DeleteCellChildren(id as CellType)

Löschen aller untergeordneten Zellen einer Zelle.

Parameter

id

ID der Zelle

Beispiel

DeleteCellChildren (CT_PNR)

Die untergeordnete Zelle (Kindzelle) CT_PNR wird mit Ihrer Definition gelöscht.

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


DrawCell

DrawCell(id as CellType, continue as Bool)

Zeichnen einer Zelle und deren Nachfolger in der Hierarchie.

Parameter

id

ID der Zelle

continue

TRUE, wenn die Tabelle mit dieser Zelle nicht beendet ist.

Beschreibung

In den allermeisten Fällen werden Zellhierarchien mit nur einer Wurzelzelle definiert. Durch das Zeichnen dieser Zelle werden auch die Nachfolger gezeichnet und somit die ganze Hierarchie. Das Zeichen continue wird dazu verwendet, um das Ende der Tabelle zu erkennen und damit den Tabellenfuß anzuhängen.

Beispiel

DrawCell (CT_TITLE, FALSE)

DrawCell | Befehl zum Zeichnen einer Zelle und deren Kinder
CT_TITLE | Zelle
FALSE | Das Tabellenende ist erreicht, die Fußzeile der Tabelle wird gedruckt.
TRUE | Das Tabellenende ist nicht erreicht, die Fußzeile der Tabelle wird nicht gedruckt.

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , CellType , GetCellWidth , GetCellHeight


DuplicateCell

DuplicateCell (id as CellType) as Numeric

Duplizieren einer bereits vorhandenen Zelle.

Parameter

id

ID der Zelle

Rückgabewert

ID der neuen Zelle

Beschreibung

Durch das Erstellen einer Kopie einer Zelle können bereits definierte Formatierungen in neue Zellen übernommen werden. In Ihrem Formular können Sie also Zellen als Vorlagen definieren und immer wieder Kopien erstellen, um erneute Formatierungen zu ersparen.

Beispiel

CT_Title2 = DuplicateCell (CT_Title)

CT_Title2 | Name der neuen Zelle
DuplicateCell | Duplizierungsanweisung (Kopieranweisung)
CT_Title | Die bereits definierten Formatierungen dieser Zelle soll in CT_Title2 dupliziert werden.

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


GetCellHeight

GetCellHeight(id as CellType) as Numeric

Ermitteln der Höhe einer Zelle.

Parameter

id

ID der Zelle

Rückgabewert

Höhe in 0,1mm Einheiten

Beschreibung

Die Höhe kann von eingestellten Höhe abweichen, falls der Parameter CELL_TYPE_DYNVERT angegeben wurde.

Beispiel

GetCellHeight (CT_TITLE)

If (GetCellHeight (CT_TITLE) < 300) then

.... (z.B. zu klein)

End If

GetCellHeight | Befehl zum Ermitteln der Höhe der nachfolgenden Zelle
CT_TITLE | Zelle, deren Höhe ermittelt werden soll
IF | Bedingte Programmausführung
GetCellHeight (CT_TITLE) < 300 | Ist die Zelle CT_TITLE kleiner 300,
then | dann führe
.... | diese Anweisung aus.
End IF | Beenden der Bedingung.

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth


GetCellWidth

GetCellWidth(id as CellType) as Numeric

Ermitteln der Breite einer Zelle.

Parameter

id

ID der Zelle

Rückgabewert

Breite in 0,1mm Einheiten

Beschreibung

Die Breite kann von der eingestellten Breite abweichen, falls der Parameter CELL_TYPE_DYNHORZ angegeben wurde.

Beispiel

GetCellWidth (CT_TITLE)

If (GetCellWidth (CT_TITLE) < 200 ) then

..... (z.B. Zelle ist zu klein)

End If

GetCellWidth | Befehl zum Ermitteln der Breite der nachfolgenden Zelle
CT_TITLE | Zelle, deren Breite ermittelt werden soll
IF | Bedingte Programmausführung
GetCellWidth (CT_TITLE) <200 | Ist die Zelle CT_TITLE kleiner 200,
then | dann führe
.... | diese Anweisung aus.
End IF | Beenden der Bedingung.

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellHeight


SetCellAlign

SetCellAlign(id as CellType, align as Numeric)

Setzen der Ausrichtung von Text innerhalb der Zelle.

Parameter

id

ID der Zelle

align

neue Ausrichtung von Text in der Zelle. Möglich sind CELL_TEXT_LEFT, CELL_TEXT_CENTER, CELL_TEXT_RIGHT

Beispiel

SetCellAlign (CT_TITLE, CELL_TEXT_CENTER)

SetCellAlign | Befehl zur Ausrichtung des Textes innerhalb einer Zelle
CT_TITLE | Zelle, in welcher der Text ausgerichtet werden soll
CELL_TEXT_CENTER | Der Text soll in der Zelle zentriert ausgerichtet werden.

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


SetCellBackground

SetCellBackground(id as CellType, color as Numeric)

Setzt die Hintergrundfarbe einer Zelle.

Parameter

id

ID der Zelle

color

Hintergrundfarbe

Beispiel

SetCellBackground (CT_TITLE, COLOR_WHITE)

SetCellBackground | Befehl
CT_TITLE, COLOR_WHITE | In dieser Zelle soll der Hintergrund weiß dargestellt werden.

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


SetCellBorder

SetCellBorder(id as CellType, which as Numeric, width as Numeric, type as Numeric, color as Numeric)

Setzt die Eigenschaften einer Linie einer bestimmten Zelle.

Parameter

id

ID der Zelle

which

gibt an, welche Linie geändert werden soll. Möglich sind CELL_BORDER_LEFT, CELL_BORDER_RIGHT, CELL_BORDER_TOP, CELL_BORDER_BOTTOM, CELL_LINE_SEPARATOR

width

Stiftbreite

type

PEN_SOLID, PEN_DOT, PEN_DASH, PEN_NULL

color

Farbe des Stifts

Beschreibung

Ein Wert PEN_NULL für den type Parameter erzeugt einen unsichtbaren Stift. Dieser kann dazu verwendet werden, eine Linie verschwinden zu lassen. Eine Stiftbreite von 0 erzeugt eine Haarlinie.

Beispiel

SetCellBorder (CT_TITLE, CELL_BORDER_BOTTOM, 0, PEN_DOT, COLOR_BLACK)

SetCellBorder | Befehl
CT_TITLE | Zelle
CELL_BORDER_BOTTOM | Die untere Linie der Zelle soll wie folgt geändert werden
0 | Stiftbreite soll 0 = Haarlinie werden
PEN_DOT | Die Linie soll gepunktet sein
COLOR_BLACK | Die Farbe der Linie soll schwarz sein

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


SelectCellBorder

SelectCellBorder(id as CellType, which as Numeric, pen as PenType )

Setzt die Eigenschaften einer Linie einer bestimmten Zelle.

Parameter

id

ID der Zelle

which

gibt an, welche Linie geändert werden soll. Möglich sind

CELL_BORDER_LEFT, CELL_BORDER_RIGHT, CELL_BORDER_TOP, CELL_BORDER_BOTTOM, CELL_LINE_SEPARATOR

pen

Identifikator eines Stifts

Beschreibung

Siehe Beschreibung unter CreatePen .

Beispiel

SelectCellBorder (CT_TITLE, CELL_BORDER_BOTTOM, hSolidPen)

SelectCellBorder | Befehl
CT_TITLE | Zelle
CELL_BORDER_BOTTOM | Die untere Linie der Zelle soll wie folgt geändert werden
hSolidPen | Identifikator einer durchgezogenen Linie

Siehe auch

CreatePen , Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


SetCellClip

SetCellClip(id as CellType, clip as Bool)

Schaltet das Clipping für eine Zelle ein oder aus.

Parameter

id

ID der Zelle

clip

True, falls das Clipping eingeschaltet werden soll

Beschreibung

Bei Zellen, die mit einer fixen Breite definiert wurden, wird der Zelleninhalt, der länger ist als die definierte Breite, abgeschnitten. Mit diesem Befehl können Sie das Abschneiden des Zelleninhaltes aufheben. Folge davon ist, dass weitere Zellen die folgen, überschrieben werden.

Beispiel

SetCellClip (CT_PNR, TRUE)

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


SetCellSize

SetCellSize(id as CellType, width as Numeric, heigth as Numeric)

Setzt die Mindestgröße einer Zelle. Die tatsächliche Zellgröße wird durch die Zellenflags beeinflusst, die bei CreateCell und SetCellFlags gesetzt werden ( z.B. CELL_TYPE_DYNHORZ ).

Parameter

id

ID der Zelle

width

Breite der Zelle

heigth

Höhe der Zelle

Beispiel

SetCellSize (CT_TITLE, 200, 300)

SetCellFont | Befehl
CT_TITLE | Zelle
200 | Breite 2cm
300 | Höhe 3cm

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellFlags , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


SetCellFlags

SetCellFlags(id as Numeric, flags as Numeric)

Setzt die Eigenschaften (vgl. CreateCell ) einer Zelle neu.

Parameter

id

ID der Zelle

Flags

Name des Kennzeichens

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


SetCellFont

SetCellFont(id as CellType, name as String, size as Numeric, type as Numeric, color as Numeric)

Setzt die Schriftart einer Zelle.

Parameter

id

ID der Zelle

font

Name der Schrift

size

Schriftgröße in Punkt

type

FONT_NORMAL, FONT_BOLD, FONT_ITALIC, FONT_BOLD_ITALIC

color

Textfarbe

Beispiel

SetCellFont (CT_TITLE, "Arial", 8, FONT_BOLD, COLOR_BLACK)

SetCellFont | Befehl
CT_TITLE | Zelle
"Arial" | Name der Schriftart
8 | Schriftgröße
FONT_BOLD | Schrifttyp (Fettschrift)
COLOR_BLACK | Schriftfarbe

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


SelectCellFont

SelectCellFont(id as CellType, font as FontType )

Setzt die Schriftart einer Zelle.

Parameter

id

ID der Zelle

font

Identifikator der Schrift

Beispiel

SelectCellFont (CT_TITLE, ARIAL_8)

SetCellFont | Befehl
CT_TITLE | Zelle
ARIAL_8 | Name der Schriftart

Die Variable für den Font ARIAL_8 ist von der Firma Lexware bereits definiert und wird mit ausgeliefert.

Siehe auch

CreateFont , Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


SetCellParent

SetCellParent(id as CellType, parent as CellType)

Setzen des Vaters einer Zelle.

Parameter

id

ID der Zelle

parent

Vater der Zelle

Beschreibung

Eine Tabelle wird aus hierarchisch angeordneten Zellen zusammengesetzt. Durch SetCellParent kann man die Hierarchie aufbauen. Allerdings kann jede Zelle nur einen Vater besitzen.

Beispiel

CT_pnr = CreateCell(150, 0, CELL_TYPE_DYNVERT)

SetCellParent(CT_pnr, CT_titel)

Dim CT_pnr as CellType | Definiert CT_pnr als Zelle
CT_pnr = CreateCell | Erzeugt die Zelle
150, | minimale Breite der Zelle
0, | minimale Höhe der Zelle
CLL_TYPE_DYNVERT | Die Zelle soll in vertikaler Richtung eine flexible Größe haben
SetCellParent | Setzt den Vater der Zelle
CT_pnr, CT_titel | von der Zelle CT_pnr ist die Zelle CT_titel die Vaterzelle

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


SetCellText

SetCellText(id as CellType, text as String)

Setzen des Textes einer Zelle.

Parameter

id

ID der Zelle

text

neuer Text der Zelle

Beschreibung

Es besteht die Möglichkeit, Zeilenumbrüche innerhalb der Zeichenkette anzugeben (Steuerzeichen \n). Ist für eine Zelle mit fester Breite die Eigenschaft CELL_WORD_WRAP definiert, dann findet ein automatisches Einfügen von Zeilenumbrüchen statt, falls die Textbreite die Zellenbreite überschreitet.

Beispiel

SetCellText (CT_TITLE, "Titel")

SetCellText | Befehl, um der Zelle einen Text zu hinterlegen
CT_TITLE | Name der Zelle
"Titel" | Text der Zelle

SetCellText (CT_PNR, Get ("P", 1)

SetCellText | Befehl, um der Zelle einen Text zu hinterlegen
CT_PNR | Name der Zelle
Get ("P" , 1) | Text der Zelle. Hier wird auf die Variable eines Lexware Programms zugegriffen.

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


SetCellTextBorder

SetCellTextBorder(id as CellType, left as Numeric, top as Numeric, right as Numeric, bottom as Numeric)

Setzen des inneren Abstands des Textes vom Zellenrand.

Parameter

id

ID der Zelle

left

linker Abstand

top

oberer Abstand

right

rechter Abstand

bottom

unterer Abstand

Beschreibung

Die Einheit für den Abstand beträgt 0,1 mm.

Beispiel

SetCellTextBorder (CT_TITLE, 5, 5, 5, 5)

SetCellTextBorder | Befehl zum Setzen des inneren Abstands des Textes vom Zellenrand
CT_TITLE | Zelle für die der Abstand gelten soll
5, | 0,5 mm Abstand vom linken Zellenrand
5, | 0,5 mm Abstand vom oberen Zellenrand
5, | 0,5 mm Abstand vom rechten Zellenrand
5 | 0,5 mm Abstand vom unteren Zellenrand

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , DrawCell , CellType , GetCellWidth , GetCellHeight


SetHeaderCell

SetHeaderCell (id as CellType)

Setzen der aktuellen Kopfzeile einer Tabelle.

Parameter

id

ID des neuen Kopfes

Beschreibung

Der Kopf einer Tabelle wird jeweils zu Beginn einer neuen Tabelle und nach einem Seitenumbruch innerhalb einer Tabelle automatisch ausgegeben.

Beispiel

SetHeaderCell (CT_TITLE)

Setzt die zuvor definierte Vaterzelle CT_TITLE als aktuelle Kopfzeile einer Tabelle.

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetFooterCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


SetFooterCell

SetFooterCell (id as CellType)

Setzen der aktuellen Fußzeile einer Tabelle.

Parameter

id

ID des neuen Fußes

Beschreibung

Der Fuß einer Tabelle wird jeweils am Ende einer Tabelle und vor einem Seitenumbruch innerhalb einer Tabelle automatisch ausgegeben. Das Ende der Tabelle wird anhand des continue-Zeichens des DrawCell-Befehls erkannt.

Beispiel

SetFooterCell (CT_SUMME)

Setzt die zuvor definierte Zelle CT_SUMME als aktuelle Fußzeile einer Tabelle.

Siehe auch

Zellkonstanten , CreateCell , DeleteCell , DeleteCellChildren , SetCellParent , DuplicateCell , SetHeaderCell , SetCellFont , SetCellBackground , SetCellClip , SetCellBorder , SetCellText , SetCellAlign , SetCellTextBorder , DrawCell , CellType , GetCellWidth , GetCellHeight


FontType

Dieser Datentyp ist eigentlich kein eigenständiger Datentyp, sondern ein Numeric-Wert. Allerdings vereinfacht die Einführung eines speziellen Typs für Font-Identifikatoren die Lesbarkeit des Formulars.


CreateFont

CreateFont(font as String, size as Numeric, type as Numeric, color as Numeric) as FontType

Erzeugen einer Schriftart.

Parameter

font

Name der Schrift

size

Schriftgröße in Punkt

type

eine Kombination der Schriftkonstanten FONT_NORMAL, FONT_BOLD, FONT_ITALIC, FONT_BOLD_ITALIC

color

eine Farbkonstante alsTextfarbe, z.B. COLOR_BLACK

Beschreibung

Diese Funktion liefert einen FontType -Wert zurück. Mit Hilfe dieses Wertes kann die Funktion SelectFont den aktuellen Font setzen.

Beispiel

Dim f as FontType = CreateFont ("Arial", 12, FONT_NORMAL, COLOR_BLACK)

SelectFont (f)

Dim f as FontType | Definieren der Variable f als Identifikator
CreateFont | Erzeugen des Fonts
Arial | Schriftart (font)
12 | Schriftgröße
FONT_NORMAL | Schrifttyp
COLOR_BLACK | Schriftfarbe
SelectFont | Befehl
f | Identifikator

Siehe auch

SelectFont , Schriftkonstanten , Farbkonstanten


SelectFont

SelectFont(id as FontType )

Setzt die aktuelle Schriftart anhand eines Identifikators für eine Schriftart.

Parameter

id

Identifikator der Schrift

Beschreibung

Der Identifikator muss zuvor mit CreateFont erzeugt worden sein.

Beispiel

Dim f as FontType = CreateFont ("Arial", 12, FONT_NORMAL, COLOR_BLACK)

SelectFont (f)

Dim f as FontType | Definieren von f als Variable für einen Font
CreateFont ...... | Erzeugen des Fonts
SelectFont | Befehl zur Auswahl des Fonts
f | Fontvariable

Siehe auch

CreateFont


SetFont

SetFont(font as String, size as Numeric, type as Numeric, color as Numeric)

Setzt die aktuelle Schriftart. Soll innerhalb eines Formulars die Schriftart gewechselt werden, so muss eine neue Schriftanweisung erfolgen.

Parameter

font

Name der Schrift

size

Schriftgröße in Punkt

type

eine Kombination der Schriftkonstanten FONT_NORMAL, FONT_BOLD, FONT_ITALIC, FONT_BOLD_ITALIC

color

eine Farbkonstante alsTextfarbe, z.B. COLOR_BLACK

Beispiel

SetFont("Arial", 14, FONT_BOLD, COLOR_BLACK)

"Arial" | Name der Schrift
14 | Größe der Schrift
FONT_BOLD | Fettschrift
COLOR_BLACK | Farbe schwarz

Siehe auch

SetFontName , SetFontSize , SetFontType , SetFontColor , Schriftkonstanten , Farbkonstanten


SetFontColor

SetFontColor(color as Numeric)

Setzen der Textfarbe.

Parameter

color

Textfarbe

Beispiel

SetFontColor (COLOR_BLUE)

Wurde zuerst die Schriftart ("Arial", 12, FONT_NORMAL, COLOR_BLACK ) angegeben so wird nun die Schriftfarbe COLOR_BLACK durch COLOR_BLUE ersetzt. Die Schriftart, die Schriftgröße und der Schrifttyp bleiben gleich.

Siehe auch

SetFont , SetFontName , SetFontSize , SetFontType , Farbkonstanten


SetFontName

SetFontName(font as String)

Setzen der Schriftfamilie.

Parameter

font

Name der Schrift

Beschreibung

Gewechselt wird nur die Schriftfamilie. Die Attribute der Schrift, wie Farbe und Typ, bleiben erhalten

Beispiel

SetFontName ("Garamond")

Wurde zuerst die Schriftart ("Arial", 12, FONT_NORMAL, COLOR_BLACK ) angegeben so wird nun "Arial" durch "Garamond" ersetzt. Die Größe der Schrift, der Schrifttyp und die Schriftfarbe bleiben gleich.

Siehe auch

SetFont , SetFontSize , SetFontType , SetFontColor


SetFontSize

SetFontSize(size as Numeric)

Setzen der Schriftgröße

Parameter

size

Schriftgröße in Punkt

Beispiel

SetFontSize (14)

Wurde zuerst die Schriftart ("Arial", 12, FONT_NORMAL, COLOR_BLACK ) angegeben so wird nun die Schriftgröße 12 durch 14 ersetzt. Die Schriftart, der Schrifttyp und die Schriftfarbe bleiben gleich.

Siehe auch

SetFont , SetFontName , SetFontType , SetFontColor


SetFontType

SetFontType(type as Numeric)

Setzen des Schrifttyps.

Parameter

type

FONT_NORMAL, FONT_BOLD, FONT_ITALIC, FONT_BOLD_ITALIC

Beispiel

SetFontType (FONT_BOLD)

Wurde zuerst die Schriftart ("Arial", 12, FONT_NORMAL, COLOR_BLACK ) angegeben so wird nun der Schrifttyp FONT_NORMAL durch FONT_BOLD (Fettdruck) ersetzt. Die Schriftart, die Schriftgröße und die Schriftfarbe bleiben gleich.

Siehe auch

SetFont , SetFontName , SetFontSize , SetFontColor , Schriftkonstanten


SetBodyMargin

SetBodyMargin(left as Numeric, top as Numeric, right as numeric, bottom as Numeric)

Setzen der Ränder des Seitenrumpfes.

Parameter

left

Abstand von linken physikalischen Seitenrand

top

Abstand vom oberen physikalischen Seitenrand

right

Abstand vom rechten physikalischen Seitenrand

bottom

Abstand vom unteren physikalischen Seitenrand

Beschreibung

Die Werte werden in 0,1 mm Einheiten angegeben. Gerechnet wird der Abstand vom physikalischen Rand der Seite. Wichtig ist, die Werte in der richtigen Reihenfolge zu hinterlegen.

Beispiel

SetBodyMargin(110, 310, 140, 280)

SetBodyMargin | Befehl
(110, | 11,0 mm vom linken Seitenrand
310, | 31,0 mm vom oberen Seitenrand
140, | 14,0 mm vom rechten Seitenrand
280) | 28,0 mm vom unteren Seitenrand

Siehe auch

SetHeaderMargin , SetFooterMargin


SetHeaderMargin

SetHeaderMargin(left as Numeric, top as Numeric, right as numeric, height as Numeric)

Setzen der Ausmaße der Kopfzeile. Mit dieser Funktion definieren Sie, wo und wie hoch die Kopfzeile ausgedruckt wird.

Parameter

left

Abstand von linken physikalischen Seitenrand

top

Abstand vom oberen physikalischen Seitenrand

right

Abstand vom rechten physikalischen Seitenrand

height

Höhe der Kopfzeile

Beschreibung

Die Werte werden in 0,1 mm Einheiten angegeben. Gerechnet wird der Abstand vom physikalischen Rand der Seite. Wichtig ist, die Werte in der richtigen Reihenfolge zu hinterlegen.

Beispiel

SetHeaderMargin (110, 90, 140, 150)

SetHeaderMargin | Befehl
(110, | 11,0 mm vom linken Seitenrand
90, | 9,0 mm vom oberen Seitenrand
140, | 14,0 mm vom rechten Seitenrand
150) | 15,0 mm Höhe der Kopfzeile

Siehe auch

SetBodyMargin , SetFooterMargin


SetFooterMargin

SetFooterMargin(left as Numeric, top as Numeric, right as numeric, height as Numeric)

Setzen der Ausmaße der Fußzeile.

Parameter

left

Abstand von linken physikalischen Seitenrand

top

Abstand vom unteren physikalischen Seitenrand

right

Abstand vom rechten physikalischen Seitenrand

height

Höhe der Fußzeile

Beschreibung

Die Werte werden in 0,1 mm Einheiten angegeben. Gerechnet wird der Abstand vom physikalischen Rand der Seite.

Vorsicht

Der Parameter top wird bewusst als Abstand vom unteren Rand definiert, um von der Seitenorientierung unabhängig zu bleiben. Wichtig ist, die Werte in der richtigen Reihenfolge zu hinterlegen.

Beispiel

SetFooterMargin (110, 180, 140, 100)

SetHeaderMargin | Befehl
(110, | 11,0 mm vom linken Seitenrand
180, | 18,0 mm vom unteren Seitenrand
140, | 14,0 mm vom rechten Seitenrand
100) | 10,0 mm Höhe der Fußzeile

Siehe auch

SetBodyMargin , SetHeaderMargin


PageBreak

PageBreak()

Auslösen eines Seitenumbruchs.

Beschreibung

Mit dieser Funktion können Sie einen Seitenwechsel im Formular bestimmen.


SetWordWrap

SetWordWrap (wrap as BOOL)

Gibt an, ob ein Text am Ende einer Zeile umgebrochen oder abgeschnitten wird.

Parameter

Wrap TRUE Text wird umgebrochen

FALSE Text wird abgeschnitten

Standardeinstellung ist false !

Abkürzungen für DrawText-Funktionen , DrawText , SetBodyMargin , SetHeaderMargin , SetFooterMargin , SetFont


Abkürzungen für DrawText-Funktionen

Folgende Abkürzungen für die DrawText-Funktionen existieren

T - DrawText

Ausgabe eines Strings ohne anschließenden Zeilenwechsel

TL - DrawTextLn

Ausgabe eines Strings mit anschließendem Zeilenwechsel

LF - DrawTextLn("")

Zeilenvorschub

Beispiel

T("Hallo")

LF

hat das gleiche Ergebnis wie

TL("Hallo")

Siehe auch

DrawText , DrawTextLn , DrawTextExt


DrawText

DrawText(text as String)

Gibt an der aktuellen Position einen Text aus.

Parameter

text

auszugebender Text

Beschreibung

Die aktuelle Ausgabeposition wird entsprechend verschoben.

Beispiel

DrawText ("Hallo")

Siehe auch

Abkürzungen für DrawText-Funktionen , DrawTextLn , DrawTextExt , SetWordWrap , SetFont


DrawTextLn

DrawTextLn(text as String)

Gibt einen Text an der aktuellen Position aus und führt einen Zeilenvorschub aus.

Parameter

text

auszugebender Text

Beispiel

DrawTextLn ("Hallo")

Siehe auch

Abkürzungen für DrawText-Funktionen , DrawText , DrawTextExt , SetWordWrap , SetFont


DrawTextExt

DrawTextExt(x as Numeric, y as Numeric, text as String)

Gibt einen Text an einer bestimmten Position aus.

Parameter

x

horizontale Position

y

vertikale Position

text

auszugebender Text

Beschreibung

Die Positionsparameter haben die Einheit 0,1 mm und werden ab dem eingestellten Seitenrand gerechnet.

Beispiel

DrawTextExt (1000, 2000, "Müller")

An der Stelle 1000, 2000 (auf ein Koordinatensystem bezogen) wird der Text "Müller" gezeichnet.

Siehe auch

Abkürzungen für DrawText-Funktionen , DrawText , SetBodyMargin , SetHeaderMarginSetFooterMargin , SetWordWrap , SetFont


DrawLine

DrawLine(x as Numeric, y as Numeric)

Zeichnet eine Linie mit dem aktuell eingestellten Stift von der aktuellen Position zur angegebenen Zielposition.

Parameter

x

horizontale Position des Endpunkts

y

vertikale Position des Endpunkts

Beispiel

DrawLine (100, 200)

Es wird nun eine Linie von der aktuellen Position zur Position 100, 200 gezeichnet.

Siehe auch

DrawLineExt , DrawHorzLine , SetPen


DrawLineExt

DrawLineExt(x1 as Numeric, y1 as Numeric, x2 as Numeric, y2 as Numeric)

Zeichnet eine Linie mit dem aktuell eingestellten Stift von einer Start- zu einer Zielposition.

Parameter

x1

horizontale Position des Startpunkts

y1

vertikale Position des Startpunkts

x2

horizontale Position des Endpunkts

y2

vertikale Position des Endpunkts

Beispiel

DrawLineExt (100, 200, 500, 200)

Es wird nun eine Linie von der Position 100,200 bis zur Position 500, 200 gezeichnet.

(Waagrechte Linie).

Siehe auch

DrawLine , DrawHorzLine , SetPen


DrawHorzLine

DrawHorzLine(bottom as Bool)

Zeichnet eine horizontale Linie mit dem aktuell eingestellten Stift.

Parameter

bottom

Linie unterhalb der aktuellen Textzeile, falls True

andernfalls oberhalb

Beispiel

DrawHorzLine (True)

Beschreibung

Die Linie wird vom linken bis zum rechten Seitenrand Unterhalb der momentanen Textzeile

gezeichnet. Zur besseren Lesbarkeit sind die Konstanten LINE_BOTTOM (=TRUE) und LINE_TOP (=FALSE) definiert.

Bsp.: DrawHorzLine(LINE_BOTTOM) à vgl. Linienkonstanten

Siehe auch

DrawLine , DrawLineExt , SetPen


DrawRect

DrawRect(x as Numeric, y as Numeric)

Zeichnet ein Rechteck mit aktuellem Stift und aktuellem Pinsel. Der Punkt links oben ist die aktuelle Ausgabeposition, der rechte untere Punkt ist als Parameter angegeben.

Parameter

x

horizontale Position des rechten unteren Punktes

y

vertikale Position des rechten unteren Punktes

Beispiel

DrawRect (1000, 2000)

Zeichnet ein Rechteck von der aktuellen Position zu der Position 1000, 2000.

Siehe auch

DrawRectExt , SetPen


DrawRectExt

DrawRectExt(x1 as Numeric, y1 as Numeric, x2 as Numeric, y2 as Numeric)

Zeichnet ein Rechteck mit aktuellem Stift und aktuellem Pinsel. Die Ausmaße des Rechtecks sind spezifiziert durch den Punkt links oben und rechts unten.

Parameter

x1

horizontale Position des linken oberen Punktes

y1

vertikale Position des linken oberen Punktes

x2

horizontale Position des rechten unteren Punktes

y2

vertikale Position des rechten unteren Punktes

Beispiel

DrawRectExt (100, 200, 1000, 2000)

Zeichnet ein Rechteck von der Position 100, 200 bis zur Position 1000, 2000.

Siehe auch

DrawRect , SetPen


PenType

Dieser Datentyp ist eigentlich kein eigenständiger Datentyp, sondern ein Numeric-Wert. Allerdings vereinfacht die Einführung eines speziellen Typs für Pen-Identifikatoren die Lesbarkeit des Formulars.


CreatePen

CreatePen(width as Numeric, type as Numeric, color as Numeric) as PenType

Erzeugen eines Stifts.

Parameter

width

Stiftbreite

type

PEN_SOLID, PEN_DOT, PEN_DASH, PEN_NULL

color

Farbe des Stifts

Beschreibung

Ein Stift wird dazu verwendet, eine Linie zu zeichnen. PEN_NULL erzeugt einen unsichtbaren Stift. Dieser kann dazu verwendet werden, eine Linie verschwinden zu lassen.

Eine Stiftbreite von 0 erzeugt eine Haarlinie.

Beispiel

Dim p as PenType = CreatePen (10, PEN_SOLID, COLOR_BLACK)

SelectPen (p)

Dim p as PenType | Definieren der Variable f als Identifikator
CreatePen | Erzeugen des Stifts
10 | Stiftbreite
PEN_SOLID | Typ
COLOR_BLACK | Schriftfarbe
SelectPen | Befehl
p | Identifikator

Diese Funktion liefert einen PenType -Wert zurück. Mit Hilfe dieses Wertes kann die Funktion SelectPen den aktuellen Stift setzen.

Siehe auch

SelectPen , Stiftkonstanten , Farbkonstanten


SelectPen

SelectPen(id as PenType )

Setzt den aktuellen Stift anhand eines Identifikators für einen Stift.

Parameter

id

Identifikator des Stiftes

Beschreibung

Der Identifikator muss zuvor mit CreatePen erzeugt worden sein.

Beispiel

Dim p as PenType = CreatePen (10, PEN_SOLID, COLOR_BLACK)

SelectPen (p)

Dim p as PenType | Definieren der Variable f als Identifikator
CreatePen | Erzeugen des Stifts
10 | Stiftbreite
PEN_SOLID | Typ
COLOR_BLACK | Stiftfarbe
SelectPen | Befehl
p | Identifikator

Siehe auch

CreatePen


SetPen

SetPen(width as Numeric, type as Numeric, color as Numeric)

Setzen des aktuellen Stifts

Parameter

width

Stiftbreite

type

PEN_SOLID, PEN_DOT, PEN_DASH, PEN_NULL

color

Farbe des Stifts

Beschreibung

Ein Stift wird dazu verwendet eine Linie zu zeichnen. PEN_NULL erzeugt einen unsichtbaren Stift. Dieser kann dazu verwendet werden, eine Linie verschwinden zu lassen.

Eine Stiftbreite von 0 erzeugt eine Haarlinie.

Beispiel

SetPen (10, PEN_SOLID, COLOR_BLACK)

SetPen | Befehl
10 | Stiftbreite
PEN_SOLID | Typ
COLOR_BLACK | Farbe

Siehe auch

Stiftkonstanten , Farbkonstanten , SetPenWidth , SetPenType , SetPenColor


SetPenColor

SetPenColor(color as Numeric)

Setzen der Farbe des Stifts

Parameter

color

Farbe des Stifts

Beispiel

SetPenColor (COLOR_BLUE)

Wurde zuerst der Stift mit (10, PEN_SOLID, COLOR_BLACK) angegeben, so wird nun die Stiftfarbe COLOR_BLACK durch COLOR_BLUE ersetzt. Die Stiftgröße und der Stifttyp bleiben gleich.

Siehe auch

SetPen , SetPenType , SetPenWidth


SetPenType

SetPenType(type as Numeric)

Setzen des Stifttyps

Parameter

type

PEN_SOLID, PEN_DOT, PEN_DASH, PEN_NULL

Beispiel

SetPenType (PEN_DOT)

Wurde zuerst der Stift mit (10, PEN_SOLID, COLOR_BLACK) angegeben, so wird nun der Stifttyp PEN_SOLID durch PEN_DOT ersetzt. Die Stiftgröße und die Stiftfarbe bleiben gleich.

Siehe auch

SetPen , SetPenWidth , SetPenColor


SetPenWidth

SetPenWidth(width as Numeric)

Setzen der Stiftbreite

Parameter

width

Stiftbreite

Beispiel

SetPenWidth(12)

Wurde zuerst der Stift mit (10, PEN_SOLID, COLOR_BLACK) angegeben, so wird nun die Stiftbreite 10 durch 12 ersetzt. Der Stifttyp und die Stiftfarbe bleiben gleich.

Siehe auch

SetPen , SetPenType , SetPenColor


DrawBitmap

DrawBitmap(x as Numeric, y as Numeric, width as Numeric, height as Numeric, file as String)

Zeichnen eines Bitmaps an einer festgelegten Position.

Parameter

x

horizontale Koordinate des linken oberen Ecks

y

vertikale Koordinate des linken oberen Ecks

width

Breite des Bitmaps

height

Höhe des Bitmaps

file

Dateiname des Bitmaps

Wird als Dateiname ein leerer String("") übergeben, so wird der Befehl ignoriert.

Beschreibung

Die Höhe und die Breite des Bitmaps müssen angegeben werden. Das Bitmap wird auf diese Werte skaliert. Der Dateiname kann entweder einen vollen Pfad beinhalten oder auch relativ zum Verzeichnis des aktuellen Formulars.

Wichtig:

Bei voller Pfadangabe müssen immer zwei \\ angegeben werden !

z.B.: c:\\lexware\\loge\\formular\\logo.bmp

Beispiel

DrawBitmap (100, 200, 500, 500, "Clip.bmp")

Siehe auch


DrawGIF

DrawGIF(x as Numeric, y as Numeric, width as Numeric, height as Numeric, file as String)

Zeichnet eine Grafik, die als Datei im GIF-Format vorliegt, an die festgelegte Position.

Parameter

x

horizontale Koordinate des linken oberen Ecks

y

vertikale Koordinate des linken oberen Ecks

width

Breite des GIF´s

height

Höhe des GIF´s

file

Dateiname des GIF´s

Wird als Dateiname ein leerer String("") übergeben, so wird der Befehl ignoriert.

Beschreibung

Die Höhe und die Breite des GIF´s müssen angegeben werden. Das GIF´s wird auf diese Werte skaliert. Der Dateiname kann entweder einen vollen Pfad beinhalten oder auch relativ zum Verzeichnis des aktuellen Formulars.

Wichtig:

Bei voller Pfadangabe müssen immer zwei \\ angegeben werden !

z.B.: c:\\lexware\\loge\\formular\\logo.gif

Beispiel

DrawGIF (100, 200, 500, 500, "Clip.gif")

Siehe auch


DrawJPG

DrawJPG(x as Numeric, y as Numeric, width as Numeric, height as Numeric, file as String)

Zeichnet eine Grafik, die als Datei im JPG-/ JPEG-Format vorliegt, an die festgelegte Position.

Parameter

x

horizontale Koordinate des linken oberen Ecks

y

vertikale Koordinate des linken oberen Ecks

width

Breite des JPEG´s

height

Höhe des JPEG´s

file

Dateiname des JPEG´s

Wird als Dateiname ein leerer String("") übergeben, so wird der Befehl ignoriert.

Beschreibung

Die Höhe und die Breite des JPEG´s müssen angegeben werden. Das JPEG´s wird auf diese Werte skaliert. Der Dateiname kann entweder einen vollen Pfad beinhalten oder auch relativ zum Verzeichnis des aktuellen Formulars.

Wichtig:

Bei voller Pfadangabe müssen immer zwei \\ angegeben werden !

z.B.: c:\\lexware\\loge\\formular\\logo.jpg

Beispiel

DrawJPG (100, 200, 500, 500, "Clip.JPG")

Siehe auch

DrawBitmap DrawGIF


LXPlayMetafile

LXPlayMetafile(x as Numeric, y as Numeric, width as Numeric, height as Numeric, file as String)

Zeichnet eine Grafik, die als Enhanced-Metafile-Datei vorliegt, an die festgelegte Position.

Parameter

x

horizontale Koordinate des linken oberen Ecks

y

vertikale Koordinate des linken oberen Ecks

width

Breite des Metafile

height

Höhe des Metafile

file

Dateiname des Metafile

Wird als Dateiname ein leerer String("") übergeben, so wird der Befehl ignoriert.

Beschreibung

Die Höhe und die Breite des Metafile müssen angegeben werden. Das Metafile wird auf diese Werte skaliert. Der Dateiname kann entweder einen vollen Pfad beinhalten oder auch relativ zum Verzeichnis des aktuellen Formulars.

Beispiel

LXPlayMetafile (100, 200, 500, 500, "Clip.emf")


StringRight

StringRight(text as String, len as Numeric) as String

Extrahiert aus dem übergebenen String einen Teilstring von rechts und gibt diesen zurück.

Parameter

text

Ein Text als String, von dem extrahiert werden soll.

len

Anzahl der Zeichen, die vom Ausgangsstring zurückgegeben werden sollen.

Beispiel

Dim p as string

P = StringRight("Buchstabe", 4)

Ergebnis: p = "tabe"

Siehe auch

StringLeft , StringMid , StringLength , StringGetAt ,

StringSetAt , StringMakeUpper , StringMakeLower


StringLeft

StringLeft(text as String, len as Numeric) as String

Extrahiert aus dem übergebenen String einen Teilstring von links und gibt diesen zurück.

Parameter

text

Ein Text als String, von dem extrahiert werden soll.

len

Anzahl der Zeichen, die vom Ausgangsstring zurückgegeben werden sollen.

Beispiel

Dim p as string

P = StringLeft("Buchstabe", 4)

  Ergebnis: p = "Buch"

Siehe auch

StringRight , StringMid , StringLength , StringGetAt ,

StringSetAt , StringMakeUpper , StringMakeLower


StringMid

StringMid(text as String, pos as Numeric, len as Numeric) as String

Extrahiert aus dem übergebenen String einen Teilstring von einer Anfangsposition und gibt diesen zurück.

Parameter

text

Ein Text als String, von dem extrahiert werden soll.

pos

Die Position, von der aus eine Anzahl von Zeichen zurückgegeben werden soll.

len

Anzahl der Zeichen, die vom Ausgangsstring zurückgegeben werden sollen.

Beispiel

Dim p as string

P = StringMid("Buchstabe", 3, 4)

Ergebnis: p = "chst"

Siehe auch

StringRight , StringLeft , StringLength , StringGetAt ,

StringSetAt , StringMakeUpper , StringMakeLower


StringLength

StringLength(text as String) as Numeric

Gibt die Anzahl von Zeichen eines String zurück.

Parameter

text

Ein Text als String, von dem die Anzahl der Zeichen ermittelt werden soll.

Beispiel

Dim w as numeric

w = StringLength("Buchstabe")

Ergebnis: w = 9

Siehe auch

StringRight , StringLeft , StringMid , StringGetAt ,

StringSetAt , StringMakeUpper , StringMakeLower


StringGetAt

StringGetAt(text as String, pos as Numeric) as String

Ermittelt aus dem übergebenen String an einer definierten Position einen Teilstring und gibt diesen zurück.

Parameter

text

Ein Text als String, von dem extrahiert werden soll.

pos

Die Position, dessen Zeichen zurückgegeben werden soll.

Beispiel

Dim p as String

p = StringGetAt("Buchstabe", 5)

  Ergebnis: p = "s"

Siehe auch

StringRight , StringLeft , StringMid , StringLength ,

StringSetAt , StringMakeUpper , StringMakeLower


StringSetAt

StringSetAt(text REF String, pos as Numeric, char as String)

Ersetzt im String text den Buchstaben an der Position pos durch den Buchstaben char.

Wichtig:

Dem Befehl wird der übergebene String als Referenz übergeben, d.h. er verändert diesen, so dass er anschliessend die gewünschte Eigenschaft hat.

Parameter

text

Ein Text als String, in dem ein Zeichen geändert werden soll.

pos

DiePosition, an der ein Zeichen geändert werden soll.

char

Ein Zeichen, welches gesetzt werden sollen.

Beispiel

Dim text as String = "Buchstabe"

StringSetAt(text, 4, "k")

Ergebnis: text = "Buckstabe"

Siehe auch

StringRight , StringLeft , StringMid , StringLength ,

StringGetAt , StringMakeUpper , StringMakeLower


StringMakeUpper

StringMakeUpper(text REF String)

Ersetzt im String text alle Kleinbuchstaben durch Großbuchstaben.

Wichtig:

Dem Befehl wird der übergebene String als Referenz übergeben, d.h. er verändert diesen,

so dass er anschliessend die gewünschte Eigenschaft hat.

Parameter

text

Ein Text als String, in dem alle Zeichen geändert werden soll.

Beispiel

Dim text as String = "Buchstabe"

StringMakeUpper(text)

Ergebnis: text = "BUCHSTABE"

Siehe auch

StringRight , StringLeft , StringMid , StringLength ,

StringGetAt , StringSetAt , StringMakeLower


StringMakeLower

StringMakeLower(text REF String)

Ersetzt im String text alle Großbuchstaben durch Kleinbuchstaben.

Wichtig:

Dem Befehl wird der übergebene String als Referenz übergeben, d.h. er verändert diesen,

so dass er anschliessend die gewünschte Eigenschaft hat.

Parameter

text

Ein Text als String, in dem alle Zeichen geändert werden soll.

Beispiel

Dim text as String = "BuCHstabe"

StringMakeLower(text)

Ergebnis: text = "buchstabe"

Siehe auch

StringRight , StringLeft , StringMid , StringLength ,

StringGetAt , StringSetAt , StringMakeUpper


StringToNumeric

StringToNumeric (strZahl as String) as Numeric

Ermittelt eine als String vorliegende Zahl und gibt diese als Numeric-Wert zurück.

Parameter

StrZahl

Eine als String vorliegende Zahl.

Beispiele:

Dim wert as Numeric

Wert = StringToNumeric("-30.1")

Der Numeric-Variablen wert wurde -30.1 zugewiesen.

· Als Tausendertrennzeichen und Dezimalpunkt werden standardmäßig benutzt:
kein Tausendertrennzeichen
Dezimalpunkt: "." (also ein Punkt)
Dies lässt sich mit dem Befehl SetFormatNumericOptions verändern.

· Bei Auftreten eines nicht auswertbaren Zeichens wird die bisher ermittelte Zahl ausgegeben
wert = StringToNumeric("1zwei3")
' Der Numeric-Variablen wert wurde 1 zugewiesen

· sind keine Ziffernzeichen auswertbar, wird der Wert Null zurückgegeben
wert = StringToNumeric("zwei3")
' Der Numeric-Variablen wert wurde 0 zugewiesen

· Das Auswerten einer Zahl in Exponentialdarstellung ist möglich
wert = StringToNumeric("1e-2")
' Der Numeric-Variablen wert wurde 0.01 zugewiesen


FormatString

FormatString(format as String, s as String) as String

Formatiert einen String.

Parameter

format

String, der das Ausgabeformat des String-Wertes beschreibt

s

String-Wert, der formatiert werden soll

Beschreibung

Diese Funktion wird meistens dazu verwendet, um komplexe Zeichenketten zu erstellen. Im Format-string können Sie mit Hilfe der Zeichenfolge %s die Position des String-Wertes steuern. Weitere Parameter bestimmen die Formatierung des String-Wertes. Anhand von Beispielen kann man schnell erkennen, welcher Parameter welche Funktion erfüllt.

Beispiele

FormatString("Hallo %s Meier", "Frau") = "Hallo Frau Meier"

oder

FormatString("Hallo %10s Meier", "Frau") = "Hallo Frau Meier"

oder

FormatString("Hallo %-10s Meier", "Frau") = "Hallo Frau Meier"

FormatString | Befehl
"Hallo %s Meier" | Zeichenkette, in welche die nachfolgende Zeichenkette an der Stelle %s eingesetzt wird.
"Frau" | Zeichenkette

%10s | Zeichenkette hat auf jeden Fall 10 Stellen. Fehlende Zeichen werden mit Leerstellen am Anfang aufgefüllt
%-10s | Zeichenkette hat auf jeden Fall 10 Stellen. Fehlende Zeichen werden mit Leerstellen am Ende aufgefüllt

Siehe auch

FormatNumeric , FormatDate


FormatDate

FormatDate(format as String, date as Numeric) as String

Formatiert einen Datums- und Uhrzeit-Wert und wandelt ihn in einen String.

Parameter

format

String, der das Ausgabeformat des String-Wertes beschreibt

date

Datum- und Uhrzeit-Wert

Beschreibung

Der Format-String kann eine beliebige Zeichenfolge sein, die bestimmte Zeichenfolgen beinhaltet, welche die Position von Teilen des Datums und der Uhrzeit bestimmen. Folgende Zeichenfolgen werden unterstützt

%a kurzer Wochentag

%A langer Wochentag

%b kurzer Monatsname

%B langer Monatsname

%c Datum und Uhrzeit in länderspezifischer Formatierung

%d Tag im Monat (01 - 31)

%H Stunde im 24-Stunden Format (00 - 23)

%I Stunde im 12-Stunden Format (01 - 12)

%j Tag im Jahr (001 - 366)

%m Monat (01 - 12)

%M Minute (00 - 59)

%p A.M. oder P.M. in 12-Stunden Formatierung

%S Sekunden (00 - 59)

%U Kalenderwoche (00 - 51)

%w Wochentag (0 - 6; Sonntag ist 0)

%x Datum in länderspezifischer Formatierung

%X Uhrzeit in länderspezifischer Formatierung

%y kurzes Jahr (00 - 99)

%Y langes Jahr

Beispiel

FormatDate("%A, den %d.%m.%Y um %H:%M Uhr", Now()) = "Freitag, den 15.02.1998 um 20:11 Uhr"

Siehe auch

Now , FormatNumeric , FormatString , PRINTDATE


FormatNumeric

FormatNumeric(format as String, n as Numeric) as String

Wandelt einen Numeric-Wert in einen String um.

Parameter

format

String, der das Ausgabeformat des Numeric-Wertes beschreibt

n

Numeric-Wert, der formatiert werden soll

Beschreibung

Der Format String kann beliebige Zeichen beinhalten. Der Numeric-Wert wird an einer bestimmten Stelle im String platziert. Diese Stelle können Sie im Formatstring mit der Zeichenfolge %f bestimmen. Weitere Parameter in dieser Zeichenfolge bestimmen die Formatierung der Zahl.

Die Funktionsweise dieser Parameter wird am besten durch ein paar Beispiele erläutert

Beispiele

FormatNumeric("Hundert: %.0f", 100) = "Hundert: 100"

oder

FormatNumeric("Hundert DM: %.2f DM", 100) = "Hundert DM: 100,00 DM"

oder

FormatNumeric("DATEV: %05.0f", 100) = "DATEV: 00100"

FormatNumeric | Befehl
"Hundert: %.0f" | Zeichenkette, in die der nachfolgende Wert an der Stelle %.0f eingesetzt wird. (%.0f = Wert ohne Nachkommastellen).
100 | Wert

%.2f | Wert mit 2 Nachkommastellen ausgegeben
%05.0f | 5-stelliger Wert ohne Nachkommastellen (fehlende Stellen werden mit 0 aufgefüllt)

Siehe auch

FormatNumeric erweitert

FormatString , FormatDate , SetFormatNumericOptions


FormatNumeric erweitert

FormatNumeric(format AS String, zahl AS Numeric) AS String

Parameter

format

String, der die Formatierung von zahl festlegt

zahl

numerische Wert, der als formatierter String ausgegeben werden soll

Beschreibung

Dabei darf in dem Formatierungsstring an höchstens einer Stelle das Prozentzeichen "%" vorkommen, das die Stelle kennzeichnet, an der die Zahl in den Formatierungsstring eingefügt wird. Dem "%" muss ein Typ-Parameter folgen, der die allgemeine Darstellung der Zahl beschreibt. Als Typ-Parameter ist einer der Buchstaben e, f, g oder G erlaubt.

Beispiele:

e: FormatNumeric("Ergebnis: %e", 501.123)

Ergebnis: 5.011230e+002

Exponentialdarstellung mit kleinem e als Exponentenzeichen

f: FormatNumeric("Ergebnis: %f", 501.123)

Ergebnis: 501.123000

Gleitkommadarstellung

g: FormatNumeric("Ergebnis: %g", 0.123)

Ergebnis: 0.123

 FormatNumeric("Ergebnis: %g", 0.00000123)

Ergebnis: 1.23e-006

es wird automatisch Exponentialdarstellung oder Gleitkommadarstellung verwendet, je nachdem, welche Form kürzer ist.

G: FormatNumeric("Ergebnis: %G", 0.00000123)

Ergebnis: 1.23E-006

wie g, jedoch bei Exponentialdarstellung mit großem "E"

Wichtig:

Die Angabe des Typ-Parameters ist verpflichtend. Zusätzlich sind noch optionale Parameter möglich, die zwischen "%" und "typ" eingefügt werden können.

%[ ausrichtung ][ breite ][ .nachkommastellen ]typ

breite:

gibt die Mindestbreite in Zeichen an, die für die Zahl eingefügt werden

Werte:

positive ganze Zahlen

ausrichtung:

Ausrichtung der Zahl

Werte:

"-" Linksausrichtung der Zahl in dem mit breite reservierten Brereich

(Standard:Rechtsausrichtung).

"0" Die Zahl wird durch führende Nullen auf die angegebene Breite gebracht

(Standard: Leerzeichen)

"+" Es wir stets das Vorzeichen der Zahl dargestellt

(Standard: nur negatives Vorzeichen anzeigen)

.nachkommastellen

Anzahl der angezeigten Nachkommastellen (Beachte den vorangestellten "."!)

typ

siehe oben

Beispiele:

FormatNumeric("Ergebnis: %.1f", 501.123)

Ergebnis: 501.1

FormatNumeric("Ergebnis: %+08.1f", 501.123)

Ergebnis: +00501.1

(mit Vorzeichen, 1 Nachkommastelle, insgesamt 8-stellig, mit führenden Nullen aufgefüllt)

Siehe auch

FormatNumeric

FormatString , FormatDate , SetFormatNumericOptions


SetFormatNumericOptions

SetFormatNumericOptions ( mode as Numeric, dp as String, ts as String)

Setzt das Ausgabeformat für einen Numeric-Wert.

Parameter

mode FN_DEFAULT dp= " . " ts= " "

FN_CUSTOM selbstgewählte Trennzeichen

FN_LOCALE benutzt die Einstellungen aus Windows/ Systemsteuerung/Ländereinstellungen

dp String, der das Aussehen des Dezimaltrennzeichens bestimmt

ts String, der das Tausendertrennzeichen bestimmt

Diese Einstellungen haben Auswirkungen auf die Befehle StringToNumeric und FormatNumeric

Beispiel für ein benutzerdefiniertes Zahlenformat:

Dim wert as Numeric
wert = 8000.1
SetFormatNumericOptions(modeFNCustom, "d", "t")
TL(FormatNumeric("%.2f", wert))
SetFormatNumericOptions(modeFNDefault, "", "")
TL(FormatNumeric("%.2f", wert))
gibt aus:
8t000d10
8000.10


Allgemeines zur COM-Schnittstelle

Über den Datentyp Object der Formularsprache ist das Ansteuern von COM-fähigen Komponenten möglich. Dies kann insbesondere genutzt werden, um mittels OLE-Automation z.B. Programme der Microsoft-Office-Familie anzusteuern.

Über die Befehle CreateObject und GetObject lässt sich die Verbindung zu einer COM-fähigen Komponente aufbauen, mittels ReleaseObject wird diese Verbindung wieder freigegeben. Alle weiteren Funktionen sind davon abhängig, was die jeweilige Komponente zur Verfügung stellt. Die Operationen der Komponente werden über den Punkt-Operator angesprochen.

Wenn das Ansteuern einer COM-fähigen Komponente die einzige Aufgabe einer Formulardatei ist (also nicht gleichzeitig auch Druckausgaben stattfinden), dann kann mittels der Beschreibungsvariablen

Description form target as "COM"

das Starten eines Druckauftrages bzw. der Seitenvorschau verhindert werden.

Siehe auch:

CreateObject , GetObject , ReleaseObject , GetObject erweitert ,

Export von Druckdaten


CreateObject

CreateObject(application as string) as object

Diesem Befehl wird die ProgID der Komponente als string übergeben und die Schnittstelle zu dieser Komponente als Object-Variable zurückgegeben.

Es ist zu beachten, dass dabei stets eine neue Instanz dieser Komponente erzeugt wird. Weiterhin ist die Existenz dieser Instanz nur während der Ausführung des Formulars gesichert.

Beispiel: siehe Schulung

Siehe auch:

Allgemeines zur COM-Schnittstelle ,

GetObject , ReleaseObject , GetObject erweitert

Export von Druckdaten


GetObject

GetObject(application ref string, result ref numeric) as object

Dieser Befehl stellt eine Erweiterung des CreateObject-Befehls dar. Wenn bereits eine Instanz der gewünschten Komponente aktiv ist, wird eine Schnittstelle zu dieser Instanz bereitgestellt, statt eine neue Instanz zu erzeugen. Wird hingegen keine aktive Instanz gefunden, so wird wie bei CreateObject eine neue Instanz erzeugt.

Die Existenz einer bereits vor der Formularausführung aktiven Komponente ist auch nach der Formularausführung gesichert.

Siehe auch:

Allgemeines zur COM-Schnittstelle ,

CreateObject , ReleaseObject , GetObject erweitert

Export von Druckdaten


ReleaseObject

ReleaseObject(objVar as Object)

Gibt die Schnittstelle zu einer Komponente wieder frei.

Siehe auch:

Allgemeines zur COM-Schnittstelle ,

CreateObject , GetObject , GetObject erweitert

Export von Druckdaten


GetObject erweitert

Function GetObject(strPathOrName Ref String, nResult Ref Numeric) As Object

Es wird aufgrund eines Identifikationsstrings versucht, ein COM-Objekt anzusprechen, der Erfolg dieser Bemühung ist in nResult codiert.

Siehe dazu:

Get_Object_Pfad , Get_Object_Name

Parameter

strPathOrName

Datentyp String der Scriptsprache

"Excel.Application" Name einer COM-fähigen Anwendung

"c:\\windows\\EigeneDateien\\Mappe1.xls" der Dateipfad eines COM-Objects

"Mappe1.xls" eine COM-fähige Datei im Verzeichnis, in dem die Formulardatei gespeichert ist

nResult:

Datentyp Numeric der Scriptsprache als Referenz . Dient lediglich als Rückgabewert!

0: es konnte kein COM-Object angesprochen werden

1: es wurde ein laufende Instanz des COM-Objekts gefunden

2: es wurde eine neue Instanz des COM-Objekts erzeugt

Beschreibung

Mit dieser Funktion wird versucht, eine bereits aktive Instanz eines COM-Objekts anzusprechen. Wird ein passendes COM-Objekt identifiziert, das allerdings noch inaktiv ist, so wird eine neue Instanz kreiert. GetObjekt() ersetzt somit die Funktionalität von CreateObject().

WICHTIG:

1. Die Stringvariable strPfadOderName ist eine Referenzvariable, die ihren Wert durch den Funktionsaufruf ändern kann. Dies findet dann statt, wenn ein unvollständiger Dateipfad angegeben wird, der durch GetObject() um den aktuellen Formularpfad ergänzt wird. strPfadOderName enthält danach den vollständigen Pfad!
Dies hat auch zur Folge, dass GetObject() kein konstanter String übergeben werden kann,
FALSCH: Excel = GetObject("Excel.Application", nResult),
sondern der String muss zuvor einer Variablen zugewiesen werden,
RICHTIG: strName = "Excel.Application"
Excel = GetObject(strName, nResult).

2. Soll einer Stringvariable eine Dateipfad zugewiesen werden, indem der String in der Formulardatei fest vorgegeben ist, so sind für den Backslash "\" jeweils zwei Slashes "\\" einzugeben. Beispiel:
"c:\\WINNT\\Profiles\\BenutzerName\\Eigene Dateien\\mappe1.xls"
Dies liegt daran, dass durch einen Backslash Steuerzeichen gekennzeichnet werden, d.h. intern bleibt von den zwei Slashes nur einer übrig.

3. Bei MS-Excel und MS-Word:
Wird ein Dokument dieser Anwendungen angesprochen, z.B.
strPfad = "Mappe1.xls"
Mappe = GetObject(strPfad, nResult),
und war dieses Dokument noch nicht aktiv, so liefert GetObject() zwar die Schnittstelle zu diesem Objekt, um aber damit arbeiten zu können, muss zunächst noch der Datei-Öffne-Befehl der Anwendung MS-Excel bzw. MS-Word ausgeführt werden, z.B.
Excel = Mappe.Application
Mappe = Excel.Workbooks.Open(strPfad)

Siehe auch

Allgemeines zur COM-Schnittstelle ,

CreateObject , GetObject , ReleaseObject ,

Export von Druckdaten


Export von Druckdaten an andere Programme über die OLE-Technik

Die Lexware Formularsprache erlaubt auch das Ansteuern von OLE-Komponenten. Dies kann bevorzugt verwendet werden, um direkt Daten an OLE-fähige Fremdprogramme zu übergeben. In erster Linie wird diese Funktionalität genutzt, um die Programme von Microsoft Office anzusteuern:

Excel
Word
Outlook

Um in einem Formular ein OLE-Object erzeugen und nach Verwendung wieder korrekt freigeben zu können wurden zum einen der Datentyp

Object

und die Funktionen

CreateObject()

GetObject()
ReleaseObject()

eingeführt. Alle weiteren Funktionen sind davon abhängig, was das jeweilige OLE-Object zur Verfügung stellt. Die Operationen des Objectes werden über den Punkt-Operator angesprochen.

Nachfolgend ein Beispiel, in dem MS-Excel aufgerufen wird, ein Arbeitsblatt erzeugt wird und dort in die Zellen A1..F1 Text eingetragen und formatiert wird. Danach wird Excel wieder beendet und das über CreateObject() erzeugte Object freigegeben.

' notwendige Automatisierungsobjekte
Dim Sheet   As Object
Dim Excel   As Object
Dim Workbook   As Object

' Excel aufrufen und die Objekte ermitteln
Excel = CreateObject( "Excel.Application" )
WorkBook = Excel.Workbooks.Add
Sheet = Workbook.WorkSheets(1)

' Excel einblenden
Excel.Visible = True

' erste Zeile
 auf Arial, fett, 10 einstellen
Sheet.Rows( 1 ).Font.Name = "Arial"
Sheet.Rows( 1 ).Font.Size = 10
Sheet.Rows( 1 ).Font.Bold = TRUE

' Überschriften
 in die erste Tabellenzelle einfügen.
Sheet.Cells(1, 1).Value = "Belegdatum"
Sheet.Cells(1, 2).Value = "Beleg"
Sheet.Cells(1, 3).Value = "Buchungstext"
Sheet.Cells(1, 4).Value = "Betrag"

' Excel beenden
Excel.Quit

' Freigeben der Objektvariable.
ReleaseObject( Excel )


GetAreaLength

GetAreaLength() as Numeric

Ermittelt die Länge des aktuellen Ausgabebereichs.

Beschreibung

Der Ausgabebereich ist entweder Kopfzeile, Fußzeile oder Seitenrumpf.

Beispiel

If GetYPos() + GetLineHeight () > GetAreaLength () then

PageBreak

End If

If GetYPos() + GetLineHeight () > GetAreaLength () then | Wenn die aktuelle Position im Formular + eine zusätzlich ermittelte Zeilenhöhe größer ist als der Ausgabebereich, dann
PageBreak | Seitenumbruch
End If | Ende der Bedingung

Siehe auch


GetAreaWidth

GetAreaWidth() as Numeric

Ermittelt die Breite des aktuellen Ausgabebereichs.

Beschreibung

Der Ausgabebereich ist entweder Kopfzeile, Fußzeile oder Seitenrumpf.

Beispiel

DrawLineExt( 0, 2000, GetAreaWidth(), 2000 )

Hier wird eine Linie vom linken Rand (0) bis zum rechten Rand an der vertikalen Position 20,00 cm gezeichnet.

0 | horizontale Position Startpunkt
2000 | vertikale Position Startpunkt
GetAreaWidth | ermittelt die Breite des aktuellen Bereichs (horizontale Position vom Endpunkt)
2000 | vertikale Position Endpunkt

Siehe auch


GetLineHeight

GetLineHeight () as Numeric

Ermittelt die aktuelle Zeilenhöhe.

Beschreibung

Die aktuelle Zeilenhöhe ist von der gewählten Schriftart abhängig.

Beispiel

If GetYPos() + GetLineHeight () > GetAreaLength()then

PageBreak

End If

If GetYPos() + GetLineHeight () > GetAreaLength () then | Wenn die aktuelle Position im Formular + eine zusätzlich ermittelte Zeilenhöhe größer ist als der Ausgabebereich, dann
PageBreak | Seitenumbruch
End If | Ende der Bedingung

Siehe auch


GetFormFileName

GetFormFileName() as String

Liefert den kompletten Pfad zur aktuellen Formulardatei. Wird in der Regel in der Fußzeile ausgegeben. D.h. Sie können auf dem Ausdruck in der Fußzeile den Namen der Formulardatei erkennen.

Beispiel

function OnPrintFooter()

 SetFont("Arial", 8, FONT_NORMAL, COLOR_BLACK)

 SetTabs("C R-200 R")

 DrawHorzLine(LINE_TOP)

 TL("(C) Lexware GmbH & Co. KG 1998\t" + PAGENUMBER + "\t" +

GetFormFileName() + "\t" + FormatDate("%d.%m.%Y", Now()) )

 TL( GetProgramName() + " " + GetProgramVersion() )

end function

SetEventHandler(EVENT_PRINT_FOOTER, OnPrintFooter)

Siehe auch

GetProgramName , GetProgramVersion


GetPageNumber

GetPageNumber() as Numeric

Ermittelt die aktuelle Seitennummer. (Funktion um die Seitennummer zu erhalten)

Beispiel

If GetPageNumber() = 5 then

....

End If

If GetPageNumber() = 5 then | Wenn die Seitennummer = 5 dann
.... | durchzuführende Anweisung
End If | Ende der Bedingung

Siehe auch

FormatNumeric , PAGENUMBER


GetPos

GetPos(x ref Numeric, y ref Numeric)

Ermittelt die aktuelle Ausgabeposition

Parameter

x

zur Aufnahme der X-Koordinate

y

zur Aufnahme der Y-Koordinate

Beschreibung

Die Werte werden in 0,1 mm Einheiten angegeben.

Beispiel

Dim x as Numeric

Dim y as Numeric

Get Pos (x, y)

Siehe auch

GetPosX , GetPosY , SetPos


GetPosX

GetPosX() as Numeric

Ermittelt die X-Koordinate der aktuellen Ausgabeposition

Beschreibung

Die Werte werden in 0,1 mm Einheiten angegeben.

Beispiel

Dim x as Numeric = GetPosX()

Siehe auch

GetPos , GetPosY , SetPos


GetPosY

GetPosY() as Numeric

Ermittelt die Y-Koordinate der aktuellen Ausgabeposition

Beschreibung

Die Werte werden in 0,1 mm Einheiten angegeben.

Beispiel

Dim y as Numeric = GetPosY()

Siehe auch

GetPos , GetPosX , SetPos


GetProgramName

GetProgramName() as String

Ermittelt den Namen des Programms.

Beschreibung

Ermittelt wird der Name der Anwendung, die das Druckmodul verwendet. Wird in der Regel in der

Fußzeile mit ausgegeben.

Beispiel

function OnPrintFooter()

 SetFont("Arial", 8, FONT_NORMAL, COLOR_BLACK)

 SetTabs("C R-200 R")

 DrawHorzLine(LINE_TOP)

 TL("(C) Lexware GmbH & Co. KG 1998\t" + PAGENUMBER + "\t" + GetFormFileName() + "\t" + FormatDate("%d.%m.%Y", Now()) )

 TL( GetProgramName() + " " + GetProgramVersion() )

end function

SetEventHandler(EVENT_PRINT_FOOTER, OnPrintFooter)

Siehe auch

GetProgramVersion , GetFormFileName


GetProgramVersion

GetProgramVersion() as String

Ermittelt die Version des Programms.

Beschreibung

Ermittelt wird die Version des Programms, welches das Druckmodul verwendet und nicht die Version des Druckmoduls selbst. Wird in der Regel in der Fußzeile angegeben.

Beispiel

function OnPrintFooter()

 SetFont("Arial", 8, FONT_NORMAL, COLOR_BLACK)

 SetTabs("C R-200 R")

 DrawHorzLine(LINE_TOP)

 TL("(C) Lexware GmbH & Co. KG 1998\t" + PAGENUMBER + "\t" + GetFormFileName() + "\t" + FormatDate("%d.%m.%Y", Now()) )

 TL( GetProgramName() + " " + GetProgramVersion() )

end function

SetEventHandler(EVENT_PRINT_FOOTER, OnPrintFooter)

Siehe auch

GetProgramName , GetFormFileName


Modulo

Modulo(x as numeric, y as numeric) as numeric

Liefert den Divisionsrest von x geteilt durch y, genauer gesagt die Differenz zwischen x und dem Wert n * y, wobei n die nächstniedrige ganze Zahl von x / y ist.

Das Ergebnis der Modulo-Operation selbst ist also nicht zwingend ganzzahlig.

Parameter

X

Eine Zahl, durch die geteilt werden soll.

Y

Eine Zahl, die teilt.

Beispiel

Dim z as numeric

Z = modulo(15,6)

 Ergebnis: z = 3, denn 15 / 6 = 2, Rest 3

Z = modulo(40.45 , 7 )

 Ergebnis: z = 5.45, denn 40.45 / 7 = 5, Rest 5.45


Now

Now() as Numeric

Ermittelt das aktuelle Datum und die aktuelle Uhrzeit.

Beispiel

TL (FormatDate ("%A, den %d.%m.%Y um %H:%M Uhr", Now ())

Ergebnis:

Wochentag, den dd.mm.yyyy um HH:MM Uhr)


PAGENUMBER

PAGENUMBER

Konstante, die für die aktuelle Seitennummer als String-Datentyp steht.

Beschreibung

Die Konstante verwendet GetPageNumber und FormatNumeric um die aktuelle Seitennummer in einem Standardformat auszugeben.

Beispiel

DrawText( PAGENUMBER )

Bei vielen Formularen soll die Seitennummer in der Fußzeile ausgegeben werden. Hierzu nachfolgendes Beispiel:

function OnPrintFooter()

 SetFont("Arial", 8, FONT_NORMAL, COLOR_BLACK)

 SetTabs("C R-200 R")

 DrawHorzLine(LINE_TOP)

 TL("(C) Lexware GmbH & Co. KG 1998\t" + PAGENUMBER + "\t" + GetFormFileName() + "\t" + FormatDate("%d.%m.%Y", Now()) )

 TL( GetProgramName() + " " + GetProgramVersion() )

end function

SetEventHandler(EVENT_PRINT_FOOTER, OnPrintFooter)

Siehe auch

GetPageNumber , FormatNumeric


PRINTDATE

PRINTDATE

Konstante, die den Ausdruck FormatDate("%d.%m.%Y", Now()) ersetzt.

Beschreibung

Die Konstante verwendet FormatDate um das aktuelle Datum auszugeben.

Beispiel

TL(PRINTDATE)

Siehe auch

FormatDate


RemoveAllTabs

RemoveAllTabs()

Entfernen aller zuvor angegebenen Tabulatoren.

Siehe auch

SetTabs , RemoveTab


RemoveTab

RemoveTab(tab as numeric)

Entfernen eines Tabulators.

Parameter

tab

Position des zu entfernenden Tabulators

Beschreibung

Es kann immer nur ein Tabulator entfernt werden. Um Sie alle Tabulatoren zu entfernen, müssen Sie den Befehl RemoveAllTabs verwenden.

Beispiel:

SetTabs("R200 L300 C1000 R-200 R")

RemoveTab(300)

Durch diesen Befehl wird der zweite Tab aus dem o.g. Beispiel entfernt. Nach dieser Anweisung werden nur noch folgende Tabs berücksichtigt: ("R200 C1000 R-200 R").

Siehe auch

SetTabs , RemoveAllTabs


SetPos

SetPos(x as Numeric, y as Numeric)

Setzt die aktuelle Ausgabeposition auf der aktuellen Seite. Stellen Sie sich den Druckbereich in einem Formular als Koordinatensystem vor. Der Ursprung dieses Koordinatensystems liegt in der linken oberen Ecke der zu druckenden Seite. Dabei wachsen die X-Koordinaten von links nach rechts, die Y-Koordinaten von oben nach unten.

Parameter

x

horizontale Position

y

vertikale Position

Beschreibung

Die Werte werden in 0,1 mm Einheiten angegeben.

Beispiel

SetPos (1000, 2000)

TL ("Hallo")

SetPos (1000, 2000) | Setzt den Cursor auf die horizontale Position 1000 mm und die vertikale Position 2000.
TL ("Hallo") | Schreibt in die erreichte Position "Hallo".

Siehe auch

GetPosX , GetPosY , GetPos


SetTabs

SetTabs(tabs as String)

Setzen eines oder mehrerer Tabulatoren

Parameter

tabs

String, der die zu setzenden Tabulatoren beschreibt

Beschreibung

Der String folgt einer eigenen Syntax. Ein Tabulator wird mit Hilfe von zwei Eigenschaften beschrieben. Die erste beschreibt die Ausrichtung und die zweite die horizontale Position. Die Ausrichtung wird durch ein Zeichen angegeben.

Folgende Ausrichtungen werden berücksichtigt

L – linksbündig, R – rechtsbündig, C - zentriert

Die Position folgt direkt auf das Ausrichtungszeichen. Existiert für einen zentrierten oder rechtsbündigen Tabulator keine Positionsangabe, so wird als Position die Seitenmitte bzw. der rechte Seitenrand definiert.

Eine negative Tabulatorposition bedeutet, dass die Position vom rechten Seitenrand berechnet werden soll.

Die Tabulatorposition wird in 0,1 mm Einheiten angegeben.

Beispiel:

SetTabs("R200 L300 C1000 R-200 R")

Set Tabs | Befehl
R200 | Erster Tab rechtsbündig bei 20,0 mm
L300 | Zweiter Tab linksbündig bei 30,0 mm
C1000 | Dritter Tab zentriert bei 100,0 mm
R-200 | Vierter Tab rechtsbündig vom rechten Seitenrand aus -20,0 mm
R | Fünfter Tab R = einfacher Tab der auf dem rechten Seitenrand sitzt

Siehe auch

RemoveTab


SetPrintDevice()

SetPrintDevice(nDevice as Numeric)

Mit dem Befehl SetPrintDevice ist es möglich, innerhalb eines Formulars die für die Ausgabe relevanten Druckereinstellungen zu wechseln. Diese Einstellungen können für jedes Formular einzeln vorgenommen werden und werden zusammen mit dem Formular abgespeichert (in einer der Formulardatei gleichnamigen Datei mit der Endung ".lsp").

Der Formulareditor bietet die Möglichkeit, für zwei Drucker diese Einstellungen vorzunehmen. Innerhalb der Formulardatei lassen sich diese Einstellungen dann mit den Befehlen

SetPrintDevice(1) bzw. SetPrintDevice(2) auswählen.

Wird keiner dieser Befehle benutzt, wird mit den Druckereinstellungen gearbeitet, die als Windows-Standarddrucker festgelegt sind. (Diese Einstellungen werden ebenfalls benutzt, wenn die benutzerdefinierten Einstellungen des SetPrintDevice-Befehls nicht ausgewertet werden können.

Die Einstellungen können sich u.A. auf folgende Parameter beziehen:

· Papierformat

· Papierschacht

· Drucker (falls mehrere Drucker von dem Rechner angesprochen werden können)

· ...

Ignoriert wird die Anzahl der auszugebenden Kopien des Formulars. Diese Einstellungen werden direkt im Anwendungsprogramm festgelegt.

Zum Verhalten des SetPrintDevice-Befehls:

· Der SetPrintDevice-Befehl löst automatisch einen Seitenumbruch aus. Erfolgte auf der Seite bis zum Auftauchen des SetPrintDevice-Befehls noch keine Ausgabe, entfällt dieser Seitenwechsel.

· Um die Druckereinstellungen abhängig von der aktuellen Seitenzahl zu wechseln, sollte auf das Event EVENT_START_PAGE reagiert werden. Dort kann die Seitenzahl abgefragt werden (Befehl: GetPageNumber()) und abhängig davon ein SetPrintDevice-Befehl ausgeführt werden (vgl. dazu das folgende Beispiel 2).

Es folgen zwei Beispiele für die Anwendung des Befehls.

Beispiel 1: Ausgabe des gleichen Formulars auf zwei verschiedenen Druckern

Mit Hilfe einer WHILE-Schleife werden die Formularbefehle zweimal durchlaufen. Vor dem zweiten Durchlauf erfolgt ein Wechsel der Druckereinstellungen.

à Formulardatei: Bsp_ SetPrintDevice1.lsf

Beispiel 2: Schachtwechsel nach automatischem Erkennen der zweiten Druckseite

Es wird eine Zahlenkolonne mit den Zahlen 1 bis 100 ausgegeben. In der Funktion OnStartPage, die dem Event EVENT_START_PAGE zugeordnet ist, wird die Seitenzahl abgefragt. Ist Seite 2 erreicht, werden die Druckereinstellungen gewechselt.

à Formulardatei: Bsp_ SetPrintDevice2.lsf


Druckbefehle der Lexware-Anwendungen

Zusätzlich kann jedes Lexware-Programm weitere Befehle zur Verfügung stellen, die zumeist dem Datenaustausch dienen. Diese Befehle werden im Formulareditor nicht automatisch eingefärbt und sollten möglichst nicht verändert werden.

Daten ermitteln

Get

Is

GetTime

GetDate

GetNumeric

Schleifendurchläufe

FirstRecord

NextRecord


Get

Get(gruppe as String, bereich as Numeric) as String

Ermitteln einer Zeichenkette.

Parameter

gruppe

Identifikator einer Gruppe

bereich

Nummer innerhalb der Gruppe

Rückgabewert

Zeichenkette

Beschreibung

Der Identifikator einer Gruppe besteht aus einer Zeichenkette mit genau einem Zeichen. Zum Beispiel im Falle der Personaldaten muss der Gruppenparameter den Wert "P" haben.

Diese Parameter sind stark vom verwendeten Programm abhängig. Für genauere Informationen über die programmspezifischen Variablen lesen Sie bitte die Variabelenliste in der Programmdokumentation.

(Bsp.: Lexware urlaubskartei = PCUVAR.INT, Lexware reisekosten = PCRKVAR.INT).

Beispiel

Dim s as String

s = Get("P", 1) ' Personalnummer wird der Variablen S zugewiesen

Siehe auch

Is , GetTime , GetDate , GetNumeric , FirstRecord , NextRecord , FormatString


GetDate

GetDate(gruppe as String, bereich as Numeric) as Numeric

Ermitteln eines Datumswertes.

Parameter

gruppe

Identifikator einer Gruppe

bereich

Nummer innerhalb der Gruppe

Rückgabewert

Datumswert in Form eines Numeric

Beschreibung

Der Identifikator einer Gruppe besteht aus einer Zeichenkette mit genau einem Zeichen. Zum Beispiel muss im Falle der Personaldaten der Gruppenparameter den Wert "P" haben.

Beispiel

Dim t as Numeric

t = GetDate("P", 24)

FormatDate("%Y", t) ' Jahrgang

Siehe auch

Get , Is , GetTime , GetNumeric , FirstRecord , NextRecord , FormatDate


GetNumeric

GetNumeric(gruppe as String, bereich as Numeric) as Numeric

Ermitteln eines Numeric-Wertes.

Parameter

gruppe

Identifikator einer Gruppe

bereich

Nummer innerhalb der Gruppe

Rückgabewert

Numerischer Wert, z.B. ein Betrag

Beschreibung

Der Identifikator einer Gruppe besteht aus einer Zeichenkette mit genau einem Zeichen. Zum Beispiel muss im Falle der Personaldaten der Gruppenparameter den Wert "P" haben.

Beispiel

Dim n as Numeric

t = GetNumeric("P", 23)

FormatNumeric("%.2f DM", n)

Siehe auch

Get , Is , GetTime , GetDate , FirstRecord , NextRecord , FormatNumeric


GetTime

GetTime(gruppe as String, bereich as Numeric) as Numeric

Ermitteln eines Zeitwertes.

Parameter

gruppe

Identifikator einer Gruppe

bereich

Nummer innerhalb der Gruppe

Rückgabewert

Zeitwert in Form eines Numeric

Beschreibung

Der Identifikator einer Gruppe besteht aus einer Zeichenkette mit genau einem Zeichen. Zum Beispiel muss im Falle der Personaldaten der Gruppenparameter den Wert "P" haben.

Beispiel

Dim t as Numeric

t = GetTime("P", 23)

FormatDate("%h:%m", t)

Siehe auch

Get , Is , GetDate , GetNumeric , FirstRecord , NextRecord , FormatDate


Is

Is(gruppe as String, bereich as Numeric) as Bool

Ermitteln eines Wahrheitswertes.

Parameter

gruppe

Identifikator einer Gruppe

bereich

Nummer innerhalb der Gruppe

Rückgabewert

Wahrheitswert

Beschreibung

Der Identifikator einer Gruppe besteht aus einer Zeichenkette mit genau einem Zeichen. Zum Beispiel muss im Falle der Personaldaten der Gruppenparameter den Wert "P" haben.

Diese Parameter sind stark vom verwendeten Programm abhängig. Für genauere Informationen über die programmspezifischen Variablen lesen Sie bitte die Variabelenliste in der Programmdokumentation.

(Bsp.: Lexware urlaubskartei = PCUVAR.INT, Lexware reisekosten = PCRKVAR.INT).

Beispiel

if Is("P", 999) then

...

end if

Siehe auch

Get , GetTime , GetDate , GetNumeric , FirstRecord , NextRecord


FirstRecord

FirstRecord(gruppe as String) as Bool

Initialisieren einer Schleife über Gruppendaten.

Parameter

gruppe

Identifikator einer Gruppe

Rückgabewert

TRUE, falls ein Datensatz zu dieser Gruppe vorhanden ist.

Beschreibung

Der Identifikator einer Gruppe besteht aus einer Zeichenkette mit genau einem Zeichen. Zum Beispiel muss im Falle der Personaldaten der Gruppenparameter den Wert "P" haben. Weitere Datensätze werden mit NextRecord angesprochen.

Beispiel

Dim b as Bool = FirstRecord ("P")

While b do

.....

b = NextRecord ("P")

End While

Dim b as Bool = FirstRecord ("P") | Legt die Variable b als Datentyp Bool fest (wahr oder unwahr)
While b do | Es wird geprüft ob die Variable b wahr ist. Wenn ja, dann soll
...... | diese Anweisung durchgeführt werden.
b = NextRecord ("P") | Gibt die Variable b den Wert wahr zurück, dann ist der nächste Datensatz gelesen worden
End While | Ende der Schleife

Ergebnis: Die Schleife wird für alle Mitarbeiter durchlaufen.

Siehe auch

Get , Is , GetTime , GetDate , GetNumeric , NextRecord


NextRecord

NextRecord(gruppe as String) as Bool

Nächsten Datensatz ermitteln in einer Schleife über Gruppendaten.

Parameter

gruppe

Identifikator einer Gruppe

Rückgabewert

TRUE, falls ein weiterer Datensatz zu dieser Gruppe vorhanden ist.

Beschreibung

Der Identifikator einer Gruppe besteht aus einer Zeichenkette mit genau einem Zeichen. Zum Beispiel muss im Falle der Personaldaten der Gruppenparameter den Wert "P" haben. Eine Schleife wird mit FirstRecord initialisiert.

Beispiel

Dim b as Bool = FirstRecord ("P")

While b do

.....

b = NextRecord ("P")

End While

Dim b as Bool = FirstRecord ("P") | Legt die Variable b als Datentyp Bool fest (wahr oder unwahr).
While b do | Es wird geprüft ob die Variable b wahr ist. Wenn ja, dann soll
...... | diese Anweisung durchgeführt werden.
b = NextRecord ("P") | Gibt die Variable b den Wert wahr zurück, dann ist der nächste Datensatz gelesen worden
End While | Ende der Schleife

Siehe auch

Get , Is , GetTime , GetDate , GetNumeric , FirstRecord , FormatString


Musterbeispiel

In diesem Beispiel wird eine Formulardatei aus dem Programm Lexware urlaubskartei beschrieben. D.h. die Variablen VB_PERSONALDATEN, VAR_P_PERSONALNUMMER, VAR_P_IST_SCHWERBEHINDERT etc. sind programmspezifisch. Jedes Programm der Firma Lexware hat eine eigene Variabelenliste, die Sie zum schreiben bzw. ändern von Formulardateien benötigen. Diese liegen i. d. R. im Verzeichnis "FORMULAR" des jeweiligen Programmverzeichnisses.

‘Interface-Deklarationen des Programms einbinden’

Include "pcu.int"

"Hilfreiche Funktionen einbinden"

Include "pcutool.lsf"

‘Variabelenliste aus dem Programm einbinden’

Include "pcuvar.int"

‘Beschreibung der Formulardatei’

Description Form_Description as "Personaldaten kurz"

"Kennung des Formulars"

Description Form_Code as "Personaldaten"

"Seitenorientierung (hier Hochformat)"

Description Page_Orientation as PAGE_PORTRAIT

"Ränder der Fußzeile werden gesetzt"

SetFooterMargin(200, 220, 200, 100)

"Formulardatei, welche die Fußzeilen beinhaltet, wird eingefügt.

Include "StdFuss.lsf"

"Ränder des Rumpfes der Formulardatei werden gesetzt"

SetBodyMargin(200, 200, 200, 300)

"Definieren der Variable c_memo als Zelle."

Dim c_memo as CellType

"Erzeugt die Zelle c_memo."

c_memo = CreateCell( 1600, 0, CELL_TYPE_DYNVERT + CELL_WORD_WRAP )

" Setzt die Eigenschaften der unteren Linie der Zelle."

SetCellBorder( c_memo, CELL_BORDER_ALL, 0, PEN_NULL, COLOR_WHITE )

"Setzt die Schriftart der Zelle."

SetCellFont( c_memo, "Arial", 9, FONT_NORMAL, COLOR_BLACK )

"Definieren der Variable result_p als Datentyp Bool (wahr oder unwahr)"

Dim result_p as Bool

"Ersten Datensatz lesen."

result_p = FirstRecord( VB_PERSONALDATEN )

"Es wird geprüft, ob der Rückgabewert von result_p wahr ist, solange das der Fall ist, werden die folgenden Anweisungen durchgeführt, wenn nicht, wird die Schleife übersprungen, das Formular wird nach dem Befehl "End While" weiter abgearbeitet.

While result_p do

"Setzen von mehreren Tabulatoren."

SetTabs("L450 L1000 L1300")

"Ausgabe des Wertes einer programmspezifischen Variable (hier Lexware urlaubskartei) mit anschließendem Zeilenwechsel. "\t" führt eine zuvor gesetzte Tab-Anweisung aus."

TL("Pers-Nr.:\t" + Get( VAR_P_PERSONALNUMMER ))

"Ausgabe der Werte von programmspezifischen Variablen mit anschließendem Zeilenwechsel"

TL("Name:\t" + Get( VAR_P_NACHNAME ) + " " + Get( VAR_P_VORNAME ) + "\tGeb.-

Name:\t" + Get( VAR_P_GEBURTSNAME ))

TL("Straße:\t" + Get( VAR_P_STRASSE ) + "\tGeb.-Dat:\t" + FormatDate("%d.%m.%Y",

"Ermitteln eines Datumswertes über eine programmspezifische Variable."

GetDate( VAR_P_GEBURTSDATUM )))

"Erzeugen einer bedingten Programmausführung. Wenn VAR_P_IST_SCHWERBEHINDERT

wahr ist, dann,"

if Is( VAR_P_IST_SCHWERBEHINDERT ) then

"drucke nachfolgende Werte aus, und mache einen Zeilenwechsel"

TL("Plz, Ort:\t" + Get( VAR_P_POSTLEITZAHL ) + " " + Get( VAR_P_ORT ) +

"\tSchwerbeh.:\tja")

"Wird die oben genannte Bedingung nicht erfüllt, soll die nachfolgende Anweisung ausgeführt

werden"

else

"drucke nachfolgende Werte aus, und mache einen Zeilenwechsel"

TL("Plz, Ort:\t" + Get( VAR_P_POSTLEITZAHL ) + " " + Get( VAR_P_ORT ) +

"\tSchwerbeh.:\tnein")

"Beenden der bedingten Programmausführung"

end if

"drucke nachfolgende Werte aus, und mache einen Zeilenwechsel"

TL("Bundesland:\t" + Get( VAR_P_BUNDESLAND ))

"drucke nachfolgende Werte aus, und mache einen Zeilenwechsel"

TL("Telefon:\t" + Get( VAR_P_PRIV_TELEFON ))

"füge eine Leerzeile ein"

LF

"drucke nachfolgende Werte aus, und mache einen Zeilenwechsel"

TL("Eintrittsdatum:\t" + FormatDate("%d.%m.%Y", GetDate( VAR_P_EINTRITTSDATUM )) + "\tAustrittsdatum:\t" + FormatDate("%d.%m.%Y", GetDate( VAR_P_AUSTRITTSDATUM )))

"füge eine Leerzeile ein"

LF

"drucke nachfolgende Werte aus, und mache jeweils einen Zeilenwechsel"

TL(FormatNumeric("Arbeitstage pro Woche:\t%.0f", GetNumeric( VAR_P_WOCHENTAGE )))

TL("Tage:\t" + GetTage())

TL("Arbeitsort:\t" + Get( VAR_P_ARBEITSORT ))

TL("Qualifikation:\t" + Get( VAR_P_QUALIFIKATION))

TL("Telefon dienstl.:\t" + Get( VAR_P_DIENSTTELEFON ))

' ersten Gruppennamen zum Mitarbeiter laden."

Is( VAR_G_LADE_GRUPPE )

TL("Gruppe:\t" + Get( VAR_G_GRUPPENNAME ))

"drucke nachfolgende Werte aus, und mache jeweils einen Zeilenwechsel"

TL("Vertretung:\t" + Get( VAR_P_VERTRETER ))

TL("Memo:\t")

"füge eine Leerzeile ein"

LF

"Der zuvor definierten Zelle c_memo wird der Wert der Variable VAR_P_MEMO zugewiesen."

SetCellText( c_memo, Get( VAR_P_MEMO ) )

"Ausgeben der Zelle c_memo."

DrawCell( c_memo, FALSE )

"Springe zum nächsten Datensatz."

result_p = NextRecord("P")

"Es wird geprüft, ob der Rückgabewert von result_p wahr ist, solange das der Fall ist, werden die folgenden Anweisungen durchgeführt, wenn nicht, wird die bedingte Programmanweisung übersprungen, das Formular wird nach dem Befehl "End If" weiter abgearbeitet.

if result_p then

PageBreak()

end if

"Ende der Programmschleife"

end while


anlagen pro

anlagenverwaltung pro

- das mehrplatzfähige Verwaltungsprogramm, mit dem Sie Ihre betrieblichen Anlagegüter am bequemsten abschreiben.


Befehlsreferenz

Befehlsreferenz


buchhalter pro

- das mehrplatzfähige Buchhaltungsprogramm, das Ihnen höchsten Buchungskomfort bei denkbar einfacher Anwendung bietet.


faktura pro

- das mehrplatzfähige Verwaltungsprogramm, das eine professionelle Fakturierung ebenso einfach wie effizient macht.


fehlzeiten pro

- das mehrplatzfähige Verwaltungsprogramm, mit dem Sie die Übersicht über alle anfallenden Fehlzeiten behalten.


Get_Object_Name

include "DruckNT.int"

'soll auch Druckausgabe erfolgen?

'description form_target as "COM"

Dim Excel As Object

Dim Sheet As Object

Dim Workbook as Object

Dim strObject As String

Dim nResult As Numeric

Dim strGesucht As String

Dim strGefunden As String

Dim strLastTime As String

strObject = "Excel.Application"

strGesucht = strObject

Excel = GetObject(strObject, nResult)

Excel.Visible = TRUE

' nResult auswerten

if nResult = 1 then ' Excel gefunden, ist schon aktiv!

strGefunden = strObject + " war bereits aktiv!"

end if

if nResult = 2 then ' Excel gefunden, ist aber noch nicht aktiv

strGefunden = strObject + " ist lokalisiert, aber noch nicht aktiv."

end if

if nResult <> 0 then ' nur fortfahren, falls kein Fehler auftrat

' füge eine Arbeitsmappe hinzu und schreibe ein paar Informationen hinein.

Workbook = Excel.Workbooks.Add

Sheet = Workbook.Worksheets(1)

Excel.Visible = TRUE

' Breite und Text für Spalte 1

Sheet.Columns(1).ColumnWidth = 20

Sheet.Cells(1,1).Value = "gesucht:"

Sheet.Cells(2,1).Value = "gefunden:"

Sheet.Cells(4,1).Value = "jetzt geöffnet:"

' Breite und Text für Spalte 2

Sheet.Columns(2).ColumnWidth = 25

Sheet.Cells(1,2).Value = strGesucht

Sheet.Cells(2,2).Value = strGefunden

Sheet.Cells(4,2).Value = "=jetzt()"

strLastTime = Sheet.Cells(4,2).Text

Sheet.Cells(4,2).Value = strLastTime

' Wenn Excel vorher nicht aktiv war, schließen

if nResult = 2 then

Excel.Quit

end if

ReleaseObject(Sheet)

ReleaseObject(Workbook)

ReleaseObject(Excel)

end if


Get_Object_Pfad

Include "DruckNT.int"

'soll auch Druckausgabe erfolgen?

'description form_target as "COM"

Dim Excel As Object

Dim Sheet As Object

Dim Workbook as Object

Dim strPfad As String

Dim nResult As Numeric

Dim strGesucht As String

Dim strGefunden As String

Dim strLastTime As String

strPfad = "Mappe1.xls" ' ...wird bei Bedarf um den Formularpfad ergänzt

strGesucht = strPfad

Workbook = GetObject(strPfad, nResult)

TL(strPfad)

if nResult = 1 then

strGefunden = strPfad + " war bereits aktiv in Excel!"

' Applikation zur Arbeitsmappe holen

Excel = Workbook.Application

Excel.Visible = TRUE

end if

if nResult = 2 then

strGefunden = strPfad + " ist lokalisiert, aber noch nicht aktiv in Excel."

Excel = Workbook.Application

Excel.Visible = TRUE

' Bisher ist Mappe1 ein namenloses Objekt in Excel. Jetzt öffnen und übernehmen!

Workbook = Excel.Workbooks.Open(strPfad)

Workbook = GetObject(strPfad, nResult)

end if

if nResult <> 0 then ' nur fortfahren, wenn kein Fehler auftrat

Workbook.Activate

Excel.Visible = TRUE

' Fülle ein paar Zellen in Excel mit Informationen über das Öffnungsverhalten

Sheet = Workbook.WorkSheets(1)

' Breite und Text für Spalte 1

Sheet.Columns(1).ColumnWidth = 20

Sheet.Cells(1,1).Value = "gesucht:"

Sheet.Cells(2,1).Value = "gefunden:"

Sheet.Cells(3,1).Value = "zuletzt geöffnet:"

Sheet.Cells(4,1).Value = "jetzt geöffnet:"

' Breite und Text für Spalte 2

Sheet.Columns(2).ColumnWidth = 25

Sheet.Cells(1,2).Value = strGesucht

Sheet.Cells(2,2).Value = strGefunden

' Der Zeitpunkt des letzten Öffnens

strLastTime = Sheet.Cells(4,2).Text

Sheet.Cells(3,2).Value = strLastTime

' aktuellen Zeitpunkt eintragen und anschließend in festen Text umwandeln

Sheet.Cells(4,2).Value = "=jetzt()"

strLastTime = Sheet.Cells(4,2).Text

Sheet.Cells(4,2).Value = strLastTime

ReleaseObject(Sheet)

ReleaseObject(Workbook)

ReleaseObject(Excel)

end if


loge pro

lohn + gehalt pro

- das mehrplatzfähige Abrechnungsprogramm, das Ihnen mit seinem Schritt-für-Schritt-Assistenten jederzeit zur Verfügung steht.


reisekosten pro

- das mehrplatzfähige Abrechnungsprogramm, das Reise- und Bewirtungskosten komfortabel und Zeit sparend abrechnet.


Schulung

Inhalt Schulung

Allgemeines

Grundlagen zum DruckNT Formulareditor

Die Skriptsprache

Zusätzlich finden Sie ein Lernbeispiel mit integrierten Kursformularen.

Lernbeispiele


SetPrintDevice Beispiel 1

Include "DruckNT.int"

' Mit den ersten Druckereinstellungen beginnen

' Die Druckereinstellungen müssen in einer lsp-Datei gespeichert sein !!

SetPrintDevice(1)

Dim i as numeric = 1

' Alle Druckausgaben zweimal durchlaufen

while i <=2 do

' Beim zweiten Durchlauf die Druckereinstellungen wechseln

if i = 2 then

SetPrintDevice(2)

end if

TL("Hier könnte eine vollständige Formularausgabe stehen!")

i = i + 1

end while


SetPrintDevice Beispiel 2

Include "DruckNT.int"

' ---------------------------------------------------------------------------

' Funktionen, die auf Events reagieren

' Eine Kopfzeile

function OnPrintHeader()

SetHeaderMargin( 200, 200, 290, 300)

SetFont("Arial", 14, FONT_BOLD, COLOR_BLACK)

DrawHorzLine(LINE_BOTTOM)

TL( "Kopfzeile" )

end function

SetEventHandler(EVENT_PRINT_HEADER, OnPrintHeader)

' Eine Fußzeile

SetFooterMargin( 200, 200, 800, 500)

function OnPrintFooter()

SetFont("Arial", 8, FONT_NORMAL, COLOR_BLACK)

SetTabs("R")

DrawHorzLine(LINE_TOP)

TL("(C) Lexware GmbH & Co. KG 1999\t" + FormatDate("%d.%m.%Y", Now()) )

end function

SetEventHandler(EVENT_PRINT_FOOTER, OnPrintFooter)

' EVENT_START_PAGE: Wechsel der Druckereinstellungen nach Auswertung der aktuellen Seitenzahl

function OnStartPage()

if GetPageNumber() = 2 then

SetPrintDevice(2)

end if

end function

SetEventhandler(EVENT_START_PAGE, OnStartPage)

' -------------------------------------------------------------------------

' Ausgabe des Seiteninhalts

' Druckereinstellungen für die erste Seite

' WICHTIG: Hiervor dürfen keine Druckbefehle stehen, sonst

' erfolgte ein überflüssiger Seitenwechsel!

SetPrintDevice(1)

SetBodyMargin( 200, 420, 150, 500 )

' Erzeugen einer Zahlenkolonne

' (Bei Erreichen von Seite 2 werden aufgrund der Funktion OnStartPage() die

' Druckereinstellungen geändert)

Dim i as numeric

while i < 80 do

TL(FormatNumeric("%.2f", i))

i = i + 1

end while


startseite

Willkommen bei Lexware professional

im Web

Lexware Homepage

Lexware Online Shop

Feedback senden