
 Travel Expense Help Index
How To ...

<<add your application-specific "how to" topics here>>

Commands
File menu
Record menu
View menu
Window menu
Help menu



File menu commands

The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Close Closes an opened document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Print Prints a document.
Print 
Preview

Displays the document on the screen as it would appear printed.

Print Setup Selects a printer and printer connection.
Exit Exits Travel Expense.



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple 
views of multiple documents in the application window:

New Window Creates a new window that views the same document.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Window 1, 
2, ...

Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays the version number of this application.



New command (File menu)

Use this command to create a new document in Travel Expense.

You can open an existing document with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing document in a new window.    You can open multiple 
documents at once.    Use the Window menu to switch among the multiple open documents.  
See Window 1, 2, ... command.

You can create new documents with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
*.exp

Drives
Select the drive in which Travel Expense stores the file that you want to open. 

Directories
Select the directory in which Travel Expense stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Close command (File menu)

Use this command to close all windows containing the active document.    Travel Expense 
suggests that you save changes to your document before you close it.    If you close a 
document without saving, you lose all changes made since the last time you saved it.    
Before closing an untitled document, Travel Expense displays the Save As dialog box and 
suggests that you name and save the document.

You can also close a document by using the Close icon on the document's window, as shown 
below:



Save command (File menu)

Use this command to save the active document to its current name and directory.    When 
you save a document for the first time, Travel Expense displays the Save As dialog box so 
you can name your document.    If you want to change the name and directory of an existing 
document before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active document.    Travel Expense displays the 
Save As dialog box so you can name your document.    

To save a document with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save a document with a different name.    A filename can contain 
up to eight characters and an extension of up to three characters.    Travel Expense adds 
the extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
documents you closed.    Choose the number that corresponds with the document you want 
to open.



Exit command (File menu)

Use this command to end your Travel Expense session.    You can also use the Close 
command on the application Control menu.    Travel Expense prompts you to save documents
with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in Travel Expense, such as File Open.    A check mark appears next
to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in Travel Expense,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

<< Add or remove toolbar buttons from the list below according to which ones your 
application offers. >>

Click To

Open a new document.

Open an existing document.    Travel Expense displays the Open dialog box, in which 
you can locate and open the desired file.

Save the active document or template with its current name.    If you have not named
the document, Travel Expense displays the Save As dialog box.

Print the active document.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the Travel Expense window.    To display or hide 
the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.



New command (Window menu)

Use this command to open a new window with the same contents as the active window.    You
can open multiple document windows to display different parts or views of a document at 
the same time.    If you change the contents in one window, all other windows containing the 
same document reflect those changes.    When you open a new window, it becomes the 
active window and is displayed on top of all other open windows.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped 
fashion.



Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main 
window.    If there is an open document window at the bottom of the main window, then 
some or all of the icons may not be visible because they will be underneath this document 
window.



1, 2, ... command (Window menu)

Travel Expense displays a list of currently open document windows at the bottom of the 
Window menu.    A check mark appears in front of the document name of the active window.  
Choose a document from this list to make its window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using Travel Expense and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of Travel 
Expense.



Context Help command 

Use the Context Help command to obtain help on some portion of Travel Expense.    When 
you choose the Toolbar's Context Help button, the mouse pointer will change to an arrow 
and question mark.    Then click somewhere in the Travel Expense window, such as another 
Toolbar button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

Travel Expense for Windows - Untitled 1<< Show your application's title bar here. >>

The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the Travel Expense window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    Travel Expense 
determines which window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    Travel Expense 
determines which window is previous according to the order in which you opened the 
windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the <<YourType>> window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Modifying the Document

Changes to the documents data modify the document using standard Windows procedures.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.





Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where 
you may specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that Travel Expense is sending output to the
printer.    The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When 
you choose this command, the main window will be replaced with a print preview window in 
which one or two pages will be displayed in their printed format.    The print preview toolbar 
offers you options to view either one or two pages at a time; move back and forth through 
the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

No additional page setup functions are available in this version.



  Travel Expense Help Index - Version 1.52
How To ...

Get Started:
Fill in the NAMES/RATES dialog box (located in the DATA drop down menu) with

the information requested using as many exchange rates as necessary.    PLEASE ENTER    1.0
FOR THE BASE CURRENCY EXCHANGE RATE.    The program automatically calculates all 
expenses in terms of the BASE CURRENCY to 2 decimal places.    Press SAVE after completing
each expense entry.    The INSERT button, located on many of the dialogues, places the entry
after the entry at which you are looking.    So, press INSERT and you will be shown a new, 
blank entry to fill in and when filled in, press SAVE and the transaction will be placed in the 
list after the one you saw before pressing INSERT.    The report, both screen and print, will put
entries in the order they show when cycling through the lists.    Within each list (i.e. 
Transport, Hotel, etc.) they can be automatically sorted by date (See SORTING below).    For 
manual sorting other than by date or Project/Client use the INSERT button.    Please note:    
Changing the BASE CURRENCY will result in cross rates being calculated, a very useful 
feature for some people some of the time.    However, cross rates necessarily involve 
rounding and the resulting rates may not be as accurate as ones you enter directly.    This is 
compounded by the number of times you calculate the cross rates.    If you do not need cross
rate calculations, so much the better.    This version can handle about 8-10 pages of output, 
so probably most trips will have to be divided into weeks.    Future versions will have more 
capacity.    The printing is not perfect, but adequate and will be improved in later versions.

Other points of interest:
--Please do not use commas when entering amounts in the expense boxes (or in the 

exchange rate boxes for that matter), with apologies to those parts of the world using 
commas where Americans use periods and vice versa.    Doing it all one way makes the 
program smaller and faster.

--Please remember to always place the BASE CURRENCY (that is the currency in 
which you want the expenses to be expressed, usually your home currency) in the list 
among the ten available currency rate boxes and give it a value of 1.0.    If you change the 
BASE CURRENCY (see discussion above and remember that it must be one of the ten 
currencies in the list), the new BASE CURRENCY will automatically be assigned the value 
1.0.    You just click on the BASE CURRENCY spin control to select the currency you want and 
then click on the OK button.

--If you see the WARNING Have you entered exchange rates for all transaction 
currencies?, that means you have probably tried to enter a transaction in Greece drachma 
when you do not have an exchange rate listed for that currency.    The program continues on 
and allows the listing of that transaction, but you will not see any exchange calculation and 
no amount is added to sub-totals or totals for expenses.    If you go to the NAMES/RATES 
dialog and enter an exchange rate for the currency in question, everything will be resolved.

--To choose a currency from the spin controls in all the dialog boxes you can use the 
up and down arrow keys or the mouse.    If you key in the first letter of the currency you 
want, the list jumps to the currencies that begin with that letter, thus speeding up the 
process of finding the right currency.    Continuing to hit the same letter cycles through all 
the currencies that begin with that letter.

--Please use the TAB key to move among the boxes within a dialog box.

-Choose screen and print fonts from the main (REPORT VIEW) screen only.    These 
screen and printer fonts will then be used for all reports (except the ROWVIEW screen) until 
you change them.    They will also be saved with the rest of the data and will be in use when 



you reopen a file.

Sorting

by Date

- IMPORTANT POINT: If you want to sort by date, the dates in the transaction dialog
boxes (that is all except the overall trip dates in the NAMES/RATES box) must be entered in 
the format mm/dd/yy and fill in zeros where appropriate.    So 9 April 1995 looks like 
04/09/95.    If you do not use that format, nothing dramatic will happen, but you will also not 
get a chronological date sort.

-Perform the date sort from the main (or REPORT) screen by pulling down the VIEWS 
menu, then press on SORTING and then BY DATE.    

by Project/Client

-Some have asked for a way to separate transactions by subsidiary company, client 
project etc.    In this version there are five sub accounts that can be used.    Simply mark the 
transaction for one of the numbers in the PROJECT/CLIENT box in each of the transaction 
dialogs and then, from the main (that is REPORT VIEW) screen press VIEWS, then SORTING, 
then BY PROJECT/CLIENT and a dialog box will appear offering you the chance to fill in the 
five sub account names (to correspond with the numbers you chose in the individual 
transaction records) and then press the radio button to the right of the sub account 
summary you wish to see.    You will get a view of the same kind of report as the main 
REPORT VIEW only containing that sub accounts transactions and appropriately labeled and 
headed.    You can print that report and then, from the menus choose another sub account 
report to view.    You can only have one sub account open for viewing and printing at the 
same time.    

-All of the transactions will appear in the main REPORT VIEW regardless of how you 
arrange the sub accounts and, of course, you are not obligated to indicate any sub accounts,
simply ignore that entry in each transaction dialog box.

-The sub account names will continue in the file (and be saved along with the other 
data) and will only change when you change them so you only have to enter them once.    It 
is much easier to use than to explain.      

Rowview

-Another new feature for this version is a ROWVIEW.    This can be reached from the 
main (REPORT VIEW) under the VIEWS menu.    ROWVIEW shows the entire list of transaction 
(no sub account sorting) in a simplified row view so that more of them fit on a screen.    
Clicking once on a transaction will highlight it and clicking twice on that transaction will call 
up the dialog box with that transaction for quick editing.    You can go forward or backward 
within the same category (i.e. HOTEL, MEALS, etc.) as you can in the main view directly from
that dialog box.    This view does not print.    Scrolling in this view is tricky and not yet perfect
so if it seems that you cannot highlight anything scroll back up to the top, click on the up 
scroll arrow a few times and everything should be back in line.

--Portions (c) Microsoft Corporation, 1985-1992,    All Rights Reserved.



Contact The Author:
The author, David D. Black, can be contacted via CompuServe 70670,3063 

with comments, suggestions, money, criticisms (if nicely put), and that is the only charge for
this version of the program.    The program was born of a frustration in finding a simple, 
efficient way of tracking business expenses while traveling around Asia.      Please send your 
thoughts!
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