Program Windows Media Encoder

Program Microsoft® Windows Media® Encoder 9 Series je výkonný nástroj pro převádění jak živého, tak předem natočeného zvuku a videa na soubory Windows Media nebo datové proudy Windows Media. Následující části obsahují informace týkající se procesu kódování a postupy pro používání programu Windows Media Encoder.

  • Začínáme. Vysvětluje, jak nastavit relaci kódování v několika krátkých krocích pomocí rychlých úvodů nebo Průvodce novou relací. Také popisuje změny v programu Windows Media Encoder, popisuje systémové požadavky a obsahuje informace o různých panelech, které tvoří uživatelské rozhraní.
  • Koncepty. Obsahuje obecné informace o práci s kodérem.
  • Konfigurační zdroje. Obsahuje informace o vstupních zdrojích podporovaných kodérem včetně souborů, zařízení, obrazovek a příkazů skriptu.
  • Vlastní úprava relace. Popisuje, jak konfigurovat novou relaci kódování nebo upravit existující relaci pro své potřeby.
  • Možnosti výstupu. Popisuje možnosti výstupu, které jsou k dispozici při kódování: kódování do souboru nebo vysílání živé události distribuce (odesíláním nebo načítáním).
  • Možnosti konfigurace systému. Popisuje možnosti konfigurace systému včetně zabezpečení kódujícího počítače, spuštění více instancí kodéru v počítači, kódování dávky a postupu, kterým dosáhnete optimálního výkonu systému.
  • Časté otázky a odstraňování problémů. Obsahuje odkaz na web společnosti Microsoft, kde je možné najít návrhy řešení situací, které mohou vzniknout při používání kodéru.
  • Funkce usnadnění pro osoby tělesně postižené. Obsahuje informace o funkcích, produktech a službách, které zpřístupňují Windows Media Encoder osobám tělesně postiženým.
  • Glosář. Obsahuje definice a termíny týkající se kodéru.
© 2000-2002 Microsoft Corporation. Všechna práva vyhrazena.


Začínáme

Tato část obsahuje návod pro vytvoření relace kódování v několika jednoduchých krocích pomocí rychlých úvodů nebo Průvodce novou relací. Obsahuje také informace o novinkách této verze programu Windows Media Encoder, požadavky funkcí, požadavky na hardware a software a popisy panelů, které tvoří rozhraní kodéru.

Příbuzná témata

  • Program Windows Media Encoder
  • Kódování pomocí rychlých úvodů nebo pomocí Průvodce novou relací
  • Co je nového
  • Požadavky funkcí
  • Požadavky na hardware a software
  • Druhy zobrazení kodéru
  • Nástroje kodéru
  • Typografické konvence v dokumentu


Kódování pomocí rychlých úvodů nebo pomocí Průvodce novou relací

Před kódování obsahu je třeba vytvořit relaci kódování. Nejsnadnější je použít rychlé úvody nebo Průvodce novou relací. Rychlé úvody jsou soubory s relacemi, které jsou součástí programu Windows Media Encoder. Jsou sestaveny tak, aby odpovídaly běžným scénářům kódování a obsahují již většinu nastavení, která jsou třeba, jestliže chcete kódovat ihned. Jediné, co je třeba upřesnit, jsou informace o vlastním obsahu, např. názvy souborů nebo serverů. Můžete také použít Průvodce novou relací, který vás provede všemi kroky, které jsou nezbytné pro vytvoření čtyř nejběžnějších scénářů kódování.

Rychlé úvody a Průvodce jsou k dispozici v dialogovém okně Nová relace (je-li povoleno), které se zobrazí po prvním spuštění kodéru, nebo klepnutím na tlačítko Nová relace na panelu nástrojů hlavního okna kodéru.

Po vytvoření relace kódování můžete spustit kódování obsahu. Budete-li chtít použít stejnou relaci znovu, můžete nastavení uložit do souboru s relací a použít později. Soubory s relacemi se ukládají s příponou WME.

Příbuzná témata

  • Začínáme
  • Použití rychlých úvodů pro kódování
  • Použití Průvodce novou relací pro kódování
  • Relace
  • Postup při otevírání existující relace
  • Postup při ukládání relace


Použití rychlých úvodů pro kódování

Rychlé úvody jsou soubory relací, které jsou součástí programu Windows Media Encoder. Jsou určeny pro běžné scénáře kódování a obsahují většinu nastavení, která umožňují, aby uživatel mohl začít ihned kódovat. Jediné, co musí uživatel zadat, jsou vlastní specifikace obsahu, např. názvy souborů nebo serverů.

Dostupné rychlé úvody obsahují tyto možnosti:

  • Digitalizace živého obsahu pro místní přehrávání. Slouží k digitalizaci živého obsahu ze zvukových zařízení, videozařízení a ke kódování do souboru. Obsah lze distribuovat tak, aby si jej uživatelé mohli stáhnout a přehrávat místně.
  • Digitalizace živého obsahu pro datový proud. Slouží k digitalizaci živého obsahu ze zvukových zařízení a videozařízení a k jeho kódování do souboru Windows Media.
  • Převedení filmového obsahu na video. Slouží k převedení obsahu souboru, ve kterém byl film uložen, do formátu Windows Media Format, který si mohou uživatelé stáhnout a přehrávat místně.
  • Vysílání podnikového jednání. Vysílá datový proud do adresáře pro publikování na serveru, na kterém běží služba Microsoft Windows Media Services.

Do seznamu rychlých úvodů můžete přidat libovolnou relaci, kterou chcete často používat.

Poznámka - obrázek Poznámka

  • Rychlé úvody spustíte z panelu nástrojů klepnutím na Nová relace, na kartu Rychlé úvody a potom klepnutím na libovolný rychlý úvod.

Příbuzná témata

  • Kódování pomocí rychlých úvodů nebo pomocí Průvodce novou relací
  • Postup při vytváření vlastního rychlého úvodu
  • Kódování CBR a VBR


Použití Průvodce novou relací pro kódování

Průvodce novou relací vás provede kroky, které je nutno provést při instalaci čtyř nejběžnějších kódovacích scénářů. Čtyři běžné scénáře:

  • Živé vysílání: Digitalizuje zvuk nebo video ze zařízení nainstalovaných v počítači a pak živě vysílá obsah buď odesíláním datového proudu serveru služeb Microsoft Windows Media, nebo povolením serverům a přehrávačům Windows Media načítat datový proud přímo z kodéru.
  • Digitalizace zvuku nebo videa: Digitalizuje zvuk nebo video ze zařízení nainstalovaných v počítači a převede digitalizovaný obsah do souboru Windows Media pro pozdější distribuci.
  • Převedení souboru: Převede zvukový soubor i videosoubor do formátu Windows Media pro pozdější distribuci.
  • Digitalizace obrazovky: Digitalizuje obraz obrazovky včetně pohybů ukazatele myši. Můžete digitalizovat celou obrazovku, její oblast nebo určité okno.

Změnit vlastnosti relace můžete spuštěním položky Průvodce novou relací nebo použít panel Vlastnosti. Budete-li chtít relaci použít znovu, uložte svá nastavení do souboru relací.

Poznámka - obrázek Poznámka

  • Chcete-li na panelu nástrojů otevřít položku Průvodce novou relací, klepněte na tlačítko Nová relace, a pak klepněte na tlačítko jednoho ze čtyř průvodců. Chcete-li nastavit vlastní relaci pro kódování, můžete použít příkaz Vlastní relace.

Příbuzná témata

  • Kódování pomocí rychlých úvodů a Průvodce novou relací
  • Postup při ukládání relace


Co je nového

Program Windows Media Encoder 9 Series obsahuje rozšíření, která jsou výkonná a jednoduše použitelná. Tato sekce obsahuje souhrn změn v této verzi kodéru.

  • Bylo zjednodušeno směrování různých scénářů kódování s přidáním nových míst. Navíc jsou dostupné čtyři rychlé úvody umožňující zahájit kódování bez prodlevy. Každý rychlý úvod je navržen tak, aby vyhovoval obecnému scénáři kódování.
  • Nové kodeky zlepšily kvalitu obsahu kódovaného zvuku a videa.
  • Podpora pro přetahování zdrojových souborů a souborů relací myší do okna kodéru umožňuje rychlé zahájení kódování.
  • Nové režimy kódování s konstantní přenosovou rychlostí (CBR) a variabilní přenosovou rychlostí (VBR) umožňují jemné nastavení v závislosti na požadovaném scénáři přehrávání.
  • Funkce ovládání zařízení umožňuje spouštět zařízení přímo z kodéru. (Toto zařízení musí být připojeno prostřednictvím digitálního portu pro video IEEE 1394, nebo můžete použít videorekordér podporující protokol Sony RS422 připojený k portu COM.) Můžete také použít vestavěný seznam pravidel střihu (EDL) k sestavení a kódování klipů v libovolném pořadí.
  • Je dostupné kódování vícekanálového zvuku díky kodekům Windows Media Audio 9 Professional a Windows Media Audio 9 Lossless.
  • Je k dispozici funkce správy digitálních práv (DRM) umožňující ochranu kódovaného obsahu.
  • Nová distribuční funkce odesílání umožňuje připojit se z kodéru k serveru Windows Media.
  • Podpora jazyků umožňuje určit jazyk obsahu.
  • Jsou zahrnuty čtyři programy poskytující další funkce, jako je vytváření vlastních profilů, rozdělování a spojování datových proudů v různých souborech a indexování souborů po kódování.
  • Dočasné uložení obsahu na pevný disk pomáhá zajistit kvalitu kódovaného obsahu.
  • Podpora převodních modulů plug-in umožňuje vývojářům upravovat obsah zvuku a videa, což lze využít k přidávání zvláštních efektů v průběhu kódování.
  • Byla implementována podpora zdrojů z dalších formátů souborů.
  • Podpora obdélníkových pixelů pomáhá kódování obsahu ve formátu Letterbox při zachování poměru souřadnic zdrojového videa.
  • Vytvářením nebo uchováváním časových kódů pro některé zdroje lze implementovat vyhledávání na úrovni snímků.
  • Obsah s více přenosovými rychlostmi (MBR) nyní podporuje více zvukových formátů a rozlišení videa.
  • Podpora funkce Plug and Play v systému Microsoft Windows® XP umožňuje automatickou detekci zařízení kodérem při spuštění. Navíc je kodér automaticky spuštěn při připojení nového zařízení k počítači.

Příbuzná témata

  • Začínáme
  • Použití rychlých úvodů pro kódování
  • Seznámení s kodeky
  • Kódování CBR a VBR
  • Použití zařízení jako zdroje
  • Použití vícekanálových zvukových souborů jako zdroje
  • Použití technologie DRM (Digital Rights Management) k ochraně obsahu
  • Vysílání obsahu živě
  • Nástroje kodéru


Požadavky funkcí

Následující tabulka obsahu informace o funkcích programu Windows Media Encoder, které mají specifické požadavky na přehrávač Microsoft Windows Media Player, operační systém nebo kodeky.

Funkce | Windows Media Player |  |  | Operační systémy | Kodeky
 | 6.4 | 7.1/Windows XP | 9 Series |  |
Prokládaný výstup videa |  |  | X | Microsoft Windows XP | Windows Media Video 9
Výstup obdélníkových pixelů |  |  | X |  |
Obsah MBR s více rozlišeními |  |  | X |  |
Zvuk MBR |  |  | X |  |
Podpora DRM | X | X | X |  |
Vícekanálový zvuk |  |  | X | Microsoft Windows XP | Windows Media Audio 9 Professional nebo Windows Media Audio 9 Lossless
Zvuk s vysokým rozlišením (24 bitů, 96 kHz)1 |  |  | X | Microsoft Windows XP | Windows Media Audio 9 Professional
Řízení dynamického rozsahu |  |  | X | Microsoft Windows XP | Windows Media Audio 9 Professional
Kódování CBR (jednofázové nebo dvojfázové) | X | X | X |  | Viz následující tabulka
VBR podle kvality |  | X | X |  | Viz následující tabulka
VBR podle přenosové rychlosti |  | X | X |  | Viz následující tabulka
VBR podle maximální přenosové rychlosti |  | X | X |  | Viz následující tabulka

1 Starší přehrávače nebo operační systémy budou obsah zobrazovat v rozlišení 16 bitů/48 kHz

Poznámka: Obsah kódovaný kodeky Windows Media Audio a Video 9 Series (vyjma kodeku Windows Media Audio 9) není podporován přehrávačem Windows Media Player verze 6.4. Před přehráváním obsahu kódovaném některým z uvedených kodeků v přehrávačích Windows Media Player verze 7.1 a Windows Media Player pro Windows XP musí uživatelé stáhnout příslušný kodek. V obsahu kódovaném metodou VBR kodekem Windows Media Audio 9 se mohou při přehrávání v přehrávači Windows Media Player verze 6.4 objevit rušivé impulsy nebo ticho. Při přehrávání obsahu kódovaném kodekem Windows Media Audio 9 v přehrávačích Windows Media Player verze 7.1 a Windows Media Player pro Windows XP není třeba kodek stahovat.

Následující tabulka obsahuje seznam podporovaných metod kódování pro kodeky, které jsou dodávány s kodérem.

Kodek | Jednofázové kódování CBR | Dvojfázové kódování CBR | VBR podle kvality | VBR podle přenosové rychlosti | VBR podle maximální přenosové rychlosti
Windows Media Audio 9 Professional | Ano | Ano | Ano | Ano | Ano
Windows Media Audio 9 Lossless | Ne | Ne | Ano | Ne | Ne
Windows Media Audio 9 | Ano | Ano | Ano1 | Ano1 | Ano1
Windows Media Audio 9 Voice | Ano | Ne | Ne | Ne | Ne
Windows Media Video 9 | Ano | Ano | Ano | Ano | Ano
Windows Media Video 8.1 | Ano | Ano | Ano | Ano | Ano
Windows Media Video 7 | Ano | Ano | Ano | Ano | Ano
Windows Media Video 9 Screen | Ano | Ne | Ano | Ne | Ne

1 Při přehrávání v přehrávači Windows Media Player verze 6.4 se mohou objevit rušivé impulsy nebo ticho.

Příbuzná témata

  • Začínáme
  • Kódování CBR a VBR


Požadavky na hardware a software

Nejnovější informace o požadavcích na hardware a software jsou k dispozici na několika webech:

  • Informace o požadavcích na systém naleznete na této stránce webu společnosti Microsoft.
  • Seznam podporovaných karet pro digitalizaci zvuku a videa najdete na této stránce věnované poskytovatelům hardwaru na webu společnosti Microsoft.
  • Seznam podporovaných přenosných zařízení najdete na této stránce webu společnosti Microsoft.

Příbuzná témata

  • Začínáme


Druhy zobrazení kodéru

Hlavní okno programu Windows Media Encoder obsahuje řadu panelů, které informují o aktuální relaci. Tyto panely se zobrazí během kódování v závislosti na typu kódovaného obsahu, počtu zdrojů nastavených pro aktuální relaci a předvolbách uživatele. Je možné zobrazit další panely nebo zobrazené panely skrýt. Všechny změny zobrazení hlavního okna se mezi relacemi ukládají.

  • Panel Vlastnosti. Obsahuje vlastnosti, které slouží k úpravě nastavení aktuální relace nebo k vytvoření vlastní relace.
  • Panel Video. Zobrazuje kódovaný obsah. Okno lze nastavit podle typu obsahu tak, aby zobrazovalo pouze obsah před kódováním, kódovaný obsah nebo obojí. V některých případech není zdrojový obsah nebo kódovaný výstup během kódování zobrazen.
  • Panel Zdroje. Zobrazuje všechny zdroje aktuální relace. Klepnutím na tlačítko příslušného zdroje lze během kódování zdroje přepínat.
  • Panel Zvuk. Obsahuje ovládací prvky pro sledování a nastavování hlasitosti kódovaného zvukového datového proudu.
  • Panel Zařízení. Zobrazí se, pokud je k počítači připojeno zařízení prostřednictvím portu IEEE 1394 nebo prostřednictvím portu COM videorekordér s podporou protokolu Sony RS422. Z tohoto panelu lze ovládat funkce zařízení přehrát, pozastavit, zastavit, rychle převinout vpřed, převinout zpět a vysunout. Také můžete vytvořit seznam pravidel střihu (EDL), podle kterého se budou automaticky kódovat určité časové intervaly obsahu z jedné nebo více videokazet.
  • Panel Sledování. Obsahuje informace o stavu relace.
  • Panel Skript. Tento panel se zobrazí, jestliže pro vytvořenou aktuální relaci povolíte jako typ zdroje skripty. Z tohoto panelu je možné vkládat skripty do datového proudu během kódování.

Chcete-li libovolný panel zobrazit nebo skrýt, klepněte na požadovaný panel v nabídce Zobrazit.

Příbuzná témata

  • Začínáme


Nástroje kodéru

Program Windows Media Encoder obsahuje čtyři nástroje:

  • Program Windows Media Profile Editor. Slouží k vytváření vlastních profilů používaných v relacích pro kódování.
  • Program Windows Media File Editor. Dříve se tento nástroj nazýval Windows Media ASF Indexer. Tento nástroj lze použít k úpravám souborů Windows Media. Můžete například oříznout začátek a konec souboru, přidat značky a příkazy skriptu, řídit dynamický rozsah zvukového obsahu, u vícekanálových zvukových souborů můžete také určovat skladbu kanálů při stereofonním přehrávání.
  • Program Windows Media Stream Editor. Tento nástroj slouží k rozdělování a spojování datových proudů v existujících souborech Windows Media za účelem vytváření nových souborů. Můžete například rozdělit soubor typu MBR (vícenásobná přenosová rychlost) do několika souborů se základní přenosovou rychlostí. Můžete také vytvořit několik souborů, se stejným obrazovým datovým proudem, avšak jiným zvukovým datovým proudem (například pro vytvoření jednoho souboru ve více jazycích).
  • Program Windows Media Encoding Script. Dříve se tento nástroj nazýval Windows Media Encoding Utility. Tento nástroj obsluhovaný z příkazového řádku (Wmcmd.vbs) lze používat ke kódování a vysílání obsahu. Je nainstalován ve stejné složce jako kodér, výchozí složkou pro instalaci je C:\Program Files\Windows Media Components\Encoder.

Příbuzná témata

  • Začínáme
  • Postup při spouštění nástrojů kodéru


Postup při spouštění nástrojů kodéru

  1. Klepněte na tlačítko Start, přejděte na příkaz Programy, dále na položku Windows Media a Nástroje.
  2. Klepněte na nástroj, který chcete použít.

Poznámka - obrázek Poznámka

  • Ze stejného místa lze spustit nápovědu k programu Windows Media Encoding Script.

Příbuzná témata

  • Nástroje kodéru


Typografické konvence v dokumentu

V tomto systému nápovědy je použito následujících typografických konvencí.

Konvence | Význam
Tučné písmo | Text, který je zobrazen v uživatelském rozhraní nebo je určen pro zadání do rozhraní přesně jak uvedeno.
Kurzíva | Zástupný text, který je třeba nahradit textem vhodným pro uživatelské prostředí.
Kód | Vzorový kód, který je třeba nahradit kódem vhodným pro uživatelské prostředí.

Příbuzná témata

  • Začínáme


Koncepty

Tato část obsahuje obecné informace o práci s programy řady Windows Media Encoder 9.

Příbuzná témata

  • Program Windows Media Encoder
  • Seznámení s kodeky
  • Relace
  • Srovnání serverů Windows Media a webových serverů
  • Kódování CBR a VBR
  • Jednofázové a dvojfázové kódování


Seznámení s kodeky

Při vysílání datového proudu nebo vytváření velkých souborů dokáže nekomprimovaný zvukový a obrazový obsah spotřebovat velkou část šířky pásma. Komprimovaný obsah lze vysílat s ohledem na běžnou šířku pásma v síti Internet nebo ukládat do souborů Windows Media, které budou mít přiměřenou velikost. Datový obsah lze komprimovat použitím komprimačních algoritmů. Přitom je nutné vzít v úvahu požadovanou výstupní kvalitu a dostupnou šířku pásma. Před přehráváním se obsah pomocí dekompresních algoritmů dekomprimuje. Tyto kompresní a dekompresní algoritmy se nazývají kodeky. V následující tabulce jsou uvedeny podrobnější informace o kodecích, které jsou k dispozici v programu Windows Media Encoder.

Kodek | Popis
Windows Media Audio 9 Professional | Umožňuje kódování plného prostorového zvuku a ovládání dynamického rozsahu. Podle konfigurace reproduktorů přehrávacího zařízení inteligentně dělí vícekanálový zvuk na dva kanály (stereo) nebo jeden kanál (mono). Je určen pro přenosové rychlosti od 128 do 768 kb/s.
Windows Media Audio 9 Lossless | Umožňuje bezztrátové kódování zvukového obsahu. Podporuje kódování vícekanálového zvuku a ovládaní dynamického rozsahu.
Windows Media Audio 9 | Nabízí o 20 procent lepší kompresi, než kodek Windows Media Audio 8. Podporujte kódování zvuku VBR.
Windows Media Audio 9 Voice | Nabízí vysokou kvalitu komprese zvukového obsahu se zvýrazněním hlasu. Podporuje smíšený režim kódování hlasu a hudby. Je určen pro přehrávání přenosovou rychlostí 20 kb/s nebo nižší.
Windows Media Video 9 | Vytváří vysoce kvalitní video pro vysílání, pro stažení s přehráním a pro scénáře vysílání ve fyzickém formátu. Nabízí o 15 až 50 procent lepší kompresi než kodek Windows Media Video 8.1, přičemž k nejvýraznějšímu zlepšení dochází při vyšších přenosových rychlostech. Umožňuje přehrávání prokládaného obsahu na televizorech a digitálních terminálech.
Windows Media Video 8.1 | Podporuje velké množství šířek pásma sítě. Před kódováním obsahu ruší prokládání.
Windows Media Video 7 | Uživatelům přehrávače Windows Media Player 7 umožňuje sledovat kódované video, aniž by bylo nejprve nutné stáhnout nejnovější kodeky. Nejlepší volba v případě, kdy výkon kódovacího počítače nedostačuje nárokům novějších kodeků Windows Media Video.
Windows Media Video 9 Screen | Nabízí dokonalejší zpracování stínovaného obrazu, pohybu na obrazovce a posunu při digitalizaci obrazovky. Podporuje jednofázové kódování CBR a VBR bez vynechávání snímků. Tento kodek je plně optimalizován pro scénáře živého vysílání i pro scénáře stažení a přehrání.

Poznámka - obrázek Poznámka

  • V některých případech se v seznamu kodeků může objevit kodek Sipro Labs ACELP. K této situaci dochází například po importu profilu, který byl vytvořen za použití programu Windows Media Encoder verze 7.1. V takovém případě doporučujeme použít náhradní kodek Windows Media Audio 9 Voice.

Příbuzná témata

  • Koncepty


Relace

Než začnete kódovat, musíte nastavit relaci kódování. V rámci nastavování relace musíte provést následující kroky:

  • Určete zdroj zvukového nebo obrazového obsahu. Zdrojem mohou být zařízení, soubory nebo soubory i zařízení. Můžete také provádět digitalizaci obrazovek přímo z pracovní plochy systému.
  • Zvolte si možnost výstupu. Vyberte si, zda chcete obsah vysílat, nebo zda jej chcete kódovat do souboru. Pokud chcete obsah vysílat, můžete nabízet datový proud na server Windows Media nebo povolit serverům Windows Media a přehrávačům vyžádat si datový proud z kodéru. Můžete se také rozhodnout archivovat kopii vysílání pro pozdější použití.

Před zahájením kódováním byste měli navíc zkontrolovat nastavení komprese a kvality. Budou použita výchozí nastavení, můžete však přizpůsobit nastavení svým potřebám. Pokud například plánujete distribuci obsahu pro stažení a přehrávání v počítači, budete chtít patrně použít kódování VBR zaměřené na rychlost přenosu a zajistit tak úroveň kvality zvuku a obrazu na vyšší přenosové rychosti.

Po určení zdroje obsahu a volbě výstupu existuje několik možností vlastní úpravy relace. Můžete například optimalizovat zvuk a obraz pro zlepšení kvality kódovaného obsahu.

Jakmile bude relace nakonfigurována tak, aby splňovala vaše potřeby, můžete zahájit kódování. Pokud chcete spouštět stejnou relaci znovu, můžete relaci uložit do souboru, a to před provedením kódování nebo i po něm.

Poznámka - obrázek Poznámka

  • Není nutné při každém kódování vytvářet novou relaci. Kodér poskytuje rychlé metody spuštění a Průvodce novou relací, který je zaměřen na nejběžnější scénáře kódování.

Příbuzná témata

  • Koncepty
  • Konfigurace zdrojů
  • Možnosti výstupu
  • Vlastní úprava relace
  • Kódování pomocí rychlých úvodů nebo pomocí Průvodce novou relací
  • Postup při ukládání relace


Srovnání serverů Windows Media a webových serverů

Obsah médií můžete přenášet do přehrávače ze serveru se spuštěnou službou Windows Media Services nebo z webového serveru. Lze použít server a přehrávač v síti Internet nebo intranet. Mohou být vzájemně odděleny serverem firewall. Server Windows Media je na rozdíl od standardního webového serveru určen především pro přenášení obsahu založeného na technologii Windows Media. Pokud se rozhodnete použít webový server, musíte si být vědomi rozdílů ve způsobech doručování obsahu, které mohou mít vliv na kvalitu přehrávání.

Servery Windows Media

Server Windows Media dávkuje doručování paketů na základě informací ze zpětné vazby, kterou přijímá při odesílání datového proudu do přehrávače. Pakety přijaté přehrávačem tímto způsobem budou s mnohem větší pravděpodobností zobrazovány plynuleji. Díky řízení použité šířky přenosového pásma se může k serveru připojit více uživatelů současně a všichni mohou přijímat datové proudy bez přerušování.

Obsah médií, který má být ze serveru Windows Media přenesen jako jednosměrový datový proud, může být kódován jako vícesměrový datový proud MBR (video s více přenosovými rychlostmi). Tato metoda poskytuje lepší kvalitu obsahu médií v případě, že síť je zahlcena. Přijímá-li přehrávač obsah médií kódovaný metodou MBR, datové proudy jsou přenášeny rychlostí, která nejvíce vyhovuje šířce pásma sítě. Proces volby vhodného datového proudu je řízen serverem Windows Media server a programem Windows Media Player, a uživateli je skryt.

Server Windows Media je navržen tak, aby při zahlcení sítě zabezpečil plynulost jednosměrného přenosu datových proudů nebo souborů. Dojde-li během vysílání k zahlcení sítě, datový proud je "zúžen", to znamená že se sníží frekvence snímků. Pokud nedojde ke zlepšení, přenos datového proudu videa je zastaven a je přenášena pouze zvuková část.

Webové servery

Server Windows Media je navržen tak, aby v co nejkratším čase načetl co největší množství dat. Tato metoda je upřednostňována při odesílání paketů obsahujících statické obrázky, text a skript webových stránek, není však nejvýhodnější při odesílání paketů obsahujících mediální datové proudy. Ty by měly být doručovány v reálném čase, nikoli ve velkých dávkách, a přehrávač by měl přijímat pakety bezprostředně před jejich vykreslením.

Webové servery nepodporují datové proudy MBR. Při přenosu souboru datovým proudem z webového serveru není sledována kvalita doručování a nelze provádět žádné změny přenosové rychlosti. Webové servery nemohou použít upřednostňovaný protokol doručování UDP (User Datagram Protocol), a je tedy pravděpodobnější výskyt přerušování chvílemi ticha, kdy přehrávač načítá data do vyrovnávací paměti. Webové servery také neumožňují přenosy živého vysílání datovým proudem a vysílání Multicast.

Poznámka - obrázek Poznámka

  • Služba Windows Media Services 9 Series serveru Windows .NET Server 2003 zahrnuje několik funkcí nazývajících se Vysílání rychlých datových proudů, které mohou kombinovat některé výhody stahování a vysílání datových proudů. Více informací o metodě Vysílání rychlých datových proudů naleznete v nápovědě služby Windows Media Services.

Příbuzná témata

  • Koncepty
  • Možnosti výstupu


Kódování CBR a VBR

Program Windows Media Encoder umožňuje použít pro kódování zvukového a obrazového obsahu konstantní (CBR) nebo variabilní (VBR) přenosovou rychlost.

Kódování CBR

Kódování CBR lze optimálně využít ve scénáři pro vysílání datového proudu. Při použití tohoto kódování zůstává přenosová rychlost po celou dobu vysílání proudu poměrně stabilní a díky nastavenému časovému intervalu vyrovnávací paměti se udržuje blízko cílové přenosové rychlosti. Nevýhodou kódování CBR je nestálá kvalita kódovaného obsahu. Protože se některé položky obsahu hůře komprimují než ostatní, jsou některé části proudu CBR méně kvalitnější než ostatní. Navíc se nestálá kvalita kódování CBR přenáší z jednoho proudu do ostatních. Obecně platí, že výkyvy kvality jsou méně patrné při nižších přenosových rychlostech.

Kódování VBR

Kódování VBR je vhodné, pokud chcete distribuovat obsah pro stažení a místní přehrávání nebo pro přehrávání v zařízení s omezenou rychlostí načítání, například v přehrávači CD nebo DVD. (Chcete-li obsah vysílat formou datového proudu, můžete rovněž použít režim kódování VBR při maximální přenosové rychlosti.) Kódování VBR je nejvhodnější pro kódování obsahu, který se skládá z jednoduchých i složitých dat, např. rychlého a pomalého videa. Při kódování VBR spotřebují méně složité části obsahu automaticky méně bitů. Díky tomu zbývá dostatek bitů, které mohou zajistit dobrou kvalitu složitějších částí. To znamená, že výhody kódování VBR nelze využít například u obsahu, jehož složitost je stabilní (např. záznamu televizní diskuse). V porovnání s kódováním CBR vzniká při použití kódování VBR u obsahu se smíšenou složitostí daleko lepší kódovaný výstup při stejné velikosti souboru. V některých případech může být konečná kvalita souboru kódovaného v režimu VBR stejná, jako u souboru kódovaného v režimu CBR, avšak při poloviční velikosti souboru.

Možnosti režimů kódování

V režimu CBR je k dispozici jednofázové nebo dvojfázové kódování. V režimu VBR jsou tři možnosti kódování: jednofázové VBR podle kvality, dvojfázové podle přenosové rychlosti a dvojfázové VBR podle maximální přenosové rychlosti. Režim VBR nebo dvojfázový režim CBR nejsou podporovány všemi kodeky.

Příbuzná témata

  • Koncepty
  • Používání kódování CBR
  • Používání kódování VBR
  • Jednofázové a dvojfázové kódování
  • Požadavky funkcí


Jednofázové a dvojfázové kódování

V programu Windows Media Encoder můžete provádět jednofázové nebo dvojfázové kódování, a to buď metodou CBR, nebo metodou VBR. (Metoda VBR zaměřená na kvalitu je jednofázová; kódovací režimy VBR zaměřené na přenosovou rychlost a nejvyšší přenosovou rychlost jsou dvojfázové.)

Při jednofázovém kódování prochází obsah kodérem jen jednou a ihned se provádí komprese obsahu. Při dvojfázovém kódování je obsah v průběhu první fáze analyzován a poté v druhé fázi kódován na základě údajů nashromážděných z první fáze. Dvojfázové kódování může znamenat vyšší kvalitu obsahu, protože kodér věnuje čas nalezení optimální kombinace přenosové rychlosti, frekvence snímků, velikosti vyrovnávací paměti a kvality obrazu podle kompozice scény. Dvojfázové kódování však trvá déle, protože musí projít celý obsah dvakrát.

Dvojfázové kódování nelze využít v následujících případech:

  • Jedná se o vysílání datového proudu.
  • V relaci je více zdrojů.
  • Je nastaveno opakování zdroje.
  • V datovém proudu jsou obsaženy příkazy skriptu.
  • Obsah zdroje pochází ze zařízení a není přístupné ovládání tohoto zařízení.
  • Zdrojový soubor má název s příponou BMP.

Seznam kodeků podporujících dvojfázové kódování naleznete v části Požadavky pro funkce.

Poznámka - obrázek Poznámka

  • Pokud používáte dvojfázové kódování, neuvidíte při první fázi v kodéru výstupní video.

Příbuzná témata

  • Koncepty
  • Kódování CBR a VBR
  • Povolení ovládání zařízení


Konfigurace zdrojů

Program Windows Media Encoder umožňuje kódování živého obsahu v reálném čase, kódování uloženého obsahu nebo digitalizaci obrazovky. Mezi zdroje obsahu v reálném čase patří vše, co lze připojit ke zvukové nebo grafické kartě, včetně přehrávače CD, mikrofonu, videorekordéru, videokamery, videopřehrávače nebo televizoru. Uložené zdroje představují zvukové soubory nebo videosoubory. Můžete také digitalizovat zobrazení přímo z pracovní plochy počítače a během kódování vkládat příkazy skriptu.

Uvědomte si, že čím je vyšší kvalita zdrojového obsahu, tím je vyšší kvalita výstupního obsahu. To znamená, že je třeba začít s co nejkvalitnějším zdrojovým souborem nebo, v případě načítání ze zdrojových zařízení, nastavit digitalizační zařízení na nejvyšší možnou kvalitu.

Při konfigurování zdroje nejprve určete typy zdrojů (zvuk, video nebo skript), ze kterých se zdroj skládá. Zdroj musí obsahovat alespoň jeden typ zdroje zvuku nebo videa. Do relace kódování je možné přidat neomezené množství zdrojů, a to buď před nebo po začátku kódování. Každý další zdroj bude nicméně vycházet z kombinace typů zdrojů, které jste v relaci vytvořili. Pokud například první zdroj obsahoval pouze zvuk, potom budou všechny další zdroje v relaci vycházet pouze ze zvuku. Pro relace s více zdroji doporučujeme nakonfigurovat první zdroj tak, aby byly použity všechny tři typy zdrojů. Pokud ostatní zdroje některý typ zdroje nepoužívají, je možné pro daný typ zdroje kódovat prázdný datový proud.

Příbuzná témata

  • Program Windows Media Encoder
  • Používání souboru jako zdroje
  • Použití vícekanálových zvukových souborů jako zdroje
  • Použití zařízení jako zdroje
  • Digitalizace obrazovek
  • Vkládání příkazů skriptu
  • Použití více zdrojů v jedné relaci


Používání souboru jako zdroje

Program Windows Media Encoder umožňuje používat jako zdrojové soubory s příponami WMA, WMV, ASF, AVI, WAV, MPG, MP3, BMP a JPG. (Chcete-li jako zdroj použít soubor s příponou MPG, je třeba, aby byl v kódovacím počítači nainstalován kompatibilní dekodér MPEG-2.)

Jestliže kódujete soubor Windows Media, budou všechny atributy hlavičky související s daným souborem (například značky, příkazy skriptu, atd.) během zpracování ztraceny. Atributy název, autor, autorská práva a popis je možné přidat zpět do souboru pomocí nástroje Windows Media File Editor.

Při používání souboru jako zdroje můžete upravit čas spuštění a ukončení souboru a zajistit, že se zakóduje pouze požadovaná část souboru.

Další informace o získání dekodéru MPEG-2 získáte na webu společnosti Microsoft.

Poznámka - obrázek Poznámka

  • Soubory, které obsahují obrázky, jejichž rozměrem je liché číslo, nejsou podporovány. Například obrázek velikosti 300 x 321 pixelů není podporován, ale obrázek velikosti 300 x 320 pixelů je podporován.

Příbuzná témata

  • Konfigurace zdrojů
  • Postup při používání souboru jako zdroje


Postup při používání souboru jako zdroje

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Zdroje.
  2. V části Zdroj klepněte na položku Soubor.

    -nebo-

    Chcete-li používat jako zdroje zvuku a videa dva odlišné soubory, klepněte na položku Zařízení i soubor.

  3. Klepněte na příkaz Procházet a vyhledejte zdrojový soubor.
  4. Chcete-li zkrátit začátek nebo konec souboru, klepněte na položku Začátek a konec. Bude zakódována pouze zbývající část souboru.
  5. Chcete-li kódovat pouze zvukovou nebo pouze obrazovou část souboru, zrušte zaškrtnutí políčka Video nebo Zvuk.

Poznámka - obrázek Poznámka

  • Zdrojový soubor lze do kodéru také přetáhnout.

Příbuzná témata

  • Používání souboru jako zdroje


Použití vícekanálových zvukových souborů jako zdroje

Program Windows Media Encoder umožňuje kódování vícekanálového zvuku, tzn. že uživatel může kódovat zvuk pro prostorovou reprodukci v šesti (zvukový formát 5.1) nebo osmi (zvukový formát 7.1) kanálech. Tento formát je speciálně určen pro CD, DVD, televizory s vysokým rozlišením a programy pro zpracování zvuku digitálních systémů domácího kina. Zdrojem obsahu musí některý z uvedených zdrojů:

  • Jeden šestikanálový nebo osmikanálový soubor ve formátu WAVE_FORMAT_EXTENSIBLE. Další informace najdete na webu společnosti Microsoft. Jestliže používáte jako zdroj osmikanálový soubor, doporučujeme, aby se shodovala vzorkovací frekvence a množství bitů na vzorek u zdrojového souboru a u kódovaného obsahu.
  • Šest monofonních souborů WAV. Chcete-li vytvořit soubory, použijte program pro úpravu zvuku a rozložte zdrojový zvuk do šesti zvukových souborů, pro každý kanál jeden soubor. Při nastavování zdroje v kodéru určete, ke kterým kanálům jsou jednotlivé soubory přiřazeny. Velikost žádného WAV souboru nesmí přesáhnout 2 GB. Tato možnost není k dispozici pro zvukový formát 7.1.
  • Stávající vícekanálový soubor Windows Media Audio. Použijte stávající soubor a proveďte kódování pro jinou přenosovou rychlost. Jestliže kodér není spuštěn v počítači s operačním systémem Windows 2000, nelze kódování stávajícího vícekanálového souboru Windows Media Audio provést.

Pro kódování vícekanálového obsahu je třeba použít buď kodek Windows Media Audio 9 Professional nebo kodek Windows Media Audio 9 Lossless a zvukový formát, který podporuje vícekanálové kódování. Uživatel, který chce obsah přehrát, musí navíc používat operační systém Microsoft Windows XP a přehrávač, který vychází ze sady Windows Media Format 9 Series Software Development Kit (SDK). V opačném případě bude zvuk automaticky rozdělen do dvou kanálů pro stereofonní reproduktory.

Kodér automaticky dělí kanály do dvou kanálů pro přehrávání prostřednictvím stereofonních reproduktorů. Jestliže kódujete zvuk ve formátu 5.1, můžete na kartě Zpracování panelu Vlastnosti nastavit rozdělení mezi prostorový, středový a basový kanál. Jestliže jste zakódovali obsah do souboru, můžete pro nastavení kanálového rozdělení u výstupního souboru použít také nástroj Windows Media File Editor.

Příbuzná témata

  • Konfigurace zdrojů
  • Postup při používání vícekanálových zvukových souborů jako zdroje
  • Postup při používání souboru jako zdroje


Postup při používání vícekanálových zvukových souborů jako zdroje

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Zdroje.
  2. V části Zdroj klepněte na položku Zařízení.
  3. V části Zvuk klepněte na položku Zdroj vícekanálového souboru WAV a potom na příkaz Konfigurovat.
  4. Zadejte zdrojový WAV soubor pro každý kanál.
  5. Klepněte na kartu Komprese.
  6. V části Cíl klepněte podle scénáře přehrávání na jednu z položek Stažení souboru, Hardwarová zařízení, Server Windows Media nebo Webový server.
  7. V části Zvuk klepněte na položku Vícekanálový zvuk.
  8. Klepněte na příkaz Upravit a potom na tabulku přenosových rychlostí.
  9. V části Formát zvuku klepněte na zvukový formát 5.1 nebo 7.1, který chcete použít.

Poznámka - obrázek Poznámka

  • Kodér automaticky dělí kanály do dvou kanálů pro přehrávání prostřednictvím stereofonních reproduktorů. Jestliže kódujete zvuk formátu 5.1, můžete na kartě Zpracování upravit výchozí rozdělení distribuce.

Příbuzná témata

  • Použití vícekanálových zvukových souborů jako zdroje


Použití zařízení jako zdroje

Při načítání obsahu ze zdrojových zařízení je třeba nejdříve zvolit zvuková nebo obrazová zařízení, která chcete používat. Po zvolení zařízení je možné nastavit jejich vlastnosti přímo z kodéru. Nastavení vlastností některých zařízení, jako např. zvukových nebo grafických karet, jsou globální a nevztahují se pouze na všechny zdroje v relaci kódování, ale na všechny programy v počítači. (Například jas, kontrast, formát zachytávaných dat a nastavení směšovače zvuku.)

Během relace je možné digitalizační zařízení a karty použít pouze jednou. Například vytvoříte-li dva zdroje (prvním zdrojem je živý záznam, ve kterém mluvčí představuje nové video, a druhým zdrojem je zmíněné video), je třeba pro každý zdroj použít samostatnou kartu a zařízení.

Některá zařízení lze ovládat přímo z kodéru. Je-li povoleno ovládání zařízení, můžete vytvořit seznam pravidel střihu (EDL), ve kterém označíte části videokazety, které chcete kódovat.

Konfiguraci zvukových a grafických zařízení je možné provádět pomocí Průvodce novou relací, panelu Vlastnosti, nebo příkazem Konfigurovat zařízení v nabídce Nástroje. Aby bylo možné zařízení konfigurovat z kodéru, musí být nainstalována v počítači. Pomocí kodéru nelze přidávat ani odebírat hardware. Pro tento účel použijte Ovládací panely.

Je-li v počítači nainstalována podporovaná karta tuneru TV, je možné pomocí kodéru měnit televizní kanály.

Příbuzná témata

  • Konfigurace zdrojů
  • Povolení ovládání zařízení
  • Vytvoření seznamu EDL
  • Postup při používání zařízení jako zdroje
  • Postup při změně kódovaného televizního kanálu


Postup při používání zařízení jako zdroje

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Zdroje.
  2. V části Zdroj klepněte na položku Zařízení.
  3. V částech Video a Zvuk klepněte na zařízení, která chcete použít jako zdroje.

Příbuzná témata

  • Použití zařízení jako zdroje


Postup při změně kódovaného televizního kanálu

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom na kartu Zdroje.
  2. V části Zdroj klepněte na položku Zařízení.
  3. V části Video klepněte na kartu televizního tuneru, který chcete použít jako zdroj.
  4. Klepněte na příkaz Konfigurovat.
  5. V části Kanál zadejte kanál, která chcete kódovat.
  6. V části Vstupy vyberte jako možnost tuner a klepněte na tlačítko OK.
  7. V části Zvuk klepněte na digitalizační kartu, která je nakonfigurována pro práci s kartou televizního tuneru.

Příbuzná témata

  • Použití zařízení jako zdroje


Povolení ovládání zařízení

Funkce ovládání zařízení umožňuje spouštět různé typy zařízení přímo z kodéru. Ovládání zařízení umožňuje pracovat s funkcemi zařízení přehrávání, pozastavení, zastavení, rychlé převíjení vpřed, převíjení zpět a vysunutí z kodéru. Chcete-li povolit ovládání zařízení, musí být toto zařízení připojeno k portu digitálního videa IEEE 1394 nebo lze použít videorekordér s podporou protokolu Sony RS422, který je připojen prostřednictvím portu COM. Také můžete použít integrovaný seznam pravidel střihu (EDL) ovládací funkce zařízení pro uspořádání a kódování klipů v libovolném pořadí.

Jestliže jste povolili ovládání zařízení a provedli následující kroky, můžete použít dvojfázové kódování:

  • Zvolili jste možnost kódování do souboru
  • Zvolili jste možnost dočasného uložení obsahu
  • Vytvořili jste pro obsah seznam EDL

Poznámka - obrázek Poznámka

  • Jestliže zařízení, které používáte v relaci, není zobrazeno v dialogovém okně Konfigurovat zařízení , zavřete toto dialogové okno, klepněte na tlačítko Použít a potom znovu dialogové okno otevřete.

Příbuzná témata

  • Použití zařízení jako zdroje
  • Vytvoření seznamu EDL
  • Postup při dočasném ukládání digitalizovaného obsahu
  • Postup při povolování ovládání zařízení


Postup při povolování ovládání zařízení

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom na kartu Zdroje.
  2. V části Zdroj klepněte na položku Zařízení.
  3. V částech Video a Zvuk klepněte na zařízení, které chcete použít jako zdroj.

    Jestliže zařízení není uvedeno v seznamu, zkontrolujte, zda je zapnuté. Po zapnutí zařízení bude pravděpodobně nezbytné kodér ukončit a znovu spustit.

  4. Klepněte na tlačítko Použít.
  5. Na panelu Zařízení klepněte na položku Nastavení.
  6. Vyberte ze seznamu zařízení nebo port COM, prostřednictvím kterého je zařízení připojeno, a potom klepněte na tlačítko OK.
  7. K ovládání zařízení použijte ovládací prvky panelu.

Poznámka - obrázek Poznámka

  • Chcete-li pomocí kodéru ovládat digitální zařízení, musí být toto zařízení přepnuto do režimu videorekordér. Videorekordéry musí být přepnuty do režimu TC.

Příbuzná témata

  • Povolení ovládání zařízení


Vytvoření seznamu EDL

Jestliže je povoleno ovládání zařízení, můžete pomocí časového razítka přesně určit požadovaný začátek a konec kódování obrazového a zvukového obsahu. Chcete-li tuto možnost využít, je třeba vytvořit seznam pravidel střihu (EDL), ve kterém jsou určeny části nahrávky, které se mají kódovat.

Nedoporučujeme používat seznam EDL pro vysílání, protože kodér vyžaduje během kódování čas navíc pro vyhledání bodů EDL. Během vysílání může docházet k nadměrnému ukládání do vyrovnávací paměti přehrávače.

Do seznamu EDL můžete přidat libovolný počet položek v libovolném pořadí – položky nemusí být na seznamu v pořadí, ve kterém se nacházejí na videokazetě. Lze také vytvořit seznam EDL, který obsahuje zdroje z několika různých videokazet. Během relace kódování budete kodérem v příslušnou dobu vyzváni, abyste videokazetu vyměnili.

Při vytváření seznamu EDL je třeba použít videokazetu se zaznamenaným časovým kódem. Chcete-li videokazetu opatřit časovým kódem, nahrajte ji po zakoupení souvisle od začátku až do konce. Tím je zajištěno, že je časový kód na videokazetě souvislý. Pokud videokazeta není opatřena časovým kódem, bude zařízení pokaždé, když pro něho vytvoříte seznam EDL, generovat nový časový kód.

Příbuzná témata

  • Použití zařízení jako zdroje
  • Povolení ovládání zařízení
  • Postup při vytváření seznamu EDL


Postup při vytváření seznamu EDL

  1. Vytvořte relaci pro ovládání zařízení, která bude zakódována do souboru.
  2. V nabídce Zobrazit klepněte na položku Panel Sledování a potom na kartu Seznam EDL.
  3. Klepněte na příkaz Upravit seznam EDL.
  4. Klepnutím na příkaz Přehrát v části Zařízení spusťte přehrávání videokazety.

    Spuštění přehrávání videokazety od určitého bodu lze provést také pomocí dalších ovladačů přehrávání, např. tlačítky Hledat a Rychle převinout vpřed.

  5. Po vyhledání požadovaného snímku klepněte na položku Začátek. Tento snímek bude nastaven jako počáteční bod klipu.

    Přehrávání videokazety bude pokračovat.

  6. Na snímku, který chcete nastavit jako koncový bod klipu, klepněte na položku Konec.
  7. Používáte-li několik videokazet, zadejte do políčka ID kazety jednoznačné označení ID (např. 1, 2, 3 nebo A, B, C).
  8. Klepnutím na příkaz Přidat položku EDL přidejte klip do seznamu pravidel střihu (EDL).
  9. Na klip, který chcete upravit, klepněte v seznamu a potom klepněte na tlačítko Upravit.
  10. Opakováním kroků 4 až 8 přidejte další klipy.
  11. Jste-li s úpravami seznamu spokojeni, klepněte na tlačítko OK a potom klepněte na příkaz Spustit kódování na panelu nástrojů.

    Během kódování se na kartě Seznam EDL panelu Sledování zobrazují informace o stavu klipů.

Příbuzná témata

  • Vytvoření seznamu EDL
  • Postup při povolování ovládání zařízení
  • Postup při kódování do souboru


Digitalizace obrazovek

Je možno digitalizovat celou plochu obrazovky, jednotlivá okna, nebo oblast na obrazovce a vysílat obrazovku nebo ji kódovat do souboru stejně jako jakýkoli jiný obsah. Funkci digitalizace obrazovky lze používat pro:

  • digitalizaci ze souborů AVI vytvořených programy pro digitalizaci obrazovky od jiného dodavatele,
  • digitalizaci okna (nebo celé obrazovky) přímo z prostředí pracovní plochy systému,
  • digitalizaci z karty, která je připojena k zařízení pro převod skenování.

Když digitalizujete okno, můžete ukládat relaci pro pozdější použití. Pamatujte však, že nadpis okna a jeho souřadnice budou uloženy spolu s dalšími konfiguračními informacemi do souboru relace. Když znovu načtete soubor relace pro další relaci digitalizace obrazovky, bude kodér sledovat okno, které odpovídá uloženému nadpisu. Pokud takové okno nebude nalezeno, bude digitalizováno okno, které odpovídá uloženým souřadnicím.

Pokud digitalizujete celou obrazovku a ukládáte relaci, bude do souboru relace uložena velikost obrazovky a nastavení barev. Pokud se po uložení relace rozhodnete změnit velikost nebo barvu obrazovky, musíte vytvořit novou relaci, která tato nastavení zahrne.

Pokud se v průběhu digitalizace okna nebo celé obrazovky zobrazí spořič obrazovky, bude tento spořič obrazovky kódován. Proto doporučujeme, abyste při digitalizaci okna nebo obrazovky spořič vypnuli.

Poznámka - obrázek Poznámky

  • Pokud převodník skenování zpracovává analogový signál a převádí jej do formátu NTSC, mohou se objevit artefakty. Tyto artefakty budou při kódování zesíleny a mohou snížit kvalitu kódovaného videa.
  • Po dokončení digitalizace obrazovky nezapomeňte klepnout na tlačítko Zastavit kódování na panelu nástrojů. Pouhým minimalizováním digitalizovaného okna relaci kódování neukončíte.

Příbuzná témata

  • Konfigurace zdrojů
  • Zvýšení výkonu při kódování obrazovek
  • Postup při kódování souboru AVI s obsahem obrazovky
  • Postup při digitalizaci obrazovky počítače


Zvýšení výkonu při kódování obrazovek

Vzhledem k objemu zpracovávaných dat a zatížení procesoru je digitalizace obrazovky proces, který vyžaduje vysoký výkon. Chcete-li, aby se digitalizovaný obraz kódoval a přehrával správně, dodržujte následující zásady:

  • Používejte rychlý procesor.
  • Používejte kodek Windows Media Video 9 Screen.
  • Nastavte nižší velikost zobrazení monitoru. Například při digitalizaci zobrazení v rozlišení 1024 x 768 se vytvoří větší množství dat, než při digitalizaci zobrazení v rozlišení 640 x 480.
  • Nastavte 16bitový nebo 8bitový režim zobrazení barev. Chcete-li ještě lépe využít procesor, nastavte kodér na barevný režim 256 barev. Nezapomeňte, že při provozu v režimu 256 barev může při přepínání mezi programy s různými barevnými schématy docházet ke změnám palety. Kodér nepodporuje změny palety při digitalizaci obrazovky v reálném čase. Z tohoto důvodu je nutné použít 16bitový režim barev nebo nejprve zachytit obrazovku do souboru AVI a potom jej převést do formátu Windows Media.
  • Používejte nízkou frekvenci snímků. Při určování požadované frekvence snímků je obvykle nutné vyzkoušet různá nastavení.
  • Digitalizujte menší obraz.
  • Používejte vyšší přenosovou rychlost.
  • Vyhněte se opakovaným změnám scény, např. rychlému otevírání a zavírání oken během digitalizace.
  • V případě scénáře s dvěma monitory digitalizujte obrazovku nebo její části pouze na primárním monitoru.
  • Vypněte hardwarové urychlování. (Hardwarové urychlování však zapněte po dokončení digitalizace obrazovky, aby bylo možné s ostatními programy dosáhnout nejlepších výsledků.)
  • Ukončete všechny videoprogramy, které nepoužíváte.
  • Nastavte stejnou výstupní velikost snímku jako u zdrojového videa. Neměňte velikost zdrojového videa v kodéru.

Příbuzná témata

  • Digitalizace obrazovek
  • Požadavky na hardware a software


Postup při kódování souboru AVI s obsahem obrazovky

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Zdroje.
  2. V části Zdroj klepněte na položku Soubor a zadejte název souboru AVI.
  3. Klepněte na kartu Komprese.
  4. V části Cíl klepněte podle vlastního scénáře přehrávání buď na položku Server Windows Media nebo Webový server.
  5. V části Video klepněte na položku Digitalizace obrazovky.
  6. Klepněte na tlačítko Použít a potom klepněte na příkaz Spustit kódování na panelu nástrojů.

Poznámka - obrázek Poznámka

  • Při digitalizaci ze souborů AVI, které byly vytvořeny pomocí nástroje na digitalizaci obrazovky jiného výrobce, použijte pro soubory, které chcete později pomocí kodéru konvertovat, kompresi typu RLE nebo formáty bez RGB komprese.

Příbuzná témata

  • Digitalizace obrazovek


Postup při digitalizaci obrazovky počítače

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Zdroje.
  2. V části Zdroj klepněte na položku Zařízení.
  3. V části Video klepněte na položku Digitalizace obrazovky a potom na příkaz Konfigurovat. Určete oblast nebo obrazovku, kterou chcete digitalizovat.
  4. Klepněte na kartu Komprese.
  5. V části Cíl klepněte podle vlastního scénáře přehrávání buď na položku Server Windows Media nebo Webový server.
  6. V části Video klepněte na položku Digitalizace obrazovky.
  7. Klepněte na tlačítko Použít a potom klepněte na příkaz Spustit kódování na panelu nástrojů.

    Okno kodéru se během kódování minimalizuje. Používáte-li jako zdroj kódování soubor, obvykle se kodér při obnovení okna pozastaví. Pokud se ale v relaci digitalizace obrazovky používá ještě další soubor jako zdroj zvuku, potom se při obnovení okna kodér nepozastaví. V případě relace vysílání bude kódování pokračovat i po obnovení okna kodéru. Chcete-li kódování zastavit nebo pozastavit, klepněte na tlačítko kodéru na hlavním panelu Windows. Potom klepněte na příkaz Zastavit kódování nebo Pozastavit kódování na panelu nástrojů.

Příbuzná témata

  • Digitalizace obrazovek


Vkládání příkazů skriptu

Příkazy skriptu lze vkládat do datového proudu během kódování. Kodér podporuje následující typy příkazů skriptu:

  • Titulky. Textové řetězce libovolného formátu, které se zobrazují v přehrávači společně s kódovaným obsahem. Aby byly titulky viditelné, musí být v přehrávačích uživatelů povoleno zobrazování titulků.
  • Skryté titulky. Pokud digitalizační karta uživatele podporuje data skrytých titulků, lze titulky kódovat.
  • Adresy URL. Při vložení tohoto příkazu do datového proudu se otevře výchozí prohlížeč uživatele a zobrazí se požadovaná adresa URL. Pokud je přehrávač integrován v prohlížeči, nahradí požadovaná adresa URL přehrávač a uživatelé neuvidí zbytek datového proudu. To je možné obejít zobrazením požadované adresy URL v samostatném okně spuštěného prohlížeče nebo spuštěním dalšího prohlížeče.
  • Vlastní příkazy skriptu. Kromě podpory titulků a adres URL přehrávač automaticky vykonává příkazy skriptu FILENAME, EVENT a OPENEVENT. Příkaz FILENAME lze použít pro otevření určitého souboru digitálních médií v zadaném čase. Příkaz EVENT je možné použít k vytváření vlastních příkazů skriptu. Například lze vložit do datového proudu reklamu. Nezapomeňte, že aby přehrávač provedl určenou událost, musí být její kód definován v metasouboru Windows Media datového proudu. Příkaz OPENEVENT předchází vlastní příkaz EVENT. Příkaz OPENEVENT umožňuje přehrávači předem uložit obsah do vyrovnávací paměti tak, aby byl přechod v určeném čase plynulý.

Podrobné informace příkazech skriptu podporovaných přehrávači Windows Media Player 9 Series najdete v sadě Windows Media Player 9 Series Software Development Kit (SDK). Informace o příkazech skriptu podporovaných službou Windows Media Services 9 Series najdete v sadě Windows Media Services 9 Series SDK.

Příkazy skriptu nelze upravovat, protože jsou ukládány do datového proudu.

Chcete-li vkládat příkazy skriptu do relace kódování, je třeba při jejím sestavování vybrat skripty jako typ zdroje. Skripty nejde vkládat během vytváření relace pomocí Průvodce novou relací. Později je ale možné do takové relace vkládat skripty prostřednictvím karty Zdroje na panelu Vlastnosti.

Příbuzná témata

  • Konfigurace zdrojů
  • Postup při vkládání příkazů skriptu během kódování
  • Postup při kódování dat se skrytými titulky


Postup při vkládání příkazů skriptu během kódování

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Zdroje.
  2. V části Zdroj klepněte na položku Zařízení.

    -nebo-

    Chcete-li vkládat příkazy skriptu během používání souboru jako zdroje, klepněte na možnost Zařízení i soubor.

  3. Zaškrtněte políčko Skript a potom klepněte na položku Panel Skript.
  4. Klepněte na tlačítko Použít a potom na příkaz Spustit kódování.
  5. Na panelu Skript klepněte na tlačítko příslušného druhu skriptu, který chcete vložit. Je možné vložit titulek (textový řetězec), adresu URL nebo vlastní příkaz skriptu.
  6. Použijte jeden z těchto postupů:
    • V případě titulku nebo adresy URL zapište text nebo adresu URL, kterou chcete vložit.
    • V případě vlastního skriptu zadejte typ příkazu a hodnotu.
  7. V místě, kde chcete vložit skript do datového proudu, klepněte na příkaz Vložit. Při vložení každého příkazu skriptu se zvýší položka Skripty (celkem) na panelu Sledování.

Příbuzná témata

  • Vkládání příkazů skriptu


Postup při kódování dat se skrytými titulky

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Zdroje.
  2. V části Zdroj klepněte na položku Zařízení.
  3. Zaškrtněte políčko Skript a potom klepněte na název digitalizační karty, která podporuje skryté titulky.
  4. Chcete-li kartu konfigurovat, klepněte na příkaz Konfigurovat.

Příbuzná témata

  • Vkládání příkazů skriptu


Použití více zdrojů v jedné relaci

V relaci můžete použít více zdrojů. Ačkoli lze zpracovávat v jednu chvíli pouze jeden zdroj, můžete během kódování přepínat mezi různými zdroji a zpracovávat tak různý obsah. Například před vysíláním jednání společnosti můžete nastavit zdroje pro hlavní obsah a pro uvítání, přestávku a závěrečný obsah. Při vysílání události můžete spustit uvítací zdroj, pak přepnout ve správnou chvíli na hlavního mluvčího, při přestávce přepnout na zdroj pro přestávku a v závěru události přepnout na zdroj pro zakončení vysílání.

Jestliže používáte kodek Windows Media Audio 9 Voice v relaci s několika zdroji, určuje režim (pouze hlas nebo smíšený hlas a hudba) prvního zdroje režimy následujících zdrojů. Jestliže například pro první zdroj nastavíte režim pouze hlas nebo smíšený, budou následující zdroje kódovány ve stejném režimu. Nastavíte-li však pro první zdroj smíšený režim a vytvoříte-li pro něho soubor definice optimalizace, budou následující zdroje v relaci kódovány v režimu pouze hlas.

Příbuzná témata

  • Konfigurace zdrojů
  • Postup při přepínání mezi více zdroji během kódování
  • Postup při nastavování pořadí více zdrojů


Postup při přepínání mezi více zdroji během kódování

  1. V nabídce Zobrazit klepněte na položku Panel Zdroje.
  2. Na panelu Zdroje klepněte na zdroj, kterým chcete začít, a potom klepněte na příkaz Spustit kódování.
  3. Chcete-li přepnout na jiný zdroj, klepněte na příslušné tlačítko na panelu Zdroje.

Příbuzná témata

  • Použití více zdrojů v jedné relaci


Postup při nastavování pořadí více zdrojů

  1. Na panelu nástrojů klepněte na Vlastnosti a potom klepněte na kartu Zdroje.
  2. V seznamu klepněte na zdroj, který chcete přesunout, a potom klepněte na tlačítko Šipka nahoru Šipka nahoru nebo Šipka dolů Šipka dolů .

Příbuzná témata

  • Použití více zdrojů v jedné relaci


Vlastní úprava relace

V tomto oddílu naleznete informace o možnostech vlastního nastavení relace pro kódování podle svých potřeb. Pokud chcete opakovaně použít vlastní nastavení relace, můžete relaci uložit do souboru relací a potom ji přidat do seznamu rychlých úvodů.

Příbuzná témata

  • Program Windows Media Encoder
  • Postup při otevírání existující relace
  • Postup při ukládání relace
  • Postup při spouštění, zastavování a pozastavování kódování
  • Postup při vytváření vlastního rychlého úvodu
  • Oříznutí a změna velikosti videa před kódováním
  • Zachování poměru stran pixelu videa
  • Optimalizace zvuku a videa
  • Zadávání jazyka obsahu
  • Použití časové komprese pro obsah
  • Používání kódování CBR
  • Používání kódování VBR
  • Nastavení datového proudu MBR
  • Použití technologie DRM (Digital Rights Management) k ochraně obsahu
  • Vkládání vodoznaku do obsahu
  • Používání hardwarových profilů
  • Používání převodních modulů plug-in


Postup při otevírání existující relace

  1. V nabídce Soubor klepněte na příkaz Otevřít.
  2. Do políčka Název souboru zadejte název a umístění souboru s relací, který chcete otevřít.

    Soubory s relacemi mají příponu WME.

  3. Klepněte na příkaz Otevřít.

Poznámka - obrázek Poznámka

  • Soubor s relací lze také otevřít přetažením do kodéru.

Příbuzná témata

  • Vlastní úprava relace


Postup při ukládání relace

  1. V nabídce Soubor klepněte na příkaz Otevřít.
  2. Do políčka Název souboru zadejte název a umístění souboru a potom klepněte na tlačítko Uložit.

Příbuzná témata

  • Vlastní úprava relace


Postup při spouštění, zastavování a pozastavování kódování

  • Chcete-li spustit kódování, klepněte na příkaz Spustit kódování na panelu nástrojů. Po spuštění kódování se zobrazí upozornění.

    -nebo-

    Chcete-li kódování zastavit, klepněte na příkaz Zastavit na panelu nástrojů. Po zastavení kódování se zobrazí upozornění. V dialogovém okně Výsledky kódování je k dispozici přehled výsledků relace.

    -nebo-

    Chcete-li pozastavit kódování, klepněte na příkaz Pozastavit na panelu nástrojů. Kódování je možné pozastavit, pouze pokud kódujete ze zařízení nebo digitalizovaných obrazovek do souboru. Kódování nelze pozastavit, pokud relace používá jako zdroj soubor.

Příbuzná témata

  • Vlastní úprava relace


Postup při vytváření vlastního rychlého úvodu

  1. Vytvořte a uložte relaci, podle které chcete kódovat.
  2. Uložte soubor relace do složky Templates, která se nachází na stejném umístění jako program Windows Media Encoder. Standardní umístění je C:\Program Files\Windows Media Components\Encoder\Templates.

    Rychlý úvod se objeví v seznamu rychlých úvodů v dialogovém okně Nová relace.

Příbuzná témata

  • Vlastní úprava relace
  • Použití rychlých úvodů pro kódování


Oříznutí a změna velikosti videa před kódováním

Pomocí programu Windows Media Encoder můžete oříznout hrany obrazu vstupního videa. Na okrajích obrazu se například často objevuje šum, takže můžete oříznout jednu nebo více hran a eliminovat tak zasažené řádky. Můžete určit, o kolik se ořízne každá strana obrazu, nebo můžete použít výchozí hodnoty pro oříznutí. Po oříznutí můžete změnit výšku a šířku výstupního videa. Podle výchozího nastavení je obraz výstupního videa natažen tak, aby jeho velikost odpovídala velikosti snímku nastaveného v profilu. Můžete však změnit velikost videa tak, aby výstupní obraz odpovídal rozměrům oříznutého obrazu. Případně se může měnit velikost videa automaticky tak, aby se využila šířka přenosového pásma zadaná v profilu. Můžete také určit rozměry pro vlastní změnu velikosti.

Video MBR a více zdrojů

Pokud kódujete video do formátu MBR, můžete změnit výstupní velikost snímků pro každou přenosovou rychlost zvlášť. To znamená, že soubor typu MBR nebo datový proud může obsahovat obraz v různých velikostech.

Pokud máte v relaci více zdrojů, výstupní rozměry prvního zdroje jsou určující pro rozměry ostatních zdrojů. Proto je v relaci s více zdroji možno měnit pouze velikost prvního zdroje.

Zjištění vstupní velikosti

Používáte-li jako zdroj soubor, dokáže kodér před spuštěním kódování zjistit velikost zdrojového videa. Používáte-li jako zdroj zařízení nebo digitalizované obrazovky, nelze před kódováním vstupní velikost zdroje zjistit. Pokud ořezáváte a měníte velikost videa ze zařízení nebo digitalizovaných obrazovek, je nutné určit vstupní velikost zdroje. V takovém případě kodér při spuštění kódování zjistí skutečnou velikost vstupního zdroje. Bude-li se velikost zadaná uživatelem lišit od skutečné vstupní velikosti, použije se zadaný poměr oříznutí (nikoli skutečné hodnoty pixelu) na skutečnou vstupní velikost zdroje.

Například jste zadali vstupní velikost 100 x 200 pixelů a následující nastavení oříznutí:

  • Nahoře: 4 (2 % výšky)
  • Dole: 4 (2 % výšky)
  • Vlevo: 10 (10 % šířky)
  • Vpravo: 10 (10 % šířky)

Pokud kodér zjistil, že skutečná vstupní velikost je 200 x 400, přizpůsobí se skutečné oříznutí nastavenému poměru oříznutí takto:

  • Nahoře: 8 (2 % výšky)
  • Dole: 8 (2 % výšky)
  • Vlevo: 20 (10 % šířky)
  • Vpravo: 20 (10 % šířky)

Hardwarové ořezávání

Pokud digitalizační karta podporuje hardwarové ořezávání, doporučuje se pro oříznutí videa používání tohoto hardwaru. Informace o hardwarovém ořezávání najdete v dokumentaci k digitalizační kartě.

Pokud digitalizační karta nepodporuje hardwarové ořezávání, nebo pokud používáte jako zdroj soubor, nezobrazí se oříznuté video do spuštění kódování v části Vstup na panelu Video.

Změna velikosti

Aby bylo dosaženo nejlepších výsledků, neměňte velikost výstupního videa. Změna velikosti může znamenat nedostatečně kvalitní výstup. Pokud však kódujete do souboru pomocí kodeku Windows Media Video 9 a čas vyžadovaný pro kódování není důležitý, můžete zlepšit kvalitu obsahu, pro který měníte velikost, úpravou nastavení výkonnosti kodéru při volbě Kódovat do souboru na vyšší důraz na kvalitu. Pamatujte, že čas pro kódování se při použití této metody značně zvyšuje.

Upozornění - obrázek Upozornění

  • Neměli byste měnit velikost obrazu, pokud kódujete obrazovku. Může se tím zhoršit kvalita kódovaného obsahu.

Příbuzná témata

  • Vlastní úprava relace
  • Úprava nastavení výkonu kodéru
  • Oříznutí a změna velikosti videa
  • Postup při přizpůsobování velikosti snímku zdrojovému videu


Postup při přizpůsobování velikosti snímku zdrojovému videu

  1. Na panelu nástrojů klepněte na Vlastnosti a potom klepněte na kartu Komprese.
  2. Klepněte na příkaz Upravit a potom na tabulku přenosových rychlostí.
  3. Zaškrtněte políčko Stejné jako vstup videa.

Příbuzná témata

  • Oříznutí a změna velikosti videa před kódováním


Oříznutí a změna velikosti videa

  1. Na panelu nástrojů klepněte na tlačítko Vlastnosti a pak na kartu Velikost videa.
  2. V seznamu zdrojů klepněte na zdroj, který chcete oříznout. (Nutné pouze v případě vícezdrojových relací.)
  3. Používáte-li jako zdroje zařízení nebo obrazovky zadejte v části Oříznout vstupní velikost.
  4. V položce Metoda oříznutí klepněte na tlačítko Vlastní nebo na jednu z výchozích hodnot ořezání.
  5. Pokud zvolíte vlastní ořezání, zadejte počet pixelů k zastřižení shora, zdola, z levé a pravé strany videa.
  6. V nabídce Metoda změny velikosti klepněte na jednu z následujících možností:
    • Shodně s profilem. Roztáhne rozměry videa na výstupu tak, aby odpovídaly rozměrům snímku zadaného v profilu.
    • Neměnit velikost. Rozměry videa na výstupu budou odpovídat rozměrům oříznutého videa na vstupu.
    • Automaticky. Pokud je zdrojem soubor, změní se rozměry videa na výstupu tak, aby bylo možné použít šířku pásma zadanou v profilu. Zároveň se program pokusí zachovat poměr stran oříznutého vstupního obrazu. Pokud se vstupní velikost zadaná v kroku 4 liší od skutečné velikosti, přizpůsobí se rozměry výstupního videa oříznutému vstupnímu videu.
    • Vlastní. Umožňuje zadat vlastní rozměry videa na výstupu.
  7. Pokud kódujete obsah MBR, klepněte na jinou přenosovou rychlost a změňte velikost. (Tato možnost je dostupná pouze tehdy, když pro první přenosovou rychlost zvolíte metodu změny velikosti Vlastní nebo Shodně s profilem.)

Poznámka - obrázek Poznámka

  • Pokud ořezáváte obsah, u něhož zároveň probíhá zrušení prokládání nebo u něhož používáte filtr inverzního přepisu Telecine, musí být hodnoty horního a spodního oříznutí beze zbytku dělitelné dvěma.

Příbuzná témata

  • Oříznutí a změna velikosti videa před kódováním
  • Optimalizace zvuku a videa


Zachování poměru stran pixelu videa

V případě, že zdroj videa používá pro zobrazení obdélníkové pixely, lze poměr stran pixelu zachovat. V příslušné dokumentaci zjistíte, zda jsou pro zobrazení u zařízení video obdélníkové pixely použity.

Poměr stran pixelu udává poměrnou šířku pixelu (x) k jeho délce (y). Na rozdíl od nečtvercového pixelu (obdélníkový pixel) jsou u čtvercového pixelu výška a šířka v poměru 1:1. Tento koncept je podobný poměru stran snímku, což je celková šířka snímku k jeho výšce. Tyto ukazatele poměrů stran nemusí spolu souviset. Širokoúhlý obrázek s poměrem stran snímku 16:9 může být složen jak ze čtvercových, tak obdélníkových pixelů.

Stejný poměr stran snímků a rozdílné poměry stran pixelu.

V následujícím diagramu je znázorněno zkreslení výstupu kódovaného zdroje videa, které namísto čtvercových pixelů používá pro zobrazení obdélníkové pixely.

Kódování obrázku s obdélníkovými pixely bez zachování poměru stran.

Znáte-li hodnotu poměru stran snímku (Ix:Iy) a přesnou výšku a šířku zdroje obrázku, k určení hodnot x a y poměru stran pixelu můžete použít následující vzorec.

poměr_stran_pixelu_X / poměr_stran_pixelu_Y = (Ix * výška) / (Iy * šířka)

Jsou-li například rozměry obrázku 720 krát 360 pixelů a poměr stran snímku je širokoúhlý (16:9), pak poměr_stran_pixelu_X=8 a poměr_stran_pixelu_Y=9:

poměr_stran_pixelu_X / poměr_stran_pixelu_Y = (16*360) / (9*720) = 8/9

Poznámka - obrázek Poznámky

  • Je-li nastavení velikosti výstupu videa stejné jako u zdroje videa a tento zdroj používá pro zobrazení obdélníkové pixely, poměr stran pixelu u zdroje videa bude u výstupu videa automaticky zachován.
  • Zachování poměru stran pixelu videa způsobí zvětšení velikosti souboru nebo přenosové rychlosti datových proudů.

Příbuzná témata

  • Vlastní úprava relace
  • Postup při nastavování zachování poměru stran pixelu videa
  • Postup při přizpůsobování velikosti snímku zdrojovému videu


Postup při nastavování zachování poměru stran pixelu videa

  1. Na panelu nástrojů klepněte na položku Vlastnosti, potom na kartu Komprese a klepněte na příkaz Upravit.
  2. Na kartě Obecné zaškrtněte políčko Povolit výstup obdélníkových pixelů a potom klepněte na tlačítko OK.
  3. Klepněte na kartu Velikost videa a v části Poměr stran pixelu určete poměr stran pixelu vstupního videa. Používáte-li vlastní nastavení poměru stran pixelu, musí být zadány hodnoty 1 až 255.

Příbuzná témata

  • Zachování poměru stran pixelu videa


Optimalizace zvuku a videa

Program Windows Media Encoder můžete použít ke zrušení prokládání zdrojového videa, které je prokládané, použít filtr pro inverzní přepis Telecine na obsah, který je ve formátu Telecine, nebo zachovat prokládání zdrojového videa.

Pokud si nejste jisti, zda je zdrojový obsah prokládaný nebo ve formátu Telecine, můžete pomocí kodéru zjistit formát klepnutím na tlačítko Rozpoznat na kartě Zpracování na panelu Vlastnosti.

Pokud je zvukovým obsahem především hlas kombinovaný částečně s hudbou, můžete použít hlasový kodek Windows Media Audio 9 a optimalizovat obsah pro hlas.

Příbuzná témata

  • Vlastní úprava relace
  • Zrušení a zachování prokládání videa
  • Použití filtru pro inverzní přepis Telecine na video
  • Optimalizace zvuku pro hlas


Zrušení a zachování prokládání videa

Snímek videa může být prokládaný nebo progresivní. Snímek prokládaného videa obsahuje dvě nasnímaná políčka zachycená v různých časových okamžicích. Při zobrazení videa se nejprve zobrazí řádky jednoho políčka a potom řádky druhého políčka. Na rozdíl od progresivního snímku videa jsou řádky v každém políčku vykreslovány postupně. Prokládaný obsah je běžný, protože televizní vysílací normy NTSC a PAL používají signály prokládaného videa.

Zrušení prokládání

Při zobrazení prokládaného videa na zobrazovacím zařízení s progresivním snímáním, např. v počítači, může při vykreslování políček blikat. Zrušením prokládání se z prokládaného snímku vytvoří progresivní snímek videa a omezí se blikání. Kodér je vybaven třemi filtry zrušení prokládání. Kodér vybírá filtry podle rozdílu mezi vstupní a výstupní velikostí snímku a podle frekvence snímků.

  • Normální zrušení prokládání. Výchozí filtr, který se použije při nastavení možnosti zrušení prokládání. Tento filtr směšuje sudá a lichá políčka prokládaného snímku a vytváří progresivní snímek (viz následující obrázek).

    Normální zrušení prokládání

  • Zrušení prokládání na poloviční velikost. Tento filtr se použije, jestliže je počet řádků nastavených pro výstupní video poloviční (nebo menší), než pro řádky výstupního videa. Filtr se použije například v případě, je-li rozlišení snímků vstupního videa 640x480 pixelů a rozlišení snímků výstupního videa 320x240 pixelů. Filtr používá algoritmus, který políčka směšuje místo pouhého odstraňování jednoho datového políčka. Výsledkem je velmi kvalitní výstupní video.
  • Zrušení prokládání na poloviční velikost a dvojnásobnou frekvenci snímků. Tento filtr se použije, jestliže je počet řádků nastavených pro výstupní video poloviční (nebo menší), než pro řádky výstupního videa a frekvence snímků výstupního videa je dvojnásobně vyšší než frekvence snímků vstupního videa. Filtr vytváří snímek z každého políčka videosekvence (viz následující obrázek).

    Zrušení prokládání na poloviční velikost a dvojnásobnou frekvenci snímků

    Mezi výhody tohoto filtru patří, že vytváří velmi kvalitní progresivní snímky, protože není nutné směšovat informace mezi políčky. Navíc je zachována plná dynamika prokládaných políček. Při použití filtru se ovšem zvyšují nároky na výkon a přenosovou rychlost.

Zrušení prokládání není podporováno u zdrojů, které nebyly původně prokládané.

Zachování prokládání ve zdrojovém videu

Zachování prokládání videa je užitečné, jestliže je určeno k přehrávání na zařízeních s prokládaným zobrazením, např. televizorech. Tato možnost je k dispozici pouze v případě, že použijete kodek Windows Media Video 9. Pro přehrání obsahu musí uživatel kromě toho používat operační systém Microsoft Windows XP, přehrávač vycházející ze sady Windows Media Format 9 Series Software Development Kit (SDK), a grafickou kartu, která podporuje prokládání. V opačném případě bude prokládání obsahu automaticky zrušeno.

Jestliže je zdroj videa smíšený (progresivní a prokládaný) a vyberte možnost Zachovat prokládání , bude výstupní video rovněž smíšené.

Poznámka - obrázek Poznámka

  • Některé digitalizační karty podporují hardwarové zrušení prokládání. Pokud je to možné, doporučujeme toto zrušení prokládání používat.
  • V případě zachování prokládání ve zdrojovém videu během kódování s nízkou frekvencí snímků (například 15 snímků/s) může dojít v kódovaném obsahu k výskytu nežádoucích artefaktů. To znamená, že pokud kódujete s nízkou frekvencí snímků, doporučujeme zrušit prokládání videa, ačkoliv je obsah určen pro přehrávání na zařízení s prokládaných zobrazením.

Příbuzná témata

  • Optimalizace zvuku a videa
  • Postup při rušení prokládání obrazu
  • Postup při zachovávání prokládání videa


Postup při rušení prokládání obrazu

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Zpracování.
  2. Klepnutím vyberte zdroj, u kterého chcete zrušit prokládání. (Nutné pouze v případě relace s více zdroji.)
  3. Klepněte na příkaz Zrušit prokládání.

Poznámka - obrázek Poznámka

  • Filtr zrušení prokládání používejte pouze pro zdroj videa, které bylo původně prokládané.
  • Filtr zrušení prokládání nepoužívejte při digitalizaci obrazovky.

Příbuzná témata

  • Zrušení a zachování prokládání videa


Postup při zachovávání prokládání videa

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  2. Klepněte na příkaz Upravit a potom zaškrtněte políčko Povolit prokládané zpracování.
  3. Klepněte na kartu Zpracování.
  4. Klepnutím vyberte zdroj, u kterého chcete zachovat prokládání. (Nutné pouze v případě relace s více zdroji.)
  5. Klepněte na příkaz Zachovat prokládání.
  6. Jestliže víte, které pole je v obsahu první, klepněte na položku Nejdříve nahoře nebo Nejdříve dole. Nejste-li si jisti, které pole je první, klepněte na položku Automaticky.

Poznámka - obrázek Poznámka

  • Pro zachování prokládání videa je nutné použít kodek Windows Media Video 9.

Příbuzná témata

  • Zrušení a zachování prokládání videa


Použití filtru pro inverzní přepis Telecine na video

Proces inverzního přepisu Telecine odstraní snímky, které jsou přidány v průběhu přepisu Telecine, když je film (24 snímků/s) převáděn na video ve formátu NTSC (29,97 nebo 30 snímků/s). Filtr pro inverzní přepis Telecine odstraní artefakty a zlepší kvalitu kódovaného obsahu, především pro nízké přenosové rychlosti.

Obsah je ve formátu Telecine ve vzoru nazývaném "3:2 pulldown", což znázorňuje proces použitý k vytvořený doplňujících snímků. Pokud je vzor "3:2 pulldown" konzistentní v průběhu celého zdrojového videa, je video označováno jako koherentní. Video však často koherentní není, což znamená, že ve vzoru "3:2 pulldown" jsou zlomy. Zlomy ve vzoru, tedy porušení koherence, se mohou například objevit při editaci videa. Pokud je obsah koherentní, můžete přesně určit snímek, na kterém vzor "3:2 pulldown" začíná. Můžete také nechat tento vzor rozpoznat automaticky.

Inverzní přepis Telecine není podporován pro:

  • zdroj ve formátu NTSC který nebyl přepsán metodou Telecine,
  • obsah, na který byla aplikována komprese času,
  • obsah, pro který zachováváte nebo vytváříte časový kód.

Příbuzná témata

  • Optimalizace zvuku a videa
  • Postup při používání filtru inverzního přepisu Telecine pro video


Postup při používání filtru inverzního přepisu Telecine pro video

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom na kartu Zpracování.
  2. Klepnutím vyberte zdroj, pro který chcete použít inverzní filtr Telecine. (Nutné pouze v případě relace s více zdroji.)
  3. Klepněte na položku Inverzní přepis Telecine.
  4. Pokud je obsah souvislý a chcete omezit úpravy poškozených vzorků, klepněte v seznamu na počáteční snímek záznamu.

Poznámka - obrázek Poznámka

  • Inverzní filtr Telecine použijte pouze pro zdroj videa, který byl předtím přepsán na frekvenci 30 snímků za sekundu.
  • Nepoužívejte inverzní filtr Telecine při digitalizaci obrazovky.

Příbuzná témata

  • Použití filtru pro inverzní přepis Telecine na video


Optimalizace zvuku pro hlas

Používáte-li jako zdroj zvuk, který je zcela nebo částečně tvořen hlasem, je vhodné použít kodek Windows Media Audio 9 Voice, který je určen ke kódování hlasu. Pokud zjistíte, zda je obsah tvořen pouze hlasem nebo zda obsahuje také hudbu, lze chování kodeku optimalizovat. Je-li zvuk tvořen směsicí hlasu a hudby, používá kodek během kódování automaticky příslušný algoritmus pro optimalizaci kódování obsahu (hlasu nebo hudby). Další možností je vytvořit soubor definice optimalizace. Jedná se o textový soubor, ve kterém jsou označena místa v souboru, ve kterých začíná a končí hudba. Zbývající neoznačené části souboru jsou považovány za hlas.

Používáte-li kodek Windows Media Audio 9 Voice v relaci s více zdroji, najdete informace o vlastnostech tohoto kodeku v části Používání více zdrojů v relaci.

Příbuzná témata

  • Optimalizace zvuku a videa
  • Postup při optimalizaci zvuku pro hlas
  • Postup při vytváření souboru definice optimalizace zvuku


Postup při optimalizaci zvuku pro hlas

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  2. Klepněte na příkaz Upravit a potom v části Režim klepněte na položku CBR.
  3. V části Kodek klepněte na položku Windows Media Audio 9 Voice a potom klepněte na tlačítko OK.
  4. Klepněte na kartu Zpracování a dále na položku Pouze hlas nebo Zvuk se zvýrazněním hlasu.

    Při výběru zvuku se zvýrazněním hlasu máte možnost vytvořit soubor definice optimalizace, který určuje začátek a konec hudby ve zvuku.

  5. Jestliže jste vytvořili soubor definice optimalizace, zadejte jeho název.

Příbuzná témata

  • Optimalizace zvuku pro hlas
  • Postup při vytváření souboru definice optimalizace zvuku


Postup při vytváření souboru definice optimalizace zvuku

  1. Pomocí jednoduchého textového editoru, jako například Poznámkový blok, vytvořte textový soubor.
  2. Zadejte číslo verze a počet hudebních segmentů, které soubor obsahuje.

    Číslo verze musí být vždy 1.

  3. Zadejte čas začátku a konce (v milisekundách) každého segmentu. Jednotlivé časy začátku a konce oddělte pomlčkou.

    Například zadání 1, 3, 0, 10000, 50000, 80000, 150000 a 200000 znamená, že soubor obsahuje tři hudební segmenty. Kodek bude pracovat v režimu hudby v časech 0 až 10 sekund, 50 až 80 sekund a 150 až 200 sekund.

  4. Převeďte textový soubor do kódu Unicode.

    Soubor vytvořený v Poznámkovém bloku můžete uložit v kódování Unicode. V nabídce Soubor zvolte příkaz Uložit jako a potom v okně Kódování klepněte na možnost Unicode.

Příbuzná témata

  • Optimalizace zvuku pro hlas


Zadávání jazyka obsahu

Při kódování je k obsahu automaticky přiřazen jazyk. Podle potřeby je možné obsah kódovat v různých jazycích. Pro přidání dalších jazyků do jednoho souboru lze použít nástroj Windows Media Stream Editor. Uživatelé si potom mohou při přehrávání souboru zvolit jazyk, který chtějí poslouchat.

Příbuzná témata

  • Postup při zadávání jazyka obsahu


Postup při zadávání jazyka obsahu

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  2. Klepněte na příkaz Upravit.
  3. V části Jazyk klepněte na jazyk v seznamu.

Příbuzná témata

  • Zadávání jazyka obsahu


Použití časové komprese pro obsah

Použitím komprese času obsahu při kódování můžete zrychlit nebo zpomalit obsah při přehrávání. Zrychlení obsahu sníží množství času potřebného pro shlédnutí celého videa nebo poslechnutí celého zvukového souboru, což je užitečné, když máte vtěsnat obsah do určitého časového bloku. Zpomalení obsahu může zlepšit srozumitelnost v situacích, kdy je materiál vysoce odborný nebo použitý jazyk není rodným jazykem uživatelů. Použití komprese času má následující požadavky:

  • Zdroj musí obsahovat zvukový obsah.
  • Každý zdroj v relaci musí být soubor.
  • Musíte provádět kódování do souboru. (Komprese času není podporována pro vysílání.)
  • Musíte používat jednofázový režim kódování (jednofázový režim CBR nebo VBR v nízké kvalitě).
  • V kombinaci s kompresí času nelze použít filtr pro inverzní přepis Telecine.
  • V kombinaci s kompresí času nelze použít funkci opakování.
  • Kompresi času nelze použít, když zdrojem je vícekanálový zvuk.

Pokud používáte různé zdrojové soubory zvuku a videa, kódování se ukončí po dokončení kratšího souboru.

Windows Media Encoder nabízí pro kompresi času dvě funkce, které lze použít nezávisle na sobě nebo i současně:

  • Zrychlení nebo zpomalení zvuku a snímků videa. Zrychlení a zpomalení nemá vliv na výšku zvuku.
  • Detekce a odstranění pauz ve zvuku a dění. Ze zvukové stopy jsou odstraněny chvíle ticha a z videa jsou odstraněny příslušné snímky. Pokud se rozhodnete vytvořit protokol, budou do souboru protokolu zaznamenány časy začátků a konců odstraněných segmentů, takže budete mít trvalý záznam.

Před použitím komprese času se ujistěte, že pracujete se zvukem, který je v nejlepší možné kvalitě. Zvukové vady a šum ve zdrojovém obsahu budou zrychlením obsahu zvýrazněny. Šum ve zdrojovém obsahu také snižuje přesnost odstranění pauz.

Vždy prověřte obsah a ujistěte se, zda jste dosáhli požadovaných výsledků. Pro otestování zakódujte část obsahu pomocí komprese času a poté výsledek přehrajte. Pokud výsledek není uspokojivý, upravte nastavení komprese času a poté zakódujte obsah znovu.

Příbuzná témata

  • Vlastní úprava relace
  • Postup při zrychlování a zpomalování zvuku a snímků videa
  • Postup při odstraňování pauz z obsahu


Postup při zrychlování a zpomalování zvuku a snímků videa

  1. Vytvořte novou relaci, která používá jako zdroj soubory.
  2. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  3. Zaškrtněte políčko Komprese času a potom klepněte na položku Vlastnosti.
  4. Posuvníkem nastavte požadovanou rychlost obsahu. Je možné použít zpomalení až o 50 procent nebo zrychlení až o 250 procent.

Příbuzná témata

  • Použití časové komprese pro obsah
  • Postup při používání souboru jako zdroje


Postup při odstraňování pauz z obsahu

  1. Vytvořte novou relaci, která používá jako zdroj soubory.
  2. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  3. Zaškrtněte políčko Komprese času a potom klepněte na položku Vlastnosti.
  4. Zaškrtněte políčko Povolit odstraňování pauz.
  5. Chcete-li vytvořit soubor protokolu, do kterého se budou zapisovat odstraněné segmenty s časovým razítkem, klepněte na položku Možnosti a zadejte název souboru protokolu.

Příbuzná témata

  • Použití časové komprese pro obsah
  • Postup při používání souboru jako zdroje


Používání kódování CBR

Při kódování CBR se zadává požadovaná přenosová rychlost, která se má udržovat, a dále velikost vyrovnávací paměti. Přenosová rychlost bude v průběhu datového proudu kolísat, nicméně toto kolísání bude vyrovnáváno velikostí vyrovnávací paměti. Kvalita obsahu rovněž kolísá, aby se zabránilo přetečení nebo podtečení vyrovnávací paměti. (Chcete-li zajistit kvalitu kódovaného výstupu, použijte kódování VBR podle kvality.) Počáteční zpoždění při přehrávání obsahu závisí na velikosti vyrovnávací paměti. Kódování CBR však zaručuje plynulý přenos datového proudu za předpokladu, že přenosová rychlost je kompatibilní s rychlostí připojení klienta. Chcete-li dosáhnout vyšší kvality, aniž by došlo ke omezení výhod kódování CBR, používejte dvojfázové kódování CBR. Dvojfázové kódování není pro některé scénáře k dispozici.

Příbuzná témata

  • Vlastní úprava relace
  • Kódování CBR a VBR
  • Jednofázové a dvojfázové kódování
  • Požadavky funkcí
  • Postup při vytváření relace kódování CBR


Postup při vytváření relace kódování CBR

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  2. V části Cíl klepněte na cíl, který podporuje kódování CBR a který odpovídá scénáři přehrávání.
  3. V částech Video a Zvuk vyberte požadovaná nastavení obrazu a zvuku.
  4. Chcete-li povolit dvojfázové kódování CBR, zaškrtněte políčko Dvojfázové kódování.

Poznámka - obrázek Poznámka

  • Dvojfázové kódování není pro některé scénáře k dispozici.

Příbuzná témata

  • Používání kódování CBR
  • Jednofázové a dvojfázové kódování
  • Požadavky funkcí


Kódování VBR

Windows Media Encoder - titulní obrázek

Používání kódování VBR

Program Windows Media Encoder podporuje tři režimy kódování VBR:

  • Kódování podle kvality. Při kódování VBR podle kvality zadáte požadovanou úroveň kvality (0 - 100). Během kódování se přenosová rychlost mění v závislosti na složitosti datového proudu. V detailech či při větším množství pohybu je vyšší, při jednodušším obsahu je nižší. Výhodou tohoto režimu kódování je konzistentní úroveň kvality všech datových proudů, pro které stejnou hodnotu kvality nastavíte. Nevýhodu představuje skutečnost, že před kódováním nelze předpovědět ani velikost souboru, ani požadavky na šířku pásma kódovaného obsahu. Při kódování podle kvality se používá jednofázové kódování. Režim je vhodný pro archivaci obsahu.

    Pokud v tomto režimu kódujete zvukový obsah, můžete použít bezztrátový kodek Windows Media Audio 9 Lossless. Výsledkem bezztrátového kódování je špičková kvalita při současné kompresi dat.

  • Kódování podle přenosové rychlosti. Při kódování VBR podle přenosové rychlosti zadáte požadovanou průměrnou přenosovou rychlost. Přenosová rychlost může ve kterémkoliv okamžiku překročit průměrnou přenosovou rychlost, avšak celková přenosová rychlost bude vždy nižší než průměrná. Při kódování podle přenosové rychlosti se používá dvojfázové kódování. V první fázi dojde k analýze složitosti dat. V druhé fázi se úroveň kvality nastaví tak, aby bylo dosaženo průměrné přenosové rychlosti. Výhodou tohoto režimu kódování je skutečnost, že komprimovaný datový proud dosáhne nejvyšší možné úrovně kvality a zároveň zůstane v předvídatelné průměrné šířce pásma.
  • Kódování podle maximální přenosové rychlosti. Kódování VBR podle maximální přenosové rychlosti je podobné předchozímu režimu kódování, avšak zadáváte při něm také maximální přenosovou rychlost. Kodér určuje kvalitu obrazu tak, aby nebyla překročena maximální přenosová rychlost. Během kódování se přenosová rychlost sice mění, ale nikdy nepřekročí maximální přenosovou rychlost. Toto kódování používejte v případě, že hodláte obsah distribuovat k přehrávání na zařízení s omezenou rychlostí čtení (přehrávač CD nebo DVD). Kódování podle maximální přenosové rychlosti používá dvojfázové kódování.

Poznámka - obrázek Poznámka

  • Kódování VBR podporují pouze některé kodeky.
  • Režimy kódování VBR podle kvality a přenosové rychlosti se nedoporučují používat ve scénáři přenosu je datovým proudem vytvořen vysokými maximy přenosových rychlostí v obsahu. Ve scénáři přenosu, kdy všechny přehrávače dosáhnou bodu v datovém proudu s vysokou přenosovou rychlostí přibližně ve stejnou dobu, existuje mv Toto maximum může přesáhnout kapacitu sítě a způsobit špatnou kvalitu přehrávání.

Příbuzná témata

  • Vlastní úprava relace
  • Kódování CBR a VBR
  • Používání kódování CBR
  • Požadavky funkcí
  • Jednofázové a dvojfázové kódování
  • Nastavení relace kódování VBR podle kvality
  • Postup při kódování zvuku bez ztráty kvality
  • Postup při vytváření relace kódování VBR podle přenosové rychlosti
  • Postup při vytváření relace kódování VBR podle maximální přenosové rychlosti


Postup při vytváření relace kódování VBR podle kvality

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  2. V části Cíl klepněte na položku Archiv souborů.
  3. V částech Video a Zvuk vyberte požadovaná nastavení kvality obrazu a zvuku.

    -nebo-

    Klepněte na příkaz Upravit a dále na kartu Podle kvality. V části Kvalita videa zadejte požadované nastavení kvality videa. Nastavení může být v rozsahu 0 až 100, kde 100 představuje nejvyšší kvalitu.

Příbuzná témata

  • Používání kódování VBR


Postup při kódování zvuku bez ztráty kvality

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  2. V části Cíl klepněte na položku Archiv souborů.
  3. V části Zvuk klepněte na položku Zvuk bez ztráty kvality.

Příbuzná témata

  • Používání kódování VBR


Postup při vytváření relace kódování VBR podle přenosové rychlosti

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  2. V části Cíl klepněte na položku Stažení souboru.
  3. V částech Video a Zvuk vyberte požadovaná nastavení obrazu a zvuku.

    -nebo-

    Po klepnutí na příkaz Upravit zadejte vlastní nastavení.

Poznámka - obrázek Poznámka

  • Režim VBR používá dvojfázové kódování. Toto kódování není pro některé scénáře k dispozici.

Příbuzná témata

  • Používání kódování VBR
  • Jednofázové a dvojfázové kódování


Postup při vytváření relace kódování VBR podle maximální přenosové rychlosti

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  2. V části Cíl klepněte na položku Hardwarová zařízení.
  3. V částech Video a Zvuk vyberte požadovaná nastavení obrazu a zvuku.

    -nebo-

    Po klepnutí na příkaz Upravit zadejte vlastní nastavení.

Poznámka - obrázek Poznámka

  • Režim VBR používá dvojfázové kódování. Toto kódování není pro některé scénáře k dispozici.

Příbuzná témata

  • Používání kódování VBR
  • Jednofázové a dvojfázové kódování


Nastavení datového proudu MBR

Pokud plánujete vysílat vlastní obsah jako jednosměrný datový proud ze serveru se systémem Microsoft Windows Media Services, umožní kódování datového proudu pro více přenosových rychlostí (MBR) uživatelům vyšší kvalitu obsahu v případě přetížení sítě. Při nastavení datového proudu MBR se obsah zakóduje ve všech určených přenosových rychlostech. Když přehrávač načte datový proud MBR, začne se přehrávat pouze ten proud, který bude nejlépe vyhovovat aktuálním podmínkám sítě. Mechanizmus výběru vhodného proudu, který je pro uživatele skrytý, zajišťuje server Windows Media a přehrávač. Protože je datový proud MBR určen pouze pro použití ve scénáři s datovým proudem, můžete při kódování datového proudu MBR použít pouze kódování CBR.

Datový proud MBR je možné kódovat pro zvukový i obrazový obsah; není však nutné používat kódování MBR pro zvukový i obrazový obsah v jednom proudu. Můžete například přenášet zvuk jednou přenosovou rychlostí a používat několik přenosových rychlostí pro obrazovou část proudu.

Při nastavení datového proudu MBR nezapomeňte, že čím více přenosových rychlostí vyberete, tím je třeba větší souhrnná šířka pásma pro distribuci živého datového proudu z kodéru do serveru Windows Media. Pro odhad souhrnné šířky profilu MBR sečtěte všechny přenosové rychlosti zvukových i obrazových datových proudů a přenosovou rychlost skriptu. Rovněž nezapomeňte, že při kódování datového proudu MBR je vyžadován vyšší výkon kódovacího počítače.

Používáte-li v relaci MBR kodek Windows Media Audio 9 Voice a nastavíte smíšený režim hlasu a hudby, doporučujeme vynechat z relace všechny přenosové rychlosti nižší než 8 kilobitů za sekundu (kb/s). Důvodem je, že všechny přenosové rychlosti nižší než 8 kb/s budou kódovány v režimu pouze hlas, což může snížit kvalitu zvukového obsahu.

Příbuzná témata

  • Vlastní úprava relace
  • Postup při kódování datového proudu MBR
  • Postup při kódování zvuku s jednou přenosovou rychlostí a videa MBR
  • Postup při kódování videa s jednou přenosovou rychlostí a zvuku MBR


Postup při kódování datového proudu MBR

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  2. V části Cíl klepněte na položku Server Windows Media.
  3. V částech Video a Zvuk klepněte na požadovaná nastavení kvality.
  4. V části Přenosové rychlosti vyberte požadované přenosové rychlosti datového proudu.

    -nebo-

    Klepněte na příkazy Upravit a dále Přidat. Zobrazí se dialogové okno Přidat přenosovou rychlost. Zadejte požadovanou přenosovou rychlost, která má být součástí datového proudu MBR.

Poznámka - obrázek Poznámka

  • Vyberte takový rozsah přenosových rychlostí, který podle vás bude vyhovovat požadavkům na přehrávání posluchačů, na které se zaměřujete.
  • V jednou datovém proudu není nutné používat kódování MBR pro zvuk i video. Můžete například přenášet zvuk jednou přenosovou rychlostí a používat několik přenosových rychlostí pro obrazovou část proudu.

Příbuzná témata

  • Nastavování datového proudu MBR
  • Kódování zvuku s jednou přenosovou rychlostí s videem MBR
  • Kódování videa s jednou přenosovou rychlostí se zvukem MBR


Postup při kódování zvuku s jednou přenosovou rychlostí a videa MBR

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  2. V části Cíl klepněte na položku Server Windows Media.
  3. V částech Video a Zvuk klepněte na nastavení kvality, která chcete použít.
  4. V části Přenosové rychlosti vyberte požadované přenosové rychlosti datového proudu.
  5. Klepněte na příkaz Upravit a ve všech přehledech přenosových rychlostí vyberte stejná nastavení jako v části Formát zvuku.

Příbuzná témata

  • Nastavení datového proudu MBR
  • Postup při kódování videa s jednou přenosovou rychlostí a zvuku MBR


Postup při kódování videa s jednou přenosovou rychlostí a zvuku MBR

  1. Na panelu nástrojů klepněte na Vlastnosti a potom klepněte na kartu Komprese.
  2. V části Cíl klepněte na Server Windows Media.
  3. V částech Video a Zvuk klepněte na nastavení kvality, která chcete použít.
  4. V části Přenosové rychlosti vyberte požadované přenosové rychlosti datového proudu.
  5. Klepněte na příkaz Upravit a ve všech tabulkách přenosových rychlostí v části video vyberte stejná nastavení. (Všechna nastavení musí souhlasit, jinak bude během kódování použito více přenosových rychlostí videa.)

Příbuzná témata

  • Nastavování datového proudu MBR
  • Postup při kódování zvuku s jednou přenosovou rychlostí a videa MBR


Použití technologie DRM (Digital Rights Management) k ochraně obsahu

Použitím technologie DRM (Digital Rights Management) lze řídit proces kódování obsahu médií. Tato technologie může být použita buď při kódování souboru, nebo při vysílání datového proudu. Aby bylo možno obsah přehrát, je poté, co je obsah médií zakódován a zašifrován pomocí klíče, uživateli vyžadována licence. Tato licence obsahuje klíč k odšifrování obsahu a práva k jeho použití. Licence například určuje maximální počet přehrání obsahu nebo datum vypršení platnosti licence.

Důležité upozornění Důležité upozornění

  • Licence jsou vydávány třetí stranou, proto je nutné, chcete-li k zabezpečení obsahu médií používat tuto technologii, otevřít zákaznický účet u tohoto poskytovatele licencí.

Postup při použití technologie DRM

Základní kroky při použití technologie DRM:

  1. Otevřít relaci kódování.
  2. Otevřít u poskytovatele licencí zákaznický účet (pokud jste tak již neučinili) a vytvořit profil DRM.
  3. Identifikovat v rámci relace profil DRM, který bude v souvislosti s obsahem médií použit.
  4. Zakódovat a distribuovat obsah médií, buď pomocí datového proudu, nebo poskytnutím souborů ke stažení.
  5. Pokud uživatel přehrává chráněný obsah, přehrávač obdrží licenci od vámi vybraného poskytovatele. Uživatel má poté právo přehrát obsah médií podle této licence.

    Uživatelé mohou přehrát chráněný obsah pouze s použitím přehrávače, který podporuje technologii DRM firmy Microsoft. Seznam těchto přehrávačů naleznete na webu firmy Microsoft.

Opětovné použití profilů DRM

Vytvořený profil DRM můžete použít znovu v jiných relacích. Profil lze také exportovat a použít u počítače s jiným způsobem kódování. Podobně lze z jiného počítače importovat profil DRM. Profily DRM jsou z bezpečnostních důvodů udržovány na úrovni jednotlivých uživatelů. Vytvořené profily nemohou tedy být jinými uživateli zobrazeny, upraveny ani používány. Pro soubory profilů DRM se používá přípona DRM.

Příbuzná témata

  • Vlastní úprava relace
  • Vytváření účtu u poskytovatele licence
  • Postup při ochraně obsahu pomocí technologie DRM


Postup při ochraně obsahu pomocí technologie DRM

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom Zabezpečení.
  2. Pokud jste tak již neučinili, vytvořte účet u poskytovatele licence a potom vytvořte profil.
  3. Zaškrtěte políčko Chránit obsah před neoprávněným použitím pomocí technologie DRM.
  4. V seznamu v části Profil DRM vyberte profil, který chcete pro tuto relaci použít.

    Po spuštění kódování bude obsah chráněn.

Příbuzná témata

  • Použití technologie DRM (Digital Rights Management) k ochraně obsahu
  • Vytváření účtu u poskytovatele licence


Vytváření účtu u poskytovatele licence

Poskytovatel musí vydat licence na obsah, který chcete zabezpečit. Uživatel musí vytvořit účet u poskytovatele licence, který podporuje řadu programů Windows Media Encoder 9 Series. Během vytváření účtu vás poskytovatel vyzve, abyste vybrali práva, na která se má licence vztahovat. Podle typu licenčního serveru budete pravděpodobně vyzváni, abyste změnili další nastavení, např. způsob, jakým mají být licence vydány.

Po vytvoření účtu vydá poskytovatel licencí profil DRM, který uloží do místního počítače. Nyní můžete profil používat k ochraně svého obsahu. Profil obsahuje následující informace:

  • ID profilu DRM
  • Název a popis
  • Atributy (dvojice název-hodnota)
  • Adresa URL webu poskytovatele licence
  • Adresa URL pro získání licence

    Přehrávače mohou podporovat různé verze technologie Microsoft DRM: Windows Media Rights Manager verze 1 nebo 7. Z tohoto důvodu se používají různé adresy URL pro získání licence, které odpovídají každé verzi. Každá adresa URL pro získání licence odkazuje na stránku na webu poskytovatele licence, kde lze licenci získat a která je uvedena v hlavičce vašeho zabezpečeného obsahu. Při přehrávání zabezpečeného obsahu se v přehrávači zobrazí příslušná adresa URL pro získání licence.

Následující hodnoty se rovněž vytvoří a uloží v místním počítači během vytváření profilu DRM:

  • Veřejné a soukromé podpisové klíče. Poskytovatel licence požaduje veřejný podpisový klíč pro vydání licencí. Soukromý podpisový klíč se nevrací.
  • Počáteční číslo licenčního klíče. Pro ochranu každého požadovaného souboru nebo datového proudu se používá počáteční číslo, které slouží k vygenerování klíče pro šifrování obsahu. Tuto hodnotu používá také poskytovatel licencí pro opakované generování klíče, který vloží do licence a podle kterého přehrávač uživatele dešifruje obsah.

Příbuzná témata

  • Použití technologie DRM (Digital Rights Management) k ochraně obsahu
  • Postup při vytváření účtu u poskytovatele licence


Postup při vytváření účtu u poskytovatele licence

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom Zabezpečení.
  2. Klepněte na příkaz Nový a potom Přidat.
  3. Použijte jeden z těchto postupů:
    • Zadejte název a adresu URL požadovaného poskytovatele.
    • Klepnutím na příkaz Najít poskytovatele přejdete na web se seznamem poskytovatelů.

    Po vybrání poskytovatele se zobrazí dialogové okno Nový profil.

  4. Klepněte na název poskytovatele v seznamu a potom klepněte na příkaz Vytvořit.

    Zobrazí se uživatelské rozhraní poskytovatele.

  5. Postupujte podle pokynů pro vytvoření profilu DRM pro obsah. Profil lze po vytvoření používat k ochraně obsahu.

Příbuzná témata

  • Vytváření účtu u poskytovatele licence
  • Postup při ochraně obsahu pomocí technologie DRM


Vkládání vodoznaku do obsahu

Digitální vodoznak lze vložit do libovolného datového proudu. Vodoznaky představují způsob, jak doplnit do zvukového nebo obrazového datového proudu informace, jako např. autorská práva nebo jméno interpreta. Vodoznaky ale nejsou pro uživatele viditelné ani slyšitelné. Vodoznak je uchován v kódovaném souboru nebo datovém proudu a nelze jej odstranit. Tento vodoznak lze použít k identifikaci obsahu i v případě, že je kopírován nebo upravován.

Chcete-li pracovat s vodoznaky, musíte získat a zaregistrovat modul plug-in dalšího výrobce. Informace o získávání modulů plug-in pro vodoznaky najdete na webu společnosti Microsoft.

Příbuzná témata

  • Vlastní úprava relace
  • Postup při přidávání vodoznaku k obsahu


Postup při přidávání vodoznaku k obsahu

  1. Pokud jste tak již neučinili, zaregistrujte modul plug-in vodoznaku, který chcete používat.
  2. Spusťte kodér. Potom v nabídce Zobrazit klepněte na panel Vlastnosti.
  3. Klepněte na kartu Zabezpečení.
  4. Chcete-li přidat vodoznak k obrazovému obsahu, zaškrtněte políčko Video a potom v seznamu klepněte na modul plug-in, které chcete použít.
  5. Chcete-li přidat vodoznak ke zvukovému obsahu, zaškrtněte políčko Zvuk a potom v seznamu klepněte na modul plug-in, které chcete použít.

Poznámka - obrázek Poznámka

  • Jestliže použitý modul plug-in vodoznaku vyžaduje soubor konfigurace, určete soubor klepnutím na příkaz Konfigurovat.

Příbuzná témata

  • Vkládání vodoznaku do obsahu


Používání hardwarových profilů

Obsah založený na formátu Windows Media již není přehráván pouze v počítačích. Naopak se zvyšuje poptávka po přehrávání obsahu na různých hardwarových zařízeních, jako např. datové terminály, bezdrátová sluchátka a přehrávače DVD. Chcete-li zajistit, aby bylo možné obsah přehrávat na určitém typu hardwarového zařízení, můžete obsah zakódovat pomocí hardwarového profilu. Program Windows Media Encoder obsahuje řadu hardwarových profilů, které mají uspokojit škálu požadavků na kódování.

Nechcete-li pro kódování obsahu použít hardwarový profil, přesto můžete určit typ hardwarového zařízení, které může obsah přehrát. Všechen zakódovaný obsah se namapuje do hardwarového profilu. Profil použitý pro kódování je uveden v dialogovém okně Výsledky kódování (v části Přizpůsobení profilu), které se zobrazí po dokončení kódování.

Profily pro video

Program Windows Media Encoder obsahuje následující hardwarové profily: jednoduchý nízký, jednoduchý střední hlavní nízký, hlavní střední a hlavní vysoký. Další informace o jednotlivých profilech najdete v části Hardwarové profily pro video. Daný profil a úroveň vždy podporuje nižší profily a úrovně. Například zařízení, které podporuje hlavní profil a střední úroveň, zároveň podporuje hlavní profil, nejnižší úroveň a všechny úrovně v jednoduchém profilu.

Profily pro zvuk

V následující tabulce jsou vzestupně seřazeny hardwarové profily pro zvukový obsah, které jsou součástí kodéru.

Profil pro zvuk | Popis
L1 | Pro přenosové rychlosti zvuku od 64 do 128 kb/s (používá kodek Windows Media Audio 9)
L2 | Pro přenosové rychlosti zvuku 160 kb/s nebo méně (používá kodek Windows Media Audio 9)
L3 | Pro přenosové rychlosti zvuku 384 kb/s nebo méně (používá kodek Windows Media Audio 9)
L | Podporuje všechny přenosové rychlosti. Určeno pro přehrávání v počítači jako ukázka možností kodeku (používá kodek Windows Media Audio 9)
S1 | Pro přenosové rychlosti zvuku 20 kb/s nebo méně, pro méně složitý hlasový obsah (používá kodek Windows Media Audio 9)

Při vytváření relace nelze vybírat profily uvedené v následující tabulce. Pokud ale kódovaný obsah odpovídá parametrům v tabulce, bude namapován na odpovídající hardwarový profil.

Profil pro zvuk | Popis
S2 | Pro přenosové rychlosti zvuku 20 kb/s nebo méně, pro obsah se smíšenou hudbou a hlasem (používá kodek Windows Media Audio 9)
M1 | Pro přenosové rychlosti zvuku 48 kb/s nebo méně a pro 5.1 kanálů a méně. Doporučeno pro prostorový zvuk filmů ve standardním zvukovém formátu (používá kodek Windows Media Audio 9 Professional)
M2 | Pro přenosové rychlosti zvuku 768 kb/s nebo méně, pro vzorkovací frekvence 96 kHz a méně a pro 5.1 kanálů a méně. Doporučeno pro prostorový zvuk filmů ve špičkovém zvukovém formátu (používá kodek Windows Media Audio 9 Professional)
M | Podporuje všechny přenosové rychlosti, vzorkovací frekvence a kanály. Určeno pro přehrávání v počítači jako ukázka možností kodeku (používá kodek Windows Media Audio 9 Professional)

Kombinování profilů pro video a zvuk

V následující tabulce je uveden seznam doporučených kombinací hardwarových profilů pro video a zvuk.

Video | Zvuk
Jednoduchý nízký | L2 nebo S2
Jednoduchý střední | L2 nebo S2
Hlavní nízký | L2 nebo S2
Hlavní střední | L3, S2 nebo M1
Hlavní vysoký | L3, S2 nebo M2

Příbuzná témata

  • Vlastní úprava relace
  • Postup při vytváření hardwarového profilu
  • Hardwarové profily pro video


Postup při vytváření hardwarového profilu

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Komprese.
  2. V části Cíl klepněte na položku Hardwarové profily Windows Media.
  3. V částech Video a Zvuk klepněte na požadovaný profil a úroveň kódování.

Příbuzná témata

  • Používání hardwarových profilů


Hardwarové profily pro video

V této části jsou uvedeny podrobné informace hardwarových profilech, které jsou k dispozici pro obsah videa, a které jsou součástí instalace programu Windows Media Encoder.

Jednoduchý nízký (SP@LL)

Položka | Hodnota
Cílová hardwarová zařízení | Bezdrátová sluchátka
Maximální rozlišení | 176 x 144
Maximální frekvence snímků | 15 snímků/s
Maximální přenosová rychlost | 96 kb/s
Maximální velikost vyrovnávací paměti | Asi 3,4 sekundy při maximální přenosové rychlosti

Jednoduchý střední (SP@ML)

Položka | Hodnota
Cílová hardwarová zařízení | Příruční počítače, osobní organizéry dat a nejnovější bezdrátová sluchátka
Maximální rozlišení | 352 x 288
Maximální frekvence snímků | 15 snímků/s při 352 x 288 24 snímků/s při 320 x 240
Maximální přenosová rychlost | 384 kb/s
Maximální velikost vyrovnávací paměti | Asi 3,3 sekundy při maximální přenosové rychlosti

Hlavní nízký (MP@LL)

Položka | Hodnota
Cílová hardwarová zařízení | Starší digitální terminály
Maximální rozlišení | 352 x 288
Maximální frekvence snímků | 30 snímků/s
Maximální přenosová rychlost | 2 Mb/s
Maximální velikost vyrovnávací paměti | Asi 2,5 sekundy při maximální přenosové rychlosti

Hlavní střední (MP@ML)

Položka | Hodnota
Cílová hardwarová zařízení | Nejnovější digitální terminály, přehrávače DVD, grafické karty s rozhraním DirectX Video Acceleration (VA)
Maximální rozlišení | 720 x 576
Maximální frekvence snímků | 30 snímků/s při 720 x 576 25 snímků/s při 720 x 576 (PAL)
Maximální přenosová rychlost | 10 Mb/s
Maximální velikost vyrovnávací paměti | Asi 1 sekundu při maximální přenosové rychlosti

Hlavní vysoký (MP@HL)

Položka | Hodnota
Cílová hardwarová zařízení | Přehrávače DVD, grafické karty s rozhraním DirectX VA a systémy domácího kina
Maximální rozlišení | 1920 x 1080
Maximální frekvence snímků | 30 snímků/s při 1920 x 1080 60 snímků/s při 1280 x 720
Maximální přenosová rychlost | 20 Mb/s
Maximální velikost vyrovnávací paměti | Asi 2 sekundy při maximální přenosové rychlosti

Příbuzná témata

  • Používání hardwarových profilů


Používání převodních modulů plug-in

Windows Media Encoder obsahuje upravitelné uživatelské rozhraní, které umožňuje vývojářům programovat převodní moduly plug-in, založené na přizpůsobení funkce kódování. Kodér podporuje rozhraní Microsoft DirectShow® a převodní filtry DirectX® Media DMO. Moduly plug-in je možné konfigurovat podle typu zdroje.

Další informace o rozhraní DirectShow získáte na webu společnosti Microsoft. Informace o objektech DirectX Media Object získáte na webu společnosti Microsoft.

Příbuzná témata

  • Vlastní úprava relace
  • Postup při používání převodního modulu plug-in


Postup při používání převodního modulu plug-in

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Moduly plug-in.
  2. V části Typ převodního modulu plug-in klepněte na položku Video nebo Zvuk.
  3. Klepnutím vyberte zdroj, u kterého chcete použít modul plug-in. (Nutné pouze v případě relace s více zdroji.)
  4. Jestliže seznam neobsahuje žádní dostupné moduly plug-in, klepněte na příkaz Zaregistrovat a zaškrtněte políčka modulů, které chcete použít. (Chcete-li zrušit registraci libovolného modulu, zrušte zaškrtnutí příslušného políčka.)

    Pro registraci libovolného modulu plug-in musí mít uživatel oprávnění správce pro počítač, který chce použít pro kódování.

  5. Klepněte na libovolný modul plug-in, který je v dispozici v seznamu. Potom modul klepnutím na tlačítko přesunout doprava (>>) přidejte do seznamu modulů pro zdroj.
  6. Klepnutím na příkaz Konfigurovat nakonfigurujte vybraný modul plug-in.

Upozornění - obrázek Upozornění

  • V dialogovém okně Registrace a zrušení registrace převodních modulů plug-in jsou uvedeny všechny převodní moduly, které jsou v kódovacím počítači k dispozici. Některé moduly pravděpodobně nebudou pro použití s kodérem vhodné. Pokud je zkusíte použít, může dojít k neočekávaným výsledkům.

Příbuzná témata

  • Používání převodních modulů plug-in


Možnosti výstupu

Obsah lze kódovat do souboru pro pozdější použití nebo vysílat živě. V případě vysílání můžete odesílat datový proud na server se spuštěnou službou Windows Media Services, nebo můžete povolit serverům Windows Media a přehrávačům načítat datový proud přímo z kodéru. Kopii vysílání lze archivovat do souboru. Před nebo po spuštění kódování lze provést následující operace:

  • změnit výstupní port vysílání,
  • nastavit nebo zrušit archivaci do souboru,
  • změnit název nebo umístění výstupního souboru.

Během kódování lze:

  • nastavit nebo zrušit archivaci do souboru,
  • změnit název souboru archivu v době, kdy právě neprobíhá archivace.

Během kódování nelze:

  • změnit číslo portu,
  • změnit relaci vysílání na relaci kódování do souboru.

Příbuzná témata

  • Program Windows Media Encoder
  • Kódování a archivace vysílání do souboru
  • Kódování nekomprimovaných souborů zvuku a videa
  • Vysílání obsahu živě
  • Testování obsahu


Kódování a archivace vysílání do souboru

Můžete kódovat obsah do souboru nebo archivovat živou událost do souboru pro pozdější použití.

Srovnání archivace na serveru Windows Media a archivace v kódujícím počítači

Pokud vysíláte prostřednictvím serveru Windows Media, můžete archivovat vysílání na serveru a nikoli v počítači provádějícím kódování. Archivace na serveru Windows Media je nejlepším řešením v těchto případech:

  • Chcete-li, aby archiv byl okamžitě dostupný pro prohlížení.
  • Prostředky počítače určeného ke kódování jsou převážně využívány pro kódování.
  • Máte na serveru více prostoru na disku než v kódujícím počítači.

Pokud se rozhodnete archivovat vysílání v kódujícím počítači, všechny zdroje, které použijete v relaci vysílání, budou archivovány automaticky. Archivování všech zdrojů však není vždy žádoucí. Pokud je například jedním ze zdrojů reklama, nebudete patrně chtít tuto reklamu archivovat. Můžete nastavit, aby kodér automaticky pozastavil archivaci pro zdroje, které určíte.

Povolení vyhledávání ve výstupním souboru

Indexování každého klíčového snímku je standardně zapnuto vždy při archivaci nebo kódování do souboru, pokud zdroj obsahuje video. Díky indexování obsahu mohou uživatelé využít funkcí rychlého převíjení vpřed a zpět v přehrávači při prohlížení zakódovaného obsahu. Indexování není dostupné pro vysílání. Můžete také umožnit vyhledávání na úrovni snímků ve výstupním souboru generováním časového kódu (nebo uchováním časového kódu, který je již obsažen ve zdrojovém videu). Časový kód můžete vygenerovat, pokud váš zdroj obsahuje video a zdrojem je soubor digitálního videa (DV) ve formátu AVI, digitalizační zařízení nebo digitální zařízení. Časový kód můžete uchovat, pokud zdroj obsahuje video a zdrojem je soubor digitálního videa (DV) ve formátu AVI nebo digitální zařízení. Pro uchování časového kódu u videorekordéru musíte pro relaci vytvořit seznam EDL. Časový kód nelze uchovat ani vytvořit, pokud aplikujete filtr pro inverzní přepis Telecine.

Dočasné uložení obsahu

Pokud kódujete do souboru a zdrojem je zařízení, proces kódování se může opozdit za procesem digitalizace, čímž se sníží kvalita kódovaného obsahu. Aby se tomu zamezilo, můžete dočasně ukládat digitalizovaný obsah a poté jej kódovat do souboru. Pokud zvolíte tuto možnost, digitalizace a kódování bude probíhat souběžně a data budou dočasně ukládána, pouze pokud se kódování bude opožďovat. Nejlepší kvality, obzvláště při digitalizaci velkého množství dat, lze dosáhnout tak, že nejprve provedete digitalizaci a kódování spustíte až po zastavení digitalizace. (Tato možnost není dostupná, pokud je zdrojem digitální zařízení. Pokud nejprve digitalizujete, nelze navíc při následném kódování omezit velikost nebo délku výstupního souboru.)

Pokud tuto možnost použijete (včetně možnosti nejprve digitalizovat a potom kódovat) v relaci s více zdroji, je nutné před ukončením kódování počkat, dokud se neuloží všechna data z prvního zdroje. Můžete např. používat dva zdroje a chcete digitalizovat pouze část druhého zdroje. Během kódování je možné přepnout na druhý zdroj. Před ukončením kódování je však nutné počkat, až se na náhledech (na panelu Video) nebo v části Vstup (karta Obecné panelu Sledování) zobrazí, že první zdroj dokončil odesílání všech dat. V tomto případě je zajištěno, že se digitalizuje požadovaná část obsahu.

Příbuzná témata

  • Možnosti výstupu
  • Soubory s příponami ASF, WMA a WMV
  • Vytvoření seznamu EDL
  • Postup při kódování do souboru
  • Postup při nastavování možností archivace jednotlivých zdrojů
  • Postup při zapínání a vypínání indexování
  • Postup při povolování vyhledávání po snímcích
  • Postup při dočasném ukládání digitalizovaného obsahu
  • Kódování nekomprimovaných souborů zvuku a videa


Soubory s příponami ASF, WMA a WMV

Přípony ASF, WMA a WMV označují soubory ve standardním formátu Windows Media. Přípona ASF je běžně používána pro obsah určený pro Windows Media vytvořený pomocí nástrojů Windows Media Tools 4.0. Přípony WMA a WMV byly vytvořeny jako standard pro konvenci pojmenování pro program Windows Media Encoder 7, aby uživatelé mohli jednoduše odlišit soubory obsahující pouze zvuk (WMA) a soubory obsahující video (WMV). Všechny tyto tři přípony jsou však vzájemně zaměnitelné. Některé nástroje a služby vytvořené pro použití s dřívějšími verzemi technologií Windows Media vyžadují soubory s příponou ASF. Stačí jen přejmenovat příponu WMA nebo WMV v názvu souboru na příponu ASF a soubor bude použitelný i pro tyto nástroje. (Doporučujeme však v rámci možností používat aktuální nástroje a služby.)

Příbuzná témata

  • Kódování a archivace vysílání do souboru:


Postup při kódování do souboru

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Výstup.
  2. Zrušte zaškrtnutí políček Odeslat na server a Načítat z kodéru.
  3. Zaškrtněte políčko Kódovat do souboru.
  4. Do políčka Název souboru zadejte název výstupního souboru.
  5. Chcete-li omezit velikost výstupního souboru, klepněte na položku Omezit velikost a zadejte maximální velikost souboru s označením K (kilobajty), M (megabajty) nebo G (gigabajty).
  6. Chcete-li omezit stopáž výstupního souboru, klepněte na položku Omezit stopáž a zadejte maximální stopáž souboru ve formátu hh:mm:ss; např. 01:30:00.

Příbuzná témata

  • Kódování a archivace vysílání do souboru


Postup při nastavování možností archivace jednotlivých zdrojů

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Výstup.
  2. Vyberte metodu vysílání (odesílání nebo načítání) a potom zaškrtněte políčko Archivovat do souboru.
  3. Do políčka Název souboru zadejte název archivního souboru.
  4. Chcete-li omezit velikost archivního souboru, klepněte na položku Omezit velikost a zadejte maximální velikost souboru s označením K (kilobajty), M (megabajty) nebo G (gigabajty).
  5. Chcete-li omezit stopáž archivního souboru, klepněte na položku Omezit stopáž a zadejte maximální stopáž souboru ve formátu hh:mm:ss, např. 01:30:00.
  6. Pokud nechcete, aby se archivovaly všechny zdroje vysílání, klepněte na kartu Zdroje a v seznamu zdrojů klepněte na zdroj, který nechcete archivovat.
  7. Klepnutím na příkaz Pozastavit nebo Zastavit v části Archivace zabráníte archivaci daného zdroje.

    Tato nastavení lze potlačit použitím možnosti Ruční řízení archivace v nabídce Ovládání.

Příbuzná témata

  • Kódování a archivace vysílání do souboru


Postup při zapínání a vypínání indexování

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Výstup.
  2. Zaškrtněte políčko Kódovat do souboru nebo Archivovat do souboru.
  3. Zaškrtnutím nebo zrušením zaškrtnutí políčka Přidat index se indexování zapíná nebo vypíná.

Poznámka - obrázek Poznámka

  • Indexování umožňuje provádět vyhledávání klíčových snímků. Vyhledávání po snímcích lze povolit pro některý druh obsahu.

Příbuzná témata

  • Kódování a archivace vysílání do souboru
  • Postup při povolování vyhledávání po snímcích


Postup při povolování vyhledávání po snímcích

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Upřesnit.
  2. Zaškrtněte políčko Časový kód.
  3. Pokud je zdrojové video již vybaveno časovým kódem, klepněte na příkaz Zachovat původní.

    -nebo-

    Chcete-li vygenerovat časový kód, klepněte na příkaz Vytvořit nový časový kód. Do políčka Začátek potom zadejte čas ve formátu hh:mm:ss:fm, ve kterém se má časový kód spustit. V seznamu Formát videa dále vyberte formát zdrojového videa.

Poznámka - obrázek Poznámka

  • Časový kód je možné vygenerovat pro zdroj, který obsahuje video a pokud jako zdroj používáte soubory digitálního videa (DV) ve formátu AVI (Audio-Video Interleaved), zařízení pro digitalizaci a digitální zařízení. Časový kód je možné zachovat, pokud zdroj obsahuje video a pokud jako zdroj používáte soubory digitálního videa (DV) ve formátu AVI (Audio-Video Interleaved) nebo digitální zařízení. Chcete-li zachovat časový kód videorekordéru, který je připojen prostřednictvím portu COM a používá protokol Sony RS422, je třeba pro tuto relaci vytvořit seznam EDL. Jestliže používáte inverzní filtr Telecine, nelze časový kód zachovat ani vytvořit.

Příbuzná témata

  • Kódování a archivace vysílání do souboru


Postup při dočasném ukládání digitalizovaného obsahu

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Upřesnit.
  2. Zaškrtněte políčko Dočasně uložit obsah na pevný disk.
  3. Chcete-li obsah nejprve digitalizovat a potom uložit, zaškrtněte políčko Nejdříve digitalizovat na pevný disk, pak kódovat.

Poznámka - obrázek Poznámka

  • Pokud jako zdroj používáte digitální zařízení, není k dispozici možnost Nejdříve digitalizovat na pevný disk, pak kódovat.

Příbuzná témata

  • Kódování a archivace vysílání do souboru


Kódování nekomprimovaných souborů zvuku a videa

Program Windows Media Encoder umožňuje digitalizaci a archivaci velmi kvalitního obsahu do archivního souboru pro pozdější použití. Ve většině případů je nejvhodnější možnost Archiv souborů, která využívá kódování VBR podle kvality. Chcete-li ovšem obsah později upravovat, pravděpodobně využijete možnosti kódování nekomprimovaných souborů.

Nekomprimované soubory mají značně vyšší požadavky na ukládání než komprimované soubory. Doporučujeme ukládat obsah do svazku NTFS. U souborového systému FAT32 je velikost souboru omezena na 4 GB. Pokud předpokládáte, že velikost obsahu přesáhne 4 GB, je třeba změnit konfiguraci pevného disku na formát NTFS.

Při digitalizace nekomprimovaného obsahu ze zařízení, např. z kamery nebo z videorekordéru, bude výsledné video vytvořeno ve formátu YV12 YUV, bez ohledu na formát pixelu zadaný v zařízení nebo v profilu. Protože je kodek Windows Media Video 9 optimalizován pro formát YUV, je tento formát upřednostňován pro kvalitu, velikost a výkon. Výsledný zvuk je vytvořen ve formátu pulzní kódové modulace (PCM).

Pro dosažení nejlepších výsledků při digitalizaci nekomprimovaného obsahu dodržujte tyto zásady:

  • Používejte rychlý pevný disk, který bude stačit na kódování při vysokých přenosových rychlostech.
  • Při digitalizaci rozlišení 640 x 480 používejte frekvenci 15 snímků/s.
  • Při digitalizaci rozlišení 320 x 240 používejte frekvenci 30 snímků/s.

Příbuzná témata

  • Možnosti výstupu
  • Postup při používání možnosti Archiv souborů
  • Postup při kódování nekomprimovaného obsahu


Postup při používání možnosti Archiv souborů

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Výstup.
  2. Zrušte zaškrtnutí políček Odesílat a Načítat a potom zaškrtněte políčko Kódovat do souboru.
  3. Klepněte na kartu Komprese a potom v části Cíl klepněte na položku Archiv souborů.
  4. V částech Video a Zvuk vyberte požadovaná nastavení kvality.

Příbuzná témata

  • Kódování nekomprimovaných souborů zvuku a videa


Postup při kódování nekomprimovaného obsahu

  1. Na panelu nástrojů klepněte na Vlastnosti a potom klepněte na kartu Komprese.
  2. V části Cíl klepněte na položku Server Windows Media nebo Webový server a potom klepněte na příkaz Upravit.
  3. Jestliže kódujete zvuk, zaškrtněte políčko Zvuk a potom v části Kodek klepněte na položku Žádný (PCM).
  4. Jestliže kódujete video, zaškrtněte políčko Video a potom v části Kodek klepněte na položku Úplné snímky (bez komprese).

Poznámka - obrázek Poznámka

  • Při kódování zvuku i videa je třeba použít pro obojí možnost bez komprese.
  • Nekomprimovaný obsah nelze kódovat do datového proudu MBR.

Příbuzná témata

  • Kódování nekomprimovaných souborů zvuku a videa


Vysílání obsahu živě

Pokud chcete obsah vysílat, můžete datový proud odeslat z kodéru na server Windows Media, nebo můžete umožnit klientům (serverům Windows Media nebo přehrávačům) obsah stáhnout. Použitá metoda závisí na situaci.

Scénáře odesílání

Odesílání datového proudu z kodéru je užitečné, pokud kodér je za serverem firewall nebo pokud chcete zahájit připojení z kodéru. Předpokládejme například, že jste právě obdrželi na poslední chvíli zprávu o tom, že prezident vaší společnosti chce odvysílat řeč ke svým zaměstnancům. Server Windows Media je umístěn vzdáleně, za firemním serverem firewall. Správce serveru má právě půlnoc. Odesláním datového proudu z kodéru můžete dostat tento datový proud za server firewall a splnit požadavek prezidenta bez nutnosti nouzového shánění správce serveru. Distribuci odesíláním umožňuje pouze služba Windows Media Services 9 Series serveru Windows .NET Server 2003.

Scénáře stahování

Umožnění stahování datového proudu ze serverů Windows Media je užitečné v několika případech. Zaprvé, pokud je několik distribučních serverů a připojují se v různou dobu, může se každý tento server připojit ke kodéru ve chvíli, kdy je připraven přenášet datový proud. Za druhé, stahování ze serveru je užitečné, pokud je důležité minimalizovat využití šířky pásma mezi serverem a kodérem. Správce serveru může například přidat adresář pro publikování a konfigurovat jej tak, aby se spouštěl automaticky při požadavku klienta, což znamená, že server se nepřipojí ke kodéru, dokud se k němu nepřipojí první klient. Tím se eliminuje zbytečné zatížení přenosového pásma mezi serverem a kodérem. (Tento scénář umožňuje využít pouze služba Windows Media Services 9 Series serveru Windows .NET Server 2003.) A konečně, stahování ze serveru je také užitečné, pokud je server za serverem firewall. Předpokládejme například, že máte nastaven kodér ve veřejné síti, protože vysíláte události z konference. Potřebujete dostat datový proud na distribuční server v zabezpečené síti. Správce serveru pak může stáhnout datový proud přes server firewall.

Umožnění stahování datového proudu do přehrávačů je užitečné, pokud neočekáváte, že by datový proud sledovalo mnoho klientů. Windows Media Encoder dovoluje přímé připojení až pěti klientů v průběhu vysílání. Jestliže povolujete klientům stáhnout si datový proud, můžete omezit přístup k obsahu podle adresy IP nebo podle skupin adres IP.

Příbuzná témata

  • Možnosti výstupu
  • Srovnání serverů Windows Media a webových serverů
  • Odeslání datového proudu z kodéru
  • Povolení klientům načítat datový proud z kodéru
  • Vytvoření oznámení vysílání Multicast
  • Omezení přístupu k vysílání


Odeslání datového proudu z kodéru

Při odesílání nabídky datového proudu z programu Windows Media Encoder je nutné určit přijímající server Windows Media a adresář pro publikování vysílání (nový, nebo již existující), pomocí kterého bude nabídka odeslána. Na serveru Windows Media lze v adresáři pro publikování vysílání nakonfigurovat několik možností, jako jsou nastavení omezení počtu přehrávačů, které budou mít přístup k datovému proudu, řízení přístupu k obsahu a nastavení přihlášení. Chcete-li konfiguraci adresáře pro publikování vysílání použít opakovaně, můžete postupovat tak, že na serveru tento adresář určíte, nastavíte požadovanou konfiguraci a nastavení kopírujete při každém odeslání nabídky datového proudu na server. Více informací o konfigurování adresářů pro publikování vysílání naleznete v nápovědě služby Windows Media Services. Funkce odesílání nabídky datového proudu je přístupná pouze u služby Windows Media Services 9 Series serveru Windows .NET Server 2003.

Obsah médií může být ze serveru Windows Media doručen pomocí vysílání Multicast nebo Unicast.

Oznámení požadované pro datové proudy vysílání Multicast

Chcete-li ze serveru doručit obsah médií pomocí vysílání Multicast, je nutné před spuštěním procesu kódování vytvořit a distribuovat oznámení. Oznámení dává na vědomí, že obsah médií se stává přístupný pro přehrávače. Toto oznámení lze vytvořit pomocí Průvodce oznámením vysílání Multicast nebo jej lze vytvořit na serveru. Vytvoření oznámení v programu Windows Media Encoder vyžaduje přístupová práva ke službě Windows Media Services pomocí distribuované verze modelu DCOM. Změníte-li během relace nastavení konfigurace, je třeba před spuštěním procesu kódování vytvořit oznámení znovu.

Přístup k serveru Windows Media

Aby bylo možno vytvořit nabídku datového proudu pro server Windows Media, musí být na tomto serveru povolen modul plug-in pro WMS protokol správy serverů v protokolu HTTP. Navíc je třeba mít povolení zápisu při přístupu na server pomocí modulu plug-in pro WMS oprávnění seznamu ACL adresářů pro publikování. Chcete-li namísto serveru vytvořit adresář pro publikování vysílání v programu Windows Media Encoder, musíte mít také povolení vytvoření přístupu pro modul plug-in. Povolení musí být nastavena na úrovni serveru i adresáře pro publikování. Konfigurace modulu plug-in vyžaduje přístupová práva ke službě Windows Media Services pomocí modelu DCOM.

Místní správci mají na serveru jak povolení zápisu, tak povolení vytvoření.

Při spuštění kódování se program Windows Media Encoder připojí k serveru.

Chcete-li vytvořit nabídku datového proudu pro server Windows Media, můžete použít Průvodce oznámením vysílání Multicast, nabídku Rychlé zahájení vysílání nebo můžete vytvořit relaci nabídky datového proudu z panelu Vlastnosti.

Více informací o vytvoření nabídky datového proudu vysílání Unicast nebo Multicast pro server Windows Media naleznete v nápovědě služby Windows Media Services.

Příbuzná témata

  • Vysílání obsahu živě
  • Vytvoření oznámení vysílání Multicast
  • Postup při odesílání datového proudu na server Windows Media
© 2000-2002 Microsoft Corporation.Všechna práva vyhrazena.


Postup při odesílání datového proudu na server Windows Media

  1. Na panelu nástrojů klepněte na Vlastnosti a potom klepněte na kartu Výstup.
  2. Zaškrtněte políčko Vysílat na server a zrušte zaškrtnutí políčka Načítat z kodéru.
  3. Do políčka Název serveru zadejte název serveru Windows Media, ze kterého chcete obsah distribuovat. Můžete použít název pro rozhraní NetBIOS, adresu IP nebo DNS (Domain Name System) serveru.

    Pro odesílání datového proudu na server používá kodér protokol HTTP. Pro tento protokol používá server standardně port 80. Pokud je server nakonfigurován pro použití jiného čísla portu, musí kodér odpovídat číslu portu. Do políčka Název serveru můžete zadat název ve formátu název_serveru:číslo_portu. Jestliže máte přístupové oprávnění ke službám Windows Media Services prostřednictvím DCOM, bude číslo portu rozpoznáno automaticky.

  4. Do políčka Adresář pro publikování zadejte název stávajícího nebo nového adresáře pro publikování, jehož prostřednictvím chcete odesílat datový proud. Při vytváření adresáře používejte pouze alfanumerické znaky. Dále nejsou pro název adresáře pro publikování platné tyto znaky: * < > \ ? % & # " { } | ^ [ ] `

    Chcete-li vytvořit adresář pro publikování z kodéru, je nejprve nutné vytvořit přístupové oprávnění prostřednictvím modulu plug-in WMS Publishing Points ACL Authorization (na úrovni serveru i adresáře pro publikování) serveru Windows Media.

  5. Při vytváření adresáře pro publikování můžete použít konfiguraci výchozího adresáře nebo můžete zkopírovat konfiguraci stávajícího adresáře do adresáře pro publikování, který vytváříte. Chcete-li konfiguraci zkopírovat, zadejte do políčka Kopírovat nastavení z název stávajícího adresáře pro publikování s požadovanou konfigurací.
  6. Chcete-li adresář pro publikování, jehož prostřednictvím odesíláte datový proud, odebrat po ukončení kodéru (nebo po vypršení několikaminutového časového limitu), zaškrtněte políčko Odebrat automaticky.

    Časový limit umožňuje uživateli ukončit a restartovat kódování, aniž by bylo nutné vytvořit adresář pro publikování. Tato funkce je užitečná, chcete-li například upravit nastavení relace a potom pokračovat v kódování.

Poznámka - obrázek Poznámka

  • Chcete-li obsah odeslat jako datový proud Multicast, je rovněž třeba vytvořit oznámení.

Příbuzná témata

  • Odeslání datového proudu z kodéru
  • Vytvoření oznámení vysílání Multicast


Vytvoření oznámení vysílání Multicast

Pokud odesíláte datový proud na server Windows Media a distribuujete jej jako datový proud typu multicast, musíte vytvořit oznámení (ASX) a soubor informací multicast (.nsc). Oznámení je metasoubor serveru Windows Media odkazující přehrávače na soubor informací multicast. Soubor informací multicast obsahuje informace umožňující přehrávačům přistupovat k datovému proudu typu multicast a dekódovat jej. Součástí těchto informací je adresa IP, číslo portu a informace o formátu datového proudu.

Vytvoření oznámení

Pro vytvoření oznámení můžete použít Průvodce oznámením vysílání Multicast v kodéru, nebo můžete oznámení vytvořit na serveru Windows Media. Vytvoření oznámení v kodéru vyžaduje, abyste měli oprávnění přístupu ke službám Windows Media Services prostřednictvím protokolu DCOM. Pokud po vytvoření oznámení provedete jakékoli změny konfigurace relace, musíte před zahájením kódování vytvořit nové oznámení.

Když spouštíte průvodce z kodéru, vytvoříte soubor s oznámením, soubor informací multicast a webovou stránku obsahující vložený přehrávač a odkaz na oznámení. Budete požádáni o zadání názvů těchto souborů a o uložení těchto souborů do úložného prostoru přístupného pro přehrávače (nebo do dočasného umístění, pokud chcete data vysílat později). Úložným prostorem může být web přístupný prostřednictvím HTTP nebo veřejně sdílený prostor, pokud poskytujete přístup pomocí cesty UNC. Pokud soubory zpřístupníte prostřednictvím webu, ujistěte se, zda konfigurace webu nedovoluje ukládání souborů do mezipaměti nebo zda vyžaduje kontrolu obnovení při použití mezipaměti u klienta, aby přehrávače nepoužívaly zastaralé informace pro vysílání multicast.

Distribuce souboru s oznámením

Máte několik možností zpřístupnění datového proudu multicast uživatelům. Můžete umístit odkaz na soubor s oznámením na webovou stránku, zpřístupnit oznámení ve sdílené složce nebo odeslat oznámení ve zprávě elektronické pošty. Uživatelé mohou přistupovat k oznámení klepnutím na odkaz na oznámení na webové stránce nebo přímo otevřením tohoto oznámení. Pokud uživatel otevře soubor s oznámením (ASX) v přehrávači, přehrávač použije adresu URL obsaženou v oznámení. Tato adresa URL odkazuje na sobor informací multicast. Přehrávač poté stáhne soubor informací multicast z dané adresy URL a začne přehrávat obsah.

Příbuzná témata

  • Vysílání obsahu živě
  • Postup při spouštění Průvodce oznámením vysílání Multicast


Postup při spouštění Průvodce oznámením vysílání Multicast

  1. Vytvořte relaci pro odesílání na server Windows Media, který bude distribuovat obsah jako datový proud vysílání Multicast.
  2. V nabídce Nástroje klepněte na položku Oznámit vysílání.
  3. Postupujte podle pokynů průvodce pro vytvoření souborů pro tuto relaci.

Příbuzná témata

  • Odeslání datového proudu z kodéru
  • Vytvoření oznámení vysílání Multicast


Povolení klientům načítat datový proud z kodéru

Chcete-li klientům povolit načítání datového proudu z kodéru, jednoduše vytvořte libovolnou relaci a spusťte vysílání přímo z kodéru. Klienti (servery Windows Media nebo přehrávače) se mohou k datovému proudu kdykoli připojit prostřednictvím adresy URL v následujícím formátu: http://adresa_IP:port (pro připojení v síti Internet) nebo http://název_kódovacího_počítače:port (pro připojení v místní síti LAN). Kodér standardně podporuje až pět přímých připojení během vysílání. Tento počet lze úpravou klíče registru zvýšit až na 50. (Pro úpravu tohoto klíče je třeba oprávnění správce kódovacího počítače.)

Požadovaný formát datového proudu pro vícesměrový přenos

Chcete-li poskytovat obsah jako vícesměrový datový proud ze serveru Windows Media, musí být server schopen rozpoznat formát datového proudu z kodéru. Formát datového proudu obsahuje informace, které používají přehrávače pro dekódování vícesměrového datového proudu, jako jsou kodeky, přenosové rychlosti a velikosti snímků. Tento formát je uložen v hlavičce datového proudu. Jestliže spustíte kódování předtím, než server naváže spojení s kodérem, server automaticky rozpozná formát datového proudu. Pokud ale nechcete nejprve spustit kódování, můžete vytvořit soubor s formátem datového proudu a zpřístupnit jej správci serveru. Správce může soubor přidat do seznamu podporovaných formátů datového proudu v adresáři pro publikování na serveru. Soubory s formátem datového proudu mají příponu ASF.

Upozornění - obrázek Upozornění

  • Chybná úprava registru může způsobit vážné poškození systému. Před prováděním úprav registru je třeba zálohovat v počítači veškerá důležitá data.

Poznámka - obrázek Poznámka

  • Toto téma obsahuje pouze na kroky, které je třeba provést s kodérem, když server Windows Media inicializuje datový proud. Další informace o krocích, které je třeba provést na serveru Windows Media, najdete v nápovědě programu Windows Media Services.

Příbuzná témata

  • Vysílání obsahu živě
  • Postup při povolování klientům načítat datový proud z kodéru
  • Postup při vytváření souboru ve formátu datového proudu
  • Srovnání serverů Windows Media a webových serverů
  • Postup při zvyšování maximálního počtu přímých připojení


Postup při povolování klientům načítat datový proud z kodéru

  1. Na panelu nástrojů klepněte na položku Vlastnosti a potom klepněte na kartu Výstup.
  2. Zaškrtněte políčko Načítat z kodéru.

Příbuzná témata

  • Povolení klientům načítat datový proud z kodéru


Postup při vytváření souboru ve formátu datového proudu

  1. Vytvořte relaci, která umožňuje serveru Windows Media načítat datový proud z kodéru.
  2. V nabídce Nástroje klepněte na příkaz Vytvořit soubor ve formátu datového proudu.
  3. Do políčka Název souboru zadejte název a umístění souboru a potom klepněte na tlačítko Uložit.
  4. Předejte soubor správci serveru Windows Media.

Poznámka - obrázek Poznámka

  • Pokud změníte některé nastavení konfigurace kodéru, je třeba vytvořit jiný soubor ve formátu datového proudu a předat jej správci serveru Windows Media.

Příbuzná témata

  • Povolení klientům načítat datový proud z kodéru
  • Postup při povolování klientům načítat datový proud z kodéru


Postup při zvyšování maximálního počtu přímých připojení

  1. V editoru registru vyhledejte ve stromu zobrazení následující podklíč: HKEY_CLASSES_ROOT\Software\Microsoft\Windows Media Tools\Encoder\MaxClientConnections.
  2. Upravte podklíč tak, aby udával maximální počet přímých připojení, které chcete umožnit. Maximální možný počet je 50.

Upozornění - obrázek Upozornění

  • Chybná úprava registru může způsobit vážné poškození systému. Před prováděním úprav registru je třeba zálohovat v počítači veškerá důležitá data.

Příbuzná témata

  • Povolení klientům načítat datový proud z kodéru


Omezení přístupu k vysílání

Chcete-li klientům povolit načítání datového proudu z kodéru, můžete přístup k vysílání povolit nebo zakázat podle statické adresy IP nebo skupin adres IP. Při výchozím nastavení nemá žádný klient omezen přístup k vysílání. Chcete-li určit klienty, kteří se mohou k vysílání připojit, přidejte příslušné adresy IP do seznamu povolených klientů. Po provedení tohoto kroku se klienti, kteří nejsou v seznamu uvedeni, nebudou moci připojit. Chcete-li konkrétnímu klientovi zabránit v připojení k vysílání, můžete rovněž přidat jeho adresu IP do seznamu zakázaných klientů.

Provedete-li změny v seznamu adres IP během kódování, projeví se změny pouze pro klienty, kteří se připojí po provedení změn. Pokud například přidáte do seznamu zakázaných klientů adresu IP klienta, který je právě připojen, klient nebude odpojen. Jestliže se však klient odpojí a pokusí se znovu připojit ke stejnému vysílání, bude přístup odmítnut. Je-li nezbytně nutné klienta odpojit ihned, je možné ukončit kódování.

V následující tabulce je uveden příklad pořadí, ve kterém jsou adresy IP povoleny nebo zakázány podle omezení nastavených uživatelem.

Seznam povolených klientů | Seznam zakázaných klientů | Výsledek
Prázdné | Prázdné | Povolit všechny adresy IP
Prázdné | Adresa IP 1 | Zakázat adresu IP 1, povolit všechny ostatní
Adresa IP 1 | Prázdné | Povolit adresu IP 1, zakázat všechny ostatní
Adresa IP 1 | Adresa IP 2 | Povolit adresu IP 1, zakázat všechny ostatní
Adresa IP 1 | Adresa IP 1 | Zakázat všechny adresy IP
Adresa IP 1, adresa IP 2 | Adresa IP 1 | Povolit adresu IP 2, zakázat všechny ostatní

Zvolíte-li omezení přístupu k vysílání podle adres IP, můžete specifikovat adresy Internet Protocol verze 6 (IPv6) a Internet Protocol verze 4 (IPv4). IPv6 je nejnovější verze standardu Internet Protocol, která je přizpůsobena vzrůstajícímu požadavku na jedinečné adresy IP. IPv6 zvyšuje velikost adresy IP z 32 na 128 bitů a umožňuje tak využívat rozsáhlejší hierarchii adresování a větší počet adresovatelných uzlů. Další informace o IPv6 najdete na stránce věnované tomuto standardu na webu společnosti Microsoft.

Poznámka - obrázek Poznámka

  • Chcete-li sledovat, které adresy IP se připojují k vašemu vysílání, povolte na kartě Protokol událostí na panelu Sledování protokolování do souboru.

Příbuzná témata

  • Vysílání obsahu živě
  • Povolení nebo zákaz přístupu k vysílání


Postup při povolování a zakazování přístupu k vysílání

  1. V nabídce Nástroje klepněte na Zabezpečení vysílání.
  2. Použijte jeden z těchto postupů:
    • Chcete-li povolit přístup ke kódovacímu počítači, klepněte v části Povolit na příkaz Přidat.
    • Chcete-li zakázat přístup ke kódovacímu počítači, klepněte v části Zakázat na příkaz Přidat.
  3. Do políčka Adresa IP zapište adresu IP počítače, pro který chcete povolit nebo zakázat přístup.

    -nebo-

    Do políčka Maska IP zadejte rozsah adres IP, pro které chcete povolit nebo zakázat přístup.

  4. Klepněte na příkaz Přidat.
  5. Opakujte kroky 3 a 4 pro všechny adresy IP.

Příbuzná témata

  • Omezení přístupu k vysílání


Testování obsahu

Před vysíláním uživatelům je vždy vhodné obsah zkontrolovat. Chcete-li spustit test, nakonfigurujte relaci a potom zakódujte část obsahu. Během kódování připojte prostřednictvím adresy URL uvedené na kartě Připojení panelu Sledování přehrávač ke kodéru a zobrazte datový proud. Jestliže kódujete do souboru, můžete kodér zastavit a přehrát výstupní soubor.

Pokud chcete obsah distribuovat prostřednictvím serveru Windows Media, můžete provést koncový test. Chcete-li test provést, nastavte na serveru Windows Media připojení ke kodéru prostřednictvím adresy URL uvedené na kartě Připojení panelu Sledování.

Během zobrazení proudu zkontrolujte:

  • Zda bylo dosaženo očekávané frekvence snímků.
  • Zda je přijatelná propustnost šířky pásma.
  • Zda je přijatelná kvalita přijímaného zvuku a videa.

Další informace o vysílání datového proudu ze serveru Windows Media najdete v nápovědě programu Windows Media Services.

Příbuzná témata

  • Možnosti výstupu


Možnosti konfigurace systému

Tato část obsahuje informace o možnostech konfigurace kódovacího systému uživatele, včetně informací, které se týkají zabezpečení kódovacího počítače a ochraně kódovaného obsahu, nastavení optimálního výkonu systému, spouštění několika instancí kodéru v jednom počítači a dávkovém kódování.

Příbuzná témata

  • Program Windows Media Encoder
  • Zabezpečení a Windows Media Encoder
  • Nastavení optimálního výkonu systému
  • Doporučené postupy nastavení komprese
  • Spuštění několika kodérů v jednom počítači
  • Dávkové kódování


Zabezpečení a Windows Media Encoder

Bezpečnostní opatření, která souvisejí s programem Windows Media Encoder, zahrnují zabezpečení kódovacího počítače a také kódovaného obsahu. Další informace o problematice zabezpečení kódovacího počítače najdete v části dokumentace k operačnímu systému věnované zabezpečení.

Obsah vysílání lze během vysílání chránit prostřednictvím správy práv k digitálním médiím (DRM).

Během vysílání je možné omezit přístup ke kodéru prostřednictvím adresy IP. Navíc lze využít zabezpečení protokolu Internet Protocol Security (IPSec). Jedná se o sadu oborových standardů pro ověření, která případně umožňuje šifrovat data na úrovni paketů IP. Další informace o zabezpečení IPSec najdete v nápovědě a podpoře operačního systému Windows.

Provádíte-li kódování obsahu, která je určen pro vysílání ze serveru Windows Media, najdete informace o zabezpečení a o serveru Windows Media v nápovědě služby Windows Media Services.

Příbuzná témata

  • Možnosti konfigurace systému
  • Použití technologie DRM (Digital Rights Management) k ochraně obsahu
  • Omezení přístupu k vysílání


Nastavení optimálního výkonu systému

Návod pro dosažení optimálního výkonu systému:

  • Používejte počítač s rychlým procesorem nebo více procesory. Protože kvalitní kódování vyžaduje více výpočetního výkonu, používejte počítač s rychlým procesorem nebo více procesory, především pro živé události. Windows Media Encoder může využít až dva procesory pro zvuk a až čtyři procesory pro video a efektivně tak rozložit zatížení při kódování. Pokud používáte kodek Windows Media Video 9, můžete také upravit nastavení výkonu a zajistit tak úspěšné kódování. Obecně platí, že pokud zjistíte, že stále dosahujete nebo přesahujete 80 procent zatížení procesoru (zatížení je znázorněno na kartě Obecné na panelu Monitor), měli byste zvážit možnost inovace počítače.
  • Používejte podporované zvukové karty a videokarty. Úplný seznam podporovaných karet naleznete na webu společnosti Microsoft.
  • Používejte Microsoft Windows XP Professional. Systém Windows XP Professional zcela využije možnosti víceprocesorového počítače automatickým rozložením jednotlivých podprocesů, aby tak umožnil procesům provádět různé části programů souběžně na různých procesorech. Toto rozdělení práce umožňuje provádět vysoce náročné úlohy kódování, aniž by docházelo k přetěžování procesoru.
  • Prověřte šířku pásma připojení do sítě. Zřídkakdy se stane, že dosáhnete 100% propustnosti při odesílání obsahu do sítě. Pro dosažení optimálních výsledků zajistěte, aby síť mohla pojmout agregovanou šířku pásma požadovanou pro relaci vysílání spolu s rezervou pro HTTP.
  • Používejte vysoce výkonný pevný disk. Pro archivaci a převod souborů používejte vysoce výkonný pevný disk, například pevný disk s rozhraním SCSI a rychlostí 15 000 otáček za minutu. Použití vysoce výkonného pevného disku může pomoci snížit požadavky na výkon procesoru, protože se uvolní výpočetní výkon pro kódování. Je také užitečné používat jeden pevný disk pouze pro účely kódování.
  • Provozujte kodér na vyhrazeném počítači. Pokud posíláte obsah ve formě datového proudu ze serveru provozujícího Windows Media Services, doporučujeme, abyste spouštěli kodér na samostatném počítači a nikoliv přímo na serveru Windows Media.
  • Vypněte náhled a výsledné zobrazení pro video. Oblasti Vstup a Výstup v hlavním okně kodéru zobrazují, jak obsah vypadá před kódováním a po něm. Vypnutí tohoto zobrazení zvýší výkon pro kódování. Případně můžete částečně zvýšit výkon kódování zmenšením těchto pohledů.
  • Uchovávejte dočasně digitalizovaný obsah. Pokud kódujete do souboru a zdrojem je zařízení, uložte obsah dočasně na pevný disk. Používejte k tomuto účelu jiný pevný disk, než který se používá pro kódování.

Příbuzná témata

  • Možnosti konfigurace systému
  • Úprava nastavení výkonu kodéru
  • Postup při vypínání a zmenšování náhledu videa
  • Zvyšování výkonu při kódování obrazovek
  • Postup při dočasném ukládání digitalizovaného obsahu


Postup při vypínání a zmenšování náhledu videa

  1. V nabídce Zobrazit klepněte na položku Panel Video.
  2. Chcete-li vypnout náhled videa, klepněte v části Zobrazení na položku Výstup.

    -nebo-

    Chcete-li zmenšit velikost náhledu, klepněte v části Velikost na položku 50 %.

Příbuzná témata

  • Nastavení optimálního výkonu systému


Úprava nastavení výkonu kodéru

Kódování je proces náročný na výkon procesoru. Pokud soustavně přesahujete schopnosti počítače určeného pro kódování, můžete zobrazit přehled posledních požadavků na hardware a software a rozhodnout, zda nepotřebujete počítač s vyšším výkonem. Pokud inovaci nelze provést, můžete alespoň upravit nastavení výkonu kodéru pro zajištění úspěšného kódování. (Nastavení lze použít pouze pro relace, ve kterých se používá kodek Windows Media Video 9.) Volbou výkonu určíte, zda klást důraz na vyšší výkon nebo na vyšší kvalitu. Nastavení vyššího výkonu znamená nižší zatížení procesoru, vyšší kvalita znamená vyšší zatížení procesoru. Při nastavování výkonu mějte na paměti následující fakta:

  • Není-li důležité množství času potřebné pro kódování, můžete použít volbu vyšší kvality. Tato volba je nejvhodnější pro situace, ve kterých zdrojem kódování je soubor a kóduje se rovněž do souboru. Kodér použije pro kódování tolik času, kolik bude potřebovat.
  • Je-li důležité, aby kódování probíhalo souběžně s digitalizací, použijte nastavení vyššího výkonu. To je vhodné v situacích, kdy se vysílá nebo v situacích, kdy zdrojem je zařízení a kóduje se do souboru. Při kódování do souboru můžete také použít dočasný úložný prostor pro digitalizovaný obsah. Při použití dočasného úložiště jsou digitalizovaná data dočasně ukládána ve chvílích, kdy se proces kódování opožďuje za procesem digitalizace.

Ve všech těchto situacích můžete zkusit použít různá nastavení výkonu a pokusit se najít vyvážený poměr kvality a výkonu pro svůj počítač. Nezapomeňte, že v průběhu kódování ovlivňují výkon procesoru ještě další faktory. Například nastavení relace, jako je frekvence snímků, přenosová rychlost a velikost snímku, mají vliv na to, kolik výpočetního výkonu procesoru se spotřebuje při provádění kódování. Další programy běžící v počítači provádějícím kódování navíc nechávají méně výpočetního výkonu pro kodér.

Příbuzná témata

  • Nastavení optimálního výkonu systému
  • Požadavky na hardware a software
  • Kódování a archivace vysílání do souboru
  • Postup při úpravě nastavení výkonu
  • Postup při dočasném ukládání digitalizovaného obsahu


Postup při úpravě nastavení výkonu

  1. V nabídce Nástroje klepněte na položku Možnosti a potom na kartu Výkon.
  2. V části Při vysílání nastavte jezdec do požadované polohy.
  3. V části Při kódování do souboru nastavte jezdec do požadované polohy.

Příbuzná témata

  • Úprava nastavení výkonu kodéru


Doporučené postupy nastavení komprese

Je k dispozici mnoho vzájemně vyvážených nastavení komprese. Kodér obsahuje mnoho předem definovaných nastavení pro cíl, video a zvuk (profilů), u kterých je již toto vyvážení použito. Pomocí předem definovaného profilu můžete jednoduše nastavit relaci kódování. Pokud však chcete provádět vlastní úpravy nastavení, následující odstavce poskytují informace o nastaveních včetně určitých otázek rozhodování, které je třeba zvážit.

  • Vyrovnávací paměť. Větší vyrovnávací paměť může zajistit lepší kvalitu obrazu, ale uživatel musí déle čekat, než se video spustí, protože přehrávač čeká, dokud není vyrovnávací paměť naplněna. Typicky prodleva vyrovnávací paměti odpovídá času v sekundách velikosti vyrovnávací paměti nastavení v kodéru. Pokud však plánujete vytvořit datový proud ze serveru Windows Media, můžete nastavit v kodéru větší vyrovnávací paměť. Funkce služby Windows Media Services nazývaná Rychlý start umožňuje, aby přehrávač naplnil svou vyrovnávací paměť rychleji než v reálném čase za předpokladu, že síť má dostatečnou šířku přenosového pásma. To znamená, že počáteční prodleva vyrovnávací paměti může být výrazně kratší. Pokud se například uživatel pokouší přehrát obsah kódovaný na kapacitu 56 kb/s na lince DSL nebo kabelovém modemu, počáteční prodleva může trvat jen jednu nebo dvě sekundy, i když velikost vyrovnávací paměti nastavená při kódování je daleko větší. Další informace o funkci Rychlý start naleznete v nápovědě služby Windows Media Services.

    Vytvoříte-li relaci, která používá pro zvuk kódování VBR podle maximální přenosové rychlosti, musí být maximální velikost vyrovnávací paměti zvuku menší, než velikost vyrovnávací paměti videa (používáte-li pro video kódování CBR) nabo maximální velikosti vyrovnávací paměti pro video (používáte-li kódování videa podle maximální přenosové rychlosti).

  • Přenosová rychlost. Vyšší přenosová rychlost znamená vyšší kvalitu obrazu. Je-li nastavena příliš nízká přenosová rychlost, bude kodek vynechávat snímky, aby zajistil lepší kvalitu obrazu, i když to pozorovatel nemusí postřehnout. (Nezapomeňte, že pokud kódujete video s pomalým pohybem, skutečná přenosová rychlost může být značně nižší, než je očekávaná přenosová rychlost.)
  • Frekvence snímků. Je potřeba se rozhodnout mezi kvalitou obrazu a frekvencí snímků, protože se vzrůstající kvalitou obrazu se frekvence snímků snižuje. Pokud je frekvence snímků důležitější, můžete nastavení kvality obrazu snížit.
  • Kvalita obrazu (plynulost). Můžete nastavit vyšší kvalitu obrazu, tzn. plynulejší obraz. Zvyšování kvality může v závislosti na konkrétním videu ovlivnit frekvenci snímků. Pokud například video obsahuje hodně pohybu, zvyšování kvality může snížit frekvenci snímků. Navíc zvýšení kvality má za následek vyšší požadavky na přenosovou rychlost a může také znamenat nutnost zvýšení velikosti vyrovnávací paměti.
  • Velikost snímku. Čím větší je velikost snímku, tím vyšší jsou požadavky na přenosovou rychlost.
  • Klíčové snímky. Pokud používáte větší vzdálenost klíčových snímků, jsou v případě potřeby vkládány další klíčové snímky; například při změně scény. Pro méně se pohybující obsah je typicky dostačující nastavení 20 sekund. Pro obsah s vyšší rychlostí je vhodné vzdálenost klíčových snímků snížit.
  • Kodeky. Pro relaci je třeba použít příslušný kodek. Pokud je například primárním zdrojem zvuk nebo převážně zvuk, použijte kodek Windows Media Audio 9 Voice. Pro relaci digitalizace obrazovky použijte kodek Windows Media Video 9 Screen.
  • Dvojfázové kódování. Typicky dosáhnete vyšší kvality dvojfázovým kódováním, protože kodér má možnost v první fázi analyzovat obsah.
  • Změna velikosti videa. Výstupní velikost snímků nastavte stejnou, jako je velikost vstupních snímků. Nepoužívejte kodér ke změně velikosti zdrojového videa.

Příbuzná témata

  • Možnosti konfigurace systému
  • Nastavení optimálního výkonu systému
  • Optimalizace zvuku pro hlas
  • Zvýšení výkonu při kódování obrazovek
  • Seznámení s kodeky
  • Jednofázové a dvojfázové kódování
  • Postup při přizpůsobování velikosti snímku zdrojovému videu


Spuštění několika kodérů v jednom počítači

Při dostatečném výkonu počítače lze v jednom počítači spustit několik instancí programu Windows Media Encoder. Spuštění několika instancí kodéru umožňuje:

  • Vysílat několik samostatných datových proudů v různých přenosových rychlostech najednou.
  • Převést několik souborů do formátu Windows Media Format najednou.
  • Používat jako zdroj víceportové zařízení a vysílat kódovaný obsah z každého portu do jiného umístění.

Rozhodnete-li se spouštět několik kodérů v jednom počítači, nezapomeňte, že vstupní zařízení mohou provádět pouze jeden proces najednou. Z tohoto důvodu bude pravděpodobně třeba nainstalovat více zvukových a grafických karet. Pro optimální výkon použijte počítač se dvěma nebo více procesory.

Příbuzná témata

  • Možnosti konfigurace systému


Dávkové kódování

Pokud chcete kódovat více souborů obsahujících zvuk a video, můžete použít program Windows Media Encoding Script, který je součástí programu Windows Media Encoder. Případně můžete spustit v kodéru dávkové kódování pomocí skriptu a programu Windows Script Host.

Bližší informace o programu Windows Script Host a dávkovém kódování naleznete v sadě Windows Media Encoder 9 Series SDK.

Příbuzná témata

  • Možnosti konfigurace systému
  • Nástroje kodéru


Časté otázky a odstraňování problémů

Nejnovější informace týkající se používání kodéru najdete na webové stránce Windows Media na webu společnosti Microsoft.


Usnadnění pro tělesně postižené uživatele

Společnost Microsoft se zavázala, že její produkty a služby budou snadno použitelné pro všechny. Následující témata poskytují informace o funkcích, produktech a službách zajišťujících snadnější použití programu Microsoft Windows Media Encoder tělesně postiženým osobám:

  • Usnadnění přístupu v programu Windows Media Encoder
  • Usnadnění přístupu v nápovědě programu Windows Media Encoder
  • Produkty a služby společnosti Microsoft pro usnadnění přístupu

Poznámka - obrázek Poznámka

  • Informace v této části se týkají pouze uživatelů, kteří zakoupili produkty společnosti Microsoft v USA. Pokud jste produkt získali jinde než v USA, balení produktu obsahuje informační leták s telefonními čísla a adresami středisek podpory společnosti Microsoft pro danou oblast. Chcete-li zjistit, zda jsou produkty a služby popsané v této části dostupné ve vaší oblasti, kontaktujte místní zastoupení společnosti Microsoft. Informace o usnadnění přístupu jsou dostupné v dalších vybraných jazycích včetně japonštiny a francouzštiny. Další informace naleznete na webu společnosti Microsoft.


Usnadnění přístupu v programu Windows Media Encoder

Vedle funkcí a podpůrných programů pro usnadnění přístupu v systému Windows jsou k dispozici následující funkce programu Windows Media Encoder, které ještě více usnadní používání programu tělesně postiženým osobám:

  • Používání klávesových zkratek

Příbuzná témata

  • Usnadnění pro tělesně postižené uživatele


Použití klávesových zkratek

Pomocí následujících klávesových zkratek můžete v programu Windows Media Encoder rychle provést řadu běžných úkolů.

Akce | Klávesová zkratka
Zobrazit místní nápovědu. | F1
Procházet možnosti v dialogovém okně nebo na stránce vlatností vpřed. | TAB
Procházet možnosti v dialogovém okně nebo na stránce vlatností zpět. | SHIFT+TAB
Přejít v číselníku nebo rozevíracím seznamu na vyšší položku. | ŠIPKA NAHORU
Přejít v číselníku nebo rozevíracím seznamu na nižší položku. | ŠIPKA DOLŮ
Procházet po kartách vpřed. | ŠIPKA VPRAVO
Procházet po kartách zpět | ŠIPKA VLEVO
Aktualizovat otevřené dialogové okno nebo ovládací prvek (aktualizovat seznam modulů plug-in, aktualizovat zobrazení stop). | F5 nebo CTRL+R
Zavřít stránku vlastností, dialogové okno nebo ukončit průvodce. | ESC
Provést příkaz aktivní možnosti nebo tlačítka | ENTER
Vyjmout vybrané položky a zkopírovat do schránky. | CTRL+X
Zkopírovat vybrané položky do schránky. | CTRL+C
Vložit obsah schránky do vybraného umístění. | CTRL+V
Zobrazit nebo skrýt panel Vlastnosti relace. | ALT+ENTER
Zavřít otevřené okno. | ALT+F4
Zobrazit místní nabídku. | SHIFT+F10
Vybrat nebo vymazat výběr položky | MEZERNÍK
Zobrazit místní nabídku | WINDOWS
Přepnout do režimu Vysoký kontrast | LEVÝ ALT+LEVÝ SHIFT+PRINT SCREEN

Příbuzná témata

  • Usnadnění pro tělesně postižené uživatele


Usnadnění přístupu v nápovědě programu Windows Media Encoder

Nápověda programu Windows Media Encoder obsahuje funkce, které zjednodušují její použití řadě uživatelů včetně osob s omezenou pohyblivostí, zhoršeným zrakem a jiným postižením.

Nápověda programu Windows Media Encoder je také k dispozici na webovém serveru společnosti Microsoft.

Příbuzná témata

  • Usnadnění pro tělesně postižené uživatele


Klávesové zkratky pro použití okna nápovědy

Následující klávesové zkratky okna nápovědy umožňují rychle provádět řadu běžných úkonů.

Akce | Klávesová zkratka
Otevřít okno nápovědy. | F1
Přepnout mezi tématem nápovědy a kartami Obsah, Hledat a Rejstřík. | F6
Vybrat další skrytý text nebo hypertextový odkaz. | TAB
Vybrat předchozí skrytý text nebo hypertextový odkaz. | SHIFT+TAB
Provést akci pro vybrané Zobrazit vše, Skrýt vše, skrytý text nebo hypertextový odkaz. | ENTER
Zobrazit nabídku Možnosti pro přístup k libovolnému příkazu panelu nástrojů nápovědy. | ALT+O
Skrýt nebo zobrazit podokno s kartami Obsah, Hledat a Rejstřík. | ALT+O, potom stiskněte klávesu T
Zobrazit naposledy zobrazené téma | ALT+O, potom stiskněte klávesu B
Zobrazit další téma v naposledy zobrazené sekvenci témat. | ALT+O, potom stiskněte klávesu F
Přejít zpět na určenou domovskou stránku. | ALT+O, potom stiskněte klávesu H
Zastavit otevírání tématu nápovědu v okně nápovědy (vhodné pro zabránění načítání webové stránky). | ALT+O, potom stiskněte klávesu S
Otevřít v prohlížeči Microsoft Internet Explorer dialogové okno Nastavení sítě Internet, ve kterém lze nastavit funkce usnadnění. | ALT+O, potom stiskněte klávesu I
Aktualizovat téma (vhodné po připojení k webové stránce). | ALT+O, potom stiskněte klávesu R
Tisknout všechna témata v knize nebo pouze vybrané téma. | ALT+O, potom stiskněte klávesu P
Zavřít okno nápovědy. | ALT+F4

Příbuzná témata

  • Funkce usnadnění nápovědy programu Windows Media Encoder


Postup při změně vzhledu tématu nápovědy

  1. Chcete-li upravit barvy, styl a velikost písma použité v nápovědě, otevřete okno nápovědy.
  2. Klepněte na položku Možnosti a potom na položku Možnosti sítě Internet.
  3. Na kartě Obecné klepněte na položku Usnadnění. Zaškrtněte možnosti Ignorovat barvy definované na webových stránkách, Ignorovat styly písem definované na webových stránkách a Ignorovat velikosti písem definované na webových stránkách. Můžete rovněž zvolit nastavení podle vlastní předlohy se styly.
  4. Postup změny barev použitých v nápovědě je uveden v části Postup při změně barvy pozadí a textu nápovědy. Postup změny písma je uveden v části Postup při změně písma nápovědy.

Příbuzná témata

  • Funkce usnadnění nápovědy programu Windows Media Encoder


Postup při změně barvy pozadí a textu nápovědy

  1. Otevřete okno nápovědy.
  2. Klepněte na položku Možnosti a potom na položku Možnosti sítě Internet.
  3. Na kartě Obecné klepněte na položku Usnadnění. Potom zaškrtněte možnost Ignorovat barvy definované na webových stránkách. Můžete rovněž zvolit nastavení podle vlastní předlohy se styly.
  4. Chcete-li změnit barvy použité v nápovědě, na kartě Obecné klepněte na položku Barvy. Zrušte zaškrtnutí políčka Používat barvy Windows a potom vyberte požadované písmo a barvu pozadí.

Poznámka - obrázek Poznámka

  • Jestliže změníte barvu pozadí témat v okně nápovědy, bude mít tato změna vliv rovněž na barvu pozadí při zobrazení webové stránky v prohlížeči Microsoft Internet Explorer.

Příbuzná témata

  • Funkce usnadnění nápovědy programu Windows Media Encoder


Postup při změně písma nápovědy

  1. Otevřete okno nápovědy.
  2. Klepněte na položku Možnosti a potom na položku Možnosti sítě Internet.
  3. Na kartě Obecné klepněte na položku Usnadnění. Chcete-li použít stejná nastavení jako v nainstalovaném prohlížeči Microsoft Internet Explorer, zaškrtněte možnosti Ignorovat styly písem definované na webových stránkách a Ignorovat velikosti písem definované na webových stránkách. Můžete rovněž zvolit nastavení podle vlastní předlohy se styly.
  4. Chcete-li změnit styl písma použitý v nápovědě, na kartě Obecné klepněte na položku Písma a potom na požadovaný styl.

Poznámka - obrázek Poznámka

  • Jestliže změníte písmo témat v okně nápovědy, bude mít tato změna vliv rovněž na písmo v zobrazení webových stránek v prohlížeči Microsoft Internet Explorer.

Příbuzná témata

  • Funkce usnadnění nápovědy programu Windows Media Encoder


Produkty a služby společnosti Microsoft pro usnadnění přístupu

Následující témata poskytují informace o funkcích, produktech a službách zajišťujících snadnější použití tohoto produktu společnosti Microsoft pro tělesně postižené osoby:

  • Usnadnění přístupu v Microsoft Windows
  • Přizpůsobení produktů společnosti Microsoft osobám s potřebou usnadnění přístupu
  • Volně dostupné výukové programy krok za krokem
  • Alternativní formáty dokumentace společnosti Microsoft
  • Asistenční technologie pro systém Windows
  • Služba pro sluchově postižené zákazníky
  • Bližší informace o usnadnění přístupu

Informace v této části se týkají pouze uživatelů, kteří zakoupili produkty společnosti Microsoft v USA. Pokud jste produkt získali jinde než v USA, balení produktu obsahuje informační leták s telefonními čísly a adresami středisek podpory společnosti Microsoft pro danou oblast. Chcete-li zjistit, zda jsou typy produktů a služeb popsané v této části dostupné ve vaší oblasti, kontaktujte místní zastoupení společnosti Microsoft. Usnadnění přístupu je dostupné v dalších vybraných jazycích včetně japonštiny a francouzštiny. Další informace naleznete na webu společnosti Microsoft.

Příbuzná témata

  • Usnadnění pro tělesně postižené uživatele


Usnadnění přístupu v Microsoft Windows

Do systému Microsoft Windows bylo zabudováno mnoho funkcí pro usnadnění přístupu, a to již od představení systému Windows 95. Tyto funkce jsou užitečné pro osoby, které mají potíže s psaním na klávesnici nebo používáním myši, pro osoby slepé nebo se zhoršeným zrakem nebo pro osoby sluchově postižené. Zmíněné funkce lze nainstalovat při instalaci systému. Bližší informace o různých možnostech usnadnění přístupu v produktech společnosti Microsoft, jako je například Microsoft Windows XP Professional, Windows XP Home Edition, Windows Millennium Edition, Windows 2000, Windows 98 a Windows 95, naleznete na webu společnosti Microsoft.

Příbuzná témata

  • Produkty a služby společnosti Microsoft pro usnadnění přístupu


Přizpůsobení produktů společnosti Microsoft osobám s potřebou usnadnění přístupu

Funkce a možnosti pro usnadnění přístupu jsou vestavěny do mnoha produktů společnosti Microsoft včetně operačního systému Windows. Tyto funkce a možnosti jsou užitečné pro osoby, které mají potíže s psaním na klávesnici nebo používáním myši, pro osoby slepé nebo se zhoršeným zrakem nebo pro osoby sluchově postižené.

Příbuzná témata

  • Produkty a služby společnosti Microsoft pro usnadnění přístupu


Volně dostupné výukové programy krok za krokem

Společnost Microsoft nabízí řadu výukových programů krok za krokem, které obsahují informace pro uživatele o tom, jak upravit možnosti usnadnění a nastavení v počítači. Výukové programy obsahují podrobné postupy, jak upravit parametry a nastavení pro tělesně postižené uživatele. Informace jsou seřazeny vedle sebe, aby se uživatel snadno orientovat jak používat myš, klávesnici nebo obojí.

Výukové programy krok za krokem pro produkty Microsoft najdete v části Accessibility (Usnadnění) na webu společnosti Microsoft.

Příbuzná témata

  • Produkty a služby společnosti Microsoft pro usnadnění přístupu


Alternativní formáty dokumentace společnosti Microsoft

Pro větší usnadnění přístupu je dokumentace řady produktů společnosti Microsoft k dispozici kromě standardních formátů také v dalších formátech. Máte-li potíže se čtením nebo používáním tištěných materiálů, můžete získat dokumentaci řady produktů Microsoft v jiných, přístupnějších formátech. Mnohé z těchto knih lze stáhnout z webového serveru společnosti Microsoft.

Rejstřík dokumentace společnosti Microsoft s usnadněným přístupem je k dispozici v části Usnadnění (Accessibility) webového serveru společnosti Microsoft.

Dále jsou k dispozici doplňkové publikace společnosti Microsoft z vydavatelství Recording for the Blind & Dyslexic, Inc. Tato dokumentace je distribuovaná oprávněným registrovaným členům distribuční sítě vydavatele na audiokazetách nebo disketách. Sbírka obsahuje více než 80 000 titulů, včetně dokumentace produktů společnosti Microsoft a knih z nakladatelství Microsoft Press. Informace o oprávnění a dostupnosti dokumentace produktů společnosti Microsoft a knih z nakladatelství Microsoft Press získáte na adrese:

Recording for the Blind & Dyslexic, Inc.
20 Roszel Road
Princeton, NJ 08540

Telefonní číslo v rámci USA: (800) 221-4792
Telefonní číslo mimo USA a Kanadu: (609) 452-0606
Fax: (609) 987-8116

Webový server vydavatelství Recording for the Blind & Dyslexic

Webové adresy se mohou změnit. V takovém případě pravděpodobně nebude možné se k uvedené adrese nebo adresám připojit.

Příbuzná témata

  • Produkty a služby společnosti Microsoft pro usnadnění přístupu


Asistenční technologie pro systém Windows

Je k dispozici široké spektrum produktů pro usnadnění přístupu nebo asistenčních technologií, aby počítače mohli jednoduše používat i handicapované osoby.

Společnost Microsoft poskytuje prohledávatelný katalog funkcí pro usnadnění přístupu používaných v operačním systému Microsoft Windows v sekci Usnadnění přístupu na webu společnosti Microsoft.

K různým typům produktů dostupných pro operační systémy MS-DOS, Windows a Windows NT patří:

  • Programy, které zvětšují zobrazené informace nebo upravují barvu informací na obrazovce pro osoby se zhoršeným zrakem.
  • Programy, které popisují informace na obrazovce Braillovým písmem nebo syntetickým hlasem pro osoby slepé nebo s obtížemi ve čtení.
  • Hardwarové a softwarové prostředky upravující chování myši a klávesnice.
  • Programy, které umožňují osobám psát nebo používat myš pomocí svého hlasu.
  • Software předpovídající slova nebo fráze a umožňující tak uživatelům psát rychleji a s menším počtem stisků kláves.
  • Alternativní vstupní zařízení, například jednoduchý přepínač nebo zařízení pro ovládání ústy, pro osoby, které nemohou používat myš nebo klávesnici.

Aktualizace

Pokud před aktualizací softwaru nebo hardwaru použijete asistenční technologii, nezapomeňte kontaktovat dodavatele asistenční technologie a ověřit kompatibilitu s produkty instalovanými v počítači. Dodavatel asistenční technologie vám může pomoci zjistit, jak upravit nastavení pro optimalizaci kompatibility s verzí Windows nebo dalších produktů společnosti Microsoft.


Služba podpory zákazníků pro neslyšící nebo pro osoby se sluchovými potížemi

Jste-li neslyšící nebo máte-li sluchové potíže, využijte kompletního přístupu k produktům Microsoft a ke službám podpory zákazníků prostřednictvím textové telefonní služby (TTY/TDD).

Služba podpory zákazníků

Prodejní informační středisko společnosti Microsoft (Microsoft Sales Information Center) můžete kontaktovat na čísle textového telefonu (800) 892-5234 od 6:30 do 17:30 tichomořského času, od pondělí do pátku (vyjma svátků).

Technická pomoc

Pro technickou pomoc v USA se můžete obrátit na službu odborné pomoci pro produkty společnosti Microsoft (Microsoft Product Support Services) na čísle textového telefonu (800) 892-5234 od 6:00 do 18:00 tichomořského času, od pondělí do pátku (vyjma svátků). V Kanadě na čísle (905) 568-9641 od 8:00 do 20:00 východního času, od pondělí do pátku (vyjma svátků). Na služby podpory zákazníků společnosti Microsoft se vztahují ceny a podmínky platné v době poskytnutí.

Příbuzná témata

  • Produkty a služby společnosti Microsoft pro usnadnění přístupu


Získávání dalších informací o usnadnění přístupu

V části Usnadnění na webu společnosti Microsoft se nacházejí informace o technologii, která pomáhá usnadnit život tělesně postiženým osobám tím, že vytváří z počítačů přístupný nástroj v zaměstnání, vzdělávání a oddechu. Informace na této stránce jsou určeny pro pomoc tělesně postiženým osobám a jejich přátelům a rodinným příslušníkům, zaměstnancům chráněných pracovišť, pedagogům a právníkům.

V části Usnadnění na webu společnosti Microsoft je k dispozici zdarma měsíčník rozesílaný elektronickou poštou obsahující nejnovější informace o funkcích usnadnění produktů Microsoft.

Příbuzná témata

  • Produkty a služby společnosti Microsoft pro usnadnění přístupu


Glosář

Chcete-li vyhledat termín v glosáři, klepněte na písmeno v abecedě, kterým hledaný termín začíná.

Termíny v glosáři lze rovněž zobrazit v rámci textu nápovědy klepnutím na podtržené odkazy glosáře. Po klepnutí na odkaz glosáře se termín a jeho definice zobrazí v místním okně. Chcete-li okno zavřít, klepněte na libovolné místo na ploše.

A | B | C | Č | D | E | F | G | H | CH | I | J
K | L | M | N | O | P | Q | R | Ř | S | Š | T
U | V | W | X | Y | Z | Ž |

A

adresář pro publikování

Uspořádané paměťové umístění, které přeloží požadavek klienta na obsah na fyzickou cestu k obsahu na hostitelském serveru. Základní funkce adresáře pro publikování je přesměrování.

AVI (Audio Video Interleaved)

Formát multimediálního souboru pro ukládání zvuku a pohyblivého obrazu ve formátu RIFF.

AVI

Viz definice : AVI (Audio Video Interleaved)

Na začátek

B

bezeztrátová komprese

Proces komprese dat, při kterém jsou informace uspořádány ve zkrácené podobě. Při dekompresi jsou informace obnoveny do původního tvaru.

Na začátek

C

CBR

Viz definice : konstantní přenosová rychlost (CBR)

Na začátek

Č

časový kód

Digitální signál vložený do datového proudu. Signál přiděluje každému snímku videa číslo, které obsahuje hodiny, minuty, sekundy a snímky.

čekací doba

Zpoždění, ke kterému dochází při zpracovávání nebo předávání dat.

Na začátek

D

datový proud

Spojitý tok digitálního média, který se přenáší v síti.

dvojfázové kódování

Způsob kódování, kdy v jedné fázi provádí kodér analýzu a ve druhé fázi provádí kompresi. Viz též jednofázové kódování.

dynamický rozsah

Rozdíl (v decibelech) mezi nejslabšími a nejsilnějšími zvuku v jednotlivé části zvukového obsahu.

Na začátek

F

formát běžného zobrazení

Formát zobrazení videa, při kterém během přehrávání zobrazují nad a pod obrazem černé pruhy. Formát běžného zobrazení zachovává původní poměr stran obrazu při přehrávání na obrazovce, která má odlišný poměr stran.

formát datového proudu

Informace o vlastnostech datového proudu, např. použité kodeky, frekvence a velikost snímků. Pomocí tohoto formátu přehrávač dekóduje datový proud.

formát pixelů

Velikost a uspořádání barevných složek pixelu. Tento formát je určen celkovým počtem bitů použitých na pixel a počtem bitů použitých pro uložení barevných složek pixelu červené, zelené, modré a alfa.

formát Windows Media

Formát produktů Microsoft Windows Media Technologies (nebo jiných produktů na základě licence technologie Windows Media), který slouží k vytváření, ukládání, úpravám, distribuci, vysílání nebo přehrávání obsahu, který obsahuje data uspořádaná na časové ose.

frekvence snímků

Počet snímků videa zobrazených za sekundu. Při vyšších frekvencích je pohyb na videu obvykle vykreslován plynuleji.

Na začátek

H

hlavička

Část struktury souboru s informací, podle kterých program dekomprimuje a vykresluje obsah. Hlavička v chráněném souboru obsahuje také informace nezbytné pro získání licence.

Na začátek

I

IEEE (Institute of Electrical and Electronics Engineers) 1394

Standard řadiče vysokorychlostní sériové sběrnice, který umožňuje připojit k počítači širokou škálu zařízení, včetně spotřební audiovizuální elektroniky, úložných periferních zařízení, dalších počítačů a přenosných zařízení.

IEEE 1394

Viz definice : IEEE (Institute of Electrical and Electronics Engineers) 1394

inteligentní datový proud

Typ proudu, který rozpozná stav sítě a upraví vlastnosti obrazového a zvukového datového proudu tak, aby bylo dosaženo maximální kvality.

Internet Protocol verze 6 (IPv6)

Aktualizovaná verze protokolu IP (Internet Protocol) umožňující další růst sítě Internet. Mezi zlepšení patří 128bitová velikost adresy IP, rozšířené možnosti směrování a podpora ověřování a ochrany osobních dat.

inverzní přepis Telecine

Proces odstranění snímků, které byly přidány během převodu filmu s frekvencí 24 snímků/s na video s frekvencí 30 snímků/s.

IPv6

Viz definice: Internet Protocol verze 6 (IPv6)

Na začátek

J

jednofázové kódování

Způsob kódování, při kterém se analýza a komprese obsahu provádí kodérem najednou v rámci jedné fáze.

Viz též: dvojfázové kódování

jednosměrový přenos

Způsob, kterým servery s médii předávají obsah připojeným klientům. Každý klient obdrží diskrétní datový proud. K tomuto proudu nemá žádný jiný klient přístup.

Na začátek

K

klíčový snímek

Snímek videa, který obsahuje všechna data potřebná k vytvoření obrazu bez nutnosti předchozích snímků.

Viz též: rozdílový snímek

kodek Windows Media Screen

Kodek používaný pro kompresi a dekompresi sekvencí zobrazení obrazovky.

kodek Windows Media Video

Kodek používaný pro kompresi a dekompresi datových proudů videa.

kodek

Zkratka slov komprimátor/dekomprimátor. Jedná se o software nebo hardware, který se používá ke kompresi a dekompresi digitálních médií.

kódování

Převod zvukového a obrazového obsahu do určeného digitálního formátu.

komprese

Proces, při kterém se ze souboru digitálních médií nebo z datového proudu odstraňují nadbytečná data, aby se zmenšila jeho velikost nebo použitá šířka pásma.

koncová sekvence

Prodloužení kódovaného videa o určený počet snímků.

konfigurační soubor

Textový soubor používaný programem Windows Media Encoding Script. Soubor definuje kódovaný obsah a parametry příkazového řádku, které se mají při kódování použít.

konstantní přenosová rychlost (CBR)

Charakteristika datového proudu, v jehož průběhu zůstává přenosová rychlost takřka neměnná.

Viz též: variabilní přenosová rychlost (VBR)

Na začátek

L

licence

Data připojená ke chráněnému obsahu, která popisují, jak lze obsah používat.

Na začátek

M

MBR

Viz definice: více přenosových rychlostí (MBR)

metadata

Údaje o datech. Příkladem metadat souboru mohou být název, předmět, autor a velikost.

metasoubor Windows Media

Soubor produktů Windows Media Technologies, který obsahuje informace o souborech ve formátu Windows Media a jejich prezentaci. Mezi přípony názvů metasouborů Windows Media patří ASX, WAX, WVX, WMX a NSC.

Na začátek

N

načítání

Předávání dat klientovi pouze na základě jeho požadavku.

NTSC (National Television Standards Committee)

Norma televizního vysílání, která se převážně používá v USA a Japonsku. Při vysílání v normě NTSC se přenáší 30 prokládaných snímků za sekundu s rozlišením 525 řádků.

NTSC

Viz definice: NTSC (National Television Standards Committee)

Na začátek

O

obsah

Zvuk, video, obrázky, text, nebo další informace v souboru digitálních médií nebo v datovém proudu.

opakovat

Opakovaně spouštět datový proud.

oznámení

Metasoubor ve formátu Windows Media, který předává přehrávači informace potřebné pro příjem obsahu. Soubory s oznámením obsahují skripty XML (Extensible Markup Language).

Na začátek

P

PAL (Phase Alternating Line)

Norma televizního vysílání, která se převážně používá v Evropě. Při vysílání v normě PAL se přenáší 25 prokládaných snímků za sekundu při rozlišení 625 řádků.

PAL

Viz definice: PAL (Phase Alternating Line)

PCM

Viz definice: pulsně kódovaná modulace (PCM)

počáteční sekvence

Digitalizace nebo přehrání určitého počtu snímků videa nebo určité části zvukových dat před začátkem kódování nebo zobrazením, aby se mohl stabilizovat stav zdrojového zařízení. Také se používá k označení dat počáteční sekvence.

poměr stran

Poměr šířky a výšky obrazu.

profil

Skupina nastavení, na základě kterých se podle typu obsahu a přenosové rychlosti volí vhodné zvukové kodeky a videokodeky.

Profile Editor (editor profilů)

Nástroj poskytnutý společně s programem Windows Media Encoder, který slouží k vytváření a úpravám profilů kódování.

Viz též: profil

prokládání

Zobrazení videosnímku ve dvou políčcích. Jedno políčko obsahuje sudé řádky, druhé políčko obsahuje liché řádky videa. Během přehrávání se nejprve zobrazí řádky v jednom políčku a potom se zobrazí řádky ve druhém políčku.

PRX

Přípona souboru s profilem.

přenosová rychlost

Počet přenesených bitů za sekundu.

přepis Telecine

Systém převodu filmu na video, při kterém se rozdíly mezi frekvencemi snímků filmu a videa kompenzují přidáním snímků do videa.

příkazy skriptu

Pojmenovaná data, která souvisejí s časovým určením v obsahu formátu Windows Media. Data mohou sloužit přehrávačům k provedení specifické operace, jako např. zobrazení webové stránky.

pulsně kódovaná modulace (PCM)

Postup digitalizace zvuku do nekomprimovaného formátu, při kterém se amplitudě signálu přiřazují hodnoty v určených intervalech.

Na začátek

R

RGB

Barevný model, který charakterizuje barevnou informaci jako podíl intenzity červené (R), zelené (G) a modré (B) složky v barvě.

rozdílový snímek

Snímek videa, který obsahuje pouze změny od minulého snímku. Naproti tomu klíčový snímek obsahuje všechna data nezbytná pro vytvoření snímku.

Na začátek

S

soubor ve formátu datového proudu

Soubor, podle kterého přehrávač dekóduje vícesměrový datový proud.

Viz též: formát datového proudu

soubor ve formátu Windows Media

Soubor ve formátu Windows Media, ve kterém je uložen zvuk, obraz nebo data skriptu. Podle obsahu a účelu se pro soubory ve formátu Windows Media používá řada přípon, např. WMA, WME, WMS, WMV, WMX, WMZ nebo WVX.

Na začátek

Š

šířka pásma

Kapacita sítě pro přenos množství dat v daném čase.

Na začátek

T

titulek

Text, který doplňuje obraz nebo video a obsahuje další informace nebo přepis mluveného slova.

Na začátek

U

UDP (User Datagram Protocol)

Protokol pro bezdrátový přenos v zásobníku protokolu TCP/IP, který se používá v případech, kdy jsou přijatelné ztráty některých paketů, například u datových proudů digitálních médií.

UDP

Viz definice: UDP (User Datagram Protocol)

UNC (Universal Naming Convention)

Celý název síťového prostředku. Odpovídá syntaxi \\název_serveru\sdílená_položka, kde název_serveru je název serveru a sdílená_položka je název sdíleného prostředku. Syntaxe názvů UNC pro adresáře nebo soubory může také obsahovat cestu adresáře pod názvem sdílené položky v následující podobě: \\název_serveru\sdílená_položka\adresář\název_souboru.

UNC

Viz definice: UNC (Universal Naming Convention)

Na začátek

V

variabilní přenosová rychlost (VBR)

Charakteristika datového proudu, při kterém přenosová rychlost kolísá podle složitosti dat.

VBR

Viz též: variabilní přenosová rychlost (VBR)

více přenosových rychlostí (MBR)

Charakteristika datového proudu, ve kterém je stejný obsah kódován v několika odlišných přenosových rychlostech pro optimalizaci předávání.

vícekanálový zvuk

Systém reprodukce zvuku pro zpracování několika, obvykle více než dvou, zvukových kanálů. Například vícekanálový formát zvuku 5.1 představuje systém prostorového zvuku, který obsahuje pět primárních kanálů a kanál basového reproduktoru.

vícesměrový přenos

Způsob předávání obsahu, při kterém je jeden datový proud vysílán ze serveru s médii pro více klientů. Klienti se nepřipojují k serveru. Místo toho server odesílá do sítě jednu kopii datového proudu na směrovače pro vícesměrové vysílání, které vytvářejí kopie dat. Klienti mohou načítat datový proud sledováním určené adresy IP a portu vícesměrového vysílání.

vysílání

Předávání dat klientovi bez jeho požadavku.

vzorkovací frekvence

Frekvence, při které se provádí vzorkování. Čím vyšší je vzorkovací frekvence (tzn. čím se provede více vzorků za jednotku času), tím přesněji se bude digitalizovaný výsledek podobat původní předloze.

vzorkování

Součást převodu analogového signálu do digitálního formátu, při kterém se v pravidelných intervalech měří amplituda analogového signálu.

Na začátek

W

WEU

Přípona konfiguračních souborů, které používá program Windows Media Encoding Script.

WMA

Přípona zvukového souboru ve formátu Windows Media. Zvukový obsah souboru je kódován pomocí kodeku Windows Media Audio.

WME

Přípona souboru relace programu Windows Media Encoder.

WMV

Přípona videosouboru ve formátu Windows Media.

Na začátek

Y

YUV

Barevný model, který charakterizuje barevnou informaci podle jasu (luminance nebo Y) a barevnosti (chrominance nebo U a V).

Na začátek

Z

zdroj

Zvukový a obrazový obsah, který lze digitalizovat a kódovat ze zařízení instalovaných v počítači nebo ze souboru.

značka

Textový řetězec, který souvisí s přiřazeným časem v obsahu ve formátu Windows Media. Značky často označují vhodná místa pro začátek přehrávání, jako např. začátek nové scény.

zrušení prokládání

Kombinace prokládaných políček videosnímku tak, aby se řádky videosnímku během přehrávání vykreslovaly sekvenčně.

Viz též: prokládání

ztrátová komprese

Proces komprese dat, při kterém jsou informace považované za zbytečné odstraněny a nelze je při dekompresi obnovit. Obvykle se používá pro zvuková nebo obrazová data, u kterých je přípustné mírné snížení kvality.

zvukový kodek Windows Media Audio

Kodek používaný pro kompresi a dekompresi zvukových datových proudů.

Na začátek


Přidání poskytovatele

Uveďte nového poskytovatele licenčních služeb, kterého chcete přidat.

  • Název. Zadejte vlastní název pro poskytovatele.
  • URL. Zadejte adresu URL webu poskytovatele.
  • Najít poskytovatele. Klepnutím přejděte na web se seznamem poskytovatelů, ze kterých si můžete vybrat.

Příbuzná témata

  • Použití technologie DRM (Digital Rights Management) k ochraně obsahu


Velikost videa

Zdrojové video lze oříznout, změnit jeho velikost a zachovávat poměr stran.

  • Oříznutí. Klepněte na výchozí metodu, podle které má být video oříznuto, nebo klepněte na volbu Vlastní a ořízněte video ručně. Výška a šířka oříznutí musí mít sudý počet pixelů (například je podporováno 300 x 320 pixelů, nikoli 300 x 321 pixelů.

    Používáte-li jako zdroj soubor, dokáže kodér před spuštěním kódování rozlišit velikost zdrojového videa; používáte-li jako zdroj zařízení nebo digitalizované obrazovky, nelze před kódováním vstupní velikost zdroje rozlišit. Jestliže ořezáváte a měníte velikost videa ze zařízení nebo digitalizovaných obrazovek, je třeba určit vstupní velikost zdroje. V takovém případě kodér při spuštění kódování rozliší skutečnou velikost vstupního zdroje. Bude-li se velikost zadaná uživatelem lišit od skutečné vstupní velikosti, použije se zadaný poměr oříznutí (nikoli skutečné hodnoty pixelu) na skutečnou vstupní velikost zdroje.

    Pokud chcete použít změny v relaci a nespustili jste ještě kódování, je v oblasti Vstup na panelu Video hlavního okna kodéru zobrazen obraz ještě před oříznutím. (Pokud je však zdrojem digitalizační zařízení, které podporuje hardwarové ořezávání, je zobrazen oříznutý obraz.) V průběhu kódování je oříznutý obraz zobrazen v oblastech Vstup i Výstup.

  • Poměr stran pixelu. Vyberte hodnotu, která odpovídá poměru stran zdroje, nebo vyberte volbu Vlastní. Kódovaný výstup bude odpovídat zde zadanému poměru stran. (Hodnoty v závorkách představují poměr stran snímku a poměr stran pixelu pro nastavení digitální videokamery a anamorfní nastavení.) Toto pole je dostupné po zaškrtnutí políčka Povolit výstup obdélníkových pixelů v dialogovém okně Vlastní nastavení kódování přístupném z karty Komprese.
  • Změna velikosti. Pokud je zdrojem video, pro které může být zjištěna velikost vstupu (soubor), klepnutím na Automaticky se automaticky provede změna velikosti videa podle nastaveného oříznutí a dostupné šířky pásma určené v profilu. (Pokud je zdrojem zařízení, volba Automaticky má stejný účinek jako volba Beze změny velikosti.) Klepnutím na volbu Beze změny velikosti zajistíte, aby výstupní obraz odpovídal rozměrově oříznutému vstupnímu obrazu. Klepnutím na volbu Shodně s profilem nastavíte, aby velikost výstupního obrazu byla upravena podle rozměrů uvedených na kartě přenosové rychlosti. (Kartu přenosové rychlosti zobrazíte klepnutím na kartu Komprese, klepnutím na tlačítko Upravit a poté klepnutím na kartu pro přenosovou rychlost, pro kterou měníte velikost.) Pokud kódujete obsah typu MBR, můžete zvolit přenosovou rychlost, pro kterou chcete změnit velikost, vybrat ze seznamu Přenosová rychlost a poté změnit velikost pro každou přenosovou rychlost zvlášť. (Přenosovou rychlost můžete změnit pouze pokud je pro změnu velikosti vybrána volba Vlastní nebo Shodně s profilem.)

Příbuzná témata

  • Oříznutí a změna velikosti videa před kódováním


Stornované oznámení

Pokud plánujete distribuovat obsah jako datový proud typu Multicast ze serveru používajícího systém Windows Media Services, musíte nejprve pro tento datový proud vytvořit oznámení. Pokud máte práva přístupu ke službě Windows Media Services prostřednictvím protokolu DCOM, můžete k vytvoření oznámení použít Průvodce oznámením vysílání Multicast v kodéru. V opačném případě musíte vytvořit oznámení na serveru Windows Media. Informace o vytváření oznámení pomocí kodéru naleznete v části Vytvoření oznámení vysílání Multicast. Informace o vytváření oznámení na serveru naleznete v nápovědě služby Windows Media Services.

Pokud plánujete distribuovat obsah jakou datový proud typu unicast ze serveru Windows Media, nepotřebujete vytvářet oznámení.


Požadován formát HTTP

Adresa URL v protokolu HTTP má formát http://Název_webu.


Požadován formát UNC

Cesta UNC má formát \\název_počítače\název_složky.


Publikování souborů

Určete dočasné umístění pro soubory. Po dokončení Průvodce oznámením vysílání Multicast můžete uložit soubory na svůj web a zahájit tvorbu datového proudu pro vysílání.


Vytvoření oznámení

Vytvořili jste adresář pro publikování, odkud budete distribuovat obsah jako datový proud typu multicast ze serveru používajícího systém Windows Media Services. Než budete moci zahájit vytváření datového proudu ze serveru, musíte vytvořit oznámení pro tento datový proud. Pro vytvoření oznámení můžete použít Průvodce oznámením vysílání Multicast v kodéru. V ostatních případech musíte vytvořit oznámení na serveru Windows Media. Informace o vytváření oznámení pomocí kodéru naleznete v části Vytvoření oznámení vysílání Multicast. Informace o vytváření oznámení na serveru naleznete v nápovědě služby Windows Media Services.


Spuštění archivace v průběhu vysílání

Pokud nastavíte archivaci před zahájením kódování relace vysílání, archivace se spustí automaticky při spuštění kódování. Pokud se však rozhodnete spustit archivaci až po zahájení kódování relace vysílání, musíte archivaci spustit ručně klepnutím na volbu Spustit archivaci v nabídce Ovládání.


Panel Zvuk

Panel Zvuk obsahuje ovládací prvky pro sledování a úpravy hlasitosti zvukového datového proudu, který kódujete. Mezi tyto ovládací prvky patří:

  • Ukazatel hlasitosti nahrávání. Zobrazuje vizuální reprezentaci úrovně hlasitosti kódovaného obsahu. Při vzrůstající hlasitosti zvuku se barva ukazatele změní ze zelené na žlutou a poté na červenou. Nahrávání při příliš vysoké (převážně v červené barvě) nebo při příliš nízké (převážně v zelené barvě) úrovni hlasitosti bude poskytovat neuspokojivé výsledky. Nejlepších výsledků dosáhnete, pokud udržíte úroveň hlasitosti nahrávání konstantní.
  • Ovládání hlasitosti nahrávání. Tento ovládací prvek se podobá hlavnímu ovladači hlasitosti nahrávání dostupnému v programu směšovače, která je dodávána se zvukovou kartou. Posunutím jezdce upravíte hlasitost zvuku kódovaného obsahu. Pokud používáte tento ovladač v kodéru, je ovladač ve směšovači nastavován souběžně. Pokud ovladače zvukové karty nepodporují hlavní ovladač pro nastavení hlasitosti nahrávání, není tento ovládací prvek dostupný.
  • Tlačítko Ztlumit. Klepnutím ztlumíte při kódování zvukovou stopu. Karta pro digitalizaci určuje dostupnost tohoto tlačítka. Pokud karta nemá ovládání ztlumení, není tlačítko Ztlumit v kodéru dostupné.
  • Tlačítko Směšovač. Po klepnutí můžete nastavit hlasitost pro různé vstupy včetně kamery, mikrofonu a CD. Pro nastavení hlasitosti všech vstupů můžete také použít hlavní ovladač. Klepnutím na tlačítko Směšovač spustíte program směšovače nahrávání, která je dodávána s digitalizační kartou. Tlačítko Směšovač je dostupné, pouze pokud je vybráno zvukové zařízení.


Formát není platný

Některé nastavení v této relaci není kompatibilní s používaným kodekem. Kodek může například vyžadovat, aby šířka a výška zdrojového videa (nebo výstupního videa v případě oříznutí) měla sudý počet pixelů. Je také možné, že s kodekem není kompatibilní vybraný zvukový formát. Pokud například používáte kodek Windows Media Audio 9 Professional s režimem kódování VBR zaměřeným na kvalitu, nejvyšší možná kvalita je 98. Případně zvukový formát používá 5.1 kanálů, ale zdrojový zvuk je dvoukanálový. Chcete-li změnit formát zvuku, klepněte na kartě Komprese panelu Vlastnosti na tlačítko Upravit. Poté klepněte na kartu pro přenosovou rychlost a v poli Formát zvuku vyberte ze seznamu požadovaný formát zvuku.


Změna okrajů pro oříznutí

Výška i šířka oříznutého videa musí být větší než 16 pixelů.


Zadejte název adresáře pro publikování

Zadejte název existujícího nebo nového adresáře pro publikování, ze kterého chcete datový proud odesílat.

Příbuzná témata

  • Odeslání datového proudu z kodéru


Může být požadováno oznámení vysílání Multicast

Pokud plánujete distribuovat obsah jako datový proud typu multicast ze serveru používajícího službu Windows Media Services, musíte nejprve vytvořit pro tento datový proud oznámení. Pokud máte oprávnění přístupu ke službě Windows Media Services prostřednictvím protokolu DCOM, můžete k vytvoření oznámení použít Průvodce oznámením vysílání Multicast v kodéru. V opačném případě musíte vytvořit oznámení na serveru Windows Media. Informace o vytváření oznámení pomocí kodéru naleznete v části Vytvoření oznámení vysílání Multicast. Informace o vytváření oznámení na serveru naleznete v nápovědě služby Windows Media Services.

Pokud plánujete distribuovat obsah jako datový proud typu unicast ze serveru Windows Media, nepotřebujete vytvářet oznámení.


Konfigurace zařízení

Zde jsou uvedena veškerá zařízení, která používáte v aktuální relaci. Zařízení, která jsou nainstalována do počítače, ale nejsou právě používána, zobrazena nejsou. Zařízení mohou být v jedné relaci používána pouze jedním zdrojem.

Chcete-li upravovat vlastnosti zařízení, vyberte zařízení, klepněte na položku Konfigurovat a poté podle potřeby upravte vlastnosti. Vlastnosti, které můžete upravovat, závisejí na typu použitého zařízení.

Poznámka - obrázek Poznámka

  • Zařízení pro digitalizaci obrazovky nejsou uvedena. Tato zařízení lze konfigurovat na panelu Vlastnosti.


Dokončení Průvodce oznámením

Klepnutím na tlačítko Dokončit dokončete průvodce. Průvodce pravděpodobně vytvoří následující typy souborů:

  • Informační soubor Multicast (NSC). Tento soubor obsahuje informace o formátu datového proudu a adresu vícesměrového vysílání.
  • Soubor s oznámením (ASX). Soubor přesměrování, který odkazuje přehrávač na informační soubor vícesměrového vysílání.
  • (Volitelné) Webová stránka (HTM). Webová stránka s vloženým přehrávačem a odkazem na soubor s oznámením.


Nastavení komprese vícekanálového videa

Při kódování vícekanálového videa je třeba použít kodek Windows Media Audio 9 Professional nebo Windows Media Audio 9 Lossless a zvukový formát , který podporuje více kanálů.

Příbuzná témata

  • Použití vícekanálových zvukových souborů jako zdroje


Nastavení komprese digitalizovaného obsahu obrazovky

Při digitalizaci obrazovky je třeba použít profil pro digitalizaci obrazovky. Profil používá optimalizovaná nastavení digitalizace obrazovky, např. kodek Windows Media Video Screen. Chcete-li použít profil pro digitalizaci obrazovky, klepněte na kartu Komprese. V části Cíl klepněte na položku Server Windows Media nebo Webový server a potom na položku Digitalizace obrazovky.

Pro zvýšení výkonu při digitalizaci obrazovky je k dispozici řada možností konfigurace relace kódování a počítače. Další informace najdete v části Zvýšení výkonu při kódování obrazovek.


Karta Připojení

Karta Připojení obsahuje seznam adres IP všech klientů, kteří jsou aktuálně připojeni ke kodéru, ze kterého probíhá přímé vysílání. Klienty mohou být servery Windows Media, webové servery nebo přehrávače.

Klepnutím na příkaz Kopírovat internetovou adresu URL nebo Kopírovat místní adresu URL zkopírujete adresu IP nebo síťovou adresu kódovacího počítače do přehrávače. Přehrávač použije adresu URL k připojení ke kodéru, aby bylo možné otestovat datový proud.


Vytvoření souboru

Zadejte název souborů, které Průvodce vytvoří. Všechny soubory budou mít stejný název, ke kterému bude připojena příslušná přípona. Průvodce vytvoří minimálně soubor s oznámením (ASX) a informační soubor Multicast (NSC). Soubor s oznámením je metasoubor Windows Media, který odkazuje přehrávače na informační soubor Multicast. Informační soubor Multicast obsahuje informace, které umožňují přehrávačům otevřít a dekódovat vícesměrový datový proud, mimo jiné adresu IP, port a informace o formátu datového proudu.

Vyberte, zda chcete vytvořit webovou stránku (HTM) s odkazem na oznámení a s vloženým přehrávačem.


Nastavení

V tomto dialogovém okně vyberte zařízení, které chcete použít v této relaci ovládání zařízení.


Panel Zařízení

Na panelu Zařízení se nacházejí tlačítka, která slouží k ovládání zařízení, jehož ovládání jste povolili.

Příbuzná témata

  • Povolení ovládání zařízení
  • Vytvoření seznamu EDL


Nastavení zařízení

Toto dialogové okno nabízí pokročilé možnosti při vytváření seznamu EDL.

  • Počáteční sekvence. Určuje počet snímků ve vztahu k počátečnímu času, které má zařízení přehrát před spuštěním kódování. Nastavení počáteční sekvence stabilizuje videokazetu tak, aby nebyly kódovány pruhy, chvění nebo jiné artefakty vzniklé při spuštění zařízení. K počáteční sekvenci nesmí dojít před čekací dobou spuštění. Při výpočtu počtu snímků pro počáteční sekvenci proto zvažte čekací dobu systému.
  • Čekací doba ukončení. Určuje počet snímků ve vztahu ke koncovému času, kterými má kódování pokračovat. To zaručuje, že kodér digitalizuje poslední snímek klipu dříve, než se ukončí.
  • Čekací doba spuštění. Určuje počet snímků ve vztahu k počátečnímu času, kterými má kodér spustit kódování. Toto nastavení vyrovnává čekací dobu mezi vydáním příkazu pro spuštění a skutečným spuštěním kódování. Pro určení čekací doby systému bude třeba vyzkoušet více možností. Po určení délky čekací doby ve snímcích můžete spustit kodér brzy (ve vztahu k počátečnímu času) podle tohoto počtu snímků. Jestliže například počítač spustí kódování po 10 snímcích a vy chcete spustit kódování na prvním snímku, nastavíte čekací dobu spuštění -9 (9 snímků předtím, než skutečně chcete spustit kódování).
  • Formát videa. Slouží k určení formátu zdrojového videa.


Ochrana osobních údajů při vytváření profilu DRM

Při vytváření nebo upravování profilu pro správu práv k digitálním médiím (DRM) se uživatel připojuje prostřednictvím sítě Internet k cizímu poskytovateli. Při vytváření profilu může cizí poskytovatel po uživateli požadovat osobní údaje, např. informace pro fakturaci. Doporučujeme, abyste si před poskytnutím jakékoliv informace ověřili, zda poskytovatel webu využívá zabezpečené připojení.

Po vytvoření nebo po dokončení úprav můžete profil používat k ochraně obsahu během kódování.

Příbuzná témata

  • Použití technologie DRM (Digital Rights Management) k ochraně obsahu


Seznam pravidel střihu (EDL)

V tomto dialogovém okně může uživatel pomocí časového razítka přesně určit požadovaný začátek a konec kódování obrazového a zvukového obsahu.

Klepnutím na tlačítko přehrát v části Zařízení spustíte přehrávání obsahu ze zařízení. Pro vyhledání požadovaného počátečního nebo koncového snímku použijte tlačítka rychle převinout vpřed nebo převinout zpět nebo klepněte na položky Předchozí snímek a Další snímek.

Volbou možnosti Nejpomaleji, Pomalu, Normálně, Rychle nebo Nejrychleji nastavte rychlost vyhledávání zařízení. Zařízení pravděpodobně nebude podporovat všechny uvedené rychlosti. Znáte-li časové razítko požadovaného snímku, zadejte je do políčka Hledat a potom klepněte na tlačítko Přejít.

Klepnutím na tlačítka se šipkami lze měnit pořadí položek EDL.

Po dokončení EDL můžete spustit kódování klepnutím na příkaz Spustit kódování na panelu nástrojů.


Karta Seznam EDL

Karta Seznam EDL obsahuje časové údaje začátků a konců všech klipů v seznamu EDL. K dispozici je také statistika dokončení každého klipu na seznamu v procentech.


Karta Protokol událostí

Na kartě Protokol událostí je uveden seznam všech událostí, ke kterým došlo během aktuální relace kódování.

Jestliže zvolíte možnost protokolování do souboru, je třeba určit název souboru protokolu. Jestliže kódování zastavíte a znovu spustíte, připojí se nové události k tomuto souboru protokolu.

Jakmile se soubor protokolu naplní (1024 znaků), přestanou se do něho události protokolovat. Chcete-li protokolování obnovit, je třeba vytvořit nový soubor protokolu, tzn. zrušit zaškrtnutí a potom znovu zaškrtnout políčko Protokolovat do souboru.


Karta Obecné

Karta Obecné obsahuje následující informace:

  • Vstup. Informuje o aktuálně vybraném zdroji.
  • Kódování. Obsahuje následující informace: nastavení kódování v relaci, zda je obsah chráněn technologií DRM, velikost obrazu videa, zda byly před zpracováním použity filtry, přenosová rychlost, předpokládaná a skutečná (průměrná) frekvence snímků, a celkové množství příkazů skriptu, která byly vloženy do datového proudu.
  • Výstup. V případě relací kódování (nebo archivace) do souboru obsahuje seznam souborů, které se vytvářejí. V případě vysílání obsahuje vysílací port a počet připojených klientů. V případě vysílání prostřednictvím serveru Windows Media obsahuje adresu URL, prostřednictvím které se klienti připojují k vysílání ze serveru.
  • Průběh. Informuje o čase, který uběhl od spuštění kódování. V případě souborových zdrojů obsahuje odhadovanou dobu zbývající do dokončení kódování obsahu a velikost již dokončené části v procentech.
  • Systém. Informuje o velikosti zbývajícího prostoru na pevném disku, zatížení procesoru během kódování v procentech a čas, který zbývá do zaplnění pevného disku.


Výstup

Vyberte některou z možností distribuce obsahu:

  • Odeslat na server Windows Media. Tuto možnost vyberte, chcete-li, aby se kodér připojil k serveru se spuštěnou službou Windows Media Services za použití protokolu HTTP. Je třeba zadat název serveru a název adresáře pro publikování. Jestliže adresář pro publikování na serveru dosud neexistoval, bude vytvořen automaticky, pokud máte správné přístupové oprávnění pro server Windows Media. (Při vytváření adresáře pro publikování používejte pouze alfanumerické znaky. Dále nejsou pro název adresáře pro publikování platné tyto znaky: * < > \ ? % & # " { } | ^ [ ] `). Chcete-li použít nastavení jiného adresáře pro publikování, můžete do políčka Kopírovat nastavení z zadat název existujícího adresáře pro publikování (nepovinné). Klepnutím na položku Odebrat automaticky bude adresář pro publikování po ukončení programu kodéru nebo po vypršení časového limitu odebrán. (Časový limit umožňuje uživateli ukončit a restartovat kódování, aniž by bylo nutné vytvořit adresář pro publikování. Tato funkce je užitečná, chcete-li například upravit nastavení relace a potom pokračovat v kódování.)
  • Načíst z kodéru. Tuto možnost vyberte, chcete-li, aby server Windows Media přehrávač navázal spojení s kodérem za použití protokolu HTTP. Jako výchozí je použit port 8080. Kodér podporuje až pět přímých připojení. Seznam adres URL klientů, kteří se mohou připojit ke kodéru, je uveden na kartě Připojení panelu Sledování.
  • Kódování do souboru Tuto možnost vyberte, budete-li chtít distribuovat obsah později nebo chcete-li uložit kopii vysílání. Je možné omezit velikost nebo stopáž souboru. Omezení se použije na výstupní soubor, nikoli na zdrojový soubor. Chcete-li omezit velikost souboru, zadejte požadovanou velikost a použijte označení K (kilobajty), M (megabajty) nebo G (gigabajty). Chcete-li omezit stopáž souboru, zadejte stopáž výstupního souboru v hodinách, minutách a sekundách. Standardně je soubor indexován na každém klíčovém snímku, což uživatelům umožňuje použít funkci přehrávače pro vyhledávání a přehrávat obsah od konkrétního místa. Lze rovněž nastavit, kdy má kodér uživatele varovat, že dochází volné místo na pevném disku; výchozí nastavení je 1 MB. Do políčka Varování při nedostatku místa na disku zadejte číslo a použijte označení K, M nebo G pro kilobajty, megabajty nebo gigabajty.

    Poznámka - obrázek Poznámka

    • Jestliže omezíte stopáž výstupního souboru a ve stejné relaci použijete rovněž funkci komprese času, bude výstupní soubor pravděpodobně obsahovat o něco více nebo méně obsahu, než jste předpokládali. Jestliže například omezíte stopáž výstupního souboru na 30 minut a potom se rozhodnete zrychlit přehrávání souboru faktorem 2, bude výstupní soubor trvat 30 minut, ale bude obsahovat 60 minut obsahu.

Příbuzná témata

  • Možnosti výstupu
  • Použití časové komprese pro obsah


Vlastní nastavení kódování--obecné

Windows Media Encoder - titulní obrázek

Vlastní nastavení kódování – obecné

Slouží k zobrazení nebo úpravě obecných nastavení profilu.

  • Název a Popis. Při vytváření libovolného profilu zadejte do tohoto políčka název. Nepoužívejte v názvu hvězdičku (*). Vyplnění políčka s popisem není povinné.
  • Jazyk. Vyberte jazyk obsahu. (Jako výchozí se používá jazyk nastavený v kódovacím počítači.) Jestliže při kódování obsahu použijete různé jazyky, budou si uživatelé moci během přehrávání vybrat vlastní jazyk.
  • Importovat a Exportovat. Chcete-li naimportovat existující profil pro úpravy, klepněte na příkaz Importovat. Soubory s profily mají příponu PRX. Chcete-li změny uložit do profilu, klepněte na příkaz Exportovat.
  • Typy médií. Zadejte kombinaci typů zdrojů, které má tento profil podporovat. Jestliže vyberete skripty, bude během kódování možno vkládat do datového proudu příkazy skriptu. Každý typ zdroje spotřebovává část šířky pásma, které se používá při kódování. Vyberte ze seznamu režim VBR, který chcete použít pro zvuk a video. Chcete-li použít jednofázové kódování CBR, klepněte na položku CBR. (Chcete-li použít dvojfázové kódování CBR, je také nutno zaškrtnout políčko Dvojfázové kódování na kartě Komprese. Lze také vybrat kodeky, které chcete použít. Nezapomeňte, že režimy VBR nebo dvojfázové kódování CBR nejsou podporovány všemi kodeky.
  • Přenosové rychlosti. Obsahuje seznam aktuálně vybraných přenosových rychlostí (s výjimkou kódování VBR podle kvality, protože v tomto případě není možné určit přenosovou rychlost předem). Chcete-li pro obsah vytvořit jinou přenosovou rychlost, klepněte na příkaz Přidat. (Tato možnost není k dispozici, pokud seznam obsahuje přenosovou rychlost pro režimy kódování VBR.) Chcete-li provést vlastní úpravy, vyberte libovolnou přenosovou rychlost a klepněte na příkaz Upravit. Je třeba vybrat alespoň jednu přenosovou rychlost.
  • Formát videa. Zadejte formát zdroje videa (NTSC nebo PAL). Jestliže změníte nastavení frekvence snímků nebo velikosti videa na nestandardní hodnotu, bude automaticky vybrán formát Vlastní.
  • Povolit prokládané zpracování. Toto nastavení použijte, pokud je obsah prokládaný a pokud chcete, aby kódovaný výstup zůstal rovněž prokládaný. (Na kartě Zpracování je také třeba zaškrtnout políčko Zachovat prokládání.)
  • Povolit výstup obdélníkových pixelů. Nastavte, zda zdrojové video používá obdélníkové pixely (je-li například zdrojem digitální video), nebo zda má zdrojové video jiný poměr stran než 4:3 a chcete zachovat tento poměr v kódovaném výstupu. Poměr stran lze nastavit na kartě Velikost videa.

Příbuzná témata

  • Nastavení norem NTSC a PAL
  • Kódování CBR a VBR
  • Optimalizace zvuku a videa
  • Zachování poměru stran pixelu videa


Komprese

Vyberte cíl a nastavení zvuku a videa, které chcete použít v této relaci kódování.

  • Cíl, Zvuk a Video. Vyberte scénář distribuce, pro kterou vytváříte relaci. Výběrem určíte nastavení, která budou k dispozici v částech Zvuk a Video. Na základě kombinace voleb se určí nastavení (např. režim kódování, rozsah komprese, kodeky, přenosová rychlost a frekvence snímků), která se v relaci použijí. Skupina těchto nastavení se nazývá profil. Chcete-li provést vlastní úpravy profilu nebo importovat nebo exportovat profil, klepněte na příkaz Upravit.
  • Přenosové rychlosti. Obsahuje seznam aktuálně vybraných přenosových rychlostí. (V případě cílů Archiv souborů a Stažení souboru jsou zobrazena nastavení kvality videa.) Je-li v části Cíl vybrána možnost Server Windows Media, můžete klepnutím nastavit více přenosových rychlostí a vytvořit relaci pro více přenosových rychlostí.
  • Dvojfázové kódování. Toto nastavení se provádí automaticky podle cíle, který jste pro relaci zvolili. Dvojfázové kódování lze vybrat také v případě, chcete-li vytvořit dvojfázovou relaci kódování s konstantní přenosovou rychlostí (CBR). Nezapomeňte, že v některých případech není dvojfázové kódování vhodné.
  • Komprese času. V tomto nastavení vyberte, zda chcete obsah během přehrávání zrychlit nebo zpomalit. Klepněte na položku Vlastnosti a nastavte rozsah zrychlení nebo zpomalení obsahu nebo nastavte odstranění pauz ze zvuku. Kompresi času nelze použít na zdroj, která obsahuje pouze video.

    Použijete-li kompresi času společně s možností Omezit stopáž na kartě Výstup, nezapomeňte, že omezení se použije na výstupní soubor, nikoli na zdroj. Z tohoto důvodu bude výstupní soubor pravděpodobně obsahovat více nebo méně obsahu, než jste předpokládali. Pokud například omezíte stopáž výstupního souboru na 30 minut a potom se rozhodnete zrychlit přehrávání souboru dvojnásobně, bude výstupní soubor trvat 30 minut, ale bude obsahovat 60 minut obsahu.

Příbuzná témata

  • Jednofázové nebo dvojfázové kódování
  • Použití časové komprese pro obsah


Zdroje

Umožňuje přidávat nové zdroje do aktuální relace kódování, upravovat vlastnosti existujících zdrojů, nebo odebírat z relace nepotřebné zdroje.

  • Název. Zadejte název zdroje. Chcete-li zdroj z relace odstranit, klepněte na příkaz Odebrat. (Nezapomeňte, že relace musí obsahovat alespoň jeden zdroj.)
  • Zdroj. Vyberte zdroj (zařízení, soubory nebo obojí) a potom zvolte typ zdroje ke kódování (video, zvuk a skripty). Digitální zařízení, ze kterého kódujete, musí být zapnuté. V opačném případě se nezobrazí v seznamu zařízení. Zařízení, které jste přiřadili k některému zdroji, nelze použít pro jiný zdroj v relaci.
  • Na konci. Pokud v relaci používáte více zdrojů, vyberte akci, která se má provést po dosažení konce libovolného zdroje. (Tato možnost je k dispozici pouze pro zdrojové soubory s příponou AVI, WAV, WMV, WMA nebo MP3.) Jako krok můžete zvolit opakování libovolného zdroje, po dosažení konce jednoho zdroje přechod na další zdroj, nebo po dosažení konce jednoho zdroje přejít na první zdroj. Standardně se po dosažení konce zdroje kódování zastaví.
  • Začátek a konec (pouze pro zdrojové soubory). Klepnutím lze v souboru určit začátek a konec kódování.
  • Archivace. Pokud kódujete vysílání, zvolili jste archivaci kopie tohoto vysílání a používáte v relaci více zdrojů, klepněte na požadovanou možnost archivace jednotlivých zdrojů. Můžete např. chtít archivovat hlavní událost a pozastavit archivaci během přestávky.

Přidávat zdroje je možné před nebo po spuštění kódování. Chcete-li změnit pořadí, ve kterém jsou zdroje zobrazeny v hlavním okně kodéru, klepněte na některý zdroj a potom klepněte na tlačítko Šipka nahoru Šipka nahoru nebo Šipka dolů Šipka dolů .

Příbuzná témata

  • Používání souboru jako zdroje


Karta VBR podle kvality

Následující nastavení se vztahují k profilu, který používá kódování VBR podle kvality.

  • Formát zvuku. Klepněte na požadovanou úroveň kvality zvukového obsahu. Toto nastavení rovněž určuje frekvenci vzorkování a zda je zvuk určen pro přehrávání v monofonních nebo stereofonních reproduktorech. Při nastavení vyšší kvality je výsledkem kvalitnější zvuk, ale zároveň větší výstupní soubor.
  • Velikost videa. Zadejte požadovanou velikost (v pixelech) kódovaného videa. Použijte číslo od 16 do 2000. Velikost snímku kódovaného videa bude přizpůsobena požadované velikosti. Zaškrtnutím políčka Stejné jako vstup videa se velikost kódovaného videa přizpůsobí velikosti snímku zdrojového videa.
  • Frekvence snímků. Zadejte počet snímků obsahu videa za sekundu. Počet, který v tomto nastavení zadáte, závisí na rychlosti procesoru počítače a na tom, zda kódujete rychlé nebo pomalé video. Zobrazení rychlého videa je při vyšší frekvenci snímků obvykle plynulejší, ale zároveň se zvyšuje zatížení procesoru. Uvedené nastavení představuje maximální frekvenci snímků za sekundu. Vlivem některých faktorů, jako např. velikost videa a nastavení kvality kodeku, bude skutečně dosažená frekvence snímků za sekundu pravděpodobně nižší.
  • Interval klíčových snímků. Zadejte čas (v sekundách), kterým chcete oddělit klíčové snímky. Všechny snímky mezi klíčovými snímky jsou rozdílové snímky, které jsou značně menší než klíčové snímky, ale jejich obrazová kvalita není dostatečná. Pokud prodloužíte čas mezi klíčovými snímky, zmenší se velikost videa (v bajtech), protože se použije méně klíčových snímků. Zkrátíte-li čas mezi klíčovými snímky, velikost videa se zvýší. Prodloužení intervalu klíčových snímků je vhodné pro obsah s nehybným pozadím, např. kreslené filmy. Zkrácení intervalu klíčových snímků je vhodné pro rychlý obsah, např. sportovní záznam.
  • Kvalita videa. Zadáním hodnoty od 0 do 100 určete požadovanou kvalitu obrazu. Během kódování bude přenosová rychlost podle potřeby upravena tak, aby bylo dosaženo požadované kvality bez vynechání snímků. Aktuálně je k dispozici 30 jednotlivých nastavení kvality, takže každému nastavení kvality patří několik úrovní kvality. Následující úrovně kvality odpovídají jednotlivým nastavením kvality: 1, 4, 8, 11, 15, 18, 22, 25, 29, 33, 36, 40, 43, 47, 50, 54, 58, 61, 65, 68, 72, 75, 79, 83, 86, 90, 93, 97 a 100. Čísla mezi dvojicemi hodnot odpovídají stejnému nastavení kvality jako nižší číslo. Například čísla 2 i 3 odpovídají stejnému nastavení kvality jako 1.
  • Složitost dekodéru. Pokud kódujete pro jiné hardwarové zařízení než počítač, můžete určit kategorii složitosti kódovaného obsahu. Některá hardwarová zařízení podporují pouze některé kategorie. (Další informace najdete v dokumentaci k zařízení.) Možnost Složitý je určena pro přehrávání v počítači. Obvykle je třeba použít nastavení Automaticky, které umožňuje automaticky opravit nastavení složitosti během kódování.
  • Přenosová rychlost skriptu. Zadejte požadovanou přenosovou rychlost skriptů (v bitech za sekundu). Hodnota se musí nacházet mezi 1000 a 10 000 b/s. Použijte označení k pro kilobity.


Atributy

Atributy představují skupinu doplňkových položek, které se rovněž nazývají metadata, a které poskytují informace o obsahu. Atributy jsou součástí kódovaného datového proudu a lze je extrahovat nástroji pro vyhledávání nebo vlastními programy, které vycházejí ze sady Microsoft Windows Media Format Software Development Kit (SDK). Mezi výchozí atributy patří název, autor, autorská práva a popis obsahu. Tyto atributy se zobrazí při přehrávání obsahu v přehrávači Windows Media Player nebo v jiných programech pro přehrávání, které vycházejí ze sady Windows Media Format SDK. Můžete vytvářet vlastní atributy, např. datum úpravy obsahu, jméno autora atd. Vlastní atributy se nezobrazují v přehrávači Windows Media Player, ale lze je extrahovat pomocí nástrojů pro vyhledávání nebo jiných vlastních programů, které vycházejí ze sady Windows Media Format SDK.

Chcete-li vytvořit atribut, klepněte na příkaz Přidat. Chcete-li upravit nebo odstranit libovolný atribut, vyberte jej ze seznamu a klepněte na příkaz Upravit nebo Odebrat.


Přidat přenosovou rychlost

Zadejte přenosovou rychlost v bitech za sekundu. Použijte označení k pro kilobity, M pro megabity nebo G gigabity. Nezapomeňte, že skutečná přenosová rychlost bude o něco vyšší než zadaná hodnota, protože se k přenosové rychlosti přidává režie.


Práva a ochranné známky

Informace obsažené v této příručce, včetně adres URL a dalších internetových odkazů na webové stránky, mohou podléhat změnám bez předchozího upozornění. Názvy společností, organizací, produktů, jména a údaje použité v ukázkách jsou smyšlené. Nemůže být vyvozováno žádné jejich spojení se skutečnou společností, organizací, produktem, jménem a údajem. Uživatel je povinen dodržovat veškeré platné zákony o autorských právech. Bez omezení práv vyplývajících z autorského zákona, nesmí být tato příručka rozšiřována po částech ani jako celek, převáděna do jakékoli jiné formy ať mechanicky, nebo elektronicky včetně fotokopírování a snímání, a to pro jakékoli účely, bez předchozího výslovného písemného povolení společnosti Microsoft Corporation.

Některé patenty, patentové žádosti, ochranné známky, autorská práva nebo jiná práva na duševní vlastnictví společnosti Microsoft se mohou týkat obsahu tohoto dokumentu. Není-li výslovně stanoveno v písemném licenčním ujednání od společnosti Microsoft, poskytnutím tohoto dokumentu vám společnost neuděluje žádnou licenci na žádný z těchto patentů, patentových přihlášek, ochranných známek, autorských práv nebo práv k duševnímu vlastnictví.

© 2000-2002 Microsoft Corporation. Všechna práva vyhrazena.

Microsoft, MS-DOS, Windows, Windows Media, Windows NT, ActiveSync, ActiveX, Direct3D, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, FrontPage, JScript, Microsoft Press, MSN, NetShow, Outlook, PowerPoint, Visual Basic, Visual C++, Visual InterDev, Visual J++, Visual Studio, WebTV, Win32 a Win32s jsou buď registrované ochranné známky, nebo ochranné známky společnosti Microsoft Corporation ve Spojených státech amerických a v dalších zemích.

Uvedené názvy produktů nebo společností mohou být ochrannými známkami vlastníků těchto známek.


Dvojfázové kódování ze zařízení

Při používání zařízení jako zdroje můžete používat dvojfázové kódování, pokud jste provedli následující kroky:

  • povolili jste ovládání zařízení,
  • zvolili jste možnost kódování do souboru,
  • zvolili jste možnost dočasného uložení obsahu,
  • vytvořili jste pro obsah seznam EDL.

Příbuzná témata

  • Povolení ovládání zařízení
© 2000-2002 Microsoft Corporation.Všechna práva vyhrazena.


Nový profil

Slouží ke správě služeb poskytovatelů licencí a k vytvoření nového profilu.

  • Přidat nebo Odebrat. Klepnutím na tyto příkazy přidáte nebo odeberete poskytovatele.
  • Vytvořit. Klepnutím na toto tlačítko po vybrání poskytovatele ze seznamu se vygeneruje profil DRM.

Poznámka - obrázek Poznámka

  • Profily vytvářejí různí poskytovatelé. Informace, které zadáte při vytváření nebo úpravách profilu, se přenášejí po síti Internet.

Příbuzná témata

  • Použití technologie DRM (Digital Rights Management) k ochraně obsahu


Kodér nepodporuje přenos souborů

Načtený soubor relace byl vytvořen programem pro přenos souborů. Tento kodér nepodporuje přenos souborů. Chcete-li proto kódovat obsah pomocí tohoto souboru relace, musíte použít program pro přenos souborů, ve kterém byl tento soubor relace vytvořen.


Je nutné zvolit možnost výstupu

Kódovaný obsah je nutné uložit do souboru nebo vysílání.

Příbuzná témata

  • Možnosti výstupu


Zadejte název serveru

Zadejte platný název serveru Windows Media. Můžete použít název pro rozhraní NetBIOS, adresu IP nebo název DNS (Domain Name System) serveru.

Příbuzná témata

  • Odeslání datového proudu z kodéru


Nastavení norem NTSC a PAL

Následující tabulka obsahuje informace o frekvencích snímků a velikostech videa, které jsou kompatibilní s normou NTSC.

Nastavení | Možné hodnoty
Frekvence snímků za sekundu | 60, 30, 15, 10 a 7,5
Velikost snímku | 160 x 120 176 x 120 240 x 180 320 x 240 352 x 240 640 x 480 720 x 480

Následující tabulka obsahuje informace o frekvencích snímků a velikostech videa, které jsou kompatibilní s normou PAL.

Nastavení | Možné hodnoty
Frekvence snímků za sekundu | 50, 25, 12,5, 8,3 a 6,25
Velikost snímku | 176 x 144 192 x 144 288 x 216 352 x 288 384 x 288 720 x 576 768 x 576

Příbuzná témata

  • Vlastní nastavení kódování – obecné


Optimalizace výkonu

Existuje řada možností nastavení optimálního výkonu systému během kódování.

Příbuzná témata

  • Nastavení optimálního výkonu systému


Karta VBR podle maximální přenosové rychlosti

Následující nastavení lze použít v profilu, který používá kódování VBR podle maximální přenosové rychlosti.

  • Formát zvuku. Klepnutím na tuto položku lze nastavit zvukový obsah. Nastavení určuje cílovou přenosovou rychlost zvuku, frekvenci vzorkování a také, zda je zvuk určen pro přehrávání v monofonních nebo stereofonních reproduktorech. Při nastavení vyšší vzorkovací frekvence dosáhnete kvalitnějšího zvuku, který ale vyžaduje větší šířku pásma, nebo se projeví na velikosti souboru. Je nutné dosáhnout správné rovnováhy mezi přenosovou rychlostí a frekvencí vzorkování.
  • Maximální přenosová rychlost zvuku. Zadejte maximální přenosovou rychlost, kterou chcete použít pro zvukový obsah. Kodér během kódování zvolí kvalitu zvuku, které lze dosáhnout bez překročení maximální přenosové rychlosti.
  • Maximální velikost vyrovnávací paměti zvuku. Zadejte maximální velikost vyrovnávací paměti (v sekundách), po kterou má klient čekat před přehráváním obsahu, který byl kódován při maximální přenosové rychlosti zvuku. Pokud kódujete pro přehrávání v hardwarovém zařízení, zadejte velikost vyrovnávací paměti (v sekundách), která odpovídá velikosti vyrovnávací paměti daného zařízení. Výchozí nastavení vyrovnávací paměti je 3 sekundy. Chcete-li dosáhnout nejlepších výsledků, musí se toto číslo vždy rovnat nebo být menší než velikost vyrovnávací paměti (používáte-li kódování videa CBR) nebo maximální velikost vyrovnávací paměti videa (používáte-li kódování videa podle maximální rychlosti).
  • Velikost videa. Zadejte požadovanou velikost (v pixelech) kódovaného videa. Použijte hodnoty od 16 do 2000. Velikost snímku kódovaného videa bude přizpůsobena požadovanému nastavení. Zaškrtnutím políčka Stejné jako vstup videa se velikost kódovaného videa přizpůsobí velikosti snímku zdrojového videa.
  • Frekvence snímků. Zadejte počet snímků datového proudu videa za sekundu. Počet, který v tomto nastavení zadáte, závisí na rychlosti procesoru počítače a na tom, zda kódujete rychlé nebo pomalé video. Zobrazení rychlého video je při vyšší frekvenci snímků obvykle plynulejší, ale zároveň se zvyšuje zatížení procesoru. Uvedené nastavení představuje maximální počet snímků za sekundu, ale jejich skutečný počet bude pravděpodobně nižší.
  • Interval klíčových snímků. Zadejte čas (v sekundách), kterým chcete oddělit klíčové snímky. Všechny snímky mezi klíčovými snímky jsou rozdílové snímky, které jsou značně menší, než klíčové snímky, ale jejich obrazová kvalita není dostatečná. Pokud prodloužíte čas mezi klíčovými snímky, zmenší se velikost videa (v bajtech), protože se použije méně klíčových snímků. Zkrátíte-li čas mezi klíčovými snímky, velikost videa se zvětší. Prodloužení intervalu klíčových snímků je vhodné pro obsah s nehybným pozadím, např. kreslené filmy. Zkrácení intervalu klíčových snímků je vhodné pro rychlý obsah, např. sportovní záznam.
  • Přenosová rychlost videa (průměr). Zadejte průměrnou přenosovou rychlost (v bitech za sekundu), kterou chcete použít pro obrazovou část obsahu. Použijte označení k pro kilobity, M pro megabity nebo G pro gigabity. Okamžitá přenosová rychlost může průměrnou přenosovou rychlost kdykoli překročit, ale celková přenosová rychlost nemůže být vyšší než průměrná přenosová rychlost.
  • Maximální přenosová rychlost videa. Zadejte maximální velikost vyrovnávací paměti (v bitech za sekundu), kterou chcete použít pro obrazovou část obsahu. Kodér během kódování určí kvalitu obrazu, které lze dosáhnout, aniž by byla překročena maximální přenosová rychlost. Pokud kódujete pro přehrávání v hardwarovém zařízení, např. přehrávači DVD, zadejte jeho rychlost načítání.
  • Maximální velikost vyrovnávací paměti videa. Zadejte maximální velikost vyrovnávací paměti (v sekundách), po kterou má klient čekat před přehráváním obsahu, který je kódován při maximální přenosové rychlosti videa. Pokud kódujete pro přehrávání v hardwarovém zařízení, zadejte velikost vyrovnávací paměti (v sekundách), která odpovídá velikosti vyrovnávací paměti daného zařízení. Výchozí nastavení vyrovnávací paměti je 5 sekund.
  • Složitost dekodéru. Kódujete-li pro jiné hardwarové zařízení než počítač, můžete určit kategorii složitosti kódovaného obsahu. Některá hardwarová zařízení podporují pouze některé kategorie. (Další informace najdete v dokumentaci k zařízení.) Možnost Složitý je určena pro přehrávání v počítači. Obvykle je nutné použít nastavení Automaticky, které umožňuje automaticky opravit nastavení složitosti během kódování.
  • Přenosová rychlost skriptu. Zadejte požadovanou přenosovou rychlost skriptů (v bitech za sekundu). Hodnota se musí nacházet mezi 1000 a 10 000 b/s. Použijte označení k pro kilobity.


Nastavení přenosové rychlosti, datové proudy pouze pro zvuk

Následující způsobem je možno nastavit profil kódování datového proudu pouze pro zvuk.

Klepněte na nastavení zvukového obsahu. Vyšší frekvencí vzorkování je dosažena vyšší kvalita zvuku, ovšem za použití větší šířky pásma.

Chcete-li kódovat zvukový obsah pomocí maximální přenosové rychlosti založené na kódování VBR, zadejte pro tuto rychlost požadovanou hodnotu (v bitech za sekundu). Přípona K vyjadřuje kilobity, M megabity a G gigabity. Během kódování určí program Encoder dosažitelnou kvalitu zvuku, aniž by byla překročena maximální přenosová rychlost. Nastavte také hodnotu pro maximální vyrovnávací pamět.


Nastavení přenosové rychlosti, tabulka CBR

Následujícím způsobem lze nastavit profil používající kódování CBR.

  • Formát zvuku. Klepněte na nastavení zvukového obsahu. Zde lze nastavit přenosovou rychlost zvuku, frekvenci vzorkování a způsob přehrávání u reproduktorů (mono nebo stereo). Vyšší frekvencí vzorkování je dosažena vyšší kvalita zvuku, avšak za použití větší šířky pásma nebo větší velikosti souboru. Ideálním stavem je dosažení rovnováhy mezi přenosovou rychlostí a frekvenci vzorkování. Dostupná šířka pásma sítě pro zvukový datový proud musí být stejná jako pro datový proud videa nebo skriptu.
  • Velikost videa. Zadejte požadovanou velikost (v pixelech) pro kódování videa. Použijte hodnoty od 16 do 2000. Velikost snímku kódovaného videa bude změněna podle zadané hodnoty. Chcete-li, aby velikost snímku odpovídala zdroji videa, zaškrtněte políčko Stejné jako vstup videa .
  • Frekvence snímků. Zadejte hodnotu frekvence snímků za sekundu (f/s) pro datový proud videa. Hodnota nastavení závisí na rychlosti procesoru počítače a dynamice kódovaného videa (velká nebo nízká dynamika). Kvalita videa s velkou dynamikou je obecně vyšší, ovšem tato metoda kódování zvyšuje požadavek na činnost procesoru. Nastavená hodnota určuje maximální frekvenci snímků. V závislosti na faktorech, jako jsou nastavení velikosti videa a dostupná šířka pásma, může být dosažená frekvence snímků nižší.
  • Interval klíčových snímků. Zadejte dobu v sekundách, která bude oddělovat jednotlivé klíčové snímky. Všechny snímky mezi klíčovými snímky se nazývají snímky delta a jsou výrazně menší než klíčové snímky, ovšem jejich kvalita je také malá. Zvětšením časového intervalu mezi klíčovými snímky se sníží velikost videa (v bajtech), protože klíčových snímků bude použito méně. Zmenšením časového intervalu mezi klíčovými snímky se velikost videa zvýší. Interval klíčových snímků zvětšete u typů videa se statickým pozadím, jako jsou např. kreslené seriály. Tuto hodnotu zvětšete u videa s velkou dynamikou, jako jsou např. sportovní sekvence.
  • Přenosová rychlost videa. Zvolte přenosovou rychlost (v bitech za sekundu), která bude použita u části programu obsahující video. Předpona K vyjadřuje kilobity, M megabity a G gigabity. Zadaná hodnota nezahrnuje část nutnou pro síťový provoz. Dostupná šířka pásma sítě pro zvukový datový proud musí být stejná jako pro datový proud videa nebo skriptu.
  • Velikost vyrovnávací paměti. Zadejte počet sekund vyjadřující dobu uložení obsahu videa před tím, než se spustí proces kódování. Čím je toto číslo větší, tím je lepší kvalita videa, ovšem proces vyžaduje více kapacity paměti. Proces kódování je pozdržen po dobu specifikovanou ve vyrovnávací paměti a také obsah videa je při vysílání datového proudu do přehrávače po stejnou dobu pozdržen. Obsah videa přehrávaný programem Windows Media Player je během vysílání datového proudu pozdržen o čas určený hodnotou Velikost vyrovnávací paměti. Výchozí nastavení velikosti vyrovnávací paměti je 5 sekund.
  • Plynulost videa. Zadejte číslo od 0 do 100, kde hodnota 0 znamená nejplynulejší průběh a hodnota 100 nejčistější obraz. Přehrávání videa je plynulé, pokud objekty na obrazovce mění svoji polohu plynule a pohyb není trhaný. Obraz videa je čistý, pokud jsou objekty a pohyby zřetelné a jsou vykresleny čistě. Zvýšení čistoty obrazu může mít, v závislosti na formátu videa, vliv na frekvenci snímků. Pokud je například video hodně dynamické, zvýšení čistoty obrazu může snížit frekvenci snímků.
  • Složitost dekodéru. Jestliže zadáváte jiné hardwarové zařízení než počítač, můžete určit kategorii složitosti kódovaného obsahu. Některá hardwarová zařízení podporují pouze některé kategorie. (Další informace najdete v dokumetaci k zařízení.) Možnost Složitý je určena pro přehrávání v počítači. Obvykle je třeba použít nastavení Automaticky, které umožňuje automaticky opravit nastavení složitosti během kódování.
  • Přenosová rychlost skriptu. Zvolte přenosovou rychlost (v bitech za sekundu), která bude použita pro skripty. Hodnota musí být mezi 1000 b/s a 10 000 b/s.


Moduly plug-in

Vyberte převodní moduly plug-in, které mají být v relaci přiřazeny zdrojům.

  • Seznam zdrojů. Vyberte zdroj, ke kterému bude přidán modul plug-in (nutné pouze u vícezdrojových relací).
  • Převod typu modulu plug-in. Chcete-li zobrazit aktuálně nainstalované a registrované převodní moduly plug-in v kódovacím počítači, klepněte na tlačítko Zvuk nebo Video.
  • Registr. Klepnutím zobrazíte dialogové okno Registrace a zrušení registrace převodních modulů plug-in . V dialogovém okně se zobrazí převodní moduly plug-in, které jsou aktuálně nainstalované v kódovacím počítači. Moduly je třeba před jejich použitím zaregistrovat. Chcete-li registraci provést, vyberte v dialogovém okně modul plug-in a poté klepněte na tlačítko OK.
  • Posunutí doprava a Posunutí doleva. Klepnutím na tlačítko Posunutí doprava (>>) přidáte modul plug-in ke zdroji. Klepnutím na tlačítko Posunutí doleva (<<) odstraníte modul plug-in od zdroje. Pořadí, v jakém jsou moduly plug-in přiřazeny zdroji, lze změnit klepnutím na šipku nahoru nebo dolů.
  • Konfigurovat. Klepnutím můžete upravit vlastnosti zvoleného modulu plug-in.

    Upozornění - obrázek Upozornění

    • V dialogovém okně Registrace a zrušení registrace převodních modulů plug-in jsou zobrazeny všechny převodní moduly plug-in, které jsou v kódovacím počítači k dispozici. Některé moduly plug-in nejsou pro program Windows Media Encoder vhodné a jejich použití může způsobit neočekávané výsledky.


Zabezpečení

Zvolte, chcete-li k zabezpečení obsahu médií použít technologii DRM (Digital Rights Management) nebo vložit do obsahu vodoznak.

  • Použít technologii DRM k zabránění neoprávněnému použití obsahu médií. Zvolte, chcete-li zabezpečit obsah médií pomocí technologie DRM. Před použitím této technologie musí být vytvořen profil DRM.
  • Profil DRM. Klepnutím zvolíte profil DRM, který bude v této relaci použit pro kódování obsahu médií. Profil DRM obsahuje klíč, ID klíče, adresu URL k licenčnímu serveru, ID obsahu a další informace nezbytné k zašifrování obsahu. Pokud požadovaný profil neexistuje nebo chcete vytvořit nový, klepněte na tlačítko Nový. Chcete-li existující profil odstranit, klepněte na tlačítko Odstranit. Chcete-li profil upravit, klepněte na tlačítko Upravit. Chcete-li použít profil, který je umístěn na jiném počítači, klepněte na tlačítko Importovat a zadejte cestu k požadovanému profilu. Chcete-li zajistit sdílení profilu s jiným počítačem, klepněte na tlačítko Exportovat a zadejte příslušnou cestu.
  • ID klíče. ID klíče se zobrazí pouze při vytváření profilu a toto ID nelze měnit. ID klíče je obsaženo v hlavičkovém souboru, který je připojen ke kódovanému obsahu. Přehrávač přečte hlavičkový soubor, nalezne ID klíče a předá jej licenčnímu serveru. Pokud licenční server rozpozná toto ID, vydá licenci.
  • Vložit digitální vodoznak. Zvolte, chcete-li při přenášení zvukového datového proudu, datového proudu videa nebo obou proudů najednou použít vodoznak. Vodoznak vkládá do datového proudu digitální otisk prstu. Různé softwarové nástroje mohou tyto informace týkající se např. autorský práv, podmínek použití produktu nebo autora dekódovat. Vodoznak slouží k označení pravosti zvukového obsahu nebo obsahu videa. Chcete-li pracovat s vodoznaky, musíte získat a zaregistrovat modul plug-in jiného výrobce. Více informací o získání vodoznaku naleznete na webu firmy Microsoft.
  • Konfigurovat. Klepněte, pokud použitý modul plug-in vodoznaku požaduje specifikaci konfiguračního souboru.

Příbuzná témata

  • Použití technologie DRM (Digital Rights Management) k ochraně obsahu


Heslo pro vysílání

Zadejte uživatelské jméno a heslo k přístupu na server Windows Media. Tato pověření je nutno při odeslání nabídky datového proudu na server Windows Media, který může provádět ověření modulů plug-in, zadat.


Publikování souborů

Pokud ukončíte průvodce a vysílání obsahu datového proudu je připraveno, soubory lze uložit přímo do sdíleného adresáře. Pokud vysílání obsahu datového proudu ještě připraveno není, soubory lze uložit dočasně a před započetím vysílání můžete soubory zkopírovat do sdíleného adresáře.


Zabezpečení vysílání

Program Windows Media Encoder podporuje až pět způsobů přímého připojení k vysílání. Přístup k vysílání lze omezit určením adres IP vysílacích serverů, na které se chcete připojit, nebo naopak, na které se připojit nechcete.

Příbuzná témata

  • Omezení přístupu k vysílání


Registrace modulů plug-in

V tomto dialogovém okně je uveden seznam modulů plug-in, které jsou v počítači k dispozici. Některé z těchto modulů nejsou pro použití s programem Windows Media Encoder vhodné.

Pro registraci libovolného modulu plug-in musí mít uživatel oprávnění správce pro počítač, který chce použít pro kódování.


Panel Skript

Panel Skript obsahuje ovládací prvky, které umožňují vkládat do datového proudu během kódování příkazy skriptu, jako např. titulky (textové řetězce), adresy URL a vlastní příkazy skriptu. Při vložení každého skriptu se zvýší položka Skripty (celkem) na panelu Sledování.


Zabezpečení vysílání

Program Windows Media Encoder umožňuje až pět přímých připojení během vysílání. Je možné určit, který počítač nebo skupina počítačů má ke kodéru povolený přístup. Pro povolení nebo zákaz přístupu jednotlivým počítačům použijte adresu IP. Pro povolení nebo zákaz přístupu skupině počítačů použijte masku IP.

Při omezení přístupu k vysílání prostřednictvím adres IP je možné specifikovat adresy standardu Internet Protocol verze 6 (IPv6) a Internet Protocol verze 4 (IPv4). IPv6 je nejnovější verze standardu Internet Protocol, která je přizpůsobena vzrůstajícímu požadavku na jedinečné adresy IP. IPv6 zvyšuje velikost adresy IP z 32 na 128 bitů a umožňuje tak využívat rozsáhlejší hierarchii adresování a větší počet adresovatelných uzlů. Další informace o IPv6 najdete na stránce věnované tomuto standardu na webu společnosti Microsoft.

V rozsahu adres se každý bit masky IP porovnává s odpovídajícím bitem adresy IP. Je-li hodnota v masce 1, zařadí se do rozsahu odpovídající bit v adrese IP. Je-li hodnota v masce 0, je přijatelná libovolná hodnota. Pokud je například adresa IP v seznamu v desítkovém zápisu 134.123.123.20 a maska je 255.255.255.0, budou do rozsahu zařazeny všechny adresy IP od 134.123.123.0 do 134.123.123.255. Pokud je maska 255.255.255.128, budou do rozsahu zařazeny všechny adresy IP od 134.123.123.0 do 134.123.123.127. Při zadání neplatné masky bude adresa IP ignorována.


Karta Výkon

Jestliže během kódování dojde opakovaně k překročení možností kódovacího počítače, je možné pomocí nastavení na této kartě zajistit úspěšné kódování. Uživatel může zvolit, zda chce dát přednost vyššímu výkonu nebo vyšší kvalitě obsahu. Při nastavení vyšší kvality dochází k vyššímu zatížení procesoru; při nastavení vyššího výkonu bude zatížení procesoru nižší. Nastavení se vztahují na relace, které využívají kodeky Windows Media Video 9 nebo Windows Media Video 8.1.

Bude pravděpodobně třeba vyzkoušet různá nastavení a najít rovnováhu mezi kvalitou a výkonem. Chcete-li obnovit nastavení kodeků, zaškrtněte políčko Použít výchozí.

Změny je možné použít pro všechny relace nebo je možné změnit nastavení pouze u aktuální relace.

Poznámka - obrázek Poznámka

  • Pro dosažení optimálního výkonu během kódování jsou k dispozici další možnosti.

Příbuzná témata

  • Nastavení optimálního výkonu systému


Karta Server

Karta Server zobrazuje informace o stavu serveru Windows Media během odesílání datového proudu na server. Rovněž zobrazuje počet přehrávačů, které jsou aktuálně připojeny k serveru Windows Media (pouze jednosměrné datové proudy).

Chcete-li přijímat informace o stavu, musíte mít oprávnění k přístupu ke službě Windows Media Services prostřednictvím DCOM.


Upřesnit

Umožňuje změnit název kodéru, použít vlastní velikost paketu, vytvořit časový kód nebo povolit dočasné úložiště obsahu.

  • Identifikační název. Název kodérů je přiřazován automaticky, ale v případě nutnosti je možné jej upravit. Název umožňuje rozlišit kodéry, pokud je v jednom počítači spuštěno několik instancí současně.
  • Maximální velikost paketu. Určuje maximální velikost (v bajtech) paketů protokolu UDP (User Datagram Protocol), které se odesílají po síti. Toto nastavení se vztahuje k obsahu s jednou přenosovou rychlostí, který je odesílán ze serveru Windows Media. Maximální výchozí velikost paketu je 16 000 bajtů. Aktuální velikost paketů se vypočítává během kódování. Zjistíte-li během vysílání, že se pakety ztrácejí nebo fragmentují, můžete pomocí nastavení Vlastní snížit maximální velikost paketů. Nezapomeňte, že při kódování zvukového obsahu při velmi vysokých přenosových rychlostech může dojít k překročení maximální velikosti paketu.
  • Časový kód. Vyberte, zda chcete povolit vyhledávání po snímcích. Je možné zachovat časový kód, který je již přítomen ve zdrojovém videu, nebo je možné časový kód vytvořit. Při vytváření časového kódu lze zadat požadovaný čas spuštění kódu ve formátu hh:mm:ss:fm; dále je možné vybrat formát zdrojového videa, jako např. NTSC.
  • Dočasně uložit obsah na pevný disk. Nelze-li data z některého zařízení digitalizovat do souboru během kódování, je možné je dočasně uložit. Po zaškrtnutí políčka Nejdříve digitalizovat na pevný disk, pak kódovat se veškerá data nejprve digitalizují, a v následujícím kroku se zakódují. Zvolením této možnosti zabráníte ztrátám snímků při digitalizaci velkého množství dat. Při dosažení minimálního volného místa na disku se kódování zastaví. Pro uložení hodinového záznamu z digitálního zařízení je třeba přibližně 15 GB úložného prostoru. Při zaplnění místa na disku se kódování automaticky zastaví.

Příbuzná témata

  • Kódování a archivace vysílání do souboru


Karta Obecné

Následující možnosti ovlivňují vzhled hlavního okna kodéru. Ačkoliv je u řady možností použito výchozích nastavení, uživatel může nastavení měnit podle vlastních potřeb.

  • Automaticky zobrazit panely nutné k aktuální relaci. Slouží k zobrazení panelů v hlavním okně kodéru podle podle nastavení, které jste provedli po spuštění Průvodce novou relací. Pokud chcete v hlavním okně kodéru používat pro výběr zobrazení panelů nabídku Zobrazit, zrušte zaškrtnutí tohoto políčka.
  • Změnit velikost hlavního okna, pokud je video příliš zvětšeno. Slouží ke přizpůsobení velikosti hlavního okna kodéru zvětšeným zobrazením Vstup a Výstup. Po zrušení zaškrtnutí tohoto políčka budou tato zobrazení pravděpodobně částečně skrytá. Toto nastavení nemá žádný vliv na velikost kódovaného obrazu.

    Poznámka - obrázek Poznámka

    • Velká vstupní a výstupní zobrazení mohou mít negativní vliv na výkon procesoru během kódování.
  • Minimalizovat okno kodéru při digitalizaci obrazovky. Slouží k automatické minimalizaci kodéru při digitalizaci obrazovky. V případě relace kódování do souboru se při obnovení okna kodér pozastaví. V případě relace vysílání bude kódování pokračovat i po obnovení okna kodéru.
  • Před zastavením kódování zobrazit upozornění. Slouží k nastavení upozornění, které se zobrazí při každém zastavení kodéru.
  • Při spuštění zobrazit dialogové okno Nová relace. Slouží k zobrazení dialogového okna při spuštění kodéru. Dialogové okno Nová relace obsahuje výběr průvodců nebo šablon, které usnadňují nastavení relace.
  • Po zastavení kódování zobrazit dialogové okno Výsledky kódování. Zaškrtnutím tohoto políčka se po ukončení kódování automaticky zobrazí dialogové okno Výsledky kódování. Jestliže zrušíte zaškrtnutí tohoto políčka, můžete zobrazit výsledky klepnutím na možnost Výsledky kódování v nabídce Zobrazit.
  • Zobrazit všechny tipy. Klepnutím na toto tlačítko se zobrazí tipy.
  • Výchozí formát videa. Slouží k výběru požadovaného formátu videa (NTSC nebo PAL) pro kódování. Tato možnost se týká nastavení cílového umístění, obrazu a zvuku, které se zobrazí na kartě Komprese panelu Vlastnosti.


Zpracování

Vyberte možnosti úprav obsahu před zpracováním, které chcete použít pro zvýšení kvality kódovaného obsahu.

Video

  • Žádný. Pokud nechcete k úpravě obsahu před zpracováním použít žádný filtr, klepněte na tuto možnost. Tuto možnost použijte pouze v případě, že se obsah již nachází ve formátu progresivního snímání zobrazení.
  • Zrušit prokládání. Klepnutím na tuto možnost se prokládaná pole videa rozdělí do jednotlivých snímků, což může přispět k jemnějšímu zobrazení videa.
  • Inverzní přepis Telecine. Pokud jste jako zdroj použili video v přepisu Telecine, klepnutím na tuto možnost se odstraní nadbytečné snímky, které byly doplněny během přepisu Telecine. Klepnutím na možnost Automaticky se přepis Telecine rozpozná automaticky. Pokud je úsek přepisu Telecine v obsahu souvislý, vyberte v seznamu klepnutím nastavení, které odpovídá prvnímu snímku ve zdrojovém videu.
  • Zachovat prokládání. Na tuto možnost klepněte, jestliže chcete prokládání ze zdrojového videa zachovat v kódovaném videu.
  • Rozpoznat. Pokud nevíte, zda byl obsah prokládaný nebo v přepisu Telecine, klepněte na tuto možnost. Kodér obsah vyhodnotí a doporučí použití vhodného filtru.
  • Formát pixelů. Slouží k výběru požadovaného formátu pixelů.
  • Převrátit svisle. Tuto možnost použijte, jestliže je video vzhůru nohama. Otočení videa vzhůru nohama může být způsobeno použitím zařízení pro digitalizaci souborů formátu AVI, které zcela nevyhovuje specifikacím pro publikování. Otočení obvykle souvisí s formátem pixelů zařízení.

Zvuk

  • Optimalizace hlasového kodeku: Uživatelé hlasového kodeku Windows Media Audio 9 mohou optimalizovat chování kodeku, pokud zadají, zda je obsahem pouze hlas, nebo také hudba. Pokud se obsah skládá z hlasu i hudby, klepněte na možnost Zvuk se zvýrazněním hlasu. Během kódování kodek používá automaticky vhodný algoritmus pro optimalizaci kódování podle obsahu (hlas nebo hudba). Můžete také vytvořit soubor definice optimalizace, který optimalizuje zvuk tím, že v souboru vyhledá místa, kde hudba začíná a končí.
  • Zvukový formát 5.1. Při kódování obsahu s vícekanálovým zvukem jsou kanály automaticky rozděleny na dva pro přehrávání prostřednictvím stereofonních reproduktorů. Na tomto místě lze ovšem provádět vlastní nastavení rozdělení. Hodnoty zadané uživatelem nejsou konečné. Místo toho bude normalizováno celkové zesílení kanálů, aby nedošlo k deformaci. Je možné zadat hodnoty mezi 0 a -144 decibely. (Tato možnost není k dispozici při kódování zvukového formátu 7.1.)

Příbuzná témata

  • Optimalizace zvuku a videa
  • Použití vícekanálových zvukových souborů jako zdroje


Panel Zdroje

Na panelu Zdroje jsou uvedeny všechny zdroje aktuální relace. Během kódování je možné zdroje přepínat klepnutím na příslušné tlačítko.


Karta Statistika

Na kartě Statistika jsou zobrazeny informace o vstupu a výstupu zvuku i videa, včetně počtu kanálů a vzorkovací frekvence, frekvence snímků, vynechaných snímků, průměrné přenosové rychlosti atd.


Zastavení kódování v druhé fázi

Aktuální relace používá dvojfázové kódování. Zastavíte-li nyní kódování, nedokončí se druhá fáze a kódovaný obsah pravděpodobně nebude platný.

Příbuzná témata

  • Jednofázové a dvojfázové kódování


Generování souboru ve formátu datového proudu

Windows Media Encoder - titulní obrázek

Generování souboru formátu datového proudu

Soubor formátu datového proudu obsahuje informace, které přehrávač potřebuje pro dekódování vícesměrového datového proudu. Tento soubor je třeba vygenerovat pouze v případě, pokud chcete spustit kódování až poté, co server naváže spojení s kodérem. (Jestliže chcete spustit kódování dříve, než server naváže spojení s kodérem, není třeba žádný soubor ve formátu datového proudu generovat, protože server rozpozná formát datového proudu automaticky.) Po vygenerování je třeba soubor předat správci serveru. V rámci nastavení informace o vícesměrovém datovém souboru pro vysílání správce serveru identifikuje soubor, který obsahuje formáty pro datový proud. Soubor ve formátu datového proudu má příponu ASF.

Příbuzná témata

  • Povolení klientům načítat datový proud z kodéru


Panel Skript

Tento panel se zobrazí po nakonfigurování relace kódování pro použití typu zdrojového skriptu. Chcete-li do relace přidat skripty, použijte kartu Zdroje na panelu Vlastnosti.

Příbuzná témata

  • Vkládání příkazů skriptu


Panel Zdroje

Tento panel se zobrazí po nakonfigurování relace kódování, která obsahuje více zdrojů. Během kódování je možné mezi jednotlivými zdroji přepínat.


Karta VBR podle přenosové rychlosti

Následující nastavení jsou použitelné pro profil, který používá kódování VBR podle přenosové rychlosti.

  • Formát zvuku. Klepnutím na tuto položku lze nastavit zvukový obsah. Nastavení určuje cílovou přenosovou rychlost zvuku, frekvenci vzorkování a také, zda je zvuk určen pro přehrávání v monofonních nebo stereofonních reproduktorech. Při nastavení vyšší vzorkovací frekvence dosáhnete kvalitnějšího zvuku, ale zvětší se velikost souboru.
  • Velikost videa. Zadejte požadovanou velikost (v pixelech) kódovaného videa. Použijte hodnoty od 16 do 2000. Velikost snímku kódovaného videa bude přizpůsobena požadovanému nastavení. Zaškrtnutím políčka Stejné jako vstup videa se velikost kódovaného videa přizpůsobí velikosti snímku zdrojového videa.
  • Frekvence snímků. Zadejte počet snímků datového proudu videa za sekundu. Počet, který v tomto nastavení zadáte, závisí na rychlosti procesoru počítače a na tom, zda kódujete rychlé nebo pomalé video. Zobrazení rychlého video je při vyšší frekvenci snímků obvykle plynulejší, ale zároveň se zvyšuje zatížení procesoru. Uvedené nastavení představuje maximální počet snímků za sekundu, zatímco skutečný počet snímků za sekundu bude pravděpodobně nižší.
  • Interval klíčových snímků. Zadejte čas (v sekundách), kterým chcete oddělit klíčové snímky. Všechny snímky mezi klíčovými snímky jsou rozdílové snímky, které jsou značně menší, než klíčové snímky, ale jejich obrazová kvalita není dostatečná. Pokud prodloužíte čas mezi klíčovými snímky, zmenší se velikost videa (v bajtech), protože se použije méně klíčových snímků. Zkrátíte-li čas mezi klíčovými snímky, velikost videa se zvýší. Prodloužení intervalu klíčových snímků je vhodné pro obsah s nehybným pozadím, např. kreslené filmy. Zkrácení intervalu klíčových snímků je vhodné pro rychlý obsah, např. sportovní záznam.
  • Přenosová rychlost videa (průměr). Zadejte průměrnou přenosovou rychlost (v bitech za sekundu), kterou chcete použít pro obrazovou část videa. Použijte označení k pro kilobity, M pro megabity nebo G pro gigabity. Okamžitá přenosová rychlost může průměrnou přenosovou rychlost kdykoli překročit, ale celková přenosová rychlost nemůže být vyšší než průměrná přenosová rychlost.
  • Složitost dekodéru. Kódujete-li pro jiné hardwarové zařízení než počítač, můžete určit kategorii složitosti kódovaného obsahu. Některá hardwarová zařízení podporují pouze některé kategorie. (Další informace najdete v dokumentaci k zařízení.) Možnost Složitý je určena pro přehrávání v počítači. Obvykle je nutné použít nastavení Automaticky, které umožňuje automaticky opravit nastavení složitosti během kódování.
  • Přenosová rychlost skriptu. Zadejte požadovanou přenosovou rychlost skriptů (v bitech za sekundu). Hodnota se musí nacházet mezi 1000 a 10 000 b/s. Použijte označení k pro kilobity.


Adresa URL k umístění souborů

Soubory musí být přístupné pro přehrávače. Jednou z možností je umístění na webu pro přístup prostřednictvím protokolu HTTP. Další možností je sdílená složka, kdy je třeba určit přístup pomocí cesty UNC. Pokud zadáte cestu UNC, musí mít přehrávač k cestě alespoň oprávnění pouze pro čtení.


Panel video

Panel video zobrazuje obsah, který kódujete. V závislosti na typu obsahu můžete zobrazení upravit, aby ukazovalo pouze předem zakódovaný obsah, kódovaný obsah nebo obojí. Není možné zobrazit předem zakódovaný obsah v oblasti Vstup, pokud:

  • Digitalizujete obrazovku.
  • Používáte funkci zrušení prokládání u souborů s příponami AVI nebo MPG.
  • Používáte soubor Windows Media s příponou WMV nebo ASF jako vstup a ten má stejné vlastnosti jako výstup.
  • Požíváte kartu pro digitalizaci videa, která nepodporuje náhled na obrázek předtím, než je zakódován.
  • Zvolili jste dočasné ukládání obsahu na pevný disk a dále nejdříve digitalizovat na pevný disk a potom kódovat. (Obsah se však zobrazí, až ukončíte kódování.)

Není možné zobrazit kódovaný obsah v oblasti Výstup, když:

  • Používáte profil digitalizace obrazovky nebo nekomprimovaný profil.
  • Používáte soubor Windows Media s příponou WMV nebo ASF jako vstup a ten má stejné vlastnosti jako výstup.
  • Používáte dvojfázové kódování a kodér je v první fázi.
  • Vybrali jste ukládat obsah dočasně na pevný disk a nejdříve digitalizovat na pevný disk a potom kódovat. (Obsah se však zobrazí, až ukončíte kódování.)

Poznámka - obrázek Poznámky

  • Video zobrazené v oblasti Výstup může vypadat blockier než když je přehráváno programem Windows Media Player, protože tento program obsahuje deblocking filtry, které nejsou k dispozici v oblasti Výstup. The blockiness je normální a neovlivňuje kvalitu zakódovaného obsahu.
  • Pokud kódujete video pro více přenosových rychlostí, můžete zkontrolovat jeho kvalitu pro každou přenosovou rychlost zvolením rychlosti z pole Náhled.


Výsledky kódování

Toto dialogové okno zobrazuje informace o relaci, která byla právě zakódována, včetně typu kódování (vysílat nebo kódovat do souboru), zvolených zařízení a očekávaných a průměrných přenosových rychlostí dosažených během relace kódování. Výsledky poskytují okamžitou zpětnou kontrolu chodu relace, což je užitečné pro potřeby testování. Můžete se například rozhodnout snížit přenosovou rychlost po zobrazení průměrné přenosové rychlosti pro relaci kódovaní. Je možné změnit konfiguraci relace, znovu zakódovat obsah a potom zobrazit souhrnné výsledky, abyste zjistili, zda bylo dosaženo požadované přenosové rychlosti.

© 2000-2002 Microsoft Corporation.Všechna práva vyhrazena.


Chybový protokol

Seznam zobrazuje chybové zprávy přijaté během relace kódování současně s datem a časem, kdy se vyskytly. Ručně lze vymazat protokol klepnutím na tlačítko Vymazat. Chybový protokol je vymazán při každém restartování kodéru a je k dispozici pouze z uživatelského rozhraní kodéru.


Používání Průvodce oznámením vysílání Multicast

Pokud doručujete obsah jako proud vysílání multicast prostřednictvím serveru se spuštěnou službou Windows Media Services, vytvořte oznámení (ASX) a soubor informací o vysílání multicast (.nsc). Abyste mohli vytvořit soubory na kódujícím počítači, musíte mít povolení k přístupu ke službě Windows Media Services prostřednictvím objektu DCOM. Pokud nemáte povolení k přístupu k této službě, vytvořte soubory na serveru.

Pokud doručujete obsah jako proud vysílání unicast prostřednictvím serveru Windows Media, není třeba vytvářet oznámení.