Program Windows Media Encoding Script

Program Microsoft® Windows Media® Encoding Script je nástroj pro příkazový řádek, který lze použít k převádění jak živého, tak předem natočeného zvuku a videa na soubory Windows Media nebo datové proudy Windows Media. Program Windows Media Encoding Script umožňuje:

  • Převádět soubory s příponami WMA, WMV, ASF, AVI, WAV, MPG, MP3, BMP a JPG.
  • Digitalizovat živou událost ze zařízení.
  • Vysílat kódované soubory nebo živou událost.
  • Upravit relaci kódování včetně zadání profilu, kódování určených částí souboru a stříhání a změny velikosti zdrojového videa.

Tato dokumentace vysvětluje, jak používat program Windows Media Encoding Script. Je uspořádána následujícím způsobem:

  • Kódování souborů a živých událostí. Vysvětluje, jak provádět základní kódovací úkoly za použití některých obvyklých možností příkazového řádku.
  • Použití profilů. Vysvětluje, jak používat profily a obsahuje seznam všech profilů, které jsou k dispozici v programu Windows Media Encoding Script.
  • Vylepšené postupy kódování. Popisuje některé dostupné kódovací filtry, které mohou zlepšit kvalitu videa. Tato část také obsahuje seznam všech možností příkazového řádku, které jsou k dispozici v programu Windows Media Encoding Script.
  • Časté otázky. Obsahuje odpovědi na obvyklé otázky týkající se programu Windows Media Encoding Script.
  • Glosář. Definuje termíny týkající se programu Windows Media Encoding Script.
© 2000-2002 Microsoft Corporation. Všechna práva vyhrazena.


Kódování souborů a živých událostí

Program Windows Media Encoding Script umožňuje komprimovat soubory s příponami WMA, WMV, ASF, AVI, WAV, MPG, MP3, BMP a JPG do formátu Windows Media. Převádět lze jeden soubor, všechny soubory ve složce či podsložkách nebo také zadané soubory (s využitím dávkového souboru). Program Windows Media Encoding Script lze použít i k digitalizaci živé události ze zařízení, přičemž můžete volit mezi výstupem do souboru a vysíláním obsahu.

Program Windows Media Encoding Script je nainstalován ve stejné složce jako program Windows Media Encoder. Složka je jako výchozí umístěna v adresáři Program Files\Windows Media Components\Encoder.

Používáním základní syntaxe příkazového řádku lze řešit nejrůznější zadání - viz následující příklady:

Získávání zdrojových dat ze souboru a kódování do souboru:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy_kódované\Myfile.wmv

Můžete rovněž zadat cestu UNC.

Postup při kódování všech souborů ve složce:

cscript.exe wmcmd.vbs –input C:\My-clips –output C:\Klipy_kódované

Získávání zdrojových dat ze zařízení a kódování do souboru:

cscript.exe wmcmd.vbs –adevice 1 -vdevice 2 –output C:\Klipy_kódované\Myfile.wmv -duration 620

Vysílání události živě:

cscript.exe wmcmd.vbs –adevice 1 -vdevice 2 –broadcast 8080 -duration 480

Na konec příkazu lze připojit další parametry příkazového řádku. Je například možné zadat kódování CBR nebo VBR, použít filtr zrušení prokládání pro zdroj nahrávání videa, zadat profil, který se má použít atd. Parametry příkazového řádku lze přidávat v jakémkoliv pořadí.

Příbuzná témata

  • Program Windows Media Encoding Script
  • Použití parametrů příkazového řádku
  • Otevření okna příkazového řádku
  • Postup při kódování souboru
  • Postup při kódování všech souborů ve složce
  • Postup při digitalizaci živé události
  • Dávkové kódování


Postup při otevírání okna příkazového řádku

Windows Media Encoder - titulní obrázek

Otevření okna příkazového řádku

  1. Klepněte na tlačítko Start.
  2. Přejděte na příkaz Programy.
  3. Přejděte na položku Příslušenství a potom klepněte na položku Příkazový řádek.

Příbuzná témata

  • Kódování souborů a živých událostí


Postup při kódování souboru

  1. Otevřete okno příkazového řádku.
  2. Do příkazového řádku zadejte cestu k souboru Wmcmd.vbs. Například:
    cd \Program Files\Windows Media Components\Encoder
  3. Zadejte následující příkaz a potom stiskněte klávesu ENTER:
    cscript.exe wmcmd.vbs –input jednotka:\cesta\název_vstupního_souboru -output jednotka:\cesta\název_výstupního_souboru

    - nebo -

    cscript.exe wmcmd.vbs –input jednotka:\cesta\název_vstupního_souboru -broadcast číslo_portu

    Například:

    cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy_kódované\Myfile.wmv

    - nebo -

    cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi -broadcast 9090

Poznámka - obrázek Poznámka

  • Jestliže neurčíte příponu názvu výstupního souboru, bude přípona připojena k názvu souboru automaticky.
  • Názvy souborů je nutné uzavřít do uvozovek. Například "moje ukázka.avi".

Příbuzná témata

  • Kódování souborů a živých událostí
  • Postup při kódování všech souborů ve složce
  • Postup při digitalizaci živé události


Postup při kódování všech souborů ve složce

  1. Otevřete okno příkazového řádku.
  2. Do příkazového řádku zadejte cestu k souboru Wmcmd.vbs. Například:
    cd \Program Files\Windows Media Components\Encoder
  3. Zadejte následující příkaz a potom stiskněte klávesu ENTER:
    cscript.exe wmcmd.vbs –input jednotka:\vstupní_složka -output jednotka:\výstupní_složka

    Například:

    cscript.exe wmcmd.vbs –input C:\Skladby –output C:\Skladby_kódované

Poznámka - obrázek Poznámka

  • Jestliže výstupní složka neexistuje, bude vytvořena.
  • Názvy souborů je nutné uzavřít do uvozovek. Například "složka".

Příbuzná témata

  • Kódování souborů a živých událostí
  • Postup při kódování souboru
  • Postup při digitalizaci živé události


Postup při digitalizaci živé události

  1. Otevřete okno příkazového řádku.
  2. Do příkazového řádku zadejte cestu k souboru Wmcmd.vbs. Například:
    cd \Program Files\Windows Media Components\Encoder
  3. Zadejte následující příkaz a potom stiskněte klávesu ENTER:
    cscript.exe wmcmd.vbs -adevice číslo_zařízení_digitalizace_zvuku -vdevice číslo_zařízení_digitalizace_videa -output jednotka:\cesta\název_výstupního_souboru -duration čas

    - nebo -

    cscript.exe wmcmd.vbs -adevice číslo_zařízení_digitalizace_zvuku -vdevice číslo_zařízení_digitalizace_videa -broadcast číslo_portu -duration čas

    Například:

    cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –output C:\My-clips\Myfile.wmv -duration 620

    - nebo -

    cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 8080 -duration 620

Poznámka - obrázek Poznámka

  • Pomocí parametru -devices lze zjistit čísla zařízení pro digitalizaci zvuku a videa v kódovacím počítači.

Příbuzná témata

  • Kódování souborů a živých událostí
  • Postup při kódování souboru
  • Postup při kódování všech souborů ve složce


Dávkové kódování

Dávkové kódování umožňuje rychle kódovat velké množství souborů bez nutnosti zadávat kódovací příkaz pro každý soubor zvlášť. V případě dávkového kódování vytvoříte dávkový soubor nebo textový soubor s příponou BAT, který bude obsahovat všechny požadované kódovací příkazy. Tyto příkazy mohou obsahovat názvy vstupních a výstupních souborů, požadované profily a další parametry příkazového řádku, které se mají během kódování použít. Počet příkazů, které může obsahovat dávkový soubor, není omezen a protože se jedná o prostý textový soubor, snadno se upravuje.

Máte-li připraven dávkový soubor ke spuštění, přejděte do složky, ve které je instalován program Windows Media Encoding Script, a zadejte název dávkového souboru. Například Dávkový_soubor.bat.

Následující příklad obsahuje obvyklé příkazy dávkového souboru. Zdrojem v následující ukázce je film o rozlišení 640 × 480 a frekvenci 24 snímků za sekundu, který byl převeden přepisem Telecine na frekvenci 30 snímků za sekundu. Pomocí uvedených příkazů bude tento film před kódováním převeden na frekvenci 24 snímků za sekundu s použitím inverzního filtru Telecine. První dva příkazy zajistí, aby se ke kódování zdroje použil režim kódování variabilní přenosovou rychlostí (-v_mode 2) podle kvality s nastavením kvality 95 a 97. Poslední dva příkazy určí, že se ke kódování zdroje použije režim dvojfázového kódování konstantní přenosovou rychlostí (-v_mode 1) 1 megabitu za sekundu (Mb/s) a 500 kilobitů za sekundu (kb/s).

cscript.exe wmcmd.vbs -input C:\Klipy\Mymovie.avi -output C:\Klipy_kódované\Mymovie-640x480-vbr095.wmv -v_mode 2 -v_quality 95 -v_keydist 30 -v_preproc 5
cscript.exe wmcmd.vbs -input C:\Klipy\Mymovie.avi -output C:\Klipy_kódované\Mymovie-320x240-vbr097.wmv -v_mode 2 -v_quality 97 -v_keydist 30 -v_preproc 5 -v_width 320 -v_height 240
cscript.exe wmcmd.vbs -input C:\Klipy\Mymovie.avi -output C:\Klipy_kódované\Mymovie-640x480-cbr2.wmv -v_mode 1 -v_bitrate 1000000 -v_keydist 30 -v_buffer 10000 -v_quality 100 -v_preproc 5
cscript.exe wmcmd.vbs -input C:\Klipy\Mymovie.avi -output C:\Klipy_kódované\Mymovie-320x240-cbr2.wmv -v_mode 1 -v_bitrate 500000 -v_keydist 30 -v_buffer 10000 -v_quality 100 -v_preproc 5 -v_width 320 -v_height 240

  • Kódování souborů a živých událostí


Použití profilů

Profil je soubor parametrů příkazového řádku, které přesně definují typ kódovaného obsahu, rychlost připojení potenciálních posluchačů a požadovanou kvalitu výstupu. Pokud nezadáte vlastní profil pro relaci, použije se výchozí profil, který obsahuje tato nastavení:

  • kodeky Windows Media Audio 9 a Windows Media Video 9,
  • jednofázové kódování CBR,
  • frekvence snímků 30 za sekundu,
  • výška a šířka vstupního zdroje,
  • stereofonní zvuk,
  • vzorkovací frekvence 44 100 Hz,
  • vyrovnávací paměť 5000 milisekund,
  • nastavení plynulosti 75,
  • vzdálenost klíčových snímků 10 sekund,
  • přenosová rychlost zvuku 64 kilobitů za sekundu (kb/s) a přenosová rychlost videa 250 kilobitů za sekundu (kb/s).

Připojením dalších parametrů příkazového řádku lze libovolné nastavení změnit.

Chcete-li vytvořit vlastní profil, zadejte všechna požadovaná nastavení do příkazu. Potom můžete k příkazu připojit parametr -saveprofile, který uloží profil pro další použití. Budete-li chtít tento profil znovu použít nebo kódovat obsah pomocí některého profilu programu Windows Media Encoder, zadejte parametr -loadprofile. Soubory profilů mají příponu PRX.

Program Windows Media Encoding Script obsahuje řadu předdefinovaných profilů, které lze použít v relaci (pomocí parametru -profile).

Příbuzná témata

  • Program Windows Media Encoding Script
  • Postup při zadávání profilu pro relaci
  • Profily zvuku a videa
  • Profily pouze pro zvuk
  • Profily pouze pro video
  • Použití konfiguračních souborů
  • Použití parametrů příkazového řádku


Postup při zadávání profilu pro relaci

  1. Otevřete okno příkazového řádku.
  2. Do příkazového řádku zadejte cestu k souboru Wmcmd.vbs. Například:
    cd \Program Files\Windows Media Components\Encoder
  3. Použijte jeden z těchto postupů:
    • Chcete-li zadat profil, který je součástí programu Windows Media Encoding Script, zadejte následující příkaz a stiskněte klávesu ENTER:
      cscript.exe wmcmd.vbs –input jednotka:\cesta\název_vstupního_souboru -output jednotka:\cesta\název_výstupního_souboru -profile číslo_profilu

      Například:

      cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy_kódované\Myfile.wmv –profile av100
    • Chcete-li zadat profil programu Windows Media Encoder nebo vlastní profil, který jste si vytvořili, zadejte následující příkaz a klepněte na tlačítko ENTER:
      cscript.exe wmcmd.vbs –input jednotka:\cesta\název_vstupního_souboru -output jednotka:\cesta\název_výstupního_souboru -loadprofile jednotka:\cesta\název_souboru_profilu

      Například:

      cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi -output C:\Klipy_kódované\Myfile.wmv -loadprofile C:\Profily\500kbps_peakVBR.prx

  • Použití profilů


Profily zvuku a videa

Program Windows Media Encoding Script obsahuje 14 systémových profilů pro kódování obsahu obsahujícího zvuk i video. Následující tabulka obsahuje stručný popis každého profilu.

Název profilu | Přenosová rychlost (Kb/s) | Popis
av20 | 20 | Modem 28 kb/s
av32 | 32 | Modem 56 kb/s
av100 | 100 | Místní síť (LAN)
av225 | 225 | Síť LAN
av350 | 350 | Síť LAN a digitální linka (DSL)
av450 | 450 | Síť LAN a DSL
av700 | 700 | Systém NTSC (National Television Standards Committee) v kvalitě na úrovni vysílání
av1400 | 1 400 | NTSC v kvalitě na úrovni vysílání
av350pal | 350 | Širokopásmový systém PAL (Phase Alternating Line)
av700pal | 700 | PAL v kvalitě na úrovni vysílání
av100_2p | 100 | Síť LAN a dvojfázový režim CBR (konstantní přenosová rychlost)
av350_2p | 350 | Síť LAN, připojení DSL a dvojfázový režim CBR
av600vbr | 600 | Film, režim CBR (zvuk) a rychlý režim VBR (variabilní přenosová rychlost) (video)
avq97vbr | -- | Film, režim CBR (zvuk) a na kvalitu zaměřený režim VBR (video)

  • Použití profilů


av20

  • Název: av20 (Profile_AudioVideo_Modem_28K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 5000 b/s
  • Vzorkovací frekvence: 8000 Hz
  • Počet kanálů: 1
  • Kodek videa: Windows Media Video 9
  • Režim kódování: jednofázový CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 15 000 b/s
  • Šířka snímku: 160 pixelů
  • Výška snímku: 120 pixelů
  • Frekvence snímků: 15 snímků/s
  • Vyrovnávací paměť: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 20 000 b/s

  • Profily zvuku a videa


av32

  • Název: av32 (Profile_AudioVideo_Modem_56K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 10 168 b/s
  • Vzorkovací frekvence: 11 025 Hz
  • Počet kanálů: 1
  • Kodek videa: Windows Media Video 9
  • Režim kódování: jednofázový CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 22 000 b/s
  • Šířka snímku: 176 pixelů
  • Výška snímku: 144 pixelů
  • Frekvence snímků: 15 snímků/s
  • Vyrovnávací paměť: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 32 168 b/s

  • Profily zvuku a videa


av100

  • Název: av100 (Profile_AudioVideo_LAN_100K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 16 000 b/s
  • Vzorkovací frekvence: 16 000 Hz
  • Počet kanálů: 1
  • Kodek videa: Windows Media Video 9
  • Režim kódování: jednofázový CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 84 000 b/s
  • Šířka snímku: 320 pixelů
  • Výška snímku: 240 pixelů
  • Frekvence snímků: 15 snímků/s
  • Vyrovnávací paměť: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 100 000 b/s

  • Profily zvuku a videa


av225

  • Název: av225 (Profile_AudioVideo_LAN_256K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 40 000 b/s
  • Vzorkovací frekvence: 32 000 Hz
  • Počet kanálů: 2
  • Kodek videa: Windows Media Video 9
  • Režim kódování: jednofázový CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 185 000 b/s
  • Šířka snímku: 320 pixelů
  • Výška snímku: 240 pixelů
  • Frekvence snímků: 30 snímků/s
  • Vyrovnávací paměť: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 225 000 b/s

  • Profily zvuku a videa


av350

  • Název: av350 (Profile_AudioVideo_LANDSL_384K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 48 000 b/s
  • Vzorkovací frekvence: 32 000 Hz
  • Počet kanálů: 2
  • Kodek videa: Windows Media Video 9
  • Režim kódování: jednofázový CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 302 000 b/s
  • Šířka snímku: 320 pixelů
  • Výška snímku: 240 pixelů
  • Frekvence snímků: 30 snímků/s
  • Vyrovnávací paměť: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 350 000 b/s

  • Profily zvuku a videa


av450

  • Název: av450 (Profile_AudioVideo_LANDSL_768K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 64 040 b/s
  • Vzorkovací frekvence: 44 100 Hz
  • Počet kanálů: 2
  • Kodek videa: Windows Media Video 9
  • Režim kódování: jednofázový CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 386 000 b/s
  • Šířka snímku: 320 pixelů
  • Výška snímku: 240 pixelů
  • Frekvence snímků: 30 snímků/s
  • Vyrovnávací paměť: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 450 040 b/s

  • Profily zvuku a videa


av700

  • Název: av700 (Profile_AudioVideo_NearBroadCast_700K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 64 040 b/s
  • Vzorkovací frekvence: 44 100 Hz
  • Počet kanálů: 2
  • Kodek videa: Windows Media Video 9
  • Režim kódování: jednofázový CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 636 000 b/s
  • Šířka snímku: 320 pixelů
  • Výška snímku: 240 pixelů
  • Frekvence snímků: 30 snímků/s
  • Vyrovnávací paměť: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 700 040 b/s

  • Profily zvuku a videa


av1400

  • Název: av1400 (Profile_AudioVideo_NearBroadCast_1400K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 128 040 b/s
  • Vzorkovací frekvence: 44 100 Hz
  • Počet kanálů: 2
  • Kodek videa: Windows Media Video 9
  • Režim kódování: jednofázový CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 1 272 000 b/s
  • Šířka snímku: 320 pixelů
  • Výška snímku: 240 pixelů
  • Frekvence snímků: 30 snímků/s
  • Vyrovnávací paměť: 5000
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 1 400 040 b/s

  • Profily zvuku a videa


av350pal

  • Název: av350pal (Profile_AudioVideo_Broadband_PAL_384K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 48 000 b/s
  • Vzorkovací frekvence: 32 000 Hz
  • Počet kanálů: 2
  • Kodek videa: Windows Media Video 9
  • Režim kódování: jednofázový CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 302 000 b/s
  • Šířka snímku: 384 pixelů
  • Výška snímku: 288 pixelů
  • Frekvence snímků: 25 snímků/s
  • Vyrovnávací paměť: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 350 000 b/s

  • Profily zvuku a videa


av700pal

  • Název: av700pal (Profile_AudioVideo_NearBroadCast_PAL_700K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 64 040 b/s
  • Vzorkovací frekvence: 44 100 Hz
  • Počet kanálů: 2
  • Kodek videa: Windows Media Video 9
  • Režim kódování: jednofázový CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 636 000 b/s
  • Šířka snímku: 384 pixelů
  • Výška snímku: 288 pixelů
  • Frekvence snímků: 25 snímků/s
  • Vyrovnávací paměť: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 700 040 b/s

  • Profily zvuku a videa


av100_2p

  • Název: av100_2p (Profile_AudioVideo_LAN_100K_2Pass)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 16 000 b/s
  • Vzorkovací frekvence: 16 000 Hz
  • Počet kanálů: 1
  • Kodek videa: Windows Media Video 9
  • Režim kódování: dvojfázový CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 84 000 b/s
  • Šířka snímku: 320 pixelů
  • Výška snímku: 240 pixelů
  • Frekvence snímků: 15 snímků/s
  • Vyrovnávací paměť: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 100 000 b/s

  • Profily zvuku a videa


av350_2p

  • Název: av350_2p (Profile_AudioVideo_LANDSL_384K_2Pass)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 48 000 b/s
  • Vzorkovací frekvence: 32 000 Hz
  • Počet kanálů: 2
  • Kodek videa: Windows Media Video 9
  • Režim kódování: dvojfázový CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 302 000 b/s
  • Šířka snímku: 320 pixelů
  • Výška snímku: 240 pixelů
  • Frekvence snímků: 30 snímků/s
  • Vyrovnávací paměť: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 350 000 b/s

  • Profily zvuku a videa


av600vbr

  • Název: av600vbr (Profile_AudioVideo_FilmVBR_600K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 64 040 b/s
  • Vzorkovací frekvence: 44 100 Hz
  • Počet kanálů: 2
  • Kodek videa: Windows Media Video 9
  • Režim kódování: VBR podle maximální přenosové rychlosti (video) a CBR (zvuk)
  • Optimalizace videa: Inverzní přepis Telecine
  • Přenosová rychlost videa: 536 000 b/s
  • Maximální přenosová rychlost videa: 804 000 b/s
  • Šířka snímku: 320 pixelů
  • Výška snímku: 240 pixelů
  • Frekvence snímků: 24 snímků/s
  • Max. vyrovnávací paměť: 5000 ms
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 600 040 b/s

  • Profily zvuku a videa


avq97vbr

  • Název: avq97vbr (Profile_AudioVideo_FilmVBR_Quality97)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 64 040 b/s
  • Vzorkovací frekvence: 44 100 Hz
  • Počet kanálů: 2
  • Kodek videa: Windows Media Video 9
  • Režim kódování: VBR zaměřený na kvalitu (video) a CBR (zvuk)
  • Optimalizace videa: Inverzní přepis Telecine
  • Šířka snímku: 320 pixelů
  • Výška snímku: 240 pixelů
  • Frekvence snímků: 24 snímků/s
  • Kvalita: 97
  • Vzdálenost klíčových snímků: 10 s

  • Profily zvuku a videa


Profily pouze pro zvuk

Program Windows Media Encoding Script obsahuje sedm systémových profilů pro kódování obsahu obsahujícího zvuk, ale ne video. Následující tabulka obsahuje stručný popis každého profilu.

Název profilu | Přenosová rychlost (Kb/s) | Popis
a20_1 | 20 | Rádio FM mono
a20_2 | 20 | Rádio FM stereo
a32 | 32 | Modem 56 kb/s
a48 | 48 | Kvalita blížící se CD
a64 | 64 | Kvalita na úrovni CD
a96 | 96 | Kvalita špičkového CD
a128 | 128 | Kvalita špičkového CD

  • Použití profilů


a20_1

  • Název: a20_1 (Profile_AudioOnly_FMRadioMono_28K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 20 008 b/s
  • Vzorkovací frekvence: 22 050 Hz
  • Počet kanálů: 1
  • Celková přenosová rychlost: 20 008 b/s

  • Profily pouze pro zvuk


a20_2

  • Název: a20_2 (Profile_AudioOnly_FMRadioStereo_28K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 20 008 b/s
  • Vzorkovací frekvence: 22 050 Hz
  • Počet kanálů: 2
  • Celková přenosová rychlost: 20 008 b/s

  • Profily pouze pro zvuk


a32

  • Název: a32 (Profile_AudioOnly_Modem_56K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 32 000 b/s
  • Vzorkovací frekvence: 32 000 Hz
  • Počet kanálů: 2
  • Celková přenosová rychlost: 32 000 b/s

  • Profily pouze pro zvuk


a48

  • Název: a48 (Profile_AudioOnly_NearCDQuality_48K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 48 024 b/s
  • Vzorkovací frekvence: 32 000 Hz
  • Počet kanálů: 2
  • Celková přenosová rychlost: 48 024 b/s

  • Profily pouze pro zvuk


a64

  • Název: a64 (Profile_AudioOnly_CDQuality_64K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 64 016 b/s
  • Vzorkovací frekvence: 44 100 Hz
  • Počet kanálů: 2
  • Celková přenosová rychlost: 64 016 b/s

  • Profily pouze pro zvuk


a96

  • Název: a96 (Profile_AudioOnly_CDAudiophileQuality_96K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 96 024 b/s
  • Vzorkovací frekvence: 44 100 Hz
  • Počet kanálů: 2
  • Celková přenosová rychlost: 96 024 b/s

  • Profily pouze pro zvuk


a128

  • Název: a128 (Profile_AudioOnly_CDAudiophileQuality_128K)
  • Kodek zvuku: Windows Media Audio 9
  • Přenosová rychlost zvuku: 128 016 b/s
  • Vzorkovací frekvence: 44 100 Hz
  • Počet kanálů: 2
  • Celková přenosová rychlost: 128 016 b/s

  • Profily pouze pro zvuk


Profily pouze pro video

Program Windows Media Encoding Script zahrnuje dva systémové profily pro kódování obsahu, který obsahuje video, avšak nikoliv zvuk. Následující tabulka obsahuje stručný popis každého profilu.

Název profilu | Přenosová rychlost (kb/s) | Popis
v20 | 20 | Pouze pro video, modem s rychlostí 28 kb/s
v32 | 32 | Pouze pro video, modem s rychlostí 56 kb/s

  • Použití profilů


v20

  • Název: v20 (Profile_VideoOnly_Modem_28K)
  • Obrazový kodek: Windows Media Video 9
  • Režim kódování: jednofázové kódování CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 20 000 b/s
  • Šířka snímku: 176 pixelů
  • Výška snímku: 144 pixelů
  • Frekvence snímků: 15 snímků/s
  • Kapacita vyrovnávací paměti: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 20 000 b/s

  • Profily pouze pro video


v32

  • Název: v32 (Profile_VideoOnly_Modem_56K)
  • Obrazový kodek: Windows Media Video 9
  • Režim kódování: jednofázové kódování CBR
  • Optimalizace videa: žádná
  • Přenosová rychlost videa: 32 000 b/s
  • Šířka snímku: 240 pixelů
  • Výška snímku: 176 pixelů
  • Frekvence snímků: 15 snímků/s
  • Kapacita vyrovnávací paměti: 5000 ms
  • Plynulost/kvalita: 75
  • Vzdálenost klíčových snímků: 10 s
  • Celková přenosová rychlost: 32 000 b/s

  • Profily pouze pro video


Vylepšené postupy kódování

Při použití programu Windows Media Encoding Script máte mnoho možností jemného vyladění nastavení kódování. Tato část popisuje jednotlivé možnosti a způsob jejich použití.

Příbuzná témata

  • Program Windows Media Encoding Script
  • Optimalizace zvuku a videa
  • Použití kódování CBR a VBR
  • Použití vícekanálových zvukových souborů jako zdroje
  • Použití konfiguračních souborů
  • Použití parametrů příkazového řádku


Optimalizace zvuku a videa

Program Windows Media Encoding Script obsahuje filtry, které umožňují zlepšit obsahu s přepisem Telecine a prokládaného obsahu pro přehrání buď na displejích s progresivním skenováním, nebo k zachování prokládání v obsahu tak, aby jej bylo možno přehrávat na zařízeních s prokládaným přehráváním. Ve výchozím nastavení nejsou použity žádné filtry (-v_preproc 0). V případě obsahu, který je již ve formátu progresivního skenování a bude zobrazen na displeji s progresivním skenováním, byste neměli použít žádný filtr.

Pokud zvukový obsah představuje především hlas kombinovaný s hudbou, můžete použít parametry -a_content a -a_contentedl tak, aby byl obsah optimalizován pro hlas.

Příbuzná témata

  • Vylepšené postupy kódování
  • Filtry zrušení prokládání
  • Inverzní přepis Telecine
  • Filtry prokládání
  • Optimalizace zvuku pro hlas


Filtry zrušení prokládání

Filtr zrušení prokládání převádí prokládané video do formátu progresivního snímání. V následující tabulce jsou uvedeny příkazy, které jsou k dispozici pří použití filtru zrušení prokládání videa.

Příkaz | Popis
-v_preproc 1 | Slouží k zachování velikosti zdrojového videa. Například video o velikosti 640 × 480 pixelů s frekvencí 30 snímků/s bude kódováno na velikost 640 × 480 pixelů s frekvencí 30 snímků/s.
-v_preproc 2 | Výstupní video bude mít poloviční velikost než původní video. Například video o velikosti 640 × 480 pixelů s frekvencí 30 snímků/s bude kódováno na velikost 320 × 240 pixelů s frekvencí 30 snímků/s.
-v_preproc 3 | Výstupní video bude mít poloviční velikost než původní video a dvojnásobnou frekvenci snímků. Například video o velikosti 640 × 480 pixelů s frekvencí 30 snímků/s bude kódováno na velikost 320 × 240 pixelů s frekvencí 60 snímků/s.
-v_preproc 4 | Výstupní video bude mít poloviční vertikální velikost než původní video a dvojnásobnou frekvenci snímků. Například video o velikosti 320 × 480 pixelů s frekvencí 30 snímků/s bude kódováno na velikost 320 × 240 pixelů s frekvencí 60 snímků/s.

Příbuzná témata

  • Optimalizace zvuku a videa
  • Inverzní filtry Telecine
  • Filtry prokládání
  • Postup při používání filtru na obsah


Inverzní filtry Telecine

Inverzní filtr Telecine převádí video z frekvence 30 snímků/s na 24 snímků/s. V následující tabulce jsou uvedeny příkazy, které jsou k dispozici při použití inverzního filtru Telecine na video.

Příkaz | Popis
-v_preproc 5 | Tento příkaz použijte, pokud je obsah nesouvislý nebo nejste-li si jisti, kterým snímkem obsah začíná.
-v_preproc 6 | Tento příkaz použijte, pokud je první políčko na snímku horní (liché) se vzorem AA Telecine.
-v_preproc 7 | Tento příkaz použijte, pokud je první políčko na snímku horní (liché) se vzorem BB Telecine.
-v_preproc 8 | Tento příkaz použijte, pokud je první políčko na snímku horní (liché) se vzorem BC Telecine.
-v_preproc 9 | Tento příkaz použijte, pokud je první políčko na snímku horní (liché) se vzorem CD Telecine.
-v_preproc 10 | Tento příkaz použijte, pokud je první políčko na snímku horní (liché) se vzorem DD Telecine.
-v_preproc 11 | Tento příkaz použijte, pokud je první políčko na snímku dolní (sudé) se vzorem AA Telecine.
-v_preproc 12 | Tento příkaz použijte, pokud je první políčko na snímku dolní (sudé) se vzorem BB Telecine.
-v_preproc 13 | Tento příkaz použijte, pokud je první políčko na snímku dolní (sudé) se vzorem BC Telecine.
-v_preproc 14 | Tento příkaz použijte, pokud je první políčko na snímku dolní (sudé) se vzorem CD Telecine.
-v_preproc 15 | Tento příkaz použijte, pokud je první políčko na snímku dolní (sudé) se vzorem DD Telecine.

Příbuzná témata

  • Optimalizace zvuku a videa
  • Filtry zrušení prokládání
  • Filtry prokládání
  • Postup při používání filtru na obsah


Filtry prokládání

Filtr prokládání zachovává prokládání zdrojového videa. V následující tabulce jsou uvedeny příkazy, které jsou k dispozici při použití filtru prokládání videa.

Příkaz | Popis
-v_preproc 16 | Zachovává prokládání ve zdrojovém videu.
-v_preproc 17 | Zachovává prokládání ve zdrojovém videu. Tento příkaz použijte, pokud se jako první kóduje horní (liché) políčko.
-v_preproc 18 | Zachovává prokládání ve zdrojovém videu. Tento příkaz použijte, pokud se jako první kóduje dolní (sudé) políčko.

Příbuzná témata

  • Optimalizace zvuku a videa
  • Filtry zrušení prokládání
  • Inverzní filtry Telecine
  • Postup při používání filtru na obsah


Postup při používání filtru na obsah

  1. Otevřete okno příkazového řádku.
  2. Do příkazového řádku zadejte cestu k souboru Wmcmd.vbs. Například zadejte
    cd \Program Files\Windows Media Components\Encoder
  3. Zadejte následující příkaz a potom stiskněte klávesu ENTER:
    cscript.exe wmcmd.vbs –input jednotka:\cesta\název_vstupního_souboru -output jednotka:\cesta\název_výstupního_souboru -v_preproc filtr

    Například:

    cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy_kódované\Myfile.wmv -v_preproc 3

  • Optimalizace zvuku a videa


Optimalizace zvuku pro hlas

Používáte-li jako zdroj zvuk, který je zcela nebo částečně tvořen hlasem, můžete pro optimalizaci kódování použít parametr -a_content a kodek Windows Media Audio 9 Voice. Chování kodeku lze optimalizovat, pokud je obsah tvořen pouze hlasem (-a_content 1) nebo pokud obsahuje také hudbu (-a_content 2). Je-li zvuk tvořen směsicí hlasu a hudby, používá kodek během kódování automaticky příslušný algoritmus pro optimalizaci kódování obsahu (hlasu nebo hudby). Další možností je vytvořit soubor definice optimalizace (-a_contentedl). Jedná se o textový soubor, ve kterém jsou označena místa v souboru, ve kterých začíná a končí hudba. Zbývající neoznačené části souboru jsou považovány za hlas. V následujícím příkladu je obsah tvořen pouze hlasem.

cscript.exe wmcmd.vbs –input C:\Proslovy\Proslov.wav –output C:\Proslovy_kódované\Proslov.wma -a_codec WMSP9 -a_content 1

V následujícím příkladu je obsah tvořen směsicí hlasu a hudby a využívá se souboru obsahujícího definici optimalizace.

cscript.exe wmcmd.vbs –input C:\Proslovy\Proslov.wav –output C:\Proslovy_kódované\Proslov.wma -a_codec WMSP9 -a_content 2 -a_contentedl c:\Proslovy\definice_optimalizace.txt

Příbuzná témata

  • Optimalizace zvuku a videa
  • Postup při vytváření souboru definice optimalizace zvuku


Postup při vytváření souboru definice optimalizace zvuku

  1. Pomocí jednoduchého textového editoru, jako například Poznámkový blok, vytvořte textový soubor.
  2. Zadejte číslo verze a počet hudebních segmentů, které soubor obsahuje.

    Číslo verze musí být vždy 1.

  3. Zadejte čas začátku a konce (v milisekundách) každého segmentu. Jednotlivé časy začátku a konce oddělte pomlčkou.

    Například zadání 1, 3, 0, 10000, 50000, 80000, 150000 a 200000 znamená, že soubor obsahuje tři hudební segmenty. Kodek bude pracovat v režimu hudby v časech 0 až 10 sekund, 50 až 80 sekund a 150 až 200 sekund.

  4. Převeďte textový soubor do kódu Unicode.

    Soubor vytvořený v Poznámkovém bloku můžete uložit v kódování Unicode. V nabídce Soubor zvolte příkaz Uložit jako a potom v okně Kódování klepněte na možnost Unicode.

  • Optimalizace zvuku pro hlas


Používání kódování CBR a VBR

Zvukový obsah a obsah video je možné kódovat konstantní přenosovou rychlostí (CBR) nebo variabilní přenosovou rychlostí (VBR). Chcete-li obsah vysílat jako datový proud, použijte kódování CBR. Chcete-li obsah distribuovat pro stahování a přehrávání místně nebo na zařízení s omezenou rychlostí načítání (např. přehrávače CD nebo DVD), použijte kódování VBR.

  • Kódování CBR. Při použití této možnosti se kolísání přenosové rychlosti během kódování omezuje velikostí vyrovnávací paměti a kolísání kvality obrazu zaručuje, že vyrovnávací paměť nepřetéká ani nepodtéká. Pro kódování CBR je k dispozici jednofázové nebo dvojfázové kódování.
  • Kódování VBR podle kvality Při použití této možnosti se obsah kóduje podle zadané kvality (od 0 do 100). Kolísání přenosové rychlosti během kódování zaručuje, aby bylo dosaženo požadované kvality. Tuto možnost použijte, pokud vám nezáleží na přenosové rychlosti, ale chcete zajistit kvalitu výstupu. Tato možnost používá jednofázové kódování.
  • Kódování VBR podle přenosové rychlosti. Při použití této možnosti se obsah kóduje průměrnou přenosovou rychlostí. Zadaná přenosová rychlost může být v libovolném místě překročena, ale v rámci celkové přenosové rychlosti bude odpovídat průměrné přenosové rychlosti. V tomto režimu se nevynechávají žádné snímky. Tato možnost používá dvojfázové kódování.
  • Kódování VBR podle maximální přenosové rychlosti. Tato možnost je podobná možnosti kódování VBR podle přenosové rychlosti s výjimkou toho, že kolísání přenosové rychlosti nepřesahuje maximální přenosovou rychlost. Tuto použijte pro obsah, který bude přehráván na zařízení s omezenou rychlostí načítání, např. přehrávače CD nebo DVD. Tato možnost používá dvojfázové kódování.

Poznámka - obrázek Poznámka

  • Jestliže při kódování obsahu používáte profil, který neurčuje kódování CBR ani VBR, nebo pokud jste vytvořili vlastní relaci kódování a neurčili jste kódování CBR ani VBR, použije se jako výchozí jednofázové kódování CBR.

Příbuzná témata

  • Vylepšené postupy kódování
  • Použití režimů kódování CBR a VBR


Použití režimů kódování CBR a VBR

Při použití režimů kódování CBR nebo VBR je nutné zadat pouze parametry -v_mode nebo -a_mode. Lze však určit doplňkové parametry každého režimu. Pokud nezadáte vlastní parametry, použijí se výchozí hodnoty.

Následující tabulka obsahuje přehled parametrů příkazového řádku, které lze použít při kódování obsahu videa v režimu CBR nebo VBR.

Režim | Doplňkové parametry
Jednofázové kódování CBR (-v_mode 0) | -v_bitrate a -v_buffer
Dvojfázové kódování CBR (-v_mode 1) | -v_bitrate a -v_buffer
Kódování VBR podle kvality (jednofázové, -v_mode 2) | -v_quality (výchozí nastavení: 95)
Kódování VBR podle přenosové rychlosti (dvojfázové, -v_mode 3) | -v_bitrate
Kódování VBR podle maximální přenosové rychlosti (dvojfázové, -v_mode 4) | -v_bitrate, -v_peakbitrate a -v_peakbuffer

Následující tabulka obsahuje přehled parametrů příkazového řádku, které lze použít při kódování obsahu zvuku v režimu CBR nebo VBR.

Režim | Doplňkové parametry
Jednofázové kódování CBR (-a_mode 0) | -a_setting
Dvojfázové kódování CBR (-a_mode 1) | -a_setting
Kódování VBR podle kvality (jednofázové, -a_mode 2) | -a_setting (další informace viz předchozí odstavec)
Kódování VBR podle přenosové rychlosti (dvojfázové, -a_mode 3) | -a_setting
Kódování VBR podle maximální přenosové rychlosti (dvojfázové, -a_mode 4) | -a_setting, -a_peakbitrate a -a_peakbuffer

V jedné relaci lze současně použít několik kódovacích režimů. Můžete například použít dvojfázové kódování CBR pro zvuk a kódování VBR podle kvality pro video.

Používání kódování VBR podle kvality pro zvuk

Používáte-li kódování VBR podle kvality pro zvuk, můžete pomocí parametru -a_setting zadat cílovou kvalitu použitím formátu Qhodnota_vzorkovací frekvence_kanál. Výchozí nastavení je Q75_44_2. V případě, že rovněž zadáte kodek Windows Media Audio 9 Professional, bude výchozí nastavení Q75_44_2_24. Například:

cscript.exe wmcmd.vbs –input C:\Skladby\Song1.wav –output C:\Skladby_kódované\Song1.wma -a_codec WMA9PRO -a_mode 2 –a_setting Q98_48_2_24

Lze rovněž použít kodek Windows Media Audio 9 Lossless, který vyžaduje kódování VBR podle kvality s nastavením kvality 100. Výchozí nastavení parametru -a_setting je Q100_44_2_16. Následující příklad ukazuje, jak vytvořit příkaz, který určuje bezeztrátovou kompresi při frekvenci vzorkování 48 kHz, se dvěma kanály a 24bitovým kódováním:

cscript.exe wmcmd.vbs –input C:\Skladby\Song1.wav –output C:\Skladby_kódované\Song1.wma -a_codec WMA9LSL -a_mode 2 –a_setting Q100_48_2_24

  • Používání kódování CBR a VBR


Použití vícekanálových zvukových souborů jako zdroje

Program Windows Media Encoding Script umožňuje kódovat vícekanálový zvuk, tzn. že uživatel může kódovat zvuk pro prostorovou reprodukci v šesti nebo osmi kanálech. Zdrojem obsahu musí být buď jeden šestikanálový nebo osmikanálový soubor ve formátu WAVE_FORMAT_EXTENSIBLE, nebo lze jako zdroj použít šest monofonních souborů WAV.

Chcete-li jako zdroj použít jeden soubor, je třeba vytvořit příkaz, který identifikuje tento soubor jako vstup. Také je nutné nastavit kodek Windows Media Audio 9 Professional. Například:

cscript.exe wmcmd.vbs –input C:\Zdrojove_soubory\6_channel.wav -output C:\My_song.wma -a_codec WMA9PRO -a_setting 640_48_6_24

-nebo-

cscript.exe wmcmd.vbs –input C:\Zdrojove_soubory\8_channel.wav -output C:\My_song.wma -a_codec WMA9PRO -a_setting 384_48_8_24

Šestikanálové monofonní soubory WAV není možné použít přímo jako zdroj programu Windows Media Encoding Script. Místo toho je možné pomocí programu Windows Media Encoder nastavit vícekanálovou zvukovou relaci. Potom můžete relaci uložit a vložit odkaz na soubor s relací do příkazu. Například:

cscript.exe wmcmd.vbs –wme C:\Vicekanalova_relace.wme

Při používání vícekanálových zvukových souborů jako zdroje lze do příkazu vložit také parametr -a_folddown6to2. Tento parametr určuje, jak se šest kanálů rozdělí do dvou kanálů pro přehrávání prostřednictvím stereofonních reproduktorů.

Aby si uživatel mohl váš obsah přehrát, musí používat operační systém Microsoft Windows XP a přehrávač, který vychází ze sady Windows Media Format 9 Series Software Development Kit (SDK). V opačném případě bude zvuk automaticky rozdělen do dvou kanálů pro stereofonní reproduktory.

  • Vylepšené postupy kódování


Použití konfiguračních souborů

Pokud jste vytvořili sadu parametrů příkazového řádku a chcete ji znovu použít, můžete ji uložit do tzv. konfiguračního souboru. Jedná se o textový soubor, který obsahuje názvy a hodnoty parametrů příkazového řádku, které chcete v relaci kódování použít. Namísto zadávání parametrů na příkazových řádcích jednotlivě můžete vše umístit do konfiguračního souboru, který lze vyvolat při každém spuštění programu Windows Media Encoding Script.

Údaje v konfiguračním souboru mohou obsahovat název vstupního souboru, zvukové zařízení nebo video, profil nebo jakékoliv další parametry, které chcete zadat. Nastavení v souboru můžete vynechat, a to tak, že do příkazového řádku jednotlivé parametry napíšete.

Konfigurační soubory můžete vytvořit pomocí nástroje pro úpravu textu nebo z příkazového řádku připojením parametru –s_config k příkazu. Při připojování parametru –s_config zadáte název souboru, do kterého se všechny parametry příkazu uloží. Konfigurační soubory mají v názvu příponu WEU. Pokud ji při vytváření konfiguračního souboru nezadáte sami, bude mu přiřazena.

Příbuzná témata

  • Vylepšené postupy kódování
  • Postup při volání konfiguračního souboru


Postup při volání konfiguračního souboru

  1. Otevřete okno příkazového řádku.
  2. Do příkazového řádku zadejte cestu k souboru Wmcmd.vbs. Například zadejte
    cd \Program Files\Windows Media Components\Encoder
  3. Zadejte následující příkaz a potom stiskněte klávesu ENTER:
    cscript.exe wmcmd.vbs –config jednotka:\cesta\název_konfiguračního_souboru

    Například:

    cscript.exe wmcmd.vbs –config C:\Config-files\Myvideos.weu

  • Použití konfiguračních souborů


Použití parametrů příkazového řádku

Tato část obsahuje všechny parametry příkazového řádku, jejichž přidáním k příkazům můžete dosáhnout specifických výsledků kódování. Pokud některý z těchto parametrů přidáte k příkazu a navíc určíte profil, budou mít parametry přednost.

Chcete-li z příkazového řádku otevřít rychlou nápovědu, zadejte cscript.exe wmcmd.vbs a stiskněte klávesu ENTER.

-a_codec index_kodeku

Slouží k určení zvukového kodeku. Pokud uživatel kodek neurčí, použije se kodek Windows Media Audio 9. Parametr -a_codecs použijte k vyhledávání kodeků a jejich indexů (například WMA9STD), které jsou nainstalovány v kódovacím počítači.

-a_codecs

Slouží k zobrazení seznamu zvukových kodeků, jejich indexů a režimů kódování (CBR a VBR), které podporují kodeky a které jsou nainstalovány v kódovacím počítači.

-a_content číslo_režimu

Slouží k určení, zda zvukový obsah převážně hlasový (-a_content 1) nebo smíšený (-a_content 2). Standardně se používá neutrální nastavení -a_content 0. S parametrem -a_content je třeba zadat kodek Windows Media Audio 9 Voice. Další informace viz Optimalizace zvuku pro hlas.

-a_contentedl název_souboru

Pokud se zvuk obsahuje směs hlasu a hudby, umožňuje tento parametr určit místa, kde v obsahu začíná a končí hudba. S parametrem -a_contentedl je třeba zadat kodek Windows Media Audio 9 Voice a parametr -a_content 2. Další informace viz Optimalizace zvuku pro hlas.

-adevice číslo zvukového zařízení

Slouží k určení zvukového zařízení, které se má použít jako zdroj. Například:

cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 8080 –duration 480

Parametr -devices lze použít k vyhledání čísel zařízení pro digitalizaci zvuku a videa v kódovacím počítači. Pro zachytávání ze zařízení je třeba použít parametr -duration.

-a_folddown6to2 prostorový kanál střední kanál kanál pro subwoofer

V případě kódování vícekanálového zvuku určuje způsob automatického dělení šesti kanálů do dvou kanálů pro přehrávání na stereofonních reproduktorech. Používejte pouze celá čísla. Hodnoty, které musí být od 0 do 144 decibelů, se převádějí na záporná čísla. Například:

cscript.exe wmcmd.vbs –input C:\Skladby\Song1.wav –output C:\Skladby_kódované\Song1.wma -a_codec WMA9PRO -a_mode 2 –a_setting 640_48_6_24 -a_folddown6to2 3 3 12

-a_formats

Slouží k zobrazení zvukových formátů (přenosová rychlost, vzorkovací frekvence a kanály) podporovaných jednotlivými kodeky.

-a_mode číslo_režimu

Slouží k určení režimu kódování zvukového obsahu. Lze použít jednofázové nebo dvojfázové kódování CBR (-a_mode 0 nebo -a_mode 1) nebo režim kódování VBR: podle kvality (-a_mode 2), podle přenosové rychlosti (-a_mode 3) nebo podle maximální přenosové rychlosti (-a_mode 4). Další informace viz Používání kódování CBR a VBR.

-a_peakbitrate maximální přenosová rychlost

Slouží k určení maximální přenosové rychlosti (v bitech za sekundu) pro kódování zvukového obsahu v režimu kódování VBR podle maximální přenosové rychlosti. Výchozí nastavení je 1,5 násobek přenosové rychlosti zvuku. Například:

cscript.exe wmcmd.vbs –input C:\Skladby\Mysong.wav –output C:\Skladby_kódované\Mysong.wma -a_mode 4 -a_setting 80_44_2 -a_peakbitrate 300000 -a_peakbuffer 8000

-a_peakbuffer maximální velikost vyrovnávací paměti

Slouží k určení doby (v milisekundách), po kterou se zvukový obsah ukládá do vyrovnávací paměti. Tento parametr se používá při kódování zvukového obsahu v režimu kódování VBR podle maximální přenosové rychlosti. Výchozí nastavení je 3000 milisekund. Například:

cscript.exe wmcmd.vbs –input C:\Skladby\Mysong.wav –output C:\Skladby_kódované\Mysong.wma -a_mode 4 -a_setting 80_44_2 -a_peakbitrate 300000 -a_peakbuffer 8000

-a_setting přenosová rychlost_vzorkovací frekvence_kanál

Slouží k určení nastavení přenosové rychlosti, vzorkovací frekvence a kanálu pro kódování zvukového obsahu. Pokud používáte kodek Windows Media Audio 9 Professional nebo Windows Media Audio 9 Lossless, slouží parametr -a_setting rovněž k nastavení 16- nebo 24-bitového kódování, a to ve tvaru přenosová rychlost_vzorkovací frekvence_kanál_bitů na vzorek. Parametr -a_formats lze použít pro znázornění nastavení, která podporují jednotlivé kodeky. Pokud používáte kodek Windows Media Audio 9 Voice, je výchozí hodnotou 12_16_1. Pokud používáte kodek Windows Media Audio 9 Professional, je výchozí hodnotou 128_44_2_24 (výjimkou je, pokud vkládáte také relaci kódování VBR podle kvality - v tomto případě je výchozí hodnotou Q75_44_2_24.) Pokud používáte kodek Windows Media Audio 9 Lossless, je výchozí hodnotou Q100_44_2_16. Pokud kódujete nekomprimovaný obsah, je výchozí hodnotou 705_22_2. Pro všechny ostatní scénáře je výchozí hodnotou 64_44_2. Například:

cscript.exe wmcmd.vbs –input C:\Skladby\Song1.wav –output C:\Skladby_kódované\Song1.wma –a_setting 32_44_2

Další informace o používání parametru -a_setting při kódování zvukového obsahu v režimu VBR podle kvality viz Použití režimů kódování CBR a VBR.

-audioonly

Používáte-li jako zdroj soubor, který obsahuje zvukový i obrazový obsah, slouží tento parametr pro nastavení kódování pouze zvukové části.

-author řetězec

Slouží k zadání autora obsahu. Tato informace se zobrazí během přehrávání obsahu. Případné mezery v řetězci oddělte uvozovkami. Maximální délka řetězce je 255 znaků. Například:

cscript.exe wmcmd.vbs –input C:\Skladby\Song1.wav –output C:\Skladby_kódované\Song1.wma –author "Jan Novák"

-broadcast číslo_portu

Slouží k zadání portu HTTP, který se použije pro vysílání. Výchozí nastavení je 8080. Pokud používáte jako zdroje zařízení, je třeba také doplnit parametr -duration. Například:

cscript.exe wmcmd.vbs –input C:\Skladby\Song1.wav –broadcast 9090
cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 9090 –duration 620

-config název_souboru

Slouží k zadání souboru konfigurace, který se má použít během relace kódování. Soubory konfigurace mají příponu WEU. Pro vytvoření souboru konfigurace použijte parametr -s_config nebo textový editor. Další informace viz Používání souborů konfigurace. Například:

cscript.exe wmcmd.vbs –config C:\Konfigurační soubory\Myconfig_file.weu

-copyright řetězec

Slouží k zadání informací o autorských právech na obsah. Tyto informace se zobrazí během přehrávání obsahu. Případné mezery v řetězci oddělte uvozovkami. Maximální délka řetězce je 255 znaků. Například:

cscript.exe wmcmd.vbs –input C:\Skladby\Song1.wav –output C:\Skladby_kódované\Song1.wma –copyright "Jan Novák 2001"

-description řetězec

Slouží k zadání popisu obsahu; tato informace se zobrazí během přehrávání obsahu. Případné mezery v řetězci oddělte uvozovkami. Maximální délka řetězce je 255 znaků. Například:

cscript.exe wmcmd.vbs –input C:\Skladby\Song1.wav –output C:\Skladby_kódované\Song1.wma –description "Sbírka oblíbených skladeb"

-devices

Slouží k zobrazení seznamu zvukových a obrazových zařízení (s příslušnými čísly) v kódovacím počítači. Tato čísla zařízení lze použít při digitalizaci živé události. (Další informace viz parametry -adevice a -vdevice.)

-duration čas

Slouží k zadání délky kódování v sekundách. Tuto možnost použijte, jestliže používáte zařízení jako zdroje. Kódování se spouští na začátku vysílání a končí po uplynutí zadaného času. Skutečná délka kódování se bude od zadaného času o několik sekund lišit. Například:

cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 8080 –duration 480

-input název_souboru nebo název_složky

Slouží k zadání názvu souboru nebo složky. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi -output C:\Klipy kódované\Myfile.wmv
cscript.exe wmcmd.vbs –input C:\Klipy -output C:\Klipy kódované

Název soubor nebo složky, která obsahuje mezery, je nutné uzavřít do uvozovek. Například "moje ukázka.avi".

Jestliže do některého příkazu zadáte pouze zdrojový soubor, můžete zobrazit jeho statistiku. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi

-loadprofile název_souboru_profilu

Slouží k zadání názvu souboru programu Windows Media Encoder nebo vlastního profilu, které chcete použít v relaci kódování. Profily mají příponu souboru PRX. (Chcete-li použít některý z předdefinovaných profilů, které jsou součástí programu Windows Media Encoding Script, použijte parametr -profile.) Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi -output C:\Klipy kódované\Myfile.wmv -loadprofile C:\Profily\500kbps_peakVBR.prx

Další informace o vytváření profilů viz Použití profilů.

-output název_souboru nebo složka

Slouží k zadání názvu výstupního souboru nebo složky. Pokud zadaná složka neexistuje, bude vytvořena. Například:

cscript.exe wmcmd.vbs –input C:\Skladby\Song1.wav –output c:\Skladby_kódované\Skladby.wma
cscript.exe wmcmd.vbs –input C:\Skladby –output C:\Skladby_kódované

-outputstring řetězec

Při kódování souborů do složky vloží tento příkaz zadaný text řetězce do názvu všech výstupních souborů. Řetězec bude umístěn před příponu WMA nebo WMV souboru. Například:

cscript.exe wmcmd.vbs –input C:\Skladby –output C:\Skladby_kódované –outputstring coded

-pixelratio x y

Slouží k nastavení poměru stran pixelu kódovaného videa. Tento parametr použijte, pokud zdrojové video obsahuje obdélníkové pixely a zároveň chcete uchovat poměr stran pixelu zdrojového videa. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi -output C:\Klipy kódované\Myfile.wmv -pixelratio 8 9

-pixelformat formát

Slouží k nastavení formátu pixelů kódovaného videa. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi -output C:\Klipy kódované\Myfile.wmv -pixelformat RGB32

Přehled podporovaných formátů pixelů viz Podporované formáty pixelů.

-profile profil_index

Slouží k nastavení předefinovaného profilu pro relaci kódování. (Chcete-li použít vlastní profil, použijte parametr -loadprofile.) Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi -output C:\Klipy kódované\Myfile.wmv -profile av700pal

Přehled profilů viz Použití profilů.

-rating řetězec

Slouží k zadání hodnocení obsahu. Tato informace se zobrazí během přehrávání obsahu. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv –rating PG

-saveprofile název_profilu

Slouží k ukládání ostatních parametrů v příkazu jako profilu pro pozdější použití. Profily mají příponu souboru PRX. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi -output C:\Klipy kódované\Myfile.wmv –v_clip 4 6 2 8 –v_codec WMV8 -v_bitrate 100000 –v_keydist 20 –v_framerate 24 -saveprofile C:\Profily\100kbps.prx

Další informace o vytváření profilů viz Použití profilů.

-silent

Zabraňuje, aby se po dokončení procesu kódování zobrazila statistika kódování.

-s_config název_souboru

Slouží k vytvoření konfiguračního souboru. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv –s_config C:\Konfigurační soubory\Myvideos.weu

Pro vytvoření konfiguračního souboru lze použít také textový editor. Po vytvoření konfiguračního souboru lze parametrem -config soubor vyvolat. Další informace viz Použití konfiguračních souborů.

-time začátek a konec

Slouží k časovému určení (v milisekundách), kdy má kódování v rámci vstupního souboru začít a skončit. (Pokud je zdrojem soubor, použijte parametr -time . Při digitalizaci živé události ze zařízení použijte parametr -duration .) Neznáte-li přesný čas ukončení kódování, zadejte místo časového údaje parametr end. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv –time 10000 20000
cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi -output C:\Klipy kódované\Myfile.wmv –time 10000 end

-title řetězec

Slouží k zadání názvu obsahu. Tato informace se zobrazí během přehrávání obsahu. Případné mezery v řetězci oddělte uvozovkami. Maximální délka řetězce je 255 znaků. Například:

cscript.exe wmcmd.vbs –input C:\Skladby\Song1.wav –output C:\Skladby_kódované\Song1.wma –title "Oblíbené skladby"

-videoonly

Používáte-li jako zdroj soubor, který obsahuje zvukový i obrazový obsah, slouží tento parametr pro nastavení kódování pouze obrazové části.

-v_bitrate přenosová rychlost

Slouží k zadání požadované přenosové rychlosti v bitech za sekundu. Výchozí nastavení je 250 000. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv –v_bitrate 100000

-v_buffer velikost

Slouží k nastavení části videa (v milisekundách), které se ukládá do paměti před přehráním. Výchozí hodnota je 5000 milisekund. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv –v_buffer 1000

-v_clip levá horní pravá dolní

Slouží k nastavení části obrazu, která se má ze zdrojového videa oříznout. Pokud je pro pravou stranu nastavena hodnota 0 nebo hodnota vyšší než šířka, bude nastavení ignorováno a nahrazeno skutečnou šířkou. Pokud je pro dolní stranu nastavena hodnota 0 nebo hodnota vyšší než výška, bude nastavení ignorováno a nahrazeno skutečnou výškou. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv –v_clip 4 6 2 8

-v_codec index_kodeku

Slouží k určení obrazového kodeku. Pokud uživatel kodek neurčí, použije se kodek Windows Media Video 9. Parametr -v_codecs použijte k vyhledávání kodeků a jejich indexů (například WMS9), které jsou nainstalovány v kódovacím počítači.

-v_codecs

Slouží k zobrazení přehledu obrazových kodeků a jejich indexů, které jsou nainstalovány v kódovacím počítači.

-vdevice číslo videozařízení

Slouží k určení videozařízení, které se má použít jako zdroj. Například:

cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 8080 –duration 480

Parametr -devices lze použít k vyhledání čísel zařízení pro digitalizaci zvuku a videa v kódovacím počítači. Pro zachytávání ze zařízení je třeba použít parametr -duration.

-v_framerate přenosová rychlost

Slouží k nastavení frekvence snímků, která se použije při kódování videa. Frekvence může být celé nebo desetinné číslo. Výchozí nastavení je 30 snímků za sekundu. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv –v_framerate 24

-v_height výška

Slouží k nastavení výšky kódovaného snímku v pixelech. Výchozím nastavením je výška zdrojového videa. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv –v_height 480

-v_keydist čas

Slouží k nastavení doby (v sekundách) mezi klíčovými snímky. Výchozí nastavení je 10 sekund.

-v_mode číslo_režimu

Slouží k určení režimu kódování obrazového obsahu. Lze použít jednofázové nebo dvojfázové kódování CBR (-v_mode 0 nebo -v_mode 1) nebo režim kódování VBR: podle kvality (-v_mode 2), podle přenosové rychlosti (-v_mode 3) nebo podle maximální přenosové rychlosti (-v_mode 4). Další informace viz Používání kódování CBR a VBR.

-v_peakbitrate maximální přenosová rychlost

Slouží k určení maximální přenosové rychlosti (v bitech za sekundu) pro kódování obrazového obsahu v režimu kódování VBR podle maximální přenosové rychlosti. Výchozí nastavení je 1,5 násobek přenosové rychlosti videa. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv -v_mode 4 -v_bitrate 100000 -v_peakbitrate 300000 -v_peakbuffer 8000

-v_peakbuffer maximální velikost vyrovnávací paměti

Slouží k určení doby (v milisekundách), po kterou se obrazový obsah bude ukládat do vyrovnávací paměti při kódování videa v režimu kódování VBR podle maximální přenosové rychlosti. Výchozí nastavení je 5000 milisekund. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv -v_mode 4 -v_bitrate 100000 -v_peakbitrate 300000 -v_peakbuffer 8000

-v_performance číslo

Slouží k nastavení hardwarového výkonu kódovacího počítače. Tento parametr slouží pro kódování za použití kodeku Windows Media Video 9. Nezadáte-li žádnou konkrétní hodnotu, použije se výchozí nastavení kodeku. Pro nastavení je možné použít hodnoty 0, 20, 40, 60, 80 a 100, kde hodnota 100 představuje nejvyšší kvalitu. Další informace nastavení výkonu viz nápověda programu Windows Media Encoder.

-v_preproc číslo_filtru

Slouží k nastavení filtru zpracování obsahu. Seznam možných nastavení viz Optimalizace zvuku a videa.

-v_profile index_přizpůsobení_zařízení

Slouží k nastavení kategorie složitosti kódovaného obsahu. Tento parametr použijte, pokud je obsah určen pro přehrávání na jiných hardwarových zařízeních než v počítači. Některá hardwarová zařízení podporují pouze některé kategorie. (Další informace najdete v dokumentaci k zařízení.) Jestliže nechcete přidat do příkazu parametr -v_profile, bude správné nastavení složitosti vybráno během kódování automaticky. K dispozici jsou nastavení SP (jednoduchý), MP (hlavní) nebo CP (složitý). Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv –v_profile SP

Program Windows Media Encoder obsahuje hardwarové profily, které vyhovují různým typům hardwarových zařízení. Další informace o těchto profilech najdete v nápovědě programu Windows Media Encoder.

-v_quality číslo_kvality

Definuje kvalitu obrazu kódovaného videa. Rozsah nastavení kvality obrazu je 0 až 100. V režimech kódování videa CBR (-v_mode 0 nebo –v_mode 1) představuje nastavení 0 nejjemnější vykreslení pohybu a nastavení 100 představuje nejostřejší obraz. Výchozí nastavení je 75. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv –v_mode 0 –v_quality 40

V režimu kódování videa VBR podle kvality (-v_mode 2) toto nastavení představuje kvalitu výsledného obrazu v rámci celé sekvence. Výchozí nastavení je 95. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv –v_mode 2 –v_quality 95

-v_width šířka

Slouží k nastavení šířky kódovaného snímku v pixelech. Výchozím nastavením je šířka zdrojového videa. Například:

cscript.exe wmcmd.vbs –input C:\Klipy\Myfile.avi –output C:\Klipy kódované\Myfile.wmv –v_width 640

-wme název souboru

Slouží k nastavení stávajícího souboru s relací kódování. Například:

cscript.exe wmcmd.vbs –wme C:\Relace\My_session_file.wme

  • Vylepšené postupy kódování


Podporované formáty pixelů

Při použití možnosti –pixelformat je třeba zadat jeden z následujících formátů pixelů.

  • I420
  • IYUV
  • RGB24
  • RGB32
  • RGB555
  • RGB565
  • RGB8
  • UYVY
  • YUY2
  • YV12
  • YVU9
  • YVYU

  • Použití parametrů příkazového řádku


Časté otázky

  1. Lze s programem Windows Media Encoding Script používat rozšířené soubory AVI?

    Ano. Program Windows Media Encoding Script podporuje specifikaci rozšířeného formátu AVI a dokáže kódovat soubory tohoto formátu o velikost nad 2 GB.

  2. Pokud chci dosáhnout různých přenosových rychlostí, mohu kódovat komprimované soubory Windows Media s příponami WMA a WMV?

    Ano. Lepších výsledků ale dosáhnete, pokud zakódujete původní zdrojový soubor znovu a určíte požadovanou přenosovou rychlost pomocí parametru –v_bitrate pro video nebo parametru –a_setting pro zvuk.

  3. Při použití parametru –v_bitrate s jednofázovým a dvojfázovým režimem kódování CBR a režimy kódování VBR podle přenosové rychlosti (-v_mode 0, 1 a 3) je přenosová rychlost komprimovaného klipu oproti nastavení značně nižší. Jedná se o chybu?

    Ne. Pokud se klip nebo část klipu snadno kóduje pro cílovou přenosovou rychlost (například je nastavena příliš vysoká přenosová rychlost a rozlišení je nízké), nevyžaduje kodek pro kompresi obsahu celou dostupnou šířku pásma.

  4. Při použití parametru –v_bitrate pro režim kódování VBR podle přenosové rychlosti (-v_mode 3) je přenosová rychlost komprimovaného klipu oproti nastavení značně vyšší. Jedná se o chybu?

    Ne. Při použití parametru –v_mode 3 ke kódování obsahu nejsou vynechány snímky. Pokud se klip nebo část klipu obtížně kóduje pro cílovou přenosovou rychlost (například je nastavena příliš nízká přenosová rychlost a rozlišení je vysoké), budek kodek pro kompresi obsahu vyžadovat větší šířku pásma.

  5. V jakém pořadí provádí program Windows Media Encoding Script ořezání, zpracování a změnu velikosti obsahu?

    Prvním krokem procesu je ořezání, které se provádí u zdroje. Tento postup zefektivňuje proces kódování, protože se všechny nepotřebné části videa vyloučí ještě před kódováním. Jako druhé v pořadí se provádí zpracování, tzn. například použití filtrů zrušení prokládání nebo inverzního přepisu Telecine. Následuje nastavení velikosti výstupu kódovaného videa.

  6. Lze v programu Windows Media Encoding Script zakódovat soubor pro více přenosových rychlostí (MBR) tak, aby bylo možné vysílat obsah datovým proudem pro uživatele s různými rychlostmi připojení?

    Pro tento způsob kódování je třeba použít některý profil MBR vytvořený v programu Windows Media Encoder.

  7. Pomocí parametru -v_quality jsem nastavil kvalitu obrazu na hodnotu 95 a později na hodnotu 96. Výsledek byl u obou nastavení stejný. Je to normální?

    Ano. Některá nastavení parametru -v_quality jsou vnitřně mapována na stejnou hodnotu kvality obrazu. Chcete-li, aby změna kvality obrazu byla viditelná, musíte zvyšit nebo snížit nastavení parametru -v_quality o větší hodnotu.

  • Program Windows Media Encoding Script


Glosář

Chcete-li vyhledat termín v glosáři, klepněte na písmeno v abecedě, kterým hledaný termín začíná.

Termíny v glosáři lze rovněž zobrazit v rámci textu nápovědy klepnutím na podtržené odkazy glosáře. Po klepnutí na odkaz glosáře se termín a jeho definice zobrazí v místním okně. Chcete-li okno zavřít, klepněte na libovolné místo na ploše.

A | B | C | Č | D | E | F | G | H | CH | I | J
K | L | M | N | O | P | Q | R | Ř | S | Š | T
U | V | W | X | Y | Z | Ž |

A

adresář pro publikování

Uspořádané paměťové umístění, které přeloží požadavek klienta na obsah na fyzickou cestu k obsahu na hostitelském serveru. Základní funkce adresáře pro publikování je přesměrování.

AVI (Audio Video Interleaved)

Formát multimediálního souboru pro ukládání zvuku a pohyblivého obrazu ve formátu RIFF.

AVI

Viz definice : AVI (Audio Video Interleaved)

Na začátek

B

bezeztrátová komprese

Proces komprese dat, při kterém jsou informace uspořádány ve zkrácené podobě. Při dekompresi jsou informace obnoveny do původního tvaru.

Na začátek

C

CBR

Viz definice : konstantní přenosová rychlost (CBR)

Na začátek

Č

časový kód

Digitální signál vložený do datového proudu. Signál přiděluje každému snímku videa číslo, které obsahuje hodiny, minuty, sekundy a snímky.

čekací doba

Zpoždění, ke kterému dochází při zpracovávání nebo předávání dat.

Na začátek

D

datový proud

Spojitý tok digitálního média, který se přenáší v síti.

dvojfázové kódování

Způsob kódování, kdy v jedné fázi provádí kodér analýzu a ve druhé fázi provádí kompresi. Viz též jednofázové kódování.

dynamický rozsah

Rozdíl (v decibelech) mezi nejslabšími a nejsilnějšími zvuku v jednotlivé části zvukového obsahu.

Na začátek

F

formát běžného zobrazení

Formát zobrazení videa, při kterém během přehrávání zobrazují nad a pod obrazem černé pruhy. Formát běžného zobrazení zachovává původní poměr stran obrazu při přehrávání na obrazovce, která má odlišný poměr stran.

formát datového proudu

Informace o vlastnostech datového proudu, např. použité kodeky, frekvence a velikost snímků. Pomocí tohoto formátu přehrávač dekóduje datový proud.

formát pixelů

Velikost a uspořádání barevných složek pixelu. Tento formát je určen celkovým počtem bitů použitých na pixel a počtem bitů použitých pro uložení barevných složek pixelu červené, zelené, modré a alfa.

formát Windows Media

Formát produktů Microsoft Windows Media Technologies (nebo jiných produktů na základě licence technologie Windows Media), který slouží k vytváření, ukládání, úpravám, distribuci, vysílání nebo přehrávání obsahu, který obsahuje data uspořádaná na časové ose.

frekvence snímků

Počet snímků videa zobrazených za sekundu. Při vyšších frekvencích je pohyb na videu obvykle vykreslován plynuleji.

Na začátek

H

hlavička

Část struktury souboru s informací, podle kterých program dekomprimuje a vykresluje obsah. Hlavička v chráněném souboru obsahuje také informace nezbytné pro získání licence.

Na začátek

I

IEEE (Institute of Electrical and Electronics Engineers) 1394

Standard řadiče vysokorychlostní sériové sběrnice, který umožňuje připojit k počítači širokou škálu zařízení, včetně spotřební audiovizuální elektroniky, úložných periferních zařízení, dalších počítačů a přenosných zařízení.

IEEE 1394

Viz definice : IEEE (Institute of Electrical and Electronics Engineers) 1394

inteligentní datový proud

Typ proudu, který rozpozná stav sítě a upraví vlastnosti obrazového a zvukového datového proudu tak, aby bylo dosaženo maximální kvality.

Internet Protocol verze 6 (IPv6)

Aktualizovaná verze protokolu IP (Internet Protocol) umožňující další růst sítě Internet. Mezi zlepšení patří 128bitová velikost adresy IP, rozšířené možnosti směrování a podpora ověřování a ochrany osobních dat.

inverzní přepis Telecine

Proces odstranění snímků, které byly přidány během převodu filmu s frekvencí 24 snímků/s na video s frekvencí 30 snímků/s.

IPv6

Viz definice: Internet Protocol verze 6 (IPv6)

Na začátek

J

jednofázové kódování

Způsob kódování, při kterém se analýza a komprese obsahu provádí kodérem najednou v rámci jedné fáze.

Viz též: dvojfázové kódování

jednosměrový přenos

Způsob, kterým servery s médii předávají obsah připojeným klientům. Každý klient obdrží diskrétní datový proud. K tomuto proudu nemá žádný jiný klient přístup.

Na začátek

K

klíčový snímek

Snímek videa, který obsahuje všechna data potřebná k vytvoření obrazu bez nutnosti předchozích snímků.

Viz též: rozdílový snímek

kodek Windows Media Screen

Kodek používaný pro kompresi a dekompresi sekvencí zobrazení obrazovky.

kodek Windows Media Video

Kodek používaný pro kompresi a dekompresi datových proudů videa.

kodek

Zkratka slov komprimátor/dekomprimátor. Jedná se o software nebo hardware, který se používá ke kompresi a dekompresi digitálních médií.

kódování

Převod zvukového a obrazového obsahu do určeného digitálního formátu.

komprese

Proces, při kterém se ze souboru digitálních médií nebo z datového proudu odstraňují nadbytečná data, aby se zmenšila jeho velikost nebo použitá šířka pásma.

koncová sekvence

Prodloužení kódovaného videa o určený počet snímků.

konfigurační soubor

Textový soubor používaný programem Windows Media Encoding Script. Soubor definuje kódovaný obsah a parametry příkazového řádku, které se mají při kódování použít.

konstantní přenosová rychlost (CBR)

Charakteristika datového proudu, v jehož průběhu zůstává přenosová rychlost takřka neměnná.

Viz též: variabilní přenosová rychlost (VBR)

Na začátek

L

licence

Data připojená ke chráněnému obsahu, která popisují, jak lze obsah používat.

Na začátek

M

MBR

Viz definice: více přenosových rychlostí (MBR)

metadata

Údaje o datech. Příkladem metadat souboru mohou být název, předmět, autor a velikost.

metasoubor Windows Media

Soubor produktů Windows Media Technologies, který obsahuje informace o souborech ve formátu Windows Media a jejich prezentaci. Mezi přípony názvů metasouborů Windows Media patří ASX, WAX, WVX, WMX a NSC.

Na začátek

N

načítání

Předávání dat klientovi pouze na základě jeho požadavku.

NTSC (National Television Standards Committee)

Norma televizního vysílání, která se převážně používá v USA a Japonsku. Při vysílání v normě NTSC se přenáší 30 prokládaných snímků za sekundu s rozlišením 525 řádků.

NTSC

Viz definice: NTSC (National Television Standards Committee)

Na začátek

O

obsah

Zvuk, video, obrázky, text, nebo další informace v souboru digitálních médií nebo v datovém proudu.

opakovat

Opakovaně spouštět datový proud.

oznámení

Metasoubor ve formátu Windows Media, který předává přehrávači informace potřebné pro příjem obsahu. Soubory s oznámením obsahují skripty XML (Extensible Markup Language).

Na začátek

P

PAL (Phase Alternating Line)

Norma televizního vysílání, která se převážně používá v Evropě. Při vysílání v normě PAL se přenáší 25 prokládaných snímků za sekundu při rozlišení 625 řádků.

PAL

Viz definice: PAL (Phase Alternating Line)

PCM

Viz definice: pulsně kódovaná modulace (PCM)

počáteční sekvence

Digitalizace nebo přehrání určitého počtu snímků videa nebo určité části zvukových dat před začátkem kódování nebo zobrazením, aby se mohl stabilizovat stav zdrojového zařízení. Také se používá k označení dat počáteční sekvence.

poměr stran

Poměr šířky a výšky obrazu.

profil

Skupina nastavení, na základě kterých se podle typu obsahu a přenosové rychlosti volí vhodné zvukové kodeky a videokodeky.

Profile Editor (editor profilů)

Nástroj poskytnutý společně s programem Windows Media Encoder, který slouží k vytváření a úpravám profilů kódování.

Viz též: profil

prokládání

Zobrazení videosnímku ve dvou políčcích. Jedno políčko obsahuje sudé řádky, druhé políčko obsahuje liché řádky videa. Během přehrávání se nejprve zobrazí řádky v jednom políčku a potom se zobrazí řádky ve druhém políčku.

PRX

Přípona souboru s profilem.

přenosová rychlost

Počet přenesených bitů za sekundu.

přepis Telecine

Systém převodu filmu na video, při kterém se rozdíly mezi frekvencemi snímků filmu a videa kompenzují přidáním snímků do videa.

příkazy skriptu

Pojmenovaná data, která souvisejí s časovým určením v obsahu formátu Windows Media. Data mohou sloužit přehrávačům k provedení specifické operace, jako např. zobrazení webové stránky.

pulsně kódovaná modulace (PCM)

Postup digitalizace zvuku do nekomprimovaného formátu, při kterém se amplitudě signálu přiřazují hodnoty v určených intervalech.

Na začátek

R

RGB

Barevný model, který charakterizuje barevnou informaci jako podíl intenzity červené (R), zelené (G) a modré (B) složky v barvě.

rozdílový snímek

Snímek videa, který obsahuje pouze změny od minulého snímku. Naproti tomu klíčový snímek obsahuje všechna data nezbytná pro vytvoření snímku.

Na začátek

S

soubor ve formátu datového proudu

Soubor, podle kterého přehrávač dekóduje vícesměrový datový proud.

Viz též: formát datového proudu

soubor ve formátu Windows Media

Soubor ve formátu Windows Media, ve kterém je uložen zvuk, obraz nebo data skriptu. Podle obsahu a účelu se pro soubory ve formátu Windows Media používá řada přípon, např. WMA, WME, WMS, WMV, WMX, WMZ nebo WVX.

Na začátek

Š

šířka pásma

Kapacita sítě pro přenos množství dat v daném čase.

Na začátek

T

titulek

Text, který doplňuje obraz nebo video a obsahuje další informace nebo přepis mluveného slova.

Na začátek

U

UDP (User Datagram Protocol)

Protokol pro bezdrátový přenos v zásobníku protokolu TCP/IP, který se používá v případech, kdy jsou přijatelné ztráty některých paketů, například u datových proudů digitálních médií.

UDP

Viz definice: UDP (User Datagram Protocol)

UNC (Universal Naming Convention)

Celý název síťového prostředku. Odpovídá syntaxi \\název_serveru\sdílená_položka, kde název_serveru je název serveru a sdílená_položka je název sdíleného prostředku. Syntaxe názvů UNC pro adresáře nebo soubory může také obsahovat cestu adresáře pod názvem sdílené položky v následující podobě: \\název_serveru\sdílená_položka\adresář\název_souboru.

UNC

Viz definice: UNC (Universal Naming Convention)

Na začátek

V

variabilní přenosová rychlost (VBR)

Charakteristika datového proudu, při kterém přenosová rychlost kolísá podle složitosti dat.

VBR

Viz též: variabilní přenosová rychlost (VBR)

více přenosových rychlostí (MBR)

Charakteristika datového proudu, ve kterém je stejný obsah kódován v několika odlišných přenosových rychlostech pro optimalizaci předávání.

vícekanálový zvuk

Systém reprodukce zvuku pro zpracování několika, obvykle více než dvou, zvukových kanálů. Například vícekanálový formát zvuku 5.1 představuje systém prostorového zvuku, který obsahuje pět primárních kanálů a kanál basového reproduktoru.

vícesměrový přenos

Způsob předávání obsahu, při kterém je jeden datový proud vysílán ze serveru s médii pro více klientů. Klienti se nepřipojují k serveru. Místo toho server odesílá do sítě jednu kopii datového proudu na směrovače pro vícesměrové vysílání, které vytvářejí kopie dat. Klienti mohou načítat datový proud sledováním určené adresy IP a portu vícesměrového vysílání.

vysílání

Předávání dat klientovi bez jeho požadavku.

vzorkovací frekvence

Frekvence, při které se provádí vzorkování. Čím vyšší je vzorkovací frekvence (tzn. čím se provede více vzorků za jednotku času), tím přesněji se bude digitalizovaný výsledek podobat původní předloze.

vzorkování

Součást převodu analogového signálu do digitálního formátu, při kterém se v pravidelných intervalech měří amplituda analogového signálu.

Na začátek

W

WEU

Přípona konfiguračních souborů, které používá program Windows Media Encoding Script.

WMA

Přípona zvukového souboru ve formátu Windows Media. Zvukový obsah souboru je kódován pomocí kodeku Windows Media Audio.

WME

Přípona souboru relace programu Windows Media Encoder.

WMV

Přípona videosouboru ve formátu Windows Media.

Na začátek

Y

YUV

Barevný model, který charakterizuje barevnou informaci podle jasu (luminance nebo Y) a barevnosti (chrominance nebo U a V).

Na začátek

Z

zdroj

Zvukový a obrazový obsah, který lze digitalizovat a kódovat ze zařízení instalovaných v počítači nebo ze souboru.

značka

Textový řetězec, který souvisí s přiřazeným časem v obsahu ve formátu Windows Media. Značky často označují vhodná místa pro začátek přehrávání, jako např. začátek nové scény.

zrušení prokládání

Kombinace prokládaných políček videosnímku tak, aby se řádky videosnímku během přehrávání vykreslovaly sekvenčně.

Viz též: prokládání

ztrátová komprese

Proces komprese dat, při kterém jsou informace považované za zbytečné odstraněny a nelze je při dekompresi obnovit. Obvykle se používá pro zvuková nebo obrazová data, u kterých je přípustné mírné snížení kvality.

zvukový kodek Windows Media Audio

Kodek používaný pro kompresi a dekompresi zvukových datových proudů.

Na začátek


Práva a ochranné známky

Informace obsažené v této příručce, včetně adres URL a dalších internetových odkazů na webové stránky, mohou podléhat změnám bez předchozího upozornění. Názvy společností, organizací, produktů, jména a údaje použité v ukázkách jsou smyšlené. Nemůže být vyvozováno žádné jejich spojení se skutečnou společností, organizací, produktem, jménem a údajem. Uživatel je povinen dodržovat veškeré platné zákony o autorských právech. Bez omezení práv vyplývajících z autorského zákona, nesmí být tato příručka rozšiřována po částech ani jako celek, převáděna do jakékoli jiné formy ať mechanicky, nebo elektronicky včetně fotokopírování a snímání, a to pro jakékoli účely, bez předchozího výslovného písemného povolení společnosti Microsoft Corporation.

Některé patenty, patentové žádosti, ochranné známky, autorská práva nebo jiná práva na duševní vlastnictví společnosti Microsoft se mohou týkat obsahu tohoto dokumentu. Není-li výslovně stanoveno v písemném licenčním ujednání od společnosti Microsoft, poskytnutím tohoto dokumentu vám společnost neuděluje žádnou licenci na žádný z těchto patentů, patentových přihlášek, ochranných známek, autorských práv nebo práv k duševnímu vlastnictví.

© 2000-2002 Microsoft Corporation. Všechna práva vyhrazena.

Microsoft, MS-DOS, Windows, Windows Media, Windows NT, ActiveSync, ActiveX, Direct3D, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, FrontPage, JScript, Microsoft Press, MSN, NetShow, Outlook, PowerPoint, Visual Basic, Visual C++, Visual InterDev, Visual J++, Visual Studio, WebTV, Win32 a Win32s jsou buď registrované ochranné známky, nebo ochranné známky společnosti Microsoft Corporation ve Spojených státech amerických a v dalších zemích.

Uvedené názvy produktů nebo společností mohou být ochrannými známkami vlastníků těchto známek.