
Contact the author
If you find any bugs, have questions or suggestions:

please email me at: irekz@yahoo.com
And remember when you have problem with subtitle file ->don't forget to send me it...

In urgent situations you can also call me at: ++48 503-741-408

I can provide help in ENGLISH and POLISH languages.
Please remember also about time zones and call between: 8AM - 10PM
Central European Time (GMT + 2)

Irek Zielinski, author





GET INFORMATION ABOUT AVI FILE command
Menu command:
Get AVI file information...

Toolbar button:

Keyboard accelerator:
none

This option allows you to extract basic information about video files.
In order to do that:

· Click the AVI info button or choose File >Get AVI file information...
· OPEN video file.

Dialog is pretty easy to use but if you still have some problems here is a description:

1 - Here you can see name and path of loaded file.

2 - Here you can point video file to examine. Under Win 9x you will have additional preview during directory 
browsing. On Win XP this button still works but looks ugly.

3 - Here you can point video file to examine. Under Win 9x you will NOT have additional preview during directory 



browsing. This is recommended OPEN button for Win XP users.

4 - Here you have different informations extracted from video file. The most important (in most cases) is FPS value.

5 - Here you have info about file type.

6 - This button closes dialog box.





CONVERT command
Menu command:
Convert file...

Toolbar button:

Keyboard accelerator:
none

This option allows you to change format of your subtitle file.
In order to do that:

· OPEN file you want convert.
· Click the Convert button or choose File >Convert File...
· Use dialog box described bellow.

Dialog is pretty easy to use but if you still have some problems here is a description:

1 - Here you have source file name.

2 - Here you have source file format detected by TA.

3 - Here you can select output format you want. Please note that when you convert between formats where one is in
frame-based and second is time-based you will have to enter "Frame / sec:" value.

4 - This value is required only when you convert between time and frame formats. If you don't know this value you 
can do two things:
Use "Load FPS from AVI" button (then load AVI file, and click "OK" - FPS value will be auto-filled).
Ignore it and accept default 25.0 value - but then (in most cases) you will have to synchronize output file !

5 - This button opens AVI info dialog - there you can load video file and extract FPS rate from it. When you close that
dialog by clicking OK - extracted FPS will be auto-filled to edit box no.4 !

6 - Begin operation.

7 - Abandon operation.





EXIT command
Menu command:
Exit

Toolbar button:
none

Other button:

Keyboard accelerator:
Alt + F4

This option allows you to quit from Time Adjuster.





JOIN TWO FILES command
Menu command:
Join 2 files...

Toolbar button:

Keyboard accelerator:
none

This option allows you to join two separate subtitle files with proper time moving.
In order to do that:

· OPEN file you want to be first.
· Click the Join button or choose File >Join 2 files... to open second file.
· If you have two source files opened click on Join button or choose File >Join 2 files... again in order to open 
JOIN dialog.
· Use dialog box described bellow.

Dialog is pretty easy to use but if you still have some problems here is a description:

1 and 2 - Here you can see in different units when the first file ends. If source file is in time-based format - you 
will see exacly this dialog (with TPOS'es and hour,minute,second values).
If your source file is in frame-based format you will see last frame value from first source file.

3 - Here you can enter no. of TPOS'es or FRAMES (all depends on subtitle format) that Time Adjuster will add to 
second file when joinig.

4 - You can enter values described above also in hh:mm:ss format - just click on radio button and select this box.
If your file is in frame-based format you will have to enter FPS value in order to use this feature.

5 - Here you have to enter FPS value - but only if you're working on frame-based format and wants to add TIME 



values to second file.

6 - Begin operation.

7 - Abandon operation.





LAST FOUR DIRECTORIES submenu
Menu command:
Last four directories:

Toolbar button:
none

Keyboard accelerator:
Ctr + 1
Ctr + 2
Ctr + 3
Ctr + 4

This option allows you to quick open files from last four stored paths.
In order to do that:

· Choose File >Last four directories: and select proper path.
You can also use keyboard shortcuts (Ctr+1 to Ctr+4).





MOVE TIME command
Menu command:
Move Time... Ctr+T

Toolbar button:

Keyboard accelerator:
Ctr + T

This option allows you to force all subtitle lines to appear earlier or later.
In order to do that:

· OPEN file you want adjust.
· Click the Move button , choose File >Move time... or press Ctr + T.
· Use dialog box described bellow.

Dialog is pretty easy to use but if you still have some problems here is a description:

1 Here you have source file name.

2 Here you have source file format detected by TA.

3 Here you can decide if you want your subtitles to appear later or earlier - just select proper radio button.

4 Here you can see adjustment for all subtitle lines. "+" means that subtitles will be displayed later, "-" that earlier.



5 Here you can set the level of adjustment. How many seconds, minutes, TPOS'es or frames (depends on subtitle 
format) you want to add or remove from EVERY line in file. Just select proper adjustment using sliders.

6 Begin operation.

7 Abandon operation.





OPEN FILE command
Menu command:
Open... Ctr+0

Toolbar button:

Keyboard accelerator:
Ctr + O

To open a subtitle file:

Click the Open button , choose File >Open... or press Ctr + O. In the Open dialog box, select one filename, and click 
Open. Subtitle documents usually have the extension *.txt *.sub or *.srt .





REPAIR command
Menu command:
Repair file...

Toolbar button:

Keyboard accelerator:
none

This option allows you to repair some common errors in subtitle files.
In order to do that:

· OPEN file you want convert.
· Click the Repair button or choose File >Repair File...
· Use dialog box described bellow.

Dialog is pretty easy to use but if you still have some problems here is a description:

1 - Click here to scan file for "UNIX" type enters.

2 - Click here to scan file for non sorted lines.

3 - Click here to scan file for too early disappearing lines (standard values are used).

4 - Click here to scan file for too early disappearing lines and set advanced settings.

5 - Abandon operation.





SAVE FILE command
Menu command:
Save... Ctr+S

Toolbar button:

Keyboard accelerator:
Ctr + S

To save a subtitle file:

Click the Save button , choose File >Save... or press Ctr + S.
Warning !
This operation wipes out previous content of source file !





SAVEAS FILE command
Menu command:
Save As... Ctr+A

Toolbar button:

Keyboard accelerator:
Ctr + A

To save a subtitle file:

Click the Save button , choose File >Save As... or press Ctr + A.

If you have only one output file - simple Save As dialog will be displayed in order to select file name for output file.

If you have two output files (for example after SPLITTING operation): such dialog box will be displayed:

1 If you want to save one of output files click on one of those buttons and select name for this file.

2 Here goes file name you select using button no. 1.

3 You can abandon saving file (even if file name is already chosen) by unchecking those boxes.

4 Save selected files.

5 Abandon operation.





SPLIT FILE command
Menu command:
Split file...

Toolbar button:

Keyboard accelerator:
none

This option allows you to split subtitle file into two separate files with proper time adjustment.
In order to do that:

· OPEN file to split.
· Select line you want to be first in second splited file.
· Click the Split button or choose File >Split file...
· Use dialog box described bellow.
· After splitting - second file or both can be not synchronized with video. Use MOVE TIME or SYNCHRONIZE 
command to fix it.

Dialog is pretty easy to use but if you still have some problems here is a description:

1 and 2 - Here you can see in different units when the first output file will be ending. If source file is in time-based
format - you will see dialog with TPOS'es and hour,minute,second values.
If your source file is in frame-based format you will see frame value.

3 - Here you can enter no. of TPOS'es or FRAMES (all depends on subtitle format) that Time Adjuster will remove 
from second output file when splitting.

4 - You can enter values described above also in hh:mm:ss format - just click on radio button and select this box.
If your file is in frame-based format you will have to enter FPS value in order to use this feature.



5 - Here you have to enter FPS value - but only if you're working on frame-based format and wants to remove TIME 
values from second output file.

6 - Begin operation.

7 - Abandon operation.





Add stamp-line to output file... command
Menu command:
Add stamp-line to output file...

Toolbar button:

Keyboard accelerator:
none

This option allows you add your personal information to subtitle files.
It's possible to add up to two lines (on at the beginning of file and one on the end of file).

You can add those lines on demand or set Time Adjuster to add those lines every-time you work with subtitles (in 
background).

Dialog is pretty easy to use but if you still have some problems here is a description:

1 - Decide where TA should add your personalized lines.

2 - Enter the text that should appear on the beginning of file. Use "|" character if you want to add another line.

3 - Enter the text that should appear on the end of file. Use "|" character if you want to add another line.

4 - Decide here if TA should auto-add stamp-lines in background, every time you work with subtitle files.

5 - Use this button to apply changes.

6 - Abandon all changes and close this dialog.

7 - Use this button to add stamp-lines to currently open source file. If you made any changes in this dialog and want 
them to be used in adding a stamp-liens please remember to use "Apply changes" button before.
This button is active only when one source file is open and there is no output files open.





SYNCHRONIZE command
Menu command:
Synchronize

Toolbar button:

Keyboard accelerator:
none

This option allows you to synchronize subtitle file with video.
In order to do that:

· OPEN file you want synchronize.
· Click the Synchronize button or choose File >Synchronize
· Use dialog box described bellow.

Dialog is pretty easy to use but if you still have some problems here is a description:

1 - Here you have can see first lines of subtitle file. You have to select one of those lines and enter time (or frame 
value - depends on format) when this line should appear (in box 4).

2 - Here you have can see last lines of subtitle file. You have to select one of those lines and enter time (or frame 
value - depends on format) when this line should appear (in box 6).

3 - Here you can change if you want to enter time value in TPOS'es or in hour,minute,second format. If source file is 
in frame-based format you will be forced to enter frame value.

4 - Here is place where you can see original value of selected line and you have to enter NEW value for selected 
line.



5 - VERY IMPORTANT button ! If you selected line in box 1 or 2 you can use those buttons to lunch AVI player and 
point when those selected lines should appear in very easy way.

6 - The same meaning as edit box no. 4 - here you can see selected different value type than above.

7 - Begin operation.

8 - Abandon operation.

If you want to start synchronization remember to select lines in both 1 & 2 boxes.
And change at least ONE time/frame value !





GET INFORMATION SUBTITLE FILES command
Menu command:
Subtitle files info...

Toolbar button:

Keyboard accelerator:
none

This option allows you to extract basic information about subtitle files currently loaded in TA.
In order to do that:

· Click the TXT info button or choose File >Subtitle files info...
· Select subtitle to show info about it.

Dialog is pretty easy to use but if you still have some problems here is a description:

1 - Here you can see list of subtitle files currently loaded in Time Adjuster. Click on file name go get basic info about 
it.

2 - Here you can see basic info about selected subtitle.

3 - Here you can decide if you want to show this window every time you load subtitle or only on demand.

4 - This button closes dialog box.

Here is a list of supported subtitle formats.





Supported formats
Time Adjuster supports following subtitle formats:

- time format    00:00:00  
- time format    0:00:00  
- time format    MPL2 [xxx][xxx]  
- time format    SRT 00:00:00,xxx --) 00:00:00,xxx  
- time format    SUB [00:00:00] - SubViewer  
- time format    Dialogue: Marked=0,h:mm:ss.xx,h:mm:ss.xx,NORMAL,00,0000,0000,0000,,txt here - Sub Station 
Alpha (SSA)  
- time format    hh:mm:ss.xx,hh:mm:ss.xx - similar in some points to Sub Station Alpha (unknown name)  
- frame format    {xxx}{xxx} (mDVD)  
 





FPS value - what is it ?
Q1: FPS value - what is it ?

FPS it's short-name for Frames Per Second. As you know every video file is made of frames. DivX movies are not an 
exception. But there is one problem: people who make DivX movies like to set FPS value on different level. Some 
movies are encoded with 25.0 frames shown per second some 23.something, etc...

What it means for YOU & why TA asks for that value ?
I made TA to ask you for FPS value only if it's REALLY necessary. The problems occurs when for example you load 
subtitle file written in FRAME format & want to convert it into f/e: MPL2 Time format. In source file there is only 
information such: at frame 1000 show subtitle until frame 1025 etc... and without information how to translate frames 
into seconds (time) such conversion is not possible. That's the job for FPS value.

Once again: FPS = 25.0 means that during watching one second of DivX movie you will see 25 frames. When TA 
have this value conversion is possible.

Q2: FPS value - how to get it ?
I understand that not everyone in fast enough to count number of frames per second only by watching DivX movie ;-D
That's why TA can help you & extract this value for video file. All you have to do is to select "AVI info" button and load 
your DivX. Even more - if you're converting subtitle file and FPS value is required ->use "Load FPS form AVI" button, 
load AVI file and finally select "OK" button. FPS field will be auto-filled by movie FPS.





HELP menu
Content of help menu:

Check for UPGRADE 

Tip of the Day 

Main help file... 

View README.TXT 

Frequently Asked Question - ENG 

Discuss on TA FORUM 

About Time Adjuster 

List of ppl who HELPED me with TA :) 





Introduction
Time Adjuster

it's Windows application that can:

· Make your subtitles to appear earlier or later.
· Convert your subtitle files into other formats.
· SYNCHRONIZE text with video VERY EASY !
· Join & split subtitle files.
· REPAIR damaged TXT files dloaded via FTP in BINARY mode.
· Sort lines used time-based technique.
· Get basic info about video & subtitle file.
· Scan & repair TOO EARLY DISAPPEARING LINES.

Other features:

· program can check via internet if new version is available
· you can change the program's LANGUAGE
· leave your TA alone for a while and just watch... :-D

Time Adjuster DO NOT SUPPORT UNICODE  - sorry !
And remember this program is FREEWARE    !

Here is a list of supported subtitle formats.
Take a look also at application OVERVIEW.

LIGHT and STANDARD versions:

Time Adjuster is distributed in two versions:

·LIGHT 
·STANDARD 





AVI PLAYER - usage
AVI PLAYER - usage

Avi player it's a part of Time Adjuster.
This player has one important task: TO HELP you in SYNCHRONIZING your subtitle file with DivX video.

General idea:

Desynchronization of subtitle files can be removed by Time Adjuster by using SYNCHRONIZE command.
This command requires to select two lines - one on the beginning of subtitle file and one on the end.
Then you have to enter time/or frame (depends on subtitle format) when this line has to appear on the screen.
All rest lines will be recalculated and synchronized to video !

Do you think that it couldn't be easier ? You're WRONG ;-D ! It could be easier and IT IS !
You don't have to enter manually those time/frame data !
You can lunch avi player, load move and when move is being played just push a button when selected line should 
appear.
Time Adjuster will auto-fill proper fields in synchronize dialog according to data extracted form avi player.

Here description of some AVI PLAYER buttons and features:

1 This is SEEKING BAR - allows you to quick seek around video file.

2 This button opens video file.

3 This button stops playback.

4 This button pauses/resumes playback of video file.

5 Those two buttons allow to make quick jumps forward and back.

6 Here you can slow down movie playback.

7 Click on this button when line we're seeking is being played. Current time/frame will be used by 
SYNCHRONIZATION dialog.

8 Current movie position.

9 Last selected movie position.

10 Change state of this button if you want or not playback window to be stick to control panel.

11 This is the line we're seeking ! Press button 7 when it will appear in movie.



If you loaded movie and found point when selected line should appear click on "OK". Proper value will be transfered 
to SYNCHRONIZATION dialog.
If you want to abandon changes click on "Cancel".

Avi player uses DirectX technology.





CREDITS PAGE
Time Adjuster's credits:

Credits for the translators of Time Adjuster's language files :

LATVIAN texts Deadly BrEaThE (aka. B[r]3) (breathe@punkass.com)
LITHUANIAN texts Aurimas Tijunonis alias Savas_j0xxx (j0@xxx.lt)
FRENCH texts Lagoon (lagoon@nerim.net)
ITALIAN texts Fabrizio "Rush" Degni (rush@openaccess.it)
SPANISH texts Juan José Bojórquez (jjbm@mail.com)
SLOVAK texts Roman Husarik (gusto.death@inmail.sk)
HUNGARIAN texts Mirr Murr (Kara Károly) (k.kara@flexiton.hu)
ROMANIAN texts Robert Anton (robert.anton@ntlworld.com)
and: Marius Ovidiu (ovidium@xnet.ro)
CROATIAN texts Budimir Skrtic (budimir.skrtic@ka.tel.hr)
BRAZILIAN-Portugese texts Henrique Sambiase (lucki_jr@yahoo.com.br)
PORTUGESE texts David Guerreiro (david.guerreiro@megamail.pt)
CZECH texts Petr "Cherubin" Rybysar (petr.rybysar@upce.cz)
GREEK texts Oikonomou Basilis (oikonomoub@in.gr)
DUTCH texts Bertus Wagenaar (bertuswagenaar@hotmail.com)
ESTONIAN texts Indrek Soon (isoon@hot.ee)
HEBREW texts Nadav Schachter (sch@aquanet.co.il)
CATALAN texts Pau Bosch i Crespo (paubcrespo@hotmail.com)
TURKISH texts Ömer ERZEN (omerzen@alumni.bilkent.edu.tr)
FINNISH texts Petri Hutri (petri.hutri@kolumbus.fi)
SWEDISH texts Royne Dahlqvist (Royne.Dahlqvist@Telia.com)
GALICIAN texts Xosé Antón Vicente Rodríguez (antonvicente@navegalia.com)
SLOVENIAN texts Damjan Kuznar (damjan.kuznar@guest.arnes.si)
DANSH texts Bjarne Andersen (bjarne_andersen@hotmail.com)
NORVEGIAN texts Marita Nilsen (biia@tiscali.no)
POLISH texts me :) (irekz@yahoo.com)
ENGLISH texts me :) (irekz@yahoo.com)

Thanks:

- To all people that use Time Adjuster and submit feedback !
- To Lagoon for his GREAT help in many fields.
- To Pawel Balasz for help in testing and debugging under XP





DONATE !





How can I... ?
How can I... ?

Q1) Subtitles shows too early/late by constant factor of X seconds. What can I do ?

A: That's the typical situation to use MOVE TIME command.

Q2) Subtitles shows too early/late but this changes in time. What can I do ?

A: That's the typical situation to use SYNCHRONIZE command.

Q3) I have 2 CDs DivX movie but I found on Internet subtitle file for ONE CD version. What can I do ?

A: That's the typical situation to use SPLIT FILE command.

Q4) I have 1 CD DivX movie but I found on Internet subtitle file for 2 CDs version. What can I do ?

A: That's the typical situation to use JOIN 2 FILES command.

Q5) When I watch video, subtitles are disappearing very quickly from the screen - I CAN'T READ IT! What can I do ?

A: That's the typical situation to use REPAIR command.





R1 !





R2 !





R3 !





UPGRADE CHECKER - usage
UPGRADE CHECKER - usage

Upgrade checker it's a part of Time Adjuster.
The main role of this application is to check if you have the most recent version of Time Adjuster.

General idea:

· Upgrade checker can connect to Time Adjuster home page in background (when you use Time Adjuster and 
Internet connection is active), and check for upgrade availability.
· Upgrade checker can also be run directly by user to perform the same action.

1 Status window. Information if upgrade is available or not is displayed here.

2 Here you can turn ON/OFF auto upgrade check in background.

3 Here you can start upgrade check. If upgrade is available this button changes to hyperlink to download page.

4 This button closes upgrade check window.





Getting more help
To get more help please use:

1) E-MAIL:

All comments, suggestions & questions please send to: irekz@yahoo.com

2) PHONE:

In urgent situations you can also call me at: ++48 503-741-408
I can provide help in ENGLISH and POLISH languages.
Please remember also about time zones and call between: 8AM - 10PM
Central European Time (GMT + 2)

3) WEB FORUM:

Visit Time Adjuster's web forum at: 
http://www.geocities.com/irekz/TA/board_ref.html (available also through button & menu command in TA)

4) HOME PAGE:

Visit Time Adjuster's web page: 
http://www.ireksoftware.com/ta/ (available also through button & menu command in TA)

5) FAQ:

In English & some other languages is attached to Time Adjuster and is available
through Time Adjuster's menu and Windows Start Menu.





CONFIGURATION command
Menu command:
Configuration... Ctr+C

Toolbar button:

Keyboard accelerator:
Ctr + C

This command gives you access to Configuration menu.
There you can set many aspects of Time Adjuster's behavior.





TPOS - what is it ?
TPOS - Tenth Part Of Second

1 TPOS it's time equivalent to 1/10 of second
10 TPOSes = 1 second





Help to translate TA
You can speak FOREIGN language
(different than listed bellow) ?

Maybe you could translate Time Adjuster ?!
It's easy and wouldn't take you more than 20 minutes...

- your name will be placed in "Help" menu of the program !
- your local community will be able to use Time Adjuster in their native language !

How to do it ?

· step 1: Go to Time Adjuster web site and download the most recent version of this application (even if it has 
the same version number as yours - because I often add new lanf. files without changing version number) - and
check if your language is not already supported.
· step 2: Open in any text editor (f/e: in Windows Notepad) file: ENGLISH_language.lan
(this file is located in languages directory.)
· step 3: Translate all text lines in the file.
· step 4: Save file as: YourLangauage_language.lan
· step 5: Send me this file with your Name & contact e-mail at: irekz@yahoo.com

One more thing:
line 0110: contains name of the font used in main window - leave it "Arial" or change to the name of font
that contains characters proper for your language for example: Arial CE (for Centrall European characters).
\n in text file means: new line, \t means: tab space

Also: you don't have to translate lines starting "//" it's just a comment.

The most recent list of languages already supported by Time Adjuster is available HERE.





Overwiev
Time Adjuster - OVERVIEW & main application info

Time Adjuster it's application that contains few parts:

·Main application. 
· DirectX video player.
· Upgrade check utility.
·Help and FAQ files. 
·Instal utility. 
·Uninstal utility. 

Time Adjuster - MAIN APPLICATION

1 - Content of source file. If you select any line here - it's number will appear at box 7. Right mouse click shows 
context menu.

2 - Content of output file.

3 - Toolbar.

4 - Menu.

5 - Status bar. Here you can read some useful TIPS. If size of this bar is too small to show all text - bars 6 and 7 will 
be auto-closed in order to make some extra room.

6 - CPU load monitor.



7 - Here you can see number of selected line in source file. If file is in format where for example file-line number xx - 
doesn't mean subtitle number xx (for example in STR format where one subtitle can have many lines) - you can 
select line in source file and click at this number here - value will be retranslated to subtitle number.

8 - Creature walking trought your desktop - even this is possible in Time Adjuster ;-D. It's not a virus - just a funny 
stuff, you can disable in configuration menu.





Time format 00:00:00

It's format that contains two type of data:

· time (when to show subtitle line) in hour, minute, second
· text line to show

Data are organized in following way:

hh:mm:ss:text line|second line

where:
hh - hour
mm - minute
ss - second
| - in text line is a line separator (like enter)

Example:

00:00:16:The Empire of Izmer|has long been a divided land.
00:00:22:Ruled by the Mages,|an elite group of magic users.
00:00:26:The lowly Commoners,|those without magic...
00:00:29:are little more than slaves.
00:00:32:Izmer's young Empress Savina...
00:00:35:wishes equality|and prosperity for all.



Time format 0:00:00

It's format that contains two type of data:

· time (when to show subtitle line) in hour, minute, second
· text line to show

Data are organized in following way:

hh:mm:ss:text line|second line

where:
h - hour
mm - minute
ss - second
| - in text line is a line separator (like enter)

Example:

0:00:16:The Empire of Izmer|has long been a divided land.
0:00:22:Ruled by the Mages,|an elite group of magic users.
0:00:26:The lowly Commoners,|those without magic...
0:00:29:are little more than slaves.
0:00:32:Izmer's young Empress Savina...
0:00:35:wishes equality|and prosperity for all.



Time format MPL2 [xxx][xxx]

It's format that contains following data:

· time (when to show subtitle line) in TPOS
· time (when to hide subtitle line) in TPOS
· text line to show

Data are organized in following way:

[xxx][yyy]text line|second line

where:
xxx - time when to show subtitle line
yyy - time when to hide subtitle line
| - in text line is a line separator (like enter)

This format can have information about when to hide subtitle, but it's not necessary.
When this information is not available second time value is empty. For example:

[260][]The lowly Commoners,|those without magic...

Example:

[160][170]The Empire of Izmer|has long been a divided land.
[220][240]Ruled by the Mages,|an elite group of magic users.
[260][]The lowly Commoners,|those without magic...
[290][305]are little more than slaves.
[320][330]Izmer's young Empress Savina...
[350][]wishes equality|and prosperity for all.



Time format SRT 00:00:00,xxx --> 00:00:00,xxx

It's format that contains following data:

· time (when to show subtitle line) in hour, minute, second, 1/1000 of sec
· time (when to hide subtitle line) in hour, minute, second, 1/1000 of sec
· text line to show

Data are organized in following way:

X
h1:m1:s1,xxx --> h2:m2:s2,yyy
first text line
second text line etc...

where:
X - number of text line
h1,h2 - hour when to show/hide text line
m1,m2 - minute when to show/hide text line
s1,s2 - second when to show/hide text line
xxx,yyy - number of 1/1000 of second when to show/hide text line

In this format character "|" doesn't mean new line.
So when converting from other formats Time Adjuster removes this character and puts new line instead.

This format can have information about when to hide subtitle, but it's not necessary.
When this information is not available second time values are 0. For example:

00:00:26,000 --> 00:00:00,000

Example:

1
00:00:16,000 --> 00:00:17,000
The Empire of Izmer
has long been a divided land.
2
00:00:22,000 --> 00:00:24,000
Ruled by the Mages,
an elite group of magic users.



Time format [00:00:00] - SubViewer

It's format that contains two type of data:

· time (when to show subtitle line) in hour, minute, second
· text line to show

Data are organized in following way:

[hh:mm:ss]
text line|second line

where:
hh - hour
mm - minute
ss - second
| - in text line is a line separator (like enter)

This format has many headers, that can contain author name, file path, title etc...
When TA works over this format it saves those headers and add to output files. When you're converting this format to 
others all headers WILL BE LOST !
When you convert file to this format default header will be generated.

This format doesn't contain information when to hide subtitle but some files has empty lines that are sort of hiding 
mechanism.

Example:

[TITLE]
Movie of the year
[AUTHOR]
Unknown
[DELAY]
0
[CD TRACK]
0
[BEGIN]
******** START SCRIPT ********
[00:00:16]
The Empire of Izmer|has long been a divided land.
[00:00:22]
Ruled by the Mages,|an elite group of magic users.
[00:00:26]
The lowly Commoners,|those without magic...
[00:00:29]
are little more than slaves.
[00:00:30]
[00:00:32]
Izmer's young Empress Savina...
[00:00:35]
wishes equality|and prosperity for all.
[END]
******** End Script ********



Time format Sub Station Alpha

Time Adjuster supports version 4.0 of SSA script files.
This format has many headers.
When TA works over this format it saves those headers and add to output files. When you're converting this format to 
others all headers WILL BE LOST !
When you convert file to this format default header will be generated. In this format character: "|" doesn't mean "new 
line" and when converting to SSA this characters will be converted to "\n" string.

When working over this format - precision will be limited to 1/10 of second.
Specification of this format is very long. You can a lot of information about this format at: 
http://www.eswat.demon.co.uk/substation.html

Example:

[Script info]
PlayResY: 304
[V4 Styles]
Format: Name, Fontname, Fontsize, PrimaryColour, SecondaryColour, TertiaryColour, BackColour, Bold, 
Italic, BorderStyle, Outline, Shadow, Alignment, MarginL, MarginR, MarginV, AlphaLevel, Encoding
Style: NORMAL,Times New Roman CE,28,16777215,65535,65535,0,1,0,1,3,5,2,30,30,10,0,238
Style: ITALIC,Times New Roman CE,28,16777215,65535,65535,0,1,1,1,3,5,2,30,30,10,0,238
Style: NORMAL,Times New Roman CE,28,16777215,65535,65535,0,1,0,1,3,5,2,30,30,10,0,238
[Events]
Format: Marked, Start, End, Style, Name, MarginL, MarginR, MarginV, Effect, Text
Dialogue: Marked=0,0:00:16.00,0:00:00.00,NORMAL,00,0000,0000,0000,,The Empire of Izmer\nhas long been a 
divided land.
Dialogue: Marked=0,0:00:22.00,0:00:00.00,NORMAL,00,0000,0000,0000,,Ruled by the Mages,\nan elite group 
of magic users.
Dialogue: Marked=0,0:00:26.00,0:00:00.00,NORMAL,00,0000,0000,0000,,The lowly Commoners,\nthose without 
magic...
Dialogue: Marked=0,0:00:29.00,0:00:00.00,NORMAL,00,0000,0000,0000,,are little more than slaves.
Dialogue: Marked=0,0:00:32.00,0:00:00.00,NORMAL,00,0000,0000,0000,,Izmer's young Empress Savina...
Dialogue: Marked=0,0:00:35.00,0:00:00.00,NORMAL,00,0000,0000,0000,,wishes equality and prosperity for 
all.



mm:ss.xx,hh:mm:ss.xx - similar in some points to Sub Station Alpha (unknown name)

I don't know the name and origin of this format. It's similar to SSA but only in some points.
This format has many headers.
When TA works over this format it saves those headers and add to output files. When you're converting this format to 
others all headers WILL BE LOST !
When you convert file to this format default header will be generated. In this format character: "|" means "new line".

When working over this format - precision will be limited to 1/10 of second.

Example:

[INFORMATION]
[TITLE]
[AUTHOR]
[SOURCE]
[PRG]
[FILEPATH]
[DELAY]
[CD TRACK]
[COMMENT]Subtitle synchronized using Time Adjuster: www.timeadjust.z.pl
[END INFORMATION]
[SUBTITLE]
[COLF]&HFFFFFF,[STYLE]bd,[SIZE]16,[FONT]Arial
00:00:22.40,00:00:00.00
Ruled by the Mages,|an elite group of magic users.
00:00:26.00,00:00:00.00
The lowly Commoners,|those without magic...
00:00:29.00,00:00:00.50
are little more than slaves.
00:00:32.00,00:00:00.00
Izmer's young Empress Savina...
00:00:35.30,00:00:00.00
wishes equality|and prosperity for all.



Frame format {xxx}{xxx} (mDVD)

It's format that contains following data:

· frame number (when to show subtitle line)
· frame number (when to hide subtitle line)
· text line to show

Data are organized in following way:

{xxx}{yyy}text line|second line

where:
xxx - frame number when to show subtitle line
yyy - frame number when to hide subtitle line
| - in text line is a line separator (like enter)

This format can have information about when to hide subtitle, but it's not necessary.
When this information is not available second time value is empty. For example:

{650}{}The lowly Commoners,|those without magic...

Example:

{400}{425}The Empire of Izmer|has long been a divided land.
{550}{600}Ruled by the Mages,|an elite group of magic users.
{650}{}The lowly Commoners,|those without magic...
{725}{762}are little more than slaves.
{800}{825}Izmer's young Empress Savina...
{875}{}wishes equality|and prosperity for all.



Keyboard shortcut: Ctr+U

Opens dialog window that allows you to check if more recent version of Time Adjuster is available.
Active connection to INTERNET is reqired.
You can set there also to perform auto-check in background.



Keyboard shortcut: none

Opens dialog window with number of interesting TIPs. You can also set there to auto-load this window on Time 
Adjuster's start up.



Keyboard shortcut: F1

Opens this help file.
Please note that this full help file is available only on Time Adjuster STANDARD.
Time Adjuster LIGHT version (in order to reduce size) doesn't have this file attached.



Keyboard shortcut: none

Opens README.TXT file in default TXT viewer.



Keyboard shortcut: none

Opens FAQ file in default *.doc viewer.



Toolbar icon:

Keyboard shortcut: Ctr+F

Opens Time Adjuster's WWW DISCUSSION BOARD in default web browser.
Active connection to INTERNET is required.



Keyboard shortcut: none

Shows ABOUT menu.



Keyboard shortcut: none

Shows list of people that translated TA language files.
Thanks again guys !



Double bytes charactest. It's other than ANSI way to code text.
Used mostly in Japan, China and countries with such alpahbets.



You can use and copy it free of charge.
All you have it's to keep package in one piece and DO NOT earn money on seling it.



In order to seduce file size this version doesn't have THIS HELP file !



This is FULL version of Time Adjuster. It has THIS HELP file attached. And that's why is near twice bigger than LIGHT
version.



Take a look BELLOW !



Time Adjuster can be downloaded in two versions:

· Standard - you will have BIG package but all HELP & FAQ files.
· LIGHT - you will have SMALL package but only FAQ files.

LIGHT version is recommended for experienced Time Adjuster users.
While standard version is recommended for new users.



Allows you to install Time Adjuster in your system.
If you're upgrading to new version of TA - installer will use old settings.
If it's first-time installation default settings will be used.



Allows you to REMOVE Time Adjuster from your system.
All files, directories, registry keys will be deleted.







Time format 00:00:00

It's format that contains two type of data:

· time (when to show subtitle line) in hour, minute, second
· text line to show

Data are organized in following way:

hh:mm:ss:text line|second line

where:
hh - hour
mm - minute
ss - second
| - in text line is a line separator (like enter)

Example:

00:00:16:The Empire of Izmer|has long been a divided land.
00:00:22:Ruled by the Mages,|an elite group of magic users.
00:00:26:The lowly Commoners,|those without magic...
00:00:29:are little more than slaves.
00:00:32:Izmer's young Empress Savina...
00:00:35:wishes equality|and prosperity for all.



Time format 0:00:00

It's format that contains two type of data:

· time (when to show subtitle line) in hour, minute, second
· text line to show

Data are organized in following way:

hh:mm:ss:text line|second line

where:
h - hour
mm - minute
ss - second
| - in text line is a line separator (like enter)

Example:

0:00:16:The Empire of Izmer|has long been a divided land.
0:00:22:Ruled by the Mages,|an elite group of magic users.
0:00:26:The lowly Commoners,|those without magic...
0:00:29:are little more than slaves.
0:00:32:Izmer's young Empress Savina...
0:00:35:wishes equality|and prosperity for all.



Time format MPL2 [xxx][xxx]

It's format that contains following data:

· time (when to show subtitle line) in TPOS
· time (when to hide subtitle line) in TPOS
· text line to show

Data are organized in following way:

[xxx][yyy]text line|second line

where:
xxx - time when to show subtitle line
yyy - time when to hide subtitle line
| - in text line is a line separator (like enter)

This format can have information about when to hide subtitle, but it's not necessary.
When this information is not available second time value is empty. For example:

[260][]The lowly Commoners,|those without magic...

Example:

[160][170]The Empire of Izmer|has long been a divided land.
[220][240]Ruled by the Mages,|an elite group of magic users.
[260][]The lowly Commoners,|those without magic...
[290][305]are little more than slaves.
[320][330]Izmer's young Empress Savina...
[350][]wishes equality|and prosperity for all.



Time format SRT 00:00:00,xxx --> 00:00:00,xxx

It's format that contains following data:

· time (when to show subtitle line) in hour, minute, second, 1/1000 of sec
· time (when to hide subtitle line) in hour, minute, second, 1/1000 of sec
· text line to show

Data are organized in following way:

X
h1:m1:s1,xxx --> h2:m2:s2,yyy
first text line
second text line etc...

where:
X - number of text line
h1,h2 - hour when to show/hide text line
m1,m2 - minute when to show/hide text line
s1,s2 - second when to show/hide text line
xxx,yyy - number of 1/1000 of second when to show/hide text line

In this format character "|" doesn't mean new line.
So when converting from other formats Time Adjuster removes this character and puts new line instead.

This format can have information about when to hide subtitle, but it's not necessary.
When this information is not available second time values are 0. For example:

00:00:26,000 --> 00:00:00,000

Example:

1
00:00:16,000 --> 00:00:17,000
The Empire of Izmer
has long been a divided land.
2
00:00:22,000 --> 00:00:24,000
Ruled by the Mages,
an elite group of magic users.



Time format [00:00:00] - SubViewer

It's format that contains two type of data:

· time (when to show subtitle line) in hour, minute, second
· text line to show

Data are organized in following way:

[hh:mm:ss]
text line|second line

where:
hh - hour
mm - minute
ss - second
| - in text line is a line separator (like enter)

This format has many headers, that can contain author name, file path, title etc...
When TA works over this format it saves those headers and add to output files. When you're converting this format to 
others all headers WILL BE LOST !
When you convert file to this format default header will be generated.

This format doesn't contain information when to hide subtitle but some files has empty lines that are sort of hiding 
mechanism.

Example:

[TITLE]
Movie of the year
[AUTHOR]
Unknown
[DELAY]
0
[CD TRACK]
0
[BEGIN]
******** START SCRIPT ********
[00:00:16]
The Empire of Izmer|has long been a divided land.
[00:00:22]
Ruled by the Mages,|an elite group of magic users.
[00:00:26]
The lowly Commoners,|those without magic...
[00:00:29]
are little more than slaves.
[00:00:30]
[00:00:32]
Izmer's young Empress Savina...
[00:00:35]
wishes equality|and prosperity for all.
[END]
******** End Script ********



Time format Sub Station Alpha

Time Adjuster supports version 4.0 of SSA script files.
This format has many headers.
When TA works over this format it saves those headers and add to output files. When you're converting this format to 
others all headers WILL BE LOST !
When you convert file to this format default header will be generated. In this format character: "|" doesn't mean "new 
line" and when converting to SSA this characters will be converted to "\n" string.

When working over this format - precision will be limited to 1/10 of second.
Specification of this format is very long. You can a lot of information about this format at: 
http://www.eswat.demon.co.uk/substation.html

Example:

[Script info]
PlayResY: 304
[V4 Styles]
Format: Name, Fontname, Fontsize, PrimaryColour, SecondaryColour, TertiaryColour, BackColour, Bold, 
Italic, BorderStyle, Outline, Shadow, Alignment, MarginL, MarginR, MarginV, AlphaLevel, Encoding
Style: NORMAL,Times New Roman CE,28,16777215,65535,65535,0,1,0,1,3,5,2,30,30,10,0,238
Style: ITALIC,Times New Roman CE,28,16777215,65535,65535,0,1,1,1,3,5,2,30,30,10,0,238
Style: NORMAL,Times New Roman CE,28,16777215,65535,65535,0,1,0,1,3,5,2,30,30,10,0,238
[Events]
Format: Marked, Start, End, Style, Name, MarginL, MarginR, MarginV, Effect, Text
Dialogue: Marked=0,0:00:16.00,0:00:00.00,NORMAL,00,0000,0000,0000,,The Empire of Izmer\nhas long been a 
divided land.
Dialogue: Marked=0,0:00:22.00,0:00:00.00,NORMAL,00,0000,0000,0000,,Ruled by the Mages,\nan elite group 
of magic users.
Dialogue: Marked=0,0:00:26.00,0:00:00.00,NORMAL,00,0000,0000,0000,,The lowly Commoners,\nthose without 
magic...
Dialogue: Marked=0,0:00:29.00,0:00:00.00,NORMAL,00,0000,0000,0000,,are little more than slaves.
Dialogue: Marked=0,0:00:32.00,0:00:00.00,NORMAL,00,0000,0000,0000,,Izmer's young Empress Savina...
Dialogue: Marked=0,0:00:35.00,0:00:00.00,NORMAL,00,0000,0000,0000,,wishes equality and prosperity for 
all.



mm:ss.xx,hh:mm:ss.xx - similar in some points to Sub Station Alpha (unknown name)

I don't know the name and origin of this format. It's similar to SSA but only in some points.
This format has many headers.
When TA works over this format it saves those headers and add to output files. When you're converting this format to 
others all headers WILL BE LOST !
When you convert file to this format default header will be generated. In this format character: "|" means "new line".

When working over this format - precision will be limited to 1/10 of second.

Example:

[INFORMATION]
[TITLE]
[AUTHOR]
[SOURCE]
[PRG]
[FILEPATH]
[DELAY]
[CD TRACK]
[COMMENT]Subtitle synchronized using Time Adjuster: www.timeadjust.z.pl
[END INFORMATION]
[SUBTITLE]
[COLF]&HFFFFFF,[STYLE]bd,[SIZE]16,[FONT]Arial
00:00:22.40,00:00:00.00
Ruled by the Mages,|an elite group of magic users.
00:00:26.00,00:00:00.00
The lowly Commoners,|those without magic...
00:00:29.00,00:00:00.50
are little more than slaves.
00:00:32.00,00:00:00.00
Izmer's young Empress Savina...
00:00:35.30,00:00:00.00
wishes equality|and prosperity for all.



Frame format {xxx}{xxx} (mDVD)

It's format that contains following data:

· frame number (when to show subtitle line)
· frame number (when to hide subtitle line)
· text line to show

Data are organized in following way:

{xxx}{yyy}text line|second line

where:
xxx - frame number when to show subtitle line
yyy - frame number when to hide subtitle line
| - in text line is a line separator (like enter)

This format can have information about when to hide subtitle, but it's not necessary.
When this information is not available second time value is empty. For example:

{650}{}The lowly Commoners,|those without magic...

Example:

{400}{425}The Empire of Izmer|has long been a divided land.
{550}{600}Ruled by the Mages,|an elite group of magic users.
{650}{}The lowly Commoners,|those without magic...
{725}{762}are little more than slaves.
{800}{825}Izmer's young Empress Savina...
{875}{}wishes equality|and prosperity for all.



Keyboard shortcut: Ctr+U

Opens dialog window that allows you to check if more recent version of Time Adjuster is available.
Active connection to INTERNET is reqired.
You can set there also to perform auto-check in background.



Keyboard shortcut: none

Opens dialog window with number of interesting TIPs. You can also set there to auto-load this window on Time 
Adjuster's start up.



Keyboard shortcut: F1

Opens this help file.
Please note that this full help file is available only on Time Adjuster STANDARD.
Time Adjuster LIGHT version (in order to reduce size) doesn't have this file attached.



Keyboard shortcut: none

Opens README.TXT file in default TXT viewer.



Keyboard shortcut: none

Opens FAQ file in default *.doc viewer.



Toolbar icon:

Keyboard shortcut: Ctr+F

Opens Time Adjuster's WWW DISCUSSION BOARD in default web browser.
Active connection to INTERNET is required.



Keyboard shortcut: none

Shows ABOUT menu.



Keyboard shortcut: none

Shows list of people that translated TA language files.
Thanks again guys !



Double bytes charactest. It's other than ANSI way to code text.
Used mostly in Japan, China and countries with such alpahbets.



You can use and copy it free of charge.
All you have it's to keep package in one piece and DO NOT earn money on seling it.



In order to seduce file size this version doesn't have THIS HELP file !



This is FULL version of Time Adjuster. It has THIS HELP file attached. And that's why is near twice bigger than LIGHT
version.



Take a look BELLOW !



Time Adjuster can be downloaded in two versions:

· Standard - you will have BIG package but all HELP & FAQ files.
· LIGHT - you will have SMALL package but only FAQ files.

LIGHT version is recommended for experienced Time Adjuster users.
While standard version is recommended for new users.



Allows you to install Time Adjuster in your system.
If you're upgrading to new version of TA - installer will use old settings.
If it's first-time installation default settings will be used.



Allows you to REMOVE Time Adjuster from your system.
All files, directories, registry keys will be deleted.






