Seznámení s ochranným systémem OptimAccess

Ochranný systém OptimAccess slouží k zabezpečení pracovních stanic i notebooků proti neodbornému, neúmyslnému, či zcela záměrnému poškození již instalovaného software. Chrání nastavení instalovaných programů, operačního systému, komunikačních prostředků a nastavení Windows na pevných discích jednotlivých počítačů. Umožňuje rovněž sledovat využití počítače a monitorovat konkrétní události.

Jedná se o samostatný, komplexní a modulární ochranný systém. Díky široké škále ochranných metod si dokáže poradit jak s počítačovými viry, tak se zásahy laických či sofistikovaných uživatelů. Počítač má pro všechny uživatele jednotný vzhled, tytéž aplikace a stejné nastavení. Díky reportům generovaným systémem je možné mít dokonalý přehled o využití počítačů a programového vybavení v rámci organizace.

Využívání funkcí ochranného systému zabezpečí správcům a administrátorům počítačových systémů značnou nejen časovou, ale i materiální úsporu. OptimAccess nalezne uplatnění při ochraně jednotlivých počítačů nebo celých rozsáhlých informačních systémů, kde je velice obtížné udržet bezchybný provozuschopný stav.

Bezpečnost bez šifrování?

Je důležité si uvědomit, že program OptimAccess je „pouze ochranným systémem“. Systém přímo nechrání fyzicky uložená data na pevném disku pomocí kryptografického algoritmu. Dále je třeba vzít v úvahu obecný bezpečnostní fakt, že bez použití šifrovacího algoritmu nemá vůbec smysl o zabezpečení dat hovořit. Je-li tedy jedním z vašich požadavků také fyzická ochrana dat, je třeba skombinovat nasazení programu OptimAccess spolu s některým programovým balíkem pro šifrování dat.

Nejvíce bezpečné a transparentní vůči uživateli jsou balíky pro on-line šifrování pracující přímo na úrovni fyzického uložení dat na pevném disku či výměnném médiu. Více informací o nabídce a možnostech konkrétních produktů naleznete na www stránkách výrobce nebo je můžete telefonicky získat na obchodním a technickém oddělení.

Provoz systému

Nespornou předností ochranného systému OptimAccess je jeho nenápadný provoz. Uživatel pracuje v naprosto standardním prostředí, které je mu důvěrně známo, přičemž neregistruje žádný rozdíl. Výjimkou jsou situace, kdy jeho aktivity směřují k potencionálně nebezpečným situacím.

Podrobnější informace o návrhu, funkcích programu, nasazení systému v jednotlivých operačních systémech a počítačových sítích naleznete pod hesly:

  • Koncepce ochranného systému;
  • Specifika jednotlivých operačních systémů;
  • Nasazení v síti.


Koncepce ochranného systému

Systém OptimAccess lze instalovat na stanice s operačním systémem MS-DOS, Windows 3.x, 9x, NT, 2000 a XP. Díky zavádění na úrovni systémových ovladaču dosahuje vysokého stupně stability, bezpečnosti a běžnému uživateli je znemožněno nelegálně deaktivovat ochranný systém.

Prvotní instalace ochranného systému OptimAccess je snadná, časově nenáročná a výhodou je možnost jeho zavedení do již nakonfigurované stanice. Lze jej instalovat také hromadně prostřednictvím sítě. Není zde třeba provádět žádné úpravy, reinstalovat operační systém ani již instalovaný software. Aktivaci respektive deaktivaci je možno provést kdykoli během práce systému OptimAccess. Uživatel počítače při své práci není nijak omezován a přítomnost ochranného systému OptimAccess ani nezaregistruje.

Modulární pojetí systému

Jednotlivé funkční vlastnosti ochranného systému jsou rozloženy do samostatných modulů. Díky této koncepci máte možnost si plně přizpůsobit ochranný systém OptimAccess na základě vašich specifických požadavků. Lze volit mezi těmito moduly:

  • OptimAccess Standard – slouží pro základní zabezpečení programů a operačního systému instalovaného na pracovní stanici.
  • OptimAccess Extension – rozšiřuje ochranné funkce modulu Standard v oblastech operačního systému Windows.
  • OptimAccess Remote Control – je nástroj pro administraci, konfiguraci a centrální správu ochranného systému.
  • OptimAccess Computer Audit – umožňuje evidenci a sledování programového vybavení počítače.
  • OptimAccess WorkSpy – eviduje a sleduje využití počítače a pracovního času stráveného u počítače.

Podrobnější informace o jednotlivých modulech naleznete pod hesly Moduly ochranného systému, OptimAccess Standard, OptimAccess Extension, OptimAccess Remote Control,OptimAccess Computer Audit a OptimAccess WorkSpy.


Specifika jednotlivých operačních systémů

Tato nápověda je společná pro operační systémy Windows 9x, Windows ME, Windows NT, Windows 2000 a Windows XP. Příslušnost jednotlivých hesel k danému operačnímu systému je v pravém horním rohu jednotlivých hesel a témat vyznačena následujícími ikonami:

Informace uvedené pod daným heslem se vztahují k operačnímu systému Windows 9x a Windows ME
Informace uvedené pod daným heslem se vztahují k operačnímu systému Windows NT, Windows 2000 a Windows XP

Ochranný systém OptimAccess je určen pro operační systémy MS-DOS, Windows 3.x, Windows 9x, Windows ME, Windows NT, Windows 2000 a Windows XP. V dalších operačních systémech je použitelný s jistým omezením. S jeho specifiky pro jednotlivé operační systémy vás seznámí následující hesla:

  • MS-DOS, MS Windows 3.1x;
  • MS Windows 9x a ME;
  • MS Windows NT, 2000 a XP.

Podrobnější informace o možnostech síťového nasazení produktu naleznete pod heslem Nasazení v síti.


MS-DOS, MS Windows 3.1x

U počítačů, které mají instalovaný pouze Operační systém MS-DOS, Windows 3x, například technologie Tenkých klientů, které podporuje Windows 2000 Server, se může OptimAccess ovládat a kompletně spravovat pomocí DOSového Ovládacího prostředí. Pro tuto platformu jsou dostupné pouze funkce modulu OptimAccess Standard dle níže popsaných omezení.

Ovládací prostředí systému se spouští souborem Oa16.exe z adresáře, kde je aplikace nainstalována (pokud jste při instalaci neurčili jiný adresář, aplikace je instalována v adresáři C:\OAx, kde x je číslo verze ochranného systému OptimAccess).

Ovládání systému

Po zadání hesla se hlavní nabídka systému ovládá klávesou F10. V levé části modrého okna je adresářová struktura, ve které se správce může pohybovat pomocí kurzorových kláves. Příznak adresáře se mění kombinací kláves Ctrl a Enter. Pomocí klávesy Tab se přepíná kurzor mezi adresářovou a souborovou částí okna. Příznaky jednotlivých souborů se mění klávesou Enter. Všechny funkce systému jsou identické s modulem OptimAccess Standard s výjimkou funkcí:

  • komplexní ochrany Registrační databáze;
  • ochrany Ovládacích panelů.

Podrobnější informace o možném nastavení jednotlivých funkcí ochranného systému získáte pod heslem Ovládání aplikace ve Windows 9x/ME.


MS Windows 9x a ME

Pro platformu operačního systému Windows 9x jsou bez jakýchkoliv omezení ekvivalentní následující verze (jak česká, tak i anglická mutace):

  • Microsoft Windows 95;
  • Microsoft Windows 95 OSR2;
  • Microsoft Windows 98;
  • Microsoft Windows 98 SE;
  • Microsoft Windows ME.

Nápověda obsahuje kompletní popis průvodce, ovládacího prostředí a funkcí ochranného systému, modulů, doporučení a rad pro optimální nastavení. Podrobnější informace o jednotlivých tématech naleznete pod hesly:

  • Popis instalace systému plus další informace týkající se technické podpory a omezení systému naleznete pod heslem Začínáme s programem OptimAccess.
  • Popis ovládacího rozhraní systému a konfigurace jeho funkcí naleznete pod heslem Ovládání aplikace ve Windows 9x/ME.
  • Popis ovládání a konfigurace jednotlivých modulů systému je obsažen pod heslem Moduly ochranného systému.
  • Rady a doporučení výrobce pro optimální konfiguraci a vyladění ochranného systému naleznete pod heslem Doporučený postup konfigurace.
  • Informace o kolizích a řešení případných možných problémů jsou umístěny pod heslem Odstraňování problémů.
  • Vysvětlení základních pojmů s nimiž tato nápověda pracuje nalezne pod heslem Slovníček.


MS Windows NT, 2000 a XP

Pro platformu operačního systému Windows NT/2000/XP jsou bez jakýchkoliv omezení ekvivalentní následující verze (jak česká, tak i anglická mutace):

  • Microsoft Windows NT Workstation 4.0 s aktualizací Windows NT Service Pack 4 nebo vyšší (build 2195);
  • Microsoft Windows NT Server 4.0 s aktualizací Windows NT Service Pack 4 nebo vyšší (build 2195);
  • Microsoft Windows 2000 Professional;
  • Microsoft Windows 2000 Server;
  • Microsoft Windows 2000 Advanced Server;
  • Microsoft Windows XP Home Edition;
  • Microsoft Windows XP Professional.

Nápověda obsahuje kompletní popis průvodce, ovládacího prostředí a funkcí ochranného systému, modulů, doporučení a rad pro optimální nastavení. Podrobnější informace o jednotlivých tématech naleznete pod hesly:

  • Popis instalace systému plus další informace týkající se technické podpory a omezení systému naleznete pod heslem Začínáme s programem OptimAccess.
  • Popis ovládacího rozhraní systému a konfigurace jeho funkcí naleznete pod heslem Ovládání aplikace ve Windows NT/2000/XP.
  • Popis ovládání a konfigurace jednotlivých modulů systému je obsažen pod heslem Moduly ochranného systému.
  • Rady a doporučení výrobce pro optimální konfiguraci a vyladění ochranného systému naleznete pod heslem Doporučený postup konfigurace.
  • Informace o kolizích a řešení případných možných problémů jsou umístěny pod heslem Odstraňování problémů.
  • Vysvětlení základních pojmů s nimiž tato nápověda pracuje nalezne pod heslem Slovníček.


Nasazení v síti

Ochranný systém OptimAccess spolu s klienty pro vzdálenou správu podporují síťové prostředí postavené na protokolech TCP/IP a NetBEUI.

Hromadná instalace

OptimAccess podporuje vzdálenou hromadnou síťovou instalaci. Nakopírujete soubory na server a do přihlašovacího skriptu uživatelů zadáte patřičnou síťovou cestu k instalačním souborům. Snadno tak instalujete ochranný systém na jednotlivé pracovní stanice a aktivujete na stanicích klienta pro vzdálenou správu. Následně pak můžete jednotlivé stanice obejít, aktivovat a nakonfigurovat ochranný systém. Mnohem pohodlnější je ovšem použití modulu OptimAccess Remote Control, který je určený pro vzdálenou správu.

Celý proces síťové instalace lze velmi detailně nakonfigurovat. Podrobný popis postupu síťové instalace systému naleznete pod heslem Síťová instalace.

Vzdálená správa

Pro plné využití síťových schopností ochranného systému je třeba mít instalován modul OptimAccess Remote Control, určený pro vzdálenou správu. Modul rozlišuje dvě platformy v závislosti na použitém operačním systému spravovaných počítačů, na kterých běží klient ochranného systému.

Detailní informace o možnostech a funkcích vzdálené správy ochranného systému OptimAccess naleznete pod heslem OptimAccess Remote Control.


Začínáme s programem OptimAccess

Dříve než použijete ochranný systém OptimAccess si pečlivě prostudujte Licenční ujednání. Naleznete jej na Registrační kartě a nebo jako přílohu příručky Začínáme s ochranným systémem OptimAccess. Nesouhlasíte-li s ustanoveními tohoto ujednání, můžete produkt do 10-ti dnů od koupě vrátit oproti úhradě jeho ceny ze strany dodavatele.

Balení

Základním médiem pro distribuci ochranného systému OptimAccess je disk CD-ROM. Distribuční balení produktu obsahuje:

  • disk CD-ROM s programem a elektronickou dokumentací;
  • Registrační kartu a Návratku registrační karty, obsahující licenční číslo, počet licencí produktu, informace o zakoupených nadstavbách ochranného systému a aktivační kód;
  • příručku Začínáme s ochranným systémem OptimAccess, dodávanou ve formě bookletu.

Systémové požadavky

Po stránce hardwarových požadavků se nároky ochranného systému OptimAccess nijak neliší od doporučených systémových požadavků pro daný operační systém. Základní instalace Ochranného systému bez nadstavbových modulů vyžaduje 2,5 MB diskového prostoru. Plná instalace ochranného systému včetně všech nadstavbových modulů zabírá na pevném disku místo 10 MB.

Pokyny pro:

  • instalaci ochranného systému naleznete pod heslem Instalace;
  • upgrade ze starší verze ochranného systému naleznete pod heslem Upgrade ze starších verzí;
  • informace o možnostech získání odborné pomoci a rady jak kontaktovat výrobce naleznete pod heslem Odborná pomoc.


Instalace

Ochranný systém OptimAccess se instaluje také do systémových oblastí pevného disku a pro svou práci vyžaduje bezchybně funkční operační systém a Windows. Z tohoto důvodu je nutné před započetím vlastní instalace ochranného sytému provést následující kroky:

  • antivirovou kontrolu zvláště s ohledem na viry napadající zaváděcí oblast pevného disku (též označované jako Boot-viry);
  • kontrolu chyb povrchu disku, souborů a složek programem ScanDisk (spustíte jej tak, že klepnete na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Příslušenství, položku Systémové nástroje a klepnete na položku ScanDisk);
  • případně můžete optimalizovat rychlost načítání a spouštění programů pomocí programu Defragmentace disku (spustíte jej tak, že klepnete na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Příslušenství, položku Systémové nástroje a klepnete na položku Defragmentace disku);
  • zkontrolovat celkovou funkčnost operačního a Windows (systém je možné spustit, je v něm možné spouštět aplikace atd.);
  • zkontrolovat, zda všechny ovladače a zařízení pracují bez konfliktu a ve 32bitovém režimu (dialogové okno Systém můžete otevřít také tak, že klepnete na tlačítko Start, přejdete na příkaz Nastavení, zvolíte položku Ovládací panely a poklepete na ikonu Systém; informace o jednotlivých ovladačích zkontrolujete na kartě Správce zařízení);
  • v BIOSu zrušit detekci virů (nastavit položku Virus Warning na hodnotu Disabled);
  • po dobu instalace je rovněž doporučeno deaktivovat rezidentní části antivirů; je možné je znova aktivovat jakmile je ochranný systém OptimAccess aktivní a jejich funkce nebudou nijak omezeny (postupujte dle dokumentace dodané výrobcem vámi používaného antivirového programu);
  • v případě že hodláte u ochranného systému používat funkci Komplexní ochrana Registrační databáze, nastavte rovněž operační systém podle vzoru na nějž se bude obnovovat při každém restartu.
  • Instalujete-li OptimAccess do Windows 9x, musíte mít v systému nainstalovánu aplikaci Microsoft Internet Explorer 4.0 nebo vyšší. Jinak nebude možné spustit instalátor ochranného systému.

  • Instalujete-li OptimAccess do Windows NT, Windows 2000 nebo Windows XP je nutné být přihlášen jako Administrátor.
  • Používáte-li Windows NT je potřeba mít instalovánu aktualizaci Windows NT Service Pack 4 nebo vyšší.

Po provedení výše uvedených kroků je váš operační systém připraven na korektní instalaci ochranného systému OptimAccess. Pokyny pro vlastní instalaci systému na samostatný počítač jsou uvedeny pod heslem Instalace na samostatné PC. Tyto pokyny si přečtěte i v případě, hodláte-li instalovat ochranný systém v rámci počítačové sítě. Další instalační pokyny specifické pro síťovou instalaci jsou uvedeny pod heslem Síťová instalace.


Instalace na samostatné PC

Po vložení CD-ROM disku s distribucí ochranného systému OptimAccess se automaticky spustí Instalační program. Ten nakopíruje soubory potřebné pro ochranný systém na pevný disk vašeho počítače a povede veškeré úpravy nutné pro jeho korektní funkci.

Nedojde-li po vložení disku k automatickému spuštění instalačního programu, máte na systému vypnutou funkci Automatické přehrávání disků CD po vložení do jednotky. Tuto funkci operačního systému můžete aktivovat následujícím postupem:

  1. Dialogové okno Systém - vlastnosti otevřete tak, že klepnete na tlačítko Start, přejdete na příkaz Nastavení, zvolíte položku Ovládací panely a poklepete na ikonu Systém.
  2. Klepněte na znaménko plus vedle složky CDROM, klepněte pravým tlačítkem myši na ikonu mechaniky u níž chcete funkci nastavit, a zvolte příkaz Vlastnosti.
  3. Klepněte na kartu Nastavení a zaškrtněte políčko Automatické oznámení.

Automatickému přehrávání CD-ROM disků můžete naopak zabránit tak, že při jejich vkládání stisknete klávesu SHIFT.

Obsah distribučního disku

Soubory potřebné pro instalaci ochranného systému jsou v kořenovém adresáři distribučního média. Soubor s nápovědou je spolu s ostatními soubory tvořícími dokumentaci umístěn v adresáři DOC. Programy sloužící k podrobnější úpravě systému OptimAccess jsou umístěny v adresáři UTIL. Nemáte-li absolutní jistotu o funkcích jednotlivých souborů, nespouštějte je. Vyhnete se tak případným problémům ve funkci ochranného systému.

Soubory z distribučního média je při dodržení Licenčního ujednání možné kopírovat na pevný disk počítače a instalaci pak následně provádět z pevného disku. Lze je zkopírovat i prostřednictvím počítačové sítě, například v případech, kdy je třeba instalovat systém na počítač bez CD-ROM mechaniky.

Manuální spuštění instalace

Manuálně lze instalaci spustit souborem Setup.exe z kořenového adresáře distribučního média.

Postup instalace

  1. Před vlastní instalací ochranného systému je doporučeno ukončit všechny běžící aplikace.
  2. Po spuštění instalačního programu se zobrazí úvodní dialog se základními informacemi. Po jeho přečtení pokračujte v instalaci stiskem tlačítka Další >.
  3. Nyní se vás instalační program táže na souhlas s Licenčním ujednáním. Jeho tištěnou podobu můžete nalézt na Registrační kartě a nebo jako přílohu příručky Začínáme s ochranným systémem OptimAccess. Po důkladném přečtení svůj souhlas můžete vyjádřit označením volby S licenčním ujednáním souhlasím a v instalaci pokračovat stiskem tlačítka Další >. Nesouhlasíte-li s ustanoveními Licenčního ujednání, ukončete instalaci stiskem tlačítka Storno. Tento krok povede k ukončení instalace.
  4. V dalším kroku instalace program zobrazí licenční číslo vámi zakoupené instalace produktu a vyžaduje od vás zadání aktivačního kódu. Jedná se o čtyři čtveřice složené z číslic 0 až 9 a znaku A až F. Spolu s licenčním číslem jej naleznete na Registrační kartě. Máte-li zakoupeno více různých licencí produktu (reprezentovaných více různými licenčními čísly), uvádějte vždy patřičný aktivační kód příslušející k danému licenčnímu číslu zobrazenému instalačním programem. V případě nesrovnalostí či rozhodnete-li se rozšířit svou stávající licenci o další nadstavby, kontaktujte výrobce dle pokynu uvedených pod heslem Odborná pomoc. Po vyplnění aktivačního kódu pokračujte v instalaci stiskem tlačítka Další >.
  5. V dalším kroku instalace se zobrazí seznam veškerých částí, které OptimAccess má a jste oprávněni je na základě zakoupené licence instalovat. Jednotlivé části ochranného systému OptimAccess k instalaci určíte označením patřičné volby. Vždy můžete instalovat jádro ochranného systému označením volby OptimAccess – ovládací aplikace. Dle vámi zakoupené licence je možné dále instalovat nadstavbové moduly systému představované volbami OptimAccess Standard, OptimAccess Extension, OptimAccess Remote Control, OptimAccess Computer Audit a OptimAccess WorkSpy.

    • Modul Remote Control je nutné instalovat na všechny počítače a stanice, které mají být vzdáleně spravovány. Není-li tento modul na počítači instalován, není možné jej vzdáleně spravovat.

    Dále máte možnost zvolit adresář, kam bude ochranný systém OptimAccess instalován. Můžete tak učinit přímo vypsáním do textového pole vedle tlačítka Nalistuj (přednastaven je adresář C:\OAx, kde x představuje číslo verze ochranného systému OptimAccess) či po stisku na tomto tlačítku vybrat zvolený adresář pomocí grafického dialogu.
  6. Dříve než začnete vlastní instalaci je vhodné provést zálohu zaváděcích sektoru pevného disku. Instalační program vám nabídne možnost vytvořit spouštěcí disketu a tuto zálohou. V případě nouze můžete s pomocí této diskety spustit operační systém a nouzově odinstalovat. Nehodláte-li tuto disketu vytvářet, postupujte dle kroku č. 8.
  7. Dialog Záložní disketa vám nyní nabízí možnost zálohovat systémové oblasti zaváděcích sektoru pevného disku a vytvořit spouštěcí disketu pro ochranný systém OptimAccess. Po označení volby Vytvořit záložní soubor máte možnost do textového pole pod touto volbou zadat název souboru se záložními daty. Neprovedete-li žádné úpravy, je přednastaveno jméno souboru BACKUP.000. Zálohu si můžete pojmenovat libovolně, doporučuje se však použít konvence max. 8 znaku pro jméno souboru a 3 pro příponu. Spouštěcí disketu vytvoříte označením volby Vygenerovat speciální bootovací disketu ochranného systému OptimAccess. Označte tedy obě volby, vložte do mechaniky disketu a stiskněte tlačítko Provést.
  8. Nyní dochází ke zkopírování souboru ochranného systému OptimAccess na pevný disk počítače dle dříve provedených nastavení.
  9. V závěrečné fázi instalace vás instalační program vyzve k zadání hesla pro přístup do ovládací aplikace ochranného systému. Heslo je nutné zadat a není možné použít prázdné heslo. Podrobnosti a náležitosti hesla naleznete v části Náležitosti a pravidla pro volbu hesla.
  10. Na závěrečném dialogu instalace vám instalační program oznámí, že celý proces kopírování souboru ochranného systému a jeho nastavení pro váš počítač proběhl úspěšně. Ukončete jej stiskem na tlačítko Dokončit.

Od tohoto okamžiku se proces instalace považuje za ukončený. Nyní jsou na pevném disku počítače nakopírovány všechny soubory potřebné pro korektní funkci ochranného systému OptimAccess. Rovněž je nastaveno vstupní heslo pro spuštění ovládací aplikace ochranného systému.

I přesto, že není po korektní instalaci ochranný systém aktivní, je v paměti počítače spuštěn klient pro vzdálenou správu. Klient se spouští a zavádí do paměti počítače při každém startu operačního systému. Tedy ihned po instalaci lze na počítači systém aktivovat vzdáleně, restartovat počítač a následně provést všechny požadované úpravy nastavení ochranného systému. Přirozeně se znalostí nastaveného hesla lze všechny tyto operace provést i na počítači samotném.
  • Instalujete-li OptimAccess do Windows 9x, instalační program při svém ukončení automaticky spustí ovládací aplikaci OptimAccess (soubor Oa8GUI.exe). Po zadání správného hesla pro přístup do ovládací aplikace zobrazí dialog oznamující, že ochranný systém je momentálně deaktivován. Stiskem tlačítka Ne můžete aktivaci odložit do okamžiku následujícího spuštění ovládací aplikace. Označením volby Příště tento dialog již nezobrazovat a stiskem tlačítka Ne odložíte aktivaci ochranného systému na později. Podrobnější informace o aktivaci ochranného systému naleznete v následující sekci Aktivace systému.

Aktivace systému

Aby mohl ochranný systém OptimAccess plnit svou funkci, je třeba jej aktivovat (at již vzdáleně s pomocí nadstavbového modulu Remote Control či přímo). Učiníte tak při prvním spuštění ovládací aplikace OptimAccess. Naleznete ji mezi programy v nabídce Start ve skupině Ochranný systém OptimAccess. Je označena ikonou [image]. Systém aktivujete následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. Ochranný systém není aktivní a ovládací aplikace to dá najevo dialogem zobrazí oznamujícím, že ochranný systém je momentálně deaktivován.
    Detailní nastavení speciálních funkcí ochranného systému můžete upravit po stisku tlačítka Rozšířené volby aktivace …; jedná se o technicky specifické nastavení ochranného systému, které je detailně popsáno v elektronické nápovědě ochranného systému OptimAccess.
    Stiskem tlačítka Aktivuj ochranný systém navoleným způsobem aktivujete. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  4. Ochranný systém provede svou aktivaci zápisem do konfiguračních souboru operačního systému a systémových oblastí pevného disku. Po úspěšné aktivaci se spustí ovládací aplikace OptimAccess. Její popis naleznete v elektronické nápovědě.

Popis jednotlivých funkcí a prvku ovládací aplikace ochranného systému OptimAccess je uveden pod heslem Ovládání aplikace ve Windows 9x/ME. V případě systému Windows NT, Windows 2000 a Windows XP naleznete popis funkcí systému a ovládací aplikace pod heslem Ovládání aplikace ve Windows NT/2000/XP.

Při nastavování jednotlivých funkcí samozřejmě můžete také vycházet z výrobcem doporučené optimální konfigurace. Rady pro optimální nastavení systému naleznete v odstavcích Doporučený postup konfigurace.


Síťová instalace

V prostředí počítačové sítě postavené na rodině síťových protokolu TCP/IP můžete hromadnou síťovou instalaci provést podle následujícího postupu (proměnná <localhost> představuje síťové jméno počítače z nějž hodláte instalovat). S výjimkou cílového adresáře musíte pro daný typ instalace vytvořit všechny zmiňované adresáře. Jejich pojmenování plně záleží na vaší benevolenci.

  1. Nejprve připravte adresář s instalačními soubory. Máte možnost instalovat:
    • z distribučního CD-ROM: vložte jej do mechaniky počítače z nějž hodláte instalovat a nasdílejte jej (například \\<localhost>\cd).
    • ze síťového adresáře: na počítači z nějž hodláte instalovat vytvořte sdílený adresář s právem pouze pro čtení. Do tohoto adresáře pak po síti nakopírujte obsah instalačního CD (například \\<localhost>\install_oa).
  2. Dále připravte adresář pro soubor protokolu a konfigurační soubory. Nezapomeňte jej nasdílet i pro zápis, jestliže do něj budete ukládat soubor protokolu. V případě, kdy instalujete ze síťového adresáře, je vhodné umístit jej jako podadresář (například \\<localhost>\install_oa\log).
  3. Instalujte ochranný systém OptimAccess na jeden počítač a nastavte při instalaci vstupní heslo pro ovládací aplikaci ochranného systému OptimAccess. Pokyny a postup pro instalaci naleznete pod heslem Instalace na samostatné PC v sekci Postup instalace. Nezapomeňte rovněž nastavit heslo pro klienta vzdálené správy, jestliže jej chcete používat.
  4. Do adresáře připraveného pro soubor protokolu a konfigurační soubory podle kroku č. 2 nakopírujte soubor s heslem pro ovládací aplikaci Oa8.dat a případně i soubor určený aplikaci pro vzdálenou správu Rc8.dat (není nutné aby jej instalace obsahovala). Tyto soubory naleznete v adresáři, kam jste instalovali ochranný systém dle pokynů v bodu č. 3 tohoto postupu.
  5. Upravte konfigurační soubor Setup.ini. Jeho zdrojovou podobu naleznete na distribučním CD-ROM. Upravený soubor uložte do adresáře pro soubor protokolu a konfigurační soubory - tj. \\<localhost>\install_oa\log\setup.ini.

    Soubor Setup.ini je velmi dobře komentován. Řádky začínající středníkem jsou považovány za komentáře. V původním souboru Setup.ini jsou všechny záznamy se vzorovým nastavením (s výjimkou označení konfigurační sekce) zakomentovány. Nezapomeňte proto mimo správné nastavení jednotlivých konfiguračních voleb ze začátku příslušných řádků středníky odstranit.

    Po úpravě by soubor Setup.ini měl mít přibližně následující podobu:

    ;Konfigurační soubor pro vzdálenou instalaci ochranného systému OptimAccess verze 8.0
;
;Pokud chcete provést automatickou instalaci podle parametrů nastavených v tomto souboru
;spusťte program SETUP.EXE se jménem tohoto souboru. Pokud se soubor nenachází
;v adresáři, ze kterého se spouští program SETUP.EXE, pak uveďte celou cestu k tomuto
;INI souboru.
;

;Všechny parametry se nastavují v části [remote], nemusíte dodržovat velká a malá písmena.
[remote]

;AC - Aktivační kód, vložte kód z licenční karty
AC=879E5BA9C21DEC4

;DestPath - Cesta, do které se bude instalovat ochranný systém. implicitně je nastavena
;na C:\OA8. Cesta musí být na disk C a doporučujeme  ponechat adresář přímo v C:\
DestPath=C:\OA8

;SourcePath - z této cesty se budou kopírovat soubory ochranného systému
SourcePath=\\<localhost>\install_oa

;LogFile - plná cesta k souboru, do kterého se budou ukládat informace o provedených
;operacích. Soubor se ukládá v CSV formátu pro možnost prohlížení např. v MS-EXCEL.
;Doporučujeme ponechat příponu CSV.
LogFile=\\<localhost>\install_oa\log\oalog.csv

;OADAT - cesta k souboru OA8.DAT, ve kterém se nachází heslo pro použití programu OA8GUI.EXE,
;což je lokální ovládací prostředí ochranného systému.
OADAT=\\<localhost>\install_oa\log\oa8.dat

;RCDAT - cesta k souboru RC8.DAT, ve kterém můžete definovat výchozí heslo pro
;komunikaci mezi ovládací aplikací OARC a klientem vzdálené správy. Pokud není tento
;soubor definován, pak se nastaví prázdné komunikační heslo.
RCDAT=\\<localhost>\install_oa\log\rc8.dat

;StartMenu - pokud se rovná 1, pak se vytvoří v Nabídce Start odkaz na ochranný systém
;OptimAccess
StartMenu=1
  6. Síťovou hromadnou instalaci provedete na jednotlivých stanicích spuštěním souboru Setp.exe z adresáře s instalačními soubory, kterému zadáte jako parametr soubor Setup.ini.

    Instalujete-li podle tohoto postupu z jednotky CD-ROM, spustíte instalaci příkazem:
    \\<localhost>\cd\setup.exe \\<localhost>\install_oa\log\setup.ini
    Instalujete-li ze síťového adresáře, spustíte instalaci příkazem:
    \\<localhost>\install_oa\setup.exe \\<localhost>\install_oa\log\setup.ini
  7. Instalátor nyní nakopíruje na stanici všechny soubory ochranného systému OptimAccess, upraví konfiguraci stanice podle nastavení vzorové instalace a spustí na stanici klienta pro vzdálenou správu. Následně tedy můžete nastavovat ochranný systém OptimAccess přímo na stanici či prostřednictvím aplikace pro vzdálenou správu.


Upgrade ze starších verzí

Pro upgrade ze starších verzí ochranného systému OptimAccess výrobce doporučuje použít následující postup:

  1. Deaktivovat ochranný systém.
  2. Odinstalovat starou verzi ochranného systému.
  3. Instalovat novou verzi ochranného systému dle postupů uvedených pod heslem Instalace.
  4. Případně můžete vyladit konfiguraci ochranného systému dle rad a doporučení uvedených pod heslem Doporučený postup konfigurace.


Odborná pomoc

Zakoupením licence k používání aplikace OptimAccess získáváte rovněž nárok na odbornou pomoc od společnosti SODAT software spol. s r. o. Tato se vztahuje na dotazy a řešení problémů spojených s používáním ochranného systému OptimAccess.

Dříve než kontaktujete výrobce ...

Odpovědi na základní a běžné uživatelské otázky jsou uvedeny rovněž v této nápovědě. Prostředky vynaložené na telefon můžete ušetřit, jestliže se pokusíte odpověď na své otázky nejprve najít v heslech nápovědy.

  • Význam a nastavení jednotlivých funkcí ochranného systému je vysvětlen v heslech Ovládání aplikace ve Windows 9x/ME, Ovládání aplikace ve Windows NT/2000/XP a Nadstavbové moduly ochranného systému.
  • Rady a doporučení pro základní nastavení ochranného systému obsahuje heslo Doporučený postup konfigurace.
  • Informace o kolizích a řešení případných možných známých problémů jsou umístěny pod heslem Odstraňování problémů.

Jak získat odbornou pomoc?

Odbornou pomoc od společnosti SODAT software spol. s r. o. lze získat následujícími způsoby:

  • Základní odborné informace lze získat prostřednictvím WWW stránek věnovaných ochrannému systému OptimAccess na adrese http://www.optimaccess.cz/.
  • Svůj dotaz na oddělení technické podpory můžete zaslat prostřednictvím elektronické pošty na adresu support@optimaccess.cz.
  • Odpověď na své dotazy můžete také získat prostřednictvím telefonu přímo od pracovníka technické podpory a to na čísle +420 - 543 236 177 až 8; standardní bezplatná technická pomoc je výrobcem poskytována v pracovní dny (tj. v pondělí až pátek s výjimkou svátků) a to vždy od 8:00 do 16:30.
  • V případě zákazníků, kteří mají s výrobcem uzavřenu dodatečnou Servisní smlouvu o odborné pomoci a technické podpoře platí dále veškerá ustanovení v ní uvedená.

Jak kontaktovat výrobce?

S dalšími dotazy a náměty v souvislosti s ochranným systémem OptimAccess můžete společnost SODAT software spol. s r. o. kontaktovat následujícími způsoby:

  • Písemně na adresu: SODAT software spol. s r. o., Sedlákova 33, 602 00 BRNO.
  • Elektronickou poštou na adresu info@optimaccess.cz.
  • Telefonicky na čísle +420 - 543 236 177 až 8; v pracovní dny (tj. v pondělí až pátek s výjimkou svátků) a to vždy od 8:00 do 16:30.


Ovládání aplikace ve Windows 9x/ME

Ovládací aplikace se v operačním systému Windows 9x či Windows ME spouští prostřednictvím souboru OA8GUI.exe z adresáře, kde je instalován ochranný systém OptimAccess (základní nastavení pro instalaci je C:\OAx, kde x je číslo verze ochranného systému). Při instalaci je v nabídce Start systému Windows vytvořen odpovídající zástupce pojmenovaný OptimAccess. Ovládací aplikaci lze tedy spustit i následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.

Ovládání funkcí ochranného systému prostřednictvím aplikace

  • Postup pro aktivaci a deaktivaci ochranného systému naleznete pod heslem Aktivace a deaktivace ochranného systému.
  • Rady a postupy potřebné pro zálohu nastavení ochranného systému a následný import zálohy naleznete pod heslem Zálohování a obnova nastavení ochranného systému.
  • Popis náležitostí a požadavků pro správně zvolené heslo a postup pro jeho nastavení naleznete pod heslem Změna hesla pro přístup do ochranného systému.
  • Popis funkcí a ovládacích prvků pro jednotlivé moduly ochranného systému naleznete pod heslem Moduly ochranného systému.


Aktivace a deaktivace ochranného systému

Při aktivaci ovladačů se modifikuje zavaděč pevného disku tak, aby se v okamžiku spuštění počítače automaticky aktivovaly všechny nastavené ochranné funkce. Je-li systém OptimAccess aktivní, máte možnost jeho jednotlivé ochranné funkce přizpůsobovat vašim aktuálním požadavkům na ochranu počítače. Vzhledem k tomu, že systém pracuje se zavaděčem pevného disku, je pro aktivaci systému nutný restart počítače. Ten provedete stiskem tlačítka OK v dialogu zakončujícím aktivační proceduru.

V případě, že nejsou ve vnitřní paměti (RAM) počítače zavedeny ovladače nebo je ochranný systém právě nainstalován, se aktivační procedura vyvolá při každém spuštění aplikace OptimAccess (souborem OA8GUI.exe).

Aktivace ochranného systému při spuštění ovládací aplikace

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. Po zadání správného hesla pro přístup do ovládací aplikace zobrazí dialog oznamující, že ochranný systém je momentálně deaktivován. Stiskem tlačítka Ne můžete aktivaci odložit do okamžiku následujícího spuštění ovládací aplikace. Označením volby Příště tento dialog již nezobrazovat a stiskem tlačítka Ne odložíte aktivaci ochranného systému na později.
  4. Ochranný systém provede svou aktivaci zápisem do konfiguračních souborů operačního systému a systémových oblastí pevného disku. Pro úspěšnou aktivaci může být případně vyžadován restart počítače. Stiskem tlačítka OK provedete restart počítače.

Aktivace ochranného systému z ovládací aplikace

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Ochranný systém aktivujete stiskem na tlačítko Aktivovat ochranný systém ... v oblasti Stav systému OptimAccess.
  5. Při aktivaci máte možnost načíst nastavení funkcí ochranného systému ze souboru. V dialogu Aktivace ochranného systému označte stiskem myši volbu Načíst nastavení ochranného systému ze souboru. V dialogu Otevřít vylistujte příslušný soubor s nastavením.
  6. Ochranný systém provede svou aktivaci zápisem do konfiguračních souborů operačního systému a systémových oblastí pevného disku. Pro úspěšnou aktivaci může být případně vyžadován restart počítače. Stiskem tlačítka OK provedete restart počítače.

Deaktivace ochranného systému

Deaktivace ochranného systému OptimAccess má za následek odstranění aktivních ovladačů z vnitřní paměti (RAM) počítače. Výsledkem je vypnutí všech ochran realizovaných systémem OptimAccess. Funkce opět vyvolá dialog s informací o nutnosti provedení restartu počítače. Po restartu je váš systém zcela bez ochrany.

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Ochranný systém deaktivujete stiskem na tlačítko Deaktivovat ochranný systém ... v oblasti Stav systému OptimAccess.
  5. Hodláte-li opravdu ochranný systém deaktivovat potvrďte to v dialogu stiskem tlačítka Ano. Stiskem tlačítka Ne ukončíte plánovanou deaktivaci a systém zůstane aktivní.
  6. Při deaktivaci máte možnost uložit nastavení funkcí ochranného systému do souboru. V dialogu Deaktivace ochranného systému označte stiskem myši volbu Uložit nastavení ochranného systému do souboru. Do dialogu Uložit zadejte jméno příslušného souboru s nastavením.
  7. Ochranný systém provede svou deaktivaci zápisem do konfiguračních souborů operačního systému a systémových oblastí pevného disku. Pro úspěšnou deaktivaci je nutný restart počítače. Ovládací aplikace informuje o úspěšné deaktivaci ochranného systému dialogem Deaktivace systému. Stiskem tlačítka OK provedete restart počítače.

Příkaz je vhodný použít zejména při plánovaných rozsáhlých instalacích programového vybavení, které s sebou nesou nutnost větších zásahů do konfigurace operačního systému a aktualizovaných aplikací.


Zálohování a obnova nastavení ochranného systému

Záloha čerstvě instalovaného systému

Ihned po instalaci ochranného systému OptimAccess si proveďte zálohu základního nastavení. Využijete je například v případě rozsáhlejších instalací či případných updatů operačního systému. Více informací naleznete pod heslem Doporučený postup konfigurace.

Export nastavení do souboru

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Stiskněte tlačítko Exportovat nastavení do souboru ... pod oblastí Stav systému OptimAccess.
  5. V dialogu Export nastavení systému OptimAccess stiskněte tlačítko Nalistovat a v dialogu Otevřít vylistujte příslušný soubor pro uložení nastavením. V oblasti Soubor s nastavením bude obsahovat tyto části zvolte nastavení kterých modulů má být exportováno. Rovněž lze vyexportovat nastavení pro adresářovou strukturu.
  6. Po volbě souboru a nastavení exportu zahájíte export dat stiskem tlačítka OK. Zrušení exportu můžete provést tlačítkem Storno.

Import nastavení ze souboru

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Stiskněte tlačítko Importovat nastavení ze souboru ... pod oblastí Stav systému OptimAccess.
  5. V dialogu Otevřít vylistujte soubor s nastavením ochranného systému, které chcete importovat. Složku se souborem můžete vylistovat pomocí rozvíracího seznamu Oblast hledání či ji poklepáním v oblasti dialogu. Rovněž můžete jméno souboru včetně cesty zadat do pole Název souboru. V případě komplikací si neopomeňte zkontrolovat, zdali máte v seznamu Soubory typu: nastavený správný typ souboru.
  6. Po volbě souboru zahájíte import dat stiskem tlačítka OK. Zrušení exportu můžete provést tlačítkem Storno.


Změna hesla pro přístup do ochranného systému

Heslo nastavené pro ovládací aplikaci ochranného systému OptimAccess je vyžadováno při jeho každém spuštění. Bez jeho znalosti nelze ovládací aplikaci spustit.

Nastavení hesla pro spouštění ovládací aplikace

Se znalostí stávajícího hesla můžete nové heslo nastavit tímto způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. Z nabídky Správce zvolte příkaz Změna vstupního hesla ....
  4. V dialogu Změna hesla zadejte do textových polí Původní heslo, Nové heslo a Potvrzení nového hesla původní a vámi požadované heslo a stiskněte tlačítko OK.
  5. Zadali-li jste do obou polí s novým heslem stejný alfanumerický řetězec, systém změní přístupové heslo a informuje vás o tom dialogem Přístupové heslo OptimAccess s textem Heslo bylo změněno. Ukončete jej stiskem tlačítka OK. V případě, kdy se vámi zadané řetězce liší, informuje vás o této situaci systém dialogem Přístupové heslo OptimAccess s textem Potvrzené heslo je odlišné od hesla nového. Zadejte heslo znovu. Stiskněte tlačítko OK a pokračujte podle bodu č. 4.

Náležitosti a pravidla pro volbu hesla

Pro zadávání hesla platí následující omezení:

  • heslo se skládá z alfanumerických znaků;
  • heslo rozlišuje malá a velká písmena (vlastnost nazývaná též case-sensitivity);
  • nelze použít prázdné heslo, je nutné zadat minimálně jeden znak;
  • maximální délka hesla je omezena na 20 znaků.

Je vhodné volit heslo tak, aby jej potenciální útočnici nemohli snadno hádáním odhalit. Tudíž za heslo nevolte své křestní jméno, název firmy či jiné potenciálním útočníkům známé skutečnosti. Rovněž není vhodné používat hesla, která jsou snadno odhalitelné pomocí „slovníkového útoku“. Správné heslo by se mělo skládat přibližně z osmi náhodně zkombinovaných alfanumerických znaků.


Ovládání aplikace ve Windows NT/2000/XP

Ovládací aplikace se v operačním systému Windows 2000 a Windows NT spouští prostřednictvím souboru OA8GUI.exe z adresáře, kde je instalován ochranný systém OptimAccess (základní nastavení pro instalaci je C:\OAx, kde x je číslo verze ochranného systému). Při instalaci je v nabídce Start systému Windows vytvořen odpovídající zástupce pojmenovaný OptimAccess. Ovládací aplikaci lze tedy spustit i následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.

Ovládání funkcí ochranného systému prostřednictvím aplikace

  • Postup pro aktivaci a deaktivaci ochranného systému naleznete pod heslem Aktivace a deaktivace ochranného systému.
  • S principem logiky ochrany systémů Windows 2000 a Windows NT založeném na uživatelských účtech a jeho ovládání se seznámíte pod heslem Koncepce uživatelů.
  • Rady a postupy potřebné pro zálohu nastavení ochranného systému a následný import zálohy naleznete pod heslem Export a import nastavení ochranného systému.
  • Popis náležitostí a požadavků pro správně zvolené heslo a postup pro jeho nastavení naleznete pod heslem Změna hesla pro přístup do ovládacího prostředí.
  • Popis funkcí a ovládacích prvků pro jednotlivé moduly ochranného systému naleznete pod heslem Moduly ochranného systému.


Aktivace a deaktivace ochranného systému

Při aktivaci ovladačů se modifikuje zavaděč pevného disku tak, aby se v okamžiku spuštění počítače se automaticky aktivovaly všechny nastavené ochranné funkce. Je-li systém OptimAccess aktivní, máte možnost jeho jednotlivé ochranné funkce přizpůsobovat vašim aktuálním požadavkům na ochranu počítače. Vzhledem k tomu, že systém pracuje se zavaděčem pevného disku, je pro aktivaci systému nutný restart počítače. Ten provedete stiskem tlačítka OK v dialogu zakončujícím aktivační proceduru.

V případě, že nejsou ve vnitřní paměti (RAM) počítače zavedeny ovladače nebo je ochranný systém právě nainstalován, se aktivační procedura vyvolá při každém spuštění aplikace OptimAccess (souborem OA8GUI.exe).

Aktivace ochranného systému při spuštění ovládací aplikace

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. Po zadání správného hesla pro přístup do ovládací aplikace zobrazí dialog oznamující, že ochranný systém je momentálně deaktivován. Stiskem tlačítka Ne můžete aktivaci odložit do okamžiku následujícího spuštění ovládací aplikace. Označením volby Příště tento dialog již nezobrazovat a stiskem tlačítka Ne odložíte aktivaci ochranného systému na později.
  4. Ochranný systém provede svou aktivaci zápisem do konfiguračních souborů operačního systému a systémových oblastí pevného disku. Pro úspěšnou aktivaci může být případně vyžadován restart počítače. Stiskem tlačítka OK provedete restart počítače.

Aktivace ochranného systému z ovládací aplikace

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Ochranný systém aktivujete stiskem na tlačítko Aktivovat ochranný systém ... v oblasti Stav systému OptimAccess.
  5. Při aktivaci máte možnost načíst nastavení funkcí ochranného systému ze souboru. V dialogu Aktivace ochranného systému označte stiskem myši volbu Načíst nastavení ochranného systému ze souboru. V dialogu Otevřít vylistujte příslušný soubor s nastavením.
  6. Ochranný systém provede svou aktivaci zápisem do konfiguračních souborů operačního systému a systémových oblastí pevného disku. Pro úspěšnou aktivaci může být případně vyžadován restart počítače. Stiskem tlačítka OK provedete restart počítače.

Deaktivace ochranného systému

Deaktivace ochranného systému OptimAccess má za následek odstranění aktivních ovladačů z vnitřní paměti (RAM) počítače. Výsledkem je vypnutí všech ochran realizovaných systémem OptimAccess. Funkce opět vyvolá dialog s informací o nutnosti provedení restartu počítače. Po restartu je váš systém zcela bez ochrany.

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Ochranný systém deaktivujete stiskem na tlačítko Deaktivovat ochranný systém ... v oblasti Stav systému OptimAccess.
  5. Hodláte-li opravdu ochranný systém deaktivovat potvrďte to v dialogu stiskem tlačítka Ano. Stiskem tlačítka Ne ukončíte plánovanou deaktivaci a systém zůstane aktivní.
  6. Při deaktivaci máte možnost uložit nastavení funkcí ochranného systému do souboru. V dialogu Deaktivace ochranného systému označte stiskem myši volbu Uložit nastavení ochranného systému do souboru. Do dialogu Uložit zadejte jméno příslušného souboru s nastavením.
  7. Ochranný systém provede svou deaktivaci zápisem do konfiguračních souborů operačního systému a systémových oblastí pevného disku. Pro úspěšnou deaktivaci je nutný restart počítače. Ovládací aplikace informuje o úspěšné deaktivaci ochranného systému dialogem Deaktivace systému. Stiskem tlačítka OK provedete restart počítače.

Příkaz je vhodný použít zejména při plánovaných rozsáhlých instalacích programového vybavení, které s sebou nesou nutnost větších zásahů do konfigurace operačního systému a aktualizovaných aplikací.


Koncepce uživatelů

S použitím bezpečnostní politiky operačních systémů Windows NT, Windows 2000 a Windows XP máte možnost nastavovat jednotlivá omezení ochranného systému OptimAccess na úrovni globálního nastavení stanice, nastavení skupin a nastavení jednotlivých uživatelských účtů. V tomto uvedeném pořadí se aplikuje nastavení jednotlivých funkcí ochranného systému OptimAccess.

Po spuštění ovládací aplikace tedy poklepáním na ikonu plus vedle síťového jména počítače ( [image]) vylistujete globálního nastavení stanice, seznam všech skupin a seznam všech uživatelských účtů. Jednotlivé typy nastavení jsou graficky odlišeny:

  • Globální nastavení stanice – je obecně platná sada nastavení ochranných funkcí systému pro konkrétní počítač či pracovní stanici. Toto nastavení je platné pro všechny skupiny a uživatele, pokud nemají své vlastní individuální nastavení.
  • Individuální nastavení uživatelů – obsahuje všechny uživatelské účty dostupné na počítači či pracovní stanici. Jsou zde rovněž obsaženy všechny doménové účty, po něž jsou na stanici vytvořeny profily.
  • Skupiny – obsahuje všechny účty skupin dostupné na počítači či pracovní stanici.

Stiskem na ikonu plus vedle příslušné volby vylistujete seznam modulů, které máte možnost nastavovat. Příslušné ovládací prvky pro nastavování jednotlivých voleb naleznete v pravém okně ovládací aplikace.

Chcete-li nastavovat ochranné funkce na úrovni jednotlivých skupin či uživatelských účtů, je vždy třeba v pravém okně ovládací aplikace po vylistování příslušného účtu označit volbu Individuální nastavení. Není-li tato volba označena, jsou všechny ovládací prvky v pravém okně dočasně nepřístupné.

Specifika účtu „Nový uživatel“ či „Default user“

Ačkoliv je účet „Nový uživatel“ (či „Default user“ na anglických mutacích systému) vedený jako běžný uživatelský účet, vyznačuje se jednou specifickou vlastností. Vytváříte-li v systému nového uživatele, základní nastavení nového uživatelského účtu bude okopírováno dle nastavení tohoto účtu.


Export a import nastavení ochranného systému

Záloha čerstvě instalovaného systému

Ihned po instalaci ochranného systému OptimAccess si proveďte zálohu základního nastavení. Využijete je například v případě rozsáhlejších instalací či případných updatů operačního systému. Více informací naleznete pod heslem Doporučený postup konfigurace.

Export nastavení do souboru

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Stiskněte tlačítko Exportovat nastavení do souboru ... pod oblastí Stav systému OptimAccess.
  5. V dialogu Export nastavení systému OptimAccess stiskněte tlačítko Nalistovat a v dialogu Otevřít vylistujte příslušný soubor pro uložení nastavením. V oblasti Soubor s nastavením bude obsahovat tyto části zvolte nastavení kterých modulů má být exportováno. Rovněž lze vyexportovat nastavení pro adresářovou strukturu.
  6. Po volbě souboru a nastavení exportu zahájíte export dat stiskem tlačítka OK. Zrušení exportu můžete provést tlačítkem Storno.

Import nastavení ze souboru

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace stiskem myši označte počítač Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Stiskněte tlačítko Importovat nastavení ze souboru ... pod oblastí Stav systému OptimAccess.
  5. V dialogu Otevřít vylistujte soubor s nastavením ochranného systému, které chcete importovat. Složku se souborem můžete vylistovat pomocí rozvíracího seznamu Oblast hledání či ji poklepáním v oblasti dialogu. Rovněž můžete jméno souboru včetně cesty zadat do pole Název souboru. V případě komplikací si neopomeňte zkontrolovat, zdali máte v seznamu Soubory typu: nastavený správný typ souboru.
  6. Po volbě souboru zahájíte import dat stiskem tlačítka OK. Zrušení exportu můžete provést tlačítkem Storno.


Změna hesla pro přístup do ovládacího prostředí

Heslo nastavené pro ovládací aplikaci ochranného systému OptimAccess je vyžadováno při jeho každém spuštění. Bez jeho znalosti nelze ovládací aplikaci spustit.

Nastavení hesla pro spouštění ovládací aplikace

Se znalostí stávajícího hesla můžete nové heslo nastavit tímto způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. Z nabídky Správce zvolte příkaz Změna vstupního hesla ....
  4. V dialogu Změna hesla zadejte do textových polí Původní heslo, Nové heslo a Potvrzení nového hesla původní a vámi požadované heslo a stiskněte tlačítko OK.
  5. Zadali-li jste do obou polí s novým heslem stejný alfanumerický řetězec, systém změní přístupové heslo a informuje vás o tom dialogem Přístupové heslo OptimAccess s textem Heslo bylo změněno. Ukončete jej stiskem tlačítka OK. V případě, kdy se vámi zadané řetězce liší, informuje vás o této situaci systém dialogem Přístupové heslo OptimAccess s textem Potvrzené heslo je odlišné od hesla nového. Zadejte heslo znovu. Stiskněte tlačítko OK a pokračujte podle bodu č. 4.

Náležitosti a pravidla pro volbu hesla

Pro zadávání hesla platí následující omezení:

  • heslo se skládá z alfanumerických znaků;
  • heslo rozlišuje malá a velká písmena (vlastnost nazývaná též case-sensitivity);
  • nelze použít prázdné heslo, je nutné zadat minimálně jeden znak;
  • maximální délka hesla je omezena na 20 znaků.

Je vhodné volit heslo tak, aby jej potenciální útočnici nemohli snadno hádáním odhalit. Tudíž za heslo nevolte své křestní jméno, název firmy či jiné potenciálním útočníkům známé skutečnosti. Rovněž není vhodné používat hesla, která jsou snadno odhalitelné pomocí „slovníkového útoku“. Správné heslo by se mělo skládat přibližně z osmi náhodně zkombinovaných alfanumerických znaků.


Moduly ochranného systému

V rámci modulárního pojetí ochranného systému OptimAccess je možné zvolit si funkce na míru dle vašich konkrétních požadavků. Máte možnost využít modulů:

  • OptimAccess Standard - slouží pro základní zabezpečení programů a operačního systému instalovaného na pracovní stanici. Nabízí funkce pro ochranu adresářové struktury, ochranu nastavení operačního systému Windows, zamezení instalace programů a přístupu k souborům, zákaz manipulace a vytváření konkrétních souborů či typů a kontrolu manipulace s výměnnými médii. Uplatnění modulu je všude tam, kde počítače sdílí více uživatelů či jsou nutné jejich časté reinstalace z důvodu neautorizovaných zásahů do nastavení a úprav programového vybavení.
  • OptimAccess Extension - rozšiřuje ochranné funkce modulu Standard v oblastech operačního systému Windows (Ovládací panely, Průzkumník a složky, nastavení uživatelských aplikací a bezpečnostní funkce). Nabízí pokročilé ochranné funkce i pro aplikační vybavení počítače a zohledňuje bezpečnostní rozměr kontroly správného využívání hesel.
  • OptimAccess Remote Control - je nástroj pro administraci, konfiguraci a centrální správu ochranného systému. Umožňuje vzdáleně sledovat a upravovat nastavení jednotlivých koncových stanic i celých skupin počítačů. Kopíruje topologii sítě a nabízí možnost řazení počítačů do skupin v Databázi okolních počítačů. Prostřednictvím přehledného grafického rozhraní lze rychle a efektivně sledovat i nastavovat desítky, stovky či tisíce instalací systému na koncových stanicích. Přínosem je také možnost časového plánování těchto akcí.
  • OptimAccess Computer Audit - umožňuje evidenci a sledování programového vybavení počítače. Nabízí pokročilé funkce pro monitorování okamžitého stavu programového vybavení počítače, kontrolu jednotlivých softwarových balíků a vygenerování výsledných tiskových sestav. Představuje účinný nástroj pro kontrolu stavu programového vybavení počítačů a počtu instalovaných licencí vybraného software v organizaci.
  • OptimAccess WorkSpy - eviduje a sleduje využití počítače a pracovního času stráveného u počítače. Nabízí monitorovací funkce ke sledování základních operací s počítačem, událostí v rámci operačního systému, souborového systému a práce s Internetem. Výstupy z jednotlivých monitorovacích funkcí lze prohlížet, exportovat do souboru či generovat ve formě tiskových sestav v rámci daných časových období. Představuje účinný nástroj pro kontrolu využívání počítače a pracovního času zaměstnanců.


OptimAccess Standard

Modul slouží pro základní zabezpečení programů a operačního systému instalovaného na pracovní stanici. Nabízí tyto funkce:

  • Ochrana adresářové struktury – jednotlivé složky lze nastavit jako neporušitelné (vždy se uvádějí do původního stavu) či s právem pouze ke čtení.
  • Ochrana nastavení operačního systému Windows – uživateli lze znepřístupnit jednotlivé Ovládací panely.
  • Komplexní ochrana registrační databáze – při restartu počítače se veškerá nastavení uvádí zpět do předem definovaného stavu.
  • Zamezení instalace programů a přístupu k instalačním souborům – není možné spuštění instalačních programů.
  • Zákaz manipulace a vytváření konkrétních souborů či typů (*.exe, *.com, *.bat, *.vbs, *.dll)
  • Kontrola manipulace s výměnnými médii – lze definovat které výměnné disky (CD, ZIP, FDD,...) se mohou na počítači použít.

Uplatnění modulu OptimAccess Standard je všude tam, kde počítače sdílí více uživatelů či jsou nutné jejich časté reinstalace z důvodu neautorizovaných zásahů do nastavení a úprav programového vybavení.

Ovládání ve Windows 9x

V prostředí Windows 9x se modul Standard ovládá prostřednictvím aplikace OptimAccess následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace poklepáním myši označte počítač a rozbalte ikonu Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Poklepáním myši na položce Standard vylistujete jednotlivé volby a nastavení modulu OptimAccess Standard.

Ovládání ve Windows NT, 2000 a XP

V prostředí Windows NT, Windows 2000 a Windows XP se modul Standard pro konkrétního uživatele ovládá pomocí nabídky Standard v pravém okně ovládací aplikace. Vyvoláte ji následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně si stiskem na ikonu plus před jménem počítače vylistujte seznam možných úrovní, na nichž je možné funkce ochranného systému nastavovat – globální nastavení stanice, seznam skupin a uživatelských účtů.
  4. Zvolte příslušnou úroveň nastavení na níž chcete provádět úpravy nastavení a stiskem na příslušející ikonu plus vylistujte moduly jejichž volby máte možnost nastavovat.
  5. Z vylistovaného seznamu označte volbu Standard. Pravé okno ovládací aplikace změní svoji podobu a máte v něm možnost pracovat s modulem Standard.

Volby modulu Standard

  • Výměnná média
  • Obnova adresářů a souborů
  • Omezení přístupu k souborům
  • Omezení přístupu k adresářům
  • Ovládací panely
  • Komplexní ochrana nastavení
  • Adresářová struktura


Manipulace s výměnnými médii

Ochranný systém nabízí zákaz používání jednotlivých typů výměnných zařízení. Prostřednictvím volby Zakázat použití máte možnost zakázat používat:

  • disketové mechaniky;
  • CD-ROM mechaniky;
  • jiná výměnná média (pouze platforma NT/2000/XP);
  • systém souborů FAT (pouze platforma NT/2000/XP).

Dále můžete uživateli povolit přístup pouze k vybraným CD-ROM diskům prostřednictvím jejich identifikace na základě názvu.

Na platformě 9x/ME lze kontrolovat, aby byly v mechanice počítače používány pouze autorizované diskety. Pokud disketa není autorizována je její použití vyloučeno. Nelze z ní číst ani na ni ukládat data. Tímto způsobem lze omezit pohyb disket na pracovišti. Lze takto chránit počítač i před boot viry, ale to pouze za předpokladu, kdy má správce dokonalý přehled a kontrolu nad pohybem autorizovaných disket. Do jisté míry lze tuto funkci přirovnat jako ekvivalent zámků na disketových mechanikách nebo fyzického odpojení disketových mechanik. Funkci je vhodné aktivovat zejména v případě školských zařízeních, kdy chce správce sítě maximálně uplatnit restrikce platné na daných počítačích.

Zákaz používání určitého typu výměnných zařízení

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Výměnná média.
  2. V pravém okně ovládací aplikace máte možnost prostřednictvím volby Zakázat použití znemožnit uživateli práci s vybranými druhy výměnných médií.
  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se ochranný systém bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.

Povolení CD-ROM s určitými názvy

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Výměnná média.
  2. V pravém okně ovládací aplikace máte možnost prostřednictvím tlačítek Přidat a Odebrat upravovat seznam názvu CD-ROM médiím které má uživatel právo používat. Stiskem tlačítka Přidat vyvoláte dialog Povolení CD podle názvu, kam můžete zadat patřičné jméno a potvrdit je stiskem tlačítka OK.
  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se ochranný systém bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.

Autorizace disket a její rušení

Autorizace disket probíhá speciálním záznamem mimo běžnou datovou oblast. Proto nelze autorizaci kopírovat. Rovněž ji nelze zrušit formátováním. S disketou lze pracovat bez jakýchkoliv omezení – lze z ní číst, zapisovat, mazat, formátovat, měnit její jméno a podobně. Proces autorizace i její následné rušení se nijak nedotýká datové oblasti diskety. Proto lze autorizovat i rušit autorizaci disket, aniž by se to jakkoliv dotýkalo dat na ní uložených.

Autorizace diskety pro použití

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Výměnná média.
  2. V pravém okně ovládací aplikace stiskněte tlačítko Autorizovat disketu A:.
  3. O průběhu autorizace vás bude systém informovat dialogem Probíhá autorizace....
  4. O úspěšném ukončení procesu autorizace vás systém informuje dialogem Autorizace s textem Disketa byla autorizována!. Proces autorizace dokončíte stiskem tlačítka OK.

Rušení autorizace diskety pro použití

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Výměnná média.
  2. V pravém okně ovládací aplikace stiskněte tlačítko Zrušit autorizaci na disketě A:.
  3. O průběhu autorizace vás bude systém informovat dialogem Probíhá rušení autorizace....
  4. O úspěšném ukončení procesu autorizace vás systém informuje dialogem Zrušení autorizace s textem Disketě byla zrušena autorizace!. Proces rušení autorizace dokončíte stiskem tlačítka OK.


Koncepce obnovy souborů dle vzoru

Obnova souborů a adresářů funguje na principu záložních kopií vzorového nastavení. Při startu systému jsou vždy smazány chráněné adresáře a soubory a jsou nahrazeny ze záložních kopií. Tuto funkci je vhodné používat obzvláště pro pracovní adresáře aplikací, které ukládají uživatelská data a měly by vždy mít stejné základní nastavení.

Obnova adresářů

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Obnova souborů.
  2. Pro nastavení obnovy adresářů slouží horní polovina pravého ovládacího okna. Nastavení pro adresáře se týká části Chráněné adresáře. Pro manipulaci s chráněnými adresáři slouží tlačítka:
    • Přidat pro zadávání nových chráněných adresářů;
    • Odebrat pro odstraňování adresářů ze seznamu;
    • Upravit pro změny ve stávajícím nastavení.
    Stiskem tlačítek Přidat a Upravit zobrazíte dialog Obnova adresářů. V něm máte možnost prostřednictvím tlačítka Změnit nadefinovat Chráněný adresář a jemu příslušející Vzorový adresář.

    Dále můžete prostřednictvím volby Vytvořit obraz již existujícího adresáře nakopírovat aktuální stav chráněného adresáře do záložního vzorového adresáře. V případě adresářů máte dále možnost obnovovat i vnořené podadresáře označením volby Obnovovat i podadresáře.

    Nastavené změny aktivujete stiskem tlačítka OK.
  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se ochranný systém bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.

Obnova souborů

Obnova souborů se provádí analogicky k výše uvedenému postupu s tím rozdílem, že pracujete s ovládacími prvky ve spodní části pravého okna.


Omezení přístupu k souborům

Máte možnost zakázat jednotlivým uživatelům manipulovat s vybranými typy souborů, instalování nových programů a povolit spouštění pouze těch souborů, které jsou umístěny v definovaných složkách.

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Omezení přístupu k souborům.
  2. V pravém okně ovládací aplikace máte možnost voleb:
    • Základní ochrana před instalací nových aplikací – zabraňuje uživateli v manipulaci se soubory, jejichž názvy obsahují klíčová slova setup či install. Uživatel nemá oprávnění ani ke čtení takto pojmenovaných souborů, tudíž je nemůže přejmenovat a spustit pod jiným názvem.
    • Ochrana přístupu k souborům – soubory lze chránit na dvou úrovních. Jednak je možno zamezit čtení souboru na základě rozlišení typu na úrovni přípony. Seznam přípon souborů k nimž nemá uživatel právo přístupu je vylistován v okně Znemožnit přístup k souborům s těmito názvy. Rovněž je možno zamezit zápisu do souboru na základě rozlišení typu na úrovni přípony. Seznam přípon souborů k nimž nemá uživatel právo zápisu je vylistován v okně Znemožnit změnu obsahu a vytváření souborů s těmito názvy. Oba seznamy lze upravovat po stisku příslušného tlačítka Změnit ....
    • Povolit přístup k .exe a .dll souborům pouze z adresáře Program Files a systémového adresáře – lze zakázat spouštění souborů z jiných než vymezených složek. Seznam uživatelských složek z nichž je možno spouštět programy je obsažen v okně Povolit přístup také v těchto adresářích. Lze jej upravovat po stisku tlačítka Změnit ....
  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se ochranný systém bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.


Omezení přístupu k adresářům

Máte možnost zakázat jednotlivým uživatelům manipulovat s vybranými složkami.

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Omezení přístupu k adresářům.
  2. Pro nastavení omezení přístupu k systémovým adresářům slouží horní polovina pravého okna ovládací aplikace. Lze zakázat přístup k těmto složkám:
    • Program Files – základní adresář pro instalaci programů, obsažený v kořenovém adresáři disku s instalací systému Windows.
    • Nabídka Start – adresář s položkami nabídky Start, obsažený ve složce systému Windows a uživatelském profilu.
    • Windows 2000 (WINNT) – základní adresář s instalací operačního systému, obsažený v kořenovém adresáři disku s instalací systému Windows.
    • Pracovní plocha – adresář s položkami Pracovní plochy, obsažený ve složce systému Windows a uživatelském profilu.
    Pro nastavení omezení přístupu k uživatelským složkám slouží volba vybrané adresáře v dolní polovině pravého okna ovládací aplikace. Je zde vylistován seznam složek, k nimž je aktuálně zakázán přístup. Změnu nastavení v rámci uživatelských složek lze provádět po stisku tlačítka Změnit ....
  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se ochranný systém bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.


Ovládací panely

Máte možnost zakázat jednotlivým uživatelům manipulovat s vybranými Ovládacími panely následujícím postupem:

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Ovládací panely.
  2. V pravém okně ovládací aplikace máte možnost prostřednictvím oken Povoleno a Zakázáno nastavovat oprávnění k použití jednotlivých Ovládacích panelů. Označte stiskem myši zvolený Ovládací panel a stiskem tlačítek Zakázat >> respektive Povolit >> (v závislosti na tom, zdali se panel momentálně vyskytuje v okně Povoleno respektive Zakázáno) nastavte příslušné oprávnění.
  3. Aktivaci provedených změn provedete stiskem tlačítka Použít. V případě že tak neučiníte se ochranný systém bude dožadovat potvrzení provedených změn v okamžiku kdy přepnete jiný ovládací prvek v levém okně či se pokusíte aplikaci ukončit.


Komplexní ochrana nastavení

Při každém startování Windows se přepíše registrační databáze v adresáři Windows původní zálohovanou databází bezpečně uloženou v adresáři do, kterého jste instalovali systém OptimAccess. Jedná se konkrétně o soubory system.dat a user.dat.

Funkce využijete v případě, kdy je potřeba zajistit absolutní neměnnost nastavení Windows a to včetně nastavení ikon, tapety, komunikačních prostředků, driverů a dalších nastavení. Ideální řešení v učebnách firem, školských zařízeních, internetových kavárnách. Všeobecně na místech s přístupem mnoha těžko neidentifikovatelných lidí k jednomu nedefinovanému počítači.

Nastavení ochrany Registrační databáze

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Komplexní ochrana nastavení.
  2. V pravém okně ovládací aplikace označte volbu Komplexní ochrana Registrační databáze a stiskněte tlačítko Použít.
  3. Systém vám úspěšnou aktivaci ochrany oznámí dialogem Ochrana registrační databáze byla instalována. Ukončete jej stiskem tlačítka OK.

Zrušení ochrany Registrační databáze

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Komplexní ochrana nastavení.
  2. V pravém okně ovládací aplikace zrušte označení volby Komplexní ochrana Registrační databáze a stiskněte tlačítko Použít.
  3. Systém vám úspěšnou deaktivaci ochrany oznámí dialogem Ochrana registrační databáze byla odinstalována. Ukončete jej stiskem tlačítka OK.

Aktualizace Registrační databáze

Příkaz Aktualizace Registrační databáze v podstatě zkopíruje soubory user.dat a system.dat do adresáře kam jste instalovali OptimAccess, čímž přepíše soubory s dřívější zálohou. Aktualizuje jejich podobu dle nejnovějších změn provedených ve Windows. Funkce může vyžadovat RESTART z důvodu načtení posledních modifikací provedených v Registrační databázi.

  1. Vylistujte v levém okně ovládací aplikace modul Standard pro lokální stanici či příslušného uživatele. Stiskem na ikonu plus vylistujte seznam voleb a označte ikonu Komplexní ochrana nastavení.
  2. V pravém okně ovládací aplikace stiskněte tlačítko Aktualizovat.
  3. Systém vám úspěšnou deaktivaci ochrany oznámí dialogem Aktualizace proběhla úspěšně. Ukončete jej stiskem tlačítka OK.
Jedná se o řešení k aktualizaci minoritních změn v Registrační databázi v rámci Windows. V případě provedení rozsáhlejších změn (rozsáhlé instalace, update operačního systému a podobně) je vhodnější deaktivovat ochranný systém.


Adresářová struktura

Pro systémy Windows 9x a Windows ME máte možnost pro jednotlivé složky a soubory na disku nastavovat přístupová práva obdobně jako v systémech na platformě NT/2000/XP.

Manipulace s ochranou složek

Ochranu složek adresářové struktury lze nastavovat pouze v levém okně aplikace OptimAccess. V pravém okně aplikace se při označení složky stisknutím myši vylistuje pouze v ní obsažené soubory, nikoliv adresáře. Ty vylistujete v levém okně stiskem na ikonu plus ( [image]) příslušející k dané složce.

Příznak ochrany složky nastavíte pomocí dialogu Nastavení příznaku složky. Ten pro danou složku vyvoláte poklepáním na její ikonu. Ochrana všech souborů a složek nacházející se na pevném disku počítače s parametrem může mít následující úrovně dle nastavených příznaků:

  • RW (složka pro čtení a zápis)
    Se složkou je možné běžně pracovat bez jakýchkoliv omezení
  • RO (složka pouze pro čtení)
    Ze složky lze pouze číst data. Nelze ji žádným způsobem smazat ani upravit (přejmenovat, změnit její příznaky a podobně).
  • HI (skryté složky resp. zakázané k použití)
    Do takto označené složky bude zakázán přístup. POZOR! Přístup je zakázán i na systémové úrovni a proto s takto zabezpečenou složkou nebude možné žádným způsobem pracovat. Vhodné pro nastavení složek s obsahem instalačních souborů, které systémový správce využívá spíše příležitostně a v delším časovém horizontu.

Mimo příznak složky lze v dialogu Nastavení příznaku složky prostřednictvím voleb dále nastavit:

  • totožnou ochranu pro všechny podsložky označením volby Podsložky dědí příznak;
  • totožnou ochranu pro všechny soubory dané složky označením volby Soubory dědí příznak složky.

Manipulace s ochranou souborů

Ochranu souborů lze mimo výše popsaný případ, kdy soubory dědí nastavení složky nastavovat výlučně v pravém okně. Nastavení lze provádět dvěma způsoby:

  • poklepáním na daný soubor lze střídavě přepínat mezi nastavením příznaku RW a RO;
  • hromadně pomocí masky - stiskem pravého tlačítka myši na jménu souboru vyvoláte dialog Maska příznaku souborů, do textového pole pomocí hvězdičkové konvence uvedete vámi požadovaný výběr jmen souborů a stiskem tlačítek Nastav RO respektive Nastav RW nastavíte požadovaný příznak.


OptimAccess Extension

Modul OptimAccess Extension rozšiřuje ochranné funkce OptimAccess Standard v těchto oblastech operačního systému Windows:

  • Ovládací panely – je možné uživateli zakázat manipulaci s jednotlivými volbami v rámci Ovládacích panelů Síť, Hesla, Tiskárny, Systém, Obrazovka.
  • Průzkumník a složky – lze omezit používání jednotlivých voleb v rámci nabídky Start, Plochy, Průzkumníka, nastavení vlastností složek a používaných logických diskových jednotek.
  • Nastavení uživatelských aplikací – funkce umožňují zachovat klíčové volby pro aplikace MS Internet Explorer, MS Word, MS Excel, MS Outlook a MS Outlook Express. Dále je možné zakázat přístup k přílohám v elektronické poště a řídit aplikace přístupné pro uživatele.
  • Bezpečnost – lze zamezit úpravám registrační databáze, softwarovému vypnutí počítače a kontrolovat parametry a využívání hesel v rámci Windows.

Přínosem modulu OptimAccess Extension jsou pokročilé ochranné funkce. Rozšiřuje ochranu i na aplikační vybavení počítače a zohledňuje bezpečnostní rozměr kontroly správného využívání hesel.

Ovládání ve Windows 9x

V prostředí Windows 9x se modul Extension ovládá prostřednictvím aplikace OptimAccess následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace poklepáním myši označte počítač a rozbalte ikonu Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Poklepáním myši na položce Extension vylistujete jednotlivé volby a nastavení modulu OptimAccess Extension.

Ovládání ve Windows NT, 2000 a XP

V prostředí Windows NT, Windows 2000 a Windows XP se modul Extension pro konkrétního uživatele ovládá pomocí nabídky Extension v pravém okně ovládací aplikace. Vyvoláte ji následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně si stiskem na ikonu plus před jménem počítače vylistujte seznam možných úrovní, na nichž je možné funkce ochranného systému nastavovat – globální nastavení stanice, seznam skupin a uživatelských účtů.
  4. Zvolte příslušnou úroveň nastavení na níž chcete provádět úpravy nastavení a stiskem na příslušející ikonu plus vylistujte moduly jejichž volby máte možnost nastavovat.
  5. Z vylistovaného seznamu označte volbu Extension. Pravé okno ovládací aplikace změní svoji podobu a máte v něm možnost pracovat s modulem Extension.

Volby modulu Extension

  • Ovládací panely
  • Průzkumník a složky
  • Nastavení aplikací
  • Bezpečnost


Ovládací panely

Karta Síť

  • označením volby Odstranit složku "Celá síť" z menu okolní počítače skryjete ikonu Celá síť z dialogového okna Okolní počítače
  • označením volby Skryj záložku Identifikace v Ovládacích panelech -> Síť skryjete kartu Identifikace v dialogovém okně Síť
  • označením volby Skryj ikonu okolní počítače (Ikona okolní počítače je automaticky instalována při instalaci sítě) skryje ikonu Okolní počítače z pracovní plochy
  • označením volby Uživatel nemůže vytvářet, rušit a měnit sdílení souborů a tiskáren zakážete uživateli měnit nastavení sdílení souborů a tiskáren prostřednictvím dialogu Sdílení souborů a tiskáren (tedy uživatel nemůže zasahovat do konkrétního správcem provedeného nastavení)
  • označením volby Skryj záložku Řízení přístupu v Ovládacích panelech -> Síť skryjete kartu Řízení přístupu v dialogovém okně Síť

Karta Hesla

  • označením volby Záložka Vzdálená správa skryjete kartu Vzdálená správa v dialogovém okně Hesla - vlastnosti
  • označením volby Záložka Změnit hesla skryjete kartu Změnit hesla v dialogovém okně Hesla - vlastnosti
  • označením volby Záložka Profily uživatelů skryjete kartu Profily uživatelů v dialogovém okně Hesla - vlastnosti

Karta Tiskárny

  • označením volby Přidání tiskárny znemožníte uživateli přidat tiskárnu do systému
  • označením volby Odebrání tiskárny znemožníte uživateli odebrat tiskárnu ze systému
  • označením volby Záložka Podrobnosti tiskárny znemožníte uživateli nastavovat systémové parametry tiskárny prostřednictvím dialogu <jméno tiskárny> - vlastnosti (tj. uživatel nemůže měnit systémové nastavení tiskárny jako jsou port tiskárny, ovladač, řazení tiskových úloh a podobně)

Karta Systém

  • označením volby Virtuální paměť skryjete tlačítko Virtuální paměť... na kartě Výkon v dialogovém okně Systém - vlastnosti
  • označením volby Hardwarové profily skryjete kartu Hardwarové profily v dialogovém okně Systém - vlastnosti
  • označením volby Systém souborů skryjete tlačítko Systém souborů... na kartě Výkon v dialogovém okně Systém - vlastnosti
  • označením volby Správce zařízení skryje kartu Správce zařízení v dialogovém okně Systém - vlastnosti

Karta Obrazovka

První volba se týká nastavení závislého na hardwarové konfiguraci počítače, ostatní tři volby jsou pouze možnosti uživatelského přizpůsobení operačního systému.

  • označením volby Skryj záložku nastavení skryjete kartu Nastavení v dialogovém okně Obrazovka - vlastnosti (uživatel nebude moci měnit nastavení, která vyžadují případné opravy od správce; jako například nastavení ovladače grafické karty, typ monitoru, obnovovací frekvenci monitoru a podobně)
  • označením volby Skryj záložku Pozadí skryjete kartu Pozadí v dialogovém okně Obrazovka - vlastnosti
  • označením volby Skryj záložku Šetřič obrazovky skryjete kartu Šetřič obrazovky v dialogovém okně Obrazovka - vlastnosti
  • označením volby Skryj záložku Vzhled skryjete kartu Vzhled v dialogovém okně Obrazovka - vlastnosti


Průzkumník a složky

Karta Nabídka Start

  • označením volby Ovládací panely a tiskárny odeberete příkazy Tiskárny a Ovládací panely z nabídky Nastavení v hlavní nabídce Start systému Windows
  • označením volby Příkaz spustit odeberete příkaz Spustit z nabídky Start systému Windows
  • označením volby Příkaz najít odeberete příkaz Najít z nabídky Start systému Windows

Karta Diskové jednotky

V rámci karty Diskové jednotky máte možnost zakázat na počítači použití stanovených logických jednotek. Zákaz použití pro vybrané logické jednotky nastavíte označením voleb v rozsahu A až Z. Ochrannému systému je úplně jedno, zdali se jedná o disketovou jednotku, pevný disk, síťový disk, CD-ROM, ZIP , JAZZ nebo jiné diskové médium.

Nastavení jsou platná pouze pro ovládací rozhraní operačního systému a jim příslušné aplikace (Průzkumník, MS Internet Explorer). V souborových manažerech (například Windows Commander) jsou tyto jednotky přístupné. Rovněž nelze skrývat jednotku, která je sdílena (případně jejíž část je sdílena).

Karta Plocha

  • označením volby Skryj všechny ikony na ploše skryjete všechny ikony na pracovní ploše
  • označením volby Zakázat změnu nastavení Active Desktop zakážete změnu nastavení v rámci Systému Active Desktop
  • po označení volby Obnovit nastavení Tapety plochy po restartu počítače se po každém restartu Windows se obnoví vaše původní nastavení tapety Windows, které bylo použito v okamžiku aktivace této volby (nastavení tapety nelze měnit ani z jiných aplikací či nabídek)
  • po označení volby Obnovit nastavení Vzhledu po restartu počítače se po každém restartu obnoví původní nastavení vzhledu Průzkumníka (vzhledu oken - jako například barvy oken, použité fonty v oknech), které bylo použito v okamžiku aktivace této volby

Karta Průzkumník

  • označením volby Zakázat volbu možnosti úplně znemožníte vstup do nastavování vzhledu aplikace Průzkumník
  • označením volby Zobrazení ikony "připojení síťové jednotky" zakážete uživatelům připojovat síťové disky, čímž znemožní provádět nepovolené akce na síti (obzvláště v sítích bez centralizované správy)
  • označením volby Chránit nastavení "Panelů nástrojů" chráníte celý panel proti editaci v aplikaci Průzkumník
  • označením volby Při ukončení Průzkumníku se nebude ukládat nastavení (rozestavění oken na ploše při vypnutí počítače, vzhled Průzkumníku při jeho ukončení) chráníte nastavení oken (jejich pozici na monitoru a vzhled, včetně zobrazení a seřazení)

Karta Vlastnosti Složky

  • označením volby Zobrazení skrytých a systémových souborů chráníte neměnnost nastavení aktuálního zobrazení skrytých a systémových souborů
  • označením volby Zobrazení známých přípon chráníte neměnnost zobrazení známých přípon
  • označením volby Globální nastavení zobrazení Složek chráníte před efektivním použitím tlačítka „Jako aktuální složka“, které se nachází na kartě Zobrazit dialogu Možnosti složky (dostupný v aplikaci Průzkumník a Internet Explorer prostřednictvím nabídky Zobrazit po klepnutí na příkaz Možnosti složky...).


Nastavení aplikací

Karta Internet

  • označení volby Znemožnit Download zakáže stahování souborů ze sítě Internet
  • označení volby Prostřednictvím Internet Exploreru lze stáhnout pouze vybrané soubory umožní uživateli stahovat soubory příslušející pouze do konkrétní povolené množiny na základě použité přípony; seznam povolených přípon je obsažen v okně Povolené soubory a jeho obsah lze editovat po stisku tlačítka Změnit
  • označení volby Znepřístupnit kontextové menu zakáže uživateli pracovat s kontextovou nabídkou na pravém tlačítku myši
  • označení volby Chránit nastavení domovské stránky zakáže změnu vámi původně nastavené domovské www stránky a to ani klávesovou zkratkou CTRL+D
  • označením volby Chránit nastavení ovládacích panelů chráníte nestavení a vzhled jednotlivých panelů a ovládacích prvků aplikace Internet Explorer
  • označení volby Skrýt volbu Oblíbené skryje nabídku Oblíbené z hlavní nabídkové lišty aplikace Internet Explorer
  • označení volby Chránit nastavení Připojení k internetu zakáže měnit nastavení na kartě připojení v dialogovém okně Internet - vlastnosti (volba rovněž chrání nastavení Telefonických připojení sítě - tj. nelze měnit čísla a nastavení stávajících telefonních účtů)

Karta Word

Aplikace sice uživateli dovolí změnit její vzhled a nastavení, avšak při jejím opětovném spuštění je obnoveno původní nastavení.

  • označení volby Uchovávat nastavení a pozici Ovládacích panelů zakáže přesouvat, modifikovat ikony či jakkoliv jinak měnit panely nástrojů programu Microsoft Word
  • po označení volby Hlídat celkové nastavení aplikace Microsoft Word nelze provádět jakékoliv změny nastavení aplikace Microsoft Word prostřednictvím příkazu Možnosti z nabídky Nástroje
  • označení volby Ochrana základní šablony pro tvorbu dokumentů chrání proti změně šablonu Normal.dot

Karta Excel

Aplikace sice uživateli dovolí změnit její vzhled a nastavení, avšak při jejím opětovném spuštění je obnoveno původní nastavení.

  • označení volby Uchovávat nastavení a pozici Ovládacích panelů zakáže přesouvat, modifikovat ikony či jakkoliv jinak měnit panely nástrojů programu Microsoft Excel
  • po označení volby Hlídat celkové nastavení aplikace Microsoft Excel nelze provádět jakékoliv změny nastavení aplikace Microsoft Excel prostřednictvím příkazu Možnosti z nabídky Nástroje
  • označení volby Zachovat pozici a velikost hlavního okna při spuštění aplikace zachová aktuální rozmístění okna aplikace Microsoft Excel

Karta Outlook

S výjimkou přidávání a odebírání informačních služeb sice aplikace uživateli dovolí změnit její vzhled a nastavení, avšak při jejím opětovném spuštění je obnoveno původní nastavení.

  • označení volby Zachovat pozici a velikost okna při spuštění zachová aktuální rozmístění okna aplikace Microsoft Outlook
  • označení volby Uchovávat nastavení a pozici Ovládacích panelů zakáže přesouvat, modifikovat ikony či jakkoliv jinak měnit panely nástrojů programu Microsoft Outlook
  • označení volby Zakázat rušení již instalovaných a přidávání nových Informačních služeb zakáže provádět změny nastavení v rámci dialogu Účty sítě Internet

Následující volby slouží k omezení možnosti provádět změny nastavení programu Microsoft Outlook prostřednictvím příkazu Možnosti z nabídky Nástroje:

  • označením volby Úkoly a poznámky ignorujete změny provedené v nabídce Nástroje, příkaz Možnosti, karta Předvolby v částech Úkoly a Poznámky
  • označením volby Kontrola pravopisu ignorujete změny provedené v nabídce Nástroje, příkaz Možnosti, karta Kontrola pravopisu
  • označením volby Připomenutí ignorujete změny provedené v nabídce Nástroje, příkaz Možnosti, karta Předvolby, část Kalendář
  • označením volby Kalendář ignorujete změny provedené v nabídce Nástroje, příkaz Možnosti, Karta Předvolby, část Kalendář
  • označením volby Kompletní ochrana menu Možnosti celkově zabezpečí program Microsoft Outlook tak, aby nikdo nemohl prostřednictvím příkazu Možnosti z nabídky Nástroje udělat jakékoliv změny nastavení
  • označením volby Možnosti kontaktů (MS Outlook 2000) ignorujete změny provedené v nabídce Nástroje, příkaz Možnosti, panel Předvolby, část Kontakty
  • označením volby Možnosti el. pošty (MS Outlook 2000) ignorujete změny provedené v nabídce Nástroje, příkaz Možnosti, panel Předvolby, část Kalendář

Karta Outlook Express

  • označením volby Chránit nastavení účtů zakážete uživateli měnit nastavení účtů elektronické pošty a dalších adresářových služeb
  • označením volby Chránit nastavení vzhledu Outlook Express zakážete uživateli přesouvat, modifikovat ikony či jakkoliv jinak měnit panely nástrojů programu Microsoft Outlook
  • označením volby Kompletně chránit nastavení Outlook Express zakážete uživateli provést jakoukoliv změnu v nastavení aplikace Microsoft Outlook Express

Karta E-mail

  • označením volby Zakázat otevírat dopisy programem Microsoft Outlook s vybranými soubory máte možnost zakázat uživateli manipulovat se soubory příslušejícími do konkrétní povolené množiny na základě použité přípony; seznam zakázaných přípon je obsažen v okně Zakázané soubory a jeho obsah lze editovat po stisku tlačítka Změnit

Karta Povolené aplikace

  • označení volby Příkazová řádka znemožní spouštění aplikace Příkazový řádek z nabídky Start (obecně zamezí spouštění interpretru příkazové řádky systému MS-DOS programem Command.com). Tudíž nelze používat aplikace systému MS-DOS.
  • označení volby Spouštění programů znemožní uživateli spustit jakýkoliv jiný program než explicitně povolený správcem systému; toto omezení se netýká programu OptimAccess, který je možné spustit kdykoliv. Pro jednotlivé programy se oprávnění k jejich spouštění nastavuje pomocí tlačítka Nalistovat aplikaci .... Naopak zrušení oprávnění se provádí označením programu v okně v pravé části karty Povolené aplikace dialogu Ochrana nastavení aplikací a následným stiskem tlačítka Odeber aplikaci. Prostřednictvím tlačítka Vybrat ze seznamu dostupných aplikací ... máte možnost v rámci dialogu Výběr spustitelného souboru volit z přehledu spustitelných souborů obsažených na disku počítače.


Bezpečnost

Karta Bezpečnost

  • označením volby Vypnutí počítače zakážete příkaz Vypnout v hlavní nabídce Start systému Windows
  • označením volby Nástroje pro editaci registrů zakážete spuštění standardních aplikací umožňujících měnit obsah registrů systému Windows
  • po označení volby Vyžadovat platné uživatelské jméno a heslo při vstupu do systému systém Windows vždy zobrazí přihlašovací dialog do operačního systému, který nelze obejít stisknutím tlačítka Storno; tuto volbu aktivujte pouze v případě, že máte v rámci vaší sítě server ověřující přihlašovací hesla domény Windows NT. Systém vyžaduje ověření zadaného uživatelského hesla vůči doméně Windows NT! Jinak se do systému Windows nebudete moci přihlásit a bude jej nutné reinstalovat.
  • po označení volby Při zadávání nového hesla vyžadovat alfanumerické heslo bude systém Windows při zadávání hesla nového uživatele vyžadovat zadání řetězce znaků skládající se z kombinace písmen a číslic
  • po označení volby Vyžadovat heslo, které je delší než minimální velikost bude systém Windows při zadávání hesla nového uživatele vyžadovat zadání řetězce znaků, který je stejně dlouhý nebo delší než udaná hodnota čísla uvedená v části minimální velikost na kartě Bezpečnost


OptimAccess Remote Control

Modul Remote Control slouží k dálkové a hromadné správě jednotlivých instalací systému OptimAccess na počítačích a pracovních stanicích v rámci počítačové sítě. Funkčnost není závislá na serveru sítě, přístup je možný z kterékoli stanice kde je modul instalován. V levém okně ovládací aplikace ochranného systému je modul indikován ikonou Remote Control, umístěnou pod ikonou Lokální stanice. Pro jednotlivou symboliku stavu spravovaných počítačů a stanic jsou použity tyto ikony:

  • Je třeba načíst aktuální stav počítače.
  • Ochranný systém není aktivní, je možno jej pouze aktivovat.
  • Ochranný systém je aktivní a lze měnit nastavení ochranného systému.
  • Na počítači není instalovaný klient vzdálené správy nebo počítač není na síti přístupný.

Ovládání ve Windows 9x, ME, NT, 2000 a XP

V prostředí Windows se modul Standard ovládá prostřednictvím aplikace OptimAccess následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace poklepáním myši označte počítač a rozbalte ikonu Remote Control, umístěnou pod ikonou Lokální stanice.

Volby modulu Remote Control

  • Okolní počítače
  • Databáze okolních počítačů
  • Nalezené počítače


Okolní počítače

Volba Okolní počítače slouží k průchodu všech okolních počítačích (obdobně jako v případě použití ikony Okolní počítače na ploše systému Windows). Přitom systém respektuje topologii vaší sítě. Po vylistování obsahu položky Okolní počítače stiskem na ikonu plus se vám zobrazí všechny přístupné pracovní skupiny a domény. Po vylistování obsahu skupiny či domény se vám zobrazí všechny přístupné počítače.

Zobrazené počítače mají ikonu počítače se světle šedým monitorem (protože není známo, které počítače obsahují klienta vzdálené správy a je možné je ovládat). Kliknutím na počítač se u počítače zobrazí příslušná ikona stavu klienta vzdálené správy. V pravé části ikony je indikována použitá platforma - 9x či NT. Je-li na daném počítači aktivní ochranný systém, lze u něj stiskem ikony plus vylistovat příslušné moduly. Nastavování a ovládání jednotlivých voleb je totožné jako v případě práce s ikonou Lokální stanice.

Roletová nabídka na ikoně počítače

  • Znovu načíst - nastaví počítač do výchozího stavu. Při rozbalení se znovu zjišťuje aktivita klienta vzdálené správy a načítá se struktura disků a adresářů.
  • Restartovat - restartuje označený počítač.
  • Vymazat - smaže ikonu označeného počítače. Po opětovném načtení obsahu skupiny (například klávesou F5 či ukončením a spuštěním ovládací aplikace) na základě síťové topologie bude smazaný počítač opět zobrazen.


Databáze okolních počítačů

Databáze okolních počítačů představuje uživatelskou databázi. Administrátor má možnost vytvoření skupin počítačů nebo vložení jmen jednotlivých počítačů, na kterých je instalovaný klient vzdálené správy. Počítače a skupiny lze přidávat a ubírat pomocí kontextové nabídky, která se vyvolá stiskem pravého tlačítka myši na příslušné položce. Většina základních funkcí aplikace pro vzdálenou správu je dostupná prostřednictvím roletových nabídek.

Nastavení ochranných funkcí lze provádět pro všechny počítače současně prostřednictvím ikony Nastavení skupiny. Nastavení ochranných funkcí pro konkrétní počítač v rámci skupiny (či samostatně stojící mimo skupinu) lze prostřednictvím jemu příslušející ikony.

Jednotlivé počítače a skupiny počítačů lze v rámci Databáze okolních počítačů libovolně přemísťovat a vzájemně zanořovat do hierarchické struktury prostřednictvím uchopení a tažení myší.

Roletová nabídka na ikoně Databáze okolních počítačů

  • Nový objekt - umožní vložení nového počítače nebo skupiny do Databáze okolních počítačů. Do databáze je možné vkládat samostatně stojící počítače a skupiny počítačů s nastavením pro platformu Windows 9x a Windows NT.

Roletová nabídka na ikoně skupiny

  • Nový objekt - umožní vložení nového počítače nebo skupiny do Databáze okolních počítačů. Do databáze je možné vkládat samostatně stojící počítače a skupiny počítačů s nastavením pro platformu Windows 9x a Windows NT.
  • Vymazat - umožní vymazání obsahu skupiny nebo celé skupiny z Databáze okolních počítačů.
  • Restartovat - restartuje všechny počítače náležející do příslušné skupiny.

Roletová nabídka na ikoně počítače

  • Znovu načíst - nastaví počítač do výchozího stavu. Při rozbalení se znovu zjišťuje aktivita klienta vzdálené správy a načítá se struktura disků a adresářů.
  • Restartovat - restartuje vzdálený počítač.
  • Vymazat - umožní počítač z Databáze odstranit.


Práce se skupinou počítačů

Všechny akce pro skupinu počítačů lze plánovat dle pokynů pod heslem Plánování akcí pro skupinu počítačů.

Aktivace a deaktivace ochranného systému

Po vylistování skupiny počítačů v levém okně ovládací aplikace lze ochranný systém aktivovat prostřednictvím tlačítka Aktivace systému ... a deaktivovat prostřednictvím tlačítka Deaktivace systému ... Obě tyto volby prostřednictvím příslušných dialogů další nastavení jako v případě práce s lokální stanicí.

Nastavení skupiny

Při manipulaci s nastavením skupiny máte možnost používat tlačítka Aplikovat nastavení všem stanicím ..., Exportovat nastavení do souboru ... a Importovat nastavení ze souboru .... Volby pro import a export nastavení vyžadují prostřednictvím příslušných dialogů další nastavení jako v případě práce s lokální stanicí.

Distribuce software

Funkce pro distribuci software funguje na principu jednoduchých *.ini souborů. V rámci této funkce lze na vzdálenou stanici nakopírovat stanovené soubory a spustit stanovený soubor. Tímto způsobem lze například provádět aktualizaci programového vybavení jednotlivých klientských stanic. V rámci složky Update adresáře s instalací ochranného systému je třeba vytvořit *.ini soubor s následující strukturou.

; Ukázkový inicializační soubor
; pro distribuci software pod Win9x.

[init]
fileType = rcSofwareDistribution

; Název distribuce. Zobrazí se při
; výběru v okně Remote Control
packName = Distribuce software XY

; Adresář který bude jako aktuální
; při čtení souboru (relativně
; k inicializačnímu souboru).
dir = .

[file]
; Seznam všech souborů, které mají
; být překopírovány (počet souborů
; není omezen).
file0 = setup.exe
file1 = readme.txt
file2 = ...

[run]
; Soubor který je po překopírování
; všech souborů spuštěn.
run = setup.exe

V rámci distribuce software není nutné kopírovat celou instalaci. Může být kopírován a spuštěn pouze *.bat soubor, který provede vzdálenou instalaci z adresářů sdílených na serveru.


Plánování akcí pro skupinu počítačů

Všechny akce pro skupinu počítačů lze provést buďto ihned nebo je naplánovat v rámci časového intervalu od či od/do s přesností na vteřiny. Je-li akce provedena ihned, její výsledek se projeví pouze na počítačích které jsou v daném okamžiku dostupné. Pro plánování je třeba mít některou ze stanic určených pro ovládání ochranného systému OptimAccess nastavenou jako server. Každý klient se při spuštění vyhledává aktivní servery či se přímo přihlásí k nastavenému serveru a provede připravené úkoly. Jednotlivé úkoly pro klientské stanice můžete buďto plánovat dvojím způsobem:

  • časově omezené - v rámci určitého časového intervalu od/do;
  • časově neomezené - stále platné od stanoveného počátečného časového okamžiku.

Nastavení vzdáleného serveru

  1. V rámci Databáze okolních počítačů v levé části okna ovládací aplikace vylistujte počítač, který bude fungovat jako server. Z nabídky dostupných modulů vylistujte položku Základní nastavení v modulu Remote Control.
  2. Úlohu stanice v podobě serveru aktivujete prostřednictvím volby Nastavit stanici jako server s databází pro plánované úlohy.
  3. Pro všechny stanice je vhodné označit volbu Při startu informovat vzdálenou stanici a do pole Vzdálená stanice: vepsat síťové jméno zvoleného serveru. Aktivace této volby pro jednotlivé stanice není nutná, avšak pro server eliminuje čas nutný k hledání všech klientů na síti.
  • Jeden počítač určený jako server postačuje pro obsluhu minimálně 50 klientských stanic.

Plánování časově omezené akce

  1. V rámci Databáze okolních počítačů v levé části okna ovládací aplikace vylistujte skupinu počítačů. Stiskem myši na příslušné tlačítko v pravé části ovládací aplikace označte požadovanou funkci, pro niž chcete naplánovat úkol.
  2. Vyžaduje-li příslušná akce nějaké další parametry, budete nejprve dotázáni dialogem na jejich nastavení.
  3. V dialogu Nastavené akce pro skupinu vzdálených stanic označte položku Akci plánovat a nastavte požadované intervalové časové omezení. Při zadávání datumové i časové části intervalu označte volby Od a Do.
  4. U položky Akci uložit na server vylistujte ze seznamu příslušný server, do nějž se má plánovaná akce uložit. Seznam vzdálených serverů můžete modifikovat prostřednictvím položky Vzdálené servery z nabídky Správce v ovládací aplikaci.
  5. Všechny provedené změny aktivujete stiskem tlačítka OK.

Plánování časově neomezené akce

  1. V rámci Databáze okolních počítačů v levé části okna ovládací aplikace vylistujte skupinu počítačů. Stiskem myši na příslušné tlačítko v pravé části ovládací aplikace označte požadovanou funkci, pro niž chcete naplánovat úkol.
  2. Vyžaduje-li příslušná akce nějaké další parametry, budete nejprve dotázáni dialogem na jejich nastavení.
  3. V dialogu Nastavené akce pro skupinu vzdálených stanic označte položku Akci plánovat a nastavte požadované intervalové časové omezení. Při zadávání datumové i časové části intervalu označte pouze volbu Od.
  4. U položky Akci uložit na server vylistujte ze seznamu příslušný server, do nějž se má plánovaná akce uložit. Seznam vzdálených serverů můžete modifikovat prostřednictvím položky Vzdálené servery z nabídky Správce v ovládací aplikaci.
  5. Všechny provedené změny aktivujete stiskem tlačítka OK.


Nalezené počítače

Ikona Nalezené počítače představuje seznam výsledků hledání počítačů na základě jména či IP adresy. Vyhledávání počítačů lze provádět tímto postupem:

  1. Z nabídky Správce zvolte příkaz Najít počítač.
  2. V dialogu Najít počítač můžete vyhledávat prostřednictvím síťového jména nebo IP adresy. Zvolte požadovaný způsob vyhledávání, do příslušného pole zadejte jméno či IP adresu a stiskněte tlačítko Najít.
  3. Nalezený počítač se formou ikony s indikací stavu a platformy zobrazí v rámci ikony Nalezené počítače.

Nalezený počítač lze uchopením a tažením myši umístit do Databáze okolních počítačů.

Roletová nabídka na ikoně počítače

  • Znovu načíst - nastaví počítač do výchozího stavu. Při rozbalení se znovu zjišťuje aktivita klienta vzdálené správy a načítá se struktura disků a adresářů.
  • Restartovat - restartuje označený počítač.
  • Vymazat - smaže ikonu označeného počítače.


OptimAccess Computer Audit

Modul OptimAccess Computer Audit slouží k evidenci a sledování programového vybavení počítače. Umožňuje monitorovat a sestavovat:

  • Okamžitý stav počítače – je možné provést okamžitý audit počítače či jej plánovat formou časových intervalů.
  • Softwarové balíky – nabízí možnost ručně vydefinovat či automaticky vygenerovat šablonu obsahující záznamy o podobě vzorové instalace pracovní stanice. Detailní vysvětlení pojmu naleznete pod heslem Softwarový balík.
  • Tiskové sestavy – výstupy z jednotlivých monitorovacích funkcí lze prohlížet, exportovat do souboru či generovat ve formě tiskových sestav v rámci daných časových období.

Velmi snadno lze identifikovat chybějící a přebývající aplikace a části operačního systému. Modul OptimAccess Computer Audit představuje účinný nástroj pro kontrolu stavu programového vybavení počítačů a počtu instalovaných licencí vybraného software v organizaci.

Ovládání ve Windows 9x

V prostředí Windows 9x se modul Computer Audit ovládá prostřednictvím aplikace OptimAccess následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace poklepáním myši označte počítač a rozbalte ikonu Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Poklepáním myši na položce Computer Audit vylistujete jednotlivé volby a nastavení modulu OptimAccess Computer Audit.

Ovládání ve Windows NT, 2000 a XP

V prostředí Windows NT, Windows 2000 a Windows XP se modul Computer Audit pro konkrétního uživatele ovládá pomocí nabídky Computer Audit v pravém okně ovládací aplikace. Vyvoláte ji následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně si stiskem na ikonu plus před jménem počítače vylistujte seznam možných úrovní, na nichž je možné funkce ochranného systému nastavovat – globální nastavení stanice, seznam skupin a uživatelských účtů.
  4. Zvolte příslušnou úroveň nastavení na níž chcete provádět úpravy nastavení a stiskem na příslušející ikonu plus vylistujte moduly jejichž volby máte možnost nastavovat.
  5. Z vylistovaného seznamu označte volbu Computer Audit. Pravé okno ovládací aplikace změní svoji podobu a máte v něm možnost pracovat s modulem Computer Audit.

Volby modulu Computer Audit

  • Plánování
  • Softwarové balíky
  • Prohlížení


Plánování

Prostřednictvím volby Plánování lze naplánovat skenování instalovaného programového vybavení na stanicích a automatické zálohování souborů s výsledky skenování.
  • Plánování scanu – lze naplánovat s přesností na minuty v rozmezí dne, týdne či měsíce. Skenování je možné realizovat formou sledování spustitelných souborů či jako kompletní otisk počítače. V případě kompletního otisku je dle základního nastavení srovnáván kompletní obsah souborového systému stanice. Na základě uživatelského nastavení je možno z kompletního otisku vyřadit některé typy souborů rozlišované na základě přípony.
  • Plánování přenosů – automatické ukládání informací z provedeného skenování je možné plánovat v intervalu dne, týdne či měsíce s přesností na minuty. V danou dobu lze provést přesun souboru s výsledky skenování na vzdálenou stanici či jej přesunout do zadaného adresáře.
Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Plánování vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


Softwarové balíky

Prostřednictvím funkce Softwarové balíky si lze jednotlivé balíky obsahující informace o programech instalovaných na počítači vytvářet ručně či si je nechat systémem OptimAccess automaticky vygenerovat. Detailní vysvětlení pojmu naleznete pod heslem Softwarový balík.
  • Ruční vytváření – při ručním vytváření balíků lze začít buďto s prázdným balíkem anebo jako základ použít jiný dříve vytvořený balík. V rámci takto zvoleného základu je možno přidávat a odebírat jednotlivé spustitelné aplikace nebo dávkově přidat všechny spustitelné soubory ze zadané složky. Vytvořený balík lze uložit případně smazat.
  • Generování balíků – na základě provedeného skenování instalovaného programového vybavení na stanicích lze programové balíky generovat dle identifikace obsažené v jednotlivých spustitelných souborech. Ve výpisu provedeného skenování jsou jednotlivé spustitelné soubory seskupeny podle obsažené identifikace. Na základě označení je lze ukládat jako samostatné programové balíky či jako jeden balík pod společným názvem. Jeden programový balík může obsahovat i více různých aplikací.
Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Softwarové balíky vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


Prohlížení

S použitím funkce Prohlížení máte možnost vizualizovat výsledky skenování programového vybavení počítaču a pracovních stanic pomocí srovnávání scanů a tiskových sestav.
  • Porovnávání scanů – nabízí možnost vizualizace rozdílů při srovnání původního referenčního a provedeného kontrolního skenování programového vybavení. Při srovnávání lze využívat informace z předem připravených softwarových balíků. V případě rozdílných souborů je zobrazováno jméno souboru, absolutní cesta od kořenového adresáře a čas modifikace. Zjištěné rozdíly je možné uložit jako softwarový balík a vytvářet tak hierarchii – například pro aktualizované verze programů.
  • Tiskové sestavy – nabídka obsahuje generování tiskových sestav:
    • Instalovaný software – na základě vytvořených softwarových balíků a výsledků skenování programového vybavení lze vygenerovat přehled programového vybavení instalovaného na jednotlivých stanicích. V rámci kontroly lze vypisovat nerozlišované soubory, souhrnnou tabulku instalovaných balíků a seznam balíků použitých pro výpis. Rovněž lze kontrolovat datum posledního provedení skenování programového vybavení počítačů.
    • Porovnávání výsledků – lze srovnávat provedené skenování programového vybavení počítačů s referenčním scanem. Při hledání rozdílů je možné vyloučit informace na základě sestavených softwarových balíků. V případě že se jedná o kompletní otisky, je možné srovnávat i nespustitelné soubory. Rovněž lze kontrolovat datum posledního provedení skenování programového vybavení počítačů.
Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Prohlížení vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Chcete-li pracovat s jednotlivými tiskovými sestavami, musíte je nejprve vylistovat stiskem myši na ikoně Tiskové sestavy v levém okně ovládací aplikace. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


OptimAccess WorkSpy

Modul OptimAccess WorkSpy slouží k evidenci a sledování využití počítače a pracovního času stráveného u počítače. Nabízí monitorovací funkce ke sledování:

  • Základních operací – vypnutí a zapnutí počítače, přihlašování uživatelů, spouštění aplikací a časové prodlevy nad stanovený interval.
  • Operačního systému – tisk souborů, využívání Ovládacích panelů a úpravy registrační databáze.
  • Souborového systému – lze sledovat používaná výměnná média a monitorovat zápis a čtení stanovených typů souborů.
  • Internetu – přístup k jednotlivým WWW serverům, soubory stahované z Internetu a přílohy zasílané elektronickou poštou.

Výstupy z jednotlivých monitorovacích funkcí lze prohlížet, exportovat do souboru či generovat ve formě tiskových sestav v rámci daných časových období. Modul OptimAccess WorkSpy představuje účinný nástroj pro kontrolu využívání počítače a pracovního času zaměstnanců.

Ovládání ve Windows 9x

V prostředí Windows 9x se modul WorkSpy ovládá prostřednictvím aplikace OptimAccess následujícím způsobem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně ovládací aplikace poklepáním myši označte počítač a rozbalte ikonu Lokální stanice. Tato lokální stanice doplněna o označení platformy a síťové jméno počítače – například Lokální stanice (9x) "NEXUS".
  4. Poklepáním myši na položce WorkSpy vylistujete jednotlivé volby a nastavení modulu OptimAccess WorkSpy.

Ovládání ve Windows NT, 2000 a XP

V prostředí Windows NT, Windows 2000 a Windows XP se modul WorkSpy pro konkrétního uživatele ovládá pomocí nabídky WorkSpy v pravém okně ovládací aplikace. Vyvoláte ji následujícím postupem:

  1. Klepněte na tlačítko Start, přejdete na příkaz Programy, zvolíte položku Ochranný systém OptimAccess a klepněte na položku OptimAccess.
  2. Po spuštění ovládací aplikace vás systém vyzve k zadání přístupového hesla. Po jeho vepsání do příslušného textového pole stiskněte klávesu ENTER anebo stiskněte myší tlačítko Ano. Stiskem na tlačítko Storno ukončíte ovládací aplikaci OptimAccess.
  3. V levém okně si stiskem na ikonu plus před jménem počítače vylistujte seznam možných úrovní, na nichž je možné funkce ochranného systému nastavovat – globální nastavení stanice, seznam skupin a uživatelských účtů.
  4. Zvolte příslušnou úroveň nastavení na níž chcete provádět úpravy nastavení a stiskem na příslušející ikonu plus vylistujte moduly jejichž volby máte možnost nastavovat.
  5. Z vylistovaného seznamu označte volbu WorkSpy. Pravé okno ovládací aplikace změní svoji podobu a máte v něm možnost pracovat s modulem WorkSpy.

Volby modulu WorkSpy

  • Nastavení
  • Plánování
  • Prohlížení


Nastavení

Prostřednictvím volby Nastavení máte možnost zvolit události, které mají být modulem WorkSpy monitorovány:
  • Základní monitorování PC – lze sledovat zapnutí a vypnutí PC, přihlašování uživatelů, pauzy delší než stanovený časový interval v minutách a spouštěné aplikace.
  • Internet – lze sledovat přístup k WWW stránkám, soubory stahované z Internetu a přílohy v elektronické poště.
  • Souborový systém – lze sledovat používání výměnných médií, operace na sdílených síťových discích a události čtení a zápisu stanovených typů souborů (na základě přípon).
  • Operační systém – lze sledovat tisk souborů, použití Ovládacích panelů a úpravu Registrační databáze.
Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Nastavení vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


Plánování

Prostřednictvím volby Plánování lze naplánovat automatické zálohování či odstraňování logových souborů s přehledem sledovaných událostí.
  • Plánování přenosů – Plánování je možné provádět v intervalu dne, týdne či měsíce s přesností na minuty. V danou dobu lze provést přesun logového souboru na vzdálenou stanici, smazat logový soubor či přesunout logový soubor do zadaného adresáře.
Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Plánování vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


Prohlížení

S použitím funkce Prohlížení máte možnost generovat tiskové sestavy za vymezený časový interval formou od/do s přesností na vteřiny a detailně prohlížet logové soubory se záznamem sledovaných událostí.

  • Detailní prohlížení – volba nabízí možnost prohlížení logových souborů se sledovanými událostmi v grafickém prostředí. Umožňuje filtrovat jednotlivé událostí na základě typu a časového intervalu s přesností na vteřiny.
  • Tiskové sestavy – nabídka obsahuje generování tiskových sestav:
    • Aplikace na popředí – seznam všech aplikací spuštěných na počítači v definovaném časovém intervalu. Ve výsledné sestavě je možno zanedbat aplikace, které se na popředí vyskytovaly kratší dobu než zadaná hodnota v sekundách.
    • Využitelnost PC – výpis skutečného využití stanice v době jejího běhu očištěný o prodlevy. V sestavě je možno pominout záznamy s menším zastoupením než udaná procentuelní hodnota. Sestavu je možno generovat v rámci periody dne, týdne, měsíce či bez časového omezení.
    • Četnost WWW stránek – přehled navštívených internetových stránek v zadaném časovém intervalu s přesností na dny. Sestavu je možno generovat v rámci periody dne, týdne, měsíce či bez časového omezení.

Při nastavování jednotlivých funkčností si nejprve v levém okně ovládací aplikace stiskem myši na ikoně Prohlížení vylistujte příslušné kategorie voleb dle výše uvedeného seznamu. Chcete-li pracovat s jednotlivými tiskovými sestavami, musíte je nejprve vylistovat stiskem myši na ikoně Tiskové sestavy v levém okně ovládací aplikace. Označte příslušnou kategorii v níž chcete měnit nastavení a v rámci pravého okna ovládací aplikace stiskem myši označte příslušné volby.


Doporučený postup konfigurace

  1. Vyexportovat základní nastavení ochranného systému do datového souboru. Je vhodné uložit si základní nastavení bez jakýchkoliv změn. V případě instalace ochranného systému pod Windows 9x proto ukončete průvodce stiskem tlačítka Storno a vyexportujte základní nastavení systému (bez případných změn). Určitě toto základní nastavení budete potřebovat v případě rozsáhlých aktualizací programového vybavení počítače či samotného operačního systému (podrobnosti naleznete pod heslem Jak postupovat v případě změny konfigurace OS?).
  2. Zakázat instalaci nových programů. Je vhodné použít pro jména instalačních souborů obecnou masku *setup* a *install* (některé programy totiž v názvu souboru instalátoru obsahují rovněž i číslo verze či jazykovou mutaci).
  3. Nemáte-li instalován nadstavbový modul Extension, je vhodné aktivovat kompletní ochranu Registrační databáze. Dále pokračujte v tomto postupu podle bodu č. 6.
  4. Máte-li instalován nadstavbový modul Extension případně nepoužijete-li funkci pro kompletní ochranu Registrační databáze, je vhodné chránit následující Ovládací panely: Systém, Síť, Možnosti sítě Internet, Pošta, Modemy.
  5. V modulu Extension použijte toto nastavení:
    • Nastavení vlastností Ovládacích panelů
      • karta Síť: označit volbu Sdílení souborů a tiskáren
      • karta Hesla: označit volby Zákožka Vzdálená správa a Záložka Profily uživatelů
      • karta Tiskárny: označit volby Přidání tiskárny a Záložka Podrobnosti tiskárny
      • karta Obrazovka: označit volbu Skryj záložku Nastavení
    • Nastavení vlastností Průzkumníka a Složky
      • karta Průzkumník: s výjimkou volby Zobrazení ikony Připojení síťové jednotky označit všechny ostatní volby
      • karta Vlastnosti Složky: označit všechny volby
    • Ochrana nastavení aplikací
      • karta Internet Explorer: označit volby Chránit nastavení domovské stránky a Chránit nastavení Připojení k internetu
      • karta Word: označit všechny volby
      • karta Excel: označit všechny volby
      • karta Outlook: označit všechny volby
    • Bezpečnost
      • karta Bezpečnost: označit volbu Nástroje pro editaci registrů
  6. V modulu Computer Audit použijte postup s ohledem na instalované programové vybavení.
    • Mají-li mít všechny stanice stejnou konfiguraci programového vybavení (například jednotlivé stanice v počítačové učebně):
      1. Nainstalujte a nakonfigurujte počítač dle požadované specifikace.
      2. Vytvořte referenční scan vzorového počítače.
      3. V rámci Databáze okolních počítačů si vytvořte skupinu a začleňte do ní všechny počítače.
      4. V rámci skupiny vylistujte Plánování scanu nastavte plánování pro všechny počítače na požadovaný interval.
      5. V rámci skupiny porovnejte scany jednotlivých stanic vůči referenčnímu scanu prostřednictvím voleb Prohlížení – je třeba mít zatrženou volbu Referenční scan a vylistovaný příslušný soubor se scanem vzorového počítače.
    • Mají-li mít stanice individuální konfiguraci programového vybavení s ohledem na pracovní zařazení (například pracovní stanice pro skupiny typu sekretariát, techničtí pracovníci, vedení, atd.):
      1. V rámci Databáze okolních počítačů si vytvořte skupinu a začleňte do ní odpovídající počítače.
      2. V rámci nastavení příslušné skupiny vylistujte Plánování přenosů, označte volby Ihned po provedení scanu, provést danou akci a Posílat softwarové scany na vzdálenou stanici a do pole Název stanice vyplňte počítač z nějž je ochranný systém administrován. Nezapomeňte tuto změnu aplikovat stiskem tlačítka Použít a rozeslat tak nastavení všem počítačům ve skupině.
      3. V nastavení skupiny vylistujte Plánování scanu a pomocí tlačítka Provést ihned ... proveďte oskenování všech počítačů. V tomto okamžiku budete mít na ovládací stanici pro všechny stanice ve skupině jim příslušející referenční scany.
      4. Pro skupinu vylistujte Plánování scanu nastavte plánování pro všechny počítače na požadovaný interval.
      5. V rámci skupiny porovnejte scany jednotlivých stanic vůči referenčnímu scanu prostřednictvím voleb Prohlížení – je třeba mít zatrženou volbu Adresář referenčních scanů a vylistovanou příslušnou složku se scany jednotlivých počítačů ve skupině.
    • Provádění kompletního otisku stanice může mnohdy díky velkým diskům trvat i desítky minut a v jeho průběhu jsou generovány nemalé objemy dat. Budete-li používat volbu Provádět kompletní otisk počítače je vhodné omezit sledované soubory jen na nutné minimum formou přípon.

  7. V modulu WorkSpy je s ohledem na účely archivace a auditu vhodné logy ukládat na server (například ovládací stanici). Pro skupinu vylistujte Plánování přenosu nastavte jej s použitím volby Přesouvat logový soubor na vzdálenou stanici a Název stanice.

    Výhody přesunu logů na server:

    • nezabírají místo na disku lokální stanice;
    • jsou chráněny proti poškození či úmyslné modifikaci.

  8. Nastavit následující ochranu adresářové struktury:
    • složce WINDOWS nastavit příznak RO, souborům v ní ponechat základní nastavení příznaků
    • složkám COMMAND, INF, FONTS a SYSTEM, včetně souborů v nich obsažených, ve složce WINDOWS nastavit příznak RO
    • složce SYSBACKUP ve složce WINDOWS nastavit příznak WR, souborům v ní obsaženým nastavit příznak RO s výjimkou souborů Rb001.cab až Rb005.cab (ponechat nastavený příznak WR)
    • nastavit příznak WR pro všechny soubory *.ini a *.txt ve složce WINDOWS
    • nastavit příznak WR souboru Win386.swp ve složce WINDOWS
    • máte-li instalován program Microsoft Office, nastavte pro všechny jeho složky příznak RO, u souborů ponechejte původní nastavení příznaků (základní složka pro instalaci programu Microsoft Office je C:\Program Files\Microsoft Office)
    • složkám C:\Program Files\Internet Explorer a C:\Program Files\Outlook Express nastavit příznak RO bez aplikace na soubory v nich obsažené
    • nastavit příznak RO pro systémové soubory v kořenovém adresáři disku C (tj. soubory C:\Config.sod, C:\Io.sys, C:\Msdos.sys a podobně)
    • nastavit příznak RO na složku s instalací programu OptimAccess a to včetně souborů v ní obsažených (základní složka pro instalaci je C:\OA8)
  9. Exportovat vlastní nastavení ochranného systému do datového souboru.

Jak konfigurovat síťové instalace?

Při konfiguraci síťové instalace lze samozřejmě postupovat mnoha způsoby. Jednoznačně nelze některý z možných postupů označit jako nevhodný. Jsou pouze více a méně pracné postupy. Jako obecně nejrychlejší a nejméně pracný lze považovat následující způsob:

  1. Instalovat kompletního ochranný systém na jednom počítači. Následující kroky lze provádět buďto přímo na konkrétním počítači nebo vzdáleně prostřednictvím nadstavbového modulu Remote Control.
  2. Aktivovat ovladače ochranného systému.
  3. Uložit základní konfiguraci ochranného systému do souboru.
  4. Nastavit vlastní konfiguraci ochranného systému v závislosti na konkrétních podmínkách a požadavcích. Mimo specifických požadavků souvisejících s konkrétní instalací je vhodné použít výše popsaný doporučený způsob konfigurace.
  5. Uložit vlastní konfiguraci ochranného systému do souboru.
  6. Na ostatních počítačích instalovat ochranný systém a importovat jeho nastavení ze souboru vytvořeného dle bodu č. 5.


Jak postupovat v případě změny konfigurace OS?

Plánujete-li na chráněnou stanici rozsáhlejší instalaci nového programového vybavení, rozsáhlejší aktualizaci stávajících aplikací nebo aktualizaci části operačního systému proveďte zamýšlené úpravy následujícím způsobem (odkazy na hesla uváděná v postupu přísluší k ovládací aplikaci pro Windows 9x, ekvivalentní hesla pro Windows NT a 2000 naleznete v Ovládání aplikace ve Windows NT/2000):

  1. Prostřednictvím příkazu Export nastavení do souboru zálohujte stávající nastavení systému. Postup pro export nastavení do datového souboru naleznete pod heslem Export nastavení do souboru.
  2. Obnovte základní nastavení ochranného systému, které jste zálohovali ihned po instalaci systému OptimAccess prostřednictvím příkazu Import nastavení ze souboru. Postup pro import nastavení z datového souboru naleznete pod heslem Import nastavení ze souboru.
  3. Prostřednictvím příkazu Deaktivace systému deaktivujte ochranný systém OptimAccess. Postup pro deaktivaci ochranného systému OptimAccess naleznete pod heslem Aktivace a deaktivace ochranného systému.
  4. Restartuje počítač a proveďte plánované úpravy programového vybavení počítače.
  5. Aktivujte ochranný systém a restartujte počítač. Postup pro aktivaci ochranného systému OptimAccess naleznete pod heslem Aktivace a deaktivace ochranného systému.
  6. Obnovte vaše nastavení ochranného systému OptimAccess, které jste zálohovali před úpravami programového vybavení počítače (dle kroku č. 1 tohoto postupu) prostřednictvím příkazu Import nastavení ze souboru. Postup pro import nastavení z datového souboru naleznete pod heslem Import nastavení ze souboru. Případně proveďte další požadované úpravy v nastavení funkcí ochranného systému OptimAccess.


Odstraňování problémů

V následující sekci jsou popsána řešení pro všeobecně známé situace, které mohou při práci s ochranným systémem OptimAccess nastat.

  • Tvorba záchranné diskety
  • Nouzová deinstalace systému
  • Nelze zavést operační systém
  • Nelze provést aktivaci ochranného systému
  • Zavedení systému se ukončí chybou zápisu na disk
  • Při zavedení systému hlásí výjimku Plánovač úloh
  • Zavedení systému se ukončí chybou porušení ochrany Registrační databáze
  • Operační systém hlásí nedostatek paměti
  • Systém není aktivní a nelze používat disketovou případně CD-ROM mechaniku
  • Problémy s tiskem
  • Operační systém se samovolně restartuje
  • Zastavování aplikací pro MS-DOS
  • Zapomenuté heslo pro ovládací aplikaci
  • V ovládací aplikaci nejsou vidět klienti
  • V ovládací aplikaci nelze nalézt funkčního klienta
  • Záloha uživatelského nastavení Databáze
  • Chyba porušení konfiguračního souboru
  • Nelze autorizovat disketa
  • Podezření na virovou nákazu

V případě jakýchkoliv jiných problémů kontaktujte výrobce dle pokynů uvedených pod heslem Odborná pomoc.


Tvorba záchranné diskety

Vlastní systémovou disketu můžete ve Windows 9x či ME na příkazovém řádku vytvořit prostřednictvím příkazu format <jednotka>: /s. V grafickém rozhraní Windows použijte následující postup:

  1. V okně Tento počítač nebo v pravém podokně programu Průzkumník klepněte na ikonu diskety, kterou chcete formátovat.
  2. V nabídce Soubor klepněte na příkaz Naformátovat.
  3. V dialogu Formátovat nastavte odpovídající kapacitu diskety, nastavte Typ formátování na Úplné, označte volbu Zkopírovat systémové soubory a stiskněte na tlačítko spustit.

Vytvořenou systémovou disketu dále upravte následujícím způsobem:

  1. Z distribučního CD-ROM spusťte soubor Initdisk.exe.
  2. Z distribučního CD-ROM nakopírujte na disketu soubory Repair.exe a Backup.exe.
  3. Zkopírujte na ni soubory Fdisk.exe, Format.com a Sys.com z adresáře Windows\Command.


Nouzová deinstalace systému

Pokud se po instalaci a následném restartu proces zavádění systému zastaví nebo vůbec není zahájen, došlo ke konfliktu, který může být způsoben:
  • aktivní rezidentní částí antivirového programu,
  • přítomností viru,
  • poškozeným operačním systémem,
  • vadným pevným diskem
  • nebo přítomností neznámého nestandardního kódu.

V závislosti na provozovaném operačním systému pokračujte dle postupu:

  • Nouzová deinstalace systému OptimAccess na platformě Windows 9x/ME,
  • Nouzová deinstalace systému OptimAccess na platformě Windows NT/2000/XP.


Nouzová deinstalace systému OptimAccess na platformě Windows 9x/ME

Pro úspěšnou deinstalaci je nutné vědět zda jste instalovali ochranný systém OptimAccess do zavaděče pevného disku či nikoliv. Nejste-li si jisti vyzkoušejte zavést operační systém ze standardní záchranné diskety Windows (neupravené dle postupu Tvorba záchranné diskety). Zdaří-li se vám systém zavést z této diskety, můžete přeskočit následující odstavce Nouzová deinstalace ze zaváděcí oblasti disku.

Nouzová deinstalace ze zaváděcí oblasti disku

  1. Pokuste se zavést operační systém s pomocí Záchranné diskety, kterou jste vytvořili v průběhu instalace nebo dle postupu pod heslem Tvorba záchranné diskety.
  2. Ze Startovací nabídky systému Windows zvolte položku Jen systém MS-DOS a stiskněte klávesu ENTER.
  3. Spusťte z diskety nouzovou opravnou utilitu repair.exe. Můžete tak nouzově odinstalovat první část systému OptimAccess ze zavaděčů a to klasicky, nebo s využitím záložního souboru, který se generuje při prvotní instalaci.
  4. Spusťte z diskety příkaz fdisk /mbr.
  5. Pokuste se restartovat počítač, zavést operační systém z pevného disku a opět aktivovat ochranný systém.

Disk s nimž manipulujete musí být zapojen jako PRIMARY MASTER. V případě, kdy nedojde k odstranění problému je příčinou nekompatibilní BIOS vašeho počítače. Kontaktujte oddělení technické podpory výrobce dle pokynů uvedených pod heslem Odborná pomoc.

Nouzová deinstalace v prostředí Windows

Restartujte počítač a zaveďte pouze systém MS-DOS. V průběhu zavádění operačního systému stiskněte klávesu F8. Ze Startovací nabídky systému Windows zvolte položku Jen systém MS-DOS a stiskněte klávesu ENTER. V případě, kdy jsou některé zmiňované soubory určeny pouze pro čtení, změňte nastavení jejich příznaků pomocí příkazu attrib.

Následně je třeba ručně odstavit všechny části systému OptimAccess, například souborovým manažerem:

  • přejmenovat soubor Config.sod na Config.sys (není-li záložní soubor Config.sod přítomen, odstraňte ze stávajícího souboru Config.sys řádek device=C:\Oa8\Oa16.sys);
  • v souboru Autoexec.bat smazat řádek, ve kterém se zavádí program Recovreg.exe (pokud se zavádí Komplexní ochrana registrační databáze);
  • přejmenovat v adresáři Windows soubor System.sod na System.ini (není-li záložní soubor System.sod přítomen, ze stávajícího souboru System.ini v sekci [386ENH] odstraňte řádky device=C:\Oa8\Oafile.vxd a pro případ nadstavbových modulů rovněž device=C:\Oa8\Oareg.vxd);
  • v adresáři Windows\System\Iosubsys smazat soubor Sios.vxd.
Po odstranění výše uvedených součástí restartujte počítač a operační systém by se měl zavést bez problémů klasickým způsobem. Zkontrolujte nastavení operačního systému a proveďte úkony, které jsou popsány v nápovědě pod heslem Instalace.


Nouzová deinstalace systému OptimAccess na platformě Windows NT/2000/XP

Používáte-li jako souborový systém FAT či FAT32, můžete následující úpravy provést z prostředí interpretru příkazové řádky systému MS-DOS. Máte-li operační systém instalován na souborovém systému NTFS, je k provedení následujících úprav třeba systém schopný manipulovat s použitým souborovým systémem. Můžete využít například záchrannou disketu NT Admin Boot Disk, manipulovat si diskem vzdáleně po síti (pokud to stav počítače dovoluje) či disk vyjmout a připojit jej do jiného počítače, který je schopen se souborovým systémem NTFS operovat (například s instalací Windows NT, 2000 či XP).

V rámci adresářové struktury Windows je potřeba odstranit (popř. přejmenovat) tyto soubory:

<WINDOWS>\system32\drivers\oafile.sys
<WINDOWS>\system32\drivers\oaregmgr.sys
<WINDOWS>\system32\oakel8NT.dll

Následně restartujte počítač, odinstalujte ochranný systém OptimAccess a zkuste jej nainstalovat znovu.


Nelze zavést operační systém

Problém: Proces zavádění operačního se zastaví za výpisem informace o instalaci ochranného systému.

Řešení:

V závislosti na provozovaném operačním systému odstraňte ochranný systém OptimAccess dle postupu:

  • Nouzová deinstalace systému OptimAccess na platformě Windows 9x/ME,
  • Nouzová deinstalace systému OptimAccess na platformě Windows NT/2000/XP.


Nelze provést aktivaci ochranného systému

Problém: Proces aktivace ochranného systému neproběhne korektně či vůbec a ukončí se chybovým hlášením. Případně ochranný systém není možné instalovat.

Řešení:

Jednou z příčin tohoto problému může být předchozí instalace starší verze OptimAccessu. Deaktivujte a odinstalujte předchozí verze.

Není-li problém odstraněn, zkontrolujte zda nemáte v kořenovém adresáři disku soubor oasys.set. Je-li přítomen, tak jej smažte. Rovněž smažte v registru klíč HKEY_LOCAL_MACHINE\SOFTWARE\SODAT software.

Dále mohou být na vině 16bitové ovladače jednotlivých hardwarových komponent. Kontrolu jejich stavu a funkce provedete prostřednictvím Ovládacího panelu Systém.


Zavedení systému se ukončí chybou zápisu na disk

Problém: Proces zavádění operačního systému Windows se ukončí chybou zápisu na disk a operační systém se ukončí.

Řešení:

Příčinou je nezavedení ovladače Oa16.sys prostřednictvím konfiguračních souborů. V paměti je aktivní pouze ovladač ze zaváděcího sektoru a celý disk je možné pouze číst.

  1. Pokuste se zavést operační systém s pomocí Záchranné diskety, kterou jste vytvořili v průběhu instalace nebo dle postupu pod heslem Tvorba záchranné diskety.
  2. Nouzově odstavte ochranný systém dle postupu pod heslem Nouzová deinstalace systému.
  3. Pokuste se restartovat počítač, zavést operační systém z pevného disku, a opět aktivovat ochranný systém.


Při zavedení systému hlásí výjimku Plánovač úloh

Problém: Proces zavádění operačního systému Windows je přerušen výjimkou programu Plánovač úloh.

Řešení:

Příčinou je chybné nastavení příznaků pro soubor protokolu programu Plánovač úloh. V adresáři Windows nastavte pro soubor Shedlog.txt příznak WR namísto stávajícího RO.


Zavedení systému se ukončí chybou porušení ochrany Registrační databáze

Problém: Proces zavádění operačního systému Windows se ukončí chybou porušení ochrany Registrační databáze a systém je možné pouze restartovat.

Řešení:

Příčinou je chybné nastavení příznaků pro adresář Windows\Sysbckup nebo některý z *.cab souborů se zálohou Registrační databáze. Tyto záložní soubory musejí být přístupné pro zápis. Podrobnosti naleznete pod heslem Doporučený postup konfigurace.


Operační systém hlásí nedostatek paměti

Problém: Proces zavádění operačního systému Windows je přerušován chybovým hlášením Nedostatek paměti.

Řešení:

Příčinou je chybné nastavení příznaků pro soubor virtuální paměti Win36.swp v adresáři Windows. Tento soubor musí být přístupný pro zápis. Podrobnosti naleznete pod heslem Doporučený postup konfigurace.


Systém není aktivní a nelze používat disketovou případně CD-ROM mechaniku

Problém: Nelze pracovat s disketovou případně CD-ROM mechanikou ačkoliv není ochranný systém aktivní.

Řešení:

Příčinou je neúplná deaktivace ochranného systému. Tento problém odstraníte smazání souboru Sios.vxd z adresáře Windows\System\Iosubsys.


Problémy s tiskem

Problém: Do operačního systému nelze přidat novou tiskárnu, případně přidaná tiskárna netiskne. Odstraňování tiskárny se ukončí chybou.

Řešení:

Příčinou je chybné nastavení příznaků pro adresář s tiskovou frontou a konfigurační soubory operačního systému. Při manipulaci s tiskárnou je třeba dodržet následující pravidla:

  • při přidávání a odstraňování tiskárny je třeba mít pro zápis přístupný soubor Win.ini z adresáře Windows;
  • při tisku musí mít uživatel pro zápis přístupný adresář Spool, tvořící pro příslušnou tiskárnu její tiskovou frontu.


Operační systém se samovolně restartuje

Problém: V průběhu práce operační systém samovolně provede restart, aniž by se opakovala stejná situace či operace.

Řešení:

Příčinu je třeba hledat v ovladačích hardwarových komponent, které jsou spolu v konfliktu. Hardwarové problémy můžete řešit za pomocí hesla Poradce při potížích v případě konfliktu hardwaru systému Windows ze standardní nápovědy operačního systému, případně konfliktní hardwarové prvky a ovladače z počítače odstranit.

Restartuje-li se samovolně systém Windows 2000 či XP, lze tomuto procesu zabránit prostřednictvím volby Automaticky restartovat. V ovládacím panelu Systém zvolte záložku Upřesnit, stiskněte tlačítko Nastavit v oblasti Spouštění a zotavení systému a zrušte označení volby Automaticky restartovat v oblasti Selhání systému. Operační systém namísto pokračování zobrazí obrazovku s výraznou zprávou, informující o chybě způsobující zastavení. S výpisem této chyby můžete následně kontaktovat technickou podporu.


Zastavování aplikací pro MS-DOS

Problém: Při práci s aplikací v režimu MS-DOS přestane počítač odpovídat.

Řešení:

Příčinu je třeba hledat v automatickém přidělování paměti pro aplikace. Přidělování paměti pro jednotlivé aplikace je třeba nastavit ručně. Ve vlastnostech konkrétní aplikace se přepněte na kartu Paměť a nastavené hodnoty automaticky změňte dle systémových požadavků konkrétní aplikace.


Zapomenuté heslo pro ovládací aplikaci

Problém: Ovládací aplikaci ochranného systému nelze spustit, protože jste zapomněli nastavené vstupní heslo.

Řešení:

Ochranný systém je bohužel třeba přeinstalovat. Nouzově jej deaktivujte dle postupu uvedeného pod heslem Nouzová deinstalace systému a instalujte jej znovu.


V ovládací aplikaci nejsou vidět klienti

Problém: V ovládací aplikaci ochranného systému nelze vylistovat či najít konkrétní počítač.

Řešení:

Na spravovaných počítačích musí být pro korektní chování systému vzdálené správy aktivní klient (program Rcclient). Zkontrolujte jeho přítomnost v paměti prostřednictvím programu Správce úloh. Není-li v paměti aktivní, lze jej spustit prostřednictvím souborů Rcclient.exe (Windows 9x) respektive Rcclientnt.exe (Windows NT a Windows 2000). V případě potíží se spouštěním klienta reinstalujte ochranný systém.

Je-li klient v paměti spravované stanice aktivní a daný počítač stále nelze v ovládací aplikaci ochranného systému vylistovat či najít, je třeba zkontrolovat nastavení použitého komunikačního protokolu. Dále je pro korektní chování mít třeba instalovány síťové služky Klient sítě Microsoft a Sdílení souborů a tiskáren v sítích Microsoft.


V ovládací aplikaci nelze nalézt funkčního klienta

Problém: V ovládací aplikaci ochranného systému nelze vylistovat či najít konkrétní počítač, kde je v paměti aktivní klient pro vzdálenou správu.

Řešení:

Problém může být na straně síťové kabeláže či připojení počítače k síti. Zkontrolujte kabeláž a vyzkoušejte zdali je možno na počítači pracovat se sdílenými síťovými prostředky. V případě problémů na straně ochranného systému OptimAccess kontaktujte výrobce dle pokynů pod heslem Odborná pomoc.


Záloha uživatelského nastavení Databáze

Problém: Jak zachovat nastavení uživatelsky definované Databáze ovládací aplikace ochranného systému při případné reinstalaci ochranného systému.

Řešení:

Uživatelské nastavení databáze se ukládá do souboru Database.dat v základním adresáři s instalovaným ochranným systémem (základní nastavení je C:\OAx, kde x představuje číslo verze ochranného systému). Před případnou reinstalací si zálohujte tento soubor a po reinstalaci přepište nový soubor původní zálohou.


Chyba porušení konfiguračního souboru

Problém: Po instalaci a aktivaci hlásí ochranný systém OptimAccess chybu, kdy došlo k porušení konfiguračního souboru.

Řešení:

Smažte porušený konfigurační soubor Oasys.set v kořenovém adresáři disku C.


Nelze autorizovat disketa

Problém: Proces autorizace diskety při použití ochrany disketové mechaniky neproběhne korektně a disketa není autorizována.

Řešení:

V případě některých značkových počítačů je znemožněno provádění nestandardních operací s hardwarovými komponentami na úrovni mikrokódu. Disketu je třeba autorizovat v disketové mechanice jiného počítače.


Podezření na virovou nákazu

Problém: Antivirový program hlásí při kontrole pevného disku případně autorizovaných disket podezření na virovou nákazu.

Řešení:

Upravené zaváděcí sektory se při běžné kontrole antivirovým programem mohou zdát jako napadené virem. Jistotu, že se jedná o planý poplach můžete získat jestliže:

  1. bezprostředně před instalací ochranného systému provedete antivirovou kontrolu zaváděcího sektoru pevného disku;
  2. instalujete ochranný systém OptimAccess a ihned poté si v antivirovém programu vytvoříte záložní kopii zaváděcího sektoru pevného disku.

Srovnáním podoby záložní kopie a s aktuálním stavem zaváděcího sektoru tak kdykoliv v budoucnu snadno odhalíte virovou nákazu.


Slovníček

V rámci sekce slovníček naleznete vysvětlení těchto pojmů:

  • Aktivace
  • Alokační tabulka souborů
  • BIOS
  • Instalace
  • Registrační databáze
  • Softwarový balík
  • Zaváděcí sektor
  • Zavaděč


Aktivace

Pojmem aktivace se v případě ochranného systému OptimAccess rozumí zavedení ovladačů potřebných pro korektní funkci systému. Při aktivaci ovladačů se modifikuje rovněž zaváděcí oblast pevného disku. Pro korektní aktivaci ochranného systému je tudíž nutný restart počítače.

Klient pro vzdálenou správu je spuštěn v závěrečné fázi instalace a je v paměti počítače aktivní bez ohledu na to, zdali je současně aktivní také ochranný systém OptimAccess. Aktivaci ochranného systému lze tedy provést kdykoliv po instalaci systému a to i prostřednictvím ovládací aplikace.


Alokační tabulka souborů

Pojmem alokační tabulka souborů (angl. file allocation table, zkráceně též FAT) se označuje speciální oblast zformátovaného datového média, kde jsou uloženy informace o adresářové struktuře a v ní obsažených souborech. Alokační tabulka souborů je vytvořena operačním systéme při formátování média. Data v ní obsažená nejsou pro uživatele přímo dostupná. Manipuluje s ní operační systém a provádí v ní změny na základě uživatelských operací nad adresáři a soubory.


BIOS

Pojmem BIOS (angl. basic input/output system, zkráceně též BIOS) se rozumí základní programové vybavení počítače uložené v čipu na základní desce. Obsahuje instrukce pro zavedení operačního systému z vnější paměti (rozuměj pevného disku) do vnitřní paměti (rozuměj fyzickou RAM) počítače. Jeho prostřednictvím lze rovněž nakonfigurovat základní parametry systému (typ procesoru, velikost paměti, informace o pevných discích a podobně).


Instalace

Pojmem instalace (angl. install) se rozumí proces přípravy programu k běhu, který se sestává z fyzického překopírování potřebných souborů na pevný disk počítače, jejich rozmístění na odpovídající pozice adresářové struktury, propojení s ostatním programovým vybavením a s tím nutně související úprava nastavení jednotlivých programových částí.


Registrační databáze

Pojmem registrační databáze (angl. registry) se rozumí centrální databáze informací operačního systému Windows. Slouží k ukládání informací o hardwarovém a programovém vybavení počítače, informací o uživatelských konfiguracích a podobně. Eliminuje se tak potřeba dodatečných informačních souborů pro jednotlivé aplikace a periférie počítače. Pro manipulaci s touto centrální databází obsahuje operační systém Windows program Editor registru.


Softwarový balík

Pojmem softwarový balík se v případě ochranného systému OptimAccess rozumí označení skupiny souborů příslušejících konkrétnímu programu či skupině programů – například aplikaci Microsoft Word.

Prostřednictvím softwarových balíků nadefinovaných dle zakoupených licencí programů lze hlídat a sledovat příslušné počty instalovaných licencí konkrétních produktů.


Zaváděcí sektor

Pojmem zaváděcí sektor (angl. boot sector) se označuje speciální oblast zformátovaného datového média, kde je umístěn zavaděč operačního systému. Zavaděč umístěný v zaváděcím sektoru lze spustit pouze tím způsobem, kdy datové médium umístíte do počítače a určíte jej jako „bootovací“.


Zavaděč

Pojmem zavaděč (angl. loader) se rozumí krátký jednoúčelový program určený pro zavedení operačního systému z vnější paměti (rozuměj pevného disku) do vnitřní paměti (rozuměj fyzickou RAM) počítače. Je umístěn na disku ve speciální části označované jako zaváděcí sektor. Zavaděč zkopíruje jádro operačního systému z vnější do vnitřní paměti počítače a předá mu řízení.