
Introduction

The L&H User Dictionary Editor (UDE) is an application designed to create and edit user dictionaries. User dictionaries enable 
you to customize Text-to-Speech output and specify the way in which particular words or strings of characters are pronounced 
(e.g. abbreviations).
User dictionaries may contain orthographic as well as phonetic information. The L&H UDE includes two phonetic alphabet sets 
used to generate phonetic transcriptions: the L&H+ phonetic alphabet and the International Phonetic Alphabet (IPA).
The User Dictionary Editor allows you to hear how dictionary entries are pronounced, using the L&H Text-to-Speech system. 
Text-to-Speech parameters can be set according to your preferences.
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UDE Main Window

The main UDE window consists of the following components:

· Selected Dictionary list 
· Language box 
· UDE Menu 
· Output Message window 
· Exit button 



File Tab

The File Tab is for functions involving the management of user dictionary files.    The following components are provided:

Dictionary Properties 
File command buttons 



Dictionary Properties

Name
Displays the logical name of the user dictionary.

Language
Displays the language of the user dictionary.

Description
Displays a short description of the user dictionary.

Entries
Displays the number of entries in the user dictionary.

Date
Displays the date and time the user dictionary is created.



File Command Buttons

New
Creates a new user dictionary.

Open
Opens a user dictionary.

Close
Closes the user dictionary.

Save
Applies and saves any changes made to the user dictionary.

Save As
Applies any changes made to the user dictionary and saves the dictionary in another file.



Edit Tab

The Edit Tab provides all functions needed for editing user dictionaries. The following components are available:

Dictionary Entries and Phonetic Symbols 
Edit command buttons 



Dictionary Entries and Phonetic Symbols

Dictionary Entries
Lists all entries in the user dictionary.

Source Text
Allows you to display and/or enter the source text (orthographic input) of the dictionary entry.

Destination
Allows you to display and/or enter the target text (orthographic or phonetic input) of the dictionary entry. 

Phonetic Symbols
Displays all phonetic symbols of the currently selected phonetic alphabet.

Example
Displays a phonetic and orthographic sample word for the phonetic symbol selected in the Phonetic Symbols list. 

Alphabet Set
Shows the name of the currently selected alphabet: plain orthographic, L&H+ or international phonetic alphabet (IPA). 

Type
Allows you to select a phoneme type (consonants, vowels, diphthongs, suprasegmentals or additional symbols) within a given 
phonetic alphabet. All phonemes belonging to the selected phoneme type are displayed in the Phonetic Symbols list.
This option is not available for the plain orthographic alphabet.



Edit Command Buttons

New
Clears the Source Text box and Destination box. To enable a new dictionary entry to be entered.

Convert
Converts the word entered in the Source Text box into its phonetic transcription. The converted word is displayed in the 
Destination box. The phonetic transcription used to display the target text depends on the phonetic alphabet selected in the 
Options tab.

Add
Adds a newly created dictionary entry to the user dictionary.

Update
Updates the target text of a dictionary entry.

Delete
Deletes one or more entries from the user dictionary.

Copy
Copies the selected dictionary entries.

Paste
Pastes all copied dictionary entries to the dictionary.

Speak
Allows you to vocalise a dictionary entry by the Text-to-Speech system. 

Help
Displays help on how to use the L&H User Dictionary Editor.

Phonetic Symbols:
Vocalise
Allows you to vocalise the currently displayed sample word spoken by the Text-to-Speech system, thus illustrating the use of the 
selected phonetic symbol in the Phonetic Symbols list. 

Copy
Copies the currently selected phonetic symbol from the Phonetic Symbols list to the Destination box.



Options Tab

The Options Tab allows you to select a phonetic alphabet and set the Text-to-Speech system parameters.

Destination Text Mode
Allows the user to select an alphabet set used for displaying the target text in the Edit tab. 

Three alphabet sets are available: 
· Plain orthographic alphabet
· L&H+ phonetic alphabet
· International phonetic alphabet (IPA)

Parameters button
Click this button to set the Text-to-Speech system parameters (voice, voice attributes, pitch, speed, volume, system context and 
read mode). Changing the speech parameters will affect the way in which the dictionary entries and/or sample words are 
vocalised in the UDE.



Help Tab

The Help Tab offers help on how to use the L&H User Dictionary Editor and provides information on the product you are using.

Contents

Provides information on how to use the L&H User Dictionary Editor.

About

Shows the version number of the L&H User Dictionary Editor and copyright information.



Opening a User Dictionary

1. In the File tab, choose the Open button to prompt the Open Dictionary File dialogue box. 
2. Select the drive and folder where the dictionary is located. The default extension for dictionary files is .DCB.
3. Select the required dictionary. 
4. Click the Open button.
5. The path and name of the user dictionary file are displayed in the top left-hand corner of the main UDE window. The 

dictionary properties are shown in the File tab.

The UDE can handle up to sixteen dictionaries at a time. The path and name of each of these dictionaries is displayed in the 
Selected Dictionary list in the top left-hand corner of the main UDE window.



Closing a User Dictionary

1. If more than one dictionary is opened, make sure the dictionary you want to close is the active file. 
(If this is not the case, select the dictionary you want to close from the Selected Dictionary list in the top left-hand corner of 
the main UDE window.)

2. In the File tab, select the Close button. If changes have been made to the user dictionary, you will be asked to save your 
changes. 

See Also:
Saving a user dictionary 



Saving a User Dictionary

1. If more than one dictionary is opened, make sure the dictionary you want to save is the active file.
(If this is not the case, select the dictionary you want to save from the Selected Dictionary list in the top left-hand corner of the
main UDE window.)

2. In the File tab, click the Save button. When you save a dictionary the first time, the Save As dialogue box appears.
3. Select the drive and folder for saving the dictionary.
4. In the File name box, type a name for the dictionary.
5. Click Save.



Save As: Saving a User Dictionary

1. If more than one dictionary is opened, make sure the dictionary you want to save is the active file.
(If this is not the case, select the dictionary you want to save from the Selected Dictionary list in the top left-hand corner of the
main UDE window.)

2. In the File tab, click the Save As button. The Save As dialogue box appears.
3. Select the drive and folder for saving the dictionary.
4. In the File name box, type a new name for the dictionary.
5. Click the Save button.



Selecting a User Dictionary

The UDE allows you to open up to sixteen dictionaries at a time but you can only view and edit by selecting the relevant 
dictionary from them individually. 

1. To select a dictionary, click on a dictionary file in the Selected Dictionary list in the top left-hand corner of the main UDE 
window. The selected dictionary will be highlighted. 

2. The File tab displays details of the active dictionary file is shown. The dictionary entries box in the Edit tab displays all entries 
contained in the dictionary.



Exiting the UDE 

To exit the UDE, click the Exit button in the bottom right-hand corner of the main UDE window. If changes have been made to 
one or more dictionary files, you will be asked to save the changes.



Creating a New User Dictionary

1. In the File tab, select New.
The New Dictionary dialogue box appears.

2. Enter a logical name for the new dictionary. Each dictionary file should have a unique logical name.
3. From the Language list, select the language for the new dictionary.
4. If you wish, enter a description for the dictionary.
5. Click OK.
6. The File tab will incorporate the information you have just specified. You can now start to enter dictionary entries from the Edit

tab.
7. By default, the new dictionary will be named "Untitled(N).dcb", where (N) is an integer number. This filename is displayed in 

the Selected Dictionary list in the top left-hand corner of the UDE window. When closing, saving or exiting, you will be asked 
to specify a filename and location for the dictionary.



Editing a User Dictionary

To edit a user dictionary:

1. Open or select the dictionary you want to edit, or create a new dictionary file.
2. Go to the Edit tab.
3. Edit the dictionary.

See Also:
Adding a new dictionary entry 
Converting a dictionary entry 
Updating a dictionary entry 
Deleting a dictionary entry 
Copying and pasting a dictionary entry 
Listening to a dictionary entry 



Adding a New Dictionary Entry

1. Open or select the user dictionary file.
2. Select the Options tab.
3. Choose the alphabet set to be used for the target text.
4. Go to the Edit tab.
5. In the Source Text box, enter a word in orthographic spelling. The source text characters is 40; no spaces are allowed.
6. Go to the Destination box.
7. If you selected Plain Orthographic in the Options tab, enter the target text in orthographic spelling.

If you selected one of the two phonetic alphabets in the Options tab, click    convert to convert the source text automatically. 
You may also enter the target text manually (max. 1024 characters).
Note that both source and target text must be specified before an entry can be added to the dictionary.

8. If necessary, edit the automatically generated target text.
9. Click Add. The entry will be added to the Dictionary Entries list box.
10. For each new entry you want to add, click New to clear the Source Text box and Destination box.

See Also:
Converting a dictionary entry 
Manually entering the target text 



Converting a Dictionary Entry

The UDE offers a way to generate the phonetic transcription of a dictionary entry automatically:

1. In the Options Tab, select one of the two phonetic alphabet sets. 
2. Go to the Edit Tab.
3. In the Source Text box, enter the source text. The source text is limited to 40 characters; no spaces are allowed.
4. Click the convert button. The phonetic transcription of the source text is generated automatically and displayed in the 

Destination box. The phonetic alphabet used for the target text depends on the alphabet selected in the Options Tab.
5. If necessary, edit the target text manually. 

Notes:
· Automatically generated transcriptions always contain pause symbols (#) at the beginning and end of the word. If you do 

not want to include these symbols, delete them manually.
· The convert button is used to convert orthographic text into phonetic transcription. Consequently, this button cannot be 

used if the alphabet has been set to "Plain Orthographic".

See Also:
Selecting the alphabet set 



Updating a Dictionary Entry

To update dictionary entries already saved:

1. Open the dictionary you want to update or select it from the Selected Dictionary list.
2. Go to the Edit tab.
3. In the Dictionary Entries list box, select and double-click on the word you want to update. 

The source and target text of the selected entry appear in the source and destination text boxes.
4. Make the necessary changes to the target text.
5. Click Update. 

Note:
The Update button can only be used to update the target text of a dictionary entry. If you want to change the source text of an 
entry (e.g. if you made a spelling mistake), delete the entry and add a new entry instead.



Deleting a Dictionary Entry

To delete an entry from a user dictionary:

1. Open the user dictionary or select it from the Selected Dictionary list.
2. Go to the Edit tab.
3. In the Dictionary Entries list box, select the entry (or entries) you want to delete.
4. Click the Delete button. The Delete dialogue box appears.
5. Click Delete to delete one entry at a time. Click Delete All to delete all selected entries simultaneously.



Copying and Pasting a Dictionary Entry

The UDE allows you to copy one or more entries from one user dictionary to another:

1. Open the dictionary from which you want to copy entries or select it from the Selected Dictionary list.
2. Go to the Edit tab.
3. In the Dictionary Entries list box, select the entry (or entries) you want to copy.
4. Click Copy. 
5. If the dictionary to which you want to copy the entries has not been opened yet, go to the File tab and open or create the 

target dictionary. 
If the target dictionary is already open, select it from the Selected Dictionary list in the top left-hand corner of the main UDE 
window.

6. Go to the Edit tab.
7. Click Paste. The copied entries are added to the Dictionary Entries list box.



Listening to a Dictionary Entry

The UDE enables you to vocalise dictionary entries via the L&H Text-to-Speech system. 

1. In the Edit tab, select an entry from the Dictionary Entries list box.
2. Click Speak. The target text of the selected dictionary entry will be vocalised.

Note:
If you want to change any Text-to-Speech parameters (e.g. volume, voice speed, pitch), click the Parameters button in the 
Options Tab.

See Also:
Changing speech parameters 



Manually Adding the Target Text of a Dictionary Entry

Instead of automatically converting the source text of a dictionary entry, you can also enter the target text manually. 

1. In the Options tab, choose the alphabet set you want to use for the target text.
2. Select the Edit Tab.
3. In the Source Text box, enter a word in orthographic spelling. 
4. Go to the Destination box.

If you selected Plain Orthographic mode in the Options tab:
5a. Type the target text in orthographic spelling. 

If you selected one of the two phonetic alphabets in the Options tab:
5b. Enter the phonetic transcription manually. The phonetic alphabet displayed at the bottom of the Edit tab can be used as a 

reference.
or
5c. Enter the phonetic transcription by copying the phonetic symbols from the alphabet displayed at the bottom of the Edit tab.

Set the Type radio button to `vowels', `consonants', `diphthongs', `suprasegmentals' or `additional'. The selected phoneme 
set will be displayed in the Phonetic Symbols list box.
To copy one or more phonemes from the Phonetic Symbols list to the Destination box:
- double-click the required phoneme in the Phonetic Symbols list. The selected phoneme will be inserted at the cursor 

position in the Destination box. 
- select the required phoneme in the Phonetic Symbols list. Click the copy button to copy the symbol to the Destination 

box.
Repeat these steps for each phoneme you want to enter.

See Also:
Selecting the alphabet set 
Selecting the phoneme type 



Selected Dictionary List

The Selected Dictionary list is located in the top left-hand corner of the main UDE window and lists all currently opened user 
dictionaries. The UDE can handle up to sixteen dictionaries at a time. 



UDE Menu

The UDE Menu contains four tabs. These tabbed pages provide the user interface for managing user dictionaries. The following 
tabs are available:

File Tab
Edit Tab
Options Tab
Help Tab



Output Message Window

The Output Message window is located at the bottom of the main UDE window. It displays a brief history log of user 
transactions and error messages.



Exit Button

Use the Exit button to quit the UDE. Before exiting, you will be asked to save the user dictionary.



Selecting the Alphabet Set

To add entries to the user dictionary, you need to set the alphabet to be used:

1. Go to the Options tab.
2. Under Destination Text Mode, select an alphabet set.

Three alphabet sets are available: 
· Plain orthographic alphabet
· L&H+ phonetic alphabet
· International phonetic alphabet (IPA)

If you select plain orthographic, the target text of the dictionary entries should be specified in orthographic spelling. Plain 
orthographic mode is especially useful if you want to add abbreviations to your user dictionary or if you want to define a 
`sounds like' string for the source text. 



Selecting the Phoneme Type

The UDE provides the phoneme set of each of the two phonetic alphabets used. This makes it easier for you to read or enter 
target texts if you are not acquainted with the phonetic alphabet.

To select a phoneme type:
1. In the Options tab, choose the phonetic alphabet you want to use.
2. Go to the Edit tab.
3. Set the Type radio buttons to vowels, consonants, diphthongs, suprasegmentals or additional.
4. The selected phoneme set will be displayed in the Phonetic Symbols list. Sample words are provided for each of the 

phonemes.

Note:
The phoneme set `suprasegmentals' contains the symbols for indicating syllable boundaries, primary word stress and secondary 
word stress. The phoneme set `additional' contains the symbols for indicating sentence accent, silence, word delimiter and 
punctuation marks. 

See Also:
Showing and vocalising sample words 



Setting the Speech Parameters

The L&H UDE allows you to vocalise a dictionary entry, using the L&H Text-to-Speech system. Text-to-Speech parameters can 
be set according to your preferences. Changing these parameters will affect the way dictionary entries are pronounced by the 
Text-to-Speech system.

The following options are available:

Voice
1. Select the required voice (female or male).
2. Select a set of voice attributes from the list. A selection can be made from variation 1 (default voice attributes) to variation 9.

Each variation has pre-set pitch and speed values. You can also choose to create an additional voice by selecting the user-
defined variation. Only the user-defined option allows you to set the pitch and speed sliders.

3. Use the slider to set the voice pitch. Since voice variations 1 to 9 have pre-set pitch values, the slider can only be used for 
user-defined voices.

4. Use the slider to set the voice speed. Since voice variations 1 to 9 have pre-set rate values, the slider can only be used for 
user-defined voices.

Volume
Use the slider to set the voice volume.

Test
Enter a test sentence in the test box and click the speak button to have the text spoken with the selected speech parameters.

System Context
Select the system context: choose text to read standard text, choose e-mail to read e-mail messages.

General
1. Select the read mode. Choose letter-by-letter, word-by-word, sentence-by-sentence or terminator-based. By default, the

input text will be read sentence-by-sentence. (This option is not available for all languages.)
2. Choose the silence interval between letters, words or sentences (depending on the read mode). The silence interval ranges 

from 0 to 1800 milliseconds.

Buttons :
Show Defaults
Shows the default speech parameter settings.
Cancel
Closes the dialogue without saving any changes you have made.
Apply
Closes the dialogue and applies any changes you have made. When listening to dictionary entries or sample words in the User 
Dictionary Editor, the new speech parameter settings will be activated.

See Also:
Listening to a dictionary entry 
Showing and speaking sample words 



Showing and Vocalising Sample Words

The UDE provides an sample word - both in orthographic and phonetic spelling - for each phoneme of the selected phonetic 
alphabet set. The sample word illustrates the use of the phoneme and is displayed at the bottom of the Edit tab.    

1. Select a phonetic alphabet in the Options tab. 
2. Go to the Edit tab.
3. Under Type, select the phoneme type (vowels, diphthongs, consonants, suprasegmentals or additional symbols). The list of 

phonemes appears in the Phonetic Symbols list box.
4. When clicking a phoneme in the Phonetic Symbols list box, the corresponding sample word is displayed, both in orthographic

and phonetic spelling.
5. To vocalise the sample word pronounciation via the Text-to-Speech system, click the Speak button. 

Note:
If you want to change any Text-to-Speech parameters (e.g. volume, voice speed, pitch), click the Parameters button in the 
Options Tab.



Language Box

The Language box in the top right-hand corner of the main UDE window displays the language of the currently loaded L&H Text-
to-Speech driver.



Shows the version number of the L&H User Dictionary Editor and copyright information.



Enter a name and a description for the new dictionary and select the language.



Shows the version number of the L&H User Dictionary Editor and copyright information.



The Edit Tab dialogue provides all functions for editing user dictionaries. 



The File Tab dialogue is intended for functions involving the management of user dictionary files.



Use the Options Tab to select an alphabet and set the speech parameters.



The Help Tab offers help on how to use the L&H User Dictionary Editor and provides information about the product you are 
using. 



Lists all user dictionaries that are currently open. 



Displays the logical name of the user dictionary.



Displays the language of the user dictionary.



Displays a short description of the user dictionary.



Displays the number of entries in the user dictionary.



Displays the date and time the user dictionary is created.



Click this button to create a new user dictionary.



Click this button to open a user dictionary.



Click this button to close the user dictionary.



Click this button to apply and save any changes made to the user dictionary.



Click this button to apply any changes made to the user dictionary and save the dictionary in another file.



Lists all entries in the user dictionary.



Type the source text (orthographic input) of the dictionary entry.



Displays the target text (orthographic or phonetic input) of the dictionary entry. 



Displays all phonetic symbols of the currently selected phonetic alphabet.



Displays a sample word in phonetic transcription, illustrating the use of the currently selected phonetic symbol in the Phonetic 
Symbols list.



Displays a sample word in orthographic spelling, illustrating the use of the currently selected phonetic symbol in the Phonetic 
Symbols list.



Click this button to vocalise the currently displayed sample word. 



Click this button to copy the currently selected phonetic symbol from the Phonetic Symbols list to the Destination box.



Shows the name of the currently selected alphabet: plain orthographic, L&H+ or international phonetic alphabet (IPA). The 
alphabet is selected in the Options Tab.



Displays all vowels of the currently selected phonetic alphabet in the Phonetic Symbols list.



Displays all diphthongs of the currently selected phonetic alphabet in the Phonetic Symbols list. (Not available for all 
languages.)



Displays all consonants of the currently selected phonetic alphabet in the Phonetic Symbols list.



Clears the Source and Destination Text boxes to enable a new dictionary entry to be entered.



Converts the word entered in the source text box into its phonetic transcription. The converted word is shown in the Destination
box. The phonetic transcription used to display the target text depends on the phonetic alphabet selected in the Options Tab.



Adds a newly created dictionary entry to the user dictionary.



Updates the target text of an entry in the user dictionary.



Deletes one or more entries from the user dictionary.



Copies the selected dictionary entries.



Pastes all copied dictionary entries to the dictionary.



Starts up help on how to use the L&H User Dictionary Editor.



Click this button to vocalise the selected dictionary entry via the Text-to-Speech system.



Select this button to use the plain orthographic mode to display the target text of the dictionary entry.



Select this button to use the L&H+ phonetic alphabet to display the target text of the dictionary entry.



Select this button to use the International Phonetic Alphabet (IPA) to display the target text of the dictionary entry.



Click this button to set Text-to-Speech parameters (voice, voice attributes, pitch, speed, volume, system context and read mode).



Deletes all selected entries from the user dictionary.



Cancels the deletion of a dictionary entry.



Enter the name of the new user dictionary.



Enter a description for the user dictionary.



Select the language of the new user dictionary.



Displays the language of the currently loaded L&H Text-to-Speech driver.



Displays a brief history log of user transactions and error messages.



Select this button to use the L&H+ phonetic alphabet to display the target text of the dictionary entry.



Select this button to use the International Phonetic Alphabet (IPA) to display the target text of the dictionary entry.



Deletes the selected entry from the user dictionary.



Closes this dialogue without saving any changes you have made.



Closes the User Dictionary Editor.



Closes this dialogue and saves any changes you have made.



Closes this dialogue without saving any changes you have made.



Closes this dialogue and saves any changes you have made.



Closes this dialogue without saving any changes you have made.



Shows the version number of the L&H User Dictionary Editor and copyright information.



Starts up help on how to use the L&H User Dictionary Editor.



Displays the target text (orthographic or phonetic input) of the dictionary entry.



Displays all phonetic symbols of the currently selected phonetic alphabet.



Select this button to display all suprasegmental symbols of the currently selected phonetic alphabet in the Phonetic Symbols 
list. 



Select this button to display all additional symbols of the currently selected phonetic alphabet in the Phonetic Symbols list. 




