Windows Media Player SDK

The Windows Media™ Player component of the Microsoft® Windows Media™ Software Development Kit (SDK) enables developers to extend the capabilities of Microsoft® Windows Media™ Player. This SDK component explains how to add multimedia content to your Web site by embedding the Windows Media Player ActiveX® control in a Web page. It also describes how to create a customized user interface by using Windows Media Player skins technology. The custom visualizations section explains how to use Microsoft® Visual C++® with a provided visualization wizard to create visual effects that respond to music. Finally, the SDK explains how Windows Media metafiles are used to build custom playlists, insert advertising in a presentation, add banner graphics, and perform seamless stream switching.

This SDK component has not been installed. You can install it from the following location:

Windows Media Player SDK

© 2000 Microsoft Corporation. All rights reserved.


Windows Media Metafiles

Window Media™ metafiles provide information that Microsoft® Windows Media™ Player uses to receive unicast streams, multicast streams, and other supported media from an intranet or the Internet. This documentation explains how developers can use Windows Media metafiles to build custom playlists, insert advertising into a presentation, add banner graphics, add or modify metadata, and facilitate seamless stream switching. The Windows Media metafile documentation is included in the Microsoft® Windows Media™ Player Software Development Kit (SDK), which is a component of the Microsoft® Windows Media™ SDK.

This SDK component has not been installed. You can install it from the following location:

Windows Media Player SDK

© 2000 Microsoft Corporation. All rights reserved.