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Začínáme

Fireworks 4 představuje řešení pro profesionální grafický webový design. 
Jde o první produkční prostředí, které odpovídá na speciální požadavky, 
které kladou weboví designéři a vývojáři.

S Fireworks® můžete použít vytvářet, upravovat nebo animovat webovou 
grafiku, přidávat pokročilou interaktivitu a optimalizovat grafiku v profesionálním 
prostředí. Program Fireworks kombinuje jak bitmapové, tak vektorové nástroje. 
Ve Fireworks zůstává vše po celou dobu editovatelné. Své workflow můžete navíc 
automatizovat tak, aby vyhovovalo požadavkům na aktualizace a změny.

Fireworks se také integruje s dalšími produkty firmy Macromedia, jako je 
FreeHand, Director, Dreamweaver™ a Macromedia Flash™, ale i s dalšími 
oblíbenými grafickými aplikacemi a HTML editory, a umožňuje tak vytvořit 
skutečně integrované webové řešení. Z Fireworks můžete grafiku jednoduše 
exportovat do HTML kódu a JavaScriptu™ přizpůsobeného pro editor, který 
používáte.

Systémové požadavky

Pro spuštění Fireworks je vyžadován následující hardware a software:

· Pro Microsoft Windows™: procesor Intel Pentium® (doporučeno Pentium 
II); Windows 95, 98, ME, 2000 nebo NT 4 (se Service Packem 5) nebo novější; 
64 MB RAM a 100 MB volného místa na harddisku; rozlišení 800x600 v 256 
barvách (doporučeno 1024x768 v TrueColor); myš nebo tablet; CD-ROM 
mechanika.

ÚVOD

1
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· Pro Macintosh®: Power Macintosh (doporučeno G3 nebo vyšší); System 
8.6 nebo 9.x; 64 MB RAM a 100 MB volného místa na disku; Adobe Type 
Manager® 4 nebo novější pro použití Type 1 fontů; barevný monitor 
(doporučeno rozlišení 1024x768, TrueColor); myš nebo tablet; CD-ROM 
mechanika.

Instalace Fireworks

Před samotnou instalací se ujistěte, že váš počítač odpovídá systémovým 
požadavkům uvedeným výše. Nejaktuálnější informace naleznete v dokumentu 
ReadMe na CD Fireworks.

Instalace Fireworks:

1. Vložte Fireworks 4 CD do CD mechaniky vašeho počítače.

2. Začněte instalaci:

· Ve Windows se instalační program Fireworks spustí automaticky. Pokud ne, 
zvolte v nabídce Start příkaz Spustit (Run). Klepněte na tlačítko Procházet 
(Browse) a na CD s Fireworks 4 vyberte soubor Setup.exe. Klepněte na OK.

· Na Macintoshi klepněte dvakrát na ikonu Fireworks 4 Installer.

3. Postupujte podle informací na obrazovce. Instalační program vás vyzve 
k zadání potřebných informací.

4. Pokud budete požádáni, restartujte svůj počítač.

Jak se naučit Fireworks

Chcete-li se naučit Fireworks, máte možnost použít mnoha různých zdrojů včetně 
tištěného manuálu, systému nápovědy, který můžete spustit z aplikace. Dále máte 
k dispozici interaktivní lekce a množství webových informačních zdrojů.

Nápověda Fireworks (Help) je dostupná, kdykoliv máte aplikaci spuštěnou. 
Obsahuje stejný materiál, jako tento průvodce, plus další doplňkové informace.
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Seminář Fireworks (Tutorial) představuje interaktivní úvod do klíčových vlastností 
Fireworks a můžete ho celý projít zhruba během hodiny. Obsahuje návody na 
provádění běžných úkonů ve Fireworks – optimalizaci GIF a JPEG obrázků, 
vytváření animací a rolloverů. Pokud s Fireworks začínáte, začněte v menu Help 
a projděte si nejprve lekce a pak tento seminář.

Lekce Fireworks (Lessons) jsou série krátkých obrazovkových lekcí, které 
jsou zaměřeny na určité funkce Fireworks od základů animace až po vytváření 
rolloverů a rozbalovacích menu. Každá z lekcí může být dokončena zhruba za 10 
minut. Pokud s Fireworks začínáte, začněte právě s těmito lekcemi a pak přejděte 
k semináři (Tutorial).

Program Fireworks obsahuje mnoho dialogových oken a bublinkových nápověd, 
které jsou navrženy tak, aby vám pomáhali při používání programu. Bublinková 
nápověda se objeví ve chvíli, kdy s kurzorem myši zastavíte nad určitým prvkem 
uživatelského rozhraní.

Kniha Extending Fireworks (Rozšiřujeme Fireworks) obsahuje informace o psaní 
JavaScriptu pro automatizaci úkonů ve Fireworks. Každý příkaz nebo nastavení ve 
Fireworks může být ovládáno pomocí speciálního příkazu JavaScriptu, který umí 
Fireworks interpretovat. PDF verzi knihy Extending Fireworks si můžete stáhnout 
na adrese http://www.macromedia.com/support/fireworks/extend.html.

Webová stránka Fireworks Support Center je pravidelně aktualizována posledními 
informacemi o Fireworks, obsahuje rady expertů, pokročilá témata, příklady, tipy 
a aktualizace. Chcete-li se dozvědět, jaké jsou u Fireworks novinky a jak dostat 
z programu co nejvíce, podívejte se na stránku centra podpory na adrese 
http://www.macromedia.com/support/fireworks/.

Diskuzní skupiny nabízí čilou výměnu zkušeností s ostatními uživateli Fireworks, 
s technickou podporou a s členy vývojového týmu Fireworks. Požijte klienta na 
čtení diskuzních skupin a načtěte si zprávy na adrese 
news://forums.macromedia.com/macromedia.fireworks.

http://www.macromedia.com/support/fireworks/extend.html
http://www.macromedia.com/support/fireworks/
news://forums.macromedia.com/macromedia.fireworks
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Základy Fireworks

Fireworks je nejmodernější aplikace pro návrh grafiky pro web. Jeho inovativní 
řešení se dotýká hlavních problémů, kterým čelí grafici a wedesigneři. 

Fireworks je pro grafiky a webdesignery neuvěřitelně univerzální nástroj. Jeho 
široké spektrum nástrojů vám umožní vytvářet grafiku pomocí těch nejlepších 
vlastností vektorových i bitmapových editorů v rámci jedné aplikace. Můžete 
editovat s pružností vektorových objektů a přitom aplikovat bitmapové efekty 
včetně zkosení hran (bevel), záře (glow), stínů (drop shadow) a filtrů z Photoshopu, 
které se automaticky překreslují přitom, jak kreslíte.

Příchod Fireworks osvobodil webdesignery od nutnosti skákat tam a zpět mezi 
mnoha různými jednoúčelovými aplikacemi. Nedestruktivní efekty (Live Effects) 
odstraňují frustraci pramenící z nutnosti znovu vytvářet webovou grafiku od 
začátku při každé jednoduché změně. Fireworks generují JavaScript a umožňují 
jednoduchou tvorbu rollover efektů. Jejich optimalizační schopnosti sráží velikost 
webové grafiky bez nutnosti obětovat kvalitu.

Vektorová a bitmapová grafika

Počítače zobrazují grafiku buď ve vektorovém nebo bitmapovém formátu. 
Pochopení rozdílu mezi těmito dvěma typy vám pomůže pracovat efektivněji. 
Fireworks vám umožňují vytvářet obrázky pomocí vektorových i bitmapových 
kreslících nástrojů a umožňují vám importovat a pracovat s vektorovou 
i bitmapovou grafikou vytvořenou v jiných aplikacích.

KAPITOLA 2

2 
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Vektorová grafika

Vektorová grafika popisuje obrázky pomocí čar a křivek nazývaných vektory. Ty 
také obsahují informaci o barvě a pozici objektu. Například obrázek listu může být 
popsán jako série bodů, které jsou spojené čárami s měnícími se tvary a tloušťkou. 
Výsledkem bude obrys listu. Barva listu je stanovena barvou obrysu a barvou 
oblasti uzavřené v tomto obrysu.

Pokud upravujete vektorovou grafiku, upravujete vlastnosti čar a křivek 
popisujících tvar. Vektorovou grafiku můžete přesouvat, zvětšovat, měnit její tvar 
nebo barvu bez toho, že by změnila kvalita zobrazení. Objekty můžete překrývat, 
takže jsou částečně skryté, a můžete měnit jejich průhlednost. Vektorová grafika je 
nezávislá na rozlišení, což znamená, že může být bez ztráty kvality zobrazena na 
výstupních zařízeních s různým rozlišením.

Bitmapová grafika

Bitmapová grafika popisuje obrázek pomocí bodů nazvaných pixely, které jsou 
uspořádány v mřížce. Samotná vaše počítačová obrazovka se skládá z velké 
mřížky pixelů. V bitmapové grafice by byl dříve zmíněný list určen pozicí a barvou 
každého pixelu v mřížce. Každý bod má přiřazenou barvu a pokud se na ně díváte 
ve správném rozlišení, jsou tečky spojené jako kostičky v mozaice a tvoří obrázek. 
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Pokud editujete bitmapovou grafiku, upravujete místo čar a křivek jednotlivé pixely. 
Tato bitmapová grafika je závislá na rozlišení, protože data popisující obrázek 
jsou vázána na mřížku určité velikosti. Zvětšení bitmapové grafiky může způsobit 
otrhané okraje obrázků způsobené přeskládáním pixelů v mřížce. Zobrazení 
bitmapové grafiky na výstupním zařízení s nižším rozlišením, než má samotný 
obrázek, také sníží kvalitu tohoto obrázku. 

Workflow Fireworks

Pokud navrhujete grafiku ve Fireworks, můžete vytvářet bitmapové a vektorové 
obrázky, navrhovat webové efekty jako jsou například rollovery nebo rozbalovací 
menu, můžete manipulovat s grafikou tak, abyste snížili velikost souboru, a také 
se můžete zautomatizovat často opakované úkony a zbavit se tak nutnosti je stále 
opakovat.

Když je váš dokument kompletní, můžete ho exportovat jako HTML soubor, 
pokud ho chcete použít na webu, nebo ho můžete uložit do formátu Photoshopu 
nebo Illustratoru, pokud na něm potřebujete provést ještě nějakou další práci.

Vytváření grafiky

Fireworks vám umožňují kreslit ve vektorovém i v bitmapovém módu. Ve 
vektorovém módu můžete kreslit a editovat cesty (křivky), v bitmapovém módu 
upravujete pixely.

Nové vektorové a bitmapové obrázky ve Fireworks vytváříte tak, že na panelu 
Tools vyberte příslušné nástroje a použijete je na plátně. Každý kreslící mód má 
svoji vlastní sadu nástrojů. Některé jsou specifické jen pro jeden mód, jiné fungují 
v obou módech, i když mohou v každém fungovat trochu odlišně. 

Vytváření webových objektů

Webové objekty jsou základní stavební bloky, které Fireworks používá pro 
vytváření interaktivních webových stránek. Webový objekt je buď řez (slice) nebo 
aktivní oblast (hotspot). Řezy rozdělují obrázek na různé sekce a umožňují vám na 
jednotlivé částí celého obrázku použít chování (behavior), animaci nebo odkaz na 
URL. Řezy vám také umožňují exportovat každou takovou sekci s jiný, nastavením. 
Hotspot vám jednoduše dovolí přiřadit k celé nebo k části grafiky odkaz na URL. 
K hotspotu můžete také připojit určitá chování. 
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Optimalizace

Ve Fireworks můžete optimalizovat webovou grafiku a minimalizovat tak velikost 
souboru – získáte tak rychle se načítající webové stránky. Fireworks nabízí silné 
optimalizační techniky, které vám pomohou dosáhnout menší velikosti souboru 
bez ztráty kvality informace, kterou chcete sdělit.

Můžete si například vybrat pozadí fotografie a snížit počet barev v této konkrétní 
části. Nebo můžete obrázek rozřezat na menší části a každou část převést do 
formátu, který se nejlépe hodí pro její obsah.

Export dokumentů

Pokud jste nastavili optimalizaci vašeho obrázku, je dalším krokem export 
do souboru, který se dá prohlédnout ve webovém prohlížeči nebo který je 
kompatibilní s jinou grafickou nebo webovou aplikací. Nezávisle na tom, 
jaké exportní nastavení použijete, zůstane původní PNG soubor z Fireworks 
nezměněný. Tímto způsobem můžete pomocí jednoho zdrojového souboru 
exportovat do mnoha různých webových nebo tiskových formátů.

Optimalizaci grafiky můžete provést také jako součást procesu exportování. 
Během exportu jsou dostupné všechny optimalizační volby.
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Pracovní prostředí Fireworks

Pokud spustíte Fireworks poprvé, zobrazí se vám v horní části obrazovky menu, 
na levé straně panel Tools s nástroji a několik panelů se záložkami na pravé straně. 
Pokud otevřete dokument, Fireworks umístí okno s dokumentem doprostřed.
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Zobrazení dokumentu ve Fireworks

V okně dokumentu je v titulku okna zobrazeno jméno dokumentu a aktuální 
procento zvětšení. V záhlaví vidíte také čtyři záložky. Každá záložka představuje 
odlišný pohled na dokument. Záložka Original zobrazuje aktuální PNG dokument. 

Další tři záložky zobrazují náhledy dokumentu tak, jak se bude exportovat. 

Záložka Original a další tři náhledové záložky v levém horním rohu pracovní plochy.

Zobrazení původního PNG dokumentu:

Klepněte v okně dokumentu na záložku Original.

Náhledy dokumentu

Záložka Preview zobrazuje grafiku v závislosti na aktuálním nastavení exportu tak, 
jak se objeví ve webovém prohlížeči. V pohledech 2-Up a 4-Up můžete porovnávat 
náhledy založené na odlišném exportním nastavení. V těchto pohledech můžete 
porovnat i optimalizovanou a původní verzi dokumentu.

Zobrazení náhledu exportu:

V okně dokumentu klepněte na záložku Preview, 2-Up nebo 4-Up.

Ke změně exportního nastavení použijte panely Optimize a Color Table. Tyto 
panely a pohled Preview nahrazují dialogové okno Export Preview z předchozích 
verzí Fireworks a přenáší vám tak optimalizaci přímo na pracovní plochu.

V pohledu Preview můžete také zkontrolovat funkčnost rollover efektů, navigace 
a animace.
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Zobrazení a výběr nástrojů

Panel Tools obsahuje nástroje, které používáte pro vytváření, výběr a editaci 
objektů. Ve Windows vám mnoho příkazů zpřístupňují ještě panely nástrojů  Main 

a Modify. Pokud jste uživatel Macintoshe, můžete tyto příkazy vybrat z menu. 

Panel Tools obsahuje tucty nástrojů, z nichž některé jsou uspořádány do skupin, 
jak vidíte na obrázku. Skupina nástrojů je vyznačena malým trojúhelníčkem 
v pravém dolním rohu nástroje. 

Nástroj vyberte klepnutím na něj. Z jednoho nástroje na druhý se můžete také 
přepínat stiskem klávesových zkratek. 

Poznámka: Klávesovou zkratku nástroje se můžete vidět i v bublinkové nápovědě, 
která se zobrazí pokud nad ikonou nástroje na panelu Tools podržíte kurzor myši.
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Výběr alternativního nástroje z nástrojové skupiny:

1. Klepněte myší na jakýkoliv nástroj s trojúhelníčkem v pravém dolním rohu 
a podržte.

2. Přetáhněte kurzor na alternativní nástroj, který potřebujete, a uvolněte tlačítko 
myši. Vybraný nástroj se zobrazí na panelu Tools.

Poznámka: Funkce některých nástrojů se mění v závislosti na tom, zda editujete 
bitmapy nebo vektorové objekty. 

Uspořádání panelů nástrojů (jen ve Windows)

Panely nástrojů můžete zobrazit nebo skrýt, vyjmout z doku nebo je přesunou na 
obrazovce nahoru nebo dolů. 

Zobrazení nebo skrytí panelu Tools nebo panelu nástrojů:

V menu zvolte Window > Tools nebo vyberte příslušný panel nástrojů v podmenu 
Window > Toolbars.

Pokud je panel nástrojů vyjmut z doku, můžete klepnout na tlačítko Close 
v pravém horním rohu záhlaví panelu.

Vyjmutí panelu nástrojů z doku:

Přetáhněte panel za jeho záhlaví s titulkem mimo jeho pozici v doku. Z panelu 
nástrojů se stane plovoucí panel. 

Umístění panelu do doku:

1. Uchopte panel za jeho záhlaví s titulkem.

2. Přetáhněte panel nástrojů do oblasti doku v horní nebo dolní části okna 
aplikace. 
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Změna nastavení nástroje

Panel Tool Options zobrazuje nastavení vztahující se k aktivnímu nástroji. 
Například nástroj Pointer (šipka) obsahuje volby Mouse Highlight, Preview Drag 
a Show Fill Handles. Více informací o konkrétním možnostech jednotlivých 

nástrojů se dozvíte v průběhu manuálu při představování jednotlivých nástrojů. 

Zobrazení nebo skrytá panelu Tool Options:

• Klepněte dvakrát na nástroj na panelu Tools.

• Zvolte v menu Window > Tool Options.

Používání panelů

Panely jsou plovoucí sady ovladačů, které vám pomáhají editovat různé aspekty 
vybraného objektu. Panely vám umožní pracovat s jednotlivými snímky, vrstvami, 
symboly, barvami, atd. Například můžete použít panel Effect a vybrat efekt, který 
chcete na objekt aplikovat. 

Každý panel jde přetáhnout, takže si můžete jednotlivé nástroje seskupovat 
do vlastního uspořádání. 

Panel Mini-Launcher obsahuje ikony pro otevírání a zavírání nejčastěji používaných 
panelů včetně panelu Stroke (obrys), Layers (vrstvy), Behaviors (chování) 
a Optimize (optimalizace). Panel Mini-Launcher je umístěn na spodním okraji okna 
každého dokumentu. 
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Panely Object (objekt), Stroke (obrys), Fill (výplň) a Effect (efekt) ovládají 
široké spektrum vlastností objektu.

Panely Color Mixer (mixér barev) a Swatches (vzorky barev) spravují aktuální 
barevnou paletu dokumentu.

Panely Layers (vrstvy) a Frames (snímky) slouží pro organizaci struktury 
dokumentu a obsahují nástroje na vytváření, mazání a práci s vrstvami a snímky. 
Panel Frames obsahuje volby pro vytváření animace.

Panel Behaviors (chování) spravuje chování, která určují jak bude určitá aktivní 
oblast nebo řez reagovat na pohyby myši.

Panel History (historie) vypisuje seznam příkazů, které jste naposledy použili, 
takže se můžete rychle vrátit zpět nebo zase vpřed. Můžete si také vybrat příkazy, 
které budete chtít opakovat, a uložit si tyto příkazy do sekvencí, které pak 
používáte jako jediný příkaz.

Panel Library (knihovna) obsahuje grafické symboly, symboly tlačítek a animační 
symboly. Instance těchto symbolů můžete jednoduše z knihovny přetáhnout do 
dokumentu. Můžete provádět globální změnu všech instancí jenom tím, že upravíte 
zdrojový symbol.

Panely Optimize (optimalizace) a Color (barva) vám umožní ovládat 
výslednou velikost souboru a jeho typ.

Project Log (záznam projektu) vám umožní exportovat vybrané soubory 
pomocí jejich posledního exportního nastavení a vybrat soubory pro dávkové 
zpracování.

Panel Info (informace) poskytuje informace p rozměrech vybraných objektů 
a o přesných souřadnicích ukazatele myši při jeho pohybu nad dokumentem.

Panel Tool Options (volby nástroje) vám umožňuje upravit a nastavit aktuálně 
zvolený nástroj.

Panel Styles (styly) vám umožní upravit vzhled objektu nebo textu. Program 
Fireworks se dodává s množstvím stylů, ze kterých si můžete vybrat.
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Zobrazení nebo skrytí panelu:

Vyberte jméno panelu z menu Window.

Všechny panely mají roletové menu Options. 

Klepnutím otevřete menu.

Výběr možnosti z roletového menu Options panelu:

1. Klepněte na šipku mířící doprava v pravém horním rohu panelu. Objeví se 
menu Options.

2. Vyberte z menu Options požadovaný příkaz.

Některé ovládací prvky na panelech mají vlastní roletové menu, rozbalovací paletu 
barev, jezdce nebo stupnici.

Použití menu u ovládacího prvku:
1. Klepněte na šipečku mířící dolů vedle textového pole. 

2. Změňte hodnotu:

• Vyberte volbu nebo vzorek barvy.

• Zatáhněte za jezdce nebo stupnici.

• Stiskněte první písmeno možnosti, kterou chcete vybrat (Windows). 
Opakovaným stisknutím písmena budete procházet mezi možnostmi 
začínajícími tímto písmenem.
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Zadání informace do textového pole na panelu:

1. Klepněte do textového pole.

2. Napište hodnotu.

3. Stiskněte Enter.

Zkombinování dvou nebo více panelů:

1. Přetáhněte plovoucí panel nad jiný plovoucí panel. Když se okolo spodního 
panelu objeví zvýrazněný okraj, uvolněte tlačítko myši.

2. Klepnutím na libovolnou záložku ve skupině přenesete panel do popředí.

Odstranění panelu ze skupiny panelů:

Přetáhněte panel za jeho záložku mimo skupinu panelů.

Skrytí panelu nebo skupiny panelů se záložkami:

Klepněte na tlačítko Close v pravém horním rohu panelu nebo skupiny panelů.

Skrytí všech panelů nebo zobrazení skrytých panelů:

• V menu zvolte View > Hide Panels.

Poznámka: Panely, které byly skryté, když jste v menu aktivovali Hide Panels (skrýt 
panely), zůstanou skryté i potom, co tuto volbu deaktivujete.

Vrácení panelů do jejich výchozích pozic:

• V menu zvolte Commands > Panel Layout Sets > 1024 x 768.
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Resetování předvoleb aplikace:

1. Ukončete Fireworks.

2. Smažte soubor s předvolbami pojmenovaný Fireworks 4 Preferences v adresáři, 
kam jste nainstalovali Fireworks (Windows) nebo v adresáři System\Preferences 
(Macintosh).

3. Znovu spusťte Fireworks.

Používání kontextových menu

Kontextová menu vám umožní rychlý přístup k příkazům, které jsou relevantní 
k aktuálnímu výběru.

Zobrazení kontextového menu:

Klepněte pravým tlačítkem myši (Windows) nebo klepněte se stisknutou klávesou 
Control (Macintosh) na zvoleném prvku v okně dokumentu.
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Nastavení předvoleb

Nastavením předvoleb Fireworks ovládáte obecný vzhled a chování uživatelského 
rozhraní stejně jako další aspekty editace.

Nastavení předvoleb:

1. V menu zvolte Edit > Preferences.

2. Vyberte skupinu předvoleb, kterou chcete upravit. (Detaily o těchto skupinách 
předvoleb se dozvíte v následující části.)

3. Proveďte požadované změny a klepněte na tlačítko OK.

Nastavení předvoleb General (obecné předvolby)

Mezi obecné předvolby patří nastavení počtu možných kroků zpět (undo), výchozí 
barvy a nastavení interpolace.

Volbou Undo Steps nastavíte počet kroků zpět nebo vpřed na číslo mezi 0 a 100. 
Toto nastavení platí jak pro příkaz Edit > Undo tak pro panel History.

Vyšší počet kroků zpět může zvýšit množství paměti požadované programem 
Fireworks.

Volby Color Default nastavují výchozí barvy pro tahy štětcem, výplně a zvýrazněné 
cesty.

Volba Interpolation nastavuje jednu ze čtyř různých metod interpolace, kterou 
Fireworks používá pro interpolaci pixelů při změně velikosti obrázku:

• Interpolace Bicubic (bikubická) poskytuje ve většině případů nejostřejší 
a nejkvalitnější výsledek a proto výchozí metodou.

• Interpolace Bilinear (bilineární)  poskytuje sice ostřejší výsledek než interpolace 
Soft, ale ne tak ostrý jako u bikubické interpolace.

• Interpolace Soft (měkká) se používala ve Fireworks 1. Jejím výsledkem je mírné 
rozmazání, které eliminuje ostré detaily. Tato metoda je užitečná ve chvílích, kdy 
ostatní metody vytvářejí nežádoucí artefakty.

• Výsledkem interpolace Nearest Neighbor (nejbližší soused) jsou zubaté okraje 
a vysoké kontrasty bez jakéhokoliv rozmazání. Efekt je podobný zvětšení nebo 
zmenšení obrázku nástrojem Zoom (lupa).
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Nastavení předvoleb Editing (editace)

Editačními předvolbami ovládáte vzhled kurzoru a vizuální pomůcky při práci 
v bitmapovém módu.

Volba Precise Cursors (přesné kurzory) nahrazuje ikonu nástroje kurzorem 
ve tvaru nitkového křížku.

Delete Objects when Cropping (smazat objekty při oříznutí) nevratně smaže pixely 
nebo objekty, které byly mimo hraniční obdélník výběru při použití nástroje Edit > 
Crop Document nebo Modify > Canvas Size.

Brush Size Painting Cursors (kurzory velikosti štětce) nastavují velikost kurzoru 
myši u nástrojů Brush (štětec) a Eraser (guma) tak, aby přesně odpovídala tomu, 
čím budete kreslit nebo mazat.

Poznámka: Pro určité štětce s více hroty bude mít kurzor tvar výchozího nitkového 
křížku.

Expand to Fill Document (roztáhnout na velikost dokumentu) roztáhne při vstupu 
do bitmapového módu proužkované okraje tak, aby obklopovali celé plátno. To 
vám umožní editovat pixely po celém dokumentu. Pokud je tato volba vypnutá, 
můžete upravovat jenom pixely uvnitř hranic vybraného bitmapového objektu.

Open in Bitmap Mode (otevřít v bitmapovém módu) otevře jakýkoliv dokument 
přímo v bitmapovém módu. Pokud je tato volba vypnutá, otevírají se všechny 
soubory ve vektorovém módu.

Turn Off  „Hide Edges“ (Vypnout příkaz „Skrýt okraje“) automaticky deaktivuje 
příkaz Hide Edges při vstupu nebo odchodu z bitmapového módu.

Display Striped Border (zobrazit proužkovaný okraj) automaticky zapne 
proužkovaný okraj okolo bitmapového obrázku v bitmapovém módu.

Pick Distance (vzdálenost pro uchopení) vám umožní nastavit, jak blízko musí být 
kurzor u objektu, abyste ho mohli vybrat. Tato vzdálenost může být mezi 1 až 10 
pixely.

Snap Distance (vzdálenost pro přichycení) vám umožní nastavit, jak blízko musí 
objekt být, než se přichytí na mřížku nebo vodící linku. Nastavení Snad Distance 
se používá v případě, že jsou aktivované příkazy Snap ti Grid (přichytávat k mřížce) 
nebo Snap tu Guides (přichytávat k vodícím linkám). Tuto vzdálenost můžete 
nastavit na hodnotu 1 až 10 pixelů.
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Nastavení předvoleb Launch and Edit 
(spustit a upravit)

Zde můžete nastavit, zda má Fireworks otevřít zdrojový PNG soubor, když 
upravujete a optimalizujete obrázek v Dreamweaveru.

Volba When Editing from External Application (při úpravách v externí aplikaci)  
určuje, zda se má otevřít původní PNG soubor z Fireworks, když používáte 
Fireworks pro editaci obrázků z Dreamweaveru nebo jiného HTML editoru. 

Volba When Optimizing from External Application (při optimalizaci v externí 
aplikaci)  určuje, zda se má otevřít původní PNG soubor z Fireworks, když 
v Dreamweaveru použijete u grafického objektu příkaz Optimize Image in 
Fireworks. 

Nastavení předvoleb Folders (externí adresáře 
a odkládací disky)

Předvolby na záložce Folders vám umožňují přístup k doplňkovým plug-inům  pro 
Photoshopu, souborům textur a vzorů z externích zdrojů. Můžete také nastavit, 
kam chcete, aby Fireworks ukládal své dočasné soubory.

Skupina Additional Materials (Photoshop Plug-ins, Textures, Patterns) ukazuje na 
adresáře s plug-iny, texturami a vzory. Tyto adresáře se mohou nacházet v jiném 
adresáři na vašem disku, na CD-ROMu nebo jiném externím disku nebo na 
síťovém disku.

• Plug-iny z Photoshopu se objeví ve Fireworks v menu Xtras a na panelu 
Effects.

• Textury a vzory uložené jako PNG soubory se objeví jako volby v roletkách 
Pattern a Texture na panelu Fill a v roletce Texture na panelu Stroke.
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V oblasti Scartch Disks (Primary a Secondary) nastavujete, kam má Fireworks 
ukládat dočasné soubory, které mohou být někdy velmi velké. Pokud máte 
v počítači více jak jeden harddisk, určete jako primární odkládací disk ten 
s nevětším objemem volného místa. Můžete určit i sekundární disk, který se 
použije v případě, že na prvním dojde volné místo.

Nastavení předvoleb Import (předvolby pro import 
souborů z Photoshopu)

Předvolby na záložce Import ošetřují záležitostí týkajících se importování souborů 
z Photoshopu.

Změna sad klávesových zkratek

Fireworks vám umožňují používat klávesové zkratky pro výběr příkazů z menu, 
výběr nástrojů z panelu Tools a pro urychlení různých úkonů, které neexistují 
ani jako příkazy v menu. Pomocí klávesových zkratek zvýšíte svoji produktivitu, 
protože budete moci jednoduché akce provádět velmi rychle. Pokud jste používali 
klávesové zkratky v jiných aplikacích, jako je například FreeHand, Illustrator, 
Photoshop nebo jiné produkty používající standard Macromedia, můžete si 
přepnout na takovou sadu klávesových zkratek, která vám vyhovuje.

Změna aktuální sady klávesových zkratek:

1. Z menu Edit zvolte příkaz Keyboard Shortcuts.

2. Z roletky Current Set vyberte požadovanou sadu zkratek.
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Dialogové okno Keyboard Shortcuts (klávesové zkratky).

Vytváření vlastních zkratek

Ve Fireworks si můžete vytvořit vlastní klávesové zkratky.  Chcete-li to 
udělat, zduplikujte si některou z předinstalovaných sad a potom tuto kopii 
příslušně modifikujte. Vlastní klávesové zkratky jsou vždy založeny na nějaké 
předinstalované sadě. Sady zkratek by se měl držet několika málo obecných 
pravidel:

• Příkazy menu musí obsahovat Control key (kontrolní klávesu)(Windows) nebo 
Command key (příkazovou klávesu)(Macintosh).

Poznámka: Jedinou výjimkou z tohoto pravidla je případ, kdy příkazu v menu 
přiřadíte některou funkční klávesu (F2 až F12).

• Ve Fireworks nemohou klávesové zkratky pro nástroje obsahovat některou 
z modifikačních kláves (ve Windows jsou to Control, Shift nebo Alt, na 
Macintoshi jsou to Command, Shift a Control). Zkratky pro nástroje sestávají 
pouze z jednoduchého písmene nebo číslice.



  Základy Fireworks 4  36

Vytvoření vlastní klávesové zkratky pro příkaz menu, nástroj nebo 
jinou akci:

1. Otevřete dialogové okno Keyboard Shortcuts.

2. Klepněte na tlačítko Duplicate Set (duplikovat sadu).

3. V dialogovém okně Duplicate Set zadejte jméno vlastní sady a klepněte na OK.
Jméno nové sady se objeví v poli Current Set.

4. Z roletky Commands vyberte příslušnou kategorii zkratek. Vyberte položku 
Menu Commands (příkazy menu), pokud chcete vytvářet zkratku pro jakýkoliv 
příkaz dostupný v menu programu.

• Vyberte položku Tools (nástroje), pokud chcete vytvářet zkratku pro nějaký  
nástroj z panelu Tools.

• Vyberte položku Miscellaneous (různé) pokud chcete vytvářet zkratku pro 
předdefinované akce. 

Jakmile provedete volbu, objeví se seznam všech možných příkazů v dané 
kategorii, pro které můžete nadefinovat zkratku.

5. Ze seznamu Commands vyberte příkaz, jehož zkratku chcete upravit.
Aktuální zkratka je zobrazena v poli Shortcuts (zkratky).

6. Do pole Press Key (stisknout klávesu) zadejte  novu klávesovou zkratku.

7. Klepněte na tlačítko Change.

Vytváření sekundárních zkratek

Pokud potřebujete mít několik různých způsobů, jak provést určitou akci, můžete 
vytvořit i sekundární klávesové zkratky. Sekundárná klávesové zkratky se zobrazují 
v poli Shortcuts pod už existujícími zkratkami. Zkratky můžete samozřejmě 
vytvářet i tam, kde ještě žádná zkratka není.

Vytvoření sekundární zkratky nebo nové zkratky tam, kde ještě 
žádné zkratka neexistuje:

1. Postupujte podle kroků 1 až 6 předcházející procedury.

2. Klepněte na tlačítko Add Shortcut (+) (přidat zkratku).

3. Zadejte novou klávesovou zkratku.
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Smazání vlastních zkratek a vlastních sad zkratek

Jakoukoliv vlastní zkratku nebo sadu zkratek můžete smazat.

Smazání vlastní sady zkratek:

1. Otevřete dialogové okno Keyboard Shortcuts. 

2. Klepněte na tlačítko Delete Set.

3. V dialogovém okně Delete Set vyberte sadu zkratek, kterou chcete smazat.

4. Klepněte na tlačítko Delete.
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Smazání vlastní klávesové zkratky:

1. V poli Shortcuts vyberte zkratku, kterou chcete smazat.

2. Klepněte na tlačítko Remove Shortcut (-) (odstranit zkratku).

Vytvoření referenční karty z aktuální sady zkratek

Referenční karta je záznam aktuální sady zkratek uložený ve formátu HTML 
tabulky. Tuto referenční kartu si můžete vytisknout nebo prohlédnout ve webovém 
prohlížeči.

Vytvoření referenční karty:

1. Otevřete dialogové okno Keyboard Shortcuts.

2. Klepněte na tlačítko Export Set as HTML (exportovat sadu jako HTML) vedle 
pole Current Set.
Objeví se dialogové okno Save.

3. Zadejte jménu souboru a vyberte jeho požadované umístění.

4. Klepněte na tlačítko Save.
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Vracení a opakování několika akcí

Na panelu History (historie) si můžete prohlédnout, upravit nebo opakovat 
akce, které jste použili při vytváření dokumentu. Panel History vypisuje seznam 
posledních akcí provedených ve Fireworks a to až do počtu kroků nastavených 
v předvolbách aplikace. Na panelu History můžete provádět následující věci:

• Rychle vrátit zpět (undo) nebo vpřed (redo) poslední akce pomocí značky.

• Vybrat na panelu History posledně provedené akce a klepnutím na tlačítko 
Repeat je zopakovat.

• Uložit skupinu posledně provedených akcí jako vlastní příkaz. Ten potom 
můžete vybrat v menu Command a použít celou sadu akcí jako jediný 
příkaz. Více informací o vytváření příkazů na panelu History najdete v části 
„Skriptování“ na straně 380.

Vrácení provedených akcí zpět nebo vpřed:

1. Z menu zvolte Window > History a zobrazte tak panel History.

2. Myší přetáhněte značku po seznamu akcí nahoru nebo dolů.
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Zopakování akcí:

1. Pokud mají příkazy ovlivnit některé objekty, vyberte tyto objekty.

2. Na panelu History zvýrazněte příkazy, které se mají zopakovat. Pokud chcete 
vybrat spojitý blok příkazů, podržte stisknutou klávesu Shift.

3. Klepněte na tlačítko Replay ve spodní části panelu History.

Uložení akcí pro opětovné použití:

1. Zvýrazněte požadované akce na panelu History.

2. Klepněte na tlačítko Save ve spodní části panelu.

3. Zadejte jméno příkazu a klepnutím na OK přidejte příkaz do menu Commands.

Použití uloženého příkazu:

Vyberte jméno příkazu v menu Commands.
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Založení dokumentu ve Fireworks

Pokud v menu zvolíte File > New, vytvoříte ve Fireworks nový dokument ve 
formátu PNG (Portable Network Graphics). PNG je pro Fireworks nativním 
formátem. Když ve Fireworks vytvoříte nějakou grafiku, můžete ji exportovat 
do dalších používaných grafických formátu pro web, např. JPEG, GIF nebo 
animovaný GIF. Pokud grafiku vyexportujete do jiného souborového formátu, 
zůstane původní PNG ve Fireworks nezměněné, takže ho můžete používat znovu 
a znovu.

Když máte otevřený PNG dokument, můžete si grafiku přibližovat nebo oddalovat. 
Můžete měnit velikost nebo rozlišení dokumentu. Můžete také otočit plátno 
a tak třeba obrátit importovaný obrázek vzhůru nohama nebo na bok. Můžete také 
připínat hodnotu Gamma a vidět tak, jak bude grafika vypadat na monitorech buď 
ve Windows nebo na Macintoshi.

Můžete otevřít soubory ve formátu Photoshop. FreeHand, Illustrator, 
nekomprimovaný CorelDRAW�, WBMP, EPS a animovaný GIF. Navíc můžete 
importovat obrázky z digitálního fotoaparátu nebo skeneru. Můžete také 
exportovat do dalších formátů. 

Vytvoření nového dokumentu

Chcete-li ve Fireworks vytvářet webovou grafiku, musíte nejprve založit nový 
dokument nebo otevřít nějaký existující. U nového dokumentu je mnohem 
efektivnější nastavit vše správně napoprvé, než potom provádět spoustu změn 
později.

Pokud chcete, aby velikost nového dokumentu odpovídala nějaké jiné grafice, 
můžete tuto grafiku nejprve zkopírovat do schránky. 

KAPITOLA 3

3
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Vytvoření nového dokumentu

1. V menu zvolte File > New. Objeví se dialogové okno New Document.

2. Zadejte šířku a výšku plátna v pixelech, palcích nebo centimetrech.
Jakákoliv grafika, kterou budete vytvářet se potom musí vejít na toto plátno.

3. Zadejte rozlišení obrázku v pixelech na palec nebo v pixelech na centimetr.

4. Vyberte, jako barvu pozadí má mít plátno (Canvas color): bílou (white), 
průhlednou (Transparent) nebo uživatelskou (Custom).
Chcete-li vybrat nějakou vlastní uživatelskou barvu, klepněte na rozbalovací 
políčko s barvou.

5. Klepnutím na OK otevřete nový dokument.

Vytvoření nového dokumentu stejné velikosti jakou má existující objekt:

1. Z jednoho z následujících zdrojů zkopírujte objekt do schránky (clipboard):

• z jiného dokumentu ve Fireworks

• z webového prohlížeče

2. V menu zvolte File > New. Objeví se dialogové okno New Document ve 
kterém bude vyplněna šířka a výška odpovídající objektu ve schránce,

3. Nastavte rozlišení a barvu pozadí a klepněte na OK.

4. Chcete-li do dokumentu vložit objekt ze schránky, zvolte v menu Edit > Paste.
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Otevření existujícího dokumentu:

1. V menu zvolte File > New. Objeví se dialogové okno Open.

2. Vyberte požadovaný soubor a klepněte na tlačítko Open.

Otevírání grafiky z jiných aplikací

Ve Fireworks můžete otevřít soubory z jiných aplikací nebo v jiných formátech, 
a to včetně Photoshopu, FreeHandu, nekomprimovaný formát CorelDRAW, 
WBMP, EPS a animované GIFy.

Pokud pomocí příkazu File > Open otevřete jiný souborový formát než PNG, 
je ve Fireworks vytvořen nový dokument. Nový dokument má formát PNG 
a původní soubor zůstává nezměněn.

Otevírání souborů z Fireworks 1

Ve Fireworks 1 je vrstva pozadí obrázek trvale se roztahující přes celé plátno. 
Pod vrstvou pozadí nemohou ležet žádné další vrstvy nebo objekty. 
Ve Fireworks 4 nejsou žádné permanentní vrstvy pozadí.

Pokud otevřete dokument z Fireworks 1 ve Fireworks 4, je vrstva pozadí 
z Fireworks 1 převedena na bitmapový objekt a umístěna jako sdílená vrstva 
na spodek dokumentu. Také URL overlay z Fireworks 1 je převeden ve Fireworks 4 
na webovou vrstvu (web layer).
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Otevírání souborů z Photoshopu

Pokud ve Fireworks otevřete soubor z Photoshopu, při výchozím nastavení 
zůstanou textové vrstvy stále editovatelné a ostatní vrstvy z Photoshopu jsou 
převedeny na Fireworks objekty. Nastavení importu z Photoshopu můžete 
upravit tak, aby se jednotlivé vrstvy z Photoshopu importovali do Fireworks jako 
jednotlivé snímky a textové vrstvy jako bitmapové obrázky. 

Poznámka: Ve Windows musí soubory z Photoshopu obsahovat koncovku PSD, 
aby je Fireworks rozpoznal jako formát Photoshopu.

Otevření souborů z Photoshopu

1. V menu zvolte File > Open.

2. Vyberte soubor a klepněte na tlačítko Open.

Otevírání souborů z FreeHandu, Illustratoru nebo 

CorelDRAW

Ve Fireworks můžete otevřít vektorové kresby z FreeHandu, Illustratoru nebo 
z CorelDRAW a pak na ně aplikovat potřebné úpravy, jako jsou například tahy 
štětce nebo texturovaná výplň.

Fireworks umí importovat nekomprimované CDR soubory vytvořené 
v CorelDRAW 7 nebo 8 pro Windows.Fireworks neumí otevřít komprimované 
CDR soubory nebo CMX soubory.

Protože CorelDRAW podporuje rozdílnou sadu funkcí než Fireworks, dojde při 
importu CDR souborů k těmto změnám:

• Obsah Master page (vzorové stránky v CorelDRAW) se bude ve Fireworks 
opakovat v každém snímku .

• U přechodu mezi objekty (blend) budou naimportovány jenom dva koncové 
objekty (ne jejich mezistupně). Oba objekty budou po importu seskupeny.

• Dimenze (dimensions) se převádí na vektorový objekt.
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• Základní text je importován. Většina parametrů nastavených u znaků 
a odstavců však podporována není.

• Barvy jsou převedeny do RGB.

Otevření souborů z FreeHandu, Illustratoru nebo CorelDRAW:

1. V menu zvolte File > Open.

2. V dialogovém okně Vector File Options nastavte požadované volby:

Scale (velikost) určuje velikostní poměr importovaného obrázku.

Width a height (šířka a výška) určuje v pixelech šířku a výšku importovaného 
souboru.

Resolution (rozlišení) nastavuje rozlišení importovaného obrázku.

Anti-Alias (vyhlazení hran) vyhlazuje importované objekty a zabraňuje tak 
zubatým hranám.

Poznámka: Chcete-li vybrané objekty změnit na vyhlazené hrany (Anti-Alias) 
nebo hrubé hrany (Hard Edge), zvolte po importu v menu příkaz Modify > Alter > 
Hardfill, Anti-Alias Fill nebo Feather Fill

File Conversion (konverze souboru) určuje, jak je při importu naloženo 
s vícestránkovými dokumenty:
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• Volba Open a page (otevřít stránku) naimportuje jen jednu určenou stránku.

• Volba Open pages as frames (otevřít stránky jako snímky) naimportuje všechny 
stránky z dokumentu a každou umístí do samostatného snímku.

• Remember layers (zapamatovat si vrstvy) zachová strukturu vrstev 
importovaného souboru.

• Convert Layers to frames (převést vrstvy na snímky) umístí každou vrstvu 
importovaného dokumentu do samostatného snímku.

Include Invisible Layers (zahrnout neviditelné vrstvy) importuje i objekty ve 
vrstvách, které byly vypnuty. Jinak jsou neviditelné vrstvy ignorovány.

Include Background Layers (zahrnout vrstvu pozadí) importuje i objekty z vrstvy 
pozadí dokumentu. Jinak je vrstva pozadí ignorována.

Render as image (vykreslit jako obrázky) rastruje složité skupiny, přechody 
nebo výplně a každou skupinu vkládá do dokumentu Fireworks jako jednu 
bitmapu.Zadáním čísla do textových polí nastavujete, kolik objektů má minimálně 
skupina, přechod nebo výplň obsahovat, než je při importu rastrována do bitmapy.

Otevírání animovaných GIFů

Animované GIFy můžete do Fireworks dostat dvěma způsoby:

• Animovaný GIF můžete naimportovat jako animační symbol. Symbol vám 
umožňuje upravovat a pohybovat se všemi prvky animace jako s jedinou 
jednotkou. Tento způsob vám také umožňuje používat panel Library 
(knihovnu) a vytvářet nové instance symbolu.

Poznámka: Pokud naimportujete animovaný GIF, bude časový odstup mezi 
jednotlivými snímky standardně nastaven na 0,20 vteřiny. Pokud potřebujete, 
můžete tuto hodnotu na panelu Frames upravit na hodnotu původního GIFu.

• Animovaný GIF můžete otevřít, jako by šlo o normální GIF soubor. Každý 
prvek GIFu je pak umístěn jako samostatný obrázek do jeho vlastního snímku 
ve Fireworks. Pokud budete chtít, stále ještě můžete tuto grafiku převést na 
animační symbol.
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Otevírání EPS souborů

Pokud nemůže Fireworks otevřít EPS soubor jako vektory, otevírá ho jako 
zploštělý bitmapový obrázek.

Pokud importujete EPS soubor do existujícího dokumentu, otevře se dialogové 

okno EPS File Options.

Měrné jednotky určují v jakých jednotkách je zobrazena velikost obrázku. Můžete 
si vybrat mezi pixely, procenty, palci a centimetry.

Pole Resolution (rozlišení) určuje požadované rozlišení v pixelech na jednotku 
(palce nebo centimetry).

Volba Constrain Proportions (zachovat proporce) otevře soubor ve stejném 
velikostním poměru k originálu.

Volba Anti-Aliased (vyhlazení hran) vyhladí hrany v otevíraném EPS souboru.
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Otevírání WBMP souborů

Fireworks umí otevřít WBMP soubory, což jsou 1-bitové (monochromatické) 
soubory optimalizované pro mobilní zařízení. Tento formát se používá pro WAP 
(Wireless Application Protocol) stránky.

Import ze skeneru nebo digitálního fotoaparátu

Při importu obrázků ze skeneru nebo digitálního fotoaparátu se používají 
TWAIN moduly nebo plug-iny Acquire z Photoshopu (Macintosh). Obrázky 
naimportované do Fireworks ze skeneru nebo digitálního fotoaparátu se otevírají 
jako nový dokument. 

Poznámka: Fireworks nemůže skenovat obrázky, pokud nejsou nainstalovány 
příslušné softwarové ovladače, moduly a plug-iny. Konkrétní instrukce o instalaci 
a nastavení najdete v dokumentaci k vašemu TWAIN modulu nebo v manuálu 
k Photoshop Acquire plug-inu.

Na Macintoshi Fireworks automaticky hledá Photoshop Acquire plug-iny 
v adresáři Fireworks 4\Output\Xtras. Pokud nechcete do tohoto místa váš plug-in 
dávat, musíte Fireworks nastavit alternativní umístění plug-inu.

Jak ve Fireworks nastavit, kde hledat Photoshop Acquire plug-iny:

1. Ve Fireworks zvolte v menu Edit > Preferences

2. Klepněte na záložku Folders.

3. Vyberte volbu Photoshop Plug-Ins.

4. Klepněte na tlačítko Browse a ukažte na adresář obsahující plug-iny pro 
Photoshop.

Import obrázku ze skeneru nebo digitálního fotoaparátu:

1. Připojte skener nebo fotoaparát k vašemu počítači.

2. Nainstalujte software dodaný se skenerem nebo fotoaparátem.
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3. Ve Fireworks zvolte v menu File > Scan a vyberte TWAIN modul nebo 
Photoshop Acquire plug-in odpovídající zařízení, že kterého chcete obrázky 
naimportovat.
Většina TWAIN modulů a Photoshop Acquire plug-inů zobrazí další dialogová 
okna, kde nastavíte další podrobnosti.

4. Postupujte podle instrukcí a nastavte vše potřebné.
Importovaný obrázek je otevřen ve Fireworks jako nový dokument.

Vkládání objektů do dokumentu ve Fireworks

Do dokumentu ve Fireworks můžete naimportovat, přetáhnout myší nebo 
zkopírovat a vložit vektorové objekty, bitmapové obrázky nebo text vytvořený 
v jiných aplikacích. Stejně tak můžete naimportovat obrázek ze skeneru nebo 
digitálního fotoaparátu.

Přetažení myší (drag and drop)

Do Fireworks můžete přetáhnout vektorové objekty, bitmapové obrázky, nebo text 
z kterékoliv aplikace, která podporuje metodu drag and drop:

• FreeHand 7 nebo novější

• Flash 3 nebo novější

• Photoshop 4 nebo novější

• Illustrator 7 nebo novější

• Microsoft Office 97 nebo novější

• Microsoft Internet Explorer 3 nebo novější

• Netscape Navigator 3 nebo novější

• CorelDRAW 7 nebo novější
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Přetažení objektu do Fireworks:

Přetáhněte grafiku z jiné aplikace do otevřeného dokumentu ve Fireworks.

Vkládání ze schránky do Fireworks

Pomocí schránky (clipboard) můžete zkopírovat a vložit tyto formáty:

• FreeHand 7 nebo novější

• Illustrator

• PICT (Macintosh)

• DIB (Windows)

• BMP (Windows)

• ASCII text

• EPS

• WBMP

Pokud do Fireworks vložíte objekt zkopírovaný v jiné aplikaci, bude vycentrován 
v aktivním dokumentu.

Každý z editačních módu zachází s vkládanými daty odlišně:

• Pokud ve vektorovém módu vložíte pixelovou selekci, vloží se obdélníkový 
bitmapový objekt, který používá alfa průhlednost k tomu, aby zachoval vzhled 
původního výběru. Vektorový objekt si zachová své vektorové vlastnosti.

• Pokud v bitmapovém módu vložíte vektorovou grafiku nebo bitmapu, vloží se 
pixelová selekce, která zůstane plovoucí do té doby, než je zrušen výběr. 
Ve chvíli, kdy je výběr zrušen, stane se selekce částí aktuálního obrázku.
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Převzorkování vložených objektů

Pokud vkládáte ze schránky bitmapu, jejíž rozlišení se liší od rozlišení dokumentu 
ve Fireworks, zobrazí se zpráva a dotaz, zda chcete bitmapu převzorkovat.

Převzorkování přidá nebo ubere pixely ze zvětšeného nebo zmenšeného obrázku 
tak, aby se vzhled obrázku přiblížil vzhledu původní bitmapy, jak nejvíc je to jen 
možné. Převzorkování bitmapy do vyššího rozlišení způsobuje typicky jen malou 
ztrátu dat nebo kvality. Převzorkování do nižšího rozlišení vždy způsobuje ztrátu 
dat a pokles kvality. 

• Chcete-li zachovat původní šířku a výšku vkládaných dat přidáním nebo 
ubráním pixelů podle potřeby, zvolte Resample.

• Chcete-li zachovat původní pixely, zvolte Don’t Resample. To může způsobit, 
že relativní velikost vloženého obrázku bude menší nebo větší než u originálu.

Import PNG souborů

Do aktuální vrstvy ve Fireworks můžete naimportovat PNG soubor. Aktivní 
oblasti (hotspot) a řezy (slice) ze souboru budou umístěny do webové vrstvy (Web 
Layer). 

Naimportování  PNG souboru do dokumentu ve Fireworks:

1. V menu zvolte File > Import. Otevře se dialogové okno Import.

2. Najděte na disku soubor a klepněte na Open.

3. Přesuňte importní kurzor myši na místo, kam chcete umístit levý horní roh 
importovaného obrázku:

• Klepnutím naimportujte obrázek v plné velikosti.

• Tažením importního kurzoru myši můžete změnit velikost importovaného 
obrázku. Fireworks zachová proporce obrázku.



53  Kapitola 3

Navigování a prohlížení dokumentu

U zobrazeného obrázku můžete ovládat faktor zvětšení, počet pohledů 
a zobrazovací mód. Navíc se můžete po dokumentu jednoduše posouvat. 
To je užitečné v případě, že si dokument hodně zvětšíte a nevidíte už najednou 
celou grafiku.

Přibližování a oddalování dokumentu (zooming)

Faktor zvětšení se ve Fireworks může pohybovat od 6 % do 6400 %. Pokud se 
k dokumentu přiblížíte, můžete s obrazem rolovat až za hranice plátna do šedé 
oblasti.

          Z roletového menu vyberte faktor zvětšení

Roletové menu pro nastavení zvětšení v okně dokumentu a nástroje Zoom (lupa) a Hand (ruka) 
na panelu Tools.

Přiblížení (zvětšení) dokumentu:

• Vyberte nástroj Zoom (lupa) a klepněte uvnitř okna dokumentu v místě, kde 
chcete mít nový střed oblasti.

• Zvolte faktor zvětšení z roletového menu v okně dokumentu.

• V menu zvolte View > Zoom a vyberte volbu zvětšení.
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Oddálení (zmenšení) dokumentu:

• Zvolte faktor zmenšení z roletového menu v okně dokumentu.

• Z menu zvolte View > Zoom a vyberte volbu zmenšení.

Zvětšení konkrétní oblasti:

Nástrojem Zoom natáhněte v dokumentu obdélníkovou oblast.

Zmenšení v závislosti na označené oblasti:

Podržte stisknutou klávesu Alt (Windows) nebo Options (Mac) a natáhněte 
nástrojem Zoom v dokumentu obdélníkovou oblast.

Návrat k velikosti 100 %:

Poklepejte dvakrát na nástroj Zoom  na panelu Tools.

Posouvání po dokumentu:

1. Vyberte nástroj Hand (ruka). Objeví se kurzor ve tvaru ruky.

2. Táhněte v dokumentu kurzorem myši.

Poznámka: Pokud při posouvání dokumentu dorazíte k okraji dokumentu, bude 
pohled pokračovat v rolování ještě několik pixelů do šedé oblasti.

Přizpůsobení dokumentu aktuálnímu pohledu:

Poklepejte dvakrát na nástroj Hand na panelu Tools.
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Zobrazení více pohledů na dokument

Více pohledů na dokument můžete použít například tehdy, když chcete vidět 
dokument najednou ve více zvětšeních. Změny provedené v jednom okně při 
jednom zvětšení se automaticky objevují i v ostatních pohledech s jiným faktorem 
zvětšení.

Otevření dalšího pohledu na dokumentu s jiným faktorem 

zvětšení:

1. V menu zvolte Window > New Window.

2. V novém okně nastavte požadovaný faktor zvětšení.

Seřazení pohledů vedle sebe:

V menu zvolte Window > Tile Horizontal (seřadit vedle sebe) nebo Window > 
Tile Vertical (seřadit nad sebe).

Zavření okna s pohledem na dokument:

Klepněte na zavírací tlačítko okna.

Ovládání překreslování dokumentu

Zobrazovací módy ovlivňují zobrazení dokumentu na obrazovce, ne však samotná 
data jeho objektů nebo kvalitu výstupu.

• Mód Full Display (plné zobrazení) zobrazuje dokument ve všech dostupných 
barvách se všemi detaily.

• Mód Draft Display (hrubé zobrazení) zobrazuje křivky jako 1-pixelové čáry bez 
výplně a obrázky jako obdélníky s přeškrtnutím uvnitř.

• Příkaz Macintosh Gamma (ve Windows) nebo Windows Gamma (na 
Macintoshi) modifikuje mód Full Display, aby zobrazoval grafiku tak, jak bude 
vypadat na druhé platformě. Pokud pracujete ve Windows, můžete se podívat, 
jak bude grafika vypadat na Macintoshi, a obráceně.
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Přepnutí zobrazovacího módu:

V menu View vyberte příkaz Full Display.

Změny plátna

Vlastnosti plátna nastavujete, když vytváříte ve Fireworks nový dokument. I potom 
se však můžete vrátit a změnit velikost a barvu plátna nebo rozlišení obrázku. Při 
práci s dokumentem můžete také plátno natočit a odříznout pryč nepotřebné části.

Změna velikosti, barvy a rozlišení dokumentu

Velikost plátna, jeho barvu a rozlišení můžete ve Fireworks změnit velice 
jednoduše.

Změna velikosti plátna:

1. V menu zvolte Modify > Canvas Size.

2. Klepněte na jedno z tlačítek Anchor, kterým určíte, jaké strany plátna se 
budou přidávat nebo mazat. Klepněte na OK.

Poznámka: Standardně je vybráno prostřední tlačítko Anchor, což 
znamená, že změny velikosti plátna se projeví na všech jeho stranách.

3. Do polí Width (šířka) a Height (výška) zadejte nové rozměry plátna.
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Změna barvy plátna:

1. V menu zvolte Modify > Canvas Color.

2. Vyberte jednu z následujících možností:

• White (bílá)

• Transparent (průhledná)

• Custom (uživatelsky definovaná)
Pokud zvolíte uživatelsky definovanou barvu, klepněte na políčko s barvou a 
vyberte požadovanou barvu z nabídnuté palety.

3. Klepněte na OK.

Změna velikosti dokumentu a veškerého jeho obsahu:

1. V menu zvolte Modify > Image Size. Objeví se dialogové okno Image Size.

2. Do polí v oblasti Pixel Dimensions (rozměry v pixelech) zadejte novou šířku a 
výšku dokumentu.
Můžete také změnit měrné jednotky. Pokud je deaktivovaná volba Resample 
Image (převzorkovat obrázek), můžete měnit rozlišení obrázku (Resolution) a 
velikost v tisku (Print Size), ale ne samotnou velikost v pixelech.
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3. Do polí v oblasti Print Size (velikost v tisku) můžete zadat výšku a šířku 
obrázku pro tisk. I zde můžete změnit měrné jednotky. 

4. Do pole Resolution (rozlišení) zadáváte nové rozlišení obrázku. 
Zde si také můžete vybrat mezi jednotkami – buď pixely na palec (Pixels/
Inch) nebo pixely na centimetr (Pixels/Cm), nebo zvolte volbu Resample 
Image (převzorkovat obrázek). Změnou rozlišení změníte i velikost obrázku 
v pixelech.

5. Chcete-li zachovat stejný poměr mezi šířkou a výškou dokumentu, aktivujte 
volbu Constrain Proportions (zachovat poměr). Chcete-li měnit šířku a výšku 
nezávisle na sobě, volbu Constrain Proportions deaktivujte.

6. Zaškrtnete-li volbu Resample Image (převzorkovat obrázek) budou se při 
změně velikosti do obrázku přidávat nebo z něho ubírat pixely tak, aby měl 
stejný vzhled i v jiné velikosti.

7. Klepněte na OK.

O změně velikosti ve Fireworks

Převzorkování (resampling) ve Fireworks se liší od většiny aplikací pro editaci 
obrázků. Fireworks obsahuje bitmapové objekty z pixelů a zároveň vektorové 
objekty z křivek.

• Pokud dojde k převzorkování bitmapového objektu, jsou do něho přidány nebo 
z něho ubrány pixely tak, aby byl větší nebo menší.

• Pokud dojde k převzorkování vektorového objektu, nedojde k téměř žádné 
ztrátě kvality, protože křivky jsou jen matematicky překresleny v menší nebo 
větší velikosti.

Protože jsou však jednotlivé atributy vektorového objektu ve Fireworks 
zobrazovány jako pixely, mohou se po převzorkování mírně lišit některé obrysy 
nebo výplně, jelikož musí dojít i k překreslení pixelů těchto obrysů a výplní. 

Poznámka: Při změně velikosti obrázku se změní velikost i vodících linek, hotspot 
objektů (aktivních oblastí) a řezů (slice).
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Změna velikosti bitmapového objektu vás vždy vystaví jedinečnému problému 
– přidáváte nebo odstraňujete pixely z obrázku, nebo měníte počet pixelů na palec 
nebo centimetr?

Velikost obrázku můžete změnit buď )pravou rozlišení nebo převzorkováním 
obrazu. Pokud upravíte rozlišení, změníte ve skutečnosti velikost pixelů v obrázku, 
takže se jich do dané oblasti vejde více nebo méně. Při úpravě rozlišení bez 
převzorkování nedochází ke ztrátě dat.

• Převzorkování dolů (downsampling), neboli odstraňování pixelů vedoucí 
ke zmenšení obrázku, vždy způsobí ztrátu kvality, protože pixely jsou ze 
zmenšeného obrázku vyhozeny. 

• Převzorkování nahoru (resampling up), neboli přidávání pixelů vedoucí ke 
zvětšení obrázku, může vést ke ztrátě kvality, protože některé pixely, které byly 
do obrázku přidány proto, aby se obrázek zvětšil, ne vždy odpovídají  pixelům 
v původním obrázku.

Původní obrázek a obrázek po převzorkování dolů (downsampling).
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Otáčení plátna

Otočení plátna může být užitečné v případě, že je obrázek naimportován obráceně 
nebo je otočený na bok. Plátno můžete otočit o 180 stupňů nebo o 90 stupňů po 
nebo proti směru hodinových ručiček.

Pokud otočíte plátnem, otočí se i všechny objekty v něm.

Původní obrázek a obrázek otočený o 180 stupňů.

Otočení plátna:

1. V menu zvolte Modify > Rotate Canvas.

2. V podmenu vyberte příslušnou volbu otočení.
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Oříznutí plátna

Pokud váš dokument obsahuje okolo obrázku prázdné místo navíc, můžete plátno 
zastřihnout (trim). Prázdné místo na okrajích obrazu můžete odstranit i oříznutím 
(crop) obrázku. oříznout. Více informací najdete v části „Ořezávání křivky (cesty)“ 
na straně 121 a „Ořezávání bitmapového obrázku“ na straně 140.

Původní obrázek

Zastřihnutý obrázek

Zastřihnutí plátna:

V menu zvolte Modify > Trim Canvas a Fireworks automaticky odebere 
přebytečné pixely na okrajích dokumentu.

Každá strana plátna je oříznuta až ke krajům objektů uvnitř dokumentu.

Pokud obsahuje dokument více než jeden snímek, ořízne příkaz Trim Canvas 
obrázek tak, aby potom obsahoval objekty ve všech snímcích, nejenom v tom 
aktuálním.



  Založení objektu ve Fireworks 4  62

Plátno můžete zastřihnout i pomocí příkazu Modify > Fit Canvas. Tento příkaz 
vám navíc k tomu, že funguje stejně jako příkaz Trim Canvas, umožňuje ještě 
naopak roztáhnout plátno mimo své okraje tak, aby obsahovalo všechny objekty, 
které za tyto okraje vyčnívají.

Používání pravítek, vodítek a mřížky

Pravítka a vodící linky můžete použít k tomu, abyste přesně rozmístili objekty, 
nebo je můžete použít i jako pomoc při kreslení. Do dokumentu můžete umístit 
vodící linky a objekty pak k těmto linkám přichytávat, nebo můžete ve Fireworks 
zapnout mřížku a přichytávat objekty k této mřížce.
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Používání pravítek

Pravítka vám pomohou zorganizovat a naplánovat rozvržení vaší práce. Pravítka 
měří vždy v pixelech nezávisle na tom, jaké měrné jednotky jste použili při 
vytváření dokumentu.

Zobrazení a skrytí pravítek:

V menu zvolte View > Ruler.

Podél okraje okna dokumentu se objeví vodorovné a svislé pravítko.
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Práce s vodítky

Vodítka jsou linky které můžete z oblasti pravítek přetáhnout nad plátno dokumentu. 
Slouží jako pomůcky pro umisťování a zarovnávání objektů. Vodítka používejte 
ke zdůraznění důležitých oblastí  vašeho dokumentu, jako jsou například okraje, střed 
dokumentu, nebo oblasti, kde chcete provést nějakou přesnou práci. Také můžete 
později vyexportovat obrázek rozřezaný podél těchto vodítek do HTML tabulky.

Při zarovnávání objektů vám Fireworks umožní přichytávat objekty na tyto vodící linky.

Vodítka můžete zamknout a zabránit tak jejich nechtěnému přesunu.

Poznámka: Vodítka nejsou umístěna do žádné vrstvy ani se neexportují 
s dokumentem. Slouží pouze jako nástroj při návrhu grafiky.

Vodítka (guides) se liší od vodítek řezů (slice guides). 

Vytvoření vodorovného nebo svislého vodítka:

1. Klepněte na příslušné pravítko a táhněte myší.

2. Umístěte vodítko nad plátno dokumentu a uvolněte tlačítko myši. 
Vodítko můžete přemístit opětovným přetažením.

Přesun vodítka na určitou pozici:

1. Poklepejte dvakrát na vodítko.

2. V dialogovém okně Move Guide zadejte novou pozici.

3. Klepněte na OK.

Zobrazení nebo skrytí vodítek:

V menu zvolte View > Guides > Show Guides.

Přichytávání objektů k vodítkům:

V menu zvolte View > Guides > Snap to Guides.

Změna barvy vodítek:

1. V menu zvolte View > Guides > Edit Guides.

2. Z rozbalovacího vzorníku barev vyberte novou barvu vodítek a klepněte na OK.
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Zamknutí a odemknutí vodítek:

V menu zvolte View > Guides  Lock Guides.

Odstranění vodítka:

Přetáhněte vodítko myší mimo plátno.

Používání mřížky

Mřížka zobrazí nad plátnem dokumentu soustavu vodorovných a svislých linek. 
Mřížka je užitečná při přesném umisťování objektů. Mřížku můžete zobrazit, 
editovat, měnit její velikost a barvu.

Poznámka: Mřížka není umístěna do žádné vrstvy ani se neexportuje 
s dokumentem. Slouží pouze jako nástroj při návrhu grafiky.

Zobrazení a skrytí mřížky:

V menu zvolte View > Grid > Show Grid.

Přichytávání objektů k mřížce:

V menu zvolte View > Grid > Snap to Grid.

Změna barvy mřížky:

1. V menu zvolte View > Grid > Edit Grid.

2. Z rozbalovacího vzorníku barev vyberte novou barvu mřížky a klepněte na 
OK.

Změna velikosti buněk mřížky:

1. V menu zvolte View > Grid > Edit Grid.

2. Do políček v dialogovém okně zadejte příslušné hodnoty vodorovného 
a svislého rozestupu linek a klepněte na OK.
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Práce s objekty

Při práci ve vektorovém módu Fireworks budete potřebovat manipulovat 
s vektorovými objekty, textovými bloky, symboly, řezy a hotspoty a bitmapovou 
grafikou. Cokoliv, co budete chtít s jakýmkoliv existujícím objektem provést, 
nejprve vyžaduje vybrání tohoto objektu.

Jakmile jednou objekt vyberte, můžete ho přesunout, zkopírovat, smazat nebo ho 
upravit. Můžete také použít transformační nástroje vektorového módu a objekty 
otočit, zvětšit nebo naklonit bez ztráty kvality. V dokumentech, kde existuje více 
objektů, můžete přeskládat pořadí objektů, seskupit více objektů nebo je mezi 
sebou zarovnat.

Vybírání objektů ve vektorovém módu

Fireworks disponuje několika nástroji pro vybírání vektorových objektů. 
Tyto nástroje můžete ve vektorovém módu použít i pro výběr textových bloků, 
symbolů, webových objektů a bitmapové grafiky. Část „Vybírání pixelových 
oblastí“ na straně 127 popisuje metody, jak vybírat pixely v bitmapovém módu.

Můžete si vybrat z těchto možností výběru:

• Pro výběr vektorového objektu použijte nástroj Pointer 

• Pro výběr objektu a jeho jednotlivých bodů použijte nástroj Subselection 

• Chcete-li vybrat oblast, kterou chcete exportovat do samostatného souboru, 
použijte nástroj Export Area.

KAPITOLA 4

4  
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Používání panelu Object

Kdykoliv vyberete nějaký objekt, projeví se tento výběr na panelu Object. Pokud je 
vybrán jediný objekt, popisuje titulek panelu Object typ tohoto objektu, například 
rectangle (obdélník), slice (řez), path (cesta/křivka) nebo text. Pokud je vybráno 
více než jeden objekt, zobrazuje se v titulku panelu Object jejich počet.

Poznámka: Vybrané objekty jsou ve Windows také identifikovány na stavovém 
řádku v dolní části okna dokumentu..

Panel Object také u některých vybraných objektů zobrazuje informace a nastavení. 
Pokud například vyberete vektorovou cestu, zobrazuje panel Object tlačítka pro 
nastavení pozice obrysu této cesty relativně vzhledem k samotné vektorové cestě. 
Zobrazuje také roletku obsahující volby, kterými se nastavuje, co se stane, pokud je 
objekt transformován.

Pokud vyberete například řez, můžete na panelu Object nastavit, zda jde o 
obrázkový nebo textový řez. Také zde pro exportované rozřezané obrázky můžete 
nastavit URL, zadat alternativní text, určit cíl odkazu a nadefinovat konvenci 
pojmenovávání rozřezaných obrázků.

Informace o konkrétních nastaveních na panelu Object jsou probírány během 
celého manuálu v kontextu s informacemi o různých typech objektů, které můžete 
ve Fireworks vybírat.
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Používání nástroje Pointer

Nástroj Pointer (šipka)  vybírá objekty, na které klepnete nebo kolem jejichž části 
natáhnete nástrojem obdélníkový výběr. Nástrojem Pointer nemůžete vybírat 
jednotlivé doby v objektech – k tomu slouží nástroj Subselection

.

Výběr objektu klepnutím:

Přesuňte nástroj Pointer nad obrys objektu a klepněte.

Pokud má objekt výplň, můžete objekt vybrat i klepnutím na výplň.

Chcete-li při práci vidět náhled toho, co vyberete, kdybyste právě klepli myší, 
zaškrtněte volbu Mouse Highlight na panelu Tool Options. Pokud bude kurzor 
myši v pozici, kdy je možné objekt vybrat, zvýrazní se objekt červenou čarou.

Výběr objektu tažením:

Táhněte nástrojem Pointer obdélníkový výběr kolem jednoho nebo více objektů.

Používání nástroje Subselection

Stejně jako u nástroje Pointer můžete použít nástroj Subselection pro vybírání 
objektů buď tak, že na ně klepnete nebo kolem nich natáhnete obdélníkový výběr. 
Nástroj Subselection však má ještě několik dalších schopností:

• Můžete vybrat a přesouvat jednotlivé body.

• Můžete upravovat cesty přilehlé k bodům tím, že budete tahat myší za táhle 
u jednotlivých bodů.

• Můžete vybírat a upravovat objekty uvnitř skupiny nebo složené cesty.

Chcete-li se jednoduše přepnout mezi nástrojem Pointer s Subselection a pak zase 
zpět, stiskněte klávesu Alt (Windows) nebo Options(Macintosh).
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Používání nástroje Select Behind

Pokud pracujete na grafice skládající se z mnoha objektů, můžete použít nástroj 
Select Behind a vybrat objekt, který je částečně zakrytý nebo krytý za jinými 
objekty. 

Výběr objektu za jinými objekty:

Klepáním nástrojem Select Behind nad na sebe naskládanými objekty se budete 
přesouvat od jednoho objektu k druhému, až se dostanete k tomu, který chcete 
vybrat.

Poznámka: Těžko dosažitelný objekt můžete vybrat i tak, že klepnete na jeho 
miniaturu na panelu Layers.

Používání panelu Layers pro výběr objektů

Panel Layers (vrstvy) obsahuje pojmenovanou miniaturu každého objektu v každé 
vrstvě dokumentu. Každý objekt je na panelu vypsán po d vrstvou, ve které je 
umístěn. Pokud je objekt vybraný, objeví se na panelu Layers vpravo od jména 
vrstvy malý modrý indikátor výběru.

Výběr objektu na panelu Layers:

Klepněte na miniaturu nebo jméno objektu na panelu Layers.

Přesun vybraného objektu z jedné vrstvy do druhé:

• Na panelu Layers přetáhněte miniaturu objektu na jméno jiné vrstvy.

• Na panelu Layers přetáhněte z jedné vrstvy do druhé malý modrý indikátor 
výběru.
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Úprava výběru

Jestliže máte vybraný jeden objekt, můžete do tohoto výběru další objekty přidávat 
nebo vybrané objekty ubírat. Jediným příkazem můžete vybrat nebo zrušit výběr 
všech objektů ve všech vrstvách dokumentu. Můžete také skrýt zvýraznění výběru 
a editovat vybraný objekt v takovém zobrazení, v jakém se objeví například na 
webu nebo v tisku.

Přidání k výběru:

Stiskněte a podržte klávesu Shift a klepejte na další objekty nástrojem Pointer, 
Subselection nebo Select Behind.

Zrušení výběru objektu při zachování výběru ostatních objektů:

Stiskněte a podržte klávesu Shift a klepněte na vybraný objekt.

Výběr všeho ve všech vrstvách dokumentu:

V menu zvolte Edit > Select All. Chcete-li zrušit výběr všech vybraných objektů, 
zvolte v menu Edit > Deselect.

Příkaz Select All (vybrat vše) nevybere skryté objekty.

Chcete-li vybírat všechny neskryté objekty ve všech vrstvách dokumentu, musíte 
také vypnout volbu Single Layer Editing (editace v jedné vrstvě). Pokud je volba 
Single Layer Editing aktivní, vyberou se objekty jen v aktuální vrstvě.

Skrytí cesty vybraného objektu:

V menu zvolte View > Hide Edges (skrýt hrany).

Poznámka: Vybraný objekt se krytými hranami a body můžete identifikovat 
na stavovém řádku (Windows) nebo na panelu Object.
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Skrytí vybraných objektů:

V menu zvolte View > Hide Selection. Pro zobrazení skrytých objektů použijte 
příkaz v menu View > Show All.

Chcete-li skrýt objekty, ať už jsou vybrané či ne, klepněte nebo táhněte na panelu 
Layers myší ve sloupci pro zobrazení/skrytí objektu (sloupec s ikonkami oka).

Poznámka: Skryté objekty se neexportují.

Přesouvání, kopírování, klonování a mazání objektů

Vybrané objekty můžete přesouvat přetažením po plátně, vyjmutím a vložením 
ze schránky, stiskem kurzorových kláves nebo zadáním souřadnic na panelu Info.  
Pomocí schránky (clipboard) můžete vybrané objekty přesunovat mezi Fireworks 
a jinými aplikacemi. Objekty můžete kopírovat buď vložením ze schránky nebo 
jejich přetažením. Pokud už objekt na plátně nechcete, můžete ho vymazat.

Přesun výběru:

• Přetáhněte výběr nástrojem Pointer, Subselection nebo Select Behind.

• Stiskem kurzorové klávesy přesouváte výběr po 1-pixelových krocích. Pokud 
podržíte klávesu Shift, budete přesouvat po 10-pixelových krocích.

• Na panelu Info můžete zadat souřadnice X a Y levého horního rohu výběru. 
Souřadnice levého horního rohu plátna jsou X=0 a Y=0. Souřadnice se 
vyjadřují v pixelech.

Přesun nebo zkopírování vybraných objektů vložením:

1. Vyberte jeden nebo více objektů.

2. V menu zvolte Edit > Cut (vyjmout) nebo Edit > Copy (zkopírovat). Objekt je 
vyjmut nebo zkopírován do schránky. 

3. V menu zvolte Edit > Paste.

Poznámka: Pokud ve Fireworks vytvoříte nový dokument, pokud je ve schránce 
nějaký výběr, bude výchozí nastavení velikosti plátna nového dokumentu odpovídat 
rozměrům výběru ve schránce.
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Duplikování výběru:

V menu zvolte Edit > Duplicate.

Duplikát výběru se objeví odstupňovaný od originálu. Každý nový duplikát se 
stane aktuálně vybraným objektem.

Klonování výběru:

V menu zvolte Edit > Clone.

Klon výběru je umístěn přesně před originálem s automaticky se stane aktuálně 
vybraným objektem.

Chcete-li klon přesunout od originálu s přesností na pixel, použijte kurzorové 
klávesy. To je užitečné v případě, že chcete zachovat přesné rozestupy mezi klony, 
nebo pokud chcete udržet zarovnání jednotlivých klonů.

Smazání vybraných objektů:

• Stiskněte klávesu Dlete nebo Backspace.

• Klepněte pravým tlačítkem (Windows) nebo podržte klávesu Control a klepněte 
(Macintosh) nad objektem a v kontextovém menu zvolte Edit > Cut.

• V menu zvolte Edit > Clear.

• V menu zvolte Edit > Cut.
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Transformace a deformování objektů

Pomocí transformačních nástrojů nebo příkazů v menu můžete ve vektorovém 
módu zvětšit, otočit, obrátit, zdeformovat nebo naklonit objekt nebo skupinu 
objektů.

Transformační nástroje

Pokud vyberete jakýkoliv transformační nástroj nebo příkaz v menu, objeví se 
kolem vybraných objektů transformační úchyty.

Transformační úchyty

 

Středový bod

Původní objekt

Otočený, zmenšený, nakloněný, zdeformovaný a obrácený svisle a vodorovně.

Editace vybraných objektů pomocí transformačních úchytů:

1. Vyberte transformační nástroj. Jakmile přiblížíte kurzor myši směrem k výběru, 
změní se kurzor tak, aby naznačoval aktuální transformaci.

2. Tažením myší objekty transformujete.
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Prohlížení transformačních informací na panelu Info

Panel Info vám zobrazuje číselné informace o transformaci aktuálně vybraného 
objektu. Informace se při editaci objektu neustále aktualizují.

• Při změně velikosti (scale) a volné transformaci zobrazuje panel Info šířku (W) 
a výšku (H) původního objektu před transformací a procentuální nárůst nebo 
snížení šířky a výšky během transformace. 

• Při naklánění (skew) a deformaci (distort) zobrazuje panel Info souřadnice X 
a Y původního objektu před transformací a nové souřadnice X a Y během 
transformace.

Když uvolníte tlačítko myši a odsunete kurzor myši z objektu, nahradí na panelu 
Info informaci o transformaci informace o barvě. 

Zobrazení transformačních informací při transformaci výběru?

V menu zvolte Window > Info.
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Změna velikosti (scaling) objektů

Objekt můžete zvětšit nebo zmenšit ve vodorovném svislém nebo v obou 
směrech,

Změna velikosti vybraného objektu:

1. Zobrazte transformační úchyty:

• Vyberte nástroj Scale.

• V menu zvolte Modify > Transform > Scale.

2. Táhněte za transformační úchyty.

• Chcete-li objekt roztáhnout zároveň vodorovně i svisle, táhněte za jeden 
z rohových úchytů. Proporce stále zůstávají zachovány.

• Chcete-li objekt roztáhnout jen vodorovně nebo svisle, zatáhněte za postraní 
úchyt.

Vybraný objekt můžete také zvětši nebo zmenšit zadáním nové šířky (W) a výšky 
(H) na panelu Info.



  Práce s objekty  76

Otáčení objektů

Při otáčení se objekt točí kolem svého středového bodu. Objekt můžete otočit 
buď tak, že ho uchopíte za transformační úchyty a zatáhnete, nebo vyberete 
přednastavený úhel.

Otočení vybraného objektu o 90 nebo 180 stupňů:

V menu zvolte Modify > Transform a z podmenu vyberte příkaz pro požadované 
otočení.

Otočení vybraného objektu tažením:

1. Vyberte jakýkoliv transformační nástroj

2. Přesuňte kurzor vně objektu, až se objeví rotační kurzor myši.

3. Tažením otočte objekt.
Chcete-li otáčení omezit na přírůstky po 15 stupních relativně k horizontu, 
podržte při tažení myší stisknutou klávesu Shift.

Přemístění osy otáčení:

Přetáhněte středový bod mimo střed.

Chcete-li osu otáčení vrátit zpět do středu výběru, poklepejte dvakrát na středový 
bod.
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Převracení objektů

Objekt můžete převrátit podél jeho svislé nebo vodorovné osy bez toho, že byste 
změnili jeho relativní pozici na plátně.

Převrácení vybraného objektu:

V menu zvolte Modify > Transform > Flip Horizontal (převrátit vodorovně) nebo 
Flip Vertical (převrátit svisle).

Naklánění objektů

Objekt můžete naklonit podél jeho vodorovné nebo svislé osy. Objekty můžete 
naklonit tažením myší.

Naklonění vybraného objektu:

1. Zobrazte transformační úchyty:

• Vyberte transformační nástroj Skew.

• V menu zvolte Modify > Transform > Skew.

2. Tažením za úchyt objekt nakloňte.

Navození iluze perspektivy:

Zatáhněte za rohový úchyt.
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Deformace objektů

Při deformaci objektů posouváte jejich strany nebo rohy do směrů, kterými táhnete 
nástrojem Distort.

Deformace vybraného objektu:

1. Zobrazte transformační úchyty:

• Vyberte nástroj Distort.

• V menu zvolte Modify > Transform > Distort.

2. Tažením za úchyty deformujte objekt.

Číselné transformace

Objekty můžete otáčet nebo zvětšovat nejen tažením myší, ale můžete je 
transformovat i zadáním číselných hodnot.

Změna velikosti nebo otočení objektů o určenou hodnotu:

1. V menu zvolte Modify > Transform > Numeric Transform.
Objeví se dialogové okno Numeric Transform.

2. Z roletky vyberte typ transformace, kterou chce aplikovat na aktuální výběr:

• Scale – změna velikosti zadaná v procentech

• Resize – změna velikosti zadaná v pixelech

• Rotate – otočení

3. Chcete-li při změně velikosti objektu zachovat poměry jeho stran, aktivujte 
volbu Constrain Proportions (zachovat proporce).

4. Chcete-li, aby se zároveň s objektem transformovali i jeho vlastnosti (výplň, 
obrys, efekty), aktivujte volbu Scale Attributes (zvětšovat/zmenšovat atributy). 
Pokud bude volba Scale Attributes vypnutá, bude se měnit pouze velikost 
samotné vektorové cesty.

5. Zadejte číselné hodnoty transformace a klepněte na OK.
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Uspořádání objektů

Pokud v jednom dokumentu pracujete v více objekty, můžete pro uspořádání 
dokumentu použít několik různých technik:

• Jednotlivé objekty můžete seskupovat tak, aby se s nimi zacházelo jako 
s jediným objektem nebo aby se zachovala vzájemná vazba mezi objekty ve 
skupině.

• Objekty můžete řadit před nebo za jiné objekty. Způsobu, jakým jsou objekty 
seřazeny, se říká pořadí vrstvení (stacking order).

• Vybrané objekty můžete zarovnat k určité oblasti plátna nebo k vodorovné 
nebo svislé ose.

Seskupování objektů

Jednotlivé vybrané objekty můžete seskupit a dále s nimi pracovat, jako by šlo
o jediný objekt. Například po nakreslení lístků květiny jako samotných objektů 
je můžete seskupit a pak celou květinu jednoduše vybírat a přesouvat jako jediný 
objekt.

Skupiny můžete editovat i bez jejich rozdělení. Můžete vybrat samostatný objekt 
uvnitř skupiny a upravovat ho, aniž byste ho museli oddělit od skupiny. Objekty 
samozřejmě můžete oddělit od skupiny kdykoliv. 

Seskupený vybraných objektů do jediného objektu.

Seskupení dvou nebo více vybraných objektů:

V menu zvolte Modify > Group.

Chcete-li skupinu rozdělit, zvolte v menu Modify > Ungroup.
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Vybírání objektů uvnitř skupin

Chcete-li pracovat s jednotlivými objekty uvnitř skupiny, můžete buď objekty 
rozdělit nebo použít nástroj Subselection a vybrat jednotlivé objekty ve skupině 
bez nutnosti rozdělení skupiny.

Výběr objektu, který je částí skupiny:

Zvolte nástroj Subselection a klepněte na objekt nebo kolem něho natáhněte myší 
oblast výběru. Chcete-li do výběru přidat další objekty nebo je z něho ubrat, držte 
při klepání na objekty stisknutou klávesu Shift. 

Výběr skupiny, která obsahuje vybraný objekt:

• Klepněte pravým tlačítkem (Windows) nebo klepněte se stisknutou 
klávesou Control (Macintosh) kdekoliv na skupinu a z kontextového menu 
zvolte Select > Superselect.

• V menu zvolte Edit > Superselect.

Výběr všech objektů uvnitř vybrané skupiny:

• Klepněte pravým tlačítkem (Windows) nebo klepněte se stisknutou 
klávesou Control (Macintosh) kdekoliv na skupinu a z kontextového menu 
zvolte Select > Subselect.

• V menu zvolte Edit > Subselect.
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Vrstvení objektů

Ve Fireworks jsou na sebe objekty v rámci jedné vrstvy vrstveny v pořadí, v jakém 
byly vytvořeny, přičemž poslední vytvořený objekt je navrchu. Pořadí vrstvení 
objektů určuje, jak se objekty zobrazují, když se překrývají. 

Uvědomte si, že pořadí vrstvení ovlivňují i vrstvy. Pokud má například dokument 
dvě vrstvy pojmenované Layer 1 a Layer 2 a vrstva Layer 1 je v seznamu na panelu 
Layers pod vrstvou Layer 2, objeví se všechno ve vrstvě Layer 2 před čímkoliv, 
co je ve vrstvě Layer 1. Chcete-li změnit pořadí vrstev, přetáhněte myší vrstvu na 
panelu Layers do nové pozice.

Změna pořadí vrstvení vybraného objektu nebo skupiny uvnitř vrstvy:

• V menu zvolte Modify > Arrange > Bring to Front (přenést do popředí) nebo 
Send to Back (přenést do pozadí), čímž posunete objekt nebo skupiny na vrchol 
nebo na spodek navrstvených objektů.

• V menu zvolte Modify > Arrange > Bring Forward (přenést o krok vpřed) 
nebo Send Backward (přenést o krok vzad), čímž posunete objekt nebo skupinu 
nahoru nebo dolů o jednu úroveň v navrstvených objektech.

Pokud je vybrán více jeden objekt nebo skupina, přenášejí se společně před nebo 
za všechny nevybrané skupiny a objekty, ale navzájem si zachovávají svoje relativní 
pořadí.
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Zarovnávání objektů

Příkazy Align (zarovnat) v menu Modify vám umožňují zarovnávat objekty podle 
vodorovné nebo svislé osy. Vybrané objekty můžete zarovnat svisle podle jejich 
pravých hran, středu nebo levých hran, nebo vodorovné podle jejich horních hran, 
středu nebo dolních hran. Hrana je určena hraničním obdélníkem obklopujícím 
každý vybraný objekt.

Pomocí příkazů pro zarovnávání můžete také objekty distribuovat tak, aby byly 
mezi jejich hranami nebo středy rovnoměrné rozestupy. Můžete dokonce zvětšit 
všechny objekty tak, aby jejich šířky nebo výšky odpovídaly největšímu z vybraných 
objektů. Můžete také zarovnat objekty vzhledem k plátnu. Na vybrané objekty 
můžete aplikovat jeden nebo více zarovnávacích příkazů najednou.

Zarovnání vybraných objektů:

• V menu zvolte Modify > Align > Left pro zarovnání objektů na objekt nejvíce 
vlevo mezi vybranými objekty.

• V menu zvolte Modify > Align > Center Vertical pro zarovnání středů objektů 
podél svislé osy.

• V menu zvolte Modify > Align > Right pro zarovnání objektů na objekt nejvíce 
vpravo mezi vybranými objekty.

• V menu zvolte Modify > Align > Right pro zarovnání objektů na nejhornější 
objekt  mezi vybranými objekty.

• V menu zvolte Modify > Align > Center Horizontal pro zarovnání středů 
objektů podél vodorovné osy.

• V menu zvolte Modify > Align > Bottom pro zarovnání objektů na 
nejspodnější objekt  mezi vybranými objekty.

Rovnoměrná distribuce šířek a výšek tří nebo více objektů:

V menu zvolte Modify > Align > Distribute Widths (distribuovat šířky) nebo 
Modify > Align > Distribute Heights (distribuovat výšky).
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Rozmisťování objektů mezi vrstvami

Panel Layers vám nabízí další možnosti organizace objektů. Vybrané objekty 
můžete přesouvat z jedné vrstvy do druhé. Přetáhněte miniaturu objektu nebo 
modrý indikátor výběru na panelu Layers nad jinou vrstvu.
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Práce s vektorovými objekty

Vektorový objekt je počítačová grafika, jejíž tvar je definovaný sérií čar a křivek, 
nazývaných vektory, spojujících body, které formují cestu (path). Barva obrysu 
objektu (stroke) následuje tuto cestu. Výplň objektu zabírá oblast uvnitř cesty. 
Obrys (stroke) a výplň (fill) určují, jak grafika vypadá při publikování na web nebo 
do tisku.

Fireworks má mnoho nástrojů pro kreslení a editaci vektorových objektů mnoha 
různými technikami. Pomocí nástrojů pro tvorbu základních tvarů můžete rychle 
nakreslit rovné čáry. kružnice a elipsy, čtverce a obdélníky, hvězdy a jakýkoliv 
rovnostranný mnohoúhelník s 3 až 360 stranami.

Pomocí nástrojů Pencil (tužka), Brush (štětec) a Pen (pero) můžete kreslit libovolné 
vektorové cesty od ruky. Pero (pen) vám umožňuje kresli komplexní tvary 
z plynulých křivek a rovných čar nanášením jednoho bodu za druhým.

Když máte vektorové objekty nakreslené, nabízí vám Fireworks několik metod 
jejich editace. Můžete měnit tvar objektu přesouváním , přidáváním nebo mazáním 
jeho bodů. Můžete použít táhla u bodu a změnit tvar přilehlého segmentu křivky. 
Nástroje pro volnou deformaci vám umožní měnit tvar objektu přímou editací 
cesty.

Příkazy v menu Modify vám poskytují další možnosti editace objektů a to včetně 
zkombinování více objektů do jednoho objektu, vytvoření objektu z průniku 
několika objektů, rozšíření obrysu objektu. Můžete také naimportovat bitmapové
a vektorové obrázky a ve vektorovém módu s nimi manipulovat.

KAPITOLA 5

5
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Přechod do vektorového módu

Fireworks má dva kreslící módy – vektorový mód a bitmapový mód. Při kreslení 
vektorových objektů musíte být ve vektorovém módu.

Poznámka: V předchozích verzích Fireworks se vektorovému módu říkalo objektový 
mód (object mode).

Pokud je Fireworks v bitmapovém módu, ve standardním nastavení obklopuje 
plátno proužkovaný okraj.

Přepnutí z bitmapového do vektorového módu:

Udělejte jedno z následujícího:

• Klepněte na tlačítko Exit Bitmap Mode (opustit bitmapový mód) na spodním 
okraji okna dokumentu.

Tlačítko Exit Bitmap Mode

• V menu zvolte Modify > Exit Bitmap Mode.

• Stiskněte klávesu Esc.

• Vyberte nástroj, který funguje pouze ve vektorovém módu, například nástroj 
Pen (pero).
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Kreslení základních tvarů

Pokud použijete nástroje na tvorbu základních tvarů, můžete snadno nakreslit 
čtverce, obdélníky, ovály, hvězdy nebo další mnohoúhelníky. Můžete také kreslit 
obdélníky s oblými rohy a po nakreslení obdélníku upravit poloměr těchto rohů. 
Můžete také nakreslit množství různých hvězd od tenkých a špičatých až po ty 
velké s tlustými špičkami,

Nástroje pro kreslení základních tvarů se nachází v kreslící sekci panelu Tools. 
Pokud použijete některý z kreslících nástrojů a vytvoříte objekt, nástroj na tento 
objekt použije aktuální nastavení obrysu a výplně. 

Nástroje pro kreslení tvarů

Poznámka: V bitmapovém módu můžete nástroji pro tvorbu základních tvarů kreslit 
pixely.

Kreslení čar, obdélníku a elips

Nástroje Line (čára), Rectangle (obdélník) nebo Ellipse (elipsa) můžete použít 
pro rychlé vytvoření základních tvarů. Nástroj Rectangle kreslí obdélníky jako 
seskupené objekty. Chcete-li pohnout nezávisle s rohem obdélníku, musíte skupinu 
obdélníku nejprve rozdělit nebo použít nástroj Subselection. 

Nakreslení čáry, obdélníku nebo elipsy:

1. Vyberte nástroj Line (čára), Rectangle (obdélník) nebo Ellipse (elipsa).

2. Volitelně nastavte vlastnosti obrysu a výplně.

3. Tažením myší po plátně nakreslete tvar.
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U nástroje Line můžete podržet klávesu Shift a omezit tak kreslení čar v úhlech 
s krokem 45 stupňů od vodorovné osy. 

U nástrojů Rectangle a Ellipse omezuje stisknutá klávesa Shift tvary na přesné 
čtverce nebo kružnice.

Nakreslení čáry, obdélníku nebo elipsy z konkrétního středového bodu:

Najeďte s myší nad zamýšlený středový bod tvaru a potom táhněte kreslícím 
nástrojem se stisknutou klávesou Alt (Windows) nebo Option (Macintosh).

Nakreslení omezeného tvaru společně s kreslením od středu:

Najeďte s myší nad zamýšlený středový bod tvaru a potom táhněte kreslícím 
nástrojem se stisknutými klávesami Shift+Alt (Windows) nebo Shift+Option 
(Macintosh).

Změna velikosti vybrané čáry, obdélníku nebo elipsy:

• Zatáhněte za bod.

• Zadejte novou šířku (W) nebo výšku (H) do polí na panelu Info.

• V menu zvolte Transform > Scale a pak zatáhněte za kontrolní úchyt.

Kreslení obdélníku s oblými rohy

Pomocí nástroje Rounded Rectangle (zakulacený obdélník) můžete kreslit 
obdélníky s oblými rohy. Ještě před kresbou však musíte specifikovat rádius 
rohu v hodnotách 0 % až 100 %, nebo můžete použít panel Object a nastavit 
zakulacení rohů už existujících vybraných obdélníků. Nástroj Rounded Rectangle 
kreslí obdélníky jako seskupené objekty. Chcete-li pohybovat nezávisle s body 
zakulaceného obdélníku, musíte obdélník nejprve rozdělit nebo použít nástroj 
Subselection.
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Nakreslení obdélníku s oblými rohy:

1. Poklepejte dvakrát na nástroj Rounded Rectangle. Otevře se panel Tool 
Options.

2. Zadáním hodnoty 0 až 100 nebo tažením za jezdce určete zaoblení rohu.
Zaoblení rohu můžete měnit i při kreslení opakovaným stisknutím kurzorové 
klávesy nahoru a dolů.

Zakulacení rohů vybraného obdélníku:

Zadejte velikost zaoblení rohu do pole Roundness (zaoblení) na panelu Object 
a stiskněte Enter.

Kreslení mnohoúhelníků

Nástrojem Polygon (mnohoúhelník) můžete kreslit rovnostranné mnohoúhelníky 
a to od trojúhelníku až po mnohoúhelník s 360 stranami.

Nakreslení mnohoúhelníku:

1. Poklepejte dvakrát na nástroj Polygon. Otevře se panel Tool Options s volbami 
pro mnohoúhelník.

2. Z roletky Shape (tvar) vyberte volbu Polygon (mnohoúhelník).

3. Zadejte počet stran mnohoúhelníku:

• Použijte jezdce a vyberte počet stran od 3 do 25.

• Zadejte číslo od 3 do 360 do textového pole Sides (počet stran).

4. Tažením nakreslete mnohoúhelník.
Chcete-li natočení mnohoúhelníku omezit na přírůstky po 45 stupních, stiskněte 
při kreslení klávesu Shift. Nástroj Polygon vždy kreslí tvar od středu.
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Kreslení hvězd

Pokud použijete volbu Star nástroje Polygon, můžete nakreslit hvězdu s 3 až 360 cípy.

Nakreslení hvězdy:

1. Poklepejte dvakrát na nástroj Polygon, čímž otevřete panel Options.

2. Z roletky Shape vyberte volbu Star (hvězda).

3. Zadejte počet cípů hvězdy.

4. Aktivujte volbu Automatic Acuteness (automatická ostrost) nebo zadejte úhel. 
Hodnoty bližší se k 0 mají za následek dlouhé úzké cípy, hodnoty bližší k 100 
mají za následek krátké tlusté cípy.

5. Tažením nakreslete na plátno hvězdu.
Chcete-li natočení hvězdy omezit na přírůstky po 45 stupních, stiskněte 
při kreslení klávesu Shift. Nástroj Polygon vždy kreslí tvar od středu.

Kreslení cest od ruky

Pomocí nástrojů Pencil (tužka) a Brush (štětec) můžete kreslit vektorové cesty 
od ruky stejným způsobem, jakým byste to dělali se skutečnou tužkou nebo štětcem.

Nástroje Pencil (tužka) a Brush (štětec).

I u cest nakreslených nástrojem Pencil a Brush můžete měnit atributy obrysu 
a výplně. Nástroje Pencil a Brush můžete použít i v bitmapovém módu.

Používání nástroje Pencil (tužka)

Ve vektorovém módu kreslí nástroj Pencil (tužka) obrys široký jeden pixel. 
U existujících tahů nástrojem Pencil můžete upravit vlastnosti obrysu a objektům 
nakresleným nástrojem Pencil můžete přidat výplň, ale pokaždé, když nástroj 
použijete na nakreslení nového objektu, vrátí se jeho nastavení k 1-pixelové cestě.
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Nakreslení vektorového objektu 1-pixelovým tahem nástrojem Pencil:

1. Poklepejte dvakrát na nástroj Pencil. Zobrazí se panel Tool Options, 
kde můžete nastavit tyto volby:
Volba Anti-Aliased vyhlazuje nakreslené čáry.
Volba Auto Erase překreslí tah barvou výplně.
Volba Prevent Transparency omezí nástroj Pencil na kreslení pouze přes již 
existující pixely (nebude se kreslit přes průhledné oblasti). Tato volba funguje 
pouze v bitmapovém módu.

2. Volitelně můžete změnit na panelu Stroke název tahu v roletce Stroke name 
na 1-Pixel Soft, Colored Pencil nebo Graphite. Také můžete změnit barvu tahu 
pomocí jakéhokoliv barevného pole pro změnu barvy tahu (stroke color).

3. Tažením myší začněte kreslit. Chcete-li kresbu omezit na rovnou vodorovnou 
nebo svislou čáru, podržte během tažení myší stisknutou klávesu Shift.

4. Uvolněním tlačítka myši dokončete cestu. Chcete-li cestu uzavřít, uvolněte 
tlačítko myši v místě, kde jste začali cestu kreslit.

Poznámka: Nástrojem Pencil můžete v bitmapovém módu malovat pixely.
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Používání nástroje Brush (štětec)

Nástroj Brush (štětec) nabízí široký výběr kategorií štětců, včetně stříkací pistole, 
spreje, kaligrafických štětců, kříd a nepřirozených štětců. V každé této kategorii 
je mnoho druhů štětců, například světlá a tmavá plsť, olejové cákance, bambus, 
stuha, konfety, 3D, zubní pasta, lepkavá malba.

I když tahy těmito štětci mohou vypadat jako malba nebo inkoust, všechny 
obsahují body jako jakýkoliv jiný vektorový objekt. To znamená, že můžete měnit 
tvar tahu štětcem tím, že přemístíte jeho body. Poté, co změníte tvar cesty, je tah 
štětce překreslen. Tímto způsobem můžete upravit celé kresby, aniž byste museli 
vymazat nebo překreslit jediný tah štětcem.

Kresba upravená posunutím vektorových bodů.

Můžete také upravit existující tahy štětcem a vybraným objektům nakresleným 
štětcem přidat výplň. Nové nastavení tahu (obrysu) a výplně zůstává aktivní 
pro všechna další použití štětce v aktuálním dokumentu. Pokud však máte aktivní 
nástroj Brush a změníte kategorii na volbu Pencil, vrátí se nastavení při dalším 
použití štětce do kategorie Basic. 

Malování vektorové cesty od ruky:

1. Klepněte na nástroj Brush. Nastavení na panelu Tool Options funguje 
pro tento nástroj pouze v bitmapovém módu.

2. Volitelně můžete nastavit vlastnosti obrysu (stroke) a výplně (fill).

3. Tažením myší začnete malovat. Chcete-li nakreslit rovnou vodorovnou 
nebo svislou čáru, podržte během tažení stisknutou klávesu Shift.

4. Uvolněním tlačítka myši dokončete cestu. Chcete-li cestu uzavřít, uvolněte 
tlačítko myši v místě, kde jste začali cestu kreslit.

Poznámka: Nástrojem Brush můžete v bitmapovém módu malovat pixely.
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Používání nástroje Pen (pero)

Jedním ze způsobů, jak kreslit a upravovat objekty ve Fireworks, je nanášet body 
jako při obkreslování obrázku typu „spojte všechny tečky.“ Pokaždé, když klepnete 
nástrojem Pen a vytvoříte bod, je z posledního naneseného bodu automaticky 
nakreslena vektorová cesta do tohoto nového bodu.

Nástrojem Pen však nemusíte pouze spojovat body rovnými segmenty, ale můžete 
kreslit i plynulé, matematicky odvozené křivky známé pod názve Bézierovy křivky. 
Typ každého bodu (rohový bod  nebo bod na křivce) určuje, zda budou přilehlé 
křivky rovné čáry nebo křivky.

• Rohový bod (corner point) definuje nejméně jeden přilehlý segment jako přímý.

• Bod na křivce (curve point) definuje nejméně jeden přilehlý segment jako 
zakřivený.

Ať už nakreslíte objekt nástrojem Pen nebo jiným kreslícím nástrojem Fireworks, 
mají všechny body vektorového objektu kontrolní táhla. Poloha kontrolního táhla 
každého bodu určuje tvar přilehlých segmentů tvaru objektu. Tvar vektorového 
objektu můžete upravit tažením za kontrolní táhla nástrojem Pen nebo 
Subselection. Tvar objektu můžete změnit i tím, že změníte typ bodu z rohového 
na křivkový.

Nástroj Pen (pero)
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Kreslení přímých segmentů cesty

Kreslení přímých čárových segmentů je jednoduše záležitostí umisťování bodů 
klepnutím myši. Každé klepnutí myši nástrojem Pen umístí na plátno jeden rohový 
bod.

Nakreslení cesty s přímými čárovými segmenty:

1. Zvolte nástroj Pen (pero).

2. Na panelu Tool Options nastavte jakoukoliv z těchto voleb, pokud chcete:

• Volba Show Pen Preview vám zobrazí při kreslení náhled segmentu, který bude 
výsledkem vašeho dalšího klepnutím myší.

• Volba Show Solid Point zobrazuje nanášené body jako vyplněné čtverečky.

3. Klepnutím umístěte první bod.

4. Přesuňte kurzor myši a klepnutím umístěte další bod. Oba body spojí přímý 
čárový segment.

5. Pokračujte v nanášení bodů. Každou mezeru mezi dvěma bodu posléze vyplní 
přímý segment.

6. Ukončete cestu, ať už otevřenou nebo uzavřenou:

• Dvojitým klepnutím v místě posledního bodu ukončíte cestu jako otevřenou.

• Výběrem jiného nástroje také ukončíte cestu jako otevřenou cestu. 

• Chcete-li cestu uzavřít, klepněte na první nanesený bod. U uzavřené cesty je 
počáteční bod shodný s koncovým.

Poznámka: Smyčky tvořené cestou, která překrývá sama sebe, nejsou uzavřenou 
cestou. Uzavřené jsou pouze cesty, které začínají a končí ve stejném bodě.
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Kreslení zakřivených segmentů cesty

Chcete-li nakreslit zakřivený segment cesty, musíte při nanášení bodů klepnout 
a táhnout. Při kreslení se u aktuálního bodu zobrazují kontrolní táhla.

Nakreslení objektu se zakřivenými segmenty:

1. Zvolte nástroj Pen (pero).

2. Klepnutím umístěte první bod.

3. Přesuňte se na místo dalšího bodu a klepnutím a následným tažením vytvořte 
křivkový bod. Pokaždé, když klepnete a zatáhnete, rozšíří Fireworks segment 
čáry i do nového bodu.

4. Pokračujte v nanášení bodů. Pokud klepnete a zatáhnete, vytvoříte křivkový 
bod. Pokud jenom klepnete, vytvoříte rohový bod.

5. Zakončete cestu, ať už otevřenou nebo uzavřenou.

• Dvojitým klepnutím v místě posledního bodu ukončíte cestu jako otevřenou.

• Výběrem jiného nástroje také ukončíte cestu jako otevřenou cestu. Pokud jen 
vyberete jiný nástroj a potom se vrátíte k nástroji Pen, budete dalším klepnutím 
pokračovat v kreslení objektu.

• Klepnutím na první bod uzavřete cestu. U uzavřené cesty je počáteční bod 
shodný s koncovým.
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Úprava tvaru přímého segmentu cesty

Úprava přímého segmentu cesty:

1. Nástrojem Pointer nebo Subselection vyberte cestu.

2. Nástrojem Subselection klepněte na bod a vyberte ho.
Vybrané rohové body se zobrazí jako plné modré čtverečky.

3. Přetáhněte bod do nové pozice.

Úprava tvaru zakřiveného segmentu cesty

Úprava Bézierovy křivky segmentu cesty:

1. Nástrojem Pointer nebo Subselection vyberte cestu.

2. Nástrojem Subselection klepněte na bod na křivce a vyberte ho.
Vybraný bod na křivce se zobrazuje jako plné modré kolečko. Z bodu vystupují 
kontrolní táhla.
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3. Přetáhněte bod nebo jedno z jeho táhel do nové pozice. Modrý náhled cesty 
ukazuje, kde bude ležet nová cesta, pokud uvolníte tlačítko myši.

Táhlo bodu

Kurzor nástroje Subselection

Náhled nové cesty

Původní cesta

Vybraný bod

Zatáhněte například za levé táhlo směrem dolů. Všimněte si, že pravé táhlo 
vystoupilo nahoru.

Omezení pohybu táhla na 45 stupňové kroky:

Při tažení táhla stiskněte klávesu Shift.
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Převody segmentů cesty na přímé nebo zakřivené

Přímé segmenty cesty se protínají v rohových bodech. zakřivené segmenty cesty 
křivkové body obsahují.

Přímé segmenty můžete převádět na zakřivené segmenty a  obráceně, pokud 
převedete příslušný bod.

Převod rohového bodu na vybrané cestě na křivkový bod:

1. Zvolte nástroj Pen.

2. Klepněte na rohový bod a táhněte směrem od něho.
Z bodu se vytáhnou táhla, která zakřiví přilehlé segmenty.
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Převedení křivkového bodu na vybrané cestě na rohový bod:

1. Zvolte nástroj Pen.

2. Klepnutím na křivkový bod ho převeďte na rohový.

Táhla se stáhnou zpět a přilehlé segmenty se napřímí.

Přesun bodu:

Přesuňte bod nástrojem Subselection.

Cesta se překreslí s ohledem na novou polohu bodu.

Změna tvaru segmentu cesty:

Zatáhněte za táhlo bodu.

Navázání na existující cestu

Pokračování v kreslení existující otevřené cesty:

1. Zvolte nástroj Pen.

2. Klepněte na koncový bod a pokračujte v tvorbě cesty.

3. Kurzor nástroje Pen se změní a bude indikovat, že přidáváte k existující cestě.
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Spojování dvou otevřených cest

Dvě otevřené cesty můžete spojit a vytvořit tak jednu souvislou cestu. 
Při spojování dvou cest se vlastnosti obrysu, výplně a efektů první cesty přenesou 
na nově připojenou cestu.

Spojení dvou otevřených cest:

1. Klepněte nástrojem Pen na koncový bod jedné cesty.

2. Přesuňte kurzor nad koncový bod druhé cesty a klepněte.

Automatické spojování podobných otevřených cest

Otevřenou cestu můžete jednoduše spojit s jinou cestou, která má podobné 
charakteristiky obrysu a výplně.

Automatické spojení dvou otevřených cest:

1. Vyberte otevřenou cestu.

2. Zvolte nástroj Subselection a přesuňte koncový bod cesty do vzdálenosti 
několika pixelů od konce druhé podobné cesty. Koncový bod se přichytne 
k druhé cestě a obě cesty se spojí do jedné.
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Vkládání a mazání bodu na cestě

Na cestu můžete přidávat nové body nebo je z cesty mazat. Přidání bodu na cestu 
vám poskytne větší kontrolu nad určitým segmentem cesty. Smazáním bodů 
můžete změnit tvar cesty nebo také zjednodušit její editaci.

Vložení bodu na vybranou cestu:

Pomocí nástroje Pen klepněte kamkoliv na oblast cesty, která neobsahuje bod.

Převedení křivkového bodu na rohový bod:

Klepněte na křivkový bod nástrojem Pen.

Smazání bodu z vybraného segmentu cesty:

• Nástrojem Pen klepněte na rohový bod vybraného objektu.

• Nástrojem Pen dvakrát klepněte na křivkový bod vybraného objektu.

• Vyberte bod nástrojem Subselection a stiskněte klávesu Delete nebo Backspace.
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Vybírání bodů

Nástrojem Pen můžete vybrat pouze jeden bod. Potřebujete-li vybrat více bodů, 
použijte nástroj Subselection a klepejte na body se stisknutou klávesou Shift. Nebo 
můžete použít nástroj Subselection a natáhnout kolem požadovaných bodů výběr.

Pře výběrem bodu nástrojem Pen nejprve nástrojem Pointer vyberte cestu. Jinak 
bude nástroj Pen místo vybírání bodu na existující cestě kreslit novou cestu.

Výběr konkrétních bodů:

1. Zvolte nástroj Subselection.

2. Klepněte na bod nebo podržte klávesu Shift a klepejte postupně na více bodů.

Zobrazení táhel křivkového bodu:

Klepněte na bod nástrojem Subselection. Pokud jsou nejbližší přilehlé body také 
křivkové, zobrazí se i jejich bližší táhla.
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Zobrazení táhel na každé straně rohového bodu:

1. Se stisknutou klávesou Alt (Windows) nebo Option (Macintosh) táhněte 
nástrojem Subselection z bodu na stranu.

2. Chcete-li zobrazit druhé táhlo, opakujte předchozí krok.
Náhled cesty vám ukazuje, jak bude cesta vypadat, až uvolníte tlačítko myši. 

Táhlo bodu

Nástroj Subselection

Náhled cesty

Cesta

Vybraný bod

Přilehlé segmenty cesty upravíte tažením táhla bodu nástrojem Subselection.

Ohnutí segmentu cesty přilehlé k rohovému bodu:

1. Zvolte nástroj Subselection.

2. Vyberte rohový bod.

3. Se stisknutou klávesou Alt (Windows) nebo Option (Macintosh) táhněte 
za úchyt bodu a ohněte přilehlý segment.
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Změna tvaru cest pomocí editačních nástrojů 
vektorového módu

Kromě přetahování bodů a jejich táhel můžete použít několik nástrojů Fireworks 
pro přímou editaci vektorových objektů.

Editační nástroje vektorového módu: Freeform (volná transformace), Reshape Area (přetvarování 
oblasti), Path Scrubber (škrabka), Redraw Path (překreslení cesty) a Knife (nůž).

Ohýbání a přetvarování vektorových objektů

Nástroj Freeform (volná transformace) můžete použít pro přímé přetvarování 
vektorového objektu bez nutnosti editovat body. Můžete zatlačit nebo vytáhnout 
jakoukoliv část cesty nezávisle na tom, kde jsou umístěny body. Fireworks během 
vašich změn vektorového objektu automaticky přidává, přesouvá nebo maže body 
na cestě.

Nástroj Freeform vytahující segment cesty.

  

Nástroj Freeform zatlačující segment cesty a překreslená cesty odpovídající tomuto zatlačení.

Určená délka
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Kurzor myši se v závislosti na své relativní poloze vůči cestě mění na různé typy 
kurzorů.

Kurzor Naznačuje

 Používá se nástroj Freeform.
 

Používá se nástroj Freeform a je v pozici, kdy je možné  
 zatáhnout za cestu.

 Používá se nástroj Freeform a vytahuje vybranou cestu.

 Používá se nástroj Freeform a je ve stavu vytlačování cesty.

 Používá se nástroj Reshape Area. Oblast mezi vnitřním 
a vnějším kruhem představuje oblast snížené síly nástroje.

Když umístíte kurzor přímo nad cestu, můžete za ní zatáhnout. Pokud kurzor není 
přímo nad cestou, můžete cestu vytlačovat. Velikost štětce toho nástroje můžete 
změnit na paletce Tools Options.

Vytahování vybrané cesty:

1. Zvolte nástroj Freeform.

2. Přesuňte kurzor myši přímo nad vybranou cestu.
Kurzor se změní na kurzor tažení.

3. Zatáhněte za cestu.



105  Kapitola 5

Vytlačování vybrané cesty:

1. Zvolte nástroj Freeform.
Kurzor se změní na kurzor vytlačování.

2. Ukažte na oblast mírně mimo cestu.

3. Klepněte a táhněte směrem k cestě. Najížděním do vybrané cesty můžete měnit 
její tvar.

Změna velikosti vytlačovacího kurzoru:

• Stiskněte na klávesnici šipku doprava nebo klávesu 2 – zvětšíte poloměr 
kurzoru.

• Stiskněte na klávesnici šipku doleva nebo klávesu 1 – zmenšíte poloměr 
kurzoru.

• Velikost kurzoru a tedy i délku cesty, kterou ovlivňuje, můžete nastavit i v poli 
Size na panelu Tool Options. Můžete zadat hodnoty 1 až 500. Hodnota určuje 
velikost kurzoru v pixelech.

Poznámka: Nástroj Freeform reaguje i na přítlak tabletů Wacom a dalších 
kompatibilních tabletů.
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Deformování cest

Nástroj Reshape Area (přetvarování oblasti) můžete použít pro tažení vybraných 
cest uvnitř oblasti vnějšího kruhu nástroje. 

Vnitřní kruh nástroje je hranice, kde působí nástroj plnou silou. Oblast mezi 
oběma kruhy tvaruje cestu s menší než plnou silou. Vnější kruh určuje gravitační 
tah nástroje. Jeho sílu můžete nastavit.

Poznámka: Také nástroj Reshape Area reaguje na přítlak tabletů Wacom a dalších 
kompatibilních tabletů.

Deformace vybraných cest:

1. Zvolte nástroj Reshape Area.

2. Táhněte kurzorem pře cesty. Tím dojde k jejich přetvarování.

Změna velikosti kurzoru nástroje Reshape Area:

• Klepněte myší a držte tlačítko stisknuté. Na klávesnici pak šipkou doprava 
nebo klávesou 2 zvětšujete velikost kurzoru. 

• Klepněte myší a držte tlačítko stisknuté. Na klávesnici šipkou doleva nebo 
klávesou 1 zmenšujete velikost kurzoru. 

• Velikost kurzoru a tedy i délku segmentu cesty, kterou ovlivňuje, můžete 
nastavit i v poli Size na panelu Tool Options. Můžete zadat hodnoty 1 
až 500. Hodnota určuje velikost kurzoru v pixelech.
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Nastavení síly vnitřního kruhu nástroje Reshape Area:

Na panelu Tool Options zadejte do pole Strength (síla) hodnotu od 1 do 100. 
Hodnota určuje procento potenciální síly nástroje. Čím vyšší je tato hodnota, 
tím větší je síla.

Překreslování cest

Nástroj Redraw Path (překreslit cestu) můžete použít pro překreslení segmentu 
vybrané cesty se zachováním všech charakteristik obrysu, výplně a efektů.

Překreslení segmentu vybrané cesty:

1. Vyberte nástroj Redraw Path.

2. Přesuňte kurzor přímo na cestu.

3. Tažením překreslete segment cesty. Část cesty, která bude překreslena, 
je zvýrazněna červenou barvou. 

4. Uvolněním tlačítka myši nahraĎte překreslený segment.

Rozdělování cest do několika objektů:

Nástrojem Knife (nůž) můžete cestu rozříznout na dvě nebo více cest.

Poznámka: Pokud vyberete bitmapový obrázek, stane se z nástroje Knife (nůž) 
nástroj Eraser (guma).
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Rozdělení vybrané cesty:

1. Zvolte nástroj Knife.

2. Udělejte jedno z následujícího:

• Zatáhněte kurzorem přes cestu.

• Klepněte na cestu.

3. Zrušte výběr cesty.

Změna tvaru vektorových objektů pomocí operací 
s cestami

Příkazy pro práci s cestami v menu Modify můžete využít i pro tvorbu nových 
tvarů pomocí kombinování nebo upravování existujících cest. U některých operací 
je průběh celého procesu operace závislý na pořadí vrstvení objektů. 

Poznámka: Pokud použijete tyto příkazy pro práci s cestami, odstraní 
se ze změněných cest veškeré informace o přítlaku a rychlosti tahu.

Spojování cest

Více cest můžete sloučit do jediné cesty.

Vytvoření spojité cesty ze dvou otevřených cest:

1. Zvolte nástroj Subselection.

2. Vyberte dva koncové body dvou otevřených cest.

3. V menu zvolte Modify > Join.
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Vytvoření složené cesty:

1. Vyberte dvě nebo více otevřených nebo uzavřených cest.

2. V menu zvolte Modify > Join.

Rozdělení složené cesty:

1. Vyberte složenou cestu.

2. V menu zvolte Modify > Split.

Sloučení dvou uzavřených cest do cesty obklopující celou oblast 

původních cest:

V menu zvolte Modify > Combine > Union. Výsledná cesta převezme nastavení 
obrysu a výplně zadního objektu.

Vytváření objektů z průniku jiných objektů

Můžete vytvořit objekt, který je výsledkem průniku dvou nebo více objektů.

Vytvoření uzavřené cesty obklopující oblast společnou všem 

vybraných uzavřeným cestám:

V menu zvolte Modify > Combine > Intersect. Výsledná cesta převezme nastavení 
obrysu a výplně zadního objektu.
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Odstraňování části objektu

Z vybraného objektu (cesty) můžete odstranit část definovanou jako překrytí jinou 
vybranou cestou, která je v popředí před objektem.

Odstranění části objektu:

1. Vyberte cestu definující oblast, která má být odstraněna.

2. V menu zvolte Modify > Arrange > Bring to Front.

3. Podržte stisknutou klávesu Shift a přidejte k výběru objekt, že kterého chcete 
část odstranit.

4. V menu zvolte Modify >Combine > Punch.
Vlastnosti obrysu a výplně zůstanou beze změny.

Ořezávání cesty

Z objektu můžete odstranit části, které se nacházejí mimo oblast definovanou jinou 
vybranou cestou v popředí. 

Oříznutí vybrané cesty:

1. Vyberte cestu definující oblast oříznutí. 

2. V menu zvolte Modify > Arrange > Bring to Front.

3. Podržte klávesu Shift a přidejte do výběru cesty, které budou oříznuty.

4. V menu zvolte Modify > Combine > Crop.
Výsledným objektům zůstanou vlastnosti obrysu a výplně objektů v pozadí.
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Zjednodušení cesty

Z cesty můžete odstranit body při zachování jejího celkového tvaru.

Zjednodušení vybrané cesty:

V menu zvolte Modify > Alter Path > Simplify.

Rozšíření obrysu

Hranici obrysu vybrané cesty můžete převést na uzavřenou cestu. Výsledná cesta 
vytvoří iluzi cesty bez výplně a obrysu, který je stejný jako výplň původního 

objektu.

Rozšíření obrysu vybraného objektu:

1. V menu zvolte Modify > Alter Path > Expand Stroke. Otevře se dialogové 
okno Expand Stroke. 

2. Nastavte šířku (width) výsledného uzavřené cesty.
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3. Nastavte typ rohu: ostrý, kulatý nebo zkosený.

4. Pokud jste vybrali ostrý roh, nastavte limit ostrosti (miter limit), což je bod, 
za kterým se ostrý roh automaticky změní na zkosený roh. Limit ostrosti je 
poměr mezi délkou ostrého rohu a šířkou obrysu.

5. Zvolte variantu zakončení: tupý, čtvercový nebo kulatý. 

6. Klepněte na OK.
Původní cestu nahradí uzavřená cesta stejného tvaru jako původní obrys, 
se stejným nastavením tahu a výplně.

Smrštění nebo roztažení cesty

Křivku vybraného objektu můžete smrštit nebo roztáhnout o zadanou hodnotu.

Roztažení nebo smrštění vybrané cesty:

1. V menu zvolte Modify > Alter Path > Inset Path. Otevře se dialogové okno 
Inset Path.

2. Zvolte směr, kterým chcete cestu smrštit nebo roztáhnout:

• Volba Inside vede ke smrštění cesty.

• Volba Outside vede k roztažení cesty.

3. Do pole Width nastavte rozestup mezi původní a roztahovanou nebo 
smršťovanou cestou.

4. Nastavte typ rohu: ostrý, kulatý, zkosený.

5. Pokud jste vybrali ostrý roh, nastavte limit ostrosti (miter limit), což je bod, 
za kterým se ostrý roh automaticky změní na zkosený roh. Limit ostrosti je 
poměr mezi délkou ostrého rohu a šířkou obrysu.

6. Klepněte na OK.
Původní cestu nahradí menší nebo větší cesta se stejnými parametry obrysu 
a výplně, jako měla původní.
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Práce s bitmapami

Bitmapové obrázky jsou tvořeny pixely, což jsou malé body na obrazovce, které se 
skládají jako mozaika a vytvářejí tak obraz. Příkladem bitmapového obrázku může 
být naskenovaná barevná fotografie. Kromě vektorových kreslících a editačních 
nástrojů nabízí Fireworks i množství nástrojů pro manipulaci s bitmapovými obrázky.

Možnosti editace bitmap zahrnují tradiční kreslící nástroje pro změnu barvy pixelů, 
mazání pixelů, replikaci bitmapových prvků nástrojem Rubber Stamp (razítko), 
rozostření okrajů bitmapových obrázků a jejich ořezávání a transformaci.

Přechod do bitmapového módu

Pokud zvolíte nějaký nástroj bitmapového módu (například Lasso (laso)), poklepete 
dvakrát na bitmapu nebo vyberete bitmapový obrázek na panelu Layers, přepne 
se Fireworks do bitmapového módu. Pokud je Fireworks v bitmapovém módu, je 
kolem celého dokumentu proužkovaný okraj. Tento okraj vám připomíná, že se 
nacházíte v bitmapovém módu a že v současnosti editujete pixely.

Poznámka: V předchozích verzích Fireworks se bitmapovému módu (bitmap mode) 

říkalo mód editace obrazu (image edit mode).

Proužkovaný okraj okolo plátna v bitmapovém módu.

KAPITOLA 6

6
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Při kreslení a editaci v bitmapovém módu kreslíte jednotlivé pixely na bitmapový 
obraz. narozdíl od vektorového módu , cokoliv v bitmapovém módu nakreslíte, 
změní pixely a přemaže to, co obsahovaly předtím. 

Vektorový objekt s cestou a body a bitmapový objekt celý složený z pixelů.

Přepnutí z a do bitmapového módu

Chcete-li upravovat pixely v naimportované, otevřené nebo vytvořené bitmapě, 
musíte se přepnout z vektorového do bitmapového módu.

Přepnutí do bitmapového módu:

• Vyberte bitmapový objekt jedním z následujících nástrojů: Marquee (výběr), 
Ellipse Marquee (eliptický výběr), Lasso (laso), Polygon Laso (polygonální laso), 
Magic Wand (magická hůlka), Eraser (guma) nebo Rubber Stamp (razítko).

• Klepněte dvakrát na bitmapový obrázek nástrojem Pointer.

• Klepněte na miniaturní náhled bitmapového obrázku na panelu Layers.

• Vyberte bitmapový objekt a v menu zvolte Modify > Edit Bitmap.

Návrat z bitmapového módu do vektorového módu:

• Klepněte na tlačítko Stop umístěné v dolní části okna dokumentu.

Tlačítko Stop
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• Klepněte dvakrát jakýmkoliv výběrovým nástrojem mimo plátno.

• Klepněte dvakrát jakýmkoliv výběrovým nástrojem do dokumentu mimo oblast 
bitmapového obrázku.

• Vyberte na panelu Layers vektorový objekt.

• V menu zvolte Modify > Exit Bitmap Mode.

• Stiskněte Esc.

Dočasné skrytí proužkovaného okraje:

V menu zvolte View > Hide Edges (skrýt okraj). Pokud opustíte bitmapový mód, 
volba Hide Edges se opět vypne.

Nastavení předvolby, která skryje proužkovaný okraj:

1. V menu zvolte Edit > Preferences.

2. V dialogovém okně Preferences zvolte záložku Editing.

3. Deaktivujte volbu Display Striped Border (zobrazit proužkovaný okraj) 
a klepněte na OK.

Zabránění tomu, aby proužkovaný okraj obklopoval celý dokument:

1. V menu zvolte Edit > Preferences.

2. V dialogovém okně Preferences zvolte záložku Editing.

3. Deaktivujte volbu Expand to Fill Document (rozšířit na celý dokument) 
a klepněte na OK.
To je užitečné například v případě, že dokument obsahuje malé bitmapové 
obrázky a vy chcete, aby proužkovaný okraj obklopoval pouze zvolený 
bitmapový obrázek.
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Vybírání oblastí pixelů

V bitmapovém módu jsou primárními výběrovými nástroji nástroje Marquee 
(výběr), Ellipse Marquee (eliptický výběr), Lasso (laso), Polygon Laso (polygonální 
laso) a Magic Wand (magická hůlka).

Nástroje Marquee a Ellipse Marquee

Nástroje Lasso, Polygon Lasso a Magic Wand

Nástroje pro pixelový výběr definují oblast pixelů, kterou chcete vybrat. Když 
natáhnete nástrojem oblast výběru, můžete potom na tyto pixely klepnout 
nástrojem pointer a přetáhnout je:

• Tažením můžete přesunout nebo zvětšit pixely uvnitř výběru.

• Můžete vytvořit plovoucí výběr, který můžete upravovat, přesouvat, vyjmout 
nebo zkopírovat jinam.

Pokud máte aktivní některý z výběrových nástrojů, můžete podržet klávesu Control 
(Windows) nebo Command (Macintosh) a dočasně se tak přepnout na nástroj 
Pointer, kterým můžete výběr přetáhnout a vytvořit tak plovoucí výběr pixelů.

Nastavení voleb výběrových nástrojů

Pokud poklepete dvakrát na nástroj Marquee, Lasso nebo Magic Wand, objeví se 
panel Tools Options s volbami náležejícími k příslušnému nástroji. Roletka Edge je 
dostupná u všech nástrojů pro výběr pixelů:

Volba Hard vytvoří výběr s přesným okrajem.

Volba Anti-alias zabrání zubatým okrajům výběru.

Volba Feather vám umožní změkčit okraj pixelového výběru.
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Pouze pro nástroje Marquee (výběr, eliptický výběr) jsou dostupné tyto volby:

Normal vám umožní vytvořit výběr s nezávislou šířkou a výškou.

Fixed Ration udržuje šířku a výšku výběru ve stanoveném poměru.

Fixed Size nastaví šířku a výšku výběru na zadané rozměry.

Výběr obdélníkové nebo eliptické oblasti pixelů:

1. Klepněte dvakrát na nástroj Marquee nebo Ellipse Marquee. Otevře se 
panel Tool Options.

2. Vyberte styl výběru (roletka Style) a typ hrany (roletka Edge).

3. Tažením myší označte pixely.

Poznámka: Pokud při tažení podržíte klávesu Shift, budete označovat přesně 
čtvercový nebo kruhový výběr. Pokud podržíte klávesu Alt (Windows) nebo Options 
(Macintosh), budete výběr vytvářet od středu.
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Výběr oblasti pixelů od ruky:

1. Klepněte dvakrát na nástroj Lasso (laso) a otevřete tak panel Tool Options.

2. Zvolte typ hrany výběru (Edge)-

3. Táhněte kurzorem myši kolem pixelů, které chcete vybrat.

Vybrání polygonální oblasti pixelů:

1. Klepněte dvakrát na nástroj Polygon Lasso (polygonální laso) a otevřete tak 
panel Tool Options, na kterém vyberte typ hrany výběru (Edge).

2. Klepáním myší ohraničujte oblast výběru.

3. Uzavřete polygon:

• Klepněte na počáteční bod.

• Klepněte dvakrát na pracovní ploše.

Poznámka: Pokud podržíte klávesu Shift, bude nástroj Polygon Lasso vytvářel 
výběr jen ve 45 stupňových úhlech.



  Práce s bitmapami  119

Výběr oblasti pixelů s podobnou barvou:

1. Klepněte dvakrát na nástroj Magic Wand (magická hůlka) a otevřete panel 
Tool Options.

2. Vyberte typ hrany výběru (roletka Edge) a v poli Tolerance nastavte 
toleranci vybíraných barev.
Tolerance definuje rozsah barev, které se vyberou, pokud nástrojem Magic 
Wand klepnete na pixel. Pokud zadáte hodnotu 0, vyberou se pouze 
přilehlé pixely s přesně stejnou barvou, jakou má vybraný pixel. Pokud 
zadáte například hodnotu 65, vybere se široké spektrum souvisejících 
barev.

3. Klepněte na oblast s barvou, kterou chcete vybrat. Okolo vybrané oblasti 
pixelů se objeví ohraničení. 

Pixely vybrané s tolerancí nastavenou na hodnotu 87.

Výběr podobných barev:

1. Vyberte oblast barva obdélníkovým nebo eliptickým výběrovým nástrojem 
nebo lasem.

2. V menu zvolte Edit > Select Similar (vybrat podobné). Okolo vybraných 
pixelů se objeví ohraničení.
Rozsah podobný barev, které jsou vybrány, je určen aktuálním nastavením 
hodnoty tolerance na panelu Tool Options.
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Odstranění ohraničení:

1. Natáhněte jiný výběr nebo výběrovým nástrojem klepněte mimo aktuální výběr.

2. V menu zvolte Edit > Deselect.

3. Opusťte bitmapový mód.

Úprava ohraničení výběru

Když vyberete pixely některým z nástrojů pro výběr, můžete hranici tohoto výběru 
přesunout nebo jinak editovat bez toho, abyste ovlivnili pixely pod ním. Pomocí 
modifikačních kláves můžete do výběru manuálně přidávat pixely nebo je z výběru 
ubírat.

Hranice výběru můžete také roztáhnout nebo zúžit o stanovený počet pixelů, 
můžete vybrat dodatečnou oblast pixelů kolem existujícího výběru, můžete vyhladit 
hranici výběrů nebo vytvořit plovoucí výběr pixelů. Plovoucí výběr vám umožňuje 
upravovat, přesouvat nebo kopírovat vybranou oblast pixelů.

Přesunutí hranice výběru

Výběr můžete přesunout, aniž byste ovlivnili pixely pod ním,

Přesun hranice výběru:

• Zatáhněte za výběr některým z výběrových nástrojů (Marquee, Lasso)

• Pomocí kurzorových kláves můžete výběr posouvat po 1-pixelových krocích.

• Pokud stisknete klávesu Shift a potom některou z kurzorových kláves, budete 
výběr posouvat po 10-pixelových krocích.

Přidávání nebo odebírání pixelů pomocí 

modifikačních kláves:

Pomocí modifikačních kláves můžete přidávat nebo odebírat pixely z výběru. 
Můžete také například vybrat pixely nacházející se v průniku dvou výběrů.
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Přidání pixelů do výběru:

Držte stisknutou klávesu Shift a vyberte oblast pixelů, kterou chcete k výběru 
přidat. Do výběru můžete přidávat i pixely, které nepřiléhají k původnímu výběru.

Odebrání pixelů zevnitř nebo z okraje výběru:

Podržte stisknutou klávesu Alt (Windows) nebo Option (Macintosh) a vyberte 
oblast pixelů, jejíž výběr chcete zrušit.

Použití druhého výběru pro vybrání pixelů uvnitř vybrané oblasti:

1. Při natahování druhého výběru, který překrývá první výběr, podržte stisknutou 
kombinaci Alt+Shift (Windows) nebo Option+Shift (Macintosh).

2. Uvolněte tlačítko myši. Vybrány zůstanou pouze ty pixely, které se nacházely 
v průniku dvou výběrů.

Obdélníkový výběr překrývající původní výběr.

Výsledný výběr
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Roztažení a zúžení výběru

Pokud máte označený nějaký výběr, můžete ho roztáhnout nebo naopak zúžit.

Roztažení hranice výběru:

1. Proveďte výběr a potom v menu zvolte Modify >Marquee > Expand.

2. Zadejte počet pixelů, o který chcete rozšířit hranici výběru. a stiskněte OK.

Zúžení hranice výběru:

1. Proveďte výběr a potom v menu zvolte Modify >Marquee > Contract.

2. Zadejte počet pixelů, o který chcete zúžit hranici výběru. a stiskněte OK.
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Vybrání oblasti okolo existující hranice výběru

Můžete vytvořit výběr, který v zadané šířce rámuje existující výběr. To vám umožní 
vytvářet speciální grafické efekty, jako je například rozmazání krajů výběru.

Původní výběr

Po orámování doplňkovým výběrem

Výběr oblasti okolo existující hranice výběru:

1. Označte výběr a potom v menu zvolte Modify > Marquee > Border.

2. Zadejte šířku pásu, který chcete vybrat okolo existující hranice výběru 
a klepněte na OK.
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Vyhlazení hranice výběru

Ve Fireworks můžete eliminovat přebytečné pixely podél hrany výběru. To je 
užitečné zejména v případě, kdy máte přebytečné pixely po celé délce výběru 
po použití magické hůlky (Magic Wand). 

Výběr pixelů před a po vyhlazení

Vyhlazení hranice výběru:

1. V menu zvolte Modify > Marquee > Smooth.

2. Zadejte poloměr určující požadovaný stupeň vyhlazení a klepněte na OK.

Vytváření plovoucího výběru pixelů

Pokud označíte výběr a přetáhnete ho no jiné místo, zároveň s  výběrem se na nové 
místo nepřesunou pixely pod výběrem. Pokud chcete přesunout, editovat, vyjmout 
nebo zkopírovat vybrané pixely, musíte z nich nejprve udělat plovoucí výběr.

Vytvoření plovoucího výběru pixelů:

Označte výběr a potom za něho zatáhněte nástrojem Pointer (šipka).

Plovoucí výběr můžete přesunout kamkoliv v rámci proužkovaného okraje. Pokud 
vyberete jiné pixely nebo opustíte bitmapový mód, budou pixely permanentně 
umístěny na nové místo.
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Malování v bitmapovém módu

Bitmapové obrázky můžete vytvářet tak, že je otevřete nebo naimportujete, 
namalujete v bitmapovém módu, nebo převedete vektorové objekty na bitmapové. 

Bitmapový soubor (například JPEG) se ve Fireworks automaticky otevře 
v bitmapovém módu.

Vybrané vektorové objekty můžete převést na jeden bitmapový objekt. Můžete také 
převést několik bitmapových objektů do jediného bitmapového objektu. Konverze 
vektorů na bitmapy je technicky nevratná, stále však existuje možnost vrátit 
provedení akce pomocí Edit > Undo nebo pomocí panelu History. Bitmapového 
obrázky nemohou být převedeny na vektorové objekty.

Vytvoření nové bitmapy:

Vložení prázdného bitmapového obrázku:

• Natáhněte nástrojem pro výběr (Marquee, Lasso) označte v dokumentu 
prázdnou oblast.

• V menu zvolte Insert > Empty Bitmap.

Převod vybraných vektorových objektů do bitmapového obrázku:

V menu zvolte Modify > Convert to Bitmap.

Používání kreslících nástrojů v bitmapovém módu

V bitmapovém módu můžete použít nástroje pro tvorbu základních tvarů Line 
(čára)m Pencil (tužka) a Brush (štětec). Při práci v bitmapovém módu však 
nevytváříte vektorové objekty, ale kreslíte jednotlivé pixely. Cokoliv namalujete, 
přemaže existující pixely v obrázku.

Pokud je v dokumentu aktuálně nějaký výběr, malují tyto nástroje pixely pouze 
uvnitř této vybrané oblasti.

Pokud nakreslíte čáry nebo taky štětcem, které přesáhnout dosavadní velikost 
bitmapového obrázku, je velikost bitmapy po opuštění bitmapového módu 
automaticky přizpůsobena rozměrům obdélníkového tvaru obklopujícího všechny 
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pixely bitmapy bez průhledných oblastí na krajích obrázku.

Malování pixelů v bitmapovém módu:

1. Vyberte nástroj pro tvorbu základního tvaru – Line, Pencil nebo Brush.

2. Nastavte na panelu Stroke vlastnosti obrysu. Pokud budete vytvářet nějaký 
základní tvar, nastavte i barvu výplně.

3. Tažením myší malujte.

Změna barvy pixelů nástrojem Paint Bucket 
(kyblík s barvou)

Pokud vyberete pixely, můžete nástrojem Paint Bucket (kyblík s barvou) změnit 
jejich barvu na barvu definovanou v políčku pro barvu výplně. 

Nástroj Paint Bucket

Změna barvy výplně vybraných pixelů:

1. Vyberte požadovanou barvu v políčku pro barvu výplně (fill color).

2. Klepněte dvakrát na nástroj Paint Bucket.

3. Na panelu Tool Options zaškrtněte volbu Fill Selection Only (vyplnit pouze 
výběr).

4. Klepněte dovnitř hranice výběru. Vybrané pixely změní svojí barvu výplně.
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Mazání pixelů

Pro vymazání pixelů nebo jejich přemazání jinou barvou můžete použít nástroj 
Eraser (guma).

Nástroj Eraser (guma)

Standardně odpovídá kurzor nástroje Eraser velikosti a tvaru gumy nastavené 
na panelu Tool Options. 

Smazání pixelů:

1. Dvojitým poklepáním na nástroj Eraser otevřete panel Tool Options.

2. V roletce Erase To (mazat do) nastavte barvu gumy:
Volba Transparent činí vygumované oblastí průhledné.
Volba Fill Color nastavuje barvu vymazaných pixelů na barvu výplně.
Volba Stroke Color nastavuje barvu vymazaných pixelů na barvu obrysu.
Volba Canvas Color vybere jako barvu pro mazání barvu plátna dokumentu.

3.  Vyberte čtvercový nebo kulatý tvar gumy.

4. Chcete-li aby měla guma měkké okraje, nastavte požadovanou hodnotu v poli 
Edge Softness.

5. V poli Eraser Size nastavte velikost hrotu gumy.

6. Táhněte nástrojem Eraser pře pixely, které chcete vymazat nebo přemazat jinou 
barvou.
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Rozostření okrajů výběrů:

Rozostření výběrů nerozmaže pixely v obrázku, ale pouze hranu samotného 
výběru. To je užitečné například v případě, kdy se snažíte vyjmou objekt 
z fotografie. Feathering (rozostření) vám pomůže zkopírovat plynulý přechod 
pixelů do pixelů okolní oblasti.

Rozostření okrajů výběru:

1. V menu zvolte Modify > Marquee > Feather. Otevře se dialogové okno Feather 
Selection.

2. Zadejte hodnotu poloměru rozostření a klepněte na OK.
Hodnota poloměru určuje počet pixelů, které jsou rozostřeny na každé straně 
okraje výběru.

Klonování oblasti pixelů

Pro duplikování oblastí bitmapového obrázku můžete použít nástroj Rubber Stamp 
(razítko). Při klonování se objevují dva typy kurzorů myši. Modrý kroužek indikuje 
oblast, kterou chcete klonovat (zdroj). Kurzorem ve tvaru razítka pak naznačíte, 
kam chcete klonovanou oblast umístit.

Nástroj Rubber Stamp (razítko)

Klonování je užitečné například při opravě poškrábaných fotografií. Jednoduše 
naklonujete nějakou jinou oblast fotografie umístíte ji přes škrábanec.

Kurzory nástroje Rubber Stamp (razítko)
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Klonování se hodí i při vytváření zajímavých efektů, jako je například duplikování 
lidského obličeje nebo jen obličejových částí jinam.

Klonování částí bitmapového obrazu:

1. Klepněte dvakrát na nástroj Rubber Stamp (razítko).

2. Na panel Tool Options zvolte v roletce Source (zdroj) jednu z následujících 
možností:

• Volba Fixed uzamkne zdrojový kurzor (modré kolečko) nad určitou oblastí 
obrázku, takže jí můžete duplikovat více než jednou.

• Volba Aligned odemkne zdrojový kurzor, takže nástrojem můžete duplikovat 
různé části obrázku. Oba kurzory se pak pohybují zároveň.

3. Vyberte požadovanou možnost v roletce Sample (vzorek):

• Volba Image vám umožní klonovat pouze z vybraného obrázku.

• Volba Document vám umožňuje klonování z celé oblasti dokumentu, včetně 
vektorových cest.

4. Pomocí jezdce u pole Stamp Size nastavte velikost razítka.

5. Jezdcem vedle náhledu v poli Edge Softness nastavte měkkost okrajů razítka. 

6. Přesuňte kurzor nad oblast, kterou chcete kopírovat a klepněte.

7. Přesuňte kurzor nástroje Rubber Stamp do oblasti, kam chcete klon umístit, 
a znovu klepněte.

Poznámka: Chcete-li přemístit ukazatel zdroje, podržte stisknutou klávesu Alt 
(Windows) nebo Option (Macintosh) a klepněte nástrojem Rubber Stamp.
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Ořezávání bitmapového obrázku

Pro odstranění částí bitmapového obrázku můžete použít příkaz v menu Edit 
> Crop Selected Bitmap (oříznout vybranou bitmapu). Pokud máte například 
fotografii, která byla pořízena jako moc široká, můžete odříznout objekty v pozadí 
a nechat na fotografii jen hlavní předmět.

Nástroj Crop (oříznutí)

Oříznutí bitmapového obrázku:

1. V menu zvolte Edit > Crop Selected Bitmap. Objeví se úchyty oříznutí.

2. Nastavte úchyty tak, aby hraniční obdélník obklopoval oblast obrázku, který 
chcete zachovat:

• Táhněte za úchyty.

• Podržte klávesu Shift a použijte kurzorové klávesy.

3. Dvojitým klepnutím dovnitř hraničního obdélníku nebo stisknutím klávesy 
Enter provedete oříznutí obrázku. Vše vně hraničního obdélníku bude 
odstraněno.
Chcete-li příkaz Crop přerušit, stiskněte Esc.
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Používání textu

Fireworks obsahuje mnoho funkcí pro práci s textem, které obvykle bývají výsadou 
sofistikovaných DTP aplikací. Text můžete vytvářet ve všech možných fontech 
a velikostech, upravovat prostrkání, rozestup znaků, barvu, proklad, účaří, atd. 
Pokud zkombinujete možnosti editace textu s širokým spektrem obrysů, výplní 
a efektů, uděláte z textu velmi působivý prvek vašich grafických návrhů.

Schopnost editovat text kdykoliv – dokonce i potom, co na text aplikujete živé 
efekty, např. stín a zkosení hran – vám umožňuje kdykoliv opravit pravopisnou 
chybu nebo překlep. Objekty obsahující text můžete také kopírovat a v každé 
kopii text změnit. Další možnosti při tvorbě grafického návrhu vám pak nabídne 
vertikální text, transformovaný text, text na křivkách a text převedený do křivek.

Do Fireworks můžete naimportovat text, který si zachová svoje formátování. 
Text zůstane editovatelný i pokud naimportujete dokument z Photoshopu 
obsahující text. Fireworks zvládá i správu chybějících fontů – při importu vás 
vyzve k vybrání substitučního fontu.

KAPITOLA 7

7
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Zadávání textu

Pomocí nástroje Text a dialogového okna Text Editor můžete do své grafiky vložit 
text a ten editovat a formátovat.

Nástroj Text

Dialogové okno Text Editor

Veškerý text v dokumentu Fireworks se objevuje uvnitř obdélníku s úchyty 
po stranách. Tomuto obdélníku se říká textový blok.

Vložení textu:

1. Zvolte nástroj Text.

2. Klepněte do dokumentu v místě, kde chcete mít začátek textového bloku.
Otevře se dialogové okno Text Editor.

3. Nastavte barvu, font, velikost, proklad a další vlastnosti textu.
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4. Napište text. Zalomení řádku vložíte stisknutím klávesy Enter (Windows) nebo 
Return (Macintosh).

5. Pokud již máte text napsaný, můžete ho v okně textového editoru vybrat a 
přeformátovat.

6. Chcete-li vidět text v dokumentu už při tom, jak píšete v textovém editoru, 
zaškrtněte volby Auto-Apply a klepněte na tlačítko Apply.

7. Klepněte na OK.
V dokumentu Fireworks se objeví textový blok se zadaným textem.

Poznámka: Fireworks si pamatuje barvu nastavenou v textu odděleně od barvy 
obrysu a výplně. Tuto barvu uchovává až do dalšího použití nástroje.

Znovuotevření okna Text Editor:

Poklepejte dvakrát na textový blok.

Přesouvání textových bloků

Textový blok můžete vybrat a přesunout ho kamkoliv v dokumentu stejně jako 
kterýkoliv jiný objekt. S textem můžete pohybovat dokonce i když je otevřené okno 
textového editoru.

Přesun textového bloku:

Přetáhněte blok na nové místo.
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Textové bloky s automatickou velikostí

Fireworks obsahuje textové bloky s automatickou velikostí. Když píšete jeden 
řádek, textový blok se roztahuje. Pokud text odstraníte, textový blok se smrští tak, 
aby obklopil zbývající text. Víceřádkové textové bloky se automaticky nezvětšují.

Chcete-li ovládat šířku zalomeného textu v textovém bloku, změňte velikost 
textového bloku.

Změna velikosti textového bloku:

Zatáhněte za zvětšovací úchyt.

Editace textu

Uvnitř textového bloku můžete měnit všechny aspekty textu včetně velikosti, 
fontu, rozestupů mezi znaky, prokladu, účaří.

Vlastnosti textového bloku můžete měnit buď pomocí menu Text nebo 
v dialogovém okně Text Editor. Menu Text nabízí rychlý způsob, jak měnit 
jednoduché atributy. Při detailnějších úpravách textu použijte okno Text Editor.

Při editaci textu se odpovídajícím způsobem překreslují a jeho obrys, výplň a 
efekty.

Editace textu v okně Text Editor:

1. Klepněte dvakrát na textový blok.

2. V okně Text Editor označte text, který chcete měnit.

3. Proveďte a aplikujte požadované změny.
Informace o změnách vlastností textu se dozvíte v odpovídajících částech této 
kapitoly.

4. Klepněte na OK.
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Výběr fontu, velikosti písma a stylu

Pokud měníte font, velikost a styl písma textu v textovém bloku, můžete použít jak 
menu Text, tak okno textového editoru.

Poznámka: Abyste na Macintoshi mohli používat Type 1 fonty, potřebujete Adobe 
Type Manager 4 nebo vyšší.

Pokud se na text díváte v okně Text Editor, zobrazuje se text standardně vybraným 
fontem ve skutečné velikosti. Textový blok může obsahovat více fontů i velikostí.

Text si v textovém editoru můžete také nechat zobrazit systémovým fontem 
a velikostí. To je užitečné v případech, kdy velikost fontu ztěžuje čtení textu 
při jeho zadávání.

Zobrazení textu systémovým fontem:

V okně Text Editor deaktivujte volbu Show Font.

Zobrazení textu ve standardní velikosti:

V okně Text Editor deaktivujte volbu Show Size & Color.

Změna fontu, velikosti a stylu písma v okně Text Editor:

1. V okně textového editoru označte text, který chcete měnit.

2. Chcete-li změnit font, vyberte nový z roletky Font.
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3. V roletce Size můžete vybrat novou velikost písma.

4. Chcete-li na text aplikovat styl (tučné nebo podtržené písmo, kurzíva), klepněte 
na příslušné tlačítko.

5. Klepněte na OK.

Změna fontu, velikosti a stylu písma pomocí menu Text:

1. Vyberte textový blok nebo bloky. Pokud při vybírání bloků podržíte klávesu 
Shift, můžete vybrat a měnit atributy více textových bloků najednou.

2. Chcete-li změnit font, vyberte ho v podmenu Text > Font.

3. Chcete-li změnit velikost, vyberte novou velikost v podmenu Text > Size.

4. Chcete-li změnit styl, zvolte příslušný styl v podmenu Text > Style.
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Nastavení posunutí účaří a prokladu

Posunutí účaří (baseline shift) určuje, jak hodně text sedí nad nebo pod jeho 
přirozeným účařím. Posunutí účaří můžete použít při vytváření horních a dolních 
indexů.

Proklad (leading) určuje rozestup mezi jednotlivými řádky textu v odstavci. Proklad 
se vyjadřuje v procentech bodové velikosti písma a určuje vzdálenost mezi účařími 
jednotlivých řádků.

Proklad a posunutí účaří můžete nastavit v okně Text Editor.

Prostrkání (kerning)

Proklad (leading)

Posunutí účaří (baseline shift)

Roztažení znaků

Roletky pro nastavení prokladu (nahoře) a posunutí účaří (dole)

Nastavení prokladu a posunutí účaří:

1. V textovém editoru vyberte znaky, které chcete měnit.

2. Z roletky Baseline Shift vyberte hodnotu pro posunutí textu nahoru nebo dolů.

3. Z roletky Leading vyberte hodnotu prokladu. Výchozí hodnota je 100%.

4. Klepněte na OK.
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Nastavení prostrkání

Prostrkání (kerning) zvětšuje nebo zmenšuje mezery mezi určitými páry písmen 
tak, aby se vylepšil jejich vzhled. Většina fontů obsahuje informace, které 
automaticky redukují mezery mezi určitými páry písmen, například „TA“ nebo 
„Va.“ Fireworks při zobrazování textu standardně používá informace fontu 
o prostrkání, ale při malých velikostech písma nebo při vypnutém vyhlazování 
písmen budete chtít možná tuto volbu vypnout. 

Pro nastavení prostrkání použijte okno textového editoru.

Vypnutí automatického prostrkání:

V okně Text Editor deaktivujte volbu Auto Kern.

Nastavení prostrkání:

1. V okně textového editoru vyberte znaky:

• Chcete-li měnit prostrkání dvou znaků, klepněte mezi ně.

• Chcete-li měnit prostrkání bloku znaků, označte znaky, které chcete měnit.

2. Zadejte hodnotu prostrkání.

Nula představuje normální prostrkání. Kladné hodnoty odsunují písmena díle 
od sebe, záporné hodnoty písmena přibližují k sobě.
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Nastavení směru a orientace

Směr textu (neboli tok textu) určuje, zda text plyne zprava doleva nebo zleva 
doprava. Výchozí je nastavení toku zleva doprava.

Text plynoucí zleva doprava a zprava doleva

Orientace textu určuje, zde je textový blok orientován vodorovně nebo svisle. 
Výchozí je nastavení vodorovného bloku.

Vodorovná a svislá orientace

Pro nastavení směru a orientace textu použijte okno textového editoru. 
Tato nastavení se aplikují pouze na celý textový blok.

Tlačítka pro nastavení orientace, zarovnání a směr textu
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Nastavení orientace textu v okně Text Editor:

Klepněte na tlačítko Horizontal Text (vodorovný text) nebo Vertical Text (svislý 
text).

Nastavení zarovnání vybraného textu pomocí menu Text:

Z podmenu Text > Align zvolte příkaz pro požadované zarovnání.

Nastavení směru textu v okně Text Editor:

Klepněte na tlačítko Left to Right (zleva doprava) nebo Right to Left (zprava 
doleva).

Nastavení zarovnání

Zarovnání určuje pozici každé řádky textu v odstavci relativně k pravému a levému 
okraji textového bloku. Text můžete zarovnat k levému nebo pravému kraji 
textového bloku, vycentrovat ho uprostřed bloku nebo text zarovnat k pravému 
i levému bloku zároveň (zarovnání do bloku). Ve výchozím nastavení se text 
zarovnává vlevo.

Chcete-li text roztáhnout tak, aby vyplnil určitý prostor, můžete zarovnávání 
nastavit na vodorovné roztažení textu (nebo svislé pro svislé texty).

Vodorovný text roztažený tak, aby vyplnil textový blok

Zarovnání můžete nastavit v textovém editoru i v menu Text. Zarovnání můžete 
nastavit nezávisle pro jednotlivé odstavce v rámci textového bloku.
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Nastavení zarovnání v okně Text Editor:

1. Vyberte text v textovém bloku.

2. Klepněte na tlačítko Left Alignment (zarovnání vlevo), Center Alignment (na 
střed), Right Alignment (vpravo), Justified Alignment (do bloku) nebo Stretched 
Alignment (roztažení na velikost bloku.

Nastavení barvy textu

Standardně je text černý a nemá žádný obrys. Pokud změníte barvu textu, bude 
Fireworks tuto barvu používat, dokud ji znovu nezměníte. 

Barvu můžete aplikovat na celý textový blok nebo na jednotlivé znaky uvnitř 
textového bloku.

Nastavení barvy textu:

• Zvolte barvu z rozbalovací palety barev v okně textového editoru.

• Vyberte textový blok a zvolte barvu rozbalovací palety barev na panelu Fill.

Okno s paletou barev
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Vyhlazování hran textu

Hrany textu vyhladíte pomocí anti-aliasingu. Ten vytvoří na hranách písmen jemný 
přechod do pozadí, takže text je čistší a čitelnější ve velkých velikostech.

Anti-aliasing nastavíte v okně Text Editor. Vyhlazování se použije na všechny 
znaky v daném textovém bloku.

Vyhlazení hran písma vybraného textu:

1. Otevřete okno Text Editor.

2. Z roletky Anti-Aliasing vyberte jednu z voleb: Crisp (ostrý) , Strong (silný) nebo 
Smooth (hladký).

3. Klepněte na OK.

Poznámka: Pokud ve Fireworks otevřete vektorové soubory například z FreeHandu, 
je text vyhlazený. Pomocí textového editoru můžete tuto vlastnost upravit.

Aplikace obrysů, výplní, efektů a stylů na text

Na text můžete, stejně jako na jiné objekty, aplikovat různá nastavení obrysů, 
výplní, efektů a stylů. Na jeden textový blok můžete aplikovat cokoliv z těchto 
nastavení nebo i všechno najednou. Na panelu Style můžete na text aplikovat 
jakýkoliv styl, a to dokonce i když se nejedná o textový styl. Nastavené vlastnosti 
textu však můžete jako styl uložit.

Text zůstane stále editovatelný. Obrysy, výplně, efekty a styly se při editaci textu 
automaticky aktualizují.

Text s aplikovaným obrysem, výplní, efektem a stylem



  Používání textu  143

Uložení atributů textu

Atributy textu, jako jsou obrys, výplň a efekty, aplikované na text můžete uložit a 
pak znovu používat jako styl z panelu Styles. Uložení atributů textu neukládá text 
samotný, ale pouze nastavené efekty.

Uložení textových atributů do stylu:

1. Vytvořte textový objekt a aplikujte na něj efekty, které chcete.

2. Vyberte textový objekt a na panelu Styles vyberte z menu Options příkaz New 
Style.

3. Vyberte vlastnosti nového stylu a pojmenujte ho.

4. Klepněte na OK.

Připojení textu ke křivce

Chcete-li osvobodit text od omezení obdélníkových textových bloků, můžete 
nakreslit křivku (cestu) a text na ni připojit. Text poteče podél tvaru cesty a stále 
zůstane editovatelný.

Cesta, na kterou připojíte text, dočasně ztrácí svoje nastavení obrysu, výplně a 
efektů. Jakékoliv atributy obrysu, výplně nebo efektů, které aplikujete posléze, 
jsou použity na text, ne na cestu. Pokud text od cesty odpojíte, cesta obnoví svoje 
nastavení obrysu, výplně a efektů. 

Umístění textu na cestu:

1. Podržte stisknutou klávesu Shift a označte textový blok a cestu.

2. V menu zvolte Text > Attach to Path.

Odpojení textu od vybrané cesty:

V menu zvolte Text > Detach from Path.
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Editace textu připojeného k cestě:

• Klepněte dvakrát na objekt textu na cestě. Otevře se okno Text Editor.

• Zvolte nástroj Text a vyberte text, který chcete upravit.

Editace tvaru cesty:

1. V menu zvolte Text > Detach from Path.

2. Upravte cestu.

3. Po dokončení editace opět připojte text ke zvolené cestě.

Pokud text na otevřené cestě přesáhne délku cesty, provede se odřádkování textu a 
text opakuje tvar původní cesty.

Text na cestě se odřádkuje a opakuje tvar cesty.

Směr, ve kterém nakreslíte cestu, určuje směr textu, který se je na cestu připojen. 
Pokud například nakreslíte cestu zprava doleva, objeví se připojený text pozpátku a 
vzhůru nohama. 

Text připojený k cestě nakreslené zprava doleva

Můžete buď změnit směr a orientaci textu připojeného k cestě, nebo můžete změnit počáteční bod 
textu na cestě.
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Změna orientace textu na vybrané cestě:

V menu zvolte Text > Orientation a vyberte požadovanou orientaci.

Text otáčený kolem cesty (volba Rotated Around Path)

Text svisle kolem cesty (volba Vertical)

Text nakloněný svisle kolem cesty (volba Skew Vertical)

Tet nakloněný vodorovně kolem cesty (volba Skew Horizontal)

Otočení směru textu na vybrané cestě:

V menu zvolte Text > Reverse Direction..

Posunutí počátečního bodu textu připojeného k cestě:

1. Vyberte objekt s textem na cestě.

2. Na panelu Object zadejte hodnotu do pole Text Offset (odsazení textu)
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Transformace textu

Textové bloky můžete transformovat stejným způsobem jako ostatní objekty. 
Můžete je zvětšovat, otáčet, naklánět nebo obracet a tak vytvářet unikátní textové efekty.

Transformovaný text můžete stále editovat, i když některé transformace ho mohou 
učinit těžko čitelný. Transformace textu nemění bodovou velikost textu.

Konverze textu do křivek

Text můžete převést na křivky (cesty) a potom editovat tvary písmen jako by šlo 
o jakýkoliv vektorový objekt. Jakmile text převedete na křivky, můžete ho 
upravovat všemi vektorovými editačními nástroji. Nemůžete ho však dále 
upravovat jako text.

Důvod proč převádět text do křivek může být například ten, když potřebujete 
dokument otevřít na počítači, kde není nainstalovaný příslušný font.

Poznámka: Převod textu do křivek není nutný pro prohlížení určitého fontu 
ve webovém prohlížeči, protože při exportu pro web je text exportován do 
bitmapového formátu jako je např. GIF.

Převedení vybraného textu do křivek:

V menu zvolte Text > Convert to Paths.

Text převedený do křivek si zachovává všechny svoje vizuální atributy, ale můžete 
ho už editovat pouze jako text.



  Používání textu  147

Importování textu

Text můžete z jiných dokumentů přenést do Fireworks přetažením nebo 
zkopírováním a vložením ze zdrojových dokumentů.

Ve Fireworks můžete také otevřít nebo naimportovat celé textové soubory.

Fireworks umí naimportovat tyto formáty:

• RTF (formátovaný text)

• ASCII (prostý text)

Otevření nebo importování textu ze souboru:

1. V menu File zvolte příkaz Open nebo Import.

2. Přejděte do adresáře, který obsahuje váš soubor.

3. Vyberte soubor a klepněte na OK.

Import textu z Photoshopu

Do Fireworks můžete otevřít nebo naimportovat celý soubor z Photoshopu, 
nebo můžete do aktuálního dokumentu ve Fireworks text zkopírovat a vložit přes 
schránku, nebo ho můžete z Photoshopu přetáhnout myší.

Pokud chcete z jiného souboru použít pouze určitá slova nebo znaky a nevadí vám, 
že přijdete o možnost editace textu, použijte přetažení myší nebo zkopírování a 
vložení přes schránku. Text se ve Fireworks objeví jako needitovatelný ve formě 
pixelů.

Pokud chcete, aby text zůstal editovatelný, otevřete nebo naimportujte celý soubor.

Poznámka: Textová vrstva si zachová svůj název.
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Import RTF souborů

Při importu textu ve formátu RTF Fireworks zachovává tyto atributy:

• Font, velikost a styl (tučné, podtržené, kurzíva)

• Zarovnání (vlevo, vpravo, na střed, do bloku)

• Proklad

• Posunutí účaří

• Blokové prostrkání (prostrkání shodné pro skupinu znaků)

• Vodorovné rozšíření

• Barvu prvního znaku

Všechny další informace v RTF jsou ignorovány.

Fireworks nemůže importovat RTF text pomocí kopírování přes schránku nebo 
přetažením myší.

Import ASCII textu

ASCII text můžete importovat pomocí kterékoliv metody. Importovaný ASCII text 
je nastaven na aktuální font, velikost 12 pixelů a aktuální barvu výplně.
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Chybějící fonty

Pokud otevřete ve Fireworks dokument, který obsahuje fonty nenainstalované na 
vašem počítači, objeví se dialogové okno Missing Font.

V tomto okně můžete vybrat chybějící font nahradit jiným fontem. Pokud 
nevyberete náhradní font, zobrazí se text výchozím systémovým fontem. Text 
můžete upravit a uložit.

Pokud je soubor otevřen na počítači, který obsahuje původní font, Fireworks si 
tento font bude pamatovat a zobrazí ho.

Výběr náhradního fontu:

1. Ze seznamu Change Missing Font vyberte chybějící font.

2. Ze seznamu To vyberte náhradní font a klepněte na OK. 
Když příště otevřete dokument se stejným chybějícím fontem, bude už 
dialogové okno Missing Fonts obsahovat vámi vybraný font.

Ponechání chybějícího fontu tak, jak je:

Klepněte na tlačítko No Change.
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Aplikace barev, tahů a výplní

Fireworks vám při výběru barev pro vaši grafiku poskytuje širokou škálu možností. 
Můžete použít vzorníky barev, které vám pomohou zachovat vzhled vaší grafiky 
v různých webových prohlížečích a na různých počítačových platformách. Kromě 
výchozího vzorníku barev můžete použít i vzorníky systémových barev Windows 
a Macintoshe nebo si dokonce vytvořit vlastní barva a vzorníky.

Vlastní barvy si můžete namíchat pomocí několika barevným modelů – 
hexadecimálního, RGB, CMY, HSB nebo Grayscale (šedá škála). Jakoukoliv barvu 
ve vašem dokumentu si můžete zobrazit v každém z těchto barevných modelů.

Možnosti nastavení obrysu objektu  (tahu štětce) ve Fireworks se pohybují od 
tenkých vlasových linek až po široké pásy napodobující malbu rozprašovačem. 
Možnosti výplně se pak různí od plné barvy přes vícebarevné přechody až po 
bitmapové vzory. Když aplikujete na objekt přechod nebo výplň vzorem, můžete 
tuto výplň upravovat přímo na pracovní ploše. Kromě základních vzorů Fireworks 
můžete jako výplň použít v podstatě jakýkoliv obrázek. Obrysům a výplním můžete 
také přidat texturu. Navíc můžete nastavení obrysu a výplně objektu uložit jako styl 
a tento styl pak aplikovat na jiné objekty.

KAPITOLA 8
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Vybírání barev

Při vytváření grafiky můžete použít pro výběr barev panel Swatches (vzorník). 
Barvy z panelu Swatches se objevují také v rozbalovacích vzornících na panelech 
Stroke, Fill, Color Mixer a Tools.

Panel Swatches (vzorník)

Otevření panelu Swatches:

V menu zvolte Windows > Swatches.

Políčka s barvou na panelu Tools

Rozbalovací vzorník barev

Otevření rozbalovacího vzorníku barev:
Klepněte na barevné políčko nebo na malou šipku vedle políčka.
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Používání barev

Panel Swatches nebo rozbalovací vzorníky barev můžete použít pro výběr barvy 
obrysu nebo výplně objektu.

Aplikace barvy na vybraný objekt:

1. Klepněte na políčko s barvou výplně nebo tahu.

2. Vyberte barvu:

• Na panelu Swatches klepněte na vzorek barvy. Barva se přenese do obrysu 
nebo výplně vybraného objektu. Tato barva bude také přiřazena do aktivního 
barevného políčka.

• Otevřete rozbalovací vzorník barev a klepněte na vzorek barvy nebo do okna 
zapište její hexadecimální hodnotu.

Nabírání (vzorkování) barev

Z jakéhokoliv místa na obrazovce, včetně jiného dokumentu ve Fireworks, můžete 
nabrat barvu a použít ji na vybrané objekty. Tomuto procesu se anglicky říká 
sampling (nabírání nebo vzorkování barev). Umožňuje vám najít a použít na vaši 
grafiku přesně tu barvu, kterou potřebujete. Můžete tak také zjistit hexadecimální 
hodnotu jakékoliv barvy předtím, než ji aplikujete na vybraný objekt. 

Poznámka: Musíte používat 24-bitový nebo 32-bitový barevný mód.

Aplikace barvy odkudkoliv z obrazovky na vybraný objekt:

1. Na panelu Tools klepněte na políčko s barvou obrysu nebo výplně. Rozbalí 
se vzorník barev a kurzor myši se změní na kapátko.

2. Klepnutím kdekoliv na obrazovce naberete kapátkem barvu v příslušném místě. 
Tato vybraná barva je aplikována na vybraný objekt.

Poznámka: Pokud klepnete se stisknutou klávesou Shift, naberete barvu 
bezpečnou pro web (web safe).
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Zjištění hexadecimální hodnoty barvy:

1. Otevřete rozbalovací vzorník barev u políčka s barvou obrysu, výplně nebo 
efektu. Kurzor myši se změní na kapátko.

2. Přesuňte ukazatel myši nad barvu. V rozbaleném vzorníku barev se objeví 
hexadecimální hodnota barvy.

Poznámka: Pokud klepnete na pole s hexadecimální hodnotou, můžete zadat 
konkrétní hexadecimální hodnotu barvy.

Změna sady barev:

Sadu barev můžete vybrat v menu Options každého vzorníku barev. Výchozí je 
nastavení použité na panelu Swatches.

Přizpůsobení panelu Swatches (vzorník barev)

Vzorky barev na panelu Swatches můžete přidávat, odebírat, nahrazovat nebo 
třídit. Tyto změny se automaticky projeví v ostatních rozbalovacích vzornících.

Můžete také přidávat nebo ubírat celé skupiny vzorků. 

Poznámka: Přidání nebo odebrání vzorku barvy nemůžete vrátit zpět příkazem Edit 
> Undo.
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Přidání barvy z dokumentu Fireworks na panel Swatches:

1. Na panelu Tools vyberte nástroj Eyedropper (kapátko).

2. Klepněte a barvu, kterou chcete přidat.

3. Přesuňte kurzor na panel Swatches nad prázdné místo za posledním vzorkem. 
Kurzor myši se změní na kyblík s barvou.

4. Klepnutím přidejte vzorek na panel.

Přidání barvy odkudkoliv z obrazovky na panel Swatches:

1. Otevřete rozbalovací vzorník barev na panelu Tools. Kurzor myši 
se změní na kapátko.

2. Klepněte kamkoliv na obrazovku (klidně do jiného Fireworks dokumentu) a 
vyberte barvu.

3. Přesuňte kurzor na panel Swatches nad prázdné místo za posledním vzorkem. 
Kurzor myši se změní na kyblík s barvou.

4. Klepnutím přidejte vzorek na panel.

Poznámka: Pokud je v menu Options rozbalovacího vzorníku barev aktivní volba 
Snap to Websafe (vybírat nejbližší barvu bezpečnou pro web), bude jakákoliv 
barva ne bezpečná pro web převedena na nejbližší bezpečnou barvu.

Uložení vzorků barev:

1. Přidejte si požadované barvy na panel Swatches.

2. V menu Options panelu Swatches zvolte příkaz Save Swatches (uložit vzorky).

3. Otevře se dialogové okno Export Swatches. Zadejte adresář a jméno souboru a 
klepněte na Save.
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Nahrazení vzorku jinou barvou:

1. Na panelu Tools vyberte nástroj Eyedropper (kapátko). 

2. Klepněte na barvu.
Tato barva se použije na vybraný objekt a stane se aktivní barvou obrysu nebo 
výplně.

3. Podržte stisknutou klávesu Shift a ukažte na vzorek barvy na panelu Swatches. 
Kurzor myši se změní na kyblík s barvou.

4. Klepnutím na vzorek ho nahradíte novou barvou.

Odebrání vzorku z panelu Swatches:

1. Stiskněte klávesu Control (Windows) nebo Command (Macintosh) 
a ukažte myší na vzorek. Kurzor se změní na nůžky.

2. Klepnutím na vzorek ho odeberete z panelu Swatches.

Vymazání celého panelu Swatches:

V menu Options panelu Swatches zvolte příkaz Clear Swatches (vymazat vzorky).

Návrat k výchozím vzorkům barev:

V menu Options panelu Swatches vyberte paletu barev Windows System nebo 
Macintosh System.

Seřazení vzorků podle barvy:

V menu Options panelu Swatches zvolte Sort by Color (seřadit podle barvy).
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Změna skupiny vzorků barev

Ve Fireworks se můžete jednoduše přepnout na jinou skupinu vzorků nebo 
si vytvořit svoji vlastní. Fireworks vám dává na výběr z těchto skupin: Color 
Cubes (barevné kostky), Continuous Tone (spojité polotóny), Macintosh System 
(systémové barvy Macintoshe), Windows System (systémové barvy Windows), 
Grayscale (škála šedé) a vlastní skupiny vzorků, které naimportujete z ACT nebo 
GIF souborů.

Skupinu vzorků vyberete na panelu Swatches.

Menu Options panelu Swatches

Výběr skupiny vzorků barev:

Skupinu vzorků barev vyberte v menu Options panelu Swatches.

Výběr vlastní skupiny vzorků barev:

1. V menu Options na panelu Swatches zvolte příkaz Replace Swatches (nahradit 
vzorky).

2. Najděte adresář a soubor se vzorky.

3. Klepněte na Open. 
Barevné vzorky ze zvoleného souboru nahradí předchozí vzorky barev.
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Připojení skupiny vzorků barev k aktuálním vzorkům na panelu Swatches:

1. V menu Options na panelu Swatches zvolte příkaz Add Swatches (přidat 
vzorky).

2. Najděte adresář a soubor se vzorky barev. Klepněte na tlačítko Open.
Fireworks přidává vzorky z ACT nebo GIF souborů. Nové vzorky barev se 
objeví na konci aktuální sady vzorků.

Uložení skupiny vlastních vzorků barev:

1. V menu Options na panelu Swatches zvolte příkaz Save Swatches (uložit 
vzorky).

2. Pojmenujte svůj soubor se vzorky a klepněte na tlačítko Save.
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Vytváření barev

Ve Fireworks si můžete vytvořit vlastní barvy a pak je použít na objekty, přidat 
na panel Swatches nebo z nich vytvořit vlastní sadu barevných vzorků. Barvy 
můžete vytvářet na panelu Color Mixer (míchání barev) nebo můžete použít 
systémový panel pro výběr barev.

Vytváření barev na panelu Color Mixer

Panel Color Mixer můžete pro zjištění hodnot aktivní barvy a pro vytváření nových 
barev.

Svoje vlastní barvy můžete vytvářet pomocí těchto barevných modelů: RGB, 
hexadecimálního, HSB, CMY a Grayscale.

Standardně panel Color Mixer identifikuje RGB barvy jako hexadecimální 
a zobrazuje hexadecimální hodnoty červené (R), zelené (G) a modré (B) barevné 
složky. Hexadecimální hodnoty jednotlivých složek se mohou pohybovat v rozmezí 
od 00 do FF.
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Barevný model Barevné složky jsou vyjádřeny jako
RBG Hodnoty červené, zelené a modré (red, green, blue - 

RGB) složky, z nichž každá může mít hodnotu od 0 do 
255. Hodnoty 0-0-0 představují černou a hodnoty 255-
255-255 bílou barvu.

Hexadecimální RGB hodnoty červené, zelené a modré. Každá složka je 
vyjádřena hexadecimální hodnotou od 00 do FF. 00-00-00 
představuje bílou, FF-FF-FF černou barvu.

HSB Hodnoty odstínu (hue), sytosti (saturation) a jasu 
(brightness). Odstín může nabývat hodnoty 0 až 360 
stupňů, hodnoty sytosti a jasu se pohybují v rozmezí 0 až 
100 %.

CMY Hodnoty azurové (cyan), purpurové (magenta) a žluté 
(yellow) složky, z nichž každá může nabývat hodnot 0 až 
255. Hodnota 0-0-0 představuje bílou barvu, hodnota 
255-255-255 černou barvu.

Grayscale Procentuální podíl černé. Jediná černá složka (black – K) 
může mít hodnotu 0 až 100 %, kde hodnota 0 představuje 
bílou a hodnota 100 černou barvu, mezi nimi jsou stupně 
šedi.

Alternativní barevné modely můžete vybrat z menu Options panelu Color Mixer. 
Hodnoty barevných složek se vždy změní na příslušný barevný model.

Zobrazení panelu Color Mixer:

V menu zvolte Window > Color Mixer.

Cyklování proužku s barvami přes různé barevné modely:

Shift-klepněte na barevný proužek v dolní části panelu Color Mixer.

Volby na panelu Color Mixer se nezmění. 
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Použití barvy z barevného proužku na vybraný objekt:

1. Na panelu Color Mixer klepněte na políčko s barvou obrysu nebo výplně. Tím 
ho aktivujete.

2. Přesuňte kurzor myši nad barevný proužek ve spodní části panelu. Kurzor myši 
se změní na kapátko.

3. Klepnutím vyberte barvu.
Barva se použije na vybraný objekt a zároveň se stane aktivní barvou obrysu 
nebo výplně.

Vytvoření barvy na panelu Color Mixer:

1. Před míchání barev zrušte označení všech objektů, abyste zabránili nechtěné 
aplikaci barev na tyto objekty.

2. Klepněte buď na políčko s barvou výplně nebo obrysu – to se stane cílem pro 
novou namíchanou barvu.

3. V menu Options panelu Color Mixer vyberte požadovaný barevný model.

4. Zadejte jednotlivé složky barvy:

• Zadejte hodnoty do textových polí jednotlivých složek.

• Použijte rozbalovací jezdce.

• Vyberte barvu z barevného proužku ve spodní části panelu.

Vytvořenou barvu si můžete umístit na panel Swatches pro další použití.
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Vytváření barev pomocí systémových panelů barev

Kromě panelu Color Mixer a panelu Swatches můžete novou barvu vytvořit také 
pomocí dialogových oken Color (Windows) nebo Color Picker (Macintosh).

Zobrazení systémového panelu barev:

• Poklepejte dvakrát na jakékoliv políčko s barvou.

• V rozbalovacím vzorníku barev u políček s barvou klepněte na tlačítko 
systémového panelu barev.

Zobrazování hodnot barev

Chcete-li zjistit hodnotu určité barvy, použijte panel Info, panel Color Mixer nebo 
rozbalovací vzorník barev u každého políčka s barvou. V rozbalovacím vzorníku 
barev si můžete nechat zobrazit hodnotu téměř jakéhokoliv viditelného objektu 
v jakékoliv aplikaci včetně plochy operačního systému. Na panelu Color Mixer 
můžete vidět hodnotu aktivních barev obrysu a výplně.

Zobrazení panelu Info:

V menu zvolte Window > Info.

Zobrazení panelu Color Mixer:

V menu zvolte Window > Color Mixer nebo klepněte na záložku Mixer na panelu 
Color.

Zobrazení hodnoty barvy jakékoliv částí dokumentu pomocí panelu Info:

Přesuňte kurzor nad objekt obsahující barvu, jejíž hodnotu chcete zjistit.



  Aplikace barev, tahů a výplní  162

Zobrazení hodnoty aktivní barvy obrysu a výplně:

• Chcete-li zjistit RGB hodnoty nebo hodnoty v jiném barevném modelu, 
použijte panel Color Mixer.

• Chcete-li zjistit hexadecimální hodnotu, použijte rozbalovací vzorník 
u políčka s barvou.

Standardně se na panelu Info a Color Mixer zobrazují RGB hodnoty 
a na rozbalovacím vzorníku barev hexadecimální hodnoty. Hodnotový systém 
na panelu Info a Color Mixer však můžete kdykoliv změnit.

Zobrazení informace o barvě v alternativním barevném modelu:

Z menu Options na panelu Info nebo Color Mixer vyberte jiný barevný model.

Používání tahů (obrysů)

U nástrojů Pen (pero), Pencil (tužka) a Brush (štětec) můžete změnit atributy tahu 
nástroje, takže další nakreslený vektorový objekt bude mít tyto nové vlastnosti. 
Tyto vlastnosti samozřejmě můžete na objekt aplikovat i po jeho nakreslení. 
Nastavení tahů (obrysů) můžete použít pouze na vektorové objekty nebo text.

Aktuální barva tahu se objevuje v políčku s barvou tahu na panelu Tools. Toto 
políčko s barvou použijte pro změnu barvy tahu (obrysu) aktuálního kreslícího 
nástroje. 

Políčko s barvou obrysu na panelu Tools označuje ikonka se štětcem

Barvy a další parametry obrysu můžete změnit na panelu Stroke. Můžete si zde 
například vybrat z mnoha různých velikostí a typů štětců.
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Změna barvy tahu (obrysu) kreslících nástrojů:

1. Na panelu Tools klepněte na políčko s barvou obrysu nebo 
na trojúhelníček vedle něj. Otevře se rozbalovací vzorník barev.

2. Ze sady barevných vzorků vyberte požadovanou barvu tahu nástroje.

3. Vyberte kreslící nástroj.

4. Táhněte nástrojem po plátně a nakreslete objekt.

Změna barvy obrysu vybraného objektu:

Na panelu Tools vyberte požadovanou barvu v políčku s barvou obrysu nebo 
v políčku s barvou výplně.

Prohození barvy obrysu a výplně:

Na panelu Tools nebo na panelu Color Mixer klepněte na tlačítko Swap Colors 
(prohodit barvy).

Nastavení barev na výchozí hodnoty:

Klepněte na tlačítko Default Colors (výchozí barvy).

Odstranění všech vlastností obrysu (tahu) z vybraného objektu:

Klepněte na tlačítko No Stroke (bez obrysu) nebo na tlačítko No Fill (bez výplně). 
Aktuální obrys (nebo výplň) bude nastaven na hodnotu None (žádný obrys/výplň).

Použití barvy ze systémového panelu barev:

1. Na rozbalovacím vzorníku barev klepněte na tlačítko systémového panelu 
barev.
Otevře se dialogové okno Colors (Windows) nebo Color Picker (Macintosh).

2. Na systémovém panelu vyberte barvu a klepněte na OK. Vybraná barva 
se stane aktuální barvou obrysu. 
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Změna tahu (obrysu)

Ve Fireworks můžete měnit typ tahu nástroje a vytvářet tak křivky s mnoha 
různými vlastnostmi pera nebo štětce od tenkých, jako tužkou nakreslených čar, 
až po široké pásy napodobující malbu sprejem nebo olejové cákance. Možnost 
přidat k tahu texturu ještě více rozšiřuje jeho kreativní možnosti.

Pomocí panelu Stroke a dialogového okna Edit Stroke máte plnou kontrolu nad 
každou drobnou nuancí štětce, včetně množství nanášeného inkoustu, velikosti 
a tvaru špičky nástroje, textury a efektů na hranách. Navíc můžete pomocí 
nastavení citlivosti ovládat, jak tlakově citlivý tablet ovlivňuje vzhled štětce. 
Výsledný štětec si můžete uložit pro pozdější použití.

Nově vytvořený tah štětce na sebe přebírá aktuálně nastavenou barvu tahu 
(obrysu).

Na panelu Stroje můžete měnit typ obrysu aplikovaného na objekt.

Zobrazení panelu Stroke:

V menu zvolte Window > Stroke.
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Změna atributů tahu (obrysu) vybraného objektu:

1. Na panelu Stroke vyberte v roletce Stroke Category kategorii tahu – například 
Pencil (tužka), Oil (olej), Watercolor (akvarel), atd.

2. V roletce Stroke name vyberte typ tahu.

3. Chcete-li změnit barvu tahu, vyberte vzorek barvy pomocí políčka s barvou na 
panelu Stroke.

4. Pomocí jezdce Edge Softness upravte měkkost hrany tahu. 

5. Z roletky Texture vyberte texturu a zadejte hodnotu její intenzity. 

Poznámka: Některé kategorie štětců mají texturu aplikovanou už ve výchozím 
stavu.

Ukládání tahů

Na panelu Stroke si můžete upravit charakteristiku tahu (např. množství inkoustu, 
tvar hrotu, citlivost hrotu, atd.) a uložit si toto nastavení jako styl, který můžete 
později znovu použít v dalších dokumentech.

Chcete-li si uživatelské nastavení tahu uložit pouze v aktuálním dokumentu, 
použijte menu Options na panelu Stroke. Pomocí tohoto menu můžete upravit 
atributy existujícího tahu nebo vytvořit a uložit vlastní tahy.

Umístění tahu na cestě

Standardně je tah (obrys) objektu vycentrován na vektorové cestě. Toto nastavení 
můžete změnit a obrys umístit buď úplně vně nebo naopak dovnitř cesty. To vám 
umožní kontrolovat celkovou velikost obtažených objektů a dovolí vám to vytvářet 
efekty, jako jsou například hrany vystouplého tlačítka, apod.
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Vycentrovaný obrys, obrys uvnitř a obrys vně cesty

Pro změnu umístění obrysu na cestě použijte tlačítka Stroke na panelu Object.

Posunutí obrysu vně nebo dovnitř cesty:

1. Na panelu Object klepněte na jedno z tlačítek Stroke: Inside (uvnitř), Centered 
(vycentrovaný) nebo Outside (vně).

2. Volitelně můžete aktivovat volbu Fill over Stroke (výplň přes obrys).
Normálně obrys překrývá výplň. Pokud aktivujete volbu Fill over Stroke, 
bude naopak výplň překrývat obrys. Pokud tuto volbu použijete pro objekt 
s neprůhlednou výplní, bude ta část obrysu spadající dovnitř cesty zakrytá. 
Výplň s alespoň nějakou úrovní průhlednosti může zabarvit nebo se smíchat 
s částí obrysu uvnitř cesty.

Používání výplní

U nástrojů Rectangle (obdélník), Rounded Rectangle (zakulacený obdélník), Ellipse 
(elipsa) a Polygon (mnohoúhelník) můžete změnit atributy výplně pro další objekty, 
které těmito nástroji nakreslíte. Objekty můžete vytvářet s jednobarevnou výplní, 
s výplní barevným přechodem nebo s výplní vzorem.

Aktuální barva výplně se objevuje na panelu Tools v políčku s barvou výplně. Panel 
Tools použijte pro změnu výplně kreslícího nástroje.

Ikonka kyblíku s barvou označuje na panelu Tools políčko s barvou výplně.
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Barvu výplně kreslícího nástroje můžete změnit i na panelu Fill. Zde si můžete 
vybrat z množství barevných přechodů a výplňových vzorů. Navíc zde můžete 
změnit vlastnosti výplně objektu i potom, co ho nakreslíte.

Každý objekt nakreslený nástrojem Brush, Pencil nebo Pen vypadá, jako že nemá 
žádnou výplň. Výplň musíte objektu přidat až potom, co nakreslíte objekt.

Změna barvy výplně nástrojů pro tvorbu základních tvarů:

1. Na panelu Tools klepněte na políčko s barvou výplně. Zobrazí se rozbalovací 
vzorník barev.

2. Ze sady barevných vzorků vyberte barvu vaší výplně.

3. Zvolte nástroj Rectangle, Ellipse nebo Polygon.

4. Nakreslete objekt.

Změna výplní

U vašich objektů můžete měnit výplně a vytvářet tak množství efektů od 
jednobarevné výplně až po barevné přechody napodobující satén, vlny nebo různé 
záhyby.  U jednotlivých výplní můžete měnit mnoho atributů, jako je například 
barva, okraj, textura a průhlednost.

Uživatelsky upravenou výplň s barevným přechodem si můžete uložit a pak ji dále 
používat v rámci aktuálního i dalších dokumentů. Chcete-li výplň uložit pro použití 
v různých dokumentech, uložte ji jako styl. 

Nově vytvořené výplně přejímají aktuálně nastavenou barvu z barevného políčka 
na panelu Tools. 

Na panelu Fill upravujete vlastnosti výplně
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Změna jednobarevné výplně

Jednobarevná výplň (solid fill) je tvořena jedinou barvou, která vyplňuje vnitřek 
objektu. Barvu výplně objektu můžete změnit na panelech Tools, Fill nebo Color 
Mixer.

Úprava jednobarevné výplně vybraného objektu:

1. Na panelu Fill vyberte z v roletce Fill Category volbu Solid.

2. Z rozbalovacího vzorníku barev vyberte požadovanou barvu.
Uvnitř vybraného objektu se objeví výplň a vybraní barva se stane aktivní 
barvou výplně.

Používání gradientní výplně 

Všechny kategorie výplní kromě voleb None, Solid, Pattern a Web Dither jsou 
gradientní výplně (výplně barevným přechodem). V gradientu dochází k míchání 
barev a vytváří se tak různé efekty.

Objekty s gradientní výplní typu Satin (satén), Radial (kruhový) a Linear (lineární).
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Aplikace gradientní výplně na vybraný objekt:

1. Na panelu Fill vyberte v roletce Fill Category nějaký typ gradientní výplně.

2. V roletce Fill Name vyberte kombinaci barev výplně, například Red, Green, 
Blue (červeno-zeleno-modrá výplň) nebo Pastels (pastelové barvy).
Uvnitř vybraného objektu se objeví zvolená výplň a zároveň se stane aktivní 
výplní.

Úprava gradientní výplně

Gradientní výplň můžete upravit, uložit, přejmenovat nebo smazat pomocí menu 
Options na panelu Fill.

 výběr barvy

  náhled

Okno pro editaci gradientu

Otevření okna Edit Gradient:

1. Vyberte objekt obsahující gradientní výplň nebo vyberte gradientní výplň 
v roletce Fill Category.

2. Udělejte jedno z následujícího:

• Klepněte na tlačítko Fill na panelu Fill.

• V menu Options na panelu Fill zvolte Edit Gradient.

Objeví se okno Edit Gradient s pruhem barev gradientu a s náhledem 
výsledného gradientu.

Úprava přechodu mezi barvami ve výplni:

Přetáhněte vzorky barev doprava nebo doleva po pruhu barev.
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Přidání nové barvy do gradientu:

Klepněte do oblasti mezi barevným pruhem a náhledem gradientu.

Odstranění barvy z gradientu:

Přetáhněte vzorek barvy mim okno Edit Gradient.

Změna barvy barevného vzorku:

1. Klepněte na vzorek barvy.

2. Z rozbalovacího vzorníku vyberte novou barvu.

Pokud dokončíte úpravu gradientu, stiskněte Enter nebo klepněte mimo okno Edit 
Gradient. Upravená výplň se stane aktivní výplní a zobrazí se ve všech vybraných 
objektech.

Uložení výplní jako stylů

Jakékoliv změny provedené u gradientní výplně si můžete uložit jako styl a ten pak 
používat v mnoha dalších dokumentech (viz. „Používání knihoven, stylů a URL“ 
na straně 223). Gradientní výplň si můžete také uložit pro použití pouze v rámci 
aktuálního dokumentu.

Používání vzorové výplně

Kromě jednobarevné a gradientní výplně můžete objekt vyplnit i bitmapovou 
grafikou – vzorem.   Fireworks se dodává s množstvím vzorových výplní, které 
můžete použít včetně například. koberce, listů a cihel.
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Jako vzorovou výplň můžete také použít bitmapový soubor. Jako vzory můžete 
použít soubory v těchto formátech: PNG, GIF, JPEG, BMP, TIFF a PICT (pouze 
Macintosh). Pokud má soubor se vzorem hloubku 32 bitů a obsahuje průhlednost, 
ovlivní tato průhlednosti i výplň ve Fireworks. Pokud obrázek nemá hloubku 32 
bitů, bude neprůhledný.

Chcete-li do roletky Fill Name na panelu Fill přidat nějaký externí vzor, zkopírujte 
soubor se vzorem do adresáře Fireworks 4\Configuration\Patterns.

Aplikace vzorové výplně na vybraný objekt:

1. Na panelu Fill zvolte v roletce Fill Category volbu Pattern (vzor).

2. Vyberte typ vzoru:

• Vyberte požadovaný vzor z roletky Pattern Name na panelu Fill.

• Chcete-li použít externí vzor, vyberte v roletce Pattern Name položku Other. 
Objeví se dialogové okno, ve kterém najděte a vyberte soubor se vzorem.

Uvnitř vybraného objektu se objeví výplň a vzor se zároveň stane aktivní výplní.

Poznámka: I když je jako aktivní výplň nastaven vzor a je také používán 
na všechny nově kreslené objekty, neobjevuje se tento vzor v políčku s barvou 
výplně na panelech Tools, Fill a Color Mixer.

Transformace a deformace gradientních a vzorových výplní

Vzor nebo gradient ve výplni objektu můžete přesouvat, otáčet, naklánět nebo 
měnit jeho šířku. Pokud vyberete objekt s gradientní nebo vzorovou výplní 
nástrojem Pointer nebo Paint Bucket, objeví se u objektu skupiny táhel. Tažením 
za tyto táhla můžete upravit výplň objektu.

Táhla výplně můžete použít pro interaktivní úpravu vzoru nebo gradientu ve výplni.
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Přesun výplně uvnitř objektu:

Zatáhněte za kulatý střed táhel nebo klepněte na nový střed výplně nástrojem Paint 
Bucket.

Otočení výplně:

Zatáhněte za čáry mezi jednotlivými úchyty.

Úprava šířky a naklonění výplně:

Zatáhněte za čtvercové úchyty.

Nastavení tvrdých, vyhlazených nebo rozostřených hran výplně

Ve Fireworks můžete nastavit hranu výplně tak, aby tvořila skutečně tvrdou linii, 
nebo můžete hranu vyhladit pomocí anti-aliasingu nebo ji rozostřit. Standardně 
jsou hrany výplně vyhlazené anti-aliasingem.Anti-aliasing vyhlazuje zubaté hrany, 
které se mohou objevit u zaoblených objektů (například elips nebo kruhů), jemným 
přechodem hrany do pozadí.

Rozostření (feathering) vytváří viditelný přechod na obou stranách hrany. 
To poskytuje hraně změkčující efekt – téměř něco jako záři.

Změna hrany výplně vybraného objektu:

1. Na panelu Fill vyberte v roletce Edge typ hrany: Hard Edge (tvrdá hrana), 
Anti-Alias (vyhlazená hrana) nebo Feather (rozostřená hrana).

2. Pokud vyberete rozostřenou hranu (Feather), musíte také nastavit počet pixelů, 
které budou na každé straně hrany použity pro rozostření. Výchozí hodnota 
je 10, můžete ji však nastavit v rozmezí 0 až 100. Čím větší číslo nastavíte, tím 
větší bude rozostření hrany.
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Přidávání textur k tahům a výplním

K výplním i tahům (obrysům) můžete přidat texturu a docílit tak prostorového 
efektu. Můžete použít textury dodávané s Fireworks nebo externí textury. 

Přidávání textury k tahu

Textury modifikují jas tahu, ale ne jeho odstín, a dávají tak tahu méně mechanický, 
více organický vzhled, jako byste malovali na strukturovaný povrch. Textury jsou 
mnohem účinnější, pokud se používají společně se širokými tahy. Fireworks 
se dodává s několika texturami, které můžete použít – například šifon, brusný 
papír, atd.

Pomocí panelu Stroke můžete přidat texturu tahu štětcem (obrysu)

Roletka Texture zobrazuje i náhled označené textury
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Přidání textury k obrysu vybraného objektu:

1. Na panelu stroke vyberte kategorii tahu v roletce Stroke Category a typ tahu 
v roletce Stroke Name.

2. Vyberte texturu:

• Vyberte texturu v roletce Texture.

• Chcete-li použít externí texturu, vyberte v roletce Texture položku Other. 
V dialogovém okně najděte soubor s externí texturou. Jako texturu můžete 
použít soubory ve formátu GIF, JPEG, BMP, TIFF 
a PICT (pouze Macintosh).

3. Zadejte hodnotu od 0 do 100, kterou nastavujete hloubku textury. Čím vyšší je 
hodnota, tím je textura intenzivnější.

Přidávání textury k výplni

Textury modifikují jas výplně, ale ne její odstín, a dávají jí tak méně mechanický 
a více organický vzhled. Texturu můžete přidat k jakékoliv výplni. Jako texturu 
můžete použít jednu z textur dodávaných s Fireworks nebo můžete použít externí 
soubor. To vám umožní vytvořit jakýkoliv typ textury.

Texturu k výplni přidáte na panelu Fill
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Roletka Texture zobrazuje i náhled označené textury

Přidání textury k výplni vybraného objektu.

1. Na panelu Fill vyberte typ výplně v roletce Fill Category.

2. Vyberte texturu:

• Vyberte texturu z roletky Texture.

• Chcete-li použít externí texturu, vyberte z roletky Texture volbu Other a zvolte 
soubor s texturou.

3. Zadejte hodnotu od 0 do 100. Tato hodnota nastavuje hloubku textury. Vyšší 
hodnota znamená větší intenzitu textury.

4. Chcete-li do textury přidat průhlednost, zaškrtněte volbu Transparent. Hodnota 
intenzity textury pak kontroluje i průhlednost.

Dithering do barev bezpečných pro web

Někdy můžete potřebovat použít barvu, která není označena jako barva bezpečná 
pro web. Například logo vaší formy může obsahovat barvu, která není bezpečná 
pro web. Chcete-li barvu ditherovat pomocí nejbližších bezpečných barev, zvolte 
typ výplně Web Dither.

Web Dither je metoda, při které jsou dvě barvy v paletě zkombinovány tak, 
aby co nejblíže napodobily barvu, která v paletě není. Pozor však na to, že Web 
Dither může zvětšit velikost cílového souboru.
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Dvě barvy bezpečné pro web vytvářejí ditherovanou výplň.

Použití výplně Web Dither:

1. Vyberte objekt obsahující barvu, která není bezpečná pro web.

2. Na panelu Fill vyberte jako kategorii výplně volbu Web Dither.
Vedle roletky s typem výplně se v políčku s barvou ukazuje původní 
nebezpečná barva. Pod ní se ve tvaru šachovnice objeví dvě webově bezpečné 
barvy. Na vybraném objektu se objeví výplň Web Dither 
a zároveň se stane aktivní výplní.

Poznámka: Nastavení hrany výplně Web Dither na volbu Feather nebo Anti-Alias 
vede opět k webově nebezpečným barvám. 

Vytvoření iluze skutečně průhledné výplně ve webovém prohlížeči:

1. Na panelu Fill aplikujte na vybraný objekt výplň Web Dither.

2. Zaškrtněte volbu Transparent.

3. Vyexportujte objekt jako GIF nebo PBG s nastavenou volbou Index 
Transparency nebo Alpha Channel Transparency.

Pokud se na grafiku podíváte ve webovém prohlížeči, bude pozadí webové 
stránky prosvítat skrze každý pixel průhledné výplně a bude tak vytvářet dojem 
skutečné průhlednosti. Uvědomte si však,že všechny prohlížeče nepodporují 
formát PNG.
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Úprava barvy a tónu

Filtry v menu Xtras a panel Live Effects vám mohou pomoci vylepšit a zdokonalit 
barvy vašich bitmapových obrázků. Fireworks obsahuje mnoho nový filtrů pro 
úpravu barev. Můžete upravovat kontrast, jas, odstín, sytost barev a tonální rozsah.

Navíc můžete obrázek rozostřit nebo zaostřit, dát mu jedinečný vzhled například 
inverzí barev nebo kolorováním obrázku. Nejste však omezeni jen na tyto filtry. 
Do menu Xtras a na panel Live Effects můžete také přidat filtry z Photoshopu.

Tyto filtry se primárně používají na bitmapové obrázky, například na digitální 
fotografie. Filtry však můžete použít i na vektorové objekty. Pokud však aplikujete 
filtr z menu Xtras na vektorový objekt, dojde k jeho převodu na bitmapu. 

Efekty vytvořené pomocí filtrů a plug-inů jsou vratné pomocí příkazu Undo nebo 
panelu History. Filtry a efekty aplikované pomocí panelu Live Effects jsou navíc 
vratné a editovatelné pomocí tohoto panelu.

Používání filtrů a plug-inů jako živých efektů

Ve Fireworks můžete na obrázek aplikovat vestavěné filtry a plug-iny z Photoshopu 
pomocí panelu Effect. To z těchto efektů udělá tzv. živé efekty (live effects).

Používání filtru Levels pro úpravu tonálního rozsahu

Filtr Levels (úrovně) můžete použít pro opravení bitmap s vysokou koncentrací 
pixelů ve světlech, středních tónech i ve stínech. Bitmapa s plným tonálním 
rozsahem by měla obsahovat vyrovnaný počet pixelů ve všech oblastech. Bitmapa 
s vysokou koncentrací světlých pixelů (světla) vypadá jako vybledlá, bitmapa 
s velkým počtem pixelů ve středních tónech zase mdle. Bitmapa s příliš mnoha 
tmavými pixely zase ztrácí detaily.

KAPITOLA 9
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Filtr Levels nastaví nejtmavší pixel jako černou a nejjasnější pixel jako bílou 
a potom proporcionálně přerozdělí střední tóny. Tím se vytvoří obrázek 
s ostřejšími detaily ve všech oblastech.

Původní obrázek s pixely koncentrovanými ve světlých oblastech

Obrázek po úpravě filtrem Levels

V dialogovém okně filtru Levels můžete použít histogram a podívat se na rozložení 
pixelů bitmapy. Histogram je grafické znázornění distribuce pixelů ve světlech, 
středních tónech a stínech bitmapy.

Histogram

Pomocí histogramu můžete zjistit nejlepší metodu opravy tonálního rozsahu 
obrázku. Vysoká koncentrace pixelů v oblasti stínů a světel naznačuje, že byste měli 
obrázek vylepši aplikací funkcí Levels (úrovně) nebo Curves (křivky).

Vodorovná osa představuje hodnoty barev od nejtmavší (0) až po nejsvětlejší (255). 
Pokud se vodorovnou osu budeme dívat zleva doprava, pak vlevo jsou nejtmavší 
pixely, vpravo nejsvětlejší a mezi nimi uprostřed jsou pixely v oblasti středních 
tónů. Pokud upravíte šipečku u středních tonů, ovlivníte jejich jas bez toho, 
abyste ovlivnili stíny nebo světla.
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Úprava světel, středních tónu a stínů:

1. Vyberte obrázek ve vektorovém nebo bitmapovém módu.

2. Otevřete dialogové okno Levels:

• V menu zvolte Xtras > Adjust Color > Levels.

• Na panelu Effect zvolte v roletce Effect volbu Adjust Color > Levels.

3. Chcete-li prováděné změny vidět ihned na plátně, zaškrtněte volbu Preview 
(náhled). Při každé změně se obrázek automaticky aktualizuje.

4. V roletce Channel vyberte, zda chcete změna aplikovat na samostatný barevný 
kanál (červený (red), zelený (green), modrý (blue)) nebo na všechny barevné 
kanály (RGB).

5. Zatáhnutím za jezdce Input Levels pod histogramem upravte světla, střední 
tóny a stíny.
Jezdec napravo upravuje světla v rozmezí hodnot 255 až 0; jezdec uprostřed 
upravuje střední tóny pomocí hodnot 10 až 0,19; jezdec vlevo upravuje stíny 
v rozmezí hodnot 0 až 255. Při posouvání jezdců se hodnoty automaticky 
zapisují do políček Input Levels (vstupní úrovně).

Poznámka: Hodnota stínů nemůže být větší než hodnota světel a obráceně.

6. Zatáhnutím za jezdce Output Levels upravte hodnoty kontrastu v obrázku.
Přetažením pravého jezdce upravujete světla v rozmezí hodnot 255 až 0 
a přetažením levého jezdce upravujete stíny v rozmezí hodnot 0 až 255. 
Při posouvání jezdců se hodnoty automaticky zapisují do políček Output Levels.
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Automatická úprava tonálního rozsahu

Pomocí filtru Auto Levels můžete automaticky nadefinovat nejsvětlejší a nejtmavší 
pixely v obrázku. Filtr Auto Levels je naprosto stejný jako filtr Levels, pouze s tím 
rozdílem, že vše nastaví Fireworks automaticky.

Automatická úprava světel, středních tónů a stínů:

1. Vyberte obrázek ve vektorovém nebo bitmapovém módu.

2. Zvolte příkaz Auto Levels:

• V menu zvolte Xtras > Adjust Color > Auto Levels.

• Na panelu Effect v roletce Effect zvolte příkaz Adjust Colors > Auto Levels.

Poznámka: Světla, střední tóny a stíny můžete automaticky nastavit i tak, že 
v dialogovém okně Levels nebo Curves klepnete na tlačítko Auto.

Úprava tonálního rozsahu pomocí filtru Curves

Funkce Curves (křivky) je podobná funkci Levels, ale nabízí přesnější kontrolu 
nad tonálním rozsahem. Zatímco filtr Levels vám umožňuje ovládat světla, stíny 
a střední tóny, filtr Curves vám umožňuje ovládat jakoukoliv barvu podél celého 
tonálního rozsahu a ne jen tři proměnné. Filtr Curves můžete použít například pro 
odstranění barevného nádechu z fotografie způsobeného světelnými podmínkami.

Mřížka v dialogovém okně Curves znázorňuje hodnotu jasu:

• Vodorovná osa představuje původní jas pixelů (hodnota v poli Input).

• Svislá osa představuje novou hodnotu jasu (hodnota v poli Output).

Pokud otevřete okno Curves poprvé, zobrazuje diagonální čára stav, ve kterém 
nebyla provedena žádná změna, takže vstupní a výstupní hodnoty jsou stejné pro 
všechny pixely.
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Úprava určitého bodu v tonálním rozsahu:

1. Vyberte obrázek ve vektorovém nebo bitmapovém módu.

2. Otevřete dialogové okno Curves:

• V menu zvolte Xtras > Adjust Color > Curves.

• Na panelu Effect vyberte v roletce Effect příkaz Adjust Color > Curves.

3. Pokud chcete vidět prováděné změny na pracovní ploše, zaškrtněte volbu 
Preview (náhled). Provedené změny se pak automaticky aktualizují v obrázku.

4. V roletce Channel vyberte, zda chcete změny provádět v samostatném 
barevném kanálu nebo na všech barvách.

5. Křivku upravíte tak, že klepněte na bod na diagonální čáře a přetáhnete ho 
do nové pozice.

• Každý bod na křivce má svou vlastní hodnotu Input a Output (vstup a výstup). 
Když táhnete myší za bod, hodnoty Input a Output se automaticky aktualizují.

• Křivka zobrazuje hodnoty jasu v rozmezí 0 až 255, kde 0 představuje stíny.
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Křivka po přetažení bodu

Poznámka: Klepnutí na tlačítko Auto vyvolá stejný výsledek jako klepnutí 
na tlačítko Auto v okně Levels.

Smazání bodu na křivce:

Přetáhněte bod mimo mřížku.

Poznámka: Nemůžete vymazat koncové body křivky.

Úprava tonálního rozsahu pomocí kapátek

Světla, stíny a střední tóny můžete upravit i pomocí tlačítek s kapátky v dialogových 
oknech Levels a Curves.

Máte například obrázek s velkým obsahem bílé, který proto vypadá vybledlý. 
Klepněte na kapátko pro světla (tlačítko Select highlight color) a potom klepněte 
do obrázku na pixel, který není bílý. Světla v obrázku budou přemapována 
na novou barvu a obrázek tak získá větší kontrast.
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Úprava tonálního rozsahu pomocí kapátka:

1. Otevřete dialogové okno Curves nebo Levels a z roletky Channel vyberte 
barevný kanál.

2. Vyberte příslušné kapátko:

• Kapátko světel (kapátko s bílým inkoustem) přenastavuje hodnotu světel.

• Kapátko stínů (kapátko s černým inkoustem) přenastavuje hodnotu stínů.

• Kapátko středních tónů (kapátko s šedým inkoustem) přenastavuje hodnotu 
středních tónů.

3. Klepněte na pixel v obrázku a potom na tlačítko OK.
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Úprava jasu a kontrastu

Filtr Brightness/Contrast upravuje kontrast a jas všech pixelů v obrázku. Tento 
příkaz ovlivní světla, stíny i střední tóny obrázku.

Filtr Brightness/Contrast můžete použít pro korekce obrázků, které nevyžadují 
žádné velké změny.

Originál

Po úpravě jasu
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Úprava jasu nebo kontrastu:

1. Vyberte obrázek ve vektorovém nebo bitmapovém módu.

2. V menu zvolte Xtras > Adjust Color > Brightness/Contrast. Objeví 
se dialogové okno Brightness/Contrast.

3. Chcete-li vidět prováděné změny okamžitě na pracovní ploše, zaškrtněte 
políčko Preview (náhled).

4. Přetáhnutím jezdců Brightness a Contract upravte nastavení. Hodnoty 
se mohou pohybovat v rozmezí -100 až 100.

5. Klepněte na OK.

Aplikace barevných výplní

Efekt Color Fill (barevná výplň) můžete použít pro rychlou změnu barvy objektu. 
Efekt buď úplně nahradí pixely objektu vybranou barvou nebo můžete novou 
barvu prolnout s existujícími barvami v objektu. Pokud budete barvy prolínat 
dohromady, bude nová barva přidána navrch objektu. Přimíchání barvy do 
existujícího objektu funguje podobně jako filtr Hue/Saturation, umožňuje však 
rychle aplikovat vybranou barvu.

Přidání efektu Color Fill na vybraný objekt nebo oblast pixelů:

1. Na panelu Effect vyberte z roletky Effect příkaz Adjust Color > Color Fill.

2. Vyberte mód prolínání barev (Blending Mode). Výchozí nastavení je Normal.

3. Z rozbalovacího vzorníku barev vyberte barvu.

4. Vyberte procento průhlednosti barvy a stiskněte klávesu Enter.
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Úprava odstínu a sytosti

Efekt Hue/Saturation můžete použít pro úpravy odstínu, sytosti barev a světlosti 
barev v obrázku.

Úprava odstínu nebo sytosti:

1. Vyberte obrázek ve vektorovém nebo bitmapovém módu.

2. Otevřete dialogové okno Hue/Saturation:

• V menu zvolte Xtras > Adjust Color > Hue/Saturation.

• Na panelu Effect vyberte v roletce Effect příkaz Adjust Color > Hue/
Saturation.

3. Pokud chcete prováděné změny okamžitě vidět na pracovní ploše, zaškrtněte 
políčko Preview.

4. Chcete-li RGB obrázek změnit na dvoutónový obrázek nebo chcete-li přidat 
barvu do černobílého obrázku, zaškrtněte volbu Colorize.
Pokud zaškrtnete volbu Colorize, změní se rozsah jezdců Hue 
a Saturation. Jezdec Hue může nabývat hodnot 0 až 360, jezdec Saturation 
hodnot 0 až 100.

5. Tažením za jezdce Saturation upravte sytost barev. Hodnoty se mohou 
pohybovat v rozmezí -100 až 100.

6. Tažením za jezdce Hue upravte barvu (odstín) obrázku. Hodnoty 
se mohou pohybovat v rozmezí -180 až 180.

7. Tažením za jezdce Lightness upravte světlost barev. Hodnoty se mohou 
pohybovat v rozmezí -100 až 100.

8. Klepněte na OK.
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Invertování barevných hodnot obrázku

Filtr Invert (inverze) můžete použít pro záměnu všech barev v obrázku za jejich 
protějšky na barevném kotouči. Pokud například aplikujete filtr Invert na červený 
objekt (R=255, G=0, B=0), změní se barva na světle modrou (R=0, G=255, 
B=255).

Originál

Po inverzi

Inverze barev:

1. Vyberte vektorový nebo bitmapový objekt.

2. V menu zvolte Xtras > Adjust Color > Invert.
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Rozostření obrázku

Pro rozostření pixelů v obrázku můžete použít příkazy Blur. Možnosti rozostření 
jsou následující: Blur (rozostření), Blur More (větší rozostření) a Gaussian Blur 
(Gaussovské rozostření). Příkaz Blur More rozostří obrázek zhruba třikrát více než 
příkaz Blur. Filtr Gaussian Blur aplikuje na každý pixel vážený průměr rozostření 
a vytváří tak rozmazaný efekt.

Před použitím Gaussovského rozostření

Po použití Gaussovského rozostření

Rozostření obrázku:

1. Vyberte obrázek ve vektorovém nebo bitmapovém módu.

2. Vyberte možnosti rozostření:

• V menu zvolte Xtras > Blur > Blur nebo Blur More.

• Na panelu Effect zvolte v roletce Effect příkaz Blur > Blur nebo Blur More.
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Rozostření obrázku pomocí Gaussovského rozostření:

1. Vyberte obrázek ve vektorovém nebo bitmapovém módu.

2. Otevřete dialogové okno Gaussian Blur:

• V menu zvolte Xtras > Blur > Gaussian Blur.

• Na panelu Effect zvolte v roletce Effect příkaz Blur > Gaussian Blur.

3. Pokud chcete prováděné změny vidět okamžitě na pracovní ploše, zaškrtněte 
políčko Preview.

4. Jezdcem Blur Radius určete sílu efektu rozostření. Hodnota se může pohybovat 
v rozmezí 0,1 až 250. Větší hodnota poloměru rozostření vede k většímu 
rozmazání obrázku.

5. Klepněte na OK.
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Změna přechodů barev na čáry

Pomocí filtru Find Edges (najdi hrany) můžete identifikovat části obrázku, kde 
jsou přechody mezi barvami. Filtr Find Edges tyto přechody převede na čáry. 
V bitmapových obrázcích vyvolává použití filtru Find Edges vzhled skicy.

Originál

Po aplikaci filtru Find Edges

Změna přechodů barev na čáry ve vybraném objektu:

Zvolte příkaz Find Edges:

• V menu zvolte Xtras > Other > Find Edges.

• Na panelu Effect vyberte v roletce Effect příkaz Other > Find Edges.
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Konverze obrázku

Filtr Convert to Alpha můžete použít pro konverzi objektu nebo textu do 
gradientu v závislosti na jasu obrázku.

Převedení vybraného obrázku na alfa kanál:

Zvolte příkaz Convert to Alpha:

• V menu zvolte Xtras > Other > Convert to Alpha.

• Na panelu Effect vyberte v roletce Effect příkaz Other > Convert to Alpha.

Zaostření obrázku

Filtr Sharpen (zaostření) můžete použít pro opravu rozmazaných obrázků. 
Podmenu Sharpen obsahuje příkazy Sharpen, Sharpen More a Unsharp Mask. 
Příkaz Sharpen upraví ostrost rozmazaného obrázku zvýšením kontrastu přilehlých 
pixelů. Příkaz Sharpen More zvětší tento kontrast zhruba třikrát více než příkaz 
Sharpen. Příkaz Unsharp Mask zaostří obrázek úpravou kontrastu na hranách 
obrázku. Unsharp Mask nabízí největší míru kontroly a je proto obvykle tou 
nejlepší volbou při zaostřování obrázku.

Originál

Po zaostření
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Zaostření obrázku:

1. Vyberte obrázek ve vektorovém nebo bitmapovém módu.

2. Zvolte jednu z možností zaostření:

• V menu zvolte Xtras > Sharpen > Sharpen nebo Sharpen More.

• Na panelu Effect vyberte v roletce Effect příkaz Sharpen > Sharpen nebo 
Sharpen More.

Poznámka: Pokud obrázek zaostříte příliš, může to degradovat jeho kvalitu.

Zaostření obrázku pomocí Unsharp Mask:

1. Vyberte obrázek ve vektorovém nebo bitmapovém módu.

2. Otevřete dialogové okno Unsharp Mask:

• V menu zvolte Xtras < Sharpen > Unsharp Mask.

• Na panelu Effect vyberte v roletce Effect příkaz Sharpen > Unsharp Mask.

3. Pokud chcete prováděné změny ihned vidět na obrázku, zaškrtněte políčko 
Preview.

4. Přetažením jezdce Sharpen Amount (množství zaostření) nastavte množství 
zaostření v rozsahu 1 až 500 procent.

5. Přetažením jezdce Pixel Radius (poloměr v pixelech) nastavte poloměr zaostření 
v rozmezí 0,1 až 250.
Větší rádius má za následek větší oblast ostrého kontrastu okolo každé hrany 
v obrázku.

6. Přetažením jezdce Threshold (práh) nastavte práh s hodnotou od 0 do 255. 
Běžně se používají hodnoty mezi 2 a 25.
Vyšší práh zaostří pouze pixely s vyšším kontrastem. Nižší práh zahrne do 
zaostření i pixely s nižším kontrastem.
Práh s hodnotou 0 zaostří všechny pixely v obrázku.
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Používání živých efektů

Efekty ve Fireworks jsou živé, což znamená, že pokud upravíte objekt 
s aplikovaným efektem, je efekt pro upravený objekt přepočítán tak, aby bylo 
docíleno správného výsledku. Tyto efekty mohou být jednoduše zapínány 
a vypínány, což zjednodušuje porovnávání různých verzí grafiky.

S širokým výběrem obrysů a výplní Fireworks můžete vytvořit velmi podmanivou 
grafiku pro vaši webovou stránku. Ale co takhle ještě aplikovat na tlačítka zkosení 
hran a přidat tak tlačítkům vystouplý vzhled? Nebo nechat z objektu vycházet záři? 
Ne k textu přidat jemný stín vyvolávající dojem hloubky?

Tyto a mnoho dalších efekt můžete ve Fireworks jednoduše použít. Navíc můžete 
všechny efekty na objekt aplikovat pouze pomocí jedné návštěvy panelu Effect. 
Živé efekty můžete upravovat a editovat stejně jednoduše, jako je přidávat.

Ve Fireworks 4 můžete jako živé efekty použít i filtry z menu Xtras (doplňky), 
například filtry Gaussian Blur nebo Sharpen. Flexibility živých efektů může nyní 
využít i mnoho plug-inů z Photoshopu.

KAPITOLA 10

10



Aplikování živého efektu

živé efekty se aplikují pomocí panelu Effect. Na jeden objekt můžete aplikovat 
několik efektů. Pokaždé, když k objektu přidáte efekt, přidá se do seznamu na 
panelu Effect. Vedle každého efektu v seznamu je zaškrtávací políčko. Tímto 
políčkem můžete efekt zapínat a vypínat.

 Ukládání, editace, pojmenování a mazání efektů

Výběr kategorie efektu

Seznam efektů

Panel Effect

Použití živého efektu na vybraný objekt:

1. Vyberte efekt z roletky Effect.
Vybraný efekt se přidá do seznamu efektů objektu.

2. Pokud se otevře dialogové okno, upravte nastavení efektu.
Klepnutím na OK dialogové okno zavřete. 

Poznámka: Panel Effect není dostupný v bitmapovém módu.

3. Chcete-li k objektu přidat další živé efekty, opakujte kroky 1 a 2.
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Používání doplňků (Xtras) Fireworks jako živých efektů

Ve Fireworks můžete pomocí panelu Effect aplikovat na objekt jako živé efekty 
všechny vestavěné filtry z menu Xtras. U takto aplikovaných živých efektů máte 
zajištěno, že budete moci efekt z objektu kdykoliv odstranit nebo ho upravit. 
Samozřejmě můžete upravovat i objekt s aplikovaným efektem.

Menu Xtras používejte pro aplikaci filtrů pouze tehdy, pokud jste si jisti, že filtr již 
nebudete potřebovat odstranit nebo upravit.

Poznámka: Pokud aplikujete filtr z menu Xtras, můžete filtr odstranit pouze 
v případě, že je možné použít příkaz Undo. Pokud soubor zavřete a znovu otevřete, 
filtr již nepůjde odstranit, protože dojde v vyčištění panelu History.

Používání plug-inů z Photoshopu jako živých efektů

Pokud do Fireworks doinstalujete plug-iny z Photoshopu, jsou přidány do menu 
Xtras a na panel Effect. Menu Xtras používejte pro aplikaci efektů pouze tehdy, 
když jste si jisti, že nebudete potřebovat filtr upravit nebo ho z objektu odstranit.

Pokud pro aplikaci plug-inů z Photoshopu použijete panel Effect, aplikují se jako 
živé efekty. Některé plug-iny z Photoshopu však jako živé efekty použít nejdou.

Poznámka: Pokud s někým sdílíte soubor z Fireworks, ve kterém je jako živý efekt 
použit plug-in z Photoshopu, musí mít příjemce souboru plug-in také nainstalovaný, 
aby mohl efekt vidět. Vestavěné efekty Fireworks jsou však přenášeny zároveň se 
souborem, takže příjemce nemusí instalovat žádný další software, aby efekty viděl.

Instalace plug-inu z Photoshopu:

1. Na panelu Effect zvolte v menu Options příkaz Locate Plugins.

2. Najděte adresář, kde je nainstalovaný plug-in z Photoshopu a klepněte na OK.

3. Restartujte Fireworks, aby se plug-in načetl.

Poznámka: Pokud plug-in přesunete do jiného adresáře, zopakujte výše popsané 
kroky nebo v menu zvolte File > Preferences a na záložce Folders změňte cestu 
k plug-inům. Potom restartujte Fireworks.

Aplikace plug-inu z Photoshopu jako živého efektu na vybraný objekt:

Vyberte příslušný plug-in z roletky Effect na panelu Effect.
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Používání tradičních efektů

Ve Fireworks můžete vytvářet tradiční webové efekty jako jsou například zkosené 
hrany, stíny, záře nebo vytlačení. Každý efekt si můžete přizpůsobit, aby vypadal 
přesně tak, jak chcete. Každé nastavení můžete kdykoliv změnit.

Pokud vyberete efekt Bevel (zkosení hran), Emboss (vytlačení), Shadow (stín) 
nebo Glow (záře), objeví se na panelu Effect rozbalovací okno, ve kterém můžete 
upravit nastavení efektu. Volby v tomto okně se liší v závislosti na vybraném 
efektu.

Experimentujte s nastavením, dokud nedosáhnete požadovaného vzhledu. 

Šířka zkosení

Kontrast

Měkkost

Úhel zkosení

Nastavení efektu Inner Bevel (vnitřní zkosení)

Aplikace zkosených hran (Bevel)

Aplikací zkosených hran přidáte například k tlačítku prostorový vzhled. Můžete 
provést buď vnitřní nebo vnější zkosení (inner bevel, outer bevel).

Vnitřní zkosení (inner bevel) a vnější zkosení (outer bevel).
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Aplikace zkosených hran na vybraný objekt:

1. Na panelu Effect vyberte jednu z možností zkosení:

• Zvolte Bevel and Emboss > Inner Bevel (vnitřní zkosení).

• Zvolte Bevel and Emboss > Outer Bevel (vnější zkosení).

2. V rozbaleném okně upravte nastavení efektu.

3. Klepněte mimo okno s nastavením nebo stiskněte Enter. Tím okno zavřete.

Aplikace efektu vytlačení (Emboss)

Efekt vytlačení (emboss) můžete použít pro simulaci objektu vytlačeného nebo 
naopak vtlačeného do pozadí. Pomocí vytlačení můžete vytvořit tlačítko, které 
zamáčknuté nebo naopak vystupuje nad své okolí. Na objekt můžete použít efekt 
Inset Emboss pro simulaci vtlačení do pozadí nebo efekt Raised Emboss pro 
simulaci vyvýšení nad pozadí.

Inset Emboss (vtlačení) a Raised Emboss (vyvýšení) na modrém pozadí.

Aplikace efektu vytlačení:

1. Otevřete roletku Effect a podívejte se na seznam dostupných efektů.

2. Vyberte efekt Emboss:

• Zvolte Bevel and Emboss > Inset Emboss (vtlačení do pozadí).

• Zvolte Bevel and Emboss > Raised Emboss (vyvýšení nad pozadí).

3. V rozbaleném okně upravte nastavení efektu. 
Pokud chcete, aby byl ve výsledku vidět i původní objekt, zaškrtněte políčko 
Show Object.

4. Pokud jste s nastavením hotovi, klepněte mimo okno nebo stiskněte Enter. Tím 
okno zavřete.

Poznámka: Z důvodů zpětné kompatibility se efekty Emboss ve starších 
dokumentech otevírají s vypnutým políčkem Show Object.
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Aplikace stínů a září

Ve Fireworks můžete u objektů velice jednoduše udělat stíny, vnitřní stíny a záře. 
U stínu můžete určit úhel stínu a tam simulovat úhel světla dopadajícího na objekt.

Stín (drop shadow), vnitřní stín (inner shadow) a záře (glow).

Použití stínů a vnitřních stínů:

1. Otevřete roletku Effect a podívejte se na seznam dostupných efektů.

2. Zvolte jednu z možností stínu:

• Zvolte Shadow and Glow > Drop Shadow (stín).

• Zvolte Shadow and Glow > Inner Shadow (vnitřní stín).

3. V rozbaleném okně upravte nastavení efektu:

• Tažením za jezdce Distance nastavte vzdálenost stínu od objektu.

• Tažením za jezdce Opacity nastavte procento průhlednosti stínu.

• Zatržením políčka Knock Out skryjete objekt a zůstane zobrazen pouze stín.

4. Pokud jste hotovi, zavřete okno klepnutím mimo něj nebo stisknutím Enter.

Použití záře:

1. Otevřete roletku Effect a podívejte se na seznam dostupných efektů.

2. Zvolte Shadow and Glow > Glow.

3. V rozbaleném okně upravte nastavení efektu:

• Tažením za jezdce Offset nastavte vzdálenost záře od objektu.

• Tažením za jezdce Opacity nastavte procento průhlednosti záře.

• Klepněte na políčko s barvou a vyberte barvu záře.

4. Pokud jste hotovi, zavřete okno klepnutím mimo něj nebo stisknutím Enter.



  Používání živých efektů  199

Změna živých efektů

Chcete-li změnit efekt aplikovaný na objekt, klepněte na panelu Effect na tlačítko 
Info vedle jména efektu.

Úprava živého efektu:

1. Na panelu Effect klepněte na tlačítko Info vedle jména efektu, který chcete 
upravit. Objeví se buď rozbalovací okno s nastavením nebo dialogové okno.

Poznámka: Pokud se efekt nedá upravovat, je tlačítko Info zašedlé. Například 
nejde editovat efekt Auto Levels.

Okno s nastavením efektu Drop Shadow (stín).

2. Upravte nastavení efektu.

3. Pokud jste hotovi, zavřete okno klepnutím mimo něj nebo stisknutím Enter.
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Změna pořadí živých efektů

Pořadí efektů aplikovaných na objekt můžete měnit. Přeskládání efektů změníte 
pořadí, ve kterém jsou na objekt aplikovány. To může ovlivnit vzhled objektu.

Obecně by měli být efekty, kterém mění vnitřek objektu (například Inner Bevel), 
aplikovány před objekty, které mění vnějšek objektu. Například efekt Inner Bevel 
by měl být aplikován před efekty Outer Bevel, Glow a Shadow.

Změna pořadí efektů aplikovaných na vybraný objekt:

Na panelu Effect přetáhněte efekt myší na požadovanou polohu v seznamu efektů.

Efekty v horní částí seznamu jsou aplikovány před efekty ve spodní části.

Odstraňování živých efektů

Efekty z objektu můžete jednoduše odstranit. Pokud je na objekt aplikováno 
několik efektů, můžete odstranit například jen jeden z nich nebo všechny.

Odstranění jednoho efektu aplikovaného na vybraný objekt:

1. Na panelu Effect vyberte ze seznamu efekt, který chcete z objektu odstranit.

2. Klepněte na tlačítko Delete v dolní části panelu nebo efekt myší přetáhněte na 
toto tlačítko.

Odstranění všech efektů z vybraného objektu:

Na panelu Effect vyberte z roletky Effect položku None.
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Vytváření vlastních živých efektů

Pomocí menu Options na panelu Effect můžete uložit vlastní nastavení efektů, 
přejmenovat efekt nebo ho smazat. Ve Fireworks 4 jsou efekty ukládají s aplikací. 
Pokud pojmenujete a uložíte nastavení efektu na objektu, bude tento efekt 
dostupný ve všech následně otevřených dokumentech.

Pokud pojmenujete a uložíte skupinu efektů aplikovaných na objekt, můžete pak 
všechny tyto efekty použít na jiný objekt najednou. 

Poznámka: Pokud otevřete dokument z předchozích verzí Fireworks, který 
obsahuje pojmenované efekty, mají tyto efekty název Unnamed (beze jména). 
Všechny parametry efektů jsou však zachovány. Efekt můžete přejmenovat 
na panelu Effect.

Uložení nastavení efektu:

1. Z menu Options panelu Effect zvolte Save Effect As.

Menu Options panelu Effect

2. Zadejte jméno efektu a klepněte na OK. Efekt bude přidán do roletky Effect.

Přejmenování uživatelského efektu:

1. Na panelu Effect vyberte uživatelský efekt, který chcete přejmenovat.

2. V menu Options panelu Effect zvolte příkaz Rename Effect (přejmenovat efekt).

3. Zadejte nové jméno a klepněte na OK.
Standardní efekty Fireworks nemůžete mazat ani  přejmenovat.
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Smazaní pojmenovaného uživatelského efektu:

1. Vyberte objekt obsahující uživatelský efekt, který chcete smazat, nebo vyberte 
tento efekt v roletce Effect. 

2. V menu Options panelu Effect zvolte příkaz Delete Effect (smazat efekt).

Uložení živého efektu jako stylu

Efekt můžete uložit jako styl a potom ho opětovně používat. Živé efekty patří 
k těm atribut´m, které můžete uložit jako styl nebo součást stylu. 

Používání výchozího nastavení  živých efektů

Pokud často používáte určité nastavení živého efektu, můžete toto nastavení 
nadefinovat pro efekt jako výchozí. Pokud například pro tlačítka používáte určitou 
kombinaci stínu a záře, uložte tuto kombinaci nastavení jako výchozí a potom ji 
používejte ve svých dokumentech.

Uložení kombinace nastavení efektu jako výchozího nastavení:

1. Vyberte objekt, který obsahuje nastavení, které chcete používat jako výchozí.

2. Z menu Options panelu Effect zvolte příkaz Save Defaults.

Použití výchozího nastavení efektu na objekt:

Z roletky Effect na panelu Effect zvolte příkaz Use Defaults.

Ovládání vykreslování živých efektů

Pokud je v dokumentu obsaženo velké množství živých efektů, může otevření 
takového souboru trvat o trochu déle. Pokud navíc zvětšíte nebo třeba upravíte 
objekt s množstvím efektů, může Fireworks trvat delší dobu překreslení objektu na 
obrazovce.

Pokud chcete zvýšit rychlost překreslování, můžete efekty přechodně vypnout.
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Přechodné vypnutí a zapnutí efektu aplikovaného na objekt:

Aktivujte nebo deaktivujte zaškrtávací políčko vedle jména efektu na panelu Effect.

Přechodné vypnutí nebo zapnutí všech efektů aplikovaných na objekt:

Z menu Options panelu Effect zvolte příkaz All Off  (vše vypnout) nebo All On 
(vše zapnout).

Aplikace efektů na seskupené objekty

Pokud aplikujete efekt na skupinu, je použit na každý objekt ve skupině. Jestliže je 
skupina objektů opět rozdělena, vrátí se každý objekt k nastavení efektů, které měl 
dříve jako samostatný objekt.

Pokud objekt uvnitř skupiny vyberete nástrojem Subselection, můžete aplikovat 
efekt jen na tento objet.
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Vrstvy a maskování

Vrstvy rozdělují dokument Fireworks do samostatných rovin, jako by byly 
jednotlivé části kresby nakresleny na samostatných průhledných fóliích. Dokument 
se může skládat z mnoha vrstev a každá vrstva může obsahovat mnoho objektů. 
Ve Fireworks je seznam vrstev a objektů v jednotlivých vrstvách umístěn na panelu 
Layers. Vrstva ve Fireworks je ekvivalentní skupině vrstev ve Photoshopu 6. Vrstva 
z Photoshopu je ekvivalentní samostatnému objektu z Fireworks. 

Techniky maskování a prolínání vrstev vám poskytují další stupeň kreativní 
kontroly nad dokumentem. Při maskování můžete použít vektorový nebo 
bitmapový objekt a zakrýt část pod ním ležícího obrázku. Můžete například vytvořit 
eliptický vektorový objekt a použít ho jako masku navrchu fotografie. K nastavení 
masky k fotografii použijte příkaz Paste as Mask. Všechny oblasti vně elipsy budou 
skryty a bude se zobrazovat pouze část fotografie uvnitř elipsy.

KAPITOLA 11

11
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O vrstvách

Každý objekt v dokumentu leží ve vrstvě. Všechny vrstvy si klidně můžete vytvořit 
ještě předtím, než začnete kreslit, nebo je můžete přidávat postupně podle potřeby. 
Plátno je pod všemi vrstvami a samo o sobě není vrstvou. 

Na panelu Layers (vrstvy) můžete vidět pořadí objektů. To ke pořadí, ve kterém 
se objekty objevují v dokumentu. Uvnitř dokumentu skládá Fireworks vrstvy 
v takovém pořadí, v jakém byly vytvořeny, přičemž tu nejnovější dává nahoru nad 
ostatní. Pořadí vrstvení vrstev určuje, jak budou objekty v jedné vrstvě překrývat 
objekty v druhé vrstvě. Pořadí vrstev můžete upravit stejně tak, jako můžete 
upravit pořadí objektů uvnitř vrstvy.

Panel Layers zobrazuje aktuální stav všech vrstev v aktuálním snímku dokumentu. 
Jméno aktivní vrstvy je zvýrazněno. Vrstvu můžete rozbalit a podívat se na seznam 
objektů, které obsahuje. U objektů jsou zobrazeny jejich miniaturní náhledy. 

Na panelu Layers se zobrazují i masky. Pomocí panelu Layers můžete také vytvořit 
novou masku. Pokud vyberete miniaturní náhled masky, můžete masku editovat. 

Na panelu Layers najdete také nastavení průhlednosti a módu prolínání vrstev.
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Pokud chcete ochránit objekty ve všech vrstvách kromě aktivní vrstvy od 
nechtěných změn, zvolte v menu Options panelu Layers příkaz Single Layer 
Editing (editace jediné vrstvy). Zaškrtnutí (Windows) nebo puntík (Macintosh) 
v menu vedle příkazu Single Layer Editing ukazuje, zda je mód editace jedné vrstvy 
aktivní. Pokud je mód aktivní, můžete vybírat a editovat pouze objekty v aktuální 
vrstvě.

Webová vrstva (web layer)

Webová vrstva (web layer) je speciální vrstva, která je navrchu každého dokumentu. 
Webová vrstva obsahuje webové objekty, jako jsou řezy (slices) a aktivní oblasti 
(hotspots) používané pro tvorbu interaktivity při exportu dokumentů z Fireworks.  

Webovou vrstvu nemůžete smazat, duplikovat, přesunout ani přejmenovat. Webová 
vrstva se vždy sdílí pro všechny snímky a webové objekty jsou v každém snímku 
viditelné. 

Zamknout/odemknout vrstvu
Zobrazit/skrýt vrstvu

Rozbalit/zabalit vrstvu

  
       Smazat vrstvu

 Nový bitmapový obrázek

       Přidat masku

Nová vrstva/duplikovat vrstvu

Aktivní vrstva
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Přejmenování řezu nebo hotspotu v webové vrstvě:

1. Poklepejte dvakrát na řez nebo hotspot na panelu Layers.

2. Zadejte jméno a klepněte vně okno nebo stiskněte Enter.

Poznámka: Pokud přejmenujete řez (slice), použije se nové jméno při exportování 
řezu.

Práce s vrstvami

Když vytvoříte novou vrstvu, je prázdná vrstva vložena před aktuálně zvolenou 
vrstvu. Nová vrstva se automaticky stane aktivní vrstvou a zvýrazní se na panelu 
Layers. Pokud vytvoříte duplikát vrstvy, přidá se do dokumentu nová vrstva, která 
obsahuje stejné objekty jako duplikovaná vrstva.. Duplikované objekty 
si zachovávají průhlednost i mód prolínání objektů, ze kterých byly zkopírovány. 
Na duplikovaných objektech můžete provést změny bez toho, že by to ovlivnilo 
originály. 

Každou vrstvu můžete nezávisle upravovat. To znamená, že můžete provádět 
změny objektů ve vrstvě, aniž byste ovlivnili objekty v jiných vrstvách. 

Přidání vrstvy:

Udělejte jedno z následujícího:

• V menu Options na panelu layers zvolte příkaz New Layer (nová vrstva). 
Pokud chcete, aby byly objekty ve vrstvě sdíleny ve všech snímcích dokumentu, 
zaškrtněte volbu Share across Frames. Klepněte na OK.

• Nemějte vybranou žádnou vrstvu a klepněte na tlačítko New/Duplicate Layer 
ve spodní části panelu Layers.

• V menu zvolte Insert > Layer.

Aktivace vrstvy:

Udělejte jedno z následujícího:

• Klepněte na jméno vrstvy na panelu Layer.

• Vyberte objekt z požadované vrstvy.
Objekty, které nakreslíte nebo vložíte ze schránky se umístí do aktuální vrstvy.
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Rozbalení nebo zabalení seznamu objektů ve vrstvě:

Klepněte na znaménko plus (Windows) nebo na trojúhelníček (Macintosh) vlevo 
od jména vrstvy na panelu Layers.

Pojmenování vrstvy:

1. Poklepejte dvakrát na jméno vrstvy na panelu Layers.
Otevře se okno se jménem vrstvy.

2. Do políčka Layer Name napište nové jméno vrstvy. Okno zavřete klepnutím 
mimo něj nebo stiskem klávesy Enter.

Poznámka: Můžete přejmenovat i objekty v jednotlivých vrstvách. Poklepejte 
dvakrát na vybraný objekt a zadejte jeho nové jméno.

Smazání vrstvy:

Vyberte vrstvu a klepnete na tlačítko Delete nebo vrstvu na tlačítko Delete 
přetáhněte.

Zobrazení nebo skrytí vrstvy nebo objektů ve vrstvě:

Klepněte na čtvereček v prostředním sloupci vlevo od jména vrstvy nebo objektu.

Ikonka oka indikuje, že je vrstva viditelná.

Zobrazení nebo skrytí všech vrstev a objektů:

Z menu Option panelu Layers vyberte příkaz Show All (zobrazit vše) nebo Hide 
All (skrýt vše).

Poznámka: Skryté vrstvy a objekty nejsou exportovány.

Uzamknutí vrstvy:

Klepněte na čtvereček ve sloupci hned vlevo od jména vrstvy.

Ikonka zámku indikuje, že je vrstva uzamknutá.
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Uzamknutí více vrstev:

Na panelu Layers zatáhněte myší přes sloupec s ikonkou zámku.

Uzamknutí nebo odemknutí všech vrstev:

V menu Options na panelu Layers zvolte příkaz Lock All (zamknout vše) nebo 
Unlock All (Odemknout vše).

Poznámka: zamčené objekty nejde editovat.

Sdílení vybraných vrstev mezi snímky:

Na panelu Layers vyberte v menu Options příkaz Share This Layer (sdílet tuto 
vrstvu).

Poznámka: Pokud je vrstva sdílena mezi všemi snímky a pokud v této vrstvě 
upravíte objekt, projeví se změny ve všech snímcích. To je užitečné v případě, 
kdy chcete aby se objekty (například prvky pozadí) objevovali ve všech snímcích 
animace.

Zapnutí nebo vypnutí módu editace jedné vrstvy:

V menu Options panelu Layers zvolte příkaz Single Layer Editing (editace jedné 
vrstvy). Zatržení vedle příkazu v menu indikuje, zda je tento mód aktivní nebo ne.

Přesun objektů na panelu Layers

Objekty můžete přesouvat v rámci vrstev nebo mezi vrstvami. Přesun objektu 
na panelu Layers změní pořadí vrstvení objektů v dokumentu. Pro přesun objektů 
v dokumentu můžete použít příkazy v menu Modify > Arrange, který mění pořadí 
objektů na panelu Layers. Objekty na vrchu vrstvy se zobrazují před objekty 
na spodku téže vrstvy.

Objekty jsou na panelu Layers zobrazovány ve formě miniaturních náhledů. Pokud 
objekt vyberete v dokumentu, zvýrazní se i na panelu Layers.

Chcete-li vidět seznam jednotlivých objektů ve vrstvě, klepněte na panelu Layers 
na znaménko plus (Windows) nebo na trojúhelníček (Macintosh) vlevo od jména 
vrstvy. Chcete-li rozbalit nebo sbalit všechny vrstva, klepněte na znaménko plus 
nebo mínus se stisknutou klávesou Alt (Windows) nebo na ikonku trojúhelníčku 
s klávesou Option (Macintosh).
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Přesun objektu do jiné vrstvy:

Přetáhněte objekt myší do požadované vrstvy.

Poznámka: Přetažením objektů v rámci vrstvy měníte jejich pořadí vrstvení ve 
vrstvě.

Kopírování vybraného objektu do jiné vrstvy:

Stiskněte klávesu Alt (Windows) nebo Options (Macintosh) a přetáhněte objekt do 
požadované vrstvy.

Přejmenování objektu:

1. Na panelu Layers poklepejte dvakrát na jméno objektu.

2. Zadejte nové jméno objektu a buď klepněte mimo textové pole nebo stiskněte 
klávesu Enter.
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Duplikování vrstev

Na panelu Layers můžete vytvářet i duplikáty vrstev a rozhodnout se, kam je 
umístíte. Duplikovaná vrstva obsahuje stejné objekty jako aktuálně vybraná vrstva. 
Duplikovaná vrstva má stejné jméno jako původní vrstva, pouze je k ním připojeno 
číslo.

Duplikování vrstvy:

1. Udělejte jedno z následujícího:

• Přetáhněte vrstvu na tlačítko New/Duplicate Layer.

• Vyberte vrstvu a klepněte v menu Options panelu Layers zvolte příkaz  
Duplicate Layer.

2. Pokud jste použili ten druhý způsob, zadejte kolik duplikátu chcete vložit a kam 
je zařadit v pořadí vrstvení.

Poznámka: Webová vrstva je vždy nejvrchnější vrstvou v dokumentu, takže i když 
v dialogovém okně vyberte volbu At the top (umístit nahoru), umístí se duplikáty 
pod webovou vrstvu.

Uspořádání vrstev

Přesouvání vrstev na panelu Layers mění pořadí, v jakém se objekty zobrazují 
v dokumentu. Nejvrchnější vrstva se objevuje v popředí všech ostatních vrstev. 
Objekty z nejvrchnější vrstvy se objevují v popředí všech objektů z nižších vrstev.

Přesunutí vrstvy:

Na panelu Layers vyberte vrstvu a přetáhněte ji nahoru nebo dolů v seznamu 
vrstev.
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Maskování obrázků

Masky jsou k obrázkům přidávány proto, aby vytvářely efekt oříznutí objektu. Pro 
maskování existujícího objektu může být použita prázdná maska nebo jiný objekt. 
Masky jsou plně editovatelné.

Jako maskovací objekt můžete použít buď bitmapový nebo vektorový objekt.

Masky mají dva hlavní způsoby použití:

• Cesta vektorové masky může vytvářet okraj jiného objektu nebo obrázku. 
Maskuje vespod ležící objekty nebo obrázky do své cesty.

• Pixely objektu masky mohou ovlivňovat viditelnost jiných objektů. 
Ve Photoshopu se tomuto říká maska vrstvy (layer mask). Masky se obvykle 
používají pro definici gradientní průhlednosti jiných objektů. 

Editací atributů obrysu a výplně objektu masky můžete vytvořit mnoho 
jedinečných efektů.

Obrázek a maskovací objekt

Vektorová maska
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Bitmapová maska

Vytváření bitmapových a vektorových masek

Masku objektu můžete vytvořit pomocí panelu Layers nebo pomocí menu Modify. 
Jako masku lze použít vektorový nebo bitmapový objekt. Masky mohou být 
tvořeny více než jedním objektem.

Vytvoření bitmapové masky od začátku:

1. Vyberte objekt, který chcete maskovat.

2. Ve spodní části panelu Layers klepněte na tlačítko Add Mask.

3. Pomocí bitmapových nástrojů na panelu Tools nakreslete masku,

Poznámka: Při tvorbě masky lze použít bitmapové nástroje, jako například Brush 
(štětec), Pencil (tužka), Rectangle (obdélník) a Ellipse (elipsa).

Vytvoření vektorové masky od začátku:

1. Vytvořte si cestu, textový objekty nebo jiné objekty, které chcete použít jako 
masku.

2. Objekt nebo objekty zkopírujte (Copy) nebo vyjměte (Cut) do schránky.
Více objektů vyberete klepáním se stisknutou klávesou Shift.

3. Vyberte objekt, který chcete maskovat.

4. Vložte masku:

• V menu zvolte Edit > Paste as Mask (vložit jako masku).

• V menu zvolte Modify > Mask > Paste as Mask.
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Vytváření masky pomocí existujícího objektu

Jako maska může být použit kterýkoliv objekt. To můžete provést pomocí příkazu 
Paste as Mask (vložit jako masku), který vytvoří masku z obsahu schránky. Masku 
můžete vytvořit i z více objektů.

Použití obsahu schránky jako masky:

1. Vytvořte objekt nebo objekty, které chcete použít jako masku.

2. Umístěte objekt nebo objekty do schránky: 

• V menu zvolte Edit > Cut (vyjmout).

• V menu zvolte Edit > Copy (zkopírovat).

3. Vyberte objekt, který chcete maskovat.

4. V menu zvolte Edit > Paste as Mask nebo Modify > Mask > Paste as Mask.
Pokud už maska existuje, můžete si vybrat, zda k ní chcete novou masku přidat 
(Add) nebo ji nahradit (Replace). Pokud budete k masce přidávat, vytvoříte tak 
masku z více objektů.

Přidání masky k obsahu schránky:

1. Vyberte objekt, který chcete maskovat.

2. V menu zvolte Edit > Cut.

3. Vyberte objekt, který chcete použít jako masku.

4. V menu zvolte Edit > Paste Inside.
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Seskupení objektů pro vytvoření masky

Můžete vybrat dva nebo více existujících objektů, seskupit je a vytvořit tak 
maskovaný objekt. Vrchní objekt ve skupině bude tvořit masku (maskovací 
objekt). Na panelu Layers si zkontrolujte, který objekt je ve skupině navrchu. Do 
maskovaného objektu mohou být seskupeny i objekty z různých vrstev. Maskou 
(maskovacím objektem) bude ten nejvrchnější objekt z nejvrchnější vrstvy. 

Objekty můžete seskupit buď jako bitmapovou nebo vektorovou masku. 
Výsledkem příkazu Group as Mask (seskupit jako masku) je bitmapová maska. 
Příkaz Group as Vector Mask (seskupit jako vektorovou masku) najdete v menu 
Edit > Keyboard Shortcuts v kategorii Miscellaneous, kde si pro něho můžete 
nastavit klávesovou zkratku. U toho příkazu jde o stejný princip, jako když 
použijete příkaz Group as Mask a potom na panelu Object zvolíte Path Outline. 

Seskupení objektů do maskovaného objektu:

1. Shift-klepněte na dva nebo více objektů.

2. V menu zvolte Modify > Mask > Group as Mask.

Používání textu jako masky

Text se běžně používá jako maska pro vytváření zajímavých efektů. Další efekty 
pak můžete k textu přidat, pokud na panelu Object aktivujete volbu Show Fill and 
Stroke (zobrazit výplň a obrys) – tím aktivujete efekty přidané na textovou masku 
pomocí panelů Fill a Stroke. Můžete se také vybrat, že masku aplikujete pomocí 
dalších voleb Path Outline nebo Grayscale Appearance na panelu Object. 

Vytvoření masky pomocí textu:

1. Pomocí dialogového okna Text Editor vytvořte text.

2. Textový objekt pomocí příkazů Cut nebo Copy zkopírujte nebo vyjměte 
do schránky.

3. Vyberte objekt, který chcete maskovat, a v menu zvolte Edit > Paste as Mask.
O objektu bude přidána vektorová maska.
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Vytváření prázdné masky

K objektu můžete přidat i prázdnou masku. Tato maska může být buď celá bílá 
(ta zobrazuje celý objekt) nebo celá černá (ta skrývá celý objekt). Prázdné masky 
jsou plně editovatelné.

Používání příkazů Reveal/Hide All

Příkaz Reveal All (odhalit vše) přidá k objektu prázdnou bílou masku. Příkaz Hide 
All (skrýt vše) přidá k objektu prázdnou černou masku.

Použití příkazů Reveal All a Hide All pro vytvoření masky:

1. Vyberte objekt, který chcete maskovat.

2. Vytvořte masku:

• V menu zvolte Modify > Mask > Reveal All (zobrazí celý objekt).

• V menu zvolte Modify > Mask > Hide All (skryje celý objekt).

3. Vyberte miniaturní náhled masky na panelu Layers.

4. Vyberte nástroj na panelu Tools a upravte masku.

Používání příkazů Reveal/Hide Selection

Příkazy Reveal Selection (odhalit výběr) a Hide Selection (skrýt výběr) mohou být 
použity na bitmapové objekty. Příkaz Reveal Selection přidá bílou masku v místech, 
kde je aktuální výběr. Ostatní pixely bitmapy jsou budou maskou skryti. Příkaz 
Hide Selection přidá černou masu v místech, kde je aktuální objekt. Tato část je 
tedy skryta, zobrazeny jsou ostatní části objektu.

Použití příkazů Reveal Selection a Hide Selection pro vytvoření masky:

1. Na panelu nástrojů Tools vyberte jeden z výběrových nástrojů (Marquee, Lasso, 
atd.).

2. Vyberte pixely v bitmapě:

• V menu zvolte Modify > Mask > Reveal Selection. Tím necháte zobrazenou 
pouze tu část definovanou výběrem.
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• V menu zvolte Modify > Mask > Hode Selection. Tím skryjete všechny oblasti 
definované výběrem.

Editace masek

Masky zůstávají i po vytvoření plně editovatelné. Masky můžete upravit, smazat 
nebo vypnout. Vypnutím masku dočasně odstraníte. Vypnutá maska může být 
později zase zapnuta a její efekt se projeví na objektu. 

Masky a objekty můžete jednoduše identifikovat a editovat pomocí jejich náhledů 
na panelu Layers. Pokud začnete editovat masku, objeví se vedle objektu na panelu 
Layers ikonka masky. Pokud začnete editovat objekt, objeví se ikonka tužky.

Velikost miniaturních náhledů na panelu Layers můžete změnit, abyste viděli 
jednotlivé detaily objektů a masek jasněji. V menu Options panelu Layers zvolte 
Thumbnail Options. Pokud chcete šetřit paměť, můžete náhledy úplně vypnout.

Editace masky:

1. Vyberte masku:

• Na panelu Layers klepněte na miniaturní náhled masky.

• V menu Options panelu Layers zvolte příkaz Edit Mask (editovat masku).

• Poklepejte dvakrát na přesouvací úchyt maskovaného objektu.

2. Proveďte na masce požadované změny:

• Na panelu Tools vyberte vhodný nástroj a proveďte změny.

• Přetáhněte přesouvací úchyt masky.

• Aplikujte na masku efekt.

Ačkoliv maska samotná není vidět, efekt její editace se při práci okamžitě projevuje. 
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Editace objektu bez ovlivnění masky:

1. Klepněte na miniaturní náhled objektu na panelu Layers.

2. Proveďte změny objektu.

Přesun objektu bez ovlivnění masky:

1. Na panelu Layers klepněte na ikonku vazby vedle miniatury masky.
To zruší vazbu mezi objektem a maskou, takže můžete s objektem pohybovat 
nezávisle na masce.

2. Přetáhněte objekt na požadované místo.

Převod vektorové masky na bitmapovou masku:

1. Na panelu Layers vyberte miniaturní náhled masky.

2. V menu zvolte Modify > Convert to Bitmap.

Poznámka: Nemůžete převést bitmapovou masku na vektorovou.

Ikonka vazby
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Vypnutí nebo zapnutí masky:

1. Vyberte maskovaný objekt.

2. Zapněte nebo vypněte masku:

• V menu Options panelu Layers zvolte příkaz Disable Mask (vypnout masku) 
nebo Enable Mask (zapnout masku).

• V menu zvolte Modify > Mask > Disable Mask nebo Enable Mask.

Pokud je maska vypnutá, objeví se u jejího náhledu červené X. Klepnutím na X 
masku opět zapnete.

Smazání masky:

1. Vyberte masku,

2. Smažte masku:

• V menu Options panelu Layers zvolte Delete Mask (smazat masku).

• V menu zvolte Modify > Mask > Delete Mask.

3. Vyberte, zda chcete ještě před smazáním masku aplikovat na objekt:

• Pokud zvolíte Apply (použít masku), projeví se efekt masky na objektu, ale 
samotná maska už není nadále editovatelná.

• Pokud zvolíte Discard (zrušit změny), zruší se veškeré projevy masky a objekt 
se obnoví do své původní podoby.
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Používání panelu Object při maskování

Na panelu Object se můžete ujistit, že skutečně editujete masku a identifikovat, 
o jaký typ masky se jedná. Když máte vybranou masku, můžete na panelu Object 
ovlivnit způsob, jakým je maska použita. 

Vektorová maska může být aplikována pomocí jejího tvaru cesty. Takto se jako 
maska použije tvar cesty nebo textu. Pokud chcete v maskovaném objektu zobrazit 
výplň a obrys masky, aktivujte volbu Show Fill and Stroke (zobrazit výplň 
a obrys).Oblast vně masky je z objektu odstřižena. Funguje to stejně jako příkaz 
Paste Inside (vložit dovnitř) ve FreeHandu.

U bitmapové masky můžete chtít objekt vymaskovat raději pomocí alfa kanálu 
masky než pomocí jasu jejích pixelů.

Vektorová i bitmapová maska můžete být aplikována pomocí volby Grayscale 
Appearance (vzhled podle šedé šály). Pokud je maska aplikována pomocí 
volby Grayscale Appearance, ovlivňuje jas pixelů masky, jak hodně je zobrazen 
maskovaný objekt. Světlé pixely zobrazují maskovaný objekt a naopak v oblasti 
tmavých pixelů se maskovaný objekt ztrácí a je vidět pozadí.

Prolínání barev výplní překrývajících se objektů

Kompozice je proces, při kterém se používají módy prolínání pro změnu 
průhlednosti nebo barevné interakce dvou nebo více překrývajících se objektů. 
Módy prolínání (blending modes) zpracovávají barevné hodnoty překrývajících 
se objektů. Přidávají také další úroveň kontroly na efektem průhlednosti.

O módech prolínání:

Pokud vyberete mód prolínání (blending mode), aplikuje se na celý vzhled 
vybraného objektu. Objekty v rámci jednoho dokumentu nebo jedné vrstvy mohou 
mít módy prolínání odlišné od ostatních objektů v dokumentu nebo ve vrstvě.

Pokud jsou do skupiny seskupeny objekty s různými módy prolínání, přebije 
jednotlivé módy mód prolínání skupiny. Pokud skupiny rozdělíte opět 
na samostatné objekty, obnoví se jejich jednotlivé módy prolínání.



221  Kapitola 11

Mód prolínání obsahuje tyto prvky:

• Prolínaná barva (blend color) je barva, na kterou je aplikován mód prolínání.

• Průhlednost (opacity) představuje stupeň průhlednosti, se kterou je prolínání 
aplikováno.

• Základní barva (base color) je barva pixelů ležících pod prolínanou barvou.

• Výsledná barva (result color) je výsledek prolnutí prolínané barva na základní 
barvu.

Základní barva

Prolínaná barva

Výsledná barva

Ve Fireworks můžete použít tyto módy prolínání:

Normal neaplikuje žádný druh prolínání.

Multiply vynásobí základní barvu prolínanou barvou, výsledkem jsou tmavší barvy.

Screen vynásobí inverzi prolínané barvy základní barvou, výsledkem je bělící efekt.

Darken vybere tmavší barvu z prolínané a základní barvy a tu použije jako 
výsledek. Tímto způsobem se nahradí jen ty pixely, které jsou světlejší než 
prolínaná barva.

Lighten vybere světlejší z obou barev a použije jako výsledek. Nahradí se tedy 
pouze pixely s tmavší barvou, než je prolínaná barva.

Difference odečte prolínanou barvu od základní barvy nebo základní barvu od 
prolínané barvy. Barva s nižším jasem je odečtena od barvy s vyšším jasem.

Hue kombinuje odstín prolínané barvy se světlostí a sytostí základní barvy.

Saturation kombinuje sytost prolínané barvy se světlostí a odstínem základní barvy.
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Color kombinuje odstín a sytost prolínané barvy se světlostí základní barvy. 
Výsledkem je, že se zachovávají úrovně šedé pro kolorování černobílých obrázků 
a tónování barevných obrázků.

Luminosity kombinuje světlost prolínané barvy s odstínem a sytostí základní barvy.

Invert invertuje základní barvu.

Tint přidává do základní barvy šedou.

Erase odstraňuje všechny barevné pixely základu, včetně těch v obrázku pozadí.
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Příklady módů prolínání

Módy prolínání se ve vektorovém a bitmapovém módu chovají odlišně. 

• Ve vektorovém módy ovlivní mód prolínání vybraný objekt.

• V bitmapovém módu ovlivní mód prolínání plovoucí výběr pixelů.

• V bitmapovém módu bez plovoucího výběru ovlivní mód prolínání štětce 
a výplně následně nakreslených objektů.

Původní obrázek Normal Multiply

Screen Darken Lighten

Difference Hue Saturation

Color Luminosity Invert

Tint Erase
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Úprava průhlednosti a nastavení módu prolínání

Průhlednost vybraných objektů a módy prolínání nastavíte na panelu Layers. 
Nastavení na hodnotu 100 zobrazí objekt úplně neprůhledný. Nastavení na 
0 zobrazí objekt úplně průhledný.

Výběr módu prolínání

Nastavení průhlednosti

Na panelu Layers můžete nastavit průhlednost a vybrat mód prolínání

Nastavení módu prolínání u existujících objektů:

1. Ze dvou překrývajících se objektů vyberte ten vrchní.

2. Na panelu Layers vyberte v roletce Blending Mode požadovaný mód prolínání.

Nastavení výchozího módu prolínání, který se na objekty aplikuje 
při jejich kreslení:

1. V menu zvolte Edit > Deselect, abyste zabránili nechtěné aplikaci módu 
prolínání na existující objekt.

2. Na panelu Layers vyberte mód prolínání, který se bude používat jako výchozí.
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Použití živého efektu Fill Color

Fill Color (barva výplně) je živý efekt, který vám umožní upravit barvu objektu 
pozměněním průhlednosti objektu a módu prolínání. Tento efekt nabízí 
stejný výsledek, jaký byste dostali při překrytí objektu jiným objektem se jinou 
průhledností a módem prolínání. 

Efekt Fill Color je úplně kompatibilní s vrstevným efektem Color Fill 
z Photoshopu. Pokud budete chtít, můžete do Fireworks kdykoliv importovat 
grafiku s tímto efektem, nebo ji naopak exportovat do Photoshopu.

Použití živého efektu Color Fill na objekt:

1. Vyberte objekt, na který chcete aplikovat barvu.

2. Na panelu Effect vyberte v roletce v podmenu Adjust Color položku Color Fill.

3. Nastavte barvu, mód prolínání a průhlednost.

Spolupráce s Photoshopem

Maskované objekty můžete exportovat do Photoshopu. Budou převedeny na 
masky vrstev. Masky (včetně textu) zůstávají editovatelné. Pokud chcete zachovat 
naprostou editovatelnost, použijte při exportu volbu Maintain Editability over 
Appearance (zachovat editovatelnost spíše než vzhled).

Import masek vrstev z Photoshopu

Ve Photoshopu můžete obrázky maskovat pomocí masek vrstvy nebo pomocí 
seskupených vrstev. Fireworks vám umožňuje importovat obrázky s maskami 
vrstev bez ztráty schopnosti masky upravovat. Masky vrstev jsou importovány jak 
bitmapové masky.

Import seskupených vrstev z Photoshopu

Při importu souboru z Photoshopu obsahujícího vrstvy je každá vrstva umístěna 
jako samostatný objekt do jediné vrstvy ve Fireworks. Seskupené vrstvy jsou 
naimportovány jako samostatné vrstvy. Ořezový efekt seskupených vrstev 
Photoshopu je při importu ztracen.
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Používání knihoven, stylů a URL

Tato kapitola se zabývá popisem tří panelů, na kterých si můžete uložit o potom 
znovu použít symboly, styly a URL.  Symboly jsou uloženy na panelu Library 
(knihovna). Nápodobně styly jsou uloženy na panelu Styles (styly) a URL na panelu 
URL.

Panel Styles obsahuje sadu předdefinovaných stylů Fireworks, ze kterých si můžete 
vybrat a které můžete použít. Pokud se vám libí, jak jste použili vlastní obrysy, 
výplně a další atributu na vašem objektu, můžete si tyto atributy uložit jako nový 
styl. Místo toho, abyste stejné atributy museli nastavovat pokaždé znovu, můžete 
je jednoduše uložit na panel Styles a potom stejnou kombinaci atributu používat 
na jiné objekty.

Symboly jsou uloženy na panelu Library. Ve Fireworks existují tři různé druhy 
symbolů: tlačítka (buttons), grafické symboly (graphics) a animace (animations). 
Můžete vytvářet nové symboly, duplikovat je, importovat existující symboly nebo 
je upravovat.

URL (Uniform Resource Locator) jsou uložena na panelu URL. URL představuje 
adresu určité stránky nebo souboru na internetu. Pokud používáte mnohokrát 
stejné URL, můžete si ho uložit na panel URL. URL můžete řadit a seskupovat 
do URL knihoven.

KAPITOLA 12

12



O stylech

Vytvořením stylu můžete uložit sadu předdefinovaných atributů výplně, obrysu, 
efektů nebo textu, kterou pak můžete znovu použít. Styly ve Fireworks fungují 
spíše jako namíchané barvy na malířově paletě, než jako styly v textovém editoru. 
Pokud styl aplikujete na objekt, převezme objekt veškeré charakteristiky definované 
uvnitř stylu.

Fireworks obsahuje mnoho předdefinovaných stylů. Styly můžete přidávat, měnit 
a mazat. Na instalačním CD Fireworks a na webové stránce firmy Macromedia 
můžete nalézt mnoho dalších předdefinovaných stylů, které můžete naimportovat 
do Fireworks. Styly můžete také exportovat a sdílet je s ostatními uživateli 
Fireworks, nebo můžete naimportovat styly z jiných dokumentů Fireworks. 
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Používání stylů

Pro ukládání a aplikování stylů na objekty nebo text se používá panel Style. Panel 
Styles otevřete pomocí příkazu menu Window > Styles.

Panel Styles

Pokud styl použijete na objekt, můžete styl později upravit bez toho, že byste 
ovlivnili původní objekt. Fireworks nesleduje, jaký styl jste na objekt aplikovali. 
Pokud styl smažete, nemůžete ho obnovit. Pokud smažete styl dodávaný 
s Fireworks, můžete ho (a další smazané styly dodané s Fireworks) obnovit 
příkazem Reset Styles (vynulovat styly) z menu Options panelu Styles. Vynulování 
stylů však zároveň smaže i vaše uživatelské nadefinované styly.
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Použití stylu na vybraný objekt nebo textový blok:

Klepněte na požadovaný styl na panelu Styles.

Vytvoření nového stylu:

1. Vytvořte objekt nebo text s požadovaným nastavením obrysu, výplně, efektů 
nebo nastavení textových vlastností.

2. Ve spodní části panelu Styles klepněte na tlačítko New Style (nový styl).

3. Zvolte vlastnosti, které chce, aby byly součástí stylu. Styl pojmenujte a klepněte 
na OK.
Na panelu Styles se objeví ikonka zobrazující uložený styl.

Editace stylu:

1. V menu zvolte Edit > Deselect.

2. Na panelu Styles dvakrát poklepejte dvakrát na styl.

3. V dialogovém okně Edit Style aktivujte nebo deaktivujte komponenty stylu, 
které chcete aplikovat, a potom klepněte na OK.

Založení nového stylu na základě existujícího:

1. Aplikujte existující styl na vybraný objekt.

2. Upravte atributy objektu.

3. Uložte atributy jako nový styl.

Smazání stylu:

1. Vyberte styl na panelu Styles.
Chcete-li vybrat ke smazání více stylů najednou, držte při vybírání stylů klávesu 
Shift.

2. Na panelu Styles klepněte na tlačítko Delete Styles (smazat styly).
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Export stylů:

1. Na panelu Styles vyberte jeden nebo více stylů.
Chcete-li vybrat více stylů najednou, držte při vybírání klávesu Shift.

2. V menu Options panelu Styles zvolte příkaz Export Styles (exportovat styly).

3. Zadejte jméno a umístění ukládaného soubory se styly.

4. Klepněte na Save.

Import stylů:

1. V menu Options panelu Styles zvolte příkaz Import Styles (importovat styly).

2. Vyberte soubor se styly, které chcete naimportovat.
Všechny styly z tohoto dokumentu se naimportují a umístí přímo pod styl 
vybraný na panelu Styles.

Vynulování panelu Styles na výchozí styly:

V menu Options panelu Styles zvolte příkaz Reset Styles (vynulovat styly).

Poznámka: Pokud styly vynulujete do výchozího nastavení, přepíše to vaše 
uživatelské styly, které jste si mohli na panel uložit.

Změna velikosti ikon s náhledem stylů:

V menu Options panelu Styles zvolte příkaz Large Icon (velké ikony). Tímto 
příkazem přepínáte mezi zobrazením malých a velkých náhledů stylů.
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O symbolech a instancích

Symbol představuje objekt, textový blok nebo skupinu a může být buď grafikou, 
animací nebo tlačítkem. Instance jsou představitelé původního objektu z Fireworks. 
Pokud je objekt symbolu (originál) upraven, změní se automaticky všechny instance 
(kopie) tak, aby odrážely provedenou změnu.

Symboly jsou užitečné v případě, že potřebujete opětovně používat grafiku mezi 
dokumenty. Symboly jsou také potřebné pro tvorbu tlačítek a animovaných 
dokumentů napříč několika snímky dokumentu.  

Symboly a instance můžete používat pro jednoduché změny kopií stejného objektu, 
pro sdílení komponent mezi jednotlivými stavy rollover efektů a pro tvorbu 
animací.

Používání knihovny symbolů

Symboly vytváříte a ukládáte na panelu Library. Panel Library uchovává grafické, 
tlačítkové i animační symboly. Symbol můžete vytvořit z objektu, textového bloku 
nebo skupiny. Symboly mohou obsahovat další symboly.

Vytvoření nového symbolu:

1. Udělejte jedno z následujícího:

• Chcete-li vytvořit nový symbol od začátku, vyberte v menu příkaz Insert 
> Symbol nebo v menu Options panelu Library příkaz New Symbol (nový 
symbol).

• Chcete-li vytvořit symbol z existujícího objektu, vyberte objekt a v menu zvolte 
Insert > Convert to Symbol (převést na symbol).

2. Do textového pole Name v dialogovém okně Symbol Properties zadejte jméno 
symbolu.

3. Vyberte typ symbolu – Graphic (grafický symbol), Animation (animace) nebo 
Button (tlačítko). Klepněte na OK.
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4. Pokud vytváříte nový symbol od začátku, otevře se Symbol Editor (editor 
symbolů) nebo Button Editor (editor tlačítek). Nakreslete objekt, který bude 
tvořit symbol, a editor zavřete.

Symbol se objeví na panelu Library a v dokumentu.

Umisťování instancí

Do aktuálního dokumentu můžete přidat více instancí symbolu.

Instanci do dokumentu umístíte přetažením symbolu z panelu Library na plochu 
aktuálního dokumentu.

Ikonka šipky představuje instanci symbolu

Změna symbolů

Symbol můžete modifikovat v editoru symbolů (Symbol Editor) a automaticky tak 
upravit všechny jeho instance. 

Poznámka: Úprava instance ovlivní i samotný symbol a všechny jeho instance. 

Změna symbolu:

1. Otevřete editor symbolů:

• Poklepejte dvakrát na instanci.

• Poklepejte dvakrát na symbol objektu na panelu Library.

2. Proveďte na symbolu požadované změny a zavřete okno.
Symbol a všechny jeho instance budou nyní odrážet provedené změny.
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Přejmenování symbolu:

1. Poklepejte dvakrát na jméno symbolu na panelu Library.

2. V dialogovém okně Symbol Properties (vlastnosti symbolu) změňte jméno 
a klepněte na OK.

Duplikování symbolu:

1. Vyberte symbol na panelu Library.

2. Z menu Options zvolte příkaz Duplicate (duplikovat).

Smazání symbolu:

1. Vyberte symbol na panelu Library.

2. Z menu Options zvolte příkaz Delete (smazat).

3. Pokud se symbol používá, klepněte ještě jednou na Delete. Smaže se symbol 
a všechny jeho instance.

Výběr všech symbolů v knihovně, které se nepoužívají v aktuálním
dokumentu:

Z menu Options panelu Library zvolte příkaz Select Unused Items (vybrat 
nepoužité položky).
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Přerušení vazby mezi instancí a symbolem

Pokud upravíte instance, projeví se změna na symbolu a na všech ostatních 
instancích. Můžete však upravit samotnou instanci bez ovlivnění symbolu a dalších 
instancí, ale musíte nejprve přerušit vazbu mezi instancí a symbolem.

Uvolnění instance od jejího symbolu:

1. Vyberte instanci.

2. V menu zvolte Modify > Symbol > Break Apart (oddělit).
Instance se přemění na skupinu. Symbol v knihovně již není nadále s touto 
skupinou nijak spojen. Tlačítkové symboly přestanou fungovat jako tlačítka 
a animační symboly přestanou fungovat jako animace.

Poznámka: Chcete-li uvolněnou instanci editovat jako objekt, vyberte ji a v menu 
zvolte Modify > Ungroup.

Používání symbolů z jiných knihoven

Symboly můžete exportovat pro použití v jiných dokumentech ve Fireworks 
a nebo je můžete z jiných dokumentů naimportovat.

Pokud změníte symbol v původním dokumentu, můžete tyto změny aktualizovat 
i v jiných dokumentech, do kterých byl tento symbol naimportován.

Předpokládejme například, že jste vytvořili symbol loga vaší firma ve vzorovém 
souboru. Potom tento symbol naimportujete do ostatních dokumentů. Pokud 
se logo změní, můžete ho upravit ve vzorovém souboru a aktualizovat všechny 
soubory, do kterých jste ho importovali.

Pokud symbol v aktuálním dokumentu upravíte, automaticky přerušíte vazbu 
mezi naimportovaným symbolem a původním dokumentem. Přerušení vazby vám 
umožní upravovat importovaný symbol nezávisle na originálu.
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Export symbolů:

1. Z menu Options panelu Library zvolte příkaz Export Symbols (exportovat 
symboly).

2. Vyberte symboly, které chcete exportovat, a klepněte na Export.

3. Zadejte jméno a umístění souboru pro symboly a klepněte na Save.
Fireworks uloží symboly do jednoho PNG souboru.

Importování symbolů přetažením myší nebo zkopírováním 
a vložením ze schránky:

• Přetáhněte symbol do aktuálního dokumentu.

• Vložte (Paste) symbol do aktuálního dokumentu.

Import symbolů pomocí panelu Library:

1. V menu Options panelu Library zvolte příkaz Import Symbols (importovat 
symboly).

2. Vyberte soubor obsahující symboly a klepněte na Open.

3. Vyberte symboly, které chcete naimportovat, a klepněte na Import.

Importované symboly se objeví na panelu Library. Vedle typu symbolu budou 
mít text „(imported).“
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Aktualizace symbolu importovaného z jiného dokumentu:

1. Upravte symbol v původním dokumentu a soubor uložte.

2. V dokumentu, kam byl symbol naimportován, vyberte symbol na panelu 
Library.

3. V menu Options panelu Library zvolte příkaz update (aktualizovat).

Poznámka: Chcete-li aktualizovat všechny importované symboly, vyberte všechny 
symboly na panelu Library a zvolte příkaz Update.

O panelu URL

Pokud nějakému webovému objektu přiřadíte URL, vytvoří se odkaz na soubor. 
Tento soubor může být například webová stránka. URL můžete přiřadit 
hotspotům, tlačítkům a řezům. Pokud hodláte stejné URL použít několikrát, 
vytvořte si na panelu URL knihovnu URL a uložte odkaz do této knihovny. 
Pro přidávání, editaci a organizaci URL slouží panel URL.

Pokud například vaše webová stránka obsahuje několik navigačních tlačítek pro 
návrat na domovskou stránku, přidejte URL domovské stránky na panel URL. 
Potom toto URL přiřaďte každému tlačítku prostě jen tím, že ho vyberete v URL 
knihovně. Pro změnu URL napříč mnoha dokumenty použijte příkaz Find and 
Replace (najít a nahradit).

URL knihovny jsou dostupné ve všech dokumentech Fireworks a jsou ukládány 
i mezi jednotlivými sezeními.

Panel URL
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Práce s URL

URL můžete seskupovat dohromady do knihoven. Tím udržujete související URL 
pohromadě a snadněji přístupné. URL můžete ukládat do výchozí URL knihovny 
(URLs.htm) nebo do nových URL knihoven, které si vytvoříte. URL jsou uložena 
v HTML souboru s odkazy v adresáři Fireworks 4\Settings\URL Libraries. Jména 
zde uložených souborů se objevují na panelu URL.

Vytvoření nové URL knihovny:

1. V menu Options panelu URL zvolte příkaz New URL Library (nová URL 
knihovna).

2. Do textového pole zadejte jméno knihovny a klepněte na OK.
Jméno nové knihovny se objeví na panelu URL v roletce Library.

Přidání nového URL do URL knihovny:

1. V roletce Library zvolte knihovnu.

2. Do textového pole Link zadejte URL.

3. Klepněte na symbol plus (+).

Symbol plus přidá aktuální URL do knihovny.

URL můžete organizovat dokonce tak, že do knihovny přidáte pouze ta, která jsou 
obsažena v aktuálním dokumentu. 

Přidání použitých URL do URL knihovny:

1. V roletce Library vyberte knihovnu.

2. V menu Options panelu URL zvolte příkaz Add Used URLs to Library (přidat 
použitá URL do knihovny).
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Přiřazení URL webovému objektu:

1. Vyberte objekt.

2. Zadejte URL:

• V menu Options panelu URL zvolte příkaz Add URL (přidat URL). Zadejte 
absolutní nebo relativní URL a klepněte na OK.

• Zadejte URL do textového pole Link na panelu URL a klepněte na znaménko 
plus (+).
URL se objeví v seznamu.

Editace URL:

1. Ze seznamu vyberte URL, které chcete upravit.

2. V menu Options panelu URL zvolte příkaz Edit URL (editovat URL).

3. Upravte URL. Pokud chcete tento odkaz aktualizovat v celém dokumentu, 
zvolte Change All Occurrences in Document (změnit všechny výskyty 
v dokumentu).

4. Klepněte na OK.

Smazání vybraného URL ze seznamu:

Ve spodní části panelu URL klepněte na tlačítko Delete URL from library (smazat 
URL z knihovny).

Smazání nepoužitých URL z knihovny:

V menu Options panelu URL zvolte příkaz Clear Unused URLs (smazat nepoužitá 
URL).

Importování URL:

1. V menu Options panelu URL zvolte příkaz Import URLs (importovat URL).

2. Vyberte HTML soubor a klepněte na Open.
Naimportují se všechna URL obsažená v dokumentu.
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Export URL:

1. Na panelu URL vyberte URL, která mají být exportována.

2. V menu Options panelu zvolte příkaz Export URLs.

3. Zadejte nové jméno souboru a klepněte na Save.
Vytvoří se soubor s odkazy. Tento soubor obsahuje všechna vybraná URL.

Zadávání absolutních nebo relativních URL

Při zadávání URL na panelu URL můžete zadat buď absolutní nebo relativní URL:

• Pokud se odkazujete na stránku mimo vaše webové sídlo, musíte zadat 
absolutní URL.

• Pokud se odkazujete na stránku uvnitř vašeho webu, můžete použít absolutní 
nebo relativní URL.

Absolutní URL jsou kompletní URL obsahující serverový protokol, což je pro 
webové stránky obvykle http://. Například http://www.macromedia.com/
support/fireworks je absolutní URL na webovou stránku technické podpory 
Fireworks. Absolutní URL zůstávají správná nezávisle na umístění zdrojového 
dokumentu, neodkazují se ale správně v případě, že je přesunut cílový dokument.

Relativní URL jsou relativní k adresáři obsahujícím zdrojový dokument.  
Následující příklady ukazují syntaxi relativních URL:

• soubor.htm odkazuje ne soubor ve stejném adresáři jako je zdrojový dokument.

• ../../soubor.htm odkazuje na soubor umístěný v adresáři o dvě úrovně nad 
adresářem se zdrojovým dokumentem. Každé ../ představuje jednu úroveň 
nahoru.

• htmldocs/soubor.htm odkazuje na soubor umístěný v adresáři htmldocs, který 
se nachází v adresáři se zdrojovým dokumentem.

Relativní URL jsou obvykle tou nejjednodušší cestou při odkazování se na soubory, 
které vždy zůstanou ve stejném adresáři jako aktuální dokument.

http://www.macromedia.com/support/fireworks
http://www.macromedia.com/support/fireworks
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Vytváření tlačítek a navigačních pruhů

Ve Fireworks můžete vytvářet množství javascriptových tlačítek, a to dokonce 
i v případě, že o JavaScriptu nic nevíte. Editor tlačítek (Button Editor) ve Fireworks 
vás provede procesem vytváření tlačítka a zautomatizuje mnoho částí tvorby 
tlačítka. Výsledkem je symbol tlačítka, který můžete umísťovat a transformovat 
jako jeden objekt. Tlačítko můžete rychle replikovat a vytvořit tak navigační pruh, 
ve kterém můžete jednoduše upravíte text v jednotlivých snímcích tlačítek.

Tlačítko je ovládáno JavaScriptem, který běží na pozadí. Pokud tlačítko exportujete, 
Fireworks automaticky vytvoří JavaScript potřebný pro zobrazení tlačítka 
ve webovém prohlížeči. V Macromedia Dreamweaveru můžete JavaScript a HTML 
kód z Fireworks jednoduše vložit do webové stránky. Kód můžete samozřejmě 
zkopírovat do jakéhokoliv HTML souboru.

Navigační pruh je skupina tlačítek, které typicky zůstávají (nebo vypadají, 
že zůstávají) na stránce, i když se ostatní části stránky mění.

Tlačítka

Ve Fireworks je tlačítko typ rolloveru (rollover = obrázek, který mění vzhled podle 
různých akcí myši), který zahrnuje až čtyři různé stavy. Každý stav představuje 
vzhled tlačítka odpovídající určité akci myši:

• Stav Up je výchozí klidový stav tlačítka.

• Stav Over představuje vzhled tlačítka ve webovém prohlížeči ve chvíli, kdy je 
kurzor myši nad tlačítkem.

• Stav Down představuje stav tlačítka při klepnutí myší na něj. 

• Stav Over While Down zobrazuje vzhled tlačítka v případě, že se myš ve stavu 
Down (stisknuté tlačítko myši)  pohybuje přes tlačítko.

KAPITOLA 13

13
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Nové tlačítko můžete vytvořit úplně od začátku nebo můžete na tlačítko převést 
existující objekt. Editor tlačítek vám umožní editovat všechny čtyři stavy, včetně 
aktivní oblasti, která aktivuje tlačítko (řez, který editor tlačítek automaticky vytvoří).

Mnoho tlačítek na webu má pouze dva stavy – Up a Over. Stav Over je užitečný, 
protože upozorňuje uživatele, že klepnutí myší v tomto místě pravděpodobně 
povede k nějaké akci. Stavy Up a Down představují stavy klidu, zatímco stav Over 
While Down varuje uživatele, že klepnutí myší pravděpodobně nebude mít žádný 
další efekt.

Tlačítko vytvořené v Button Editoru je více než javascriptový rollover:

• Tlačítko je speciální typ symbolu. Jeho instance můžete přetahovat z knihovny 
do dokumentu. 

• Tlačítko je zapouzdřené. Přetáhnutím tlačítka v dokumentu přetahujete všechny 
jeho části a stavy k němu připojené. Nejsou potřeba žádné komplikované 
vícesnímkové úpravy.

• Tlačítko se jednoduše upravuje. Dvakrát na něho poklepejte a změní 
se na editor tlačítek (Button Editor).

• Vybrané tlačítko má na panelu Object pohodlné textové pole, ve kterém můžete 
aktualizovat text tlačítka ve všech stavech najednou.

• Stejně jako ostatní symboly má tlačítko registrační značku. Registrační značka 
je středový bod, který vám pomáhá zarovnávat text v různých stave tlačítka.

Vytváření tlačítek

Nejjednodušším způsobem, jak vytvořit javascriptové tlačítko nebo navigační pruh, 
je použít Button Editor. Tipy na každém panelu editoru tlačítek vám pomáhají 
provádět potřebná rozhodnutí. Editor tlačítek vám umožní nakreslit všechny čtyři 
stavy tlačítka a přiřadit k tlačítku URL.
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Tlačítka mohou být vytvořena na jakékoliv vrstvě popředí ve snímku 1. Pokud 
navrhujete zvláštně tvarovaná tlačítka, uvědomte si, že Fireworks používá pouze 
pozadí snímku 1 bez ohledu na pozadí nastavené v jiných snímcích.

Editor tlačítek (Button Editor)

Vytváření tlačítka

Tlačítko můžete vytvořit v Button Editoru (editoru tlačítek). Pokud je vaše tlačítko 
součástí navigačního pruhu, budete možná potřebovat použít všechny jeho stavy. 
Pokud se však tlačítko vyskytuje pouze na jedné stránce, budete pravděpodobně 
potřebovat pouze stavy Up a  Over.

Poznámka: Pokud vytvoříte nebo vložíte tlačítko, Fireworks ho automaticky umístí 
do snímku 1. Tlačítka fungují správně pouze ve snímku 1. Pokud tlačítko přesunete 
do jiného snímku, nebude fungovat správně.
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Vytvoření tlačítka:

1. V menu zvolte Insert > New Button (nové tlačítko). Otevře se Button Editor 
(editor tlačítek).
Button Editor se otevře na záložce stavu Up.

2. Na pracovní plochu editoru tlačítek umístěte grafiku, která se objeví ve stavu 
Up tlačítka:

• Použijte kreslící a editační nástroje vy vytvořte grafiku.

• Do editoru tlačítek naimportujte nebo přetáhněte existující grafiku.

3. Pokud chcete, aby se na tlačítku zobrazoval text, použijte nástroj Text.

Poznámka: Je vhodné nastavit u textu zarovnávání na střed, protože pokud 
budete později potřebovat text na tlačítku upravit, zachová si svoji pozici ve středu 
tlačítka.

4. Klepněte na záložku Over.

5. Zaškrtněte tlačítko Onion Skinning (průhled), abyste mohli vizuálně zarovnat 
grafiku v každém stavu tlačítka.

6. Umístěte grafiku do stavu Over tlačítka:

• Chcete-li do stavu Over zkopírovat grafiku ze stavu Up, klepněte na Copy Up 
Graphic (zkopírovat grafiku stavu Up). Pak můžete změnit vzhled grafiky. 

• Vytvořte novou grafiku specifickou pro stav Over.

• Do okna Over naimportujte grafiku odjinud.
Pokud chcete, aby se na tlačítku zobrazoval text, použijte nástroj Text.

Přidání stavu Down

Ve webovém prohlížeči se stav Down objeví v případě, že tlačítko, na které jste 
klepli, zůstane na stránce viditelné. Stav Down se často používá u navigačních 
pruhů. Mnoho tlačítek existuje pouze na jedné stránce a nepotřebuje proto stavy 
Down a Over While Down.
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Přidání stavu Down k tlačítku:

1. V editoru tlačítek klepněte na záložku Down.

2. Do editoru umístěte grafiku stavu Down:

• Chcete-li do stavu Down zkopírovat grafiku ze stavu Up, klepněte na Copy Up 
Graphic (zkopírovat grafiku stavu Up). Pak můžete změnit vzhled grafiky. 

• Vytvořte novou grafiku specifickou pro stav Down.

• Do okna Down naimportujte grafiku odjinud.
Pokud chcete, aby se na tlačítku zobrazoval text, použijte nástroj Text.

3. Volitelně můžete zaškrtnout volbu Show Down State Upon Load (zobrazit stav 
Down po načtení), pokud chcete, aby se stav Down zobrazil okamžitě 
po načtení webové stránky.

Přidání stavu Over While Down

Stav Over While Down se objeví ve chvíli, kdy se kurzor pohybuje nad tlačítkem 
ve stavu Down. Stejně jako stav Down se tento stav používá hlavně u navigačních 
pruhů.

Přidání stavu Over While Down ke tlačítku:

1. V editoru tlačítek klepněte na záložku Over While Down.

2. Do editoru umístěte grafiku pro tento stav:

• Chcete-li do stavu Over While Down zkopírovat grafiku ze stavu Up, klepněte 
na Copy Up Graphic (zkopírovat grafiku stavu Up). Pak můžete změnit vzhled 
grafiky. 

• Vytvořte novou grafiku specifickou pro stav Over While Down.

• Do okna Over While Down naimportujte grafiku odjinud.
Pokud chcete, aby se na tlačítku zobrazoval text, použijte nástroj Text.
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Připojení URL k tlačítku

Chcete-li, aby se tlačítko odkazovalo na jinou webovou stránku, jiné webové 
sídlo nebo na kotvu na současné webové stránce, přiřaďte k tlačítku URL. Pro 
vložení URL tlačítka použijte Link Wizard (průvodce vložením odkazu). Můžete 
také zadat alternativní text, který se zobrazí, když kurzor najede na tlačítko, a také 
zprávu do stavového řádku prohlížeče. Link Wizard vám také umožní upravit 
nastavení exportu tlačítka a konvenci pojmenování. Více informací o konvencích 
pojmenovávání najdete v části „Automaticky pojmenovávané řezy“ na straně 264.

Připojení URL k tlačítku pomocí průvodce odkazem:

1. V editoru tlačítek klepněte na záložku Active Area (aktivní oblast).
Objeví se aktivní oblast obsahující jeden řez.

Poznámka: Editor tlačítek standardně vytváří řez automaticky. Pokud je zaškrtnutá 
volba Set Active Area Automatically (nastavit aktivní oblast automaticky), mění se 
velikost řezu tak, aby řez pokryl veškerou grafiku uvnitř tlačítka.

2. Klepnutím na tlačítko Link Wizard připojte k vytvářenému tlačítku URL.

3. Klepněte na záložku Link a do prvního políčka zadejte URL adresu. 
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4. Pokud chcete, zadejte do zbývajících polí alternativní text a text pro stavový 
řádek prohlížeče.

5. Pokud chcete, aby URL zacílilo do určitého rámce (frame) nebo okna, klepněte 
na záložku Target a vyberte požadovaný cíl ze seznamu nebo ho zadejte ručně.

6. Klepněte na OK.

Když zavřete editor tlačítek, objeví se tlačítko na panelu Library a jeho instance 
v dokumentu. Pokud tlačítko přesunete nebo zvětšíte jako jednotku, budou 
zároveň s ním přesunuty nebo zvětšeny všechny jeho stavy i aktivní oblast.

Umístění dalších kopií tlačítka do dokumentu:

Přetáhněte tlačítko z knihovny do dokumentu.

Alternativně můžete přetáhnout existující instancí se stisknutou klávesou Alt 
(Windows) nebo Option (Macintosh) a vytvořit tak novou instanci.

Změna tlačítka

Symbol tlačítka můžete editovat i po jeho vytvoření. Pokud upravíte symbol 
tlačítka, promítne se změna do všech instancí. 

Pokud jste tlačítko naimportovali z knihovny nebo jiného dokumentu Fireworks, 
přeruší editace tlačítka v aktuální dokumentu vazbu na předchozí dokument. 
Jinými slovy – provedené změny neovlivní originál.

Editace existujícího symbolu tlačítka:

1. Dvojitým poklepáním na tlačítko otevřete Button Editor. 

2. Klepněte na záložku libovolného stavu tlačítka-

3. Vyberte objekt a upravte ho stejně, jako by se jednalo o objekt v dokumentu.
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Nakreslení a úprava aktivní oblasti

Aktivní oblast tlačítka je to, co spouští rollover efekt při najetí myši nad tlačítko 
ve webovém prohlížeči. 

Pokud je zapnuta volba Set Active Area Automatically (nastavit aktivní oblast 
automaticky), Fireworks automaticky vytvoří tak velký řez, aby obsáhl všechny 
stavy zapouzdřené v tlačítku. Pokud potřebujete aktivní oblast jiné velikosti nebo 
tvaru, můžete patřičným způsobem upravit řez. Pokud změníte velikost řezu nebo 
vytvoříte nový, volba Set Active Area Automatically se vypne.

Webové objekty v aktivní oblasti tlačítka se při otevřeném editoru tlačítek objevují 
ve webové vrstvě dokumentu.

Vytvoření webového objektu řezu nebo hotspotu:

1. Poklepejte dvakrát na tlačítko.

2. V editoru tlačítek klepněte na záložku Active Area.

3. Deaktivujte volbu Set Active Area Automatically.

4. Zvolte nástroj Slice nebo Hotspot a nakreslete v editoru tlačítek nový tvar.

Editace aktivní oblasti tlačítka:

1. Poklepejte dvakrát na tlačítko.

2. Klepněte na záložku Active Area. 

3. Použijte nástroje Pointer, Slice nebo Polygon Slice a přesuňte, překreslete nebo 
změňte tvar aktivní oblasti. 

Editace textu tlačítka

Ve Fireworks je velmi jednoduché změnit text na tlačítku bez toho, abyste museli 
upravovat každý snímek tlačítka.
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Současná změna textu ve všech stavech tlačítka:

1. Vyberte v dokumentu tlačítko.

2. Na panelu Object zapište nový text do pole Button Text a klepněte na OK. 
Text se aktualizuje ve všech stavech tlačítka.

Současná změna textu ve všech stavech tlačítka v editoru tlačítek:

1. Změňte text v horním textovém bloku jakéhokoliv stavu tlačítka.
Objeví se okno dotazující se, zda chcete aktualizovat text i v ostatních stavech 
tlačítka.

2. Klepněte na Yes.
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Používání efektů zkosení (bevel)) pro nakreslení 
stavu tlačítek

Pro vytvoření rollover stavu tlačítka můžete použít jakékoliv nástroje. Protože jsou 
však tlačítka tím nejběžnějším typem javascriptového rolloveru, obsahuje Fireworks 
živý efekt, který zjednodušuje tvorbu běžného vzhledu tlačítek. Na panelu Effect 
na tlačítko aplikujte efekt Inner Bevel (vnitřní zkosení) nebo Outer Bevel (vnější 
zkosení)  a potom v roletce Button Presets (předvolby tlačítka) nastavte jednu 
z možných variant tlačítka – Raised (vystouplé), Highlighted (zvýrazněné), Inset 
(zamáčklé) nebo Inverted (invertované).

Efekt z roletky Button Presets Popis

Raised (vystouplé) Zkosení navozuje dojem, že tlačítko 
vystupuje nad okolní objekty.

Highlighted (zvýrazněné) Barvy tlačítka jsou zesvětleny.

Inset (zamáčklé) Zkosení navozuje dojem, že je tlačítko 
vmáčklé do okolních objektů.

Inverted (invertované) Zkosení navozuje dojem, že je tlačítko 
vmáčklé do okolních objektů a jeho barvy 
jsou zesvětleny.

Pokud například vytváříte tlačítko se čtyřmi stavy, můžete efekt Raised aplikovat 
na grafiku ve stavu Up, efekt Highlighted na stav Down, atd.
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Vkládání tlačítek z knihovny

Knihovna (panel Library) vám pomáhá zefektivňovat a zjednodušovat tvorbu 
konzistentních tlačítek pro vaše webové stránky. Můžete vytvořit originální symbol 
tlačítka a ten pak používat jako zdroj pro všechna tlačítka na vaší stránce.

Chcete-li použít symbol tlačítka, naimportujte ho do knihovny. Přetažením 
symbolu z knihovny na plátno vytváříte jeho nové instance.

Poznámka: Upravením instance přerušíte vazbu instance a původního symbolu.

Pokud v některém bodě práce potřebujete změnit tlačítka na vaší webové stránce, 
můžete jen upravit původní symbol a použít příkaz Update (aktualizovat) panelu 
Library, kterým změny promítnete do každého tlačítka v dokumentu. 

Importování kopie tlačítka do aktuálního dokumentu

Importování kopie tlačítka do aktuálního dokumentu:

1. V menu zvolte Window > Library. Tím otevřete panel Library. 

2. V menu Options tohoto panelu zvolte příkaz Import Symbols.

3. Najděte na disku symbol tlačítka nebo dokument Fireworks, který jste 
si vytvořili dříve, a klepněte na OK.

4. Klepnutím na Import přenesete kopii symbolu do knihovny.

Vkládání tlačítka z knihovny

Vložení tlačítka z knihovny:

1. Otevřete panel Library.

2. Přetáhněte symbol tlačítka do dokumentu.
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Importování předinstalovaného symbolu tlačítka

Fireworks se dodává s několika styly tlačítek.

Import předinstalovaného tlačítka do aktuálního dokumentu:

1. V menu zvolte Insert > Libraries > Buttons.

2. Ze seznamu symbolů vyberte tlačítko, které chcete použít.

3. Klepněte na Import.

Vytváření navigačního pruhu s tlačítky

Navigační pruh (navigation bar, někdy také nav bar) je skupina tlačítek, která 
typicky zůstávají na stránce (nebo alespoň vypadají, že zůstávají), i když se ostatní 
části stránky mění. Navigační pruh použijte pro vytvoření konzistentní navigace 
po vaší webové stránce. Jednoduchý způsob, jak vytvořit navigační pruh  je 
několikrát zduplikovat tlačítko a na každém takovém tlačítku změnit text a URL 
odkazu. Navigační pruh tak vypadá stále stejně na všech stránkách webu, ale 
odkazy na něm jsou specifické pro funkci a účel každé stránky.

Ačkoliv tlačítka v navigačním pruhu vypadají obecně stejně, mělo by být každé 
schopno zobrazit unikátní text. Problém je vytvořit symbol tlačítka, který dovolí 
vložit unikátní text, ale stále může být použit pro aktualizaci vzhledu všech tlačítek 
na stránce. Tento problém můžete vyřešit vnořování symbolů tlačítek. Vytvořte 
jeden symbol tlačítka, který bude obsahovat pouze grafiku a žádný text. Potom 
vytvořte druhé tlačítko, do kterého vložíte grafiku prvního symbolu a nad ní 
do nesdílené vrstvy přidáte vlastní text. Duplikováním tohoto tlačítka vytvoříte 
navigační pruh.
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Vytvoření navigačního pruhu pomocí vnořených symbolů:

1. Vytvořte tlačítko složené pouze z grafických prvků a žádného textu.
Tlačítko se automaticky objeví v knihovně.

2. V menu zvolte Insert New Button (nové tlačítko).

3. Objeví se Button Editor nastavený na stavu Up.

4. Do pracovní plochy stavu Up přetáhněte z knihovny první symbol tlačítka. 

5. Na panelu Layers vyberte vrstvu, která není sdílená a jen nad vrstvou, ve které 
je vložen symbol původního tlačítka.

6. Pro každý stav nového tlačítka přidejte text.

7. Na záložkách Down a Over While Down nastavte náležitě volby Include.

8. Zavřete editor tlačítek.

9. V dokumentu tlačítko zduplikujte.

10. U každého duplikovaného tlačítka změňte na panelu Object text.

Poznámka: Sérii tlačítek můžete vnořit do dalšího symbolu a vytvořit tak přenosný 
navigační pruh.

Aktualizace grafiky všech tlačítek jednoduchého navigačního pruhu:

Použijte Button Editor a upravte původní tlačítko (tlačítko bez textu).

Fireworks aktualizuje ostatní tlačítka s ohledem na provedené změny. Protože text 
je unikátní pouze pro nové symboly tlačítek, není nijak ovlivněn aktualizací grafiky. 

Pomocí stavů Down a Over While Down můžete vytvořit ještě komplexnější 
navigační pruhy.
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Převod rolloverů Fireworks na tlačítka

Tlačítka můžete vytvořit i z již dříve vytvořených rolloverů. Tyto rollovery můžete 
převést (včetně těch z minulých verzí Fireworks) na tlačítka a využít tak výhod 
a pohodlnosti tlačítkových symbolů.

Komponenty rolloveru převedeného na tlačítko a nové tlačítko jsou umístěny 
do knihovny. Tlačítko automaticky vytvoří svůj vlastní řez, takž již není nadále 
potřeba hotspot nebo řez původního rolloveru.

Převod Fireworks rolloveru na tlačítko:

1. Na panelu Frames vyberte v roletce Onion Skinning volbu Show All Frames 
(zobrazit všechny snímky).

2. Vyberte všechny komponenty rolloveru.

3. V menu zvolte Insert > Convert to Symbol (převést na symbol).

4. Zadejte jméno a jako typ zvolte Button (tlačítko). Klepněte na OK.

Vložení tlačítka z externího zdroje

Tlačítko si můžete vybrat z knihovny Fireworks nebo z jiného dokumentu 
Fireworks. Pokud naimportujete tlačítko z externího zdroje, bude si Fireworks 
tento zdroj pamatovat. Pokud se pak zdrojový soubor změní, můžete importované 
tlačítko aktualizovat, aby reflektovalo změny originálu.
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Vložení hotového tlačítka z knihovny do dokumentu:

1. V menu zvolte Insert > Libraries > Other a vyberte knihovnu nebo Fireworks 
dokument, ze kterého chcete tlačítko vložit. 

2. V zobrazené knihovně vyberte symbol a klepněte na Import.

Aktualizace importovaného tlačítka:

1. Na panelu Library vyberte symbol tlačítka, který chcete aktualizovat.

2. V menu Options panelu zvolte příkaz Update.
Fireworks aktualizuje importované tlačítko tak, aby odpovídalo vzhledu 
originálního tlačítka.
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Používání hotspotů a řezů

Hotspoty a řezy jsou představují hlavní nástroje pro vytváření interaktivních 
objektů, jako jsou rollovery a obrazové mapy. 

Hotspoty a řezy jsou tzv. webové objekty (web objects), což znamená, že neexistují 
jako obrázky, ale v konečné podobě jako HTML kód přidávající k vašemu 
dokumentu interaktivitu. Tyto objekty můžete prohlížet, vybírat a přejmenovávat 
pomocí webové vrstvy (Web Layer) na panelu Layers.

Tato kapitola popisuje základní koncepty, jejichž pochopení je nutné pro vytváření 
hotspotů a řezů.

Vytváření hotspotů a obrazových map

Weboví designéři intenzivně používají hotspoty a obrazové mapy pro vytváření 
jednodušší navigace po webových stránkách. Hotspot je aktivní oblast webové 
grafiky, která se odkazuje na nějaké URL. Obrazová mapa pak není nic jiného 
než grafika, nad kterou je umístěno několik hotspotů.  Fireworks vám umožňuje 
vytvářet hotspoty téměř jakéhokoliv tvaru a umožňuje vám vyexportovat HTML 
kód, který obrazovou mapu reprodukuje na webu.

Na zdrojové grafice si nejprve určete oblasti, které budou představovat dobré 
navigační body. V těchto oblastech pak vytvoříte hotspoty a přiřadíte k nim URL 
odkazy. Hotspoty se dají vytvářet dvěma způsoby:

• Hotspot můžete kolem cílové oblasti grafiky nakreslit pomocí nástrojů 
Rectangle Hotspot (obdélníkový hotspot), Circle Hotspot (kruhový hotspot) 
nebo Polygon Hotspot (nepravidelný, polygonální hotspot).

• Můžete vybrat objekt a hotspot vložit přes něj

KAPITOLA 14

14
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Vytvoření obdélníkového nebo kruhového hotspotu:

1. Vyberte nástroj Rectangle Hotspot nebo Circle Hotspot.

2. Táhněte nástrojem a nakreslete přes požadovanou oblast grafiky hotspot. 
Pokud podržíte klávesu Alt (Windows) nebo Option (Macintosh), budete 
hotspot kreslit od středu.

Hotspot nemusí být vždy obdélníkový nebo kruhový. Můžete také potřebovat 
vytvořit nepravidelný polygonální hotspot tvořený mnoha body. Tento přístup 
se hodí hlavně při práci se složitějšími obrázky.

Vytvoření nepravidelného hotspotu:

1. Vyberte nástroj Polygon Hotspot.

2. Klepáním myší umísťujte vektorové body stejně, jako byste kreslili přímé 
segmenty čar nástrojem Pen. Ať už je kreslená cesta otevřená nebo uzavřená, 
definuje oblast hotspotu viditelná výplň. 

Vytvoření hotspotu obkreslením jednoho nebo více vybraných 
objektů:

1. V menu zvolte Insert > Hotspot.
Pokud máte vybraných více než jeden objekt, objeví se dialogové okno 
s dotazem, zda chcete vytvořit jeden obdélníkový hotspot pokrývající všechny 
objekty nebo více hotspotů pokrývajících každý jeden objekt.
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2. Klepněte na tlačítko Single (jeden velký hotspot) nebo Multiple (více 
samostatných hotspotů). Ve webové vrstvě se zobrazí nový hotspot nebo 
hotspoty.

Přiřazování URL k hotspotům

URL je adresa určité stránky nebo souboru na internetu. Pokud přiřadíte URL 
k hotspotu, může se uživatel na tuto adresu přesunout klepnutím na hotspot 
ve webovém prohlížeči. Pro přiřazení URL k hotspotu použijte panel Object.

Přiřazení URL k vybranému hotspotu:

1. Příkazem z menu Window > Object zobrazte panel Object.

2. Do pole Link na tomto panelu zadejte URL.

3. Volitelně můžete zadat alternativní text, který se v prohlížeči objeví při načítání 
stránky.

4. V roletce Target (cíl) můžete zadat jméno rámce nebo vybrat jeden 
z rezervovaných cílů. Tento cíl je jiný rámec (frame) nebo jiné okno prohlížeče, 
kam se odkazovaný soubor načte.

5. Pokud chcete, můžete z barevného vzorníku vybrat jinou barvu překryvu 
hotspotu. To je užitečné pro lepší organizaci webových objektů.



258  Kapitola 14

Uspořádání URL na panelu URL

Pokud plánujete stejné URL použít několikrát, můžete na panelu URL vytvořit 
URL knihovnu a vaše URL do ní uložit. 

Nastavení alternativního textu

Alternativní text (alt) se objeví na místě grafiky při načítání webové stránky nebo 
pokud načtení grafiky z nějakého důvodu selže. V některých prohlížečích 
se alternativní text objevuje také jako bublinková nápověda u kurzoru myši.

Nastavení alternativního textu:

Na panelu Object zadejte text do pole Alt.

Nastavení cíle odkazu

Cíl (target) může představovat jiný rámec (frame) nebo jiné okno prohlížeče, 
do kterého se načte odkazovaný dokument. Cíle pro vybraný hotspot nebo řez 
můžete nastavit na panelu Object v poli Target.
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Nastavení cíle:

• Napište jméno HTML rámce, do kterého chcete otevřít dokument.

• V roletce Target Vyberte jeden z rezervovaných cílů.

Rezervované cíle jsou následující:

• _blank načte odkazovaný dokument do nového, nepojmenovaného okna 
prohlížeče.

• _parent načte odkazovaný dokument do rodičovské sady rámců (frameset) 
nebo do obsahujícího rámec, který obsahuje odkaz.

• _self  načte odkazovaný dokument do stejného rámce nebo okna, ve kterém je 
odkaz. Tento cíl je výchozí, takže ho obvykle nemusíte nastavovat.

• _top načte odkazovaný dokument do celého okna prohlížeče, čímž se odstraní 
všechny existující rámce.

Změna hotspotů

Webové objekty mají body a cesty stejné jako vektorové objekty. Pro změnu tvaru 
a velikosti hotspotu můžete použít stejné nástroje Pointer, Subselection a nástroje 
Transform. Další editační nástroje (například nástroj Freeform) hotspoty needitují. 

Editace vybraného hotspotu pomocí bodů:

1. Zvolte nástroj Pointer nebo Subselection.

2. Přetáhněte body:

• Obdélníkový hotspot mění svoji polohu a rozměry, ale zůstává obdélníkový.

• Kruhový hotspot mění svoji polohu a průměr, ale zůstává kruhový.

• Polygonální hotspot mění svůj tvar v závislosti na tom, kam přetahujete jeho 
body.
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Převod vybraného hotspotu na obdélníkový, kruhový nebo 
polygonální hotspot:

1. Volbou z menu Window > Object otevřete panel Object.

2. V roletce Shape zvolte volbu Rectangle (obdélníkový), Circle (kruhový) nebo 
Polygon (polygonální).

Použití chování drag-and-drop na hotspoty

Můžete použít drag-and-drop (táhni a pusť) chování a nakonfigurovat tak hotspot, 
aby spustil nebo naopak vypnul rollover efekt. Drag-and-drop chování se na 
hotspoty aplikuje stejně jako na řezy. 

Hotspot může pouze spustit nebo vypnout rollover efekt. Nemůže být sám cílem 
drag-and-drop chování přicházejícího od jiného hotspotu nebo řezu.

Jakmile jednou přiřadíte hotspotu drag-and-drop chování, je spojující modrá linka 
viditelná pouze když je hotspot vybraný.
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Exportování obrazových map

Poté, co z hotspotů vytvoříte obrazovou mapu, musíte ji předtím, než bude 
ve webovém prohlížeči fungovat, exportovat.

Fireworks při exportu vytváří pouze klientské obrazové mapy (client-side). 
Export klientských obrazových map vygeneruje grafický soubor a HTML soubor 
obsahující informace o hotspotech na mapě a od odpovídajících URL odkazech.

Export rozřezané obrazové mapy typicky vytváří mnoho souborů. 

Export obrazové mapy:

1. Optimalizujte grafiku a připravte ji pro export.

2. V menu zvolte File > Export.

3. Nastavte adresář, kam chcete umístit HTML soubor a pojmenujte tento soubor.
Pokud jste již pro svoje webové stránky vytvořili lokální strukturu, můžete 
odtud uložit grafiku přímo do této struktury.

4. V roletce Save as type zvolte HTML and Images (HTML a obrázky).

5. V roletce HTML zvolte Export HTML File (exportovat HTML soubor).

6. V roletce Slices zvolte None (žádné řezy).

7. Pokud chcete umístit obrázky do podadresáře, zaškrtněte volbu Put Images in 
Subfolder a vyberte příslušný adresář.

8. Klepnutím na Save vyexportujete obrazovou mapu.

V roletce HTML můžete vybrat volbu Copy to Clipboard (zkopírovat HTML do 
schránky) a pak příslušnou obrazovou mapu vložit do Dreamweaveru nebo jiného 
HTML editoru.

Při exportu do HTML může Fireworks použít HTML komentáře, které jasně 
označí začátek a konec kódu obrazových map a dalších webových funkcí 
vytvořených ve Fireworks. Standardně se komentáře do kódu nevkládají. Pokud 
je chcete vložit, aktivujte volbu Include HTML Comments v dialogovém okně 
HTML Setup.
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Po exportu HTML se funkce Update HTML postará o doručení HTML kódu 
generovaného ve Fireworks na správné místo uvnitř HTML souborů vašeho 
webového sídla.

Rozřezávání

Rozřezávání (slicing) rozřeže dokument Fireworks do různých segmentů, z nichž 
se každý vyexportuje do samostatného souboru. Existují tři důvody, proč je 
užitečné tento krok udělat: optimalizace velikosti obrázkových souborů, vytvoření 
interaktivity a prohazování částí obrázků. Rozřezávání můžete také použít 
k nahrazení části obrázku HTML textem.

Optimalizace obrázku

Jedou z výzev při tvorbě webové grafiky je zachování malé velikosti souborů, aby 
se obrázky stahovaly rychle. Rozřezávání je silný nástroj, kterým grafiku rozdělíte 
do menších bloků, se kterými počítač uživatele zachází efektivněji. Fireworks vám 
umožní převést každý samostatný řez do toho nejvhodnějšího obrazového formátu 
a potom ho exportovat pomocí množství různých HTML stylů (například pro 
Dreamweaver nebo Microsoft FrontPage).

Přiřazení interaktivity oblastem dokumentu

Řezům můžete přiřadit interaktivitu a vytvořit tak oblasti reagující na pohyb nebo 
klepnutí myši uživatele. Například může dojít ke změně obrázku, pokud přes něho 
přejedete myší (rollover efekt), nebo se může kurzor myši změnit na ručičku 
a naznačit tak, že zde je odkaz na jinou webovou stránku.

Řezy můžete použít pro vytvoření mnoha interaktivních efektů, jako jsou tlačítka, 
navigační pruhy a rollovery.

Řezy také můžete použít pro vložení HTML textu dovnitř grafiky, takže text 
zůstane editovatelný.
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Záměna části obrázku

Dalším důvodem pro rozřezávání může být záměna často se měnících částí 
obrázku bez toho, aby se musel vždy načítat znovu celý obrázek. Váš web může 
například obsahovat stránku, která zobrazuje zaměstnance měsíce. Každý měsíc 
aktualizujete pouze řez s obrázkem zaměstnance bez toho, že byste museli 
aktualizovat zbytek grafiky na stránce.

Vytváření řezů

Řezy můžete vytvářet dvěma základními způsoby v závislosti na jejich účelu. 
Můžete buď automaticky vložit obdélníkový řez pokrývající objekt nebo můžete 
řez nakreslit ručně. Pokud chcete udělat celý objekt interaktivní, můžete ho 
jednoduše vybrat a vložit nad něho řez. Tímto krokem obsáhnete celý objekt 
do obdélníkového řezu, nezávisle na tvaru objektu.

Pokud je vybrán hotspot, můžete ho pomocí příkazu z menu Insert > Slice převést 
na řez.

Pokud chcete na interaktivní oblast převést jen menší část objektu, rozřežte objekt 
na několik řezů pomocí nástrojů Slice nebo Polygon Slice. 

Červené čáry vystupující z řezu jsou řezná vodítka (slice guides), která definují 
hrany samostatných souborů, do kterých bude při exportu rozdělen.

Objekt řezu můžete zkopírovat a vložit do jiného Fireworks dokumentu.

Vložení obdélníkového řezu založeného na objektu:

1. Vyberte objekt.
Se stisknutou klávesou Shift můžete vybrat více než jeden objekt.

2. V menu zvolte Insert > Slice. řez je tvořen obdélníkem jeho oblast zahrnuje 
všechny nejkrajnější pixely vybraného objektu.
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3. Pokud jste vybrali více než jeden objekt, objeví se dialogové okno, ve kterém 
zvolte:

• Tlačítkem Single vytvoříte jeden velký řez, který pokryje všechny vybrané 
objekty.

• Tlačítkem Multiple vytvoříte samostatný řez pro každý z vybraných objektů.

Nakreslení obdélníkového řezu:

1. Vyberte nástroj Slice.

2. Tažením myší nakreslete řez. Ve webové vrstvě dokumentu se objeví objekt 
řezu a řezná vodítka.

Překrývající se řezy

Občas může dojít k tomu, že se řezy, které měly být pouze blízko sebe, mohou 
navzájem překrývat. Místo toho, aby se v oblasti překryvu vytvářel další řez 
navíc, bere Fireworks 4 v potaz pouze ten řez nejvíce vpředu. Tímto způsobem 
se exportuje méně přebytečných pixelů. Problém překrývajících se řezů běžně 
nastává pouhým přehlédnutím. Doporučuje se takovéto překryvy odstranit buď 
překreslením nebo úpravou řezů.

Přiřazení URL řezu

Objektu řezu můžete pomocí panelu Object přiřadit URL odkaz.

1. Volbou v menu Window > Object zobrazte panel Object.

2. Do pole Link zadejte URL.
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3. Volitelně zadejte alternativní text.

4. Do pole Target zadejte jméno HTML rámce nebo vyberte jednu 
z rezervovaných možností. Cíl je jiný rámec nebo okno webového prohlížeče, 
kam se otevře odkazovaná stránka.

Vytváření textových řezů

Textový řez vyznačuje oblast v rozřezaném obrázku, kde se v prohlížeči objeví 
běžný HTML text. U textového řezu se neexportuje ani pixel obrazových dat, ale 
pouze HTML text, který se objeví v buňce tabulky definované řezem.

Textové řezy jsou užitečné v případě, že chcete rychle aktualizovat zprávy na svých 
stránkách bez nutnosti vytvářet novou grafiku.

Vytvoření textového řezu:

1. Nakreslete objekt řezu.

2. Na panelu Object vyberte v roletce Type položku Text.

3. Do velkého pole ve spodní části panelu Object zadejte váš text.

4. Chcete-li text uvnitř řezu naformátovat, tak:

• V textu na panelu Object použijte HTML tagy pro formátování textu.

• Použijte HTML formátovací tagy v HTML souboru, který hodláte po exportu 
obrázku přenést na svou webovou stránku.
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Text v textovém řezu se nezobrazuje ve vašem  PNG souboru ve Fireworks, ale 
objeví se ve webovém prohlížeči po exportu obrázku obsahujícího textový řez. 

Vytváření neobdélníkových řezů

Při vytváření některých rollover efektů by vám nemuseli obdélníkové řezy stačit. 
Pokud rollover obsahuje překrývající se řezy nebo pokud má nepravidelný tvar, 
může se při záměně obrázku nahradit nechtěně i nějaká nežádoucí informace 
v pozadí. Fireworks tento problém řeší tak, že vám dovolí nakreslit řezy 
jakéhokoliv tvaru. Těmto řezům se říká polygonální řezy. Obvykle je nutné je 
použít pouze v případech, kdy by se jinak překrývaly dva rollover obrázky.

Nepravidelný tvar řezu můžete také vytvořit převedením vektorové cesty.

Automatické vytvoření polygonálního řezu:

1. Vyberte objekt.

2. V menu zvolte Insert > Hotspot.

3. V menu zvolte Insert > Slice.
Hotspot je převeden na polygonální řez.
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Ruční nakreslení polygonálního řezu:

1. Zvolte nástroj Polygon Slice.

2. Klepáním myší umísťujte vektorové body polygonu. Nástroj Polygon Slice 
kreslí pouze rovné segmenty čar.

3. Pokud kreslíte polygonální řez kolem měkkého okrajem ujistěte se, že řez 
obsahuje celý objekt, abyste se vyhnuli nechtěným tvrdým hranám u grafiky 
uvnitř řezu.

4. Chcete-li ukončit práci nástrojem Polygon Slice, vyberte na panelu Tools jiný 
nástroj. Pro uzavření polygonu nemusíte znovu klepat na první bod.

Dejte pozor, abyste nepoužívali polygonální řezy příliš často, protože vyžadují 
mnohem více JavaScriptu než podobné obdélníkové řezy. Vysoký počet polygonální 
řezů vy mohl nepříznivě ovlivnit délku zpracovávání webovým prohlížečem.

Převedení vektorové vesty na řez:

1. Vyberte vektorovou cestu.

2. V menu zvolte Insert > Hotspot.

3. V menu zvolte Insert > Slice.
Je vytvořen řez, který odpovídá tvaru vektorové vesty.

Zobrazování řezů a vodítek řezů

Pokud je objekt zakrytý řezem, budete zřejmě potřebovat řez skrýt, abyste mohli 
objekt editovat. Řez můžete zneviditelnit. Vypnout můžete buď všechny webové 
objekty v dokumentu nebo jen jeden konkrétní. 

Vodítka řezu se objeví automaticky jakmile řez nakreslíte.Tato vodítka ukazují, jak 
Fireworks rozřeže obrázek při exportu. Vodítka řezů nemůžete upravovat jako 
normální vodítka, ale překreslují se samy když přidáte, posunete nebo upravíte řez. 

Řezy a vodítka řezů jsou vidět v náhledovém módu (Preview). V tomto módu 
se jednotlivé řezy zobrazují jako bílý překryv.

Jednotlivým řezům můžete přiřadit unikátní barvy a tak si usnadnit jejich 
organizaci. Můžete také změnit barvu vodítek řezů.
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Skrytí určitých řezů a hotspotů:

Na panelu Layers klepněte na ikonku oka vedle jednotlivých webových objektů, 
které chcete skrýt.

Klepnutím na stejné místo (nyní prázdné) viditelnost objektu opět zapnete. Ikonka 
oka se opět objeví a objekt je v dokumentu znovu viditelný.

Skrytí nebo zobrazení všech hotspotů, řezů a vodítek:

• Na panelu Tools klepněte na tlačítko Hode Hotspots and Slices (skrýt hotspoty 
a řezy) nebo na tlačítko Show Hotspots and Slices (zobrazit hotspoty a řezy).

• Na panelu Layers klepněte na ikonku oka vedle webové vrstvy (Web Layer).

Skrytí nebo zobrazení vodítek řezů v jakémkoliv pohledu na dokument:

V menu zvolte View > Slice Guides.

Změna barvy vybraného řezu:

Na panelu Object vyberte novou barvou klepnutím na políčko s barvou Slice color.
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Změna barvy vodítek řezů:

1. V menu zvolte View > Guides > Edit Guides (upravit vodítka).

2. V políčku s barvou Slice color zvolte novou barvu vodítek.

Prohlížení a pojmenovávání řezů na panelu Layers

Pomocí webové vrstvy na panelu Layers můžete jednoduše pojmenovávat 
řezy a další webové objekty. Webová vrstva zobrazuje všechny webové objekty 
v dokumentu, takže můžete každý z nich vybrat, prohlédnout a pojmenovat.

Prohlédnutí a výběr řezu pomocí panelu Layers:

1. Pomocí příkazu Window > Layers zobrazte panel Layers.

2. Klepnutím na znaménko plus (Windows) nebo na trojúhelníček (Macintosh) 
rozbalte webovou vrstvu. 
Pod webovou vrstvou se zobrazí kompletní seznam všech webových objektů 
ve vašem dokumentu. 

3. Klepnutím vyberte řez.
Řez se zvýrazní ve webové vrstvě i na ploše dokumentu.
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Rozřezávání rozdělí obrázek na kousky. Každý kousek se exportuje jako 
samostatný soubor, takže každý soubor musí mít jméno. Pokud má obrázek 
více než jeden snímek, představuje každý kousek v každém snímku jedinečně 
pojmenovaný soubor.

Obrázek může být rozřezán na několik kousků

Fireworks při exportu automaticky pojmenovávají soubor každého řezu. Buď 
můžete akceptovat výchozí jmennou konvenci, nebo můžete každému řezu zadat 
vlastní jméno:

• Klepněte na jméno řezu ve webové vrstvě a zadejte nové jméno.

• Pokud na panelu Object zaškrtnete volbu Auto-Name Slices (pojmenovávat 
řezy automaticky), pojmenují se jednotlivé soubory podle aktuální jmenné 
konvence. 

• Pokud volbu Auto-Name Slices na panelu Object deaktivujete, můžete zadat 
jméno každého řezu do pole Slice Name.

Pojmenování řezů ve webové vrstvě

Nejjednodušším způsobem, jak přejmenovat jednotlivý řez, je přejmenovat ho 
ve webové vrstvě na panelu Layers.

Pojmenování řezu ve webové vrstvě:

1. Příkazem Window > Layers zobrazte panel Layers.

2. Klepnutím na znaménko plus (Windows) nebo na trojúhelníček (Macintosh) 
rozbalte webovou vrstvu. 
Pod webovou vrstvou se zobrazí kompletní seznam všech webových objektů 
ve vašem dokumentu. 
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3. Poklepejte dvakrát na výchozí jméno webového objektu (řezu nebo hotspotu).

4. Zadejte nové jméno.

Automaticky pojmenovávané řezy

Pokud nechcete zadávat vlastní jméno pro každý řez, můžete nechat Fireworks 
přiřadit každému řezu jedinečné jméno automaticky v závislosti na výchozí jmenné 
konvenci.

Fireworks vám umožňuje nastavit si vlastní jmenné konvence pomocí širokého 
spektra voleb. Můžete vytvářet jmenné konvence, které se skládají až ze šesti prvků. 
Každý prvek se může skládat z následujících voleb.

Volba Popis
None V prvku není použito žádné jméno.
doc.name Prvek přebírá jméno dokumentu-

“slice“ Do jmenné konvence můžete vložit slovo 
„slice.“

Slice # (1,2,3...)

Slice # (01,02,03...)

Slice # (A,B,C...)

Slice # (a,b,c...)

Prvek je číselně nebo abecedně podle 
příslušného vybrané stylu.

row/column(r3_c2,r4_c7...) Row(r##) a Col(##) označují řádky a 
sloupce v tabulce, kterou webový prohlížeč 
používá při skládání rozřezaného obrázku. 
Tuto informaci můžete použít ve jmenné 
konvenci.

Underscore (podtržítko)

Period (tečka)

Space (mezera)

Hyphen (spojovník)

Prvek použije jakýkoliv z těchto znaků 
většinou jako oddělovač jiných prvků.
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Pokud se například dokument jmenuje mydoc a jmenná konvence je doc.name 
+ „slice“ + Slice # (A,B,C...), bude výsledný řez jmenovat mydocsliceA. 
Pravděpodobně nikdy nebudete ve jmenné konvenci potřebovat využít všech šesti 
prvků.

Automatické pojmenování souborů řezů:

1. Vyberte jeden nebo více řezů.

2. Na panelu Object aktivujte volbu Auto-Name Slices.

3. Při exportu rozřezaného obrázku zadejte v dialogovém okně Export do pole 
File Name (Windows) nebo Name (Macintosh) jméno souboru. Nepřidávejte 
ke jménu koncovku souboru. Fireworks automaticky přidá koncovky 
jednotlivým souborů až při exportu.
Jmennou konvenci můžete změnit v dialogovém okně HTML Setup.

Dialogové okno HTML Setup
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Změna standardní jmenné konvence:

1. V menu zvolte File > HTML Setup a otevřete dialogové okno HTML Setup.

2. Klepněte na záložku Document Specific.

3. V sekci File Names vytvořte vlastní jmennou konvenci výběrem požadovaných 
voleb z roletek.

Například jmenná konvence doc.name + „slice“ + Slice # (A,B,C...) by vypadala 
takto:

Chcete-li nastavené informace v dialogovém okně HTML Setup nastavit jako 
výchozí, klepněte na tlačítko Set Defaults.

Vlastní pojmenovávání souborů řezů

Můžete chtít pojmenovat řezy vlastními jmény, abyste mohli jednotlivé soubory 
ve struktuře webového sídla lépe identifikovat. Pokud například máte tlačítko 
nebo navigační pruh, který uživatele vrací na domovskou stránku, mohli byste ho 
pojmenovat „home.“
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Zadání vlastního jména pro vybraný řez:

1. Na panelu Object deaktivujte volbu Auto-Name Slices.

2. Do pole Slice Name zadejte vlastní jméno řezu. Pokud žádné jméno nezadáte, 
Fireworks opět zapne volbu automatického pojmenování. K základnímu jménu 
nepřidávejte žádnou koncovku, Fireworks ji automaticky přidá při exportu.

Pokud obsahuje řez více než jeden snímek, přidá Fireworks standardně k souboru 
každého snímku číslo. Pokud například pro třístavový rollover zadáte jako základní 
jméno řezu „home,“ pak Fireworks pojmenuje stav Up jako home.gif, stav Over 
jako home_f2.gif  a stav Down jako home_f3.gif. Pomocí dialogového okna HTML 
Setup můžete vytvořit vlastní jmennou konvenci pro vícesnímkové řezy.

Změna automatické jmenné konvence pro soubory 
vícesnímkových řezů:

1. V menu zvolte File > HTML Setup a otevřete dialogové okno HTML Setup.

2. Klepněte na záložku Document Specific.

3. V sekci File Names hned za popiskem Frames nastavte pomocí dvou roletek 
příslušnou jmennou konvenci. 
Například jmenná konvence Underscore + Rollover (over, down, overdown) 
přidá k souboru stavu Over text „_over.“ Jméno stavu Over řezu mydocsliceA 
pak bude mydocsliceA_over.
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Chcete-li tuto jmennou konvenci používat i pro další nové dokumenty, klepněte na 
záložce Document Specific na tlačítko Set Defaults.

Používání vnořených tabulek a spacerů

V dialogovém okně HTML Setup můžete na záložce Table vybrat, jakým 
způsobem bude konstruována tabulka na vaší webové stránce. Můžete také 
nastavit, zda mají při rozřezání obrázku prohlížeče tabulku znovu sestavit pomocí 
spacerů (rozpěr) nebo pomocí vnořených tabulek.

Aktualizace řezu v HTML dokumentu

Obrázek pod jedním řezem rozřezaného obrázku můžete aktualizovat bez toho, 
že byste museli exportovat a posílat celý rozřezaný obrázek. V tomto případě 
se doporučuje, abyste používali vlastní pojmenování řezů, abyste mohli lehce 
identifikovat obrázek, který nahrazujete.
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Aktualizace jednoho řezu obrázku:

1. Skryjte řez a požadovaným způsobem upravte grafiku ležící pod ním.

2. Řez znovu zobrazte a vyberte ho.

3. V menu zvolte File > Export.

4. zaškrtněte Selected Slices Only (exportovat pouze vybrané řezy).

5. Exportujte řez do stejného adresáře jako původní řez a použijte stejné základní 
jméno.

Pokud zachováte původní jméno aktualizovaného řezu a uložíte řez na stejné místo 
do vašeho webového sídla, nahradí nový řez ten původní.
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Vytváření rolloverů

Editor tlačítek (Button Editor) vám umožňuje vytvářet tlačítka a dosahovat 
vizuálních efektů pomocí jediného řezu. Pro své stránky však můžete potřebovat 
vytvořit komplexnější  chování, než jaké můžete vytvořit b editoru tlačítek. Můžete 
například chtít vytvořit odpojený rollover, který zobrazuje obrázek na jiném místě, 
než je kurzor myši, nebo například rozbalovací menu, které se rozvine jakmile 
kurzor najede nad příslušnou grafiku.

Tato kapitola popisuje, jak vytvořit jednoduché a odpojené rollovery pomocí řezů 
s snímků. Dozvíte se také, jak vytvořit rozbalovací menu.

Základními stavebními bloky pro vytváření rolloverů ve Fireworks jsou řezy, 
hotspoty a drag-and-drop chování. Drag-and-drop chování vám umožňují vytvářet 
rollovery a efekty záměny obrázku, které spojují řezy a hotspoty s cílovými řezy. 

Rollovery

Javascriptové rollovery představují grafiku, která mění ve webovém prohlížeči svůj 
vzhled, pokud přes ně přejede kurzor myši nebo pokud je na ně klepnuto. Do 
skupiny rolloverů patří i tlačítka a záměny obrázků.

A´t už jsou v jakékoliv formě, fungují všechny rollovery stejným způsobem: jeden 
grafický prvek vyvolá zobrazení druhého grafického prvku, pokud se něj klepne 
nebo najede myší. Obrázky rolloveru mohou být umístěny do dvou nebo více 
snímků. Spoušť rolloveru je vždy webový objekt., tedy buď řez nebo hotspot. Na 
tento webový objekt může být navázáno jedno nebo více chování.

Nejjednodušší typ rolloveru zamění obrázek ve snímku 1 za obrázek přímo pod 
ním ve snímku 2. Můžete však vytvořit mnohem komplikovanější rollovery: 
rollover může nahrazovat obrázek z jakéhokoliv snímku nebo může například 
nahrazovat obrázek na jiném místě než je kurzor myši.

KAPITOLA 15

15
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Vytváření jednoduchých rolloverů pomocí panelu Behaviors

Jednoduchý rollover je takový, který  při najetí nebo klepnutí myší zobrazí pod 
kurzorem jiný obrázek. Toto na výrobu nejjednodušší rollover, protože vyžaduje 
pouze jeden řez a protože oblast spouště chování i jeho cílová oblast jsou stejné.

Jednoduchý rollover vždy bere obrázek ze snímku 2.

Připravení řezu, obrázků a snímků

Jednoduchý rollover se vytváří ve dvou krocích. První krok zahrnuje přípravu řezu, 
dvou obrázků tvořících efekt a snímků, ve kterých tyto obrázky leží. Dva obrázky 
tvořící rollover leží na plátně na stejném místě, ale každý v jiné snímku.

Příprava řezu, obrázků a snímků pro jednoduchý rollover:

1. Vyberte obrázek, který má spouštět rollover efekt.

2. V menu zvolte Insert > Slice a přidejte tak na obrázek řez.

3. Pomocí panelu Frames (snímky) vytvořte nový snímek:
V menu zvolte Window > Frames a potom na panelu Frames klepněte 
na tlačítko New/Duplicate Frame (Nový snímek/duplikovat snímek).

Poznámka: Pokud už v obrázku máte druhý snímek, nemusíte žádný nový snímek 
vytvářet.

4. Pokud není na panelu Frames nový snímek dosud zvýrazněný, vyberte ho.

5. Do prostoru dokumentu, kde leží vytvořený řez, umístěte druhý obrázek:

• Použijte kreslící a editační nástroje a vytvořte grafiku.

• Naimportujte nebo přetáhněte existující grafiku do oblasti řezu.
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Aplikace chování jednoduchého rolloveru na řez

Pokud jste si připravili obrázky a snímky, aplikujte na řez chování jednoduchého 
rolloveru.

Aplikace chování jednoduchého rolloveru:

1. Vyberte řez.

Poznámka: Řezy jsou mezi jednotlivými snímky sdíleny. Pokud máte zapnutou 
volbu Show Hotspots and Slices, zůstávají řezy viditelné nezávisle na tom, jaký 
snímek je právě zobrazený.

2. Příkazem Window > Behaviors otevřete panel Behaviors (chování).

3. Z roletky Add Action (+) (přidat akci) vyberte Simple Rollover (jednoduchý 
rollover).

Používání panelu Behaviors

Panel Behaviors můžete použít pro vytváření, editaci a odstraňování  chování 
připojených k vybranému řezu nebo hotspotu.

Panel Behaviors vám umožní vytvářet i ostatní typy efektů a dovolí vám 
nadefinovat typ události (například klepnutí myší), která spouští efekt. Panel 
Behaviors nabízí velkou flexibilitu i při úpravě existujících chování.
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Připojení chování v vybranému řezu nebo hotspotu pomocí panelu 
Behaviors:

1. Na panelu Behaviors klepněte na tlačítko Add Action (+).

2. Z roletky Add Action (+) vyberte požadované chování.

Dostupná jsou tato chování:

• Simple Rollover (jednoduchý rollover) vytváří rollover pomocí obrázku 
ve snímku 1 pro stav Up a obrázku ve snímku 2 pro stav Over. Pokud nastavíte 
toto chování, musíte stav Over vytvořit tak, že do snímku 2 nakreslíte novou 
grafiku do oblasti stejného řezu. Volba Simple Rollover (jednoduchý rollover) 
je ve skutečnosti skupina obsahující chování Swap Image a Swap Image Restore 
(viz. dále).

• Swap Image (záměna obrázku) nahradí obrázek v oblasti určitého řezu obsahem 
jiného snímku pod stejným řezem nebo obsahem externího souboru.

• Swap Image Restore (vrácení záměny do původního stavu) vrátí rollover k jeho 
výchozímu vzhledu ve snímku 1.

• Set Nav Bar Image (nastavení obrázku navigačního pruhu) nastaví řez jako 
součást navigačního pruhu. Každý řez, který je částí navigačního pruhu, musí 
obsahovat toto chování. Volba Set Nav bar Image je ve skutečnosti skupina 
chování obsahující chování Nav Bar Over, Nav Bar Down a Nav Bar Restore 
(viz. dále).

Přidat chování

Odebrat chování



  Vytváření rolloverů  281

• Nav Bar Over (stav Over navigačního pruhu) určuje stav over aktuálně 
vybraného řezu, když je součástí navigačního pruhu, a volitelně určuje i stav 
Over While Down.

• Nav Bar Down (stav Down navigačního pruhu) určuje stav Down aktuálně 
vybraného řezu, když je součástí navigačního pruhu.

• Nav Bar Restore (vrácení navigačního pruhu do původního stavu) vrátí všechny 
ostatní řezy navigačního pruhu do jejich stavu Up.

• Set Pop-Up Menu (nastavení rozbalovacího menu) připojí k řezu nebo 
hotspotu rozbalovací menu.

• Set Text of  Status Bar (nastavení textu na stavovém řádku) vám umožní 
nadefinovat test, který se ve většině prohlížečů zobrazí ve stavovém řádku 
na spodním okraji okna prohlížeče.

Chování ve Fireworks 4 jsou kompatibilní s chováními v Dreamweaveru 4. Pokud 
rollover z Fireworks exportujete do Dreamweaveru 4, můžete chování z Fireworks 
upravovat pomocí panelu Behaviors v Dreamweaveru.

Poznámka: Rozbalovací menu fungují v Dreamweaveru 4, ale editovat je musíte 
ve Fireworks.

Změna události myši, která aktivuje chování:

1. Vyberte řez nebo hotspot, který spouští a obsahuje chování, které chcete 
upravit.
Všechna chování připojená k webovému objektu se zobrazí na panelu 
Behaviors.

2. Vyberte chování, které chcete upravit.
Všechna vybraná chování kromě jednoduchého rolloveru (Simple Rollover) 
zobrazují seznam událostí.

3. Ze seznamu vyberte novou událost.
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Poznámka: Událost OnLoad spustí chování okamžitě po načtení webové stránky. 
Pokud například změníte spouštěcí událost pro záměnu obrázku na OnLoad, 
zobrazí se náhradní obrázek okamžitě.

Používání drag-and-drop chování pro vytvoření 

efektu záměny obrázku

Pro vytvoření efektu záměny obrázku můžete použít drag-and-drop chování (táhni 
a pusť). Drag-and-drop chování představují rychlý a efektivní způsob, jak určit, 
co se stane s hotspotem nebo řezem, pokud na něho najedete myší. V předchozích 
verzích Fireworks jste museli nastavovat jednotlivé události na panelu Behaviors. 
Drag-and-drop chování jsou rychlejší metodou, která vám umožňuje přetáhnout 
úchyt z řezu nebo hotspotu, který spouští událost, na cílový řez. Tento úchyt 
představuje kroužek s křížkem ve středu řezu.

Když vyberete spouštěcí webový objekt, zobrazí Fireworks všechny vazby 
jednotlivých chování tohoto objektu. Vazbu drag-and-drop chování představuje 
standardně modrá linka.
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Vytvoření rolloveru pro záměnu obrázku pomocí 
jednoho řezu

Rollover pro záměnu obrázku pomocí jednoho řezu můžete použít pro vytvoření 
tlačítka nebo pro vytvoření obrázku, který se mění, pokud na něj klepnete nebo jen 
najedete myší. 

Chcete-li vytvořit tento typ rolloveru, přetáhněte úchyt ze středu řezu k okraji 
tohoto řezu. Zaměňovaný obrázek můžete vybrat z jakéhokoliv snímku.

Vytváření měnícího se obrázku se skládá ze dvou částí: první část zahrnuje 
připravení řezu, náhradního obrázku a snímku, ve kterém bude náhradní obrázek 
umístěn.

Příprava řezu, náhradního obrázku a snímku pro rollover efekt 
záměny obrázku:

1. Vyberte obrázek, který má spouštět efekt.

2. V menu zvolte Insert > Slice a vytvořte tak nad obrázkem řez.

3. Pomocí panelu Frames vytvořte nový snímek:
V menu zvolte Window > Frames a pak klepněte na panelu na tlačítko New/
Duplicate Frame.

4. Pokud není nově vytvořený snímek na panelu Frames zvýrazněný, vyberte ho.

5. Do prostoru, kde je řez, umístěte grafiku druhého obrázku:

• Použijte kreslící a editační nástroje a vytvořte novou grafiku.

• Naimportujte nebo přetáhněte existující grafiku na správnou pozici uvnitř řezu.
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Napojení drag-and-drop chování

Druhým krokem celého procesu je pak připojení chování pro záměnu obrázku 
na vybraný řez.

Dokončení záměny obrázku pomocí drag-and-drop chování:

1. Vyberte řez překrývající spouštěcí oblast.

Poznámka: Řez můžete vybrat v kterémkoliv snímku.

2. Umístěte kurzor myši nad úchyt uprostřed řezu. Kurzor myší se změní na 
ručičku.
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3. Klepněte a podržte stisknuté tlačítko myši. Kurzor se změní na zatnutou pěst.

4. Přetáhněte kurzorem myši k hraně řezu.
Modrá linka drag-and-drop chování se táhne od středu řezu k jeho levému 
hornímu okraji.
Objeví se dialogové okno Swap Image.
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5. Z roletky Swap Image From vyberte snímek, ve kterém je umístěn obrázek 
určený pro záměnu. Klepněte na OK.

6. V menu zvolte File Preview in Browser (náhled v prohlížeči) nebo klepněte na 
záložku Preview v horní části okna dokumentu. Zobrazí se náhled, jak bude 
rollover vypadat v prohlížeči.

Vytváření odpojených rolloverů pomocí 
drag-and-drop chování

Odpojený rollover je jen o trošku komplikovanější než rollover se záměnou 
obrázku v jednom řezu. Odpojený rollover představuje stav, kdy klepnutí nebo 
najetí myši na spouštěcí řez vyvolá záměnu v jiném místě webové stránky. Každý 
obrázek leží ve svém vlastním snímku.  Odpojené rollovery proto vyžadují dva 
webové objekty: řez nebo hotspot spouštějící rollover efekt a cílový řez zakrývající 
oblast v níž chcete provádět záměnu obrázku.

Při výběru spouštěcího webového objektu máte tři možnosti:

• Pokud sama spouštěcí oblast není rolloverem ani nemění sama svůj vzhled, 
použijte zde hotspot.

• Pokud má i spouštěcí oblast měnit svůj vzhled, vytvořte zde řez.

• Pokud chcete pro vytvoření spouštěcího objektu použít Button Editor, umístěte 
do oblasti symbol tlačítka. Na symboly tlačítka můžete umisťovat chování 
stejným způsobem, jakým je připojujete k řezům a hotspotům.

 Stejně jako u obrázků měnících se v jednom řezu, sestává se i zde postup ze dvou 
kroků.Nejprve si připravíte spouštěcí a cílový webový objekt ve snímku, kde leží 
náhradní obrázek. Potom spojíte spouštěcí objekt s cílovým řezem pomocí chování 
drag-and-drop.
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Příprava webových objektů, obrázků a snímků

Aby odpojený rollover fungoval, musíte umístit dva obrázky do samostatných 
snímků.

Příprava webových objektů, cíle a snímků pro odpojený rollover:

1. Vyberte obrázek, který má spouštět efekt odpojeného rolloveru.

2. Připojte k tomu obrázku webový objekt:

• Pokud chcete do webového objektu uzavřít celý obrázek, zvolte v menu Insert 
> Slice (vložit řez) nebo Insert > Hotspot (vložit hotspot).

• Pokud chcete, aby spoušť tvořila pouze část obrázku, použijte nástroje Slice 
nebo Hotspot a nakreslete natáhněte webový objekt ručně.

3. Pomocí panelu Frames vytvořte nový snímek:
V menu zvolte Window > Frames a pak klepněte na panelu na tlačítko New/
Duplicate Frame.

4. Umístěte na správné místo cílový obrázek rolloveru.

5. V menu zvolte Insert > Slice, čímž vytvoříte řez nad cílovým obrázkem.

Použití drag-and-drop chování pro vytvoření 
odpojeného rolloveru:

Druhou část vytváření odpojeného rolloveru představuje napojení spouštěcího 
webového objektu na cílový řez pomocí drag-and-drop chování.

Nastavení chování pro záměnu obrázku odpojeného rolloveru:

1. Vyberte webový objekt překrývající spouštěcí oblast.
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2. Kurzor myši umístěte nad úchyt drag-and-drop chování ve středu objektu.
Kurzor se změní na ručičku.

3. Klepněte a podržte tlačítko myši. Kurzor se změní na zatnutou pěst.
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4. Přetáhněte kurzor myši k cílovému řezu překrývajícímu obrázek, který chcete 
zaměnit.
Objeví se modrá linka táhnoucí se ze středu spouštěcího objektu k levému 
hornímu okraji cílového řezu. Objeví se dialogové okno Swap Image.

5. V roletce Swap Image From vyberte snímek, ve kterém je umístěn náhradní 
obrázek.

Mazání drag-and-drop chování

Drag-and-drop chování (ty modré linky) můžete vymazat pomocí nástroje Pointer.

Smazání drag-and-drop chování připojeného k řezu nebo 
hotspotu:

1. Vyberte hotspot nebo řez.
U webového objektu se zobrazí všechny drag-and-drop vazby (modré linky) 
připojené k tomuto objektu.

2. Klepněte na modrou linku, kterou chcete vymazat.
Objeví se dialogové okno, které chce potvrdit, zda opravdu chcete chování 
smazat.

3. Klepnutím na OK chování smažete.
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Připojení URL odkazů k rolloverům

Pokud chcete, aby se váš rollover odkazoval na jinou webovou stránku, připojte 
k hotspotu nebo řezu rolloveru URL odkaz.

Připojení URL odkazu k vybranému hotspotu nebo řezu:

• Na panelu Object zadejte  nebo vyberte URL v roletce s URL odkazy.

• Vyberte URL z panelu URL.

Vytváření rozbalovacích menu

Rozbalovací menu (nebo také roletky nebo pop-up menu) jsou menu, která 
se rozbalí v okamžiku, kdy uživatel klepne nebo přejede myší přes spouštěcí 
řez nebo hotspot. Takováto menu poskytují vašim stránkám mnohem větší 
navigační flexibilitu bez dlouhých nahrávacích časů. Vzhled rozbalovacího menu 
si můžete nadefinovat tak, aby odpovídal celkovému vzhledu vaší webové stránky. 
Rozbalovací menu jsou podobná tabulkám – každá položka menu je jako buňka 
tabulky. Menu si můžete přizpůsobit výběrem všech typů fontů, barev buněk 
a obrázků na pozadí.

Průvodce Set Pop-up Menu vás provede vytvořením menu od začátku až 
do konce. Menu se tvoří ve dvou fázích. V první fázi můžete zadat text menu, 
vytvořit podmenu a určit URL adresy, kam ukazují jednotlivé položky menu.

Ve druhé fázi můžete nadefinovat vzhled menu, nastavit obrázky pozadí, font 
a stavy Up a Over položek menu.

Roletka s URL dkazy
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Vytváření položek rozbalovacího menu

Následující kroky vám ukážou, jak vytvořit základní položky rozbalovacího menu.

Vytvoření položek rozbalovacího menu:

1. Nad objekt, který chcete použít jako spouštěč menu, umístěte řez nebo hotspot.

2. V menu zvolte Insert > Pop-Up Menu.
Zobrazí se průvodce Set Pop-Up Menu.

3. Do pole Text zadejte položku menu.

4. V poli Link určete webovou adresu pro tuto položku.

5. Pokud je to potřeba, nastavte cíl v poli Target.

6. Klepnutím na tlačítko Add Menu (+) přidáte položku do menu. Uvidíte ji 
i na náhledu v dolní části okna.

7. Chcete-li vytvořit podmenu, vyberte v náhledu položku, ke které chcete 
podmenu vytvořit a klepněte na tlačítko Indent Menu (odsadit menu). Chcete-li 
položku vrátit do nadřazené úrovně menu, klepněte na tlačítko Outdent menu 
(předsadit menu).

Poznámka: Do podmenu nemůžete odsadit první položku na seznamu.

8. Opakujte kroky 3 až 7, dokud nezadáte všechny požadované položky menu.

9. Klepnutím na tlačítko Next pokračujte.
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Nastavení vzhledu rozbalovacího menu

Jakmile zadáte všechny položky menu, umožní vám průvodce na další obrazovce 
upravit vzhled vašeho menu.

Nastavení vzhledu rozbalovacího menu:

1. U volby Cells (buňky) nastavte buď HTML nebo Image:
Volba HTML nastaví vzhled a pozadí stavů Up a Over pomocí HTML 
formátování.
Volba Image vám umožní použít jako pozadí pro stavy Up a Over obrázky.

2. Vyberte příslušný font a nastavte další atributy textu, jako je velikost, 
zarovnávání a řez písma.

3. V polích Up State a Over State nadefinujte vzhled menu pro jednotlivé stavy:

• Pokud jste v kroku 1 vybrali volbu HTML, vyberte pro každý stav barvu textu 
a pozadí.

• Pokud jste v kroku 1 vybrali volbu Image, vyberte dva obrázky pozadí, které 
se v menu použijí.
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4. Klepnutím na Finish menu dokončete.

Když takto vytvoříte rozbalovací menu, objeví se blízko řezu modrý obrys menu. 
Tento obrys vypadá jako prázdná tabulka připojená na řez modrou čarou chování 
drag-and-drop.

Poznámka: Počet buněk v tomto obrysu odpovídá počtu položek v hlavní úrovni 
menu. Položky podmenu nejsou v tomto obrysu nijak zobrazeny.

Editace rozbalovacího menu

Obsah rozbalovacího menu můžete upravit, přeskládat položky menu nebo 
třeba obrys menu přesunout na jakékoliv místo na plátně. Menu můžete upravit 
opětovným otevřením průvodce Set Pop-Up Menu a aktualizací obsahu menu. 
Průvodce tvorbou menu můžete otevřít dvěma způsoby:

• Poklepejte dvakrát na obrys menu.

• Poklepejte dvakrát na chování Show Pop-Up Menu řezu na panelu Behaviors.

Změna textu položky menu:

1. Otevřete průvodce Set Pop-Up Menu.

2. Vyberte položku menu.
Detaily aktuální položky vyplní políčka Text, Target a Link.

3. Upravte položku menu.

4. Klepněte na tlačítko Change.

Přeskládání položek v menu:

1. Otevřete průvodce Set Pop-Up Menu.

2. V náhledovém seznamu přetáhněte položku menu na nové místo.
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Změna pozice rozbalovacího menu

Obrys menu můžete přesunout, takže menu se může objevit kdekoliv na jevišti. 
Standardně se menu objevuje nad řezem, ke kterému je připojeno.

Přesun rozbalovacího menu:

1. Vyberte řez, ke kterému je připojeno menu.

2. Přetáhněte obrys menu do nové pozice.

Export rozbalovacího menu

Fireworks generuje veškerý JavaScript potřebný k tomu, aby šlo menu zobrazit 
ve webovém prohlížeči. Pokud je dokument exportován, vyexportuje 
se do stejného místa jako ostatní soubory i soubor menu.js s JavaScriptem menu. 
Pokud posíláte své soubory na server, měli byste tento soubor poslat do stejného 
adresáře, kde je stránka, která menu obsahuje. Pokud chcete poslat soubor menu.js 
do jiného adresáře, musíte v HTML kódu z Fireworks přepsat všechny odkazy tak, 
aby odpovídali vlastnímu požadovanému adresáři.

Pokud dokument obsahuje několik rozbalovacích menu, nepotřebuje Fireworks 
žádné další soubory menu.js. Pro celý dokument se používá jediný soubor.

Pokud do menu zadáte i podmenu, vytvoří Fireworks ještě obrázek nazvaný 
Arrow.gif. Na tomto obrázku je malá šipka, která v menu ukazuje, že zde ještě 
existuje podmenu. Nezáleží ba tom, kolik podmenu v dokumentu máte, Fireworks 
vždy použije pouze jeden obrázek se šipkou.

Vytváření rolloverů s nepravidelným tvarem

Fireworks zjednodušuje proces vytváření rolloverů nepravidelných tvarů. 

Fireworks vám umožňuje použít jako rollover jakýkoliv objekt bez psaní dalšího 
javascriptového kódu navíc.

U pravidelných a lépe spravovatelných tvarů je pro vytvoření rolloveru potřeba 
pouze jeden řez. Pro složitější tvary však potřebujete zkombinovat několik řezů 
dohromady, aby se pokryla cílová oblast.
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Fireworks pro znovuvytvoření vzhledu nepravidelného tvaru vyexportuje 
množství řezů a stavů. JavaScript, který Fireworks během exportu vytvoří, spouští 
změnu zobrazení několika řezů najednou. Každý z těchto řezů pak odhalí kousek 
nepravidelného tvaru.

Vytvoření nepravidelných rolloverů:

1. Pomocí nástroje Polygon Slice nakreslete polygonální řezy odpovídající tvaru 
každého objektu.

Fireworks vytvoří množství řezů a automaticky tak nadefinuje mnoho 
obdélníkových řezů pokrývajících oblast nepravidelného řezu.

2. Rollover efekt vytvoříte tak, že každému z takto vzniklých řezů přiřadíte 
chování Swap Image.

3. Vyexportujte soubor. 

Vytváření rolloverů s překrývajícími se řezy

Pokud jsou objekty použité v odpojeném rolloveru nepravidelného tvaru a jsou 
umístěny blízko u sebe, budou se jejich hraniční obdélníky (definované řeznými 
vodítky) často překrývat. Obdélníkové řezy prohazují celý obdélníkový blok 
definovaný zeleným zvýrazněním řezu a to včetně pozadí, které není součástí 
druhého obrázku. Pokud obrázek nahradíte obrázkem z druhého snímku a přitom 
se oba obrázky proplétají přes sebe, může rollover efekt zakrýt část původního 
spouštěcího obrázku. Zabránit tomu můžete použitím nástroje Polygon Slice. 

Poznámka: I když se budou hraniční obdélníky řezů překrývat, umožní vám nástroj 
Polygon Slice zabránit překrytí zeleně zvýrazněných částí řezu.
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Vytvoření Rolloveru s překrývajícími se řezy:

1. Do snímku 1 obrázku vložte obdélníkový řez.

2. Na panelu Frame vyberte snímek 2.

3. Klepnutím na tlačítko Onion Skinning ve spodní části panelu Frames zapněte 
průhled na ostatní snímky, abyste viděli okraj obrázku ve snímku 1. 

4. Použijte nástroj Polygon Slice a nakreslete řez kolem obrázku ve snímku 2. 
Buďte přitom opatrní, abyste se vyhnuli překrytí obrázku ve snímku 1.

5. Pro spouštěcí řez nastavte chování Swap Image.
Pokud si zobrazíte náhled, uvidíte, že se zaměňovaný obrázek objevuje bez 
toho, že by odřezával jakoukoliv část spouštěcího obrázku.

Používání externích souborů jako obrázků pro 
rollovery

Jako zdroj pro rollover můžete použít obrázek ve formátu GIF, animovaný GIF, 
JPEG nebo PNG. Pokud jako zdroj rolloveru vyberete externí zdroj, bude tento 
soubor zobrazen v cílovém řezu ve chvíli, kdy ve webovém prohlížeči dojde 
ke spuštění rolloveru.

Soubor musí mít stejnou šířku a výšku jako řez, do kterého ho chcete nahrazovat. 
Pokud velikost neodpovídá, změní webový prohlížeč velikost obrázku tak, 
aby se vešel přesně do objektu řezu. Takováto změna velikosti však může snížit 
kvalitu obrázku, hlavně u animovaných GIFů.

Pokud jste pokročilým uživatelem v HTML, je pro vás důležité vědět, že cachování 
obrázků může narušit zobrazování animovaných GIFů v rollover stavech. Tomuto 
problému se vyhnete, pokud při nastavování rolloveru deaktivujete volbu Preload 
Images.

Výběr externího souboru jako zdroje pro rollover:

1. V dialogovém okně Swap Image, Nav Bar Over nebo Nav Bar Down vyberte 
volbu Image File.

2. Najděte na disku soubor, který chcete použít.

3. Pokud je to potřeba, deaktivujte volbu Preload Images (pokud je externí soubor 
animovaný GIF).
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Používání hotspotů navrchu řezů pro vytvoření 
komplexní interaktivity

Fireworks vám umožní umístit navrch řezů ještě hotspoty. To vám poskytuje 
velkou flexibilitu při vybírání místa a velikosti spouště rolloveru.

Pokud například chcete, aby se rollover objevil pouze v případě, že kurzor přejede 
přes střed zaměňovaného obrázku, můžete doprostřed řezu umístit menší hotspot, 
který bude fungovat jako spoušť. Tím zabáníte nechtěnému zobrazení náhradního 
obrázku.

Pokud umístíte hotspot navrch řezu, nepřipojují se k řezu žádná chování. Ta jsou 
napojena pouze na hotspot.

Nastavení hotspotu navrchu řezu jako spouště:

1. Nad obrázek, který chcete zaměňovat, vložte řez.

2. Nad oblastí obrázku, která má sloužit jako spoušť, vytvořte hotspot. 

3. Přetáhněte úchyt drag-and-drop chování ze středu hotspotu na řez.
Zobrazí se dialogové okno Swap Image.

4. V roletce Swap Image From vyberte snímek uchovávající rollover obrázek.

5. Klepněte na OK.
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Optimalizace grafiky

Konečným cílem grafického designu pro web je vytvoření skvěle vypadající grafiky, 
která se stahuje tak rychle, jak je to jen možné. Pro dosažení tohoto cíle musíte pro 
váš obrázek vybrat formát s nejvhodnější kompresí  a zároveň zachovat co možná 
nejvíce kvality. Tomuto balancování mezi dvěma protichůdnými požadavky se říká 
optimalizace. Jde o nalezení správného mixu barev, komprese a kvality pro váš 
obrázek.

Ve Fireworks se optimalizační nastavení aplikuje pouze na exportované obrázky. 
Během kreativního procesu tedy můžete pracovat bez omezení a nemusíte se příliš 
starat o omezené použití barev nebo aplikaci efektů, Ve chvíli, kdy jste připraveni 
na export, nastavíte a porovnáte mezi sebou různá optimalizační nastavení 
a vyberete to nejlepší pro váš obrázek.

Optimalizace se ve Fireworks sestává ze tří kroků:

• Výběr nejlepšího souborového formátu. Každý souborový formát používá 
různý způsob komprese barevné informace v souboru. Výběrem správného 
formátu vhodného pro určitý typ grafiky můžete výrazně snížit velikost grafiky.

• Nastavení specifických voleb zvoleného formátu. Každý souborový formát má 
svoji vlastní sadu nastavení pro ovládání komprese obrazu. Například 
u formátu GIF můžete použít dithering a kompenzovat tak menší počet barev 
ve výsledném souboru. U formátu JPEG zase můžete použít vyhlazování, které 
obrázek mírně rozmaže, což pomůže JPEGu soubor lépe zkomprimovat 
a docílit tak menší velikosti souboru.

• Úprava barev v obrázku. Limitováním počtu barev omezíte obrázek na určitou 
množinu barev, které se říká barevná paleta. Z barevné palety se potom 
odříznou nepoužité barvy. Čím méně barev je v paletě, tím méně barev je 
v obrázku a tím menší je výsledný soubor. Snížení počtu barev však může 
snížit i kvalitu obrázku, takže musíte zkusit různé barevné palety, abyste našli 
nejvhodnější rovnováhu mezi kvalitou a velikostí.

KAPITOLA 16

16
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Optimalizace na pracovní ploše

Ovládání optimalizace je ve Fireworks příhodně umístěno na panelech na pracovní 
ploše programu:

• Panel Optimize (optimalizace) obsahuje klíčová nastavení optimalizace.

• Panel Color Table (tabulka barev) zobrazuje barvy v aktuální exportní barevné 
paletě.

• Okno Preview zobrazuje náhled toho, jak bude vyexportovaná grafika vypadat. 

Poznámka: Ve Fireworks jsou všechna optimalizační nastavení na pracovní ploše. 
Obrázek však můžete optimalizovat i přímo při exportu, pokud v menu zvolíte File 
> Export Preview. 

Souborový formát můžete rychle vybrat volbou jednoho z běžných 
optimalizačních nastavení a potom můžete upravit několik specifických nastavení. 
Můžete si upravit i přednastavené volby.

Pokud potřebujete přesnější kontrolu nad optimalizací, než jakou nabízí 
přednastavené volby, můžete si vytvořit vlastní optimalizační nastavení pomocí 
panelu Optimize.

Výběr přednastavené optimalizace:
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Vyberte nastavení z roletky Settings na panelu Optimize.

Dostupné jsou následující volby:

GIF Web 216 si vynutí, aby všechny barvy byly barvy bezpečné pro web. Barevná 
paleta obsahuje až 216 barev.

GIF WebSnap 256 převede všechny barvy, které nejsou bezpečné pro web, na jejich 
nejbližší bezpečné barvy.  barevná paleta obsahuje až 256 barev.

GIF WebSnap 128 převede všechny barvy, které nejsou bezpečné pro web, na jejich 
nejbližší bezpečné barvy.  barevná paleta obsahuje až 128 barev.

GIF Adaptive 256 je barevná paleta obsahující pouze aktuální barvy použité 
v grafice. Tato barevná paleta obsahuje až 256 barev.

JPEG – Better Quality nastaví kvalitu JPEGu na 80 a vyhlazování (smoothing) 
na 0, takže výsledkem je vysoce kvalitní, ale větší grafika.

JPEG – Smaller File nastaví kvalitu JPEGu na 60 a hodnotu vyhlazování na 2. 
Výsledkem je někdy i méně než poloviční než u předchozího nastavení, 
ale se sníženou kvalitou.

Poznámka: Typ nastavení GIFu, který vyberete pro vaši grafiku, může záviset 
na počtu barev v grafice. Paleta se 128 barvami je vyhovující pro obrázky 
s menším počtem barev a jejím výsledkem je menší soubor.

Určení optimalizačních nastavení obrázku:

1. Na panelu Optimize vyberte souborový formát.

2. Nastavte volby specifické pro tento formát, například barvy, dithering nebo 
kvalitu.

3. Pokud je to potřeba, můžete další optimalizační nastavení vybrat z menu 
Options panelu Optimize.
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Určení optimalizačních nastavení pro řezy

Pro každý řez v rozřezaném dokumentu můžete specifikovat jedinečné 
optimalizační nastavení. Můžete například chtít, aby se jedna část vašeho obrázku 
obsahující fotografii exportovala jako JPEG, zatímco jiná část obsahující celistvé 
plochy se bude lépe komprimovat jako GIF. Pokud přes každou část nakreslíte řez, 
můžete pro každý z řezů nadefinovat jiný typ exportu.

Pokud na webové vrstvě dokumentu vyberete objekt řezu, zobrazí se na panelu 
Optimize nastavení optimalizace pro tento řez.

Nastavení optimalizačních nastavení pro řez:

1. Vyberte objekt řezu.
Pokud není objekt řezu viditelný, klepněte na tlačítko Show Hotspots and Slices 
na panelu Tools. Toto tlačítko zobrazuje a skrývá webovou vrstvu.

2. Na panelu Optimize zadejte optimalizační nastavení. 
Vybraný řez je nyní připraven k exportu se specifických optimalizačním 
nastavením.
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Používání překryvu řezu

V pohledech Preview, 2-Up a 4-Up odlišuje překryv řezu aktuálně optimalizovanou 
oblast od zbytku dokumentu. Tento překryv řezu, který je standardně zapnutý, 
zobrazuje oblasti, u kterých se právě neprovádí optimalizace, pomocí tlumeného 
průhledného bílého nádechu. To vám umožňuje jednoduše identifikovat oblasti, 
které právě optimalizujete. Tento překryv řezu (slice overlay) se nezobrazuje 
v pohledu Original.

Pokud se připravujete optimalizovat vybraný řez, jsou zbylé oblasti ztlumené.

Pokud nejsou vybrané žádné řezy, je ztlumená rozřezaná oblast (tj. oblast, kde jsou vytvořeny 
řezy) a provádí se optimalizace zbytku dokumentu.
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V okně Preview, 2-Up nebo 4-Up můžete vybírat oblasti, které chcete 
optimalizovat. Pokud je vybraný určitý řez, je na něm vypnut tlumený bílý překryv. 
Pokud podržíte klávesu Shift a budete klepat nástrojem Pointer, můžete vybrat více 
řezů najednou.

Výběr oblasti pro optimalizaci:

1. Klepněte na záložku Preview, 2-Up nebo 4-Up.

2. Klepněte na oblast, kterou chcete optimalizovat.

Skrytí nebo zobrazení tlumeného překryvu řezů:

V menu zvolte View > Slice Overlay.

Skrytí tohoto tlumeného překryvu je užitečné v pohledech 2-Up a 4-Up, pokud 
chcete porovnat originální obrázek  s viditelnými řezy s optimalizovaným náhledem  
se skrytými řezy.

Ukládání a opětovné používání optimalizačního 
nastavení

Vlastní optimalizační nastavení si můžete uložit pro další použití nebo dávkové 
zpracování. Uložením nastavení uchováte tyto informace:

• Nastavení panelu Optimize

• barevnou paletu na panelu Color Table

• Délku prodlevy mezi jednotlivými snímky animace nastavenou na panelu 
Frames (pouze pro animované GIFy)

Uložení optimalizačního nastavení jako předvolby:

1. Na panelu Optimize klepněte na tlačítko Save.

2. Zadejte jméno optimalizačního nastavení a klepněte na OK.
Uložené optimalizační nastavení se objeví jako poslední volba v roletce Settings 
na panelu Optimize. Tato optimalizační nastavení jsou od nynějška dostupná 
ve všech dokumentech. Soubor s nastavením je uložen v adresáři Fireworks 4\
Configuration\Export Settings.
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Sdílení uloženého optimalizačního nastavení s jiným uživatelem:

Zkopírujte uložený soubor s předvolbami z adresáře Fireworks 4\Configuration\
Export Settings do stejného adresáře na jiném počítači.

Smazání vytvořeného optimalizačního nastavení:

1. Na panelu Optimize vyberte v roletce Settings nastavení, které chcete smazat.

2. V dolní části panelu Optimize klepněte na tlačítko Delete. 
Výchozí optimalizační nastavení Fireworks nemůžete smazat.

Náhled nastavené optimalizace a chování

Okno Preview zobrazuje, jak by váš obrázek vypadal vyexportovaný s aktuálně 
nastaveným optimalizačním nastavením. V okně Preview také můžete ještě před 
exportem vyzkoušet chování a rollover efekty.

Náhled obrázku založený na aktuálním optimalizačním nastavení:

Klepněte na záložku Preview v levém horním rohu okna dokumentu. 

Zobrazení nebo skrytí řezů a jejich vodítek v okně Preview:

Klepněte na tlačítko Show (nebo Hide) Slices and Hotspots na panelu Tools.
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Náhled tlačítek a rolloverů

V okně Preview přesuňte kurzor myši nad rollover nebo tlačítko a podívejte se, 
jak se bude objekt chovat ve webovém prohlížeči.

Poznámka: Abyste si mohli zobrazit náhled tlačítek a rolloverů, musíte si prohlížet 
snímek 1. Na snímek 1 se přesunete pomocí panelu Frames.

Odhadovaný čas stahování

Okno Preview zobrazuje celkovou velikost obrázku a odhadovaný čas stahování 
obrázku. Odhadovaný čas stahování je průměrný čas, za který se na 28.8 kbps 
modemu stáhnou všechny obrázky jednotlivých řezů s stavy rolloverů při aktuálním 
nastavení optimalizace.

Porovnávání optimalizačních nastavení

Pokud chcete porovnat stejnou grafiku pod různými optimalizačními nastaveními, 
můžete pomocí pohledů 2-Up a 4-Up okno rozdělit na dvě nebo čtyři části. 
Každému náhledu můžete potom přiřadit jiné optimalizační nastavení a porovnat, 
jak každé nastavení ovlivňuje obrázek.

Pokud zobrazujete náhled 2-Up nebo 4-Up, je prvním pohledem vždy originální 
obrázek. V tomto pohledu můžete pokračovat v práci a přitom ihned porovnávat 
původní grafiku s optimalizovanou verzí.

Ve spodní části každého náhledu se zobrazuje statistika aktuálního nastavení včetně 
souborového formátu, odhadovaného stahovacího času, velikosti souboru, palety 
a počtu barev.

Okno náhledu
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Porovnání dvou různých optimalizačních nastavení:

1. V horní části dokumentu klepněte na záložku 2-Up nebo 4-Up.

2. Klepnutím vyberte jeden z náhledů v rozděleném okně.

3. Na panelu Optimize a Color Table nastavte požadované optimalizační 
nastavení. 

4. Vyberte další náhled a nastavte jiné optimalizační nastavení, které chcete 
porovnat s tím prvním.
V pohledech 2-Up nebo 4-Up zobrazuje první náhled původní PNG dokument 
z Fireworks, takže ho můžete porovnávat s optimalizovanými verzemi. Tento 
pohled samozřejmě můžete zaměnit za další optimalizovanou verzi.

Přepnutí pohledu na originál na optimalizovaný náhled v okně 

2-Up nebo 4-Up:

1. Vyberte pohled obsahující originál.

2. Pod zobrazeným dokumentem vyberte z roletky Preview volbu Export Preview.

Přepnutí optimalizovaného pohledu zpět na pohled na originál 
v okně 2-Up nebo 4-Up:

1. Vyberte optimalizovaný pohled.

2. Pod zobrazeným dokumentem vyberte z roletky Preview volbu Original (Ne 
Preview).
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Výběr souborového formátu

Ve webovém vývoji jsou běžné grafické formáty GIF a JPEG, protože jsou vysoce 
komprimovatelné. Formát PNG není tak rozšířený, protože ho zatím nepodporují 
všechny prohlížeče.  Komprese zajišťuje rychlejší přenos obrázku přes internet. 
Vzhled grafiky se však může formát od formátu lišit v závislosti na použitých 
metodách komprese. Souborový formát pro svou grafiku tedy volte podle jejího 
obsahu a účelu.

GIF

Graphics Interchange Format, neboli GIF, je na webu oblíbeným grafickým 
formátem, GUF může obsahovat maximálně 256 barev. Tento formát nabízí 
dobrou kompresi obrazu, ale pokud zdrojový obraz obsahuje více jak 256 barev, 
významně se snižuje kvalita obrazu. GIF může také obsahovat průhledné oblasti 
a více snímků pro animaci.

Obrázky komprimované bezztrátovou kompresí normálně neztrácení nic na kvalitě 
GIF komprimace probíhá tak, že se skenují vodorovné řádky pixelů a vyhledávají 
se jednolité oblasti barvy, které se pak zapíšou do souboru ve zkrácené formě. GIF 
je bezztrátový pouze v případě, že obrázek obsahuje pouze několik málo barev, což 
čárové a geometrická grafika obvykle obsahuje. 

Obrázky s jednolitými barevnými plochami se proto nejlépe exportují právě 
do GIFu. GIF je obvykle ideální pro kreslenou grafiku, loga, grafiku s průhlednými 
oblastmi a pro animace. Vektorové objekty jsou nejčastěji ukládány jako GIF.

Poznámka: Dithering a anti-aliasing GIF souborů vede k větším výsledným 
souborům.

JPEG

JPEG byl vyvinut skupinou  Joint Photographic Experts Group speciálně pro 
fotografické obrázky a obrázky s vysokým počtem barev. JPEG podporuje milióny 
barev (24-bitů), zatímco GIF pouze 256 barev. U fotografických obrazových dat 
poskytuje JPEG vždy vyšší kvalitu.

JPEG je ztrátový formát, což znamená, že při komprimaci jsou některá data 
ztracena, čímž se snižuje kvalita výsledného souboru. Obrazová data jsou však 
někdy ztracena jen s malým nebo úplně neznatelným dopadem na kvalitu obrázku.
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Při exportu do JPEGu můžete použít nastavení Quality na panelu Optimize a určit, 
jak velká bude ztráta dat při komprimaci souboru.

• Nastavení na vyšší procento zachovává lepší kvalitu obrazu, ale provádí menší 
komprimaci souboru a tedy vytváří větší soubory.

• Nastavení nižší hodnoty zmenší výsledný soubor, ale vyprodukuje méně kvalitní 
obraz.

Použijte pohledy 2-Up nebo 4-Up a porovnejte vzhled a odhadovanou velikost 
různých nastavení formátu JPEG.

Formát JPEG je nejlepší pro skenované fotografie, obrázky používající textury, 
obrázky s gradienty a jemnými přechody a pro jakékoliv obrázky s větším počtem 
barev než 256.

PNG

Portable Network Graphics, neboli PNG, je všestranný webový grafický 
formát. Ne všechny prohlížeče však bez plug-inů podporují plnou škálu výhod 
charakteristik tohoto formátu. Proto se z něho zatím nestal běžný webový formát. 
PNG podporuje až 32-bitovou barvu, může obsahovat průhlednost nebo alfa kanál 
a může být progresivní. 

PNG komprese je bezztrátová dokonce i ve větších bitových hloubkách. 
Komprimaci probíhá skrze řádky i sloupce pixelů. Pro obrázky s vysokým počtem 
barev poskytuje JPEG excelentní kvalitu. PNG navíc u 32-bitových obrázků 
umožňuje průhlednost, ale velikost souboru je větší.

Formát PNG je nejlepší volbou pro vytváření komplexní živé průhlednosti, pro 
grafiku s vysokým počtem barev a pro lepší komprimaci grafiky s malým počtem 
barev.

PNG je pro Fireworks nativním formátem. PNG soubor z Fireworks však 
obsahuje další doplňkové informace, které se neukládají při exportu PNG pro web.
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Volba optimalizačního nastavení pro GIFy a PNG

Pro GIFy a 8-bitové PNG soubory jsou optimalizační nastavení Fireworks 
podobné.

Výběr barevné hloubky

Barevná hloubka (color depth) je počet barev v exportované grafice. GIF obrázky 
jsou vždy exportovány v 8-bitové barvě (256 barev nebo méně). PNG můžete 
exportovat i při větších barevných hloubkách.

Větší barevné hloubky vytvářejí větší exportované soubory a obvykle nejsou 
pro webovou grafiku ideální. PNG s 24 nebo 32-bitovou hloubkou nebo 
JPEG použijte pro export fotografických obrázků se spojitými polotóny nebo 
s komplexními gradientními přechody mezi barvami.

Výběr barevné palety

Exportované GIF a 8-bitové PNG soubory obsahují barevnou paletu. Barevná 
paleta představuje seznam až 256 barev dostupných v souboru. V grafice se 
objevují pouze barvy definované v barevné paletě, nicméně  některé palety mohou 
obsahovat barvy neobsažené v grafice. Úprava barevné palety během optimalizace 
ovlivňuje barvy v exportovaném obrázku. 
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Použití ditheringu pro napodobení ztracených barev

Dithering napodobuje barvy, které nejsou v aktuální paletě kombinováním dvou 
dostupných barev, které pixel od pixelu střídá. Dithering je užitečný hlavně při 
exportu obrázků s komplexními přechody nebo gradienty, nebo při exportu 
fotografických obrázků do indexovaného obrazového formátu, jako je například GIF.

Dithering může podstatně zvětšit velikost souboru.

Ditherování exportovaného obrázku:

Do políčka Dither na panelu Optimize zadejte procentuální hodnotu 
požadovaného ditheringu.

Nastavení ztráty kvůli zmenšení velikosti souboru

Chcete-li GIF zkomprimovat ještě více, než je obvyklé, nastavte na panelu 
Optimize hodnotu v poli Loss (ztráta). Čím vyšší nastavení vede k menšímu 
souboru, ale také k menší kvalitě výsledného obrazu. 

Nejlepších výsledků se obvykle dosahuje nastavením hodnoty mezi 5 a 15.

Definování průhledných oblastí

Ve formátech GIF a PNG můžete nastavit průhledné oblasti, takže ve webovém 
prohlížeči je skrze tyto oblasti vidět pozadí stránky. 

Odstranění nepoužitých barev z palety

Pokud před exportem odstraníte z obrázku nepoužité barvy, dosáhnete menší 
velikosti souboru.

Odstranění nepoužitých barev:

V menu Options panelu Optimize zvolte příkaz Remove Unused Colors (odstranit 
nepoužité barvy).

Pokud tuto volbu deaktivujete, zahrnou se do obrázku všechny barvy z barevné 
palety, včetně těch, které se v obrázku nevyskytují. 
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Prokládání: stahování po segmentech

Pokud si prokládané (interlaced) obrázky prohlížíte ve webovém prohlížeči, zobrazí 
se nejprve rychle v nízkém rozlišení a potom, jak se postupně stahuje jejich zbytek, 
se mění do plného rozlišení.

Nastavení prokládání u exportovaného GIFu nebo PNG:

V menu Options panelu Optimize zvolte položku Interlaced.

Volba optimalizačního nastavení pro JPEGy

JPEGy se vždy ukládají ve 24-bitové barvě. JPEG komprese se specializuje na 
komprimaci barevných přechodů a gradientů. Tento formát se používá zejména 
pro fotografie a pro obrázky s vysokým počtem barev. Selektivní PEG komprese 
vám umožňuje komprimovat různé části obrázku s různým stupněm komprese.

Selektivní JPEG komprese

Selektivní JPEG komprese vám umožňuje komprimovat různé oblasti JPEGu 
s různým stupněm komprese. Oblast zvýšeného zájmu může být komprimována 
s vysokou kvalitou. Oblasti menší důležitosti (například pozadí) může být 
komprimováno na nižší kvalitu, čímž se zmenší velikost výsledného souboru při 
zachování kvality důležitých oblastí.
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Komprese vybraných oblastí JPEGu:

1. Pomocí výběrového nástroje (Marquee) označte oblast grafiky pro komprimaci.

2. V menu zvolte Modify > Selective JPEG > Save Selection as JPEG Mask 
(uložit výběr jako JPEG masku).

3. V roletce Settings  na panelu Optimize vyberte formát JPEG.

4. Na panelu Optimize klepněte na tlačítko Selective Quality. Objeví se dialogové 
okno Selective JPEG Settings.

5. Zaškrtněte volbu Enable Selective Quality a zadejte do políčka hodnotu 
komprese.
Pokud zadáte nízkou hodnotu, bude se vybraná oblast komprimovat více 
než zbytek obrázku. Pokud zadáte vysokou hodnotu, bude se vybraná oblast 
komprimovat méně než zbytek obrázku.

6. V políčku Overlay Color vyberte barvu zvýraznění oblasti. Tato barva nijak 
neovlivní výstup.

7. Zaškrtněte volbu Preserve Text Quality (zachovat kvalitu textu). Veškerý text se 
pak bude automaticky exportovat s vyšším nastavením komprese, nezávisle na 
hodnotě Selective Quality.

8. Zaškrtněte volbu Preserve Button Quality a symboly tlačítek se budou 
automaticky exportovat s vyšším nastavením kvality. 

9. Klepněte na OK.

Poznámka: Efekt komprese si můžete prohlédnout přepnutím do okna Preview 
nebo volbou z menu File > Preview in Browser (náhled v prohlížeči).
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Úprava oblasti selektivní JPEG komprese:

1. V menu zvolte Modify > Selective JPEG > Restore JPEG Mask as Selection 
(obnovit JPEG masku jako výběr). 
Na ploše se zvýrazní výběr.

2. Použijte nástroj Marquee nebo jiné výběrové nástroje a proveďte požadované 
změny oblasti.

3. V menu zvolte Modify > Selective JPEG > Save Selection as JPEG Mask.

4. Pokud je to potřeba, změňte na panelu Optimize nastavení selektivní kvality.

Poznámka: Chcete-li selektivní masku odebrat, zvolte v menu Modify > Selective 
JPEG > Remove JPEG Mask.

Snížení kvality kvůli zmenšení velikosti souboru

Nastavením Quality na panelu Optimize snižujete nebo zvyšujete kvalitu JPEG 
obrázku. Nižší kvalita se projeví menším výsledným JPEG souborem.

Rozmazání hran pro zvýšení komprese

Na panelu Optimize můžete zaškrtnutím volby Smoothing (vyhlazování) snížit 
velikost souboru JPEG. Vyhlazení rozmaže ostře hrany, které se pomocí JPEGu 
nekomprimují dobře. Nastavením vyšší hodnoty aplikujete větší rozmazání, které 
se v exportovaných JPEG souborech obvykle projevuje zmenšenou velikostí. 

Nastavení hodnoty vyhlazování na 3 obvykle sníží velikost obrázku při stálém 
zachování rozumné kvality.

Zaostření barevných hran a jemných detailů

V menu Options panelu Optimize vyberte volbu Sharpen JPEG Edges (zaostřit 
hrany JPEGu), která vám pomůže zachovat dobré hrany mezi dvěma barvami. 
Volbu Sharpen JPEG Edges použijte při exportu JPEGů s textem nebo jemnými 
detaily, aby se zachovala ostrost těchto prvků.

Volba Sharpen JPEG Edges zvětšuje velikost souboru.
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Progresivní JPEG

pokud chcete vyexportovat progresivní JPEG, zvolte v menu Options panelu 
Optimize volbu Progressive JPEG. Progresivní JPEG se, stejně jako prokládaný 
GIF, zobrazí nejprve v nízkém rozlišení a při tom, jak postupuje stahování dat, 
se postupně zvyšuje jeho kvalita. 

Některé starší aplikace pro editaci bitmapových obrázku neumí progresivní JPEG 
otevřít. 

Optimalizace barevných palet

GIFy a PNG soubory exportované v 8-bitových (nebo menších) barvách používají 
barevnou paletu pro uložení barev použitých v exportovaném obrázku. Barevné 
palety můžete optimalizovat a upravovat na panelu Color Table.

Výběr vhodné barevné palety

Paletu vyberte v roletce Palette na panelu Optimize a potom ji optimalizujte. 

Standardně dostupné jsou následující palety:

Adaptive je uživatelská paleta odvozená od aktuálních barev v dokumentu. 
Adaptivní palety nejčastěji produkují ty nejkvalitnější výsledky.

Web Adaptive je adaptivní paleta, ve které jsou barvy, které jsou blízko barev 
bezpečných pro web, převedeny právě na tyto nejbližší bezpečné barvy. 

Web 216 je paleta 216 barev běžných jak ve Windows, tak na Macintoshi. Tato 
paleta se také často označuje jako bezpečná pro web (websafe), protože produkuje 
poměrně konzistentní výsledky v různých webových prohlížečích na různých 
platformách při prohlížení na 8-bitovém monitoru.

Exact obsahuje přesné barvy použité v obrázku. Exaktní paletu mohou mít pouze 
obrázku s 256 nebo méně barvami. Pokud obsahuje obrázek více jak 256 barev, 
přepne se paleta na adaptivní.

System (Windows) a System (Macintosh) obsahují 256 barev definovaných 
standardy operačních systému Windows a Macintosh.

Grayscale je paleta 256 (nebo méně) stupňů šedi. Výběrem této palety převedete 
exportovaný obrázek na černobílý. 

Black and White je dvoubarevná paleta skládající se pouze z černé a bílé barvy.
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Uniform je matematická paleta založená na RGB hodnotách pixelů.

Custom je paleta, která byla upravena nebo načtena z externího GIFu nebo 
souboru s paletou.

Import palety:

1. Načtěte ACT nebo GIF paletu:

• V menu Options panelu Color Table zvolte Load Palette.

• V roletce Palette na panelu Optimize vyberte volbu Custom.

2. Najděte požadovaný soubor ACT nebo GIF a klepněte na Open.
Barvy z ACT nebo GIF souboru se přidají na panel Color Table.

Nastavení počtu barev paletě

Na panelu Optimize zadejte nebo vyberte počet barev v roletce Colors. Tím 
nastavíte maximální počet barev v barevné paletě exportovaného obrázku. 
Fireworks často optimalizuje obrázek pomocí skutečných barev v obrázku. Počet 
těchto barev může být menší než číslo, které jste nastavili. Číslo v levém dolním 
rohu panele Color Table ukazuje, kolik barev je v současnost v obrázku použito. 
Snížením počtu barev budete vytvářet menší soubory. 

Pokud nastavíte menší počet barev, než je ve skutečnosti použitý, dojde 
k odstranění některých barev, přičemž jako první se odstraní ty nejméně použité. 
Pixely obsahující odstraněné barvy jsou převedeny na nejbližší barvu zbývající 
v paletě. Tím se snižuje velikost, ale zároveň i kvalita obrázku.
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Prohlížení barev v paletě

Panel Color Table zobrazuje barvy v aktuálním náhledu při práci v 8-bitových 
(nebo menších) barvách a umožňuje vám upravovat paletu obrázku. Pokud 
jste v módu Preview, aktualizuje se panel Color Table automaticky. Pokud 
optimalizujete více než jeden řez najednou nebo pokud neoptimalizujete 8-bitový 
formát, zobrazí se panel prázdný.

Na některých barevných vzorcích se objevují různé symboly, které určují určité 
charakteristiky jednotlivých barev:

Symbol Význam
Barva byla upravena a ovlivní pouze exportovaný soubor. Nemění 
to barvu v aktuálním dokumentu.

Barva je zamčená.

Barva je průhledná.

Barva bezpečná pro web (websafe).

Barva má více atributů. V tomto případě jde o barvu bezpečnou 
pro web, která je uzamčená a která byla upravená. 

 

Pokud upravíte dokument, nemusí panel Color Table ukazovat všechny barvy 
v dokumentu. V takovém případě se titulek panelu změní na Color (Rebuild), 
který naznačuje, že musíte barevnou paletu znovu sestavit.
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Aktualizace barev na panelu Color Table tak, aby reflektovaly 
změny v dokumentu:

V menu Options panelu Color Table zvolte Rebuild Color Table (znovu sestavit 
barevnou paletu).

Výběr barvy:

Klepněte ba barvu na panelu Color Table.

Výběr více barev:

Při klepání na barvy podržte stisknutou klávesu Control (Windows) nebo 
Command (Macintosh).

Výběr rozsahu barev:

1. Klepněte na barvu.

2. Stiskněte klávesu Shift a klepněte na druhou barvu.

Zobrazení všech pixelů v dokumentu obsahujících určitou barvu:

1. Klepněte na záložku Preview v okně dokumentu.

2. Na panelu Color Table klepněte a podržte na vzorku barvy.
Pixely obsahující zvolenou barvu se dočasně zvýrazní do té doby, než uvolníte 
tlačítko myši.

Poznámka: Při zobrazování pixelů v pohledu 2-Up nebo 4-Up nejprve klepnutím 
vyberte jiný pohled než na původní obrázek.

Zamykání barev v paletě

Jednotlivé barvy v paletě můžete zamknout, takže se neodstraní nebo nezmění při 
změnách palety nebo při snížení počtu barev v paletě. Pokud zamknete barvy 
a potom přepnete na jinou paletu, přidají se zamčené barvy k této nové paletě.
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Zamknutí vybrané barvy:

Klepněte na tlačítko Lock v dolní části panelu Color Table nebo zvolte příkaz Lock 
Color v menu Options panelu.

Odemknutí barvy:

1. Vyberte zamčenou barvu na panelu Color Table.

2. V dolní části panelu klepněte znovu na tlačítko Lock nebo v menu options 
deaktivujte příkaz Lock Color.

Odemknutí všech barev:

V menu Options panelu Color Table zvolte příkaz Unlock All Colors (odemknout 
všechny barvy).

Editace barev v paletě

Úpravou barev na panelu Color Table můžete změnit barvy v paletě obrázku. 
Úpravou barvy nahradíte všechny instance této barvy v exportovaném obrázku. 
Úpravou barvy nenahradíte barvu v originálním obrázku.

Úprava barvy:

1. Jedním z následujících postupů otevřete systémový vzorník barev:

• Vyberte barvu a klepněte na tlačítko Edit Color v dolní části panelu Color 
Table.

• Poklepejte dvakrát na barvu na panelu Color Table.

2. Pomocí systémového vzorníku barev změňte barvu.
Nová  barva nahradí všechny instance původní barvy v okně náhledu (Preview).

Poznámka: Pokud na barvu na paletě klepnete pravým tlačítkem myši (Windows) 
nebo Control-klepnete (Macintosh), zobrazí se menu editačních možností barvy.
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Nastavení barev bezpečných pro web

Barvy bezpečné pro web jsou barvy, které jsou běžné jak na platformě Windows, 
tak na platformě Macintosh. U těchto barev neprobíhá dithering, pokud jsou 
zobrazeny ve webovém prohlížeči na monitoru s 256 barvami.

Fireworks nabízí několik metod aplikace a používání barev bezpečných pro web.

Vynucení všech barev bezpečných pro web:

Vyberte paletu Web 216.

Vytvoření adaptivní palety, která upřednostňuje barvy bezpečné pro web:

Vyberte paletu Web Adaptive. Nebezpečné barvy, které jsou blízko bezpečných, 
jsou převedeny na tuto nejbližší bezpečnou barvu.

Přeměna barvy na její nejbližší webově bezpečný ekvivalent:

1. Na panelu Color Table vyberte barvu.

2. Klepněte na tlačítko Snap to Websafe.
Změna barvy na bezpečnou barvu na panelu Color Table ovlivní pouze 
exportovaný obrázek, ne skutečný originál.

Ukládání palet

Uživatelské palety si můžete uložit do externích souborů palet. Uložené palety 
můžete použít v jiných dokumentech Fireworks nebo v jiných aplikacích 
podporujících externí palety (například Adobe Photoshop, Macromedia FreeHand 
a Flash 5).

Uložení uživatelské palety barev:

1. V menu Options panelu Color Table zvolte příkaz Save Palette.

2. Zadejte jméno a cílový adresář pro soubor s paletou.

3. Klepněte na Save.
Uloženou paletu můžete načíst na panel Swatches nebo ji použít při exportu 
jiných dokumentů.
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Nastavení průhlednosti

Brvu pozadí a další barvy můžete v exportovaném GIF nebo PNG souboru 
nastavit jako průhledné. Pokud to tak uděláte, je přes tyto průhledné oblasti vidět 
pozadí na webové stránce. Tak můžete vytvořit grafiku, která vypadá jako součást 
stránky, místo toho aby vypadala, jako že leží nad stránkou. 

Ve Fireworks představuje průhlednou oblast šedobílá šachovnice, která je vidět 
v okně Original i v okně Preview.

Jako průhledné můžete nastavit i plátno (pozadí dokumentu). Pokud je barva 
plátna nastavena na průhlednou, můžete průhlednost optimalizovaného obrázku 
nastavit volbou položky Alpha Transparency z roletky Transparency (průhlednost).

Pokud chcete, aby v prohlížeči vypadala průhledná nějaké konkrétní barva, použijte 
nástroj kapátko průhlednosti (v levé dolní části panelu).

Poznámka: Nastavením optimalizovaných barev na průhledné neovlivníte původní 
obrázek, ale jenom jeho exportovanou verzi. Jak bude exportovaný obrázek 
vypadat můžete vidět v okně Preview.

Výběr průhledné barvy:

1. Klepněte na záložku Preview, 2-Up nebo 4-Up. V okně 2-Up nebo 4-Up 
klepněte na jiný pohled než je ten na originální obrázek.

2. Na panelu Optimize zvolte v roletce Transparency v dolní části panelu položku 
Index Transparency.
Plátno v náhledu je náhle průhledné.

3. Chcete-li zprůhlednit jinou barvu, klepněte v dolní části panelu na tlačítko Set 
Transparent.
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Kurzor myši se změní na kapátko.

4. Vyberte barvu, kterou chcete zprůhlednit. 

• Klepněte na vzorek barvy na panelu Color Table.

• Klepněte na barvu v dokumentu.

Přidání nebo odebrání barev z průhlednosti:

1. Klepněte na záložku Preview, 2-Up nebo 4-Up. V okně 2-Up nebo 4-Up 
klepněte na jiný pohled než je ten na originální obrázek.

2. na panelu Optimize klepněte v dolní části panelu na tlačítko Add to 
Transparency (přidat k průhlednosti) nebo na Remove from Transparency 
(odebrat z průhlednosti).

Tlačítko Add to Transparency (přidat k průhlednosti)

Tlačítko Remove from Transparency (odebrat z průhlednosti)

3. Vyberte barvu, kterou chcete přidat k průhlednosti nebo jí naopak odebrat:

• Klepněte na vzorek barvy na panelu Color Table.

• Klepněte a barvu v náhledu.

Vyhlazování hran odpovídající barvě cílového pozadí

Anti-aliasing dělá objekt hladší pomocí přechodu barvy objektu do barvy jeho 
pozadí. Pokud je například objekt černý a pozadí bílé, přidá anti-aliasing několik 
odstínů šedé na pixely obklopující hranu objektu. Tak se vytvoří plynulý přechod 
mezi černou a bílou.

Chcete-li zabráni tomu, aby měl váš exportovaný objekt kolem sebe aureolu, 
nastavte barvu plátna stejnou, jako bude mít cílová stránka, proveďte anti-aliasing 
objektu vůči pozadí a potom nastavte plátno jako průhledné.
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Pokud chcete použít anti-aliasing grafiky u více exportů pro různé barvy pozadí, 
použijte roletku Matte na panelu Optimize. To je užitečné v případě, že se má stená 
grafika objevit na webových stránkách s různou barvou pozadí.

Změna barvy anti-aliasingu na barvu odpovídající cílovému pozadí:

Na panelu Optimize vyberte barvu z roletky Matte. Barvu nastavte co nejblíže 
plánované barvě pozadí cílové webové stránky. 

Poznámka: Toto funguje na objekty s měkkými hranami, které leží přímo nad 
plátnem.

Odstraňování aureol z webové grafiky

Pokud se podíváte na vyhlazenou grafiku s průhlednou barvou pozadí ve webovém 
prohlížeči, objevuje se někdy kolem kraje grafiky obrys špatnou barvou, aureola.

Pokud zprůhledníte plátno, anti-aliasované pixely zůstanou. Pokud pak tuto grafiku 
umístíte na webovou stránku, která má jiné pozadí, než nad kterým byla grafika 
anti-aliasována, jsou okrajové pixely vyhlazeného objektu na webové stránce vidět. 
Tato forma aureoly je obzvláště patrná na tmavých pozadích.

U nativních souborů z Fireworks nebo importovaných souborů z Photoshopu 
se můžete této aureole vyhnout, když nastavíte barvu plátna stejnou, jaká je 
na pozadí webové stránky.

Tuto aureolu je většinou třeba odstranit u GIF souborů, ke kterým vám chybí 
zdrojový soubor. Aureolu odstraníte tak, že světlé pixely anti-aliasingu pomocí 
panelu Optimize zprůhledníte.

V roletce Transparency nastavte volbu Index Transparency a ručně pomocí 
kapátek zprůhledněte barvy tvořící aureolu. 
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Odstranění aureoly z grafiky:

1. Klepněte na záložku Preview, 2-Up nebo 4-Up. V okně 2-Up nebo 4-Up 
klepněte na jiný pohled než je ten na originální obrázek.
Na panelu Optimize nastavte v roletce Transparency volbu Index Transparency.

2. Zvolte nástroj Zoom (lupa) a zvětšete si pohled tak, abyste rozpoznali 
jednotlivé pixely ohraničující okraj objektu.

3. Na panelu Optimize klepněte na tlačítko Add to Transparency. 
Kurzor myši se změní na kapátko.

4. Klepejte postupně ba nevhodné barvy aureoly na okrajích objektu a dělejte je 
průhledné.
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Exportování

Poté, co ve Fireworks vytvoříte grafiku, ji můžete jednoduše optimalizovat 
a exportovat do běžných webových formátů, stejně tak jako do vektorových 
aplikačních formátů. Export a nastavení optimalizace nijak nemění původní 
dokument z Fireworks. 

Předtím, než začnete soubor exportovat pro web, můžete ho optimalizovat. 

Pokud chcete optimalizaci provést až jako část exportního procesu, nabízí vám 
dialogové okno Export Preview všechny optimalizační možnosti kromě selektivní 
JPEG komprese. Dialogové okno Export Preview zobrazuje okamžitě jakékoliv 
provedené změny, takže vidíte, jak tyto změny ovlivňují kvalitu a velikost souboru.

Pokud jste v optimalizaci a exportu pro web nováčkem, použijte Export Wizard – 
průvodce exportem. Průvodce vás provede celým exportním procesem a doporučí 
vám vhodné nastavení.

Grafiku můžete také exportovat do jiných vektorových aplikací, jako je například 
Macromedia FreeHand a Flash nebo Adobe Illustrator a Photoshop. Vektorové 
cesty z Fireworks můžete také do jiných aplikací zkopírovat přes schránku.

KAPITOLA 17

17
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Exportování obrázku

Pokud jste dokončili optimalizaci grafiky na pracovní ploše, vyberte v menu File > 
Export. Tak přeskočíte dialogové okno Export Preview a otevřete přímo dialogové 
okno Export.

Dialogové okno Export

Export obrázku:

1. V menu zvolte File > Export.

2. Vyberte místo, kam chcete uložit HTML soubor.
Obvykle je tím nejlepším místem adresář uvnitř vašeho webového sídla.

3. zadejte jméno souboru.

4. V roletce Save as type zvolte volbu HTML and Images (uložit HTML 
a obrázky).
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Poznámka: Volba Images Only vyexportuje pouze obrázky, ne HTML soubor.

5. Pokud váš obrázek obsahuje řezy, nastavte volby řezů. 

6. Pokud chcete obrázky při uložení umístit ještě do samostatného adresáře, 
zaškrtněte volbu Put Images in Subfolder. Pokud nevyberete žádný vlastní 
adresář, budou obrázky vloženy do automaticky vytvořeného adresáře Images.

Poznámka: Fireworks automaticky vygeneruje vazby mezi HTML souborem a obrázky.

7. Klepněte na Save.

Výsledky exportu

Pokud exportujete i HTML soubor, vytvoří Fireworks následující soubory, 
které vám pomohou při sestavování obrázku na webové stránce:

• Vygeneruje se HTML soubor s JavaScriptem a tabulkami potřebnými pro 
složení rozřezaného obrázku nebo pro vytvoření funkcionality rollover efektů. 
HTML generované z Fireworks vždy obsahuje odkaz na exportovaný obrázek. 
Brva pozadí je nastavená na barvu plátna ve Fireworks nebo na maskovací 
barvu (Matte) grafiky. 

• Vygeneruje se jeden nebo více obrázků v závislosti na tom, kolik řezů jste 
v dokumentu vytvořili a kolik různých stavů mají použité rollovery a tlačítka. 

• Pokud je to potřeba, vygeneruje se soubor Spacer.gif. To je průhledný GIF 
a rozměrech 1x1 pixel, který Fireworks používá jako pomůcku při skládání 
obrázku v HTML tabulce. Ve Fireworks si můžete nastavit, zda se má tento 
obrázek exportovat. 

Ve Fireworks existuje mnoho voleb, které ovlivní způsob, jakým se soubory 
z Fireworks exportují. 
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Export pomocí průvodce exportem (Export Wizard)

Průvodce exportem vás celým procesem provede krok za krokem. Odpovídejte 
na otázky, kam chcete soubory umístit, jaké je jejich zamýšlené použití, atd. 
a průvodce exportem vám doporučí typ souboru a optimalizační nastavení.

Pokud dáváte přednost optimalizaci na velikost cílového souboru, vyexportuje 
průvodce výsledný soubor tak, aby byla jeho velikost ve vámi zadaných mezích.

Průvodce exportem (Export Wizard)

Export grafiky pomocí průvodce exportem:

1. V menu zvolte File > Export Wizard.

2. Na každém panelu odpovězte na položenou otázku a klepnutím na tlačítko 
Continue se vždy přesuňte na další obrazovku.
Na konci se objeví obrazovka Analysis Results (výsledek analýzy) 
s doporučením souborových formátů.

Poznámka: Pokud na prvním panelu vyberete volbu Target export file size (cílová 
velikost exportovaného souboru), bude se obrázek optimalizovat s ohledem na tuto 
maximální velikost souboru.
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3. Klepněte na tlačítko Exit.
V náhledovém okně 2-Up se zobrazují dvě doporučená exportní nastavení. 

4. Klepněte na náhled nastavení, které chcete použít.

5. Podle potřeby si upravte nastavení optimalizace.

6. Klepněte na tlačítko Export.

7. V dialogovém okně Export pojmenujte soubor, nastavte možnosti rozřezávání 
a klepněte na tlačítko Save.

Optimalizace a náhled během exportu

Dialogové okno Export Preview zobrazuje většinu optimalizačních nastavení 
Fireworks a až čtyři náhledová okna exportovaného obrázku. záložka Options 
obsahuje všechny optimalizační nastavení z panelů Optimize a Color Table. 
Na záložce Animation můžete zase najít nastavení z panelu Frames. 

Dialogové okno Export Preview optimalizuje budˇnerozřezaný obrázek, 
nebo všechny řezy pomocí stejného nastavení. Pokud chcete jednotlivé řezy 
optimalizovat individuálně, použijte panel Optimize. Okno Export Preview vám 
také umožní optimalizovat soubor na cílovou velikost. Stačí když klepnete 
na tlačítko Optimize to Size Wizard (průvodce optimalizací na velikost). 
Tato volba je dostupné i v menu Options panelu Optimize. 

Kromě nastavení optimalizace má okno Export Preview i unikátní využití. 
Objevuje se například při nastavení uživatelské optimalizace při dávkovém 
zpracování souborů nebo při spuštění Fireworks z Dreamweaveru za účelem 
optimalizace obrázku na stránce.

Export grafiky pomocí dialogového okna Export Preview:

1. V menu zvolte File > Export.

2. Navolte exportní a optimalizační nastavení.

3. Klepněte na Export.

4. V dialogovém okně Export zadejte jméno souboru, umístění, vyberte formát 
v roletce Save as type a klepněte na Save.
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Náhled optimalizace v okně Export Preview

Oblast náhledu zobrazuje grafiku přesně tak, jak bude vyexportována, 
a odhaduje velikost souboru a čas stahování při současném exportním nastavení. 

Odhadovaná velikost souboru a čas stahování

Uložení exportního nastavení 
do aktivního pohledu

Náhled zvoleného exportního 
nastavení

Uložená sada voleb pro vybraný export

Náhled můžete rozdělit a porovnat tak různá nastavení, abyste našli co nejmenší 
velikost souboru při zachování rozumné míry kvality. Pomocí průvodce Optimize 
to Size Wizard můžete také omezit velikost souboru.

Při exportu animovaných GIFů nebo javascriptových rolloverů se odhadovaná 
velikost souboru bere pro všechny snímky.

Poznámka: Chcete-li zvýšit rychlost překreslování okna Export Preview, deaktivujte 
volbu Preview. Chcete-li zastavit překreslování oblasti s náhledem při změně 
nastavení, stiskněte Esc.
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Náhled optimalizace v dialogovém okně Export Preview:

1. V menu zvolte File > Export Preview.

2. Pomocí nástroje Zoom (lupa) si můžete zvětšit nebo zmenšit zobrazení 
náhledu. Klepnutím lupou náhled zvětšíte. Alt-klepnutím (Windows) nebo 
Option-klepnutím (Macintosh) náhled zmenšíte.

3. Pro posouvání oblasti náhledu použijte buď nástroj Pointer, kterým zatáhněte 
v oblasti náhledu, nebo podržte stisknutý mezerník a zatáhněte v oblasti 
náhledu.
Pokud máte otevřeno více pohledů, zvětšují se všechny pohledy stejnou měrou. 
Všechny pohledy se také současně pohybují tak, aby vždy zobrazovaly stejnou 
část obrázku.

4. Chcete-li v v okně Export Preview porovnávat více optimalizačních nastavení, 
klepněte na tlačítka pro rozdělení pohledu na dva nebo čtyři různé náhledy.
Každé náhledové okno může zobrazovat grafiku s jiným exportním nastavením.

5. Chcete-li optimalizovat grafiku na velikost cílového souboru, klepněte 
na tlačítko Optimize to Size Wizard a zadejte velikost souboru v kilobytech.
Průvodce optimalizací na velikost souboru se pokusí dosáhnout požadované 
velikosti souboru pomocí těchto metod:

• Nastavením kvality JPEG komprese

• Nastavením vyhlazování (smoothing) JPEGu

• Úpravou počtu barev v 8-bitových obrázcích

• Změnou nastavení ditheringu v 8-bitových obrázcích

• Zapnutím nebo vypnutím optimalizačních nastavení

Exportování snímků nebo vrstev do samostatných souborů

Fireworks může pomocí jediného exportního příkazu vyexportovat všechna 
snímku nebo všechny vrstvy v dokumentu do samostatných souborů. Každý 
snímek nebo vrstva se vyexportuje pomocí optimalizačního nastavení z panelu 
Optimize. Jméno každého vyexportovaného souboru bude určeno jménem 
exportované vrstvy nebo snímku.
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Export snímků nebo vrstev do samostatných souborů:

1. V menu zvolte File > Export.

2. Vyberte jednu z následujících možností:

• Chcete-li vyexportovat do samostatný souborů snímky, zvolte Frames to Files.

• Chcete-li vyexportovat do samostatný souborů vrstvy, zvolte Layers to Files.

3. Chcete-li aby se exportované obrázky vždy ořízly na velikost objektů v každém 
snímku, vyberte volbu Trim Images.
Pokud chcete exportovat snímky nebo vrstvy do obrázku se stejnou velikostí, 
jako má dokument, deaktivujte volbu Trim Images.

4. Vyberte cílové umístění a klepněte na Save.

Export oblasti

Pokud chcete vyexportovat pouze část grafiky ve Fireworks, použijte nástroj Export Area.

Export části dokumentu:

1. Na panelu Tools zvolte nástroj Export Area.

2. Myší natáhněte výběr definující část obrázku, kterou chcete vyexportovat.
Po uvolnění tlačítka myši zůstane oblast vybraná.

3. Pokud je to potřeba, změňte velikost exportní oblasti:

• Stiskem klávesy Shift a tažením za úchyt budete měnit velikost exportní oblasti 
proporcionálně.

• Stiskem klávesy Alt (Windows) nebo Option (Macintosh) a tažením za úchyt 
budete měnit velikost exportní oblasti od jejího středu.

• Stiskem kláves Alt+Shift (Windows) nebo Option+Shift (Macintosh) a tažením 
za úchyt budete měnit velikost exportní oblasti od jejího středu při zachování 
proporcí.

• Pomocí kurzorových kláves můžete oblastí posouvat. Pokud stisknete Shift 
a kurzorové klávesy, budete měnit velikost oblasti.
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4. Dvojím poklepáním dovnitř exportní oblasti přejděte do okna Export Preview.

5. V dialogovém okně Export Preview upravte nastavení a klepněte na Export.

6. V roletce Save as vyberte volbu Images Only.

7. V dialogovém okně Export zadejte jméno souboru, cílový adresář a klepněte 
na Save.

Poznámka: Chcete-li akci přerušit bez dokončení vlastního exportu, poklepejte 
dvakrát mimo vyznačenou exportní oblast, stiskněte klávesu Shift nebo vyberte jiný 
nástroj.

Exportování řezu

Někteří webdesigneři vytváří grafiku, kterou pak rozdělují na kousky označované 
jako řezy (slices). Tomuto procesu se říká rozřezávání (slicing). Rozřezávání je 
užitečné například v případě, že chcete některé části obrázku vyexportovat jako 
GIF a jiné jako JPEG, tak aby se těžilo z výhod obou formátů. Jednotlivé kousky 
jsou pak na webové stránce složeny dohromady pomocí HTML tabulky. 

Dialogové okno Export Preview vám umožňuje optimalizovat řezy během 
exportu. Optimalizace v okně Export Preview však optimalizuje všechny řezy 
pomocí stejného nastavení. Jednotlivé řezy můžete optimalizovat individuálně 
na pracovní ploše.

Export vybraných řezů:

1. Dokončete optimalizaci řezů:

• Pokud chcete exportovat bez doplňkové optimalizace, zvolte v menu File > 
Export. 

• Pokud chcete změnit optimalizační nastavení, zvolte v menu File > Export 
Preview. Změňte nastavení a klepněte na Export.

2. Vyberte metodu rozřezávání (roletka Slices):

• Volba None zabraňuje rozřezání dokonce i v případě, že máte v dokumentu 
vytvořené řezy.

• Volba Export Slices vyexportuje řezy definované pomocí objektů řezu. Pokud 
chcete zároveň s řezy exportovat i další grafiku, zaškrtněte volbu Include 
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Areas without Slices (zahrnout i oblasti bez řezů). Pokud jste před exportem 
měli některé řezy vybrané, můžete zaškrtnutím volby Selected Slices Only 
vyexportovat pouze tyto řezy. 

• Volbou Slice Along Guides vyexportujete řezy nadefinované existujícími 
vodícími linkami.

3. V dialogovém okně Export zadejte jméno, cílový adresář a klepněte na Save.
Každý řez je vyexportován s jedinečným optimalizačním nastavením 
definovaným pro každý řez na panelu Optimize.

Poznámka: Chcete-li vyexportovat samostatný vybraný řez, klepněte na něho 
pravým tlačítkem (Windows) nebo klepněte se stisknutou klávesou Control 
(Macintosh) a v menu vyberte Export Selected Slice (exportovat vybraný řez).

Používání spacerů nebo vnořených tabulek při rozřezávání

Když Fireworks pro rozřezaný obrázek vyexportuje HTML, jsou v tomto souboru 
řezy opět sestaveny pomocí tabulky. Tabulku pro rozřezané dokumenty můžete 
vyexportovat pomocí spacerů (rozpěrek) nebo pomocí vnořených tabulek:

• Spacery (rozpěrky) jsou obrázky, které nutí buňky tabulky k tomu, aby byly 
při zobrazené v prohlížeči správně zarovnané.

• Vnořená tabulka je tabulka v tabulce. Vnořené tabulky nepoužívají spacery. 
Tabulka se může v prohlížeči načítat pomaleji, ale protože se v ní nevyskytují 
žádné spacery, je jednodušší úprava jejího HTML kódu.

V každém dokumentu můžete pro rozřezaný objekt nadefinovat jedinečné 
nastavení exportu tabulky. V dialogovém okně HTML Setup můžete stiskem 
tlačítka Set Defaults nadefinovat nastavené volby jako výchozí pro všechny další 
dokumenty.
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Nastavení exportu HTML tabulek z Fireworks:

1. V menu zvolte File > HTML Setup nebo klepněte na tlačítko Options 
v dialogovém okně Export. 

2. Přejděte na záložku Table.

3. V roletce Space width vyberte nastavení:
Nested Tables – no Spacers vytvoří vnořené tabulky bez spacerů.
Single Table – no Spacers vytvoří jedinou tabulku bez spacerů. 
Tato volba může v některých případech způsobit nekorektní zobrazení.
1-Pixel Transparent Spacer použije 1x1 pixelový průhledný GIF jako rozpěrku, 
která je v HTML roztažena podle potřeby.

4. Vyberte barvu buněk textových řezů (Cell Color).

• Výběrem volby Use Canvas Color necháte buňkám stejné pozadí, jako má 
plátno dokumentu.

• Deaktivujte volbu Use Canvas Color a vyberte požadovanou barvu ze vzorníku 
barev.

5. Z roletky Contents vyberte, co se má vložit do prázdných buněk tabulky:
None zanechá buňku úplně prázdnou.
Spacer Image složí do prázdných buněk malý průhledný obrázek spacer.gif.
Non-breaking Space vloží do prázdných buněk HTML tag pro nezlomitelnou 
mezeru. Buňka se bude zobrazovat jako prázdná.

6. Klepněte na OK.

Export vektorových cest

Z Fireworks můžete vyexportovat vektorové cesty a otevřít je v jiných vektorových 
aplikacích včetně Macromedia FreeHandu, Adobe Illustratoru 7 a vyššího, Flashe 
3 a vyššího. Vektorové cesty navíc můžete do vektorových programů přímo 
zkopírovat přes schránku.

Pokud exportujete do FreeHandu nebo Illustratoru, může se vzhled objektů lišit 
v závislosti na tom, jak aplikace podporuje tu kterou funkci Fireworks.
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Ve FreeHandu a Illustratoru nejsou podporovány – a tudíž se v exportovaném 
souboru nezobrazují –  tyto funkce:

• živé efekty

• módy prolínání

• textury, vzory, výplně Web Dither a všechny gradientní výplně (FreeHand)

• objekty řezů a obrazové mapy

• mnoho voleb pro formátování textu

• vodítka, mřížky a barva plátna

• bitmapové obrázky (FreeHand)

Navíc jsou u objektů nastaveny tvrdé hrany v svislý text je převeden na vodorovný.

Exportování do FreeHandu a Illustratoru

Vektorovou grafiku z Fireworks můžete exportovat do FreeHandu nebo 
Illustratoru a použít ji například pro tištěnou grafiku, nebo můžete chtít grafiku 
vyexportovat jen proto, abyste ji upravili v mnohem komplexnějším vektorovém 
programu.

Export grafiky do FreeHandu nebo Illustratoru:

1. V menu zvolte File > Export.

2. V roletce Save as vyberte Illustrator 7.

3. Klepněte na tlačítko Options.

4. V dialogovém okně Illustrator Export Options vyberte jednu z následujících 
voleb:
Volba Export Current Frame Only (exportovat pouze aktuální snímek) zachová 
jména vrstev.
Volba Convert Frames to Layers převede každý snímek z Fireworks do vrstvy 
v exportovaném souboru.
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5. Pokud chcete soubor použít ve FreeHandu, zaškrtněte volbu FreeHand 
Compatible.
Volba FreeHand Compatible vypustí všechny bitmapové obrázky a gradientní 
výplně převede na jednobarevné.

6. Klepněte na OK.

7. V dialogovém okně Export zadejte jméno, cílový adresář a klepněte na Save.

Exportování do Macromedia Flashe

Vektorové cesty můžete z Fireworks exportovat do Macromedia Flashe a použít 
je pro vytvoření animace na vaší webové stránce.

Poznámka: Chcete-li exportovat vektorovou cestu bez jakýchkoliv bitmapových 
charakteristik, zkopírujte a vložte vestu do Flashe pomocí příkazu Edit > Copy as 
Vectors.

Pokud v dialogovém okně Export Options nezaškrtnete volbu Maintain 
Appearance in the Flash SWF (zachovat vzhled v SWF souboru)m ztratí se při 
exportu určité typy formátování. Velikost obrysu a barva zůstanou zachovány.

Při exportu se ztratí toto formátování:

• živé efekty

• průhlednost a módy prolínaní (objekt s průhlednosti je převeden na symbol 
s alfa kanálem)

• masky

• řezy, obrazové mapy a chování (je ztracen například efekt rolloveru)

• některé volby formátování textu, například proklad a bitmapové tahy

• rozostřené okraje

• vrstvy

• anti-aliasing objektů (Přehrávač Flashe aplikuje anti-aliasing na úrovni 
dokumentu. Anti-aliasing je proto při exportu aplikován na dokument.)

Při exportu do Flashe můžete provést několik voleb, které ovlivní, jak jsou objekty 
exportovány.
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Export grafiky do Flashe:

1. V menu zvolte File > Export.

2. V roletce Save as zvolte Flash SWF.

3. Klepněte na tlačítko Options.

4. Chcete-li zachovat vzhled dokumentu, vyberte buď jednu z těchto voleb 
nebo obě dvě:
Volba Objects: Maintain Appearance převede vektorové objekty  na bitmapy 
a zachová tak vzhled aplikovaných obrysů a výplní. Objekt však nejde dále 
editovat.
Volba Text: Convert to Paths převede text na cesty a zachová tak jakékoliv 
uživatelské nastavení prokladu a mezer mezi znaky.

5. Chcete-li zachovat hlavně editovatelnost, uvolte Objects: Maintain Paths 
a Text: Maintain Editability. Objekt půjdou editovat, ale ztratí se jejich efekty 
a formátování.

6. Posuvníkem JPEG Quality nastavte kvalitu JPEG obrázků.

7. Vyberte snímky, které chcete exportovat a rychlost přehrávání 
(počet snímků za vteřinu).

8. Klepněte na OK.

9. V dialogovém okně Export zadejte jméno souboru, cílový adresář 
a klepněte na Save.

Kopírování a vkládání vybraných cest

Chcete-li vybranou vektorovou cestu zkopírovat do jiných aplikací (například 
FreeHand, Flash, Photoshop, Illustrator, CorelDRAW), použijte příkaz Copy as 
Vectors.

Příkaz Copy as Vectors zkopíruje pouze vektorovou cestu.

Zkopírování vybrané vektorové cesty:

1. V menu zvolte Edit > Copy as Vectors.

2. Přepněte se do otevřeného dokumentu  jiné aplikaci.

3. Vložte cestu příkazem Paste (vložit se schránky).
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Exportování do knihoven Dreamweaveru

Položky v knihovnách Dreamweaveru zjednodušují proces editace a aktualizace 
často používaných prvků webových stránek, například navigačních pruhů. Položka 
v knihovně je část HTML kódu umístěného v adresáři Library v kořenovém 
adresáři vašeho webového sídla. Položky knihovny se v Dreamweaveru objevují 
na panelu Library, odkud je můžete přetáhnout a zkopírovat do jakékoliv stránky 
vašeho webu.

Z Fireworks můžete exportovat HTML pro Dreamweaver. 

Export grafiky do Dreamweaveru:

1. V menu zvolte File > Export.

2. V roletce Save as zvolte Dreamweaver Library.

3. Vyberte adresář knihovny Dreamweaveru ve vašem webu. Pokud vybraný 
adresář není adresář knihovny, objeví se dialogové okno Select Folder, kde 
můžete adresář najít nebo vytvořit nový. Vyberte adresář a klepněte na Open.

4. Pokud váš obrázek obsahuje řezy, zvolte nastavení tvorby řezů. 

5. Zvolte volbu Put Images in Subfolder a vyberte samostatný adresář 
pro umístění obrázků.

6. Klepněte na Save.

Exportování do Directoru

Sílu Fireworks a Directoru můžete kombinovat. Fireworks vám umožní exportovat 
grafiku do Directoru 7 a 8 a naimportovat grafiku z Directoru zpět do Fireworks. 
Proces exportu zachová chování a řezy grafiky. Zcela bezpečně můžete exportovat 
rozřezaný obrázek s rollovery nebo dokonce obrázek ve vrstvách. Director tak 
může používat výhod optimalizačních a grafických nástrojů Fireworks 
bez kompromisů v kvalitě.
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Export grafiky do Directoru:

1. V menu zvolte File > Export. 

2. V roletce Save as zvolte Director.

3. V roletce Source vyberte jednu z voleb:
Volba Fireworks Layers vyexportuje každou vrstvu v dokumentu.
Volba Fireworks Slices vyexportuje řezy dokumentu.

4. Pokud chcete exportované obrázky automaticky oříznout na velikost grafiky 
v jednotlivých snímcích, zaškrtněte volbu Trim Images.

5. Zaškrtněte volbu Put Images in Subfolder a vyberte adresář pro uložení 
obrázků.

6. V dialogovém okně Export zadejte jméno souboru, cílový adresář a klepněte na Save.

Poznámka: Pokud vaše verze Directoru neobsahuje podporu pro import obrázků 
z Fireworks, nainstalujte si doplněk Fireworks Import Xtra for Director. Doplněk je 

volně je stažení na stránce http://www.macromedia.com.

Exportování do Photoshopu

Grafika z Fireworks exportovaná do Photoshopu si zachovává při opětovném 
otevření ve Fireworks stejnou editovatelnost, jako jiná grafika z Photoshopu. 
Exportní volby týkající se editovatelnosti, vzhledu a velikosti souboru vám umožní 
nastavit tu nejlepší exportní možnosti pro konkrétní grafiku. Uživatelé Photoshopu 
mohou se svojí grafikou pracovat ve Fireworks a potom opět pokračovat v editaci 
ve Photoshopu.

Export grafiky do Photoshopu:

1. V menu zvolte File > Export.

2. V roletce Save as zvolte Photoshop PSD.

http://www.macromedia.com
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3. V roletce Settings vyberte jednu z následujících voleb:
Volba Maintain Editability over Appearance převede objekty na vrstvy, zachová 
editovatelné efekty a text převede na editovatelné textové vrstvy Photoshopu.
Volba Maintain Fireworks Appearance převede každý objekt do samostatné 
vrstvy ve Photoshopu, efekty převede na objekty a text převede na obrázky.
Volba Smaller Photoshop File zploští všechny vrstvy do jednoho obrázku.
Volba Custom vám umožní nastavit specifické nastavení pro objekty, efekty 
a text. Více informací najdete dále v textu.

4. V dialogovém okně Export zadejte jméno, vyberte cílový adresář a klepněte na Save.

Poznámka: Photoshop 5.5 a předchozí verze nemohou otevřít soubory s více jak 
100 vrstvami. Pokud tedy exportujete obsah, kde je více jak 100 objektů, musíte 
vrstvy smazat nebo sloučit dohromady.

Vlastní nastavení exportu do Photoshopu

Při exportu souboru do Photoshopu si můžete vybrat vlastní uživatelské nastavení 
pro export objektů, efektů a textu.

Úprava nastavení  exportu do Photoshopu:

1. V dialogovém okně Export vyberte v roletce Settings volbu Custom.

2. V roletce Objects vyberte jednu z následujících voleb:
Convert to Photoshop Layers převede jednotlivé objekty z Fireworks na vrstvy 
ve Photoshopu.
Flatten Each Fireworks Layer zploští každou vrstvu ve Fireworks do vrstvy 
ve Photoshopu.

3. V roletce Effects na stavte jednu z následujících voleb:
Maintain Editability převede živé efekty z Fireworks na jejich ekvivalenty 
ve Photoshopu. Pokud podobný efekt ve Photoshopu neexistuje, je ztracen,
Render Effects převede efekty do objektů. Efekty nejsou ve Photoshopu 
editovatelné.

4. V roletce Text vyberte jednu z následujících voleb:
Maintain Editability převede text na textovou vrstvu ve Photoshopu. Textové 
formátování, které není Photoshopem podporováno, je ztraceno.
Render Text převede text na bitmapový obrázek.
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Export do formátu WBMP

Wireless Bitmap (WBMP) je grafický formát používaný v mobilních zařízeních. 
Tento formát je konkrétně používán na WAP stránkách.

Export grafiky do formátu WBMP:

1. Na panelu Optimize zvolte v roletce Format typ WBMP.

Poznámka: Protože jde o 1-bitový formát, budou vidět jenom dvě barvy – černá a bílá.

2. V menu zvolte File > Export.

3. Vyberte formát v roletce Save as type. Obvykle jde o volbu Images Only 
(pouze obrázky) nebo o HTML and Images (HTML a obrázky).

4. V dialogovém okně Export zadejte jméno, vyberte cílový adresář a klepněte na Save.

Exportování CSS vrstev

Kaskádní styly (Cascading Style Sheets, CSS) vám umožňují vytvářet menší 
a rychlejší webové stránky. CSS vrstvy vám umožní vytvořit styly, jak vypadají 
jednotlivé prvky (například hlavičky nebo odkazy). Tento druh exportu většinou 
používají pouze profesionálové, kteří s HTML souborem po exportu dále pracují. 
CSS vrstvy se mohou překrývat a mohou se skládat jedna na druhou. Běžný 
HTML výstup z Fireworks žádné překrývání neumožňuje.

Export grafiky do CSS vrstev:

1. V menu zvolte File > Export.

2. V roletce Save as type vyberte CSS Layers.

3. V roletce Source vyberte jedno z následujících nastavení:
Fireworks Layers vyexportuje do CSS vrstev všechny vrstvy z Fireworks.
Fireworks Frames vyexportuje do CSS vrstev všechny snímky z Fireworks.
Fireworks Slices vyexportuje do CSS vrstev jednotlivé řezy z dokumentu.

4. Pokud chcete exportované obrázky a vrstvy automaticky oříznout na velikost 
objektů, zatrhněte volbu Trim Images.
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5. Zaškrtněte volbu Put Images in Subfolder a určete adresář, kam se mají umístit 
exportované obrázky. 

6. V dialogovém okně Export zadejte jméno, vyberte cílový adresář a klepněte na Save.

Exportování pro Lotus Domino Designer

Výsledkem exportu obrázků pro Lotus Domino Designer je jeden velký soubor. 
Tento soubor má buď formát GIF nebo JPEG, podle toho, co nastavíte před exportem.

Export grafiky pro Domino Designer:

1. V menu zvolte File > Export.

2. V roletce Save as type vyberte Lotus Domino Designer.

3. V roletce Source vyberte jedno z následujících nastavení:
Fireworks Layers vyexportuje do souboru čtyři vrchní vrstvy z Fireworks.
Fireworks Frames vyexportuje do čtyři vrchní snímky z Fireworks.
Fireworks Slices vyexportuje první čtyři snímky každého řezu do samostatného 
souboru.

4. Pokud chcete exportované obrázky automaticky oříznout na velikost objektů 
v každém snímku, zatrhněte volbu Trim Images.

5. V dialogovém okně Export zadejte jméno, vyberte cílový adresář a klepněte na Save.

Používání příkazu Update HTML

Příkaz Update HTML aktualizuje buď obrázky a HTML vygenerované 
ve Fireworks nebo jenom obrázky.
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Aktualizace HTML:

1. V menu zvolte File > Update HTML.

2. V dialogovém okně Locate HTML File vyberte HTML soubor, který chcete 
aktualizovat.

3. Klepněte na Open.

4. Pokud v souboru není nalezeno HTML vygenerované ve Fireworks, přidáte 
klepnutím na OK nové HTML na konec dokumentu.

5. Pokud je v souboru nalezeno HTML z Fireworks, vyberte jednu z následujících 
voleb a klepněte na OK:
Replace Images and their HTML (nahradit obrázky a jejich HTML) nahradí 
kompletně předchozí verzi HTML.
Update Images Only zaktualizuje pouze obrázky.

6. Otevře se dialogové okno Select Images Folder. Vyberte adresář, kam chcete 
umístit obrázky a klepněte na Open.

Editace souborů Fireworks umístěných do Dreamweaveru

Obrázky z Fireworks umístěné do Dreamweaveru můžete editovat přímo 
z Dreamweaveru. GIFy a JPEGy z Dreamweaveru můžete editovat pomocí 
zdrojového souboru Fireworks, nebo můžete optimalizovat obrázek bez ovlivnění 
jeho zdroje. 

Předtím, než začnete s editací, se ujistěte, že je Fireworks v Dreamweaveru 
nastavený jako externí editor. 

Pro aktualizaci grafiky z Fireworks zvolte v Dreamweaveru příkaz Edit and Launch 
Fireworks. U ostatních HTML editorů upravte původní zdrojový soubor ve 
Fireworks a HTML a obrázky aktualizujte pomocí příkazu Update HTML.

Dialogové okno HTML Setup

Dialogové okno HTML Setup vám umožňuje nadefinovat jakým způsobem 
Fireworks exportuje HTML. Toto nastavení může být specifické pro každý 
dokument nebo může být použito jako výchozí nastavení při všech exportech 
HTML. Změny provedené na záložce Document Specific se vztahují pouze 
k aktuálnímu dokumentu. Na záložkách General a Table jsou globální nastavení.
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Nastavení exportu HTML z Fireworks:

1. V menu zvolte File > HTML Setup nebo klepněte na tlačítko Options 
v dialogovém okně Export. 

2. Na záložce General nastavte následující volby:

• V roletce HTML Style vyberte styl exportovaného HTML.

• V roletce Extension vyberte příponu souboru nebo zadejte svoji vlastní.

• Chcete-li do souboru vkládat HTML komentáře označující začátek a konec 
vkládaného kódu, zaškrtněte volbu Include HTML Comments.

• Pokud chcete, aby jména exportovaných souborů včetně přípon byly malými 
písmeny, zaškrtněte volbu Lowercase File Name.

3. Na Záložce Table nastavte způsob vytváření HTML tabulek.

4. Na záložce Document Specific nastavte následující možnosti:

• V roletkách v části File Names nastavte způsob automatického pojmenovávání řezů.

• Zadejte text do pole Alternate Image Description. Tento alternativní text 
se objeví na stránce místo obrázku  ve chvíli, kdy se obrázek ještě stahuje 
nebo když jeho stahování selhalo. V některých prohlížečích se tento text také 
objevuje jako bublinková nápověda v místě, kdy myš najede na obrázek. Tento 
text tvoří i pomůcku pro zrakově postižené uživatele.

• Pokud používáte HTML dokumenty bez rámců (frames) zaškrtněte volbu 
Multiple Nav Bar HTML Pages.

5. Pokud chcete toto nastavení uložit jako výchozí globální nastavení, klepněte 
na tlačítko Set Defaults.

6. Klepněte na OK.
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