Dialogové okno Nastavení ovladače Microsoft ODBC for Oracle

Dialogové okno Nastavení ovladače Microsoft ODBC for Oracle obsahuje následující ovládací prvky:

Název zdroje dat | Název identifikátoru, který slouží v aplikacích k volání nebo použití tohoto zdroje dat. Uživatelé mohou zdroje dat pojmenovat pomocí libovolné metody popisu. Ve výchozím nastavení je toto pole prázdné, je však požadováno.
Popis | Obsahuje podrobnější informace. Ve výchozím nastavení je toto pole prázdné.
Uživatelské jméno | Uživatelské jméno pro zdroj dat.
Server | Alias databáze vytvořený v programu SQL*Net Easy Configuration nebo připojovací řetězec. (Informace o vytváření řetězce najdete v části Atributy připojovacího řetězce. Popisy připojovacích řetězců osobních a vzdálených databází najdete v souboru nápovědy Oracle.)
Převod | Po klepnutí na tlačítko Vybrat zvolte převaděč načtených dat. Výchozí nastavení je Žádný převaděč.
Výkon Možnost Velikost vyrovnávací paměti určuje velikost paměti (v bajtech) přidělené pro příjem načtených dat. Ovladač optimalizuje načítání tak, že jedno načtení ze serveru Oracle vrátí dostatečný počet řádků k naplnění vyrovnávací paměti o zadané velikosti. Vyšší hodnoty mají za následek zvýšení výkonu při načítání velkého množství dat.

Políčko Zahrnout klauzuli REMARKS ve funkcích katalogu určuje, zda ovladač bude vracet u výsledné sady SQLColumns sloupce klauzule REMARKS. Zrušením zaškrtnutí tohoto políčka dosáhnete vyššího výkonu.

Možnost Zahrnout klauzuli SYNONYMS ve sloupcích SQLColumns určuje v případě nastavení na hodnotu True (1), že volání rozhraní API SQLColumns() vrací informace o sloupcích tabulek, pohledů a synonym. Tento ovladač načítá informace o sloupci rychleji v případě, že tato hodnota není nastavena (nebo pokud je nastavena na hodnotu 0).
Vlastní úpravy Možnost Zajistit standard ODBC DayOfWeek nastaví u výsledné sady formát určitého dne v týdnu. Zaškrtnuté políčko udává, že se výsledná sada řídí formátem ODBC pro den v týdnu (neděle = 1, sobota = 7). V opačném případě se řídí formátem Oracle pro den v týdnu (pondělí = 1, neděle = 7).

Zaškrtávací políčko Funkce SQLDescribeCol vždy vrátí hodnotu určující přesnost určuje, zda volání funkce SQLDescribeCol vrátí hodnotu přesnosti 130 v případě, že tyto informace nejsou poskytovány serverem Oracle. Některé typy číselných dat Oracle nemají pevnou přesnost, jako například data vypočítávaných číselných sloupců a sloupců definovaných jako klauzule NUMBER bez přesnosti nebo měřítka. Pokud není toto políčko zaškrtnuto, vrátí ovladač u těchto typů sloupců hodnotu 0.

Poznámka: Podrobné a programové informace o tomto ovladači naleznete na serveru msdn.microsoft.com. Otevřete knihovnu MSDN Library Online, část Platform SDK (Sada SDK pro používanou platformu), kde naleznete informace o sadě SDK pro součásti MDAC, jejichž součástí je oddíl s názvem ODBC Drivers (Ovladače ODBC). Ovladač Microsoft ODBC for Oracle podporuje pouze aplikaci SQL*Net 2.3 a novější. Další informace o produktech společnosti Oracle najdete v dokumentaci Oracle. Jiné informace můžete najít v částech Verze podporovaného softwaru a Podpora produktu v tomto souboru s nápovědou.


.topic 4209
Název identifikátoru, který slouží v aplikacích k volání nebo použití tohoto zdroje dat. Ve výchozím nastavení je toto pole prázdné, je však požadováno.

.topic 4210
Podrobnější informace. Ve výchozím nastavení je toto pole prázdné.

.topic 4201
Množství dat (v bajtech), které se aplikace pokusí načíst současně.

.topic 4202
Zadejte uživatelské jméno databáze. Jedná se o ID uživatele pro databázi.

.topic 4203
Nastaví u výsledné sady formát určitého dne v týdnu; ODBC nebo Oracle.

.topic 4204
Zaškrtnutím tohoto políčka zadáte, že ovladač bude vracet u výsledné sady SQLColumns sloupce Poznámky. Zrušením zaškrtnutí tohoto políčka dosáhnete vyššího výkonu.

.topic 4205
Určuje, zda ovladač bude vracet informace o sloupci u klauzule SYNONYMS.

.topic 4206
Zadejte připojovací řetězec modulu serveru Oracle, ke kterému chcete získat přístup.

.topic 4207
Po klepnutí vyberte převaděč načtených dat.

.topic 4208
Pokud je toto políčko zaškrtnuto, vrátí volání funkce SQLDescribeCol hodnotu přesnosti 130 v případě, že tyto informace nejsou poskytovány serverem Oracle. V opačném případě vrátí ovladač u těchto typů sloupců hodnotu 0.


Atributy připojovacího řetězce

Namísto dialogového okna mohou některé aplikace vyžadovat připojovací řetězec, který určuje (pomocí příslušných atributů) způsob připojení ovladače ke zdroji dat. Jednotlivé atributy označují určité informace vyžadované ovladačem pro úspěšné připojení. Připojovací řetězec má vždy následující formát:

"DSN=<název zdroje dat> ;[SERVER=<hodnota>] [;PWD=<hodnota>] [;UID=<hodnota>] [;<Atribut>=<hodnota>]"

Poznámka: Ovladač Microsoft ODBC for Oracle podporuje také parametr CONNECTSTRING z první verze (1.x) ovladače.

Nezadáte-li atributy UID, PWD, SERVER (nebo CONNECTSTRING) a DRIVER, je nutné zadat název zdroje dat. Všechny ostatní atributy jsou však volitelné. Pokud není atribut zadán, je jako výchozí použit atribut zadaný na kartě DSN v dialogovém okně Správce zdrojů dat ODBC.

Následující tabulka popisuje atributy připojovacího řetězce.

Atribut | Popis | Výchozí hodnota
DSN Název zdroje dat uvedený v tabulce Uživatelské DSN nebo Systémové DSN v dialogovém okně Správce zdrojů dat ODBC. ""
PWD Heslo serveru Oracle, k němuž chcete získat přístup. Tento ovladač podporuje omezení Oracle na 30 znaků a zahrnuje stejná omezení, jaká platí pro hesla Oracle. ""
SERVER Řetězec serveru Oracle, k němuž chcete získat přístup.

Řetězec může představovat zástupný název databáze Oracle, položku v souboru Tnsnames.ora nebo alias, který bude připojen k příslušném serveru pomocí serveru Oracle Names Server.

Zástupný název databáze lze nastavit pomocí programu Oracle SQL*Net Fast Configuration (nebo programu Net8 Easy Configuration pro databáze Oracle8). Další informace o připojení k databázi Oracle naleznete v dokumentaci Oracle.

 ""
UID Uživatelské jméno pro server Oracle. Tento atribut nemusí být volitelný. Některé databáze a tabulky jej mohou vyžadovat za účelem zabezpečení.

Ověření operačního systému serveru Oracle označíte zadáním UID=/;.

""
BUFFERSIZE Optimální velikost vyrovnávací paměti k načítání sloupců.

Ovladač optimalizuje načítání tak, že jedno načtení ze serveru Oracle vrátí dostatečný počet řádků k naplnění vyrovnávací paměti o této velikosti. Vyšší hodnoty mají za následek zvýšení výkonu v případě načítání velkého množství dat.

 65535
SYNONYMCOLUMNS | Je-li tato hodnota True (1), vrátí volání rozhraní API SQLColumns informace o sloupcích Tabulky, Pohledy a Synonyma. V opačném případě vrátí rozhraní SQLColumns pouze sloupce tabulek a pohledů. Pokud tuto hodnotu nenastavíte, dosáhnete vyššího výkonu. | 1
REMARKS | Pokud je tato hodnota True (1), bude ovladač vracet u výsledné sady rozhraní SQLColumns sloupce Poznámky. Pokud tuto hodnotu nenastavíte, dosáhnete vyššího výkonu. | 0
StdDayOfWeek | Zajistí standard ODBC u skaláru DAYOFWEEK. Toto je výchozí hodnota. Uživatelé požadující lokalizovanou verzi mohou chování změnit tak, že bude použita libovolná hodnota vrácená serverem Oracle. | 1

Poznámka: Hodnoty atributů mohou rozlišovat velká a malá písmena.

Příklady

Následující připojovací řetězec provádí připojení ke zdroji dat Employees (Zaměstnanci) pomocí serveru Oracle mickey.world uživatele Oracle cindy:

"DSN=Employees;UID=cindy;PWD=secret;SERVER=mickey.world"

Následující spojovací řetězec provádí připojení ke zdroji dat Payroll (Zúčtování mezd a platů) pomocí ověření operačního systému serveru Oracle a serveru Oracle s názvem moola:

"DSN=Payroll;UID=/;PWD=;SERVER=moola"


Dialogové okno Připojení ovladače Microsoft ODBC for Oracle

Dialogové okno Připojení ovladače Microsoft ODBC for Oracle obsahuje následující ovládací prvky:

Uživatelské jméno | Jméno použité k připojení k databázi Oracle.
Heslo | Heslo použité k připojení k databázi Oracle zahrnující stejná omezení, jaká platí pro hesla Oracle.
Server | Zadejte alias databáze Oracle, položku v souboru Tnsnames.ora nebo alias, který bude připojen k příslušném serveru pomocí serveru Oracle Names Server. Další informace o připojení k databázi Oracle naleznete na serveru msdn.microsoft.com. Otevřete knihovnu MSDN Library Online, část Platform SDK, kde naleznete informace o sadě SDK pro součásti MDAC, jejichž součástí je oddíl s názvem ODBC Drivers (Ovladače ODBC). Informace o souboru Tnsnames.ora naleznete v dokumentaci Oracle.


Podpora produktu

Podrobné a programové informace o tomto ovladači naleznete na serveru msdn.microsoft.com. Otevřete knihovnu MSDN Library Online, část Platform SDK, kde naleznete informace o sadě SDK pro součásti MDAC, jejichž součástí je oddíl s názvem ODBC Drivers (Ovladače ODBC).

Společnost Oracle poskytuje dokumentaci s nápovědou zaměřenou na instalaci a použití klientského softwaru Oracle.


Verze podporovaného softwaru

Ovladač Microsoft ODBC for Oracle podporuje:

  • Microsoft Windows 95/98, Microsoft Windows NT 4.0 nebo Windows 2000,

  • Oracle Call Interface 7 (OCI7),

  • SQL*Net 2.3 nebo novější,

  • ODBC 2.x a starší. (Je možné nainstalovat nejnovější verzi rozhraní ODBC, nebudou však využívány všechny jeho funkce.)


Rozhraní SQLColumns

Vytváří výslednou sadu pro tabulku, která představuje seznam sloupců zadané tabulky nebo tabulek. Při požadavku na sloupce synonyma PUBLIC je nutné nastavit atribut připojení SYNONYMCOLUMNS a jako argument szTableOwner zadat prázdný řetězec. Při vracení sloupců pro synonyma PUBLIC, nastaví ovladač sloupec TABLE NAME na prázdný řetězec. Výsledná sada obsahuje na konci každého řádku další sloupec s názvem ORDINAL POSITION. Tato hodnota představuje pořadové číslo polohy sloupce v tabulce.