Karta Zprostředkovatel

Pomocí karty Zprostředkovatel můžete vybrat zprostředkovatele OLE DB pro příslušný typ dat, ke kterým chcete získat přístup. Některé aplikace vybrání zprostředkovatele či změnu současného zprostředkovatele neumožňují. Tato karta se zobrazí pouze v případě, že daná aplikace povoluje změnu zprostředkovatele OLE DB. Propojení dat je možné uložit spolu s aplikací nebo jako samostatný soubor. Další informace o vytváření propojení dat naleznete v části „Creating a Data Link“ (Vytváření propojení dat) v sadě SDK pro součásti MDAC.

Možnost | Popis
Zprostředkovatelé OLE DB | Zobrazí seznam všech zprostředkovatelů OLE DB zjištěných v počítači. Další informace týkající se zprostředkovatelů naleznete v části „Microsoft OLE DB Providers Overview“ (Zprostředkovatelé Microsoft OLE DB – přehled) v sadě SDK pro součásti MDAC.
Další | Zobrazí kartu Připojení pro vybraného zprostředkovatele OLE DB.

Poznámka: Kartu Připojení můžete zobrazit přímo poklepáním na požadovaného zprostředkovatele. Další informace o propojení dat naleznete v části Odkazy na rozhraní API pro propojení dat.


Karta Upřesnění

Pomocí karty Upřesnění můžete zobrazit a nastavit další inicializační vlastnosti dat.

Karta Upřesnění v dialogovém okně Vlastnosti Data Link je specifická pro daného zprostředkovatele a zobrazuje pouze inicializační vlastnosti požadované vybraným zprostředkovatelem OLE DB. Další informace o upřesnění inicializačních vlastností naleznete v dokumentaci daného zprostředkovatele OLE DB.

Následující tabulka popisuje nejčastější možnosti inicializace.

Možnost | Popis
Úroveň zosobnění Úroveň zosobnění, kterou je server oprávněn použít při zosobnění klienta. Tuto vlastnost je možné využít pouze v případě síťových připojení jiných než spojení vzdáleného volání procedur (Remote Procedure Call – RPC). Úrovně zosobnění jsou podobné jako u RPC. Hodnoty této vlastnosti odpovídají úrovním zosobnění, které mohou být zadány u ověřených spojení RPC, lze je však použít u jiných druhů připojení. Vyberte některou z následujících úrovní:
  • Anonymous – Klient je vůči serveru anonymní. Proces serveru nezíská informace o identifikaci klienta a nemůže jej zosobnit.

  • Delegate – Proces může zosobnit rámec zabezpečení pro klienta jeho jménem. Proces serveru může také jménem klienta odesílat volání jiným serverům.

  • Identify – Server může získat identitu klienta. Server může zosobnit klienta pro seznam přístupových práv (ACL), ale nemá na rozdíl od klienta přístup k systémovým objektům.

  • Impersonate – Server může zosobnit rámec zabezpečení pro klienta jeho jménem. Tato informace je získána při vytvoření připojení a nikoli při každém volání.
Úroveň ochrany Úroveň ochrany dat posílaných mezi klientem a serverem. Tuto vlastnost je možné využít pouze v případě síťových připojení jiných než spojení vzdáleného volání procedur (RPC). Úrovně ochrany jsou podobné jako u RPC. Hodnoty této vlastnosti odpovídají úrovním ochrany, které mohou být zadány u ověřených spojení RPC, lze je však použít u jiných druhů připojení. Vyberte některou z následujících úrovní:
  • Call – Ověří zdroj dat na začátku každého požadavku klienta na server.

  • Connect – Provede ověření pouze při vytvoření připojení k serveru ze strany klienta.

  • None – Neprovádí žádné ověřování dat posílaných na server.

  • Pkt – Ověřuje, zda všechna přijímaná data pochází od klienta.

  • Pkt Integrity – Ověřuje, zda všechna přijímaná data pochází od klienta a zda nebyla během přenosu změněna.

  • Pkt Privacy - Ověřuje, zda všechna přijímaná data pochází od klienta, zda nebyla během přenosu změněna a pomocí šifry zabezpečí soukromí dat.
Časový limit připojení | Určuje dobu (v sekundách), po kterou zprostředkovatel OLE DB čeká na dokončení inicializace. Při překročení této doby se zobrazí chybová zpráva a připojení není vytvořeno.
Oprávnění přístupu Vyberte jedno nebo více následujících oprávnění:
  1. Read – Pouze čtení.

  2. ReadWrite – Čtení a zápis.

  3. Share Deny None – Nikomu nemůže být zamítnut přístup ke čtení nebo zapisování.

  4. Share Deny Read – Zabrání ostatním v otevření režimu čtení.

  5. Share Deny Write (Sdílení se zamítnutím zápisu) – Zabrání ostatním otevírat v režimu zapisování.

  6. Share Exclusive – Zabrání ostatním v otevření režimu čtení/zápis.

  7. Write – Pouze zapisování.

Poznámka: Další informace o inicializaci propojení dat naleznete v části Odkazy na rozhraní API pro propojení dat.


Karta Vše

Pomocí karty Vše můžete zobrazit a upravit všechny inicializační vlastnosti OLE DB dostupné pro daného zprostředkovatele OLE DB. Vlastnosti se mohou lišit v závislosti na konkrétním zprostředkovateli OLE DB. Další informace o vlastnostech inicializace naleznete v dokumentaci daného zprostředkovatele OLE DB.

Možnost | Popis
Seznam inicializačních vlastností | Zobrazí seznam všech vlastností a jejich současných hodnot.
Upravit hodnotu | Otevře dialogové okno Úprava hodnoty vlastnosti pro vybranou vlastnost.

Poznámka: Dialogové okno Úprava hodnoty vlastnosti je možné otevřít poklepáním na požadovanou vlastnost. Další informace o inicializaci propojení dat naleznete v části Odkazy na rozhraní API pro propojení dat.


Karta Připojení

Pomocí karty Připojení můžete zadat způsob propojení vašich dat pomocí zprostředkovatele OLE DB.

Karta Připojení v dialogovém okně Vlastnosti Data Link je specifická pro daného zprostředkovatele a zobrazuje pouze vlastnosti spojení požadované vybraným zprostředkovatelem OLE DB. Vlastnosti připojení umožňují zadat umístění dat a způsob, jak se k datům připojit. Další informace naleznete v dokumentaci daného zprostředkovatele OLE DB.

V následující tabulce jsou popsány nejčastější možnosti připojení.

Možnost | Popis
Zdroj dat | Zadejte název zdroje dat, ke kterému chcete získat přístup – většinou se jedná o název serveru.
Umístění | Zadejte umístění zdroje dat, ke kterému chcete získat přístup – většinou se jedná o název databáze.
Použít integrované zabezpečení Windows NT | Klepnutím použijete ověřovací službu, která slouží k vaší identifikaci. Tuto službu je možné využít pouze v případě, že zprostředkovatel OLE DB ověřovací službu podporuje. Jedná se například o zprostředkovatele OLE DB pro SQL Server. Chcete-li použít ověřovací službu, je nutné mít rovněž oprávnění pro daný zdroje dat.
Použít specifické uživatelské jméno a heslo | Klepnutím použijete zadané uživatelské jméno a heslo k ověření přihlašovacích informací pro zdroj dat.
Uživatelské jméno | Zadejte ID uživatele, které bude ověřeno při přihlášení ke zdroji dat.
Heslo | Zadejte heslo, které bude ověřeno při přihlášení ke zdroji dat.
Prázdné heslo | Umožňuje danému zprostředkovateli vynechat v připojovacím řetězci heslo.
Povolit uložení hesla | Umožňuje uložit heslo v rámci připojovacího řetězce. To, zda bude heslo obsaženo v připojovacím řetězci, závisí na možnostech volané aplikace. Poznámka: Uložené heslo je vráceno a uloženo v neskryté a nezašifrované podobě.
Zadejte požadovaný počáteční katalog | Zadejte katalog, ke kterému chcete mít v rámci připojení přístup.
Testovat spojení | Klepnutím vyzkoušejte připojení k zadanému zdroji dat. Pokud se připojení nezdaří, přesvědčte se o správnosti nastavení. Nezdaření operace mohou způsobit například pravopisné chyby nebo nerozlišování malých a velkých písmen.

Poznámka: Další informace o propojení dat naleznete v části Odkazy na rozhraní API pro propojení dat.


Karta Připojení pro databázové jádro Jet

Pomocí karty Připojení můžete zadat způsob propojení s daty aplikace Microsoft Access.

Karta Připojení je specifická pro daného zprostředkovatele a zobrazuje pouze vlastnosti připojení požadované zprostředkovatelem OLE DB Provider for Microsoft Jet.

Možnost | Popis
Název databáze | Zadejte název souboru MDB databáze Microsoft Access, ke které chcete získat přístup. Chcete-li soubor vyhledat, klepněte na tlačítko.
Uživatelské jméno | Zadejte ID uživatele, které bude ověřeno při přihlášení ke zdroji dat.
Heslo | Zadejte heslo, které bude ověřeno při přihlášení ke zdroji dat.
Prázdné heslo | Umožňuje danému zprostředkovateli vynechat v připojovacím řetězci heslo.
Povolit uložení hesla | Umožňuje uložit heslo v rámci připojovacího řetězce. To, zda bude heslo obsaženo v připojovacím řetězci, závisí na možnostech volané aplikace. Poznámka: Uložené heslo je vráceno a uloženo v neskryté a nezašifrované podobě.
Testovat připojení | Klepnutím vyzkoušejte připojení k zadanému zdroji dat. Pokud se připojení nezdaří, přesvědčte se o správnosti nastavení. Nezdaření operace mohou způsobit například pravopisné chyby nebo nerozlišování malých a velkých písmen.

Poznámka: Další informace o propojení dat naleznete v části Odkazy na rozhraní API pro propojení dat.


Karta Připojení pro ovladač ODBC

Pomocí karty Připojení můžete zadat způsob propojení s daty ODBC.

Karta Připojení je specifická pro daného zprostředkovatele a zobrazuje pouze vlastnosti spojení požadované zprostředkovatelem Microsoft OLE DB Provider for ODBC.

Možnost | Popis
Použít název zdroje dat | Vyberte ze seznamu nebo zadejte název zdroje dat ODBC (DSN), ke kterému chcete získat přístup. Prostřednictvím Správce zdrojů dat ODBC můžete přidat více zdrojů. Seznam obnovíte klepnutím na tlačítko Aktualizovat.
Použít připojovací řetězec | Umožňuje zadat nebo sestavit připojovací řetězec ODBC, který bude použit místo stávajícího zdroje DSN.
Sestavit Otevře dialogové okno Vybrat zdroj dat. Po vybrání zdroje dat se zobrazí připojovací řetězec daného zdroje dat na kartě Připojení v dialogovém okně Vlastnosti Data Link.

Jestliže vyberete možnost Souborové DSN, nebude výsledný připojovací řetězec ODBC založen na zdroji DSN. Připojovací řetězec ODBC je trvale uložen v souboru Data Link (UDL) a nezávisí na vybraném souborovém zdroji DSN.

Jestliže vyberete Zdroj DSN počítače, bude výsledný připojovací řetězec ODBC založen na zdroji DSN. Připojovací řetězec ODBC odkazuje na vybraný zdroj DSN počítače. Pokud se pokusí získat přístup k souboru Data Link (UDL) uživatel z jiného systému, je nutné, aby měl také nainstalován zdroj DSN počítače.
Uživatelské jméno | Zadejte ID uživatele, které bude ověřeno při přihlášení ke zdroji dat.
Heslo | Zadejte heslo, které bude ověřeno při přihlášení ke zdroji dat.
Prázdné heslo | Umožňuje danému zprostředkovateli vynechat v připojovacím řetězci heslo.
Povolit uložení hesla Umožňuje uložit heslo v rámci připojovacího řetězce. To, zda bude heslo obsaženo v připojovacím řetězci, závisí na možnostech volané aplikace.

Poznámka: Uložené heslo je vráceno a uloženo v neskryté a nezašifrované podobě.
Zadejte požadovaný počáteční katalog | Zadejte název katalogu (nebo databáze) nebo jej vyberte z rozevíracího seznamu.
Testovat připojení | Klepnutím vyzkoušejte připojení k zadanému zdroji dat. Pokud se připojení nezdaří, přesvědčte se o správnosti nastavení. Nezdaření operace mohou způsobit například pravopisné chyby nebo nerozlišování malých a velkých písmen.

Poznámka: Další informace o propojení dat naleznete v části Odkazy na rozhraní API pro propojení dat.


Karta Připojení pro aplikace Oracle

Pomocí karty Připojení můžete zadat způsob propojení s daty aplikací Oracle.

Karta Připojení je specifická pro daného zprostředkovatele a zobrazuje pouze vlastnosti připojení požadované zprostředkovatelem Microsoft OLE DB Provider for Oracle.

Možnost | Popis
Název serveru | Zadejte název serveru s databází, ke které chcete získat přístup.
Uživatelské jméno | Zadejte ID uživatele, které bude ověřeno při přihlášení ke zdroji dat.
Heslo | Zadejte heslo, které bude ověřeno při přihlášení ke zdroji dat.
Prázdné heslo | Umožňuje danému zprostředkovateli vynechat v připojovacím řetězci heslo.
Povolit uložení hesla | Umožňuje uložit heslo v rámci připojovacího řetězce. To, zda bude heslo obsaženo v připojovacím řetězci, závisí na možnostech volané aplikace. Poznámka: Uložené heslo je vráceno a uloženo v neskryté a nezašifrované podobě.
Testovat připojení | Klepnutím vyzkoušejte připojení k zadanému zdroji dat. Pokud se připojení nezdaří, přesvědčte se o správnosti nastavení. Nezdaření operace mohou způsobit například pravopisné chyby nebo nerozlišování malých a velkých písmen.

Poznámka: Další informace o propojení dat naleznete v části Odkazy na rozhraní API pro propojení dat.


Karta Připojení pro SQL Server

Pomocí karty Připojení můžete zadat způsob propojení s daty serveru Microsoft SQL Server.

Karta Připojení je specifická pro daného zprostředkovatele a zobrazuje pouze vlastnosti spojení požadované zprostředkovatelem OLE DB Provider for Microsoft SQL Server.

Možnost | Popis
Název serveru | Vyberte server v rozevíracím seznamu nebo zadejte umístění serveru, ve kterém se nachází databáze, ke které chcete získat přístup. Výběr databáze na serveru je samostatná akce. Seznam obnovíte klepnutím na tlačítko Aktualizovat.
Použít integrované zabezpečení Windows NT | Klepnutím zadáte, že zprostředkovatel požaduje bezpečné (nebo důvěryhodné) připojení k serveru SQL Server v systému Microsoft Windows NT. Je-li vybrána tato možnost, použije SQL Server integrované zabezpečení přihlášení pro vytvoření připojení pomocí tohoto zdroje dat bez ohledu na současný režim zabezpečení přihlášení na serveru. Všechna přihlašovací ID a hesla jsou ignorována. Je nutné, aby správce serveru SQL Server sjednotil vaše ID pro síť systému Microsoft Windows s ID pro přihlášení na SQL Server.
Použít specifické uživatelské jméno a heslo | Klepnutím použijete zadané uživatelské jméno a heslo k ověření přihlašovacích informací ke zdroji dat.
Uživatelské jméno | Zadejte ID uživatele, které bude ověřeno při přihlášení ke zdroji dat.
Heslo | Zadejte heslo, které bude ověřeno při přihlášení ke zdroji dat.
Prázdné heslo | Umožňuje danému zprostředkovateli vynechat v připojovacím řetězci heslo.
Povolit uložení hesla Umožňuje uložit heslo v rámci připojovacího řetězce. To, zda bude heslo obsaženo v připojovacím řetězci, závisí na možnostech volané aplikace.

Poznámka: Uložené heslo je vráceno a uloženo v neskryté a nezašifrované podobě.
Vybrat databázi Použijte jednu z uvedených metod:
  1. Zadejte název databáze, ke které chcete získat přístup.

  2. V případě serveru SQL Server 7.0 připojte databázový soubor jako název databáze. Zadejte název databáze pro připojený databázový soubor SQL.

  3. Používáte-li SQL Server verze 6.5 a starší, zadejte název databázového souboru pro připojení. Potom zadejte název databázového souboru (s jedním souborem). Chcete-li soubor vyhledat, klepněte na tlačítko.
Testovat připojení | Klepnutím vyzkoušejte připojení k zadanému zdroji dat. Pokud se připojení nezdaří, přesvědčte se o správnosti nastavení. Nezdaření operace mohou způsobit například pravopisné chyby nebo nerozlišování malých a velkých písmen.

Poznámka: Další informace o propojení dat naleznete v části Odkazy na rozhraní API pro propojení dat.


Odkazy na rozhraní API pro propojení dat

Další informace o rozhraní API pro propojení dat naleznete na serveru msdn.microsoft.com. Otevřete knihovnu MSDN Library Online, oddíl Platform SDK, kde naleznete informace o sadě SDK pro součásti MDAC, kde se nacházejí odkazy na rozhraní API pro propojení dat (Data Link API Reference).


Dialogové okno Úprava hodnoty vlastnosti

Pomocí dialogového okna Úprava hodnoty dat je možné upravit inicializační vlastnosti OLE DB vybrané na kartě Vše. Vlastnosti se mohou lišit v závislosti na konkrétním zprostředkovateli OLE DB.

Poznámka: Další informace o vlastnostech specifických pro daného zprostředkovatele naleznete v dokumentaci daného zprostředkovatele OLE DB.

Možnost | Popis
Popis vlastnosti | Zobrazí popis vybrané vlastnosti.
Hodnota vlastnosti | Vyberte platnou hodnotu.
Původní hodnota | Nastaví vybranou hodnotu vlastnosti na výchozí hodnotu zprostředkovatele OLE DB.