What is AVDatePicker

free5.gif (17373 bytes) Buy the commercial version

What is AVDatePicker?

AVDatePicker is a component for date edition. Full customizable and adaptable to any language. This allow edit dates or pick them from a drop down calendar. Allow enter dates in modes masked and not. The dates can be entered in free format using separators '/', '-' or '.' and displayed in the mm/dd/yyyy, dd/mm/yyyy and dd/yyyy formats . The years autocompletion feature complete the year when this is entered whith less than 4 digits.

The Skin property allow place a background image, giving a stylish fashion to the drop down calendar, as well this have properties for change the button glyph, the font of labels, the color of calendar and transparent property of background bitmap (skin).

This is freeware for not commercial use.

COMMERCIAL VERSION

This is the same what the freeware version but without the advertisement message.

You can buy it now at $10.00

SOURCE CODE

You may get the source code at $20 purchasing again the commercial version. I will send it to you via email.

____________________________________________________________________

If you have any comments, suggestions and bug-reports, please forward

it to avalega@softhome.net or avalega@interlap.com.ar

____________________________________________________________

Author : Alcides Valega

Address : Santa Cruz 1468, 3400-Corrientes, Argentina

E-mail : avalega@softhome.net

URL : http://wind.prohosting.com/alvalega

____________________________________________________________

AVDatePicker Software License Agreement.

BEFORE PROCEEDING WITH THE INSTALLATION AND/OR USE OF THIS SOFTWARE, CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS OF THIS LICENSE AGREEMENT AND LIMITED WARRANTY (The "Agreement").

BY INSTALLING OR USING THIS SOFTWARE YOU INDICATE YOUR ACCEPTANCE OF THIS AGREEMENT. IF YOU DO NOT ACCEPT OR AGREE WITH THESE TERMS, YOU MAY NOT INSTALL OR USE THIS SOFTWARE !

LICENSE

AVDatePicker Software, including documentation, source code, object code and/or additional materials (the "Software") is owned by Alcides Valega (the "Author"). This Agreement does not provide you with title or ownership of Product, but only a right of limited use as outlined in this license agreement. Software author hereby grant you a non-exclusive, royalty free license to use the Software.

REDISTRIBUTION RIGHTS

You are granted a non-exclusive, royalty-free right to reproduce and redistribute executable files created using the Software (the "Executable Code") in conjunction with software products that you develop and/or market (the "Applications").

LIMITED WARRANTY

THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES MERCHANTIBILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PRODUCT IS WITH YOU. SHOULD THE PRODUCT PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING OR ERROR CORRECTION.

THE AUTHOR OF AVDatePicker DO NOT WARRANT THAT THE FUNCTIONS CONTAINED IN THE SOFTWARE WILL MEET YOUR REQUIREMENTS OR THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR FREE.

If you have any questions regarding this agreement, please contact author.