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Instalace Flashe

Při instalaci Flashe ve Windows nebo na Macintoshi postupujte podle těchto kroků:

1. Vložte do mechaniky disk Flash 5. 

2. Udělejte následující :
� Ve Windows klikněte na tlačítko Start > Spustit. Klikněte na Procházet a vyberte

soubor Setup.exe na disku Flash 5.  Klikněte na tlačítko OK v dialogovém
okně, čímž spustíte instalaci.
Na Macintoshi dvakrát klikněte na ikonu Flash 5 instalátor.

3. Následujte instrukce na obrazovce.

4. Po skončení instalace restartujte počítač.

Co je nového ve verzi 5

Nové vlastnosti verze 5 poskytují zvýšené možnosti pro vytváření díla, zefektivňují vaši
práci a ulehčují komunikaci s programem. Flash 5 také obsahuje velmi rozšířené
možnosti pro vytváření akcí pomocí ActionScript. Viz "Co nového v ActionScript"
v uživatelské příručce k ActionScript.

Vytváření nového díla

Zlepšená kontrola barev obsahující míchací panel, panel pro vyplňování a kreslení
čar, panel se vzory a panel nástrojů, který umožňuje kontrolovat vyplňování a kreslení
čar a poskytuje rozšířené možnosti pro kreslení. Viz kapitola 4 "Práce s barvami." 

Nová funkce zvýrazňování výběru usnadňuje rozpoznání zvýrazněných řádků, výplní
a skupin stejně tak jako barvy vybraných objektů. Viz "Vybírání objektů". 

K uspořádání objektů na ploše vám pomohou průvodci. Viz "Používání mřížky,
průvodců a pravítek".

Nástroj tužka vám umožní vytvořit přesné čáry; podobně jako tužka v Macromedia
FreeHand nebo Macromedia Fireworks. Viz "Používání nástroje tužka".

Uživatelská příručka - FLASH 5

ÚVOD

Začínáme

Macromedia Flash je profesionálním standardem pro vytváření působivých webových
stránek a aplikací.
A= už vytváříte animovaná loga, navigační panely pro webové stránky, dlouhé animace,
celé webové stránky používající Flash nebo webové aplikace, zjistíte, že Flash je schopným
a flexibilním prostředkem, ideálním pro využití vaší kreativity.

Systémové požadavky pro Flash editor

Pro Microsoft Windows™: procesor Intel Pentium® 133 Mhz nebo ekvivalentní
(doporučuje se 200), na kterém fungují Windows 95 nebo vyšší verze (včetně
Windows 2000), nebo verze NT 4.0 nebo pozdější; 32 MB RAM (doporučuje se 64 MB);
40 MB volného místa na disku; barevný monitor s rozlišením 800 x 600; a mechanika
CD-ROM.

Pro Macintosh®: Power Macintosh (G3, doporučuje se vyšší), na němž pracuje
System 8.5 nebo jeho pozdější verze; 32 MB RAM volně použitelné paměti plus 40MB
volného místa na disku; barevný monitor s rozlišením 800 x 600 a mechanika CD-ROM.

Systémové požadavky pro Přehrávač Flash

K přehrávání animací pomocí Přehrávače Flash v prohlížeči je zapotřebí následující
software a hardwar:

� Microsoft Windows 95, NT 4.0 nebo pozdější verze; nebo PowerPC s prostředím
System 8.1 nebo pozdější verzí.

� Netscape plugin který pracuje pod Netscape 3 nebo pozdější verzí 
(Windows 95 a Macintosh).

� Pro fungování ovladačů ActiveX se vyžaduje Microsoft Internet Explorer 3.02 
nebo pozdější verze (Windows 95).

� Pro fungování Flash Player Java Edition, je nutný prohlížeč podporující Javu.
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Průvodce instruktážními médii

Balík Flash 5 obsahuje různá média, která vám pomohou naučit se rychle program
a stát se zběhlým ve vytváření vlastních animací ve Flash Player - včetně online
nápovědy, která se objeví ve vašem www prohlížeči, interaktivních lekcí, průvodce,
dvou tištěných knih a pravidelně aktualizované www stránky.

Lekce a průvodce ve Flashi

Jestliže jste novým uživatelem Flashe nebo pokud jste pracovali pouze s některými
jeho částmi, začněte s lekcemi. Lekce vás uvedou do hlavních znaků Flashe a nechají
vás procvičit si je na zvláštních příkladech.

Průvodce vás uvede do pracovního procesu tím, že vám ukáže, jak vytvořit
jednoduchou animaci. Průvodce předpokládá porozumění tématům, která se  probírají
v lekcích.

Chcete-li začít s lekcemi, vyberte v menu Help > Lessons > Introduction 

Průvodce Používání Flashe a ActionScript Reference

Používání Flashe v sobě zahrnuje instrukce a informace pro použití všech nástrojů
a příkazů Flashe. Je k dispozici jednak jako online nápověda a jednak jako tištěná
kniha. Online nápověda obsahuje různé animace v Přehrávači Flash demonstrující
efekty a zajímavosti.

Průvodce ActionScript Reference zahrnuje instrukce a informace týkající se ActionScript,
včetně psaní ActionScript, vytváření interakce s ActionScriptem a úplný slovník
ActionScript. Je k dispozici jako online nápověda i tištěná kniha.

Nápověda Flash

Flash 5 obsahuje tři systémy nápovědy: Používání Flashe, ActionScript Referece
a Slovník ActionScript.

Pro nejlepší zážitek při používání Nápovědy Flash vám Macromedia velmi doporučuje
použít Netscape Navigator 4.0 nebo pozdější verzi nebo Microsoft Internet Explorer
4.0 nebo pozdější verzi ve Windows a Netscape Navigator 4.0 nebo pozdější verzi
nebo Microsoft Internet Explorer 4.5 nebo pozdější verzi na Macintoshi. Pokud
použijete verzi 3.0 vašeho prohlížeče, je veškerý obsah animací a Nápovědy Flash
stále dostupný, ale některé části (jako např. Najít) nebudou fungovat.  Spuštění
Flashe a Nápovědy Flash najednou na Macintoshi může vyžadovat až 32 MB paměti
v závislosti na potřebě paměti vašeho prohlížeče.

Uživatelská příručka - FLASH 5

Vlastní práce s Flashem

Nové panely pro práci s barvou, typem, akcemi, snímky, situacemi a celými animacemi
usnadňují možnosti přístupu k modifikování částí ve flashových animacích. 
Viz kapitola 2 "Základy práce s Flashem."

Sdílené knihovny vám umožní připojit se k položkám knihovny jako externím
prostředkům. Můžete vytvářet znaky písmen a vložit je do sdílených knihoven stejně
jako tlačítka, grafiku, animované klipy a zvuky. Viz "Používaní sdílených knihoven".

Macromedia Dashboard poskytuje způsob jak jednoduše držet krok s posledními
informacemi o používání Flashe. Viz "Macromedia Dashboard pro Flash".

Uživatelské  klávesové zkratky vám dovolují vytvářet vaše vlastní klávesové zkratky
pro příkazy a funkce tak, abyste si mohli práci s Flashem přizpůsobit. Viz "Uzpůsobení
klávesových zkratek".

Díky podpoře pro importování zvukových souborů formátu MP3 můžete importovat již
zkomprimované zvuky do Flashe. To snižuje čas potřebný k publikování a exportování
animace se zvukem, takže nemusíte komprimovat zvuky během exportu. Používání
zkomprimovaných zvuků zmenšuje velikost souboru hotových animací a snižuje
požadavky na pamě= během vytváření. Viz kapitola 6 "Přidávání zvuku."

Interaktivita

Rozšířený ActionScript poskytuje zvýšené schopnosti vytváření interaktivity ve Flashi.
Blíže v uživatelské příručce k ActionStript.

Prohlížeč animací vám umožňuje jednoduše prohlížet kompletní obsah aktuální ani-
mace a prohlížet panel vlastností pro upravení označené položky. Viz "Používání
prohlížeče animací".

Tisková akce vás nechá přiřadit akce pro tisknutí filmových rámců z Flash přehrávače
jako vektorovou nebo bitmapovou grafiku. Viz Uživatelská příručka ActionScriptu.

Rozšířená integrace s ostatními produkty firmy Macromedia

Podpora pro importování souborů PNG z programů FreeHand a Fireworks vám
umožňuje tyto soubory importovat přímo do Flashe jako editovatelnou grafiku 
se zachováním vrstev, textu a dalších součástí. Viz "Vkládání obrázků do Flashe".

Zlepšená integrace s Macromedia Generator rozšiřuje prostředí pro produkci
Flashových animací tak, abyste mohli vytvářet rychle se měnící dynamický obsah. 
Viz "O Generatoru a Flashi".

Zlepšená integrace s Macromedia Fireworks vám umožní jednoduše otevřít Fireworks
k editování bitmapových obrázků importovaných do Flashe. Viz "Editace bitmap".
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Macromedia Dashboard proFlash

Macromedia Dashboard pro Flash poskytuje přístup ke zdrojům rozvojové oblasti
Flash přímo z aplikace Flash. Macromedia Dashboard použijte, pokud chcete získat
informace o různých tématech týkajících se Flashe. Macromedia publikuje na Dashboard
pravidelně nový obsah. Můžete si vybrat, zda chcete obsah Dashboard obnovovat
manuálně nebo automaticky.

Pro shlédnutí Dashboard:

1. Zvolte Help > Macromedia Dashboard.

2. Klikněte na tlačítko Dashboard a zvolte téma.

Pro upřesnění, jak často je aktualizován obsah Dashboard:

V Macromedia Dashboard vyberte Automatická aktualizace k pravidelnému 
automatickému obnovování informací. Pokud chcete obsah Dashboard obnovovat
ručně, odznačíte předchozí volbu tak, že kliknete na tlačítko Aktualizovat.

Poznámka: Abyste mohli obnovit obsah Dashboard, musíte být připojeni k internetu

Centrum pro podporu Flash 

Webová stránka Centrum pro podporu Flash je pravidelně aktualizována a poskytuje
nejnovější informace o Flashi, plus rady od zkušených uživatelů, pokročilá témata,
příklady, tipy a další aktuality. Navštěvujte proto často internetovou stránku
www.macromedia.com/support/flash, abyste se dozvěděli poslední novinky a abyste
věděli, jak nejlépe využít váš program.

Uživatelská příručka - FLASH 5

Použití Nápovědy Flash:

1. Vyberte si jeden ze tří systémů nápovědy z nabídky Help menu (Nápověda).

2. Brouzdejte tématy nápovědy a využívejte těchto vlastností:

� Obsahy organizuje informace podle předmětu. Klikněte na seznam nejvyšší 
úrovně pro zobrazení podtémat.

� Index řadí informace jako tradičně tištěný index. Klikněte na termín pro skok
na odpovídající téma.

� Hledat najde jakýkoliv řetězec znaků ve všech textech nápovědy. Hledat 
(search) vyžaduje prohlížeč verze 4.0 nebo vyšší, který pracuje s Javou. Pro 
hledání slovního spojení jej vepište do okna pro vstup textu.

Pro hledání souborů, které obsahují dvě klíčová slova (například layers a style), oddělte
tato slova znaménkem plus (+).

Pro hledání souborů, které obsahují slovní spojení, oddělte slova mezerou.

Tlačítka Předchozí (previous) a Další (next) vám umožní pohybovat se v tématech
v rámci určitého oddílu.

Ikona Flash vás odkáže na www stránku Centrum podpory Flash.
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Pro procházení interaktivní lekcí zvolte Help > Lessons, pak vyberte ze seznamu.
Abyste porozuměli této velké výukové Lekci ještě lépe, vyzkoušejte si, zda jste opravdu
důkladně pochopili látku, se kterou vás interaktivní lekce seznámily.

Shlédnutí hotové animace

Dříve než začnete vytvářet svou vlastní animaci, podívejte se na konečnou verzi
Lekce, abyste si udělali obrázek o tom, co vytváříte. Dále vás konečná Lekce nechá
vyzkoušet si Časovou osu (Timeline), Prohlížeč animací (Movie Explorer), okno
Knihovna (Library) a Plochu (Stage), abyste porozuměli práci při vytváření animací.

1. V adresáři aplikace Flash 5 otevřete složku Tutorial > Finished.

2. Vyberte soubor Kite.swf (Drak.swf) a přetáhněte jej do otevřeného okna 
vašeho prohlížeče. 

� Animace Flash mají v editovacím prostředí příponu FLA. Animace exportovaná 
do Přehrávače Flash má pak příponu SWF.

3. Klikněte na tlačítko Select a kite (Vybrat draka).
Všimněte si, že když kliknete na toto tlačítko, přehraje se zvuk a objeví 
se zvolený drak.

4. Klikněte na tlačítko Select a color (Vybrat barvu).
Všimněte si, jak drak mění barvu, kterou jste si vybrali.
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KAPITOLA 1

Výuková lekce

Přehled

Představte si, že kdysi existoval obchod s papírovými draky, který měl svou vlastní
www stránku. Zákazníci na tuto stránku přicházeli a procházeli statickými obrázky
s různými draky, aby se rozhodli, kterého z nich si vyberou - to bylo alespoň cílem.
Ve skutečnosti většině zákazníků stránka připadala nudná a ztratili o ni zájem. Stránka
sice splnila svůj účel, ale nepřitahovala žádný zájem.
Nyní si představte, že k této stránce můžete přidat Flash. V této výukové lekci
(dále jen Lekci) vytvoříte www stránku pro létající draky - interaktivní stránku která
návštěvníkům umožní prohlížet a navrhovat své vlastní draky. Pokud se zákazník
rozhodne pro nějakého draka, klikne na tlačítko, které načte a přehraje animaci
s létajícím drakem. Pro dokončení ukázkového příkladu využijete toho, co jste se naučili
v Lekcích a dozvíte se více o vytváření animací. Přesněji řečeno budete plnit tyto úkoly:

� Měnit vlastnosti animace 

� Importovat, tvořit a měnit objekty vyskytující se ve vaší animaci

� Přidávat k tlačítku zvuk

� Používat Plochu (Stage) a Časovou osu (Timeline) ke kompletaci animace

� Tvořit animace zobrazující pohyb a změnu tvaru

� Používat postupy umožňující větší interaktivitu a efektivnější tvorbu

� Testovat animaci na natažení a přehrání

� Publikovat animaci pro www přehrávání

Výuková lekce trvá přibližně jednu hodinu, záleží na vašich zkušenostech.

Co byste měli vědět

Ačkoliv je Lekce určena pro začínající uživatele Flashe, je nutno se nejdříve obeznámit
se sedmi základními lekcemi, které najdete v nápovědě Flash. Tyto interaktivní lekce,
vytvořené ve Flashi, nabízejí seznámení s následujícími tématy:

� Kreslení � Tlačítka
� Symbol � Zvuk
� Vrstvy � Tvorba animací
� Tisk
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5. Pro zobrazení autorem vytvořených popisků,  které označují části animace, 
prozkoumejte vrstvu labels (popisky), což je první vrstva v Časové ose. 
Kromě popisů, které identifikují jednotlivé části animace, můžete použít popisy
pro navigaci tak, že určíte, že se přehrávání posune do prvního rámu dané části,
pokud uživatel klikne na příslušné tlačítko. V Lekci se o popisech a přesměrování
dozvíte víc.

6. Podívejte se na další vrstvu, kterou je vrstva akcí animace (Actions). Tato vrstva
určuje ty snímky, ve kterých je zahrnut ActionScript, skriptovací jazyk Flashe.
Všechna malá písmenka, která vidíte v rámu, představují ActionScript.

7. Vyberte hrací hlavu (Playhead) a pomalu jí posouvejte přes snímky. 
Sledujte, jak změny v pohybu na Ploše odpovídají změnám v Časové ose.
Všimněte si ale, že jak posouváte přehrávání, přehrává se animace sekvenčně
namísto takového přehrávání, jaké vidí uživatel. Navigace pracující s pomocí
ActionScript v animaci umožní uživateli přeskakovat do určených snímků,
na místo toho aby se pohyboval sekvenčně v Časové ose.

Použití Prohlížeče animací

Movie Explorer (Prohlížeč animací) vám pomůže uspořádat, umístit a upravovat
složky animace a je velice prospěšný, pokud pracujete na animaci s velkým počtem
položek. Díky své hierarchické stromové struktuře vám Prohlížeč animací poskytne
náhled do organizace a struktury animace, což je zvlášC užitečné při práci s animací
vytvořenou někým jiným.

1. Pokud ještě nemáte otevřen Prohlížeč animací, zvolte Window > Movie Explorer 
(Prohlížeč animací) nebo klikněte na Prohlížeč animací na Startovací liště 
(Launcher bar). 
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5. Klikněte na tlačítko Fly it (Pustit draka).
Poslouchejte zvukovou kulisu a sledujte animaci.
Všimněte si, že ikona, symbol pro klip animace, se přizpůsobila typu a barvě
draka, kterého jste vybrali.
Klip je menší animace, která se přehrává mimo hlavní animaci.

6. Pokud chcete začít přehrávat animaci znovu, klikněte na tlačítko Back (Zpět).

7. Po skončení prohlížení souboru typu SWF můžete okno buF zavřít nebo 
jej nechat otevřené, aby vám posloužilo jako manuál.

Soubor Kite.fla (Drak.fla)

Je dobré prozkoumat hotový soubor typu FLA, abyste mohli určit, jak autor soubor
vlastně vytvořil. Je mnoho způsobů, jak k tomuto zkoumání přistupovat. V této Lekci
budete zkoumat soubor v následujících krocích:

1. Ve Flashi zvolte File > Open. Přejděte do složky aplikace Flash a otevřete 
Tutorial/Finished/Kite.fla
Nyní uvidíte hotovou animaci ve vytvářecím prostředí.

2. Abyste viděli více Plochy (Stage) a Časové osy (Timeline), zvolte Window > 
Close All panels (Zavřít všechny panely). Samozřejmě to není podmínkou,
pokud máte větší monitor a pracujete ve větším rozlišení.

3. Pro změnu velikosti Plochy a Časové osy, táhněte za příčku, která odděluje 
Plochu od Časové osy nahoru a dolů. Procházejte Časovou osu, abyste viděli, 
jak jsou organizovány jednotlivé vrstvy.

4. Jak jste se naučili v lekcích Vytváření animací, klíčový snímek je snímek,
ve kterém definujete změny v animaci. Při pohubu v Časové ose si všimněte,
které vrstvy a snímky obsahují klíčové snímky.
Počáteční a prostřední klíčové snímky se vyskytují jako pevné kruhy, zatímco
koncové klíčové snímky vypadají jako malé načrtnuté obdélníky.
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4. V levé horní části okna Prohlížeče animací ověřte, že jsou označena pouze 
filtrační tlačítka Show Text (Zobrazit text), Show Buttons (Zobrazit tlačítka),
Movie Clips (Klipy animací), Graphics (Grafika) a Show ActionScripts (Zobrazit 
ActionScript).

5. Procházejte seznamem a dívejte se na některé položky zahrnuté v animaci, 
abyste si všimli jejich vztahu k jiným položkám.
Pokud například procházíte tlačítko Rokkaku Kite, vidíte, že je s ním asociován
ActionScript. Roztáhněte ikonu a uvidíte animaci, která vám přehraje soubor
typu SWF rokkaku kite, pokud uživatel klikne na tlačítko Rokkaku Kite.
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2. Pokud je to nutné, zvětšete si Prohlížeč animací (táhněte za dolní pravý roh okna),
abyste mohli vidět stromovou strukturu v tabulce.
Filtering buttons (Filtrační tlačítka) Prohlížeče animací zobrazují nebo
schovávají informace.

3. Klikněte na trojúhelník v pravém horním rohu Prohlížeče animací a v kontextovém
menu, které se vám objeví, se ujistěte, že jsou zatrženy volby Show Movie
Elements (Zobrazit složky animace) a Show Symbol Definitions (Zobrazit 
definice symbolů). 
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10. Klikněte pravým tlačítkem myši (ve Windows) nebo klikněte a podržte Control
(pro Macintosh) na první ikoně tlačítka Rokkaku Kite na seznamu a vyberte 
Find in Library (Najít v knihovně) z menu, které se vám objeví v pravém horním
rohu Prohlížeče animací.

� Služba Najít v knihovně otevře knihovnu, pokud již není otevřená, a zvýrazní
symbol Knihovna.
Knihovna obsahuje a organizuje položky ve vaší animaci.

11. Zavřete Movie Explorer (Prohlížeč animací).

12. Pro zavření animace zvolte File > Close. 
Jestliže jste provedli změny v animaci, neukládejte je.
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6. Odznačte filtrační tlačítko Zobrazit ActionScript a zvolte tlačítko Show Frames 
and Layers (Zobrazit snímky a vrstvy.

7. Přejděte na začátek Prohlížeče animací. Pod vrstvou popisky (Labels), dvakrát
klikněte na Snímek 43 (rokkaku), abyste posunuli přehrávání v Časové ose
na první snímek části rokkaku.
Objeví se také panely, které mají vztah k snímku.
Chcete-li si prohlédnout nějakou položku ve stromové struktuře, dvakrát
klikněte na odpovídající ikonu. Jestliže dvakrát kliknete na ikonu snímku,
přehrávání v Časové ose se posune na tento snímek. Jestliže na příslušnou
ikonu snímku kliknete dvakrát, objeví se příslušný asociovaný panel, který vám
umožní sledovat a měnit vlastnosti položek.

8. Odznačte filtrační tlačítko Show Frames and Layers (Zobrazit snímky a vrstvy).

9. V rámečku Find text (Hledat text) napište rokkaku kite BUTTON.
Prohlížeč animací zobrazí výsledky vyhledávání. 
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Definování vlastností pro vytváření animace Flash

Konfigurace vlastností animace je obvykle prvním krokem při její tvorbě. Pro určení
nastavení, které se bude týkat celé animace, jako je například rychlost přehrávání ve
snímcích za sekundu (fps) a velikost Plochy a barva pozadí, použijete dialogové okno
Movie Properties (Vlastnosti animace).

Změna implicitního nastavení animace

1. Zvolte Modify > Movie.

2. V dialogovém okně Movie Properties (Vlastnosti animace) ověřte, že v textovém
okně Frame rate (Rychlost snímků) je číslo 12.
Animace se bude přehrávat rychlostí 12 snímků za sekundu, to znamená
optimální rychlostí pro přehrávání animací na webu.

3. Klikněte na okno Background Color (Barva pozadí) pro zobrazení kontextového
menu a vyberte tmavě šedou.
Když označíte barvu, objeví se v políčku u horní části okna její hexadecimální kód.
Dokončený průvodce používá šedou barvu s hexadecimálním kódem #333333.

4. Pro použití vlastností klikněte na tlačítko OK.
Pro další informace o vlastnostech animace viz "Vytváření nové animace
a nastavení jejích vlastností".
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Otevření úvodního souboru

Nyní jste připraveni vytvořit svou vlastní verzi ukázkové animace.

1. Zvolte File > Open.

2. Ve složce aplikace Flash, nechejte zobrazit a otevřít soubor 
Tutorial/My_kite/MyKite.fla
Uvidíte částečně hotovou výukovou animaci.

3. Zvolte File > Save As a uložte animaci pod novým jménem do stejné složky 
jako MyKite.fla.Vytvořením kopie souboru umožníte sobě i dalším uživatelům
dokončovat výukový soubor znovu použitím MyKite.fla.

4. Jestliže okno Knihovny není otevřeno, zvolte Window > Library.

Poznámka: Pokud dokončujete výukový soubor, nezapomínejte svou práci průběžně
ukládat.
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9. Klikněte na políčko barev, čímž se vám zobrazí kontextové okno, kde vyberte
bílou barvu s hexadecimální hodnotou #FFFFFF.

10. Klikněte na Nástroje pro psaní textu kdekoliv na levé straně okna a napište
tento text:
"Krabicový drak byl sestrojen Australanem Lawrencem Hargravem v roce 1893.
Používal draka na vynášení klimatických přístrojů vzhůru."
Ačkoliv jste vybrali bílý text, objeví se šedě, aby byl vidět na bílém pozadí
textového rámečku.

11. Stále máte označeno tlačítko Nástrojů pro psaní textu. Klikněte na ovladač
velikosti - malé kolečko v pravém horním rohu textového okna - a táhněte 
jej do leva, takže se text zalomí po slově sestrojen.

� Text se rozdělí do několika řádků. Jak pohybujete ovladačem velikosti, 
mění se z kolečka na čtverec, aby naznačil, že napsaný text má nyní 
určenou šířku.
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Vytváření symbolů

Kromě vkládání objektů nabízí Flash různé nástroje, které pomáhají vytvářet vysoce
kvalitní grafiku a text. V dokončeném ukázkovém příkladě se objevuje text, který
poskytuje na pozadí informace o vybraném draku. Vy vytvoříte symbol, který řekne
zákazníkovi něco o tvůrci krabicového draka.

Poznámka: Při práci s ukázkovým příkladem se vám může hodit možnost vrátit se
o krok zpět ve změnách, které jste učinili. Flash je schopen vrátit se o několik kroků
zpět, v závislosti na úrovních kroků zpět, které jste nastavili ve Vlastnostech. Pokud
chcete přejít o krok zpět, zvolte Edit > Undo nebo stisknete Control+Z (ve Windows)
nebo Command+Z (na Macintoshi). Můžete naopak i znovu udělat to, co jste odvolali
tak, že vyberete Edit > Redo nebo stisknutím Control+Y (ve Windows) nebo
Command+Y (na Macintoshi).

1. Zvolte Insert > New Symbol.

2. V dialogovém okně Symbol Properties (Vlastnosti symbolu), pojmenujte 
symbol box TEXT.

3. Ověřte si, že v Behavior (Režim) je nastavena Grafika, pak stiskněte OK.
Flash se přepne do režimu pro editaci symbolů. Všimněte si, že jméno symbolu,
který upravujete, se objeví v levém horním rohu okna. Pozadí okna zůstává
ve stejném stupni šedi, jaký jste zvolili ve Vlastnostech animace.

4. V panelu nástrojů vyberte Nástroje pro psaní textu.

5. Jestliže není otevřený Panel znaků, zvolte Window > Panels > Character.

6. V kontextovém okně Fonty Panelu znaků vyberte _sans.
Vaše animace ve Flashi nahradí font vaší volbou - fontem sans serif, jako
je Arial nebo Helvetica.

7. V kontextovém okně Velikost písma najeFte myší na 12 pt.

8. Stiskněte tlačítko Bold (Tučné).
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Test animace

Kdykoliv během vytváření animace můžete zkusit, jak bude vypadat a jak se bude
chovat jako soubor typu SWF.

1. Uložte svou animace a zvolte Control > Test Movie.
Flash exportuje kopii vaší animace ve formě SWF.

2. V SWF souboru klikněte na tlačítko Kite button (Krabicový drak) a všimněte
si, že namísto toho, abyste viděli text o krabicovém drakovi, uvidíte text 
o drakovi rokkaku.Potřebujete tedy nahradit TEXT o rokkaku správným textem
o krabicovém drakovi.

3. Zavřete SWF soubor a vraCte se do editovacího prostředí Flashe. 

Výměna instance

Během editace je poměrně běžné, že budete chtít nahradit jednu instanci jinou,
zvláště pokud se rozhodnete změnit váš výtvor nebo text. Flash tento proces
zjednodušuje tím, že vám umožní nahradit jednu instanci jinou, přičemž zachová
vlastnosti původní instance.

1. Ve vrstvě popisky (Labels) v Časové ose klikněte na první snímek Box Red 
(Snímek 21), abyste přesunuli přehrávání do sekce, která zobrazuje informace 
o krabicovém drakovi. Číslo vybraného snímku se objeví na ukazateli stavu
ve spodní části Časové osy.

2. Máte stále zatržen nástroj Šipka. Klikněte na textovou ukázku na Ploše, která zní
"Rokkaku je japonský bojovný drak... "
To je text, který chcete nahradit textem o krabicovém drakovi, který jste vytvořili.

3. Jestliže Panel instancí není vidět, zvolte Window > Panels > Instance.
Objeví se Panel instancí.
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Změna registračního bodu v textu

Každý blok textu, stejně jako ostatní složky ve Flashi, má registrační bod, který
aplikace může použít, aby jej umístila. Zkontrolujete registrační bod vašeho bloku
textu, abyste si ověřili, že se shoduje s registračním bodem dalších textových bloků
animace; to zajistí shodné uspořádání bloků.

1. V panelu nástrojů vyberte Šipku.
Na ploše je označen textový blok.

2. Pro otevření Informačního panelu zvolte Window > Panels > Info, nebo klikněte
na tlačítko Informační panel na Startovací liště.

3. Informační panel obsahuje malou mřížku s černým čtverečkem, který označuje
registrační bod. Jestliže se černý čtvereček nenachází v levém hornímrohu 
mřížky, klikněte na levý horní čtvereček, čímž do této pozice registrační bod 
umístíte.

4. Napište 0 pro x-ové i y-ové souřadnice a zmáčkněte Enter (ve Windows) 
nebo Return (na Macintoshi); pak informační panel zavřete.

5. Klikněte na Scéna 1 v levém horním rohu okna, abyste se dostali zpět do režimu
pro editaci animací.

Ve Flashi můžete používat několik scén, které vkládáme příkazem Insert > Scene.
Ukázkový příklad používá pouze jednu scénu.
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Vkládání médií

Kromě vytváření vysoce kvalitního textu a grafiky můžete do vaší animace ve Flashi
importovat různé typy médií. Pro obchod s papírovými draky chcete zvuk, který se
spustí, pokud uživatel klikne na tlačítko PusC ho! Abyste mohli asociovat zvuk s vaším
tlačítkem, musíte nejprve importovat zvukový soubor formátu MP3. Tím, že zvukový
formát zkomprimujete, zajistíte, že zvuková nahrávka nezvýší výrazně velikost vaší
animace.

1. Zvolte File > Import.

2. Pokud používáte operační systém Windows, v dialogovém okně Importovat 
zobrazte Tutorial/Mykite v rámci složky aplikace Flash a dvakrát klikněte na
wizz.mp3.
Pokud používáte operační systém pro Macintosh, zobrazte Tutorial/MyKite
ve složce aplikace Flash. Dvakrát klikněte na wizz.mp3f, pak klikněte na
Importovat.
Zvukový soubor se objeví v okně Knihovna. Abyste si mohli zvuk poslechnout,
vyberte ho a klikněte na tlačítko Přehrát v okně Knihovna.
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4. V Panelu instancí klikněte na tlačítko Swapovací symbol.

5. V dialogovém okně Swapovacího symbolu dvakrát klikněte na rámeček TEXT 
v seznamu symbolů.

Na Ploše bude starý symbol nahrazen novým. Vlastnosti instance z předešlého symbolu
budou aplikovány na nový symbol.
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Přidání zvuku k tlačítku

Když vytváříte symbol tlačítka, Flash vytvoří akce pro různé stavy tlačítka ve vztahu
k ukazateli myši. Například pohyb Over  představuje chování tlačítka když je ukazatel
nad tlačítkem. Další možnosti chování tlačítka zahrnují Up, Down a Hit. Další informace
k možnostem chování symbolů tlačítka se dozvíte v Lekci o tlačítkách (vyberte Help
> Lessons > Buttons).

Nyní budete přidávat zvuk ke stavu tlačítka Down, což znamená, že zvuk bude hrát
když uživatel klikne na tlačítko. Protože budete přidávat zvuk k symbolu tlačítka v knihovně
a nejen k výskytu symbolu, bude zvuk hrát pro každý výskyt tlačítka.

1. V Okně knihovny dvojklikem otevřete Složku s tlačítky.

2. Vyberte symbol tlačítka k pouštění draka, potom zvolte Editovat z menu. 
Možnosti knihovny. Stejně tak můžete dvakrát kliknout na ikonu symbolu v Okně 
knihovny. Flash se přepne do módu editování symbolu.

3. Zvolte Insert > Layer a pojmenujte novou vrstvu Zvuk. Pamatujte, že pokud
chcete vrstvu přejmenovat, můžete dvojkliknout na její jméno.

4. K přidání prázdného klíčového snímku pro vytváření animací, vyberte rámec 
Down (Snímek 3) ze Zvukové vrstvy a zvolte Insert > Keyframe.

5. Pro definování vlastností zvuku, dvakrát klikněte na Snímek 3 Zvukové vrstvy.
Kromě Zvukového panelu se mohou objevit i další panely.

6. Ve zvukovém panelu, vyberte wizz.mp3 z kontextového Zvukového menu. 
Potom panel zavřete.

7. Zvolte Edit > Edit Movie nebo klikněte na Scene 1 v horním levém rohu okna
pro návrat do módu editování animace z módu editování symbolu. 

Poznámka: Nezapomeňte si často ukládat svou práci. Nezapomeňte také, že si
můžete poslechnout, jak zvuk ve formátu SWF hraje tím, že zvolíte Control > Test Movie. 
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Organizace vaší knihovny

Obecně je v praxi dobré uspořádávat si soubory do složek v rámci knihovny animací.
Tato výuková ukázka potřebuje mnoho souborů s médii, takže organizace je důležitá.
V této části přesunete váš textový soubor do Textové složky a vytvoříte složku pro
zvukové soubory a pak do ní všechny zvukové soubory přesunete.

1. V menu Library Options (Volby knihovny) vyberte Collapse All Folders (Zavřít 
všechny složky), abyste viděli pouze složky a položky mimo ně.

2. Vyberte rámeček symbol TEXT a přetáhněte jej do Textové složky.

3. Dvakrát klikněte na Textovou složku, abyste ji zavřeli.

Vytvoření nové složky pro zvukové soubory

1. V menu Volby knihovny vyberte New Folder (Nová složka) a pojmenujte tuto 
složku Zvuk.

2. Pokud je to nutné, změňte velikost okna, abyste viděli jak soubor wizz.aif tak 
složku Zvuk.

3. Pro označení všech čtyř zvukových souborů podržte Control (ve Windows)
nebo Command (na Macintoshi) a klikněte na soubory pipot.mp3, piskot.mp3,
svih2.mp3 a wizz.mp3.
Přetáhněte vybrané soubory do složky Zvuk.
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Zarovnání objektů na Ploše

K zarovnání objektu vzhledem k dalším objektům, použijete nyní Align panel
(Zarovnávací panel).

1. Na Ploše vyberte tlačítko Vybrat draka, potom vyberte další dvě tlačítka Vybrat
draka tím, že na ně kliknete a současně držíte stisknutou klávesou Shift. 
Časová osa by měla být stále nastavena na Snímek 1.

2. Pokud nevidíte Zarovnávací panel, zvolte Window > Panels > Align.

3. V zarovnávacím panelu klikněte na tlačítko Vertical Align Top (Zarovnat svisle
nahoru) - třetí tlačítko zprava v horní řadě, čímž tlačítka vyrovnáte relativně 
vzhledem k jejich zaznamenaným umístěním.

4. Klikněte na Horizontal Distribute Left (Rozdělit vodorovně vlevo) - třetí tlačítko
zprava v prostřední řadě, čímž rozdělíte tlačítka rovnoměrně od sebe.

V závislosti na tom, kde jste umístili tlačítko Drak rokkaku, budete muset provádět
další zarovnání tří tlačítek Vybrat draka. Můžete je upravovat použitím dalších vyrovná-
vacích tlačítek ve Vyrovnávacím panelu tak dlouho, dokud jste nedosáhli
požadovaného výsledku
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Používání Plochy a Časové osy 

Nyní, když jste vytvořili, importovali a modifikovali všechny složky vaší animace,
použijete Plochu a Časovou osu ke kompletaci celé animace. Můžete objekty vytvořit
rovnou na Ploše (v tom případě se neobjeví v knihovně, pokud jste se nerozhodli
přeměnit je v symbol), nebo můžete Plochu použít k sestavení importovaných objektů
pro jednotlivé snímky. Časová osa určuje, kdy se vaše média objeví v animaci při
přehrávání jednotlivých snímků.

Změna šířky a výšky tlačítka

Na Ploše jedno z tlačítek Vyber draka chybí: přidáte tlačítko, změníte jeho velikost
a zarovnáte ho na Plochu.
Jelikož symbol tlačítka, který přidáte do vaší animace je větší než tlačítka, které
už máte na Ploše, použijete k změně velikosti nového tlačítka Informační panel.

1. Jestliže není Informační panel otevřen, zvolte Window > Panels > Info nebo 
klikněte na tlačítko Informačního panelu ve Startovací liště.

2. V Časové ose klikněte na Snímek 1 z vrstvy  Kite button (Tlačítko vybrat draka)

3. Potáhněte tlačítko rokkaku kite BUTTON z Okna knihovny na Plochu a umístěte
ji mezi další dvě tlačítka Vyber draka. Pokud jste hotovi, tlačítka by měla 
vypadat takto:

4. V Informačním panelu změňte šířku (W) na 54,2 a výšku (H) na 50,0 a stiskněte 
Enter (Windows) nebo Return (Macintosh).
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Bude-li třeba, klikněte na trojúhelník v dolním pravém rohu v panelu Akcí objektu
a otevře se vám tabulka, která zobrazuje parametry a měňte velikost okna 
dokud nejsou viditelné jak Panel nástrojů tak Seznam akcí.

4. K rozbalení kategorie vyberte Ikonu akcí, potom rolujte Panelem nástrojů 
a dvakrát klikněte na goto.

5. V kontextové nabídce Type vyberte Frame Label (Popsat snímek).

6. V kontextové nabídce Frame vyberte popisek rokkaku. Tím specifikujete,
že když uživatel klikne na tlačítko Rokkaku Kite, zobrazí se první snímek 
animace a uvnitř bude název rokkaku.

7. Odznačte Go to and Play ve spodní části panelu Akcí objektu.
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Vytvoření navigační akce pro instanci tlačítka

Flash vám dovoluje přidat interaktivitu přidáním akcí do animace. Panel akcí vám
pomůže v přidávání ActionScriptu - skriptovacího jazyka produktu Flash. Můžete
použít panel Akcí k prohlížení, zapisování, editování nebo přidávání akcí k symbolu
nebo ukázce.
Nyní použijete Panel akcí k vytvoření a navigování akcí, které umožní pohyb do
určitého snímku v Časové ose, když uživatel klikne na tlačítko Rokkaku Kite.

1. Vyberte tlačítko Rokkaku Kite na Ploše (k odznačení stiskněte Shift a klikněte
na další dvě tlačítka Vybrat draka). 
Vybrali jste prostřední tlačítko ze tří tlačítek Vybrat draka. Panel instancí vám
je může pomoci identifikovat podle jména. Časová osa by měla stále být
nastavena na Snímek 1.

2. Vyberte Window > Action nebo klikněte na tlačítko Akce v Startovacím panelu
a objeví se panel Akcí objektu.

Poznámka: Pokud používáte Panel Akcí k práci s akcemi přidruženými k objektu, je
panel označen Object Actions (Akce objektu). Pokud pracujete spíše se snímky než
s objekty, Flash zobrazuje Frame Actions (Panel akcí snímku).

3. Klikněte na trojúhelník v horním pravém rohu panelu a zobrazí se vám kontextová
nabídka. Ověřte si, že máte vybrán Normální mód a ne Expertní mód. 
Expertní mód nabízí možnosti, které jsou užitečné pro ty, kdo mají zkušenosti 
s ActionScript. V Normálním módu vám s tvorbou akcí pomáhají pole s parametry 
a návody.
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Animace instancí

Flash nabízí několik odlišných způsobů animování instancí, buF používáním techniky
snímek za snímkem (frame-by-frame), nebo vykreslovací (tweening) techniky. Při
používání vykreslování  (tweening) animace, definujete, jak se objekt objeví v jednom
klíčovém snímku, potom definujete, jak se ten samý objekt objeví v dalším klíčovém
snímku. Flash automaticky vytvoří animaci mezi oběma snímky. V tomto výukovém
programu budete vytvářet dva odlišné typy vykreslovacího efektu: pohybové
vykreslení (Motion tweening) draka a tvarové vykreslení (Shape tweening) provazu. 

Jak se dozvíte, kterého draka animovat, jestliže vaše animace má devět možných
kombinací draků (tři modely draků násobeny třemi barvami draků)? Budete muset
animovat všech devět draků? Naštěstí ne. Místo toho použijete zprostředkovatel
draka, který vám pomůže s nastavením animace. Později v tomto výukovém programu
vytvoříte funkci, která rozpozná, kterého draka si zákazník vybral.  Podle informace,
kterou funkce obdrží, se v animaci místo zprostředkovatele objeví externí SWF klip
zvoleného draka.

Při přípravě pro vykreslení potřebujete změnit registrovaný bod ve složkách draka.

Změna registračního bodu

Implicitně je registrační bod symbolu v SWF souboru v jeho horním levém rohu. 

Průvodce napojuje zprostředkovatele draka na externí SWF soubory draků, kteří
budou ve vaší animaci pomalu rotovat. Potřebujete změnit registrační bod
zprostředkovatele ukázky draka tak, aby když je nahrazen souborem SWF s drakem,
SWF rotoval místo okolo svého levého horního rohu okolo svého středu.
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Ukázání správného draka

Kromě akce Go To, přidáte opatření, aby se objevil správný drak, když uživatel klikne
na tlačítko Rokkaku Kite.

1. V nabídce Panelu nástrojů dvakrát klikněte na setProperty

2. V kontextové nabídce položky Vlastnosti, vyberte_visibility (Viditelný)

3. Do textového pole Target napište demoKite a ujistěte se, že Expression, 
umístěný vedle textového pole, není označen.

4. V Hodnotovém textovém poli (Value) napište True  a označte Expression
vedle textového pole

5. V nabídce Panelu nástrojů dvakrát klikněte na loadMovie

6. Do textového pole URL napište r.swf, což je název externího souboru s obrázkem 
draka rokkaku.

7. V kontextové nabídce Location (Umístění) vyberte Target (Cíl).

8. Do textového pole Location (Umístění) napište demoKite.

9. Ověřte, že máte zatrženo Don t Send v kontextové nabídce Variable (Proměnné)
a žádná z obou možností Expression není zatržena. Potom zavřete panel 
Akcí objektu. 

Poznámka: Pokud se chcete dozvědět více informací o chování nabídek setProperty
a loadMovie, použijte Uživatelskou příručku k ActionScript.

Zamykání objektů

TeF když jste umístili a změnili tlačítka, uzamknete je, abyste se ujistili, že se kvůli
žádné nepředvídané situaci nepohnou nebo na nich nedojte k nějakým jiným
změnám. 

Ve vrstvě Pick a Kite button, klikněte na černou tečku ve sloupci Lock (Zamknout).
Ve sloupci Lock (Zamknout) se objeví ikona visacího zámku. (Pokud chcete vrstvu
odemknout, klikněte znovu na ikonu visacího zámku).
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Příkaz Edit Center (Editovat Střed) vám umožní vytvořit středový bod rotace ukázky,
který je odlišné od středového bodu rotace symbolu.

1. V Časové ose, vrstvě popisky najděte první snímek letící smyčky označeného
draka (Snímek 168) a klikněte na snímek tak, aby se animace nastavila na tuto 
pozici

2. Vyberte draka, který se objeví na Ploše.

3. Jestliže panel Instance není otevřen, klikněte na něj ve Startovací liště.

Poznámka: pokud je vybrán symbol draka, v panelu Instance je jeho symbol pojmenován
placeholderKite a jméno jeho výskytu je demoKite. Později v průvodci, poté co přidáte
ActionScript k vaší animaci, nahradí v průběhu přehrávání animace výskyt demoKite
drak, kterého si zákazník vybere.

4. Vyberte Modify > Transform > Editovat Center. Registrační bod se stane
viditelným a označeným.

5. Na Ploše zatáhněte registrační bod, vypadá jako malý křížek, přibližně
do středu draka.
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Vykreslení pohybu draka

Poté, co si zákazníci vyberou draka, kliknou na tlačítko Fly It (PusC ho!), aby viděli
pohyb draka během letu. Abyste dosáhli efektu letícího draka po obloze, budete
muset do vaší animace přidat vykreslení jeho pohybu. 

K tomu potřebujete definovat vlastnosti draka jako pozice, velikost  a rotaci pro výskyt
v jednom bodě Časové osy a potom přidáte nový klíčový snímek, ve kterém všechny
tyto vlastnosti změníte. Flash vytvoří obsah snímků mezi těmito dvěma definovanými
snímky sám.

Přidání klíčového snímku na konec animace

Když přidáváte nadefinovaný snímek, nezapomeňte, že ho můžete vložit do jakéhokoliv
místa, v němž chcete animaci změnit; kromě prvního a posledního, nemusíte rámce
vkládat na místo, které je v tomto průvodci přesně specifikováno.

1. V Časové ose, ve vrstvě drak zkontrolujte, že je animace nastavena 
na Snímku 168.

Všimněte si rámce, který bude označovat začátek vaší animace. Také si všimněte
vodících linek na Ploše, které ukazují trasu, ke které drak přilne.  V Časové ose jsou
tyto cesty v Lekci: vrstva drak, která je vodící vrstvou, speciální vrstva, kterou můžete
vytvořit, aby vám pomohla v rozmístění objektů na Ploše.

Vodící linky jsou zde jenom proto, aby autorovi pomohly shromáždit složky animace
podél trasy; v publikované Flash animaci se neobjeví. Vodící vrstvy můžete rozpoznat
v Časové ose podle jejich ikony.
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Určení pohybového vykreslení (motion tweening)

Nyní, když jste určili začátek a konec animace, použijete panel Frame pro zadání
pohybu a druhu animace mezi rámy..

1. V Časové ose, ve vrstvě drak  klikněte na jakýkoli snímek mezi 168. (začátek 
animace) a 228. (konec animace), takže označíte pouze rámce mezi těmito
dvěma.

2. Vyberte Window -> Panels -> Frame a označte druh animace Motion z kon
textové nabídky Tweening.

3. Ověřte si, že je zatrženo Snap (Přilnutí)

� Přilnutí zajistí, že instance draka se připojí k vodícím linkám prostřednictvím
registračního bodu.

� Můžeme říci, že pohybové vykreslení je implementováno správně, pokud se 
v Časové ose mezi definovanými snímky objevuje pevná čára a snímky mají 
světle modré pozadí.

� Špatně implementované vykreslení indikují přerušované čáry mezi definovanými
snímky, což se může přihodit, pokud dojde k nepředvídanému smazání 
počátečního nebo koncového snímku.
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2. Použijte kontextovou nabídku v okně aplikace vlevo dole, abyste mohli zvětšit 
velikost plochy na 800%.

Nyní si všimněte, že trasa není jeden souvislý tvar – má malé zalomení v místě, kde
animace končí.

3. V Časové ose, ve vrstvě drak nastavte animaci na Snímek 229 a zvolte Insert
> Keyframe. Zkontrolujte ukazatel polohy v Časové ose dole, abyste se ujistili,
že jste vybrali správný snímek. Koncový snímek se objeví ve snímku 228, což
je místo, kde jeho pohyb končí.

4. Se stále zvětšenou Plochou a animací nastavenou na snímku 229 vrstvy drak, 
jemně táhněte drakem doprava tak dlouho, až je registrační bod na druhé
straně trasy. Definujete, kde drak bude na konci animace.

Poznámka: pokud už je registrační bod na druhé (pravé) straně trasy, vaše animace
nebude fungovat. Opakujte kroky tak, abyste změnili registrační bod, tentokrát pohybujte
bodem nalevo od místa, kde byl předtím.

5. Změňte velikost na 100%.
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4. Klikněte na roh okraje a táhněte ho tak, aby se drak otočil přibližně o 30°
ve směru hodinových ručiček.

5. Posuňte nastavení animace na Pole 184. Na Ploše použijte Měnič rotace, 
abyste mohli drakem pohnout přibližně o 60° proti směru hodinových ručiček. 
Použijte Měnič velikosti a draka zmenšete. Během animace se drak bude jevit 
jakoby odlétal pryč.

6. Posuňte nastavení animace do Klíčového snímku 198. Na Ploše použijte Měnič
velikosti k tomu, abyste draka zmenšili.

7. Pro Klíčové snímky 207 a 214 použijte Nástroj na změnu velikosti, abyste 
mohli draka zvětšit.

8. K prohlédnutí animace letícího draka potáhněte nastavení přehrávače animace
ze Snímku 168 do Snímku 228.

Poznámka: Nezapomeňte si často svoji práci ukládat.
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Přidávání klíčových snímků doprostřed animace

Nyní budete přidávat klíčové snímky, které určují místa, kde se bude animace měnit.

1. V Časové ose, ve vrstvě drak s animací nastavenou na Snímku 175, stiskněte F6,
abyste přidali klíčový snímek. Na Ploše se drak pohnul podél trasy na pozici 
vztahující se k Snímku 175.

2. Vložte klíčové snímky do Snímků 184, 198, 207 a 214, také ve vrstvě drak.

Velikost a rotace draka

Animace bude více realistická, pokud drak bude měnit velikost a rotovat při pohybu
po určené trase. Abyste tohoto efektu dosáhli, musíte draka zvětšit, zmenšit a rotovat
v místech, kde jste přidali klíčové snímky.

1. Se stále vybranou vrstvou drak, posuňte animaci zpět na Klíčový snímek 175. 

Poznámka: Pokud jste klíčové snímky vložili do jiných polí než těch, které jsme speci-
fikovali, všechny tyto změny vzhledu provádíte na těchto klíčových snímcích.

2. V panelu nástrojů vyberte Nástroj šipka a Scale modifier (Měnič velikosti). 
Na Ploše klikněte na vnější okraj a táhnutím draka jemně zvětšete.

3. Vyberte Rotate modifier (Měnič rotace). Na Ploše pohněte ukazatelem myši 
nad jedním z rohů okraje draka. Ukazatel se změní na čtyři zahnuté šipky
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Vytvoření vykreslení tvaru (shape tweening) provazu draka

Abyste animovali draka, použili jste vykreslení pohybu (motion tweening). Pro animaci
šňůry od draka, použijete shape tweening (vykreslení tvaru) : nakreslíte tvar (v tomto
případě šňůru) v jednom bodě Časového osy a v dalších bodech změníte její tvar.
Flash změní tvar ve snímcích mezi počátečním a koncovým klíčovým snímkem, čímž
vytvoří animaci. 

1. V Časové ose, ve vrstvě string (provaz) vložte klíčový snímek (F6) do Snímku 168,
což je začátek animace pohybu draka.

2. V panelu nástrojů vyberte Nástroj tužka. Klikněte na paletu barev a zobrazí
se vám kontextové okno.  Vyberte světlý odstín žluté.

3. Z Pencil Mode modifier (Měniče režimu tužky) vyberte Smooth (Vyhladit).

4. Abyste otevřeli panel Stroke (Kreslení čar), zvolte Window > Panels > Stroke. 
Z kontextové nabídky Velikost čáry vyberte 2 nebo napište 2 do textového pole
Velikost čáry.

5. Na Ploše nakreslete čáru, která spojuje cívku s provazem s přibližným 
středem draka.
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Neustálé opakování animace

Animace draka se zastaví, když přehrávač dosáhne Snímku 228. Aby drak letěl
nepřerušovaně, budete muset přidat atribut neustálého opakování.

1. Ve vrstvě akcí Časové osy, vložte klíčový snímek na Snímek 228, a potom na něj
dvakrát klikněte, abyste otevřeli panel Akcí rámce.

2. Klikněte na Ikonu Actions (akce) k otevření kategorie, potom dvakrát klikněte
na goto v nabídce Panelu nástrojů.

3. V kontextové nabídce Type vyberte Frame Label.

4. V kontextové nabídce Frame vyberte kite flight loop. 
Časová osa zahrnuje popisek (label) pojmenovaný kite flight loop. První  snímek
uvnitř smyčky letu je Snímek 168. Určujete, že přehrávač animace bude
opakovat smyčku ze Snímku 228, kde jste vložili klíčový snímek, zpět ke
Snímku 168, což je start animace.

5. Ověřte, že je vybráno Go to and Play, potom zavřete panel Akcí rámu.
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Specifikace vykreslení tvaru (shape tweening)

Jako příprava před samotným vykreslením tvarů se může zdát užitečné zamknout
draka, oblohu a Guide (Průvodce) ve vrstvě kite (drak) v Časové ose, abyste se vyhnuli
nešCastnému pohnutí těchto objektů na Ploše.

1. Ve vrstvě provaz klikněte na jakýkoliv Snímek mezi 168. a 229., takže jsou 
označeny pouze snímky mezi těmito dvěma klíčovými snímky.

2. Pokud panel Snímků není otevřen, vyberte Window > Panels > Frame
a z kontextové nabídky Tweening (Vykreslování) vyberte Shape (Tvar). 
Stejně jako ve vykreslování pohybu nepřerušovaná čára mezi klíčovými rámy
napovídá, že je všechno v pořádku. Časová osa ukazuje vykreslený tvar
se světle zeleným pozadím.

3. Posuňte nastavení animace na Snímek 168. Pomalu potahujte přehrávačem 
doprava napříč Časovou osou dokud se provaz neobjeví oddělený od draka.
Do tohoto bodu Časové osy přidejte další klíčový snímek.

Poznámka: před tím, než přidáte klíčový snímek, podívejte se na mezeru mezi drakem
a provazem. Kvůli malé mezeře není třeba klíčový snímek přidávat.

4. Vyberte Nástroj šipka v panelu nástrojů. Pokud je označen celý provaz,
klikněte kdekoli na Ploše, abyste ho odznačili. Potom potáhněte vrchol provazu
tak, že se znovu objeví připojen ke středu draka.

5. Použijte Nástroj šipka s vybraným Smooth modifier (Měničem vyhlazení) tak,
že vyberete a potáhnete provaz z bodu okolo středu čáry, ale abyste zároveň
zachovali tvar křivky. 

Nastavili jste animaci tak, že šňůra draka vypadá jako by nikdy nebyla od draka oddělena.
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6. Bude-li třeba, použijte nástroj šipka pro výběr šňůry na Ploše a použijte 
opakovaně Smooth modifier (Měnič vyhlazení) dokud se čára nebude podobat
provazu.

7. V Časové ose přidejte klíčový snímek do Snímku 230 vrstvy string (provaz).
Kromě klíčového snímku ve Snímku 230 se koncový klíčový snímek objeví
ve Snímku 229.

8. Ve Snímku 231 vyberte Insert (Vložit) > Blank Keyframe (Prázdný klíčový snímek),
takže se provaz od tohoto snímku dál už v animaci neobjeví. 
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Vytvoření funkce

Funkce, kterou vytvoříte, se bude jmenovat refreshKite (obnovDraka). Pokud si svou
animaci představíte jako obchod, který skladuje draky, za funkcí refreshKite si představte
prodávajícího, který draka představí zákazníkům.

Parametr zvaný currentKite (tentoDrak) řekne funkci refreshKite, kterého draka si zákazník
vybral: jeho barvu a typ. Definice parametru je jednoduchá, znamená, že je tím, kdo
předává informace funkci.

1. V Časové ose dvakrát klikněte na Snímek 1 vrstvy akcí. Objeví se panel Frame
Action (Akce Snímků). Pokud je to nutné, změňte velikost okna tak, abyste
viděli obě okna. Seznam akcí už zahrnuje ActionScripty, ke kterým přiřadíte
nové akce.
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6. Pokud pokračujete s pohybem přehrávače pomalu doprava, přidejte klíčový 
snímek do vrstvy provazu pokaždé,  když uvidíte významnou mezeru mezi
drakem a provazem. Potom pokračujte kroky 4 a 5 tak často jak je to nutné, 
dokud nedosáhnete konce animace - Snímek 229.

7. K prohlédnutí animace přesuňte přehrávač na Snímek 168 a zvolte Control ->
Play. Až skončíte s prohlížením animace, zvolte Control -> Stop.

Poznámka: Nezapomeňte si často ukládat práci.

Použití akcí a zefektivní práce

Jste připraveni přidávat do své animace akce, které určí, jakého draka si zákazník
vybral a zobrazí ho se správnou ikonou. Nejprve použijete panel Frame Actions (Akce
snímků), abyste vytvořili funkci, blok kódu pro opakované použití, který provede úkol.
V tomto případě tím úkolem je nahrát určenou SWF animaci draka do Přehrávače
Flash v závislosti na tom, kterého draka si uživatel vybral.

Poznámka: SWF soubory různých modelů a barevných kombinací draků jsou ve složce
My_kite.
Kromě funkce, kterou vytvoříte, můžete také používat Include action (Vloženou akci),
čímž vytvoříte odkaz na jinou funkci v externím souboru.

Poznámka: Není v možnostech tohoto ukázkového příkladu naučit vás syntaxe
ActionScriptu, odkazujeme vás na Referenční příručku ActionScript, kde naleznete
další informace o vytváření ActionScriptu.
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3. Do textového pole Name (Název) napište refreshKite (obnovitDraka).

4. Do textového pole Parametry napište currentKite (tentoDrak). Funkce použije
parametr currentKite (v současnosti označený drak), aby identi fikovala 
správného draka, kterého má zobrazit.
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2. V seznamu Panelu nástrojů klikněte na ikonu Actions, pak dvakrát klikněte
na function.

Můžete také přetáhnout ikonu function na konec Seznamu akcí.

KAPITOLA 1 - Správa sítě 37



11. V textovém okně Proměnná napište chosenKite (vybranyDrak), jméno proměnné.
Ověřte, že není zvolen Výraz, napravo od textového okna.

12. V textovém okně Value (Hodnota) napište currentKite (tentoDrak). Zvolte
Expression (Výraz) napravo od textového okna.

Vložení externí funkce

Naučili jste se, že funkce je souhrn akcí, které plní úkoly v závislosti na informacích
získaných od parametrů. Nyní do svého ActionScriptu vložíte funkci, která vytvoří
ikonu podle vámi vybraného draka.

Externí funkce pojmenovaná KiteFunction.txt je v textovém souboru ve složce
Tutorial/My_kite ve složce aplikace Flash 5. Pro odkaz na externí soubor použijete
Vloženou akci.
Jedním pozitivem odkazu na externí soubor v porovnání se zařazením funkce jako
součásti animace je, že pokud se funkce změní, nemusíte svou animaci aktualizovat.
Externí funkce ukazuje, jak stručný, a přesto schopný, může ActionScript být:

� function generateInvoice (Style, Color, Price, currentKite) {

� _root.invoice.invoiceStyle = Style;
_root.invoice.invoiceColor = Color;
_root.invoice.invoicePrice = Price;
flyingKite = currentKite;
}

5. Stále mějte otevřenu kategorii Akce v seznamu Panelu nástrojů, dvakrát klikněte 
na loadMovie (nahrátAnimaci).

Přikazujete Flashi, aby nahradil klip animace na Ploše souborem SWF,
jež je určen parametrem.

6. Do textového pole URL napište currentKite+".swf"

7. Zvolte Expression (Výraz) napravo od textového pole URL.

Tím, že zvolíte Výraz, říkáte Flashi, že currentKite+".swf" není doslovný řetězec
znaků, ale spíše popis. Funkce používá tento popis k určení správného
názvu externího souboru.

8. V kontextovém menu Location (Umístění) zvolte Target (Cíl) a do textového
okna napravo napište demoKite (demoDrak).

Zapamatujte si, že symbolické jméno pro instanci zprostredkovatel Drak
bude demoDrak.

9. Ověřte, že je zvoleno Don t Send (Neposílat) v kontextovém menu Variables 
(Proměnné).

10. V Panelu nástrojů dvakrát klikněte na set variable, čímž definujete novou
proměnnou.

Proměnná je schránka, která uchovává informace, např. o tom jaký drak
byl vybrán.
Ve vaší animaci si proměnná pamatuje naposledy vybraného draka.
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2. Do textového okna Path (Cesta) napište KiteFunction.txt.

3. Zavřete panel Akce snímků.

Poznámka: Nezapomínejte svou práci často ukládat.

Publikování animace

Gratulujeme! Vaše animace je už téměř hotová. Pro dokončovací práce použijte
příkaz Publikovat, abyste vytvořili verzi kompatibilní s www s příponou SWF. 

Pokud použijete příkaz Publikovat s původním nastavením, připraví Flash váš soubor
pro publikaci na www. Flash publikuje SWF a HTML soubory s tagy nezbytnými pro
zobrazení souboru SWF.

Když vstoupíte do potřebných voleb Publish Settings (Nastavení publikace), můžete
opakovaně exportovat do všech vybraných formátů pouhým zvolením File > Publish.
Flash uloží nastavení publikace, která specifikujete pro příslušný soubor, takže každá
animace má vlastní nastavení.
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� Všimněte si, že funkce není komentovaná. Je výhodné přidávat k ActionScriptu
komentáře, což jsou poznámky o účelu skriptu, kterému lze jinak někdy
těžce porozumět. Zde je tatáž funkce s vysvětlujícími komentáři. Komentáře
k ActionScriptu jsou odděleny dvěma lomítky (//), což Flashi oznamuje, aby
text následující po dvou lomítkách na dané řádce ignoroval.

� function generateInvoice (Style, Color, Price, currentKite) {

� //Přiřadí parametru Styl hodnotu proměnné Stylikony
_root.invoice.invoiceStyle = Style;

� //Přiřadí parametru Barva hodnotu proměnné Barvaikony
_root.invoice.invoiceColor = Color;

� //Přiřadí parametru Cena hodnotu proměnné Cenaikony
_root.invoice.invoicePrice = Price;

� //Nastaví stejnou hodnotu proměnné letajiciDrak jako je hodnota proměnné
tentoDrak
flyingKite = currentKite;
}

� Nyní přidáte include (vložený) skript, jež spojí interní funkci, kterou jste
vytvořili, s externí funkcí.

1. V Panelu nástrojů Akce snímků v kategorii Akce přetáhněte ikonu include 
(vložení) nakonec textu v Seznamu akcí.
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Poznámka: Ačkoli Profilovací program nepoukazuje na závažné problémy při sta-
hování ukázkové animace, můžete svou animaci optimalizovat pro rychlejší stažení.
Detaily viz "Optimalizace animace".

4. po skončení prohlížení Profilovacího programu zvolte Náhled > Profilovací 
program, abyste tak tuto volbu odznačili. Zavřete testovací okno a vraCte se
do editovacího prostředí.

Použití příkazu Publikovat (Publish)

Uložte svou animaci a zvolte File > Publish.

Flash vaši animaci zveřejní vytvořením SWF souboru a možná i dalších souborů,
založených na vlastnostech ve Publish Settings (Vlastnostech publikace). Vaše
publikované soubory najdete ve složce My_kite. Tak jednoduchá je publikace vašich
animací pro www přehrávání.
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Testování natahování animace

Aby mohla být animace Flash správně přehrána přes Internet, musí se snímek nahrát
dřív než k němu animace doběhne. Jestliže animace dojde k snímku, který nebyl ještě
natažen, zastaví se, dokud nepřijdou potřebná data.  

Malé velikosti souborů Flash nicméně podporují vcelku rychlá stahování. Bandwidth
Profiler vám pomůže určit, na kterém místě by se pauzy mohly objevit. Profilovací pro-
gram graficky ukáže, kolik dat je posíláno z každého snímku v animaci, v závislosti na
zvolené rychlosti modemu.

1. Zvolte Control > Test Movie.

� Flash animaci exportuje do SWF souboru a otevře jej v novém okně.

2. Z nabídky Debug (Ladit) vyberte rychlost, která určí rychlost stahování, jež bude
Flash simulovat.

� Můžete také vybrat Customize (Přizpůsobit), pokud chcete tuto rychlost sami
napsat.

3. Vyberte View > Bandwidth Profiler (Profilovací program) a počítač vám přehraje 
simulaci stahování SWF souboru.

� Všechny šrafované sloupce představují snímky vaší animace. Výška sloupce
představuje velikost snímku v bytech a kilobytech. Jestliže sloupec přesáhne
červenou čáru, znamená to, že na tento snímek může při přehrávání animace 
čekat.
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Změna nastavení publikace

Flash přiděluje implicitně souboru SWF stejné jméno jako souboru FLA. Jelikož
vytváříte stránku o Létajících dracích (Orbit kites), přikážete Flashi, aby soubor SWF
pojmenoval OrbitKites.swf (LétajícíDraci.swf).

1. Na přehledu Formáty v dialogovém okně Publish Settings (Nastavení publikace), 
odznačte Use default names (Použít původní jména).

2. V textovém okně Flash (.swf), zvolte původní text a napište OrbitKites.swf 
(LétajícíDraci.swf), pak klikněte na tlačítko OK.

� Když budete publikovat svou animaci znovu, Flash vytvoří soubor se jménem
OrbitKites.swf.
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Náhled na nastavení publikace (Publish Settings)

Použití Nastavení publikace vám lehce umožní přenastavit způsob publikace vašeho
souboru.

K prohlédnutí vašich nastavení vyberte File > Publish Settings.

Flash je původně nastaven tak, že vytváří podporovaný HTML soubor, který zobrazí
animaci Flash nebo alternativní obrázek.

Pokud vyberete formát, který vyžaduje další nastavení, objeví se nová tabulka.
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KAPITOLA 2

Základy práce s Flashem

Animace vytvořené pomocí produktu Flash jsou animace a grafika určené pro Webové
stránky. Jsou tvořeny především vektorovou grafikou, ale mohou také obsahovat
importovanou bitmapovou grafiku a zvuky. Flashové animace mohou být interaktivní,
takže do nich mohou diváci zasahovat a můžete vytvářet nelineární animace, které
mohou spolupracovat s ostatními internetovými aplikacemi. Weboví návrháři používají
Flash, aby vytvořili navigační tlačítka, animovaná loga, dlouhé animace se synchroni-
zovaným zvukem a dokonce kompletní webové stránky, které bohatě působí na smyslové
vjemy. Flashové animace jsou kompaktní vektorovou grafikou, takže se načítají rychle
a změní svou velikost podle velikosti obrazovky návštěvníka.

Pravděpodobně jste zhlédli a pracovali s mnoha Fleshovými animacemi na mnoha
Webových stránkách včetně stránek firem Disney ®, Simpsonovi ®, a  Coca-Cola ®.
Milióny uživatelů Webu obdrželi Flash přehrávač se svými počítači, prohlížeči nebo
systémovým softwarem; další si ho stáhli z internetové stránky firmy Macromedia.
Flash přehrávač je nainstalován na místním počítači, kde přehrává animace v prohlížeči
nebo je samostatnou aplikací. Prohlížení Flashové animace přehrávačem je podobné
jako prohlížení videokazety na videorekordéru – Flash přehrávač je zařízení používané
k prohlížení animací, které vytváříte ve Flash editoru.

Pokud se chcete s Flashem seznámit pomocí interaktivní nápovědy,
vyberte Help > Lessons > Introduction.

Průběh práce s programem Flash

Během práce ve Flashi vytváříte animaci tím, že kreslíte nebo importujete její složky,
uspořádáváte je na Ploše a animujete pomocí Časové osy. Děláte ji interaktivní tím,
že používáte akce, takže animace může reagovat na události specifickými způsoby.

Když je animace hotová, exportujete ji jako Flashovou animaci určenou k přehrávání,
aby mohla být prohlížena pomocí Flash přehrávače nebo jako samostatný Flash
promítač tak, aby byla prohlížena  přehrávačem, který obsahuje samotná animace. 

Flash můžete přehrávat následujícími způsoby:

� V internetových prohlížečích jako jsou Nescape Navigator a Microsoft Internet
Explorer, které jsou vybaveny přehrávačem Flash

� Pomocí Flash ActiveX v Microsoft Office, Microsoft Internet Explorer pro Windows
a v dalších prostředích s podporou ActiveX
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Další kroky

Dokončením ukázkového příkladu jste splnili velký úkol v poměrně krátkém čase.
Nyní víte, jak provést následující:

� Měnit vlastnosti animace

� Importovat, vytvářet a měnit prostředky

� Přidávat k tlačítku zvuk

� Používat Plochu a Časový rozvrh ke kompletaci animace 

� Vytvářet vykreslení pohybů a tvarů

� Používat akce pro přidání anteraklivity a organizaci editace

� Testovat animaci pro stažení

� Publikovat animaci pro přehrání na www

Při plnění hlavních cílů jste se také naučili, jak plnit různé další související úkoly.
Pro pokračování výuky Flashe zobrazte témata v Používání Flashe a Nápověda Flash.
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Konfigurace serveru pro Flash přehrávač

Aby si uživatelé mohli vaší animaci na internetu prohlédnout, musí být web server
správně nakonfigurován, aby animaci rozpoznal jako soubor určený pro přehrávač Flashe.

Je možné, že už váš server je správně nakonfigurován. Abyste otestovali konfiguraci
serveru, podívejte se na TechNote (technické záznamy) #12696 v Centru podpory
produktu Macromedia Flash, http://www.macromedia.com/support/flash/. Pokud váš
server není správně nastavený, následujte instrukce, které vám s konfigurací pomohou.

Nastavování serveru spočívá ve správném nastavení MIME (standart pro definování
různých typů souborů) typu na serveru tak, aby identifikoval soubory s příponou .swf
jako soubory patřící k aplikaci Shockwave Flash. Prohlížeč, který přijme správný
MIME typ může nahrát vhodný pug-in, ovladač nebo pomocnou aplikaci ke zpracování
a správnému zobrazení příchozích dat. Pokud MIME type chybí nebo není
serverem správně dodán, prohlížeč může zobrazit chybovou zprávu nebo prázdné
okno se záhadnou ikonou.

Poznámka: když publikujete flashovou animaci, tak ji musíte nastavit pro Flash
prohlížeč, aby ji uživatelé viděli. Viz kapitola 14 „Publikování a exportování.“ 

Pro nakonfigurování serveru udělejte následující:

� Pokud je vaše stránka vystavena prostřednictvím poskytovatele Internetu,
kontaktujte ho a žádejte, aby byl na server přidán MIME type aplikace
/x-shockwave-flash s příponou .swf

� Pokud administrujete vlastní server, podívejte se do dokumentace k vašemu
Web serveru na instrukce ohledně přidávání a nastavování MIME typu.
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� V přehrávači Flash, což je samostatná aplikace, která funguje podobně jako
plug-in Flash přehrávač

� Jako samostatný promítač, což je animovaný soubor, který může být přehráván
bez pomoci dalšího softwaru pro přehrávání

Pokud se chcete dozvědět více, podívejte se do kapitoly 14 „Publikování a exportování.“

Vytváření grafiky ve Flashi

Flash poskytuje rozmanité metody pro vytváření původních výtvorů a jejich importování
z ostatních aplikací. Můžete vytvářet objekty pomocí kreslících a malovacích nástrojů
a měnit vlastnosti existujících objektů. Viz kapitola 3 „Kreslení“ a kapitola 4 „Práce
s barvami.“
Můžete také importovat vektorovou a bitmapovou grafiku z ostatních aplikací a impor-
tovanou grafiku měnit rovnou ve Flashi. Viz kapitola 5 „Používání importovaných výtvorů.“

Poznámka: Také můžete importovat zvuk, což je popsáno v kapitole 6 „Přidávání zvuku.“

AAnniimmoovváánníí vvee FFllaasshhii

Používáním Flashe můžete animovat objekty tak, aby vypadaly, že se pohybují po Ploše,
nebo měnit jejich tvar, velikost, varvu, průhlednost, rotaci a další vlastnosti. Můžete
vytvářet animace pomocí techniky snímek za snímkem, kde vytváříte samostatný
obraz pro každý snímek. Také můžete vytvářet animaci pomocí techniky vykreslování
pohybu, při které vytvoříte první a poslední snímek, ostatní snímky mezi nimi vytvoří
přímo Flash. Viz kapitola 11 „Vytváření animací.“

Animace můžete také vytvářet používáním akce Set Property (Nastavení vlastností).
Viz Referenční příručka k ActionScript.

Interaktivní animace ve Flashi

Flash vám dovoluje vytvářet interaktivní animace, ve kterých vaší diváci mohou použít
klávesnici nebo myš k tomu, aby skočili do jiné části animace, hýbali s objekty, zadali
informace do formulářů a prováděli mnoho dalších operací.
Můžete vytvořit interaktivní animace tím, že založíte akce použitím ActionScriptu.
Pro informace o zakládání nejběžnějších akcí se podívejte do kapitoly 12 „Vytváření
interaktivních animací.“ Pro kompletní informace o používání ActionScriptu se podívejte
do jeho uživatelské příručky.
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Bitmapová grafika

Bitmapová grafika popisuje obrázek použitím barevných bodů, nazývané pixely, které
jsou uspořádány do mřížky. Například obrázek listu je charakterizován určeným
umístěním a barevnou hodnotou každého bodu v mřížce, takže obrázek je vytvářen
podobným způsobem jako mozaika.

Když  editujete bitmapovou grafiku, měníte pixely a ne čáry a křivky. Bitmapová grafika
je závislá na rozlišení, protože data popisující obrázek jsou fixována k mřížce určitých
rozměrů. Editování bitmapové grafiky může změnit kvalitu jejího zobrazení. Obzvláště
změna velikosti bitmapy může způsobit, že okraje obrázku prezentovány jako body
jsou rozházeny po mřížce a tak působí roztřepeně. Také zobrazování bitmapové
grafiky na výstupní zařízení, které má menší rozlišení než sám obrázek znehodnocuje
kvalitu vzhledu.

Pracovní prostředí programu Flash

Když vytváříte a editujete animaci, typicky pracujete s těmito klíčovými částmi:

� Plocha - obdélníková oblast, kde se přehrávají animace

� Časová osa, kde je grafika animována podle časového rozvržení

� Symboly - znovu použitelné složky animace

� Okno Knihovny, kde jsou symboly uspořádány

� Prohlížeč animace, pomocí kterého máte přehled nad animací a její strukturou

� Plovoucí, upevnitelné panely, které vám dovolují měnit různé části animace
a nastavovat prostředí editoru tak, aby nejlépe vyhovovalo vaší pracovní
činnosti.
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Bitmapová a vektorová grafika

Počítače zobrazují grafiku buJ ve vektorovém nebo bitmapovém formátu.
Porozumění rozdílům mezi těmito dvěma formáty vám pomůže zefektivnit vaši práci.
Pomocí Flashe můžete vytvářet a animovat kompaktní vektorovou grafiku. Můžete
také importovat a manipulovat s vektorovou a bitmapovou grafikou, která byla
vytvořena v jiných aplikacích.

Vektorová grafika

Vektorová grafika popisuje obrázky pomocí čar a křivek, které se nazývají vektory
- ty také obsahují informace o barvě a pozici. Například obrázek listu je charakterizován
body, kterými prochází čáry vytvářející tvar obrysu listu. Barva listu je určená barvou
obrysové čáry a barvou plochy, která ji obklopuje. 

Když vektorovou grafiku editujete, měníte vlastnosti čar a křivek, které popisují její
tvar. Můžete hýbat, měnit velikost, tvar a barvu beze změny kvality jejího vzhledu.
Vektorové grafiky jsou nezávislé na rozlišení, což znamená, že mohou být zobrazeny
na výstupní zařízení různého rozlišení bez ztráty kvality.

KAPITOLA 2 - Správa sítě 51



Časová osa je místo kde koordinujete načasování animace a shromažJujete výtvory
umístěné na oddělených vrstvách

Vrstvy (layers) působí jako zaplněný povrch průhledného nátěru, který udržuje výtvory
oddělené, takže můžete kombinovat různé části do soudružného viditelného obrázku.

Logo, křeslo a navigační tlačítka v animaci jsou na oddělených vrstvách.

Symboly a instance

Symboly jsou znovu použitelné části, které v animaci používáte. Symbolem může být
grafika, tlačítko, animovaný klip, zvukový soubor nebo fonty. Když vytvoříte symbol,
je uložen v souborové knihovně. Když umístíte symbol na Plochu, vytváříte instanci
(výskyt) symbolu.

Symboly zmenšují velikost souboru, protože nezáleží na tom, kolik instancí symbolu
vytvoříte / Flash uloží symbol do souboru pouze jednou. Používat symboly (animované
či jiné) pro každý element, který se ve vaší animaci objeví více než jednou, je dobrý
nápad. Můžete měnit vlastnosti instance bez jakéhokoli vlivu na jeho symbol a zároveň
můžete změnit symbol, abyste změnili všechny jeho instance. 
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Plocha a Časová osa 

Stejně jako filmy jsou Flashové animace rozděleny do snímků podle časové délky.
A Plocha je místo, kde skládáte obsah pro každý snímek z animace, přímo kreslíte
složky animace nebo je importujete a urovnáváte.

Plocha je místo, kde skládáte jednotlivé snímky do animace.

Časová osa (timeline) je místo, kde koordinujete načasování animace a shromažJujete
výtvory umístěné na oddělených vrstvách. Časová osa zobrazuje každý snímek v animaci. 
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Symboly a interaktivní animace

Symboly jsou také nedílnou součástí vytváření interaktivní animace; můžete použít
instance symbolů, abyste vytvořili interaktivní animaci. Například můžete vytvořit symbol
tlačítka, který se změní v závislosti na tom, co dělá myš a umístí instanci symbolu
na Plochu. Použijete další typ symbolu nazvaný animovaný klip, abyste vytvořili
složitou interaktivní animaci. Viz kapitola 12 „Vytváření interaktivních animací.“

Okno Knihovny 

Okno Knihovny je místo, kde ukládáte a uspořádáváte jak symboly vytvořené ve Flashi,
tak importované soubory zahrnující zvukové soubory, bitmapovou grafiku a QuickTime
klipy. Pomocí okna Knihovny můžete uspořádat její položky do složek, podívat se,
jak často je položka používána v animaci a třídit je podle typu. Viz „Používání knihovny“.

Panely 

K prohlížení, organizování a měnění součástí v animaci můžete použít plovoucí pan-
ely, které obsahují příkazy a možnosti vztahující se ke každému jejímu typu. Panely
vám dovolují měnit symboly, instance, barvy, typ, rámy a další součásti. Můžete pan-
ely použít, abyste si přizpůsobili rozhraní Flashe tak, že zobrazíte panely, které potře-
bujete ke specifické úloze a ostatní skryjete. Viz „Používání panelů“.
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Symbol můžete editovat umístěním na Plochu. Ostatní součásti na Ploše jsou viditelné,
ale ztlumené. Symboly můžete také měnit v samostatném okně. Když editujete symbol,
okno Časové osy zobrazuje pouze Časovou osu symbolu, který editujete. Viz „Editování
symbolů“.

Můžete najít a otevřít symbol v knihovně zevnitř Movie Explorer (Prohlížeče animací)
použitím příkazu Find in Library (Najdi v knihovně). Viz „Používání Prohlížeče animací“.

Pro více informací k symbolům a instancím se podívejte do lekce Symboly umístěné
v nabídce Help > Lessons > Symbols a do kapitoly 10 „Používání symbolů a instancí.“
Editování symbolu zvlášR (vlevo) a editování symbolů v jeho kontextu vzhledem k animaci.
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Prohlížení a testování animací

Jak vytváříte animaci, budete ji potřebovat přehrát, abyste si ji prohlédli a otestovali
interaktivní tlačítka. Prohlížet a testovat animaci můžete v prostředí editoru Flashe,
v odděleném okně nebo v internetovém prohlížeči.

Prohlížení animací v prostředí editoru

K prohlížení animací použijte příkazy z nabídky Control (Kontrola), tlačítka na Controller
(Kontrolním) panelu nebo příkazy zadané z klávesnice.

K prohlédnutí aktuálního obrazu udělejte jedno následujících:

� Vyberte Control > Play

� Vyberte Window > Toolbars > Controller (Windows) nebo Window > Controller
(Macintosh) a klikněte na Play

� Stiskněte Enter (Windows) nebo Return (Macintosh). Sekvence animace
se přehrává v okně Movie (Animace) rychlostí, kterou jste pro ni určili. 
Abyste mohli procházet snímky animace, použijte tlačítka Step Forward
(O krok kupředu) a Step Backward (O krok zpět) z Kontrolního panelu nebo
zvolte příkazy z nabídky Control. Stejně tak můžete stisknout klávesy „<“ a „>“
na klávesnici. K přechodu na první nebo poslední snímek použijte tlačítko Rewind
(První snímek) nebo Go To End (Poslední snímek) v Kontrolním panelu. 

Poznámka: K prohlížení rámů animace můžete také přesunout přehrávání. Viz „Posuv
přehrávání“.

Přehrávání můžete měnit používáním příkazů v nabídce Control. Všimněte si, že abyste
mohli prohlížet animaci používáním následujících příkazů, musíte zároveň vybrat
Control > Play.

Přehrání animace v opakující se smyčce:

� Vyberte Control > Loop Playback (Přehrávání ve smyčce)

Přehrání všech scén v animaci:

� Vyberte Control > Play All Scenes (Přehrát všechny scény)
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Vytváření nové animace a nastavování jejích vlastností

Pokaždé, když otevřete Flash, aplikace vytvoří nový soubor s příponou FLA. V průběhu
vaší práce můžete vytvořit další nové animace. K nastavení velikosti, rychlosti animace,
barvy pozadí a dalších vlastností nové animace použijte dialogové okno Vlastnosti
animace.

K vytvoření nové animace nastavte tyto vlastnosti:

11.. Vyberte File > New.

22.. Vyberte Modify (Změnit) > Movie (Animaci). Objeví se dialogové okno Vlastnosti 
animace (Movie Properties).

33.. Pro nastavení Rychlosti animace zadejte počet animovaných snímků, které
se budou každou vteřinu objevovat. Pro mnoho animací, které se budou
zobrazovat na počítači (zvláště těch, které se budou přehrávat na Webové
stránce) je postačující hodnota 8 až 12 fps (snímků za vteřinu). 

44.. Za Dimensions (Rozměr) zvolte jednu z následujících možností:

� Abyste určili velikost Plochy, na které dojde k přehrávání, zadejte hodnoty
pro Šířku a Výšku. Implicitní hodnota animace je 550 x 400 bodů. Minimální
velikost je 18 bodů na 18 bodů; maximum je 2880 x 2880 bodů.

� K určení velikosti Plochy tak, aby bylo na všech stránkách stejně místa okolo
jejich obsahu, klikněte na Shoda obsahů. Abyste minimalizovali velikost animace,
tak vyrovnejte všechny součástí do levého horního rohu Plochy než použijete
nástroj Match Contents (Shoda obsahů).

� Abyste nastavili velikost Plochy na maximálně možnou oblast tisku, klikněte
na Match Printers (Shoda s tiskárnou). Oblast je určena podle velikosti papíru
minus současný okraj nastavený v Oblasti okrajů dialogového okna Nastavení
stránky (Windows) nebo dialogového okna Tisknout okraje (Macintosh).

55.. Abyste nastavili barvu pozadí vaší animace, vyberte barvu ze vzorníku barvy 
Bacground (Pozadí).

66.. Pro pravítka, která můžete zobrazit podél horní a boční strany aplikačního okna
vyberte jednotkovou míru z kontextové nabídky Ruler Units (Jednotky pravítka).
Viz „Používání mřížky, vodítek a pravítek“. (Možnost Jednotky pravítka také
určuje jednotky požité v Informačním panelu.)

77.. Klikněte na OK.
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Ukládaní animací

Soubor FLA můžete uložit tak, že použijete jeho aktuální jméno a umístění nebo ho můžete
uložit pod jiným názvem a umístěním. K naposled uležené verzi souboru se můžete vrátit.

K uložení dokumentu:

11.. Udělejte jedno z následujících:

� K přepsání aktuální verze na disk zvolte File > Save

� K uložení souboru do jiného umístění nebi pod jiným jménem zvolte File >
Save As.

22.. Pokud zvolíte příkaz Save As (Uložit jako) nebo pokud jste soubor ještě 
neukládali, vložte název souboru a jeho umístění.

33.. Klikněte na Save.

Návrat k předchozí verzi souboru:

� Vyberte File  > Revert (Návrat k předchozí).

Používání panelu nástrojů

Nástroje v panelu nástrojů vám umožňují kreslit, malovat, vybírat a měnit vaše výtvory
a změnit náhled na Plochu. Panel nástrojů je rozdělen do čtyř sekcí:

� Sekce Tools (Nástrojů) obsahující kreslení, malování a nástroje výběrů

� Sekce View (Náhledu) obsahující nástroje pro přibližování a přepínání do okna
aplikace

� Sekce Colors (Barev) obsahující měniče barevných výplní a kreslení čar

� Sekce Options (Možností) zobrazuje možnosti změny vybraného nástroje,
které mají vliv na jeho kreslení nebo editování.
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Přehrání animace bez zvuku:

� Vyberte Control > Mute Sounds (Ztlumit zvuk)

Umožnění akcí snímku nebo akcí tlačítka:

� Vyberte Control > Enable Simple Frame Actions (Umožnit jednoduché akce
snímku) nebo Enable Simple Buttons (Umožnit jednoduchá tlačítka).

Testování animací

Ačkoli Flash dokáže animace přehrávat v prostředí editoru, mnoho animačních a interak-
tivních funkcí nefunguje, dokud není animace exportována do svého konečného formátu.
Použitím příkazů v nabídce Control můžete aktuální animaci exportovat a rovnou
přehrát v novém okně. Exportovaná animace používá možnosti nastavené v dialogovém
okně Publish Settings (Nastavení publikování). Toto okno můžete také použít na to,
abyste otestovali, jak se bude animace stahovat. Viz „Test stahování animace“. Kromě toho
můžete animaci testovat v internetovém prohlížeči. 

Akce použité v animaci můžete také testovat použitím Debugger (Ladících prostředků).
Viz „Používání Ladicích prostředků“ v kapitole o odstraňování problémů Referenční
příručky ActionScript.

Otestování všech interaktivních funkcí a animací:

� Vyberte Control > Test Movie nebo Control > Test Scene.

Flash vytvoří animaci určenou pro Flash přehrávač (soubor SWF), otevře ji ve zvláštním
okně a přehrává ji pomocí přehrávače. Soubor SWF je umístěn do stejné složky
jako soubor FLA.

Otestování animace v internetovém prohlížeči:

� Vyberte File > Publish Preview > HTML. Viz „Prohlížení publikovaného
formátu a nastavení“.
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Používání panelů

Plovoucí panely vám pomáhají měnit, organizovat a nahlížet na prvky vaší animace.
Vlastnosti vybraného prvku můžete ovládat pomoci možností, které jsou k němu
k dispozici.

Panely ve Flashi vám umožňují práci s objekty, barvami, textem, instancemi, rámy,
obrazy a celou animací. Například k vybrání typu vlastnosti znaku použijete panel
Characters (Znaků) a ke vkládání popisků snímku a zvolení možnosti vykreslování
použijete panel Frame (Snímek). K prohlédnutí úplného seznamu panelů, které jsou
ve Flashi dostupné zvolte Window > Panels.

Při vaší práci můžete panely zobrazit, skrýt, seskupit. Můžete také zobrazit a skrýt
několik panelů včetně Informačního, Míchacího, panelu Instancí, Snímků a Akcí
použitím startovací lišty ve spodní části okna aplikace.

Panely můžete seskupovat dohromady tak, abyste je měli uspořádány podle vašich
představ a toto rozvržení potom uložit. Můžete vrátit zobrazení panelů do původního
rozložení (zobrazení Informačního, Míchacího, Znakového panelu a panelu Instancí
na pravou stranu okna aplikace) nebo do uživatelského rozvržení, které jste si dříve uložili.

Většina panelů obsahuje kontextovou nabídku s dalšími možnostmi. Kontextová
nabídka je označována Triangle indicating (trojúhelníkem) v pravém horním rohu panelu.
(Pokud  je trojúhelník špatně viditelný, tak k tomuto panelu žádná kontextová nabídka
neexistuje).
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Pro informace k používání nástrojů na kreslení a malování se podívejte do odstavce
„Kreslící a malovací nástroje produktu Flash“. Pro informace k používání nástrojů
na označování se podívejte do „Vybírání objektů“. Pro informace k používání nástrojů
sloužících k měnění náhledu se podívejte do odstavce „Prohlížení plochy“.

Zobrazení a skrytí panelu nástrojů:

� Vyberte Window  > Tools (Nástroje).

K vybrání nástroje proveJte jedno z následujících:

� Klikněte na nástroj, který chcete použít. V závislosti na tom, který nástroj jste
si zvolili, se ve spodní části panelu nástrojů objeví sada modifikátorů (modifiers)

� Stiskněte klávesovou zkratku příslušného nástroje
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Přenesení panelu ze skupiny do zvláštního okna:

� UchyRte panel za proužek a přetáhněte na vnější stranu okna.

Posunutí panelu nebo skupiny panelů:

� UchyRte panel nebo skupinu za horní proužek s titulkem a přetáhněte

Uložení uživatelského rozložení panelů:

� Vyberte Window > Save Panel Layout (Ulož rozvržení panelů). Zadejte jméno
rozvržení a klikněte na OK.

Smazání uživatelského rozvržení panelů:

� Otevřete složku aplikace Flash 5 na vašem pevném disku smažte soubor
Panel Sets (Nastavení panelů).

Zvolení rozvržení panelů:

11.. Vyberte Window > Panel Sets (Nastavení panelů).

22.. K nastavení rozvržení do původní podoby zvolte z podnabídky Default Layout 
(Původní rozvržení), jinak vyberte vlastní uspořádání, které jste si dříve uložili.

Změna velikost panelu:

� UchyRte pravý spodní roh panelu (Windows) a přetáhněte ho nebo uchyRte
a přetáhněte velikost obdélníku pravého spodního rohu panelu (Macintosh).

Sbalení panelu nebo skupiny tak, že je vidět pouze proužek s titulkem:

� Dvojklikněte na proužek s titulkem. Abyste vrátili  panel nebo skupinu do jejich
původní velikosti, dvojklikněte na proužek ještě jednou.

Sbalení panelu nebo skupiny tak, že je vidět pouze proužek s titulkem (pouze Macintosh:

� Klikněte na tlačítko sloužící ke sbalení umístěné na pravém konci proužku
s titulkem. Abyste vrátili  panel nebo skupinu do jejich původní velikosti,
znovu na něj klikněte.
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Otevření panelu:

� Zvolte Window > Panels a požadovaný panel vyberte ze seznamu.

K uzavření panelu proveJte jedno z následujících:

� Klikněte na tlačítko Close (Zavřít) v pravém horním rohu (Windows) nebo levém
horním rohu (Macintosh).

� Zvolte Window > Panels a požadovaný panel vyberte ze seznamu.

� Klikněte pravým tlačítkem (Windows) nebo zároveň držte klávesu Control
(Macintosh) na horní proužek panelu a zvolte Zavřít panel z kontextové nabídky.

Otevření nebo zavření panelů použitím Startovací lišty (Launcher bar):

� V Startovací liště, klikněte na tlačítko Info (Informačního), Characters (Znakového)
panelu nebo panelu Instance (Instancí) či Mixer (Míchače barev).

Poznámka: pomocí Startovací lišty můžete otvírat a zavírat také okno Knihovny
nebo Prohlížeče animací. Viz „Používání knihovny“ nebo „Používání Prohlížeče animací“.

Použití kontextové nabídky panelu:

11.. Klikněte na trojúhelník v pravém horním rohu panelu a zobrazí se vám nabídka

22.. Klikněte na položku v nabídce

Uzavření všech panelů:

� Zvolte Window > Close All Panels (Zavřít všechny panely)

Seskupení panelů:

� UchyRte panel za proužek a přetáhněte na horní proužek jiného panelu.

Přenesení panelu do čela skupiny:

� Klikněte na horní proužek panelu.
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Stav Časové osy zobrazený v jeho spodní části označuje aktuální číslo snímku (frame
number), aktuální rychlost přehrávání (frame rate) a zbývající čas do aktuálního
snímku (elapsed time).

Poznámka: když je animace přehrávána, je zobrazována aktuální rychlost; pokud
počítač nestačí animaci zobrazovat dostatečně rychle, může se tato hodnota lišit od
skutečné rychlosti.

V Časové ose můžete změnit způsob, kterým se snímky zobrazují a zobrazit náhledy
obsahu snímků. Časová osa ukazuje, na kterém místě v animaci dochází k pohybu,
včetně animace snímek za snímkem, vykreslování (tweened) animace a trasy pohybu
objektu. Pro více informací k animacím se podívejte na Kapitolu 11 „Vytváření animací.“

Ovládání v sekci vrstvy Časové osy vám umožní skrývat nebo zobrazovat, zamykat,
odemykat nebo zobrazovat obsah vrstev jako obrysy. Viz „Upravování animace“. Dále
můžete vkládat, mazat, vybírat a přemisRovat snímky. Snímky můžete také přetáhnout
na nové umístění, aR už do stejné nebo jiné vrstvy. Viz „Práce s rámy v Časové ose“.

Změna umístění Časové osy

Časová osa se implicitně objevuje nad Plochou, v horní části okna aplikace. Abyste
změnili její umístění, můžete Časovou osu ukotvit dolů nebo na stranu hlavního okna
aplikace nebo ho zobrazit v samostatném okně. Časovou osu můžete také skrýt.
Abyste změnili počet viditelných vrstev a snímků, můžete změnit velikost Časové osy.
Pokud je v Časové ose více vrstev než může být zobrazeno, můžete si další vrstvy
prohlédnout tak, že použijete rolovací lišty na jeho pravé straně.
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Používání kontextové nabídky

Kontextové nabídky obsahují příkazy vztahující se k danému výběru. Například pokud
vyberete rám v okně Časové osy, kontextová nabídka obsahuje příkazy pro vytváření,
mazání a měnění snímků a klíčových snímků.

Kontextová nabídka k vybranému snímku

Otevření kontextové nabídky:

� Klikněte pravým tlačítkem (Windows) nebo stiskněte Control a klikněte
(Macintosh) na položku v Časové ose, v okně Knihovny nebo na Ploše.

Používání Časové osy

Časová osa organizuje a kontroluje obsah animace ve vrstvách a snímcích z časového
hlediska. Hlavní komponenty Časové osy jsou vrstvy, snímky a přehrávání.

Vrstvy animace jsou vyjmenovány ve sloupci na levé straně Časové osy. Snímky
obsažené v každé vrstvě se zobrazují v řadě jména vrstvy, směrem doprava. Záhlaví
Časové osy umístěné na jeho vrcholu ukazuje číslo snímku. Ukazatel přehrávání
označuje aktuální snímek zobrazený na ploše.
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Změna zobrazení snímků v Časové ose

V Časové ose můžete měnit velikost snímků a zobrazovat jejich sekvenci s barevnými
políčky. Do Časové osy můžete také zahrnout náhled zmenšeniny obsahu snímku.
Tyto zmenšeniny jsou užitečné k tomu, abyste měli o animaci přehled, ale zabírají
zvláštní místo na obrazovce.

Změna zobrazení snímků v Časové ose:

11.. Klikněte na tlačítko Náhled snímku v pravém horním rohu Časové osy (vypadá 
jako plot) a zobrazí se vám kontextová nabídka 

22.. Vyberte z následujících možností:

Abyste změnili šířku políčka snímku, vyberte: Tiny (Drobný), Small (Malý), Normal
(Normální), Medium (Střední) nebo Large (Veliký). (Nastavení šířky na Veliký snímek
je užitečné pro zobrazení detailů zvukové křivky.)

Pro zmenšení výšky řádků buněk ve snímku vyberte Short (Krátký).

K zapnutí nebo zapnutí tónování sekvencí snímku vyberte Tinted Frames (Tónované
snímky).

K zobrazení zmenšenin obsahu každého snímku upravených tak, aby se shodovali
se snímky Časové osy, vyberte Preview (Náhled). Může to způsobit zdánlivě odlišnou
velikost obsahu.

Abyste zobrazili zmenšeniny každého plného snímku (včetně prázdného místa),
vyberte Preview in Context (Náhled v širší souvislosti). To je užitečné k prohlédnutí
způsobu, jakým se jednotlivé části v průběhu animace ve snímcích přesunují, ale tyto
pohledy jsou obecně menší než s volbou Náhled.
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Přesunutí Časové osy:

� Přesun z oblasti nad záhlavím Časové osy.

� K ukotvení přetáhněte Časovou osu na okraj okna aplikace. Abyste zabránili
ukotvování během přemisRování, zmáčkněte klávesu Control (Windows
i Macintosh).

Rozšíření nebo zkrácení názvu polí vrstvy:

� Přetáhněte sloupec oddělující názvy vrstev a část s rámy od Časové osy.

Abyste změnili velikost Časové osy, proveJte jedno z následujících:

� Pokud je Časová osa ukotvena v okně aplikace, přetáhněte sloupek oddělující
Časovou osu od okna aplikace

� Pokud Časová osa není ukotvena v okně aplikace, přetáhněte pravý dolní roh
(Windows) nebo obélník určující velikost v pravém dolním rohu (Macintosh).

Přesun ukazatele přehrávání 

Ukazatel přehrávání (playhead) se pohybuje přes Časovou osu a tím ukazuje aktuál-
ní snímek zobrazený na Ploše. Záhlaví Časové osy ukazuje čísla snímků animace. K
tomu, abyste zobrazili snímek na Ploše, musíte pohnout ukazatelem přehrávání na
snímek v Časové ose. Pokud pracujete s velkým počtem snímků a nemůžete je v
Časové ose zobrazit najednou, můžete ukazatel přehrávání v Časové ose umístit
doprostřed a tak jednodušeji najít správný snímek.

Přechod na snímek:

� Klikněte na umístění snímku v záhlaví Časové osy nebo přetáhněte ukazatel
přehrávání na žádoucí pozici.

Umístění ukazatele přehrávání doprostřed animace:

� Klikněte na tlačítko Center Frame button (Vyrovnat rám na střed)  ve spodní
části Časové osy.

KAPITOLA 2 - Správa sítě 67



Tvorba popisků snímku a komentářů k animaci

Popisky snímku jsou užitečné pro identifikaci klíčových snímků v Časové ose a pokud
na ně odkazujete v nějaké akci (např. Go to),  měly by být použity místo čísla snímku.
Pokud přidáváte nebo odebíráte snímky, přesunuje se popis s tím snímkem, ke
kterému byl původně připojen, i když se číslo snímku může změnit. Popisy jsou
exportovány s daty animace, takže abyste minimalizovali velikost souboru, vyhněte se
dlouhým názvům.

Komentáře ke snímku jsou užitečné pro poznámky určené pro vás i další lidi, kteří
pracují na stejné animaci. Komentáře nejsou exportovány s daty animace, takže je
můžete psát tak dlouhé, jak chcete.

Vytvoření poznámky nebo popisu ke snímku:

11.. Vyberte rám a zvolte Window > Panels > Frame.

22.. V panelu Frame zadejte text pro popisek nebo komentář do textového pole Label 
(Popisek). K vytvoření textového komentáře zadejte na začátek každého řádku
textu dvě lomítka (//).

Práce se snímky v Časové ose

V Časové ose pracujete se snímky a klíčovými snímky. Klíčový snímek je snímek, ve
kterém  definujete změnu v animaci nebo vkládáte akce, abyste animaci změnili.
Klíčové snímky jsou důležitou součástí vykreslované (tweened) animace. Přesunutím
klíčového snímku v Časové ose můžete měnit délku vykreslené animace. 

Se snímky a klíčovými snímky můžete provést následující změny:

� Vložit, vybrat, smazat a přesunout

� Přetáhnout je do nového umístění na stejné nebo odlišné vrstvě

� Kopírovat je a vkládat

� Přeměnit klíčové snímky na snímky

� Přetáhnout položku z okna Knihovny na Plochu za účelem jejího přidání
do aktuálního klíčového snímku

Časová osa poskytuje náhled na vykreslené snímky animace. Pro informace k editování
vykreslených snímků se podívejte do Kapitoly 11, „Tvorba animace.“
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Kontextová nabídka Náhledu snímku

Volby k náhledu  snímku Krátký a Normální

Volby Náhled a Náhled v širší souvislosti
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� K změnění délky vykreslené (tweened) sekvence, zatáhněte pomoci myši
začáteční nebo konečný klíčový snímek doprava nebo doleva. Abyste zjistili,
jak změnit sekvenci snímek za snímkem, podívejte se na odstavec „Tvorba
animace snímek za snímkem“.

� K přidání položky z knihovny do aktuálního klíčového snímku, přetáhněte
položku z okna Knihovny na Plochu. 

Používání scén

Pro tématickou organizaci vaší animace můžete používat scény. Například můžete
použít zvláštní scénu pro úvod, nahrání vzkazu a pro seznam lidí, kteří se na tvorbě
animace podíleli.

Když publikujete animaci Flash, která obsahuje víc než jednu scénu, přehrají se scény
v souboru SWF v jedné sekvenci v takovém pořadí, v jakém jsou uspořádány na Panelu
scén ve FLA souboru. Snímky v souboru SWF jsou očíslovány za sebou ve scénách.
Například pokud obsahuje animace dvě scény, z nichž každý má deset snímků,
snímky ve Scéně 2 jsou očíslovány 11 - 20.

Scény můžete přidávat, mazat, duplikovat, přejmenovávat nebo měnit.

Pro zastavení nebo pozastavení animace po každém scéně nebo pro umožnění
uživateli navigace v nelineárním pořadí můžete použít akce. Viz Kapitola 12 "Tvorba
interaktivních animací".

Zobrazení Panelu scén :

� Zvolte Window > Panels > Scene

Prohlížení určité scény :

� Zvolte Window > Go to a pak vyberte jméno scény z podnabídky.
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K přidání snímků do Časové osy proveJte jedno z následujících:

� K přidání nového snímku zvolte Insert > Frame.

� K vytvoření nového klíčového snímku zvolte Insert > Keyframe, nebo klikněte
pravým tlačítkem myši (Windows) nebo klikněte a zároveň držte stisknutou 
klávesu Control (Macintosh) na snímku, kde chcete klíčový snímek 
umístit a z kontextové nabídky vyberte Insert Keyframe.

� K vytvoření nového prázdného klíčového rámu vyberte Insert > Blank Keyframe,
nebo klikněte pravým tlačítkem myši (Windows) nebo klikněte a zároveň držte
stisknutou klávesu Control (Macintosh) na snímku, kde chcete klíčový snímek
umístit a z kontextové nabídky vyberte Insert Blank Keyframe.

Ke smazání nebo změně snímku nebo klíčového snímku proveJte jedno z následujících:

� Ke smazání snímku, klíčového snímku nebo sekvence snímků, vyberte snímek,
klíčový snímek nebo sekvenci snímků a zvolte Insert > Delete Frame, nebo
klikněte pravým tlačítkem myši (Windows) nebo klikněte a zároveň držte
stisknutou klávesu Control (Macintosh) na snímku, klíčový snímek nebo
sekvenci znaků a z kontextové nabídky vyberte Delete Frame. Okolní snímky
zůstávají nezměněny.

� K přesunutí klíčového snímku nebo sekvence snímků je pomoci myši přetáhněte
do požadovaného umístění.

� Ke zvýšení doby trvání klíčového snímku ho se stisknutou klávesou Alt (Windows)
nebo Option (Macintosh)  přetáhněte myší do konečného snímku sekvence
nové doby trvání.

� Ke kopírování klíčového snímku nebo sekvence snímků pomocí myši, klikněte
na ně se stisknutou klávesou Alt (Windows) nebo Option (Macintosh)
a přetáhněte do nového umístění.

� Ke kopírování a vkládání snímku nebo sekvence snímků, označte snímek
nebo sekvenci a vyberte Edit > Copy Frames. Vyberte snímek nebo sekvenci,
kterou chcete nahradit a zvolte Edit > Paste Frames.

� K přeměně klíčového snímku na snímek vyberte klíčový snímek a zvolte
Insert > Clear Keyframe, nebo klikněte pravým tlačítkem myši (Windows)
nebo klikněte a zároveň držte stisknutou klávesu Control (Macintosh) na klíčovém
snímku a z kontextové nabídky vyberte Clear Keyframe. Vyprázdněný klíčový
snímek a všechny snímky až do následujícího klíčového snímku jsou nahrazeny
obsahem snímku, který vyprázdněnému klíčovému snímku předcházel.
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Ve Flashi také můžete vytvářet stálé knihovny, které budou k dispozici, kdykoliv
spustíte Flash. Flash také obsahuje několik vestavěných knihoven, obsahujících tlačítka,
grafiku, klipy a zvuky, které můžete přidávat do svých vlastních animací. Seznam
vestavěných knihoven a stálých knihoven, které vytvoříte, se nachází pod volbou
Window > Common Libraries (Společné knihovny). Viz "Práce se sdílenými knihovnami".

Knihovnu můžete exportovat do URL pro vytvoření shared library (sdílené knihovny),
což vám dovolí odkazovat se na položky knihovny jakékoliv animace Flash. Viz "Používání
sdílených knihoven".

Pro zobrazení okna Knihovna proveJte jedno z následujících:

� Zvolte Window > Library.

� Klikněte na tlačítko Knihovna na Startovací liště okna aplikace.
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Pro přidání scény proveJte jedno z následujících:

� Klikněte na tlačítko Add Scene v Scene panel (Panelu scén).

� Zvolte Insert > Scene.

Pro smazání scény proveJte jedno z následujících :

� Klikněte na tlačítko Delete Scene na Panelu scén.

� Otevřete scénu kterou chcete smazat, a zvolte Insert > Remove Scene.

Změna názvu scény:

� Dvakrát klikněte na jméno scény v Panelu scén a zadejte nové jméno.

Duplikace scény:

� Klikněte na tlačítko Duplicate Scene na Panelu scén.

Pro změnu pořadí scén v animaci:

� Přetáhněte jméno scény do jiného místa na Panelu scén.

Používání knihovny

Knihovna v animaci Flashe uchovává symboly, včetně těch, které byly ve Flashi
vytvořeny a těch, které byly do Flashe importovány, a umožňuje vám tyto soubory
prohlížet a organizovat během vaší práce. Okno Knihovna zobrazuje posuvný seznam
se jmény všech položek obsažených v knihovně. Ikona vedle jména položky v knihovně
vyjadřuje typ souboru dané položky.

Když v okně Knihovna vyberete položku, objeví se miniaturní náhled na položku v horní
části okna Knihovna. Jestliže je zvolená položka animovaná nebo je to zvukový soubor,
můžete použít tlačítko Play v okně Knihovna nebo ovladač pro přehrání (controller).

Položky knihovny můžete organizovat do složek. Sloupce v okně Knihovna zobrazí
jméno jakékoliv položky, její typ, číslo představující počet jejího použití v souboru, její
odkazovací status (je-li položka asociována se sdílenou knihovnou) a datum, kdy byla
naposledy upravena. Položky v okně Knihovna můžete seřadit podle kteréhokoliv
sloupce. Okno Knihovna také obsahuje kontextové menu Options (Volby) s volbami
pro úpravu položek knihovny.
Pro editaci položek knihovny, včetně importovaných souborů, zvolte options z menu
Library Options (Volby knihovny). Importované soubory můžete po jejich úpravě v externím
editoru aktualizovat použitím volby Update (Aktualizovat) ve Volbách knihovny.

Při práci s Flashem můžete otevřít knihovnu k jakémukoliv FLA souboru, čímž si zpřís-
tupníte položky knihovny daného souboru pro aktuální animaci.
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Práce se složkami (folders) v okně Knihovna

Použitím složek můžete organizovat položky v okně Knihovna, podobně jako v
Průzkumíkovi ve Windows nebo Hledači na Macintoshi. Když vytváříte nový symbol,
je uložen ve zvolené složce. Jestliže není vybrána žádná složka, je symbol uchován v
kořenovém adresáři knihovny.

Vytvoření nové složky:

� Klikněte na tlačítko New Folder (Nová složka) ve spodní části okna Knihovna.

Přesun položky mezi složkami:

� Přetáhněte položku z jedné složky do druhé. 

Pro otevření nebo zavření složky proveJte jedno z následujících:

� Dvakrát klikněte na složku.

� Vyberte složku a zvolte Expand Folder (Rozbalit složku) nebo Collapse Folder
(Sbalit složku) z nabídky Volby knihovny.

Otevření nebo zavření všech složek:

� Zvolte Expand All Folders (Rozbalit všechny složky) nebo Collapse All Folders
(Sbalit všechny složky) z nabídky Volby knihovny.

Řazení položek v okně Knihovna

V okně Knihovna lze položky řadit alfanumericky podle jakéhokoliv sloupce.
Řazení položek vám umožní vidět příbuzné položky pohromadě. Položky jsou
seřazeny v rámci složek.

Seřazení položek v okně Knihovna:

� Klikněte na záhlaví sloupce, podle něhož chcete položky řadit. Kliknutím
na trojúhelníkové tlačítko napravo od záhlaví sloupce obrátíte pořadí položek.
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Použití položky knihovny v aktuální animaci:

� Přetáhněte položku z okna Knihovna na Plochu. Položka je přidána do aktuální
vrstvy.

Otevření knihovny z jiného souboru Flash: 

11.. Zvolte file > Opes as Library (Otevřít jako knihovnu).

22.. Přesuňte se na soubor, jehož knihovnu chcete otevřít, a klikněte na Otevřít.

Knihovna zvoleného souboru se otevře v aktuálním okně se jménem souboru v horní
části okna Knihovna. Pro použití položek z knihovny vybraného souboru v současné
animaci přetáhněte položky do okna Knihovna aktuální animace.

Pro změnu velikosti okna Knihovna proveJte jedno z následujících:

� Táhněte za pravý dolní roh.

� Klikněte na tlačítko Wide State (Široký stav) pro zvětšení okna Knihovna,
takže budou zobrazeny všechny sloupce.

� Klikněte na tlačítko Narrow State (Úzký stav) pro zmenšení šířky okna Knihovny
jen na sloupec Název.

Změna šířky sloupce:

� Umístěte ukazatel mezi záhlaví sloupce a táhněte s ním, čímž změníte velikost.
Nemůžete měnit pořadí sloupců.

Použití menu Volby knihovny:

11.. Klikněte na trojúhelník v pravém horním rohu okna Knihovna, čímž se vám
zobrazí kontextové menu.

22.. Klikněte na položku v menu.
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Vymazání položky v knihovně

Jestliže smažete položku z knihovny, všechny instance a události této položky v animaci
budou také smazány. Sloupec Use Count (Stav použití) v okně Knihovna ukazuje,
zda je položka používána.

Smazání položky knihovny:

� Vyberte položku a pak klikněte na ikonu s košem na odpadky v dolní části
okna Knihovna

Nalezení nepoužívaných položek knihovny

Pro zmenšení velikosti FLA souboru ve Flashi můžete vyhledat nepoužívané položky
knihovny a smazat je. Nicméně není nutné tyto položky mazat pro zmenšování
velikosti SWF souboru animace, protože do něj nepoužívané položky knihovny
nejsou zahrnuty.

Pro nalezení nepoužívaných položek udělejte jedno z následujících:

� Zvolte Select Unused Items (Označit nepoužívané položky) v menu Volby
knihovny.

� SeřaJte položky knihovny podle sloupce Use Count (Stav použití). Viz "Seřazení
položek v okně Knihovna".

Aktualizace importovaných souborů v okně Knihovna

Pokud použijete ke změně souborů, které jste importovali do Flashe, jako jsou např.
bitmapy nebo zvukové soubory, nějaký externí editor, může tyto soubory ve Flashi
aktualizovat, bez toho abyste je museli znovu importovat.

Aktualizace importovaného souboru:

� Vyberte importovaný soubor v okně Knihovna a zvolte Update (Aktualizovat)
z nabídky Volby knihovny.

78 Uživatelská příručka - FLASH 5

Editace položek v knihovně

Jakékoliv položky knihovny lze editovat ve Flashi nebo, v případě importovaných
souborů, v jakémkoliv externím editoru.

Editace položky v knihovně:

11.. Zvolte položku v okně Knihovna.

22.. Z menu Volby knihovny vyberte jedno z následujících:

� Zvolte Editovat pro úpravu položky ve Flashi.

� Zvolte Editovat pomocí a vyberte externí aplikaci, v níž si přejete položku
upravovat.

Přejmenování položek v knihovně

Položky v knihovně lze přejmenovat. Změna jména položky importovaného souboru
nemění jméno daného souboru.

Pro přejmenování položky knihovny proveJte jedno z následujících:

� Dvakrát klikněte na jméno položky a zadejte nové jméno do textového pole.

� Vyberte položku a klikněte na ikonu vlastností v dolní části okna Knihovna.
Zadejte nové jméno do dialogového okna Symbol Properties (Vlastnosti
symbolu) a klikněte na tlačítko OK.

� Vyberte položku a zvolte Rename (Přejmenovat) z menu Volby knihovny,
pak zadejte nové jméno do textového pole.

� Klikněte pravým tlačítkem myši (ve Windows) nebo podržte Control a klikněte
(na Macintoshi) na položku a z kontextového menu vyberte Přejmenovat,
pak zadejte nové jméno do textového pole.

KAPITOLA 2 - Správa sítě 77



Tvorba sdílených položek a odkazy na ně

Pro vytvoření sdílené knihovny, kterou můžete použít v dalších animacích, definujete
vlastnosti odkazů pro položky v knihovně animace. Když animaci uložíte, sdílená knihovna
se uloží spolu s FLA souborem animace.

Pro používání položek ze sdílené knihovny jiné animace zvolte File > Open As Shared
Library (Otevřít jako sdílenou knihovnu) v aktuálním okně, pak označte soubor sdílené
knihovny, kterou chcete používat. Sdílená knihovna se otevře jako okno knihovny
v aktuální animaci. Pak přidáte položky ze sdílené knihovny do knihovny aktuální
animace, abyste vytvořili odkazy na položky.

Aby bylo animacím, které se odkazují na sdílené knihovny, umožněno zobrazit
odkázané položky, musíte sdílenou knihovnu také umístit na web. Pro zveřejnění
sdílené knihovny na webu musíte publikovat animaci, ve které jste sdílenou knihovnu
vytvořili. Tato procedura umístí sdílenou knihovnu na stejné URL, kde se nachází SWF
soubor animace. (Pokud si to přejete, můžete určit jiné umístění sdílené knihovny.) 

Když přehráváte Flash animaci, která obsahuje odkazy na sdílené položky, animace
nahraje sdílenou knihovnu z jejího umístění na webu a zobrazí sdílené položky, jak je
uvedeno. Animace stáhne celý soubor sdílené knihovny, když doběhne k prvnímu
rámu obsahujícímu odkaz na položku. (Pokud animace obsahuje odkázané položky
z více než jedné knihovny, bude zvlášR nahrána každá knihovna, jakmile se objeví
první položka této knihovny.)

Pokud nastane chyba ve stahování sdílené knihovny, animace se nepřehraje.
Doporučuje se uchovávat knihovny co nejmenší, aby se minimalizovala doba stahování,
a testovat animace, které se odkazují na sdílené položky, abyste se ujistili, že stahování
dobře funguje.

Definování položek sdílené knihovny

Dialogové okno Symbol Linkage (Vazba symbolů) použijete pro přiřazení vlastností
odkazů existujícím položkám v knihovně, čímž určíte, že dané položky budou
položkami sdílené knihovny. Po přiřazení vlastností odkazů sdíleným položkám
musíte uložit soubor animace, ve kterém jste definovali sdílené položky, aby odkazy
na tyto položky byly dostupné z jiných animací Flash. 

Dialogové okno Symbol Linkage (Vazba symbolů) také použijete pro přiřazení
identifikačního jména pro klip nebo zvukový soubor, který chcete přehrát použitím
metody attachMovie (připojenáAnimace) nebo attachSound (připojenýZvuk). Pro infor-
mace o metodě připojenáAnimace viz "Připojování klipů animace" v kapitole o klipech
animace Referenční příručky o ActionScript. Pro informace o metodě připojenýZvuk
viz "Vytváření zvukového ovládání" v interakční kapitole Referenční příručky
ActionScript.
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Práce se společnými (common) knihovnami

Pro přidávání symbolů, tlačítek nebo zvuků do vaší animace můžete použít vestavěné
knihovny obsažené ve Flashi. Také můžete vytvářet stálé knihovny pro své Flash
aplikace, které pak lze použít pro jakoukoliv animaci, kterou budete vytvářet.
(Knihovna, kterou vytváříte při úpravě animace Flash, je dostupná pouze k této animaci,
pokud z ní neučiníte stálou knihovnu nebo nezvolíte File > Open As Library.)

Oba tyto typy knihoven jsou v seznamu pod volbou Window > Common Libraries.

Vytvoření stálé knihovny pro vaši aplikaci Flash:

11.. Vytvořte soubor Flash s knihovnou obsahující symboly, které chcete mít ve stálé
knihovně.

22.. Umístěte soubor Flash do složky Knihovny, která je ve složce aplikace Flash 
na vašem disku.

Použití položky ze společné knihovny v animaci:

11.. Zvolte Window > Common Libraries a vyberte knihovnu z podnabídky.

22.. Přetáhněte položku ze společné knihovny do knihovny pro aktuální animaci.

Používání sdílených (shared) knihoven

Pro používání položek jedné knihovny ve více animacích můžete vytvářet sdílené kni-
hovny. Pro používání sdílených knihoven nejprve definujete položku knihovny v jedné
animaci a pak na ni odkážete v jiných animacích. Když odkážete na položku ve
sdílené knihovně, položka je považována za externí soubor, ale soubor s položkou
není připojen k animaci.

Požívání sdílených knihoven může optimalizovat vaši pracovní činnost a řízení
položek animace různými způsoby. Sdílené knihovny můžete použít například k těmto
činnostem:

� Sdílení zvukového souboru v rámci celé web stránky

� Sdílení textových symbolů v rámci více web stránek (pro informace o textových
symbolech viz "Tvorba textových symbolů")

� Stanovení jednoho zdroje pro prvky animace používané ve více scénách
nebo animacích.

� Vytvoření centrální knihovny zdrojů, která se použije pro úpravy průběhu
a ovládání.
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Odkazování na položky sdílené knihovny

Pro odkazy na položky sdílené knihovny animace Flash otevřete sdílenou knihovnu
a přidáte položky sdílené knihovny do knihovny aktuální animace.

Pro vytvoření odkazu na sdílené položky otevřete FLA soubor pro sdílenou knihovnu.
Není nutné publikovat sdílenou knihovnu jako SWF soubor, pokud chcete vytvořit
odkazy na sdílené položky.

Poznámka: Pro náhled na odkázané položky při testování animace nebo pro
zobrazení odkázaných položek když přehráváte publikovanou animaci musíte nejprve
vytvořit SWF soubor pro sdílenou knihovnu. Pro vytvoření SWF souboru sdílené knihovny
publikujete animaci, ve které jste vytvořili sdílenou knihovnu.

Odkazy na položky sdílené knihovny:

11.. Mějte otevřený soubor animace, vyberte File  > Open As Shared Library.

22.. Vyberte sdílenou knihovnu, kterou si přejete otevřít a klikněte na Otevřít.

� Sdílená knihovna se otevře jako okno Knihovna v aktuální animaci. Příkazy
a tlačítka v menu Volby v okně sdílené knihovny jsou ztlumená, což znamená,
že nejsou k dispozici.

33.. Pro odkaz na položku sdílené knihovny v aktuální animaci proveJte jedno 
z následujících:

� Přetáhněte položku ze sdílené knihovny do aktuální animace.

� Přetáhněte položku ze sdílené knihovny na Plochu.

� Název sdílené položky se objeví v knihovně aktuální animace. Položka 
je odkázána do aktuální animace jako externí soubor; soubor položky není
přidán k aktuální animaci.

Používání Prohlížeče animací (Movie Explorer)

Prohlížeč animací vám poskytne jednoduchý způsob prohlížení a organizování
obsahu animace a výběru prvků animace pro změnu. Nabízí mnoho způsobů zefektivnění
práce pro tvorbu animací. Prohlížeč animací můžete například použít pro tyto činnosti:

� Hledat prvek animace podle jména

� Zobrazovat panel vlastností pro zvolený prvek pro provedení změn

� Seznámit se se strukturou animace Flash vytvořenou jiným uživatelem

� Najít všechny instance určitého symbolu nebo akce
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Definice položky sdílené knihovny:

11.. Mějte otevřený soubor animace, vyberte Window > Library nebo klikněte 
na tlačítko Knihovna na Startovací liště (v pravé dolní části okna aplikace),
čímž se zobrazí okno Knihovna, pokud již není viditelné.

22.. ProveJte jedno z následujících:

� Označte položku v okně Knihovna a vyberte Linkage (Vazba) z menu Volby
knihovny.

� Klikněte pravým tlačítkem (ve Windows) nebo podržte Control a klikněte
(na Macintoshi) na položku v okně Knihovna a vyberte z kontextového menu
volbu Linkage (Vazba)

33.. V dialogovém okně Linkage Properties (Vlastnosti vazby) symbolu zvolte
Exportovat symbol.

44.. V textovém poli Identifier (Identifikátor) vložte identifikátor, nebo jméno,
pro symbol. (V identifikátoru nesmějí být mezery.)

55.. Klikněte na tlačítko OK.

66.. Uložte soubor animace.

Umístění sdílené knihovny na URL

Aby se sdílené položky objevily v animaci, která na ně obsahuje odkazy, musí být
sdílená knihovna umístěna na URL jako SWF soubor. Když publikujete animaci, která
obsahuje sdílenou knihovnu (to znamená animaci, v níž jste definovali sdílené
položky), je sdílená knihovna automaticky zahrnuta v SWF souboru animace.

Aby byla knihovna zahrnuta do SWF souboru animace, není třeba specifikovat její
URL. Nicméně můžete to udělat, jestliže chcete knihovnu umístit jinam.

Specifikace URL pro sdílenou knihovnu:

11.. V okně Knihovna zvolte Shared Library Properties (Vlastnosti sdílené knihovny) 
z menu Volby knihovny.

22.. V dialogovém okně Vlastnosti sdílených knihoven zadejte URL, na které chcete
svou sdílenou knihovnu umístit.

33.. Klikněte na tlačítko OK.
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Náhled na Prohlížeč animací:

� Zvolte Window > Movie Explorer (Prohlížeč animací).

Výběr kategorií položek zobrazených v Prohlížeči animací:

� Klikněte na jedno nebo více filtračních tlačítek napravo od Show option (Ukázat
volbu) pro zobrazení textu, symbolů, ActionScriptu, importovaných souborů
nebo snímků a vrstev. Pro uzpůsobení toho, které položky ukazovat, klikněte
na tlačítko Customize (Uzpůsobit). Označte volby v oblasti Show (Zobrazit)
v dialogovém okně Nastavení Prohlížeče animací, abyste tyto prvky viděli.

� Z kontextového menu v pravém horním rohu Prohlížeče animací zvolte
Show Movie Elements (Zobrazit prvky animace), čímž zobrazíte položky
ve scénách, a vyberte Show Symbol definitions (Zobrazit definice symbolů),
aby se vám zobrazily informace o symbolech. (Obě volby mohou být aktivní
zároveň)

Hledání položky pomocí okna Find (Najít) text:

� V okně Find (Najít) text zadejte název položky, název fontu, řetězec ActionScript,
číslo snímku nebo pár jmenných nebo hodnotových Zdrojových objektů.
Funkce Najít vyhledá všechny položky aktuálně zobrazené v Prohlížeči animací.

Výběr položky z Prohlížeče animací:

� Klikněte na položku v navigačním stromě. Držte Shift a klikněte na další položky,
pokud jich chcete označit více.

� Úplná cesta pro zvolenou položku se objeví ve spodní části Prohlížeče animací.

� Výběrem scény z Prohlížeče animací se zobrazí první snímek této scény na Ploše.
Výběr prvku v Prohlížeči animací vybere tento prvek na Ploše, pokud vrstva,
která tento prvek obsahuje, není zamčená.

Použití příkazů kontextového menu nebo pop-up menu Prohlížeče animací:

11.. ProveJte jedno z následujících:

� Pro náhled na pop-up menu klikněte na trojúhelník v pravém horním rohu
Prohlížeče animací.

� Pro náhled na kontextové menu klikněte pravým tlačítkem (ve Windows) nebo
podržte Control a klikněte (na Macintoshi) na položku v navigačním stromě
Prohlížeče animací.
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� Nahradit všechny výskyty určitého fontu jiným fontem

� Prohlížet páry jmen/hodnot pro Objekty Macromedia Generator

� Kopírovat text do Schránky a vkládat jej do externího textového editoru
pro kontrolu pravopisu

� Tisknout seznam zobrazení, který je aktuálně zobrazen v Prohlížeči animací.

Prohlížeč animací zahrnuje seznam zobrazení, seznam obsahu animace seřazený
v ovladatelném hierarchickém stromě. Můžete omezit, které  kategorie položek animací
jsou zobrazeny v Prohlížeči animací vybráním z textu, grafiky, tlačítek, klipů, akcí,
importovaných souborů a Zdrojových objektů. Zvolené kategorie můžete zobrazit
jako prvky animace (obrazy), definice symbolů nebo jako obojí. Navigační strom
můžete rozbalovat a sbalovat.

Prohlížeč animací obsahuje kontextové menu s volbami a kontextová menu pro volby
provádění operací pro určité položky nebo změnu zobrazení Prohlížeče animací.
Kontextové menu s volbami je označeno trojúhelníkem v pravém horním rohu
Prohlížeče animací.
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� Collapse Others (Sbalit další) sbalí větve v navigačním stromě, které neobsahují
daný prvek.

� Print (Tisknout) vytiskne hierarchický seznam zobrazení, který je aktuálně
zobrazen v Prohlížeči animací.

Náhled na Plochu

Pro změnu náhledu na Plochu můžete změnit úroveň zvětšení nebo pohybovat s Plochou
v rámci pracovního prostředí Flash. Svůj náhled na Plochu můžete také přizpůsobit
tlačítky View (Náhled).

Změna velikosti náhledu

Změnou úrovně zvětšení můžete vidět na obrazovce celou Plochu nebo určitou
zvětšenou část vašeho výtvoru. Maximální úroveň zvětšení závisí na rozlišení vašeho
monitoru a velikosti animace.

Pro zvětšení nebo zmenšení náhledu na Plochu použijte tyto postupy:

� Pro zvětšení určitého prvku vyberte nástroj Lupa a klikněte na prvek. Pro přepnutí
Lupy mezi zvětšením a zmenšením použijte měnič Zvětšit nebo Zmenšit
nebo přidržte klávesu Alt (ve Windows) nebo klávesu Volba (na Macintoshi).

� Pro zvětšení určité oblasti vašeho výtvoru táhněte obdélníkový výběr pomocí
nástroje Lupa. Flash nastaví úroveň zvětšení, takže daný obdélník vyplní okno.

� Pro zvětšení nebo zmenšení náhledu na celou plochu zvolte View > Zoom
In nebo View > Zoom Out.

� Pro zvětšení nebo zmenšení o dané procento zvolte view > Magnification
a vyberte procento z podnabídky nebo zvolte procento v Zoom (Lupě) v levé
dolní části okna aplikace.
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22.. Vyberte si volbu z nabídky:

� Goto Location přeskočí na zvolenou vrstvu, scénu nebo rám animace.

� Goto Symbol Definition (Definice symbolu)přeskočí na definici symbolu,
který je vybrán v oblasti Movie Elements (Prvky animace) v Prohlížeči animací.
Definice symbolu obsahuje všechny soubory přiřazené k symbolu. (Volba
Show Symbol Definitions (Definice symbolu zobrazit) musí být označena.
Viz níže - definice volby.)

� Select Symbol Instances (Vybrat instance symbolu) přeskočí na scénu
obsahující instance symbolu, který je vybrán v oblasti Definice symbolů
v Prohlížeči animací. (Volba Show Movie Elements (Zobrazit prvky animace)
musí být označena. Viz níže - definice volby.)

� Find in Library (Najít v knihovně) zvýrazní vybrané symboly v okně knihovny
(Flash otevře okno Knihovny, pokud již není zobrazeno).

� Properties (Vlastnosti) otevře příslušný panel nebo panely pro označený prvek.
(Některé prvky mohou mít víc než jeden přiřazený panel.)

� Rename (Přejmenovat) vám umožní vložit nové jméno vybraného prvku.

� Edit in Place (Editovat na ploše) vám umožní upravit vybraný symbol na ploše.

� Edit in New Window (Editovat v novém okně) vám umožní upravit symbol
v novém okně.

� Show Movie Elements (Zobrazit prvky animace) zobrazí prvky vaší animace,
organizované do scén.

� Show Symbol Definitions (Zobrazit definice symbolů) zobrazí všechny prvky
přiřazené k symbolu.

� Copy Text to Clipboard (Kopírovat text do schránky) zkopíruje označený text
do Schránky. Můžete tento text vložit do externího textového editoru pro kontrolu
pravopisu nebo pro další úpravy.

� Cut (Vyjmout), Copy (Kopírovat), Paste (Vložit) a Clear (Vymazat) vykonají
tyto běžné funkce na označeném prvku. Změna položky v seznamu zobrazení
změní odpovídající prvek v animaci.

� Expand Branch (Rozbalit větev) rozbalí navigační strom ve zvoleném prvku.

� Collapse Branch (Sbalit větev) sbalí navigační strom ve zvoleném prvku.

KAPITOLA 2 - Správa sítě 85



Zobrazení nebo skrytí pravítek:

� Zvolte View > Rulers (Pravítka)

Určení jednotkové míry pravítka:

11.. Zvolte Modify > Movie.

22.. Zvolte volbu z kontextového menu Rulers Units (Jednotky pravítka).

Zobrazení nebo skrytí kreslící mřížky nebo vodítek:

� Zvolte View > Grid > Show Grid (Zobrazit mřížku) 
nebo View > Guides > Show Guides (Zobrazit vodítka).

� Zvolte View > Grid > Edit Grid (Upravit mřížku) 
nebo View > Guides > Edit Guides (Upravit vodítka) a v dialogovém okně 
vyberte Show Grid (Zobrazit mřížku) nebo Show Guides (Zobrazit vodítka).

Poznámka: Jestliže je mřížka viditelná a Snap to Grid (Ukotvit k mřížce) je aktivováno,
pak se po vytvoření ukotví vodítka k mřížce.

Pro aktivaci nebo deaktivaci ukotvení k čárám mřížky nebo vodítkům proveJte jedno
z následujících:

� Zvolte View > Grid > Snap to Grid (Ukotvit k mřížce) 
nebo View > Guides > Snap to Guides (Ukotvit k vodítkům).

� Zvolte View > Grid > Edit Grid (Upravit mřížku)  
nebo View > Guides > Edit Guides (Upravit vodítka) a v dialogovém okně 
vyberte Snap to Grid (Ukotvit k mřížce) nebo Snap to Guides (Ukotvit k vodítkům).

Poznámka: V místech, kde jsou vodítka mezi čárami mřížky, má ukotvení k vodítkům
přednost před ukotvením k mřížce.

Určení ukotvovací odchylky pro mřížku nebo vodítka:

11.. Zvolte View > Grid > Edit Grid (Upravit mřížku) 
nebo View > Guides > Edit Guides (Upravit vodítka).

22.. Vyberte volbu z kontextového menu Snap Accuracy (Přesnost ukotvení) 
v dialogovém okně.

Změna barvy mřížky nebo čáry mřížky:

11.. Vyberte View > Grid > Edit Grid (Upravit mřížku) 
nebo View > Guides >Edit Guides (Upravit vodítka).

22.. Klikněte na trojúhelník vedle palety barev a vyberte z palety.
Implicitní barva čáry mřížky je šedá. Implicitní barva čáry vodítka je zelená.
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� Pro zobrazení obsahu aktuálního rámu zvolte View > Magnification > Show All
nebo zvolte Show All (Ukázat vše) v Lupě v levé dolní části okna aplikace.
Jestliže je scéna prázdná, je zobrazena celá Plocha.

� Pro zobrazení celé Plochy zvolte View > magnification > Show Frame (Ukázat
snímek) nebo zvolte Show Frame (Ukázat snímek) v Lupě v levé spodní části
okna aplikace.

� Pro zobrazení pracovního prostředí v okolí plochy vyberte View > Work Area
(Pracovní plocha). Pracovní plocha je zobrazena ve světlém odstínu šedi.
Příkaz Pracovní plocha použijte pro prohlížení prvků scény, které jsou částečně
dokončovány mimo Plochu. Například pokud chcete, aby do rámu přiletěl pták,
umístili byste jej v počátečním stadiu mimo Plochu.

Posun náhledu na Plochu

Když je Plocha zvětšená, nebudete ji možná moci vidět celou. Nástroj Hand (Ruka)
vám umožní pohybovat Plochou, čímž změníte náhled, aniž byste měnili jeho velikost.

Změna náhledu na Plochu:

11.. Vyberte nástroj Hand (Ruka). Pro dočasné přepnutí mezi jiným nástrojem 
a nástrojem Ruka podržte mezerník a klikněte na nástroj v panelu nástrojů.

22.. Táhněte Plochou.

Používání mřížky, vodítek a pravítek

Když jsou v animaci zobrazeny mřížky, objeví se jako čáry na pozadí ve všech
scénách. K mřížce můžete ukotvovat objekty a můžete měnit velikost mřížky a barvu
čáry mřížky.
Když jsou zobrazena pravítka, objeví se na horním a levém kraji animace.
Můžete si vybrat jednotkovou míru, kterou pravítka použijí. Když budete pohybovat
prvkem po Ploše a budou zobrazena pravítka, objeví se na nich rozměry prvku.
Když jsou zobrazena pravítka, můžete  z nich po Ploše přetáhnout horizontální a vertikální
vodítka. Vodítka můžete posunovat, zamykat, schovávat a odstraňovat. Můžete k nim
také ukotvovat objekty a měnit jejich barvu. Posuvná vodítka se objeví v Časové ose,
ve které byla vytvořena.
Poznámka: Pro vytváření společných vodítek nebo nepravidelných vodítek použijte
vodící vrstvy. Viz "Používání vodících vrstev".
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Uzpůsobení klávesových zkratek

Ve Flashi můžete nastavovat klávesové zkratky, které se budou shodovat se zkratkami,
jež používáte v jiných aplikacích, abyste urychlili průběh své práce. Implicitně Flash
používá vestavěné klávesové zkratky navržené pro aplikaci Flash. Můžete si také
vybrat soubor vestavěných klávesových zkratek z jedné z některých oblíbených
grafických aplikací, včetně Fireworks, Adobe Illustrator a Adobe Photoshop.

Pro vytvoření a uzpůsobení sady klávesových zkratek zkopírujete existující sadu a pak
k ní přidejte nebo z ní odeberete zkratky. Přizpůsobené klávesové zkratky můžete mazat.

Výběr sady klávesových zkratek:

11.. Zvolte Edit > Keyboard Shortcuts (Klávesové zkratky).

22.. V dialogovém okně Keyboard Shortcuts (Klávesové zkratky) zvolte sadu
klávesových zkratek z kontextového menu Current Set (Aktuální sada). 
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Změna proložení mřížky:

11.. Zvolte View > Grid > Edit Grid (Upravit mřížku).

22.. V dialogovém okně Mřížka zadejte hodnoty pro vertikální a horizontální proložení
mřížky a klikněte na tlačítko OK.

Posun vodítka:

� Použijte nástroj Šipka pro označení a přetáhnutí vodítka.

Zamknutí vodítek nebo vymazání vodítek:

� Zvolte View > Guides > Edit Guides (Upravit vodítka) a pak vyberte Lock Guides
(Zamknout vodítka) nebo Clear All (Vymazat vše) a klikněte na tlačítko OK.

Poznámka: Vymazat všechna vodítka odstraní všechna vodítka z aktuální scény.

Odstranění vodítka:

� Mějte odemknutá vodítka, použijte nástroj Šipka pro přetáhnutí vodítka
na horizontální nebo vertikální pravítko.
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66.. Klikněte na Change (Změnit).

77.. Pro přidání nebo odstranění dalších zkratek opakujte tento postup.

88.. Klikněte na tlačítko OK.

Vymazání sady klávesových zkratek:

11.. Zvolte Edit > Keyboard Shortcut (Klávesové zkratky). V dialogovém okně 
Customize Shortcut (Upravit zkratky) klikněte na tlačítko Delete Set (Vymazat
sadu).

22.. V dialogovém okně Delete Set (Vymazat sadu) vyberte sadu zkratek a klikněte 
na tlačítko Delete (Vymazat).

Poznámka: Klávesové zkratky, které jsou zabudovány ve Flashi, nemůžete vymazat.

Tisk souborů Flash při editaci animací

Pro prohlížení a editaci svých animací můžete během své práce tisknout snímky z FLA
souborů.

Můžete také určit snímky, které bude možno vytisknout z Přehrávače Flash pomocí
prohlížeče zobrazujícího animaci Flash. Viz kapitola 13 "Vytváření tisknutelných animací".

Pro tisk snímků z FLA souboru použijte dialogové okno Print (Tisk) pro určení rozsahu
scén a snímků, které chcete tisknout, stejně jako počtu jejich kopií. Ve Windows určuje
dialogové okno Page Setup (Vzhled stránky) velikost papíru, orientaci a různé volby
tisku - včetně nastavení okrajů a toho, zda má být každý rám tisknut na zvláštní
stránku. Na Macintoshi jsou tyto volby rozděleny do dialogových oken Page Setup
(Vzhled stránky) a Print Margins (Tisk okrajů).

Dialogová okna Tisk a Vzhled stránky jsou standardní pro oba operační systémy
a jejich vzhled záleží na zvoleném ovladači tiskárny.

Nastavení voleb tisku:

11.. Zvolte File > Page Setup (Vzhled stránky) (ve Windows) 
nebo File > Print Margins (Tisk okrajů) (na Macintoshi).

22.. Nastavte okraje stránky. Pro tisk snímků doprostřed stránky vyberte volbu 
Center (Střed).

33.. V každém kontextovém menu Frames zvolte vytisknout všechny snímky animace 
nebo jen první snímek každé scény.
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Vytvoření nové sady klávesových zkratek:

11.. Vyberte sadu klávesových zkratek, jak bylo popsáno výše.

22.. Klikněte na tlačítko Duplikovat sadu

33.. Zadejte jméno pro novou sadu zkratek a klikněte na tlačítko OK.

Přejmenování a uzpůsobení sady klávesových zkratek:

11.. V dialogovém okně Customize Shortcuts (Uzpůsobit klávesové zkratky) vyberte
sadu zkratek z kontextového menu Current Set(Aktuální sada).

22.. Klikněte na tlačítko Rename set (Přejmenovat sadu).

33.. V dialogovém okně Přejmenovat zadejte nové jméno a klikněte na tlačítko OK.

Poznámka: Vestavěné sady nelze přejmenovávat.

Přidání nebo odstranění zkratky:

11.. Zvolte Edit > Keyboard Shortcuts (Klávesové zkratky) a vyberte sadu, kterou
chcete změnit.

22.. Vyberte Drawing Menu Commands (Příkazy kreslícího menu), Drawing Tools
(Nástroje kreslení) nebo Test movie (Testovat animaci) z kontextového menu 
Commands (Příkazy), abyste viděli zkratky pro zvolenou kategorii.

33.. V seznamu Příkazů vyberte příkaz, ke kterému chcete přidat nebo ze kterého
chcete odebrat zkratku.
Vysvětlivka k vybranému příkazu se objeví v oblasti Description (Popis)
v dialogovém okně.

44.. ProveJte jedno z následujících:

� Pro přidání zkratky klikněte na tlačítko Add Shortcut (Přidat zkratku) (+).

� Pro odstranění zkratky klikněte na tlačítko Delete Shortcut (Odstranit zkratku)
(-) a pokračujte krokem č. 6.

55.. Pokud přidáváte zkratku, zadejte novou kombinaci kláves zkratky v textovém
okně Press Key (Zmáčknout klávesu).

Poznámka: Pro vložení kombinace kláves stačí pouze zmáčknout klávesy na klávesnici.
Nemusíte vypisovat názvy kláves jako Control, Volba atd.
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Urychlení přehrávání animace

Pro urychlení přehrávání animace můžete použít příkazy v nabídce View pro vypnutí
zvláštností kvalitního vyobrazení, které vyžadují zvláštní operace a zpomalují animace.
Žádný z těchto příkazů nemá vliv na to, jak Flash exportuje animaci. Pro specifikaci
kvality zobrazení animací Flash v internetovém prohlížeči použijte parametry OBJECT
a EMBED. Příkaz Publikovat to neumí udělat automaticky. Pro více informací viz
"Publikace animací Flash".

Změna rychlosti zobrazení:

Zvolte View a vyberte si z následujících voleb:

� Outlines (Hlavní rysy) zobrazí jen obrysy tvarů na scéně a způsobí, že všechny
čáry budou tenké. To ulehčí změnu tvaru vašich grafických prvků a urychlí
zobrazení celých scén.

� Fast (Rychle) vypne potlačení roztřepení a zobrazí všechny barvy a styly čar
vašeho návrhu.

� Antialias (Potlačení roztřepení) zapne zostření pro čáry, tvary a bitmapy. Zobrazí
tvary a čáry tak, že jejich okraje vypadají na obrazovce hladší. Tato volba
vykresluje pomaleji než volba Rychle. Potlačení roztřepení nejlépe pracuje
u grafických karet, které jsou schopny zobrazit tisíce (16-bitové) nebo milióny
(24-bitové) barev. V barevném módu 16 nebo 256 barev jsou černé čáry
vyhlazovány, ale barvy mohou lépe vypadat v režimu Rychle.

� Antialias Text (Potlačení roztřepení textu) vyhlazuje okraje jakéhokoliv textu.
Tento příkaz pracuje nejlépe s velkými velikostmi písma a může být pomalý v případě
velkého množství textu. Je to nejpoužívanější režim pro práci.

Preference Flash

Flash vám umožní nastavit preference pro obecné operace aplikace, editovací operace
a operace se Schránkou.

Pro nastavení preferencí použijte podnabídku Edit >Preferences. Viz také "Výběr
nastavení kreslení".

Nastavení preferencí:

11.. Vyberte Edit > Preferences.

22.. Klikněte na volbu General (Obecné), Editing (Úpravy) nebo Clipboard (Schránka)
a vyberte z daných nabídek.
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44.. V kontextovém menu Layout (Rozvržení) vyberte jednu z těchto voleb:

� Actual Size (Aktuální velikost) vytiskne snímek v plné velikosti. Pro zmenšení
nebo zvětšení tištěného snímku zadejte hodnotu ve volbě Scale (Měřítko).

� Fit on One Pages (Vměstnat na jednu stranu) zmenší nebo zvětší každý snímek
tak, že vyplní oblast tisku na straně.

� Storyboard (Volby Panelu událostí) vytisknou na jednu stranu několik
miniaturních zmenšenin. Do textového okna Frames zadejte počet zmenšenin
na stránku. V textovém okně Story Margin (Okraj události) nastavte mezeru mezi
zmenšeninami. Aby se vytiskl název snímku jako zmenšenina, zvolte Label
(Popis).

Náhled na rozložení scény na stránce:

� Vyberte File  > Print Preview (Tisk náhledu).

Tisk snímků:

� Zvolte File > Print.

Řešení problémů tisku

Pokud se vyskytnou problémy při tisku Flash souborů na postscriptové tiskárně,
je možná jedna z vyplněných ploch vašeho návrhu příliš složitá. (To se častěji stává
u starších postscriptových tiskáren úrovně 1.) 

Pro tento problém existují dvě řešení:

� Zvolte Disable PostScript (Vypnout postscript) v dialogovém okně Tisk okrajů
(na Macintoshi) nebo Preference (ve Windows) a zkuste tisk znovu. Může se stát,
že to podstatně zpomalí tisk, ale mělo by to vyřešit váš problém. (Pro informace
o nastavení preferencí viz "Preference Flashe".)

� Zjednodušte svůj návrh. Problémy s tiskem jsou typicky zapříčiněny rozsáhlou
barevnou plochou se složitými okraji. Tento problém můžete vyřešit rozdělením
složité oblasti do několika jednodušších oblastí. 
Použijte Modify > Curves > Optimize, čímž zmenšíte složitost těchto ploch.

� Také pamatujte na to, že Flash nemůže tisknout průhledné efekty (kanál alfa)
nebo vrstvy masky.
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Pro nastavení vlastností Schránky vyberte z následujících voleb:

� Pro Bitmapy (jen ve Windows) zvolte Color depth (volbu pro Hloubku) 
a Resolution (rozlišení) barvy pro specifikaci těchto parametrů bitmap 
kopírovaných do Schránky. Zvolte Smmoth (Vyhladit) pro aplikaci potlačení
roztřepení. Zadejte hodnotu Size Limit (Omezení velikosti) pro určení velikosti
RAM, která je použita pro vkládání bitmapového obrázku do Schránky. 
Při práci s velkými bitmapami a bitmapami s velkým rozlišením tuto hodnotu
zvětšete. Pokud má váš počítač omezenou velikost paměti zvolte "Žádné".

� Pro Gradienty (jen ve Windows) vyberte volbu pro určení kvality výplně 
gradientu umístěného do metasouboru ve Windows. Vybráním vyšší kvality
zvýšíte čas nutný pro kopírování výtvoru. Toto nastavení použijte pro určení
kvality gradientu při vkládání položek do umístění mimo aplikaci Flash. Když
vkládáte mimo Flash, je zachována kvalita kopírovaných dat nezávisle 
na Gradientech v nastavení Schránky.

� Pro nastavení PICT (jen na Macintoshi) zvolte za Typ Objekty, aby byla data
vkládaná do Schránky jako vektorový výtvor nebo zvolte jeden z formátů
bitmapy pro změnu kopírovaného výtvoru na bitmapu. Zadejte hodnotu pro
Resolution (Rozlišení). Zvolte Include PostScript (Zahrnout postscript),
abyste zahrnuli postscriptová data. Pro Gradienty zvolte volbu pro určení
kvality gradientu v PICT. Vybráním vyšší kvality zvýšíte potřebný čas pro
kopírování díla. Nastavení Gradienty použijte pro specifikaci kvality gradientu,
když vkládáte data do místa mimo aplikaci Flash. Když vkládáte mimo Flash,
je zachována úplná kvalita gradientu kopírovaných dat, nezávisle na nastavení
Gradientu.

� Pro FreeHand Text (od ruky) zvolte Maintain (Uchovat) text jako bloky, abyste
zachovali možnost editovat text ve vkládaném souboru, kde používáte psaní
od ruky.
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Pro nastavení obecných preferencí vyberte z následujících voleb:

� Pro Undo Levels (Úrovně kroků) zpět zadejte hodnotu od 0 do 200 pro nastavení
úrovní kroků zpět nebo vpřed. Úrovně kroků zpět potřebují paměR, čím víc
úrovní použijete, tím víc paměti je zabráno.

� Pro Printing Options (Volby tisku) (jen ve Windows) zvolte Vypnout postscript
pro vypnutí výstupu postscriptu, pokud tisknete na postscriptové tiskárně.
Implicitně tato volba není zatržena. Zvolte tuto volbu, jestliže máte problémy
s tiskem. Zpomalí tisk na postscriptové tiskárně.

� Pro Selection Options (Volby výběru) označte Výběr se stisknutou klávesou Shift,
abyste dohlédli na to, jak Flash provádí výběr více prvků. Když je volba Výběr
se stisknutou klávesou Shift vypnutá, kliknutí na další prvky je přidá do výběru.
Pokud je tato volba zapnutá, kliknutí na další prvek odznačí původní prvek,
pokud nepodržíte klávesu Shift.

� Pro Show Tooltips (Zobrazení tipů) zvolte Zobrazit tipy a kdykoliv se ukazatel
zastaví nad symbolem tipů, nějaký z nich se objeví. Pokud nechcete vidět tipy,
odznačte tuto volbu.

� Pro Timeline Options (Volby Časové osy) označte Disable Timeline Dockings
(Vypnout ukotvení časové osy), čímž zabráníte tomu, aby se Časová osa
připojovala k oknu aplikace, pokud byla oddělena do svého vlastního okna.
Viz také "Používání Časové osy".

� Pro Zobrazení snímků zvýrazněným stylem používaným ve Flashi 4 zvolte 
Použít styl výběru Flash 4.

� Zvolte Show Blank Keyframes (Zobrazit prázdné klíčové snímky), aby se vám
ukázaly prázdné klíčové snímky s prázdnými kruhy.

� Pro Highlight Color (Barvu zvýraznění) zvolte Use This Color (Použít tuto barvu)
a vyberte barvu z panelu barev nebo zvolte Use Layer Color (Použít barvu
vrstvy), jestliže chcete použít barvu obrysu aktuální vrstvy.

� Pro Actions Panel (Panel akcí) vyberte Normal Mode (Normální režim) pro
tvorbu akcí s použitím ovladačů na panelu nebo Expert Mode (Rozšířený režim)
pro tvorbu akcí vkládáním ActionScriptu v textovém okně na panelu.

� Pro nastavení preferencí úprav vyberte z následujících voleb:

� Pro Pen Tool Options (Volby nástroje Tužka) viz "Nastavení preferencí nástroje
Tužka".

� Pro Drawing Settings (Nastavení kreslení) viz "Výběr nastavení kreslení"
na straně 133.
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Když pro vytváření nějakého objektu použijete kreslícího nebo malovacího nástroje,
použijí se na objekt vlastnosti aktuálního tahu (okraje) a výplně. Pro změnu vlastností
tahu a výplně stávajících objektů můžete použít nástroje Paint Bucket (Plechovka
s barvou) a Ink Bottle (Kalamář).
Viz "Určení vlastností tahu a výplně".

Čáry a okraje tvarů můžete měnit různými způsoby. Výplně a tahy se chovají jako
zvláštní objekty. Výplně a tahy můžete vybírat zvláš- pro pohyb a změnu. Viz "Změna
tvaru čar a okrajů tvarů".

Pro automatické spojení objektů nebo vyrovnání s kreslící mřížkou nebo vodítky
můžete použít ukotvení. Viz "Používání mřížky, vodítek a pravítek".

O překrývání objektů ve Flashi

Když používáte ve Flashi nástroje Tužka, Čára, Ovál, Obdélník nebo Štětec pro
kreslení čáry přes jinou čáru nebo namalovaný tvar, jsou překrývající se čáry rozděleny
do částí mezi průsečíky. Pro označení, pohyb nebo změnu tvaru každé části zvláš-
můžete použít nástroj Šipka.

Poznámka: Překrývající se čáry, které vytvoříte s nástrojem Pero, se nerozdělí v průsečících
do částí, ale zůstanou celé. Viz "Použití nástroje Pero".

Při nakreslení linky přes výplň, vlastně linku rozdělíte na tři části 
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Kreslení

Nástroje kreslení ve Flashi umožní vytvářet a měnit tvary vašeho díla v animacích.
Pro interaktivní úvod do kreslení ve Flashi vyberte Help > Lessons > Drawing.

Dříve než budete ve Flashi kreslit a malovat, je důležité, abyste věděli, jak pracují
nástroje kreslení a jak mohou kreslení, malování a změny tvaru ovlivnit jiné útvary
ve stejné vrstvě.

Kreslící a malovací nástroje ve Flashi

Flash obsahuje různé nástroje pro kreslení, netradiční nebo přesné čáry, tvary a trasy
a malování plných objektů.

� Pro kreslení netradičních čar a tvarů podobně jako při kreslení skutečnou
tužkou použijete nástroj Pencil (Tužka). Viz "Kreslení s nástrojem Tužka".

� Pro kreslení přesných tras jako rovných nebo zakřivených čar použijte
nástroj Pen (Pero). Viz "Používání nástroje Pero".

� Pro kreslení základních geometrických tvarů použijete nástroje Line (Čára), 
Oval (Ovál) a Rectangle (Obdélník). Viz "Kreslení rovných čar, oválů a obdélníků".

� Pro vytvoření tahů štětcem jakobyste malovali použijte nástroj Brush (Štětec).
Viz "Malování s nástrojem Štětec".
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3. Vyberte kreslící režim pod Volbami v panelu nástrojů:

� Zvolte Straighten (Vyrovnat) pro nakreslení rovných čar a vyrovnání
do trojúhelníků, oválů, kruhů, obdélníků a čtverců.

� Zvolte Smooth (Vyhladit) pro vyhlazení křivek.

� Zvolte Ink (Inkoust) pro nakreslení čar od ruky bez úprav.

4. Přesuňte se na Plochu pro kreslení s nástrojem Tužka. Podržte Shift a táhněte 
myší pro přesun čar do vertikální nebo horizontální polohy.

Kreslení rovných čar, oválů a obdélníků

Nástroje Line (Čára), Oval (Ovál) a Rectangle (Obdélník) můžete použít pro rychlé
vytvoření základních geometrických tvarů. Nástroje Ovál a Obdélník vytvářejí čárkované
a plné tvary. Nástroj Obdélník můžete použít pro vytváření obdélníků s pravoúhlými
nebo zaoblenými rohy.

Kreslení rovné čáry, oválu nebo obdélníku:

1. Zvolte nástroj Čára, Ovál nebo Obdélník.

2. Vyberte vlastnosti čáry a výplně. Viz "Určení vlastností čáry a výplně".

Poznámka: Pro nástroj Čára nemůžete nastavovat vlastnosti.

3. Pro nástroj Obdélník určíte zaoblené rohy kliknutím na Roun Rectangle
Radius (měnič Kulatý obdélník) a zadáním hodnoty poloměru rohu. Nulová
hodnota vytvoří pravoúhlé rohy.

4. Přesuňte se na Plochu. Pokud používáte nástroj Obdélník, mačkejte šipky 
nahoru a dolů při jeho kreslení, pro uzpůsobení poloměru zaoblených rohů.

� Pro nástroje Ovál a Obdélník držte Shift a táhněte myší pro vymezení tvarů
do koleček a čtverců.

� Pro nástroj Čára držte Shift a táhněte myší pro násobení pod úhlem 45°.
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Když malujete na tvary nebo čáry, jsou nahrazeny tím, co je nahoře. Malba stejné
barvy se spojí dohromady. Malby různých barev zůstávají rozlišené. Tyto vlastnosti
můžete využít k tvorbě masek, vystřihovánek a negativních obrázků. Například níže
uvedená vystřihovánka byla vytvořena přemístěním osamostatněného draka na zelenou
plochu, odznačením draka a pak přesunem vyplněné oblasti pryč ze zelené plochy.

Abyste se vyhnuli nedopatřením při změnách tvarů a čar jejich překrytím, můžete
seskupit plochy nebo použít vrstvy k jejich oddělení. Viz "Seskupování objektů"
a kapitola 8 "Používání vrstev".

Kreslení  nástrojem Tužka

Pro kreslení čar a ploch používejte nástroj Pencil (Tužka), podobně jako byste
používali skutečnou tužku. Pokud chcete použít vyhlazení nebo vyrovnání čar a ploch
při kreslení, vyberte kreslící režim pro nástroj Tužka.

Kreslení nástrojem Tužka:

1. Zvolte nástroj Tužka.

2. Zvolte barvu tahu, tlouš-ku čáry a styl. Viz "Určení vlastností čáry a výplně".
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Kreslení rovných čar pomocí nástroje Pero

Pro kreslení rovných úseků čar pomocí nástroje Pero vytváříte kotvící body, body na
čáře, které určují délku jednotlivých úseků čar.

Nakreslení rovné čáry pomocí nástroje Pero:

1. Zvolte nástroj Pero.

2. Zvolte vlastnosti čáry a výplně. Viz "Určení vlastností čáry a výplně".

3. Umístěte ukazovátko na Ploše tam, kde chcete, aby začínala rovná čára 
a klikněte pro určení prvního kotvícího bodu.

4. Klikněte na místo, kde chcete ukončit první úsek rovné čáry. Podržte Shift 
a klikněte pro posun nástroje o 45°.

5. Pokračujte klikáním pro vytváření dalších úseků.

6. Pro dokončení trasy jako otevřený nebo zavřený útvar, udělejte jedno 
z následujících:

� Pro dokončení otevřené trasy dvakrát klikněte na poslední bod, klikněte
na nástroj Pero v panelu nástrojů nebo držte Control a klikněte (ve Windows)
nebo držte Command a klikněte (na Macintoshi) kdekoliv mimo trasu.

� Pro zakončení trasy umístěte nástroj Pero na první kotvící bod. Pokud je ukazatel
umístěn dobře, objeví se vedle tipu malý kroužek. Klikněte nebo táhněte
pro uzavření trasy.
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Používání nástroje Pero

Pro kreslení přesných tras jako rovných čar nebo vyhlazených křivek můžete použít
nástroj Pero. Můžete vytvářet úseky rovných čar a křivek a přizpůsobovat úhel a délku
rovných úseků a sklon křivek.

Když kreslíte nástrojem Tužka, nakreslením křivky, nebo i rovné čáry vytvoříte body,
pomocí kterých můžete měnit křivky na rovné čáry a naopak. Na čárách můžete také
zobrazovat body, které vytvoříte pomocí jiných kreslících nástrojů jako jsou Tužka,
Štětec, Čára, Ovál nebo Obdélník, abyste tyto čáry uzpůsobili. Viz "Změna tvaru
čar a obrysů ploch".

Nastavení preferencí nástroje Pero

Můžete určit vlastnosti pro nastavení vzhledu ukazovátka nástroje Pero, pro nahlížení
na úseky čar, které kreslíte, pro vzhled zvolených kotvících bodů. Vybrané úseky čar
a kotvící body jsou zobrazeny barvou obrysů vrstvy, na které se čáry a body objeví.

Nastavení preferencí nástroje Pero:

1. Zvolte Edit > Preferences a klikněte na Editing záložku.

2. Pod Nástrojem pero (Pen Tool) nastavte následující volby:

� Zvolte Show Pen Preview (Zobrazit náhled na pero) pro náhled na úseky
během kreslení. Flash zobrazí náhled na úseky čar, jak pohybujete ukazatelem
po Ploše, předtím než kliknete pro vytvoření koncového bodu úseku. Pokud
tato volba není vybrána, Flash nezobrazí úsek čáry, dokud nevytvoříte koncový
bod úseku.

� Zvolte Show Solid Points (Zobrazit  pevné body), abyste zaručili, že odznačené
kotvící body se objeví jako pevné body a označené kotvící body se objeví
jako prázdné body (tato volba je vybrána implicitně). Odznačte tuto volbu,
aby se vám odznačené kotvící body objevovaly jako prázdné body a označené
body jako pevné body.

� Zvolte Show Precise Cursors (Zobrazit přesné polohy) pro určení toho,
že ukazovátko nástroje Pero se objeví jako křížek a ne jako implicitní ikona
nástroje Pero pro přesnější umístění čar. Odznačte tuto volbu pro zobrazení
implicitní ikony nástroje Pero.

Poznámka: Pro přepnutí mezi kursory zmáčkněte klávesu Caps Lock.

3. Klikněte na tlačítko OK.
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� Držte Shift a táhněte myší pro posun o 45°.

6. Pro nakreslení nového úseku křivky umístěte ukazovátko tam, kde chcete
ukončit aktuální úsek a táhněte mimo křivku.

Uzpůsobení kotvících bodů na trasách

Když kreslíte křivku pomocí nástroje Pero, tvoříte body křivky, kotvící body na spojité
křivce. Když kreslíte úseky rovné čáry nebo rovnou čáru spojenou s úsekem křivky,
tvoříte rohové body, kotvící body na rovné trase nebo na průsečíku rovné trasy a křivky.

Implicitně se vybrané body křivky zobrazují jako prázdná kolečka a vybrané rohové
body jako prázdné čtverečky.

Pro změnu úseků čáry z rovných na křivky nebo naopak změňte rohové body na body
křivky a naopak.
Na trasu můžete také přidávat kotvící body, pohybovat s nimi nebo je mazat. Kotvícím
bodem pohybujete použitím nástroje Subselection (Podvýběr), kterým  přizpůsobíte
úhel a rovnost úseků rovných čar nebo sklon úseků křivek. Zvolenými kotvícími body
můžete pro malé úpravy pohnout.
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� Pro dokončení tvaru zvolte Edit > Deselect All (Odznačit všechny) nebo vyberte
z panelu nástrojů jiný nástroj.

Kreslení křivek pomocí nástroje Pero

Křivky můžete tvořit táhnutím nástroje Pero ve směru, kterým má křivka jít, abyste
vytvořili první kotvící bod, a pak táhněte Pero opačným směrem, abyste vytvořili druhý
kotvící bod.

Při použití nástroje Pero pro vytvoření úseků křivek se kotvící body zobrazí jako tečné
úchytky.  Sklon a délka každé tečné úchytky určí sklon a výšku, respektive hloubku
křivky. Posun tečných úchytek změní tvar křivky a trasy. Viz "Uzpůsobování úseků".

Nakreslení křivky:

1. Zvolte nástroj Pero.

2. Umístěte nástroj Pero na Plochu, kde má křivka začínat. Podržte tlačítko myši. 
Objeví se první kotvící bod a nástroj pero se změní na kótovací šipku.

3. Táhněte myší směrem, kterým se má křivka vykreslit. Jak táhnete, objeví 
se tečná úchytka. Držte Shift a táhněte myší pro posun o 45°.

4. Pus-te tlačítko myši.

� Délka a sklon tečné úchytky určí tvar úseku křivky.

5. Umístěte ukazovátko tam, kde chcete skončit úsek křivky, podržte tlačítko
myši a táhněte jí opačným směrem pro dokončení úseku.
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Uzpůsobení úseků

Rovné úseky můžete uzpůsobit změnou úhlu nebo délky úseku nebo můžete uzpůsobit
úseky křivky změnou sklonu nebo směru křivky.

Když pohybujete bodovou úchytkou po křivce, přizpůsobí se křivky na obou stranách
bodu. Když pohybujete "bodovou úchytkou" v rohovém bodě, přizpůsobí se jen křivka
na stejné straně bodu.

Uzpůsobení rovného úseku:

1. Zvolte nástroj Subselection (Podvýběr) a vyberte rovný segment.

2. Použijte nástroj Podvýběr pro přetáhnutí kotvícího bodu na úseku do nové pozice.

Uzpůsobení úseku křivky:

� Zvolte nástroj Podvýběr a táhněte za úsek.

Poznámka: Kotvící body jsou schovány, když kliknete na trasu nástrojem Podvýběr.
Abyste tyto body po uzpůsobení viděli, klikněte na trasu nástrojem Podvýběr nebo Pero.
Také uzpůsobení úseku s nástrojem Podvýběr může na trasu přidat body.

Uzpůsobení bodů nebo bodových úchytek na křivce:

1. Zvolte nástroj Podvýběr a vyberte úsek křivky. Bodové úchytky se objeví 
na úseku.

2. ProveRte jedno z následujících:

� Pro uzpůsobení umístění kotvících bodů na křivce táhněte s kotvícími body.

� Pro uzpůsobení tvaru křivky na kterékoliv straně kotvícího bodu, táhněte za kotvící
bod nebo za "bodovou úchytku".  Držte Shift a táhněte myší pro změnu úhlu o 45°.
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Mazání nepotřebných kotvících bodů křivku optimalizuje a snižuje velikost souboru.

Pohyb kotvícího bodu:

� Táhněte jej použitím nástroje Subselection (Podvýběr).

Mírný posun kotvícího bodu nebo bodů:

� Vyberte bod nebo body z nástroje Podvýběr a použijte klávesy šipky pro pohyb
bodu nebo bodů.

Pro konvertování kotvícího bodu proveRte jedno z následujících:

� Pro konvertování rohového bodu na bod křivky použijte nástroj Podvýběr a držte
Alt (ve Windows) nebo Volba (na Macintoshi) a táhněte myší.

� Pro konvertování bodu křivky na rohový bod použijte nástroj Pero a klikněte na bod.

Přidání kotvícího bodu:

� Klikněte na nástroj Pero a úsek čáry.

Pro vymazání kotvícího bodu proveRte jedno z následujících:

� Pro vymazání rohového bodu klikněte jedenkrát na bod použitím nástroje Pero.

� Pro vymazání bodu křivky klikněte dvakrát na nástroj Pero. (Poprvé klikněte
pro konvertování na rohový bod, podruhé pro smazání.)

� Zvolte bod pomocí nástroje Podvýběr a zmáčkněte Vymazat.
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4. Vyberte velikost štětce, tvar štětce a barvu štětce z měničů (modifiers)
nástroje Štětec.

5. Jestliže máte k počítači připojen tablet citlivý na tlak, můžete vybrat měnič
Tlak pro odlišení šířky vašich tahů štětcem odlišením tlaku na hrot.

6. Přesuňte se na Plochu. Držte Shift a táhněte myší pro posun tahů štětcem
do horizontální nebo vertikální polohy.

Změna tvaru čar a okrajů ploch

Můžete měnit tvary čar a okrajů ploch vytvořených v nástrojích Tužka, Štětec, Čára,
Ovál nebo Obdélník táhnutím nástroje Šipka nebo optimalizací jejich křivek.

Pro zobrazení bodů na čarách a okrajích ploch a změnu čar a okrajů uzpůsobováním
bodů můžete použít nástroj Podvýběr. Pro informace o uzpůsobování kotvících bodů
viz "Používání nástroje Pero".

Zobrazení kotvících bodů na čáře nebo okraji plochy vytvořených v nástrojích Tužka,
Štětec, Čára, Ovál nebo Obdélník:

1. Zvolte nástroj Podvýběr.

2. Klikněte na čáru nebo okraj plochy.

Změna tvarů použitím nástroje Šipka

Pro změnu tvaru čáry nebo okraje plochy můžete táhnout kterýmkoliv bodem na čáře
použitím nástroje Šipka. Ukazovátko se změní a bude zobrazovat typ změny, kterou
může provádět na čáře nebo výplni.

Flash uzpůsobí křivku úseku čáry, aby vyhovovala nové pozici přemístěného bodu.
Je-li přemístěný bod koncovým bodem, můžete čáru prodloužit nebo zkrátit. Jestliže
je přemístěný bod rohový, úseky čáry zůstanou rovné a zkrátí se nebo prodlouží.

Když se pod ukazatelem objeví roh, můžete měnit bod, pokud se objeví oblouček,
můžete měnit křivku.
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Malování s nástrojem Štětec

Nástroj Brush (Štětec) kreslí tahy jakoby byly nakresleny opravdovým štětcem.
Umožní vám vytvořit zvláštní efekty, včetně kaligrafických. Na tabletech nejvíce
citlivých na tlak můžete rozlišit šířku tahů různým tlakem na hrot.

Při malování s nástrojem Štětec můžete použít importované bitmapy jako výplň.
Viz "Rozdělování bitmap".

Malování s nástrojem Štětec:

1. Zvolte nástroj Štětec.

2. Zvolte barvu výplně. Viz "Určení vlastností čáry a výplně".

3. Klikněte na měnič režimu Štětec a vyberte režim malování:

� Paint Normal (Malovat normálně) maluje přes čáry a výplně na stejné vrstvě.

� Paint Behind (Malovat na pozadí) maluje na bílé plochy na Ploše na stejnou
vrstvu a nechá čáry a výplně netknuté.

� Paint Selection (Malovat výběr) použije novou výplň na výběr, jestliže
vyberete výplň v Fill modifier (měniči Výplň) nebo panelu Výplň. (Tato volba 
je totéž jako pouhý výběr vyplněné plochy a její použití na novou výplň.)

� Paint Fills (Malovat výplně) vyplňuje a vyprazdňuje plochy a nechává čáry
nedotčené.

� Paint Inside (Malovat vnitřek) maluje výplně, v nichž začnete kreslit štětcem
a nevykresluje čáry. Funguje to spíše jako chytrý panel barev a nedovolí vám 
kreslit vně čar. Když začnete malovat na prázdné ploše neovlivní výplň již
existující vyplněné oblasti.

Originál, Paint Normal, Paint Behind, Paint Selection, Paint Fills, Paint Inside
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Vyhlazení křivky každého vybraného okraje plochy nebo křivky:

� Vyberte nástroj Šipka a klikněte na Smooth (Vyhladit) v sekci Volby panelu
nástrojů nebo zvolte Modify > Smooth (Vyhladit).

Malé vyrovnávací úpravy na každém zvoleném obrysu výplně nebo na křivce:

� Zvolte nástroj Šipka a klikněte na Straighten (Vyrovnat) v sekci Volby panelu
nástrojů nebo zvolte Modify > Straighten (Vyrovnat).

Použití přetváření ploch:

� Zvolte nástroj Šipka a klikněte na Straighten (Vyrovnat) nebo zvolte Modify >
Straighten (Vyrovnat).

Optimalizace křivek

Jiným způsobem vyhlazení křivek je jejich optimalizace. Ta zjemní křivky a okraje
výplní zmenšením počtu křivek použitých k definici těchto prvků.
Optimalizace křivek také zmenšuje velikost animace Flash a exportované animace
v Přehrávači Flash. Stejně jako tomu je u příkazů a měničů Vyhladit a Vyrovnat
můžete optimalizaci použít na stejné prvky několikrát.

Optimalizace křivek:

1. Vyberte nakreslené prvky, které mají být optimalizovány, a zvolte Modify >
Optimize (Optimalizovat).

2. V dialogovém okně Optimalizovat křivky určete stupeň vyhlazení.

� Přesné výsledky budou záležet na vybrané křivce. Obecně optimalizace
zmenší počet křivek a je méně podobná původnímu okraji.
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Některé oblasti tahů štětcem je lepší měnit pokud se na ně díváte jako na okraje.

Pokud máte problém se změnou celé čáry, můžete ji vyhladit, abyste odstranili některé
její části, čímž si změnu tvaru ulehčíte. Zvýšením procenta zvětšení si změnu tvarů
také ulehčíte a upřesníte, viz "Optimalizace křivek" nebo "Náhled na Plochu".

Změna tvaru čáry nebo okraje plochy pomocí nástroje Šipka:

1. Zvolte nástroj Šipka.

2. ProveRte následující:

� Táhněte za jakýkoliv bod na úseku pro změnu jeho tvaru.

� Držte klávesu Control (ve Windows) nebo Volba (na Macintoshi) a táhněte
myší za čáru pro vytvoření nového rohového bodu.

Vyrovnávání a vyhlazování čar

Čáry a okraje ploch můžete měnit vyrovnáváním nebo vyhlazováním.

Poznámka: Volbou nastavení kreslení v Preferencích zvolíte stupeň automatického
vyhlazování a vyrovnávání. Viz "Volba nastavení kreslení".

Vyrovnávání udělá malé vyrovnávací změny čárám a křivkám, které jste již nakreslili.
Nemá to vliv na již rovné úseky.

Vyrovnávací techniku můžete ve Flashi použít také pro přetváření ploch. Jestliže
nakreslíte nějaké oválné, obdélníkové nebo trojúhelníkové tvary s volbou Rozpoznat
tvary vypnutou, můžete zvolit volbu Vyrovnat pro geometricky dokonalé tvary.
(Viz "Výběr nastavení kreslení" pro další informace o volbě Přetváření tvarů.) Tvary,
které se dotýkají a jsou tedy spojeny s dalšími prvky, nejsou rozpoznány.

Vyhlazení ztlumí křivky a zmenší počet hrbolků nebo jiných defektů v celkovém směru
křivky. Také zmenší počet úseků křivky. Vyhlazení je nicméně relativní a nemá žádný
vliv na rovné úseky. Je obzvláš- užitečné, pokud máte problémy se změnou počtu
velmi krátkých úseků křivek. Vybrání všech úseků a jejich vyhlazení zmenší počet
úseků a vytvoří hladší křivku, která se snadněji upravuje.

Opakovaná aplikace vyhlazení nebo vyrovnání učiní každý úsek hladší a rovnější
v závislosti na tom, jak zakřivený nebo rovný byl úsek původně.
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� Erase Inside (Gumovat vnitřek) maže pouze výplň, na které začnete gumovat
tahem. Pokud začnete gumovat na prázdném bodě, nebude vymazáno nic.
Čáry jsou v tomto režimu gumou netknuté.

3. Klikněte na Eraser Shape (Tvar gumy) a vyberte tvar a velikost gumy. Ujistěte
se, že není označen Faucet (Kohoutek).

4. Táhněte myší po Ploše.

Změna tvarů

Tvary můžete měnit konvertováním čar do výplní, zvětšováním vyplněných objektů
nebo vyhlazováním rohů vyplněných objektů změnou křivek ploch.

Vlastnost Lines to Fills (Čáry na výplně) mění čáry na výplně, což vám dovolí plnit čáry
gradienty nebo mazat části čáry. Vlastnosti Expand Shape (Zvětšit tvar) a Soften
Edges (Vyhladit rohy) vám dovolí zvětšit tvary a zamlžit jejich rohy.

Expand Shape (Zvětšit tvar) a Soften Edges (Vyhladit rohy) nejlépe funguje na malých
tvarech, které neobsahují mnoho malých detailů. Použití Vyhladit rohy na tvary s velkým
počtem detailů může zvýšit velikost souboru animace Přehrávače Flash.

Přeměna čar na výplně:

1. Zvolte čáru nebo více čar.

2. Vyberte Modify > Shape > Convert Lines to Fills (Přeměnit čáry na výplně).

Zvolené čáry jsou změněny na vyplněné objekty. Přeměna čar do výplní může zvětšit
velikost souboru, ale může také urychlit vykreslování u některých animací.

Zvětšení plochy vyplněných objektů:

1. Zvolte vyplněný objekt. Tento příkaz nejlépe funguje u ploch vyplněných
jednoduchou barvou bez čar.

2. Vyberte Modify > Shape > Expand Fill (Zvětšit výplň).

3. V dialogovém okně Expand Path (Zvětšit trasu) zadejte hodnotu v bodech 
pro Distance (Vzdálenost) a pro Směr vyberte Expand (Zvětšit) nebo Inset
(Vložit dovnitř). Expand zvětší tvar a Inset ho zmenší.

Vyhlazení rohu objektu:

1. Vyberte vyplněný objekt. Tento příkaz nejlépe funguje u ploch vyplněných 
jednoduchou barvou bez čar.

2. Zvolte Modify > Shape > Soften Fill Edges (Vyhladit rohy výplně).
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3. Nastavte další volby:

� Zvolte Use Multiple Passes (Použít vícenásobné kroky) pro opakování
vyhlazovacího procesu do té doby, dokud může být ještě použita optimalizace.
To je totéž jako byste opakovaně používali na stejný prvek volbu Optimalizovat.

� Zvolte Show Totals Message (Detaily pro zobrazení výstražného okna),
které ukazuje míru optimalizace, když je vyhlazení hotovo.

4. Klikněte na tlačítko OK.

Gumování

Gumování s nástrojem Eraser (Guma) odstraňuje čáry a výplně. Můžete rychle
vymazat všechno na Ploše, vymazat jeden úsek čáry, vyplněné oblasti nebo gumovat
tahem myši.
Nástroj Guma můžete upravit tak, aby mazal pouze čáry, pouze vyplněné oblasti nebo
pouze jednu vyplněnou oblast. Nástroj Guma může být kulatý nebo čtvercový a může
mít jednu z pěti velikostí.

Rychlé vymazání všeho na Ploše:

� Dvakrát klikněte na nástroj Guma.

Odstranění úseků čar nebo vyplněných ploch:

1. Zvolte nástroj Guma a pak klikněte na Faucet (Kohoutek).

2. Klikněte na úsek čáry nebo vyplněnou oblast, které chcete smazat.

Gumování táhnutím myši:

1. Zvolte nástroj Guma.

2. Klikněte na Eraser Mode (Gumovací režim) a vyberte režim pro gumování:

� Erase Normal (Gumovat normálně) gumuje čáry a výplně na stejné vrstvě.

� Erase Fills (Gumovat výplně) maže pouze výplně; čáry zůstávají netknuty.

� Erase Lines (Gumovat čáry) maže pouze čáry; výplně zůstávají netknuty.

� Erase Selected Fills (Gumovat vybrané výplně) maže pouze aktuálně označené
výplně a nechává čáry netknuté, a- už jsou označené nebo ne. (Výplně, které
chcete vymazat, zvolte před použitím nástroje guma v tomto režimu.)
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Výběr nastavení kreslení

Nastavení kreslení slouží k nastavení chování ukotvení, vyhlazování a vyrovnávání při
používání kreslících nástrojů Flashe. Pro každou volbu můžete změnit nastaveni
Odchylky a každou z těchto voleb můžete vypnout nebo zapnout. Nastavení Tolerance
(Odchylky) je relativní a záleží na rozlišení vaší počítačové obrazovky a aktuálním zvětšení
náhledu na obraz. Implicitně je každá výplň zapnutá a nastavená na Normální odchylku.
Nastavení kreslení:

1. Zvolte Edit > Preferences a klikněte na záložku Editing (Úpravy).

2. Pod Drawing Settings (Nastavením kreslení) vyberte z následujících voleb:

� Connect Lines (Spojit čáry) určí, jak blízko úseku čáry musí být nakreslen 
konec čáry, aby se koncový bod ukotvil k nejbližšímu bodu další čáry. 
Dostupné volby jsou Must be Close (Musí být blízko), Normální a Can be Distant
(Může být daleko). Toto nastavení také kontroluje horizontální a vertikální 
rozpoznání čáry - to znamená jak blízko musí být nakreslena horizontální 
nebo vertikální čára, aby ji Flash nakreslil přesně horizontální nebo vertikální.
Když je aktivováno Ukotvení k objektům, kontroluje toto nastavení, jak blízko 
k sobě musí objekty být, aby byly ukotveny jeden k druhému.

� Smooth Curves (Vyhladit křivky) určí počet vyhlazení aplikovaný na křivky
kreslené nástrojem Tužka, když je kreslící režim nastaven na Straighten
(Vyrovnat) nebo Smooth (Vyhladit). (U hladších  křivek se lépe mění tvar,
zatímco hrubší křivky lépe odpovídají původním čarám.) Volby jsou Off (Vypnout),
Rough (Hrubé), Normální a Smooth (Hladké).

Poznámka: Dále můžete vyhlazovat existující úseky křivek použitím Modify > Smooth
a Modify > Optimize.

� Recognize Lines (Rozpoznat čáry) definuje, jak moc rovné musí být úseky čáry
nakreslené nástrojem Tužka, aby je Flash rozpoznal a úplně je vyrovnal.
Volby jsou Off (Vypnout), Strict (Přísné), Normální a Tolerant (Tolerantní). 
Jestliže Rozpoznat čáry je vypnuto pokud kreslíte, můžete čáry vyrovnat později
vybráním jednoho nebo více úseků čar a zvolením Modify > Straighten.

� Recognize Shapes (Rozpoznat tvary) kontroluje, jak moc přesně musíte kreslit
kruhy, ovály, čtverce, obdélníky a jejich úhly 90° a 180°, aby byly rozpoznány
jako geometrické tvary a správně překresleny. Volby jsou Off (Vypnuto), 
Strict (Přísné), Normální a Tolerant (Tolerantní). Jestliže je volba Rozpoznat 
tvary vypnuta, když kreslíte, můžete čáry vyrovnat později vybráním jednoho 
nebo více tvarů (například spojené úseky čar) a zvolením Modify > Straighten.

Click Accuracy (Přesnost kliknutí) specifikuje, jak blízko položky musí být ukazovátko,
aby Flash položku rozpoznal. Volby jsou Strict (Přísná), Normální a Tolerantní.
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3. Nastavte následující volby:

� Distance (Vzdálenost) je šířka vyhlazeného rohu v bodech.

� Number of Steps (Počet kroků hlídá), kolik křivek bude použito pro efekt vyhlazení
rohu. Více kroků poskytne hladší efekt, ale vytvoří také větší soubory a vykreslení
bude trvat déle.

� Expand (Zvětšit) nebo Inset (Vložit dovnitř) hlídá, zda plocha bude při vyhlazování
rohů zvětšena nebo zmenšena.

Ukotvování

Pro seskupování objektů můžete využít ukotvování.
Ukotvování může být aktivováno použitím Snap (Ukotvit) pro nástroj Šipka nebo příkazem
Snap v menu View.

Poznámka: Můžete ukotvovat také k mřížce nebo k vodítkům. Pro více informací viz
"Používání mřížky, vodítek a pravítek".

Jestliže je měnič Ukotvit nástroje Šipka zapnutý, objeví se černý kroužek pod ukaza-
telem, když táhnete za prvek. Malý kroužek se změní na větší, když je objekt v rámci
ukotvovací vzdálenosti čáry mřížky.

Pro zapnutí nebo vypnutí ukotvování proveRte jedno z následujících:

� Zvolte nástroj Šipka a klikněte na měnič Snap (Ukotvit) v panelu nástrojů.

� Zvolte View > Snap to Objects (Ukotvit k objektům). Pokud je příkaz aktivní,
je vedle něj zobrazeno zatržítko.

Když pohybujete objektem nebo měníte jeho tvar, pozice nástroje Šipka na objektu
poskytne referenční bod pro ukotvovací kroužek. Například pokud pohybujete
vyplněným tvarem a držíte jej poblíž středu, ukotví se středový bod k jiným objektům.
To je obzvláště užitečné pro ukotvení tvarů k pohybovým trasám pro animaci.

Uzpůsobení odchylek ukotvení:

� Přizpůsobte nastavení Connect Lines (Spojit čáry) pod Nastavením kreslení
v Preferencích úprav. Viz další oddíl.

Poznámka: Pro lepší kontrolu umístění objektu při ukotvování začínejte přetahování
z rohového nebo středového bodu.
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Používání kontrolky Kreslení čar a Výplně v panelu nástrojů

K vybrání plné barvy tahu nebo plné či gradientní barvy výplně přepněte barvy tahu
a výplně nebo vyberte implicitní barvy tahu a výplně (černá čára a bílá výplň), můžete
použít kontrolku Kreslení čar a Výplně v panelu nástrojů.

Kontrolka Kreslení čar a Výplně z panelu nástrojů nastavuje vlastnosti malování
nových objektů, které vytváříte za pomoci kreslících a malovacích nástrojů. Abyste
mohli použít kontrolu Kreslení čar a Výplně když chcete změnit vlastnosti malování
použité na existující objekty, musíte je nejdříve označit. 
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KAPITOLA 4
Práce s barvou

Flash poskytuje mnoho různých způsobů  používání, tvorby a změny barev. Barvy
můžete aplikovat na výplň nebo načrtnutí objektu použitím a0 už implicitní nebo
vytvořené palety. Aplikace barvy tahu na tvar nakreslí touto barvou obrys tvaru.
Aplikace barvy výplně na tvar vyplní touto barvou vnitřní prostor tvaru.

Pokud na objekt aplikujete barvu tahu, můžete si vybrat jakoukoli plnou barvu a také
si můžete vybrat jeho styl a šířku. Na výplň tvaru můžete aplikovat plnou barvu,
gradient nebo bitmapu. Abyste na výplň mohli aplikovat bitmapu, musíte ji do souboru
nejdříve importovat. K vytvoření pouze obrysu objektu bez výplně nebo pouze výplně
bez obrysu můžete použít transparentní výplň nebo náčrt. A také můžete použít plnou
barvu výplně, kterou budete psát. Viz „Nastavování typu vlastností“.

Vytvoření a úpravu plných barev vám umožní Mixer (Míchací) panel. K vytvoření a úpravě
gradientu výplní použijte panel Fill (Výplně). Používáním panelu Swatches (Vzorů)
můžete importovat, exportovat, mazat a jinak měnit paletu barev pro soubor.

Určování vlastností tahu a výplně

K určení barvy tahu nebo výplně můžete použít kontrolku Stroke (Kreslení čar) a Fill
(Výplně) v panelu nástrojů, nástroje Ink Bottle (Kalamář) a Paint Bucket (Plechovka
s barvou), nebo panel Stroke (Kreslení čar) a Fill (Výplně). Ke změnění stylu tahu nebo
tlouš0ky čáry použijte panel Stroke (Kreslení čar). K vytvoření nebo editování gradientu
výplně nebo aplikování bitmapových výplní použijte panel Fill (Výplně).
Když vytváříte nové objekty s použitím kreslících nebo malovacích nástrojů, jsou
objekty malovány s vlastnostmi, které jste určili v kontrolce Kreslení čar a Výplně. Také
můžete změnit vlastnosti tahu a výplně již existujících objektů.

Vlastnosti tahu nebo výplně můžete kopírovat z jednoho objektu na jiný použitím
nástroje Dropper (Kapátko).
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Výběr barvu, stylu a tlouš0ky tahu pomocí panelu Kreslení čar:

1. Zvolte Window > Panels > Stroke (Kreslení čar)

2. K vybrání barvy klikněte na trojúhelník vedle nabídky barev v panelu Kreslení
čar a proveBte jedno z následujících:

� Z palety barev vyberte vzor barvy

� Do textového pole napište hexadecimální hodnotu barvy

� K použití transparentní čáry klikněte na tlačítko None (Žádná).

Poznámka: transparentní čáru můžete aplikovat na nový objekt, ale ne na už existující
objekt. Místo toho označte existující čáru a smažte ji.

Klikněte na tlačítko Color Picker (Vyber barvu) a zvolte barvu.

3. Abyste vybrali styl tahu, klikněte na trojúhelník vedle kontextové nabídky
Style (Styl) a zvolte možnost  z nabídky. K vytvoření vlastního stylu, zvolte
Custom (Vlastní) z kontextové nabídky v pravém horním rohu panelu
Kreslení čar, potom vyberte možnost z dialogového okna Styl čáry a klikněte 
na OK.

Poznámka: Vybrání jiného stylu tahu než Solid (Plný) může způsobit zvětšení velikosti
souboru.

4. Abyste vybrali tlouš0ku tahu, klikněte na trojúhelník vedle kontextové nabídky 
Weight (Šířka) a nastavte požadovanou šířku.

Práce s plnými, gradientními a bitmapovými výplněmi v panelu Výplň

Panel Fill (Výplň) můžete použít k vybrání transparentní nebo plné barvy výplně, gradientní
nebo bitmapové výplně. Panel Výplň vám také umožňují vybrat nebo upravovat gradient
výplně. Použitím bitmapy importované do aktuálního souboru můžete aplikovat
bitmapovou výplň. Pro informace k vytváření bitmapové výplně se podívejte na „Rozdělní
bitmapy“.

Použití transparentní výplně pomocí panelu Výplně:

1. Vyberte Window > Panels > Fill (Výplň)

2. Z nabídky výplně zvolte None (Žádná)

Poznámka: transparentní výplň můžete aplikovat na nový objekt, ale ne na už existu-
jící objekt. Místo toho označte existující výplň a smažte ji.
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Pro aplikaci barvy tahu a výplně pomocí panelu nástrojů, proveBte jedno z následujících:

� Klikněte na trojúhelník vedle panelu s barvami Stroke (Tahu) nebo Fill (Výplně)
a vyberte vzorek barvy z kontextového okna. Gradienty mohou být vybrány
pouze pro barvu výplně.

� Do textového pole v kontextovém okně barvy vepište hexadecimální hodnotu 
barvy.

� K použití transparentního tahu nebo výplně klikněte v kontextovém okně
na tlačítko None (Žádná).

� Poznámka: transparentní čáru nebo výplň můžete aplikovat na nový objekt,
ale ne na už existující objekt. Místo toho označte existující čáru nebo výplň
a smažte je.

� Klikněte na tlačítko Color Picker (Výběr barvy) v kontextovém okně k barvě
a zvolte barvu z color Picker (Výběru barvy).

� Abyste vyměnili barvy mezi výplní a čárou, klikněte na tlačítko Swap Fill
and Stroke (Vyměň Výplň a Čáru) v panelu nástrojů.

� Abyste se vrátili k implicitnímu nastavení barev (bílá výplň a černá čára),
klikněte na tlačítko Default Fill and Stroke (Původní Výplň a Čára) v panelu
nástrojů.

Určení barvy, stylu a tlouš/ky tahu v panelu Kreslení čar

Panel Stroke (Kreslení čar) můžete použít ke změně barvy, stylu a tlouš0ky čáry tahu
vybraného objektu. Styl tahu můžete zvolit ze stylů, které jsou už ve Flashi nahrány
předem nebo vytvořit vlastní styl.
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5. Abyste přidali ukazovatel (pointer) ke gradientu, klikněte pod lištu s definicí
gradientu. Vyberte barvu pro nový ukazovatel podle postupu popsaného
v kroku 4.

6. Abyste odebrali ukazovatel z gradientu, přetáhněte ho myší pryč z lišty.

7. Abyste gradient uložili, klikněte na trojúhelník v pravém horním rohu panelu 
Výplně a z kontextové nabídky vyberte Add (Přidat) gradient. Gradient je přidán
do palety Swatches (Vzorů) patřící k aktuálnímu dokumentu.

Použití bitmapové výplně pomocí panelu Výplně:

1. Vyberte Window > Panels > Fill (Výplň)

2. Z nabídky Výplně zvolte Bitmapa

� Klikněte na bitmapu v okně Výplň bitmapou, které se objeví v panelu Výplně.
Bitmapovou výplň můžete změnit za použití nástroje Plechovka s barvou.
Viz další sekce.
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Použití plné barvy pomocí panelu Výplně:

1. Vyberte Window > Panels > Fill (Výplň)

2. Vyberte Solid (Plná) z nabídky Výplně

3. Klikněte na trojúhelník vedle nabídky barev Výplně a proveBte jedno
z následujících:

� Táhněte myší, abyste jste vybrali barvu z palety

� Do textového pole vepište hexadecimální hodnotu barvy

� Klikněte na tlačítko Color Picker (Výběr barvy) z kontextového okna barvy
a vyberte barvu

Použití, vytvoření nebo upravování gradientní výplně pomocí panelu Výplně:

1. Vyberte Window > Panels > Fill (Výplň)

2. Z nabídky Výplně vyberte jeden z následujících:

� Lineární gradient vytvoří gradient, který přechází z počátečního do konečného
bodu v přímé linii

� Radiální gradient vytváří gradient, který přechází z počátečního do konečného
bodu podle kruhového vzoru

3. Klikněte na tlačítko Fill color (Vyplnit barvou) v panelu nástrojů a z palety
vyberte gradient.

4. Abyste změnili barvu vybraného gradientu, klikněte na jeden z ukazovatelů
(pointer) pod lištou s definicí gradientu a klikněte na nabídku s barvou,
která se vedle ní objeví 
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Přizpůsobení gradientu nebo bitmapy pomocí nástroje Plechovka s barvou:

1. Vyberte nástroj Plechovka s barvou.

2. Klikněte na Transform Fill (Měnič výplně).

3. Klikněte na oblast vyplněnou gradientem nebo bitmapou.

� Když pro úpravy vyberete gradient nebo bitmapu, objeví se její centrální bod 
a hranice s úchytkami určenými pro úpravy. Pokud je ukazatel myši nad jednou 
z těchto úchytek, změní se tak, aby naznačoval její funkci. Abyste dosáhli toho,
že směr výplně lineárního gradientu je násobkem 45°, zmáčkněte klávesu Shift.

4. Změňte gradient nebo výplň jedním z následujících způsobů:

� Abyste přemístili centrální bod gradientu nebo bitmapové výplně, přetáhněte
ho myší.

� Abyste změnili šířku gradientu nebo bitmapové výplně, přetáhněte čtvercovou
úchytku na straně hranice objektu. (Tato možnost změní pouze velikost 
výplně, ne objektu, který výplň obsahuje.)

� Abyste změnili výšku gradientu nebo bitmapové výplně, přetáhněte čtvercovou
úchytku na spodní straně hranice objektu.
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Používání nástroje Plechovka s barvou

Nástroj Paint Bucket (Plechovka s barvou) vyplňuje uzavřené oblasti barvou. Může
vyplnit jak prázdné oblasti, tak změnit barvu oblastí už vymalovaných. Malovat
můžete plnými barvami, gradienty a bitmapami. Nástroj Plechovka s barvou můžete
použít k tomu, abyste vymalovali oblasti, které nejsou úplně uzavřeny a můžete určit,
aby Flash uzavřel mezery ve tvaru obrysů.

Nástroj Plechovka s barvou můžete také použít k tomu, abyste přizpůsobili velikost,
směr a střed výplní gradient a bitmapa. Pro informace k vytváření bitmapových výplní
se podívejte na „Rozdělování bitmapy“.

Poznámka: Když změníte bitmapovou výplň pomocí nástroje Plechovka s barvou,
jsou změněny všechny instance bitmapové výplně a nejen aktuální výběr.

Tvar vlevo není úplně uzavřen, ale stále může být vyplněn. Tvar hvězdy se skládá
z jednotlivých čar, které uzavírají oblast, která může být vyplněna.

Použití Plechovky s barvou při přebarvení:

1. Vyberte nástroj Plechovka s barvou

2. Vyberte barvu a styl výplně tak, jak je popsáno v „Práce s plnými, gradientními
a bitmapovými výplněmi v panelu Výplň“.

3. Klikněte na měnič Gap Size (Velikosti mezery) a vyberte možnost velikosti
mezery:

� Vyberte Don t Close Gaps (Neuzavírat mezery), pokud chcete před vyplněním
tvaru mezery uzavřít ručně. Uzavírání mezer ručně může být rychlejší u složitých
kreseb.

� Vyberte možnost Close (Uzavřít) a Flash vyplní tvary s mezerami.

4. Klikněte na tvar nebo uzavřenou oblast, kterou chcete uzavřít.

Poznámka: Přibližování nebo oddalování mění pouze náhled, ale ne vlastní velikost
mezer. Pokud jsou mezery příliš velké, budete je muset uzavřít ručně.
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� Abyste vnitřek tvaru vydláždili bitmapou, změňte měřítko výplně.

Poznámka: Abyste viděli všechny úchytky, když pracujete s velkými výplněmi nebo
výplněmi blízko okraje Plochy, vyberte View > Work Area.

Používání nástroje Kalamář

Ke změnění barvy tahu, šířky čáry a stylu čar nebo tvaru obrysů můžete použít nástroj
Ink Bottle (Kalamář). Na čáry nebo obrysy můžete aplikovat pouze plné barvy, 
ne gradienty nebo bitmapy.
Použitím nástroje Kalamář místo vybírání jednotlivých čar si zjednodušíte práci
při změně vlastnosti čáry několika objektů najednou.

Používání nástroje Kalamář:

1. Vyberte nástroj Kalamář.

2. Vyberte barvu tahu tak, jak je popsáno v „Používání kontroly Kreslení čar
a Výplně v panelu nástrojů“.

3. Vyberte styl a šířku čáry z panelu Kreslení čar. Viz „Určení barvy, stylu a tlouš0ky
tahu v panelu Kreslení čar“.

4. Abyste aplikovali změny tahu, klikněte na objekt na Ploše.

Používání nástroje Kapátko

Nástroj Eyedropper (Kapátko) můžete použít ke kopírování vlastností výplně a čar
z jednoho objektu a okamžitě je aplikovat na jiný. Nástroj Kapátko vám také umožňuje
použít obrázek z bitmapy jako vzorek výplně.
Viz „Rozdělování bitmapy“.

Používání nástroje Kapátko ke kopírování a aplikování vlastností tahu a výplně:

1. Vyberte nástroj Kapátko a klikněte na čáru nebo vyplněnou plochu, jejíž
vlastnosti chcete aplikovat na jinou čáru nebo vyplněnou oblast. 
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� K otočení gradientu nebo bitmapové výplně, přetáhněte kulatou úchytku v rohu.
Přetáhnout také můžete nejnižší úchytku na hranici kružnice kulatého gradientu
nebo výplně.

� Abyste změnili velikost lineárního gradientu nebo výplně, přetáhněte úchytku 
uprostřed hranice objektu.

� Abyste změnili poloměr kruhového gradientu, přetáhněte prostřední kulatou
úchytku na hranici kružnice.

� Abyste zkreslili nebo naklonili výplň v rámci tvaru, přetáhněte jednu z kulatých
úchytek na horní nebo boční straně hranice objektu.
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Vytváření a upravování plných barev pomocí 
Míchacího panelu

Mixer (Míchací) panel můžete použít k vytvoření a úpravě plných barev. Pokud je objekt
na Ploše vybrán, jsou změny barvy, které jste provedli v Míchacím panelu na výběr
aplikovány.
Barvu můžete vybrat z existující palety barev nebo můžete vytvořit barvu novou. Barvy
můžete vybrat v RGB nebo hexadecimálním módu, nebo určit hodnotu Alfa a tím pro
barvu definovat stupeň průhlednosti.

Vytváření nebo upravování plné barvy pomocí Míchacího panelu:

1. Vyberte Window > Panels > Mixer.

2. Abyste vybrali  zobrazení módu barvy, z kontextové nabídky v pravém
horním rohu Míchacího panelu zvolte RGB (implicitní nastavení), HSB nebo Hex.

3. Klikněte na nabídku barev Stroke (Čáry) a Fill (Výplně). 

Pokud jste vybrali objekt s gradientní výplní, nabídka barev pro Výplň zobrazí
gradient. K výměně gradientu za plnou barvu ve výběru, klikněte na nabídku 
barev Výplně a vyberte plnou barvu výplně tak, jak je popsáno v kroku 4. 

Pokud právě upravujete gradientní výplň pomocí panelu Výplně, Míchací
panel zobrazuje obdélník s aktuálně vybranou barvou z editoru gradientu
Výplně. K ukončení editování gradientu klikněte na barevný knoflík v Míchacím
panelu.
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Když klikněte na čáru, nástroj se automaticky změní na nástroj Kalamář. Pokud
kliknete na vyplněnou oblast, nástroj se automaticky změní na nástroj Plechovka s
barvou a zapne se měnič Lock Fill (Zamknout výplň). Viz „Zamykání gradientu nebo
bitmapy k vyplnění Plochy“.

2. K aplikování nových vlastností klikněte na další čáru nebo vyplněnou plochu 

Zamykání gradientu nebo bitmapy k vyplnění Plochy

Aby to vypadalo tak, že výplň přesahuje přes celou Plochu a že objekty vymalované
výplní jsou masky zakrývající níže ležící gradient nebo bitmapu, můžete gradient nebo
bitmapovou výplň zamknout. Když vyberete měnič Lock Fill (Zamknout výplň) pomoci
nástroje Štětec nebo Plechovka s barvou a s nástrojem malujete, bitmapa nebo gradientní
výplň přesahuje přes objekty, které jste na Ploše namalovali.

Používání zamknutého gradientu nebo bitmapové výplně:

1. Vyberte nástroj Brush (Štětec) nebo Plechovku s barvou a vyberte výplň gradient
nebo bitmapa.
Abyste použili bitmapu jako výplň, rozdělte ji a než nástroj Štětec nebo
Plechovka s barvou použijete, použijte nástroj Kapátko k označení bitmapy. 
Viz „Rozdělování bitmapy“.

2. Klikněte na měnič Lock Fill (Zamknout výplň).

3. Nejdřív namalujte oblasti, kam chcete umístit střed výplně a potom se přesuňte
do dalších oblastí.
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Duplikování a odebírání barev z palety

Můžete duplikovat nebo mazat jednotlivé barvy nebo smazat všechny barvy z palety. 

Duplikování nebo smazání barvy z palety barev:

1. Vyberte Window > Panels > Swatches (Vzorky).

2. Klikněte na barvu, kterou chcete duplikovat nebo smazat.

3. Vyberte Duplicate Swatch (Duplikovat vzorek) nebo Delete Swatch (Smazat 
vzorek) z kontextové nabídky v pravém horním rohu.

Smazání všech barev z palety:

� V panelu Swatches (Vzorků) vyberte Clear Colors (Smazat barvy) z kontextové 
nabídky v pravém horním rohu. Všechny barvy kromě černé a bílé jsou z palety
odstraněny.

Požívání implicitní palety a palety bezpečné pro Web

Aktuální paletu můžete uložit jako implicitní, přepsat ji původní pro soubor definovanou
paletou, nebo nahrát paletu bezpečnou pro Web.

Nahrání nebo uložení původní palety:

� V panelu Swatches (Vzorků) vyberte z kontextové nabídky v pravém horním
rohu jeden z následujících příkazů:

� Load Default Colors (Nahrát původní barvy) nahradí aktuální paletu paletou
implicitní

� Save as Default (Uložit jako implicitní) uloží aktuální paletu jako implicitní.
Když vytváříte nové soubory, je použita nová implicitní paleta.

K nahrání pro Web bezpečné palety s 216 barvami:

� Z kontextové nabídky v pravém horním rohu v panelu Vzorků vyberte Web 216.

Třídění palety

Abyste barvu jednodušeji našli, můžete barvy v paletě setřídit podle odstínu.

K setřídění barev v paletě:

� Z kontextové nabídky v pravém horním rohu v panelu Swatches (Vzorků) 
vyberte Sort by Color (Třídit podle barvy).
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4. ProveBte jedno z následujících:

� Klikněte na nabídku barev pro Stroke (Kreslení čar) nebo Fill (Výplně) a vyberte
barvu z kontextového okna.

� K výběru barvy klikněte na lištu barev v dolní části Míchacího panelu

� Do polí hodnoty barvy zadejte hodnoty: Red (Červené), Green (Zelené) a Blue
(Modré) pro RGB; Hue (Odstín), Saturation (Sytost) a Brightness (Jas) pro HSB;
nebo hexadecimální hodnotu pro hexadecimální zobrazení. Zadejte hodnotu
alfa pro určení stupně průhlednosti, od 0 pro úplnou průhlednost do 100 pro
úplnou neprůhlednost.

� Pro návrat k implicitnímu nastavení barev (bílá výplň a černá čára) klikněte
na Default Stroke and Fill (Původní čára a výplň).

� K výměně barev mezi výplní a čárou klikněte na tlačítko Swap (Vyměnit) čáru
a výplň.

� K aplikaci průhledné výplně nebo čáry klikněte na tlačítko None (Žádná).

Poznámka:  transparentní čáru nebo výplň můžete aplikovat na nový objekt, ale ne na
už existující objekt. Místo toho označte existující čáru nebo výplň a smažte ji.

5. Abyste přidali barvu definovanou v kroku 4 do vzorníku barev aktuálního
souboru, vyberte Add Swatch (Přidat vzorek) z kontextové nabídky v pravém 
horním rohu Míchacího panelu.

Výměna palety barev

Každý Flash soubor obsahuje svou vlastní uloženou paletu barev. Flash paletu
souboru zobrazuje jako vzorky v modifikátorech pro výplň, čáru a barvu k psaní a v panelu
Vzorků. Implicitní paleta barev je pro Web bezpečná paleta obsahující 216 barev.
Barvy do aktuální palety můžete přidávat pomocí Míchacího panelu.  Viz „Vytváření
a upravování plných barev pomocí Míchacího panelu“.

K importování, exportování a měnění palety barev v souboru použijte panel Vzorků.
Barvy můžete duplikovat nebo je z palety odebírat, měnit implicitní paletu, obnovit
paletu bezpečnou pro Web (pokud jste ji přepsali) nebo paletu seřadit podle odstínu.

Můžete importovat a exportovat plnou i gradientní barvu jak mezi Flash soubory, tak
mezi soubory Macromedia Fireworks a Adobe Photoshop.
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KAPITOLA 5

Používání importovaných výtvorů

Vaše animace Flash může používat výtvory z jiných aplikací. Můžete importovat
vektorovou grafiku a bitmapy ve velkém množství formátů souborů. Pokud máte
nainstalovaný QuickTime 4 nebo pozdější verzi, můžete importovat i tyto formáty
souborů. Pro více informací viz "Import formátů souborů".

Přímo do Flashe můžete také importovat soubory FreeHand (verze 7 nebo pozdější)
a PNG soubory Fireworks při zachování vlastností těchto formátů.

Pro import zvukových souborů ve formátech WAV (ve Windows), AIFF (na Macintoshi)
a MP3 (oba případy), viz "Import zvuků".

Umístění výtvoru do Flashe

Flash rozpozná velké množství formátů vektorů a bitmap. Výtvory můžete do Flashe
umís0ovat importem nebo vkládáním. Flash importuje vektorovou grafiku, bitmapy
a sekvence obrázků následovně:

� Vektorové obrázky z FreeHand jsou importovány přímo do animace Flash.
Můžete si vybrat volby pro zachování vrstev, stránek a bloků textu FreeHand. 
O importování souboru FreeHand viz "Import souborů FreeHand".

� Obrázky PNG z Fireworks mohou být importovány přímo do animace Flash při 
zachování vektorových a bitmapových dat jako upravovatelných objektů. 
Můžete si vybrat volby pro zachování obrázků, textu a vodítek. O importu 
PNG souboru Fireworks viz "Import PNG souborů Fireworks".

Poznámka: Pokud importujete PNG soubor z Fireworks kopírováním a vložením,
je soubor konvertován do bitmapy.

� Vektorové obrázky ze souborů formátu SWF, Adobe Illustrator a Windows 
Metafile jsou importovány jako skupina do aktuální vrstvy. Viz "Import formátů 
souborů" a "Soubory Adobe Illustrator".

� Bitmapy (skenované fotografie, BMP soubory) jsou importovány jako 
jednoduché objekty do aktuální vrstvy. Flash zachovává nastavení průhlednosti
importovaných bitmap. Protože importování bimapy může zvýšit velikost 
souboru animace, budete možná chtít importované bitmapy komprimovat. 
Viz "Nastavení vlastností bitmap".

Poznámka: Průhlednost bitmapy nemusí být zachována, pokud jsou bitmapy importovány
přetahováním myši. Pro zachování průhlednosti použijte příkaz Soubor > Importovat.
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Importování a exportování palet barev

K importování a exportování jak RGB barev, tak gradientů mezi Flash soubory,
použijete Flash soubory s Nastavením barvy (CLR soubory). RGB palety barev
můžete importovat a exportovat  pomocí souborů s Tabulkou barvy (ACT soubory),
které mohou být použity s Macromedia Fireworks a Adobe Photoshop. Palety barev
(ale ne gradienty) můžete importovat i ze souborů GIF. Gradienty nemůžete importovat
ani exportovat ze souborů ACT.

Importování palety barev:

1. V panelu Swatches (Vzorků) vyberte jeden z následujících příkazů z kontextové
nabídky v pravém horním rohu:

� K přidání importovaných barev do aktuální palety vyberte Add Colors 
(Přidat barvy).

� K přepsání aktuální palety importovanými barvami vyberte Replace Colors
(Nahradit barvy).

2. Přesuňte se na požadovaný soubor a vyberte ho.

3. Klikněte na tlačítko OK.

Exportování palety barev:

1. Z kontextové nabídky v pravém horním rohu vyberte Save Colors (Uložit barvy)

2. Do dialogového okna, které se objeví, vepište název palety barev.

3. Pro Save As (Uložit jako) (Windows) nebo Formát (Macintosh) vyberte Color Set 
(Nastavit barvu) nebo Color Table (Tabulka barvy). Klikněte na tlačítko Save 
(Uložit).
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Import formátů souborů

Flash 5 může importovat různé formáty souboru v závislosti na tom, zda je instalován
QuickTime 4 nebo jeho pozdější verze. Používání Flashe s instalovaným QuickTime 4
je zvláště užitečné pro společné projekty, ve kterých autoři pracují ve Windows i na
Macintoshi. QuickTime 4 rozšiřuje podporu pro určité formáty souboru (včetně Adobe
Photoshop, PICT, QuickTime Movie a dalších) v obou systémech.

Následující formáty souborů mohou být importovány do Flashe, nezávisle na tom,
zda je nainstalován QuickTime 4:

Následující formáty souborů mohou být importovány do Flashe jen pokud je nainstalován
QuickTime 4 nebo jeho pozdější verze:
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Typ souboru
Adobe Illustrator
(verze 6.0 nebo
dřívější; viz soubory
Adobe llustrator)
AutoCAD DXF 
(viz "Soubory DXF")
bitmapa
Enhanced Windows
Metafile
FreeHand

FutureSplash Player
GIF a animovaný
GIF
JPEG
PICT
PNG
Přehrávač Flash
Winows Metafile

Přípona
.eps, .ai

.dxf

.bmp

.emf

.fh7, .ft7, .fh8, .ft8,

.fh9, .ft9

.spl

.gif

.jpg

.pct, .pic

.png

.swf

.wmf

Windows
�

�

�

�

�

�

�

�

�

�

�

�

Macintosh
�

�

�

�

�

�

�

�

�

Typ souboru
MacPaint
Photoshop
PICT
QuickTime Image
QuickTime Movie
Silicon Graphics
TGA
TIFF

Přípona
.pntg
.psd
.pct, .pic
.qtif
.mov
.sai
.tgf
.tiff

Windows
�

�

��(jako bitmapa)
�

�

�

�

�

Macintosh
�

�

�

�

�

�

�

� Jakákoliv sekvence obrázků (například PICT a BMP sekvence) je importována 
jako po sobě následující snímky do aktuální vrstvy.

� Informace o specifických formátech souborů viz "Import formátů souborů".

Import souboru do Flashe:

1. Zvolte File > Import.

2. V dialogovém okně Importt vyberte formát z kontextového menu Show (Zobrazit).

3. Najděte požadovaný soubor a označte jej.

� Jestliže má importovaný soubor více vrstev, může Flash vytvořit nové vrstvy.
Ujistěte se, že je při importování souboru s více vrstvami viditelná Časová osa.

Poznámka: Pokud importujete PNG soubor Fireworks viz "Import PNG souborů
Fireworks". Pokud importujete soubor FreeHand viz "Import souborů FreeHand".

4. ProveOte jedno z následujících:

� Ve Windows klikněte na Open (Otevřít).

� Na Macintoshi klikněte na Add (Přidat) pro přidání zvoleného souboru
do seznamu Importovat a klikněte na Importovat pro import souboru nebo
souborů v seznamu Importovat.

5. Jestliže název souboru, který importujete, končí číslem, a ve stejné složce
jsou další následně očíslované soubory, Flash se vás zeptá, jestli chcete 
importovat sekvenci těchto souborů:

� Klikněte na Ano pro import všech následných souborů.

� Klikněte na Ne pro import pouze označeného souboru.

Následují příklady jmen souborů, které mohou být použity jako sekvence:

� Snímek001.gif, Snímek002.gif, Snímek003.gif
Pták 1, Pták 2, Pták 3
Chůze-001.ai, Chůze-002.ai, Chůze-003.ai

Vložení bitmapy z jiné aplikace do Flashe:

1. Zkopírujte obrázek v aplikaci do schránky.

2. Ve Flashi zvolte File > Paste (Vložit).
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� Flatten Image (Zploštit obrázek) importuje PNG soubor jako bitmapový 
obrázek do aktuální vrstvy. Bitmapa je umístěna v knihovně aktuální animace
a může být  upravována ve Fireworks nebo jiném externím obrázkovém editoru.
Viz "Úprava bitmap".

6. Klikněte na tlačítko OK.

Import souborů Freehand

Soubory FreeHand (verze 7 nebo pozdější) můžete importovat přímo do Flashe.
FreeHand je nejlepší volba pro vytváření vektorové grafiky pro import do Flashe,
protože můžete zachovávat vrstvy, bloky textu, symboly knihovny a stránky z
FreeHand a vybrat rozsah stránky pro import. Jestliže importovaný soubor FreeHand
je v režimu CMYK, Flash jej konvertuje do RGB.

Při importu souborů FreeHand mějte na paměti následující:

� Při importu souborů s překrývajícími se objekty, které chcete uchovat jako
samostatné objekty, umístěte objekty ve FreeHand do zvláštních vrstev
a při importu souboru do Flashe v dialogovém okně Import z FreeHand
vyberte Layers (Vrstvy). (Pokud jsou do Flashe importovány překrývající se 
objekty na jedné vrstvě, budou rozděleny v průsečících, stejně jako je tomu
u překrývajících se objektů vytvořených ve Flashi.)

� Když importujete soubory s gradientní výplní, může Flash podporovat až osm
barev v gradientním poli. Jestliže soubor FreeHand obsahuje gradientní
výplň s více než osmi barvami, vytvoří Flash vystřižené úseky pro simulaci
vzhledu gradientního pole. Vystřižené úseky mohou zvětšit velikost souboru.
Pro minimalizaci velikosti souboru používejte ve FreeHand gradientní výplně
s osmi nebo méně barvami.

� Když importujete soubor s blends (přechodovými) efekty, Flash importuje
každý krok v přechodu jako zvláštní úsek. Proto čím více kroků má přechodový
efekt, tím větší bude importovaný soubor ve Flashi.

� Když importujete soubory se čtvercovými tahy, Flash je konvertuje na kulaté.

� Když importujete soubory s vloženými obrázky v šedé stupnici, Flash
je konvertuje do RGB obrázků. Tato změna může zvýšit velikost importovaného 
souboru.

� Když importujete soubory s vloženými EPS obrázky, musíte nejprve zvolit 
Convert Editable EPS (Konvertovat upravitelné EPS) ve volbě Importovat
ve Freehand v Preferencích importu. Pokud tuto volbu neoznačíte, EPS
obrázek nebude při importaci do Flashe viditelný.  Flash dále nezobrazuje 
informace o importovaném EPS obrázku (nezávisle na nastavení v Preferencích
použitém ve FreeHand).
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Import PNG souborů Fireworks

PNG soubory Fireworks můžete do Flashe importovat jako plošné obrázky nebo
upravovatelné objekty. Když importujete PNG soubor jako plošný obrázek, je celý
soubor (včetně vektorových výtvorů) rastrován nebo konvertován do bitmapového
obrázku.
Když importujete PNG soubor jako upravovatelné objekty, vektorový výtvor v souboru
je zachován ve vektorovém formátu. Když importujete jako upravovatelný objekt,
můžete si vybrat uchování umístěných bitmap, textu a vodítek v PNG souboru.

Když importujete PNG soubor jako plošný obrázek, můžete spustit Fireworks ve Flashi
a upravit původní PNG soubor (s vektorovými daty). Viz "Úprava bitmap".

Poznámka: Bitmapové obrázky můžete ve Flashi upravovat konvertováním
bitmapových obrázků do vektorové grafiky nebo rozdělením bitmapových obrázků.
Viz "Konverze bitmap do vektorové grafiky" a "Rozdělování bitmap".

Import PNG souboru Fireworks:

1. Zvolte File > Import.

2. V dialogovém okně Import vyberte z kontextového menu Show (Zobrazit)
obrázek PNG.

3. Najděte PNG obrázek Fireworks a označte jej.

4. ProveOte jedno z následujících:

� Klikněte na Open (Otevřít) (ve Windows).

� Klikněte na Add (Přidat) (na Macintoshi) pro přidání označeného souboru
do seznamu Importovat a klikněte na Importovat pro import souboru nebo
souborů ze seznamu Importovat.

5. V dialogovém okně Import Settings (Nastavení importu) PNG vyberte jedno
z následujících:

� Import Editable Elements (Importovat upravitelné prvky) importuje PNG soubor
jako zvláštní prvky a zachová vektorové výtvory. Vyberte Include Images
(Zahrnout obrázky) pro zachování bitmapových obrázků v importovaném
souboru. (Bitmapové obrázky jsou umístěny v knihovně aktuální animace, 
ale nemohou být upravovány v externím obrázkovém editoru.) Vyberte
Include Text (Zahrnout text) pro zachování textu jako upravitelných bloků
textu. Zvolte Include Guides (Zahrnout vodítka) pro import vodítek Fireworks 
jako tažiteltelných vodítek.
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� Include Background Layer (Vložit vrstvy v pozadí) importuje s dokumentem
FreeHand vrstvy v pozadí.

� Maintain text Blocks (Zachovat bloky textu) zachová text dokumentu
FreeHand upravitelný v animaci Flash.

9. Klikněte na tlačítko OK.

Soubory Adobe Illustrator

Flash podporuje import a export formátů Adobe Illustrator 88, 3.0, 5.0 a 6.0.
(Informacích o exportování souborů Illustrator viz "Adobe Illustrator".)

Když importujete soubor Illustratoru do Flashe, musíte  rozdělit objekty Illustratoru,
které jsou ve skupinách, ve všech vrstvách. Jakmile jsou objekty rozděleny, může
se s nimi manipulovat jako s jakýmkoliv dalším objektem Flash.

O importu bitmapových obrázků

Import bitmapových obrázků do animace může zvýšit velikost souboru animace.
Pro zmenšení velikosti souboru bitmapového obrázku můžete vybrat volbu komprimace
v dialogovém okně Vlastnosti bitmapy. Viz "Nastavení vlastností bitmapy". 

Importovanou bitmapu můžete upravovat spuštěním Fireworks nebo jiného externího
obrázkového editoru v rámci Flashe. 

Bitmapu můžete obkreslit, abyste její obrázek konvertovali do vektorové grafiky.
Provedení této konverze vám umožní měnit grafiku stejně jako ostatní vektorové
výtvory ve Flashi a také zmenší velikost souboru. Viz "Konverze bitmap do vektorové
grafiky".

Bitmapu můžete rozdělit do upravitelných oblastí. Bitmapa si uchovává svůj původní
detail, ale je rozdělena do samostantých ploch barev, které můžete vybírat a upravovat
zvlášX pomocí kreslících a malovacích nástrojů Flashe. Rozdělení bitmapy vám také
umožní použití bitmapy jako výplně objektů. Viz "Rozdělování bitmap".

Pokud animace Flash zobrazí importovanou bitmapu větší než je originál, může
být obrázek deformován. Abyste se ujistili, že obrázky budou zobrazeny správně,
proveOte nejprve náhled na bitmapu.
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Import FreeHand souboru:

1. Zvolte File > Import.

2. V dialogovém okně Importovat zvolte FreeHand v kontextovém menu Show
(Zobrazit).

3. Najděte soubor FreeHand a označte jej.

4. ProveOte jedno z následujících:

� Ve Windows klikněte na Open (Otevřít).

� Na Macintoshi klikněte na Add (Přidat) pro přidání označeného souboru 
do seznamu Importovat a klikněte na Importovat pro import souboru nebo 
souborů v seznamu Importovat.

5. V dialogovém okně Import Settings (Nastavení importu) souborů FreeHand
vyberte nastavení pro Mapping Pages (Mapování stránek):

� Scenes (Scény) konvertuje každou stránku dokumentu FreeHand na scénu
v animaci Flash.

� Keyframes (Klíčové snímky) konvertuje každou stránku dokumentu
FreeHand na klíčový snímek animace Flash.

6. Pro Layers (Vrstvy) vyberte jedno z následujících:

� Layers (Vrstvy) konvertuje každou vrstvu v dokumentu FreeHand na vrstvu
animace Flash.

� Keyframes (Klíčové snímky) konvertuje každou vrstvu v dokumentu
FreeHand na klíčový snímek animace Flash.

� Flatten (Zploštit) konvertuje všechny vrstvy v dokumentu FreeHand do jedné
ploché vrstvy animace Flash.

7. Pro volbu Pages (Stránky) vyberte jedno z následujících:

� All (Všechny) importuje všechny stránky dokumentu FreeHand.

� From (Od) (číslo stránky) To (Do) (číslo stránky) importuje daný rozsah stran
dokumentu FreeHand.

8. Pro Options (Volby) zvolte jednu z následujících voleb:

� Include Visible Layers (Vložit viditelné vrstvy) importuje pouze viditelné vrstvy
(ne skryté vrstvy) z dokumentu FreeHand.
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Soubory AutoCAD DXF

Flash podporuje formát AutoCAD DXF verze 10.

DXF soubory nepodporují standardní fonty systému. Flash se pokouší namapovat
náležité fonty, ale výsledky jsou nepředvídatelné, zvláště pokud jde o zarovnání textu.

Protože formáty DXF nepodporují plné výplně, jsou vyplněné plochy exportovány
pouze jako obrysy. Z tohoto důvodu je DXF formát nejvhodnější pro kreslení čar,
např. plánů podlaží a map.

Ačkoliv Flash v DXF souboru nepodporuje změnu měřítka, všechny soubory DXF
vytvářejí animace o rozměrech 12x12 palců, které můžete upravit přes volbu Modify
> Transform > Scale (Změnit měřítko). Flash také podporuje pouze ASCII DXF
soubory. Pokud jsou vaše DXF soubory binární, musíte je konvertovat na ASCII
předtím, než je importujete do Flashe.

Konverze bitmap na vektorovou grafiku

Příkaz Trace Bitmap (Obkreslit bitmapu) konvertuje bitmapu do vektorové grafiky
se samostatnými upravitelnými barevnými plochami. Tento příkaz použijte pro zacházení
s obrázkem jako s vektorovou grafikou nebo pro zmenšení velikosti souboru.

Pokud konvertujete bitmapu do vektorové grafiky, vektorová grafika se už neodkazuje
na symbol bitmapy v okně Knihovna.

Poznámka: Pokud importovaná mapa obsahuje složité tvary a mnoho barev, velikost
souboru konvertované vektorové grafiky můžete být větší než velikost souboru
původní bitmapy. Vyzkoušejte různá nastavení v dialogovém okně Trace Bitmap
(Obkreslit bitmapu), abyste nalezli vhodnou rovnováhu mezi velikostí souboru a kval-
itou obrázku.

Bitmapu můžete také rozdělit pro úpravu obrázku pomocí kreslících a malovacích
nástrojů Flashe nebo pro použití bitmapy jako výplně. Viz "Rozdělování bitmapy".

Konverze bitmapy do vektorové grafiky:

1. Vyberte bitmapu na aktuální scéně.

2. Zvolte Modify > Trace Bitmap (Obkreslit bitmapu).

3. Zadejte Color Threshold (Prahovou hodnotu barvy) mezi 1 a 500.

� Jestliže je při porovnání dvou bodů rozdíl v hodnotách RGB menší než prahová
hodnota, považují se ony dva body za stejné barvy. Jak zvyšujete prahovou
hodnotu, snižujete počet barev.
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Používání animací QuickTime

Pokud máte na svém systému nainstalován QuickTime 4 nebo jeho pozdější verzi,
můžete do Flashe importovat animaci QuickTime, abyste ji  ve Flashi mohli upravit.
Nicméně pokud chcete zobrazit animaci QuickTime, musíte ji exportovat ve formátu
QuickTime. Animaci QuickTime nemůžete zobrazit ve formátu SWF. Pro více informací
o publikování souboru Flash jako animace QuickTime viz "Publikování animací
QuickTime 4".

Animaci QuickTime můžete animovat, můžete s ní otáčet a můžete měnit její měřítko
a můžete také nastavovat cestu do adresáře animace v knihově.  Nicméně obsah
animace QuickTime nemůžete vykreslovat ve Flashi. Na importovanou animaci
QuickTime můžete použít jakoukoliv akci uvedenou v kategorii Basic Actions
(Základní akce) v Panelu akcí. 

Když importujete animaci QuickTime, je zobrazen pouze první snímek animace.
Abyste viděli další snímky v animaci ve Flashi, musíte přidat snímky do Časové osy
importované animace. Animace QuickTime importovaná do Flashe se nestává částí
souboru Flashe. Namísto toho Flash zachová odkaz na zdrojový soubor.

Náhled na animaci QuickTime:

1. Přidejte do Časové osy počet snímků, který odpovídá délce animace Flash,
kterou chcete přehrát.

2. Zvolte Control > Play.

Poznámka: Obsah animace QuickTime nemůžete prohlížet použitím příkazu
Control > Test Movie.

Nastavení cesty k souboru animace QuickTime:

1. Zvolte window > Library (Knihovna) a vyberte animaci QuickTime, kterou
chcete upravovat.

2. V menu Options (Volby) v pravém horním rohu okna Knihovna vyberte
Properties a klikněte na Set Path (Nastavit cestu) v dialogovém okně Video
Properties (Vlastnosti videa).
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Malování s bitmapovým obrázkem:

1. Break Apart (Rozdělte) bitmapu podle výše uvedeného postupu.

2. Zvolte nástroj Eyedropper (Kapátko) a klikněte na bitmapu.

� Kapátko nastaví bitmapu jako aktuální výplň a změní aktivní nástroj na Plechovku
s barvou.

3. Malujte pomocí nástroje Štětec nebo Plechovka s barvou.

Změna výplně označených oblastí rozdělené bitmapy:

1. Vyberte rozdělenou bitmapu na aktuální scéně.

2. Označte nástroj Laso a klikněte na měnič Kouzelnická hůlka.

3. Klikněte na měnič Magic Wand Settings (Nastavení kouzelnické hůlky) a nastavte
následující volby:

� Pro Threshold (Práh) nastavte hodnotu mezi 1 a 200 pro definování toho,
jak blízce musí odpovídat barva přilehlých bodů, aby byly zahrnuty do výběru.
Vyšší číslo zahrnuje širší škálu barev. Když zadáte 0, budou označeny jen
body přesně stejné barvy, jakou označíte kliknutím na bod.

Pro Smoothing (Vyhlazení) vyberte volbu z kontextového menu, kterou definujete, jak
moc budou vyhlazeny okraje bitmapy.

4. Klikněte na bitmapu pro výběr oblasti. Pokračujte v klikání pro přidání do výběru.

5. Označte výplň, kterou chcete použít pro vyplnění vybraných oblastí bitmapy.
Viz "Určení vlastností čar a výplní".

6. Vyberte nástroj Plechovka s barvou a klikněte kamkoliv na označené oblasti 
pro přidání nové výplně.
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4. Pro Minimum Area (Minimální oblast) zadejte hodnotu mezi 1 a 1000 
pro nastavení počtu okolních bodů, které budou brány v potaz při přiřazování
barvy bodu.

5. Pro Curve Fit (Přizpůsobení křivky) zadejte volbu z kontextového menu,
která určí, jak hladce budou vykresleny okraje.

6. Pro Corner Threshold (Rohovou prahovou hodnotu) vyberte volbu
z kontextového menu, která určí, zda budou ostré rohy zachovány nebo
vyhlazeny.

Pro vytvoření vektorové grafiky, která se nejvíce podobá původní bitmapě zadejte
následující hodnoty:

� Color Threshold (Prahová hodnota barvy): 10

� Minimum Area (Minimální plocha): 1 bod

� Curve Fit (Přizpůsobení křivky): Body

� Corner Threshold (Rohová prahová hodnota): Many Corners (Mnoho rohů)

Rozdělování bitmapy

Breaking Apart (Rozdělování bitmapy) oddělí body na obrázku do oddělených ploch,
které mohou být vybírány a upravovány zvlášX. Když rozdělujete bitmapu, můžete ji
měnit kreslícími a malovacími nástroji Flash. Bitmapu můžete také použít jako výplň.

Použitím nástroje Lasso (Laso) s měničem Magic Wand (Kouzelnická hůlka) můžete
měnit výplň označených oblastí bitmapy, která byla rozdělena.

Poté co vymalujete oblast bimapy, můžete použít nástroj Plechovka s barvou pro
otáčení, zešikmení nebo změnu měřítka bitmapového obrázku. Viz "Používání nástro-
je Plechovka s barvou".

Rozdělení bitmapy:

1. Zvolte bitmapu z aktuální scény.

2. Vyberte Modify > Break Apart (Rozdělit).
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Nastavení vlastností bitmapy

Na bitmapu můžete použít anti-aliasing (potlačení roztřepení čar) pro vyrovnání okrajů
obrázku. Můžete také vybrat volbu komprimace pro zmenšení velikosti bitmapového
souboru a formátovat soubor pro zobrazení na webu.

Pro nastavení vlastností bitmapy použijte dialogové okno Vlastnosti bitmapy.

Nastavení vlastností bitmapy:

1. Vyberte bitmapu v okně Knihovna.

2. ProveOte jedno z následujících:

� Klikněte na ikonu properties (vlastností) v okně Knihovna.

� Klikněte pravým tlačítkem myši (ve Windows) nebo držte Control a klikněte
(na Macintoshi) na ikonu bitmapy a v kontextovém menu zvolte Properties
(Vlastnosti).

� Vyberte properties (Vlastnosti) z menu Options (Možnosti) v pravém horním
rohu okna Knihovna.

3. V dialogovém okně Bitmap Properties (Vlasnosti bitmapy) zvolte Allow
Smoothing (Povolit vyhlazování) pro vyhlazení okrajů mapy pomocí potlačení
roztřepení čar.
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Úprava bitmap

Pokud máte ve vašem systému nainstalován Fireworks 3 nebo jeho pozdější verzi
nebo jinou aplikaci pro úpravu obrázků, můžete tuto aplikaci spustit přímo z Flashe
pro úpravu importované bitmapy.

Pokud upravujete PNG soubor Fireworks importovaný jako plošný obrázek, můžete
si vybrat úpravu PNG zdrojového souboru na bitmapu, pokud je tato volba k dispozici.

Poznámka: Bitmapy z PNG souborů Fireworks importované jako upravitelné objekty
nemůžete upravovat v externím obrázkovém editoru.

Úprava bitmapy pomocí Fireworks 3 nebo pozdější verze:

1. V okně Knihovna klikněte pravým tlačítkem (ve Windows) nebo držte Control 
a klikněte (na Macintoshi) na ikonu bitmapy.

2. V kontextovém menu bitmapy zvolte Edit (Upravit) ve Fireworks 3.

3. V dialogovém okně Edit Image (Upravit obrázek) určete, zda zdrojový PNG
soubor nebo bitmapový soubor mají být otevřeny.

4. ProveOte požadované změny v souboru ve Fireworks.

5. Zvolte File > Update (Aktualizovat).

� Soubor je ve Flashi automaticky aktualizován.

Úprava bitmapy pomocí jiné externí aplikace:

1. V okně Knihovna klikněte pravým tlačítkem (ve Windows) nebo držte Control
a klikněte (na Macintoshi) na ikonu bitmapy.

2. V kontextovém menu bitmapy zvolte Edit With (Upravit pomocí).

3. Zvolte aplikaci pro úpravu obrázků, ve které otevřete bitmapový soubor 
a klikněte na tlačítko OK.

4. ProveOte vyžadované změny v souboru v aplikaci pro úpravu obrázků.

5. Ve Flashi proveOte jedno z následujících:

� Vyberte ikonu bitmapy v okně Knihovna a zvolte Aktualizovat z menu Volby
knihovny.

� Klikněte pravým tlačítkem (ve Windows) nebo držte Control a klikněte
(na Macintoshi) na ikonu bitmapy v okně Knihovna a v kontextovém menu 
zvolte Aktualizovat.

� Soubor je ve Flashi automaticky aktualizován.
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KAPITOLA 6

Přidávání zvuků

Flash nabízí mnoho možností, jak používat zvuky. Můžete vytvářet zvuky, které hrají
nepřetržitě nezávisle na Časové ose, nebo můžete synchronizovat animaci se zvukovou
stopou. Můžete přiřadit zvuky k tlačítkům a tím je učinit více interaktivní a pro uhlazenější
zvukovou stopu zvuky zesilovat a zeslabovat.

Zvuky můžete použít ve sdílených knihovnách a tím zvuk připojit z jedné knihovny
k několika animacím. Zvuky také můžete použít ve Zvukových objektech a tím kontrolovat
zvukové přehrávání s ActionScript.

Ve Flashi existují 2 typy zvuků: event sounds (zvuky k událostem) a stream sounds
(streamované zvuky). Zvuk k události musí být před začátkem přehrávání úplně
stažen a pokračuje v přehrávání tak dlouho, dokud není jednoznačně zastaven.
Streamované zvuky se začínají přehrávat jakmile je staženo dostatek dat pro prvních
pár snímků; streamované zvuky jsou synchronizovány k přehrávání na Webové
stránce podle Časové osy.

Vyberte volby komprimace, abyste mohli kontrolovat kvalitu a velikost zvuků 
v exportovaných animacích.  Pomocí dialogového okna Sound Properties (Vlastnosti
zvuku) můžete vybrat volby komprimace pro jednotlivé zvuky, nebo v dialogovém
okně Publish Settings (Nastavení pro publikaci) definovat nastavení pro všechny
zvuky v animaci.

Pro interaktivní úvod do používání zvuku ve Flashi, vyberte Help > Lessons > Sound.

Importování zvuků

K přenesení souboru Wav (pouze Windows), AIFF (pouze Macintosh) nebo MP3
(obě platformy) do Flashe použijte příkaz File  > Import, stejně tak jako byste chtěli
importovat jakýkoli jiný typ souboru.

Pokud máte ve vašem systému nainstalován QuickTime verze 4 nebo pozdější,
můžete importovat navíc ještě tyto další formáty zvukových souborů:

� Zvuk Designer II (pouze Macintosh)

� Zvuky animací QuickTime (Windows nebo Macintosh)

� Sun AU (Windows i Macintosh)

� Zvuky Systému 7 (pouze Macintosh)

� WAV (Windows nebo Macintosh)
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4. Pro Compression (Komprimacii) vyberte jednu z následujících voleb:

� Zvolte Photo (Fotografická) pro komprimaci obrázku do formátu JPEG.
Pro použití původní kvality komprimace určené pro daný obrázek vyberte
Use Document Default Quality (Použít implicitní kvalitu dokumentu). Pro
specifikaci nového nastavení komprimace, odznačte Použít implicitní kvalitu
dokumentu a zadejte hodnotu mezi 1 a 100 v textovém okně Kvalita. (Vyšší 
nastavení zachová větší integritu obrázku, ale umožní menší zmenšení
velikosti souboru.)

� Zvolte Lossles (Bezeztrátová) (PNG/GIF) pro komprimaci obrázku bezeztrátovou
komprimací, ve které nejsou z obrázku vymazána žádná data.

Poznámka: Pro obrázky se složitou barvou nebo tónovou variací, jako jsou fotografie
nebo obrázky s gradientními výplněmi, použijte Fotografickou komprimaci.
Bezeztrátovou komprimaci použijte pro obrázky s jednoduchými tvary a relativně
malým počtem barev.

5. Pro určení výsledků komprimace klikněte na Test. Abyste zjistili, zda nastavení
komprimace vyhovují, porovnejte původní velikost souboru a velikost 
komprimovaného souboru.

6. Klikněte na tlačítko OK.

Poznámka: Nastavení kvality JPEG, které vyberete v dialogovém okně Publish
Settings (Nastavení publikace) neurčují kvalitu nastavení pro importované JPEG
soubory. Nastavení kvality pro importované JPEG soubory musíte určit v dialogovém
okně Vlastnosti bitmapy.
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Přidávání zvuku do animace

Abyste přidali zvuk do animace, přiřa�te zvuk k vrstvě a nastavte možnosti v panelu
Zvuku. Doporučujeme, abyste každý zvuk umístili do vlastní vrstvy.

Pro přidání zvuku k animaci:

1. Pokud zvuk ještě není importován, importujte ho. Viz „Importování zvuku“.

2. Zvolte Insert > Layer (Vrstva) a vytvoříte vrstvu pro zvuk.
3. S označenou novou zvukovou vrstvou přetáhněte zvuk z knihovny na Plochu.

Zvuk je přidán do aktuální vrstvy. Můžete umístit několik zvuků na jednu vrstvu 
nebo vrstvu obsahující jiné objekty. Nicméně je doporučováno, aby každý
zvukový kanál. Když přehráváte animaci, jsou kombinovány zvuky na všech
vrstvách.

4. Zvolte Window > Panels > Sound.

5. Ve Zvukovém panelu vyberte z kontextové nabídky Zvuku zvukový soubor.

6. Z kontextové nabídky Effects (Efekty) vyberte možnost efektu:

� None (Žádný) neaplikuje na zvukový soubor žádný efekt. Tuto volbu
zvolte k odstranění efektů aplikovaných dříve.

� Left Channel/Right Channel (Levý kanál/Pravý kanál) přehrává zvuk pouze 
v levém nebo pravém kanálu.

� Fade Left to Right/Fade Right to Left (Ustupovat zleva doprava/Ustupovat
zprava doleva) přesouvá zvuk z jednoho kanálu do druhého.

� Fade In (Postupně zesilovat) zvětšuje zvukovou amplitudu během doby
přehrávání.
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Flash zvuky ukládá v knihovně společně s bitmapami a symboly. Stejně jako u grafických
symbolů potřebujete pouze jednu kopii zvukového souboru a ta může být ve vaší animaci
použita mnoha způsoby. Pokud chcete zvukové soubory mezi animacemi sdílet,
můžete zvuky vkládat do sdílených knihoven. Viz „Používání sdílených knihoven“.
Abyste mohli zvuky ve sdílených knihovnách použít, přiřa�te v dialogovém okně
Symbol Linkage Properties (Vlastnosti vazby symbolu) zvukovému souboru iden-
tifikační řetězec Identifikátor může být použit i k přístupu ke zvuku jako objektu
v ActionScript, viz Referenční příručka k ActionScript.

Zvuky mohou využívat značné množství diskového prostoru a paměti RAM. Nicméně
zvuková data formátu MP3 jsou zkomprimována a menší než zvuková data WAV nebo
AIFF. Pokud používáte soubory WAV nebo AIFF, je obecně nejlepší používat 16-bitové
22 kHz mono zvuky (stereo používá dvakrát větší množství dat než mono), avšak
Flash umí importovat i 8 nebo 16-bitové zvuky ve vzorkové rychlosti 11, 22 nebo 44 kHz.
Při exportu Flash umí zvuky konvertovat do nižší vzorkové rychlosti. Viz „Komprimování
zvuků pro export“.

Poznámka: Zvuky nahrány ve formátech, které nejsou násobky 11 kHz (např. 8,32
nebo 96 kHz) jsou při importování do Flashe převzorkovány.

Pokud chcete ke zvukům ve Flashi přidávat efekty, je nejlepší importovat 16-bitové
zvuky. Pokud jste omezení množstvím paměti RAM, udržujte vaše zvukové klipy
krátké nebo pracujte s 8-bitovými místo 16-bitovými zvuky.

K importování zvuku:

1. Vyberte File > Import.

2. V dialogovém okně Import najděte a otevřete požadovaný zvukový soubor.

� Importovaný zvuk je umístěn do knihovny aktuální animace.

Poznámka: zvuk můžete také přetáhnout ze společné knihovny do knihovny aktuální
animace. Viz „Práce se společnými knihovnami“.
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Přidávání zvuku k tlačítkům

Zvuk můžete přiřadit k různým stavům symbolu tlačítka. Protože jsou zvuky uloženy
se symbolem, fungují pro všechny výskyty symbolu.

K přidání zvuku k tlačítku:

1. Vyberte tlačítko v knihovně

2. Vyberte Edit (Úpravy) z nabídky Options (Možnosti) knihovny

3. V Časové ose tlačítka přidejte vrstvu pro zvuk.

4. Ve vrstvě zvuku vytvořte obvyklý nebo prázdný klíčový snímek tak, aby souhlasil
se stavem tlačítka, ke kterému chcete zvuk přidat.

� Například k přidání zvuku, který hraje když někdo na tlačítko klikne, vytvořte
klíčový snímek ve snímku nazvaném Down (Dolů).

5. Klikněte na snímek, který jste právě vytvořili.

6. Vyberte Window > Panels > Sound.

7. Ve Sound (Zvukovém) panelu vyberte z kontextové nabídky Zvuku zvukový
soubor.

8. Z kontextové nabídky Synchronization (Zvuk) vyberte Event (Událost).

K přiřazení různého zvuku ke každému klíčovému snímku tlačítka vytvořte prázdný
klíčový snímek a přidejte další zvukový soubor ke každému klíčovému snímku.
Můžete taky pro každý klíčový snímek použít stejný soubor a aplikovat různé efekty.
Viz „Používání ovládání pro úpravu zvuku“.

Používání zvuků se sdílenými knihovnami nebo
Zvukovými objekty

Z jedné knihovny můžete zvuk spojit s několika Flash animacemi tak, že přiřadíte
vlastnosti vazby k zvuku a zvuk zahrnete do sdílené knihovny. Pro více informací
k používání sdílených knihoven se podívejte na „Používání sdílených knihoven“.

Abyste přidali zvuky k animaci a abyste ovládali zvuky v animaci, můžete použít
Zvukový objekt v ActionScript. Ovládání zvuků zahrnuje nastavení hlasitosti nebo
pravé a levé balance během přehrávání. Viz „Tvorba ovládání zvuku“ v kapitole
uživatelské příručky k ActionScript.

K používání zvuku ve sdílené knihovně nebo Soun Actions (Zvukové akci) přiřa�te
identifikační řetězec ke zvuku v dialogovém okně Symbol Linkage (Vazby symbolu).

148 Uživatelská příručka - FLASH 5

� Fade Out (Postupně zeslabovat) snižuje zvukovou amplitudu během doby
přehrávání.

� Custom (Vlastní) vám s pomocí Editoru umožní vytvořit vaše vlastní In (Počáteční)
a Out (Koncové) body zvuku. Viz „Používání ovládání pro úpravu zvuku“.

7. Vyberte synchronizační volbu z kontextové nabídky Sync (synchronizace):

� Event (Událost) synchronizuje zvuk podle výskytu události. Zvuk k události 
hraje když je poprvé zobrazen jeho klíčový snímek a hraje v celém svém 
rozsahu nezávisle na časové ose, kromě případu, že se animace zastaví.
Zvuky k události jsou mixovány když přehráváte vaši publikovanou animaci.
Příklad zvuku k události je zvuk který hraje, když uživatel klikne na tlačítko.

� Start je to stejné jako Event (Událost); kromě případu, že zvuk už hraje -  v tom
případě začne nová instance zvuku.

� Stop ztiší určený zvuk.

� Streamovat synchronizuje zvuk pro přehrávání na Web stránce. Flash animaci 
donutí, aby udržovala tempo se zvukem. Pokud Flash nemůže animaci 
vykreslovat dost rychle, přeskakuje snímky. Na rozdíl od zvuku k události, 
streamované zvuky skončí, pokud skončí animace. Streamovaný zvuk
zároveň nikdy nemůže hrát déle než je délka snímků, které obsazuje.
Streamované zvuky jsou mixovány, když vaší animaci publikujete. Příkladem
streamovaného zvuku v animaci je hlas postavy, který se přehrává v několika
snímcích.

Poznámka: pokud jako streamovaný zvuk používáte zvuk ve formátu MP3, musíte pro
export zvuk znovu zkomprimovat. Viz „Komprimování zvuků pro export“.

8. Zadejte hodnotu Loop (Smyčky), abyste určili kolikrát by se měl zvuk opakovat.
Pro nepřetržité přehrávání zadejte číslo dost vysoké k tomu, aby přehrávání déle
trvalo. Například k přehrání 15-sekundového zvuku po dobu 15 minut, zadejte 60.

Poznámka: Není doporučováno opakovat streamovaný zvuk. Pokud je nastaven
do smyčky, jsou do animace přidány snímky a velikost souboru se zvětší o tolik,
kolikrát je zvuk opakován.
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� Pro změnu zvukového okna přetáhněte zarážky okna a změníte úrovně v různých 
bodech zvuku. Hranice okna ukazuje hlasitost zvuku během přehrávání.
K vytvoření dalších zarážek (nejvýše však osmi), klikněte na hranici okna.
K jejich odstranění je přetáhněte z okna pryč.

� Pro zobrazení méně nebo více zvuku v okně klikněte na tlačítka Zoom In/Out 
(Přiblížit/Oddálit).

� K přepnutí časových jednotek mezi vteřinami a snímky klikněte na tlačítka
Seconds a Frames.

Spouštění a zastavování zvuků ve snímcích

� Nejvíce známých úloh ve Flashi, které se vztahují ke zvuku, je spouštění
a zastavování zvuků v klíčových snímcích tak, aby zvuk byl synchronizovaný 
s obrazem.

K spuštění a zastavení zvuku v klíčovém snímku:

1. Přidejte zvuk k animaci.

� K synchronizování tohoto zvuku s události na scéně vyberte počáteční
klíčový snímek, který koresponduje s klíčovým snímkem události na scéně.
Můžete zvolit jakoukoli synchronizační volbu. Viz „Přidávání zvuku k animaci“.

2. Ve snímku, kde chcete, aby zvuk končil, vytvořte klíčový snímek ve zvukové
vrstvě Časové osy. V Časové ose se objeví zastoupení zvukového souboru.

3. Vyberte window > Panels > Sound.

4. Z kontextové nabídky Zvuku vyberte ten stejný zvuk

5. Z kontextové nabídky synchronizace vyberte Stop (Zastavit). 

� Když animaci přehráváte, zastaví se přehrávání zvuku, když dosáhne koncového
klíčového snímku. K opětovnému přehrání zvuku jednoduše posuňte ukazatelem
přehrávání.

Komprimování zvuku pro export

K vybrání volby komprimace zvuku můžete použít volby v oblasti Export Settings
(Nastavení exportu) dialogového okna Sound Properties (Vlastnosti zvuku). Dostupné
volby závisí na vámi zvolené komprimační metodě. Dialogové okno Vlastnosti Zvuku
můžete také použít k aktualizaci zvuků, které jste upravili v externím zvukovém editoru
nebo k testování zvuku.
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K přiřazení identifikačního řetězce ke zvuku:

1. Vyberte zvuk v okně Knihovny

2. Prove�te jedno z následujících:

� Zvolte Linkage (Vazba) z nabídky Volby knihovny

� Klikněte pravým tlačítkem myši (Windows) nebo klikněte a držte stisknutou
klávesu Control (Macintosh) na název zvuku v okně knihovny a z kontextové
nabídky vyberte Vazba.

3. Pod Linkage (Vazbou) v dialogovém okně Symbol Linkage Properties 
(Vlastnosti vazby symbolu) vyberte Export This Symbol (Exportovat tento symbol).

4. Do textového pole zadejte identifikační řetězec a klikněte na tlačítko OK.

Používání kontroly úpravy zvuku

K definování počátečního bodu zvuku nebo k ovládání hlasitosti zvuku během
přehrávání použijte kontrolu úpravy zvuku ze Zvukového panelu. Flash umožňuje
změnit bod, ve kterém se zvuk začíná a ukončuje přehrávat. To je užitečné pro
zmenšení zvukových souborů tím, že odeberete nepoužité oblasti. 

Úprava zvukového souboru:

1. Přidejte zvuk do snímku (viz „Přidávání zvuků do animace“) nebo vyberte
snímek, který už zvuk obsahuje

2. Vyberte Window > Panels > Sound a klikněte na Edit (Úpravy).

3. Prove�te jedno z následujících:

� Ke změně počátečních a koncových bodů zvuku přetáhněte ukazatele Time In
(Začátek) a Time Out (Konec) ve Zvukovém panelu.
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2. Pokud byl zvukový soubor upravován externě, klikněte na Update (Aktualizovat).

3. Z komprimace zvolte Default, ADPCM, MP3 nebo Raw (Hrubá). Pro vybrání 
možností pro formát komprimace, kterou jste si zvolili se podívejte do následující 
části odpovídající vybranému formátu.

4. Nastavte možnosti exportu (export settings).

5. Klikněte na Test, abyste si zvuk přehráli a na Stop, abyste ho zastavili.

6. Pokud je to nezbytné, přizpůsobujte nastavení exportu, dokud nedosáhnete
požadované kvality zvuku.

7. Klikněte na tlačítko OK.

� Volba Implicitní komprimace 

� Volba Default (Implicitní) komprimace používá implicitní nastavení komprimace
z dialogového okna Publish Settings (Nastavení pro publikaci) při exportování
vaší animace. Pokud vyberete Implicitní, žádné další nastavení exportu 
nejsou dostupná.

Používání volby ADCMP komprimace

Volba ADCMP komprimace nastavuje kompresi pro 8-bitová nebo 16-bitová zvuková data.
Použijte nastavení ADCMP, když exportujete krátké zvuky pro událost, např. kliknutí
na tlačítko.

K použití ADCMP komprimace:

1. V dialogovém okně Sound Properties (Vlastnosti zvuku) zvolte z nabídky 
Komprimace ADCMP.

2. Pro Preprocessing (Předzpracování) vyberte Convert Stereo to Mono 
ke zkonvertování mixovaných stereo zvuků na mono (jednodušší). (Mono 
zvuky jsou touto volbou nezměněny.)

3. Pro Sample Rate (Vzorkovou míru) vyberte takovou volbu, abyste mohli  řídit 
přesnost zvuku a velikost souboru. Nižší rychlosti snižují velikost souboru,
ale mohou také znehodnotit kvalitu zvuku. Volby míry jsou následující:

� 5 kHz je ztěží přijatelná pro řeč

� 11 kHz je nejnižší doporučovaná kvalita krátký úsek hudby a je to čtvrtinová
míra standardu CD.

� 22 kHz je populární volba pro přehrávání na internetu je to polovina míry
standardu CD.

� 44 kHz je míra CD standardu.
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Vzorková míra a stupeň komprese mají za následek významný rozdíl v kvalitě a velikosti
zvuků v exportovaných animacích. Čím je větší komprese zvuku a menší vzorková
rychlost, tím je menší velikost a nižší kvalita. Měli byste experimentovat, abyste našli
optimální rovnováhu mezi kvalitou zvuku a velikostí souboru. Soubory formátu MP3
jsou zkomprimovány už při importu. Nicméně pokud potřebujete, můžete je znovu
zkomprimovat. Například pokud bude soubor MP3 použit jako streamovaný zvuk,
musíte jej znovu zkomprimovat, protože streamované zvuky musí být pro export
komprimovány.

Pokud pro zvuk nejsou žádná nastavení definována, exportuje ho Flash s použitím
nastavení v Publish Settings (Nastavení pro publikaci). Nastavení exportu určené
v dialogovém okně Sound Properties (Vlastnosti zvuku) můžete přepsat vybráním
Override Sound Settings (Nastavení přepisu zvuku) v dialogovém okně Nastavení pro
publikaci. Tato volba je užitečná, pokud chcete vytvořit vysoce přesnou zvukovou animaci
pro místní použití a menší málo přesnou verzi pro internet. (Viz „Publikování animace
pro Flash přehrávač“.)

Poznámka: Ve Windows můžete všechny zvuky exportovat také jako soubory WAV
pomocí File  > Export Movie. Viz „Exportování animací a obrázků“.

K nastavení vlastností exportu pro jednotlivý zvuk:

1. Prove�te jedno z následujících:

� Dvakrát klikněte na ikonu zvuku v okně Knihovny.

� Klikněte pravým tlačítkem myši (Windows) nebo klikněte a držte stisknutou
klávesu Control (Macintosh) na zvukový soubor v okně Knihovny a z kontextové 
nabídky vyberte Properties (Vlastnosti).

� V okně Knihovny vyberte zvuk a z nabídky Options (Volby) knihovny zvolte 
Properties (Vlastnosti).

� V okně Knihovny vyberte zvuk a v její spodní části klikněte na ikonu vlastnosti.
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Používání volby Hrubá komprimace

Volba Raw (Hrubá) komprimace exportuje zvuk bez komprese.

K použití Hrubé komprimace:

1. V dialogovém okně Vlastností zvuku vyberte z nabídky Komprese Raw (Hrubá).

2. Pro Preprocessing (Předzpracování) vyberte Convert Stereo to Mono 
ke zkonvertování mixovaných stereo zvuků na mono (jednodušší). (Mono 
zvuky jsou touto volbou nezměněny.)

3. Pro Sample Rate (vzorkovou míru) vyberte takovou volbu, abyste mohli  řídit
přesnost zvuku a velikost souboru. Nižší rychlosti snižují velikost souboru,
ale mohou také znehodnotit kvalitu zvuku. Volby míry jsou následující:

� 5 kHz je ztěží přijatelná pro řeč

� 11 kHz je nejnižší doporučovaná kvalita krátký úsek hudby a je to čtvrtinová
míra standardu CD.

� 22 kHz je populární volba pro přehrávání na internetu je to polovina míry 
standardu CD.

� 44 kHz je míra CD standardu.

Poznámka: Flash nedokáže zvýšit kHz míru importovaného souboru nad míru, s kterou
byl importován.

Návod pro exportování zvuku ve Flash animacích

Stranou vzorkové míry a komprese existuje několik způsobů, jak použít v animaci
zvuk účinně a udržet nízkou velikost souboru.

� Nastavit počáteční a konečné body k tomu, aby nebyly do souboru 
Shockwave Flash ukládána prázdná místa a snížit velikost zvuku.

� Mít větší užitek ze stejných zvuků aplikováním různých efektů (jako úroveň
hlasitosti, opakování a počáteční/koncové body) v různých klíčových snímcích.
Použitím pouze jednoho zvukového souboru můžete dostat plno zvukových 
efektů.

� Použijte smyčku k vyjmutí nejobvyklejší části zvuku a přehrávejte ji opakovaně.
Pro hudbu hrající v pozadí použijte opakující se krátký zvuk.

� Nenastavujte smyčku pro streamovaný zvuk.
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Poznámka: Flash nedokáže zvýšit kHz míru importovaného souboru nad míru, s kterou
byl importován.

Používání volby MP3 komprimace

Volba komprimace MP3 vám umožní exportovat zvuky s MP3 kompresí. Použijte MP3,
když exportujete delší streamované zvuky, např hudební skladby.

K použití MP3 komprimace:

1. V dialogovém okně Vlastnosti zvuku vyberte MP3 z nabídky Komprimace.

2. Pro Bit Rate (Míru v bitech) vyberte možnost k určení maximální rychlosti
zvuku v bitech tvořené enkodérem MP3. Flash podporuje od 8 kbps (kilobitů
za sekundu) do 160 kbps CBR (konstantní bitová míra). Pokud exportujete
hudbu, pro nejlepší výsledky nastavte míru v bitech na 16 Kbps nebo vyšší.

3. Pro Preprocessing (Předzpracování) vyberte Convert Stereo to Mono 
ke zkonvertování mixovaných stereo zvuků na mono (jednodušší). (Mono 
zvuky jsou touto volbou nezměněny.)

Poznámka: volba Předzpracování je dostupná pouze pokud vyberete míru v bitech 20
Kbps nebo větší.

4. Pro Quality (Kvalitu) vyberte volbu k určení komprimační rychlosti a kvality zvuku:

� Fast (Rychlá) přináší rychlejší komprimaci, ale nižší kvalita zvuku.

� Medium (Střední) přináší o něco pomalejší komprimaci, ale vyšší kvalitu zvuku.

� Slow (Pomalá) přináší nejpomalejší komprimaci s nejvyšší kvalitou zvuku.
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KAPITOLA 7

Práce s objekty

Ve Flashi jsou objekty položkami na Ploše. Flash vám umožní objekty pohybovat,
kopírovat je, mazat, transformovat, vrstvit, seřazovat a seskupovat je. Objekt můžete
také odkázat na URL. Nezapomeňte, že změna čar a tvarů může změnit jiné čáry a tvary
na stejné vrstvě. Viz kapitola 3, Kreslení.

Poznámka: Termín objekt je použit v programovacím jazyku ActionScript v jiném významu.
Dejte si pozor, abyste nepletli tyto dva způsoby použití tohoto výrazu. Pro více objektů
v programovacím jazyce se obraVte na Referenční příručku ActionScript.

Výběr objektů

Pokud chcete objekt měnit, musíte jej nejprve vybrat. Flash poskytuje různé metody
pro provedení výběru, včetně nástroje Šipka, nástroje Laso a klávesových příkazů.
Jednotlivé objekty můžete seskupovat, abyste s nimi zacházeli jako s jedním objektem.
Viz "Seskupování objektů".

Flash zvýrazní objekty, které byly vybrány. Čary jsou zvýrazněny barevnou čarou.
Výplně jsou zvýrazněny tečkovaným vzorem. Vybrané skupiny jsou zvýrazněny
ohraničujícími rámy.

Čáry a výplně jsou zvýrazněny barvou použitou na okraj vrstvy, které obsahuje
vybrané objekty. Barvu okraje můžete měnit v dialogovém okně Vlastnosti vrstvy.
Viz "Náhled na vrstvy".

Můžete si zvolit výběr pouze čar nebo pouze výplní objektu. Můžete skrýt zvýraznění
výběru za účelem úpravy objektů, abyste neviděli zvýraznění. Možná budete chtít
zabránit tomu, aby byla skupina symbolů omylem vybrána a změněna. To můžete
udělat zamknutím skupiny nebo symbolu.

Vybrané bitmapy a symboly jsou zvýrazněny tečkovaným vzorem. Viz kapitola 5,
"Používání importovaných výtvorů".
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Návod pro exportování zvuku v QuickTime animacích

Animace, které exportujete jako soubory QuickTime používají zvuk jinak než ho používají
animace Shockwave Flash. Návod pro exportování zvuku s QuickTime animacemi
zahrnuje následující:

� Používejte tak mnoho zvuků a kanálů, kolik  chcete, aniž byste měli strach o
velikost souboru. Zvuky jsou kombinovány do jednoduché stopy, kterou
exportujete jako QuickTime soubor. Počet zvuků, které používáte nemá 
žádný efekt na konečnou velikost souboru.

� Když animaci v editoru prohlížíte, použijte synchronizaci streamování, abyste
animaci udrželi synchronizovanou s vaší zvukovou stopou. Pokud váš počítač
není dostatečně rychlý na to, aby vykresloval snímky animace tak, aby držely
krok s vaší zvukovou stopou, Flash snímky přeskakuje.

KAPITOLA 6 - Správa sítě 155



Odznačení všeho ve všech vrstvách:

� Zvolte Edit > Deselect All (Odznačit vše) nebo zmáčkněte Control+Shift+S
(ve Windows) nebo Command+Shift+S (na Macintoshi).

Označení všeho v jedné vrstvě mezi klíčovými snímky:

� Klikněte na snímek v Časové ose. Více informací viz "Používání Časové osy".

Zamknutí skupiny nebo symbolu:

� Vyberte skupinu nebo symbol a zvolte Modify > Arrage (Uspořádat) > Lock 
(Zamknout).
Pro odemknutí všech zamknutých skupin a symbolů zvolte Modify > Arrange
(Uspořádat) > Unlock All (Odemknout vše).

Používání nástroje Laso

Pro vybrání objektů nakreslením výběrové oblasti od ruky nebo pomocí rovných okrajů
můžete použít nástroj Laso a jeho měnič Polygonální režim. Při používání nástroje
Laso můžete přepínat mezi výběrovými režimy s rovnými a nestandardními okraji.

Výběr objektů kreslením výběrové oblasti od ruky:

Zvolte nástroj Laso a obtáhněte jej kolem oblasti. Smyčku ukončete přibližně tam,
kde jste ji začali, nebo nechejte Flash smyčku automaticky uzavřít rovnou čarou.
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Používání nástroje Šipka

Nástroj Arrow (Šipka) vám umožní vybírat celé objekty kliknutím na objekt nebo jeho
přetáhnutím a uzavřením do obdélníkového výběru.

Poznámka: Pro výběr nástroje Šipka můžete také zmáčknout klávesu V. Pro dočasné
přepnutí do nástroje Šipka, když je aktivní jiný nástroj, podržte klávesu Control
(ve Windows) nebo Command (na Macintoshi).

Výběr čáry, výplně, skupiny, instance nebo bloku textu:

� Zvolte nástroj Arrow (Šipka) a klikněte na objekt.

Výběr spojených čar:

� Vyberte nástroj Šipka a dvakrát klikněte na jednu z čar.

Výběr vyplněného tvaru a jeho okraje:

� Vyberte nástroj Šipka a dvakrát klikněte na výplň.

Výběr objektů v rámci obdélníkové plochy:

� Zvolte nástroj Šipka a roztáhněte kraj okolo objektu nebo objektů, které chcete
vybrat. Instance, skupiny a bloky písmen musí být úplně uzavřeny, aby mohly
být vybrány.

Změna výběrů

Můžete přidávat k výběrům, označovat nebo odznačovat všechno na každé vrstvě
na scéně, označovat všechno mezi klíčovými snímky nebo zamykat a odemykat
vybrané symboly a skupiny.

Přidání k výběru:

� Držte klávesu Shift při provádění dalších výběrů.

Poznámka: Pro odstranění volby vybírat pomocí klávesy Shift, odznačte volbu v Obecných
preferencích Flash. Viz "Preference Flash".

Označení všeho ve všech vrstvách scény:

� Zvolte Edit > Select All (Vybrat vše) nebo zmáčkněte Control+A (ve Windows)
nebo Command+A (na Macintoshi). Vybrat vše nevybere objekty v zamčených 
nebo skrytých vrstvách nebo vrstvách, které nejsou na aktuální Časové ose.
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Seskupování objektů

Pro zacházení s prvky jako s jedním objektem je potřebujete seskupit.  Například
po vytvoření kresby jako je strom nebo květina, můžete seskupit prvky kresby tak,
že může být lehce vybrána a přemísGována jako celek.

Skupiny můžete upravovat, aniž byste je museli rozdělit. Můžete pro úpravy také
vybrat jeden prvek ze skupiny, bez nutnosti rozdělit objekty.

Vytvoření skupiny:

1. Vyberte objekty na Ploše, které chcete seskupit.

� Můžete vybírat tvary, další skupiny, symboly, texty a tak dále.

2. Zvolte Modify > Group (Seskupit) nebo zmáčkněte Control+G (ve Windows)
nebo Command+G (na Macintoshi).

Oddělení objektů:

� Zvolte Modify > Ungroup (Oddělit).

Úprava skupiny nebo objektu ve skupině:

1. Mějte označenu skupinu, zvolte Edit > Edit Selected (Upravit označené)
nebo dvakrát klikněte na skupinu nástrojem Šipka.

� Všechno na stránce, co není součástí skupiny, je ztlumeno, což znamená,
že to není zpřístupněno.

2. Upravte jakýkoliv prvek ve skupině.

3. Zvolte Edit > Edit All (Upravit vše) nebo dvakrát klikněte na volné místo na Ploše
nástrojem Šipka.

� Flash obnoví status skupiny jako jednoho objektu a můžete pracovat s dalšími
prvky na Ploše.

Pohyb, kopírování a mazání objektů

Objekty můžete pohybovat jejich táhnutím po Ploše, kopírováním a vkládáním,
použitím nástroje Šipka nebo použitím Panelu objektů pro určení jejich přesného
umístění. Můžete také objekty přemisGovat mezi Flashem a jinými aplikacemi pomocí
Schránky. Objekty můžete kopírovat přetahováním nebo vkládáním nebo při jejich
přeměně.

Při přesunu objektu pomocí nástroje Šipka můžete použít měnič Snap pro nástroj
Šipka pro rychlé zarovnání objektu s body nebo jinými objekty.

160 Uživatelská příručka - FLASH 5

Výběr objektů kreslením výběrové oblasti s rovnými okraji:

1. Zvolte nástroj Laso a vyberte měnič Polygon Mode (Polygonální režim) v sekci
Options (Volby) v panelu nástrojů.

2. Klikněte pro nastavení výchozího bodu.

3. Umístěte ukazatel do bodu, ve kterém chcete ukončit první čáru, a klikněte. 
Pokračujte určováním bodů pro další úseky čar.

4. Pro uzavření výběrové oblasti dvakrát klikněte.

Výběr objektů kreslením výběrových oblastí s volnými i rovnými okraji:

1. Zvolte nástroj Laso a odznačte měnič Polygon Mode (Polygonový režim).

2. Pro nakreslení úseku od ruky táhněte myší po Ploše.

3. Pro nakreslení úseku s rovným okrajem podržte klávesu Alt (ve Windows)
nebo Volba (na Macintosthi) a klikněte pro nastavení výchozích a koncových
bodů. Můžete pokračovat přepínáním mezi kreslením volných a rovných úseků.

4. Pro uzavření výběrové oblasti proveLte jedno z následujících:

� Pokud kreslíte volný úsek, pusGte tlačítko myši.

� Pokud kreslíte rovný úsek, dvakrát klikněte.

Skrytí zvýraznění výběru

Abyste mohli upravovat objekty bez toho, aby bylo vidět jejich zvýraznění, můžete
zvýraznění výběru skrýt. Toto skrytí vám umožní sledovat, jak bude váš výtvor vypadat
ve svém konečném stadiu, zatímco vybíráte a upravujete objekty.

Skrytí zvýraznění výběru:

� Zvolte View > Hide Edges (Skrýt okraje). Pro odznačení této vlastnosti
použijte tento příkaz znovu.
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Přesun a kopírování objektů vkládáním

Jestliže potřebujete přesunout nebo zkopírovat objekty mezi vrstvami, scénami nebo
jinými soubory Flash, měli byste použít vkládací techniku. Objekt můžete vkládat
doprostřed Plochy nebo na stejné místo jako byly původní pozice.

Přesun a kopírování objektů vkládáním:

1. Zvolte objekt nebo více objektů.

2. Vyberte Edit > Cut (Vyjmout) nebo Edit > Copy (Kopírovat).

3. Zvolte jinou vrstvu, scénu nebo soubor a proveLte jedno z následujících:

� Vyberte Edit > Paste (Vložit) pro vložení výběru do středu Plochy.

� Vyberte Edit  > Paste in Place (Vložit do místa) pro vložení výběru do stejné
pozice jako byla původní pozice objektu na Ploše.

O kopírování výtvorů pomocí Schránky

Prvky kopírované do Schránky mají potlačeno roztřepení čar, takže v ostatních
aplikacích vypadají stejně dobře jako ve Flashi. To je obzvlášG užitečné pro snímky,
které obsahují bitmapový obrázek, gradienty, průhlednost nebo vrstvu masky.

Grafika vkládaná z jiných animací nebo programů je umístěna do aktuálního snímku
nebo aktuální vrstvy. To, jak je grafický prvek vložen na Flash scénu  závisí na typu
prvku, jeho zdroji a preferencích, které jste nastavili:

� Text z textového editoru se stává jednoduchým textovým objektem.

� Grafika založená na vektorech z jakéhokoliv kreslícího programu se stává
skupinou, která může být oddělována a upravována jako jakýkoliv prvek Flash.

� Bitmapy se stávají jednoduchým seskupeným objektem, stejně jako importované
bitmapy. Vkládané bitmapy můžete rozdělovat nebo konvertovat do vektorové
grafiky.

� Pro informace o konverzi bitmap do vektorové grafiky viz "Konverze bitmap 
do vektorové grafiky".

Poznámka: Před vkládáním grafiky z FreeHand do Flash nastavte preference exportu
do FreeHand pro konverzi barev do CMYK a RGB formátů Schránky.
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Přesun objektů

Pokud chcete přesunout objekty, můžete objekt táhnout myší, použít nástroj Šipka
nebo použít Info panel.

Přesun objektů nebo kopií objektů táhnutím myši:

1. Zvolte objekt nebo více objektů.

2. Zvolte nástroj Šipka, umístěte kurzor myši na objekt a táhněte jím do nové
pozice. Pro kopírování objektu a přesun kopie podržte klávesu Alt (ve Windows)
nebo Option (na Macintoshi)  a táhněte myší. Pro posun objektu o 45°
držteShift a táhněte myší.

Přesun objektů pomocí šipek:

1. Zvolte objekt nebo více objektů.

2. Zmáčkněte šipku ve směru, kterým chcete objekt přesunout pro posun o 1 bod.
Zmáčkněte Shift a šipku pro posun výběru o 8 bodů.

Přesun objektů použitím Informačního panelu:

1. Zvolte objekt nebo více objektů.

2. Vyberte Window > Panels > Info.

3. V Informačním panelu zadejte hodnoty pro umístění levého horního rohu
výběru. Jednotky jsou relativní k levému horním rohu Plochy.

Poznámka: Informační panel používá jednotky zvolené ve volbě Ruler Units (Jednotky
pravítka) v dialogovém okně Movie Properties (Vlastnosti animace). Změna těchto
jednotek viz "Vytváření nové animace a nastavování jejích vlastností".
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Vrstvení objektů

V rámci vrstvy Flash vrství objekty v pořadí, v němž byly vytvořeny, nejnověji vytvořený
objekt umístí na vrch vrstvy. Pořadí navrstvených objektů určí, jak budou při překrývání
vypadat.

Nakreslené čáry a tvary se vždy objeví pod navrstvenými skupinami a symboly. Pro jejich
přemístění na vrch vrstvy je musíte seskupit nebo přeměnit na symboly. Kdykoliv
můžete změnit pořadí navrstvení objektů.

Nezapomeňte, že vrstvy také ovlivňují pořadí navrstvení. Všechno na Vrstvě 2 se objeví
nad vším ve Vrstvě 1 a tak dále. Pro změnu pořadí vrstev přetáhněte jméno vrstvy
v Časové ose do jiné pozice. Viz kapitola 8 "Používání vrstev".

Změna pořadí navrstvení objektů:

1. Zvolte objekt.

2. Použijte jeden z následujících příkazů:

� Zvolte Modify > Arrange > Bring to Front (Přenést na začátek) nebo
Send to Back (Poslat zpět) pro posun objektu nebo skupiny do horní
nebo spodní části vrstvícího pořádku.

� Zvolte Modify > Arrange > Bring Forward (Přenést dopředu) nebo Send
Backward (Poslat dozadu) pro přesun objektu nebo skupiny o jednu pozici
nahoru nebo dolů v pořadí vrstvení.

� Jestliže je označena více než jedna skupina, pohybují se skupiny v popředí
nebo pozadí všech neoznačených skupin, zatímco je zachováno jejich 
vzájemné pořadí.
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Kopírování upravených objektů

Pro vytvoření kopie objektu, která má jinou velikost, je otočená nebo zešikmená,
můžete použít Transformační panel.

Vytvoření transformované kopie objektu:

1. Zvolte objekt.

2. Vyberte Window > Panels  > Transform.

3. Zadejte hodnoty změny velikosti, otočení nebo zešikmení. Viz "Změna 
velikosti objektů", "Otáčení objekty" a "Zešikmení objektů".

4. Klikněte na tlačítko Create Copy (Vytvořit kopii) na Transformačním panelu 
(levé tlačítko v pravém dolním rohu panelu).

Mazání objektů

Mazání odstraní objekt ze souboru. Vymazání instance na Ploše nevymaže symbol
z knihovny.

Vymazání objektu:

1. Zvolte objekt nebo více objektů.

2. ProveLte jedno z následujících:

� Zmáčkněte Delete nebo Backspace.

� Zvolte Edit > Clear (Vymazat).

� Vyberte Edit  > Cut (Vyjmout).

� Klikněte pravým tlačítkem myši (ve Windows) nebo držte Control a klikněte 
(na Macintoshi) na objekt a vyberte Cut (Vyjmout) z kontextového menu.
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Otáčení objekty

Otáčení objektem jej otočí kolem jeho registrovaného bodu. Implicitně je registrovaný
ve středu objektu, ale můžete jej posunout. Viz "Pohyb registrovaným bodem objektu".
Objektem můžete otáčet použitím příkazu Rotate táhnutím myši nebo zvolením úhlu
v Transformačním panelu.

Otočení objektu táhnutím myši:

1. Zvolte objekt.

2. ProveLte jedno z následujících:

� Vyberte nástroj Šipka a klikněte na měnič Rotate (Otočit) v sekci Volby
panelu nástrojů.

� Zvolte Modify > Transform > Rotate.

3. Táhněte za jednu z rohových úchytek.

4. Klikněte na prázdnou plochu na Ploše nebo zvolte Modify > Transform > Rotate
(Otočit) pro skrytí otáčecích úchytek.

Otočení objektu o 90°:

1. Zvolte objekt.

2. Vyberte Modify > Transform > Rotate 90° CW (Otočit o 90° ve směru hodinových
ručiček) nebo Rotate 90° CCW (Otočit o 90° proti směru hodinových ručiček). 

Otočení objektu pomocí Transformačního panelu:

1. Zvolte objekt.

2. Vyberte Window > Panels > Transform.

3. Klikněte na Rotate (Otočit).

4. Zadejte úhel otočení.

5. Zmáčkněte Enter (ve Windows) nebo Return (na Macintosh) pro aplikaci otočení.
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Změna velikosti objektů

Změna velikosti objektů zvětšuje nebo zmenšuje objekt horizontálně, vertikálně
nebo oběma směry. Velikost objektu můžete měnit přetáhnutím nebo zadáním hodnot
v Transformačním panelu. Instance, skupiny a bloky textu mění velikost ve vztahu
k registrovanému bodu. Viz "Pohyb registrovaným bodem objektu".

Změna velikosti objektu táhnutím myši:

1. Zvolte objekt.

2. Zvolte nástroj Šipka a klikněte na měnič Scale (Měřítko) v oblasti Volby panelu
nástrojů nebo zvolte Modify > Transform > Scale (Změnit velikost).

3. ProveLte jedno z následujících:

� Pro horizontální a zároveň vertikální změnu velikosti táhněte úchytkami v rozích.
Poměry jsou při změně velikosti zachovány

Pro změnu velikosti buL horizontálně nebo vertikálně táhněte za střední úchytku.

4. Klikněte na prázdnou oblast na Ploše nebo vyberte Modify > Transform > Scale
(Změnit velikost) pro skrytí úchytek pro změnu velikosti.

Poznámka: Když zvyšujete velikost většího počtu položek, ty, které jsou poblíž okrajů
hraniční oblasti mohou být přesunuty mimo Plochu. Pokud se tak stane, zvolte
View  > Work Area (Pracovní plocha), abyste viděli prvky za okraji Plochy.

Změna velikosti objektu pomocí Transformačního panelu:

1. Zvolte objekt.

2. Vyberte Window > Panels > Transform.

3. Zadejte hodnotu změnu velikosti od 1 do 1000 pro vertikální, horizontální
nebo obě změny.

4. Zvolte Constrain (Udržet poměr stran) pro zachování poměrů.

5. Zmáčkněte Enter (ve Windows) nebo Return (na Macintoshi).
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4. Klikněte na prázdnou plochu na Ploše nebo vyberte 
Modify > Transform >Rotate (Otočit) pro skrytí otáčecích úchytek.

Zešikmení objektu použitím Transformačního panelu:

1. Zvolte objekt.

2. Vyberte Window > Panels > Transform.

3. Klikněte na Skew (Zešikmit).

4. Zadejte úhly pro horizontální a vertikální hodnoty.

Obnovení transformovaných objektů

Když měníte velikost instancí, skupin a písmen a otáčíte s nimi a zešikmujete je pomocí
Transformačního panelu, Flash uloží původní hodnoty velikosti a otočení objektu.
Tak můžete odstraňovat naposledy aplikované transformace a vracet se k původním
hodnotám. Můžete také odstraňovat transformace použité v Transformačním panelu
kliknutím na tlačítko Undo (O krok zpět) v panelu.

Návrat transformovaného objektu k původnímu stavu:

1. Zvolte transformovaný objekt.

2. Vyberte Modify > Transform > Remove Transform (Odstranit transformaci).

Návrat o krok zpět v transformaci provedené v Transformačním panelu:

� Se stále označeným objektem klikněte na tlačítko Undo (O krok zpět) 
v Transformačním panelu (pravé tlačítko v pravé dolní části panelu).
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Otočení a změna velikosti objektu zároveň:

1. Zvolte objekt.

2. Vyberte Modify > Transform > Scale and Rotate (Změnit velikost a otočit).

3. Zadejte hodnoty pro Změnu velikosti a Otočení.

4. Klikněte na tlačítko OK.

Přetáčení objektů

Objekty můžete otáčet také podél horizontálních a vertikálních os bez změny jejich
relativní polohy na Ploše.

Přetočení objektu:

1. Zvolte objekt.

2. Vyberte Modify > Transform > Flip Horizontal (Přetočit horizontálně) nebo
Flip Vertical (Přetočit vertikálně).

Zešikmení objektů

Skewing (Zešikmení) objektů je transformace objektu zkosením podle jedné nebo obou
os. Objekty můžete zešikmovat táhnutím myši nebo zadáním hodnoty v Transformačním
panelu.

Zešikmení objektu táhnutím myši:

1. Zvolte objekt.

2. ProveLte jedno z následujících:

� Vyberte nástroj Šipka a klikněte na měnič Rotate (Otočit) v sekci Options
(Volby) panelu nástrojů.

� Vyberte Modify > Transform > Rotate (Otočit).

3. Táhněte myší za střední úchytku.
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Zarovnání objektu:

1. Zvolte objekty, které mají být zarovnány.

2. Vyberte Window > Panel > Align (Panel zarovnání).

3. V Panelu zarovnání označte To stage (K Ploše) pro použití zarovnacích změn
vzhledem k rozměrům plochy. 

4. Vyberte zarovnávací tlačítka pro změnu vybraných objektů:

� Pro Align (Zarovnat) vyberte Align Left (Zarovnat vlevo), Align Horizontal
Center (Zarovnat horizontálně na střed), Align Right (Zarovnat vpravo), Align Top
(Zarovnat nahoru), Align Vertical Center (zarovnat verikálně na střed) nebo
Align Bottom (Zarovnat dolů).

� Pro Distribute (Roztřídit) zvolte Distribute Top (Roztřídit nahoru), Distribute
Horizontal Center (Roztřídit horizontálně na střed), Distribute Bottom
(Roztřídit dolů), Distribute Left (Roztřídit doleva), Distribute Vertical Center 
(Roztřídit vertikálně na střed) nebo Distribute Right (Roztřídit doprava).

� Pro Match Size (Přizpůsobit velikosti) vyberte Match Width (Přizpůsobit šířce),
Match Height (Přizpůsobit výšce) nebo Match Height and Width (Přizpůsobit 
výšce  a šířce)

� Pro Space (Rozmístit) zvolte Space Horizontally (Rozmístit horizontálně)
nebo Space Vertically (Rozmístit vertikálně).
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Zarovnání objektů

Panel Align (Zarovnání) vám umožní zarovnat zvolené objekty podél horizontální nebo
vertikální osy. Objekty můžete zarovnat vertikálně podél pravého okraje, do středu
nebo podél dolního okraje  zvolených objektů. Okraje jsou určeny hraničními kraji
uzavírajícími každý zvolný objekt.

Použitím Panelu zarovnání můžete roztřídit vybrané objekty tak, že jejich středy nebo
okraje jsou rozmístěny rovnoměrně. U vybraných objektů můžete změnit velikost tak,
aby se horizontální nebo vertikální rozměry všech objektů shodovaly s největším
označeným objektem. Zvolené objekty můžete také zarovnat vzhledem k Ploše.
Na zvolené objekty můžete použít jedno i více Zarovnání.

� Originá obrázek

� Zarovnání k horní hraně vrchního objektu
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Rozdělování skupin a objektů

Pro rozdělení skupin, bloků textu, instancí a bitmap do samostatně upravitelných
prvků použijte příkaz Break Apart (Rozdělit). Rozdělení závažně zmenší velikost
souboru importované grafiky.

Rozdělení není zcela odvolatelné a ovlivní objekty následovně:

� Přetrhne spojení mezi instancí symbolu a hlavním symbolem.

� Vymaže všechny snímky kromě aktuálního pro animovaný symbol.

� Konvertuje bitmapu na výplň.

� Konvertuje textové znaky na obrysy.

Příkaz Break Apart (Rozdělit) by neměl být zaměňován s příkazem Ungroup (Oddělit).
Příkaz Oddělit oddělí seskupené objekty do samostatných složek a vrátí je do stavu,
ve kterém byly pře seskupením. Nerozděluje bitmapy, instance nebo text a nekonvertuje
text na obrysy.

Rozdělení skupin nebo objektů:

1. Zvolte skupinu, blok textu, bitmapu nebo symbol, které chcete rozdělit.

2. Vyberte Modify > Break Apart.

Poznámka: Nedoporučuje se rozdělovat animované symboly nebo skupiny ve vložené
animaci a mohlo by mít nepředvídatelné důsledky. Rozdělování složitých symbolů
a bloků textu může dlouho trvat. Možná budete potřebovat zvýšit příděl paměti
pro aplikaci, abyste mohli správně rozdělit složité objekty.
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Pohyb registrovaným bodem objektu

Všechny skupiny, instance, bloky textu a bitmapy mají registrovaný bod, který Flash
používá pro umísGování a transformování. Implicitně je tento bod umístěn ve středu
objektu. Přesunem registrovaného bodu objektu můžete objekt umísGovat a transformovat
vzhledem například k dolnímu levému rohu objektu. Čáry a tvary nemají registrovaný
bod a jsou umísGovány a transformovány vzhledem ke svému levému hornímu rohu.

Při úpravě registrovaného bodu instance pravděpodobně dostanete lepší výsledky,
pokud budete upravovat symbol a pak jej přesunete do režimu pro úpravu symbolu,
takže se registrovaný bod objeví v místě, které si budete přát. Viz "Úpravy symbolů".

Úprava registrovaného bodu skupiny, instance, bloku textu nebo bitmapy:

1. Zvolte objekt.

2. Vyberte Modify > Transform > Edit Center (Upravit střed).

� Zvýrazní se křížek představující středový bod.

3. Přetáhněte zvýrazněný křížek do nového umístění.

4. Klikněte na prázdnou oblast na Ploše nebo zvolte Modify > Transform > Edit 
Center (Upravit střed), čímž se křížek skryje.
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Pro usnadnění toho, abyste poznali, do které vrstvy objekty patří, můžete všechny
objekty na vrstvě zobrazit jako barevné obrysy. Barvu obrysů použitou pro každou
vrstvu můžete změnit. 

V Časové ose můžete měnit výšku vrstev, aby se v Časové ose zobrazilo více
informací (jako například tvar křivky zvuku). Můžete také měnit počet vrstev zobrazených
v Časové ose.

Pro zobrazení nebo skrytí vrstvy prove*te jedno z následujících:

� Klikněte na sloupec Eye (Oko) napravo od jména vrstvy pro skrytí vrstvy. 
Klikněte znovu pro zobrazení vrstvy.

� Klikněte na ikonu oko pro skrytí všech vrstev. Klikněte znovu pro zobrazení 
všech vrstev.

� Táhněte myší přes sloupec Oko pro zobrazení nebo skrytí více vrstev.

� Podržte Alt (ve Windows) nebo Option (na Macintoshi) a klikněte na sloupec 
Oko napravo od jména vrstvy pro skrytí všech ostatních vrstev. Podržte Alt
(ve Windows) nebo Option (na Macintoshi) a klikněte znovu pro zobrazení 
všech vrstev.

Pro zobrazení obsahu vrstvy jako obrysů prove*te jedno z následujících:

� Klikněte na sloupec Outline (Obrys) napravo od jména vrstvy, aby se všechny
obrysy na dané vrstvě zobrazily jako obrysy. Klikněte na něj znovu, pro vypnutí
obrysového zobrazení.

� Klikněte na ikonu obrysy pro zobrazení objektů na všech vrstvách jako obrysů.
Klikněte na ni znovu pro vypnutí obrysového zobrazení na všech vrstvách.

� Podržte Alt (ve Windows) nebo Option (na Macintoshi) a klikněte na sloupec
Obrys napravo od jména vrstvy, aby se objekty na všech vrstvách zobrazily
jako obrysy. Podržte Alt (ve Windows) nebo Option (na Macintoshi) a klikněte
znovu pro vypnutí obrysového zobrazení pro všechny vrstvy.
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KAPITOLA 8
Používání vrstev

Vrstvy jsou jako průhledné listy s nátěrem umístěné postupně nad sebou. Když vytváříte
animaci Flash, obsahuje jednu vrstvu. Pro organizaci výtvoru, animací a dalších prvků
vaší animace můžete přidávat další vrstvy. Na jednu vrstvu můžete kreslit objekty
a upravovat je bez vlivu na další vrstvy. Pokud na vrstvě nic není, můžete přes ni vidět
vrstvy pod ní.

Počet vrstev, které můžete vytvářet, je omezen pouze pamětí vašeho počítače a vrstvy
nezvyšují velikost souboru vaší publikované animace. Vrstvy můžete skrývat, zamykat
nebo zobrazovat jejich obsah jako obrysy. Můžete také měnit pořadí vrstev.

Dále můžete použít speciální vodící vrstvy pro usnadnění kreslení a úprav a maskovací
vrstvy, které vám pomohou vytvářet náročné efekty.

Dobrý nápad je oddělit vrstvy pro zvukové soubory, akce, popisy snímků a komentáře
ke snímkům. To vám pomůže tyto položky rychle najít, když je potřebujete upravit.

Pro interaktivní úvod do vrstev zvolte Help > Lessons > Layers.

Vytváření vrstev

Když vytváříte novou vrstvu, objeví se nad označenou vrstvou. Nově přidaná vrstva je
pak aktivní.

Pro vytvoření vrstvy prove*te jedno z následujících:

� Klikněte na tlačítko Add Layer (Přidat vrstvu) ve spodní části Časové osy.

� Vyberte Insert > Layer (Vrstvu).

� Klikněte pravým tlačítkem myši (ve Windows) nebo podržte Control a
klikněte (na Macintoshi) na jméno vrstvy na Časové ose a zvolte Insert Layer (Vložit
vrstvu) z kontextového menu.

Nahlížení na vrstvy

Během vaší práce budete možná chtít zobrazit nebo skrýt vrstvy. Červené X vedle
jména vrstvy znamená, že vrstva je skryta. Skryté vrstvy jsou zachovány při publikaci
animace. Nicméně skryté vrstvy nemůžete upravovat v SWF souboru, pokud jej otevřete
ve Flashi.
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Úprava vrstev

Pro kreslení, malování nebo jinou změnu vrstvy označte vrstvu, aby byla aktivní. Ikona
tužka vedle jména vrstvy znamená, že vrstva je aktivní. V danou dobu může být aktivní
pouze jedna vrstva (ačkoliv může být najednou označeno více vrstev). Vrstvy můžete
přejmenovávat, kopírovat a mazat. Vrstvy můžete zamykat, abyste zabránili jejich
úpravě, a můžete měnit jejich pořadí.

Implicitně jsou vrstvy pojmenovány podle pořadí, v jakém byly vytvořeny : Vrstva 1,
Vrstva 2 a tak dále. Vrstvy můžete pojmenovat, aby lépe vystihovaly svůj obsah. Vrstvy
můžete skrývat nebo můžete zobrazovat obsahy vrstev jako obrysy při úpravách
jiných vrstev,  aby nebyla pracovní plocha přecpaná. Viz "Nahlížení na vrstvy".

Pro výběr vrstvy prove*te jedno z následujících:

� Klikněte na jméno vrstvy v Časové ose.

� Klikněte na snímek v Časové ose z vrstvy, kterou chcete vybrat.

� Zvolte objekt na Ploše, který je umístěn na vrstvě, kterou chcete vybrat.

Pro výběr dvou nebo více vrstev prove*te následující:

� Pro výběr sousedících vrstev podržte Shift a klikněte na názvy vrstev v Časové
ose.

� Pro výběr nesousedících vrstev podržte Control (ve Windows) nebo Command
(na Macintoshi) a klikněte na jména vrstev v Časové ose.

Pro přejmenování vrstvy prove*te jedno z následujících:

� Dvakrát klikněte na jméno vrstvy a zadejte nový název.

� Klikněte pravým tlačítkem (ve Windows) nebo podržte Control a klikněte (na
Macintoshi) na jméno vrstvy a vyberte Vlastnosti z kontextového menu. 
Zadejte nové jméno do textového pole Name (Název) a klikněte na tlačítko OK.
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Změna barvy obrysů na vrstvě:

1. Prove*te jedno z následujících:

� Dvakrát klikněte na ikonu vrstvy (ikona nalevo od jména vrstvy) v Časové ose.

� Klikněte pravým tlačítkem myši (ve Windows) nebo podržte Control a klikněte (na
Macintoshi) na jméno vrstvy a z kontextového menu zvolte Properties (Vlastnosti).

� Vyberte vrstvu v Časové ose a zvolte Modify > Layer.

2. V dialogovém okně Properties (Vlastnosti vrstvy) klikněte na paletu barev
Outline Color (Barva obrysu) a vyberte novou barvu, zadejte její hexadecimální
hodnotu nebo klikněte na tlačítko Color Picker (Vybrat barvu) a zvolte barvu.

3. Klikněte na tlačítko OK.

Změna výšky vrstvy v Časové ose:

1. Prove*te jedno z následujících:

� Dvakrát klikněte na ikonu vrstvy (ikona nalevo od jména vrstvy) v Časové ose.

� Klikněte pravým tlačítkem (ve Windows) nebo podržte Control a klikněte (na
Macintoshi) na jméno vrstvy a z kontextového menu vyberte Properties
(Vlastnosti).

� V Časové ose vyberte vrstvu a zvolte Modify > Layer.

2. V dialogovém okně Properties (Vlastnosti vrstvy) vyberte volbu pro Layer Height
(Výšku vrstvy) a klikněte na tlačítko OK.

Změna počtu vrstev zobrazených v Časové ose:

Táhněte za příčku, která odděluje Časovou osu od oblasti Plochy.
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Používání vodících vrstev

Pro pomoc při kreslení můžete použít guide layers (vodící vrstvy). Z jakékoliv vrstvy
můžete udělat vodící vrstvu. Guide Layers (Vodící vrstvy) jsou označeny vodící ikonou
nalevo od jména vrstvy. Vodící vrstvy se neobjeví v publikované animaci Přehrávače Flash.

Můžete vytvořit také motion guide layer (vodící vrstvu pohybu), abyste mohli regulovat
pohyb objektů v animaci vykreslující pohyb. Viz "Vykreslování pohybu podle trasy".

Poznámka: Přetáhnutí normální vrstvy na vodící vrstvu přemění vodící vrstvu na vodící
vrstvu pohybu. Abyste zabránili náhodné konverzi vodící vrstvy, umístěte všechny
vodící vrstvy na konec pořadí vrstev.

Označení vrstvy jako vodící vrstvy:

� Zvolte vrstvu a klikněte pravým tlačítkem (ve Windows) nebo podržte Control 
a klikněte (na Macintoshi), pak vyberte Guide (Vodící) z kontextového menu.
Znovu vyberte Guide (Vodící) pro  zpětnou změnu vrstvy na normální vrstvu.

Používání maskovacích vrstev

Pro efekty reflektoru a přeměn můžete použít maskovací vrstvy pro vytvoření otvoru,
kterým je vidět obsah jedné nebo více níže ležících vrstev. Více vrstev můžete seskupit
do jedné maskovací vrstvy pro vytvoření složitějších efektů. Můžete také použít
jakýkoliv typ animace kromě pohybu trasy, aby se maska pohybovala. Nemůžete
maskovat vrstvy uvnitř tlačítek.

Pro vytvoření maskovací vrstvy umístěte na vrstvu vyplněnou plochu. Maskovací vrst-
va odkryje oblast níže ležících vrstev, která leží pod vyplněnou plochou a zakryje
všechny další plochy. Maskovací vrstvy mohou obsahovat pouze jednoduchý tvar,
instanci nebo znakový objekt. (Maskovací vrstvy Flash fungují podobně jako příkaz
Paste Inside (Vložit dovnitř) ve FreeHand.)

Vytvoření maskovací vrstvy:

1. Vyberte nebo vytvořte vrstvu, jejíž obsah bude viditelný skrze díry v masce.
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� Vyberte vrstvu v Časové ose a zvolte Modify > Layer. V dialogovém okně
Properties (Vlastnosti vrstvy) zadejte novou hodnotu do textového pole Name
(Název) a klikněte na tlačítko OK.

Kopírování vrstvy:

1. Klikněte na jméno vrstvy pro označení celé vrstvy.

2. Zvolte Edit > Copy Frames (Kopírovat snímky).

3. Klikněte na tlačítko Add Layer (Přidat vrstvu) pro vytvoření nové vrstvy.

4. Klikněte na novou vrstvu a zvolte Edit  > Paste Frames (Vložit rámy).

Smazání vrstvy:

1. Vyberte vrstvu.

2. Prove*te jedno z následujících:

� Klikněte na tlačítko Delete Layer (Smazat vrstvu) v Časové ose.

� Přetáhněte vrstvu na tlačítko Delete Layer (Smazat vrstvu).

� Klikněte pravým tlačítkem (ve Windows) nebo podržte Control a klikněte (na
Macintoshi) na jméno vrstvy a zvolte Delete Layer (Smazat vrstvu) v kontextovém
menu.

Pro zamknutí nebo odemknutí jedné nebo více vrstev prove*te jedno z následujících:

� Klikněte na sloupec Lock (Zámek) napravo od jména vrstvy pro zamknutí
této vrstvy. Klikněte na sloupec Lock (Zámek) pro odemknutí vrstvy.

� Klikněte na ikonu visacího zámku pro zamknutí všech vrstev. Klikněte znovu
pro odemknutí všech vrstev.

� Táhněte myší přes sloupec Lock (Zámek) pro zamknutí nebo odemknutí více
vrstev.

� Klikněte pravým tlačítkem (ve Windows) nebo podržte Control a klikněte (na
Macintoshi) na sloupec Lock (Zámek) napravo od jména vrstvy pro zamknutí
všech ostatních vrstev. Klikněte pravým tlačítkem (ve Windows) nebo podržte
Control a klikněte (na Macintoshi) znovu pro odemknutí všech vrstev.

Změna pořadí vrstev:

� Přetáhněte myší jednu nebo více vrstev v Časové ose.
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Vrstva masky; tvar, který bude v masce průhledný; maskovaná vrstva; konečný efekt

Pro maskování dalších vrstev po vytvoření maskovací vrstvy prove*te jedno 
z následujících:

� Přetáhněte existující vrstvu přímo pod maskovací vrstvu.

� Vytvořte novou vrstvu kdekoliv pod maskovací vrstvou.

� Vyberte Modify > Layer a vyberte Masked v dialogovém okně Layer Properties
(Vlastnosti vrstvy).

Pro odpojení vrstev od maskovací vrstvy:

1. Vyberte vrstvu, kterou chcete odpojit.

2. Prove*te jedno z následujících:

� Přetáhněte vrstvu nad maskovací vrstvu.

� Vyberte Modify > Layer a vyberte Normal.

Přepínáním mezi maskováním a odmaskováním:

� Podržte Alt (ve Windows) nebo Option (na Macintoshi) a klikněte na vrstvu.
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2. S takto označenou vrstvou zvolte Insert > Layer pro vytvoření nové vrstvy nad ní.

� Maskovací vrstva vždy zamaskuje vrstvu těsně pod ní, takže se ujistěte,
že maskovací vrstvu vytváříte na správném místě.

3. Nakreslete vyplněný tvar, typ polohy nebo vytvořte instanci symbolu 
na maskovací vrstvě. Flash na maskovací vrstvě ignoruje bitmapy, gradienty,
průhlednost, barvy a styly čar. Jakákoliv vyplněná plocha bude v masce
úplně průhledná; jakákoliv nevyplněná oblast bude nepropustná.

4. Klikněte pravým tlačítkem (ve Windows) nebo podržte Control a klikněte 
(na Macintoshi) na jméno maskovací vrstvy v Časové ose a z kontextového
menu vyberte Mask. 

� Vrstva je změněna na maskovací vrstvu, což ukazuje ikona šipky dolů. Vrstva 
těsně pod ní je spojena s maskovací vrstvou a její obsah se objevuje přes
vyplněnou oblast na masce. Jméno maskovací vrstvy je odsazené a jeho 
ikona se změní na šipku ukazující doprava.

� Pro zobrazení efektu masky ve Flashi zamkněte maskovací vrstvu a maskované
vrstvy.
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O vkládaných fontech a fontech uzpůsobených 
na konkrétní zařízení

Když používáte v animaci Flash font instalovaný ve vašem systému,  vloží Flash informaci
o fontu do SWF souboru Flash, aby zajistil, že se font v Přehrávači Flash správně
zobrazí. Ne všechny fonty zobrazené ve Flashi mohou být exportovány v animaci.
Pro ověření toho, že font může být exportován použijte příkaz View > Antialias Text
(Potlačení roztřepení čar textu), abyste mohli nahlížet na text; roztřepené písmo znamená,
že Flash nepozná obrysy tohoto písma a nebude jej exportovat jako text.

Jako alternativu k vloženým informacím o fontech můžete použít speciální fonty
Flashe nazvané fonty uzpůsobené na konkrétní zařízení. Tyto fonty nejsou vkládány
do SWF souborů Flash. Namísto toho použije Přehrávač Flash jakýkoliv jiný font na daném
počítači, který onomu fontu nejlépe odpovídá. Vzhledem k tomu, že není do souboru
vložena informace o fontu, použití tohoto fontu přináší o něco menší velikost souboru
animace. Navíc mohou tyto fonty při menších velikostech (do 10 bodů) být ostřejší a lépe
čitelné než vkládané fonty. Nicméně protože nejsou vložené, pokud nemá uživatel
ve svém systému instalovaný font, který odpovídá  původnímu fontu, písmo může
vypadat v jeho systému jinak, než bylo původně zamýšleno.

Flash obsahuje tři fonty uzpůsobené na konkrétní zařízení, nazvané _sans (podobný
jako Helvetica nebo Ariel), _serif (podobný jako Times Roman) a _typewriter (podobný
jako Courier). Pro určení fontu jako fontu uzpůsobeného na konkrétní zařízení vyberte
jeden z těchto tří typů fontu v Character panel (Panelu znaků) nebo zvolte Use Device
Font (Použít fonty uzpůsobené na konkrétní zařízení) v Panelu voleb textu. Pro daný
font můžete určit volitelné nastavení textu, takže uživatelé mohou kopírovat a vkládat text,
který se objeví ve vaší animaci. Viz "Používání fontů uzpůsobených na konkrétní zařízení".

Tyto fonty můžete používat pro statický text (text, který vytváříte při úpravě animace
a který se nemění při zobrazení animace) nebo dynamický text (text, který se průběžně
aktualizuje přes výstup ze serveru, jako údaje o sportovních výsledcích nebo o počasí).
Více informací o dynamickém textu viz "Vytváření textových polí pro vkládání informací
uživatelem nebo aktualizace dynamického textu".
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Používání znaků

Když ve Flashi používáte písmo, můžete nastavit jeho velikost, druh, styl, rozložení,
barvu a zarovnání. Písmo můžete transformovat jako objekt - rotací, změnou velikosti,
zešikmením, přetáčením - a stále upravovat jeho znaky. Vaše animace mohou obsahovat
textová pole pro vkládání dat uživatelem nebo pro zobrazení textu, který se může
dynamicky aktualizovat. Bloky textu můžete vázat na URL.

Písmo můžete také rozdělovat a měnit tvar jeho znaků. Pro další možnosti zacházení
s textem můžete pracovat s textem ve FreeHand a importovat soubor FreeHand do Flashe
nebo importovat soubor z FreeHand jako SWF soubor. Pro interaktivní úvod do Flashe
zvolte Help > Lessons > Type.

Animace Flash mohou používat postscriptový font Type 1, TrueType a bitmapové
fonty (jen na Macintoshi). Pro použití postscriptových fontů musíte mít nainstalovaný
Adobe Type Manager (ATM) na svém počítači (kromě systémů používajících Windows
2000, který nepotřebuje ATM). Viz TechNote #4105 na stránce Macromedia Flash
Support, http://www.macromedia.com/support/flash.

Poznámka: Když se vám objeví problémy při používání postscriptových fontů ve Flashi
ve Windows NT, možná máte nekompatibilní verze ATM a Windows NT. Pokud se objeví
problémy, kontaktujte prosím oddělení technické podpory pro ATM a Windows NT.

Když pracujete s FLA soubory Flashe, nahradí Flash fonty v animaci jinými fonty,
instalovanými na vašem systému, pokud je to nutné. Flash vám umožní vytvořit z fontu
symbol, takže můžete font exportovat jako část sdílené knihovny a použít jej v jiných
animacích Flash. 

Můžete kontrolovat pravopis textu zkopírováním do Schránky použitím Prohlížeče animací
a vložením textu do externího textového editoru. Viz "Používání Prohlížeče animací".
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Nastavení vlastností písma

Můžete nastavit vlastnosti fontu a odstavce. Font je soubor alfanumerických znaků
určitého vzhledu podle druhu písma. Vlastnosti fontu zahrnují rodinu fontu, velikost
písma, styl, barvu, "tracking", automatický "kerning" a posun základní linky. (Můžete
používat vložené fonty nebo fonty uzpůsobené na konkrétní zařízení. Viz "O vkládaných
fontech a fontech uzpůsobených na konkrétní zařízení".) Vlastnosti odstavce zahrnují
zarovnání, okraje, odsazení a řádkování.

Pro změnu vlastností fontu a odstavce použijte Character (Panel znaků) a Paragraph
(Panel odstavců). Pro nastavení Flashe pro používání fontů uzpůsobených na konkrétní
zařízení raději než vkládaných informací o fontech, použijte Text Option (Panel voleb textu).

Při vytváření nového písma Flash použije aktuální vlastnosti písma. Pro změnu vlastností
fontu nebo odstavce existujícího písma musíte toto písmo nejprve označit.

Použití Panelu znaků:

� Vyberte Window > Panels > Character (Panel znaků).

Použití Panelu odstavců:

� Vyberte Window > Panels > Paragraph (Panel odstavců).
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Vytváření textu

Pro umístění bloků textu na Plochu použijte nástroj Text. Písmo můžete umístit na jeden
řádek, který se bude rozšiřovat, když budete psát, nebo do bloku dané šířky, který text
automaticky zalomí. Flash zobrazí v pravém horním rohu textu, který se roztahuje, kulatou
úchytku a v pravém horním rohu textu, který má definovanou šířku, čtvercovou úchytku.

Flash zobrazí kulatou úchytku v pravém dolním rohu rámečků upravitelného textu,
což znamená, že velikost textového pole můžete měnit horizontálně i vertikálně podle
množství textu, které má obsahovat.

Vytvoření textu:

1. Zvolte nástroj Text.

2. Vyberte Window > Panels > Character (Panel znaků) a Window > Panels >
Paragraph (Panel odstavců), aby se vám zobrazily příslušné panely, a zvolte
vlastnosti písma, jak je to popsáno v následujícím oddíle.

3. ProveLte jedno z následujících:

� Pro vytvoření bloku textu, který se rozšiřuje, když píšete, klikněte na místo,
kde chcete začít psát.

� Pro vytvoření bloku textu s pevnou šířkou umístěte ukazatel do místa, kde chcete
začít psát, a táhněte myší na požadovanou šířku.

Poznámka: Pokud vytvoříte text, který se roztáhne přes pravý nebo spodní okraj
Plochy, když píšete, není text ztracený. Aby byla úchytka opět dosažitelná, přidejte
zalomení řádků, posuňte blokem textu nebo zvolte View > Work Area (Pracovní plocha).

Změna rozměrů bloku textu:

� Táhněte úchytkou pro změnu velikosti.

Změna bloku textu s pevnou šířkou na roztahující se a naopak:

� Dvakrát klikněte na úchytku pro změnu velikosti.
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Volby tracking, automatický kerning a posun nad linkou se nacházejí v Panelu znaků.

Nastavení trackingu, kerningu a posunu nad linkou:

1. Jestliže není zobrazen Panel znaků, vyberte Window > Panels > Character 
(Panel znaků).

2. V Panelu znaků nastavte tyto volby:

� Pro nastavení trackingu klikněte na trojúhelník vedle Tracking Value
(Hodnoty trackingu) a táhněte posuvníkem pro výběr hodnoty nebo zadejte 
hodnotu do textového pole.

� Pro použití vestavěných kerningových informací zvolte Kerning.

� Pro určení posunu nad linkou klikněte na trojúhelník vedle volby Baseline Shift
(Posun nad linkou) a zvolte pozici z menu: Normální umístí písmo na řádek, 
Superscript (Horní index) umístí písmo nad řádek a Subscript (Dolní index)
umístí písmo pod řádek.

Nastavení zarovnání, okrajů, odsazení a řádkování

Alignment (Zarovnání) určí pozici každého řádku v odstavci vzhledem k levému a pravému
okraji bloku textu. Písmo může být zarovnáno vlevo nebo vpravo, umístěno do středu
bloku nebo zarovnáno k oběma okrajům bloku textu (úplné zarovnání).

Margins (Okraje) určí velikost mezery mezi hranicí bloku textu a odstavcem. Indents
(Odsazení) určí vzdálenost mezi okrajem odstavce a začátkem prvního řádku.
Line spacing (Řádkování) určí vzdálenost mezi sousedními řádky v odstavci.

Pro určení zarovnání, okrajů, odsazení a řádkování použijte Paragraph (Panel odstavců).

Nastavení zarovnání, okrajů, odsazení a řádkování:

1. Jestliže Panel odstavců není ještě zobrazen,
vyberte Window > Panels > Paragraph (Panel odstavců).

2. V Panelu odstavců nastavte tyto volby:

� Pro nastavení zarovnání klikněte na tlačítka Zarovnání Left (Vlevo), Center
(Na střed), Right (Vpravo), Full Justification (Do bloku).

� Pro nastavení levého nebo pravého okraje klikněte na trojúhelník vedle Left
Margin (Hodnoty levého okraje) nebo Right Margin (Hodnoty pravého okraje)
a táhněte posuvníkem pro výběr hodnoty nebo zadejte hodnotu do číselného
pole.
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Volba fontu, velikosti, stylu a barvy písma

Použitím Panelu znaků můžete nastavit font, velikost, styl a barvu písma pro zvolené písmo.
Při nastavování barvy písma můžete použít pouze pevné barvy, ne gradienty. Pro použití
gradientu na písmo musíte nejprve písmo převést na jednotlivé řádky a výplně.
Viz "Změna tvaru písma".

Volba fontu, velikosti, stylu a barvy písma pomocí Panelu znaků:

1. Pokud už není Panel znaků zobrazen vyberte Window > Panels  > Character
(Panel znaků).

2. Klikněte na trojúhelník vedle textového pole Font a vyberte font ze seznamu
nebo zadejte název fontu.

Poznámka: Fonty _sans, _serif a _typewriter jsou fonty uzpůsobené na konkrétní zařízení.
Informace o těchto fontech není uložena do SWF souboru Flash. Viz "O vkládaných
fontech a fontech uzpůsobených na konkrétní zařízení".

3. Klikněte na trojúhelník vedle hodnoty Font Size (Velikosti písma) a táhněte
posuvníkem pro vybrání hodnoty nebo zadejte hodnotu velikosti fontu.

� Velikost písma je udána v bodech, nezávisle na aktuálních jednotkách pravítka.

4. Pro použití tučného písma nebo kurzívy klikněte na tlačítko Bold (Tučné)
nebo tlačítko Italic (Kurzíva).

5. Pro výběr barvy výplně písma klikněte na paletu barev nebo proveLte jedno 
z následujících:

� Vyberte vzorek barvy z palety.

� Vepište hexadecimální hodnotu barvy do textového pole.

� Klikněte na tlačítko Color Picker (Výběr barvy) a vyberte z Výběru barvu.

� Více informací o výběru barev viz kapitola 4, "Práce s barvou."

Nastavení "tracking", kerning a posun nad linkou

Tracking vkládá mezi znaky jednotnou mezeru. Používá se pro přizpůsobení
rozmístění označených znaků nebo celých bloků.

Kerning kontroluje rozmístění mezi páry znaků. Mnoho fontů má vestavěné kerning
informace. Například rozmezí mezi A a V je často menší než rozmezí mezi A a D.
Pro použití vestavěných kerningových informací pro rozmístění znaků použijte volbu
Kerning.

Posun nad linkou kontroluje, kde se objeví písmo vzhledem k řádku. 
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Vytváření symbolů fontu

Abyste mohli font použít jako položku sdílené knihovny, můžete v okně Knihovna
vytvořit symbol fontu. To vám umožní odkazovat se na font a používat ho v animaci
Flash bez toho, abyste font museli vkládat do animace. (Viz "Používání sdílených
knihoven".)

Pro použití symbolu fontu ve sdílené knihovně, přiřadíte symbolu identifikační řetězec.
Identifikátor může být také použit k přístupu k symbolu jako objektu v ActionScript.
Více informací o objektech v ActionScript viz Referenční příručka ActionScript.

Vytvoření symbolu fontu:

1. Otevřete knihovnu, do které chcete přidat symbol fontu.

2. Z menu Options (Volby) v pravém horním rohu okna Knihovna vyberte New Font
(Nový font).

3. V dialogovém okně Font Symbol Properties (Vlastnosti symbolu fontu) zadejte
název symbolu fontu do textového okna Name (Název).

4. Zvolte font z menu Fonty nebo zadejte jméno fontu do textového okna Font.

5. Pokud chcete, vyberte Tučné nebo Kurzíva pro aplikaci vybraného stylu na font.

6. Klikněte na tlačítko OK.

Přiřazení identifikačního řetězce symbolu fontu:

1. Zvolte symbol fontu v okně Knihovna.

2. ProveLte jedno z následujících:

� Zvolte Linkage (Vazba) z menu Volby v pravém horním rohu okna Knihovna.

� Klikněte pravým tlačítkem myši (ve Windows) nebo podržte Control a klikněte
(na Macintoshi) na jméno symbolu fontu v okně Knihovna a vyberte Linkage
(Vazba) z kontextového menu.

3. Pod Linkage (Vazbou) v dialogovém okně Symbol Linkage Properties 
(Vlastnosti vazby symbolu) zvolte Export This Symbol (Exportovat tento symbol).

4. Zadejte identifikační řetězec do textového pole a klikněte na tlačítko OK.
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� Pro určení odsazení klikněte na trojúhelník vedle Indent value (Hodnoty
odsazení) a táhněte posuvníkem pro označení hodnoty nebo zadejte hodnotu
do číselného pole.

� Pro určení řádkování klikněte na trojúhelník vedle Line spacing (Hodnoty
řádkování) a táhněte posuvníkem pro výběr hodnoty nebo zadejte hodnotu
do číselného pole.

Používání fontů uzpůsobených na konkrétní zařízení

Použitím Text Options (Panelu voleb) textu můžete určit, že Přehrávač Flash použije
tyto fonty pro zobrazení určitých bloků textu, takže Flash tyto fonty pro text neuloží.
To může zmenšit velikost souboru animace a zvětšit čitelnost písma malé velikosti.

Můžete určit, že text nastavený ve fontech uzpůsobených na konkrétní zařízení bude
volitelný uživateli prohlížejícími si vaši animaci.

Nastavení zobrazení textu použitím fontu uzpůsobeného na konkrétní zařízení:

1. Použijte nástroj Text pro označení bloků textu na Ploše, které mají být v Přehrávači
Flash zobrazeny s použitím tohoto fontu.

2. Vyberte Window > Panels > Text Options (Panel voleb textu).

3. Z kontextového menu vyberte Static Text (Statický text).

4. Zvolte Use Device Fonts (Použít fonty uzpůsobené na konkrétní zařízení).

Možnost vybrání písma uživatelem:

1. Zvolte písmo, které má být volitelné uživatelem.

2. Vyberte Window > Panels  > Text Options (Panel voleb textu).

3. Z kontextového menu vyberte Statický text.

4. Pokud už není písmo určeno pro použití fontu uzpůsobeného na konkrétní 
zařízení, zvolte Use Device Fonts (Použít fonty uzpůsobené na konkrétní zařízení).

5. Klikněte na Selectable (Volitelný).
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O zachování bohaté úpravy textového formátu

Flash vám umožní zachovávat bohatou úpravu textového formátu v textových polích
schopných editace. Můžete vybrat volbu HTML formátování pro dynamický nebo vkládaný
text v Text Options Panel (Panelu voleb textu). S označenou volbou HTML jsou automaticky
zachovány základní úpravy textového formátu (včetně jména, stylu, barvy a velikosti
fontu) a hypertextové odkazy v textovém poli automatickou aplikací odpovídajících
HTML tagů na dané textové pole.

Následující HTML tagy jsou podporovány v textových polích schopných editace:
� <A>

� <B>

� <FONT COLOR>

� <FONT FACE>

� <FONT SIZE>

� <I>

� <P>

� <U>

HTML tagy může také použít na textová pole v Panelu akcí, jako část hodnoty
proměnné pro textové pole. Když v Panelu voleb textu vyberete volbu HTML formát
textu, podporované HTML tagy, které jste použili v Panelu akcí, jsou zachovány
při exportu animace do SWF souboru.

Nastavení vlastností dynamického textu

Pro kontrolu toho, jak se dynamický text zobrazí v animaci Flash, můžete nastavit
jeho vlastnosti.

Nastavení vlastností dynamického textu:

1. Pokud ještě není zobrazen Panel voleb textu,
vyberte Window > Panels > Text Options (Panely voleb textu).

2. Z kontextového menu Typ textu vyberte Dynamický text.

3. Nastavte jakoukoliv z následujících voleb:

� Z kontextového menu Line Display (Zobrazení řádku) zvolte Multiline
(Víc řádků), aby se text zobrazil v několika řádcích, nebo Single Line (Jeden
řádek), aby se text zobrazil na jednom řádku.
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Vytváření textových polí pro vložení dat uživatelem nebo
dynamicky aktualizovaný text

Vkládací textová pole umožňují uživatelům vkládat text do formulářů nebo dotazníků.
Pole dynamického textu zobrazují dynamicky aktualizovaný text, jako například
sportovní výsledky, ceny akcií nebo zprávy o počasí. Obě tyto textová pole schopné
editace vytvoříte použitím Text Options (Panelu voleb).  Vyberete si volby pro určení
vzhledu vkládaných dat nebo dynamického textu v animaci Flash. Můžete zachovat
bohatou úpravu textového formátu jako HTML formát. Viz "O zachování bohaté úpravy
textového formátu". 

Když vytváříte textové pole, přiřazujete mu proměnnou. Proměnná je pevně
stanovené jméno pro proměnlivou hodnotu. Textové pole je jako okno, které zobrazí
hodnotu proměnné.  Pro předání proměnné do jiných částí animace, do aplikace na
straně serveru pro uchování v databází atd. můžete použít akce. Hodnotu proměnné
můžete také nahradit čtením z aplikace na straně serveru nebo jejím nahráním z jiné
části aplikace. Více informací o používání proměnných viz Referenční příručka
AcitionScript.

Vytvoření textového pole schopného editace:

1. Pro vytvoření nebo výběr bloku textu proveLte jedno z následujících:

� Zvolte nástroj Text a táhněte myší pro vytvoření bloku textu požadované šířky
a výšky.

� Klikněte na existující bloku textu.

2. Vyberte Window > Panels > Text Options (Volby textu).

3. Vyberte volbu z kontextového menu Text Type (Typ textu):

� Vyberte Dynamic Text (Dynamický text) pro vytvoření textového pole,
které zobrazí dynamicky aktualizovaný text.

� Vyberte Input Text (Vkládaný text) pro vytvoření textového pole, do kterého
mohou uživatelé vkládat text.
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� Pokud jste výše zvolili Multiline (Víc řádků), zvolte Word Wrap (Zalomení
textu), aby se automaticky přeskočilo na další řádek na konci textového pole.

� Jako Variable (Proměnnou) zadejte jméno proměnné pro textové pole.

� Pro Maximum znaků zadejte maximální počet znaků, který může uživatel 
zadat do textového pole.

� Za Embed Fonts (Vložené fonty) vyberte jedno nebo více tlačítek pro určení toho,
které znaky řady fontu použitého v dynamickém textu budou vloženy. Zvolte 
tlačítko Full Font (Úplný font) (tlačítko nejvíce vlevo) pro vložení celé řady
znaků fontu.

Úpravy textu

Pro úpravy textu ve Flashi můžete použít nejběžnější techniky zpracování textu.
Můžete použít příkazy Cut (Vyjmout), Copy and Paste (Kopírovat a vložit) pro přesun
písma v rámci souboru stejně jako mezi Flashem a jinými aplikacemi.

Pro kontrolu pravopisu textu můžete text zkopírovat do Schránky použitím Prohlížeče
animací a vložit text do externího textového editoru. Viz "Používání Prohlížeče animací".

Výběr textu

Při úpravách textu nebo změnách vlastností písma musíte nejprve označit znaky, které
chcete změnit.

Označení znaků v rámci bloku textu:

1. Vyberte nástroj Text.

2. ProveLte jedno z následujících:

� Táhněte myší pro označení znaků.

� Dvakrát klikněte na vybrané slovo.

� Klikněte pro určení začátku výběru, držte Shift a klikněte pro určení konce výběru.

� Zmáčkněte Ctrl+A (ve Windows) nebo Command+A (na Macintoshi)
pro označení všech znaků bloku.

Označení bloků textu:

Zvolte nástroj Šipka a klikněte na blok textu. Držte Shift a klikněte pro označení více
bloků textu.
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� Zvolte HTML pro uchování bohaté úpravy textového formátu, jako je font,
styl fontu, hypertextový odkaz, odstavec a jiné parametry textu s odpovídajícími
HTML tagy.

� Vyberte Draw Border and Bacground (Nakreslit hranici a pozadí), aby se pro 
dané textové pole zobrazila hranice a pozadí.

� Pokud jste výše zvolili Multiline (Víc řádků), zvolte Word Wrap (Zalomení
textu), aby se automaticky přeskočilo na další řádek na konci textového pole.

� Zvolte Selectable (Volitelný) (je nastaveno implicitně), abyste uživatelům 
umožnili vybírat dynamický text. Odznačte tuto volbu, jestliže chcete uživatelům
zabránit, aby vybírali text v poli dynamického textu.

� Jako Variable (Proměnnou) zadejte jméno proměnné pro textové pole.

� Za Embed Fonts (Vložené fonty) vyberte jedno nebo více tlačítek pro určení toho,
které znaky řady fontu použitého v dynamickém textu budou vloženy. Zvolte
tlačítko Full Font (Úplný font) (tlačítko nejvíce vlevo) pro vložení celé řady
znaků fontu.

Nastavení voleb vkládaného textu

Pro kontrolu toho, jak se vkládaný text zobrazí v animaci Flash, můžete nastavit
jeho vlastnosti.

Nastavení voleb vkládaného textu:

1. Pokud ještě není zobrazen Panel voleb textu,
vyberte Window > Panels > Text Options (Panely voleb textu).

2. Z kontextového menu Typ textu vyberte Input Text (Vkládaný text).

3. Nastavte jakoukoliv z následujících voleb:

� Z kontextového menu Line Display (Zobrazení řádku) vyberte Multiline
(Víc řádků) pro zobrazení textu ve více řádcích, Single Line (Jeden řádek)
pro zobrazení textu na jednom řádku nebo Password (Heslo) pro zobrazení
textu jako hvězdičky, aby byla zachována bezpečnost hesla.

Poznámka: Vybrání volby Heslo ovlivní jen zobrazení textu vloženého uživatelem.
Vytvoření funkčnosti hesla viz Referenční příručka ActionScript.

� Zvolte HTML pro uchování bohaté úpravy textového formátu, jako je font,
styl fontu, hypertextový odkaz, odstavec a jiné parametry textu s odpovídajícími
HTML tagy.

� Vyberte Draw Border and Bacground (Nakreslit hranici a pozadí), aby se pro
dané textové pole zobrazila hranice a pozadí.
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KAPITOLA 10

Používání symbolů a instancí

Symbol je grafika, tlačítko nebo klip animace, který jednou vytvoříte a pak můžete
opakovaně použít v jedné nebo více animacích. Jakýkoliv symbol, který vytvoříte, se stává
částí knihovny. Instance je kopie symbolu umístěná na Plochu nebo vsazená do jiného
symbolu. Instance se může lišit od původního symbolu barvou, velikostí a funkcí.
Úprava symbolu aktualizuje všechny jeho instance. Ale úprava instance symbolu
aktualizuje pouze tuto instanci.

Poznámka: Ve Flashi můžete vytvářet také symboly fontu. Viz "Vytváření symbolů fontu".

Používání symbolů v animaci podstatě snižuje velikost souboru; uložení několika
instancí symbolu vyžaduje méně místa než uložení úplného popisu prvku pro každý
výskyt. Například můžete snížit velikost souboru vašich animací pokud konvertujete
statickou grafiku, jako jsou obrázky v pozadí, do symbolů, které pak použijete znovu.
Používáním symbolů můžete také urychlit přehrávání animace, protože symbol se musí
do prohlížeče stáhnout pouze jednou.

Používání symbolů vám také umožní sdílet obrázky a další prvky, jako jsou klipy animace
nebo zvuky, mezi animacemi. Symboly můžete zahrnout do sdílené knihovny bez
importování položek do animací. Viz "Používání sdílených knihoven".

Pro interaktivní úvod do používání symbolů a instancí vyberte Help > Lessons > Symbols.

Symbol a jeho dvě Instance na Ploše
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Transformace písma

Bloky textu můžete transformovat stejně jako objekty. Můžete měnit jejich velikost,
otáčet s nimi, zešikmovat je a přetáčet je pro vytváření zajímavých efektů. Když změníte
velikost bloku textu jako objektu, neodrazí se zvýšení nebo snížení ve velikosti
textu v Panelu znaků.

Text v transformovaném bloku textu může být stále upravován, ačkoliv závažné
transformace jej mohou činit obtížným pro čtení.

Více informací o transformování bloků textu viz kapitola 7, "Práce s objekty".

Změna tvaru písma

Pro změnu tvaru, gumování a jinou manipulaci s písmem, jej můžete změnit na jednotlivé
čáry a výplně. Můžete je, stejně jako jiné tvary, seskupovat nebo měnit na symboly
a animovat je. Pokud písmo změníte na čáry a výplně, nemůžete ho již upravovat jako
text. Do tvarů můžete konvertovat pouze celé bloky textu, ne znaky v rámci bloku textu.

Konverze písma na jeho dílčí čáry a výplně:

1. Zvolte nástroj Šipka a klikněte na blok textu.

2. Zvolte Modify > Break Apart (Rozdělit). Znaky ve vybraném textu jsou změněny
na tvary na Ploše. 

Poznámka: Příkaz Rozdělit se dá použít pouze na okrajová písma jako jsou fonty TrueType.
Bitmapové fonty, pokud je rozdělíte, zmizí z obrazovky. Postscriptové fonty mohou být
rozděleny pouze v systémech Macintosh při spuštěném Adobe Type Manager (ATM).

Odkazování bloků textu na URL

Bloky textu můžete odkazovat na URL, abyste uživatelů umožnili přejít na další soubory
kliknutím na text.

Odkázání bloku textu na URL:

1. Použijte nástroj Šipka pro označení bloku na Ploše.

2. Pokud není už zobrazen Panel znaků, vyberte Window > Panels > Character
(Panel znaků).

3. Jako Link (Odkaz) zadejte adresu URL, na které chcete odkázat blok textu.
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Vytváření symbolů

Symboly můžete vytvářet ze zvolených objektů na Ploše nebo můžete vytvářet prázd-
né symboly a vytvořit nebo importovat jejich obsah v režimu editace symbolů.
Symboly mohou mít veškeré funkce, které můžete vytvořit ve Flashi, včetně animace.
Použitím symbolů, které obsahují animace, můžete vytvořit animace s velkým
množstvím pohybu při minimální velikosti souboru. Zvažte vytvoření symbolu ani-
mace, pokud vytváříte opakující se nebo cyklickou akci - například pohyb křídly ptáka
nahoru a dolů.

Vytvoření nového symbolu pomocí označených prvků:

1. Zvolte prvek nebo několik prvků na Ploše a vyberte Insert > Convert to Symbol
(Konvertovat na symbol).

2. V dialogovém okně Symbol Properties (Vlastnosti symbolu) napište jméno
symbolu a vyberte chování – Graphic (Grafika), Button (Tlačítko) nebo Movie Clip
(Klip animace). Viz "Typy chování symbolu".

3. Klikněte na tlačítko OK.

Flash přidá symbol do knihovny. Výběr na Ploše se stane instancí symbolu.
Objekt už nemůžete upravovat na Ploše - musíte otevřít režim editování symbolu;
viz "Úpravy symbolů".

Vytvoření nového prázdného symbolu:

1. Ujistěte se, že na Ploše není nic označeno, a prove<te jedno z následujících:

� Zvolte Insert  > New Symbol (Nový symbol).

� Klikněte na tlačítko Nový symbol v levé dolní části okna Knihovna.
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Typy chování symbolu

Každý symbol má jedinečnou Časovou osu a Plochu s vrstvami. Když vytvoříte symbol,
vyberete si, jak se bude chovat v závislosti na tom, jak ho chcete použít v animaci.

Pro statické obrázky a pro vytvoření opakovaně použitých částí animace, které jsou
vázané na Časovou osu hlavní animace, použijte grafické symboly. Grafické symboly
pracují v souladu s Časovou osou hlavní animace. Interaktivní ovladače a zvuky nebudou
fungovat v animované sekvenci grafických symbolů.

Pro vytváření interaktivních tlačítek v animaci, které odpovídají na kliknutí myši, pohyb
myši nebo jiné akce, použijte symboly tlačítek. Definujete grafiku spojenou s různými
stavy tlačítek nebo jinými akcemi. Viz "Přiřazování akcí objektům".

Pro vytvoření opakujících se částí animace použijte symboly klipu animace. Movie
Clips (Klipy animace) mají svou vlastní Časovou osu s více snímky, která se přehrává
nezávisle na Časové ose hlavní animace - přestavte si je jako minianimace uvnitř
hlavní animace, které mohou obsahovat interaktivní ovladače, zvuky a dokonce další
instance klipů. Instance klipu animace můžete také umístit dovnitř Časové osy symbolu
tlačítka, čímž vytvoříte animovaná tlačítka.

Klipu animace můžete přiřadit parametry (proměnné s hodnotami) a vytvoříte smart
(chytrý) klip. Chytrému klipu pak můžete přidat akce a skripty a vytvoříte styčné prvky
- jako rádiová tlačítka, kontextová menu nebo tipy panelu nástrojů - které budou
odpovídat na kliknutí myší nebo jiné jevy. více informací viz Referenční příručka
ActionScript.

Poznámka: Interaktivita a animace v symbolech klipu animace nefungují, když animaci
přehráváte v editovacím prostředí Flash. Abyste mohli animaci a interaktivitu vidět,
vyberte Control > Test Movie nebo Control > Test Scene. viz "Nahlížení a testování
animací".
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� Klikněte na tlačítko Edit Scene (Úpravy scény) v pravém horním rohu okna
dokumentu a vyberte scénu z menu.

Konvertování animace na Ploše do klipu animace

Vytvořili jste animovanou sekvenci na Ploše a chcete ji použít jinde v animaci nebo
s ní chcete zacházet jako s animací. Pak ji můžete označit a uložit jako symbol
klipu animace.

Konverze animace na Ploše do klipu animace:

1. Na hlavní Časové ose označte všechny snímky ve všech vrstvách animace
na Ploše, kterou chcete použít.

2. Pro kopírování snímků prove<te jedno z následujících:

� Klikněte pravým tlačítkem myši (ve Windows) nebo podržte Control a klikněte
(na Macintoshi) na jakýkoliv vybraný snímek a zvolte Copy Frames
(Kopírovat snímky) z kontextového menu.

� Zvolte Edit > Copy Frames (Kopírovat snímky).

3. Odznačte svůj výběr a ujistěte se, že na Ploše není nic označeno. Vyberte 
Insert > New Symbol (Nový symbol).

4. V dialogovém okně vlastnosti symbolu, pojmenujte symbol. Jako Behavior
(Chování) vyberte Movie Clip (Klip animace) a pak klikněte na tlačítko OK.

� Flash otevře nový symbol pro úpravy v režimu editace symbolů.

5. Na Časové ose klikněte na Snímek 1 na Vrstvě 1
a vyberte Edit > Paste Frames (Vložit snímky).

� To vloží snímky, které jste zkopírovali z hlavní Časové osy do Časové osy 
tohoto symbolu klipu animace. Jakékoliv animace, tlačítka nebo interaktivita 
ze snímků, které jste zkopírovali, se nyní stává nezávislou animací (symbolem
klipu animace), kterou můžete používat během animace.
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� Vyberte Nový symbol z menu Volby knihovny v pravém horním rohu okna
Knihovna.

2. V dialogovém okně Symbol Properties (Vlastnosti symbolu) napište jméno
symbolu a vyberte chování - Grafika, Tlačítko nebo Klip animace.
Viz "Typy chování symbolu".

3. Klikněte na tlačítko OK.

� Flash přidá symbol do knihovny a přepne do režimu pro editaci symbolu.
V tomto režimu se jméno symbolu zobrazí nad levým horním rohem okna
nad Časovou osou a křížek označuje registrovaný bod symbolu.

4. Pro vytvoření obsahu symbolu použijte Časovou osu, kreslete s kreslícími
nástroji, importujte prostředky nebo vytvářejte instance jiných symbolů.

5. Když skončíte s vytvářením obsahu symbolu, prove<te jedno z následujících 
pro návrat do režimu editace animace:

� Zvolte Edit  > Edit Movie (Úpravy animace).

� Klikněte na tlačítko Scene v levém horním rohu okna dokumentu.
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4. Pokud jste vytvořili instanci grafického symbolu, vyberte Insert > Frame
(Snímek) pro přidání počtu snímků, které bude grafický symbol obsahovat.

� Po vytvoření instance symbolu použijte Instance panel (Panel instancí) 
(Windows > Panels > Instance) pro určení barevných efektů, přiřazení akcí, 
nastavení grafického zobrazovacího režimu nebo změnu chování instance. 
Chování instance je totožné s chováním symbolu, pokud není určeno jinak. 
Veškeré změny, které uskutečníte, ovlivní pouze instanci a ne symbol. 
Viz "Změna barvy a průhlednosti instance".

Vytváření tlačítek

Tlačítka jsou ve skutečnosti interaktivní klipy animace se čtyřmi snímky. Když jako
behavior (chování) symbolu zvolíte tlačítko, Flash vytvoří Časovou osu se čtyřmi
snímky. První tři snímky zobrazují tři možné stavy tlačítka, čtvrtý definuje aktivní plochu
tlačítka. Časová osa se ve skutečnosti nepřehrává, pouze reaguje na pohyb a akce
ukazatele myši tím, že přeskočí do odpovídajícího snímku.

Aby bylo tlačítko v animaci interaktivní, umístěte instanci symbolu tlačítka na Plochu
a přiřa<te instanci akce. Akce musí být přiřazeny instanci tlačítka v animaci, ne snímkům
v Časové ose tlačítka.

Každý snímek v Časové ose symbolu tlačítka má specifickou funkci:

� První snímek je stav Up (Nahoře), představující vzhled tlačítka v situacích,
kdy na něm není ukazatel.

� Druhý snímek je stav Over (Přes), představující vzhled tlačítka, když je nad
ním ukazatel.

� Třetí snímek je stav Down (Dole), představující vzhled tlačítka, když je na něj 
kliknuto.

� Čtvrtý snímek je stav Hit (Zásah), definující oblast, která bude reagovat 
na kliknutí myši. Tato oblast je v animaci neviditelná.

Typická ukázka tlačítka – Up, Over, Down je spojen s Hit oblastí ve třetím snímku

Pro interaktivní lekci o vytváření tlačítek ve Flashi vyberte Help > Lessons > Buttons.
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6. Pro opuštění režimu pro editaci symbolů prove<te jedno z následujících:

� Vyberte Edit > Edit Movie (Úpravy animace).

� Klikněte na tlačítko Scene v levém horním rohu okna dokumentu.

� Klikněte na tlačítko edit Scene (Úpravy scény) v pravém horním rohu okna 
dokumentu a z menu vyberte scénu.

7. Vymažte animaci z Časové osy hlavní animace označením všech snímků
ve všech vrstvách a vybráním Insert  > Remove Frame (Odstranit snímek).

Duplikace symbolů

Duplikace symbolu vám umožní použít existující symbol jako počáteční bod pro
vytvoření nového symbolu.

Duplikace symbolu:

1. Vyberte symbol v okně Knihovna.

2. Pro duplikování symbolu prove<te jedno z následujících:

� Klikněte pravým tlačítkem myši (ve Windows) nebo podržte Control a klikněte
(na Macintoshi) a vyberte z kontextového menu volbu Duplicate (Duplikovat).

� Vyberte Duplikovat z menu Library Options (Volby knihovny).

Vytváření instancí

Když jste už vytvořili symbol, můžete vytvářet instance tohoto symbolu kdekoliv v
průběhu animace, včetně vnitřku jiných symbolů.

Vytvoření nové instance symbolu:

1. Zvolte vrstvu v Časové ose.

� Flash umí umístit instance jen do klíčových snímků, vždy do aktuální vrstvy. 
Pokud nevyberete klíčový snímek, instance bude přidána do prvního 
klíčového snímku nalevo od aktuálního snímku.

2. Vyberte Window > Library (Knihovna) pro otevření knihovny.

3. Přetáhněte symbol z knihovny na Plochu.

KAPITOLA 10 - Správa sítě 199



4. Klikněte na druhý snímek, pojmenovaný Over (Přes), 
a vyberte Insert  > Keyframe (Klíčový snímek).

� Flash vloží klíčový snímek, který duplikuje obsah snímku Up (Nahoře).

6. Změňte obrázek tlačítko stavu Over (Přes).

7. Opakujte kroky 5 a 6 pro snímky Down (Dole) a Hit (Zásah).

Snímek 
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Vytvoření tlačítka:

1. Vyberte Edit  > Deselect All (Odznačit vše), abyste se ujistili, že na Ploše
není označeno nic.

2. Vyberte Insert  > New Symbol (Nový symbol) nebo zmáčkněte Control+F8 
(ve Windows) nebo Command+F8 (na Macintoshi).

� Pro vytvoření tlačítka změňte snímky tlačítka na klíčové snímky.

3. V dialogovém okně Symbol Properties (Vlastnosti symbolu) zadejte jméno
nového symbolu tlačítka a jako Behavior (Chování) vyberte Button (Tlačítko).

� Flash se přepne do režimu pro editaci symbolu. Ukazatel Časové osy se změní
na zobrazení čtyř po sobě jdoucích snímků pojmenovaných Up (Nahoře),
Over (Přes), Down (Dole) a Hit (Zásah). První snímek, Up (Nahoře), je prázdný
klíčový snímek.

4. Pro vytvoření obrázku tlačítka Up (Nahoře) použijte kreslící nástroje, importujte 
grafiku nebo umístěte instanci jiného symbolu na Plochu.

� Na tlačítko můžete použít symbol grafiky nebo klipu animace, ale nemůžete 
použít jiné tlačítko do tlačítka. Pokud chcete, aby tlačítko bylo animované, 
použijte symbol klipu animace.
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Pro testování tlačítka prove<te jedno z následujících:

� Vyberte Control  > Enable Simple Buttons (Aktivovat jednoduchá tlačítka).
Posuňte ukazatelem myši na aktivované tlačítko, abyste jej otestovali.

� Označte tlačítko v okně Knihovna a klikněte na tlačítko Play (Přehrát) v kontrolním
okně Knihovna.

� Klipy animace v tlačítcích nejsou v editovacím prostředí Flash viditelné. 
Viz "Náhled na animace a jejich testování".

� Vyberte Control > Test Scene (Testovat scénu) nebo Control > Test Movie
(Testovat animaci).

Úpravy symbolů

Když upravíte symbol, Flash aktualizuje všechny instance tohoto symbolu v animaci.
Symbol můžete upravovat v kontextu s ostatními objekty na Ploše použitím příkazu
Edit in Place (Upravit na místě). Ostatní objekty jsou ztlumeny, aby byly odlišeny
od symbolu, který upravujete.

Symbol můžete upravovat také ve zvláštním okně použitím příkazu Edit in New Window
(Upravit v novém okně) nebo režimu pro editaci symbolu. Úprava symbolu ve zvláštním
okně vám umožní vidět symbol i hlavní Časovou osu zároveň.

V režimu pro editaci symbolu se okno změní z pohledu na Plochu na pohled pouze
na Symbol; křížek představuje registrovaný bod symbolu. Dále je Panel instancí ztlumený
a jméno symbolu se zobrazí v levém horním rohu okna nad Časovou osou.
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� Hit není na Ploše viditelný, ale definuje oblast tlačítka, která reaguje na kliknutí.
Ujistěte se, že grafika tlačítka Hit je jednotná plocha, dostatečně velká, aby 
obsáhla snímky Up (Nahoře), Down (Dole) a Over (Přes). Může být i větší 
než viditelné tlačítko. Když neurčíte snímek Hit (Zásah), je za něj považován 
obrázek pro stav Up (Nahoře). Můžete vytvořit nespojené rolování umístěním 
snímku Hit do jiného místa než ostatní snímky tlačítka. 

8. Pro přiřazení zvuku ke stavu tlačítka vyberte snímek stavu v Časové ose,
vyberte Modify > Frame pro zobrazení Panelu snímků a pak klikněte na záložku
Zvuk. Viz "Přidávání zvuku k tlačítkům".

9. Po ukončení vyberte Modify > Edit Movie (Úpravy animace). Přetáhněte
myší symbol tlačítka mimo okno Knihovna pro vytvoření jeho instance v animaci.

Aktivace, úpravy a testování tlačítek

Implicitně nechává Flash tlačítka neaktivní v průběhu jejich vytváření, aby se s nimi
lépe pracovalo. Když je tlačítko neaktivní, označíte jej kliknutím. Když je tlačítko
aktivní, odpovídá na události myši tak, jak jste to určili, jako by se animace přehrávala.
Nicméně aktivní tlačítka můžete stále označovat. Obecně je nejlepší tlačítka deaktivovat,
když s nimi pracujete, a aktivovat pro rychlé testování jejich chování.

Aktivace a deaktivace tlačítek:

� Vyberte Control > Enable Simple Buttons (Aktivovat jednoduchá tlačítka).
Vedle příkazu se zobrazí zatržítko, což znamená, že tlačítko je aktivní. 
Vyberte tento příkaz znovu pro jeho deaktivaci.

� Všechna tlačítka na Ploše nyní reagují. Jak posouváte ukazatelem nad 
tlačítko, zobrazí Flash snímek Over (Přes); když kliknete do aktivní oblasti
tlačítka, zobrazí Flash snímek Down (Dole).

Výběr aktivního tlačítka:

� Použijte nástroj Šipka pro vytvoření obdélníkového výběru kolem tlačítka.

� Posun aktivním tlačítkem nebo jeho úpravy:

1. Zvolte tlačítko, jak bylo výše popsáno.

2. Prove<te jedno z následujících:

� Použijte klávesové šipky pro posun tlačítkem.

� Vyberte Window > Panels > Instance, pro úpravy tlačítka nebo podržte Alt
(ve Windows) nebo Option (na Macintoshi) a dvakrát klikněte na tlačítko.
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Úprava symbolu v novém okně:

� Vyberte instanci symbolu na Ploše a klikněte pravým tlačítkem myši (ve Windows)
nebo podržte Control a klikněte (na Macintoshi) a vyberte Edit in New Window
(Upravit v novém okně) z kontextového menu.

� Dvakrát klikněte na ikonu symbolu v okně Knihovna.

Pro úpravu symbolu v režimu pro editaci symbolů prove<te jedno z následujících:

� Vyberte instanci symbolu na Ploše a klikněte na tlačítko Edit Symbol (Upravit 
symbol) v dolní části Panelu instancí.

� Označte instanci symbolu na Ploše; vyberte Edit  > Edit Symbols (Úpravy 
symbolů) nebo klikněte pravým tlačítkem myši (ve Windows) nebo podržte
Control a klikněte (na Macintoshi) a vyberte Edit (Úpravy) z kontextového menu.

� Dvakrát klikněte na symbol v okně Knihovna nebo v kontrolním okně
Knihovny; pak vyberte Edit (Úpravy) z menu Volby knihovny nebo klikněte 
pravým tlačítkem myši (ve Windows) nebo podržte Control a klikněte (na
Macintoshi) a vyberte Edit (Úpravy) z kontextového menu.

� Symbol připojený k instanci se otevře v režimu pro editaci symbolů. Nyní 
můžete symbol upravovat. Všechny instance symbolu v animaci budou
aktualizovány a budou odrážet vaše úpravy.

� Při upravování symbolu můžete použít jakýkoliv z kreslících nástrojů, importovat
prostředky nebo vytvářet instance dalších symbolů.
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Pro úpravu symbolu na místě prove<te jedno z následujících:

� Dvakrát klikněte na instanci na Ploše.

� Zvolte instanci symbolu na Ploše a klikněte pravým tlačítkem myši (ve Windows)
nebo podržte Control a klikněte (na Macintoshi) a vyberte Edit in Place 
(Upravit na místě) z kontextového menu.
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Vlastnosti jsou uloženy spolu s instancí. Pokud upravujete symbol, nebo měníte
odkaz instance na jiný symbol, jakékoliv vlastnosti instance, které jste změnily,
se stále používají na tuto instanci.

Originál obrázek a jeho dvě Instance

Změna barvy a průhlednosti instance

Každá instance symbolu může mít svůj vlastní barevný efekt. Pro nastavení voleb
barvy a průhlednosti u instancí použijte Effect panel (Panel efektů), který je zkrácen
Instance panel (Panelem instancí). Nastavení Panelu efektů také ovlivní bitmapy
umístěné v rámci symbolů.

Instance symbolu s jejich vlastními barevnými efekty

Když změníte barvu a průhlednost instance v určitém snímku, Flash tuto změnu
provede jakmile zobrazí tento snímek. Pro postupné změny barvy musíte změnu
barev vykreslit. Když vykreslujete barvu, zadáváte různé nastavení efektů v počátečných
a konečných klíčových snímcích instance a pak tato nastavení vykreslíte, aby se barvy
instance postupně měnily. Viz "Vykreslování instancí, skupin a písma".

Poznámka: Pokud aplikujete barevný efekt na klip animace, který obsahuje více
snímků, Flash tento efekt použije na všechny snímky klipu animace.
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Pro odchod z režimu pro editaci symbolů a návrat do úprav animace prove<te jedno
z následujících:

� Vyberte Edit  > Edit Movie (Úpravy animace).

� Klikněte na název scény v levém horním rohu okna dokumentu.

� Klikněte na tlačítko Edit Scene (Úprava scény) v pravém horním rohu okna
dokumentu a vyberte scénu z menu.

Změna vlastností instance

Každá instance má své vlastní vlastnosti, které jsou odděleny od symbolu.  Můžete
měnit odstín, průhlednost a jasnost instance, předefinovat jak se instance chová
(například změnit grafiku na klip animace); a nastavit, jak se animace přehraje uvnitř
grafické instance. 
Instanci můžete také zešikmovat, otáčet s ní nebo měnit její velikost bez ovlivnění
symbolu.

Dále můžete instanci klipu animace pojmenovat, takže ji můžete použít v ActionScript.

Pro úpravu vlastností instance použijte Panel instancí (Windows > Panels > Instance
(Panel instancí)) a Panel efektů (Windows > Panels > Effect (Panel efektů)).
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Nahrazení instance jiným symbolem

Přiřazení jiného symbolu instanci zobrazí na Ploše jinou instanci, které zachová vlastnosti
původní instance (jako jsou barevný efekt a akce tlačítek).

Například řekněme, že vytváříte karikaturu se symbolem Krysa pro vaši povahu,
ale rozhodnete se změnit povahu na Kočku. Mohli byste změnit symbol Krysa na Kočka
a zobrazit tak aktualizovanou povahu v přibližně stejném místě ve všech snímcích.

Přiřazení jiného symbolu instanci:

1. Zvolte instanci na Ploše a vyberte Window > Panels > Instance (Panel 
instancí); nebo podržte Alt (ve Windows) nebo Option (na Macintoshi) a dvakrát
klikněte na instanci na Ploše, abyste Panel instancí přenesli do popředí.

2. Klikněte na tlačítko Swap Symbol (Vyměnit symbol) v dolní části Panelu instancí.

3. V dialogovém okně Swap Symbol (Vyměnit symbol) vyberte symbol, který 
nahradí ten, který je aktuálně přiřazen instanci. Pro duplikaci zvoleného 
symbolu klikněte na tlačítko Duplikovat symbol v dolní části dialogového okna.

Duplikování vám umožní založit nový symbol na již existujícím symbolu v knihovně
a minimalizuje kopírování, pokud děláte několik symbolů, které se liší jen mírně.
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Změna barvy a průhlednosti instance:
1. Zvolte instanci na Ploše a vyberte Window > Panels > Effect (Panel efektů).

� Můžete také podržet Alt (ve Windows) nebo Option (na Macintoshi) a dvakrát 
kliknout na instanci na Ploše, aby se přesunul do popředí Panel instancí, 
a pak kliknout na záložku Efekt.

2. Vyberte jednu z následujících voleb v Panelu efektů:

� Brightness (Jasnost) přizpůsobí relativní světlost nebo tmavost obrázku, 
měřenou na stupnici od černé (-100%) k bílé (100%).

� Tint (Odstín) vybarví instanci stejnou barvou. Použijte posuvník Odstín v horní
části panelu pro nastavení procent odstínu od průhledné (1%) po plně 
nasycenou (100%). Pro výběr barvy zadejte červené, zelené a modré hodnoty
v odpovídajících textových polích nebo táhněte posuvníky složek; nebo použijte
Color Picker (Výběr barvy).

� Alpha (Alfa) přizpůsobí průhlednost instance.

� Advanced (Pokročilé) zvlášX přizpůsobí hodnoty červené, zelené, modré
a průhlednosti instance. To je nejužitečnější když chcete vytvořit a animovat 
jemné barevné efekty na objektech jako jsou bitmapy. Ovladače nalevo vám 
umožní snížit hodnoty barev a průhlednosti o určené procento. Ovladače
napravo vám umožní snížit nebo zvýšit hodnoty barvy nebo průhlednosti 
o konstantní hodnotu.

� Aktuální hodnoty Red (červené), Green (zelené) a Blue (modré) a alfa hodnoty
jsou násobeny procentuálními hodnotami a pak přidány ke konstantním 
hodnotám v pravém sloupci, čímž se vytvoří nové hodnoty barev. Pokud 
je například současná hodnota červené 100, nastavení levého posuvníku na 50%
a pravého posuvníku na 100 vytvoří novou hodnotu červené 150 ((100x5)
+ 100 = 150).

� Jakékoliv změny, které provedete, se automaticky aktualizují na Ploše.

� Barvu můžete měnit také použitím objektu Barva ActionScript. Více informací 
viz Referenční příručka ActionScript.
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Rozdělování instancí

Pro rozpojení vazby mezi instancí a symbolem a přeměnu instance do souboru
neseskupených tvarů a čar rozdělíte instanci. To je užitečné pro závažnou změnu
instance bez vlivu na jiné instance. Pokud změníte zdrojový symbol po rozdělení
instance, instance nebude aktualizována podle těchto změn.

Rozdělení instance symbolu:

1. Zvolte instanci na Ploše.

2. Vyberte Modify  > Break Apart (Rozdělit).

� To rozdělí instanci na dílčí grafické prvky.

3. Použijte malovací a kreslící nástroje pro požadované změny těchto prvků.

Získávání informací o instancích na Ploše

Když vytváříte animaci, může být složité identifikovat jednotlivé instance symbolu
na Ploše, zvlášX pokud pracujete s více instancemi jednoho symbolu. Instance
můžete identifikovat  použitím Instance panel (Panelu instancí), Info panel (Panelu
informací) nebo Movie Explorer (Prohlížeče animací).

Všechny panely zobrazí jméno zvoleného symbolu a ikony, které označují její typ - grafiku,
tlačítko nebo klip animace. Dále můžete prohlížet tyto informace:

V Panelu instancí můžete prohlížet chování a nastavení instance - pro grafiku režim
smyčka a délku symbolu ve snímcích; pro tlačítka volby zobrazení; a pro klipy
animace délku klipu.

V Panelu informací můžete prohlížet umístění a velikost vybrané instance.

V Prohlížeči animací můžete prohlížet obsah aktuální animace, včetně instancí as
symbolů. Viz "Používání Prohlížeče animací".

Dále můžete v Panelu akcí sledovat všechny akce přidělené grafice, tlačítku nebo
klipu animace.

Získání informace o instanci na Ploše:

1. Zvolte instanci na Ploše.

2. Zobrazte panel, který chcete použít:

� Pro zobrazení Panelu instancí vyberte Window  > Panels > Instance (Panel 
instancí) nebo podržte Alt (ve Windows) nebo Option (na Macintoshi) a dvakrát
klikněte na zvolenou instanci.
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Změna typu instance

Můžete změnit typ instance pro předefinování jejího chování v animaci. Pokud například
grafická instance obsahuje animace, které chcete přehrát nezávisle na Časové ose
hlavního okna, mohli byste předefinovat grafickou instanci na instanci klipu animace.

Změna typu instance:

1. Označte instanci na Ploše a vyberte Window > Panels > Instance (Panel
instancí); nebo podržte Alte (ve Windows) nebo Option (na Macintoshi) 
a dvakrát klikněte na instancí na Ploše, aby se přenesl do popředí Panel instancí.

2. Jako Behavior (Chování) vyberte Graphic (Grafiku), Button (Tlačítko) nebo
Movie Clip (Klip animace).

Nastavení animace pro grafické instance

Můžete určit, jak se budou chovat animované sekvence uvnitř grafické instance
během přehrávání animace pomocí nastavení voleb v Panelu instancí.

Animovaný grafický symbol je svázaný s Časovou osou animace, ve které je symbol
umístěn. Naopak symbol klipu animace má svou vlastní Časovou osu. Vzhledem k tomu,
že animované grafické symboly používají stejnou Časovou osu jako hlavní animace,
zobrazují animaci v režimu editace animace. Symboly klipu animace se zobrazí jako
statické objekty na Ploše a nezobrazí se jako animace v editovacím prostředí Flashe.

Nastavení animace grafické instance:

1. Označte grafickou instanci na Ploše a vyberte Window > Panels > Instance 
(Panel instancí);  nebo podržte Alte (ve Windows) nebo Option (na Macintoshi)
a dvakrát klikněte na Plochu, aby se Panel instancí přenesl do popředí.

2. Vyberte volbu animace z kontextového menu v rámci typu instance:

� Loop (Smyčka) opakuje animovanou sekvenci obsaženou v aktuální instanci
pro tolik snímků, v kolika se instance objevuje.

� Play (Přehrát) jednou přehraje animovanou sekvenci od snímku, který určíte,
do konce animace a pak se zastaví.

� Single Frame (Jeden snímek) zobrazí jeden snímek animované sekvence. 
Určete, který snímek se má zobrazit.
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Náhled na definici symbolu pro zvolený symbol Prohlížeče animací:

1. Klikněte na tlačítko Show Buttons (Zobrazit tlačítka), Movie Clips and Graphics
(Klipy animací a grafiku) v horní části Movie Explorer (Prohlížeče animací).

2. Klikněte pravým tlačítkem myši (ve Windows) nebo podržte Control a klikněte
(na Macintoshi) a zvolte Show Symbol Instances (Zobrazit instance) a Go to 
Symbol Definition (Přejít na definici symbolu z kontextového menu); nebo tyto
volby vyberte z kontextového menu v pravém horním rohu Movie Explorer
(Prohlížeče animací).

Skok na scénu obsahující instance zvoleného symbolu:

1. Zobrazte definice symbolu jak bylo popsáno výše.

2. Klikněte pravým tlačítkem myši (ve Windows) nebo podržte Control a klikněte
(na Macintoshi) a vyberte z kontextového menu volby Show Movie Elements 
(Zobrazit prvky animace) a select Symbol Instances (Označit instance symbolu);
nebo vyberte tyto volby z kontextového menu v pravém horním rohu Movie
Explorer (Prohlížeče animací).
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� Pro zobrazení Panelu informací vyberte Window > Panels > Info (Panel 
informací).

� Pro zobrazení Panelu akcí vyberte Okno > Akce.

� Pro zobrazení Prohlížeče animací vyberte Window > Movie Explorer
(Prohlížeč animací).

� Více informací o Prohlížeči animací viz "Používání Prohlížeče animací".
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Vytváření klíčových snímků

Klíčový snímek je snímek, ve kterém definujete změny v animování. Když vytváříte
animaci snímek-za-snímkem, je klíčový snímek každý. V klíčovém snímku
(vykreslované) animace definujete klíčové snímky v důležitých bodech animace
a necháte Flash vytvořit obsah snímků mezi nimi. Flash zobrazí vložené snímky
vykreslované animace světle modře nebo zeleně se šipkou nakreslenou mezi klíčovými
snímky. Flash překreslí tvary v každém klíčovém snímku a tyto byste měli vytvářet
pouze v těch místech vaší práce, ve kterých se něco mění.

Klíčové snímky jsou označeny v Časové ose: klíčový snímek s neprázdným obsahem
je představován plným kroužkem, prázdný klíčový snímek je představován svislou
čárou před snímkem. Následující snímky, které přidáte do stejné vrstvy, budou mít stejný
obsah jako klíčový.

Pro vytvoření klíčového snímku prove.te jedno z následujících:

� Zvolte rám v Časové ose a vyberte Insert > Keyframe (Klíčový snímek).

� Klikněte pravým tlačítkem myši (ve Windows) nebo podržte Control a klikněte
(na Macintoshi) na snímek v Časové ose a vyberte Insert Keyframe (Vložit
klíčový snímek).

Znázornění animací na Časové ose

Flash rozlišuje mezi vykreslovanou (tweened) animací a animací snímek-za-snímkem
v Časové ose následovně:

� Klíčové snímky vykreslující pohyb jsou znázorněny černou tečkou a přechodné
vykreslované snímky mají černou šipku se světlemodrým pozadím.

� Klíčové snímky vykreslující tvar jsou znázorněny černou tečkou a přechodné
snímky mají černou šipku se světlezeleným pozadím.

� Přerušovaná čára znázorňuje chybějící koncový klíčový snímek.
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Vytváření animace

Animaci vytváříte změnou obsahu po sobě jdoucích snímků. Můžete nechat objekt
pohybovat po Ploše, zvětšovat nebo zmenšovat jeho velikost, otáčet s ním, měnit jeho
barvu, přidávat nebo ubírat odstín nebo měnit jeho tvar. Změny mohou nastat
nezávisle na jiných změnách nebo ve shodě s nimi. Například můžete objekt nechat
otáčet a zároveň mu přidávat na odstínu.

Existují dvě metody pro vytváření animovaných sekvencí ve Flashi: animace
snímek-za-snímkem a vykreslovaná (tweened) animace. V animaci snímek-za-snímkem
vytváříte obrázek v každém snímku. Ve vykreslované animaci vytvoříte počáteční
a koncový snímek a necháte Flash vytvořit snímky mezi nimi. Flash změní velikost
objektu, otáčení, barvu a další vlastnosti postupně mezi počátečním a koncovým
snímkem, aby vytvořil zdání pohybu.

Vykreslování je efektivní způsob vytváření pohybu a změn během času, přičemž
zachovává minimální velikost souboru. Ve vykreslované animaci uchovává Flash
pouze hodnoty pro změny mezi snímky. V animaci snímek-za-snímkem uchovává
Flash hodnoty pro každý rám.
Pro interaktivní úvod do animace vyberte Help > Lessons  > Animation.

Poznámka: Animace můžete vytvářet také používání akce Nastavit vlastnosti. 
Viz Referenční příručka ActionScript.
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O rychlostech střídání snímků

Rychlost střídání animace, která je příliš pomalá, způsobí, že animace vypadá, jako
by se zastavovala a začínala; rychlost snímků, která je příliš rychlá rozmazává detaily
animace. Na webu obvykle přináší nejlepší výsledky rychlost 12 snímků za sekundu
(fps). Animace QuickTime a AVI mají obyčejně rychlost střídání snímků 12 fps, zatím-
co standardní rychlost pro obrázky pohybu je 24 fps.
Složitost animace a rychlost počítače, na kterém se animace přehrává, ovlivní hlad-
kost přehrávání. Pro určení optimální rychlosti střídání snímků otestujte svou animaci
na více počítačích.

Vzhledem k tomu, že pro celou animaci Flash určujete pouze jednu rychlost střídání
snímků, je dobré nastavit tuto rychlost předtím, než začnete animovat. Viz "Vytváření
nové animace a nastavení jejích vlastností".

Roztahování statických obrázků

Když vytváříte pozadí animace, je často nutné vytvořit statický obrázek obsažený v
několika snímcích. Přidání nových snímků (ne klíčových) do vrstvy rozšíří obsah
posledního klíčového snímku do všech nových snímků.

Roztažení statického obrázku do více snímků:

1. V prvním klíčovém snímku sekvence vytvořte obrázek.

2. Označte snímek napravo, na konci rozsahu, který chcete přidat.

3. Vyberte Insert > Frame (Snímek).

Použití zkratky pro roztažení statických obrázků:

1. Vytvořte obrázek v prvním klíčovém snímku.

2. Držte Alt a přesuňte snímek myší doprava. To vytvoří nový rozsah, ale bez
koncového klíčového snímku.

O vykreslované animaci

Flash umí vytvářet dva typy vykreslované (tweened) animace. Ve vykreslování pohybu
(motion tweening) definujete vlastnosti jako je umístění, velikost a otáčení pro instanci,
skupinu nebo blok textu v jednom bodě a pak tyto vlastnosti změníte v jiném bodě.
Ve vykreslování tvaru (shape tweening) nakreslíte tvar v jednom bodě a pak tvar
změníte nebo nakreslíte jiný tvar v jiném bodě. Flash vloží hodnoty nebo tvary pro
snímky mezi nimi a vytvoří animaci.
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� Jednoduchý klíčový snímek je označen černou tečkou. Světle šedé snímky 
po jednoduchém klíčovém snímku mají stejný obsah bez žádných změn a mají 
černou čáru s prázdným obdélníkem v poslední snímku.

Malé (a) znamená, že snímku byla přidělena akce snímku v Panelu akcí.

Červený praporek znamená, že snímek obsahuje popis nebo komentář.

O vrstvách v animaci

Každá scéna v animaci Flash se skládá z určitého počtu vrstev. Když animujete,
používáte vrstvy pro organizaci složek animované sekvence a pro oddělení animovaných
objektů, aby se nevygumovaly, nespojily se nebo nerozdělily na úseky. Pokud chcete,
aby Flash vykreslil pohyb několika skupin nebo symbolů najednou, musí každý z nich
být na samostatné vrstvě. Typicky obsahuje vrstva v pozadí statický výtvor. Další
vrstvy obsahují každá jeden oddělený animovaný objekt.

Když má animace několik vrstev, může být sledování a úprava objektů na jedné nebo
dvou vrstvách obtížná. Tento úkol je jednodušší, pokud pracujete v určitou dobu vždy
s obsahem jedné vrstvy. Viz kapitola 8, "Používání vrstev".
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3. Vytvořte druhý klíčový snímek, ve kterém má animace skončit.

4. Pro změnu instance, skupiny nebo bloku textu v koncovém snímku prove.te 
jedno z následujících:

� Přesuňte položku na novou pozici.

� Změňte velikost, otočení nebo zešikmení položky.

� Změňte barvu položky (jen instance nebo blok textu).

� Pro vykreslení barvy jiných prvků než instancí nebo bloků textu použijte 
vykreslení tvaru. Viz "Vykreslení tvarů".

5. Vyberte Window > Panels > Frame (Panel snímku).

6. Jako Tweening (Vykreslení) zvolte Motion (Vykreslení pohybu).

7. Pokud jste v kroku 4 změnili velikost položky, zvolte Scale (Měnit velikost)
pro vykreslení změny velikosti vybrané položky.

8. Klikněte a táhněte šipkou vedle hodnoty Easing (Vyrovnanost) nebo zadejte
hodnotu pro přizpůsobení míry změny mezi vykreslovanými snímky:

� Pro pomalý začátek a zrychlování vykreslování ke konci animace táhněte 
posuvníkem nahoru nebo zadejte hodnotu mezi -1 a -100.

� Pro rychlý začátek a zpomalování vykreslování ke konci animace, táhněte 
posuvníkem dolů nebo zadejte kladnou hodnotu mezi 1 a 100.

� Implicitně je rychlost změn mezi vykreslovanými snímky konstantní. Vyrovnanost
vytvoří přirozenější vzhled zrychlení nebo zpomalení postupným přizpůsobením
rychlosti změn.

9. Pro vykreslení otáčení vybranou položkou vyberte volbu z menu Rotate (Otáčení):

� Vyberte None (Žádné) (implicitní nastavení) pro aplikaci žádného otáčení.

� Vyberte Auto (Automatické) pro otočení objektu jednou ve směru vyžadujícím
nejméně pohybu.

� Vyberte CW – Clockwise (Ve směru hodinových ručiček) nebo CCW 
– Counterclockwise (Proti směru hodinových ručiček) a pro tato otočení
objektu a zadejte číslo určující počet rotací.

Poznámka: Toto otočení je doplněním jakéhokoliv otáčení aplikovaného na koncový
snímek v kroku 4.
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Vykreslování instancí, skupin a písma

Pro vykreslení změn ve vlastnostech instancí, skupin a písma použijete vykreslení
pohybu. Flash umí vykreslovat umístění, velikost, otáčení a zešikmení instancí, skupin
a písma. Dále umí Flash vykreslovat barvu instancí a písma vytvářením postupných
barevných změn nebo přidáváním či ubíráním odstínu. Pro vykreslení barvy skupin
nebo písma, je musíte nejprve změnit na symboly. Viz "Vytváření symbolů".

Když změníte počet snímků mezi dvěma klíčovými snímky nebo přesunete skupinu
nebo symbol do jednoho z klíčových snímků, Flash automaticky vykreslí snímky
znovu.

Pohyb můžete vykreslit pomocí dvou metod:

� Vytvořte počáteční a koncový klíčový snímek pro animaci a použijte volbu
Motion Tweening (Vykreslení pohybu) ve Frame Properties (Panelu vlastností)
snímku.

� Vytvořte první klíčový snímek animace a pak vyberte Insert > Create Motion 
Tween (Vytvořit vykreslení pohybu) a přesuňte objekt na nové místo na Ploše.

� Flash automaticky vytvoří koncový klíčový snímek.

� Při vykreslování umístění můžete objekt nechat pohybovat se po nelineární 
trase. Viz "Vykreslení pohybu podél trasy".

Vytvoření vykreslení pohybu použitím volby Vykreslení pohybu:

1. Klikněte na název vrstvy, aby se stala aktuální  a označte prázdný klíčový snímek.

2. Vytvořte na Ploše instanci, skupinu nebo blok textu nebo přetáhněte myší 
instanci symbolu z okna Knihovna.

� Pro vykreslení pohybu objektu, který jste nakreslili, jej musíte konvertovat
do symbolu.
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6. Pokud jste v kroku 4 změnili velikost položky, vyberte Scale (Měnit velikost) 
pro vykreslení velikosti vybrané položky.

7. Klikněte a táhněte šipkou vedle hodnoty Easing (Vyrovnanost) nebo zadejte
hodnotu pro přizpůsobení velikosti změny mezi vykreslovanými snímky:

� Pro pomalý začátek a zrychlení vykreslení pohybu ke konci animace, táhněte 
posuvníkem nahoru nebo zadejte hodnotu mezi -1 a -100.

� Pro rychlý začátek a zpomalování vykreslení pohybu směrem ke konci animace
táhněte posuvníkem dolů nebo zadejte kladnou hodnotu mezi 1 a 100.

� Implicitně je míra změny mezi vykreslovanými snímky konstantní. 
Vyrovnanost vytvoří přirozenější vzhled zrychlování nebo zpomalování animace
postupným přizpůsobením míry změny.

8. Pro otáčení zvoleným objektem během vykreslování vyberte volbu z menu Rotate
(Otáčení):

� Vyberte None (Žádné) (implicitní nastavení) pro aplikaci žádného otáčení.

� Vyberte Auto (Automatické) pro otočení objektu jednou ve směru vyžadujícím
nejméně pohybu.

� Vyberte CW – Clockwise (Ve směru hodinových ručiček) nebo CCW 
– Counterclockwise (Proti směru hodinových ručiček) pro tato otočení
objektu a zadejte číslo určující počet rotací.

Poznámka: Toto otočení je doplněním jakéhokoliv otáčení aplikovaného na koncový
snímek v kroku 4.

9. Pokud používáte trasu animace, vyberte Orient to Path (Orientovat na trasu)
pro orientaci základní linky prvku na trasu pohybu. Viz "Vykreslování pohybu 
podél trasy".

10. Zvolte Synchronize (Synchronizace), abyste zajistili, že instance správně 
utvoří smyčku v hlavní animaci.

� Příkaz Synchronizovat použijte pokud počet snímků v animované sekvenci 
uvnitř symbolu není sudým násobkem počtu snímků v animaci zahrnujících 
grafickou instanci.

11. Pokud používáte trasu pohybu, vyberte Snap (Ukotvit), aby se vykreslovaný 
prvek připojil k trase pohybu svým registrovaným bodem.
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10. Pokud používáte trasu animace, vyberte Orient to Path (Orientovat na trasu)
pro orientaci základní linky prvku na trasu pohybu. Viz "Vykreslování pohybu
podél trasy".

11. Zvolte Synchronization (Synchronizace), abyste zajistili, že instance správně 
utvoří smyčku v hlavní animaci.

� Příkaz Synchronize (Synchronizovat) použijte pokud počet snímků v animované
sekvenci uvnitř symbolu není sudým násobkem počtu snímků v animaci
zahrnujících grafickou instanci.

12. Pokud používáte trasu pohybu, vyberte Snap (Ukotvit), aby se vykreslovaný 
prvek připojil k trase pohybu svým registrovaným bodem.

Vytvoření vykreslení pohybu použitím příkazu Vytvořit vykreslení pohybu:

1. Vyberte prázdný klíčový snímek a nakreslete objekt na Plochu nebo přetáhněte
instanci symbolu z okna Knihovna.

2. Vyberte Insert  > Create Motion Tween (Vytvořit vykreslení pohybu).

� Pokud jste v kroku 1 nakreslili objekt, Flash tento objekt automaticky
převede na symbol a přiřadí mu jméno Tween1 (vykreslení1). Pokud jste 
nakreslili více než jeden objekt, jsou další objekty pojmenovány Tween2 
(vykreslení2), Tween3 (vykreslení3) a tak dále.

3. Klikněte na snímek kde má animace skončit, a vyberte Insert > Frame (Snímek).

4. Přesuňte objekt, instanci nebo blok textu do požadovaného místa na Ploše. 
Přizpůsobte velikost prvku, pokud chcete vykreslit změnu jeho velikost.
Přizpůsobte otočení prvku, pokud chcete vykreslit jeho otáčení. Odznačte 
objekty, když učiníte všechna přizpůsobení.

� Klíčový snímek je automaticky přidán na konec řady snímků.

5. Označte koncový klíčový snímek vykreslení pohybu a vyberte Window >
Panels > Frame (Panel snímku). V Panelu snímku by automaticky mělo být
označeno Motion Tweening (Vykreslení pohybu).
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5. Pro skrytí vodící vrstvy pohybu a čáry pohybu tak, aby byl během vaší práce 
vidět pouze pohyb objektu, klikněte na sloupec Eye (Oko) ve vodící vrstvě 
pohybu.

� Skupina nebo symbol následuje při přehrávání animace trasu pohybu.

� Pro napojení vrstev na vodící vrstvu prove.te jedno z následujících:

� Přetáhněte existující vrstvu bod vodící vrstvu pohybu. Vrstva je vsazena pod 
vodící vrstvu pohybu. Všechny objekty na této vrstvě jsou automaticky
ukotveny na vodící trasu.

� Vytvořte novou vrstvu pod vodící vrstvou pohybu. Objekty, které na této vrstvě 
vykreslíte, budou automaticky vykresleny podél trasy pohybu.

� Vyberte vrstvu pod vodící vrstvou pohybu. Vyberte Modify > Layer (Vrstva) 
a zvolte Guided (Řízená) v dialogovém okně Layer Properties (Vlastnosti vrstvy).

� Podržte Alt (ve Windows) nebo Option (na Macintoshi) a klikněte na vrstvu.

Odpojení vrstev od vodící vrstvy pohybu:

1. Označte vrstvu, kterou chcete odpojit.

2. Prove.te jedno z následujících:

� Přetáhněte vrstvu pod vodící vrstvu pohybu.

� Vyberte Modify  > Layer (Vrstva) a vyberte Normal (Normální typ vrstvy)
v dialogovém okně Layer Properties (Vlastnosti vrstvy).

� Podržte Alt (ve Windows) nebo Option (na Macintosthi) a klikněte na vrstvu.
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Vykreslování pohybu po trase

Vodící vrstvy pohybu vám umožní nakreslit trasy, po nichž budou animovány vykreslované
instance, skupiny nebo bloky textu. Na vodící vrstvy pohybu můžete odkázat více vrstev,
aby stejnou trasu následovalo více objektů. Normální vrstva, která je vázaná na vodící
vrstvu, se stává řízenou vrstvou.

Vytvoření trasy pohybu pro vykreslovanou animaci:

1. Vytvořte animaci vykreslující pohyb, jak bylo popsáno ve "Vykreslování
instancí, skupin a písma".

� Pokud zvolíte Orient to Path (Orientovat na trasu), bude základní osa 
vykreslovaného prvku orientovaná na trasu pohybu. Pokud zvolíte Snap (Ukotvit),
ukotví se registrovaný bod prvku na vodící trasu.

2. Prove.te jedno z následujících:

� Označte vrstvu obsahující animaci a vyberte Insert  > Motion Guide (Vodit
pohyb).

� Klikněte pravým tlačítkem myši (ve Windows) nebo podržte Control a klikněte
(na Macintoshi) na vrstvu obsahující animaci a vyberte Add Motion Guide
(Přidat vodící vrstvu) pohybu z kontextového menu.

� Flash vytvoří novou vrstvu nad označenou vrstvou s ikonou vodícího pohybu
nalevo od jména vrstvy.

3. Použijte nástroj Pero, Tužka, Čára, Kruh, Obdélník nebo Štětec pro nakreslení
požadované trasy.

4. Ukotvěte střed na začátek čáry prvního snímku a na konec čáry v posledním
snímku.

Poznámka: Pro nejlepší ukotvení táhněte symbolem za jeho registrovaný bod.
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8. Vyberte volbu pro Blend (Tvorbu přechodových efektů):

� Distributive (Distribuční) vytvoří animaci, ve které jsou přechodné tvary hladší 
a méně pravidelné.

� Angular (Rohová) vytvoří animaci, která zachová jasné rohy a rovné čáry
v přechodných tvarech.

Poznámka: Rohová je vhodná pouze pro tvary s přechodovými efekty s ostrými rohy
a rovnými čárami. Pokud tvary, které vyberete, nemají rohy, Flash se přepne do
distribučního vykreslování tvarů.

Používání stop tvarů

Pro kontrolu složitějších a netradičních změn tvarů můžete použít Shape Hints (Stopy
tvarů).
Stopy tvarů určí body, které by měly sobě odpovídat v počátečních a koncových
tvarech. Například pokud vykreslujete kresbu obličeje, jak mění výraz, můžete použít
stopu tvaru pro označení každého oka. Pak, místo toho, aby se obličej stal amorfní
změtí při změně tvaru, každé oko zůstane rozpoznatelné a změní se zvlášX během posunu.

Stopy tvarů obsahují písmena (od a do z) pro určení toho, které body si odpovídají
v počátečním a koncovém tvaru. Můžete použít až 26 stop tvarů. Stopy tvarů jsou
v počátečním klíčovém snímku žluté a v koncovém klíčovém snímku zelené.
Když nejsou na křivce, jsou stopy červené.
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Vykreslování tvarů

Pomocí Tweening Shapes (Vykreslování tvarů) můžete vytvářet efekt podobný
morfingu, způsobující, že určitý tvar bude vypadat jako by se postupem času měnil
na jiný. Flash může také vykreslit umístění, velikost a barvu tvarů.

Nejlepší je vykreslení jednoho tvaru za určitý časový úsek. Pokud vykreslujete najednou
více tvarů, musí všechny být na stejné vrstvě.

Flash neumí vykreslit tvar skupin, symbolů, bloků textu nebo bitmapových obrázků.
Pro aplikaci vykreslení na tyto prvky použijte Modify > Break Apart (Rozdělit). 
Viz "Rozdělování skupin a objektů".

Pro kontrolu složitých nebo svérázných změn tvaru použijte stopy tvaru, které kontrolují,
jak jsou části původního tvaru přesouvány na nový tvar. Viz "Používání stop tvarů".

Vykreslení tvaru:

1. Klikněte na název vrstvy, aby se stala aktuální vrstvou, a vyberte prázdný 
klíčový snímek, ve kterém má začít animace.

2. Vytvořte obrázek pro první snímek sekvence.

� Pro vytvoření tvaru použijte jakékoliv kreslící nástroje.

3. Vytvořte druhý klíčový snímek následující po požadovaném počtu snímků.

4. Vytvořte obrázek pro poslední snímek sekvence. (Můžete vykreslit tvar, 
barvu nebo umístění obrázku vytvořeného v kroku 2.)

5. Vyberte Window  > Panels > Frame (Panel snímku).

6. Jako Tweening (Vykreslení) vyberte Shape (Tvar).

7. Klikněte a táhněte šipkou pro hodnotu Easing (Vyrovnání) nebo zadejte
hodnotu pro přizpůsobení míry změny mezi dvěma vykreslovanými snímky:

� Pro pomalý začátek a zrychlení vykreslení pohybu ke konci animace, táhněte 
posuvníkem nahoru nebo zadejte hodnotu mezi -1 a -100.

� Pro rychlý začátek a zpomalování vykreslení pohybu směrem ke konci animace
táhněte posuvníkem dolů nebo zadejte kladnou hodnotu mezi 1 a 100.

� Implicitně je míra změny mezi vykreslovanými rámy konstantní. Vyrovnanost
vytvoří přirozenější vzhled zrychlování nebo zpomalování animace postupným
přizpůsobením míry změny.
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Vytváření animací snímek-za-snímkem

Animace snímek-za-snímkem mění obsah Plochy v každém snímku a je nejvíce vhodná
pro složité animace, ve kterých se každý snímek mění namísto postupného vykreslení
pohybu. Tento druh animace zvyšuje velikost souboru mnohem rychleji než vykreslovaná
animace.

Vytvoření animace snímek-za-snímkem:

1. Klikněte na jméno vrstvy, aby se stala aktuální vrstvou, a zvolte snímek ve vrstvě,
kde chcete animaci začít.

2. Pokud snímek dosud není klíčový, vyberte Insert > Keyframe (Klíčový snímek).

3. Vytvořte obrázek pro první snímek sekvence.

� Můžete použít kreslící nástroje, vkládat grafiku ze Schránky nebo importovat 
soubor.

4. Klikněte na další snímek napravo ve stejné řadě a vyberte Insert > Keyframe
(Klíčový snímek) nebo klikněte pravým tlačítkem myši (ve Windows) nebo
podržte Control a klikněte (na Macintoshi) a vyberte Insert Keyframe (Vložit 
klíčový snímek) z kontextového menu Frame (Snímek).

� To přidá nový klíčový snímek, jehož obsah bude stejný jako obsah prvního 
klíčového snímku.
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Pro nejlepší výsledky při vykreslování tvarů následujte tyto rady:

� Ve složitém vykreslování tvarů vytvořte přechodné tvary a vykreslete je namísto
pouhého definování počátečního a koncového bodu.

� Ujistěte se, že stopy tvarů jsou logické. Například pokud používáte tři stopy
tvaru pro trojúhelník, musí být ve stejném pořadí na původním trojúhelníku 
a trojúhelníku, který má být nakonec vykreslený. Pořadí nemůže být v prvním
klíčovém rámu abc a v druhém acb.

� Stopy tvarů nejlépe fungují, pokud je umístíte v pořadí proti směru hodinových
ručiček začínajícím v levém horním rohu tvaru.

Použití stop tvarů:

1. Označte první klíčový snímek v sekvenci vykreslující tvar.

2. Vyberte Modify > Transform > Add Shape Hint (Přidat stopu tvaru).

� Počáteční tvar se zobrazí jako červené kolečko s písmenem v některém 
místě tvaru.

3. Posuňte stopu do bodu, který chcete označit.

4. Zvolte poslední klíčový snímek ve vykreslovací sekvenci.

� Koncová stopa tvaru se zobrazí někde na tvaru jako zelené kolečko 
s písmenem a.

5. Přesuňte stopu tvaru do bodu v koncovém tvaru, který by měl odpovídat 
prvnímu bodu, který jste označili.

6. SpusXte znovu animaci, abyste viděli, jak stopa tvaru změní vykreslení tvaru.
Posunujte stopami pro doladění vykreslování.

7. Opakujte tento proces pro přidání dalších stop tvaru. Nové stopy se objeví
s dalšími písmeny (b, c, a tak dále).

� Při práci se stopami tvarů můžete také provádět následující:

� Abyste viděli stopy tvarů, vyberte View > Show Shape Hints (Zobrazit stopy
tvaru). Vrstva a klíčový snímek, které obsahují stopy tvaru, musí být aktuální,
aby tato volba byla k dispozici.

� Pro odstranění stopy tvaru jej myší táhněte mimo Plochu.

� Pro odstranění všech stop tvaru vyberte Modify > Transform > Remove All Hints
(Odstranit všechny stopy).
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Pro vymazání nebo změnu snímku nebo klíčového snímku prove.te jedno z následujících:

� Pro vymazání snímku, klíčového snímku nebo sekvence snímků označte 
snímek, klíčový snímek nebo sekvenci a vyberte Insert > Remove Frame 
(Odstranit snímek) nebo klikněte pravým tlačítkem myši (ve Windows) nebo
podržte Control a klikněte (na Macintoshi) na snímek, klíčový snímek nebo 
sekvenci a vyberte Remove Frame (Odstranit snímek) z kontextového menu. 
Okolní snímky zůstanou nezměněny.

� Pro přesun klíčového snímku nebo sekvence snímků a jejího obsahu,
přetáhněte myší klíčový snímek nebo sekvenci do požadovaného místa.

� Pro zvýšení délky trvání klíčového snímku podržte Alt (ve Windows) nebo Option
(na Macintoshi) a táhněte myší klíčový snímek na konečný snímek nové 
sekvence.

� Pro kopírování klíčového snímku nebo sekvence snímků přetáhnutím
pomocí myši podržte Alt (ve Windows) nebo Option (na Macintoshi) a klikněte 
a přetáhněte klíčový snímek do nového místa.

� Pro kopírování a vkládání snímku nebo sekvence snímků označte snímek 
nebo sekvenci a vyberte Edit  > Copy Frames (Kopírovat snímky). Označte 
snímek nebo sekvenci, které chcete nahradit a vyberte Edit  > Paste Frames 
(Vložit snímky).

� Pro změnu klíčového snímku na normální snímek, označte klíčový snímek 
a vyberte Insert  > Clear Keyframe (Vymazat klíčový snímek) nebo klikněte 
pravým tlačítkem myši (ve Windows) nebo podržte Control a klikněte (na 
Macintoshi) na klíčový snímek a vyberte Clear Keyframe (Vymazat klíčový 
snímek) z kontextového menu. Vymazaný klíčový snímek a všechny následující 
až po další klíčový snímek jsou nahrazeny obsahem klíčového snímku 
předcházejícího vymazání klíčového snímku.

� Pro změnu délky vykreslované sekvence táhněte myší za počáteční nebo
koncový snímek doleva nebo doprava. Změnu délky animace snímek-
za-snímkem viz "Vytváření animací snímek-za-snímkem".

� Pro přidání položky z knihovny do aktuálního klíčového snímku přetáhněte
položku z okna Knihovna na Plochu.

� Pro obrácení pořadí sekvence animace, označte odpovídající snímky na jedné
nebo více vrstvách a vyberte Modify  > Frames > Reverse (Obrátit pořadí).
Na začátku a konci každé sekvence musí být klíčové snímky.
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5. Změňte obsah tohoto snímku na Ploše, pro návrh následujícího vývoje animace.

6. Pro dokončení sekvence animace snímek-za-snímkem opakujte kroky 4 a 5
dokud nevytvoříte požadovaný pohyb.

7. Pro test animované sekvence vyberte Control  > Play (Přehrát) nebo klikněte
na tlačítko Play (Přehrát) na  Controller (Ovladači).

Úpravy animace

Poté, co vytvoříte snímek nebo klíčový snímek, můžete jimi pohybovat kamkoliv
v rámci aktuální vrstvy nebo do jiné vrstvy, odstraňovat je a dělat jiné změny.
Upravitelné jsou pouze klíčové snímky. Můžete prohlížet vykreslované snímky,
ale nemůžete je přímo upravovat. Vykreslované snímky upravíte změnou jednoho
z definujících klíčových snímků nebo vložením nového klíčového snímku mezi
počáteční a koncový klíčový snímek. Pro přidání položek do aktuálního klíčového
snímku můžete položky přetahovat z okna Knihovna na Plochu.

Pro zobrazení a editaci více snímků najednou použijte metodu Onion skinning
(průklepových papírů).

Pro vložení snímků v Časové ose prove.te jedno z následujících:

� Pro vložení nového snímku vyberte Insert > Frame (Snímek).

� Pro vytvoření nového klíčového snímku vložte Insert > Keyframe (Klíčový 
snímek) nebo klikněte pravým tlačítkem myši (ve Windows) nebo podržte 
Control a klikněte (na Macintoshi) na snímek, kde chcete umístit klíčový 
snímek, a vyberte Insert Keyframe (Vložit klíčový snímek) z kontextového menu.

� Pro vytvoření nového prázdného klíčového snímku vyberte Insert > Blank
Keyframe (Prázdný klíčový snímek) nebo klikněte pravým tlačítkem myši 
(ve Windows) nebo podržte Control a klikněte (na Macintoshi)  na snímek, 
kde chcete umístit klíčový snímek, a vyberte Insert Blank Keyframe (Vložit 
prázdný klíčový snímek) z kontextového menu.
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� Pro umožnění editace všech snímků mezi značkami průklepového papíru 
klikněte na tlačítko Edit Multiple Frames (Úpravy více snímků). 

� Obvykle vám průklepový papír umožní upravovat pouze aktuální vrstvu.
Nicméně můžete zobrazit obsahy všech snímků mezi značkami průklepového
papíru normálně a umožnit editaci každého z nich, nezávisle na tom, který
rám je aktuální. 

Poznámka: Zamknuté vrstvy (ty s ikonou visacího zámku) nejsou zobrazeny, když
je aktivní volba průklepového papíru.  Abyste se vyhnuli velkému množství matoucích
obrázků, můžete zamknout nebo skrýt vrstvy, které nemají být zobrazeny jako
průklepový papír.

Změna zobrazení značek průklepového papíru:

� Klikněte na tlačítko Modify Onion Makers (Změnit značky průklepového papíru) 
a vyberte si položku z menu:

� Always Show Makers (Vždy ukazovat značky) zobrazí značky průklepového
papíru na Časové ose, aX už je průklepový papír aktivní nebo ne.

� Anchor Onion Makers (Ukotvit značky průklepového papíru) zamkne 
značky na jejich aktuálním umístění v záhlaví Časové osy. Normálně rozsah 
Průklepového papíru odpovídá ukazateli aktuálního snímku a značkám 
Průklepového papíru. Ukotvením značek Průklepového papíru předejdete
posunu ukazatele aktuálního snímku.

� Onion 2 (Proklepnout 2) zobrazí dva snímky na každé straně aktuálního snímku.

� Onion 5 (Proklepnout 5) zobrazí pět snímků na každé straně aktuálního snímku.

� Onion All (Proklepnout vše) zobrazí všechny snímky na obou stranách 
aktuálního snímku.
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Metoda průklepových papírů

Flash normálně zobrazuje jeden snímek sekvence animace na Ploše. Pro usnadnění
umístění a úprav animace snímek-za-snímkem můžete prohlížet dva nebo více snímků
na Ploše najednou. Přehrávající se snímek je zobrazen plnou barvou, zatímco okolní
snímky jsou ztlumeny, aby vypadaly jako by byly nakresleny na průsvitném průklepovém
papíře a listy byly vyrovnány jeden na druhém. Tlumené snímky nemohou být upravovány.

Současný náhled na několik snímků animace na Ploše:

� Klikněte na tlačítko Onion Skin (Průklepový papír). 

� Všechny snímky mezi značkami Start Onion Skin (Začátek průklepového 
papíru) a End Onion Skin (Konec průklepového papíru) (v záhlaví Časové osy)
jsou navrstveny jako jeden snímek v okně Animace.

Pro kontrolu zobrazení průklepových papírů prove.te jedno z následujících:

� Pro zobrazení snímků typu průklepových papírů jako obrysy klikněte na tlačítko
Onion Skin Outlines (Průklepový papír obrys).

� Pro změnu umístění jedné ze značek průklepového papíru přetáhněte
její ukazatel na nové místo. (Normálně se značky průklepového papíru pohybují
společně s aktuálním ukazatelem snímku.)
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KAPITOLA 12

Vytváření interaktivních animací

V jednoduchých animacích přehrává Flash scény a snímky sekvenčně. V interaktivních
animacích používají vaši diváci klávesnici, myš nebo obojí pro přeskakování do jiných
částí animace, přesun objektů, zadávání informací do formulářů a provádění mnoha
dalších operací.

Interaktivní animace vytváříte vyvoláním akcí - sad instrukcí napsaných v ActionScript,
které se spustí a poběží, když nastane určitá událost. Události, které mohou spustit
akci jsou bu. dosažení snímku při přehrávání nebo kliknutí na tlačítko nebo mačkání
kláves na klávesnici uživatelem.

Akce pro tlačítko, klip animace nebo snímek nastavíte v Actions panel (Panelu akcí).
Použitím Panelu akcí v Normal Mode (Normálním režimu) můžete vkládat akce bez
toho, abyste je museli napsat v ActionScript; pokud jste v ActionScript zdatní, můžete
napsat vlastní skript. Instrukce mohou být ve formě jedné akce, jako je pokyn animaci,
aby se přestala přehrávat, nebo řady akcí, jako je nejprve stanovení podmínky a pak
provedení akce. Mnoho akcí vyžaduje ke svému nastavení minimum programovacích
zkušeností. Jiné akce vyžadují určitou znalost programovacích jazyků a jsou zaměřeny
na další rozvoj, informace o vytváření pokročilých akcí viz Referenční příručka
ActionScript.

O ActionScript

Flash používá skriptovací jazyk ActionScript pro přidání interaktivity do animace.
Podobně jako u JavaScriptu, ActionScript je jazyk objektově (object) orientovaného
programování. V objektově orientovaném skriptování organizujete informace
seřazením do skupin nazývaných třídy (classes). Můžete vytvářet více instancí třídy,
zvaných objekty, které použijete ve svých skriptech. Můžete použít předdefinované
třídy ActionScript a vytvářet své vlastní. 
Když vytváříte třídu, definujete všechny vlastnosti (charakteristiky(characteristics)) a metody
(chování(behaviors)) každého objektu, které vytvoří, stejně jako se definují objekty
ve skutečném světě. Například osoba má vlastnosti jako pohlaví, výšku a barvu vlasů
a vlastnosti jako mluvení, chůzi a hod. V tomto případě je "osoba" třída a každá
individuální osoba je objektem neboli instancí této třídy.
Objekty v ActionScript mohou obsahovat data nebo mohou být na Ploše graficky
reprezentovány klipy animace.
Více informací o těchto termínech a jejich použití viz Referenční příručka ActionScript.
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Přesun celé animace

Pokud potřebujete přesunout celou animací na Ploše, musíte přesunout grafiku ve všech
snímcích a vrstvách najednou, abyste se vyhnuli zarovnávání všeho.

Přesun celé animace do jiného místa na Ploše:

1. Odemkněte všechny vrstvy.

� Pro přesun všeho na jedné nebo více vrstvách a ničeho na jiných vrstvách
zamkněte  nebo skryjte vrstvy, se kterými nechcete pohybovat.

2. Klikněte na tlačítko Edit Multiple Frames (Úpravy více snímků) na Časové ose.

3. Táhněte značkami průklepového papíru, takže obklopí všechny snímky, 
které chcete označit, klikněte na Modify Onion Makers (Změnit značky 
průklepového papíru) a vyberte Onion All (Proklepnout vše)

4. Zvolte Edit > Select All (Vybrat vše).

5. Přetáhněte celou animaci do nového místa na Ploše.
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� Každý skript zachovává svůj vlastní režim. Například pokud vytvoříte ve skriptu
jednu instanci tlačítka v Normálním režimu a další v Odborném režimu, přepnutí 
mezi označenými tlačítky přepne režim panelu.

Používání Panelu akcí v Normálním režimu

V Normal Mode (Normálním režimu) vytváříte akce výběrem akcí ze seznamu na levé
straně panelu, nazvaném Toolbox List (Seznam panelu nástrojů). Seznam panelu
nástrojů obsahuje kategorie Basic Actions (Základní akce), Actions (Akce), Operators
(Operátory), Functions (Funkce), Properties (Vlastnosti) a Objects (Objekty). Kategorie
Basic Actions (Základní akce) zahrnuje nejjednodušší akce Flashe a je dostupný jen
v Normálním režimu. Zvolené akce jsou uvedeny na pravé straně panelu, v Seznamu akcí.
Do pořadí v přehledu akcí můžete přidávat nové akce, mazat je nebo měnit jejich
pořadí; můžete také zadávat parametry (argumenty) pro akce v políčku Parametry
ve spodní části panelu.
V Normálním režimu použijete ovladače v Panelu akcí pro mazání nebo změnu pořadí
a parametrů přehledu. Tyto ovladače jsou obzvláš6 užitečné pro ovládání akcí snímku
nebo tlačítka, které mají dlouhý přehled.

Označení akce:

1. Klikněte na kategorii Akce v Panelu nástrojů pro zobrazení akcí v této kategorii.

2. Dvakrát klikněte na akci nebo ji přetáhněte do Seznamu akcí napravo.
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Používání Panelu akcí

Panel akcí vám umožňuje vytvářet a upravovat akce objektu nebo snímku použitím
dvou editovacích režimů.  Můžete si vybrat předepsané akce ze Toolbox list (Seznamu
panelu nástrojů), akce táhni a pus6 a používat tlačítka pro mazání nebo přeuspořádání
akcí. V Normal Mode (Normálním režimu) můžete psát akce používáním parametrových
(argumentových) polí, které vás navedou na správné argumenty. V Expert Mode
(Odborném režimu) můžete psát a upravovat akce přímo v textovém poli, velmi
podobně jako je tomu při psaní skriptu v textovém editoru.
Více informací o vybírání voleb Panelu akcí a přepínání mezi editovacími režimy
viz odpovídající témata v Referenční příručce ActionScript.

Zobrazení Panelu akcí:

� Vyberte Window  > Actions (Akce).

� Označení snímku nebo instance tlačítka nebo klipu animace způsobí, že Panel 
akcí bude aktivní. Název Actions panel (Panel akcí) se změní na Object Action 
(Akce objektu), je-li označeno tlačítko nebo klip animace, a na Frame Actions 
(Akce snímku), je-li označen snímek.

Volba editovacího režimu akcí:

1. Se zobrazeným Panelem akcí klikněte na šipku v pravém horním rohu panelu,
aby se zobrazilo kontextové menu.

2. Vyberte Normal Mode (Normální režim) nebo Expert Mode (Odborný režim)
z kontextového menu.
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Odborný režim

V Expert Mode (Odborném režimu) vytváříte akce vložením ActionScript do textového
pole na pravé straně panelu nebo výběrem akcí ze Seznamu panelu nástrojů vlevo.
Akce upravujete, zadáváte jejich parametry nebo je mažete přímo v textovém poli,
podobně jako byste tvořili skript v textovém editoru.
Odborný režim umožňuje pokročilým uživatelům upravovat své skripty v textovém
editoru jako by používali JavaScript nebo VBScript. Odborný režim se od Normálního
režimu odlišuje v těchto věcech:

� Označení položky v kontextovém menu Add (Přidat) nebo v Seznamu panelu
nástrojů vloží položku do oblasti pro úpravu textu na pozici ukazatele.

� Neobjeví se žádné textové pole pro parametry.

� V panelu tlačítek funguje pouze tlačítko Add (Přidat) (+).

� Tlačítka Šipka nahoru a Šipka dolů zůstávají neaktivní.

� Více informací o používání Odborného režimu viz téma v Referenční příručce
ActionScript.
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Použití políčka Parametry:

1. Klikněte na trojúhelník v pravém dolním rohu Panelu akcí, aby se zobrazilo
políčko Parameters (Parametry).

2. Vyberte akci a zadejte nového hodnoty do textových polí parametrů, abyste
změnili parametry existujících akcí.

Vložení cílové trasy klipu animace:

1. Klikněte na tlačítko Target Path (Cílová trasa) v pravém dolním rohu Panelu
akcí, aby se zobrazilo dialogové okno Target Path (Cílová trasa).

2. Ze zobrazeného seznamu vyberte klip animace.

Informace o používání cílové trasy viz "Ovládání dalších animací a klipů animací".

Posun příkazu akce nahoru nebo dolů v seznamu:

1. Vyberte příkaz v Seznamu akcí.

2. Klikněte na tlačítko Šipka nahoru nebo Šipka dolů v Panelu akcí.

Vymazání akce:

1. Označte příkaz v Seznamu akcí.

2. Klikněte na tlačítko Delete (Vymazat) (-).

� Pro změnu velikosti Seznamu panelu nástrojů nebo Seznamu akcí proveMte
jedno z následujících:

� Táhněte vertikální rozdělovací lištou, která je mezi Seznamem panelu nástrojů
a Seznamem akcí.

� Dvakrát klikněte na rozdělovací lištu, aby se sbalil Seznam panelu nástrojů,
znovu dvakrát klikněte pro opětovné zobrazení seznamu.

� Klikněte na tlačítko Šipka vlevo nebo Šipka vpravo na rozdělovací liště, aby
se seznam rozbalil nebo sbalil.

� Když je Seznam panelu nástrojů skryt, můžete stále přistupovat k jeho
položkám použitím tlačítka Add (Přidat) (+) v levé horní části Panelu akcí.
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� Použijte klávesovou zkratku.

� Pokud jste označili klip animace, Flash automaticky vloží akci On Clip Event
(Událost aktivního klipu) a akci, kterou jste zvolili v Seznamu akcí. Pokud jste
označili tlačítko, Flash automaticky vloží kód On Mouse Event (Události 
aktivní myši) , aby vyvolal zvolenou akci.

4. Pro zobrazení políčka Parameters (Parametry) klikněte na trojúhelník v pravém
dolním rohu Panelu akcí. Zvolte akci a zadejte nové hodnoty do textových 
polí Parametry, čímž změníte parametry existujících akcí.

� Parametry se liší v závislosti na akci, kterou si vyberete. Například implicitním
parametrem On Clip (Aktivního klipu) je Load. Informace o parametrech pro
nejčastěji používané akce viz "Používání základních akcí pro manévrování 
a interakci".

5. Opakujte kroky 3 a 4 pro přiřazení dalších akcí, pokud je to třeba.
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Přiřazování akcí objektům

Akci můžete přiřadit tlačítku nebo klipu animace, aby se spustila, když uživatel klikne
na tlačítko nebo přes něj přejede ukazatelem, nebo když se klip animace nahraje
nebo dosáhne určitého snímku. Akci přiřadíte instanci tlačítka nebo klipu animace;
další instance symbolu to neovlivní. Popis akce, který můžete přidat, viz "Používání
základních akcí pro manévrování a interakci".

Když přiřadíte akci tlačítku nebo klipu animace, Flash automaticky přiřadí speciální
akci nazvanou ovladač - akci On Mouse Event (Událost aktivní myš)i pro tlačítka nebo
akci On Clip Event (Událost aktivního klipu) pro klipy animace. Ovladač ovládá
událost určitým způsobem a zahrnuje skupiny příkazů ActionScript, které se spustí,
když nastane určitá událost. Každý ovladač začíná slovem on nebo onClipEvent
následovaným události, na kterou odpovídá ovladač.

Události (events) jsou akce, které nastanou během přehrávání animace - například
natažení klipu animace, přehrávání na určitém snímku nebo zmáčknutí klávesy
uživatelem. Můžete určit událost myši nebo klávesy, která spustí akci; viz "Nastavení
voleb akce myši". Můžete také určit událost klipu, která vyvolá akci; viz Referenční
příručka ActionScript.
Když jste přiřadili akci, doporučuje se otestovat, zda funguje. V editovacím režimu fungují
jen jednoduché akce rámu jako Go to and Play. Následující instrukce popisují, jak nastavit
akce pro objektu použitím Panelu akcí v Normálním režimu. Informace o používání
Panelu akcí v Odborném režimu viz Referenční příručka ActionScript.

Přiřazení akce tlačítku nebo klipu animace:

1. Označte instanci tlačítka nebo klipu animace a vyberte Window > Actions (Akce).

� Pokud není výběr instancí tlačítka, nebo klipu animace, nebo snímek, nebo 
pokud výběr zahrnuje více objektů, bude Panel akcí ztlumen.

� (Informace o přiřazování akcí rámu viz "Přiřazování akcí rámům".)

2. V Seznamu panelu nástrojů v levé části panelu klikněte na kategorii Basic
Actions (Základní akce) pro zobrazení základních akcí.

� Popis akcí, který můžete přidat, viz "Používání základních akcí pro 
manévrování a interakci".

3. Pro přiřazení akce proveMte jedno z následujících:

� Dvakrát klikněte na akci v kategorii Basic Actions (Základní akce).

� Přetáhněte akci z kategorie Základní akce nalevo od Seznamu akcí na pravou
stranu panelu.

� Klikněte na tlačítko Add (Přidat) (+) a vyberte akci z kontextového menu.

KAPITOLA 12 - Správa sítě 239



� Drag Out (Přetáhnout ven) spustí akci, když je zmáčknuto tlačítko myši a ukazatel 
přejede mimo tlačítko.

5. PřiřaMte tlačítku jakékoliv další akce.

� Více informací o událostech myši viz Referenční příručka ActionScript.

Testování akcí rámu:

1. Vyberte Control > Enable Simple Frame Actions (Umožnit jednoduché akce 
snímku).

2. Vyberte Control > Test Movie (Testovat animaci).

Přiřazení akcí snímkům

Aby animace provedla něco, když dosáhne určitého klíčového snímku, přiřadíte
klíčovému snímku Akci snímku. Například aby se ve snímku animace vytvořila smyčka,
můžete přidat Akci snímku Snímku 20, která bude znít "go to Frame 10 and play".

Je dobré umístit všechny akce snímku do jedné vrstvy, aby se usnadnilo jejich
sledování. Snímky s akcemi budou v Časové ose představeny malým a.

Když jste přiřadili akci, doporučuje se otestovat, zda pracuje, použitím příkazu Control
>  Test Movie (Testovat animaci). Většina akcí nebude v editovacím režimu fungovat.
Popis akcí, které můžete přidat, viz "Používání základních akcí pro manévrování a interakci".

Následující instrukce popisují, jak nastavit akce pro snímky použitím Panelu akcí
v Normálním režimu. Informace o používání Panelu akcí v Odborném režimu viz Referenční
příručka ActionScript.

Přiřazení akce klíčovému snímku:

1. Označte klíčový snímek v Časové ose a vyberte Window > Action (Akce).

� Pokud není zvolený snímek klíčový, je akce přiřazena předcházejícímu
klíčovému snímku. Pokud výběr není snímek nebo pokud výběr obsahuje 
více klíčových snímků, bude Panel akcí ztlumen.

� (Informace o přiřazování akcí tlačítku nebo klipu animace viz "Přiřazování akcí
objektům".)
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Nastavení voleb události myši

Přiřazení akce tlačítku také automaticky přiřadí akci Mouse Event (Události) myši
k tlačítku pro ovládání nebo řízení akce.
Každý ovladač začíná slovem on, následovaný událostí (event), které ovladač odpovídá.

Například:

� on (release)
on (press key "<Space>")
on (rollOver)

� Parametr release (uvolnit) znamená, že uživatel stiskl a uvolnil tlačítko myši.

� Můžete určit, které události myši spustí tlačítko akce použitím Panelu akcí.

Nastavení voleb událostí myši:

1. Označte tlačítko, kterému přiřadíte akci.

2. V Seznamu panelu nástrojů na levé straně Panelu akcí klikněte na kategorii 
Basic Actions (Základní akce) pro zobrazení základních akcí.

3. Vyberte z následujících voleb:

� Zvolte akci On Mouse Event (Událost aktivní myši).

� Vyberte akci v kategorii Základní akce.

4. V políčku Parametry zvolte jako Event (Událost) událost klávesnice nebo myši,
která spustí akci:

� Press (Zmáčknout) spustí akci, když je tlačítko myši zmáčknuto a ukazatel 
myši je nad tlačítkem.

� Release (Uvolnit) (implicitně) spustí akci, když je uvolněné tlačítko myši 
a ukazatel je nad tlačítkem. To nastaví základní chování kliknutí.

� Release Outside (Uvolnit mimo) spustí akci, když je tlačítko myši uvolněno
a ukazatel není nad tlačítkem.

� Key Press (Zmáčknout klávesu) spustí akci, když je zmáčknuta určitá 
klávesa. Pokud zvolíte tuto volbu, zadejte klávesu do textového pole.

� Roll Over (Přejet přes) spustí akci, když ukazatel myši přejede přes tlačítko.

� Roll Out (Přejet ven) spustí akci, když ukazatel myši přejede mimo tlačítko.

� Drag Over (Přetáhnout přes) spustí akci když je tlačítko myši zmáčknuto 
a ukazatel je nad tlačítkem, ukazatel přejede mimo tlačítko a pak ukazatel 
přejede zpět přes tlačítko.
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Používání základních akcí pro manévrování a interakci

Základní akce v Panelu akcí vám umožní ovládat manévrování a interakci s uživatelem
v animaci označením animace a přikázáním skriptu napsat pro vás ActionScript.
Základní akce obsahují následující:

� Akce Go To přeskočí na snímek nebo scénu.

� Akce Play and Stop přehrají a zastaví animace.

� Akce Toggle High Quality přizpůsobí kvalitu zobrazení animace.

� Akce Stop All Sounds zastaví všechny zvuky v animaci.

� Akce Get URL přeskočí na jiné URL.

� Akce FSCommand pohlídá Přehrávač Flash, který přehrává animaci.

� Akce Load Movie and Unload Movie nahrají a uvolní z paměti další animace.

� Akce Tell Target kontroluje jiné animace a klipy animací.

� Akce If Frame Is Loaded zkontroluje, zda je nahrán snímek.

� On Mouse Event přiřadí událost myši nebo klávesy klávesnice, která spustí akci.

� Dále akce Print vám umožní určovat, jak budou vytištěny snímky vaší animace. 
Informace o dalších akcích poskytovaných ActionScript a o rozšířené 
interaktivitě viz Referenční příručka ActionScript.

Přeskočení na snímek nebo scénu

Pro přeskok na snímek nebo scénu v animaci použijte akce Go To. Když animace
přeskočí na snímek, můžete ji přehrát od tohoto nového snímku (implicitně) nebo
zastavit v tomto snímku. Animace může také přeskočit na scénu a přehrát určitý
snímek nebo první snímek příští nebo předchozí scény.

Přeskok na snímek nebo scénu:

1. Zvolte snímek, instanci tlačítka nebo klipu animace, kterým přiřadíte akci.

2. Vyberte Window  > Action (Akce) pro zobrazení Panelu akcí.

3. V Seznamu panelu nástrojů klikněte na kategorii Základní akce a zvolte
akci Go To.

� Flash vloží do Seznamu akcí akce Go To and Play.

4. Aby se animace stále přehrávala i po přeskoku, nechejte volby Go To and Play 
(implicitní) označeny na tlačítku Parametry. Pro zastavení přehrávání animace
v určitém snímku odznačte tuto volbu. Akce se změní na Go To and Stop.
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2. V Seznamu panelu nástrojů na levé straně panelu klikněte na kategorii Basic 
Actions (Základní akce) pro zobrazení základních akcí.

3. Pro přiřazení akce proveMte jedno z následujících:

� Dvakrát klikněte na akci v kategorii Základní akce v Seznamu panelu nástrojů.

� Přetáhněte akci ze Seznamu panelu nástrojů vlevo do Seznamu akcí na pravé 
straně panelu.

� Klikněte na tlačítko Add (Přidat) (+) a vyberte příkaz z kontextového menu.

� Použijte klávesovou zkratku.

4. Pro zobrazení políčka Parametry klikněte na trojúhelník v pravém dolním 
rohu Panelu akcí. Zvolte akci a zadejte nové hodnoty do textových polí 
Parametry pro změnu parametrů existujících akcí.

� Parametry se liší v závislosti na akci, kterou vyberete.

5. Opakujte kroky 3 a 4 pro přidání dalších akcí, pokud je to třeba.

Testování akce snímku na scéně:

� Vyberte Control > Test Movie (Testovat animaci).
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7. Pokud v kroku 6 vyberete Číslo snímku, Název snímku nebo Výraz, zadejte 
jako Snímek číslo, název, popis nebo výraz, který se vztahuje k číslu nebo 
popisu snímku.

� Následující výraz znamená, že snímek je pět snímků před snímkem, 
který obsahuje akci:

goAndStop(_currentframe +5);

� Informace o psaní výrazů viz Referenční příručka ActionScript.

Přehrávání a zastavování animací

Pokud není nastaveno jinak, jakmile animace začne, přehrává se každý snímek
Časové osy. V určitých intervalech můžete animaci zastavovat nebo spouštět použitím
akcí Play (Přehrát) a Stop (Zastavit). Například můžete animaci zastavit na konci
scény, než bude pokračovat další scénou. Pokud je animace zastavena, musí být
spuštěna výhradně použitím akce Play (Přehrát). 
Akce Play (Přehrát) a Stop (Zastavit) jsou nejpoužívanějšími prostředky pro ovládání
klipů animace tlačítky nebo pro kontrolu hlavní Časové osy. Klip animace, který
chcete ovládat, musí mít název instance,  musí být cílený a musí být v Časové ose.
Viz "Ovládání dalších animací  a klipů animací".

Spuštění nebo zastavení animace:

1. Zvolte snímek nebo instanci tlačítka nebo klipu animace, kterým chcete 
přiřadit akci.

2. Vyberte Window > Action (Akce) pro zobrazení Panelu akcí.

3. V Seznamu panelu nástrojů klikněte na kategorii Základní akce pro zobrazení 
základních akcí a zvolte akci Stop.

Flash vloží do Seznamu akcí ActionScript podobný:

� onClipEvent (load){
stop ();
}

� kde onClipEvent(load) znamená, že když se animace nahraje, Flash by měl
vykonat příkaz stop a zastavit animaci.

Poznámka: Prázdné závorky po akci znamenají, že to je metoda (schopnost), která nemá
žádné parametry nebo argumenty.

246 Uživatelská příručka - FLASH 5

5. V kontextovém menu Scene v políčku Parametry určete cílovou scénu: 
Currend (Aktuální) nebo Scene Name (Scéna jméno) pro určení snímku v rámci
scény nebo Next (Další) nebo Previous (Předchozí), aby animace přeskočila 
na první snímek scény.

6. V kontextovém menu Type (Typ) v políčku Parametry vyberte cílový snímek:

� Next (Další) nebo Previous Frame (Předchozí snímek).

� Frame Number (Číslo snímku), Frame Label (Název snímku) nebo 
Expression (Výraz) vám dovolí určit snímek.

� Expressions (Výrazy) jsou jakékoliv části příkazu, které poskytují hodnoty,
jako je 1+1.
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Zastavení všech zvuků

Pro zastavení audio stopy, aniž byste přerušili Hlavní časovou osu, použijte akci Stop
All Sounds (Zastavit všechny zvuky). (Není to akce, která by pouze potlačila hlasitost.)
Akce Zastavit všechny zvuky ovlivní všechny animace přehrávané v Přehrávači Flash.
Streamování zvuků bude pokračovat, když se posune Časová osa; připojené zvuky
pokračovat nebudou.
Více informací o ovládání zvuků viz "Spouštění a zastavování zvuků v klíčových snímcích".

Zastavení všech zvuků v animaci:

1. Označte snímek nebo instanci tlačítka nebo klipu animace, kterým chcete
přiřadit akci.

2. Vyberte Window  > Actions (Akce) pro zobrazení Panelu akcí.

3. V Seznamu panelu nástrojů klikněte na kategorii Akce pro zobrazení 
základních akcí a zvolte akci Stop All Sounds (Zastavit všechny zvuky).

Flash zadá následující ActionScript do Seznamu akcí:

� stopAllSounds ();

Přeskok na jinou URL

Pro nahrání dokumentu ze specifické URL do okna prohlížeče nebo pro předání
proměnných do jiné aplikace na určitém URL použijte akci Get URL (Stáhnout URL).
(Variables (Proměnné) uchovávají pojmenované hodnoty, které mohou být načítány
pro používání ve skriptech.) Data proměnné můžete například poslat do CGI skriptu
pro zpracování stejným způsobem jako byste to udělali s HTML formulářem. Jsou
poslány jen proměnné aktuální animace.
Typickým použitím akce Get URL (Stáhnout URL) je nahrání webové stránky, ale můžete
ji také použít v projektoru Flash pro automatické otevření okna prohlížeče a zobrazení
určité URL.
Testování akce požaduje, aby byl vyžadovaný soubor na určitém místě a aby měly
absolutní URL adresy připojení k síti. (například http://www.mujserver.com/).
Informace o předávání proměnných viz Referenční příručka ActionScript.

Přeskok na URL:

1. Označte snímek nebo instanci tlačítka nebo klipu animace, kterým chcete 
přiřadit akci.

2. Vyberte Window > Action (Akce) pro zobrazení Panelu akcí.

3. V Seznamu panelu nástrojů klikněte na kategorii Základní akce pro zobrazení 
základních akcí a zvolte akci Stáhnout URL.
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Spuštění klipu animace:

1. Označte klip animace, který chcete spustit, nebo označte tlačítko, které ovládá
přehrávání.

2. Vyberte Window > Action (Akce) pro zobrazení Panelu akcí.

3. V Seznamu panelu nástrojů klikněte na kategorii Základní akce pro zobrazení
základních akcí a vyberte akci Play.

Flash vloží do Seznamu akcí ActionScript podobný následujícímu:

� on (release){
play ();
}

� kde on(release) znamená, že pokud je tlačítko uvolněno, Flash by měl 
vykonat příkaz play pro spuštění animace.

Přizpůsobování kvality zobrazení animace

Anti-aliasing (Potlačení roztřepení) vyžaduje rychlejší procesor pro vyhlazení každého
snímku animace, než je přehrán na divákově obrazovce, a tak může zpomalit
přehrávání. Vypnutím potlačení roztřepení můžete animaci zrychlit. Pro zapínání
a vypínání potlačení roztřepení čar použijte akci Toggle High Quality (Přiřadit vyšší
kvalitu). Tato akce ovlivní všechny animace přehrávající se v Přehrávači Flash. (V Přehrávači
Flash nemůžete přizpůsobit kvalitu zobrazení individuální animace nebo klipu animace.)

Akce Toggle High Quality přiřazená tlačítku umožní divákům přizpůsobit kvalitu
přehrávání animace. Akce zapíná a vypíná potlačení roztřepení. To znamená, že kliknutí
jednou na tlačítko myši vypne potlačení roztřepení, druhé kliknutí na tlačítko myši má
opačný účinek. Více informací o výběru mezi vzhledem a rychlostí přehrávání viz parametr
QUALITY v "Nastavení HTML úprav Flash“.

Přizpůsobení rychlosti animace nebo kvality přehrání:

1. Označte snímek nebo instancí tlačítka nebo klipu animace, kterému chcete 
přiřadit akci.

� Označení klipu animace přizpůsobí rychlost animace; označení tlačítka 
přizpůsobí kvalitu přehrání animace.

2. Vyberte Window  > Action (Akce) pro zobrazení Panelu akcí.

3. V Seznamu panelu nástrojů klikněte na kategorii Základní akce pro zobrazení
základních akcí a zvolte akci Toggle High Quality (Přiřadit vyšší kvalitu).

Flash zadá do Seznamu akcí následující ActionScript:

� toggleHighQuality ();
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� Vyberte Send Using Post (Poslat s použitím zveřejnění) pro poslání proměnných
zvláš6 od URL jako dlouhých řetězců ve zvláštních hlavičkách; to vám umožní 
poslat více proměnných a zveřejnit informace z formuláře do CGI skriptu 
na serveru.

� Vyberte Don t Send (Neposílat), pokud se nemají předat žádné proměnné.

� Viz Referenční příručka ActionScript.

Váš kód bude vypadat podobně jako následující:

� getUrl ("stranka2.html","blank");

� kde akce Get URL(Stáhnout URL) nahraje HTML dokument "stranka2" do nového
okna prohlížeče.

Ovládání Přehrávače Flash

� Pro ovládání samostatného přehrávače Flash použijte akci FSCommand 
(Příkaz FS).

� Tuto akci můžete také použít pro posílání vzkazů do aplikace hostící 
Přehrávač Flash - například JavaScript v prohlížeči www, Director, Visual 
Basic, Visual C++ a další programy, které mohou hostit ovladače ActiveX. 
Více informací o posílání vzkazů dalším aplikacím použitím Příkazu FS viz 
odpovídající téma v Referenční příručce ActionScript.

Ovládání animace použitím projektoru:

1. Zvolte snímek nebo instanci tlačítka nebo klipu animace, kterým chcete 
přiřadit akci.

2. Vyberte Window > Action (Akce) pro zobrazení Panelu akcí.

3. V Seznamu panelu nástrojů klikněte na kategorii Základní akce pro zobrazení
základních akcí a vyberte akci FSCommand (Příkaz FS).

4. V políčku Parametry vyberte volbu pro ovládání samostatného přehrávače
z kontextového menu Commands for Standalone Player (Příkazy pro samostatný 
přehrávač):

� Vyberte Quit (Ukončit) pro zavření projektoru animace.

� Vyberte Exec (Spustit) pro začátek běhu aplikace v rámci projektoru.
V textovém poli Argumenty zadejte cestu k aplikaci.

� Vyberte Fullscreen (Celá obrazovka) [True (pravda)/False (nepravda)] pro 
ovládání náhledu projektoru. V textovém poli Argumentu zadejte True pro náhled
na celou obrazovku nebo False pro normální náhled.
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4. Do políčka Parametry zadejte URL, z níž chcete stáhnout dokument podle
těchto zásad:

� Použijte buM relativní cestu jako je mojestranka.html nebo absolutní cestu 
jako je http://www.mojedomena.com/mojestranka.html.

� Relativní cesta je zkrácenou verzí plné adresy, která vám umožní popsat 
umístění jednoho souboru vzhledem k jinému; přikáže Flashi pohybovat
se nahoru a dolů v hierarchii vložených souborů/složek/adresářů, počínaje 
souborem, ve kterém jste zadali příkaz Stáhnout URL. Absolutní cesta je úplná 
adresa, která určuje jméno serveru, na kterém se nachází soubor, cestu 
(hierarchie adresářů, svazků,složek a tak dále) a jméno samotného souboru.

� Pro stáhnutí URL založeném na hodnotě nebo výrazu, zvolte Expression 
(Výraz) a zadejte výraz, který hodnotí umístění URL.

Například následující příkaz znamená, že URL je hodnoty proměnné dynamickaURL:

� getURL(dynamickaURL);

� Informace o psaní výrazů viz Referenční příručka ActionScript.

5. Jako Okno určete okno nebo rám HTML, do kterých bude nahrán dokument 
následovně:

Vyberte z následujících rezervovaných cílových jmen:

� _self  určuje aktuální rám aktuálního okna.

� _blank určuje nové okno.

� _parent určuje předchůdce aktuálního rámu.

� _top určuje nejvýše položený rám v aktuálním okně.

� Zadejte název určitého okna nebo rámu, jak jsou pojmenovány v HTML
souboru.

� Označte Expression (Výraz) a zadejte výraz, který hodnotí umístění okna.

6. Jako Variable (Proměnnou) vyberte metodu pro odeslání proměnných 
no nahrané animace do umístění uvedeného v textovém poli URL:

� Vyberte Send Using Get (Poslat s použitím stahování) pro přidání malého
počtu proměnných na konec URL. Například použijte tuto volbu pro poslání 
hodnoty proměnné animace Flash do skriptu na straně serveru.
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� Pro použití v Přehrávači Flash nebo testování ve Flashi musí být všechny 
SWF soubory uloženy ve stejné složce a uvedeny v seznamu bez určení 
složky nebo diskové jednotky.

5. Jako umístění vyberte buM Level (Úroveň) nebo Target (Cíl) z kontextového 
menu.

6. Když jako Location (Umístění) zvolíte Level )Úroveň), zadejte číslo úrovně 
následovně:

� Pro nahrání nové animace vedle existujících animací, zadejte číslo úrovně, 
které není obsazeno jinou animací.(Pro uchování animace a aktualizaci 
proměnných s novými hodnotami použijte akci Load Variables (Nahrát 
proměnné); více informací viz Referenční příručka ActionScript.)

� Pro nahrazení existující animace nahranou animací, zadejte číslo úrovně, 
kterou nyní má ona animace.

� Pro nahrazení původní animace a uvolnění všech úrovní z paměti nahrajte 
novou animaci do úrovně 0.

� Animace, která byla nahrána jako první, je nahrána do nejnižší úrovně. 
Animace na úrovni jedna nastavuje rychlost střídání snímků, barvu pozadí 
a velikost snímků pro ostatní nahrané animace.
Animace mohou být navrstveny do dalších úrovní nad animací na úrovni 0.

� Více informací o úrovních a cílech viz  kapitola o klipech animací v Referenční
příručce ActionScript.

7. Pokud jako Location (Umístění) zvolíte Target (Cíl), určete klip animace, který
bude nahrazen nahranou animací.

� Nahraná animace zdědí vlastnosti (atributy) umístění, otočení a velikosti 
cílového klipu animace. Levý horní roh nahrané animace je umístěn do 
registrovaného bodu cílového klipu animace (umístění křížku v režimu pro 
editaci symbolů).

8. Jako Variable (Proměnnou) vyberte metodu pro odesílání proměnných
nahrané animace do místa uvedeného v textovém poli URL:

� Vyberte Send Using Get (Poslat s použitím stahování) pro přidání malého
počtu proměnných na konec URL. Například použijte tuto volbu pro poslání
hodnoty proměnné animace Flash do skriptu na straně serveru.

� Vyberte Send Using Post (Poslat s použitím zveřejnění) pro poslání proměnných
zvláš6 od URL jako dlouhých řetězců ve zvláštních hlavičkách; to vám umožní 
poslat více proměnných a zveřejnit informace z formuláře do CGI skriptu
na serveru.
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� Vyberte Allowscale (Povolit měřítko) [True (pravda)/False (nepravda)]
pro ovládání měřítka animace. V textovém poli Argumenty zadejte True pro 
povolení změny měřítka animace prohlížečem nebo zadejte False pro zobrazení 
animace bez změny měřítka.

� Vyberte Showmenu (Zobrazit menu) [True (pravda)/False (nepravda)] pro 
ovládání položek kontextového menu. V textovém poli Argumenty zadejte
True pro zobrazení plné sady položek menu pravého kliknutí myši nebo 
False pro skrytí nabídkové lišty.

� Příkazy můžete také napsat do voleb v textových polích Commands 
(Příkazy) nebo Argumenty nebo je můžete zadat jako výrazy. Více informací 
viz Referenční příručka ActionScript.

Nahrávání a uvolňování z paměti dalších animací

Pro přehrávání dalších animací, aniž byste museli zavřít Přehrávač Flash, nebo pro
přepínání mezi animacemi bez nahrávání dalších HTML dokumentů použijte akci
Load Movie (Nahrát animaci).

Akce Unload Movie (Uvolnit animaci) odstraní animaci dříve nahranou akcí Load
Movie  (Nahrát animaci).

Zde jsou vzorové způsoby použití akcí Nahrát animaci:

� Přehrání sekvence bannerů s inzeráty, které jsou soubory SWF, umístěním
akce Load Movie (Nahrát animaci) na konec každého SWF souboru pro
nahrání další animace.

� Rozvoj větvícího se rozhraní, které uživateli umožní vybrat si mezi několika 
různými SWF soubory.

� Sestavení navigačního rozhraní s navigačními ovladači na úrovni 0, které nahrají 
další úrovně. Nahrání úrovní vytvoří hladší přechody než nahrávání nových 
HTML stránek do prohlížeče.

Nahrání animace:

1. Označte snímek nebo instanci tlačítka nebo klipu animace, kterým chcete
přiřadit akci.

2. Vyberte Window > Action (Akce) pro zobrazení Panelu akcí.

3. V Seznamu panelu nástrojů klikněte na kategorii Základní akce pro zobrazení 
základních akcí a zvolte akci Load Movie (Nahrát animaci).

4. V políčku Parametry určete pro URL absolutní nebo relativní URL SWF 
souboru, který se má nahrát.
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Ovládání dalších animací a klipů animací

� Animaci nebo klip animace, které byly nahrány akcí Load Movie (Nahrát
animaci), můžete ovládat cílením klipu animace.

� Snímku, tlačítku nebo klipu animace přiřadíte akce, které budou ovládat klip
animace (zvané ovladač) a pak cílíte animaci nebo klip animace, který bude
odpovídat na akci (zvané cílený klip animace). Pro ovládání animace nebo
klipu animace můžete použít základní akci Tell Target (Určit cíl). Jinak můžete 
použít akci With (Spolu s) pro vykonání několika akcí na stejný cíl bez toho,
abyste museli adresovat cílový klip animace na každou akci.

Pro ovládání animace nebo klipu animace vyžaduje ovladač následující:

� Musí být specifikován cíl (Časová osa), na kterém se stane určitá akce.  Pro cílení
klipu animace můžete použít dialogové okno Insert Target Path (Vložit cestu k cíli).

� Klip animace, který má být cílený, musí mít jméno instance - jedinečný název
přiřazený klipu animace, který vám umožní cílit jej ve skriptech. Pro pojmenování
instance klipu použijte Panel instancí (Window > Panels > Instance).Časová
osa klipu animace musí být na Ploše, aby ji bylo možno cílit. Například
pokud KlipAnimace1 ve Snímku 5 chce sdělit KlipuAnimace 2, co má dělat, 
KlipAnimace 2 musí být na Časové ose ve Snímku 5.

� Informace o akci With (Spolu s) a ovládání více Časových os nebo ovládání klipů
animace jiným způsobem viz kapitola o klipech animací v Referenční
příručce ActionScript.

Kontrola klipu animace:

1. Zvolte snímek nebo instanci tlačítka nebo klipu animace, kterým chcete 
přiřadit akci.

2. Vyberte Window > Action (Akce) pro zobrazení Panelu akcí.

3. V Seznamu panelu nástrojů klikněte na kategorii Základní akce pro zobrazení 
základních akcí a vyberte akci Tell Target (Určit cíl).

4. Pro určení cílového klipu animace, který má být kontrolován, klikněte na 
tlačítko Insert Target Path (Vložit cestu k cíli) v pravém dolním rohu Panelu akcí.
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� Vyberte Don t Send (Neposílat), pokud se nemají předat žádné proměnné.

� Viz kapitola o webových aplikacích v Referenční příručce ActionScript.

� V následujícím příkladu nahraje kliknutí na tlačítko animaci do kořenového 
adresáře v úrovni, nahradí existující animaci a pošle proměnné do nahrané 
animace použitím metody Get (Stáhnout):

loadMovie ("nejakySoubor.cgi",0,"GET");

� kde "nejakySoubor.cgi" vytvoří výstup animace Flash ve formátu SWF.

Uvolnění animace z okna animace Flash:

1. Označte snímek nebo tlačítko instance nebo klipu animace, kterým chcete
přiřadit akci.

2. Vyberte Window  > Action (Akce) pro zobrazení Panelu akcí.

3. V Seznamu panelu nástrojů klikněte na kategorii Základní akce pro 
zobrazení základních akcí a zvolte akci Unload Movie (Uvolnit animaci).

4. Jako Location (Umístění) vyberte jednu z následujících voleb z kontextového 
menu:

� Pro nahranou animaci zvolte Level (Úroveň) a zadejte úroveň animace, kterou
chcete uvolnit.

Pro nasměrování animace, která se má uvolnit, zvolte Target (Cíl) a zadejte 
cestu animaci, kterou chcete uvolnit. Pro zadání výrazu, který se vztahuje k úrovni
nebo animaci, zvolte Expression (Výraz) a zadejte výraz. Například:

� unloadMovie (3);

� směřuje animaci na úroveň 3 a uvolní ji.

Test akcí Nahrát animaci a Uvolnit animaci:

1. Pokud testujete akci Load Movie (Nahrát animaci), ujistěte se, že animace,
která se nahrává, je na určeném místě. Pokud je cesta absolutní URL 
adresou, je vyžadováno aktivní připojení k Internetu.

2. Vyberte Control  > Test Movie (Testovat animaci).

Poznámka: Akce Nahrát animaci a Uvolnit animaci nefungují v režimu pro editaci.
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8. V Seznamu panelu nástrojů v Panelu akcí zvolte další akce, které budou 
přikazovat cílovému klipu, co má dělat.

� Akce umístěné v rámci bloku Tell Target (Určit cíl) se vztahují na cílovou 
Časovou osu.

Například:

� tellTarget (_root.plane){
stop();
}

Ověření, zda je snímek nahrán

Pro vytvoření Preloaderu (předběžného nahrávacího zařízení), které zabrání tomu,
aby byly určité akce spuštěny než se uživateli stáhne potřebný obsah, použijte akci If Frame
Is Loaded (Pokud je nahrán snímek). Předběžné nahrávací zařízení je jednoduchá
animace, která se přehrává jako zbytek animace. Akce If Frame Is Loaded je užitečná
pro ověření nahrání velkého souboru (jako je bitmapa nebo zvuk). Můžete také použít
vlastnost _framesloaded (s akcí If) pro kontrolu, zda je lokálně určitý snímek.

Použitím této vlastnosti nebo akce můžete začít přehrávat jednoduchou animace,
zatímco zbytek obsahu určitého rámu se nahraje na lokální počítač. Obojí kontroluje,
zda je lokálně dostupný obsah určitého rámu.

Akce If Frame Is Loaded  je typicky používána jako akce snímku, ale může být použita
také jako akce tlačítka. Pro testování podmínky If Frame Is Loaded použijte volbu
Streaming v příkazu Testovat animaci. Snímky se nahrají jako by se streamovaly
z webové stránky. Více informací viz "Testování výkonu stahování animace".

Ověření nahrání snímku:

1. Označte snímek nebo instanci tlačítka nebo klipu animace, kterým chcete
přiřadit akci.

2. Vyberte Window > Action (Akce) pro zobrazení Panelu akcí.

3. V Seznamu panelu nástrojů klikněte na kategorii Základní akce pro zobrazení
základních akcí a vyberte akci If Frame Is Loaded.

4. V políčku Parametry vyberte Scénu, která obsahuje požadovaný snímek: 
Current (Aktuální) nebo pojmenovanou scénu.

5. Jako Typ vyberte Frame Number (Číslo snímku), Frame Label (Popis snímku) 
nebo Expression (Výraz).

6. Jako Frame určete snímek, který se má nahrát než je akce spuštěna pomocí 
čísla snímku, popisu snímku nebo výrazu, v souladu s volbou v kroku 5.
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� Objeví se dialogové okno a zobrazí hierarchii klipů animace aktuálního klipu.
Toto dialogové okno použijete pro výběr cílové cesty pro textové pole Target
(Cíl) v políčku Parametry.

5. Jako Notation (Zobrazení) použijte implicitní Dots (Tečky) (podobně jako 
JavaScript). Označení Slash (lomítky), dostupné pro ty, kterým je bližší 
zobrazení Flash 4, používá lomítka pro vymezení cílové cesty klipu animace.

6. Jako Mode (Režim) vyberte zobrazení hierarchie instancí klipu animace:

� Relativní (implicitně) zobrazí pouze instance klipů animace, které existují
v aktuálním snímku aktuální Časové osy a jejich potomků. Označení tato se 
vztahuje na aktuální Časovou osu.

� Absolutní režim zobrazí všechny  instance klipu animace ve všech snímcích 
ve všech scénách celé animace. Tento režim vždy zahrnuje vedoucí lomítko 
nebo označení _root (kořen) (nebo _level (úroveň) pro zobrazení úrovně
nahrané animace) ve vkládané cílové cestě.

Poznámka: Absolutní režim zobrazí všechny instance ve všech snímcích, ale protože
interakce klipů animací je složitá, nemusí být instance dostupné, když je spuštěna
akce Tell Target (Určit cíl).

� Můžete volně přepínat mezi označeními. Nicméně přepínání mezi Relativním 
a Absolutním režimem může odznačit klip animace.

7. Vyberte klip animace ze stromového náhledu. Textové okno Target (Cíl) 
zobrazí cestu ke klipu. Klikněte na tlačítko OK.
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Vytváření tisknutelných animací

Jestliže jste ve vaší animaci Flash nastavili interaktivitu, můžete také nastavit, že určité
snímky animace budou tisknutelné, takže si je uživatelé budou moci vytisknout
pomocí Přehrávače Flash. Schopnost tisku v Přehrávači Flash můžete použít pro tisk
katalogů, kupónů, informačních tabulek, stvrzenek, faktur a dalších dokumentů ve vašich
animacích Flash.

Přehrávač Flash tiskne obsah Flash jako vektorovou grafiku s vysokým rozlišením
dostupným u tiskáren a jiných výstupních zařízení. Tisk ve formě vektorové grafiky
mění velikost výtvoru ve Flashi, takže tiskne jasně v jakékoliv velikosti bez zkreslujících
efektů, které se mohou objevit při tisku bitmapových obrázků s malým rozlišením.

Tisk animací z Přehrávače Flash namísto prohlížeče přináší uživatelům Flashe několik
výhod. Můžete provádět následující:

� Určit, které snímky animace Flash mohou být tisknuty. To vám umožní 
vytvářet rozvržení vhodná pro tisk a chránit materiál proti neautorizovanému tisku.

� Určit oblast tisku snímků.

� Určit, zda jsou snímky tištěny jako vektory (abyste využili výhodu vyšších
rozlišení) nebo jako bitmapy (abyste zachovali průhlednost a barevné efekty).

� Přiřadit akci Print (Tisknout) pro tisk snímků z klipů animace, i když klipy nejsou 
viditelné. To vám umožní poskytnout tisknutelný materiál bez používání cenného
místa prohlížeče.
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7. Zvolte akci, která se objeví poté, co byl nahrán určitý snímek.

Flash zadá do Seznamu akcí ActionScript podobný tomuto:

� ifFrameLoaded (100){
gotoAndPlay (10);
}

Použití akce Pokud je nahrán snímek pro přehrání krátké animace, když se nahrává
animace:

1. Vytvořte krátkou animovanou smyčku na začátku animace. Například
můžete vytvořit smyčku, která zobrazí vzkaz "Animace se nahrává..."

2. Vytvořte akci snímku s akcí If Frame Is Loaded, která vyskočí ze smyčky
animace, když se nahrají snímky a pokračuje v přehrávání animace.

Například animace se 30 snímky, která má 2 snímky dlouhou animovanou 
smyčku na začátku vyžaduje následující akci připojenou ke Snímku 1:

� ifFrameLoaded (30){
gotoAndPlay (3);

Pro doplnění příkladu připojte následující akci ke Snímku 2, aby se animace restarto-
vala ve Snímku 1:

� gotoAndPlay (1);

� Když se snímek určený v akci If Frame Is Loaded nahraje, animace přeskočí 
druhý snímek a pokračuje v přehrávání animace od třetího snímku.

Použití vlastnosti nahranýsnímek (_framesloaded) v akci pro přehrání krátké animované
smyčky během nahrávání animace:

1. Vytvořte krátkou animovanou smyčku na začátku animace. Například můžete
vytvořit smyčku, které zobrazí vzkaz "Animace se nahrává..."

2. Vytvořte akci snímku, která vyskočí z animované smyčky, jakmile se nahrají 
všechny snímky, a pokračuje v přehrávání animace.

Například animace, která má dva snímky dlouhou animovanou smyčku na začátku
vyžaduje následující akci připojenou ke Snímku 2:

� if(_framesloaded==100){
gotoAndPlay (3);
}else {
gotoAndPlay (1);
}

� Více informací o vlastnosti _nahranýsnímek (_framesloaded) viz Referenční 
příručka ActionScript.
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Tisk z Přehrávače Flash

Uživatelé mohou animace tisknou přímo z Přehrávače Flash v prohlížeči dvěma způ-
soby: bu# použitím kontextového menu Flash Player (Přehrávač Flash) a jeho
příkazem Print (Tisknout) nebo použitím akce Tisknout. Akce Tisknout dává možnost
větší kontroly nad tím, jak může být tisknuta animace Flash a ruší potřebu použití kon-
textového menu Přehrávač Flash.

Akce Tisknout umí tisknout snímky v jakékoliv Časové ose, včetně hlavní Časové osy
nebo Časové osy jakéhokoliv klipu animace nebo nahrané úrovně animace. Akce
Tisknout vám také umožní určit oblast tisku a tisknout barevné efekty, včetně průhlednosti.

Kontextové menu Přehrávač Flash je ve svém tisku více omezené, tiskne jen snímky
v hlavní Časové ose a neumožní vám tisk průhlednosti nebo barevných efektů.

Poznámka: Verze Přehrávače Flash nižší než 4.0.25 (ve Windows) nebo 4.0.20
(na Macintoshi) nepodporují přímý tisk snímků.

Příprava animací pro tisk

Pro nastavení tisku z Přehrávače Flash můžete nastavit, které snímky se budou
tisknout, a jaká bude oblast tisku. Jestliže chcete co nejlépe kontrolovat to, co mohou
uživatele tisknout, mějte při nastavování animací a klipů animací na paměti následující:

� Ve všech snímcích, které určíte jako tisknutelné, přizpůsobte rozvržení 
stránky tak, aby odpovídalo žádanému výstupu tisku. Přehrávač Flash 
vytiskne všechny tvary, symboly, bitmapy, bloky textu a textová pole. Úrovně
v animaci Flash nejsou při výstupu tisku skládány.

� Driver tiskárny Přehrávače Flash používá nastavení HTML pro dimenzi, 
měřítko a  zarovnání nastavené v dialogovém okně publish Settings
(Nastavení publikace). Toto nastavení použijte pro kontrolu rozvržení tisku.

� Zvolené snímky se vytisknou tak, jak jsou zobrazeny v symbolu klipu animace. 
Uživateli můžete umožnit tisknout i klip animace, který není viditelný uživateli 
v prohlížeči a to nastavením vlastnosti animace _visible (viditelný) jako false 
použitím Panelu akcí. Změna vlastnosti klipu animace akcí Set Property 
(Nastavit vlastnost), vykreslovacím nebo jakýmkoliv transformačním nástrojem
neovlivní, jak bude klip animace vytištěn.

� Aby bylo klip animace možno vytisknout, musí být na Ploše v pracovní 
oblasti a musí mu být přidělen název instance.

� Všechny prvky, aby mohly výt vytištěny, musí být úplně nahrány. Pro kontrolu
toho, zda je nahrán obsah pro tisk, můžete použít vlastnost _framesloaded 
nebo akci If Frame is Loaded. Více informací viz "Ověření, zda je nahrán snímek".
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KAPITOLA 13
Vytváření tisknutelných animací

Jestliže jste ve vaší animaci Flash nastavili interaktivitu, můžete také nastavit, že určité
snímky animace budou tisknutelné, takže si je uživatelé budou moci vytisknout
pomocí Přehrávače Flash. Schopnost tisku v Přehrávači Flash můžete použít pro tisk
katalogů, kupónů, informačních tabulek, stvrzenek, faktur a dalších dokumentů ve vašich
animacích Flash.

Přehrávač Flash tiskne obsah Flash jako vektorovou grafiku s vysokým rozlišením
dostupným u tiskáren a jiných výstupních zařízení. Tisk ve formě vektorové grafiky
mění velikost výtvoru ve Flashi, takže tiskne jasně v jakékoliv velikosti bez zkreslujících
efektů, které se mohou objevit při tisku bitmapových obrázků s malým rozlišením.

Tisk animací z Přehrávače Flash namísto prohlížeče přináší uživatelům Flashe několik
výhod. Můžete provádět následující:

� Určit, které snímky animace Flash mohou být tisknuty. To vám umožní 
vytvářet rozvržení vhodná pro tisk a chránit materiál proti neautorizovanému tisku.

� Určit oblast tisku snímků.

� Určit, zda jsou snímky tištěny jako vektory (abyste využili výhodu vyšších
rozlišení) nebo jako bitmapy (abyste zachovali průhlednost a barevné efekty).

� Přiřadit akci Print (Tisknout) pro tisk snímků z klipů animace, i když klipy nejsou 
viditelné. To vám umožní poskytnout tisknutelný materiál bez používání cenného
místa prohlížeče.
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Určení oblasti tisku

Implicitně označuje oblast tisku Plocha. Jakýkoliv objekt, který Plochu přesahuje,
je vystřižen a nevytiskne se. Nahrané animace používají svou vlastní velikost Plochy
pro oblast tisku, ne velikost Plochy hlavní animace.

Jako alternativu pro používání velikosti Plochy animace můžete nastavit tři různé
oblasti tisku:

� V kontextovém menu Přehrávač Flash nebo v akci Tisknout můžete určit
bounding box (hraniční oblast) tisku pro všechny snímky označením objektu
v jednom snímku. Tato volba je například užitečná, pokud chcete tisknout 
tabulku s daty přes celou stranu z webového banneru.

� Pomocí akce Tisknou můžete poskládat hraniční oblasti všech tisknutelných 
snímků v Časové ose jako oblast tisku - například pro tisk více snímků, které 
sdílejí registrovaný bod. Pro použití složené hraniční oblasti zvolte volbu 
Maximum v parametrech akce Tisknout. Viz "Přiřazení akce Tisknout".

� Pomocí akce Tisknout můžete změnit oblast tisku každého snímku změnou 
velikosti objektů tak, aby se vešly do oblasti tisku - například, aby se objekty 
různých velikostí v každém snímku vešly na stranu tisku. Pro změnu hraniční
oblasti podle snímku použijte volbu Frame v parametrech akce Tisknout. 
Viz "Přiřazení akce Tisknout".

Určení oblasti tisku:

1. Otevřete animaci, jejíž snímky budete nastavovat pro tisk.

2. Vyberte snímek, který jste neurčili jako tisknutelný popisem #p. Pro lepší 
organizaci své práce můžete označit následující snímek po snímku 
označeném #p.

3. Vytvořte tvar na Ploše velikosti vyžadované oblasti tisku.

Můžete také vybrat snímek s jakýmkoliv objektem odpovídajícím velikosti oblasti tisku
pro použití hraniční oblasti snímku.

4. Zvolte snímek v Časové ose obsahující tvar, který použijete pro určení 
hraniční oblasti.

5. Pokud Panel snímku není na obrazovce viditelný, vyberte Modify > Frame.

6. V Panelu snímku zadejte #b pro určení označeného tvaru jako hraniční 
oblasti pro oblast tisku.

V jedné Časové ose můžete zadat pouze jeden popis #b. Tato volba je stejná jako
volba Movie bounding (Hraniční oblast) animace pro akci Tisknout.
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Podporované tiskárny

Přehrávač Flash může tisknout na postscriptových i nepostscriptových tiskárnách.
Seznam tiskových platforem podporovaných Přehrávačem Flash viz "Flash Web
Printing for eBusiness" na webové stránce Macromedia
(http://www.macromedia.com/software/flash/open/webprinting/faq.html).

Navrhování tisknutelných snímků

Implicitně se tisknou všechny snímky v Časové ose. Můžete omezit počet snímků,
které se budou tisknout. Můžete také určité snímky animace navrhnout jako tisknutelné,
aby se vytiskly jen tyto snímky; ostatní se nevytisknou.

Pro označení snímků jako tisknutelné, je musíte nejprve popsat.

Navržení tisknutelných snímků:

1. Otevřete nebo aktivujte animaci, kterou chcete publikovat.

2. Pokud na obrazovce není viditelný Panel snímku, vyberte Modify > Frame.

3. V Časové ose označte požadovaný snímek, který chcete mít tisknutelný.

4. V Panelu snímku zadejte pro Label (Popis) #p, čímž snímek určíte jako
tisknutelný.

5. Opakujte kroky 3 a 4 pro každý další snímek, který chcete označit jako 
tisknutelný.
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4. V Panelu snímku zadejte jako Label (Popis) !#p pro určení snímku jako
netisknutelný. Pro ztlumení příkazu Tisknout v kontextovém menu potřebujete
určit pouze jeden popis !#p.

Poznámka: Alternativně můžete označit prázdný snímek a označit jej #p, abyste
zabránili tisku z kontextového menu Přehrávač Flash.
Deaktivace tisku odstraněním kontextového menu Přehrávače Flash:

1. Otevřete nebo aktivujte animaci, kterou chcete publikovat.

2. Vyberte File  > Publish Settings (Nastavení publikace).

3. Zvolte záložku HTML  a odznačte Display Menu (Menu zobrazení).

4. Klikněte na tlačítko OK.

Více informací o volbách publikace viz "Publikace animací Flash".

Přiřazení akce Tisknout

Akci Tisknout můžete přiřadit tlačítku nebo jinému prvku vaší animace, abyste
uživateli umožnili tisknout animaci. Akci Tisknout přiřadíte tlačítku, snímku nebo klipu
animace. Pokud akci Tisknout přiřadíte snímku, akce se vykoná, jestliže přehrávání
dosáhne určeného snímku.

Akce Tisknout vám umožní tisknout snímky i v jiných klipech animací vedle hlavní
Časové osy. Každá akce Tisknout nastaví pro tisk pouze jednu Časovou osu, ale akce
vám umožní určit jakýkoliv počet snímků v rámci Časové osy, které mají být vytisknuty.
Pokud jednomu tlačítku nebo snímku přiřadíte víc než jednu akci Tisknout, zobrazí se
pro každou akci jedno dialogové okně Tisknout.

Přiřazení akce Tisknout tlačítku, snímku nebo klipu animace:

1. Otevřete animaci, jejíž snímky budete nastavovat pro tisk.

2. Označte klíčový snímek v Časové ose, který má být možno tisknout, 
a ujistěte se, že je popsán  #p. Viz instrukce v "Navrhování tisknutelných 
snímků".

Pokud neurčíte snímky, které mají být vytisknuty, budou implicitně vytisknuty všechny.

3. Označte snímky nebo instance tlačítka nebo klipů animace, kterým chcete
přiřadit akci Tisknout.

Každá akce Tisknout nastaví pouze jednu Časovou osu, která bude tisknutelná.
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Změna barvy pozadí tisku

Přehrávač Flash tiskne barvu pozadí nastavenou v dialogovém okně Vlastnosti ani-
mace. Barvu pozadí snímků, které mají být tisknuty, můžete změnit umístěním
barevného objektu do nejnižší vrstvy Časové osy, která bude tisknuta.

Změna barvy pozadí tisku:

1. Umístěte vyplněný objekt, který pokrývá Plochu, do nejnižší vrstvy Časové 
osy, která se bude tisknout.

2. Označte tvar a vyberte Modify > Movie. Zvolte barvu pozadí tisku.

To změní barvu pozadí celé animace, včetně klipů animace a nahraných animací.

3. Vyberte z následujících voleb:

Pro vytisknutí této barvy jako pozadí animace, se ujistěte, že snímky, do kterých jste
tento tvar umístili, jsou určeny pro tisk. Instrukce viz "Navržení tisknutelných snímků".

Pro zachování různé barvy pozadí pro netisknutelné snímky opakujte kroky 2 a 3. Pak
umístěte tvar na nejnižší vrstvu Časové osy ve všech snímcích, které nejsou určeny
pro tisk. Instrukce viz následující oddíl.

Deaktivace tisku

Pokud chcete, aby nebyly tisknuty žádné snímky v hlavní Časové ose, označte
snímky !#p, aby byly netisknutelné. Označení snímku !#p způsobí, že celá animace
bude netisknutelná, a ztlumí příkaz Tisknout v kontextovém menu Přehrávač Flash.
Kontextové menu Přehrávač Flash můžete také odstranit.

Pokud deaktivujete tisk, můžete stále tisknout snímky použitím prohlížejícího příkazu
Tisknout. Vzhledem k tomu, že tento příkaz má rys prohlížení, nemůžete jej ovládat
nebo deaktivovat použitím Flashe.

Deaktivace tisku v kontextovém menu Přehrávač Flash ztlumením příkazu Tisknout:

1. Otevřete nebo aktivujte animaci, kterou chcete publikovat.

2. Pokud není Panel snímku dosud viditelný na obrazovce, zvolte Modify > Frame.

3. Označte první klíčový snímek v Časové ose.
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� Max (Maximální) používá složenou hraniční oblast všech tisknutelných 
snímků v Časové ose jako oblast tisku.

� Frame (Snímek) používá hraniční oblast objektů v každém tisknutelném
snímku Časové osy jako oblast tisku  a mění oblast tisku v každém snímku 
a mění velikost objektů tak, aby se vešly do oblasti tisku. Použijte Frame 
například tehdy, pokud v každém snímku máte objekty různých velikostí 
a chcete, aby se každý objekt vešel na stranu tisku.

Poznámka: Výběr voleb Max nebo Frame pro hraniční oblast akce Tisknout převáží
jakékoliv snímky popsané #b jako hraniční oblast animace.
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4. Vyberte Window > Action (Akce), aby se zobrazil Panel akcí.

5. V Seznamu panelu nástrojů klikněte na kategorii Akce, aby se zobrazily
akce, a dvakrát klikněte pro označení akce Tisknout.

Flash vloží akci Tisknout do Seznamu akcí.

6. Jako Tisknout vyberte tisk snímků jako vektory nebo jako bitmapy:

� Jako vektory vytiskne snímek ve vyšší kvalitě, ale bez průhlednosti. Objekty
obsahující průhlednost nebo barevné efekty nemohou být vytištěny jako 
vektorová data. (Tiskárna nemůže interpretovat kanál alfa, který definuje 
efekty jako vektorová data.)

� Jako bitmapy tiskne průhlednost v kanálu alfa nebo barevné efekty.
Tato volba tiskne v nejvíce dostupném rozlišení tiskárny.

7. Pro určení Časové osy, která bude vytištěna, vyberte volbu Location (Umístění):

� Jako Level (Úroveň) určete číslo úrovně hlavní Časové osy nebo nahrané
animace. Pro použití výrazu pro hodnocení úrovně zvolte Expression (Výraz)
a zadejte jej. Více informací o úrovních viz "Nahrávání a uvolňování dalších
animací".

� Jako Target (Cíl) zadejte cestu cílové animace nebo klikněte na tlačítko
Target Path  (Cesta k cíli) v pravém dolním rohu a použijte dialogové okno 
Insrt Target Path (Cesta k cíli) pro umístění a označení cílové animace. Pro
použití výrazu pro hodnocení cíle zvolte Expression (Výraz) a zadejte jej.

8. Pro nastavení hranic tisku označte volbu Bounding Box (Hraniční oblast):

� Animace používá hraniční oblast objektu ve snímku označeném #b jako
oblast tisku pro všechny snímky tak, jak je nastaveno v "Určení oblasti tisku". 
Například tuto volbu zvolte pro tisk datové tabulky na celé straně z webového 
banneru.
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7. Zvolte jiné volby tisku, podle vlastností vaší tiskárny.

8. Klikněte na tlačítko OK (ve Windows) nebo Tisknout (na Macintoshi).

O publikaci animace s tisknutelnými snímky

Animaci Flash můžete publikovat s tisknutelnými snímky na webu použitím příkazu
Publikovat, čímž se vygenerují nezbytné HTML šablony Flash. Více informací viz
"Publikace animací Flash".

Aby uživatelé mohli využít výhodu jakékoliv funkce Flash, kterou jste přidali, a aby
mohli vytisknout navržené snímky ve Flashi, musí mít verzi Přehrávače Flash 4.0.25
(ve Windows) nebo 4.0.20 (na Macintoshi) nebo pozdější. Můžete nastavit schéma
pro detekci, abyste ověřili správnou verzi Přehrávače Flash. Viz "Ověření cesty k vaší
webové stránce".
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Tisk z kontextového menu Přehrávače Flash

Pro tisk snímků z jakékoliv animace Flash můžete použít příkaz Tisknout v kontextovém
menu Přehrávač Flash.

Příkaz Tisknout z kontextového menu neumí vytisknout průhlednost a barevné efekty
a neumí vytisknout snímky z jiných klipů animace; pro tyto schopnosti tisku použijte
namísto toho akce Tisknout. Viz "Přiřazení akce Tisknout".

Tisk snímků animace použitím příkazu Tisknout z kontextového menu Přehrávače Flash:

1. Otevřete animaci, jejíž snímky chcete tisknout.

� Příkaz vytiskne snímky popsané #b použitím Plochy jako oblasti tisku nebo 
určením hraniční oblasti. Viz "Navrhování tisknutelných snímků" a "Určení 
oblasti tisku".

� Pokud jste nenavrhli určité snímky pro tisk, vytisknou se všechny snímky 
hlavní Časové osy animace.

2. Vyberte File > Publish Preview (Publikovat náhled) > Default (Implicitní)
nebo zmáčkněte F12 pro náhled na animaci Flash v prohlížeči

3. Klikněte pravým tlačítkem myši (ve Windows) nebo podržte Control a klikněte
(na Macintoshi) na animaci Flash v okně prohlížeče pro zobrazení kontextového
menu Přehrávač Flash.

4. Z kontextového menu Přehrávač Flash vyberte Tisknout pro zobrazení
dialogového okna Tisknout.

5. Ve Windows vyberte rozsah tisku, pro označení snímků, které se budou
tisknout:

� Zvolte All (Vše) pro vytisknutí všech snímků animace, pokud nejsou žádné
popsány.

� Zvolte Pages (Stránky) a zadejte rozsah, aby se vytiskly popsané snímky v tomto 
rozsahu.

� Zvolte Selection (Výběr) pro vytisknutí aktuálního snímku.

6. Na Macintoshi zvolte v dialogovém okně Tisk stránky, jež mají být vytištěny:

� Vyberte All (Vše), aby se vytiskl aktuální snímek, nejsou-li žádné popsány, 
nebo aby se vytiskly snímky popsané.

� Vyberte From (Od) a zadejte rozsah, aby se vytiskly popsané snímky v tomto
rozsahu.
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Jako alternativu k příkazu Publish (Publikovat), můžete, pokud jste zdatní v HTML,
vytvořit vlastní HTML dokument pomocí jakéhokoliv HTML editoru a zahrnout v něm
tagy potřebné pro zobrazení animace Flash. Viz "O publikovacích šablonách HTML".

Jestliže máte Macromedia Dreamweaver, můžete na vaší webovou stránku lehce přidat
animaci Flash. Dreamweaver vygeneruje všechen potřebný HTML kód. Více informací
viz manuál k Dreamweaveru.
Dříve než budete publikovat svou animaci, je důležité otestovat, jak funguje, pomocí
příkazů Test Movie (Testovat animaci) a Test Scene (Testovat scénu). Více informací
viz "Testování výkonu stahování animace".

Přehrávání animací Flash

Formát Přehrávače Flash (SWF) je nejdůležitějším formátem pro šíření obsahu Flashe
a jediným formátem, který podporuje interaktivní funkce Flashe.

Animaci Přehrávače Flash můžete přehrát následujícími způsoby:

� V Internetovém prohlížeči, jako je Netscape Navigator a Internet Explorer, 
které jsou vybaveny Přehrávačem Flash.

� Pomocí Flash Xtra in Director a Authorware

� Pomocí ovladače Flash ActiveX control v Microsoft Office a jinými hostiteli 
ActiveX

� Jako část animace QuickTime

� Jako typ samostatné aplikace zvané projektor

� Formát souboru Přehrávače Flash je otevřeným standardem, který je
podporován jinými aplikacemi. Nejnovější informace viz webová stránka 
Macromedia na adrese http://www.macromedia.com.
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KAPITOLA 14

Publikování a exportování

Jestliže jste připraveni předvést svou animaci divákům, musíte FLA soubor publikovat
nebo exportovat do jiného formátu.

Funkce Publish (Publikovat) je ve Flashi navržena pro prezentaci animace na Webu.
Příkaz Publikovat vytvoří soubor Přehrávače Flash (SWF) a HTML dokument, který vloží
váš soubor Přehrávače Flash do okna prohlížeče.

Příkaz Export Movie (Exportovat animaci) vám umožní vytvářet obsah Flashe, který může
být upravován jinými aplikacemi, a exportovat animaci přímo do jednoduchého formátu.
Například můžete celou animaci exportovat jako soubor Přehrávače Flash; jako sérii
bitmapových obrázků, jako jeden soubor se snímky nebo obrázky; a jako pohybující
se nebo nehybné obrázky v různých formátech, včetně GIF, JPEG, PNG, BMP, PICT,
QuickTime nebo AVI.

S příkazem Publikovat můžete provádět následující:

Vybírat formáty, do kterých má být vytvořený soubor převeden, a přizpůsobovat
nastavení pro určité formáty souboru. Flash publikuje automaticky vytvořený soubor
ve zvolených formátech, vytvoří další soubory podle zvolených nastavení a uchová
nastavení u animace pro další použití.

Volby Export Movie (Exportovat animaci) obvykle odpovídají volbám pro publikaci,
ale neukládají nastavení pro opětovné použití.

Vytvářet alternativní formáty souboru - GIF, JPEG, PNG a QuickTime - a HTML potřebný
pro zobrazení souborů v okně prohlížeče. Alternativní formáty umožní prohlížeči
zobrazit animaci a interaktivitu uživatelům, kteří nemají nainstalovaný Přehrávač Flash.

Vytvářet šablony Generátor pro snadnou aktualizaci obsahu na webové stránce,
jako je grafika a texty, aniž by bylo třeba soubory nahrazovat individuálně. Data
Generátoru můžete například použít jako proměnné pro poskytnutí okamžité a upravené
zpětné vazby návštěvníkům vaší webové stránky ve Flashi, můžete také učinit předvedení
vaší webové stránky ve Flashi účinnější a vytvářet věci jako rolovací seznamy, které
v samotném Flashi vytvořit nelze. Viz "O Generátoru a Flashi".
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Optimalizace textu a fontů:

� Omezte počet fontů a stylů fontu. Používejte zřídka vkládané fonty, protože 
zvětšují velikost souboru.

� Ve volbách Embed Fonts (Vkládané fonty) zvolte jen potřebné znaky namísto
zahrnutí celého fontu.

Optimalizace barev:

� Použijte Panel efektů (Window > Panels > Effect (Panel efektů)) pro vytvoření
mnoha různobarevných instancí jednoho symbolu.

� Použijte Míchací panel (Window > Panels > Mixer (Míchací panel)), aby se
paleta barev animace shodovala se specifickou paletou prohlížeče.

� Gradienty používejte zřídka. Vyplnění oblasti gradientní barvou vyžaduje 
o zhruba 50 bytů víc než její vyplnění jednoduchou barvou.

� Průhlednost alfa používejte zřídka, může zpomalit přehrávání.

Testování výkonu stahování animace

Abyste zjistili, kde se může animace během stahování pozastavit, můžete scénu nebo
celou animaci testovat použitím příkazu Testovat scénu nebo Testovat animaci nebo
můžete otevřít existující SWF soubor. Pokud se data nestáhnou do doby, než animace
dosáhne určitého snímku, animace se pozastaví až do jejich načtení.

Pro grafické zobrazení stahování animace můžete použít Bandwidth Profiler
(Profilovací program vlnové šířky pásma) v Přehrávači Flash, kde se zobrazí, jaké
množství dat je posíláno pro každý snímek animace v závislosti na definované
rychlosti modemu. Při simulaci rychlosti stahování odhadne Profilovací program
typizovaný výkon, ne přesnou rychlost modemu. Například modem o rychlosti 28,8 Kbps
může teoreticky stahovat data o rychlosti 3,5 kilobytů za sekundu. Ale pokud z menu
Control vyberete 28,8, Flash nastaví skutečnou rychlost na 2,3 kilobytů za sekundu,
aby simulace více odpovídala typickému výkonu.

Můžete také vygenerovat záznam tak, aby nalezl snímky, které zpomalují přehrávání
a pak optimalizovat a eliminovat část obsahu v těchto snímcích. Pro generování záznamu
použijte volbu Select Generate Report (Zvolit generovací zprávu) v dialogovém okně
Publish Settings (Nastavení publikace).
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Optimalizace animací

Čím je soubor s animací delší, tím delší je doba potřebná k jeho stáhnutí a tím pomaleji
se animace bude přehrávat. Pro optimální přehrávání animace můžete učinit několik
kroků.  Jako část publikačního procesu Flash automaticky vykoná nějaké optimalizační
změny ve vaší animaci, včetně zjištění duplikovaných tvarů při exportu a jejich
umístění do souboru pouze jednou a konverze vnořených skupin do jednoduchých
skupin.

Před exportováním můžete animaci dále optimalizovat použitím různých strategií
pro zmenšení velikosti animace. V průběhu toho, jak děláte změny, testujte animaci
na různých počítačích, operačních systémech a připojeních k Internetu.

Optimalizace animací obecně:

� Pro každý prvek, který se objeví více než jednou, použijte symbol, animovaný 
nebo jiný.

� Kdykoliv je to možné, použijte vykreslované animace, které zaberou méně
místa v souboru než série klíčových snímků.

� Pro animované sekvence používejte namísto grafických symbolů animované
klipy.

� Omezte co nejvíce oblasti změny v každém klíčovém snímku, akce nechejte 
vykonávat na co nejmenší ploše.

� Vyhýbejte se animování bitmapových prvků; bitmapové prvky používejte
jako pozadí nebo statické prvky.

� Pro zvuk použijte formát MP3, nejmenší zvukový formát, kdykoliv je to
možné.

Optimalizace prvků a čar:

� Prvky seskupujte nejvíc, jak je to možné.

� Prvky, které se v průběhu animace mění, oddělte od těch, které se nemění.

� Použijte Modify  > Curves (Křivky) > Optimize (Optimalizovat) pro minimalizaci
počtu samostatných čar, které jsou používány pro popis tvarů.

� Omezte počet speciálních typů čar, jako jsou přerušované, tečkované, 
roztrhané a tak dále. Pevné čáry vyžadují méně paměti. Čáry vytvořené 
pomocí nástroje Tužka potřebují méně paměti než tahy štětcem.
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5. Klikněte na lištu v grafu, aby se zobrazilo nastavení odpovídajícího snímku 
v levém okně a aby se animace zastavila.

6. Přizpůsobte náhled na graf podle požadavků:

� Vyberte View > Streaming Graph (Graf streamování), aby se zobrazilo, 
které snímky způsobují pauzy.

� Tento implicitní náhled zobrazí střídavě světlé a tmavě šedé bloky představující 
jednotlivé snímky. Velikost každého bloku ukazuje jeho relativní velikost v bytech.
První snímek obsahuje všechny symboly, takže je obvykle větší než ostatní.

� Vyberte View  > Frame by Frame Graph  (Graf snímek za snímkem) pro zobrazení 
velikosti každého snímku.

� To vám umožní vidět, které snímky způsobují zpoždění streamování. Pokud
kterýkoliv blok přesáhne přes červenou čáru v grafu, pak Přehrávač Flash 
zastaví přehrávání, dokud se nestáhne celý snímek.
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Pro změnu nastavení souboru Přehrávače Flash vytvořeného pomocí Testovat animaci
a Testovat scénu, vyberte File  > Publish Settings (Nastavení publikace). Viz "Prohlížení
a testování animací".

Testování výkonu stahování:

1. ProveUte jedno z následujících:

Vyberte Control > Test Scene (Testovat scénu) nebo Control > Test Movie (Testovat
animaci).
Flash zobrazí okno Output (Výstup), aby vám umožnil odhalovat a odstraňovat problémy
v ActionScriptu. Můžete použít akci Trace (Stopa) pro zobrazení komentářů v okně Output
(Výstup) a pro pomoc s laděním. Více informací viz odpovídající témata v Referenční
příručce ActionScript.

Vyberte File  > Open (Otevřít) a označte SWF soubor.

Pokud testujete scénu nebo animaci, Flash publikuje aktuální výběr jako SWF soubor
s použitím nastavení v dialogovém okně Nastavení publikace (Viz "Publikace animací
Flash".) SWF soubor se otevře v novém okně a začne se okamžitě přehrávat.

2. V menu Debug (Ladit) v Přehrávači Flash vyberte rychlost stahování pro určení
rychlosti, kterou bude Flash simulovat: 14,4 Kbps, 28,8 Kbps, 56 Kbps.
Pro zadaní vlastního nastavení vyberte Customize (Uzpůsobit).

3. V Přehrávači Flash vyberte View  > Bandwidth Profiler pro zobrazení grafu 
výkonu stahování:

� Levá strana profilovacího programu zobrazuje informace o animaci, jejím 
nastavení a stavu. Oblast Animace zobrazuje rozměry, rychlost přehrávání 
snímků, velikost v KB a bytech, dobu trvání a předběžný počet sekund 
pro snímek.

� Pravá strana profilovacího programu zobrazuje hlavičku Časové osy a graf. 
V grafu představuje každý sloupec individuální snímek animace. Velikost 
sloupce odpovídá velikosti snímku v bytech. Dolní červená čára pod hlavičkou
Časové osy ukazuje, zda se daný snímek streamuje včas vzhledem k aktuální
rychlosti modemu nastavené v menu Control. Pokud sloupec přesáhne přes 
červenou čáru, musí animace při přehrávání počkat na nahrání daného 
snímku.

4. Vyberte View > Show Streaming (Zobrazit streamování), aby se zapnula
nebo vypnula streamovací lišta. 

� Streamovací lišta ukazuje počet nahraných snímků vedle snímku, který 
se aktuálně přehrává.
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O Generátoru a Flashi

Generátor rozšiřuje editovací prostředí Flashe tím, že umožní autorům pracovat ve Flashi
a vytvářet obsah bohatý na prostředky a doručit konečný výtvor v množství animovaných
a statických formátů.

Všechny objekty vytvořené ve Flashi - včetně položek knihovny, symbolů, animací
Časových os a výstupu publikace - mohou být změněny na Generator objects (objekty
Generátoru) použitím symbolů a Generator variables (proměnných Generátoru).
(Proměnné Generátoru jsou textem uzavřených ve složených závorkách, například
{text}.) Použitím Generátoru můžete vybrat nejlepší optické zobrazení informací pro vaše
diváky - včetně rolovacích seznamů, schémat a grafů (základních, koláčových,
stonkových a bodových), tabulek a velkého množství grafických formátů, zvuku a animací
- pro vytvoření uzpůsobených multimediálních webových zážitků v reálném čase.

Pokud máte nainstalovaný Generator 2, můžete ve Flashi vytvářet šablony, které
obsahují proměnné prvky Generátoru (grafiku, text a zvuk), které budou nahrazeny
obsahem poskytnutým zdrojem dat (textové soubory, databáze a tak dále.) Tento
generovaný obsah může být přehrán zpět v klientově prohlížeči jako animace
Přehrávače Flash nebo jako JPEG, PNG, GIF, animovaný GIF nebo soubor
QuickTime.

Ve Flashi můžete využít Generátor následujícími způsoby:

� Můžete určit, jaké bude vzájemné působení Flashe a Generátoru - včetně 
implicitní rychlosti snímků, velikosti snímku a barvy pozadí - ve Panelu 
Generátoru v dialogovém okně Nastavení publikace. Viz "Publikace šablon 
Generátoru".

� HTML šablony Flash můžete změnit pro práci v Generátoru. Viz "Uzpůsobování
HTML šablon pro publikaci".

� Použitím Movie Explorer (Prohlížeče animace) můžete aktualizovat páry 
name/value (jmen/hodnot) Generátoru. Páry jmen/hodnot jsou jména 
proměnných spojená s hodnotami, jako jsou parametry URL.
Více informací o Prohlížeči animací viz "Používání Prohlížeče animací".

� Více informací o Generátoru viz http://www.macromedia.com/generator 
nebo vaše dokumentace ke Generátoru 2.
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7. Zavřete testovací okno a vraYte se do normálního editovacího prostředí.

� Jestliže jste nastavili testovací prostředí pomocí Bandwidth Profiler, můžete
SWF soubor otevřít přímo v testovacím režimu. Soubor se otevře v přehrávacím
okně s použitím Bandwidth Profiler a dalších označených voleb náhledu.

� Více informací o ladění animací viz témata o nalézání a odstraňování problémů
v Referenční příručce ActionScript.

� Generování záznamu uvedením seznamu množství dat v konečném souboru
Přehrávače Flash podle snímků:

1. Vyberte File  > Publish Settings (Vlastnosti publikace).

2. Zvolte Select Generate Size Report (Generovat záznam o velikosti).

3. Klikněte na Publish (Publikovat).

Flash vygeneruje textový soubor stejného jména jako je exportovaný soubor s příponou
txt. Záznam uvede seznam množství dat v konečném souboru Přehrávače Flash
podle jednotlivých snímků.
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3. Označte volbu pro každý formát souboru, který chcete vytvořit.

� Automaticky je označen HTML formát, protože HTML soubor je potřebný pro 
zobrazení vaší animace Flash v prohlížeči. Dále, pokud má zvolený formát
nastavení, objeví se odpovídající záložka nad aktuálním panelem v dialogovém 
okně. Výběr formátu obrázku jako je GIF, JPEG nebo PNG automaticky přidá 
požadovaný HTML kód pro zobrazení obrázku, pokud není k dispozici 
Přehrávač Flash. 

� Více informací o nastavení publikace pro individuální formáty souboru, 
viz následující oddíly.

4. Jako Filename (Název souboru) vyberte z následujících voleb:

� Use default names (Použít implicitní názvy souboru).

� Odznačte volbu Use default names (Použít implicitní názvy). Pak zadejte
vlastní jméno souboru.

� Můžete přejít na místa, kde budete publikovat soubory a publikovat každý
soubor do jiného místa (například pokud chcete uložit SWF soubor na jedno 
místo a HTML soubor na jiné místo). Ve Windows použijte zpětná lomítka pro
určení adresáře/složky/hierarchii souborů; na Macintoshi použijte dvojtečky (:).
Pro relativní cestu použijte ..\ pro udání cesty k harddisku; pro absolutní
cestu zadejte jméno jednotky. Například:
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Publikování animací Flash

Publikace animace Flash na webu je proces o dvou krocích. Připravíte si všechny
vyžadované soubory pro doplnění aplikace Flash příkazem Publish Settings
(Nastavení publikace). Pak publikujete animaci a všechny její soubory příkazem
Publish (Publikovat). Pro přípravu obsahu Flash pro použití v jiných aplikacích
použijte příkaz Export (Exportovat); viz "Exportování animací a obrázků".

Příkaz Nastavení publikace umožní vybrat formáty a určit nastavení pro individuální
soubory zahrnuté v animaci - včetně GIF, JPEG nebo PNG - a pak tato nastavení
uchovat se souborem animace.

V závislosti na tom, co jste určili v dialogovém okně Nastavení publikace, vytvoří
příkaz Publikovat následující soubory:

� Animaci Flash pro Web (soubor SWF).

� Alternativní obrázky v různých formátech, které se automaticky objeví, pokud
není k dispozici Přehrávač Flash (GIF, JPEG, PNG a QuickTime).

� Podpůrný HTML dokument vyžadovaný pro zobrazení animace (nebo 
alternativního obrázku) v prohlížeči a kontrolu nastavení prohlížeče.

� Samostatné projektory pro systémy Windows a Macintosh a videa
QuickTime z animací Flash (příslušné soubory EXE, HQX nebo MOV).

� Pro změnu nebo aktualizaci animace vytvořené pomocí příkazu Publikovat, 
musíte upravit původní animaci Flash a pak znovu použít příkaz Publikovat, 
abyste se vyhnuli ztrátě některých autorských informací. Import animace
Přehrávače Flash do Flashe zredukuje některé autorské informace.

Nastavení voleb publikace pro soubory animace Flash:

1. Určete, kam budete publikovat soubory animace Flash:

� Vytvořte složku, ve které chcete uložit publikované soubory a uložte soubor 
animace Flash.

� Najděte a otevřete existující složku a uložte svůj soubor animace Flash.

2. Vyberte File  > Publish Settings (Nastavení publikace).
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Publikování animace Přehrávače Flash

Když publikujete animaci Přehrávače Flash, můžete nastavit volby komprese obrázků
a zvuků a volbu pro ochranu vaší animace proti importu. Pro změnu následujících
voleb použijte ovladače v panelu Flash v dialogovém okně Publish Settings
(Nastavení publikace).

Publikace animace Přehrávače Flash:

1. Vyberte File > Publish Settings (Nastavení publikace) a klikněte na záložku Flash.

2. Vyberte Load Order (Nahrát pořadí) pro nastavení pořadí, ve kterém Flash 
nahraje vrstvy animace pro zobrazení prvního snímku : Bottom Up (Zdola 
nahoru) nebo Top Down (Shora dolů).

� Tato volba dohlíží na to, které části animace se nakreslí nejdříve při pomalé 
síti nebo modemovém spojení.

3. Zvolte Generate Size Report (Generovat záznam o velikosti) pro generování
záznamu uvádějícímu množství dat v konečném souboru Flash podle snímků.
Viz "Testování výkonu stahování animace".

4. Abyste umožnili ladění publikovaného SWF souboru, zvolte jednu z následujících
voleb:

� Omit Trace Actions (Vynechat akci Stopa) způsobí, že Flash ignoruje akci
Trace (Stopa) v aktuální animaci a zabrání oknu Output (Výstup) v otevření 
a zobrazení komentářů.

� Více informací viz odpovídající témata v Referenční příručce ActionScript.

� Protect from Import (Ochránit před importem) zabrání ostatním importovat 
SWF souboru Flash a konvertovat jej zpět do animace Flash.

� Debugging Permitted (Povolit ladění) aktivuje Debugger (Ladící program
a umožní ladění animace Flash na dálku. Pokud zvolíte tuto volbu, můžete si
vybrat ochranu animace pomocí hesla.

� Pokud si přejete, zvolte Password (Heslo) pro zadání hesla, které zabrání
neoprávněným uživatelům ladit animaci Flash, která má povolení Ladění. 
Pokud přidáte heslo, musí ostatní zadat toto heslo, aby mohli soubor ladit. 
Pro odstranění hesla vymažte pole Heslo.

� Více informací o Debugger (Ladícím programu) viz odpovídající témata 
v Referenční příručce ActionScript.
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� Například ve Windows určete absolutní cestu jako
C:\Složka \názevsouboru.swf, kde C: je jméno jednotky, \Složka určuje 
jméno složky a názevsouboru.swf je jméno souboru.

� Na Macintoshi určete absolutní cestu jako 
Názevharddisku:Složka:názevsouboru.swf.

5. Pro vytvoření projektoru zvolte Windows projektor nebe Macintosh projektor.

� Ačkoliv je možné vytvořit Macintosh projektor použitím verze Flash pro
Windows, musíte také použít překladač souboru jako je BinHex, aby výsledný 
soubor vypadal jako soubor aplikace v Průzkumníku Macintosh. Verze 
Flashe pro Windows přidělí k souboru Macintosh projektoru příponu .hqx.

6. Zadejte jedinečné jméno pro Filename (Název souboru) nebo zvolte Use 
Default Name (Použít implicitní název), aby se každý soubor vytvořil s použitím
názvu souboru Flash s příslušnou příponou pro daný formát.

7. Klikněte na záložku pro volby formátu, které chcete změnit. Pro každý formát 
určete nastavení publikace, jak je popsáno v následujících oddílech.

8. Když máte nastaveny volby nastavení, proveUte jedno z následujících:

� Pro generování všech určených souborů klikněte na Publikovat nebo na
tlačítko OK.

� Pro uložení nastavení s vaším souborem a uzavření dialogového okna bez
publikace, klikněte na tlačítko OK.

Publikace animace Flash:

1. Pokud je to nutné, nastavte volby publikace pro soubory, jak bylo popsáno
v předchozím postupu.

2. Vyberte File  > Publish (Publikovat), aby se vytvořily soubory ve formátech
a umístěních určených v dialogovém okně Publish Settings (Nastavení 
publikace).
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Publikování HTML pro soubory Přehrávače Flash

Přehrání animace Flash ve www prohlížeči vyžaduje HTML dokument, který animaci
aktivuje a nastaví vlastnosti prohlížeče. Tento dokument je automaticky generován
příkazem Publish (Publikovat) z parametrů HTML v dokumentu šablony.

Parametry HTML určí, kde se objeví animace Flash v okně, barvu pozadí, velikost animace
a tak dále a nastaví atributy tagů OBJECT a EMBED. Tyto a další nastavení můžete
měnit v Panelu HTML v dialogovém okně Nastavení publikace. Změna těchto nastavení
přenastaví volby, které jste nastavili v animaci.

Vaše nastavení jsou vložena do dokumentu šablony. Dokument šablony může být
jakýkoliv textový formát, který obsahuje kód pro speciální tlumočníky jako je
ColdFusin nebo Active Server Pages (ASP) nebo šablonu vloženou ve Flashi (více
informací viz "O HTML šablonách pro publikaci").

Můžete také uzpůsobit šablonu (viz "Uzpůsobování HTML šablon pro publikaci") nebo
ručně zadat HTML parametry pro Flash použitím jakéhokoliv HTML editoru (viz
"Editování HTML nastavení Flashe".)

Publikace HTML pro zobrazení souboru Flash:

1. Vyberte File  > Publish Settings (Nastavení publikace).

� Implicitně je zvolen HTML soubor.

2. Zadejte jedinečné jméno pro Filename (Název souboru) nebo zvolte Use 
Default Name  (Použít implicitní název) pro vytvoření souboru se jménem 
souboru Flash a příponou HTML.

3. Klikněte na Panel HTML pro zobrazení jeho nastavení.

4. Vyberte instalovanou šablonu, kterou chcete použít, z kontextového menu 
Template (Šablona); klikněte na Info button (Tlačítko Informace) pro zobrazení
popisu zvolené šablony.

� Menu dává soubory šablon do seznamu ve složce Macromedia Flash/HTML. 
Základní šablony prostě zobrazí animaci v prohlížeči a rozvinutější šablony 
obsahují kód pro detekci prohlížeče a další vlastnosti. Pokud si nevyberete
šablonu, použije Flash šablonu Default.html nebo pokud tato šablona není 
k dispozici, použije Flash první šablonu na seznamu.

� Flash uloží změněnou šablonu použitím názvu souboru Flashe a přípony 
souboru šablony. Například pokud zvolíte šablonu nazvanou Standardní.asp 
pro použití animací Flash pojmenovanou Mojeanimace.swf, bude výsledný 
soubor pojmenovaný Mojeanimace.asp.
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5. Pro kontrolu komprese bitmapy, přizpůsobte posuvník JPEG Quality (Kvalita 
JPEG) nebo zadejte hodnotu.

� Nižší kvalita obrázku vytvoří menší soubory, větší kvalita obrázku vytvoří větší 
soubory. Vyzkoušejte různá nastavení, abyste nalezli nejlepší kompromis 
mezi velikostí a kvalitou, 100 poskytne nejvyšší kvalitu a nejmenší kompresi.

6. Pokud jste neurčili vzorovou rychlost a kompresi pro individuální zvuky
v dialogovém okně Sound Properties (Vlastnosti zvuku) nebo pokud si přejete 
přenastavit své nastavení, zvolte volbu:

� Klikněte na Set Audio Stream (Nastavit audio streamování) pro nastavení
rychlosti a komprese streamování exportu pro všechny zvuky animace; pak
použijte dialogové okno Vlastnosti zvuku pro nastavení audio streamování. 
Streamovaný zvuk se začne přehrávat jakmile byl nahrán dostatek dat pro
prvních pár snímků; streamovaný zvuk je pro přehrávání na webové stránce 
synchronizován s Časovou osou.

� Klikněte na Set Audio Event (Nastavit audio událost) pro nastavení rychlosti 
a komprese exportu pro všechny zvuky animace; pak použijte dialogové 
okno Vlastnosti zvuku pro nastavení audio události. Zvuk události musí být 
úplně stažen, než se začne přehrávat, a pokračuje v přehrávání než je 
výslovně zastavíte.

� Zvolte Override Sound Settings (Přenastavit nastavení zvuku) pro přepsání 
nastavení v dialogovém okně Vlastnosti zvuku pro individuální zvuky a pro
vytvoření audio animace s velmi věrnou reprodukcí pro lokální použití a s méně 
věrnou reprodukcí pro Web.

� Instrukce pro změnu těchto nastavení viz "Komprese zvuků pro export".

7. Vyberte verzi Flash. Ne všechny vlastnosti Flashe 5 fungují v animacích
publikovaných jako předchozí verze Flash.

8. Pro nastavení vlastností s aktuálním souborem klikněte na tlačítko OK.
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� Auto Low (Automaticky malá) zvýrazní rychlost především, ale zlepší vzhled, 
kdykoliv je to možné. Přehrávání začne s vypnutým potlačením roztřepení 
čar. Pokud Přehrávač Flash zjistí, že to procesor zvládne, zapne potlačení 
roztřepení čar.

� Auto High (Automaticky velká) zdůrazní rychlost přehrávání animace zprvu
stejně, ale pak obětuje vzhled za přehrávání, pokud je to nutné. Přehrávání
začne se zapnutým potlačením roztřepení čar. Pokud skutečná rychlost 
snímků poklesne pod určitou rychlost, vypne se potlačení roztřepení čar, aby 
se zvýšila rychlost přehrávání. Toto nastavení použijte pro vyrovnání 
nastavení View > Antialias (Potlačení roztřepení) ve Flashi. 

� Medium (Střední) aplikuje potlačení roztřepení částečně, ale nevyhladí 
bitmapy. Poskytuje lepší kvalitu než nastavení Malá, ale nižší než nastavení 
Velká.

� High (Velká) (implicitně) dá přednost vzhledu před rychlostí přehrávání a vždy
použije roztřepení čar. Pokud animace neobsahuje animované části, jsou 
bitmapy vyhlazeny, pokud je obsahuje, nejsou bitmapy vyhlazeny.

� Best (Nejlepší) poskytne nejlepší kvalitu zobrazení a nebere v úvahu rychlost 
přehrávání. Veškerý výstup má potlačeno roztřepení a bitmapy jsou vždy 
vyhlazeny.

7. Pro verzi Internet Explorer 4.0 pro Windows s ovladačem Flasch ActiveX, 
vyberte volbu Window Mode option (Režim Windows) pro průhlednost, 
umístění a rozvrstvení. Tato volba specifikuje vlastnost ALIGN (zarovnání) pro 
tagy OBJECT, EMBED, a IMG:

� Window (Okno) přehraje animaci Přehrávače Flash ve vlastním obdélníkovém
okně na webové stránce pro rychlejší animaci. Volba nastaví parametr 
WMODE tagu OBJECT na WINDOW.

� Opaque Windowless (Tmavé bez okna) přesune prvky za animace Flash 
(například s dynamickým HTML), aby bylo zabráněno jejich zobrazení přes, 
nastavením parametru WMODE na parametr OPAQUE.

� Transparent Windowless (Průhledné bez okna) zobrazí pozadí HTML 
stránky, do které je vložena animace, přes všechny průhledné oblasti animace,
ale může animaci zpomalit. Volba nastaví WMODE na TRANSPARENT.
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5. Vyberte volbu Dimensions (Dimenze) pro nastavení hodnot atributů WIDTH 
(Šířka) a HEIGHT (Výška) tagů OBJECT a EMBED:

� Vyberte Match Movie (Odpovídat animaci) (implicitně) pro použití velikosti 
animace.

� Vyberte Pixels pro zadání hodnoty pixelů v poli Šířka a Výška.

� Vyberte Percent (Procenta) pro nastavení procentní velikosti vzhledem k oknu
prohlížeče

6. Zvolte Playback Options (Volby přehrávání) pro ovládání  přehrávání a vlastností 
animace následovně:

� Paused at Start (Pozastaveno na začátku) pozastaví animaci, dokud uživatel 
neklikne na tlačítko v animaci nebo nezvolí Play (Přehrát) ze zkráceného
menu. Implicitně tato volba není označena a animace se začne přehrávat, 
jakmile je nahrána (parametr PLAY má hodnotu true).

� Loop (Smyčka) opakuje animaci, když dosáhne posledního snímku. 
Odznačte tuto volbu pro zastavení animace, když dosáhne posledního 
snímku. (Parametr LOOP je implicitně zapnutý.)

� Display Menu (Zobrazit menu) zobrazí zkrácené menu, když uživatel klikne
pravým tlačítkem myši (ve Windows) nebo podrží Control a klikne (na Macintoshi)
na animaci. Odznačte tuto volbu pro zobrazení pouze zkráceného menu O Flashi. 
Implicitně je tato volba zapnutá (parametr MENU je true).

� Pouze pro Windows zvolte Device Font (Font uzpůsobený na konkrétní 
zařízení) pro nahrazení systému s potlačením roztřepení (vyhlazením hran) 
pro fonty, které nejsou instalovány v uživatelově systému. Použití fontů 
uzpůsobených na konkrétní zařízení zvyšuje čitelnost písma při malých 
velikostech a může zmenšit velikost souboru animace. Tato volba ovlivní 
pouze animace obsahující statický text (text, který jste vytvořili při editaci animace
a který se při zobrazení animace nezmění) nastavený pro zobrazení s fonty
uzpůsobenými na konkrétní zařízení. Více informací viz "Používání fontů 
uzpůsobených na konkrétní zařízení".

� Zvolte Quality (Kvalitu) pro stanovení kompromisu mezi dobou běhu programu
a použitím potlačení zarovnání čar pro vyhlazení každého snímku, dříve než 
je předán na obrazovku diváka. Tato volba nastaví hodnotu parametru 
QUALITY u tagů OBJECT a EMBED.

� Low (Malá) upřednostní rychlost přehrávání před vzhledem a nepoužije
potlačení roztřepení čar.
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Publikování šablon Generátoru

Generátor vám umožní přidat do animace Flash dynamický obsah, jako je text, grafi-
ka a zvuk. Volby publikace můžete specifikovat v Panelu Generátoru v dialogovém
okně Nastavení publikace.

Publikace šablony Generátoru se souborem Flash:

1. Vyberte File  > Publish Settings (Nastavení publikace).

2. Zvolte Generator Template (typ šablony Generátoru). Jako Filename (Název
souboru) zadejte jedinečný název nebo zvolte Use Default Name (Použít
implicitní název) pro vytvoření souboru se jménem souboru Flashe
a příponou .swf.

3. Klikněte na Panel Generátoru pro zobrazení jeho nastavení.

4. Jako Dimensions (Dimenze) zadejte Width (Šířku) a Height (Výšku) v bodech
pro určení výšky a šířky animace, když je soubor konvertován do souboru 
nebo je streamován; nebo zvolte Match Movie (Odpovídat animaci), aby 
publikovaná animace měla stejnou velikost jako původní animace Flash a byl
zachován její poměr.

5. Vyberte Background color (Barvu pozadí) pro scény animace, abyste přenastavili
barvu pozadí nastavenou v příkazu Modify > Movie (Animace), následovně:

� Nastavte jméno barvy bezpečné pro web, například černá. Web-safe palette
(Paleta barev bezpečných pro web) používá 216 barev, které jsou běžné
v paletách systémů Windows a Macintosh.

� Nastavte hexadecimální hodnotu pro web (například #3434aa).

� Nastavte pravou hexadecimální hodnotu (například 0x232356).

6. Určete Frame Rate (Rychlost střídání snímků) pro nastavení jak rychle 
se budou objevovat snímky aktuální animace, když je animace přehrávána
a pro přepsání rychlosti nastavené v příkazu Modify  > Movie (Animace).

� Míra je určena ve snímcích za sekundu (fps). Pokud určíte rychlost 
přehrávání snímků 10 fps, každý snímek animace se na obrazovce objeví 
za 1/10 sekundy; 100-snímková animace se přehraje za 10 sekund.

7. Vyberte Load Order (Nahrát pořadí) pro nastavení pořadí, v němž Flash 
nahrává vrstvy animace pro zobrazení prvního snímku animace: Bottom Up
(Zdola nahoru) nebo Top Down (Shora dolů).

� Tato volba dohlíží na to, které části animace se vykreslí první  při pomalé síti 
nebo modemovém spojení.
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8. Vyberte volbu HTML Alignment (Zarovnání) pro umístění okna animace
Flash vzhledem k oknu prohlížeče:

� Default (Implicitní) umístí animaci do středu okna prohlížeče a ořeže rohy,
jestliže je okno prohlížeče menší než animace. 

� Left (Vlevo), Right (Vpravo), Top (Nahoru), Bottom (Dolů) zarovná animace 
podél odpovídajícího okraje okna prohlížeče a ořeže zbývající tři strany dle
potřeby.

9. Vyberte volbu Scale option (Změnit velikost) pro umístění animace do určitých
hranic, pokud jste změnili původní délku a šířku animace. Volba Změnit 
velikost nastaví parametr SCALE (změna velikosti) u tagů OBJECT a EMBED.

� Default (Show All) (Implicitní (Zobrazit vše)) zobrazí celou animace v určené 
oblasti bez deformace, zatímco zachová původní poměr animací. Hranice se
mohou objevit na dvou stranách animace.

� No Border (Bez hranic) změní velikost tak, aby animace vyplnila určenou
oblast a zachová původní poměr bez deformace a v případě potřeby
řeže okraje.

� Exact Fit (Přesně odpovídat) zobrazí celou animaci v určité oblast bez
zachování původního poměru, což může způsobit deformaci.

10. Vyberte volbu Flash Alignment (Zarovnání Flash) pro nastavení umístění animace
v rámci okna animace a případné ořezání. Tato volba nastaví parametr
SALIGN tagů OBJECT a EMBED.

� Jako Horizontal alignment (Horizontální zarovnání) zvolte Left (Vlevo), Center 
(Na střed) nebo Right (Vpravo).

� Jako Vertical alignment (Vertikální zarovnání) zvolte Top (Nahoru), Center
(Na střed) nebo Bottom (Dolů).

11. Zvolte Show Warning Messages (Zobrazovat upozorňující zprávy) pro 
zobrazení chybových zpráv, pokud jsou nastavení tagu v konfliktu - například
pokud má šablona kód vztahující se k alternativnímu obrázku, který nebyl 
specifikován.

12. Pro uložení nastavení s aktuálním souborem klikněte na OK.
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Flash pro GIF dokáže vygenerovat klikací mapu tak, aby zachoval odkazy na URL pro
tlačítka v originální animaci. Umístěte popisek #Map do klíčového snímku tam, kde
chcete vytvořit klikací mapu. Pokud nevytvoříte popisek, Flash klikací mapu vytvoří
použitím tlačítek v posledním snímku animace. Klikací mapu můžete vytvořit pouze
pokud je v šabloně, kterou jste vybrali, přítomna proměnná šablony $IM. Viz
„Vytváření klikací mapy“.

Publikování souboru GIF se souborem Flash:

1. Vyberte File > Publish Settings (Nastavení publikace).

2. Vyberte Typ obrázku GIF. Jako Filename (Název souboru) zadejte specifické 
jméno nebo zvolte Use Default Name (Použít implicitní název) a vytvoří se 
soubor s názvem souboru Flash a příponou .gif.

3. Klikněte na panel GIF a zobrazíte jeho nastavení.

4. Jako Dimensions (Rozsah) zadejte Šířku a Výšku v pixelech pro exportovaný 
bitmapový obrázek, nebo vyberte Match Movie (Odpovídat animaci) a GIF 
bude mít stejnou velikost jako Flash animace a zachová poměr stran vašeho
původního obrázku.

5. Vyberte volbu Playback (Přehrávání) a určete, jestli má Flash vytvořit stálý
(Static) obrázek nebo animovaný GIF (Animation). Pokud zvolíte Animaci, 
vyberte Loop Continuously (Nepřetržitě opakovat) nebo zadejte počet opakování.

6. Vyberte možnosti k určení rozsahu nastavení vzhledu pro exportovaný GIF:

� Optimize Colors (Optimalizovat barvy) odstraní všechny nepoužívané barvy 
z tabulky barev souboru GIF. Tato možnost zmenší velikost souboru o 1000
až 1500 bytů bez vlivu na kvalitu obrázku, ale lehce zvedne nároky na paměY.
Tato možnost nemá žádný vliv na adaptivní paletu. (Adaptivní paleta analyzuje
barvy v obrázku a vytváří jedinečnou tabulku barev pro vybraný GIF.)

� Interlace (Prokládat) umožní exportovaný GIF v prohlížeči zobrazovat postupně
tak, jak je stahován. Prokládaný GIF uživateli poskytuje zjednodušenou 
představu o grafickém obsahu předtím, než je soubor stažen úplně a u pomalých
připojení se může stahovat rychleji.

� Smooth (Vyhlazení) na exportovanou bitmapu aplikuje potlačení roztřepení 
a vytváří bitmapy vyšší kvality a zvyšuje kvalitu zobrazení textu. Nicméně 
vyhlazení může způsobit zobrazení šedých bodů na barevném pozadí okolo 
vyhlazeného obrázku a také zvyšuje velikost souboru GIF. Exportujte
obrázek bez vyhlazení, pokud se objeví ozáření šedými body, nebo pokud 
GIF umisYujete transparentně na vícebarevné pozadí.
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8. Vyberte Data Encoding (Kódování dat) pro nastavení kódovacího systému, 
který se použije při čtení všech zdrojů dat, na které se odvolává soubor šablony.

� Implicitní používá metodu kódování systému, z něhož šablona pochází. 
Pro všechny zdroje dat byste měli používat stejný systém kódování. Více
informací viz průvodce Používání Generátoru 2 zahrnutý v produktu Generátor.

9. Zvolte Create External Font Files (Vytvořit externí soubory fontu), aby Generátor
vytvořil soubory s fonty.

� Generator Enterprise Edition ukryje tyto soubory s fonty, aby se zrychlil 
výkon, pokud je v animaci použito mnoho fontů.

10. Zvolte External Media (Externí média) pro určení názvu šablony Generátoru 
obsahující symboly a pro zahrnutí její knihovny do zvoleného souboru.

� Tato volba vám umožní přistupovat k symbolům, jako by byly umístěny
v označeném souboru. Pokud je stejný symbol definován jak v externím 
souboru s médii, tak v aktuálním souboru, není symbol externího souboru 
s médii použit.

11. Zvolte Parameters (Parametry) pro definování proměnných; pak zadejte 
název a hodnotu proměnné.

� Tato volba vám umožní testovat šablony lokálně během jejich vytváření nebo
testování fungování proměnných při jejich zpracování.

12. Pro uložení nastavení s aktuálním souborem klikněte na tlačítko OK.

Publikace souborů GIF

Soubory GIF poskytují jednoduchý způsob exportu kreseb a jednoduchých animací
určených k použití na webových stránkách. Standardní soubory GIF jsou prostě
zkomprimované bitmapy. 

Animované GIFy (někdy nazývané také GIF89a) nabízejí snadný způsob pro export
krátkých animovaných sekvencí. Flash animované GIFy optimalizuje a ukládá pouze
změny snímek za snímkem.

Pokud jste zadáním popisku snímku #Static (statický) neoznačili jiný klíčový snímek
pro export, Flash jako GIF exportuje první snímek v animaci. Pokud jste neoznačili
rozsah snímků zadáním popisků  #First (první) a #Last (poslední) v příslušných
klíčových snímcích, Flash exportuje všechny snímky aktuální animace.
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Web Snap Adaptive (Web adaptivní) je stejné jako volba Adaptivní paleta, kromě toho,
že zkonvertuje barvy velmi podobně jako Web 216 barevnou paletu. Výsledná paleta
barev je optimalizována pro obrázek, ale pokud je to možné, používá Flash barvy
z Web 216. Když je aktivní paleta Web 216 na 256 barevném systému, dosáhne tím
pro obrázek lepších barev.

Custom (Vlastní) k určení palety, kterou jste optimalizovali pro vybraný obrázek. Tato
volba má stejnou rychlost zpracování jako paleta Web 216. Abyste mohli použít tuto
volbu, měli byste vědět, jak vlastní palety vytvářet a používat. K vybrání vlastní palety
klikněte na tlačítko Ellipsis (Elipsa) (…) vpravo od Palety ve spodní části dialogového
okna a vyberte soubor palety. Flash podporuje palety uloženy ve formátu ATC,
exportovaném Macromedia Fireworks a dalšími předními grafickými aplikacemi; pro
více informací se podívejte na „Importování a exportování barevných palet“.

10. Pokud jste v kroku 9 vybrali Adaptivní nebo Web adaptivní paletu, zadejte 
hodnotu pro Maximum barev, abyste nastavili počet barev použitých v obrázku
GIF. Zadání menšího čísla barev může způsobit menší velikost souboru, 
ale může barvy v obrázku znehodnotit.

11. Pro uložení nastavení v aktuálním souboru klikněte na tlačítko OK.

Publikace souborů JPEG

Formát JPEG vám umožní uložit obrázek jako vysoce komprimovanou, 24 bitovou
bitmapu. Obecně je GIF lepší pro export perokreseb, zatímco JPEG je lepší pro
obrázky, které obsahují plynulé zabarvení, např. fotografie, gradienty nebo vložené
bitmapy. 

Pokud jste neoznačili jiný klíčový snímek pro export zadáním popisku #Static, exportuje
Flash první snímek v animaci jako JPEG

Publikace souboru JPEG se souborem Flash:

1. Vyberte File  > Publish Settings (Nastavení pro publikaci).

2. Vyberte Typ obrázku JPEG. Jako Filename (Název souboru) zadejte specifické 
jméno nebo zvolte Use Default Name (Použít implicitní název) a vytvoří se soubor
s názvem souboru Flash a příponou .jpg.

3. Klikněte na panel JPEG a zobrazíte jeho nastavení.

4. Jako Dimensions (Rozsah) zadejte Šířku a Výšku v pixelech pro exportovaný 
bitmapový obrázek, nebo vyberte Match Movie (Odpovídat animaci) a JPEG
bude mít stejnou velikost jako Flash animace a zachová poměr stran vašeho
původního obrázku.
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� Dither Solids (Kolísání plných barev) aplikuje kolísání na plné barvy a stejně 
tak na gradienty. Viz volby Kolísání v kroku 8.

� Remove Gradients (Odstranit gradienty) (což je implicitně vypnuto), konvertuje
všechny výplně gradientem v animaci na plné barvy použitím první barvy 
gradientu. Gradienty zvyšují velikost souboru GIF a často jsou ubohé kvality.
Pokud použijete tuto volbu, vyberte první barvu gradientu opatrně, abyste 
se vyhnuli nečekaným výsledkům.

7. K určení Transparent (transparentnosti) pozadí animace a způsobu, jak jsou
nastavení alfa konvertována do GIFu, vyberte volbu Transparent:

� Opaque (Neprůhledná) vytvoří pozadí plnou barvou.

� Transparentní vytvoří transparentní pozadí.

� Alpha (Alfa) nastaví částečnou transparentnost. Potom zadejte Threshold 
(Prahovou hodnotu) mezi 0 a 255 – všechny barvy pod touto hodnotou jsou 
úplně transparentní (neviditelné) a barvy nad prahovou hodnotou jsou 
částečně transparentní. Hodnota 128 odpovídá 50% alfa (transparentní).

8. Vyberte volbu Dither (Kolísání) k určení způsobu, jak jsou pixely dostupných
barev kombinovány, aby simulovaly barvy, které nejsou v aktuální paletě
dostupné. Kolísání může zvýšit barevnou kvalitu, ale zvyšuje velikost souboru. 
Vyberte z následujících možností:

� None (Žádné) vypíná kolísání a nahradí barvy, které nejsou v základní tabulce 
barev obsaženy plnými barvami z tabulky, která se určené barvě nejvíce blíží. 
Žádné kolísání vytváří menší soubory, ale neuspokojivé barvy.

� Ordered (Spořádané) poskytuje dobrou kvalitu kolísání s nejmenším 
nárustem velikosti souboru.

� Diffusion (Rozšířené) poskytuje nejvyšší kvalitu kolísání, ale zvyšuje velikost 
souboru a dobu zpracování více než spořádané kolísání. Je možné pouze s
vybranou paletou barev Web 216 barev.

9. Vyberte Palette Type (Typ palety) k definování barevné palety obrázku:

� Web 216 používá k vytvoření obrázku GIF standardních 216 barev vhodných 
pro prohlížeč, dobrou kvalitu obrázku a nejrychlejší zpracování na serveru.

Adaptive (Adaptivní) analyzuje barvy v obrázku a vytváří jedinečnou barevnou tabulku
pro vybraný GIF. Tato volba je nejlepším řešením pro systémy, které zobrazují tisíce
nebo milióny barev; vytváří nejpreciznější barvu pro obrázek, ale výsledkem je větší
velikost souboru než u GIFu vytvořeném paletou Web 216. Ke zmenšení velikosti GIFu
s adaptivní paletou použijte volbu Max Colors (Maximum barev) ke snížení počtu
barev v paletě.
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5. Vyberte Bit Depth (Barevnou hloubku), abyste nastavili počet bitů na pixel
a barvy použité při vytváření obrázku:

� Zvolte 8-bitů pro 256 barev.

� Zvolte 24 bitů pro tisíce barev.

� Zvolte 24-bitů a Alfa pro tisíce barev s transparentností (32 bitů). Čím větší
barevná hloubka, tím větší soubor.

6. Vyberte Options (Možnosti), abyste určili nastavení vzhledu pro exportovaný 
PNG:

� Optimize Colors (Optimalizovat barvy) odstraní všechny nepoužívané barvy 
z tabulky barev souboru PNG. Tato možnost zmenší velikost souboru o 1000 
až 1500 bytů bez vlivu na kvalitu obrázku, ale lehce zvedne nároky na paměY.
Tato možnost nemá žádný vliv na adaptivní paletu. (Adaptivní paleta analyzuje 
barvy v obrázku a vytváří jedinečnou tabulku barev pro vybraný PNG.)

� Interlace (Prokládat) umožní exportovaný PNG v prohlížeči zobrazovat 
postupně tak, jak je stahován. Prokládaný PNG uživateli poskytuje
zjednodušenou představu o grafickém obsahu předtím, než je soubor 
stažen úplně a u pomalých připojení se může stahovat rychleji. 
Neprokládejte animovaný PNG.

� Smooth (Vyhlazení) aplikuje na exportovanou bitmapu potlačení roztřepení 
a vytváří bitmapy vyšší kvality a zvyšuje kvalitu zobrazení textu. Nicméně 
vyhlazení může způsobit zobrazení šedých bodů na barevném pozadí okolo 
vyhlazeného obrázku a také zvyšuje velikost souboru PNG. Exportujte
obrázek bez vyhlazení, pokud se objeví ozáření šedými body, nebo pokud
PNG umisYujete transparentně na vícebarevné pozadí.

� Dither Solids (Kolísání plných barev) aplikuje kolísání na plné barvy stejně 
jako na gradienty. Viz volby Kolísání v kroku 7.

� Remove Gradients (Odstranit gradienty) (což je implicitně vypnuto), 
konvertuje všechny výplně gradientem v animaci na plné barvy použitím 
první barvy gradientu. Gradienty zvyšují velikost souboru PNG a často jsou
ubohé kvality. Pokud použijete tuto volbu, vyberte první barvu gradientu opatrně,
abyste se vyhnuli nečekaným výsledkům.

292 Uživatelská příručka - FLASH 5

5. K určení Quality (Kvality) potáhněte posuvník nebo zadejte hodnotu použité 
komprese souboru JPEG. 

� Nižší kvalita obrázku má za následek menší soubory, zatímco vyšší kvalita
obrázku způsobí většení souboru. Abyste zjistili nejlepší kompromis mez
i velikostí a kvalitou, vyzkoušejte různá nastavení.

Poznámka: Můžete nastavit kvalitu exportu bitmapy pro objekt použitím dialogového
okna Bitmap Properties (Vlastnosti bitmapy), kde můžete změnit nastavení komprese
objektu. Vybráním volby implicitní komprese v dialogovém okně Vlastnosti bitmapy
aplikuje volbu Nastavení publikace JPEG kvality. Viz „Nastavení vlastností bitmapy“.

6. Vyberte Progressive (Postupně), abyste ve webovém prohlížeči zobrazili 
obrázek JPEG postupně, takže se grafika zobrazí rychleji, když je nahrávána
přes pomalé spojení. Tato volba je podobná jako prokládání u obrázků 
GIF a PNG.

7. Pro uložení nastavení v aktuálním souboru klikněte na tlačítko OK.

Publikace souborů PNG

PNG je pouze bitmapa, použitelná na více platformách, která podporuje transparent-
nost (alfa kanál). Je to také formát pocházející z Macromedia Fireworks. 

Pokud jste neoznačili jiný klíčový snímek pro export zadáním popisku  #Static, expor-
tuje Flash první snímek v animaci jako PNG.

Publikování souboru PNG se souborem Flash:

1. Vyberte File  > Publish Settings (Nastavení pro publikaci).

2. Vyberte Typ obrázku PNG. Jako Filename (Název souboru) zadejte specifické
jméno nebo zvolte Use Default Name (Použít implicitní název) a vytvoří se soubor
s názvem souboru Flash a příponou .png.

3. Klikněte na panel PNG a zobrazíte jeho nastavení.

4. Jako Dimensions (Rozsah) zadejte Šířku a Výšku v pixelech pro exportovaný 
bitmapový obrázek, nebo vyberte Match Movie (Odpovídat animaci) a PNG
bude mít stejnou velikost jako Flash animace a zachová poměr stran vašeho
původního obrázku.
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9. Pokud jste v kroku 8 vybrali Adaptivní nebo Web adaptivní paletu, zadejte 
hodnotu pro Maximum barev, abyste nastavili počet barev použitých v obrázku
PNG. Zadání menšího čísla barev může způsobit menší velikost souboru, ale
může barvy v obrázku znehodnotit.

10. Vyberte Filter Options (Možnosti filtru), abyste vybrali filtrační metodu řádek
za řádkem k tomu, aby byl soubor PNG lépe komprimovatelný a experimentujte
s různými volbami pro jednotlivý obrázek:

� None (Žádný) vypíná filtrování.

� Sub (Pod) přenáší rozdíl mezi každým bytem a hodnotou odpovídajícího 
bytu předcházejícího pixelu.

� Up (Nad) přenáší rozdíl mezi každým bytem a hodnotou odpovídajícího bytu 
pixelu bezprostředně nad ním.

� Average (Průměr) používá průměr dvou sousedních pixelů (vlevo a nahoře) 
k tomu, aby předpověděl hodnotu pixelu.

� Path (Trasa) vypočítává jednoduchou lineární funkci tří sousedících pixelů 
(vlevo, nahoře a vlevo nahoře) a potom tu potom použije k předpovědi 
sousedního pixelu nejblíže k vypočítané hodnotě.

� Adaptive (Adaptivní) analyzuje barvy v obrázku a vytváří jedinečnou 
barevnou tabulku pro vybraný PNG. Tato volba je nejlepším řešením pro systémy,
které zobrazují tisíce nebo milióny barev; vytváří nejpreciznější barvu pro 
obrázek, ale výsledkem je větší velikost souboru než u PNG vytvořeném
paletou Web 216. Můžete snížit velikost souboru PNG vytvořeného adaptivní 
paletou zmenšením počtu barev v paletě.

11. Pro uložení nastavení v aktuálním souboru klikněte na tlačítko OK.
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7. Vyberte volbu Dither (Kolísání) k určení způsobu, jak jsou pixely dostupných 
barev kombinovány, aby simulovaly barvy, které nejsou v aktuální paletě 
dostupné. Kolísání může zvýšit barevnou kvalitu, ale zvyšuje velikost souboru.
Vyberte z následujících možností:

� None (Žádné) vypíná kolísání a nahradí barvy, které nejsou v základní tabulce
barev obsaženy plnými barvami z tabulky, která se určené barvě nejvíce blíží. 
Žádné kolísání vytváří menší soubory, ale neuspokojivé barvy.

� Ordered (Spořádané) poskytuje dobrou kvalitu kolísání s nejmenším 
nárustem velikostí souboru.

� Diffusion (Rozšířené) poskytuje nejvyšší kvalitu kolísání, ale zvyšuje velikost 
souboru a dobu zpracování víc než spořádané kolísání. Je možné pouze 
s vybranou paletou barev Web 216 barev.

8. Vyberte Typ palety k definování barevné palety obrázku:

� Web 216 používá k vytvoření obrázku PNG standardních 216 barev vhodných 
pro prohlížeč, pro dobrou kvalitu obrázku a nejrychlejší zpracování na serveru.

� Adaptive (Adaptivní) analyzuje barvy v obrázku a vytváří jedinečnou
barevnou tabulku pro vybraný PNG. Tato volba je nejlepším řešením pro systémy, 
které zobrazují tisíce nebo milióny barev; vytváří nejpreciznější barvu pro obrázek,
ale výsledkem je větší velikost souboru než u PNG vytvořeném paletou Web 216. 

� Web Snap Adaptive (Web adaptivní) je stejné jako volba Adaptivní paleta, 
kromě toho, že zkonvertuje barvy velmi podobně jako Web 216 barevnou
paletu. Výsledná paleta barev je optimalizována pro obrázek, ale pokud je to 
možné, používá Flash barvy z Web 216. Když je aktivní paleta Web 216 na 256
barevném systému, dosáhne tím pro obrázek lepších barev. 

� Ke zmenšení velikosti PNG s adaptivní paletou použijte volbu Max Colors 
(Maximum barev) ke snížení počtu barev v paletě tak, jak je popsáno 
v následujícím kroku.

� Custom (Vlastní) k určení palety, kterou jste optimalizovali pro vybraný 
obrázek. Tato volba má stejnou rychlost zpracování jako paleta Web 216. 
Abyste mohli použít tuto volbu, měli byste vědět, jak vlastní palety vytvářet 
a používat. K vybrání vlastní palety klikněte na tlačítko Elipsa vpravo od Palety
ve spodní části dialogového okna a vyberte soubor palety. Flash podporuje
palety uloženy ve formátu ATC, exportovaném Macromedia Fireworks a dalšími
předními grafickými aplikacemi; pro více informací se podívejte na „Importování 
a exportování barevných palet“.
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7. Aby Flash exportoval všechny streamované zvuky v animaci do stopy
QuickTime s použitím standartního nastavení zvuku k rekompresi, vyberte 
Streaming Sound (Streamovaný zvuk). Abyste tyto možnosti změnili, 
klikněte na Audio Settings (Nastavení zvuku); pro více informací se podívejte
do vaší dokumentace ke QuickTime.

8. Vyberte Controller (Ovladač), abyste určili typ ovladače QuickTime, který je 
používán k přehrávání exportované animace—None (Žádný), Standart
(Standardní) nebo QuickTime  VR.

9. Vyberte Playback options (možnosti Přehrávání), abyste určili, jak bude 
QuickTime animaci přehrávat:

� Looping (Smyčka) animaci opakuje po dosažení posledního snímku.

� Paused at Start (Zastavení na začátku) animaci zastaví dokud uživatel neklikne
na tlačítko v animaci, nebo dokud nevybere Play (Přehrát) z nabídky. 
Implicitně tato možnost není vybrána, takže animace začne jakmile je nahrána.

� Play Every Frame (Přehrát každý snímek) zobrazuje každý snímek animace
bez přeskakování, takže udržuje čas na stejné úrovni a nepřehrává zvuky. 

10. Vyberte File Flatten (Make Self-Contained) (Sloučení souboru (Vytvořit vlastní
obsah)), abyste sloučili obsah Flashe a importované video do jednoduché 
QuickTime animace. Neoznačení této volby způsobí, že se QuickTime animace
odkazuje na importované soubory externě; pokud tyto soubory chybí, nebude
animace správně fungovat.)

11. Pro uložení nastavení v aktuálním souboru klikněte na tlačítko OK.

Prohlížení publikovaného formátu a nastavení

K prohlédnutí animace v publikovaném formátu a s nastavením, které jste
zvolili, můžete použít příkaz Publish Preview (Prohlédnutí publikace). Tento
příkaz soubor exportuje a otevře náhled v implicitním prohlížeči. Pokud prohlížíte
QuickTime animaci, Prohlédnutí publikace otevře Přehrávač QuickTime animace.
Pokud prohlížíte projektor, Flash otevře projektor.

Prohlížení souboru pomocí příkazu Prohlédnutí publikace:

1. Určete možnosti exportu souboru použitím příkazu Publish Settings 
(Nastavení publikace); viz „Publikování Flash animací“.
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Publikování animací QuickTime 4

Možnost Publikace QuickTime vytváří animace ve formátu QuickTime, kopíruje ani-
maci Flash na samostatnou stopu QuickTime. Animace Flash se přehrává v animaci
QuickTime úplně stejně jako v Přehrávači Flash a ponechává si všechny své interak-
tivní vlastnosti. Pokud animace Flash obsahuje animaci QuickTime, kopíruje ji Flash
do své vlastní stopy v novém souboru QuickTime. Pro více informací k animacím
QuickTime se podívejte do dokumentace ke QuickTime.

Publikování animace QuickTime 4 se souborem Flash:

1. Vyberte File  > Publish Settings (Nastavení pro publikaci).

2. Vyberte Typ obrázku QuickTime. Jako Filename (Název souboru) zadejte 
jedinečné jméno nebo zvolte Use Default Name (Použít implicitní název) a vytvoří 
se soubor s názvem souboru Flash a příponou .mov.

3. Klikněte na panel QuickTime a zobrazíte jeho nastavení.

4. Pro Dimensions (Rozsah) zadejte Šířku a Výšku v pixelech pro exportovanou 
QuickTime animaci, nebo vyberte Match Movie (Odpovídat animaci) a QuickTime
animace bude mít stejnou velikost jako Flash animace a zachová poměr stran 
vašeho původního obrázku.

5. Zvolte možnost Alpha (Alfa) k upravení transparentního (alfa) módu stopy
Flash v animaci QuickTime bez vlivu na nastavení alfa v animaci Flash:

� Alpha Transparent (Transparentní) vytvoří transparentní stopu a ukáže obsah
stop za stopou Flash.

� Copy (Kopírovat) vytvoří Flash stopu neprůhlednou a zamaskuje celý obsah
stop za stopou Flash.

� Auto vytvoří stopu Flashe transparentní, pokud je nad jinými stopami,
ale neprůhlednou, pokud je vespod nebo jedinou stopou v animaci.

6. Vyberte možnost Layer (Vrstva), abyste mohli kontrolovat, kde se stopa 
Flashe přehrává v závislosti na pořadí animace QuickTime:

� Top (Nahoře) umístí stopu Flashe vždy na vrchol dalších stop v animaci
QuickTime.

� Bottom (Dole) vždy stopu Flashe umístí za ostatní stopy.

� Auto umístí stopu Flashe dopředu jiných stop, pokud jsou objekty Flashe
před video objekty animace a za všechny ostatní stopy, pokud objekty Flashe
nejsou vpředu.
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Jako alternativu k příkazu Publish (Publikovat), můžete, pokud jste zdatní v HTML,
vytvořit vlastní HTML dokument pomocí jakéhokoliv HTML editoru a zahrnout v něm
tagy potřebné pro zobrazení animace Flash. Viz "O publikovacích šablonách HTML".

Jestliže máte Macromedia Dreamweaver, můžete na vaší webovou stránku lehce přidat
animaci Flash. Dreamweaver vygeneruje všechen potřebný HTML kód. Více informací
viz manuál k Dreamweaveru.
Dříve než budete publikovat svou animaci, je důležité otestovat, jak funguje, pomocí
příkazů Test Movie (Testovat animaci) a Test Scene (Testovat scénu). Více informací
viz "Testování výkonu stahování animace".

Přehrávání animací Flash

Formát Přehrávače Flash (SWF) je nejdůležitějším formátem pro šíření obsahu Flashe
a jediným formátem, který podporuje interaktivní funkce Flashe.

Animaci Přehrávače Flash můžete přehrát následujícími způsoby:

� V Internetovém prohlížeči, jako je Netscape Navigator a Internet Explorer, 
které jsou vybaveny Přehrávačem Flash.

� Pomocí Flash Xtra in Director a Authorware

� Pomocí ovladače Flash ActiveX control v Microsoft Office a jinými hostiteli 
ActiveX

� Jako část animace QuickTime

� Jako typ samostatné aplikace zvané projektor

� Formát souboru Přehrávače Flash je otevřeným standardem, který je
podporován jinými aplikacemi. Nejnovější informace viz webová stránka 
Macromedia na adrese http://www.macromedia.com.

270 Uživatelská příručka - FLASH 5

KAPITOLA 14

Publikování a exportování

Jestliže jste připraveni předvést svou animaci divákům, musíte FLA soubor publikovat
nebo exportovat do jiného formátu.

Funkce Publish (Publikovat) je ve Flashi navržena pro prezentaci animace na Webu.
Příkaz Publikovat vytvoří soubor Přehrávače Flash (SWF) a HTML dokument, který vloží
váš soubor Přehrávače Flash do okna prohlížeče.

Příkaz Export Movie (Exportovat animaci) vám umožní vytvářet obsah Flashe, který může
být upravován jinými aplikacemi, a exportovat animaci přímo do jednoduchého formátu.
Například můžete celou animaci exportovat jako soubor Přehrávače Flash; jako sérii
bitmapových obrázků, jako jeden soubor se snímky nebo obrázky; a jako pohybující
se nebo nehybné obrázky v různých formátech, včetně GIF, JPEG, PNG, BMP, PICT,
QuickTime nebo AVI.

S příkazem Publikovat můžete provádět následující:

Vybírat formáty, do kterých má být vytvořený soubor převeden, a přizpůsobovat
nastavení pro určité formáty souboru. Flash publikuje automaticky vytvořený soubor
ve zvolených formátech, vytvoří další soubory podle zvolených nastavení a uchová
nastavení u animace pro další použití.

Volby Export Movie (Exportovat animaci) obvykle odpovídají volbám pro publikaci,
ale neukládají nastavení pro opětovné použití.

Vytvářet alternativní formáty souboru - GIF, JPEG, PNG a QuickTime - a HTML potřebný
pro zobrazení souborů v okně prohlížeče. Alternativní formáty umožní prohlížeči
zobrazit animaci a interaktivitu uživatelům, kteří nemají nainstalovaný Přehrávač Flash.

Vytvářet šablony Generátor pro snadnou aktualizaci obsahu na webové stránce,
jako je grafika a texty, aniž by bylo třeba soubory nahrazovat individuálně. Data
Generátoru můžete například použít jako proměnné pro poskytnutí okamžité a upravené
zpětné vazby návštěvníkům vaší webové stránky ve Flashi, můžete také učinit předvedení
vaší webové stránky ve Flashi účinnější a vytvářet věci jako rolovací seznamy, které
v samotném Flashi vytvořit nelze. Viz "O Generátoru a Flashi".

KAPITOLA 14 - Správa sítě 269



Optimalizace textu a fontů:

� Omezte počet fontů a stylů fontu. Používejte zřídka vkládané fonty, protože 
zvětšují velikost souboru.

� Ve volbách Embed Fonts (Vkládané fonty) zvolte jen potřebné znaky namísto
zahrnutí celého fontu.

Optimalizace barev:

� Použijte Panel efektů (Window > Panels > Effect (Panel efektů)) pro vytvoření
mnoha různobarevných instancí jednoho symbolu.

� Použijte Míchací panel (Window > Panels > Mixer (Míchací panel)), aby se
paleta barev animace shodovala se specifickou paletou prohlížeče.

� Gradienty používejte zřídka. Vyplnění oblasti gradientní barvou vyžaduje 
o zhruba 50 bytů víc než její vyplnění jednoduchou barvou.

� Průhlednost alfa používejte zřídka, může zpomalit přehrávání.

Testování výkonu stahování animace

Abyste zjistili, kde se může animace během stahování pozastavit, můžete scénu nebo
celou animaci testovat použitím příkazu Testovat scénu nebo Testovat animaci nebo
můžete otevřít existující SWF soubor. Pokud se data nestáhnou do doby, než animace
dosáhne určitého snímku, animace se pozastaví až do jejich načtení.

Pro grafické zobrazení stahování animace můžete použít Bandwidth Profiler
(Profilovací program vlnové šířky pásma) v Přehrávači Flash, kde se zobrazí, jaké
množství dat je posíláno pro každý snímek animace v závislosti na definované
rychlosti modemu. Při simulaci rychlosti stahování odhadne Profilovací program
typizovaný výkon, ne přesnou rychlost modemu. Například modem o rychlosti 28,8 Kbps
může teoreticky stahovat data o rychlosti 3,5 kilobytů za sekundu. Ale pokud z menu
Control vyberete 28,8, Flash nastaví skutečnou rychlost na 2,3 kilobytů za sekundu,
aby simulace více odpovídala typickému výkonu.

Můžete také vygenerovat záznam tak, aby nalezl snímky, které zpomalují přehrávání
a pak optimalizovat a eliminovat část obsahu v těchto snímcích. Pro generování záznamu
použijte volbu Select Generate Report (Zvolit generovací zprávu) v dialogovém okně
Publish Settings (Nastavení publikace).
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Optimalizace animací

Čím je soubor s animací delší, tím delší je doba potřebná k jeho stáhnutí a tím pomaleji
se animace bude přehrávat. Pro optimální přehrávání animace můžete učinit několik
kroků.  Jako část publikačního procesu Flash automaticky vykoná nějaké optimalizační
změny ve vaší animaci, včetně zjištění duplikovaných tvarů při exportu a jejich
umístění do souboru pouze jednou a konverze vnořených skupin do jednoduchých
skupin.

Před exportováním můžete animaci dále optimalizovat použitím různých strategií
pro zmenšení velikosti animace. V průběhu toho, jak děláte změny, testujte animaci
na různých počítačích, operačních systémech a připojeních k Internetu.

Optimalizace animací obecně:

� Pro každý prvek, který se objeví více než jednou, použijte symbol, animovaný 
nebo jiný.

� Kdykoliv je to možné, použijte vykreslované animace, které zaberou méně
místa v souboru než série klíčových snímků.

� Pro animované sekvence používejte namísto grafických symbolů animované
klipy.

� Omezte co nejvíce oblasti změny v každém klíčovém snímku, akce nechejte 
vykonávat na co nejmenší ploše.

� Vyhýbejte se animování bitmapových prvků; bitmapové prvky používejte
jako pozadí nebo statické prvky.

� Pro zvuk použijte formát MP3, nejmenší zvukový formát, kdykoliv je to
možné.

Optimalizace prvků a čar:

� Prvky seskupujte nejvíc, jak je to možné.

� Prvky, které se v průběhu animace mění, oddělte od těch, které se nemění.

� Použijte Modify  > Curves (Křivky) > Optimize (Optimalizovat) pro minimalizaci
počtu samostatných čar, které jsou používány pro popis tvarů.

� Omezte počet speciálních typů čar, jako jsou přerušované, tečkované, 
roztrhané a tak dále. Pevné čáry vyžadují méně paměti. Čáry vytvořené 
pomocí nástroje Tužka potřebují méně paměti než tahy štětcem.
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5. Klikněte na lištu v grafu, aby se zobrazilo nastavení odpovídajícího snímku 
v levém okně a aby se animace zastavila.

6. Přizpůsobte náhled na graf podle požadavků:

� Vyberte View > Streaming Graph (Graf streamování), aby se zobrazilo, 
které snímky způsobují pauzy.

� Tento implicitní náhled zobrazí střídavě světlé a tmavě šedé bloky představující 
jednotlivé snímky. Velikost každého bloku ukazuje jeho relativní velikost v bytech.
První snímek obsahuje všechny symboly, takže je obvykle větší než ostatní.

� Vyberte View  > Frame by Frame Graph  (Graf snímek za snímkem) pro zobrazení 
velikosti každého snímku.

� To vám umožní vidět, které snímky způsobují zpoždění streamování. Pokud
kterýkoliv blok přesáhne přes červenou čáru v grafu, pak Přehrávač Flash 
zastaví přehrávání, dokud se nestáhne celý snímek.
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Pro změnu nastavení souboru Přehrávače Flash vytvořeného pomocí Testovat animaci
a Testovat scénu, vyberte File  > Publish Settings (Nastavení publikace). Viz "Prohlížení
a testování animací".

Testování výkonu stahování:

1. ProveUte jedno z následujících:

Vyberte Control > Test Scene (Testovat scénu) nebo Control > Test Movie (Testovat
animaci).
Flash zobrazí okno Output (Výstup), aby vám umožnil odhalovat a odstraňovat problémy
v ActionScriptu. Můžete použít akci Trace (Stopa) pro zobrazení komentářů v okně Output
(Výstup) a pro pomoc s laděním. Více informací viz odpovídající témata v Referenční
příručce ActionScript.

Vyberte File  > Open (Otevřít) a označte SWF soubor.

Pokud testujete scénu nebo animaci, Flash publikuje aktuální výběr jako SWF soubor
s použitím nastavení v dialogovém okně Nastavení publikace (Viz "Publikace animací
Flash".) SWF soubor se otevře v novém okně a začne se okamžitě přehrávat.

2. V menu Debug (Ladit) v Přehrávači Flash vyberte rychlost stahování pro určení
rychlosti, kterou bude Flash simulovat: 14,4 Kbps, 28,8 Kbps, 56 Kbps.
Pro zadaní vlastního nastavení vyberte Customize (Uzpůsobit).

3. V Přehrávači Flash vyberte View  > Bandwidth Profiler pro zobrazení grafu 
výkonu stahování:

� Levá strana profilovacího programu zobrazuje informace o animaci, jejím 
nastavení a stavu. Oblast Animace zobrazuje rozměry, rychlost přehrávání 
snímků, velikost v KB a bytech, dobu trvání a předběžný počet sekund 
pro snímek.

� Pravá strana profilovacího programu zobrazuje hlavičku Časové osy a graf. 
V grafu představuje každý sloupec individuální snímek animace. Velikost 
sloupce odpovídá velikosti snímku v bytech. Dolní červená čára pod hlavičkou
Časové osy ukazuje, zda se daný snímek streamuje včas vzhledem k aktuální
rychlosti modemu nastavené v menu Control. Pokud sloupec přesáhne přes 
červenou čáru, musí animace při přehrávání počkat na nahrání daného 
snímku.

4. Vyberte View > Show Streaming (Zobrazit streamování), aby se zapnula
nebo vypnula streamovací lišta. 

� Streamovací lišta ukazuje počet nahraných snímků vedle snímku, který 
se aktuálně přehrává.
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O Generátoru a Flashi

Generátor rozšiřuje editovací prostředí Flashe tím, že umožní autorům pracovat ve Flashi
a vytvářet obsah bohatý na prostředky a doručit konečný výtvor v množství animovaných
a statických formátů.

Všechny objekty vytvořené ve Flashi - včetně položek knihovny, symbolů, animací
Časových os a výstupu publikace - mohou být změněny na Generator objects (objekty
Generátoru) použitím symbolů a Generator variables (proměnných Generátoru).
(Proměnné Generátoru jsou textem uzavřených ve složených závorkách, například
{text}.) Použitím Generátoru můžete vybrat nejlepší optické zobrazení informací pro vaše
diváky - včetně rolovacích seznamů, schémat a grafů (základních, koláčových,
stonkových a bodových), tabulek a velkého množství grafických formátů, zvuku a animací
- pro vytvoření uzpůsobených multimediálních webových zážitků v reálném čase.

Pokud máte nainstalovaný Generator 2, můžete ve Flashi vytvářet šablony, které
obsahují proměnné prvky Generátoru (grafiku, text a zvuk), které budou nahrazeny
obsahem poskytnutým zdrojem dat (textové soubory, databáze a tak dále.) Tento
generovaný obsah může být přehrán zpět v klientově prohlížeči jako animace
Přehrávače Flash nebo jako JPEG, PNG, GIF, animovaný GIF nebo soubor
QuickTime.

Ve Flashi můžete využít Generátor následujícími způsoby:

� Můžete určit, jaké bude vzájemné působení Flashe a Generátoru - včetně 
implicitní rychlosti snímků, velikosti snímku a barvy pozadí - ve Panelu 
Generátoru v dialogovém okně Nastavení publikace. Viz "Publikace šablon 
Generátoru".

� HTML šablony Flash můžete změnit pro práci v Generátoru. Viz "Uzpůsobování
HTML šablon pro publikaci".

� Použitím Movie Explorer (Prohlížeče animace) můžete aktualizovat páry 
name/value (jmen/hodnot) Generátoru. Páry jmen/hodnot jsou jména 
proměnných spojená s hodnotami, jako jsou parametry URL.
Více informací o Prohlížeči animací viz "Používání Prohlížeče animací".

� Více informací o Generátoru viz http://www.macromedia.com/generator 
nebo vaše dokumentace ke Generátoru 2.
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7. Zavřete testovací okno a vraYte se do normálního editovacího prostředí.

� Jestliže jste nastavili testovací prostředí pomocí Bandwidth Profiler, můžete
SWF soubor otevřít přímo v testovacím režimu. Soubor se otevře v přehrávacím
okně s použitím Bandwidth Profiler a dalších označených voleb náhledu.

� Více informací o ladění animací viz témata o nalézání a odstraňování problémů
v Referenční příručce ActionScript.

� Generování záznamu uvedením seznamu množství dat v konečném souboru
Přehrávače Flash podle snímků:

1. Vyberte File  > Publish Settings (Vlastnosti publikace).

2. Zvolte Select Generate Size Report (Generovat záznam o velikosti).

3. Klikněte na Publish (Publikovat).

Flash vygeneruje textový soubor stejného jména jako je exportovaný soubor s příponou
txt. Záznam uvede seznam množství dat v konečném souboru Přehrávače Flash
podle jednotlivých snímků.
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3. Označte volbu pro každý formát souboru, který chcete vytvořit.

� Automaticky je označen HTML formát, protože HTML soubor je potřebný pro 
zobrazení vaší animace Flash v prohlížeči. Dále, pokud má zvolený formát
nastavení, objeví se odpovídající záložka nad aktuálním panelem v dialogovém 
okně. Výběr formátu obrázku jako je GIF, JPEG nebo PNG automaticky přidá 
požadovaný HTML kód pro zobrazení obrázku, pokud není k dispozici 
Přehrávač Flash. 

� Více informací o nastavení publikace pro individuální formáty souboru, 
viz následující oddíly.

4. Jako Filename (Název souboru) vyberte z následujících voleb:

� Use default names (Použít implicitní názvy souboru).

� Odznačte volbu Use default names (Použít implicitní názvy). Pak zadejte
vlastní jméno souboru.

� Můžete přejít na místa, kde budete publikovat soubory a publikovat každý
soubor do jiného místa (například pokud chcete uložit SWF soubor na jedno 
místo a HTML soubor na jiné místo). Ve Windows použijte zpětná lomítka pro
určení adresáře/složky/hierarchii souborů; na Macintoshi použijte dvojtečky (:).
Pro relativní cestu použijte ..\ pro udání cesty k harddisku; pro absolutní
cestu zadejte jméno jednotky. Například:
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Publikování animací Flash

Publikace animace Flash na webu je proces o dvou krocích. Připravíte si všechny
vyžadované soubory pro doplnění aplikace Flash příkazem Publish Settings
(Nastavení publikace). Pak publikujete animaci a všechny její soubory příkazem
Publish (Publikovat). Pro přípravu obsahu Flash pro použití v jiných aplikacích
použijte příkaz Export (Exportovat); viz "Exportování animací a obrázků".

Příkaz Nastavení publikace umožní vybrat formáty a určit nastavení pro individuální
soubory zahrnuté v animaci - včetně GIF, JPEG nebo PNG - a pak tato nastavení
uchovat se souborem animace.

V závislosti na tom, co jste určili v dialogovém okně Nastavení publikace, vytvoří
příkaz Publikovat následující soubory:

� Animaci Flash pro Web (soubor SWF).

� Alternativní obrázky v různých formátech, které se automaticky objeví, pokud
není k dispozici Přehrávač Flash (GIF, JPEG, PNG a QuickTime).

� Podpůrný HTML dokument vyžadovaný pro zobrazení animace (nebo 
alternativního obrázku) v prohlížeči a kontrolu nastavení prohlížeče.

� Samostatné projektory pro systémy Windows a Macintosh a videa
QuickTime z animací Flash (příslušné soubory EXE, HQX nebo MOV).

� Pro změnu nebo aktualizaci animace vytvořené pomocí příkazu Publikovat, 
musíte upravit původní animaci Flash a pak znovu použít příkaz Publikovat, 
abyste se vyhnuli ztrátě některých autorských informací. Import animace
Přehrávače Flash do Flashe zredukuje některé autorské informace.

Nastavení voleb publikace pro soubory animace Flash:

1. Určete, kam budete publikovat soubory animace Flash:

� Vytvořte složku, ve které chcete uložit publikované soubory a uložte soubor 
animace Flash.

� Najděte a otevřete existující složku a uložte svůj soubor animace Flash.

2. Vyberte File  > Publish Settings (Nastavení publikace).
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Publikování animace Přehrávače Flash

Když publikujete animaci Přehrávače Flash, můžete nastavit volby komprese obrázků
a zvuků a volbu pro ochranu vaší animace proti importu. Pro změnu následujících
voleb použijte ovladače v panelu Flash v dialogovém okně Publish Settings
(Nastavení publikace).

Publikace animace Přehrávače Flash:

1. Vyberte File > Publish Settings (Nastavení publikace) a klikněte na záložku Flash.

2. Vyberte Load Order (Nahrát pořadí) pro nastavení pořadí, ve kterém Flash 
nahraje vrstvy animace pro zobrazení prvního snímku : Bottom Up (Zdola 
nahoru) nebo Top Down (Shora dolů).

� Tato volba dohlíží na to, které části animace se nakreslí nejdříve při pomalé 
síti nebo modemovém spojení.

3. Zvolte Generate Size Report (Generovat záznam o velikosti) pro generování
záznamu uvádějícímu množství dat v konečném souboru Flash podle snímků.
Viz "Testování výkonu stahování animace".

4. Abyste umožnili ladění publikovaného SWF souboru, zvolte jednu z následujících
voleb:

� Omit Trace Actions (Vynechat akci Stopa) způsobí, že Flash ignoruje akci
Trace (Stopa) v aktuální animaci a zabrání oknu Output (Výstup) v otevření 
a zobrazení komentářů.

� Více informací viz odpovídající témata v Referenční příručce ActionScript.

� Protect from Import (Ochránit před importem) zabrání ostatním importovat 
SWF souboru Flash a konvertovat jej zpět do animace Flash.

� Debugging Permitted (Povolit ladění) aktivuje Debugger (Ladící program
a umožní ladění animace Flash na dálku. Pokud zvolíte tuto volbu, můžete si
vybrat ochranu animace pomocí hesla.

� Pokud si přejete, zvolte Password (Heslo) pro zadání hesla, které zabrání
neoprávněným uživatelům ladit animaci Flash, která má povolení Ladění. 
Pokud přidáte heslo, musí ostatní zadat toto heslo, aby mohli soubor ladit. 
Pro odstranění hesla vymažte pole Heslo.

� Více informací o Debugger (Ladícím programu) viz odpovídající témata 
v Referenční příručce ActionScript.
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� Například ve Windows určete absolutní cestu jako
C:\Složka \názevsouboru.swf, kde C: je jméno jednotky, \Složka určuje 
jméno složky a názevsouboru.swf je jméno souboru.

� Na Macintoshi určete absolutní cestu jako 
Názevharddisku:Složka:názevsouboru.swf.

5. Pro vytvoření projektoru zvolte Windows projektor nebe Macintosh projektor.

� Ačkoliv je možné vytvořit Macintosh projektor použitím verze Flash pro
Windows, musíte také použít překladač souboru jako je BinHex, aby výsledný 
soubor vypadal jako soubor aplikace v Průzkumníku Macintosh. Verze 
Flashe pro Windows přidělí k souboru Macintosh projektoru příponu .hqx.

6. Zadejte jedinečné jméno pro Filename (Název souboru) nebo zvolte Use 
Default Name (Použít implicitní název), aby se každý soubor vytvořil s použitím
názvu souboru Flash s příslušnou příponou pro daný formát.

7. Klikněte na záložku pro volby formátu, které chcete změnit. Pro každý formát 
určete nastavení publikace, jak je popsáno v následujících oddílech.

8. Když máte nastaveny volby nastavení, proveUte jedno z následujících:

� Pro generování všech určených souborů klikněte na Publikovat nebo na
tlačítko OK.

� Pro uložení nastavení s vaším souborem a uzavření dialogového okna bez
publikace, klikněte na tlačítko OK.

Publikace animace Flash:

1. Pokud je to nutné, nastavte volby publikace pro soubory, jak bylo popsáno
v předchozím postupu.

2. Vyberte File  > Publish (Publikovat), aby se vytvořily soubory ve formátech
a umístěních určených v dialogovém okně Publish Settings (Nastavení 
publikace).
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Publikování HTML pro soubory Přehrávače Flash

Přehrání animace Flash ve www prohlížeči vyžaduje HTML dokument, který animaci
aktivuje a nastaví vlastnosti prohlížeče. Tento dokument je automaticky generován
příkazem Publish (Publikovat) z parametrů HTML v dokumentu šablony.

Parametry HTML určí, kde se objeví animace Flash v okně, barvu pozadí, velikost animace
a tak dále a nastaví atributy tagů OBJECT a EMBED. Tyto a další nastavení můžete
měnit v Panelu HTML v dialogovém okně Nastavení publikace. Změna těchto nastavení
přenastaví volby, které jste nastavili v animaci.

Vaše nastavení jsou vložena do dokumentu šablony. Dokument šablony může být
jakýkoliv textový formát, který obsahuje kód pro speciální tlumočníky jako je
ColdFusin nebo Active Server Pages (ASP) nebo šablonu vloženou ve Flashi (více
informací viz "O HTML šablonách pro publikaci").

Můžete také uzpůsobit šablonu (viz "Uzpůsobování HTML šablon pro publikaci") nebo
ručně zadat HTML parametry pro Flash použitím jakéhokoliv HTML editoru (viz
"Editování HTML nastavení Flashe".)

Publikace HTML pro zobrazení souboru Flash:

1. Vyberte File  > Publish Settings (Nastavení publikace).

� Implicitně je zvolen HTML soubor.

2. Zadejte jedinečné jméno pro Filename (Název souboru) nebo zvolte Use 
Default Name  (Použít implicitní název) pro vytvoření souboru se jménem 
souboru Flash a příponou HTML.

3. Klikněte na Panel HTML pro zobrazení jeho nastavení.

4. Vyberte instalovanou šablonu, kterou chcete použít, z kontextového menu 
Template (Šablona); klikněte na Info button (Tlačítko Informace) pro zobrazení
popisu zvolené šablony.

� Menu dává soubory šablon do seznamu ve složce Macromedia Flash/HTML. 
Základní šablony prostě zobrazí animaci v prohlížeči a rozvinutější šablony 
obsahují kód pro detekci prohlížeče a další vlastnosti. Pokud si nevyberete
šablonu, použije Flash šablonu Default.html nebo pokud tato šablona není 
k dispozici, použije Flash první šablonu na seznamu.

� Flash uloží změněnou šablonu použitím názvu souboru Flashe a přípony 
souboru šablony. Například pokud zvolíte šablonu nazvanou Standardní.asp 
pro použití animací Flash pojmenovanou Mojeanimace.swf, bude výsledný 
soubor pojmenovaný Mojeanimace.asp.
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5. Pro kontrolu komprese bitmapy, přizpůsobte posuvník JPEG Quality (Kvalita 
JPEG) nebo zadejte hodnotu.

� Nižší kvalita obrázku vytvoří menší soubory, větší kvalita obrázku vytvoří větší 
soubory. Vyzkoušejte různá nastavení, abyste nalezli nejlepší kompromis 
mezi velikostí a kvalitou, 100 poskytne nejvyšší kvalitu a nejmenší kompresi.

6. Pokud jste neurčili vzorovou rychlost a kompresi pro individuální zvuky
v dialogovém okně Sound Properties (Vlastnosti zvuku) nebo pokud si přejete 
přenastavit své nastavení, zvolte volbu:

� Klikněte na Set Audio Stream (Nastavit audio streamování) pro nastavení
rychlosti a komprese streamování exportu pro všechny zvuky animace; pak
použijte dialogové okno Vlastnosti zvuku pro nastavení audio streamování. 
Streamovaný zvuk se začne přehrávat jakmile byl nahrán dostatek dat pro
prvních pár snímků; streamovaný zvuk je pro přehrávání na webové stránce 
synchronizován s Časovou osou.

� Klikněte na Set Audio Event (Nastavit audio událost) pro nastavení rychlosti 
a komprese exportu pro všechny zvuky animace; pak použijte dialogové 
okno Vlastnosti zvuku pro nastavení audio události. Zvuk události musí být 
úplně stažen, než se začne přehrávat, a pokračuje v přehrávání než je 
výslovně zastavíte.

� Zvolte Override Sound Settings (Přenastavit nastavení zvuku) pro přepsání 
nastavení v dialogovém okně Vlastnosti zvuku pro individuální zvuky a pro
vytvoření audio animace s velmi věrnou reprodukcí pro lokální použití a s méně 
věrnou reprodukcí pro Web.

� Instrukce pro změnu těchto nastavení viz "Komprese zvuků pro export".

7. Vyberte verzi Flash. Ne všechny vlastnosti Flashe 5 fungují v animacích
publikovaných jako předchozí verze Flash.

8. Pro nastavení vlastností s aktuálním souborem klikněte na tlačítko OK.
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� Auto Low (Automaticky malá) zvýrazní rychlost především, ale zlepší vzhled, 
kdykoliv je to možné. Přehrávání začne s vypnutým potlačením roztřepení 
čar. Pokud Přehrávač Flash zjistí, že to procesor zvládne, zapne potlačení 
roztřepení čar.

� Auto High (Automaticky velká) zdůrazní rychlost přehrávání animace zprvu
stejně, ale pak obětuje vzhled za přehrávání, pokud je to nutné. Přehrávání
začne se zapnutým potlačením roztřepení čar. Pokud skutečná rychlost 
snímků poklesne pod určitou rychlost, vypne se potlačení roztřepení čar, aby 
se zvýšila rychlost přehrávání. Toto nastavení použijte pro vyrovnání 
nastavení View > Antialias (Potlačení roztřepení) ve Flashi. 

� Medium (Střední) aplikuje potlačení roztřepení částečně, ale nevyhladí 
bitmapy. Poskytuje lepší kvalitu než nastavení Malá, ale nižší než nastavení 
Velká.

� High (Velká) (implicitně) dá přednost vzhledu před rychlostí přehrávání a vždy
použije roztřepení čar. Pokud animace neobsahuje animované části, jsou 
bitmapy vyhlazeny, pokud je obsahuje, nejsou bitmapy vyhlazeny.

� Best (Nejlepší) poskytne nejlepší kvalitu zobrazení a nebere v úvahu rychlost 
přehrávání. Veškerý výstup má potlačeno roztřepení a bitmapy jsou vždy 
vyhlazeny.

7. Pro verzi Internet Explorer 4.0 pro Windows s ovladačem Flasch ActiveX, 
vyberte volbu Window Mode option (Režim Windows) pro průhlednost, 
umístění a rozvrstvení. Tato volba specifikuje vlastnost ALIGN (zarovnání) pro 
tagy OBJECT, EMBED, a IMG:

� Window (Okno) přehraje animaci Přehrávače Flash ve vlastním obdélníkovém
okně na webové stránce pro rychlejší animaci. Volba nastaví parametr 
WMODE tagu OBJECT na WINDOW.

� Opaque Windowless (Tmavé bez okna) přesune prvky za animace Flash 
(například s dynamickým HTML), aby bylo zabráněno jejich zobrazení přes, 
nastavením parametru WMODE na parametr OPAQUE.

� Transparent Windowless (Průhledné bez okna) zobrazí pozadí HTML 
stránky, do které je vložena animace, přes všechny průhledné oblasti animace,
ale může animaci zpomalit. Volba nastaví WMODE na TRANSPARENT.
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5. Vyberte volbu Dimensions (Dimenze) pro nastavení hodnot atributů WIDTH 
(Šířka) a HEIGHT (Výška) tagů OBJECT a EMBED:

� Vyberte Match Movie (Odpovídat animaci) (implicitně) pro použití velikosti 
animace.

� Vyberte Pixels pro zadání hodnoty pixelů v poli Šířka a Výška.

� Vyberte Percent (Procenta) pro nastavení procentní velikosti vzhledem k oknu
prohlížeče

6. Zvolte Playback Options (Volby přehrávání) pro ovládání  přehrávání a vlastností 
animace následovně:

� Paused at Start (Pozastaveno na začátku) pozastaví animaci, dokud uživatel 
neklikne na tlačítko v animaci nebo nezvolí Play (Přehrát) ze zkráceného
menu. Implicitně tato volba není označena a animace se začne přehrávat, 
jakmile je nahrána (parametr PLAY má hodnotu true).

� Loop (Smyčka) opakuje animaci, když dosáhne posledního snímku. 
Odznačte tuto volbu pro zastavení animace, když dosáhne posledního 
snímku. (Parametr LOOP je implicitně zapnutý.)

� Display Menu (Zobrazit menu) zobrazí zkrácené menu, když uživatel klikne
pravým tlačítkem myši (ve Windows) nebo podrží Control a klikne (na Macintoshi)
na animaci. Odznačte tuto volbu pro zobrazení pouze zkráceného menu O Flashi. 
Implicitně je tato volba zapnutá (parametr MENU je true).

� Pouze pro Windows zvolte Device Font (Font uzpůsobený na konkrétní 
zařízení) pro nahrazení systému s potlačením roztřepení (vyhlazením hran) 
pro fonty, které nejsou instalovány v uživatelově systému. Použití fontů 
uzpůsobených na konkrétní zařízení zvyšuje čitelnost písma při malých 
velikostech a může zmenšit velikost souboru animace. Tato volba ovlivní 
pouze animace obsahující statický text (text, který jste vytvořili při editaci animace
a který se při zobrazení animace nezmění) nastavený pro zobrazení s fonty
uzpůsobenými na konkrétní zařízení. Více informací viz "Používání fontů 
uzpůsobených na konkrétní zařízení".

� Zvolte Quality (Kvalitu) pro stanovení kompromisu mezi dobou běhu programu
a použitím potlačení zarovnání čar pro vyhlazení každého snímku, dříve než 
je předán na obrazovku diváka. Tato volba nastaví hodnotu parametru 
QUALITY u tagů OBJECT a EMBED.

� Low (Malá) upřednostní rychlost přehrávání před vzhledem a nepoužije
potlačení roztřepení čar.
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Publikování šablon Generátoru

Generátor vám umožní přidat do animace Flash dynamický obsah, jako je text, grafi-
ka a zvuk. Volby publikace můžete specifikovat v Panelu Generátoru v dialogovém
okně Nastavení publikace.

Publikace šablony Generátoru se souborem Flash:

1. Vyberte File  > Publish Settings (Nastavení publikace).

2. Zvolte Generator Template (typ šablony Generátoru). Jako Filename (Název
souboru) zadejte jedinečný název nebo zvolte Use Default Name (Použít
implicitní název) pro vytvoření souboru se jménem souboru Flashe
a příponou .swf.

3. Klikněte na Panel Generátoru pro zobrazení jeho nastavení.

4. Jako Dimensions (Dimenze) zadejte Width (Šířku) a Height (Výšku) v bodech
pro určení výšky a šířky animace, když je soubor konvertován do souboru 
nebo je streamován; nebo zvolte Match Movie (Odpovídat animaci), aby 
publikovaná animace měla stejnou velikost jako původní animace Flash a byl
zachován její poměr.

5. Vyberte Background color (Barvu pozadí) pro scény animace, abyste přenastavili
barvu pozadí nastavenou v příkazu Modify > Movie (Animace), následovně:

� Nastavte jméno barvy bezpečné pro web, například černá. Web-safe palette
(Paleta barev bezpečných pro web) používá 216 barev, které jsou běžné
v paletách systémů Windows a Macintosh.

� Nastavte hexadecimální hodnotu pro web (například #3434aa).

� Nastavte pravou hexadecimální hodnotu (například 0x232356).

6. Určete Frame Rate (Rychlost střídání snímků) pro nastavení jak rychle 
se budou objevovat snímky aktuální animace, když je animace přehrávána
a pro přepsání rychlosti nastavené v příkazu Modify  > Movie (Animace).

� Míra je určena ve snímcích za sekundu (fps). Pokud určíte rychlost 
přehrávání snímků 10 fps, každý snímek animace se na obrazovce objeví 
za 1/10 sekundy; 100-snímková animace se přehraje za 10 sekund.

7. Vyberte Load Order (Nahrát pořadí) pro nastavení pořadí, v němž Flash 
nahrává vrstvy animace pro zobrazení prvního snímku animace: Bottom Up
(Zdola nahoru) nebo Top Down (Shora dolů).

� Tato volba dohlíží na to, které části animace se vykreslí první  při pomalé síti 
nebo modemovém spojení.
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8. Vyberte volbu HTML Alignment (Zarovnání) pro umístění okna animace
Flash vzhledem k oknu prohlížeče:

� Default (Implicitní) umístí animaci do středu okna prohlížeče a ořeže rohy,
jestliže je okno prohlížeče menší než animace. 

� Left (Vlevo), Right (Vpravo), Top (Nahoru), Bottom (Dolů) zarovná animace 
podél odpovídajícího okraje okna prohlížeče a ořeže zbývající tři strany dle
potřeby.

9. Vyberte volbu Scale option (Změnit velikost) pro umístění animace do určitých
hranic, pokud jste změnili původní délku a šířku animace. Volba Změnit 
velikost nastaví parametr SCALE (změna velikosti) u tagů OBJECT a EMBED.

� Default (Show All) (Implicitní (Zobrazit vše)) zobrazí celou animace v určené 
oblasti bez deformace, zatímco zachová původní poměr animací. Hranice se
mohou objevit na dvou stranách animace.

� No Border (Bez hranic) změní velikost tak, aby animace vyplnila určenou
oblast a zachová původní poměr bez deformace a v případě potřeby
řeže okraje.

� Exact Fit (Přesně odpovídat) zobrazí celou animaci v určité oblast bez
zachování původního poměru, což může způsobit deformaci.

10. Vyberte volbu Flash Alignment (Zarovnání Flash) pro nastavení umístění animace
v rámci okna animace a případné ořezání. Tato volba nastaví parametr
SALIGN tagů OBJECT a EMBED.

� Jako Horizontal alignment (Horizontální zarovnání) zvolte Left (Vlevo), Center 
(Na střed) nebo Right (Vpravo).

� Jako Vertical alignment (Vertikální zarovnání) zvolte Top (Nahoru), Center
(Na střed) nebo Bottom (Dolů).

11. Zvolte Show Warning Messages (Zobrazovat upozorňující zprávy) pro 
zobrazení chybových zpráv, pokud jsou nastavení tagu v konfliktu - například
pokud má šablona kód vztahující se k alternativnímu obrázku, který nebyl 
specifikován.

12. Pro uložení nastavení s aktuálním souborem klikněte na OK.

KAPITOLA 14 - Správa sítě 285



Flash pro GIF dokáže vygenerovat klikací mapu tak, aby zachoval odkazy na URL pro
tlačítka v originální animaci. Umístěte popisek #Map do klíčového snímku tam, kde
chcete vytvořit klikací mapu. Pokud nevytvoříte popisek, Flash klikací mapu vytvoří
použitím tlačítek v posledním snímku animace. Klikací mapu můžete vytvořit pouze
pokud je v šabloně, kterou jste vybrali, přítomna proměnná šablony $IM. Viz
„Vytváření klikací mapy“.

Publikování souboru GIF se souborem Flash:

1. Vyberte File > Publish Settings (Nastavení publikace).

2. Vyberte Typ obrázku GIF. Jako Filename (Název souboru) zadejte specifické 
jméno nebo zvolte Use Default Name (Použít implicitní název) a vytvoří se 
soubor s názvem souboru Flash a příponou .gif.

3. Klikněte na panel GIF a zobrazíte jeho nastavení.

4. Jako Dimensions (Rozsah) zadejte Šířku a Výšku v pixelech pro exportovaný 
bitmapový obrázek, nebo vyberte Match Movie (Odpovídat animaci) a GIF 
bude mít stejnou velikost jako Flash animace a zachová poměr stran vašeho
původního obrázku.

5. Vyberte volbu Playback (Přehrávání) a určete, jestli má Flash vytvořit stálý
(Static) obrázek nebo animovaný GIF (Animation). Pokud zvolíte Animaci, 
vyberte Loop Continuously (Nepřetržitě opakovat) nebo zadejte počet opakování.

6. Vyberte možnosti k určení rozsahu nastavení vzhledu pro exportovaný GIF:

� Optimize Colors (Optimalizovat barvy) odstraní všechny nepoužívané barvy 
z tabulky barev souboru GIF. Tato možnost zmenší velikost souboru o 1000
až 1500 bytů bez vlivu na kvalitu obrázku, ale lehce zvedne nároky na paměY.
Tato možnost nemá žádný vliv na adaptivní paletu. (Adaptivní paleta analyzuje
barvy v obrázku a vytváří jedinečnou tabulku barev pro vybraný GIF.)

� Interlace (Prokládat) umožní exportovaný GIF v prohlížeči zobrazovat postupně
tak, jak je stahován. Prokládaný GIF uživateli poskytuje zjednodušenou 
představu o grafickém obsahu předtím, než je soubor stažen úplně a u pomalých
připojení se může stahovat rychleji.

� Smooth (Vyhlazení) na exportovanou bitmapu aplikuje potlačení roztřepení 
a vytváří bitmapy vyšší kvality a zvyšuje kvalitu zobrazení textu. Nicméně 
vyhlazení může způsobit zobrazení šedých bodů na barevném pozadí okolo 
vyhlazeného obrázku a také zvyšuje velikost souboru GIF. Exportujte
obrázek bez vyhlazení, pokud se objeví ozáření šedými body, nebo pokud 
GIF umisYujete transparentně na vícebarevné pozadí.
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8. Vyberte Data Encoding (Kódování dat) pro nastavení kódovacího systému, 
který se použije při čtení všech zdrojů dat, na které se odvolává soubor šablony.

� Implicitní používá metodu kódování systému, z něhož šablona pochází. 
Pro všechny zdroje dat byste měli používat stejný systém kódování. Více
informací viz průvodce Používání Generátoru 2 zahrnutý v produktu Generátor.

9. Zvolte Create External Font Files (Vytvořit externí soubory fontu), aby Generátor
vytvořil soubory s fonty.

� Generator Enterprise Edition ukryje tyto soubory s fonty, aby se zrychlil 
výkon, pokud je v animaci použito mnoho fontů.

10. Zvolte External Media (Externí média) pro určení názvu šablony Generátoru 
obsahující symboly a pro zahrnutí její knihovny do zvoleného souboru.

� Tato volba vám umožní přistupovat k symbolům, jako by byly umístěny
v označeném souboru. Pokud je stejný symbol definován jak v externím 
souboru s médii, tak v aktuálním souboru, není symbol externího souboru 
s médii použit.

11. Zvolte Parameters (Parametry) pro definování proměnných; pak zadejte 
název a hodnotu proměnné.

� Tato volba vám umožní testovat šablony lokálně během jejich vytváření nebo
testování fungování proměnných při jejich zpracování.

12. Pro uložení nastavení s aktuálním souborem klikněte na tlačítko OK.

Publikace souborů GIF

Soubory GIF poskytují jednoduchý způsob exportu kreseb a jednoduchých animací
určených k použití na webových stránkách. Standardní soubory GIF jsou prostě
zkomprimované bitmapy. 

Animované GIFy (někdy nazývané také GIF89a) nabízejí snadný způsob pro export
krátkých animovaných sekvencí. Flash animované GIFy optimalizuje a ukládá pouze
změny snímek za snímkem.

Pokud jste zadáním popisku snímku #Static (statický) neoznačili jiný klíčový snímek
pro export, Flash jako GIF exportuje první snímek v animaci. Pokud jste neoznačili
rozsah snímků zadáním popisků  #First (první) a #Last (poslední) v příslušných
klíčových snímcích, Flash exportuje všechny snímky aktuální animace.
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Web Snap Adaptive (Web adaptivní) je stejné jako volba Adaptivní paleta, kromě toho,
že zkonvertuje barvy velmi podobně jako Web 216 barevnou paletu. Výsledná paleta
barev je optimalizována pro obrázek, ale pokud je to možné, používá Flash barvy
z Web 216. Když je aktivní paleta Web 216 na 256 barevném systému, dosáhne tím
pro obrázek lepších barev.

Custom (Vlastní) k určení palety, kterou jste optimalizovali pro vybraný obrázek. Tato
volba má stejnou rychlost zpracování jako paleta Web 216. Abyste mohli použít tuto
volbu, měli byste vědět, jak vlastní palety vytvářet a používat. K vybrání vlastní palety
klikněte na tlačítko Ellipsis (Elipsa) (…) vpravo od Palety ve spodní části dialogového
okna a vyberte soubor palety. Flash podporuje palety uloženy ve formátu ATC,
exportovaném Macromedia Fireworks a dalšími předními grafickými aplikacemi; pro
více informací se podívejte na „Importování a exportování barevných palet“.

10. Pokud jste v kroku 9 vybrali Adaptivní nebo Web adaptivní paletu, zadejte 
hodnotu pro Maximum barev, abyste nastavili počet barev použitých v obrázku
GIF. Zadání menšího čísla barev může způsobit menší velikost souboru, 
ale může barvy v obrázku znehodnotit.

11. Pro uložení nastavení v aktuálním souboru klikněte na tlačítko OK.

Publikace souborů JPEG

Formát JPEG vám umožní uložit obrázek jako vysoce komprimovanou, 24 bitovou
bitmapu. Obecně je GIF lepší pro export perokreseb, zatímco JPEG je lepší pro
obrázky, které obsahují plynulé zabarvení, např. fotografie, gradienty nebo vložené
bitmapy. 

Pokud jste neoznačili jiný klíčový snímek pro export zadáním popisku #Static, exportuje
Flash první snímek v animaci jako JPEG

Publikace souboru JPEG se souborem Flash:

1. Vyberte File  > Publish Settings (Nastavení pro publikaci).

2. Vyberte Typ obrázku JPEG. Jako Filename (Název souboru) zadejte specifické 
jméno nebo zvolte Use Default Name (Použít implicitní název) a vytvoří se soubor
s názvem souboru Flash a příponou .jpg.

3. Klikněte na panel JPEG a zobrazíte jeho nastavení.

4. Jako Dimensions (Rozsah) zadejte Šířku a Výšku v pixelech pro exportovaný 
bitmapový obrázek, nebo vyberte Match Movie (Odpovídat animaci) a JPEG
bude mít stejnou velikost jako Flash animace a zachová poměr stran vašeho
původního obrázku.
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� Dither Solids (Kolísání plných barev) aplikuje kolísání na plné barvy a stejně 
tak na gradienty. Viz volby Kolísání v kroku 8.

� Remove Gradients (Odstranit gradienty) (což je implicitně vypnuto), konvertuje
všechny výplně gradientem v animaci na plné barvy použitím první barvy 
gradientu. Gradienty zvyšují velikost souboru GIF a často jsou ubohé kvality.
Pokud použijete tuto volbu, vyberte první barvu gradientu opatrně, abyste 
se vyhnuli nečekaným výsledkům.

7. K určení Transparent (transparentnosti) pozadí animace a způsobu, jak jsou
nastavení alfa konvertována do GIFu, vyberte volbu Transparent:

� Opaque (Neprůhledná) vytvoří pozadí plnou barvou.

� Transparentní vytvoří transparentní pozadí.

� Alpha (Alfa) nastaví částečnou transparentnost. Potom zadejte Threshold 
(Prahovou hodnotu) mezi 0 a 255 – všechny barvy pod touto hodnotou jsou 
úplně transparentní (neviditelné) a barvy nad prahovou hodnotou jsou 
částečně transparentní. Hodnota 128 odpovídá 50% alfa (transparentní).

8. Vyberte volbu Dither (Kolísání) k určení způsobu, jak jsou pixely dostupných
barev kombinovány, aby simulovaly barvy, které nejsou v aktuální paletě
dostupné. Kolísání může zvýšit barevnou kvalitu, ale zvyšuje velikost souboru. 
Vyberte z následujících možností:

� None (Žádné) vypíná kolísání a nahradí barvy, které nejsou v základní tabulce 
barev obsaženy plnými barvami z tabulky, která se určené barvě nejvíce blíží. 
Žádné kolísání vytváří menší soubory, ale neuspokojivé barvy.

� Ordered (Spořádané) poskytuje dobrou kvalitu kolísání s nejmenším 
nárustem velikosti souboru.

� Diffusion (Rozšířené) poskytuje nejvyšší kvalitu kolísání, ale zvyšuje velikost 
souboru a dobu zpracování více než spořádané kolísání. Je možné pouze s
vybranou paletou barev Web 216 barev.

9. Vyberte Palette Type (Typ palety) k definování barevné palety obrázku:

� Web 216 používá k vytvoření obrázku GIF standardních 216 barev vhodných 
pro prohlížeč, dobrou kvalitu obrázku a nejrychlejší zpracování na serveru.

Adaptive (Adaptivní) analyzuje barvy v obrázku a vytváří jedinečnou barevnou tabulku
pro vybraný GIF. Tato volba je nejlepším řešením pro systémy, které zobrazují tisíce
nebo milióny barev; vytváří nejpreciznější barvu pro obrázek, ale výsledkem je větší
velikost souboru než u GIFu vytvořeném paletou Web 216. Ke zmenšení velikosti GIFu
s adaptivní paletou použijte volbu Max Colors (Maximum barev) ke snížení počtu
barev v paletě.
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5. Vyberte Bit Depth (Barevnou hloubku), abyste nastavili počet bitů na pixel
a barvy použité při vytváření obrázku:

� Zvolte 8-bitů pro 256 barev.

� Zvolte 24 bitů pro tisíce barev.

� Zvolte 24-bitů a Alfa pro tisíce barev s transparentností (32 bitů). Čím větší
barevná hloubka, tím větší soubor.

6. Vyberte Options (Možnosti), abyste určili nastavení vzhledu pro exportovaný 
PNG:

� Optimize Colors (Optimalizovat barvy) odstraní všechny nepoužívané barvy 
z tabulky barev souboru PNG. Tato možnost zmenší velikost souboru o 1000 
až 1500 bytů bez vlivu na kvalitu obrázku, ale lehce zvedne nároky na paměY.
Tato možnost nemá žádný vliv na adaptivní paletu. (Adaptivní paleta analyzuje 
barvy v obrázku a vytváří jedinečnou tabulku barev pro vybraný PNG.)

� Interlace (Prokládat) umožní exportovaný PNG v prohlížeči zobrazovat 
postupně tak, jak je stahován. Prokládaný PNG uživateli poskytuje
zjednodušenou představu o grafickém obsahu předtím, než je soubor 
stažen úplně a u pomalých připojení se může stahovat rychleji. 
Neprokládejte animovaný PNG.

� Smooth (Vyhlazení) aplikuje na exportovanou bitmapu potlačení roztřepení 
a vytváří bitmapy vyšší kvality a zvyšuje kvalitu zobrazení textu. Nicméně 
vyhlazení může způsobit zobrazení šedých bodů na barevném pozadí okolo 
vyhlazeného obrázku a také zvyšuje velikost souboru PNG. Exportujte
obrázek bez vyhlazení, pokud se objeví ozáření šedými body, nebo pokud
PNG umisYujete transparentně na vícebarevné pozadí.

� Dither Solids (Kolísání plných barev) aplikuje kolísání na plné barvy stejně 
jako na gradienty. Viz volby Kolísání v kroku 7.

� Remove Gradients (Odstranit gradienty) (což je implicitně vypnuto), 
konvertuje všechny výplně gradientem v animaci na plné barvy použitím 
první barvy gradientu. Gradienty zvyšují velikost souboru PNG a často jsou
ubohé kvality. Pokud použijete tuto volbu, vyberte první barvu gradientu opatrně,
abyste se vyhnuli nečekaným výsledkům.
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5. K určení Quality (Kvality) potáhněte posuvník nebo zadejte hodnotu použité 
komprese souboru JPEG. 

� Nižší kvalita obrázku má za následek menší soubory, zatímco vyšší kvalita
obrázku způsobí většení souboru. Abyste zjistili nejlepší kompromis mez
i velikostí a kvalitou, vyzkoušejte různá nastavení.

Poznámka: Můžete nastavit kvalitu exportu bitmapy pro objekt použitím dialogového
okna Bitmap Properties (Vlastnosti bitmapy), kde můžete změnit nastavení komprese
objektu. Vybráním volby implicitní komprese v dialogovém okně Vlastnosti bitmapy
aplikuje volbu Nastavení publikace JPEG kvality. Viz „Nastavení vlastností bitmapy“.

6. Vyberte Progressive (Postupně), abyste ve webovém prohlížeči zobrazili 
obrázek JPEG postupně, takže se grafika zobrazí rychleji, když je nahrávána
přes pomalé spojení. Tato volba je podobná jako prokládání u obrázků 
GIF a PNG.

7. Pro uložení nastavení v aktuálním souboru klikněte na tlačítko OK.

Publikace souborů PNG

PNG je pouze bitmapa, použitelná na více platformách, která podporuje transparent-
nost (alfa kanál). Je to také formát pocházející z Macromedia Fireworks. 

Pokud jste neoznačili jiný klíčový snímek pro export zadáním popisku  #Static, expor-
tuje Flash první snímek v animaci jako PNG.

Publikování souboru PNG se souborem Flash:

1. Vyberte File  > Publish Settings (Nastavení pro publikaci).

2. Vyberte Typ obrázku PNG. Jako Filename (Název souboru) zadejte specifické
jméno nebo zvolte Use Default Name (Použít implicitní název) a vytvoří se soubor
s názvem souboru Flash a příponou .png.

3. Klikněte na panel PNG a zobrazíte jeho nastavení.

4. Jako Dimensions (Rozsah) zadejte Šířku a Výšku v pixelech pro exportovaný 
bitmapový obrázek, nebo vyberte Match Movie (Odpovídat animaci) a PNG
bude mít stejnou velikost jako Flash animace a zachová poměr stran vašeho
původního obrázku.
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9. Pokud jste v kroku 8 vybrali Adaptivní nebo Web adaptivní paletu, zadejte 
hodnotu pro Maximum barev, abyste nastavili počet barev použitých v obrázku
PNG. Zadání menšího čísla barev může způsobit menší velikost souboru, ale
může barvy v obrázku znehodnotit.

10. Vyberte Filter Options (Možnosti filtru), abyste vybrali filtrační metodu řádek
za řádkem k tomu, aby byl soubor PNG lépe komprimovatelný a experimentujte
s různými volbami pro jednotlivý obrázek:

� None (Žádný) vypíná filtrování.

� Sub (Pod) přenáší rozdíl mezi každým bytem a hodnotou odpovídajícího 
bytu předcházejícího pixelu.

� Up (Nad) přenáší rozdíl mezi každým bytem a hodnotou odpovídajícího bytu 
pixelu bezprostředně nad ním.

� Average (Průměr) používá průměr dvou sousedních pixelů (vlevo a nahoře) 
k tomu, aby předpověděl hodnotu pixelu.

� Path (Trasa) vypočítává jednoduchou lineární funkci tří sousedících pixelů 
(vlevo, nahoře a vlevo nahoře) a potom tu potom použije k předpovědi 
sousedního pixelu nejblíže k vypočítané hodnotě.

� Adaptive (Adaptivní) analyzuje barvy v obrázku a vytváří jedinečnou 
barevnou tabulku pro vybraný PNG. Tato volba je nejlepším řešením pro systémy,
které zobrazují tisíce nebo milióny barev; vytváří nejpreciznější barvu pro 
obrázek, ale výsledkem je větší velikost souboru než u PNG vytvořeném
paletou Web 216. Můžete snížit velikost souboru PNG vytvořeného adaptivní 
paletou zmenšením počtu barev v paletě.

11. Pro uložení nastavení v aktuálním souboru klikněte na tlačítko OK.
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7. Vyberte volbu Dither (Kolísání) k určení způsobu, jak jsou pixely dostupných 
barev kombinovány, aby simulovaly barvy, které nejsou v aktuální paletě 
dostupné. Kolísání může zvýšit barevnou kvalitu, ale zvyšuje velikost souboru.
Vyberte z následujících možností:

� None (Žádné) vypíná kolísání a nahradí barvy, které nejsou v základní tabulce
barev obsaženy plnými barvami z tabulky, která se určené barvě nejvíce blíží. 
Žádné kolísání vytváří menší soubory, ale neuspokojivé barvy.

� Ordered (Spořádané) poskytuje dobrou kvalitu kolísání s nejmenším 
nárustem velikostí souboru.

� Diffusion (Rozšířené) poskytuje nejvyšší kvalitu kolísání, ale zvyšuje velikost 
souboru a dobu zpracování víc než spořádané kolísání. Je možné pouze 
s vybranou paletou barev Web 216 barev.

8. Vyberte Typ palety k definování barevné palety obrázku:

� Web 216 používá k vytvoření obrázku PNG standardních 216 barev vhodných 
pro prohlížeč, pro dobrou kvalitu obrázku a nejrychlejší zpracování na serveru.

� Adaptive (Adaptivní) analyzuje barvy v obrázku a vytváří jedinečnou
barevnou tabulku pro vybraný PNG. Tato volba je nejlepším řešením pro systémy, 
které zobrazují tisíce nebo milióny barev; vytváří nejpreciznější barvu pro obrázek,
ale výsledkem je větší velikost souboru než u PNG vytvořeném paletou Web 216. 

� Web Snap Adaptive (Web adaptivní) je stejné jako volba Adaptivní paleta, 
kromě toho, že zkonvertuje barvy velmi podobně jako Web 216 barevnou
paletu. Výsledná paleta barev je optimalizována pro obrázek, ale pokud je to 
možné, používá Flash barvy z Web 216. Když je aktivní paleta Web 216 na 256
barevném systému, dosáhne tím pro obrázek lepších barev. 

� Ke zmenšení velikosti PNG s adaptivní paletou použijte volbu Max Colors 
(Maximum barev) ke snížení počtu barev v paletě tak, jak je popsáno 
v následujícím kroku.

� Custom (Vlastní) k určení palety, kterou jste optimalizovali pro vybraný 
obrázek. Tato volba má stejnou rychlost zpracování jako paleta Web 216. 
Abyste mohli použít tuto volbu, měli byste vědět, jak vlastní palety vytvářet 
a používat. K vybrání vlastní palety klikněte na tlačítko Elipsa vpravo od Palety
ve spodní části dialogového okna a vyberte soubor palety. Flash podporuje
palety uloženy ve formátu ATC, exportovaném Macromedia Fireworks a dalšími
předními grafickými aplikacemi; pro více informací se podívejte na „Importování 
a exportování barevných palet“.
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7. Aby Flash exportoval všechny streamované zvuky v animaci do stopy
QuickTime s použitím standartního nastavení zvuku k rekompresi, vyberte 
Streaming Sound (Streamovaný zvuk). Abyste tyto možnosti změnili, 
klikněte na Audio Settings (Nastavení zvuku); pro více informací se podívejte
do vaší dokumentace ke QuickTime.

8. Vyberte Controller (Ovladač), abyste určili typ ovladače QuickTime, který je 
používán k přehrávání exportované animace—None (Žádný), Standart
(Standardní) nebo QuickTime  VR.

9. Vyberte Playback options (možnosti Přehrávání), abyste určili, jak bude 
QuickTime animaci přehrávat:

� Looping (Smyčka) animaci opakuje po dosažení posledního snímku.

� Paused at Start (Zastavení na začátku) animaci zastaví dokud uživatel neklikne
na tlačítko v animaci, nebo dokud nevybere Play (Přehrát) z nabídky. 
Implicitně tato možnost není vybrána, takže animace začne jakmile je nahrána.

� Play Every Frame (Přehrát každý snímek) zobrazuje každý snímek animace
bez přeskakování, takže udržuje čas na stejné úrovni a nepřehrává zvuky. 

10. Vyberte File Flatten (Make Self-Contained) (Sloučení souboru (Vytvořit vlastní
obsah)), abyste sloučili obsah Flashe a importované video do jednoduché 
QuickTime animace. Neoznačení této volby způsobí, že se QuickTime animace
odkazuje na importované soubory externě; pokud tyto soubory chybí, nebude
animace správně fungovat.)

11. Pro uložení nastavení v aktuálním souboru klikněte na tlačítko OK.

Prohlížení publikovaného formátu a nastavení

K prohlédnutí animace v publikovaném formátu a s nastavením, které jste
zvolili, můžete použít příkaz Publish Preview (Prohlédnutí publikace). Tento
příkaz soubor exportuje a otevře náhled v implicitním prohlížeči. Pokud prohlížíte
QuickTime animaci, Prohlédnutí publikace otevře Přehrávač QuickTime animace.
Pokud prohlížíte projektor, Flash otevře projektor.

Prohlížení souboru pomocí příkazu Prohlédnutí publikace:

1. Určete možnosti exportu souboru použitím příkazu Publish Settings 
(Nastavení publikace); viz „Publikování Flash animací“.
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Publikování animací QuickTime 4

Možnost Publikace QuickTime vytváří animace ve formátu QuickTime, kopíruje ani-
maci Flash na samostatnou stopu QuickTime. Animace Flash se přehrává v animaci
QuickTime úplně stejně jako v Přehrávači Flash a ponechává si všechny své interak-
tivní vlastnosti. Pokud animace Flash obsahuje animaci QuickTime, kopíruje ji Flash
do své vlastní stopy v novém souboru QuickTime. Pro více informací k animacím
QuickTime se podívejte do dokumentace ke QuickTime.

Publikování animace QuickTime 4 se souborem Flash:

1. Vyberte File  > Publish Settings (Nastavení pro publikaci).

2. Vyberte Typ obrázku QuickTime. Jako Filename (Název souboru) zadejte 
jedinečné jméno nebo zvolte Use Default Name (Použít implicitní název) a vytvoří 
se soubor s názvem souboru Flash a příponou .mov.

3. Klikněte na panel QuickTime a zobrazíte jeho nastavení.

4. Pro Dimensions (Rozsah) zadejte Šířku a Výšku v pixelech pro exportovanou 
QuickTime animaci, nebo vyberte Match Movie (Odpovídat animaci) a QuickTime
animace bude mít stejnou velikost jako Flash animace a zachová poměr stran 
vašeho původního obrázku.

5. Zvolte možnost Alpha (Alfa) k upravení transparentního (alfa) módu stopy
Flash v animaci QuickTime bez vlivu na nastavení alfa v animaci Flash:

� Alpha Transparent (Transparentní) vytvoří transparentní stopu a ukáže obsah
stop za stopou Flash.

� Copy (Kopírovat) vytvoří Flash stopu neprůhlednou a zamaskuje celý obsah
stop za stopou Flash.

� Auto vytvoří stopu Flashe transparentní, pokud je nad jinými stopami,
ale neprůhlednou, pokud je vespod nebo jedinou stopou v animaci.

6. Vyberte možnost Layer (Vrstva), abyste mohli kontrolovat, kde se stopa 
Flashe přehrává v závislosti na pořadí animace QuickTime:

� Top (Nahoře) umístí stopu Flashe vždy na vrchol dalších stop v animaci
QuickTime.

� Bottom (Dole) vždy stopu Flashe umístí za ostatní stopy.

� Auto umístí stopu Flashe dopředu jiných stop, pokud jsou objekty Flashe
před video objekty animace a za všechny ostatní stopy, pokud objekty Flashe
nejsou vpředu.
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Příkaz Export Movie (Exportovat animaci) vám umožní animaci exportovat do formá-
tu statického obrázku a vytvoří číslovaný obrázkový soubor pro každý snímek v animaci.
Příkaz Exportovat animaci  můžete také použít k exportu zvuku do souboru WAV
(pouze Windows).

K exportu obsahu aktuálního snímku nebo aktuálně vybraného obrázku do jednoho
ze statických formátu obrázku, nebo do animace jednoduchého snímku, použijte
příkaz Export Image (Exportovat obrázek).

Když exportujete obrázek Flash jako soubor vektorové grafiky (ve formátu Adobe
Illustrator), zachováváte jeho vektorové informace. Tyto soubory můžete upravovat
v jiných vektorových grafických programech, ale nemůžete je importovat do většiny
sázecích programů a textových editorů.

Pokud obrázek Flashe ukládáte jako bitmapu GIF, JPEG, PICT (Macintosh) nebo BMP
(Windows), obrázek ztrácí svou vektorovou informaci a je ukládán pouze s informacemi
o pixelech. Flash obrázky exportované jako bitmapy můžete upravovat v grafických
editorech jako Adobe Photoshop, ale už je nikdy nemůžete editovat ve vektorových
grafických programech.

Exportování animace nebo obrázku:

1. Pokud exportujete obrázek, vyberte z aktuální animace snímek nebo
obrázek, který chcete exportovat.

2. Vyberte File > Export Movie (Exportovat animaci) nebo File  > Export Image
(Exportovat obrázek).

3. Zadejte jméno výstupního souboru.

4. Z kontextové nabídky Formátu vyberte formát souboru.

5. Klikněte na tlačítko Save (Uložit). 

� Pokud formát, který jste vybrali vyžaduje další informace, objeví se Exportní
dialogové okno.

6. Nastavte možnosti exportu pro vybraný formát tak, jak je popsáno v následujících
částech. 

� Možnosti exportu a nastavení publikace jsou stejné pro Flash animace a šablony
Generátoru. Pro informace k dalším formátům exportu je podívejte na následující 
část.

7. Klikněte na tlačítko OK, potom Save (Uložit).
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2. ProveUte jedno z následujících:

� Vyberte File  > Publish Preview (Náhled publikace) a z podnabídky vyberte 
formát souboru, který chcete prohlížet

� Stiskněte F12 pro export a prohlédnutí implicitního formátu. Flash použitím
aktuálních hodnot Nastavení publikace vytvoří soubor určeného typu ve stejném
umístění jako soubor animace. Tento soubor v tomto umístění zůstává,
dokud ho nepřepíšete nebo nesmažete.

Používání samostatného přehrávače

Samostatný přehrávač animaci pro Flash Přehrávač přehrává okamžitě, jakmile se objeví
v internetovém prohlížeči nebo v aplikaci ActiveX. Samostatný přehrávač je nainstalován
společně s Flashem (pojmenován FlashPla.exe ve Windows a FlashPlayer na Macintoshi).
Pokud dvojkliknete na soubor Flash Přehrávače, operační systém spustí samostatný
přehrávač, který následně spustí animaci.

Animace v samostatném prohlížeči můžete kontrolovat používáním příkazů nabídky
a akce FSCommand. Pokud chcete například přehrávač spustit přes celou obra-
zovku, přiřadíte akci FSCommand  ke snímku nebo tlačítku a poté vyberte příkaz
Fullscreen (Celá obrazovka) s argumentem True. Pro více informací se podívejte na
„Kontrola dalších animací a klipů animace“.

K ovládání animací v samostatném prohlížeči vyberte z následujících možností:

� Otevřete nový nebo existující soubor vybráním File > New nebo File  > Open.

� Změňte náhled na animaci vybráním View > Magnification (Zvětšení)
a z podnabídky vyberte Show All (Ukázat vše), Zoom In (Zvětšit), Zoom Out 
(Zmenšit) nebo 100%.

� Ovládejte přehrávání animace vybráním Control > Play (Přehrávání), Rewind 
(Přetočit), Loop (Smyčka), Step (Krok), Forward (Vpřed) nebo Step Backward
(Krok zpět).

Exportování animací a obrázků

K přípravě obsahu Flashe pro použití v dalších aplikacích nebo k exportu obsahu
aktuální animace do zvláštního formátu souboru použijte příkazy Export Movie
(Exportovat animaci) a Export Image (Exportovat obrázek). Příkazy Exportovat neukládají
nastavení exportu odděleně s každým souborem tak, jak to dělá příkaz Publikovat.
(Použijte Publikovat k vytvoření všech souborů, které potřebujete k umístění animace
na Web. Viz „Publikování Flash animací“.)
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Adobe Illustrator

Formát Adobe Illustrator je ideální pro výměnu kreseb mezi Flashem a jinými grafickými
programy, např. FreeHand. Tento formát podporuje velmi precizní konverzi křivek,
stylu čar a informaci výplně. Flash podporuje import a export formátu Adobe Illustrator
88, 3.0, 5.0 a 6.0. (Viz „Soubory Adobe Illustrator“.) Flash nepodporuje formát
Photoshop EPS nebo soubory EPS, které jsou generovány použitím Print (Tisku). 

Verze formátu Adobe Illustratoru nižší než 5 nepodporuje gradientní výplně a pouze
verze 6 podporuje bitmapy.

Exportní dialogové okno Adobe Illustratoru vám umožní vybrat jeho verzi—88, 3.0, 5.0
nebo 6.0.

Aby exportované soubory Flashe byly kompatibilní s Adobe Illustrator 8.0 nebo
vyšším, použijte plug-in Macromedia Flashwriter pro Adobe Illustrator, který je
součástí produktu Flash.

Animované Gify. GIF sekvence a obrázky GIF

Tato možnost vám umožní exportovat soubory ve formátu GIF. Nastavení jsou stejná
jako ta, která jsou dostupné na záložce GIF v dialogovém okně Nastavení publikace,
kromě následujících výjimek:

� Resolution (Rozlišení) je nastaveno v bodech na palec (dpi). Rozlišení můžete
zadat nebo klikněte na tlačítko Match Screen (Odpovídat obrazovce) a použije
se rozlišení obrazovky.

� Include (Obsah) vám umožní vybrat minimální oblast obrázku k exportu
nebo určit plnou velikost dokumentu.

� Colors (Barvy) vám umožní nastavit počet barev, které mohou být použity 
k vytvoření exportovaného obrázku—černobílá; 4-, 8-, 16-, 32-, 64-, 128- nebo 
256- bitová barva; nebo Standardní barva (standardní 216 barevná pro web 
bezpečná paleta).

� Můžete také vybrat rozhraní, vyhlazení, transparentní nebo kolísání pevných
barev. Pro informace k těmto volbám se podívejte na „Publikování souborů GIF“.

Animation (Animace) je dostupná pouze při exportu formátu Animovaný GIF a umožní
vám zadat počet opakování – 0 opakuje nekonečně.
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Export formátů souboru

Flash animace a obrázky můžete exportovat do více než tuctu různých formátů, jak je
ukázáno v následující tabulce. Animace jsou exportovány jako sekvence a obrázky
jako samostatné soubory. PNG je pouze bitmapa pro více platforem, která podporuje
transparentnost (alfa kanál). Některé nebitmapové formáty exportu alfa kanál
(transparentnost) nebo vrstvy masky nepodporují. 

Pro více informací k specifickému formátu se podívejte na následující část.
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Typ souboru
„Adobe Illustrator“ 
na straně 341
Animovaný GIF, GIF
sekvence, Obrázek GIF
Bitmapa (BMP) 
na straně 342
DXF sekvence 
a obrázek 
AutoCAD DXF 
Enhanced Windows
Metafile
EPS (verze 6 nebo
dřívější)
FutureSplash Player
Šablona Generátoru 
„JPEG sekvence 
a obrázek JPEG 
na straně“ 343
PICT sekvence
(Macintosh)
„PNG sekvence 
a obrázek PNG“ 
na straně 344
„Publikované
QuickTime 4 animace“ 
na straně 336
„Animace QuickTime
(Macintosh)“
na straně 345
„Zvuk WAV (Windows)“ 
na straně 345
„Windows AVI
(Windows)“ 
na straně 346
Winows Metafile
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EPS 3.0 s Náhledem

Aktuální snímek můžete pro umístění v dalších aplikacích, jako je sázecí program,
exportovat jako soubor EPS 3.0. EPS (encapsulated (=zapouzdřený) PostScript®)
soubor může být tisknut Postskriptovou tiskárnou. Jako možnost exportovaného EPS
souboru můžete zahrnout náhled bitmapy pro aplikace, které EPS soubory dokáží
importovat a tisknout (například Microsoft Word a Adobe PageMaker®), ale nedokáží
je zobrazit na obrazovce. Flash nenabízí pro soubory EPS žádné definovatelné
možnosti exportu.

Přehrávač FutureSplash

Tento souborový formát byl používán Flashem před tím, než byl koupen společností
Macromedia. Možnosti exportu se rovnají možnostem nastavení Flash publikace. Viz
„Publikování animace pro Flash přehrávač“.

JPEG Sekvence a JPEG obrázek

Možnosti exportu pro JPEG se rovnají možnostem Nastavení publikace JPEG s jednou
výjimkou: volba exportu Match Screen (Odpovídat obrazovce) srovná exportovaný
obrázek s velikostí animace tak, jak se objevuje na obrazovce. (Volba publikování
Match Movie (Odpovídat animaci) vytvoří obrázek JPEG se stejnou velikostí jako
animace a zachová poměr stran originálního obrázku.)

Pro více informací se podívejte na „Publikování souborů JPEG“.

PICT (Macintosh)

PICT je standardní grafický formát na Macintoshi a může obsahovat bitmapovou nebo
vektorovou informaci. K nastavení následujících možností použijte Exportní dialogové
okno PICT:

� Dimensions (Rozměr) nastavuje velikost exportované bitmapy v pixelech. 
Flash zabezpečí, že velikost, kterou jste určili, má vždycky stejný poměr
stran jako váš originální obrázek.

� Resolution (Rozlišení) nastavuje rozlišení exportovaného bitmapového 
obrázku v bodech na palec (dpi) a Flash automaticky počítá šířku a výšku 
založenou na velikosti vaší kresby. Abyste nastavili rozlišení vašeho monitoru,
vyberte Match Screen (Odpovídat obrazovce). Bitmapy PICT obvykle vypadají 
nejlépe na obrazovce s rozlišením 72-dpi.
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Bitmapa (BMP)

Tento formát vám umožňuje vytvářet bitmapové obrázky pro použití v jiných
aplikacích. Možnosti dialogového okna Exportu nabízí tyto volby:

� Dimensions (Rozměr) nastavuje velikost exportované bitmapy v pixelech. 
Flash zabezpečí, že velikost, kterou jste určili, má vždycky stejný poměr 
stran jako váš originální obrázek.

� Resolution (Rozlišení) nastavuje rozlišení exportovaného bitmapového
obrázku v bodech na palec (dpi) a Flash automaticky počítá šířku a výšku 
založenou na velikosti vaší kresby. Abyste nastavili rozlišení jako má váš 
monitor, vyberte Match Screen (Odpovídat obrazovce).

� Color Depth (Barevná hloubka) určuje bitovou hloubku obrázku. Některé 
Windows aplikace nepodporují novější 32-bitovou hloubku pro bitmapové 
obrázky; pokud máte problémy s používáním 32-bitového formátu, použijte 
starší 24-bitový formát.

� Smooth (Vyhlazení) aplikuje potlačení roztřepení na exportovanou bitmapu
a vytváří bitmapy vyšší kvality, ale může způsobit zobrazení šedých bodů 
na barevném pozadí okolo vyhlazeného obrázku. Exportujte obrázek bez
vyhlazení, pokud se objeví ozáření šedými body.

DXF Sekvence a obrázek AutoCAD DXF

Tento 3D formát vám umožní exportovat části vaší animace jako soubory AutoCAD
DXF číslo verze 10, takže pro další úpravy mohou být vneseny do DXF-kompatibilní
aplikace.

Tento formát nemá žádné definovatelné možnosti.

Enhanced Metafile (Windows)

Formát Enhanced Metafile (EMF) je grafický formát dostupný ve Windows 95 
a Windows NT, který ukládá jak vektorovou, tak bitmapovou informaci. EMF podporuje
křivky použité v kresbách Flashe lépe, než starší Windows Metafile formát. Ačkoli
mnoho aplikací ještě tento novější grafický formát nepodporuje. 

Tento formát nemá žádné definovatelné možnosti.
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QuickTime

Volba exportu QuickTime vytvoří animaci se stopou Flash ve formátu QuickTime 4.
Všechny vrstvy ve Flash projektu jsou exportovány jako jednoduché Flash stopy.
Tento formát exportu vám umožní sloučit interaktivní možnosti Flashe s možnostmi
multimédií a videa v QuickTime v jednoduché QuickTime 4 animaci, která může být
prohlížena čímkoli s QuickTime 4 plug-inem. 

Tyto možnosti exportu jsou totožné s možnostmi publikace QuickTime. Viz
„Publikování QuickTime 4 animací“ na straně 336.

QuickTime Video (Macintosh)

Formát QuickTime video konvertuje Flash projekt do sekvence bitmap vložených do
video stopy souboru. Obsah Flashe je exportován jako bitmapový obrázek bez
jakékoli interaktivity. Tento formát je užitečný pro úpravy obsahu Flashe v aplikacích
pro editování videa.

Dialogové okno Exportu QuickTime videa obsahuje následující možnosti:

� Dimensions (Rozsah) určuje šířku a výšku v pixelech pro snímky QuickTime
animace. Implicitně můžete určit pouze šířku nebo výšku a další rozměr 
je automaticky nastaven tak, aby byl zachován poměr stran vaší originální 
animace. K nastavení výšky i šířky odznačte Maintain Aspect Ratio (Zachovat
poměr stran).

� Formát vybere barevnou hloubku. Možnosti jsou černobílá; ; 4-, 8-, 16- nebo
24-bitová barva; a 32-bitová barva s alfa kanálem (transparentnost).

� Smooth (Vyhlazení) aplikuje potlačení roztřepení na exportovanou 
QuickTime animaci a vytváří bitmapy vyšší kvality, ale může způsobit 
zobrazení šedých bodů na barevném pozadí okolo vyhlazeného obrázku. 
Exportujte obrázek bez vyhlazení, pokud se objeví ozáření šedými body.

� Compressor (Komprimace) vybere standardní QuickTime komprimaci. Pro
více informací se podívejte na dokumentaci ke QuickTime.

� Quality (Kvalita) kontroluje velikost komprese aplikované na vaší animaci.
Efekt závisí na vybrané komprimaci.

� Sound Format (Zvukový formát) nastavuje exportovanou míru pro zvuky
v animaci. Vyšší míra poskytuje lepší věrnost a větší soubory. Nižší míry šetří 
místo.
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� Color Depth (Barevná hloubka) určuje, jestli je soubor PICT založen na
objektech nebo bitmapě. Obrázky založené na objektech vypadají obecně 
lépe vytištěné a úprava rozměrů nemá vliv na vzhled. Bitmapové obrázky 
PICT normálně vypadají nejlépe na obrazovce a mohou být zpracovány 
v aplikacích jako Adobe Photoshop®. U bitmapových souborů PICT si můžete
zvolit rozsah barevné hloubky.

Include Postscript (Zahrnout Postskript) je dostupný pouze pro objektově založený
PICT soubor a zahrnuje informaci pro optimalizaci tisku na Postskriptové tiskárně.
Tato informace způsobuje zvětšení souboru a není rozpoznána všemi aplikacemi.

PNG sekvence a PNG obrázek

Tyto nastavení exportu jsou podobné možnostem Nastavení publikace PNG, 
s následujícími výjimkami:

� Dimension (Rozměr) nastaví velikost exportované bitmapy na počet pixelů, 
který jste zadali v polích Width (Šířka) a Height (Výška).

� Resolution (Rozlišení) vám umožní zadat rozlišení v bodech na palec (dpi). 
Abyste použili rozlišení obrazovky a uchovali poměr stran vašeho originálního
obrázku, vyberte Match Screen (Odpovídat obrazovce).

� Colors (Barvy) je totožná s možností Bit Depth (Bitová hloubka) v záložce
Nastavení publikace PNG a nastaví počet bitů na pixel, které se použijí při
vytváření obrázku. Pro 256 barevný obrázek vyberte 8 bitů; pro tisíce barev 
vyberte 24 bitů; pro tisíce barev s transparentností (32 bitů) vyberte 24 bitů s Alfa 
kanálem. Čím je vyšší bitová hloubka, tím je soubor větší. 

� Include (Zahrnout) vám umožní vybrat minimální oblast obrázku pro export 
nebo určit plnou velikost dokumentu.

� Filter (Filtr) srovná možnosti s možnostmi v záložce Nastavení publikace PNG. 

� Navíc můžete vybrat Interlace (Prokládat) a exportovaný PNG se bude 
v prohlížeči zobrazovat postupně tak, jak se bude stahovat; Smooth
(Vyhlazení) aplikuje potlačení roztřepení na exportovanou bitmapu a vytvoří
bitmapový obrázek vyšší kvality a zvýší kvalitu zobrazení textu; Dither Solid 
Colors (Kolísání plných barev) aplikuje kolísání na plné barvy a gradienty. 

� Pro informace k těmto možnostem se podívejte na „Publikování souborů PNG“.
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HTML šablony pro publikaci

Šablony HTML vám umožňují ovládat, jaká animace patří na Web stránku a jak vypadá
a přehrává se v internetovém prohlížeči. Flash šablona je textový soubor, který
obsahuje neměnný HTML kód i kód šablony nebo proměnných (které se odlišují
od ActionScript proměnných). Když publikujete Flash animaci, Flash nahrazuje
proměnné v šabloně, které jste vybrali v dialogovém okně Publish Settings (Nastavení
publikace), vaším nastavením HTML a výsledkem je HTML stránka s vloženou animací.

Flash zahrnuje různé šablony vhodné pro většinu uživatelových potřeb, které eliminují
potřebu editovat HTML stránku s Flash animací. Například jedna šablona jednoduše
umístí Flash animaci na vygenerovanou HTML stránku, takže ji uživatelé, pokud mají
nainstalován plug-in, mohou prohlížet pomocí internetového prohlížeče. Jiná šablona
dělá to stejné kromě toho, že nejdříve zjistí, jestli je plug-in nainstalován, a když ne,
tak ho nainstaluje. 
Jednoduše můžete použít stejnou šablonu, změnit nastavení a publikovat novou
HTML stránku. Pokud jste znalí HTML, můžete za použití HTML editoru vytvářet své
vlastní šablony. Vytváření šablony je stejné jako vytváření standardní HTML stránky
kromě toho, že specifické hodnoty týkající se animace nahrazujete proměnnými, které
začínají značkou dolar ($).

Flash HTML šablony mají tyto charakteristiky:

� Jednořádkový titulek, který se objeví v kontextové nabídce Template (Šablona)

� Delší popis, který se objeví, když kliknete na Info tlačítko

� Template variables (Proměnné šablony), které začínají $, což znamená,
že hodnoty parametrů by měly být nahrazeny, když Flash generuje výstupní
soubor

Poznámka: pokud potřebujete v dokumentu použít znak $ pro jiný účel, použijte místo
toho \$

� HTML tagy OBJECT a EMBED jsou tagy, které splňují požadavky Microsoft
Internet Exploreru, respektive Netscape Communicatoru/Navigatoru. 
Aby se animace správně zobrazovala na HTML stránce, musíte tyto
požadavky pro tagy splnit. Internet Explorer Flash animaci otevírá použitím 
HTML tagu OBJECT; Netscape používá tag EMBED. Pro více informací 
se podívejte na „Použití tagů OBJECT  a EMBED“.
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Zvuk WAV (Windows)

Možnost Exportu animace WAV exportuje pouze zvukový soubor aktuální animace do
jednoduchého zvukového WAV souboru. Můžete určit zvukový soubor nového souboru.

Vyberte Sound Format (Zvukový formát) k určení vzorkové frekvence, bitové míry a stereo
nebo mono nastavení exportovaného zvuku. K vyjmutí zvukových událostí 
z exportovaného souboru vyberte Ignore Event Sounds (Ignorovat zvukové události).

Windows AVI (Windows)

Tento formát exportuje animaci jako Windows video, ale vyřazuje jakoukoli interaktivitu.
Tento standardní video formát je dobrý pro otevírání Flash animací v aplikaci pro editování
videa. Protože AVI je formát založený na bitmapě, tak animace, které obsahují dlouhé
animace nebo animace s vysokým rozlišením se mohou rychle stát velmi obsáhlé.

Dialogové okno Exportu Windows AVI obsahuje následujíc možnosti:

� Dimensions (Rozsah) určuje šířku a výšku v pixelech pro snímky AVI animace.
Implicitně můžete určit pouze šířku nebo výšku a další rozměr je automaticky
nastaven tak, aby byl zachován poměr stran vaší originální animace. K nastavení 
výšky i šířky odznačte Maintain Aspect Ratio (Zachovat poměr stran).

� Video Formát vybere barevnou hloubku. Hodně aplikací ještě nepodporuje 
Windows 32-bitový formát. Pokud máte problémy s použitím tohoto formátu, 
použijte starší 24-bitový formát.

� Compress Video (Komprimace videa) zobrazí dialogové okno pro výběr 
standardních možností AVI komprese.

� Smooth (Vyhlazení) aplikuje potlačení roztřepení na exportovanou 
QuickTime animaci a vytváří bitmapy vyšší kvality, ale může způsobit
zobrazení šedých bodů na barevném pozadí okolo vyhlazeného obrázku. 
Exportujte obrázek bez vyhlazení, pokud se objeví ozáření šedými body.

� Sound Format (Zvukový formát) vám umožní nastavit vzorkovou míru a velikost
zvukové stopy a jestli bude exportován mono nebo stereo. Čím menší 
vzorková míra a velikost, tím menší exportovaný soubor a menší zvuková 
kvalita. Pro více informací k exportování zvuku do formátu AVI se podívejte
na „Komprimování zvuků pro export“. 

Windows Metafile

Formát Windows Metafile je standardní grafický formát a je podporován většinou
aplikací pro Windows. Tento formát poskytuje dobré výsledky pro importování a expor-
tování souborů. Nemá žádné definovatelné možnosti pro export. Viz „Enhanced
Metafile (Windows)”.
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Přizpůsobení HTML šablon pro publikování

Pokud jste v HTML zběhlí, můžete změnit proměnné HTML šablony a vytvořit tak klikací
mapu, textovou zprávu, seznam URL nebo vložit vaše vlastní hodnoty pro některé
z nejobvyklejších parametrů OBJECT a EMBED (pro Internet Explorer, respektive
Netscape Communicator).

Šablony mohou obsahovat jakýkoli HTML obsah vaší animace, ale dokonce i kód
speciálních interpreterů jako je Cold Fusion, ASP a podobně.

Úprava HTML šablony pro publikaci:

1. Pomocí HTML editoru otevřete HTML šablonu Flashe, kterou chcete změnit
– je umístěna ve složce Macromedia 5/HTML.

2. Upravte šablonu jak potřebujete. K použití implicitních hodnot nechejte
proměnné prázdné. 

� Pro informace k proměnným, které jsou ve Flashi podporovány, se podívejte 
do následující tabulky. 

� Pro informace k vytváření klikací mapy, textové zprávy, seznamu URL nebo
vložení vašich vlastních hodnot pro parametry OBJECT a EMBED se podívejte
na následující části věnované těmto tématům.

3. Až skončíte s úpravami proměnných, uložte šablonu do složky Macromedia 
Flash 5/HTML. 

� Flash uloží změněnou šablonu pojmenovanou podle souboru animace 
a s příponou šablony. Například uložení šablony pojmenované Standard.asp
pro publikaci Flash animace se jménem MojeAnimace.swf vytvoří šablonu 
pojmenovanou MojeAnimace.asp.

4. Abyste aplikovali nastavení šablony k vaší animaci vyberte File  > Publish
settings (Publikovat nastavení), vyberte panel HTML a vyberte šablonu,
kterou jste upravili, Flash změní proměnné šablony pouze v šabloně 
vybrané v dialogovém okně Publikovat nastavení.

5. Vyberte zbývající nastavení publikace a klikněte na tlačítko OK. Pro více 
informací se podívejte na „Publikování Flash animací“.

� Následující tabulka uvádí proměnné šablony, které Flash rozpoznává. 
Na definici všech tagů, se kterými tyto proměnné pracují, se podívejte 
na „Upravování HTML nastavení“.
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Parametr

Titulek šablony

Začátek popisu šablony

Konec popisu šablony

Šířka 

Výška 

Animace 

HTML  zarovnání 

Smyčka 

Parametry pro OBJECT 

Parametry pro EMBED 

Přehrát 

Kvalita 

Stupnice 

Salign 

Mód okna 

Font zařízení 

Barva pozadí 

Text animace (oblast, kde se zapisuje text animace) 

Seznam URL animace (umístění URL animace) 

Šířka obrázku (nespecifikovaný typ obrázku) 

Výška obrázku (nespecifikovaný typ obrázku)

Název souboru obrázku (nespecifikovaný typ obrázku)

Název klikací mapy 

Umístění tagu klikací mapy 

Šířka QuickTime 

Výška QuickTime 

Název souboru QuickTime

Šířka GIFu

Výška GIFu

Název souboru GIFu

Šířka JPEGu

Výška JPEGu

Název souboru JPEGu

Šířka PNG

Výška PNG

Název souboru PNG

Generátor proměnné tagu OBJECT

Generátor proměnné tagu EMBED

Proměnná šablony

$ TT

$ DS

$ DF

$ WI

$ HE

$ MO

$ HA

$ LO

$ PO

$ PE

$ PL

$ QU

$ SC

$ SA

$ WM

$ DE

$ BG

$ MT

$ MU

$ IW

$ IH

$ IS

$ IU

$ IM

$ QW

$ QH

$ QN

$ GW

$ GH

$ GS

$ JW

$ JH

$ JN

$ PW

$ PH

$ PN

$ GV

$ GE



Vytvoření textové zprávy

Proměnná šablony $MT způsobí, že Flash vloží všechen text aktuální animace jako
komentář v HTML kódu. To je užitečné pro indexaci obsahu animace a její zviditelnění
pro vyhledávací služby.

Vytvoření seznamu URL

Proměnná šablony $MU způsobí, že Flash vygeneruje seznam URL odkazovaných
akcemi v aktuální animaci a vloží ho jako komentář do aktuálního umístění. To umožní
nástrojům pro kontrolu odkazu, aby zjistili a zkontrolovali odkazy v animaci.

Použití zkrácených proměnných šablony

Proměnné šablony $PO (pro tag OBJECT) a $PE (pro tag EMBED) jsou užitečné
krátké součásti. Obě proměnné způsobí, že Flash vloží do šablony jakoukoli
neimplicitní hodnotu pro nejpoužívanější parametry tagu OBJECT a EMBED, včetně
(Přehrát)-PLAY ($PL), (Kvalita)-QUALITY ($QU), (Měřítko)-SCALE ($SC),
(Zarovnání)-SALIGN ($SA), (Mód)-WMODE ($WM), (Font zařízení)-DEVICEFONT
($DE) a (Barva pozadí)-BGCOLOR ($BG). Viz ukázková šablona v následující části
příkladu těchto proměnných.
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Vytvoření klikací mapy

Flash dokáže generovat klikací mapu použitím jakéhokoli obrázku a zachová funkci
tlačítek, které odkazují na URL, i když je nahrazen jiným obrázkem. Pokud Flash
narazí na proměnnou šablony $IM, vloží do šablony kód klikací mapy. Proměnná $IU
identifikuje název souboru GIF, JPEG nebo PNG.

Vytvoření klikací mapy:

1. Ve vaší animaci určete klíčový snímek, který pro klikací mapu použijete a označte 
ji #Map v panelu Frame (Window > Panels > Frame). 

� Můžete použít jakýkoli klíčový snímek s tlačítky, které mají přiřazeny
akce Get URL. 

� Pokud jste nevytvořili popisek snímku, Flash vytvoří klikací mapu použitím
tlačítek v posledním snímku animace. Tato volba generuje vloženou klikací
mapu, a ne vloženou animaci.

2. V HTML editoru otevřete HTML šablonu, kterou budete upravovat. Flash
ukládá HTML šablony do složky Macromedia Flash 5/HTML.

3. Uložte vaši šablonu.

4. Vyberte File  > Publish Settings (Nastavení publikace), klikněte na záložku 
Formát a vyberte formát pro klikací mapu—GIF, JPEG nebo PNG.

5. Klikněte na tlačítko OK a uložte nastavení.

Například vložení následujícího kódu do šablony:

� $IM
<IMG SRC=$IS použitámapa=$IU WIDTH=$IW HEIGHT=$IH BORDER=0>

� může mít za následek tento kód v HTML dokumentu vytvořeném pomocí 
příkazu Publish (Publikace):

� <MAP NAME="mojeanimace">
<AREA COORDS="130,116,214,182" HREF="http://www.macromedia.com">
</MAP>
<IMG SRC="mojeanimace.gif" použitámapa="#mojeanimace" WIDTH=550
HEIGHT=400
BORDER=0>
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Používání tagu OBJECT a EMBED

K zobrazení Flash animace v internetovém prohlížeči musíte v HTML dokumentu
použít tagy OBJECT a EMBED se správnými parametry.

U OBJECTu jsou čtyři nastavení (HEIGHT, WIDTH , CLASSID a CODEBASE) atributů,
které se objevují s tagem OBJECT; všechny ostatní jsou parametry, které se objevují
v odděleném tagu PARAM. Například:

<OBJECT CLASSID="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 
WIDTH="100" 
HEIGHT="100"CODEBASE="http://active.macromedia.com/flash5/cabs/swflash.cab
#version=5,0,0,0">
<PARAM NAME="MOVIE"VALUE="nazevanimace.swf">
<PARAM NAME="PLAY"VALUE="true">
<PARAM NAME="LOOP"VALUE="true">
<PARAM NAME="QUALITY"VALUE="high">
</OBJECT>

U tagu EMBED jsou všechna nastavení (jako HEIGHT , WIDTH , QUALITY a LOOP)
atributy, které se objevují mezi složenými závorkami otevírajícího tagu EMBED.
Například:

<EMBED SRC="nazevanimace.swf" WIDTH="100" HEIGHT="100" PLAY="true"
LOOP="true"QUALITY="high"
PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?P1_
Prod_Version=ShockwaveFlash">
</EMBED>

K použití obou tagu najednou pouze umístěte EMBED tag před uzavírající OBJECT
tak, jak je ukázáno následovně:

<OBJECT CLASSID="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 
WIDTH="100" 
HEIGHT="100"CODEBASE="http://active.macromedia.com/flash5/cabs/swflash.cab
#version=5,0,0,0">
<PARAM NAME="MOVIE" VALUE="nazevanimace.swf">
<PARAM NAME="PLAY" VALUE="true">
<PARAM NAME="LOOP" VALUE="true">
<PARAM NAME="QUALITY" VALUE="high">

<EMBED SRC="nazevanimace.swf" WIDTH="100" HEIGHT="100" PLAY="true”
LOOP="true" QUALITY="high" PLUGINSPAGE="http://www.macromedia.com/shock-
wave/download/index.cgi?P1_Prod_Version=ShockwaveFlash">
</EMBED>
</OBJECT>
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Ukázková šablona

Implicitní soubor html šablony, který je zde uveden jako ukázka, obsahuje mnoho
běžně používaných proměnných šablony.

$TTFlash Pouze (Implicitní)
$DS
Použijte tag OBJECT a EMBED k zobrazení Flashe.
$DF
<HTML>
<HEAD>
<TITLE>$TI</TITLE>
</HEAD>
<BODY bgcolor="$BG">
<!--URL použité v animaci-->
$MU
<!--použitý text v animaci-->
$MT
<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"

codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.ca
b#version=5,0,0,0"
ID=$TI WIDTH=$WI HEIGHT=$HE>
$PO
<EMBED $PE WIDTH=$WI HEIGHT=$HE
TYPE="application/x-shockwave-flash"
PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?
P1_Prod_Version=ShockwaveFlash"></EMBED>
</OBJECT>
</BODY>
</HTML>

Úprava nastavení HTML

K přehrávání Flash animace v internetovém prohlížeči a k určení nastavení prohlížeče
je požadován HTML dokument. Pokud máte s HTML zkušenosti, můžete změnit nebo
vložit parametry HTML ručně v HTML editoru, nebo vytvořit vaše vlastní HTML soubory
k ovládání Flash animace.

Pro informace, jak nechat Flash vytvořit HTML dokument automaticky, když publikujete
animaci, se podívejte na „Publikování Flash animace“. Pro informace, jak uzpůsobit
HTML šablony vložené do Flashe, se podívejte na „Přizpůsobení HTML šablon pro
publikování“.
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HEIGHT
Hodnota
číslo nebo číslo %
Proměnná šablony: $HE
Popis
Určuje výšku animace – buU v pixelech nebo v procentech okna prohlížeče. Protože
jsou Flash animace stupňovatelné, jejich kvalita se neznehodnotí při různých
velikostech, pokud je zachován poměr stran. (Například následující velikosti (v pixelech)
mají poměr stran 4:3: 640 na 480, 320 na 240 a 240 na 180.)

CODEBASE
Hodnota
http://active.macromedia.com/flash5/cabs/swflash.cab#version=5,0,0,0"
Popis
Identifikuje umístění ovládání ActiveX Flash přehrávače, takže pokud ještě není nain-
stalované, může jej prohlížeč automaticky stáhnout. Hodnota musí být zadána přes-
ně tak, jak je zde ukázáno. Pouze OBJECT.

PLUGINSPAGE
Hodnota
http://www.macromedia.com/shockwave/download/
index.cgi?P1_Prod_Version=ShockwaveFlash
Popis
Identifikuje umístění plug-inu Flash přehrávače, takže pokud ještě není nainstalované,
může jej uživatel stáhnout. Hodnota musí být zadána přesně tak, jak je zde ukázáno.
Pouze EMBED.

SWLIVECONNECT
Hodnota
true | false
Popis
(Volitelná). Určuje, jestli má prohlížeč spustit Javu, když nahrává Flash přehrávač
poprvé. Pokud tento atribut chybí, je hodnota implicitně nastavená na false. Pokud
používáte JavaScript a Flash na stejné stránce, musí být Java spuštěna, aby mohl
FSCommand fungovat. Ačkoli pokud JavaScript používáte pouze pro detekci
prohlížeče nebo pro jiné účely, které nesouvisí s akcemi FSCommand, můžete se startu
Javy vyhnout nastavením atributu SWLIVECONNECT na false. Pokud JavaScript
s Flashem nepoužíváte a chcete, aby se Java spustila explicitně, nastavte
SWLIVECONNECT na true. Spuštění Javy značně zvyšuje dobu, za kterou se animace
spustí; tento tag nastavte na true pouze pokud je to nutné. Pouze EMBED.

Abyste spustili Javu ze samostatného přehrávače, použijte akci Exec FSCommand
(Vykonat FSPříkazu). Viz „Ovládání Flash přehrávače“.
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Poznámka: pokud používáte oba tagy OBJECT a EMBED, použijte stejné hodnoty pro
každý atribut nebo parametr, abyste zajistili shodné přehrání nezávisle na prohlížeči.
Parametr swflash.cab#version=5,0,0,0 je volitelný a můžete ho vynechat, pokud
nechcete číslo verze kontrolovat. 

Pokud budete psát vlastní HTML vložené do Flash animací, můžete se na tento seznam
odkazovat. Pokud na to není upozorněno, je možné všechny položky použít jak
k OBJECT, tak EMBED tagu. Na volitelné údaje je upozorněno. Pokud si přizpůsobujete
šablonu, můžete hodnotu nahradit zde vyjmenovanými proměnnými šablony. 
Viz „Přizpůsobení HTML šablon pro publikování“.

SRC
Hodnota
Názevanimace.swf
Proměnná šablony: $MO
Popis
Určuje název animace, která má být nahrána. Pouze EMBED.

MOVIE
Hodnota
Názevanimace.swf
Proměnná šablony: $MO
Popis
Určuje název animace, která má být nahrána. Pouze OBJECT.

CLASSID
Hodnota
clsid:D27CDB6E-AE6D-11cf-96B8-444553540000
Popis
Identifikuje ovládání ActiveX pro prohlížeč. Hodnota musí být zadána přesně tak, jak
je zde ukázáno. Pouze OBJECT.

WIDTH
Hodnota
číslo nebo číslo %
Proměnná šablony: $WI
Popis
Určuje šířku animace – buU v pixelech nebo v procentech okna prohlížeče.
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High (Vysoká) upřednostňuje kvalitu zobrazení před rychlosti přehrávání a potlačení
roztřepení aplikuje vždy. Pokud animace neobsahuje dynamické prvky, jsou bitmapy
vyhlazeny; pokud obsahuje, vyhlazeny nejsou.

Best (Nejlepší) poskytuje nejlepší kvalitu zobrazení a rychlost přehrávání nebere v úvahu.
U celého výstupu je aplikováno potlačení roztřepení a všechny bitmapy jsou vyhlazeny.

Pokud je tento atribut vynechán, je pro Quality (Kvalitu) implicitně použita hodnota
high (Vysoká).

BGCOLOR
Hodnota
#RRGGBB (hexadecimální hodnota RGB)
Proměnná šablony: $BG
Popis
(Volitelná) Určuje barvu pozadí animace. Tento atribut použijte, pokud chcete přepsat
nastavení barvy pozadí nastavené v souboru Flashe. Tento atribut neovlivní barvu
pozadí HTML stránky.

SCALE
Hodnota
showall | noborder | exactfit
Proměnná šablony: $SC
Popis
(Volitelná) Definuje, jak je animace umístěna do okna prohlížeče, pokud jsou hodnoty
atributů WIDTH a HEIGHT procentuální.

Default (Show All) (Implicitní (Ukaž vše)) udělá v určené oblasti viditelnou celou animaci
bez zkreslení, zatímco zachová původní poměr stran animace. Okraje se mohou objevit
na dvou stranách animace.

No Border (Bez Okraje) změní velikost animace tak, aby zaplnila určenou oblast bez
zkreslení, ale s možným ořezáním, zatímco zachová původní poměr stran animace.

Exact Fit (Umístit přesně) způsobí, že celá animace bude v určené oblasti viditelná
bez toho, že by byl zachován původní poměr stran. Může se objevit zkreslení.

Pokud je tento atribut vynechán, je jeho hodnota implicitně nastavena na showall
(a hodnoty WIDTH a HEIGHT jsou procentuální).
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PLAY
Hodnota
true | false
Proměnná šablony: $PL
Popis
(Volitelná). Určuje, jestli se animace začne přehrávat okamžitě po nahrání do prohlížeče.
Pokud je vaše animace interaktivní, možná chcete nechat uživatele, aby zahájil
přehrávání kliknutím na tlačítko nebo vykonáním jiné úlohy. V tomto případě nastavte
atribut PLAY na false a zabráníte tomu, aby se animace začala přehrávat automaticky.
Pokud tento atribut vynecháte, je implicitně nastaven na true.

LOOP
Hodnota
true | false
Proměnná šablony: $LO
Popis
(Volitelná). Určuje, jestli se animace bude opakovat nekonečně nebo se zastaví, když
dosáhne posledního snímku. Pokud tento atribut vynecháte, je implicitně nastaven na true.

QUALITY
Hodnota
low | high | autolow | autohigh | best
Proměnná šablony: $LO
Popis
(Volitelná) Určuje úroveň potlačení roztřepení, která bude použita během přehrávání
vaší animace. Potlačení roztřepení vyžaduje rychlejší procesor, aby byl vyhlazen
každý snímek animace před tím, než je zobrazen na obrazovku; vyberte hodnotu
závislou na tom, jestli je vaší prioritou rychlost nebo vizáž.

Low (Nízká) upřednostňuje rychlost před vizáží a nikdy nepoužívá potlačení roztřepení.

Autolow (Automaticky nízká) dává v prvé řadě důraz na rychlost, ale zvyšuje kvalitu
zobrazení tak, jak je to možné. Přehrávání začíná s vypnutým potlačením roztřepení.
Pokud Flash zjistí, že je procesor schopen ho zvládnout, je potlačení roztřepení zapnuto.

Autohigh (Automaticky vysoká) dává při přehrávání nejdříve stejný důraz na rychlost
i zobrazení, ale pokud je to nutné, obětuje kvalitu zobrazení pro rychlost přehrávání.
Přehrávání začne se zapnutým potlačením roztřepení. Pokud skutečná rychlost
přehrávání klesne pod určenou rychlost, je potlačení roztřepení vypnuto a rychlost
přehrávání zvýšena. Toto nastavení použijte, abyste napodobili nastavení View > Antialias
(Potlačení roztřepení) ve Flashi.

Medium (Střední) trochu aplikuje potlačení roztřepení a nevyhlazuje bitmapu.
Výsledkem je vyšší kvalita než u nastavení Low (Nízká), ale nižší než u High (Vysoká).
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MENU
Hodnota
true | false
Proměnná šablony: $ME
Popis
(Volitelná) Určuje, jaký typ nabídky je zobrazen, když uživatel klikne pravým tlačítkem
(Windows) nebo drží klávesu Command a klikne (Macintosh) na oblast animace
v prohlížeči.

True zobrazí úplnou nabídku a povoluje tak uživateli různé možnosti k zlepšení nebo
ovládání přehrávání.

False zobrazí nabídku, která obsahuje pouze volbu O Flashi.

Pokud tento atribut chybí, je implicitní hodnota true.

WMODE
Hodnota
Window | Opaque | Transparent
Proměnná šablony: $WM
Popis
(Volitelná) Umožní vám využít výhody transparentní animace, absolutní nastavení
polohy a schopnosti vrstev, které jsou dostupné v Internet Explorer 4.0. tento tag funguje
pouze ve Windows s ovládáním ActiveX..

Window (Okno) přehrává animaci na Webové stránce v jejím vlastním pravoúhlém okně.

Opaque (Neprůhledná) způsobí, že všechno za animací na stránce je schované.

Transparent (Transparentní) způsobí, že přes všechny transparentní části animace
jde vidět pozadí HTML stránky a může zpomalit předvádění animace. 

Pokud tento atribut chybí, je implicitní hodnota Window. Pouze OBJECT.
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ALIGN
Hodnota
L | R | T | B
Proměnná šablony: $HA
Popis
Určuje atribut ALIGN (Zarovnání) pro tagy OBJECT, EMBED a IMG a určuje, jak
je okno animace umístěno do okna prohlížeče.

Default (Implicitní) zarovná animaci v okně prohlížeče doprostřed a pokud je okno
prohlížeče menší než animace, tak zastřihne okraje.

Left (Vlevo), Right (Vpravo), Top (Nahoru) a Bottom (Dolů) animaci zarovná podle
odpovídajícího okraje okna prohlížeče a pokud je potřeba, tak zastřihne zbývající tři strany.

SALIGN
Hodnota
L | R | T  | B | TL | TR | BL | BR
Proměnná šablony: $SA
Popis
(Volitelná) určuje, kam je animace určitého stupně rozměru umístěna v prostoru
definovaném nastavením WIDTH a HEIGHT. Pro více informací k těmto podmínkám
viz „SCALE“.

L, R, T a B zarovná animaci podle levého, pravého, horního nebo dolního okraje okna
prohlížeče a pokud je potřeba, tak zbývající tři okraje zastřihne.

TL a TR zarovná animaci do horního levého a horního pravého rohu okna prohlížeče
a pokud je potřeba, tak zbývající tři okraje zastřihne.

BL a BR zarovná animaci do dolního levého a dolního pravého rohu okna prohlížeče
a pokud je potřeba, tak zbývající tři okraje zastřihne.

Pokud je tento atribut vynechán, je animace umístěna doprostřed okna prohlížeče.
Pokud je potřeba, může se na některé straně vyskytnout ořezání nebo objevit
rámeček. 

BASE
Hodnota
Základní adresář nebo URL
Popis
(Volitelná) Určuje základní adresář nebo URL použitý k vyřešení všech relativních cest
ve Flash Přehrávači animace. Tento atribut je užitečný, pokud jsou animace uloženy
v jiném adresáři než ostatní soubory.
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Konfigurace Web serveru pro Flash
Když jsou vaše soubory z Web serveru dostupné, server je musí správně rozpoznat,
aby je mohl zobrazit. Pokud MIME typ chybí nebo není serverem správně doručen,
prohlížeč může zobrazit chybovou zprávu mebo prázdné okno se zmatenou ikonou. 

Je možné, že už váš server je správně nakonfigurován. Abyste otestovali konfiguraci
serveru, podívejte se na TechNote (Technické záznamy) #12696 v Centru podpory
produktu Macromedia Flash, http://www.macromedia.com/. Pokud váš server není
správně nastaven, musíte (nebo váš administrátor) přidat ke konfiguračním souborům
serveru MIME typ Flash přehrávače a následující MIME typy přidružit k souborové
příponě přehrávače Flash:

� MIME typ application/x-shockwave-flash má příponu .swf

� MIME typ application/futuresplash má příponu .spl.

� Pokud administrujete vlastní server, podívejte se do dokumentace k vašemu
Web serveru na instrukce ohledně přidávání a nastavování MIME typu. 
Pokud neadministrujete vlastní server, kontaktujte vašeho poskytovatele 
Internetu, webmastera nebo administrátora serveru a žádejte, aby byla na server
přidána informace o MIME typu.

� Pokud je vaše stránka na serveru Macintosh, musíte také nastavit následující
parametry: Akce: Binary; Typ: SWFL; a Creator: SWF2.

Prověřování provozu na vaší Webové stránce
Když publikujete obsah Flashe na Internet, můžete Web server nakonfigurovat tak,
aby přehrával Flash animace snadněji. Docílit toho můžete použitím skriptu, který zjistí,
jestli uživatel má nainstalován plug-in pro Flash přehrávač nebo ovládání ActiveX.
Tento detektor, nazván Macromedia Flash Dispatcher, je obsažen v Macromedia Flash
(SWF) Deployment Kit ve složce Macromedia Flash 5/Goodies. 

Dispatcher je kombinací JavaScriptu, VBScriptu a Flash dat, které prověřují příchozí
provoz na vaší Webové stránce. Dispatcher detekuje, jestli má uživatelův prohlížeč
nainstalován Flash plug-in nebo ovládání ActiveX, a jestli ano, jaké verze. Dispatcher
můžete nakonfigurovat tak, aby nahrál dokument s Flash obsahem, nahrál alternativní
obsah, kontroloval aktualizování nebo instalaci prohlížeče.

Pro více informací si přečtěte soubor ReadMe a dokumentaci dodanou s Flash (SWF)
Deployment Kit ve složce Macromedia Flash 5/Goodies.
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