Was ist das?

AnmanieSMP ist ein Werkzeug zur Bildbearbeitung. Konkret dient es der Erstellung von Verzerrungseffekten.
Besonders gut geeignetes Ausgangsmaterial für solche Verzerrungen sind dabei natürlich Fotos von Personen, deren Gesichter sich dadurch teilweise bis zur Unkenntlichkeit verändern lassen.

Wie Sie sich jetzt vieleicht schon denken können, soll dieses Programm in erster Linie Spaß machen, ist also keine richtig ernsthafte Anwendung. Und da ein Programm nur halbsoviel Spaß macht wenn man es teuer bezahlen muß, ist es außerdem Freeware. D.h. Sie dürfen es kostenlos benutzen und weitergeben.


Erste Schritte

Einleitung

Es ist im Prinzip sehr einfach diese Software zu bedienen und erste Resultate zu erzielen. Um es Ihnen so leicht wie möglich zu machen, sich einen Eindruck von den Möglichkeiten der Software zu verschaffen, ist nach dem Programmstart bereits ein Bild geladen. An diesem können Sie die Wirkung der verscheidenen Werkzeuge ausprobieren.
Für den Anfang eignet sich besonders das Werkzeug 'Ziehen'.
Sie können übrigens den ursprünglichen Zustand des Bildes wiederherstellen, indem Sie im Menü 'Verzerrungen' den Punkt 'Entfernen' wählen.

Beispiele
Einige Beispiele, wie man mit AnmanieSMP Bilder verzerren kann, finden sich auch auf der Homepage. Um die Anmanie Homepage zu besuchen, klicken Sie im Menü '?' auf 'Internet Homepage'.


Tutorial

Willkommen beim Tutorial zu "AnmanieSMP".

Hier werden einige der Werkzeuge kurz vorgestellt und ihre Wirkung an einem Beispiel gezeigt.

WEITER


Eigene Bilder laden und speichern

Einleitung

Wenn Sie ein neues, eigenes Bild bearbeiten wollen, wählen Sie aus dem Menü 'Projekt' unter 'Neu' den Punkt 'Aus Datei importieren...'. Das Ergebnis können Sie später mit 'Projekt' -> 'Aktuelles Bild exportieren...' wieder in einem gängigen Dateiformat speichern.


Eigene Bilder laden und speichern

TWAIN

Im Menü 'Projekt' unter 'Neu' -> 'Scannen...' können Sie ein Bild von einem TWAIN
kompatiblen Farbscanner oder einer Webcam abrufen.
Beachten Sie bitte, daß so eingelesene Bilder sehr groß sein können. Da AnmanieSMP vergleichsweise viel Arbeitsspeicher benötigt um Bilder zu bearbeiten, sollten Sie Ihren Scanner auf eine niedrige Auflösung einstellen.


Erstellen von Animationen

Einleitung

Eine zusätzliche Funktion dieser Software ist es, aus den von Ihnen verzerrten Bildern Animationen zu erstellen. Dazu wird im einfachsten Fall eine Serie von Zwischenbildern berechnet, die den Übergang von der ursprünglichen Version des Bildes zu der von Ihnen erstellten, verzerrten darstellen.


Erstellen von Animationen

Die Animationsleiste:

Hier sehen Sie verkleinerten Ansichten der im aktuellen Projekt enthaltenen "Stützframes" zur Erstellen einer Animation. Nachdem ein neues Projekt angelegt wurde, sind dort bereits zwei Bilder enthalten. Das zweite ist aktiviert und erscheint somit im Hauptfenster. Während Sie es dort bearbeiten können, bleibt das Erste unverändert. Klicken Sie nun mit der linkem Maustaste auf dieses und es erscheint anstelle des Zweiten im Hauptfenster. Wenn sie ein weiteres Bild anlegen möchten, klicken Sie mit der rechten Maustaste auf den nächten freien Rahmen und wählen Sie im erscheinenden Menü "Aktuelles Bild einfügen".

Unter den Bildern befinden sich Eingabefelder, in denen Sie die Anzahl der Bilder angeben können, die später als Übergang zwischen den entsprechenden Frames berechnet werden. Die Zahl unter dem letzten aktiven Bild stellt den Übergang zurück zum ersten Bild dar.

Die Animationsleiste ist jedoch nicht nur dann nützlich wenn man eine Animation erstellen will. Sie eignet sich auch gut zum Ablegen von verschiedenen Variationen eines Bildes während der Bearbeitung.


Erstellen von Animationen

Animation speichern:

Um eine Animation zu erstellen, d.h. die entsprechenden Einzelbilder zu berechnen und abzuspeichern, wählen Sie im Menü "Projekt" den Menüpunkt "Animation erstellen...". Es wird nun eine Dialogbox angezeigt, in der Sie das Format auswählen können in dem die Animation erstellt wird.

"nur testen": Alle Frames werden berechnet und auf dem Bildschirm angezeigt aber nicht gespeichert.

"Folge von Einzelbildern": Es werden die einzelnen Frames der Animation als BMP-Dateien gespeichert.

"AVI Video": Es wird ein AVI Video erstellt, welches von der Windows Medienwiedergabe abgespielt werden kann. Wenn Sie ein solches Video erstellen wollen, werden Sie später aufgefordert eine Kompressionsmethode auszuwählen. Empfehlenswert sind hier "Cinepak" oder "Indeo R3.2". Zu beachten ist außerdem, daß evtl. nicht jeder auf Ihrem System installierte Codec beliebige Bildgrößen unterstützt und sich somit nicht uneingeschränkt für die Verwendung mit AnmanieSMP eignet.


Tutorial

Wir fangen mit dem Werkzeug "Wachsen" an. Es befindet sich ganz links-oben in der Werkzeugpalette. Die Größe stellen wir im Fenster "Werkzeugeinstellungen" auf 80. Wir wenden es auf das linke Auge an, indem wir dort die linke Maustaste kurz gedrückt halten.


Tutorial

Und so sieht das Ergebnis aus.
Als nächstes versuchen wir es mit dem Werkzeug "Schrumpfen" bei dem anderen Auge.


Tutorial

So.
Nun wählen wir das Werkzeug "Ziehen" aus und stellen die Größe auf 60.


Tutorial

Wir positionieren die Maus über dem linken Mundwinkel und ziehen ihn etwa 30 Grad nach rechts oben. Evtl. müssen wir dabei noch einmal neu ansetzen um den Effekt zu verstärken.


Tutorial

Wir führen jetzt noch eine leichte Korrektur an der Lage des Mundes durch. Dazu verwenden Wir das Werkzeug "Verdrehen (links)" mit 100 Pixel Durchmesser.


Tutorial

Als nächstes legen wir eine Maske an. Dies geschieht automatisch durch wählen des Werkzeugs "Maske bearbeiten". Die dunklen Bereiche des Bildes werden sobald die Maske aktiv ist von den Verzerrungswerkzeugen nicht mehr beeinflußt. Wir zeichnen diesmal einen 60 Pixel großen Kreis um das linke Auge.


Tutorial

Als nächstes versuchen wir es mit dem "Wiederherstellen"-Werkzeug. Die Maske ist jetzt aktiv. Wir können also nur noch das linke Auge bearbeiten. Wir bewegen das Werkzeug einmal rund um das linke Auge herum.


Tutorial

Wie man sieht sind die Verzerrungen dort nahezu verschwunden.
Es sind allerdings auch einige unschöne "Kanten" entstanden. Diese werden jetzt noch mit dem Werkzeug "Plätten" entfernt.


Tutorial

Wir "plätten" die Kanten weg, indem wir das Werkzeug langsam um das Auge herumbewegen.

Das war es schon! Damit sind wir am Ende dieser kleinen Einführung angelangt. Viel Spaß noch bei der Verwendung von AnmanieSMP!