Windows Media 8 Encoding Utility

Microsoft® Windows Media™ 8 Encoding Utility is a command-line tool that enables the creation of Windows Media-based content using the latest audio and video compression technology. It includes many of the features of Windows Media Encoder 7, but provides new compression/decompression algorithms (codecs) that significantly improve audio and video quality.

Using Windows Media 8 Encoding Utility, you can:

  • Convert uncompressed files with .wma, .wmv, .avi, and .wav file name extensions to the compressed Windows Media format.

  • Perform one-pass constant-bit-rate encoding on your audio and video content, perform two-pass constant bit rate on your video content, and perform one- and two-pass variable-bit-rate encoding on your video content.

  • Create batch files that produce multiple Windows Media audio and video files or encode all files in a directory.

  • Encode specific portions of a file.

  • Convert the audio sampling rate as part of the encoding process.

  • Apply inverse telecine or deinterlacing filters to your content.

  • Clip and resize and the source video as part of the encoding process.

  • Apply a number of different encoding profiles depending on your audience needs.

This guide will explain how to use all of these features. It is organized as follows:

  • Supported formats. Lists the file formats that you can use with Windows Media 8 Encoding Utility.

  • Using Windows Media 8 Encoding Utility. Explains how to perform basic encoding tasks using some of the more common command-line options.

  • Understanding profiles. Explains how profiles are used and lists all of the profiles available in Windows Media 8 Encoding Utility.

  • Advanced encoding techniques. Explains some of the encoding filters that are available to improve the quality of your video. This section also lists all of the command-line options that are available in Windows Media 8 Encoding Utility.

  • Accessing Help from the command line. Lists the commands that you can use to view Help from the command line.

  • Frequently asked questions. Provides answers to common questions about Windows Media 8 Encoding Utility.

  • Glossary. Defines terms that are related to Windows Media 8 Encoding Utility.
© 2000-2001 Microsoft Corporation. All rights reserved.


Supported formats

You can use the following file formats as source files with Windows Media 8 Encoding Utility. Once encoded, all files will have either a .wma or .wmv file name extension depending on whether they are audio-only (.wma), video-only (.wmv), or contain both audio and video (.wmv).

File name extension | File type | Notes
.avi Audio and video files For audio, only uncompressed files with 16-bit pulse code modulation (PCM) are supported. For video, Windows Media 8 Encoder Utility supports these pixel formats:
  • IYUV (I420)

  • YV12

  • YUY2

  • UYVY

  • YVYU

  • YVU9

  • RGB (24 bit)

  • RGB (16 bit)

  • RGB (15 bit)

  • RGB (32 bit)

  • RGB (8 bit)

Note Compressed .avi files are supported if an Image Compression Manager (ICM) decompressor is available on your computer.
.wav | Audio files | Only 16-bit, uncompressed files are supported.
.wma, .wmv | Windows Media format audio and video files | Only 16-bit uncompressed .wma and uncompressed .wmv files are supported. Windows Media 8 Encoder Utility only supports .asf version 1.

Related topics

  • Viewing the properties of your source file


Viewing the properties of your source file

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type cd \program files\windows media components\tools.

  3. Type the following command, then press the ENTER key:
    wm8eutil –input input_file_name


Using Windows Media 8 Encoding Utility

Windows Media 8 Encoding Utility is a command-line tool that enables you to take uncompressed files with .wma, .wmv, .avi, and .wav file name extensions and compress them into Windows Media format files with .wma and .wmv extensions. The resulting files can then be used for streaming or on-demand playback. Windows Media 8 Encoding Utility does not support live capture or live broadcasts.

Windows Media 8 Encoding Utility is installed by default in the Program Files\Windows Media Components\Tools directory.

The basic command-line syntax for Windows Media 8 Encoding Utility is:

wm8eutil -input input_file_name -output output_file_name [-option]

The command line contains three required items, plus any additional command-line options:

  • The application name: wm8eutil or wm8eutil.exe

  • The –input parameter and an input file name: -input input_file_name

  • The –output parameter and an output file name: -output output_file_name

Here is an example of the basic encoding command:

wm8eutil –input myfile.avi –output myfile.wmv

This command takes the source file "myfile.avi" and converts it to "myfile.wmv." If you don't specify the file name extension, then it will be appended to the file name for you. The converted file resides in the same directory as the source file.

If you have a number of files that are contained within the same directory or subdirectories and want to convert all of them to Windows Media format, you can specify directory names in both the –input and –output portions of the command, and all files within that directory will be converted. Here is an example of the command that would convert all files in the My-songs directory:

wm8eutil –input my-songs –output my-songs-coded

Additional command-line options are available and can be appended to the end of the basic command. These options enable you to specify profiles, set start and end times, designate configuration files, set the buffer size and image quality settings, and so on.

Related topics

  • Using command-line options

  • To open a command prompt window

  • To encode a file

  • To encode all files within a directory


To open a command prompt window

  1. Click Start.

  2. Point to Programs.

  3. Point to Accessories.

  4. Click Command Prompt.

Related topics

  • Using Windows Media 8 Encoding Utility


To encode a file

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
    cd \program files\windows media components\tools.
  3. Type the following command, then press the ENTER key:
    wm8eutil –input input_file_name -output output_file_name
  4. Provide the appropriate source and output file names in place of input_file_name and output_file_name, respectively. For example:
    wm8eutil –input myfile.avi –output myfile.wmv

Related topics

  • To encode all files within a directory

  • Using Windows Media 8 Encoding Utility


To encode all files within a directory

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
    cd \program files\windows media components\tools.
  3. Type the following command, then press the ENTER key:
    wm8eutil –input input_directory -output output_directory
  4. Provide the appropriate source and output directory names in place of input_directory and output_directory, respectively. For example:
    wm8eutil –input my-songs –output my-songs-coded

Note If the output directory does not already exist, it will be created for you.

Related topics

  • To encode a file

  • Using Windows Media 8 Encoding Utility


Viewing encoding statistics

Windows Media 8 Encoder Utility displays statistics and diagnostic information after a given file is encoded. Statistics include codecs used, total number of bytes encoded, average bit rate, average frame rate, and so on. The statistics enable you to monitor the success of the encoding session and provide useful information that you can use to change the command-line options to achieve a different result the next time you encode a file.

The most common statistics are displayed by default, but you can turn them off by using the –silent option. Use the –allstats option to see all of the available statistics.

Related topics

  • To turn off the encoding statistics

  • To see all encoding statistics


To turn off the encoding statistics

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
     cd \program files\windows media components\tools
  3. Type the following command, then press the ENTER key:
    wm8eutil –input input_file_name -output output_file_name –silent

Related topics

  • Viewing encoding statistics


To see all encoding statistics

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
     cd \program files\windows media components\tools
  3. Type the following command, then press the ENTER key:
    wm8eutil –input input_file_name -output output_file_name –allstats

Related topics

  • Viewing encoding statistics


Batch encoding

Batch encoding enables you to encode numerous files in quick succession without having to issue a separate encoding command for each one. Instead, you can create a batch file, or text file with a .bat extension, that includes all of the encoding commands that you want to use. These commands might include the names of your input and output files, profiles to be used, and other optional parameters to be applied. There is no limit on the number of commands that you can include in a batch file, and because it is a basic text file, editing is easy.

When you are ready to run the batch file, navigate to the directory where the Windows Media 8 Encoding Utility is installed and type the name of the batch file. For example:

mybatch.bat

The following is an example of some commands that you might find in a batch file. The commands in this example take a 640 x 480, 24-fps film source that has been telecined to 30 fps, and convert it to 24 fps using an inverse telecine filter before encoding it. The first two commands use quality-based variable bit rate (-v_mode 2) to encode the source at quality settings of 95 and 97, respectively. The final two commands use two-pass constant bit rate (-v_mode 1) to encode the source at 1 megabit per second (Mbps) and 500 Kbps, respectively.

wm8eutil -input mymovie.avi -output mymovie-640x480-vbr095.wmv -v_mode 2 -v_quality 95 -v_keydist 30 -v_preproc 5
wm8eutil -input mymovie.avi -output mymovie-320x240-vbr097.wmv -v_mode 2 -v_quality 97 -v_keydist 30 -v_preproc 5 -v_width 320 -v_height 240
wm8eutil -input mymovie.avi -output mymovie-640x480-cbr2.wmv -v_mode 1 -v_bitrate 1000000 -v_keydist 30 -v_buffer 10000 -v_quality 100 -v_preproc 5
wm8eutil -input mymovie.avi -output mymovie-320x240-cbr2.wmv -v_mode 1 -v_bitrate  500000 -v_keydist 30 -v_buffer 10000 -v_quality 100 -v_preproc 5 -v_width 320 -v_height 240


Using configuration files

Configuration files are text files that contain the names and values of command-line options that you want to use in an encoding session. Rather than specifying each option individually at the command prompt, you can put them into a configuration file and then call the configuration file when you run the Windows Media 8 Encoding Utility. This is especially helpful if you use the same options often.

Information contained within the configuration file can include the input and output file names, the profile, start and end times, and any other options that you want to specify. You can also override the settings in the configuration file by typing individual options on the command line.

You can create configuration files with a text editing tool or from the command line by appending the –s_config option to your command. When you append the –s_config option, you specify a file name and all of the options in your command will be collected and saved into that configuration file. Configuration files have a .weu file name extension. If you don't specify the file name extension when creating the configuration file, it will be appended to the file name for you.

Related topics

  • To create a configuration file

  • To call a configuration file


To create a configuration file

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
     cd \program files\windows media components\tools.
  3. Type the following command, then press the ENTER key:
    wm8eutil –input input_file_name -output output_file_name -s_config configuration_file_name

    For example:

    wm8eutil –input myfile.avi –output myfile.wmv –s_config myvideos.weu

Related topics

  • To call a configuration file

  • Using configuration files


To call a configuration file

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
     cd \program files\windows media components\tools
  3. Type the following command, then press the ENTER key:
    wm8eutil –config configuration_file_name

    For example:

    wm8eutil –config myvideos.weu

Related topics

  • To create a configuration file

  • Using configuration files


Encoding specific portions of a file

If you have specific time segments within an audio or video file that you want to encode without having to encode the entire file, you can use the –time option to specify the segment to encode. The –time option allows you to specify in milliseconds where in the source file encoding should begin and end.

Related topics

  • To specify start and end times


To specify start and end times

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
     cd \program files\windows media components\tools.
  3. If you know the end time, type the following command and then press the ENTER key:
    wm8eutil –input input_file_name -output output_file_name –time start_time end_time

    For example:

    wm8eutil –input myfile.avi –output myfile.wmv –time 10000 20000

Note The start and end times should be denoted in milliseconds.

  4. If you do not know the end time and just want to encode to the end of the file, type the following command and then press the ENTER key:
    wm8eutil –input input_file_name -output output_file_name –time start_time end
wm8eutil –input input_file_name -output output_file_name –time start_time end

    For example:

    wm8eutil –input myfile.avi –output myfile.wmv –time 10000 end

    Note The start time should be denoted in milliseconds.

Related topics

  • Encoding specific portions of a file


Understanding profiles

A profile is a collection of command-line options tailored to the type of content being encoded, the connection speed of the intended audience, and the desired image quality of the output. The options stored in a profile include the audio and video bit rate, frame rate, video size, client connection speed, and codecs. Using a profile can simplify the process of setting up an encoding session. Instead of specifying each individual setting that you want to use to encode your content, you specify a profile name. All settings within that profile will be applied.

Windows Media 8 Encoding Utility includes a number of system profiles for encoding both National Television Standards Committee (NTSC) and Phase Alternating Line (PAL) formats. These profiles are similar to the profiles that were included with Windows Media Encoder 7 except that:

  • They include the newest codecs, Windows Media Video version 8 and Windows Media Audio version 8.

  • The audio bit rates and audio profiles have been adjusted.

Note The NTSC format is the broadcast system standard accepted by and used in North America, Japan, most of Central America, and portions of Southeast Asia. It specifies that video must contain 525 lines per frame at an update rate of 30 frames per second (fps).

The PAL format is the broadcast standard for most of Europe, Africa, China, South America, and the Middle East. This format specifies that video must contain 625 lines per frame at an update rate of 25 fps. PAL video has higher resolution than NTSC, but also displays more flicker in the image.

You can see the list of profiles that are installed with Windows Media 8 Encoding Utility from the command line by using one of the following command-line options:

-profile?

Displays all audio and video profiles.

-profileall?

Displays all audio and video profiles and the details of each profile.

-profile_profilename?

Displays the details of the profile that you specify. Replace profilename with the number of the specific profile. For example:

wm8eutil -profile_av32?

To specify the profile that you want to use for an encoding session, use the –profile command-line option, followed by the name of the profile. For example:

wm8eutil -profile av700pal

Related topics

  • To specify a profile for your encoding session

  • Creating and editing profiles

  • Audio and video profiles

  • Audio-only profiles

  • Video-only profiles


To specify a profile for your encoding session

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
     cd \program files\windows media components\tools.
  3. Type the following command, then press the ENTER key:
    wm8eutil –input input_file_name -output output_file_name -profile profilename

Related topics

  • Understanding profiles


Creating and editing profiles

With the Windows Media 8 Encoding Utility, there are two ways to create your own profiles. First, you can specify each of the options that you want to use on the command line. For example, you could use the –v_bitrate, -v_codec, -v_width, -v_height, -v_framerate, and -v_keydist options to specify the settings for encoding your content. You could also create a configuration file that contains all of the options you want to use, and then use the configuration file as your input source.

Windows Media 8 Encoding Utility does not enable you to edit system profiles. Rather, if you are using a system profile and want to change some of its settings, you can use command-line options to override the settings in the profile. For example, if you use the av700 profile, which has an image quality setting of 75, and you want the image quality setting to be 100, then you would specify that with the –v_quality option. Here is what the command would look like:

wm8eutil –input myfile.avi –output myfile.wmv –profile av700 –v_quality 100

Related topics

  • Using configuration files

  • Using command-line options

  • Understanding profiles


Audio and video profiles

Windows Media 8 Encoding Utility includes 14 system profiles for encoding content that contains both audio and video tracks. The table below contains a brief description of each profile. See the related topics for links to profile details.

Profile name | Bit rate (Kbps) | Actual rate (Kbps) | Description
av20 | 28 | 20 | 28K modem
av32 | 56 | 32 | 56K modem
av100 | 100 | 100 | LAN
av225 | 256 | 225 | LAN
av350 | 384 | 350 | LAN, DSL
av450 | 768 | 450 | LAN, DSL
av700 | 700 | 700 | Near-broadcast quality NTSC
av1400 | 1,400 | 1,400 | Near-broadcast quality NTSC
av350pal | 384 | 350 | Broadband PAL
av700pal | 700 | 700 | Near broadcast-quality PAL
av100_2p | 100 | 100 | LAN, two-pass
av350_2p | 350 | 350 | LAN, DSL, two-pass
av600vbr | 600 | 600 | Film, variable bit rate
avq97vbr | -- | -- | Film, variable bit rate, fixed quality

Related topics

  • av20

  • av32

  • av100

  • av225

  • av350

  • av700

  • av350pal

  • av700pal

  • av450

  • av1400

  • av100_2p

  • av350_2p

  • av600vbr

  • avq97vbr


av20

  • Name: av20 (Profile_AudioVideo_Modem_28K)

  • Audio codec: Windows Media Audio version 8.

  • Audio bit rate (bps): 5,000

  • Sampling rate (Hz): 8,000

  • Number of channels: 1

  • Video codec: Windows Media Video version 8

  • Video bit rate (bps): 15,000

  • Frame width (pixels): 160

  • Frame height (pixels): 120

  • Frame rate (fps): 15.00

  • Delay buffer (milliseconds): 3,000

  • Smoothness/Quality: 0

  • Key frame distance (seconds): 8

  • Total bit rate (bps): 20,000

Related topics

  • Audio and video profiles


av32

  • Name: av32 (Profile_AudioVideo_Modem_56K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 10,168

  • Sampling rate (Hz): 11,025

  • Number of channels: 1

  • Video codec: Windows Media Video version 8

  • Video bit rate (bps): 22,000

  • Frame width (pixels): 176

  • Frame height (pixels): 144

  • Frame rate (fps): 15.00

  • Delay buffer (milliseconds): 3,000

  • Smoothness/Quality: 0

  • Key frame distance (seconds): 8

  • Total bit rate (bps): 32,168

Related topics

  • Audio and video profiles


av100

  • Name: av100 (Profile_AudioVideo_LAN_100K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 16,000

  • Sampling rate (Hz): 16,000

  • Number of channels: 1

  • Video codec: Windows Media Video version 8

  • Video bit rate (bps): 84,000

  • Frame width (pixels): 320

  • Frame height (pixels): 240

  • Frame rate (fps): 15.00

  • Delay buffer (milliseconds): 3,000

  • Smoothness/Quality: 0

  • Key frame distance (seconds): 8

  • Total bit rate (bps): 100,000

Related topics

  • Audio and video profiles


av225

  • Name: av225 (Profile_AudioVideo_LAN_256K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 40,000

  • Sampling rate (Hz): 32,000

  • Number of channels: 2

  • Video codec: Windows Media Video version 8

  • Video bit rate (bps): 185,000

  • Frame width (pixels): 320

  • Frame height (pixels): 240

  • Frame rate (fps): 30.00

  • Delay buffer (milliseconds): 3,000

  • Smoothness/Quality: 0

  • Key frame distance (seconds): 6

  • Total bit rate (bps): 225,000

Related topics

  • Audio and video profiles


av350

  • Name: av350 (Profile_AudioVideo_LANDSL_384K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 48,000

  • Sampling rate (Hz): 32,000

  • Number of channels: 2

  • Video codec: Windows Media Video version 8

  • Video bit rate (bps): 302,000

  • Frame width (pixels): 320

  • Frame height (pixels): 240

  • Frame rate (fps): 30.00

  • Delay buffer (milliseconds): 3,000

  • Smoothness/Quality: 0

  • Key frame distance (seconds): 4

  • Total bit rate (bps): 350,000

Related topics

  • Audio and video profiles


av450

  • Name: av450 (Profile_AudioVideo_LANDSL_768K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 64,040

  • Sampling rate (Hz): 44,100

  • Number of channels: 2

  • Video codec: Windows Media Video version 8

  • Video bit rate (bps): 386,000

  • Frame width (pixels): 320

  • Frame height (pixels): 240

  • Frame rate (fps): 30.00

  • Delay buffer (milliseconds): 3,000

  • Smoothness/Quality: 0

  • Key frame distance (seconds): 4

  • Total bit rate (bps): 450,040

Related topics

  • Audio and video profiles


av700

  • Name: av700 (Profile_AudioVideo_NearBroadCast_700K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 64,040

  • Sampling rate (Hz): 44,100

  • Number of channels: 2

  • Video codec: Windows Media Video version 8

  • Video bit rate (bps): 636,000

  • Frame width (pixels): 320

  • Frame height (pixels): 240

  • Frame rate (fps): 30.00

  • Delay buffer (milliseconds): 3,000

  • Smoothness/Quality: 0

  • Key frame distance (seconds): 3

  • Total bit rate (bps): 700,040

Related topics

  • Audio and video profiles


av1400

  • Name: av1400 (Profile_AudioVideo_NearBroadCast_1400K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 128,040

  • Sampling rate (Hz): 44,100

  • Number of channels: 2

  • Video codec: Windows Media Video version 8

  • Video bit rate (bps): 1,272,000

  • Frame width (pixels): 320

  • Frame height (pixels): 240

  • Frame rate (fps): 30.00

  • Delay buffer (milliseconds): 3,000

  • Smoothness/Quality: 0

  • Key frame distance (seconds): 3

  • Total bit rate (bps): 1,400,040

Related topics

  • Audio and video profiles


av350pal

  • Name: av350pal (Profile_AudioVideo_Broadband_PAL_384K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 48,000

  • Sampling rate (Hz): 32,000

  • Number of channels: 2

  • Video codec: Windows Media Video version 8

  • Video bit rate (bps): 302,000

  • Frame width (pixels): 352

  • Frame height (pixels): 288

  • Frame rate (fps): 30.00

  • Delay buffer (milliseconds): 3,000

  • Smoothness/Quality: 0

  • Key frame distance (seconds): 4

  • Total bit rate (bps): 350,000

Related topics

  • Audio and video profiles


av700pal

  • Name: av700pal (Profile_AudioVideo_NearBroadCast_PAL_700K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 64,040

  • Sampling rate (Hz): 44,100

  • Number of channels: 2

  • Video codec: Windows Media Video version 8

  • Video bit rate (bps): 636,000

  • Frame width (pixels): 352

  • Frame height (pixels): 288

  • Frame rate (fps): 30.00

  • Delay buffer (milliseconds): 3,000

  • Smoothness/Quality: 0

  • Key frame distance (seconds): 3

  • Total bit rate (bps): 700,040

Related topics

  • Audio and video profiles


av100_2p

  • Name: av100_2p (Profile_AudioVideo_LAN_100K_2Pass)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 16,000

  • Sampling rate (Hz): 16,000

  • Number of channels: 1

  • Video codec: Windows Media Video version 8

  • Encoding mode: two-pass constant bit rate

  • Video bit rate (bps): 84,000

  • Frame width (pixels): 320

  • Frame height (pixels): 240

  • Frame rate (fps): 15.00

  • Delay buffer (milliseconds): 5,000

  • Smoothness/Quality: 75

  • Key frame distance (seconds): 10

  • Total bit rate (bps): 100,000

Related topics

  • Audio and video profiles


av350_2p

  • Name: av350_2p (Profile_AudioVideo_LANDSL_384K_2Pass)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 48,000

  • Sampling rate (Hz): 32,000

  • Number of channels: 2

  • Video codec: Windows Media Video version 8

  • Encoding mode: two-pass constant bit rate

  • Video bit rate (bps): 302,000

  • Frame width (pixels): 320

  • Frame height (pixels): 240

  • Frame rate (fps): 30.00

  • Delay buffer (milliseconds): 5,000

  • Smoothness/Quality: 75

  • Key frame distance (seconds): 10

  • Total bit rate (bps): 350,000

Related topics

  • Audio and video profiles


av600vbr

  • Name: av600vbr (Profile_AudioVideo_FilmVBR_600K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 64,040

  • Sampling rate (Hz): 44,100

  • Number of channels: 2

  • Video codec: Windows Media Video version 8

  • Encoding mode: bit-rate-based variable bit rate for download and play

  • Pre-process type: inverse telecine

  • Video bit rate (bps): 536000

  • Frame width (pixels): 320

  • Frame height (pixels): 240

  • Frame rate (fps): 24.00

  • Key frame distance (seconds): 10

  • Total bit rate (bps): 600,040

Related topics

  • Audio and video profiles


avq97vbr

  • Name: avq97vbr (Profile_AudioVideo_FilmVBR_Quality97)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 64,040

  • Sampling rate (Hz): 44,100

  • Number of channels: 2

  • Video codec: Windows Media Video version 8

  • Encoding mode: quality-based variable bit rate for download and play

  • Pre-process type: inverse telecine

  • Frame width (pixels): 320

  • Frame height (pixels): 240

  • Frame rate (fps): 24.00

  • Smoothness/Quality: 97

  • Key frame distance (seconds): 10

Related topics

  • Audio and video profiles


Audio-only profiles

Windows Media 8 Encoding Utility includes seven system profiles for encoding content that contains an audio track, but no video. The table below contains a brief description of each profile. See the related topics for links to profile details.

Profile name | Bit rate (Kbps) | Actual rate (Kbps) | Description
a20_1 | 28 | 20 | FM radio mono
a20_2 | 28 | 20 | FM radio stereo
a32 | 56 | 32 | Audio only, 56K modem
a48 | 48 | 48 | Near CD quality
a64 | 64 | 64 | CD quality
a96 | 96 | 96 | CD audiophile quality
a128 | 128 | 128 | CD audiophile quality

Related topics

  • a20_1

  • a20_2

  • a32

  • a48

  • a64

  • a96

  • a128


a20_1

  • Name: a20_1 (Profile_AudioOnly_FMRadioMono_28K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 20,008

  • Sampling rate (Hz): 22,050

  • Number of channels: 1

  • Total bit rate (bps): 20,008

Related topics

  • Audio-only profiles


a20_2

  • Name: a20_2 (Profile_AudioOnly_FMRadioStereo_28K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 20,008

  • Sampling rate (Hz): 22,050

  • Number of channels: 2

  • Total bit rate (bps): 20,008

Related topics

  • Audio-only profiles


a32

  • Name: a32 (Profile_AudioOnly_Modem_56K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 32,000

  • Sampling rate (Hz): 32,000

  • Number of channels: 2

  • Total bit rate (bps): 32,000

Related topics

  • Audio-only profiles


a48

  • Name: a48 (Profile_AudioOnly_NearCDQuality_48K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 48,024

  • Sampling rate (Hz): 44,100

  • Number of channels: 2

  • Total bit rate (bps): 48,024

Related topics

  • Audio-only profiles


a64

  • Name: a64 (Profile_AudioOnly_CDQuality_64K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 64,016

  • Sampling rate (Hz): 44,100

  • Number of channels: 2

  • Total bit rate (bps): 64,016

Related topics

  • Audio-only profiles


a96

  • Name: a96 (Profile_AudioOnly_CDAudiophileQuality_96K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 96,024

  • Sampling rate (Hz): 44,100

  • Number of channels: 2

  • Total bit rate (bps): 96,024

Related topics

  • Audio-only profiles


a128

  • Name: a128 (Profile_AudioOnly_CDAudiophileQuality_128K)

  • Audio codec: Windows Media Audio version 8

  • Audio bit rate (bps): 128,000

  • Sampling rate (Hz): 44,100

  • Number of channels: 2

  • Total bit rate (bps): 128,000

Related topics

  • Audio-only profiles


Video-only profiles

Windows Media 8 Encoding Utility includes two system profiles for encoding content that contains a video track, but no audio. The table below contains a brief description of each profile. See the related topics for links to profile details.

Profile name | Bit rate (Kbps) | Actual rate (Kbps) | Description
v20 | 28 | 20 | Video only, 28K modem
v32 | 56 | 32 | Video only, 56K modem

Related topics

  • v20

  • v32


v20

  • Name: v20 (Profile_VideoOnly_Modem_28K)

  • Video codec: Windows Media Video version 8

  • Video bit rate (bps): 20,000

  • Frame width (pixels): 176

  • Frame height (pixels): 144

  • Frame rate (fps): 15.00

  • Delay buffer (milliseconds): 3,000

  • Smoothness/Quality: 0

  • Key frame distance (seconds): 8

  • Total bit rate (bps): 20,000

Related topics

  • Video-only profiles


v32

  • Name: v32 (Profile_VideoOnly_Modem_56K)

  • Video codec: Windows Media Video version 8

  • Video bit rate (bps): 32,000

  • Frame width (pixels): 240

  • Frame height (pixels): 176

  • Frame rate (fps): 15.00

  • Delay buffer (milliseconds): 3,000

  • Smoothness/Quality: 0

  • Key frame distance (seconds): 8

  • Total bit rate (bps): 32,000

Related topics

  • Video-only profiles


Advanced encoding techniques

There are a number of ways that you can fine-tune your settings to ensure that your encoded video is just the way you want it. This section describes the customization features that are available in Windows Media 8 Encoding Utility and how to use them.

Related topics

  • Using preprocessing filters

  • Encoding video at a constant bit rate

  • Encoding video at a variable bit rate

  • Using command-line options

  • Setting audio parameters


Using preprocessing filters

Standard motion picture film is shot at 24 fps. When motion picture film is recorded to video, it is put through a telecine process where frames are added that convert it to 30 fps for NTSC format so that it can be viewed on a television screen.

When video, such as a game show or news broadcast, is prepared for broadcast on television screens it is interlaced. Interlacing is necessary because television screens only display half of the horizontal lines in a frame, first the odd, and then the even.

Displaying video that has been telecined or interlaced on a computer monitor can result in flickering or streaking because computer monitors use a progressive display format, displaying one line after another in quick succession.

Windows Media 8 Encoding Utility includes filters that enable you to improve the quality of telecined and interlaced content on progressive-scan displays by removing the extra frames and deinterlacing the content before it is encoded. The filter that you apply depends on the source of your content.

This table describes the filters that are available.

Command | Description
-v_preproc 0 | No filters are applied. This is the default and can be used with content that is already in a progressive-scan format.
v_preproc 1 | Deinterlaces the content, but preserves its size. For example, it takes 640 pixels by 480 pixels and 30 fps interlaced content and encodes it at 640 by 480 by 30 fps progressive-scan format.
v_preproc 2 | Deinterlaces the content, but delivers half the original video size. For example, 640 by 480 and 30 fps interlaced content would be encoded at 320 by 240 and 30 fps progressive-scan format.
v_preproc 3 | Deinterlaces the content, but delivers half the original video size and doubles the frame rate. For example, 640 by 480 and 30 fps interlaced content would be encoded at 320 by 240 and 60 fps progressive-scan format.
v_preproc 4 | Deinterlaces the content, but delivers half the original vertical size and doubles the frame rate. For example, 320 by 480 and 30 fps interlaced content would be encoded at 320 by 240 and 60 fps progressive-scan format.
v_preproc 5 | Converts the video from 30 fps to 24 fps using the inverse telecine filter.

The final quality of the encoded video depends on many issues, including the filters you apply and the technique that was used to create the source film or video. If you are unsure about the source of your content, then use the -v_preproc 0 filter. If, after applying the -v_preproc 0 filter, you see telecine or interlace artifacts, encode the content again using the –v_preproc 1 deinterlacing filter.

The inverse telecine filter is designed to detect and repair 3:2 pattern breaks in your content. These pattern breaks are also called incoherencies. If you know that your content came from a film source that was telecined, use -v_preproc 5. If there are telecine artifacts in the encoded content, and you don't know whether the telecine process was coherent, encode the content again using the -v_preproc 1 deinterlacing filter.

On rare occasions, using the -v_preproc 5 filter on content that has a consistent 3:2 pattern can result in minor telecine artifacts being introduced into the encoded content. For some high-quality applications, even a single telecine artifact in an entire movie is unacceptable. In these situations, and when you know that your content is coherent, you can set a registry key that will put the inverse telecine filter into "coherent mode." In coherent mode, you specify the frame in the 3:2 pattern where the shot begins. The inverse telecine filter will assume that the telecine pattern begins with that frame and is coherent, making no pattern-break adjustments at any time.

Coherent mode is disabled by default. To enable this feature, use the registry editor to locate the registry key HKEY_CURRENT_USER\SOFTWARE\Microsoft\Scrunch\WMVideo\Coherent Content For Inverse Telecine, and then set the DWORD value of this registry key to the appropriate value. The registry values correspond to the five frames in the telecine pattern, which are represented as AA, BB, BC, CD, DD. The first letter in each of these two-letter combinations represents the odd or top field of a frame, and the second the even or bottom field.

The following table shows the registry values that correspond to each of the five frames in the 3:2 pattern.

Value | Description
0 | Coherent mode is disabled.
1 | The first frame in the clip is AA.
2 | The first frame in the clip is BB.
3 | The first frame in the clip is BC.
4 | The first frame in the clip is CD.
5 | The first frame in the clip is DD.

To set coherent mode to begin with frame BC, for example, you would set the DWORD value of the registry key to 3.

Note You should only edit the registry if you are an advanced user. It is strongly recommended that you do not edit any other values in the registry. For more information about the registry, see Windows Help.

Related topics

  • To apply a filter to your content


To apply a filter to your content

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
     cd \program files\windows media components\tools
  3. Type the following command, then press the ENTER key:
    wm8eutil –input input_file_name -output output_file_name -v_preproc filter

    Replace filter with the number of the filter you want to use. For example, to apply the deinterlacing filter that would halve the size of the original video and double the frame rate, type:

    wm8eutil –input myfile.avi –output myfile.wmv -v_preproc 3

Related topics

  • Using preprocessing filters


Encoding video at a constant bit rate

When encoding video content at a constant bit rate, you specify the average bit rate that you want to maintain and then set the size of your buffer. The bit rate fluctuations during the encoding session will be constrained by the given buffer size. Specifying a constant bit rate causes the image quality to fluctuate in order to ensure that the buffer does not overflow or underflow.

Note Audio is always encoded at a constant bit rate

Related topics

  • When to encode at a constant bit rate


When to encode at a constant bit rate

Encode your content at a constant bit rate when you intend for it to be streamed on demand. The size of the buffer will determine the amount of initial delay when the video is started, but the constant bit rate will ensure that the content can be streamed smoothly, assuming that the bit rate is compatible with the client connection speed.

Windows Media 8 Encoding Utility enables you to choose between two modes when encoding at a constant bit rate. Choosing one-pass, mode 0, means that the content will pass through the encoder once. Compression is applied as the content is encountered, and the process is complete when all content has gone through the encoder.

Choosing two-pass, mode 1, means that the encoder analyzes the content during the first pass and then encodes in the second pass based on the data it gathered the first time. Two-pass encoding can result in better image quality because the encoder takes its time to find the optimal combination of bit rate, frame rate, buffer size, and image quality based on the scene composition. Two-pass encoding also takes longer because the encoder goes through all of the video twice.

Whether you are encoding your constant bit rate content in one or two passes, you must specify the desired bit rate, buffer size, and image quality settings using these parameters: -v_bitrate, -v_buffer, and –v_quality. For each of these parameters, keep these things in mind:

  • The higher the bit rate, the better the image quality that you will be able to achieve.

  • A larger buffer enables you to achieve better image quality, but the user will wait longer for the video to start.

  • As the image quality increases, the frame rate decreases so you might have to experiment to achieve a balance between these two settings.

Related topics

  • To encode in one pass using a constant bit rate

  • To encode in two passes using a constant bit rate


To encode in one pass using a constant bit rate

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
     cd \program files\windows media components\tools
  3. Type the following command, then press the ENTER key:
    wm8eutil –input input_file_name -output output_file_name -v_mode 0 -v_bitrate bitrate –v_buffer size –v_quality quality

    For example:

    wm8eutil –input myfile.avi –output myfile.wmv -v_mode 0 -v_bitrate 100000 –v_buffer 5000 –v_quality 75

Related topics

  • Encoding video at a constant bit rate

  • Encoding video at a variable bit rate


To encode in two passes using a constant bit rate

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
     cd \program files\windows media components\tools
  3. Type the following command, then press the ENTER key:
    wm8eutil –input input_file_name -output output_file_name -v_mode 1 -v_bitrate bitrate –v_buffer size –v_quality quality

    For example:

    wm8eutil –input myfile.avi –output myfile.wmv -v_mode 1 -v_bitrate 100000 –v_buffer 5000 –v_quality 75

Related topics

  • Encoding video at a constant bit rate

  • Encoding video at a variable bit rate


Encoding video at a variable bit rate

Encoding video content at a variable bit rate enables you to specify, from 0 to 100, the image quality that you want to maintain throughout the encoding process. Specifying the desired image quality will cause the bit rate to fluctuate according to the complexity of the scene—a higher bit rate is used for intense detail or high motion, and a lower bit rate is used for simpler content. If bit rate is more important to you than image quality, you can specify a desired bit rate and the encoder will establish the image quality level that can be achieved reasonably.

Related topics

  • When to encode at a variable bit rate


When to encode at a variable bit rate

Encode your content at a variable bit rate when you intend for the content to be downloaded and then played back locally. Windows Media Player might experience pauses or glitches when streaming clips that were encoded at a variable bit rate over the Internet. This is, in part, caused by the bit rate of variable bit rate content varying significantly from scene to scene. As a result, variable bit rate clips are currently suitable for download-and-play applications only. Future versions of Windows Media Services are expected to stream variable bit rate clips properly, but streaming of variable bit rate clips is not supported currently.

As with constant bit rate content, you can encode variable bit rate content in one or two passes. These passes are called quality-based variable bit rate and bit-rate-based variable bit rate, respectively. In the variable bit rate mode that is based on quality, mode 2, all frames are encoded at the image quality specified and no frames are dropped. Use this mode when you want to guarantee the image quality. When encoding variable bit rate content in mode 2, you must specify the desired image quality setting using the –v_quality parameter.

Use the variable bit rate mode that is based on bit rate, mode 3, when you want to set an average bit rate. During the first pass, the encoder evaluates the complexity of the video to determine the image quality setting that can be achieved uniformly and then encodes the content during the second pass. When encoding variable bit rate content in mode 3, you must specify the desired bit rate using the –v_bitrate parameter. No frames are dropped in this mode.

Note The content generated in the variable bit rate modes should be played in Windows Media Player version 7 and above; variable bit rate content does not play well in Windows Media Player versions 6.4 and earlier.

Related topics

  • To encode variable bit rate content that is based on quality

  • To encode variable bit rate content that is based on bit rate


To encode variable bit rate content that is based on quality

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
     cd \program files\windows media components\tools
  3. Type the following command, then press the ENTER key:
    wm8eutil –input input_file -output output_file -v_mode 2 -v_quality quality

    For example:

    wm8eutil –input myfile.avi –output myfile.wmv -v_mode 2 -v_quality 85

Related topics

  • Encoding video at a constant bit rate

  • Encoding video at a variable bit rate


To encode variable bit rate content that is based on bit rate

  1. Open a command prompt window.

  2. Go to the working directory where the file wm8eutil.exe is located. For example, type
     cd \program files\windows media components\tools
  3. Type the following command, then press the ENTER key:
    wm8eutil –input input_file -output output_file -v_mode 3 -v_bitrate bitrate

    For example:

    wm8eutil –input myfile.avi –output myfile.wmv -v_mode 3 -v_bitrate 100000

Related topics

  • Encoding video at a constant bit rate

  • Encoding video at a variable bit rate


Using command-line options

The following are all of the command-line options that you can append to your command to achieve specific encoding results. If you've specified a profile in addition to any of these parameters, these parameters will take precedence.

–allstats

Displays all available statistics once the encoding process is complete. For example:

wm8eutil –input my-songs.wav –output my-songs.wma –allstats

-a_setting bitrate_samplerate_channel

Specifies the audio bit rate, sample rate, and channel setting to use while encoding. Each value is separated by an underscore, in the form bitrate_samplerate_channel. The default value is 64_44_2. For example:

wm8eutil –input myfile.wav –output myfile.wma –a_setting 32_32_2

To view the complete list of acceptable combinations, see Setting audio parameters or type wm8eutil –a_audio? at the command line.

-author string

Specifies the author of the audio or video clip.

wm8eutil –input my-songs.wav –output my-songs.wma –author David Johnson

-copyright string

Specifies the copyright information for the audio or video clip. For example:

wm8eutil –input my-songs.wav –output my-songs.wma –copyright David Johnson 2001

-description string

Specifies information about the audio or video clip. For example:

wm8eutil –input my-songs.wav –output my-songs.wma –description A collection of my favorite music

-input file_name

Used by itself, and without a corresponding –output parameter, displays the properties of the input file. For example:

wm8eutil –input myfile.avi

-output output_file_name

Used in conjunction with the –input parameter, this command specifies the name of the output file. For example:

wm8eutil –input my-songs.wav –output my-songs.wma

-outputstring string

When -input specifies a directory, appends the text entered for string to the file name of every output file. The string precedes the .wma or .wmv file name extension. For example:

wm8eutil –input my-songs –output my-songs-coded –outputstring coded

-profile profilename

Specifies the profile that is to be used during the encoding session. For example:

wm8 eutil –input myfile.avi output myfile.wmv -profile av700pal

-rating string

Specifies the rating of the audio or video clip. For example:

wm8eutil –input myfile.avi –output myfile.wmv –rating PG

-silent

Prevents encoding statistics from being displayed once the encoding process is complete.

wm8eutil –input my-songs.wav -output _my-songs.wma –silent

-time start time end time

Specifies, in milliseconds, the precise times within the audio or video that encoding should start and stop. If you do not know the precise end time, then replace end time with end. For example:

wm8eutil –input myfile.avi –output myfile.wmv –time 10000 20000
wm8eutil –input myfile.avi -output myfile.wmv –time 10000 end

-title string

Specifies the title of the audio or video clip. For example:

wm8eutil –input my-songs.wav –output my-songs.wma –title My Favorite Music

-v_bitrate bitrate

Specifies the desired bit rate in bits per second. The default is 80000. For example:

wm8eutil –input myfile.avi –output myfile.wmv –v_bitrate 100000

-v_buffer size

Specifies the portion of the video, in milliseconds, to be stored in memory before being played. The default value is 5000 milliseconds. For example:

wm8eutil –input myfile.avi –output myfile.wmv –v_buffer 1000

-v_clip left top right bottom

Specifies the horizontal and vertical coordinates of the top-left and lower-right portions of the video. For example, clipping 60 pixels off of the top and bottom of a 640 by 480 video would result in these coordinates: 0, 60, 640, 420. Clipping is done on the source. The default is no clipping. For example:

wm8eutil –input myfile.avi –output myfile.wmv –v_clip 0 60 640 420

-v_codec name

Specifies the video codec to be used. Use WMV7 for Windows Media Video version 7 and WMV8 for Windows Media Video version 8. The default is WMV8. For example:

wm8eutil –input myfile.avi –output myfile.wmv –v_codec WMV8

-v_framerate rate

Specifies the frame rate at which the video will be encoded. The rate can be an integer or floating-point value. The default is the frame rate of the source. For example:

wm8eutil –input myfile.avi –output myfile.wmv –v_framerate 24

-v_height height

Specifies, in pixels, the height of the frame to be encoded. The default is the height of the source. For example:

wm8eutil –input myfile.avi –output myfile.wmv –v_height 480

-v_keydist time

Specifies the number of seconds between key frames. The default is 10. For example:

wm8eutil –input myfile.avi –output myfile.wmv –v_keydist 20

-v_mode mode

Specifies whether to encode in one or two passes. Also indicates whether to use a constant bit rate or variable bit rate. For example:

wm8eutil –input myfile.avi –output myfile.wmv -v_mode 2

-v_preproc filter

Specifies the preprocessing filter to apply to your content. Replace filter with the number of the filter you want to use. For example:

wm8eutil –input myfile.avi –output myfile.wmv -v_preproc 3

-v_quality quality

Defines the image quality of the encoded video. Image quality ranges from 0 to 100. In the constant bit rate modes (-v_mode 0 or –v_mode 1) 0 represents the smoothest motion and 100 represents the crispest images. The default is 75. For example:

wm8eutil –input myfile.avi –output myfile.wmv –v_mode 0 –v_quality 40

In the variable bit rate mode that is based on quality (-v_mode 2) this value represents the target image quality for the entire sequence. The default is 85. For example:

wm8eutil –input myfile.avi –output myfile.wmv –v_mode 2 –v_quality 95

-v_width width

Specifies, in pixels, the width of the frame to be encoded. The default is the width of the source. For example:

wm8eutil –input myfile.avi –output myfile.wmv –v_width 640


Setting audio parameters

When using the –a_setting bitrate_samplerate_channel command, you must specify the audio bit rate, sample rate, and channel combination to apply to your content during the encoding process. Only a finite set of combinations is supported by the Windows Media Audio version 8 codec. Those combinations are provided in the table below. Each value in the string is separated by an underscore, in the form bitrate_samplerate_channel. The default value is 64_44_2.

String | Bit rate (bps) | Sampling rate | Channels
192_48_2 | 192000 | 48000 | 2
160_48_2 | 160000 | 48000 | 2
128_48_2 | 128000 | 48000 | 2
192_44_2 | 192000 | 44100 | 2
160_44_2 | 160000 | 44100 | 2
128_44_2 | 128000 | 44100 | 2
96_44_2 | 96000 | 44100 | 2
80_44_2 | 80000 | 44100 | 2
64_44_2 | 64000 | 44100 | 2
48_44_2 | 48000 | 44100 | 2
32_44_2 | 32000 | 44100 | 2
48_44_1 | 48000 | 44100 | 1
32_44_1 | 32000 | 44100 | 1
48_32_2 | 48000 | 32000 | 2
40_32_2 | 40000 | 32000 | 2
32_32_2 | 32000 | 32000 | 2
20_32_1 | 20000 | 32000 | 1
32_22_2 | 32000 | 22050 | 2
22_22_2 | 22000 | 22050 | 2
20_22_2 | 20000 | 22050 | 2
20_22_1 | 20000 | 22050 | 1
16_22_1 | 16000 | 22050 | 1
20_16_2 | 20000 | 16000 | 2
16_16_2 | 16000 | 16000 | 2
16_16_1 | 16000 | 16000 | 1
12_16_1 | 12000 | 16000 | 1
10_16_1 | 10000 | 16000 | 1
10_11_1 | 10000 | 11025 | 1
8_11_1 | 8000 | 11025 | 1
12_8_2 | 12000 | 8000 | 2
8_8_1 | 8000 | 8000 | 1
6_8_1 | 6000 | 8000 | 1
5_8_1 | 5000 | 8000 | 1
0* | 0 | N/A | N/A

* Use 0 when you want to encode only the video portion of your source.

Related topics

  • Advanced encoding techniques


Accessing Help from the command line

Help is available from the command line. The command-line help is intended for quick reference and does not include all of the information provided by this help document. The following table lists the commands you can use and descriptions for each of them. Precede all commands with wm8eutil.

-a_default?

Lists the default values for each of the optional audio parameters.

-a_example?

Displays sample commands for encoding audio-only files.

-all?

Describes all command-line options.

-audio?

Lists all of the possible audio settings.

-av_example?

Displays sample commands for encoding files that contain both audio and video.

-cont_desc?

Displays each of the content description parameters and explains how to use them. These parameters include –title, -author, -copyright, -description, and -rating.

-default?

Lists the default values for each of the optional audio and video parameters.

-d_example?

Displays sample commands for encoding all files within a directory.

-example?

Displays sample commands for encoding various types of content.

-help?

Displays this compiled help file.

-io?

Describes all of the input and output options, including –input, -output, -ouputstring, -time, -silent, -config, and –s_config.

-profile?

Lists all of the available profiles by number and includes basic descriptions.

-profileall?

Lists the details for all profiles, including codecs, bit rate, frame rate, image quality, buffer, key frame, and video size.

-profile_profilename?

Displays the details of the profile that you specify. Replace profilename with the number of the profile that you want to see.

-v_default?

Lists the default values for each of the optional video parameters.

-video?

Displays the details of each available video setting, such as –v_codec, -v_width, -v_height, -v_framerate, and so on.

-v_example?

Displays sample commands for encoding video-only files.


Frequently asked questions

  1. Is the new Windows Media Audio version 8 codec compatible with previous versions of the codec?

    Yes. Content encoded with the Windows Media Audio version 8 codec can be decoded by previous versions of the Windows Media Audio codec.

  2. Can I set up a live broadcast with Windows Media 8 Encoding Utility?

    No. Windows Media 8 Encoding Utility is intended for creating on-demand files only.

  3. Can I use extended .avi files with Windows Media 8 Encoding Utility?

    Yes. Windows Media 8 Encoding Utility supports the extended .avi format specification and can encode .avi files that are larger than 2 gigabytes (GB).

  4. Can I edit profiles with the Windows Media Encoder 7 Profile Manager feature and then use those edited profiles with Windows Media 8 Encoding Utility?

    No. But you can create your own profiles using a configuration file. See Using configuration files for more information.

  5. What kind of compression is applied if I don't specify a profile or optional parameters in my encoding command?

    Windows Media 8 Encoding Utility will use the defaults for each setting. For example, the Windows Media Audio version 8 and Windows Media Video version 8 codecs would be used, the frame rate would match that of the input source, and the audio and video bit rates would be 60 and 80 kilobits per second (Kbps), respectively.

  6. What's the difference between the new codecs and those that were included with Windows Media Encoder 7?

    The Windows Media Audio version 8 codec improves audio quality by 30 to 50 percent over the Windows Media Audio version 7 codec. For example, it offers the same audio quality as .mp3 but in a file that is one-third the size. It can also provide audio streams that are near CD-quality over a 48 Kbps connection. The Windows Media Video version 8 codec provides video quality improvements of 20 to 30 percent for broadband Internet users compared with the Windows Media Video version 7 codec.

  7. Can I transcode compressed Windows Media files with .wma and .wmv file name extensions in order to achieve a different bit rate?

    No. If you want to encode your audio or video at a different bit rate than what you encoded the first time, encode the original uncompressed source file (with a .wma, .wmv, .avi, or .wav file name extension) again and specify the bit rate you want with the –v_bitrate option for video or the –a_setting option for audio.

  8. I set the –v_bitrate in one- and two-pass constant bit rate and bit-rate-based variable bit rate modes (-v_mode 0, 1, and 3), and the bit rate of the compressed clip is significantly lower than what I specified. Is this an error?

    No. If the clip, or some segment of the clip, is easy to encode for the target bit rate (for example, the bit rate setting is very high and the resolution is low) then the codec will not require all of the available bandwidth to compress the content.

  9. I set the –v_bitrate in bit-rate-based variable bit rate mode (-v_mode 3), and the bit rate of the compressed clip is significantly higher than what I specified. Is this an error?

    No. Frames are not dropped when you encode using the –v_mode 3 option. Therefore, if the clip, or some segment of the clip, is difficult to encode for the target bit rate (for example, the bit rate setting is low and the resolution is high) then the codec will require more bandwidth to compress the content.

  10. In what order does Windows Media 8 Encoding Utility clip, preprocess, and resize my content?

    Clipping is the first step and is performed on the source. By clipping first, your encoding process will be more efficient because you eliminate any unwanted portions of the video before encoding them. Preprocessing, such as applying deinterlacing or inverse telecine filters, comes second, followed by setting the output size of the encoded video.

  11. What is the difference between the encoding modes in Windows Media Encoder 7 and Windows Media 8 Encoding Utility?

    Windows Media 8 Encoding Utility enables you to perform two-pass constant bit rate video encoding and variable bit rate encoding that is either based on quality or bit rate.

  12. Can I add the Windows Media Audio version 8 and Windows Media Video version 8 codecs to Windows Media Encoder 7?

    No. Windows Media Encoder 7 does not currently support Windows Media Audio version 8 and Windows Media Video version 8 codecs. The next version of Windows Media Encoder will support these or other future versions of the codecs, as well as two-pass constant bit rate video encoding and quality- and bit-rate-based variable bit rate encoding.

  13. Can I use Windows Media 8 Encoding Utility to encode a multiple bit rate file in order to stream my content to users who have various connection speeds?

    No. Windows Media 8 Encoding Utility does not support multiple bit rate encoding. Windows Media Encoder 7 does support multiple bit rate encoding, and includes several profiles to suit your needs.

  14. Should I convert my .mp3 files to .wav files in order to encode them with Windows Media 8 Encoding Utility?

    No. Converting from .mp3 to .wav causes quality degradation. Use Windows Media Encoder 7 to encode your .mp3 files. Use the original uncompressed content when encoding with Windows Media 8 Encoding Utility.

  15. When playing back my encoded audio in Windows Media Player 7, I hear popping sounds. I don't hear these sounds when playing the same audio in Windows Media Player 6.4. What is causing this?

    The popping sound you hear is a brief discontinuity in the audio track caused by a reading error in Windows Media Player 7. This problem is not common and is usually inaudible. Until an update is available to fix the problem, use Windows Media Player 6.4 to play any clips where the popping sound is noticeable.

  16. I used the -v_quality setting to set my image quality at 95 and then 96. I achieved the same result with both settings. Is this normal?

    Yes. Some of the -v_quality settings are mapped internally to the same image quality value. To see a change in your image quality, increase or decrease your -v_quality setting by larger increments.

  17. The statistic showing the amount of buffer that was used during my encoding session differs from the -v_buffer value that I set. Why?

    If you set a large buffer but are encoding content that is not very complex, the codecs may not use all of the buffer space that was allocated. In the rare case that you set a very small buffer, the codecs may need a larger buffer space than what you allocated. The effective buffering delay is either the buffer that you set or that the codecs actually used, whichever is larger.

  18. Why is my encoded video upside down when I play it back in Windows Media Player?

    Occasionally, encoded video will be upside down when it is played in Windows Media Player because capture card drivers interpret the packed YUV file format in different ways.

    Windows Media 8 Encoding Utility enables you to set a registry key that will flip the video before encoding it so that it displays correctly. By default this feature is disabled. To enable this feature, use the registry editor to locate the registry key HKEY_CURRENT_USER\SOFTWARE\Microsoft\Scrunch\WMVideo\Vertical Flip Packed YUV, and then set the DWORD value of this registry key to 1.

    Note You should only edit the registry if you are an advanced user. It is strongly recommended that you do not edit any other values in the registry. For more information about the registry, see Windows Help.


Glossary

To find a term in the glossary, click the letter of the alphabet that is the first letter in the term you want to look up.

You can also read glossary terms within the text of Help by clicking the underlined glossary term links. After you click a glossary link, the glossary term and definition appear in a pop-up window. To close the window, click anywhere on the screen.

A | B | C | D | E | F | G | H | I | J | K | L | M
N | O | P | Q | R | S | T | U | V | W | X | Y | Z

Symbols

.avi

A Windows multimedia video file.

.wav

The file name extension for an audio file in WAV format that can be played by most Windows-based programs.

.wma

The file name extension of an audio file in Windows Media Format. The audio content of the file is encoded with the Windows Media Audio codec.

.wmv

The file name extension of a video file in Windows Media Format.

Back to Top

B

bandwidth

The data transfer capacity of a digital communications system, such as the Internet or a local area network (LAN). Bandwidth is usually expressed in the number of bits that a system is capable of transferring in a second: bits per second (bps) or kilobits per second (Kbps).

bit rate

The speed at which digital audio and video content must be streamed to be rendered properly by a player; or the speed at which digital content in general is streamed on a network. Bit rate is usually measured in kilobits per second (Kbps), for example, 28.8 Kbps.

Back to Top

C

CD quality

Audio that is encoded by using uncompressed pulse code modulation (PCM) at 44.1 kHz and 16-bit stereo. A CD and an audio stream encoded at CD quality sound identical.

codec

An abbreviation for compressor-decompressor. It is software or hardware used to compress and decompress digital media.

compression

The coding of data to reduce file size or the bit rate of a stream. Content that has been compressed is decompressed for playback.

configuration file

A text file used by Windows Media 8 Encoding Utility that contains the names of the files to be encoded and the command line options to be invoked.

constant bit rate

Describes the ability to increase or decrease the quality of the encoded video during the encoding process to maintain a nearly constant bit rate.

content

Audio, video, images, text, or any other information that is contained in a digital media file or stream.

Back to Top

D

deinterlace

To combine two interlaced fields into a single frame that is not interlaced. Deinterlacing is done to remove artifacts and improve the quality of encoded video.

Back to Top

F

frame rate

The number of frames displayed per second in video. High frame rates generally produce better quality video because there are more frames, which makes movement in the video appear smoother.

Back to Top

I

ICM

See definition for: Image Compression Manager (ICM)

Image Compression Manager (ICM)

Provides system-level support for image compression and decompression drivers. Also called the Video Compression Manager (VCM).

interlace

To display video by using a half-resolution image known as a field. Interlaced video uses two video fields to make a single frame of video. Each field of video contains alternating lines of an image: field 1 displays the odd numbered lines and field 2 displays the even numbered lines. Interlacing saves bandwidth when the video is transmitted as a television broadcast or on cable.

inverse telecine

The process that intelligently removes the frames that were added when 24-fps film was converted to 30-fps video.

Back to Top

K

key frame

A frame of video data that contains all the data necessary to construct that frame. In contrast, delta frames contain data relating to changes from the last key frame, and do not contain enough information to construct a complete frame.

Back to Top

M

multiple bit rate

Describes a file or stream that contains the same content encoded at several different bit rates. As network traffic changes, a Windows Media server can switch to a lower or higher bit rate to optimize content delivery.

Back to Top

N

National Television Standards Committee (NTSC)

The standards body that is responsible for setting television and video standards in the United States. The NTSC standard for television defines a composite video signal with a refresh rate of 60 half-frames (interlaced) per second. Each frame contains 525 lines and can contain 16 million different colors.

NTSC

See definition for: National Television Standards Committee (NTSC)

Back to Top

O

one-pass encoding

The ability to pass content through the encoder once. Compression is applied as the content is encountered.

Back to Top

P

PAL

See definition for: Phase Alternating Line (PAL)

PCM

See definition for: Pulse Code Modulation (PCM)

Phase Alternating Line (PAL)

The dominant television standard in Europe. Whereas the NTSC, the U.S. standard, delivers 525 lines of resolution at 60 half-frames per second, PAL delivers 625 lines at 50 half-frames per second.

pixel format

The color depth of an image, usually measured in RGB or YUV.

profile

A predefined group of settings that match content type and bit rate with appropriate audio and video codecs.

Profile Manager

A component of Windows Media Encoder that creates and edits the encoding profiles needed to identify the appropriate codec, the multimedia input streams, and the number and bit rate of the encoded output streams.

Pulse Code Modulation (PCM)

A sampling technique for digitizing analog signals, especially audio signals. When you encode audio by using PCM, no compression is applied.

Back to Top

R

RGB

A color model that describes color information in terms of the red (R), green (G), and blue (B) intensities that make up the color.

Back to Top

S

sampling rate

The frequency at which audio or video is sampled, or recorded, into a digital format. Each sample represents the audio or video signal at a particular moment in time. The higher the sampling rate (that is, the more samples taken per unit of time), the more closely the digitized result resembles the original.

source

Content that you can encode. Source audio and video content can be captured and encoded from devices installed on your computer or from a file.

stream

Data transmitted across a network and any properties associated with the data. Streaming digital data enables clients to begin rendering the data immediately instead of waiting for the entire file to be received.

Back to Top

T

target bandwidth

The number of bits that are transferred to users based on their network connection speeds.

telecine

The film-to-video conversion system that adds frames to video to compensate for the differences in frame rates between film and video. When converting 24 fps film to 30 fps NTSC video, an additional 6 frames per second are added.

transcode

To encode content that is already in Windows Media format, but at a different bit rate.

two-pass encoding

The ability to pass content through the encoder twice. During the first pass, the encoder analyzes the content. During the second pass the encoder applies the appropriate levels of compression, based on the complexity of the material, as determined during the first pass.

Back to Top

V

variable bit rate

Describes the ability to increase or decrease the bit rate of the encoded video as needed during the encoding process to maintain a given quality level.

Back to Top

W

Windows Media file

A file containing audio, video, or script data that is stored in Windows Media Format. Depending on their content and purpose, Windows Media files use a variety of file name extensions, such as: .wma, .wme, .wms, .wmv, .wmx, .wmz, or .wvx.

Windows Media Format

The format used by Microsoft Windows Media Technologies (or a third-party product that incorporates a licensed Windows Media technology) to author, store, edit, distribute, stream, or play timeline-based content.

Back to Top

Y

YUV

A color model that describes color information in terms of luminance (Y) and chrominance (U, V).

Back to Top


Legal Notice

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, people and events depicted herein are fictitious and no association with any real company, organization, product, person or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2000-2001 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows Media, Windows NT, ActiveSync, ActiveX, Direct3D, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, FrontPage, JScript, Microsoft Press, MSN, NetShow, Outlook, PowerPoint, SQL Server, Visual Basic, Visual C++, Visual InterDev, Visual J++, Visual Studio, WebTV, Win32, and Win32s are either registered trademarks or trademarks of Microsoft Corporation in the U.S.A. and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.