Welcome

Archivační Průzkumník

Elektronická příručka

Tato příručka je elektronickou podobou tištěné příručky.

Použití příručky

S příručkou můžete pracovat tak, že jí budete pročítat běžným způsobem, nebo si jí vytisknete a budete jí používat v tištěné podobě.

Pročítání příručky

Pročítání příručky můžete začít otevřením složky Příručka v levém panelu a pak kliknout na příslušnou stránku, která vás zajímá.

Tisk příručky

Vytištění příručky můžete začít kliknutím na složku Tisk příručky v levém panelu a pak se řídit pokyny na zobrazené stránce.

copyright © 1999 amedea.cz


Contets

Obsah


Page 2

 Archivační Průzkumník


Pg 3

 Úvod

Úvod

Při práci s počítačem zpravidla narazíte na problém přenosu dat mezi počítači. Ať už pomocí disket, CD, Internetu, apod.

Také často potřebujete archivovat(zálohovat) některá svá důležitá data.

Samozřejmě, že když data, z jakéhokoliv důvodu, archivujete, tak je také potřebujete získat nazpět, nebo si je alespoň ověřit.

Archivační Průzkumník

K archivování souborů, ať už z důvodu přenosu dat, zálohování dat, popř.jiného, je určen právě Archivační Průzkumník. Pomocí Archivačního Průzkumníka lze snadno a rychle soubory nejen archivovat, ale také je zpětně obnovit. K archivaci i obnovení používá nejpoužívanější formáty. To má ten důsledek, že nemusíte předpokládat, že když budete někomu předávat data vytvořená Archivačním Průzkumníkem, že má také Archivačního Průzkumníka. Stačí aby měl nějaký program, který umí pracovat s příslušným formátem archivu. Kromě toho má Archivační Průzkumník další možnost, a to vytvářet soubory zcela nezávislé na použitém formátu dat.

Jak získat další informace

Další informace o programu lze získat z on-line nápovědy, která je součástí programu Archivační Průzkumník. Informace, týkající se Archivačního Průzkumníka také naleznete na internetovské adrese http://www.amedea.cz/arcexpl/cze. Další informace je možno získat také dotazem na schránku podpory support@amedea.cz.

Archivační Průzkumník 1 - 1


Page 4

 Základní pojmy

Základní pojmy

Než se seznámíte s Archivačním Průzkumníkem, je vhodné se seznámit s pojmy, které budou v dalším textu používány.

Archiv

Archiv je soubor, který obsahuje jiné soubory. Archiv může být tvořen jedním souborem, nebo může být rozdělen do několika na sebe navazujících souborů. Archiv může mít různý formát. Tím se myslí, že soubor, v němž jsou uloženy jiné soubory, může mít různé uspořádání.

Archiv můžete vytvářet (stránka Archivace) a soubory z archivu také můžete zpětně obnovit (stránka Obnovení).

Když budete používat archivy jen pro sebe, tak není z hlediska zpětného obnovení důležité, jaký mají formát. Pokud ale budete archivy předávat někomu jinému, na jiný počítač, už musíte použít takový formát, s nímž bude možné na tomto počítači pracovat.

Archiv může mít význam souboru s kompresovanými daty, které slouží pro přenos mezi počítači, ale také význam souboru(nebo souborů) záložních kopií souborů.

Archivační výčetka

Archivační výčetkou se rozumí určitý výběr souborů včetně nastavení určitých možností , které s ním souvisí. Archivační výčetku můžete uložit na disk a pak jí zpětně otevřít(načíst), založit novou výčetku, a také použít uloženou výčetku k vytvoření zástupce, nebo položky plánovače úloh.

2 - 1 Archivační Průzkumník


Page 5

 Základní pojmy

Součástí archivační výčetky jsou nejen složky a soubory, které vyberete, ale i specifikace složky(popř.driveru), do něž se bude archivovat, druh archivace, jméno archivu, atd. Často používané možnosti nastavení archivační výčetky můžete změnit přímo z Panelu možností. Chcete-li ale měnit možnosti souhrnně je potřeba použít příkaz menu Možnosti. Tak lze změnit nejen archivační složku, druh archivace, ale také velikosti archivů, jaké se mají vytvářet, jejich jména i návěští disket, jestliže se archivuje na diskety. Také můžete specifikovat, zda se má vytvořit po ukončení archivace soubor hlášení, popř.zda se má po ukončení archivace převést vytvořený archiv na samoobnovovací soubor.

Samoobnovovací soubor

Když chcete předat soubory na jiný počítač a nevíte zda bude na tomto jiném počítači archiv možno obnovit, můžete připravit archiv v podobě samoobnovovacího souboru. Samoobnovovací soubor je spustitelný soubor(zpravidla s příponou exe). K obnovení souborů z takového archivu není potřeba žádný speciální program(například Archivační Průzkumník).

Archivace

Archivací se rozumí proces vytváření archivů. To znamená přenos souborů z vašeho počítače, popř.z okolí vašeho počítače.

Obnovení

Obnovením se rozumí proces obnovení souborů z archivů do vašeho počítače, popřípadě jeho okolí.

Archivační Průzkumník 2 - 2


Page 6

 Archivace

Archivace

Vytváření archivů

Program je určen k archivování dat z počítače, popř.jeho okolí, a k jejich zpětnému obnovení.

První spuštění

Nejsnadnější cesta, jak se s programem seznámit je jeho spuštění. Program můžete např.spustit:

  • ze Start menu v menu Programy a Archivační Průzkumník,
  • dvojkliknutím na ikonu archivu ve Windows Průzkumníku.

Když poprvé spustíte program, objeví se toto okno:

3 - 1 Archivační Průzkumník


Page 7

 Archivace

Toto je úvodní obrazovka, která vám může pomoci provést nejčastější úlohy. Přečtěte si informace, které jsou vám tímto oknem podány. Pokud nebudete chtít, aby se toto okno zobrazovalo při dalším spuštění, tak odškrtněte zaškrtávací políčko ve spodní části obrazovky. Pokud jen nechcete spustit žádného z průvodců, tak klikněte na Zavřít.

V tomto okně je vám nabídnuto několik průvodců. Vy si můžete vybrat ten, který je pro vás v daném okamžiku nejvhodnější. Výběr provádíte jednoduše tím, že myší ukážete na příslušný řádek. Tento řádek se zvýrazní a zobrazí stručné informace k danému průvodci. Pokud na takto zvýrazněný text kliknete, automaticky se spustí příslušný průvodce.

Nemá smysl popisovat každého průvodce, protože práce s každým z nich je obdobná. Proto jen stručně například k Jednoduché archivaci. Po ukázání myší se zobrazí toto okno:

Archivační Průzkumník 3 - 2


Page 8

 Archivace

Všimněte si zvýrazněného textu Jednoduchá archivace a v pravém obdélníku pak krátký text týkající se tohoto průvodce. Když na tento zvýrazněný text nyní kliknete zobrazí se úvodní okno průvodce. Toto okno vypadá takto:

3 - 3 Archivační Průzkumník


Page 9

 Archivace

Zde jsou uvedeny všechny kroky, které je potřeba provést. Ve spodní části jsou pak dvě tlačítka. Když kliknete na Start, tak s vámi začne průvodce jednotlivé kroky provádět. Jestliže nechcete průvodce spouštět jen klikněte na Storno. K přerušení průvodce také můžete kliknout na tlačítko Zavřít(křížek v horní části okna - [image]). Kliknutím na toto tlačítko můžete průvodce stornovat i později, kdykoliv během práce s průvodcem. Po kliknutí na Start se ukáže pravděpodobně(záleží podle toho, co již je hotovo) toto okno:

Archivační Průzkumník 3 - 4


Page 10

 Archivace

Již hotové, splněné, kroky jsou znázorněny červeným zaškrtnutím. Krok, který se právě plní je znázorněn modrou šipkou a ještě nesplněné kroky jsou znázorněny šipkou šedou.

U kroku který se právě plní je vždy stručně popsáno, co se v tomto kroku od vás požaduje. V tomto příkladu to je požadavek na vybrání souboru nebo složky a nebo driveru.

Jestliže nevíte, co se pro provedení kroku má provést kliknete na příslušnou položku. Například, když nevíte, jak vybrat soubor, klikněte na text Jak vyberu soubor. Po kliknutí na tento text se vám ukáže, co se má udělat k tomu aby se soubor vybral. Okno pak může vypadat takto:

3 - 5 Archivační Průzkumník


Page 11

 Archivace

Ve žluté oblasti je popsáno v jednotlivých krocích, co se všechno má provést. Pokud vám tento popis nevyhovuje, nebo se jím teď nechcete zabývat, klikněte na Prosím, vyber soubor, nevím jak to udělat. Průvodce to udělá za vás.

Archivační Průzkumník 3 - 6


Page 12

 Archivace

Obdobně se takto postupně prochází všemi kroky. Vždy víte, co máte splněno, co vás čeká a co máte právě udělat. Po provedení všech kroků se průvodce sám ukončí. Pokud se kdykoliv v průběhu práce s průvodcem rozhodnete, že už dále jeho pomoc nebudete potřebovat, tak jednoduše kliknete, tak jak už bylo uvedeno dříve, na tlačítko zavřít a můžete pokračovat podle svého uvážení.

Seznámení se s programem

Když spustíte program, tak jak již bylo uvedeno:

  • ze Start menu v menu Programy a Archivační Průzkumník,
  • dvojklikem na ikonu archivu ve Windows Průzkumníku,

a nezobrazí se úvodní obrazovka s nabídkou průvodců, nebo když úvodní obrazovku s průvodci zavřete, uvidíte některou ze stránek Archivačního Průzkumníka. Archivační Průzkumník má dvě stránky: stránku Archivace a stránku Obnovení. Mezi oběma stránkami můžete jednoduše a rychle přepínat pomocí Info panelu(viz.dále), nebo pomocí menu a nebo klávesou F7. Oba panely si jsou velmi podobné, liší se ale svým účelem.

Stránka archivace

Stránka archivace obsahuje vše, co je potřeba k vytvoření archivu, tzn.souboru, nebo souborů, které tvoří záložní kopie dat, nebo kompresovaná data, která chcete použít k přenosu na jiný počítač, apod.

Stránka Archivace může vypadat takto(záleží na tom, jak si jí uzpůsobíte):

3 - 7 Archivační Průzkumník


Page 13

 Archivace

Archivační Průzkumník 3 - 8


Page 14

 Archivace

Panel menu

V panelu menu jsou obsaženy všechny dostupné příkazy Archivace.

Panel nástrojů

V panelu nástrojů jsou umístěny nejpoužívanější tlačítka. Tento panel si můžete upravit podle svých potřeb. V nápovědě se dozvíte konkrétní postup.

Panel možností

V panelu možností jsou obsaženy často používané možnosti nastavení archivace. Jestliže potřebujete změnit tato nastavení, tak jednoduše kliknete na přilehlé tlačítko, popř. na šipku u příslušného políčka. Jak změnit všechny možnosti archivace se opět dozvíte z on-line nápovědy.

Info panel

Info panel vás informuje o stránce v níž právě pracujete. V tomto případě to je stránka Archivace. Tento panel také můžete využít k přepínání mezi touto stránkou a stránkou Obnovení. Pouze na něj kliknete. Nezáleží na které místo.

Panel složek

V panelu složek jsou obsaženy všechny složky, dostupné k archivaci z vašeho počítače. U složky, kterou lze archivovat, je malý čtvereček. Tento čtvereček signalizuje, zda se složka bude a nebo nebude archivovat. Čtvereček může vypadat takto:

3 - 9 Archivační Průzkumník


Page 15

 Archivace
Značka | Popis
 | Složka není vybrána. To znamená, že žádný soubor nebo složka, obsažená v této složce nebude archivována.
 | Složka je vybrána. To znamená, že všechny soubory, včetně i všech složek, které jsou obsaženy v této složce budou archivovány.
 | Složka je částečně vybrána. To znamená, že jsou vybrány pouze některé soubory nebo složky, které tato složka obsahuje.

Změnu stavu výběru složky, změníte kliknutím na tento čtvereček. Po kliknutí se změní jeho vzhled podle toho k jaké změně došlo.

U složky také může být čtvereček se znaménkem plus nebo mínus. Tento čtvereček indikuje a umožňuje změnit zobrazení složek:

Značka | Popis
 | Znamená, že složka obsahuje další, podřízené, složky. Pokud kliknete na tuto značku tak se tyto složky zobrazí.
 | Znamená, že složka obsahuje další složky. Tyto složky jsou právě viditelné. Když kliknete na tuto značku, tak se tyto složky skryjí.

Jestliže u složky není ani jedna z těchto značek, tak to znamená, že složka neobsahuje žádné další složky.

Každá složka má také své jméno. Když na toto jméno kliknete tak se změní vzhled tohoto jména – jméno se zvýrazní. V pravém panelu, tj.panelu se seznamem položek se pak zobrazí všechny položky, které tato složka obsahuje. V panelu položek jsou obsaženy jak složky tak i soubory.

Toto jméno, včetně celé cesty, je také uloženo v archivu a slouží jako informace pro obnovení. Toto jméno ale v případě potřeby můžete změnit a uložit tak složku, popř.celou cestu, pod jiným jménem než jak jí máte ve vašem počítači. Při této změně si však dejte pozor, aby nebylo stejné jméno použito dvakrát, protože by pak při obnovení nemohl Archivační Průzkumník soubory se stejným jménem rozlišit. Postup, jak změnit jméno složky, popř.změnit cestu naleznete v nápovědě k programu.

Panel složek nemusíte používat. Pokud vám více vyhovuje práce bez tohoto panelu, můžete ho skrýt a pracovat bez něj.

Archivační Průzkumník 3 - 10


Page 16

 Archivace

Panel Položek

V panelu položek jsou zobrazeny všechny položky vybrané složky. Jsou zde obsaženy soubory, ale také složky. Podobně jako v panelu složek je u každé položky, kterou lze archivovat čtvereček, který označuje její stav:

Značka | Popis
 | Položka není vybrána. To znamená, že soubor nebo složka nebude archivována.
 | Položka je vybrána. To znamená, že soubor bude archivován. U složky to znamená že budou archivovány všechny její soubory a složky v ní obsažené.
 | Složka je částečně vybrána. Tento příznak se může vyskytovat jen u složky a znamená, že se budou archivovat jen některé položky této složky.

Změnu stavu výběru složky změníte kliknutím na tento čtvereček. Po kliknutí se změní jeho vzhled podle toho k jaké změně došlo. Podobně jako u složek se jméno položky, tj.souboru nebo složky použije i pro archivaci. Toto jméno lze i zde změnit a archivovat tak soubor nebo složku pod jiným jménem, než pod jakým jí máte uloženu ve vašem počítači. Postup, jak změnit jméno složky nebo souboru naleznete v nápovědě. Po změně jména pak toto nové jméno, můžete vidět ve stavovém panelu.

Panel položek si můžete upravit podle potřeby. Lze změnit pořadí a viditelnost sloupků. Také lze snadno změnit třídění položek. Pouze klikněte na titulek příslušného sloupku a položky se přetřídí nejprve vzestupně a když kliknete opět, tak sestupně, atd.

Stavový panel

Stavový panel je ve spodní části obrazovky. Jsou v něm vidět další informace.

3 - 11 Archivační Průzkumník


Page 17

 Archivace

Rozhodovací strom

Soubory můžete archivovat několika druhy formátů. Jaký formát použijete, si můžete vybrat z nabízeného seznamu. K dispozici však máte i rozhodovací strom, který vám s výběrem může pomoci:

Archivační Průzkumník 3 - 12


Page 18

 Archivace

K dispozici máte několik kritérií. Každé kritérium specifikuje různou vhodnost pro ten který formát(tuto vhodnost můžete změnit po kliknutí na tlačítko Položka a pak Upravit). Pomocí tlačítek Důležitost a + popř. -, nastavíte důležitost pro kritérium, které vás zajímá. Pokud je vám nějaké kritérium lhostejné, dáte mu žádnou váhu, tzn.nepřidělíte mu žádný černý obdélníček. Čím je pro vás dané kritérium důležitější, tím mu dáte větší důležitost(více černých obdélníčků). Po nastavení všech kritérií stisknete tlačítko Doporučit. Okno po tomto příkazu vyhodnotí jednotlivá kritéria a na základě toho pak přiřadí jednotlivým položkám v Seznamu formátů hvězdičky. Čím více hvězdiček, tím více formát vyhovuje kritériím. Vy pak jen vyberete (zvýrazníte) formát, který chcete použít a kliknete na OK. Tím je formát vybrán.

Změna archivačního jména

Soubory se do archivu standardně ukládají se jmény, jenž odpovídají jejich umístění ve vašem počítači. Někdy je ale vhodné uložit soubor do archivu pod jiným jménem, popřípadě s jinou cestou. To je vhodné v případech, když chcete předat soubory z vašeho počítače někomu jinému a chcete mu nabídnout jiné rozmístění, popř.pojmenování souborů, než je ve vašem počítači.

3 - 13 Archivační Průzkumník


Page 19

 Archivace

Odstranění cesty

Často se změna archivačního jména použije v případě, když chcete, aby se soubory uložily do archivu bez počáteční cesty. Taková změna je jednoduchá a rychlá. Nejprve vyberete složku v panelu Složky. Pak kliknete v menu na Archivovat Jako. Zobrazí se například tento dialog:

V tomto dialogu nyní stačí jen kliknout na Vyjmout Vše a pak na OK a všechny složky v cestě budou odstraněny. Soubory, jejichž plná specifikace jména obsahuje Program Files\Amedea\Archivační Průzkumník se o tento text zkrátí a při zpětném obnovení se neobjeví.

Úprava jména

Občas není vhodné odstranit celou cestu. Někdy chcete jen odstranit jednu nebo více složek, popř. jen některou složku, popř.jméno souboru změnit. V tom případě nekliknete na Odstranit Vše, ale kliknete na jiné tlačítko, podle toho, co potřebujete udělat.

Tímto způsobem lze například vytvořit zcela jiné uspořádání složek, než jaké je ve vašem počítači.

Archivační Průzkumník 3 - 14


Page 20

 Archivace

Obnovení původní složky

Později, po změně cesty nebo jména se můžete vrátit k původnímu jménu jednoduše kliknutím na Obnovit, popř.můžete zaškrtnout pole Po archivaci použít originální cestu.

Použití Zástupců

Pro usnadnění práce s archivací si můžete vytvořit Zástupce. Zástupce způsobí to, že když na něj kliknete, tak se, podle nastavení, spustí Archivační Průzkumník a ihned se otevře příslušná archivační výčetka nebo se okamžitě vykoná archivace.

Vytvoření Zástupce

Zástupce můžete vytvořit pouze na uloženou archivační výčetku. Po zadání příkazu k vytvoření zástupce(postup naleznete v on-line nápovědě) se zobrazí toto okno:

Po kliknutí na OK se zástupce vytvoří.

3 - 15 Archivační Průzkumník


Page 21

 Archivace

Umístění Zástupce

Zástupce můžete umístit na místo podle potřeby. Lze ho umístit do Start menu, na pracovní plochu apod. Když ho umístíte na pracovní plochu můžete např. zálohy souborů spouštět z pracovní plochy. Někdy je ale vhodnější si ho umístit do Start menu. Umístění zástupce specifikujete v oblasti s názvem Zástupce uložit do. Nejprve se vybere příslušná počáteční složka, tzn.zda to bude pracovní plocha, menu apod., a pak můžete specifikovat umístění Zástupce v této složce.

Naplánování archivace

Občas bývá výhodné archivaci naplánovat na nějaký vhodnější čas. Například když potřebujete vytvořit záložní kopie vašich souborů, tak tyto zálohy je dobré provádět v době kdy se soubory, které chcete zálohovat nebudete pracovat. Nebo chcete provést nějakou větší archivaci a běh Archivačního Průzkumníka by vás zdržoval v práci, apod. V takových případech je vhodné archivaci naplánovat na nějakou vhodnější dobu.

Naplánování úloh

K naplánování archivace používá Archivační Průzkumník Naplánování úloh, které je volitelnou součástí Windows. Z tohoto důvodu je možno použít plánování archivace pouze tehdy, když máte Naplánování úloh nainstalováno. Pokud nevíte, zda máte Naplánování úloh nainstalováno, tak to nevadí. V případě, že se rozhodnete naplánovat archivaci, tak Archivační Průzkumník vždy nejprve zjistí zda je Naplánování úloh nainstalováno. Součásti Naplánování úloh pak můžete v případě potřeby doinstalovat z vašich instalačních médií k systému Windows.

Jak naplánovat archivaci

Můžete naplánovat pouze uloženou(na disk) archivační výčetku. Pokud máte archivační výčetku uloženu, pak Archivační Průzkumník povolí vykonat příkaz Plánování. Po jeho provedení(viz. on-line nápověda) se zobrazí takovéto okno:

Archivační Průzkumník 3 - 16


Page 22

 Archivace

V tomto okně vidíte všechny naplánované úlohy ve Windows(nejen plánované z Archivačního Průzkumníka). Kliknutím na příslušné tlačítko pak můžete přidat, odstranit nebo upravit vlastnosti příslušné položky.

3 - 17 Archivační Průzkumník


Page 23

 Obnovení

Obnovení

Onovení souborů z archivů

K obnovení souborů z archivu můžete použít stránku Obnovení Archivačního Průzkumníka. Stránka se podobá stránce Archivace a podobně se s ní i pracuje. Na rozdíl od Archivace jsou v panelu složek zobrazeny ne složky vašeho počítače, ale složky souborů z archivu. V panelu položek pak jsou vidět soubory příslušné vybrané složky.

Archivační Průzkumník 4 - 1


Page 24

 Obnovení

Panel menu

V panelu menu jsou obsaženy všechny dostupné příkazy Obnovení.

4 - 2 Archivační Průzkumník


Page 25

 Obnovení

Panel nástrojů

V panelu nástrojů jsou umístěny nejpoužívanější tlačítka. Tento panel si můžete upravit podle svých potřeb. V nápovědě se dozvíte konkrétní postup.

Panel možností

V panelu možností je obsaženo pole pro změnu cesty, a popřípadě i jména pod jakým se archivovaný soubor do vašeho počítače obnoví. Jak lze změnit cestu a nebo i jméno archivovaného souboru se opět dozvíte z nápovědy.

Info panel

Info panel vás informuje o stránce v níž právě pracujete. V tomto případě to je stránka Obnovení. Tento panel také můžete využít k přepínání mezi touto stránkou a stránkou Archivace. Pouze na něj kliknete. Nezáleží na které místo.

Panel složek

V panelu složek jsou obsaženy všechny složky, uložené v archivu a které obsahují nějaké soubory. U složky, kterou lze archivovat, je malý čtvereček. Tento čtvereček signalizuje, zda se složka bude a nebo nebude archivovat. Čtvereček může vypadat takto:

Značka | Popis
 | Složka není vybrána. To znamená, že žádný soubor, obsažený v této složce nebude obnovován.
 | Složka je vybrána. To znamená, že všechny soubory, včetně i všech složek, které jsou obsaženy v této složce budou obnoveny.
 | Složka je částečně vybrána. To znamená, že jsou vybrány pouze některé soubory nebo složky, které tato složka obsahuje

Změnu stavu výběru složky, změníte kliknutím na tento čtvereček. Po kliknutí se změní jeho vzhled podle toho k jaké změně došlo.

Archivační Průzkumník 4 - 3


Page 26

 Obnovení

U složky také může být čtvereček se znaménkem plus nebo mínus. Tento čtvereček indikuje a umožňuje změnit zobrazení složek:

Značka | Popis
 | Znamená, že složka obsahuje další složky. Pokud kliknete na tuto značku tak se tyto složky zobrazí.
 | Znamená, že složka obsahuje další složky. Tyto složky jsou právě viditelné. Když kliknete na tuto značku, tak se tyto složky skryjí.

Jestliže u složky není ani jedna z těchto značek, tak to znamená, že složka neobsahuje žádné další složky.

Každá složka má také své jméno. Když na toto jméno kliknete tak se změní vzhled tohoto jména – jméno se zvýrazní. V pravém panelu, tj.panelu se seznamem položek se pak zobrazí všechny položky, které tato složka obsahuje. V panelu položek jsou obsaženy soubory této vybrané složky.

Toto jméno, včetně celé cesty, a slouží jako informace pro obnovení. Toto jméno ale v případě potřeby můžete změnit a obnovit tak složku, popř.celou cestu, pod jiným jménem, než pod jakým je uložena v archivu. Postup, jak změnit jméno složky, popř.změnit cestu naleznete v nápovědě k programu.

Panel Položek

V panelu položek jsou zobrazeny všechny soubory vybrané složky. Podobně jako v panelu složek je u každé položky, kterou lze archivovat čtvereček, který označuje její stav:

Značka | Popis
 | Soubor není vybrán. To znamená, že soubor nebude obnovován.
 | Soubor je vybrán. To znamená, že tento soubor bude obnoven.

Změnu stavu výběru složky, změníte kliknutím na tento čtvereček. Po kliknutí se změní jeho vzhled podle toho k jaké změně došlo. Podobně jako u složek se jméno položky, tj.souboru nebo složky použije i pro obnovení. Toto jméno lze i zde změnit a obnovit tak soubor pod jiným jménem, než pod jakým je uložen v archivu. Postup, jak změnit jméno složky nebo souboru naleznete v nápovědě.

4 - 4 Archivační Průzkumník


Page 26

 Obnovení

Po změně jména pak toto nové jméno, můžete vidět v Panelu možností. Původní cestu a jméno archivovaného souboru můžete vidět ve stavovém panelu.

Panel položek si můžete upravit podle potřeby. Lze změnit pořadí a viditelnost sloupků. Také lze snadno změnit třídění položek. Pouze klikněte na titulek příslušného sloupku a položky se přetřídí nejprve vzestupně a když kliknete opět, tak sestupně.

Stavový panel

Stavový panel je ve spodní části obrazovky. Jsou v něm vidět další informace.

Změna jména souboru

Někdy bývá vhodné změnit složku nebo i jméno souboru, pod kterým se má soubor z archivu obnovit.

To je vhodné v případech, když nechcete přepsat soubory ve vašem počítači soubory z archivu.

Archivační Průzkumník 4 - 5


Page 28

 Obnovení

Cestu, a popřípadě i jméno souboru můžete změnit snadno příkazem Kam obnovit. Po zadání tohoto příkazu se zobrazí takovéto okno:

V tomto okně pak jen v poli Obnovit do složky změníte příslušnou cestu a popřípadě i jméno souboru. K nalezení, nebo založení vhodné cesty můžete použít tlačítko Najít. Jestliže se chcete vrátit k původní cestě a jménu souboru, tak stačí jen zaškrtnout políčko Pro obnovení použít cestu z archivu.

4 - 6 Archivační Průzkumník


Page 29

 Příkazová řádka

Příkazová řádka

Spouštění z příkazové řádky

Archivačního Průzkumníka můžete pouštět také z příkazové řádky. Při tomto spouštění máte k dispozici několik parametrů, kterými můžete Archivačního Průzkumníka do určité míry řídit.

Tento způsob spuštění lze použít v dávkových souborech, při vytváření Zástupců, položky Plánovače úloh, apod.

Přehled parametrů

Parametr | Popis
-s | Archivace nebo obnovení se spustí "potichu". To znamená nezobrazí se klasické okno Archivačního Průzkumníka, ale archivace resp.obnovení souborů se okamžitě provede.
<jméno souboru> | Otevře se příslušný soubor. Přičemž o tom, zda se jedná o archivační výčetku nebo archiv se rozhodne podle přípony tohoto souboru.
-a:<jméno souboru> | Soubor se otevře bez ohledu na příponu jako archivační výčetka.
-r:<jméno souboru> | Soubor se otevře bez ohledu na příponu jako archiv.
-t:<cesta> | Pro obnovení použít specifikovanou cestu
-c | Nepotvrzovat cestu pro obnovení

Jména souborů musí obsahovat i příponu.

Archivační Průzkumník 5 - 1


Page 30

 Příkazová řádka

Pokud jméno souboru obsahuje mezery nebo středník, tak musí být uvozeno v uvozovkách, tj. mezi znaky " a ".

Jednotlivé parametry jsou odděleny, tak jak je obvyklé, mezerou, popř.čárkou. Parametry mohou být uvedeny v libovolném pořadí. Pokud uvedete několik parametrů s názvem souboru, např. <jméno souboru> a pak -a:<jméno souboru>, tak platí pouze jeden parametr a to ten, který byl uveden jako poslední.

V parametru -t: lze uvést přímo cestu, např."c:\Program Files\Moje Soubory". Při specifikaci cesty lze ale také použít předdefinované názvy standardních cest Windows, které se nastaví podle nastavení počítače. Možné jsou tyto hodnoty:

Označení | Popis
$(Win) | Cesta windows. Ve Windows 95 nebo Windows 98 to je standardně c:\windows. Ve Windows NT, 2000 to je standardně c:\winnt.
$(Sys) | Systémová složka windows. Typicky c:\windows\system, ev.c:\winnt\system
(ProgrFiles) | Složka "Program Files", tj. složka do níž se standardně instalují programy.
$(Common) | Složka Common files. Typicky podsložka složky Program Files, tj. "c:\Program Files\Common Files"
$(Temp) | Složka do níž se umísťují dočasné soubory. Typicky c:\windows\temp, ev.c:\temp, apod.

Příklady

Příklady spuštění Archivačního Průzkumníka z příkazové řádky:

ArcExpl Týdenní.cao

nebo v případě názvu s mezerou např.

ArcExpl "Týdenní zálohy.cao"
5 - 2 Archivační Průzkumník


Page 31

 Příkazová řádka

spustí Archivačního Průzkumníka a ihned otevře archivační výčetku Týdenní.cao event.Týdenní zálohy.cao.

ArcExpl –a:Týdenní.cao

stejné jako v předchozím příkladě.

ArcExpl –s Týdenní.cao

nebo

ArcExpl –s –a:Týdenní.cao

spustí Archivačního Průzkumníka, ale jeho okno se nezobrazí. Místo toho se okamžitě vykoná archivace podle archivační výčetky Týdenní.cao.

ArcExpl Týdenní.zip

také

ArcExpl Týdenní.cab

popř.

ArcExpl –r:Týdenní.cao

nebo v případě dlouhého názvu

ArcExpl "Týdenní zálohy.zip"

také

ArcExpl "Týdenní zálohy.cab"

popř.

ArcExpl –r:"Týdenní zálohy.cao"

Všechny tyto příkazy spustí Archivačního Průzkumníka a automaticky přejdou na stránku Obnovení a otevřou archiv Týdenní popř.Týdenní zálohy. V případě, že k příkazu přidáte parametr –s, např. Archivační Průzkumník 5 - 3


Page 32

 Příkazová řádka
ArcExpl –s Týdenní.zip

nebo

ArcExpl –s -a:Týdenní.cab

tak se výše uvedený archiv také okamžitě obnoví(před obnovením vás ještě vyzve ke specifikaci složky do níž se má archiv obnovit).

V případě, že chcete obnovit soubory do složky c:\data s tím, že chcete potvrdit, popř.změnit tuto složku, tak zadáte:

ArcExpl –s -a:NovaData.cab -t:"c:\data"

Pokud chcete obnovit data do složky data v podsložce Program Files, tak zadáte:

ArcExpl –s -a:NovaData.cab -t:"$(ProgrFiles)\data"

Pokud nechcete, aby se zobrazilo dialogové okno pro potvrzení, popř.změnu složky, tak zapíšete:

ArcExpl –s -a:NovaData.cab -t:"c:\data" -c
5 - 4 Archivační Průzkumník


Cover Odd

Copyright ©1999 amedea.cz. Všechna práva vyhrazena.

Internet: http://www.amedea.cz/arcexpl/cze


Cover Even

 Příručka

Archivační Průzkumník

pro Windows


Print Cover

Tisk obálky příručky

Nyní vytiskete obálku příručky.

Obálku vytiskněte tímto postupem:

  • Do tiskárny vložte tlustější papír.
  • Klikněte na tuto položku: Po kliknutí se zobrazí malé okno jen s tlačítky pro tisk a nastavení tiskárny.
  • Tuto dvojstranu vytiskněte. Dvojstranu vytisknete jednoduše tak, že v zobrazeném okně jen kliknete na tlačítko Tisk. Pokud potřebujete, můžete ještě před tím nastavit tiskárnu. Tiskárna by měla být nastavena na tisk na papír formátu A4 a tisk "naležato".
  • Zavřete zobrazené okno. Toto okno zavřete tak, že kliknete na tlačítko s křížkem [image].
  • Dokončete výrobu příručky kliknutím na tlačítko Pokračovat.


Face printing

Tisk "líců" příručky

Nyní vytisknete dvojstránky, které obsahují "lícové" strany.

Stránky vytiskněte tímto postupem:

  • Vyberte si dvojstranu, kterou chcete vytisknout ze seznamu dole a klikněte na ní myší. Po kliknutí se zobrazí malé okno jen s tlačítky pro tisk a nastavení tiskárny.
  • Tuto dvojstranu vytiskněte. Dvojstranu vytisknete jednoduše tak, že v zobrazeném okně jen kliknete na tlačítko Tisk. Pokud potřebujete, můžete ještě před tím nastavit tiskárnu. Tiskárna by měla být nastavena na tisk na papír formátu A4 a tisk "naležato".
  • Zavřete zobrazené okno. Toto okno zavřete tak, že kliknete na tlačítko s křížkem [image].
  • Jestliže ještě nejsou vytištěny všechny dvojstrany opakujte kroky i až iii. Pokud jsou již všechny dvojstrany vytištěny přejděte na tisk rubových dvojstran kliknutím na tlačítko Pokračovat.

Pokud nepotřebujete příliš šetřit papírem můžete tyto stránky vytisknout také najednou tak, že vytisknete tuto stránku s tím, že tiskárnu nastavíte tak jako v předchozím případě, tzn. tisknout na papír formátu A4 naležato, ale ještě navíc zaškrtněte políčko Vytisknout všechny odkazované dokumenty. Takto se vytiskne(zbytečně) tato strana, ale současně s ní se vytisknou i strany na něž se v této stránce odkazuje, tzn. všechny lícové dvojstrany.


Printing finished

Dokončení příručky

V tomto kroku se provede dokončení příručky. To znamená svázání do podoby příručky a následné její oříznutí.

Stránky si nejprve uspořádejte tak, aby stránky tvořily příručku.

Pak si můřete naznačit rozměry stránky. Stránky jsou navrženy na šířku 128mm a výšku 184mm. Protože pracujete s dvojstranou, označte si její střed a pak její rozměry tzn. kolem 256mm a 184mm na výšku.

Potom stránky můžete vhodným způsobem svázat.

Nyní se mohou stránky ohnout na polovinu tak, aby vytvořily příručku.

Nakonec můžete stránky oříznou na uvedený rozměr(128x164mm).


Reverse

Tisk "rubů" příručky

Nyní vytisknete dvojstránky, které obsahují "rubové" strany. Aby se stránky vytiskly ve správném pořadí je potřeba více opatrnosti.

Před tím, než začnete tisknout dvojstrany, vyjměte již potištěné papíry(lícové - z předchozího kroku) z tiskárny, a znovu je vložte do tiskárny tak, aby tiskárna tiskla na jejich druhou stranu(rubovou). Zde je potřeba dávat pozor v prvé řadě na to, v jakém pořadí se budou dvojstrany tisknout. Jestliže se jako první dvojstrana bude tisknout lícová dvojstrana naposledy vytištěná, tiskněte dvojstrany v seznamu dole v pořadí od shora dolů, v druhém případě tyto dvojstrany tiskněte v pořadí opačném, tj. od zdola nahoru.

Stránky vytiskněte obdobným postupem, jako v předchozím kroku, tj.:

  • Vyberte si dvojstranu, kterou chcete vytisknout ze seznamu dole a klikněte na ní myší. Po kliknutí se zobrazí malé okno jen s tlačítky pro tisk a nastavení tiskárny.
  • Tuto dvojstranu vytiskněte. Dvojstranu vytisknete jednoduše tak, že v zobrazeném okně jen kliknete na tlačítko Tisk. Pokud potřebujete, můžete ještě před tím nastavit tiskárnu. Tiskárna by měla být nastavena na tisk na papír formátu A4 a tisk "naležato".
  • Zavřete zobrazené okno. Toto okno zavřete tak, že kliknete na tlačítko s křížkem [image].
  • Jestliže ještě nejsou vytištěny všechny Dvojstrany opakujte kroky i až iii. Pokud jsou již všechny dvojstrany vytištěny přejděte na tisk obálky kliknutím na tlačítko Pokračovat.

Pokud nepotřebujete příliš šetřit papírem můžete tyto stránky vytisknout také najednou tak, že vytisknete tuto stránku s tím, že tiskárnu nastavíte tak jako v předchozím případě, tzn. tisknout na papír formátu A4 naležato, ale ještě navíc zaškrtněte políčko Vytisknout všechny odkazované dokumenty. Takto se vytiskne(zbytečně) tato strana, ale současně s ní se vytisknou i strany na něž se v této stránce odkazuje, tzn. všechny rubové strany. Tyto strany se vytisknou v sestupném pořadí, tzn. nejprve se bude tisknout na rub strany 15-18, pak 13-20 atd.


Tisk

Tisk příručky

Aby se stránky vytiskly ve tvaru příručky, je potřeba je vhodně uspořádat. Příručka se tiskne na papír A4 z obou stran. K vytištění příručky použijte tento postup výroby:

Postup výroby příručky:

  • Vytiskne se jedna strana("líc") pro určené stránky
  • Vytiskne se druhá strana("rub") pro určené stránky
  • Vytiskne se obálka
  • Stránky se svážou do podoby příručky