
Phone Dialer Pro

      Phone Dialer Pro is designed as a substitute for the Windows95/98 Phone Dialer. It's the ultimate 
dialer which comes with popular features, such as different users profiles, speed dials, extended 
address book capacity, automatic redialing if the phone line is busy and the ability to display caller 
name and phone number (Caller ID).
It has an easily accessible phone book with subjected or indexed entries and the ability to hide phone 
dialer's dialing pad so only speed dials can be seen.

It also has special features that are directed to different groups of users:

-For the businessmen and professionals; 
Phone Dialer Pro can accept very long dialing sequences to accommodate calling cards, passwords and
extension numbers.
Pop-up Memo Pad displays relevant information and allows to take fast notes, dated and time stamped.

-For travellers;
Phone Dialer Pro will always recognize international and long distance calls regardless of the 
originating call site (foreign country or another city) and will act appropriately, ie. by using predefined 
calling cards and/or additional prefixes to place a call.

-For software developers; 
It can act as the Dial Engine by accepting command line parameters as a dialing string, keeping
itself in minimized state and being always ready to place a call.

-For the investors and people using automatic banking systems; 
When the connection is made, a small window will pop-up on the screen, containing all the information 
previously recorded: your account no., password and other relevant information.    The extra memo 
space is time stamped and allows the users to input their own information, such as: the name of the 
person the user spoke to, a transaction confirmation number or anything the user may need as 
reference.

-For golf players, who often have a hard time calling to book a tee time; 
It will redial busy signals up to 999 times and when connected it will alert the user by playing a 
customizable sound through the computer's speakers. 

-For the power users;
To automate the dialing process Phone Dialer Pro will accept special dialing characters:
 "," ( 2 seconds pause),    "$" (wait-for-billing-tone),    "@" (wait-for-quiet) and "W" (wait-for-dialtone).

-For small businesses;
It keeps detailed logs for all outgoing and incoming calls. The logs are self maintained; the user has 
option to specify for how many days it wants to keep the log entries.

-For Multi-Users;
Phone Dialer Pro can maintain multiple profiles, each has its own address book with speed dials and 
preserves user's preferrences. 

-For users without modems;
Phone Dialer Pro can dial numbers direct to the phone receiver through the computer's speakers.

Note
      ·Phone Dialer Pro is NOT an Internet dialer.





Phone Dialer Pro (R) Copyright    © 1998-2000    Jack Kozlowski
All rights reserved.

License Agreement

You should carefully read the following terms and conditions before using this software.    Your use of 
any version of Phone Dialer Pro (R)    indicates your acceptance of this license agreement and warranty.
For additional license information specific to use and/or distribution of the Evaluation Version of Phone 
Dialer Pro see the section titled    Evaluation License. No component part of any version of Phone Dialer Pro
may be distributed individually, disassembled, copied, reverse engineered, or altered in any form.

Registered Version

One registered copy of Phone Dialer Pro may either be used by a single person who uses the software 
personally on one or more computers, or installed on a single workstation used nonsimultaneously by 
multiple people, but not both.

You may access the registered version of Phone Dialer Pro through a network, provided that you have 
obtained individual licenses for the software covering all workstations that will access the software 
through the network.    For instance, if 7 different workstations will access Phone Dialer Pro on the 
network, each workstation must have its own Phone Dialer Pro license, regardless of whether they use 
Phone Dialer Pro at different times or concurrently.

Governing Law

This agreement shall be governed by the laws of the Province of Ontario, Canada.

Disclaimer of Warranty

THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD "AS IS" AND WITHOUT WARRANTIES AS TO 
PERFORMANCE OR MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED.
Because of the various hardware and software environments into which Phone Dialer Pro may be put, 
NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED.

Good data processing procedure dictates that any program be thoroughly tested with non-critical data 
before relying on it.    The user must assume the entire risk of using the program.    ANY LIABILITY OF 
THE SELLER WILL BE LIMITED EXCLUSIVELY TO PRODUCT REPLACEMENT OR REFUND OF PURCHASE 
PRICE.





System Requirements

-486 or better processor 
-4MB of RAM or more
-Windows 95/98 or Windows NT

Additional Requirements for Call ID

-voice modem with Call ID capability
-phone line subscribed to the Call ID service
-Windows95/98 only (not WindowsNT)





Dialing a number manually

Make sure your modem and modem cables are connected correctly. 
A telephone must be connected to the modem.
Type in the number or choose the number from display window pull-down list. 
Click Dial. 
Note 
        · The pull-down list holds the most recent dialed numbers.
        · If you dial the same number frequently, you can store it on a speed-dial button. 

See also:
Programming Speed Dial buttons





Phone number formats

Phone Dialer Pro will accept any combination of numbers and letters as a dialing string, as long as this 
combination constitues real dialing sequence, like in shown below example:

1-800-444-PIZZA

and translate them into dialable string.

Also, Phone Dialer Pro will accept the phone numbers in any format the user likes to store his/her 
phone numbers. The phone numbers can be punctuated by brackets, periods or dashes and any 
combination of them,    like in the examples below:

    (###) ###-####
        #############
        ##.###.####
 Note 
      ·The characters: "," "*" and "#" are reserved dialable characters so should only be used when 
needed.      
      ·Choosing    "Ignore all settings in Dialing Properties" in Tools/Options/Expert tab will allow user to 
create customized dialing string using other special characters as: "$" (wait-for-billing-
tone), "@" (wait-for-quiet) and "W" (wait-for-dialtone).

See also:
How to insert additional information in a phone number 
How to insert a pause in a phone number





Configuring a modem

In normal situation there is no need to manually configure a modem. Windows 95/98 or Windows NT 
configures the modem during the modem's initial installation.
However, if such need occurs, click on Modem Properties in the Advanced Options window, which 
can be accessed from the Tools menu and adjust the selected modem's configuration accordingly.

Note 
       · In case your modem does not work properly or does not work at all, check for any interrupt 
conflicts in the Windows Device Manager, and/or refer to the Windows Troubleshooter.

See also:
Choosing a modem
How to add, remove and test modems





Selecting a startup mode

You can customize the way Phone Dialer Pro starts up.

The available settings are:
- Hiding/Showing the Dialing Pad
- Index or Subject mode
- Showing icon in taskbar or system tray

Note 
       · Different profiles can have their own custom startup modes.





Hiding/Showing the Dialing Pad

For a user who does not use the Dialing Pad very often, there is an option to start Phone Dialer Pro with
the Dialing Pad hidden.To select a starting mode, go to Options in the Tools menu and check one which 
suits your needs.

Note
        · It is possible to show and hide the Dialing Pad by clicking on the small button located at the 
bottom of the Speed Dials frame or choose it from the View menu.





Index or Subject mode

Index mode tabs are displayed as consecutive alphabetical letters.
Subject mode tabs are customizable by the user by being able to be named and rearranged.
To set Index or Subject startup mode, go to Options in the Tools menu and check the mode you want to
startup in. 

Note 
        · The default startup setting is Index mode.





Showing icon in taskbar or system tray

To show the Phone Dialer Pro icon in the System Tray, go to Options in the Tools menu, and check 
"Show icon in the system tray".

Note 
       · Having checked this option, the minimized Phone Dialer Pro window will not be shown in the 
taskbar.





Choosing a modem

Phone Dialer Pro will detect all installed modems in the system, the default modem is the first installed
modem. To specify another modem, go to Options in the Tools menu, and click on the Advanced tab.    
Then select a modem from the pull down menu.

See also:
Configuring a modem
How to add, remove and test modems





Adding, removing and testing modems

Phone Dialer Pro will detect all installed modems in the system, the default modem is the first installed
modem.
To add/remove/test modems, go to Options, and click on the Advanced tab. Then click on the System 
Modems button.    For the installation of a new modem, consult your modem manual.

Note 
       · In case your modem does not work properly or does not work at all, check for any interrupt 
conflicts in the Windows Device Manager, and refer to the Windows Troubleshooter.

See also:
Choosing a modem
Configuring a modem





To set up a new location 

On the Tools menu, click Dialing Properties. 
Click New to set up a new . Type the name of the new location in I am dialing from. 
Click the settings that match the way you dial from this location. 

Notes 
      · If an area you are dialing has multiple area codes, click Area Code Rules to specify how to call a 
location.    





To select tone or pulse dialing
 
On the Tools menu, click Dialing Properties. 
Under When dialing from here, select the Tone dial or Pulse dial option.

Note
      ·The default setting is Tone dial.





Selecting a calling card
 
On the Tools menu, click Dialing Properties. 
Under When dialing from here, select the For long distance calls, use this calling card check 
box. 
Click the list box to choose the calling card you want to use. 

Note 
      ·To set up a new calling card, click Calling Card, then click New.





To change the location you are calling from 

On the Tools menu, click Dialing Properties. 
Click the you are dialing from. 
Click the settings that match the way you dial from this location. 

Note 
      ·You can also set up a new location by clicking New.





Viewing Logged Calls
Select "Outgoing Calls Log"    or "Incoming Calls Log" from the View menu.

Note 
       · To change between ascending and descending order, click on the the selected column header.

See also:
How to maintain your logs
Printing Logged Calls
Editing Logged Calls





Printing Logged Calls

Select Print from either the main File menu, or the log window's File menu.

Note
       · To print part of the Logged Calls record, highlight and copy the section to print    Next, paste to 
a word processing program such as Notepad and print from it.

See also:
How to maintain your logs
Viewing Logged Calls
Editing Logged Calls





Editing Logged Calls

Cutting/Copying:      right click on it or select it and open the Edit menu and choose "Cut" or "Copy".
Deleting:    right click on it or select it and open the Edit menu and choose "Delete".

Note 
        · The changes to the Logged Calls records will not become permanent until being saved.To save,
click on Save in the Logged Calls File menu.

See also:
How to maintain your logs
Printing Logged Calls
Viewing Logged Calls





Using the Memo Pad

Memo Pad will appear    when a phone connection is confirmed by the user picking up the phone 
receiver and clicking on the "OK" button.
Memo Pad consists of 2 sections: the Log section and the scratch pad section.

Log section:
The Log section (upper darker part of Memo Pad) holds all the records up todate.
To protect the log area from accidental, unwanted changes, the log section is locked.
To unlock click on Edit Log button and all editing/deleting functions become available.

Scratch pad section:
The Scratch pad section (lower white part of Memo Pad) is Date and Time stamped.
This area is designed for the user to enter his/her own memos.
When finished click on the Add to Log button to enter the new entry in the log. Then click            
OK to save the new log.

 
Note 
       · There is no need to unlock the Log section to add new entry.
        · After a memo is added to the log, the OK button must be pressed to save the new log. 
        · To access the Memo Pad at any time click on the Edit menu, then select the Edit Button and 
choose the Speed Dial button and click the Edit Memo button or right click on the Speed Dial button 
and choose Edit Memo.
       · To speed up loading it is a good idea to maintain your Memo Pads by periodically deleting the 
outdated entries.

See also:
Memo pad





Registration

Phone Dialer Pro    should be used for evaluation purposes only.    After a reasonable period of time, the 
user is required to register or to delete the program from the user's computer.
To register, submit the Order Form together with the appropriate payment to:

Jack Kozlowski
32 Larstone Ave.,
Toronto, ON M8Z 2N8
Canada

Note
      ·The Order Form can be found in the Phone Dialer Pro folder or in the Start Menu >Programs>Phone
Dialer Pro menu.





Programming Speed Dial buttons

Click on the Edit menu, then select Edit Button and choose the appropriate Speed Dial number or click 
on an empty button or right-click on an empty button, and choose the "Add new entry" command.
Fill in the requested information. 
Click Save or Save and Dial.

See also:
Copying Speed Dial buttons
Editing Speed Dial buttons
Deleting Speed Dial buttons





Copying Speed Dial buttons

Right-click on the Speed Dial button, and choose the "Copy" command.
Next, right-click on the location where you want to copy the Speed Dial to and choose "Paste."

Note
       ·    Pasting a Speed Dial button on a already existing Speed Dial will overwrite it.
        ·    It is possible to copy Speed Dials from one tab mode to another (Index and Subject)
       ·    To copy at once all programmed Speed Dial buttons within a Tab, see Moving a tab into a new 
location
See also:

Programming Speed Dial buttons
Editing Speed Dial buttons
Deleting Speed Dial buttons





Deleting Speed Dial buttons

Right-click on the Speed Dial button, and choose the "Delete" command.
Confirm depletion by clicking OK on the follow up message.

Note
       ·    You cannot undelete once deleted button. All information including underlying Memo Pad will be 
lost.
See also:

Copying Speed Dial buttons
Editing Speed Dial buttons





Editing Speed Dial buttons

Click on the Edit menu, then select Edit Button and choose the appropriate Speed Dial number or 
right-click on the Speed Dial button, and choose the "Edit" command if it is an existing Speed Dial, or 
choose the "Add new entry" command if it is a blank Speed Dial.
Next, input new information or edit the existing one and click "Save" or "Save and Dial." 

Note
       ·    The Speed Dial will not save if a name is not present, a phone number, however is not 
necessary.
See also:

Programming Speed Dial buttons
Copying Speed Dial buttons
Deleting Speed Dial buttons





Creating a new tab

Creating a tab can only be done in Subject mode .
To create a tab, click on a blank tab, or right-click on a    blank tab and choose the "Name this tab" 
command.

See also:
Renaming an existing tab
Moving a tab into a new location
Index or Subject mode





Renaming an existing tab

Renaming a tab can only be done in Subject mode.
To rename a tab, right-click on a named tab and choose the "Edit tab" command.

See also:
Creating a new tab 
Moving a tab into a new location
Index or Subject mode





Moving a tab into a new location

Moving a tab can only be done in Subject mode.
To move a tab, right-click on an existing tab and choose the "Move tab" command.
Next, right-click on the blank tab where you want to paste the tab, and choose "Paste tab."

Note
       · After pasting the tab into the new location, the original tab will be deleted
       · You can only paste into a blank tab
See also:

Renaming an existing tab 
Creating a new tab
Index or Subject mode





Deleting a tab

Deleting a tab can only be done in Subject mode.
To delete a tab, right-click on an existing tab and choose the "Delete tab" command.
Next, confirm depletion by pressing OK on the follow up message.

Note
       · Deleting a tab will cause the Speed Dials within it to be deleted
See also:

Moving a tab into a new location
Renaming an existing tab
Creating a new tab
Index or Subject mode





Speed Dialing

Click on an programmed Speed Dial button.
Phone Dialer will automatically dial the number

Note
      ·To program a Speed Dial button, click on an empty button and fill in the requested information or 
click on the Edit menu, then select Edit Button, and choose the appropriate Speed Dial number.
      ·Speed Dialing is the recommended way of making phone calls.

See also: Speed Dials





How to insert a pause in a phone number

If you have a USRobotics or any Hayes compatible modem you may want to insert Pauses, between 
numbers you dial. This is specially useful, if you are calling a place requiring you to punch in additional 
numbers (for instance, an extension number or account number).
The character for Pause is "," and each "," creates a delay of about 2 seconds.    For example, if you 
want to call your bank (111) 222-3333 and talk to a person at extension number 555 you would dial 
like this:

    (111) 222-3333,,,555

In this example the total delay between connection number and the following extension number is 
about 6 seconds. This delay is neeeded to initilize the connection between both sides.
How many commas you need to insert it depends on that particular connection and after several trials 
you will be able to optimize your dialing.    

See also:
How to insert additional information in a phone number 
How to format phone numbers





Memo Pad

The Memo Pad is an integral part of a programmed Speed Dial button. It will appear when a phone 
connection is confirmed by the user picking up the phone receiver and clicking on the "OK" button.
The Memo Pad is designed to hold records of phone conversations, time-stamping it with each new 
entry.

Note 
        · The Memo Pad will ONLY appear when Speed Dialing.

See also:
Using the Memo pad





Profiles

A profile is a database customized for one or more users.
A profile consists of:

-programmed Speed Dials and attached Memo Pads,
-customized Tabs,
-Logged Calls,
-list of recent dialed phone numbers,
-preferences and configuration options

It is possible to maintain multiple profiles.    Multiple profiles are useful if there is more than one user or
if there is need for customizing another profile.

Note
        · Individual profiles are saved with a ".pdp" extension.
See also: Multiple Profiles





Multiple Profiles

A profile consists of:
-programmed Speed Dials and attached Memo Pads,
-customized Tabs,
-Logged Calls,
-list of recent dialed phone numbers,
-preferences and configuration options

It is possible to maintain multiple profiles.    Multiple profiles are useful if there is more than one user or
if there is need for customizing another profile.

To save a profile, go to the File menu, and choose Save profile.
To create a new profile, go to the File menu, and choose New profile.
To open another profile, go to the File menu, and choose Open profile.
Note 
        · It is possible to have an unlimited amount of profiles.

See also:
Profiles





Logged Calls

Logged Calls provide a record of connected calls, recording following data:
- Name of called upon party (Speed Dialing),
- Phone Number,
- Date and Time of the call

Note
        · Logged Calls will not record unsuccessful attempts to make a call (such as quitting on busy 
signal).
        · Due to the modem limitation the Logged Calls record does not provide time duration of the 
call.
See also:

How to maintain your logs
Printing Logged Calls
Viewing Logged Calls
Editing    Logged Calls





Tabs Modes and Pages

Phone Dialer Pro tabs can be viewed in 2 modes:
    -Indexed Mode
    -Subject Mode

Index Mode contains 26 tabs, alphabetically indexed which cannot be edited in any way.
Subject Mode contains also 26 tabs which can be fully customized by the user.
Each tab holds 83 pages, each page contains 12 Speed Dials.
In total there are 996 Speed Dials per tab.

Note
        · By using different profiles, the user is able to create an unlimited amount of databases.
See also:

Multiple Profiles
Index or Subject mode

Also check the Customizing tabs section under How to Use.





Speed Dials

Speed Dials provide the best solution to store phone numbers and are the fastest way to make a call.
The programmed Speed Dial button can accomodate a 19 character long name and a 256 character 
long dialing string.
Each Speed Dial has a dedicated Memo pad, making it very easy for the user to create a record of a 
call and to maintain data related to that particular phone number.

Note 
        · The Memo Pad will ONLY appear when making a call using Speed Dialing.
See also:

Using the Memo pad
Speed Dialing





Dialing Pad

The Dialing Pad provides the user with the ability to insert and dial the number manually.
Also, by pulling down the Display window, the user can select one of recently dialed phone numbers.
The Dialing Pad can be hidden from view by clicking on Hide Dialing Pad button or selecting it from 
the View menu.

Note 
        · To fully utilize Phone Dialer Pro's potential, the recommended way of making a call is with 
Speed Dialing.
See also:

Hiding/Showing the Dialing Pad
Dialing a number manually





See the section titled    Licence Agreement for the full license agreement.    

Evaluation and Registration

Phone Dialer Pro is not free software. You are hereby licensed to use the Evaluation Version of Phone 
Dialer Pro, without charge, for a limited time evaluation period of 21 days. Purchase of the Full Version 
of Phone Dialer Pro is mandatory for use extending beyond the evaluation period. Use of the Evaluation
version of Phone Dialer Pro after the evaluation period is expired, constitutes a violation of this license 
and of Canada and international copyright laws.

Distribution

Provided that you verify that you are distributing the unregistered version (select About from the 
Phone Dialer Pro Help menu to check) you are hereby licensed to make unmodified copies of the 
Evaluation Version of Phone Dialer Pro software and documentation for the purpose of distributing it via
electronic means: Web, FTP, Bulletin Board Systems, Electronic Services. You are specifically prohibited
from charging, or requesting donations, for any such copies, however made. You are also prohibited 
from distributing the software and/or documentation with other products or services (commercial or 
otherwise) without obtaining prior written permission, with no exceptions.
This software may NOT be distributed on CD-ROM without the expressed written consent of the author.

Copyright © 1998-2000    Jack Kozlowski





GENERAL tab

Options

Load Phone Dialer Pro at Windows startup
-allows dialer to be loaded during Windows initialization

Start Dialer in the Subject mode
-dialer is initialized with Speed Dials user customized Tabs

Start Dialer in the Index mode
-dialer is initialized with Speed Dials in alphabetically predefined Tabs

Show program's icon in the System Tray
-this is a convenient way to indicate that Dialer is ready to receive incoming calls and to make 
outgoing calls
-when the dialer is minimized, it saves taskbar space for other programs

Show Dialing Pad at Phone Dialer startup 
-displays compact sized Phone Dialer when using only Speed Dials to dial

Play sound when:

Connected after redialing busy line
-plays sound "Connect.wav" to alert user about the connected call after conquering a busy line.
This useful feature was requested by the golf players who have hard time to call to reserve tee time 
while simultaneously helping their spouses in the kitchen..

Reached the end of redials
-plays sound "EndDial.wav" to alert user about the end of attempts to conquer busy line. 

Receiving incoming call
-plays sound "Incoming.wav" when Call ID option is enabled

Enable Automatic Redial:

-allows user to set the automatic redial up to 999 times in user predefined time intervals
Default is 3 redials in 2 minutes intervals.





ADVANCED tab

Dial using modem:

-this window shows the name of installed modem.
If there is more then one modem installed, user should select the wanted modem from the pull down 
list. 

There is no need to set Modem properties under normal circumstances. 
When troubleshooting please consult modem's manual.

Dial without modem:

-this option allows the user to dial out without using modem but instead using the computer's 
speakers.
See: How to dial without using modem 

Disallow use of Calling Card for local calls

-when selecting use of Calling Cards in Dialing Properties Windows insist for using Calling Card regardless
whether it is local or long distance call. 
This option allows the user to disable use of Calling Card for the local calls.

Keep Outgoing Logged Calls for: xx days

-Dialer will delete from the log the outgoing calls which exceed the set time limit.
Default value is 30 days.

Keep Incoming Logged Calls for: xx days

-Dialer will delete from the log the incoming calls which exceed the set time limit.
Default value is 2 days.

Add, Remove & Diagnostics

Clicking on System Modems will lead user to the Windows/Control Panel/Modems window to allow to 
check and test installed modems.





EXPERT tab

Ignore all settings in Dialing Properties

-Choosing this option will allow user to send any keyboard character to the modem.
This is specially useful when the user wants to create his own dialing sequence taking full advantage of
the modem's dialing options:

-wait-for-billing-tone ($)
-wait-for-quiet (@)
-wait-for-dialtone (W) 

Dialing options:

Mode 1 (most modems)
-Most popular option.
This mode does not disconnect modem's speaker until after user clicks on "OK" or "Cancel" button.

Mode 2 (some Winmodems)
-Depending on modem's hardware sometimes this option works better then Mode 1.
-Modem's speaker disconnects automatically soon after starting dialing.
-It may not detect busy line.
 
Accept dialing numbers from other applications
-This is an option for software developers.
 Executing Run or Shell from other application calling Phone Dialer Pro executable file while passing the
dialing string for the command line parameters will keep dialer in mimimized state and dial the 
number.

Allow Call ID (Call Display)
-This option enables the displaying of information about the incoming call (name of caller, phone 
number)
Caller ID

Connected Call detection delay timer

-On some slow computers Phone Dialer may display the "Connected" window before recognizing a 
busy line and start dialing again.
 In this case increasing the delay timer by a few seconds will correct the situation.
-Default is 9 seconds





Customizing Sounds

To announce events Phone Dialer Pro uses wave files (.wav) located in it's own directory.

To change default sound:

-copy new wave file into dialer directory and rename it:

      -EndDial.wav    --->announce end of attempt to redial
      -Connect.wav --->announce successful connection after initial busy signal
      -Incoming.wav--->announce incoming call (option: "Allow Call ID" must be checked, see Expert tab 
in Tools/Option menu)





Modem's special dialing options:

-wait-for-billing-tone ($)
-wait-for-quiet (@)
-wait-for-dial tone (W)

Wait-for-billing-tone can be used when dialing with a Calling Card. Suppose a person with a calling 
card wants to make a long distance call.
The normal process is to dial a prefix code, followed by the area code and a phone number. The caller 
then waits to hear a "bong" on the line (the billing tone). After hearing the bong, the caller enters the 
calling card number.
The following example shows how to automate such dialing sequence:
 
                 1        905                777 4321      $        1234567890987654321

Wait-for-quiet tells the modem to detect "quiet" on the line, which usually means no tones (such as 
ringing or busy tones and no other sounds (such as human voices).
A modem that supports wait-for-quiet is useful for making calls to automated phone systems, such as 
voicemail systems or automated banking systems.
The following example shows how to use wait-for-quiet:

                                            777 4321          @        1,,1,,3,,2,6578768934210564,0500,72779673#
 
Another dial option is wait-for-dialtone. If a modem supports this option, it pauses after a W 
character in the dial string until it detects a dial tone. Once it detects a dial tone, it dials any remaining
digits after the W character. This option is especially useful in hotels or large companies, where it is 
usually necessary to dial a special prefix digit, such as an 8 or 9, to reach an outside line.
The following example uses wait-for-dialtone:

                                            9              W          (905) 777 4321        
Note 
        · To be able to use these special options,    "Ignore all settings in Dialing Properties" in 
Tools/Options/Expert tab must be checked.

        · In the wait-for-quiet example, both the @ and the comma are used for pauses.Typically, user 
should use the @ when unsure of the length of the pause or when the length of the pause can 
change and use commas when the length of the pause is consistent and rarely 
changes.
 
See also:

How to insert a pause in a phone number
How to insert additional information in a phone number 





Caller ID (Call Display)

When receiving a call, a small oval shaped window will pop-up on the user's screen, announcing the 
caller's name and phone number if available, or displaying "Unknown Caller" and    "Unknown #" if not 
available.
All calls are automatically logged in the Incoming Calls log. The call can be easily returned right from 
the log, by clicking on it.

Note 
        · Availability of Caller ID depends on many factors. These include the capabilities of user's local 
phone company, the capabilities of the phone company from where the call is originating. Also a factor
is the option the caller has on his or her telephone line, that is, whether they're blocking Caller ID or 
not.
Another factor is a computer modem used to receive incoming calls. It should be a voice modem with 
Caller ID capability.
Not every voice modem has Caller ID capability.

See also:
Troubleshooting Caller ID





Updates

If you are a registered user you will be automatically notified by e-mail when a new version is released.    
Updates are always free for registered users.

To inquire about new version and to suggest different features please send e-mail to:
jkozl@altavista.net





Support

Support for Phone Dialer Pro can be obtained by e-mail or snail-mail. However, before asking for support 
please try to find an answer in this Help file.

Send e-mail to:    jkozl@altavista.net

Send snail-mail to:

Jack Kozlowski
32 Larstone Ave.,
Toronto, ON M8Z 2N8
Canada





Troubleshooting Caller ID

For Caller ID to work there are four necessary requirements :

-modem's hardware support
-modem's driver TAPI compliance
-Windows support
-phone line must be subscribed to Caller ID service

Modem's hardware support

First the user's modem must be a voice modem supporting Caller ID. If in doubt please consult 
modem's manual.
To test modem's Caller ID capabilities:
      -open a communication program which allows sending    AT commands to the modem; in Windows 
use HyperTerminal (>Start>Accessories>Communications>HyperTerminal)
      -type:

AT#CID=1 <Enter>
    
      modem's response should be "OK"

      -now let someone to call you and observe the    terminal's screen.
        If you will see something like this:

RING
DATE = 0501
TIME = 1155
NMBR = 9057771234
NAME = QUEEN VICTORIA
RING

        your modem is Caller ID capable.
        If not:

your modem is not Caller ID capable
        or

your phone line is not subscribed to the Caller ID service (ask your local phone company)
 

Modem's driver TAPI compliance    

Modem's driver must be TAPI compliant. 
To check it, open your modem's log file.
In Phone Dialer Pro click on: >Tools>Options>Advanced>Modem 
Properties>Connection>Advanced>View Log.
Look at this file and see if the command to enable Caller ID (AT#CID=1) is being logged. If not, then 
modem's driver is not TAPI compliant. Contact modem manufacturer for the updated modem's driver.

Windows support

Caller ID in Windows is supported by Unimodem/V. If you have earlier release of    Windows95, probably
you have installed Unimodem not Unimodem/V (V stands for voice).
To check, look for the file Unimdm.tsp in the Windows/System directory. If the date on that file is 
11/16/1995 or later Windows have Unimodem/V installed. If it is older, then you need to download the 
newer version.

Note 
        · Caller ID does not work under WindowsNT



        · If you live in United Kigdom you will need the newest (Windows98) release of Unimodem/V 
supporting phone numbers longer then 10 digits.





Dialing without modem

If you do not have a modem or if you just want to impress your friends you can still use Phone Dialer 
Pro to place a call.
How to do it:

1. Check "Dial without modem" option in Tools>Options>Advanced
2. Place the phone receiver very close to the computer's speakers.
3. Click on Speed Dial or Dial button to dial the full number at once,

                              or you can dial manually by clicking on the individual digits on the Dialer keypad.

Note 
        · To dial this way you need to have installed soundcard in your computer and your phone should 
use the tone line.

        · You may need to adjust the sound volume and the position of the phone receiver.

        · Dialing string can contain only the numericals plus "*", "#" and "," for 2 seconds pause.

See also:
 How to    insert a pause in a phone number
 How to insert additional information in a phone number 

 





How to insert additional information in a phone number

Additional information may consist of:
-calling card number,
-account number,
-password,
-credit card number,
-any numerical data or letters

A user may create a dialable string consisting of a telephone number and additional information up to 
256 characters, punctuated by "," (one comma causes a pause in dialing of about 2 seconds), # or *    
required by the called upon party. 

Below is an example for the heavy but reasonable credit card user wanting to check on his/her account
balance.
The recorded voice may require information that looks like this:
    (a)    if    you use tone(touch) dial press 1,
    (b)    if you speak English press 1,
    (c)    to check on balances press 3,
    (d)    to check credit card balance press 2,
    (e)    enter 16 digits credit card number,
    (f)    enter 4 digits expiration date,
    (g)    enter your password ending with the pound (#) sign.

For our heavy but reasonable credit card user, the dialing string will look like this:

(bank telephone number),,,,1,,1,,3,,2,6578768934210564,0500,72779673#
 
or if    the user's password is a word, not a number Phone Dialer Pro allows you to enter the letters 
instead of numbers:

(bank telephone number),,,,1,,1,,3,,2,6578768934210564,0500,password#
 
        · The number of inserted commas depends on particular connection and is up to user to find the
best combination. However it is recommended, that between the phone number and the first 
additional number the choosen pause was 6-8 seconds (3-4 commas) to allow enough time to establish
connection.
The pauses between the next consecutive numbers can be smaller (1-2 commas) and there can be no 
pause at all between inserting final information: credit card number,expiration date and password.

Note 
        · It is imperative for the user to wait for the modem to process the whole dialing 
sequence,before clicking the OK button.
Dialer    has no means to check, whether modem has proccessed the dialing string to the end, so 
clicking on the OK button too early will interrupt this process. In such case user may continue that 
process by punching missing numbers on the telephone pad (NOT Phone Dialer Pro dialing keypad).

See also:
How to format phone numbers
How to insert a pause in a phone number
How to use modem's special dialing options





Maintaing Outgoing & Incoming Calls Logs

You can tell Phone Dialer Pro for how long you want to keep logged entries.

To specify go to: >Tools>Options>Advanced, check the option and choose the number of days.

Note 
        · Default is: 30 days for Outgoing    Calls Log and 2 days for Incoming Calls Log.








