
Keyboard Shortcuts

Keyboard shortcuts execute a command without using the mouse, just by pressing one or two keys 
instead. Once you learn these shortcuts, you may find using them faster than using the mouse. 
Keyboard shortcuts are divided into the following categories:
Open, save, and print keys                               Opening, saving, and printing documents.
View keys                                                         Displaying the current document.
Multipage keys                                                 Paging through a multipage document.
Document window keys                                    Arranging the display of document windows.
Configure, draw, and modify object keys          Working with objects.
Edit document keys                                          Cutting, copying, pasting, and finding text.
Help keys                                                         Retrieving help topics.

See also
Keyboard shortcuts listed by keys 



Open, save, and print keys

Use the following keyboard shortcuts to open, save, and print documents. They are Windows standards.
Keys Corresponds to Function
CTRL+O File -> Open Displays the Open Documents dialog box.
CTRL+N File -> New Creates a blank document window to 

contain a new document.
CTRL+S File -> Save Saves changes to the active document.
CTRL+P File -> Print Opens the Print dialog box.

See also
Opening documents using File, Open 
Creating a document 
Save command (File menu) 
Printing the active document 



View keys

Use the following keyboard shortcuts to change the display of the current document.

Key(s) Corresponds to Function
CTRL+1 View -> Zoom -> 1:1 Displays the document at a 1:1 scale factor.
F2 View -> Zoom -> 

Best Fit
Scales the document to fill the active 
document window.

F6 Window -> 
Reference

Opens or closes the Reference window.

F11 Window -> Detail Opens or closes the Detail window.
CTRL+F11 -- Freezes or releases the view in the Detail 

window.
F12 Window -> Line 

Width
Opens or closes the Line Width window.

F7 View -> Refresh Redraws all windows containing a view of 
the active document, including the 
Reference window.

F8 View -> Special -> 
Invert

Inverts the document colors.

F9 View -> Rotate -> 
Left (90 deg.CCW)

Rotates the document 90 degrees counter-
clockwise.

F10 View -> Rotate -> 
Right (90 deg. CW)

Rotates the document 90 degrees 
clockwise.

+ View -> Zoom -> 
Enlarge

Zooms into the document one zoom step.

- View -> Zoom -> 
Reduce

Zooms out of the document one zoom step.

Arrow 
keys

-- Scrolls one scroll step in the direction of the 
key.

See also
Zooming and scaling
Redrawing windows
Inverting document colors
Rotating a document



Document window keys

Use the following keyboard shortcut to copy document windows.

Keys Corresponds to Function
CTRL+F3 Window -> New Copies the view of the active document 

into a new window.

See also
Creating a document



Multipage keys

Use the following keyboard shortcuts to move through the pages in the active document window.

Key Corresponds to Function
PAGE UP Page -> Previous Displays the previous page.
PAGE DOWN Page -> Next Displays the next page.
HOME Page -> First Displays the first page of the current 

multipage.
END Page -> Last Renumbers the multipage (if needed) and 

displays the last page of the current 
multipage.

CTRL+G Page -> Go to Renumbers the multipage (if needed) and 
allows you to specify the page number of the 
page to view next.

See also
Changing pages



Configure, draw, and modify object keys

Use the following keyboard shortcuts to select tool options, paste text, and modify objects using the Edit 
menu commands.

Key(s) Corresponds to Function
F12 Window -> Line 

Width
Displays or hides the Line Width window that 
selects the line width for the active tool.

CTRL+L Edit -> Select Activates and deactivates the Select command 
for selecting and deselecting objects.

CTRL+A Edit -> Select All Selects all objects on the active edit layer.
DELETE Edit -> Delete Deletes the selected objects.
CTRL+X Edit -> Cut Copies and deletes the selected objects.
CTRL+C Edit -> Copy Copies the selected objects.
CTRL+V Edit -> Paste and

Paste button
When a Text dialog box is open, pastes text into 
the text box. Otherwise, allows you to place the 
copy stored in the Clipboard onto the active edit 
layer.

F5 Edit -> Modify 
Selected

Opens the Attributes dialog box that changes the 
appearance (color, size, font, and so on) of the 
selected objects.

CTRL+Z Edit -> Undo Undoes the previous object placement or 
deletion on the active edit layer.

CTRL+Y Edit -> Redo Reverses the previous Undo command on the 
active edit layer.

See also
Setting the drawing tool options 
Line Width command 
Edit menu commands 



Edit document keys

Use the following keyboard shortcuts to cut, copy, and paste rasters, and to search for text.

Keys Corresponds to Function
CTRL+X Edit -> Cut When no objects are selected, allows you to erase 

an area of the active raster document and copies 
the area to the Windows Clipboard.

CTRL+C Edit -> Copy When no objects are selected, allows you to select 
an area of the current document and copies the 
area to the Windows Clipboard.

CTRL+V Edit -> Paste Allows you to place the copy stored in the Windows
Clipboard onto the active Full Edit or Edit layer.

CTRL+F Tools -> Find 
Text

Searches for occurrences of specific text on edit 
layers.

See also
Copying rasters 
Pasting rasters 
Text searching
Setting eraser options 



Help keys

Use the following key shortcuts to gain access to the on-line help system.

Key(s) Function
F1 Displays the Help Contents.

        or
Retrieves the specific help topic for the highlighted command or the active dialog box.

See also
Help menu commands



Keyboard shortcuts list

The following table lists the all used keyboard shortcuts sorted by accelerator keys.
Keys Function Corresponds to

- (NUM MINUS) Zooms out of the document one zoom 
step.

View -> Zoom -> 
Reduce

+ (NUM PLUS) Zooms into the document one zoom step. View -> Zoom -> 
Enlarge

Arrow keys Scrolls one scroll step in the direction of 
the key.

--

DELETE Deletes the selected objects. Edit -> Delete
END Renumbers the multipage (if needed) and 

displays the last page of the current 
multipage.

Page -> Last

HOME Displays the first page of the current 
multipage.

Page -> First

PAGE DOWN Displays the next page. Page -> Next
PAGE UP Displays the previous page. Page -> Previous
CTRL+1 Displays the document at a 1:1 scale 

factor.
View -> Zoom -> 1:1

CTRL+A Selects all objects on the active edit layer. Edit -> Select All
CTRL+C Copies the selected objects. When no 

objects are selected, allows you to select 
an area of the current document and 
copies the area to the Windows Clipboard.

Edit -> Copy

CTRL+F Searches for occurrences of specific text 
on edit layers.

Tools -> Find Text

CTRL+G Renumbers the multipage (if needed) and 
allows you to specify the page number of 
the page to view next.

Page -> Go to

CTRL+L Activates and deactivates the Select 
command for selecting and deselecting 
objects.

Edit -> Select

CTRL+N Creates a blank document window to 
contain a new document.

File -> New

CTRL+O Displays the Open Documents dialog box. File -> Open
CTRL+P Opens the Print dialog box. File -> Print
CTRL+S Saves changes to the active document. File -> Save
CTRL+V Allows you to place the copy stored in the 

Windows Clipboard onto the active Full 
Edit or Edit layer. When a Text dialog box 
is open, pastes text into the text box. 
Otherwise, allows you to place the copy 
stored in the Clipboard onto the active edit
layer.

Edit -> Paste

CTRL+X Copies and deletes the selected objects. 
When no objects are selected, allows you 
to erase an area of the active raster 
document and copies the area to the 
Windows Clipboard.

Edit -> Cut

CTRL+Y Reverses the previous Undo command on
the active edit layer.

Edit -> Redo

CTRL+Z Undoes the previous object placement or 
deletion on the active edit layer.

Edit -> Undo



F1 Displays the Help
F2 Scales the document to fill the active 

document window.
View -> Zoom -> Best 
Fit

F5 Opens the Attributes dialog box that 
changes the appearance (color, size, font, 
and so on) of the selected objects.

Edit -> Modify Selected

F6 Opens or closes the Reference window. Window -> Reference
F7 Redraws all windows containing a view of 

the active document, including the 
Reference window.

View -> Refresh

F8 Inverts the document colors. View -> Special -> 
Invert

F9 Rotates the document 90 degrees 
counter-clockwise.

View -> Rotate -> Left 
(90 deg.CCW)

F10 Rotates the document 90 degrees 
clockwise.

View -> Rotate -> 
Right (90 deg. CW)

F11 Opens or closes the Detail window. Window -> Detail
F12 Displays or hides the Line Width window 

that selects the line width for the active 
tool.

Window -> Line Width

CTRL+F3 Copies the view of the active document 
into a new window.

Window -> New

CTRL+F11 Freezes or releases the view in the Detail 
window.

--

See also
Keyboard shortcuts by groups 



Eroiica Help Contents

Eroiica allows you to view documents of many different file formats. You can annotate, redline, markup, 
and edit these documents. Help is provided in the following categories.

Commands
This section explains what every menu and what every command in each menu does.

Eroiica API Help
Click this to get help with Eroiica's Application Programming Interface (API).

Keyboard Shortcuts
This section lists all keyboard shortcuts available. Keyboard shortcuts allow you to carry out a command
without using the mouse. Once you learn these keystrokes, you may find using them faster than using 
the mouse.

Message boxes
This topic lists messages and warnings that Eroiica might display and tells you how to solve the 
problem.
Procedures
The Procedures section explains how to perform various tasks in Eroiica. The procedures are divided 
into functional categories.

The EROICA.INI File 
The EROICA.INI file is default name of the initialization file that stores all default values. This section 
describes all EROICA.INI file entries that you can modify only by editing the file directly.



Eroiica Commands

For help on the menu commands, click the name of the menu. 
File menu commands
Use the File menu contains commands to manipulate files: open and close documents, save 
documents, print and scan documents, and so on.
Edit menu commands
Use the Edit menu commands to erase, to cut, copy, and paste, and to edit objects. The menu also 
contains Undo and Redo commands. Its Copy Document command provides OLE support.
View menu commands
The View menu commands change the display of the document in the active document window and 
displays toolbars and Eroiica Contents window.
Draw menu commands
The Draw menu commands provide the markup tools used to draw or place objects on the active edit 
layer.
Tools menu commands
The Tools menu commands create a new raster document by altering the document on the active raster 
layer, or by merging several layers.
Options menu commands
The Options menu commands allow you to configure Eroiica to suit your requirements and working 
style.
Window menu commands
Use the Window menu commands to manipulate the document windows.
Help menu commands
Use the Help menu commands to choose the Help area of choice.



File menu commands

Use the File menu contains commands to manipulate documents: open and close documents, save 
documents, print and scan documents, and so on.

New Ctrl+N creates a document.
Open... Ctrl+O opens selected documents.
Close closes the active document.
Close All closes all open document windows.

Save Ctrl+S resaves the active document.
Save As... saves the active document under the selected name, label, and location.
Scan... if available, allows you to set scan options and activates the scan process.
Scan Setup... if available, allows you to select the active scanner and scanner options.
Acquire... if available, acquires documents from a TWAIN-compatible peripheral device.
Select Source... if available, selects the TWAIN-compatible device to use.
Fax... if available, remotely faxes requested pages of the active document.
Print... Ctrl+P prints requested pages of the active document.
Print Setup... sets printer options.
Send Mail... if available, e-mails the active document.
Check In... if available, checks documents into a database.
Check Out... if available, checks documents out of a database.
#     File name  lists the most recently opened documents. When you choose one of these file 

names, the document opens again.

Exit closes Eroiica.



New command (File menu)

 New icon (Standard Toolbar)
Keyboard shortcut: CTRL+N

File -> New creates a document. It is called "Blank Window #". You can import existing documents, 
layers or place new edit layers into the window.

See also
Importing layers 
Creating a document 
Creating an edit layer 



Open command (File menu)

 Open icon (Standard Toolbar)
Keyboard shortcut: CTRL+O

File -> Open opens an existing document in a new window.
You can load more than one document at a time.

See also
Open Documents dialog box
Opening documents using File, Open 



Close command (File menu)

File -> Close closes all windows containing views of the active document. If the windows contain 
changes, you are given an opportunity to save them.
To close only the active document window, but leave open all other windows displaying views of the 
active document, use the Window -> Close command.

See also
Close All command (File menu)
Closing windows 



Close All command (File menu)

File -> Close All closes all open document windows. If a document contains changes, you are given an 
opportunity to save it.
Although the windows are closed, Eroiica still runs.

See also
Close command (File menu)
Exit command (File menu)
Closing windows



Save command (File menu)

 Save icon (Standard Toolbar)
Keyboard shortcut: CTRL+S

File -> Save stores changes made to the active document.

See also
Save As command (File menu)



Save As command (File menu)

Use File -> Save As to save the active document using whatever file name, label, and directory location 
you want.

See also
Save command (File menu)



Scan command (File menu)

 Scan icon (Standard Toolbar)
Use File -> Scan to set scan options and start the scanning process. The resulting document appears in 
its own window. This command is only available when Eroiica is connected to a scanner.

See also
Scan Setup command (File menu)
Scanning



Scan Setup command (File menu)

File -> Scan Setup opens a dialog box from which you select the scanner to use, and set scanner 
options for it. This command is only available when Eroiica is connected to a scanner.

See also
Scan command (File menu)
Scanning



Acquire command (File menu)

File -> Acquire loads the document from the TWAIN-compatible peripheral device you have selected 
with Select Source into an Eroiica document window.

See also
Scanning



Select Source command (File menu)

Use File -> Select Source to select the application program from which you want to acquire a document. 
This command is only available when Eroiica is connected to a TWAIN-compatible peripheral device.

See also
Acquire command (File menu)
Scanning



Fax command (File menu)

File -> Fax faxes out all or part of the active document. You must have compatible remote fax software 
configured and running to activate this command.

See also
FAX Send dialog box
Faxing the active document



Print command (File menu)

 Print icon (Standard Toolbar)
Keyboard shortcut: CTRL+P

File -> Print controls how the active document is printed.

See also
Print dialog box
Printing the active document



Print Setup command (File menu)

Use File -> Print Setup to select a printer from the list of defined printers. It also provides access to the 
Windows Printer Setup or to the custom Setup dialog boxes.

See also
Printer Select dialog box 
Selecting a printer 
Configuring remote printing 



Send Mail command (File menu)

File -> Send Mail appears only when your computer is running a CMC-compatible e-mail program. Use it
to electronically mail the active document. The document is converted to the SMF format (if required) 
and appears in the Mail window as an attachment.

See also
E-mailing the active document



Check In command (File menu)

File -> Check In checks a new or modified document into the document database. This command is only
available when Eroiica is running with an integrated database system.

See also
Check Out command (File menu)



Check Out command (File menu)

File -> Check Out checks out a document from a document database. This command is only available 
when Eroiica is running with an integrated database system.

See also
Check In command (File menu)



Exit command (File menu)

File -> Exit closes all open document windows, giving you an opportunity to save any outstanding 
changes, and closes Eroiica.

See also
Quitting Eroiica



1,2,3,4... command (File menu)

Use the numbers and names listed at the bottom of the File menu to open one of the documents you 
recently worked on. Choose the name or number that corresponds to the document to open. If you want,
you can open an already displayed document again.
To change the number of documents listed, use the [Most Recently Used] section of the EROICA.INI file.

See also
Reopening documents 



Edit menu commands

Use the Edit menu commands to erase, to cut, copy, and paste, and to find text. The menu also contains
Undo and Redo commands. Its Copy Document command provides OLE support.

Undo Ctrl+Z reverses the previous object placement or deletion on the active edit layer.
Redo Ctrl+Y reverses the previous Undo on the active edit layer.

Cut Ctrl+X allows you to erase and copy an area of the document or removes and copies 
the selected objects.

Copy Ctrl+C allows you to select and copy an area of the document or copies the selected 
objects.

Copy Document copies the active document to the Clipboard for pasting into other programs as 
an OLE embedded object.

Paste Ctrl+V permits you to place the copy onto the active edit layer.

Paste from... brings existing documents onto the current page as layers.

Select Ctrl+L when active, allows you to select objects so that they can be modified, or to 
deselect them.

Select All Ctrl+A selects all objects on the active edit layer.

Deselect All deselects all selected objects on the active edit layer.

Bind stores the selected objects as a single bound object.

Unbind  removes the binding from the selected bound objects.

Delete Del deletes the selected objects.

Save As Symbol... saves the selected objects as a symbol.

Modify Selected.. F5 opens the Options dialog box displaying the categories of the selected objects so
that you can change their appearance.

Attach Hotspot... makes the selected group of objects a hotspot.



Undo command (Edit menu)

Keyboard shortcut: CTRL+Z

Edit -> Undo reverses the last changes you have made on the active edit layer, such as object 
placement or deletion. You can choose Edit -> Undo repeatedly until you reach an action that cannot be 
undone, or until no actions are left to undo.
To reverse an undo, use the Edit -> Redo command.

See also
Undoing object placement and deletion



Redo command (Edit menu)

Keyboard shortcut: CTRL+Y

Edit -> Redo reverses the effect of the last Edit -> Undo command issued for the active edit layer.

See also
Undoing object placement and deletion



Cut command (Edit menu)

 Cut icon (Standard Toolbar)
Keyboard shortcut: CTRL+X

You can use Edit -> Cut to draw a rectangular, circular, elliptical, or polygonal area on the current 
document to copy. This area is then painted to the background color, making it appear that the 
underlying layers have been erased. 
Alternatively, you can select objects on the active edit layer and choose the Edit -> Cut command to 
delete and copy them.

See also
Paste command (Edit menu)
Cutting and copying rasters
Cutting, copying, and pasting objects 



Copy command (Edit menu)

 Copy icon (Standard Toolbar)
Keyboard shortcut: CTRL+C

You can use Edit -> Copy to select a rectangular, circular, elliptical, or polygonal area on the current 
document and copy it. Alternatively, you can select objects on the active edit layer and choose Edit -> 
Copy to copy them.

See also
Paste command (Edit menu)
Copying rasters
Cutting, copying, and pasting objects 



Copy Document command (Edit menu)

Edit -> Copy Document copies the active document to the Clipboard. You can then paste the document 
into any OLE-compliant program as an embedded object. If required, documents are converted to SMF 
format before being copied.

See also
Copying a document



Paste command (Edit menu)

 Paste icon (Standard Toolbar)
Keyboard shortcut: CTRL+V

Use Edit -> Paste to place the copy of the active raster document or of the selected objects onto the 
active Full Edit or Edit layer. The paste is in the same shape as the cut or copy.
The contents of the Clipboard remain until a new Cut, Copy, or Copy Document command is carried out.

See also
Cut command (Edit menu)
Copy command (Edit menu)
Pasting rasters
Cutting, copying, and pasting objects 



Paste from (Edit menu)

Use Edit -> Paste from... to bring existing raster document or edit layers onto the current document.

See also
Layer Import dialog box
Importing layers



Select command (Edit menu)

 Select icon (Drawing Toolbar)
Keyboard shortcut: CTRL+L

When active, Select allows you to select an object or a group of objects on the active edit layer. 
Click the object that you want to select or, for multiple object selection, hold the CTRL or SHIFT key 
down and click every object that you want to select or with the right mouse button drag a box around 
them. Stacked objects are selected from the top down.
If you click selected objects while holding the SHIFT or CTRL key down when the Select tool is active, 
the objects are deselected.

See also
Select All command (Edit menu) 
Deselect All command (Edit menu) 
Selecting objects



Select All command (Edit menu)

Keyboard shortcut: CTRL+A

Edit -> Select All selects every object on the active edit layer.

See also
Deselect All command (Edit menu) 
Selecting objects



Deselect All command (Edit menu)

Edit -> Deselect All deselects all selected objects on the active edit layer.

See also
Select All command (Edit menu) 
Selecting and deselecting objects



Bind command (Edit menu)

Edit -> Bind joins the selected objects on the active edit layer. Thereafter, when you click any one object 
in the bound group with the Select tool, the entire group is automatically selected.
Once bound, the group of objects are saved as such and remain bound until you select the group and 
choose the Edit, Unbind command.

See also
Unbind command (Edit menu)
Binding and unbinding objects 



Unbind command (Edit menu)

Edit -> Unbind removes the binding performed by the Bind command. Unbound objects remain selected.
You cannot unbind individual dimensions, symbols, or hotspots. You can unbind pastes and text 
documents.

See also
Bind command (Edit menu)
Binding and unbinding objects 



Delete command (Edit menu)

Keyboard shortcut: DELETE

Edit -> Delete removes the selected objects from the active edit layer. You restore deleted objects with 
the Edit, Undo command.

See also
Deleting objects



Save as Symbol command (Edit menu)

Edit -> Save as Symbol saves the selected objects on the active edit layer as a symbol.
You can later assign the symbol to the Symbol or Hotspot tool (through Symbol or Hotspot Options 
category, or the floating Symbol palette) and place it on the active edit layer.

See also
Save Symbol As dialog box
Creating a symbol



Modify Selected command (Edit menu)

Keyboard shortcut: F5

Use Edit -> Modify Selected to change the appearance (line width, color, line style, text, etc.) of the 
selected objects.

See also
Changing object attributes



Attach Hotspot command (Edit menu)

Edit -> Attach Hotspot binds the selected group of objects as a hotspot object. Note that the selected 
group must be on a Full Edit or a Hotspot layer for the command to be available.

See also
Attaching hotspots
Hotspot Data dialog box 



View menu commands

The View menu commands change the display of the document in the active document window.

Contents... lists the names of all documents opened or added in the current session.
Toolbars Subcommands control the display of all toolbars in the main window.

Standard displays or removes the Standard Toolbar.
Status Bar displays or removes the Status Bar.
Drawing displays or removes the Drawing Toolbar.

Refresh F7 redraws the all windows displaying the active document.

Zoom Subcommands control the zoom level in the active document window.
Best Fit F2 scales the document to fill the window.
Enlarge + zooms into the page.
Reduce - zooms out of the page.
1:1 Ctrl+1 displays the document at a 1:1 scale ratio.
Fit to Width scale the document to fill the width of the window.
Fit to Height scale the document to fill the height of the window.
Custom scale the document to a given scale ratio.

Rotate Subcommands control the rotation of active documents in the window.
Left (90 CCW) F9 rotates the document 90 degrees counter-clockwise.
Right (90 CW) F10 rotates the document 90 degrees clockwise.
Rotate (180) rotates the document 180 degrees.

Colors Subcommands control the color of documents in the active window.
Monochrome when active, displays all layers on the document--other than color and 

grayscale rasters--as being black and white.

Gray scale when active, displays the active, bilevel raster document as though it were a 
grayscale document. 

Original when active, returns the active, bilevel raster document to its default colors.
Special Subcommands control the display of annotations and presentation of 

documents in the active window.
Mirrored mirrors the document.
Negative reverses the raster document pixels and changes which color is dominant for

scaling. 
Sample when active, displays only a sample of bilevel raster pixels, so that the 

document appears less dense.
Show Annotations displays the text of all annotations.
Hide Annotations displays all annotations as icons..



Contents command (View or Window menu)

 Contents icon (Standard Toolbar)
Window -> Contents command displays and removes the Eroiica Contents    floating window that 
displays the names of all the layers, pages, documents, and multipage documents open in Eroiica.    
Multipage and multi-layer documents are indicated by a (+) sign. Click their icon to display the next sub-
level.
If you select the name of a layer, page, or a document in the Eroiica Contents window and click the right 
mouse button, a submenu appears. The submenu contains Insert new, Import, Save As, Attach Page, 
Delete, Move up/down, Clipboard, Color, and Properties commands. Double-clicking any name in the list
displays and activates the corresponding document.
You can resize and move the Eroiica Contents window. As long as Save=1 in the [Initial Window] section
of the EROICA.INI file, its size and position is saved on quit.

See also
Save keyname 
Getting layer information
Displaying and hiding layers
Branching and Collapsing layers 



Toolbars, Standard command (View menu)

View -> Toolbars -> Standard displays and removes the toolbar that contains icons and, by default, 
appears below the menu bar. The toolbar serves as a fast means of selecting some of the most common
File, Edit, View, and Window  commands.

See also
Changing the location of the Standard and Drawing toolbar 
[User Interface Preferences] section
Showing and hiding bars and floating windows



Toolbars, Status Bar command (View menu)

View -> Toolbars -> Status Bar displays and removes the Status Bar at the bottom of the Eroiica window.
The Status Bar displays the coordinates of the pointer, a status line, and contains icons serving as a fast
means of selecting some of the most common page commands.

See also
Save ([Initial Window] section)
Showing and hiding bars and floating windows
Using the Status Bar 



Status Bar

Status Bar displays and removes the Status Bar at the bottom of the Eroiica window. The Status Bar 
displays the coordinates of the pointer, a status line and, when measuring, the current X and Y pointer 
coordinates as well as the distance of the pointer from the first point selected. The Status Bar also 
contains icons serving as a fast means of selecting some of the most common page commands

See also
Save ([Initial Window] section)
Showing and hiding bars and floating windows
Using the Status Bar 



Toolbars, Drawing command (View menu)

View -> Toolbars -> Drawing displays and removes the bar that, by default, appears at the left of the 
Eroiica window. The Drawing Toolbar serves as a fast means of selecting Draw menu    commands.

See also
Changing the location of the Standard and Drawing toolbar
Using the drawing tools 
[User Interface Preferences] section



Toolbars

Toolbars contain buttons that give you quick mouse access to many commands and features in Eroiica.

For example you can add a new layer by clicking the New Layer  button on the Standard toolbar and
sketch by clicking the Sketch 

 button on the Drawing toolbar.

See also
Changing the location of the Standard and Drawing Bar
Using the drawing tools



Refresh command (View menu)

 Refresh icon (Standard Toolbar)
Keyboard shortcut: F7

View -> Refresh redraws all windows displaying a view of the active document--including the Reference 
window. That way all are up-to-date in terms of markups and edits, and no residues of previous displays 
remain.

See also
Redrawing windows
Opening another view of the active document



Zoom, Best Fit command (View menu)

 Fit icon (Standard Toolbar)
Keyboard shortcut: F2

View -> Best Fit scales the entire document to fit into the active document window.

See also
Fitting the document to the window



Zoom, Enlarge command (View menu)

 Enlarge icon (Standard Toolbar)
Keyboard shortcut: PLUS SIGN (numeric keypad)
View -> Zoom -> Enlarge zooms into the document by one zoom step. The zoom step value is set in the 
[View] section of the EROICA.INI file. By default it is 2.25 times the current view.

See also
Reduce command (View menu)
Zoom Step keyname ([View] Section)
Magnifying and reducing the document



Zoom, Reduce command (View menu)

 Reduce icon (Standard Toolbar)
Keyboard shortcut: MINUS SIGN (numeric keypad)
View -> Zoom -> Reduce zooms out of the document by one zoom step. The zoom step value is set in 
the [View] section of the EROICA.INI file. By default it is 1/2.25th of the current view.

See also
Enlarge command (View menu)
Zoom Step keyname ([View] section)
Magnifying and reducing the document



Zoom, 1:1 command (View menu)

 1:1 icon (Standard Toolbar)
Keyboard shortcut: CTRL+1

View -> 1:1 displays the document so that raster documents display with one document pixel equal to 
one screen pixel. You place objects most accurately at this scale factor.

See also
Displaying the document at 1:1 or another scale factor.



Zoom, Fit to Width command (View menu)

View -> Zoom -> Fit to Width scales the current document so that its width matches the width of the 
window.

See also
Fitting the document to the window



Zoom, Fit to Height command (View menu)

View -> Zoom -> Fit to Height scales the current document so that its height matches the height of the 
window.

See also
Fitting the document to the window



Zoom, Custom command (View menu)

View -> Zoom -> Custom scales the current document at the specified scale factor.

See also
Fitting the document to the window
Custom Zoom dialog box



Zoom command (View menu)

 Zoom icon (Standard Toolbar)
View -> Zoom appears only when "Single Click Activation=1" in the [View] section of the EROICA.INI file.
When selected, it allows you to select a zoom area with the left mouse button or on a touch screen. You 
then click or tap (on touch screens) inside the drawn area to activate the zoom, or drag the drawn area 
by its edge to a different zoom region. To cancel, click outside the drawn area.
After you zoom, the command is no longer active.

See also
Single Click Activation ([View] section)
Drawing the zoom region
Zoom command (View menu)



Rotate, Left    (90 CCW) command (View menu)

 Rotate CCW icon (Standard Toolbar)
Keyboard shortcut: F9

View -> Rotate -> Left (90 CCW) turns the current document 90 degrees Counter-ClockWise.

See also
Rotate 90 CW command (View menu)
Rotate 180 command (View menu) 
Rotating a document



Rotate, Right (90 CW) command (View menu)

 Rotate CW icon (Standard Toolbar)
Keyboard shortcut: F10

View -> Rotate -> Right (90 CW) turns the current document 90 degrees ClockWise.

See also
Rotate 90 CCW command (View menu)
Rotate 180 command (View menu) 
Rotating a document



Rotate, Down (180) command (View menu)

 Rotate 180 icon (Standard Toolbar)
View -> Rotate 180 turns the current document 180 degrees.

See also
Rotate 90 CCW command (View menu) 
Rotate 90 CW command (View menu) 
Rotating a document



Colors, Monochrome command (View menu)

When active, View -> Colors -> Monochrome displays all documents and their layers--other than color or
grayscale documents--as being black and white. This can be helpful when comparing layers.

See also
Comparing layers 
Changing layer and document colors 



Colors, Gray scale command (View menu)

When active, View -> Colors -> Gray scale displays the active, bilevel raster document as though it were
a grayscale document. It renders the blacks and whites as shades of gray. This helps clarify some 
documents, such as documents on which text is fuzzy and difficult to read, or very dense documents. At 
scale factors of 1.0 or more, Scale to Gray has no effect.

See also
Scaling to gray



Colors, Original command (View menu)

When active, View -> Colors -> Original displays all documents and their layers in their original color.

See also
View Options dialog box (Default Raster Color) 
Changing layer and document colors 



Special, Invert command (View menu)

 Invert icon (Standard Toolbar)
Keyboard shortcut: F8

View->Special->Invert reverses the colors of the document in the active document window.

See also
Inverting document colors



Special, Mirrored command (View menu)

View -> Special -> Mirrored mirrors the document along a vertical axis. Text in vector and text 
documents mirrors incorrectly.

See also
Mirroring a document



Special, Negative command (View menu)

View -> Special -> Negative reverses the raster document pixels and changes which color is dominant 
for scaling. Use it to make negative documents positive.
This command applies to active raster documents. Only bilevel rasters can be negative.

See also
Viewing a negative document



Special, Sample command (View menu)

View -> Special -> Sample clears dense raster documents. When active, only a sample of the document 
pixels are displayed. This command applies to active raster documents at scale factors below 1.0 (1:1).

See also
Sampling a dense raster document



Special, Show Annotations command (View menu)

View -> Special -> Show Annotations displays the text stored in all annotations on the current document.

See also
Special, Hide Annotations command (View menu)
Viewing annotations



Special, Hide Annotations command (View menu)

View -> Special -> Hide Annotations displays all annotations on the current document as annotation 

icons: .

See also
Special, Show Annotations command (View menu)
Viewing annotations



Draw menu commands

The Tool menu commands provide the markup and edit tools used to draw, place or remove objects on 
the active edit layer.

Rubout activates and deactivates the freehand eraser tool.
Erase Area activates and deactivates the object-shaped eraser tool.
Highlight activates and deactivates the tool for freehand highlighting.
Highlight area activates and deactivates the tool used for highlighting (or shading) areas.
Arc activates and deactivates the tool for drawing arcs.
Arrow activates and deactivates the tool for drawing arrows.
Box activates and deactivates the tool for drawing boxes.
Circle activates and deactivates the tool for drawing circles.
Dimension activates and deactivates the tool used for drawing dimension lines.
Ellipse activates and deactivates the tool for drawing ellipses.
Line activates and deactivates the line-drawing tool.
Polygon activates and deactivates the polygon-drawing tool.
Polyline activates and deactivates the tool that allows you to draw connected, straight lines.
Sketch activates and deactivates the freehand drawing tool.
Text activates and deactivates the tool used to place text.
Annotation activates and deactivates the tool used to place textual annotations.
Hotspot activates and deactivates the tool used for placing hotspots.
Symbol activates and deactivates the tool used to place the preselected symbol.

See also
Using the drawing tools 



Rubout command (Draw menu)

 Rubout icon (Standard Toolbar)
Draw -> Rubout activates and deactivates the freehand (sketch) eraser tool for the active Full Edit or 
Edit layer.

See also
Erase Area command (Draw menu)
Freehand erasing
Draw Options
Rubout category: Rubout Options dialog box



Erase Area command (Draw menu)

 Erase Area icon (Standard Toolbar)
When active, Erase Area allows you to erase an area in the defined shape on the active Full Edit or Edit 
layer. The area is not copied to the Clipboard.

See also
Rubout command (Draw menu)
Using Erase Area 
Draw Options
Erase Area category: Erase Area Options dialog box



Highlight command (Draw menu)

 Highlighter icon (Drawing Toolbar)
When active, Highlight allows you to freehand draw translucent sketch lines on the active Full Edit, Edit, 
Annotation, or Redline layer.

See also
Sketch command (Draw menu)
Freehand highlighting
Draw Options
Highlighter Category: Draw Options dialog box



Highlight area command (Draw menu)

 Highlight Area icon (Drawing Toolbar)
When active, Highlight Area allows you to highlight (or shade) an area of a specified shape--circle, 
ellipse, box, or polygon--on the active Full Edit, Annotation, or Edit layer.
This is equivalent to drawing one of these objects with a translucent fill style.

See also
Using Highlight area 
Draw Options
Highlight area category: Draw Options dialog box



Arc command (Draw menu)

 Arc icon (Drawing Toolbar)
When active, Arc allows you to draw circular arcs on the active Full Edit, Edit, Hotspot, or Redline layer.

See also
Drawing an arc
Draw Options
Arc category: Draw Options dialog box



Arrow command (Draw menu)

 Arrow icon (Drawing Toolbar)
When active, Arrow allows you to draw arrow-tipped lines on the any active edit layer.

See also
Drawing an arrow
Draw Options
Arrow category: Draw Options dialog box



Box command (Draw menu)

 Box icon (Drawing Toolbar)
When active, Box allows you to draw boxes on the active Full Edit, Edit, or Redline (transparent boxes 
only) layer.

See also
Drawing a box
Draw Options
Box category: Draw Options dialog box



Circle command (Draw menu)

 Circle icon (Drawing Toolbar)
When active, Circle allows you to draw circles on the active Full Edit, Edit, or Redline (transparent 
circles only) layer.

See also
Drawing a circle
Draw Options
Circle category: Draw Options dialog box



Dimension command (Draw menu)

 Dimension icon (Drawing Toolbar)
When active, Dimension allows you to draw dimension lines on the active Full Edit, Edit, or Redline 
layer.

See also
Drawing a dimension line
Text dialog box
Draw Options
Dimension category: Draw Options dialog box



Ellipse command (Draw menu)

 Ellipse icon (Drawing Toolbar)
When active, Ellipse allows you to draw ellipses on the active Full Edit, Edit, or Redline (transparent 
ellipses only) layer.

See also
Drawing an ellipse
Draw Options
Ellipse category: Draw Options dialog box



Line command (Draw menu)

 Line icon (Drawing Toolbar)
When active, Line allows you to draw straight lines on the active Full Edit, Edit, Hotspot, or Redline 
layer.

See also
Drawing a line
Draw Options
Line category: Draw Options dialog box



Polygon command (Draw menu)

 Polygon icon (Drawing Toolbar)
When active, Polygon allows you to draw polygons on the active Full Edit, Edit, or Redline (transparent 
polygons only) layer.

See also
Drawing a polygon
Draw Options
Polygon category: Draw Options dialog box



Polyline command (Draw menu)

 Polyline icon (Standard Toolbar)
When active, Polyline allows you to draw series of joined, straight lines on the active Full Edit, Edit, 
Hotspot, or Redline layer.

See also
Drawing a polyline
Draw Options
Polyline Category: Draw Options dialog box



Sketch command (Draw menu)

 Sketch icon (Drawing Toolbar)
When active, Sketch allows you to freehand draw on the active Full Edit, Edit, Hotspot, or Redline layer.

See also
Freehand drawing
Draw Options
Sketch category: Draw Options dialog box



Text command (Draw menu)

 Text icon (Drawing Toolbar)
When active, Text allows you to place text on the active Full Edit, Edit, Annotation, or Redline layer.

See also
Use Dialog for Text Entry ([User Interface Preferences] section)
Text dialog box
Draw Options
Text category: Draw Options dialog box
Placing text



Annotation command (Draw menu)

 Annotation icon (Drawing Toolbar)
When active, Annotation allows you to place annotations on the active Full Edit or Annotation layer. The 
annotation is textual only (cannot include graphics). You can display annotations as icons, as text, in a 
modal dialog box, or hide them completely.

See also
Annotation Text dialog box
Placing an annotation
Draw Options
Annotation Category: Draw Options dialog box
Viewing annotations 



Hotspot command (Draw menu)

 Hotspot icon (Drawing Toolbar)
When active, Hotspot allows you to place or draw hotspots on the active Full Edit or Hotspot layer.
The hotspot appears on the document as long as Show Hotspots is selected in View Options. Their 
action is defined through an associated program, but may include starting another program, performing 
an Eroiica function, or echoing text.
Placed hotspots can be symbols, icons, boxes, circles, ellipses, or polygons. Their shape is specified in 
the Hotspot Options dialog box.

See also
Hotspot Data Prompt ([Tool] section)
Hotspot Data dialog box
Draw Options
Hotspot category: Draw Options dialog box
Placing a hotspot
Using HOTSPOT.EXE



Symbol command (Draw menu)

 Symbol icon (Drawing Toolbar)
When active, Symbol allows you to place the preselected (in Symbol Options, File Formats Options, or 
the Symbol palette) symbol object on the active Full Edit, Edit, or Redline layer.

See also
Symbol Palette command (Window menu) 
Selecting and placing a symbol 
Draw Options
Symbol category: Draw Options dialog box



Tools menu commands

The Utility menu commands create another raster document by altering the active raster document, or 
by merging several layers.

Merge... combines all or some of the layers on the current document or page, making each a 
single new raster document.

Despeckle... creates a raster document by removing a defined size of speckles from the active raster 
document.

Deskew... creates a raster document by rotating the active raster document by given number of 
degrees.

Raster... creates a raster document by changing the attributes of the active raster document.
Resize... creates a raster document by resizing the active raster document.
Crop clips the raster document to the defined area, creating a new raster document.

Set Region employs a user-defined crop region.
Auto initiates the automatic cropping of the bilevel raster document.
Shift creates a crop box of the same size as the active raster document. You shift the box 

to select the crop area.
Size creates a crop box of the selected size. You shift the box to select the crop area.

Measure measures regions of the page.
Compare layers... displays the layers on the document according to their differences or similarities 

or in combination.
Move layer... moves the selected layer in relation to other layers on the document.

Find Text... Ctrl+F searches for specific text strings in the current document.

See also
Overwrite Raster ([System] section)



Merge command (Tools menu)

Tools -> Merge combines all or some of the layers on the current document with the specified resolution,
color, and banner options.

See also
Merge dialog box
Merging layers



Despeckle command (Tools menu)

Tools -> Despeckle removes connected dots of a specific size from the active raster document. This 
utility creates a despeckled document. It applies to bilevel documents only.

See also
Despeckle dialog box
Despeckling a document



Deskew command (Tools menu)

Tools -> Deskew rotates the document to correct its misalignment. You can define the skew angle or 
have Eroiica suggest a skew value for you. This utility creates a new deskewed document, usually in a 
new window. It applies to bilevel documents only.

See also
Deskew dialog box
Deskewing a document



Raster command (Tools menu)

Tools -> Raster changes the attributes of the raster document and creates a new raster document, 
usually in a new window. It changes the actual raster data, instead of just the header information. It 
applies to bilevel, color, and grayscale documents.

See also
Raster Operations dialog box
Changing raster document characteristics



Resize command (Tools menu)

Use Tools -> Resize to set new size values for the raster document and produce a new raster document 
of that size. The entire document is preserved, but it is larger or smaller than it was before. This 
command applies to color, grayscale, and bilevel raster documents.

See also
Resizing a raster document
Resize dialog box



Crop command (Tools menu)

Use Tools -> Crop to define a region of the raster document and create a new raster document out of 
that region. It applies to color, grayscale, and bilevel rasters documents.

See also
Crop, Set Region command (Tools menu)
Crop, Shift command (Tools menu)
Crop, Size command (Tools menu)
Cropping raster documents



Crop, Set Region command (Tools menu)

Use Tools -> Crop -> Set Region to draw the region on the document to crop.

See also
Verify Crop Region dialog box
Drawing the crop region



Crop, Shift command (Tools menu)

Tools -> Crop -> Shift creates a region of the same size as the raster document and allows you to move 
the region and click to define the crop area.

See also
Verify Crop Region dialog box
Cropping a region the same size as the active raster document



Crop, Auto command (Tools menu)

Tools -> Crop -> Auto initiates the automatic cropping of the bilevel raster document. All white space 
around the document is removed, leaving a smaller document with no loss of significant data.

See also
Cropping automatically 



Crop, Size command (Tools menu)

Tools-> Crop -> Size creates a region of the size specified by the crop subcommand and allows you to 
move the region on the active raster document and click to define the crop area.

See also
Verify Crop Region dialog box
Cropping a region to a specific size



Measure command (Tools menu)

 Measure icon (Drawing Toolbar)
Tools -> Measure displays the length, perimeter, and area value of a line or region on a document that 
you define. The values appear in a floating window. They are based on the scale of the document that 
you define, or on the document resolution.

See also
Taking drawing measurements



Compare layers command (Tools menu)

Tools -> Compare layers only becomes available when the current document contains more than one 
displayed layer. As long as the document contains no active edit layers, it can display the layers with 
only their differences showing, only their similarities showing, or by combining all layers. A default 
display is also allowed.
Pixels of different colors count as "differences" and may be combined, creating different colors. Activate 
View -> Colors -> Monochrome to compare layers regardless of color.

See also
Layers Compare dialog box
Comparing layers
View Options dialog box 



Move layer command (Tools menu)

Tools -> Move layer only becomes available when the current document contains more than one layer. 
Use it to select one of the layers on the current page and then move it relative to the other layers. That 
way you can align all the layers better.

See also
Moving layers



Find Text command (Tools menu)

Keyboard shortcut: CTRL+F

The Tools -> Find Text command becomes available when at least one edit layer appears on the current 
document. It searches for specified text on all edit layers in the document. The text last found is 
highlighted.

See also
Find dialog box
Finding text



Options menu commands

Use the Options menu commands to configure Eroiica to suit your requirements and working style.

System... defines system-wide defaults.
View... defines the viewing defaults for subsequent layers and documents.
Draw... defines the default attributes of all the tools on subsequent edit layers.

See also
The EROICA.INI File



System command (Options menu)

The settings contained in Options -> System affect the entire program. They include options such as 
initial window display, optimizations, and preview document size.
These preferences can be changed for the session only or be saved as the defaults for future sessions.

See also
 [System] section



View command (Options menu)

Options -> View defines the initial display of individual raster documents and edit layers. Some settings 
also apply to pages.
The View Options can be changed for the session only or be saved as the defaults for future sessions.

See also
View Options dialog box
Using the view options
[View] section



Draw command (Options menu)

Options -> Draw defines the default attributes of the objects drawn or placed by the tools. The 
categories available are Global, Line, Arc, Arrow, Box, Circle, Ellipse, Sketch, Polyline, Polygon, 
Highlighter, Highlight Area, Dimension, Text, Annotation, Symbol, and Hotspot. Scroll up and down the 
Category list to select the tool to configure.
The drawing tool options can be changed for the session only or be saved as the defaults for future 
sessions.

See also
Setting the drawing tool defaults
Setting the drawing tool options
[Tool] section



Window menu commands

The Window menu commands allow you to manipulate the document windows.

New Window Ctrl+F3 creates a window and displays another view of the active document, with its 
current view options.

Close closes the active document window, but not any other windows also displaying 
views of the active document.

Cascade arranges all document windows in a stacked display.
Tile arranges all document windows in a tiled display.
Tile Strips arranges all document windows in a horizontal stripped display.
Arrange Icons arranges all document window icons neatly at the bottom left of the Eroiica 

window.
Contents... lists the name of all documents currently loaded in Eroiica and allows you to work

with them.
Reference F6 displays or removes the Reference window.
Detail F11 displays or removes the Detail window.
Symbol Palette displays or removes the floating symbol palette.
Measurements displays or remove the window that displays various measurements.
Line Width F12 displays or removes the Line Width window.
# Document Name list of all open documentwindows. The active document window is checked.



New window command (Window menu)

Use the Window -> New window command to display the active document in another window with its 
current view options--with the same scaling, rotation, position, and so on--as the active window.

See also
Displaying document windows



Close command (Window menu)

The Window -> Close command closes the active document window, but not any other windows that are
displaying the same document. To close all the windows that are displaying a view of the active 
document, use the File -> Close command.

See also
Closing windows 



Cascade command (Window menu)

Window -> Cascade arranges all document windows so that they overlap, all are of the same size, and 
the title bar of each is visible. Only the top window is fully visible.

See also
Displaying document windows



Tile command (Window menu)

Window -> Tile arranges the document windows in columns and rows so that each window is of equal 
size, when possible, and no windows overlap.

See also
Displaying document windows



Tile Strips command (Window menu)

Window -> Tile Strips arranges the document windows in horizontal bands so that each window is as 
wide as the Eroiica window and as high as all the other document windows. No windows overlap.

See also
Displaying document windows



Arrange Icons command (Window menu)

When Window -> Arrange Icons is chosen, document windows that are minimized (displayed as icons) 
are arranged into a row at the bottom left of the Eroiica window. 

See also
Arranging window icons 



Reference command (Window menu)

 Reference icon (Standard Toolbar)
Keyboard shortcut: F6

Window -> Reference displays and removes a small, usually floating window. This window displays the 
entire active document in miniature. The crossed box inside the Reference window indicates which part 
of the document is displayed in the document window.
By moving or resizing the crossed box, you change the viewing region of the current document.

See also
Using the Reference window
Floating Reference Window ([Initial Window] section) 



Detail command (Window menu)

 Detail icon (Standard Toolbar)
Keyboard shortcut: F11

The Window -> Detail command displays and removes the Detail window. The Detail window provides a 
close-up view of the document window at the pointer location.

See also
Showing and hiding bars and floating windows
Using the Detail window



Symbol Palette command (Window menu)

 Symbol Palette icon (Standard Toolbar)
Window -> Symbol Palette displays and removes a floating window that displays the symbols available 
for selection in the symbol directory. The symbol stays selected until another you choose another 
symbol.
From the Symbol Palette menu, choose Refresh to update the palette with any new symbols you have 
created. Choose Help to retrieve this help topic.

See also
Selecting and placing a symbol 



Measurement command (Window menu)

 Measurement window icon (Standard Toolbar)
The Window -> Measurement command displays and removes the floating window that you use to display
measurements. You can display the size and angle of certain objects as you draw them, or you can take 
measurements of document sections using the tools.

See also
Taking drawing measurements



Line Width command (Window menu)

 Line Width icon (Standard Toolbar)
Keyboard shortcut: F12

The Window -> Line Width command displays and removes the floating window that you use to select 
the line or frame width for the selected tool.

See also
Defining line width



1,2,3,4... command (Window menu)

Displays an alphabetic listing at the bottom of the Window menu of all open document windows.
When you choose an open window, the document in that window becomes the active document.

See also



Help menu commands

Use the Help menu to choose the on-line help area of choice.

Contents leads to the on-line help's master table of contents.
Search for Help on... leads directly to the Eroiica Help Search dialog box.
Keyboard identifies all keyboard shortcuts used to immediately carry out a command.
Commands lists all menus and commands with a brief description of their function.
Procedures lists several procedure topics by category.
Eroiica API leads to the Eroiica API on-line help.

About... displays the About dialog box, with registration information.
Product Info... displays information about the program that you are running.
Version Info... displays information about all files in the EROIICA.EXE directory.



Contents command (Help menu)

Keyboard shortcut: F1 (when no dialog box is active and no command is selected.)
Contents is the on-line help system's master table of contents. Click the Contents button in the Help 
window at any time to return to it.



Search for Help on command (Help menu)

This command leads you directly to the Eroiica Help Search dialog box.
In the Search dialog box, type in the word or words that represent the area that you want help with, or 
select key words from the list. Then click the Show Topics button or double-click the selected words to 
see the related help topics. To display a particular topic in the Help window, select it in the box, and 
double-click it or click Go To.
The Search terms include synonyms that may not appear in the help text. Try this command if a full-text 
search has failed.
To retrieve the Search dialog box at any time while in Help, click the Search button.



Keyboard command (Help menu)

The Keyboard topic identifies all keyboard shortcuts used to immediately carry out a command. To go to 
the Keyboard Shortcuts opening window, select this topic: Keyboard Shortcuts



Commands command (Help menu)

The Commands topic lists all menus and commands with a brief description of their function. To go to 
the opening window of Commands, click this topic: Eroiica     Commands  



Procedures command (Help menu)

Procedures lists many "How to..." discussions. The procedures are combined into functional categories. 
To go to the Procedures opening window, select this topic: Procedures



Eroiica API command (Help menu)

This displays the Eroiica API on-line help. The API help file is distributed depending of the Eroiica 
version.



About command (Help menu)

Help -> About displays information about the registration of the program.

See also
About dialog box



Product Info command (Help menu)

Help -> Product Info gives you the title, serial number, and release number of the program that you are 
using.

See also
Product Information dialog box
Getting product and version information 



Version Info command (Help menu)

Help -> Version Info lists all files in the directory that Eroiica is running out of and gives information about
them.

See also
Version Information dialog box
Getting product and version information 



Eroiica main window

A window that contains Eroiica. The Eroiica main window displays menus and provides the workspace 
for any document open in Eroiica.
From the File menu, choose Open to select a document for viewing.

See also
Opening documents using File, Open 
Open command (File menu)



Eroiica active document window

A rectangular portion of the screen in which you view and edit a document. You can have multiple 
document windows open in the Eroiica main window, at least one for each active document. Each 
document can be viewed in more windows independently.
The document windows can be cascaded, tiled and iconized to fill the main window workspace optimally.

See also
Opening documents using File, Open 
Open command (File menu)
Close command (File menu)



Measurements Window

The Window -> Measurement (or Tools -> Measure) window is used to set the measurement scale in 
units and use that as a basis for measuring drawn objects or parts of the document. You can also 
measure parts of the document without setting a scale, using the document resolution as a basis.
To define relative units, draw a line on the document and from the Units menu in the Measurements 
window, choose Calibrate.

See also
Taking drawing measurements



Line Width Window

The line width window (Window -> Line Width) is used to set line width by draging the vertical bar. The 
color of the vertical bar indicates the active line color used for the selected drawing tool.

See also
Defining line and frame width



Symbols window
The Symbols window (Window->Symbol Palette) lists selected default symbols.

See also
Selecting a default symbol
Defining Hotspots



Detail window

The Detail window (Window->Detail) shows an enlarged view of the pointer location.

See also
Using the Detail window



Reference window

The Reference window (Window->Reference) shows an enlarged view of the pointer location. It always 
shows the entire document and the crossed box in the Reference window indicates what section of the 
document appears in the document window.

See also
Using the Reference window
Using the Reference window to zoom 



New Layer command

 New Layer icon (Standard Toolbar)
New Layer creates an active edit layer. Depending on the type of layer, restrictions on placing or 
drawing objects and the use of Draw and Edit menu commands may apply.

See also
Creating an edit layer



Mode menu commands (Eroiica Contents Window menu)

Nabídka Mod okna Eroiica Obsah umožòuje øídit zobrazení struktury dokumentù v obsahu a zobrazení 
dokumentu v oknì.
Rozvinout Enter, + zobrazí skrytou úroveò vybraného objektu (napø. vrstvy ve stránce) pro detailní 

pohled na dokument
Svinout Enter, - skryje zobrazenou úroveò vybraného objektu (napø. stránky v souboru) pro 

zpøehlednìní seznamu
Skrýt CTRL+H zmìní atribut viditelnosti vybraného objektu (viditelný nebo skrytý) v oknì 

dokumentu
Chránit CTRL+P zmìní atribut ochrany proti zápisu u vybraného objektu, pokud to umožòuje 

nastavená úroveò oprávnìní
Editovat CTRL+E otevøe vybraný objekt k úpravám (mazání, kreslení, vkládání poznámek atd.)
Zavøít ALT+F4 zavøe okno obsahu

Viz také
Uložit (Sekce [Initial Window]) 
Seznámení s vlastnostmi vrstev
Zobrazení a skrytí vrstev
Rozvinutí a svinutí objektù

Branch
Collapse
Hidden
Protected
Edit
Close

See also
Save keyname 
Getting layer information
Displaying and hiding layers
Branching and Collapsing layers 



Object menu commands (Eroiica Contents Window menu)

Nabídka Objekt okna Eroiica Obsah umožòuje pøehlednì pracovat s objekty v dokumentech (tvoøit nové
vrstvy a stránky, ukládat existující, kopírovat, pøesouvat atd.).

Vložit nový Ins Vloží nový objekt do seznamu (vrstvu do stránky, stránku do souboru, soubor
do seznamu)

Import... CTRL+I Naète soubor a uloží ho jako objekt do seznamu
Uložit jako... Uloží vybraný objekt na disk pod zvoleným jménem
Pøipojit stránku Pøipojí stránku k vybranému dokumentu
Pøipojit vrstvu Pøipojí vrstvu k vybranému dokumentu nebo stránce
Zavøít soubor/ Vymazat Odstraní vybraný objekt ze seznamu 
Posuò nahoru CTRL+U Posune objekt ve struktuøe o pozici výše (napø. stránku smìrem k zaèátku 

dokumentu)
Posuò dolù CTRL+D Posune objekt ve struktuøe o pozici níže (napø. stránku smìrem ke konci 

dokumentu)
Schránka Podnabídka, umožní kopírovat a vkládat objekty pomocí schránky (clipboard)
Barva... Vyvolá nabídku s možnými barvami pro vybraný objekt a zvolenou barvu 

nastaví do dokumentu. Tak lze napøíklad barevnì odlišit vrstvy v dokumentu.

Vlastnosti Otevøe dialogové okno s vlastnostmi a parametry objektu (název, velikost, 
rozlišení rastru, typ dokumentu atd.)

Viz také
Uložit (Sekce [Initial Window]) 
Seznámení s vlastnostmi vrstev
Zobrazení a skrytí vrstev
Rozvinutí a svinutí objektù

Insert New
Import
Save As
Attach page
Attach layer
Close file/ Delete
Move up
Move down
Clipboard
Color
Properties

See also
Save keyname 
Getting layer information
Displaying and hiding layers
Branching and Collapsing layers 



Object, Clipboard menu commands (Eroiica Contents Window menu)

Tyto pøíkazy umožòují kopírovat objekty z dokumentù do schránky (clipboard) a vkládat obrázky nebo 
texty ze schránky do dokumentù.

Vyjmout CTRL+X Pøesune vybraný objekt (napø. vrstvu) z dokumentu do schránky a nabídne jej 
ostatním Windows aplikacím ke zkopírování. Vyjímaný objekt se z dokumentu 
odstraní.

Kopírovat CTRL+C Okopíruje objekt z dokumentu do schránky a nabídne jej ostatním Windows 
aplikacím ke zkopírování. Kopírovaný objekt zùstává dále na svém místì v 
dokumentu.

Vložit CTRL+V Okopíruje objekt ze schránky do dokumentu za právì vybraný objekt. Podle typu 
objektu ve schránce a vybraného objektu se založí nová vrstva, stránka nebo 
soubor.

Viz také
Uložit (Sekce [Initial Window]) 
Seznámení s vlastnostmi vrstev
Zobrazení a skrytí vrstev
Rozvinutí a svinutí objektù

Cut
Copy
Paste

See also
Save keyname 
Getting layer information
Displaying and hiding layers
Branching and Collapsing layers 



Title Bar

A horizontal bar at the top of a window that show the name of the active application and document. To 
move a window or dialog box, position the mouse pointer on the Title bar and then press and hold down 
the mouse button while moving the mouse pointer to a new location.

See also
Window system menu



Size command (Control menus)

Changes the size of the active window--the window in which you are working. When you choose size 
and the mouse pointer becomes a four-headed arrow, you can use the arrow keys to select the border 
you want to move. When the border is in the position you want, press ENTER.
This command is unavailable if you maximize the window.

See also
Window system menu



Minimize command (Control menus)

Reduces the active window (the window in which you are working) to an icon. You can also reduce the 
active window to an icon by clicking the Minimize button in the upper-right corner of the active window.

See also
Window system menu



Maximize command (Control menus)

Enlarges the active window (the window in which you are working) to fill the available space. A 
document window expands to fill the Eroiica main window, whereas the Eroiica main window expands to
fill the entire screen. You can also maximize the active window by clicking the Maximize button in the 
upper-right corner of the window.

See also
Window system menu



System

The window system menu is accessible by clicking to the top left window icon or by using ALT+SPACE 
key. A menu appears that contains main window system commands for resizing, moving and closing the 
window. Some special commands can appear here depending of your installed system utilities.

See also
Maximize command
Minimize command
Size command
Move command



Horizontal Scroll Bar

The horizontal scroll bar is used to move horizontally through a document with a mouse.

See also
Scrolling 



Vertical Scroll Bar

The vertical scroll bar is used to move vertically through a document with a mouse.

See also
Scrolling 



Window Sizing

You can make a window smaller so that you can view more than one window at a time, or larger to see 
more of a window or document content.

See also
Window system menu



Move command (Control menus)

Moves the active window--the window in which you are working.When you choose Move, the mouse 
pointer becomes a four-headed arrow. You can then use arrow keys to move the window. When the 
window is in the location you want, press ENTER.
This command is unavailable if you maximize the window.

See also
Window system menu



Switch To command (Control menus)

Displays a list of all open applications so that you can switch to or close any application on the list.

See also
Window system menu



Next Window command (Document Control menu)

Makes the next open document window (a window in which you view and edit a document) active. 
Eroiica determines which window to make active from the order in which you opened the documents.

See also
Window system menu



Restore command (Control menus)

Returns the active window (window in which you are working) to its original size and position. Once you 
restore a window to its original size, you can fill the entire screen with a window or reduce the window to 
an icon. 
You can also return the active window to its original size and position by clicking the Restore button in 
the upper-right corner of Eroiica main window or the Eroiica document window when the window is 
maximized.

See also
Window system menu



Close command (Control menus)

Closes the active document (the document in which you are working), or an open dialog box, or Eroiica 
itself.
If you have multiple windows open for a single document, the Close command on the document Control 
menu (a menu that has commands for sizing, positioning, splitting, and closing a document window) 
closes only one window at a time.
To close all windows at the same time, choose the Close command from the File menu in Eroiica.

See also
Window system menu



Open Documents dialog box

Use the Open Documents dialog box to select documents to open immediately into a new window or 
windows (File -> Open).
File name:
Gives the file name extensions of the files listed in the list box or the full names of the documents to 
open or add.

List box
displays all of the labels or file names having the indicated extensions in the specified directory. 
Select one or several files to open or add.

List Files of Type:
displays which type of document to open (though you are not restricted to that type). One option is All 
Files (*.*).

Directories:
provides access to all available directory paths. The area above the box displays the current directory.
Drives:
The list displays all available disk drives for selection.

See also
Opening documents using File, Open 



Eroiica Contents window

The Eroiica Contents window (View -> Contents or Window->Contents) lists all documents that were 
opened in this session.

The first column shows a graphic representation of the open documents structure. Folders  are 
used to represent documents. 

 are used to represent pages and 
 are used to represent layers.

The Mode menu commands are used to manipulate object appearance (branch the tree, collapse, 
activating layers etc.).
The Object menu commands are used to control objects functions (loading, saving, clipboard functions, 
color setting, properties etc.).

See also
Mode menu
Object menu
Going to a specific page
Changing pages
Page Numbering in Dialogs ([System] section)
Add Documents dialog box 
Opening another view of the active document 



Export Layer dialog box

The Export Layer dialog box (View -> Contents -> Object -> Save As) creates a document based on an 
existing layer on the current document.
Label:
is the label to use for the edit layer. For raster layers layers, the label always corresponds to the file 
name.
File name:
is the drive, directory, and file name to use for the layer.
Format:
selects the file format of the layer.

OK
It exports the layer and closes the dialog box.
Save
It saves the layer and closes the dialog box.

Browse...
opens the Select File Name and Location dialog box in which you select the drive, directory, format, and 
file name to use for the layer.
Advanced...
appears only for raster layers allowing header rotation. It opens the Advanced Raster Information dialog 
box in which you select a header rotation and type comments about the raster layer.

See also
Select File Name and Location dialog box 
Saving a single layer



Select File Name and Location dialog box

This dialog box selects the drive, directory, format, and file name for the set, multipage document, page, 
or layer that you are saving or exporting. It appears when you click the Browse button in several save, 
export, and change attributes dialog boxes.

File Name:
is the file name to use for the document. The list box shows other document names of the specified type 
already in use in the selected directory.
Save File as Type:
selects the file format of the document.

Directories: or Folders:
provides access to all available directory paths (or folders). The current directory is displayed above the 
box.
Drives:
The list displays all available disk drives for selection.

OK
returns you to the originating dialog box and places the selected drive, directory, and file name in its File 
Name text box, and the selected format in the Format box.

See also
Raster Layer Information dialog box
Export Layer dialog box



Advanced Raster Information dialog box

This dialog box specifies a header rotation and comment for the raster document being saved, exported,
or modified. You open it with the Advanced button in the Export Layer dialog box.

Rotation
selects a header rotation value of 0°, 90° CW (clockwise), 180°, or 90° CCW (counter-clockwise). (Only 
some raster formats allow you to store a rotation value in the header.)

Comment:
With CALS (Computer-aided Acquisition and Logistics support) and TIFF (Tagged Image File Format) 
documents, you can type a comment to store in the file header. The raster document stays the same.

See also
Saving a page
Saving a single layer



FAX Send dialog box

The FAX Send dialog box (File -> Fax) initiates the remote faxing of the active document. Remote faxing
must be specially configured.

FAX:
specifies what documents to fax. Available options depend on the type of documents (raster or edit), and
whether they are displayed, hidden, active, or inactive.

Active Raster Only
faxes only the active raster document.
Entire Page
faxes all the layers on each page.
As Displayed
faxes the part of the document displayed within the window boundary.
Active Edit Only
faxes only the active edit layer on each document.
Displayed Rasters Only
faxes all displayed raster layers on each document.
Displayed Edits Only
faxes all displayed edit layers on each document.

Phone:
shows the fax number to which the document is sent.
Scale:
defines how the documents are scaled on fax.

To Fit
scales the document to match the size of the paper used.
Fit to Width
scales the document to fit horizontally on the paper.
Fit to Length
scales the document to fit vertically on the paper.
Actual size
sends each document at its actual size.
To Half Page
scales the document to fit on half a sheet of paper.
Actual Size or Fit
If, at actual size, the document fits on a sheet of paper, the document is scaled to actual size. 
Otherwise, the document is scaled to match the size of paper used.
No Scaling
The document faxes at a 1:1 scale ratio (one document pixel equals one print pixel). This option gives
maximum resolution without any loss of data.

Orientation:
defines how the documents are oriented on fax.

Best Fit
faxes the documents portrait or landscape, whichever provides the best fit given the page size and 
scale mode used.
Portrait
faxes the documents in portrait mode (width up).
Landscape
faxes the documents in landscape mode (length up).
Minimum Length



rotates the documents so that more width than length is used.
Banner...
is active when the Banner check box is selected. Opens the Banner Information dialog box that you use 
to define text banner options.
Tile
is active when the "Actual size" or the "Actual Size or Fit" scale setting is selected. When selected, Tile 
causes the entire document to be sent, spreading the document out over numerous pages if necessary. 
When cleared, only one piece of paper is used for as much of the document that fits on it.
Banner
when selected, a banner is placed on each faxed document. Define the banner using the Banner button.
Pages:
specifies which pages to fax.

Current
faxes the current page.
All
faxes all of the pages in the multipage document.
From ..... To ......
faxes the specified page range.

Normal
faxes the document at a 100 dots per inch horizontal resolution.
Fine
faxes the document at a 200 dots per inch horizontal resolution.

See also
Faxing the active document
Banner Information dialog box 



Print dialog box

Use the Print dialog box (File -> Print) to print the active document. The title bar of the dialog box names
the selected printer.

Print:
specifies what layers on each document to print. Available options depend on the type of layer (raster or 
edit) on the document, and whether they are displayed, hidden, active, or inactive.

Active Raster Only 
prints only the active raster layer on each document.
Entire Page
prints all the layers on each page.
As Displayed 
prints what is displayed within the window boundary.
Active Edit Only
prints only the active edit layer on each document.
Displayed Rasters Only
prints only displayed raster layers on each document.
Displayed Edits Only
prints only displayed edit layers on each document.

Copies:
defines the number of copies to print (printer permitting).
Scale:
specifies how the documents are scaled on print.

To Fit
scales the document to match the size of paper used.
Fit to Width
scales the document on each page to fit horizontally on the paper.
Fit to Length
scales the document on each page to fit vertically on the paper.
Actual Size
prints each document at its actual size.
To Half Page
scales the document to fit on half a piece of paper.
Actual Size or Fit
The document is printed at actual size if it fits on one sheet of paper at that size. Otherwise, the 
document is scaled to match the size of paper used.
No Scaling
The document prints at a 1:1 scale ratio (one document pixel equals one print pixel). This option gives
maximum resolution without any loss of data.

Orientation:
specifies how the documents are oriented on print. They override the Orientation selected in the 
Windows' Print Setup dialog box.

Best Fit
prints the document in portrait or landscape, whichever provides the best fit given the page size and 
scale mode used.
Portrait
prints the document in portrait mode (width up).
Landscape
prints the document in landscape mode (length up). (If you have any problems with this setting, use 
the Print Landscape keyname in the [System] section of the EROICA.INI file to correct them.)



Minimum Length
rotates the document so that more width than length is used. This is useful when printing on large 
document paper roll printers.

Light and Dark slider
Use it when the Dither check box is selected. It defines how light or dark documents print on black-and-
white printers. Drag the box or click the bar to change the setting.
Tile
is active when the "Actual size" or the "Actual Size or Fit" scale setting is specified. When selected, Tile 
causes the printer to print the entire document, spreading the document out over numerous pages if 
necessary to print the whole thing. When cleared, only one piece of paper is used to print as much of the
document that fits on it.
Merge
when selected, merges (or rasterizes) the text document or vector document before printing it. This may 
print faster, or more accurately, since the display driver does the document rendering instead of the print 
driver.
Center
is only available when the Tile check box is cleared. When selected, it centers the document on each 
page.
Bilevel
when selected, prints vector document and text document as black and white. Select Bilevel to print 
these document more accurately on black-and-white printers. Otherwise pale lines may dither or 
disappear on print.
Banner
When Banner is selected, a text banner appears on each printed page. Use the Banner button to define 
it.
Dither
when selected, prints the document with pixel patterns that simulate gray or color areas of the 
document. If Merge is also selected, vector documents and text documents dither on print, which can 
result in better print quality.

Pages:
specifies which pages in the active document window to print.
Current
prints the current page/document only.
All
prints all pages in the window, including embedded pages.
From and To
prints the specified page range.

Banner...
is active only when the Banner check box is selected. It opens the Banner Information dialog box in 
which you to define the banner to print.

Setup...
opens the Windows' Print Setup or the custom Print Setup dialog box for the active printer. More printer 
options are available there.

See also
Banner Information dialog box 
Printing the active document
Print Landscape ([System] section) 





Banner Information dialog box

Use this dialog box (File -> Print, Banner or Tools -> Merge, Banner) to define the text banner to print, 
fax, or merge on each document.
Text Size:
defines the height of the banner text in the selected units.
Text Font:
specifies the banner text font.

Top
places text at the top of each page.
Right:
places the typed or inserted text at the top right of each page.
Center:
places the typed or inserted text at the top center of each page.
Left:
places the typed or inserted text at the top left of each page.

Banner Variables:
selects the variable to insert at the insertion point. They include the following.

Date
The date in Windows format.
Page
The current page number.
Pages
The total number of pages.
File Name
The file name of the document.
Full File Name
The fully qualified file name of the document.
Document Name
The label of the document.
TileCol
A number indicating which column that part of the document belongs in. Useful when the Tile check 
box is selected.
TileRow
A number indicating which row that part of the document belongs in. Useful when the Tile check box 
is selected.
Time
The time in Windows format.

Insert
Inserts the selected variable at the insertion point.

Bottom
places text at the bottom of each document.
Right:
places the typed or inserted text at the bottom right of each document.
Center:
places the typed or inserted text at the bottom center of each document.
Left:



places the typed or inserted text at the bottom left of each document.

See also
Print dialog box
Merge dialog box 



Printer Select dialog box

The Printer Select dialog box (File -> Print Setup) selects the printer to use.

Printer
lists all available Windows printers and specially configured printers.

Setup...
interfaces with the Windows dialog boxes or the custom Print Setup dialog boxes for the active printer. 
More printer options are available there.

See also
Selecting a printer 
Configuring remote printing
[PlotDevices] section



Printer Setup dialog box

This dialog box appears when you have selected a custom printer and you click the Setup button in the 
Print or the Printer Select dialog box. It sets certain print attributes.

Scale to
specifies the print output size.
Print Time Stamp
when selected, prints the time on each page.
Banner
prints the specified text string on each page.

See also
Print dialog box 
Configuring remote printing
[  printer-driver  ] section  



Find dialog box

The Find dialog box (Edit -> Find Text...) searches for specified text on all edit layers in the active 
document. Found text is highlighted.
Find:
Type the text to search for.

Direction:
sets the search direction.

All
searches the entire document from the current location.
Down
searches from the start of the document to the end.
Up
searches from the end of the document to the start.

Match Case
when selected, finds only those occurrences with the exact combination of uppercase and lowercase 
letters specified in the Find box.
Whole Words Only
when selected, finds occurrences that are complete words, and not part of a larger word.

Find Next
finds and highlights the next occurrence of the text specified in the Find box.
First
finds and highlights the first occurrence of the text specified in the Find box.
Last
finds and highlights the last occurrence of the text specified in the Find box.

See also
Finding text



Rubout category: Rubout Options dialog box

The Rubout Options dialog box (Options -> Draw) defines the attributes of the rubouts drawn on the 
active Full Edit or Edit layer. Rubouts already placed stay the same. Each edit layer can have different 
edit options. The dialog box also changes the appearance of selected objects on the active edit layer, 
including selected rubouts.

Category:
specifies which edit element to modify.
Rubout
displays the rubout settings described in this topic. They define the objects subsequently drawn with the 
Rubout tool or the selected rubout objects.

Width:
defines the thickness of the rubout line in the specified units.

Save as default
It saves the current edit settings as the new defaults.
Load defaults
It reloads the edit settings last saved.
OK
It uses the current rubout settings.

See also
Freehand erasing
Erase Area category dialog box
Rubout Capstyle ([Tool] section)



Erase Area category: Erase Area Options dialog box

The Erase Area Options dialog box (Options -> Draw) defines the appearance of subsequent erased 
areas drawn on the active Full Edit or Edit layer. The erased areas already placed stay the same. Each 
edit layer can have different edit options.

Category:
specifies which edit element to modify.
Erase Area
displays the erase area settings described in this topic. They define the objects drawn with the Erase 
Area tool.

Shape:
specifies what shape the Erase Area tool draws to erase an area. The options are Box, Polygon, Circle, 
and Ellipse.
Frame Width:
defines the thickness of the frame around the erased area in the specified units. Because the frame is 
invisible, we recommend you keep this at the default of 0.005 inch.

Save as default
It saves the current edit settings as the new defaults.
Load defaults
It reloads the edit settings last saved.
OK
It uses the current settings.

See also
Using Erase Area
Rubout category, Rubout Options dialog box



Cut/Copy category: Cut/Copy Options dialog box

The Cut/Copy Options dialog box (Options -> Draw) defines the appearance of subsequent cut and 
copied areas placed on the active edit layer. Each edit layer can have different edit options.

Category:
specifies which edit element to modify.
Cut/Copy
displays the cut/copy settings described in help topic. They define the shape of the area with the Edit -> 
Cut and Edit -> Copy commands.

Shape:
specifies what shape the Edit -> Cut and Edit -> Copy commands draw to cut or copy an area. The 
options are Box, Polygon, Circle, and Ellipse.

Save as default
It saves the current edit settings as the new defaults.
Load defaults
It reloads the edit settings last saved.
OK
It uses the current settings.

See also
Cutting or copying rasters
Paste category, Paste Options dialog box



Paste category: Paste Options dialog box

The Paste Options dialog box (Options -> Draw) defines the attributes of the subsequent pastes placed 
on the active Full Edit or Edit layer. Pastes already placed stay the same. Each edit layer can have 
different edit options.
The Paste Options dialog box also changes the appearance of selected objects on the active edit layer, 
including the selected pastes.

Category:
specifies which edit element to modify.
Paste
displays the paste settings described in this topic. They define the subsequent objects placed with the 
Edit -> Paste command the selected paste object.

Color:
specifies the foreground color of bilevel pasted objects. The box beside it displays the color.

Translucent
indicates that the layers underlying the paste will show.
Opaque
indicates that the paste will hide the underlying layers.

Save as default
It saves the current paste settings as the new defaults.
Load defaults
It reloads the paste settings last saved.
OK
It uses the current settings.

See also
Pasting rasters
Changing object attributes
Cut/Copy category, Cut/Copy Options dialog box



View Options dialog box

The View Options dialog box (Options -> View) defines how the current document, or all pages in the 
active document window, are displayed. Each document in each window can have different view 
options.

Display
defines specific display options.
Rotation
The document can turn 0°, 90° CW (clockwise), 180°, or 90° CCW (counter-clockwise).
Sample
when selected, reduces the number of pixels displayed. This seems to clear up dense documents. It has
no effect if the Scale factor is 1.0 or larger. It only applies to bilevel raster documents.
Invert
when selected, reverses the document colors so that black becomes white, light gray becomes dark 
gray, and color pixels are set to their inverse intensity.
Mirror
when selected, displays a horizontal reflection of the document.
Negative
when selected, reverses the foreground and background pixels to corrects negative documents. It only 
applies to bilevel raster documents. When magnified, a negative document looks the same as an 
inverted one, but when reduced, it looks much darker.
Scale to Gray
When Scale to Gray is selected, bilevel raster documents display as though they were grayscale 
documents, with the black and white converted to varying shades of gray. This clarifies some 
documents.
Row & Column
when selected, displays spreadsheet documents with an additional row and column that number rows 
numerically and columns alphabetically. This information does not appear on prints nor on merged 
documents.

Factor
displays the current scale factor of the document and allows you to enter another one in the text box (or 
to set it using the slider).
Best Fit
scales the document to fit entirely in the window.
Fit to Width
scales the document to match its width to the width of the window.
Fit to Height
scales the document to match its height to the height of the window.
Actual Size
displays the document at its actual size, given the resolution of the screen.
1:1
scales the document to a 1:1 scale factor, at which the placement of objects on edit layers is most 
accurate.
Scroll Step
defines the percentage of the screen to scroll the document by when you use the scroll arrows or the 
arrow keys. If over 50, it also defines the amount scrolled when you click the scroll bars.

Show Paste Outlines
when selected, grays out all raster pastes.



Show Erase Outlines
when selected, grays out all erased (or cut) areas and rubouts.
Show Annotations
when selected, displays all annotations on all displayed documents. When cleared, annotations are 
hidden.
Show Hotspots
when selected, displays all hotspots on all displayed documents. When cleared, hotspots are hidden.
Use Hairlines
when selected, displays all vector object lines as being 1 screen pixel wide at all scale factors.
Use Wireframes
when selected, displays only the outlines of vector objects, and not their fills.

Use Monochrome
when selected, displays all documents--other than color and grayscale documents--in black-and-white 
tones, with no color.
Horizontal Scroll Bar
When selected, the horizontal scroll bar of the document window is displayed.
Vertical Scroll Bar
When selected, the vertical scroll bar of the document window is displayed.
Apply to All Pages
When selected, whatever options selected for the current page are applied to all pages.

Default Raster Color
It specifies the default foreground color of all bilevel raster documents.
Annotations
defines whether annotation text is displayed as Simple Text, or in a Modal Dialog box.

Snap and Grid
defines grid options for the document.
Snap to Grid
when selected, all objects snap to grid points when drawn or moved. Type or select the grid size in the 
selected units.
Snap Orthogonal
when selected, all objects are drawn, resized, and rotated by 90 degree angles.
Display Grid
when selected, grid points are displayed on the document. Select the grid color from the list.

Save as default
It saves the view settings as the new defaults.
Apply to All Wins
It applies all view settings to all documents in the window.
OK
It applies the selected options to the current document only and closes the dialog box.

See also
[View] section
Using the view options 



Measurement Calibration dialog box

Use the Measurement Calibration dialog box (Tools -> Measure -> Units -> Calibrate) to define the 
length of the line you have just drawn on the document.

Length Measured:
defines the number of units represented by the drawn line.

Calibrate To:
Enter value and unit name to calibrate the measured length.

See also
Taking drawing measurements



Page Import dialog box

The Page Import dialog box (View -> Contents -> Object -> Import) selects documents to add to the 
document in the active window at the current level.

File name:
lists the extensions of the files in the list box or the full names of the documents to import.

List box
displays all labels or file names having the indicated extensions in the specified directory. Select one 
or several files.

List Files of Type:
specifies which type of document to open (though you can open any type). One option is All Files (*.*).

Directories:
provides access to all available directory paths. The current directory is displayed above the box.
Drives:
The list displays all available disk drives for selection.

See also
Importing pages
Setting open defaults 



Font Remapping dialog box

This dialog box substitutes fonts contained in text documents and vector documents for other fonts that 
are available on your system, and allows you to resize these fonts and to change their attributes.
List of Fonts:
lists the fonts contained in the active text document, or listed as system defaults--plus those in the active
vector file. Click the one to modify.

Mapping Information
defines the attributes of the substituted font.
Map To:
lists all available fonts. Choose the one to use (which can be the same one as the original--if it is 
available).
ScaleX:
defines how much to scale the original text width.
ScaleY:
defines how much to scale the original text height.
Bold
puts the characters in bold.
Italic
puts the characters in italic.
Underline
underlines the text.
Strikeout
draws a line through the text.
Delete
deletes the selected font, resetting it to the default mapping for that font.
To save the font mappings for future sessions, use the Save as default.

See also
Remapping fonts in text documents
Remapping fonts in vector documents



Page Go To dialog box

In the Page Go To dialog box (click the page number in the Status Bar), you specify the number of the 
page to display. The pages are numbered starting at 1 at the current page level.

Page Number:
Type the number of the page to display, or how much to increase or decrease the current page number 
by (for example, +3, -1). By default the current page number is displayed.

Last page number is:
gives you the number of pages at this level in the multipage. If some of the pages are still unformatted, it
initially counts up to the last page.

See also
Going to a specific page
Changing pages



Layer Import dialog box

The    Layer Import dialog box (View -> Contents -> Object -> Import) selects raster or edit layers to add 
to the current document.

File name:
lists the extensions of the files in the list box, or the full names of the layers to import.

List box
displays the names of all files with the indicated extensions in the selected directory. Select one or 
several layer files to import.

List Files of Type:
specifies the type of document to import. You can only import vector documents, text documents, and 
raster documents.

Directories:
provides access to all available directory paths. The area above the box displays the current directory. 
Drives:
The list displays all available disk drives.

See also
Importing layers



Layer Compare dialog box

The Layer Compare dialog box (Tools -> Compare layers...) defines how the layers on the document are
displayed. 

Note: Default mode is always used when only one layer on the document is displayed, and when the 
document contains an active edit layer. To use the other modes, make sure that at least two layers on 
the page are displayed.
Pixels of different colors are treated as "differences," and may be "combined" as new colors. To compare
the layers regardless of color (in terms of position only), activate the View -> Colors, Monochrome 
command.

Default
displays the layers the normal way, with the raster layers combined and the edit layers overlaid on them.
Intersect
displays only the sections of the layers that are same on every layer.
Combine
displays all layers (raster and edit) as a combination. This looks similar to the default display.
Difference
displays only the sections of the layers that are different on every layer.

See also
Comparing layers
Activating layers 
Displaying and hiding layers



Raster Layer Information dialog box

The Raster Layer Information dialog box (View -> Contents -> Object -> Properties) displays information 
about the selected raster layer and allows you to modify the layers label.

Label:
is the label of the raster layer--a name up to 80 characters long that can include spaces.
File Name:
is the file name of the raster layer.
Header Format:
specifies the format of the header in the original document, if any.
Data Format:
specifies the format of the raster data in the original document.
File Size:
displays the number of bytes used to store the raster layer.
Colors:
indicates whether the raster layer or document is Bilevel, Color, or Grayscale.
Rotation:
displays the rotation factor to apply to the data when it is displayed.
Mirror:
indicates whether the document is mirrored on display or not.

Dimensions
gives information about the Width and Length of the document.
Width (X):
gives the document width in the selected units.
Length (Y):
gives the document length in the selected units.
X resolution:
gives the horizontal resolution of the document in the selected units.
Y resolution:
gives the vertical resolution of the document in the selected units.

Tiles
gives information about tiled documents -- documents composed of parts, or tiles.
Number:
reports the number of tiles in the document. If the number is 1, the document is not tiled.
Width (pixels):
gives the width of full tiles in pixels.
Length (pixels):
gives the length of full tiles in pixels.

Permissions:
lists the permissions associated with the raster layer.

OK
modifies the layers label if changes were made and closes the dialog box

See also
Getting layer information





Edit Layer Information dialog box

The Edit Layer Information dialog box (View -> Contents -> Object -> Properties) displays information 
about the selected edit layer.

Label:
is the label of the edit layer--a name up to 80 characters long that can include spaces.
File Name:
is the file name of the edit layer.
Header Format:
identifies the header format of the original document, if that vector document has one.
Data Format:
identifies the format of the vector data in the original file.
File Size:
indicates the number of bytes used to store the edit layer.
Layers Type:
indicates whether the edit layer is of the Full Edit, Edit, Redline, Annotation, or Hotspot type.

Layer Dimensions
gives information about the Width and Length of the document.
Width (X):
gives the document width in the selected units.
Length (Y):
gives the document length in the selected units.
X resolution:
gives the horizontal resolution of the document in the selected units.
Y resolution:
gives the vertical resolution of the document in the selected units.

Entities
gives information about the objects on the edit layer.
Total:
provides the number of objects on the edit layer.
Selected:
indicates the number of selected objects on the edit layer.

Permissions:
lists the permissions associated with the edit layer.

OK
modifies the layers label if changes were made and closes the dialog box

See also
Getting layer information



Text or Dimension Text dialog box

You enter or edit the text or dimension text to place on the active edit layer in the Text or Dimension Text 
dialog box (Draw -> Text or Draw -> Dimension or Edit -> Modify Selected).

Text box
Type the text to place on the active edit layer in this box.

Paste
copies the contents of the Clipboard into the text box. Appears dimmed unless the Clipboard contains 
text only--graphics cannot be pasted into the Text dialog box.

Cancel
closes the dialog box without placing or changing the text. If the Text or Dimension tool was active, it 
remains active.

See also
Placing text
Drawing a dimension line
Modifying object text



Annotation Text dialog box

You enter or edit the annotation text to place on the active edit layer in the Annotation Text dialog box 
(Draw -> Annotation or Edit -> Modify Selected...).

Text box
Type the text to place in the annotation on the active edit layer.

Paste
copies the contents of the Clipboard into the text box. Appears dimmed unless the Clipboard contains 
text only--graphics cannot be pasted into the Annotation Text dialog box.

Cancel
closes the dialog box without placing or changing the annotation. If the Annotation tool was active, it 
remains active.

See also
Placing an annotation
Modifying object text



Hotspot Data dialog box

This dialog box (Draw -> Hotspot or Edit -> Attach Hotspot or Edit -> Modify Selected) prompts you for or
allows you to change the hotspot data. This data completes the message sent to the receiving program 
on placement or on activation of the hotspot.

Text box
Type the hotspot data in the box. The data entered must be a text string that the receiving program 
can handle.

Paste
copies the contents of the Clipboard into the text box. Appears dimmed when the Clipboard is empty or 
contains graphics--only text can be pasted.
Cancel
closes the dialog box without placing or attaching the hotspot. If the Hotspot tool was active, it remains 
active.

See also
Placing a hotspot
Attaching hotspots
Hotspot Data Prompt ([Tool] section)



Global category: Global Options dialog box

The Global Options (Options -> Draw) define the attributes of subsequent objects drawn or placed on 
the active edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Global
displays the global settings explained in this topic. They define all tools and are overridden if you make 
changes to the same settings in other categories before clicking OK. They override selections in other 
categories if selected last. All settings are blank on open.

Color:
specifies the object line, frame, or text color, displayed in the box beside it.
Line Width:
defines the thickness of the object lines or frames, in the specified units.
Line Style:
specifies Solid (___), Dash (- - - ), Dot (......), or another object line pattern.

Cap Round
produces rounded object line ends.
Cap Square
produces squared object line ends.

Save as default
It saves the current tool settings as the new defaults.
Load defaults
It reloads the tool settings last saved.
OK
Apply current settings

See also
Setting global options 
Changing object attributes



Line category: Line Options dialog box

The Line Options (Options -> Draw) define the attributes of subsequent line objects drawn on the active 
edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Line
displays the line settings explained in this topic. They define the objects drawn with the line tool or the 
selected arc objects (Attributes).

Color:
specifies the line color, displayed in the box beside it.
Line Width:
defines the line thickness, in the specified units.
Line Style:
specifies Solid (___), Dash (- - - ), Dot (......), or another line pattern.

Translucent
produces semi-transparent (or highlighted) line objects.
Opaque
produces line objects of solid color.

Cap Round
produces rounded line ends.
Cap Square
produces squared line ends.

Save as default
It saves the current tool settings as the new defaults.
Load defaults
It reloads the tool settings last saved.
OK
Apply current settings

See also
Drawing a line
Selecting object colors 
Defining line width 
Changing line style 



Arc category: Arc Options dialog box

The Arc Options (Options -> Draw) define the attributes of arc objects drawn on the active edit layer. 
Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Arc
displays the arc settings explained in this topic. They define the objects drawn with the Arc tool or the 
selected arc objects (Attributes).

Color:
specifies the arc color, displayed in the box beside it.
Line Width:
defines the thickness of the arc lines, in the selected units (mm or in.).
Line Style:
specifies Solid (___), Dash (- - - ), Dot (......), or another arc line pattern.

Translucent
produces semi-transparent (or highlighted) arc lines.
Opaque
produces arc lines of solid color.

Save as default
It saves the current tool settings as the new defaults.
Load defaults
It reloads the tool settings last saved.
OK
Apply current settings

See also
Drawing an arc
Selecting object colors 
Changing line style 
Arc Capstyle keyname



Arrow category: Arrow Options dialog box

The Arrow Options (Tool -> Options) define the attributes of subsequent arrow objects drawn on the 
active edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Arrow
displays the arrow settings explained in help topic. They define the objects drawn with the Arrow tool or 
the selected arrow objects (Attributes).

Color:
specifies the arrow color, displayed in the box beside it.
Line Width:
defines the thickness of the arrow line, in the selected units.
Line Style:
specifies Solid (___), Dash (- - - ), Dot (......), or another arrow line pattern.

Translucent
produces semi-transparent (or highlighted) arrows.
Opaque
produces arrows of solid color.

Arrowhead
defines the arrowhead of the arrow.
Size:
It defines the arrowhead size. 

Fixed
The arrowhead is always the size you type or select.
Proportional
The arrowhead is proportional to the length of the arrow line.

Style:
selects the type of arrowhead.

Solid

produces triangular arrowheads ( ) 
Hollow
produces arrowheads made up of two lines (>).

Heads:
It determines the number of heads on the arrow.

Double
places a head at each end of the arrow line.
Single
places one head at the end point of the arrow line.

Save as default
It saves the current tools settings as the new defaults.
Load defaults
It reloads the tool settings last saved.
OK
Apply current settings

See also



Setting arrowhead attributes 
Drawing an arrow
Changing line style 
Arrow Capstyle ([Tool] section)



Box category: Box Options dialog box

The Box Options (Options -> Draw) define the attributes of subsequent box objects drawn on the active 
edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Box
displays the box settings explained in this topic. They define the objects drawn by the Box tool or the 
selected box or box-shaped objects (Attributes).
Fill Color:
specifies the interior color of Opaque or Translucent boxes.
Frame Color:
specifies the color of the line framing the box.
Fill Style:
specifies whether the box interior is Opaque (solid color), Translucent (semi-transparent color), 
Transparent (hollow), Hatch (line-filled), or Erase (background color).
Frame Width:
defines the thickness of the line framing the box, in the selected units.
Frame Style:
specifies Solid (____), Dash (- - - - ), Dot (......), or another line pattern framing the box.
Save as default
It saves the current tool settings as the new defaults.
Load defaults
It reloads the tool settings last saved.
OK
Apply current settings

See also
Setting fill attributes 
Drawing a box
Selecting object colors 
Changing line style 



Circle category: Circle Options dialog box

The Circle Options (Options -> Draw) define the attributes of the subsequent circle objects drawn on the 
active edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Circle
displays the circle settings explained in this topic. They define the objects drawn with the Circle tool or 
the selected circle or circle-shaped objects (Attributes).
Fill Color:
specifies the interior color of Opaque or Translucent circles.
Frame Color:
specifies the color of the line framing the circle.
Fill Style:
specifies whether the circle interior is Opaque (solid color), Translucent (semi-transparent color), 
Transparent (hollow), Hatch (line-filled), or Erase (background color).
Frame Width:
defines the thickness of the lines framing the circle, in the selected units.
Frame Style:
specifies Solid (_____), Dash (- - - -), Dot (......), or another line pattern framing the circle.

Save as default
It saves the current tool settings as the new defaults.
Load default
It reloads the tool settings last saved. 
OK
Apply current settings

See also
Setting fill attributes 
Drawing a circle
Changing line style 
Selecting object colors 



Ellipse category: Ellipse Options dialog box

The Ellipse Options (Options -> Draw) define the attributes of the subsequent ellipse objects drawn on 
the active edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Ellipse
displays the ellipse settings explained in this topic. They define the objects drawn with the Ellipse tool or 
the selected ellipse and elliptical objects (Attributes).
Fill Color:
specifies the interior color of Opaque or Translucent ellipses.
Frame Color:
specifies the color of the line framing the ellipse.
Fill Style:
specifies whether the ellipse interior is Opaque (solid color), Translucent (semi-transparent color), 
Transparent (hollow), Hatch (line-filled), or Erase (background color).
Frame Width:
defines the thickness of the line framing the ellipse, in the selected units.
Frame Style:
specifies Solid (_____), Dash (-- -- --), Dot (......), or another line pattern framing the ellipse.

Save default
It saves the current tool settings as the new defaults. 
Load defaults
It reloads the tool settings last saved. 
OK
Apply current settings

See also
Setting fill attributes 
Drawing an ellipse
Changing line style 
Selecting object colors 



Sketch category: Sketch Options dialog box

The Sketch Options (Options -> Draw) define the attributes of the sketch objects drawn on the active 
edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Sketch
displays the sketch settings explained in this topic. They define the objects drawn by the Sketch tool or 
the selected sketch objects (Attributes).
Color:
specifies the sketch color, displayed in the box beside it.
Line Width:
defines the thickness of the sketch lines, in the selected units.
Line Style:
specifies Solid (___), Dash (- - - ), Dot (......), or another sketch line pattern.

Translucent
produces semi-transparent (or highlighted) sketches.
Opaque
produces sketches of solid color.

Save as default
It saves the current tool settings as the new defaults.
Load defaults
It reloads the tool settings last saved. 
OK
Apply current settings

See also
Freehand drawing
Changing line style 
Selecting object colors 
Sketch Capstyle ([Tool] section)



Polyline category: Polyline Options dialog box

The Polyline Options (Options -> Draw) define the attributes of subsequent polyline objects drawn on the
active edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Polyline
displays the polyline settings explained in this topic. They define the objects drawn with the Polyline tool 
or the selected polyline objects.
Color:
specifies the polyline color, displayed in the box beside it.
Line Width:
defines the thickness of the polylines, in the selected units.
Line Style:
specifies Solid (___), Dash (- - - ), Dot (......), or another polyline pattern.

Translucent
produces semi-transparent (or highlighted) polylines.
Opaque
produces polylines of solid color.

Save as default
It saves the current tool settings as the new defaults.
Load defaults
It reloads the tool settings last saved.
OK
Apply current settings

See also
Drawing a polyline
Changing line style 
Selecting object colors 
Polyline Capstyle ([Tool] section)



Polygon category: Polygon Options dialog box

The Polygon Options (Options -> Draw) define the attributes of subsequent polygon objects drawn on 
the active edit layer. Each edit layer can have different tool options

Category:
specifies which tool to configure.
Polygon
displays the polygon settings explained in this topic. They define the objects drawn by the Polygon tool 
or the selected polygon or polygonal objects (Attributes).

Fill Color:
specifies the interior color of Opaque or Translucent polygons.
Frame Color:
specifies the color of the line framing the polygon.
Fill Style:
specifies whether the polygon interior is Opaque (solid color), Translucent (semi-transparent color), 
Transparent (hollow), Hatch (line-filled), or Erase (background color).
Frame Width:
defines the thickness of the line framing the polygon, in the selected units.
Frame Style:
specifies Solid (_____), Dash (- - - -), Dot (......), or another line pattern framing the polygon.

Save as default
It saves the current tool settings as the new defaults.
Load defaults
It reloads the tool settings last saved.
OK
Apply current settings

See also
Setting fill attributes 
Drawing a polygon
Changing line style 
Selecting object colors 



Highlighter category: Highlighter Options dialog box

The Highlighter Options (Options -> Draw) define the attributes of the subsequent highlighter objects 
drawn on the active edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Highlighter
displays the highlighter settings explained in this topic. They define the objects drawn with the 
Highlighter tool or the selected highlighter objects (Attributes).
Color:
specifies the highlighter color, displayed in the box beside it.
Width:
defines the thickness of the highlighter lines, in the selected units.

Save as default
It saves the current tool settings as the new defaults.
Load defaults
It reloads the tool settings last saved.
OK
Apply current settings

See also
Freehand highlighting
Selecting object colors 
Defining line width 
Highlighter Capstyle ([Tool] section)



Highlight Area category: Highlight Area Options dialog box

The Highlight Area Options (Options -> Draw) define the attributes of the subsequent Highlight Area 
objects drawn on the active edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Highlight Area
displays the Highlight Area settings explained in this topic. They define the objects drawn with the 
Highlight Area tool.

Shape:
specifies the shape drawn to shade an area. The options are Box, Circle, Ellipse, and Polygon.
Fill Color:
specifies the interior color of the shaded area.
Frame Color:
specifies the color of the line framing the shaded area.
Frame Width:
defines the thickness of the lines framing the shaded area, in the selected units.

Save as default
It saves the current tool settings as the new defaults.
Load defaults
It reloads the tool settings last saved.
OK
Apply current settings.

See also
Setting fill attributes 
Using Highlighter 
Selecting object colors 
Defining line width 



Dimension category: Dimension Options dialog box

The Dimension Options (Options -> Draw) define the attributes of subsequent dimension objects drawn 
on the active edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Dimension
displays the dimension settings explained in this topic. They define the objects drawn with the 
Dimension tool.
Color:
specifies the dimension color, displayed in the box beside it.
Translucent
produces semi-transparent (or highlighted) dimension lines.
Opaque
produces dimension lines of solid color.
Style:
defines the placement of text and extension lines.

External Linear
places text in the center of the dimension line and extension lines at each end.
Internal Linear
places text in the center of the dimension line, uses no extensions lines.
Leader Text
places text at the end of the dimension line, uses no extension lines.

Text Font:
specifies the dimension text font. The options are any installed TrueType or printer font.
Text Size:
defines the dimension text height, in the specified units.
Angle:
specifies the dimension text orientation. The options are 0°, 90° CW (clockwise), 180°, and 90° CCW 
(counter-clockwise).
Line Width:
defines the thickness of the dimension line, in the specified units.
Style:
specifies Solid (____), Dash (- - - - ), Dot (......), or another dimension line pattern.

Arrowhead
defines the dimension arrowhead.
Size:
defines the arrowhead size. 

Fixed
The arrowhead is always the size you type or select.
Proportional
The arrowhead size changes based on the length of the arrow line.

Style:
selects the type of arrowhead.

Solid

produces triangular arrowheads ( ) 
Hollow



produces arrowheads made up of two lines (>).

Heads:
selects the number of arrowheads.

Single
places one arrowhead at the end point of the line.
Double
places arrowheads at each end of the line.

Save as default
It saves the current tool settings as the new defaults.
Load defaults
It reloads the tool settings last saved.
OK
Apply current settings.

See also
Defining the dimension style 
Setting arrowhead attributes 
Drawing a dimension line
Dimension keynames ([Tool] section)



Text category: Text Options dialog box

The Text Options (Options -> Draw) define the attributes of subsequent text objects placed on the active 
edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Text
displays the text settings explained in this topic. They define the objects placed with the Text tool or the 
selected text objects (Attributes).

Color:
specifies the text color, displayed in the box beside it.
Font:
specifies the text font. You can select any installed TrueType or printer font.
Size:
defines the text height, in the specified units.
Angle:
specifies the text orientation. The options are 0°, 90° CW (clockwise), 180°, and 90° CCW (counter-
clockwise).
Style:
defines the text attributes. You can combine any of the settings. (Note that underline and strikeout are 
not applied to some TrueType fonts, such as Aquiline Book.) When selected:

Bold
increases the thickness of the characters.
Italic
italicizes the characters.
Underline
underlines the text.
Strikeout
draws a horizontal line through the text.

Save as default
It saves the current tools settings as the new defaults.
Load defaults
It reloads the tool settings last saved.
OK
Apply current settings.

See also
Setting text attributes 
Placing text
Text Width keynames ([Tool] section)
Use Dialog for Text Entry ([User Interface Preferences] section)



Annotation category: Annotation Options dialog box

The Annotation Options (Options -> Draw) define the attributes of subsequent annotation objects placed 
on the active edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Annotation
displays the annotation settings explained in this topic. They define the objects placed with the 
Annotation tool or selected annotation objects (Attributes).
Color:
specifies the annotation text color, displayed in the box beside it.
Font:
specifies the annotation text font. The options are any installed TrueType or printer font.
Size:
defines the annotation text height, in the specified units.
Angle:
specifies the annotation text orientation. The options are 0°, 90° CW (clockwise), 180°, and 90° CCW 
(counter-clockwise).
Style:
defines the annotation text attributes. You can combine any of these. (Note that underline and strikeout 
are not available for a few TrueType fonts, such as Aquiline Book.) When selected:

Bold
increases the thickness of the characters.
Italic
italicizes the characters.
Underline
underlines the annotation text.
Strikeout
draws a horizontal line through the annotation text.

Initially iconized
When selected, it causes annotations to initially appear as icons instead of text.
Save as default
It saves the current tool settings as the new defaults.
Load default
It reloads the tool settings last saved.
OK
Apply current settings.

See also
Setting text attributes 
Placing an annotation
Annotation keynames ([Tool] section)



Symbol category: Symbol Options dialog box

The Symbol Options (Options -> Draw) allow you to select a default symbol file. You can place the 
selected symbol on an active edit layer using the Symbol tool or the Hotspot tool (symbol shape). The 
selected symbol file remains available until you choose another symbol file.

Category:
specifies which tool to configure.
Symbol
displays the symbol settings explained in this topic.

Name:
is the drive, directory, and file name of the symbol file to use.
Identifier:
gives the label (if any) of the symbol file.
Browse...
opens the Set Symbol dialog box in which you can search for symbol files.

Save as default
It saves the current tool settings as the new defaults.
Load default
It reloads the tool settings last saved.
OK
Apply current settings.

See also
Set Symbol dialog box 
Hotspot category: Draw Options dialog box
Selecting and placing a symbol 



Set Symbol dialog box

This dialog box (Options -> Draw -> Symbol, Browse) or (Options -> Draw -> Hotspot, Browse) selects a
symbol file. A symbol file selected in the symbol category applies to the Symbol tool only. A symbol file 
selected in the hotspot category applies to both the Hotspot and the Symbol tools.

File name:
lists the extensions of the files in the list box, or the full name of the symbol file to select.

List box
displays all the file names or labels of the files having the indicated extensions in the specified 
directory. Select one document only.

List Files of Type:
specifies the type of document to open.

Directories:
provides access to all available directories. The current directory is displayed above the box.
Drives:
The list displays all available disk drives for selection.

See also
Symbol Category: Symbolo Options dialog box
Hotspot Category: Hotspot Options dialog box
Selecting and placing a symbol
Defining hotspots 



Hotspot category: Hotspot Options dialog box

The Hotspot Options (Options -> Draw) define the attributes of subsequent hotspot objects drawn or 
placed on the active edit layer. Each edit layer can have different tool options.

Category:
specifies which tool to configure.
Hotspot
displays the hotspot settings explained in this help topic. They define the objects drawn or placed by the 
Hotspot tool.

Shape:
specifies the type of hotspot to place. The options are Box, Polygon, Circle, Ellipse, Symbol, or Icon.

The following are active for rectangular, polygonal, circular, and elliptical hotspots.
Fill Color:
specifies the interior color of Opaque or Translucent hotspots.
Frame Color:
specifies the color of the line framing the hotspot.
Fill Style:
specifies whether the hotspot interior is Opaque (solid color), Translucent (semi-transparent color), 
Transparent (hollow), Hatch (line-filled), or Erase (background color).
Frame Width:
defines the thickness of the lines framing the hotspot, in the specified units.
Frame Style:
specifies Solid (_____), Dash (- - - -), Dot (......), or another line pattern framing the hotspot.

The following are active for hotspot Symbols. The symbol file you select here is also assigned to the 
Symbol tool.

Symbol:
is the drive, directory, and file name of the symbol file to use.
Identifier:
is the label (if any) of the symbol file.
Browse...
opens the Set Symbol dialog box in which you can search for symbol files.

The following is active for hotspot Icons.
Icon:
specifies which hotspot icon to place.

Save as default
It saves the current tool settings as the new defaults.
Load defaults
It reloads the tool settings last saved.
OK
Apply current settings.

See also
Defining hotspots 
Set Symbol dialog box 
Placing a hotspot



Save Symbol As dialog box

The Save Symbol As dialog box (Edit -> Save As Symbol) saves the selected objects as a symbol. You 
can then retrieve the saved symbol and place it onto any active edit layer (except Annotation and 
Hotspot types).

Label:
is the label to use for the symbol.
File name:
is the drive, directory, and file name to use for the symbol.

Browse...
opens the Select File Name and Location dialog box in which you select the drive, directory, and file 
name for the symbol file.

See also
Select File Name and Location dialog box 
Creating a symbol 



Merge dialog box

The Merge dialog box (Tools -> Merge) merges the indicated layers into one raster layer. Normally a 
new document window is created containing the new document. If Overwrite Raster equals 1 (in the 
[System] section of the EROICA.INI file), however, the new document replaces the active document in 
the window--without warning you to save any changes.

Merge:
specifies which layers to merge. All options except "Multipage document" apply to the current document 
only.

Active Raster Only
makes a separate raster document out of the active raster layer. This is useful if the current raster 
document is corrupted.
Entire Page
combines all of the layers on the document, displayed or not.
Multipage Document
combines all of the layers on each page. The result is a multipage made up of raster layers.
As Displayed
combines the section of the document displayed within the window boundary.
Active Edit Only
rasterizes the active edit layer.
Displayed Rasters Only
combines only the displayed raster layers on the document.
Displayed Edits Only
combines and rasterizes all displayed edit layers on the document.

Output:
defines how the document is merged.
Use Active Raster Resolution
is active only when the current documents contain an active raster. When selected, the resolution of the 
active raster applies to the new document.
Resolution
is active only when the Use Active Raster Resolution check box is cleared. It defines the resolution of 
the new document. We recommend you use a value between 100 and 1200.
Merge to Color / Grayscale Output
is active only when the Dither Bilevel Output check box is cleared, on color screens. When selected, it 
produces a color or grayscale document (drawing information from the layers being merged) instead of a
bilevel one.

Dither Bilevel Output
is active only when the Merge to Color / Grayscale Output check box is cleared. When selected, it 
produces a bilevel document in which dithering--generating pixel patterns--is used to simulate gray or 
color areas. It has no effect on bilevel document.

Light / Dark slider
is active only when Dither Bilevel Output is selected. It defines how light or dark the dithered 
document is.

Banner
when selected, a text banner is placed on the merged document. Define it using the Banner button.
Banner...
is active only when the Banner check box is selected. It opens the Banner Information dialog box in 
which you define the banner to place.

See also



Merging layers
Merge Tile Width ([System] section) 
Overwrite Raster ([System] section) 
Banner Information dialog box 



Despeckle dialog box

The Despeckle dialog box (Tools -> Despeckle) defines the size of speckle to remove from the 
document on the active raster layer. This command applies only to bilevel documents.

Speckle Size:
defines the number of pixels that make up the size of speck to remove. The maximum allowed is 30.

See also
Despeckling a document
Overwrite Raster ([System] section)



Deskew dialog box

The Deskew dialog box (Tools -> Deskew) realigns a raster document that was scanned crookedly. This 
command applies only to bilevel documents.

Skew Range Available:
gives the maximum angle in degrees that the document can be deskewed.
Current Skew Angle:
displays the deskew angle (0.00 initially). Type in any angle value up to the maximum listed in "Skew 
range available," click Set Angle and draw the angle, or get Eroiica to suggest a value.

Set Angle
Use this button to define the deskew angle by clicking two points of a skewed line on the image.
Suggest
Click this to get a deskew value suggested for you based on automated document analysis. If the 
suggested value is 0.00, then the document is straight or the skew level was incalculable. With any other
suggested value, click OK to accept the value and the document will be deskewed by that amount.

See also
Deskewing a document
Overwrite Raster ([System] section)



Raster Operations dialog box

The Raster Operations dialog box (Tools -> Raster) creates a new raster document by redefining the 
characteristics of the active raster document. The command applies to bilevel, color, and grayscale 
documents.

Rotation:
rotates the document the specified number of degrees. The options are 0, 90 CW (clockwise), 90 CCW 
(counter-clockwise), and 180 degrees. This is a data rotation, not just a header rotation. The document 
is repainted with a new point of origin.
Mirror
when selected, creates a horizontal reflection of the document.
Negative
when selected, creates a negative of the document (bilevel only).

Resolution
defines the resolution of the new document.
X
defines the horizontal resolution in the specified units.
Y
defines the vertical resolution in the specified units.
Same X & Y
when selected, makes the X and Y resolution values the same. Having different X and Y resolution 
values can distort the document.

After you perform the raster operations, the header rotation is always reset to 0.

See also
Changing raster characteristics
Overwrite Raster ([System] section)



Resize dialog box

This dialog box (Tools -> Resize) specifies the size you want the new raster document to be, based on 
the active raster document. This command applies to bilevel, color, and grayscale raster documents.

Current X:
gives the current document width in the selected units.
Current Y:
gives the current document length in the selected units.
New X:
defines the new document width in the selected units.
New Y:
defines the new document length in the selected units.

Preserve Aspect
when selected, preserves aspect ratio for the new document. Therefore, if you change either one of the 
New X or the New Y values, the other New value automatically changes as well, to ensure that aspect 
ratio is maintained.

After you perform the resize operation, the header rotation is always reset to 0.

See also
Resizing a raster
Overwrite Raster ([System] section)



Verify Crop Region dialog box

Use the Verify Crop Region dialog box to reset the region on the active raster document to crop, or 
starts the crop operation. You can crop bilevel, color, and grayscale raster documents.

Reset
returns control to the active window, enabling you to reposition the crop region.

See also
Cropping a raster document
Overwrite Raster ([System] section)



Optimizations category: Optimizations Options dialog box

The Optimizations Options dialog box (Options -> System) sets the program defaults for this and, if you 
want, for future sessions.

Window:
defines how the document windows are displayed when first opened.
Cascaded
overlaps each document window so that the title bar of each is displayed, all windows are the same size,
and the active window is on top.
Maximized
displays each document window so that it fills the Eroiica window, with the active window on top.

Performance:
determines which optimization algorithms are used. Generally, for maximum speed choose all 
optimizations except Minimize Resources. To compensate for a computer system with low memory, by 
contrast, be sure to select Minimize Resources. Then you can improve speed by selecting all other 
optimizations except Use Previews. If document display quality is most important, it is safest to deselect 
all Optimize options (Minimize Resources has no effect on document display quality, but does slow down
document display).
Fast Load
when selected, raster documents load more quickly. They may look less sharp than they otherwise 
would. Unless deactivated, sampling is automatically applied to them.
Fast Scroll
when selected, raster documents scroll more quickly. On some display drivers, you may notice display 
distortions.
Fast Display
when selected, raster documents are displayed more quickly, but possibly less accurately.
Use Previews
when selected, loads preview images if they exist, and saves raster documents with preview images, if 
the file format supports it. Large documents load much more quickly. Clear this check box if preview 
images are causing any problems, and when trying to save memory.
Minimize Resources
when selected, preserves a small amount of memory by using a more efficient but slower compression 
algorithm.

Save Documents as Viewed
when selected, saves CLF- and SMF page documents with their current layer display. When the page 
document opens later, the saved display is used by default.
Preview image size:
specifies the maximum dimension (in pixels) of the preview image. Set this to the maximum size of the 
screen (often 1024).

Save as default
saves the current settings as the new defaults.
Load defaults
reloads the settings last saved. 
OK
applies the current settings.

See also
Optimizing memory 
Optimizing raster document speed 



[System] section



Zoom custom dialog box

The Zoom Custom dialog box (View -> Zoom -> Custom) lets you define the user value of the screen 
zoom. You can use it to set some precise values for the view measure not covered by other commands 
(1:1, original size etc.). You can select for example exactly 400% to see bitmaps 4x larger.

See also
Zoom, Custom command 



Measurement category: Measurement Options dialog box

The Measurements Options dialog box (Options -> System) selects metric, Imperial, or default units, and
allows you to define custom units.
Units of Measure:
From the list, you can select metric, Imperial, or default units for all dialog boxes and floating windows. If
you select default, the shipped default units are used, a mix of Imperial and other units of measurement.

Custom Units
Use this section to define custom units.
1.0
In the box, type the name of the custom unit.
=
Select a real unit from the list. Type or select how many real units equal your custom unit.
Example
1.0 custom = 0.5 in.
Whatever custom unit you define becomes available in all unit lists in Eroiica.



File Formats category: File Formats Options dialog box

The File Formats Options dialog box (Options -> System) selects the defaults for opening, reading, and 
saving various documents.

Image Directory:
names the disk and path to the directory that is first displayed in dialog boxes for selecting and saving 
documents.
Symbol Directory:
names the disk and path to the directory that is first displayed in dialog boxes for selecting and saving 
symbols.

Open files as
defines which type of document is displayed by default in the Select Files of Type box in Open, Add and 
Import dialog boxes. More options are available in the EROICA.INI file.
All Files
displays all documents by default.
Sets
displays sets by default.
Documents
displays documents.
Raster Files
displays raster documents.
Text Files
displays text documents.

Show
defines which names are displayed in lists of files for selection.
Labels
displays document labels. A label can be up to 80 characters in length and can include spaces.
File names
displays MS-DOS file names.

Output File Formats:
defines the document name extensions that are suggested by default when you save documents of 
various types.
Documents:
defines the default extension for saving single page documents and multiple page documents.
Raster Files:
defines the default extension used for saving raster documents. The list defines the default file format for
raster documents.
Vector Files:
defines the default extension for saving vector documents.
Save as default
saves the settings as the new defaults.
Load defaults
reloads the settings last saved.

See also
File Open Extensions Options dialog box 
Text Layout Options dialog box 



Font mapping options box 
[File] section



File Extensions category: File Extensions Options dialog box

The File Extensions dialog box (Options -> System) defines the file name extensions displayed by 
default in the File name box when you open, add, or import various document types. You can specify a 
maximum of 8 three-letter extensions for each. Use the ampersand symbol (*) as a wildcard.

Sets:
defines the default extensions for the Sets document type.
Documents:
defines the default extensions for the Documents document type.
Edit Layers:
defines the default extensions for the Vector Documents type.
Raster Files:
defines the default extensions for the Raster Documents type.
Text Files:
defines the default extensions for the Text Documents type.
Symbol Files:
defines the default extensions for the Symbol Files type.

See also
Setting open defaults



Vector Pens: Vector Pens Options dialog box

This dialog box (Options -> System) sets the characteristics of the eight pen lines in some vector 
documents, such as HPGL documents.

Pen 1 - Pen 8:
Each specifies the thickness, units, and color of that particular pen line. The box displays the specified 
color.

See also
[HPGL] section
Configuring HPGL documents



Text Layout category: Text Layout Options dialog box

The Text Layout dialog box (Options -> System) sets defaults for rendering text documents.

Show Borders:
when selected, displays a box that indicates the page borders of text documents.

Presentation:
determines how many pages of text documents you see at once. The picture depicts the options. Each 
displayed "page" is treated as one edit layer.

ASCII Template:
displays the name of the selected RTF template. This template defines the page size, margins, text 
color, font name, font size, and tab size for ASCII text files.
Browse....
opens the ASCII Template dialog box in which you can search for the RTF template file to use.

Font remap section
In this section you can set the alias for each active, not directly supported, font. The example is if your 
CAD file contains CAD font that not resides on your hard disk. You can select and setup Windows or 
CAD font that is (probably) similar to original. The remap is remembered after exit and restored each 
time the aliased font is used.
Remapping fonts using Font Remap section

See also
Configuring text document display 
ASCII Template dialog box 
Formatting ASCII text files
Remapping fonts in documents



ASCII Template dialog box

Use this dialog box (Options -> System -> Text Layout, Browse) to select the RTF template used for 
defining ASCII text documents.
File name:
lists the extensions of the files in the list box, or the full name of the template file to use.

List box
displays all the file names or labels of the files having the indicated extensions in the selected 
directory. Select one file only.

List Files of Type:
specifies which type of document to open. Select a Rich Text Format (RTF) file.

Directories:
provides access to all available directory paths. The current directory is displayed above the box.
Drives:
The list displays all available disk drives for selection.

See also
Formatting ASCII text documents
Formatted Text Settings dialog box
Configuring text document display 



Crop Formats category: Crop Formats dialog box

This dialog box (Options -> System) defines the sizes available for cropping the active raster 
documents.

List of formats:
displays the labels of the crop sizes already defined. Select the one to edit or delete.

Format definition
Use this section to define a new crop size or to edit an existing one.
Format name:
defines the name of the selected or new crop size.
Width (X):
defines the width of the selected or new crop size in the specified units.
Length (Y):
defines the length of the selected or new crop size in the specified units.

Add to list
saves the defined crop sizes to the EROICA.INI file.
Load defaults
restores the previously saved crop sizes to the dialog box.

Clear
empties the Format name, Width, and Length boxes for you to fill in with a new crop size.
Delete item
removes the selected crop size from the box.
Restore standards
restores the shipped default crop sizes to the dialog box.

See also
Cropping a region to a specific size



About dialog box

The About dialog box (Help -> About) identifies the version of the program that you are running, the 
registration information entered when the program was installed.
When calling for assistance, have the serial number and registration information handy.

See also
Logo ([Initial Window] section)



Version Information dialog box

This dialog box (Help -> Version Info) displays version information about the files in the Eroiica directory.

File
lists the names of all the files in the EROICA.EXE directory.
Version
lists the version numbers of these files (if any).
Size
lists the size of the files in bytes.

Save to File
saves the version information to the LOG file in the EROICA.EXE directory.

See also
Getting product and version information 



Product Information dialog box

This dialog box (Help -> Product Info) gives more information about your version of Eroiica.

Product Title:
is the name of the program.
Serial Number:
gives the unique number assigned to your installation of the program.
Product Release:
provides the program version number.
RD Release:
gives the internal version number.
Creation Time:
indicates when the program was created.

OEM Number:
gives the special release number, if any.
Eval Copy
when selected, indicates that you have an evaluation copy of the program.
Hardware Key
when selected, indicates that your version of the program came with a hardware key. This allows you to 
try the product out for a limited amount of time.
Installed
when selected, indicates that you have an installed version of the program with no special restrictions.

List box
provides a summary of the dialog box information.

See also
Getting product and version information 



TruScan 800 Scan Window

The TruScan 800 Scan window contains the most commonly required scan options. Select more 
specialized options with the Options button.

Overview Window
This is the window located at the left of the scan window. Shows a reduced-scale version of the 
document as it is being acquired. Can be deselected (in Options).

Scroll Window
This is the window located at the bottom of the scan window. Shows a pixel-level view of the image as it 
is being acquired. Can be deselected (in Options).

Document Info
defines the size and orientation of the document to scan.

ANSI 1 - ANSI E; ISO A4 - ISO A1; custom sizes
Select the appropriate document size.
Portrait Mode
Feed the short side of the page into the scanner first.
Landscape Mode
Feed the long side of the page into the scanner first.

Width
defines the width of the document to scan, in the specified units. You normally can only modify the 
custom sizes.
Length
defines the length of the document to scan, in the specified units. You normally can only modify the 
custom sizes.

Bilevel Output
when selected, assigns 1 bit per pixel when scanning the document SO that the resulting document, 
regardless of the original document, is black and white.
Dithered Output
when selected, produces a document in which a dither pattern is used to simulate gray or color 
sections of the original document. The file size is smaller than it would be with Grayscale Output.
Grayscale Output
when selected, produces a document with about the same range of grays as the original document. 
Assigns 6 bits per pixel, which results in 64 levels of gray.
75 DPI - 500 DPI
specifies the document resolution. Larger resolutions produce documents with fine details, but the 
resulting files are larger. DPI = dots per inch.

Scan Settings
defines the type of scanning to be done.

Black and White, BluePrint, Pencil, Sepia, Clear Mylar, and custom media types
Select the media type that best represents the document to scan.

Thresholding
is only available for Bilevel Output. It defines the type of thresholding to use.

Manual
applies a single Threshold value to the entire document.
Adaptive Area
changes the thresholding based on the quality of each section of the document.

Rocker Mode
only becomes active during a scan and is only available for Bilevel Output. When selected, causes the 



scanner to repeatedly scan a section of the document corresponding to the height (in pixels at the 
resolution selected) of the Scroll window (which must be displayed). Adjust the scan settings as the 
scanner rocks. You then do a full scan to obtain a complete image.

Edge Sharpening
when selected, improves the sharpness of the background and foreground densities. Deselect it only if 
too much background speckling occurs when scanning at larger resolutions.
Dark Enhancement
when selected, improves the ability of the scanner to discriminate between foreground elements on a 
dark background by lightening the background.
Negative Document
is only available Bilevel Output when Adaptive Area Thresholding is selected. Select it if the document 
has a white foreground on a black background.
Contrast
matches the dynamic range of the scanner to the density range of the document. Increase the value 
when the contrast between the foreground and background of the document is low.
Variability
is only available for Bilevel Output when Adaptive Area Thresholding is selected. Adjusts the scanner's 
degree of freedom for automatically compensating for variations in the document background density. 
Increase the value when a document has variable background density.
Brightness
is only available for Bilevel Output when Adaptive Area Thresholding is selected. Adjusts the scanner's 
degree of freedom for automatically discriminating between foreground and background. Increase the 
value to minimize speckling in the document background.
Threshold
is only available for Bilevel Output when Manual Thresholding is selected. It defines a Threshold value 
from 0 - 63. Decrease the threshold value if you get background speckling or to sharpen fine details. 
Increase it if fine lines are disappearing.
File Name
is the file name to apply to the document when you save it.

File format list
specifies the file format to save the document under. The list differs depending on whether Bilevel or 
Grayscale Output is selected.

Browse...
opens the Browse dialog box in which you select the drive, directory, file name, and file format for the 
scan.
Batch
When selected, you scan and save several pages in a row. Select this when scanning several pages of 
similar size and quality, after you had optimized the scan settings.
Multipage
When selected, you scan and save several pages in a row, and they are saved as a multipage 
document.
Scan
activates the scan process. Feed in the document after you select it.
Options...
opens the Scan Window Options - TruScan 800 dialog box that you use to refine the scan options.



TruScan 500 Scan Window

The TruScan 500 Scan window contains the most commonly required scan options. Select more 
specialized options with the Options button.

Overview Window
This is the window located at the left of the scan window. It shows a reduced-scale version of the 
document as it is being acquired. You can deselect it (in Options).

Scroll Window
This is the window located at the bottom of the scan window. It shows a pixel-level view of the document
as it is being acquired. You can deselect it (in Options).

Document Info
defines the size and orientation of the document to scan.

ANSI 1 - ANSI E; ISO A4 - ISO A1; custom sizes
Select the appropriate document size. ANSI = American National Standards Institute. ISO = 
International Standards Organization.
Portrait Mode
Feed the short side of the page into the scanner first.
Landscape Mode
Feed the long side of the page into the scanner first.

Width
defines the width of the document to scan, in the specified units. You normally can only modify the 
custom sizes.
Length
defines the length of the document to scan, in the specified units. You normally can only modify the 
custom sizes.

Bilevel Output
when selected, assigns 1 bit per pixel when scanning the document so that the resulting document, 
regardless of the original document, is black and white.
Grayscale Output
when selected, produces a document with about the same range of grays as the original document. 
Assigns 6 bits per pixel, which results in 64 levels of gray.
75 DPI - 500 DPI
specifies the document resolution. Larger resolutions produce documents with fine details, but the 
resulting files are larger. DPI = dots per inch.

Scan Settings
defines the type of scanning for Bilevel Output. For Grayscale Output, no scan settings are available.

Black and White, BluePrint, Pencil, Sepia, Clear Mylar, and custom media types
Select the media type that best represents the document to scan.

Thresholding
defines the type of thresholding done.

Manual
applies a single Threshold value to the entire document.
Prescan/Rescan
produces documents by scanning a document twice. The first time, the scanner gathers information 
from the document on a line-by-line basis. The second time the scanner adjusts the data for each 
scan line using information from the first pass. This creates acceptable documents from documents 
exhibiting a range of quality.

Threshold



appears only when Manual Thresholding is selected. It defines a Threshold value from 0 - 63. Decrease 
the threshold value if you get background speckling or to sharpen fine details. Increase it if fine lines are 
disappearing.

Negative Document
appears only when Prescan/Rescan Thresholding is selected. Select it if the document has a white 
foreground on a black background.

Brightness
appears only when Prescan/Rescan Thresholding is selected. Increase it if extensive background 
speckling occurs or to sharpen fine details. Decrease it if fine lines are disappearing.

Rocker Mode
only becomes active during a scan when Manual Thresholding is selected. When selected, you 
repeatedly view a particular section of the document for evaluation and threshold control adjustment.

Directory
displays the directory in which the documents are saved by default.
Batch Scan
When Batch Scan is selected, you scan and save several pages in a row. Select this when scanning 
several pages of similar size and quality, after you had optimized the scan settings.
File name
is the file name to apply to the document when you save it.

File format list
specifies the file format to save the document under. The list differs depending on whether Bilevel or 
Grayscale Output is selected.

Scan
activates the scan process. Feed in the document after you select it.
Browse...
opens the Browse dialog box in which you select the drive, directory, file name, and file format for the 
scan.
Options...
opens the Scan Window Options - TruScan 500 dialog box that you use to refine the scan options.



Browse dialog box

This dialog box selects the drive, directory, file name, and file format for saving the next scanned image.

File Name:
is the file name to use for the next scanned document.
Save File as Type:
specifies the file format to save the document under.

Directories:
provides access to all available directory paths. The current path is displayed above the box.
Drives:
The list displays all available drives for selection.

See also
TruScan 500 Scan Window
TruScan 800 Scan Window



Scan Window Options - TruScan 800

The Scan Window Options defines other scan options.

Document Control
specifies how the document is scanned.
Overscan Border
when selected, scans beyond the document size you designated in the Scan window. Useful if you are 
saving a series of pages having similar but not identical sizes and when you do not want to accurately 
stage documents each time. Enter the size of the scan border in the box.
Roll In
when selected, causes the scanner to ignore part of the leading edge of the document. Type the size 
value of the roll in section.
Auto Rewind Before the Scan
When this check box is cleared, the scan starts wherever the document is located. Useful when 
scanning large documents in pieces.
Auto Eject
determines what happens to a document at the end of the scan, before the document is displayed in 
Eroiica.

None
leaves the documents at its location in the scanner.
Back
moves the document to the back of the scanner (usually faster).
Front
moves the document to the front of the scanner (more convenient to remove).

Units
Specify all values in Inches, Centimeters, or Pixels.

Auto Name
configures the automatic naming of scanned documents.
Enable Auto Name
When selected, a file name is automatically created for each document.
File Template
defines a pattern used to generate file names. The template is any valid MS-DOS file name (without 
directory and extension) that contains at least one wildcard character (#, @, or &). Wildcards have the 
following influence on automatically generated file names.
# = numerical series 0 - 9
@ = alphabetical series A - Z
& = alphanumeric series 0 - 9 then A - Z
Start Count
represents the first set of numbers or letters to substitute for the wildcards. They must match the 
wildcard mask.

Image Prescanning
specifies how the scanned document is displayed in Eroiica.
Rotation
specifies a rotation factor of 0, 90 CW (clockwise), 90 CCW (counter-clockwise), or 180 degrees.
Mirror
when selected, flips the new document from left to right before it is displayed. Mirroring is applied before 
Rotation is.
Invert



when selected, exchanges foreground and background tones in the document before it is displayed.
Auto Deskew
when selected, crooked documents are automatically straightened before they are displayed.

Windows
use this section to configure the display of the TruScan 800 Scan window.
Overview Window
when selected, the Overview window is displayed. It shows a reduced-scale version of the document as 
it is being acquired from the scanner. It always appears dimmed for Grayscale Output.
Scroll Window display
when selected, the Scroll window is displayed. It shows a pixel-level view of the document as it is being 
acquired. Deselect it to increase scanning speed.
Scroll Window orientation
Use this to select a display orientation of Wide or Tall for the Scroll window.
Cleanup...
leads to the Cleanup dialog box where you can deskew and smooth the document.

See also
Scan window



Scan Window Options - TruScan 500

The Scan Window Options define the display of the scan window, determine how the scanner deals with
the document after scanning, link to a cleanup dialog, and configure automatic naming of the scanned 
images.

Document Control
specifies how the document is scanned.
Overscan Border
when selected, scans beyond the document size you designated in the Scan window. Useful if you are 
saving a series of pages having similar but not identical sizes and when you do not want to accurately 
stage documents each time. Enter the size of the scan border in the box.

Note: Avoid large overscan borders when using Prescan/Rescan.

Roll In
when selected, causes the scanner to ignore part of the leading edge of the document. Enter the size 
value of the roll in section.
Auto Rewind Before the Scan
When this check box is cleared, the scan starts wherever the document is located. Useful when 
scanning large documents in pieces.
Auto Eject
Reserved for future use.
Units
allows you to specify all values in Inches, Centimeters, or Pixels.
Cleanup
allows you to improve document quality while it is scanned.

Despeckle
opens the Cleanup dialog box that contains despeckling and smoothing options.

View Control
specifies how the scanned document is displayed in Eroiica.
Rotation
specifies a rotation factor of 0, 90 CW (clockwise), 90 CCW (counter-clockwise), or 180 degrees.
Mirror
when selected, flips the new document from left to right before it is displayed. Mirroring is applied before 
Rotation is.
Invert
when selected, exchanges foreground and background tones in the new document before it is displayed
in Eroiica.

Scroll Window check box
when selected, the Scroll window is displayed. It shows a pixel-level view of the document as it is being 
acquired. Deselect it to increase scanning speed.

Scroll Window
selects a display orientation of Wide or Tall for the Scroll window.

Windows
configures the display of the TruScan 500 Scan window.
Overview Window
when selected, the Overview window is displayed. It shows a reduced-scale version of the document as 
it is being acquired from the scanner. It always appears dimmed for Grayscale Output.



Auto Name
configures the automatic naming of scanned documents.
Enable Auto Name
When Enable Auto Name is selected, a file name is automatically created for each document.
File Template
defines a pattern used to generate file names. The template is any valid MS-DOS file name (without 
directory path and extension) that contains at least one wildcard character (#, @, or &). Wildcards have 
the following influence on automatically generated file names.
# = numerical series 0 - 9
@ = alphabetical series A - Z
& = alphanumeric series 0 - 9 then A - Z
Start Count
is the first set of numbers or letters to substitute for the wildcards. They must match the wildcard format.

See also
Scan window. 



Cleanup dialog box

The Cleanup dialog box specifies values for improving the quality of the scanned document.

Bi-Level
For Bilevel Output, it allows you to despeckle the document while it is scanned.
Size of Speckle
defines the maximum size of speckle (group of pixels) to remove from the scanned document.

Grayscale Smoothing Mode
allows you to improve the display of grayscale documents while they are scanned.
Smoothing
when selected, specifies a smoothing matrix of 3x3, 5x5, or 7x7.



Scan Setup dialog box

The Scan Setup dialog box selects the scanner to use.

Scanner
specifies the scanner to use.
Scan Driver
indicates the scan driver name for your scanner.
Options...
opens the Scan Options dialog box for the selected scanner.

See also
Scan Setup Options - TruScan 500
Scan Setup Options - TruScan 800



Scan Setup Options - TruScan 800

This dialog box selects options relating to the scanner configuration and to run certain scanner tests.

SCSI Control
defines the SCSI card settings.
Auto SCSI Address Detect
When this option is selected, the program automatically finds the address of the scanner on the SCSI 
(Small Computer System Interface) bus. Selecting this is a little slower than specifying the address 
yourself, and if you have two scanners connected, the program only finds the first one.
SCSI Address
becomes active when the Auto SCSI Address Detect check box is cleared. Enter the address of the 
scanner on the SCSI bus.

Diagnostics
runs tests to ensure your scanner is working properly.
Full System Test
initiates a test process that directs the scanner to conduct various internal test routines. The results of 
the test are displayed.
Motor Speed...
opens a dialog box that asks you to feed the test pattern into the scanner. Follow the dialog box 
instructions and click OK. The test runs.
Stitch...
opens a dialog box that asks you to feed the test pattern into the scanner. Follow the dialog box 
instructions and click OK. The test runs.

Correction
use this section to change values if the tests recommend it.
Motorspeed
Select this button to correct motor speed,
Tilt
Select this button for other problems.

See also
TruScan 800 Scan Window
Scan Window Options - TruScan 800



Motor Speed Correction dialog box

This function calculates a manual value and overrides the automatic motor speed correction.
Expected Distance
Enter the expected distance in inches between two endpoints from your original document.
Measured Distance
Enter the measured distance in inches between the same two endpoints after a scan of the document.



Tilt Correction dialog box

Tilt correction is used to eliminate small errors in the scanner or the printer.
Width of Document
Enter the width of the document in inches.
Amount Diverged
Enter the amount the corners diverged in the vertical axis in inches.



Scan Setup Options - TruScan 500

This dialog box selects options relating to the scanner configuration and to run certain scanner tests.

AT Board Host Control
defines the information required by the AT interface board.
Memory Address
gives the memory address for the AT interface board.
IO Address
gives the IO (input/output) address for the AT interface board.
Interrupt
gives the Interrupt address for the AT interface board.

Diagnostics
runs tests to ensure your scanner is working properly.
Full System Test
Reserved for future use.
Motor Speed
opens a dialog box that asks you to feed the test pattern into the scanner. Follow the dialog box 
instructions and click OK. The test runs.
Stitch
opens a dialog box that asks you to feed the test pattern into the scanner. Follow the dialog box 
instructions and click OK. The test runs.

Correction
use this section to change values if the tests recommend it.
Motorspeed
Select this button to correct motor speed.
Tilt
Select this button for other problems.

See also
TruScan 500 Scan Window
Scan Window Options - TruScan 500



Message boxes

The following is an alphabetical listing of Eroiica error messages.
A Document File name must be entered.
Reason You pressed ENTER when the File Name text box of a save or export dialog box was 

blank.
Action Type a file name in the File Name text box or click Cancel to close the dialog box without 

saving.

Allowable error count exceeded, read aborted
Reason The document will not load because it contains too many errors.

Blanks are not allowed in a file name.
Reason The file name you typed contains a blank space. File names must conform to MS-DOS 

standards (even in Windows 95).
Action Remove the blank space, and keep the file name to a maximum of eight characters, plus 

a three-letter extension.

Cannot deskew: width or length exceeds 16000 pels.
Reason The document is too tall or wide to deskew.
Action Resize the document first, then deskew it.

Cannot invoke device driver setup. Please try to setup printer through Control Panel.
Reason The printer is not properly configured.
Action Try to set up the printer through Control Panel or use the remote printing procedure.

Cannot load file-name. File corrupted.
Reason The document you are trying to load is damaged.
Action If a backup of the document exists, try loading that instead.

Cannot load file-name. File corrupted or file is not a format.
Reason The document you are trying to load is damaged or unsupported.
Action If a backup of the document exists, try loading that instead or try translating the document

to a different format in a graphics program or with a translation utility.

Cannot open document.
Reason You have selected a document through the File menu that has moved or been deleted.
Action Try to open the document using the File, Open command instead.
Cannot read from drive A (or drive B).
Reason You opened an document from your disk drive, removed the disk, then tried to print the 

document. This problem will occur with any Windows program.
Action Put the disk back in the disk drive, and then print the document.
Chain length must be between 1 and 30, inclusive.
Reason You have entered a number larger than 30 or smaller than 1 in the Speckle Size text box.
Action Type an integer between 1 and 30.

Chosen file file-name is not a signature file.
Reason The file named as the signature file contains no signature information.
Action Locate your signature file (called EROICA.SIG by default) and make sure it is being found

by Eroiica. Put it in the same directory as EROICA.EXE.

Compound Document Set is empty.
Reason The CDS document you selected contains no documents and so cannot open.

Data type data-type found in header is unknown.
Reason Eroiica did not recognize the header data and so did not load the document.



Action Try to convert the document using a graphics program or a translation utility.

dir is not a valid directory.
Reason The directory you have specified in File Formats is invalid.
Action Select a valid (available) directory path instead.

Document cannot contain pages/layers from other directories.
Reason You have tried to save a page in the CLF format or a multipage in the DAS format that 

contains layers or pages in a different directory location.
Action Change the drive and directory of all layers or pages that constitute the CLF or DAS 

document so that all are in the same location as the CLF or DAS document. Alternatively, 
you can save the page or multipage under the SMF format.

Drawing extents too large to adjust offset. Setting y offset to be zero.
Reason The DXF or DWG document you are loading has vertical minimum extent values that 

would make the document too large for the scaleable space of Eroiica.
Action None required. Eroiica changes the vertical offset value to 0.

Entered scale value is invalid. Please try again.
Reason The relative scale value you have typed contains letters, wildcards, or is otherwise 

invalid.
Action Type a standard numerical value instead.

Entity dependent on external reference, some or all entities may be omitted.
Reason The DXF document you are trying to load makes reference to other objects or files that 

may or may not be present. Eroiica displays as much of the document as it can.

Error updating new data for window.
Reason The document cannot be correctly redrawn.
Action Try using the View, Refresh command. If the document remains messy, try saving and 

reloading the document.

Error while reading file-name header format. Bad file or incorrect options in header.
Reason The document you tried to open is damaged or its header is inaccurate.
Action If a backup copy of the document exists, try loading that instead.

Extremely low memory condition (x Kbytes available). Unable to continue operation. Please close
some documents/applications.
Reason Eroiica cannot allocate enough memory to continue processing.
Action Close some windows or programs. Select the Minimize Resources check box in the 

Optimizations Options dialog box.

Failed decrypting the given signature file.
Reason The signature file (EROICA.SIG) is damaged.
Action Contact Eroiica Customer Support.

Failed to open font file. Please check if fonts directory is under system directory.
Reason Your FONTS directory must be located just under your system directory--the directory 

that contains EROICA.EXE. For example: C:\DOCUMENT\FONTS.
Action If the FONTS directory is located elsewhere, move it to below the system directory.

Failed trying to load the preview image.
Reason The document selected was saved with a preview image, which Eroiica was unable to 

load.
Action Speed may be affected, but otherwise Eroiica will display the document correctly even 

without the preview image.

Failed trying to read the file file-name, file corrupt or truncated.



Reason The document you want to open is damaged.
Action If a backup copy of the file exists, try loading that instead.

File contains unsupported data type. Data type unknown.
Reason The document you have tried to open contains data that Eroiica does not recognize.
Action Try translating the document using a graphics program or a translation utility.

File file-name. Invalid file type for import operation.
Reason You have selected a page, multipage, or set document in the Layer Import dialog box.
Action Select only layer files (raster, vector, or text) for import.

File file-name is not writeable.
Reason You have tried to save a document without specifying a file name, but just a directory 

path.
Action Type a file name at the end of the directory path in the File Name text box.

File file-name. Unknown type or failed in identification.
Reason Eroiica does not recognize one of the documents you tried to open.
Action Try to convert the document using a graphics program or a translation utility.

File is of unknown format and cannot be read.
Reason The document you have tried to open contains data that Eroiica does not recognize.
Action Try translating the document using a graphics program or a translation utility.

File open failed -> Attempt to load file-name as a raster file.
Reason For some reason Eroiica was unable to load the selected document.
Action See how the document looks when opened as a raster file. Consider converting it.

File width of value exceeds maximum width of value. Cannot display image.
Reason The document is too wide to load. This is much more likely to happen with color 

documents than with bilevel.

'File-name' is not a legal file name.
Reason When saving a document, you have specified a file name that does not conform to MS-

DOS standards (even in Windows 95).
Action Limit the file name to eight characters (no spaces), plus an extension of up to three 

letters.

Image contains non-compliant CCITT Group IV data that may cause errors when loading. Do you 
want to continue? (Yes/No)
Reason The CCITT Group 4 image data is not strictly compliant.
Action You can continue, but the document may not display completely accurately.

Image contains unsupported data types.
Reason The document contains data that Eroiica cannot read.

Image size is too large for this version, contact sales for upgrade.
Reason The raster document is too large for the edition of Eroiica that you have.
Action Contact your sales representative to get a different edition of Eroiica that can handle 

larger files.

Insufficient memory.
Reason Eroiica lacks the memory required to perform the action requested.
Action Close some windows or other programs. Select the Minimize Resources check box in 

Optimizations Option dialog box.

Internal point buffer exceeded, object truncated.
Reason The object has become too large for Eroiica to handle.



Action The object is truncated. You can draw a new object.

Invalid output format detected in preferences. Resetting to system default value.
Reason While editing the EROICA.INI file, you have specified an Output Raster Extension 

number that does not exist.
Action To avoid getting that message every time, go to the [File] section of the EROICA.INI file. 

Change all Output Raster Extension numbers to valid format numbers (roughly between 1
and 64). If that seems too difficult, just delete the Output Raster Extension keynames 
completely. Eroiica will automatically rewrite them with valid entries the next time you 
save the file preferences.

Invalid type extension 'ext'.
Reason You have entered an extension containing wildcards in the File Formats Options dialog 

box.
Action Change the specified extension to make it conform to MS-DOS standards, even in 

Windows 95.

Invalid width or length
Reason Either the Width or the Length value is too large for the crop size you have just defined.
Action Enter smaller values for the Width and Length in the Crop Formats Options dialog box.

Low GDI resources. Bytes free. Close some windows to free up GDI resources. Do you want to 
continue?
Reason Your computer is very low on available memory.
Action Do not continue. Close as many windows and programs as you can. You may even want 

to restart Eroiica.

Low memory warning: You have x Kbytes of memory available. Recommended amount for a 
Crop is y Kbytes. Continue with Crop? (Yes/No)
Reason The amount of memory available may be insufficient for cropping the document.
Action If the document to crop is small, you can proceed. Otherwise, select "No" and close some

windows or programs before trying again.

Low memory warning: You have x Kbytes of memory available. Recommended amount for a 
Deskew is y Kbytes. Continue Deskew? (Yes/No)
Reason The amount of memory available may be insufficient for deskewing the document.
Action If the raster is small, you can proceed. Otherwise, select "No" and close some windows 

or programs before trying again.

Low memory warning: You have x Kbytes of memory available. Recommended amount for a 
Despeckle is y Kbytes. Continue with Despeckle? (Yes/No)
Reason The amount of memory available may be insufficient for despeckling the document.
Action If the document to despeckle is small, you can proceed. Otherwise, select "No" and close

some windows or programs before trying again.

Low memory warning: You have x Kbytes of memory available. Recommended amount for a 
Merge is y Kbytes. Continue with Merge? (Yes/No)
Reason The amount of memory available may be insufficient for merging the layers.
Action If the documents to merge are small, you can proceed. Otherwise, select "No" and close 

some windows or programs before trying again.

Low memory warning: You have x Kbytes of memory available. Recommended amount for a New
Layer is y Kbytes. Continue with New Layer? (Yes/No)
Reason The amount of memory available may be insufficient for creating a new edit layer.
Action If you proceed, be aware that you may run out of memory shortly. Otherwise, select "No" 

and close some windows or programs before trying again.

Low memory warning: You have x Kbytes of memory available. Recommended amount for 



document load is y Kbytes. Continue loading document? (Yes/No)
Reason The amount of memory available may be insufficient for opening the document.
Action If the document is small, you can proceed. Otherwise, select "No" and close some 

windows or programs before trying again.

Low memory warning: You have x Kbytes of memory available. Recommended amount for Paste 
is y Kbytes. Continue with Paste? (Yes/No)
Reason The amount of memory available may be insufficient for pasting onto the edit layer.
Action If the paste is small, you can proceed. Otherwise, select "No" and close some windows or

programs before trying again.

Low memory warning: You have x Kbytes of memory available. Recommended amount for Raster
is y Kbytes. Continue with Raster? (Yes/No)
Reason The amount of memory available may be insufficient for changing the attributes of the 

raster.
Action If the document to alter is small, you can proceed. Otherwise, select "No" and close some

windows or programs before trying again.

Low memory warning: You have x Kbytes of memory available. Recommended amount for this 
read is y Kbytes. Continue with Read? (Yes/No)
Reason The amount of memory available may be insufficient for reading the document.
Action If the document is small, you can proceed. Otherwise, select "No" and close some 

windows or programs before trying again.

Maximum Number of Crop Sizes is 18
Reason You have tried to define more than 18 crop sizes in the Crop Formats Options dialog box.
Action Limit the total number of crop sizes to 18.

Maximum text string length exceeded.
Reason You have typed in more characters than allowed in a text dialog box.
Action Shorten your text string.

Merge of length number pels will be truncated to number pels. Data on the bottom will be lost.
Reason The document was too long to merge the entire thing.
Action You can try cropping superfluous parts of the document or resizing it before merging it 

again.

Merge of width number pels will be truncated to number pels. Data on the right side will be lost.
Reason The document was too wide to merge the entire thing.
Action You can try cropping superfluous parts of the document or resizing it before merging it 

again.

Missing Label, or X, or Y, or Unit, or Invalid Data
Reason In the Crop Formats dialog box, one of the crop sizes is incompletely or incorrectly 

defined.
Action Check each crop size in the dialog box and correct any errors or omissions that you find.

Must specify a label.
Reason The Label text box of a Export Layer dialog box is blank.
Action Type in a label text string of up to 80 characters.

No installed Windows printers found.
Reason You chose the File, Print command, but Eroiica did not find the active print device.
Action Make sure your printer is properly connected, that it is compatible with Windows (or is set

up for custom printing), and that it is correctly selected and configured.

No objects read from symbol.



Reason The selected symbol file is empty--it contains no vector objects. See: Creating a symbol 
Action Select a different symbol file or create a new one.

Non-compliant pel line progression value
Reason "pel line progression" is a CALS (Computer-aided Acquisition and Logistics Support) term

for a header rotation. A "non-compliant value" is bad or out of spec.
Action The header rotation value is ignored. Eroiica loads the document with a 0 degree 

rotation. Use the View -> Rotate commands if necessary to orient the document properly. 
See: Rotating a document 

Non-compliant resolution of resolution DPI detected. Proceeding with the save will overwrite the 
resolution field with resolution2 DPI. Accuracy may be compromised.
Reason The resolution value of the document is unacceptable.
Action Resave the file in a different format, such as TIFF (Tagged Image File Format).

Only one extension allowed.
Reason You have put a space between characters in defining single Output Extensions in File 

Formats Options.
Action Remove the space between characters. Extensions must be one to three characters long,

with no spaces between them.

Point buffer overflow, object truncated.
Reason The object has become too large for Eroiica.
Action The object is truncated. You can draw a new object.

Present item is a multipage document. Do you wish to enter it?
Reason You have reached embedded pages.
Action Choose Yes to view the embedded pages or No to view the page following or preceding 

the embedded pages.

Preview Image Size value value must be integral.
Reason You have entered a fraction in the Preview Image Size text box in the Optimizations 

Options dialog box.
Action Replace the fraction with an integer value.

Printer printer-name not currently supported.
Reason Eroiica cannot write to the active printer.
Action Contact Customer Support.

Resolution must be between value and value.
Reason You have entered an invalid resolution value in the Merge or Raster Operations dialog 

box.
Action Type a resolution value within the given range.

Security violation. EROICA.SIG missing or corrupted.
Reason The EROICA.SIG file is missing or damaged.
Action Try to locate the EROICA.SIG file and copy it to the system directory, or reinstall Eroiica.

The current object has reached the maximum number of points allowed per object and will be 
truncated. Continue drawing with new object.
Reason The object has become too large for Eroiica.
Action The object is truncated. You can draw a new object.

The deskew angle cannot equal 0.00 degrees.
Reason You pressed ENTER without specifying a skew angle in the Deskew dialog box.
Action Enter a skew angle within the range allowed or press ESC to cancel the deskew.

The deskew angle must be +-value degrees or less.



Reason The skew angle you have defined in the Deskew dialog box s too large.
Action Redefine the skew angle.

The saved layer contains one or more entities that are not compatible with DXF. File may have 
modified or missing entries. See log file.
Reason The DXF document you saved contains objects that are unsupported by DXF.
Action Open the log file (called EROICA.LOG by default) to see what information could not be 

displayed. Remember that DXF files are of the Edit type (no annotations or hotspots 
saved).

The search item was not found.
Reason The document did not contain the text specified in the Find dialog box.
Action Try another text search. Make sure you have not limited it too much with the Whole 

Words Only and Match Case check boxes.

This image contains bad data. Eroiicas integrity may have been compromised. Do you want to 
continue (Yes/No)?
Reason The document you want to open is seriously damaged.
Action If you choose to open it anyway, realize that Eroiica may fail. Most likely, however, the 

document will partially load correctly.

This multipage does not contain any layers.
Reason The SMF document you tried to open is empty.
Action If a backup of the document exists, try opening that instead.

Unable to Create Device Context. Check that printer is properly installed and active.
Reason Eroiica detected some problem with the active printer.
Action Check the printer to make sure it is on, properly connected, and not giving any error 

messages.

Unable to read file file-name, unknown type or corrupt file.
Reason The document you want to open is damaged or unsupported.
Action If a backup copy of the document exists, try loading that instead.

Unable to write to disk. Insufficient disk space.
Reason The storage disk is almost full and cannot accommodate what you are trying to save.
Action Clear up some space on the disk or save the document somewhere else.

Unrecognized file format: file-name
Reason The document you have tried to open cannot be read by Eroiica.
Action Try converting the document using a graphics program or a translation utility.

Unsupported file format variant: variant.
Reason The document you have tried to open is a slight variation on a supported type and cannot

be loaded.

Version in the signature file is incorrect.
Reason The EROICA.SIG file is listing an incorrect version of Eroiica.
Action Reinstall Eroiica or contact Customer Support.

Version of the software does not match version in signature file.
Reason The EROICA.SIG file does not make reference to the available version of Eroiica.
Action Reinstall Eroiica.

You do not have permission for the chosen operation.
Reason The permissions attributed to you through the API or the EROICA.SIG file prevent you 

from carrying out the command you chose.



Action Talk to your System Administrator if the permissions assigned seem incorrect, or contact 
Customer Support.

You do not have permission to view the chosen file.
Reason The document is protected and only users who have been given access to it can view it.
Action Contact your System Administrator if you require access to this document.



The EROICA.INI File

The initialization file for Eroiica is called EROICA.INI (by default), and it is often stored in the same 
directory as EROICA.EXE. If an EROICA.INI file is not found, then Eroiica creates a new one.
System defaults are stored in EROICA.INI. While many are set using Options (and a few other) dialog 
boxes, others require that you edit the EROICA.INI file itself. To do so, follow this procedure.
1. Exit and close Eroiica. Start any ASCII Text editor (such as Notepad).
2. Open the EROICA.INI file.
3. Edit the file as required, keeping in mind that many keynames are case-sensitive.
4. Save the file.
5. Quit the Text editor.
6. To activate the changes in Eroiica, restart Eroiica.

Help is provided for all EROICA.INI file entries that do   not   correspond to any Options or other dialog box  
setting. Click the name of the Section to get a description of each editable keyname in that section.

Section Contains
[Initial Window] Defaults relating to the Eroiica window
[User Interface 
Preferences] 

Defaults relating to icons, system colors, and placing certain 
objects

[System] General options such as display fonts, optimizations, and 
dialog box definitions

[Locale] Defines the default unit and any custom units
[File] Loading, rendering, and saving documents
[XRef Paths] The location of external references in DGN and DWG 

documents
[Most Recently 
Used]

The number and name of the most recently viewed 
documents

[View] Document display attributes
[HPGL] Defaults for loading HPGL-format documents
[FormattedText] Text documents defaults
[Tool] Default object attributes
[Dashed Lines] Line and frame style options
[AutoRun] Other programs that start automatically when Eroiica starts
[Utilities] Defines crop size and despeckle defaults
[Print] Printing defaults, mostly for remote printing
[PlotDevices] Names of non-standard printers
[  printer-driver  ]  Configuration of each non-standard printer
[Fax] Remote faxing configuration

The information in the EROICA.INI file is formatted as follows.
[Section A]
keyname1=value
keyname2=value
and so on

Note: The exact name and location of the INI file is specified in the [Eroiica] section of the WIN.INI file, 
with the INI Filename keyname. In the Help, we assume its name is EROICA.INI.





[Initial Window]

The [Initial Window] section of the EROICA.INI file determines whether certain screen elements appear 
automatically when you start Eroiica. It also defines the size and location of the Eroiica window itself. If 
"Save=1" in this section, all keynames in it other than Logo are saved on quit.
Keynames that cannot be modified by resizing, moving, showing, or hiding a window or bar are 
described in this Help topic. You have to edit the EROICA.INI file to change them. How to edit the 
EROICA.INI file Restart Eroiica to activate the changes.

Floating Reference Window=0 | 1
Purpose Defines whether the Reference window is a floating window or a child window.
Values 0 = The Reference window is a child window, a view option of active document window. 

You cannot move it outside the document window. It closes when its parent document 
window does.
1 = The Reference window is a floating window that you can move anywhere on the 
desktop. You can display it even if no document windows are open. When displayed, it 
stays open even if all document windows close.

Default 1
See also Using the Reference window 

Logo=0 | 1
Purpose Determines whether the Eroiica Logo appears on startup.
Values 0 = Do not display the Eroiica Logo on startup.

1 = Display the Eroiica Logo on startup.
Default 1

ribbon window type=1 | 2 | 3 | 4 | 5
Purpose Defines the location of the Standard Toolbar (the bar or floating window that contains file, 

edit, view,    and floating windows icons) in the Eroiica window.
Values 1 = Top ribbon

2 = Bottom ribbon
3 = Right ribbon
4 = Left ribbon
5 = Floating view ribbon

Default 1

Save=0 | 1
Purpose When set to 1, all other keynames in this section other than Logo are saved on quit. 

These keynames define the display of the Standard Toolbar, Drawing Toolbar, Status Bar,
Reference window, Detail window, Eroiica Contents window, Line Width window, 
Measurements window, Symbol palette, and Eroiica main window, 

Values 0 = Do not save settings on quit.
1 = Save settings on quit.

Default 1

tool window type=1 | 2 | 3 | 4 | 5
Purpose Defines the location of the Drawing Toolbar (the bar or floating window that contains 

drawing icons) in the Eroiica window.
Values 1 = Top ribbon

2 = Bottom ribbon
3 = Right ribbon
4 = Left ribbon
5 = Floating tool box



Default 4

See also
Showing and hiding Toolbars and floating windows 
Changing the location of the Standard Toolbar and Drawing Toolbar 



[User Interface Preferences]

Use this section to change the size of the Standard Toolbar and Drawing Toolbar icons and to change 
their background color. This section also defines the default color of lines around selected objects, the 
color of bandy controls, and whether text objects are placed directly on an edit layer or through a dialog 
box. Editing the EROICA.INI file Restart Eroiica to activate the changes.

Button Size=1 | 2 | 3
Purpose Defines the size of the icons in the Standard Toolbar and the Drawing Toolbar.
Values 1 = small icons

2 = medium icons
3 = large icons

Default 1

Idle Sketch Lag Time=Time
Purpose Specifies the time, in milliseconds, that the mouse must be idle before sketching the 

object being placed. It applies to paste, symbol, resize, rotate, and move. Use it to 
preview the placement of these objects.

Values Any value in milliseconds. To disable this function, use 0.
Default 150

SketchTool Colour=0 | 1 | 2 | ... | 15 or RRR,GGG,BBB
Purpose Defines the color of the bandy controls used in certain tools, such as polylines.
Values Any color from 0 (background) to 15 (foreground). Color options 

or
Any combination of a red value (0 to 255), a green value (0 to 255), and a blue value (0 to
255), each separated by a comma, where 0 means no color and 255 means the 
maximum amount of that color. Tip 

Default 255,0,0 (red)
See also Drawing a polyline 

Use Dialog for Text Entry=0 | 1
Purpose Defines whether text is placed on edit layers through dialog boxes or by being typed 

directly on the layer.
Values 0 = place text directly on the edit layer.

1 = place text through a dialog box.
Default 1
See also Placing text 



[System]

The keynames in this section affect the overall operation of Eroiica and are supplementing the ones that 
are set in the Optimizations Options dialog box.
You modify the rest of the keynames by editing the EROICA.INI file. How to edit the EROICA.INI file 
They are described below. To activate the changes, click Load defaults in the System Options dialog box
or restart Eroiica.

Allow Single-Layer Page Files=0 | 1
Purpose When set to 1, single layers are saved under the CLF or the SMF (using File -> Save and

File -> Save As).
Values 0 = CLF and SMF are not options for single layers.

1 = Single layers are saved under the CLF or SMF format.
Default 1
See also Saving a page 

Attribute Prompt On Create=0 | 1
Purpose When set to 1, the user is asked to assign a label on creation of a layer or a page.
Values 0 = normal layer and page creation

1 = layer and page creation automatically followed by a prompt for a label name
Default 0
See also Creating an edit layer; Creating a page 

Dialog Box Font=font-name
Purpose Defines the font used in dialog boxes.
Values The name of any TrueType or printer font available on your system.
Default Arial

DPI=resolution
Purpose Overrides the Windows-defined screen resolution (visible screen width in pixels divided 

by measured real screen width in inches).
Values Any valid integer in dots per inch (DPI). Delete this line or use value of 0 to use Windows 

default value for the frame window device context.
Default Windows default, typically 96 DPI

Fast Load Size Thr=Size
Purpose Defines a threshold beyond which raster documents are stored in the Group 4 format. 

Documents smaller than the specified size are stored in a simple, compressed format that
uses more memory, but is also faster to load. This setting is not used when the Minimize 
Resources check box is selected in Optimizations Options.

Values Document size in squared inches.
Default 160
See also Optimizing raster speed; Optimizations Options dialog box    

Flag Dirty Doc=0 | 1
Purpose Defines whether modified or new documents are indicated by an asterisk (*) beside their 

name in the title bar.
Values 0 = Do not flag new or modified documents

1 = Flag new or modified documents with an asterisk
Default 0

Font Database=directory-path-name
Purpose Specifies the directory where Fonts.fdb database will be located.



Value Any valid path name (disk and directories).
Default EROICA.EXE directory.

Font Search Path=directory-path-name
Purpose Specifies the directory path that is searched for shape fonts (that are contained in some 

AutoCAD files), in addition to the Eroiica FONTS directory.
Value Any valid path name (disk and directories).
Default None
See also Displaying shape fonts in AutoCAD files 

Highlight Box Colour=0 | 1 | 2 | … | 15
Purpose Defines the color of the crossed box in the Reference window.
Values Any color from 0 (background) to 15 (foreground). Color options 
Default 10
See also Using the Reference window 

Hotspot Icons Location=directory-path-name
Purpose Defines the location of the external DLL (Dynamic Link Library) that contains the hotspot 

icons to use.
Values Any valid path name (disk and directories).
Default None

Log Errors=0 | 1
Purpose Determines whether to create internal error log files, called EROICA.LOG and 

EROICA.BAK by default. These files are located in the directory specified by Log 
Filename keyname in the [Eroiica] section of the WIN.INI file (by default, the system 
directory).

Values 0 = do not log errors
1 = log errors

Default 0

Low Memory Stop Thr=Size
Purpose Determines the threshold at which Eroiica issues an extremely low memory message and

abandons the load document process.
Values Any positive value in kilobytes. We recommend it be set to the Windows minimum 

requirement (1000K) plus the size of the largest typical document with which you expect 
to work.

Default 1800

Low Memory Warning Thr=Size
Purpose Determines the threshold at which Eroiica issues low memory warning messages during 

document loads. After the warning is issued, you are given a chance to proceed with 
loading the current document, skipping the document, or canceling the load.

Values Any positive value in kilobytes. We recommend it be set to the Low Memory Stop Thr 
value, plus the size of the largest typical document you expect to work with, plus 10% of 
that total.

Default 2800
See also Optimizing memory 

Measurement Window Font Face=font-name
Purpose Defines the font used in the Measurements window.
Values The name of any TrueType or printer font available on your system.
Default Arial



Measurement Window Font Size=font-size
Purpose Defines the size of the font used in the Measurements window.
Values Any valid font size in points.
Default 10

Merge Tile Width=width
Purpose Defines the width of the tile used when merging documents.
Values A width value in pixels that is a multiple of 512. To disable tiled merging, use 0.
Default 4096
See also Merging layers 

OverWrite Raster=0 | 1
Purpose Determines the location of the document created with any of the utilities.
Values 0 = place the new document in a new document window.

1 = replace the active document with the new document. You are not warned that the 
active document is being replaced.

Default 0
See also Tools menu commands 

Page Numbering in Dialogs= 0 | 1
Purpose When set to 1, places "Page #" beside the page name in all Page dialog boxes.
Values 0 = Do not display page numbers in dialog boxes.

1 = Display "Page #" beside all page names in dialog boxes.
Default 0

Print Buffer Size=Size
Purpose Defines the size of the memory buffer allocated for storing decompressed data during a 

print job.
Values Any value from 8 to 16384. Use 50% or less of your computer RAM (random access 

memory). Suggested values include 4096, 2048, 1024, 512, 256, 64, and 32. All values 
are in kilobytes.

Default 1024

Print Landscape=0 | 1
Purpose Some printers have difficulty printing in landscape mode, but not in portrait mode. Use 

this keyname to solve that problem.
Values 0 = Normal print.

1 = When landscape orientation is specified in the Print dialog box, the printer prints the 
document at a portrait orientation, but rotates it by 90 degrees. The resulting print 
appears to be landscape but prints correctly.

Default 0
See also Printing the active document 

Status Bar Font=font-name
Purpose Defines the font used in the Status bar.
Values The name of any TrueType or printer font available on your system.
Default System

Text Greeking Threshold=height
Purpose Defines the point at which vector text is drawn as blocks instead of characters. When text

is blocked, it is faster to display.
Values Any integer that represents the text height in screen pixels at which the text is Greeked.
Default 2



See also Optimizing vector performance 

Unload Max=number
Purpose Defines how many pages of multipage documents are unloaded when they are not being 

viewed.
Values 0 = Keep all pages loaded.

1 = Unload all pages but the current one.
Any other integer ("n") = Unload all pages but the current one and the last ("n" - 1) pages 
viewed.

Default 9
See also Speeding multipage display 

Use CTL3D DLL=0 | 1
Purpose Determines whether all dialog boxes are displayed with three-dimensional shading (color 

screens only).
Values 0 = Dialog boxes are displayed without shading.

1 = Dialog boxes are displayed with three-dimensional shading.
Default 1

Use ODMA=0 | 1
Purpose Defines whether Eroiica uses ODMA (Open Document Management API) if it is available.
Values 0 = Do not use ODMA, even if it is available.

1 = Use ODMA if available.
Default 1

Vector Layer DPI=resolution
Purpose Defines the X (horizontal) and Y (vertical) resolution value of edit layers when no raster 

layer is present. (If a raster layer is present, its resolution is used.)
Values Any valid integer in dots per inch.
Default 200
See also Creating an edit layer; Importing layers 



[Locale]

All [Locale] section keynames are modified using the Measurement Options dialog box.



[File]
The [File] section keynames affect the loading and saving of documents and are supplementing the 
ones that are set in the File Formats Options dialog box and the File Extensions dialog box.
Modify the following keynames by editing the EROICA.INI file. How to edit the EROICA.INI file They are 
described below. To activate the changes in Eroiica, click Load defaults or restart Eroiica.

AutoTrol Input Auto Scale=0 | 1
Purpose Defines the scaling mode for all AutoTrol-format vector documents.
Values 0 = Use the value defined in the AutoTrol Input Scale Factor keyname.

1 = On open, scale the AutoTrol documents to E-size (34 x 44 inches). On layer import, 
scale the AutoTrol documents to fit over the underlying document.

Default 1

AutoTrol Input Scale Factor=multiplier
Purpose Defines the scale factor used for loading AutoTrol-format files that are not automatically 

scaled.
Values Any real number.
Default 1.00

AutoTrol Input Units=1 | 2
Purpose Determines the scale units used for mapping incoming AutoTrol-format files.
Values 1 = inches

2 = centimeters
Default 1

CGM Input Auto Scale=0 | 1
Purpose Defines the scaling mode for all CGM-format vector documents.
Values 0 = Use the value defined in the CGM Input Scale Factor keyname.

1 = On open, scale the CGM documents to A-size (8½ x 11). On layer import, scale the 
CGM document to fit over the underlying document.

Default 1

CGM Input Scale Factor=multiplier
Purpose Defines the scale factor used for loading CGM-format documents that are not 

automatically scaled.
Values Any real number.
Default 1.00

CGM Input Units=1 | 2
Purpose Determines the scale units used for mapping incoming CGM-format files.
Values 1 = inches

2 = centimeters
Default 1

DGN Input Auto Scale=0 | 1
Purpose Defines the scaling mode for DGN-format vector documents.
Values 0 = Use the value defined in the DGN Input Scale Factor keyname.

1 = On open, scale the DGN documents to E-size (34 x 44 inches). On layer import, scale
the DGN document to fit over the underlying document.

Default 1

DGN Input Scale Factor=multiplier
Purpose Defines the scale factor used for loading DGN-format documents that are not 

automatically scaled.



Values Any multiplier of the original scale value. 40960 suffices for most drawings.
Default 40960

DGN Load Stroke 2D Object=0 | 1
Purpose Defines whether DGN elements such as arc, circle, polygon, and ellipse are converted to 

the corresponding EDT objects.
Values 0 = Convert arcs, circles, polygons, unrotated ellipses, and other DGN elements to the 

corresponding EDT objects.
1 = Simulate all DGN elements with polylines. Do not convert them to EDT objects.

Default 0

DGN Load Stroke FONTS=0 | 1
Purpose Defines whether the stroke fonts in DGN files are rendered as fonts that can be 

remapped, or are simulated with polylines.
Values 0 = Display DGN stroke fonts using TrueType fonts, which can be remapped.

1 = Simulate DGN stroke fonts with polylines.
Default 0

DXF Input Auto Scale=0 | 1
Purpose Defines the scaling mode for reading DXF-format and DWG-format vector documents.
Values 0 = Use the value defined by DXF Input Scale Factor.

1 = On open, scale the image to E-size (34 x 44 inches). On layer import, scale the DXF 
image to fit over the underlying document.

Default 1

DXF Input Scale Factor=multiplier
Purpose Determines the scale values used for mapping incoming DXF and DWG files that are not 

automatically scaled.
Values Any real number.
Default 1.00

DXF Input Units=1 | 2
Purpose Determines the scale units used for mapping incoming DXF and DWG files.
Values 1 = inches

2 = centimeters
Default 1

DXF Output Scale Factor=multiplier
Purpose Factor or multiplier used for writing DXF files.
Values Any real number.
Default 1.00

DXF Output Units=1 | 2
Purpose The scale value units used for writing DXF files.
Values 1 = inches

2 = centimeters
Default 1
See also Setting save defaults 

GenericG4 X=offset, resolution, width, length
Purpose Defines the formatting of certain Group 4 raster documents. Up to 100 of these keynames

are admitted.
Values X = value from 0 to 99

offset = the position where the data in the file starts



resolution = the document resolution in dots per inch (dpi)
width = the document width in pixels
length = the document height in pixels

Defaults None

IGS Input Auto Scale=0 | 1
Purpose Defines the scaling mode for all IGS-format vector documents.
Values 0 = Use the value defined in the IGS Input Scale Factor keyname.

1 = On open, scales the IGS documents to E-size (34 x 44 inches). On layer import, 
scales the IGS document to fit over the underlying document.

Default 1

IGS Input Scale Factor=multiplier
Purpose Defines the scale factor used for loading IGS-format documents that are not automatically

scaled.
Values Any real number.
Default 1.00

IGS Input Units=1 | 2
Purpose Determines the scale units used for mapping incoming IGS-format documents.
Values 1 = inches

2 = centimeters
Default 1

MI Input Auto Scale=0 | 1
Purpose Defines the scaling mode for all MI-format vector documents.
Values 0 = Use the value defined in the MI Input Scale Factor keyname.

1 = On open, scales the MI documents to E-size (34 x 44 inches). On layer import, scales
the MI documents to fit over the underlying documents.

Default 1

MI Input Scale Factor=multiplier
Purpose Defines the scale factor used for loading MI-format documents that are not automatically 

scaled.
Values Any real number.
Default 1.00

MI Input Units=1 | 2
Purpose Determines the scale units used for mapping incoming MI-format documents.
Values 1 = inches

2 = centimeters
Default 1

Multipage Output Format=0 | 1
Purpose Defines the format used by default when saving multipage documents.
Values 0 = DAS

1 = SMF
Default 0
See also Setting save defaults 

OCR Region Raster Format=format-number
Purpose Defines the file format of selected OCR (Optical Character Recognition) regions. It is 

used only in versions of Eroiica integrated with an OCR program.
Values Any appropriate raster format number.



Default 3 (TIFF--Tagged Image File Format)

Open Mode=0 | 1 | 2 | 3 | 4 | 5 | 6
Purpose Determines which document type to list by default in the List Files of Type box in open, 

add, and import dialog boxes.
Values 0 = Sets 1 = Documents

2 = Raster files 3 = Text documents
4 = Vector files 5 = Symbol documents
6 = All files

Default 6
See also Setting open defaults 

Output Vector Format=100 | 102 | 112
Purpose Defines the document format used by default when saving edit layers.
Values 100 = EDT

102 = AutoCAD Data Exchange Format (DXF)
112 = Windows Metafile (WMF)

Default 100
See also Setting save defaults 

Retain Last Active Symbol=0 | 1
Purpose Allows the symbol last selected to be automatically saved for future sessions.
Values 0 = Symbol last selected is only saved for future session if the tool preferences are saved

(with the Save button or on quit).
1 = The symbol last selected is saved automatically. When Eroiica is restarted, the same 
symbol remains selected.

Default 0
See also Selecting and placing a symbol 

Temp Dir=directory-path-name
Purpose Specifies the temporary document directory. If not set, Eroiica looks first at the TEMP and

then at TMP environment variables.
Values Any Read/Write directory path.
Default None
Notes This keyname value cannot be saved.



[XRef Paths] section

This section defines a possible location for external references in vector documents.
When a DGN, DXF, or DWG document contains an external reference, Eroiica looks for it in the 
following order:
1. According to the document name specified in the originating DGN or DWG document.
2. In the directory the originating document came from.
3. In one of the format-specific directories specified in this section.
4. In the system search path, also specified in this section.
5. If it is a DWG file, in the ACAD directory.

You set all of these keynames by editing the EROICA.INI file. How to edit the EROICA.INI file To activate
the changes, restart Eroiica.

Format IDs=format-number,format-number,...
Purpose Defines the document formats that can contain external references for which to search.
Values In this release, only DGN, DXF, and DWG are supported. Formats are indicated by their 

API format numbers.
Default None
Example Format IDs=505,508

format-number=directory-path-name
Purpose Defines the directory path that Eroiica searches for that particular file format. You can 

specify a different location for each supported format. You can also indicate more than 
one path for each format.

Values Any available directory path. Separate each different path by a semicolon.
Default None
Example 508 = C:DGN\XREFS;C\:DGN

505 = D:\DWG\XREFS;D:\DWG

0=directory-path-name
Purpose Defines the directory path that Eroiica searches if all other attempts to locate the external 

reference have failed.
Values Any available directory path. You can indicate more than one path. Separate each by a 

semicolon.
Default None
Example 0=C:\XREFS;D:\XREFS



[Most Recently Used] section

This EROICA.INI section contains one keyname that you can modify. How to edit the EROICA.INI file To 
activate the changes, restart Eroiica.

max in list=0 | 1 | 2 | ... | 10
Purpose Defines the number of previously opened documents to list in the File menu in reverse 

chronological order.
Values 0 = List no document names.

1 = List the previously opened document.
2 = List the two previously opened documents.
"n" = List the "n" previously opened documents (where "n" = any integer from 3 to 10).

Default 5
The remaining keynames in this section list the names of the previously opened documents. They are 
updated automatically as you open documents.

See also
Reopening documents 



[View]

The keynames in the [View] section affect the initial display of documents in Eroiica and are 
supplementing the ones that are set in the View Options dialog box.
Modify the remaining keynames by editing the EROICA.INI file. How to edit the EROICA.INI file To 
activate the changes in Eroiica, click Load defaults in the View options dialog box or restart Eroiica.

Detail Scale=floating-number
Purpose Defines the scale at which the Detail window initially displays the pointer location.
Values Any floating number between 0.010 and 250
Default 1.0 (1:1 scale)
See also Using the Detail window 

Highlight Hotspot Range=Size
Purpose Defines a distance from the pointer within which hotspots are highlighted and can be 

activated. Use it only when Single Click Activation=1.
Values Any distance value in screen pixels.
Default 0 (disables highlighting)
See also Activating hotspots

Single Click Activation=0 | 1
Purpose Defines whether a single or a double click is required to activate a hotspot and change 

the annotation shape. Also defines whether the Zoom command appears in the View 
menu.

Values 0 = double click, Zoom command does not appear.
1 = single click, Zoom command appears.

Default 0
See also Activating hotspots; Viewing annotations

Zoom Step=floating-point-number
Purpose Sets the amount zoomed when the Enlarge or Reduce command is chosen.
Values Any value that represents the amount of current view by which to magnify or reduce the 

document.
Default 2.25
See also Magnifying and reducing the document



[HPGL]

This section defines the appearance of the pen lines used in plotter documents with simple pen lines, 
such as HPGL documents, and the scaling of these documents. You modify the following keynames by 
editing the EROICA.INI file. How to edit the EROICA.INI file To activate the changes, restart Eroiica.

HPGL Input Scale=0 | 1
Purpose Defines whether the keynames in this section are used. We recommend you use them.
Values 0 = Ignore the keynames in this section

1 = Use the keynames in this section
Default 1

Pen X=value units color
Purpose Defines the width, units, and color of Pens 1 through 256 for HPGL-format documents.
Values X = integer from 1 through 256

value=width of pen line
units=1 for inches or 2 for centimeters
color=RGB value corresponding to the pen color you want. Tip 

Defaults Pen 1=0.0 1 255,255,255
Pen 2=0.0 1 255,0,0
Pen 3=0.0 1 0,255,0
Pen 4=0.0 1 255,255,0
Pen 5=0.0 1 0,0,255
Pen 6=0.0 1 255,0,255
Pen 7=0.0 1 0,255,255
Pen 8=0.0 1 194,194,194
Pen 10=0.0 1 255,0,0
…
Pen 256=0.0 1 255,255,0

Note Modify Pens 1 through 8 using the Vector Pens Options dialog box. The rest require 
EROICA.INI file editing. Note that if pen values are stored in the HPGL document, they 
are applied. Otherwise, the EROICA.INI Pen X values are used.

PortX1=number
Purpose Together with PortY1, defines the lower left edge of the plotter coordinates for the device 

that the HPGL file was plotted to.
Values See table in "Loading HPGL files" topic.
Default -21072

PortX2=number
Purpose Together with PortY2, defines the upper right edge of the plotter coordinates for the 

device that the HPGL file was plotted to.
Values See table in "Loading HPGL files" topic.
Default 21072

PortY1=number
Purpose Together with PortX1, defines the lower left edge of the plotter coordinates for the device 

that the HPGL file was plotted to.
Values See table in "Loading HPGL files" topic.
Default -16472

PortY2=number
Purpose Together with PortX2, defines the upper right edge of the plotter coordinates for the 

device that the HPGL file was plotted to.



Values See table in "Loading HPGL files" topic.
Default 16472

Resolution=dpi
Purpose Defines the resolution of the device that the HPGL document was plotted to.
Values See table in "Loading HPGL files" topic.
Default 1016

See also
Configuring HPGL documents



[FormattedText]

The [FormattedText] section defines how text documents are displayed. The following keynames are set 
in the Text Layout Options dialog box:
(Page) Presentation Show Borders ASCII Template List of Fonts

You modify the keyname listed below by editing the EROICA.INI file. How to edit the EROICA.INI file To 
activate the changes in Eroiica, click Load defaults in the Text Layout Options dialog box or restart 
Eroiica.

Hotspot Trigger String=text-string
Purpose Defines a text string that indicates when a WordPerfect comment or Word for Windows 

annotation is interpreted as a hotspot instead of as an annotation.
Values Any text string.
Default !HOTSPOT!

See also
Placing hotspots in a text document



[Tool]

The [Tool] section keynames correspond to categories of the Draw Options dialog box. These keynames
define the default operation of the edit and markup tools. Listed below are keynames that you modify by 
editing the EROICA.INI file. How to edit the EROICA.INI file

Annotation Iconized=0 | 1
Purpose Determines the default shape of annotations when placed on an edit layer, when the 

Simple Text display option is selected.
Values 0 = annotations are initially placed as text.

1 = annotations are initially placed as icons.
Default 1

Annotation Text Width Units=1 | 2
Purpose Defines the units of measurement for the annotation text width.
Values 1 = thousandths of an inch

2 = thousandths of a centimeter
Default 1

Annotation Text Width Value=Width
Purpose Defines the width of annotation text. It is stored in 4096ths of the width unit.
Values Any positive number that is a multiple of 4096.
Default 409600 (0.1 inches)
See also Setting text attributes 

Arc Capstyle=0 | 1
Purpose This keyname defines the style of arc line ends.
Values 0 = rounded line ends.

1 = squared line ends.
Default 0
See also Using the cap settings 

Arrow Capstyle=0 | 1
Purpose This keyname defines the style of arrow line ends.
Values 0 = rounded line ends.

1 = squared line ends.
Default 0

Dimension Capstyle=0 | 1
Purpose This keyname defines the style of dimension line ends.
Values 0 = rounded line ends.

1 = squared line ends.
Default 0

Dimension Text Typeface=number
Purpose Defines the dimension text attributes.
Values 0 = Normal 1 = Bold

32 = Strikeout 64 = Underline
128 = Italic
Add these numbers to combine styles.

Default 0

Dimension Text Width Units=1 | 2
Purpose Defines the units of measurement for the dimension text width.



Values 1 = thousandths of an inch
2 = thousandths of a centimeter

Default 1

Dimension Text Width Value=Width
Purpose Defines the width of dimension text. It is stored in 4096ths of the width unit.
Values Any positive number that is a multiple of 4096.
Default 409600 (0.1 inches)
See also Setting text attributes 

Highlighter Capstyle=0 | 1
Purpose This keyname defines the style of highlighter line ends.
Values 0 = rounded line ends.

1 = squared line ends.
Default 0
See also Using the cap settings 

Hotspot Data Prompt=0 | 1
Purpose Defines whether a prompt for hotspot data appears when hotspots are placed.
Values 0 = do not display prompt for data.

1 = display prompt for data on hotspot placement.
Default 1
See also Placing a hotspot 

Hotspot Single Line Edit=0 | 1
Purpose Defines whether the Hotspot Data dialog box appears with a multi-line or a single-line text

box.
Values 0 = multi-line text box used in Hotspot Data dialog box.

1 = single-line text box used in Hotspot Data dialog box. Position of dialog box saved.
Default 0
See also Hotspot Data dialog box 

Polyline Capstyle=0 | 1
Purpose This keyname defines the style of polyline ends.
Values 0 = rounded line ends.

1 = squared line ends.
Default 0
See also Using the cap settings 

Rubout Capstyle=0 | 1
Purpose This keyname defines the style of rubout line ends.
Values 0 = rounded line ends.

1 = squared line ends.
Default 0

Sketch Capstyle=0 | 1
Purpose This keyname defines the style of sketch line ends.
Values 0 = rounded line ends.

1 = squared line ends.
Default 0

Text Width Units=1 | 2
Purpose Defines the units of measurement of the text width value.



Values 1 = thousandths of an inch
2 = thousandths of a centimeter

Default 1

Text Width Value=Width
Purpose Defines the width of text. It is stored in 4096ths of the width unit.
Values Any positive number that is a multiple of 4096.
Default 409600 (0.1 inches)
See also Setting text attributes 

See also
Selecting line, frame, and text colors 



[Dashed Lines]

Use this section to define additional line (and frame) styles for selection in the Draw Options dialog 
boxes. You define all of its keynames by editing the EROICA.INI file. How to edit the EROICA.INI file To 
activate the changes, restart Eroiica.

name=0 | 1 1 | 2 +value -value (+value -value ...)
Purpose Defines the line styles available for selection in the Draw Options dialog boxes.
Values name = text string that describes the line pattern

0 = do not center dash pattern
1 = center dash pattern between extents
1 = inches
2 = centimeters
+value = length of a dash (or dot) in the line style. The plus sign is optional. If you omit it, 
it is assumed.
-value = length of the space following the dash.
Continue to specify dash and space values until you have finished specifying one cycle of
the line pattern. Omit parentheses when doing so.

Example To produce a line with this pattern -.-..-... , enter the following values.
DashManyDots=0 2 0.04 -0.04 0.01 -0.04 0.04 -0.04 0.01 -0.02 0.01 -0.04 0.04    -0.04 
0.01 -0.02 0.01 -0.02 0.01 -0.04

Defaults None

See also
Changing line style 



[AutoRun]

Add this section to your EROICA.INI file to make HOTSPOT.EXE or any other program start 
automatically when Eroiica starts. Programs have to be configured to close when Eroiica does, however.
HOTSPOT.EXE has this capability. How to edit the EROICA.INI file To activate the changes, restart 
Eroiica.

directory-path-name=command-line-parameters
Purpose Causes the designated program to start automatically when Eroiica starts.
Values directory-path-name = Any valid directory path to the executable, such as C:\EROIICA\

HOTSPOT.EXE.
command-line-parameters = Any parameters to pass on the command line, such as 
AUTOSTOP, which makes HOTSPOT.EXE shut down when Eroiica does. Use {none} if 
no parameters are passed to the command line.

Default None
Example C:\EROIICA\HOTSPOT.EXE=AUTOSTOP

This makes HOTSPOT.EXE start when Eroiica does, and shut down when Eroiica 
terminates.

See also
Using HOTSPOT.EXE 



[Utilities]

All "Crop" keynames in this section are defined in the Crop Formats Options dialog box. The "Despeckle 
size" keyname is defined in the Despeckle dialog box. Whatever speckle size you select is automatically
saved for use the next time.



[Print]

Use the [Print] section keynames to configure printing. In addition to keynames set in the Print dialog 
box, Printer Select dialog box and the Banner Information dialog box, four keynames must be set by 
editing the EROICA.INI file. How to edit the EROICA.INI file They are described below. To activate the 
changes, restart Eroiica.

Aspect Correction=scale-factor
Purpose When printing at actual size, scales the document in the horizontal direction only.
Value Any scale factor
Default 1.0

Old Print Ver=0 | 1
Purpose This keyname defines which remote printing version to use (if any): Command Line or 

Command File.
With Command File, Eroiica creates a file that includes all of the parameters, and runs a 
command line consisting of an executable name followed by the command file name. 
This interface allows for printing of multiple pages in documents.
With Command Line, when a print is requested to a custom device, Eroiica assembles 
and runs a command line consisting of an executable name followed by a fixed and 
ordered list of parameters.

Values 0 = Command file interface
1 = Command line interface

Default None, which implies the Command file interface.

Scale Correction=scale-factor
Purpose When printing at actual size, scales the document in the horizontal and vertical directions.
Value Any scale factor
Default 1.0

Server Dir=directory-path-name
Purpose Defines the directory used for creating temporary files used in the remote printing 

process. If undefined, Eroiica uses the directory the document was found in. If that is a 
read-only directory, printing will fail. 

Values Any drive and directory path that the user has write permissions to.
Default None
Example C:\TEMP

See also
[PlotDevices] section
[  printer-driver  ] section  
Printing the active document 
Configuring remote printing 



[PlotDevices]

The [PlotDevices] section keynames further define the available printers. It provides the link to remote 
plotting. This section is unnecessary for Windows-supported printers, although you can use it to 
customize the name of the printer. Editing the EROICA.INI file To activate the changes, restart Eroiica.

printer-name=printer-driver,TYPE
Purpose Specifies the user-defined name of the printer used for remote printing.
Values printer-name is the text string describing the printer.

printer-driver is the name of the INI file section that further defines the printer driver.
TYPE is the printer type.

Default None

See also
[Print] section
[  printer-driver  ] section  
Configuring remote printing



[printer-driver]

Use this section when printing (or plotting) remotely. The parameters below must be set up for each 
printerdriver defined in the [PlotDevices] section. Editing the EROICA.INI file To activate the changes, 
restart Eroiica.

Banner=text-string
Purpose Defines the default text string to print on the drawing when using a remote or custom 

printer.
Values Any text string.
Default None

Exec=directory-path-name
Purpose Defines the process that must be carried out when a remote or custom print is started.
Values directory-path-name is a valid drive, path, and file name. The file must be a Windows 

EXE (executable) or an MS-DOS EXE, COM, or BAT (batch) program.
Default None

Format=format-number
Purpose Defines the output format of the temporary file created for remote printing.
Values 1 = CALS (Computer-aided Acquisition and Logistics Support) Type 1

3 = TIFF (Tagged Image File Format) LSB (least significant bit) header, MSB (most 
significant bit) Group 4 data
6 = PCX
11 = TIFF LSB header, MSB Group 3 data
13 = TIFF MSB header, MSB Group 4 data
14 = TIFF MSB header, MSB Group 3 data
Note that Eroiica PLOT only supports types 1, 3, and 13

Default None, implying CALS Type 1.

Scale=scale-factor
Purpose Defines the default scale size.
Values All possible values are defined with the ScaleList keyname.
Default None

ScaleList=scale1,scale2,...
Purpose Defines the list of output sizes available for the defined remote or custom printer. The 

selections are listed in the Setup for the printers.
Values Any scale value text string separated by a comma.
Default None

Timestamp=Y | N
Purpose Defines the inclusion of a time stamp with the banner when doing remote or custom 

printing.
Values Y = print timestamp

N = do not print timestamp
Default None

See also
[PlotDevices] section
Configuring remote printing
Printer Setup dialog box





[Fax]

Use the [Fax] section keynames to configure remote faxing. In addition to keynames set in the FAX 
Send dialog box, four keynames must be set by editing the EROICA.INI file. How to edit the EROICA.INI
file They are described below. To activate the changes, restart Eroiica.

Exec=directory-path-name
Purpose Defines the full directory path to the remote faxing program that you are using.
Values Any valid directory path.
Defaults None

Server Dir=directory-path-name
Purpose Defines the directory used for creating temporary files used in the remote faxing process. 

If undefined, Eroiica uses the directory the document was found in. If that is a read-only 
directory, faxing will fail. 

Values Any drive and directory path that the user has write permissions to.
Default None
Example C:\TEMP

See also
Faxing the active document 



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
The basic Windows open procedures are supplemented by alternative procedures.
Opening documents using File, Open 
Reopening documents 
Loading bad files 
Creating a document 
Setting open defaults 

Arranging Windows
Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
These help topics explain how to work with the Eroiica window, and the document windows.
Showing and hiding bars and floating windows
Resizing icons
Changing the location of the Standard Toolbar and Status Bar 
Displaying document windows
Activating document windows
Opening another view of the active document 
Arranging window icons 
Closing windows
Exiting

Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Documents Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
These view procedures apply to the document or documents displayed in the active document window.
Using the view options 
Zooming and scaling
Scrolling 
Using the Reference window
Using the Detail window
Rotating a document
Inverting document colors
Refreshing windows 
Mirroring a document
Displaying and hiding layers
Changing layer colors
Spotting erases and pastes 
Viewing annotations 
Activating hotspots 

Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
Displaying Text Documents
For text documents, the basic document viewing functions are supplemented by others that define fonts,
margins, borders, and so on.
Configuring text document display 
Formatting ASCII text documents 
Finding text 
Remapping fonts in text documents 

Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Special commands exist for dealing with multiple pages in a single window.
Changing pages
Speeding multipage display
Applying view options to all pages
Adding and removing pages
Reordering pages

Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Eroiica offers flexible printing, faxing, and scanning options, and permits the use of CMC-compliant mail 
programs for e-mailing.
Configuring remote printing 
Selecting a printer 
Printing the active document 
Faxing the active document 
E-mailing the active document 
Scanning

Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Getting Information
Eroiica offers several means of finding out what type of document you are viewing, what command is 
active, how big a document is, what version of the software you have, and so on.
Using the Status Bar 
Taking drawing measurements
Getting document information 
Getting product and version information 

Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
You can define in detail the appearance of objects before you draw them.
Setting the drawing tool options 
Setting the drawing tool defaults 
Setting global tool options 
Setting Grid options 
Selecting line, frame, and text colors 
Defining line and frame width
Changing line and frame style 
Selecting translucent or opaque lines 
Using the cap settings 
Setting arrowhead attributes 
Setting text attributes 
Defining the dimension style 
Setting fill attributes 
Defining hotspots 
Selecting a default symbol 
Setting eraser options 

Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Pages
Displaying Text Files
Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
You can draw lines, arrows, boxes, arcs, polygons, text, and other vector objects on the active edit layer.
Creating an edit layer 
Using the drawing tools
Drawing a line or an arrow
Drawing an arc
Freehand drawing, highlighting, and erasing
Drawing a polyline
Drawing a polygon
Drawing a dimension line
Drawing a box
Drawing a circle or an ellipse
Selecting and placing a symbol
Placing a hotspot
Placing text or an annotation

Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
You can change objects after you place them. These topics explain how.
Undoing object placement and deletion
Selecting objects
Deselecting objects 
Binding and unbinding objects 
Moving and resizing objects 
Rotating objects 
Deleting objects
Cutting, copying, and pasting objects 
Changing object attributes 
Modifying object text 
Creating a symbol 
Attaching hotspots 

Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
You can save changes to the active document, or export a layer, page, or multipage to create a new 
document. Changing attributes is a prelude to saving or exporting.
Setting save defaults 
Saving a single layer 
Saving a page 
Saving a multipage 
Changing layer attributes 

Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
"Editing" refers to cutting, copying, and pasting raster documents.
Cutting and copying raster documents 
Pasting raster documents 
Copying a document 

Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
You can manipulate the current layers in various ways, as explained in these topics.
Activating layers
Branching and Collapsing layers 
Comparing layers
Moving layers
Adding and removing layers
Reordering layers
Merging layers

Modifying Raster Documents
Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
You create new rasters by altering certain aspects of existing raster documents, as explained in these 
topics.
Despeckling a document 
Deskewing a document 
Cropping a raster document
Changing raster document characteristics 
Resizing a raster document 

Optimizing Document Display and Performance



Procedures

Click any procedure title to see the available topics.
Opening Documents
Arranging Windows
Viewing Documents
Displaying Text Documents
Working with Multiple Pages
Peripheral Devices
Getting Information
Configuring Drawing Tools
Drawing Objects
Modifying Objects
Saving, Exporting, and Changing Attributes
Editing
Manipulating Layers
Modifying Raster Documents
Optimizing Document Display and Performance
Optimizations are often a trade-off: To increase speed, you usually have to sacrifice document quality. To
improve memory allocation, you have to sacrifice speed. These topics discuss various display and 
performance optimizations for raster and vector documents.
Improving raster document display 
Optimizing raster document speed 
Optimizing memory 
Optimizing vector document speed 
Optimizing vector document display 



Opening documents using File, Open

You can open one or several documents and have each display in its own window, or all in the same 
window.
To open one or several files:

1. Click  in the Standard Toolbar.
or
Choose File -> Open.
or
Press CTRL+O.

In the Open Documents dialog box:
2. If required, scroll up or down the list of files to find the names or labels of the ones to open.
3. If you cannot find the names or labels you want, you can:

Change the Drive and Directory.

Select another document type, such as All Files, in List Files of Type.

Add to or change the extensions in the File name text box (put a semicolon between each), and 
press ENTER to display a different list of files.

4. Click the names or labels of the documents to open and click OK.
The specified documents open into one or several windows. The windows are either cascaded or 
maximized, depending on the Options -> View Options setting.

See also
Open Documents dialog box
Optimizations Options dialog box 
Displaying document windows
Reopening documents 



Reopening documents

You can reopen documents quickly using the File menu. It lists the last few documents you opened.

To change the number of documents listed in the File menu:
1. Load the EROICA.INI file into a text editor.
2. In the [Most Recently Used] section, set the "max in list" keyname to the number of documents 

opened previously that you want listed in the File menu. Use any integer from 0 to 10.
Do not change the other settings in the [Most Recently Used] section. They are pointers to the 
documents you last opened.

3. Save the EROICA.INI file. Restart Eroiica for the change to take effect.
To reopen a file:

From the File menu, choose the name of the document to reopen. (Only the files opened through 
the Open Documents dialog box are listed.)

The document opens into its own window.

Note: Through the File menu, you can open the same document twice. That is different from opening a 
second view of one document. Click here for a table comparing the two: Comparison 

See also
[Most Recently Used] section 
Opening another view of the active document 
Opening documents using File, Open 



Loading bad files

Eroiica loads and displays "bad" raster documents, unless the data is corrupted too badly. Clues that a 
file contains corrupted data include:

The document is greatly distorted.

The document fails to save under certain file formats.

The document displays anomalies or distortions when scrolled, magnified, or reduced.

The bilevel document fails to deskew.
If you have access to the merge function, convert the corrupted file into a good one.
To save a raster file with corrupted data as a good file:
1. Open the "bad" raster document.
2. Choose Tools -> Merge. In the Merge dialog box, select the Active Raster Resolution check box. 

Click OK.
The document is merged.
3. Save or export the new raster document.

The new document contains no corrupted data.

See also
Opening documents using File, Open 
Merging layers 
Merge dialog box 
Saving a single layer 



Creating a document

You can create an empty document into which you can import existing layers or documents, or place 
new edit layers.
To create a blank window:

Click 

 in the Standard Toolbar.
or

Choose File -> New.
or

Press CTRL+N.
A blank document window opens. It is now the active window.

See also
Importing layers 
Importing pages 
Creating an edit layer 
Creating a page 



Setting open defaults

In the various Open, Add, and Import dialog boxes, a directory path and document type are displayed by
default, and for each available document type, certain extensions are suggested. You can change any of
these defaults.

To define the default open directory, naming convention, and open extensions:
1. Choose Options -> System.

If required, scroll up or down the list of categories to find File Formats.    Click the File Formats icon.    
The File Formats Options dialog box appears.
In the File Formats Options dialog box:
2. In the Image Directory text box, type the directory path to use as the default.
3. Choose to Show File names or Labels in lists of files for selection.
4. To define open extensions, click the File Extensions icon. In the File Extensions Options dialog box, 

change, add to, or delete any of the extensions, using the ampersand (*) as a wild card character. 
Leave a space between each. Include no more than 8 three-letter extensions for each document 
type. If you leave any text boxes blank, that document type will not appear for selection. Click OK.

5. To save your selections for future sessions, click Save as default.
The selected preferences are used for the next document you open, add, or import.

To define the default open document type:

For Sets, Documents, Raster Files, Text Files or All Files to be the document type listed by default
in List Files of Type: Select them in the Open files as section of the File Formats Options dialog box.

For Vector Files, or Symbols to be the document type listed by default: Select them by setting the 
"Open Mode" keyname in the [File] section of the EROICA.INI file to 4 (Vector Files), or 5 (Symbol Files).

See also
"Open Mode" keyname ([File] section) 
Setting save defaults



Showing and hiding bars and floating windows

With the View -> Toolbars and Window menu, you choose whether or not to display certain Eroiica 
window elements:

The Standard Toolbar, which displays file, edit, view, draw, and window icons, by default below 
the menu bar.

The Drawing Toolbar that displays drawing tools icons, by default at the left of the Eroiica window.

The Status Bar that displays page icons and other information at the bottom of the Eroiica 
window.

The Reference window, which displays the entire current document in miniature, and indicates 
with a crossed box what section of the document appears in the active document window.

The floating Symbols Palette that depicts all symbols available for selection in the symbol 
directory.

The Detail window, a floating window that shows the pointer location in close-up.

The Eroiica Contents window that lists all open documents and allows you to manipulate them.

The Line Width window that allows you to select the line or frame width for the active tool.

The Measurements window that displays measurement information.
To hide or display any of these elements, choose the appropriate command in the View -> Toolbars or 
Window menu. Displayed elements have a check mark beside their name in the menu.
Some floating windows have icons for showing or hiding them:

Reference window:  in the Standard Toolbar.

Detail window:  in the Standard Toolbar.

Eroiica Contents window:  in the Standard Toolbar.

Line Width window:  in the Standard Toolbar.

Symbols Palette window:  in the Standard Toolbar.

Measurements window:  in the Standard Toolbar.
Some also have keyboard shortcuts:

Reference window: F6

Detail window: F11

Line Width window: F12

The hidden or displayed status of these screen elements is saved on quit (unless "Save=0" in the [Initial 
Window] section of the EROICA.INI file).
For more information about any of these, select one of the following topics.
Standard Toolbar command (View menu)
Drawing Toolbar command (View menu)
Status Bar command (View menu) 
Reference command (Window menu) 
Symbol Palette command (Window menu) 
Detail command (Window menu) 
Contents command (View, Window menu) 



Line Width command (Window menu) 
Measurements command (Window menu) 



Resizing icons

The icons in the Standard Toolbar and Drawing Toolbar are assigned a certain size that varies with the 
screen size. Use the EROICA.INI file to change the default size and shading of these icons.
To resize the Drawing and Standard Toolbar icons:
1. Load the EROICA.INI file into a text editor.
2. In the [User Interface Preferences] section, set the "Button Size" keyname to 1 for small, 2 for 

medium, and 3 for large icons.

1:           2: 

          3: 

          (actual size)
3. Save the EROICA.INI file.

When you restart Eroiica, the specified size and shading are used.

See also
[User Interface Preferences] section
Changing the location of the Standard and Drawing Toolbar



Changing the location of the Standard and Drawing Toolbar

By default, the Standard Toolbar displays icons below the menu bar, and in most editions, the Drawing 
Toolbar displays tool icons at the left of the Eroiica window. You can change their positions.
To define the location of the Standard and Drawing Toolbar:
1. Load the EROICA.INI file into a text editor.

In the [Initial Window] section:
2. Set "ribbon window type" to 1 for top, 2 for bottom, 3 for right, 4 for left, or 5 for floating.

3. Set "tool window type" to a position value between 1 and 5.
4. Save the EROICA.INI file.

When you restart Eroiica, the Standard and Drawing Toolbar appear at the selected locations.

See also
[Initial Window] section 
Resizing icons 



Displaying document windows

When document windows are first opened, they are either cascaded (overlapping) or maximized (filling 
the workspace). Choose the default display that you prefer.
To change the default display of document windows:
1. Choose Options -> System.

If required, scroll up or down the list of categories to find Optimizations.    Click the Optimizations icon.    
The Optimizations Options dialog box appears.
In the Optimizations Options dialog box:
2. In the Window section, click Cascaded or Maximized.
3. To save your selection for future sessions, click Save as default. Otherwise click OK.

The next documents you open have the selected display.

Whatever the default window display, you can change it. You can cascade or tile all the open document 
windows (except those that are minimized).

To cascade the document windows:

Choose Window -> Cascade.
All document windows neatly overlap, and all are the same size. When cascaded, you can quickly 
activate a window by clicking its title bar.

To tile the document windows:

Choose Window -> Tile.
The document windows are arranged in columns and rows, so that none overlap. Use tiling to compare 
all the documents.

Tiling in strips places windows in a single column, keeping all windows visible. This display is preferable 
to plain tiles for certain documents.
To tile the document windows in a horizontally stripped arrangement:

Choose Window -> Tile Strips.
The documents appear in a single column in the Eroiica window.

See also
Arranging window icons 



Activating document windows

The document window last opened, created, or activated is the active document window.
To determine which document window is active:

Cascade or tile the windows, and observe the title bars of each. The bar of the active window is a 
different color.

or
1. Click the Window menu.
2. The menu lists all open windows. The window name with the check mark beside it is the active 

document window.
3. To close the menu, click the Window menu again or press ESC.

Note that the active document window is never hidden by the other document windows (though it may 
be by floating windows).

To change the active window:

Click the title bar of the document window to activate. (This is easier when the windows are tiled 
or cascaded.)

or

From the Window menu, choose the name of the window to activate.
or

Pull down the Window menu, and type the number that appears beside the name of the window 
to activate.

That document window appears above the others, and its title bar is colored. All Eroiica commands 
apply to it.

See also
Displaying document windows



Arranging window icons

If the desktop gets too crowed, minimize some document windows. When minimized, document 
windows appear as icons that you can drag around.
To arrange all window icons neatly in the lower left corner of the Eroiica window:

Choose Window -> Arrange Icons.
The window icons are neatly arranged on your desktop.

See also
Displaying document windows



Opening another view of the active document

You can create a window that displays another view of the active document. That way you can 
simultaneously view two different pages of a document, or two different sections of a large document.
The new view can be an exact duplicate of the current view of the active document, or it can be the 
document at its default display (i.e. default scaling and rotation, and so on.)

To open a duplicate view of the active document:

Choose Window -> New Window.
or

Press CTRL+F3.
A window opens displaying the active document. The title bar contains a colon and a number after the 
window name. You can select different view options for each window displaying the same document.
Markups or edits to the document in one window are only reflected in the other windows on redraw or 
save. Changes to the document structure are immediately reflected in the other windows.

See also
Redrawing windows 



Closing windows

You can close the active window, all windows containing the active document, selected windows, or all 
document windows.

To close the active window:

Choose Window -> Close.
or

Use the Control-menu box (Windows 3.1) or Close button (Windows 95) of the document window.
To close all windows displaying views of the active document:

Choose File -> Close.
To close all document windows:

Choose File -> Close All.
For all procedures, if any layers or documents have changed, you are asked if you want to save the 
changes before closing.

See also
Quitting Eroiica
Saving a single layer 
Saving a page 



Quitting Eroiica

To end a session:
1. Choose File -> Exit.

or

Use the Control-menu box (Window 3.1) or Close button (Windows 95) of the Eroiica window.
2. If any layers or documents have changed since the last save, you are asked if you want to save 

them. Choose Yes and follow the save procedure, No to quit without saving.
3. If you have changed any defaults in this session, you are asked if you want to save options. Choose 

Yes to have your current settings used as defaults for next session, No to quit without saving them.
All the document windows close, as does the Eroiica window.

See also
Closing windows 



Using the view options

The View Options dialog box contains all the View menu commands in one place, and adds some 
others. It is therefore the best way to select several display options at once. You can also use it to 
change the display of all the pages in the window instead of just the current one.
To set the view options for the active document:
1. Choose Options -> View.

In the View Options dialog box:
2. Select the Display, Scale, Snap and Grid, and other settings that you want to use.
3. To apply the settings to the current page only, click OK. 

To apply them to all pages of a multipage document, click Apply to All Pages.
To apply them to all open documents, click Apply to All Wins.
To save current settings as defaults for next sessions, click Save as default. 

The document or pages in the active window are displayed with the selected options.

See also
View Options dialog box



Zooming and scaling

You can set the default scale factor for all documents.

To change the default scale factor of documents:
1. Choose Options -> View.
2. In the View Options dialog box, click one of the Zoom buttons:

Best Fit fits the document to the size of the document window.

Fit to Width displays the document so that its width matches the width of the document window.

Fit to Height displays the document so that its height matches the height of the document window.

Actual Size displays the document at its actual size, given the screen resolution.

1:1 displays the document at the size that allows for the most accurate drawing on the document.

Factor displays the document at the specified scale factor.
3. To save your selection for future sessions, click Save as default. Click OK.

That scale factor is used by default for all documents.

Once a document is open, you magnify and reduce it using various methods, among them the following.
Drawing the zoom region
Using the Reference window to zoom 
Fitting the document to the window
Enlarging and reducing the document
Displaying the document at 1:1 or another scale factor
Displaying the document at its actual size

If you click the Apply to All Pages button in the View Options dialog box, any scale factor selected for 
one page is applied to the other pages in the window as well.



Drawing the zoom region

The mouse zoom is the fastest way to zoom in exactly on the part of the document to magnify. Normally 
you do this with the right mouse button.
To draw a zoom region with the right mouse button:

On the current document, with the right mouse button, drag a box from one corner of the area to 
magnify to the diagonal corner. (To cancel, press ESC.)

Note: If you inadvertently release the mouse button after drawing a very small area, it can seem that 
your document has suddenly become blank or all one color. You have zoomed in very close to an area 

of one color. Click  (Fit) or 

 (Reduce) to zoom back out.

See also
Fitting the document to the window 
Magnifying and reducing the document 
Using the Reference window to zoom 



Using the Reference window to zoom

The Reference window always displays the entire document. Use it to reduce a greatly magnified 
document, or to move from one side of the document to the other.
To use the Reference window to zoom in and out:

1. If the Reference window is hidden, click  in the Standard Toolbar.
2. In the Reference window, use the right mouse button to drag a box from one corner of the zoom area

to its diagonal corner. (To cancel, press ESC.)
The defined area is displayed in the document window. The Reference window continues to show the 
entire document. The crossed box in the Reference window indicates what section of the document 
appears in the document window.

See also
Drawing the zoom region



Fitting the document to the window

You can match the document or page size to the size of the window that contains it. You do this using a 
number of Fit commands.

To show the entire page or document, so that it fills the window:

Click 

 in the Standard Toolbar.
or

Choose View -> Zoom -> Best Fit.
or

Press F2.
or

In the View Options dialog box, click Best Fit. Click OK or select other choices such as Save as 
default as required.

To scale the document so that its width matches the width of the window:

In the View Options dialog box, click Fit to Width. Click OK or select other choices such as Save 
as default as required.

To scale the document so that its height matches the height of the window:

In the View Options dialog box, click Fit to Height. Click OK or select other choices such as Save 
as default as required.

If the Apply to All Pages check box is selected in View Options dialog box, the new scale factor is 
applied to all pages in the multipage.

See also
View Options dialog box (Scale) 



Magnifying and reducing the document

You zoom into or out of the document or page by successive steps with the View -> Zoom -> Enlarge 
and View -> Zoom -> Reduce commands.

To zoom into the document by one zoom step:

Click 

 in the Standard Toolbar.
or

Choose View -> Zoom -> Enlarge.
or

Press PLUS SIGN on the numeric keypad.
To zoom out of the document by one zoom step:

Click 

 in the Standard Toolbar.
or

Choose View -> Zoom -> Reduce.
or

Press MINUS SIGN on the numeric keypad.
The document is magnified or reduced one zoom step around the displayed center of the document. You
can repeatedly choose these commands.

If you dislike the zoom step amount, you can change it.
To change the size of the zoom step:

In the [View] section of the EROICA.INI file, change the value of the "Zoom Step" keyname. Its 
value equals the amount of current view by which to magnify or reduce the document. (For example, 2.25 
times the current view or 1/2.25ths of the current view.)

See also
"Zoom Step" keyname ([View] section) 



Displaying the document at 1:1 or another scale factor

You can display the document at a specific scale factor, such as 1:1. You draw most accurately when the
document is displayed at 1:1.

To select a 1:1 scale factor:

Click 

 in the Standard Toolbar.
or

Choose View -> Zoom -> 1:1.
or

Press CTRL+1.
or

In the View Options dialog box, click 1:1 Click OK or select other choices such as Save as default
as required.

To select another scale factor:
1. Choose Options -> View.

In the View Options dialog box:
2. Click Factor and type the value in the text box.

or

Drag the slider box up or down. As you adjust the box, Factor displays the scale value.
3. Click OK (current document) or Apply to All Pages as required.

The document appears at the selected scale factor around the displayed center. Aspect ratio is 
maintained. If the Apply to All Pages is clicked in the View Options dialog box, the new display size is 
applied to all pages in the multipage.

See also
View Options dialog box (Scale) 
Displaying the document at its actual size 



Displaying the document at its actual size

To get an idea how big the active document really is, display it at its actual size.
To display the document at its actual size:

In the View Options dialog box, click Actual Size. Click OK or select other choices such as Save 
as default as required.

You can scroll around the document at its new scale factor.

See also
View Options dialog box (Scale) 
Printing the active document



Scrolling

Scrolling means moving around the document so that you see different parts of it without zooming in or 
out.

To display or hide Scroll Bars:
1. Choose Options -> View.

In the Scrolling section of the View Options dialog box:
 2. Click Horizontal or Vertical Scroll Bar

The Horizontal Scroll Bar and Vertical Scroll Bar check boxes define whether or not document 
windows have scroll bars. Unless you require the extra space, display the bars.

Scroll Step defines how much the document moves when you click the scroll arrows or press the 
Arrow keys. Its value is a percentage of current view.

3. To save your selection for future sessions, click Save as default. Click OK.
To scroll around the document:

Drag the scroll boxes or click the scroll arrows or click the scroll bar or press the Arrow keys.
As in other programs running under Windows, the view shifts in the indicated direction.

See also
View Options dialog box (Scale) 
Scrolling using the Reference window 



Scrolling using the Reference window

You can use the Reference window to move around the document at the current scale factor.
To scroll using the Reference window:

1. If the Reference window is hidden, click  in the Standard Toolbar.
In the Reference window:
2. Drag the crossed box to the area to view.

or

Click the area that you want to view. The crossed box automatically moves there.
The area selected in the Reference window is displayed in the document window.

See also
Using the Reference window 
Scrolling 



Using the Reference window

The Reference window is a small window that shows the entire current document and orients you by 
indicating (with a crossed box) what appears in the active document window. By default, the Reference 
window is a floating window whose display is saved on quit. (You can also configure it as a child window 
of the active document.)
To display or hide the Reference window:

Click 

 in the Standard Toolbar.
or

Choose Window -> Reference.
or

Press F6.
To scroll using the Reference window:

Drag the crossed box to the new viewing area.
or

In the Reference window, click the area that you want to view. The crossed box moves there 
automatically.

To refresh the Reference window so that any newly drawn objects display in it:

Click 

 in the Standard Toolbar.
or

Choose View -> Refresh.
or

Press F7.
To zoom into the document using the Reference window:

With the right mouse button, drag a box from one corner of the zoom area to its diagonal corner. 
(To cancel, press ESC.)

To change the color of the crossed box in the Reference window:

In the [System] section of the EROICA.INI file, set the "Highlight Box Colour" keyname to the 
appropriate color number.

See also
"Highlight Box Colour" keyname ([System] section) 
"Floating Reference Window" keyname ([Initial Window] section) 
Redrawing windows 
Using the Detail window



Using the Detail window

To examine something in close-up without zooming in a lot, use the Detail window. It shows an enlarged 
view of the pointer location, by default at a 1:1 scale ratio. You can move and resize the Detail window.

To display or hide the Detail window:

Click 

 in the Standard Toolbar.
or

Choose Window -> Detail.
or

Press F11.
If displayed when you quit Eroiica, the Detail window normally displays (at the same size and position) 
when you next restart it as well.

The "Detail Scale" keyname (in the [View] section of the EROICA.INI file) defines the Detail window's 
default scale factor.
To change the display scale of the Detail window:
1. With the right mouse button, click in the Detail window.
2. From the submenu that appears, choose 1:1, Magnify, or Reduce.
3. Repeat as required.

or
1. Activate the Detail window by clicking in its title bar.
2. Press CTRL+1 for 1:1, PLUS SIGN for Magnify, or MINUS SIGN for Reduce. Repeat as required.

The display scale only increments by a small amount each time.

Normally the Detail window display changes as the pointer moves. You can freeze the display.

To freeze the Detail window display:
1. Make sure that the Layers and Line Width windows are inactive.
2. Press CTRL+F11.

The Detail window display stops moving as the pointer does. To release the Detail window, press 
CTRL+F11 again.

See also
"Save" keyname ([Initial Window] section) 
"Detail Scale" keyname ([View] section) 
Using the Reference window



Rotating a document

Some documents may open on their sides, or upside down. You can turn them. You can also rotate 
documents to have them fit better in the window.

To rotate the current document counter-clockwise by 90 degrees:

Click 

 in the Standard Toolbar.
or

Choose View -> Rotate -> Left (90° CCW).
or

Press F9.
or

In the View Options dialog box, click the appropriate Rotation number (90° CCW if the document 
is at a 0 degree rotation initially). Click OK.

To rotate the document clockwise by 90 degrees:

Click 

 in the Standard Toolbar.
or

Choose View -> Rotate -> Right (90° CW).
or

Press F10.
or

In the View Options dialog box, click the appropriate Rotation number (90° CW if the document is 
at a 0 degree rotation initially). Click OK.

To rotate the document by 180 degrees:

Click 

 in the Standard Toolbar.
or

Choose View -> Rotate ->Down (180°).
or

In the View Options dialog box, click the appropriate number (180° if the document is at a 0 
degree rotation initially). Click OK.

The document always rotates around its center.

See also
View Options dialog box (Display) 



Inverting document colors

Inverting bilevel raster documents, vector documents, and text documents means reversing their colors. 
Inverting grayscale raster documents means inverting the color scale. In inverted color raster 
documents, the intensity changes, with bright areas becoming dark and vice versa.
To specify the default inversion:
1. Choose Options -> View.

In the Display section of the View Options dialog box:
2. Select or clear the Invert check box. If you mostly view complex vector documents, you might select 

the Invert check box, as these documents look better with a black background.
3. To save the selection for future sessions, click Save as default. Click OK.

To invert the active document (or to remove inversion):

Click 

 in the Standard Toolbar.
or

Press F8.
or

In the View Options dialog box, select or clear the Invert check box. Click OK.
The document colors are inverted.

See also
View Options dialog box (Display) 
Displaying a negative document 



Redrawing windows

Redrawing a window has three main functions. Use it to:
1. Get rid of "noise"--extraneous data--that remains from previous views.
2. Accurately position fonts that you have remapped.
3. Update all windows displaying the active document, including the Reference window.

To redraw all windows displaying views of the active document:

Click 

 in the Standard Toolbar.
or

Choose View -> Refresh.
or

Press F7.
The active document window, and any other windows displaying a view of that document, are redrawn.

See also
Opening another view of the active document
Using the Reference window



Mirroring a document

Documents are sometimes backward, appearing in the document window as though you were looking at
a reflection of them in a mirror. Flip such documents around to make them usable. The View -> Special -
> Mirrored command applies to raster, vector, and text documents. However, text in text and vector 
documents mirrors inaccurately.
In the View Options dialog box, you can select the Mirror check box. Avoid doing this, however, unless 
you constantly view mirrored raster documents.

To select or deselect mirroring for the current document:

Choose View -> Special -> Mirrored.
or

In the View Options dialog box, select or clear the Mirror check box. Click OK.
The document is mirrored around a vertical axis.

See also
View Options dialog box (Display) 
Changing raster document characteristics 



Spotting erases and pastes

If you are viewing a document that you know (or suspect) contains pasted or erased areas, but you are 
having trouble seeing where, use the Show Paste Outlines and Show Erase Outlines check boxes in the
View Options dialog box.
To find pastes or erases on the current document:
1. Choose Options -> View.
2. In the Layer Objects section of the View Options dialog box, select the Show Paste Outlines check 

box, or the Show Erase Outlines check box, or both. Click OK.
When both these check boxes are selected, erased areas, rubouts, and raster pastes are displayed as 
cross-hatches:

    
Selecting the Show Paste and Erase Outlines check boxes also moderately speeds up document 
scrolling and zooming.

See also
View Options dialog box (Show Paste Outlines) 
Optimizing vector document performance



Viewing annotations

The document you are viewing may contain annotations, or textual notes. Annotations are recognizable 
when minimized: They resemble yellow sticky notes. Annotations can also be displayed as plain text, 
however, in which case they are indistinguishable from other text objects.
To find out if "text" on the document is text or an annotation:
1. Deactivate any checked Draw or Edit menu commands.
2. Place the pointer on top of the "text."

If nothing happens to the pointer, it is text. If the pointer changes to this shape: , it is an annotation.

To reduce annotation text to an icon:

Place the pointer over the annotation text, and double-click (unless "Single Click Activation=1" in 
the [View] section of your EROICA.INI file, in which case you just click).

To view the text in an annotation icon:

Repeat the previous procedure.

The annotation text appears. Note that the pointer becomes this shape:  when it is over an 
annotation icon.

The annotation text may appear in a dialog box or as a text object on the document. You define this in 
the Annotations section of the View Options dialog box.
To change the display of annotation text:

In the Annotations section of the View Options dialog box, select the annotation display option 
you want. Simple Text displays annotations as a text object. Modal Dialog displays annotation text in a 
dialog box.

When Simple Text is selected, you can perform aggregate operations.
To display the text of all annotations on the document:

Choose View -> Special -> Show Annotations.
To reduce all annotations on the document to icons:

Choose View -> Special -> Hide Annotation.
The shape of annotations is saved when you save the layer.

The Show Annotations check box in the Layer Objects section of the View Options dialog box defines 
whether annotations appear by default. When cleared, annotations are completely hidden, so you do not
even know they are there. We therefore recommend that it be selected. If annotations are obscuring the 
view on the current document, however, hide them.
To hide annotations on the current document:

In the View Options dialog box, clear the Show Annotations check box. Click OK.
All annotations on the document seem to disappear.

See also
"Single Click Activation" keyname ([View] section) 
View Options dialog box (Annotation Display) 
Placing an annotation



Activating hotspots

The document you are viewing may contain hotspots--objects that send a block of information when 
activated. If a hotspot is an icon shape (under any number of designs), it is recognizable as a hotspot. 
Otherwise, hotspots generally look the same as any other object.
To find out if an object on the document is a hotspot:
1. Deactivate any checked Tool or Edit menu commands.
2. Place the pointer on top of the object.

If the pointer changes to this shape:  (the object might also be highlighted), the object is a hotspot.

When you activate hotspots, an action occurs, if a program is attached to Eroiica (through the API), and 
is configured to respond to hotspot activation. Possible actions include launching other programs, 
loading documents, and echoing text.
To activate a hotspot:
1. If necessary, start the program that is linked to Eroiica (such as HOTSPOT.EXE).
2. Place the pointer on top of the hotspot, and double-click (unless "Single Click Activation=1" in the 

[View] section of the EROICA.INI file, in which case you just click).
The action occurs. You can activate hotspots on any displayed layer.

The Show Hotspots check box in the Layer Objects of the View Options dialog box defines whether or 
not hotspots display by default, and we recommend that it be selected. You can, however, hide hotspots 
on the current document.
To hide hotspots on the current document:
1. Choose Options -> View.
2. In the Layer Objects of the View Options dialog box, clear the Show Hotspots check box. Click OK.

All hotspots on the document seem to disappear.

See also
"Single Click Activation" keyname ([View] section) 
Using HOTSPOT.EXE
View Options dialog box (Layer Display) 
Placing a hotspot



Using HOTSPOT.EXE

Eroiica comes with HOTSPOT.EXE, a sample hotspot program.

To place a HOTSPOT.EXE-compatible hotspot:
1. Open the EROICA.INI file in a text editor and make sure that "Hotspot Data Prompt=1," not 0 (in the 

[Tool] section). If necessary, change the value, save the EROICA.INI file.    Restart Eroiica.
2. Select an object or objects and choose Edit -> Attach Hotspot.

or

Choose Draw -> Hotspot. On the active edit layer, click the location of the hotspot icon, draw the 
hotspot object, or place the hotspot symbol (depending on the hotspot Shape in the Tool Options dialog 
box).

3. In the Hotspot Data dialog box, type the required text. Any line that begins with # echoes on 
activation. Any line that begins with > is a Windows command, to be carried out on activation. All 
other lines are API commands, transmitted back on activation. Click OK.

The hotspot object is placed or attached.

To activate a HOTSPOT.EXE hotspot:
1. If necessary, double-click the Hotspot icon in the Eroiica window on your desktop.

HOTSPOT.EXE starts at the same time as Eroiica if it is configured to do so in the EROICA.INI file. 
When it is running, it appears as a hotspot icon at the bottom of your desktop.

2. In Eroiica, deactivate any checked Draw or Edit command.
3. Depending on your "Single Click Activation" keyname, click or double-click the hotspot.

Text echoes, a Windows command is executed, an API command is sent and acted on, or any 
combination of these.

See also
Placing a hotspot
Activating hotspots
Hotspot category: Draw Options dialog box
[AutoRun] section



Displaying and hiding layers

You can display or hide any layer on the current document. Hiding some layers can make a document 
easier to work with. Note, however, that hiding active layers deactivates them.
To display or hide layers on the current document:

1. If the Eroiica Contents window is hidden, click  in the Standard Toolbar.
or

From    the View menu, choose Contents.
In the Eroiica Contents window:
2. If necessary, Branch any of the document folders or pages whose subordinate layers you want to 

display or hide. The "base" document folders or pages have a plus sign (+) inside their icon.
 3. Click the eye glasses icon of the layer to hide or display.

or

With the right mouse button, click the eye glasses icon of the layer or layers to hide or display. 
From the submenu that appears, choose Hidden.

or

From the Mode menu of the Eroiica Contents window, choose Hidden.
or

Press CTRL+H.
The layers selected for display show on the document. The rest seem to disappear.

Note that activating a layer also redisplays it if it was hidden.
When an edit layer contains an erased area (whether created with Cut, Rubout, or Erase Area), the area
is painted to the background color, which hides the underlying layers. When this edit layer is hidden, the 
"erased" parts of the document redisplay.

See also
Branching and Collapsing layers 



Changing layer and document colors

You can change the foreground color of any layer on the current document--other than color raster 
documents--to make the document easier to view.

To define the default foreground color of layers and bilevel raster documents:
1. Choose View -> Contents.

In the Eroiica Contents dialog box:
2. If necessary, Branch any of the document folders or pages whose subordinate layers color you want 

to change. The "base" document folders or pages have a plus sign (+) inside their icon.
 3. Click the color box icon of the layer whose color you want to change.

or

From the Object menu of the Eroiica Contents window, choose Color.
4. Select the color you want from the Raster Color list.
5. To save the color for future sessions, click Save as default. Click OK.

The layers or documents are displayed with the selected colors. (Note that if View -> Colors -> 
Monochrome is active, layers--other than grayscale and color raster documents--appear in black-and-
white tones.)

Grayscale and color raster documents, vector documents, and text documents are stored with particular 
colors. CLF and SMF documents can be saved as viewed with their current layer colors. 

See also
Branching and Collapsing layers 
View Options dialog box (Default Raster Color) 



Configuring text file display

You select text document display defaults in the Text Layout Options dialog box.
To set text document display defaults:
1. Choose Options -> System.
2. Scroll down or up the category box as required and click the Text Layout icon.

In the Text Layout Options dialog box:
3. To display each page of text documents with a box that indicates page borders, select the Show 

Borders check box.
4. Select the page Presentation to use. Presentation defines how many pages of text documents are 

displayed at once. 1x1 displays one page at a time. 1x2 displays two pages at a time. 1x2 book 
displays the first page, then displays two pages at a time. 2x2 displays four pages at a time. 2x4 
displays eight pages. 3x3 displays nine pages at a time, and 4x4 displays sixteen pages at once.

5. The ASCII template defines how ASCII text documents are rendered. To change the template file, 
click Browse and select the RTF template file to use from the ASCII Template dialog box that 
appears. Click OK.

6. In the Text Layout dialog box, click Save as default to save your selections for future use. Click OK.
Text files you open subsequently are displayed with the settings you selected.

See also
Text Layout Options dialog box 
ASCII Template dialog box 
Formatting ASCII text documents



Formatting ASCII text documents

The appearance (margins, page size, fonts used, and so on) of ASCII text documents are specified by a 
Rich Text Format (RTF) template that you select in the ASCII Template dialog box. The template has the 
following format:
{\rtf1\ansi\deff0\cf0\doctemp
{\fonttbl{f0\font-style font-name;}}
{\colortbl\redRRR\greenGGG\blueBBB;}
\paperwwidth\paperhheight
\marglleft\margrright\margttop\margbbottom
\deftabtab
\f0\fsfont-size
}
Where font-style = fswiss (for sans serif fonts), froman (for serif fonts), or fnil (for unknown style).

font-name = the name of the font.
RRR GGG BBB = red-green-blue (RGB) color values, each a number between 0 and 255, where 
0 represents no color and 255 represents the deepest intensity of that color.
width and height = page width and height in "twips," where 1 twip = 1/1440 inch.
left, right, top, and bottom = size of the left, right, top, and bottom page margins in twips.
tab = tab size in twips.
font-size = font size value in half points (for example, for 12-point text you type 24).

The default template for ASCII text files is TEMPLATE.RTF. It contains the following settings:
{\rtf1\ansi\deff0\cf0\doctemp
{\fonttbl{f0\fnil Courier New;}};
{\colortbl\red255\green255\blue255;};
\paperw12240\paperh15840;
\margl1080\margr1080\margt1440\margb1440;
}
This produces a text document with a Courier New font, black text, an 8.5 by 11-inch page size, left and 
right margins of 0.75 inches, and top and bottom margins of 1 inch. Several other templates are shipped
with Eroiica.
You can create your own RTF-format template (using a text editor that writes RTF) and select it in the 
ASCII Template dialog box, or you can edit an existing one. Note that you can specify other elements in 
RTF templates, such \qr (on a single line) for right alignment (qr = quadding right). Refer to RTF 
documentation for more information.

See also
Text Layout Options dialog box 
ASCII Template dialog box 
Configuring text document display 



Finding text

As in other Windows-based programs, you can search for specific text strings in the active document, 
whether they are contained in text or vector documents. All displayed edit layers in the document are 
searched.
To locate specific text:
1. Choose Tools -> Find Text. 

or

Press CTRL+F.
In the Find dialog box:
2. Type the text you are searching for in the Find text box.
3. Select your search Direction: All (down, then wrap around), Up, or Down.
4. Specify your search criteria. You can:

Select the Match Case check box to search for the exact uppercase and lowercase letters 
specified.

Select the Whole Words Only check box to search for entire words, and not parts of words.
5. To find only the first or last occurrence of your search term, click First or Last. To find the next 

occurrence, click Find Next.
The text last found is highlighted.
6. Repeat step 5 as required. Click Close when done.

The text last found remains highlighted until the document is redrawn (by you or automatically by 
Eroiica).

See also
Find dialog box 



Remapping fonts in text files

You can change font mappings in the active text document, substituting available one font for another, or
just resizing the fonts.
To change the font mappings in the active text documents:
1. Choose Options -> System -> Text Layout.

The Text Layout Options dialog box appears. All fonts contained in the active text document display in 
the List of Fonts box. In the List of Fonts box of the Text Layout Options dialog box:
2. Click the name of one of the original fonts in List of Fonts to select it.
3. Mapping Information for that font is displayed. You can:

Select a different font from the Map To list.

Change the width or height of the font by selecting a ScaleX and ScaleY factor as a multiple of 
the font's original size.

Select the appropriate formatting (Bold, Italic, Underline, and Strikeout).
4. Repeat steps 2 and 3 as required. To delete a mapping relationship, select a font in List of Fonts and

click Delete.
5. To make these remappings apply to other text documents that you open in this session, click Save 

as default. Click OK.
The text document is redrawn with the new fonts. The document may become longer or shorter. Unless 
you clicked Save as default, your changes affect only the active document.
If you did click Save as default, you can save the font mappings for future sessions.

See also
Font Remapping dialog box 
Remapping fonts in vector documents



Changing pages

Multipage documents are displayed much as any other documents are, except that the current page 
number appears in the Status Bar.
You can page up or down a multipage document.
The following procedures give details about viewing multipage documents.
Paging up or down a multipage
Going to a specific page
Selecting a page by name 
Selecting the first or last page



Paging up or down a multipage

You can page up or down multipage documents.

To move forward a page:

Click 

 in the Status Bar.
or

Press PAGE DOWN.
The next page is displayed. Repeat as required (until you reach the last page) to move through the 
pages.

To move backward a page:

Click 

 in the Status Bar.
or

Press PAGE UP.
The previous page is displayed. Repeat as required (until you reach the first page) to move back 
through the pages.

See also
Going to a specific page number
Selecting a page by name 
Selecting the first or last page



Going to a specific page number

Instead of scrolling through all the pages, you can go directly to a page that you specify by number.

To go to a specific page number:

1. Click the page box  in the Status Bar.
or

Press CTRL+G.
The Page Go To dialog box appears. If some pages have not been formatted yet, the dialog box counts 
up to the Last Page Number.
2. In the dialog box, type the Page Number, or type a plus or minus sign followed by the number to 

increase or decrease the current page by. (For example, if you are on page 2 and you type +4, you 
will go to page 6.) Click OK.

The selected page is displayed.
Note that the page number used by Go to is the one displayed in the Status Bar page window. It may 
differ from the formatted page number that appears in the header or footer of some text files.

See also
Selecting a page by name 
Paging up or down a multipage
Changing pages



Selecting a page by name

Instead of scrolling through all the pages, you can go directly to a page that you specify by name.

To go to a specific page name:

1. Click  in the Standard Toolbar.
or

Choose View -> Contents.
In the Multipage Contents dialog box:
2. If necessary, Branch any of the document folders or pages you want to go to. The "base" document 

folders or pages have a plus sign (+) inside their icon.
3. Double-Click the name of the page to view.

The page whose name you selected is displayed.

See also
Multipage Contents dialog box
Paging up or down a multipage
Going to a specific page number 



Selecting the first or last page

You can go directly to the first or last page of the multipage document. Note that while the current page 
number is displayed in the Status Bar, the total number of pages is not.

To display the first page (at the current page level):

Click 

 in the Status Bar.
or

Press HOME.
To display the last page (at the current page level):

1. Click     in the Status Bar.
or

Press END.
2. If some pages have not been formatted yet, the Count All Pages dialog box appears. It counts up as 

pages are formatted. You can cancel the count by pressing any key, but then the page last counted 
is displayed, instead of the last page in the document.

See also
Going to a specific page number
Selecting a page by name 
Changing pages



Speeding multipage document display

Having a long multipage document loaded can make your system slow down. You can use the "Unload 
Max" keyname in the [System] section of the EROICA.INI file to unload some pages and improve 
performance.
To unload more pages of multipages:
1. Load the EROICA.INI file into a text editor.
2. In the [System] section, set "Unload Max" to an integer value that represents the number of pages to 

keep loaded. To speed viewing, set it to a smaller value than its current one, but a value larger than 
0, as 0 disables page unloading.
If set to 6, for example, the current page and the last five viewed are loaded into memory. The rest 
are not. 

3. Save the EROICA.INI file.

When you restart Eroiica, the "Unload Max" value specified is used.

See also
"Unload Max" keyname ([System] section) 
Optimizing vector document performance 



Applying view options to all pages

The View menu commands apply to the current page only. To set display attributes for all pages in the 
active window, you must use the View Options dialog box. It contains settings that mirror most of the 
View menu commands.
To apply view options to all pages in the active window:
1. Choose Options -> View.

In the View Options dialog box:
2. Select the Display, Scale, Snap and Grid, and other settings that you want to use.
3. Click the Apply to All Pages button.

The dialog box closes, and the selected options are applied to all pages in the window. If you had 
clicked OK instead of Apply to All Pages, the options would have applied to the current page only.

See also
View Options dialog box 
View menu commands
Changing pages 



Adding and removing pages

You can change which pages appear in the active window. You can:

Add a new, blank page to the start or end of the document, or before or after the current page.

Import one or more existing pages to any of these same locations.

Remove one or more pages from the document.
The following procedures give more details.
Creating a page
Importing pages
Removing pages



Creating a page

You can add a blank page containing no layers to the active document window. The result is similar to 
choosing the File, New command, but instead of opening into a separate window, the blank page 
appears in the active window along with whatever other pages are already there.
To add a new page to the document:
1. Choose View -> Contents.
2. Click a document icon or a name of a document that is to receive the new page.
3. Press the right mouse button. Choose Attach page from the pull-down menu that appears.

or

From the Object menu, choose Attach page.
The new page is inserted at the end of the document and is displayed. You can place new edit layers or 
import existing layers into it.

See also
Raster Layer Information dialog box 
Creating an edit layer
Importing layers
"Attribute Prompt on Create" keyname ([System] section)



Importing pages

Use the Eroiica Contents Object -> Import command to bring existing pages into the active document. To
import a page,
To import one or several existing documents as pages:
1. Choose View -> Contents.

In the Eroiica Contents dialog box:
2. Click a document icon or a name of a document that is to receive the page.
3. Press the right mouse button. Choose Import from the pull-down menu that appears.

or

From the Object menu, choose Import.

4. Scroll up or down the list of files in the Page Import dialog box to find the names or labels of the 
pages to import. Click OK.

The page is imported into the window and appended to the end of the document.

See also
Page Import dialog box 
Removing pages



Removing pages

You can remove one or several pages from the active document.
To remove pages from the window:
1. Choose View -> Contents.

In the Eroiica Contents dialog box:
2. If necessary, Branch any of the document folders whose pages you want to remove. The "base" 

document folders have a plus sign (+) inside their icon.
3. Click the name of a page to remove and press the right mouse button. Choose Delete from the pull-

down menu that appears.
or

From the Object menu, choose Delete.
The selected page is removed from the document.

See also
Importing pages



Reordering pages

You can change the order of the pages in the active multipage document.
To reorder pages:
1. Choose View -> Contents.

In the Eroiica Contents dialog box:
2. If necessary, Branch any of the document folders whose pages you want to reorder. The "base" 

document folders have a plus sign (+) inside their icon.
3. Click the name of the page to move and press the right mouse button. From the pull-down menu that

appears, choose Move up to move it one position higher than it is or Move down to move it one 
position lower. Repeat as required.

or

From the Object menu, choose Move up or Move down.
4. Repeat as required.

The multipage is displayed in its new order.

See also
Reordering layers



Configuring remote printing

Through the EROICA.INI file, Eroiica provides services that allow printing to devices for which no 
Windows print driver is available. The [PlotDevices] section allows you define the name, driver, and type 
of print devices to use.
Each device listed in the [PlotDevices] section must further be defined in its own EROICA.INI section. 
These [printer-driver] sections contain settings for the executable, size options and default size, and 
banner and time stamp options.
Finally, the "Old Print Ver" keyname in the [Print] section allows you to specify whether you are calling a 
Command Line interface or a Command File interface.

Once you have configured custom printing, you activate it through the User Interface.
To select a custom printer and specify its print options:
1. Choose File -> Print Setup.

In the Printer Select dialog box:
2. Click the name of the custom printer to use.
3. To specify options for the printer, click Setup.

In the Printer Setup dialog box:
4. Select a Scale To value.
5. Select or clear the Print Time Stamp check box.
6. Optionally, type a text string in the Banner text box. Click OK.
7. In the Printer Select dialog box, click OK.

Print as usual.

See also
[Print] section 
[  printer-driver  ] sections   
Printing the active document



Selecting a printer

The first step in printing is to select the printer you want to use.
To select a printer:
1. Choose File -> Print Setup.

In the Printer Select dialog box:
2. Click the name of the printer to activate.
3. If required, click Setup and set options from the Windows or custom printer dialog boxes. Click OK 

when done.
4. Click OK.

The selected printer becomes active.

See also
Configuring remote printing 
Printing the active document 



Printing the active document

The print operation uses the selected printer and prints the active document according to the options 
you select.
To print the active document:
1. Arrange the document display appropriately.

2. Click  in the Standard Toolbar.
or

Choose File -> Print.
or

Press CTRL+P.
In the Print dialog box (the title bar displays the name of the active printer):
3. From the Print list, select what layers to print.
4. Type the number of Copies to print, if greater than 1.
5. From the Scale list, select how to scale the document. If available, select or clear the Tile check box. 

If available, select or clear the Center check box.
6. Select the print Orientation to use.
7. Select or clear the Merge, Bilevel, and Dither check boxes. If the Dither check box is selected, set 

the Light / Dark slider to the appropriate level.
8. To print a text banner on each page, select the Banner check box. Click the Banner button. In the 

Banner Information dialog box:
a) Type or select the Size of the banner text.
b) Select the Font to use.
c) Type the text to place or Insert Banner Variables at the Top or Bottom Left, Center, or Right of 

each page. Click OK.
9. In the Print dialog box, select the Pages to print: Current page, All pages, or a range of pages (From:

and To:). Click OK.
A message box appears as the document is sent to the selected printer.

See also
Print dialog box 
Banner Information dialog box 
Selecting a printer 



Faxing the active document

To fax locally, use the File -> Print command. To fax from a remote, dedicated fax server, use the File -> 
Fax command if available.
To fax the active document remotely:
1. Arrange the document display appropriately.
2. Choose File -> Fax.

In the FAX Send dialog box:
3. Select which layers to FAX.
4. Type the fax Phone number.
5. Select how to Scale the document. If available, select or clear the Tile check box.
6. Select the fax Orientation to use.
7. To fax each page with a text banner, select the Banner check box. Click the Banner button. In the 

Banner Information dialog box:
a) Type or select the Size of the banner text.
b) Select the Font to use.
c) Type the text to place or Insert Banner Variables at the Top or Bottom Left, Center, or Right of 

each page. Click OK.
8. Click Normal to produce a vertical resolution of 100 dots per inch or Fine for a vertical resolution of 

200 dots per inch. The horizontal resolution is always 100 dots per inch.
9. If the active window contains multiple pages, click which pages to fax: Current page, All pages, or a 

range of pages (From: and To:). Click OK.
The document is sent to the fax server.

See also
FAX Send dialog box 
Displaying and hiding layers
Printing the active document 



E-mailing the active document

Users of CMC-compliant e-mail programs, such as Microsoft Mail, can mail the active document from 
within Eroiica.

To e-mail the active document:
If available

Choose File -> Send Mail.
If not already a SMF document format, the document is converted to SMF format (without overwriting the
original file). The e-mail program opens with the active document appearing as an attachment in it. The 
document has an automatically generated document name.



Scanning

Eroiica supports the TruScan 500, TruScan 600, TruScan 800 (and the ALS836), TruScan Flash, Fujitsu 
3096G, and all TWAIN-compatible scanners (and other TWAIN-compatible peripheral devices).
You select the scanner to use and its options with the File -> Scan Setup command. You can then 
activate scanning.

To produce a scanned document that appears in its own window, use  or the File -> Scan command.
You also use this command to select specific scan options and to initiate scanning.
For more information, refer to your scanner documentation and to the following Help topics:

Scan Setup dialog box
Scan Setup Options - TruScan 500
TruScan 500 Scan Window
Scan Window Options - TruScan 500 dialog box
Cleanup dialog box
Scan Setup Options - TruScan 800
TruScan 800 Scan Window
Scan Window Options - TruScan 800
Browse dialog box

To select the TWAIN-compatible device to use, use the File -> Select Source command. Once you have 
done that, retrieve document from that device using the File -> Acquire command. Your scanner (or 
other device) manual provides all the other information you need.



Using the Status Bar

When displayed, the Status Bar appears in a bar at the bottom of the Eroiica window. It shows pointer 
and status information at all times.
To show or hide the Status Bar:

Choose View -> Toolbars -> Status Bar.
The Status Bar provides the following information.

Status 
Bar item

Purpose

Coordi-
nates

Indicates the pointer's position relative to the top and left edges of the
document. For example, a value of 0,0 indicates that the pointer 
appears at the top left of the document. For raster documents, you 
can use these coordinates to locate the same point on the document 
regardless of the scale factor of the document.

Status 
line

Indicates what action is occurring in the program, such as "Viewing, 
no layers active" or "Drawing lines."

Layer: Indicates which edit layer is currently active

Page 
controls

Indicates which page of a document is currently active.    Page icons 
allow easy access to first, last, previous, and next page.

See also
Showing and hiding bars and floating windows 
Taking drawing measurements 



Taking drawing measurements

You can take measurements of lines and areas on the document. Measure values are displayed in a 
floating Measurements window. It appears automatically when you choose the Measure command, or 
you can choose to display or hide it.

To display or hide the Measurements window:

Choose Window -> Measurement.
Measure information is displayed in the window when you measure a region or draw certain objects. 
Otherwise it is blank.

To measure part of a document:

1. Click  in the Drawing Toolbar.
or

Choose Tools -> Measure.
If not already displayed, the Measurements floating window opens.

2. Click the tool icon that represents the shape of the area to measure:  (line), 

 (box), or 

 (polygon).
3. Do one of the following:

To measure a linear area, drag from one end of the line to measure to the other end.

To measure a rectangular area, drag from one corner of the area to the diagonal one.

To measure a polygonal area, click each corner of the area. When the entire area is defined, 
double-click or click the right mouse button.

As you draw the region to measure, the Measurements shows line length, pointer position, and angle. 
You can change the font used in the Measurements window.
To change the Measurements window font:
1. Load the EROICA.INI file into a text editor.

In the [System] section:
2. Set the "Measurement Window Font Face" keyname to the name of the font to use.
3. Set the "Measurement Window Font Size" keyname to the name of the font to use, in points.
4. Save the EROICA.INI file.
5. To update the Measurements window with the new fonts, restart Eroiica.

See also
"Measurements Window" keyname ([System] section) 
Drawing a line 
Drawing a box 
Drawing a polygon 



Getting layer information

You can obtain technical information about any document, or layer on the current page, such as file size,
data format, image dimension, and resolution.
To view information about a document, page or layer:

1. If the Eroiica Contents window is hidden, click  in the Standard Toolbar.
or

Choose View -> Contents.
In the Eroiica Contents window:
2. If necessary, Branch any of the document folders whose pages or layers are of interest to you. The 

"base" document folders have a plus sign (+) inside their icon.
3. Click the name of the document, page, or layer you want information about. With the right mouse 

button, click the selected item. From the submenu that appears, choose Properties.
3. Read the information in the dialog box and click OK.

You then return to the Eroiica Contents dialog box

See also
Edit Layer Information dialog box 
Raster Layer Information dialog box 



Getting product and version information

With two Help menu commands, you obtain information about the Eroiica program and about all the files
in the system directory.

To view product information:
1. Choose Help -> Product Info.
2. In the Product Information dialog box, read the information and click OK.

Normal display returns.

To view version information:
1. Choose Help -> Version Info.

In the Version Information dialog box:
2. Scroll up and down the list of Files as required.
3. Optionally, click Save to File to save the file information. A message box appears explaining where to

find the information. Click OK.
4. In the Version Information dialog box, click OK.

Normal display returns.

See also
Product Information dialog box 
Version Information dialog box 



Setting the drawing tool options

To set the attributes of objects on the active edit layer:
1. Choose Options -> Draw.

The drawing tools options dialog box appears. If a tool is active, its category is displayed. Otherwise, the
Global category settings are. Global sets certain defaults for all objects.
2. Click the category icon representing the object you want to define.

The title bar displays the category name, and the dialog box shows the settings specific to that tool.
3. Select the options you want for that object.
4. Repeat steps 2 and 3 as required. Click OK.

OK activates the selected settings for all tool categories, not just the one last displayed.

See also
Setting the drawing tool defaults 
Using the drawing tools 
Selecting and placing a symbol 



Setting the drawing tool defaults

Once you decide which tool attributes will work for you most of the time, set those in the drawing tool 
options dialog box, and save your selections for future sessions.
To set tool attribute defaults:
1. Choose Options -> Draw.

The drawing tools options dialog box appears. If a tool is active, its category is displayed. Otherwise, the
Global category settings are. Global sets certain defaults for all objects.
2. Scroll down the Category box as required, and click the icon representing the drawing tool whose 

attributes you want to change.
The title bar displays the category name and the dialog box shows the settings specific to that tool.
3. Select the preferences you want for that object.
4. Repeat steps 2 and 3 as required.
5. To save the settings for future sessions, click Save as default. Click OK.

The settings selected are used by default for all subsequent edit layers. The active edit layer (if any) 
retains the current tool options.

See also
Setting the drawing tool options 
Using the drawing tools 



Setting Global drawing tool options

The Global settings define attributes for several drawing objects at once, which is useful if you want all 
your objects to have the same attributes. The Global settings are used as long as you click OK before 
making changes in any other categories.
To set global drawing tool attributes:
1. Choose Options -> Draw.

The drawing tools options dialog box appears. If a tool is active, its category is displayed.
2. Scroll down the Category box as required, and click the icon representing the Global category.

The title bar displays Global Options and the dialog box shows the defaults specific to all tools:
3. You can:

Select a line, frame, or text Color for all objects.

Type or select a line or frame Width for all objects.

Select a line Style for all objects.

Click Cap Round or Cap Square for all objects.
4. To save the global attributes for future sessions, click Save as default. Click OK.

The selected attributes are used for all subsequent objects on the edit layers.

See also
Global category: Global Options dialog box 
Selecting object colors 
Changing line style 
Using the cap settings 



Setting Grid options

As you draw objects, you may want them to snap to grid points. Or you may want them to be orthogonal.
You set grid options in the View Options dialog box.
To set grid defaults:
1. Choose Options -> View.

In the Snap and Grid section of View Options dialog box:
2. You can:

Select or clear the Snap to Grid check box. If selected, type or select the grid size.

Select or clear the Snap Orthogonal check box. If selected, all objects are drawn, move, and 
rotate by 90 degree angles.

For the grid to show on the document, select the Display Grid check box and, from the list, select 
the grid color to use.

3. Click Save as default. Click OK.
Those grid options are used by default.

See also
View Options dialog box (Snap and Grid) 



Defining units of measurement

When defining the size of objects, you can select various units of measurement. You will likely prefer to 
use either imperial or metric units by default. You specify that in the Measurement Options dialog box.
To select a default unit of measurement and define custom units:
1. Choose Options -> System.
2. Scroll down the Category box as required, and click the icon representing the Measurement 

category.
In the Measurement Options dialog box:
3. Select the Imperial, or Metric as the default units from the Units of Measure list.
3. Define any Custom Units by typing their name and typing or selecting their equivalent value.
4. To save the units for future sessions, click Save as default. Click OK.

In all dialog boxes, units are reset to the ones selected. Custom units are added to the list of options.

See also
Defining line and frame width 
Setting text attributes 



Selecting line, frame, and text colors

You can choose different colors for your objects. A Color or Frame Color setting is available in almost all 
the tool categories.
To select line, frame, or text colors: 
1. In the Draw Options dialog box, click the Category icon of the object to define.
2. Select a color from the Color or Frame Color list. Repeat from step 1 as required.

The default color is often red. The Background color is normally white, black if inverted. The Foreground 
color is normally black (white if inverted).
3. To save the colors for future sessions, click Save as default. Click OK.

The line, frame, and text colors are used for subsequent objects on the active edit layers.

Sixteen colors are available for selection in the dialog boxes. You can select other default colors by 
editing the EROICA.INI file. (Your selection--unless it one of the basic 16--does not get added as a list 
option in the dialog boxes.)
The [Tool] section contains numerous "Colour" keynames that define the line and frame colors for all the 
objects. The syntax for these keynames is:
Object Colour=RRR,GGG,BBB
Where R=red, G=green, and B=blue, and each is a value between 0 and 255, where 0 equals none and 
255 equals the maximum intensity of that color. For example, for pure red you use 255,0,0.

Tip: Use the Options -> Edit Colors in the Windows 3.1 Paintbrush to see what numbers produce what 
colors.

Note that changes to the EROICA.INI file only take effect after you restart Eroiica.

If the View -> Colors -> Monochrome command is active, all objects appear in black and white. 
Deactivate this option to see object colors.

See also
[Tool] section (EROICA.INI file) 
Inverting document colors 



Defining line and frame width

You can specify various widths for your drawing object lines using the Width, Line Width, and Frame 
Width settings in the drawing tools options dialog boxes. This setting is in all categories except Symbol, 
Text, and Annotation.
To define the line or frame width of an object: 
1. In the Draw Options dialog box, select the Category of the object to define.
2. Select the Line Width, Width, or Frame Width unit.
3. Type or select the appropriate value. Repeat from step 1 as required.
4. To save the widths for future sessions, click Save as default. Click OK.

The selected line or frame widths are defined for the active or for subsequent edit layers.

You can also set lines width using the floating Line Width window.
To use the Line Width window to define line width:

1. If the Line Width window is hidden, click  in the Standard Toolbar.
or

Choose Window -> Line Width.
2. Choose the tool you want to draw with.

A line appears in the Line Width window. The title bar indicates the current line width.
3. In the Line Width window, click the triangle at the appropriate line width or drag the red line up or 

down the box to the appropriate line width.
Your Line Width selection affects subsequent objects drawn with the active tool, but not those already 
placed.

Please note that if the Use Hairlines in the View Options dialog box is active, all object lines display as 
being 1 screen pixel thick at all scale factors. Deactivate the command to see the different line widths.

See also
Defining units of measurement 



Changing line and frame style

Lines can be dotted or dashed in a variety of patterns. Use the Line Style or Frame Style setting to 
select the line pattern to use. It is available in all drawing tool categories except Highlighter, Highlight 
Area, Text, and Annotation.
To select line styles: 
1. In the Draw Options dialog box, click the Category of the object to define.
2. Select the style you want from the Style or Frame Style list. Repeat from step 1 as required.
3. To save the styles for future sessions, click Save as default. Click OK.

The line styles selected apply to subsequent objects on the active or on subsequent edit layers.

The [Dashed Lines] section of the EROICA.INI file defines additional line and frame styles for selection. 
Any styles defined are added to the Line and Frame Style lists. The syntax is:
name=0 | 1 1 | 2 +value -value (+value -value ...)
Where
name = any text string that describes the line style.
0 | 1 = do not (0) or do (1) center dash pattern between extents
1 | 2 = inches (1) or centimeters (2)
+value = length of a dash (or dot) in the line style, in pixels.
The + sign is optional. If you omit it, it is assumed.
-value    = length of the space following the dash, in pixels.
Continue to specify dash and space values until you have completed one cycle of the line pattern. Omit 
parentheses when doing so.

See also
[Dashed Lines] section 



Selecting translucent or opaque lines

Most line objects can be either translucent (semi-transparent color) or opaque (solid color). The 
exceptions are highlighter lines, which are always translucent, and rubout lines, which are always 
background color.
To select object opacity:
1. In the Draw Options dialog box, click the category icon (Line, Arc, Arrow, Sketch, Polyline, or 

Dimension) of the line object to define.
2. Click Translucent or Opaque. Repeat from step 1 as required.
3. To save the opacity for future sessions, click Save as default. Click OK.

The selected color styles are used for subsequent objects on the active or on subsequent edit layers.

See also
Selecting line, frame, and text colors 



Using the cap settings

You can specify the style of the line ends in the Line and Global categories of Draw Options dialog box.
To select a cap style:
1. In the Draw Options dialog box, to define the line end style for all objects, click the Global category. 

To define line objects only, click the Line category.
2. Click Cap Round ( ) or Cap Square (
).
3. To use that cap style in future sessions, click Save as default. Click OK.

To set the default cap styles of specific objects other than lines, edit the EROICA.INI file.
To set the default cap style of objects other than lines:
1. Load the EROICA.INI file into a text editor.
2. In the [Tool] section, find keynames with the word "Capstyle" in them. Set them to 0 for rounded and 

1 for squared.
3. Save the EROICA.INI file.
4. Restart Eroiica.

The selected cap styles are updated for subsequent edit layers.

See also
Global category: Draw Options dialog box 
Line Category: Draw Options dialog box 
[Tool] section 



Setting arrowhead attributes

The Arrow and Dimension categories contain settings for defining the appearance of their arrowheads.
To define the appearance of arrowheads:
1. In the Draw Options dialog box, click the Arrow or the Dimension category.
2. Click the Arrowhead Size to use: Fixed, or Proportional to the length of object line. If you click Fixed, 

type or select the Size value.

3. Click the Arrowhead Style to use: Solid ( ) or Hollow (>).
4. Click the number of Heads: Single (one) or Double (two).
5. To save the arrowhead attributes for future sessions, click Save as default. Click OK.

The arrow or dimension arrowheads appear as defined for subsequent objects on the active or 
subsequent edit layers.

See also
Arrow category: Draw Options dialog box 
Dimension category: Draw Options dialog box 



Setting text attributes

The Text, Annotation, and Dimension categories contain settings that define the appearance of text for 
these objects.
To define the appearance of text objects:
1. In the Draw Options dialog box, click the Text, Annotation, or Dimension category.
2. Select the Text Font. You can use any installed TrueType or printer font.
3. Type or select the Text Size (or height).
4. Select the Text Angle.
5. For text and annotations, select or clear the Style check boxes: Bold, Italics, Underline, and 

Strikeout. You can select combinations of styles.
6. For annotations, select or clear the Initially Iconized check box. When selected, annotations appear 

as icons when placed. When cleared, annotations appear as text when placed, if Simple Text is 
selected as the Annotation Display in view options.

5. To save the text attributes for future sessions, click Save as default. Click OK.
Subsequent text, annotation, or dimension text appears as defined on the active or on subsequent edit 
layers.

You set certain text defaults in the EROICA.INI file.
To change the default shape of annotations and the default style of dimension text:
1. Load the EROICA.INI file into a text editor.

In the [Tool] section:
2. Set "Annotation Iconized" to 0 to have annotations display initially as text, or to 1 to have them 

initially display as icons.
3. Set "Dimension Text Typeface" to 0 for normal, 1 for bold, 32 for strikeout, 64 for underline, and 128 

for italic. To combine the styles, add these values together. For example, to have Bold Italic text, set
the value to 129 (1 + 128 = Bold + Italic = 129).

4. Save the EROICA.INI file.
5. Restart Eroiica.

The selected annotation shape and dimension text style are used by default for subsequent edit layers.

See also
Dimension category: Draw Options dialog box 
Annotation category: Draw Options dialog box 
Text category: Draw Options dialog box 
View Options dialog box (Annotation Display) 
[Tool] section 



Defining the dimension style

Dimensions appear in one of three Styles, styles that determine the placement of extension lines and 
text, but not the number of arrows.

To select the dimension style:
1. In the Draw Options dialog box, click the Dimension category.
2. Select the dimension style you want from the Style list.
3. To save the style for future sessions, click Save as default. Click OK.

That style applies to subsequent dimensions on the active or on subsequent edit layers.

See also
Dimension category: Draw Options dialog box 
Drawing a dimension line 



Setting fill attributes

The Box, Circle, Ellipse, and Polygon categories all contain the same settings. The Highlight Area 
category is similar, except that it has no Fill Style setting--it is always translucent--while it does have a 
Shape setting. The Erase Area category contains Shape and Frame Width settings only.

To select the color of fill attributes:
1. In the Draw Options dialog box, click the Box, Circle, Ellipse, Polygon, Highlight Area, or Erase Area 

category.
2. Select the Fill Color to use.
3. For categories other than Highlight Area and Erase Area, select the Fill Style.

Highlight Area is always translucent. Erase Area always has an erase fill.
5. For Highlight Area and Erase Area, select the Shape to use: Box, Polygon, Circle, or Ellipse. Repeat 

from step 1 as required.
6. To save the fill attributes for future sessions, click Save as default. Click OK.

The selected fill attributes apply to subsequent objects on the active or on subsequent edit layers.
Please note that if the Use Wireframes in the Vectors section of the View Options dialog box is active, all
objects appear as having transparent fills. Deactivate this command to display the different fill styles.

See also
Selecting object colors 
Changing line style 
Defining line width 
View Options dialog box 



Defining hotspots

Hotspots can come in any shape or size. You can place them with the Hotspot tool or attach them to 
existing objects. The type of object used by the Hotspot tool is defined in the Hotspot category.
To define hotspots:
1. In the Draw Options dialog box, click the Hotspot category.
2. Select the hotspot Shape to use: Box, Circle, Ellipse, Polygon, Symbol, or Icon.
3. Do one of the following:

If you have selected a filled object shape, select the Fill and Frame attributes you want.

If you have selected the Icon shape, scroll through the list of Icons to the one you want to use.

If you have selected the Symbol shape, click Browse, select the symbol file in the Set Symbol 
dialog box, and click OK.

4. To save the hotspot settings for future sessions, click Save as default. Click OK.
Hotspots are defined for the active or for subsequent edit layers.

See also
Hotspot category: Draw Options dialog box 
Set Symbol dialog box 
Placing a hotspot 
Setting fill attributes 



Selecting a default symbol

You can select a file to use by default as a symbol.
To select the default symbol file:
1. Choose Options -> Draw.
2. Scroll down or up the category box as required and click the Symbol icon.

In the Symbol Options dialog box:
3. Type the drive, directory, and file name of the symbol in the Name text box.

or

Click Browse and, in the Symbol dialog box, select the Drive and Directory and type the File 
Name. Click OK.

4. To save the symbol settings for future sessions, click Save as default. Click OK.
The selected symbol is now attached to the Symbol tool. It remains selected until you choose another 
symbol file.
If you want whatever symbol file you selected last to be saved as the default, edit the EROICA.INI file.
To always save the last symbol selected as the default symbol:
1. Load the EROICA.INI file into a text editor.
2. In the [File] section, set the "Retain Last Active Symbol" keyname to 1.
3. Save the EROICA.INI file.

When you restart Eroiica, the last symbol you select automatically becomes the default symbol for the 
next session.

See also
Set Symbol dialog box 
Selecting and placing a symbol 
Creating a symbol
"Retain Last Active Symbol" keyname ([File] section) 



Setting eraser options

You select attributes for the Rubout and Erase Area tools in the Draw Options dialog boxes.
To specify the attributes of subsequent rubouts and erased areas:
1. Choose Options -> Draw.

In the Draw Options dialog box:
2. To change the rubout line options, scroll down or up the category box as required and click the 

Rubout category. Type or select the Width of the rubout line in the units selected.
3. To change the erase area options, scroll down or up the category box as required and click the Erase

Area category. Select the erase area Shape to use: Box, Polygon, Circle, or Ellipse. Because the 
Frame Width lines are invisible, we recommend you leave this setting at a value of 0.005 inches 
(very thin, in other words).

4. To save the eraser options for future sessions, click Save as default. Click OK.
Rubout and Erase Area are defined for the active or for subsequent edit layers.

See also
Rubout category: Draw Options dialog box 
Erase Area category: Draw Options dialog box 
Freehand erasing 
Using Erase Area 



Using the drawing tools

Eroiica offers a broad selection of drawing tools. What follows are common questions and problems 
concerning them.
I cannot select the drawing tools...
The current document probably does not contain an active edit layer. To activate an edit layer, either 
create one by clicking the New Layer icon in the Standard Toolbar, or activate an existing one using the 
Eroiica Contents window (Object -> Attach layer).
How can I tell which drawing tool is active?
An active drawing tool is indicated by a checked command in the Draw menu or a drawing tool icon 
depressed. For the various tools the pointer changes shape to help guide you as you draw the object. 
An active drawing tool stays active until you go to another document window or click the Select icon.
How do I deactivate a drawing tool?
To deactivate a tool either activate another tool or click the Select icon.
What if I make a mistake while drawing an object?
While still drawing, use the ESC key to cancel what you have already placed. Right after drawing an 
object, use Edit -> Undo to remove it. You can also delete objects by selecting them (Edit -> Select) and 
pressing the DELETE key. Other Edit menu commands allow you to modify objects.
The objects seem to move after I zoom in or merge the document...
That is because you can place objects very accurately only when the document displays at a 1:1 scale 
factor. Use the CTRL+1 key combination to display the document at that scale ratio. You can also use the 
Detail window as a guide while drawing.

See also
Draw menu commands 
Drawing Bar command (View menu) 
Creating an edit layer 
Selecting objects 



Creating an edit layer

An active edit layer must appear on the document before you can use any of the Draw and most of the 
Edit menu. One way to activate an edit layer is to add a new one by clicking the New Layer icon in the 
Standard Toolbar.
To define a layer type:
1. Choose Options -> System.
2. Scroll down or up the category box as required and click the Optimizations icon.

In the Optimizations Options dialog box:
3. Choose the appropriate layer type from the New layer will be text box: Redline, Edit, Full Edit, 

Annotation, or Hotspot.

With Redline layers are for all objects except annotations, hotspots, highlighted areas, erased (or 
cut) areas, rubouts, and raster pastes. You are also limited to the transparent fill style.

Edit types allow you to use all the Edit commands and place any objects (with any attributes) 
except annotations and hotspots.

Full Edit types have no restrictions. You can place all objects and use all the Edit menu 
commands.

Annotation types permit annotations, arrows, text, highlighted sketches, and box-shaped highlight
areas.

Hotspot layers are for hotspots, lines, arcs, arrows, sketches, and polylines only.
To create a layer:

To create an edit layer, click 

 in the Standard Toolbar.
or

1. Choose View -> Contents.
In the Eroiica Contents window:
2. If necessary, Branch any of the document folders or pages you want to go to. The "base" document 

folders or pages have a plus sign (+) inside their icon.
3. Click the name of a page or document.
4. Choose Object -> Attach layer.

The new layer becomes the active edit layer, ready for edits and markups. Unless you have already 
specified a label, it is called "New Layer #" (where # = an integer).

See also
Edit Layer Information dialog box
Using the drawing tools
"Attribute Prompt on Create" keyname ([System] section) 



Drawing a line

You draw lines on active Full Edit, Edit, Hotspot, or Redline edit layers. Unless Snap Orthogonal is 
selected, you can angle the line in any direction.
To draw a line:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Line.
2. On the active edit layer, drag from the start of the line to the end. (To cancel, press ESC.)

If the Measurements window is displayed, measure information for the line is displayed in it as you draw 
the line.

The Line tool remains active.

The default attributes of lines are set by the Line category in the Draw Options dialog box. To change 
these attributes for the active edit layer, use the Line category in the Draw Options dialog box or the Line
Width window. To change the attributes of this line, use the Edit -> Modify Selected menu commands.

See also
Creating an edit layer
Setting grid options 
Line category: Draw Options dialog box
Edit menu commands



Drawing an arc

You can draw arcs on active Full Edit, Edit, Hotspot, or Redline edit layers. If Snap Orthogonal is 
selected, the two ends points of the arc must be vertical or horizontal, but the third point is unrestricted.
To draw an arc:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Arc.
On the active edit layer:
2. Click one end of the arc.
3. Move the pointer to the other end of the arc and click. 
4. Move the pointer out to the radius of the arc and click. (To cancel, press ESC.)

The arc is drawn so that it connects the three points you clicked, starting at the first point and ending at 
the second, moving in a clockwise direction through the third. The Arc tool remains active.

The default attributes of arcs are set by the Arc category in the Draw Options dialog box. To change 
these attributes for the active edit layer, use the Arc category in the Draw Options dialog box, or the Line
Width window. To change the attributes of this arc, use the Edit -> Modify Selected menu commands.

See also
Creating an edit layer
Setting grid options 
Arc category: Draw Options dialog box 
Edit menu commands 



Drawing a box

You can boxes on active Full Edit, Edit, or Redline (transparent boxes only) edit layers.
To draw a box:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Box.
2. On the active edit layer, drag from one corner of the box to the diagonal corner. (To cancel, press 

ESC.)
If the Measurements window is displayed, measure information is displayed in it as you draw the box.

The Box tool remains active.

The default attributes of boxes are set by the Box category in the Draw Options dialog box. To change 
these attributes for the active edit layer, use the Box category in the Draw Options dialog box, the Line 
Width window. To change the attributes of this box, use the Edit -> Modify Selected menu commands.

See also
Creating an edit layer
Box category: Draw Options dialog box 
Setting fill attributes 
Edit menu commands 



Drawing a circle

You can draw circles on active Full Edit, Edit, or Redline (transparent circles only) edit layers.
To draw a circle:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Circle.
2. On the active edit layer, drag from the center of the circle to the appropriate radius. (To cancel, press 

ESC.)

The Circle tool remains active.

The default attributes of circles are set by the Circle category in the Draw Options dialog box. To change 
these attributes for the active edit layer, use the Circle category in the Draw Options dialog box, the Line 
Width window. To change the attributes of this circle, use the Edit -> Modify Selected menu commands.

See also
Creating an edit layer
Circle category: Draw Options dialog box 
Setting fill attributes 
Edit menu commands 



Drawing an ellipse

You can draw ellipses on active Full Edit, Edit, or Redline (transparent ellipses only) edit layers.
To draw an ellipse:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Ellipse.
2. On the active edit layer, drag from the center of the ellipse to the appropriate radius. (To cancel, 

press ESC.)

The Ellipse tool remains active.

The default attributes of ellipses are set by the Ellipse category in the Draw Options dialog box. To 
change these attributes for the active edit layer, use the Ellipse category in the Draw Options dialog box,
the Line Width window. To change the attributes of this ellipse, use the Edit -> Modify Selected menu 
commands.

See also
Creating an edit layer
Ellipse category: Draw Options dialog box 
Setting fill attributes 
Edit menu commands 



Drawing an arrow

You can draw arrow-tipped lines on any active edit layer. If Snap Orthogonal is selected, the arrow must 
be vertical or horizontal.
To draw an arrow:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Arrow.
2. On the active edit layer, drag from the start of the arrow to the end.

The single arrowhead is drawn at the last point defined. The Arrow tool remains active.

The default attributes of arrows are set by the Arrow category in the Draw Options dialog box. To change
these attributes for the active edit layer, use the Arrow category in the Draw Options dialog box, or the 
Line Width window. To change the attributes of this arrow object, use the Edit -> Modify Selected menu 
commands.

See also
Creating an edit layer
Setting grid options 
Arrow category: Draw Options dialog box 
Edit menu commands 



Freehand drawing

You use the Sketch tool to freehand draw on active Full Edit, Edit, Redline, or Hotspot edit layers. If 
Snap Orthogonal is selected, the sketch consists of vertical and horizontal lines only.
To draw freehand:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Sketch.
2. On the active edit layer, position the pointer where you want to start sketching and drag to draw. (To 

cancel, press ESC.)

The Sketch tool remains active.

The default attributes are set by the Sketch category in the Draw Options dialog box. To change these 
attributes for the active edit layer, use the Sketch category in the Draw Options dialog box or the Line 
Width window. To change the attributes of this sketch, use the Edit -> Modify Selected menu command.

See also
Creating an edit layer
Setting grid options 
Sketch category: Draw Options dialog box 
Edit menu commands 



Drawing a polyline

You can draw polylines on active Full Edit, Edit, Hotspot, or Redline edit layers. If Snap Orthogonal is 
selected, the polyline consists of vertical and horizontal lines only. 
To draw a polyline:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Polyline.
On the active edit layer:
2. Click the start of the first line, move the pointer to the end point of that line and click, move to the end

of the second line and click, and so on. (To cancel, press ESC.)
3. To place the last point at the pointer location, double-click.

If you have already placed all points, click with the right mouse button.

The Polyline tool remains active.
The default attributes are set by the Polyline category in the Draw dialog box. To change these attributes
for the active edit layer, use the Polyline category in the Draw Options dialog box, or the Line Width 
window. To change the attributes of this polyline, use the Edit -> Modify menu commands.

See also
Creating an edit layer
Setting grid options 
Polyline category: Draw Options dialog box 
Edit menu commands 



Drawing a polygon

You can draw polygons on active Full Edit, Edit, or Redline (transparent polygons only) edit layers. If 
Snap Orthogonal is selected, the lines that bind the polygon must all be vertical or horizontal, except for 
the closing line segment.
To draw a polygon:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Polygon.
On the active edit layer:
2. Click where the first corner goes, move the pointer to the second corner and click, move it to the third

corner and click, and so on.
3. To place the last corner at the pointer location, double-click.

If you have already placed all points, click with the right mouse button.

The Polygon tool remains active.

The default attributes of polygons are set by the Polygon category in the Draw dialog box. To change 
these attributes for the active edit layer, use the Polygon category in the Draw Options dialog box, the 
Line Width window. To change the attributes of this polygon, use the Edit -> Modify Selected menu 
commands.

See also
Creating an edit layer
Setting grid options 
Polygon category: Draw Options dialog box 
Edit menu commands 



Freehand highlighting

You can use the Highlighter tool on active edit layers of the Redline, Edit, Annotation, and Full Edit type. 
If Snap Orthogonal is selected for this edit layer, the highlighting lines must all be vertical or horizontal.
To freehand highlight:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Highlighter.
2. On the active edit layer, position the pointer where you want to start highlighting and drag to sketch.

The Highlighter tool remains active.

The default attributes of highlighted sketches are set by the Highlighter category in the Draw dialog box. 
To change these attributes for the active edit layer, use the Highlighter category in the Draw Options 
dialog box, or the Line Width window. To change the attributes of this highlighted line object, use the Edit
-> Modify Selected menu commands.

See also
Creating an edit layer
Setting grid options 
Highlighter category: Draw Options dialog box 
Edit menu commands 



Using Highlight Area

You can use Highlight Area on active edit layers of the Edit, Annotation, or Full Edit type. Highlight Area 
highlights an area of the document. If Snap Orthogonal is selected for this edit layer, polygonal 
highlighted areas consist of vertical and horizontal lines, except for the closing line segment.
To highlight an area:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Highlight Area.
2. For rectangular areas, drag from one corner to the diagonal corner. For circular or elliptical areas, 

drag from the center to the appropriate radius. For polygonal areas, click all the corner points, then 
click with the right mouse button.

The Highlight Area tool remains selected.

The default attributes of shaded areas are set by the Highlight Area category in the Draw dialog box. To 
change these attributes for the active edit layer, use the Highlight Area category in the Draw Options 
dialog box, or the Line Width window. To change the attributes of this highlighted area, use the Edit -> 
Modify Selected menu commands.

See also
Creating an edit layer
Setting grid options 
Highlight Area category: Draw Options dialog box 
Setting fill attributes 



Placing text

You can add text to active Full Edit, Edit, Annotation, or Redline edit layers. You can type text directly on 
a layer or place it through a dialog box, depending on the "Use Dialog Box for Text Entry" keyname in 
the [User Interface Preferences] section of the EROICA.INI file.

To place text through a dialog box (Use Dialog Box for Text Entry=1):

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Text.
The pointer becomes an I-beam.
2. On the active edit layer, click the upper left corner of the text location.
3. In the Text dialog box, type the text to place. Press ENTER to start a new line of text. To paste text 

from the Clipboard, click Paste or press CTRL+V. (If the Clipboard is empty or contains graphics, the 
Paste button is unavailable.) Click OK.

To place text directly on the active edit layer (Use Dialog Box for Text Entry=0):
1. Activate the Text tool.

The pointer becomes an I-beam cursor.
2. On the active edit layer, type the text where you want it to be. Press ENTER to start a new line of text. 

(To undo any typing, press the BACKSPACE key.)
3. To complete the text object, click somewhere else on the layer or press ENTER twice.

The default text attributes are set by the Text category in the Draw dialog box. To change these 
attributes for the active edit layer, use the Text category in the Draw Options dialog box. To change the 
attributes of this text object, use the Edit -> Modify Selected menu commands.

See also
Creating an edit layer
"Use Dialog Box for Text Entry" keyname ([User Interface Preferences] section) 
Text category: Draw Options dialog box 
Setting text attributes 



Placing an annotation

You can place annotations (textual notes that can be reduced to icons) are placed on active Full Edit or 
Annotation edit layers.
To place an annotation:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Annotation.
The pointer changes to: .
2. On the active edit layer, click the center of the annotation icon or the beginning of the annotation text.
3. In the Annotation Text dialog box, type the annotation text in the box. Press ENTER to start a new line 

of text. To copy text from the Clipboard, click Paste or press CTRL+V. (If the Clipboard is empty or 
contains graphics, the Paste button is unavailable.) Click OK.

As long as the Show Annotations check box is selected in the View Options dialog box, the annotation 
appears on the layer as either an icon or as text. (Otherwise it is hidden.) The Annotation tool remains 
active.
You display the annotation text or minimize the annotation with the View, Annotations commands or by 
double-clicking the annotation when no tool is active.

The default attributes of annotations are set by the Annotation category of the Draw dialog box. To 
change these attributes for the active edit layer, use the Annotation category in the Draw Options dialog 
box. To change the attributes of this annotation, use the Edit -> Modify Selected menu commands.

See also
Creating an edit layer
Viewing annotations 
View Options dialog box (Show Annotations) 
Annotation category: Draw Options dialog box 



Placing a hotspot

You can place hotspots on active Full Edit or Hotspot edit layers.
To place a hotspot:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Hotspot.
2. On the active edit layer, click the location of the hotspot icon, draw the hotspot object, or paste the 

hotspot symbol.
A dialog box appears if "Hotspot Data Prompt=1" in the [Tool] section of the EROICA.INI file.
3. In the Hotspot Data dialog box, type the required text. It must be a text string that the receiving 

program can handle. Click OK.
As long as the Show Hotspots check box is selected in the View Options dialog box, the hotspot appears
where you placed it. (Otherwise it is hidden.) The Hotspot tool remains active.

Hotspot defaults are selected in the Draw dialog box, Hotspot category. To change them for the active 
edit layer, use the Hotspot category in the Draw Options dialog box. To modify the appearance of this 
hotspot, use the Edit -> Modify Selected command. To change the hotspot data, use the Draw -> 
Hotspot command.

See also
Placing hotspots in a text document 
"Hotspot Data Prompt" keyname ([Tool] section) 
Activating hotspots 
Hotspot category: Draw Options dialog box 



Placing hotspots in a text document

You can place a hotspot in a Word for Windows or WordPerfect document, if you have access to one of 
these programs.
To place a hotspot in a text document:
1. Start the Word or WordPerfect program.
2. Open the document that you want to place a hotspot in.
3. Place a Word annotation or a WordPerfect comment at the hotspot location. Begin the annotation or 

comment with the "Hotspot Trigger String" text, as defined in the [FormattedText] section of the 
EROICA.INI file. The default trigger string is !HOTSPOT!.

4. Follow the trigger string immediately with > for right margin, < for left margin, or . for inline. (This 
defines the hotspot location.)

5. Follow the <, >, or . character with #nnn (nnn = an integer from 001 to 100) to attach the hotspot to 
a hotspot icon or with text-string (note the single quotation mark character) to attach the hotspot
to a text object containing "text-string".

6. Press ENTER to start a new line (leave no spaces), and type the hotspot data.
For example, if you are using HOTSPOT.EXE, you can type:

!HOTSPOT!<#075
#echo this text

to create a hotspot attached to icon #75 that displays "echo this text" in a dialog box when activated.
7. Save the document.

When you view that document in Eroiica, the comment or annotation is interpreted as a hotspot icon or a
hotspot text object instead of as an annotation.

See also
[FormattedText] section 
Activating hotspots
Placing hotspots
Using HOTSPOT.EXE



Drawing a dimension line

Dimensions are arrows with dimension text. External linear dimensions also have extension lines at 
each end of the arrow. You can place dimensions on active Full Edit, Edit, or Redline edit layers.
The following topic explains how to select a dimension style: Defining the dimension style

To draw a horizontal external linear dimension:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Dimension.
On the active edit layer:
2. Click the first point of the dimension line. (To cancel, press ESC.)
3. Move the pointer across to the end point of the dimension line and click.
4. Move the pointer back between the two dimension points and click.

5. In the Dimension Text dialog box, type the dimension text in the box. Press ENTER to start a new line 
of text. To copy text from the Clipboard, click Paste or press CTRL+V. (If the Paste button appears 
dimmed, the Clipboard is empty or contains graphics.) Click OK.

If the text is longer than the dimension line length, the line breaks up. The Dimension tool remains 
active.

To draw an internal linear or leader text dimension:
1. Activate the Dimension tool.

On the active edit layer:
2. Click the first point of the dimension line.
3. Move the pointer across to the end point of the dimension line and click. (To cancel, press ESC.)
4. Type the dimension text and click OK.

For internal line dimensions, if the text is longer than the dimension line, the line breaks up. The 
Dimension tool remains active.

The default dimension attributes are set by the Dimension category in the Draw dialog box. To change 
these attributes for the active edit layer, use the Dimension category in the Draw Options dialog box or 
the Line Width window. To change the attributes of this dimension, use the Edit -> Modify Selected menu
commands.

See also
Creating an edit layer
Setting grid options 
Dimension category: Draw Options dialog box 



Selecting and placing a symbol

You can recall a saved group of objects--a symbol--and place it onto any active Full Edit, Edit, or Redline
edit layer.

To define the default symbol directory:
1. Choose Options -> System.
2. Scroll down or up the category box as required and click the File Formats category.

In the File Formats Options dialog box:
3. Type the directory path in the Symbol Directory text box. Click Save as default. Click OK.

That directory is used by the Symbol palette.

To select a symbol:
1. If the floating Symbols window is hidden, choose Windows -> Symbol Palette.

The Symbols palette displays all symbol files located in the symbol directory. If necessary, click it with 
the right mouse button and, from the submenu that appears, choose Refresh to update it.
2. In the Symbols palette, click the symbol to use.

To place a symbol:

1. Click  in the Drawing Toolbar.
or

Choose Draw -> Symbol.
On the active edit layer:
2. Drag the symbol to where you want it placed. (To cancel, press ESC.)

The symbol appears on the layer. The Symbol tool remains active.

To change the attributes of this symbol, use the Edit -> Modify Selected menu commands.

See also
Creating a symbol
File Formats dialog box 
Symbol Category: Draw Options dialog box 
Set Symbol dialog box 



Freehand erasing

You can draw rubout lines on active Edit or Full Edit layers. If Snap Orthogonal is selected, all rubout 
lines must be vertical or horizontal.
To freehand erase:

1. Click  in the Standard Toolbar.
or

Choose Draw -> Rubout.
On the active edit layer:
2. Position the pointer on the layer and drag to erase.

The lines drawn are painted to the background color, hiding the underlying layers. The Rubout tool 
remains active.

The default erase attributes for rubout lines are set by the Rubout category in the Draw dialog box. To 
change these attributes for the active edit layer, use the Rubout category in the Draw Options dialog 
box. To change the attributes of this rubout object, use the Edit -> Modify Selected menu commands.

See also
Creating an edit layer
Setting grid options 
Rubout category: Draw Options dialog box 
Using Erase Area 



Using Erase Area

You can draw erased areas on active Edit or Full Edit layers. If Snap Orthogonal is selected, polygon-
shaped erased areas consist of vertical and horizontal lines, except for the closing line segment.
To erase an area:

1. Click  in the Standard Toolbar.
or

Choose Draw -> Erase Area.
2. On the active edit layer, for rectangular erased areas, drag from one corner to the diagonal corner. 

For elliptical and circular erased areas, drag from the center to the appropriate radius. For polygonal 
erased areas, click all the corner points, then click with the right mouse button.

The erased area is filled with the background color. The Erase Area tool remains active.

The default Erase Area attributes are set by the Erase Area category of the Draw dialog box. To change 
these attributes for the active edit layer, use the Erase Area category of the Draw Options dialog box. To 
change the attributes of the erased area, use the Edit -> Modify Selected menu commands.

See also
Creating an edit layer
Setting grid options 
Erase Area category: Draw Options dialog box 
Freehand erasing 



Undoing object placement and deletion

Eroiica keeps track of the changes you made on each edit layer. If you change your mind or make a 
mistake, reverse the last several actions, keeping in mind that actions include placing and deleting 
objects, but not moving and resizing them. You can also "redo" an action that you have undone.

To undo the latest action on the active edit layer:

Choose Edit -> Undo.
or

Press CTRL+Z.
The last change made is reversed. You can choose Edit, Undo repeatedly until you reach an action that 
cannot be undone, or until no actions are left to be undone.

To "redo" an action that you have canceled:

Choose Edit -> Redo.
or

Press CTRL+Y.
The last Undo command result is reversed. You can also choose Edit, Redo repeatedly, until all actions 
are reversed. Redo and Undo lists are not saved from session to session.



Selecting objects

You can move, resize, rotate, change the attributes of, change the text of, and attach hotspots to any 
objects on the active edit layer. Before you do, however, you must select them.
To select one or several objects:
1. Unless Select is already active, do one of the following:

Click 

 in the Drawing Toolbar.
or

Choose Edit -> Select.
or

Press CTRL+L.
Any already selected objects are outlined.
2. Click an object that you want to select or drag a box around them all. Stacked objects are selected 

from the top down.
Each selected object is outlined with short dashed lines, and the entire group is outlined with one 
rectangle composed of long dashed lines. The Status Bar (if displayed) indicates the number of objects 
selected. The Select tool remains active.

To quickly select all objects on the active edit layer:

Choose Edit -> Select All.
or

Press CTRL+A.
You can perform the following procedures on selected objects:
Binding and unbinding objects 
Moving and resizing objects
Rotating objects
Modifying object text
Changing object attributes
Attaching hotspots

See also
Deselecting objects 



Deselecting objects

You may have more objects selected than you need, since the Edit commands affect all selected 
objects. Deselect any that you do not want to modify.
To deselect one or several selected objects:
1. Unless Select is already active, do one of the following:

Click 

 in the Drawing Toolbar.
or

Choose Edit -> Select.
or

Press CTRL+L.
Any already selected objects are outlined.
2. Press CTRL or SHIFT and click each selected object that you want to deselect. Stacked objects are 

deselected from the top down.

To deselect all selected objects:

Choose Edit -> Deselect All.
Unselected objects are not outlined. Select remains (or becomes) active.

See also
Selecting objects 



Binding and unbinding objects

If you are constantly selecting the same group of objects, save yourself some time by binding them 
together. Once bound, the entire group is selected automatically when you click any one object in the 
group with the Select tool.
To bind selected objects:

Choose Edit -> Bind.
After binding, the entire group of selected objects is double outlined with short and long dashed lines. 
The Status Bar indicates "1 group selected." The previously active tool remains active.
The group remains bound until you deliberately unbind it. Bound groups are saved as such when you 
save the layer.

To unbind a selected, bound group of objects:

Choose Edit -> Unbind.
Once unbound, the entire group remains selected, but each object in the group is outlined individually 
with short dashed lines. You cannot unbind individual symbols, dimensions, and hotspots. You can 
unbind vector pastes and text documents.

See also
Selecting objects 



Moving and resizing objects

Before you move or resize objects on the active edit layer, you must select them. How to select objects

To move the selected objects:
1. Unless Select tool is already active

Click 

 in the Drawing Toolbar.
or

Choose Edit -> Select.
or

Press CTRL+M.
2. Click objects that you want to move.

Control handles appear around the selected objects. They are outlined with long dashed lines.
3. Place the pointer on the center control handle.

The pointer changes to: .
 3. Press the left mouse button and drag the objects to the location you want.

All outlined objects move. If Snap to Grid is selected, the objects snap to the grid points as they move.
To resize the selected objects:
1. Activate the Select command.
2. On the active edit layer, drag the corner or side control handles to change the size.

All outlined objects are resized (except annotations and hotspot icons, which move but stay the same 
size).
If Snap Orthogonal is selected, aspect ratio is maintained when you resize with the corner handles.

See also
Activating layers
Setting grid options 
Moving layers 



Rotating objects

To rotate objects on the active edit layer, you must first select them. How to select objects. Note that 
annotations and hotspot icons move when rotated, but do not become angled differently. Pastes of color 
rasters fail on rotate.
To rotate the selected objects:
1. Unless Select tool is already active

Click 

 in the Drawing Toolbar.
or

Choose Edit -> Select.
or

Press CTRL+M.
2. Click objects that you want to move.

Corner handles appear around the selected objects, with a Center of Rotation icon:  in the center.
On the active edit layer:
2. Drag the Center of Rotation icon to the location to serve as center of rotation.
3. Drag the upper right hand control handle in the direction of the rotation.

The objects rotate.
If Snap Orthogonal is selected, objects rotate at 90-degree increments. 

See also
Activating layers
Setting grid options 
Rotating a document 



Deleting objects

You can remove objects from the active edit layer. You must select them first. How to select objects 
To delete selected objects:

Choose Edit -> Delete.
or

Press DELETE.
All the selected objects are deleted. The Select tool remains active. To restore deleted objects, choose 
Edit, Undo.

See also
Cutting, copying, and pasting objects 
Removing layers 



Cutting, copying, and pasting objects

You can cut or copy objects for pasting back onto an active edit layer (Full Edit, Edit, or Redline type). 
How to select objects

To copy the selected objects:

Click 

 in the Standard Toolbar.
or

Choose Edit -> Copy.
or

Press CTRL+C.
The selected objects are copied to the Clipboard. Copy is no longer active.

To cut selected objects:

Click 

 in the Standard Toolbar.
or

Choose Edit -> Cut.
or

Press CTRL+X.
The selected objects are deleted and copied to the Clipboard. Cut is no longer active.

To paste objects onto the active edit layer:

1. Click  in the Standard Toolbar.
or

Choose Edit -> Paste
or

Press CTRL+V.
2. On the active edit layer, drag the paste to the position you want. (To cancel, press ESC.)

The paste object appears as a bound object. Paste is no longer active.

To change the attributes of the paste object, use the Edit -> Modify Selected menu commands.

See also
Cutting and copying rasters 
Pasting rasters 
Deleting objects 
Edit menu commands 



Changing object attributes

You can change most of the defined attributes (line or frame width, color, style, and so on) of the 
selected objects. How to select objects 
To change the attributes of the selected objects:
1. Choose Edit    -> Modify Selected.

or

Press F5.
In the objects options dialog box:
2. Change the settings as appropriate.
4. Repeat steps 1 and 2 for any other selected objects to modify.

The objects are redrawn with the new attributes.
As the following table indicates, for certain categories displayed, some tool settings are unavailable.

Selected object Displayed categories Attributes that cannot be
changed

Erased (or cut) 
area or shaded 
area

Matches the shape of the area: 
Box for rectangular, Polygon for 
polygonal, and so on.

Shape

Arrow Arrow Arrowhead size and heads
Dimension Line, text, and arrow Dimension style, 

arrowhead size and heads
Inclined ellipse Polygon None
Symbol or 
hotspot

All categories relevant to the 
object or objects that make up the
symbol or hotspot

Shape, arrowhead size 
and heads (if applicable)

See also
Setting the drawing tool options 
Modifying object text 



Modifying object text

If the text in an annotation, hotspot, dimension, or text object is incorrect, you can change it. You cannot,
however, change the text of text documents.
To edit an annotation, text, hotspot, or dimension object:
1. Select the object. It must be the only object selected. How to select objects
2. Click the icon of the object whose text you want to edit.

or

From the Draw menu, choose the object whose text you want to edit.
The Annotation Text, Hotspot Data, Text, or Dimension Text dialog box appears, with the existing text 
selected.

3. Move the cursor over the object and click when the cursor changes to .
4. In the dialog box, change the text as appropriate. Press ENTER to start a new line of text. If Paste is 

available, you can click it (or press CTRL+V) to paste text from the Clipboard into the text box. Click 
OK.

The object reappears on the edit layer in the same place with new text.

Note that if you delete the text in an annotation or text object, the object itself is deleted. If you delete all 
the text in hotspots and dimensions, however, they remain on the layer.

See also
Changing object attributes
Deleting objects 



Creating a symbol

You can save any object or group of objects on the active edit layer as a symbol. That way you build up 
a library of objects that you place frequently.
To create a symbol:
1. Draw or place the objects to use on the active edit layer.
2. Activate the Select tool and, with the left mouse button, click the objects that are to form the symbol. 

How to select objects
3. Choose Edit -> Save As Symbol.

In the Save Symbol As dialog box:
4. Type the Label to use.
5. Type the drive, directory and File name for the symbol.

or

Click Browse and, from the Select File Name and Location dialog box, select the Drive and 
Directory for the symbol, and type its File Name. Click OK.

Save the symbol in the default symbol directory to have it appear in the Symbol palette.
6. In the Save Symbol As dialog box, click OK.

The symbol is saved in the selected location.

See also
Save Symbol As dialog box 
Select File Name and Location dialog box 
Selecting and placing a symbol



Attaching hotspots

You can attach hotspots to any selected objects, other than annotations.
To attach hotspots to selected objects:
1. Choose Edit -> Attach Hotspot.

A dialog box appears if "Hotspot Data Prompt=1" in the [Tool] section of the EROICA.INI file.
2. In the Hotspot Data dialog box, type the required data. It must be a text string that the receiving 

program can handle. Click OK.
As long as the Show Hotspots check box is selected in the View Options dialog box, the group of objects
resemble bound objects. (Otherwise, the objects seem to disappear, leaving only double dashed lines.) 
The Status Bar, if displayed, states "1 symbol selected." You cannot unbind hotspot objects.

See also
"Hotspot Data Prompt" keyname ([Tool] section) 
View Options dialog box 
Placing a hotspot
Activating hotspots 



Setting save defaults

When saving and exporting documents, default directory paths, file formats, and extensions are 
suggested. You can change many of these default values.

To define the default output formats and extensions for several document types:
1. Choose Options -> System.
2. Scroll down or up the category box as required and click the File Formats category.

In the File Formats Options dialog box:
3. Select the Documents Output File Format and extension to use by default.
4. Select the Vector Output File Format and extension to use by default.

This format is used by default for new edit layers, for vector documents of a format that Eroiica does not 
write, and for edit layers contained in a CLF or DAS document whose attributes are undefined.
5. Select the Raster Files format and extension to use by default.

This format is used for new bilevel raster documents and for bilevel raster layers contained in a CLF or 
DAS document whose attributes are undefined. Existing raster documents are by default saved under 
their current format.
6. Select the Color Raster format and extension to use by default.

This format is used for new color and grayscale rasters and for color and grayscale rasters contained in 
a CLF or DAS document whose attributes are undefined. Existing rasters are by default saved under 
their current format.
7. To save your selections for future sessions, click Save as default. Click OK.

The selected extensions and formats are used by default when saving documents of each type.

See also
System Options dialog box 



Saving a single layer

This procedure applies when the active document window contains only one edit or raster layer, and 
"Allow Single-Layer Page Files=0" in the [System] section of the EROICA.INI file.

To save any changes to the single edit layer in the active window:

Click 

 in the Standard Toolbar.
or

Choose File -> Save.
or

Press CTRL+S.
The layer is saved in the same location with the same name and label it had before.

To save a new layer or to change the attributes (name, format, header values, and so on) of the single-
layer document as you save it, follow this procedure.

To save a single layer document with the specified attributes:
1. Choose View -> Contents.

In the Eroiica Contents window:
2. Choose a layer to save.
3. Choose Object -> Save As.

In the Export Layer dialog box:
4. If saving an edit layer, type the Label to use.

For raster layers, the label always corresponds to the file name.
5. Select the file Format to use (unless you are selecting it with Browse).
6. Type the drive, directory and file name in the File name text box.

or

Click Browse to select these from the Select File Name and Location dialog box:
a) Select the Drive and Directory.
b) Select the file format to use from the Save File as Type list.
c) Type the File Name to use. Click OK.

7. If saving a raster layer, click Advanced to specify a header rotation and comment. In the Advanced 
Raster Information dialog box:
a) With some raster file formats, you can select a header Rotation value of 0°, 90° CW (clockwise), 

90° CCW (counter-clockwise), or 180°.
b) With CALS and TIFF documents, you can type a Comment to be placed in the header. Click OK.

8. In the Save Layer As dialog box, click OK.
9. If a file with the selected name already exists in that location, you are asked if you want to overwrite 

it. Click Yes to overwrite or No and repeat the entire save procedure, this time selecting a different 
name or location.

The layer is saved. The changes are displayed in all windows displaying a view of this document.

See also
"Allow Single-Layer Page Files" ([System] section) 
Export Layer dialog box 
Select File Name and Location dialog box 





Saving a page

This procedure applies when the document window contains a single page composed of two or more 
layers, or a single layer, if "Allow Single-Layer Page Files=1" in the [System] section of the EROICA.INI 
file.

To save changes to the current page:

Click 

 in the Standard Toolbar.
or

Choose File -> Save.
or

Press CTRL+S.
The page is saved in the same location with the same name, label, and file format it had before.

To save a page with new layers or to change the attributes (name, format, header values, and so on) of 
the page as you save it, follow this procedure.
To save the active page document with the specified attributes:
1. Choose View -> Contents.

In the Eroiica Contents window:
2. Choose a page to save.
3. Choose Object -> Save As.

In the Select File Name and Location dialog box:
4. Select the file Format to use.

CLF documents require less disk space than SMFs do, but all of their component layers must be 
located in the same directory path.

5. Type the drive, directory, and file name in the Filename text box.
6. Click OK.
7. If a file with the selected name already exists in that location, you are asked if you want to overwrite 

it. Click Yes to overwrite or No and repeat the entire save procedure, this time selecting a different 
name or location.

The page is saved. The changes, other than the removal of layers, are displayed in all windows 
displaying a view of the active document.

See also
Select File Name and Location dialog box 
Edit Layer Information dialog box 
Changing layer attributes



Saving a multipage

This procedure applies when the active document window contains two or more pages.

To save changes to the active multipage document:

Click 

 in the Standard Toolbar.
or

Choose File -> Save.
or

Press CTRL+S.
The multipage document is saved in the same location with the same name, label, and file format it had 
before.

If the multipage is untitled, if it contains new pages or layers, or to change its attributes (name, format, 
header values, and so on) as you save it, follow this procedure.
To save the active multipage document with the specified attributes:
1. Choose View -> Contents.

In the Eroiica Contents window:
2. Choose a multipage document to save.
3. Choose Object -> Save As.

In the Select File Name and Location dialog box:
4. Select the file Format to use.

DAS files require less disk space than the other formats do, but all of its component pages must be 
located in the same directory path.

5. Type the drive, directory, and file name in the File name text box.
6. Click OK.
8. If a file with the selected name already exists in that location, you are asked if you want to overwrite 

it. Click Yes to overwrite or No and repeat the entire save procedure, this time selecting a different 
name or location.

The multipage is saved. The changes are displayed in all windows displaying a view of this document.

See also
Select File Name and Location dialog box 
Raster Layer Information dialog box



Changing layer attributes

Changing layer attributes allows you to select a layer on a document and change its label and other 
attributes. The change is stored when you save the document.
To change the attributes of a layer, page, or document:
1. Choose View -> Contents.

If the Eroiica Contents window:
2. Click the name of the layer, page, or document to alter.
3. Choose Object -> Properties.

In the Edit or Raster Layer Information dialog box:
4. For edit layers, type the Label to use. (For raster layers, the label always corresponds to the file 

name.)
5. In the Edit or Raster Layer Information dialog box, click OK.

The new attributes are used by default when saving. Any change in labels appear in the title bar.

See also
Edit Layer Information dialog box 
Select File Name and Location dialog box 
Saving a page



Selecting the shape of cut and copy areas

Cut/copy areas can be the shape of boxes, circles, ellipses, or polygons. The Draw Options dialog box, 
Cut/Copy category, defines the default shape.

To change the shape of the area to cut or copy on the current page:
1. Choose Options -> Draw.
2. Scroll down or up the category box as required and click the Cut/Copy category.
3. Select the Shape to use for the area: Box, Polygon, Circle, or Ellipse. Click OK.

The selected shape applies to the active edit layer for the current session. 
To change the shape for subsequent edit layers, click Save as default. Click OK.

See also
Cut/Copy category: Draw Options dialog box 
Copying rasters 
Cutting rasters 



Copying rasters

You activate the Edit, Copy command and then select part of the active raster document to copy.

To copy an area of the document:

1. If you plan to paste the copy back into Eroiica, make sure an active ( ) raster layer appears on the
document.

2. Click  in the Standard Toolbar.
or

Choose Edit -> Copy
or

Press CTRL+C.
The pointer becomes a scissors shape: 
3. On the document, for rectangular copies, drag from one corner to the diagonal corner. For circular 

and elliptical copies, drag from the center to the radius. For polygonal copies, click each corner of 
the copy area, then double-click.

The area is copied to the Clipboard. The Copy command is no longer active.

See also
Selecting the shape of cut and copy areas 
Pasting rasters 
Activating layers 



Cutting rasters

You activate the Edit, Cut command and then select part of the document to cut.

To cut an area of the document:
1. Make sure an active edit layer of the Full Edit- or Edit-type appears on the page. If you plan to paste 

the area back into Eroiica, make sure an active ( ) raster layer appears on the page as well.

2. Click  in the Standard Toolbar.
or

Choose Edit -> Cut
or

Press CTRL+X.
The pointer becomes a scissors shape: 
3. On the page, for rectangular cuts, drag from one corner to the diagonal corner. For circular and 

elliptical cuts, drag from the center to the radius. For polygonal cuts, click each corner of the copy 
area, then double-click.

This portion of the page is saved into the Clipboard, and the cut area is filled with the background color, 
as an erased area would be. The Cut command is no longer active.

See also
Selecting the shape of cut and copy areas 
Pasting rasters
Activating layers 



Selecting paste attributes

The Paste category in Draw Options defines the default paste attributes. To change them for the active 
edit layer, use the Draw Options dialog box, Paste category.
To define the appearance of subsequent pastes placed on the active edit layer:
1. Choose Options -> Draw.
2. Scroll down or up the category box as required and click the Paste category.
3. Select the foreground paste Color from the list (bilevel pastes only).
4. Select a Translucent or Opaque paste background. If you select Translucent, the layers underlying 

the paste show.
If you select Opaque, the paste hides the underlying layers. Click OK.

This defines the appearance of the paste for the active edit layer only.

See also
Pasting rasters 
Paste category: Draw Options dialog box 
Selecting the shape of cut and copy areas 



Pasting rasters

You paste the section of the active raster document that you last cut or copied onto the active Full Edit or
Edit-type edit layer.

To paste the copy from the Clipboard:
1. Make sure the Edit-type or Full Edit-type edit layer to which you want to paste is active.

2. Click  in the Standard Toolbar.
or

Choose Edit -> Paste.
or

Press CTRL+V.
3. On the active edit layer, drag the paste to the position you want.

The paste is the same shape as the last cut or copy performed. The Paste command is no longer active.

See also
Cutting rasters 
Copying rasters 
Selecting paste attributes 
Activating layers 



Copying a document

You can copy the active document (all pages) to the Clipboard, and then paste the copy into another 
program running under Windows as an OLE embedded object.
To copy the active document:

Choose Edit -> Copy Document.
A message appears, indicating that the document is being converted to the SMF format. Once 
converted, the document is ready to be pasted into another program running under Windows that 
supports OLE embedded objects.

When you paste the document, only the current page shows. When activated in the other application, 
you return to Eroiica, which displays the complete document. The Update, Save Copy As, and Exit and 
Return to "Program" commands are added to the File menu.

See also
Copying rasters 



Activating layers

The active edit layer is the one that can be edited and marked up. The active raster layer is affected by 
most of the Tools and some other commands. Each page in each document window contains, at most, 
one active edit layer and one active raster layer.
By default, a single layer is active when first created or first imported. Single raster layers are also active
when first opened. Edit layers, by contrast, are inactive on open.

To activate or deactivate an edit or raster layer:
1. If the Eroiica Contents window is hidden, choose View -> Contents.
2. In the Eroiica Contents window, double-click the name of the layer to activate or deactivate.
The layer or document icons in the Eroiica Contents window change according to their active/inactive 
status. If they were hidden, active layers are displayed. If no active layer of one type appears on the 
document, the commands that apply to that type of active layer appear dimmed.    The document 
properties are displayed in the Eroiica status and summary windows that appear at the bottom of the 
Eroiica Contents window.

See also
Using the drawing tools
Tools menu commands 



Branching and Collapsing layers

Some vector documents consist of one edit layer made up of two or more subordinate layers. You can 
view and manipulate the subordinate layers.
To expand an edit layer:
1. If the Eroiica Contents window is hidden, choose View -> Contents.
2. In the Eroiica Contents window, click the name of the edit layer to branch. Note that the document or 

page icon has a plus sign (+) in it.    Document icon without the sign (+) in it cannot be branched.
The Eroiica Contents window lists the names of the subordinate layers. The names are slightly 
outdented. The "base" edit layer icon now has a minus sign (-) in it.

You can display or hide and change the foreground color of the subordinate layers. To do that using the 
Eroiica Contents window, expand the base layer first.

See also
Displaying and hiding layers
Changing layer colors
Showing and hiding bars and floating windows 



Comparing layers

When the current page contains two or more displayed layers that are relatively similar, you can find out 
what is the same and what is different about them with the Tools -> Compare command.
To compare layers:
1. Deactivate the active edit layer on the page, if any.
2. To do a layer comparison that ignores differences in color, activate the View -> Color -> Monochrome

command. This makes all layers monochrome.
3. If the Eroiica Contents window is hidden, choose View -> Contents. In the Eroiica Contents window, 

click to display layers to be compared (all displayed layers are compared).
4. Choose Tools -> Compare layers.
5. In the Layer Compare dialog box, select one of the following:

Intersect, which displays only the parts of the document that are the same on each displayed 
layer

Difference, which displays only the differences between all displayed layers

Combine, which integrates the displayed raster and edit layers

Default, which returns the document to normal layer display.
The document display changes as you select each option.
6. When you are satisfied with the current document display, click OK.

The document is displayed according to the Compare option you selected.

See also
Layer Compare dialog box 
Displaying and hiding layers
Activating layers 
View Options dialog box 



Moving layers

You can move any layer on the current document to make the layers line up better. The Move command 
is only available when the document contains two or more layers.
To move a layer on the current page:
1. If the Eroiica Contents window is hidden, choose View -> Contents.
2. In the Eroiica Contents window, activate by double click the name of the layer to move.
3. Choose Tools -> Move layer.
4. From the submenu that appears, choose Move.
5. On the layer, click part of the document to move.
6. Move the pointer to the new location, and click.

A line is drawn between the first and second clicks.
The layer moves to the selected location.

See also
Moving and resizing objects



Adding and removing layers

You can add layers to and remove layers from the current document or page. You can:

Place a new active edit layer on top of the document for redlining, editing, and marking up.

Bring an existing layer or layers onto the document.

Remove one or more layers from the document.
The following procedures give more details.
Creating an edit layer
Importing layers
Removing layers



Importing layers

Use the Object -> Import command in the Eroiica Contents window to bring existing raster or edit layers 
onto the current document.
To import layers:
1. If Eroiica Contents window is not displayed, choose View -> Contents.

In the Eroiica Contents window:
2. Click the name of a page or document to choose the location for the new layer.
3. Choose Object -> Import.

In the Layer Import dialog box:
4. Scroll up or down the list of files to find the names or labels of the layers to import.
5. If you cannot find the names or labels you want, you can:

Change the Drive and Directory.

Select another document type from List Files of Type. All Files is one option, but you cannot 
import single pages, multipage documents or sets).

Add to or change the extensions listed in the File name text box and press ENTER to display a 
different list of files.

6. Click the names or labels of the layers to import. Click OK.
The imported layers appear on the current document and in any other windows displaying views of that 
document. One imported edit layer and one imported raster layer become active. Edit layers imported 
onto a document containing an active raster take on the raster's resolution.

Any changes you make and save to an imported edit layer contained in another CLF document affects 
that document too. To avoid the problem, rename the edit layer, or save the document under the SMF 
format.

See also
Layer Import dialog box 
Changing layer attributes
Importing pages 
Saving a page 



Removing layers

You can remove layers from the current document with the Object -> Delete command in the Eroiica 
Contents window.
To remove layers:
1. If Eroiica Contents window is not displayed, choose View -> Contents.

In the Eroiica Contents window:
2. Click the name of a layer to be removed and choose Object -> Delete.

The selected layer is removed from the page or document. The layers remain in storage. To restore 
removed layers to the page or document, use the Object -> Import command.

See also
Removing pages 
Deleting objects 
Importing layers



Reordering layers

You can reorder the inactive edit layers and the raster layers on the current document or page. They 
initially appear with the raster layers at the bottom, the inactive edit layers next, and the active edit layer 
on top.
To reorder layers:
1. If Eroiica Contents window is not displayed, choose View -> Contents.

In the Eroiica Contents window:
2. Click the name of the Layer to move.
3. Choose Object -> Move up of Move down . Repeat as required.
4. Repeat steps 2 and 3 until the list is in the appropriate order. Click OK.
5. Press F7 to redraw all windows displaying the active document.

The layers appear in their new order. Note that erases hide all underlying layers but none above.

Note that the active edit layer is always on top.

See also
Activating layers
Reordering pages 
Refreshing windows 



Merging layers

Merging means combining layers to form raster documents. The merged document is usually faster to 
print, load, and view, especially if the originating document is a complex vector. Merging also corrects 
any corrupted data in the originating raster document.
To merge all or selected layers on the current document:
1. Choose Tools -> Merge.

In the Merge dialog box:
2. Select which layers on which pages to Merge.
3. Select the Use Active Raster Resolution check box (available only when an active raster layer is on 

the current page) or clear it and type a Resolution value between 100 and 1200 (dots per inch).
4. If some of the layers to merge are in color, select one of the following options:

To produce a color or grayscale raster, select the Merge to Color / Grayscale Output check box.

To produce a document in which gray or color sections are simulated by pixel patterns, select the 
Dither Bilevel Output check box. Set the Dark / Light slider to the appropriate brightness level.

5. To place a banner on each page of the merged document, select the Banner check box. Click the 
Banner button. In the Banner Information dialog box, select the Text Size and Font. Type the banner 
text in the appropriate locations, using the Banner Variables as appropriate. Click OK.

6. In the Merge dialog box, click OK.
A message box shows the progress of the merge operation, and allows you to cancel. When complete, 
the new document appears in the active document window.

Note: A Merge option is available in the Print dialog box. It allows you to rasterize a vector or text 
document before printing it.

See also
Merge dialog box 
Banner Information dialog box 
Activating layers
Displaying and hiding layers



Despeckling a document

Scanned document can contain "noise"--unwanted points or dots. The despeckling function removes 
dots up to a specified size from the document on the active raster layer. Note that this function works 
only on bilevel raster documents.
To despeckle the active raster document:
1. Choose Tools -> Despeckle.
2. In the Despeckle dialog box, type the maximum Size of Speckle to remove (in pixels). Type any 

integer from 1 to 30. Click OK.
A message box shows Eroiica's progress in removing clusters of pixels of the size specified, and allows 
you to cancel. When complete, the new despeckled document appears in the active document window. 
Save it if you want.

See also
Activating layers
Saving a single layer
"Overwrite Raster" keyname ([System] section)



Deskewing a document

Sometimes documents are scanned crookedly, which results in skewed images. To correct this, specify 
an angle of rotation for the document (bilevel raster documents only). You can:

Get Eroiica to suggest a deskew value.

Draw a triangle on the document showing the deskew angle.

Type in a numerical angle value.
The following procedures provide details.
Using a suggested deskew value 
Drawing the deskew region 
Typing the deskew value 



Using a suggested deskew value

Instead of drawing or guessing at the deskew value, you can get Eroiica to suggest a value for you.
To have Eroiica suggest a deskew value for you:
1. Choose Tools -> Deskew.
2. In the Deskew dialog box, click Suggest.

A Processing message box appears. When complete, a new value appears in the Current Skew Angle 
text box or the value remains at 0.00, which means that either the document is straight, or the skew 
value is incalculable.
3. In the Deskew dialog box, click OK to accept the suggested value (if any), or click Cancel to close 

the dialog box. (Eroiica rejects skew values of 0.00.)
If a deskew value was calculated, a message box shows the progress of the deskewing operation, and 
allows you to cancel. The new deskewed document appears in the active document window. It is larger 
than the original was. Save it if you want.

See also
Deskew dialog box 
Resizing a raster
Cropping a raster
Saving a single layer



Drawing the deskew region

If the document lends itself to it, you can trace along a skewed line on the document, and Eroiica uses 
that to correct the skew.
To deskew the active raster document by drawing the skew angle:
1. Choose Tools -> Deskew.
2. In the Deskew dialog box, click Set Angle.

The pointer changes to: . On the current document:
3. Select a skewed line on the document to use as a guide. Click one end of this line, and move the 

pointer toward the other end. (To cancel, press ESC.)
As you move the pointer, it draws a red triangle with a 90º angle. Its horizontal side represents the 
correcting line.
4. Click the end point of the skewed line.

If the deskew angle drawn is within the allowed range, the Deskew dialog box reappears, this time 
displaying the value of the skew angle. Otherwise you are given an opportunity to redraw the triangle.
5. In the Deskew dialog box, click OK or click Set Angle and repeat steps 4 and 5.

A message box shows the progress of the deskewing operation, and allows you to cancel. The new 
deskewed document appears in the active document window. It is larger than the original was. Save it if 
you want.

See also
Deskew dialog box 
Resizing a raster
Cropping a raster
Saving a single layer



Typing the deskew value

You can type the deskew value to use.
To deskew the active raster document by typing the skew angle:
1. Choose Tools -> Deskew.
2. In the Deskew dialog box, type the angle by which to deskew the document (within the Skew Range 

Available) in the Current Skew Angle box. Click OK.
When you click OK, a message box shows the progress of the deskewing operation, and allows you to 
cancel. The new deskewed document appears in the active document window. It is larger than the 
original was. Save it if you want.

See also
Deskew dialog box 
Resizing a raster
Cropping a raster
Saving a single layer



Cropping a raster document

Cropping means selecting part of the active raster document and creating a new document from it. You 
can crop color, grayscale, and bilevel raster documents.
Four crop methods are available: Set Region, Shift, Auto, and Size.
1. Set Region: You draw the crop region on the document. Use Set Region to create a new document 

out of a small section of another document, or to remove a blotch on the outside of the document 
that is too large for the despeckling function.

2. Shift: Crops a region of the same size as the active raster document. Use Shift to depict a different 
section of the document at the same size.

3. Auto: Initiates an automatic crop. Use it to remove white space around the document, creating a 
smaller-size document with no loss of significant data. Only works with bilevel rasters.

4. Size: The various Size options crop a region to a specified size, which is useful if you want 
documents to be an exact size. You define what crop sizes are available.

For more information on each of these crop options, see the following topics.
1. Drawing the crop region
2. Cropping a region the same size as the active raster document
3. Cropping automatically 
4. Cropping a region to a specific size



Drawing the crop region

You can draw the crop area on the active raster document.
To crop the active raster document by drawing the crop region:
1. Choose Tools -> Crop -> Set Region.

The pointer changes to: .
2. Drag a box from one corner of the crop region to its diagonal corner.

A block appears over the area that you defined.
3. In the Verify Crop Region dialog box, click OK to continue or click Reset to select a different region.

A message box shows the progress of the cropping operation, and allows you to cancel. The new 
cropped document appears in the active document window. Save it if you want.

See also
Activating layers
Saving a single layer
"Overwrite Raster" keyname ([System] section)



Cropping a region the same size as the active raster document

You can select a shifted region the same size as the active raster document and create a document from
that.
To create a document the same size as the original:
1. Choose Tools -> Crop -> Shift.
2. On the current document, move the crossed box to the crop location you want, and click. (To cancel, 

press ESC.)
3. In the Verify Crop Region dialog box, click OK to continue or click Reset to select a different crop 

region.
A message box indicates the progress of the crop operation, and allows you to cancel. The new 
document appears in the active document window. Save it if you want.

See also
Activating layers
Saving a single layer
"Overwrite Raster" keyname ([System] section)



Cropping automatically

If you remove white space around the active, bilevel raster document, you end up with a smaller-size 
document with no loss of significant data. Use the automatic crop function to do this.
To automatically crop the active raster document:

Choose Tools -> Crop -> Auto.
A message box shows the progress of the cropping operation, and allows you to cancel. The new 
cropped document appears in the active document window. Save it if you want.

See also
Activating layers 
Saving a single layer
"Overwrite Raster" keyname ([System] section)



Cropping a region to a specific size

You can crop regions of the active raster document to specific sizes. The sizes available are 
configurable.
To define crop sizes:
1. Choose Options -> System.
2. Scroll down or up the category box as required and click the Crop Formats category.
2. In the Crop Formats dialog box, do one of the following:

Add a crop size by clicking Clear. Type the Custom Label for the size, and type or select its Width
and Length in the selected units.

Change an existing crop size by clicking its name in the List of Sizes box, then making changes 
to the Custom Label, Width, and Length values.

Delete a size by selecting its name and clicking Delete.

Reload the previously saved crop sizes by clicking Load defaults.

Restore the shipped default sizes by clicking Restore Standards.
3. Click Save as default. Click OK.
4. Repeat from step 1 as required.

Any new sizes are added as Tools -> Crop options. Deleted sizes are removed. Any changes to the 
existing sizes apply when you select them.

To crop the active raster document to a specific size:
1. If required, rotate the document to permit better cropping.
2. Choose Tools -> Crop.
3. Choose the size to use (for example, A1, A - Size, or Legal).
4. On the current document, move the crossed box to the crop position you want, and click. (To cancel, 

press ESC.)
5. In the Verify Crop Region dialog box, click OK to continue or click Reset and select a different crop 

region (repeat step 3).
A message box indicates the progress of the crop operation, and allows you to cancel. The new cropped
document appears in the active document window. Save it if you want.

See also
Crop Options dialog box 
Activating layers
Saving a single layer
"Overwrite Raster" keyname ([System] section)



Changing raster document characteristics

The Tools -> Raster command allows you to redefine the attributes of the active raster document to 
create a new raster document. It applies to bilevel, color, and grayscale raster documents.
To create a new document by modifying the active raster document:
1. Choose Tools -> Raster.

In the Raster Operations dialog box:
2. Select the required operations. You can:

Rotate the document by 90 CCW (counter-clockwise), 90 CW (clockwise), or 180 degrees. Note 
that after a raster operation, the header rotation is always reset to 0.

Select the Mirror or Negative check box to correct originally negative or mirrored documents.

Change the document Resolution. The higher the number, the sharper the document(although 
increasing the original value adds no detail to the document), but the greater the file size. To specify 
different X (horizontal) and Y (vertical) resolution values, clear the Same X & Y check box first. Doing so 
may distort the document.

3. Click OK.
A message box shows the progress of the raster operation, and allows you to cancel. The new 
document appears in the active document window. Save it if you want.

See also
Activating layers
Raster Operations dialog box 
Saving a single layer
"Overwrite Raster" keyname ([System] section)



Resizing a raster document

You can change the size of any raster document, whether color, grayscale, or bilevel. Smaller 
documents take less disk space, and are faster to load, but they lose some detail.
To resize the active raster document:
1. Choose Tools -> Resize.

In the Resize dialog box:
2. Select the units to use from any of the unit lists.
3. Decide if you want to Preserve Aspect. Unless you select this check box, the new document may be 

stretched in one direction.
4. If you have selected the Preserve Aspect check box, type in a New X (width) or a New Y (height) 

value, in inches. The other value automatically changes as well, so that aspect ratio is preserved.
If the Preserve Aspect check box is clear, you can type in both a New X and a New Y value. Click 
OK.

A message box shows the progress of the resizing operation, and allows you to cancel. When complete,
the new raster document appears in the active document window. Save it if you want.

Note that after a resize operation, the header rotation is always reset to 0.

See also
Activating layers
Resize dialog box 
Saving a single layer
"Overwrite Raster" keyname ([System] section)



Improving raster document display

Some raster documents are hard to read. They can look dark, dense, and dirty. Document display 
problems normally originate in the files themselves, but are improved by certain Eroiica functions.

If the bilevel document looks inverted (has a dark background) when magnified but very black 
when reduced, it is probably a negative document.

If the bilevel document looks fuzzy when reduced, try using the Scale to Gray command to clarify 
it.

If the bilevel document is dense when reduced, but does not have a black background, try the 
Sample command to clarify it.

For more information, see the following topics.
Displaying a negative document
Sampling a dense raster document
Scaling to gray

Also note that deactivating the speed optimizations can improve the quality of the document display.

See also
Optimizing vector document display 
Configuring text document display 
Optimizing raster document speed 



Displaying a negative document

Negative documents looked inverted when magnified, but very black when reduced. The negative of a 
bilevel raster document is as that of a negative photograph: the black pixels predominating.
Using the Invert command will not solve the problem. You can use the Negative command instead.
You can select Negative as a default using the View Options dialog box, and it is specified in the header 
of certain raster documents.

To select or deselect negative for the active raster document:

Choose View -> Special -> Negative.
or

1. Choose Options -> View.
In the View Options dialog box:
2. Click the Negative check box in the Rasters section.
3. Click OK (current document) or Apply to    All Pages.

The negative document is displayed as positive, or vice versa.

See also
View Options dialog box (Rasters) 
Inverting document colors
Sampling a dense raster document



Scaling to gray

Some bilevel raster documents look fuzzy due to scanning problems. Try the Scale to Gray command to 
make the document more legible. The option has no effect on monochrome monitors.
Gray scaling is applied by default when the Scale to Gray check box is selected in the View Options 
dialog box.

To select or deselect scale to gray for the active raster document:

Choose View -> Colors -> Gray scale.
or

1. Choose Options -> View.
In the View Options dialog box:
2. Click the Scale to Gray check box in the Rasters section.
3. Click OK (current document) or Apply to All Pages.

The black-and-white pixels are displayed as shades of gray. Note that at scale factors of 1.00 or more, 
scale to gray has no effect.

See also
View Options dialog box (Rasters)
Sampling a dense raster document 



Sampling a dense raster document

Some bilevel raster documents contain far more black pixels than white pixels, making them difficult to 
view. Try displaying only a sample of their pixels.

Sampling applies by default when selected in the View Options dialog box, and when Fast Load is 
selected in Optimizations Options.
To select or deselect sampling for the active raster document:

Choose View -> Special -> Sample.
or

1. Choose Options -> View.
In the View Options dialog box:
2. Click the Sample check box in the Rasters section.
3. Click OK (current document) or Apply to All Pages.

When Sample is selected, the document is displayed with fewer pixels. Note that at scale factors of 1.00
or more, sampling has no effect.

See also
View Options dialog box (Rasters) 
System Options dialog box 
Displaying the document at 1:1 or another scale factor
Scaling to gray



Optimizing raster document speed

You can improve raster load and display speed, but that sometimes affects document quality and 
increases memory requirements.
To optimize raster speed:
1. Choose Options -> System.
2. Scroll up or down the category box and select the Optimizations category.

In the Optimizations Options dialog box:
3. In the Performance section, select the Fast Load, Fast Scroll, Fast Display, and Use Previews check 

boxes. Make sure that the Minimize Resources check box is clear.
4. To save the default for future sessions, click Save as default. Click OK.

Raster documents will load, zoom, and scroll more quickly. If you encounter certain problems, however, 
you may want to deactivate certain speed optimizations.

If your documents look too pale, deactivate the View -> Special -> Sample command (it gets 
activated when Fast Load is selected).

If you get document distortions on scroll, clear the Fast Scroll check box.

If your computer has 8 MB of RAM or less, clear the Use Previews check box and select the 
Minimize Resources check box.

Note that the Scale to Gray option slows down document display.

See also
System Options dialog box 
Optimizing memory 
"Fast Load Size Thr" keyname ([System] section) 
Optimizing vector document performance 



Optimizing memory

Certain Eroiica options reduce the incidence of "out of memory" errors. Use them if your computer has 8 
MB of RAM or less.
1. Choose Options -> System.
2. Scroll up or down the category box and select the Optimizations category.

In the Optimizations Options dialog box:
3. Select the Minimize Resources check box.

When Minimize Resources is selected, Eroiica saves memory by using more efficient compression 
algorithms. As a result, display and scroll slow down.
4. In the Performance section, make sure the Use Previews check box is clear. You can, however, 

select the Fast Load, Fast Scroll, and Fast Display check boxes to improve speed. These options do 
not use much extra memory.

5. To save the default for future sessions, click Save as default. Click OK.
You will notice a reduction in "out of memory" errors.

See also
System Options dialog box 
"Low Memory" keynames ([System] section) 
Optimizing raster document speed 



Optimizing vector document speed

The display of complex vector documents is sometimes slow. Two functions improve the load, zoom, 
redraw, and scroll speed for vector documents. They affect document quality, however.
To improve the display speed of vector documents:
1. Choose Options -> View.

In the View Options dialog box:
2. Select the Use Hairlines and Use Wireframes check boxes in the Vectors section.
3. Click OK or Save as default.

All vector lines on the document appear as being 1 pixel thick at all scale factors, and all filled vector 
objects appear as being transparent.
To further increase the speed of vector documents--at least those that contain text--increase the value of
the "Text Greeking Threshold" in the [System] section of the EROICA.INI file. It defines the text height in 
screen pixels at which text is Greeked, or displayed as blocks. Greeked text is faster to draw. The 
default value of the keyname is 2.
For HPGL documents, you achieve best performance by setting all pen line widths to 0.0. Do this in the 
Vector Pens Options dialog box (Options -> System, Vector Pens).

See also
View Options dialog box 
Spotting pastes and erases
Speeding multipage display 
Optimizing raster document speed 



Optimizing vector document display

Several commands exist for the express purpose of making vector documents looks better. Often 
display problems are particular to one vector document format.
The following topics give more information about optimizing vector display.
Configuring HPGL documents 
Displaying shape fonts in AutoCAD documents 
Remapping fonts in vector documents
In general, note that changes to color and fonts have little effect on speed, unlike changes to line widths 
and fill styles.



Configuring HPGL files

Many HPGL documents consist of eight pen lines. You can configure each separately.
To configure the pen lines in HPGL vector documents:
1. Choose Options -> System.
2. Scroll up or down the category box and select the Vector Pens category.

In the Vector Pens Options dialog box:
3. Select the units, type or select the width value, and select the color of Pen 1 through Pen 8. Click 

OK.
4. To save your selections for future sessions, click Save as default. Click OK.

Some HPGL documents may contain up to 256 pen lines. Often acceptable pen values are stored within
these files. If not, you configure them in the [HPGL] section of the EROICA.INI file. The pen keynames 
have the following format:
Pen X=width units color
where X = the pen number (an integer from 1 to 256)

width = the line thickness in normal units (not divided by 4096)
units = 1 for inches or 2 for centimeters
color = an RGB color value. Tip 

You may also have to define the HPGL plotter coordinates. See Loading HPGL documents for more 
information.

See also
 [HPGL] section 
Optimizing vector document performance 



Loading HPGL documents

The [HPGL] section of the EROICA.INI file defines how HPGL documents are scaled on load. First, 
make sure that "HPGL Input Scale=1," not 0. Then set the "PortX1," "PortX2," "PortY1," and "PortY2" 
values according to the table. Always set the "Resolution" keyname to 1016.

HP Plotter
Optional Switch 
Settings or Paper 
Size

PortX1, PortY1 PortX2, PortY2

7090A ANSI (A-size)
ANSI (B-size)
ISO (A4-size)
ISO (A3-size)

160, 447
865, 160
514, 348
325, 514

10 210, 7682
16 140, 10 210
10 564, 7583
15 600, 10 564

7440A or 
7470A

US (A-size)
A4 (A4-size)

250, 279
250, 279

10 250, 7479
10 250, 7479

7475B US/A4 (A-size)
US/A3 (B-size)
MET/A4 (A4-size)
MET/A3    (A3-size)

250, 596
522, 259
603, 521
170, 602

10 250, 7796
15 722, 10 259
10 603, 7721
15 370, 10 602

7510A Standard
Paper (A-size)
Paper (B-size)
Paper (A4-size)
Paper (A3-size)
Paper (8 X 10)

1634, 1090
80, 320
620, 80
430, 200
380, 430
80, 320

14 710, 9806
10 080, 7520
15 820, 10 080
10 430, 7400
15 580, 10 430
10 080, 7520

7550A A-size
B-size
A4-size
A3-size

80, 320
620, 80
430, 200
380, 430

10 080, 7520
15 820, 10 080
10 430, 7400
15 580, 10 430

7570A Normal (C-size)
Normal (D-size)
Normal (A2-size)
Normal (A1-size)

-9976, -6956
-15 592, -9976
-10 680, -6720
-15 140, -10 680

9976, 6956
15 592, 9976
10 680, 6720
15 140, 10 680

7580A,B Normal (A-size) 
(landscape)
Normal (B-size
Normal (C-size)
Normal (D-size)
Normal (A4-size) 
(landscape)
Normal (A3-size)
Normal (A2-size)
Normal (A1-size)

-2638, -4388

-6956, -4388
-9496, -7436
-15 592, -9976
-2520, -4740

-6720, -4740
-10 200, -7200
-15 140, -10 680

6956, 4388

2638, 4388
9496, 7436
15 592, 9976
2520, 4470

6720, 4740
10 200, 7200
15 140, 10 680

7585A,B or 
7586B

Normal (A-size) 
(landscape)
Normal (B-size)
Normal (C-size)
Normal (D-size)
Normal (E-size)
Normal (A4-size) 

-2638, -4388

-6956, -4388
-6956, -9976
-15 592, -9976
-20 672, -16 072
-2520, -4470

2638, 4388

6956, 4388
6956, 9976
15 592, 9976
20 672, 16 072
2520, 4470



(landscape)
Normal (A3-size)
Normal (A2-size) 
(landscape)
Normal (A1-size)
Normal (A0-size)

-6720, -10 680
-6720, -10 680

-15 140, -10 680
-22 100, -15 620

6720, 4740
6720, 10 680

15 140, 10 680
22 100, 15 620

7595A or 
7596A

Normal (A-size) 
(landscape)
Normal (B-size)
Normal (C-size)
Normal (D-size)
Normal (E-size)
Normal (A4-size) 
(landscape)
Normal (A3-size)
Normal (A2-size) 
(landscape)
Normal (A1-size)
Normal (A0-size)

-4348, -2598

-6916, -4348
-9936, -6916
-15 552, -9936
-20 632, -16 032
-4700, -2480

-6680, -4700
-10 640, -6680

-15 100, -10 640
-22 060, -15 580

4348, 2598

6916, 4348
9936, 6916
15 552, 9936
20 632, 16 032
4700, 2480

6680, 4700
10 640, 6680

15 100, 10 640
22 060, 15 580

LaserJet III Letter
Legal
A4

0, 0
0, 0
0, 0

10 837, 8297
13 885, 8297
11 538, 8060

Unless otherwise specified, paper orientation is portrait.
Changes to the EROICA.INI file only take effect after you restart Eroiica.



Displaying shape fonts in AutoCAD documents

Some DXF-format and DWG-format documents contain shape fonts.
To copy shape fonts for Eroiica access:
1. Choose Options -> System.
2. Scroll up or down the category box and select the Text Layout category.

In the Text Layout Options dialog box:
3. In the List of Fonts list box, click the name of a shape font that you intend to copy, and click Delete. 

Repeat as required.
4. Click Save as default. Click OK.
5. Quit Eroiica.
6. Copy the shape font files from their originating directory to Eroiica's FONTS directory.

or

Open the EROICA.INI file into a text editor and, in the [System] section, use the "Font Search 
Path" keyname to specify the full directory path to these fonts. You can specify more than one directory by
separating each with a semicolon.

7. Save the INI file.
Thereafter, any document you view in Eroiica that contains those shape fonts displays them correctly. 
You can also use those fonts with the Text, Annotation, and Dimension tools.
If you do not have permission to copy the AutoCAD shape fonts to the Eroiica FONTS directory (or you 
have no access to these fonts), remap the shape fonts to other available fonts.

See also
File Formats Options dialog box 
Font Remapping dialog box 
"Font Search Path" keyname ([System] section) 
Remapping fonts in vector documents



Remapping fonts in vector documents

The Font Mapping options section of the Text Layout Options dialog box defines default font mappings 
for both vector and text documents. Changes made in that section, however, also affect the active vector
document, if any.
To remap fonts in vector files:
1. Choose Options -> System.
2. Scroll up or down the category box and select the Text Layout category.

In the Text Layout Options dialog box:
3. In the List of Fonts list box, click the name of a font to remap.
4. Change the Map To, ScaleX, ScaleY, Bold, Italic, Underline, and Strikeout values as appropriate.
5. To save the font mappings for future sessions, click Save as default. Click OK.
6. Press F7 to redraw the window.
7. Repeat steps 1 to 6 as required.

Once the font display is acceptable, reopen the vector document to make sure the font positioning is 
accurate.

See also
Font Remapping dialog box 
Remapping fonts in text documents
"DGN Load Stroke Fonts" keyname ([File] section)



active document

The document displayed in the active document window, affected by the View and other commands. A 
document can appear in more than one window at once. As long as one of those windows is active, the 
document itself is active.



active document window
 
This window appears "on top" of all other document windows (unless tiled), and its title bar is highlighted. 
It contains one view of the active document, the one to which the chosen commands apply. To activate a 
window, click on its title bar.



Annotation layer

Annotation edit layers permit annotations, arrows, text, highlighted sketches, and shaded areas.



annotations

Annotations are notes on a document, signified by an icon: . They contain text and are never printed. 
You place annotations with the Annotation tool.



API

Application Programming Interface. The API allows programmers to integrate Eroiica with other programs 
or to customize the user interface.



Arrow line

Drawing a line 
Drawing an arrow 



aspect ratio

Aspect ratio is the relationship of width to height. When aspect ratio is maintained, the document is scaled
proportionally. When it is not, the document is "stretched" vertically or horizontally when scaled.



banner

A banner is a page stream that can be printed, faxed, or merged on each document.



bilevel raster document

Raster document in which data is stored as one data bit for one dot (or pixel) of raster data. The data is 
either on or off (black or white) with no intermediate status.



CGM

CGM stands for Computer Graphics Metafile. CGM is a vector document format that comes in three 
types: binary, character, and clear text. Eroiica reads all three.
Portions of the code related to CGM: copyright Henderson Software.



Circles and Ellipses

Drawing a circle 
Drawing an ellipse 
Using Highlight Area 
Using Erase Area 



CLF document

Component List File, a single page document composed of a list of layers. When you open a CLF 
document, the layers are gathered in order and are displayed in the document window, one on top of the 
other.



CMC

CMC = Continuous Motor Control. A type of e-mail program.



Color options

The following color options are available:
0 = Background (White)
1 = Blue
2 = Cyan
3 = Red
4 = Yellow
5 = Green
6 = Magenta
7 = Gray
8 = Dark Blue
9 = Dark Cyan
10 = Dark Red
11 = Dark Yellow
12 = Dark Green
13 = Dark Magenta
14 = Dark Gray
15 = Foreground (Black)



color raster document

Raster documents in which combinations of red-green-blue (RGB) forms the color pixels.



Color tip

Use the Options, Edit Colors command in the Windows 3.1 Paint program to see what number 
combinations produce what colors.



Comparing a document opened twice with two views of a document

Elements One document opened 
twice

Two views of one 
document

Appearance Normal title bar Title bar numbered
Editing Changes to one 

document do not affect 
the other

Changes to one view 
affect the other view 
on redraw

File, Close Closes one window 
containing the document

Closes both windows 
containing the 
document



Copyrights

Portions of the source code used in the interpretation of several formats.



Cutting and Copying

Selecting the shape of cut and copy areas 
Copying rasters 
Cutting rasters 



DAS-format multipage

DAS = Document Association Set. It is a collection of any combination of single or stacked layers and 
other multipage documents. It is made up of a list of document names starting with the first page followed 
by each consecutive page.



Detail window

A floating window that shows a close-up view of the pointer location at the selected scale factor (by 
default 1:1).



DGN

It is also called a "Design" file. It is a vector document format that Eroiica supports.



dither

"Dithering" means to simulate gray or color in a bilevel (black and white) document by using a particular 
pixel pattern.



document

Generally, any file that Eroiica supports.



document type

Classification of documents according to the data they contain. Eroiica reads raster, vector, and text 
document types, in certain formats. Raster documents are made up of dots, vector documents of 
mathematical equations, and text documents of text with formatting.
These basic document types are combined to create other document types: multi-layer page documents, 
multipage documents, and sets.



Drawing boxes

Drawing a box 
Using Highlight Area 
Using Erase Area 



Drawing polygons

Drawing a polygon 
Using Highlight Area 
Using Erase Area 



Drawing toolbar

A bar with buttons that perform some of the most common drawing tasks in Eroiica, such as opening, 
copying, printing, zooming, rotating, erasing, adding layers, opening windows and so on.
To display or hide the Drawing toolbar, choose Toolbars from the View menu, and then select Drawing.



DWG-format document

DWG = drawing. Vector document in the native AutoCAD® format. It usually has a DWG extension.



DXF-format document

DXF = Data Exchange Format. AutoCAD® vector file format that Eroiica reads and writes. It is defined by 
AutoDesk®.



edit layer

An edit layer can contain vector objects, raster pastes, and the text from text documents. It cannot contain
full raster images or documents.
Edit layers can be subdivided into five types: Edit, Full Edit, Redline, Annotation, and Hotspot. All types 
other than Full Edit have some restrictions.



Editing the EROICA.INI file

1. Start a Text editor (such as Notepad).
2. Open the EROICA.INI file.
3. Edit the file as required, keeping in mind that many keynames are case-sensitive.
4. Save the file.
5. Quit the Text editor.
6. To activate the changes in Eroiica, click the Load defaults button in the appropriate dialog box, or 

restart Eroiica.



Edit-type edit layer

You can place any object on Edit layers except annotations and hotspots. Edit-type edit layers can be 
also created by saving edit layers under the AutoCAD Data Exchange (DXF) or Windows MetaFile 
formats.



embedded pages

Several pages or a multipage document contained within another multipage document as one page.



enclosing multipage

Multipage document that contains another multipage document as a single page.



Eroiica Contents

A list of the documents that were selected (added or opened) during the current session. You can add and
remove documents from the list, import new documents and layers, attach new pages and layers to 
existing documents, save documents, copy documents to clipboard, and perform many other functions on
the documents listed in the Eroiica Contents window. 



exporting

Exporting means saving a document, multipage, page, or layer document without replacing the active 
document.



file

Files are all the data that describes one symbol, layer, text document, page document, multipage 
document, or set, maintained under a single naming code and stored in a computer. Files are referred to 
as documents in Eroiica.



floating window

A small window that can be placed anywhere on your desktop--that is, it "floats" above all other windows.



Freehand drawing

Freehand drawing 
Freehand highlighting 
Freehand erasing 



Full Edit-type edit layer

Full Edit-type edit layers have no restrictions. Text documents appear on Full Edit-type edit layers.



grayscale raster document

Raster document in which each dot (or pixel) is assigned a number ranging from 0 to black to some other 
number (often 255) for white. Each number in between represents an ever-lighter shade of gray.



header

Data attached to the beginning of an electronic document that describes or controls the actions that apply 
to the following data, such as rotation, mirroring, data type, and compression.



hotspot

Hotspots are objects that, when activated or placed, send a block of information to programs that have 
requested to be advised of hotspot activation or placement. The associated applications then act on the 
information received. You draw or place hotspots on Full Edit and Hotspot layers.



Hotspot layer

Hotspot edit layers are for line objects: hotspots, lines, arcs, arrows, sketches, and polylines.



HPGL

Hewlett-Packard Graphics Language, a vector document format that Eroiica supports.



image

Graphic (raster or vector) or text displayed on a single document, page or layer.



layer

Two-dimensional planes that can be overlaid on one another, so that all display at once. Combined on a 
single document, the planes can constitute a hybrid document--pictorial data made up of multiple data 
types. Raster layers contain raster data and edit layers contain vector objects, raster pastes, and text 
documents.



multipage document

Document made up of more than one page, alias multiple page document.



object

Objects are the base elements that constitute edit layers. They include arcs, circles, boxes, lines, 
dimensions, text, annotations, symbols, cuts, erases, and pastes. You create and manipulate objects on 
the active edit layer.



OLE

A communication protocol that allows you to link Windows programs. When you embed or link objects, 
your document contains information that was created in a different program and you can edit any of this 
from inside your document.



Orthogonal

Relating to, consisting of, or involving right angles. Perpendicular.



page

A page refers to one or more stacked layers within a document. Normally a single layer is referred to as a 
"page" only when it appears in a window with other pages. Otherwise, it is referred to as a document.



Pasting and configuring pastes

Selecting paste attributes 
Pasting rasters 



polylines

Polylines are vector objects in the shape of joined, straight lines. You draw them with the Polyline drawing
tool by defining all the line end points.



raster document

A raster document is a data type consisting of dots (also known as pixels) that are turned on or off in 
bilevel rasters, or are assigned a shade of gray or a color. The dots are stacked into lines known as scan 
lines, which are themselves stacked to form a two-dimensional array of dots



raster layer

A two-dimensional plane consisting of dots (also known as pixels) that are turned on or off, in bilevel 
raster layers, combinations of red-green-blue (RGB) forming color pixels in color raster layers, or are 
assigned a shade of gray in grayscale raster layers. Raster layers contain raster data.



Redline edit layer

With Redline edit layers you can place all objects except annotations, hotspots, raster pastes, shaded 
areas, erased (or cut) areas, and rubouts. You are also limited to the transparent fill style.



Reference window

A Reference window is a small window that contains a representation of the entire current document. The 
crossed box indicates what part of the document appears in the document window. The Reference 
window can be used to zoom into the document and to move around the document at the current scale 
factor.



RGB

Red-green-blue, the additive components of color in many raster pixels and vector objects. Used as 
standard color model in Windows screen device. Other models can represent the color too, for example 
CMY (subtractive, cyan, magenta, yellow) or HSB (hue, saturation, brightness).



RTF

Rich Text Format, a text document format that Eroiica supports.



scale factor

A scale factor is the ratio of screen pixels to document pixels. For example, a scale factor of 0.2 (1:5) 
indicates one screen pixel for five document pixels and a scale factor of 2 (2:1) indicates two screen 
pixels for one document pixel.



Selecting objects

To select objects on the active edit layer:

1. Unless Select is already active, click , or choose Select from the Edit menu, or press CTRL+L.
2. Click an object to select, or select a group of objects by dragging a box around them all, or press the 

CTRL key and click each object to select.

To quickly select all objects on the active edit layer:
Choose Select All from the Edit menu or press CTRL+A.

Selected objects are individually outlined with short dashed lines, and the whole group is outlined with 
long dashed lines.



set

A set is a grouping of any combination of other sets, multipage documents, single page documents, raster
images, vector documents, and text documents. When opened, each documents in the set appears in a 
different window.



Standard toolbar

A bar with buttons that perform some of the most common tasks in Eroiica, such as opening, copying, 
printing, zooming, rotating, erasing, adding layers, opening windows and so on.
To display or hide the Standard toolbar, choose Toolbars from the View menu, and then select Standard.



symbol

A symbol is a group of objects--created by selecting and saving vector objects. Symbols are assigned to 
the Symbol or Hotspot tool for placement on an active edit layer.



text document

A document that contains text and (sometimes) formatting information. It is often created with word 
processing programs.



Texts and Annotations

Placing text 
Placing an annotation 



vector document

Documents that are defined mathematically and displayed graphically. They are used in CAD and 
engineering applications for precise, mathematically editable designs. In Eroiica they are stored in edit 
layers.



VGA

Video Graphics Array. Video display standard.



workspace

The workspace is the area inside the Eroiica main window, excepting that taken up by the Standard 
Toolbar, Drawing Toolbar, and Status Bar. All document windows are displayed in this area.




