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Basic Tutorial

In this tutorial, you will construct a hollowed-out block with a hole in it. It is a toy part.

You will learn the basics of how to create and modify sketches and features. You will be able to use this knowledge 
in the Advanced Tutorial, where you will create and detail realistic parts.
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Set Your Modeling Units

This tutorial works in inches. To set up the units for modeling distances:

From the Tools menu, choose the Options command. 
Select the Units page by clicking on its tab.
Where it says Model distances, select “Inches” from the list if not already selected.
Press the OK button to complete the dialog window.

All distances you enter for parts will now be understood to be in inches.
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Create a New Part

You will start with a new part. To create a new part:

From the File menu, choose the New command.
A dialog window is displayed listing the types of document you can create. Select “part” from the list, and 

press the OK button.

A new part window is displayed.
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Create a Sketch for the Block

You will now create a rectangular profile, which will be extruded to become a solid block. To create the profile:

From the modeling toolbar at the edge of the part window, press the Create Rectangle button. 
Alternatively, you could choose the Rectangle command from the Line menu.

Move the pencil cursor to the origin of the workplane. This is where you see the work axes displayed. Look
in the dialog bar at the top of the part window. Position the cursor so that the dialog bar says Snap to Grid and the 
point says (0, 0).

Press and hold the left mouse button down, and drag the cursor up and to the right until the dialog bar 
shows (4, 6) for the point.

Now release the mouse button.

You have created four straight lines that form a rectangle.
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Create the Block

You will now extrude the rectangular sketch to create a solid block.

From the Feature menu, choose the Extrude Profile command.
A dialog window is displayed. Where it says Distance, enter a value of 2 inches.
Press the OK button to complete the dialog.

The part window shows a solid block.
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Shade and Autoscale the Part

To appreciate the solid form of the part:

On the dialog bar at the top of the part window, check the Shaded box.
With the cursor in the graphics area of the part window press and hold the right mouse button to display 

the popup menu. Choose the Autoscale command to fit the part to the window.

You can work with or without shading displayed. For this tutorial, we shall keep shading on.
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Create a New Workplane

You will now create a workplane on the top face of the block, so that you can sketch on that face.

From the modeling toolbar at the edge of the part window, press the Select Faces button. Alternatively, 
you could choose the Faces command from the Select menu.

Move the cursor over one of the edges of the top face, but slightly inside the face, so that all the edges of 
the top face are pre-highlighted. Now click to confirm selection of that face.

From the Workplane menu, choose the Plane of Object command.
A dialog window is displayed inviting you to enter a name for the workplane. Just press the OK button to 

accept the suggested name.

A workplane is created on the top face of the block. A sketch is also created and this becomes the active sketch, 
ready for you to create lines on the top face.
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Sketch the Hole

You will now sketch a circle on the top face of the block, that will be used to create a hole.

From the modeling toolbar at the edge of the part window, press the Create Circle button. Alternatively, 
you could choose the Circle command from the Line menu.

Position the cursor so that the dialog bar at the top of the part window shows Snap to Grid and a point of 
(1, -1).

Press and hold the left mouse button down, and drag until (1.5, -1) is displayed in the dialog bar.
Now release the mouse button.

You have skethed a circle on the top face of the block with a radius of 0.5 inches, and a center of (1, -1).
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Add the Hole Feature

You will now use the circle sketch to create a hole.

From the Feature menu, choose the Project Profile command.
A dialog window is displayed. Select the Below workplane and Subtract material options.
Press the OK button to complete the dialog.

You have created a through hole by projecting the circle down through the block.
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Modify the Position of the Hole

You will now change the size of the hole.

From the modeling toolbar at the edge of the part window, press the Select Lines button. Alternatively, you
could choose the Lines command from the Select menu.

Move the cursor over the circle, and then double-click using the left mouse button.
The Properties dialog window is displayed. Near the bottom, where it says Center, enter a new position of 

(0, -1).
Press the OK button to complete the dialog.
From the modeling toolbar, press the Update Design button. Alternatively, you could choose the Update 

Design command from the Feature menu.

The part updates to show the new position of the hole.
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Hollow the Part

You will now hollow out the part.

From the modeling toolbar at the edge of the part window, press the Select Faces button. Alternatively, 
you could choose the Faces command from the Select menu.

Move the cursor over one of the edges of the top face, but slightly inside the face, so that all the edges of 
the top face are pre-highlighted. Now click to confirm selection of that face.

From the Feature menu, choose the Hollow Solids command.
A dialog window is displayed. Where it says Offset, enter a value of 0.25 inches.
Press the OK button to complete the dialog.

The face you selected has been removed from the solid, and all the other faces have been offset inwards to 
produce a thin-walled part.
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Blend Some Edges

You will now blend all the edges around one face of the part.

If you are following this tutorial strictly, you will already be in the mode for selecting faces at this point. If 
not, from the modeling toolbar at the edge of the part window, press the Select Faces button. Alternatively, you 
could choose the Faces command from the Select menu.

Select the front face of the part.
From the Select menu, choose the Edges of Selected Faces command to turn the single selected face into a

selection of edges.
From the Feature menu, choose the Blend Edges command.
A dialog window is displayed. Where it says Radius, enter a value of 0.25 inches.
Press the OK button to complete the dialog.

The part updates to show the edges blended.
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Admire Your Part

You have completed the basic tutorial. Now you can admire the part you have built.

On the dialog bar at the top of the part window, check the Admire box.
Use the arrow keys to rotate the part within the window.
From the View menu, choose the Tumble command to see your part rotating around on its own.

To stop the part tumbling, just press any key.
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Stage 1 - Creating a Wheel

In this stage of the tutorial, you will construct the basic wheel design shown. You will learn how to create sketches, 
manage sketches, manipulate the work axes, and create features.

In stage 2 of this tutorial, you will use the wheel design as the basis for a derived slotted wheel design.
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Set Your Modeling Units

This tutorial works in inches. To set up the units for modeling distances:

From the Tools menu, choose the Options command. 
Select the Units page by clicking on its tab.
Where it says Model distances, select “Inches” from the list if not already selected.
Press the OK button to complete the dialog window.

All distances you enter for parts will now be understood to be in inches.
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Create a New Part

You will start with a new part. To create a new part:

From the File menu, choose the New command.
A dialog window is displayed listing the types of document you can create. Select “part” from the list, and 

press the OK button.

A new part window is displayed.
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Wheel Profile – Vertical Lines

You will now sketch the profile of revolution for the wheel. First you need to create some vertical lines.

From the View menu, choose the Onto Workplane command so that you are looking flat onto the active 
workplane.

From the modeling toolbar at the edge of the part window, press the Create Straight button. Alternatively, 
you could choose the Straight command from the Line menu.

Move the pencil cursor until the point (-1, 0) is displayed in the dialog bar at the top of the part window. 
Press and hold down the left mouse button. Drag the cursor to the right while holding down the SHIFT key, until 
some point (1, y) is displayed. The Y-value is unimportant since the SHIFT key constrains the line to be horizontal 
in this case. Release the mouse button, and then release the SHIFT key.

Create another straight line from (0, -1) to (0, 1) in the same manner.
From the Edit menu, choose the Select All command to select the two lines you have created. Then choose

the Toggle Construction command from the Line menu to turn the lines into construction lines.
Click on the vertical construction line to select it. From the Line menu, choose the Offset Chain command. 

Where it says Offset, enter 0.125 inches. Press the OK button to complete the dialog window.
Click on the vertical construction line to select it a second time. Choose the Offset Chain command again, 

and enter 0.69 inches.
Click on the vertical construction line to select it a third time. Choose the Offset Chain command again, 

and enter 0.84 inches.
With the cursor in the graphics area of the part window press and hold the right mouse button to display 

the popup menu. Choose the Zoom In command. Place the cursor near the center of the lines you have created. 
Press and hold down the left mouse button. Drag until the zoom rectangle surrounds all the lines, and then release 
the mouse button.

The creation of the profile continues on the next page.
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Wheel Profile – Horizontal Lines

To continue with the profile, you will now create some horizontal lines:

Click on the horizontal construction line to select it. From the Line menu, choose the Offset Chain 
command. Where it says Offset, enter 0.425 inches. Press the OK button to complete the dialog window.

From the Line menu, choose the Toggle Construction command to turn the two newly created lines into 
construction lines.

Click on the original horizontal construction line to select it a second time. Choose the Offset Chain 
command again, and enter 0.6 inches.

The creation of the profile continues on the next page.
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Wheel Profile – First Pair of Angled Lines

Now you will create some lines at a specific angle.

From the Workplane menu, choose the Transform Axes command.
A dialog window is displayed. Click on the Rotate tab to select that page. Where it says Angle, enter a 

value of –15 degrees. Press the OK button to complete the dialog window.
From the modeling toolbar at the edge of the part window, press the Create Straight button. Alternatively, 

you could choose the Straight command from the Line menu.
Create the two angled straight lines. Each angled line is from an intersection point to a point on an 

existing line. Position the cursor over the intersection point so that the attaction point is displayed, press and hold 
down the cursor, and drag with the SHIFT key held down until the line to junction with is pre-highlighted. Then 
release the mouse button.

The creation of the profile continues on the next page.
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Wheel Profile – Second Pair of Angled Lines

You will now create the other two angled lines.

From the Workplane menu, choose the Transform Axes command again. Click on the Rotate tab again to 
select that page. Where it says Angle, enter a value of 30 degrees. Press the OK button to complete the dialog 
window.

Create the other two angled lines in the same manner as before.
Choose the Transform Axes command again. Click on the Rotate tab again to select that page. Where it 

says Angle, enter a value of -15 degrees. Press the OK button to complete the dialog window.

In stage 2 of this tutorial, you will use this wheel as a component. The position and orientation of the work axes in 
the “base” workplane of the component part determine the location of the component in the assembly. So that the 
component does not get added 15 degrees skew, you have to return the work axes to their initial orientation.

The creation of the profile continues on the next page.
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Wheel Profile – Trim Outer Lines

You will now trim the outer vertical lines to their intended lengths:

From the modeling toolbar at the edge of the part window, press the Delete Line Segment button. 
Alternatively, you could choose the Delete Segments command from the Line menu.

To trim the four vertical lines to their intended length, you must hold the SHIFT key down while selecting 
line segments. This indicates that you want to delete all segments of the line except the segment under the cursor. 
For each line, place the cursor over the segment you want to keep, press and hold down the SHIFT key, click on the
line segment, and then release the SHIFT key.

The creation of the profile continues on the next page.
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Wheel Profile – Trim Inner Lines

Now you will shorten the inner vertical lines:

From the modeling toolbar at the edge of the part window, press the Select Lines button. Alternatively, you
could choose the Lines command from the Select menu.

To trim the next two vertical lines, you could delete line segments again, but this time it is more efficient 
to drag their end points. For each line, click on the line to select it. Then place the cursor over one end point, press 
and hold down the left mouse button, and then drag the end point until it snaps onto the end of the angled line to 
which it should join. Do this for the other end of the line too.

The creation of the profile continues on the next page.
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Wheel Profile – Tidy Up Corners

The profile is almost complete. You will now tidy up the corners:

From the modeling toolbar at the edge of the part window, press the Delete Line Segment button. 
Alternatively, you could choose the Delete Segments command from the Line menu.

For the horizontal lines at top and bottom of the sketch, delete the line segments that extend beyond the 
four corners of the profile.

You have completed the profile.
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Rename the Profile Sketch

Now you will give the profile sketch a meaningful name.

In the browser to the left of the part window, double-click on the “base” workplane to expand that node to
show the sketches that it contains.

Place the cursor over the “initial” sketch, and then press and hold the right mouse button down. Choose 
the Properties command.

A dialog window appears showing you the sketch properties. Where it says Name, enter the name “wheel-
profile” for the sketch.

Press the OK button to complete the dialog.

The browser will now show the new name for the sketch.
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Define the Axis Sketch

The next step is to define a separate sketch in the same workplane for the axis of revolution.

From the modeling toolbar at the edge of the part window, press the Select Lines button. Alternatively, you
could choose the Lines command from the Select menu.

Click on the bottom horizontal line to select it. From the Line menu, choose the Offset Chain command. 
Where it says Offset, enter 0.625 inches. Press the OK button to complete the dialog window.

Two offset lines are created and are shown highlighted. The lower one will be the axis, but the upper one 
is not required. Click on the upper line to select it, then press the DELETE key. Alternatively, you could choose the 
Delete command from the Edit menu.

Click on the lower offset line to select it. From the Edit menu, choose the Cut command. The line is not 
removed from the sketch, but a dotted box is displayed around the line to indicate that it is on the clipboard.

From the Workplane menu, choose the New Sketch command.
A dialog window is displayed. Where it says Name, enter “wheel-axis” for the name of the new sketch. 

Press the OK button to complete the dialog window.
The new sketch is the active sketch. The line on the clipboard is still in the profile sketch. From the Edit 

menu, choose the Paste command to move the axis line to the axis sketch.

The straight line you have created will be used as the axis of revolution for the wheel.
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Create the Wheel

You will now rotate the profile about the axis to form solid material.

From the Feature menu, choose the Revolve Profile command.
A dialog window is displayed. Where it says Sketch to use as profile, select the “wheel-profile” sketch. 

Where it says Axis of revolution, the sketch “wheel-axis” will automatically be offered as a suitable axis sketch.
Press the OK button to complete the dialog.
From the View menu, choose the Trimetric command.
On the dialog bar at the top of the part window, check the Shaded box.
From the File menu, choose the Save command.
A dialog window is displayed inviting you to choose a folder and file name for the wheel part. Navigate to 

the “Samples\Tutorial” folder and save your part as “my wheel”.

You have completed stage 1 of the advanced tutorial. Press the Contents button on this help window to return to 
the help contents. Then select the next stage.
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Stage 2 - Creating the Slotted Wheel

In this stage of the tutorial, you will learn how to construct a new part by deriving it from an existing part. If you 
subsequently change the original part, the changes also propagate to the derived model.

You will learn how to work with existing models, duplicate lines to create a pattern, and project a profile to create 
through holes.
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Create a New Part

You will start with a new part. To create a new part:

From the File menu, choose the New command.
A dialog window is displayed listing the types of document you can create. Select “part” from the list, and 

press the OK button.

A new part window is displayed.
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Create a Component Feature

You will now create a component feature, which is the mechanism behind derived models.

From the Assembly menu, choose the Add Component command.
A dialog window is displayed allowing you to select the component part file. Navigate to the “Samples\

Tutorial” folder. Locate the part, “my wheel”, you saved at the end of stage 1. If you did not save your work in 
stage 1, or you are starting the tutorial from stage 2, you can select “wheel” instead.

Press the OK button to complete the dialog. The basic wheel component is added to your part.
From the Feature menu, choose the Use Component command.
A dialog window is displayed. The option Add material should already be checked. Press the OK button to 

complete the dialog.
With the cursor in the graphics area of the part window press and hold the right mouse button to display 

the popup menu. Choose the Autoscale command to fit the part to the window.

The component you added was turned into solid material in the new part. You can now add further features to the 
part.
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Create a New Workplane

You will now create a new workplane, which you will use to sketch a profile for slots to be added to the wheel.

From the modeling toolbar at the edge of the part window, press the Select Faces button. Alternatively, 
you could choose the Faces command from the Select menu.

Select the face shown in the illustration. This is the face through which the slots are to be punched. 
Position the cursor over one of its edges, slightly inside the face so that the face pre-highlights, then click the left 
mouse button to confirm the selection.

From the Workplane menu, choose the Plane of Object command to create a new workplane sited on the 
selected face.

A dialog window is displayed. Where it says Sketch name, enter “slots” for the name of the sketch. Press 
the OK button to complete the dialog.

A new workplane containing a new sketch was just created.
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Slots Profile – Two Angled Lines

You will now create two straight lines which will form part of the profile of a slot.

From the View menu, choose the Onto Workplane command to look flat onto the active sketch.
From the Workplane menu, choose the Transform Axes command.
A dialog window is displayed. Go to the Rotate page by clicking on its tab. Where it says Angle, enter a 

value of 15 degrees. Press the OK button to complete the dialog.
From the modeling toolbar at the edge of the part window, press the Create Straight button. Alternatively, 

you could choose the Straight command from the Line menu.
You will now draw a straight line parallel to the Y-axis, which is currently 15 degrees counter-clockwise 

from vertical. The start of the line is at the center of the wheel. On the dialog bar at the top of the part window, 
check the Edges box. Alternatively, you could choose the Points from Edges command from the Select menu. 

Position the cursor over one of the circular edges of the wheel, slightly inside it, so that the center of the 
circle is displayed as a black square. Press and hold down the left mouse button. Press and hold down the SHIFT 
key and drag the cursor up and to the left to create a line that extends outside the wheel. Release the mouse 
button, then release the SHIFT key.

From the Edit menu, choose the Duplicate command.
A dialog window is displayed. Go to the Circular page by clicking on its tab. Where it says Angle, enter a 

value of 60 degrees. Press the OK button to complete the dialog.

The creation of the profile continues on the next page.
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Slots Profile – Two Circles

You will now create two circles, which will form part of the profile of the slot.

From the modeling toolbar at the edge of the part window, press the Create Circle button. Alternatively, 
you could choose the Circle command from the Line menu.

Clear the Edges box in the dialog bar, so that you can select points from lines again.
Place the cursor over the center where the two straight lines meet. Press and hold down the left mouse 

button, then drag a circle of an arbitrary radius.
With the cursor still in the graphical view, press and hold the right mouse button to display the popup 

menu. Choose the Properties command.
The Properties dialog window is displayed. In the bottom section where it says Radius, enter “2.75/2” to 

get a diameter of 2.75 inches. Press the OK button to complete the dialog.
Create and edit a second circle in the same manner, this time entering “2.25/2” for the radius.

The creation of the profile continues on the next page.
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Slots Profile – Create a Slot

You will now trim the 4 lines you have created, to form the profile of a single slot.

From the modeling toolbar at the edge of the part window, press the Delete Line Segment button. 
Alternatively, you could choose the Delete Segments command from the Line menu.

To trim the two straight lines and two circles to their intended form, you should hold the SHIFT key down 
while selecting line segments. This indicates that you want to delete all segments of the line except the segment 
under the cursor. For each line, place the cursor over the segment you want to keep, press and hold down the 
SHIFT key, click on the line segment, and then release the SHIFT key.

The creation of the profile continues on the next page.
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Slots Profile – Duplicate the Slot

You will now duplicate the slot profile to create the profile of 4 slots.

From the Edit menu, choose the Select All command to select all the lines.
From the Edit menu, choose the Duplicate command.
A dialog window is displayed. Go to the Circular page by clicking on its tab. Where it says Number, enter a

value of 4. Press the OK button to complete the dialog.
From the Workplane menu, choose the Transform Axes command.
A dialog window is displayed. Go to the Rotate page by clicking on its tab. Where it says Angle, enter a 

value of -15 degrees to return the work axes to their original orientation. Press the OK button to complete the 
dialog.

The profile for the 4 slots is complete.
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Slots Profile – Create the Slots

You will now create the slots using the profile you have sketched.

From the View menu, choose the Isometric command so you can see the wheel in 3D again.
From the Feature menu, choose the Project Profile command.
A dialog window is displayed. Select the Below workplane and Subtract material options. You can use the 

context sensitive help for information on what these options mean. To do this, click on the help icon at the top right
of the dialog window, then click on the option you are interested in. 

Press the OK button to complete the dialog.
On the dialog bar at the top of the part window, check the Shaded box so you can see the solid form of the

slots.

The slots have been added to the wheel.
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Slots Profile – Blend the Edges of the Slots

You will now add blends to the slots. 

From the modeling toolbar at the edge of the part window, press the Select Edges button. Alternatively, 
you could choose the Edges command from the Select menu.

You will now select the 16 parallel straight edges that were produced when the slots were added. To select
more than one edge, you must press and hold down the SHIFT key as you click on the second and subsequent 
edges. You may want to use the Zoom In command on the popup menu to enlarge the edges for ease of selection. 
You may also want to use the arrow keys to rotate the view as you select - you must release the SHIFT key 
momentarily for this.

Having selected all 16 edges, choose the Blend Edges command from the Feature menu.
A dialog window is displayed. Where it says Feature name, enter “slot fillets”. Where it says Radius, enter 

a value of 0.06 inches. Press the OK button to complete the dialog.

Instead of adding a blend feature, you could have filleted the lines in the slot profile. This would produce the same 
result, but having a separate blend feature provides an easy way to change the blend radius in the future. It also 
allows you to suppress the blends to simplify the model.

{button <<,Prev()} {button >>,Next()}



Save Your Part

You will now save your part so you can use it as a component in stage 3 of this tutorial.

On the dialog bar at the top of the part window, check the Admire box so you can appreciate the part you 
have made.

To see the features you have created, choose Features from the drop list in the dialog bar to display the 
feature browser.

From the File menu, choose the Save command.
A dialog window is displayed inviting you to choose a folder and file name for the slotted wheel part. 

Navigate to the “Samples\Tutorial” folder and save your part as “my slotted wheel”.

You have completed stage 2 of the advanced tutorial. Press the Contents button on this help window to return to 
the help contents. Then select the next stage.
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Stage 3 - Creating the Wheel Sub-Assembly

In this stage of the tutorial you will construct a wheel assembly that will be used in stage 4 as a sub-assembly. 

You will learn how to add components and use assembly mating conditions.
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Create a New Part

You will start with a new part. To create a new part:

From the File menu, choose the New command.
A dialog window is displayed listing the types of document you can create. Select “part” from the list, and 

press the OK button.

A new part window is displayed. You will add components to the part so that it becomes an assembly.
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Add the Slotted Wheel and Spindle

You will add the slotted wheel and spindle to the assembly:

From the Assembly menu, choose the Add Component command.
A dialog window is displayed allowing you to select the component part file. Navigate to the “Samples\

Tutorial” folder. Locate the part, “my slotted wheel”, you saved at the end of stage 2. If you did not save your work 
in stage 2, or you are starting the tutorial from stage 3, you can select “slotted wheel” instead.

Press the OK button to complete the dialog. The slotted wheel component is added to your part.
Choose the Add Component command again and add “spindle” this time.

The two components are not assembled correctly. You will do that next.
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Position the Spindle – Select Axes to Center

You will select two axial faces, one in each component, that should be centered:

From the modeling toolbar at the edge of the part window, press the Select Faces button. Alternatively, 
you could choose the Faces command from the Select menu.

Select the two cylindrical faces shown. Move the cursor over one of the edges of each face and slightly 
inside the face so that it pre-highlights. Click the left mouse button to confirm the selection. To add the second face
to the selection you must press and hold down the SHIFT key while you click.

You will center these axes next.

{button <<,Prev()} {button >>,Next()}



Position the Spindle – Select Faces to Align

You will center the axes, and then select two planar faces, one in each component, that should be aligned:

From the Assembly menu, choose the Center Axes command.
The axis of the spindle is correct, but the spindle needs to be moved along to its correct position. Select 

the two planar faces shown, as you did on the previous page.

You will align these faces next.
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First Spacer – Select Faces to Mate

You will align the faces, and then add a spacer:

From the Assembly menu, choose the Align Planes command to position the spindle so that the two faces 
are aligned facing the same way.

From the Assembly menu, choose the Add Component command again, and add the “spacer” part.
From the modeling toolbar at the edge of the part window, press the Select Faces button. Alternatively, 

you could choose the Faces command from the Select menu.
Select the two planar faces shown.

You will mate these faces next.
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First Spacer – Select Axes to Center

You will mate the faces, and then select two cylindrical faces, one in each component, that should be centered:

From the Assembly menu, choose the Mate Planes command to assemble the spacer so that the two faces 
are aligned facing each other.

Select the two cylindrical faces shown.

You will center these axes next.
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Add and Position the Second Spacer

You will center the axes, and then add and position another spacer:

From the Assembly menu, choose the Center Axes command to place the spacer on the spindle.
Choose the Add Component command again, and add another “spacer” part.
Use Mate Planes and Center Axes again to assemble the second spacer at the other end of the spindle.

The wheel sub-assembly is complete.
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Save Your Sub-Assembly

You will now save your wheel sub-assembly so you can use it as a component in stage 4 of this tutorial.

On the dialog bar at the top of the part window, check the Admire and Shaded boxes so you can appreciate
the assembly you have made.

To see the components you have added, choose Components from the drop list in the dialog bar to display
the component browser. Double click on a component in the browser to expand that node to show you its mating 
conditions.

From the File menu, choose the Save command.
A dialog window is displayed inviting you to choose a folder and file name for the slotted wheel part. 

Navigate to the “Samples\Tutorial” folder and save your part as “my wheel subassy”.

You have completed stage 3 of the advanced tutorial. Press the Contents button on this help window to return to 
the help contents. Then select the next stage.
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Stage 4 - Creating the Roller Assembly

In this stage of the tutorial you will construct the complete roller assembly. 

Later in stage 5, you will create a drawing of the assembly.
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Create a New Part

You will start with a new part. To create a new part:

From the File menu, choose the New command.
A dialog window is displayed listing the types of document you can create. Select “part” from the list, and 

press the OK button.

A new part window is displayed. You will add components to the part so that it becomes an assembly.
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Add the Base and First Support

You will add the base and first support to the assembly:

From the Assembly menu, choose the Add Component command.
A dialog window is displayed allowing you to select the component part file. Navigate to the “Samples\

Tutorial” folder. Select the “base” part. Press the OK button to complete the dialog.
Choose the Add Component command again and add “support” this time.

The two components are not assembled correctly. You will do that next.
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Support – Select Faces to Mate

You will select two planar faces, one in each component, that should be mated:

From the modeling toolbar at the edge of the part window, press the Select Faces button. Alternatively, 
you could choose the Faces command from the Select menu.

Select the two planar faces shown. Move the cursor over one of the edges of each face and slightly inside 
the face so that it pre-highlights. Click the left mouse button to confirm the selection. To add the second face to the
selection you must press and hold down the SHIFT key while you click.

You will mate these faces next.
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Support – Select First Pair of Axes to Center

You will mate the faces, and then select two cylindrical faces, one in each component, that should be centered:

From the Assembly menu, choose the Mate Planes command to site the support on top of the base plate.
Select the two cylindrical faces shown. It may be helpful to use the Zoom In command on the popup menu 

in the graphical view to enlarge the view. You might also use the arrow keys to rotate the view.

You will center these axes next.
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Support – Select Second Pair of Axes to Center

You will center the axes, and then select another pair of cylindrical faces, one in each component, that should be 
centered:

From the Assembly menu, choose the Center Axes command to align one pair of holes.
Select the two cylindrical faces shown.

You will center these axes next.
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Support – Add a Second Support

You will center the axes, and then add and position a second support:

From the Assembly menu, choose the Center Axes command to align the second pair of holes.
From the Assembly menu, choose the Add Component command and add another “support” component.
Use Mate Planes and Center Axes again to assemble the second support on the other end of the base plate.
On the dialog bar at the top of the part window, check the Shaded box so you can see the solid form of the

assembly.

The two supports are in place.
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Add the Two Sleeves

You will now add and position two sleeves:

From the Assembly menu, choose the Add Component command and add a “sleeve” component.
Use Center Axes and Align Planes to assemble the sleeve inside the support hole.
Choose the Add Component command again and add a second “sleeve” component.
Use Center Axes and Align Planes to assemble the second sleeve inside the second support hole.

All that remains is to add the wheel sub-assembly.

{button <<,Prev()} {button >>,Next()}



Add Wheel Sub-Assembly

You will now add and position the wheel sub-assembly:

From the Assembly menu, choose the Add Component command.
A dialog window is displayed. Locate the part, “my wheel subassy”, you saved at the end of stage 3. If you

did not save your work in stage 3, or you are starting the tutorial from stage 4, you can select “wheel subassy” 
instead.

Use Center Axes to assemble the wheel sub-assembly so that the spindle is located inside the support 
holes. You might also need to use Mate Planes if the wheel sub-assembly gets positioned outside the supports.

The roller assembly is almost complete.
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Add the Four Pins

You will now add and position four pins:

From the Assembly menu, choose the Add Component command again, and add the “pin” part.
Use Center Axes and Align Planes to assemble the pin in the correct place.
Add and assemble three more pins in the three remaining holes.

The roller assembly is now complete.
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Change a Component Color

You will now change the color of the support components:

From the modeling toolbar at the edge of the part window, press the Select Parts button. Alternatively, you
could choose the Parts command from the Select menu.

Select one of the support components by clicking on it using the left mouse button.
From the Assembly menu, choose the Set Component Color command.
A dialog window is displayed. Select a color from the pallet on the left, or by using the color mixers to the 

right. Press the OK button to complete the dialog.

Notice that both supports change color.
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Save Your Sub-Assembly

You will now save your roller assembly so you can use it again in stage 5 of this tutorial.

On the dialog bar at the top of the part window, check the Admire box so you can appreciate the assembly
you have made.

From the File menu, choose the Save command.
A dialog window is displayed inviting you to choose a folder and file name for the slotted wheel part. 

Navigate to the “Samples\Tutorial” folder and save your part as “my roller assy”.

You have completed stage 4 of the advanced tutorial. Press the Contents button on this help window to return to 
the help contents. Then select the next stage.
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Stage 5 - Creating the Roller Assembly Drawing

In this stage of the tutorial you will create an assembly drawing.

You will build skills in the areas of drawing format creation, view layout, dimensioning, and other forms of 
annotation.
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Set Your Drawing Units

This tutorial works in inches. To set up the units for drawing distances:

From the Tools menu, choose the Options command. 
Select the Units page by clicking on its tab. Where it says Paper distances, select inches from the list if 

not already selected. This setting affects distances measured in the drawing sheet, such as line geometry.
Select the Number page by clicking on its tab. Where it says Units, select “Inches” from the list if not 

already selected. This setting affects the dimension units.
Press the OK button to complete the dialog window.

All distances you enter for drawings and dimensions will now be understood to be in inches.
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Create a Drawing Format

You will start with a new drawing. To create a new drawing:

From the File menu, choose the New command.
A dialog window is displayed listing the types of document you can create. Select “drawing” from the list, 

and press the OK button.
A dialog window is displayed showing you the properties of the drawing. Where it says Specify format, 

select “ANSI–B” from the drop list. Press the OK button to complete the dialog.

A new drawing window is displayed. You will add lines to this drawing to create a drawing format.
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Create a Drawing Format

You will now sketch the drawing format:

From the drafting toolbar at the edge of the drawing window, press the Create Rectangle button. 
Alternatively, you could choose the Rectangle command from the Line menu.

Move the pencil cursor to the origin of the workplane. This is at the bottom-left where you see the work 
axes displayed. Look in the dialog bar at the top of the drawing window. Position the cursor so that the dialog bar 
says Snap to Grid and the point says (0, 0).

Press and hold the left mouse button down, and drag the cursor up and to the right until the dialog bar 
shows (17, 11) for the point. Now release the mouse button.

From the Line menu, choose the Offset Chain command.
A dialog window is displayed. The Inside option should be selected. Where it says Offset, enter a value of 

0.5 inches. Press the OK button to complete the dialog.
From the drafting toolbar at the edge of the drawing window, press the Create Straight button. 

Alternatively, you could choose the Straight command from the Line menu.
Create the remaining straight lines. To create lines that are horizontal or vertical, hold down the SHIFT key

while you drag the cursor.
From the File menu, choose the Save command.
A dialog window is displayed inviting you to choose a folder and file name for the drawing. Navigate to the

“Samples\Tutorial” folder and save your part as “my format B”.
Click on the Close button at the top-right of the drawing window. Alternatively you can choose the Close 

command from the File menu.

You will use this format to create a drawing.
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Create the New Drawing

You will now create another drawing:

From the File menu, choose the New command.
A dialog window is displayed listing the types of document you can create. Select “drawing” from the list, 

and press the OK button.
A dialog window is displayed showing you the properties of the drawing. Select the Use existing format 

option, then press the Browse button. Locate and select the “my format B” format you have just saved, then press 
the Open button to complete the sub-dialog.

Press the OK button to complete the drawing properties dialog.

A new drawing window is displayed, showing an empty drawing with the format you created as a backdrop. The 
lines in the format are not selectable.
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Add the Principle View

You will now add a view of the roller assembly to the drawing:

From the File menu, choose the Open command.
A dialog window is displayed. Locate and select the part, “my roller assy”, you saved at the end of state 4 

of this tutorial. If you did not save your work in stage 4, or you are starting the tutorial from stage 5, you can 
select “roller assy” instead. Press the Open button to complete the dialog.

From the View menu, choose the Right Elevation command.
Activate the drawing window by clicking on its title bar, or by selecting it from the list of open windows 

shown at the bottom of the Windows menu.
From the Drawing menu, choose the Add Modeling View command.
A dialog window is displayed, listing all the part windows in the session. Select the part window, then 

press the OK button to complete the dialog and add the view to the drawing.
The view that was added is now selected. Position the cursor over the dashed rectangle surrounding the 

view so that it pre-highlights. Press and hold down the left mouse button. Drag the view to the desired position on 
the drawing, then release the mouse button.

The view that you just added is a snapshot of the view direction of the part window you selected. You can change 
the part window view direction and this will not affect the drawing.
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Stepped Section – Cut Lines

You will now define a stepped section in terms of the principle view you just added.

From the Drawing menu, choose the New Sketch command.
A dialog window is displayed. Where it says Name, enter “section AA” for the sketch name. Press the OK 

button to complete the dialog.
From the drafting toolbar at the edge of the drawing window, press the Create Straight button. 

Alternatively, you could choose the Straight command from the Line menu.
On the dialog bar at the top of the drawing window, check the Edges box. Alternatively, you could choose 

the Points from Edges command from the Select menu. 
You will now draw a vertical straight line passing through the center of the wheel. Position the cursor over, 

but just inside, one of the circular edges of the wheel so that the center of the circle is displayed as a black square.
Press and hold down the left mouse button. Press and hold down the SHIFT key. Drag the cursor upwards until the 
vertical line extends outside the view. Release the mouse button, then release the SHIFT key.

For the lower-right vertical line, there is no specific point on an edge that will accurately guide the line 
along the axis of the hole. So clear the Edges box on the dialog bar.

With the cursor in the graphics area of the drawing window press and hold the right mouse button to 
display the popup menu. Choose the Zoom In command. Place the cursor near the center of the hole in the base 
plate. Press and hold down the left mouse button. Drag until the zoom rectangle surrounds the hole, and then 
release the mouse button.

Create a vertical line passing along the axis of the hole as accurately as you can. Use the SHIFT key again 
to constrain the line to be vertical.

From the popup menu again, choose the Autoscale command so that you can see the whole drawing.

The two vertical lines will define the cuts through the assembly. The section view definition continues on the next 
page.
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Stepped Section – Complete the Sketch

You will now complete the sketch that defines the stepped section view.

Click on the upper-left vertical line to select it. Place the cursor over the bottom end of the line. Press and 
hold the left mouse button down. Press and hold the SHIFT key down while you drag the end of the line down to a 
short distance below the bottom of the wheel, then release the mouse button. Now release the SHIFT key.

Extend the top of the lower-right line in the same manner. While dragging the end point of the line, 
position the cursor over the bottom end point of the other line so that the point is pre-highlighted. Then release the
mouse button.

Create the line connecting the vertical lines. Then choose the Toggle Construction command from the Line 
menu to turn it into a construction line.

Create the construction line at the top in the same manner. The line does not have to be accurately 
horizontal. It just indicates the side of the cut that you want to keep.

The sketch defining the section cut is complete.
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Add the Stepped Section 

You will now add the stepped section view to the drawing.

From the drafting toolbar at the edge of the drawing window, press the Select Views button. Alternatively, 
you could choose the Views command from the Select menu.

Using the left mouse button, click on the dashed rectangle surrounding the principle view to select it. From
the Drawing menu, choose the Add Section View command.

A dialog window is displayed. The active sketch, “section AA”, is selected for you. Just press the OK button
to complete the dialog.

The section view is added to the drawing and is now selected. Position the cursor over the dashed 
rectangle surrounding the new view so that it pre-highlights. Press and hold down the left mouse button. Press and
hold down the SHIFT key to maintain the alignment of the view. Drag the view to the desire position on the 
drawing. Release the mouse button and the release the SHIFT key.

Drawing views are now complete.
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Save Your Drawing

You will now save your drawing so you can use it in stage 6 of this tutorial.

From the File menu, choose the Save command.
A dialog window is displayed inviting you to choose a folder and file name for the roller assembly drawing. 

Navigate to the “Samples\Tutorial” folder and save your drawing as “my roller assy”.

You have completed stage 5 of the advanced tutorial. Press the Contents button on this help window to return to 
the help contents. Then select the next stage.
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Stage 6 - Dimensioning the Roller Assembly Drawing

In this stage of the tutorial you will annotate the roller assembly drawing you made in stage 5. In the process, you 
will build dimensioning skills.

This stage assumes that you have completed stage 5 first. You cannot start the tutorial at stage 6.

{button Start,Next()}



Open the Roller Assembly Drawing

You will start by opening the roller assembly drawing that you created in stage 5 of this tutorial.

From the File menu, choose the Open command. 
The file dialog window is displayed. Where it says Files of type, select “Drawings” from the drop list. 

Navigate to the “Samples\Tutorial” folder and select the “my roller assy” drawing. Press the OK button to complete 
the dialog.

Click the Maximize button at the top-right of the drawing window. Then click the Maximize button at the 
top-right of the DesignWave application window.

You will now proceed to annotate the drawing.
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Add Diametric Dimensions to the Section View

You will now add the 4 diametric dimensions to the section view on the right.

From the drawing toolbar at the edge of the drawing window, press the Diametric Dimension button. 
Alternatively, you could choose the Diametric command from the Dimension menu.

You will now add the four dimensions. Position the cursor over the feature to be dimensioned so that it 
pre-highlights. Press and hold down the left mouse button. Drag the dimension line to the desired location, then 
release the mouse button.

The extension lines and centerlines are added automatically as you create dimensions. Dimensioning the drawing 
continues on the next page.
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Dimension the Size of the Wheel

You will now create the leader-directed diametric dimension for the wheel. For a leader-directed diameter, you have
to create a radial dimension, and then convert it to diametric.

From the drawing toolbar at the edge of the drawing window, press the Radial Dimension button. 
Alternatively, you could choose the Radial command from the Dimension menu.

Position the cursor over the outside of the wheel so that it pre-highlights. Press and hold down the left 
mouse button. Drag the text out to the desired location, then release the mouse button.

With the cursor still in the drawing, press and hold down the right mouse button to display the popup 
menu. Choose the Properties command from the popup menu.

A dialog window is displayed showing the properties of the dimension. Go to the Measurement page by 
clicking on its tab. Where it says Size, select the Diameter option, then press the OK button to complete the dialog.

Dimensioning the drawing continues on the next page.
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Add Some Linear Dimensions

You will now add the three linear dimensions at the bottom of the section view.

From the drawing toolbar at the edge of the drawing window, press the Linear Dimension button. 
Alternatively, you could choose the Linear command from the Dimension menu.

All three dimensions are measured from the same feature. Click on the feature to select it.
Now create the three dimensions. Position the cursor over the feature to which you want to dimension so 

that it pre-highlights. Press and hold down the left mouse button. Drag the cursor down to position the dimension 
line, then release the mouse button.

Notice how the first feature is re-used, allowing you to just keep dragging from other second features.
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Add the Remaining Linear Dimensions

You will now add the remaining linear dimensions.

For each linear dimension, click on the first feature to select it, then drag from the second feature to 
position the dimension line.

Do not worry about the inappropriate position of the dimension text in many cases. You will address that on the 
next page.
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Position the Dimension Text

Many of the linear dimensions you just added will now need their text to be re-positioned. You might also want to 
move some of the dimension lines to improve the layout.

From the drafting toolbar at the edge of the drawing window, press the Select Annotations button. 
Alternatively you either can choose the Annotations command from the Select menu, or you can click on the 
drawing background.

Using the left mouse button, click on the dimension text to select it. With the cursor still over the 
dimension text, press and hold down the left mouse button. Drag the text to the desired position, then release the 
mouse button.

To re-position a dimension line, select the dimension line first, and then drag it to the desired position. The
dimension text will follow it.

To add the shoulder to the linear dimension showing the height of the base part in the left-hand view, first
select the dimension text. Then, from the Shoulder sub-menu on the Dimension menu, choose the Right command.

The dimensioning is now done.
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Completing the Section Lines

You will now complete the section lines shown in the left-hand principle view.

From the Drawing menu, choose the New Sketch command.
A dialog window is displayed. Where it says Name, enter “section AA – additional lines” for the sketch 

name. Press the OK button to complete the dialog.
From the drafting toolbar at the edge of the drawing window, press the Create Straight button. 

Alternatively, you could choose the Straight command from the Line menu.
Create a horizontal straight line to connect the two vertical cuts lines.
Create the two horizontal lines, one at each end of the section cut, drawn to the left. For each line, use the

Properties command on the popup menu just as soon as the line is created. Go to the Line page by clicking on its 
tab. Where it says End terminator, select “Arrow” from the drop list, then press the OK button to complete the 
dialog.

On the next page you will add the textual notes that complete the section lines.
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Labeling the Section Lines and Section View

You will now add notes to label the section lines and section view.

From the drafting toolbar at the edge of the drawing window, press the Textual Note button. Alternatively 
you can choose the Note command from the Dimension menu.

Dragging in the drawing will create notes directed by leaders. To create a free-standing note, you can 
either delete the leader afterwards, or you can hold down the SHIFT key while dragging to omit the leader. Position 
the cursor near to where you want the textual note at the one end of the section lines. Press and hold down the left
mouse button. Drag a short distance until you see the outline of the text appear. Continue dragging to position the 
note, then release the mouse button.

Choose the Properties command from the popup menu.
A dialog window is displayed. Enter the text, “A”, for the note. Go to the Text page by clicking on its tab. 

Where it says Height, enter 0.2 inches for the value. Press the OK button to complete the dialog.
Create the “A” label for the other end of the section lines in the same manner. Then do the same again to 

create the label “SECTION A-A” for the section view itself.
To re-position a note, first make a single click on the background of the drawing to enter the Select 

Annotations mode, or press that button on the drawing toolbar. Click on the note if it is not already selected, and 
then drag the note to the new position.

The drawing is almost finished.
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Completing the Drawing

You will now complete the drawing by adding the remaining free-standing notes.

From the drafting toolbar at the edge of the drawing window, press the Textual Note button. Alternatively 
you can choose the Note command from the Dimension menu.

Create the remaining free-standing notes by dragging in the drawing with the SHIFT key held down. For 
the “NOTES” block, select the Multi-line option on the Note page of the Properties dialog so you can enter several 
lines of text.

From the File menu, choose the Save command to save your work.

You have completed stage 6 of the advanced tutorial. Press the Contents button on this help window to return to 
the help contents. Then select the next stage.
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Stage 7 - Processing an Engineering Change Order

In this stage of the tutorial you will learn methods for modifying an existing design. 

An ECO (Engineering Change Order) has been generated requiring the following:

Use of a standard wheel as opposed to the slotted wheel. 
Support brackets now require a .375 radius through hole located 1.75 inches up from the bottom of the 

base. 
Assembly detail needs to be updated to reflect the changes and the addition of a dimension from the top 

of the base to the center of the hole. 
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Open the Roller Assembly

You will start by opening the roller assembly that you created in stage 4 of this tutorial.

From the File menu, choose the Open command. 
The file dialog window is displayed. Navigate to the “Samples\Tutorial” folder and select the “my roller 

assy” part. Press the OK button to complete the dialog.
Click the Maximize button at the top-right of the part window. Then click the Maximize button at the top-

right of the DesignWave application window.

You will now proceed to modify the assembly.
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Open the Wheel Sub-Assembly In Context

You will now open the wheel sub-assembly in the context of the roller assembly.

From the drop list in the dialog bar at the top of the part window, select Components from the list of 
browsers. Alternatively, you can choose the Components Browser command from the Tools menu.

In the browser, position the cursor over the “my wheel subassy” component. Press and hold down the 
right mouse button to display the popup menu. Choose the Select Component command.

From the Assembly menu, choose the Open Part in Context command.

A new part window is displayed showing the wheel sub-assembly open in the context of the roller assembly.
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Replace the Wheel Component

You will now replace the slotted wheel with the plain wheel.

From the modeling toolbar at the edge of the part window, press the Select Parts button. Alternatively, you
could choose the Parts command from the Select menu.

Position the cursor over the slotted wheel so that it pre-highlights. Click using the left mouse button to 
confirm the selection. Now press the Delete key to remove the component.

From the Assembly menu, choose the Add Component command.
A dialog window is displayed. If necessary, navigate to the “Samples\Tutorial” folder. Select the “my 

wheel” part you created in stage 1 of this tutorial. If you did not complete stage 1, select “wheel” instead. Press 
the OK button to complete the dialog and add the component.

Click on the Close button at the top-right of the part window. When asked whether to save changes, 
answer “Yes” to save the modified assembly. 

The roller assembly window now shows the modified wheel sub-assembly. The first change in the ECO is done.
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Add the Through Hole in the Support

You will now add a through hole to the support component.

Select one of the “support” parts using the popup menu in the component browser again, and choose the 
Open Part in Context command again. A new part window is displayed.

From the View menu, choose the Onto Workplane command.
From the modeling toolbar at the edge of the part window, press the Create Straight button. Alternatively, 

you could choose the Straight command from the Line menu.
On the dialog bar at the top of the part window, check the Edges box. Alternatively, you could choose the 

Points from Edges command from the Select menu. 
Position the cursor over the center of the gray horizontal edge at the top of the base plate so that the mid-

point is pre-highlighted. Press and hold down the left mouse button. Press and hold down the SHIFT key. Drag the 
line upwards slightly. Release the mouse button, then release the SHIFT key.

With the cursor still in the view, press and hold down the right mouse button to display the popup menu. 
Choose the Properties command.

Select the middle section of the page by clicking in its left margin. Where it says Length, enter a value of 
1.75 inches. Press the OK button to complete the dialog.

From the Line menu, choose the Toggle Construction command.
From the modeling toolbar at the edge of the part window, press the Create Circle button. Alternatively, 

you could choose the Circle command from the Line menu.
Clear the Edges box in the dialog bar at the top of the part window. Drag a circle starting from the top of 

the straight line.
Use the Properties command again to modify the circle. This time change the radius to be 0.375 inches.
From the Feature menu, choose the Project Profile command.
A dialog window is displayed. Select the Below workplane and Subtract material options, the press the OK 

button to complete the dialog and create the through hole.
From the File menu, choose the Save command.

The second change in the ECO is done. The through hole appears in the other support too. Use the arrow keys to 
examine the assembly.
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Update the Roller Assembly Detailed Drawing

You will now update the drawing of the roller assembly.

From the File menu, choose the Open command. Select the drawing, “my roller assy”, that you created in 
stage 6 of this tutorial. Press the OK button to complete the dialog.

From the drawing toolbar at the edge of the drawing window, press the Update Views button. Alternatively,
you could choose the Update Views command from the Drawing menu.

Add the diametric dimension for the through hole you just created, and the linear dimension that positions
it above the base plate.

The diameter of the slotted wheel has gone, since that wheel is no longer used. Add the diameter for the 
replacement wheel by creating a radial dimension and then converting it to diametric, as you did in stage 6 of the 
tutorial.

From the File menu, choose the Save command to save the updated drawing.

The third and final change in the ECO is done.

You have successfully completed the advanced tutorial. Congratulations!
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